Оригинальный элемент
(В качестве первоисточника выступила ветка 3D-форума под названием "Порекоммендуйте способ получения элемента")

Batuhan: Интересует способ получения такого "штопора", как постоянного сечения так и переменного.
Сам делал sweep2, однако тяжело ловить постоянность сечения двумя трехмерными кривыми. Если делать sweep1, то не поддается корректировке промежуточные положения поперечного сечения, но зато присутствует постоянство сечения.
Сложность метода sweep2 (для меня) заключается в построении второй направляющей. То есть 1-ю кривую построить не сложно, а вот равноотстоящую и еще дающую нужную траекторию - тяжело.
Loft думаю более геморный будет. Прийдется строить штук 5 сечений. В принципе неплох sweep2, но как делать 2-ю рельсу?
Что посоветуете, спецы?

KreySlider: Рождественский прикол, млина... Берешь копируешь и перемещаешь в сторону... А вообще можно и по одной кривой выстроить...

Sashkin: Batuhan, я бы сделал так:
померял длину кривой - командой length. нарисовал ровную линию этой длины. по ней построил сурфейс с нужным перегибом.и потом этот сурфейс уже загнул бы по кривой командой flow along curve.
такие пироги =)

Batuhan: KreySlider, получатся НЕравноудаленные кривые.

Sashkin, в принципе вариант. Но думаю с 1-го раза все равно не поймаешь требуемую форму.

Вцелом спасибо за варианты.

S_i_l_v_e_r: Ювелирка жжет...
Можно такой вариант - строится средняя линия (типа осевая), по ней - pipe с радиусом = расстоянию между двумя требуемыми кривыми-рельсами. Затем по осевой ставятся отрезки (длиной > радиуса) с пересечением в их (отрезках) центрах и корректируется их положение, чтобы получить пов-ть, пересечение оной с пайпом и будут две кривые (искомые равноуделенные рельсы).

Может кто и поймет, что написал

Mask: Мне похожую ерунду один фиг вручную доводить приходилось, т.к. сразу получить равноудаленные и при этом смещенные относительно друг друга (как на том рисунке) кривые так и не получилось.

colibrica: Делалось чтото подобное только по 2 рельсам, но исходная была одна(синяя), затем перпендикулярно ей строились половины высот сечений с последующим продлением на такуюже длину и джоин, затем офсет на половину длины сечения и из точки пересечения половинки длины,потом-ректангл 3 поинтс. Может и на неплоских кривых сработает, но геморойно ловить сечения, чтоб не перекручивались но это вопрос нужности.

111: а без красных рельс разве нельзя было обойтись?

colibrica: Нельзя, потомучто если профили в конце пути будут переходить в точку, то концы элемента будут выглядеть как
луковки у храма с иглообразными окончаниями и резкими плечами, вобщем косячная геометрия будет а это стало ножкой телеф. столика из клееного шпона. А вообще на первой картинке нормальный элемент,
и зачем точнейшее по размерам моделирование такой сложной геометрии? ведь наверняка это ювелирка а там это до фени, сам гравёр 6 разряда.

Batuhan: Цитата: "А вообще на первой картинке нормальный элемент,
и зачем точнейшее по размерам моделирование такой сложной геометрии? ведь наверняка это ювелирка а там это до фени..."

Не факт. А если по этой дороге будут камни расставляться? Причем одинаковые. То нужна постоянная ширина.

colibrica: Ну не до соток же, о чём реч то , камни то потом всё равно гравёр будет крепить

Saved by PHlab. 2005