Disclamer

ВНИМАНИЕ

Вся информация в данном документе предоставлена в образовательных целях. Для того, чтобы показать как плохо защищены пользователи. Авторы не несут никакой ответственности за действия лиц использующих информацию из данной статьи. Если вы не согласны с изложенным выше, то немедленно закройте, а затем удалите данный файл.


Legion

Далее я опишу ряд способов и программ, с помощью которых ты можешь добыть так необходимые тебе файлы.

Самая простая из них - это знаменитый Legion (поищи ее в интернете, но она уже морально устарела, поэтому я ее подробно описывать не буду). Просто запусти его, введи начальный и конечный IP, жми Scan. И получаешь список бакланов с расшаренными ресурсами, выделяешь диск С, кликаешь Mount, и получаешь сетевой диск. Затем ищешь pwl или другие необходимые тебе файлы, затем копируй их к себе на винт и расшифровывай.


Essential Net Tools

Программа Essential Net Tools также выполняет такие функции. (Описание предоставлено Игорьком)

- Запустите программу. В левой колонке, нажимаете на NBScan

Как видно на рисунке,

в нижнем окошке, где написано Starting IP address:, введите начальный IP . В нашем случае это 212.38.112.1 Автоматически заполнится нижнее окошко - Ending IP address. И нажимаете на кнопку Start . Программа начнёт сканировать все подключённые к этому диапазону в данное время компьютеры.

После окончания сканирования смотрите на результаты [image]:

В колонке RS есть надписи YES и NO . Сразу же уберите взгляды с NO . И можете больше не обращать на них внимания. Нам нужны только YES . Но и это ещё не всё .

В самой последней колонке, где написано MAC Address , видно мнооооооого цифр.

Опять же, уберите взгляды с чисел , начинающимися на 00: Это системы Windows 2000 , Linux и другие. С них вы всё равно ничего не получите.

Нам нужны OS - Windows 95, 98, Me. Цифры типа 44:45:53:54:... это и есть нужные нам оськи . В них то мы и будем искать расшаренные диски С.

Выбрав первую жертву, например :

SERVER NETCLUB YES 212.38.112.32 44:45:53:54:00:00

тыкаете на него правой кнопкой мышки и нажимаете Open Computer

Система при этом может на 2-3 минуты затормозить, винт затрещит, начнёт думать. Не волнуйтесь, это нормально. Откроется панель Explorer (точно такая же, как когда вы открываете "Мой компьютер")

Смотрите на названия папок, открывшихся там. Если там есть папка С, то она нам и нужна. Некоторые юзеры могут переименовать диск С на своё имя или фамилию или ещё как - либо. Так что если диска С вы не увидите, а вместо него увидите допустим папку "Вася", то стоит и её просмотреть (но папок там может и не быть , В этом случае сразу же переходите к следующей жертве ). А если всё вышеуазанное вы увидели , то не спешите радоваться ;) Это пока может ещё не Эврика. Закройте окно Explorer и нажмите в левой колонке ENT - a, на кнопку Shares. Внизу , в окошке Share name: , введите следущее \\212.38.112.32\c

Это IP адрес и диск С, который вы увидели когда открывали комп жертвы. А в правом , нижнем всплывающем окошке(Local drive) , выберите любую из букв . Это будет ваш временный локальный диск . Нажмите на кнопку "Mount", т.е. подключиться . Опять же комп может затормозить на пару минут . И , следующее , что вы увидите , - появится надпись "connection succesfull" , что означает подключено чего мы и добивались.

Но, может произойти и хреновое. Может появиться надпись - неправильный пароль . В этом случае попробуйте эту - последнюю процедуру ещё раз . Программа иногда ошибается . Но если и во второй и в третий раз вы увидели надпись о неправильном пароле , это будет означать , что он установил пароль на диск С . В этом случае можете переходить смело к следующему клиенту .

Далее , после всех этих процедур , открываете программу FAR

manager , и начинаете просматривать и копировать нужное из его диска С.


LANguard Network Scanner

Следующая прога LANguard Network Scanner v1.25 . У неё тот же принцип действия, только есть дополнительные возможности, такие как вывод информации о MAC, также portscan и bruteforce для запароленных дисков, если пользователь оказался чуть умнее. При нахождении запароленного диска С взламываем пароль bruteforc`ом и подключаем как сетевой диск к своей машине, а дальше по шаблону. Единственный минус - некоторое подвисание программы при сканировании.


Shared Resource Scanner

Еще одна программа Shared Resource Scanner 6.3 , самая быстрая программа в данном роде, есть также bruteforce к дискам, и многие другие фишки.

На момент написания данного хелпа у автора данной программы появились проблемы, его обвиняют по 272(?) статье «создание вредоносных программ». Из-за того, что кто-то воспользовался данной прогой с целью доступа к компьютеру других пользователей.


xSHaReZ

Следующая программа xSHaReZ принцип действия почти тот же, использует для взлома паролей к дискам прогу xIntruder. Очень быстро справляется с задачей подбора паролей к запароленным дискам.


Pwl-grab

И наконец, самая лучшая прога для кражи чужих pwl: pwl-grab - это проста мечта для халявщика, просто запусти ее, укажи необходимые параметры, и вперед. Эта прога сама подключится к расшаренным дискам, и скопирует файлы pwl и system.ini в указанную директорию.


PWLTool

Теперь о прогеPWLTool последняя версия 6.x, кряк можно найти на сайте у Hex`a ( http://hex.warp0.com ) Её можно скачать с оффсайта : http://soft4you.com/ Или вот прямой линк для закачки: http://lastbit.com/getprg.asp?id=pwltool

Так вот, устанавливаете эту прогу, крякаете её и едете дальше.

Скопированный pwl, например default.pwl,

запускате двумя щелчками мышки, (как обычно вы запускаете любую программу или файл)

В открывшейся программе PWLTool

нажимате кнопку CheckPass, или, если появится сообщение типа (это имя незарегистрировано в вашей системе, хотя это маловероятно), нажмите CheckPassFast и прога начнёт искать пароль на зпароленный PWL. Далее откроются вашему взору пароль или все пароли жертвы. Но может случиться и такое, что при нажатии кнопки выйдет сообщение о неправильном пароле на PWL. В этом случае нажмите на кнопку "SearchPasswordFast" и программа начнёт искать пароль pwl-ки. Но и этот вариант случается довольно редко (процентов 20 пользователей при включении компьютера, вводят пароль). У таких пользователей как раз и стоит пароль на PWL-ку. Если программа не найдёт пароль, увеличьте значение в окошке "To:" это кол-во знаков в пароле (по умолчанию и в незарегистрированной версии максимальное кол-во знаков 4) или измените знаки в окошке

"Charset string".

Внимание: При увеличении этих значений, увелчится и время поиска.

Итак, если всё нормально, программа откроет все пароли этого PWL. В окошке видны все пароли и Логины (имя пользователя). Вот пример [image] :

-----------------------------------------

Dial-up:'*Rna\Worldnet\ifesaz1'

Password:'T10sbadPhonE'

-----------------------------------------

Где Worldnet - это имя провайдера, ifesaz1 - это ЛОГИН пользователя

И как вы наверное уже догадались, T10sbadPhonE - это пароль пользователя для входа в инет.

Вот в принципе и все, о PWL, кстати в PWLTool есть кнопка Adv, при нажатии на нее вам откроются дополнительные возможности для расшифровки файлов edialer.ini и tree.dat. Переходим на закладку More… выбираем программу, указываем файл, и все все логины и пароли у вас.


Trojans

Еще один способ. Добычи PWL состоит в подсовывание объекту трояна. Но

сначало следует заметить вот что:

Статья 273. Создание, использование и распространение вредоносных программ для ЭВМ

1. Создание программ для ЭВМ или внесение изменений в существующие программы, заведомо приводящих к несанкционированному уничтожению, блокированию, модификации либо копированию информации, нарушению работы ЭВМ, системы ЭВМ или их сети, а равно использование либо распространение таких программ или машинных носителей с такими программами - наказываются лишением свободы на срок до трех лет со штрафом в размере от двухсот до пятисот минимальных размеров оплаты труда или в размере заработной платы или иного дохода осужденного за период от двух до пяти месяцев.

2. Те же деяния, повлекшие по неосторожности тяжкие последствия, - наказываются лишением свободы на срок от трех до семи лет.

Теперь рассмотрим моменты, в каких случаях следует использовать трояны:

1) Вы залезли на компьютер жертвы, скопировали PWL и system.ini. Но

все равно не можете его взломать. Такое иногда случается. Ну, например

слишком большой пароль на PWL, который придется взламывать очень и

очень долго.

2) Вы все скопировали, как надо открыли файл PWL, а там нужного вам

пароля не оказалось.

3) У жертвы вообще нет шаров, и придется впаривать ему троян другим

способом.

Теперь рассмотрим попарядку как быть в каждом случае.

1) Итак мы заходим на компьютер и просто копируем, троян на чужую машину. Ну, например, в папку windows или еще дальше windows\systems. Потом берем и открываем файл win.ini, он лежит в папке windows\. В самом начале этого файла мы увидим строчки load= и run= , и прописываем там полный путь к трояну. Например, если мы поместили

троян в папку window и он имеет название, скажем bad.exe (лучше конечно, другое давать имя). Тогда будет load=c:\windows\bad.exe или run=c:\windows\bad.exe. Как вам больше нравится :-)

Можно поступит проще запихнуть троян в автозагрузку и ничего нигде не надо прописывать, но тогда ссылка на него появится в пуск-программы-автозагрузка, что не желательно. (Но если придать файлу трояна статус СКРЫТЫЙ, то в Автозагрузке ничего не отобразиться).

Какие трояны следует использовать в этом случае. Те, которые высылают расшифровывают PWL, а также файлы программ дозвоньщиков, в которых хранятся пароли. В зависимости от троянов пароль может высылаться на мыло или сохранять свои результаты на диске жертвы в виде лог файла или чего-то похожего. Я приведу в пример такого трояна MOscow State trojan. Был опробован лично мною в целях опыта, с моим другом. С его согласия конечно. Свои функции выполнил, кроме одной, но она не имеет

большого значения. Следует сказать, что есть такой троян с названием Наеби соседа. Он отсылает пароли не только вам на мыло, но и на мыло его создателя.

2) В этом случае сперва попробуйте полазить по компьютеру, потому что некоторые пользователи не сохраняют пароли в PWL, а просто хранят его на диске в открытом виде. Чаще всего или на Рабочем столе или в Моих документах. Еще пароли могут скрываться в файлах *.scp. Некоторые провайдеры в разделах в помощь пользователю пишут, как подключаться через скрипт, и некоторые конструкции скриптов включают пароли и логины в открытом виде. Так что обращайте внимание на такие файлы. Они могут

находится тут *:\Program Files\Accessories, а могут и где-то еще.:-)

Нету? Ну да ладно. Нам понадобятся так называемые тряны keyloggerы они отлавливают комбинацию вводимых цифр и букв нажатых на клавиатуре. И также либо отсылают на мыло, либо хранят на диске жертвы.

Способ установки такой же.

3) Самый интересный способ. Лучше всего впаривать трояны в виде картинок. Т.е вы просто склеиваете троян с картинокй и даете расширение картинка.jpg. еxe.(много пробелов) Это дело можно послать по асе, так как она не покажет расширение exe окошко у нее слишком маленькое не поместится или по почте. Здесь уже включаем фантазию и

думаем как это сделать чтоб юзверь открыл этот файл.

Подробно. Итак, что мы имеем. Предположим такую ситуацию. Вариант номер 1. Просканили Мы диапазон, а там всего там мало некуда не залезешь. Ужас просто. Попробуем сделать так посмотрите внимательно на имена компьютеров. Ну и наметьте себе имя что-то типа Natasha или Valy, не пропускайте также имена Timur или похожие. Может нам придется побыть девушкой или наоборот парнем. Вобщем пол сменить. Ну, так ип мы знаем. Берем программу, которая сканируют порты на наличие аси {--забыл

как называется--}самые популярные 1080, 5120, 4000. Ну, как нашли? Если нет, ищем другого. Если удачно то высветится номерок. Смотрим кто это, главное чтобы было достаточно информации. Т.е прописано мыло и так далее. Если информация скудна, то лучше ищите другого. Ну, если эти этапы пройдены удачно, едем дальше.

Видим, что это девушка, возраст колеблется от 15 до 28, просто если больше, то вероятность что она замужем возрастает. Мы быстренько меняем информацию на подходящую, т.е. соответственно на возраст от 16 до 30. Лучше даже заведите отдельную асю и пропишите ее своими виртуальными данными. Пропишите похожие увлечения, только не переусердствуете, а то получится уж слишком много совпадений. Все готово первый этап пройден. Стучимся в асю к жертве и начинаем разговаривать. Обязательно восхвалите, ник пользователя и скажите, что у нее или него ;) хороший вкус. Дальше стандартные вопросы и слова. Наконец спросите имя пользователя. И скажите, что оно вам нравится. Только не будьте ангелочком, это настораживает. Ну и далее долгожданный

вопрос У тебя есть фотка? Неважно, что вам ответят. Главное чтобы у вас спросили, есть ли она у вас? Конечно да. Отсылаем заранее заготовленную фотографию, склеенную с трояном. Естественно лучше высылать не свою фотографию, а взятую, например с сайта знакомств чужую. И постарайтесь сделать так чтобы пользователь после ее отправки

у себя нажал на кнопочку открыть, чтобы в этом быть уверенным нужно довести клиента до кондиции. Т.е. чтобы он хотел побыстрее на вас взглянуть. Ну и после для проверки, чтобы узнать посмотрели все-таки на вас или нет. Задайте вопрос типа «Как думаешь, в каком клубе сделана эта фотография?» или что-то типа того. А лучше послать фотографию на которой изображены два человека. Тогда вас по любому спросят, который из них вы? Да и не посылайте фотографии размером 10Х10 склеенным с трояном размера 200kb. Заметить элементарно, такое попустительство с вашей стороны.

Если вам такой способ непонраву можно сделать подругому.

Вариант 2.

Заведите себе отдельное мыло, Например admini@mail.ru. Здесь опять воля вашей фантазии и пошлите письмо. С примерно таким содержанием.

Здрасте.........

Мы производим тестирование программы

с помощью, которой вы можете зарабатывать деньги в интернете просто

находясь в нем. Она фиксирует время вашего нахождения в

интернете,...... и так далее. Что придет на ум.

Всего хорошего.

И будет лучше, если вы не просто так вышлете троян, а, например склеете

ее с какой-то прогой. Т.е найдите программу, которая для установки требует другие файлы. Например, при инсталяции извлекает из какого-то архива файлы. Возьмите и удалите этот архив. И посмотрите как себе тогда поведет установочный файл. Если программа не может установиться без этого архива чудесно. Только продумайте этот момент, а то как-то некрасиво будет, если выскочит окошко сейчас будет установлен Flash, а только потом выскочит ошибка при копировании. Продумали? Смело

клейте с троей и вперед.

Только один важный момент отсылайте такие письма через специальные службы и пользуйтесь специальными программами, которые сотрут ваш ип из заголовка письма. Т.е. Не забывайте об анонимности, а то вас могут легко найти.{ А вот про то, как надо отсылать анонимно я точно не помню, где-то видел хорошую статью на эту тему, а где забыл}

Подумайте о безопасности. Заведите для паролей отдельную почту. Только

для этого!!!!!. Всегда. Запомните, всегда заходите на неё через анонимный прокси. Ну, вот вроде и все.


Язык сркиптов

1.) Введение.

Эта статья была написана для ответа на вопрос "Как написать свой скрипт для dial-up
соединения?" часто задававшийся в эхах фидо, на BBS, а теперь время от времени появляющийся у тех, кто хочет использовать сети x.25. Фактически данный документ является русским, несколько измененным, вариантом документа Dial-Up Scripting Command Language For Dial-Up Networking Scripting Support. Часть примеров была взята из скрипта для подсоединения к серверу SPb Code|NET.
Так для чего же нужны dial-up скрипты? Они позволяют автоматизировать операции по передаче/приему и обработке информации, которой обмениваются собой компьютеры при соединении по модему. Причем эта передача ограничивается пересылкой логина , пароля и получением IP адреса только для соединения с некоторыми Internet провайдерами, в основном же эти скрипты используются для подсоединения к BBS, а так же к специализированным серверам, где передав несколько строк можно сразу получить нужную информацию, а не искать ее по директориям (так сделано на серверах Spb Code| NET). Так же с помощью скриптов можно указывать, какие услуги нужны для устанавливаемого соединения. Если вам интересно каким образом можно использовать скрипты зайдите на любую поисковую машину и введите "Dial-up scripting".
Сам язык скриптов сильно напоминает язык BASIC, поэтому тем кто его знает будет проще.

2.) Переменные

В сценарии подключения можно использовать переменные. Имена переменных
должны состоять из набора букв английского алфавита цифр и знака подчеркивания - "_", но начинаться имена могут только с буквы или знака "_". В качестве имен переменных нельзя использовать зарезервированные слова, при работе скрипта такие имена будут обрабатываться как команды. Для использования предусмотрены три типа переменных:

Объявление переменных происходит следующим способом:
[тип] [имя переменной]=[начальное значение переменной]
Пример:
…
integer attempt = 3
; объявление переменной attempt типа integer и значением 3
string szLogin = "username:"
; объявление переменной szLogin типа string и значением username:
…
Для переменных типа string предусмотрен ряд специальных символов (литер), они следующие:

Пример:
…
transmit "^M"
; посылка символа возврата каретки
transmit "Rook^M"
; посылка строки, содержащей последовательность символов и знак перевода
; каретки.
transmit ""
waitfor ""
;ожидание ответа от удаленного компьютера
…
Существуют несколько системных переменных, которые определяются при вводе данных в диалоговом окне dial-up подключения и при выполнении команд. Эти команды представлены ниже:

Менять такие переменные пользователь не может, но допускается их использование как параметров команд.
Пример:
…
transmit $USERID
transmit $PASSWORD
; пересылка имени пользователя и пароля на удаленной компьютер.
…
Примечание: необходимо учитывать тип этих переменных при использовании в командах.

3.) Математические выражения.

Математическое выражение - это комбинация математических операций и
аргументов, представленных переменными или постоянными величинами. Выражения могут использоваться как параметры для команд.
Для использования предусмотрены следующие математические операции (положение в таблице показывает старшинство операции):

Примеры:
…
transmit "Hello from "+$USERID
delay 64/(32-(3+4*3))
…
Поскольку в этом языке нет типа real дробные результаты будут округляться.

4.) Команды, ключевые и зарезервированные слова.

Все команды являются зарезервированными слова- это значит, что их нельзя
использовать в качестве имен переменных, так же как и ключевые слова, которые представляют собой терминалы языка.
В языке скриптов для dial-up соединений есть следующие зарезервированные слова:
;
Точка с запятой показывает, на то, что все, идущее за ней является комментарием и не обрабатывается.
Пример:
; Это комментарий
integer a
; Следующий комментарий

AND
Логическое "Или"
Пример:
…
boolean a
boolean b
…
if !a and b then
endif
…

BOOLEAN
Ключевое слово для задания логического типа для переменной
Пример:
…
boolean name [ =value ]
…

DATABITS
см. set

DELAY nSeconds
Пауза между выполнением команд в секундах, записанная в nSeconds.
Пример:
…
integer seconds=5
…
delay 10
delay Seconds+2
…

DO
cм. while

ENDIF
см. if

ENDPROC
Указывает на конец процедуры

ENDWHILE
см. whille
EVEN
см. set port parity

FALSE
Булевская переменная, указывающее, что результат операции над булевыми переменными оказался ложным

GETIP [value]
Команда ожидает, когда будет получен IP адрес с удаленного компьютера. Если передается несколько IP адресов, они записываются в строчную переменную, для получения определенного IP адреса используйте параметр value.
Пример:
…
szAddress = getip
; передает первый полученный IP адрес в строку szAddress
szAddress = getip 2
; передает второй полученный IP адрес в строку szAddress
…

GOTO label
Переход на метку в скрипте указанную как label и продолжение выполнения команд с этого места.
Пример:
…
IF $SUCCESS then
goto _out
endif
Transmit "bbs^M"
Goto end
_out:
transmit "err^M"
end:
…

Примечание: место на которое необходимо перейти должна иметь тоже имя, что указано в команде goto, но после нее указывается знак двоеточия.

HALT
Прерывает работу скрипта, но не закрывает диалоговое окно. Перезапустить скрипт в этой сессии уже нельзя.

IF condition THEN
Ряд команд
ENDIF
выполняется ряд операций от then до endif, если condition=true;
Пример:

If $USERID == "Rook" then
transmit "CODENET.MEMBER.SENIOR.rook^M"
endif

INTEGER
Ключевое слово для задания целочисленного типа для переменной
Пример использования:
…
integer name [ =value ]
…

IPADDR
см. set

KEYBOARD
см. set

MARK
см. set port parity

MATCHCASE
см. waitfor

NONE
см. set port parity

ODD
см. set port parity

OFF
см. set screen keyboard

ON
см. set screen keyboard

OR
Логическое "И"

PARITY
см. set

PORT
см. set

PROC name
Указывает на начало процедуры. Любой скрипт должен содержать процедуру main, только по ней рн начинает и заканчивает выполнение. При этом общий вид процедуры такой:
proc main
Объявление переменных
…
Блок команд
endproc

RAW
см. transmit

SCREEN
см. set

SET
SET PORT DATABITS 5|6|7|8
Изменяет количество бит в байтах, пересылаемых и получаемых во время сессии. По умолчанию значение устанавливает таким, какое указано в настройках соединения.
Пример:
set port databits 7

SET PORT PARITY none|odd|even|mark|space
Изменяет четность порта через который передаются и принимаются данные во время сессии. По умолчанию значение устанавливает таким, какое указано в настройках соединения.
Пример:
set port parity even

SET PORT STOPBITS 1|2
Изменяет число стоп-битов на время сессии. По умолчанию значение устанавливает таким, какое указано в настройках соединения.
Пример:
set port stopbits 2

SET PORT SCREEN KEYBOARD on|off
Включает или выключает ввод с клавиатуры в окне терминала.
Пример:
set screen keyboard on

SET IPADDR _string
Устанавливает IP адрес для текущей сессии. Строка должна быть записана в формате IP адресов.
Примеры:
_ipaddress="11.83.23.1"
set ipadd _ipaddress
set ipaddr "11.83.23.1"
set ipaddr getip

SPACE
см. set port parity

STOPBITS
см. set

STRING
Ключевое слово для задания строкового типа для переменной
Пример использования:
…
string name [ =value ]
…

THEN
см. if

TRANSMIT _string [,raw]
Пересылка строки _string на удаленный компьютер. Удаленный компьютер может распознать escape последовательность и возврат каретки, если не используется параметр raw. Параметр raw используется, когда пересылаются $USERID и $PASSWORD в которых имеются указанные последовательности, иначе они будут восприняты как специальные символы. На практике это значит что пароль abc^Mddea будет послан как abc^M.
Примеры:
…
transmit "SLIP^M"
transmit $USERID, raw
…

TRUE
Булевская переменная, указывающее, что результат операции над булевыми переменными оказался верным

UNTIL
см. waitfor

WAITFOR string [,matchcase][then label {,string1[,matchcase]then label1}][until time]
Команда ожидает получения строк от удаленного компьютера, которые ассоциируются со string, string1 и так далее. Параметр sting не чувствителен к регистру, если не указан параметр matchcase. Если известная строка была получена и для нее был установлен параметр then label, то скрипт перейдет на указатель label. Параметр until устанавливает время ожидания ответа от удаленного компьютера, прежде чем перейти к следующей команде, без этого параметра компьютер будет ожидать постоянно.
Примеры:
…
Waitfor "Login:"
; это означает, что будет ожидаться появление строки Login:
waitfor
"Login:" then _login
"Password:" then _password
until 15
…

WHILE condition DO
Ряд команд
ENDWHILE
Цикл по командам, пока условние condition не станет ложным.
Пример:
…
integer attempt=3
integer n=0
while n transmit "^M"
waitfor "Login: " until 15
if $SUCCESS then
goto _login
endif
n=n+1
endwhile
…

5.) DUN

Файлы с таким расширением создаются мастером новых соединение и представляют
собой запись всех установленных параметров, включая все настройки модема и скрипт для соединения. Как ни странно, но в чистом виде на диске они не записываются, но если воспользоваться сервисом drag&drоp и перенести созданный файл в любую папку, то при просмотре можно будет увидеть подобный файл (файл экспорта):

;Файл aanet.ru.dun
[Entry]
Entry_Name=AANET.RU
Import_Name=AANET 3
Multilink=no

[Phone]
Dial_As_Is=no
Phone_Number=XXXXXXX
Area_Code=
Country_Code=7
Country_ID=7

[Device]
Type=modem
Name=LT Win Modem
Settings_Size=108
Settings=1C000100130101100100180060100001010102001C02020002C22102122200
2000400A500100180200311340050000600600060034000000300000003000000030000
00000000000000000003C000000000000000000000001000000D3010000000000000000
0000000000000C

[Server]
Type=PPP
SW_Compress=no
PW_Encrypt=no
Network_Logon=no
SW_Encrypt=no
Negotiate_NetBEUI=no
Negotiate_IPX/SPX=no
Negotiate_TCP/IP=yes

[TCP/IP]
Specify_IP_Address=no
Specify_Server_Address=yes
DNS_address=XXX.XXX.XXX.XX
DNS_Alt_address=XXX.XXX.XXX.XX
WINS_address=0.0.0.0
WINS_Alt_address=0.0.0.0
IP_Header_Compress=yes
Gateway_On_Remote=yes

[Scripting]
Name=Pppmenu.scp

[Script_File]
0=;
1=; This is a script file that demonstrates how
2=; to establish a PPP connection with a host
3=; that uses a menu system.
4=;
5=; A script file must have a 'main' procedure.
6=; All script execution starts with this 'main'
7=; procedure.
8=;
9=
10=
11=; Main entry point to script
12=;
13=proc main
14=
15=; Change these variables to customize for your
16=; specific Internet service provider
17=
18=integer nTries= 3
19=
20=; This is the login prompt and timeout values
21=
22=string szLogin = "username:"
23=integer nLoginTimeout = 3
24=
25=; This is the password prompt and timeout values
26=
27=string szPW = "password:"
28=integer nPWTimeout = 3
29=
30=; This is the prompt once your password is verified
31=
32=string szPrompt= "annex:"
33=
34=; This is the command to send to establish the
35=; connection. This script assumes you only need
36=; to issue one command to continue. Feel free
37=; to add more commands if your provider requires
38=; it.
39=
40=;
41=; This provider has a menu list like this:
42=;
43=; 1 : Our special GUI
44=; 2 : Establish slip connection
45=; 3 : Establish PPP connection
46=; 4 : Establish shell access
47=; 5 : Download our software
48=; 6 : Exit
49=;
50=; annex:
51=;
52=
53=string szConnect = "3^M"
54=
55=; Set this to FALSE if you don't want to get an IP
56=; address
57=
58=boolean bUseSlip = FALSE
59=
60=
61=; -----------------------------------------------------
62=
63=
64=; Delay for 2 seconds first to make sure the
65=; host doesn't get confused when we send the
66=; two carriage-returns.
67=
68=delay 2
69=transmit "^M^M"
70=
71=; Attempt to login at most 'nTries' times
72=
73=while 0 < nTries do
74=
75=; Wait for the login prompt before entering
76=; the user ID, timeout after x seconds
77=
78=waitfor szLogin then DoLogin
79=until nLoginTimeout
80=
81=TryAgain:
82=transmit "^M" ; ping
83=nTries = nTries - 1
84=
85=endwhile
86=
87=goto BailOut
88=
89=DoLogin:
90=; Enter user ID
91=
92=transmit $USERID, raw
93=transmit "^M"
94=
95=; Wait for the password prompt
96=
97=waitfor szPW until nPWTimeout
98=if FALSE == $SUCCESS then
99=goto TryAgain
100=endif
101=
102=; Send the password
103=
104=transmit $PASSWORD, raw
105=transmit "^M"
106=
107=; Wait for the prompt
108=
109=waitfor szPrompt
110=
111=transmit szConnect
112=
113=if bUseSlip then
114=; An alternative to the following line is
115=;
116=; waitfor "Your address is "
117=; set ipaddr getip
118=;
119=; if we don't know the order of the IP addresses.
120=
121=set ipaddr getip 2
122=endif
123=goto Done
124=
125=BailOut:
126=; Something isn't responding. Halt the script
127=; and let the user handle it manually.
128=
129=set screen keyboard on
130=halt
131=
132=Done:
133=
134=endproc
135=

Как уже было написано выше, в файл DUN, в раздел [Script_File], включается Dial-up
скрипт целиком с коментариями и с пустыми строками. В раздел [Scripting] записывается имя файл со скриптом, это сделано для того, чтобы при подсоединении была возможность автоматически обновить используемый скрипт.

6.) Заключение.

В Windows 9x/Me существует такая интересная вещь - для одного файла DUN могут существовать 3 разные настройки:
1. Хранится собственно в файле создаваемом мастером.
2. Хранится в файле экспорта, а при его изменении создается новое соединение (а не изменяется существующее).
3. Хранится непонятно где, а задается в дебрях этого диалога:


Proxy

Прокси-серверы и их предназначение
Зачастую пользователи, услышав слово прокси-сервер, либо не понимают его истинного предназначения, либо же просто считают, что прокси-сервер - это обыкновенный сервер, и разницы между обычным сервером и прокси практически никакой. Данная статья предназначена для разъяснения понятия прокси-сервер и ответа на вопрос "Что же такое прокси-сервер?".

Прокси-серверы используют для того, чтобы обеспечить эффективный и безопасный доступ в Интернет. Их устанавливают в различных организациях для обеспечения взаимодействия локальной сети с глобальной сетью Интернет. В качестве средства дополнительной безопасности прокси-серверы используются как межсетевые экраны. Рассмотрим функционирование прокси-серверов. Когда клиент пересылает запрос на какой-то конкретный документ прокси-серверу, то сначала этот сервер получает требуемый документ по соответствующему протоколу, а затем уже пересылает его клиенту. Запросы клиента передаются серверу по протоколу HTTP (HyperText Transfer Protocol). Однако это не является ограничением, кроме этого, не имеет значения и тип затребованного документа, поскольку в самом запросе к серверу содержится полная информация о необходимом документе, в частности его тип и необходимый для этого протокол. Для того чтобы это осуществилось, прокси-сервер сам анализирует пришедший запрос и уже после этого определяет нужный адрес, по которому и будет перенаправлен пришедший запрос.

Все прокси-серверы разделяют на две группы: это прозрачные (transparent) и непрозрачные (no transparent). В чем же их отличия? Прозрачные прокси-серверы при различного рода запросах покажут ваш реальный IP-адрес, если Вы, конечно, не используете цепочку из нескольких прокси-серверов, желательно непрозрачных. Поэтому, если Вы задумали что-то не совсем хорошее, то советую воспользоваться непрозрачными прокси-серверами. Такие серверы при любых запросах не выдадут Ваш реальный IP-адрес, поэтому для анонимности нужно использовать именно no transparent прокси-серверы, к тому же желательно не один, а несколько. В этом случае Вас практически невозможно будет отследить и вычислить реальный IP-адрес. Для того чтобы настроить свой браузер на работу с прокси-сервером, Вам необходимо в IE выбрать Сервис -> Свойства обозревателя, а после этого, если Вы используете локальную сеть, на закладке "Подключение" выбрать "Настройка сети", где нужно и вписать адрес прокси-сервера и его порт. В случае, когда для доступа в сеть Интернет Вы не используете локальную сеть, то Вам необходимо выбрать нужное соединение и уже в его настройках указать необходимый прокси-сервер. Однако если вам нужно использовать для анонимности целую цепочку прокси-серверов, то тут настройками одного лишь браузера не ограничишься. Для этого написаны специальные программы, которые и осуществляют подключение посредством нескольких прокси-серверов.

Для эффективности работы прокси-серверов используют кэширование. Оно предназначено для ускорения доступа к документам и снижению трафика, проходящего через сеть Интернет. Допустим, Вы скачали какой-то файл. После этого другой человек, подключившись к этому же прокси-серверу, захотел скачать тот же файл, что был затребован Вами ранее, так вот этот человек получит его намного быстрее, нежели Вы, из-за того, что файл был помещен сервером в кэш и при повторном запросе он уже не выкачивался заново, а был взят из кэша прокси-сервера. Именно поэтому сокращается время ожидания клиентом.

Хочу предупредить, что не все документы можно кэшировать. Если доступ к документу или страницам Web открывается только после внесения Вами абонентской платы, то в этом случае эти документы содержат теги WWW-Authenticate, Pragma: no-cache, Cache-control: private, Cache-control: no-cache, а также SetCookie. Если для доступа к определенным документам требуется пройти аутентификацию или же документ, который Вы потребовали, устарел, то в таких случаях прокси-серверы не заносят в кэш такие документы.

Для кэширования применяются различные средства. Существует две технологии кэширования: пассивное и активное. Пассивное кэширование (passive caching) заключается в том, что прокси-сервер просто ожидает запрос и лишь после этого осуществляет поиск нужного документа, а также определяет, нужно ли производить кэширование. Технология активного кэширования (active caching) состоит в следующем. Прокси-сервер в те моменты, когда активность пользователей снижается, пытается предугадать, какие из документов с большей вероятностью будут затребованы, и извлекает их. Для того чтобы ускорить доступ к ресурсам, крупные компании устанавливают сразу несколько прокси-серверов. Для управления кэшированием применяют специальные протоколы, такие как ICP (Internet Cache Protocol) и CARP (Cache Array Routing Protocol).

Исходя из вышесказанного можно сделать вывод, что прокси-серверы зачастую облегчают жизнь пользователей, используя кэширование, поэтому Вы сможете сэкономить свое время в сети, а к тому же остаться анонимными при использовании непрозрачных прокси-серверов. Но здесь нужно учитывать тот факт, что при использовании прокси-серверов Вы тратите лишнее время на подключения, поэтому иногда можно и обойтись и не использовать такие серверы.


Sita

Пока я опишу простейший способ добычи СИТА. Этот способо основывается на использовании обычных сканеров.

СИТА специализируется на аэроперевозках и это означает что это связано с авиакомпаниями. Для начала нам надо узнать о поиске доменов.
Узнаёте название авиакомпании вашей страны . Для примера берём Исландию. Авиакомпания у них называется islandair. Далее берём концовку доменов для этой страны - Исландия - is, и что же мы получаем ? Мы полцчаем домен islandair.is
Далее берём любую Whois проограмму. Например Smart Whois и вводим этот домен там. Жмём Enter и получаем диапазон IP этого домена. Если у вас нету такой программы, то это можно сделать и здесь http://www.leader.ru/secure/ в разделе watson . Ну и вот. Сканируем всё это дело обычным сканером и получаем то что нужно. У всех у них анлимы . Днем они на работе , а вечером, те у кого есть дома компьютер, сидят в инете за счёт своей компании. То же самое и для Экванта.
Кстате не забудьте у них кроме ПВЛ-ок искать на диске С (но вполне может быть и на других дисках) файлы с расширением scp (Макрос удалённого доступа) или скрипт. Чаще всего его суют в папу Windows . Но, ещё раз повторяю, он может быть и в "Моих документах" и где угодно.
Для телевидения типа CNN , BBS и т.д. уже дело обстоит по другому. Там в доменах окончания на com или net
Роуминг ( филиалы) у них разбросаны по всему миру. И поэтому добыча инета вообще простая . Заходите сюда : http://www.1globalplace.ru/ и разбирайтесь ( это совсем несложно). Если разберётесь, то вы обеспечены халявой на всю жизнь.
Вот вам ля этого небольшой списочек. Но вникнув в это дело, вы уже сами будете пополнять этот список:
@islandia.is
@islandair.is
@tal.is
@sita.int
@equant.com
@li.is
@rtl.com
@skima.is
@simi.is
@simnet.is
@taeknival.is
@iff.is
@val.is
@in.is
@islandssimi.is
@strik.is
@airiceland.is
@flugflelag
@isnet.is
@binet.is

А ниже привожу список окончаний доменов разных стран:

Что означают .com, .org и т.д. в URL-ах Интернет.

.com - (Commerce) коммерческие организации
.org - (Organizations) не-коммерческие организации
.gov - (Goverment) официальные правительственные организации.
.net - (Network) сетевые организации и службы
.mil - военные организации (Интернет начинался как военная сеть)
.edu - образовательные организации
.int - международные организации
.eu - European Union

Для стран региональные домены совпадают с двухбуквенным ISO-кодом:

A
AD - Andorra AE - United Arab Emirates AF - Afghanistan
AG - Antigua and Barbuda AI - Anguilla AL - Albania
AM - Armenia AN - Netherland Antilles AO - Angola
AQ - Antarctica AR - Argentina AS - American Samoa
AT - Austria AU - Australia AW - Aruba
AZ - Azerbaidjan
B
BA - Bosnia-Herzegovina BB - Barbados BD - Bangladesh
BE - Belgium BF - Burkina Faso BJ - Benin
BG - Bulgaria BH - Bahrain BI - Burundi
BM - Bermuda BN - Brunei Darussalam BO - Bolivia
BR - Brazil BS - Bahamas BT - Buthan
BV - Bouvet Island BW - Botswana BY - Bielorussia
BZ - Belize
C
CA - Canada CC - Cocos (Keeling) Isl. CF - Central African Rep.
CG - Congo CH - Switzerland CM - Cameroon
CI - Ivory Coast CK - Cook Islands CL - Chile
CN - China CO - Colombia CR - Costa Rica
CU - Cuba CV - Cape Verde CX - Christmas Island
CY - Cyprus CZ - Czech Republic
D-E
DE - Germany DJ - Djibouti DK - Denmark
DM - Dominica DO - Dominican Republic DZ - Algeria
EC - Ecuador EE - Estonia EG - Egypt
EH - Western Sahara ES - Spain ET - Ethiopia
F-G
FI - Finland FJ - Fiji FK - Falkland Isl.(Malvinas)
FM - Micronesia FO - Faroe Islands FR - France
FX - France (European Ter.)
GA - Gabon GB - Great Britain (UK) GD - Grenada
GE - Georgia GF - Guyana (Fr.) GH - Ghana
GI - Gibraltar GL - Greenland GM - Gambia
GN - Guinea GP - Guadeloupe (Fr.) GQ - Equatorial Guinea
GR - Greece GT - Guatemala GU - Guam (US)
GW - Guinea Bissau GY - Guyana
H-J
HK - Hong Kong HM - Heard & McDonald Isl HN - Honduras
HR - Croatia HT - Haiti HU - Hungary
ID - Indonesia IE - Ireland IL - Israel
IN - India IO - British Indian O. Terr. IQ - Iraq
IR - Iran IS - Iceland IT - Italy
JM - Jamaica JO - Jordan JP - Japan
K
KE - Kenya KG - Kirgistan KH - Cambodia
KI - Kiribati KM - Comoros KN - St.Kitts Nevis Anguilla
KP - Korea (North) KR - Korea (South) KW - Kuwait
KY - Cayman Islands KZ - Kazachstan
L
LA - Laos LB - Lebanon LC - Saint Lucia
LI - Liechtenstein LK - Sri Lanka LR - Liberia
LS - Lesotho LT - Lithuania LU - Luxembourg
LV - Latvia LY - Libya
M
MA - Morocco MC - Monaco MD - Moldavia
MG - Madagascar MH - Marshall Islands MK - Macedonia
ML - Mali MM - Myanmar MN - Mongolia
MO - Macau MP - Northern Mariana Isl. MQ - Martinique (Fr.)
MR - Mauritania MS - Montserrat MT - Malta
MU - Mauritius MV - Maldives MW - Malawi
MX - Mexico MY - Malaysia MZ - Mozambique
N-O
NA - Namibia NC - New Caledonia (Fr.) NE - Niger
NF - Norfolk Island NG - Nigeria NI - Nicaragua
NL - Netherlands NO - Norway NP - Nepal
NR - Nauru NT - Neutral Zone NU - Niue
NZ - New Zealand
OM - Oman
P-R
PA - Panama PE - Peru PF - Polynesia (Fr.)
PG - Papua New Guinea PH - Philippines PK - Pakistan
PL - Poland PM - St. Pierre & Miquelon PN - Pitcairn
PR - Puerto Rico (US) PT - Portugal PW - Palau
PY - Paraguay
QA - Qatar
RE - Reunion (Fr.) RO - Romania RU - Russian Federation
RW - Rwanda
S
SA - Saudi Arabia SB - Solomon Islands SC - Seychelles
SD - Sudan SE - Sweden SG - Singapore
SH - St. Helena SI - Slovenia SJ - Svalbard & Jan Mayen Is
SK - Slovakia SL - Sierra Leone SM - San Marino
SN - Senegal SO - Somalia SR - Suriname
ST - St. Tome and Principe SU - Soviet Union (still used) SV - El Salvador
SY - Syria SZ - Swaziland
T
TC - Turks & Caicos Islands TD - Chad TF - French Southern Terr
TG - Togo TH - Thailand TJ - Tadjikistan
TK - Tokelau TM - Turkmenistan TN - Tunisia
TO - Tonga TP - East Timor TR - Turkey
TT - Trinidad & Tobago TV - Tuvalu TW - Taiwan
TZ - Tanzania
U-V
UA - Ukraine UG - Uganda UK - United Kingdom
UM - US Minor outlying Isl US - United States UY - Uruguay
UZ - Uzbekistan
VA - Vatican City State VC - St.Vincent & Grenadines VE - Venezuela
VG - Virgin Islands (British) VI - Virgin Islands (US) VN - Vietnam
VU - Vanuatu
W-Z
WF - Wallis & Futuna Islands WS - Samoa
YE - Yemen YU - Yugoslavia
ZA - South Africa ZM - Zambia ZR - Zaire
ZW - Zimbabwe

А прочитав внимательно статью про язык скриптов, вы уже сами сможете клепать свои так необходимые всем скрипты с халявным нетом.


Sita

Снифферы

I. Введение

Я надеюсь эта статья будет хорошим повествованием о снифферах для начинающих, а также для тех, кто имел с ними дело.

II. Что такое Сниффер?

Сниффер(нюхач, eng) - это программа, которая устанавливается под NIC (Сетевую Интерфейсную Карту), иначе называемую Ethernet карта(одна из необходимых частей аппаратных средств, для физического соединения компьютеров в локальной сети). Как известно информация по сетке передается пакетами - от вашей машины к удаленной, так вот сниффер, установленный на промежуточном компьютере, через который будут проходить пакеты - способен захватывать их, пока они еще не достигли цели. У разных снифферов процесс захвата информации реализован по разному, ну об этом чуть ниже.

(соседний комп) (комп со сниффером) (удаленный комп)
| | |
(ваш комп) -----------------------------------------------------
> > > ^ > > > > > > > ^ > > > > > > > > ^

Стандартный пакет попутешествует из "вашего компа " через сеть. Он пройдет через каждый компьютер в сети, начиная с "соседнего компа", через "комп со сниффером" и заканчивая "удаленным компом". Каждая машина должна игнорировать пакет если он не предназначен для ее IP адреса. Тем не менее, машина со Сниффером забивает на эти правила и принимает ЛЮБОЙ пакет, который через нее проходит. Сниффер также известен как сетевой анализатор. Нет реального различия между сетевым анализатором и сниффером, но компании по безопасности и Федеральное правительство предпочитают второе название поскольку оно звучит более угрожающе.

III Какой это тип Атаки?

Для хакеров, сниффер отличное средство для наблюдения за посылаемой информацией, и это считается пассивным типом атаки. Пассивная атака - эта та атака которой непосредственно не вторгаются в чужую сеть или компьютер, например, используя сниффер, в надежде получить желаемую информацию, включая пароли. С другой стороны, активная атака непосредственно связывается с дистанционной машиной. Дистанционные переполнения буфера хоста, сетевые наводнения и другое, попадают под категорию активной атаки. По сути, пассивная атака сниффера не может быть обнаружена. Следы его деятельности ни где не отражаются. И при этом атака сниффера также серьезна, как любая активная атака.

IV. Чем хорош Сниффер

С помощью сниффера, вы можете получить любую информацию, которая была передана в сети, как то: пароли, почта, конфиденциальные документы, и любую другую незакодированную информацию. В сущности, сниффер действует как регистратор программ, установленных на машинах, от которых передаются пакеты. Захватывая эти пакеты, сниффер поможет вам создать точную карту сети и машин, которые находятся в ней. Есть одно правило для сниффера: для эффективной атаки сниффер должен устанавливаться в непосредственной близости к главному компьютеру, либо на сам главный компьютер(если получится). Поверьте, что не все машины из одной сети могут поделиться информацией друг с другом. Следовательно если у вас будет возможность доступа к главной машине или наиболее приближенной, то стоит злоупотребить этим и использовать эту машину как трамплин в остальную часть сети. При установке сниффера в хостах близких к главной машине, возможность получения секретной информации повышается.

V. Типы Снифферов

Наиболее популярный тип Снифферов использует кратковременный забор информации и работает в небольших сетях. Причина этого кроется в том, что невозможно поставить сниффер, который бы постоянно отслеживал пакеты и при этом не сильно использовал мощность центрального процессора. Чрезмерная загрузка центрального процессора и файловой системы являются единственным путем обнаружения снифферов. Эти снифферы осуществляют быстрый и кратковременный забор информации, чтобы утилиты, подобные РS и IFCONFIG не смогли обнаружить их. Если Вы обнаружили что загрузка центрального процессора была выше нормального, или, каждый день, Вы теряете еще один мег. дискового пространства, и это ничем не может быть объяснено, знайте - это указывает на присутствие сниффера.

Следующий тип снифферов, работает на больших протоколах передачи данных, соответственно, жрет по более ресурсов в центральном процессоре. В больших сетях, эти снифферы могут сгенерировать вплоть до десяти мегабайтных протоколов в день, если в сниффере установлена регистрация всего диалогового движения. А если стоит и обработка почты то объемы могут расти даже быстрее.

Следующий тип снифферов записывает только первые Х байтов пакета (X определенное число), чтобы захватить имя/пароль. Другой метод заключается в захвате целого сеанса, и "вырубания" ключа. Более продвинутые типы снифферов поддержит оба метода. Выбор типа сниффа зависит от возможностей сетки, хакера и желаемого конечного результата.

VI. Конструкция Сниффера

Если Вам интересны детали сниффера, хотите понять как работает, есть отличная статья(eng)Renfro's. Она описывает подробно основные элементы программирования сниффера, которые требует практическое знание языка C. Если Вы поймете статью, можете изучить исходный код сниффера (например, esniff.c).

VII. Популярные Снифферы

Есть люди считающие, что снифферы это инструмент для хакера, тогда как остальная часть их считает, что эта вещь для системных администраторов. Так или иначе сниффер необходим и тем и другим ;) Следующий список содержит наиболее популярные снифферы:

Sniffit: Это - один из первых снифферов и он по прежнему хорош. Этот сниф сохраняет первые 400 байтов пакета по умолчанию, но Вы можете запрограммировать его так, чтобы он захватывал целую сессию и вырубал пароль.

Snort: На момент написания статьи Snort 1.2.1 был только выпущен. Это - тоже хороший сниффер поскольку скорректирован более четко чем Sniffit, имеет кучу опций. Пользуйтесь.

TCPdump: Очень знаменитый сниффер. Считается, профессиональным административным средством. Вы может помните, что Tsutomu Shimomura модифицировал версию этого снифа (на самом деле это был Пакетный Фильтр Berkeley (BPF), но нет значительного различия между ними).

ADMsniff: известная, очень квалифицированная группа хакеров ADM написала хороший сниффер, советую посмотреть, т.к. все что они делают - определенно стоит внимания.

Linsniffer: известный сниффер разработанный для платформы Linux .

Esniff: Это хорошо известный сниффер.

Sunsniff: этот сниффер сделан под платформу SunOS. Возможно один из наиболее известных снифферов т.к. был сделан почти десять лет назад.

Solsniffer: сниффер для Solaris. Это - просто модификация Sunsniff разработанная, для компиляции чисто на платформу Solaris. Есть много хороших снифферов подобно Snort, которые умеют работать на многочисленных платформах. Я мог бы продолжить этот список, но для начала хватит. Загляните на любой хороший сайт по безопасности и качайте от души.

VIII. Обнаружение и Предотвращение атаки

Если Вы ответственный за сетевую безопасность, и собираетесь проверить сетку на наличие снифферов, я советую воспользоваться следующими программами и советами. Первая небольшая програмка которая вам поможет - promisc.c, написаная на С. Когда скомпилируете ее, она проверит вашу локальную машину с любым типом карты NICs. Следующая прога тоже на С neped.c, умеет делать дистанционные проверки на любые типы снифферов, но она компилируется только под Linux. Для поиска вручную, наберите команду 'ifconfig -', если вы имеете дело с *nix платформами, и хорошенько посмотрите все сетьевые интерфейсы, которые будут носить флаг PROMISC. Не так давно комманда L0pht выпустила хороший продукт AntiSniff под Win9*, правда пока только бета версию. Под NT сущетвует рабочая версия(если кому надо - вышлю). Также L0pht выложили исходный код своей проги для Linux. Но если вам нужен поисковик уже сейчас, советую neped.c в принципе он обладает таким же типом поиска. Все эти инструменты предназначены для дистанционного обнаружения снифферов как на удаленных хостах, так и в пределах подсети. Эти программы зарекомендовали себя как отличные средства обнаружения и зачастую очень надежные. Совет: для предотвращения несанкционированного сниффинга, вы должны использовать хорошую криптографию, даже если кто-нибудь поставил вам сниффер, с крипто - вы будете как в бронежилете.

IX. Как уничтожить Сниффер

Я не собираюсь подробно описывать все методы уничтожения поскольку существует подробная статья(eng) на эту тему от Phrack 54, если интересно посмотрите. В этом текстовике описано много методов для уничтожения снифферов.

X. Ссылки

На web сайте Security Focus можно найти очень много различных снифферов.

Сходите на сайт L0pht.com - изготовителя AntiSniff, почитайте о нем, если вас интересуют подробности.

XI. Заключение

Я надеюсь, что сделал хорошую статью, достаточную для того чтобы понять, что такое Сниффер, а также привел ссылки для более опытных людей. Удачи Вам в этом нелегком деле.


Firewall

Персональных файерволлов на рынке программного обеспечения довольно много, но программы эти в большинстве своем не очень известны, за исключением, пожалуй, уже несколько устаревшего AtGuard. Выбрать есть из чего, но насколько эффективно вы обезопасите с их помощью свои системы от злоумышленников зависит не только от того, что вы предпочтете, но и от того, как настроите и как будете использовать эту программу.

Sygate Personal Firewall (Sybergen's Secure Desktop)

www.sygate.com

Если вы собираетесь использовать персональный файерволл для значительного коллектива подопечных пользователей, то вам необходима некоторая степень централизованного развертывания и управления. Personal Firewall позволяет это легко осуществлять.

Хакер, решивший проникнуть на машину, снабженную такой программой, не только не обнаружит открытых портов, но и решит, что компьютер просто выключен, благодаря так называемому STEALTH-режиму, при котором неиспользуемые вами порты не откликаются на запросы из Сети. При активном Personal Firewall не удастся получить никакой информации, обычно доступной с подключенного к сети ПК - такой как имя компьютера, пользователя, рабочей группы. Использование его совместно с дополнительным компонентом Sygate Enterprise Network – сетевым центром управления пользовательскими машинами - эффективнейшим образом защитит любую корпоративную среду, позволяя дистанционно управлять всеми ПК в сети предприятия. Так, можно заставить файерволл высылать по электронной почте уведомление администратору об обнаруженном сканировании портов или попытке взлома. При этом ведется детальный протокол всех событий, облегчающий дальнейший “разбор полетов”.

Простота панели управления программы не должна вводить вас в заблуждение – вы можете заблокировать любой порт, задавая либо отдельно протокол TCP или UDP, либо оба одновременно. Имеется поддержка и протокола ICMP. Эта обманчиво простая панель настроек позволяет без каких-либо особенных знаний всех тонкостей сетевых коммуникаций задавать пять стандартных конфигураций уровня безопасности. При этом степень Ultra High с точки зрения защиты практически равнозначен выдергиванию штепселя модемного шнура из телефонной розетки при Dial-Up подключении к интернету – и его следует иногда использовать, например, если вы постоянно подключены по выделенной линии. Установка High, тем не менее, дает полный доступ к ресурсам сети через Internet Explorer и Outlook Express при отличных показателях безопасности. Так, например, при попытке использовать другие программы, стремящиеся попасть во внешний мир, Personal Firewall выдаст запрос на включение этих программ в “белый список” приложений, которым вы доверяете – это так называемый интерактивный режим “обучения” программы. Программы из этого списка будут иметь сетевой доступ независимо от выбора уровня безопасности.

Только не вполне понятно, почему в программе существует понятие разрешенных IP-адресов, и нельзя задавать запрещенные адреса – это серьезное ограничение ее функциональности.

Personal Firewall умеет задавать степень защиты, которая изменяется в зависимости от времени суток, что чрезвычайно важно при постоянном подключении к интернету. Так, администратор может позволить пользователям иметь полноценный доступ в Сеть днем и блокировать все на свете по окончании рабочего дня, защищая систему от несанкционированного доступа в свое отсутствие.

Еще одна необычная особенность файерволла – самостоятельное повышение уровня защиты при активизации скринсейвера, что, правда, может создавать помехи некоторым сетевым программам удаленного администрирования. Диалог конфигурирования Personal Firewall позволяет и вручную регулировать дополнительные настройки портов или выбирать “пресеты” часто встречающихся установок типа “Разрешить обзор сетевого окружения” простой установкой одного флажка. Если вы предпочтете управлять доступом к портам вручную, то сможете не только открыть/закрыть любой порт, но и назначить заданным приложениям разрешенные рабочие порты.

Инсталляция, требующая перезагрузки ПК, проблем не вызывает, файерволл работает и в Windows 2000, однако, обратите внимание на список известных “багов”. Так, например, предыдущая версия программы, называвшаяся Sybergen's Secure Desktop, была несовместима с Internet Chess Server. В общем, читайте немногословную, но достаточно грамотную документацию.

Network Ice Black ICE Defender

www.networkice.com

Этот файерволл применяет в своей работе приятную во всех отношениях функцию Black Trace - получение всей возможной информации о “хакающем” вас злоумышленнике. Генерируемый при отслеживании хакера протокол, зафиксировавший в пригодном для предъявления обвинения формате все незаконные действия правонарушителя, пригодится если уж не в суде, то, по крайней мере, будет серьезной уликой в разборках с привлечением интернет- провайдера (или местной братвы). Попавшийся чрезмерно активный “кулхацкер” запросто лишится как минимум выхода в интернет (о максимуме говорить не будем). Идентификация природы неизвестного трафика – очень хорошая функция, но манера Black ICE Defender обозначать любое соединение как атаку может заставить юзера поседеть гораздо раньше времени. В дополнение ко всему, Black ICE Defender при предупреждении (а это делается даже звуковыми сигналами) об обнаруженных попытках вторжения определяет степень опасности произошедшего события - от “критического” до “информационного”. При этом файерволл даже слишком многословен, когда ведет протокол событий - регистрируется абсолютно все!

У Black ICE Defender имеется и еще одна уникальная возможность. Путешествуя с мобильным ПК, или при Dial-UP доступе в интернет вы обычно не можете получить статический IP-адрес. Это означает, что нельзя заранее создать безопасное соединение между двумя ПК, задав явным образом их IP- адреса и разрешив им совместный доступ к файлам. Black ICE Defender очень элегантно решает эту проблему. Для этого достаточно (не пугайтесь!) открыть порты NetBIOS и установить нетривиальный пароль на доступ к файлам – если Black ICE Defender обнаружит попытку подобрать пароль, он тут же самостоятельно занесет IP злоумышленника в черный список и разорвет это соединение. Вы же, зная правильный пароль, всегда получите полный доступ, вне зависимости от динамически назначаемого IP-адреса своего рабочего ноутбука. Настройка совместного доступа к файлам очень проста, что есть немаловажный плюс программы.

К сожалению, хоть Black ICE Defender и блокирует порты весьма эффективно, он не умеет управлять доступом в Сеть установленных на компьютере приложений – уходящий трафик ничем не защищен. Таким образом, если уж “троянский конь” попал в вашу систему, то ничто не помешает ему воспользоваться открытым (например, для Outlook Express) портом и отправить все ваши пароли куда-нибудь на анонимный почтовый ящик mail.ru.

Еще один недостаток заключается в том, что иногда замечается неожиданное, без каких-либо предупреждений, прекращение работы файерволла. К тому же за это хозяйство разработчики еще хотят ежегодный лицензионный взнос, как будто вы не покупаете программу, а берете ее в аренду.

Black ICE Defender также имеет несколько заранее заданных уровней безопасности, причем названия им выбраны не без юмора: Trusting, Cautions, Nervous и Paranoid. Каждый уровень, хоть и пропускает все исходящие соединения, но обеспечивает чрезвычайно надежную фильтрацию поступающих соединений. При ручном же вводе конкретного IP-адреса в список разрешенных или заблокированных IP, Black ICE Defender либо разрешит полный доступ с этого адреса к вашему ПК, либо полностью заблокирует все приходящие пакеты.

Однако очень неудобно то, что нельзя задавать диапазон IP-адресов или маску подсети. Оригинальное динамическое управление правилами снимает необходимость обучающего режима (отсутствующего в этой программе). Небольшой совет: поскольку IP-адрес, в принципе, можно и “подделать”, будет неплохо, если вы сконфигурируете свои маршрутизаторы так, чтобы они не пропускали пакеты, носящие IP-адреса вашей сети, но порожденные за ее пределами.

На системы с Windows NT и Windows 9x программа устанавливается, даже не требуя перезагрузки компьютера, что немного облегчит жизнь “админам” с большим парком обслуживаемой техники. Тщательно продуманная документация охватывает все функции программы и содержит неплохие рекомендации о том, как следует реагировать на засеченные попытки взлома.

Zone Alarm

www.zonelabs.com

В напарники к Black ICE Defender можно посоветовать программу Zone Alarm, компенсирующую его основной недостаток - отсутствие контроля за приложениями, пытающимися выбраться в интернет. Эта бесплатная программа (есть и чуть расширенный платный вариант - Zone Alarm Pro) почти идеальна для индивидуального использования и защитит и одиночных “диалапщиков”, и десяток машин в локальной сети небольшой конторы. Помимо того, что утилита работает без проблем на любых версиях Windows - вплоть до Windows 2000 и “Миллениума”, она требует всего-навсего 486-й процессор и более чем нетребовательна к объемам оперативной памяти.

Все всплывающие сигнализаторы неопознанной сетевой активности будут понятны самым неопытным пользователям и предлагают всего два выбора - допустить соединение или отказаться от него. Также Zone Alarm спросит, хотите ли вы, чтобы программа запомнила этот ваш выбор на будущее. Для каждой зарегистрированной подобным образом или вручную программы есть возможность впоследствии конкретизировать настройки, указав разрешенные IP и порты. Все без исключения обращения к Сети протоколируются, даже если вы отключите вывод информационных сообщений о детектировании разрешенных соединений.

Разработчики этого файерволла тоже заботятся об удобстве пользователя, позволяя простым перемещением движка-регулятора задавать любой из трех предустановленных уровней защиты, причем отдельно настраиваются две зоны - локальная сеть и интернет. Характеристики этих установок легко изменить, если вас в них что-то не устраивает. При максимальном уровне не произойдет никаких соединений, пока вы лично их не разрешите, что, впрочем, требует некоторого времени на “обучение” программы - так что более чем десятку пользователей не стоит ее устанавливать одновременно, если не хотите стать админом-марафонцем.

Zone Alarm, как и многие другие защитные утилиты, использует STEALTH- режим, который “прячет” все неиспользуемые порты, предотвращая ответы о текущем статусе порта, запрашиваемые, например, при сканировании вашей машины в поисках “дыры”. Несмотря на кажущуюся простоту программы, она способна блокировать множество потенциально угрожающих вашей системе пакетов из интернета. При активизации экранной заставки или во время простоя ПК программа может полностью перекрыть выход в интернет, что повышает уровень безопасности забывчивых пользователей, особенно при постоянном подключении к Сети.

Для локальной зоны лучше установить среднюю степень защиты, чтобы сохранить сетевой доступ к “зашаренным” ресурсам - немаловажно, что при этом пользователь сам определяет, что относится к локальной зоне. К счастью, в этом случае не нужно вводить IP-адрес каждого ПК в локальной сети - достаточно задать диапазон адресов или маску.

В последнем релизе Zone Alarm добавилась опция Mail Safe, предотвращающая запуск потенциально опасных скриптов, полученных по электронной почте, типа печально известного вируса I LOVE YOU. В отличие от антивирусных программ, эта функция не даст пользователю запустить новейший, неизвестный антивирусам деструктивный скрипт. К сожалению, документация к программе ограничена HTML-справкой, но зато написана она довольно прилично. При желании вы сами воплотите ее в материальную форму, распечатав на принтере.

Norton Internet Security 2001 Family Edition

www.symantec.com

После покупки фирмой г-на Питера Нортона Symantec популярнейшей программы AtGuard можно было с полным правом ожидать, что изменится не только название файерволла, но и значительно улучшится его надежность и функциональность. В чем-то эти ожидания оправдались, а в чем-то и нет. Зато теперь программа “весит” около 40 Мб, поскольку в нагрузку к ней дается Norton Antivirus, что, согласитесь, заставляет трижды подумать при выкачивании демонстрационной (да и купленной) версии NIS2001 с сайта Symantec.

Появились аналогичные другим программам «движки», задающие несколько степеней защиты. Кроме того, программа теперь сама умеет автоматически создавать для нескольких наиболее распространенных приложений (Outlook Express, Internet Explorer, CuteFTP и т. д.) необходимые настройки, избавляя юзера от лишних проблем. Набор вариантов настроек существенно расширен, и теперь есть возможность блокировать IGMP-пакеты и фрагментированные IP-пакеты. Ручная конфигурация, естественно, позволяет настраивать программу как угодно, никаких ограничений нет вообще, вот только добраться до нужного меню стало труднее – надо раза четыре нажать кнопку мыши, переходя от одного меню к другому. Да и удобная панель быстрого доступа к настройкам и наглядной индикации событий Dashboard по умолчанию отключена – чтобы ее вызвать, надо вручную создать ярлык C:FilesInternet Security Family Edition.EXE -AppBar, в то время как в инструкции о существовании Dashboard вообще ничего не сказано.

Никаких проблем с “обучением” файерволла новым правилам в процессе детектирования попытки установления нового, незарегистрированного соединения не наблюдается, весь процесс укладывается в два клика во всплывшем диалоговом окне. Появилась шикарная опция – NIS2001 теперь умеет связывать привилегии доступа в интернет с конкретными приложениями. Вы можете, например, разрешить только вашему Internet Explorer соединяться только с ресурсами веб-серверов по портам 80 (http) и 443 (https) – то есть любому трояну уже ничего не светит. Для любой настройки есть даже возможность установить часы работы, чтобы разрешать, например, выход в интернет пользователям локальной сети только в обеденный перерыв. Надежность работы файерволла обеспечивается тем, что пакеты обрабатываются на низком уровне специальным драйвером до их отправки на растерзание какой-либо другой программе.

Уникальнейший режим блокирования баннеров сэкономит вам немало денег и времени, вырезая весь этот мусор из трафика. Помимо этого, вы можете сделать огромное количество других настроек – от блокировки подозрительных и опасных элементов ActiveX, JAVA-скриптов и апплетов – еще одного узкого места в безопасности браузеров, - до запрещения отправки cookies, выдачи версии вашего браузера и адреса электронной почты – анонимность нынче в моде.

Совершенно новая функция - ограничение доступа детей к “взрослым” сайтам - обойти ее, не зная пароля для доступа к настройкам файерволла (или тонкостей настройки самой операционной системы), будет очень непросто. Впрочем, если это вам не нужно, то приобретайте облегченную и удешевленную версию программы под названием Personal Edition. В ней отсутствует родительский контроль, однако в нем удалена еще и возможность блокировать рекламу.

К сожалению, в точности следуя своему названию, Norton Internet Security предназначен для работы исключительно с интернетом и не поддерживает сетевые протоколы NetBEUI, IPX, ARP, так что в локальной сети нет особого смысла его использовать, ибо защита получится несколько однобокая. Хотя для работы в интернете как самое комплексное решение он, пожалуй, идеален.

Учтите только, что в некоторых версиях программы после ее инсталляции оказываются открытыми порты NetBIOS для совместимости с некоторыми старыми кабельными модемами - первым же делом их закройте, если не намерены применять совместный доступ к файлам.

ConSeal PC Firewall

www.signal9.com

Интерфейс этой программы оставляет желать лучшего, но она - один из самых надежных, настраиваемых и гибких файерволлов, приближающийся по качеству к аппаратному брандмауэру, отлично подходящий опытному пользователю. Отсюда проистекает и самый главный его недостаток – пользователь должен отчетливо себе представлять, что такое TCP/IP.

Наборы правил этого файерволла представляют собой обычные файлы, которые без труда размножаются на любом количестве ПК в больших сетях. Настройке поддается все, что нужно: IP-адреса, порты, доступ приложений, направление пакетов. Есть и режим обучения, так как необходимость создания наборов правил вручную может сначала напугать кого угодно. На этот счет разработчики выложили на сайте несколько комплектов уже готовых файлов с вполне исчерпывающими настройками, которые послужат неплохой основой для создания установок, оптимальных в вашей конкретной системе. Учтите только, что когда вы устанавливаете новый файл с набором правил, то старые настройки не уничтожаются, а дополняются новыми, а в случае конфликта двух правил работает то, которое было установлено последним.

Установка проходит довольно гладко, да и инструкция весь процесс неплохо описывает, особо обращая внимание на всяческие хитрые моменты конфигурирования программы. Зато в Windows 2000 программа не работает совсем.

Пользователь изначально обеспечивается четырьмя типами начальных конфигураций: Dial-Up – модемный выход в интернет - блокируется весь ICMP; Cable - для кабельных и DSL-модемов; Browse – выбор готового файла настройки и None - для самостоятельного конфигурирования. Индивидуальному пользователю начинать с этого файерволла, наверное, не стоит, если только вы не готовы выучить наизусть всю инструкцию.

McAfee Personal Firewall (ConSeal Private Desktop)

www.mcafee.com

Еще одна перепроданная программа (вернее, “движок” от нее) - бывший ConSeal Private Desktop. Эта программа ориентирована в основном на рядового пользователя, в отличие от своего старшего брата - ConSeal PC Firewall.

Что мы имеем? Есть удобный и достаточно простой в использовании режим “обучения” программы, ставший практически стандартом для современных файерволлов. Не обошлось и без готового комплекта встроенных профайлов, вполне подходящих для первого знакомства с программой.

McAfee Personal Firewall умеет контролировать выход других программ в интернет, – блокировка исходящего трафика предотвратит ущерб от троянских программ. В случае попыток незарегистрированного в настройках файерволла приложения выйти в Сеть выскакивает диалоговое окно, требующее определиться, в какой из списков – “черный” или “белый” - занести эту программу. Из дополнительных функций стоит отметить разве что фильтрацию фрагментированных пакетов – в общем, не густо.

В администрировании этот продукт не очень удобен, и его, как и Zone Alarm, не рекомендуется устанавливать в больших сетях, хотя, учитывая то, что файерволл изначально рассчитан на индивидуальных пользователей, недостатком это назвать нельзя.

При тестировании программы нашелся неприятный “глюк”, - каждые десять секунд система на мгновение подвисает.

Вышеперечисленными программами, разумеется, список персональных файерволлов далеко не ограничивается, и я вам также настоятельно рекомендую посмотреть, например, еще и новейший файерволл Sphinx Personal Firewall (shop2.sphinxwall.com), который просто предельно дружественен к пользователю, благодаря использованию Configuration Wizard – мастера настройки. С помощью вполне понятного (для не разбирающегося во всех премудростях сетевых технологий пользователя) диалога, ответив на несколько вопросов, вы сможете задать все необходимые начальные параметры файерволла. В результате уже через минуту после его инсталляции получите совершенно работоспособную систему при максимуме безопасности. Хотя веселенький интерфейс программы и наводит на мысли о ее несерьезности, это впечатление обманчиво, и мне кажется, что у Sphinx Personal Firewall очень хорошие перспективы, так как он обладает всеми возможностями маститых конкурентов.

Проверить же качество вашего файерволла и его настроек вы сможете на сайтах Security Scan и ShildsUP!, которые вместо хакера просканируют все ваши порты и найдут потенциальные "дыры" в защите вашей информации.

(Лично я пользуюсь ZoneAlarmPRO, и мне нравится, как говорится дешево и сердито)


АОН

Дарова, вот решил взяться за очень классную тему для любого халявщика.

Начнем с принципа определения номера АОНом. Когда ты поднимаешь трубку и начинаешь звонить комунить у кого стоит АОН происходит следущее: твоя АТС(назовем ее АТС-1) связываться с АТС твоего абонента(АТС-2) при этом этому абоненту начинает поступать индукторный вызов. АОН подключается к телефонной линии, понижая напряжение до уровня 22-24в. Затем, через 250-275 мс (время на оканчание переходных процесов при комутации телефонной линии) АОН выдает на АТС-1 сигнал "запрос АОН" частотой 495-505 Гц с уровнем 4.3 дб и длительностью порядка 100 мс. На АТС-1 декодируется этот сигнал и выдается ответ - твой номер, ответ выдается многочастотным методом "безинтервальный пакет" в принятом коде "2 из 6". АОН осуществляет прием пакета частотной информации в порядке поступления с последуещей дешифрации комбинации.

Кстати, видишь на рисунке "24В", так вот это то самое напряжение ниже которого будет срабатывать повременка(если у тебя телефон на повременной оплате), о том как поддерживать напряжение на этом уровне при разговоре, в инете есть куча инфы. Теперь разберемся с тем что такое "2 из 6". "2 из 6" означает комбинацию двух частот из шести возможных:

f (Гц) Уровень (дб)
700 -6.5 до 27.4
900 -6.5 до 29.0
1100 -6.5 до 31.0
1300 -6.5 до 32.6
1500 -6.5 до 34.3
1700 -6.5 до 36.0

Цифра f1 + f2 Код «2 из 6»
1 700 + 900 000011
2 700 + 1100 000101
3 900 + 1100 000110
4 700 + 1300 001001
5 900 + 1300 001010
6 1100 + 1300 001100
7 700 + 1500 010001
8 900 + 1500 010010
9 1100 + 1500 010100
0 1300 + 1500 011000
«начало» 1100 + 1700 100100
«повтор» 1300 + 1700 101000

"Начало" - означает начало/конец пакета двухчастотных посылок, "Повтор" - означает, что очередная цифра повторяет предыдущую. Сам пакет содержащий номер выглядит так: "начало", цифра категории, 7я - 1я цифры номера, "начало". Тобишь номер 2534498 первой категории в безинтервальном пакете будет выглядеть так: "...352Н189П4352Н189...". Что касается категории абонента то она нужна для "распознавания" различного рода предоставляемых услуг для конкретных групп телефоных номеров, но поскольку значение категории может отличаться для отдельно взятого города/страны(хотя почти везде принято что к первой категории относятся абоненты квартирные, учрежденческие, имеющие право междугородной и международной связи на общих основаниях), мы ее расматривать не будем. Это была теория, а теперь приступим к практике.
Итак, чтобы скрыть твой номер от чужого АОНа тебе понадобится АНТИ-АОН(логично да? :) Принцип действия классического АНТИ-АОНа состоит в замыкании-размыкании линии с определенной частотой(от 3 до 13 Гц), что делает невозможным отправку "ответа" твоей АТС. Естественно если нет ответа то нет и определившегося номера, хотя многие современные АТС сами без всяких запросов выдают ответ(проверить свою АТС на это просто - звонишь приятелю и спрашиваешь не слышал ли он при поднятии трубки мелодичного пиликанья, если он говорит что слышал, то считай что тебе не повезло :) Вобщем юзая при правильной настройке такой АНТИ-АОН можно спать спокойно, но иногда хочеться прикольнуться и заслать на АОН чужой номер - надо всего лишь сэмулировать ответ твоей АТС и заслать его в линию. В инете валяется множество програм которые этим занимаются - некоторые позволяют выдавать пакеты прямо в линию через модем(например АНТИ-АОН 2.5), другие же умеют писать ответ в wav-файл. Последние может даже и лучше т.к. достаточно сразу после набора номера поднести трубку к динамику.


АонVSАнтиАон

Одним из самых древних способов защиты от определения АОНом твоего номера является АнтиАОН. Здесь ты сможешь прочитать про методы определения твоего номера, а также о том, как сделать твой номер абсолютно нераспознаваемым.

Способ № 1.

Итак, нам понадобятся:

1.) Модем Courier, так как данная ниже строка инициализации работает только на них.

2.) Желание

Вот вроде и все. Теперь заходим в “Удаленный доступ к сети”, далее в настройках соединения, дополнительных параметрах, в строкеинициализациипишешьследующуюкомбинацию:at&f1+s1=0s8=1 (at&f1 – делает параметры модема согласно шаблону f1, s8=1 – задает паузу между набором цифр, в данном случае 1, s1=0 – считает и запоминает количество звонков от входящего вызова).

Затем, в строке, где указывается номер подключения к прову, после каждой цифры ставишь запятую, а после последней цифры номера – две запятых. После этих двух закорючек, ты ставишь шесть нулей. В итоге все должно выглядеть примерно вот так (9,9,5,5,5,5,5,,000000). Кто не знает запятые определяют паузу, так что если у вас что-то не получается попробуйте поэкспериментировать с количеством запятых после номера ПЕРЕД нулями.

Для других типов моделей модификация данной строки авторам неизвестна, так что, если кто-то знает их пришлите нам.

Способ № 2.

Техническое описание.
Система защиты от определения телефонного номера (антиАОН) обеспечивает защиту Вашего номера от определения абонентом при использовании им системы АОН любого типа.
Данную систему можно использовать как встроенной в телефонный аппарат, так и в виде отдельной приставки к телефонному аппарату.
Система защиты от определения номера обладает следующими техническими характеристиками:

количество режимов работы...2

вероятность защиты от определения номера при правильном использовании системы...95%

вероятность полного "ослепления" аппаратуры АОН (без тональной посылки)...55%

время работы, с...10-60

напряжение питания, В...4,9-5,3

потребляемая мощность, мВт...не более 200

температура окружающей среды, град. C...-5 +30

Система построена на базе логического комплекта серии SN7440. Основой является задающий генератор, настроенный на частоту 12.626262 Гц.
Вторым функциональным узлом является усилительный каскад, собранный на транзисторе 2N2904, усиливающий импульсы тактового генератора, необходимые для работы третьего функционального узла - исполнительной части.
Исполнительная часть представляет собой реле типа РЭС64А, паспорт РС4.569.724.

Принцип работы антиАОНа.

Работа системы защиты основана на воздействии на тракт приема информации систем АОН, обходя блокировку голосового тракта вызывающего абонента и невозможностью передачи по ней каких-либо цифровых или аналоговых сигналов во время передачи информации о его номере. Осуществляется это путем передачи на станцию нетональной информации посредством замыкания линии с частотой 12.626262 Гц. (замыкает телефонную линию с частотой 13 раз в секунду)
Инструкция по эксплуатации.
Конструктивно система защиты выполнена в виде отдельного модуля, залитого эпоксидной смолой для предохранения радиодеталей от внешнего воздействия.
При правильном включении антиАОНа и нажатии на кнопку вы услышите характерное тихое потрескивание с частотой около 13 Гц, что свидетельствует о нормальной работе устройства. При отпущенной кнопке и поднятой трубке телефонного аппарата в трубке должен быть слышен длинный гудок.
При работе с антиАОНом выполняются следующие действия: набирается нужный вам номер и после соединения линии нажимается кнопка антиАОНа и держится приблизительно от 10 до 60 секунд; если же после отпускания кнопки в трубке слышно, что станция начинает слать вашему абоненту тональную посылку, то следует еще на некоторое время нажать кнопку.
Настройка схемы.
Имеется расхожее мнение о том, что правильно собранная цифровая система отладки не требует и начинает работать сразу; тем не менее при наличии в схеме хотя бы одной неисправности задача поиска и локализации ее становится практически неразрешимой без применения специализированных систем.
Настройка начинается с проверки значений питающего напряжения, которое должно находиться в пределах от 4.9 до 5.3 вольт. Затем необходимо добиться частоты задающего генератора, собранного на логических элементах: DD1.1, DD1.2, DD2.1, конденсаторе C1, резисторе R1, равной 12.626262 Гц. После этого подключают транзистор VT1, резистор R2, служащий для более стабильной работы реле, и реле K1 и проверяют работу всего устройства в целом: при нажатии на кнопку должно происходить срабатывание реле с частотой 12.626262 Гц.
При нормальной работе антиАОНа его можно подключать к телефонной сети.

Примечание.

1. При замене радиодеталей зарубежного производства их советскими аналогами не гарантируется надежная работа системы и соответствие всем вышеперечисленным параметрам при работе с АОН любого типа.
2. Возможно изменения схемы задающего генератора с использованием других логических элементов: микросхем типа SN7420, SN7400, SN7422, а также генератора, стабилизированного кварцевым резонатором.
Принципиальная схема антиАОНа.

Данная схема может работать без внешнего источника питания. Реле К1-РЭС10, конденсатор C1 определяет частоту срабатывания реле (частоту импульсов АнтиАОН) его номинал около 47мF.

Эта схема представляет собой мультивибратор, собранный на транзисторах VT1 и VT2 — КТ361Г, резисторы R1 — 200 Ом, R2 — 20 кОм R3 — 6.8 кОм, конденсаторы С1, С2 — 47mF, реле K1 — РЭС64А.

P.S. IMHO лучше использовать данные АнтиАОНы, схемы которых были приведены выше, так как это дает более надежную защиту по сравнению с программными. Также можно купить данное чудо на Митинском рынке, хотя это и не дает гарантию, так что тест, тест, и еще раз тест. Если кто-то подумает, что это все слишком сложно или занудно, то я их разочарую, нет ничего важнее собственной безопасности, а друзей, у которых руки под паяльник из нужного места растут – полно.


УК

Статья 272. НЕПРАВОМЕРНЫЙ ДОСТУП К КОМПЬЮТЕРНОЙ ИНФОРМАЦИИ

1. Неправомерный доступ к охраняемой законом компьютерной информации, то есть информации на машинном носителе, в электронно-вычислительной машине (ЭВМ), системе ЭВМ или их сети, если это деяние повлекло уничтожение, блокирование, модификацию либо копирование информации, нарушение работы ЭВМ, системы ЭВМ или их сети, - наказывается штрафом в размере от двухсот до пятисот минимальных размеров оплаты труда или в размере заработной платы или иного дохода осужденного за период от двух до пяти месяцев, либо исправительными работами на срок от шести месяцев до одного года, либо лишением свободы на срок до двух лет.

То есть, если ты не напортачил, не уничтожил данные и не скопировал их себе (нет доказательств-их копий у тебя на дисках), то ты чист. Так что если что-то копируешь, то всегда стирай то, что уже тебе не нужно (иногда FORMAT C: бессилен) параноидально прячь то, что нужно (на флопиках, матрицах и бумажках, но не у себя в квартире, а у соседа, друга или ... врага :))).

2. То же деяние, совершенное группой лиц по предварительному сговору или организованной группой либо лицом с использованием своего служебного положения, а равно имеющим доступ к ЭВМ, системе ЭВМ или их сети, - наказывается штрафом в размере от пятисот до восьмисот минимальных размеров оплаты труда или в размере заработной платы или иного дохода осужденного за период от пяти до восьми месяцев, либо исправительными работами на срок от одного года до двух лет, либо арестом на срок от трех до шести месяцев, либо лишением свободы на срок до пяти лет.

Вывод: Даже если тебя прищучили, и есть все улики и доказательства и в отказ ты идти уже не можешь, то бери на себя всю вину сам. Не верь наглым россказням ментов что, если ты скажешь, кто еще с тобой это совершил, то тебя отпустят, не будут бить и т.д. Отпускать тебя никто не станет - это их хлеб, премии и т.д. Насчет "бить" - уж пусть лучше из тебя сделают котлету, нежели ты сядешь вообще, сядешь на срок вдвое больший и подставишь своих корешей-подельников, которые тебе вряд ли за это будут благодарны.

Статья 273. СОЗДАНИЕ, ИСПОЛЬЗОВАНИЕ И РАСПРОСТРАНЕНИЕ ВРЕДОНОСНЫХ ПРОГРАММ ДЛЯ ЭВМ.

1. Создание программ для ЭВМ или внесение изменений в существующие программы, заведомо приводящих к несанкционированному уничтожению, блокированию, модификации либо копированию информации, нарушению работы ЭВМ, системы ЭВМ или их сети, а равно использование либо распространение таких программ или машинных носителей с такими программами - наказываются лишением свободы на срок до трех лет со штрафом в размере от двухсот до пятисот минимальных размеров оплаты труда или в размере заработной платы или иного дохода осужденного за период от двух до пяти месяцев.

2. Те же деяния, повлекшие по неосторожности тяжкие последствия, - наказываются лишением свободы на срок от трех до семи лет.

То есть, если ты закинул трояна кому-то в комп и этот вирь шлет инфу и пароли юзера тебе на мыло, то, прежде чем сделать такую гадость, 1000 раз подумай над ответом на следующие вопросы:

- ты регистрировал тот почтовый ящик на свои реальные имя и фамилию?

- ты регистрировал тот почтовый ящик через прокси, их цепочку, сокспрокси или же от своего реального АйПи?

- если ты юзал прокси, то был ли он НЕпрозрачен? Проверял ли ты его на НЕпрозрачность?

- Как ты забираешь отчеты трояна с того ящика? (из интернет-кафе - минимум опасности; из канализационного люка, приконнектившись ноутбуком к случайно выбранной из тысячи телефонной "лапше" какой-либо из квартир; через кучу прокси; от друга; из своей квартиры - максимум опасности).

- оставил ты в том вире или на компе юзера какие-либо следы?

- ты был уверен, что юзер не юзал файрвол, ведущий лог, в котором зафиксирована твоя троян-атака?

- сам ли ты писал вирь и были ли у тебя ЗЛЫЕ умыслы, побудившие тебя, его написать или использовать? Обычно состав преступления упирается в то, был ли умысел. Нет умысла - нет и состава преступления. Т.е. если ты закинул кому-то вируса, заведомо зная, что он безвреден, а все его действия сводятся к тому, что он рисует цветочек на экране с надписью "С любовью, Борис!", или же, закидывая виря ты не подозревал что ты делаешь такое и насколько это нехорошо - в этих случаях как бы злого умысла нет. Но тут есть одно "НО"... Оно заключается в том, а поверят ли тебе прокурор и судьи? Если ты считаешь, что все законники лохи, то я вынужден тебя разочаровать. Все они либо умные, либо хитрые, либо два в одном :)

Статья 274. НАРУШЕНИЕ ПРАВИЛ ЭКСПЛУАТАЦИИ ЭВМ, СИСТЕМЫ ЭВМ ИЛИ ИХ СЕТИ.

1. Нарушение правил эксплуатации ЭВМ, системы ЭВМ или их сети лицом, имеющим доступ к ЭВМ, системе ЭВМ или их сети, повлекшее уничтожение, блокирование или модификацию охраняемой законом информации ЭВМ, если это деяние причинило существенный вред, - наказывается лишением права занимать определенные должности или заниматься определенной деятельностью, на срок до пяти лет, либо обязательными работами на срок от ста восьмидесяти до двухсот сорока часов, либо ограничением свободы на срок до двух лет.

2. То же деяние, повлекшее по неосторожности тяжкие последствия, - наказывается лишением свободы на срок до четырех лет.

Нда, уж очень размывчато. "Блокирование" - т.е. ты просто всего-навсего вломился в чью-то аську, поменял пароль юзера на свой, таким образом, что юзер больше не может свою асю юзать (ну не обязательно УИНы и аська, например мейлбокс тоже подходит, да много всего подходит - рутовский пароль, например), то ты, заблокировал информацию, охраняемую законом. "Модификация" - сюда приплести они могут все что угодно... ВСЕ - например ты влез в мыльницу юзера и, не меняя его пароля на свой, всего лишь изменил его имя, введенное им при регистрации с Николай Кольцов на Василий Пупкин. Юзер как и прежде может юзать свой почтовый ящик, но, заметь он изменение имени - это уже предпосылка о заведении уголовного дела. Также, лазив по чьему-то компу, ты заменил атрибут какого-нибудь наигалимейшего файла на компе юзера с "скрытый" на "нескрытый архивный" например. По сути вреда мало, но под статью деяние попадает. А "нарушение эксплуатации" - это может быть всего лишь факт использования тобой всяких сканеров портов, CGI-дыр, даже галимых нюкеров и флудеров. Ах да, вывод... А вывод таков: подумай, насколько важно тебе то, что ты делаешь, и важнее ли оно свободы? Ну и подумай про степень риска.


История

Ну, вот и все вышла вторая часть хелпа, так что радуйтесь и читайте. Как обычно была перелопачена гора информации, добывались статьи с разных уголков Интернета, выслушивалась конструктивная критика, и многое другое.

Ну так вот Хистори:

V 2.0 – Добавлена информация по:

- мультилогинам и троянам (спасибо re14)

- также добавлен пункт в раздел идея (про Триллиан)

- подробно описан язык скриптов

- добавлено описания ряда различных файрволов

- описание принципа АОНа и АнтиАОНа

- также внес комментарии к УК

- шнифферам

- получения халявной СИТЫ

- инфа про прокси (сенкс to Igorek)

V 1.0 – Первый релиз по многочисленным просьбам.


Авторы

Идею данного хелпа подал Igorek, программная реализация Gamer. Был собран и переработан огромный материал по данной теме, использованы примеры из личного опыта. Огромное спасибо p!ro и re14 за их вклад в наш проект.

На данный момент у авторов есть последние версии всех программ, так что если вы не нашли то что нужно, то ищите нас на форуме Игорька http://bestfilez.r2.ru/cgi-bin/ikonboard/ikonboard.cgi или сайта www.daphouse.com В дальнейшем хелп будет дополнятся различной полезной информацией по данной теме. Так что если вам есть чем поделиться, то найдите нас и передайте ваши статьи, они будут опубликованы естественно с указанием авторских прав.

Gamer&Igorek&re14 Corporation - 2002 - spring


Безопасность

Теперь поговорим о безопасности.

Для начала ПРЕДУПРЕЖДЕНИЕ: НЕ ПОПАДИСЬ !!! Если ты «украл» у человека пароли от инета, то не удаляй, не редактируй важную информацию на компьютере пользователя. Этим ты можешь себя обнаружить. И если у человека пропадет очень важная информация, а ты еще будешь пользоваться его интернетом, то есть возможность того, что он узнает твой номер телефона и тогда у тебя будут огромные проблемы. Так что усвой первое правило - ты в безопасности пока тебя не обнаружили.

Второе правило - чисти логи, у тебя в квартире не должно быть листков, дискет, и другой информации о других пользователях (логины, пароли, счета, номера кредиток). Всю информацию либо запоминай, либо не используй, так как из-за одной такой бумажки тебе могут дать срок. Про АнтиАОН знают все, но он не у всех работает, так что это проблема каждого, кто использует халявный инет. Статей на эту тему много, так что представляю вам возможность разобраться с этим самим. Повторяю - это необходимость для каждого хакера использующего халявный инет.

При проверке состояния счета лучше всего заходить через proxy, так безопаснее. И не бросайтесь использовать интернет сразу же. Так как если вы измените пароль, чтобы получить полный контроль над аккаунтом пользователя, то его могут восстановить, и когда он в логах увидит ваш телефон (при отсутствии АнтиАОНа) вам не поздоровиться. Так что каждый логин выставляйте в « отстойник » на 7-8 дней, и если после этого срока пароль не изменился, и никаких движений на счету не было, то смело можете его использовать.

Для полной безопасности сделайте у себя на винте зашифрованный диск. Используйте программу PGP 7.03 HF2 (www.pgpi.com), или лучше BestCrypt 7.06.1 (www .jetico.com) + дополнительный модуль шифрования blowfish-448. Как создать этот диск читайте Help. Скидывай туда любые файлы, от сканнеров безопасности, до украденных PWL. Устанавливайте пароль минимум 40 символов, также не храните пароли в Windows звонилке (которая и создаёт эти файлы PWL), так как их можно восстановить, используйте программы для дозвона, которые хранят пароли в себе. Также не давайте пароли своим друзьям, знакомым, родственникам. Ведь если они попадутся, то выйти на вас не составит проблем. Еще после каждого сеанса удаляй информацию о соединениях из реестра: HKEY_CURRENT_USER>RemoteAccess>Profile- информация о логине соединения, HKEY_CURRENT_USER>NETwork>Recept - информация о подключённых рессурсах в интернет. Это минимальная необходимость. Без данных действий даже не пытайтесь использовать халявный интернет.

Также будьте готовы, в один прекрасный день вам могут позвонить, и потребовать деньги за использованный интернет. Во-первых не следует паниковать, во-вторых сразу же удалите все pwl файлы, при помощи утилиты PGPWipe или BCWipe и им подобных, сканнеры, и другие хакерские утилиты.

Если же к вам пришли менты, то все отрицайте, и заранее сделайте на линии следы постороннего подключения. Это даст вам шанс «выйти сухим из воды».

А теперь подумайте. Еще раз подумайте, а оно вам надо. Мне кажется проще объяснить родителям, что вам и им грозит, если они пожалеют 15-50$ на интернет. Ведь эта нормальная плата за спокойный сон и безоблачное будущее.


Идея

Ну вот, все необходимые знания есть, так что в этой части на самом деле нужды нет. Если же идея так и не родилась, читаем дальше.

Стратегия

Итак, задача получения доступа в инет за чужой счет сводится к получению логина/пароля провайдера, что дает dial-up доступ. Логин/пароль, если не рассматривать очень доверчивых пользователей, можно получать двумя способами - перехватывать при вводе и добывать из парольного кэша. Содержимое парольного кэша можно, опять же, получить достав сам кэш (методами социальной инженерии, с помощью трояна или же через общие ресурсы) либо выпросив его содержимое у системы (при наличии физического доступа или опять же с помощью трояна). Подробно я остановлюсь на методах, использующих любезно предоставленный пользователями доступ к общим ресурсам.

Возможная тактика.

Самый простой способ - просканировать подсеть определенного провайдера, чтобы найти те самые 3-5% пользователей, при этом автоматически известно логин/пароль какого провайдера получен. Схема действий при этом выглядит следующим образом:

  • выбираем в своем городе какого-нибудь провайдера;
  • с помощью сервиса whois или из других источников (www.google.com ) узнаем диапазон принадлежащих ему ip;
  • сканируем весь либо часть диапазона с помощью сканера общих ресурсов, находим пользователей с открытым диском C:. Пароль, естественно, существенной преградой не является;
  • сливаем файлы *.pwl и system.ini на случай, если имя пользователя превышает 8 символов (Не тратьте время на копирование и просмотр файлов Rna.pwl . В этом файле вы ничего не найдёте, кроме параметров модема. И ещё нам не нужны файлы .pwl размером меньше 720 байт. Потому что в них нету паролей. От 688 до 719 байт это файлы pwl тех юзеров, которые не ставят галочку в окошке "запомнить пароль")
  • расшифровываем кэш и получаем требуемые логины/пароли.
  • ищем файл tree.dat из пакета программы CuteFTP 4.x В данном файле хранятся пароли от тех сайтов к которым пользователь имеет доступ через данную программу (расшифровывается программой PwlTool 6.5x)
  • также ищем папку ICQ/200хb. В данной папке хранятся файлы *.dat, из которых ты можешь достать пароли к UIN`ам данного пользователя. (расшифровывается программой ICQr Information v1.5 или Advanced ICQ Password Recovery (вторая работает быстрее))
  • еще если у жертвы стоит Trillian 0.725, то взяв из папки Trillian\users\default любой из файлов *.ini и заменив им файл в своей папке, то можно подконнектиться под его логином без авторизации.

Вариант тактики.

Если обнаруженый диск открыт на запись, то машину можно заразить трояном который, например, отсылает пароли по почте. Эта вариация работает в меньшем числе случаев, но действует наверняка - не требуется расшифровывать pwl, это проделает Windows.

Нестандартные звонилки.

Также некоторые пользователи используют нестандартные звонилки, например Edialer, так что стоит интересоваться их конфигурационными файлами. Тот же Edialer хранит логины и пароли в файле Edialer.ini в зашифрованом виде, но алгоритм шифрования прост до безобразия: например, пароль 11111 в закодированом виде выглядит как 12345. Многие звонилки cами расшифруют пароль и покажут его, правда, в виде звездочек.


мЮВЮКН

Путешествуя по Интернету, мы очень часто наталкивались на мольбы пользователей дать им халявного интернета. Цель данного хелпа – показать как «хакеры» используют различные бреши в продукции компании Майкрософт с целью получения «бесплатного» интеренета, а также научиться защищаться от данного вида атак.


Пароли

 Как же обезопасить свой аккаунт от похищения? Есть несколько несложных правил, соблюдая которые можно быть уверенным, что пароли не будут похищены:
  1. Никогда не делать общедоступными целые диски или системные папки, даже только на чтение и под паролем. Все расшареные папки делать доступными только для чтения, если необходимо сделать возможным закачивать файлы на машину, то нужно разрешить полный доступ к отдельной пустой папке, например Incoming.
  2. В Windows 98 никогда не включать удаленное администрирование.
  3. Отключить парольный кэш. Для этого надо найти ключ
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Network
    и изменить параметр DisablePwdCaching с 0 на 1, если не существует - создать (он имеет тип DWORD или Binary в терминологии Norton Regedit).
  4. Все исполняемые файлы и архивы, скачиваемые из интернета, а также все файлы, приходящие по почте проверять на наличие вирусов. Это защитит от всевозможных троянов.
  5. Придумывать сложные пароли, содержащие прописные и строчные буквы, цифры, прочие символы, длиной не менее 8 символов. Это сделает невозможным подбор.
  6. Не предоставлять всем подряд физический доступ к компьютеру.


Igiagaiiu

Программы упоминаемые в хелпе:

http://www.nerf.f2s.com/files/pwl-grab.rar - программа pwl-grab

ftp://ftp.languard.com/lannetscan.exe - программа LANguard Network Scanner

http://obmen.hypermart.net/obmen/srscanner63.zip - программа Shared Resource Scanner

http://obmen.hypermart.net/obmen/srs6_3cr.zip - кряк к вышеуказанной программе

ftp://daphouse:com@212.20.30.136/nettools3.rar - программа Essential Net Tools

http://lastbit.com/getprg.asp?id=pwltool - программа PWLTool

http://hex.warp0.com/Pwld65.exe - кряк к программе PWLTool

http://www.hex.warp0.com/Guest.zip

http://www.hex.warp0.com/Sharez2031.exe - кряк к программе xSharez

http://www.hex.warp0.com/Sharez.zip - то же самое , только к предыдущим версиям

http://www.tools-for.net/load.php?file=xsharez - программа xSharez

http://www.tools-for.net/load.php?file=xintruder - программа xIntruder - дополнение к программе xSharez

http://hex.warp0.com/toolpwl6.zip


рЕНПХЪ

 Как известно, знание - главное оружие хакера, вот его получением мы и займемся.

Историческая справка.

Все началось в 1985 году, когда Microsoft выпустил первую версию Windows, тогда еще оболочки для DOS. Никто и представить не мог, что всего через 15 лет два из трех компьютеров, если не больше, будут работать под управлением OS Windows. Система задумывалась как максимально дружественная к пользователю, что называется 'для домохозяек'. Эта доктрина сохраняется во всей серии Windows 95/95OSR2/98/98SE/ME, где все сделано для того, чтобы пользователю было максимально удобно работать. Безопасность была принесена в жертву удобству и простоте. Потом конечно была NT c гораздо более серьезной защитой и разделением доступа к файлам, но зачем домохозяйке такие сложности? Забота о пользователях в сумме с небрежной реализацией механизма аутентификации дает многим и многим любителям халявного интернета возможность получить желаемое, неграмотным пользователям шанс потерять некоторое количество денег, а армии врачей-практологов дополнительную работу в лице провайдеров.

Пользователи и пароли.

Самый ненадежный элемент в любой системе - это человек. Особенно если этот человек слабо разбирается в компьютерах и не задумывается о безопасности своей системы, если для него вообще существует такое понятие. Большинство пользователей не понимает, что пароль есть средство защиты. Средний пользователь имеет очень плохую память или просто боится забыть пароль, поэтому вводит что-нибудь легко запоминающееся, вроде 12345, qwerty, gfhjkm, password, имя любимой кошечки, девушки :) , свой же логин, а если воможно, то вообще не вводит. Чтобы, опять же, не забыть десяток паролей, введенных в разных местах, средний пользователь имеет один единственный пароль на все случаи жизни. Иногда средний пользватель все же имеет много паролей, причем хорошей сложности, но, чтобы не забыть, хранит их в текстовом файле. 'Пароль среднего пользователя' подбирается без особого труда. Только не надо спешно менять все пароли, ведь перебор - не единственный способ их получения. В последней части содержатся рекомендации по повышению уровня безопасности системы. Грамотно же составленный пароль, включающий строчные и прописные буквы, цифры, прочие печатные символы можно подбирать многие тысячи лет и не добиться результата. Это связано с очень быстрым ростом количества паролей, имеющих заданное число символов. Например, односимвольных паролей из маленьких английских букв существует ровно 26, двусимвольных - 676, восьмисимвольных - чуть больше 200 миллиардов, с такой же скоростью возрастает и время перебора методом 'грубой силы'. При скорости 50000 паролей в секунду (подбор пароля к парольному кэшу Windows на Pentium-200) времена перебора получаются следующие:

Длина пароля | 26 [a..z] | 36 [a..z]+[0..9] | 70 (все отображаемые)
4 | instantly | instantly | 8 minutes
5 | 4 minutes | 20 minutes | 9 hours
6 | 100 minutes | 12 hours | 27 days
7 | 45 hours | 18 days | 5 years
8 | 24 days | 21 months | 371 years
9 | 48 days | 65 years | 26,000 years

Очевидно, что время перебора обратно пропорционально тактовой частоте процессора, т.е. обратно пропорционально скорости перебора, так что даже на полуторагигагерцовом процессоре эти числа не уменьшатся до нескольких часов. Из этих соображений следует, что перебор стоит начать со словаря, составленного из стандартных паролей, а затем уже переходить к методу грубой силы. Самый простой пароль - общеупотребительное английское слово (love, sex, secret, god :)), самый сложный - случайный набор символов ( f1gH@Eb{ ).

Парольный кэш Windows.

Чтобы помочь несчастным пользователям со слабой памятью Microsoft придумал парольный кэш - систему сохранения паролей. В кэше служба удаленного доступа (Remote Access Service) сохраняет логины и пароли телефонных соединений, Windows - пароли для доступа к общим ресурсам и много чего еще. Все это богатство хранится в зашифрованном виде в файлах C:\%WINDIR%\*.pwl, где имя файла получается из имени пользователя укорачиванием до восьми символов и, при наличии нехороших символов вроде пробела, еще некоторыми преобразованиями. В любом случае, соответствие имя пользователя - имя парольного файла хранится в файле system.ini. Размер пустого парольного кэша 688 байт. Шифрование происходит алгоритмами MD5 и RC4. В Windows 95 OSR1 шифрование было организовано небрежно, что позволяло извлекать содержимое, не зная пароля, за сотые доли секунды (программа Glide). В остальных версиях для дешифровки нужно знать пароль и полное имя пользователя. Здесь на сцену со всеми вытекающими последствиями вламывается 'пароль среднего пользователя'. Используя соответствующие инструменты (например, RePWL или мой любимый PWLHack) можно попытаться подобрать пароль, но если пользователь окажется не средним, то процесс перебора может занять значительное время, измеряемое даже не годами, а сотнями и тысячами лет. При наличии физического доступа к компьютеру задача расшифровки кэша становится тривиальной - после того, как требуемый пользователь залогинился в систему достаточно запустить программу, запрашивающую кэшированые пароли у самой системы, например, Phone Book Viewer, который AVP обзывает Trojan.PSW.Hackof. Подробнее на эту тему можно почитать по адресу http://www.passwords.ru/.

А как же телефоны?

В парольном кэше Windows можно найти пару логин/пароль провайдера, но где же телефон? Microsoft предусмотрел и это. Windows хранит настройки соединений, включая телефоны, которые отображаются в папке 'Удаленный доступ к сети', как и другую личную информацию пользователя,вроде паролей Outlook в реестре, секция
HKEY_CURRENT_USER\RemoteAccess\Addresses.
Содержимое же ключа HKEY_CURRENT_USER физически хранится по адресу %WINDIR%\user.dat, правда не в текстовом виде. Файл user.dat может занимать от 100Kb до 2Mb. Извлечь значение ключа позволяет стандартная программа regedit, запущенная в режиме эмуляции ms-dos. Например, команда
regedit /R:user.dat /E raccess.reg HKEY_CURRENT_USER\RemoteAccess\Addresses
записывает содержимое секции HKEY_CURRENT_USER\RemoteAccess\Addresses в файл raccess.reg. Его содержимое будет иметь вид
REGEDIT4

[HKEY_CURRENT_USER\RemoteAccess\Addresses]
"mtu"=hex:f5,f6,84,86,b3,b4,b4,b4,94,b4,b4,b4,95,b4,b4,b4,b3,b4,b4,b4,98,\
   .........
   b4,b4,b4,b4,b4,b4,b4,b4,a4,b5,b4,b4,b4,b4,b4,b4,b4,b4,b4,b4,b4,b4,b4,b4.
Из этой последовательности байт трудно что-то понять, но этого и не требуется. Достаточно внести содержимое этого файла в реестр и в папке 'Удаленный доступ к сети' появится новый значек.

Общие ресурсы (Shared resources).

Опять же заботясь о пользователях, Microsoft придумала сеть Microsoft (Microsoft Network), которая позволяет пользователю в локальной сети или сети интернет с равным успехом получить доступ к файлам и принтерам компьютера, находящегося в соседней комнате и в хижине вождя племени Зулусов где-нибудь в Африке. Чтобы все это заработало надо установить:
клиент для сетей Microsoft,
службу доступа к файлам и принтерам сетей Microsoft -
и в случае dial-up соединения поставить в его настройках галочку "Войти в сеть". Далее можно как пользоваться чужими ресурсами, так и предоставлять доступ к своим. Есть несколько способов подключиться к чужим ресурсам:
  • набрать ip или сетевое имя во вкладке 'Найти компьютер' и открыть список его общих ресурсов в проводнике, либо командой 'подключить сетевой диск' сделать ресурс удаленной машины доступным как локальный;
  • выполнить одну из команд
    \\<сетевое имя>
    или
    \\<ip адрес>
    при этом в проводнике откроется список общих ресурсов;
  • воспользоваться командой NET - команда вида
    NET VIEW \\<ip адрес>
    либо вида
    NET VIEW \\<сетевое имя>
    покажет список общих ресурсов удаленного компьютера, включая скрытые, а строка вида
    NET USE x: \\<ip адрес>\<имя ресурса>
    или
    NET USE x: \\<сетевое имя>\<имя ресурса>
    смонтирует (mount) ресурс с заданным именем на локальный диск X:.
Иногда Windows постоянно выдает ошибку 'Не найдено сетевое имя', в этом случае нужно помочь системе, добавив в файл lmhosts строку вида
<ip adress> <сетевое имя>       #PRE.
есурсы, имена которых заканчиваются на $ считаются скрытыми и не отображаются в списке общих ресурсов проводника, а также некоторыми сканерами. Кроме определяемых пользователем существуют ресурсы IPC$ (InterProcess Communication), который является служебным и доступа к файлам не предоставляет и ADMIN$ (в Windows 98/NT/2000), который позволяет получить полный доступ к системным ресурсам c$, d$... Делать доступными можно целые диски, отдельные папки и принтеры, доступ к файлам может быть двух типов: только чтение (Read only) и полный (Full) - и, естественно, ограничивается паролем. Эта защита в Windows 95/98/ME, как будет дальше видно, чисто номинальная и защищает только домохозяек от тех же домохозяек. Делает её таковой, опять же, небрежность реализации, а именно: пароль переводится в верхний регистр, усекается до 8 символов и в процессе аутентификации проверяется посимвольно. Первые два пункта еще не смертельны - они просто существенно сокращают пространство возможных паролей, но третий сводит всю защиту на нет, позволяя подбирать пароль за время не превышающее нескольких минут даже при плохой связи. Итак, пользователь вводит пароль и Windows начинает передавать его знаки, один за другим, удаленной машине. Она же, не дождавшись ввода последнего символа начинает сверять введенный пароль с правильным и как только встречает неверный символ отсылает назад сообщение об ошибке. Таким образом, пароль можно подбирать посимвольно, как в фильмах про хакеров, что успешно делают программы типа LANGuard Network Scanner и xIntruder. В Windows NT/2000/XP защита уже не детская: нужно знать кроме пароля еще и логин, так что подбирается только 'пароль среднего пользователя', также есть шанс, что администратор любезно оставил какой-нибудь стандартный аккаунт.

Пользователи и общие ресурсы.

Средний пользователь достаточно ленив и имеет достаточно знаний, чтобы пользоваться таким полезным механизмом как общие ресурсы, но он недостаточно умен, чтобы понять как делать это, не подвергаясь опасности быть обкраденным. Он делает доступным всему миру свой диск С:, с паролем или без, на котором стоит его звонилка, лежит парольный кэш, любимая ася, список паролей, документы... Иногда, чтобы что-то туда закачивать, дает даже полный доступ. По моим личным наблюдениям таких пользователей 3-5%. Для автоматизации обнаружения этих пользователей существуют сканеры, которые опрашивают заданный диапазон ip адресов на предмет общих ресурсов. Например, xSharez, Legion, LANGuard Network Scanner, Essential Nettools.

Сервис whois.

Как известно, у интернета нет владельца, но кто-то все-таки должен устанавливать правила, принимать протоколы и т.д. Этим занимаются некоммерческие организации. RIPE отвечает за распределение ip адресов и имеет огромную базу данных, которая содержит информацию о тех, за кем числятся все распределенные ip адреса. Она содержит название организации, диапазон выделенных ей ip адресов, почтовый адрес организации, ip маршрутизаторов и некоторую информацию о контактных лицах. Эта база данных является публичной, т.е. любой желающий может сделать к ней запрос с помошью програм, работающих по протоколу whois, например, Smart Whois, либо через скрипт, например, по адресу http://www.ripe.net/perl/whois/. Например, для ip 213.180.194.130 (Yandex, www.ya.ru) результат выполнения запроса имеет вид:
inetnum:      213.180.194.0 - 213.180.195.255       - диапазон ip
netname:      COMPTEK-NET2
descr:        CompTek International, inc.           - название организации
descr:        Gubkina st.3, Moscow, Russia          - её адрес
country:      RU
admin-c:      VLI1-RIPE
tech-c:       KBG2-RIPE
status:       ASSIGNED PA
notify:       noc@comptek.ru
mnt-by:       COMPTEK-MNT-RIPE
changed:      wawa@comptek.ru 20001121
source:       RIPE

route:        213.180.192.0/20                      - маршрутизатор
descr:        CompTek network / special
origin:       AS13238
notify:       noc@comptek.ru
mnt-by:       COMPTEK-MNT-RIPE
changed:      wawa@comptek.ru 20010123
source:       RIPE

person:       Vladimir L Ivanov                     - контактное лицо
address:      CompTek International, inc.
address:      Gubkina street 3
address:      Moscow
address:      Russia
phone:        +7 095 785 2525
fax-no:       +7 095 785 2526
e-mail:       wawa@comptek.ru
nic-hdl:      VLI1-RIPE
mnt-by:       COMPTEK-MNT-RIPE
changed:      wawa@comptek.ru 19990212
source:       RIPE

Автозагрузка.

Во время загрузки Windows стартует некоторое количество програм, например AVP Monitor, MSOffice Fastload, всякие троянцы, угнездившиеся в системе, ICQ NetDetect... Существует несколько способов заставить программу запускаться при старте Windows. Самый тривиальный - добавить её в группу Автозагрузка (Autorun) в меню 'Пуск'. Как известно, в этом самом меню отображается содержимое папки C:\%WINDIR%\Главное меню\. Этот способ очень прост, но пользователь может легко заметить лишний ярлычёк. Новые программы, как и трояны, в большинстве запускаются из реестра (registry), ключи
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run*,
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run*,
но этот способ в Windows 95/98 нельзя использовать удаленно. Про autoexec.bat и winstart.bat, надеюсь, упоминать не надо. Также можно использовать способ, применявшийся еще в ранних версиях Windows, когда реестр заменяли ini-файлы. Чтобы запускать программу из win.ini, нужно в секцию [Windows] добавить строчку вида
run=<имя файла с путём>.

Борьба со звездочками.

Метод избежать подглядывания пароля при вводе был придуман, видимо, одновременно с самим паролем: на экран вместо вводимых символов либо не выводится ничего, либо все символы заменяются на какой-нибудь один, например ту же '*'. Microsoft не обошел эту меру безопасности своим вниманием - Windows имеет поддержку особых полей ввода, отображающих вместо символов '*'. Обработка введенного пароля, как правило, осуществляется после того, как пользователь сообщит системе, что ввод закончен, например, нажав кнопку Ok. Естественно напрашивается вывод, что когда на экране отображаются звездочки пароль в это время преспокойно хранится в памяти, причем в открытом виде. Само по себе это еще ничего не дает, если бы не привычка некоторых приложений отображать в полях такого типа ранее сохраненные пароли, давая пользователю возможность изменить ввод налету. Таким образом приложение само расшифровывает пароль, остается только прочитать его, с чем успешно справляются программы типа OpenPass или Behind The Asterisks.

Мультилогины.

В природе существует такое понятие как мультилогины. Это такие логины, по которому может сидеть одновременно несколько людей. Некотрые провайдеры предоставляют такую услугу. Владельцу они обходятся в кругленькую сумму, но вам оно не все равно? Так как же определить мульти он или нет.

Первый признак это то, что вы в любое время спокойно заходите в сеть. Иногда, когда вы пытаетесь зайти не по мультилогину после проверки логина может появиться окошко вход в сеть, где windows предложит вам ввести логин и пароль( В XP это будет ошибка 691) Это характерный признак того, что к сожалению логин не является мульти. Так же это может просто означать, что логин уже не рабочий.

Признак второй. Во время того, как вы сидите в сети. Попробуйте попинговать человека, у которого вы добыли своим трудом логин, естественно это на случай если он имеет статистический ип. А если нет, то просто попробуйте посканить сеть на имя компьютера с

которого был добыт аккаунт . Вы ведь его запомнили? ;-) Ну, вот, пожалуй, и все.