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Sequence of Programming Steps for PartMaker Mill 
 

1. Complete the Setup dialog to determine the stock, table type and part boundaries you 
will be working with. 

2. Create geometry in CAD mode or choose the Import command from the File menu if 
you want to import geometry from a CAD system in either a 2D or 3D Solid Model 
Format. Working with a Solid Model may allow your part boundaries to be determined 
automatically. 

 Note: To enter CAD Mode click the CAD/CAM switch at the bottom left hand 
corner of the screen. 

The CAD/CAM switch appears as 
 

in CAM Mode and as 
 

in CAD Mode. 

3. Choose the Tools command from the ToolMinder menu to add new tools.  

4. Choose the Cycles command from the ToolMinder menu to add new cycles.  

5. Choose the Open Material File command from the File menu to open a material file 
from the Material directory. 

6. Choose the Defaults command from the Job Optimizer menu to set up your defaults. 

7. Switch back to CAM Mode clicking the CAD/CAM switch. 

8. Choose New Hole Group from the Part Features menu to add a new hole group.  

9. Specify hole locations using the following icons: 

 
Single Hole Icon 

 
Chain Circle Icon 

 
Hole Pattern Icon 

10. Choose New Profile Group  (or New Surface Group  if performing 3D 
Surface Machining) from the Part Features menu to define a new profile group. 

11. Create profiles using the following icons: 

 
Define Profile Icon 

 
Chain Geometry Icon 

 
2-Point Chain Icon 

12. Repeat steps 8 through 11 to create groups of all part features required for the job.  

13. Choose Post Config File=? command from the Job Optimizer menu and select the 
desired post configuration file.  

14. Choose the Generate Process Table command from the Job Optimizer menu to 
generate a process table.  

15. Choose Simulation from the Simulation menu to watch the part cut in 3D.  

16. Choose the Generate NC Program command from the Job Optimizer menu to 
generate an NC Program. 
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Important User Notices  
 
Copyright 1991-2014 Delcam Ltd. All rights reserved.  
 
Delcam Ltd has no control over the use made of the software described in this 
manual and cannot accept responsibility for any loss or damage howsoever 
caused as a result of using the software. Users are advised that all the results 
from the software should be checked by a competent person, in accordance 
with good quality control procedures.  
 
The functionality and user interface in this manual is subject to change without 
notice in future revisions of software.  
 
The software described in this manual is furnished under licence agreement and 
may be used or copied solely in accordance with the terms of such licence.  
Delcam Ltd grants permission for licensed users to print copies of this manual or 
portions of this manual for personal use only. Schools, colleges and universities 
that are licensed to use the software may make copies of this manual or 
portions of this manual for students currently registered for classes where the 
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Introduction  
Using CAM Software to Program NC Machines  

The invention of NC (Numerically Controlled) machines has revolutionized the metal 
cutting industry. Computer controlled machine tools are faster, have a higher 
degree of accuracy and repeatability. 

NC machines can be programmed manually, which means typing machine 
"language" motion and other instructions into a computer text file. Such a file, 
called a part program, is then loaded into the NC machine memory for execution.    

The following are the major deficiencies of manual programming:  

 The languages of NC machines are cumbersome for humans and require a 
long learning curve. 

 Geometric calculations must be performed to determine coordinates of points 
comprising the tool path. 

 Typing is a time consuming process. 

 The absence of adequate methods to prove out the program results in tools 
breakage and material waste. 

Since the earliest days of computer technology a significant effort has gone into 
automation of the programming process by utilizing CAM (Computer Aided 
Manufacturing) Software. CAM systems accept user input in an interactive manner 
and generate a part program file automatically. CAM Systems provide assistance in 
tool path calculations and verification. The overall improvement in productivity 
resulting from a use of a particular CAM System depends on how long it takes to 
learn the software, how easy it is to use, and how much information a user has to 
enter during each programming session.  

How PartMaker Improves Productivity 
PartMaker relieves you from the tedious process of reentering the same tooling 
and process information over and over again in every program. It captures 
information about how to machine individual part features, namely, holes and 
profiles, and makes it available for future use. It allows shop personnel to benefit 
from the expertise of the most skilled programmer, who enters their knowledge into 
the software. Using PartMaker, your parts can be programmed faster, with higher 
precision and less cost.  

Intuitive Windows GUI Assures Quick Learning 
PartMaker features an intuitive user interface that complies fully with Windows GUI 
(Graphics User Interface) guidelines. The benefits of the Windows environment for a 
PartMaker user include: Context Sensitive Help, pictorial explanation of parameter 
entry, the ability to Cut, Copy and Paste part features and/or geometry, and, most 
importantly, shorter learning time. 
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Tools Data Base Keeps Track of Tool Inventory 
A tools database allows the user to keep track of his current tool inventory. 
Geometric characteristics saved with each tool are used for the automatic 
determination of cutting conditions. The software performs automatic hole depth 
calculations by maintaining through hole clearance and blind hole relief distances for 
each tool. A pictorial representation of each tool in a separate window simplifies the 
entry of tool parameters. Corrective coefficients compensate for tool wear. Special 
fields are reserved for the customer's data, which includes part numbers and 
reordering information among others.  The tool descriptions are kept in a tool file. 
The tools used on different machines may be kept in multiple tool files. 

Cycles Data Base Stores Sequences of Repetitive Operations 
A cycles database allows the user to create and store cycles, sequences of 
repetitive operations such as center drilling, drilling, tapping, boring, reaming, 
chamfering and circular hole milling. The cycles database links directly into the tools 
database. A tool for each operation is selected automatically based on the hole 
diameter. Windows GUI makes creation and modification of cycles a simple task. A 
full description of the tools and operations included in a cycle is shown in one 
window, while the corresponding hole cross-section is shown in another window. 
Studies have indicated that over 70 percent of machine cycle time for an average 
CNC machining center is spent making holes. Therefore, PartMaker pays significant 
attention to holemaking in order to achieve the greatest gain in productivity. Often, 
the same or similar features belong to a group of products that are ordered by the 
same shop's customer. Since cycles may be customer specific, the user has a choice 
of whether or not to store them in multiple cycle files. 

Materials Data Base Facilitates Automatic Feeds and Speeds 
Calculations  
A materials database allows the user to store materials data that is used in the 
automatic calculation of feedrates and spindle speeds. The software comes with an 
extensive materials database, recommending average cutting parameters. Feed rate 
and spindle speed are computed based on tool geometry (size, number of flutes. 
etc.) and machinability data. This data is presented in the form of flexible computer 
charts giving the user full control over the performance of his machine. The charts 
can be quickly modified via a drag and drop screen interaction. Machinability charts 
can be further optimized by automatic curve fitting through points of best 
performance. 

Multi Face Programming Simplifies Machining in Different Planes 
You can program machining operations in different faces (planes) and specify up to 
eight different faces per part. A separate Face Window is associated with each face 
of a part. PartMaker determines the order of machining based on the angle you 
specify for each face from the smallest angle to the largest. You can choose to finish 
all machining operations on one face before proceeding to the next or perform all 
operations with a tool on all faces, then change tools. 
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Optimized Process Plan Generation Saves Programming Time 
Rather than creating a job plan in a conventional sequential manner, the 
programmer describes the placement of groups of part features on the surfaces of a 
machined part.  Once the part features description is entered into the computer, 
PartMaker automatically generates an optimized job plan. The results are 
summarized in a Process Table Window that can be reviewed on the screen or 
printed out. The Process Table lists tools and cutting conditions for each process. 
Feed rates, spindle speeds and cycle time are automatically calculated and 
displayed. The cycle time allows the programmer to quickly estimate the cost of 
machining a part. While reviewing the Process Table, the user can manually modify 
the sequence of processes as well as cutting conditions.  

User Customizable Output Format Eliminates Manual Editing 
When the user is satisfied with the views of the part and its job plan, he proceeds 
with the next step (known as postprocessing) to automatically generate an NC 
program for a designated machine. The part program is optimized, using 
subroutines, to occupy minimum space in the machine tool memory and shorten 
transmission time. PartMaker eliminates the need for manual editing of the 
generated NC program - a well-known obstacle of most CAM systems.  

The ability to generate editing-free programs results in an additional productivity 
gain. It is achieved by giving the user full control over the generated NC program 
format by means of flexible ConfigPost application that allows the user to create 
and save custom postprocessor configuration files for virtually any CNC control. 
ConfigPost uses the familiar Windows interactive environment that enables the 
user to do output customization quickly and easily. 

Verification by Cutting Simulation Catches Programming Errors 
PartMaker is sold bundled with a graphic verifier that reads a part program and 
graphically simulates the entire cutting process utilizing solid modeling techniques.  
This add-in allows the programmer to catch errors before expending machining 
time.  
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About This Guide 
Please read this section to determine which chapters in the PartMaker User Guide 
address your needs. 

Chapter 1 “Getting Started With PartMaker” explains how to get started with 
PartMaker. This chapter includes a description of the hardware and software 
you need to run PartMaker and tells you how to install PartMaker and related 
files.  It also shows you how to access PartMaker on-line context sensitive help. 

  
Chapter 2 “PartMaker Fundamentals” discusses the unique programming approach 

PartMaker employs for programming CNC mills. Concepts covered in this 
chapter include selecting the appropriate Face Window, setting up and working 
with PartMaker’s databases, PartMaker Synchronization modes and material 
control processes, using various PartMaker icons and Snap Modes and 
synchronizing processes being executed simultaneously on the machine.  

  
Chapter 3 “Mill Programming Tutorial” shows you how to create a sample part using 

some of the most popular features of PartMaker. We recommend you go 
through this chapter to familiarize yourself with the PartMaker application. 

  
Chapter 4 “Programming the Advanced Turn-Mill Tutorial Part – Twin Spindle, Twin 

Turret” shows you how to create a part on an 8-axis Turn-Mill Center 
highlighting advanced PartMaker features such as Material Control Processes and 
Process Synchronization.  Recommended to be done after reviewing Chapter 3. 

  
Chapter 5 “PartMaker Simulation” discusses how to use and the functionality of 

PartMaker’s 3-D Simulation module. 

What you will not find in this manual is an explanation of every PartMaker dialog 
and parameter.  For information on specific PartMaker dialogs, use the context 
sensitive help that comes with PartMaker.  This context sensitive help can be found 
by pressing the F1 key on your keyboard. 
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Chapter 1: Getting Started With 
PartMaker 
In Your Package 

 PartMaker CD-ROMs  

 PartMaker Manuals 

 Hardware lock  

You will receive a license file that works with the hardware lock.  For standalone 
licensing the file is called a Product Authorization File (PAF).  For network licensing 
the file is an RMS license file.  Obtaining and installing the PAF file will be discussed 
later in this chapter in the section titled PAF Installation Instructions.  The 
PartMaker Installation guide explains the RMS license file in detail. 

Technical Support 
Please use the following information when you wish to get Technical Support or 
more information about PartMaker’s products: 

Phone:  215-643-5077 

Fax:   215-653-0105  

e-mail:  support@partmaker.com  

Web Site:  http://www.PartMaker.com 

A Customer PIN has also come included with your PartMaker software. 

Before Using PartMaker... 
Before you begin working with PartMaker, you need a basic knowledge of Microsoft 
Windows operations. You should understand mouse techniques such as pointing, 
clicking, double clicking, dragging, choosing menu commands, and making dialog 
selections. If you are unfamiliar with basic Microsoft Windows terms or techniques, 
see your Microsoft Windows documentation for details. 
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System Requirements 
Please read the following sections to determine what you’ll need to get started with 
PartMaker. To use PartMaker, you need a Windows-based PC with the following 
specifications: 

 
PartMaker 
Standard 

Parasolid 
Import Module 

(Solids)* 

Full Machine 
Simulation 

(FMS) 

Advanced 
Surface 

Machining (ASM) 

Processor Pentium 3 800 
MHz or higher 

Pentium 3 800 
MHz or higher 

Pentium 4 3 
GHz or higher 

Intel Core Duo 
processor or higher 

Memory 512 MB or more 1 GB or more 2 GB or more 4 GB or more 

Hard drive 40 GB 40 GB 40 GB 80 GB 

Independent 
video card 128 MB NVIDIA 512 MB NVIDIA 512 MB 

NVIDIA 1 GB NVIDIA 

 

64-bit and 32-bit versions of PartMaker are available and are supported on Windows 
7. Only the 64-bit version of PartMaker is compatible with Windows 8 PCs. 

Please take note that Microsoft has discontinued support for the Windows XP and 
Vista operating systems.  
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Starting PartMaker 
From your desktop, double-click the PartMaker Mill icon. 

A window containing information about PartMaker appears for a few moments. 

 
The PartMaker application window and the Setup dialog are displayed in the Face 
Window. 
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Installing PartMaker 4 & 5-Axis Mill Post Processors 
PartMaker Mill Version 2014 and higher features a unique capability for downloading 
your licensed Mill post processors and related files directly through the software’s 
user interface.  This feature is helpful for both new users installing the software for 
the first time and existing users who wish to update their post processors and 
related files to the most recent “distribution” Post Processors (see below for more 
information on “distribution” versus “non-distribution” post processors). 

Important! You must be connected to the internet to automatically download and 
install your licensed post processors through the PartMaker interface as described 
below. 

Once you have successfully launched the Mill application, you can install the Mill 
post processors that you have licensed directly from the PartMaker user interface. 

To do so: 

1 From the Help menu, choose Download Licensed Post Config Files… 

 
2 You will be presented with the dialog below: 
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3 Check the boxes to the left corresponding to the post processor(s) you wish 
to download as shown below: 

 
4 Once you have selected the items you wish to download, click the 

<Download Selected Posts> button to begin downloading the specified 
items into the directory specified in Step 2 of the Download Licensed Post 
Config Files dialog. Upon doing so, you will see a progress bar showing the 
status of your download. 

5 Once you have successfully downloaded the selected items, you will see the 
Download Status column will indicate “Successful” as shown below. 

 

 If you receive any message other than “Successful” after this process, 
contact PartMaker technical support at support@partmaker.com or your 
local PartMaker support representative (outside North America). 

6 Once you successfully downloaded the requested files, click the <Close> 
button to continue using PartMaker. 



 

1-6 PartMaker  Copyright @2014 Delcam Ltd 

 

What You Have Just Downloaded 
Once you have completed the previous steps, you will have downloaded what are 
known as “distribution post processors,” the library post processor support by 
PartMaker Inc. for particular machine-control combinations.  PartMaker post 
processors are more than just standard post processors that come with a CAM 
system. They are highly engineered, actively supported, routinely maintained and 
well documented machine configuration files to assure you generate accurate NC 
code for your CNC Mill machines utilizing the full capability of your machine tool.  All 
PartMaker post processors are customizable, by you, the user. 

In the process above, you have downloaded much more than just post processors.  
You have downloaded the following items: 

1 The Post Processors your company has licensed – This includes the 
*.pst file. PartMaker defines a post processor as a machine, control 
combination. 

2 Related Simulation Files – PartMaker’s Advanced and Full Machine 
simulation (FMS) modules use additional files to simulate the architecture of 
your machine.  You will need to use the *.MCH corresponding to your post 
processor to view your machine’s working envelope when using Advanced 
Simulation.  If you have licensed FMS, you will need to use the *.FMS and 
*.MCH corresponding to your post processor to view your machine’s working 
envelope when using Full Simulation.  Please see the Chapter 4 of this 
manual for information on using PartMaker’s Advanced and Full Machine 
Simulation modules. Included with these files are PartMaker Job (*.job), 
Tools (*.tdb) and Cycles (*.cdb) files that are configured to run in both 
Advanced and Full Machine Simulation. 

3 Post Processor Related Documentation – Documentation related to your 
licensed post processors and simulation files. 

4 Sample Files – Sample Job (*.job), Tools (*.tdb) and Cycles (*.cdb) files in 
both the inch and metric system corresponding to the tutorials in your 
PartMaker user guide and configured to your machine tool’s specific 
architecture are also provided. 

To see an example, of this, let’s look at the files download in this example: 

1 The picture below shows the result of the download above: 

 Note: PartMaker Mill comes with an extensive library of 3-Axis post 
processors as seen in the image.  

 
2 Double clicking the folder, 0539_DMG_DMU_50___December_3_2014, above 

reveals the following where: 

1 A *.TXT is a readme file explaining changes made in the most recent 
version of the post processor 
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2 The *.pst, the post processor file 

3 A folder containing the simulation, *.MCH and *.FMS referred to above 

4 A folder containing the machine specific addendum and FMS reference kit 
referred to above 

5 A folder containing tutorial files in the inch system corresponding to the 
tutorial in the user guide 

6 A folder containing tutorial files in the metric system corresponding to the 
tutorial in the user guide 

 

 Tip: If using Advanced and/or Full Machine Simulation, placing the *.FMS 
and *.MCH in the same directory as the *.PST file will allow your 
simulation files to open automatically when loading the post processor. 

More on Mill Post Processors 
PartMaker Inc’s application staff maintains a library of well documented well 
supported Mill post processors.  Once you start to customize your own post 
processor using the ConfigPost application, you create a “non-distribution” or ND 
post processor. 

Please also note, PartMaker is constantly updating and improving its post processors 
to add functionality and correct any possible reported errors. You can use the same 
procedure above to check for post processor updates periodically if you are 
experiencing difficulty with your post processor.  Even if you have customized your 
post processor and are using a “non distribution” post processor, you can quickly 
see any differences between your customized “non distribution” post processor and 
the most current “distribution” post processor using the Compare function in 
PartMaker’s ConfigPost application.  See the ConfigPost user guide that came with 
your software for more information on this function. 
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Exiting PartMaker 
1 To exit PartMaker, choose Exit from the File menu. If you changed an open 

job file, a dialog prompts you to save the current job file before exiting. 

 

2 Do one of the following: 

 Click <Yes> to save the changes. 

 If the file is untitled, select a location and enter a file name in the dialog that 
appears, then click <OK>. 

 Click <No> to discard the changes and exit. 

 Click <Cancel> to return to the presentation window without exiting. 

Using On-Line Help 
On-line help provides fast access to information about the application’s tools, 
commands, dialogs, and program features. Help commands are located in the Help 
menu in PartMaker: 

1 Choose Contents from the PartMaker Help menu, click the icon on the 
toolbar or press <F1>. 

The Help window appears, displaying the Main Index (shown on the 
following page). 

 
2 Click an index to view a list of help topics. 

3 Click the topic you want to read about. 

Information about the selected topic appears in the window. 

 Note: Some topic lists include sub-lists from which you can select a help 
topic. 
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4 To return to the last screen you viewed, click the <Back> button. 

5 To search for information, click the <Search> tab. 

6 Type in a key word to choose a topic and click the <List Topics> button. 

7 Click the <Display> button to view the selected topic.  Your help screen will 
appear as below: 

 

8 When you are finished using help, choose Close from the help window’s 
Control menu. 

Using Context-Sensitive Help 
To view context-sensitive help while viewing any PartMaker dialog: 

1 Display any PartMaker dialog. 

2 Press <F1> to display the help topic for the dialog. 

Installing Updates 
PartMaker Version 2010 and higher allows you to update to more recent versions 
and service packs of the software automatically from the PartMaker environment. 
You can check for and download the most recent version of PartMaker by selecting 
Check for PartMaker Updates from the Help menu. 
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Working with Databases 
Databases are where you store tool, material, and cycle information for PartMaker 
jobs. PartMaker uses material, tools, and cycles databases to store the information 
needed for each job. 

Material Database 
A Materials Database allows you to store your shop’s accumulated materials data. 
Materials data is used by PartMaker in the automatic calculation of feedrates and 
spindle speeds. In addition, you can utilize material data in the extensive material 
library provided with PartMaker. 

Turn to Appendix A for a complete list of materials. 

Tools Database 
A Tools Database allows you to keep track of your current tool inventory. PartMaker 
uses geometric and cutting tool characteristics saved with each tool in the database 
for automatic cutting conditions and automatic depth calculation. 

Cycles Database 
PartMaker lets you combine a number of repetitive operations (center drilling, 
drilling, tapping, boring, etc.) into a single entity called a Cycle.  All cycles are saved 
in a Cycles Database. For each cycle operation, you can designate a tool from the 
Tools Database. Once a cycle is created, you can recall it at any time when you 
need to use it again. 

Working with Files 
PartMaker uses different file types for storing tools, cycles, and material 
information as well as your jobs and the postprocessor files used to create NC 
programs for machining. 

 Information about tools in the tool crib is saved in Tools files that have the 
file extension .TDB. 

 Information about material characteristics needed to calculate feedrates and 
spindle speeds is saved in Material files that have the file extension .MDB. 

 Information about user-created machining cycles is saved in Cycles files that 
have the file extension .CDB . 

 Part geometry is saved in Job files that have the file extension .JOB. 

 Postprocessor configuration information is saved in Post Configuration files 
that have the file extension .PST. 
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Chapter 2: PartMaker Fundamentals 
Introduction 

This chapter provides an overview of the PartMaker environment. You will learn 
basic concepts such as how to work in a face window to define part geometry in 
CAD Mode and locations of holes and profiles in CAM mode. 

The Setup Dialog 
Any programming exercise in PartMaker begins with the Setup dialog.   

The Setup dialog is displayed when launching the PartMaker application.  It can also 
be accessed at any time during the use of PartMaker by choosing Setup from the 
View menu.  It can also by accessed by clicking on the short cut to the Setup dialog 
icon in the upper left corner of any PartMaker Face Window. 

The diagram below highlights the various aspects of the Setup dialog. 

 
1 Table: Determines the type of machining table you will be making a part on.  

Choices here are Standard, Tombstone, Rotary 4-axis, Rotary 5-axis 
and Vertical Rotary.  Each of these items will be discussed in detail in the 
pages to follow. 

2 Stock: Determines the type of stock being machined, either a prismatic 
Block or round Cylinder.  Once the setup dialog has been completed, you 
can use PartMaker’s Define Custom Stock Shape command to create a 
custom, user defined stock (see Chapter 5 for information on this feature). 

3 Machining Function: Specifies the machining function to be used with in a 
given Face Window. Options under this drop down menu include Mill XY 
Plane, Mill 4-Axis Plane, Mill 5-Axis Plane, Mill End, Index, Mill End, Polar, Mill 
Polygon, Mill Diam, Index, and Mill Cylinder. The ability to access and 
appearance of each of these items will change depending on the selections 
made for Table and Stock. 



 

2-2 PartMaker  Copyright @2014 Delcam Ltd 

 

4 List of Face Windows: Presents the list of Face Windows created for a 
particular job file. 

5 Rename To: States the name of a given Face Window.  You should give 
each Face Window you are working with an appropriate name based on the 
machining occurring within that Face Window. The number of the left of this 
field determines the order of the Face Window when you have a number of 
Face Windows in a particular job file. 

6 Function Buttons: These buttons allow you to perform the following 
operations in the Setup dialog: 

<New> Creates new face windows of different machining function 
types, adding to the List of Face Windows. 

<Delete> 
Deletes the currently selection from the List of Face Windows. 
This button will only be active when you have more than one 
Face Window and DO NOT have a Process Table generated. 

<Duplicate> 
Allows the user to duplicate a series of identical Mill ZX, ZY 
and Mill XY windows. Only active when one of these Windows 
is selected. 

<User Data> Allows the user view the User Data for a given post processor.  
Only active if a post processor is loaded. 

<Apply> 
Accepts or applies any new parameters or data entered into 
the various fields in the Setup dialog, and the dialog remains 
open. 

<Close> Accepts or applies any new parameters or data entered into 
the various fields in the Setup dialog and closes the dialog. 

7 Notes: Allows you to specify notes about a particular Job or Face Window.  
Depending on the configuration of the post processor you choose, the 
contents of these fields can be output into your NC program.  See the 
ConfigPost User Guide that came with your PartMaker Software for more 
information on post processor configuration. 

Table, Stock and Machining Function Setting 
Whenever starting a programming exercise in PartMaker Mill, the first step is to 
determine the Table type you will be using for a part. You can only set one type of 
Table in a given job file.  The table type chosen in the first Face Window will 
determine the type of machining Table used throughout the job.  It will also 
determine the appearance of the Face Options dialog, which is explained in greater 
detail in the pages to follow.  

Once a job file has been created, the Table type can be changed by changing the 
selection for the Face Window in the list of Face Windows. 

Once you have determined the type of machining Table you will be using in a given 
job, you will proceed to determine the type of Stock being used.  These two 
selections will then determine the types of machining functions available to you. 

The various combinations of Table, Stock and Machining Function types will be 
explained to follow. 
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Table Type: Standard 
Setting the Table Type to Standard assumes you are working on a vertical 
machining center with a flat machining table. This selection should generally be set 
when programming for a vertical machining center and you wish to see the stock 
being machined relative to the machining table.  This Table Type is especially 
helpful when machining multiple pieces in a single setup such as in the picture 
shown below: 
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Settings 
The Settings dialog is accessed for the Table Type: Standard by clicking the 
Settings button.  The Settings dialog is used to define the dimension and 
appearance of the machining table in PartMaker’s 3D machining simulation. 

 

Length (L): Specifies the length along the X axis of the machining table 

Width (W): Specifies the length along the Y axis of the machining table 

Height (H): Specifies the height or thickness of the machining table 

Import From 
Machine File 

Clicking this button allows you to import the parameters of a 
previously created machining table from an *.MCH file which 
saves you from having to define a new machining table for 
every PartMaker JOB file  

Export to 
Machine File 

Clicking this button allows you to export the parameters of a 
specific machining table as an *.MCH file for use with future 
jobs.  Exporting these parameters to a machine file allows 
you to setup a number of different types of machining tables 

Table 
Transparency 

Allows you to set the transparency of the table in PartMaker’s 
3D simulation, 0 being totally opaque, 100 being totally 
transparent  

Table Color Allows you to choose the table color of the machining table 
from the available color pallet 
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Stock 
When the Table is set to Standard, you can choose from two types of stock, Block 
or Cylinder.  The Block selection assumes you are working with prismatic stock, 
while the cylinder selection assumes you are working with cylindrical stock being 
held vertically.   

Define Custom Shape 
Use the Define Custom Shape dialog to define a custom shape in PartMaker. 

 
To display the Define Custom Shape dialog, select Part Features > Define 
Custom Shape.  

The following settings are available: 

Use as Initial Stock Shape — Select this option if you want to use the custom 
shape as the initial stock shape, as shown in simulation. 

Shape Definition — Select the method for defining the custom shape from the 
geometry: 

Revolve: If you are using 2D profile geometry to define the custom shape, 
selecting this option creates the shape by revolving the 2D profile around a 
vertical axis.  
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 You must draw the profile in the fourth quadrant. Also ensure that 2D 
profile of the custom shape is closed, so the start and end points 
coincide. 

Extrude: If you are using 2D profile geometry to define the custom shape, 
selecting this option creates the shape by extrusion. Specify the extrusion 
vector (the stock length) on the Setup dialog.  

 
Solid Model: Select to create the shape using a solid model file. Click the 
<Model Data> button to display the Model Data dialog, where you can select 
the solid model file you want to use.  

 

Shape Tolerance — Enter a tolerance value for the custom shape. PartMaker 
uses this value when saving the custom shape to an .stl file and when 
calculating surface machining toolpaths whose machining limits are defined 
using this custom shape. 

Shape Name — Enter a name for the custom shape. 
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Shape Preview — Click to display the Stock Shape Preview window, where 
you can preview a 3D representation of the custom shape. 

Save as STL File — Click to save the custom shape to an .stl file. PartMaker 
displays the Export STL File dialog, where you can specify the folder location 
and filename of the file. 

Close — Click to save any changes you have made and close the dialog. 

Cancel — Click to discard any changes you have made and close the dialog. 

Apply — Click to save any changes you have made to the dialog. 

Part ID 
Specifies which part the current Face Window applies to on a machining table.  
Different face windows can be made for separate sides of the same part on a 
Standard Table, where each Face Window represents a different stock (see page 2-
12 for an explanation Independent and Dependent stocks). 

When multiple face windows representing different stocks have the same Part ID, 
the whole completed part can be shown in 3D simulation as PartMaker will know the 
relation to one another of the multiple stocks being machined as defined in the Face 
Options dialog (see page 2-15). 

When multiple face windows representing different stocks have the different Part 
IDs, PartMaker will know different parts are being machined in each Face Window 
and prompt you for which completed part you wish to see in 3D simulation when 
choosing the Show Finished Part command. 

Machining Functions for use with Table Type: Standard 
The Machining Function drop down menu allows you to choose the type of 
machining being performed in a given Face Window. 

For Standard Table type, the available Machining Function is Mill XY Plane. 
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Mill XY Plane 
The Mill XY Plane machining function supports 3-axis planar machining operations. 
Features that can be created by using this Face Window include holes, 2 ½ axis 
milled features such as pockets and contours and features requiring 3D surface 
machining. 

 

Height (H): Height of the initial stock being machined 

Z Face (F): The location of the top of the stock relative to the
 Z = 0 Plane 

x1: X coordinate of the lower left hand corner of the 
rectangular machining area  

y1: Y coordinate of the lower left hand corner of the  
rectangular machining area   

x2: X coordinate of the upper right hand corner of 
the  rectangular machining area   

y2: Y coordinate of the  upper right hand corner of 
the  rectangular machining area   

Work Offset: The work coordinate system of the stock in the 
current Face Window 
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Face Options 
When the Table is set to Standard using the Mill XY Plane window, the Face 
Options dialog can be accessed by clicking the Face Options button.  When doing 
so, the Face Options dialog will appear as shown below: 

 
Each section of the Face Options dialog is explained below: 

Face Designation in Multiple Stocks Machining 
This section of the Face Options dialog allows you determine whether the 
machining operations programmed in the current Face Window are being done on a 
separate stock from those being used in other Face Windows or on the same stock 
as another face window. 

 
Checking the Independent, Add New Stock radio button indicates that tool paths 
created in the current Face Window are being machined on a separate stock from 
other face windows.  Independent Stocks will be shown separately on the Standard 
Machining Table in PartMaker’s 3D simulation.  

 Important! Face windows containing Independent Stocks should each have 
a different Work Offset value assigned in the Setup dialog. 

Checking the Dependent, Use Stock defined for Face radio button indicates that 
tool paths created in the current Face Window are being machined on the same 
stock defined in the Face Window designated. In the Setup dialog the Part ID will 
be disabled. 
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Work Coordinates 
This Work Coordinates section of the Face Options dialog allows you determine 
the location of an Independent Stock on the machining table. 

 

Xw: Allows you to define the X location of the center of the Independent Stock 
relative of the lower left hand corner of the machining table.  

Yw: Allows you to define the Y location of the center of the Independent Stock 
relative of the lower left hand corner of the machining table. 

Zw: Allows you to define the Z location of the top of the Independent Stock 
relative of the top of the machining table. 

The values entered in these fields can be manipulated in PartMaker’s 3D simulation 
window by double clicking on the stock using the Change Stock Position dialog. 

Orientation Options 
This Orientation Options section of the Face Options dialog allows you to 
determine which face of a multi-sided part, i.e. the FRONT, BACK, TOP, BOTTOM, 
RIGHT or LEFT is being machined in the current Face Window. 

 

When using the Table Type: Standard PartMaker provides you with a very unique 
capability for programming a mutli-sided part on a vertical machining center where 
each side of the part is being machined in a separate vice and assigned a different 
work offset. 
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The relation of these faces is selected in the Face Orientation in Finished Part 
drop down selection and its orientation on the machining table is selected in the 
drop down dialog for Stock Positioning Angle on Machining Table. 

 Note:  When machining a multi-sided part using the Orientation Options 
section of the Face Options dialog with Independent Stocks (as defined in 
the Face Designation in Multiple Stocks Machining section of the Face 
Options dialog), you should make sure all the Face Windows 
corresponding to the same finished part should have the same Part ID in 
the Setup dialog. 

Arc Output Options 

 

Break Arc Into Lines — Select this option if you want PartMaker to break all 
toolpath arcs into small lines in the NC program when programming for machine 
controls that do not support circular interpolation of arcs. You can also use this 
option to break helical ramp entry into lines when the Advanced Milling Toolpath 
option is enabled.  

Arc Tolerance — When Break Arc Into Lines is selected, you can also specify: 

Roughing — Enter the chord tolerance that PartMaker uses to break arcs into 
lines during roughing operation. 

Finishing — Enter the chord tolerance that PartMaker uses to break arcs into 
lines during finishing, chamfering, and corner rounding operations. 
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Table Type: Rotary 4 Axis 
Setting the Table Type to Rotary 4 Axis assumes you are working a 
vertical machining center with a Rotary Machining Table. (4th-axis-
Rotary.JOB shown here) 

 

Settings 
The Settings dialog is accessed for the Table Type: 4 Axis Rotary by clicking the 
<Settings> button.  The Settings dialog is used to define the dimension and 
appearance of the machining table in PartMaker’s 3D machining simulation for both 
block and cylinder stock. 

 

Length (L): Specifies the  table length. 

Width (W): Specifies the table width. 

Height (H): Specifies the table height.  

Indexing Time (min): Specifies the average 4-Axis Rotary table indexing time. 
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Work Holding Location Select the location of the work holding (Left or Right). 
Specifies which side of the part will be in the holder. 

Use Chuck Specifies that Chuck will be used on 4-Axis Rotary Table 

Chuck Data Allows you to set the chuck parameters. 

Import From Machine File Clicking this button allows you to import the parameters 
of a previously created machining table from an *.MCH 
file which saves you from having to define a new 
machining table for every PartMaker JOB file  

Export to Machine File Clicking this button allows you to export the parameters 
of the specific machining table as an *.MCH file for use 
with future jobs.  Exporting these parameters to a 
machine file allows you to setup a number of different 
types of machining tables. 

Table Transparency Allows you to set the transparency of the table in 
PartMaker’s 3D simulation, 0 being totally opaque, 100 
being totally transparent  

Table Color Allows you to choose the color of the machining table 
from the available color pallet. 

Stock 
When the Table is set to Rotary 4 Axis, you can choose from two types of stock, 
Block or Cylinder.  The Block selection assumes you are working with prismatic 
stock, while the cylinder selection assumes you are working with cylindrical stock 
being held horizontally across the machining table and perpendicular to the tool 
spindle. 

See page 2-5 of this manual for information on using custom stocks in PartMaker 
Mill. 

Part ID 
Disabled when using the Rotary 4 Axis table, as you can only program one complete 
part per JOB file when using this table type. 
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Machining Functions for Block Stock: Mill 4 Axis Plane 
The Mill 4 Axis Plane machining function supports 3-axis planar machining 
operations. Features that can be created by using this Face Window include holes, 2 
½ axis milled features such as pockets and contours and features requiring 3D 
surface machining. 

 

Height (H): Height of the initial stock being machined. 

Z Face (F): The Z coordinate of the surface of the part, measured from 
the rotary axis. 

Stock Index 
Angle (C): 

Orientation angle of the stock to achieve the desired face 
position. 

x1: X coordinate of the lower left hand corner of the rectangular 
machining area  

y1: Y coordinate of the lower left hand corner of the rectangular 
machining area   

x2: X coordinate of the upper right hand corner of the  
rectangular machining area 

y2: Y coordinate of the  upper right hand corner of the  
rectangular machining area 

Work Offset: The work coordinate system of the stock in the current Face 
Window 

Face Options 
When the Table is set to Rotary 4 Axis, the Face Options dialog can be accessed by 
clicking the Face Options button.   

Only Arc Output Options area of this dialog apply to the Mill 4 Axis Plane 
Machining Function when with Table Type: Rotary 4 Axis setting. 

The Arc Output Options area of this dialog is explained on page 2-18. 
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Machining Functions for Cylinder Stock: Mill 4 Axis Plane 
The Mill 4 Axis Plane machining function supports 3-axis planar machining 
operations on a work piece that is cylindrical in nature. Features that can be created 
by using this Face Window include holes, 2 ½ axis milled features such as pockets 
and contours and features requiring 3D surface machining. 

 
 

Length (L): Length of the initial stock being machined 

X Face (F): The X coordinate of the initial front face 

Stock Index 
Angle (C): 

Orientation angle of the stock to achieve the desired 
face position 

OD: The Outside diameter of the stock 

ID: The Inside diameter of the stock 

Work 
Offset: 

The work coordinate system of the stock in the current 
Face Window 
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Machining Functions for Cylinder Stock: Mill Polygon 
The Mill Polygon machining function allows you to create multiple flat surfaces on 
the OD of a part using the rotary-axis capability of your machine. 

 
 

Length (L): Length of the initial stock being machined 

X Face (F): The X coordinate of the front face of the initial stock 

OD: The Outside diameter of the stock 

ID: The Inside diameter of the stock 

Work Offset: The work coordinate system of the stock in the current 
Face Window 
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Machining Functions for Cylinder Stock: Mill Diam, Index 
The Mill Diam, Index machining function allows you  to create “cross holes” or 
horizontal slots on the OD of the part.  In order to support this machining function, 
your mill must be able to support Rotary-axis indexing.  

This machining function supports the following features cut on the outside diameter 
of the cylinder. 

 Slots oriented along the length (X-axis) of the stock. 

 Holes drilled anywhere along the cylinder except the end of the stock. 

 
 

Length (L): Length of the initial stock being machined 

X Face (F): The X coordinate of the front face of the initial stock 

OD: The Outside diameter of the stock 

ID: The Inside diameter of the stock 

Work Offset: The work coordinate system of the stock in the current 
Face Window 



 

2-18 PartMaker  Copyright @2014 Delcam Ltd 

 

Machining Functions for Cylinder Stock: Mill Cylinder 
The Mill Cylinder machining function supports continuous milling on the outside 
diameter of the part.  Cylindrical milling assumes that your Mill has the ability to 
simultaneously feed in the X, Y and C axes. 

Using motions of this type, combined with a tool motion, profiles can be created on 
the outside diameter of the stock. 

Tool positioning is programmed using X, Y, and C axis coordinates.  The C position 
is programmed in terms of degrees of rotation relative to machine C=0. 

Programming of this machining function requires that your Mill has a programmable 
Rotary-axis.  

 
 

Length (L): Length of the initial stock being machined 

X Face (F): The X coordinate of the front face of the initial stock 

OD: The Outside diameter of the stock 

ID: The Inside diameter of the stock 

Work Offset: The work coordinate system of the stock in the current 
Face Window 

Face Options 
When the Table is set to Rotary 4 Axis, the Face Options dialog can be accessed by 
clicking the Face Options button.   

Only Arc Output Options section of this dialog applies to the Mill 4 Axis Plane 
Machining Function when with Table Type: Rotary 4 Axis setting. 

The Arc Output Options area of this dialog is explained on page 2-18. 
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Table Type: Rotary 5 Axis 
Setting the Table Type to Rotary 5 Axis assumes you are working on a vertical 
machining center with a Rotary Table capable of rotating about two axes: X-axis 
and Z-axis, i.e. a 5 axis rotary table. (Multi-sided-Milling\6-sided-on-5-axis-
table.JOB shown here) 

 

Settings 
The 5-Axis Rotary Table Settings dialog is accessed by clicking the Settings 
button in the Setup dialog.  The 5-Axis Rotary Table Settings dialog is used to 
define the dimension and appearance of the machining table in PartMaker’s 3D 
machining simulation for both block and cylinder stock. 

 
 

Length (L): Specifies the  table length. 

Width (W): Specifies the table width. 

Height (H): Specifies the table height.  

Stock Extension (E): Specifies the distance from the part face to the Chuck. 

Pivot Distance (Pd): Specifies distance from the table pivot point to the top of 
the stock. 
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Use Turning in Job Is only available with Cylinder Stock and allows the use 
conventional turning tools moving in the X and Z-axes. 

Indexing Time (min): Specifies the average 5-Axis Rotary table index time. 

Use Chuck Specifies that Chuck will be used on 5-Axis Rotary Table  

Chuck Data Allows you to set the chuck parameters. 

Import From Machine 
File 

Clicking this button allows you to import the parameters 
of a previously created machining table from an *.MCH 
file which saves you from having to define a new 
machining table for every PartMaker JOB file  

Export to Machine File Clicking this button allows you to export the parameters 
of the specific machining table as an *.MCH file for use 
with future jobs.  Exporting a these parameters to a 
machine file allows you to setup a number of different 
types of machining tables. 

Table Transparency Allows you to set the transparency of the table in 
PartMaker’s 3D simulation, 0 being totally opaque, 100 
being totally transparent  

Table Color Allows you to choose the table color of the machining 
table from the available color pallet. 

Stock 
When the Table is set to Rotary 5 Axis, you can choose from two types of stock, 
Block or Cylinder.  The Block selection assumes you are working with prismatic 
stock, while the cylinder selection assumes you are working with cylindrical stock 
initially being held vertically.   

See page 2-10 of this manual for information on using custom stocks in PartMaker 
Mill. 

Part ID 
Disabled when using the Rotary 5 Axis table, as you can only program one complete 
part per JOB file when using this table type. 
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Machining Functions for Block Stock: Mill XY Plane 
The Machining Function drop down menu allows you to choose the type of 
machining being performed in a given Face Window. When the Table is set to Rotary 
5 Axis and the stock type is set to Block, the Mill XY Plane, Mill 4 Axis Plane, and Mill 
5 Axis Plane, are available for machining functions. Each of these functions is 
explained below. 

The Mill XY Plane machining function supports 3-axis planar machining operations. 
Features that can be created by using this Face Window include holes, 2 ½ axis 
milled features such as pockets and contours and features requiring 3D surface 
machining.  

 
 

Height (H) Height of the initial stock being machined 

Z Face (F): The location of the top of the stock relative to Z = 0 Plane 

Stock Index 
Angle (C): 

Orientation angle of the stock to achieve the desired face 
position. 

x1: X coordinate of the lower left hand corner of the rectangular 
machining area  

y1: Y coordinate of the lower left hand corner of the  
rectangular machining area   

x2: X coordinate of the upper right hand corner of the  
rectangular machining area   

y2: Y coordinate of the  upper right hand corner of the  
rectangular machining area   

Work Offset: The work coordinate system of the stock in the current Face 
Window 
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Machining Functions for Block Stock: Mill 4 Axis Plane 
The Mill 4 Axis Plane machining function Face Window supports 4-axis planar 
machining operations to rotate the part about the machine’s X axis.  Features that 
can be created by using this Face Window include holes, 2 ½ axis milled features 
such as pockets and contours and features requiring 3D surface machining. You will 
use this machining function to machine the side faces of your part. 

 

 
Height (H): 

Z Face (F): 

Height of the initial stock being machined 

The location of the top of the stock relative to Z = 0 Plane 

Stock index 
Angle (C): 

Orientation angle of the stock  about the X-axis to achieve 
the desired face position 

x1: X coordinate of the lower left hand corner of the 
rectangular machining area  

y1: Y coordinate of the lower left hand corner of the  
rectangular machining area   

x2: X coordinate of the upper right hand corner of the  
rectangular machining area   

y2: Y coordinate of the  upper right hand corner of the  
rectangular machining area   

Work Offset: The work coordinate system of the stock in the current 
Face Window 
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Face Options 
When the Table is set to Rotary 5 Axis using the Mill XY Plane or Mill 4 Axis 
Plane window, the Face Options dialog can be accessed by clicking the Face 
Options button.  The only section of the Face Options dialog that applies to this 
table type is the Arc Output Options area shown here: 

 
This should only be used when programming for machine controls that do not 
support circular interpolation of arcs (i.e. G2s and G3s).  Checking the Break Arcs 
Into Lines box indicates to PartMaker to break all arc output into small lines in the 
NC program.  The Roughing and Finishing field under Arc Tolerance specify the 
chord tolerance used when breaking arcs into lines for roughing and finishing 
operations, respectively.  
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Machining Functions for Block Stock: Mill 5 Axis Plane 
The Mill 5 Axis Plane machining function Face Window supports 3-axis planar 
machining operations within an inclined plane.  This inclined plane can be achieved 
by using a tilting a 5-axis rotary table. Features that can be created by using this 
Face Window include holes, 2 ½ axis milled features such as pockets and contours 
and features requiring 3D surface machining that must be machined on an angle. 

 
 

Height (H): Height of the initial stock being machined 

x1: X coordinate of the lower left hand corner of the 
rectangular machining area  

y1: Y coordinate of the lower left hand corner of the  
rectangular machining area   

x2: X coordinate of the upper right hand corner of the  
rectangular machining area   

y2: Y coordinate of the  upper right hand corner of the  
rectangular machining area   

Work Offset: The work coordinate system of the stock in the current 
Face Window 

Face Options 
When the Table is set to Rotary 5 Axis, the Face Options dialog can be accessed by 
clicking the Face Options button.   

Three sections of the Face Options dialog apply to the Mill 5 Axis Plane 
Machining Function when with Table Type: Rotary 5 Axis setting. 
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Orientation Options 
The Orientation Options section of the Face Options dialog allows you to set the 
location of local coordinate system being used on the inclined plane being machined. 

 
 

Index Angle (C): Specifies the angle of the part rotation about the Z-axis to 
which the stock is indexed 

Inclination Angle (B): Sets the inclination angle to which the table is tilted 

Local X (Xo): 

Local Y (Yo): 

Local Z (Zo): 

These fields represent the co-ordinates for the local origin 
created for the planar face being machined. These fields 
represent the coordinates with respect to the work pieces’ 
global coordinate system (part coordinate system of the 
solid model) origin after the work piece is indexed or 
rotated by the Index Angle (C).  

Work Coordinates 
The Work Coordinates area of the Face Options dialog is shown here: 

 
The Work Coordinates section of the Face Options dialog will display work 
coordinates based on calculations performed on the values entered in the 
Orientation Options fields and the Pivot Distance entered in the Table Setting 
Dialog. These work coordinates represent the distance from the origin of the Global 
Coordinate system (solid model coordinate system) to the origin of the local 
coordinate system for the 5-axis Face Window. 

Arc Output Options 
See page 2-18 of this guide for an explanation of the Arc Output Options section 
of Face Options dialog. 



 

2-26 PartMaker  Copyright @2014 Delcam Ltd 

 

Machining Functions for Cylinder Stock: Mill XY Plane 
The Machining Function drop down menu allows you to choose the type of 
machining being performed in a given Face Window. 

When the Table is set to Rotary 5 Axis and you are using Cylinder stock, there are 
nine types of Machining Functions, Mill XY Plane, Mill 4 Axis Plane, Mill 5 Axis Plane, 
Mill Polygon, Mill End Index, Mill End Polar, Mill Diameter Index, Mill Cylinder, and 
Turn. Each of these are explained below: 
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The Mill XY Plane machining function supports 3-axis planar machining operations. 
Features that can be created by using this Face Window include holes, 2 ½ axis 
milled features such as pockets and contours and features requiring 3D surface 
machining. 

 
 

Length (L): Length of the initial stock being machined 

X Face (F): The X coordinate of the initial front face. 

Stock Angle Index Orientation angle of the stock about the Z-axis to 
achieve the desired face position.  

OD: The Outside diameter of the stock 

ID: The Inside diameter of the stock 

Work Offset: The work coordinate system of the stock in the current 
Face Window 
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Machining Functions for Cylinder Stock: Mill 4 Axis Plane 
The Mill 4 Axis Plane machining function Face Window supports 4-axis planar 
machining operations. Features that can be created by using this Face Window 
include holes, 2 ½ axis milled features such as pockets and contours and features 
requiring 3D surface machining. 

 
 

Length (L): Length of the initial stock being machined 

X Face (F): The X coordinate of the initial front face 

Stock Index 
Angle (C): 

Orientation angle of the stock about the X-axis to achieve 
the desired face position 

OD: The Outside diameter of the stock 

ID: The Inside diameter of the stock 

Work Offset: The work coordinate system of the stock in the current Face 
Window 
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Face Options 
When the Table is set to Rotary 5 Axis using the Mill XY Plane or Mill 4 Axis 
Plane window using Cylinder Stock, the Face Options dialog can be accessed by 
clicking the Face Options button.  The only section of the Face Options dialog 
that applies to this table type is the Arc Output Options area shown here: 

 
This should only be used when programming for machine controls that do not 
support circular interpolation of arcs (i.e. G2s and G3s).  Checking the Break Arcs 
Into Lines box indicates to PartMaker to break all arc output into small lines in the 
NC program. 

The Roughing and Finishing field under Arc Tolerance specify the chord 
tolerance used when breaking arcs into lines for roughing and finishing operations, 
respectively.  
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Machining Functions for Cylinder Stock: Mill 5 Axis Plane 
The Mill 5 Axis Plane machining function Face Window supports 3-axis planar 
machining operations within an inclined plane.  This inclined plane can be achieved 
by tilting the 5-axis rotary table in an arbitrary 5-axis plane. Features that can be 
created by using this Face Window include holes, 2 ½ axis milled features such as 
pockets and contours and features requiring 3D surface machining that must be 
machined on an angle. 

 
 

Length (L): Length of the initial stock being machined 

OD: The Outside diameter of the stock 

ID: The Inside diameter of the stock 

Work Offset: The work coordinate system of the stock in the current 
Face Window 

Face Options 
When the Table is set to Rotary 5 Axis, the Face Options dialog can be accessed by 
clicking the Face Options button. 

Three sections of the Face Options dialog apply to the Mill 5 Axis Plane 
Machining Function when with Table Type: Rotary 5 Axis setting. 
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Orientation Options 
The Orientation Options section of the Face Options dialog allows you to set the 
location of local coordinate system being used on the inclined plane being machined. 

 
 

Index Angle (C): Specifies the angle of the part rotation about the Z-axis 
to which the stock is indexed 

Inclination Angle (B): Sets the inclination angle to which the table is tilted 

Local X (Xo): 

Local Y (Yo): 

Local Z (Zo): 

These fields represent the co-ordinates for the local 
origin created for the planar face being machined. These 
fields represent the coordinates with respect to the work 
pieces’ global coordinate system (part coordinate system 
of the solid model) origin after the work piece is indexed 
or rotated by the Index Angle (C).  

Work Coordinates 
The Work Coordinates area of the Face Options dialog is shown here: 

 
The Work Coordinates section of the Face Options dialog will display work 
coordinates based on calculations performed on the values entered in the 
Orientation Options fields and the Pivot Distance entered in the Table Setting 
Dialog. These work coordinates represent the distance from the origin of the Global 
Coordinate system (solid model coordinate system) to the origin of the local 
coordinate system for the 5-axis Face Window. 

Arc Output Options 
See page 2-16 of this guide for an explanation of the Arc Output Options section 
of Face Options dialog. 
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Machining Functions for Cylinder Stock: Mill End Index 
The Mill End, Index machining functon is used when drilling holes and milling slots 
on the end face of the part. The holes are located in the XY plane and oriented 
along the Z-axis.  

The shapes that can be created with this machining function are:  

 Holes in the end of the work piece. This motion type supports off-center 
drilling on the end of the part, using C-axis indexing and X-axis or Y-axis 
positioning to locate the hole position.  

 Radial slots which are milled using C-axis indexing to position and hold the 
part while X-axis or Y-axis motion is used to cut the part. 

 

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining  

Work Offset Specifies the work offset for the current face 
window 

Arc Output Options 
See page 2-18 of this guide for an explanation of the Arc Output Options section 
of Face Options dialog. 
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Machining Functions for Cylinder Stock: Mill End Polar 
The Mill End, Polar machining function allows you to perform polar interpolation on 
the face of the part. This machining function assumes that the Mill Center has the 
ability to perform simultaneous feed motions with the X, Z and C-axes.  

Programming of this machining function requires that your Mill Center has a 
programmable C-axis and that you have purchased the PartMaker C-axis milling 
option. 

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining  

Work Offset Specifies the work offset for the current face 
window 

Arc Output Options 
See page 2-18 of this guide for an explanation of the Arc Output Options section 
of Face Options dialog. 
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Machining Functions for Cylinder Stock: Mill Polygon 
The Mill Polygon machining function allows you to create multiple flat surfaces on 
the OD of a part using the rotary-axis capability of your machine. 

 
 

Length (L): Length of the initial stock being machined 

X Face (F): The X coordinate of the front face of the initial stock 

OD: The Outside diameter of the stock 

ID: The Inside diameter of the stock 

Work Offset: The work coordinate system of the stock in the current 
Face Window 

Face Options 
The Face Options dialog is disabled for the Mill Polygon Machining Function 
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Machining Functions for Cylinder Stock: Mill Diam, Index 
The Mill Diam, Index machining function allows you  to create “cross holes” or 
horizontal slots on the OD of the part.  In order to support this machining function, 
your mill must be able to support Rotary-axis indexing.  

This machining function supports the following features cut on the outside diameter 
of the cylinder. 

 Slots oriented along the length (X-axis) of the stock. 

 Holes drilled anywhere along the cylinder except the end of the stock. 

 
 

Length (L): Length of the initial stock being machined 

X Face (F): The X coordinate of the front face of the initial stock 

OD: The Outside diameter of the stock 

ID: The Inside diameter of the stock 

Work Offset: The work coordinate system of the stock in the current 
Face Window 

Face Options 
The Face Options dialog is disabled for the Mill Diameter Index Machining Function. 
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Machining Functions for Cylinder Stock: Mill Cylinder 
The Mill Cylinder machining function supports continuous milling on the outside 
diameter of the part.  Cylindrical milling assumes that your Mill has the ability to 
simultaneously feed in the X, Y and C axes. 

Using motions of this type, combined with a tool motion, profiles can be created on 
the outside diameter of the stock. 

Tool positioning is programmed using X, Y, and C axis coordinates.  The C position 
is programmed in terms of degrees of rotation relative to machine C=0. 

Programming of this machining function requires that your Mill has a programmable 
Rotary-axis.  

 
 

Length (L): Length of the initial stock being machined 

X Face (F): The X coordinate of the front face of the initial stock 

OD: The Outside diameter of the stock 

ID: The Inside diameter of the stock 

Work Offset: The work coordinate system of the stock in the current 
Face Window 

Face Options 
When the Table is set to Rotary 4 Axis, the Face Options dialog can be accessed by 
clicking the Face Options button.   

Only Arc Output Options section of this dialog applies to the Mill Cylinder 
Machining Function when with Table Type: Rotary 4 Axis setting. 

The Arc Output Options area of this dialog is explained on page 2-18. 
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Machining Functions for Cylinder Stock: Turning 
The picture below shows the appearance of the Setup dialog when performing 
Turning on the Rotary 5 Axis table.  

The Turn machining function is only available when the Stock selection is set to 
Cylinder and the Use Turning in Job check box is selected in the Settings Dialog. 

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining 

Excess Stock (E) Rough stock left for facing on the front of the part  

Work Offset Specifies the work offset for the current face 
window 
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In the Set up Dialog click on the Settings button and select Use Turning in Job. 
This has to be selected while in any of the Mill Machining Functions. 

 
 

Length (L): Specifies the table length. 

Width (W): Specifies the table width. 

Height (H): Specifies the table height.  

Stock Extension (E): Specifies the distance from the part face to the Chuck. 

Indexing Time 
(min): 

Specifies the average 4-Axis Rotary table indexing time. 

Work Holding 
Location 

Select the location of the work holding (Left or Right). Specifies 
which side of the part will be in the holder. 

Use Chuck Specifies that Chuck will be used on 4-Axis Rotary Table 

Chuck Data Allows you to set the chuck parameters. 

Import From 
Machine File 

Clicking this button allows you to import the parameters of a 
previously created machining table from an *.MCH file which 
saves you from having to define a new machining table for every 
PartMaker JOB file  

Export to Machine 
File 

Clicking this button allows you to export the parameters of the 
specific machining table as an *.MCH file for use with future jobs.  
Exporting these parameters to a machine file allows you to setup 
a number of different types of machining tables. 

Table Transparency Allows you to set the transparency of the table in PartMaker’s 3D 
simulation, 0 being totally opaque, 100 being totally transparent  

Table Color Allows you to choose the color of the machining table from the 
available color pallet. 
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In PartMaker/Mill, you can use the Turning Machining Position dialog to change 
the orientation of the stock from Vertical to Horizontal for turning operations when 
you are using a Rotary 5 Axis table. 

 
The Turn machining function uses conventional turning tools moving in the X and Z-
axes. This machining function includes on centerline drilling where a drill is held 
stationary while the spindle holding the part rotates. All drilled holes must therefore 
be on the rotational centerline of the part. 
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Table Type: Vertical Rotary  
Setting the Table Type to Vertical Rotary assumes you are working on a vertical 
machining center with a Rotary Table. 

 

Settings 
The Vertical Rotary Table Settings dialog is accessed by clicking the Settings 
button in the Setup dialog.  The Vertical Rotary Table Settings dialog is used to 
define the dimension and appearance of the machining table in PartMaker’s 3D 
machining simulation for both block and cylinder stock. 

 
 

Length (L): Specifies the  table length. 

Diameter (D): Specifies the diameter of the rotary table. 

Height (H): Specifies the table height.  

Stock Extension 
(E):  Specifies the distance from the part face to the Chuck. 
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Part Top 
Distance (T): 

Specifies distance from the table top surface to the top of the 
stock. 

Use Turning in 
Job 

Is only available with Cylinder Stock and allows the use 
conventional turning tools moving in the X and Z-axes. 

Indexing Time 
(min): Specifies the average Rotary table index time. 

Use Chuck Specifies that Chuck will be used on Rotary Table  

Chuck Data Allows you to set the chuck parameters. 

Import From 
Machine File 

Clicking this button allows you to import the parameters of a 
previously created machining table from an *.MCH file which 
saves you from having to define a new machining table for every 
PartMaker JOB file 

Export to 
Machine File 

Clicking this button allows you to export the parameters of the 
specific machining table as an *.MCH file for use with future jobs.  
Exporting a these parameters to a machine file allows you to 
setup a number of different types of machining tables. 

Table 
Transparency 

Allows you to set the transparency of the table in PartMaker’s 3D 
simulation, 0 being totally opaque, 100 being totally transparent  

Table Color Allows you to choose the table color of the machining table from 
the available color pallet. 

Stock 
When the Table is set to Vertical Rotary, you can choose from two types of stock, 
Block or Cylinder.  The Block selection assumes you are working with prismatic 
stock, while the cylinder selection assumes you are working with cylindrical stock 
initially being held vertically.   

See page 2-10 of this manual for information on using custom stocks in PartMaker 
Mill. 

Part ID 
Disabled when using the Vertical Rotary table, as you can only program one 
complete part per JOB file when using this table type. 
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Machining Functions for Block Stock: Mill XY Plane 
The Machining Function drop down menu allows you to choose the type of 
machining being performed in a given Face Window. 

When the Table is set to Vertical Rotary and the stock type is set to Block, the Mill 
XY Plane, and Mill 5 Axis Plane, are available for machining functions. Each of 
these functions is explained below. 
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The Mill XY Plane machining function supports 3-axis planar machining operations. 
Features that can be created by using this Face Window include holes, 2 ½ axis 
milled features such as pockets and contours and features requiring 3D surface 
machining.  

 
 

Height (H) Height of the initial stock being machined 

Z Face (F): The location of the top of the stock relative to Z = 0 Plane 

Stock Index 
Angle (C): 

Orientation angle of the stock to achieve the desired face 
position. 

x1: X coordinate of the lower left hand corner of the rectangular 
machining area  

y1: Y coordinate of the lower left hand corner of the  rectangular 
machining area   

x2: X coordinate of the upper right hand corner of the  
rectangular machining area   

y2: Y coordinate of the  upper right hand corner of the  
rectangular machining area   

Work Offset: The work coordinate system of the stock in the current Face 
Window 
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Face Options 
When the Table is set to Vertical Rotary using the Mill XY Plane window, the Face 
Options dialog can be accessed by clicking the Face Options button.  The only 
section of the Face Options dialog that applies to this table type is the Arc Output 
Options area shown here: 

 
This should only be used when programming for machine controls that do not 
support circular interpolation of arcs (i.e. G2s and G3s).  Checking the Break Arcs 
Into Lines box indicates to PartMaker to break all arc output into small lines in the 
NC program.  The Roughing and Finishing field under Arc Tolerance specify the 
chord tolerance used when breaking arcs into lines for roughing and finishing 
operations, respectively.  
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Machining Functions for Block Stock: Mill 5 Axis Plane 
The Mill 5 Axis Plane machining function Face Window supports 3-axis planar 
machining operations within an inclined plane.  This inclined plane can be achieved 
by using a tilting a 5-axis rotary table. Features that can be created by using this 
Face Window include holes, 2 ½ axis milled features such as pockets and contours 
and features requiring 3D surface machining that must be machined on an angle. 

 
 

Height (H): Height of the initial stock being machined 

x1: X coordinate of the lower left hand corner of the 
rectangular machining area  

y1: Y coordinate of the lower left hand corner of the  
rectangular machining area   

x2: X coordinate of the upper right hand corner of the  
rectangular machining area   

y2: Y coordinate of the  upper right hand corner of the  
rectangular machining area   

Work Offset: The work coordinate system of the stock in the current 
Face Window 

Face Options 
When the Table is set to Vertical Rotary, the Face Options dialog can be accessed 
by clicking the Face Options button.   

Two sections of the Face Options dialog apply to the Mill 5 Axis Plane Machining 
Function with this Table Type: 
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Orientation Options 
The Orientation Options section of the Face Options dialog allows you to set the 
location of local coordinate system being used on the inclined plane being machined. 

 
 

Index Angle (C): Specifies the angle of the part rotation about the Z-axis 
to which the stock is indexed 

Inclination Angle 
(B): 

Sets the inclination angle to which the table is tilted 

Local X (Xo): 

Local Y (Yo): 

Local Z (Zo): 

These fields represent the co-ordinates for the local 
origin created for the planar face being machined. These 
fields represent the coordinates with respect to the work 
pieces’ global coordinate system (part coordinate 
system of the solid model) origin after the work piece is 
indexed or rotated by the Index Angle (C).  

Arc Output Options 
See page 2-18 of this guide for an explanation of the Arc Output Options section 
of Face Options dialog. 
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Machining Functions for Cylinder Stock: Mill XY Plane 
The Machining Function drop down menu allows you to choose the type of 
machining being performed in a given Face Window. 

When the Table is set to Vertical Rotary and you are using Cylinder stock, there are 
seven types of Machining Functions, Mill XY Plane, Mill 5 Axis Plane, Mill End Index, 
Mill End Polar, Mill Diameter Index, Mill Cylinder, and Turn. Each of these is 
explained below: 
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The Mill XY Plane machining function supports 3-axis planar machining operations. 
Features that can be created by using this Face Window include holes, 2 ½ axis 
milled features such as pockets and contours and features requiring 3D surface 
machining. 

 
 

Length (L): Length of the initial stock being machined 

Stock Angle Index Orientation angle of the stock about the Z-axis to 
achieve the desired face position.  

OD: The Outside diameter of the stock 

ID: The Inside diameter of the stock 

Work Offset: The work coordinate system of the stock in the 
current Face Window 

Face Options 
When the Table is set to Vertical Rotary using the Mill XY Plane, Mill End Index 
Mill End Polar window using Cylinder Stock, the Face Options dialog can be 
accessed by clicking the Face Options button.  The only section of the Face 
Options dialog that applies to this table type is the Arc Output Options area 
shown here: 

 
This should only be used when programming for machine controls that do not 
support circular interpolation of arcs (i.e. G2s and G3s).  Checking the Break Arcs 
Into Lines box indicates to PartMaker to break all arc output into small lines in the 
NC program.  The Roughing and Finishing field under Arc Tolerance specify the 
chord tolerance used when breaking arcs into lines for roughing and finishing 
operations, respectively.  
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Machining Functions for Cylinder Stock: Mill 5 Axis Plane 
The Mill 5 Axis Plane machining function Face Window supports 3-axis planar 
machining operations within an inclined plane.  This inclined plane can be achieved 
by tilting the 5-axis rotary table in an arbitrary 5-axis plane. Features that can be 
created by using this Face Window include holes, 2 ½ axis milled features such as 
pockets and contours and features requiring 3D surface machining that must be 
machined on an angle. 

 
 

Length (L): Length of the initial stock being machined 

OD: The Outside diameter of the stock 

ID: The Inside diameter of the stock 

Work Offset: The work coordinate system of the stock in the current 
Face Window 

Face Options 
When the Table is set to Vertical Rotary, the Face Options dialog can be accessed 
by clicking the Face Options button.   

Two sections of the Face Options dialog apply to the Mill 5 Axis Plane Machining 
Function. 
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Orientation Options 
The Orientation Options section of the Face Options dialog allows you to set the 
location of local coordinate system being used on the inclined plane being machined. 

 
 

Index Angle (C): Specifies the angle of the part rotation about the Z-axis 
to which the stock is indexed 

Inclination Angle (B): Sets the inclination angle to which the table is tilted 

Local X (Xo), 

Local Y (Yo) 

Local Z (Zo): 

These fields represent the co-ordinates for the local 
origin created for the planar face being machined. 
These fields represent the coordinates with respect to 
the work pieces’ global coordinate system (part 
coordinate system of the solid model) origin after the 
work piece is indexed or rotated by the Index Angle 
(C).  

Arc Output Options 
See page 2-18 of this guide for an explanation of the Arc Output Options section 
of Face Options dialog. 
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Machining Functions for Cylinder Stock: Mill End Index 
The Mill End, Index machining functon is used when drilling holes and milling slots 
on the end face of the part. The holes are located in the XY plane and oriented 
along the Z-axis.  

The shapes that can be created with this machining function are:  

 Holes in the end of the work piece. This motion type supports off-center 
drilling on the end of the part, using C-axis indexing and X-axis or Y-axis 
positioning to locate the hole position.  

 Radial slots which are milled using C-axis indexing to position and hold the 
part while X-axis or Y-axis motion is used to cut the part. 

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining  

Work Offset Specifies the work offset for the current face 
window 
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Machining Functions for Cylinder Stock: Mill End Polar 
The Mill End, Polar machining function allows you to perform polar interpolation on 
the face of the part. This machining function assumes that the Mill Center has the 
ability to perform simultaneous feed motions with the X, Z and C-axes.  

Programming of this machining function requires that your Mill Center has a 
programmable C-axis and that you have purchased the PartMaker C-axis milling 
option. 

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining  

Work Offset Specifies the work offset for the current face 
window 
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Machining Functions for Cylinder Stock: Mill Diam, Index 
The Mill Diam, Index machining function allows you  to create “cross holes” or 
slots on the OD of the part.  In order to support this machining function, your mill 
must be able to support Rotary-axis indexing.  

This machining function supports the following features cut on the outside diameter 
of the cylinder. 

 Slots oriented along the length (X-axis) of the stock. 

 Holes drilled anywhere along the cylinder except the end of the stock. 

 
 

Length (L): Length of the initial stock being machined 

X Face (F): The X coordinate of the front face of the initial stock 

OD: The Outside diameter of the stock 

ID: The Inside diameter of the stock 

Work Offset: The work coordinate system of the stock in the current 
Face Window 

Face Options 
The Face Options dialog is disabled for the Mill Diameter Index Machining Function. 
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Machining Functions for Cylinder Stock: Mill Cylinder 
The Mill Cylinder machining function supports continuous milling on the outside 
diameter of the part.  Cylindrical milling assumes that your Mill has the ability to 
simultaneously feed in the X, Y and C axes. 

Using motions of this type, combined with a tool motion, profiles can be created on 
the outside diameter of the stock. 

Tool positioning is programmed using X, Y, and C axis coordinates.  The C position 
is programmed in terms of degrees of rotation relative to machine C=0. 

Programming of this machining function requires that your Mill has a programmable 
Rotary-axis. 

 
 

Length (L): Length of the initial stock being machined 

X Face (F): The X coordinate of the front face of the initial stock 

OD: The Outside diameter of the stock 

ID: The Inside diameter of the stock 

Work Offset: The work coordinate system of the stock in the current 
Face Window 

Face Options 
When the Table is set to Vertical Rotary, the Face Options dialog can be accessed 
by clicking the Face Options button. 

Only Arc Output Options section of this dialog applies to the Mill Cylinder 
Machining Function.  

The Arc Output Options area of this dialog is explained on page 2-18. 
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Machining Functions for Cylinder Stock: Turning 
The picture below shows the appearance of the Setup dialog when performing 
Turning on the Vertical Rotary table.  

The Turn machining function is only available when the Stock selection is set to 
Cylinder and the Use Turning in Job check box is selected in the Settings Dialog. 
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In the Set up Dialog click on the Settings button and select Use Turning in Job. 
This has to be selected while in any of the Mill Machining Functions.  

 
The Turn machining function uses conventional turning tools moving in the X and Z-
axes. This machining function includes on centerline drilling where a drill is held 
stationary while the spindle holding the part rotates. All drilled holes must therefore 
be on the rotational centerline of the part.    

 

Diameter (D) Diameter of the Rotary Table 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining 

Excess Stock (E) Rough stock left for facing on the front of the part  

Work Offset Specifies the work offset for the current face 
window 
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Table Type: Tombstone 
Setting the Table Type to Tombstone assumes you are working on a horizontal 
machining center with a Tombstone machining table. This Table Type is especially 
helpful when machining multiple pieces in a single setup. With the Tombstone table 
setting, multiple stocks are allowed in simulation. The user can either choose an 
option to add a new stock for a given face or to “share” a stock defined on another 
face. The face where the stock is defined is called the “Independent” face; the face 
that uses a stock defined on another face is called the “dependent” face. Faces that 
“share” a stock may have different angles. Multiple parts can be machined by 
assigning a Part ID for every face. All of the faces with the same Part ID belong to a 
single part. This Part ID is used for “Show Finished Part” in Simulation to 
reconstruct a single part machined in multiple fixtures. (Tombstone-Many-
Stocks\vice_demo.JOB shown here) 
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Settings 

 
 

Length (L): Specifies the Tombstone length 

Height (H): Specifies the Tombstone height 

Indexing Time (min): Specifies the average Tombstone indexing time 

Tombstone Type Type 1: Specifies tombstone layout where angle 
corresponding to each side is incremented in Clockwise 
direction. 

Type2: Specifies tombstone layout where angle 
corresponding to each side is incremented in Counter 
Clockwise direction. 

Import From Machine 
File 

Allows you to import the parameters of a previously 
created machining table from an *.MCH file which saves 
you from having to define a new machining table for every 
PartMaker JOB file  

Export to Machine 
File 

Allows you to export the parameters of the specific 
machining table as an *.MCH file for use with future jobs.  
Exporting a these parameters to a machine file allows you 
to setup a number of different types of machining tables. 

Tombstone 
Transparency 

Allows you to set the transparency of the table in 
PartMaker’s 3D simulation, 0 being totally opaque, 100 
being totally transparent  

Tombstone Color Allows you to choose the table color of the machining table 
from the available color pallet. 
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Stock 
When the Table is set to Tombstone, you can choose from two types of stock, 
Block or Cylinder.  The Block selection assumes you are working with prismatic 
stock, while the cylinder selection assumes you are working with cylindrical stock 
being held horizontally, perpendicular to the tombstone surface.  

Part ID 
Specifies which part the current Face Window applies to on a machining table.  
Different face windows can be made for separate sides of the same part on a 
Standard Table, where each Face Window represents a different stock (see page 2-
15 below for an explanation Independent and Dependent stocks). 

When multiple face windows representing different stocks have the same Part ID, 
the whole completed part can be shown in 3D simulation as PartMaker will know the 
relation to one another of the multiple stocks being machined as defined in the Face 
Options dialog (see page 2-15). 

When multiple face windows representing different stocks have the different Part 
IDs, PartMaker will know different parts are being machined in each Face Window 
and prompt you for which completed part you wish to see in 3D simulation when 
choosing the Show Finished Part command. 
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Machining Functions for Block Stock: Mill XY Plane 
The Machining Function drop down menu is always set to Mill XY Plane. 

The Mill XY Plane machining function supports 3-axis planar machining operations. 
Features that can be created by using this Face Window include holes, 2 ½ axis 
milled features such as pockets and contours and features requiring 3D surface 
machining. 

 

 
Height (H) Height of the initial stock being machined 

Z Face (F): The location of the top of the stock relative to Z = 0 
Plane 

Tombstone Index 
Angle (C): 

Orientation angle of the stock to achieve the desired 
face position. 

x1: X coordinate of the lower left hand corner of the 
rectangular machining area  

y1: Y coordinate of the lower left hand corner of the  
rectangular machining area   

x2: X coordinate of the upper right hand corner of the  
rectangular machining area   

y2: Y coordinate of the  upper right hand corner of the  
rectangular machining area   

Work Offset: The work coordinate system of the stock in the current 
Face Window 
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Machining Functions for Cylinder Stock: Mill XY Plane 

 

Length (L): Length of the initial stock 

Z Face (F): The location of the top of the stock relative to Z = 0 Plane 

Tombstone 
Index Angle  

Orientation angle of the tombstone to achieve the desired face 
position 

OD: The Outside diameter of the stock 

ID: The Inside diameter of the stock 

Work Offset: The work coordinate system of the stock in the current Face 
Window 

Face Options 
When the Table is set to Tombstone using Box Stock, the Face Options dialog 
can be accessed by clicking the Face Options button. When doing so, the Face 
Options dialog will appear as shown below: 

 
Each section of the Face Options dialog is explained beginning on the next 
page. 
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Face Designation in Multiple Stocks Machining 

 
This section of the Face Options dialog allows you determine whether the 
machining operations programmed in the current Face Window are being done on a 
separate stock from those being used in other Face Windows or on the same stock 
as another face window. 

Checking the Independent, Add New Stock radio button indicates that tool paths 
created in the current Face Window are being machined on a separate stock from 
other face windows.  Independent Stocks will be shown separately on the 
Tombstone in PartMaker’s 3D simulation. This option will create a face in simulation 
that is parallel to the tombstone.   

 Important! Face windows containing Independent Stocks should each have 
a different Work Offset value assigned in the Setup dialog. 

Checking the Dependent, Use Stock defined for Face radio button indicates that 
tool paths created in the current Face Window are being machined on the same 
stock defined in the face window designated. In the Setup dialog the Part ID will be 
disabled.  

When creating dependent faces, the user must enter a value in Tombstone Index 
Angle field in the Setup dialog that corresponds to the index angle for the 
dependent face. For example, the FRONT Independent Face shown below can be 
specified at an index angle of 0 degrees. The RIGHT Dependent face would need an 
index angle of 270 degrees to have the face become aligned with the tool for 
machining.   The FRONT and RIGHT designations used here are explained further 
below under Orientation Options. 
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Orientation Options 

 
This Orientation Options section of the Face Options dialog allows you determine 
which face of a multi-sided part, i.e. the FRONT, BACK, TOP, BOTTOM, RIGHT or 
LEFT is being machined in the current Face Window. 

When using the Tombstone as the machining table PartMaker provides you with a 
very unique capability for programming a mutli-sided part on a horizontal machining 
center where each side of the part is being machined in a separate vice and 
assigned a different work offset.  

The following set of options is only available if Block Stock is selected in the Setup 
dialog. This feature allows you specify different Face Windows for different sides of 
the block, program them in the orientation needed to produce proper NC code (how 
it will be set up on the CNC machine table), and allow PartMaker simulation to 
connect the machining conducted on different stocks together to show the correct 
finished part. 

The relation of these faces is selected in the Face Orientation in Finished Part 
drop down menu and its orientation on the tombstone is selected in the drop down 
menu for Stock Positioning Angle on Machining Table. 

Face Orientation in Finished Part: This allows the user to select the side of the 
part which the face window will represent in the finished part during simulation. The 
FRONT face of the part is always parallel to the X-Y plane of the solid model and 
has the Z-axis pointing upward.  

 Note: If you work with a solid model the Face Orientation in Finished Part 
will be set automatically and the Stock Positioning Angle will be set to 
Zero. 

 Note: FRONT orientation MUST be used on every part otherwise an error 
message will display. 

Stock Position Angle on Machine Table: Allows the user to specify how stock for a 
given face window will be oriented during machining when compared to finished 
part. The NC code will not be affected by this field but the tool path in PartMaker’s 
3D Simulation will be rotated according the value in this field. If you are rotating the 
part to 90 or 270 degrees, you will need to adjust the coordinates of the boundaries 
in the Setup Window. 
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Work Coordinates 

 
This Work Coordinates section of the Face Options dialog allows you determine 
the location of an Independent Stock on the machining table. The work 
coordinates are used to specify the coordinates of the stock on the tombstone in 
terms of the Tombstone Coordinate System with origin at bottom left corner of the 
tombstone. 

Xw: Allows you to define the X location of the origin of the stock relative of the 
lower left hand corner of the Tombstone side where the stock is mounted.  

Yw: Allows you to define the Y location of the origin of the stock relative of the 
lower left hand corner of the Tombstone side where the stock is mounted.  

Zw: Allows you to define the Z location of the origin of the stock relative of the 
lower left hand corner of the Tombstone side where the stock is mounted.  

The values entered in these fields can be manipulated in PartMaker’s 3D simulation 
window by double clicking on the stock using the Change Stock Position dialog. 

Arc Output Options 
The Arc Output Options area of this dialog is explained on page 2-18. 
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Working in a Face Window 
A Face Window is the work area in which you define groups of holes and profiles 
that need to be machined. The main area of the window displays the part 
boundaries; the left side displays group icons, which have cycle name labels needed 
to machine the current part. 

 
 

Display the 
Axes  

You can display the axes in a face window by 
choosing Show Axes from the View menu. 

Display the 
Grid  You can display the grid in a face window by 

choosing Show Grid from the View menu. 

Display the 
Boundaries  

You can display the part boundaries in a face 
window by choosing Show Boundaries from the 
View menu. 



 

2-66 PartMaker  Copyright @2014 Delcam Ltd 

 

Using the CAD/CAM Switch 

 

The left icon represents CAM mode. Clicking on it will switch to the CAD 
mode represented by the icon on the right. 

 

Using the Color Bar 
 

You use the color bar in the upper-right corner of a Face Window to select a color 
for group symbols. You can also use it to change the color of geometry. The group 
symbol or geometric element will have the color of the currently chosen Sample 
Color (round color icon). 

 Note: If you want to change the color of a Group Symbol, select the Group 
Symbol in the Face Window, click a color on the color bar, and then click 
the Sample Color (round icon) on the left side of the color bar. 

To change the color of a geometric element, select the geometry in the Face 
Window, click a color on the color bar, and then click the Sample Color (round 
icon) on the left side of the color bar. 

Using the Icon Toolbars 
PartMaker Version 9 and higher provides Toolbars to speed up commonly used 
functions throughout the software. PartMaker supports four types of icon toolbars, a 
Main Toolbar which is available throughout a job file, a Face Window Toolbar 
which is associated with each Face Window, a Solids Window Toolbar which 
appears when working with an imported Solid Model and a Simulation Toolbar 
which appears when working in PartMaker’s 3D simulation.  Here, the Main Toolbar 
and Face Window Toolbar are explained.  Chapter 6 of this guide will explain the 
use of the Simulation Toolbar while Appendix C to this manual will explain the use of 
the Solids Window Toolbar. 

Main Toolbar 
The Main Toolbar lets you perform many of the functions in PartMaker’s menus 
with the click of a button.  The Main Toolbar will look the same throughout your 
PartMaker session and appears as below: 

 

 Note:  When holding your mouse over any of these icons, a “Tool Tip” will 
appear showing the function performed by that icon. Each command is 
explained in greater detail in Chapter 4 of this manual. 

Face Window Toolbar – CAM Mode 
The Face Window Toolbar lets you perform many of the functions in PartMaker’s 
menus with the click of a button.  The Face Window Toolbar applies only to the 
active Face Window and may look differently depending on the Machining 
Function Face Window being used. 
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Face Window Toolbar – CAD Mode 

 

Displaying Toolbar Icons 
The display of the Toolbars can be manipulated by choosing Toolbars from the 
View menu.  When a toolbar is checked, it will appear.  When unchecked, it will not 
be visible. 

Creating Groups of Part Features 
Groups of part features such as holes, profiles and surfaces are created in 
PartMaker. The currently selected group icon or Group Symbol in a Face 
Window is the work group from which tool paths are being added. 

To create a new Group Symbol: 

1 Click the desired color on the color bar. 

2 Choose New Profile, New Surface or New Hole Group (depending on the type 
of Part Feature being created) from the Part Features menu to display the 
Group Parameters dialog. 

When you exit the dialog, the new group is created using the color you 
specified. 
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Using the Graphics Icons in PartMaker CAD mode 
You can create your part drawings in PartMaker in the CAD mode. Alternatively, 
you can also import drawings from other CAD systems into PartMaker by using the 
Import command from the File menu. Imported geometry can be altered in 
PartMaker’s CAD mode. 

 
Geometry is created in PartMaker CAD using the Graphics Icons that include 
Drawing Icons and Snap Modes. 
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Geometry Drawing Icons 
Geometry Drawing icons allow you to create different types of geometric 
constructions such as lines and arcs. PartMaker’s geometry drawing icons are 
defined below. 

 

 

Selection Icon indicates that the system is in the selection mode. In this 
mode you can select lines, arcs and circles in the Face Window either by 
clicking on them or dragging a selection rectangle around them. 

 
Zero Icon allows you to define a new location for the zero point using 
Snap Modes. 

 Trim/Extend Icon allows you to stretch or shorten an existing line or arc. 

 
Remove Icon allows you to remove portions of lines or arcs between 
intersection points. 

 
Line Thru Two Points Icon allows you to create a line between two 
points specified using Snap Modes. 

 
Connected Lines Icon allows you to create connected lines with end 
points specified using Snap Modes. 

 
Line Parallel Horizontal axis Icon allows you to create a line parallel to 
the Horizontal axis by specifying positive or negative offset. 

 
Line Parallel Vertical axis Icon allows you to create a line parallel to the 
Vertical axis by specifying positive or negative offset. 

 
Parallel Element Icon allows you to create a line, arc, or circle parallel to 
the cursor selected entity specifying an unsigned distance. 

 
Line on an Angle Icon allows you to create a line on an angle to a cursor-
selected line passing through a point specified using Snap Modes. 

 
Fillet Icon allows you to insert a fillet between two cursor-selected lines or 
arcs. 

 
Chamfer Icon allows you to insert a chamfer between two cursor-selected 
lines or arcs. 

 
Circle with a Known Radius and Center Icon allows you to define a 
circle with a center specified using Snap Modes. 

 
Circle with a Known Radius and Two Points Icon allows you to define 
a circle with two points on the circumference specified using Snap Modes. 

 

Circle with a Known Center and a Point Icon allows you to define a 
circle with a center and a point on the circumference specified using Snap 
Modes. 

 
Circle Through Three Points Icon allows you to define a circle with three 
points specified using Snap Modes. 

 
Polygon Icon allows you to create various rectangles by entering a flat-to-
flat distance. 

 
Divide/Append Icon aids you in the “breaking” of segments at specific 
point within the geometry. 

 
Multiple Offset Icon allows you to offset the selected geometry chain 
through a user-defined distance. 

 
Ellipse Icon allows you to create an approximate ellipse in the face 
window, using tangential circular arcs. 
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Dimensioning Icons 
The Dimensioning Icons appear in the PartMaker CAD mode.  These icons allow you 
to create dimension and annotations on your drawings in PartMaker. 

 

 Note Icon Allows you to create a note on a dimensioned drawing. 

 
Note with Leader Icon allows you create a note with an arrow leader to 
point to a specific item on your drawing you wish to annotate. 

 
Angular Dimension This icon allows you to insert an Angular Dimension 
between two lines.. 

 
Circular Dimension Icon This icon allows you to insert a Circular 
Dimension on arc or circle. 

 

Horizontal Dimension Icon This icon allows you to insert a Horizontal 
Dimension between two points that are either end points of arcs and lines 
or centers of circles. 

 

Vertical Dimension Icon This icon allows you to insert a Vertical 
Dimension between two points that are either end points of arcs and lines 
or centers of circles. 

 

Linear Dimension Icon This icon allows you to insert a Linear Dimension 
between two points that are either end points of arcs and lines or centers 
of circles. 

 

Flexible Dimension Icon This icon allows you to insert a “Flexible 
Dimension” that is automatically set by the software to either Horizontal 
Dimension or Vertical Dimension or Linear Dimension depending on the 
cursor position when the text location is specified. 
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Snap Modes 
Snap modes are used in conjunction with geometry icons to define point location. 
PartMaker’s Snap Modes are defined below. Snap drawing modes are also used in 
the CAM mode to define tool path location. 

 

 
XY Coordinates: Used for entering Cartesian coordinates. 
For Face Windows of various machining functions, this snap mode will appear 
differently. 

 

XY for Mill XY Plane, Mill Polygon, Mill End Index, MillEnd Polar and Mill Diam 
Polar 
ZX for Mill ZX Plane and Turn 
ZC for Mill Diam Index and Mill Cylinder 
ZY for Mill ZY Plane 

 Polar Coordinates: Used for entering Polar coordinates 

 
Point on a Circle: Clicking a point on an existing arc or circle and entering an 
Angle 

 Screen: Clicking a cursor location anywhere within the face window 

 
Grid: Clicking a grid location (grid can be turned on from the View Menu by 
choosing Show Grid. Grid size can be set in the Preferences dialog accessed from 
the View menu). 

 Circle Center: Clicking the center an existing circle 

 Closest Intersection: Clicking the closest intersection of geometric elements 

 End of an Element: Clicking the end of an existing line or arc 

 Middle of an Element: Clicking the middle of an existing line or arc 

 Tangency: Clicking near the tangency point that will be calculated by the system 

 
Horizontal Constraint allows you to specify a point whose vertical coordinate 
remains constant, allowing changes in horizontal coordinate only. 

 
Vertical Constraint allows you to specify a point whose horizontal coordinate 
remains constant, allowing changes in vertical coordinate only. 
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Using the Graphics Icons in PartMaker CAM mode 
The Graphics Icons on the left side of a CAM Face Window allow you to define and 
manipulate tool paths. Certain Graphics Icons for use in assigning a particular part 
feature to your part (i.e. a Group Symbol) will have a different appearance and 
function depending on the Machining Function Face Window being used. 

The two icons below will have the same appearance and usage regardless of which 
machining function Face Window you are using. 

 

Selection Icon indicates that the system is in the selection mode. In 
this mode, you can select part features and tool paths in the Face 
Window either by clicking or dragging a selection rectangle around 
them. 

 

Selected profiles in a Face Window are highlighted; unselected 
profiles are not highlighted. Selected holes in a Face Window are 
highlighted; unselected holes are hollow.  You can delete selected 
elements by pressing the <Backspace> key on the keyboard or by 
choosing the Delete command from the Edit menu. 

 
Zero Icon allows you to define a new location for the zero point or 
origin using Snap Modes. 

Graphics Icons: Machining Functions Mill XY Plane, Mill 4 Axis Plane, Mill 5 
Axis, Mill Polygon, Mill Diam Index and Mill Cylinder 
The Machining Functions Mill XY Plane, Mill ZY Plane, Mill Polygon, Mill End Polar, Mill 
Diam Polar and Mill Cylinder use some or all of the following icons to allow you to 
assign part features to created geometry in order to create a tool path. 

 

 
Single Hole Icon enables you to use Snap Modes to define the location on the 
geometry where a currently active Hole Group Symbol is to be executed. 

 

Chain Circle Icon enables you to click an enclosed circle on the geometry and 
specify that the currently active Hole Group Symbol is also to be automatically 
applied at the centers of all the other circles (holes) of the same size that appear 
on the geometry. 

 

Define Profile Icon enables you to specify that the currently active group 
symbol is to be applied to the profile described by either coordinate entry or by 
clicking on geometric elements. 

 

Chain Geometry Icon enables you to specify that the currently active group 
symbol is to be applied to a profile that is created when PartMaker 
automatically connects all the elements that form an unbroken chain with an 
initial line or arc clicked. 

 
2-Point Chain icon The 2-Point Chain icon allows you to define a profile by the 
start point in the chain, and the end point of the chain. 

 
Engrave Icon enables you to use the Engrave Data dialog box to create a 
profile containing numbers and letters. 

 
Hole Pattern Icon is displayed in PartMaker/Mill as a dropdown menu: 
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Graphics Icons: Machining Functions Mill End, Index and Mill Diam, Index 
The Machining Functions Mill End, Index and Mill Diam, Index uses the following 
icons to allow you to assign part features to created geometry in order to create a 
tool path. 

 
Single Hole Icon enables you to use Snap Modes to define the location on 
the geometry where a currently Hole Group Symbol is to be executed. 

 

Chain Circle Icon enables you to click an enclosed circle on the geometry 
and specify that the currently active Hole Group Symbol is also to be 
automatically applied at the centers of all the other circles (holes) of the same 
size that appear on the geometry. 

 

Profile Icon enables you to specify that the currently active group symbol is 
to be applied to the profile described by either coordinate entry or by clicking 
on geometric elements.  When performing indexing operations, the Profile 
Icon may only join two points during its usage. 

 

Chain Icon enables you to specify that the currently active group symbol is 
to be applied to a profile that is created when PartMaker automatically 
connects all the elements that form an unbroken chain with an initial line or 
arc clicked. When performing indexing operations, the Chain Icon may only 
join two points during its usage. 

Hole Pattern Icon – Machining Function Mill XY Plane, Mill 4 Axis Plane, Mill 5 
Axis. 
The Graphics icons on the left side of a face window allow you to define holes by 
entering individual point coordinates.  If you prefer, you can define “patterns” of 
holes by using the Hole Pattern Icon; A dialog will be used to specify options such 
as the number of holes, X and Y starting coordinates, pitch, angle, radius, length, 
and/or offset.  (To see complete list below, click on View, Preferences, Uncheck 
Hide Hole Pattern Icon, click ok.) 
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Using the Linear Pattern Icon 
The Linear Pattern icon lets you specify a linear pattern of holes in a face window. 
When you select the Linear Pattern icon, the Linear Pattern dialog appears. After 
entering parameters in the dialog, a linear pattern of holes is displayed in the face 
window. 

 
 

 
 

No. Holes on 
Line (N) Specifies the number of holes in the pattern 

X Start (X) Specifies the X starting coordinate for the first hole in the pattern 

Y Start (Y) Specifies the Y starting coordinate for the first hole in the pattern 

Pitch (Q) 
Specifies the pitch of holes in 
the pattern from the X, Y 
starting point 

X End (I) Specifies the X coordinate of the 
ending location for the pattern 

Angle (A) 
Specifies the angle of holes in 
the pattern from the X, Y 
starting point 

Y End (J) Specifies the +Y coordinate of the 
ending location for the pattern 

Point, Angle Creates the hole pattern based on the starting location and angle entered in the 
dialog 

Start, End Creates the hole pattern based on the starting and ending locations entered in the 
dialog 
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Using the Circular Pattern Icon 
The Circular Pattern icon lets you specify a circular or arc-shaped pattern of holes in 
a face window. When you select the Circular Pattern icon, the Circular Pattern dialog 
appears. After entering parameters in the dialog, a circular pattern of holes is 
displayed in the face window. 

 

 
 

No. Holes (N) Specifies the number of holes in the pattern 

X Center (X) Specifies the X starting coordinate for the pattern center 

Y Center (Y) Specifies the Y starting coordinate for the pattern center 

Radius (R) Specifies the radius of the pattern center 

Start Angle (A) Specifies the starting angle from which the pattern is 
generated 

Angular Pitch (B) Specifies the pitch for arc-shaped patterns (This option is 
not used for full circle patterns.) 

Arc Creates an arc-shaped pattern of holes 

Full Circle Creates a circular pattern of holes 
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Using the Frame Pattern Icon 
The Frame Pattern icon lets you specify a rectangular pattern of holes in a face 
window. When you select the Frame Pattern icon, the Frame Pattern dialog appears. 
After entering parameters in the dialog, a rectangular pattern of holes is displayed 
in the face window. 

 

 
 

No. Holes in X (N) Specifies the number of holes in the pattern in the X 
(horizontal) direction 

No. Holes in Y (M) Specifies the number of holes in the pattern in the Y 
(vertical) direction 

X Start (X) Specifies the X starting coordinate for the first hole in 
the pattern 

Y Start (Y) Specifies the Y starting coordinate for the first hole in 
the pattern 

X Length (I) Specifies the total length of horizontal holes from the 
center of the first hole to the center of the last hole 

Y Length (J) Specifies the total length of vertical holes from the 
center of the first hole to the center of the last hole 
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Using the Grid Pattern Icon 
The Grid Pattern icon lets you specify a rectangular grid pattern of holes in a face 
window. When you select the Grid Pattern icon, the Grid Pattern dialog appears. 
After entering parameters in the dialog, a grid pattern of holes is displayed in the 
face window.  

 
 

 
 

No. Holes on 
Line (N) Specifies the number of holes in the pattern 

X Start (X) Specifies the X starting coordinate for the first hole in the pattern 

Y Start (Y) Specifies the Y starting coordinate for the first hole in the pattern 

Pitch (Q) 
Specifies the pitch of holes 
in the pattern from the X, 
Y starting point 

X End (I) Specifies the X coordinate of the 
ending location for the pattern 

Offset (D) Specifies the offset distance for each line of holes in the pattern 

Angle (A) 
Specifies the angle of holes 
in the pattern from the X, 
Y starting point 

Y End (J) Specifies the +Y coordinate of the 
ending location for the pattern 

Point, Angle Creates the hole pattern based on the starting location and angle entered in 
the dialog 

Start, End Creates the hole pattern based on the starting and ending locations entered in 
the dialog 
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Using the Nested Grid Pattern Icon 
The Nested Grid Pattern icon lets you specify a rectangular nested grid pattern of 
holes in a face window. When you select the Nested Grid Pattern icon, the Nested 
Grid Pattern dialog appears. After entering parameters in the dialog, a nested grid 
pattern of holes is displayed in the face window. 

 
 

 

 

No. Holes on 
Line (N) Specifies the number of holes in the pattern 

X Start (X) Specifies the X starting coordinate for the first hole in the pattern 

Y Start (Y) Specifies the Y starting coordinate for the first hole in the pattern 

Pitch (Q) 
Specifies the pitch of holes 
in the pattern from the X, Y 
starting point 

X End (I) Specifies the X coordinate of the 
ending location for the pattern 

Offset (D) Specifies the offset distance for each line of holes in the pattern 

Angle (A) 
Specifies the angle of holes 
in the pattern from the X, Y 
starting point 

Y End (J) Specifies the +Y coordinate of the 
ending location for the pattern 

Point, Angle Creates the hole pattern based on the starting location and angle entered in 
the dialog 

Start, End Creates the hole pattern based on the starting and ending locations entered in 
the dialog 
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Chapter 3: Creating a Sample Part 
Introduction 

The illustration on the following page represents a typical task you might perform. 
The name of this part is Milldemo. You’ll create the Milldemo part in this chapter 
using PartMaker. 

This tutorial is designed to help you learn some of the most common PartMaker 
commands and features you’ll use every day. Before you begin, we recommend you 
read Chapter 2 if you haven’t already done so to familiarize yourself with some 
basic PartMaker concepts and features. 

 Important! The tutorial below is presented in both inch and metric units, 
depending on how you are working with PartMaker.  The inch units of 
measure are given first, with the metric entries gives in parenthesis ( ). 

For example you may see instruction that says: Enter an X value 1 (25), where 1 is 
1 inch and 25 is 25 mm. 

How You Will Create Milldemo  
Here are the major steps you’ll follow to create Mill-demo: 

 Start PartMaker and open a new Face Window 

 Specify part boundaries 

 View tool information for the part 

 View cycle information for the part 

 Select a material for the part 

 Set up PartMaker defaults 

 Create Geometry  

 Define holes for a boring cycle 

 Define holes for a tapping cycle 

 Define holes for a reaming cycle 

 Define profiles for Pocket Mill 

 Define profiles for Contour Mill 

 Select a post processor 

 Generate a process table containing machining data 

 Generate an NC program for the part 

 Print the NC program for the part 
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Job File: Milldemo.job (Milldemo_metric.job) 
 

Group 1: Holes 1” (24mm) Bore 

Operation Inch Diameter Metric Diameter 

Center Drill 7/32 5 

Drill 31/32 23.5 

*Bore 1” 25 

Chamfer 1” 25 

Group 2: Holes 1/2” (12mm) Tap 

Operation Inch Diameter Metric Diameter 

Center Drill 7/32 5 

Drill 27/64 10 

*Tap ½” 12.5 

Chamfer ½” 12.5 

Group 3: Holes 1/4” (6mm) Ream 

Operation Inch Diameter Metric Diameter 

Center Drill 7/32 5 

Drill 15/64 5.5 

*Ream ¼” 6.25 

Chamfer ¼” 6.25 
 
Inch Units 
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Metric Units 
 

 
The mill demo has three groups of holes. Each group has a cycle with a major 
operation indicated by an asterisk in the illustration on the previous page. 
Operations are shown for each group that is used for machining the part. The hole 
diameter information and hole locations for each group of holes are also shown in 
the illustration. 

We have provided the boring and tapping cycle information and tool information for 
Milldemo; you’ll create the reaming cycle needed to complete the part. (A complete 
list of what you’ll be doing in the tutorial is shown in the next section.) 

You may find it useful to refer to the illustration as you create Milldemo. We have 
provided the finished part. To view the part, do one of the following: 

Choose Open All Files from the PartMaker File drop down menu, locate and select 
the file named Milldemo.job (Milldemo_metric.job) in the PartMaker directory. 



 

3-4 PartMaker  Copyright @2014 Delcam Ltd 

 

Start PartMaker 
You will now look in detail at each of the steps necessary to program each of the 
components of the finished part.  The components of the completed tutorial Mill part 
can be found in your PartMaker Mill directory under the following file names: 

Completed Job File:   C:\PartMaker\PM-Mill\Milldemo.job  

Completed Tools Data Base:  C:\PartMaker\ PM-Mill\Milldemo.tdb 

Completed Cycles Data Base: C:\PartMaker\ PM-Mill\Milldemo.cdb 

In the Mill tutorial, the default Tools Data Base and Cycles Data Base will be the 
same as Milldemo.tdb and Milldemo.cdb found in the PM-Mill root directory. 

1 Double Click on the PartMaker Mill icon on your Windows desktop, or in the 
Windows Start button, locate the PartMaker Group and double click the 
PartMaker Mill application icon. 

A window containing the PartMaker logo appears. 

 
2 After a few seconds, you will see the Setup definition dialog box open. The 

Setup dialog appears on top of the Face Window. 
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Setup Part Boundaries 
In this section you’ll specify the part boundaries for the Face Window.  

The first dialog you see when you start PartMaker is the Setup dialog, shown 
below. 

 
1 To manually open this dialog, choose Setup from the View menu. 

 Tip: To advance from one numeric entry field to another in a dialog, press 
the <Tab> key. You can also press the <Tab> key to advance from the 
X coordinate field to the Y coordinate field when a numeric prompt 
appears at the bottom of a Face Window. 

2 From the Table drop down menu, choose None 

3 Enter the following values next to these options in the dialog: 

x1 -4.5 (-105) 

y1 -3.5 (-80) 

x2 4.5 (105) 

y2 3.5 (80) 

Height 1 (25) 

4 Click <Apply>. 

5 Click the close box in the lower-right corner of the dialog to close it and 
return to the Face Window. 

6 Click anywhere in the Face Window to make sure it is active. 
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View the Tool Information 
The tool library for the Mill tutorial has been created. 

1 Choose Open Tools File from the File menu. 

2 Open the Milldemo.tdb from the C:\PartMaker\PM-Mill directory as 
shown below by choosing Open Tools File from the File menu. 

3 Choose Tools from the ToolMinder menu to display the Tool Data dialog. 

4 Select the Tool ID T003 from the list shown on the right side of the dialog 
to view a graphic display of the tool and its characteristics. Each tool you use 
in PartMaker has a tool type name, material, and a unique tool ID, which 
are used by the cycles you create for machining. 

Notice that each tool picture corresponds to the selected tool type in the dialog. 

 

 Note: The tools used in this chapter are for the tutorial only. As you begin to 
use PartMaker, you will create your own tools database. 

Each tool has many parameters that need to be fully defined so that PartMaker can 
accurately program your parts. 

In the upper left-hand corner of the dialog is a pull down menu called Type. This 
menu is used to select the basic tool types. For milling operations, these types are 
typically:  Center, Spot Drill, Chamfer, Tap, and Ream…  

 
In a vertical column in the center of the dialog is a list of the parameters that are 
used to define the exact shape of the tool and its holder.  



 

Copyright @2014 Delcam Ltd  User Guide 3-7  

 

The color graphic to the left in the dialog box clearly describes most of the 
parameters as shown in the example below. 

 
The following list explains the remaining parameters: 

 Material: defines the cutting insert material, typically either HSS or 
Carbide. 

 Tool ID: A unique ID number that is used by PartMaker to keep track of 
the tools you have defined. 

 Tool No.: The number as it appears in the actual part program.  

 Comp No.: The tool nose radius compensation number used for the tool. 

 Offset No.: The offset register number used to define the length and 
diameter offset values for the defined tool. 

 Axial Step: Specifies the peck depth for drills, the roughing depths for end 
mills. Specifies step in the axial cutting to be used by the currently-selected 
tool. The programmer may change this value at any time during the 
programming process as needed. 

Below is a button labeled Verify Shape this button is used to display the 2 
dimensional shape of the tool defined by the user parameters.  The button labeled 
Shape Preview will display the 3 dimensional models of the tool and a holder if 
you have selected one. Press this button now to see the exact shape of the 31/32 
(23.5) Drill. 

 
Click on the Hide Shape button to close the dialog. 

Spindle Direction can be set to CW, CCW or None: 
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There are three other items of interest on this dialog for you to note before 
proceeding: 

By Selecting the Cutting Data button you can choose to use Speeds and Feeds 
calculated from the Material file or set as User Defined values. 

 

Once you are finished editing the tool information, select the Lock Parameters 
check box to disable all parameters for that particular tool. Each tool can be 
individually locked to prevent modification. 

 
When you are finished viewing tool information, click the <Close> button. 

View the Cycle Information 
You can view information about the boring and tapping cycles used for Milldemo in 
the Cycles dialog. 

PartMaker lets you combine a number of repetitive operations (center drilling, 
drilling, tapping, boring, etc.) into a single entity called a cycle. The Cycle 
information you create is saved in a Cycles Database for easy retrieval; reusing 
cycle information is as easy as opening a cycles file from the cycle’s database.  

1 Choose Cycles from the ToolMinder menu to display the Cycles dialog. 

2 Open the Milldemo.cdb (Milldemo_metric.cdb) from the 
C:\PartMaker\PM-Mill directory as shown below by choosing Open Cycles 
File from the File menu.  

The cycle you are viewing is indicated by the selected cycle name under List of 
Cycles. The Major Operation type is displayed for each cycle, as well as the 
Canned Cycle, Hole Diameter, Depth, and Tool ID. 
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3 Select BORE-1 (BORE-24) on the right side of the dialog to view the 
information for this cycle, which will be used in Milldemo.job 
(Milldemo_metric.job). 

 Note: If left blank, the Depth for each operation is calculated automatically 
by PartMaker. 

Cycle information for the BORE-1 cycle 

 
4 When you’re finished viewing cycle information, click the <Close> button or 

double-click the close box in the upper-left corner of the dialog to return to 
the Face Window. 

Select a Material for the Part 
Before you create the process table for Milldemo, you must select the type of 
material to be machined in the Open Material File dialog. Milldemo requires Free 
Machining Stainless Steel.  

PartMaker has a materials database from which you can select a variety of 
material types with different characteristics. A material database allows you to store 
your shop’s accumulated materials data. PartMaker uses this data for the 
automatic calculation of feedrates and spindle speeds. 

1 Choose Open Material File from the File menu to display the Open 
Material File dialog. 
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2 Locate and select ST_FMSTW (Free Machining Stainless Steel Wrought) from 
the list on the left side of the dialog, then click <OK>. (Refer to Appendix A 
for a complete list of materials.) 

You are returned to the Face Window. 

 Note: Sometimes the Face Window looses focus and its title bar becomes 
gray. You may find a number of menu commands being disabled (gray) if 
a front window is not active (not in focus). To make sure the Face 
Window is the active window, click its title bar. 

View the Material Characteristics 
In this section, you’ll view the characteristics of the material you selected with 
respect to feedrates and/or speed, and the operation type. 

The Material dialog lets you enter and/or change surface speed and feed information 
for each operation based on the currently open material file. For each material and 
operation, you enter data by dragging points on the graph (points are initially 
positioned on the X-axis of the graph). 

1 Choose Material from the ToolMinder menu to display the Material dialog. 

 
2 Click the <Feed> button to see how the feed varies for the currently 

selected operation. 

3 Click an Operation Type to see the feed for that operation. 

4 Drag a point on the graph in the dialog to see how you can change the feed 
for the selected operation. 

5 Double-click the close box in the upper-left corner of the dialog (on icon) to 
return to the Face Window. 
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Setting Defaults 
In this section, you’ll use the Defaults dialog to specify a Z depth of one inch for the 
three groups of holes in Milldemo. 

Since the tutorial is designed for a part using the inch mode, you must be sure that 
PartMaker is in the correct mode. To verify: 

Choose <Preferences> from the View menu to display the Preferences dialog.  
If the <Inch> button under Input Units is not selected, click the radio button to 
the left.  Click <OK> to close the dialog box. 

Default settings are used in the program generated for a part. Hole group 
parameters are used for each new group (cycle) you create. You can change 
Process Parameters at any time in the Process Parameters dialog (Process 
Parameters command in the Job Optimizer menu); you can change Part 
Boundaries at any time in the Setup dialog (Setup command in the View menu). 

1 Select <Defaults> from the Job Optimizer menu to display the Defaults 
dialog. 

 
2 Enter 1 (25) next to Z_Depth. 

3 Select Standard from the Coolant drop-down list in the dialog, and then click 
<OK> to return to the Face Window. 

Width of Cut:  Has two options;  “% Tool Diameter” and “Part Units”.  This 
facilitates direct input of Width of Cut in addition to % Diameter in Profile 
Group Parameters dialog for Milling. 

 Tip: The default button in all PartMaker dialogs is the heavily-outlined 
button (<OK> or <Apply>, for example). You can use the default button 
by clicking it or by pressing the <Enter> key. 
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Create Geometry  
There are two methods of creating Geometry in PartMaker. You can either import 
Geometry from a CAD file (method 1) or define Geometry using PartMaker's own 
CAD mode (method 2). If you want to use method 2 skip to the section called "Set 
up Part Boundaries." 

Method 1: Import Geometry from a CAD system via DXF file. 
To import Geometry for Milldemo, do the following:  

1 Choose Import > DXF File from the File menu to display Import DXF File 
dialog. 

 
2 Locate and select Milldemo.dxf (milldemo_metric.dxf), then click <Open>. 

 
Your screen should look like the illustration below. 
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Now that you have a drawing in the Face Window, take a few minutes to explore 
some of the basic features of PartMaker that you will be using in CAD mode. 

1 Click on the CAD/CAM Switch icon on the lower left hand side to switch to 
CAD mode (see picture above) 

The screen should appear as shown below. 

 
2 From the View menu, you have the following Zoom options available: 

 

 
Select Full View to expand the drawing to fill the screen 

 
Select Previous View to return the screen display to the previous 
setting. 

 
Select Zoom In and use any mouse button to drag opposite 
corners of a rectangle that you want to magnify.  

 Select Zoom Out to shrink the drawing on the screen 

 
Select Continuous Zoom to magnify the drawing at a steady rate. 
You can do this by pressing <Ctrl> and the <+> or <–> key 

 
Select Continuous Pan to move the drawing to the left or right at 
a steady rate. You can do this by pressing <Ctrl> and the 
directional keys. 

 

Select Zoom to Fit to create the smallest possible window that will 
contain all of the geometry, dimensions and notes in the current 
window 

 

Select Zoom All to create the smallest possible window that will 
contain all of the geometry, dimensions, notes and the boundaries 
in the current window. 

3 Select Show Axes to show the current X0 Z0 location. Select Hide Axes to 
turn them off again.  

4 Show and Hide Grid is used to display a user definable grid that can be 
used to locate convenient points on the screen.  

5 Show and Hide Boundaries is used to show the boundaries of the rough 
stock being turned.  

Depending on your needs, any or all of these display options may be activated at 
any time during the drawing (CAD) or programming (CAM) process. 
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Method 2: Create Geometry in PartMaker CAD 
Now that you are familiar with geometry imported via a DXF file, we will now show 
you how to create the geometry using PartMaker CAD functions. 

The method that we will demonstrate in the following pages will demonstrate how 
geometry can quickly and easily be created in PartMaker CAD.  It is recommended 
you try drawing the part to gain a fuller understanding of the capabilities of 
PartMaker CAD. 

1 First, create a new job by selecting New Job from the File Menu.  

2 Make sure you have setup your part defaults correctly as shown below.  
From the View menu, select Setup. 

 

To create the profile of the Milldemo part in PartMaker CAD, first make sure you 
are in CAD mode. You can switch between CAM and CAD mode by clicking on the 
button in the lower left-hand corner of the screen. 

 The button looks like this in CAM mode 

 
The button looks like this in CAD mode 
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The window displayed should be empty and appear as below: 

 

 Note: To view a white background, go to the View>Preferences menu 
option and select White under Face Window background drop down 
menu 

Now that you are in CAD mode you will want to show the X and Z axes as well as 
the boundaries of your part.  To do so, select the two buttons: 

 Show Boundaries 

 Show Axis. 

After doing so, your window should show the Z and X axes as well as the boundaries 
of your part as shown below. 

 
Once you begin drawing you may choose to hide the boundaries and axes. 
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Create Five Circles with Radius = 1" (25 mm) 
To do so: 

1 Select the Circle with a Known Radius and Center icon. 

2 When prompted to enter 1 (25) as the "r" value on the bottom of the screen, 
then press the <Enter> key. 

3 When snap mode icon bar appears, click the XY Coordinates Snap Mode 
icon.  

4 Enter the following coordinates for the circles centers, accepting the same 
radius value in between each entry that you entered in the step above by 
pressing <Enter>: 

Z value, X value: Inch Z value, X value: Metric 

0, 0 0, 0 

3, 2 75, 50 

3, -2 75, -50 

-3, 2 -75, 50 

-3, -2 -75, -50 

 Note: In PartMaker, you do not need to re-enter a numerical value that 
has not changed from the previous entry. 

The screen will look as shown below: 
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Create Four Tangent Lines 
1 Select the Line Thru Two Points icon. 

2 Select the Tangency Snap Mode icon. 

3 Click the cursor at locations 1 and 2 to create first line. 

4 Click the cursor at locations 3 and 4 to create a second line. 

5 Click cursor at locations 5 and 6 to create third line. 

6 Click cursor at locations 7 and 8 to create fourth line. 

 Note: The numbers on the illustration below indicate the location of the 
cursor clicks: 

The screen will look as shown below: 

 

 Tip:  If you make a mistake. use the Undo command from the Edit menu 
or select the geometry you wish to remove and press the backspace 
button.  
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Create Four Parallel Lines 
1 Select the Parallel Element Icon. 

2 When prompted enter 1 (25) as the "d" value on the bottom of the screen. 

3 Click on location 1, then on location 2 as indicated below. 

4 When prompted enter 2.5 (62.5) as the new "d" value at the bottom of the 
screen 

5 Click on location 3, then on location 4. 

The screen will look as shown below: 

 

Create Four Lines through Two Points 
1 Select the Line Thru Two Points Icon. 

2 Select the End of Element Snap Mode icon 

3 Click on locations 1 and 2 to create the first line. 

4 Click on locations 3 and 4 to create the next line. 

5 Click on locations 5 and 6 to create the next line. 

6 Click on locations 7 and 8 to create last line. 

The screen will look as shown below: 
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Remove Redundant Geometry 
1 Select the Remove icon. 

2 Click geometry to remove it so your image appears as below: 

 

Insert Fillets  
1 Select the Fillet icon. 

2 When prompted to enter 0.25 (6.25) as the "r" value on the bottom of the 
screen. 

3 Click the cursor inside of every sharp corner to insert a fillet. 

The screen will look as shown below: 
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Create Seven Circles Representing Holes 
1 Select the Circle with a Known Radius and Center Icon. 

2 When prompted to enter 0.5 (12.5) as the "r" value on the bottom of the 
screen. 

3 Select the Circle Center Snap Mode icon. 

4 Click the cursor at the center of the four outside arcs until the four circles are 
created. 

5 Next enter 0.25 (6.25) as the new “r” value. 

6 Select the XY Coordinates Snap Mode icon. 

7 Enter the following coordinates for the circle centers for X and Y respectively: 

Top circle: 0,  2.5 ( 62.5) 

Bottom circle: 0, -2.5 (-62.5). 

8 Next enter 0.125 (3.125) as the new "r" value. 

9 Enter 0.65, 0 (16.25, 0) for the center coordinates for the last circle and 
press <Enter>. 

The screen will look as shown below: 
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Create Bolt Circle 
1 Verify that the Selection icon is select and then click to select the small circle 

in the middle of the CAD drawing.  

2 From the Edit > Transform menu, choose the Rotate. A dialog will display 
as shown below: 

 
3 Click the Multiple Copies checkbox 

4 Enter 7 for No. of Copies. Click <Rotate> and then <Close>. 

5 Click anywhere in the Face Window to deselect circles. 

You should see a picture as shown below. 
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Creating Milldemo in PartMaker CAM Mode 
Now that you have created the geometry for Milldemo, you are ready to begin 
working in PartMaker CAM mode.  You are in CAM mode when the CAD/CAM switch 
in the lower left-hand corner of the screen looks appears as follows: 

 
For those of you who chose to create geometry via Method 2, you should select 
New Job from the File Menu.  Having done so, choose Import DXF file from the 
File Menu and choose Milldemo.dxf (Milldemo_metric.dxf) as in Method 1 to 
insure you are working with same drawing which will be shown in the pages to 
come. 

Before proceeding, your Face Window should appear as the one below, with your 
geometry shown as a gray outline on the screen: 

 

Save Your Work 
It is always advisable to save your work periodically as you program jobs in 
PartMaker.  To do so: 

1 Choose Save Job File As… from the File menu to display the Save Job File 
dialog. 

2 Enter the name TUTORIAL in the space provided. 

 
3 Locate and select the PartMaker directory, then click <SAVE>.  
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Define Group 1 Profiles for Face Mill Cycle 

1 On the color bar click Red.   

2 Choose New Profile Group from the Part Features menu to display the 
Profile Group Parameters dialog. 

3 Choose "Face Mill" from the Strategy drop-down menu.  

4 Enter 0 next in the Z_Depth (D) field. 

5 Enter 3.0 (76.0) under Diam (d). 

6 Choose Uni-Directional from the Tool Path Direction drop-down menu. 

 
7 Click the <Select Tools> button.  The Select Tool dialog will display as 

shown below: 
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You will now create a new Face Mill Tool.  To do so: 

1 Click on the Add button to create the 3 inch (76 MM) face Mill.  

2 Change the tool description to match the dialog below. 

 
3 Select <Apply> and <OK>. 

When you are finished the dialog box should appear as the one shown below. 

 
4 Enter Face_3 (Face_76) in the Group Name field. If you do not name a 

milling cycle, PartMaker will give it a default name when you close the dialog 
box. 

5 A group icon is displayed in the upper left corner of the face window in the 
Job Explorer Tree as shown: 

 

6 Click the <Close> button. 
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A tool path is automatically created for you. Your screen will appear as below: 

 

Verify Face Tool Path  
1 Select the Verify Work Group Tool Path command from the Part Features 

menu.  

2 Set options to match the dialog shown below and click <OK> 

 
You will see a picture as below: 

 
3 Select the Hide Every Tool Path command from the Part Features menu. 
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Define Group 2 Holes for the Boring Cycle 
The first operation in Milldemo is to Bore four 1.0” (25 mm) diameter holes. 

1 Click anywhere in the Face Window to make it active. 

2 Click the blue square in the Color Bar   

3 Choose New Hole Group from the Part Features menu to display the 
Profile Group Parameters dialog.  

 
4 From the Major Cycle Operation menu, select Bore 

5 Enter 1 (25) in the Diameter (d) field for the major hole diameter. 

6 Enter .05 (2) in the Chamfer (c) field  
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7 Click the <Cycle> button and select the Bore-1 (Bore-25) cycle. 

 

 PartMaker finds the appropriate cycle in the database Bore-1 (Bore-25). 
Tool information for the cycle is displayed at the bottom of the dialog when 
the appropriate cycle is found. If there is more that one cycle that matches 
the Major operation and Diameter you can check each one to see the tool 
information for that cycle.  The dialog box should appear as shown below.  
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To verify the hole shape, click the Verify Shape button; click the Hide Shape 
button under the picture to hide the hole shape and return to the dialog. 

 
8 Click on the Edit Cycle button in Hole Group Parameters dialog to access the 

selected cycle. Only the selected cycle will be available for modification, any 
changes that are made will automatically update the Hole Group Parameters. 

 

9 Select the drop down menu for the 31/32 drill and you will see options for 
the drilling cycle. 

 
By selecting the Edit Hole Operations button to the right of the Tool ID field 
you can review and modify the parameters for this type of operation. 
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 Output Hole Canned Cycle — This option is selected by default so the 
machining operation for the hole is output as a canned cycle in the NC 
Program file. If your postprocessor does not support all of the parameters 
for this canned cycle, deselect this option. 

10 When you are satisfied that you have correctly defined the Group 
Parameters, Close the dialog. 

A Blue square displaying the group name BORE-1(BORE-25) appears in the upper 
right corner of the Face Window as shown below. The square is a group icon. Each 
part you create in PartMaker will display one or more group icons in the Face 
Window to indicate the various machining cycles for a part. 
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Hole Creation Method  
The icons (called Snap Modes) at the top of the Face Window represent various 
ways of defining locations such as hole center. In the next several sections of the 
tutorial, you’ll use some of these methods to define holes for TUTORIAL. 

Using the Single Hole icon and a Snap Mode, you can define single holes by X,Y 
coordinates, polar coordinates, a point on an arc or circle, a screen location, a grid 
location, a circle center location, the closest intersection an endpoint of a line, or a 
midpoint of a line. 

Single Hole Icon Snap Modes 

 

 Note: The Snap Modes are used with the Single Hole icon only. 

You can define multiple holes quickly using the Chain Circle icon. 

Specifying Holes Using the Chain Circle Icon 
1 Select the Chain Circles Geometry icon on the left side of the CAM Face 

Window. 

2 Click on any of the four 1 inch (25 mm) diameter bored holes. Your Face 
Window should appear as shown below: 

 
Since all of the holes were defined at the same time, they all remain selected in the 
Face Window. You can click anywhere in the Face Window to deselect holes. 

Save Your Work 
Choose Save from the File menu or press <CTRL + S>. 
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Define Group 3 Holes for the Tapping Cycle 
In this section, you’ll specify the holes for Group 2, the tapping cycle. Notice that 
PartMaker accepts fractions or decimal values in any dialog. 

1 Click the Red color square in the color bar at the top of the Face Window to 

specify the color for the new group.   

2 Choose New Hole Group from the Part Features menu to display the Hole 
Group Parameters dialog. 

3 Choose Tap from the Type pop-up menu. 

4 Turn off the Through Hole check box. 

5 Enter 1/2   (12.5 mm) next to the Diameter option. 

6 Enter 0.05 (2mm) for the Chamfer value. 

7 Enter 0.5 (12.5 mm) for the Nominal Depth value. 

8 Select Shoulder of Major Tool for the depth. 
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9 Click the <Cycle> button and select the Tap ½ (Tap-12.5) cycle. 

 
When you are done your screen should appear as below. 

 
10 To verify the shape of the hole, click the <Verify Shape> button; click the 

<Hide Shape> button under the picture to return to the dialog.  
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A group icon for Group 3 displays in the upper-right corner of the Face Window 
under the Bore-1 group icon. The group name Tap-1/2 (Tap-12.5) appears to 
the right of the group symbol. 

 

11 Click the <Close> button to exit the dialog and return to the Face Window.  

Specify Holes Using a Chain Circles Icon 

1 Select the Chain Circles icon (fourth from the bottom) on the left side of the 
Face Window. 

2 Click the cursor at the location shown below. Holes are automatically created 
in the centers of the 2 circles. 

 

Save Your Work 
Choose <Save> from the File menu. 
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Define Group 4 Holes for the Reaming Cycle 
In this section, you’ll specify the holes for Group 3, the reaming cycle. 

1 Click the Yellow color square in the color bar at the top of the Face Window 

to specify the color for the new group.   

2 Choose New Hole Group from the Part Features menu to display the Hole 
Group Parameters dialog. 

3 Choose Ream from the Type drop-down menu. 

4 Enter .25 (6.25mm) next to the Diameter option. 

5  Enter 0.05 (1mm) for the Chamfer option. 

 
6 Click the <Cycle> button and select the Ream-1/4 (Ream-6.25) cycle. 
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7 When you are done your screen should appear as below. 

 
8 To verify the shape of the hole, click the <Verify Shape> button; click the 

<Hide Shape> button under the picture to return to the dialog. 

 
9 Click the <Close> button to exit the dialog and return to the Face Window. 

10 The group icon for the Ream-1/4 (Ream-6.25) cycle appears on the right 
side of the Face Window. 

 

 Note: If a group icon appears with a question mark (?) instead of a name, 
it means that you didn’t specify the correct operation or diameter in the 
Hole Group Parameters dialog. If this happens, you can choose the Group 
Parameters command (Part Features menu) to check the diameter or 
use the Cycle button in the dialog to select a new cycle. If this group is 
not wanted you can right mouse click on it and select Delete Group or 
select the Delete Group on the CAM mode tool bar.  
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Specify Holes Using a Chain Circles Icon 

1 Select the Chain Circles Icon (fourth from the top) on the left side of the 
Face Window.  

2 Click the cursor at the location shown below. Holes are automatically created 
in the centers of the 8 circles. 

 

Save Your Work 
Choose <Save> from the File menu. 
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Define Group 5 Profiles for Pocket Mill Cycle 

1 On the color bar click magenta.     

2 Choose New Profile Group from the Part Features menu to display the 
Profile Group Parameters dialog. 

3 Choose "Pocket Mill" from the Strategy drop-down menu.  

4 Enter 0.5 (12.5) next in the Z_Depth field. 

5 Enter 0.5 (12.5) under Diam (d). 

6 Enter 30 in the Width of Cut field. 

7 Select the Toolpath Direction you prefer from the drop down menu. 

 

8 Click the <Select Tools> button. Select tool T009 in the database. 
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9 When you are finished the dialog box should appear as the one shown below. 

 
10 You can enter a name in the Group Name field. If you do not name a milling 

cycle PartMaker will give it a default name when you close the dialog box, as 
shown below.  

11 A group icon is displayed in the upper right corner of the face window under 
the Ream-1/4 (Ream-6.25) group symbol icon. The default group name 
Pocket_0.5 (Pocket_12.5) appears to the right of the group symbol. 

 
12 Click the <Close> button. 
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Profile Creation Methods 
There are two methods to creating profiles: Define Profile and Chain Geometry. 

Using the Define Profile icon and a Snap Mode, you can define a profile by 
connecting points defined by X,Y coordinates, polar coordinates, a point on an arc or 
circle, a screen location, a grid location, a circle center location, the closest 
intersection and endpoint of a line, or a midpoint of a line. 

 
  

Using the Chain Geometry icon you can define a profile by selecting an endpoint of 
a line or an arc. PartMaker automatically finds all lines and arcs that are connected 
together. 

This command allows you to enter coordinates for either approach or escape point 
for a selected profile. 

Create Profiles Using Chain Geometry Icon  
1 Select the Chain Geometry icon on the left side of the Face Window. Click 

the cursor on the location shown on the screen below. A profile is 
automatically created. 

 
2 Select the Chain Geometry icon on the left side of the Face Window 

again. Click the cursor on the screen corresponding to the pocket on the 
right side of the illustration. Another profile is automatically created. 
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Verify Pocket Tool Path 
1 Select the Verify Work Group Tool Path command from the Part 

Features menu. You will see a picture as below.  

 
2 Select the Hide Every Tool Path command from the Part Features menu. 
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Define Group 6 Profiles for Contour Mill Cycle 

1 On the color bar click green.   

2 Choose New Profile Group from the Part Features menu to display the 
Profile Group Parameters dialog. 

3 Choose Contour Mill from the Strategy drop-up menu. 

4 Enter 1.05 (25)  in the Z_Depth field. 

5 Enter 0.5 (12.5) in the Diam(d) field. 

6 Under Operations group, uncheck Roughing and check Finishing 

7 Click the <Select Tools> button. Select tool T009. 

 
When you are finished your dialog box should appear like the one below: 

 
8 You can enter a name in the Group Name field containing "?". If you do not 

name a milling cycle PartMaker will give it a default name as shown below. 

9 A group icon for Group 6 is displayed in the upper right corner of the Face 
Window under the Pocket_0.5 (Pocket 12.5) group icon. The default group 
name Contour_0.5 (Contour_12.5) appears to the right of the group symbol. 

 
10 Click the <Close> button. 
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Create Profiles Using Chain Geometry Icon 
1 Select the Chain Geometry icon on the left side of the Face Window. 

2 Click the cursor on the outside profile of the following illustration. A profile is 
automatically created. 

 

 Note: The profile shows direction arrows. This means it is selected and can 
be reversed, translated or rotated. 

Verify Contour Tool Paths 
1 Select the Verify Work Group Tool Path command from the Part 

Features menu. You will see a picture as shown below.  

 
2 Select the Hide Work Group Tool Path command from the Part Features 

menu.  

 Note: Group symbols can be dragged and dropped to change the order of 
machining.  
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Generate a Process Table 
A process table shows you all of the processes for a part. Before generating a 
process table, you can choose to reorder processes automatically by tool diameter 
(smallest to largest) and/or reorder them to minimize tool change time and optimize 
machining. 

When PartMaker generates a process table, all cutting conditions such as feed rate 
and spindle speed RPM are calculated automatically based on the tools and material 
information.  

1 Choose Generate Process Table from the Job Optimizer menu to display 
the Process Table Options dialog. The dialog box should look like the picture 
below. 

 
2 Click <OK> to display the process table window. 

PartMaker generates and displays the Process Table as shown below: 

 

 Tip: If tool numbers are not in the proper order, you can choose 
Renumber Tools from the Job Optimizer menu to automatically 
renumber the tools before generating an NC part program. 
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Modify the Spindle Speed 
Process 1 is used on all holes in TUTORIAL.JOB . In this section, you’ll change the 
spindle speed (RPM) used for this process. 

1 Click anywhere on the second process line in the process table window. The 
line is highlighted in blue as shown below. 

 

 Note: Red triangles appear on the left side of the process table window. To 
move a selected process in the table, click a triangle—it will become the 
new location for the selected process. If you make a mistake when 
moving a process in the table, choose Undo from the Edit menu to move 
it back to its original position. 

2 Double click on this process or choose Process Parameters from the Job 
Optimizer menu to display the Process Parameters dialog. 

3 Enter 3000 next to Spindle RPM as shown below. 
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4 Check the box for Lock Feeds and Speeds. 

5 Click <OK> to return to the Process Table. 

Compare the second line of the process table to the previous illustration to 
see the change. 

 

 Tip: Practice selecting and modifying other processes. If you want to 
remove a process from simulation and simply un-check the box ate the 
right of the process. This un-checked process will not simulate or be used 
to generate NC code. If you want to delete a selected process, choose 
Delete from the Edit menu or press the <Delete> key. You can undo a 
command by choosing Undo from the Edit menu immediately. 
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Simulate the Process 
Once you are satisfied with the appearance of your Process Table you can simulate 
cutting. 

1 From the Process Table, click the Simulate in the lower left hand corner of 
the Process Table or just press the <Space Bar>.  

2 When the simulation Window appears, press the <Space Bar> or choose 
Simulation from the Simulate menu to initiate 3D simulation.  Your 
completed part should appear as shown below: 
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Generate an NC Program 
1 Choose Post Config File= ? From the Job Optimizer menu to display the 

Open Post Configuration File dialog. 

2 Locate and double-click POSTLIB to open the Post Configuration file. 

3 Select the DEMO.PST postprocessor, and then click <Open>. 

 

 Tip: If you use the same .PST file all the time, move it from POSTLIB (the 
post processor library) to your working directory/folder where it will be 
loaded automatically when you generate an NC program. 

4 Choose Generate NC Program from the Job Optimizer menu to display the 
Save NC Program dialog. When you generate an NC Program for the first 
time during a programming session the Post Options dialog is displayed 
before the Save NC Program dialog. 

 
5 Choose the Post Options you prefer. If you leave Block Increment at zero 

there will be no sequence numbers in your part program. Click <OK> to 
proceed to the Save NC Program dialog: 
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6 Enter the name TUTORIAL.TXT for the NC program, then click <Save> to 

generate the NC Program. 
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Chapter 4: PartMaker® Simulation 
Introduction  

PartMaker Versions 5.0 and higher come standard with an integrated 3D solid 
modeling process simulation and verification module.  The purpose of simulation is 
to let you visualize all the processes as ordered on PartMaker’s Process Table. You 
should run Simulation after the Process Table is arranged to your liking. 

PartMaker’s integrated process simulation module allows you to: 

 Simulate all machining processes as they appear on the Process Table 

 Observe the results of any process reordering 

 Examine a solid model of the part through dynamic rotation and cross-
sectioning 

Using PartMaker Simulation 

PartMaker Simulation can be viewed at any point in the programming process.  You 
need not complete programming a part to see the results of your work. 

 Important! To launch PartMaker Simulation you must have a Process Table 
generated.  To generate the Process Table, choose Generate Process 
Table from the Job Optimizer menu.  It is not necessary to complete 
synchronization of simultaneous operations before launching PartMaker 
Simulation. 

Launching Simulation 
To launch PartMaker Simulation: 

1 Press the Simulation button in on the Main tool bar. 

or 

Press the Simulation button in the lower left hand corner of the Process Table 

or 

Choose Basic Simulation or Full Machine Simulation from the Simulation 
menu 

Upon launching simulation, you will see an uncut work piece and the machining 
table that has been defined. A newly launched simulation window is shown below: 
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Running Simulation 
Once you have launched PartMaker Simulation, to start machining: 

2 To start Simulation press the Start Simulation button.  

or 

Choose Start Simulation from the Simulation menu 

or 

Press the <Space Bar> on your keyboard 

Once simulation has started, you can suspend cutting be pressing the Pause or the 
<Esc> button on your keyboard.  

Below, is an example of suspending Basic simulation in progress: 

 

Below, is an example of suspending Full Machine simulation in progress: 
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The Simulation Toolbar 
Many of the common functions used in PartMaker’s 3D simulation can be accessed 
via the Toolbar that appears at the top of the Simulation Window as shown here: 

 

Each icon on the Simulation Toolbar is explained below.  The features each of 
these icons enable will be explained in greater depth throughout this chapter. 

 
Starts the simulation 

 
Pauses the simulation 

 
Resets the simulation 

 
Shows the finished 3D model of the part 

 
Allows the user to measure the completed part. 

 
Automatically arranges the milling Stock to fit on the table 

 
Allows the user to change stock position interactively 

 
Allows basic Simulation 

 
Allows Full Machine Simulation 

 
Allows you to take cross sectional views of the completed part 

 
Allows you to show a full view of a part after sectioning 

 
Allows you to manipulate the view of machined part 

 
Allows you to see the Simulation Options dialog 
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Simulation Features 
PartMaker Simulation has a number of process and part analysis features available 
both during and after process simulation is complete.   

These features are described here: some of these features are not available in 
PartMaker Mill.  

Reset 
At any point you can reset the simulation to the initial screen by choosing Reset 
from the Simulation menu.  Alternatively, if you have suspended Simulation by 
pressing <Esc>, you can press <Esc> again to reset the simulation. 

The Reset command is also accessible by clicking the right mouse button when 
viewing the finished part (see below). 

Show Travel Limits 
Displays the travel limits for machine being simulated for each machine component 
depending on how the machine is equipped.  Travel limits for each machine 
components including main spindle, sub spindle and tool posts are set in the 
Machine Date File dialog accessed from the ToolMinder menu. 

Show Finished Part 
By choosing the Show Finished Part command from the Simulation menu, you 
can see a 3D model of your programmed part.  You need not run the simulation 
prior to choosing Show Finished Part.  

When choosing Show Finished Part, the verified part alone will appear in the 
Simulation window as shown here: 

 

Save Finished Part As STL file 
This will save the finished part to an STL file format.  This can be then used again in 
PartMaker for Custom Stock or Surface Machining. 
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Compare Finished Part to Solid Model 
This will use the solid model specified in the Comparison Options Dialog to show 
a comparison of the part to the solid model. 

 

Comparison Options 
This will open the Comparison Options dialog.  This allows you to specify the 
comparison models as well as the over and undercut display colors. 

View Setting Features 
PartMaker Basic Simulation allows you to automatically set a variety of views when 
simulation has been halted by using the <Esc> key or when using the Show 
Finished Part command.  Various view orientations are available from the View 
sub-menu under the Solids menu. 

Default 
Choosing Default sets the view in the simulation window to the default view when 
Simulation was launched. 

Best Fit 
Choosing Best Fit sets the view in the simulation window to the best fit relative to 
the Simulation window as determined automatically by PartMaker. 

XY View 
Choosing the XY View command sets the view in the simulation window normal to 
the cross sectional plane formed by XY axes.  The axes along which the part is 
defined are constantly active in the lower left hand corner of the simulation window. 

YZ View 
Choosing the YZ View command sets the view in the simulation window normal to 
the cross sectional plane formed by YZ axes.  The axes along which the part is 
defined are constantly active in the lower left hand corner of the simulation window. 
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ZX View 
Choosing the ZX View command sets the view in the simulation window normal to 
the cross sectional plane formed by ZX axes.  The axes along which the part is 
defined are constantly active in the lower left hand corner of the simulation window. 

Isometric View 
Choosing the Isometric View command sets the view in the simulation window 
aligned to the X, Y and Z axes.  This view presents the part at a 45 degree angle. 

Show Coordinate Axes 
Checking this selection on allows the user to the axes symbol in lower left hand 
corner of PartMaker Simulation Window. 

Show Finished part Origin 
This will hide or show the 3-D axis on the finished part. 

Show Coordinate axis 
This will hide or show the 3-D coordinate system axes in the lower left hand side of 
the simulation window. 

Background Color 
Allows the user to choose the background color of the simulation.  The background 
may be set to gradient by choosing different colors for the Top and Bottom Gradient 
Color respectively. 

Datum Color 
Sets the color of each axis of the datum, X, Y and Z respectively. 
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View Manipulation Features: Rotate, Move and Zoom 
PartMaker simulation allows you to manipulate the view of either the entire process 
simulation or the finished part (when using Show Finished Part).  When using 
PartMaker, one of these commands will be activated, as denoted by a check next to 
it under the Change View sub menu under the Simulation menu.   

Whenever the Rotate, Move or Zoom command is checked, it can be activated by 
holding down the left mouse key and moving your mouse.   

It is advisable to always leave the Rotate command checked as both Move and 
Zoom can always be accessed using keyboard shortcut keys or the mouse.  For 
example, if the Rotate command is checked under the Change View sub menu 
under the Simulation menu, Rotate can be activated by clicking the left mouse 
button and moving the mouse, Move can be activated by holding down the mouse’s 
scroll wheel and moving the mouse and Zoom can be activated by simply scrolling 
the mouse’s scroll wheel. 

PartMaker provides fully dynamic simulation such that the Rotate, Move and Zoom 
commands can be accessed at any time during simulation. 

Rotate 
This command allows you to dynamically rotate the entire process simulation within 
the simulation window.  When using Show Finished Part, Rotate allows you to 
dynamically rotate the solid model of the completed part.   

When Rotate is active, you can rotate the process simulation or finished part by 
clicking the left hand mouse button and dragging your mouse in the orientation you 
would like to see the view. 

Rotate may only be used when it is activated from the Solids menu.  You can 
activate Rotate by choosing it from the Solids menu.  Its activation is denoted by a 
check next to it under the Simulation window. 

Move 
This command allows you to dynamically move the entire process simulation around 
the simulation window.  When using Show Finished Part, Rotate allows you to 
dynamically rotate the solid model of the completed part.   

When Move is active, you can move the process simulation or finished part by 
clicking the left hand mouse button and dragging your mouse in the direction you 
want to move the view.   

You can move the view if Move is NOT active by holding down the <Ctrl> + 
<Arrow> keys on your keyboard, with arrows denoting the direction in which the 
view will move.  These are the same keys used when performing panning in 
PartMaker. 

Additionally, Move can always be activated using the mouse by holding down the 
mouse wheel (if your mouse is so equipped) and dragging your mouse in the 
direction you want to move the view. 

You can activate Move by choosing it from the Solids menu.  Its activation is 
denoted by a check next to it under the Simulation window. 

Zoom 
This command allows you to dynamically size the entire process simulation within 
the simulation window when it has been halted by using the <Esc> key.  When 
using Show Finished Part, Zoom allows you to dynamically size the solid model of 
the completed part.   
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When Zoom is active, you can scale the process simulation or finished part by 
clicking the left hand mouse button and dragging it upward to increase the size of 
the part and dragging downward to decrease the size of the part.   

You can scale the view if Scale is NOT active by pressing the <F4> key to decrease 
the size of the view or the <F5> key to increase the size of the view.  These are the 
same keys used when performing Continuous Zoom In or Zoom Out in 
PartMaker. 

Additionally, Scale can always be activated using the mouse by scrolling the mouse 
wheel (if your mouse is so equipped) upward to zoom in and downward to zoom 
out. 

Sectioning Features 
PartMaker simulation allows you to section the solid view to inspect the interior of 
the part. Various sectioning options by choosing Sectional View from the 
Simulation menu.  Choosing Sectional View opens the Section Finished Part 
dialog as shown below: 

 
1 Sectioning Plane – The Sectioning Plane section of this dialog allows you to 

determine the plane across which sectioning will occur normal to. The use 
can section a finished part normal to the XY, ZY and ZX plane. The axes 
along which the part is defined are constantly active in the lower left hand 
corner of the simulation window.  

2 Dynamic Sectioning – Checking this box enables dynamic section, or the 
ability to see the part being sectioned as you adjust the location of the 
sectional plane.  If Dynamic Sectioning is unchecked, , you will be able to see 
the result of your sectioning by clicking the <Preview> button or by exiting 
this dialog by clicking <OK> 

3 Plane Coordinate - This area of the dialog allows you to adjust the level of 
the sectioning plane. 

4  Reverse Direction - This allows you to reverse the direction of sectional 
plane shown. 
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Simulation Options 
You can manipulate the appearance of simulation by choosing Options from the 
Simulation menu or by clicking the right mouse button in the Simulation Window 
and choosing Options.   

PartMaker Simulation allows you to change the appearance of the view in the 
simulation window when simulation has been halted by using the <Esc> key or 
when using the Show Finished Part command.   

The Options dialog as it appears in Basic Simulation for PartMaker Turn-Mill is 
displayed below: 

 

Pause On  
Never: Specifies that simulation should never pause during simulation 

Eject: Specifies that simulation should pause before part eject operation is 
performed 

Cut-off: Specifies that simulation should pause after the cut-off operation is 
performed 

Every Process: Specifies that simulation should pause at the beginning of every 
process in the current Process Table 

Selected Process: Specifies that simulation should pause at the beginning of a 
selected process in the current Process Table 

Every Move: Specifies that simulation should pause before every tool move 

Tool Collision: Specifies that simulation should pause every time a collision 
occurs 

Tool Overtravel: Specifies that simulation should pause every time tool post 
goes outside of its travel limits specified in the Machine File. 
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Settings 
Turning Insert Thickness: Specifies the thickness of the turning insert 
Max ID Tool Holder Thickness: Specifies the maximum thickness of a tool 
holder for inside diameter tool. 

Enable Collision Checking/Report Collision Types 
Checking the Enable Collision Checking box allows you to detect the following 
collision types in Simulation: 

Tool with Stock(s) on Rapid Move: Specifies that PartMaker should check for 
collisions between the tool (or insert) and that stock in the main spindle as well 
as a part in sub-spindle 

Tool with GB and/or Sub-Spindle: Specifies that PartMaker should check for 
collisions between the tool (or insert) and the Guide Bushing and/or Sub-Spindle 

GB and Sub-Spindle: Specifies that PartMaker should check for collisions 
between the Guide Bushing and Sub-Spindle. 
Tool Holder Collision: Specifies that PartMaker should check for Tool Holder 
collisions with any part/stock as well as with the Main Spindle and Sub-Spindle 

Tool with Foreign Stock: Specifies that PartMaker should check for collisions 
between the tool (or insert) working on the Main Spindle with part in the Sub-
Spindle or between the tool (or insert) working on Sub-Spindle with the stock or 
part in the Main Spindle 

Tool with Tool: Specifies that PartMaker should check for collisions between two 
tools on the machine. This is for Advanced an Full Machine simulations only. 

Tool with Toolpost: Specifies that PartMaker should check for collisions between 
a tool and another tool post on the machine.  This is for Advanced and Full 
Machine simulations only. 

Toolpost with Toolpost: Specifies that PartMaker should check for collisions 
between tool posts on the machine.  This is for Advanced and Full Machine 
Simulations only. 

Toolpost with Stock: Specifies that PartMaker should check for collisions 
between a tool post and the stock being machined.  This is for Advanced and Full 
Machine Simulations only. 

Toolpost with Spindle:  Specifies that PartMaker should check for collisions 
between a tool post and the main or sub spindle.  This is for Advanced and Full 
Machine Simulations only. 

Non-Active Tool with Spindle:  Specifies that PartMaker should check for 
collisions between a tool not in the cut and the main or sub spindle.  This is for 
Advanced and Full Machine Simulations only. 

Non-Active Tool with Stock:  Specifies that PartMaker should check for collisions 
between a tool not in the cut and the stock.  This is for Advanced and Full 
Machine Simulations only. 

Tool with Machine Housing:  Specifies that PartMaker should check for collisions 
between a tool (or insert) and the machine housing.  This is for Full Machine 
Simulation only. 
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Display Control  
Time Delay (0...9): Specifies a time delay following every screen update for every 
tool motion.  Negative number -9 to -1 may also be used to speed simulation 
more then 0. 

Transparency of GB/Sub-Spindle: Specifies how transparent the Main Spindle 
and/or Sub-Spindle should appear. 0% means solid appearance, 100% means 
‘fully transparent’ appearance, i.e. the Guide Bushing and/or Sub-Spindle will 
become invisible. 

Transparency of Stock/Part: Specifies how transparent the part and/or stock 
should appear. 0% means solid part, 100% means "fully transparent" part, i.e. 
an invisible part. 

Display Status: Specifies that the current simulation status consisting of the 
Process ID and current Tool Point coordinates will be displayed on the top of the 
Simulation window 

Run in a Loop: Specifies that Simulation will run in a continuous loop 

Hide Tool Holders:  Specifies that Tool Holders for Turning Tools will not be 
displayed during Simulation 

Display Status:  Allow the Simulation to display coordinate and movement 
information at the top of the simulation window. 

Cosmetic Thread: Specifies that during Simulation every Multi-Pass helical 
thread will be replaced by a single pass in order to speed up simulation. 

Software Rendering: Specifies that Open GL software graphics libraries should 
be used instead of the hardware implementation of the Open GL drivers that are 
dependent on the actual Graphics Video card used in every computer. If you use 
a high performance AGP video card you may achieve a significant simulation 
speed improvement if you do not use Software Rendering 
Wireframe Display: Specifies that everything will be displayed using a wire 
frame representation instead of solid modeling. 

Show Tool Numbers on Tool Posts:  This will show all tool numbers available 
on a tool post on the solid for that tool post.  This is for Advanced Simulation 
only. 

Show Machine Housing:  This will show the Machine Housing Components 
specified in the Machine File. This is for Full Machine Simulation only. 
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Display Quality 
Coarse: Specifies that solids will be displayed using relatively large facets to 
assure the fastest simulation 

Medium: Specifies that solids will be displayed using medium size facets that will 
result in lesser simulation speed 

Fine: Specifies that solids will be displayed using very small size facets that will 
result in further decrease in simulation speed 

Apply to All Machine Components: Specifies that solid models will be 
converted to simulation models with the specified Display Quality (Coarse, 
Medium, Fine), regardless of the quality specified in its model data.  These solid 
models can include custom stocks and tool posts. 

Colors and Textures 
Use Group Colors: Specifies that user-defined Group Colors will be used as cut 
colors. If this option is not checked a metallic gray color will be used as cut color 
for all tools 

Set Stock Color: Allows a user to choose the color of initial stock using a 
Windows standard dialog. 

Set Stock Texture: Opens the Texture Dialog for various texture options for 
the stock. 
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Appendix A:Materials 
PartMaker Material Library 

This appendix contains a list of all material files and their abbreviations. 

 

File Description 

ALU_ALLC.MDB Aluminum Alloy, Cast 

ALU_ALLW.MDB Aluminum Alloy, Wrought 

CARBIDES.MDB Machinable Carbides  

CHNICKEL.MDB Chromium-Nickel, Alloy 

COP_ALLC.MDB Copper Alloy, Cast  

COP_ALLW.MDB Copper Alloy, Wrought 

IRON_DUC.MDB Ductile Iron, Cast  

IRON_GRC.MDB Gray Iron, Cast 

LEADALLC.MDB Lead Alloys, Cast  

MAG_ALLC.MDB Magnesium Alloys Cast 

MAG_ALLW.MDB Magnesium Alloys Wrought 

NICKELWC.MDB Nickel Alloys, Wrought and Cast 

ST_ALLOW.MDB Alloy Steels, Wrought 

ST_CARB.MDB Carbon Steels, Wrought 
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File Description 

ST_FMCAW.MDB Free Machining Carbon Steel, Wrought 

ST_FMSTW.MDB Free Machining Stainless Steel, Wrought 

ST_STAIC.MDB Stainless Steel, Cast 

ST_STAIW.MDB Stainless Steel, Wrought 

ST_STRUW.MDB Structural Steels, Wrought  

ST_TOOLW.MDB  Tool Steel, Wrought 

THERMOPL.MDB Thermoplastics 

TIN_ALLC.MDB Tin Alloys, Cast 

TIT_ALLC.MDB Titanium Alloys, Cast 

TIT_ALLW.MDB Titanium Alloys, Wrought 

ZINCALLC.MDB Zinc Alloy Cast 
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Appendix B: Included Post 
Configuration Files  
PartMaker Post Library 

PartMaker software package includes a library called POSTLIB that contains sample 
Post Configuration Files (called Config files below) for a variety of popular CNC 
machines. 

You can use the ConfigPost application to customize and create additional Config 
files for CNC machines in your shop. PartMaker uses a Config file as a template to 
convert the Process Table into a part program file according to CNC machine 
guidelines. This conversion step is called "Post Processing". 

Part programs produced when using these Config files can be fully verified with N-
See verification software unless otherwise stated below. 

All Config files are distributed with the Macro (Subroutines) option disabled in the 
General Info section. Customization of ConfigPost's Macro Related Formats may be 
required because of a great variety of macro calling conventions and user's 
preferences. 

If it is stated below that Milling and Drilling Macros (subroutines) are supported, 
they can be enabled in ConfigPost's General Info Dialog. 

Inch Post Configuration Files 

1 AB8200.PST 

 Sample Config file for Allen Bradley 8200 control. 

 Cutter diameter compensation is supported. 

 Multiple fixture numbers H1,H2... are supported.  

 Enter the fixture number in PartMaker Faces Dialog in the Work Offset field. 

 Milling Macros (subroutines) are supported.  

 Drilling Macros are not supported. 

 Milling Macros can be enabled in ConfigPost's General Info Dialog. 

2 ACRA850.PST 

 Sample Config file for Vickers Acramatic 850 control as found on the Arrow 
mill (and others). 

 Arc centers are absolute 

 Multiple fixture offsets are supported 

 Cutter diameter compensation is supported 

3 ACRA1000.PST 

 Sample Config file for Acramatic controls 10H, 10HC-1000/1500/2500 ("Big 
Blue") 

 Single quadrant circular interpolation 

 Vector type (P,Q) cutter diameter compensation is supported 

 Consult PartMaker Inc. regarding availability of a translator to fully verify NC 
programs generated for this control. 
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4 ACRA2100.PST 

 Sample Config file for Vickers Acramatic 2100 control 

 Arc centers are absolute 

 Multiple fixture offsets are supported 

 Cutter diameter compensation is supported 

5 ANILAM14.PST 

 Sample Config file for Anilam 1400 control on a mill with an automatic tool 
changer 

 Arc centers are always absolute 

 Multiple work offsets are supported 

 Uses M6 for tool change command 

6 1400-1.PST 

 Sample Config file for Anilam 1400 control on a mill with a manual tool 
changer 

 Arc centers are always incremental 

 Multiple work offsets are supported 

 Uses M6 for tool change command 

7 BOSS4A.PST 

 Sample Config file for Bridgeport BOSS4,5 controls.  

 Uses single quadrant circular interpolation with unsigned I,J values. 

 Cutter diameter compensation is not supported. 

8 BOSS6.PST 

 Sample Config file for Bridgeport BOSS5,6,7 controls.  

 Cutter diameter compensation is supported. 

 16 Milling Macros (subroutines) are supported.  

 Drilling Macros are not supported. 

 Milling Macros can be enabled in ConfigPost's General Info Dialog 

9 BOSS10.PST 

 Sample Config file for Bridgeport BOSS8,9,10 and new BOSS10 compatible 
controls.  

 Cutter diameter compensation is supported. 

 99 Milling Macros (subroutines) are supported.  

 Drilling Macros are not supported. 

 Milling Macros can be enabled in ConfigPost's General Info Dialog. 

 M3 / M4 and M5 are not output for spindle control. If these codes are 
required, then use the DX32.PST 

10 CRUSAD-G.PST 

 Sample Config file for Anilam Crusader-G mill 

 Cutter diameter compensation is supported 
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11 CRUDSAD-M.PST 

 Sample Config file for Anilam Crusader-M mill 

 Cutter diameter compensation is supported 

12 DEMO.PST   

 Functionally the same as Fanuc.pst. Additional comments included to further 
illustrate how ConfigPost can be used to improve NC program format. 

13 DX32.PST 

 Sample Config file for Bridgeport DX32 and new BOSS10 compatible controls 
that require M3 / M4 and M5 to activate the spindle. 

 Cutter diameter compensation is supported. 

 99 Milling Macros (subroutines) are supported.  

 Drilling Macros are not supported. 

 Milling Macros can be enabled in ConfigPost's General Info Dialog. 

14 DYNACONV.PST 

 Sample Dynapath 10/20/30 Config file in CONVERSATIONAL mode. 

 Each line must begin with an event (1) and end with a $ 

 Drilling Macros are not supported 

 Milling Macros are not supported 

 Multiple Work Offsets are supported 

 Cutter diameter compensation is supported 

15 DYNAEIA2.PST 

 Sample Dynapath 20/30 Config file for EIA (G-code) programming with 2 
digit tool numbers. 

 Cutter diameter compensation is supported 

 Multiple Work Offsets are supported 

 Drilling macros are not supported 

 Milling macros are not supported 

16 DYNAEIA4.PST 

 Sample Dynapath 20/30 Config file for EIA (G-code) programming with 4 
digit tool numbers. 

 Cutter diameter compensation is supported 

 Multiple Work Offsets are supported 

 Drilling macros are not supported 

 Milling macros are not supported 

17 FADAL.PST 

 Sample Config file for FADAL controls. 

 Cutter diameter compensation is supported.  

 Multiple work offset coordinate systems are supported 
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18 FADAL-A.PST 

 Sample Config file for FADAL controls with programmable A rotary axis. 

 Cutter diameter compensation is supported.  

 Fixture offsets E1 – E99 supported 

 In order to verify part programs produced when using this Config file you 
must locate a file FADAL.MCF in N-SEE\MCF directory and copy it to a file 
FADAL_A.MCF. 

19 FADAL-E.PST 

 Sample Config file for FADAL controls. 

 Cutter diameter compensation is supported.  

 Multiple fixture numbers E1,E2... are supported.  

 You should enter the fixture number in PartMaker Faces Dialog in the Work 
Offset field. 

 Fanuc style Milling and Drilling Macros (subroutines) are supported. 

 Milling and Drilling Macros can be enabled in ConfigPost's General Info 
Dialog. 

 In order to verify part programs produced when using this Config file you 
must locate a file FADAL.MCF in N-SEE\MCF directory and copy it to a file 
FADAL_E.MCF. 

20 FAGOR.PST 

 Sample Config file for Fagor 80XX series control 

 Tool changes are assumed to be with an automatic changer, using the 
Taa.bb format where aa is the tool number and bb is the offset number. 

 Multiple Work Offsets are supported 

 Drilling macros are supported 

 Milling macros are supported 

 Cutter diameter compensation is supported 

21 FAGOR-M.PST 

 Sample Config file for Fagor 80XX series control 

 Tool changes are assumed to be with a manual changer, using the T.aa 
format where aa is the tool offset to be applied. 

 Multiple Work Offsets are supported 

 Drilling macros are supported 

 Milling macros are supported 

 Cutter diameter compensation is supported 
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22 FANUC.PST 

 Sample Config file for Fanuc type controls. 

 Cutter diameter compensation is supported. 

 Uses M6 for tool change.  

 Multiple work offsets (G54,G55,..) are supported.  

 Milling and Drilling Macros (subroutines) are supported. 

 Milling and Drilling Macros can be enabled in ConfigPost's General Info 
Dialog. 

23 FANUC-1.PST  

 Sample Config file for Fanuc type controls without M6.  

 Cutter diameter compensation is supported. 

 Multiple work offsets (G54,G55,..) are supported. 

 Milling and Drilling Macros (subroutines) are supported. 

 Milling and Drilling Macros can be enabled in ConfigPost's General Info 
Dialog. 

24 FANUC-A.PST 

 Sample Config file for Fanuc control with rotary A axis 

 Drilling macros are supported 

 Milling macros are supported 

 Multiple Work Offsets are supported 

 Cutter Diameter compensation is supported 

25 FANUCO.PST 

 Sample Config file for the Fanuc O series control 

 Drilling macros are supported 

 Milling macros are supported 

 Multiple Work Offsets are supported 

 Cutter Diameter compensation is supported 

26 GE1050IJ.PST  

 Sample Config file for GE 1050 controls. 

 Uses unsigned I,J values for circular interpolation. 

27 HAAS.PST 

 Sample Config file for HAAS controls.  

 Cutter diameter compensation is supported. 

 Uses M6 for tool change.  

 Multiple work offsets (G54,G55,..) are supported. 

 Fanuc style Milling and Drilling Macros (subroutines) are supported. 

 Milling and Drilling Macros can be enabled in ConfigPost's General Info 
Dialog. 
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28 HG_VMC.PST 

 Sample Config file for Hardinge VMC and VMC II (600, 800, 1000)with Fanuc 
OT control. 

 Drilling macros are supported 

 Milling macros are supported 

 Multiple Work Offsets are supported 

 Cutter Diameter compensation is supported 

29 HHCON.PST  

 Sample Config file for Heidenhain conversational control.  

 Cutter diameter compensation is supported. 

 Milling Macros (subroutines) are supported.  

 Drilling Macros are not supported. 

 Milling Macros can be enabled in ConfigPost's General Info Dialog. 

30 HURCOII.PST 

 Sample Hurco Ultitmax II or Ultimax III Config file 

 Cutter Diameter compensation is supported 

 Drilling Macros are not supported 

 Milling Macros are not supported 

31 MAZAK.PST 

 Sample Config file for MAZAK controls.  

 Cutter diameter compensation is supported. 

 Uses M6 for tool change. 

 Tools preloading is not supported.  

 Multiple work offsets (G54,G55,..) are supported. 

 Milling Macros (subroutines) are supported.  

 Drilling Macros are not supported. 

 Milling Macros can be enabled in ConfigPost's General Info Dialog. 

32 MAZAK-1.PST 

 Sample Config file for MAZAK controls.  

 Cutter diameter compensation is supported. 

 Uses M6 for tool change. 

 Tools preloading is supported.  

 Multiple work offsets (G54,G55,..) are supported. 

 Milling Macros (subroutines) are supported.  

 Drilling Macros are not supported. 

 Milling Macros can be enabled in ConfigPost's General Info Dialog. 
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33 MELDAS.PST 

 Sample Config file for Mitsubishi MELDAS control 

 Cutter compensation is supported 

 Multiple work offsets are supported 

 Tools are changed with a M6 command 

 Drilling Macros are supported 

 Milling Macros are supported 

34 MELDAS-1.PST 

 Sample Config file for Mitsubishi MELDAS control for use with machines 
without automatic tool changer. Tool changes are assumed to be by hand.  

 T-Codes are not used. Appropriate tool is determined by the H-code used in 
the G43 line associated with the tool changing process. 

 Cutter compensation is supported 

 Multiple work offsets are supported 

 Drilling Macros are supported 

35 OSP5020M.PST 

 Sample Config file for OKUMA 5000 series controls.  

 Cutter diameter compensation is supported. 

 Single fixture number G15H1 is supported.    

 Milling Macros (subroutines) are supported.  

 Drilling Macros are not supported. 

 Milling Macros can be enabled in ConfigPost's General Info Dialog. 

36 OSP_H.PST 

 Sample Config file for OKUMA 5000 series controls.  

 Cutter diameter compensation is supported. 

 Multiple fixture numbers G15H1, G15H2 are supported.  

 Enter the fixture number in PartMaker Faces Dialog in the Work Offset field. 

 Milling Macros (subroutines) are supported.  

 Drilling Macros are not supported. 

 Milling Macros can be enabled in ConfigPost's General Info Dialog. 

 In order to verify part programs produced when using this Config file you 
must locate a file OSP5020M.PST in N-SEE\MCF directory and copy it to a file 
OSP_H.PST. 

37 PROT_MX3.PST 

 Sample Config file for ProtoTrack-MX3 controls.  

 Cutter diameter compensation is supported. 

 Uses M6 for tool change.  

 Fully Fanuc compatible. 
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38 PROT_PLU.PST 

 Sample Config file for ProtoTrack-PLUS controls.  

 Cutter diameter compensation is supported. 

 Not fully Fanuc compatible because it uses ";" at the end of each line. 

 Milling Macros are supported 

 Consult PartMaker Inc. regarding availability of a translator to fully verify NC 
programs  generated for this control. 

39 QUICK.PST 

 Sample Config file for QUICKMILL (Canadian). 

 Cutter diameter compensation is supported 

 Multiple work offsets are supported 

 Drilling Macros are supported 

 Milling Macros are supported 

40 TECHNO.PST 

 Sample Config file for TECHNO mill, which is basically a subset of standard 
FANUC control language. 

 Cutter compensation is not supported 

 Milling macros are not supported 

 Drilling macros are not supported 

41 YASNAC.PST 

 Sample Config file for YASNAC controls.  

 Cutter diameter compensation is supported. 

 Uses M6 for tool change.  

 Multiple work offsets (G54, G55...) are supported. 

 Fanuc style Milling and Drilling Macros (subroutines) are supported. 

 Milling and Drilling Macros can be enabled in ConfigPost's General Info 
Dialog. 

Metric Post Configuration Files 

1 M_FANUC.PST 

 Sample Config file for Fanuc type controls with metric output. 
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Appendix C: GPF Files  
Why GPF Files  

In addition to the interactive input, PartMaker version 2.3 and higher is capable of 
reading a text file in the format shown in Fig.1 below. The format of such a file is 
very similar to a part program file where drilling canned cycles were replaced by 
PartMaker compound cycles. It is not a complete part program yet since essential 
machining parameters, namely feedrates, spindle speeds, tool numbers, etc. are 
missing. The name Generic Program Format or, in short, GPF was chosen for such 
a format. A GPF file can be created via a text editor or generated by PartMaker or 
another CAD/CAM program.  

GPF files can be used for various purposes. The three most frequently used cases 
are: 

 Repetitive patterns of most commonly used Part Features 

 Font files for Engraving 

 Interfacing to other CAM/NC systems 

GPF Files Import/Export 
An example of GPF file is shown below: 

 
The import of the foregoing GPF file into PartMaker results in two tapped blind 
holes at locations (0,2.5) and (0,-2.5) and a rectangular profile 8"x6" with 1" radius  
corner fillets. 

Export GPF File command in PartMaker's File menu creates a GPF file that contains 
all Groups of Part Features in the active (front most) Face Window.  

Import GPF File command in PartMaker's File menu merges (attaches) all Groups 
of Part Features from a GPF file to the list of Groups in the active (front most) Face 
Window. 
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Details of GPF File Format 
The GPF file consists of statements and data blocks.  There are 3 types of 
statements: $$Mill, $$Drill, and $$End. The statement type must be followed by 
parameters as specified below: 

1 $$Drill Statement Structure 
 $$Drill(Tap-1/2)Chamfer(0.0500)Surface(0.0000)Depth(0.5000)Rapid(0.0500)Blind 

 The word $$Drill  

 The name of the cycle Tap-1/2 in PartMaker database. 

 Word Chamfer or letter “C” followed by the hole chamfer value. 

 Word Surface or letter “S” followed by the machining surface Z coordinate 

 Word Depth or letter “D” followed by the nominal depth  

 Word Rapid or letter “R” followed by the rapid traverse level. (The latter is defined as 
unsigned distance from the part surface) 

 Letter “T” for the through hole or “B” for blind hole 

2 $$Drill statement is followed by hole location blocks 

 Each block contains X, Y coordinates that must be in decimal format without leading 
zeros.  Both coordinates must be in the first block.  

 Sequence numbers are allowed. 

Example1: X0.000000 Y2.500000 

Example2: N020 X0.000000 Y2.500000 

3 $$Mill statement structure 

 $$Mill (Contour_0.5)Surface(0.0000)Depth(1.0000)Rapid(0.0500)Tool(0.5000) On 

 The word $$Mill 

 The name of a milling group Contour_0.5. Any combination of letters and digits can 
be used. 

 Word Surface or letter “S” followed by the machining surface Z coordinate 

 Word Depth or letter “D” followed by the cutting depth 

 Word Rapid or letter “R” followed by the rapid traverse level. (The latter is defined as 
unsigned distance from the part surface) 

 Word Tool or letter “T” followed by the tool diameter. 

 Word “On” or letter "O” for the center line cutting, or Word “Left” or letter "L” for 
offset Left, or Word “Right” or letter "R” for offset Right, or Word “Pocket” or letter 
"P” for a pocket. 

4 $$Mill statement is followed by one or several profiles that represent tool path.  

 Profiles consist of straight lines and circular arcs. Profiles can be closed or open. The 
profiles are defined as: 

G0 X-3.000000 Y-3.000000 //Start point: (-3,-3) 

G1 X3.000000 Y-3.00000 //Line to (3,-3) 

G3 X4.000000 Y-2.000000 I3.000000 J-2.000000 R1.000000 
//Counter-Clockwise arc to (4,-2). 

//Circle center at (3,-2). Radius=1

G2 modifier is used for clockwise arc. 

 Each block must contain both X and Y coordinates in decimal format without leading 
zeros.  Sequence numbers are allowed. 

5 $$End statement 

 This statement indicates the end of valid data. Comments can be placed after the 
$$End statement. 
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Usage of GPF Files as Font Files for Engraving 
When you select engraving icon in PartMaker you are prompted to enter text, text 
height, and spacing between letters. 

The software loads the default font from a file "FONT.GPF" located in the working 
directory. If such file is not present PartMaker displays a standard file open dialog 
that allows the user to designate another "***.GPF" file as a font file.  

 When you create your own font file, you must place each character, namely: ["A...Z", 
"0-9",". ","- ","/"] in a separate group named after this character.  The size of a 
character and its origin can be arbitrary. 
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Appendix D: Programming Directly on a 
Solid Model 
Introduction 

This document describes the process of programming directly on a Solid Model in 
PartMaker/Mill version 9 and higher. 

Key Definitions 
Part Coordinate System (PCS):The Origin of a PCS is on a Solid Model. After 
being set, the PCS should not change during the programming session. 

 
Face Coordinate System (FCS): This is a coordinate system with two axes in the 
Face Plane and the third axis perpendicular to the Face Plane. A Face Plane is the 
plane in which a PartMaker Face Window is programmed. Each Face Window can 
have its own Face Plane. The Face Plane must be set in the correct place to properly 
program on the Solid Model. 

 



 

D-2 PartMaker  Copyright @2014 Delcam Ltd 

 

Face Plane Icons for Solid Model: 

 
Show Profiles and Holes on Solid Model: You will need to have this feature 
selected to work on the Solid Model. This will allow you to view the Profiles as they 
are created. 
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Solids Programming Tutorial 
This tutorial is designed to help you learn the steps to go through in using 
PartMaker Mill to program on a Solid Model. 

The Complete Finished Job Files can be found in the C:\PartMaker\PM-Mill\ 
Solids_Programming_Tutorial Directory. 

How you will create the Sample part 
Here are the major steps you will follow to create the Swiss tutorial part: 

√ Start PartMaker 

√ Open Sample Program and review 

√ View tool information for the part 

√ View cycle information for the part 

√ Select a material for the part 

√ Open a new Face Window 

√ Create Profile and Hole Groups 

√ Extract Information from the Solid Model 

√ Create a Process Table 

√ Simulate the Machining Process 

√ Generate an NC Program 
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The picture below shows the part to be programmed in this tutorial. 

 

When you complete this tutorial, you will have a part that looks like the picture 
below. 
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Getting Started 
The machining functions used in this tutorial are as follows: 

Mill XY: 
Use an end mill to create Pockets and Profiles. 

Use Hole Groups and Cycles. 

Programming on the Solid Model can accomplish almost every Machining Function 
needed. In Most Cases you will not need to work in the CAD window at all. 

Now you will look in detail at the steps necessary to program each of the 
components of the finished part. 

Starting PartMaker 
1 Double click on the PartMaker Mill icon.   

2 A picture containing the PartMaker logo will appear for a few moments. You 
will then see the Setup definition dialog box shown below. Click the 
<Close> button.   

3 This dialog will be explained in greater depth later in this document. 
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View the Finished Sample 
1 Use the Open All Files Command from the File Menu. 

2 You will find the Job Files in the Follwing Directories. 

C:\PartMaker\PM-Mill\ Solids_Programming_Tutorial 

 NOTE: This will also open the Sample Tools and Cycles files for you to use 
when you create your own Part. 

3 Look through the Sample Job file and familize yourself with the Profiles and 
Hole Groups. 

4 When Ready, Choose New Job from the File Menu. 

Importing a Solid Model 
1 Select the Import icon and select the X_T Solid Model. 

 
2 Choose the file, SampleSolidProgramming.X_T, and click <Open>. 
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Select a Material for the Part 
The work piece in this exercise will be machined from Free Machining Stainless 
Steel, Wrought. To load this material: 

1 Choose Open Material File from the File menu. 

2 Choose st_fmstw.mdb as shown below and click <Open>. 

 
You have now loaded the tools, cycle, and material files that were previously 
developed for the Solid Model Programming Sample. 

Editing the Coordinate System 
In this section, you will edit the Coordinate System on the Solid Model.  

1 On the Solids Tool Bar, Choose the Edit Part Coordinate System. 

2 Edit the Coordinate System on the Solid Model so the Origin is at the Center 
of the Part and the Z positive is pointing up away from the Part. 
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Setting up the Face Window 
In this section, you will set up the Face Window for the Milling operations.  To do 
so: 

1 You will need to make certain changes to the Set-up Dialog before moving to 
the Solid Model. 

Table    Standard 
Stock    Block 
Machining Function Mill XY Plane 

 

2 When Programming with a Solid Model. Many items will be set automatically 
from the information obtained from the Solid Model. To import these setting 
into the Set-up Window, you will need to define a face plane.  

3 Select the Define Face Plane Icon in the Solids Tool Bar. 

4 For Block Mill parts, you can define your Face Plane Parallel to XY Plane. 
Check the Set Face Plane box. Choose Parallel to XY Plane in the Drop 
Down Menu, and check the Set Boundaries Box. 

 Note: There are many choices to select the Origin for the Face Plane. 
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5 Click the New Origin drop down menu to view the options available as shown 
below: 

 
6 Select Parallel to XY Plane at this time. 
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7 Click the <Preview> Button to see the Face Plane on the Solid Model 
update as shown here: 

 
8 Click <OK> and open the Set-up Window. Note the Part height, X1, X2, Y1, 

Y2 were imported from the Solid Model. You could now make any other 
changes required for your face window.  

 

9 Click <Apply> and <Close>. 
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Programming a Pocket Operation 
1 Select the New Profile Group icon. 

2 Change the following settings on the Profile Group Parameters dialog: 

Strategy Pocket Mill 

Remove Check Roughing 

Check (checked when Roughing unchecked) Finishing 

Diameter 0.5 

 

3 Click <Select Tools> and choose the ½ End Mill. 

 
4 Name the Group, Pockets. 
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5 Click the Extract Parameters from Solid check box. 

6 Select the Wall of one of the Pockets. 

 
7 Click the <Extract> Button. 

8  Your dialog should look like the following. 

 

9 Click <Apply> and <Close>. 
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10 Select the Chain Geometry on Solid Model icon. 

11 Select a Start Point of the 1st Pocket. When choosing start point, click on the 
side of the point that you want the Chain to follow. This will determine the 
direction the chain will follow. 

 

12 Select the End Point of the 1st Pocket. 

 Note: The Dotted line indicates the Profile Preview. 
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13 Repeat these steps for the Second Pocket. 

 
14 To verify the Profile Group, Select the Verify Work Group Toolpath icon. 

15 The Tool Path Verification Options dialog will now Display. Make sure to 
check the Option for Enable Verification on Solid Model. 

Your screen should appear as below: 

 
16 After Verifying the Tool Path, Click the Hide Every Tool Path icon to hide all 

verifications. 
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Programming a Profile Operation 
1 Select the New Profile Group icon. 

2 Change the Following settings in the Profile Group. 

Strategy Contour Mill 

Tool Position Left 

Remove Check Roughing 

Check (checked when Roughing unchecked) Finishing 

Diameter 0.5 

 

3 Click <Select Tools> and choose the ½ End Mill. 

 
4 Name the Group Profiles.  
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5 Click the Extract Parameters from Solid check box. 

6 Select the Wall of one of the Outside Radii. 

 

7 Click the <Extract> Button. 

8  Your dialog should look like the following. 

 

9 Click <Apply> and <Close>. 
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10 Select Define Profile on Solid Model icon. 

11 Select Edge Endpoint Snap Mode icon. 

 
12 Select a Start Point of the 1st Corner. 

 
13 Select the End Point of the 1st Corner. Note: The Dotted line indicates the 

Profile Preview. 

 
14 Press the Selection icon. 
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15 Repeat this process for 3 the other Corners. 

 
16 To verify the Profile Group, Select the Verify Work Group Toolpath icon. 

17 The Tool Path Verification Options will now Display. Make sure to check 
the Option for Enable Verification on Solid Model. 

Your screen should appear as below: 

 
18 After Verifying the Tool Path, Click the Hide Every Tool Path icon to hide all 

verifications. 
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Programming a Reamed Hole Group 
1 Select the New Hole Group icon. 

2 Change the Major Cycle Operation type to Ream. 

3 Click the Extract Parameters from Solid check box. 

4 The Hole Group Parameters dialog should appear as follow.  

 

5 Select one of the Holes around the Center of the Part. 

6 Click the <Extract> Button. 
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7 The Select Cycle dialog will appear; select the Ream ¼ Cycle. 

 
8 The Hole Group Parameters dialog should appear as follow. 

 

9 Click <Apply> and <Close>. 
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10 Select Chain Holes on Solid Model icon. 

11 Select one of the holes around the Center of the Part. Note: Other holes with 
exact same feature are also highlighted. 

 
12 To verify the Profile Group, Select the Verify Work Group Toolpath icon. 

13 The Tool Path Verification Options dialog will now Display. Make sure to 
check the Option for Enable Verification on Solid Model. 

Your screen should appear as below: 

 
14 After Verifying the Tool Path, Click the Hide Every Tool Path icon to hide all 

verifications. 
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Programming a Tapped Hole Group 
1 Select the New Hole Group icon. 

2 Uncheck Through Hole 

3 Change the Major Cycle Operation type to Tap. 

4 Click the Extract Parameters from Solid check box. 

Your dialog should look like the following image: 

 
5 Select one of the two blind holes on the Part. 

6 Click the <Extract> Button. 
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7 The Select Cycle dialog will appear; select the Tap ½ Cycle. 

 

8 The Hole Group Parameters Dialog should appear as follows: 

 
9 Select <Apply> and <Close>. 
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10 Select Single Hole on Solid Model icon. 

11 Select The First Hole at the Bottom of the Part. 

 
12 Then Select the Second Hole at the Top of the Part. 

 
13 To verify the Profile Group, Select the Verify Work Group Toolpath icon. 
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14 The Tool Path Verification Options Dialog will now Display. Make sure to 
check the Option for Enable Verification on Solid Model. 

Your screen should appear as below: 

 
15 After Verifying the Tool Path, Click the Hide Every Tool Path icon to hide all 

verifications. 
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Programming a Bore Hole Group 
1 Select the New Hole Group icon. 

2 Change the Major Cycle Operation type to Bore. 

3 Click the Extract Parameters from Solid check box. 

Your dialog should look like the following. 

 
4 Select one of the four outside corners of the part. 

5 Click the <Extract> Button. 
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6 When the Select Cycle dialog appears, select the Bore-1 Cycle as shown 
below: 

 
The Hole Group Parameters Dialog should appear as follows. 

 
7 Select <Apply> and <Close>. 
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8 Select Chain Holes on Solid Model icon. 

9 Select one of the 4 holes at the outside corners of the Part. 

 Note: Other holes with exact same feature are also highlighted. 

 

 
10 To verify the Profile Group, Select the Verify Work Group Toolpath icon. 

11 The Tool Path Verification Options Dialog will now Display. Make sure to 
check the Option for Enable Verification on Solid Model. 
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Your screen should appear as below: 

 
12 After Verifying the Tool Path, Click the Hide Every Tool Path icon to hide all 

verifications. 
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Generating the Process Table 
1 Choose the Generate Process Table icon. 

2 Click <OK> for the Process Table Options. 

 
3 Your Process Table should look like the picture below. 

 

Simulating Machining in 3D 
Now that you have generated the Process Table, you can simulate the cutting of the 
part in 3D. To do so: 

1 Choose the Simulation icon to watch process run and see the finished part. 

2 Click the Show Finished Part icon to view the completed part: 
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Generating the NC Program 
1 Choose the Open Config Post File icon. 

2 Open the Post for the Appropriate Machine. (Haas Post Shown) 

 
3 Choose the Generate NC Program icon. The Post Options dialog will 

display. 

 
4 Review Post Options and make changes as needed. 

5 Click <OK> to display the Save Program File dialog. 
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6 Enter a name for your file and click <Save> to generate the NC program. 

You will see your program as shown below: 
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Appendix E: The 4th-Axis Tutorial Part 
The drawing below shows the part to be programmed. 

Inch Units 
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Metric Units 

 

 

 Important!  To complete this tutorial, you must license the PartMaker 
Production Milling Module (PMM). 

When you complete this tutorial, you will have a part that looks like the 
picture on the page to follow. 
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Introduction 
The first part of any programming exercise with PartMaker’s 4th Axis milling module 
is to decide which machining functions will be used.  

 Important! The tutorial below is presented in both inch and metric units, 
depending on how you are working with PartMaker.  The inch units of 
measure are given first, with the metric entries gives in parenthesis ( ). 

For example you may see instruction that says: Enter an X value 1 (25), where 1 is 
1 inch and 25 is 25 mm. 

This tutorial is for use with PartMaker Version 7.8 and higher. 

The machining functions used in this tutorial are as follows:  

Mill Polygon:  
Use an end mill to create hexagonal flats on the end of the part. 

Mill Polygon: 
Use an end mill to create a set of octagonal flats that begin 2.25” (56 MM) from the 
end of the part.  

Mill Diameter - Index:  
Use a spot drill and a drill to create the eight holes arranged around the diameter of 
the part.  

Mill Cylinder:  
Use an end mill to create four channels around the cylinder of the workpiece. 
Programming of these channels will use the simultaneous X and A axis feed 
capabilities of the machines’ rotary axis.  

Mill 4 Axis Plane:  
Use a spot drill and a drill to create the three .125” (3 MM) diameter holes .200” (5 
MM) from the face of the part and arranged .300” (7.5MM) apart.  

Getting Started 
Now you will look in detail at the steps necessary to program each of the 
components of the finished part.  The components of the completed tutorial for 4th 
Axis part can be found in the following directories: 

Completed Job File: C:\PartMaker\PM-Mill\4th-axis-Rotary.job 

Completed Tools File: C:\PartMaker\PM-Mill\4th-axis-Rotary.tdb 

Completed Cycles File: C:\PartMaker\PM-Mill\4th-axis-Rotary.cdb 
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Starting PartMaker Mill 
Start the PartMaker Milling application. An icon containing the PartMaker logo will 
appear for a few moments.  You will then see the Setup definition dialog box shown 
below.  Click the <Close> button.  This dialog will be explained in greater detail 
starting on page E-9. 

 

Setting Preferences for the 4th-Axis Exercise 
In this section, you will setup the necessary preferences for this exercise.   

1 Choose Preferences from the View menu. 

2 Check the Display Axis Symbol box.  It may already be checked.  Checking 
this box will display the axes you are working with in the lower left hand 
corner of each Face Window.  

3 Make sure to uncheck the In Part Boundaries box.  This will allow you to 
create part features on the edge of a cylinder. 

4 Click <OK> to Exit the Preferences dialog. 

Your completed preferences dialog should appear as the one shown below: 
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Opening the Tools file 
The tool library for the 4th-Axis Programming Exercise has already been created. 

1 Choose Open Tools File from the File menu 

2 Open the 4th-axis-Rotary.tdb (4th-axis-Rotary_Metric.tdb) from the 
C:\PartMaker\PM-Mill\4th-axis-Rotary directory as shown below: 

 

3 Select the file to be opened and click the <Open> button to load the tools 
file. 

Once you have loaded the tools database, you can view the tools that you will be 
using for this programming exercise.  To do so 

4 Choose Tools from the ToolMinder menu. This tools file contains five tools.  
The first of these appears below:  

 
5 Click the <Close> button to close the Tools dialog. 
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Opening the Cycles file 
At this point, you should be familiar with the concept of Cycles in PartMaker. Cycles 
are sequences of repetitive operations that go into machining a hole.  The cycles 
library for the 4th-Axis Programming Exercise has already been created.  

1 Choose Open Cycles File from the File menu. 

2 Open the 4th-axis-Rotary.cdb (4th-axis-Rotary_Metric.cdb) from the 
C:\PartMaker\PM-Mill\4th-axis-Rotary directory as shown below: 

 
You can view the cycle that you will be using for this programming exercise.  To do 
so:  

1 Select the file to be opened and click the <Open> button to load the tools 
file. 

2 Choose Cycles from the ToolMinder menu. 

 
3 Click the <Close> button to close the Cycles dialog. 
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Select a Material for the Part 
The work piece in this exercise will be machined from aluminum alloy wrought.  
To load this material: 

1 Choose Open Material File from the File menu. 

2 Choose alu_allw.mdb as shown below and click <OK>. 

 

You have now loaded the tools, cycle, and material files that were previously 
developed for the 4th Axis tutorial. PartMaker has also provided a completed job 
file. At this point you will not open the job file. You will be guided through a step-
by-step process to develop a job file for the tutorial.  
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Creating the Flats Using Mill Polygon 
This section of the tutorial will instruct you in the steps necessary to create the 
hexagonal flats at the end of the part. 

Setting Up the Face Window 
In this section, you will set up the Face Window for the Hexagonal Flats.  To do 
so: 

1 Choose Setup from the View menu to view the Setup dialog box.  In this 
dialog, you will define the machining methods, part boundaries and location 
of the stock with respect to the programming origin.  

The default setup screen will appear as shown below. 

 
2 From the Table drop down menu select Rotary 4 Axis. 

3 From the Stock drop down menu select Cylinder. 

4 From the Machining Function drop down menu select Mill Polygon.  

5 Rename the current face window by clicking on Front in the List of Face 
Windows: field and type Mill Hexagon in the Rename To: field and click 
the <Apply> button. 

6 Now enter the parameters listed below in the appropriate fields: 

Length (L): 3.0 (76.0) 

X Face (F): 0 (0) 

OD: 1.0 (25.0) 

ID: 0 (0) 
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When you are finished, your Setup dialog should appear as shown below:  

 

7 When you are satisfied that your Setup dialog appears as the one above, 
click the <Apply> button. This will apply the parameters to the current face 
window.   

Creating the Settings for the Rotary 4 Axis Table 

Before exiting the setup dialog, you will define the settings of the rotary 4th Axis 
table being used on this part. 

The Settings dialog is accessed for the Table Type: 4 Axis Rotary by clicking the 
<Settings> button in the Setup dialog.  The Settings dialog is used to define the 
dimension and appearance of the machining table in PartMaker’s 3D machining 
simulation for both block and cylinder stock.  

A description of all of the fields for the 4 Axis Rotary Table Settings is located in 
Chapter 2 of the Part Mill User Manual. 

 

1 Click the Settings button in the Setup dialog to enter the 4-axis Rotary 
Table Settings dialog. 
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2 Enter the values into the following values into 4 Axis Rotary Table 
Settings dialog: 

Length (L): 9 (230) 

Width (W): 8 (200) 

Height (H): 7 (175) 

Stock Extension (E): 8.25 (175) 

Indexing time: 0.1  

Once you have entered the parameters as shown above, you will then create the 
chuck for this part.  To do so: 

1 Check the Use Chuck box 

2 Click the Chuck Data button to enter the Chuck Data dialog 

3 Enter the parameters indicated below: 

Chuck OD: 7.0 (175) Chuck ID: 3.1 3.1 (78.0) 

Chuck Length (Lc): 4.0 (100) Jaw Length (Lj): 1.5 (37.5) 

Jaw Height (Hj): 1.75 (43.75) Jaw Width (Wj): 1.0 (25.0) 

Number of Jaws: 3  First Jaw Angle: 0  

Once you are satisfied the Chuck Data dialog appears as shown below, click 
the <OK> button to return to the 4-Axis Rotary Settings dialog 

 
4 Click the <OK> button to close 4-Axis Rotary Table Settings dialog and 

return to the setup dialog. 

5 Click the <Close> button to close the Setup dialog. 

 Note: If at any time the menu commands become “grayed out” and 
unusable, this indicates that the window you are working in has become 
inactive. This will be evident by the top bar of your window (where the 
name of the window is displayed) becoming gray. To reactivate the 
window, click anywhere within your face window. 



 

Copyright @2014 Delcam Ltd  User Guide E-11  

 

Creating Geometry in CAD Mode 
In this section, you will create the geometry for the hexagonal flats. 

1 Choose Show Axes from the View menu.  This will display the horizontal 
and vertical axes lines which will help you create the geometry in the next 
section of the tutorial. 

2 Choose Show Boundaries from the View menu.  A circle should now 
appear on the screen that indicates the boundary of the one-inch diameter of 
the stock 

 

3 To create geometry, click on the CAD/CAM switch in the lower left-hand 
corner of the window. The icon will change its appearance from a drill bit to a 
pencil. 

4 Choose the Hexagon icon from the icon bar on the left side of the screen. 

5 After selecting this icon a field will open at the bottom of the screen 
prompting you to enter a flat to flat distance. 
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6 Type .750 (19.00) and press <Enter> 

This will draw a Hexagon with a .750 (19) flat to flat distance as shown 
below: 

 
Next you will proceed to machine this hexagon in the CAM mode. 
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Creating the Hexagonal Profile  
In this section, you will define the profile to machine the hexagon on the end of the 
cylinder. 

1 Click the CAD/CAM switch such that it appears as a drill bit. This will put you 
back into the CAM mode. 

2 Select New Profile Group from the Part Features menu.  

3 In the Group Name: box type in Mill Hexagon. 

4 Choose Left Tool Edge and enter 0.500 (12) for P1. 

5 Enter 0.5 (12) for Tool Diamter Click on the <Select Tools> button.  The 
endmill icon will appear to the right of the Tool ID box. 

 

Now that you have completed setting up the profile group, take a moment to study 
this dialog, as it is unique to others you have encountered in PartMaker for 2 ½ axis 
milling.  

Z_Surf:  The distance from the center of the cylinder to the edge of the 
diameter.  PartMaker calculates this parameter automatically based on the 
value you enter for the OD of the stock in the Setup dialog.  For the tutorial 
workpiece this is 1.0/2 or .500 (25/2 or 12.5). 

P1 P2 or P3 Is the distance in from the face of the work piece to the 
location on the tool. 

6 When you are satisfied that your Profile Group Parameters dialog matches 
the one above, click the <Close> button.  

After closing you should see the group symbol for Mill Hex appear in the upper 
right of  the screen.  Notice the group symbol is an empty box because you have 
not yet assigned the part feature to the geometry. 
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The next step is to develop the tool path.  

1 Select the Chain Geometry  icon.   

2 Move your cursor above the top line of the hex and slightly to the left of the 
vertical axis line as indicated by the words Click Here. 

3 Click your mouse button and the screen should appear as shown below: 

 
The arrows display the direction of  the tool path.  The flats will be machined 
in this order.  If you wish to machine the flats in a different order, using the 
Selection  icon, click anywhere on the tool path to select it.  Choose 
Reverse from the Edit  menu and the arrows displayed on the tool path will 
change direction. 

Saving Your Work 
You have finished the first part face for the 4th axis tutorial. At this point save your 
work by choosing Save Job File As from the File menu.  In the file name box type 
in a name and select <Save>. 

The next step will be to program the .925” (23.00) octagonal profile located 2.25” 
(56.00) from the end of the workpiece. You will therefore have to create a second 
face for the octagon. 
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Creating the Octagonal Profile  
The next profile to create will be the .925” (23.00) octagonal profile located 2.25” 
(56.00) from the end of the workpiece. 

Setting Up the New Face Window 
In this section, you will set up the Face Window for the octagonal profile.  To do 
so: 

1 Choose Setup from the View menu to view the Setup dialog box.  

2 Click the <New> button to create a new face window. 

3 Type Mill Octagon in the Rename To: field and press <Apply>.  

4 From the Machining Function drop down menu select Mill Polygon. 

When completed, your completed Setup dialog should appear as shown 
below: 

 

5 When you are satisfied that your Setup dialog appears as the one above, 
click the <Apply> button. This will apply the parameters to the current face 
window.  Click the <Close> button to close the Setup dialog. 

6 Switch to the new window you created by choosing Mill Octagon from the 
Window menu. 

7 Select Show Axes from the view menu.   

8 Select Show Boundaries from the view menu. 
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Creating Geometry in CAD Mode 
In this section, you will create the geometry for the eight holes. 

1 Go to CAD mode by clicking on the CAD/CAM switch. 

2 Select the Line Parallel to the Horizontal Axis icon.  

3 Type in .925/2 (23/2) in the field which appears in the lower left corner of 
the window and press <Enter>.  You should see the following: 

 
4 Choose the Selection icon and click the line you just created. 

5 Select Rotate from the Edit > Transform menu to create seven more 
copies to complete the octagon. 

6 Complete the Rotate dialog box as shown below and click <Rotate> and 
<Close>. 
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Your window should now appear as the one below: 

 
Next, trim the ends of each line.  

1 Select the Remove icon. 

2 Click your cursor near the end of each line until only the octagon is visible as 
shown below: 

 
Save your work by pressing <CTRL+S> 
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Creating the Octagonal Profile  
In this section, you will define the profile to machine the octagonal profile. 

1 Click the CAD/CAM switch such that it appears as drill bit. This will put you 
back into the CAM mode. 

2 Choose New Profile Group from the Part Features menu. 

3 In the Group Name: box type in Mill Octagon. 

4 Choose Right Tool Edge and enter 2.25 (56.00) for P3. 

5 Enter 0.5 (12.00) for Tool Diameter. 

6 Click on the <Select Tools> button.  The endmill icon will appear to the 
right of the Tool ID box. 

 
7 When you are satisfied that your Profile Group Parameters dialog matches 

the one above, click the <Close> button.  

The next step is to develop the tool path.  

1 Select the Chain Geometry icon.  

2 Click on the geometry along the top of the octagon to the right of the vertical 
axis line as shown below. 
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Verifying the Tool Path 
You can now verify the tool path of the operation you have just programmed. 

1 Choose Verify Work Group Tool Path from the Part Features menu.  You 
should see the following: 

 
2 Choose Hide Work Group Tool Path from the Part Features menu. 

3 Save your work with using <CTRL+S>. 
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Creating Indexed Holes Using Mill Diameter Index 
This section of the tutorial incorporates the concept of ‘unwrapping’ a cylinder and 
programming it as a flat surface. 

To understand this concept, imagine the outside diameter (OD) of the cylinder as a 
paper wrapper on a tin can. Slit that wrapper and peel it off the can and lay it front 
side up on the table. This is how PartMaker handles cylindrical (OD) machining. 
Instead of using X and Y coordinates, programming is done with X and C, where X is 
the ‘length’ of the cylinder along the machine X axis and C is measured in degrees 
of rotation, starting from the machine 0 and progressing to 360 degrees. 

Setting Up the Face Window 
In this section, you will set up the Face Window for the indexed holes.  To do so: 

1 Choose Setup from the View menu to view the Setup dialog box.  

2 Click the <New> button to create a new face window. 

3 From the Machining Function drop down menu select Mill Diam, Index. 

4 Type Holes in the Rename To: field and press <Enter>.  

When completed, your Setup dialog should appear as shown below: 

 

5 When you are satisfied that your Setup dialog appears as the one above, 
click the <Apply> button. This will apply the parameters to the current face 
window.  Click the <Close> button to close the Setup dialog. 

6 Switch to the new window you created by choosing Holes from the Window 
menu. 

7 Select Show Axes from the view menu.   

8 Select Show Boundaries from the view menu. 
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Creating Geometry in CAD Mode 
In this section, you will create the geometry for the eight holes. 

1 Go to CAD mode by clicking on the CAD/CAM switch.  

2 Select the Circle with a Known Radius and Center icon. This will allow 
you to draw the first of the eight 0.1875 (5.00) diameter holes shown on the 
part drawing.  

3 Enter a value for the radius of .1875/2 (5.00/2) in the field at the bottom 
of the face Window press <Enter>.  

4 Select the XC coordinates icon from the Snap Mode icon bar.  

5 In the lower left of the window you are prompted for the X axis location and 
the angle where the first hole begins on the circumference of the work. Enter 
–1.0 (-25.00) for X and zero (0) for C and press <Enter>. A hole should 
now appear on the negative side (left) side of the vertical axis and on the C-
axis line.  

Your window should look like the one below: 

 
6 To draw the remainder of the holes choose the Selection icon and select the 

circle that you drew on your screen by clicking on it.  
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7 After the circle is highlighted, select Translate from the Transform 
submenu found under the Edit menu.  Enter parameters as shown here: 

 

The horizontal distance is set to zero (0) to show the holes will only be 
translated along the C axis in increments of 90 degrees. 

8 Once you have entered these parameters, click on <OK>. Your screen 
should now appear as shown below: 

 
Next you will translate all four holes in the X-axis by 1.0” (25.00mm) in the 
negative direction.   

1 Click anywhere within the window to deselect the holes you just translated. 

2 Choose Select All from the Edit menu.  All four holes should be highlighted.  
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3 Select Translate from the Transform submenu found under the Edit menu 
and enter the parameters as shown here. (metric users, enter -25 for X 
Distance) 

 
4 Once you have entered these parameters, click on <OK>. Your screen 

should now appear as shown below: 

 
5 Click anywhere in the Face Window to deselect the holes. 

6 Now that the geometry for the holes has been created you will next define 
the tool path. 

First, you must save your work.  You can do so in one of two ways: 

Choose the Save command from the File menu.  

or 

Hold down the <Ctrl> key and the <S> key simultaneously. 
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Creating the Indexed Holes 
In this section, you will define the holes to be machined along the outside of the 
cylinder. 

1 Click the CAD/CAM switch such that it appears as cutting tools.  

2 Select New Hole Group from the Part Features menu.  

3 Uncheck the Through Hole box. 

4 From the Type: drop down menu, select Drill. 

5 Enter a Diameter of 0.1875 (5.00) 

6 Enter a Chamfer of 0.05 (1.0) 

7 Enter a Nominal Depth of 0.2125 (5.00) 

8 In the To: drop down menu, select Tip of Largest Drill 

9 Click the <Cycle> button. In doing so, PartMaker found an existing cycle 
from the Cycles database where the major operation was a .1875 (5.00) 
diameter drill.  The completed dialog should appear as shown below:  

 
10 Click the <Verify Shape> button to see the shape of your hole 

 
11 11. Once you are satisfied that your dialog and hole shape appear as the 

ones above, click  <Hide Shape> and <Close> to exit the dialog.   
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You will specify the holes you want to machine.  

1 Select the Chain Circle icon.  

2 Click your cursor somewhere near the first hole you want to machine.  In this 
case you will select the lower right hole in the window as shown below: 

 

The holes you have chained should now be highlighted in the Sample Color. 

 Note: If all the holes are not selected when performing the chaining 
operation described here, you may not have unchecked the In Part 
Boundaries box in the Preferences dialog.  To do so select Preferences 
from the View menu. 

Verifying the Tool Path 
You can now verify the tool path of the operation you have just programmed.   

1 Click anywhere within the Face Window to un-highlight the holes.  

2 Select Verify Work GroupTool Path from the Part Features to see the 
tool path displayed below:  

 

3 When you are satisfied that your toolpath appears as the one shown, choose 
Hide Work GroupTool Path from the Part Features to hide the tool path 
displayed.  

Now save your work by pressing <CTRL+S>.  You have finished the third part 
face for the 4th axis tutorial.  The next step will be to program the four .125” 
(3.5) slots.  
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Creating Helical Channels Using Mill Cylinder 
PartMaker’s Mill Cylinder machining function supports cylindrical milling, the ability 
to simultaneously feed in the X and C axes.  This machining function also 
incorporates the concept of ‘unwrapping’ a cylinder and programming it as a flat 
surface as discussed previously. 

Setting Up the Face Window 
In this section, you will set up the Face Window for the helical slots.  To do so: 

1 Choose Setup from the View menu to view the Setup dialog box.  

2 Click the <New> button to create a new face window. 

3 From the Machining Function drop down menu select Mill Cylinder 

4 Type Slots in the Rename To: field and press <Enter>.  

When completed, your Setup dialog should appear as shown below: 

 

5 When you are satisfied that your Setup dialog appears as the one above, 
click the <Apply> button. This will apply the parameters to the current face 
window.  Click the <Close> button to close the Setup dialog. 

6 Switch to the new window you created by choosing Slots from the Window 
menu. 

7 Select Show Axes from the View menu. 
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8 Select Show Boundaries from the View menu.  Your screen should now 
appear as shown below: 

 

Creating Geometry in the CAD Mode 
To quickly define geometry for the slots you can use the holes created in the 
previous section. Because the slots run between the centers of the holes, instead of 
drawing this geometry again, you will copy the hole geometry created in the 
previous face window to the one you are working with now. 

1 Select Holes from the Window menu.  

2 Click the CAD/CAM switch to enter CAD mode   

3 Choose Select All from the Edit menu. All the holes should now be 
highlighted. 

4 Choose Copy from the Edit menu. 

5 Return to the Slots face window by choosing Slots from the Window menu. 

6 In CAD mode in the Slots face window, select Paste from the Edit menu. 

Now you will shift one set of holes by 90 degrees.  

1 Move your cursor slightly above the top set of holes and between them.  
Holding your mouse button down drag your cursor down and to the left. As 
you do this you create a dotted box around the left set of holes.  
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2 Once the box is around all four holes on the left release the mouse button.  
Your screen should look like the one below. After releasing the mouse button 
the holes on the left will be highlighted. 

 

 Note: If the bottom row of holes appears to be off the screen and is 
unselectable, choose Zoom Out from the View menu. 

You will now shift the selected circles down so that you can create diagonal lines   
between the centers of the holes.   

1 Choose Translate from the Transform submen found under Edit menu.  
Set the parameters as shown below: 

 



 

Copyright @2014 Delcam Ltd  User Guide E-29  

 

2 Once you have entered these parameters, click on <Translate>. Your 
screen should now appear as shown below: 

 
3 Click anywhere within the Face Window to deselect the circles that were 

just translated.   

4 Change back to the CAM  mode by clicking CAD/CAM switch. 
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Creating the Helical Channels 
You can now use the translated circles to more easily define the tool path for the 
helical slots. 

1 Select New Profile Group from the Part Features menu. 

2 From the Strategy: drop down menu, select Contour Mill. 

3 From the Tool Position: drop down menu, select On. 

4 Enter a Z_Depth (D):  of 0.098 (2.5) 

5 Enter a Diam (d) of 0.125 (3.5) 

6 In the Group Name box type in Contour_0.125 ( 3.5). 

7 After having entered these parameters, click the <Select Tools> button to 
call up the .125 (3.5) end mill.  

Your completed dialog should appear as shown below: 

 

8 Once your screen looks like the one above click the <Close> button to exit 
the Profile Group Parameters dialog 

Next, you will define the tool motion. 

1 Select the Define Profile icon. This icon will allow you to define the tool 
motion for the slots from point to point. 

2 Select the Center of Circle snap mode icon from the snap mode icon bar at 
the top of the face window.  This will allow you to use the centers of the 
circles you defined as guides for the creation of the slots.  Your cursor should 
now appear as a circle with an arrow attached to it. 

3 Click on the lowest right hand hole, the one labeled #1 below.  Move your 
cursor down and click on the bottom left hole lying directly on the X axis, #2 
in the window.   

4 Choose the Selection icon to deselect the profile you just created. 

5 Once you have done so, repeat steps 1 to 4 above for holes 3 and 4, 5 and 
6, and 7 and 8 respectively as shown in the picture below. 
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Your screen should appear as shown below: 

 

Verifying the Tool Path 
You can now verify the tool path of the operation you have just programmed.  

This time try a different type of verification process. 

1 Choose Verification Options from the Part Features menu. 

2 In the Tool Path Verification Options dialog select the Solid radio button 
and click <OK>. 

 
3 Choose Verify Work Group Tool Path from the Part Features menu.  

PartMaker should show the tool path verified as shown below: 
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4 When you are satisfied that your screen looks like the one above, choose 

Hide Work Group Tool path from the part features menu and press <Ctrl-
S> to save your work. 
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Creating Offset Holes Using Mill 4 Axis Plane 
This section of the tutorial you will use a spot drill and a drill to create the three 
.125’ (3.00) diameter holes .200’(5.00) from the face of the part and arranged 
.300” (7.5) apart.  

Setting Up the Face Window 
In this section, you will set up the Face Window for the indexed holes.  To do so: 

1 Choose Setup from the View menu to view the Setup dialog box.  

2 Click the <New> button to create a new face window. 

3 From the Machining Function drop down menu select Mill 4 Axis Plane 

4 Type Off Center Holes in the Rename To: field and press <Enter>.  

When completed, your Setup dialog should appear as shown below:      
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Creating Geometry in CAD Mode 
In this section, you will create the geometry for the three holes. 

1 From the View menu, choose Show Axes. 

2 From the View menu, choose Show Boundaries. 

3 Go to CAD mode by clicking on the CAD/CAM switch.  

4 Select the Circle with a Known Radius and Center icon. This will allow 
you to draw the first of the three 0.125 (3.00) diameter holes.  

5 Enter a value for the radius of .125/2 (3/2) in the field at the bottom of the 
face Window press <Enter>.  

6 Select the XY coordinates icon from the Snap Mode icon bar.  

7 In the lower left hand corner of the window you are prompted for the X and Y 
location for the first hole. Enter –.200 (-5.00) for X and zero (0) for Y and 
press <Enter>. A circle should now appear on the negative side (left) side of 
the vertical axis and on the Y-axis line.  

Your window should look like the one below: 

 
8 To draw the remainder of the holes choose the Selection icon and select the 

circle that you drew on your screen by clicking on it.  
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9 After the circle is highlighted, select Translate from Transform submen 
found under the Edit menu.  Enter parameters as shown here and click 
<Translate>: (metric users enter a Y Distance of 7.5) 

 
Now you will translate the first circle you created -.300 (-7.5) in Y. To do so:  

10 Select the first circle you drew using the Selection icon. 

11 Select Translate from the Tranform submen found under the Edit menu 
again.  Enter parameters as shown here and click <Translate>: (metric 
users enter a Y Distance of 7.5) 
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Your window should look like the one below: 

 

Creating the Off Center Holes 
In this section, you will define the holes to be machined on the top of the part. 

1 Click the CAD/CAM switch such that it appears as a drill bit.  

2 Select New Hole Group from the Part Features menu.  

3 Uncheck the Through Hole box. 

4 From the Type: drop down menu, select Drill. 

5 Enter a Diameter of 0.125 (3.00) 

6 Enter a Nominal Depth of 0.500 (12.00) 

7 In the To: drop down menu, select Shoulder of Major Tool 

8 Click the <Cycle> button. In doing so, PartMaker found an existing cycle 
from the Cycles database where the major operation was a .125 (3.00) 
diameter drill.  The completed dialog should appear as shown below: 
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9 Click the <Verify Shape> button to see the shape of your hole. 

 
10 Once you are satisfied that your dialog and hole shape appear as the ones 

above, click  <Hide Shape> and <Close> to exit the dialog.   

You will now specify the holes you want to machine.  

1 Select the Chain Circle icon.  

2 Click your cursor somewhere near the first hole you want to machine.  In this 
case you will select the lower hole in the window as shown below: 
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Verifying the Tool Path 
You can now verify the tool path of the operation you have just programmed.   

1 Click anywhere within the Face Window to un-highlight the holes.  

2 Select Verify Work GroupTool Path from the Part Features to see the 
tool path displayed below:  

 
3 When you are satisfied that your toolpath appears as the one shown, choose 

Hide Work GroupTool Path from the Part Features, 

Now save your work by pressing <Ctrl+S>.  You have finished the 4th axis tutorial 
part.  
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Creating an NC Program 
At this point, you have completed creating the five faces for the tutorial part.  You 
are now prepared to take the final steps in developing your machine specific Part 
Program. 

Generating a Process Table  
The first step in generating an NC program is creating a Process Table.  A process 
table shows you all of the machining processes for a part.  When PartMaker 
generates a process table, all cutting conditions such feed rate and spindle speed 
(RPM) are calculated automatically based on the tools and material information 
previously entered. 

1 Choose Generate Process Table from the Job Optimizer menu.  

 
2 Click on <OK> to display the Process Table shown below: 
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Selecting a Post Processor 
Having generated a Process Table you must now select a Post Configuration File 
before you can output an NC progrm.   

1 Choose Post Config File = ? from the Job Optimizer menu. 

2 Select the 4a-rot-table-generic.pst postprocessor from the 4th-axis- 
Rotary directory as shown below.   

 
3 Click on the post processor and click the <Open> button to load the post 

processor. 

Simulating the Process 
Now that the Process Table has been generated you can simulate the entire 
machining operation for the part 

4 Click the Simulation button at the bottom left hand portion of the Process 
Table.  

5 Press the <Space Bar> or choose Simulation from the Simulation menu.  
Below a picture of the simulation in process is shown: 
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Once simulation has completed, you can choose Show Finished Part from the 
Simulation menu to view a completed solid model of the finished part. 

 

Shown above is the finished part in the Simulation window. 

Generating an NC Program 
Having selected a Post Configuration file, you are now ready to generate an NC 
Program.   

1 Choose Generate NC Program from the Job Optimizer menu. 

 
2 Click <OK> in the Post Options Dialog to proceed to the Save NC 

Program dialog. 

3 In this dialog, enter a name for your program in the File Name: field.  Here 
we have entered the Tutorial. 
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4 Click <Save> to generate the NC program.  

The completed NC Program is shown below: 
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Appendix F: The 5-Axis Milling Tutorial 
Part 

The drawing below shows a part print of the part you will be programming in this 
tutorial:  

Inch Units 
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Metric Units 

 

 

For this tutorial, you will work with an imported Solid Model.  A graphic of the solid 
model is shown below: 

 

 Important!  To complete this tutorial, you must have licensed the PartMaker 
Production Milling Module (PMM), the PartMaker Parasolid Import Module and 
the PartMaker 5th Axis Milling Module. 
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How you’ll create the 5 Axis Mill tutorial part 
You will complete the following steps in working through this tutorial: 

1 Importing the solid file 

2 Transfer geometry for a 5 axis plane 

3 Perform milling operations in the chosen plane  

4 Duplicate step 3 for the other faces 

5 Generate the Process Table 

6 Simulate the machining of the part 

7 Generate an NC program 

Introduction 
The first part of any programming exercise with PartMaker’s 5 Axis milling module is 
to decide which machining functions will be used.  

The machining functions used in this tutorial are as follows:  

Mill 5 Axis Plane 
Use an end mill to create hexagonal flats on the end of the part and mill .3386” 
(8.50) diameter hole .250 (6.35) inches deep. 

This tutorial will help you learn the steps to go through in using PartMaker to 
program a PartMaker Mill part that requires 5-axis milling. This tutorial uses a solid 
model. 

Getting Started 
Now you will look in detail at the steps necessary to program each of the 
components of the finished part.  The components of the completed tutorial for the 
5 Axis Milling part can be found in the following directories: 

Completed Job File: C:\PartMaker\PM-Mill\5-axis-demo\5-axis-job.JOB 

Completed Tools File: C:\PartMaker\PM-Mill\5-axis-demo\5-axis-job.TDB 

Completed Cycles File: C:\PartMaker\PM-Mill\5-axis-demo\5-axis-job.CDB 
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Starting PartMaker 
Start the PartMaker Milling application. An icon containing the PartMaker logo will 
appear for a few moments.  You will then see the Setup definition dialog box shown 
below.  Click the <Close> button.  This dialog will be explained in greater depth 
starting on page F-10. 

 

Setting Preferences for the 5-Axis Exercise 
In this section, you will setup the necessary preferences for this exercise.   

1 Choose Preferences from the View menu.  

2 Check the Display Axis Symbol item.  It  may already be checked.  
Checking this box will display the axes you are working with in the lower left 
hand corner of each Face Window.  

Your completed Preferences dialog should appear as the one shown below: 

 
3 Click <OK> to close the Preferences dialog. 
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Opening the Tools file 

The tools library for the 5-Axis Programming Exercise has already been created.  To 
open the tools library: 

1 Choose Open Tools File from the File menu 

2 Open the 5_axis_job.tdb from the C:\PartMaker\PM-Mill\5-axis-demo\5-
axis-job.TDB directory as shown below: 

 
Once you have loaded the tools database, you can view the tools that you will be 
using for this programming exercise.  To do so: 

3 Choose Tools from the ToolMinder menu.  This tools file contains five tools.  
The first of these appears below: 

 
4 Click the <Close> button to close the Tool Data dialog. 
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Opening the Cycles file 
At this point, you should be familiar with the concept of Cycles in PartMaker. Cycles 
are sequences of repetitive operations that go into machining a hole.  The cycles 
library for the 5-Axis Programming Exercise has already been created.  To open the 
cycles file: 

1 Choose Open Cycles File from the File menu.  

2 Open the 5_axis_job.CDB from the C:\PartMaker\PM-Mill\5-axis-demo 
directory as shown below 

 
You can view the cycle that you will be using for this programming exercise.  To 
do so:  

1 Choose Cycles from the ToolMinder menu. 

 
We will use the drill-1/4 cycle to create the six drilled holes on the work piece. 

2 Click the <Close> button to close the Cycles Data dialog. 
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Select a Material for the Part 
The work piece in this exercise will be machined from aluminum alloy wrought.  
To load this material: 

1 Choose Open Material File from the File menu. 

2 Choose alu_allw.mdb as shown below and click <Open>. 

 
You have now loaded the tools, cycles, and material files that were previously 
developed for the 5 Axis tutorial. PartMaker has also provided a completed job file. 
At this point you will not open the job file. You will be guided through a step-by-step 
process to develop a job file for the tutorial. 
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Importing the Solid Model 
Note: We will use a Parasolid .x_t formatted file for this exercise.  The .x_t file is 
called 5_axis_job.x_t and is located in the C:\PartMaker\Pm-Mill\5-axis-demo 
directory. 

1 Choose Import  X_T Parasolid Transmit Text file from the File menu or 
select the Import button on the main menu tool bar.  

2 Select 5_axis_demo.x_t from the C:\PartMaker\Pm-Mill\ 5-axis-demo 
directory. 

 
Your screen should appear as below after you import the 5-axis solid model: 
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Setting Up the Face Window 
In this section, you will set up the Face Window for the Hexagonal Flats.  To do 
so: 

1 Choose Setup from the View menu to view the Setup dialog box.  In this 
dialog, you will define the machining methods, part boundaries and location 
of the stock with respect to the programming origin.  

The default setup screen will appear as shown below. 

 
2 From the Table drop down menu select Rotary 5 Axis. 

3 From the Stock drop down menu select Cylinder. 

4 From the Machining Function drop down menu select Mill 5 Axis Plane.  

5 Rename the current face window by clicking on Front in the List of Face 
Windows: field and type Mill 5 AXIS in the Rename To: field and click the 
<Apply> button. 

6 Now enter the parameters listed below in the appropriate fields: 

Length (L): 3.0 (76.0) 

OD 2.0 (50.0) 

ID 0 (0) 
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When you are finished, your Setup dialog should appear as shown below: 

 
7 When you are satisfied that your Setup dialog appears as the one above, 

click the <Apply> button. This will apply the parameters to the current face 
window.   

Setting Up the 5-axis Table 
At this point you will setup the 5-Axis Rotary Table being used in this exercise. 

The Settings dialog is accessed for the Table Type: 5 Axis Rotary by clicking the 
Settings button.  The Settings dialog is used to define the dimensions and 
appearance of the machining table in PartMaker’s 3D machining simulation for both 
block and cylinder stock.  

A description of all of the fields for the 5 Axis Rotary Table Settings dialog is 
located in Chapter 2 of this manual. 
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To setup the rotary 5-axis table: 

1 From the Table section of the Setup dialog, click the Settings button to 
enter the 5-Axis Rotary Table Settings dialog. 

2 Enter the values shown above on the 5 Axis Rotary Table Settings dialog. 

3 When you are satisfied that your 5 Axis Rotary Table Settings dialog 
appears as the one above, click the <OK> button. 

4 Click the <Close> button to close the Setup dialog. 

Saving Your Work 
At this point save your work by choosing Save Job File As from the File menu.  In 
the file name box type in a name and select <Save>.  Be sure to give your file a 
name you will remember. 

Transfer geometry for a 5 axis plane 
In this section you will transfer the geometry of the part from the solid model and 
establish the angular orientation of the 5-axis rotary table during machining. 

1 Choose Setup from the View menu to view the Setup dialog box 

2 Click the Face Options button in the lower left area of the Setup dialog box 

3 The default Face Options dialog will appear as shown below. 

 
A description of all of the fields for the Face Options dialog is located in 
Chapter 2 of this user manual. 

4 Check the Break Arcs Into Lines box in the Arc Output Options section 
of this dialog. 

 Important: Checking this box breaks arcs into small lines.  Doing so may be 
necessary for some 5-axis milling machines with rotary fixtures because they 
do no support interpolation (i.e.G2’s and G3’s) in arbitrary 5-axis planes. 

5 Click <OK> to close the Face Options dialog. 

6 Click <Close> to close the Setup dialog. 

7 Click the CAD/CAM switch to enter the CAD mode. 

8 Choose Show Axes from the View menu.  This will display the horizontal 
and vertical axes lines which will help you create the geometry in the next 
section of the tutorial. 
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9 Choose Show Boundaries from the View menu.  A rectangle should now 
appear on the screen that indicates the boundaries of the stock. 

 
10 From the Window Menu, choose Arrange Windows to display the Solid 

Model. 

11 Double click on the surface as shown below: 

 
Doing so will open the Surface Info dialog as shown below: 
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12 Click the Transfer Planer Geometry button to transfer the required 
geometry to the Mill 5 Axis Face Window.  Click anywhere to deselect. Your 
face window will appear as shown below: 

 

 Note: Transferring the geometry from the solid model will also set the 5 axis 
milling parameters for this face window. You may return to the Face 
Options dialog accessed from Setup dialog to view this.  The transferred 
parameters can be viewed in the Orientation Options section of this dialog. 

 
The 5 axis milling parameters found the in Orientation Options section of this 
dialog are defined as follows: 

Index Angle (C): This field represents the rotary angle to which to stock is 
indexed on the 5-axis table.  

Inclination Angle (B):  This field represents the angle about the Z axis at 
which the machining plane is oriented.  The tool will be perpendicular to this 
plane.  

Local Origin (Xo)/Local Origin (Yo)/Local Origin (Zo): These fields 
represent the co-ordinates for the local origin created to planar face to be 
machined. These represent coordinates with respect to the work piece’s global 
coordinate system origin after the work piece is indexed by the Index Angle (C). 
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Perform Milling Operations for the Chosen Plane 
In this section you will create the part features and tool paths necessary to 
complete machining this plane. 

 Note: Milling operations are preformed the same as any other PartMaker 
Milling face window and will use Z-oriented tools. 

Creating the Contour Mill Profile  
In this section, you will define the profile to machine the flat surface on the edge of 
the cylinder. 

1 Click the CAD/CAM switch such that it appears as a drill bit. This will put you 
back into the CAM mode. 

2 Select New Profile Group from the Part Features menu.  

3 In the Group Name: box type in Contour_1 

4 Choose Contour Mill from the  Strategy: drop down menu. 

5 Choose On from the  Tool Position: drop down menu. 

6 Enter a Value for Z_Surf that would be the maximum thickness of stock you 
will be cutting.  In this case enter 1. 

 Note: The face windows Z datum surface has been set to the surface that 
was used to bring the geometry into the face window. (Z zero surface for 
this window) 

7 Enter the same value for the Z_Depth as you did for Z_Surf, i.e. 1. Doing so 
will result in the final cut will being taken at the Z surface of the geometry 
that was used to bring the geometry into the face window from the solid 
model. 

8 Enter 1.1 for Tool Diameter number.  Click on the <Select Tools> button.  
The endmill icon will appear to the right of the Tool ID box.  

Note: In this exercise we will be only taking one pass. 

9 Uncheck Roughing and check Finishing. 

10 Enter 0 in the Axial Step field. 
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The completed dialog should appear as shown below: 

 
11 When you are satisfied that your Profile Group Parameters dialog matches 

the one above, click the <Close> button.  
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Develop the Tool Path 
1 Select the Define Profile icon.  

2 Click on the Middle of an Element Snap Mode icon located across the top 
of the Face Window. 

 
3 Select the left side of the shape by clicking the left mouse button as 

indicated above. 

4 Now select the right side of the shape by clicking the left mouse button as 
indicated above. 

5 Your screen should now have a tool profile on it. This will mill the flat surface 
on one of the flats. 

Your window should look like the one below: 

 
6 Choose the Selection icon and select the tool path that you created on your 

screen by clicking on it.  
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7 Select Approach, Escape from the Part Features drop down menu after 
the tool path is highlighted.  Enter the parameters as shown here: This will 
allow the end mill to start and exit its path off of the work piece. Approach –
1.2 (-30) , 1 (25). 

 

 Note: Approach, Escape Command; this command allows to enter 
coordinates for either approach or escape point for a selected profile. 

Verifying the Tool Path 
You can now verify the tool path of the operation you have just programmed.   

1 Click anywhere within the Face Window to un-highlight the tool path.  

2 Select Verify Work GroupTool Path from the Part Features to see the 
tool path displayed below:  

 
3 When you are satisfied that your toolpath appears as the one shown, choose 

Hide Work GroupTool Path from the Part Features to hide the tool path.  

4 Now save your work by pressing <CTRL+S>.  You have finished the contour 
mill of the flat face. 

The next step will be to program the interpolated hole. 
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Modifying Geometry in CAD Mode 
In this section, you will edit the geometry for the interpolated hole. 

1 Go to CAD mode by clicking on the CAD/CAM switch.  

2 Choose the selection icon and select the circle in the screen. It should now 
be highlighted.  

3 Choose Divide Equal from the Edit Menu as shown below to break the circle 
into 2 pieces of geometry.  

 
4 Click anywhere in the Face Window to deselect. 
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Creating the Milled Pocket 
In this section, you will create the milled hole. 

1 Go to CAM mode by clicking on the CAD/CAM switch.  

2 Select a new color from the color palet located at the top right of your 
screen. 

3 Select New Profile Group from the Part Features menu.  

4 Choose Pocket Mill from the  Strategy: drop down menu. 

5 Click on the Spiral radio button. 

6 Enter .010 (.250) for Wall Finish (w):  and 0 for Bottom Finish (b): 

7 Enter .250 (6.00) for Tool Diamter number. Click on the <Select Tools> 
button.  The endmill icon will appear to the right of the Tool ID box.  

 Note: In this exercise we will be taking two passes.  

8 Check Roughing and Finishing. 

9 In the Group Name: box type in Pocket_0.25 (6.00) 

10 Select the check box for Extract Parameters from Solid. 

11 Select the side wall of the hole as shown below: 

 
12 Press the Extract button and the depth will be entered. 
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13 Once you are satisfied that your dialog appears as the ones below, click  
<Apply> and <Close> to exit the dialog. 

 
You will specify the hole you want to machine. To do so:  

1 Select the Chain Geometry icon to select the hole on the PartMaker mill 
window 

or 

Use the Select Geometry on Solid Model icon to select the hole on the solid.  

2 Click your cursor somewhere near the hole you want to machine.  In this 
case you will select the upper right side of the hole this will cause the profile 
to be in a counter clockwise rotation. 

 
The hole you have chained should now be highlighted in the Sample Color. 
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Verifying the Tool Path 
You can now verify the tool path of the operation you have just programmed.   

1 Click anywhere within the Face Window to un-highlight the holes.  

2 Select Verify Work GroupTool Path from the Part Features to see the 
tool path displayed below:  

 
3 When you are satisfied that your toolpath appears as the one shown, choose 

Hide Work GroupTool Path from the Part Features to hide the tool path 
displayed. 

Now save your work by pressing <CTRL+S>.  You have finished the surface 
and pocket milling operations for the 5 axis tutorial.   

The next step will be to duplicate this window.  
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Duplicating the Face Window  
In this section, you will duplicate the Mill 5-Axis window you have created by using 
Duplicate function in the Setup dialog. You will make 5 copies of your original 
window at 60 degree increments. To do so: 

1 Choose Setup from the View menu to view the Setup dialog box.  

2 Click the <Duplicate> button to open the Duplicate Face dialog. 

3 Enter 5 in the Number of Copies (N): field  

4 Enter 360/6 in the Index Angle Increment (A): field.  

5 Uncheck Insert Into List Of Faces. 

6 Check on Display Parameters Next to Face Names. 

The Duplicate Face dialog should appear as shown below: 

 
7 Click <OK> to duplicate the faces.  

You will now see displayed beside the Mill XY name the number of copies (5) and 
the increment angle (60) as shown below. No new windows have been listed.  

 
8 When you are satisfied that your Setup dialog appears as the one above, 

click the <Apply> button. This will apply the parameters to the current face 
window.  Click the <Close> button to close the Setup dialog. 
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Creating the NC Program 
At this point, you have completed creating the faces for the tutorial part.  You are 
now prepared to take the final steps in developing your machine specific Part 
Program. 

Generating a Process Table  
The first step in generating an NC program is creating a Process Table.  A process 
table shows you all of the machining processes for a part.  When PartMaker 
generates a process table, all cutting conditions such feed rate and spindle speed 
(RPM) are calculated automatically based on the tools and material information 
previously entered. 

1 Choose Generate Process Table from the Job Optimizer menu. 

 
2 Click on <OK> to display the process table shown below: 

 

 Note: Only three processes are listed in the process table but each of the six 

faces will be machined.  The overlapping rectangles to the left of the Mill 
5-Axis in the Face column indicate the existence of duplicated window. 
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Selecting a Post Processor 
Having generated a Process Table you must now select a Post Configuration File 
before you can output an NC progrm.   

1 Choose Post Config File = ? from the Job Optimizer menu. 

2 Select the 5a-rot-table-generic.pst postprocessor from the 5-axis- demo 
directory as shown below.   

 

Simulate the Machining of the Part 
Now that the Process Table has been generated you can simulate the entire 
machining operation for the part 

1 Click the Simulation button at the bottom left hand portion of the Process 
Table. 

2 Press the Space Bar or choose Simulation from the Simulation menu. 

 
Shown above is the part in the Simulation window.   

3 From the Simulation menu choose show finished part to show the 
completed part. 
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Generate the NC program 
Having selected a Post Configuration file and you are now ready to generate an NC 
Program.   

1 Choose Generate NC Program from the Job Optimizer menu. 

 
2 If your machine requires NC-code coordinates in the local inclined plane, 

select Local Coordinates from the 5 Axis Output section of the Post Options 
dialog. If your machine requires global coordinates, select Global 
Coordinates. 

3 Click <OK> in the Post Options Dialog to proceed to the Save NC 
Program dialog.   

4 In this dialog, enter a name for your program in the File Name: field. 

 
5 Click <Save> to generate the NC program.  
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The completed NC Program is shown below: 
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