Электронные издания: Об издании

УДК 621.28
ББК 38.85я7
В88

Вуль В.А.

Электронные издания: Учебник
М.-СПб.: Изд-во «Петербургский институт печати», 2001. 308 с. 1000 экз.

Рекомендовано УМО в качестве учебника для специальностей 021500, 021600, 220200

В учебном пособии «Электронные издания» рассмотрены совокупность проблем, связанных с созданием, распространением и чтением таких изданий. В частности, предложена их классификация и определено место в современной медиа-индустрии, описаны основные элементы языка HTML и его применение при создании таких изданий. Рассмотрено использование различных HTML-редакторов и специализированных программных средств создания электронных и мультимедийных изданий (MS FrontPage, Macromedia Director, DreamWeaver и Flash, а также 3D Studio MAX)

Дополнительно в учебное пособие включены разделы, связанные с публикацией и хранением электронных изданий с помощью баз данных, а также семантическим анализом, индексацией и организацией поиска и долговременного хранения электронных документов. Описаны электронные библиотеки как одно из сетевых средств распространения изданий, а также новейшие аппаратные и программные средства E-Book. Анализируются возможности использования электронных изданий в учебном процессе, включая самостоятельную работу студентов, в том числе - при дистанционном обучении.

ISBN 5-93422-015-2
© В.А. Вуль, 2001
© Н.А. Аксиненко, оформление, 2001
© Московский государственный университет, 2001
© Издательство «Петербургский институт печати», 2001


Электронные издания: Указатель компаний

Указатель компаний
Adobe Systems Форматы электронных изданий Современное состояние и перспективы электронного книгоиздания Форматы представления текстовых блоков электронного издания Форматы представления графической информации Подготовка документов в PDF-формате Программные средства для работы с электронными изданиями в PDF-формате Стандарт Open E-book
Alchemy Mindworks Программы-конструкторы для подготовки анимационных GIF-файлов Программы-конструкторы для подготовки анимационных GIF-файлов
Aldus Форматы представления графической информации
America Online Электронные книжные магазины
Apple Форматы цифрового видео
Barnes i Nobles Электронные книжные магазины
CompuServe Форматы представления графической информации
Electronic Book Consortium Современное аппаратное средство E-book
Hewlett-Packard Стандарт Open E-book
IBM Стандарт Open E-book
LiveUpdate Программные средства для воспроизведения аудиофайлов
Macromedia Современное состояние и перспективы электронного книгоиздания Общая характеристика и интерфейс пакета
Microsoft Современное состояние и перспективы электронного книгоиздания Понятие о динамическом HTML и его компонентах Форматы цифрового видео Форматы цифрового видео Общая характеристика типовых HTML-редакторов первой группы Общая характеристика типовых HTML-редакторов первой группы Программы-конструкторы для подготовки анимационных GIF-файлов Программы-конструкторы для подготовки анимационных GIF-файлов Общая характеристика пакета MS FrontPage 2000 Стандарт Open E-book
Mitsubishi Мониторы и требования к ним
NEC Мониторы и требования к ним
Netscape Понятие о динамическом HTML и его компонентах Общая характеристика типовых HTML-редакторов первой группы Назначение и общая характеристика браузеров
Nokia Мониторы и требования к ним
NuvoMedia Стандарт Open E-book
Open EBook Authority Group Стандарт Open E-book
Open Electronic Book Forum (OEBF) Стандарт Open E-book
Opera Software Назначение и общая характеристика браузеров
Philips Другие виды оптических накопителей
Pitney Bowes Электронные книжные магазины
RealNetworks Программные средства для воспроизведения аудиофайлов
Sausage Software Общая характеристика типовых HTML-редакторов первой группы
Sharp Современное аппаратное средство E-book
SiliconGraphics Назначение и общая характеристика браузеров
SoftBook Press Стандарт Open E-book
Sony Мониторы и требования к ним
Sun Информационная структура современного издательства
Tumbleweed Электронные книжные магазины
Ulead System Программы-конструкторы для подготовки анимационных GIF-файлов Программы-конструкторы для подготовки анимационных GIF-файлов
World Wide Web (W3C) Общая характеристика типовых HTML-редакторов первой группы
World Wide Web Consortium (W3C) Общая характеристика и структура HTML-документа
Геликон Плюс Электронные книжные магазины
Издательский Дом «Питер» Электронные книжные магазины
Комитет MPEG (Motion Picture Expert Group - группа экспертов в области движущихся изображений) Форматы представления аудиофайлов


Электронные издания: Об электронном издании

Московский государственный университет печати

Вуль В.А.

Электронные издания

Учебник

Электронное издание подготовлено коллективом Центра дистанционного образования МГУП на основе оригинал-макета одноименного учебника, предоставленного издательством МГУП.

Текст печатного оригинала оставлен без изменения. Сноски оформлены в виде подсказки, содержание которой появляется при подведении курсора мыши к специальному значку.

Справочно-сопроводительный аппарат издания дополнен предметным указателем, выполненным в виде гипертекста, что позволяет свободно переходить из указателя на то место в тексте, где находится упоминание термина или его объяснение. В тексте учебника также проставлены ссылки на указатель. Указатель иллюстраций позволяет просматривать иллюстрации, минуя поиск в тексте. К сожалению, при работе над электронным изданием мы располагали только оригинал-макетом в формате PDF, из которого достаточно сложно получить электронные иллюстрации хорошего качества. Чтобы избежать потери информативности иллюстраций, размер их выбран большим, чем можно было ограничиться, подготавливай мы иллюстрации заново.

Если при работе с электронным изданием у вас возникнут какие-либо замечания, пожалуйста, [image] напишите нам об этом.

Юрусова А.М.
Один экземпляр электронного издания хранится на CD-ROM [image] в фондах библиотеки МГУП (г. Москва, ул. Прянишникова, 2а.)
В серии электронных изданий, размещенных на образовательном портале МГУП, в число которых входит и данное издание, приняты следующие обозначения:
Текст сноски | Сноска, заметка, информационное сообщение
Надпись к рисунку | Иллюстрация, открывающаяся в новом окне
Надпись к рисунку | Иллюстрация, раздвигающая текст
Имя персоны | Переход в именной указатель
Термин, или имя пункта иного указателя | Переход в предметный или иной (кроме именного) указатель
Надпись к схеме | Схема, диаграмма
"Список источников" | Список литературы
Название главы, в которую производится возврат | Возврат из указателя в основной текст

Дата публикации 30.10.2002. Дата обновления 14.11.2002

Авторы электронной версии
Каллиников П.Ю. | Концепция
Петров А.М. | Программирование, HTML
Бродская Е.А., Юрусова А.М., Балацкий В.Н. | Подготовка текста и аппарата издания
Соловьева А.В. | Дизайн обложки электронного издания
публикатор xBook, версия 2.02b


Электронные издания: Иллюстрации

Иллюстрации
Рис. 01.01.
Рис. 01.02. (2)
Рис. 02.01.
Рис. 02.02. (2)
Рис. 02.04.
Рис. 02.05.
Рис. 02.06. (2)
Рис. 02.07.
Рис. 02.08. (3)
Рис. 02.09.
Рис. 02.10.
Рис. 02.11. (2)
Рис. 02.12.
Рис. 02.13.
Рис. 02.14.
Рис. 03.01.
Рис. 03.02.
Рис. 03.03.
Рис. 03.04. (3)
Рис. 03.05.
Рис. 03.06.
Рис. 04.01.
Рис. 04.02. (2)
Рис. 04.03. (2)
Рис. 04.04. (2)
Рис. 04.05. (2)
Рис. 04.06.
Рис. 04.07.
Рис. 04.08.
Рис. 04.09. (3)
Рис. 04.10.
Рис. 04.11.
Рис. 04.12. (2)
Рис. 04.13. (3)
Рис. 04.14. (2)
Рис. 04.15. (2)
Рис. 04.16.
Рис. 04.17.
Рис. 04.18. (2)
Рис. 04.19.
Рис. 04.20.
Рис. 04.21. (3)
Рис. 04.22. (2)
Рис. 04.23.
Рис. 04.24.
Рис. 04.25. (2)
Рис. 04.26.
Рис. 04.27. (2)
Рис. 04.28.
Рис. 04.29.
Рис. 04.30.
Рис. 04.31.
Рис. 04.32.
Рис. 04.33. (3)
Рис. 04.34.
Рис. 04.35.
Рис. 04.36.
Рис. 04.37.
Рис. 04.38.
Рис. 04.39. (2)
Рис. 04.40.
Рис. 04.41.
Рис. 04.42. (2)
Рис. 04.43.
Рис. 04.44.
Рис. 04.45.
Рис. 04.46.
Рис. 04.47.
Рис. 04.48.
Рис. 05.01.
Рис. 05.02.
Рис. 05.03. (4)
Рис. 05.04.
Рис. 05.05.
Рис. 05.06.
Рис. 05.07.
Рис. 05.08.
Рис. 05.09. (3)
Рис. 05.10.
Рис. 05.11.
Рис. 05.12. (2)
Рис. 05.13. (2)
Рис. 05.14. (2)
Рис. 05.15.
Рис. 05.16.
Рис. 05.17.
Рис. 05.18. (2)
Рис. 05.19. (2)
Рис. 05.20. (3)
Рис. 05.21. (4)
Рис. 05.22. (3)
Рис. 05.23.
Рис. 05.24. (4)
Рис. 05.25. (2)
Рис. 05.26.
Рис. 05.27.
Рис. 05.28.
Рис. 05.29.
Рис. 05.30.
Рис. 06.01. (6)
Рис. 06.02. (2)
Рис. 06.03. (2)
Рис. 06.04.
Рис. 06.05.
Рис. 06.06.
Рис. 06.07. (2)
Рис. 06.08.
Рис. 06.09.
Рис. 06.10. (2)
Рис. 06.11.
Рис. 06.12.
Рис. 06.13.
Рис. 06.14.
Рис. 06.16.
Рис. 06.17.
Рис. 06.18. (3)
Рис. 06.19.
Рис. 06.20.
Рис. 06.21.
Рис. 06.22.
Рис. 06.23.
Рис. 06.24.
Рис. 06.25.
Рис. 06.26.
Рис. 06.27.
Рис. 06.28.
Рис. 06.29.
Рис. 06.30.
Рис. 06.31. (5)
Рис. 06.32. (2)
Рис. 06.33.
Рис. 06.34.
Рис. 06.35. (2)
Рис. 06.36.
Рис. 06.37.
Рис. 06.38.
Рис. 06.39.
Рис. 06.40. (2)
Рис. 06.41.
Рис. 06.42. (3)
Рис. 06.43. (3)
Рис. 06.44.
Рис. 06.45.
Рис. 06.46.
Рис. 06.47.
Рис. 06.48.
Рис. 06.49.
Рис. 06.50. (2)
Рис. 07.01.
Рис. 07.02.
Рис. 07.03. (4)
Рис. 07.04.
Рис. 07.05. (4)
Рис. 07.06.
Рис. 07.07. (2)
Рис. 07.08.
Рис. 07.09.
Рис. 07.10.
Рис. 07.11.
Рис. 07.12. (2)
Рис. 07.13.
Рис. 07.14.
Рис. 08.01.
Рис. 08.02.
Рис. 08.03.
Рис. 08.04.
Рис. 08.05.
Рис. 08.06.
Рис. 08.07.
Рис. 08.08.
Рис. 08.09.
Рис. 08.10.
Рис. 08.11.
Рис. 08.12.
Рис. 08.13.
Рис. 08.14.
Рис. 08.15.
Рис. 09.01.
Рис. 09.02.
Рис. 09.03.
Рис. 09.04. (2)
Рис. 09.05. (2)


Электронные издания: Именной указатель

Именной указатель
Гутенберг Иоганн Что такое «электронное издание»
Зипф Дж. Законы Зипфа и автоматизация извлечения метаданных из электронных изданий


Электронные издания: Навигатор

переход в начало переход назад переход вперед переход в конец
именной указатель предметный указатель указатель иллюстраций указатель компаний
сузить расширить


Электронные издания:

Предисловие

В настоящее время производство печатной продукции все больше интегрируется в единое пространство медиа-индустрии. Составной частью этого процесса является интеграция печатных и электронных изданий. Причин такой интеграции несколько. С одной стороны, практически все информационные технологии перешли на цифровую форму, оснастились компьютерной техникой, программным обеспечением профессионального уровня, техническими средствами обработки изображений. С другой - тот же процесс происходит и с распространением любых видов информационной продукции: появились компакт- и DVD-диски с электронными изданиями, а также музыкой и видео. Издательства внедрили новейшие сетевые технологии, связанные с распространением медиа-информации по интра- и экстрасетям, в глобальной сети Интернет.

Электронное издание значительно дешевле, чем печатное, и изготовление такого издания не связано с расходом трудно возобновимых ресурсов (леса) и загрязнением окружающей среды. Электронные издания зачастую оказываются даже более функциональными. Так, справочное или учебное электронное издание позволяет более динамично построить процесс изучения материала и усилить его мотивацию, что в конечном счете позволяет ускорить процесс восприятия и запоминания информации.

Если художественная литература преимущественно распространяется в привычной нам форме типографских изданий, то детские электронные издания уже существенно потеснили книги, так как последние не обладают многими возможностями электронных компьютерных технологий. Постепенно, но неуклонно продолжается наступление электронных изданий в учебной сфере, начиная со школьного обучения и до высшего образования.

Важнейшим преимуществом электронных изданий по сравнению с печатными является возможность их интерактивного оформления. Это относится не только к детским игровым изданиям, но и к любым изданиям сценарного типа. Такое издание может быть учебным, научно-популярным и даже художественным произведением, в котором потребителю отводится не пассивная роль читателя, но активная роль участника. Все фрагменты электронных изданий, моделирующие процессы, могут быть построены по этому типу, т. е. читатель сам становится участником событий и в определенных рамках может влиять на их исход, что сближает процесс работы над таким изданием с деловыми играми. Естественно, что в традиционной книжной форме невозможно достигнуть такого эффекта.

Еще одним проявлением интерактивности является возможность моделирования и визуализации достаточно сложных явлений, таких как ток и напряжение в электронных цепях, квантовое состояние атомов, их ядер и электронов, прохождение световых лучей в различных средах, включая анизотропные. Работая с соответствующими фрагментами электронного издания и самостоятельно определяя величины входных сигналов или углы падения световых лучей, пользователь чувствует себя участником происходящего компьютерного эксперимента, исследователем происходящих процессов и явлений. По нашему мнению, если такие операции выполняет студент, то они вполне могут быть названы виртуальными лабораторными работами.

В последние годы роль электронных изданий учебного и словарно-справочного характера непрерывно воз растает вследствие возможности их быстрой модификации в соответствии с изменением достигнутого уровня знаний, т. е. достигается чрезвычайно высокий уровень оперативности электронного издания. Особенно это заметно при работе с изданиями, распространяемыми по сетям. Если прибавить к сказанному возможность дистанционного общения преподавателя с одним или несколькими обучаемыми, дистанционного тестирования с использованием сети Интернет и определения и оценки уровня знаний, то можно прийти к выводу, что электронный учебник преобразуется в конечном счете в постоянно развивающуюся обучающую, справочную и контролирующую уровень знаний специализированную информационную среду.

Электронные издания не только публикуются в базах данных, но и могут применяется также в виде баз данных - реферативных и библиографических. Эти два вида изданий объединяет то обстоятельство, что они предназначены для квалифицированных пользователей, среди которых присутствуют как библиографы - работники крупных библиотек, так и научные работники, скрупулезно следящие за изданиями в своей предметной области. Неудивительно, что первые электронные издания были связаны именно с этой отраслью.

База данных, в которой хранятся (или публикуются) электронные издания, поддерживает каталогизацию и другие виды библиотечной деятельности, в частности, одну из важнейших - доступ читателей в публичный каталог, причем никаких специальных знаний, помимо своей предметной области, от читателей не требуется. База данных позволяет преодолеть основное ограничение в обслуживании читателей в библиотеках - она дает возможность многим пользователям использовать один и тот же материал одновременно за счет сетевой информационной структуры.

Наконец, здесь проявилось и другое очень существенное преимущество электронного издания в сравнении с любым изданием на бумаге: качество хранимого материала (текста, иллюстраций и пр.) никак не зависит от интенсивности его использования - этот материал не изнашивается и не стирается. Еще один фактор - электронное издание занимает значительно меньшие площадь и объем, что также является немаловажным экономическим фактором.

Электронные издания занимают все более заметное место в составе издательской продукции. По прогнозам к 2010 г. мировое производство печатной продукции в стоимостном отношении снизится с 60-70% до 35-50% от общего производства продукции медиа-индустрии, а производство электронных изданий в стоимостном выражении достигнет 25-30%.

Естественно, что тенденции развития издательского дела нашли свое отражение в учебном плане и Государственном обучающем стандарте по специальности 021500 «Издательское дело и редактирование».

В частности, в ГОСе перечислены основные темы, которые должны быть освещены в курсе «Электронные издания», а именно:

  • гипертекстовые документы, их структура и основные компоненты, языки гипертекста: HTML, Java, JavaScript;

  • представление информации, форматы для текстовой, графической и звуковой информации;

  • средства просмотра и подготовки электронных документов: программы-браузеры Netscape Navigator, MS Explorer, СУБД;

  • подготовка электронных документов в пакете FrontPage 2000, Macromedia DreamWeaver;

  • пакеты создания анимационной графики и мультимедиа Macromedia Director, Flash, Adobe Premier;

  • использование современных СУБД для публикации электронных изданий.

Хотя в периодических изданиях множество материалов посвящены производству и распространению электронных изданий, в том числе и с мультимедийными компонентами, пока отсутствуют как учебные пособия, так и монографии, в которых были бы рассмотрены соответствующие проблемы. В результате в настоящее время возникла настоятельная потребность в издании учебника по дисциплине «Электронные издания».

Нами накоплен определенный опыт в чтении этого курса студентам специальности 021500 «Издательское дело и редактирование». Курс полностью или отдельные его разделы были прочитаны и студентам некоторых других специальностей. Опыт чтения курса «Электронные издания», длительный опыт преподавания студентам специальности 021500 различных дисциплин, основанных на компьютерных и сетевых технологиях, а также опыт научно-исследовательской и методической работы и многочисленные доклады и публикации в этой области позволили нам осветить все темы, перечисленные в ГОСе по данной специальности. Кроме того, автор счел целесообразным включить в состав учебника некоторые дополнительные разделы, такие как распространение электронных изданий и электронные учебники, а также затронуть вопросы, связанные с HTML-формами, CGI-технологиями, метаинформацией и ее использованием при поиске электронных изданий в локальных и сетевых базах данных.

Автор надеется, что учебник будет полезен не только студентам специальности 021500 в процессе изучения курса «Электронные издания», но и студентам других специальностей, изучающим гипертекстовые системы, мультимедийные базы данных, Web-дизайн, стратегии поиска и индексации электронных документов.


Электронные издания:

1.
Глава 1. Общая характеристика электронных изданий

В первой главе будут рассмотрены в самой общей форме особенности и место электронных изданий в современной медиа-индустрии, составные элементы и форматы электронных изданий. Предпринята попытка классификации электронных изданий и показаны пути и перспективы их дальнейшего совершенствования и развития.

1.1.
Что такое «электронное издание»

Книгопечатание появилось в XV веке благодаря изобретению Гутенберг Иоганн Иоганна Гутенберга. Несколько веков печатные издания, т. е. книги, газеты и журналы, были основным средством распространения визуальной информации. Большую часть этого периода основой изготовления печатной продукции служил оригинальный металлический набор, а металлическая матрица (в заключительной части периода - стереотип) являлась информационной основой для тиражирования.

Во второй половине XX века появилось новой понятие - Невещественный носитель «невещественный носитель»,- под которым понималось любое электронное средство длительного хранения информации, на котором записано издание в целом или его часть. Чаще всего информация хранилась на магнитном носителе: магнитной ленте или магнитном диске. Однако такие носители оставались несовершенными: надежность хранения и плотность занесения информации были низки. Поэтому такие средства в издательской практике использовались достаточно редко. В большинстве отечественных издательств процесс подготовки изданий основывался на использовании «бумажных» технологий. Автор сдавал рукопись, напечатанную на пишущей машинке. В издательстве она редактировалась и в окончательном виде также перепечатывалась машинистками издательства, и этот издательский машинописный оригинал использовался в качестве основы для типографского набора.

Последние десятилетия XX века характеризуются быстрым совершенствованием и развитием электроники и компьютерных информационных технологий. Именно в этот период практически все издательства перешли на компьютерный набор и верстку газет, журналов и книг. Издание хранилось в памяти компьютера все время набора и верстки, т. е. оставалось в электронной (невещественной) форме в течение всего процесса подготовки, вплоть до вывода на принтер так называемого постраничного оригинал-макета. Полностью сверстанное и подготовленное к печати издание, хранимое в памяти компьютера (на жестком магнитном диске) или в специальном запоминающем устройстве долговременного типа можно назвать Электронное издание «электронным изданием».

Однако для того, чтобы электронная книга, журнал или газета действительно могли соперничать со своими печатными аналогами, необходимы средства их распространения, доведения до читателя. В конце XX века эти средства фактически стали массовыми, т. е. получили самое широкое распространение. Периодические электронные издания стали распространяться преимущественно по сетям, в частности, по глобальной Интернет сети Интернет. Информационной средой для распространения книг стали и остаются последние пятнадцать лет компакт-диски.

Итак, вначале электронные издания существовали как аналог печатных, но на невещественном носителе. Естественно, что для чтения электронных изданий, распространяемых по сетям, требовался персональный компьютер. Если же электронное издание было подготовлено на компакт-диске, то дополнительно требовался дисковод для чтения компакт-диска. Таким образом, издание на невещественном носителе или электронное издание не может быть прочитано непосредственно - нужно специальное дополнительное оборудование, чтобы сделать такое издание видимым для человеческого зрения или обеспечить его визуализацию.

Далее понятие Электронное издание «электронные издания» стало включать в себя тексты книг, журналов и газет, распространяемые в любом текстовом или ином формате, например в гипертекстовом (HTML) или одном из сжатых форматов (ZIP, ARJ, RAR, WINZIP и пр.). В последнее десятилетие XX века в составе электронных изданий стали применяться еще и мультимедийные компоненты, под которыми подразумеваются цифровые звуковые или видеофрагменты, а также анимационные вставки в основную часть издания. В результате электронные издания стали средством комплексного информационного воздействия на человека, сравнимого с радио, кино и телевидением, а в чем-то даже превосходящем эти важные средства массовой коммуникации.

Принципиальным отличием печатных от электронных изданий является возможность интерактивной реализации последних, при которой пользователь (читатель) может не только перемещаться по встроенным в текст гиперссылкам, но и активно вмешиваться в ход событий, моделировать процессы, в том числе производственные.

В последние несколько лет появились сетевые электронные издания. Большинство студентов уже знакомы с глобальной сетью Интернет и встречались с понятиями Web-сайт Web-сайт и Web-страница Web-страница. Последняя определяется как электронная страница в соответствующем формате, а Web-сайт - это набор связанных Web-страниц, объединенных общими признаками или назначением. В настоящее время в сети Интернет существует значительное количество сайтов, представляющих собой, по существу, электронные издания, т. е. аналоги книг или брошюр, но только в электронном сетевом представлении. В качестве примера можно сослаться на сайт «Электронные каталоги Российских библиотек», верхняя часть главной страницы которого представлена на рис. 1.1 Рис. 01.01..

Размер этой страницы достаточно велик, так как содержит перечень в несколько десятков библиотек с указанием тематики изданий, представленных в данной библиотеке, и особенностей поиска и извлечения информации из каталога каждой библиотеки. Если подвести указатель мыши к названию библиотеки, то он приобретет форму указателя (кисть руки с вытянутым указательным пальцем). Таким образом, название служит указателем перехода к другой странице, на которой организован поиск издания в соответствующей библиотеке. Для осуществления перехода следует щелкнуть левой кнопкой мыши по этому указателю перехода. Как создаются такие указатели и осуществляются переходы, мы рассмотрим во 2-й главе данной книги.

В описании каталога Государственной публичной научно-технической библиотеки есть ссылка на сводный каталог по научно-технической литературе, который также служит указателем перехода. Щелкнув мышью по соответствующему фрагменту текста, мы переместимся на страницы этого сводного каталога. Таким образом, с помощью электронных страниц и гиперссылок в сети Интернет создан мощный электронный справочник, заменяющий много толстых книг, содержащих соответствующие библиотечные каталоги. Причем поиск в этом справочнике производит не человек, а специальная поисковая система, которая работает во много тысяч раз быстрее и эффективней любого из нас.

1.2.
Составные элементы электронного издания

1.2.1.
Тексты

Основной частью большинства электронных изданий, также как и книг, выпущенных типографским способом, являются текстовые фрагменты. Некоторые издания вообще целиком текстовые. Если такое издание набрано на компьютере в любом текстовом редакторе, то его можно назвать Электронное издание электронным изданием. Разновидностью такого издания являются так называемые гипертекстовые документы- издания в специальном HTML-формате. Язык HTML и методика создания HTML-документов будет рассмотрена во второй главе, поэтому здесь мы не останавливаемся на этом подробно.

Если заглянуть во всемирную сеть Интернет, то там можно обнаружить некоммерческие электронные библиотеки [image] , в которых практически все издания представлены в текстовых или упакованных текстовых форматах, т. е. полученных в результате предварительного сжатия соответствующего файла специальными программами - архиваторами. Такие издания характеризуются минимальным информационным объемом и могут быть быстро загружены на компьютер пользователя.

Простейший текстовый формат использует кодировку отдельных символов текста в American Standart Code for Information Interchange (ASCII) - Американский стандартный код для обмена информацией ASCII-стандарте, в соответствии с которым каждый символ кодируется одним байтом. ASCII - это аббревиатура от American Standart Code of Information Interchange или, в переводе, Американский Стандартный код для информационного взаимодействия. Чем сложнее текстовый редактор, в котором набирается текстовый фрагмент, тем большее количество управляющих символов используется для форматирования текста, в результате чего информационный объем текстового фрагмента заметно растет.

В графической оболочке Windows для кодирования каждого символа используется не менее 2 б. В частности, в текстовом редакторе Word 97, в котором набирался этот учебник, на каждый кодируемый символ текста в среднем приходится около 5 б, причем в состав редактора включены средства внутреннего сжатия информации в файлах документов. Тот же текст, набранный в редакторе Word 6 или Word 7 (Word 95) под Windows, занимает значительно большее информационное пространство.

В некоторых случаях текст кодируется в графическом формате (например, формат PDF, который будет рассмотрен в § 3.2 и § 4.6). Это обеспечивает качественный визуальный интерфейс при просмотре издания, обеспечивает его независимость от шрифтовых гарнитур, установленных на компьютере пользователя, но требует применения специальных средств для его просмотра.

1.2.2.
Иллюстративный материал

Известно, что издательства и полиграфисты очень осторожны при включении иллюстраций, особенно цветных, в тиражируемые книги. Это связано с тем обстоятельством, что Иллюстрации иллюстрации требуют специальной обработки, в том числе - растрирования, а цветные еще и цветоделения, в результате чего усложняется и удорожается производство книг.

В электронных изданиях этой проблемы не существует, так как абсолютное большинство компьютеров снабжены цветными мониторами и программными средствами для воспроизведения иллюстративного материала. Поэтому в электронных изданиях следует использовать такое количество иллюстраций, которое требуется для наилучшего восприятия и понимания материала, причем эта величина всегда больше, чем в изданиях, тиражируемых печатным способом. Иллюстративный материал содержит на несколько порядков больше информации, чем текст, занимающий то же самое пространство на странице, и гораздо эффективней воздействует на чувства человека.

Скорость восприятия иллюстративной информации также многократно выше, чем скорость восприятия текста. Это связано с особенностями визуального восприятия информации человеком. Зрительные образы в виде графических объектов воспринимаются целиком и непосредственно заносятся в долговременную память, без промежуточного преобразования в понятия, как это происходит с текстом.

1.2.3.
Звуковое сопровождение

Неотъемлемой частью многих изданий является Звуковое сопровождение звуковое сопровождение. Звуковое сопровождение может представлять собой авторский текст или ремарки, шумовые эффекты, иллюстрирующие происходящие события и делающие их описание более реалистичным. Звук может синхронно сопровождать включенные в издание видеокадры или анимацию, что будет подробно изложено в последующих разделах учебника.

Скорость восприятия человеком звуковой информации имеет тот же порядок величин, что и для текста. Однако одновременная работа с текстовой и звуковой информацией не только увеличивает общую скорость восприятия, но и способствует более долговременному ее запоминанию, вероятно в результате образования определенных ассоциативных связей.

1.2.4.
Анимация и видео

Все мы смотрим телевидение, однако телевизионное вещание на всех отечественных каналах, кроме коммерческого канала НТВ+ и некоторых каналов кабельного телевидения, ведется в аналоговом формате. Цифровой формат, используемый в компьютерном видео, отличается несравненно более высоким качеством воспроизведения и разрешающей способностью, но требует большого объема памяти для хранения видеоинформации и высокой пропускной способности для ее воспроизведения с необходимой частотой кадров.

Поэтому гораздо чаще, чем видеофрагменты, в электронных изданиях используется компьютерная мультипликация или простые анимационные файлы. Они же очень часто встречаются на различных Web-страницах, причем во многих случаях используются в качестве рекламы. Однако такая мультипликация может с успехом использоваться для иллюстрации последовательности выполнения технологических операций, работы полиграфических машин и комплексов и даже последовательности выполнения операций в компьютерных программных пакетах. Во всех перечисленных случаях анимация играет вспомогательную роль, способствуя наглядности описания соответствующих процессов и лучшему пониманию и запоминанию их описания.

Цифровое компьютерное видео может успешно использоваться лишь на компьютерах с процессором и видеокартой высокой производительности, обеспечивающих скорости следования информационных потоков, достигающих, а иногда и превышающих 1 Гб/с.

1.3.
Форматы электронных изданий

В предыдущем параграфе уже упоминались форматы электронных изданий. Здесь мы поговорим от этом подробнее, впрочем, позднее мы будем еще не раз обращаться к этому вопросу. Если в обычной книге формат характеризует ее ширину и высоту, то в электронном издании формат описывает то, каким образом в файле представлена информация. В настоящее время для современных и качественных электронных изданий используются Форматы электронных изданий два основных формата, а именно:

  • PDF (Portable Document Format) PDF (Portable Document Format), разработанный фирмой Adobe Systems Adobe и представляющий развитие и совершенствование известного издательского формата описания страниц документов Post Script,

  • HTML (Hyper Text Markup Language) HTML (Hyper Text Markup Language) - гипертекстовый язык разметки страниц с помощью которого создано большое количество электронных документов, в том числе - абсолютное большинство изданий, циркулирующих в среде Интернет.

Главное достоинство обоих форматов состоит в возможности размещения в тексте издания гиперссылок, по которым осуществляются быстрые переходы как внутри данного издания, так и во внешние, по отношению к данному, документы. В частности, с помощью гиперссылки можно связаться с автором или издателем по электронной почте, просмотреть литературные источники, на которые ссылаются в данном издании, вызвать иллюстрацию, которая поясняет смысл некоторого текстового фрагмента и многое другое.

Большинство электронных материалов, циркулирующих в сети Интернет Интернет, оформлены в HTML-формате. Формат достаточно компактен и, наряду с текстом, позволяет включать в издание иллюстрации и мультимедийные фрагменты. Основу HTML-документов составляют обычные текстовые файлы, отдельные символы в которых представлены в American Standart Code for Information Interchange (ASCII) - Американский стандартный код для обмена информацией ASCII-кодировке. Эти файлы доступны для просмотра и редактирования в любом редакторе текстов. Отличием HTML-издания от обычного текста является то, что в них присутствуют специальные команды - теги, которые указывают правила форматирования документа. Язык HTML и правила составления HTML-документов и работы с ними, будут детально описаны в следующей главе. Недостатком этого формата является чувствительность к используемым в издании шрифтам: отсутствие нужного шрифта на пользовательском компьютере вызывает затруднения при просмотре документа, связанные с необходимостью замены отсутствующей шрифтовой гарнитуры.

Другим основным форматом для электронных документов является PDF (Portable Document Format), разработанный в 1993 г. фирмой Adobe. Как говорит само название, он делает документы «portable», т. е. документы могут просматриваться независимо от программ, в которых они подготовлены и независимо от используемых шрифтов и компьютеров. PDF позволяет преодолеть этот барьер. Так впервые открылась возможность распространять на невещественных носителях (дискетах и компакт-дисках) и через Интернет выполненные в графическом режиме документы, в частности, оригинал-макеты изданий. При этом гарантируется полная идентичность. Это делает PDF-формат чрезвычайно полезным не только для художественных и детских электронных изданий, но и для коммерческих и рекламных документов. В США PDF-формат стал основным для распространения правительственных материалов.

Изначально формат PDF был предложен как альтернатива печатным документам, средство для организации «безбумажного офиса». Просмотр таких документов должен быть организован с помощью универсальных средств, независимо от создавшего их приложения и установленных на данном компьютере шрифтов. Формат PDF может рассматриваться как компактный формат электронной документации. Практически вся документация разнообразных программных пакетов распространяется на компакт-дисках в этом формате. Наконец, этот формат сохраняет всю информацию для выводных устройств, т. е. может служить для хранения оригинала и распечатки по заказу. По сравнению с форматом описания документов PostScript формат PDF имеет то преимущество, что он является странично-ориентированным, т. е. описывает каждую страницу в отдельности. Это резко упрощает вывод отдельных страниц.

PDF поддерживает различные виды компрессии изображений, текста и графики, позволяющие уменьшать размер конкретных фрагментов файла с помощью наиболее подходящих для этого алгоритмов, одновременно позволяя использовать гипертекстовые связи. Фирма Adobe разработала и комплект программного обеспечения для создания, просмотра, редактирования и распечатки PDF-файлов. Эти программные средства будут рассмотрены в § 4.6.

1.4.
Классификация электронных изданий

Классификация электронных изданий Классификация электронных изданий может вестись по нескольким признакам. Наиболее существенными из них нам представляются следующие:

  • периодичность издания;

  • круг потребителей продукции;

  • вид издания;

  • способ распространения;

  • формат издания.

Сказанное иллюстрируется классификационной диаграммой, представленной на рис. 1.2 Рис. 01.02..

Круг потребителей продукции или круг пользователей электронных изданий достаточно широк и разнообразен. К ним можно отнести учащихся, использующих электронные учебники, туристов и посетителей музеев, которые с помощью электронных изданий могут совершать виртуальные путешествия и осмотр памятников культуры, специалистов, использующих справочные и иные пособия по своей специальности, детей, «посещающих» мультимедийные виртуальные спектакли и т. д. Эти издания распространяются преимущественно на компакт-дисках и рассчитаны на мультимедийный компьютер.

Научные и технические издания, преимущественно периодические, рассчитаны на широкий круг научных работников, специалистов и преподавателей и становятся все более популярными, главным образом благодаря опережающей, по сравнению с печатными изданиями, возможностью ознакомления с ними, а также в связи с большей простотой и дешевизной получения информации, простоте ее извлечения и возможности контекстного просмотра авторских ссылок и сопутствующих материалов. В последнее время основной средой распространения таких изданий стала глобальная сеть Интернет.

Сопутствующими для всех рассмотренных выше разновидностей электронных изданий являются рекламные материалы. В большинство электронных изданий, как, впрочем, и в печатные, вкрапляется реклама в самых различных формах. Самая простая и естественная из этих видов - реклама фирмы, производящей данное электронное издание, включающая в себя как минимум информацию о других электронных изданиях данного профиля, выпущенных или подготавливаемых к выпуску этой фирмой. В периодических электронных изданиях реклама автоматически переносится со сверстанных страниц оригинала в электронное издание. В изданиях, распространяемых по глобальным сетям, само оформление сайтов, страниц и интерфейсов уже содержит рекламные элементы, в частности, анимационные.

Виды изданий, разнообразие которых уже затронуто в классификации по предыдущему признаку, тесно связаны с кругом пользователей. Здесь можно ограничиться признаками периодичности и тематической области, к которой издание относится. Ежедневные и еженедельные издания распространяются практически только в сетевых средах, причем они могут, в частности, распространяться путем рассылки, т. е. полное издание, а чаще - отдельные его тематические рубрики принудительно посылаются тем пользователям, которые на них подписались. По тематической области круг электронных изданий достаточно широк. Так, на Невещественный носитель невещественных носителях распространяются:

  • учебные пособия (обучение иностранным языкам, конспекты лекций, методические указания по выполнению практических и лабораторных работ, тексты рефератов и докладов и пр.);

  • научные журналы (как правило, подборка из нескольких выпусков журналов вместе с программными пакетами и сопутствующими рекламными материалами);

  • детские издания в форме мультимедийных сценариев сказочного, приключенческого, литературно-художественного и обучающего типа;

  • художественная и научно-популярная литература (обычно в PDF-формате или в архивированной форме). Эти издания представляют интерес для всех групп читателей, поэтому на рис. 1.2 Рис. 01.02. им соответствует позиция «Общие»;

  • энциклопедические и справочные издания, иногда многотомные, в том числе аналоги ранее изданных энциклопедий, например Grolier, Laruss, и специфически компьютерные - интерактивный атлас мира, географический справочник, атлас автомобильных дорог и пр. В электронном виде создаются сейчас и другие справочно-картографические системы. Для многих крупных городов они уже созданы и позволяют не только найти нужное здание по известному адресу, но и оптимизировать маршрут до места назначения.

В сетевых средах, например в сети Интернет, распространяются электронные издания преимущественно периодические, в частности:

  • не только отдельные учебные пособия, но и целые учебные циклы для дистанционного обучения и самостоятельного изучения;

  • исключительно широкий круг научных, научно-популярных и технических журналов, начиная с компьютерных (Computer World, Computer Week/Moskow, CompuLog и др.) и сетевых (Internet Journal, CrazyWeb, LANMagazine) и кончая музыкальными и игровыми;

  • общественно-политические журналы, например широко известный «Огонек»;

  • литературно-художественные издания, в том числе журналы («Новый мир», «Иностранная литература», «Октябрь», «Арт-Петербург», причем последний представляет собой культурный альманах, существующий только в Интернете), «Литературная газета» и пр.;

  • библиографические указатели и рефераты типа Book Review и электронной библиотеки службы «ИНФОМАГ»;

  • газеты (например, «Аргументы и факты», «Аномалия», «Вести», «Вечерний Минск», «Натали», «Известия», «Учительская газета»);

  • развлекательные издания («Знакомства», «Вечерний клуб», «Пятое колесо», «Вера, Надежда, Любовь»);

  • специализированные рекламные издания, в том числе «Центр-Плюс», «Реклама-Шанс».

По способу распространения все электронные издания можно разделить на две большие группы, а именно:

  • распространяемые на физических носителях, преимущественно компакт-дисках;

  • распространяемые в сетевых средах, как локальных (например, сетевая электронная библиотека учебного института), так и глобальных.

Так же как и печатные, электронные издания могут быть классифицированы по формату. Однако если в печатном издании формат характеризует физические размеры издания, то в электронном издании формат описывает то, каким образом в файле представлена информация, содержащаяся в данном издании. Начиная с 80-х гг. электронные издания распространялись в текстовом формате, вначале под DOS (txt), а затем под Windows и другие платформы. В настоящее время используются, как уже отмечалось выше, два основных гипертекстовых формата, а именно HTML и PDF, причем последний хранит всю информацию в графической форме. Если в издании содержится цифровая анимация, а тем более цифровые аудио- и видео - фрагменты, то та кие электронные издания называют мультимедийными. Хотя это и не название формата, но важная характеристика того, какие цифровые форматы могут содержаться в издании.

1.5.
Современное состояние и перспективы электронного книгоиздания

Электронные издания относятся к динамически развивающемуся классу продукции. Их количество увеличивается быстрыми темпами, а качество непрерывно улучшается.

Интеграция полиграфической продукции с электронными документами приносит чисто практические выгоды. Так, переход на цифровую форму позволяет обеспечить сохранность многих уникальных видов продукции, таких как древние рукописи. Даже обычные фотографии и картины теряют со временем свои качества. Хранение их электронных копий позволяет донести до последующих поколений уникальные культурные шедевры. Наконец, хранение документов и изданий в электронной форме позволяет организовывать электронные базы данных, четкая структура и развитые средства поиска и навигации в которых облегчают процесс обнаружения нужных материалов и их фрагментов. В качестве примера можно сослаться на американское специализированное издательство медицинской литературы Mosby-Year Book, в котором появление цифровой графической библиотеки позволило за считанные секунды находить нужные иллюстрации и помещать их в книги, в результате чего была достигнута значительная экономия времени и материальных средств.

Для ответа на вопрос об относительной ценности электронных изданий и перспективах расширения их производства следует провести исследования в следующих основных направлениях (иначе, получить ответы на перечисленные вопросы):

  • увеличивается ли ценность книги в электронном варианте, а если да, то в каких случаях и с чем это связано;

  • какие факторы влияют на качественные характеристики электронного издания сточки зрения читателя;

  • достаточен ли уровень развития технических и программных средств создания электронной книги;

  • насколько широко распространены индивидуальные и групповые средства для чтения электронных изданий;

  • насколько сформировался рынок распространения электронных книг;

  • какие нужны изменения в традиционном издательском бизнесе для успешного маркетинга и менеджмента электронных книг.

Несомненна более высокая потребительская ценность детских и учебных электронных изданий, так как повышается интерес к изучаемому материалу и обеспечивается возможность применения новых, более эффективных, технологий не только обучения, но и постепенного вовлечения детей в процесс обучения в игровой форме. Эти методики уже опробованы во многих странах и на практике доказали свою эффективность.

Справочные и научные издания позволяют более простыми средствами и в более краткие сроки получить необходимую информацию (или краткие сведения, позволяющие оценить ее необходимость пользователю и заказать ее, в том числе и в печатном виде). Естественно, что ценность таких изданий по сравнению с печатными существенно возрастает. Степень увеличения ценности таких изданий и роль определенных факторов может быть установлена в процессе проведения соответствующих исследований.

Сточки зрения факторов, влияющих на качественные характеристики электронных документов, наибольший интерес, по нашему мнению, представляет оптимизация пользовательских интерфейсов, причем не только графических в широком смысле, включая анимацию и цифровое видео, но и цифровое аудио. Все это также требует исследований и сбора статистических данных.

Постепенно, но неуклонно продолжается наступление электронных изданий в учебной сфере, начиная со школьного обучения, и далее, в сфере среднего и высшего образования. Во многих случаях оправдан частичный или полный переход к электронным учебникам и компьютерным образовательным технологиям. Эффективность такой замены тем выше, чем больше разнообразие учебных пособий и ниже их тиражи. Ответ на вопрос об изменениях в традиционном издательском и печатном бизнесе, необходимых для адаптации к новым информационным технологиям, также требует проведения достаточно широких и глубоких научных исследований.

Так, у нашего северного соседа Финляндии с 1996 по 2000 гг. проводилась рассчитанная на пять лет исследовательская программа по электронным издательским и печатным процессам с финансированием около 60 млн. финских марок. В США же в рамках поддерживаемой правительством программы по интерактивным электронным журналам около десяти лет работает специальная служба OCLC, которая экономически поддерживает университетские издательства и сама выступает как издатель научных изданий - электронных и печатных.

Ответы на вопрос, достаточен ли современный уровень развития технических и программных средств создания электронной книги, автор надеется дать в 4-й главе и 6-й главе этого учебника. В частности, в 4-й главе будет дан анализ программных и технических средств подготовки электронных изданий, а в главе 6-й - освещены возможности подготовки мультимедийных изданий в специализированных программных пакетах, таких как FrontPage фирмы Microsoft Microsoft, Director, DreamWeaver и Flash фирмы Macromedia Macromedia, GoLive фирмы Adobe Systems Adobe и некоторых других.

Насколько широко распространены индивидуальные и групповые технические средства для работы с электронными изданиями, уже говорилось в самом начале главы. Аппаратному и программному обеспечению рабочего места читателя электронных изданий посвящена 5-я глава учебника, где анализируются современные средства, возможности их дальнейшего совершенствования и развития и перспективы их распространения в нашей стране. Отметим, что уже в конце 2000 г. в Санкт-Петербурге насчитывалось около 500 тыс. учтенных персональных компьютеров, более 40% которых снабжены дисководом для компакт-дисков и звуковой картой, т. е. могут быть использованы для работы с мультимедийными изданиями. В действительности, количество компьютеров даже несколько превышает эту цифру, так как сейчас активизировался вторичный компьютерный рынок, да и сам процесс их сборки настолько упростился, что стал вполне доступен неспециалистам.

Насколько сформировался Электронная коммерция рынок распространения электронных изданий и какие нужны изменения в традиционном издательском бизнесе для успешного маркетинга и менеджмента электронных книг, исследуется в последней, 9-й главе учебника. Здесь мы лишь укажем, что отечественные издательства в большинстве своем успешно адаптировались к современным медиа-технологиям. Самые передовые из них те, которые занимаются выпуском литературы по компьютерным и сетевым технологиям. Практически все они используют глобальную сеть для маркетинга и распространения литературы. Наряду с печатными выпускают издания на компакт-дисках, причем нередки интегрированные издания, в печатную книгу вкладывается сопутствующий компакт-диск, содержащий программный и иллюстрационный материал, дополняющий и развивающий те положения, которые содержатся в той части, тиражируемой печатным способом.

В дальнейшем широкое распространение мультимедиа-технологий и неудержимое развитие электронной коммерции наложит жесткие ограничения на конкурентоспособность и даже выживаемость предприятий отрасли печати, ориентированных на широкий спрос. Преимущества в реализации даже самой высококачественной продукции получат те, кто быстрее и эффективней освоил электронные способы коммерции и обслуживания. Фирмы, не имеющих собственной аппаратной и программной базы мультимедиа-технологий, будут испытывать трудности с получением заказов, и их продукция будет подвергаться опасности устареть раньше, чем дойдет до потребителя. Причем это невозможно компенсировать в рамках собственно процесса подготовки и выпуска продукции. Таким образом, сетевые электронные издания имеют несомненные преимущества по части распространения перед любыми печатными изданиями.

Производство как электронных изданий, так и печатной продукции все более интегрируется в единое пространство медиа-индустрии. Одновременно, в пределах той же медиа - индустрии происходит процесс интеграции печатных и электронных изданий. Состав коммерческих средств медиа - индустрии и приблизительное распределение доходов между ними представлено в табл. 1.1 [image] . В этой же таблице приведены данные прогноза на 2005 и 2010 гг. долевого участия различных средств медиа-индустрии. Прогноз предусматривает два крайних варианта развития: консервативный и прогрессивный, которые определяют диапазон разброса значений при различных сценариях развития мирового производства.

Таблица 1

Таблица 1.1.

Прогноз развития средств медиа-индустрии в мире

Средства медиа-индустрии | 2000 год | 2005 год |  | 2010 год
 |  | Консервативн. | Прогрессивн. | Консервативн. | Прогрессивн.
Печатные | 65 | 62 | 54 | 54 | 37
ТВ и радио | 15 | 16 | 18 | 18 | 22
Кино, видео, музыка | 10 | 10 | 10 | 10 | 11
Электронные издания (на дисках) | 6 | 7 | 9 | 9 | 14
Электронные издания (сетевые) | 4 | 5 | 9 | 9 | 16

Прогрессивный сценарий отражает в табл. 1.1 результаты, соответствующие существующим в развитых странах темпам развития составляющих медиа-индустрии. Консервативный сценарий подразумевает замедленное развитие перспективных средств медиа-индустрии, характерное для слаборазвитых и развивающихся стран. В целом, следует ожидать ускоренных темпов развития производства электронных изданий, в особенности мультимедийных и тех, для которых используются сетевые технологии распространения. Кстати, заметное снижение вклада печатных средств не означает абсолютного снижения производства печатной продукции. Вероятнее всего рост производства будет продолжаться (особенно это касается производства этикеток и упаковки), однако темпы этого роста будут постепенно снижаться.


Электронные издания:

2.
Глава II. Структура и элементы гипертекстовых документов

Эта глава посвящена описанию методики создания HTML-документов с помощью средств языка HTML В частности, рассматривается общая структура различных HTML-документов, включая издания с фреймовой структурой и HTML-формы. Рассмотрены основные разновидности тегов для создания заголовочной части документа и его тела, а также форматирования текста и иллюстрации, организации списковых и табличных структур, включения в документ ссылок и комментариев. Описаны варианты электронного учебника на основе фреймовой структуры. Анализируется пример HTML-формы, используемой на сервере RAMBLER для предоставления клиентам бесплатного электронного почтового адреса. В заключение дается общая характеристика средств для создания HTML-страниц с динамически изменяющимся содержимым, а именно - языка JavaScripts и каскадных таблиц стилей.

2.1.
Общая характеристика и структура HTML-документа

На заре компьютеризации приходилось работать с простыми текстовыми редакторами, такими как WordStar, для которых информация, отображаемая на экране, отличалась от выводимой на бумагу с помощью принтера. В текст документа вставлялись специальные управляющие символы, которые не отображались на экране, но обеспечивали вывод на печать в нужном формате отдельных фрагментов документа. При форматировании одна группа символов определяла начало фрагмента, затем следовал текст, к которому применялось это форматирование, а после него следовали символы конца фрагмента. Так задавались разрядка, курсив, полужирный шрифт и пр. Аналогичные способы применялись и при работе с первыми версиями СУБД dBase (например, dBase II), о чем автор может судить по своему личному опыту.

Тот же принцип положен в основу структуры HTML-документ HTML-документа, однако управляющие символы, которые здесь называются тегами, определяют особенности отображения информации, выводимой уже не на принтер, а на экран монитора. Тег Значительная часть таких тегов используется парами: вначале открывающий тег, затем объект управления, а в конце - закрывающий тег. Такая конструкция называется Контейнер контейнером, так как объект форматирования размещается внутри нее. Некоторые теги принципиально не нуждаются в паре. Примером может служить тег принудительного перевода строки. Тег может включать в себя некоторые параметры (атрибуты), которые размещаются непосредственно после имени тега. Если параметров несколько, то в качестве разделителей используются пробелы.

Для просмотра HTML-документов используют специальные программы, которые называются браузерами (Browser, т. е. средство просмотра в дословном переводе). Такие программы нуждаются в графической оболочке. В частности, значительное число браузеров (Microsoft Internet Explorer, Netscape Communicator, Opera и др.) работают в среде Windows 95, 98 и 2000.

Популярность Язык HTML языка HTML росла вместе с развитием Интернет сети Интернет. Отсутствие в течение некоторого времени стандартов на язык HTML привело к тому, что некоторые браузеры отображали должным образом не все теги, а в версиях различных фирм одни и те же теги могли трактоваться неодинаково или даже не поддерживались. Широкое использование HTML-документов в сети Интернет привело к появлению международных стандартов на этот язык, называемых спецификациями языка HTML. Этой работой занялась широко известная организация World Wide Web Consortium (W3C) World Wide Web Consortium (W3C). Первой из спецификаций, признанной большинством компаний-разработчиков, явилась HTML 2.0, представленная в конце 1995 г. Вскоре была выпущена предварительная (рабочая) версия спецификации 3.0, а в мае 1996 г.- проект спецификации HTML 3.2. После длительного обсуждения и исправления в январе 1997 г. эта спецификация стала официальной рекомендацией для разработчиков HTML-документов и браузеров. В декабре 1997 г. официальной рекомендацией стала спецификация HTML 4.0, которая остается в действии до настоящего времени.

Основой спецификации HTML 4.0 стало отделение параметров описания документов от параметров представления отдельных его фрагментов на экране монитора. Такое разделение облегчает адаптацию языка к различным платформам передам (Windows, UNIX, DOS и пр.) и упрощает процесс внесения изменений в документы. В соответствии с такой концепцией для описания документа следует использовать таблицу стилей, причем это понятие сходно с используемым в современных текстовых редакторах, таких как Word 97 или 2000. Использование же данных о форме представления документа вперемежку с содержанием самого документа не рекомендуется.

Спецификация HTML 4.0 отменяет ряд ранее использовавшихся тегов. Отмена тега означает, что этот тег по-прежнему поддерживается браузерами, но его применение в современных документах не рекомендуется. В дальнейшем такие теги могут быть переведены в разряд устаревших, которые уже могут не поддерживаться браузерами. Информация такого рода может быть получена на сайте http://www.w3.org/TR/.

Любой HTML-документ заключен в контейнер <HTML> и </HTML>. Сам документ, как уже говорилось выше, представляет собой обычный текстовый файл. Его можно просматривать в DOS'e с помощью стандартных редакторов и средств просмотра текстовых документов, при этом вместе с самим текстом мы будем видеть и теги. Структурно документ распадается на две части: заголовочную и основную, ил и тело документа. Первая часть находится внутри контейнера <HEAD> и </HEAD>, а основная часть - внутри контейнера <BODY> и </BODY>.

Единственный обязательный тег, который используется в заголовочной части,- <ТIТLE>, причем он образует контейнер, внутри которого размещается текст заголовка. При загрузке документа в браузер текст заголовка загружается в первую очередь в окно заголовка браузера. Если текст заголовка достаточно информативен, пользователь в процессе поиска релевантных документов уже на этапе загрузки документа может определить, действительно ли ему нужен этот документ, а если не нужен, то сразу отказаться от его загрузки и перейти к загрузке следующего. Текст названия используется и при создании закладки для данного документа, с этой точки зрения также очень важна его информативность.

Многие HTML-документы связаны друг с другом, и ссылки от одного документа на другие могут быть абсолютные и относительные, причем последние формируются относительно того каталога, в котором расположен документ - источник ссылки. Абсолютные ссылки длинные, а относительные - перестают работать при перемещении основного документа. Можно включать сразу обе ссылки, чтобы связи между документами не нарушались в любых условиях.

Для формирования ссылок в заголовочной части применяется тег <ВАSЕ>, в котором используется один единственный параметр HREF, в качестве значения которого указывается URL (Universal Resours Locator) - адрес файла, на который производится ссылка. Адрес может быть локальным, т. е. задавать размещение файла в каталогах и подкаталогах на том же самом компьютере, или сетевым, например <BASE HREF='http:// www.uprint.spb.ru/main.htm'>.

Для организации логической связи и соподчиненности электронных изданий может использоваться тег <LINK>. В этом теге могут использоваться четыре параметра: HREF, REL, REV и TYPE. С помощью первого из них задается URL связанного с данным документа. Параметр REL определяет вид отношения между текущим и связанным с ним документом, a REV -обратное отношение (между другим и текущим документами). Последний параметр TYPE задает тип и параметры присоединяемой к документу таблицы стилей. Примеры тега <LINK>:

<LINK REL='contents' HREF='(адрес)'>

<CLINK HREF='mailto: (адрес автора)' REV='made'>

Другими значениями параметра REL могут быть bookmark, copyright, glossary, help. Значение made параметра REV является признаком обратного отношения. Другие его значения: autor, editor, publisher.

Позднее в состав заголовочной части был добавлен специальный тег <МЕТА>, с помощью которого задается метаинформация, связанная с данным электронным изданием, или атрибуты для ускоренного поиска. Частные случаи метаинформации - это имя автора, издателя, редактора, название издательства, время публикации и другие характерные признаки издания. Тег <МЕТА> имеет два параметра: NAME, которым задается имя атрибута, и CONTENT, определяющий значение этого атрибута. Например:

<MЕТА NAME='author' CONTENT='B. А. Вуль'>

<СМЕТА NAME='description' СОМТЕМТ='Электронные издания'>

Как нам кажется, приведенные примеры не нуждаются в каких-либо комментариях.

Итак, внутри контейнера <HEAD> и </HEAD>, ограничивающего заголовочную часть HTML-документа, обычно используется один контейнер <TITLE> и </TITLE>, внутри которого размещается текст заголовка, и могут быть включены теги <BASE>, <LINK> и <МЕТА>. Отметим, что HTML-документ, содержащий только заголовочную часть, будет нормально отображаться браузерами как пустой документ. Пример такого документа представлен на рис. 2.1 Рис. 02.01.. А ниже показан соответствующий этому документу HTML-код:

<HTML>

<HEAD><ТIТLE>Пустой документ </TITLE></HEAD>

<BODY></BODY>

</HTML>

2.2.
Тело документа и оформление его основных фрагментов

2.2.1.
Тело документа

Внутри контейнера <BODY></BODY> размещается содержательная часть электронного документа. Сам тег <ВОDY> содержит ряд параметров, ни один из которых не является обязательным.

Параметры данного тега обеспечивают оформление всего тела документа. Перечислим их:

  • LINK - определяет исходный цвет ссылки;

  • BACKGROUND - задает URL изображения, определяющего фон тела документа;

  • BOTTOM MARGIN и TOPMARGIN - задает границу нижнего и верхнего полей документа в пикселах;

  • LEFTMARGIN и RIGHTMARGIN - границы левого и правого полей документа в пикселах;

  • BGCOLOR - задает цветовой оттенок фона документа (аналог тонирования бумаги, на которой печатается издание);

  • BGPROPERTIES - определяет свойства фона, задаваемого предыдущим параметром;

  • LINK - задает цвет еще не просмотренной ссылки;

  • SCROLL - определяет наличие полос прокрутки в документе, отображаемом в окне браузера;

  • TEXT - определяет цвет текста;

  • VLINK - цвет уже просмотренной ссылки.

Ряд параметров связаны с использованием цветовых оттенков в HTML-документах.

Отметим, что по умолчанию в них используется RGB цветовое пространство, причем значение каждого из основных цветов имеет 256 уровней и задается в виде двух цифр в 16-тиричной системе счисления от 00 до ЕЕ. Таким образом, цветовой тон задается последовательностью из шести 16-тиричных цифр, которым предшествует сим вол #, например последовательность #FFFFFF соответствует белому цвету максимальной интенсивности, а #800080 - фиолетовому тону, интенсивность которого равна половине от максимальной.

Приведем примеры использования параметров в теге <BODY>:

<body link='#000080' background='image/background.gif'>

<body bgcolor='#COCOCO'>

В первом примере задан синий цвет еще не просмотренной ссылки и в качестве фонового изображения используется файл background.gif, причем этот файл указан относительной ссылкой и находится в подкаталоге IMAGE. А во втором примере задан светлый фон для документа.

2.2.2.
Теги логического форматирования текста

Теги логического форматирования текста позволяют выделить определенные типы текстовых фрагментов, т. е. осуществить структурную разметку текста. Их называют также тегами уровня блока, так как они не применимы к отдельным словам, а воздействуют лишь на фрагменты текста из нескольких слов.

Так, два тега <ABBR> и <ACRONYM> позволяют выделить аббревиатурные сокращения в пределах текста, причем второй используется для произносимой аббревиатуры. В теге <ACRONYM> может использоваться параметр TITLE, значением которого является полный текст сокращения. Например, контейнер:

<ACRONYM ТITLE='Московский Государственный Университет Печати'> МГУП </ACRONYM>

позволяет при указании курсором манипулятора мыши на аббревиатуру выводить во всплывающем окне соответствующий ей полный текст названия нашего Университета.

Тег-контейнер <СIТЕ> используется для выделения цитат, названий книг, газет и журналов. Браузеры обычно выводят текст, находящийся внутри контейнера, курсивом. Тег-контейнер <CODE> выводит текст как фрагмент программного кода (строки листинга программы) моноширинным шрифтом, a <DFN> отмечает текстовый фрагмент как определяемый термин. Аналогичным образом тег-контейнер <STRONG> выделяет содержимое как важные фрагменты текста.

Тег <INS> отмечает фрагмент текста как вставку, т. е. с его помощью можно отслеживать изменения, вносимые в основной текст. Тег может иметь два параметра: CITE (не путать с одноименным тегом) и DATETIME. С помощью первого параметра задается URL документа, поясняющего причины вставки, а второй параметр указывает дату и время вставки фрагмента с учетом часового пояса. Тег-контейнер <DEL> отмечает текст как намеченный к удалению. У него имеются параметры CITE и DATETIME, назначение которых точно такое, как в теге <INS>. Ниже приводятся несколько примеров записи тегов, которые, по нашему мнению, не требуют каких-либо комментариев.

<СIТЕ>'Известия'</СIТЕ> - Популярная Российская газета <DFN>Netscape Communicator 4.5</DFN>-Версия 4.5 популярного пакета фирмы Netscape, в который, в частности, вводится браузер для просмотра HTML-файлов

<INS CITE='www.uprint.spb.ru/mydoc.htm' DATETIME='2001-1–27 T16: 1:40+ 0.00> (вставленный фрагмент текста) </INS>

Ниже, на рис. 2.2 Рис. 02.02., представлен пример отображения гипертекстового документа, в теле которого содержится ряд тегов логического форматирования текста.

2.2.3.
Теги физического форматирования текста

Определяют формат заключенного внутри соответствующих контейнеров текста при отображении на экране монитора. Как уже говорилось в начале этой главы, вместо них желательно использовать теги логического форматирования, если последние могут выполнить аналогичную функцию.

Так, тег-контейнер <В> выделяет заключенный внутри его текст полужирным начертанием. Аналогичным образом, теги <1> и <U> означают курсивное начертание и подчеркивание текста соответственно, а тег <ТТ> - моноширинный шрифт. Теги <STRIKE> и <5> совпадают по назначению и обеспечивают перечеркивание фрагмента текста горизонтальной линией, как намеченного к удалению. Надо отметить, что все перечисленные теги относятся к устаревшим и не рекомендуются к применению. Так, вместо тега <В> предпочтительнее использовать рассмотренный выше тег логического форматирования текста <STRONG>, вместо <STRIKE> или <5> - <DEL>, а вместо <ТТ> - <CODE>.

Из других тегов «шрифтового оформления» отметим <BIG> и<SMALL> которые увеличивают или уменьшают кегель шрифта на одну единицу, <SUB> и <SUP>, размещающие символы выше или ниже уровня строки. Более универсальным в этой группе является тег<ЕОМТ>, который имеет три параметра: FACE, SIZE и COLOR. Первый параметр позволяет указать используемую в текстовом фрагменте гарнитуру, причем, если такая гарнитура не установлена на компьютере, то параметр игнорируется. Можно задавать несколько наименований гарнитур, разделяя их запятыми, тогда будет использоваться первая по списку из имеющихся в наличии. Второй параметр задает размер (но не кегель) шрифта. Всего в языке HTML предусмотрено семь размеров, из которых третий номер используется по умолчанию. Последний параметр указывает цвет группы символов текста и может задаваться в виде группы из семи символов, как указывалось выше, или в наименованиях цветовых тонов. Приведем несколько примеров:

<FONT FACE='Arial','Courier' SIZE=5 COLOR=red> текст

</FONT>.

<FONT FACE='Times' SIZE=2 COLOR=#ffOOOO > текст </FONT>.

<FONT FACE='Times'> 5 <SOP><SMALL> 2 </SMALL></SOP></FONT>.

В первом примере символы текста, содержащиеся внутри контейнера, будут отображаться гарнитурой Arial, если она установлена на компьютере, а в противном случае, гарнитурой Courier. Размер символов будет достаточно велик и они будут красного цвета. Во втором примере будет использована гарнитура Times, размер символов будет на единицу меньше нормального и символы будут того же самого красного цвета. В последнем случае в окне браузера будет отображаться 52, причем размер показателя степени будет на единицу меньше, чем ее основания.

Третий пример иллюстрирует и другое важное свойство тегов-контейнеров физического форматирования текстовых символов: контейнеры могут быть вложены один в другой, причем глубина вложений формально не ограничена. При написании HTML-документ HTML-документа вручную необходимо только тщательно следить, чтобы контейнеры строго размещались один внутри другого. Действительно, в примере контейнер <SMALL> и </SMALL> расположен внутри <SUB> и </SUB>, а последний вложен в контейнер <FONT> и </FONT>.

Все рассмотренные выше теги физического форматирования, если их действие рассматривать подобно функциям текстовых редакторов, относятся к шрифтовому оформлению текстовых фрагментов. Поэтому далее следует остановиться на тегах, выполняющих функции, подобные форматированию абзаца. К ним, в частности, относится тег разделения документа на абзацы <Р>, который помещается перед началом очередного абзаца. Закрывающий тег </Р> не обязателен. Браузеры обычно отделяют абзацы друг от друга пустой строкой. Параметром этого тега является ALIGN, т. е. выравнивание. Параметры выравнивания: LEFT, CENTER, RIGHT и JUSTIFY, причем последний только сравнительно недавно начал поддерживаться браузерами.

При отображении документов в окне браузера место перевода строки определяется автоматически, в соответствии с реальными размерами его окна. В тех случаях, когда требуется выполнить принудительный перевод строки в определенном месте, используется тег <BR>, у которого нет закрывающего тега. Тег <BR>, в частности, используется при работе со стихотворными строками. В отличии от тега <Р>, при использовании тега <BR> браузер не генерирует на экране пустую строку.

Наоборот, в тех случаях, когда перенос на другую строку внутри фрагмента текста недопустим, следует использовать тег-контейнер <NOBR> и </NOBR>. Находящийся внутри контейнера текст не переносится на другую строку, т. е. не разрывается. Если такая строка получается слишком длинной, то в окне просмотра браузера автоматически появляется полоса прокрутки. В качестве примера на рис. 2.3 Рис. 02.02. показано отображение HTML-документа в окне браузера Internet Explorer, а выше - исходный HTML-код для этого документа.

Размер текста, помещенного внутри HTML-документа, формально не ограничен, т. е. он может быть эквивалентен множеству печатных страниц. На практике это обстоятельство приводит к появлению длинных страниц, для просмотра которых требуется вертикальная полоса прокрутки. Поэтому предусмотрена возможность разбивки такого протяженного текста на отдельные главы и параграфы с помощью заголовков различного уровня.

Для разметки заголовков служат шесть тегов-контейнеров <Н1> . . <Нб>, причем теги с меньшими номерами определяют заголовки более высокого уровня. Все перечисленные теги относятся к уровню блока, т. е. не могут использоваться для разметки отдельных слов. В качестве единственного параметра этих тегов используется ALIGN, который задает способ выравнивания заголовка (точно так же, как в теге <Р>). Например,

<Hl ALIGN=CENTER> Заголовок 1-го уровня </Н1>

<НЗ ALI6N=LEFT> Заголовок 3-го уровня </НЗ>.

В первом примере заголовок выравнивается по центру и в нем используется наибольший размер кегля шрифта, такой как в теге <FONT SIZE=7>. Во втором случае текст заголовка выравнивается полевому краю, а размер шрифта соответствует значению пара метра SIZE=5. Во всех случаях заголовки выделяются осветленным пространством в виде пропущенной строки до и после строки заголовка и полужирным шрифтом самого заголовка. Наконец, тег заголовка аккумулирует в себе функции тега абзаца, т. е. нет необходимости в использовании одновременно с тегом <НЗ> еще и тега <Р>.

Помимо заголовков, для разделения документа на отдельные разделы могут использовать горизонтальные линии, играющие ту же роль, что и орнаментальные линейки в печатных изданиях, где такие линейки используются в конце определенных разделов, отделяя предыдущий фрагмент издания от последующего. Для генерации таких линий в электронном документе используется тег <ВР>, который не является контейнером. В теге могут использоваться пять различных параметров. Параметр выравнивания ALIGN может принимать значения LEFT, CENTER и RIGHT. Параметр WIDTH задает длину линии в пикселах или в процентах от ширины окна браузера, что обычно предпочтительнее, a SIZE определяет толщину линии в пикселах. Параметр COLOR определяет цветовые характеристики линии, т. е. реализует те же функции, что и аналогичный параметр в теге <Р>. Наконец, параметр NOSHADE отменяет рельефный характер линии, причем у него значение отсутствует, само наличие в теге этого параметра характеризует отсутствие рельефа. Пример записи тега:

<ВР ALIGN=CENTER WIDTH=75% SIZE=8 COLOR=#800080>

На практике мы иногда сталкиваемся со случаями, когда в HTML-документ необходимо включить уже отформатированный текст, причем он должен отображаться браузером так, как он был подготовлен в текстовом редакторе. Для этой цели предусмотрен тег-контейнер <PRE>. После этого тега можно включить предварительно отформатированный текст, который должен в том же виде выводиться в окне браузера.

Для включения цитат большой протяженности (много сотен символов) предназначен тег-контейнер <BLOCKQUOTE>.

Это - тег уровня блока. Браузеры выделяют текст, размещенный внутри такого контейнера, пустыми строками до и после и небольшим отступом слева по отношению к основной части документа. Поэтому тег <BLOCKQUOTE> можно использовать не только для длинных цитат, но и для выделения некоторых блоков текста.

Из других тегов уровня блока, используемых для выделения фрагментов документа, можно отметить <DIV>. Используя контейнер с этим тегом, можно управлять параметрами данного фрагмента путем назначения стилей, например

<DIV STYLE='color: green'> (Фрагмент документа) </DIV>

выделит все текстовые элементы указанного фрагмента зеленым цветом.

Тег-контейнер уровня блока <CENTER> предназначен для горизонтального выравнивания всех заключенных в него элементов посередине окна просмотра браузера. В частности, он используется для выравнивания по центру таблиц (см. § 2.6).

Косвенное отношение ко всем рассмотренным в данном разделе тегам имеет тег-контейнер <ADDRESS>, который применяется для указания автора, владельца авторских прав, адреса автора, а иногда и даты создания и последнего обновления электронного издания. Текст внутри такого контейнера обычно отображается браузерами курсивом. Соответствующий пример мы приведем в конце главы, сравнивая исходный HTML-код и отображение документа в окне браузера.

Специфическим видом текста, который иногда включают в электронное издание и ценность которого, на наш взгляд, сомнительна, является бегущая строка. Зато на Web-страницах такие фрагменты нередко используются, преимущественно в рекламных целях. Для создания бегущей строки используется тег-контейнер <MARQUEE>. В теге используется ряд параметров: DIRECTION, BEHAVIOR, WIDTH, HEIGHT, LOOP, SCROLLDELAY, BGCOLOR. Первый параметр определяет направление движения строки и принимает значения LEFT или RIGHT. Параметры WIDTH и HEIGHT позволяют задать размеры окна, в котором движется строка текста. Размеры задаются в пикселах или в процентах от ширины и высоты страницы. Параметр LOOP задает число повторов цикла перемещения строки, если он вообще не упомянут, то число повторов бесконечно. Параметр SCROLLDELAY определяет период повторения изображения движущегося текста в миллисекундах. Наконец, значение BGCOLOR позволяет стандартным способом определить цвет фона окна, в котором движется строка текста. Если требуется изменить гарнитуру, кегль, цвети другие параметры шрифта бегущей строки, то следует тег-контейнер <MARQUEE> поместить внутрь тега-контейнера <FONT>, в котором и задать все характеристики шрифта.

2.3.
Оформление списков терминов и определений

Списки принадлежат к наиболее употребительным формам как в электронных, так и в печатных изданиях. Возможность представления списковых структур предусмотрена практически во всех текстовых редакторах, в частности, развитая система для списковых структур имеется в MS Word, весьма популярном редакторе в нашей стране. В HTML-документ HTML-документах наряду с обычными маркированным и нумерованным списками предусмотрен отдельный список определений. Оформление этих списков посредством специальных тегов составит предмет этого параграфа.

2.3.1.
Список маркированный Маркированные списки

Создаются с помощью тега-контейнера <UL> (Unordered List - неупорядоченный список). В теге могут использоваться два параметра: COMPACT, который изначально предназначался для вывода элементов списка в компактной форме (уменьшенным кеглем и расстоянием между строками) и TYPE, который используется для принудительного задания вида маркера. Параметр COMPACT не имеет значений. Современными браузерами он игнорируется. Параметр TYPE может принимать одно из трех значений: disc, circle и square. В первом случае маркеры (bullets) имеют вид закрашенного круга, во втором - окружности малого диаметра, в третьем - закрашенного квадрата. По умолчанию значение TYPE=disk.

Каждому элементу списка предшествует тег <LI> (List Item - элемент списка), который необязательно должен быть контейнером. В качестве параметра этого тега также используется TYPE, который может принимать те же самые три значения. Таким образом, в списке принципиально могут использоваться и различные маркеры для представления отдельных элементов.

2.3.2.
Создание нумерованных списков

Список нумерованный Нумерованный список организуется с помощью тега-контейнера <OL> (Ordered List), внутри которого размещаются все элементы списка. Открывающий и закрывающий теги обеспечивают пропуски строк до и после списка, выделяя его таким образом в документе. В составе тега могут использоваться три параметра: COMPACT, TYPE и START. Смысл первого параметра тот же самый, что и в теге <UL>. Параметр TYPE по-прежнему определяет тип маркера, причем TYPE=1 определяет маркеры в виде арабских цифр, TYPE=A задает маркеры в виде прописных букв латинского алфавита, TYPE=a - в виде строчных латинских букв, наконец, TYPE=I и TYPE=i определяют маркеры в виде римских цифр, больших и малых соответственно.

Параметр TYPE, заданный в форме определенного числа, определяет начало отсчета для первого элемента списка.

Каждый элемент нумерованного списка предваряется тегом <LI>. Вэтом случае в состав тега может входить параметр VALUE, позволяющий изменять номер очередного элемента списка, в результате чего соответственно изменяются и все последующие номера. В качестве примера можно привести фрагмент спортивных новостей, где содержатся результаты какого-либо соревнования:

<HTML><HEAD><TITLE> Пример нумерованного списка </TITLE></HEAD

<BODY><OL><B> Результаты чемпионата мира по гандболу 2001</В>

<LI> Франция

<LI> Румыния

<LI> Германия

<BR>. . .

<LI VALUE=6> Россия

<LI> Украина

</OL></BODY></HTML>

При выводе в окне браузера документа, HTML-код которого представлен выше, мы увидим изображение, показанное на рис. 2.4 Рис. 02.04.. Название документа, размещенного в теге-контейнере <TITLE> в заголовочной части документа, выведено в строке заголовка браузера. Название списка в теле документа показано полужирным шрифтов непосредственно перед списком. Нумерация списка по умолчанию производится арабскими цифрами, так как параметр TYPE в теге <OL> отсутствует. Нумерация списка начинается по умолчанию с первого номера, так как и параметр START в теге <OL> отсутствует. С помощью параметра VALUE=6 в одном из тегов <LI> изменен номер очередного элемента списка, а дальнейшая нумерация продолжается с нового номера. Для создания отточия использован тег принудительного перевода строки <BR>.

2.3.3.
Списки определений

В научно-технических и учебных изданиях нередко используют Список определений списки или словари определений, которые в зарубежных книгах называют глоссариями. (Например, см. ссылка на источники литературы). Каждый элемент такого списка начинается с определяемого термина, после которого следуетего определение. Для создания списка определений служит тег-контейнер <DL> (Definition List), внутри котороготег<ОТ> (Definition Term) задает определяемый термин в форме единственной строки, а тег<00> (Definition Description) предшествует абзацу с определением этого термина. Для примера приведем фрагмент списка определений для компьютерной графики.

<html><head><title>Cписок терминов и определений </title></head>

<body bgcolor=#d5d5d5><DL><ОТ>Пиксел

<DD>Наименьший элемент изображения, который характеризуется постоянством параметров по всей своей поверхности <DT> Разрешение монитора

<DD> Разрешение монитора определяется количеством пикселов на единицу длины и составляет около 96 пикселей на дюйм <ОТ>Линиатура растра

<DD> Частота размещения растровых точек в плоскости изображения, измеряется числом линий на дюйм </DL></body></html>

Отображение этого файла в окне просмотра браузера показано на рис. 2.5 Рис. 02.05.. Как следует из записи исходного HTML-документа никаких попыток выравнивания текста и формирования отступов не производилось. Сами теги <DT> и <DD> так форматируют текст, что обеспечивают оптимальное его восприятие пользователем. Фон документа задается определенным уровнем серого в соответствии со значением параметра BGCOLOR в теге <BODY>. Кстати, язык HTML, как следует из представленного выше фрагмента HTML-кода, нечувствителен к регистру.

2.3.4.
Многоуровневые списковые структуры

Список многоуровневый Многоуровневые списки в HTML-документах могут создаваться путем вложения одного типа списка внутрь другого. Например, фрагменты нумерованного списка могут быть вложены внутрь маркированного или наоборот. Сказанное иллюстрируется простым примером, в котором перечисляются спутники некоторых планет нашей солнечной системы.

<HTML><HEAD><TITLE> Пример двухуровневого списка </TITLE></HEAD

<BODY><OL><B> Спутники планет </В>

<BR> ....

<LIбл/> ЗЕМЛЯ

<OL><LI> Луна </OL>

<LI>MAPC

<OL><LI> Фобос

<LI> Деймос </OL>

<BR> ....

</UL></BODY></HTML>

Отображение двухуровнего списка в окне браузера показано на рис. 2.6 Рис. 02.06.. Внутри тега-контейнера маркированного списка <UL> размещены два контейнера нумерованного списка <О1_> и </О1_> со своими тегами <LI> каждый. Дополнительный отступ слева обеспечивает хорошую читаемость текста. По этой схеме можно создавать и многоуровневые списки.

2.4.
Использование графики при оформлении электронного издания

Известно, что с помощью графики можно точнее передать идеи и назначение любого издания, в том числе и электронного. Без Иллюстрации иллюстрации полосы набора выглядят однообразными, а хорошо подобранная и умело размещенная графика делает издание гораздо более привлекательным. Ограничения в использовании графики с позиций эстетики связано с опасностью загромождения документа изображениями, в том числе и фоновыми, и навязчивой анимацией, зачастую не связанной непосредственно с тематикой издания.

С технической точки зрения изображения требуют значительно большего объема информации, чем простой текст, поэтому может возникнуть информационная перегрузка, особенно при использовании сетевых технологий с каналами недостаточной пропускной способности. Известно, что многие пользователи сети Интернет отключают за грузку графических файлов, чтобы быстрее загрузить документ и ознакомиться с ним. Несколько улучшило положение применение компактных форматов графических файлов, таких как JPEG (с частичной потерей информации), GIF и PNG. В качестве иллюстрации сказанного можно привести данные по информационному объему файла, в котором хранится рис. 2.6 Рис. 02.06.: в формате TIFF - 46 Кб, JPEG - 31 Кб, PNG - 8 Кб и GIF - около 5 Кб.

Мы уже сталкивались с использованием изображения в качестве фонового при знакомстве с тегом <BODY>. Для этого в параметре BACKGROUND указывался URI-файла, хранящего изображения. Если в электронных изданиях, распространяемых на носителях, можно использовать практически любые графические файлы, то для сетевых изданий преимущественно используются GIF-файлы, реже файлы в формате JPEG.

Основным средством встраивания изображений в текст служит тег <IMG>, обязательным параметром которого является SRC, значение которого - адрес (URL) файла изображения. Параметр выравнивания изображения на полосе ALIGN может принимать восемь различных значений, определяющие различные способы его размещения на странице, два параметра позволяют установить размер изображения, еще два - расстояние от границы изображения до текста, отдельный параметр позволяет создать вокруг изображения рамку, а еще один - задать альтернативный текст, который будет выведен вместо изображения при отказе пользователя от его загрузки. Рассмотрим последовательно эти параметры.

Выравнивание изображения осуществляется двумя принципиально различными способами:

  • по левому или правому краю наборной полосы (аналог оборочной иллюстрации в печатном тексте);

  • изображение встраивается как элемент одной из строк текста (печатного аналога такого способа выравнивания нет, более того, в печатном издании такое расположение рисунка совершенно недопустимо).

Для выравнивания изображения по левому или правому краю окна браузера параметру ALIGN присваиваются значения LEFT или RIGHT соответственно, а текст обтекает рисунок с противоположной стороны. Для задания размеров изображения используются параметры WIDTH (ширина) и HEIGHT (высота), причем значения каждого параметра могут задаваться как в абсолютных единицах - пикселах, так и в относительных - процентах от соответствующего размера окна браузера. Реальные размеры изображения могут не совпадать со значениями параметров WIDTH и HEIGHT. В этом случае браузер автоматически масштабирует изображение по отдельным координатам.

Графические изображения могут задаваться в двух основных форматах: векторном и растровом. В соответствии с первым форматом создаются файлы сравнительно малого информационного объема, легко масштабируемые, однако в них не может быть достигнуто высокое художественное качество. Кроме того, преобразование описания изображения, содержащегося в файле, в реальный рисунок требует значительных вычислительных ресурсов.

Растровый формат масштабируется с искажениями, файлы в нем имеют большой информационный объем, но он обеспечивает достаточно высокое качество изображения. Кроме того, сама подготовка компьютерных графических файлов связана с оцифровкой (преобразованием в цифровой формат) реальных изображений, например рисунков и фотографий. Для этой цели используются так называемые сканеры, которые преобразуют изображение в один из растровых форматов, чаще TIFF.

С растровыми же форматами работают цифровые фото- и видеокамеры, которые все шире используются в современных издательских технологиях для прямого преобразования изображения в его цифровой эквивалент.

Поэтому масштабирование оправдано только для векторной графики, для растровой же следует определить реальные размеры изображения по горизонтали и вертикали в пикселах и задать эти размеры в параметрах WIDTH и HEIGHT. При этом:

  • изображение будет выведено в реальных размерах и без искажений;

  • при сетевом распространении документа пользователь сразу будет знать размеры изображения, а в остальную часть документа будет без промедления загружаться текст.

Остановимся кратко на других способах выравнивания изображения в электронном издании. Соответствующие значения параметра ALIGN следующие: ТОР, ТЕХТТОР, BOTTOM, BASELINE, ABSBOTTOM, MIDDLE, ABSMIDDLE. Значение TOP выравнивает верхнюю границу изображения по самому высокому элементу текущей строки, а ТЕХТТОР - по самому высокому текстовому элементу. Смысл различия в том, что элементом строки можетбыть и другое изображение. Значения BASELINE и BOTTOM действуют одинаково и выравнивают нижнюю границу изображения по базовой линии текущей строки, т. е. линии, на которой «стоят» шрифтовые элементы (нижние выносные элементы символов находятся под базовой линией), a ABSBOTTOM - выравнивает нижнюю границу изображения по нижней границе текущей строки, включая все элементы строки, в том числе и графические, если они имеются. Наконец, значения MIDDLE и ABSMIDDLE выравнивают середину изображения по базовой линии или посередине текущей строки соответственно. Еще раз отметим, что по нашему мнению, применение параметров выравнивания этой группы в большинстве случаев снижает качество оформления страницы, противоречит основным принципам дизайна полос.

Чтобы выделить изображение в текстовом документе, полезно предусмотреть незанятое текстом пространство вокруг него. Это можно осуществить с помощью параметров HSPACE и VSPACE, которые определяют отступы (осветленное пространство) по горизонтали и вертикали в пикселах. Для выделения изображения на странице можно заключить его в рамку, толщина которой в пикселах задается с помощью параметра BORDER. Наконец, для пользователей, работающих в режиме отключения загрузки графики, возможность вывода альтернативного текста дает параметр ALT. В случае же загрузки изображения при выводе на него курсора мыши появляется текст подсказки во всплывающем окне. Ниже приводятся пример тега <IMG> с различными параметрами:

<HTML><HEAD><TITLE> Пример вставки изображения в документ </TITLE></HEAD>

<BODYXIM6 SRC=globus.jpg ALIGN=LEFT WIDTH=40% HEI6HT=40% HSPACE=8 VSPACE=10 BORDER=5 А1/Г='Рельеф земной поверхности'>

<Р ALIGN='Justify'> В данном документе рисунок выравнивается влево, т. е. он должен размещаться в левом верхнем углу. Размеры рисунка 60 на 60 пикселей. Рисунок окружен рамкой шириной в 5 пикселей и отделен от текста полями по 10 пикселей с каждой стороны. Текст размещается справа от рисунка и, в дальнейшем, ниже его.</Р></BODY></HTML>

Приведенный выше HTML-документ отображался в браузере MS Internet Explorer и полученное в окне браузера изображение показано на рис. 2.7 Рис. 02.07.. В частности, на рисунке видна надпись «Рельеф земной поверхности», заданная в виде значения параметра ALT и возникающая на экране при подведении указателя мыши к изображению.

В заключение отметим, что фирма Netscape в своем браузере предусмотрела возможность использования еще одного параметра втеге<1МС>, а именно LOWSRC. В качестве значения этого параметра указывается графический файл с альтернативным изображением того же самого объекта, но с гораздо более низким разрешением и глубиной цвета. В результате альтернативное изображение имеет на порядок меньший информационный объем и быстро загружается на Web-страницу, а только позднее загружается основное изображение. Пример записи тега с этим параметром представлен ниже:

<IMG SRC=globus.gif LOWSRC=low-globus.gif>

Следует заметить, что размеры этих двух изображений должны совпадать. Если параметр LOWSRC задает изображение меньших размеров, то основное изображение будеттакже трансформироваться к этим меньшим размерам. Чтобы избежать возникающих вследствие этого эффекта искажений, следует в теге <IMG> указать действительные размеры основного

изображения в пикселах стем, чтобы при первом проходе и загрузке вспомогательного изображения размеры последнего приводились к размерам основного, а не наоборот.

2.5.
Включение в издание ссылок и комментариев

Ссылка Ссылки являются важнейшей составляющей HTML-документа, так как именно они и делают этот документ гипертекстовым, реализуя важнейшее преимущество электронного документа по сравнению с печатным, состоящее в широчайших возможностях перемещения по документу и вне его. Ссылка состоит из указателя и адресной части. Указатель представляет собой малый фрагмент документа (одно или два слова или изображение), который каким-либо образом выделен (например, цветом или подчеркиванием). Если подвести указатель мыши к ссылке и щелкнуть кнопкой мыши, то браузер загрузит новый документ или перейдет к той части данного документа, адрес которой указан во второй части.

Текстовые указатели чаще всего выделяются в окне браузера подчеркиванием. Если же в качестве ссылки использовано изображение, то такое изображение браузер самостоятельно заключает в рамку. Второй частью ссылки является адрес той страницы, которая должна быть загружена. Адрес, как уже указывалось ранее, может быть абсолютным ил и относительным. В последнем случае адрес формируется относительно того каталога, в котором расположен исходный документ. Пример предыдущего параграфа содержит относительный адрес рисунка globus.jpg, который расположен в том же каталоге, что и сам HTML-документ.

Для организации ссылок используется тег-контейнер <А>, который имеет параметр HREF, причем значение этого параметра и является адресом загружаемой страницы, о чем говорилось выше. Конструкция данного контейнера выглядит следующим образом:

<А HREF=URL-aflpec нужной страницы> Текст-указатель ссылки </А>.

Когда курсор мыши подводится к текстовому указателю, во всплывающем окне появляется адрес ссылки, который записан в качестве значения параметра HREF. Щелкнув левой кнопкой мыши по этому указателю, мы инициируем процесс загрузки документа или страницы с этим адресом.

Запись ссылки, указателем в которой служит не текст, а изображение, выглядит следующим образом:

<А HREF=URL-aflpec нужной страницы><IMG 8КС=(имя графического файла)></А>

Действительно, в представленном примере тег <IMG> с параметром SRC, задающим имя графического файла, играет ту же самую роль, что и текст-указатель ссылки в предыдущем примере. Некоторым преимуществом последнего способа является то, что изображение занимает больше места в окне браузера, чем текст-указатель ссылки, и на него можетбыть быстрее выведен курсор мыши.

Выше уже отмечалось, что относительная ссылка указывает не полный путь к файлу, а его местоположение относительного того документа, из которого производится ссылка. Для облегчения работы с относительными ссылками в заголовочной части документа может использоваться тег <BASE>, в котором с помощью параметра HREF указан абсолютный URL-адрес этого документа, относительно которого и строится вся адресация ссылок (см. также § 2.1 данной главы).

Если ссылки на внешние документы позволяют свободно ориентироваться пользователю в безбрежном море сети Интернет, то для качественной навигации в каждом электронном изданий необходимы ссылки внутренние (в пределах самого издания). Скажем, встретив в издании незнакомый термин, Вы захотите узнать его смысл и назначение, для чего необходимо обратиться к списку терминов и определений (см. § 2.3), а затем вернуться к исходному тексту. Любой большой документ требует также наличия ссылок из его оглавления к соответствующим разделам. Могут потребоваться и другие ссылки, например, в текущем и предыдущем абзацах, по существу, такие ссылки указаны в виде адресации пользователя к определенным разделам данного учебника. Однако в печатном издании пользователь должен заложить текущую страницу, найти раздел, на который указывает ссылка, прочесть его и вернуться к заложенному месту. В электронном же издании эти операции автоматизированы и их выполняет компьютерная программа-браузер. И это их существенное преимущество.

Для организации Закладка переходов необходимо нечто, напоминающее закладки в печатном издании. Такие закладки, на которые может быть организована ссылка, реализуются с помощью параметра NAME уже упоминавшегося тега <А>. Параметр NAME позволяет определить имя закладки стем, чтобы в дальнейшем адресоваться именно к ней. Например, изданного параграфа мы адресовались к § 2.1 и § 2.3. Чтобы такие переходы можно было осуществить в электронном учебнике, к названиям таких параграфов надо добавить закладки:

<А NAME=paragraph_2-l><А NAME=paragraph_2-3>,

а в оглавлении записать названия этих параграфов внутри тега-контейнера <А>:

<A HREF='#paragraph_2-l'> 2.1. Общая структура гипертекстового документа, заголовок и тело документа, теги оформления заголовка </А>,

<А HREF=Yl#paragraph_2-3> 2.3. Оформление списков терминов и определений </А>.

Когда такие закладки имеются, переходы к ним можно было бы оформить не только из оглавления, но и из любого другого места электронного издания. Вместо указания в скобках (см. § 2.1) можно было бы вставить конструкцию с тегом-контейнером, а именно:

<А HREF='#paragraph_2-l'> (см. § 2.1) </А.

Можно настроить браузер таким образом, что соответствующая любой ссылке страница будет демонстрироваться в отдельном окне. Тогда, просмотрев текст или рисунок на этой странице, мы можем ее закрыть или свернуть, возвращаясь таким образом к основному документу. Отрегулировав должным образом размер этого отдельного окна, мы можем одновременно рассматривать как ссылку, так и основной документ. Эти возможности будут подробнее рассмотрены в § 2.7 при изучении фреймовой структуры гипертекстового документа.

Ссылки могут указывать и на специальные виды документов, например, на аудио- или видеофайлы или анимационные файлы в GIF-формате. Браузер может уметь или же не уметь работать с указанным специальным типом документа. Скажем, все современные браузеры умеют работать с анимацией в формате GIF89a, часто встречающейся на страницах в сети Интернет. Ссылка на такой файл приводит к появлению на страницы «движущегося» изображения. Если же браузер не умеет работать со специальным документом (не распознает тип принятого документа), он обратится кдругим программам на компьютере пользователя. Если нужная программа будет обнаружена, браузер передаст полученный документ этой программе для его обработки. Скажем ссылка на видеофайл формата AVI (см. § 3.5, § 4.5, § 5.5), может привести к запуску программы для демонстрации видеофайлов. В результате видеофайл будет показан в специальном дополнительном окне.

В заключение несколько слов о включении Комментарий комментариев в HTML-документ. Комментарий может состоять из любого числа строк и слов, расположенных внутри контейнера из двух тегов: открывающего текст комментария - <!- и завершающего этот текст––->. Текст комментария не отображается в окне браузера, поэтому его можно рассматривать как личные заметки авторов или редакторов в процессе работы над изданием. В то же время, если не убрать комментарий из окончательного текста издания, то он принципиально становится доступным и для читателей.

Другой тег-контейнер для записи комментариев - <СОММЕМТ> - поддерживается только браузером MS Internet Explorer и не нашел широкого применения.

2.6.
Оформление таблиц

Таблица Таблицы достаточно широко применяются в электронной документации, причем для Web-страниц они используются не только в традиционном смысле, как метод упорядоченного представления данных, но и для форматирования самих этих страниц. Описание таблицы на языке HTML размещается внутри тела документа, т. е. в контейнере <BODY> и </BODY>. Внутри документа допускается любое число таблиц, причем некоторые из них могут быть вложенными. Каждая таблица создается в пределах контейнера <ТАВLЕ> и </ТАВLЕ>, где размещается описание структуры самой таблицы и ее содержимое.

Каждая строка таблицы размещается после тега <TR> (Table Row). Каждая ячейка таблицы в пределах строки оформляется тегом <ТН> (Table Header) - для заголовочной части таблицы или <TD> (Table Data) - для ячеек, в которых размещаются данные. В заголовочной части по умолчанию применяется полужирный шрифт и выравнивание по центру. Для отображения данных по умолчанию используется нормальное (светлое) начертание и выравнивание влево. Можно отметить, что для всех тегов, перечисленных в этом абзаце, закрывающий тег не обязателен, т. е. он может быть опущен.

Количество строк в таблице определяется количеством строчных тегов <TR>, а число столбцов - максимальным количество тегов <ТН> или <TD> в одной из строк. Строкой считается все то, что следует после очередного тега <TR> и до следующего такого тега. Для ячейки таблицы, не содержащей данных, надо использовать пустой контейнер <TD> и </TD>. Если пустые ячейки расположены в конце строки, то их описание может быть опущено - браузер самостоятельно оставит необходимое число ячеек пустыми.

Таблица может иметь название - то, что в редакционной практике называется тематическим заголовком (в отличие от нумерационного), причем если в печатном издании заголовок обязательно расположен над таблицей, то в электронном он может быть расположен как сверху, так и снизу. Заголовок расположен внутри контейнера <CAPTION> и </CAPTION>. Указанный контейнер должен быть помещен внутрь тега-контейнера <ТАВLЕ>, но вне области описания тегов <TR>, <TH> или

<TD>. Последняя спецификация HTML рекомендует размещать тег-контейнер <CAPTION> сразу после открытия таблицы, т. е. после тега <TABLE> и до первого тега <TR>.

В теге <CAPTION> первоначально был предусмотрен один необязательный параметр ALIGN, который предназначался для вертикального выравнивания и мог принимать одно из двух значений ТОР (по умолчанию) или BOTTOM. Затем выяснилась необходимость и горизонтального выравнивания стремя стандартными параметрами LEFT, RIGHT и CENTER. Однако нельзя в одном теге дважды использовать один и тот же параметр. Поэтому в современных версиях языка HTML параметр ALIGN (по умолчанию ALIGN=LEFT) оставлен для выравнивания по горизонтали, а вертикальное выравнивание (точнее - размещение заголовка над или под таблицей) осуществляется с помощью параметра VALIGN.

В теге <TABLE> могут использоваться следующие параметры: BORDER, CELLSPACING, CELLPADDING, WIDTH, ALIGN, HEIGHT и BACKGROUND. Параметр BORDER управляет отображением рамки вокруг каждой ячейки таблицы (т. е. задает вертикальные и горизонтальные линии сетки) и вокруг всей таблицы, причем его значение задаеттолщину рамки в пикселах вокруг всей таблицы, а само наличие этого параметра задает линии сетки. Значение параметра BORDER появилось лишь в версии 3.2 спецификации HTML, до это го тол щи на рамки вокруг таблицы не регулировалась.

Параметр CELLSPACING задает расстояние между смежными по горизонтали и вертикали ячейками, причем это расстояние задается в пикселах, т. е. внутри каждой ячейки создается нечто вроде рамки и лишь при CELLSPACING=0 эти рамки отдельных ячеек сливаются в единую сетку. Параметр CELLPADDING определяет расстояние между рамкой вокруг ячейки и данными внутри ее, т. е. величину отступа символов от рамки. При значении CELLPADDING=0 текст может касаться рамки, что в плане дизайна едва ли можно приветствовать. По умолчанию значение CELLSPACING=2, a CELLPADDING=1, в этом случае расстояние между данными в соседних ячейках будет равно б пикселам.

Параметры WIDTH и HEIGHT позволяют задать ширину и высоту таблицы как в абсолютных единицах - пикселах, так и в относительных - процентах относительно размера окна браузера. В большинстве случаев эти размеры не требуются браузеру, так как он автоматически вычисляет размеры таблицы, учитывая множество факторов, включая параметры документа в целом, количество ячеек в таблице и их заполнение. Браузер стремится установить такую ширину таблицы, чтобы она помещалась в окне просмотра браузера и не было необходимости в прокрутке таблицы по горизонтали, т. е. чтобы горизонтальный слайдер отсутствовал.

Надо отметить, что и при задании значений параметров WIDTH и HEIGHT нет гарантии в том, что они будут выдержаны браузером. Если ширина таблицы больше ширины окна просмотра, браузер сделает попытку уменьшить ширину до требуемой, пропорционально уменьшая размеры колонок, и только если это не удастся, установит заданную ширину таблицы, снабдив окно слайдером.

Параметр ALIGN задает горизонтальное выравнивание таблицы в окне просмотра браузера. Возможны два значения этого параметра: LEFT и RIGHT, каждый из которых обеспечивает обтекание таблицы текстом документа с противоположной стороны. Это соответствует оборочной таблице в печатном издании. По умолчанию параметр ALIGN принимает значение LEFT. Если параметр ALIGN опущен, то текста рядом с таблицей не будет вообще, т. е. таблица будет форматной или полосной (когда она занимает всю страницу по вертикали), если использовать термины, принятые в печатных изданиях. Значение параметра ALIGN=CENTER не предусмотрено. Однако если мы хотим ориентировать таблицу по центру, можно пойти другим путем: заключить контейнер <TABLE> n</TABLE>, который описывает всю таблицу целиком, в контейнер <CENTER> и </CENTER>. Напомним, что последний имеет уровень блока, т. е. форматирует любое количество данных, размещенных внутри его (см. § 2.2).

Отметим, что параметр ALIGN может использоваться и для форматирования данных внутри каждой ячейки таблицы, например:

<TABLE ALIGN=LEFT WIDTH=40% BORDER=5 >

<TR><TH ALIGN=RIGHT> Фамилия </ТН><TH ALIGN=RIGHT> Оценка</TH>

<TR><TD ALIGN=RIGHT> Иванов A.H. </TD><TD ALIGN=RIGHT>

4 </TD>

<TR><TD ALIGN=RIGHT> Сергеев И.Д. </TD><TD ALIGN=RIGHT>5 </TD>

<TR><TD ALIGN=RIGHT> Лавров В.В. </TD><TD ALIGN=RIGHT> 3</TD>

</TABLE>

Пример отображения браузером документа, включающего в себя приведенный выше фрагмент, показан на рис. 2.8 Рис. 02.08.. На рисунке хорошо видна рамка вокругтаблицы и то, что таблица выровнена влево, а справа обтекается текстом. В качестве текста использован фрагмент второго абзаца, начинающегося на данной странице. Следует обратить внимание на то, что хотя вся таблица выровнена влево, данные в каждой строке выравниваются вправо. Формально можно было бы в каждой ячейке выравнивать текст по-своему. Однако визуально это выглядело бы очень неприглядно.

Для качественного дизайна полосы данные во всех ячейках столбца таблицы должны выравниваться одинаково, т. е. в примере на рис. 2.8 Рис. 02.08. возможно было бы оставить первый столбец неизменным, а данные во втором выровнять влево (или даже по центру).

Параметр BACKGROUND, который уже был показан в примере, приведенном выше, также может использоваться как в теге <ТАВLЕ>, так и в тегах <ТН> и <TD>, определяющих характеристики отдельных ячеек таблицы. Во всех случаях он определяет фоновый рисунок с помощью параметра HREF. В последней версии спецификации HTML в теге <ТАВLЕ> появился параметр COLS, задающий общее число колонок в таблице. Эта дополнительная информация ускоряет процесс построения таблицы браузером.

При создании заголовочной части таблицы, реже боковика и прографки (основной части таблицы, где размещаются данные), возникает потребность в объединении нескольких ячеек по горизонтали (в строке) или по вертикали в единое целое. Для этого используются параметры ROWSPAN и COLSPAN, первый из которых объединяет несколько строк, а второй - столбцов в одну ячейку. Пример описания такой таблицы приводится ниже.

<TABLE BORDER=10 SELLSPACING=3 CELLPADDING=4 WIDTH=80%>

<CAPTION><H4> Объединение ячеек в заголовочной части</Н4>

<TR><TH ROWSPAN=2>3aголовок </TH><TH COLSPAN=2> Заголовок 2 </ТН>

<TR><TH>Заголовок 2-1</ТН><ТН>Заголовок 2-2 </ТН>

<TR ALIGN=CENTER><TD> 1 <TD> 2 <TD> 3

</TABLE>

Показанный ниже рис. 2.9 Рис. 02.09. построен на основании HTML-документа, в теле которого содержится приведенный выше контейнер <TABLE> и </TABLE> со всем его содержимым. По сравнению с таблицей, показанной на рис. 2.8 Рис. 02.08., здесь с помощью тега <CAPTION> добавлен тематический заголовок, выровненный по центру таблицы. В таблице хорошо видны рамки ячеек и рамка вокруг таблицы в целом. В ячейке «Заголовок 1» объединены две строки, а в ячейке «Заголовок 2» - два столбца, что соответствует исходному HTML-коду. В третьей строке, как это часто делают для длинных узких таблиц, указаны номера колонок, что позволяет при переносе на следующую полосу не повторять заголовка целиком. Отметим, что используя параметры ROWSPAN и COLSPAN можно составить многоуровневые заголовки таблиц любой степени сложности.

2.7.
Фреймовая структура электронного издания

Для удобства работы с электронным изданием окно просмотра браузера может быть принудительно разбито на несколько прямоугольных областей, непосредственно примыкающих друг к другу. В каждую такую область можно загружать отдельные HTML-документы, просматривая каждый из них независимо от других. Впервые возможность работы с фреймовыми структурами была реализована в браузере фирмы Netscape версии 2.0. MS Internet Explorer поддерживает фреймы начиная с версии 3.0.

Фреймовая структура целесообразна для применения в следующих случаях:

  • для представления информации в нескольких смежных областях окна просмотра браузера, каждая из которых просматривается независимо, чтобы иметь возможность сопоставить эту информацию;

  • для того чтобы в определенной области экрана размещалась информация, которая должна постоянно находиться в поле зрения пользователя;

  • для того чтобы иметь возможность управлять загрузкой документов в одну из областей, работая в другой области экрана.

В целом же фреймовая структура предоставляет пользователю удобные средства навигации в пределах электронного документа, практически нереализуемые при других вариантах. Видимо, по этим причинам фреймовая структура достаточно часто используется для реализации Web-страниц, особенно входных или лицевых страниц сайтов, т. е. тех, на которые пользователь попадает при начальной загрузке этого сайта.

Принципиальное отличие HTML-кода, задающего фреймовую структуру, состоит в том, что вместо тега <BODY> в нем используется тег-контейнер <FRANESET>, параметры которого и определяют разбиение площади окна браузера на отдельные участки или области. Для этого у тега <FRAMESET> используется два параметра: ROWS и COLS. Параметр ROWS делит окно браузера на горизонтальные полосы, a COLS - на вертикальные. Размеры этих полос могут устанавливаться в абсолютных единицах - пикселах и в относительных - процентах или пропорциональных единицах. Первые два способа задания уже рассматривались ранее и не требуют дополнительных комментариев, третий же способ использует количество звездочек (*), каждая из которых представляет одну часть целого, величина этой части в данном случае определяется как высота окна браузера, деленная на суммарное количество звездочек под знаком параметра ROW. Все три способа деления окна на полосы иллюстрируется приведенными ниже примерами:

<FRAMESET ROWS='10%,80%,10%'>

<FRAMESET ROWS='60,480,60'>

<FRAMESET ROWS='*,8*,*'>.

Все три варианта с тегом <FRAMESET> описывают деление экрана на три горизонтальные полосы, из которых верхняя и нижняя одинаковой ширины, а средняя в восемь раз шире каждой из них. Аналогичным образом описывается и деление на вертикальные полосы с помощью параметра COLS. Для параметров ROWS и COLS возможен и смешанный вариант задания значений, когда используются два или даже все три способа одновременно. Например:

<FRAMESET COLS='70,4*,*,15%'>.

Тег задает деление окна на четыре колонки, первая из которых имеет ширину в 70 пикселов, последняя - 15% от ширины окна, ширина третьей колонки составляет 1/5, а второй - 4/5 от оставшейся части ширины окна.

Внутри контейнера <FRAMESET> и </FRAMESET> могут использоваться лишь вложенные такие же контейнеры или теги <FRAME>, которые определяют каждый одиночный фрейм. Кстати, в теле документа может быть несколько расположенных последовательно тегов-контейнеров <FRAMESET>, в каждом из которых могут быть и вложенные аналогичные

контейнеры. Практически же такие конструкции используются крайне редко. Тег <FRAME> размещается внутри контейнера <FRAMESET> и </FRAMESET>, причем количество тегов <FRAME> внутри этого контейнера должно в точности совпасть с число отдельных фреймов, т. е. каждый фрейм должен быть описан своим тегом <FRAME>. Тег <FRAME> содержит шесть параметров, а именно: SRC, NAME, MARGINWIDTH, MARGINHEIGHT, SCROLLING и NORESIZE.

Наиболее важный из перечисленных параметров SRC определяет URL или адрес документа, который изначально загружается в данный фрейм. Обычно это HTML-документ, содержащий и заголовочную часть, и тело. Параметр NAME позволяет присвоить этому фрейму уникальное (не повторяющееся) имя, которое может использоваться для адреса циикданному фрейму. В теге <А>, который рассматривался в § 2.5, для адресации к фреймам используется специальный пара метр TARGET, значением которого является имя соответствующего фрейма. Проиллюстрируем сказанное примером:

<FRAME SRC='maintenance.htm' NAME='main_frame'>

<A HREF='main_doc.htm' TAR6ET='main_frame'> Основной документ </A>.

В представленном примере в основной фрейм (имя этого фрейма - main_f rame) исходно был загружен документ maintenance.htm, т. е. оглавление электронного издания. Если же подвести указатель мыши к словам «Основной документ», которые являются указателем ссылки, и щелкнуть левой кнопкой, то в этот фрейм будет загружен новый документ под названием main_doc.htm, который находится в том же самом каталоге и представляет собой содержательную часть данного издания. Таким образом, присвоение фрейму определенного имени позволяет в дальнейшем загружать в него документы.

Параметры MARGINWIDTH и MARGINHEIGHT тега <FRAME> позволяют установить ширину полей фрейма по ширине и высоте. Отметим, что левое и правое поле имеют одинаковую ширину. То же самое можно сказать и про верхнее и нижнее поля. Значение этих параметров задается в абсолютных единицах- пикселах. Под полями здесь подразумевается свободное пространство, где не могут присутствовать иллюстрации и текст (как и в печатном издании). Минимальное значение этих параметров, устанавливаемое по умолчанию, равно 1 пикселу.

Если содержимое фрейма не помещается в отведенной части окна браузера, для него будутавтоматически создаваться полосы прокрутки по нужной координате. Для управления этим процессом служит параметр SCROLLING, который может принимать одно из трех допустимых значений: Yes, No и Auto. Последнее значение устанавливается по умолчанию. Значение No запрещает создание полос прокрутки, a Yes приводит к обязательному их созданию, независимо оттого, нужны они или нет.

Обычно пользователь может самостоятельно изменять размеры фреймов, точно так же, как и размеры окна браузера, где они размещаются. При таких операциях может нарушаться оптимальное соотношение между размерами фреймов и ухудшаться восприятие информации с экрана компьютера. Для того, чтобы предотвратить эти действия пользователя, служит параметр NORESIZE. Для этого параметра не предусмотрено каких-либо значений, но само его использование в описании одного из фреймов запрещает не только изменение размера этого фрейма, но и любого смежного с ним. Приведем несколько примеров изданий с использованием фреймовых структур. Первый пример задает структуру из пяти фреймов, которая образуется в результате деления окна браузера на три горизонтальные полосы, средняя из которых делится еще и на две колонки. Ширина нижней полосы, как следует из строки 3 HTML-кода, составляет 50 пикселов, а верхней - восьмую часть от высоты оставшейся области окна браузера. Средняя полоса разделена на узкую полоску слева и вчетверо более широкую оставшуюся часть (см. строка 5 HTML-кода). Наконец, эта оставшаяся часть поделена пополам по горизонтали (см.строка 7 HTML-кода).

<HTML><HEAD><TITLE>Цифровая обработка изображений</TITLE>

<МЕТА NAME='Author' СОNTENT='В.А.Вуль'></HEAD>

<FRAMESET ROWS='*,7*,50'>

<FRAME SRC='zag.html'scrolling='no'>

<FRAMESET COLS='20%,80%'>

<FRAME SRC='ogl.html'>

<FRAMESET ROWS='*,*'>

<FRAME SRC='lg.html' NAME='gl'>

<FRAME SRC='2g.html' NAME='g2'>

</FRAMESET></FRAMESET>

<FRAME SRC='inf.html' scrolling='no'>

</FRAMESET>

</HTML>

Полученная в результате структура экрана показана на рис. 2.10 Рис. 02.10.. Оба фрейма, в которых выводится содержимое электронного издания, имеют наибольшие размеры. В большинстве случаев содержание можно выводить в один большой фрейм, в этом же конкретном случае их два, что позволяет в одном изучать конкретный графический пакет PhotoShop, а в другом - общие методы обработки цифрового изображения, используемые в данном конкретном случае, например сжатие изображения.

Если пронумеровать расположенные на экране фреймы, присвоив им номера с 1-го по 5-й, то можно заметить, что содержание 1-го, 2-го и 5-го фреймов не изменяется: в 1-й постоянно загружен HTML-файл, отображающий заголовок документа (см. строка 4 исходного кода), в 5-й - информация об учебном заведении и авторе электронного пособия (чтобы можно было посмотреть другие учебнике на сайте uprint.spb.ru или по электронной почте связаться с автором), а во второй - файл оглавления (см. строка б исходного кода). В 3-м и 4-м фреймах выводятся параграфы 1-й и 2-й глав: в 3-м фрейме выводится § 1.1, ссылка на который во фрейме 2 выделена другим цветом как уже использованная, а во фрейме 4 отображается § 2.1. Таким образом, из одного фрейма с помощью ссылок осуществляется управление информацией в двух других фреймах.

Отметим, что специалисты по педагогике и психологии образования считают, что не следует отображать на экране более 3-х - 4-х фреймов, в противном случае ухудшается процесс восприятия информации с экрана. Несколько подробнее на этом мы остановимся в главе 9, а здесь приведем следующий варианттого же самого электронного учебного пособия, но с лаконичной 2-фреймовой структурой. Исходный HTML-код для него:

<html><head><title>Учебник по графике</title></head>

<frameset cols='20%,*'>

<frame пате='Навигация' target='main' scrolling='auto' src='naviagation.htm' noresize>

<frame name='main' src='content.htm' target='main'><noframes><body><р>Ваш браузер не поддерживает фреймы </р></body></noframes></frameset></html>.

Соответствующая этому коду структура электронного учебника представлена на рис. 2.11 Рис. 02.11.. На рис. 2.11 Рис. 02.11. отсутствуют фреймы заголовка и общей информации, а содержательная часть представлена в одном фрейме вместо двух. Каждый читатель может сам оценить, какая структура ему больше нравится, и попытаться сформулировать причины этого. Здесь первый фрейм назван «Навигация» (см. строка 3 исходного кода), а второй - «main», т. е. главный (см. строка 5 исходного кода). При начальной загрузке в главном фрейме выводится оглавление, так как во фрейме «Навигация» названия разделов даны в сокращенной форме, чтобы уменьшить протяженность этого фрейма по вертикали.

Основная адресация производится из фрейма «Навигация», но ссылки работают и из оглавления в главном фрейме. Для возврата в оглавление во фрейме «Навигация» есть специальная кнопка «Назад в оглавление». Во фреймах сделан фоновый рисунок, улучшающий дизайн издания. Размеры фреймов нельзя изменить (см. строка 4 в исходном коде).

Из других отличий отметим вставку в исходный код строк б и 7 для того случая, когда браузер пользователя не поддерживает фреймовой структуры. В этом случае будет выдано сообщение «Ваш браузер не поддерживает фреймы», так как тег-контейнер <NOFRAMES> содержит внутри контейнер <BODY> и </BODY>, распознаваемый всеми без исключения браузерами, в результате чего они выводят в окне содержимое этого контейнера. При отсутствии этих двух контейнеров такой браузер выдал бы сообщение об ошибке или же, что еще хуже, не вывел бы ничего в своем окне. Тег-контейнер <NOFRAMES> предусмотрен специально для такого случая.

Из других замечаний можно указать, что звездочка (*) во второй строке исходного кода интерпретируется как «оставшаяся часть», вместо нее можно было бы написать 80% - и ничего бы не изменилось. Еще раз хочется обратить внимание на особенности навигации при использовании фреймов иначе - на взаимодействие фреймов. В ссвязистем, что во фрейме «Навигация» в качестве значения параметра «TARGET» указано «main» (см. строка 3 исходного кода), то все ссылки из фрейма «Навигация» будут загружать документы во фрейм «main». Кнопка во фрейме «Навигация» играетту же роль, что и изображение - указатель ссылки. Наконец, рисунки в этом учебнике выводятся в плавающих окнах, которые можно расположить так, как удобно пользователю. Пример вывода рисунка в плавающем окне в левой верхней части окна браузера показан на рис. 2.12 Рис. 02.12..

2.8.
HTML-формы

HTML-формы HTML-формы - это особый вид гипертекстового документа, предназначенный для организации интерактивного взаимодействия в электронных изданиях. Именно с помощью формы мы общаемся с поисковым сервером, начиная поиск нужных материалов (документов) для работы, учебы или развлечения. Эту форму мы получаем с сервера и в специальном ее окне задаем параметры для поиска, например выражение в виде набора ключевых слов, т. е. тех слов, которые, по нашему мнению, наиболее важные и существенные в искомом документе. Таким образом, HTML-форма является средством пересылки данных от удаленного пользователя (клиента) к Web-серверу.

В Язык HTML языке HTML для задания форм используется теги <FORM> и </FORM>. Этот контейнер размещается внутри тела HTML-документа, причем таких контейнеров может быть несколько, но вложений их один в другой не допускается. Тег <FORM> может содержать несколько параметров, а именно ACTION, METHOD, ENCTYPE. Некоторые браузеры поддерживают и другие параметры, помимо перечисленных трех стандартных. Первый из параметров задает адрес (URL) CGI-программы, которая будет обрабатывать данные этой формы. Это единственный обязательный параметр тега <FORM>.

Второй параметр (METHOD) определяет способ пересылки данных, содержащихся в форме, от браузера к Web-серверу. Он принимает два возможных значения: GET (по умолчанию) и POST. Значение METHOD=«POST» используется в случае необходимости пересылки на сервер определенного файла, который присоединяется к содержимому формы.

Параметр ENCTYPE определяет медиа-тип, используемый для кодирования и пересылки содержимого формы. Обычно его называют MIME-типом, где MIME-это аббревиатура, которая расшифровывается как Multipurpose Internet Mail Extension (многоцелевое расширение для Интернет-почты). Именно кодирование в соответствии со стандартом MIME позволяет безошибочно пересылать файлы, присоединяемые к HTML-форме.

Для создания отдельных полей внутри контейнера <FORM> и </FORM> используются теги <INPUT>, <SELECT> и <TEXTAREA>. Первый из этих тегов употребляется чаще других и обеспечивает многочисленные возможности ввода информации. Так, с его помощью можно осуществить ввод текста различного назначения, создать группу элементов-переключателей, одиночные кнопки для выполнения некоторых стандартных операций (например, сброс введенных данных), поля для установки флажков, поле для ввода имени файла, присоединяемого к форме.

Тег <SELECT> используется для организации компактной структуры для вывода одного варианта из нескольких, задаваемых в виде списка прокрутки. А тег <TEXTAREA> создает внутри формы поле для ввода многострочного текста в виде прямоугольной области, снабженной при необходимости полосами прокрутки. Кратко рассмотрим использование всех этих тегов.

Тег <INPUT> содержит два обязательных параметра: TYPE, который задает тип поля ввода, и NAME, с помощью которого имя переменной, соответствующей этому полю ввода, передается CGI-программе.

Параметр TYPE может принимать несколько значений. Одно из этих значений TYPE=«TEXT». В этом случае в форме создается узкая прямоугольная область (фрагмент строки) для ввода текста. Причем при этом значении параметра TYPE в теге INPUT могут использоваться три дополнительных параметра, а именно: MAXLENGTH=<число>, который определяет максимальное число вводимых символов, SIZЕ=<число>, задающий количество отображаемых в форме символов, и VALUE, который определяет значение текстового поля по умолчанию.

Другой вариант текстового поля - это TYPE=«PASSWORD». В этом случае вводимые символы отображаются в форме звездочками. Однако реальная безопасность передаваемого пароля не обеспечивается, так как на сервер эта строка передается в незашифрованном виде, т. е. открыто.

Еще одно значение TYPE=«FILE», причем в этом случае одновременно сполем для ввода текста (имени локального, т. е. размещенного на компьютере клиента, файла) в форме создается кнопка с подписью BROWSE (просмотр). Файл, выбираемый в процессе просмотра (локальный адрес его может быть сразу введен в поле), подсоединяется к содержимому формы при ее пересылке на сервер. Для корректного выполнения этой операции должны быть правильно заданы параметры формы: METHOD=«POST» и ENCTYPE=«MULTIPART/FORM-DATA». В противном случае вместо содержимого файла на сервер будет передано только его имя.

Значение TYPE=«CHECKBOX» создает поле ввода одного символа-флажка или переключателя типа «включено» - «выключено». Такие поля могут объединяться в группы путем задания для всех одного имени (NAME). Используется параметр VALUE, который передает на сервер выбранные переключатели. Может присутствовать также параметр CHECKED, указывающий, что определенное значение соответствующего элемента является выбранным по умолчанию.

Значение TYPE=«RADIO» определяет структуру, подобную многопозиционному переключателю, т. е. набор из нескольких выключателей, один (и только один) из которых включен в любой отрезок времени. Каждый выключатель оформлен в виде круга, внутри которого при его выборе появляется точка. Здесь строковая переменная VALUE передает на сервер значение выбранной кнопки, а параметр CHECKED устанавливает значение по умолчанию.

Значение параметра TYPE=«RESET» или же «SUBMIT» соответственно отменяет все введенные в форму значения или же пересылает содержимое формы на сервер. В обоих случаях в форме отображаются кнопки с соответствующим и надписями. Надписи на кнопках можно русифицировать, задав значение параметра VALUE равным «ОТМЕНА» или же «ОК» («ПЕРЕСЫЛКА»). Возможно использование значения параметра TYPE=«IMAGE». В этом случае создается графическое изображение, аналогичное кнопке SUBMIT. Адрес изображения задается стандартным параметром SRC=<URL файла-изображения>, а способ выравнивания значением параметра ALIGN.

Иногда вместо тега INPUT используется контейнер <SELECT> и </SELECT>, который позволяет организовать выбор значений в пределах спискового окна. Это обеспечивает экономию пространства формы. Пример контейнера:

<SELECT NАМЕ='имя поля' SIZE=[число видимых элементов списка]>

<OPTION VALUE='значение 1-го элемента'> значение элемента

<OPTION VALUE='значение 2-го элемента'> значение элемента

<OPTION VALUE='значение 3-го элемента'> значение элемента

</SELECT>

Если требуется возможность выбора нескольких значений элементов списка, то внутри тега <SELECT> после параметра SIZE используется дополнительный параметр MULTIPLY. Ему не требуется присваивать какого-либо значения, само его наличие в пределах тега является достаточным.

Внутри формы может использоваться и еще один контейнер, а именно с тегом <TEXTAREA>. Он обеспечивает ввод многострочного текста в прямоугольное окно. Параметры этого тега: NAME - для задания имени соответствующей переменной, ROWS и COLS - для определения размера прямоугольного окна, внутри которого набирается нужный текст. Может быть задан текст, выводимый внутри этого окна по умолчанию.

В качестве примера можно остановится на форме сервера www.rambler.ru, которая выводится на браузере клиента, желающего получить бесплатный почтовый адрес. На рис. 2.13 Рис. 02.13., представлена такая форма в несколько усеченном формате. Как видно на рисунке, большинство полей - текстовые однострочные, задаваемые тегом INPUT и значениями параметра TYPE, равным TEXT (E-mail, «Имя», «Фамилия», «Возраст») и PASSWORD («Введите пароль» и «Подтвердите пароль»). В состав формы включены два переключателя: для указания пола клиента и его юридического статуса (физическоелицо или представитель юридическоголица). Для сокращения размеров формы (она и так получилась довольно большой) в ней используются четыре списковых окна с одним единственным видимым элементом. Это реализуется с помощью тега-контейнера <SELECT> со значением параметра SIZE=1.

Наконец, в форме предусмотрена область для ввода текста, задаваемая с помощью тега <TEXTAREA>. Размер этой области: шесть строк и около ста столбцов. По умолчанию в этой области выводится текст юридического соглашения с клиентом бесплатной электронной почты, указывающий права и обязанности сторон. Клиент не может изменять этоттекст, он должен его прочесть и принять условия соглашения, изложенные в этом тексте, если намерен получить бесплатный почтовый адрес на этом сервере. В конце формы предусмотрена кнопка типа SUBMIT, представленная в виде графического изображения с надписью «Зарегистрироваться». Если клиент согласен с текстом соглашения, он нажимает кнопку «Зарегистрироваться» и получает бесплатный почтовый адрес на сервере RAMBLER.

2.9.
Понятие о динамическом HTML и его компонентах

Динамический HTML (DHTML) Динамический HTML (DHTML) - это не какой-то особый язык, а термин, который применяется для обозначения HTML-страниц с динамически изменяющимся содержимым. Такие страницы основаны на использовании помимо языка HTML каскадныхтаблиц стилей CSS (Cascade Style Sheets) и языка сценариев JavaScript или VBScript. Связь этих компонентов осуществляется с помощью так называемой объектной модели документа DOM (Document Object Model). При этом HTML-документ приобретает новое качество - возможность динамического изменения без перезагрузки страницы.

С помощью каскадных таблиц стилей определяется внешний вид документа: шрифт, разбивка на абзацы, цвет фона и шрифта, причем свой вариант отображения в окно браузера с их помощью можно установить для содержимого каждого из контейнеров (тегов).

Язык программирования JavaScript Язык программирования JavaScript разработан фирмой Netscape Netscape для создания интерактивных HTML-документов. Язык позволяет разрабатывать как серверные приложения, так и приложения клиентские. Первые выполняются на Web-сервере, а вторые - браузером клиентского компьютера. Для обоих типов приложений используется общее ядро, включающее стандартные объекты и конструкции, и дополнения для конкретных приложений. Сказанное иллюстрируется рис. 2.14 Рис. 02.14.. Как видно на рисунке, в состав ядра входит помимо переменных и функции LiveConnect - средство взаимодействия с Java-апплетами. Клиентские приложения непосредственно встраиваются в HTML-страницы и интерпретируются браузером по мере отображения элементов страницы, серверные же приложения предварительно компилируются для увеличения производительности.

Язык JavaScript используется на клиентской стороне для создания HTML-документов с помощью сценариев, в том числе совместно с CSS (каскадными таблицами стилей), для оперативной проверки HTML-форм до их передачи на сервер для последующей обработки и для взаимодействия с пользователем в процессе выполнения приложений этого языка. Трудно найти в сети Интернет хотя бы одну страницу, не содержащую операторов языка JavaScript. Чтобы браузер смог отобразить разработанную Web-страницу именно в том виде, в каком она задумывалась, на странице обычно помещают вызов функции JavaScript для идентификации типа используемого браузера и его версии.

Встраивание сценариев JavaScript в HTML-страницу можно осуществить одним из четырех способов:

  • заданием операторов этого языка внутри контейнера <Script> языка HTML;

  • заданием имени файла языка JavaScript в параметре 5КСтега <Script>;

  • использованием выражений языка JavaScript в качестве значений параметров HTML-тегов;

  • путем определения обработчика событий в теге HTML.

Первые два способа, по нашему мнению, достаточно понятны и не нуждаются в дополнительных комментариях. Если переменные языка JavaScript желательно использовать в качестве параметров, то их следует заключать в фигурные скобки и размещать между символом ампесанда () и точкой с запятой. Например, в теге

<TABLE ALIGN=LEFT WIDTH=40% BORDER=5>

значение параметр WIDTH можно сделать изменяемым, заменив константу 40% переменной языка JavaScript, как это сделано в выражении, представленном ниже:

<TABLE ALIGN=LEFT WIDTH='{JWidth);' BORDER=5>,

причем значение переменная JWidth должно быть предварительно определено.

Для совместимости с языками сценариев в элементы форм языка HTML (см. § 2.8) были введены специальные параметры обработки возникающих событий. Простейшим событием может быть нажатие левой кнопки мыши Click.

Значениями этих параметров могут служить операторы языка JavaScript. Соответствующий любому событию параметр будет иметь дополнительную приставку on, например событию Click будет соответствовать параметр onClick. Обработка событий задается в параметрах форм для того, чтобы проверить введенную в форму информацию до ее пересылки на сервер.

Обсуждение самого языка JavaScript потребовало бы отдельной главы. Поэтому мы ограничимся приведенными в данном коротком параграфе сведениями, а всех желающих глубже ознакомиться с ядром JavaScript отсылаем к многочисленным пособиям по этому языку, например ссылка на источники литературы, где изложено его применение в HTML-документах.

Отметим, что фирма Microsoft Microsoft разработала язык создания сценариев VBScript, функциональные возможности которого ничем не отличаются от JavaScript. Определенным достоинством этого языка является возможность использования с небольшими доделками ранее написанных процедур на Язык Visual Basic языке Visual Basic.


Электронные издания:

3.
глава III. Мультимедийный документ и форматы представления его элементов

Данная глава посвящена рассмотрению состава мультимедийного документа и представления отдельных его компонентов. В частности, описываются различные варианты представления текстовой и графической информации. Указаны наиболее популярные графические форматы, используемые в электронных изданиях. Описаны возможные форматы представления аудиофайлов, особенности кодирования и сжатия соответствующих данных. В заключение анализируются форматы анимационных файлов и цифрового видео и варианты ком-прессии соответствующих данных.

3.1.
Мультимедиа и ее роль в современных информационных технологиях

Мультимедиа Мультимедиа сейчас - это полноценное объединение компьютерных и других информационных технологий: видео, аудио, фото, кино, телекоммуникаций (телефон, телевидение, радиосвязь), не говоря уже о тексте и графике, как статической, так и динамической (анимационной). С помощью приложений мультимедиа текст, графика, аудио- и видеоинформация объединяются в единое информационное поле, подобно тому как в кинофильме объединяются звук и движущееся изображение. Однако в отличие от кинофильма мультимедиа представляет собой интерактивную среду, т. е. пользователь может управлять процессом представления мультимедиа с помощью различных средств ввода, таких как клавиатура и манипулятор мышь.

Успешное сращивание телекоммуникационных сетей с компьютерами, стремительный рост их качества и количества преобразует вещательные сети в интерактивные, создает единое мировое информационное мультимедиа-пространство. Важнейшей частью этого пространства является сеть Интернет Internet и особенно, ее гипермедиа-система World Wide Web. Распространение мультимедиа-технологий (в сочетании с развитием электронной коммерции) в дальнейшем наложит жесткие ограничения на конкурентоспособность издательско-полиграфических фирм, ориентированных на широкий спрос. Преимущества в продаже даже самой высококачественной продукции получат те, кто быстрее и эффективней освоил электронные способы коммерции и обслуживания.

Использование мультимедиа в учебных пособиях дополняет аналитические (вычислительные и логические) и навигационные возможности компьютеров способностью к образному, синтетическому описанию изучаемого предмета или объекта. Многочисленные исследования показали, что обучаемый с первого раза запоминает лишь четверть услышанного и треть увиденного, при комбинированном воздействии на слух и зрение запоминается приблизительно половина информации, а при вовлечении обучаемого еще и в активные действия (например, при использовании интерактивных мультимедиа-технологий) доля усвоенного достигает 75%. Мультимедиа, особенно интерактивное, активизирует индивидуальные, личностные мотивы усвоения материала студентом, в том числе:

  • целевой (для меня важно и необходимо знать этот материал и уметь выполнять такую работу);

  • исследовательский (работая с учебным материалом, я не только узнаю что-то новое, но и чувствую себя активным участником процесса познания, сам участвую в творческом процессе);

  • эмоционально-эстетический (в процессе изучения материала я испытываю удовольствие как от получаемых результатов, так и от самого процесса изучения этого материала);

  • игровой (эта форма обучения интересна, начав изучать материал, я не могу остановиться, мне интересно и хочется довести до конца изучение материала);

  • инициационный (предполагает органичное сочетание в мультимедийном учебнике информационной и эстетически-эмоциональной глубины).

По уровню творческих мотивов и степени воздействия на человека мультимедиа следует отнести к новому виду синтетического искусства, отличительной особенностью которого является высокая информативность и интерактивность. Поэтому в будущем следует ожидать создания теории педагогики мультимедиа, учитывающей психофизиологические и эстетические законы восприятия и усвоения большого объема информации. Не исключая традиционной формы обучения, предполагающей творческое и воспитательное общение с преподавателем, мультимедиа создает новые позитивные факторы, в частности, значительный рост эффективности обучения за счет повышения качества самостоятельной работы студента с электронными учебными материалами.

Специалисты считают, что самую сложную систему автоматизированного управления было бы гораздо легче освоить в том случае, если она реализована на основе стандартного мультимедиа-интерфейса. В будущем, видимо, будут созданы эвристические алгоритмы мультимедиа, которые позволят не только человеку адаптироваться в компьютерной системе, но и компьютеру адаптироваться к уровню восприятия человека, т. е. сделать процесс адаптации двусторонним.

3.2.
Форматы представления текстовых блоков электронного издания

Еще несколько лет тому назад ответ на поставленный в заголовке данного параграфа вопрос был предельно прост: текстовые блоки должны быть в HTML формат гипертекстовом (HTML) формате или же в PDF (Portable Document Format) формате PDF, так как только эти форматы поддерживали возможность включения в электронное издание мультимедийных компонентов. В настоящее время практически все верстальные пакеты поддерживают не только преобразование подготовленного издания в формат РОР (или HTML), ной подключение к изданию мультимедиа-компонентов. В частности, в программном пакете PageMaker фирмы Adobe Systems Adobe предусмотрена в секции меню «Сервис» команда «Дополнения /QuickTime Media» (рис. 3.1 Рис. 03.01.), которая обеспечивает подключение к электронному документу объекта в универсальном формате QuickTime, который позволяет работать с любой времязависимой информацией, начиная от аудиоданных и кончая фильмами с несколькими видео-и аудиодорожками.

В широко распространенном в нашей стране текстовом редакторе Microsoft Word, начиная с версии 1997 г., предусмотрена возможность включения в состав документа не только анимации в формате GIF, но также и видеофильма в формате QuickTime, видеоклипа в формате AVI, клипа мультимедиа. На рис. 3.2 Рис. 03.02. показано диалоговое окно для команды «Вставка/Объект», которая иллюстрирует сделанное утверждение. Кроме того, принятый в этой версии редактора формат DOC стал в полной мере гипертекстовым, так как в нем появилась возможность включать в документ гипертекстовые ссылки как внутренние, для чего в документе делаются специальные закладки, так и внешние - по URL-адресу любого другого документа. В редакторе добавлена также возможность преобразования исходного документа в формат HTML, а также создания специальных HTML-форм. Часть этих возможностей представлена и усовершенствована в новой версии редактора - MS Word 2000.

Таким образом, наряду с форматом HTML и PDF (последний, строго говоря, хранит текст в графическом формате), текстовые блоки электронных изданий могут быть представлены в Форматы электронных изданий форматах DOC (MS Word), P65 (Adobe PageMaker) и многих др.

В том случае, когда электронное издание не содержит мультимедиа-компонентов, то оно может храниться в формате любого текстового редактора или верстального пакета; единственное дополнительное требование к текстовому редактору состоит в том, что он должен поддерживать графические форматы рисунков, если они включены в текст издания.

Для чисто текстовых изданий ограничений еще меньше. Их можно хранить и распространять в любом текстовом формате, используемом в современных персональных компьютерах. В частности, может использоваться форматТХТ (в том числе «простой текст» или plain text), гораздо более экономичный, чем формат DOC. Для кодирования любого символа такого текста используется всего один байт. Пример такой кодировки представляет American Standart Code for Information Interchange (ASCII) - Американский стандартный код для обмена информацией American Standart Code for Information Interchange (ASCII) - Американский стандартный код для обмена информацией. Для языков на основе латиницы и кириллицы такое кодирование вполне удовлетворительно.

Однако для некоторых восточных языков, например китайского или японского, этот подход неприменим, так как разнообразие символов в этих языках многократно превышает 256 - предельное значение этого параметра в ASCII-стандарте. В последние годы все более прочные позиции приобретает стандарт Unicode, или ISO 10646, т. е. стандарт под номером 10646 Международной организации по стандартизации (International Organization for Standartization). В этом стандарте каждый символ кодируется уже 2 байтами, т. е. предельное разнообразие символов достигает значения 65536. Этот стандарт часто называют стандартом многоязыковой поддержки, так как он позволяет кодировать символы государственных языков всех стран нашей планеты.

Однако в ТХТ-формате электронное издание не удовлетворяет даже самым скромным эстетическим запросам, так как в нем нет возможности использования не только графики, но даже шрифтов различного начертания, заголовков и подзаголовков, примечаний и других элементов, которые в совокупности называют «разметкой текста» (markup).

Из языков разметки текста помимо HTML, рассмотренного в предыдущей главе, наибольшее распространение получили:

  • TROFF, применяющийся при оформлении документации в рамках операционной системы UNIX и различных ее версий, включая LINUX;

  • ТЕХ, который широко используется для подготовки изданий с большим количеством математических формул;

  • SGML (Standart Generic Markup Language).

Исходная программа форматирования электронных документов в системе UNIX называлась ROFF (от Run OFF - тиражирование). TROFF означает Typesetting ROFF, т. е. форматирование текста для принтеров с высоким разрешением и фотонаборных устройств. Хотя область распространения этого языка и поддерживающих его программ постепенно сужается, в США он продолжает использоваться для создания электронных отчетов, которые могут одинаково успешно выводится на терминалах с низким разрешением и распечатываться с полиграфическим качеством.

Система верстки и язык ТЕХ был разработан хорошо известным среди программистов и математиков профессором Дональдом Кнутом для подготовки книг и пособий по математическим дисциплинам. ТЕХ работает на различных аппаратных и программных платформах. Его можно отыскать в сети Интернети бесплатно перенести паевой компьютер. Имеются и коммерческие версии этого продукта, в частности для платформы Macintosh фирмы Apple. Отметим, что помимо математических книг на этом языке издаются различные академические журналы, в том числе и в нашей стране.

Язык SGML реализует принцип логической разметки текста, который позволяет разграничить содержимое издания и его электронное представление. Именно этим принципом руководствовались специалисты фирмы

IBM, создавшие этот язык, который с 1986 г. получил статус международного стандарта. Кстати, HTML был создан именно на основе SGML. Основное достоинство языка SGML состоит в его универсальности независимости от программных средств для его интерпретации. Этот формат может быть конвертирован в форматы TROFF или ТЕХ. Язык изначально создан для производственных нужд, связанных с длительным хранением электронных документов большого объема, таких как описания крупных проектов или их документация.

Большинство из перечисленных текстовых форматов можно встретить в многочисленных «Электронных библиотеках», представленных в сети Интернет, о чем подробнее будет сказано в главе 8. Для ускорения загрузки таких изданий на компьютер пользователя они нередко представлены в архивированном виде, для чего чаще всего используются программы-архиваторы ARJ, ZIP и RAR, работающие в DOS'e, и WINZIP и WINRAR, предназначенные для работы в оболочке Windows.

Специальные языки разметки страниц в будущем будут активно развиваться. Одна из причин этого связана с автоматизацией извлечения информации из подготовленных электронных изданий. Такая операция обязательно производится для облегчения поиска информации, в частности, в сети Интернет. Для изданий, в производстве которых использованы принципы логической разметки и языки разметки страниц, многократно повышается эффективность поиска ключевых слов и выражений, адекватно отражающих содержание этих изданий.

3.3.
Форматы представления графической информации

Без Иллюстрации иллюстраций любое издание выглядит однообразно. Хорошо подобранная и рационально размещенная в издании графика не только улучшает дизайн издания, но и делает его значительно более информативным для читателя, помогает лучше передать его содержание и даже суть. Однако графика требует значительного информационного пространства для своего размещения, с чем связаны основные ограничения ее использования.

Известны два способа описания компьютерного изображения: точечный (растровый), при котором изображение формируется из отдельных точек, и векторный (контурный), где изображение состоит из отдельных объектов, ограниченных замкнутыми или незамкнутыми контурами, каждый из которых представляет собой сочетание отдельных отрезков прямых линий (векторов) и кривых (дуги окружностей, фрагменты параболических кривых и кубических сплайнов) линий. Каждый такой графический объект можно перемещать, масштабировать, вращать без потери качества изображения и независимо от любых других объектов.

Векторные файлы содержат математическое описание всех элементов изображения, которое используется программой визуализации для их отображения на экране монитора. Таким образом, сам процесс отображения информации требует определенных вычислительных мощностей для преобразования математического описания объектов в растровый формат монитора. Векторная графика характеризуется рядом положительных черт, к числу которых можно отнести следующие:

  1. Экономичность хранения изображений, т. е. сравнительно небольшие размеры графических файлов, хранящих изображение в векторном формате.

  2. Легкость трансформации и манипулирования отдельными графическими объектами (и всем изображением в целом).

  3. Максимальное использование разрешающей способности выводного устройства, с помощью которого осуществляется визуализация цифрового изображения, так как величина разрешения обычно в графическом файле непосредственно не задана.

  4. Простота интеграции с текстом, который состоит из отдельных символов, формируемых преимущественно контурным методов (например, элементы TrueType-шрифтов и шрифтовые объекты в формате PostScript).

Простейшие форматы векторного типа реализованы в электронных таблицах, используемых в пакетах Lotus 1-2-3 и Excel. Большинство же векторных форматов разработано для хранения чертежей, созданных программами САПР (Систем Автоматизированного Проектирования). В издательском деле и полиграфии к наиболее распространенным можно отнести формат PostScript, используемый для описания сверстанных страниц в фотонаборных автоматах и лазерных принтерах.

С точки зрения живописности и реалистичности изображения векторная графика имеет весьма ограниченные возможности, поэтому в издательском деле шире используется растровое представление. В случае применения векторной графики определенные трудности возникают и с автоматизацией ввода графического изображения в компьютер или оцифровкой изображения. Сканеры, цифровые фото- и видеокамеры хранят оцифрованное изображение в растровых форматах.

Точечная, или растровая, графика исторически стала применяться значительно раньше векторной. К ней можно отнести художественные изображения мозаичного типа: смальту, мозаику и даже вышивку. Таким образом, к ней относят изображения, полученные из мельчайших отдельных элементов, каждый из которых неделим и описывается постоянством тона на всем своем протяжении. Такие элементы принято называть пикселами (это понятие мы уже упоминали в главе 2). Каждый такой пиксел формально независим от соседних, т. е. может иметь различные характеристики: яркость, цветовой тон, насыщенность цвета и прочее.

К достоинствам точечной графики можно отнести следующие факторы:

  • простота и легкость ввода (оцифровки) изображений;

  • удобство технической реализации вывода информации (на монитор, лазерный или струйный принтер и т. д.);

  • реалистичность изображения;

  • возможность получения тонких живописных эффектов, таких как туман, тонкие цветовые переходы и нюансы цвета, перспектива изображения, размытость и нерезкость и пр.

Однако и недостатки точечной графики существенны. К основным из них относятся:

  • необходимость точных установок параметров до начала создания графического изображения, в частности, задания количества точек на единицу длины изображения, размера изображения по каждой координате, а также глубины цвета - количества бит для цветового представления каждого отдельного пиксела;

  • большой информационный объем получаемого графического файла, который определяется произведением трех величин: площади изображения, разрешающей способности и глубины цвета в согласованных единицах измерения, например, максимальное разрешение в пакете PhotoShop составляет 10000 пиксел/дюйм при максимальном значении 30000 пикселов по каждой координате, чему соответствуют размеры файлов до нескольких сотен Мб;

  • при повороте и других трансформациях изображения составляющие его горизонтальные и вертикальные линии превращаются в ступенчатые, т. е. обязательно появляются искажения при трансформациях изображения.

Важной характеристикой любого изображения, в частности растрового, является глубина цвета. Самое простое изображение использует два уровня серого, т. е. черный и белый. На цветовое описание элемента такого изображения (пиксела) требуется лишь 1 бит. Следующий вариант использует множество уровней серого, обычно 256, в результате чего каждый элемент изображения кодируется 1 байтом. Цветные изображения также могут быть различных типов.

В некоторых графических файлах используют так называемые индексированные цвета. В этом случае количество цветовых оттенков обычно не превышает 256, причем все они хранятся в самом графическом файле в виде палитры цветовых оттенков и каждый возможный цветовой тон в изображении соответствует одному из элементов этой палитры. Общее разнообразие или глубина цвета равна, как и в предыдущем случае, 8 битам, или 1 байту. Кстати, индексированные цвета используются и в оболочке Windows в виде встроенной палитры цветов, с которой мы еще не раз встретимся в рамках данного учебника.

Наконец, так называемое полноцветное изображение (True color) чаще всего работаете RGB-цветовом пространстве и использует! байт на каждый из трех основных цветовых компонент (красная, зеленая и синяя), т. е. общая глубина цвета равна 24 битам, или 3 байтам. При таком представлении количество различных цветовых оттенков превышает 16 миллионов. В некоторых графических файлах используется даже 48-битная глубина цвета. В этом случае каждый основной цвет представляется 16 битами или 65576 различными уровнями, а общее число различных цветовых оттенков выражается фантастической величиной, превышающей 2,6-1014.

Для электронных изданий, зачастую распространяемых по сетям, информационный объем представляет собой очень важную характеристику. Понятно поэтому стремление использовать векторные форматы или же специальные растровые форматы с внутренним сжатием информации для представления графических файлов. Кратко остановимся на методах и средствах сжатия изображений.

Существует две группы методов сжатия изображений: без потерь и с потерями. В первом случае при распаковке сжатого графического файла полностью восстанавливается вся исходная информация, в том числе, цветовой оттенок каждого отдельного пиксела. Во втором же - часть информации теряется, т. е. изображение становится несколько менее качественным, некоторые мелкие его детали утрачиваются. Во многих случаях это вполне допустимо, так как человеческий глаз различает, в лучшем случае, лишь несколько тысяч оттенков цвета и не реагирует на мел кие детали изображения (разрешение глаза близко к одной угловой минуте, откуда при нормальном расстоянии до изображения в 25-30 см можно подсчитать величину линейного разрешения глаза, которая близка к 90-100 мкм).

Большинство методов сжатия без потерь основано на варианте группового кодирования (Run-Length Encoding - RLE). Идея такого метода заключается в том, что последовательности повторяющихся значений заменяются на пару чисел, первое из которых дает количество повторяющихся

значений, а второе - само это значение. В описаниях многоцветных изображений очень часто соседние пикселы характеризуются одними и теми же тоновыми и цветовыми характеристиками, что и обеспечивает эффективность такого сжатия ссылка на источники литературы.

Схема сжатия без потерь Лемпела-Зива-Велча (LZW) в последние годы используется все шире и шире. Она позволяет работать сданными любого типа, обеспечивая достаточно быстрое сжатие и распаковку данных. Этот алгоритм называют алгоритмом подстановок или алгоритмом сжатия словарного типа. На основе входного потока данных алгоритм формирует словарь данных (его также называют переводной таблицей или таблицей строк). Образцы новых данных сравниваются с записями словаря. Если они там не представлены, то создается новая кодовая фраза. Если строка повторно встречается во входном потоке, то в выходной поток записывается ссылка на соответствующую строку словаря, которая имеет меньшую величину, чем исходный фрагмент данных. Таким образом реализуется сжатие информации.

Декодирование LZW-данных производится в обратном порядке. Декомпрессор читает код из потока данных и, если этого кода еще нет в словаре, добавляет его туда. Затем этот код переводится в строку, которую он представляет, и заносится в выходной поток несжатых данных.

Ряд графических форматов, в том числе и один из базовых - TIFF - используют в своих современных версиях встроенное LZW-сжатие. В частности, этот формат использован для представления рисунков в данной книге. Достоинством этого метода для графических файлов является хорошее сжатие данных для любой глубины представления цвета, начиная от штриховых и кончая полноцветными изображениями. В частности, такое сжатие успешно используется в формате GIF с индексированными цветами (глубина цвета 8 бит). Оба эти формата будут описаны в данном разделе.

В других случаях используется сжатие с регулируемой величиной потерь и переменным коэффициентом сжатия. Чем больше величина потерь, тем больше и коэффициент сжатия. Программа сжатия обычно делит все изображение на блоки размером 8x8 пикселов каждый. Уменьшение сжимаемого фрагмента позволяет уменьшить пропорционально квадрату его линейных размеров время обработки, т. е. деление на фрагменты эффективно увеличиваетскорость преобразования. Далее к значениям пикселов применяется формула, называемая дискретным косинусным преобразованием. Оно преобразует матрицу пикселов в матрицу значений амплитуд пространственного спектра изображения.

Значения элементов полученной матрицы характеризуют различные составляющие спектра: левый верхний угол результирующей матрицы соответствует самым низким частотам пространственного спектра, а правый нижний - самым высоким. Коэффициент качества преобразования, введенный предварительно пользователем, используется при получении значений элементов матрицы квантования. Чем ниже коэффициент качества, тем большие будут значения у элементов последней матрицы. Далее каждый элемент матрицы амплитуд делится на соответствующий элемент матрицы квантования. Полученные в итоговой матрице значения округляются до ближайшего целого числа. В результате таких операций в правой нижней части итоговой матрицы будет тем больше нулевых элементов, чем ниже заданный пользователем коэффициент качества. Затем программа сжатия кодирует элементы последней матрицы, начиная от левого верхнего по строке до правого нижнего одним из методов кодирования без потерь, причем чем больше нулей в последней матрице, тем меньше окажется информационный объем сжатого файла. Величина коэффициента сжатия для этого метода изменяется в пределах от 10 до 100 в зависимости от заданного значения коэффициента качества.

Декодирование сжатого описанным методом файла изображения начинается с шага обратного преобразования без потерь, в результате чего восстанавливается заключительная матрица, в которой содержится ряд нулевых элементов в правой нижней части. Затем значения элементов этой матрицы домножаются на элементы матрицы квантования, хранимой в самом сжатом файле. В результате получим восстановленную матрицу амплитуд пространственного спектра, значения которой отличаются отэлемен-тов исходной (они округлялись до целого значения в процессе сжатия с потерями), что и определяет отличия восстановленного изображения от исходного. Далее применяется обратное косинусное преобразование, в результате чего получим восстановленную матрицу значений пикселов, размер которой по-прежнему 8x8. В результате потери высокочастотных составляющих восстановленное изображение будет выглядеть более блеклым и размытым по сравнению с исходным.

Далее остановимся на основных форматах графических файлов. Самым универсальным графическим форматом является TIFF, разработанный известной в компьютерном мире фирмой Aldus Aldus для хранения оцифрованных изображений больших размеров и высокого разрешения (в 1999 г. эта фирма вошла в состав еще более крупной фирмы Adobe Systems Adobe, хорошо известной среди дизайнеров, издателей и полиграфистов всего мира своими программными пакетами для обработки растровой и векторной графики). Формат подходит для профессиональной работы художников с графикой и для факсимильной связи и передачи изображения, размером до несколько страниц. Формат обладает универсальностью и высокой гибкостью и хранит графические данные в структурированном виде, что позволяет графическим приложениям осуществлять быстрый поиск и загрузку нужных фрагментов изображения. В нем используется как полно-цветовое представление, так и представление с индексированными цветами. Он часто применяется для обмена различными типами графики. Однако размер графических файлов, представленных в этом формате, велик, что препятствует его использованию в электронных изданиях. Этот недостаток компенсируется в последних версиях формата применением эффективного встроенного LZW-сжатия, о котором было сказано выше.

Graphic Interchange Format (GIF) Graphic Interchange Format (GIF) компьютерной информационной службы CompuServe CompuServe является одним из наиболее употребительных растровых форматов в электронных, в особенности сетевых, изданиях. Он был создан для упрощения обмена данными в локальных компьютерных сетях, при возможности отображения этих данных. Основных достоинств у формата два:

  • пригодность для различных платформ, т. е. формат является платформно-независимым;

  • малый размер файлов благодаря использованию мощного алгоритма сжатия без потерь.

Изображение записывается в этом формате с использованием RGB-цветовой модели и данных встроенной в файл палитры индексированных цветов. К сожалению, серьезным ограничением для этого формата является ограниченная глубина цвета, не превышающая 8 бит на пиксел. Важное достоинство этого формата состоит в том, что он позволяет хранить в одном файле несколько изображений. Современная версия GIF89a решила проблему обработки таких изображений, размещенных в одном файле, с помощью дополнительно включенного в файл блока управления графикой. Этот блок позволяет программе просмотра организовать взаимодействие каждого последующего изображения с текущим, что и обеспечило создание широко распространенных анимационных GIF-файлов.

Графические данные в этом формате могут храниться как последовательно, строка за строкой, так и в формате, чередующем строки. В последнем случае рисунок первоначально строится на основе 1/8 части от общего описания, а в дальнейшем изображение «прорисовывается» все четче и четче.

Растровый формате глубиной представления цвета до 48 битс использованием той же RGB-модели создан специальной группой разработчиков и получил название PNG (Portable Network Graphic - переносимый сетевой формат), что произносят как «пинг». Формат PNG изначально планировался как замена формату GIF, но с улучшенными возможностями представления цвета. Он, как и GIF, поддерживает чередование строк и ускоренную начальную загрузку файла. В нем используется улучшенный алгоритм сжатия информации. Кроме того, в формате поддерживается режим полупрозрачных корректирующих слоев, аналогичный используемым в векторном AI и растровом PSD форматах графических пакетов фирмы Adobe. Единственное ограничение формата PNG по сравнению с GIF состоит в невозможности хранения в одном файле нескольких изображений и, вследствие этого, отсутствии анимационных возможностей.

Рассмотренные выше графические форматы содержали внутреннюю компрессию без потерь информации. Еще один формат, который относят к числу самых употребительных, характеризуется регулируемой величиной сжатия в зависимости от допустимой потери качества изображения. Этот Joint Photographic Experts Group (JPEG) формат разработан объединенной группой экспертов в области фотографии (Joint Photographic Experts Group) и назван аббревиатурой JPEG (расширение файлов JPG). Этот формат также растровый с глубиной цвета, равной 24 битам. Преимущественно используется цветовая модель HSL (Hue-Saturation-Lightness, или Оттенок-Насыщенность-Яркость). Алгоритм сжатия, используемый в таких файлах, носит название «алгоритм сжатия JPEG». Он был описан ранее в этом же разделе в качестве примера технологии сжатия с потерями в графических файлах. Различные его варианты использованы также при организации сжатия видеоданных (см. § 3.5).

Графические программы, которые позволяют хранить данные в этом формате, обычно выводятспециальную линейку, на которой устанавливается значение параметра качества, изменяющегося в пределах от 0 до 10 (рис. 3.3 Рис. 03.03.). Одновременно с непрерывным изменением коэффициента качества на линейке появляется дискретный параметр качества в форме целого числа в окне «Качество», а рядом в списковом окне - характеристика этого параметра. При значении от 0 до 2 качество «Низкое», 3-5 - «Среднее», 6-7- «Высокое» и 8-10 - «Наивысшее». На рисунке значение коэффициента качества равно б и качество «Высокое». При сохранении изображения можно установить «Разновидность формата» в позицию «Progressive», при которой величина чередования строк устанавливается в пределах от 3 до 5, что обеспечивает быструю начальную загрузку изображения низкого качества в сетевых структурах.

Используемый в формате JPEG подход «сжатие с потерями» частично идентифицирует и удаляетту информацию, которая несущественна для восприятия изображения. Лишь при сжатии изображения с резко выраженными контурами линии начинают «дрожать». При высоких значениях коэффициента качества изображения этот эффект не проявляется. Возможно, в дальнейшем появится вариант формата с избирательной установкой коэффициента качества для различных фрагментов изображения, что позволит достигнуть высокого качества при очень высоких коэффициентах сжатия.

В заключение этого раздела укажем последовательность графических форматов в порядке убывания их популярности (или частоты применения) для электронных изданий и документов: GIF, JPEG, PNG, TIFF.

3.4.
Форматы представления аудиофайлов

В этом разделе речь пойдет о цифровых форматах, хранящих звук файлов. Иначе говоря, - о хранении оцифрованного звука. Напряжение, передаваемое по телефонным каналам и несущее звук, представляет собой аналоговый сигнал достаточно сложной формы. Чтобы преобразовать такой сигнал в цифровую форму, необходимо выполнить последовательно две операции: дискретизацию и квантование. Дискретизация Дискретизация состоит в периодическом измерении значений напряжения (на рис. 3.4 Рис. 03.04. дискретизация сигнала производится в моменты времени t1, . . , t4, . .), а Квантование квантование - в преобразовании измеренных аналоговых значений в цифровой код. Соответственно, на качество оцифрованного звукового сигнала оказывают влияние два фактора: частота дискретизации и разрядность цифрового кода, получаемого при квантовании. При увеличении частоты дискретизации и разрядности кода качество оцифрованного звука улучшается, но пропорционально возрастает объем информации, которая должна храниться в файле, т. е. необходимо найти компромиссное решение между качеством и размерами файла.

Частоту дискретизации определить достаточно просто. В соответствии стеоремой Котельникова частота дискретизации должна быть вдвое больше максимальной частоты спектра звукового сигнала. Принятая в настоящее время частота дискретизации для аудио-CD составляет 44100 Гц, т. е. максимальная воспроизводимая частота звукового спектра составляет 20050 Гц, что превышает диапазон звуков, воспринимаемых ухом человека. Это обеспечивает идеальное звучание таких устройств. Частота дискретизации в телефонных сетях составляет 8000, что более чем в два раза превышает полосу пропускания телефонного канала, равную 3000 Гц.

Количество уровней или разрядность квантования характеризует точность передачи уровня звукового сигнала. Действительно, при 256 уровнях квантования или представлении уровня звука с помощью 8 бит информации, величина погрешности квантования равна половине расстояния между соседними уровнями, так как к именно с этой точностью значение электрического напряжения может быть преобразовано в цифровой код (притом условии, что наименьшему уровню сигнала, обозначенному min на рис. 3.4 Рис. 03.04., соответствует цифровой код 00000000 или OOh, а наибольшему, обозначенному max, - 11111111 или Offh в 16-тиричной форме представления), т. е. отнесено к одному из двух соседних уровней, между которыми находится реальное значение сигнала. Сказанное иллюстрируется рис. 3.4 Рис. 03.04.. Нетрудно сообразить, что при частоте дискретизации в 44100 Гц и квантовании каждого такого уровня 16-двоичными разрядами (4096 уровней квантования) хранение одной минуты цифрового аудио потребует около 5 Мб информационного пространства, а 30 минут стереозвучания - около 300 Мб.

Закодированные описанным способом цифровые аудиоданные характеризуются значительной избыточностью, т. е. они могут быть упакованы, а затем восстановлены без всякой потери качества. Однако применение для сжатия цифрового аудио архиваторов обычного типа, таких как ARJ или ZIP, позволяет сжать исходный файл приблизительно лишь на 20%, т. е. оно неэффективно.

Основная идея сжатия аудиосигнала с потерями - пренебрежение теми фрагментами звука, которые лежат вне пределов восприятия человеческого уха. Первая такая возможность определяется маскирующим эффектом, в соответствии с которым сильные звуки приводят к невосприимчивости уха к слабым в том же самом частотном диапазоне. Поэтому слабые звуки можно кодировать с малым количеством уровней, в результате чего сокращается количество информации, используемое при кодировании звука.

Далее, весь частотный диапазон делится на подполосы, каждая из которых обрабатывается отдельно, причем маскирующий эффект используется как внутри каждой подполосы, так и между ними, т. е. очень мощный звук в одной из подполос приводит к маскированию во всех остальных. Затем используются особенности психоакустической модели человеческого слуха, в соответствии с которой тщательно сохраняются звуки хорошо воспринимаемых частот и удаляются звуки тех частот, которые не воспринимаются.

Для стереозвучания используется дополнительный прием, связанный с тем, что стереоэффект воспринимается человеком только в области средних звуковых частот. Поэтому сигнал низких и высоких частот передается в монофоническом звучании.

Наконец, используются специальные алгоритмы сжатия, основанные на высокой предсказуемости звукового сигнала, т. е. большом значении его коэффициента автокорреляции. Все перечисленные выше методы и алгоритмы позволяют получить десятикратный и более высокий коэффициент сжатия практически без потери качества звучания, что реализуется в формате МРЗ, разработанном Комитет MPEG (Motion Picture Expert Group - группа экспертов в области движущихся изображений) комитетом MPEG (Motion Picture Expert Group - группа экспертов в области движущихся изображений).

Для воспроизведения звуковых файлов Формат MP3 формата МРЗ существует целая группа программ-плейеров. Список большинства из них можно найти на сайте http://www.dailymp3.com. Самые популярные из них - это Winamp, включаемая в дистрибутив браузера Netscape Communicator начиная с версии 4.7, K-Jofol, которая является самым быстрым декодером звука, и NAD (или NADDY), являющаяся лидером по качеству воспроизведения звука. Другие плейеры используются гораздо реже.

Из форматов звуковых файлов следуетупомянуть AU для UNIX-подобных систем и платформ, WAV - стандарт звуковых файлов для операционной системы Windows, AIFF - стандарт звуковых файлов для платформы Apple Macintosh и MIDI (Musical Instrument Digital Interface) - формат электронных музыкальных инструментов. Кратко остановимся на каждом из них.

Формат AU Формат AU - один из наиболее распространенных в сети Интернет. В заголовочной части файла определяются параметры звуковых данных:

частота дискретизации и разрядность квантования, число звуковых каналов и метод кодирования. Наиболее распространенные файлы этого формата носят подзаголовок p-Law, рассчитанные на один звуковой канал с полосой 8000 Гц. Подзаголовок p-Law означает преобразование значений линейного квантования в логарифмическую шкалу значений, которая производится в соответствии с уравнением:

,

где Yμ - значение в логарифмической шкале, m - исходное квантованное значение, mp - максимальная величина последнего значения, μ - постоянное значение, величина которого определяет область, в которой обеспечивается наиболее высокое качество звучания.

В формате AU наряду с 8-разрядным логарифмическим кодированием, предусмотрена возможность представления 16-разрядного линейного стереозвука, имеющего частоту дискретизации 22050 и 44100 Гц.

Формат WAV Формат WAV является основным на платформе Windows. Фактически это специальный тип файла формата RIFF (Resource Interchange File Format), который предназначен для хранения произвольных структурированных данных. Полное название такого формата - WAVE RIFF Microsoft Windows. Звуковые данные в таком файле обычно хранятся в РСМ-форме (РСМ - Pulse Code Modulation или импульсно-кодовая модуляция). Это означает запись в файле значений квантованного кода в последовательных точках дискретизации. В заголовочной части файла содержится основная информация об оцифрованном звуке, например число каналов и частота дискретизации, а также среднее число передаваемых в секунду байтов. Последняя характеристика позволяет программе воспроизведения звука выбрать требуемые размеры буфера для хранения звуковых данных. Большинство программ воспроизведения звука буфферизуют количество данных, соответствующее одной секунде непрерывного звучания.

Формат WAV поддерживает также ряд дополнительных блоков данных. К ним относят дополнительную информацию о сжатых звуковых данных. В частности, фирма IBM зарегистрировала специальные коды форматирования для сжатия в формате u-Law. Специальный блок позволяет помечать определенные позиции в потоке звуковых данных, что дает возможность синхронизировать звуковой ряд с видеорядом. Предусмотрены также блоки для размещения дополнительной текстовой информации.

Формат Audio Interchange File Format (AIFF) Формат Audio Interchange File Format (AIFF) преимущественно предназначен для работы на платформе Macintosh. Он во многом напоминает WAV, но позволяет, в отличие от последнего, хранить еще и шаблоны, т. е. образцы оцифрованного звука, которые можно использовать как шаблоны для отдельных нот. Специальная версия формата AIFF-C поддерживает сжатие.

Musical Instrument Digital Interface (MIDI) Musical Instrument Digital Interface (MIDI) - старейший звуковой формат, который позволил стандартизировать работу с различными электронными музыкальными инструментами. Стандарт базируется на пакетах данных, каждый из которых соответствует определенному MIDI-событию. Эти события можно разделить по каналам. Сложная среда такого файла может включать различную аппаратуру на каждом канале, причем отдельная часть будет отвечать за события на каждом канале. Такие файлы позволяют хранить не запись оцифрованного звука, а только ноты. В результате они гораздо компактнее других типов звуковых файлов. Недостатком такого формата является то, что он не определяет в явном виде всех тонкостей воспроизведения звука.

3.5.
Форматы представления анимации и цифрового видео

3.5.1.
Анимационные GIF-файлы

Известно, что Анимационные файлы в формате GIF анимационные файлы в формате GIF, занимают почетное место на Web-страницах. Надо сказать, что в электронных изданиях любого типа анимационные файлы также используются достаточно широко. Это объясняется тем обстоятельством, что GIF-файлы непосредственно воспроизводятся большинством браузеров, причем информационный объем, занимаемый этими файлами, сравнительно невелик.

Искусственный мир компьютерной анимации лежит где-то посередине между миром неподвижных изображений, форматы которых были рассмотрены в § 3.3, и реальным миром видеоизображений. Обычные мультипликационные фильмы состоят из множества рисованных изображений-кадров, в которых последовательно изменяются позиции объекта анимации. В результате при отображении с достаточной скоростью такой последовательности изображений у зрителя возникает впечатление движения объектов.

Возможности GIF-анимации связаны с тем, что этот формат позволяет хранить в одном файле несколько различных изображений. Единственный существенный недостаток GIF-файлов связан с применением индексированных цветов, для чего в файле используется глобальная и локальные цветовые палитры. Глобальная цветовая палитра хранит до 256 различных цветовых оттенков, каждый из которых может быть использован в любом из изображений, которое хранится в данном файле. Локальные палитры относятся к каждому отдельному изображению, т. е. хранимые в них цветовые оттенки не могут использоваться в других (не своих) изображениях.

Каждое такое изображение формирует отдельный кадр, причем задержка следующего кадра и его линейное смещением относительно предыдущего по каждой координате может регулироваться. Разрешение для всех изображений, входящих в данный файл, или количество пикселов по каждой координате должно в каждом файле поддерживаться постоянным.

Структура файлового формата GIF представлена на рис. 3.5 Рис. 03.05.. Файл начинается с общего заголовка и дескриптора логического экрана, причем в последнем хранится ширина и высота каждого изображения в пикселах, индекс цвета фона и значение коэффициента сжатия. Там же задается размер глобальной цветовой таблицы, которая может и отсутствовать. В этом случае обязательно используется для каждого отдельного изображения локальная палитра. В большинстве случаев рекомендуется пользоваться именно глобальной палитрой, что экономит общее информационное пространство, занимаемое файлом.

После указанных трех элементов следуют наборы данных, характеризующие каждое из входящих в файл изображений. Каждое изображение в отдельности описывается локальным дескриптором и локальной цветовой палитрой, после которых следуют данные изображения. Последние обычно состоят из последовательностей пакетов данных, называемых блоками, причем в состав отдельных блоков могут входить и подблоки.

Малый размер GIF-файлов связан с использованием поблочного LZW-сжатия изображения, причем большинство сжимаемых блоков имеют размер 255 байтов. Каждый пиксел декодированного изображения характеризуется размером в 1 байт и содержитзначение индекса цвета, т. е. положение нужного цветового тона в глобальной или локальной цветовой палитре.

Имеется две разновидности формата GIF-файлов: первоначальная версия, названная GIF 87a, и выпущенная двумя годами позднее вторая версия, названная GIF 89а. Вторая версия добавила несколько новых возможностей, в том числе хранение текстовых и графических данных в одном файле. Для этого в описание файла добавлен специальный блок «Управляющие расширения», который размещен сразу после трех общих для всего файла элементов и предшествует описанию отдельных изображений в составе файла. На рис. 3.6 Рис. 03.06.. этот блок выделен двумя жирными линиями. В состав управляющих расширений входят: расширение комментариев, расширение приложений и расширение управления графикой. В последнем указана, в частности, и величина задержки кадра в сотых долях секунды, а также значение индекса прозрачности цвета, который позволяет создавать новые анимационные эффекты. Кстати, большинство современных программ-аниматоров обеспечивает подготовку анимационных файлов именно в этом формате (см. глава 5).

3.5.2.
Принципы представления цифрового видео

Обычные телевизионные видеоданные представляют собой поток аналоговых сигналов. Компьютерная обработка видеоинформации состоит в преобразовании их в цифровой формат с последующим хранением этих данных на жестком или компакт-диске или другом устройстве хранения информации. Оцифровка видеосигнала, как и оцифровка звука, включает те же две стадии: дискретизация данных аналогового видеопотока, т. е. снятие отсчетов с определенной частотой, и преобразование каждого такого отсчета в цифровой эквивалент или квантование.

При хранении оцифрованных данных в несжатом формате изображение размером 400x300 пикселов с глубиной цвета 24 бита на пиксел, обновляемое с частотой 25 Гц, потребует скорости передачи информации более 5,5 Мб/с. А хранение данных для показа 5-минутного ролика в указанном формате потребует информационное пространство, превышающее 1,6 Гб. Естественно, что при работе с такими данными невозможно обойтись без сжатия, однако и этом случае потребуется время, определенные вычислительные мощности на распаковку данных. Достичь оптимального сжатия можно путем совершенствования аппаратных или программных средств, а может быть, совместно тех и других.

В качестве аппаратных средств используются специальные видеопроцессоры, которые поддерживают высокоскоростную компрессию и декомпрессию данных, не загружая центральный процессор компьютера. Второй подход состоит в использовании специализированных методов программного сжатия и распаковки предварительно сжатых видеоданных.

Аналоговый видеосигнал включает в себя несколько различных компонентов, объединенных в единое целое. Такой составной видеосигнал малопригоден для оцифровки. Предварительно его следует разделить на так называемые базовые компоненты. Обычно компоненты представляют собой три различных сигнала, соответствующие определенной модели представления цветового пространства. Если в статической графике используется RGB-цветовое представление, то в цифровом видео чаще используется модель YUV. Видеопоследовательности отображаются в виде серии кадров или фреймов, каждый из которых, no-существу, является графическим изображением и включает в себя определенное число пикселов. Такой видеофрейм может быть сжат с помощью одного из алгоритмов сжатия изображений, с потерями или без потерь.

Так, применение дискретного косинусного преобразования, рассмотренного в § 3.3, позволяет выделить высокочастотные составляющие пространственного спектра, которые практически не воспринимаются человеческим глазом и могут быть отброшены как избыточная информация. Затем фрейм может быть сжат с помощью одного из алгоритмов сжатия без потерь или за счет более сложной схемы, такой как JPEG. При внутрифреймовом кодировании достигается коэффициент сжатия в пределах от 20 до 40. Еще большее значение этого коэффициента достигается при кодировании совокупности фреймов.

Различие между кадрами в обычной видеопоследовательности, как правило, невелико. Поэтому если кодировать не целиком каждый фрейм, а лишь отличия каждого последующего фрейма от предыдущего, то объем данных, характеризующий каждый фрейм, существенно уменьшится. Это так называемое межфреймовое дельта-сжатие или компенсация движения. Применение типовых схем компенсации движения позволяет довести суммарный коэффициент сжатия видеопоследовательности до 200 и более.

3.5.3.
Форматы цифрового видео

В этом разделе мы проанализируем характерные форматы представления цифрового видео, такие как QuickTime фирмы Apple Apple, MPEG комитета Motion Picture Expert Group и AVI фирмы Microsoft Microsoft.

Общая черта всех популярных форматов цифровых видеофайлов состоит в том, что основная часть любого из них - это система сжатия и восстановления видеоданных (compression/decompression - сокращенно codec), называемая кодеком. Обычно программы, поддерживающие основные форматы видеофайлов, позволяют замещать старые кодеки на новые, более совершенные, по мере разработки последних. Такой подход позволил легко адаптировать форматы видеофайлов и поддерживающие их программы к новым технологиям, как только те становились доступными.

Исходные релизы форматов QuickTime и VfW содержали очень простые кодеки, так как уровень развития компьютерной техники того периода не мог обеспечить применение более качественных методов, требовавших значительно более высоко уровня вычислительного ресурса. По мере совершенствования компьютерных технологий стало возможным использовать более эффективные методы сжатия и распаковки, что привело к применению новых кодеков.

К наиболее известным и широко применяемым форматам следует отнести Формат QuickTime QuickTime фирмы Apple. Под этим именем объединены два различных понятия. Для пользователей - это стандартный способ работы с потоковыми данными, такими как видео и аудио. Для производителей - это гибкое средство разработки приложений, совершенствующееся по мере развития технологий. Формат пригоден для работы с любой времязависимой информацией. Видеофильмы в этом формате могут содержать несколько видео- и аудиодорожек. Таким образом, фильм в этом формате может иметь многоязыковую поддержку, а также содержать MIDI-информацию для управления внешним синтезатором. Продолжительность событий на каждой из дорожек также может быть различной. Можно также накладывать друг на друга несколько видеодорожек.

Формат был создан первоначально для платформы Macintosh для хранения аудио- и видеоданных на магнитных и оптических носителях. Сейчас он используется и в оболочке Windows. Предусмотрен специальный набор средств, называемый Movie Toolbox, который обеспечивает редактирование и модификацию видеофильмов в данном формате, т. е. можно вклеивать, вырезать, копировать и редактировать отдельные видеофрагменты таким же образом, как это делается при профессиональном монтаже обычного кино. Данные в этом формате можно хранить на магнитном или компакт-диске в виде обычного файла, а также помещать на цифровой видеомагнитофон.

Набор средств Movie Toolbox определяет шесть методов сжатия, используемых при хранении видеофильмов в этом формате. Перечислим эти методы.

Photo Compressor Photo Compressor - предназначен для сжатия отдельных изображений с глубиной цвета от 8 до 24 бит (для сжатия фреймов или видеокадров обычно используется метод JPEG).

Video Compressor Video Compressor - метод сжатия видеопоследовательностей с потерями, основанный на преобразовании пространственного спектра и временном сжатии. Глубина цвета - 24 бита. Метод отличается высокой скоростью распаковки сжатого видеоряда.

Compact Video Compressor Compact Video Compressor - также метод сжатия с потерями, пригодный для 16 и 24-битного представления цвета. Отличается более высоким качеством и большим коэффициентом сжатия по сравнению с предыдущим, но требует значительных затрат времени на выполнение начального сжатия информации.

Animation Compressor Animation Compressor - метод сжатия анимационных последовательностей, основанный на применении алгоритма группового кодирования, рассмотренного в § 3.3. Используется как в варианте с потерями, так и без потерь. Работает с любой глубиной цвета.

Graphic Compressor Graphic Compressor - предназначен для быстрого сжатия и распаковки 8-битовых неподвижных изображений и их последовательностей. Коэффициент сжатия невелик. Применяется при хранении информации на устройствах с низкой скоростью обмена данными, типа компакт- или DVD-дисков.

Raw Compressor Raw Compressor - программа предварительной обработки изображений, позволяющая получить нужную глубину цвета перед тем, как сжать его одним из описанных выше методов.

Аудиоданные в этом формате кодируются в виде последовательности квантованных дискретных выборок в формате AIFF, как это было описано в § 3.4 или непосредственно в ресурсе звуковой среды видеофильма.

Основная структурная единица файлов этого формата носит название атом. Различают атомы-контейнеры и атомы-листья. Контейнеры содержат другие атомы, в том числе и атомы-контейнеры. А атомы-листья содержат только данные. Каждый поток данных файла хранится в отдельном атоме дорожки. Дополнительные сведения о данном формате можно почерпнуть из книг ссылка на источники литературы и на сайте www.quicktime.apple.com.

Комитет Motion Picture Expert Group, как уже ранее упоминалось, был создан международной ассоциацией по стандартизации специально для создания высококачественных стандартов сжатия цифрового видео. И действительно был разработан ряд стандартов, таких как MPEG-1, MPEG-2, MPEG-4 для воспроизведения видео с различной скоростью и качеством на платформах Windows, Macintosh и UNIX, а также рекомендован определенный набор методов сжатия видео- и аудиоданных.

Формат MPEG-1 Формат MPEG-1 определяет файлы для хранения кодируемого видеоматериала (расширение mpv) и формат системного потока для объединения видео- и аудиоданных (расширение mps), а также три формата для кодирования только аудио (mpa, mp2и l3). Формат MPEG-2 Формат MPEG-2 предназначен для вещания и мало пригоден для персональных компьютеров. Формат MPEG-4 MPEG-4 предназначен для передачи низкокачественного видео для систем видеотелефонии и видеоконференций.

Стандарты MPEG определяют только способ хранения данных, но не указывают, как были получены данные в этом формате. Все форматы MPEG с потерями. Для кодирования данных в этом формате вычислительных ресурсов ПК недостаточно. Корректная обработка MPEG на ПК без дополнительных аппаратных средств также связана с определенными трудностями. Они могут привести к задержкам или ухудшению качества воспроизведения.

Формат MPEG хранит несколько типов кадров. Независимые или ключевые кадры (l-frames) не требуют никакой дополнительной информации для декодирования. При их сжатии используется методика, аналогичная JPEG-сжатию, но более эффективная. Предсказуемые кадры (P-frames) хранят различие между предыдущим независимым или предсказуемым кадром и текущим кадров (то, что в § 3.5.2 определялось как межфреймовое дельта-сжатие или компенсация движения). Дальнейшее улучшение качества сжатия достигается путем использования двунаправленных предсказаний движения или B-frames. В нем предсказание сохраняется как разности текущего как с предыдущим, так и с последующим кадрами, вследствие чего последовательность кадров может иногда нарушаться.

При кодировании звука MPEG отбрасывает ряд избыточных данных, опираясь на особенности человеческого слуха, о которых уже говорилось в § 3.4. В результате достигается гораздо более высокий уровень сжатия по сравнению с РСМ и u-Law, о которых говорилось в предыдущем параграфе. Оценивая данный формат, следует отметить, что он гарантирует самое высокое качество как видео, так и аудио, но требует наличия большого количества вычислительных ресурсов.

Формат Audio/Video Interleave (AVI) Формат Audio/Video Interleave (AVI) фирмы Microsoft Microsoft получил свое название из-за того, что в нем аудио- и видеоданные расположены перемежающимися слоями. В заголовке файла хранится множество различной информации, в том числе, о частоте следования и размере кадров. Программа воспроизведения должна извлечь данные видеокадра и связанного с ним звукового сопровождения, затем передать звук на звуковую карту, а видеоданные распаковать и воспроизвести на экране монитора.

Поддержка равномерного потока данных требует внимания ко всем частям системы воспроизведения для того, чтобы сохранить синхронизацию независимо от задержек при распаковке видеоданных.

В структуре AVI-файла содержатся два блока LIST. Первый из них (LIST hdrl) содержит информацию о фильме в целом и каждом из его потоков, включая разрешение экрана и частоту кадров видеоданных, а также формат, частоту оцифровки и разрядность квантованных аудиоданных. Второй блок LIST movi хранит сами видео- и аудиоданные в виде отдельных потоков, сегментированных на блоки выборки. Интересно отметить, что в формате AVI звуковые данные опережают видео на 0,75 с.


Электронные издания:

4.
глава IV. Средства подготовки электронных изданий

В этой главе рассмотрены средства для создания электронных изданий, т. е. верстальные пакеты, различные гипертекстовые редакторы, конструкторы анимационных GIF-файлов. В частности, описана технология создания гипертекстового издания в DOC-формате в распространенных текстовых редакторах Microsoft Word 97 и 2000, а также использование Word 97 в режиме HTML-редактора. Рассматривается использование специализированного HTML-редактора Netscape Composer, входящего в состав пакета Netscape Communicator. Оба этих редактора выполняют функции визуального конструирования элементов HTML-издания, хотя могут работать и в режиме редактирования тегов. Описаны также методы создания электронных изданий в формате PDF и специальные программы-конструкторы для подготовки анимационных GIF-файлов.

4.1.
Издательские технологии и электронные издания

При заключении договора автор обычно представляет в издательство полный текст своего произведения и список иллюстраций с подробным описанием методов их создания, а иногда и сами иллюстрации. Авторский текст набран, как правило, в одном из текстовых редакторов. Чаще всего в нашей стране для этого используют различные версии Microsoft Word.

Издательская подготовка к публикации книг и журналов включает в себя несколько этапов. В нее входит редактирование и оформление текста, подготовка иллюстраций, а затем - верстка издания, т. е. интеграция текста с иллюстрациями и, на заключительном этапе, подготовка компьютерного оригинала-макета. Для печатных изданий обычно выполняется также дизайн издания в целом, т. е. оформление его внешнего вида: в первую очередь обложки или переплета, а иногда и книжного блока.

Оригинал-макет Подготовка оригинала-макета издания обычно осуществляется в одном из верстальных пакетов: PageMaker, QuarkXPress или, реже, Ventura Publisher (Corel Ventura). Такое окончательно сверстанное издание может рассматриваться как его электронная версия, полностью идентичная печатной. Однако в большинстве случаев не только дизайн, но и форматы электронного издания должны отличаться от печатного. Поэтому в верстальные пакеты встроены специальные модули для преобразования издания в формат HTML или PDF. Таким образом, для преобразования подготовленного издательством макета печатного издания в электронное издание в заданном формате от сотрудников этого издательства не требуется практически никаких дополнительных усилий.

Однако, как уже упоминалось в первой главе, некоторые издания (например, библиографические справочники или путеводители на компакт-дисках) изначально проектируются в электронном виде. Во второй главе было отмечено, что HTML-документ HTML-документ может создаваться в самых простых текстовых редакторах, причем теги HTML-форматирования добавляются в ранее подготовленный текстовый документ вручную. Такой способ вполне допустим, однако он требует кропотливого рутинного ручного труда, а также хорошего знания языка HTML и больших затрат времени. Поэтому стремление к автоматизации такого рода труда с помощью специальных HTML-редакторов естественно.

Такие редакторы принято разбивать на две группы: редакторы тегов и WYSIWYG-редакторы. Редакторы тегов представляют возможность записывать исходный код документа на языке HTML. Современные версии таких редакторов имеют панели инструментов для генерации HTML-элементов (тегов и тегов-контейнеров), а также специальные мастера и шаблоны для облегчения работы со сложными элементами типа таблиц и списков. В таких редакторах содержатся также возможности синтаксической проверки записи тегов, что позволяет автоматизировать процесс обнаружения простых синтаксических ошибок. Типичным представителем редакторов первой группы является HotDog Web Editor, многочисленные версии которого разработаны фирмой Sausage Software ссылка на источники литературы.

Редакторы второй группы не требуют глубоких знаний языка HTML, а позволяют пользователю с помощью специальных инструментов изменять визуально внешний вид HTML-издания, встраивая в издание требуемые элементы и изменяя их размещение и взаимное расположение на странице. При этом соответствующий HTML-код создается автоматически. Сам принцип WYSIWYG (аббревиатура What You See Is What You Get) означает «что ты видишь, то и получишь», т. е. редактор выполняет функции визуального конструктора страницы. Пользователь ограничен возможностями такого редактора, которые могут не обеспечить достаточной гибкости работы на уровне тегов. Характерными представителями редакторов этой группы является Netscape Composer, входящий в состав пакета Netscape Communicator, и Microsoft FrontPage, причем первый из них рассмотрен в § 4.5 данной главы, а последний - в шестой главе.

С течением времени различие между этими двумя группами все больше стирается: инструменты редакторов первой группы становятся все мощнее и обеспечивают все большие возможности визуального программирования и размещения HTML-элементов и структур на страницах изданий, а редакторы WYSIWYG-группы становятся все более гибкими и мощными, а их возможности расширяются. Надо сказать, что один из наиболее популярных редакторов в нашей стране - Microsoft Word - в частности его версия 1997 г., превратилась не только в мощный редактор гипертекстовых документов, но и в современный HTML-редактор второй группы, который может также работать в режиме редактирования тегов. Поэтому именно с этого редактора, пригодного как для подготовки гипертекстовых документов в формате DOC, так и электронных изданий в HTML-формате, мы начинаем рассмотрение средств и технологии подготовки электронного издания.

4.2.
Подготовка гипертекстовых электронных изданий в DOC-формате

4.2.1.
Подготовка изданий в редакторе MS Word 97

В России Microsoft Word Microsoft Word - самое популярное средство подготовки офисных документов. В его версию 1997 г. включены специальные дополнительные средства для работы с гипертекстовыми электронными изданиями в виде команд «Закладка» и «Гиперссылка» в секции меню «Вставка» (рис. 4.1 Рис. 04.01.).

Первая команда, в соответствии со своим названием, позволяет установить метку или закладку в нужном месте издания, т. е. оформить определенную позицию в электронном документе или его малый фрагмент как точку входа в документ, а команда «Гиперссылка» - позволяет оформить любой элемент как указатель ссылки, который каким-либо образом выделен (например, цветом или подчеркиванием). С помощью такого указателя можно перейти к любому входу в документ, т. е. к месту, где установлена одна из закладок, либо к какому-либо внешнему файлу. Чтобы разобраться в том, как практически сделать документ со ссылками, детально рассмотрим соответствующие команды.

Активизация команды «Закладка» приводит к появлению одноименного диалогового окна, которое показано на рис. 4.2 Рис. 04.02.. В строке «Имя закладки» в верхней части окна следует задать ее оригинальное имя. Имя закладки должно обязательно начинаться с латинской буквы. В качестве остальных символов могут использоваться любые буквы и цифры, а также знак подчеркивания. Если имя закладки задано неверно, то кнопка «Добавить» становится пассивной. Ниже, в большем по величине окне, показан общий список закладок, что обеспечивает пользователя информацией при выборе имени каждой последующей закладки. Для удобства закладки сортируются по имени или позиции с помощью переключателя «Сортировать по». Специальная опция «Скрытые закладки» делает закладки в тексте невидимыми. В примере эта опция активна.

Когда вы выбрали нужное имя закладки, можно включить ее в документ, нажав кнопку «Добавить» в нижней части диалогового окна. С помощью кнопки «Удалить» можно убрать ранее созданную закладку, если выяснилась ее ненужность, а кнопка «Перейти» обеспечивает перемещение в то место издания, которое соответствует имени, указанном в строке «Имя закладки», позволяя проверить расположение закладки. Самая нижняя кнопка «Отмена» убирает это диалоговое окно, т. е. действует подобно команде «Отмена» в большинстве других диалоговых окон.

Диалоговое окно «Добавить гиперссылку» показано на рис. 4.3 Рис. 04.03.. Оно состоит из двух частей. Верхняя часть окна «Связать с файлом/URL» позволяет связать фрагмент данного электронного издания с любым фа илом на жестком диске компьютера или с сетевым документом, если известен его URL. Кнопка «Обзор» вызывает дополнительное диалоговое окно, которое позволяет просмотреть все каталоги и файлы на локальном диске компьютера и сетевом жестком диске (если компьютер пользователя включен в локальную сеть) и выбрать нужный файл, путь к которому будет автоматически занесен в строку «Связать с файлом/URL».

Кстати, имеется возможность указания не только абсолютных, но и относительных адресов в ссылках, т. е. адресов относительно каталога, в котором размещается редактируемый документ. Для этого достаточно задействовать соответствующую опцию в нижнем левом углу рассматриваемого диалогового окна.

Похожим образом реализуются и внутренние гиперссылки в нижней зоне диалогового окна, названного «Имя объекта в документе». Если мы незнаем, на какую из закладок следует сделать ссылку, то с помощью кнопки «Обзор» можно просмотреть весь список закладок в дополнительном диалоговом окне и, указав мышью на одну из них, автоматически перенести ее имя в строку «Имя объекта в документе». В частности, в примере на рис. 4.3 Рис. 04.03. в эту строку именно таким способом занесено имя закладки, упомянутой на рис. 4.2 Рис. 04.02. в окне «Имя закладки» (W_параграф2_5).

С помощью команд «Закладка» и «Гиперссылка» создается гипертекстовый документ в формате DOC. Наряду с этим в рассматриваемом редакторе имеется возможность преобразования любого текстового документа в формат HTML, для чего в секции меню «Файл» предусмотрена адаптивная команда «Сохранить в формате HTML». Перед этим рекомендуется сохранить документ в исходном формате, так как при переводе в формат HTML некоторые элементы форматирования могут быть утеряны. Отметим, что возможно и обратное преобразование, причем при работе с HTML-изданием упомянутая выше команда адаптируется к виду «Сохранить в текстовом формате».

Различные фрагменты текстовых документов не всегда адекватно трансформируются в формат HTML.

В частности, это относится к таким сложным текстовым фрагментам как таблицы. В то же время, маркированные и нумерованные списки, созданные в текстовом режиме работы редактора, успешно трансформируются в HTML-формат. Если при работе с маркированным списком использовать первый стандартный маркер, то при переводе в HTML-документ будет получен следующий фрагмент кода:

<UL><FONT FACE='Times New Roman' SIZE=2>

<LI>Первый элемент списка</LI>

<LI>Второй элемент списка</LI>

<LI>Третий элемент списка</LI></UL>

Как видно из примера, маркер устанавливается по умолчанию, а список формируется с помощью тега-контейнера <UL> со шрифтом второго размера. Как уже говорилось в § 2.4, использование закрывающего тега </UL> для элементов списка необязательно. Если бы при создании маркированного списка в редакторе Word мы бы применили маркер в виде ромба, то при переводе в формат HTML списковая структура вообще бы не создавалась, а каждый элемент маркированного списка представлялся бы в виде отдельного абзаца, которому предшествует графическая миниатюра, что полностью соответствует HTML-документу с маркером в виде графического файла (см. § 2.3).

Созданный в редакторе Word нумерованный список непосредственно трансформируется в соответствующую структуру HTML-кода. Во всех случаях в редакторе рекомендуется при создании списков пользоваться командой «Список» секции меню «Формат» и в диалоговом окне выбирать тип списка и тип маркера, так как как при работе с инструментами панели «Форматирование» будет автоматически выбран тот тип маркированного списка, который использовался последним в процессе работы.

4.2.2.
Подготовка изданий в редакторе MS Word 2000

В следующей версии редактора - Microsoft Word 2000 Word 2000 - сохранилась возможность создания гипертекстовых изданий в DOC-формате, однако изменился интерфейс редактора и диалоговое окно «Создание гиперссылки». Общий вид этого окна показан на рис. 4.4 Рис. 04.04..

В нем появилась специальная колонка «Связать с», которая позволяет с помощью кнопок связать текущий документ:

  1. С имеющимся на данном компьютере файлом или Web-страницей в сети.

  2. Определенным местом в текущем документе.

  3. Новым документом.

  4. Электронной почтой.

Рассмотрим каждый из этих вариантов. Так, в первом случае можно использовать три кнопки (с номерами с 5-го по 7-й), расположенные правее первой колонки, а именно: «последние файлы», «просмотренные страницы» и «вставленные ссылки», в результате чего будет изменяться содержимое расположенного рядом с этими кнопками списочного окна. Именно из размещенного в нем перечня можно будет выбрать, на какой файл или документ сделать ссылку. Если нажать одну из расположенных правее этого окна кнопок: «Файл» или «Web-страница», то можно будет выбрать нужный элемент из множества файлов (или Web-страниц), размещенных в списочном окне.

Если же требуется создать гиперссылки внутри данного документа, то следует нажать кнопку №2 «Связать с местом в данном документе». В результате диалоговое окно будет преобразовано к виду, показанному на рис. 4.5 Рис. 04.05.. Количество различных кнопок здесь резко уменьшилось. Основное место на рис. 4.5 Рис. 04.05. занимает окно «Выберите место в документе», где можно выбрать начало документа, заголовки разделов или уже сделанные закладки, причем последние организованы в виде дерева. На рисунке имя выбранной закладки (она выделена темным) появилось в строке «Текст».

В некоторых случаях электронное издание необходимо связать с новым документом. Этот режим определяется кнопкой под номером 3 и ему соответствует диалоговое окно, показанное на рис. 4.6 Рис. 04.06.. В окне можно прямо указать имя документа, на который формируется ссылка и сразу или позднее (см. соответствующий переключатель) внести изменения в этот документ. Новое окно отличается от предыдущего появлением кнопки «Изменить». Нажав эту кнопку, мы получим диалоговое окно «Создать документ», показанное на рис. 4.7 Рис. 04.07.. В нем имеется возможность в дереве каталогов выбрать нужную папку и указать имя и тип документа MS Office, который мы собираемся создать в этой папке. Следует обратить внимание, что кнопки с номерами от 1 до 4 присутствуют во всех диалоговых окнах, позволяя оперативно изменять характер и назначение гиперссылок.

Вариант, связанный с подключением посредством гиперссылки адреса электронной почты (кнопка №4 на рис. 4.4 Рис. 04.04.), представлен на рис. 4.8 Рис. 04.08.. В нем предусмотрены специальные строки для ввода электронного адреса и темы сообщения, а также окно, в котором выводится список недавно использованных адресов, что позволяет не вводить адрес, а выбрать его из списка.

4.3.
Редактирование HTML-изданий в редакторе MS Word 97

4.3.1.
Команды секции меню «Формат»

До сих пор мы рассматривали возможность создания гипертекстовых документов в DOC-формате. Далее обсудим возможности использования Word 97 в качестве HTML-редактора. Для перехода в этот режим следует сохранить издание в HTML-формате, для чего в секции меню «Файл» предусмотрена дополнительная адаптивная команда «Сохранить в формате HTML». Когда документ сохранен в HTML-формате, интерфейс редактора существенно меняется. Это выражается в появлении обновленной панели инструментов, а также в изменении состава команд в большинстве секций меню, в том числе и в секции «Формат». Фрагмент такого интерфейса показан на рис. 4.9 Рис. 04.09.. Приведены для сравнения два списка команд: в режиме DOC и режиме HTML, причем оба смещены вниз, чтобы были видны панели инструментов.

На рис. 4.9 Рис. 04.09. хорошо заметны изменения в панели инструментов «Форматирование». Добавились два инструмента, размещенные правее списка гарнитур. Первый из них (А^) увеличивает на один размер шрифта, а второй (а') - уменьшает, что соответствует действию тегов <SUP> и <SUB>, рассмотренных в § 2.2. В правой части панели «Форматирование» добавлены еще два инструмента, а именно: горизонтальная линия, с помощью которой можно отделить одну часть документа от другой (сравните с тегом <ВР>), и фон, аналогичный действию соответствующей команды, которая будет описана ниже. Для создания фона, как показано в § 2.2, используются параметры тега <BODY>.

Обычно все студенты хорошо запоминают набор команд секции меню «Формат», с которой им чаще всего приходится сталкиваются при создании документов в редакторе Word. Внешний вид этой секции меню, как видно из рис. 4.9 Рис. 04.09., совершенно переменился: вдвое сократилось общее число команд, из прежних сохранились пять: шрифт, список, регистр, фон и стиль, причем и эти сохранившиеся (кроме единственной команды «Регистр») претерпели значительные изменения. Появилась новая команда «Цвета текста», а команда «Рисунок» сменила адаптивную команду «Объект».

Выбор команды «Шрифт» генерирует диалоговое окно с тем же именем, показанное на рис. 4.10 Рис. 04.10.. В режиме редактирования HTML-документа его размеры уменьшились в несколько раз, а число вкладок сократилось с трех до одной. Сократилось до семи и количество различных кеглей (именно таким числом, как отмечалось в § 2.2, ограничивается их разнообразие в HTML-документах) и до шести - количество вариантов шрифтового оформления, что также соответствует возможностям HTML-документов. Наконец, количество цветовых оттенков, считая черный и два варианта серого, в данном случае равно 16.

Значительные изменения претерпело и диалоговое окно «Список», показанное на рис. 4.11 Рис. 04.11.. Оно содержит только две вкладки вместо трех в режиме работы с текстом - вкладка «Многоуровневый список» здесь отсутствует. Три первых маркера соответствуют стандартным для маркированного HTML-списка, все же остальные - это миниатюры из файлов bullet1.gif - bullet8.gif, размещенных в папке MSOffice/Clipart/Bullets. Используя кнопку «Другой» можно преобразовать любой графический файл, имеющийся на данном компьютере, в миниатюру в формате GIF, после чего эта миниатюра может использоваться в качестве графического маркера. Нумерованный список в редакторе полностью соответствует стандартным возможностям формата HTML.

Команда «Цвета текста» позволяет установить различные цветовые оттенки для основного текста, гиперссылок и уже просмотренных указателей ссылок. Соответствующее диалоговое окно представлено на рис. 4.12 Рис. 04.12.. Для выбора цвета во всех случаях используются списковые окна с выводом по умолчанию одной единственной строки. Количество вариантов цвета по-прежнему равно 16, кроме того добавлена позиция «авто», что равнозначно «по умолчанию». Исходно текстовый указатель ссылки, как следует из приведенных на рис. 4.12 Рис. 04.12. данных, выводится синим цветом, а уже просмотренной - фиолетовым. Можно выбрать и любые другие цвета, включая 25% и 50% уровни серого.

Определенный интерес представляет команда «Стиль», позволяющая задать стиль оформления одного или нескольких абзацев HTML-документа. Такой подход соответствует современной концепции оформления HTML-издания, состоящий в более широком использовании тегов логического форматирования текста (см. § 2.1). Вид соответствующего диалогового окна показан на рис. 4.13 Рис. 04.13.. Основная часть диалогового окна занята снабженным слайдером тринадцатистрочным окном списка стилей, который исходно (по умолчанию) включает в себя семь 7 стилей оформления заголовка и еще четырнадцать стилей для оформления тела издания. Справа в окне показан пример оформления текста выбранным стилем (на рис. 4.13 Рис. 04.13. стиль оформления основного текста абзаца).

Для применения стиля к текстовому фрагменту следует выделить этот фрагмент, выбрать нужный стиль и нажать кнопку «Применить». Скажем, для применения стиля к абзацу достаточно поместить в него курсор (не выделяя всего абзаца). Чтобы применить стиль к нескольким абзацам, следует выделить такой фрагмент текста, в который бы входили, хотя бы частично, все эти абзацы. Кнопка «Организатор» в левой нижней части диалогового окна позволяет задать совокупность (набор) стилей для оформления издания. Возможно создание нового, изменение или удаление имеющегося стиля с помощью соответствующих кнопок в нижней части диалогового окна.

Для создания нового или изменения существующего стиля используется специальное диалоговое окно «Создание стиля», показанное на рис. 4.14 Рис. 04.14.. Это окно позволяет назначить совокупность элементов форматирования и шрифтового оформления для любого фрагмента электронного издания и сохранить такой стиль под определенным именем. Стилю можно назначить так называемые «быстрые клавиши» (например, Alt+X), что позволяет обойтись без вызова команд и диалоговых окон, а сразу применить стиль к выбранному фрагменту, нажав эти «быстрые» клавиши. Для назначения «быстрых клавиш» служит кнопка «Клавиша» в правом нижнем углу окна «Создание стиля».

Чтобы включить в состав определенного стиля элементы, необходимые для оформления абзаца, таблицы или списка используется кнопка «Формат». Нажав на нее, мы получим выпадающее меню, показанное в нижней части рис. 4.14 Рис. 04.14., которое позволяет обратится к нужной команде, установить параметры в соответствующем диалоговом окне и автоматически возвратиться в окно «Создание стиля». В завершении нажимаем кнопку «ОК» и получаем дополнительный стиль, имя которого уже включено в список стилей, показанный в окне на рис. 4.13 Рис. 04.13..

Еще одна команда в секции меню «Формат», а именно «Фон», предназначена для формирования фона HTML-издания, причем фон может быть задан как в форме тонирования, так и рисунка. При активизации этой команды генерируется цветовая палитра, представленная на рис. 4.15 Рис. 04.15.. Если пользователя не устраивает ни один из 40 цветов, представленных в палитре, он может вызвать дополнительные цвета, щелкнув по соответствующей надписи в диалоговом окне. В результате получим новое диалоговое окно «Цвета», содержащее две вкладки: «Обычные» и «Спектр», показанные на рис. 4.16 Рис. 04.16..

На вкладке «Обычные» представлен дискретный набор из 137 цветовых оттенков, сформированный в форме правильного шестиугольника,

заполненного малыми шестиугольниками различных цветовых тонов. На вкладке «Спектр» использована аналоговая системная цветовая палитра Windows. В такой палитре можно выбрать практически любой цветовой оттенок. Если пользователю известны координаты цвета в цветовом представлении RGB или MSB (Hue-Saturation-Brightness, или Цветовой тон - Насыщенность - Яркость), то эти координаты могут быть непосредственно заданы в триадах окон малого размера с помощью счетчиков или путем непосредственного ввода значений координат цвета.

Команда «Способы заливки» в «Палитре цветов» на рис. 4.15 Рис. 04.15. инициирует появление диалогового окна «Заливка», представленного на рис. 4.17 Рис. 04.17.. В этом окне в форме списка представлен набор из 24 образцов различных текстур, 12 из которых видны на рисунке. Эти текстуры могут использоваться в качестве фона электронного издания в целом или его отдельных фрагментов. С помощью кнопки «Другая текстура» можно любой графический файл автоматически преобразовать в текстурный, включив его в состав текстур палитры «Заливка». Отметим, что текстуры очень часто используются для улучшения внешнего вида электронных изданий и Web-страниц.

Последняя команда секции меню «Формат» - «Рисунок», активизируется только в том случае, если в составе документа выделен какой-нибудь рисунок. Команда активизирует одноименное диалоговое окно, состоящее из двух вкладок (рис. 4.18 Рис. 04.18.). Первая из них описывает параметры рисунка, в том числе - путь к рисунку, по умолчанию -относительный. Однако если задействовать опцию «Использовать абсолютный путь», то расположение рисунка будет задаваться полностью (абсолютно), а не относительно папки, в которой размещен файл редактируемого документа. Имеется также возможность ввода альтернативного текста в поле «Пустая рамка вместо рисунка» в тех случаях, когда загрузка рисунка не производится (см. также описание использования параметра ALT в теге <IMG> в разделе 2.4).

Во вкладке «Положение» диалогового окна «Рисунок» задается выравнивание рисунка и его расстояние от текста, т. е. те параметры тега <IMG>, которые не были определены в предыдущей вкладке. Как следует из рис. 4.18 Рис. 04.18., в редакторе возможны три варианта выравнивания рисунка: в строку (как элемент строки), вправо и влево. Как уже упоминалось в разделе 2.4, автор не является сторонником выравнивания рисунков в строку, так как это противоречит принципам дизайна изданий. Выравнивание же полевой или правой границе определяет оборочный формат иллюстрации, естественный как для текстового, так и для электронного издания. Задание вокруг рисунка осветленного пространства способствует его лучшему выделению в тексте, таким образом, поле «Расстояние от текста» во вкладке «Положение» позволяет улучшить дизайн электронного издания.

4.3.2.
Команды секции меню «Вставка»

Перейдем к командам секции меню «Вставка». Для сравнения на рис. 4.19 Рис. 04.19. представлены команды этой секции при работе редактора с изданиями в ООС - (слева) и HTML-форматах. Сравнение показывает, что в формате HTML отсутствуют команды «Разрыв», «Номера страниц», «Поле», «Примечание», «Сноска», «Название», «Перекрестная ссылка», «Оглавление и указатели», и «Надпись». В то же время при работе с HTML-документами появляется ряд новых команд: «Горизонтальная линия», «Видеоклип», «Фоновый звук», «Формы» и «Бегущая строка».

Все исключенные команды действительно не нужны для редактирования HTML-изданий, поэтому остановимся лишь на роли дополнительных команд. Так, команда «Горизонтальная линия» (и одноименный инструмент в панели «Форматирование») подобно тегу <ВР> реализует специальный вид форматирования и дизайна электронного издания, отделяя, подобно типографской линейке, различные фрагменты документа друг от друга. Предусмотрено несколько различных видов таких горизонтальных линий или линеек (см. рис. 4.20 Рис. 04.20.). Любую из этих линий можно вставить в документ, и если не злоупотреблять их количеством и разновидностями, то издание от этого только выиграет. Если представленного разнообразия линеек пользователю недостаточно, то можно, нажав на кнопку «Другая», получить дополнительные рисованные линейки, соответствующие которым изображения хранятся в папке CLIPART/LINES в каталоге MSOffice.

Далее остановимся на команде «Видеоклип». Она позволяет включить цифровой видеоклип в состав редактируемого издания. Диалоговое окно для этой команды представлено на рис. 4.21 Рис. 04.21.. Место вставки видеоклипа в электронное издание указывается с помощью миниатюры, напоминающей телевизор. На рис. 4.21 Рис. 04.21. она находится в самом начале документа, перед его заголовком. Диалоговое окно «Видеоклип» состоит из двух фрагментов: «Источник» и «Параметры воспроизведения». В первом из них с помощью двух списковых структур задается расположение файла видеоклипа и файла рисунка для его замены. В обоих случаях предусмотрены кнопки «Обзор», позволяющие просматривать всю структуру файлов на компьютере и находить нужные файлы. Ниже расположена строка, в которую вводится альтернативный текст для замены видеоклипа на тех компьютерах, где не предусмотрены средства для их воспроизведения.

Во фрагменте «Параметры воспроизведения» заданы две списковые структуры, в каждой из которых, как и в верхнем фрагменте, по умолчанию отображается одна строка, и три опции. Первый список определяет время начала воспроизведения: при открытии, щелчке мышью или обоими способами, а второй - число повторов при воспроизведении. Здесь же показаны две задействованные опции: «Отображать кнопки управления» и «Использовать относительные пути», причем вторая относится к способу задания видеоклипа и рисунка для его замены. Первая же опция позволяет разместить кнопки управления на экране и использовать их для управления видеоклипом. Опция «копировать в папку с документами» позволяет автоматически переместить указанные выше файлы в ту же папку, где находится само электронное издание (в примере эта опция не задействована).

Команда «Фоновый звук», как показано на рис. 4.22 Рис. 04.22., состоит из трех подкоманд, первая из них генерирует диалоговое окно, используемое для установки параметров этого звука, а две другие обеспечивают воспроизведение звука и его прекращение. Диалоговое окно «Фоновый звук» также представлено на рис. 4.22 Рис. 04.22.. В нем с помощью списковой структуры «Звукозапись» задается абсолютный или относительный путь к соответствующему файлу, а аналогичная структура под названием «Число повторов» задает это значение в пределах от единицы до бесконечности. Путь к нужному файлу может быть определен с помощью кнопки «Обзор», действие которой подобно ранее рассмотренному. В диалоговом окне активизирована опция «Использовать относительный путь» и отключена «Копировать в папку с документами», которые аналогичны показанным на рис. 4.21 Рис. 04.21..

Следующая команда - «Формы» - предназначается для встраивания в издание HTML-форм, которые могут использоваться для тестирования или получения отзывов и замечаний от читателей с последующей автоматической их обработкой. Активизация этой команды приводит к появлению многочисленных ее подкоманд, с помощью которых определяются разновидности форм, описанных в разделе 2.9. По-существу, это встроенный в пакет мощный конструктор форм. Интерфейс конструктора представлен на рис. 4.23 Рис. 04.23..

Каждая из подкоманд определяет создание определенного элемента формы, причем пиктограмма полностью характеризует тип этого элемента. Вначале следуют подкоманды, соответствующие тегу <INPUT> с параметрами CHECKBOX (флажок) и RADIO (переключатель), следующая пара соответствует тегу <SELECT>, подкоманда «Поле» соответствует параметру TEXT в теге <INPUT>, «Область ввода» - тегу <TEXTAREA>, кнопки соответствуют одноименным параметрам SUBMIT (переслать на сервер содержимое формы) и RESET (кнопка сброса) тега <INPUT>, а параметрам HIDDEN и PASSWORD для ввода соответствующих разновидностей текста же тега соответствуют две последние подкоманды.

Следует отметить, что помимо средств для изменения размеров форм, предусмотренных в оболочке Windows, в редакторе имеется адаптивное диалоговое окно «Свойства», параметры которого изменяются в зависимости от вида формы и в котором также можно регулировать параметры формы. В качестве примера на рис. 4.24 Рис. 04.24. показана форма «Область ввода» и соответствующее ей диалоговое окно «Свойства». В окне видно, что используется тег <TEXTAREA> и указаны его параметры, а в самой форме в нижней части рисунка вводится в окно нужный текст. Видимая область формы содержит 4 строки и 30 колонок и снабжена окном прокрутки. Списковая структура в верхней части диалогового окна позволяет выбрать любой другой вид формы, в соответствии с чем перестраиваются и остальные области окна «Свойства».

Последняя подкоманда, на которой следует остановиться - это «Бегущая строка», которая часто используется в дизайне Web-страниц и многократно реже в других электронных изданиях. Команде соответствует диалоговое окно, приведенное на рис. 4.25 Рис. 04.25.. В верхней части окна с помощью 4-х списковых структур выбирается из нескольких вариантов характер и направление движения, цвет фона (в примере - желтый) и число повторов. В окне предусмотрена специальная линейка для регулировки скорости перемещения строки. Ниже в специальном окне, вводится текст бегущей строки, а еще ниже, в окне «Образец», демонстрируется пример движущейся строки с заданными пользователем параметрами.

Из других особенностей работы Word 97 в режиме редактора HTML-документа отметим возможность просмотра подготовленного издания в браузере при активизации команды Файл/Просмотр Web-страницы, а также возможность просмотра и редактирования исходного HTML-кода с помощью команды Вид/Источник HTML. Обе эти секции меню и соответствующие команды представлены на рис. 4.26 Рис. 04.26.. В частности, при активизации команды «Источник HTML» вновь изменяется интерфейс редактора, причем остается только одна единственная панель инструментов. Это хорошо видно на рис. 4.27 Рис. 04.27.. В качестве примера выбран электронный документ, в теле которого один фрагмент, бегущая строка с желтым фоном, текст в которой синего цвета и перемещается слева направо. Движение текста происходит в окне насквозь, а количество повторов бесконечно велико. Все это было ранее установлено в диалоговом окне, показанном на рис. 4.25 Рис. 04.25..

В режиме редактирования исходного HTML-кода мы можем «вручную» вставлять в документ любые теги, т. е. в этом режиме Word 97 работает уже как редактор первой группы (см. классификацию в разделе 4.1). Именно по этой причине, секция меню «Формат» вообще отсутствует, а в секции меню «Вставка» содержится всего 3 команды: «Дата и время», «Автотекст» и «Файл», которые имеют смысл в режиме работы с исходным кодом. На панели инструментов появилась специальная кнопка «Закрыть источник HTML», при нажатии на которую мы возвратимся к редактированию HTML-издания в режиме WYSIWYG, в котором, как уже было отмечено ранее, Word 97 работает как редактор второй группы.

В той же секции меню «Вид» командой «Режим конструктора» можно вывести в окне документа конструктор HTML-форм в виде набора инструментов, полностью совпадающего с подкомандами команды «Формы», включая тождественность всех используемых для обозначения инструментов пиктограмм.

Таким образом, Word 97 представляет собой, помимо редактора текстов, еще и удобный универсальный HTML-редактор, а его широкое распространение в нашей стране определяет возможность его массового использования именно в этом качестве. Кстати, отметим, что версия Word 2000 в составе MSOffice 2000, лишена многих возможностей предыдущей версии, относящихся именно к редактированию HTML-документов. Однако эта его особенность компенсируется тесной интеграцией Word 2000 с редактором мультимедиа-изданий FrontPage 2000. Пакет FrontPage будет рассмотрен в главе 6.

4.4.
Общая характеристика типовых HTML-редакторов первой группы

Выше уже отмечалось, что HTML-редакторы HTML-редакторы делятся на две группы. К первой относятся WYSIWYG-редакторы, автоматически формирующие соответствующий HTML-код. Они наиболее пригодны для пользователей, которые слабо знакомы с языком HTML и не являются профессиональными дизайнерами электронных изданий. Вторая группа - это HTML-редакторы для профессионалов, предпочитающих самостоятельно создавать исходный HTML-код.

Причина, по которой профессиональные разработчики HTML-изданий и Web-документов неохотно используют WYSIWYG-редакторы, состоит в том, что большинство браузеров, в том числе и ведущие Web-браузеры Netscape Navigator и Microsoft Internet Explorer, по-разному интерпретируют некоторые стандарты HTML и Web, принятые консорциумом World Wide Web (W3C) World Wide Web (W3C) или находящиеся на стадии рассмотрения и утверждения. Например, язык стилей (Cascading Style Sheets) CSS1 был утвержден в качестве стандарта в 1996 г. Однако Internet Explorer 4.0 поддерживает только 80% функций CSS1, a Netscape Navigator4.0 -еще меньше. Новейшие технологии, такие как HTML 4.0, Dynamic HTML, вторая версия языка стилей CSS2, JavaScript и другие, не полностью поддерживаются даже последними версиями указанных выше браузеров.

По мнению ряда специалистов в области издательских технологий, большинство WYSIWYG-редаторов (Adobe PageMill, Microsoft FrontPage и др.) при генерации HTML-кода добавляют много лишнего, например специализированные теги, ненужные метатеги и пробелы. Даже непрофессиональный редактор этой группы Word 97 (в режиме редактирования HTML-изданий), как легко убедиться, взглянув на рис. 4.27 Рис. 04.27., страдает таким дефектом. В дальнейшем эту избыточность приходится подчищать вручную в текстовом редакторе, что требует дополнительных усилий и времени. Таким образом, главным недостатком WYSIWYG-редакторов следует считать то обстоятельство, что разработчик не имеет полного контроля над HTML-кодом подготавливаемого электронного издания.

Для таких специалистов более приемлемы технологии, связанные с использованием профессиональных редакторов первой группы в многооконном режиме работы, причем в одном из окон открывается сам редактор тегов (или текстовый редактор), в других окнах открываются нужные браузеры, воспроизводящие создаваемое электронное издание и позволяющие непосредственно, оперативно отслеживать результаты работы над изданием. Несколько окон позволяют следить также за особенностями отображения некоторых конструкций языка HTML в различных браузерах.

Разработчики электронных изданий создали общественную организацию Web Standards Project, которая требует поддержки Web-стандартов всеми браузерами. Фирмы Microsoft Microsoft и Netscape Netscape выражают готовность к обеспечению совместимости с основными Web-технологиями, но не торопятся выполнять эти обещания. А пока ситуация не изменилась, разработчикам приходится отказываться от применения простых и удобных WYSIWYG-редакторов в пользу специальных средств, предусматривающих возможность ручного HTML-кодирования. Далее остановимся кратко на характеристиках распространенных HTML-редакторов первой группы.

Когда фирма Sausage Software Sausage Software (Австралия) выпустила HotDog, этот продукт почти сразу завоевал лидирующее положение среди HTML-редакторов своей группы. Его четвертая версия помимо собственно HTML-редактора, предназначенного для ручного кодирования, содержит целый ряд дополнительных инструментов (WYSIWYG-редактор, средства администрирования и пр.), которые слабо связаны с основным его модулем. К счастью, в пятой версии эти недостатки были устранены, и HotDog стал вполне зрелым и развитым средством разработки электронных изданий.

Современную версию редактора HotDog 5.1 вполне оправданно можно считать наиболее простым и адаптивным к уровню знаний пользователя редактором этой группы. Адрес для загрузки пробной версии: www.sausage.com. После первого запуска редактор запрашивает, насколько хорошо пользователь знаком с языком HTML. Выбрав один из трех возможных уровней, а именно Beginner (начальный уровень), Intermediate (промежуточный уровень) или Hardcore (верхний уровень), можно сразу начинать работу.

Интерфейс уровня Beginner превращает редактор в наставника, подробно и терпеливо объясняющего суть многочисленных функций и режимов редактора. Это тем более важно, поскольку в новой версии появилось немало функций, для освоения которых требуется время. Более опытные пользователи могут пропустить этап обучения, выбрав интерфейс одного из двух оставшихся уровней.

Главное окно редактора HotDog содержит линейки инструментов и встроенных функций, которые предназначены для вызова программ-мастеров, макросов и других вспомогательных утилит, облегчающих разметку текста и создание тегов. В главном окне имеется область предварительного просмотра ROVER (Real-time Output ViewER), в которой встроенный браузер динамически воспроизводит создаваемый документе процессе его редактирования.

Главное окно можно настраивать. Например, разработчик способен свернуть окно просмотра и работать только в окне редактирования, или, наоборот, раскрыть область просмотра на весь экран, или динамично переключаться между этими двумя режимами, причем редактор запоминает настройку главного окна, выбранную для каждого документа. Кроме того, предусмотрены средства настройки, которые позволяют строить страницы для экранов различного разрешения, а также выводят линейки, помогающие выравнивать отдельные элементы страницы. Чтобы удобнее переключаться между разными частями документа, можно использовать закладки. К сожалению, закладки не сохраняются после окончания сеанса работы с редактором.

Уникальной особенностью HotDog является функция фильтрации тегов. Нажав на кнопку Tag Filter, пользователь открывает окно, содержащее массу полезных сведений: список всех спецификаций языка HTML (от версии 2.0 до 4.0), специализированные теги, события языка JavaScript и пр. Достаточно выбрать мышью нужные технологии или версии HTML, и редактор подсветит все несовместимые с ними теги красным цветом, указывая на синтаксические ошибки. Это очень удобная функция, которая облегчает работу с вариантами HTML. При выделении тега мышью появится всплывающая подсказка, которая содержит объяснение действий, выполняемых данным тегом, а также окно с перечнем всех допустимых параметров и возможных окончаний тега.

Модуль Website поддерживает коллективную работу в редакторе. Пользователи могут работать с различными элементами изданий, не задумываясь об их объединении. HotDog автоматически интегрирует все использованные в издании элементы. Для ускоренного редактирования параметров тегов предусмотрена функция Property Sheet, открывающая на экране окно с описанием параметров каждого тега. С помощью данной функции можно также создавать макросы и клавиши быстрого вызова для любых тегов. Имеются и средства оптимизации, ускоряющие загрузку Web-страниц. Например, функция Bandwidth Buster не только определяет, сколько времени будет загружаться какая-либо Web-страница, но и автоматически преобразует ее графику в формат, более удобный для использования в Web.

Из других средств поддержки можно отметить редактор кнопок (Button Editor), который позволяет накладывать текст на кнопки и добавлять к ним некоторые специальные эффекты. Хорошо организованы редакторы таблиц и форм, имеются конвертеры для преобразования звука и изображения в форматы потокового видео и аудио RealAudio и RealVideo. В редакторе тщательно проработаны даже второстепенные функции, например выбирая цвет для фрагментов страницы, пользователь может выделить область в любой части экрана, увеличить ее и с помощью виртуальной пипетки подобрать оттенок. Редактор автоматически найдет наиболее близкий цвет в палитре браузера.

Помимо HTML-редактора HotDog включает в себя ряд полезных дополнительных продуктов: графический редактор Paint Shop Pro, программу I nteractor для работы с языком Dynamic HTML, утилиту проверки гиперсвязей Linkbot, а также интегрируемые модули (plug-in) SuperTool, выполняющие различные дополнительные функции.

Пользовательский интерфейс HotDog отличается чрезвычайно высокой гибкостью. Можно настраивать практически все его элементы. Однако интерфейс перегружен инструментальными линейками, поэтому открывается довольно медленно. Каждая вызываемая функция открывает свое окно, и экран оказывается слишком переполненным. Пользователь должен тщательно настроить среду разработки, чтобы главное окно редактирования оказалось над инструментальными линейками и всплывающими окнами.

По разнообразию функциональных возможностей редактор WebEdit несколько отстает от HotDog, однако содержит практически все основные средства, которые требуются профессиональному разработчику электронных изданий, и отличается удобным и простым интерфейсом. Пользовательский интерфейс еще более напоминает Microsoft Word - те же инструментальные линейки, расположенные между строкой меню и рабочим окном программы. Хотя инструментальные линейки нельзя настраивать, их можно перегруппировывать по своему усмотрению и даже превратить в «плавающие» палитры.

Одна из инструментальных линеек редактора представляет собой набор раскрывающихся списков, содержащих теги и вспомогательные функции. Так, при нажатии кнопки Font появится список всех доступных шрифтов, а щелчок по кнопке Table запустит утилиту создания таблиц Таblе Builder. С помощью кнопки Custom разработчик может добавлять собственные теги, а редактор автоматически сопоставит с этими тегами быстрые клавиши. Выбор любого тега вызывает диалоговое окно, содержащее подробную информацию о теге, а также о браузерах и версиях HTML, которые его поддерживают.

WebEdit выполняет контроль синтаксических ошибок, поддерживающий HTML 4.O. Многочисленные функции-мастера помогают создавать фреймы и формы в режиме WYSIWIG, проверять гиперсвязи, составлять оглавления, импортировать в таблицы информацию из баз данных, добавлять к электронному изданию мультимедийные элементы (звук, видео, сценарии на языке JavaScript, анимацию и т. д.).

Однако основной документ с фреймами и документы в каждом фрейме нужно открывать и редактировать в отдельных окнах, что не очень удобно. Однако это неудобство в некоторой степени компенсируется тем, что WebEdit - единственный из HTML-редакторов, который позволяет предварительно просматривать совокупности фреймов и страницы с фреймами в главном окне браузера.

Для коллективной работы предназначен модуль управления проектами Project, а для публикации Web-страниц на Web-сервере служит программа Web Publishing Wizard компании Microsoft Microsoft. Кроме того, имеется встроенный FTP-клиент, облегчающий работу с удаленным Web-сервером. К сожалению, встроенная программа предварительного просмотра создаваемых Web-страниц поддерживает только HTML 2.0, нос WebEdit можно интегрировать Microsoft Internet Explorer 3.01 (или более старшую версию), а затем использовать ее в качестве встроенного браузера.

WebEdit Pro представляет собой компактный редактор, не перегруженный лишними функциями, пробную версию которого можно загрузить с сайта www.softseek.com.

Редактор HomeSite появился на рынке в 1996 г. как условно бесплатный (shareware) продукт и быстро завоевал успех у разработчиков, создающих Web-страницы на платформе Windows. С самого начала этот редактор был ориентирован только на профессионалов, хорошо знакомых с Web-технологиями, что отличало его от большинства других средств разработки Web-страниц.

В ноябре 1998 г. в продажу поступила четвертая версия данного HTML-редактора, которая открывает разработчикам доступ к новейшим Web-технологиям, таким как Dynamic HTML (DHTML), Cascading Style Sheets (CSS), Perl и JavaScript. Из ряда других профессиональных средств подготовки Web-страниц система выделяется наличием визуальной среды разработки, которая обеспечивает целостность кода, благодаря чему повышается производительность программистов, создающих и обновляющих Web-узлы. Разработчики могут быстро переключаться между тремя режимами:

  • ручное кодирование на языках HTML, DHTML, SMIL, Perl и JavaScript (режим Edit View);

  • работа в визуальной среде разработки (режим Design View);

  • просмотр Web-страниц с помощью браузера (режим Browse View).

Процессы создания и редактирования HTML-кода и сценариев ускоряются за счет использования новых функций, которые появились в четвертой версии HomeSite. Библиотека определений тегов Tag Definition Library позволяет редактировать существующие теги и добавлять новые.

Когда разработчик вводит код, на экране возникает окно подсказки Tag Completion, содержащее допустимые параметры вводимого тега (пользователь может его и отключить). Новая функция Site View, вызываемая через окно Resource Bar, графически показывает иерархическую структуру всего создаваемого Web-узла (включая Web-страницы и другие элементы), а опция Tag Inspector открывает быстрый доступ ко всем параметрам выбранного тега.

В HomeSite 4.0 предусмотрено множество клавиш быстрого вызова функций и тегов, но если разработчику их не хватает, он может задавать свои собственные комбинации клавиш, что значительно повышает гибкость среды разработки. Существует дополнительная возможность приписывать быстрые клавиши шаблонам и автоматизировать работу программиста. Пользователю достаточно создать шаблоны, сопоставить их с определенными тегами, ввести шаблоны в нужные места, а затем нажимать Ctrl-J - и все шаблоны автоматически заменяются на соответствующие коды. Это существенно ускоряет разработку и автоматизирует процесс разработки. Для создания сложных элементов в HomeSite предусмотрены программы-мастера.

Пользовательский интерфейс редактора HomeSite можно настраивать в зависимости от потребностей, превращая то в простое окно редактирования, то в развитую среду разработки. Для этого предусмотрено множество вспомогательных панелей, таких как встроенное окно предварительного просмотра, списки локальных файлов (со всплывающими списками часто используемых папок), перечни файлов удаленного доступа, которые можно считывать с удаленного сервера и редактировать их. Кроме того, имеется панель, содержащая миниатюрные изображения создаваемых Web-страниц, которые можно буксировать в окно редактирования.

Для разработчиков, предпочитающих режим WISIWYG, в четвертой версии HomeSite предусмотрен режим Design View. В нем можно буксировать объекты из одной ячейки таблицы в другую, выравнивать объекты, менять шрифты, готовить формы и выполнять другие действия визуального программирования с автоматическим формированием HTML-кода. Однако чтобы воспользоваться этим режимом, необходимо предварительно установить браузер MS Internet Explorer.

Российские разработчики Web-узлов по достоинству оценили HomeSite. Многим нравится то, что редактор окрашивает теги в разные цвета в зависимости от их принадлежности к той или иной группе, а также возможность удаленного доступа к любому Web-узлу и автоматической проверки ссылок. Эксперты информационных служб ZdNet, WebWeek и CNet, независимо друг от друга проводившие сравнения различных продуктов, назвали HomeSite 4.0 лучшим HTML-редактором для профессионалов.

Автор остановился только на самых распространенных типовых редакторах первой группы, чтобы дать возможность читателям ориентироваться во всем их разнообразии и самостоятельно выбирать пригодный для решения конкретной задачи, поставленной перед ними. Кстати, разнообразную информацию о редакторе тегов HotDog и его многочисленных версиях можно получить на сайте фирмы Sausage Software, внешний вид которого представлен на рис. 4.28 Рис. 04.28..

4.5.
Общая характеристика WYSIWYG-редактора Netscape Composer

Большинство пользователей хорошо знают браузер Netscape Communicator, но гораздо меньшая их часть знакома с мощным профессиональным редактором Composer из пакета Netscape Communicator. Нам представляется, что этот редактор можно назвать типичным представителем второй группы, т. е. WYSIWYG-редакторов.

Его интерфейс показан на рис. 4.29 Рис. 04.29.. На нем видны секции меню и две панели инструментов: Composition Toolbar (инструменты для создания чего-либо) и Formatting Toolbar (панель форматирования).

Кстати, перейти в режим редактирования с помощью Composer'a можно и из главного меню пакета - меню Communicator'a, выбрав в секции меню File команду New, а в ней - Blank Page (чистая страница). Соответствующее меню показано на рис. 4.30 Рис. 04.30..

Секции меню пакета похожи на те, которые используются в редакторе Word 97 для работы с HTML-документами за исключением двух дополнительных: «Tools» (инструменты) и Communicator, причем последняя позволяет перейти к другим программам пакета Communicator. Секция Tools генерирует дополнительные инструменты, с помощью которых можно осуществить проверку орфографии, вставить в документ специальные символы, редактировать HTML-код и изменить используемые в таблице разделители.

Вообще, обширный набор инструментов является важным достоинством данного редактора. Для вывода панелей инструментов используется команда «Show» секции меню View, которая показана на рис. 4.31 Рис. 04.31.. Всего могут быть вызваны четыре таких панели: Composition Toolbar, Formatting Toolbar, Floating Component Bar и Paragraph Marks. Так, создание и открытие документов может выполняться кнопками «New» и «Open» панели Composition Toolbar, с помощью кнопок «Preview» и «Print» можно просмотреть электронный документ и затем распечатать его, кнопка «Publish» позволяет выполнить сложную операцию, а именно, опубликовать электронный документ на определенном сайте. Инструменты позволят установить связи (Links) с другими файлами, а также включить в состав электронного издания рисунок (Image), горизонтальную линию (Н.Line), таблицу (Table) и провести проверку (Spelling) подготовленного издания.

Наконец, с помощью инструмента «Target» создаются внутри электронного издания указатели входа в документ, т. е. что-то вроде закладок, на которые можно переходить, используя гипертекстовые ссылки. В частности, можно отметить заголовки разделов внутри документа, а в его начале создать оглавление, содержащее гипертекстовые ссылки на эти закладки. Composer легко создает различные закладки. Установив текстовый курсор в нужное место, следует нажать кнопку «Target». Composer выведет диалоговое окно, в котором следует назвать закладку. После этого в назначенном месте появится маленький значок с малиновой стрелкой - место входа в документ. Теперь на это место можно ссылаться из любых позиций по мере надобности.

Широкие возможности представляют и команды меню. Практически эти команды и контекстные меню, о которых мы поговорим позднее, дублируют действие всех инструментов. Ряд команд секции «Format» напоминают команды секции «Формат» редактора Word 97, однако, как следует из рис. 4.32 Рис. 04.32., имеются и дополнительные возможности. Первые две команды в нем выполняют ту же роль, что и «Шрифт» в редакторе Word.

Прежнюю роль выполняют команды «Style» и «Color», хотя оформление диалогового окна «Color» в Composer'e заметно отличается (см. рис. 4.33 Рис. 04.33.). На этих отличиях остановимся подробнее. На рис. 4.33 Рис. 04.33. показано две палитры. Первая (вверху) - это палитра цветов, используемая по умолчанию в браузере Netscape Communicator, и именно отображение этих цветов без искажения гарантируется в браузере. Однако если их разнообразие не удовлетворяет дизайнера HTML-издания, он может, нажав на кнопку «Other» (другие), вызвать обширную цветовую палитру, показанную в нижней части рисунка.

Это стандартная цветовая палитра оболочки Windows (в данном случае версии 1998 г.). Наряду с набором основных и дополнительных цветов в ней присутствует аналоговый фрагмент, который позволяет выбрать любой цветовой оттенок непосредственно на цветовой плоскости или же задать этот оттенок с помощью цветовых координат в формате HSB (Оттенок - Насыщенность - Яркость) или RGB (Красный - зеленый - синий), непосредственно вводя значения координат в соответствующие строки. На рис. 4.33 Рис. 04.33. координаты цвета составляют: Н=40, 5=240 и В=24.

Более широкие возможности по сравнению с рассмотренной в предыдущем параграфе обеспечивает команда «List» («Список»). В ней наряду с маркированным (Bulleted) и нумерованным (Numbered) списками, а также списком определений (Description) имеются еще и две другие команды: «Directory»n «Menu», как это показано на рис. 4.34 Рис. 04.34.. Если первые три команды соответствуют вариантам списков, рассмотренных во второй главе, то последние две команды обеспечивают организацию списков типа «Каталог» и «Меню». Для отмены любого варианта списка применяется команда «None».

Команда «Paragraph» («Абзац») иллюстрируется рис. 4.35 Рис. 04.35.. Она позволяет оформить выделенный фрагмент как Normal в соответствии с одноименным стилем, Address, т. е. ссылочный адрес, Formatted, т. е. форматированный, «Blockquote», т. е. цитата, Description Title, т. е. заголовок описания, и Description Text, т. е. текст описания.

Другие команды дополняют и упрощают возможности оформления электронного издания. Так, команды «Increase Indent» и «Decrease Indent» позволяют увеличить или уменьшить отступ на фиксированную величину. Кстати, эти же операции могут быть реализованы и с помощью соответствующих инструментов палитры «Formatting Tools» (аналогичные средства предусмотрены и в редакторе Word). Команда «Align» позволяет выровнять выделенный фрагмент влево, по центру и вправо. Дополнительная команда «Heading» позволяет оформить выделенный фрагмент как заголовок определенного уровня в теле HTML-документа.

В заключение остановимся на использовании контекстных меню в этом редакторе, которые созвучны последней группе команд секции «Format». На рис. 4.36 Рис. 04.36. показан пример начального контекстного меню, т. е. меню, созданного в рабочем окне редактора при щелчке правой кнопкой мыши вне зоны текста. В нем содержатся команды «Character Properties» (свойства шрифтовых элементов), «Paragraph/List Properties» (свойства абзаца или списка, в зависимости оттого, какой выбран фрагмент документа), «Page Properties» (свойства страницы). Каждой команде соответствует свое диалоговое окно.

Например, первой команде соответствует диалоговое окно, показанное на рис. 4.37 Рис. 04.37.. В нем три вкладки: основная - Character, а также Link и Paragraph. В первой вкладке задается гарнитура, кегль, цвет и оформление шрифтовых элементов. Указатель мыши был подведен к окну цвета, поэтому на рисунке видна рамка с соответствующими черному цвету значениями цветовых координат в формате RGB и запись этих же координат в HTML-коде. Две другие вкладки в данном диалоговом окне позволяют оформить фрагмент текста как указатель ссылки, а также оформить соответствующим образом абзац, содержащий данный фрагмент текста.

Рассмотрим также диалоговое окно Page Properties, представленное на рис. 4.38 Рис. 04.38.. Его основная вкладка General, которая активна на этом рисунке, позволяет задать местоположение (электронный адрес или размещение в файловой системе) и атрибуты создаваемого электронного документа, такие как наименование документа и его автор, а также набор ключевых слов, характеризующий этот документ, и его классификационные характеристики. По-существу, это та информация, которая размещается в теге-контейнере <HEAD> HTML-издания. Другие вкладки позволяют определить цветовой фон и многие прочие элементы, используемые при оформлении страниц (цветовое оформление текстовых элементов и фона издания), а также просмотреть запись исходного кода заголовочной части документа, иначе - просмотреть теги метаинформации или атрибутов издания.

В заключение хочется отметить, что хотя материал этого параграфа не претендует на исчерпывающее описание HTML-редактора Netscape Composer, но содержит достаточно информации, чтобы оценить высокие профессиональные качества и возможности этого редактора, которые несомненно шире, чем у рассмотренного ранее текстового редактора Word 97 в режиме HTML-редактора.

4.6.
Подготовка документов в PDF-формате

Выше уже отмечалась возможность непосредственного сохранения сверстанных изданий в PDF (Portable Document Format) формате PDF, для чего в верстальных пакетах предусмотрены специальные модули-конвертеры. В частности, в пакете PageMaker 6.5 в секции меню «Файл» предусмотрена команда «Экспортировать» и подкоманда «Adobe PDF». Это иллюстрируется фрагментом интерфейса пакета, представленного на рис. 4.39 Рис. 04.39.. Кстати, на том же рис. 4.39 Рис. 04.39. видна палитра «Гиперсвязи», позволяющая организовать систему ссылок и переходов в издании. Эта же палитра позволяет включить в электронное издание в PDF-формате ссылки на аудио- и видеофайлы, т. е. сделать это издание мультимедийным.

Исходно PDF-формат был предложен фирмой Adobe Systems Adobe как платформно-независимый для создания электронных документов, презентаций, а также передачи сверстанных документов и графиков по сетям. Первая строка файла представляет собой запись вида: %PDF-<# версии>. Остальной файл - это последовательность пронумерованных объектов. В конце файла находится таблица перекрестных ссылок, позволяющая загрузившему файл приложению локализовать любой объект файла, каждый из которых имеет свой номер. Приложение начинает чтение фа ила сего конца, где находится указание на местоположение таблицы ссылок и так называемого «корневого объекта», в котором содержатся ссылки на все объекты в документе, в том числе: план издания, резюме, отдельные его страницы.

Такая структура позволяет загружать любой из объектов файла, не загружая весь файл целиком. Она же позволяет редактировать любой объект файла, добавляя его исправленный вариант в конец файла и создавая на него новую ссылку в таблице перекрестных ссылок. Можно разбить таблицу перекрестных ссылок на несколько частей так, чтобы свежие варианты ссылок заменяли устаревшие.

Формат PDF целесообразно использовать именно в тех случаях, когда необходимо сохранить точное форматирование документа. Именно поэтому многие фирмы хранят в формате PDF электронную документацию своей продукции, предоставляя доступ к ней заказчикам или же распечатывая ее при необходимости. Некоторые издательства, специализирующиеся на электронных изданиях и печати по заказу, также хранят издания в этом формате. Дополнительным достоинством PDF-файлов является возможность их эффективного сжатия, что облегчает их перенос и передачу по сетям.

В то же время для публикаций в системе World Wide Web формат PDF не нашел широкого применения вследствие жесткой физической разметки соответствующего издания. Файлы в этом формате не могут заново форматироваться в соответствии с требованиями различных устройств вывода данных. Например, документ может не поместиться по горизонтали на экране с низким разрешением, что чрезвычайно затруднит его чтение. Конечно, система логической разметки документа, которая позволяет без труда переформатировать документ в соответствии с требованиями устройства вывода, в таких случаях предпочтительнее. Разнообразная дополнительная информация о PDF-файлах и бесплатные программные средства для создания таких файлов и их просмотра, в частности, различные версии редактора Acrobat, имеются на сервере фирмы Adobe (www.adobe.com). Относительно новая продукция фирмы - редактор Acrobat Reader 4.0 - обладает рядом дополнительных свойств: возможностью создавать PDF-файлы из любых приложений, создавать аннотации для таких файлов, а также отправлять их адресату по электронной почте. Сказанное иллюстрируется данными, представленными на рис. 4.40 Рис. 04.40..

Одностраничные файлы PDF-формата могут создаваться в графических пакетах Illustrator и PhotoShop, причем достаточно высокого качества. Многостраничные документы в формате PDF кроме верстальных пакетов могут создаваться в программах Adobe Acrobat Exchange, InDesidn, PDFWriter и Acrobat Distiller. Кратко остановимся на возможностях и особенностях этих программ.

Программа InDesidn вносит небольшие искажения цвета при преобразовании рисунков с RGB цветовым представлением в цветовые координаты CMYK, a PDFWriter предназначается для быстрого изготовления простых текстовых документов. У него наблюдаются некоторые проблемы при обработке цветных иллюстраций и встраивании шрифтов. Максимально близкие к оригиналу PDF-издания создает из документов в форматах PostScript и EPS программа Acrobat Distiller, распространяемая в составе пакета Adobe Acrobat, а также в качестве приложения к верстальному пакету PageMaker, начиная с версии 6.0, когда фирма Adobe стала владельцем фирмы Aldus и приобрела права на распространение и выпуск новых версий этого верстального пакета.

Существует большое количество различных программ и дополнительных модулей к программам, которые ориентированы на решение самых различных задач, связанных с редактированием, подготовкой и выводом на печать документов в формате PDF. Многие из них перечислены в работе ссылка на источники литературы. Так, программа DigiScript позволяет редактировать в графической форме любые фрагменты файла PDF и PostScript, а также трансформировать из одного из этих форматов в другой.

Пакет DocuCom 2.0 близок по своим возможностям к Acrobat Exchange, Distiller и PDF Writer. Кроме того, он поддерживает многоязычные файлы PDF и наборы шрифтов, которые не могут использоваться под Windows. Он также содержит встроенный инструментарий для создания аннотаций. Модуль PDF Embedder позволяет дополнять PDF-файлы новыми текстами и иллюстрациями, которые также трансформируются в этот формат.

4.7.
Программы-конструкторы для подготовки анимационных GIF-файлов

Ранее уже говорилось, что как в электронных изданиях, так и на Web-страницах широко используются изображения, представленные в виде GIF-файлов. Такие файлы могут быть получены путем преобразования изображений с индексированными цветами из других форматов в формат GIF. Сложнее обстоит дело с анимацией. GIF- практически единственный распространенный компактный анимационный формат, который непосредственно поддерживается абсолютным большинством браузеров, в том числе - Internet Explorer и Netscape Communicator. Подготовка GIF-файлов, содержащих единственное изображение, возможна во многих графических редакторах и не связана с какими-либо трудностями. Поэтому нам представляется важным в рамках этого курса изложить средства и технологию подготовки анимационных GIF-файлов.

Впервые формат animated GIF был создан фирмой CompuServ в 1987 г. и получил имя GIF87a. В этом стандарте было предусмотрено чередование строк (Interlacing), что обеспечивает быструю загрузку «костяка» изображения с постепенной его детализацией. В файле предусмотрено внутреннее сжатие без потерь на основе алгоритма LZW, что минимизирует его объем. Формат позволяет определить логическую область на экране, в произвольном месте которой производится вывод изображений. Спецификация GIF 89a добавила в формат новые возможности, в том числе: управление задержкой смены кадров, управление прозрачностью, включение в файл комментариев, вывод текста и пр.

Со второй половины 2000 г. отмечается быстрый рост интереса и потребностей в средствах создания GIF-файлов. На платформе Windows для этого традиционно чаще других используются программы GIF Animator фирмы Ulead System Ulead System, Microsoft Microsoft GIF Animator и GIF Construction Set фирмы Alchemy Mindworks Alchemy Mindworks. В качестве примера рассмотрим подготовку анимационного файла с помощью широко известной версии 2.0а последней программы. На рис. 4.41 Рис. 04.41. представлен ее исходный интерфейс-заставка.

Создание анимационного GIF-файла во всех перечисленных программах включает в себя два этапа: собственно создание такого файла и его последующая оптимизация. Процесс создания файла состоит в поочередном добавлении графических изображений в структуру GIF-файла. Все три упомянутые выше программы могут добавлять отдельные кадры в анимацию не только из файлов, но из буфера обмена оболочки Windows. Важным дополнительным достоинством программ является возможность создания анимации на основе лишь двух изображений: начального и конечного. Промежуточные изображения генерируются программой автоматически с помощью одного из нескольких возможных эффектов, например, наплыва нового изображения поверх старого, смены листа бумаги, на котором формируется изображения и пр.

Анимационный файл всегда содержит один блок заголовка (HEADER) и несколько блоков с отдельными изображениями (IMAGE), которым могут предшествовать блоки управления (CONTROL). В начале работы по составлению анимационного файла программа формирует рабочее окно, в котором содержится лишь один заголовок. Соответствующий интерфейс представлен на рис. 4.42 Рис. 04.42..

Как следует из рис. 4.42 Рис. 04.42. блок HEADER содержит информацию о размерах логического экрана в пикселах, что определяет размер прямоугольной области, внутри которой будет размещаться анимационное изображение. Для каждого отдельного кадра анимации задается смещение в пикселах относительно верхнего левого угла логического экрана.

Пользователь может самостоятельно изменять размеры логического экрана. При этом следует иметь в виду, что, если хотя бы один из кадров выйдет за пределы логического экрана, то это вызовет в браузере неустранимую ошибку и приведет к прекращению его работы. Для включения в анимацию отдельного кадра можно воспользоваться командой «Insert block/ Image» секции меню «Edit» или буфером обмена, куда предварительно было помещено изображение, и командой «Paste». Сказанное иллюстрируется рис. 4.43 Рис. 04.43.. Редактирование блока Image состоит в изменении координат смещения левого верхнего края кадра относительно логического экрана и использовании или отказе от локальной палитры. При добавлении кадра в список блоков файла автоматически выполняется сравнение его палитры с глобальной. Если какой-то оттенок отсутствует в глобальной палитре, то предлагаются варианты замены этого тона на имеющиеся в палитре.

После того как все кадры изображения помещены в анимационный GIF-файл, начинается работа с управляющими блоками: глобальным и локальными. С помощью локального блока можно задать для каждого кадра изображения временную задержку, локальную палитру, положение на логическом экране, способ удаления и пр. Рассматриваемая программа и аниматор фирм Microsoft позволяют выделить несколько локальных блоков и сразу для всех определить значения параметров.

Полученные результаты можно предварительно оценить путем просмотра GIF-файла (кнопка Preview). Однако результаты просмотра не всегда совпадают с тем, что будет получено при отображении файла браузером. Команды секции меню «Block» позволяют выполнять операции по преобразованию отдельного кадра изображения, помещенного в анимационный файл. Как показано на рис. 4.44 Рис. 04.44., можно вращать (Rotate) и изменять размер (Resize) изображения, получать его зеркальное отражение (Flip) и негатив (Reverse), настраивать цвета (Color and Balance), кадрировать (Crop) и пр.

В пакете предусмотрена возможность автоматического преобразования фрагмента цифрового видео (Movie) из формата AVI в анимационный GIF-файл. Для этого следует выбрать команду «Movie/Movie to GIF» секции меню File, что показано на рис. 4.45 Рис. 04.45.. В этой же секции имеется команда вызова мастера анимации (Animation Wizard), применение которого позволяет упростить и ускорить процесс создания анимационного файла (рис. 4.46 Рис. 04.46.). В этом случае пользователь должен только отвечать на ряд последовательно задаваемых ему вопросов в форме установки значений переключателей. В качестве примера приведен один из рабочих экранов мастера анимации, в котором пользователь должен ответить на вопрос о формате изображений, входящих в состав анимационного файла: они подготовлены в растровом формате (Photorealistic), т. е. оцифрованы с помощью сканера или созданы либо в растровом пакете компьютерной графики, либо в векторном формате (Line drawing). Кроме того, требуется указать, какая требуется палитра для передачи цветовых оттенков изображений: ограничиться одной глобальной палитрой (Matched to first palette), использовать расширенную цветовую палитру (Matched to super palette) или же (для векторного формата) ограничиться 16 цветами.

Возможно создание анимационной бегущей строки в виде нескольких отдельных ее изображений, а также специальной бегущей строки, имитирующей световую рекламу. Наконец, возможно, как уже упоминалось в запросе мастера анимации, использование расширенной палитры цветов, число оттенков в которой превышает 256.

На рис. 4.47 Рис. 04.47. представлен результат просмотра подготовленного GIF-файла, содержащего несколько блоков изображений; так как блоки одновременно не помещаются слева в своем рабочем окне, в нем автоматически создан слайдер. Для каждого из блоков, показанных в окне, выведены размеры, величина смещения и миниатюра данного кадра изображения.

В процессе разработки анимационного файла следует придерживаться некоторых рекомендаций:

  • по мере возможности не пользоваться локальными цветовыми палитрами, так как иногда их применение приводит к искажениям отдельных тонов;

  • прозрачный тон следует задавать только глобально, так как локальные палитры прозрачность не поддерживают;

  • следует тщательно проверять размер кадров, так как если изображение не помещается на логическом экране, то это может привести к многим нежелательным последствиям, в том числе - аварийному завершению работы браузера.

Для уменьшения суммарного размера полученного анимационного файла следует провести его оптимизацию. Во время этого процесса осуществляется удаление избыточной информации из файла и оптимизация локальных палитр. Последняя состоит в максимальном использовании глобальной палитры и уменьшении количества оттенков в локальных. Возможность удаления избыточной информации определяется подобием и сходством соседних кадров изображения. В частности, можно вручную удалять из каждого последующего кадра повторяющуюся часть рисунка и выбирать его координаты на логическом экране таким образом, чтобы хорошо передать эффект движения.

Программа GIF Construction Set Professional фирмы Alchemy Mindworks Alchemy Mindworks (как и программа GIF Animator фирмы Ulead System Ulead System) выполняет автоматически основную часть работы по оптимизации, что является важным преимуществом по сравнению с аналогичной программой фирмы Microsoft Microsoft. Для этой цели после окончания работы по созданию файла используется команда автоматической оптимизации - «Supercompress».

В 2000 году появились новые, более мощные версии всех трех описанных пакетов для создания анимационных файлов. В частности, фирма Ulead разработала GIF Animator 4.0, который, по их мнению, является самым быстрым и наиболее простым в применении для производства мощных анимационных GIF-композиций. В него, в частности, включена опция для непосредственного размещения анимации на странице сайта, а также автоматический оптимизатор цветовой палитры. Возможна пробная загрузка полнофункциональной версии аниматора с сервера фирмы Ulead. Сказанное иллюстрируется данными, представленными на рис. 4.48 Рис. 04.48..

Количество аниматоров в последние годы растет в геометрической прогрессии. Кратко остановимся на некоторых из них. GIF Movie Gear - аниматор высокого класса, позволяет обрабатывать отдельные кадры, осуществлять чересстрочную загрузку анимационных изображений, оптимизацию палитры путем сокращения числа используемых оттенков. Хага 3D - многофункциональный качественный 3D аниматор текстовых надписей. Он характеризуется дружественным интерфейсом, простой в использовании и не требует наличия художественных навыков. Объем около 895 Кб. AniMagic GIF Animator - простой аниматор, позволяет сжимать полученные файлы до четырех раз. Пригоден для создания анимационных изображений и баннеров. Объем около 450 Кб. Подобные же характеристики имеет HVS Animator Pro, объем которого 309 Кб.

Версия 5.5 классического графического пакета для издательско-полиграфических целей PhotoShop теперь включает в себя другой известный продукт фирмы Adobe ImageReady 2.0. Шаг вполне естественный, так как подготовка графики для электронных изданий становится основным занятием многих пользователей PhotoShop. Включение в один пакет инструментов полного цикла работе веб-графикой (от эскиза до генерации HTML-страниц) дает Photoshop'y очевидное преимущество перед конкурирующими пакетами. Так, оптимизатор Web-изображений в версии 5.5 полностью снимает с дизайнеров проблему оптимизации сетевой графики. А если вам потребуется создать анимационный GIF-файл, то можно использовать встроенный ImageReady. Причем пользователь может отдельно редактировать каждый кадр будущей анимации, расположенный в отдельном слое файла в основном формате PhotoShop'a - в формате PSD. Слои позволяют также просто обеспечить пространственный сдвиг каждого последующего кадра изображения относительно предыдущего.

Новая версия Adobe PhotoShop 6.0 включает ImageReady 3.0, в который добавлены новые средства векторной графики, новые возможности форматирования текстов, улучшена работа со слоями и др. Таким образом, потребность в качественных и удобных GIF-аниматорах успешно обеспечена фирмами, специализирующимися в разработке программ компьютерной графики и Web-дизайна.


Электронные издания:

5.
глава V. Аппаратное и программное обеспечение рабочего места читателя

В данной главе рассмотрена минимальная конфигурация аппаратных средств, обеспечивающих качественное воспроизведение электронных изданий различного типа на рабочем месте пользователя. Предложена классификация браузеров как основного средства работы с сетевыми изданиями. Более подробно рассмотрен браузер MS Internet Explorer, чаще других используемый в нашей стране. Описаны также программные средства для работы с изданиями в PDF-формате и средства воспроизведения аудиофайлов в различных форматах.

5.1.
Требования и рекомендации к аппаратному обеспечению

Для работы с электронным изданием, иначе, для его чтения, необходимо определенное аппаратное и программное обеспечение рабочего места пользователя. Основными компонентами аппаратного обеспечения являются тип используемого компьютера или состав его системного блока и тип и параметры средства визуализации информации - монитора. В составе системного блока основную роль играют материнская плата и ядро компьютера, определяющее его тип и скоростные характеристики, а именно процессор, оперативное запоминающее устройство (ОЗУ) и кэш-память первого и второго уровней.

При оценке производительности и других потребительских качеств персонального компьютера существенную роль играет тип накопителя на магнитном диске, его информационный объем и скоростные характеристики, а также наличие свободного пространства на нем для буферизации данных. Для работы с переносимыми изданиями важно наличие дисковода для компакт-дисков и его характеристики. Если же компьютер предназначается для работы с сетевыми изданиями, то необходима сетевая карта (для работы в локальной сети) или модем и оплаченный доступ в глобальную сеть Интернет через специальную посредническую фирму - провайдер. Все перечисленные вопросы будут рассмотрены в этом параграфе.

5.1.1.
Требования к центральной части или ядру ПК

Требования к центральной части или ядру ПК полностью зависят от форматов электронных изданий, для работы с которыми предназначается этот компьютер. Для текстового учебника, в котором содержится лишь незначительное количество простой графики, вполне подходят даже давно устаревшие компьютеры с процессорами типа 386DX или 486. Однако для работы с качественной графикой и анимацией в формате GIF предпочтительнее процессор Pentium 166 ММХ с минимальным размером памяти в 16 Мб. Если же предполагается работать с пособиями, включающими в себя аудио - и видеофайлы в форматах MPEG, то предпочтительнее иметь компьютер с процессором не хуже, чем Pentium II Celeron 300, причем с ОЗУ не менее 32 Мб (лучше 64 Мб).

5.1.2.
Мониторы и требования к ним

Монитор Монитор - один из немногих компонентов вычислительной системы, с которыми человек взаимодействует непосредственно. Он в значительной степени определяет, насколько компьютер удобен в обращении. При этом не следует забывать, что работа видеокарты и монитора тесно связаны друг с другом, и для создании гармоничной системы визуализации информации одинаково важна производительность обоих. Хотя рынок мониторов активно развивается, появляются новые технологии, обновляется ассортимент моделей - критерии их выбора, по существу, не изменились. К монитору, как и прежде, предъявляется единственное основное требование - он должен качественно отображать изображение, поступающее в виде управляющих видеосигналов с видеокарты.

Монитор покупается в расчете на конкретные области применения - офисные задачи, настольно-издательские работы, САПР или др.- с учетом реальной длительности его ежедневной работы. Эти исходные условия предопределяют выбор размера экрана, требования к его частотным характеристикам и разрешающей способности, а также необходимость соответствия тем или иным стандартам эргономики. Случай электронного издания ближе всего к работе в составе настольно-издательской системы. Наиболее очевидными критериями выбора монитора считаются цена и размер диагонали экрана. В настоящее время изготовители предлагают покупателям модели с диагоналями 15,17,19, 20 и 21 дюймов (14-дюймовые уже не удовлетворяют требованиям современности).

От размера экрана зависит разрешающая способность монитора, т. е. полное количество точек видимого изображения по горизонтали и по вертикали. Если длина диагонали экрана не превышает 15 дюймов, то разрешение, обеспечивающее приемлемое качество изображения, составит 800x600 точек; для 17-дюймового монитора этот показатель равен 1024x768, а для модели с диагональю 20 или более дюймов - 1280x1024 точек. При задании более высоких значений разрешения расстояния между точками приближаются к предельному значению, а четкость и контрастность изображения снижаются. К тому же и буквы становятся менее разборчивыми. Неприятное следствие этого - головные боли из-за перенапряжения глаз. Тому, кто намеревается использовать свой монитор при разрешении, на одну ступень превышающем рекомендуемое, следует выбрать модель с особо тонкой маской или размерами светового пятна (0,25 или даже 0,24 мм).

Размер экрана сам по себе не гарантирует качества. Основные потребительские свойства монитора - разрешение и частота смены кадров - зависят от его главных технических характеристик: максимальной строчной частоты и частотного диапазона видеоусилителя. Чтобы глаза не уставали, рекомендуется монитор с частотой кадров не менее 75 Гц, обеспечивающий немерцающее изображение и соответствующий международному стандарту в области эргономики ISO 9241-3. Согласно результатам испытаний, при этой частоте 90% пользователей не замечают мерцания экрана, а при 80~90 Гц его не ощущает практически никто.

Не оказывает решающего влияния на выбор монитора и то, что находится внутри электронно-лучевой трубки - теневая маска, апертурная решетка ( Sony Sony Trinitron, Mitsubishi Mitsubishi DiamondTron) или гибридная щелевая маска (NEC ChromaClear). Каждая из этих технологий имеет свои достоинства и недостатки, и выбор той или иной технологии, вообще говоря, дело вкуса.

Широкому кругу потребителей предназначаются мониторы с диагоналями в 15 и 17 дюймов. Хотя рекламные проспекты пестрят утверждениями о поддержке ими разрешения 1280x1024 точек, это технически нереально. «Пятнадцатидюймовики» обладают минимальными необходимыми свойствами - разрешением 800x600 точек. Однако многие современные программы разработаны в расчете на более высокую разрешающую способность. На 15-дюймовом мониторе работать с ними неудобно, поскольку значительную часть времени занимает «прокрутка» изображений (особенно раздражает любого пользователя горизонтальный скроллинг).

На следующей, более высокой ступени находятся 17-дюймовые мониторы, которые уже успели стать офисным стандартом де-факто. Тому, кто проводит за компьютером по несколько часов в день, целесообразно выбрать именно такую модель. Мониторы с тонкими 0,24-мм масками способны представлять картинку с разрешением 1152x864. При этом шрифты небольшого размера еще вполне разборчивы, и фрагменты текстов можно просматривать и в окнах, занимающих лишь часть экрана.

Сервисные функции для монитора не главное, хотя и желательное условие. Современным плоским кинескопам необходимо большое количество электроники для автоматической коррекции искажений. Микропроцессорные средства управления, сегодня ставшие стандартной принадлежностью практически любой модели, обеспечивают пользователю более или менее широкие возможности настройки монитора. Они запоминают параметры настройки при различных разрешениях. Таким образом, при смене режимов картинка всегда остается четкой, и необходимость в дополнительной регулировке отпадает.

Директивы международного стандарта ТСО'95 и более актуальная их версия ТСО'99 определяют максимальные значения интенсивности излучений и функции энергосбережения для мониторов, а также параметры качества изображения (мерцание, четкость, отражающая способность, линейность и распределение яркости). Рекомендации ТСО'99 также регламентируют тепловыделение и уровень шума.

Для потребителя важен не только уровень излучений монитора, но и его энергопотребление. Благодаря затемнению экрана энергия экономится лишь незначительно - примерно на 20%. Функции управления расходом мощности гарантируют снижение расхода мощности: в режиме готовности - до 30 Вт и менее, в режиме отключения - до 8 Вт и менее

В продаже имеются мониторы со встроенными динамиками и даже видеокамерами, предназначенные для мультимедийных приложений. При их покупке следует проверять качество не только картинки, но и звука. В некоторых случаях изображение страдает от электромагнитных полей, создаваемых динамиками. Интересные модели мультимедиа-мониторов предлагают, в частности, фирмы Nokia Nokia и NEC NEC.

По прогнозам уже в первом десятилетии нового тысячелетия жидкокристаллические экраны смогут конкурировать в стоимостном отношении с электронно-лучевыми трубками. Цены на крупноформатные жидкокристаллические (ЖК) мониторы постепенно снижаются до разумных пределов. Однако современная TFT-технология плоских экранов на жидких кристаллах в настоящее время еще далека от совершенства: цветовые оттенки и контрастность заметно меняются в зависимости от угла обзора. Для борьбы с этими недостатками разрабатываются все новые более или менее эффективные способы. Кроме того, ЖК-дисплеям необходимы специальные видеокарты, которые способны генерировать цифровой видеосигнал. Несколько крупных изготовителей видеокарт, например ATI, Elsa, Matrox и STB, поставляют на рынок такие модели.

Современные мониторы с ЖК-дисплеями имеют ряд преимуществ по сравнению со своими конкурентами на электронно-лучевых трубках (ЭЛТ):

  1. У них отсутствует вредное для здоровья рентгеновское излучение, они не излучают электромагнитного поля, и сами нечувствительны к воздействию таких полей.

  2. В плоских ЖК-моделях, в отличие от мониторов с ЭЛТ, видимая поверхность экрана используется практически полностью. Например, диагональ полезной поверхности экрана 13,8-дюймового ЖК-монитора равняется 350 мм - как у 15-дюймового ЭЛТ-монитора, а 15-дюймовая ЖК-модель имеет ту же полезную экранную площадь (диагональ 381 мм), что и 17-дюймовая модель с ЭЛТ.

  3. Для ЖК-моделей задача сведения лучей неактуальна. Картинка остается одинаково четкой не только в центре экрана, но и по краям, и отличается высокой контрастностью, в десятки раз превышающей показатели ЭЛТ-мониторов, а также значительно большей светоотдачей.

  4. ЖК-мониторы потребляют значительно меньше электроэнергии (в среднем на 40-50%).

  5. Они отличаются компактностью и малым весом, не превышающим, как правило, 5~б кг (ЭЛТ-мониторы со сравнимыми диагоналями весят в три-пять раз больше).

Недостатки ЖК-мониторов также хорошо известны. Это более высокая стоимость и более узкий диапазон цветности, так как все основные цвета получаются из белого света, пропущенного через цветовые фильтры (по одному на каждую из RGB-составляющих).

Невзирая на эти недостатки, американские специалисты в области образования и электронных средств обучения считают наиболее перспективным для работы с электронным изданиями переносной компьютер с ЖК-монитором достаточного формата (диагональ не менее 13,8 дюймов). Некоторые колледжи и университеты США снабжают своих студентов такими компьютерами (это входит в стоимость обучения).

5.1.3.
CD-ROM-накопители для работы с переносимыми изданиями

Ранее уже отмечалось, что компакт-диски служат важным средством распространения электронных изданий. CD-ROM (Compact Disk - Read Only Memory) CD-ROM (Compact Disk - Read Only Memory) - это оптический накопитель, представляющий собой память только со считыванием информации. Информация на такой диск заносится путем переноса с так называемого мастер-диска с помощью специального штампа. Аналогичным образом изготавливаются и аудио компакт-диски. Подобным же способом с начала XX века изготовлялись грампластинки, использовавшиеся в механических, а позднее - в электромеханических граммофонах.

С технологической точки зрения CD-ROM представляет собой диск диаметром около 120 мм и толщиной около 1,2 мм. Основная его часть - это подложка, изготавливаемая на основе поликарбонатного пластика, на которую с помощью пресса наносится рельеф или информационное содержание диска. После прессования на лицевую (информационную) сторону диска наносится отражающее покрытие (обычно это алюминиевая пленка толщиной в несколько микрон), на которое сверху напыляется защитный слой лака, предохраняющий информационный и отражающий слои от повреждения.

Информация нанесена на компакт-диск не в виде набора концентрических дорожек, как это выполнено в накопителях на магнитных дисках, а в форме спиральной дорожки, разворачивающейся от внутренней области диска к периферии. Сама информация содержится на этой дорожке в виде так называемых «питов», т. е. микроскопических углублений и промежутков между ними. Ширина информационной дорожки и линейный размер, соответствующий одному биту информации, близок к 0,6 мкм.

Накопители информации на магнитных дисках используют привод с постоянной угловой скоростью вращения. В результате размеры информационных областей, хранящих постоянное количество информации (например, секторов), изменяется в зависимости от положения дорожки, на которой эта область размещается: на минимальном расстоянии от оси вращения размер такой области также минимален, а на периферии диска протяженность этой области наибольшая.

У компакт-дисков каждый бит занимает строго определенное пространство, соответственно протяженность информационного сектора также должна быть постоянной, т. е. не может зависеть от расположения этого сектора на спиральной дорожке. Вследствие этого скорость перемещения считывающей головки вдоль информационной дорожки также должна быть постоянной. Компакт-диск, в отличие от магнитных дисков, относится к устройствам с постоянной линейной скоростью. Следовательно, угловая скорость вращения компакт-диска должна уменьшаться при чтении информации с периферийных участков диска и, наоборот, увеличиваться при чтении витков спирали, расположенных ближе к оси вращения.

Дисковод для компакт-дисков представляет собой достаточно сложную конструкцию, включающую в себя электронные, оптические и электромеханические узлы. Привод вращения оптического диска сложнее, чем магнитного, так как помимо стабилизации скорости вращения имеется еще узел ступенчатого изменения скорости вращения диска в соответствии с тем, на каком витке спирали находится головка считывания информации. Обычно имеется 8-10 таких ступеней, каждая из которых соответствует определенному диапазону витков спирали. Скорость на самой верхней ступени (для внутренних витков спирали) приблизительно вдвое больше, чем на самой нижней.

Три другие электромеханические подсистемы осуществляют различные виды автоматической регулировки параметров. В частности, система позиционирования головки считывания информации переводит ее на нужный виток спирали. Система автоматического слежения за информационной дорожкой с помощью специального оптического датчика в виде многосегментного фотоприемника, усилителя сигнала рассогласования и исполнительного механизма в виде поворотного зеркальца с гальванометрическим подвесом удерживает световое пятно на дорожке. Система автофокусировки осуществляет перемещение головки считывания вдоль оси вращения оптического диска, обеспечивая точную фокусировку в той плоскости, в которой размещается информация на диске. Кстати, датчиком системы автофокусировки служит тот же самый многосегментный фотоприемник, отдельные элементы которого включены по дифференциальной схеме, а исполнительным механизмом служит так называемый «линейный двигатель». Последний выполнен в виде тонкой электрической катушки стоком, внутри которой находится намагниченный сердечник. Изменение величины и полярности тока в катушке приводит к ее перемещению в ту или иную сторону вдоль сердечника (такая система много лет используется для преобразования электрических колебаний в звуковые в громкоговорителях или динамиках). Особенность всех этих трех систем состоит в их высокой точности и скорости перемещения.

Главная из оптических подсистем - оптическая головка. Она включает в себя полупроводниковый лазер, фокусирующий объектив, который преобразует излучение лазера в световое пятно диаметром менее 1 мкм, которое должно находиться на соответствующем витке спиральной информационной дорожки, оптический расщепитель, который направляет отраженный от диска световой луч на фотоприемник системы считывания информации. Фокусирующий объектив жестко связан с электрической катушкой системы автофокусировки. Изменение положения объектива компенсирует вибрацию и другие неконтролируемые перемещения оптического диска, поддерживая точную фокусировку света на информационной дорожке.

Позиционер оптической головки на нужный виток спирали двухступенчатый: первая ступень с шаговым двигателем осуществляет грубое позиционирование, точность которого 10-20 витков спирали от требуемой позиции, вторая ступень реализует точное позиционирование с помощью легкого зеркальца, закрепленного на гальванометрическом подвесе. Оно же используется для упоминавшегося ранее слежения за дорожкой.

Скорость информационного обмена с оптическим диском при номинальной скорости вращения диска (приблизительно от 250 до 500 об/с) составляет около 150 Кб/с. Для современных персональных компьютеров это совершенно недостаточно. Поэтому все современные дисководы для оптических дисков работают на кратных скоростях вращения, которые в 40~50 раз превышают номинальную скорость, что позволяет увеличить скорость обмена до 7 Мб/с и более. Емкость оптического диска близка к 700 Мб, т. е. приблизительно за 100 с можно считать всю информацию с оптического диска.

5.1.4.
Другие виды оптических накопителей

В конце 1998 г. появился новый оптический носитель для хранения и распространения мультимедийных изданий. Он получил название DVD-диск, что представляет собой аббревиатуру от DVD-диск (Digital Video Disk) Digital Video Disk - цифровой видеодиск. Инфракрасный полупроводниковый лазер с длиной волны 780 нм, используемый в дисководах для компакт-дисков, в DVD-дисководе заменен красным лазером с длиной волны 635 нм. Это позволило за счет улучшения фокусировки вдвое уменьшить диаметр сфокусированного пятна на информационной дорожке. В результате удалось вдвое увеличить как плотность записи вдоль информационной дорожки, так и плотность размещения витков спирали. Действие этого эффекта, а также использование более совершенного формата секторов, более эффективного кодирования и автоматической компрессии при занесении данных на DVD-диск позволило достигнуть увеличения емкости диска до 4,7 Гб.

Другие конструкции DVD-диска позволили еще в несколько раз увеличить информационную емкость. Так, односторонний двухслойный диск содержит два информационных слоя, расстояние между которыми близко к 0,5 мм. Один из этих слоев полупрозрачен, в результате чего проходящая сквозь него часть светового потока полупроводникового лазера может быть сфокусирована на другом слое. Информационная емкость каждого слоя близка к 4,25 Гб, а общая емкость такого диска составляет 8,5 Гб.

В двустороннем однослойном диске используются два полупроводниковых лазера, по одному с каждой стороны диска. Каждый лазер работает со своим информационным слоем. Если емкость одного такого слоя 4,7 Гб, то суммарная емкость диска составит 9,4 Гб. Последняя конструкция может быть усовершенствована таким образом, что с каждой стороны диска будут по два информационных слоя, причем внешние, т. е. расположенные ближе к периферии диска, делаются полупрозрачными. Суммарная емкость такого четырехслойного диска близка к 17 Гб.

Скорость вращения DVD-дисков не слишком велика и соответствует 2-4-кратному приводу CD-ROM. При этом скорость информационного обмена составляет приблизительно 1,5 Мб/с. Такая скорость обмена отвечает требованиям форматов MPEG-2 и MPEG-4. Дальнейшее совершенствование таких устройством связано с развитием полупроводниковых лазеров по пути укорочения длины волны излучения. Фирма Hitachi, лидер в области DVD-технологий, обещает в ближайшие годы разработать голубой полупроводниковый лазер, что позволило бы еще втрое увеличить плотность записи информации.

В последние годы все шире используются устройства для записи информации на компакт-диск - CD-R-дисководы (CD-Recorder). Такие диски практически вытеснили существовавшие с 1985 г. диски WORM (Write Once Read Many), размеры которых изменялись в пределах от 5,25 до 12 дюймов. Причина этого очевидна - компакт-диск стал практическим стандартом в компьютерных технологиях. Записываемый компакт диск успешно может быть прочитан с помощью любого CD-ROM-дисковода.

Компакт-диск с однократной записью несколько отличается от обычного. В качестве отражающего слоя в нем используется тончайшая пленка золота, а информационный слой - диэлектрик с низкой температурой испарения. Сфокусированный луч лазера локально испаряет диэлектрик, в результате чего возникают локальные вздутия отражающей пленки, изменяющие характеристики отражения для считывающего луча полупроводникового лазера.

При занесении информации на CD-R-диск можно сразу, за один прием заполнить весь диск. Такой режим называют односеансовым или односессионным. Можно и несколько раз устанавливать диск в дисковод и постепенно заносить информацию на спиральную дорожку. В течение одного сеанса можно заполнить один или несколько витков спирали. Первый сеанс записи требует не менее 22 Мб информационного пространства, а каждый последующий - не менее 13 Мб. В течение каждого сеанса наряду с полезной на диск заносится большое количество служебной информации, поэтому количеством сеансов записи не следует злоупотреблять. Кроме того, следует иметь в виду, что односеансовые диски читаются всеми стандартными дисководами для компакт-дисков, а многосеансовые - только дисководами CD-RW.

Среди характеристик CD-R дисковода указывают скорость занесения информации на диск и ее чтения с диска. Обычно эти значения составляют 2-8 и 10-12 крат. Лишь в 2000 г. фирме Philips Philips удалось довести скорость записи в своих моделях CD-RW до 10-12 крат. Отметим также, что в режиме записи мощность излучения лазера приблизительно в 10 раз больше, чем в режиме чтения. Впрочем, эти дисководы для чтения применяются весьма редко - только для многосеансовых дисков.

5.2.
Назначение и общая характеристика браузеров

Браузер Браузеры служат основным средством для чтения (просмотра) электронных изданий в HTML-формате и Web-сайтов. В издательских технологиях браузерам отведена почетная роль универсального средства как для просмотра изданий и Web-страниц, так и организации совместной работы сотрудников по подготовке изданий в рамках передовой технологии интрасетей (Intranet). Фирма Microsoft какой-то период даже распространяла свою оболочку Windows с интегрированным в нее браузером Explorer, пока это не было ей запрещено судом. Все браузеры и сопутствующие инструменты можно разделить на четыре группы, а именно (рис. 5.1 Рис. 05.01.):

  • браузеры общего назначения;

  • специализированные браузеры для просмотра трехмерных изображений;

  • так называемые «офф-лайн» браузеры, т. е. средства для быстрого переноса информации на компьютер пользователя с последующим отключением от сети Интернет и просмотром данных в автономном режиме;

  • дополнительные средства (инструменты) для улучшения работы браузеров.

Браузер общего назначения Microsoft Internet Explorer исходно предназначался для работы исключительно на платформе Windows. За шесть лет от первой версии до нынешней пятой пакет неузнаваемо переменился, совершенствуясь вместе с самой оболочкой Windows. Работа с современной версией пакета Internet Explorer 5.0 в оболочке Windows 98 или 2000 внешне ничем не отличается от работы с другими приложениями оболочки или с предыдущей версией этой программы. Основная функция Explorer'a состоит в обмене данными в сети Интернет, в частности, отображении Web-страниц и HTML-документов. Браузер может быть загружен теми же приемами, что и другие пакеты оболочки. Он также автоматически запускается при щелчке указателем мыши по любому гипертекстовому документу. Он же обеспечивает и поиск сайтов и документов в сети Интернет, если известны их сетевые URL, атрибуты или другие признаки, пригодные для организации поиска.

Русифицированный браузер Internet Explorer, по мнению многих пользователей, является лучшим на сегодняшний день средством общего назначения для непосредственного просмотра Web-страниц. Хотя изначально это программное средство создавалось для Интернет-технологий, оно (точно так же, как и Netscape Communicator) успешно используется и для работы с любыми электронными изданиями, для представления которых использован формат HTML. В частности, в издательских технологиях широко используются интра- и экстрасети для организации совместной работы сотрудников, корпоративной организации труда. Основное средство просмотра на базе этих технологий - это браузеры.

Последняя версия 5.5 Explorer'a характеризуется общим объемом около 49 Мб. Начиная с версии 5.0 браузер содержит удобное дополнение- кнопку на панели инструментов, которая позволяет «на лету» включать и выключать режим отображения графики (Images on/off). Кнопка формируется с помощью специального программного фрагмента, информационный объем которого около 260 Кб. В версии 5.5 улучшена поддержка новых стандартов: динамического HTML, каскадных стилевых листов, XML.

Netscape Communicator, в отличие от предыдущего браузера, не русифицирован, что для многих отечественных пользователей составляет главный его недостаток. Автору, однако, интерфейс этого браузера представляется более привлекательным. К достоинствам можно отнести то, что специальная секция меню Communicator позволяет перейти к другим программам пакета, например, к Netscape Composer'y- мощному WYZIWYG-редактору HTML-документов.

Браузер фирмы Netscape является на протяжении ряда лет главным конкурентом Internet Explorer. Он работает на различных платформах, причем за рубежом его позиции не слабее, чем у Explorer'a. Информационный объем пакета Netscape Communicator для версии 4.75 составляет около 20 Мб, а для недавно появившейся версии 6.0 - 25 Мб.

Отметим, что версия 6.0 коренным образом изменилась по сравнению с 4.75. Браузер приобрел сходство с популярным на платформе UNIX браузером Mozilla. Впрочем, его внешний вид может изменяться с помощью так называемых «оболочек» (skins) точно так, как это делается в популярном МР-3 проигрывателе Winamp. В версии 6.0 используется механизм визуализации Gecko, также заимствованный из браузера Mozilla. Пока можно только заметить, что этот механизм работает быстрее.

В пакете реализована тесная интеграция программ AOL Instant Messenger и Net2Phone с собственно браузером. Первая позволяет обмениваться мгновенными сообщениями, а вторая - звонить в любую точку мира через службу Интернет-телефон. Однако такая интеграция приводит к увеличению на 20% требуемого объема оперативной памяти.

В последние годы заметно расширилось использование браузера Opera от Opera Software компании Opera Software, хотя пока он заметно уступает двум пакетам, рассмотренным выше. Сайт фирмы-распространителя данного браузера представлен на рис. 5.2 Рис. 05.02..

По сравнению с браузерами, рассмотренными выше, Opera 4.0 выглядит просто малюткой, так как дистрибутив ее занимает всего 1,6 Мб. Однако он мало в чем уступает своим признанным старшим товарищам. В нем имеется адресная книга, список закладок и модуль работы с электронной почтой, причем все они оформлены в виде одной панели со вкладками, что представляет определенное удобство для пользователя, так как позволяет быстро переходить от одной операции к другой. К достоинствам этого браузера следует отнести и реализацию концепции многодокументного интерфейса, что уменьшает потребность в системных ресурсах и увеличивает производительность. Полезной особенностью браузера является автоматическая загрузка последней просмотренной Web-страницы при повторном запуске программы.

Однако в дистрибутиве отсутствуют функции, связанные с обработкой мультимедиа и поддержкой технологии Java. Можно, однако, загрузить соответствующие Plag-in'bi, например, Sun Java 1.1.3. Кстати, размер последнего составляет около 5 Мб. Недостаток браузера - также плохая поддержка кодировки KOI-8. Разработчики браузера распространяют бесплатно 30-дневную демонстрационную версию, а за рабочую версию требуют небольшую плату.

В настоящее время распространяется версия 5.01 этого браузера, информационный объем которой 9,3 Мб. В ней устранены основные из перечисленных недостатков. Браузер работает практически на всех известных платформах.

Выше уже говорилось о сходстве браузера Mozilla с Communicator 6.0. Это неудивительно, так как Mozilla был разработан фирмой Netscape Netscape, а в 1998 г. был опубликован его исходный код, причем фирма Mozilla взяла на себя сопровождение этого браузера. Для установки браузера используется архивный ZIP-файл, который распаковывается в отдельный каталог и сразу готов к работе. Mozilla распространяется без средств поддержки технологии Java. Реализация этой возможности требует включения дополнительных Plag-in'os в его состав. Браузер распространяется и поддерживается на сайте www.mozilla.org.

Последний из браузеров общего назначения по нашей классификации, о котором хотелось бы сказать несколько слов - это AMAYA 3.0, который был создан группой разработки стандартов консорциума W3C и используется ею для демонстрации и отработки новых Web-технологий. В данной версии реализована полномасштабная поддержка HTML, DHTML, MathML и CSS. Вероятно, это единственный браузер, который на основе MathML позволяет формировать сложные математические выражения и сразу помещать их на Web-страницу. Браузер поддерживает редактирование каскадных таблиц стилей (CSS) и их связывание с конкретными документами, причем результат активации стиля сразу отображается на экране. Однако даже этот браузер не полностью поддерживает стандарт CSS.

К браузерам второй группы относится гораздо менее распространенный по сравнению с предыдущими WebSpace Navigator фирмы SiliconGraphics. Это специализированный трехмерный браузер для просмотра VRML-документов, который открывает абсолютно новые возможности для взаимодействия с Web. VRML (Virtual Reality Modeling Language) VRML (Virtual Reality Modeling Language) - это разработанный той же фирмой SiliconGraphics SiliconGraphics и лицензированный практически всеми ведущими компьютерными компаниями язык моделирования виртуальной реальности. Он широко используется при описании трехмерных миров, передаваемых по Internet и имеющих гиперсвязи с WorldWideWeb.

Некоторые виртуальные объемные объекты поражают воображение. Например, используя VirtualSOMA Planet9, можно с высокой степенью достоверности имитировать прогулку по приморским торговым кварталам Сан-Франциско. Одновременно с выбором в Web-браузере связи с VRML-документом, запускается Web Space Navigator, который позволяет интерактивно перемещаться в трехмерном пространстве. Простое нажатие клавиши мыши, установленной на одном из объектов, обеспечивает Web связь с другими виртуальными мирами, HTML страницами и мультимедийными файлами.

COSMOPIayer - это VRML 2.0 браузер фирмы SiliconGraphics, который делает мир еще более динамичным и насыщенным, чем это мог сделать его предшественник -WebSpace Navigator. В сочетании с Java, COSMO достигает высокого динамизма и интерактивности. В дальнейшем процессе развития COSMOPIayer будет включать все большее количество функций языка VRML 2.0, в том числе - COSMO Motion Engine, равномерный поток аудио- и видеоданных, а также операции в режиме разделенного времени. Только представьте себе музей, в котором двигаются трехмерные объекты и видеофильм на одной из стен, в котором объясняется суть происходящего. Кстати, CosmoPlayer, как и WebSpace интегрирован с Netscape Navigator.

Информация, в зависимости от содержания, автоматически направляется на соответствующий браузер. HTML-страницы, получившие запрос в COSMO Player поступают в NetscapeNavigator, а виртуальные VRML миры, запрошенные из NetscapeNavigator, без всякого вмешательства пользователя, попадают в COSMO Player. Это многоплатформное решение, которое SiliconGraphics намерен сделать доступным для широкого лицензирования, включая и платформы персональных компьютеров.

Еще один VRML браузер GLView версия 3.4 с информационным объемом около 1,5 Мб также предназначен для просмотра трехмерных изображений. Работаете любыми версиями Windows включая NT. Взаимодействует с браузером общего назначения MS Internet Explorer.

Специализированный Web-браузер Premo Web Talkster умеет вслух читать текст на английском языке на открытой и активной в данный момент Web-странице (либо всю страницу целиком, либо только выделенный текст). Версия 1.0.f характеризуется информационным объемом около 8,5 Мб. Такие браузеры нравятся детям и школьникам, полезны для слабовидящих и изучающих иностранные языки. В будущем браузер, вероятно, сможет читать тексты и на русском языке.

К специализированным браузерам можно отнести и Lynx for Win32. Это классический текстовый Web-браузер, не воспроизводящий ни изображений, ни Java-скриптов, но зато быстрый и надежный. Ранее он работал только на платформе Unix, а теперь новая его версия пригодна для использования под Windows. Версия 2.8.3 имеет объем около 700 Кб.

Далее остановимся на группе офф-лайн браузеров. Teleport Pro - известный и популярный офф-лайн браузер. Скачивает сайты целиком, сохраняя структуру каталогов. Ведет поиск по сайтам. При скачивании информации может следовать не только по внутренним ссылкам, но и по внешним (ведущим на другие сайты). Множество других возможностей, продуманный интерфейс, подробная справочная система. Версия 1.29 занимает на жестком диске около 850 Кб, модуль русификации - дополнительно еще 60 Кб. Ограничения незарегистрированной версии незначительны, а ее дистрибутив можно «скачать» на нескольких сайтах.

WebZIP3.71 - один из лучших в миреоф-лайн-браузеров. Создает копию выбранного Web-сайта или страницы Интернета на вашем жестком диске для последующего просмотра в автономном режиме, т. е. не подключаясь к Сети. Это очень удобно, так как дает возможность использовать ночные тарифы Интернет, как правило, гораздо более экономные и с лучшим качеством связи. В браузер вводятся данные, что именно требуется скопировать и сохранить: одну страницу или весь сайт; на какую глубину следует прорабатывать ссылки; копировать только текстовую информацию или файлы определенного формата (например, изображения в формате GIF, архивы, аудио- и видеоклипы и т. д.). WebZIP имеет хорошие настройки параметров скачивания информации.

Одной из способностей этого оф-лайн-браузера является возможность архивации в формате ZIP копируемых файлов. Для просмотра загруженных страниц не нужно распаковывать архивы - программа работаете ними, как с обычными папками. Вы можете просматривать, добавлять и удалять файлы - таким образом, WebZip можно использовать также и в качестве обычного архиватора. Опцию автоматической архивации файлов можно включать или выключать. Для визуального просмотра Web-страниц используется ядро браузера Internet Explorer, который должен быть обязательно установлен в системе. В его окне вызываются контекстные меню Internet Explorer, что позволяет уста на вливать нужную кодировку. Впрочем, сайт, уже перенесенный на ваш компьютер, можно просмотреть в автономном режиме любым браузером, установленным на компьютере.

Беспрецедентная возможность, предусмотренная в этом оф-лайн-браузере - сохранение скопированного сайта в виде одного единого файла в формате compressed HTML- Help f lies (.CHM). В этот формат (.СНМ) встроена справка (Help) браузера Internet Explorer 5, MS Office 2000, Windows 98 и т. д. Немаловажно и то, что на сайте производителя к программе прилагаются дополнительные языковые модули, в том числе и русский.

Далее кратко остановимся на нескольких программах, специализирующихся только на «скачивании» информации из сети Интернет, т. е. переносе ее с определенных серверов и сайтов (в том числе ftp-серверов) на ваш компьютер. Одна из таких программ - это ReGet. Он позволяет легко и быстро копировать файлы с FTP- и HTTP- серверов на ваш компьютер. ReGet полностью использует всю полосу канала Интернет-соединения. Если качество связи низкое (что характерно для старых отечественных телефонных линий), ReGet позволит свести неудобства к минимуму и безошибочно перенести все файлы на Ваш компьютер. Русифицированная версия ReGet 1.7 rus занимает700 Кб, а новый выпуск ReGet Junior 2.0 - около 1,3 Мб.

Пакет FlashGet может переносить файлы и сайты по частям (причем показывает графическую карту процесса и заголовки переносимых файлов), включаться в заданное время, добавлять комментарии, упорядочивать файлы по категориям. Автоматически находит зеркала (т. е. отображения данного сайта на других серверах, см. также главу 9) и определяет наиболее быстрые из них. Поддерживает режим работы drag&drop (тяни и бросай, в буквальном переводе, т. е. перетаскивание файлов и папок с помощью указателя мыши). Предусмотрена возможность записи последовательности работы в специальный Log-файл в формате HTML. Информационный объем русифицированной версии 0.94 - около 1,3 Мб.

GolZilla от Aureate Media - еще один менеджер для переноса файлов из Интернет-сайтов на Ваш компьютер. Имеет простой и дружественный интерфейс пользователя. Все действия по оптимизации загрузки - поиск альтернативных ftp-серверов, выбор самого быстрого канала и переключения между ними - осуществляются в фоновом режиме незаметно от пользователя. Он позволяет производить дозвон до провайдера, разрывать соединение и выключать компьютеры по окончании сеанса, начинать загрузку в определенное время и регулировать скорость передачи данных для отдельных файлов. GolZilla производит мониторинг буфера обмена и операций в браузерах, а также проверяет полученные файлы на вирусы. Пакет очень популярен среди молодежи. Информационный объем - около 1,8 Мб.

К четвертой группе мы отнесли средства расширения и улучшения параметров браузеров. В частности, можно указать программу Naviscope (информационный объем около 400 Кб) - набор инструментальных средств для расширения браузера. Он ускоряет процесс поиска в Интернете путем загрузки многих страниц, а также отображает информацию о загрузке используя соответствующий индикатор загрузки в специальном небольшом окне. Быстро переходит к последней из просмотренных страниц, создает карты передвижения по сайтам и точно синхронизирует часы вашего PC с атомными часами, а также сохраняет адреса просмотренных сайтов на жестком диске компьютера пользователя. Есть утилита, блокирующая загрузку рекламных объявлений (баннеров), фоновых изображений, фоновых звуков, ми тающего те кета и пр.

Как многие пользователи огорчаются, сталкиваясь с невозможностью сохранения HTML страниц с включенной в них графикой Утилита Netrieve v1.04 (объем около 600 Кб) позволяет сохранять страницы с графикой для последующего автономного просмотра. Программа OnTrack! (размер около 800 Кб) позволяет блокировать различные всплывающие и выскакивающие окна при посещении некоторых сайтов. Работает в фоновом режиме со многими популярными браузерами, (например, Internet Explorer, Netscape Navigator, Opera) и пресекает любую попытку загрузки дополнительных окон с рекламой и прочей ненужной информацией. Аналогичные функции выполняет утилита PopOff 32-bit, которая запускается одновременно с браузером. Ее объем чуть больше 800 Кб.

Синхронный перевод Web-страниц с одного языка на другой также является важной вспомогательной утилитой для браузеров. Существует ряд переводчиков, которые можно использовать для этих целей. Однако, по нашему мнению, наибольший интерес представляет браузер с синхронным переводом Web-страниц WebView.

Он входит составной частью в интегрированный пакет для работы в Интернете PROMT Internet 2000. Обеспечивает перевод с английского, немецкого, французского языков на русский и обратно. Это эффективное средство просмотра иноязычных сайтов. Пользователь, по существу, использует два браузера, в одном отображается оригинал страницы, а в другом - ее перевод. При переводе полностью сохраняется форматирование, включая фреймовую структуру и иллюстрации. Переход по ссылкам осуществляется как в окне оригинала, так и в окне перевода. Как оригинал, так и перевод сохраняется в виде файлов. В программе предусмотрены полностью настраиваемые меню и панели инструментов в стиле Microsoft Word 2000, доступны все основные функции Microsoft Internet Explorer, в том числе сохранение ссылок в Favorites.

5.3.
Браузер MS Internet Explorer

Этот браузер исходно предназначался для работы исключительно на платформе Windows. За шесть лет - от первой версии до нынешней пятой - пакет неузнаваемо переменился, совершенствуясь вместе с самой оболочкой Windows. Работа с современной версией пакета Internet Explorer 5.0 в оболочке Windows 98 или 2000 внешне ничем не отличается от работы с другими приложениями оболочки или с предыдущей версией этой программы. Основная функция Explorer'a состоит в обмене данными в сети Интернет, в частности, отображении Web-страниц и HTML-документов. Браузер может быть загружен теми же приемами, что и другие пакеты оболочки. Он также автоматически запускается при щелчке указателем мыши по любому гипертекстовому документу. Он же обеспечивает и поиск сайтов и документов в сети Интернет, если известны их сетевые URL, атрибуты или другие признаки, пригодные для организации поиска.

5.3.1.
Экранный интерфейс

Экранный интерфейс этого браузера представлен на рис. 5.3 Рис. 05.03.. Как и большинство других приложений оболочки Windows он содержит набор стандартных элементов:

  • строку заголовка;

  • строку меню;

  • панель инструментов «Обычные кнопки»;

  • панель инструментов «Адресная строка»;

  • рабочее окно программы, в котором выводятся открываемые в ней документы;

  • строку состояния.

На рис. 5.3 Рис. 05.03. показаны только две панели инструментов: «Обычные кнопки» и «Адресная строка», которые выводятся на экран по умолчанию. На рис. 5.4 Рис. 05.04. раскрыта команда «Панели инструментов» секции меню «Вид». В ней видно, что помимо этих двух панелей можно вывести на экран еще две: «Ссылки» и «Радио». На панели «Ссылки» расположены кнопки, соответствующие наиболее интересным (с точки зрения разработчиков этого программного пакета) сайтам в сети Интернет. Последняя панель инструментов позволяет пользователю выбрать радиостанцию, вещающую в сети Интернет, и обеспечить управление качественным воспроизведением этой радиостанцией речи и музыки.

Последняя подкоманда этой группы - «Настройка» - открывает диалоговое окно «Настройка панели инструментов», показанное на рис. 5.5 Рис. 05.05., с помощью которого можно менять состав и размещение кнопок в панели. Из списка «Имеющиеся кнопки», показанного слева в диалоговом окне, можно добавить любой выбранный элемент в панель инструментов. Наоборот, из списка «Панель инструментов» в правой части диалогового окна можно удалить любой инструмент. Кнопка «Сброс» (вторая справа сверху) позволяет вернуться к виду панели инструментов, установленному по умолчанию, а кнопки «Вверх» и «Вниз» диалогового окна позволяют перемещать выбранную кнопку в панели инструментов в соответствующем направлении. Эти кнопки активизируются при выборе любого элемента в списке «Панель инструментов».

Вернемся к назначению кнопок в панели «Обычные кнопки». Оно хорошо согласуется с их пиктограммами и надписями. Так, кнопки «Вперед» и «Назад» обеспечивают переход к предыдущей или последующей из списка просмотренных страниц. Кнопка «Вперед» активизируется только в том случае, если ранее была использована кнопка «Назад». Кнопка «Остановить» определяет отказ от загрузки запрошенной ранее страницы (например, по заголовку вы определили, что это не тот документ, который вам нужен). А кнопка «Обновить» определяет повтор запроса на загрузку страницы.

При нажатии кнопки «Домой» осуществляется переход к странице, которая ранее определена как начальная. Кнопка «Поиск» открывает в рабочей области программы панель со страницей, ранее назначенной страницей поиска. Нажатие кнопки «Избранное» открывает одноименную папку, в которой содержатся ранее сохраненные ссылки на Web-страницы. Кнопка «Журнал» открывает панель с записями имен последних просмотренных документов. А кнопка «Связанный» обеспечивает поиск новых документов, подобных по содержанию просматриваемому в настоящий момент.

В оставшейся части панели «Обычные кнопки» содержится кнопка «Почта», которая обеспечивает переход к работе с электронной почтой и группами новостей, «Размер», изменяющая принятый по умолчанию размер шрифтовых элементов документа, «Кодировка», позволяющая сменить принятую по умолчанию кодовую таблицу в отображаемом документе при неправильном отображении всего документа ил и его части. Кнопка «Правка» передает рассматриваемую страницу в программу редактирования (например, MS Word, где можно вносить изменения и сохранить документ в нужном формате). Для вызова последних двух кнопок следует нажать на двойную стрелку в конце панели. Предпоследняя кнопка обеспечит распечатку просматриваемого документа, а последняя кнопка позволяет максимально увеличить рабочее пространство Explorer'a, оставив на экране помимо рабочего окна единственную панель «Обычные кнопки», как это показано на рис. 5.6 Рис. 05.06..

Характерным признаком браузера, который отличает эту программу от других Windows-приложений, является наличие специального инструмента - спискового окна адреса, которое раскрывается при щелчке указателем мыши и содержит сетевые и локальные адреса, с которыми работал пользователь (рис. 5.7 Рис. 05.07.). Это позволяет быстро выбрать один из использованных ранее адресов и загрузить соответствующую Web-страницу.

Отметим, что помимо рассмотренного режима просмотра HTML-изданий и Web-страниц Explorer может работать и в других режимах. Для выбора режима работы достаточно вызвать контекстное меню программы, щелкнув правой кнопкой указателя мыши по пиктограмме Explorer'a. В контекстном меню (рис. 5.8 Рис. 05.08.) основной интерес представляют три первые команды: «Открыть», «Проводник» и «Открыть домашнюю страницу». Остальные команды стандартны для большинства контекстных меню. Первая команда осуществляет загрузку пакета, а вторая - загрузку в режиме «Проводника». Третья команда загружает браузер со страницей, установленной как исходная или домашняя.

Загрузка в режиме «Проводник» показана рис. 5.9 Рис. 05.09.. На нем хорошо видно, что рабочее окно программы разбивается на две части: в правой отображается HTML-документ или Web-страница, а в левой - панель «Папки», где показана иерархическая структура «Рабочего стола» на пользовательском компьютере.

В этом режиме можно просмотреть содержимое любой папки на локальном компьютере, выводя документы в режиме просмотра Web-страниц. Таким же образом можно просмотреть документы в локальной сети, элементом которой является пользовательский компьютер, т. е. в правой части вместо представленной на рис. 5.9 Рис. 05.09. исходной страницы сервера www.rambler.ru может быть показано содержимое любой папки, локальной или сетевой, или же загружен любой HTML-документ, содержащийся в одной из этих папок.

Самая нижняя строка интерфейса MS Internet Explorer'a - строка состояния или статус-строка (см. рис. 5.3 Рис. 05.03.). В ней отображается информация о загрузке документа или Web-страницы (индикатор загрузки), адрес гиперссылки, на указатель которой выведен манипулятор мышь, указатель уровня безопасности узла Web, с которого производится загрузка.

5.3.2.
Организация просмотра загруженного документа

Электронные HTML-издания могут иметь значительный объем. В то же время в них не предусмотрена разбивка на страницы. Кстати, это лишний довод в пользу того, что электронное издание целесообразно выводить с помощью фреймовых структур, в которых в отдельном фрейме выводится оглавление издания, которое и служит основным средством навигации. А каждая строка оглавления обеспечивает вывод соответствующего раздела, который целесообразно разбивать на дискретные фрагменты, чей размер связан с информационной емкостью экрана компьютера. Таким образом, организация просмотра загруженного документа, особенно в том случае, когда в нем не предусмотрена навигация с помощью оглавления, представляет достаточно серьезную проблему.

Традиционный способ просмотра больших документов, пригодный и для использования в браузерах, состоит в применении слайдера или вертикальной полосы прокрутки. Используя концевые указатели слайдера, можно дискретно перемещаться по документу, щелкая по ним левой кнопкой указателя мыши. Возможно непрерывное перемещение по документу, если захватить мышью движок слайдера и перемещать его вверх (к началу документа) и вниз (к его концу).

Возможно использование клавиатурных средств перемещения по электронному изданию. Так, вертикальные стрелки позволяют смещаться на одну строку вверх или вниз. Клавиши <Page Up> и <Раде Down> обеспечивают перемещение вверх или вниз на размер экранного окна документа, а клавиши <Ноте> и <End> позволяют перейти в начало или в конец издания. Надо отметить, что клавиатурные команды аналогичны тем, которые используются в тех же целях в текстовых редакторах, например, в MS Word. Однако все перечисленные средства навигации для HTML-издания недостаточно эффективны.

Основное средство навигации - это перемещение по гипертекстовым ссылкам. Для этого в электронном издании должны быть предусмотрены закладки и гиперссылки. Как поместить в текст (и не только в текст) документа такие элементы, было подробно рассмотрено во второй и четвертой главах этой книги. Продуманная система создания в документе гиперссылок обеспечит надежную и эффективную систему навигации в нем. Кстати, в браузере предусмотрена возможность перемещения по гиперссылкам с помощью клавиатуры. Так, нажатие клавиши <ТаЬ> переместит курсор к следующей гиперссылке внутри издания, а совместное нажатие <Shift> и <ТаЬ> - возвратит курсор к предыдущей.

Еще одним эффективным способом перемещения служит контекстный поиск. Для контекстного поиска в документе служит команда «Найти на этой странице» секции меню «Правка», показанная на рис. 5.10 Рис. 05.10.. Команда генерирует диалоговое окно «Поиск», в котором, как показано на рис. 5.11 Рис. 05.11., задается контекст, т. е. последовательность символов, подлежащая поиску. Последовательность символов вводится в строку «Найти». Опция «Слово целиком» позволяет определить, является ли введенная последовательность символов отдельным словом (опция задействована) или же может входить частью в другое слово (опция неактивна). Последовательность символов может быть с учетом регистра, что задается соответствующей опцией. Наконец, направление поиска может быть задано переключателем «Вверх», к началу документа, или же «Вниз», т. е. к его концу. После ввода символов активизируется кнопка «Найти далее», с помощью которой можно начать процесс поиска или продолжить его, чтобы еще раз попытаться обнаружить искомую последовательность символов или слов в тексте.

5.3.3.
Основные команды меню браузера

Рассмотрим последовательно характерные команды браузера Internet Explorer. Начнем с секции меню «Файл». Большинство команд этой секции подобны командам одноименной секции других программ, работающих под Windows. Команда «Открыть» позволяет загрузить в рабочее окно браузера документ с локального диска на компьютере пользователя или Web-страницу из сети (альтернативный вариант загрузке, с помощью адресной строки). Диалоговое «Открыть» представлено на рис. 5.12 Рис. 05.12..

В нем, в строке «Открыть», таким же образом, как и в адресной строке, можно задать сетевой адрес (URL) Web-страницы или указать абсолютный адрес документа (путь к нему) на одном из локальных дисков компьютера пользователя. В последнем случае, если путь неизвестен пользователю, следует нажать кнопку «Обзор» и в новом диалоговом окне «Microsoft Internet Explorer», которое показано на том же рис. 5.12 Рис. 05.12., задать тип файла в нижней строке и, просматривая диски и папки, найти и указать нужный. После нажатия на кнопку «Открыть» в нижнем окне последнее закроется, а полный путь к выбранному файлу появится в строке «Открыть» одноименного диалогового окна. После щелчка по кнопке «ОК» документ будет открыт в рабочем окне браузера.

При длительной работе с сетевым документом предпочтительнее сохранить его на локальном диске и в дальнейшем использовать его в автономном режиме работы компьютера. Эта операция выполняется с помощью команды «Сохранить как», которая выводит диалоговое окно «Сохранение Web-страницы» (рис. 5.13 Рис. 05.13. и рис. 5.14 Рис. 05.14.). При сохранении документа на локальном диске следует выбрать папку, в которой будет сохранен документ, и задать вариант сохранения, который зависит от того, как предполагается использовать документ в дальнейшем.

Варианты сохранения видны в раскрытом списке на рис. 5.13 Рис. 05.13.. При сохранении Web-страницы полностью запоминается как основной текстовый файл в формате HTML, так и все дополнительные элементы, вложенные в него, а именно: таблицы стилей, рисунки, мультимедийные элементы. При этом все перечисленные дополнительные элементы сохраняются в отдельной папке, вложенной в ту папку, где сохранен основной документ.

Если мы сохраняем в режиме «Веб-страница, только HTML (*.htm, *.html)», то сохраняется только текст в указанном формате, а все дополнительные элементы утрачиваются, т. е. помимо текста сохраняются все HTML-теги и возможность гипертекстовых переходов. Сохранив «Только текстовый файл (*.txt)», мы оставим только сам текст, который может в дальнейшем просматриваться и обрабатываться с помощью текстовых редакторов. Имеется и дополнительная возможность сохранения документа в формате архива электронной почты, который не представляет интереса сточки зрения электронных изданий.

На рис. 5.14 Рис. 05.14. представлен вариант того же диалогового окна, но уже с раскрытым списком «Вида кодировки» сохраняемого файла. Здесь уместно пояснить, что под кодировкой понимается таблица, в которой каждому символу сопоставляется определенный двоичный код (для компактности он записывается в 16-тиричной системе счисления). В нашей стране для кодирования кириллицы используется преимущественно таблица Windows-1251 или KOI-8r, KOI-8u применяется значительно реже. Именно эти варианты кодирования указаны в первых строках открытого списка. Первый вариант соответствует кодированию кириллицы в оболочке Windows, а второй - используется в рамках DOS, т. е. дисковой операционной системы. При сохранении файла в большинстве случаев выбирается первый вариант, который и указан по умолчанию.

Кстати, если требуется сохранить текстовый фрагмент электронного издания не в формате HTML, а в текстовом формате, то можно рекомендовать выделить указателем мыши этот фрагмент и командой «Копировать» секции меню «Правка» перенести его копию в буфер обмена Windows, откуда фрагмент будет доступен для вставки в любой текстовый документ. Рисунки, используемые в HTML-документе, также можно сохранить независимо от документа в целом. Для этого следует щелкнуть по рисунку правой кнопкой мыши, вызывая контекстное меню, в котором выбрать команду «Сохранить как». В появившемся диалоговом окне (рис. 5.15 Рис. 05.15.) выбирается каталог, в котором будет сохранен файл изображения. Изображение может быть сохранено в исходном формате, т. е. в GIF или JPEG, или в формате BMP.

Из команд секции меню «Вид», помимо рассмотренных в начале данного параграфа, интерес с точки зрения пользователя представляет «Шрифты». С ее помощью можно менять размер всех шрифтовых элементов документа одновременно от очень крупного до очень мелкого. Соответствующая команда и ее варианты показаны на рис. 5.16 Рис. 05.16..

На рис. 5.17 Рис. 05.17. показаны варианты следующей команды той же секции меню, а именно «Вид кодировки». С ее помощью можно попытаться вывести документы в должном виде в том случае, если браузер не сумел автоматически определить вид кодировки загружаемого документа (вариант «Автоматический выбор»). На рисунке показаны лишь разновидности кодировок, относящиеся преимущественно к шрифтам кириллицы. Однако выбрав вариант «Дополнительно», мы получим еще свыше двадцати различных вариантов кодировок.

5.3.4.
Ведение журнала обозревателя и команды других секций меню

Журналом обозревателя в пакете MS Internet Explorer называется регистратор ссылок на просмотренные в предыдущих сеансах страницы и сайты. Кнопка «Журнал», предназначенная для вызова журнала обозревателя, имеется на панели «Обычные кнопки», которая показана на рис. 5.3 Рис. 05.03.. При нажатии этой кнопки слева в рабочем окне браузера появляется дополнительная панель «Журнал»с кнопками «Вид» и «Поиск» (см. рис. 5.18 Рис. 05.18.). Ниже в журнале показаны ссылки, отсортированные в хронологическом порядке и представленные в виде иерархической структуры. Открыт список ссылкой, озаглавленной «2 недели назад».

Для упорядочения ссылок по другому признаку следует щелкнуть указателем мыши по кнопке «Вид» (стрелка, направленная вниз, свидетельствует о наличии выпадающего меню). Изменения интерфейса, возникающие в результате этого действия, показаны на рис. 5.19 Рис. 05.19.. Как следует из представленных данных, ссылки могут быть упорядочены не только по дате, но и по узлу (т. е. по имени Web-узла), по посещаемости (частоте посещений страниц, узлов и файлов) и по порядку посещения.

Отметим, что выбор любой ссылки из их перечня в журнале, приведет к отображению соответствующего документа в окне просмотра браузера. Так, на рис. 5.20 Рис. 05.20. выбрана ссылка CNN.com Europe (она отмечена в журнале темно-серым), а соответствующая этой ссылке Web-страница показана в окне просмотра. Кстати, в адресной строке указан адрес этой Web-страницы. Пример показывает, что действительно использование ссылок, хранимых в журнале, существенно упрощает процесс просмотра ранее загруженных из сети страниц, но теперь уже в автономном режиме.

Наконец, рис. 5.18 Рис. 05.18. и рис. 5.19 Рис. 05.19. показывают, что при большом количестве ссылок, возможно организовать поиск нужной из них. Для этого надо нажать кнопку «Поиск» в верхней части панели «Журнал» и в диалоговом окне, показанном на рис. 5.20 Рис. 05.20., ввести символы, которые следует найти. В примере на рис. 5.20 Рис. 05.20. в строку поиска введено выражение «cnn.com», а ниже, под кнопкой «Искать», показаны 5 Web-страниц, имена которых содержат искомое выражение. Выбрана одна из этих страниц, которая и отображается в окне просмотра браузера.

Панель «Журнал» может быть вызвана с помощью команды, которая, как показано на рис. 5.21 Рис. 05.21., инициируется из секции меню «Вид» командой «Панели обозревателя». Из других команд, показанных на рис. 5.21 Рис. 05.21., можно отметить «Поиск» и «Избранное», дублирующие действие соответствующих кнопок панели инструментов «Обычные кнопки». Действие команды «Папки», соответствующая панель которой также показана на рис. 5.21 Рис. 05.21., похоже на режим «Проводник», представленный на рис. 5.9 Рис. 05.09. в § 5.3.1. Наконец, команда «Полезный совет», также задействованная на рис. 5.21 Рис. 05.21., формирует в нижней части рабочего окна Explorer'a одноименную панель, в которой под рубрикой «Знаете ли Вы, что», демонстрируются различные полезные советы, в основном, достаточно тривиальные, которые связаны друге другом последовательными ссылками, позволяющими перемещаться от одного совета к следующему.

Секция меню «Избранное» позволяет пользователю возвращаться и работать с заранее отобранной информацией, что иллюстрируется содержащимися в ней командами, показанными на рис. 5.22 Рис. 05.22.. В частности, в избранное можно добавить новую информацию и избранное можно упорядочить. Само избранное уже определенным образом классифицируется с помощью папок и вложенных в них других папок, что также показано на рис. 5.22 Рис. 05.22.. В частности, в папках «Imported Bookmark»/«Search» содержатся ссылки на основные зарубежные поисковые серверы: Altavista, Excite, Infoseek, Lycos и другие. В нижней части рис. 5.22 Рис. 05.22. показана также панель «Полезные советы» («Знаете ли Вы, что...»).

В секции меню «Сервис», как показано на рис. 5.23 Рис. 05.23., с помощью команды «Почта и новости» можно прочитать сообщения, поступившие на Ваш адрес по электронной почте. Кроме того, создать и отправить сообщение по нужному электронному адресу, а также отправить электронное письмо, содержащее ссылку или просматриваемую страницу целиком.

В этой же секции меню расположена важная команда «Свойства обозревателя», позволяющая настроить данный программный пакет или же изменить начальные установки значений параметров. Соответствующее этой команде диалоговое окно показано на рис. 5.24 Рис. 05.24. шести в левой части рабочего окна программы Explorer. Диалоговое окно состоит из шести вкладок, наибольший интерес из которых представляет открытая на рис. 5.24 Рис. 05.24. вкладка «Общие». На вкладке имеются три различные зоны и несколько исполнительных кнопок. Остановимся более детально на размещенных во вкладке «Общие» элементах.

В ее верхней части размещается зона «Домашняя страница», с помощью которой можно установить адрес страницы, которая будет выводиться при начальной загрузке пакета. В следующей зоне «Временные файлы Интернета» устанавливается местоположение (адрес) папки на локальном диске, где будут временно храниться загружаемые из сети Web-страницы, что позволит просматривать их в автономном режиме. Если нет необходимости хранить какую-либо страницу далее, то с помощью кнопки «Удалить» можно уничтожить соответствующий HTML-файл и все приложения к нему, которые хранятся в отдельной папке.

В нижней части окна размещается третья зона, называемая «Журнал». В ней можно установить длительность хранения ссылок в журнале или удалить из журнала некоторые или все ссылки с помощью кнопки «Очистить». Еще ниже помещаются четыре кнопки - «Цвета», «Шрифты», «Языки» и «Оформление», которые управляют внешним видом выводимой страницы. Так, кнопка «Цвета» позволяет установить цвет основного текста, исходные цвета ссылок и цвет просмотренной ссылки.

Кнопка «Шрифты» представляет особый интерес, поэтому на рис. 5.24 Рис. 05.24. показано справа в рабочем окне Explorer'a соответствующее ей диалоговое окно. В нем можно задать шрифтовую гарнитуру для той Web-страницы, в которой исходно она не была определена. В частности, в примере указано, что будет использоваться кириллица (т. е. символы алфавита русского языка) и гарнитура Times New Roman для основного текста Web-страницы и Courier New - для отображения других текстовых элементов.

Кнопка «Языки» инициирует диалоговое окно «Выбор языка», представленное на рис. 5.25 Рис. 05.25.. С его помощью можно выбрать один или несколько языков, на одном (или нескольких) из которых будет отображаться содержимое Web-страницы. С помощью кнопки «Добавить» можно включить в список один или несколько дополнительных языков, выбрав их из другого диалогового окна-«Добавление языка», которое инициируется кнопкой «Добавить». Окно «Добавление языка»также представлено на рис. 5.25 Рис. 05.25.. Другая кнопка - «Изменить», позволяет задать другой язык для отображения команд меню и содержимого диалоговых окон. По умолчанию в качестве такого языка в пакете выбран русский.

Если нажать на кнопку «Оформление» в нижней части диалогового окна «Свойства обозревателя» - вкладка «Общие» (рис. 5.24 Рис. 05.24.), то получим одноименное диалоговое окно, показанное на рис. 5.26 Рис. 05.26.. Содержимое окна делится на две части. В верхней части, названной «Стиль Web-страницы», сделав соответствующие установки, можно не учитывать:

  • цвета, установленные на странице;

  • гарнитуры;

  • размеры (кегли) шрифтовых элементов, представленных на Web-странице.

С помощью фрагмента в нижней части диалогового окна можно задать пользовательский стиль оформления страницы. Для этого с помощью кнопки «Обзор» надо выбрать нужные стили оформления различных элементов страницы, например заголовков различного уровня, абзацев текста, и указать их в списке стилей пользователя.

Конечно, все изложенное в этом разделе не может претендовать на исчерпывающее описание MS Internet Explorer'a. Для этого потребовалось бы не менее двух-трех глав текста и еще в несколько раз большее количество рисунков. В рамках данного учебника автор ставил себе задачу привести лишь поверхностное описание работы пакета. Для тех, кто желает глубже изучить его работу и профессионально овладеть методикой и технологией работы в нем, автор рекомендует обратиться к специальным изданиям, посвященных MS Internet Explorer'y.

5.4.
Программные средства для работы с электронными изданиями в PDF-формате

Ранее уже говорилось, что достоинства и недостатки PDF (Portable Document Format) PDF-формата связаны с жестким форматированием документов, подготовленных в этом формате. Именно по этой причине формат идеально подходит для представления официальных документов. Широко используется такой формат и для подготовки отчетов и описаний, в том числе - и программных продуктов. Распространяются такие электронные издания чаще на компакт-и DVD-дисках. Основным средством просмотра таких изданий служит программный продукт фирмы Adobe Systems Adobe - Acrobat Reader.

Этот редактор обеспечивает самый простой, надежный и эффективный способ обмена информацией в электронном виде. Acrobat позволит вам преобразовать любой документ в файл формата PDF, сохранив его исходный вид, а затем распространять его для просмотра или печати в любой системе. Мощные инструменты разметки позволяют моментально просматривать электронные документы, и поэтому ваша работа с ними будет более простой и продуктивной, чем когда бы то ни было.

Чрезвычайно привлекательно выглядит возможность создать точно такую же PDF-форму, как и на бумаге, но при этом снабдить ее кнопками, текстовыми полями и всплывающими окнами. Пользователи Acrobat Reader могут заполнять такие формы и отправлять их через Internet, а пользователи Adobe Acrobat 4.0 могут сохранять их у себя на диске для последующего заполнения и отправки в удобное время. Интерфейс Acrobat Reader показан на рис. 5.27 Рис. 05.27..

Имеется возможность просматривать и распечатывать PDF-файлы с любого компьютера, используя бесплатный Acrobat Reader. Небольшой размер PDF-фалов, в некоторых случаях даже меньше чем у оригинала, позволяет загружать страницы по сети достаточно быстро.

PDF-файлы хранят информацию в графической форме. Они содержат все шрифты, форматирование и данные об изображениях, необходимые для печати, при этом конечному пользователю не нужно иметь все те приложения и шрифты, при помощи которых создан PDF-файл.

5.5.
Программные средства для воспроизведения аудиофайлов

Ранее уже упоминалось, что первые версии браузеров не содержали встроенных средств для воспроизведения звука. Netscape Navigator первый стал поставляться вместе со вспомогательным приложением NAPIayer, которое работало с аудио-форматами AU, SND и AIF. Начиная с версии 3.0, его заменил подключаемый модуль LiveAudio, который, помимо перечисленных, поддерживает стандарт звуковых файлов Windows WAV и формат электронных музыкальных инструментов MIDI.

Если на Web-странице находится звуковой файл одного из перечисленных выше форматов, модуль LiveAudio выводит в рабочем окне браузера свою консоль управления. Кнопки управления («Останов», «Воспроизведение» и «Пауза») и линейка - регулятор громкости подобны органам управления обычного аудиоплейера. Контекстное меню позволяет дублировать органы управления звуком.

В браузере MS Internet Explorer для прослушивания звуковых файлов используется встроенное вспомогательное приложение MS ActiveMovie, работающее как его составная часть. Это приложение предоставляет еще больше возможностей по управлению прослушиванием звуковых файлов. В частности, можно задать число прослушиваний фонограммы. Еще более интересная возможность состоит в наложении исполнения нескольких звуковых файлов друг на друга, создав с помощью консоли управления что-то подобное микшерскому пульту. В LiveAudio возможность наложения предусмотрена только для одного из файлов с оцифрованным звуком и файла типа MIDI.

Существуют специальные модули для воспроизведения музыки в формате MIDI. В частности, широко известен модуль Crescendo фирмы LiveUpdate LiveUpdate, который может быть скопирован со страницы www.liveupdate.com/midi.html. Модуль запускается автоматически и работает без контрольной панели. Более совершенная версия Crescendo Plus создает в окне браузера панель управления и обеспечивает работу в реальном масштабе времени, т. е. начинает воспроизведение не дожидаясь окончания загрузки аудио файла. Кстати, на сервере 300-летия Санкт-Петербурга (www.300.spb.ru) хранится в формате MIDI «Гимн великому городу» Р. М. Глиэра. На сайте www.midi.ru все музыкальные произведения хранятся именно в этом формате.

Звуковые сообщения могут быть сжаты значительно сильнее, чем предусмотрено стандартными форматами AU, WAV и MIDI, при сохранении хорошей разборчивости речи. Для воспроизведения речевых сообщений разработано несколько специальных модулей, в частности, EchoSpeech и TrueSpeech. Для первого из них предусмотрена скорость передачи данных в 9,6 кбит/с. Кодирование речи осуществляется специальной программой Speech Coder, которая может быть загружена с сайта www.echospeech.com.

Модуль TrueSpeech хранит речь в собственном внутреннем формате и требует пропускную способность канала около 8 кбит/с. В состав Windows входит кодер/декодер для этого формата, что позволяет конвертировать в него звук с помощью стандартного приложения Фонограф (Sound Recorder). Дополнительная информация об этом речевом формате может быть получена с сайта фирмы DSP Group: www.dspg.com.

В последние годы все более актуальной становится задача проведения в рамках сети Интернет аудиоконференций и организации вещания радиостанций в реальном масштабе времени. В частности, в § 5.3 отмечалось, что браузер MS Internet Explorer 5.0 поддерживает такую функцию. Технология RealAudio фирмы RealNetworks RealNetworks первой предоставила возможность передачи любых звуковых файлов в реальном масштабе времени (www.real.com). Процедура сжатия (кодирования) связана с частичной потерей информации, что воспринимается слушателем как дополнительный шум. Кроме того, для передачи звуковых данных используется протокол UDP (а не TCP), который не предусматривает контроль ошибок и повторную передачу кадров, в которых обнаружены ошибки. Повтор привел бы к задержке передачи потока данных, в то время как на отдельные ошибочные биты ухо слушателя практически не реагирует.

Для воспроизведения звуковых файлов в рамках этой технологии используется программа-плейер, названная RealPlayer G2, которая может быть загружена с упомянутого выше сайта. Программа поставляется в виде самораспаковывающегося файла, включающего как собственно плейер, так и подключаемые к браузерам модули. Внешний вид консоли управления этой программы показан на рис. 5.28 Рис. 05.28..

Ранее, в главе третьей, уже упоминалось, что высокое качество цифрового кодирования звука обеспечивает известный формат МРЗ. Для воспроизведения файлов этого формата существует большое количество аудиоплейеров, причем большая их часть может быть получена на сайте www.dailymp3.com. Безусловным лидером среди программ этой группы является Winamp (Windows Audio Mpeg Player). Как следует из самого названия, программа Winamp устанавливается в среде Windows и служит для воспроизведения звуковых файлов в самых различных форматах (МРЗ, WAV, MIDI и многих других). Таким образом, Winamp вполне можно назвать универсальным аудиоплейером. Для качественного воспроизведения формата МРЗ рекомендуется аппаратное обеспечение не ниже Pentium'a. Сведения о новых разработках в части этого формата можно получить на официальном сайте www.winamp.com и появившемся сравнительно недавно сайте www.winamp.ru.

Количество версий программы Winamp весьма велико. Был период, когда новые версии появлялись каждые две недели. Можно отметить лишь определенные вехи на пути развития программы. Так, версия 1.92 характеризует рождение нового качества, так как начиная с нее в программу включен новый декодер Nitrane 1.0, обеспечивающий поддержку технологий ММХ на платформе Intel и 3DNow! на платформе AMD. Летом 1999 г. появился модуль русификации программы Russian.Ing, который существует в трех вариантах: для версии 2.10, для группы версий 2.2х и для версий 2.5х.

Окно управления программой для версии 2.7, интегрированной в Communicator 4.75, представлено на рис. 5.29 Рис. 05.29.. Окно распадается на три очевидные части: собственно управление проигрыванием, окно эквалайзера и окно списка воспроизводимых звуковых файлов. Эти окна могут быть объединены в одно целое в произвольном порядке и вместе перемещаться в пределах экрана или же, каждое в отдельности, помещаться на различных участках экрана. Рассмотрим каждую из перечисленных частей рабочего окна программы.

Собственно окно проигрывателя содержит вверху слева окно хронометража и спектральных характеристик воспроизводимого файла. Правее размещена строка с информацией о воспроизводимом файле. Еще ниже указывается битрейт (необходимая скорость передачи) воспроизводимого файла и рабочая частота оцифровки. Еще ниже справа размещается ползунок воспроизводимого места в аудио файле, затем - настройка стереобаланса и кнопки включения / выключения окон эквалайзера и списка воспроизводимых файлов. Кстати, чтобы включить дополнительный файл в список достаточно перетянуть его указателем мыши в окно проигрывателя Winamp. Еще ниже находится регулировка громкости воспроизведения.

Самая нижняя строка окна проигрывателя содержит набор кнопок управления, расположенных в следующем порядке (слева направо): переход к предыдущему звуковому файлу (Previos Track), воспроизведение, пауза, останов, переход к следующему файлу по списку (Next Track), выбор нового файла или группы файлов (Eject). В этом же ряду расположены две кнопки-переключателя Shuffle и Repeat и кнопка About. При включении кнопка Shuffle обеспечивает воспроизведение файлов из списка в случайном порядке, в противном случае они проигрываются подряд, в списочном порядке. Нажатие кнопки Repeat обеспечит бесконечный цикл воспроизведения. Кнопка About выводит сообщение о самой программе.

В отдельном окне расположен десяти полосный эквалайзер, позволяющий настроить частотную характеристику звукового канала в соответствии с желанием пользователя. Полоса регулируемых частот простирается от 60 Гц до 16 кГц. Здесь же можно добавить предварительное усиление сигнала.

Еще ниже показано окно списка воспроизводимых аудиофайлов, снабженное слайдером в тех случаях, когда размер списка превышает возможности окна в части размещения нужного числа его элементов. Под списком размещаются кнопки для добавления или исключения отдельных элементов из списка, а также сведения по общей длительности звучания всех элементов списка и времени, прошедшем с начала воспроизведения. Если выполнить двойной щелчок по строчке с информацией о текущей фонограмме в окне управления воспроизведением, то на экране будет показано диалоговое окно с информацией о звуковом файле и окно редактора для задания дополнительных параметров. Все перечисленное показано на рис. 5.30 Рис. 05.30..


Электронные издания:

6.
глава VI. Подготовка сетевых и мультимедийных изданий в специализированных программных пакетах

Вопросы, рассматриваемые в данной главе, являются логическим продолжением тех, которые были затронуты в главе 4. Однако, если в четвертой главе рассматривались общие вопросы создания электронных изданий в формате HTML и PDF и дополнение основной части электронной книги теми или иными анимационными и мультимедийными компонентами, то в этой главе основное внимание уделено процессам создания электронной книги, которая может быть названа специализированной с точки зрения ее формы. Основное внимание уделено подготовке сетевого электронного издания в форме сайта в пакетах MS FrontPage 2000 и Macromedia Dream Weaver и мультимедийных изданий в различных пакетах фирмы Macromedia (Director и Flash). Рассмотрена также подготовка анимационных фрагментов в пакете 3D Studio MAX.

6.1.
Общая характеристика пакета MS FrontPage 2000

Программный пакет FrontPage долгое время развивался и совершенствовался фирмой Microsoft Microsoft. Последняя его версия FrontPage 2000 отличается от всех предыдущих тем, что она интегрирована в структуру Microsoft Office. Вероятно, это объясняется тем обстоятельством, что проектирование Web-сайтов и мультимедийных электронных изданий из задачи для профессионалов перешло в сферу офисной деятельности.

Ранее, в четвертой главе, уже указывалось, что электронные издания можно подготавливать в пакете MS Word 2000, что является одной из вспомогательных функций в последнем. В отличие от этого FrontPage 2000 специализирован на подготовке электронных изданий, в частности, на разработке Web-узлов целиком. Он поддерживает фреймовую структуру, ориентирован на простоту и удобство создания гиперссылок, обеспечивает единый стиль оформления различных Web-страниц, оптимизирует скорость их за грузки. Таким образом, пакет отличается продуманностью реализации как эстетических, так и технических аспектов создания электронных изданий и позволяет автоматизировать процесс проектирования.

6.1.1.
Интерфейс пакета

Интерфейс пакета существенно отличается от других приложений Microsoft Office, хотя выдержан единый стиль его оформления. Как показано на рис. 6.1 Рис. 06.01., верхние четыре строки похожи на интерфейсы других приложений: в верхней строке содержится заголовок документа, однако с указанием абсолютного пути к файлу, затем следует строка меню, еще ниже размещаются две панели инструментов и основное место занимает рабочее окно программы. Меню отличается наличием трех специальных секций: Tools (Инструменты), Table (Таблица) и Frames (Фреймы). Назначение этих секций понятно из названий, а об их практическом использовании мы поговорим позднее. Панели инструментов схожи с аналогичными в пакете Word 97 в режиме HTML-редактора. Назначение и использование отдельных инструментов будет рассмотрено далее.

Вначале же остановимся на особенностях рабочего окна программы. Как следует из рис. 6.1 Рис. 06.01., это окно делится по вертикали на три части, размер которых можно регулировать стандартными средствами оболочки Windows. Слева размещается панель переключателя режимов (Views). С помощью представленных в ней кнопок можно выбрать один из вариантов представления Web-узла (Электронного издания). В панели «Список папок» (Folder List) показана иерархическая структура папок и файлов, входящих в состав издания. Основную часть рабочего окна занимает «Панель представления», в которой отображается выбранный элемент структуры Web-узла, обычно одна из Web-страниц, которая входит в состав данного узла.

Рассмотрим вначале варианты представления Web-узла.

  • Режим страницы (Page). В примере на рис. 6.1 Рис. 06.01. нажата именно эта кнопка. В таком режиме можно редактировать любую выбранную страницу электронного издания, изменять размещенный на ней текст и рисунки, вводить новые HTML-теги, задавать новые и редактировать имеющиеся гиперссылки. Для переключения режимов просмотра страницы в нижней части панели представления имеются три вкладки: Normal, HTML и Preview.

  • Кнопка «Folders» («Папки») включает режим анализа структуры папок и файлов, входящих в Web-узел. Этот режим подобен просмотру структуры локальных дисков, определяемому «Проводником» в оболочке Windows.

  • В режиме «Reports» («Отчеты») в рабочем окне представлен отчет о текущем состоянии Web-узла.

  • Кнопка «Navigation» («Навигация») отображает в рабочем окне программы структуру издания со всем разнообразием гиперссылок, позволяющих перемещаться как внутри данного Web-узла, так и на страницы других узлов.

  • Кнопка «Hyperlinks» («Гиперссылки») в графической форме представляет все гиперссылки, переводящие на текущую страницу, и с текущей страницы на другие страницы узла.

  • Наконец, кнопка «Tasks» («Задачи») переводит рабочее окно в режим, напоминающий записную книжку. В нем в рабочем окне отображается список задач, намеченный пользователем для выполнения в будущем.

В следующей панели показана структура в форме дерева папок и файлов, составляющих Web-узел. В панели же представления, как уже рассматривалось выше, отображается выбранный элемент Web-узла в одном из способов представления, определяемом выбранной вкладкой в нижней части панели (на рис. 6.1 Рис. 06.01. активна вкладка Normal).

Важной составной частью интерфейса пакета являются панели инструментов. Первые две из них: «Стандартная» и «Форматирование» - используются по умолчанию и, в основном, подобны аналогичным панелям инструментов в других пакетах, входящих в состав MS Office. Это относится к инструментам «Создать», «Открыть», «Сохранить», «Печать», «Проверка орфографии», «Вырезать», «Скопировать», «Вклеить», «Отменить», «Повторить», «Отобразить непечатные символы», «Помощь» панели «Стандартная». Действие всех перечисленных инструментов дублируется командами секций меню.

Из специализированных инструментов этой панели следует отметить кнопку «Web-публикация», расположенную правее кнопки «Сохранить». Этот инструмент осуществляет публикацию разработанного Web-узла в сети по определенному адресу. Правее на рис. 6.1 Рис. 06.01. расположен активный инструмент «Список файлов и папок» или «Folder List». Нажатой кнопке соответствует наличие соответствующей панели в рабочем окне программы. Правее инструмента «Печать» расположен «Предварительный просмотр в браузере».

Перед стандартным инструментом «Таблица» находится кнопка «Вставить компонент», расположенный рядом с которой черный треугольник показывает наличие нескольких вариантов этого инструмента, которые становятся доступными при его активизации. Соответствующие возможности вставки компонентов иллюстрируются данными, представленными на рис. 6.2 Рис. 06.02.. В качестве простых примеров можно указать вставку «Бегущей строки» («Marquee»), «Поля подтверждения» («Confirmation Field») и «Содержания» («Table of Contents»).

На том же рис. 6.2 Рис. 06.02. виден инструмент «Таблица», предназначенный для размещения соответствующего элемента на Web-странице. Далее следует кнопка «Вставить рисунок из файла», назначение которой понятно из названия, и «Гиперсвязи», предназначенная для включения указателей гиперссылок. Два последующих инструмента: «Обновить» и «Остановить», используются в браузерах и их назначение мы уже рассматривали в четвертой главе.

Другие панели инструментов могут быть выведены на экран с помощью команды «Панели инструментов» (Toolbar) секции меню «Вид» (View), представленной на рис. 6.3 Рис. 06.03.. Вместе с уже рассмотренными общее количество панелей инструментов равно девяти. Перечислим эти панели с указанием их назначения:

  • эффекты динамического HTML (DHTML Effects). Эта панель обеспечивает добавление соответствующих эффектов с помощью своих инструментов. Сам термин используется для обозначения HTML-страниц с динамически изменяемым содержимым, о чем более подробно будет сказано ниже, при рассмотрении инструментов панели;

  • рисование (Pictures). Панель служит для создания и редактирования графических изображений;

  • размещение (Positioning). Служит для изменения положения элементов на проектируемой Web-странице;

  • стиль (Style). Служит для стилевого оформления элементов Web- страницы;

  • отчеты (Reporting). Эта панель инструментов служит для управления отчетами о состоянии Web-узла;

  • навигация (Navigation). Инструменты этой панели обеспечивают работу в режиме навигации (см. соответствующая кнопка в панели Views в левой части рабочего окна на рис. 6.1 Рис. 06.01..);

  • таблицы (Tables). Эта панель объединяет инструменты, предназначенные для создания и работы с таблицами.

Панель «Рисование» значительно отличается от аналогичной в пакете MS Word 2000. Это подтверждает даже простое перечисление используемых в ней инструментов. На рис. 6.4 Рис. 06.04. активизирован рисунок на Web-странице, в результате чего активными стали инструменты панели «Рисование», которая размещена в нижней части рабочего окна пакета. Первый инструмент дублирует имеющуюся в панели «Стандартные» кнопку «Вставить рисунок из файла». Нажатие ее приводит к появлению диалогового окна, в котором и осуществляется выбор графического файла.

Инструмент «Текст» позволяет сделать подпись к рисунку, а третий - «Указатель ссылки» (Autothumb Nail) - создать стрелку-указатель ссылки. Четвертый инструмент позволяет задать положение рисунка на Web-странице в абсолютных координатах. Следующие две кнопки выполняют стандартные функции - «Поместить наверх» (Bring Forward) и поместить назад (Send Backward), т. е. меняют содержимое переднего и заднего плана графической композиции. Подобные инструменты имеются не только во всех графических редакторах, но также и в текстовом редакторе Word.

Группа из следующих четырех кнопок характерна для редакторов векторной графики. Это «Поворот влево» (Rotate Left), «Поворот вправо» (Rotate Right), «Отражение горизонтальное» (Flip Horizontal) и «Отражение вертикальное» (Flip Vertical), т. е. от зеркала, ориентированного вдоль вертикали или горизонтали соответственно.

Следующая группа из четырех кнопок обеспечивает простые операции, связанные с тоновой коррекцией рисунка. Это «Увеличить контраст» (More Contrast), «Уменьшить контраст» (Less Contrast), «Увеличить яркость» (More Brightness) и «Уменьшить яркость» (Less Brightness).

Далее размещается группа из шести инструментов, предназначенных для обработки иллюстраций: «Кадрирование» (Crop), «Установка прозрачного цвета» (Set Transparent Color), «Преобразовать в черно-белый рисунок» (Black And White), «Осветление» (Wash out), «Наклон» (Bevel) и (Resample).

В следующей группе содержатся пять инструментов: «Выбор» (Select), (Rectangular Hotspots), (Circular Hotspots), (Poligonal Hotspots), (Highlight Hotspots). Наконец, последний инструмент «Восстановить» (Restore) позволяет отменить преобразование, сделанное с помощью предыдущего инструмента.

6.1.2.
Технология подготовки новых Web-сайтов

Как уже говорилось ранее, для просмотра структуры Web-узла следует перейти в режим «Навигация», щелкнув указателем мыши по соответствующей кнопке в панели View. В результате «Панель представления» примет вид, показанный на рис. 6.5 Рис. 06.05.. Иерархическая структура организации страниц Web-узла соответствует их логической организации или соподчиненное™. Логическая структура связана с именами отдельных страниц сайта, которые обычно не совпадают с именами соответствующих HTML-файлов. В частности, в приведенном примере роль начальной или домашней страницы играет страница Index, на которой размещены ссылки на все другие страницы. Ее внешний вид представлен на рис. 6.6 Рис. 06.06..

Для того чтобы добавить в структуру логического узла новую страницу, надо вначале определить страницу-родителя (Parent Page), щелкнув по ней указателем мыши. Затем выбирается в секции меню «Файл» команда «Создать» (New) и подкоманда «Страница» (Page). Новые страницы создаются со стандартными именами, поэтому их целесообразно переименовать таким образом, чтобы имена соответствовали назначению страницы. В частности, на рис. 6.7 Рис. 06.07. представлена структура сайта с двумя дополнительными страницами. Первая из них подчинена странице «Что_такое», которая описывает особенности электронных изданий. Она посвящена описанию форматов и носит имя Formats. Вторая подчинена странице Institute и носит название Sec-Edu, так как на ней описываются услуги, оказываемые в Институте Печати по получению второго высшего образования. На рис. 6.7 Рис. 06.07. показана лишь часть интерфейса, точнее,- часть «Панели представления», занятая структурой сайта.

Наряду с общей структурой сайта можно просмотреть и структуру гиперссылок на какой-либо странице сайта. Для этого отображается нужная страница, а затем на панели Views нажимается кнопка Hyperlinks. В частности, на рис. 6.8 Рис. 06.08. показаны гиперсвязи страницы Index. И в этом случае представлена лишь часть «Панели представления», на которой размещаются гиперсвязи между страницами. Приведена также внешняя связь с сайтом фирмы Microsoft.

Если в процессе проектирования общей структуры сайта количество страниц настолько возросло, что они не помещаются по ширине «Панели представления», можно использовать небольшую панель инструментов «Навигация» (Navigation), где имеются инструменты «Масштаб» (Zoom) и «Книга/Альбом» (Portrait / Landscape). Панель вызывается с помощью одноименной подкоманды команды «Панели инструментов» (Toolbars) секции меню «Вид» (View), которая показана на рис. 6.3 Рис. 06.03.. Эти инструменты позволяют рационально разместить в пределах «Панели представления» даже достаточно сложные структуры сайтов. Кстати, те страницы, которые в дальнейшем окажутся бесполезными, можно легко удалить. Для этого в режиме «Навигация» страница выделяется и нажимается клавиша Del.

Следующий этап работы связан с оформлением отдельных Web-страниц. Для этого в панели «Список папок» (Folder List) выбирается одна из созданных страниц и разрабатывается ее дизайн теми же средствами, которые мы рассматривали при изучении HTML-редакторов, работающих в WYSIWYG-режиме. Можно использовать соответствующие инструменты и команды, чтобы поместить на страницу текст, графику, GIF-анимацию, различные звуковые и видеоэлементы. Желающим подробнее изучить и освоить работу в этом программном пакете можно рекомендовать литературные источники ссылка на источники литературы.

Знакомство с этим пакетом показывает, что это утверждение имеет под собой прочную основу. Как уже делалось несколько раз, начнем изучение пакета с его интерфейса.

6.2.
Назначение и общая характеристика пакета Dreamweaver

Программный пакет DreamWeaver, как и FrontPage, предназначен для проектирования различных сайтов, в том числе - сайтов издательств, одной из задач которых является распространение электронных изданий. Он пригоден как для создания небольших, так и очень больших сайтов. В первом случае разработкой занимается единственный специалист- вебмастер. В последнем случае над проектом работает целый коллектив, включающий администратора проекта, веб-дизайнера, HTML-верстальщика, веб-программиста, корректора, менеджера рассылок. Многие специалисты утверждают, что профессиональные Web-дизайнеры в своей работе чаще всего используют Adobe PhotoShop для подготовки графики и Macromedia DreamWeaver для дизайна отдельных Web-страниц.

Знакомство с этим пакетом показывает, что это утверждение имеет под собой прочную основу. Как уже делалось несколько раз, начнем изучение пакета с его интерфейса.

6.2.1.
Интерфейс пакета DreamWeaver

Интерфейс пакета DreamWeaver 4.0 показан на рис. 6.9 Рис. 06.09.. Помимо строки заголовка, строки меню, панели инструментов и стандартного рабочего окна программы отметим наличие нескольких палитр, которые, как и в графических редакторах, размещаются в рабочем окне программы. Кстати, названия открытых трех палитр «Объекты» (Object), «Свойства» (Properties) и «Загрузить» (Launcher) соответствуют первым трем командам секции меню «Окно» (Window).

Данный пакет интегрирован с точки зрения используемых технологий в группу программных продуктов фирмы Macromedia, которая завоевывает все более прочные позиции на рынке средств Web-дизайна. Другие программы этой группы: Macromedia Director и Flash будут рассмотрены в следующих параграфах этой главы. В совокупности они обеспечивают основные направления Web-дизайна, а каждая в отдельности специализирована в одном конкретном направлении.

Вначале остановимся на палитре «Объекты» (Objects), внешний вид которой представлен на рис. 6.10 Рис. 06.10.. Внешний вид палитры изменяется в зависимости от типа объекта, выбранного в списочном окне в ее верхней части, т. е. палитру можно назвать адаптивной. По умолчанию в списке устанавливается позиция «Основные» (Common). На рис. 6.10 Рис. 06.10. в открытом списке выбран именно этот вариант. Эта палитра с помощью 18-ти различных инструментов позволяет включать в состав страницы различные элементы, в частности (по порядку расположения кнопок в палитре): графику (Image), анимированную кнопку (Rollover Image), внешний вид которой изменяется при подведении к ней курсора мыши, таблицу (Table), таблицу с занесенными в нее данными, подготовленными заранее в другом программном пакете (Tabular Data), линейку (Horizontal Rule), навигационную панель (Navigation Bar) с кнопками для перемещения по сайту, новый изобразительный слой (Draw Layer), мягкий перенос (Line Break) в текст, ссылку на электронный адрес (E-mail Link), текущую дату (Оат.е),флеш- (Flash) и шоквэйв- (Shockwave) анимацию, заготовку Generator и объект FireWorks, Java-апплеты и элементы ActiveX, объекты, воспроизводимые с помощью дополнительных модулей (Plag-ins), и внешний HTML-файл (SSI).

Палитра «Шрифтовые элементы» (Characters) позволяет добавить на Web-страницы один из 12-ти различных специальных символов: переход на новую строку, авторского права (копирайт), зарегистрированный торговый знак, денежные знаки, в том числе, фунт стерлингов, иена, евро, а также кавычки, тире и другие знаки (см. рис. 6.11 Рис. 06.11.).

Палитра «Формы» (Forms), показанная на рис. 6.12 Рис. 06.12., служит для создания форм (см. § 2.8) и содержит следующие кнопки: собственно форма (Forms), текстовое поле (Text field), кнопка (Button), переключатели Checkbox и Radio Batton, список/меню (List/menu), поле для передачи файлов (Filefield) и изображений (Imagefield), скрытое поле (Hidden field) и указатель гиперссылки для перехода на другой сайт (Jump menu).

Отметим, что в нижней части всех палитр группы «Объект» предусмотрены поля «Выравнивание» (Layout) и «Просмотр» (View), которые позволяют наблюдать и управлять размещением объектов на Web-странице.

Палитра «Фреймы» (Frames), показанная на рис. 6.13 Рис. 06.13., позволяете помощью соответствующей кнопки выбирать определенный вид фреймовой структуры страницы с двумя, тремя и четырьмя различным образом расположенными фреймами. Общее число вариантов равно восьми.

Палитра «Заголовочная часть» (Head) позволяет добавлять в заголовочную часть HTML-документа соответствующие теги и значения параметров, в том числе: теги метаинформации и ключевые слова, описание сайта, параметры его обновления, значение базовой ссылки (ссылки по умолчанию), ссылки для связей.

Палитра «Невидимые объекты» (Invisibles), показанная на рис. 6.14 Рис. 06.14., позволяет разместить на странице закладки (см. также § 4.2 и § 4.3), сноски и комментарии (см. § 2.5) и Java-скрипты (см. § 2.9).

Последняя палитра, входящая в состав комплексной адаптивной палитры «Объекты», носит название «Специальная» (Special). В ней, как показано на рис. 6.16 Рис. 06.16., имеются три пиктограммы или кнопки, а именно: апплеты, плагины и элементы ActiveX.

6.2.2.
Последовательность проектирования сайта в пакете Dreamweaver

Прежде всего надо тщательно продумать общую структуру сайта, а также структуру каталогов (папок) и размещение в них файлов. В качестве прикладного примера рассмотрим проектирование сайта небольшого издательства. В начале работы следует разместить в корневом каталоге сайта все HTML-файлы и не менее трех подкаталогов, в том числе: каскадных стилей, изображений и каталог с фрагментами текста и отзывами на книги, выпускаемые издательством.

Для непосредственного создания сайта следует предварительно сделать все необходимые установки. С этой целью в секции меню «Редактирование» (Edit) следует выбрать команду «Установки» (Preference). В результате получим диалоговое окно, показанное на рис. 6.17 Рис. 06.17.. Из множества категорий, перечисленных в левой части диалогового окна, следует выбрать позицию «Сайт» (Site). Диалоговое окно несколько изменяет свой внешний вид: в нижней его части появляется кнопка «Определить сайты» (Define Sites). В результате генерируется новое диалоговое окно, показанное на рис. 6.18 Рис. 06.18..

В этом диалоговом окне предлагается выбор из нескольких вариантов: учебный сайт «Уроки» (Lessons), «Руководство» (Tutorial) и «Сайт без названия 1» (Unnamed Site 1). В данном случае естественно выбрать именно последний вариант. После нажатия кнопки «Новый» (New) в правой части диалогового окна, показанного на рис. 6.18 Рис. 06.18., мы получим новое диалоговое окно «Определение параметров сайта без названия», которое представлено на рис. 6.19 Рис. 06.18..

Это диалоговое окно включает в себя пять вкладок, которые перечислены в левой части каждой вкладки. По умолчанию активна первая вкладка «Локальная информация» (Local Info). Поле с тем же названием, расположенное в правой части окна на рис. 6.19 Рис. 06.19., содержит различные установки. Вверху, в строке «Имя сайта» (Site Name) задается соответствующее название сайта. Далее, в поле «Локальный корневой каталог» (Local Root Folder) указывается имя папки, которая будет основной (корневой) для данного сайта. В ней, как уже говорилось, будут размещены HTML-файлы, представляющие исходный код Web-страниц, входящих в состав сайта. Обычно задействуют опцию «Автоматически обновлять список локальных файлов» (Refresh Local Fale List Automatically). Ниже следует задать HTTP-адрес сайта.

Следующая вкладка «Информация о Web-сайте» позволяет выполнить настройку параметров доступа к удаленному серверу, на который будет загружен проектируемый сайт. Соответствующие параметры устанавливаются в правой части окна в поле, имя которого совпадаете категорией, выбранной в левой части окна. Остальные вкладки заполняются аналогичным образом.

Проектирование отдельных страниц сайта производится по той же методике, которая рассматривалась в разделе 6.1 с широким использованием палитр, описанных в § 6.2.1.

6.3.
Подготовка мультимедийных изданий в пакете Macromedia Director

Изначально данный пакет был задуман разработчиком как средство подготовки файлов компьютерной анимации. Однако постепенно он сделался одним из основных средств для разработки мультимедиа-изданий. Пакет базируется на концепции обработки последовательности экранных кадров, причем эта последовательность может быть как линейной, так и произвольной. Для работы с кадрами существует специальное монтажное окно, содержащее всю необходимую информацию о каждом объекте, находящемся в текущем кадре, так и о движении от одного кадра к другому.

В пакете предусмотрено несколько встроенных редакторов для работы с отдельным и видами издательской информации. В частности, имеется текстовый редактор, предоставляющий определенные возможности оформления текстов. Помимо выбора гарнитуры и кегля шрифта, предусмотрены стандартные средства форматирования абзаца, а также кернинг. Возможно преобразование текста в графический объект, что позволяет применить к текстовому блоку стандартные преобразования векторной графики, такие как поворот, наклон и зеркальное отражение. Пакет поддерживает возможность импорта текста в стандартных форматах: TXT, RTF, HTML и пр. Предусмотрена также возможность включения в разрабатываемый проект дополнительных шрифтовых гарнитур и отдельных символов.

Исходная ориентация пакета на компьютерную графику и цифровую анимацию определяет поддержку им практически всех основных форматов графических файлов, включая PSD (см. § 3.4). В пакете предусмотрены два различных графических редактора: растровой и векторной графики, каждый из которых использует отдельные диалоговые окна и работает со своими объектами, т. е. графическими файлами соответствующих форматов.

Ориентация пакета на подготовку мультимедийных изданий определила наличие разнообразных средств для управления кадрами и порядком их следования, создания связей и гиперссылок, контроля свойств объектов. В целом следует отметить, что пакет Director представляет собой чрезвычайно большую систему с сотнями экранов и диалоговых окон, огромным числом различных параметров, команд меню и «быстрых» клавиш.

6.3.1.
Интерфейс пакета Macromedia Director

Интерфейс пакета ориентирован на обработку кадров, для чего предусмотрено специальное монтажное окно, содержащее всю необходимую информацию об отображаемом кадре и последовательности кадров в целом. Сказанное иллюстрируется данными, представленными на рис. 6.20 Рис. 06.20.. Интерфейс содержит строку заголовка, строку меню и панель инструментов, ниже которой расположено рабочее окно программы.

В рабочем окне программы слева показана палитра инструментов, напоминающая аналогичные палитры в пакетах векторной графики. Кроме этой палитры показаны окна, представляющие собой важные компоненты разработки мультимедийного проекта, в частности:

  • окно сцены (stage), в котором производится компоновка элементов мультимедиа-проекта (экран компьютера);

  • окно партитуры (score) -окно, которое представляет структуру мультимедиа-проекта и содержит информацию о каждом объекте, используемом в нем;

  • окно труппы (cast), которое содержит все элементы проекта.

Для общей характеристики пакета определенный интерес представляет также состав панели инструментов. Первые два из них «Создать кадр» (New Movie) и «Создать труппу» (New Cast), позволяют создать соответствующие элементы. Следующие инструменты «Открыть» (Open), «Импорт» (Import), «Сохранить» (Save) и «Сохранить все» (Save All) выполняют стандартные функции, точно такие же, как в других программных пакетах. Инструмент«Опубликовать» (Publish) обеспечивает загрузку издания на выбранный сервер. Группа из четырех инструментов: «Отменить» (Undo), «Вырезать» (Cut), «Копировать» (Сору) и «Вклеить» (Paste) соответствуют стандартным командам в секции меню «Редактирование» или «Правка» в большинстве программных пакетов. Две следующие команды «Найти составляющую окна труппы» (Find Cast Member) и «Заменить составляющую окна труппы» (Exchange Cast Member) выполняют специальные функции, о чем мы поговорим в § 6.3.2. Следующие три инструмента выполняют стандартные функции управления видеомагнитофоном: «Перемотка» (Rewind), «Стоп» (Stop), «Воспроизведение» (Play). Далее, три инструмента инициируют появление окон сцены, партитуры и труппы. Оставшиеся восемь инструментов также связаны с окнами инспекторов, палитр и редакторов: «Окно инспектор свойств» (Property Inspector), «Палитра библиотеки» (Library Palette), «Окно растрового графического редактора» (Paint Window), «Окно векторного графического редактора» (Vector Shape Window), «Окно текстового редактора» (Text Window), «Окно инспектора проекта» (Behavior Inspector), «Окно сценария» (Script Window) и «Окно поручений» (Message Inspector). Назначение большинства инструментов мы рассмотрим в разделе § 6.3.2.

6.3.2.
Основные окна и инспекторы пакета

Для работы с различной информацией существует множество окон, палитр и инспекторов. На рис. 6.21 Рис. 06.21. показан пример такого окна. Одновременно можно открыть несколько «Окон труппы» (Cast), что может позволить работать в каждом окне с однородными объектами.

Для управления структурой кадров в проекте применяется окно партитуры (Score) (рис. 6.22 Рис. 06.22.). Весь проект представляет собой последовательность кадров, причем движение от кадра к кадру может быть как линейным, так и произвольным. Кроме того, можно задавать способы появления кадров и объектов на экране (появление из-за экрана, с масштабированием и т. д.).

По вертикали расположены объекты одного кадра (сначала специальные: временные задержки, палитра, эффекты переходов между кадрами, два звуковых канала, программный код; затем все другие объекты: графические и текстовые). По горизонтали расположены столбцы, означающие кадры проекта. Для размещения объекта в кадре его «перетаскивают» в нужную позицию мышью, и одновременно с этим пакет Director автоматически формирует ссылку на него в окне партитуры (Score). Теперь объект управляется пакетом, здесь можно изменять время его появления на экране относительно других объектов, а также его графические размеры, цвет, положение на экране и т. д. Можно автоматически создавать в пакете серии различных трансформаций.

Инспектор свойств (Property Inspector), показанный на рис. 6.23 Рис. 06.23., представляет собой окно, содержащее четыре тематические «закладки», определяющие различные группы свойств объекта: свойства всего проекта, геометрические свойства объектов и реакции объектов на управление со стороны пользователя.

Кроме основных окон, часть из которых была рассмотрена выше, в пакете существует множество дополнительных окон, связанных с работой различных редакторов. Так, окно текстового редактора (рис. 6.24. Рис. 06.24.) имеет все необходимые средства для редактирования: возможность задания гарнитуры, кегля и начертания шрифта, а также парного кернинга, т. е. изменения расстояния между определенными парами символов. Кроме этого, предусмотрен ряд функций по форматированию абзаца: управление величиной межстрочного интервала (интерлиньяжа), абзацных и других отступов, отбивкой (т. е. величиной осветленного пространства, предшествующего абзацу и следующего после него). К сожалению, в редакторе не предусмотрена возможность задания стилей и управления ими.

Для оперативного управления параметрами текстового блока наряду с текстовым редактором можно использовать «Инспектор текста» (Text inspector), окно которого представлено на рис. 6.25 Рис. 06.25.. Инспектор текста, в частности, позволяет легко и удобно вставлять в текстовый блок гиперссылки.

В пакете Director предусмотрен редактор растровой графики (рис. 6.26 Рис. 06.26.), обладающий широкими возможностями. Наряду с типичными инструментами для растровой графики, присутствуют и некоторые инструменты для векторной. В редакторе возможна подготовка графических примитивов, выполнение простых и градиентных заливок, выделение областей, в том числе и по признаку цветового тона (таким же образом, как в редакторе PhotoShop). Редактор выполняет масштабные преобразования и даже позволяет изменить глубину цвета изображения.

В пакете Director не предусмотрен экспорт отдельных изображений в файл какого либо графического формата, возможен только экспорт одного или нескольких экранов проекта в файлы формата BMP.

Кроме редактора растровой графики в пакете Director существует редактор векторной графики (рис. 6.27 Рис. 06.27.), который позволяет рисовать различные векторные примитивы: кривые, овалы, окружности, четырех- и многоугольники. Возможно замыкание и разрывы контуров. Для замкнутых контуров возможна одноцветная или градиентная заливка. Импорт или экспорт векторных изображений в версиях пакета Director не предусмотрен.

Director имеет встроенный язык программирования и специальные средства для «быстрого» программирования, когда большую часть программного кода создает сама система, а пользователь вносит только элементы точной настройки.

Для создания программного кода способом «быстрого» программирования существует специальный инспектор «Реакций на события» (Behavior Inspector) (рис. 6.28 Рис. 06.28.), который позволяет сопоставить системному событию реакцию проекта на это событие. В качестве некоего события обычно фигурирует нажатие какой-либо кнопки. Результатом такого нажатия может быть переход к определенному кадру или даже окончание работы проекта. Для этого в инспекторе выбирается какое-нибудь конкретное событие и ему сопоставляется некоторое действие.

В пакете также предусмотрен специальный отладчик программ (Debugger), окно которого представлено на рис. 6.29 Рис. 06.29.. Отладчик позволяет устанавливать точки останова, трассировать программу построчно с заходом во внутренние процедуры или без него. Отладчик автоматически показывает название текущей процедуры и значения объявленных переменных. Кроме того, может быть вызван отдельный инспектор переменных, который позволяет не только проверить значение любой переменной, но и изменить его.

Даже из такого краткого описания понятно, что это достаточно мощный программный пакет, который позволяет подготавливать сложные мультимедийные электронные издания. Однако обучение методике работы с этим пакетом требует от изучающего много времени и сил.

6.3.3.
Основные этапы работы над мультимедийным электронным изданием

Здесь следует, прежде всего, указать, что пакет Macromedia Director достаточно сложен и многогранен и позволяет создавать электронные издания практически любой степени сложности и насыщенности медиа-фрагментами различного типа. Именно из этих соображений мы включили в § 6.3 данный раздел. Процесс создания мультимедийного издания включает в себя ряд последовательных этапов, основные из которых перечислены ниже.

Начальный этап включает в себя определение целей проекта, его аудитории и общей концепции. Этот этап существенно влияет на общую концепцию проекта, используемый в нем пользовательский интерфейс и особенности подачи текстового и графического материала, анимации и звуковых фрагментов.

Разработка интерфейса должна учитывать средства воспроизведения материалов проекта: для индивидуального пользователя они существенно отличаются по сравнению с теми, которые используют для групповой работы и воспроизведения материалов на специальном компьютерном проекторе. Даже в последнем случае интерфейсы могут варьироваться в зависимости от размеров учебной аудитории и количества слушателей и зрителей. На этом этапе следует выбрать фоновый тон или рисунок - в простейшем случае это может быть белый экран, а также тип, количество и размещение в рабочей области элементов управления и средств навигации.

Для экономии места в большинстве случаев используют всплывающие панели управления, вызываемые по требованию пользователя. Вероятно, в качестве постоянно присутствующего средства следует использовать кнопку вызова помощи. Если основу проекта составляет видеофильм или анимация, то при их демонстрации следует использовать максимальную часть рабочей области экрана, и фреймовая структура в этом случае нецелесообразна. В то же время, исходный интерфейс может быть основан на структуре с двумя или тремя фреймами, в одном из которых постоянно присутствует содержание издания.

Значительная часть усилий при работе над таким проектом связана с разработкой и реализацией сценария мультимедийного издания. Здесь можно выделить процесс создания общего сценария и обработку отдельных видеорядов или видеопоследовательностей, каждая из которых раскрывает определенную тему. Точно так же следует тщательно продумать переходы от одного тематического видеоряда к другому. Исходный сценарный план или вступительная часть издания должны включать в себя четыре основных экрана, а именно (см. рис. 6.30 Рис. 06.30.):

  • заставка с приветствием и исходными навигационными кнопками;

  • информация о программе;

  • сообщение об авторах данного мультимедийного издания и других работниках, принявших участие в его подготовке и редактировании;

  • содержание издания, включающее в себя список иллюстраций, а также аудио- и видеопоследовательностей.

В начало издания следует включить описание используемых в нем навигационных средств, таких, как кнопки перехода на страницы, кнопки вызова помощи, содержания и оглавления. На четвертой странице присутствует также перечень основных разделов материала, которые одновременно являются указателями соответствующих гиперссылок.

Следующий этап работы - это импорт и подготовка новых изображений и текстовых фрагментов. Когда изображение просматривается в окне труппы программы Director, оно может быть также обработано в окне редактора растровой или векторной графики. Это окно годится и для создания новых изображений. Когда элемент труппы закончен, его внешний вид на сцене можно изменить с помощью наложения, смешивания и цвета. Кроме того, к изображениям можно применять форматные преобразования. Пакет позволяет применять такие преобразования не только к графическим объектам, но и к текстовым.

Для создания анимации изображение нужного объекта переносится в окно партитуры. При анимировании необходимо задать начальное и конечное положение объекта на экране (размеры, положение, угол наклона, цвет), все необходимые промежуточные преобразования выполняются автоматически. Можно управлять траекторией его перемещения, задавая ее на экране в виде кривой. После окончания работы над проектом можно преобразовать его в независимый модуль для последующего воспроизведения вне среды разработки. Пакет предоставляет возможность создания независимого модуля трех видов:

  • Win32 приложение для воспроизведения в среде Microsoft Windows версий 95, 98, NT или Windows 2000. Для создания такого модуля необходимо выбрать в секции меню File команду Create Projector;

  • Shockwave-модуль, который воспроизводится с помощью браузера как с локального диска, так и с Web-сервера. Для создания такого модуля в секции меню File следует выбрать команду Publish/Shockwave;

  • Java-объекта, для воспроизведения также с помощью браузера. Для создания такого модуля необходимо в секции меню File выбрать команду Publish/Java.

Заключительная стадия работы над любым проектом - это его тестирование. Первый этап тестирования проводится с целью обнаружения и исправления ошибок и недоработок. Следующий этап тестирования на компьютерах разного типа ставит целью определение минимальной конфигурации компьютера для качественной работы с данным мультимедийным изданием. После окончания тестирования осуществляется публикация подготовленного издания путем его записи на компакт-диск с однократной записью на соответствующем оборудовании (см. § 5.1.4).

6.4.
Дизайн Web-сайтов в пакете Macromedia Flash

6.4.1.
Общая характеристика и интерфейс пакета

Пакет Macromedia Flash реализует специальную технологию Flash Flash, которая позволяет объединить в одном формате текст, графику, звук, анимацию и интерактивные компоненты. Основу Flash-фильмов составляет специальная векторная анимация, отличающаяся высокой компактностью при удовлетворительном качестве. Сайт, разработанный на основе этой технологии, приобретает высокую динамичность и практически безграничную интерактивность. Публикация Flash-фильмов в сети производится путем встраивания их в HTML-документ. В качестве одного из HTML-редакторов, позволяющих корректно встраивать Flash-анимацию в HTML-документ, можно рекомендовать Macromedia DreamWeaver, рассмотренный в § 6.2. Достоинством редактора является его экономичность. В отличие от многих других WYSIWYG-редакторов он практически не добавляет никаких избыточных тегов, в том числе и при встраивании в HTML-документ Flash-анимации. Технология публикаций HTML-документов со встроенной Flash-анимацией позволяет не только легко модифицировать сайт, но также и обеспечить к нему доступ тех пользователей, которые не имеют проигрывателей Flash-анимации.

Macromedia Flash сохраняет созданные фильмы в формате SWF (ShockWave Flash). Это один из весьма распространенных форматов векторной анимации в сети. Его спецификация была опубликована фирмой Macromedia Macromedia в 1998 г. В новом тысячелетии эта спецификация, по существу, стала стандартом де-факто. Свыше 200 миллионов человек загрузили с сайта Macromedia проигрыватель Flash-фильмов. Почти 90% лиц, имеющих доступ к сети Интернет, пользуются браузерами, пригодными для просмотра Flash-анимации. Проигрыватели Flash-фильмов поставляются с оболочкой Windows, начиная с версии 95 г., MacOSS, браузерами MS Internet Explorer, начиная с версии 5.0, и Netscape Navigator, начиная с версии 4.0. Некоторые производители программного обеспечения поддерживают формат SWF, включая в свои программные продукты модули, позволяющие экспортировать данные в этот формат (например, Flash Writer для Adobe Illustrator).

Созданную в пакете Flash анимацию в дальнейшем уже нельзя редактировать. Только для интерактивных фрагментов возможно динамическое обновление из внешних источников. Графические же материалы и звуковые фрагменты требуют предварительной специальной обработки перед их вставкой в опубликованный в сети Flash-фильм. Для этой цели используется специальная программа Macromedia Generator, распространяемая с сайта данной фирмы.

Программный пакет Flash мы будем рассматривать на основе его современной версии 5.0, интерфейс которой с заставкой представлен на рис. 6.31 Рис. 06.31.. Сразу следует отметить, что объем его технического описания превышает 800 страниц, поэтому в рамках данного учебника мы остановимся лишь на некоторых узловых моментах технологии подготовки векторной анимации в данном программном пакете. В частности, просматривается определенное сходство интерфейса данного пакета и редактора векторной графики Adobe Illustrator.

Слева на рис. 6.31 Рис. 06.31. видна «Палитра инструментов» (Tools). Более крупным планом она показана на рис. 6.32 Рис. 06.32.. Представленные в составе этой палитры инструменты характерны для редакторов векторной графики. В частности, можно перечислить главные из них: стрелки для полного и частичного выделения графических объектов, инструменты «Линия» и «Лассо», «Перо» и «Шрифтовые элементы», «Овал» и «Прямоугольник», «Карандаш» и «Кисть», «Чернильница» и «Красящее ведро» (Paint Bucket), «Капельница» и «Ластик».

Под группой собственно инструментов (Tools) размещается панель «Вид» (View), куда входят инструменты: «Рука» - для перемещения изображения в пределах окна документа - и «Масштаб». Ниже расположен фрагмент «Цвета» (Colors), где, как и в других редакторах векторной графики, задается цвет контурных линий и цвет заливки замкнутых областей, которые соответствуют инструментам «Чернильница» и «Красящее ведро».

Еще ниже расположен фрагмент «Свойства» (Options). Этот фрагмент подобен адаптивной палитре инструментов в пакете PhotoShop. Здесь содержание изменяется в зависимости оттого, какой из рисующих инструментов палитры активен в данный момент.

На рис. 6.32 Рис. 06.32. активным показан инструмент «Карандаш», поэтому в нижней части этой палитры, в адаптивном фрагменте «Свойства» (Options) можно задать вариант или способ рисования им. В «Свойствах» представлены три варианта рисования: «Спрямление отрезков» (Straighten), «Скругление резких переходов» (Smooth) и «Выравнивание толщины линий» (Ink). Так как активен первый из этих вариантов, любые линии, нарисованные карандашом, будут автоматически аппроксимироваться ломаной, состоящей из прямолинейных отрезков.

Из инструментов для выделения здесь представлены стрелки для полного (черная) и частичного (светлая) выделения объектов и лассо для выделения областей произвольной формы. Представлены два инструмента для рисования плоских фигур: овал и прямоугольник, а также ластик и пипетка для съема значения цветового тона.

Кратко остановимся на некоторых других палитрах пакета Flash. Вверху справа на рис. 6.31 Рис. 06.31. показана палитра с четырьмя вкладками: «Инфо» (Info), «Трансформация» (Transform), «Выравнивание» (Stroke) и «Заполнение» (Fill). Первая вкладка активна. Она позволяет, как показано на рис. 6.33 Рис. 06.33., установить текущие координаты курсора, размеры графических объектов, а также их координаты в цветовом пространстве RGB.

Функции вкладок «Трансформация» и «Заполнение» рассматриваемого окна полностью соответствуют названиям, а вкладка «Линия» (Stroke) позволяет применять при оформлении различные линейки, ширина и цвет которых регулируются с помощью выпадающих списковых окон. Также в виде выпадающего (Pull-Down) списка представлены различные виды линеек, как это представлено на рис. 6.34 Рис. 06.34..

Из других палитр, представленных на рис. 6.31 Рис. 06.31., остановимся на цветовых. Так, линейная палитра цветов «Смеситель» (Mixer) показана на рис. 6.35 Рис. 06.35. (на рисунке открыты обе вкладки). Если сравнивать ее с соответствующими палитрами в графических пакетах фирмы Adobe, то она подобна палитрам «Синтез». Данная палитра служит для выбора цветового оттенка. С помощью двух небольших окон в верхней левой части палитры отдельно выбирается цветовой оттенок для линий (на рис. 6.35 по умолчанию показан черный цвет) и для заполнения замкнутых контуров. Цвет выбирается мышью на цветовой линейке и его координаты показываются в RGB-представлении в правой части палитры. Здесь же снизу указана прозрачность сс-канала, т. е. специального корректирующего слоя, который маскирует изображение. Сего помощью можно создавать разнообразные цветовые эффекты.

С палитрой «Смеситель» интегрирована в виде вкладки палитра «Эталоны» (Swatches). В ней представлен, как показано на рис. 6.35 Рис. 06.35., набор цветовых образцов (иначе, это библиотека эталонов цвета). Помимо большого количества цветовых образцов, в нижней части палитры содержаться еще наборы линейных и радиальных градиентов. Палитра может пополняться новыми образцами. Из нее могут удалятся те тона или градиенты, которые не требуются пользователю. Т. е. каждый пользователь адаптирует содержимое данной палитры под свои запросы.

Еще ниже, на рис. 6.31 Рис. 06.31., находятся три палитры для работы с текстом, объединенные в общее окно со вкладками. На рис. 6.36 Рис. 06.36. раскрыта одна из этих вкладок, а именно вкладка «Шрифт» (Caracter). Как видно из рисунка, с помощью палитры легко выбрать гарнитуру и кегль шрифта, а также его начертание и цвет. Предусмотрена также возможность регулировки трекинга (плотности размещения символов, обычно при малых кеглях расстояние между символами увеличивают для лучшей читаемости текста) с помощью списка, расположенного под списком для выбора кегля. Имеется также опция «Кернинг» (Kern), которая позволяет регулировать расстояние между символам и в пределах некоторых сочетаний их пар, например, прописной буквой «Г» и строчной «о».

Упомянем еще одну палитру - «Звук» (Sound), которая входит в группу из четырех палитр, с помощью которых выполняется редактирование событий и эффектов. Внешний вид этой палитры представлен на рис. 6.37 Рис. 06.37.. В ее верхней части в раскрывающемся списочном окне представлен список звуков, который пополняется путем их импорта из различных пакетов и папок. Для этой цели в секции меню «Файл» имеется соответствующая команда. Мы импортировали звуковой файл Microsoft.wav из папки Media каталога MS Windows.

Для выбранного звукового файла строчкой ниже приводятся его характеристики: частота дискретизации, разрядность оцифрованных значений (см. также § 3.4), количество каналов (моно, стерео, квадро), а также информационный объем файла. Затем, в списковом окне можно выбрать один из эффектов. В нашем случае выбрано ослабление звука слева направо. Звук может быть связан (синхронизован) с объектами или событиями с помощью расположенного ниже еще одного окна списка. Наконец, в нижней строке задается число повторов звука (в примере оно равно 10).

Мы вынуждены ограничиться кратким описанием интерфейса и палитр пакета Flash 5. В дистрибутиве имеется хорошо организованная помощь (Help) и даже учебник для начинающих, к сожалению - на английском языке, так как пока еще этот пакет не русифицирован.

6.4.2.
Основные понятия и элементы Flash-технологии

Рассмотрим далее, из каких элементов состоит Flash Flash-анимация и как она подготавливается. Весь flash-фильм делится на отдельные достаточно независимые фрагменты или эпизоды, называемые сценами (Stage). Каждая из таких сцен следует сразу за предыдущей без какой-либо задержки, т. е. анимационный фильм представляет собой линейную последовательность таких сцен. Здесь просматривается прямая аналогия со съемками обычного фильма, при которых фильм делится на отдельные эпизоды, подготавливаемые и редактируемые отдельно. Естественно, что короткие фрагменты редактировать гораздо проще. Такой подход упрощает и редактирование фильма в целом: в готовом фильме отдельные сцены можно поменять местами. Можно также добавить новую сцену, включив ее в нужное место совокупной последовательности сцен. При этом нумерация кадров изменяется автоматически, т. е. разработчик Flash-анимации освобожден от кропотливой работы с отдельными кадрами. Каждая сцена характеризуется только двумя параметрами: имя сцены и ее расположение (или порядковый номер).

Для создания новой сцены используется команда Scene секции меню Insert (Вставка). Эта команда вставляет новую сцену сразу после текущей, присваивая ей по умолчанию соответствующий номер. Для удаления сцены используется команда Remove Scene из той же секции меню Insert. Кстати, эта команда не может быть отменена. Сказанное иллюстрируется рис. 6.38 Рис. 06.38..

Для переключения между сценами используются различные подкоманды команды Goto секции меню View. Все они показаны на рис. 6.39 Рис. 06.39.. В частности, подкоманда First (альтернатива - клавиша Ноте) обеспечит переход к первой сцене, Previous (клавиша PgUp) и Next (клавиша PgDn) - к предыдущей или последующей сцене, Last (клавиша End) - к последней сцене. Можно пользоваться и списком сцен, приведенным в нижней части меню команды Goto.

Еще удобнее управлять сценами с помощью специального диалогового окна «Сцена», показанного на рис. 6.40 Рис. 06.40.. В окне имеется список всех сцен фильма. Для выбора сцены достаточно щелкнуть по ее имени мышью. Двойной щелчок позволяет изменить имя сцены. Только в этом окне можно изменить порядок следования сцен. Для этого следует выбрать нужную сцену и с помощью мыши переместить ее в заданную позицию в списке, как это сделано на рис. 6.40 Рис. 06.40. со сценой четыре. Расположенные в нижней строке окна кнопки Duplicate (дублировать), Add (добавить), Delete (удалить), позволяют дублировать, добавить и удалить сцены, а также переименовать любую из них. Кстати, пиктограммы для этих кнопок настолько выразительны, что назначение кнопок не требует пояснений.

Монтажным пультом для каждой из создаваемых сцен служит хронометрическая линейка, показанная в верхней части рабочего окна программы на рис. 6.41 Рис. 06.41.. Она представляет собой график, на котором расставляются отдельные кадры, склеиваются, смещаются, согласовываются во времени и т. д. Сцена делится на отдельные части, называемые объектами. Объект- это некоторый фрагмент фильма, состоящий из нескольких кадров. Если провести параллель с мультипликацией, то объектом может быть совокупность нескольких рисованных кадров, которые передают определенное движение рисованного персонажа.

Объект является одним из основных и фундаментальных понятий Flash-технологии. Главная задача разработчиков Flash-технологии состояла в том, чтобы создаваемые в пакете анимационные файлы были наименьшего размера. Именно для достижения этой цели был введен механизм эталонов и формируемых на их основе объектов. Вначале создается эталон, т. е. описание объекта. Эталон помещается в библиотеку. Затем соответствующий объект может любое число раз вставляться в анимационный файл (Flash-фильм) с помощью ссылок на эталон. Сам эталон вставляется во Flash-фильм при первой ссылке на объект. При повторном воспроизведении объекта плейер вставляет сохраненный эталон не обращаясь к изображению вновь. SWF-файл обеспечивает реализацию такой технологии.

Кроме того, проведена типизация объектов, т. е. определены различные их виды со свойственным им поведением. Информация о видах объектов и их поведении содержится также в проигрывателе Flash-фильмов. Это обеспечивает возможность включения новых видов объектов. В основе иерархии объектов стоит графика, затем следует анимированная графика, затем простые в управлении интерактивные объекты, а еще выше - со сложной, программируемой интерактивностью. Применение модульного принципа подразумевает возможность дальнейшего расширения видов объектов.

Таким образом, Flash-фильм состоит из определенной совокупности сцен, а каждая сцена состоит из отдельных объектов, эталоны которых хранятся в библиотеке. При компоновке Flash-файла эталон объекта (т. е. входящие в его состав графика, анимация, звук, скрипты) помещается в точке первого вхождения объекта. В дальнейшем можно задавать любые изменения свойств объекта, т. е. редактировать его. Можно включить поворот и масштабирование, наклон и смещение и т. д. все эти изменения не коснутся эталона. Однако, если изменить эталон, то эти изменения немедленно проявятся во все объектах, соответствующих этому эталону. Отметим, что имеется возможность приписать одному объекту свойства объекта другого вида.

Перечислим три основные разновидности объектов, используемых во Flash-фильмах:

  • Графические (Graphic). Они могут содержать графику, звук, анимацию, но не могут иметь имени, вследствие чего не могут управляться посредством скриптов;

  • Кнопки (Button). Могут включать в себя графику, звук и прочие элементы. Содержат толь ко четыре кадра. Имени кнопки также не имеют;

  • Клип мультимедиа (Movie Clip). Содержит графику, звук, анимацию и т. д. По-существу, это полноценный короткий Flash-фильм. У него имеется имя, что позволяет программно управлять им и создавать различные динамические эффекты.

Создать эталон можно тремя различными способами. При использовании первых двух вначале создается пустой эталон, а лишь затем он заполняется содержанием. Третий способ конвертирует в эталон уже существующую графику.

  • Первый способ инициируется командой «Новый объект» (New Symbol) секции меню «Вставка» (Insert). В появившемся диалоговом окне (рис. 6.42 Рис. 06.42.) следует ввести имя эталона и выбрать в переключателе его тип из трех возможных вариантов. В верхней части окна появится надпись, содержащая номер сцены и имя нового эталона;

  • Можно использовать пиктограмму создания нового объекта в нижней строке окна «Библиотека». В результате будет открыто уже упомянутое окно, показанное на рис. 6.42 Рис. 06.42., в котором нужно будет повторить действия предыдущего пункта данного списка;

  • Можно выделить те графические элементы, которые требуется включить в новый объект, а затем выбрать команду «Преобразовать в объект» (Convert to Symbol) секции меню «Вставка». Затем, все в том же диалоговом окне «Новый объект» (рис. 6.42 Рис. 06.42.), выполнить операции, о которых говорилось в первом пункте списка.

Выше уже упоминалось, что эталоны всех объектов хранятся в библиотеке. Соответствующее диалоговое окно показано на рис. 6.43 Рис. 06.43.. Оно открывается командой «Библиотека» (Library) секции меню «Окно» (Window). Если это окно редактируемого объекта библиотеки, то в верхней строке окна указывается имя объекта и сцены. В нашем случае указана «Сцена 1». В следующей полосе указано общее количество объектов в библиотеке и находится кнопка «Свойства» (Options), нажатие на которую вызывает появление меню окна «Библиотека». Меню также представлено на рис. 6.43 Рис. 06.43.. Ниже следует окно предварительного просмотра объекта. Если эталон состоит более, чем из одного кадра (т. е. его можно проигрывать с помощью плейера), то в левом верхнем углу окна появляются две кнопки: для запуска анимации и ее останова. Еще ниже, в окне «Библиотека», размещается список всех эталонных объектов (на рис. 6.43 Рис. 06.43. их представлено всего три).

Для каждого из эталонов библиотеки может быть вызвано контекстное меню, показанное на рис. 6.44 Рис. 06.44..

Команды контекстного меню позволяют различным образом модифицировать эталоны. Можно переименовать эталон, создать его копию, уничтожить, редактировать и т. д. В том числе возможна и организация связей между эталонами и даже изменение их типа. Предусмотрена возможность ввода в состав одного объекта других.

Следует также отметить, что в версии 5.0 рассматриваемого пакета в секции меню «Окно» наряду с командой «Библиотека» предусмотрена также команда «Стандартные библиотеки» (Common Linraries), которая вместе с соответствующими подкомандами показана на рис. 6.45э Рис. 06.45.. В стандартных библиотеках содержатся эталоны определенного типа в каждой. В частности, можно указать кнопки, графические эталоны, интерактивные обучающие фрагменты, видео- и аудиоклипы.

В заключение данного параграфа следует отметить, что программный пакет Flash и технология Flash-анимации - это большой и достаточно специфический раздел Web-дизайна, о котором в рамках данного учебника мы вынуждены ограничиться лишь очень краткими сведениями. Впрочем, даже из изложенного выше понятно, какой интерес представляет это направление для широкого круга дизайнеров и пользователей сети Интернет.

6.5.
Общая характеристика других программных средств для Web-дизайна

6.5.1.
Другие средства проектирования Web-сайтов

Рассмотрим несколько других программ для проектирования сайтов. Многие профессиональные разработчики используют программный пакет LiquidFX Pro v4.0 Он включает в себя HTML-редактор, графический редактор, специальную утилиту для извлечения информации из баз данных нее форматирования. Он также поддерживает Java-скрипты и т. д. В пакете много функций и дополнительных средств, которые позволяют создавать профессионально оформленные Web-сайты.

Младший брат рассмотренной программы - LiquidFX Express - распространяется условно бесплатно. Он ориентирован преимущественно на лиц, не имеющих опыта оформления сайтов, предоставляя для них удобный, интуитивно понятный интерфейс. В пакете реализуется технология проектирования страниц, напоминающая объектно-ориентированное программирование. Редактирование HTML-тегов осуществляется в режиме WYZIWYG. Большинство контейнеров выполнено в виде готовых конструкций, которые представляются в виде легко узнаваемых пиктограмм. Пользователь должен задать их параметры и должным образом разместить на Web-странице.

Многие молодые люди отдают предпочтение пакету Arachnophilia. Он чем-то напоминает HomeSite, о котором шла речь в § 4.4. Поддерживает разработку Java-скриптов, HTML-форм, CGI-скриптов, фреймов и т. д. Предусмотрен встроенный FTP-клиент для загрузки на сайт страниц, которые были изменены. Мощная и удобная система макросов, использования «горячих клавиш». Создание сайтов и создание страниц значительно упрощается вследствие возможности использования библиотеки заготовок.

Определенный интерес представляют новые разработки фирмы Silicon Graphics. Первая из них - WebMagic - предоставляет собой полный набор программных средств, необходимых для творческой работы Web-дизайнера.

Интерфейс основной программы WebMagicAuthor имеет достаточно полный набор пиктограмм и команд меню, позволяющих создавать разнообразные макеты страниц. Для организации гиперсвязей между различными типами объектов используется программа IndigoMagic. Здесь для связи объектов любого типа используются пиктограммы объектов, связываемые с помощью указателя мыши. Еще раз отметим, что объектами могут быть HTML-страницы, видео- и аудио-клипы в самых различных форматах, графические изображения и даже трехмерные объекты VRML

С помощью встроенной модели цифровой камеры IndyCam, можно записать любое аналоговое изображение. Интегрированная программа Capture записывает «живое видео», полученное от IndyCam, или любого другого записывающего устройства. Cdman и DATman дают возможность легко перевести в нужный цифровой формат звуковую информацию с компакт-диска или DAT-кассет, a Sound Editor обеспечивает возможность ее редактирования. Программа IRIS Impresario позволяет вводить изображения с фотографий, сканировать тексты и иллюстрации. Затем эти файлы конвертируются в форматы, необходимые для передачи по сетям Internet.

Программный продукт Showcase, который входит в любую стандартную комплектацию программных средств фирмы SiliconGraphics, помогает создать множество дополнительных эффектов - начиная от интеграции текстов, эксперимента с цветом и заканчивая включением сложных трехмерных файлов.

Программа MovieConvert импортирует видеоданные практически любого промышленного формата, необходимые вырезки, склейку и монтаж кадров позволит осуществить программа MovieMaker. И, наконец, преобразовать готовое видео в сетевой формат поможет MovieMaster.

Еще одна интегрированная в пакет программа - NetsiteCommunicationServer- позволит быстро распространять содержание Web-страниц как внутри корпоративной, так и в глобальной сети. К тому же Netsite в несколько раз быстрее доставляет по адресу документы, чем обычный сервер HTTP. Удобный графический интерфейс Netsite позволяет легко конфигурировать систему.

Другой полный набор функциональных средств для создания динамических Web-страниц фирмы Silicon Graphics носит имя COSMO. Все эти средства тесно взаимосвязаны и образуют целостное и законченное решение. Подобная технология обеспечивает прозрачную интеграцию достаточно разрозненных приложений. Пользователю теперь не придется запоминать хитроумные способы запуска Java Develpoment Environment (Cosmo Code). Если потребуется установить ошибки в приложениях Java, это легко можно сделать, не покидая среды CosmoCreate.

Программное обеспечение Cosmo Create представляет собой пакет решений для разработки интерактивного мультимедийного содержания Web-страниц. Отныне этот процесс не ограничивается лишь поиском и установкой необходимых гиперсвязей. Автор получает доступ к широкому спектру цифровых изобразительных средств, таких как графические образы, аудио- и видеоэффекты, видеоклипы, трехмерная графика и язык программирования Java. Каждое из этих изобразительных средств само по себе нуждается в огромном количестве инструментариев для создания необходимых файлов. Вслед за этим необходимо довольно долго учиться тому, как получить доступ к необходимому файлу, а затем его отредактировать.

Одно из огромных преимуществ Create - это возможность для различных мультимедийных редакторских средств работать в режиме прозрачности. Специальный редактор проверит содержание файлов, произведя по желанию пользователя необходимые модификации. Если, например, требуется отредактировать какой-либо объект - просто нужно выделить его мышью, а затем сообщить, что данный объект нуждается в редактировании. Весь набор редакторских средств тут же появится на экране. После необходимых модификаций объект автоматически сохраняется, и продолжается работа в COSMO Create. В состав COSMO Create также входят средства проверки орфографии (Spell Checker), возможности работы с кадрами, HTML-формами и пр.

CosmoCode - это профессиональная графическая UNIX среда для языка программирования Java, которая позволяет создавать интерактивные программные приложения, работающие на разных платформах. Инструментальные средства визуальной разработки SiliconGraphics существенно расширяют возможности Java за счет добавления трехмерных библиотек и цифровых мультимедия-средств. CosmoCode состоит из run-time интерпретатора и компилятора языка Java, графического отладчика, визуального редактора исходных кодов, а также библиотек Cosmo MotionEngine и CosmoMediaBase.

CosmoMediaBase представляет собой новый класс программного обеспечения для управления содержимым мультимедийных баз данных. Этот пакет дает Web-разработчикам и администраторам узлов возможность динамического хранения, поиска и доставки мультимедиа-данных.

Можно указать также несколько дополнительных программных модулей для создания или модификации объектов определенного типа. Так, в качестве примера программы для создания VRML-миров можно указать InternetBD Space Builder. Простой программный модуль для обработки звука - это Cool Ed it.

Тем, кто любит создавать графические указатели ссылок можно порекомендовать программу Xara WebStyler. Она была специально для этого создана. Здесь можно сделать обычные и трехмерные надписи, кнопки самого разного размера и стиля и пр. На этом можно закончить обзор дополнительных средств Web-дизайна.

6.5.2.
Подготовка анимационных фрагментов в пакете 3D Studio Max

Анимация Анимация - это искусственное представление движения в кино, на телевидении или компьютере путем последовательной смены рисованных кадров. Если при съемке кинофильма или видеофильма непрерывное движение разбивается на отдельные кадры, то анимация наоборот из специально подготовленных отдельных кадров создает эффект непрерывного движения. Мы уже рассматривали GIF-анимацию (см. § 4.8) и векторную flash-анимацию (см. § 6.4). Здесь кратко остановимся на возможностях трехмерной анимации в указанном выше пакете, который большинство специалистов считает наиболее профессиональным. Именно в нем создаются телевизионные рекламные заставки и модули, а также различные спецэффекты, используемые в кино.

Пакет 3D Studio Max представляет собой единый программный комплекс моделирования, визуализации и анимации объектов, разработанный фирмой Autodesk для операционной среды Windows, начиная с версии 1995 г. Пакет отличает от рассмотренных ранее наличие мощного математического аппарата как для создания моделей объектов, так и для их анимирования. Его интерфейс показан на рис. 6.46 Рис. 06.46..

Процесс создания трехмерной анимации в этом пакете можно разделить на шесть основных этапов:

  • разработка сценария анимации;

  • создание ландшафта или фона для сцены;

  • разработка объектов анимации;

  • добавление в сцену источников освещения, видеокамер и специальных эффектов;

  • собственно анимирование сцены;

  • визуализация анимации и создание автономного загружаемого модуля.

Сценарий анимации определяется тем, для каких целей она задумана, и что предполагается показать, т. е. это детализованное описание сюжета, который будет представлен в виде анимационного ролика.

Для создания ландшафта или фона для сцены в пакете предусмотрены специальные средства, например, инструмент Quad Path (сетка из прямоугольников). Имеется также набор стандартных примитивов, (рис. 6.47 Рис. 06.47.), с помощью которого можно иммитировать строения (дома), а также средства их клонирования (команда Clone в секции меню Edit).

Предусмотрен специальный инструмент «Редактор материалов» (Material Editor), с помощью которого вызывается одноименное диалоговое окно (альтернатива - одноименная команда в секции меню Edit), в котором выбирается образец материала и устанавливаются все его параметры (рис. 6.48 Рис. 06.48.). Только цвет материала подбирается в отдельном диалоговом окне «Просмотр цвета» (Color Selector).

При создании объекта анимации используются три основных модели:

  • полигональная;

  • лоскутная;

  • NURBS.

Полигональные объекты состоят из управляющих точек, называемых вершинами (vertex). Две вершины в трехмерном пространстве, соединенные прямолинейным отрезком, образуют ребро (edge). Если соединить три вершины вместе, образовав тем самым треугольник, получим грань, или многоугольник (face). Построение многоугольных моделей по существу включает в себя соединение вершин. Если у всех граней модели имеется общее ребро, с по меньшей мере тремя другими гранями, тогда говорят, что модель замкнутая (closed). Если же модель содержит грани, у которых нет общих ребер, тогда модель считается развернутой (open). Большинство полигональных моделей относятся к замкнутому типу. Пример модели представлен на рис. 6.49 Рис. 06.49..

Наиболее существенный недостаток полигонального моделирования заключается в том, что оно не вполне подходит для моделирования органических форм. Такие предметы, как тела животных и людей, человеческие лица, жидкости трудно создать с помощью многоугольников. Чтобы придать модели аккуратный и гладкий вид, необходимо наличие большого количества деталей, а значит и большого количества граней. Чем больше имеется граней, тем больше времени уходит на визуализацию, не говоря о том, что подобные операции требуют большое количество памяти. В связи с повышенной детализацией (большим количеством граней) внесение даже незначительных изменений представляется довольно сложной проблемой.

Большинство разработчиков персонажей отдает предпочтение лоскутной модели. С точки зрения расчетов, она значительно проще предыдущей. Огромное преимущество лоскутных моделей заключается в их способности легко представлять гладкие поверхности. В отличие от полигональных моделей в них существенно меньше деталей (рис. 6.50 Рис. 06.50.).

Возможно, наиболее популярной из возникших новых технологий анимационного моделирования является моделирование NURBS (Non-Uniform Rational B-Spline - неоднородные рациональные сплайны Безье). Моделирование NURBS (см. рис. 6.51 Рис. 06.50.) лучше всего подходит для гладких поверхностей, однако оно позволяет создавать и резко очерченные поверхности. В настоящее время эта технология используется для создания самых разнообразных трехмерных моделей: от персонажей мультфильмов до автомобилей. В то же время, как построение, так и редактирование поверхностей NURBS выполняется достаточно простыми средствами.

Поверхности NURBS могут быть определены по своим точкам (points), или управляющим вершинам (CV - Control Vertices). При этом точки фактически лежат на кривой и непосредственно управляют ее формой. Управляющие вершины составляют часть решетки, которая действует подобно магниту. При перестановке управляющих вершин на поверхности NURBS, они выталкиваются и притягиваются к самой кривой. Кроме того, управляющие вершины обладают определенным весом, от которого зависит влияние управляющей вершины на кривую. Вес может изменяться, редактироваться.

Многие аниматоры используют NURBS для создания персонажей, потому что NURBS дает возможность получить гладкие, очерченные поверхности и в тоже время сохранить относительно низкую степень детализации. Персонажи имеют тенденцию усложняться, поэтому использование NURBS позволяет последовательно усложнять персонажи на основе исходной модели без коренной ее переделки.

На этапе анимирования сцены определяются временные параметры будущей анимации: частота кадров, форма отображения времени, общая продолжительность (число кадров). Здесь же указывается траектория движения тех объектов, которые изменяют свое положение, при этом можно сохранять неизменное положение объекта относительно траектории движения или же, наоборот, заставить его крениться. Аналогичным образом выбираются параметры перемещения для видеокамеры по своей собственной траектории, причем, соответствующим образом настраивая окно проекции, можно предварительно просмотреть сцену в таком виде, как она отображается в объективе видеокамеры.

На заключительном этапе осуществляется окончательная подготовка анимационного ролика для последующего его просмотра с помощью стандартных средств Windows. В частности, задается имя файла, время демонстрации ролика или количество кадров в нем.

Отметим, что наш поверхностный обзор последовательности работы в пакете 3D Studio MAX ни в коей мере не претендует на анализ, а ставит целью лишь создать общее представление об этом па кете как о самом мощном средстве для создания компьютерной анимации.


Электронные издания:

7.
глава VII. Организация хранения электронных изданий

В этой главе автор излагает свой подход к организации хранения электронных изданий в рамках издательской базы данных. В частности, рассматривается информационная структура издательства и сетевое взаимодействие с хранилищем информации в рамках этой структуры. Изучение противоречивых требований к хранилищу позволяет разработать его структуру с учетом возможности хранения в ней наряду с обычными и мультимедийных изданий. Рассмотрены также концепция организации выборки информации с использованием метаданных и миниатюр, характеризующих каждое издание, а также автоматизация генерации метаданных и миниатюр при занесении изданий в хранилище.

7.1.
Организация хранения и поиска электронных изданий

В течении длительного времени для хранения электронных копий изданий и их фрагментов используются различные базы данных. В последнее время базы данных стали использоваться и для публикации электронных изданий. Преимущественно это относится к базам данных, которые используются в сети Интернет и связаны с поисковыми серверами, которые, отыскав ссылку на нужное издание в своем поисковом индексе, обращаются к соответствующей сетевой базе данных. Другой вариант публикации - в базах данных, связанных с издательскими серверами. Такой вариант рассматривается в § 8.1.

Существует два принципиально разных метода организации хранения электронных изданий:

  • в виде иерархической файловой системы, в которой файлы отдельных изданий объединены в каталоги по тематическому или другим при знакам;

  • в виде текстовой базы данных, в которой размещены файлы изданий.

Первый метод проще с точки зрения организации структур данных, но требует создания и использования дополнительных средств для поиска нужного электронного издания, в особенности если количество таких изданий достаточно велико. При его использовании, в общем случае, гораздо труднее обеспечить защиту информации от несанкционированного доступа, которая несомненно нужна, так как издания представляют собой определенную информационную и материальную ценность, являясь интеллектуальной собственностью конкретного издательства.

Во втором варианте обычно проще осуществить защиту информации. Методы и средства для этого достаточно разработаны и проверены практикой. Однако при работе с изданием, связанной с его изменением, используется большое количество операций записи и чтения информации. Это связано с тем обстоятельством, что приложение не может напрямую работать с базой данных. В результате, для больших текстовых баз данных существенно снижается скорость обработки информации. Кроме того, возникают определенные проблемы при использовании различных видов информационных носителей, например жестких магнитных дисков и оптических компакт- или DVD-дисков.

Хранение изданий требует обязательной организации системы поиска. Существуют два варианта поиска изданий пользователем. В первом случае производится поиск электронного издания, о котором точно известно, что оно существует и известен хотя бы один его поисковый атрибут. Такие системы называют фактографическими, так как в них каждому изданию однозначно соответствуют поисковые атрибуты. Во втором случае ставится задача отыскания всей совокупности электронных изданий по определенному тематическому направлению. В последнем случае заранее неизвестно не только количество изданий, но даже сам факт их существования. Такие системы называют документальными. Большинство аналитических и исследовательских задач на начальной стадии реализации связано с применение второго варианта поиска. В частности, на этапе постановки задачи всегда проводится обзор литературы по рассматриваемому вопросу.

Методы организации поиска также могут быть разделены на две группы. К первой из них относится так называемый атрибутивный поиск. Он основан на том, что каждый документ (издание представляет собой частный случай документа) характеризуется определенным набором атрибутов (полей). Эти поля заполнены конкретной информацией, которая изменяется для различных изданий. При поиске проверяется совпадение значений, содержащихся в запросе, со значениями в соответствующих полях каждого из изданий. Такой метод организации поиска характерен для фактографической модели.

К атрибутам изданий относят: название, автора (авторов), время создания, ISBN (индивидуальный номер издания по универсальной книжной классификации) и т. д. В последнее время набор атрибутов все чаще называют метаинформацией. Этот термин уже упоминался во второй главе, когда мы рассматривали содержимое заголовочной части HTML-издания. Делаются попытки стандартизации электронного описания для любого издания. В частности, имеются библиотечные стандарты, в том числе и отечественные, а также и стандарты описания в книжной торговле.

Ко второй группе средств относится полнотекстовый поиск и выборка изданий. Действительно, любая книга, в том числе - в электронном виде, представляет собой слабо структурированный набор символов, организованных в слова, предложения, разделы, параграфы и главы. Для организации полнотекстового поиска необходимо вначале произвести индексацию изданий, составить для них так называемый полнотекстовый индекс. В простейшем случае он представляет собой список всех значащих слов в текстовой базе данных с указанием, в каких изданиях встречаются эти слова. Встречаются многоуровневые индексы, в которых на верхнем уровне расположен словарь или поисковый индекс слова. В нем каждому значащему слову соответствует указатель на расположенный на следующем уровне список местонахождений или индекс ссылок, в котором содержатся адрес издания и, иногда, позиция слова внутри документа.

Многие из читателей, вероятно, использовали полнотекстовый поиск, работая в сети Интернете поисковыми серверами. В этом случае в специальное поле поиска вводится конструкция из некоторого количества слов или фраз, иногда связанных друг с другом знаками логических операций. Соответствующий механизм на сервере автоматически проверяет содержимое ссылок на документы, содержащихся в его базе данных и выдает результат поиска в виде списка подходящих или релевантных документов.

Можно сформулировать четыре основных отличия полнотекстовой выборки от атрибутивной:

  • полнотекстовая выборка отвечает на запросы с меньшей точностью;

  • выборка вероятностная, а недетерминированная;

  • критерием правильности выборки является не точное совпадение, а лишь пригодность извлеченного из базы издания;

  • время поиска и извлечения издания больше зависит не оттехничес- ких средств, а от качества формулирования запроса и скорости анализа пользователем пригодности извлеченных из базы изданий.

Нетрудно понять, что первой модели наилучшим образов соответствует атрибутивный поиск, а второй - полнотекстовый. Принципиальное отличие между этими двумя методами поиска состоит в том, что результат применения атрибутивного поиска детерминированный, в то время как полнотекстовый поиск следует характеризовать как вероятностный, т. е. его результат содержит набор документов, характеризуемых определенным уровнем релевантности, пригодности.

Исторически первыми использовались базы данных для хранения структурированной информации с жестким набором атрибутов. Затем возникла необходимость хранения документов, включая журналы и книги, которые представляют собой набор неструктурированной или почти неструктурированной информации. В последние годы возникла определенная тенденция к разметке или структурированию текстовых документов. Для этого созданы специальные языки, в частности XML, который рассмотрен в § 2.1.

Атрибутивный поиск проще и быстрее, а также позволяет получить точный, а не вероятностный, результат. Для его реализации не требуется создавать полнотекстовый индекс, занимающий значительное дисковое пространство, а также сложные поисковые механизмы. Кстати, в последний годы в сети Интернет взят курс на поисковые системы, основанные на частичном использовании метаинформации, по крайней мере в тех случаях, когда эта информация известна пользователю. Вводится и соответствующий стандарт на содержание атрибутов на каждой Web-странице для реализации такого поиска. Тем не менее полнотекстовые базы и поиск пока еще достаточно широко используется в издательских информационных системах. Атрибутивный поиск не всегда применим, так как пользователь может не знать ни одного атрибута.

Известно несколько методов поиска в текстовых базах данных, на которых автору хотелось бы остановиться. Первой и наиболее простой моделью поиска является просмотр, т. е. процесс сходный с обычной работой с книгой. В этом случае из базы данных извлекается определенное электронное издание и пользователь знакомится с его содержанием. Используя современные средства навигации, можно перемещаться по каталогу изданий, раскрывать нужные книги и просматривать их оглавления и аннотации. Для больших баз данных такой способ неэффективен и может использоваться только в сочетании с другими моделями.

Вариантом этой модели является связанное чтение, которое использует концепцию гипертекста и переходы по гиперссылкам внутри одного издания или даже между изданиями, включая рисунки, звуковые и видеофрагменты.

Чаще всего применяется Булевы модели поиска Булевы модели поиска, использующие в качестве основы логические конструкции, т. е. слова или фразы (последние заключаются обычно в круглые скобки), объединенные знаками логических операций И (AND, &), ИЛИ (OR) и НЕ (NO). Входящие в конструкцию смысловые элементы, т. е. слова и фразы, если последние рассматриваются как единое целое, обычно называют термами. Если в результате запроса поисковая система выдала чрезмерно большой список документов, запрос можно попытаться усложнить, включив в него большее количество термов и операторов И, предполагающих одновременное наличие в документе базовых слов и фраз. Наоборот, если найдено небольшое количество пригодных (релевантных) документов, запрос можно упростить, исключив из него отдельные конструкции с оператором И (или добавив конструкции с оператором ИЛИ).

Специальное программное обеспечение может обеспечить автоматическую оценку степени полезности каждого из извлеченных изданий. Эта оценка делается на основе частоты, с которой встречаются в издании термы, используемые в запросе. Результаты обычно сортируются по степени релевантности. Такая модель поиска используется, в частности, на поисковом сервере Rambler.

Векторная модель поиска основана на представлении каждого отдельного издания некоторым вектором в N-мерном пространстве. Запрос также представляется в виде вектора. Степень полезности документа, определяется как его близость в указанном N-мерном пространстве к вектору запроса. Количественная оценка близости выражается косинусом угла между этими векторами и изменяется в пределах от 0 до 1.

Векторная модель поиска обязательно подразумевает последовательные итерации. В начале поиска пользователь из всего множества выбранных изданий определяет некоторые как нужные, полезные. На основании этого выбора вырабатывается уточненное положение вектора запроса

Эффективность - главный критерий при определении применяемого метода полнотекстовой выборки. Эффективность поиска издания можно описать двумя характеристиками: точность и охват. Точность μ определяется отношением числа релевантных документов R к общему количеству документов в выборке N (|μ=R/N). Охват а характеризуется отношением числа релевантных документов в выборке R к общему числу релевантных документов в базе данных Т (a=R/T).

В случае идеального поиска все выбранные документы полностью пригодны и исчерпывают список пригодных документов в базе данных, т. е. а=1 и μ=1. Однако многочисленные исследования, выполненные различными специалистами, показали что точность и охват связаны друг с другом обратной зависимостью, а максимальное значение суммы μ+а близко к 1,4. Сказанное иллюстрируется графиком, представленным на рис. 7.1 Рис. 07.01..

Такой результат выглядит вполне осмысленным. Действительно, если мы хотим увеличить точность р мы должны как можно более точно сформулировать запрос, включив в него большое количество различных термов, связанных с помощью операторов И, чтобы исключить возможность попадания в результаты поиска непригодных документов. Однако в этом случае общее количество выбранных изданий не может быть большим, точнее - оно будет малым. Естественно, что не все релевантные документы, содержащиеся в базе данных, попадут в число выбранных.

Наоборот, если мы хотим увеличить охват, т. е. постараться выбрать наибольшее количество релевантных изданий из общего их числа в базе, следует сформулировать запрос как можно шире. В этом случае в выборку неизбежно попадет значительное число непригодных изданий, т. е. точность окажется сравнительно малой величиной.

В последнем случае увеличение количества выбранных изданий неизбежно увеличит время обработки результатов поиска. Реально, если количество выбранных изданий составляет сотни значений, то время оценки их пригодности становится чрезмерно большим, в результате пользователь утомляется, внимание его рассеивается, что неизбежно приводит к неточностям и ошибкам.

Таким образом, атрибутивная выборка выглядит гораздо предпочтительнее как с точки зрения эффективности и скорости выборки, так и экономии дискового пространства. Однако для ее практического применения необходимо знать поисковые атрибуты, что возможно далеко не во всех случаях.

Во многих случаях следует остановится на промежуточном варианте, когда наряду с атрибутами в поисковой среде хранится набор ключевых слов и терминов, каждый из которых связан с определенным кругом изданий. При включении нового издания в поисковую структуру из набора ключевых слов отбирается несколько, в наибольшей степени отвечающих тематике и содержанию издания. При поиске информации пользователь также просматривает список ключевых слов и отбирает те из них, которые, по его мнению, в наибольшей степени соответствуют его требованиям.

Помимо обеспечения возможности эффективной выборки нужного издания, очень важно то, как следует организовать хранение изданий, чтобы гарантировать только санкционированный доступ к этому хранилищу. Дополнительные трудности на организацию процесса хранения накладывает использование во многих изданиях мультимедийных компонентов.

7.2.
Информационное хранилище издательства

7.2.1.
Требования к информационному хранилищу издательства

Требования к издательской базе данных, как и любому другому программному продукту, зависят от ее назначения. Назначение База данных издательская издательской БД многогранно. Прежде всего, такая база должна обеспечить надежное и длительное хранение выпускаемой издательством продукции. В современном представлении длительность хранения составляет не менее чем 30 или даже 50 лет.

Другое назначение БД состоит в предоставлении возможности поиска и извлечения хранимой информации сотрудниками данного издательства, а иногда и другим лицам. Практически все произведения, выпускаемые в свет любым издательством, защищены авторским правом, следовательно, извлекаемая из БД информация представляет собой определенную ценность. Вывод: доступ к информации должен быть строго регламентирован, а соответствующее разрешение выдается руководителями издательства или специально уполномоченным ими лицом.

Любое современное издательство в определенной степени выполняет также функции дистрибьютора, по крайней мере, в отношении выпускаемых им самим изданий. Дистрибьюторская функция подразумевает возможность получения различной информации об имеющейся в наличии литературе, для чего в БД должны содержаться библиографические характеристики изданий, аннотации, оглавления, а также указания относительно места ее хранения на складе, имеющемся количестве ее экземпляров (остатков) в любой момент времени.

Полезно также иметь возможность оценки количества реализованных экземпляров за определенные отрезки времени и т. п. С этих позиции следует обеспечить возможность доступа к БД для дистрибьюторов, а может быть и для торговых агентов крупных книжных магазинов и посреднических фирм, специализирующихся в распространении изданий. Иногда в издательствах книги продаются со склада и в розницу. Тогда разумно разрешить доступ хотя бы к части базы данных и покупателям. Данное требование вступает в определенное противоречие с предыдущим, так как подразумевает достаточно широкий доступ к и минимальное ограничение круга лиц, которые допущены к информации, содержащейся в БД.

Ряд крупных и средних издательств имеют отделения в различных городах. Для них существенным может оказаться обеспечение возможности удаленного доступа к базе, в частности, для получения сведений о наличии изданий в главном офисе, передаче данных о расходимости тиражей в отделениях и т. п.

Для успешного планирования издательской деятельности необходимо регулярно следить за текущим уровнем развития науки и техники в тех ее областях, которые соответствуют издаваемым этим издательством книгам. Следовательно, в базе должен быть предусмотрен специальный модуль, где представлены последние издания других издательств в определенной области или областях.

Перед заключением договора с автором или авторами очень важна информация относительно области научно-практических интересов авторов и их достижениях в этой области. Таким образом, в базе данных следует предусмотреть раздел «Персоналии», где сосредоточена информация об изданиях сотрудничающих с издательством авторов, включая библиографические данные, отзывы, аннотации, списки рубрикаций и, возможно, тексты самих этих изданий.

Наконец, для проведения правильной издательской политики необходимо ориентироваться в том, какие книги уже изданы или намечены к изданию другими издательствами. Кстати, исчерпывающая информация по данному вопросу помогает заблаговременно определить, не предлагают ли авторы свои произведения одновременно нескольким издательствам, не являются ли новые предложения попыткой переизданий с небольшими изменениями ранее изданных работ и так далее. Таким образом, это требование также подчеркивает необходимость хранения специальных модулей «Последние издания» различных издательств и «Персоналии».

Чтобы принятие решений руководством издательства производилось в условиях полного обеспечения нужной информацией, база данных должна систематически пополняться сведениями в тех направлениях, которые были указаны выше. Известно, что в настоящее время основным источником для быстрого получения исчерпывающей информации по самым различным вопросам стала всемирная сеть Интернет. Именно оттуда следует пытаться с наименьшими затратами, включая рабочее время работников издательства, извлечь нужные данные. Заполнение этой части издательской БД может производиться вручную, силами специально выделенных сотрудников издательства, но гораздо лучше разработать механизмы для автоматического поиска и извлечения нужной информации из сети Интернет Интернет и последующего занесения этой информации в БД. Современные информационные технологии создают определенные возможности и предпосылки для решения этой задачи.

Таким образом, издательская база данных должна обеспечить:

  • длительное хранение изданий с высокой степенью надежности;

  • возможность поиска и извлечения информации об изданиях сотрудниками издательства, а также представителями оптовых фирм, занимающихся книгораспространением, а иногда и розничным покупателям;

  • возможность удаленного доступа для получения и занесения информации в базу;

  • включение и систематическое оперативное занесение информации в специальные модули «Последние издания» различных издательств и «Персоналии».

7.2.2.
Проектирование структуры хранилища электронных изданий

Для лучшей защиты издательской базы данных от несанкционированного доступа и ускорения работы поисковой системы путем перехода к атрибутивному поиску целесообразно разделить функции поиска документов и их хранения, извлечения и передачи клиенту.

Для поиска издания и извлечения библиографических и сопутствующих данных о нем целесообразна разработка специальной вспомогательной базы данных сравнительно небольшого информационного объема, в которой хранятся метаданные - атрибутивная информация для каждого издания: автор, название издания, формат, версия, а также аннотация, резюме, рецензии и отзывы, и ограниченный набор ключевых слов, которые специально отбираются автором и издательством (или извлекаются автоматически из аннотации, рецензий и прочих документов), в концентрированной форме отражающих особенности издания. Это традиционная База данных реляционная реляционная БД, организованная в виде совокупности полей, соответствующих структуре метаданных.

В этой же базе для каждого электронного издания храниться миниатюра, однозначно представляющая издание. Желательно, чтобы такая миниатюра также формировалась автоматически и заносилась во вспомогательную базу одновременно с атрибутами и другой сопутствующей информацией.

По запросу клиента, введенному во вспомогательную базу, в ней осуществляется поиск, в результате которого клиенту возвращается список релевантных изданий с миниатюрами и сопутствующей информацией, из которого он выбирает нужное издание. Далее он может обратиться в основное информационное хранилище, если он обладает соответствующими правами доступа, за этим изданием с целью его просмотра и/или редактирования. В противном случае клиент ограничивается миниатюрой, а также некоторые вспомогательные материалами, характеризующие издание: аннотацией, рецензией, кратким содержанием, оглавлением или развернутым планом-проспектом данного издания. Количество и содержание этих данных может изменяться, в зависимости от тех прав доступа, которыми обладает клиент.

Хранилище изданий или архив издательства является ядром всей информационной издательской системы. Как должно быть организовано такое хранилище? Сейчас преимущественно используются реляционные базы данных, обладающие мощным потенциалом, масштабируемостью, стандартным языком запросов по атрибутам SQL. Для проектирования таких баз разработано большое количество различных программных оболочек, называемых системами управления базами данных (СУБД). Наиболее широко применяется СУБД Oracle, которые обеспечивают практически неограниченный объем хранимой информации.

Однако СУБД и управляемые ими базы данных не проектировались изначально для хранения электронных изданий, содержащих большое количество неструктурированного текста и рисунки, а иногда и мультимедийные компоненты. Для работы с такими документами более пригодными представляются не реляционные, а База данных объектно-ориентированная (ООБД) объектно-ориентированные базы (ООБД), в которых могут быть включены различные индексные структуры и методы доступа для объектов определенного типа. В них же проще создать иерархию типов, которая будет отражать специфическую семантику. Сказанное представляется особенно важным для медиа-объектов различных типов и форматов. Возможно также создание комбинированных объектно-реляционных баз данных.

Реляционные базы данных не слишком удобны и для представления отношений «используется в» и «содержится». Вообще, в реляционных системах трудно представлять отношения между конкретными объектами. В ООБД можно создать индексные структуры и методы доступа специально для объектов определенного типа. Кроме атрибутов для объектов можно определить семантику, формализованную в операциях над ними, и создать иерархию типов, которая будет отражать все более и более специфическую семантику. Например, система, построенная на основе ООБД, может иметь тип данных content-object с операцией play. На следующем уровне иерархии могут быть подтипы для объектов со специфическим содержанием: audio-object, video-object, animation-object, и подтипы для специфических форматов: WAV-audio-object, MIDI-audio-object, MP3-audio-object, а также MPEG2-video-object, MPEG4-video-object, QuickTime-video-object и т. д. Независимо можно ввести тип text-index, определив для него операции автоматической индексации и выполнения запросов. В ООБД в число атрибутов могут включаться указатели, что позволяет легко реализовать упомянутые выше отношения вхождения документов.

Работа с медиа-информацией предполагает несколько различных способов доступа к объектам хранения. Довольно часто медиа-издания могут быть организованы в простую иерархию. В этом случае доступ к ним может быть реализован через аппарат фа иловой системы сервера. Требуется только знать точный адрес (URL) соответствующего издания и иметь необходимые права доступа. Для экономии пространства архива издания могут храниться в сжатом формате, например SFX, с автоматической распаковкой при извлечении. Для составных документов хороший способ - не хранить их целиком, а включать в них навигационные связи с вложенными объектами. Например, если в системе хранится журнал, то должны быть связи между его страницами и отдельными объектами, которые содержат статьи, фото, рекламу.

Система хранения должна обеспечивать несколько видов представления документов. В частности, представление «только для просмотра»дает пользователю возможность изучения содержания издания, без права редактировать его. Примеры такого представления - формат Adobe Acrobat PDF, представление изображений в формате экрана (вьюерах), файлы в формате видео QuickTime и пр.

Информационное хранилище Информационное хранилище должно опираться на файловую систему сервера. Чтобы реализовать стратегию хранения данных, от файловой системы требуется поддержка управления томами и иерархического управления памятью (Hierarchical Storage Management - HSM). HSM для иерархической памяти сверхбольшой емкости - это примерно то же самое, что виртуальная память для физического оперативного запоминающего устройства: она позволяет рассматривать различные уровни памяти (в частности, жесткие и оптические диски, магнитную ленту, если она используется) как одну большую файловую систему.

Если пользователь или приложение открывает файл, то либо он уже находится на жестком диске, либо HSM считывает его автоматически с текущего оптического диска из многотомной дисковой системы, либо извещает оператора о необходимости найти нужный том. Илиэтоттом мо-жетнаходится внутри специального сменника дисков (чейнджера), или его следует найти в библиотеке оптических дисков, на полке. В последнем случае для поиска тома с нужным номером и установки его в дисковод требуется участие оператора, в результате чего полное время обращения многократно возрастает.

Схема HSM несомненно полезна, но, к сожалению, требует определенного развития. Например, когда пользователь пытается извлечь изображение высокого разрешения - его размер может достигать десятков мегабайт,- или же фрагмент цифрового видеофильма, то было бы полезно, чтобы система формировала специальное сообщение для поль-зо-вателя, каково будет время ожидания. Последнее, кроме размера файла, зависит также от степени доступности объекта.

Выбор стратегии размещения данных зависит, конечно, от объема данных в медиа-изданиях, но, кроме того, и от требований по скорости доступа к ним - какие данные должны быть доступны немедленно, какие могут стать доступны через секунды или минуты. Например, редактор книги, у которого процесс производства длится несколько недель или месяцев, может счесть для себя приемлемым подождать десять минут и даже больше, пока оператор найдет и поставит нужный диск. Редактор же ежедневной газеты вряд ли согласится ждать, пока будет получена цифровая фотография, больше нескольких минут, т. е. его данные должны храниться в многотомной системе на оптических дисках с автоматическим поиском и установкой компакт-диска. Видеоклипы, распространяемые по каналам кабельного телевидения, должны быть доступны практически мгновенно.

7.3.
Информационная структура современного издательства

В связи с быстрым развитием электронных средств и систем распространения информации возникает все больше вопросов относительно роли новых издательских технологий и значимости электронных изданий в современном мире. Прежде всего остановимся на том, какие изменения характеризуют современные технологии издательского процесса:

  • все более широкое использование компьютеров не только при непосредственной подготовке книги или журнала, но и для создания и ведения издательского портфеля, подготовки иллюстраций, оригинал-макетов, диапозитивов и пр.;

  • использование сетевых технологий для организации совместной работы и взаимодействия наборщиков, верстальщиков, оформителей издания и т. д.;

  • повсеместное внедрение электронной формы представления издательского портфеля в виде базы данных, в которой хранятся не только окончательно сверстанные издания, но зачастую и их версии;

  • распространение в электронном виде точной копии печатного издания с возможностью ее последующей распечатки в случае необходимости в произвольном количестве экземпляров;

  • появление принципиально новых типов изданий с использованием чисто компьютерных технологий, таких как гипертекст, мультимедиа, электронное аналоговое моделирование, анимационные эффекты;

  • подключение практически всех средних и крупных издательств к всемирной сети Интернет, что открывает совершенно новые возможности сточки зрения доступа к информации, распространяемой данным издательством.

В состав цифрового мультимедиа наряду с традиционными текстовыми и графическими файлами в самых различных форматах, входит также цифровые аудио файлы, анимационные графические файлы и видео файлы в цифровом формате.

Основной информационных носитель цифрового мультимедиа - это компакт-диск, а в последние годы еще и DVD-диск, хотя такая информация может непосредственно передаваться по сетям связи, храниться в виде соответствующих файлов на жестких магнитных дисках персональных компьютеров, накапливаться в виде специальных баз данных, к которым возможно, в том числе и дистанционное обращение для занесения новой или извлечения имеющейся информации.

Все известные традиционные промышленные технологии имеют ограниченную сферу применения, что обычно следует из самого их названия. В то же время трудно привести пример области науки или техники, которая хотя бы потенциально не была связана с технологиями мультимедиа. Цифровое мультимедиа объединяет все известные формы представления информации - текст, графику и фотографические изображения, цифровое видео и аудио, цифровые модели объектов и интерактивные данные, такие как Java-апплеты. Главная задача мультимедиа технологий состоит интеграции процессов создания, управления и распространения информации любого вида.

Современное издательство постепенно превращается в систему для Обработки и хранения цифровой медиа-информации. В функции издательской системы будет входить оцифровка, индексация, длительное хранение, извлечение и защита от несанкционированного доступа цифровой медиа-информации в распределенной сетевой среде. Основные подсистемы издательской информационной системы, представленные на рис. 7.2 Рис. 07.02., перечислены ниже ссылка на источники литературы:

  • централизованное хранилище цифровой информации всех типов и форматов;

  • совокупность цифровых технологий для загрузки изданий в хранилище и их каталогизации;

  • система поиска и просмотра первичной информации;

  • доставка единиц хранения информации работнику издательства для редактирования.

Такая издательская система должна обладать определенным набором свойств, а именно:

  • все типы данных должны храниться в едином информационном пространстве;

  • минимизация ручного труда по каталогизации и индексации информации;

  • вся информация должна быть доступна с любого клиентского компьютера;

  • должна быть обеспечена возможность нахождения издания по его информационным характеристикам;

  • клиентское программное обеспечение должно легко стыковаться со средствами обработки и создания содержания изданий;

  • издания должны быть доступны только для лиц с соответствующими правами доступа.

Рассмотрим основные компоненты информационной структуры издательства. Основные компоненты системы локализуются на сервере или нескольких серверах. В частности, отдельный сервер обычно используют для ведения издательской базы данных. Иногда может быть выделен специальный сервер доставки информации клиенту, реже - сервер для поиска нужных электронных изданий. Для интеграции сервера (серверов) с клиентскими компьютерами используется издательская интрасеть. Наконец, посредством экстрасети и сети Интернет могут быть подключены территориально удаленные сотрудники издательства и некоторые контрагенты, с которыми поддерживается регулярная информационная связь.

Ядром любой издательской информационной системы является хранилище изданий. Естественно, издания хранятся в электронной форме, т. е. хранилище электронных изданий - основной компонент информационной системы издательства. Поэтому требования к этому компоненту и особенности организации хранения электронных изданий будут рассмотрены в специальном параграфе. Здесь следует лишь отметить, что для организации эффективного поиска изданий необходимо хранить атрибутивную информацию или метаданные, т. е. имя автора или авторов, название издания, время первой публикации издания, название издательства, кому принадлежат авторские права, характер представления данных (тип файла) и пр.

Загрузчик является той частью издательской системы, которая должна сделать ввод изданий и документов настолько эффективным, насколько это возможно. Поскольку количество вводимой информации велико, становится понятно требование минимизации ручного труда в этом процессе.

При вводе документов одновременно должны генерироваться метаданные для каталогизации и индексирования, на основе которых документы могут затем извлекаться пользователями. Известно несколько способов автоматизации, соответствующих разным методам доступа к данным. Наиболее известен и хорошо отработан метод автоматической индексации полного текста. Самые прогрессивные средства индексации текста базируются на технологии семантических сетей, в которой значения слов определяются по контексту, а не просто подбором унифицированных терминов для отдельных слов, однако пока работу программных средств нельзя назвать безупречной. Представляется оправданным включение в метаданные ключевых слов и выражений, отобранных автором (иногда редактором), так как никто лучше них не сможет подобрать набор ключевых слов, оптимально характеризующих как тематическую область издания, так и его отличия от близких по тематике. Возможен отбор этих слов из уже имеющегося в атрибутивной базе данных набора, но иногда оправдано и расширение этого общего набора путем ввода дополнительных элементов, характерных для нового издания.

В издательской деятельности возможна автоматическая генерация связей для отношений «содержится» и «используется в» путем разбора языка компоновки страниц и выделения элементарных объектов из составных документов. Чем более структурирован язык составления страниц, тем легче выделять информацию: форматы с высоким уровнем структуризации, подобные Adobe FrameMaker, SGML и XML, удобнее, чем форматы со специальной структурой типа QuarkXPress и Word, хуже всего интерпретируются форматы, не имеющие четко выраженной структуры - PostScript и, в меньшей степени, PDF.

До сих пор не существует общих средств автоматического выделения нетривиальной информации из изображений, аудио и видео, но некоторые разработчики (Kodak, LivePicture, Virage, Excalibur) занимаются исследованиями в этой области. Иногда атрибутивные метаданные могут генерироваться просто путем извлечения информации из определенных форматов данных. Лучший пример этого - форматы файлов Adobe PhotoShop, которые содержат массу полезной информации.

При загрузке добавляются не только метаданные, но и вспомогательные представления документов, в частности, миниатюры, представляющие внешний вид издания. Генерация миниатюр может быть автоматизирована. Например, большинство графических форматов содержат свои собственные миниатюры, для других, например для изображений с высоким разрешением, можно сгенерировать их «на лету». Аналогично можно спроектировать загрузчик таким образом, чтобы он, получая цифровые аудио-объекты, создавал клипы первых нескольких секунд (например, в форма те WAV 10 КГц). Таким же образом видео MPEG-2 может преобразовываться в клипы QuickTime длительностью в 5 или 10 с.

Существует два базовых способа доставки цифровых документов пользователю: передача файлов - ее можно использовать для текстов, изображений, аудио и видео с низким качеством, и поточная передача для высококачественного «движущегося» медиа-аудио, видео и анимации. Этот последний способ налагает очень серьезные требования на возможности сервера.

При хранении мультимедиа-данных требования к вычислительным ресурсам, необходимым для передачи документов, качественно отличаются от требований к подсистеме хранения. Поэтому, во многих случаях, выделяется отдельный сервер доставки данных. В первую очередь этот сервер должен иметь высокую пропускную способность для передачи мультимедийных объектов из хранилища на клиентские компьютеры. В идеале медиа-память должна допускать многосерверный доступ так, чтобы хранилище разделялось между сервером хранения и сервером доставки данных.

Сервер доставки аудио/видео должен обеспечивать гарантированную пропускную полосу для потока данных, поэтому в архитектуре сервера должны быть сбалансированы ресурсы процессора, периферия ввода / вывода и сетевых интерфейсов. Программное обеспечение сервера доставки, во-первых, должно включать средства низкого уровня для работы с файлами, обеспечивающие различные режимы проигрывания медиа. Во-вторых, нужно, чтобы это ПО определяло стандартные интерфейсы для разработки приложений - «плейеров» на клиентской стороне и реализовывало серверную часть этих интерфейсов.

В большинстве случаев используется сквозное проигрывание (playthrough), что дает возможность начать просмотр мультимедийного издания еще до того, как он полностью загружен на сервер доставки. Например, сервер MediaCenter фирмы Sun Sun позволяет начать воспроизведение аудио- или видео-данных уже через пять секунд после начала загрузки. Сквозное проигрывание необходимо для приложений с быстрым и непрерывным обновлением содержания. Режим playthrough развивает метод оперативной загрузки, который заключается в способности сервера одновременно загружать один и воспроизводить другой документ.

На уровне операционной системы видеоматериалы представляются взаимосвязанной совокупностью файлов (см. также § 3.5). Так, для фильма в цифровой форме хранятся файлы одного или нескольких видеопотоков и файл для аудиопотока. В дополнение к файлам содержания существуют вспомогательные файлы, которые поддерживают распределение первичного файла по разным дискам (striping), синхронизацию между видео и аудио, обеспечивают разные режимы воспроизведения.

Браузер представляет собой интерфейс пользователя для доступа и просмотра электронных изданий. Отделение браузера от уровня клиентских сервисов подчеркивает тот факт, что он может быть реализован с помощью любого стандартного Web-браузера, что дает множество преимуществ, например независимость от платформы. Наращивание функциональных возможностей может происходить путем добавления сервисов в рамках задаваемой браузером общей организации.

Браузер обеспечивает интерфейс с сервисом запросов и должен обеспечивать следующие функции:

  • иерархический доступ каталог/файл, аналогичный менеджеру файлов;

  • интерфейсы для поиска;

  • просмотр списка ответов, включающего миниатюры;

  • навигацию по связям между документами.

Если данный клиент обладает правами доступа к хранилищу изданий, он может, выбрав одну из миниатюр, сформировать запрос к хранилищу изданий на получение соответствующего документа. После определенного времени ожидания, связанного с выбором соответствующего информационного носителя в хранилище, сервер доставки начнет передачу клиенту запрошенной информации.

Второй главный компонент браузера - средства просмотра для мультимедийных изданий. Для этого компонента существенно, чтобы медиа-документы были представлены в распространенных форматах либо легко преобразовывались в них. Браузер, однако, должен быть способен получать документы в их родных форматах и активизировать соответствующие приложения обработки, например чтобы пользователь мог редактировать документы.

7.4.
Автоматизация выделения метаданных

7.4.1.
Метаинформация и ее роль

Повсеместное распространение информационной среды Интернет привело к заметному перекосу в части использования однонаправленных ссылок, служащих для организации переходов от одного документа к другому в гипертекстовых структурах. Такие ссылки не имеют атрибутов и не обеспечивают структурирования и классификации документов.

В настоящее время объем информации, циркулирующей в среде Интернет, приближается или даже превысил некий критический предел, в результате значительная ее часть остается невостребованной, препятствуя, пo существу, эффективному использованию этой среды. Все более актуальной становится задача создания гибкой информационной среды для хранения документов, включая статьи, доклады, книжные издания. Желательно обеспечить возможность сборки таких документов в группы (коллекции) с последующей возможностью включения этих первичных коллекций в состав других групп, стремясь получить в результате иерархическую структуру и, в, конечном счете, попытаться упорядочить информационное пространство в целом.

Ссылки следует снабдить такими атрибутами, как имя автора (авторов), название работы, время создания, срок хранения. Интересно отметить, что такие атрибуты рекомендовано хранить не вместе с документами, которые они характеризуют, а в отдельной базе данных, что позволит существенно упростить и ускорить поиск документов. Таким образом, структура хранилища, предложенная в § 7.2, соответствует рекомендуемой в настоящее время структуре хранения данных в глобальной сети.

Для описания метаданных консорциумом W3C подготовлен стандартный формат их представления - Resource Description Framework (RDF), который определяет основные принципы обработки метаданных и обеспечивает функциональную совместимость Web-приложений, обменивающихся такой информацией. В RDF использованы принципы объектно-ориентированного программирования и моделирования и элементы языков HTML, SGML и XML (см. также § 2.9). Следует заметить, что с одной стороны язык XML описывает в RDF синтаксис метаданных, a RDF, в свою очередь, позволяет описывать семантическую структуру XML-документов и передавать смысл данных, заключенных между XML-тегами. Консорциум W3C в учебнике упоминается несколько раз, но роль этого объединения в стандартизации и унификации сетевых средств и технологий поистине неоценима. И мы ее касаемся лишь в незначительной степени.

Наше время характеризуется достаточно тесной интеграцией издательств с сетью Интернет и использованием локальных интрасетей в самом издательстве. Таким образом, даже исходя из требований интеграции в издательстве информация об изданиях должна сопровождаться метаинформацией, которая извлекается из содержимого самого издания, желательно автоматически. Представительство издательств в глобальных сетях также требует соответствия между структурой издательских баз данных и информационных хранилищ на поисковых серверах.

7.4.2.
Законы Зипфа и автоматизация извлечения метаданных из электронных изданий

Известный математик Зипф Дж. Дж. Зипф (С. К. Zipf) показал, что все созданные человеком тексты подчиняются общим закономерностям, которые он сформулировал в 1946 г. в виде нескольких законов.

Если взять любой текст, то можно подсчитать, какие слова в нем сколько раз встречаются. Количество повторов слова в тексте можно назвать частотой. Чаще всего встречающемуся слову можно приписать ранг 1, следующему по частоте - 2 и т. д. Если несколько разных слов имеют одинаковые частоты, то учитывается только одно из этих нескольких значений. Если разделить частоту повторения слова на общее количество значащих слов в тексте, то получим его относительную частоту или вероятность встречи этого слова в тексте. Первый закон Зипфа гласит, что произведение вероятности встречи слова в тексте на его частоту приблизительно постоянно для любых текстов определенного языка. Сказанное иллюстрируется рис. 7.3 Рис. 07.03., где представлена зависимость частоты встречи слова в тексте f от его ранга R.

Второй закон Зипфа определяет соотношение между частотой и количеством слов, которые с этой частотой встречаются в тексте. Если построить график зависимости количества слов и частоты, то окажется, что характеризующая ее кривая остается неизменной для любых текстов в пределах одного языка. Сказанное иллюстрируется да иным и рис. 7.4 Рис. 07.04., на котором показаны кривые для английского (самая нижняя), французского и русского языков (самая верхняя).

Данные рис. 7.3 Рис. 07.03. могут успешно использоваться на практике для выделения значащих слов в тексте. Все значащие слова для данного текста размещаются в области средних значений ранга (область выделена на рис. 7.3 Рис. 07.03. штриховкой). Действительно, самые часто встречающиеся слова обычно относятся к вспомогательным, а самые редко встречающиеся обычно также не имеют решающего смыслового значения для данного текста. От того, как будет задан диапазон значимых слов, зависит многое. Если сделать его слишком широким - нужные термины потонут в море вспомогательных слов, установив чрезмерно узкий диапазон мы рискуем потеряешь смысловые термины.

Если рассматривать совокупность изданий, в особенности, посвященных одной и той же тематике, то вероятность случайного попадания малозначащих слов в выделенную область для группы изданий (см. рис. 7.3 Рис. 07.03.) уменьшается. Чтобы учесть такую возможность избавиться от случайных слов вводят понятие инверсной частоты термина. Инверсная частота определяется как логарифм отношения общего количества рассматриваемых документов п кчислу документов, содержащих данный термин m (под термином может пониматься не только отдельное слово, но и единое по смыслу словосочетание), т. е.

.

С учетом инверсной частоты вес или значимость термина в каждом документе определится как произведение

,

где z - вес или значимость термина в издании; f - частота повторения термина в этом издании; i - инверсная частота этого термина в группе издании.

Процесс определения веса или значимости термина в издании легко алгоритмизируется. На этом принципе основана работа всех программ - экстракторов значащих слов. Надо сказать, что даже широко распространенный в нашей стране редактор Word, начиная с версии 1997 г., как-то выполняет функции извлечения терминов. Для этого используется команда «Реферат» в секции меню «Сервис». Соответствующее команде диалоговое окно показано на рис. 7.5 Рис. 07.05..

Как следует из данных рис. 7.5 Рис. 07.05., реферат можно поместить в начало реферируемого документа или оформить в виде отдельного файла. Можно также регулировать размер реферата, задавая в процентах от основного текста количество предложений в нем. В примере на рис. 7.5 Рис. 07.05. в реферате содержатся два предложения, в то время как в исходном документе их было двадцать одно. Наряду с составлением реферата из текста документа извлекается пять наиболее значимых слов. Для их просмотра следует воспользоваться командой «Свойства» секции меню «Файл». Соответствующее диалоговое окно показано на рис. 7.6 Рис. 07.06..

Для того чтобы ключевые слова были занесены в нужное поле вкладки «Документ» окна «Свойства», в диалоговом окне, показанном на рис. 7.5 Рис. 07.05., должна быть задействована опция «Обновить сведения о документе»).

В поле «Ключевые слова» в примере отобрано пять слов, а именно: «в», «издательств», «области», «предусмотрен», «должен». Нетрудно за метить, что из пяти отобранных слов только одно соответствует тематике статьи «Современные издательства», причем одно из отобранных слов - предлог, который вообще не может иметь смысла, когда он берется отдельно от основного слова. Таким образом, качество отбора ключевых слов редактором Word 97 весьма низкое. Кстати, реферирование осуществляется только для работе названием на английском (а не на русском) языке. Надо сказать, что редактор Word 2000 ничем существенным не отличается от своего предшественника.

7.4.3.
Применение программ-экстракторов

Выделение Метаинформация метаинформации и Ключевое слово ключевых слов из изданий может быть выполнено с помощью специальных программ-экстракторов. Одна из первых таких программ - это Extractor, созданный в Институте Информационных Технологий Национального исследовательского Совета (NRC) Канады. В настоящее время доступна версия 7.0 этой программы.

Extractors качестве исходных данных использует текстовый документ, генерируя на выходе совокупность ключевых слов. Он обрабатывает тексты на английском, французском, японском, немецком, испанском и корейском языках. К сожалению, к русскому языку он пока не адаптирован. Алгоритм работы программы использует метод обучения на примерах. Алгоритм изначально предназначен для моделирования человеческого подхода к выбору ключевых слов. На большинстве платформа время работы программы с 10-страничным документом не превышает секунды. Пример интерфейса и результатов работы программы Extractor 7.0 с документом на английском языке представлен на рис. 7.7 Рис. 07.07..

На рис. 7.7 Рис. 07.07. представлен набор ключевые слов и выражений (Key-phrases) и основные фрагменты текста (Highlights). Ключевые слова в основных фрагментах текста автоматически выделяются жирным шрифтом, а наименее важные слова автоматически отображаются в серых (а не черных) тонах.

Разработанная фирмой «Научно-производственный инновационный центр «Микросистемы» отечественная программа-экстрактор Text-Analyst 1.5 позволяет на первых же этапах работы с текстами ответить на естественные вопросы, возникающие по ходу анализа. Интерфейс и заставка программы представлены на рис. 7.8 Рис. 07.08..

Демонстрационная версия этой программы доступна бесплатно на сайте фирмы. Применение программы резко сокращает время, необходимое эксперту для погружения в тематику, и дает множество подсказок и наводящих соображений для тонкого и углубленного анализа как всей информации в совокупности, так и отдельных ее фрагментов. Первые успехи эксперта при работе с анализаторами текстов, как правило, служат основой для постановки более сложных задач анализа и структурирования. И с ними TextAnalyst успешно справляется.

В настоящее время распространяется новая версия TextAnalyst 2.01, которая разработана в качестве инструмента для анализа содержания текстов, смыслового поиска информации, формирования электронных архивов, и предоставляет пользователю следующие основные возможности:

  • анализа содержания текста с автоматическим формированием семантической сети с гиперссылками - получения смыслового портрета текста в терминах основных понятий и их смысловых связей;

  • анализа содержания текста с автоматическим формированием тематического древа с гиперссылками - выявления семантической стру ктуры текста в виде иерархии тем и подтем;

  • смыслового поиска с учетом скрытых смысловых связей слов запро са со словами текста;

  • автоматического реферирования текста - формирования его смы слового портрета в терминах наиболее информативных фраз;

  • кластеризации информации - анализа распределения материала текстов по тематическим классам;

  • автоматической индексации текста с преобразованием в гипертекст;

  • ранжирования всех видов информации о семантике текста по «степени значимости» с возможностью варьирования детальности ее исследования;

  • автоматического/автоматизированного формирования полнотекстовой базы знаний с гипертекстовой структурой и возможностями ассоциативного доступа к информации.

Результаты работы программы TextAnalyst 2.01. представлены на рис. 7.9 Рис. 07.09..

В тексте выделены цветом и подчеркнуты термины, которые TextAnalyst 2.01 предлагает использовать в качестве ключевых слов, терминов, отражающих смысловое содержание работы. Пользователь может исключить часть этих слов или добавить другие, что будет учтено программой в дальнейшей работе. По нашему мнению, эта программа может успешно использоваться для автоматизации извлечения метаинформации из загружаемых в хранилище изданий.

7.5.
Публикация содержимого баз данных на Web-страницах

7.5.1.
Публикация статических Web-страниц

Источником для создания статической Web-страницы может служить любой набор записей в базе данных. Обычно на таких страницах публикуется таблица базы данных (или ее некоторая часть) или данные, полученные в результате выполнения некоторого запроса к базе. Вариантом публикации может быть отчет, созданный на основе данных, содержащихся в базе. Такая публикация может далее просматриваться в браузере. Если отчет состоит из нескольких страниц, то формируется несколько HTML-файлов, связанных друге другом гипертекстовыми ссылками. Однако не сохраняется связь этого файла с источников данных, т. е. Web-страница остается неизменной при изменении содержимого базы данных.

Все такие публикации создаются в результате экспорта соответствующих объектов базы данных. Если для такой операции используется база, созданная в рамках СУБД ACCESS (она входит в состав пакета MS Office), то рекомендуется придерживаться следующего порядка действий:

  • открыть и проверить содержимое материалов базы данных, которые предполагается публиковать;

  • выбрать объект для публикации, т. е. выбрать соответствующую вкладку диалогового окна, показанного на рис. 7.10 Рис. 07.10. (в примере нажата кнопка «Отчеты» и выбран отчет «Итоги продаж по объему»);

  • с помощью команды «Экспорт» (рис. 7.11 Рис. 07.11.) секции меню «Файл» от крыть диалоговое окно «Экспорт объектов», показанное на рис. 7.12 Рис. 07.12.;

  • в этом окне выбрать папку для размещения файла, указать его имя и тип (html или htm) и сохранить, нажав соответствующую кнопку;

  • при необходимости указать имя HTML-шаблона в появившемся после нажатия кнопки «Сохранить» диалоговом окне «Параметры вывода в формате HTML».

Полученный HTML-документ может содержать несколько страниц, связанных гиперссылками. Так в нашем примере он состоит из трех страниц (рис. 7.13 Рис. 07.13.). Из них первая или основная носит присвоенное отчету имя, а для остальных к этому имени добавляется номер страницы. В качестве примера на рис. 7.14 Рис. 07.14. показана первая страница документа. Гиперссылки в виде переходов к предыдущей, последующей, а также первой и последней страницам, размещены в нижней части полосы. Содержательная часть страниц представлена значениями из учебной базы «Борей», распространяемой совместно с СУБД MS Access.

7.5.2.
Публикация динамических Web-страниц

При всех своих достоинствах, публикации статических Web-страниц не позволяют поддерживать актуальность публикуемых данных. Из вариантов динамического связывания Web-страниц с внешними информационными источниками наибольшее распространение получили следующие:

  • использование HTML-форм и CGI-скриптов для их обработки;

  • динамические публикации страниц в формате IDC/HTX;

  • публикации динамических Web-страниц в формате ASP;

  • применение специальных страниц доступа к данным.

Первый вариант, по существу, уже обсуждался в общем виде в § 2.8. Он связан с пересылкой на сервер запроса в виде HTML-формы, в которой указаны переменные, текущие значения которых требуется узнать. На сервере с помощью CGI-скриптов эти формы обрабатываются и с помощью интерфейса с СУБД, поддерживающей локализованную на нем же базу данных, возвращаются новые значения соответствующих величин, которыми заменяют прежние. Этот способ обеспечивает максимальную гибкость, но требует создания и хранения на сервере CGI-скриптов и других пользовательских процедур.

Другие варианты организации динамической связи требуют, чтобы на сервере был определен соответствующий источник данных. Технология IDC (Internet Database Connector - средство связи сети Интернет с базою данных) / НТХ (HTml extension - расширение языка HTML) позволяет передать параметры запроса пользователя к базе данных как часть сообщения от браузера на сервер, получая в ответ динамически сформированную Web-страницу. Запрос, посылаемый серверу, - это текстовый файл в формате IDC, в котором содержится набор операторов языка SQL (Structured Query Language - язык структурированных запросов).

Язык SQL поддерживается практически всеми СУБД. В данном случае с его помощью формируется описание действий, которые должны быть выполнены на серверной стороне. Соответственно IDC-файл является исполняемым и на сервере должен размещается в папке Scripts (сценарии), предназначенной для исполняемых процедур. Пользователь должен иметь возможность занесения файлов в эту папку. В составе IDC-файла должен также находиться шаблон, описывающий Web-страницу, в составе которой будет таблица, форматирование которой определяет, каким образом будут отображаться данные, извлеченные из базы.

Какой же порядок динамического взаимодействия между пользователем и базой данных? Пользователь вводит в адресном окне браузера адрес IDC-файла. Web-сервер отыскивает этот файл в папке Scripts и активизирует динамическую библиотеку httpodbc.dll. Процедуры этой библиотеки просматривают IDC-файл и определяют имя внешнего источника данных (URL базы данных). Из библиотеки выбирается нужный драйвер, который взаимодействует с источником данных, выполняя запрос на языке SQL и извлекая нужную информацию из этого источника. После этого специальная процедура библиотеки извлекает из IDC-файла имя шаблона и формирует на основании его гипертекстовый файл, который отсылается браузеру компьютера клиента. Наконец, последний формирует и отображает Web-страницу в своем окне.

Технология публикаций ASP (Active Server Pages - страницы активного сервера) подобна рассмотренной первой. Отличие лишь в том, что она адаптирована к использованию Web-сервера, работающего в операционной системе Windows и вместо CGI-скриптов использует процедуры взаимодействия, написанные на языке VBScript, одной из ветвей языка Bisual Basic.

Самой современной и наиболее эффективной в настоящее время является технология динамической публикации на основе страниц доступа к данным (Data Access Pages - DSP). Страница доступа к данным представляет собой Web-страницу, на которой размещены связанные с внешним источником данных компоненты ActiveX (см. § 2.9), а также процедуры, написанные на языке VBScript. Сочетание гибкости управления объектами страниц доступа к данным с мощными функциональными возможностями компонентов ActiveX делает такую технологию чрезвычайно эффективной для организации удаленного доступа к данным и их динамической публикации на Web-страницах.

Страницы доступа к данным интегрированы в СУБД MS Access, причем в окне базы данных им отведена отдельная вкладка «Группы». Они разрабатываются в режиме «Конструктор страниц». Разработанные страницы доступа следует поместить в соответствующую папку Web-сервера. В самой базе данных остаются ярлыки, указывающие на файлы гипертекста, описывающие эти страницы. Использование страниц доступа к данным позволяет создавать интерактивные отчеты, формы для удаленного ввода, удаления и редактирования записей в базе данных, средства для удаленного анализа данных.

Детальное изучение этих технологий не входит в содержание учебника. Поэтому мы отсылаем всех интересующихся данным вопросом к книгам ссылка на источники литературы. Некоторые сведения по принципам и применению CGI-технологий можно извлечь из книги ссылка на источники литературы и статьи ссылка на источники литературы.


Электронные издания:

8.
глава VIII. Распространение электронных изданий

В отличие от предыдущих глав здесь рассматриваются технологии распространения электронных книг, газет и журналов. Основное внимание уделено сетевым технологиям распространения изданий и представительству в сети Интернет издательств, библиотек и электронных книжных магазинов. Рассматриваются также новейшие средства распространения электронных изданий, связанный с использованием технологий E-book.

8.1.
Виртуальный мир книги и его особенности

Понятие «виртуальный» в последние годы все шире используется в массовом обиходе. Источник этого следует, вероятно, искать в популярных фильмах, таких как «Газонокосильщик» или «Секретные материалы», в которых герои с помощью компьютера попадают в иной мир, который и носит название виртуальный, где активно действуют, сражаются, иногда изменяя течение событий в реальном мире. Термин стал настолько расхожим, что его используют даже в отечественных политических кругах, скажем, в Государственной Думе.

Мы же ставим перед собой значительно более узкую, конкретную задачу, а именно, описать возможность знакомства с различными электронными книгами в тех случаях, когда у нас нет в руках самих этих книг. На рубеже тысячелетий только в нашей стране возможность находиться в виртуальном мире имели около пяти миллионов человек, у которых домашний компьютер снабжен модемом и оплаченным доступом в Интернет. В глобальной сети представлено в виде собственных серверов или сайтов на серверах большое число реальных издательств и множество Интернет-магазин книжных магазинов.

Кроме того, привычным для нашей страны стали виртуальные книжные магазины и прилавки, которые распространяют книги через сеть, не имея никакого торгового объекта в реальном мире, даже простого киоска или стола на книжном развале. Познакомиться с электронными изданиями можно, обратившись в электронную библиотеку. Такие библиотеки могут быть двух видов:

  • представительства в сети реальных библиотек, обычно крупных, имеющих свои собственный Web-сервер или сайт;

  • типично виртуальные библиотеки, не имеющие реального представительства, а предоставляющие читателям только электронные книги; такие библиотеки организуются энтузиастами и пополняются не только организаторами, но и читателями.

Таким образом, средствами распространения электронной книги в сети являются: виртуальные магазины, которые могут существовать и на сайтах издательств, представительства в сети крупных государственных библиотек, виртуальные библиотеки, т. е. созданные на некоммерческих началах сетевые хранилища электронных изданий. Все перечисленные средства, позволяющие сделать электронную книгу доступной читателю, будут рассмотрены ниже. Вначале рассмотрим виртуальные библиотеки.

8.1.1.
Некоммерческие электронные библиотеки

Возможность познакомиться с интересными книгами предоставляется на некоторых серверах и сайтах. Обычно они так и называются «Электронная библиотека».

Самая известная из них в Русском Интернете - библиотека Максима Мошкова (http://www.lib.ru), информационный объем которой превышает 1,7 Гб. Она была открыта в 1994г. Читатели ежедневно пополняют ее новыми файлами. Здесь есть современная и античная художественная литература, фантастика и политика, техдокументация и юмор, история и поэзия, туризм и парашютизм, философия и эзотерика. Главное достоинство этой и ей подобных библиотек состоит в том, что посетитель может выбрать любую понравившуюся ему книгу и бесплатно «скачать» ее на свой компьютер. После этого он может читать или изучать ее электронную версию или распечатать книгу и работать или отдыхать с распечаткой без компьютера. Здесь автор может сослаться на собственный пример: именно так он познакомился с творчеством Милорада Павича «Пейзаж, нарисованный чаем», которая размещается в иностранной прозе (http://www.lib.ru/INPROZA/ PAWICH/tea.txt).

Главная страница этого сервера показана на рис. 8.1 Рис. 08.01.. Страница характеризуется большой протяженностью, поэтому на рисунка показан лишь верхний ее фрагмент. Как видно из рисунка на сервере предусмотрена возможность поиска нужной книги, разнообразные переходы на конкретные виды литературы, включая новинки (то, что недавно переведено в электронную форму и включено в состав библиотеки) и самиздат, т. е. произведения непрофессиональных писателей, представленные пока только в электронном виде. Следует отметить, что сайт имеет множество зеркал, т. е. его копии воспроизводятся на самых различных серверах.

В качестве примера оформления приведем страницу сайта «Новые поступления», которая показана на рис. 8.2 Рис. 08.02.. И эта страница достаточно протяженная, поэтому показана только ее верхняя часть. Из рисунка следует, что можно подписаться на новинки и получать их по электронной почте, заполнив соответствующую форму на странице. Можно, указав само новое поступление, перенести его копию на свой компьютер, чтобы затем его прочесть. В частности, так поступил я сам с книгой Рекса Стаута.

Среди прочих предусмотрена страничка «Записки Web-мастера», которая предназначена для помощи начинающим посетителям сервера (рис. 8.3 Рис. 08.03.). Наряду с ответами на часто задаваемые вопросы на странице предусмотрено описание структуры HTML-файлов в виде набора из семнадцати тем, изучив которые новичок узнает о структуре и элементах этих файлов и приобретет начальные навыки работы с ними. Имеется и специальная страница для фанатов творчества известного английского писателя фантаста Толкиена, который в некотором смысле создал задолго до Интернета свой собственный виртуальный мир.

Интересно отметить, что на этом сайте все же производятся и коммерческие операции. Здесь находится виртуальный книжный магазин под названием «24x7», в котором помимо книг распространяются другие медиа-материалы, такие как видеокассеты, музыкальные записи, как это показано на рис. 8.4 Рис. 08.04.. Здесь же представлены новости культуры, включая театральные афиши и новости кино. На сайте множество других страниц, остановиться на которых мы не сможем из-за ограниченного объема статьи.

Следует также отметить, что сайт Максима Мошкова пользуется заслуженной популярностью в виртуальном мире, в связи с чем существует множество зеркальных его отражений на различных серверах.

Большая электронная некоммерческая библиотека расположена на сайте Всероссийского общества тинейджеров (http://www.svot.narod.ru). На рис. 8.5 Рис. 08.05. показана верхняя часть страницы этого сайта. Сайт оформлен как совокупность (список) нескольких электронных тематических библиотек, для каждой из которых указан ее электронный адрес и на которые возможен переход по ссылкам. Интересно, что в списке присутствуют так называемые «Авторские страницы», на которых желающие могут попытаться разместить (опубликовать) свои произведения, с которыми затем могут ознакомиться все желающие. Надо сказать, что многие люди имеют склонность к литературному творчеству, такая возможность им здесь представлена. Фрагмент страницы с собственными публикациями различных авторов показан на рис. 8.6 Рис. 08.06..

Интересное начинание, названное «Избой-читальней» представлено на сервере «Русский Сиэттл» (www.russianseattle.com). Это тем более интересно, что территориально сайт находится не в одном из крупных городов, а в так называемой «глубинке», в черноземной зоне. Не останавливаясь на особенностях самого сайта, отметим, что на нем представлен большой список электронных библиотек, связи с которыми и переходы к ним организованы на этом сайте.

В списке библиотек на рис. 8.5 [image] представлена популярная библиотека Сергея Тарасова «Чернильница», поисковая система «Букинист», предназначенная для поиска редких изданий, имеющихся в свободном доступе в Интернете, здесь же упомянута и библиотека Максима Мошкова как самая популярная и одно из ее зеркал, библиотека на сервере Сибирь-онлайн, своеобразная библиотека Бердичевского, специализированная библиотека файлов в компактном ZIP-формате «Русская фантастика», огромная (свыше 2,5 Гб) библиотека Дмитрия Трибиса (BIS-project).

8.1.2.
Представительство крупных библиотек в Интернете

Виртуальными электронными библиотеками называют также представительство реальных крупных библиотек в Интернете. Их перечень содержится в каталоге электронных библиотек (www.svot.narod.ru). Наибольший интерес представляет сводный каталог научно-технической литературы, представленный на сайте Государственной публичной научно-технической библиотеки (ГПНТБ), адрес которого www.gpntb.ru (рис. 8.7 Рис. 08.07.).

Каталог самой библиотеки содержит более 180.000 документов, в числе которых отечественные и зарубежные книги последних лет издания, авторефераты диссертаций, неопубликованные переводы и отчеты. Имеет развитый поисковый интерфейс. По умолчанию он рассчитан на тематический поиск по ключевым словам, с возможностью использования метаинформации (заглавие, автор, предметные рубрики). Множество дополнительных установок. В частности, можно менять количество ссылок в группе результатов поиска. Сводный каталог научно-технической литературы содержит более 400.000 записей и отражает содержимое всех крупных Российских библиотек. Его интерфейс абсолютно идентичен электронному каталогу ГПНТБ.

Каталог Научной Библиотеки МГУ - крупнейший российский каталог литературы универсального содержания, доступный через Интернет. В нем отражено более 190 тысяч описаний отечественных и зарубежных книг последних лет издания. Скромный поисковый механизм допускает разыскание лишь по автору, заглавию (первое слово) и ключевому слову. Найденные результаты выдаются группами по пять записей. Поисковый механизм не всегда работает надежно.

Из других каталогов отметим каталог Российской национальной библиотеки. В нем отражено более 40 тыс. книг, поступивших в библиотеку с 1998 г. Обеспечивается поиск по всем традиционным параметрам: индивидуальный и коллективный автор, место и год издания, предметные рубрики. На сервере РНБ также расположены каталоги авторефератов диссертаций, специальных видов литературы и карт. Каталог Фундаментальной библиотеки Санкт-Петербургского государственного технического университета содержит более 18 тысяч книг последних лет издания. Возможен поиск по автору (в том числе и коллективному), заглавию, индексам УДК и ББК, предметной рубрике, издательству, году издания.

Какие же услуги оказывают эти виртуальные представительства крупных библиотек и каталогов своим клиентам. Отметим, прежде всего, что все эти услуги платные. Помимо рассылки электронных копий изданий или их частей возможна также рассылка копий на вещественном носителе: ксерокопии, фотокопии, включая микрофотографии. Предоставляются также библиографические услуги в форме поиска литературы по определенной тематике с последующей рассылкой аннотированного списка литературы или самих этих изданий. Возможны различные варианты оплаты услуг, в том числе: банковский перевод, наличными, с помощью кредитной карты и депозитного счета.

Надо сказать, что такие информационные услуги во всем мире относятся к категории услуг, с удовольствием оплачиваемых пользователями, так как предварительная обработка информации экономит впоследствии значительную часть их рабочего времени. Естественно при условии, что эти библиографические услуги выполнены на высоком профессиональном уровне.

Пока коммерческие электронные библиотеки, рассылающие в электронной форме литературу и оказывающие дистанционно библиографические услуги, в высокой степени используют преимущества сетевых технологий для повышения качества и скорости оказания услуг. Тормозящим фактором здесь, как и для электронных магазинов и электронных прилавков при издательствах, является отсутствие гарантий конфиденциальности в виртуальном пространстве, в связи с чем опасно оплачивать услуги путем дистанционного перечисления своих средств с кредитной карты. В то же время огромная армия студентов почти насильно снабжена этими картами и могла бы дистанционно приобретать учебную и научную литературу, а также библиографические услуги (в частности, старшекурсники и дипломники). Однако активно проводящиеся в этом направлении исследования позволяют надеются на то, что в ближайшие годы все радикально изменится.

Некоммерческих электронные библиотеки обеспечивают массовое распространение книги и сопутствующих услуг. Это особенно важно для жителей удаленных небольших городов и деревень, во многом отрезанных от единого пространства культуры. Такие библиотеки, как модно было говорить двадцать лет тому назад, «стирают различия между городом и деревней», причем хотя используются для этого виртуальные технологии, они обеспечивают реальное осуществления такого процесса.

8.2.
Электронные книжные магазины

Для электронной торговли, в том числе и электронными изданиями, важнейшим фактором является фактор времени. Насколько важно оказаться первым, видно хотя бы на примере Американской фирмы Amazon.com. Не имея ни одного традиционного книжного магазина, она первой создала «виртуальный прилавок» и быстро преуспела в продаже книг через Internet, выручив в 1996 г. около 16 млн. дол, а в 1997 г.- уже более 121 млн. дол. Узнав об успехе начинающей фирмы, книжный гигант Barnes i Nobles Barnes & Nobles с оборотом в несколько миллиардов долларов также решил включить в свою сбытовую сеть электронные каналы и стал распространять продукцию через собственный Web-сервер и сетевую службу доставки America Online America Online. Результаты оказались впечатляющие - еженедельно объем заказов через Internet возрастал на 20% и, хотя общая их сумма в 1997 г. оценивается всего в 15-20 млн. дол., к концу 2000 года был достигнут уровень свыше 300 млн. дол.

Основные причины, сдерживающие развитие электронной торговли, - отсутствие у компаний развитой электронной инфраструктуры сервисной поддержки покупателей, а также недостаточная осведомленность и инерция последних. На решение этих проблем необходимо время.

Большой интерес представляет мотивация покупок клиентами виртуального магазина. По данным консалтинговых фирм ErnstYoung и Anderson Consulting 75% опрошенных указывали более низкие цены, 50% - удобства и отсутствие поездок, 48% - больший выбор и разнообразие и 29% - большее удовольствие (более забавно), чем традиционные покупки. По данным тех же фирм отказ от покупки товара в электронном магазине мотивировался следующими причинами:

  1. Нежеланием доверять свою кредитную карточку сетевым технологиями, опасениями, связанными с конфиденциальностью при ее использовании - 97%.

  2. Желанием предварительно ознакомиться с оформлением и качеством изготовления приобретаемых книг- 53%.

  3. Сложностью возврата товара и получения обратно затраченных на его покупку денег - 46%.

  4. Необходимостью ввода большого количества информации на Web- страницу для приобретения товара - 42%.

  5. Нежеланием дополнительно оплачивать доставку книг - 41%.

  6. Запутанной структурой и трудностями управления страницами сайта -18%.

  7. Чрезмерной затратой времени на заказ - 11%.

В нашей стране кредитные карточки пока не получили такого широкого распространения, как за рубежом, и оплата за сделанную покупку чаще всего производится при доставке книг. Поэтому главными причинами отказа от покупки книг и сопутствующих товаров в виртуальных магазинах следует считать 2 .. 6 мотивы из приведенного выше списка. Причем если пункты 3 и 5 списка почти непреодолимы, то ликвидация или смягчение других негативных мотивов вполне возможна. Для этого требуется представить фотографию обложки или переплета книги и исчерпывающие сведения по тематике книги и ее дизайну, а также качественно оформить сайт виртуального магазина или прилавка и предельно упростить ту его страничку, которая используется при оформлении заказа на книги.

Далее рассмотрим несколько примеров электронных книжных магазинов. Магазин «Бизнес-книга» (www.bizbook.ru) распространяет деловую и компьютерную литературу и справочники в пределах Москвы. Общее количество наименований книг около 2,5 тысяч, изображения обложек отсутствует, поиск производится по автору, названию и году издания, каталогизация одноуровневая, цена изданий розничная, для получения книги можно заехать в офис фирмы. Таким образом, у этой фирмы наряду с виртуальным существует представительство реальное.

Магазин агентства «Книга-сервис» (www.akc.ru) обслуживает все регионы России и предлагает художественную и деловую книгу. Общее количество наименований не указано, каталогизация, как и в предыдущем случае, одноуровневая, хотя сайт оформлен интереснее и включает в себя значительное количество дополнительной информации. Для каждой книги имеется миниатюра обложки или переплета и аннотация. Доставка почтовая. При оплате стоимость складывается из мелкооптовой цены книги и стоимости ее почтовой доставки, используется предоплата.

Магазин «КноРус» (www.book.ru) как и «Бизнес-книга» реализует деловую и компьютерную литературу, причем общее число наименований превышает 3000. Как и в предыдущем случае предусмотрены обложки и аннотации книг. На этом сервере возможен поиск книг по автору, названию и году издания. Оптовая цена на книге, указанная на сервере, не менее, чем в 1,5 раза ниже среднерозничных цен. В результате даже с учетом почтовой доставки затраты будут ниже, чем при покупке в реальном магазине.

Одним из первых в России открыла виртуальный книжный прилавок фирма «Озон», которая вначале арендовала сайт на одном из самых популярных в России серверов www.infoart.ru. Хотя наши электронные книжные магазины не сообщают о своих успехах, но можно предположить, что дела в этом магазине шли успешно, что позволило ему в 1999 г. создать свой собственный сервер www.ozon.ru. Сервер реализует функции виртуального магазина, в котором можно заказать все основные виды продукции медиа-индустрии: книги, видео- и аудио продукцию, компакт-диски с компьютерными программными пакетами.

На сервере организована современная схема отбора заказов путем пометки соответствующего товара и последующего нажатия кнопки «добавить в корзину». Когда потенциальный покупатель отобрал все необходимое, он имеет возможность «раскрыть свою корзину» и просмотреть отобранные издания, удалив те, от которых он решил отказаться. После этого он оформляет заказ с помощью специальной страницы с развитым интерфейсом.

Сайт характеризуется, пожалуй, чрезмерно разветвленной структурой с большим количеством страниц и ссылок и значительным числом уровней вложения. Так, главная страница (Home page) содержит 84 гиперссылки. Интерфейс сайта содержит также множество закладок, пиктограмм, выпадающих окон и окон прокрутки. Информационная часть сайта несколько перегружена рубриками, ссылками, цитатами, рекламой, разнообразными приложениями (рис. 8.8 Рис. 08.08.).

С другой стороны, удобно, что на каждой странице сайта есть окна поиска по ключевым словам, что облегчает поиск пользователю нужного ему издания. Полезным достоинством сайта является наличие архивированных списков изданий различного типа с указанием объема соответствующих файлов. Это позволяет перенести нужный файл на свой компьютер и, не расходуя лишних средств на оплату работы в глобальной сети, не спеша разобраться в том, что из имеющихся товаров тебе требуется.

Из интерактивных пользовательских средств на сайте имеются страницы со вставками элементов JavaScript, позволяющих отправить отзыв о прочитанной книге, а также принять участие в книжном, музыкальном и киноведческом конкурсах. Предусмотрены и вспомогательные страницы, такие как «Часто задаваемые вопросы», «Как сделать заказ», «Впервые на Озоне?» и пр. Подраздел «Услуги» также содержит несколько интересных рубрик: «Книжный клуб», «Подписка на новости», «Предложение сотрудничества», «Как заработать деньги» и т. д.

Адрес www.top-kniga.ru представляет сервер книготорговой фирмы «Ton-книга», крупнейшего за Уралом оптового распространителя изданий (помимо Сибири и Дальнего Востока в сферу интересов фирмы входит также Казахстан, точнее его русскоязычная часть населения) и одновременно электронного розничного магазина. В частности, интернет-магазин - книга-почтой является основным виртуальным распространителем книги в Зауралье, Сибири и на Дальнем Востоке.

Наконец, магазин «Атолл-On-Line» по продаже компьютерной литературы организован на Саратовском сервере (www.saratov.ru/atoll). Общее количество наименований составляет около 500, каталогизация на сервере одноуровневая, представлены обложка и аннотация книги, удобно организован простой и расширенный поиск книги, имеются прайс-листы, гостевая книга и доска объявлений. Кстати, при разрывах связи вся информация, в том числе отобранные в корзину книги, сохраняется. Однако этот магазин обслуживает только г. Саратов и реализует книги исключительно за наличный расчет.

В Петербурге виртуальные книжные магазины стали неотъемлемой частью ряда издательств, преимущественно связанных с выпуском компьютерной литературы. В частности, появился специальный сервер «Книги России» (www.books.ru), который принадлежит издательскому дому «Символ-плюс» и претендует на освещение книгоиздания и обеспечение возможности покупки любых Российских изданий. На сервере отдельно организовано взаимодействие с оптовиками, библиотеками, и розничными покупателями. Достаточно просто и содержательно оформлена лицевая страница. Наряду с изданными уже книгами анонсируются подготавливаемые к изданию (рубрики «Сданы в типографию» и «Готовятся к печати»), причем можно заранее оформить заказ на них.

Помимо книжных изданий представлена также периодика (журналы и газеты), компакт-диски, видеокассеты и программное обеспечение. В частности, можно познакомиться с содержанием журналов «Read.Me», «Вы и ваш компьютер». На сервере реализована многоуровневая каталогизация и наряду с простым (автор и название) сложный поиск (по ключевым словам текста и аннотации). Он выгодно отличается наличием не только предоплаты заказов, но и наложенного платежа, и указанием точных цен доставки книг в любой конкретный регион России и мира. На сервере содержатся также книжные обзоры, рейтинги книг, мнения читателей о книгах и самом сервере. В целом можно оценить его как один из лучших и наиболее современных книжных серверов России.

Еще хотелось бы упомянуть сервер Издательский Дом «Питер» Издательского Дома «Питер», адрес которого www.piter-press.ru. Там предусмотрен встроенный книжный магазин, реализующий продукцию только этого издательства. Оформление главной страницы достаточно лаконично и содержательно. Наряду с шестью основными разделами, ссылки на которые можно найти в верхней части любой страницы (издательство, книги, журналы, продажа, клуб, обратная связь), предусмотрены три кнопки: «корзина» (просмотр и редактирование заказа для зарегистрированных посетителей интернет-магазина), «письмо» (его получит Web-мастер) и «главная страница».

На главной странице можно прочесть свежие новости, подписаться на рассылку новостей по электронной почте, просмотреть рейтинги книг по результатам продаж, принять участие в опросах и увидеть их результаты. В разделе «Книги» можно просмотреть тематический каталог книг, выпущенных и намеченных к выпуску издательством, ознакомится с оглавлением и отрывками из книг, познакомиться с отзывами читателей и оставить свой отзыв.

После оформления заказа на Ваш электронный адрес отправляется сообщение, в котором перечисляются отобранные Вами книги и диски и их общая стоимость. В течение 24 часов с момента посылки этого сообщения вы можете отказаться от заказа, направив соответствующее электронное письмо в службу книги-почтой. Магазин обслуживает всю территорию России.

Следует отметить, что в Санкт-Петербурге, одним из первых в России, появилось специализированное виртуальное издательство Геликон Плюс «Геликон Плюс», организованное известным писателем А. Житинским для выпуска в свет электронных изданий молодых авторов. Авторы бесплатно могли выпустить свою книгу в электронной форме на сайте издательства, а читатели могли бесплатно познакомиться с этой книгой. Некоторые молодые авторы приобрели известность в результате таких электронных публикаций. Одна из информативных страниц этого сайта показана на рис. 8.9 Рис. 08.09..

Электронное издательство представляет собой один из путей решения основной проблемы любого издательства - определения тиража выпускаемой книги. Эта задача не имеет точного алгоритмического решения. В большинстве случаев издатель полагается на свой опыт, интуицию и возможность проведения целенаправленной рекламной компании для продвижения выпускаемой книги к читателю. Один из путей решения этой задачи - это печать по заказу (Print-on-Demand), реализуемый с помощью одной из страниц сайта. Эта страница представлена на рис. 8.10 Рис. 08.10.. Метод печати по заказу полезен для молодых авторов, предлагая им следующее:

  • сам факт опубликования книги;

  • возможность провести самостоятельно маркетинг и оценить уровень спроса;

  • низкий уровень расходов на электронную публикацию;

  • полную свободу самовыражения автора, включая верстку и дизайн книги.

Компьютерная сеть Интернет представляет средство маркетинга и рекламы электронной книги. Метод печати по запросу позволяет сделать издание книг безубыточным, так как купить книгу при печатном тираже в 200 экземпляров могут лишь те, кому она безусловно нужна. А для того, чтобы эти люди узнали о ее издании, необходимо сделать ее известной предельно широкому кругу лиц. Интернет предоставляет для этого все возможности, а также позволяет сделать на книгу заказ по электронной почте.

Таким образом, электронный, или виртуальный, книжный магазин возникает в результате создания сайта, объединяющего определенные ресурсы (чаще русскоязычные), связанные с литературой, компакт- и DVD-дискам и видео- и аудио-кассетами. Используя систему «встроенных» в издательский сайт магазинов, можно обеспечить удаленный доступ и возможность заказа различного рода товаров, а также возможность получения доступа к редкой и специальной литературе.

Для издателей и распространителей книги такие магазины дают возможность активизировать и расширить сферу своей рекламы, а также расширить рынок сбыта книги и сопутствующих товаров. В принципе имеется возможность распространения через сети электронных и мультимедийных версий изданий, что многократно повысило бы скорость распространения продукции, но пока эта возможность в России реально не используется.

Электронные магазины, организованные не при издательствах, заключают договора с издательствами или оптовыми книготорговыми фирмами для торговли виртуальным товаром. В этом случае ими берется определенный процент с каждого переданного заказа. Величина процента колеблется в пределах от 8 до 12%.

Пока электронные книжные магазины крайне неэффективно используют преимущества сетевых технологий для повышения качества и скорости оказания услуг. Основным тормозящим фактором является отсутствие гарантий конфиденциальности в виртуальном пространстве, в связи с чем опасно оплачивать услуги путем дистанционного перечисления своих средств с кредитной карты. Однако активно проводящиеся в этом направлении работы позволяют надеются на то, что в ближайшие годы все радикально изменится.

Этому же должно способствовать развитие технологий электронной доставки информационных товаров, в том числе электронных изданий. В частности, такие технологии разрабатывают фирмы Pitney Bowes Pitney Bowes, один из лидеров почтовых технологий, и Tumbleweed Software Corporation, специализирующаяся на решениях в области онлайновой доставки, которые объединили свои усилия для внедрения новаторской Web-службы под названием iSend.

Эта служба, построенная на основе платформы Posta компании Tumbleweed Tumbleweed, позволит любым предприятиям безопасно и надежно отправлять и отслеживать доставку любых файлов через электронную почту и средства Web-доступа. Служба iSend в настоящее время доступна по адресу www.pitneybowes.com. Основные достоинства iSend:

  • надежная доставка. В iSend комбинируются доступность электрон ной почты для оповещения и более надежные средства передачи файлов, имеющиеся в Web, что кардинально повышает надежность онлайновой доставки файла;

  • универсальная доставка. Для iSend не требуется никакого специального программного обеспечения или специфических протоколов. Лю бой пользователь, имеющий электронную почту и Web-доступ, может при менять iSend для отправки и получения файлов. Кроме того, в iSend интегрирована программа Adobe Acrobat для автоматического преобразования файлов в формат PDF (Portable Document Format), что позволяет легко просматривать документ, независимо от приложений, используемых отправителем и получателем;

  • безопасная доставка. В отличие от обычной электронной почты, в iSend важная информация защищается средствами безопасности «точка - точка», куда входят надежное шифрование, аутентификация и парольная защита. Кроме того, iSend может защищать уязвимые почтовые программы от повреждения документов и хищений;

  • контролируемая доставка. В iSend имеются развитые возможности отслеживания, предоставляющие отправителям наглядную картину процесса доставки их файлов. Федеральное правительство США пытается защитить от хакеров систему доменных имен.

Внедрение в будущем в отечественную практику этих и других аналогичных новаций вместе с повышением уровня защищенности систем сетевой оплаты, в частности, карт, выдаваемым студентам, позволяет предполагать, что в будущем развитие сетевых средств реализации и доставки электронных изданий будет идти нарастающими темпами.

8.3.
Технология E-book и развитие электронного книгораспространения

Современный уровень развития и распространения компьютерной техники определяет целесообразность перевода информации с носителей на бумажной основе в электронную форму. Мы несколько раз обращали внимание читателей на этот процесс ссылка на источники литературы. Новые разработки в области электронных изданий, представленные на мировом форуме информационных технологий CeBit в Ганновере в марте 1999 г., еще раз показали, что этот процесс неудержим и имеет практически неограниченные возможности для своего дальнейшего развития. Такое развитие информационных компьютерных технологий обратило на себя внимание ученых, журналистов, издателей и других специалистов, так или иначе занятых в области создания и распространения информации.

Здесь хотелось бы остановится на технологии E-book, которая определяет дальнейшее совершенствование и развитие электронного книгоиздания и книгораспространения. Сам термин E-book E-book переводится как «электронная книга», хотя правильней было бы говорить о переносной электронной библиотеке. Существует два различных понятия, обозначающихся одинаковым термином E-book. E-book называют как аппаратное средство (специализированный микрокомпьютер) для хранения и чтения электронных книг, так и сами такие книги. Многие сетевые магазины, продавая электронные издания, называют их электронными книгами. Нам кажется правильнее называть E-book только аппаратное средство для хранения и чтения электронных изданий.

Мы непременно читаем с экрана компьютера то, без чего невозможно обойтись: электронную почту, Web-страницы, подготавливаемые нами тексты и программы, потому что нет альтернативы. Однако символы с экрана читать труднее, чем печатную книгу, из-за худшего разрешения и бликов на экране. К тому же мы не можем работать вдали от своего рабочего стола. Даже пользуясь портативным компьютером, мы далеки от той удобной позы, которую человек принимает за чтением книги.

Новая аппаратура E-book и новые технологии чтения с экрана этого устройства ставят целью обеспечение максимального удобства при чтении электронных изданий, а также достижение того же самого качества восприятия информации, как при работе с напечатанной на хорошей бумаге книгой. При этом аппаратные средства E-book должны позволить носить с собой, если и не всю свою библиотеку, то хотя бы значительную ее часть.

8.3.1.
Специализированные аппаратные средства для работы с электронными изданиями

Предшественником аппаратуры E-book E-book можно считать устройства Pocket PC. Это универсальные устройства, позволяющее, кроме чтения электронных книг, пользоваться рядом программ, работающих на платформе Windows.

Одно из лучших устройств такого типа - это Casio Cassiopeia EM-500. В нем используется цветной монитор на жидких кристаллах (ЖК) и процессор Pentium-150. Из программного обеспечения для E-book с устройством поставляются Microsoft Reader с ClearType, о которых мы поговорим немного позднее.

Устройство Hewlett-Packard Jornada 545 также комплектуется Microsoft Reader с ClearType. Отличительной особенностью этого устройства является возможность подключения модемного модуля, являющегося одновременно сотовым телефоном. Сводные данные для перечисленных «карманных» компьютеров сведены в таблицу (см. табл. 8.1).

Таблица 8

Таблица 8.1.

Характеристики карманных ПР

 | Тип
Параметр | Casio Cassiopeia EM-500 | Hewlett-Packard Jornada 545
Размеры | 127 х 82х 19 | 132x78x15
Разрешение | 230x320 | 240 х 320
Глубина цвета | 16 бит | 12 бит
Размер экрана, мм | 762x584 | 736x533
Голосовой ввод | Да | Да
Аудио-выход | Да | Да
ОЗУ, Мб | 16 | 16
Процессор | 150MHz | 133 MHz
Встроенный модем | Нет | Да

Следующая группа устройств - это миниатюрные средства, которые помещаются на ладони- Handheld (иначе их можно держать водной руке). Наиболее популярное из них - Palm m100. Устройство Visor Prism отличается большим количеством отображаемых цветов, и широкими возможностями для расширения. Palm Vllx является одним из самых мощных в этом классе. Сравнительные характеристики перечисленных аппаратов сведены в таблицу (см. табл. 8.2).

Параметр

Таблица 8.2.

Характеристики карманных ПК

Параметр | Тип
 | Palm m100 | Visor Prism | Palm Vllx
Размеры | 118x79x18 | 121x76x20 | 133x82x19
Тип экрана | ЖК с подсветкой | Активная матрица | ЖК
Разрешение | 160x160 |  | 160x160
Глубина цвета | Монохром | 16-бит | Монохром
Размер экрана, мм | 63x80 | 60x60 | 63x80
Время работы батареи | До 2 месяцев | 6 часов | 2-4 недели
Голосовой ввод | Нет | Да | Нет
Аудио- выход | Нет | Да | Нет
ОЗУ, Мб | 2 | 8 | 8
Процессор | 20 MHz Intel | 33 MHz Motorola | 20 MHz Motorola
ОС | Palm OS v 3.5 | PalmOS, V.3.5.2H | Palm OS v 3.5

8.3.2.
Современное аппаратное средство E-book

Современное аппаратное средство E-book появилось в США в 1998 г. Разработчики его поставили перед собой задачу создать для читателей электронной книги условия, практически неотличимые от условий чтения обычной книги. Известно, что текст обычной книги в абсолютном большинстве случаев печатается на белой бумаге черной краской. Разрешение для символов печатной книги составляет не менее 300 точек на дюйм, в то время как разрешение мониторов немного превышает 100 точек на дюйм. Поэтому перед разработчиками стояла сложная задача, состоящая в устранении или ослаблении влияния этих очевидных недостатков электронной книги по сравнению с печатной.

Разработчикам удалось создать новую шрифтовую технологию ClearType и сопутствующее ей программное обеспечение, что сделало возможным чтение с экрана компьютера, не напрягая глаза,- почти так же, как если бы это был текст, напечатанный на хорошей бумаге четким крупным шрифтом. Программа же Microsoft Reader обеспечивает качественное воспроизведение ClearType шрифтов и все необходимые операции со шрифтами и текстом, включая масштабирование и поворот. Вначале остановимся на технических характеристиках E-book, а затем перейдем к их программному обеспечению.

Выделяют две разновидности таких устройств: с одним экраном и двухэкранные. Последние более точно моделируют книгу, так как позволяют выводить на монитор не одну единственную страницу книги, а две или разворот, как принято говорить у издателей и полиграфистов. Сейчас производятся три основные модели E-book. Аппараты Rocket eBook и SoftBook Reader относятся к одноэкранным, a Every Book- устройство с двумя экранами, разворачивающимися как обычная книга. Отметим, что патентом на электронную книгу с двумя экранами уже несколько лет владеет фирма Sony. Эта же фирма еще с 1992 г. производила устройство Bookman, также представляющее собой своеобразную электронную книгу, которое не получило широкого распространения.

Аппарат Rocket eBook внешне напоминает современные миниатюрные переносные компьютеры. Его вес немного превышает 600 г. Внешний вид этого устройства представлен на рис. 8.11 Рис. 08.11.. На рис. 8.12 Рис. 08.12. показана картинка, отображаемая на экране этого устройства. Размер экрана чуть меньше, чем размер наборной полосы самого распространенного в нашей стране 7-го формата печатных изданий. Электронные книги хранятся в устройстве с помощью флэш-памяти, объем которой составляет 16 Мб. Это позволяет хранить около 3200 текстовых страниц или около десяти книг среднего объема.

Помимо самого текста справа на экране отображается индикатор прочитанной части книги в виде полоски, верхняя темная часть которой указывает положение текущей страницы и долю прочитанной части книги от ее полного объема. Сенсорный монохромный ЖК экран Rocket eBook имеет разрешение 106 точек на дюйм и снабжен четырьмя пиктограммами (рис. 7.12 Рис. 07.12.). Пиктограмма в виде раскрытой книги позволяет выделять фрагменты текста, производить поиск нужного фрагмента, а также поиск значений слов во встроенном словаре Random House Dictionary. Возможно также добавление закладок и заметок.

Пиктограмма в виде книжной полки отображает список книг, хранимых в памяти вашей Rocket eBook. Прикосновение к изображению любой из них открывает книгу. Эта пиктограмма позволяет просмотреть информацию о вашем E-book (идентификационный номер, объем памяти, заряд аккумуляторов), а также изменить размер шрифта и интенсивность подсветки экрана.

Изображение ракеты, расположенное в левой верхней части экрана, позволяет запрограммировать быстрый доступ к нужной функции (аналогия с функциональными клавишами или «быстрыми клавишами»). Пиктограмма, изображающая поворот, позволяет изменить ориентацию страницы на экране.

SoftBook Reader (рис. 8.13 Рис. 08.13.) имеет размер чуть больше стандартной книги. Он оснащен цветным ЖК-монитором с размером экрана 6x8 дюймов, 8 Мб памяти и встроенным модемом. При необходимости объем памяти можно расширить. Каждый покупатель SoftBook Reader получает доступ к ежедневным новостям с популярных американских сайтов, а также 100 классических литературных произведений бесплатно

В скором будущем SoftBook Press планирует выпустить обновленную модель устройства 250е. В нем будет увеличен объем расширяемой памяти Compact Flash до 128 Мб, установлен более совершенный модем на 56Кбит/с и сетевая карта, а также новый сенсорный ЖК-монитор.

Самая высокая стоимость и качество характеризует модель EveryBook с двумя цветными экранами. Устройство напоминает солидную старинную книгу в кожаном переплете (см. рис. 8.14 Рис. 08.14.). Кстати, в России начала XX века большинство книг оформлялись именно таким образом. Модель в режиме чтения книги показана на рис. 8.15 Рис. 08.15..

Профессиональная модель носит название Dedicated Reader, имеет размеры в сложенном виде 305x229x44 и весит чуть более 2 кг. Продолжительность работы батарей - не более 6 часов. Используются файлы в формате PDF, в результате чего достигается максимальное подобие электронного издания печатному. Экраны цветные, сенсорные. Для загрузки следующей страницы следует коснуться пальцами верхней части экрана, т. е. и в этом случае имитируется работа с печатной книгой. Устройство снабжено современным модемом, что позволяет подключаться к сайту производителя www.everybook.net и скачивать оттуда электронные книги. Запланирован также выпуск упрощенной модели с размером экрана 200x140 мм и более доступной по цене.

Rocket eBook наиболее демократичен как по дизайну, так и по цене по сравнению с двумя другими моделями. Но его возможности скромней. Данное устройство ориентировано на молодежь: студентов, школьников и т. д. Для загрузки новых изданий в Rocket eBook необходим компьютер, оснащенный модемом. Загружаемые из Internet файлы передаются из этого компьютера в Rocket eBook через последовательный порт. Конечно, подобный подход позволяет удешевить устройство (за счет исключения модема), но усложняет процесс загрузки текстов, а также делает устройство неавтономным. В комплекте Rocket eBook пользователи получают «Алису в Стране Чудес» и Random House Webster's eDictionary объемом 75 тыс. слов. В будущем разработчики планируют оснастить свое устройство цветным монитором и портом USB. Пока наряду с основной распространяется улучшенная модель Rocket eBook Pro.

Сведения для рассмотренных выше устройств E-book сведены в табл. 8.3.

Таблица 8

Таблица 8.3.

Характеристика некоторых устройств E-book

Параметр | Тип
 | Soft Book Reader | Rocket eBook | Every Book
Размеры | 177x228x31 | 180x121x20 | 305 х 229 х 44
Разрешение экрана | 480 х 640 | 240 | 450
Глубина цвета | 15 | Монохром | 15
Размер экрана, мм | Диагональ 215 | 90x140 | 2 х 290 х 205
Аудио-выход | Нет | Да | Да
ОЗУ, Мб | 8 | 16 | 16
Встроенный модем | Да | Нет | Да
ОС | Palm OS v 3.5 | PalmOS, V.3.5.2H | Palm OS v 3.5

Если в первый год в США было реализовано лишь около 6 тысяч различных моделей устройств E-book, то к лету 2001 г. общий объем продаж этих устройств превысил 500 тысяч. Таким образом, началась эра широкого распространения этих устройств. В Японии для организации широкого выпуска таких устройств организован Electronic Book Consortium «Electronic Book Consortium», в который вошли не только крупные электронные фирмы (Hitachi, Sharp, Nippon Telegraph&Telephone), но и ряд издательств и крупных книжных магазинов. Учитывая принятую в Японии иероглифическую систему письма, предложено использовать для хранения электронных книг графический формат EBJ. В результате для хранения средней книги потребуется пространство памяти объемом около 16 Мб.

В опытном образце японской E-book, разработанной фирмой Sharp Sharp, использован жидкокристаллический монохромный экран размером 7 дюймов по диагонали и разрешением 1024 х 768 элементов. Для хранения информации использован сверхминиатюрный винчестер диаметром в 2 дюйма и емкостью около 40 Мб.

К сожалению, наша страна пока не принимает участия в этом процессе, хотя распространение зарубежных моделей E-book уже началось в крупных городах. В то же время в России имеется патент на устройство двухэкранной электронной книги с приоритетом от 2 марта 1998 г., что потенциально позволяет ей принять участие в борьбе за рынок E-book.

Аппараты E-book, программное обеспечение для них, а также электронные издания для своей электронной библиотеки доступны уже сейчас. Соответствующая информация представлена на сайтах www.ebookshop.ru/rocket и www.e-book.ru. Там же можно прочесть мнения читателей о E-book и различную сопутствующую информацию.

8.3.3.
Программные средства E-book

Выступив инициатором создания аппаратных и программных средств работы с электронной книгой, фирма Microsoft разработала удобную программу чтения электронных изданий MS Reader, которая неразрывно связана со специальной шрифтовой технологией ClearType.

Основной движущей силой при разработке ClearType и сопутствующего ей программного обеспечения было стремление предложить технологию, которая сделала бы возможным чтение с экрана компьютера, не напрягая глаза,- точно так же, как если бы это был текст, напечатанный на хорошей бумаге четким крупным шрифтом. Изначально подразумевалось, что новая шрифтовая технология будет ориентирована на жидкокристаллические мониторы, включая экраны мобильных и карманных компьютеров. Ориентация на жидкокристаллические панели объяснялась тем, что именно на этих экранах с относительно высокой дискретностью тексты, набранные стандартными современными шрифтами типа True Туре, читаются плохо - становится слишком заметно, что буквы состоят из ограниченного числа квадратных элементов. В частности, возникает эффект, когда буквы, набранные мелкими кеглями, оказываются практическими нечитаемыми, а в символах, набранных крупным кеглем, четкие кривые заменяются ломаными линиями с множеством прямоугольных выступов.

Разработка новой шрифтовой технологии началась в 1998 г., причем уже тогда подразумевалось, что будут разрабатываться не только шрифты и технология их рендеринга, но и программное обеспечение, способное воспроизводить текст, отображаемый с помощью таких шрифтов. Разработки шрифтов повышенной четкости воплотились в шрифтовую технологию ClearType, а разработки в области отображения шрифтов ClearType -в программу Microsoft Reader.

Остановимся кратко на конкретных вариантах этой программы. Так, MobiPocket Reader (for handhelds) предназначена для чтения еВоок и eNews, которая работает на платформах PalmOs, WindowsCE, Psion Epoc32 и понимает стандарты DOC PRC, TXT, HTML. Программа позволяет загружать новости и читать их, причем любая представленная информация будет оптимально скомпонована для чтения на конкретном экране.

Программа Primer предназначается для просмотра PDF-файлов на Palm совместимых компьютерах. В программе предусмотрена возможность сохранения конфиденциальности просматриваемой информации. Основное внимания уделено функциям обеспечению максимального удобства просмотра электронных изданий.

Программа Peanut Reader предназначена для просмотра файлов E-book для платформ Palm и WindowsCE. Она позволяет делать закладки в тексте, записывать аннотации для читаемых фрагментов, изменять размеры шрифтов. Программа может автоматически с заданной скоростью пролистывать страницы, а также поворачивать текст на экране на угол 90 градусов, если пользователю так удобнее читать.

Это программа стала стандартом де-факто для производителей компьютеров на данной платформе. Размер просматриваемых документов ограничен только объемом памяти компьютера. Предусмотрена возможность архивации изданий. Уже создано значительное количество электронных книг в формате aportisDoc. Большинство этих изданий собрано на сайте www.aportis.com

E-book для Psion на русском первый вклад в популяризацию программного обеспечения для системы EPOC за счет его перевода на русский язык. Русифицирован не только интерфейс E-book, но и справочный файл. E-book позволит хранить на своем устройстве и носить всегда с собой библиотеку любимых книг. Удобство самого существования электронных книг нельзя недооценивать. Любые книги всегда имеются под рукой и практически мгновенно доступны для чтения.

Особенностью E-book является поддержка сжатых и обычных файлов Aportis Palm DOC (.prc и .pdb), поддержка текстовых документов; автоматическое распознавание формата файла, масштабирование экранного шрифта, режим автоматической прокрутки, копирование в буфер и в файл; расширенные средства работы с закладками (до 80 закладок на документ), интерактивная справка, малый информационный объем и высокая скорость работы.

В данное время готовится русский вариант программы чтения SwitchOn (она уже доступна в виде бета-версии для зарегистрированных пользователей). А за ней последуют и другие.

8.3.4.
Стандарт Open E-book

Фирма Microsoft выступила инициатором создания открытого стандарта электронных книг - Open E-book. Microsoft разрабатывала данный стандарт в сотрудничестве с издателями электронных текстов (EText), в числе которых Harper&Collins, Penguin Putnam, Simon&Schuster и Time-Warner Books, а также с производителями специальных устройств для их чтения (E-book). Кроме того, в разработке участвовали и такие известные компании, как Adobe Systems Adobe Systems, IBM IBM, Hewlett-Packard Hewlett-Packard.

Новый стандарт, использующий сочетание HTML и XML, регламентирует форматы файлов, форматы передачи данных, разметки и сертификатов, защищающих авторские права. Он допускает, например, такие возможности, как подгонка текста под размер экрана при его передаче из настольного ПК в карманный.

Благодаря спецификации, электронные книги можно будет читать на любом устройстве E-book или компьютере. Microsoft подчеркивает, что производители аппаратуры и издатели смогут пользоваться стандартом совершенно свободно. Стандартные электронные книги будут работать при всех программах чтения, отвечающих принятой спецификации. Это означает, что издателям не придется создавать несколько вариантов книг, а производители устройств смогут сосредоточиться исключительно на совершенствовании аппаратуры.

Следующая задача, которую ставят себе разработчики: максимально приблизить Open EBook к XML. Так что, будущие версии стандарта станут шире использовать возможности XML, но на это уйдет несколько лет, так как разработчикам аппаратуры требуется освоить новую спецификацию.

Инициатива создания стандарта Open EBook была анонсирована в октябре 1998 г. на первой международной конференции по электронным книгам, важной целью которой являлось создание открытого стандарта на разметку текстов для использования в электронных книгах.

6 января 1999 г. при поддержке компаний NuvoMedia NuvoMedia, SoftBook Press SoftBook Press и Microsoft Microsoft, активно участвовавших в работе специально созданной Open EBook Authority Group, вышел в свет первый черновой вариант Open EBook Publication Structure Specification. 28 января появился и черновик спецификации на электронную книгу как аппаратное устройство.

В сентябре 1999 г. Open EBook Authority Group Open EBook Authority Group выпустила окончательную версию 1.0 спецификации Open EBook (стандарт ОЕВ 1.0). Выпущенный стандарт поддержало значительное число фирм, связанных с публикацией электронных книг. В их числе не только компании, занимающиеся непосредственно производством и распространением электронных книг (SoftBook Press, peanutpress.com, Glassbook, Everybook), но и крупные компьютерные фирмы (например, Microsoft и Adobe), а также фирмы, занимающиеся разработкой и распространением портативных электронных устройств (например, Palm Computing и Nokia).

13 января 2000 г. был учрежден Open Electronic Book Forum (OEBF) Open Electronic Book Forum (OEBF). Цель этой организации - не только создание и поддержка стандартов, но и популяризация электронных книг. Сама организация образована не только фирмами - производителями аппаратного и программного обеспечения, но и издателями и пользователями электронных книг.

Основным достоинством стандарта Open Ebook является его свободное (без всяких лицензий) распространение на сайте http://www.openebook.org. Таким образом, производители аппаратных и программных средств для чтения электронных книг могут обеспечить совместимость своих устройств и программ сданным стандартом. В результате документ, соответствующий стандарту, может быть просмотрен при помощи любого устройства или программы, поддерживающих спецификацию ОЕВ.

Предусматриваемая им разметка не является чем-то принципиально новым, а представляет собой всего лишь один из вариантов XML. Благодаря этому для работы с электронными книгами, соответствующими спецификации ОЕВ, может использоваться любое программное обеспечение, предназначенное для работы с XML.

Эти два свойства нового стандарта существенно помогут в его распространении. Стандарт вы годен как тем, кто выпускает устройства для чтения E-book (его просто реализовать). Так и тем, кто производит сами книги, ибо авторы и издатели могут использовать для написания и публикации книг уже существующее программное обеспечение, а не искать или создавать новое.

Еще одним преимуществом стандарта ОЕВ является возможность просмотра текста при помощи браузера. Книга в формате ОЕВ 1.0 состоит из набора файлов: «головного» файла, файлов с рисунками и файлов с текстами. Файлы с текстами имеют расширение HTML и могут быть просмотрены в браузере, ибо используемый в них язык разметки практически является подмножеством HTML.

8.3.5.
Достоинства и недостатки технологии E-book

К преимуществам этой технологии можно отнести следующие:

  • значительно облегчается проблема выбора изданий и их доставка через Интернет;

  • возможность самостоятельного тиражирования и распространения электронных изданий их авторами;

  • простота перемещения больших наборов книг (библиотек) вместе с читателем;

  • простота аннотирования и добавления пометок к электронным изданиям читателем.

К недостаткам же можно отнести следующие:

  • высокую стоимость аппаратных средств E-book;

  • определенную зависимость владельца E-book от поставщика элект ронных изданий, так как для многих видов аппаратных средств существует привязка к сайту изготовителя, с которого только и можно получать эти издания;

  • пока еще недостаточно высокое качество отображения электронно го издания на экране устройства.

В будущем, скажем к 2010 г. можно ожидать широкого распространения аппаратных средств и технологий E-book, если не повсеместно, то хотя бы в США, Японии, странах Западной Европы.

Именно в этих странах, с одной стороны, значительная часть общества ориентируется на все новое и передовое, с другой стороны, очень велика роль и воздействие рекламных компаний на общество. Кстати, летом 2001 года количество проданных в США устройств E-book достигло 500 миллионов экземпляров, что явилось результатом целенаправленной агрессивной рекламной акции. Очень может быть, что новая техника и технология E-book будет активно внедряться и в нашей стране. Уже в 2001 г. в сети Интернет появились первые сайты, рекламирующие и распространяющие эту технику.


Электронные издания:

9.
глава IX. Электронные учебники

В этой главе рассматриваются некоторые проблемы подготовки электронных изданий определенной группы, а именно - учебных пособий, которые все активнее используются в учебном процессе в высшей школе. В частности, анализируются достоинства и недостатки электронных учебников, структура учебника и ее возможные разновидности, особенности работы студента с таким учебником и вытекающие отсюда требования к его экранному интерфейсу и средствам навигации. Рассматриваются также возможности использования такого учебника в системе дистанционного обучения и методика подготовки и включения в учебник средств тестирования, оценки уровня подготовки студента.

9.1.
Достоинства и недостатки электронных учебников

В последние годы количество компьютеров в нашей стране растет в геометрической прогрессии. В нашем городе их количество превысило 500 тысяч. Значительная их часть оборудована дисководом для компакт-дисков или даже DVD-дисководом. Во многих из них имеются также звуковые карты, поддерживающие стереозвук, колонки, микрофон, стереонаушники и другие средства мультимедиа.

Длительный опыт общения автора со студентами специальности 2202 показал, что к IV курсу большинство (до 80-90%) студентов имеют компьютер в личном пользовании. Естественно, поэтому, стремление к более интенсивному использованию компьютера в учебном процессе, включая самостоятельную работу студентов. Вначале была предпринята попытка использовать компьютер при проведении лекций для вывода изображений: блок-схем алгоритмов, структурных схем компьютерных узлов. Соответствующие файлы автор готовил заранее и демонстрировал аудитории на 19-дюймовом мониторе, а затем разрешал копировать их на дискеты студентам (т. е. студенты также могли не тратить время на копирование рисунков в свои конспекты). Далее пришла пора выводить на экран программы с комментариями, которые также копировались на дискеты желающим студентам. Здесь роль лектора состояла в демонстрации на компьютере работы программы (студенты убеждались, что программа действительно выполняет свои функции) и привлечении внимания студентов к структуре и назначению отдельных ее фрагментов, различным методам и средствам реализации отдельных процедур и программ.

Таким образом, среди студентов распространялись, по существу, фрагменты электронного учебника в наиболее простой форме: текстовых файлов или файлов в формате редактора Word под Windows, реже в графическом формате BMP или PCX, доступном с помощью встроенного в оболочку Windows редактора Paint. Студенты имели потенциальную возможность в любое время использовать эти материалы, скажем, в процессе подготовки к лабораторным занятиям или к сдаче зачета.

Даже в результате применения таких простых и доступных большинству преподавателей средств удалось приблизительно на 50% увеличить информативность и эффективность проведения лекций и на столько же снизить время, затрачиваемое на чтение соответствующих разделов лекционного курса. Кроме того, студенты, пропустившие занятия, получали возможность самостоятельно освоить лекционный материал. Следует отметить, что изложенные на лекции материалы по курсу «Организация ЭВМ и систем», включали процедуры и фрагменты программ на ассемблере с подробными комментариями, что позволило студентам самостоятельно выполнять лабораторные работы по курсу на своем домашнем компьютере, а затем предъявлять их преподавателю.

Естественно, что в тех курсах, где количество графического и текстового материала (блок-схем и структурных схем, алгоритмов, листингов программ), подготавливаемых лектором на доске в процессе чтения лекций, сравнительно мало, эффективность применения перечисленных мер также будет ниже. Следует также отметить, что близкие к достигнутым результаты могут быть получены путем предварительной подготовки печатного раздаточного материала для студентов (тех же самых блок-схем и листингов программ с подробными комментариями). Однако последний способ требует заметно больших усилий преподавателя (или учебно-вспомогательного персонала) на подготовку материалов и больших материальных затрат.

Конечно, общение с обычным печатным учебником для большинства из нас представляется более естественным и привычным. Учебные пособия можно читать в транспорте, во время еды и даже лежа в постели, причем во всех этих случаях практически с одинаковым успехом. Однако подготовка и тиражирование учебных изданий требует значительных затрат времени и материальных средств. В нашей стране никто таких расчетов не делал, а в штате Техас (США) Комитет по школьному образованию подсчитал, что дешевле обеспечить каждого школьника компьютером и учебниками в электронной форме, чем ежегодно расходовать огромные средства на печать этих учебников.

Сточки зрения скорости подготовки электронные учебники также имеют существенные преимущества перед печатными. Для тех учебных предметов, темой которых являются быстро меняющиеся технологии, скорость подготовки и модернизации учебных пособий является чрезвычайно важным фактором. Сошлюсь на пример из своего личного опыта. Подготовленное мною пособие по элементам и узлам современных компьютеров по данным на конец августа 1999 г. было отпечатано в декабре 1999 г. Но к моменту проведения лекций в новом учебном году в сентябре 2000 г. в части материнских плат, жестких магнитных дисков и процессоров пособие уже заметно устарело. Пришлось оперативно дополнить его новыми данными в форме электронных файлов в формате редактора Word 97.

Остановимся на преимуществах и недостатках электронного пособия по сравнению с печатным. Существенных недостатков у электронного учебника два:

  • необходимость специального дополнительного оборудования для работы с ним, прежде всего - компьютера с соответствующим программным обеспечением и качественным монитором, а иногда дополнительно также дисковода для компакт-дисков и/или сетевой карты или модема для работы в локальной или глобальной сети;

  • непривычность, нетрадиционность электронной формы представления информации и повышенной утомляемости при работе с монитором.

Достоинств электронных учебников гораздо больше. К ним можно отнести:

  1. Возможность адаптации и оптимизации пользовательского интерфейса под индивидуальные запросы обучаемого. В частности, имеется в виду возможность использования как текстовой или гипертекстовой, так и фреймовой структуры учебника, причем количество фреймов, их размеры и заполнение может изменяться. Вместо части фреймов, по желанию студента, можно использовать всплывающие окна с тем же самым содержимым, например, с рисунками или списком определений.

  2. Возможность использования дополнительных (по сравнению с печатным изданием) средств воздействия на обучаемого (мультимедийное издание), что позволяет быстрее осваивать и лучше запоминать учебный материал. Особенно важным нам представляется включение в текст пособия анимационных моделей. Положительный эффект можно достигнуть и с помощью звукового сопровождения, соответствующего лекторскому тексту.

  3. Возможность построения простого и удобного механизма навигации в пределах электронного учебника. В печатном издании таких возможностей две: оглавление и колонтитулы, иногда к ним также относят глоссарий. Однако для практической реализации этих возможностей необходимо листать страницы учебника. В электронном пособии используются гиперссылки и фреймовая структура или карты-изображения, что позволяет, не листая страниц, быстро перейти к нужному разделу или фрагменту и при необходимости так же быстро возвратиться обратно. При этом не требуется запоминать страницы, на которых были расположены соответствующие разделы.

  4. Развитый поисковый механизм не только в пределах электронного учебника, но и вне его. В частности, по гипертекстовым ссылкам можно перемещаться по тексту издания, просматривать рисунки, обращаться к другим изданиям, ссылки на которые имеются в нем (литература и пр.), даже написать электронное письмо автору пособия с просьбой объяснить те или иные положения учебника. При использовании сетевых обучающих структур возможно обсудить положения учебника с другими студентами (в электронном читальном зале), оставаясь на своем рабочем месте.

  5. Возможность встроенного автоматизированного контроля уровня знаний студента, и на этой основе автоматический выбор соответствующего уровню знаний слоя учебника, как указано в следующем пункте.

  6. Возможность адаптации изучаемого материала к уровню знаний студента, следствием чего является улучшение восприятия и запоминания информации. Адаптация основана на использовании слоистой структуры издания, причем в соответствии с результатами тестирования студенту предоставляется слой, соответствующий уровню его знаний.

  7. Главное преимущество электронного учебника это возможность интерактивного взаимодействия между студентом и элементами учебника. Уровни ее проявления изменяются от низкого и умеренного при перемещении по ссылкам до высокого при тестировании и личном участии студента в моделировании процессов. Если тестирование подобно собеседованию с преподавателем, то участие в моделировании процессов можно сопоставить с приобретением практических навыков в процессе производственной практики в реальных или приближенных к ним условиях производства.

С внедрением электронных учебников изменяются и функции библиотеки. В этом случае ее роль играет электронный читальный зал, оборудованный компьютерами, объединенными в локальную сеть, которая связана с текстовой базой данных - хранилищем электронных учебников. Все читатели такой библиотеки без всякой очереди и ожидания могут самостоятельно выбирать и читать любые электронные учебники, в том числе и одинаковые, автоматически тиражируемые для них в любом количестве экземпляров.

9.2.
Структура электронного учебника

Простейшим электронным учебником может являться конспект лекций преподавателя, набранный им самим (или даже студентами с целью размножения хорошего конспекта в большом числе экземпляров при минимальных затратах) и размещенный на студенческом сервере или на другом общедоступном электронном узле. Однако такой учебник, по существу, ничем не отличается от размноженного печатным методов конспекта и в нем никак не использованы специфические возможности электронного издания. Какие же это дополнительные возможности? Попытаемся их перечислить. Можно выделить главные из них и дополнительные. К главным особенностям можно причислить:

  • возможность построения простого и удобного механизма навигации в пределах электронного учебника;

  • развитый поисковый механизм в пределах электронного учебника, в частности, при использования гипертекстового формата издания;

  • возможность встроенного автоматизированного контроля уровня знаний студента;

  • возможность специального варианта структурирования материала;

  • возможность адаптации изучаемого материала учебника к уровню знаний обучаемого, следствием чего является резкий рост уровня мотивации обучаемого;

  • возможность адаптации и оптимизации пользовательского интерфейса под индивидуальные запросы обучаемого.

К дополнительным особенностям электронного учебника по сравнению с печатным следует отнести:

  • возможность включения специальных фрагментов, моделирующих течение многих физических и технологических процессов;

  • возможность включения в учебник аудио-файлов, в частности, для сближения процесса работы с учебником и прослушивания лекций этого же преподавателя;

  • возможность включения в состав учебника фрагментов видеофильмов для иллюстрации определенных положений учебника;

  • включение в состав пособия интерактивных фрагментов для обеспечения оперативного диалога с обучаемым;

  • полномасштабное мультимедийное оформление учебника, включающее в себя диалог на естественном языке, организацию по запросу обучаемого видеоконференции с автором (авторами) и консультантами и пр.

Электронное пособие (как впрочем и любое электронное издание) для достижения максимального эффекта должно быть составлено несколько иначе по сравнению с традиционным печатным пособием: главы должны быть более короткие, что соответствует меньшему размеру компьютерных экранных страниц по сравнению с книжными, затем каждый раздел, соответствующий рубрикациям нижнего уровня, должен быть разбит на дискретные фрагменты, каждый из которых содержит необходимый и достаточный материал по конкретному узкому вопросу. Как правило, такой фрагмент должен содержать один-три текстовых абзаца (абзацы также должны быть короче книжных) или рисунок и подпись к нему, включающую краткое пояснение смысла рисунка.

Таким образом, студент просматривает не непрерывно излагаемый материал, а отдельные экранные фрагменты, дискретно следующие друг за другом. Изучив данный экран, студент нажимает кнопку «Следующий», размещенную обычно ниже текста, и получает следующий фрагмент материала. Если он видит, что не все понял или запомнил из предыдущего экрана, то нажимает расположенную рядом с первой кнопку «Предыдущий» и возвращается на один шаг назад. Дискретная последовательность экранов находится внутри (и в пределах) наименьшей структурной единицы, позволяющей прямую адресацию, т. е. внутри параграфа или подпараграфа (того, что характеризуется заголовком третьего уровня) содержится один или несколько фрагментов, последовательно связанных друге другом гипертекстовыми связями. На основе таких фрагментов проектируется слоистая структура учебного материала, которая содержит:

  • слой, обязательный для изучения;

  • слой для более подготовленных пользователей;

  • слой для более глубокого изучения определенных разделов;

  • вспомогательные слои;

  • специальный слой «Основные понятия и определения»,

  • дополнительный слой рекомендаций по применению полученных знаний.

Такая организация учебного материала обеспечивает дифференцированный подход к обучаемым в зависимости от уровня их подготовленности, результатом чего является более высокий уровень мотивации обучения, что приводит к лучшему и ускоренному усвоению материала.

Определенный опыт, накопленный нами в проектировании электронных учебников и организации обучения студентов на их основе показал, что, по крайней мере на начальной стадии внедрения электронных учебников, целесообразна фреймовая структура. Именно при ней предусматриваются отдельные фреймы для решения многих из перечисленных задач. Пример структуры из пяти фреймов представлен на рис. 9.1 Рис. 09.01..

В частности, необходим отдельный фрейм для организации навигации в пределах пособия в целом, который может быть оформлен в виде оглавления документа. Так как размеры подробного оглавления обычно велики, то во фрейме обязательно должен содержаться слайдер (окно прокрутки).

Надо сказать, что в электронных учебниках 80-х гг. проблема навигации стояла достаточно остро. Для перемещения в пределах учебника использовались специальные программы с той или иной структурой меню. В частности, изучался вопрос о глубине такого меню и возможности сего помощью выбирать отдельные небольшие фрагменты электронного учебника. Такое меню занимало обычно много места на экране, размер которого и без того был мал. Лишь с появлением гипертекстового формата документов и развитием фреймовых структур появилась реальная возможность предоставить учащемуся при работе с электронным учебником возможность пользоваться таким же оглавлением, как и в печатном, но это оглавление постоянно находится на экране в отдельном фрейме или «всплывает» при необходимости в специально окне. Таким образом, отпала необходимость в специальном «навигационном» программном обеспечении и организации взаимодействия документа с этими программами. При использовании фреймовой структуры основная проблема связана с большой протяженностью оглавления, лишь малая часть которого помещается в окне соответствующего фрейма. В результате студент тратит определенное время на просмотр заголовков в этом фрейме. Альтернативный вариант предполагает использование иерархической структуры оглавления (см. следующий раздел).

Выбранные из оглавления разделы появляются во фрейме, названном «Основной текст электронного издания». Этот фрейм имеет самые большие размеры, необходимые для помещения двух-трех абзацев текста или рисунка с пояснениями. Указанный фрейм представляет собой главное информационное поле, т. е. содержит тот материал, который должен быть за один прием воспринят учащимся, осознан им и сохранен в оперативной, а затем и в долговременной памяти.

В этом тексте также могут содержаться ссылки в виде адресов (URL) иллюстраций (если они выводятся в специальных окнах), некоторых других электронных документов, рассматриваемых как дополнительная литература, анимационных, аудио и видео-файлов, содержащих динамическое описание процессов или явлений, авторские пояснения и иллюстрационный видеоматериал. В качестве иллюстрации этого положения, могу сослаться на большое впечатление, которое произвела на автора динамическая схема (модель) производства сахара на автоматизированном производстве, оформленная в виде анимационного изображения в GIF-формате на соответствующем сайте. Даже для абсолютно незнакомого с предметом человека схема была вполне понятна и чрезвычайно выразительна. Кстати, такие дополнения также могут оформляться вне основной фреймовой структуры, в виде дополнительных окон.

Для удобства студента в отдельный фрейм выделен глоссарий или список определений, переход к которым организован по ссылка от терминов, встречающихся в основном тексте и требующих пояснения. Этот фрейм не является обязательным. Для увеличения площади экрана, занятой основным фреймом, можно список определений формировать в дополнительном всплывающем окне.

Предметный или алфавитный указатель пособия позволяет перейти от соответствующих терминов и понятий к основному тексту, в котором они упоминаются, с помощью гипертекстовых ссылок (в печатных изданиях указаны страницы, где эти понятия встречаются). Таким образом, содержимое этого фрейма обеспечивает дополнительные возможности навигации в пределах электронного учебника. Однако реализация этого способа требует от студента хотя бы предварительного знакомства с тематикой пособия. Иначе говоря, этим способом навигации реально пользуются лишь те студенты, которые стремятся усовершенствовать или повысить уровень своих знаний по данному предмету. Таким образом, для начального обучения можно исключить этотфрейм и формировать алфавитный указатель во вспомогательном всплывающем окне.

Помимо четырех перечисленных фреймов каждый из которых снабжен слайдером, предусмотрен дополнительный пятый фрейм для размещения постоянной (неизменной) для данного издания справочной информации, на основе которой учащийся может перейти на сайт института, послать электронное письмо с вопросами или просьбой о предоставлении консультации или дополнительных материалов автору учебника, обратиться к другим пособиям по данной и близкой тематике, а иногда и участвовать в сетевом обсужден и и в месте с другим и студента ми вопросов, рассматриваемых в электронном учебнике.

Некоторые авторы считают полезным размещение в верхней части окна браузера заголовка электронного учебника, для чего можно использовать отдельный фрейм, информация в котором также постоянна. В нашей практике использовалась фреймовая структура такого типа (рис. 9.2 Рис. 09.02.). Здесь из пяти фреймов три с постоянным содержанием: заголовочный, информационный и оглавление и два с переменным содержанием: основное содержание и глоссарий. Информационное насыщение фрейма заголовка близко к нулю, поэтому в тех случаях, когда количество фреймов и без того велико, фрейм заголовка лучше не использовать.

В большинстве случаев, при проектировании электронных документов рекомендуется ограничиваться структурой с тремя-четырьмя фреймами. Для тех учащихся, которые предпочитают иметь большее количество основной информации на одном экране (т. е. максимальные размеры фрейма «Основной текст издания») можно организовать переход к структуре с тремя фреймами, а список определений и глоссарий выводить в дополнительных окнах, открывающихся по запросу обучаемого.

Рисунки, которые должны присутствовать в тексте во многих случаях следует показывать в отдельных окнах, изолировано от фрагментов текста. Следовательно, в таком случае во фрейме «Основной текст» выводятся действительно только абзацы текста учебника. Если водном из них присутствует гиперссылка на рисунок, то при воздействии на нее всплывает окно с графикой. Размер окна с рисунком не должен быть чрезмерно большим, чтобы иметь возможность перемещать это окно в пределах экрана для того, чтобы попытаться оптимально разместить на экране рисунок относительно поясняющего его текста. Например, рисунок может перекрывать фреймы «Оглавление» и «Глоссарий», так как во время изучения и запоминания изображения не требуется обычно перемещаться по тексту издания. После детального изучения рисунка вместе с поясняющим его текстом окно с рисунком, как правило, можно закрыть.

9.3.
Основные принципы подготовки электронных учебников

В связи с существенно различной природой печатного материала и электронного издания (в электронном издании не засунешь палец между страницами и пр.) в последнем возникают две новые и существенные проблемы:

  • проблема размещения и оформления текстового и графического материла на рабочей поверхности экрана, а также размер этой поверхности, использование признака цветности и субъективная реакция пользователей на наличие этих элементов;

  • проблема ориентации и перемещения пользователя внутри электронного издания: между разделами, графикой и рисунками, страница ми, включая овладение различными уровнями материала и перемещение между ними, фиксация своих шагов в процессе изучения для обеспечения возможности контроля и статистических исследований.

Способы работы с печатными материалами устанавливались в течении нескольких веков и тесно переплетены с нашими все еще недостаточно исследованными взглядами на то, как изучать, что изучать, как должна выглядеть книга или журнал. В то же время эра электронных материалов пришла быстро и внезапно. Поэтому весьма важна роль оптимизации работы с соответствующими материалами, включая как первую, так и вторую проблему. Остановимся на них последовательно.

9.3.1.
Размещение информации на поверхности экрана

При работе с электронными материалами следует учитывать несколько моментов, которые мы вначале перечислим, а затем остановимся на каждом из них подробнее:

  • гарнитура, кегль и начертание отдельных символов;

  • размещение текста и свободное пространство на поверхности экрана (в полиграфии говорят об «осветленном» пространстве);

  • виды используемых иллюстраций и графики;

  • читаемость, логическая структура и другие языковые качества электронного текста;

  • особенности реакции пользователя на электронный материал (на то, как материал классифицирован, связь осознания материала пользователем сего представлением и пр.).

Хотя печатные гарнитуры несколько отличаются от экранных компьютерных шрифтов, последние в настоящее время получили достаточное распространение и характеризуются широким разнообразием рисунка. Как правило, читатель предпочитает работать с простыми по начертанию гарнитурами (Times, Courier, Arial, Sans Serif). Вероятнее всего, это связано с тем, что экранное разрешение в несколько раз меньше, у чем печатного текста.

Во многих работах отмечено также, что большинству пользователей предпочтительнее работать с более плотными экранными текстами (т. е. с малыми размерами кеглей), которые расположены на экране компактно, легче воспринимаются взглядом как нечто единое, цельное. Аналогичные данные получены при исследовании работы пользователей с телетекстом на экране телевизора: большинство (56%) работающих с ним предпочитают иметь на экране предельно большое количество информации, что может быть достигнуто как за счет уменьшения кегля, так и более компактного размещения блоков текста на экране.

Размещение блоков информации на поверхности экрана и их взаимодействие с осветленным пространством экрана относится уже ко второй позиции. Именно количество и размещение осветленного пространства на экране играет самую важную роль как в нахождении нужного фрагмента материала из общего их экранного множества, так и в восприятии информационного содержания фрагментов текста. Здесь важно не только расстояние между отдельными разделами текста, но и размещение заголовков и соотношение кеглей и начертаний заголовков и фрагментов рядового текста. Интересно отметить, что упомянутые выше элементы, как показали многие исследования, играют важную роль не только в осознании и понимании содержания материала пользователем, но и в его последующем кодировании и переводе в долговременную память для последующего длительного хранения и дальнейшего использования (запоминания).

Исключительно негативную роль как с точки зрения производительности, так и осознания и запоминания информации играет мигание и дрожание строк текста.

Важнейшим положительным фактором является использование при отображении признака цветности. В печатном материале применение цвета существенно увеличивает информационную избыточность материала, и, что еще важнее, резко увеличивает затраты на подготовку печатного материала. Поэтому в печатном материале цвет используется осторожно и только в случае крайней необходимости. В то же время при работе с электронным материалом ничто не препятствует широкому использованию признака цветности, так как в компьютере, в большинстве случаев, используется цветной монитор. Цветом могут выделяться следующие фрагменты:

  • текстовые заголовки;

  • блоки определенного текста;

  • графика и иллюстрации;

  • осветленные пространства, которые обычно выделяются светлыми тонами (например, желтым, светло-зеленым, бледно-розовым и пр.);

  • цветом может выделятся и фактура (подложка, т. е. нечто, подобное тонированию бумаги) трех первых позиций;

  • цветом же рекомендуется выделять все гипертекстовые ссылки, не зависимо оттого, относятся ли они к текстовому или графическому фрагменту учебника.

Цвет - притягательный фактор, он играет важную роль в распознавании информационных фрагментов, не говоря уж о его субъективной привлекательности для большинства пользователей компьютеров. Однако следует тщательно подбирать цветовые оттенки, в частности, стремясь к гармоничному их сочетанию, не вызывающему негативных эмоций у читателя.

Наряду с цветом можно использовать и рисунок подложки, что реально применяется в дизайне гипертекстовых Web-страниц. Кроме внешней привлекательности, такой рисунок создает иллюзию работы с печатной страницей, что для многих пользователей может оказаться дополнительным привлекательным фактором в пользу работы с электронным учебником.

Виды используемой графики и иллюстраций - еще один из аспектов оформления пользовательского интерфейса поверхности экрана. Иллюстрации и графика сложны для разработки, но являются, в большинстве случаев, предпочтительными для пользователей, так как графическая форма представления материала характеризуется многократно большим информационным объемом и скоростью восприятия информации. Здесь также нет соответствия между печатным и электронным материалами. Если читатель печатного текста в большинстве случаев не ждет графику (или ожидает ее достаточно редко), то компьютерный пользователь автоматически предполагает высокий процент графики и иллюстраций.

В обучающем и познавательном материале эти ожидания проявляются особенно остро. Ведь графика и иллюстрация - нормальная часть рабочего материала, а в печатных изданиях их число обычно искусственно занижено, что связано с дополнительными расходами на их подготовку и включение в учебник. В электронных изданиях, в отличие от печатных, графика может не только находится внутри текста, но и выводится в отдельном окне, которое открывается (активизируется) и закрывается пожеланию пользователя. По нашему мнению, такой вариант вывода графических изображений во многих случаях является предпочтительным.

Сточки зрения форматов используемых графических файлов предпочтение отдается GIF и JPEG, которые отличаются высокой компактностью и приемлемой передачей цвета, в особенности при оптимизации используемой палитры цветов в GIF-формате. В последнее время все шире применяется полноцветные изображения в PNG-формате (см. также § 3.3).

Языковые качества электронного текста также значительно отличаются от соответствующих характеристик печатного текста. В электронных изданиях следует использовать преимущественно короткие четкие предложения и сжатые параграфы, позволяя пользователя предельно быстро просмотреть экран, отыскивая нужную информацию. Много исследователей интересовались реакцией пользователя на использование аббревиатур и сокращений с тем, чтобы лучше использовать ограниченную поверхность экрана, но пока рекомендуется ограничиваться только общеупотребительными элементами этого типа.

Последний фактор состоит в субъективной реакции пользователя на оформление текста. Если пользователю неприятен стиль оформления текста, то его производительность при работе с ним конечно снизится. Большинство специалистов считают, что познавательная ценность электронного текста измеряется тремя характеристиками:

  • первоначальная реакция пользователя на текст;

  • привлекательность текста;

  • его ясность.

Из этих характеристик привлекательность наиболее субъективна, поэтому привлекательность текста для пользователя может быть достигнута предоставлением ему возможности (в определенных пределах) самостоятельно установить формат представления материала на экране, а может быть, даже управлять системой в целом, включая расположения фрагментов текста, иллюстраций и осветленного пространства, т. е. полностью конфигурировать экранный интерфейс. Это, разумеется, потребует значительных дополнительных усилий при разработке электронного учебника, но зато обеспечит наилучшие условия его использования. Кстати, как отмечалось в § 5.3.4, в браузере MS Internet Explorer предусмотрена возможность индивидуальной настройки пользовательского интерфейса (для чего предназначена команда «Свойства обозревателя» и соответствующее ей диалоговое окно).

9.3.2.
Проблема ориентации и перемещения пользователя внутри электронного издания

Ориентация учащегося в учебнике достигается несколькими путями. Прежде всего, как и в печатном изданий, с помощью заголовков. Рубрикация электронного учебника, по нашему мнению, должна характеризоваться большей глубиной (большим числом уровней), чем у печатного. Целесообразно, чтобы каждый (или почти каждый) экран содержал заголовок раздела. Выше уже упоминалось, что разделы электронного учебника должны быть достаточно короткими, каждый раздел должен содержать исчерпывающую информацию по одному конкретному вопросу.

Другой вариант ориентации связан с использованием в электронном учебнике колонтитулов (как и в печатном пособии). Колонтитул может быть предусмотрен на каждой экранной странице и позволяет контролировать название изучаемой главы и параграфа, т. е. пользователь не теряет ориентации в учебнике.

Наконец, при использовании фреймовой структуры во фрейме «Содержание» выбранный раздел отмечается другим цветом по сравнению со всеми оставшимися. Здесь преимущество электронного учебника особенно наглядно, так как студент, наряду с чтением раздела, всегда видит, где он находится, какой раздел изучает и расположение этого раздела среди рубрикаций.

Перечисленные средства ориентации наиболее распространены, хотя можно использовать и некоторые другие, например, в форме всплывающей подсказки, содержащей название раздела или даже в виде представления на экране фрагмента графа рубрикаций, в котором указано (например, выделено цветом) название изучаемого раздела.

Перемещение внутри электронного учебника, в подавляющем большинстве случаев, производится с помощью гипертекстовых ссылок. Известно, что в печатном пособии для перемещения также используются ссылки типа: (см. параграф ...) или (см. стр. ...), или же оглавление, где указаны номера страниц соответствующих разделов. Надо сказать, что внешний вид печатных изданий, о чем часто забывают, также установился не сразу. Скажем, инкунабулы вообще не имели титульной страницы и оглавления. Титульная страница и оглавление также постепенно изменялись, пока не приобрели современный вид. Оглавление книг в СССР помещалось в конце книги, а в зарубежных изданиях - в начале.

Вообще проблема поиска пути в учебнике требует решения на стыке наук. В постановке и решении этой проблемы должны участвовать психологи, библиотекари, специалисты по компьютерным технологиям, преподаватели, издатели, графические дизайнеры. Пока единый подход к этой проблеме, к сожалению, отсутствует. Трудность ее решения связана и с тем, что эта проблема касается множества процессов, протекающих на различных уровнях активности сознания. Это одновременно проблема узнавания и проблема формирования решения, проблема выбора элементов различных поисковых стратегий, например, оглавления или глоссария (предметного указателя). В последнем случае возникает дополнительно достаточно общая проблема выбора правильных терминов (ключевых слов) для поиска, а также возможность неопределенности (неоднозначности) в результате неточного запроса.

Личные симпатии автора лежат в области использования фреймовых структур, где постоянно присутствует фрейм «Оглавление». Некоторое статистическое подтверждение оправданности такого подхода было получено в процессе проведения занятий по курсу «Семантические и гипертекстовые системы», где студентам предлагалось оценить индивидуальную привлекательность методов навигации. Однако, и в этом конкретном случае возникают определенные проблемы. Основная из них связана с ограниченным объемом упомянутого фрейма, так как он вспомогательный (см. § 9.2) и его увеличение снизило бы площадь той части экрана, которая занята собственно электронным пособием. Ограниченный размер этого фрейма наряду с многоуровневой детализованной структурой рубрикаций делает невозможным просмотр всех рубрик одновременно: во фрейме обязательно присутствует слайдер и видна лишь часть оглавления.

Здесь для увеличения количества присутствующих на экране одновременно рубрик можно идти несколькими путями. Первый из них состоит в использовании предельно коротких заголовков (из одного -двух слов), причем при подведении к нему указателя мыши всплывает полный заголовок в небольшом вспомогательном окне.

Второй путь состоит в применении иерархического структурирования оглавления. Скажем, исходно на экране в этом фрейме помещается список заголовков первого уровня. Если щелкнуть по одному из заголовков, то в этом же фрейме появляется совокупность всех заголовков второго уровня для соответствующей части учебного пособия. Аналогично, при щелчке указателем мыши на заголовок 2-го уровня, фрейм заполняется заголовками третьего уровня и так далее (обычно, число уровней не превышает трех). При заполнении фрейма заголовками 2-го, 3-го и последующих уровней должны быть предусмотрены и команды возврата во фрейм заголовков более высоких уровней (возврат на 2-й уровень, возврат на 1-й уровень). Собственно загрузка материала пособия в основной фрейм происходит только в результате щелчка по заголовку нижнего уровня, т. е. процесс навигации в материале заметно усложняется. Вероятно, такой подход оправдан лишь при двухуровневой структуре материала.

9.4.
Дистанционное обучение и организация самостоятельной работы студентов

Все современные образовательные технологии направлены в том числе и на то, чтобы приучить учащихся работать самостоятельно, так как именно самостоятельность дает возможность успешно адаптироваться к работе, в том числе и связанной с быстро меняющимися технологиями. Таким образом, одна из задач обучения состоит в том, чтобы научить и приучить студента самостоятельно работать с учебной (а затем производственной и научной книгой), в частности с электронной. Но особенно важно такое умение при заочном обучении, когда общение студента с преподавателем приобретает эпизодический характер. Современная разновидность заочного обучения - дистанционная подготовка специалистов или дистанционное обучение - преимущественно основано на самостоятельной работе студента.

Система заочной подготовки специалистов долгое время в нашей стране не пользовалась популярностью, так как она считалась неэффективной и низкокачественной. Однако в связи с изменением экономической ситуации в нашей стране возникла объективная необходимость получения качественного образования без прекращения рабочей деятельности и без регламентации часов занятий. Во многих случаях требуется второе высшее образование или высшее образование для так называемых «деловых людей», заинтересованных в получении качественного образования и готовых оплачивать необходимые затраты, но не имеющих возможности регулярно посещать учебное заведение. Для таких людей наиболее приемлемо дистанционное обучение с использованием компьютерных обучающих технологий и электронных учебных пособий как в части лекционного материала, так и материала для проведения практических и лабораторных занятий. Если методика подготовки пособий для дистанционного изучения теоретической части различных дисциплин разработана в достаточной степени, то методика подготовка материалов для виртуального проведения лабораторных и практических работ вызывает множество дополнительных трудностей и проблем, связанных с переводом соответствующих видов деятельности в форму компьютерного моделирования.

Далее остановимся подробнее на дистанционной форме обучения. Дистанционная форма обучения - это получение образовательных услуг без посещения учебного заведения, с помощью современных информационных технологий, таких как электронная почта, телевидение и глобальная сеть Интернет. Дистанционное обучение можно использовать для получения высшего образования, для повышения квалификации и переподготовки специалистов, для проведения периодических проверок знаний и навыков персонала.

Слушатель может овладевать знаниями дома, на рабочем месте, или в специальном компьютерном классе в своем родном городе, который может находиться в любой точке России, ближнего и дальнего зарубежья. Ему не нужно тратить время и деньги на проезд к месту занятий и обратно, а также на оплату гостиницы, если учебный центр находится в другом городе или другой стране.

Кроме того, он может изучать учебные курсы в любой последовательности, с той скоростью, которая оптимальна лично для него. Все это делает дистанционное обучение качественнее, доступнее и гораздо дешевле традиционного.

Наконец, есть определенная группа людей - инвалиды, для которых затруднено передвижение, т. е. для них дистанционное обучение может оказаться единственно доступной формой образования. Следовательно, такая образовательная система будет нести и определенную социальную нагрузку.

Дистанционная форма предполагает возможность использования нескольких различных моделей обучения.

Модель заочного высшего образования. Предварительно проводится тестирование знаний будущего слушателя, что позволяет индивидуализировать его программу обучения, уделив большее внимание тем предметам, где уровень его подготовки низкий. Последовательно проходятся утвержденные курсы. По окончанию каждого производится дистанционный контроль знаний. Может использоваться семестровая система, аналогичная сдаче зачетов и экзаменов в обычном ВУЗе, или же некий набор обязательных курсов и курсов по выбору. По окончании изучения и контроля знания всех этих курсов слушателю выдается документ о высшем образовании.

Модель консультаций. Консультирование по предметной области со стороны кураторов или специалистов. В этом случае основное внимание уделяется ответам на вопросы слушателей, а для оценки уровня приобретенных знаний применяется итоговое тестирование.

Модель самообразования. Обеспечивается доступ к учебным материалам и сдача тестов по окончанию изучения каждого курса. Сроки изучения жестко не регламентируются. Принципиально возможно получения высшего образования таким путем.

Модель обучения по требованию или по запросу. В этом случае используются специально разработанные курсы. Эта модель наиболее подходит для обучения персонала корпоративного заказчика. Здесь также целесообразно предварительное тестирование и адаптация учебной программы к уровню подготовки слушателей в совокупности или же к каждому в отдельности.

Комбинированная модель. Скажем, получение заочного образования с использованием дистанционного изучения и контроля по части дисциплин. Или получение дистанционного обучения по запросу с привлечением в дальнейшем наиболее подготовленных лиц к очному или очно-заочному образованию.

Дистанционное обучение обязательно требует наличия специального модульного программного обеспечения для поддержки дистанционного образования. Последнее должно обеспечивать выполнение следующих функций:

  • инструментальная и методическая поддержка авторских коллективов при подготовке материалов для распространения в рамках виртуального учебного центра;

  • инструментальная поддержка процессов управления корпоративными знаниями;

  • поддержка проведения собственно дистанционного обучения;

  • обеспечение дистанционного тестирования и прием зачетов и экзаменов;

  • администрирование в системе, включая учет слушателей, организация библиотеки, управление учебным процессом в целом и пр.

Взаимоотношения в процессе дистанционного образования могут происходить по схеме, представленной на рис. 9.3 Рис. 09.03.:

  • слушатель после регистрации зачисляется организатором в учебную группу и получает доступ к материалам учебных курсов, размещенным на сервере, снабжается необходимыми дополнительными материалами (учебники, CD-ROM и т.п.), кроме того, на сервере автоматически создается и ведется его персональная страница;

  • на своей персональной странице слушатель получает информацию от организатора и куратора группы, включая методические рекомендации по планированию выполнения учебных заданий, комментарии своего куратора;

  • по мере изучения курса слушатель проходит тестирование и сдает экзамены. Доступ к тестам и экзаменам возможен также с персональной страницы слушателя;

  • в процессе обучения и выполнения контрольных заданий слушатель может использовать электронную почту, прямой обмен файлами с куратором и коллегами по группе, телеконференции с преподавателем по изучаемому курсу и с куратором по общеорганизационным вопросам. При наличии аудио- или видео оборудования слушатель может обсуждать вопросы в режиме аудио или видеконференции;

  • слушателю доступен раздел «Часто задаваемые вопросы». Дополнительным средством общения является сервер комментариев, позволяющий вставлять заметки на страницах электронного учебника, при этом заметки может видеть сам слушатель, его куратор, коллеги по учебной группе и ведущий курс преподаватель, что обеспечивает дополнительную обратную связь и позволяет постоянно совершенствовать курс.

В США, уже действует множество высших учебных заведений, реализующих дистанционное обучение. В последние годы такие ВУЗы стали появляться и в нашей стране. Во МГУП и его СПб Институте также взят курс на развитие системы заочного образования и внедрение в нее элементов системы дистанционного обучения студентов.

9.5.
Автоматизированные методы оценки уровня подготовки студента

Современное образование и, в особенности, дистанционное обучение немыслимо без применения автоматизированных методов оценки уровня подготовки студента, т. е. без системы тестирования с автоматической обработкой его результатов. Немаловажен и тот факт, что в нашей стране намечен переход к единой системе тестирования знаний выпускников средних школ в пределах всей страны. Причем полученные в процессе тестирования результаты будут служить основой для последующего конкурсного зачисления выпускников во все ВУЗы нашей страны. Постепенный переход от системы зачетов и экзаменов к тестированию вероятно затронет всю систему образования России. По нашему мнению, этот процесс должен гармонично сочетаться с постепенным усилением роли самостоятельной работы, с использованием электронных средств обучения и контроля.

В этом плане большой интерес представляет всероссийский проект «Телетестинг», который с 1997 г. развивается в нашей стране. Он предназначен для проведения олимпиад по различным предметам среди школьников и представляет собой частный случай дистанционного компьютерного массового тестирования. Система разработана сотрудниками центра «Гуманитарные технологии» при МГУ.

В системе можно выделить четыре основных функциональных блока, а именно: подготовительный, тестирования, телекоммуникационный и анализа и обработки, что иллюстрируется рис. 9.4 Рис. 09.04.. Подготовительный блок содержит специальный редактор для маркировки и шифровки заданий и защиту от несанкционированного доступа. Все задания проверяются экспертами и только при совпадении результатов все экспертов, эти задания включаются в базу заданий. Кстати, в графических тестовых заданиях использованы элементы псевдографики, что позволяет сократить объем файлов и ускорить их передачу по сети.

Программа «Телетест» представляет собой оболочку, слабо связанную с тематикой тестов, что позволяет сравнительно просто менять предметную тематику, делая систему тестирования достаточно универсальной и пригодной для итогового школьного тестирования, тестирования на вступительных экзаменах в ВУЗ, тестирования по различным предметам в процессе обучения в ВУЗе.

Достоинством этой программы является адаптивный характер тестирования, позволяющий адаптировать уровень сложности заданий к степени подготовленности пользователя. Использование коэффициента сложности отдельных заданий и усложнение уровня заданий для тех, кто успешно справляется с более простыми, способствует более точной оценке уровня знаний и способностей тестируемых.

В то же время следует отметить ограниченные возможности всех систем тестирования, для которых характерна оценка знаний путем выбора ответа из некоторого множества вариантов. В дальнейшем следует, видимо, стремиться к разработке систем, обеспечивающих получение содержательного ответа на вопросы и последующего автоматизированного семантического анализа этих ответов. Здесь определенные возможности открывает технология составления тестов и обработки результатов тестирования на основе HTML-форм и CGI-скриптов. Эта задача достаточно сложна и объемна, поэтому мы ограничимся ее общей постановкой и описанием, уделив основное внимание технологии составления HTML-форм и принципам их автоматизированной обработки.

Полагаю, что абсолютному большинству читателей известно, что основа WWW - это так называемые Web-узлы, т. е. компьютеры, на которых выполняется специальная программа Web-сервер, обеспечивающая, в частности, поиск и выдачу документов по запросу клиентов узла. Документы на Web-узле обычно хранятся в гипертекстовом формате HTML. Клиентами Web-сервера являются программы-браузеры, запущенные на удаленном компьютере, имеющем доступ к сети. Браузер принимает документ, посланный Web-узлом, и отображает его на экране монитора в своем окне.

Аббревиатура CGI (Common Gateway Interface) обозначает ту часть Web-сервера, которая может взаимодействовать с другими программами, выполняющимися на этом же узле. Именно в этом смысле она является шлюзом (Gateway) для передачи клиентских данных программам их обработки. Схема работы CGI представлена на рис. 9.5 Рис. 09.05.. Она состоит из определенного числа этапов, на каждом из которых происходит взаимодействие пары соседей из трех представленных на рис. 9.5 Рис. 09.05., а именно: браузера на клиентском компьютере, Web-сервера и программных приложений, установленных на Web-узле.

Этапы информационного взаимодействия описаны в той временной последовательности, в которой они показаны на рис. 9.4 Рис. 09.04. (часы и направление отсчета времени показаны на рисунке справа):

  • пользователь с помощью браузера формирует запрос на получение документа и через Интернет посылает его на Web-сервер, частными случаями таких документов могут быть бланк заказа книги или оформления подписки на газету или бланк, заполняемый абитуриентом при поступлении в Университет в другом городе (в США уже есть такие преценденты), причем все такие документы объединяются общим понятием «форма»;

  • сервер извлекает документ (форму) из своей базы данных и через сеть Интернет посылает его пользователю (клиенту);

  • клиент с помощью браузера заносит в документ необходимые данные и вновь направляет его через сеть Web-серверу;

  • сервер с помощью CGI-программы анализирует полученный документ и (при необходимости) направляет его для обработки в соответствующее приложение;

  • приложение, используя CGI-переменные, обрабатывает направленный в него документ и возвращает серверу выходную информацию;

  • сервер передает выходную информацию клиенту;

  • клиент (Web-браузер) получает выходную информацию, которая отображается у него и может быть оценена и использована.

Таким образом, пользователь (клиент) имеет возможность не только получать информацию (документы) от сервера, но и передавать свои данные на сервер, где с помощью соответствующего приложения, установленного на Web-узле, эти данные будут обработаны, а клиент получит результаты обработки данных. Такая система взаимодействия обеспечивает принципиально более высокий уровень интерактивности в системе клиент-сервер, и реализацию дистанционной обработки данных клиента.

CGI-программа может быть написана на любом языке программирования, в составе которого имеются средства для выполнения обмена данными между приложениями. На платформе UNIX (популярный Web-сервер «Апачи» работает именно на этой платформе) для этой цели чаще всего используется язык Перл (Perl). Интерпретаторы этого языка без преобразования исходного текста программы вырабатывают исполняемый двоичный код. По этой причине CGI-программы часто называют также CGI-сценариями или CGI-скриптами (Script интерпретируемый текст).

CGI-программа создает динамический (виртуальный) гипертекстовый документ или же формирует ссылку на уже имеющийся документ и дополняет его передачей результатов. Чаще всего для передачи данных от удаленного пользователя Web-серверу используются HTML-формы. Именно с их помощью организуется диалог между браузером пользователя и Web-сервером удаленного узла сети. Такой диалог позволяет осуществить важнейшие операции в сети Интернет.

Далее остановимся на кодировании и обработки данных, передаваемых с помощью формы. Существует два метода кодирования содержащейся внутри формы информации. Первый соответствует значению параметра METHOD='GET' и называется application/x-www-form-urlencoded. Второй метод multipart/form-data используется только в том случае, если к содержимому формы подсоединяется локальный файл.

Основная схема кодирования формы в обоих случаях состоит в том, что для каждого элемента, имеющего имя (NAME), создается пара NAME=VALUE, где VALUE - конкретное значение соответствующего элемента формы. Для кнопок и переключателей передается только значение выбранного элемента. Указанные выше пары соединяются в виде символьных последовательностей, причем в качестве разделителей пар используется символ . Сформированный таким образом набор символов пересылается как часть URL-запроса и носит название «строка запроса». Этой строке предшествует конструкция вида «cg-bin/<имя СС1-программы>?», в которой указано имя программы-обработчика данных, а знак вопроса отделяет эту часть от строки запроса.

Внутри символьной последовательности могут содержаться символы, недопустимые в составе URL-запроса. Известно, что ASCII-символы кодируются двумя шестнадцатиричными цифрами. Поэтому недопустимые в составе запроса символы заменяются триадами из знака % и двух цифр 16-тиричной системы счисления, соответствующих этому символу. Например, символ конца строки и перехода на начало новой (используется при передачи данных из поля TEXTAREA) записывается в виде: %ODOA, где OD соответствует тринадцати в десятичной системе счисления, а ОА - десяти.

Web-сервер, получив URL-запрос от клиента, присваивает переменной среды QUERY_STRING значение строки запроса и вызывает CGI-npoграмму, указанную в первой части запроса. Затем CGI-программа может обратиться к переменной среды QUERY_STRING, чтобы осуществить обработку закодированной в ней информации.

Что требуется от CGI-скрипта? И какова цель обработки информации? Дело в том, что на основании содержащейся в форме информации необходимо создать новый HTML-документ и передать его обратно клиенту.

Какой язык следует использовать в CGI-программе? Сам CGI-интерфейс не накладывает каких-либо ограничений на выбор языка программирования. Поэтому его выбор должен быть основан на тех функциях, которые с его помощью должны быть реализованы. Перечислим их:

  • удобный интерфейс для взаимодействия с другими программами, например, с СУБД или графическим редактором;

  • наличие средств доступа к переменным среды, так как именно с их помощью данные формы поступают на вход CGI-скрипта;

  • наличие средств обработки текста, что требуется для предварительной обработки (декодирования) данных, поступающих на вход программы.

В операционной системе UNIX, используемой на большинстве Web-серверов, широко применяются скрипты, состоящие из конструкций языка shell командной оболочки операционной системы UNIX. В языке shell имеются также встроенные средства характерные для языков программирования высокого уровня: операторы цикла, условного перехода, строковые переменные и пр. Видимо, наличие этого языка и широкое использование командных процедур в оболочке UNIX привели к появлению ряда интерпретирующих языков, пригодных для написания CGI-сценариев. И хотя скрипты можно писать на любом из них, а также на языке Си, наибольшее распространение получил язык Перл практический язык извлечений и отчетов (PERL-Practical Extraction Report Language). Он не только удовлетворяет трем перечисленным выше требованиям, но обладает тремя дополнительными полезными особенностями:

  • бесплатным его распространением;

  • универсальностью его версии существуют практически для всех известных платформ, в том числе для DOS и Windows;

  • наличием большого числа готовых программных модулей, распространяемых свободно в сети Интернет.

Кроме перечисленного следует отметить, что создание CGI-скриптов на языке Перл стало значительно проще, начиная с версии 5.004 стандартного дистрибутива Перл, в который был включен специальный модуль CGI.pm. Этот модуль, который был подготовлен Линкольном Штейном, автором известной книги «Как создать и поддерживать свой Web-сайт», берет на себя всю рутинную работу по созданию CGI-программы на языке Перл. Модуль, как и сам язык Перл, является платформно-независимым, в частности, он успешно работает и во всех версиях MS Windows.


Электронные издания:

Библиография

    Глава I

  1. Вуль В. Виртуальный мир книги // Вы и Ваш компьютер.- 2000.- №11-12.

  2. Вуль В. Отрасли печати в современном мире // Вы и Ваш компьютер. - 1999. - №12.

    3. Глава II

  3. Розен К. и др. Введение в Unix.- СПб.: Лори.- 1999.

  4. Кульгин М. Технология корпоративных сетей. Энциклопедия.- СПб.: Питер, 2000.

  5. Матросов А., Сергеев А., Чаунин М. HTML4.0.- СПб.: BHV-Санкт- Петербург, 1999.

    6. Глава III

  6. Мюррей Джеймс Д., Райпер Уильям вам. Энциклопедия форматов графических файлов.- Киев: BHV-Киев, 1997.

  7. Сенцл Т. Форматы файлов Интернет.- СПб.: Питер, 1997.

    8. Глава IV

  8. Гореткина Е. HTML-редакторы для профессионалов // Сети.- 1999.-№4.

  9. Макмэхон Ф. Секретный мир PDF // Publish.- 2000.- № 2. (www. webmagazine.ru/2000/02 /062. html)

  10. Вуль В. GIF-аниматоры // Вы и Ваш компьютер.- 2001.- № 5.

  11. Миронов Д. Создание Web-страниц в MS Off ice 2000.- СПб.: BHV- Санкт-Петербург, 2000.

    12. Глава V

  12. Вуль В. А. Структура и элементная база современных персональных компьютеров. Конспект лекций.- М.: Издательство МГУП, 1999.

  13. Вуль В. Общая характеристика браузеров // Вы и Ваш компьютер.- 2001.- № 5.

    14. Глава VI

  14. Омельченко Л., Федоров А. Самоучитель FrontPage2000.- СПб.: BHV-Санкт-Петербург, 1999.

    15. 6.2. РозенцвейгГ. Macromedia Director.- СПб.: BHV-Санкт-Петербург, 1998.

  15. Миронов Д. Создание Web-страниц в MS Office 2000.- СПб.: BHV- Санкт-Петербург, 2000.

    16. Глава VII

  16. Вуль В. А. Совершенствование информационной структуры современного издательства и сетевые издательские технологии // Труды кон ференции «Региональная информатика - 2000».-СПб., 2001.

  17. Миронов Д. Создание Web-страниц в MS Office 2000.- СПб.: BHV- Санкт-Петербург, 2000.

  18. Вуль В. CGI-технологии // Вы и Ваш компьютер. - 2001.- № 3.

  19. Харитонова И. А., Михеева В. Д. Microsoft Access 2000.- СПб.: BHV - Санкт-Петербург, 1999.

  20. Пэтчет К., Райт М. CGI/Perl. Создание программ для Web/Перевод с англ.- Киев: BHV-Киев, 2000.

  21. Вуль В. А. Общая концепция издательской базы данных // Отечественная книжная индустрия на рубеже веков. Материалы первой научно- практической конференции.- СПб.: Издательство «Петербургский институт печати», 2000.

    22. Глава VIII

  22. Вуль В. Виртуальный мир книги // Вы и Ваш компьютер. - 2000. - №11-12.

  23. Вуль В. А. Современное состояние и перспективы электронного книгоиздания // Учебные и справочные электронные издания: опыт и проблемы. Материалы научно-практической конференции.- СПб: Издательство «Петербургский институт печати», 2001.

  24. Вуль В. Что мы будем читать в XXI веке // Вы и Ваш компьютер. - 2000. - №3.

    25. Глава IX

  25. Вуль В. А. Электронный учебник и самостоятельная работа студентов // Учебные и справочные электронные издания: опыт и проблемы. Ма териалы научно-практической конференции. СПб., 2001.

  26. Томасов В. С., Денисов К. М., Усольцев А. А. Разработка и использование электронных учебно-методических пособий при выполнении комплексных лабораторных работ // Учебные и справочные электронные издания: опыт и проблемы. Материалы научно-практической конференции.- СПб: Издательство «Петербургский институт печати», 2001.


Электронные издания: Предметный указатель

Предметный указатель
American Standart Code for Information Interchange (ASCII) - Американский стандартный код для обмена информацией Форматы электронных изданий Форматы представления текстовых блоков электронного издания
Animation Compressor Форматы цифрового видео
CD-ROM (Compact Disk - Read Only Memory) CD-ROM-накопители для работы с переносимыми изданиями
Compact Video Compressor Форматы цифрового видео
DVD-диск (Digital Video Disk) Другие виды оптических накопителей
E-book Технология E-book и развитие электронного книгораспространения Специализированные аппаратные средства для работы с электронными изданиями
Flash Общая характеристика и интерфейс пакета Основные понятия и элементы Flash-технологии
Graphic Compressor Форматы цифрового видео
Graphic Interchange Format (GIF) Форматы представления графической информации
HTML (Hyper Text Markup Language) Форматы электронных изданий
HTML формат Форматы представления текстовых блоков электронного издания
HTML-документ Общая характеристика и структура HTML-документа Теги физического форматирования текста Оформление списков терминов и определений Издательские технологии и электронные издания
HTML-редакторы Общая характеристика типовых HTML-редакторов первой группы
HTML-формы HTML-формы
Joint Photographic Experts Group (JPEG) Форматы представления графической информации
Microsoft Word 2000 Подготовка изданий в редакторе MS Word 2000
Microsoft Word Подготовка изданий в редакторе MS Word 97
Musical Instrument Digital Interface (MIDI) Форматы представления аудиофайлов
PDF (Portable Document Format) Форматы электронных изданий Форматы представления текстовых блоков электронного издания Подготовка документов в PDF-формате Программные средства для работы с электронными изданиями в PDF-формате
Photo Compressor Форматы цифрового видео
Raw Compressor Форматы цифрового видео
Video Compressor Форматы цифрового видео
VRML (Virtual Reality Modeling Language) Назначение и общая характеристика браузеров
Web-сайт Что такое «электронное издание»
Web-страница Что такое «электронное издание»
Анимационные файлы в формате GIF Анимационные GIF-файлы
Анимация Подготовка анимационных фрагментов в пакете 3D Studio Max
База данных издательская Требования к информационному хранилищу издательства
База данных объектно-ориентированная (ООБД) Проектирование структуры хранилища электронных изданий
База данных реляционная Проектирование структуры хранилища электронных изданий
Браузер Назначение и общая характеристика браузеров
Булевы модели поиска Организация хранения и поиска электронных изданий
Динамический HTML (DHTML) Понятие о динамическом HTML и его компонентах
Дискретизация Форматы представления аудиофайлов
Закладка Включение в издание ссылок и комментариев
Звуковое сопровождение Звуковое сопровождение
Иллюстрации Использование графики при оформлении электронного издания Форматы представления графической информации
Интернет Что такое «электронное издание» Форматы электронных изданий Общая характеристика и структура HTML-документа Мультимедиа и ее роль в современных информационных технологиях Требования к информационному хранилищу издательства
Интернет-магазин Виртуальный мир книги и его особенности
Информационное хранилище Проектирование структуры хранилища электронных изданий
Квантование Форматы представления аудиофайлов
Классификация электронных изданий Классификация электронных изданий
Ключевое слово Применение программ-экстракторов
Комментарий Включение в издание ссылок и комментариев
Контейнер Общая характеристика и структура HTML-документа
Метаинформация Применение программ-экстракторов
Монитор Мониторы и требования к ним
Мультимедиа Мультимедиа и ее роль в современных информационных технологиях
Невещественный носитель Что такое «электронное издание» Классификация электронных изданий
Оригинал-макет Издательские технологии и электронные издания
Список маркированный Маркированные списки
Список многоуровневый Многоуровневые списковые структуры
Список нумерованный Создание нумерованных списков
Список определений Списки определений
Ссылка Включение в издание ссылок и комментариев
Таблица Оформление таблиц
Тег Общая характеристика и структура HTML-документа
Формат AU Форматы представления аудиофайлов
Формат Audio Interchange File Format (AIFF) Форматы представления аудиофайлов
Формат Audio/Video Interleave (AVI) Форматы цифрового видео
Формат MP3 Форматы представления аудиофайлов
Формат MPEG-1 Форматы цифрового видео
Формат MPEG-2 Форматы цифрового видео
Формат MPEG-4 Форматы цифрового видео
Формат QuickTime Форматы цифрового видео
Формат WAV Форматы представления аудиофайлов
Форматы электронных изданий Форматы электронных изданий Форматы представления текстовых блоков электронного издания
Электронная коммерция Современное состояние и перспективы электронного книгоиздания
Электронное издание Что такое «электронное издание» Что такое «электронное издание»
Язык HTML Общая характеристика и структура HTML-документа
Язык Visual Basic Понятие о динамическом HTML и его компонентах
Язык программирования JavaScript Понятие о динамическом HTML и его компонентах


Электронные издания: Указатели

Указатели
2 именной указатель
92 предметный указатель
265 указатель иллюстраций
58 указатель компаний


Электронные издания: Титул

Московский государственный университет печати
Вуль В.А.

Электронные издания

Учебник

© Центр дистанционного образования МГУП


Электронные издания: Оглавление

Вуль В.А. Электронные издания
Начало
Печатный оригинал
Об электронном издании
Оглавление
 | Предисловие
1. | Глава 1. Общая характеристика электронных изданий
1.1. | Что такое «электронное издание»
1.2. | Составные элементы электронного издания
1.2.1. | Тексты
1.2.2. | Иллюстративный материал
1.2.3. | Звуковое сопровождение
1.2.4. | Анимация и видео
1.3. | Форматы электронных изданий
1.4. | Классификация электронных изданий
1.5. | Современное состояние и перспективы электронного книгоиздания
2. | Глава II. Структура и элементы гипертекстовых документов
2.1. | Общая характеристика и структура HTML-документа
2.2. | Тело документа и оформление его основных фрагментов
2.2.1. | Тело документа
2.2.2. | Теги логического форматирования текста
2.2.3. | Теги физического форматирования текста
2.3. | Оформление списков терминов и определений
2.3.1. | Маркированные списки
2.3.2. | Создание нумерованных списков
2.3.3. | Списки определений
2.3.4. | Многоуровневые списковые структуры
2.4. | Использование графики при оформлении электронного издания
2.5. | Включение в издание ссылок и комментариев
2.6. | Оформление таблиц
2.7. | Фреймовая структура электронного издания
2.8. | HTML-формы
2.9. | Понятие о динамическом HTML и его компонентах
3. | глава III. Мультимедийный документ и форматы представления его элементов
3.1. | Мультимедиа и ее роль в современных информационных технологиях
3.2. | Форматы представления текстовых блоков электронного издания
3.3. | Форматы представления графической информации
3.4. | Форматы представления аудиофайлов
3.5. | Форматы представления анимации и цифрового видео
3.5.1. | Анимационные GIF-файлы
3.5.2. | Принципы представления цифрового видео
3.5.3. | Форматы цифрового видео
4. | глава IV. Средства подготовки электронных изданий
4.1. | Издательские технологии и электронные издания
4.2. | Подготовка гипертекстовых электронных изданий в DOC-формате
4.2.1. | Подготовка изданий в редакторе MS Word 97
4.2.2. | Подготовка изданий в редакторе MS Word 2000
4.3. | Редактирование HTML-изданий в редакторе MS Word 97
4.3.1. | Команды секции меню «Формат»
4.3.2. | Команды секции меню «Вставка»
4.4. | Общая характеристика типовых HTML-редакторов первой группы
4.5. | Общая характеристика WYSIWYG-редактора Netscape Composer
4.6. | Подготовка документов в PDF-формате
4.7. | Программы-конструкторы для подготовки анимационных GIF-файлов
5. | глава V. Аппаратное и программное обеспечение рабочего места читателя
5.1. | Требования и рекомендации к аппаратному обеспечению
5.1.1. | Требования к центральной части или ядру ПК
5.1.2. | Мониторы и требования к ним
5.1.3. | CD-ROM-накопители для работы с переносимыми изданиями
5.1.4. | Другие виды оптических накопителей
5.2. | Назначение и общая характеристика браузеров
5.3. | Браузер MS Internet Explorer
5.3.1. | Экранный интерфейс
5.3.2. | Организация просмотра загруженного документа
5.3.3. | Основные команды меню браузера
5.3.4. | Ведение журнала обозревателя и команды других секций меню
5.4. | Программные средства для работы с электронными изданиями в PDF-формате
5.5. | Программные средства для воспроизведения аудиофайлов
6. | глава VI. Подготовка сетевых и мультимедийных изданий в специализированных программных пакетах
6.1. | Общая характеристика пакета MS FrontPage 2000
6.1.1. | Интерфейс пакета
6.1.2. | Технология подготовки новых Web-сайтов
6.2. | Назначение и общая характеристика пакета Dreamweaver
6.2.1. | Интерфейс пакета DreamWeaver
6.2.2. | Последовательность проектирования сайта в пакете Dreamweaver
6.3. | Подготовка мультимедийных изданий в пакете Macromedia Director
6.3.1. | Интерфейс пакета Macromedia Director
6.3.2. | Основные окна и инспекторы пакета
6.3.3. | Основные этапы работы над мультимедийным электронным изданием
6.4. | Дизайн Web-сайтов в пакете Macromedia Flash
6.4.1. | Общая характеристика и интерфейс пакета
6.4.2. | Основные понятия и элементы Flash-технологии
6.5. | Общая характеристика других программных средств для Web-дизайна
6.5.1. | Другие средства проектирования Web-сайтов
6.5.2. | Подготовка анимационных фрагментов в пакете 3D Studio Max
7. | глава VII. Организация хранения электронных изданий
7.1. | Организация хранения и поиска электронных изданий
7.2. | Информационное хранилище издательства
7.2.1. | Требования к информационному хранилищу издательства
7.2.2. | Проектирование структуры хранилища электронных изданий
7.3. | Информационная структура современного издательства
7.4. | Автоматизация выделения метаданных
7.4.1. | Метаинформация и ее роль
7.4.2. | Законы Зипфа и автоматизация извлечения метаданных из электронных изданий
7.4.3. | Применение программ-экстракторов
7.5. | Публикация содержимого баз данных на Web-страницах
7.5.1. | Публикация статических Web-страниц
7.5.2. | Публикация динамических Web-страниц
8. | глава VIII. Распространение электронных изданий
8.1. | Виртуальный мир книги и его особенности
8.1.1. | Некоммерческие электронные библиотеки
8.1.2. | Представительство крупных библиотек в Интернете
8.2. | Электронные книжные магазины
8.3. | Технология E-book и развитие электронного книгораспространения
8.3.1. | Специализированные аппаратные средства для работы с электронными изданиями
8.3.2. | Современное аппаратное средство E-book
8.3.3. | Программные средства E-book
8.3.4. | Стандарт Open E-book
8.3.5. | Достоинства и недостатки технологии E-book
9. | глава IX. Электронные учебники
9.1. | Достоинства и недостатки электронных учебников
9.2. | Структура электронного учебника
9.3. | Основные принципы подготовки электронных учебников
9.3.1. | Размещение информации на поверхности экрана
9.3.2. | Проблема ориентации и перемещения пользователя внутри электронного издания
9.4. | Дистанционное обучение и организация самостоятельной работы студентов
9.5. | Автоматизированные методы оценки уровня подготовки студента
 | Библиография
Указатели
2 именной указатель
92 предметный указатель
265 указатель иллюстраций
58 указатель компаний


Электронные издания: Оглавление

Оглавление

Предисловие
1. Глава 1. Общая характеристика электронных изданий
1.1. Что такое «электронное издание»
1.2. Составные элементы электронного издания
1.2.1. Тексты
1.2.2. Иллюстративный материал
1.2.3. Звуковое сопровождение
1.2.4. Анимация и видео
1.3. Форматы электронных изданий
1.4. Классификация электронных изданий
1.5. Современное состояние и перспективы электронного книгоиздания
2. Глава II. Структура и элементы гипертекстовых документов
2.1. Общая характеристика и структура HTML-документа
2.2. Тело документа и оформление его основных фрагментов
2.2.1. Тело документа
2.2.2. Теги логического форматирования текста
2.2.3. Теги физического форматирования текста
2.3. Оформление списков терминов и определений
2.3.1. Маркированные списки
2.3.2. Создание нумерованных списков
2.3.3. Списки определений
2.3.4. Многоуровневые списковые структуры
2.4. Использование графики при оформлении электронного издания
2.5. Включение в издание ссылок и комментариев
2.6. Оформление таблиц
2.7. Фреймовая структура электронного издания
2.8. HTML-формы
2.9. Понятие о динамическом HTML и его компонентах
3. глава III. Мультимедийный документ и форматы представления его элементов
3.1. Мультимедиа и ее роль в современных информационных технологиях
3.2. Форматы представления текстовых блоков электронного издания
3.3. Форматы представления графической информации
3.4. Форматы представления аудиофайлов
3.5. Форматы представления анимации и цифрового видео
3.5.1. Анимационные GIF-файлы
3.5.2. Принципы представления цифрового видео
3.5.3. Форматы цифрового видео
4. глава IV. Средства подготовки электронных изданий
4.1. Издательские технологии и электронные издания
4.2. Подготовка гипертекстовых электронных изданий в DOC-формате
4.2.1. Подготовка изданий в редакторе MS Word 97
4.2.2. Подготовка изданий в редакторе MS Word 2000
4.3. Редактирование HTML-изданий в редакторе MS Word 97
4.3.1. Команды секции меню «Формат»
4.3.2. Команды секции меню «Вставка»
4.4. Общая характеристика типовых HTML-редакторов первой группы
4.5. Общая характеристика WYSIWYG-редактора Netscape Composer
4.6. Подготовка документов в PDF-формате
4.7. Программы-конструкторы для подготовки анимационных GIF-файлов
5. глава V. Аппаратное и программное обеспечение рабочего места читателя
5.1. Требования и рекомендации к аппаратному обеспечению
5.1.1. Требования к центральной части или ядру ПК
5.1.2. Мониторы и требования к ним
5.1.3. CD-ROM-накопители для работы с переносимыми изданиями
5.1.4. Другие виды оптических накопителей
5.2. Назначение и общая характеристика браузеров
5.3. Браузер MS Internet Explorer
5.3.1. Экранный интерфейс
5.3.2. Организация просмотра загруженного документа
5.3.3. Основные команды меню браузера
5.3.4. Ведение журнала обозревателя и команды других секций меню
5.4. Программные средства для работы с электронными изданиями в PDF-формате
5.5. Программные средства для воспроизведения аудиофайлов
6. глава VI. Подготовка сетевых и мультимедийных изданий в специализированных программных пакетах
6.1. Общая характеристика пакета MS FrontPage 2000
6.1.1. Интерфейс пакета
6.1.2. Технология подготовки новых Web-сайтов
6.2. Назначение и общая характеристика пакета Dreamweaver
6.2.1. Интерфейс пакета DreamWeaver
6.2.2. Последовательность проектирования сайта в пакете Dreamweaver
6.3. Подготовка мультимедийных изданий в пакете Macromedia Director
6.3.1. Интерфейс пакета Macromedia Director
6.3.2. Основные окна и инспекторы пакета
6.3.3. Основные этапы работы над мультимедийным электронным изданием
6.4. Дизайн Web-сайтов в пакете Macromedia Flash
6.4.1. Общая характеристика и интерфейс пакета
6.4.2. Основные понятия и элементы Flash-технологии
6.5. Общая характеристика других программных средств для Web-дизайна
6.5.1. Другие средства проектирования Web-сайтов
6.5.2. Подготовка анимационных фрагментов в пакете 3D Studio Max
7. глава VII. Организация хранения электронных изданий
7.1. Организация хранения и поиска электронных изданий
7.2. Информационное хранилище издательства
7.2.1. Требования к информационному хранилищу издательства
7.2.2. Проектирование структуры хранилища электронных изданий
7.3. Информационная структура современного издательства
7.4. Автоматизация выделения метаданных
7.4.1. Метаинформация и ее роль
7.4.2. Законы Зипфа и автоматизация извлечения метаданных из электронных изданий
7.4.3. Применение программ-экстракторов
7.5. Публикация содержимого баз данных на Web-страницах
7.5.1. Публикация статических Web-страниц
7.5.2. Публикация динамических Web-страниц
8. глава VIII. Распространение электронных изданий
8.1. Виртуальный мир книги и его особенности
8.1.1. Некоммерческие электронные библиотеки
8.1.2. Представительство крупных библиотек в Интернете
8.2. Электронные книжные магазины
8.3. Технология E-book и развитие электронного книгораспространения
8.3.1. Специализированные аппаратные средства для работы с электронными изданиями
8.3.2. Современное аппаратное средство E-book
8.3.3. Программные средства E-book
8.3.4. Стандарт Open E-book
8.3.5. Достоинства и недостатки технологии E-book
9. глава IX. Электронные учебники
9.1. Достоинства и недостатки электронных учебников
9.2. Структура электронного учебника
9.3. Основные принципы подготовки электронных учебников
9.3.1. Размещение информации на поверхности экрана
9.3.2. Проблема ориентации и перемещения пользователя внутри электронного издания
9.4. Дистанционное обучение и организация самостоятельной работы студентов
9.5. Автоматизированные методы оценки уровня подготовки студента
Библиография


Центр дистанционного образования МГУП

home about news MGUP
Центр дистанционного образования
additional stuff student's work

О нас
Кто мы и как нас найти
Вакансии
Ссылки
Учебные комплексы
 История книжного дела
Библиотека
 Антикварная Книга
Общая библиография
Регионика России
ДАЛЕЕ >>>
Глобальные ресурсы
МГУП
Об университете
Сайт МГУП
Факультеты
Специальности
Поступающим
Порядок приема
Порядок обучения
Договор
Стоимость
Учебный план
Авторам
Разработка тестов
Дополнительно
РБС
Интерактивный тест

Ошибка 404

Запрашиваемый документ не найден.

Возможные причины:

• Вы неправильно набрали URL.
• Вы нажали на неверную ссылку, опубликованную на постороннем сайте.
• Закладка (ярлык) в Вашем браузере указывает на страницу, которая перемещена или удалена.
• Мы опубликовали на сайте неверную ссылку — пожалуйста, сообщите нам об этом по адресу webmaster@hi-edu.ru

Перейти на главную страницу сайта.
Rambler's Top100
[Home] [О нас] [Абитуриенту] [Студенту][Форумы] [МГУП] [Новости]
[Дополнительные материалы] [Работы студентов] [Довузовская подготовка]
© Центр дистанционного образования МГУП, 2001—2003

webmaster@hi-edu.ru