	Учебник по моделированию мобильного телефона
	перевод: Алексей Е. Попов  Aka DenziL 


Сразу же хочу оговориться, что пример не мой, а нашего китайского друга Cafer J. http://www.geocities.com/~caferj/. Поскольку человек китаец, то и учебник на китайском. Можете представить насколько достоверно я передаю его слова (точность формулировок) если учесть, что китайский я вообще не знаю, то есть совсем! Ну да ничего, картинок , прорвемся! Итак, вперед!


	Для наш друг китаец советует включить Snap, Ortho, режим Planar и Osnap по концу(End).
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	Подготавливаем поле для работы дальше. Вызываем меню Options, кликнув на [image: image2.png]


 и ставим галочки где показано, вводим циферки, как показано. Лично у меня другие, но, как говорится, кто как привык! 
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	Загружаем стандартный Templates. Файл 4 Viewports.3dm.


	Горячие клавиши: 

Space - повторение последней команды (тоже Правый клик мышки)
z+Enter: Zoom Window [image: image4.png]


 Район увеличения видового окна.
c+Enter: Select Window - выделение об'ектов в выделенной области.
s+Enter: Snap on/off вкл/выкл снапа, горячая клавиша - F9.
o+Enter: Ortho on/off вкл/выкл привязки к вертикали-горизонтали, горячая клавиша - F8, в принципе, при отлюченной опции, но при удержании Shift Ortho также работает! Какой способ выбрать - дело вкуса, я предпочитаю последний.
p+Enter: Planar on/off
F7: Grid on/off вкл/выкл координатной сетки.
F10: (PtOn) - показать контрольные точки.
F11: (PtOff) - скрыть контрольные точки.
В принципе, вы сами можете переназначить клавишиЖ Tool->Options-> Shortcut Keys. Лично у меня любимая команда - SetPt. 


	Ну, все, приготовления закончены, приступаем к моделлингу!
Кликаем на [image: image5.png]


 Curve: Interpolate points - Кривая линия. Строим две линии: левую и верхнюю (не надо строить закругленные, просто прамые).
Кликаем на [image: image6.png]


 Mirror - отражение, и относительно осей отражаем построенные линии, жмем на F10 и корректируем контрольные точки, если снап включен, прблем с симметрией не будет. Отключаем контрольные точки - F11.
Далее будем скруглять углы, кликаем на [image: image7.png]


 Fillet , затем поочередно кликаем на кривые, учавтвующие в операции. Величина ридиуса скругления вводится в командной строке, подберите ее опытным путем! Далее выделяем все кривые - [image: image8.png]Al



 и об'единяем их - [image: image9.png]o



. Теперь у нас одна монолитная кривая!


1. [image: image10.png]


 2. [image: image11.png]



3. [image: image12.png]


 4. [image: image13.png]



	Строим еще одну кривую - [image: image14.png]


, как показано на рисунке.


[image: image15.png]



	Меняем вид справа на левый.  :)
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	Копирем дважды построенную линию - [image: image17.png]


, главное, чтобы скопированные кривые заходили за недавно построенный контур. Выделяем три кривые и строим по ним лофтовую поверхность.Surface -> Loft.
[image: image18.png]


 Кликаем на иконку Loft и подтверждаем. OK!


	Должно получиться что-то вроде:


1. [image: image19.png]
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	Жмем F10 и меняем положение одной из средних точек:


[image: image21.png]



	Откорректировали, выключаем контрольные точки - F11.


[image: image22.png]




Передвигаем - [image: image23.png]


 поверхность на два шага сетки вверх.
[image: image24.png]



	Снова выделяем три кривые и строим поверхность - Loft, только теперь средние контрольные точки нужно передвинуть вниз, примерно так, как показано на рисунке:


[image: image25.png]



	В конечном итоге должно получиться что-то типа:


[image: image26.png]



	О'кей теперь приступим к боковинам. [image: image27.png]Qs
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 Кликаем на Extrude Straight ( вытянуть прямо ).   Выделяем нижний контур и в команной сторке вводим "c" - Cap Planar Holes (Закрыть плоские дыры), Enter.
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	Далее вводим 7.5 - величина вытягивания,Enter.
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	Если бы Вы не ввели "с" - по умолчанию, то построились бы только боковые грани.


[image: image30.png]



	Теперь выделяем верхнюю из недавно построенных поверхностей и проверяем направление нормалей - dir, Enter. Rhino покажет их белыми стрелками. Нам нужно перевернуть нормали (flip), вводим в командной строке - f ,Enter, нормали должны перевернуться. У нижней плоскости направление менять не нужно.


[image: image31.png]



[image: image32.png]



	Ок, теперь попробуем создать корпус. Для этой операции у нас все уже есть. Нужно просто найти разницу между вытянутым контуром и двумя поверхностями. Для этого наиболее подходит булевский оператор - [image: image33.png]


 (Boolean difference). Кликаем на иконку, выделяем вытянутый об'ект, Enter, выделяе верхнюю и нижнюю поверхности, Enter! Типа круто и все такое! :)

	


[image: image34.png]



	Ок, теперь нужно разбить об'ект на поверхности. Жмем [image: image35.png]


 (Explode) - "взорвать" и указываем на об'ект. Далее, удаляем   образованную поверхность, соединяющую верхнюю и нижнюю поверхности. 


[image: image36.png]
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	Чтобы избежать дальнейших запуток, вводим новый слой "Surface" - поверхности, кликнув на [image: image38.png]


 -Edit Layers. На рисунке показано диалоговое меню редактирования слоев Rhino 1.1, которое немного отличается от предыдущих версий, не нужно комплексовать, там все просто! В принципе идея не нова: создать несколько слоев, и в каждый помещать определенные группы об"ектов: Curve (кривые),Surface(поверхности). Можно даже расскрасить их в разные цвета, так непоняток будет еще меньше!


	Далее, выделяем группу об'ектов (поверхности) , кликаем на [image: image39.png]


 (Object Properties) - свойства об'ектов и помещаем их в соответствуюший слой, выбрав его в меню Layer.
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	Того же эффекта можно добиться, кликнув на [image: image41.png]


, и выбрать изменить слой -(Change Layer) [image: image42.png]s Layer |
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. Ок, кликаем на Blend Surface.
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	Выделяем ребра поверзностей, и смотрим, как расположены вектора обхода. Если они находятся не друг под другом или направлены в разные стороны, можно ввести в консоли "а" - автоматическое выравнивание, если и это не помогает, нужно вручную пододвинуть вектор, и , если необходимо перевернуть направление вектора "f" (flip).


[image: image45.png]



	Теперь автор советует изменить "Абсолютный допуск", чем он меньше, тем точнее будут совмещаться ребра, но тем больших обсчетов и времени требуется от машины. В меню Tool->Options, в закладке Unit находим Absolute Tolеrance и изменяем значение с 0.01 на 0.1.


Можно полюбоваться на работу [image: image46.png]


 (Shade) Cool!
[image: image47.png]



	Об'единяем полученную и верх/низ поверхности, кликнув на  [image: image48.png]o



. Собственно, ничего не изменилось, просто мы образовали одну множественную поверхность (Polysurf), которую Rhino при экспорте передаст как один меш. Ок, "безглючность" полученного об"екта можно проверить, применив Analyze->Edge Tools->Show Naked Edges (Анализ->Инструмент для ребер-> Показать открытые ребра). Если после применения данного инструментария, на об'екте не будет выделенных ребер, то все Ок, с об'ектом проблем не будет!
Показываем слой с кривыми (Curve), находим исходную кривую, по которой строились верх и низ трубки, перемещаем ее к центру [image: image49.png]


 и немного растягиваем, применив 1D Scale. Необходимо, чтобы она немного выступала с обоих концов.
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[image: image51.png]



	Выделяем кривую и применяем [image: image52.png]


 Extrude Straigh (вытянуть прямо). Вытягиваем на расстояние, превышающее габариты корпуса трубки. Если перед вытягиванием в командной строке ввести b(both), то кривая будет вытягиваться сразу в обе стороны.
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	Ок! Теперь нужно создать копии корпуса и поверхности [image: image54.png]


. Проще это сделать выделив об"екты и нажать (Ctrl+c) - copy (Ctrl+v) - paste . Теперь скройте скопированные об'екты, Примените [image: image55.png]


 (Boolean Difference) Между корпусом и поверхностью, далее скройте полученный об"ект. Откройте скопированные об"екты, примените Dir (направление нормалей) к поверхности, переверните их ("F"-flip) и примените булевский оператор разности [image: image56.png]


. У Вас должны получиться два Об'екта, представляющие верх и низ трубки.


[image: image57.png]



	Увеличте [image: image58.png]


 вид, найдите нижнюю часть корпуса и скройте ее [image: image59.png]Hide



.

Пимечание: Наш друг китаец рекомендует несколько видоизменить Toolbar, поместив на него несколько нужных иконок. На самом деле это  дело вкуса, у каждого свой интерфейс, кто как привык, сделайте его таким, какой нравится именно Вам, и никого не слушайте, даже меня :) 
Далее привожу его слова: выбирите Tools->Toolbar->Layout->Edit, найдите Select, нажмите Show, у вас появится расскытое меню Select, с нажатой кнопкой Ctrl перетащите на другое место (куда больше нравится)  несколько иконок Select (Select: Point, Curves, Polylines, Surfaces, Polysurfaces, SelectInverse). Далее, когда  Вы шелкните , например, на SelectCurves, выделятся все кривые, шелкните Hide, они скроются! Забавно... :) 
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 3. [image: image62.png]



	Ок! Теперь поместите кривые в соответствующий слой и выключите его, они исчезнут (не буквально). Строим Curve (кривую), определяющую панель индикации телефона, что-то вроде того, как показано ниже: (не стройте много точек!)


[image: image63.png]



	Кликаем на Extrude Straight ( вытянуть прямо ).   Выделяем контур и в команной сторке вводим "c" - Cap Planar Holes (Закрыть плоские дыры), Enter. Вытягиваем так, чтобы перекрыть верх трубки.



[image: image64.png]



	Ок! Теперь выделяем оба об'екта и копируем [image: image65.png]


 (Ctrl+c - Ctrl+v). Скрываем одну пару, кликаем на [image: image66.png]


 (Boolean difference - разность) выделяем трубку, Right Click, Выделяем вытянутый об'ект, Right Click. Расскрываем вторую пару (копии) и кликаем на [image: image67.png]Y



 (Boolean intersection - пересечение), потом на трубке, Right Click, на вытянутом об'екте, Right Click! Должны получиться два об"екта, составляющие трубку.


[image: image68.png]




Выбираем Solid->Fillet Edge (сгладить ребра), выделяем два нижних ребра (см. ниже)
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В командной строке вводим 0.3 Enter!
[image: image70.png]




Любуемся :)
[image: image71.png]



	Теперь построим контур дисплея. Кликаем на [image: image72.png]


 (rectangle - прямоугольник), в командной строке вводим r (rounded - скругленный) Enter, Строим прямоугольник, а когда Rhino спросит величину скругления, вводим 0.3.


[image: image73.png]




Вырезаем дисплей, подобно предыдущим пунктам.
[image: image74.png]




Расскрашивеам дисплей, кликнув на [image: image75.png]


 (Object Properties) и задаем цветовые координаты:
[image: image76.png]oK
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Расскрашиваем обод дисплея, координаты цвета следующие:
[image: image77.png]




Типа наслаждаемся цветом! [image: image78.png]



[image: image79.png]



	Теперь пришло время Вам воспользоваться Вашей фантазией! Стройте кнопки, какие Вам нравятся! Автор предлагает вот такой вариант. Чтобы построить кривые кнопки, проще построить круг, затем кликнуть на [image: image80.png]


 и перестроить его, изменив лишь второй параметр с 2 на 3. Далее включайте режим редактирования контрольных точек и творите. Рекомендуется для клонирования использовать [image: image81.png]


 [image: image82.png]


.



[image: image83.png]



	Постройте две кривые вокруг нижних кнопок. Как их строил автор, я не знаю, попробуйте построить прямоугольник с параметром r и , когда Rhino попросит указать величину скругления, мышкой скорректируйте так, чтобы боковые стороны превратились в дуги. Далее включите режим редактирования контрольных точек и поднимите средние точки. Если Вы хотите большей детальности, обязательно перестройте кривую (измените второй параметр на 3) и можете добавить несколько точек на верхней и нижней сторонах. Ни в коем случае не стройте вторую кривую инструментом Offset, Вы получите очень большое количество точек. Проше скопировать построенное и скорректировать контрольные точки. 



[image: image84.png]QO
QO

oo




	Когда все линии будут построены и перемещены на место, выделите все линии кроме нижнего ряда и обводки, кликните на [image: image85.png]


 (Extrude Straigh), в коммандной строке введите  c (cap holes) и вытяните на достаточное расстояние!



[image: image86.png]




Теперь поочередно вырезайте вытянутые контуры из верхней части корпуса телефона [image: image87.png]
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	Теперь несколько запутанная операция, следите правильность по рисункам! 
1. Кликаем на [image: image89.png]


, выделяем большую по размеру линию обводки нижних кнопок, в коммандной строке вводим c, и вытягиваем.
2. Описанным выше способом вырезаем об'ект в нижней части трубки
3. Вытягиваем меньший из контуров
4. Находим общее (Boolean intersection) между полученным об'ектом (в п.2) и вытянутым в п.3
Должно получиться что-то наподобие рис5.


1. [image: image90.png]


 2. [image: image91.png]



3. [image: image92.png]


 4. [image: image93.png]



5. [image: image94.png]



	Выделяем верхнюю поверхность в только что полученном об'екте: Solid->Extract Surface (Об'ект - выделить поверхность).
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 [image: image96.png]



	Включаем режим контрольных точек - F10. Видно, что точки значительно превышают размер поверКорректируем это, применив Surface->Edit Tools->Shrink Trimmed Surface, после этой операции точки займут свое примерное положение и можно двигаться дальше!
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1. [image: image98.png]



2. [image: image99.png]




Выделим две точки посередине поверхности (см. рис) и опустим их немного вниз.
[image: image100.png]



[image: image101.png]



	Соединим раздробленный об'ект, кликнув на [image: image102.png]o



 и указав отделенную поверхность и то, от чего отделяли, Enter. Я надеюсь, булевские операции Вы уже освоили и с легкостью вырежете три отверстия в об'единенном только что об'екте!



[image: image103.png]



[image: image104.png]



	Теперь нужно подготовить поверхности для дальнейших построений. Сделайте следующее:
Кликните на Solid->Extract Surface [image: image105.png]


, и кликните на две поверхности (верхние, на рис выделены) и нанмите Enter. Сразуже сделайте их копию [image: image106.png]


 и  скройте [image: image107.png]Hide



. Присоедените поверхности обратно с помощью [image: image108.png]o



.


[image: image109.png]



	ТOk! Теперь кликаем на [image: image110.png]


 (Fillet edge - скруглить ребра), выделите ребра вокруг кнопок (на рис. выделены), в командной строке введите 0.1, Enter! Должны получиться приятные скругления! :) Можно даже полюбоваться (рис.3).



1. [image: image111.png]



2. [image: image112.png]



3. [image: image113.png]



	Так, теперь можно заняться спрятанными поверхностями, которые мы недавно сделали. Кликните на Unhide, и спрячьте все кроме этих поверхностей. Сейчас мы будем их немного дорабатывать. Во-первых нужно убрать дырки, которые мы наделали (не знаю, почему нельзя было скопировать поверхности, когда в них еще небыло дырок!???). Ну да ладно, будем считать это демонстрацией возможностей Rhino! Кликните на Surface->Edit Tools->Untrim, (Де-тримм, т.е. трим наоборот :) и поочередно кликайте на ребра, окружности удаляйте!
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1. [image: image115.png]



2. [image: image116.png]



	Так, теперь все скройте кроме поверхностей и окружностей [image: image117.png]Hide



. Теперь поочередно нужно для каждой из окружностей построить уменьшенную копию. Автор советует использовать для уменьшения инструмент Scale 1-D или Scale 2-D с параметром c (Copy), при включенном ОSnap по центру об"екта (cen) и Ortho. В принципе это справедливо для некруглых кривых (верхние кнопки), а для окружностей можно использовать и Scale-3D, только будьте обязательно уверены, что OSnap сработал, иначе кривую унесет вникуда :) Сделайте примерно так, как показано на рис.
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[image: image119.png]




Вытягиваем контуры [image: image120.png]


, при этом параметр c вводить не нужно, закрытые об'екты нам не нужны.
[image: image121.png]



	Находим линии пересечения [image: image122.png]2|  Curve From Object

i
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, Intersection вытянутых контуров с поверхностями.


[image: image123.png]



	Все, удаляем вытянутые об'екты. Кликните на [image: image124.png]


 (Select all curves), затем на [image: image125.png]


 (Select Invert), и [image: image126.png]Hide



. Дальше будем работать только с кривыми. Выделите внутренние кривые и переместите [image: image127.png]


 (Move) их на 0.2 вверх, инвертируйте выделение (нам нужны внешние контуры) и скопируйте [image: image128.png]


 их на 0.5 вниз. Далее будем строить собственно кнопки. Для этого выделяем три кривых, образующих одну кнопку и кликаем на [image: image129.png]u



 (Surface->Loft)


	Т [image: image130.png]


 В выпавшем меню Loft Options  меняем Style на Straight sections (прямые секции). Для тех, кому дальнейшие действия по закруглению кнопок кажутся очень сложными и громоздкими, можно посоветовать не менять графу и пропустить кучу последующих пунктов


.
[image: image131.png]Cancal Preview Help





	Так, теперь необходимо построить точки, которые будут задавать величину углубления кнопок. Точка должна располагаться примерно в центре кнопки и быть немного ниже верхней кривой. Лучше всего использовать [image: image132.png]Hide



 для скрытия всех линий, кроме одной, для которой Вы строите точку. В виде Top постройте точку, а в виде Right подкорректируйте ее положение по высоте. Да, работа трудоемкая, но ее нужно сделать!


[image: image133.png]



	Чтож, когда все точки будут на месте, модно приступать к закрытию кнопок! Используем для этого инструмент Patch (сетка). Для начала скройте все линии построения. [image: image134.png]0| Q
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 Кликаете на иконке Patch, далее на верхнем ребре кнопки и на точке, Right Click! В меню Patch option измените количество Spans UV  на 3 и включите (preserve edges - сохранить положение ребер). Enter! 
Проделать такие же операции для каждой кнопки.


[image: image135.png]




Об'единяем соответствующие поверхности [image: image136.png]o



 и любуемся! Правда есть одно но: превью показано уже с закругленными кнопками, а у Вас они будут ребристые!
[image: image137.png]




[image: image138.png]



	Так! Хотелось бы закруглить кнопочки! Самый простой способ это применить [image: image139.png]


 (Fillet edges), но он будет работать плохо, Вы можете проверить сами, но сохранитесь перед этим, результат Вас не порадует! Для того, чтобы сделать корректное скругление применяется способ, описанный ниже. Он трудоемок, но зато работает ВСЕГДА и хорошо! Рассмотрим его на примере одной кнопки, главное уловить суть!


	1.Строим [image: image140.png]


 (Solid->Pipe), где кривая, вокруг которой строится труба - верхнее ребро кнопки.Величина радиуса трубы определяет скругление, вибирите ее в пределах 0.1
2.Строим еще одну трубу, но теперь вокруг среднего ребра.
3.Теперь найдем линии пересечения поверхностей с трубами. Кликаем на Curve->From Objects->Intersection, и на обекты. Трубы скрыть!
4.Разделяем кнопку на поверхности [image: image141.png]


 (Explode), и отрезаем поверхности по линиям пересечения [image: image142.png]Sl



.
5.Удаляем ненужное. Н-да! Опрерация красивая, только не всегда все гладко! Обычно со сложными об'ектами (или просто Rhinoсправился не корректно) приходится повозиться. Дело в том, что в процессе Splita ребра могут раздробиться на части, что делает невозможным дальнейшее применение Surface->Blend. Если у Вас все нормально, то следующий пункт можно пропустить!
6.Для начала можно попробовать Analyze->Edge Tools->Merge Edge (повторять операцию до тех пор, пока ребро будет выделяться).  Если же ребро выделяется, а бленд Вам предлагается только на участке ребра, значит дело серьезнее и нужно применить Analyze->Edge Tools->Rebuild Edgse. Это работает всегда, правда Вы теряете в точности :(
7.Кликаем на [image: image143.png]


 (Surface->Blend), кликаем на одном ребра, потом на втором, Right Click, Rhino спросит правильность направления обхода и построит сглаженную поверхность.
8.Об"едините кнопку в одно целое [image: image144.png]o



.
Так! Повторите операции дл всех кнопок! :) 




Полезное лирическое отступление
тех, кто знает, просьба пропустить!
	  

Лучше если это будет другой файл, новый проект. Построойте кривую, состоящую из 3-х точек [image: image145.png]


. Включите Osnap - End и Ortho, отразите кривую [image: image146.png]


 (Mirror) и об'едените [image: image147.png]o



. 
Должно получиться что-то подобное:
Теперь рассмотрим возможные варианты об"еденения. Их всего три: G0, G1 и G2. Отличаются они расположением входных и выходных контрольных точек. Разница в следующем:
1. G0: Просто две кривые имеют одну общую точку.
(Continuity implies start & end points are common) --- Position
[image: image148.png]




2. G1:Три контрольные точки расположены на одной линии. Это дает множество плюсов: при об'единении кривых и дальнейшем вытягивании получится ОДНА поверхность без резких перегибов! Такого эффекта можно добиться, если применять Match Curves (Tangency) или вручную, путем команды SetPt. 
(Continuity implies tangents have common direction) --- Tangency
[image: image149.png]




3. G2:Пять контрольных точек расположены на одной прямой. Плюсы те же, но добавляется минус, если мало контрольных точек (а это как известно хорошо), то операция сильно меняет форму кривых.
(Continuity implies curvature is the same on both sides) --- Curvature
[image: image150.png]



Об"еденить кривые можно командой Curve->Edit Tools->Match (c cответствующим параметром), а проверить, каким из способов об'еденены кривые можно командой Analyze->Curve->Geometric Continuity. В командной строке будет указано Gх.





	Теперь займемся местом для микрофона.Сделайте копию корпуса. Строим круг, перестраиваем [image: image151.png]


 (Rebuild Curve) до 10 контрольных точек и Degree на 3, корректируем положение точек. Строим еще один контур, немного больше только что построенного (copy and Scale-2D). Вытягиваем контуры [image: image152.png]


 с параметром "с" и вырезаем больший контур из корпуса [image: image153.png]


, а с меньшим находим пересечение [image: image154.png]Y



.



1. [image: image155.png]



2. [image: image156.png]



3. [image: image157.png]



4. [image: image158.png]



Кликаем на [image: image159.png]


 и присваиваем цветовые координаты:
[image: image160.png]




Строим еще одну кривую:
[image: image161.png]



	Проецируем ее на верхнюю часть корпуса телефона: Curve->From Objects->Project [image: image162.png]


. Для этого кликаем на иконку, кликаем на линии, Right Click, кликаем на телефоне, Right Click! Ок! У нас даже две кривые, нижнюю можно смело удалить!


[image: image163.png]



	Выделим одну верхнюю поверхность. Solid->Extract Surface [image: image164.png]& Solidiocl:y

Extract Surace






	Отрежьте с помощью (по спроецированной линии) [image: image165.png]Sl



 поверхность сверху и удалите ее. Постройте точку, определяющую величину прогиба будующей поверхности. Постройте еще одну кривую, меньшую по размеру, чем проецируемая, она будет определять размер динмика.


1. [image: image166.png]


 2. [image: image167.png]



	Инструментом Surface->Patch, постройте сетку, по отрезанному контуру и точке. Поставьте галочку напротив Preserve Edges.


[image: image168.png]



	Спроецируйте втрорую (меньшую) кривую на построенный патч [image: image169.png]


, отрежьте командой [image: image170.png]Sl



 по спроецированному контуру и закройте дырку командой Surface->Patch, но уже без точки, просто плоскую сетку.
Теперь хочется скруглить переход между поверхностями. Напрашивается простой путь: [image: image171.png]o



 и скруглить по ребру [image: image172.png]


 с закруглением 0.2. Может это и устроит, но только не нас! Нам нужна красивая поверхность! Следовательно, работаем по уже известной схеме:
Строим Solid->Pipe [image: image173.png]


 c радиусом 0.2, находим линии пересечения [image: image174.png]2|  Curve From Object
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 и отрезаем лишнее [image: image175.png]Sl



.


1. [image: image176.png]



2. [image: image177.png]




[image: image178.png]



	Беда! Ребро раздробилось на две части. Применим Analyze->Edge Tools->Merge Edge и все будет нормально!


	Строим поверхность Surface->Blend [image: image179.png]Surface Tools
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 между двумя ребрами. 


[image: image180.png]



	Строим 3 кривых для прорезей под динамик.


[image: image181.png]



	Проецируем их на патч [image: image182.png]


, и отрезаем середину [image: image183.png]Sl



, удаляем.


[image: image184.png]



	Вытягиваем прорезаные контуры [image: image185.png]


 на величину 0.1 вниз. Об"единяем об'екты в один [image: image186.png]o



.


[image: image187.png]



	Ок! Настало время сделать нашему телефону антену, какую-нибудь похитрее!
Строим кривую Curve [image: image188.png]


, и закручиваем ее Surface->Revolve (прямая линия является вспомогательной, по ней проходит ось вращения)
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, Далее закрываем дыры сверху и внизу командой Solid->Cap Planar Holes (закрыть плоские дыры).


[image: image190.png]IR A





Об"единяем полученный об"ект с корпусом [image: image191.png]


 (Boolean Union).
[image: image192.png]




Скругляем ребра на величину 0.2 [image: image193.png]


 (Fillet Edge).
[image: image194.png]



	Строим наконечник для антенны, он может быть любой, автор предлагает такой вариант:
Постройте кривую [image: image195.png]


 и постройте методом вращения ее (Revolve) [image: image196.png]


 поверхность. Далее строим эллипсоид (примитив) и размещаем его на наконечнике.



[image: image197.png]



	Выделяем эллипсоид, кликаем [image: image198.png]#, M
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, Array along curve (массив по кривой), Right Click, кликаем по ребру в основании наконечника, Right Click, в выпавшем меню ставим число копий -4 и способ копирования -Roadlike.



[image: image199.png]x|
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OK, кликаем на виде Front и получаем желаемые 4 копии. Применяем [image: image200.png]


 (Boolean Union) для об'единения об'ектов в один.
[image: image201.png]




Ставим его на место и наслаждаемся превью :)
[image: image202.png]



	Так, продолжаем "наворачивать" наш телефончик! Нужна кнопка включения (А как без нее???). Строим кривую, отвечающую за вырезанную область и контур желаемой кнопки.



[image: image203.png]



	Вытягиваем контур [image: image204.png]


 (Extrude Straigh), с параметром "c".


[image: image205.png]



	Помещаем об'ект в нужное место и отрезаем по нему [image: image206.png]


 (Boolean Difference). Строим фаску описанным неоднократно способом (через [image: image207.png]


 с радиусом 0.2)


1. [image: image208.png]



2. [image: image209.png]




Последний штрих, проделываем несколько отверстий для микрофона (Должны же люди куда-то говорить!)
1. [image: image210.png]



2. [image: image211.png]



Все, телефончик готов! Поздравляю! Дальнейшие шаги для тех, кто хочет экспортировать телефон в 3DMax, для дальнейшего рендераю
Скрываем все линии построения и об'единяем все об'екты какие только можно.
[image: image212.png]
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Выделяем все [image: image214.png]Al



 (Select All), Ищем Tools->Polygon Mesh->From NURBS Objects, кликаем, выпадет меню:
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	Для экспорта в MAX, в меню File->Export Selected, выбираете расширение 3ds, вводите имя файла, выпадает такая же менюшка, где ползунком меняете количество экспортируемых поверхностей (чем больше, тем сглаженнее будет конечный реультат, но нужно знать меру), подбирается опытным путем!
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Рендер в 3ds MAX, после расскраски может выглядеть так:
[image: image217.jpg]



