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  FeatureCAM 2.5D Machining  

Introduction  

 This module will familiarize you with Autodesk FeatureCAM’s history, describes 
what FeatureCAM is and show how it is advantageous over other CAM systems. 

 Increased shop productivity is the primary goal of all FeatureCAM products.  
Traditional CAM systems are Operations Based and require you to program every 
operation, one at a time, to create your part. All the manufacturing details are left to 
the machinist. That means that you must specify the details for every Spot Drill, 
Drill, Ream and Roughing pass of your part.  

 With FeatureCAM you generate your part using Features such as a Tapped Hole, 

Boss, or a Turned Groove and the operations are automatically created. 
FeatureCAM also manages the details of the manufacturing process such as Tool 
selection, Speed and Feed Rates, and Toolpaths. To modify any element of the part 
program, just change a few settings on a feature and a whole new set of operations 

are generated to reflect your changes.  

 Ease of use is another guiding principal of FeatureCAM products. Our system was 
originally developed as a graphical Windows-based program. FeatureCAM programs 
are full of graphical feedback, Step-by-Step Wizards and tutorial-style animations 
that run directly in the program dialog boxes. Ease of use has always been a 
FeatureCAM advantage and we continue to study ways to make our system even 
easier to learn and use.  

 

 The image above shows a part that can be quickly machined in 
FeatureCAM 



              
 

                 Introduction to 2.5D Machining         

 

                                                                                                                                      

                                                                                                              
 Autodesk FeatureCAM 2017   

1.4                                                                                                                  © Copyright 2016 Autodesk, Inc. All rights reserved 

CAM Software Strategies 

There are three main different types of CAM software strategies for creating toolpaths in 
today’s modern CAM software.  These strategies are Operation based, Processed 
based and Feature Based.  Some of these strategies use Knowledge Based 

Machining (KBM).  KBM is when machining intelligence is built right into the CAM 
software. KBM is used at various levels and degrees in different CAM systems. 

Operations-based CAM systems require the user to go through multiple steps to 
machine each part. The user must select which type of operation to use, select the 
machining boundary and the type of toolpath, then manually select tools, feeds and 
speeds and multiple machining options such as step over distance and the incremental 
step in Z. These multiple steps must be repeated one at a time for every operation on a 
part, making it a time-consuming process that is prone to error. These systems offer little 
or no KBM. 

Process-based CAM systems attempt to reduce these steps by grouping operations in 
standard processes. KBM is used as the program remembers the used processes and 
repeats them for future operations. However, this method only works when a shop uses 
the same processes over and over for the same types of parts.  

When a process is applied to different types of parts, or parts made of different materials, 
the CNC programmer must still verify that the correct operations were used and that 
the correct tools, step over and speeds and feeds were selected because a static 
machining process does not automatically adapt to every part. 

 

Below is a chart showing a comparison of the three different CAM strategies: 

Feature Based CAM  
Operations-Based CAM Process-Based CAM 

1. Draw or Import Your Part 

2. Identify Features 

3. Click Simulation 

      You Are Done! 

      FeatureCAM Automatically: 

 Determines Rough and Finish 
Operations 

 Selects ALL Tools Sizes 

 Calculates Feeds & Speeds 

 Determines Stopover & Z 
Increments 

 Generates Toolpath 

 Creates NC Code 

 

1. Import or draw part. 

2. Select a rough operation. 

3. Select rough boundary. 

4. Select type of toolpath. 

5. Select roughing tool. 

6. Select feeds and speeds 

7. Select step over and Z steps. 

8. Select a finish operation. 

9. Select finish boundary 

10.Select type of toolpath 

11. Select a finishing tool. 

12. Select step over and Z steps. 

13. Select feeds and speeds. 

14. Click simulation. 

15. Create NC code 

1. Import or draw part. 

2. Identify features. 

3. Select machining processes. 

4. Click simulation. 

5. Create NC code. 

???Are You Done? No. 

You must analyse and verify:  

Does the process have the correct 
operations?  

Does the process use the correct size 
tools?  

Are the correct feeds and speeds 

used?  

Does the process have the correct 
step over and Z increments? 
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Feature-Based Cam Systems 

Feature-based CAM systems use a set of interrelated machinable features to describe 
a complete part. The beauty of features is that they not only describe the shape, but 
these also are made up of one or more associative operations that describe the preferred 

method for cutting that shape at the NC machine. 

A predefined set of machining rules and user preferences are applied to a part. KBM in 
these systems streamlines the manufacturing process by building the highest level of 
machining intelligence right into the CAM system. Machinable features contain 
information and rules describing how and where material removal should occur, cutting 
depths, whether to use climb cutting, whether to spot drill or Centre drill and preferred 
machining strategies for roughing and finishing. The CAM system evaluates the part 
geometry and part material, selects the most appropriate tools and operations, 
recommends machining strategies, calculates feeds and speeds, then automatically 

generates the NC code. 

 

Feature-Based Machining has many advantages such as:  

 Dramatically shorter part programming times. 

 Part revisions do not require reprogramming. 

 NC code is consistent and predictable regardless of the CNC programmer. 

 Tools are optimized and tool changes reduced. 

 Toolpath is automatically optimized for faster machining. 

FeatureCAM is a Feature Based programming system with advantages listed 
above. Additionally FeatureCAM is very easy to use. A programmer new to 

FeatureCAM or new to programming can quickly learn the product and create 
G-code with the appropriate tools, feeds and speeds. 

Below is a list of key points that make FeatureCAM very easy to use. 

 

 User Friendly Interface (Steps & Wizards). 

 Automatic Tool Selection (2D & 3D). 

 Automatic Feature RECOGNITION (AFR). 

 Interactive Feature RECOGNITION (IFR). 

 Standard Databases (Tools, Materials, Feeds & Speeds). 

 Customizable Post Processors. 

 Outstanding Technical Support. 
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Built in intelligence 

A major advantage of FeatureCAM is the users' ability to define their own set of 
machining preferences. FeatureCAM comes with predefined machining rules 
programmed into the CAM system which are based on a standard set of material 

properties and standard tool cribs. You can then customize these settings for specific 
materials that you use and the tooling that you actually have available in your shop. Once 
you have these defined, you simply select a material for your work piece and the tool crib 
you want to work with and FeatureCAM will then make selections of tooling for a feature 
automatically. If you change the tool crib or the material then FeatureCAM automatically 
updates all of the toolpaths in the part. This means that a part may be programmed for 
one machine with the tools available there and then shifted to another machine simply 
by changing the tool crib. Similarly if you wish to cut a test part in Aluminium and then 
cut the final part in Stainless Steel you program the part with Aluminium set as the 
material. Once you have cut the test piece you change the material to be Stainless Steel 
and FeatureCAM will update the toolpaths by changing feeds, speeds, depth of cut, step 
over etc. without any further intervention from the operator. 

By providing a set of standard machining rules already in place, it's easier for you to 
customize the software to reflect the machining preferences of your Machine shop. 

Setting up your own machining preferences and rules in FeatureCAM not only reduces 
the time it takes to generate programs, but it also streamlines production because the 
approach to machining every part is predictable and consistent. Machine operators can 
rely on the fact that each job will be machined in a predictable manner regardless of who 

did the programming. 
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Starting  FeatureCAM 

 

 Select the FeatureCAM icon  from your desktop and select New 
File and Milling Setup and Millimetre. Select Finish twice and then Ok 
to close the Stock menus. The stock menu will be covered later on in the 
training notes. 

 

 

Evaluation Options 

 

1 Click on the shortcut  that is on the Desktop. This will start 
FeatureCAM. 

2 When it has finished cancel the new Part document wizard that is on the 
screen. 
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3 Go up to the top left of the screen and go to the File menu. Then Select 
Evaluation Options. 
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 FeatureCAM has now been split into three levels. Standard, 
Premium and Ultimate. The next few images show the available 
options for all modules. 

  The image below show the available options in Standard 
FeatureCAM 

 

 It is here that you will see the activated products that you have 
purchased.  
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 The image below show the available options in Premium 
FeatureCAM. 

 

 It is here that you will see the activated products that you have 
purchased.  
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 The image below show the available options in Ultimate 
FeatureCAM. 

 

 It is here that you will see the activated products that you have 
purchased.  
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Desktop Subscription 

 This is what you get when you subscribe:- 

 Individuals, teams and enterprises have more choices than ever before 
Regardless of the size of your business - small, mid-size or enterprise.  

 Autodesk offers the flexibility to choose the subscription options that best 
fit your business needs. 

 Try out new tools without making a big up-front investment. 

 Better manage changing software and budget needs. 

Access options 

 When subscribing, select the option for access and use of your 
software: 

 Single-user access - best for when software is needed for one person 

 Multi-user access - ideal for situations in which you need more than one 
person to share software licences 

Flexible term lengths 

With monthly, quarterly, annual and multi-year options, you can get exactly 
the software you need for as long as you need it. 

Access to the latest software 

 When you subscribe, you have instant access to the latest product 

releases and enhancements. 

 Stay current on the latest software rather than waiting for major product 
releases 

 Update software straightaway or choose a time that is right for your entire 
team 

More about updates and releases 

 Software when you need it, where you need it 

Use your software in more places with access to both current and 

preceding versions. 

 Access preceding versions :- 

You will be able to download and use preceding releases of most Autodesk 
software. 
More about preceding version rights :- 

 Use your software at home - Access both current and preceding versions 
of your software on your home computer. 
More about home use rights 

 Use your software when travelling :-  

http://knowledge.autodesk.com/customer-service/account-management/software-downloads/current-version
http://knowledge.autodesk.com/customer-service/account-management/software-downloads/previous-versions
http://knowledge.autodesk.com/customer-service/account-management/software-downloads/home-use
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 Use your software and services globally when travelling outside of your 

home country. More about global travel rights 

Autodesk support 

 Let us help you to resolve issues quickly. You will have access to: 

 Senior Autodesk support specialists. 

 Moderated community support forums. 

 E-learning opportunities and exclusive training web casts New Part 
Document. 

Starting a new FeatureCAM part document. 

 Select File>New from the menu or select Ctrl + N keys. 

 

 Select your Units of Measure either Inch or Millimeter. Select the 
correct Module of your choice.  

 The Modules you have purchased will be visible.   

http://knowledge.autodesk.com/customer-service/account-management/software-downloads/global-use
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User Interface 

 FeatureCAM is a windows-based product and has been a windows based 
product since its inception unlike other CAM products. Many of the functions 
and keystroke shortcuts that you are familiar with in windows are available 

inside FeatureCAM. Examples are Ctrl+C to copy, Ctrl+V to paste, Ctrl+Z 
Undo last operation. etc. 

Screen Layout 

 

Menu Bar - Located at the top. Like many other Windows based 
software, packages FeatureCAM includes a series of drop down menus.  
These menus are unique to FeatureCAM and provide one or more functions 
used to facilitate the constructing, manufacturing, viewing and editing of 
your part program. 

 

Tool Bars - usually located at the top but, may be docked in other 
locations.  Can consist of one or more buttons and used to create objects in 
the Graphics Window such as the Geometry constructors for drawing the 
shape of your part. 

 

Geometry - Use geometry constructors to create 2D geometry. 
Snapping is a CAD concept that helps you position lines, points or shapes 

as you construct geometry for the part.  
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 Snap Icons: 

 

Entering points by coordinates is exact but not always convenient or 
feasible. Picking points with the mouse is not always precise enough.  

The bridge between the methods of point selection is snaps. From left to 
right, the buttons set the snap to: 

Results - Located on the right side.  It contains the Operation list.  

Whereas the Part View contains all of the features, the Operation List 
contains all of the machining history.  It also provides the details of each 
operation, including a tool list. The NC code is also here. All of the 
information residing in this area may be printed. 
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 ViewCube  

The ViewCube is a new feature in FeatureCAM, which enables you to change 
and identify the viewpoint of the Graphics window. By clicking the ViewCube’s 
corners, faces, edges, and icons, you can use it to directly manipulate the view 
in the Graphics window. In addition, when you re-orient the view using a cube 

option, toolbar button, or keyboard shortcut, the ViewCube automatically 
reflects the new viewpoint.  

 

The ViewCube is displayed in the upper-right corner of the Graphics window. 
Click and drag the cube to re-orient the view in any direction. Alternatively, 
click:  

 A face to show it as an orthogonal view.  

 An edge to show the adjacent faces.  

 A corner to show the three adjacent faces.  

In addition, when you move the cursor near the cube, the Home icon is 
displayed. Click the icon to show the Home view.  

Manipulating orthogonal views 

When you select a single-face view and move the cursor near the cube, control 
icons are displayed: 

Click: 

To show the view of an adjacent face.  

To rotate the view clockwise through 90 degrees.  

To rotate the view counter-clockwise through 90 degrees.  
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Configuring the ViewCube 

To control the behaviour and appearance of the ViewCube, right-click the cube 
and choose a menu option. Select: 

 Set current view as home and keep scale to save the current orientation 
and magnification of the model as the Home view.  

 Set current view as home and scale to fit to save the current orientation 
of the model as the Home view, and scale it to fit the Graphics window.  

 Options to display and change the settings of the ViewCube. The 
ViewCube tab of the Viewing Options dialog is displayed. 

Setting ViewCube options 

To modify the behaviour and appearance of the ViewCube, set these options on 
the ViewCube tab of the Viewing Options dialog: 

 Show the ViewCube — Select this check box to show the ViewCube in the 
Graphics window. Deselect the check box to hide it.  

 ViewCube size — Select an option from the list to choose the size of the 
ViewCube in the Graphics window. Alternatively, select Automatic to resize 
the cube when you resize the Graphics window.  

 Keep model upright — Select this check box to prevent the view from 

being inverted. If you click an edge, corner, or face that would leave the 
view upside down, the Graphics window switches to the selected view and 
then rotates to leave the view upright. 

 

 Graphics Window - Located in the Centre.  This is where most of the activity 

is taking place, creating Stock, Importing Drawings, Creating Solid and Surface models, 

constructing Geometry, Chaining with Curves, creating Features and Simulating the tool 

path in 3D or using the Centreline Simulation. 
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 Part View - Located behind the Steps menu. This area shows the 

Stock, Setup, Features, Curves, Surfaces and Solids when available. This 
provides access to their respective Properties. 

 

 In the Part View Tool Box this contains the names of the objects that are 
created on the screen. Objects that can be contained in this area are Stock, 
Setups, Curves, Surfaces, and Solids, which can include Stl triangulated 
models. 
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 Steps - Located on the left side. A systematic sequence to guide, especially 
the beginner, as to the order of which needs to be completed first, second, etc.  

Steps Menu 
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 The Steps toolbar is an outline for the flow of the program. The Steps 
are numbered sequentially in the order they should be executed and 
can be a guide for creating your part.   

 

1 Stock Wizard steps you through entering the shape and dimensions of the 
stock, the stock material, part program zero and the coordinate system for 
modeling.   

2 Geometry. This gives you the ability to create part shapes using a series of 
Geometry commands for example Points, Lines, Arcs, Clip, Fillet etc. These are 
used to define the overall shape of parts.  Many different geometry tools are 
available.  Geometry can also be imported from other CAD systems. 

3 Curves. Shapes that involve more than a single line or arc are described as 
curves.  

4 Surfaces.  This opens the Surface Wizard. 

5 Solids.  This opens the Solid Wizard. 

6 AFR. (Automatic Feature Recognition) This creates 2.5D geometry from 
Solid Models ready for machining. IFR is also available. 

7 Features.  This relates to common shop terms like Hole, Pocket, Slot or 
Thread Milling etc.  They are created from curves or dimensions.  These 

objects are created in 2.5D and are used to generate toolpaths.   

8 Toolpaths. Toolpaths are generated from collections of features. You can 
simulate them in FeatureCAM using toolpath Centerlines, 2D shaded or 3D 
solid shaded simulations. Plus full Machine Tool Simulation. 

9 NC Code. Machine-specific G-codes are generated from the toolpaths. 
Translators are provided for many different NC controls and include a program 
for creating new translators. 

Customize MFG 

This menu gives you the ability to change your configuration file, change 
or add a tool crib, create or alter feed and speeds tables or configure 
posts processors. 

 Some Steps are displayed or not displayed depending on which 
options you have purchased or have turned on. 
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Customize Manufacturing.  

 

 FeatureCAM automates the entire part programming process; you can 
customize all of the System Settings including Feed/Speed Tables, Tooling 
Databases or Feature settings.   

Screen Layout 
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 Browser - Located on the Left hand side Toolbox below Steps. Your 
computer must be connected to the Internet. The Browser provides a link to 
the Internet. Learn about the Browser by participating in the various sections 
with downloadable examples on the opening page, then click on the links and 

explore the contents. 

 

Geometry Bar - Located near the bottom.  This area is constantly used and 
is where the dimension boxes are used to locate the Geometry on your stock 
material in the Graphics Window. 

 

Status bar - Metric or Inch. This is Located at the very bottom of 
FeatureCAM.  It contains the plane you are working in (XY–XZ-YZ), the unit 
of measure (Inch or Metric), the layer you are working in, the Setup, Post 
Processor and the Tool Crib. Normally: - BasicMetric for Metric Tools. We 
also show the number of Cores Used. 

 

 Analyzing the above screenshot from the Status Bar. 

 XY is the current drawing plane being used. Inch or Millimetres are the 

type of units being used e.g. length 4.000”. 100mm. Layer1 is the current 
active Layer. UCS_Setup1 is the current UCS (User Coordinated 
System) being used. Setup1 is the current active setup in which features 
are created. 

Fanuc Robodrill. CNC is the current Post Processor being used. 

Fanuc Robodrill.MD is the current machine simulation file. 

Training_Crib_Metric is the current Tool Crib and we are using 4 cores on 
this computer 
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Clicking on the objects in the Part View enables different functions.  Left-click 
selects the object in the Graphics Window.  Right-click reveals menu of 
options available for the object. Clicking on a “+” will expand the view to reveal 
objects that are subordinate. 

In the Centre of the screen is the Graphics Window.  All drawings and toolpath 

simulations happen in this window. On the right is the Manufacturing Results 
Window. The automatically generated documentation and part programs are 
shown in this window. 

 At the bottom of the screen is the Assistance Bars for Geometry and 
Status. The Assistance Bar is where you are prompted when creating 
Geometry. 

 The screen shots shown above and on the next page show the Results 
Window. This shows you the order in which the machining is carried out. 
The Feature in which it is associated too, plus the Tools used in that 

sequence and the corresponding Feeds and Speeds. At the end you have 
the depth that the Tool will go to for example 25mm 

 There are three tabs available on the results window at the bottom.   
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  These are Op List, Details and NC Code.  
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 Operation List Tab: - This contains a table of different sequences in 
order of operation. 

 Details, gives you a breakdown of the sequence of operations. 

 Tool List. This gives a breakdown of the tools used. 

 NC Code. CNC code that will be output from the currently selected Post 
Processor. 

  Please note you have to run the Simulation before the NC Code is 
made available for output. 

How to create a part 

Drawing a part in FeatureCAM 

1 Start FeatureCAM. 

2 Draw geometry in FeatureCAM. 

3 Resize Stock to fit part. 

4 Create and move Setup to desired location. 

5 Create curves. 
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6 Create Features. 

7 Select Crib, Select Post, and Generate NC code. 

Importing a file into FeatureCAM 

1 Start FeatureCAM. 

2 Import 2D or 3D files into FeatureCAM. 

3 Use Wizard to align part and create Setup. 

4 For Solid models use Automatic Feature Recognition (AFR) or use Interactive 
Feature Recognition (IFR) to create features which creates the toolpaths. 

5 Select Crib, Select Post, and Generate NC code. 

 Another example of the steps to take. Suppose you have a 2D drawing 
on your desk and you would like to create a solid model and a CAM 
program. To do this, we would follow the steps sequentially:  

1 Specify type of stock and stock dimensions,  

2 Draw Geometry. 

3 Create Curves from Geometry.  

4 Create Surfaces.  

5 Create Solid from Curves.  (Extra Cost Option) 

6 Use AFR (Automatic Feature Recognition) or IFR (Interactive Feature 
Recognition). 

7 Create Features which creates the toolpaths. 

8 Select Crib, Select Post, and Generate NC code. 

 You can access the majority of FeatureCAM’s functions through 

these buttons. A summary of each of the Steps function is listed 
below. Tip: We recommend that if you are just starting out with the 
program or demonstrating it to others that you use the steps 
toolbox instead of toolbar buttons in other areas of the interface to 
keep the interface simple 

What is a Feature?  

 If we look at a Part like the one shown on the next page and consider how 
we would manufacture it we can see that it can be broken down into a series 
of Machining Operations. For example we would probably want to start 
by Facing the top of the part, then machine the Rectangular Pocket and 
Step Bore and then drill the Holes in the part and finish of with Thread 
milling the Step Bore. Each of these areas of the part Face, Rectangular 
Pocket, Hole, Step Bore, Thread Milling and so on, is a Feature of the 
part.  
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 FeatureCAM defines a part in terms of Features using common shop floor 

terminology for instance an area that looks like a Pocket can be machined 
using a Pocket Feature. When you define an area as a Pocket, 
FeatureCAM will then automatically decide what operations to use to 
machine that area. All you have to do is say “This is a Pocket” and 

FeatureCAM will select suitable Roughing and Finishing Operations, 
Tooling, Speeds and Feeds. You are then free to modify these default 
values to suit your particular situation. By automating the generation of 
operations the overall time taken to program a part can be drastically 
reduced. 

 There are four different ways to activate the New Features menu. 

 Select Features  from the Steps menu. 

 Select Ctrl + R New Feature. 

 Select Construct>New Feature. 

 Select New Feature from the Advanced Toolbar. 
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How is a Feature Created? 

 There are a number of different ways in which Features can be created in 
FeatureCAM, which method you choose will depend upon the data available 
to you. In broad terms the methods are: - From Dimensions and From 
Curve. 
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From Dimensions 

 If you are working from a print (Paper Drawing) then often the 
quickest way of creating features is to pull the Dimensions from the 

drawing and enter them directly into FeatureCAM. For example you 
can create a Rectangular Pocket by entering its Length, Width, 
Depth and Location. Additional attributes for the Feature can also 
be added such as a Draft Angle, Fillet Radius or Chamfer. 

 

 New Feature from dimension available. 

 Hole Feature 

 Rectangular Pocket Feature 

 Slot Feature 

 Step Bore feature 

 Thread Milling feature 

 Face feature 
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From Curve 

 If you have a print or a 2D drawing of a part in electronic format 
for example .dxf or .dwg you can create Curves for more irregularly 

shaped parts and then create the Feature from the Curve. Just 
select Closed Curve select the 2D Geometry and select the Create 
button. For open profiles use Pick Curve Pieces and create a Side 
feature. 

 Boss Feature 

 Chamfer Feature 

 Groove Feature 

 Pocket Feature 

 Round Feature 

 Side Feature (For open and closed profiles) 

 

Automatic Feature Recognition (AFR) 

 If you are working from a Solid Model then FeatureCAM has the capability 
to analyse the part and identify Features automatically. Basically you say, 
“Here is the part, go and program it”. FeatureCAM then looks for Pockets, 
Bosses, Sides, and Holes and so on and prepares the necessary 
Machining Operations, selects the Tools and Feeds & Speeds. This can 

work very well on simple parts but on more complex parts it may require 
some manual tweaking to get the optimal toolpaths. You could use (IFR) 
where you have more control over machining your part. 
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Interactive Feature Recognition (IFR) 

 This also works off a solid model in a similar manner to AFR. The 
difference is that you tell FeatureCAM what type of feature it is that 
you are looking for, for example “Look only for Side features” or 

“Look only for holes” with a diameter of less than 25mm. This takes 
a little longer than AFR but gives you greater control over how the 
features are created and often results in a shorter cycle time for 
machining. 
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 We also have different methods of extracting features from the model. 

 Select side surfaces - Select the surfaces that represent the sides of the feature, 
such as the walls of a pocket.  

 Use horizontal surface - Select a horizontal surface that represents the shape of 
the feature, such as the bottom of a pocket or the top of a boss.  

 Automatic recognition - automatically recognize features.  

 To create all recognition features at the same height, select Force same Z height 

and enter an Elevation to specify the height at which you want to create the 
features.  

 Chain feature curves - Pick curves from a solid to define the shape of the feature.  

 Enter a Wall Angle to angle the walls of the feature.  

 Enter an Elevation to create the feature at a different height to the curves you 
select.  

 Use horizontal section - Create features from a Z-slice through a solid.  
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Saving your work 

 Question? What is the difference between Save and Save as? 

 Answer: When you are working on a document, it is a good idea to save 
your work every couple of minutes. In the File menu of the program, you 
will typically find the options "Save" and "Save As" 

 Choosing "Save" simply saves your work by updating the last saved version 
of the file to match the current version you see on your screen. 
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 Choosing "Save As" brings up a prompt to save your work as a file with a 

different name. For example, you might choose to save a document called 
"FeatureCAM_opp1". This way, you can save you file at different stages 
and keep multiple versions on your hard drive. 

 Choosing "Save" and then "Save As" is also a good way to make a backup 
of your file. Just be sure to rename the file something new when you choose 
"Save As" or you will overwrite the current saved version, just like choosing 
the "Save" command would do. 

Save Options 

 In the File menu you have save options. 

 

 See Save Options below. Adjust your computer to the same as the 
options shown. 

 

 Create backup copy: - Select this option to save a number of previous 
versions of your part as you work. Enter the Number of copies to keep 
and set the Backup location. When you save a file, the previous version(s) 
are saved to disk using the name, but prefixed with Backup of. The latest 

version of the file is always saved using the name of your FeatureCAM part.  

 Save preview picture in file: - Select this option to store an image of the 
part in the file. This image is displayed in the Open dialog. 
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 Save computed toolpath: - For certain parts, generating toolpaths can be 

time-consuming and you may want to save them for the next time you open 
a part. The setting of save computed toolpath controls the default behaviour 
for saving toolpaths. Select from Always save, never save, or ask me to 
be prompted each time you save a part. The toolpath is saved as an .fmp 

file. 

 This is different than saving the NC text file that the NC machine 
reads. Instead you are saving the FeatureCAM internal toolpath 
representation.  

 If you upgrade to a newer version of FeatureCAM, the toolpath is 
disregarded and recomputed.  

 Click the OK button to save your settings and close the dialog.  

 Cancel: - Click the Cancel button to close the dialog without saving any 
changes.  

 Help: - Click the Help button to open this Help topic. 

Send Part Files dialog 

 To display the Send Part Files dialog, select File > Send from the 
menu. 

 

Select the files you want to send from:  

 Part document: - The current .fm file.  

 Milling post: - The current milling .cnc file.  

 Turning post: - The current turning .cnc file.  

 Wire EDM post: - The current Wire EDM .cnc file.  



              
 

                 Introduction to 2.5D Machining         

 

                                                                                                                                      

                                                                                                              
 Autodesk FeatureCAM 2017   

1.36                                                                                                                 © Copyright 2016 Autodesk, Inc. All rights reserved 

 User interface settings: - The .ini file containing your user interface 

preferences.  

 Machine design files (.md): - the current .md file.  

 Crash and performance logs: - Select this option to create a separate 

.zip file of your system's crash and performance logs.  

 Select how you want to send the files:  

 As individual files: - The individual files are attached to a new email.  

 As a zip file: - The files are zipped and the .zip file is attached to a new 
email.  

 Save to desktop: - The files are zipped and the .zip file is saved to your 
desktop.  

Size confirmation  

 If you are sending .zip files, a Size Confirmation warning dialog is 
displayed:  

 The average email server limits attachments to 10 MB.  

 The total size of the attachment(s) is: N (where N is the size of your 
attachment. 

 Would you like to continue sending?  

 Click Send to attach the files to an email.  

 Click Don't Send to keep the files on your desktop.  

 Click Cancel to discard the files.  

FeatureCAM file types 

You can save several different types of files for your part.  

 .op is the Manufacturing Operation Sheet and is the same information 
shown on the Details tab when you select Operation List.  

 .tl is the Manufacturing Tool Detail Sheet and is the same information 

shown on the Details tab when you select Tool List.  

 .txt is a text file containing the NC code for the particular part file.  

 .tdb is a FeatureCAM tooling database that contains just the tools you 
used to create the part.  

 .fdb is a FeatureCAM material database that contains the feed and speed 
tables used for the part.  

 .cdb is a FeatureCAM machine configuration database that contains the 
settings for default attributes. Part Documentation 

The Part Documentation dialog enables you to add comments to the printed 
documentation and set a permanent preview picture for the part.  

 To display the Part Documentation dialog, select File > Part 
Documentation from the menu.  

 The Part Documentation dialog contains two tabs: Documentation and 
Preview Picture  
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Documentation tab 

 On the Documentation tab of the Part Documentation dialog, optionally 
enter a Title, Author, Company, Part/Drawing No., Revision, Note 1, 
Note 2, and Comments.  

 To print these values along with the documentation, select Comments in 
the Printing Options dialog.  

 
 

 If you use the custom setup sheet add-in, these values are copied 
to the Setup Sheet Options dialog.  

Preview Picture tab  

On the Preview Picture tab of the Part Documentation (see page 95) 
dialog, you can set a permanent preview image for the part. This image is 
displayed in the preview pane in the File > Open dialog when you select a 
file.  

This image is normally updated each time you save the part. If you want to 
store a permanent image with the part:  

1 Create the view of the part you want to store.  

2 Click Update preview picture  
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 The current view in the graphics window is displayed as the 
Current preview picture, for example: 

 

3 Click OK to save the preview picture or Cancel to close the dialog without 
saving the preview picture.  

Saving your settings 

 FeatureCAM uses two .ini files to store your settings:  

 Ezfm_ui.ini contains toolbars, dialog locations, graphics settings, colours, 
and other user settings.  

 Ezfm_mfg.ini contains manufacturing defaults and .cfg settings.  

The ezfm_mfg.ini file contains default values for both inch and metric 
attributes. For example, there is an entry for zrapid in inches and also an entry 
for zrapid_mm in mm. In general, the name for the metric attributes is the 
same as the inch name, with a suffix of _mm.  

 There are three items from the Options menu affect the 
communication with the ezfm_ui.ini and ezfm_mfg.ini files:  

 Options > Save Settings Now: - Writes the current settings to the files.  

 Options > Reload Settings: - Reads the settings contained in the files into 

the program.  

 Options > Save on Exit: - Saves the current settings when you exit the 

program. If this option is not selected, the settings for your current session 

are not saved to the files when you exit. 
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Import/Export  

 You can import and export various file types into and from FeatureCAM.  

 The settings for import and export are in the Import/Export Options  

 To open this dialog select File > Import/Export Options from the menu. 

Import/Export Options 

 The Import/Export Options dialog contains settings for importing and 
exporting.  

 To display the Import/Export Options dialog select File > 

Import/Export Options from the menu.  

 The dialog has three tabs:  

 General  

 Solid Import  

 Digitized Data  

General tab 

 The General tab controls how FeatureCAM Imports or Exports files. It 
contains the following options:  
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 Always replace object on import: - Select this option to overwrite 

objects of the same name when you import. Deselected prompts for every 
replacement. You can’t have two objects with the same name. 

 Smooth EZ-MILL curves: - Select this option to improve EZ-MILL curves 

on import because FeatureCAM has a higher resolution curve format.  

 Keep IGES import log file: - Select this option to keep a log of the 
import process for later review or troubleshooting.  

 IGES log file name: - Enter the path and filename for saving a record of 

the import process.  

 Import IGES entity of type:  

 Logically dependent: - can exist by itself but is also referenced by 
another entity (case of groups or grouping situation).  

 Physically dependent: - generally, you should deselect this option to 
indicate you do not want physically dependent entities to be imported. But 
if you are having trouble with your IGES file and it is not importing 
properly, try selecting this option and re-importing. Entities in an IGES file 

are marked to be either physically dependent or not. Those that are 
marked to be physically dependent are entities that are used in the 
construction of other entities. For example, a trimming loop is physically 
dependent upon the trimmed surface that uses it. The trimming loop is not 
important all by itself, but is instead a building block of something else. 
The trimmed surface is in turn marked physically dependent to indicate 
that it is a building block of a parent entity, a solid 
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 By selecting physically dependent, you cause FeatureCAM to show 

everything in the IGES file - not just the top-level entities that are usually 
shown, but also all of the lower-level building blocks. This is generally not 
what you want. Generally you want only the top-level entity, for example 
the solid.  

 Both physically and logically dependent: - meets both logically and 
physically dependent criteria (is referenced by at least two other entities: - 

the parent for the logical link cannot be the parent for the physical as well).  

 Centre stock automatically: - Select this option to automatically size and 

position the stock so that it covers the imported data.  

 Number of decimal places in IGES export: - determines how finely data 
is exported to the IGES format. 

Solid import tab 

The Solid Import tab contains the following options: 

 

 Heal Catia solids: - Select this option to try to repair the faces or surfaces 

contained in the CATIA .mod file. This option can be time-consuming 
because it attempts to:  

 Retrim the surfaces/faces against each other.  

 Force edges of surfaces to actually lie on the surface.  

 Simplify surfaces like converting a general surface into a cylinder.  

 Import hidden Catia V5 solids: - Select this option to import all parts 
contained in the CATIA file even if those parts are hidden.  



              
 

                 Introduction to 2.5D Machining         

 

                                                                                                                                      

                                                                                                              
 Autodesk FeatureCAM 2017   

1.42                                                                                                                 © Copyright 2016 Autodesk, Inc. All rights reserved 

 Import file as solids: - Select this option to import files as solid models. 

If this option is deselected, the models are imported as surface models. We 
recommend that you import models as solids. If this option is selected and 
the solid fails to import properly, you are asked if you would like to attempt 
to heal the solid to try and fix the import problem.  

 Import work planes: - When selected, planar surfaces in solids are 
imported. When deselected planar surfaces in solids are ignored.  

 Stitch IGES surfaces into solids/sheets: - Select this option to try to 
create one or more solids or sheets from an IGES file. If an IGES file contains 

more than one solid or sheet, this is the most efficient way to create the 
multiple objects from the file. 

Importing Files 

Use the File > Import menu option to load a CAD model from file.  

To import a CAD model from a file:  

1 Open a new or existing part file. You must have a part open to import 

geometry.  

2  If you want to set or change the import options, select File > 
Import/Export Options.  

3 Select File > Import from the menu. The Import dialog is displayed.  

4 Select the file you want to import, and click Open.  

 A message asks if you want to review the log file: click Yes to 
display the results, or click No to continue. The Import Results 

wizard is displayed.  

5 Follow the instruction in the wizard to complete the process.  

 

 Please note that some of the file types are extra cost options 

 Unless you have specifically ordered the FeatureCAM .step or Stp 
file import, you might get an error to say that this option needs to 

be licenced.  

 If this is the case then use the Import using exchange where the 
.step file import option is free. 
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 Wherever possible avoid importing .iges files. 

 Please import solid models, where possible. The best option is 
Parasolid which has a file extension of x_t or x_b which is a binary 

file which is compressed. Another file format is .SLDPRT which is a 
SolidWorks file. 

Mouse buttons 

 Each of the three mouse buttons performs a different dynamic operation in 
FeatureCAM.  

 

 

Left mouse button Picking and selecting. 

 This button is used for Selecting Items of the pull down menus, options 
within forms, and entities in the graphics area. 

 

Middle mouse button Dynamics. 

 In these options, you can set the behaviours to be specific viewing modes 

such as Trackball, Rotate, Pan, Zoom, Pan and Zoom, and so on, or 
choose the Current Viewing Mode option that allows the middle-mouse 
button (along with key combinations) to perform the viewing mode that is 
currently set in the toolbar. 
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 The most commonly used mouse feature is to hold the Centre wheel down 

and moving the mouse, this will rotate your part. Hold the shift key down 
at the same time and you can Pan anywhere on the screen. Hold the shift 
key down and where ever the mouse is it will zoom to that point by using 
the Wheel. This is excellent for looking closely at your component. 

 Zooming in and out: - Hold down the Shift key and mouse button 2. 
Move the mouse up and down to zoom in and out. 

 Pan around the model: -Click once with mouse button 2 to position in the 
Centre of the screen. Click and hold to zoom and then move the mouse in 

the required direction. 

 Zoom Box – Hold down mouse buttons 1 and then button 2, drag a box 
around the area to zoom. Release both buttons at the same time. Rotate 
mode: Hold down the Ctrl key and mouse button 2. Move the mouse up 

and down to zoom in and out. 

Right mouse button Special Menus & FeatureCAM Options. 

 

 When this button is pressed it brings up a local menu relating to whatever 
the Mouse Pointer is over, such as a named item in the FeatureCAM Part 
View or a physical entity in the graphics area. If nothing specific is selected 
the View menu appears.  
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Viewing Options 

 

 For those users who are already familiar with other Autodesk ® products 
DON’T PANIC!  Just do the following. 

 View changes the way you interact with the view of the part. Selecting 
any of the options from the View menu puts you in view mode. 

 Dynamic Viewing Options. 

 Dynamic Viewing Options tab, you have two choices to reset the settings 
to: 

Reset to FeatureCAM Settings  

This button resets all the options in the dialog to FeatureCAM defaults, 
which are: 

 Dynamic Viewing Choice upon FeatureCAM Start-Up - Pan and Zoom  

 Middle-mouse button behaviour - Current Viewing Mode  

 Middle-mouse button with Shift - Pan and Zoom  

 Middle-mouse button with Ctrl - Rotate  

 Middle-mouse button with Ctrl+Shift – Zoom 

Reset to PowerMILL Settings  

 This button resets all the options in the dialog to PowerMILL defaults, 
which are: 

Dynamic Viewing Choice upon FeatureCAM Start-Up - Trackball  

 Middle-mouse button behaviour - Trackball  

 Middle-mouse button with Shift - Pan  

 Middle-mouse button with Ctrl - PowerMILL Pan & Zoom  
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 Middle-mouse button with Ctrl+Shift - Box Zoom 

 This menu controls the default viewing mode when FeatureCAM first opens. 
For example, if you select Trackball, the next time FeatureCAM starts up, 
the viewing mode is Trackball. 

Viewing Options General 

In the General Viewing Options we now have the ability to change the size of 
the Snapping point. By default this size is normally 4 pixels. In order to create 
larger points, change this to 8 pixels. 

 

 

 An example of this is shown below 
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Viewing Options Machine 

 When viewing machine axis, by default the view is shown vertical: If you 
have a Horizontal machine or a Mill/Turn machine (Vertical turret lathe) use 
this option to change the view. 

 Milling — Select the type of milling machine from Vertical and Horizontal, 
to improve viewing during machine simulation and tool previews. 

 Turning — Select the type of turning machine from Slant bed lathe and 
Vertical turret lathe, to improve viewing during machine simulation and 

tool previews. 

 Swiss turn, main spindle vertical y axis – This setting is used when 
using the FeatureCAM Swiss module. 
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Display options 

 For the best Display Options for your computer set the NVidia ® 
Control Panel options to the following. 

 

 All of the viewing options are available via Right mouse button.  
Click in the Main Graphics Area 

Principle views 

  Changes to a view of the part from the front with no other 
surfaces visible. 

  Changes to a view of the part from the back with no other 
surfaces visible. 

  Changes to a view of the part from the left side with no other 
surfaces visible. 

  Changes to a view of the part from the Right side with no 
other surfaces visible. 

  Changes to a view of the part from the top only. Useful for 

drawing geometry, but harder to see the wireframe model of the part. 

  Changes the view to the bottom of the part. No sides of the 
part are visible from this perspective. 
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 Right Click in the graphics area to show this menu. 

 All the viewing modes are available, plus an option called Mode from 
Last Session. This option keeps track of the viewing mode last set 
before FeatureCAM was closed, and uses that viewing mode the next 
time FeatureCAM starts up. For example, if the option is set to Mode 
from Last Session, and you had set the viewing mode to rotate before 

you closed FeatureCAM, Rotate is the viewing mode that is set in the 
toolbar the next time you open FeatureCAM. 

 Isometric - changes the view to a three quarter view of the part 
showing the top and two sides with the current UCS near the bottom of 
the viewing area. 

 Perspective - If selected, the view is a perspective view. If 
deselected, the view is an orthographic view. 

 As on setup - If selected, the view is relative to the current setup. If 
deselected, the view is relative to the world coordinate system. 

 As on UCS - changes your view to that of the current UCS. 

 As on world - changes your view to that of the current UCS. 

Keyboard shortcuts 

 You can use the keyboard to navigate around the menus. To do this, 
press and hold the Alt key, and then press the letters on your keyboard 
that correspond to the letters underlined on the Menu bar and in the 

menu options. For example, to rotate your part, press and hold the Alt 
key, press V for View menu, press V for Viewing Modes and press R for 
Rotate. 
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Key sequence Action 

Alt+click-and-drag on any toolbar button Move button around in toolbar. 

Alt+1 (2,3,4) User View 1 (2,3,4) 

Alt+Enter Properties 

Alt+F1 Centreline simulation. 

Alt+F2 Play/pause simulation. 

Alt+F3 Single-step simulation. 

Alt+L Last view. 

Alt+R Refresh 

Alt+Shift+V Save view. 

Ctrl+click a column of any list box that does 

sorting 

Activates the second level of sorting. 

Ctrl+click a viewing mode button Stay in that viewing mode. 

Ctrl+click the 3D Simulation button. 

Release key and click the Play button. 

Run 3D simulation in hidden line mode and 

do continuous looping. 

Ctrl+click Fast Forward to End  Stops the simulation when it encounters the 

next rapid (in addition to the next 

operation). 

Ctrl+click the Machine Simulation 

button. Release key and click the Play 

button. 

Run machine simulation in hidden line mode 

and do continuous looping. 

Ctrl+A Select all. 

Ctrl+C Copy 

Ctrl+E Centre selected. 

Ctrl+F Find (text in a text window). The cursor 

must be in a text window. 

Ctrl+H Replace (text in a text window). The cursor 

must be in a text window. 

Ctrl+L Centre all. 

Ctrl+N New file 

Ctrl+O Open file 

Ctrl+P Print 

Ctrl+R Opens the New Feature wizard. 

Ctrl+S Save file 

Ctrl+V Paste 

Ctrl+X Cut 

Ctrl+Y Redo 

Ctrl+Z Undo 

Ctrl+click the Pick Curve button Causes the warp status for that dialog to 

toggle. 

Ctrl+click the Pick Curve button while a 

Key sequence 

Toggles between simulation of the selection 

feature and the entire setup. 

Ctrl+click the Play button Run simulation in hidden line mode. 

Hold Ctrl while toolpath is being computed Temporarily turns off Toolpath Computation 

Minimization. Toolpaths will be recomputed 

for all features even if that feature did not 

change. 
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Ctrl+Alt+click-and-drag on any toolbar 

button 

Duplicate and move button around in 

toolbar. 

Ctrl+Shift+click the 3D Simulation 

button. Release keys and click the Play 

button. 

Continuous loop simulation for 3D 

simulation. 

Ctrl+Shift+click the Machine Simulation 

button. Release keys and click the Play 

button. 

Continuous loop simulation for machine 

simulation. 

Ctrl+Shift+A Shade selected. 

Ctrl+Shift+C Unshade all. 

Ctrl+Shift+N Unshade selected. 

Ctrl+Shift+P Toggles perspective. 

Delete Delete the selected object 

Double-click a simulation button 

 

Activate that simulation without clicking the 

play button.  

Esc Stop current simulation. 

F1 Context-sensitive help. 

Middle-click-and-drag in the graphics 

window 

Performs viewing based on the current 

viewing mode. 

The mouse wheel-click-and-drag also 

performs this function. 

Mouse scroll wheel Zoom 

Shift+click an edge when filleting Selects all edges of the face and adds them 

to the list. 

Shift+click the NC Code tab Show ACL instead of NC code. 

Shift+click while clipping when Multiple 

Region is On 

Removes the entire picked region instead of 

to the nearest intersection. 

Shift+right-click in graphics window Dynamic viewing using current view mode. 

Shift+click the Show button in the SCL 

dialog 

Brings up a dialog that shows the attributes 

of the model selected in SCL dialog. 

Commonly used Ctrl Keys 

 New Document - Ctrl + N 

 New Feature Menu or Ctrl + R  

 Isometric View or Ctrl + 1 

 Top View or Ctrl + 5 

 Refresh - Alt + R 
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User interface: Keyboard shortcuts 

 There is a new tab in the Customize Toolbars dialog, Keyboard 
Shortcuts: 

 

 This tab lets you assign your own shortcut keys to the FeatureCAM 
menu commands. To set a new shortcut key: 

 Select a category from the Categories list.  

 Select a command from the Commands list.  

 If the command already has a shortcut, it is listed under Current 
keys. 

 To assign a new key, select the Press new shortcut key field and press 
the keys that you want to use as the shortcut.  

 Press the keys on the keyboard, for example, press and hold down the Alt 
key and press the N key; do not type ALT + N.  

 A warning displays if the shortcut you entered is already assigned to a 
command. 

 Click the Assign button to save the new shortcut.  

 If you click Assign after receiving a warning that the shortcut is already 
assigned to a command, the shortcut is removed from the existing 
command and assigned to the new command. 
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 Remove — Click this button to remove the shortcut assigned to the 

selected command. 

 Reset All — Click this button to reset all shortcuts to the FeatureCAM 
defaults. 

Blanking model entities 

 Use the Blank Selected (Ctrl + J) option to temporarily hide all visible 
components. 

 (Ctrl K) Hide Selected components 

 To re-display all of the components. Right-click in the graphics area and 
select Unblank (Ctrl L). The blanked model components are displayed. 
Please note this option will only work if you have set this up as explained in 

the previous chapter. 

Show menu 

 Show  functions help control what is displayed. This is useful as you place 
and model intricate features in a complex part. 

 You access the Show functions by selecting View > Show from the menu 
or using the Show Menu button on the Advanced toolbar: 

 

 Show All — Use this menu option to Show everything in the part model. 

 Show All Geometry — Use this menu option to Show all geometry 
(points, lines, arcs, and circles). 

 Show All Dimensions — Use this menu option to Show all dimension 
information added with the Dimensions Tool. 

 Show All Curves — Use this menu option to Show all Curves. 

 Show All Surfaces — Use this menu option to Show all surfaces (available 
only in FeatureCAM 3D). 
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 Show All Features — Use this menu option to Show all features. 

 Show All Solids — Use this menu option to Show all solids 

 Show All Vertical Surfaces — Use this menu option to Show the vertical 
surfaces in the model. This is useful for identifying surfaces that are part of 

2.5D features like holes or pockets contained in a surface or solid model. 

 Show Stock — Use this menu option to Show the stock outline. 

 Show Current UCS — Use this menu option to Show the current UCS icon. 

 Show Current Setup — Use this menu option to Show only the features 
and drawing elements that are in the current Setup. 

 Show Selected — Use this menu option to Show only the selected 
elements 

Hide Menu 

 Hide controls what is displayed at any given time. This is useful as you 
place and model intricate features in a complex part. Besides the display 
factors, you can’t snap, select or build curves from hidden entities. The Hide 
functions are not exclusive. You can click different buttons sequentially, 
hiding different entities until only the ones you want are still in view. 

 You access the Hide functions by selecting View > Hide from the menu or 
using the Hide Menu button on the Advanced toolbar: 

 

 Hide All — Use this menu option to hide all geometry, curves, Features. The 
stock and axis icon remain visible. A common procedure is to Hide All, then 
Show only one type of entity, for example features. 

 Hide All Geometry — Use this menu option to hide all geometry. Other 
entities remain visible. 

 Hide All Dimensions — Use this menu option to hide all dimension 
information added with the FeatureCAM Dimension tools. 

 Hide All Curves — Use this menu option to hide all curves. Other entities 
remain visible. 
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 Hide All Surfaces — Use this menu option to hide all surfaces in the part 

model. Only available in the 3D version. 

 Hide All Features — Use this menu option to hide all features. 

 Hide All Points — Use this menu option to hide all points. 

 Hide All Non-Vertical Surfaces — Use this menu option to hide all surfaces 
that are not vertical relative to the current setup. This is helpful if you want 
to isolate the surfaces that are part of 2.5D features in a surface or solid 
model. 

 Hide All Solids — Use this menu option to hide all of the solid models. 

 Hide Stock — Use this menu option to hide the stock outline. All other 
entities remain visible. 

 Hide Current UCS — Use this menu option to hide the current user 
coordinate system. 

 Hide Current Setup — Use this menu option to hide the axis of the 
current Setup. All other entities remain visible.  

 Hide Selected — Use this menu option to hide all selected entities. Non 
selected entities are still visible. 

 Hide Unselected — Use this menu option to hide all entities other than 
the selected ones. 

Highlighting objects from Part View 

You can now highlight objects in the graphics window by moving the cursor over 
the object's name in the Part View. This enables you to find features quickly 

and improves the work-flow in complex documents. 

For example, move the cursor over an object in the Part View: 
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Setting file location options 

 It is a good idea to set the file location for where you will save your 
files. Please select Options/File Options/Existing Files. 

 

 

1  Select Browse. Then select the following location. 
C:\Training_Data\FeatureCAM Course Data 2017. 

2 Select Apply and Ok to close the form. When we save or import files 
FeatureCAM will take us to this location. 

3 Please save all files in Coursework. 

4 Tool Crib = BasicMetric or Training_Crib_Metric 

5 Post processor used = Fanuc_Robodrill.cnc 
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Stock dimensions 

1 Open FeatureCAM by double clicking the FeatureCAM shortcut  

2 Select New File. Milling Setup. Select Finish. 
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3 Enter the dimensions of the stock. Stock Size = 100mm x 100mm x 26mm 

thick into the dimensions menu. Select Finish and the following menu will 
appear. Enter 1mm for Z to allow material above the datum. Select Finish. 

 

 

 Notice the 1mm in the Z Menu. This adds 1mm above the Z Datum for 
machining off later when creating a Face Feature. 
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Stock Types available (Information Only) 

 

Block 

 

Round 

    

N-sided 
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User-defined 

 Inside a FeatureCAM milling document there are several different Stock 
types.  The stock can be defined as a block material, a round material or 
N-sided and user defined material. We have already gone through this 
procedure with our second exercise.dxf file and resized the material around 
the part. 

 Selecting the Round Radio button you have an option to create Round 
Stock as shown below. 

 Please note: - You can define this stock as a tube by typing in a value for 

the ID as well as the OD. 

 

This option is ideal for work held in a 3 or 4 jaw chuck on a 3 or 4 Axis 
vertical machining Centre. 
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N-Sided 

 Select the N-Sided Radio button. When this button is pressed the stock 
can be defined along a specific axis with a multiple number of sides. The 

dimensions shown are just an example only. 

 

User Defined – Stock Solid 
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Stock Curve 

 

Stock – Material 
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4 From the Stock wizard you can select the Material, Specific Cutting Forces, 

Hardness and Hardness Units.  You can also access the existing Feed and 
Speed tables for the material or create a new Material. 

 

 On this page of the Stock wizard you can select the Material, Specific 
Cutting Forces, Hardness and Hardness Units.  You can also access 
the existing Feed and Speed tables for the material or create a new 
Material 

 As shown by selecting Next the multi-axis positioning options will 
appear. 
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 In the next example we will only be using 3 axis. Select No to Multi-
axis positioning to machine this part. 

First class exercise (From Dimensions) 

 

Additional information 

 Product Thickness 25mm 

 Pocket depth 12mm 

 Chamfer for Hole and Pocket features  0.5mm to 1mm 

 There are four different ways to activate the New Feature menu. 

 Select Features  from the Steps menu. 

 Select Ctrl + R New Feature. 

 Select Construct>New Feature. 

 Select New Feature from the Advanced Toolbar. 
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5 The following menu will appear. Select Hole and then Next. 

 

 Enter the following information Chamfer 0.5mm Depth 25mm, 
Diameter 12mm. Select Next. 

 

6 We now need to position the hole at X75mm and Y75mm, then Select 
Finish and then OK to close the form. 



              
 

                 Introduction to 2.5D Machining         

 

                                                                                                                                      

                                                                                                              
 Autodesk FeatureCAM 2017   

1.66                                                                                                                 © Copyright 2016 Autodesk, Inc. All rights reserved 

 

 Hole positioned in stock. 
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7 Select Ctrl + R or any of the 3 other ways to activate the New Feature Menu 

and Select Rectangular Pocket from Dimensions, then select Next. 
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8 Enter Length 50mm, Width 50mm, corner radius 6mm, Chamfer 1mm, 

Depth 12mm, select Next. Enter X12mm Y12mm for location. 
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 Rectangular Pocket Properties 

 

 Rectangle from dimension in Position. 

 

 We have excess material on the top face. We need to create a 
Facing Operation. 
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9 Select Ctrl+R New Feature or from Steps select  

10 Select Face. Remember to save the file as Mill Exercise1.fm 

 

11 Select Finish. FeatureCAM will automatically select an appropriate Facemill 
and machine the top face to Zero. And re-order the Operations list, so that the 
Face operation jumps to the beginning of the operation list, because Face has 
a higher Base Priority. 
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 That is it the job is finished; FeatureCAM has automatically created 
the operations. 

 Select 3D Simulation and then press Play  on the Simulation 
Toolbar. 

 Examine the diagram below of the Simulation Toolbar; Read the 
purpose of each button 

 

 Eject:  Erases the Simulation from the Graphics window.  

 Show Centreline: A line drawn at the Centre of the tip of the tool is 
displayed. 

 2D Simulation: A two-dimensional Simulation showing the regions cut 
by each        operation is displayed. The view is changed to the top view 
automatically. 

 3D Simulation: A 3D solid Simulation is displayed where the tool is 
animated through all of its moves.  

Eject 

Centreline 

2D 



              
 

                 Introduction to 2.5D Machining         

 

                                                                                                                                      

                                                                                                              
 Autodesk FeatureCAM 2017   

1.72                                                                                                                 © Copyright 2016 Autodesk, Inc. All rights reserved 

 3D Rapid Cut: In this mode a 3D Simulation is performed but the tool is 
not animated. Only the final result is displayed. For most parts, the 
simulation takes only a few seconds to complete. 

  This type of Simulation is only available in FeatureMILL3D. 

 Machine Simulation: A 3D solid Simulation is displayed where the tool 
is animated through all of its moves along with the machine tool 

 Stop: Cancels a Simulation.  

 Play: Starts the selected Simulation (Centreline, 2D, 3D or Rapid Cut), or 
restarts a paused Simulation. 

 Fast Forward to end: Skips to the end of the animation 

 Single step: Moves the Simulation ahead one tool move. The keyboard 

accelerator for this button is ALT+F3 or ALT+Right Arrow 

 Play to Next Operation: continues to simulate until the next operation. 
This button is actually a fly-out menu. By clicking on the triangle to the 
right of the button the following additional options are revealed. 

 

Next Rapid simulates until the next rapid tool move.  

Next Tool Change simulates until the next tool change.  

Next ZLevel will simulate the next Z of a Z level toolpath. For other 
toolpaths it will play the entire next operation 

 Clear Toolpath: Erases any Centreline toolpaths on the screen.  

 Region of interest limits the portion of the part that is simulated.  

 Show tool load indicates whether or not to display a graph of the tool 

load when the next 3D Simulation is performed. 

 

 Sim Speed: To adjust the speed of a Centreline, 2D or 3D Simulation, 

use the Slider on the right-hand side of the controls.  
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 Slide to the right to speed up, and move to the left to slow down the 
Simulation. The Slider on the Simulation Toolbar also affects the 
display for Rapid Cut Simulation. If the Slider is all the way to the 
right, only the final Simulation result is displayed. Position the slider 

bar further to the left to see slower Rapid results.  

 You should have a result similar to that shown on the next page. 

 

 

 A Centreline display of the toolpath is shown above where the lines 
displayed represent the centre of the bottom of the tools movement.  
Green lines represent rapid movement where blue lines show feed 
moves.   

 Press the Eject button  to close the simulation. 

 The image shown is an isometric View of the Toolpath 
Simulation with different colours representing each operation. 

 Select the 3D Simulation button  and press Play  to show the 
image shown on the previous page. 

 Code can only be output after the Simulation has finished. If the 
simulation fails. NC code will not be output. 
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 Tip: The image shown on the previous page shows Tool Colours 
switched on. Colours can be configured to suit your own preferences 
for all movements. Select Options>Simulation>Simulation 
Options. 
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 Tool colours switched off 

 

 In Options>Simulation>2D/3D Shaded from the top menu, 
Select Pause on Gouge, this will not only show the holder for the 
milling tool, but reveal any tool striking the stock in rapid traverse, 
or if the holder touches any part of the stock. These gouges will show 
as pink in colour, the simulation will stop, and a pop up menu will 
appear telling you of a possible gouge. 
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 In the Manufacturing results window on the right hand side of the 
screen click the Operation List tab. 

 

 

 Click on the details Tab.  
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12 Click on the NC code tab.  

13 Post Selected is Fanuc_Robodrill.cnc set to Metric. Tool change position 
X0, Y0, Z100. 

14 Tool Crib is Training_Crib_Metric. 

15 NC code is generated so it may be output and read on the machine tool. The 
NC Code shown has been generated for the Face operation and Hole Feature 
only. 

 This is an example of the first two tools showing the code that has 
been generated using the Fanuc_Robodrill.cnc Post Processor. 

% 

O0001 

( FINISH  FACE1 ) 

N25 G0 G40 G49 G80 G90 

N30 T1 M6 

N35 G54 X117.0 Y9.8 

N40 M03 S10000 

N45 G43 H1 Z26.0 M8 

N50 Z4.0 

N55 G1 Z0. F5000.0 

N60 X-17.0  

N65 Y35.6  

N70 X117.0  

N75 Y61.4  

N80 X-17.0  

N85 Y87.2  

N90 X117.0  
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N95 G0 Z26.0 

N100 M5 

N105 M9 

N110 G91 G28 Z0. 

N115 G90 G49 

(   HOLE1 ) 

N125 G0 G40 G49 G80 G90 

N130 T2 M6 

N135 G54 X75.0 Y75.0 

N140 M03 S1843 

N145 G43 H2 Z26.0 M8 

N150 G98 G81 R3.0 Z-12.236 F363.66 

N155 G80 

N170 M5 

N175 M9 

N170 G91 G28 Z0. 

N175 G90 G49 

(   HOLE1 ) 

N185 G0 G40 G49 G80 G90 

N190 T3 M6 

N195 G54 X75.0 Y75.0 

N200 M03 S2021 

N205 G43 H3 Z26.0 M8 

N210 G98 G83 R3.0 Z-28.605 Q3.0 F363.78 

N215 G80 

N220 M5 

N225 M9 

N230 G91 G28 Z0. 

N235 G90 G49 

N240 M30 

% 
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16 Select File from the main menu and select Save NC. Click the radio button 

Save to other Directory and choose a directory that you’re Instructor has 
chosen to save your files to. Select the following options. 
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 Now that the NC code is saved it can be downloaded to the 
machine and the part with the simple pocket and hole can be 
machined. 

Tool Mapping 

You can open the Tool Mapping dialog in one of these ways:  

 Select Manufacturing > Tool Mapping from the menu.  

 Click NC Code  in the Steps panel, then click Re-map the tools to new 
tool slots in the NC Code dialog.  

 

 If the order of the tools is changed you will have to re-run the simulation 

and re-output the code to the same folder. 

 The Tool Mapping dialog is where you change the tool slot assigned to 
the selected tool. You can change the Cutter comp. offset register for 
any tool here too.  

 The dialog has a table at the top. Each row of the table represents a tool. 
Select a tool to edit its values in the fields below the table.  

 Double-click on a tool name, or click the + to the left of the tool name to 

see the list of operations that use that tool.  

 Click the Add tool slots  button at the top left of the table to open 
the Number of tool slots dialog. It enables you to increase the number of 
tool slots listed; you cannot reduce this number.  



              
 

                 Introduction to 2.5D Machining         

 

                                                                                                                                      

                                                                                                              
 Autodesk FeatureCAM 2017   

1.82                                                                                                                 © Copyright 2016 Autodesk, Inc. All rights reserved 

From Curve second exercise (Class exercise) 

1 Open FeatureCAM by double clicking the FeatureCAM shortcut icon.  

2 Select New file then Next. Then select Milling Setup then select Millimetres. 
Select Finish. You will be presented with a Dimensions menu just select Cancel 
for now and Hide the Stock on the screen. Select the boundary of the Stock 
then Right click and select Hide Stock. The stock will then disappear from 
view. 

3 Go to File and select Import and at the bottom of the form select files of 
type as .dxf (*.dxf). 

 You will find the file in. C: /Training_Data/FeatureCAM Course 

Data 2017/Milling Files to import. 

 

4 Select Second Exercise.dxf Select Open.  

 

 Use the default option for file import. This uses the native 

Autodesk’s RealDWG file import. 

5 You will be presented with a form which shows Import Results. 

6 This will default to: - Use the Wizard to establish the initial setup 
location and Stock size. 
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7 Select Next twice. 

 The part is already aligned in the Z axis. 

 To reduce the amount of material needed to machine this part we 
need to orientate the part so the right hand long edge is aligned to 
the X axis. 

8 Select the Pick two points to define X direction icon. Then select the edge 
in two points as shown on the next page. 
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 Notice the X axis is aligned parallel to the right hand edge. 

9 Select Next. Use Stock type = Block. Select Next. 

 You will be presented with a form that shows Stock Dimensions 
where we have two options. 

 Option 1 - Enter specific stock dimensions or Option 2 - 
Compute stock size from the size of the part. Other stock 
options are available but we will discuss this later on. Enter the 
following values. 

 

 Fill in the dimensions shown above. Do not click Next or Finish? 

10 Please select Compute Stock from the size of the part. 
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 Metric example Option 2 - Compute stock size from the size of the 

part Metric By entering known values for example 5mm into the extra 
stock size fields the Stock dimensions Wizard will automatically Centre the 
part. Remember to add a value in the Thickness field. The thickness will 
start at 33mm with 1mm extra stock size. The finished thickness of the 

part will finish at 32mm after facing off the 1mm. 

 

11 Select Next.  

Sectional View  

 

Setups 

 By selecting Next you will be given an option to Pick Initial Setup XYZ 
Location. Select LL Lower Left, in X enter 5 in Y enter 5 and Z enter -1. 
This will move the datum by these values; we will then have Stock to 
machine off when we run a facing operation. 
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12 Select Finish which will close the Wizard. 

 

 With Guidance from your instructor we will now create Curves from 
the geometry and then Face the top of the block. 

 Select TOP view or Ctrl+5. Select Ctrl+Q to Centre the part on the 
screen. 

13 Select Closed Curve from the Geometry Menu  
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14 Single click the Geometry and select Create, FeatureCAM will create a 

closed curve around the profile selected. Do this for all profiles. Leave the 
holes these will be selected from the Edit menu using Select Circles. 

 

15 Please select Hide all Geometry from the View Menu as shown. 

 

 

 Sectional view of part 
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16 Select Ctrl + R or select Steps and Features. The New Feature dialog will 
appear. 

17 Select Face. 

 

18 Select Finish and OK to close the menu. 

 We are now going to use the outer curve to limit the face machining 
that will now just machine to the outer boundary. 

19 Double click Face in PartView. 

20 From the Dimensions Tab Select Boundaries. 

21 Select Use a Curve as a stock boundary. Use the Cursor Icon  to select 
the curve. 

22 Select OK and Apply. From the Strategy tab select Connect Step overs 
with Arc. 

23 Run a Centreline Simulation to see the changes. 



 
 
Introduction to 2.5D Machining 

                           

 

      
Autodesk FeatureCAM 2017    

© Copyright 2016 Autodesk, Inc. All rights reserved           1.89 

 

24 Select Ctrl + R. The New Feature dialog will appear. 

25 Select Pocket from Curve. 

 

26 Select Next. 

27 Using the Pick Curve or Geometry icon  select the 4 larger pockets. 
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28 Select Next. 

29 In this instance the Offset from Curve Z Location is zero. 

30 Select Next. You will now see the Dimensions tab. Enter the following 
values. 

 

31 Select Finish. 
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32 Under the Pocket Properties tab select Rough and you will see Mult. 

Rough diameter(s) enter 20, 12 select Set and Apply.  

33 This will then rough out using a 20mm tool and then semi finish the corners 
with the 12mm cutter. Set the Finish diameter to 8mm. 

 

Create another Pocket from curve operation the same as before for the 
four smaller pockets. The only difference is you will have to set Offset 
from Curve Z Location to -27 and the Feature thickness to 5.1 

34 Under the Pocket Properties tab select Rough and you will see Mult. 
Rough diameter(s) enter 20, 12 select Set and Apply. Set the Finish 
diameter to 8mm. 
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 Press ESC to cancel the simulation. 

35 Select View from the main menu. Then select Show all Geometry. 

36 Select Edit from the main menu. Then select, Select Circles. 

 Click on the blue Hyperlink Radius. 

37 Then select one of the 6mm diameter smaller circles. Then select OK. 

 All of the smaller 6mm diameter circles will highlight. 

38 Select Ctrl+R New Feature. 
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39 FeatureCAM will default to Hole and automatically select. Make a pattern 

from this Feature. 

40 Select Next. Then select Counter Bore from the drop down menu. 

 

41 Enter 10mm for the bore diameter and 33mm for depth. 

42 Select Finish and Ok. 

43 Run the 3D Simulation. 

 

44 Press ESC to cancel the simulation. 

45 Hide all Geometry. 

 Create a Boss Feature to machine all around the outside of the 

part. 

46 Select Ctrl+R New Feature. Select Boss from Curve. 
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47 Select Next. 

48 Select the outer Curve and then select Next. Then set the Offset from 
curve Z Location to zero. 

49 Select Next and set the following dimensions in the Dimensions tab. 

 

50 Select Finish. 

 Change the following settings. 
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51 Under the Strategy tab select Wind Fan. Enter the following values. 

 

52 To change the start point select the Plunge tab. Select Finish under 
Operations. Pick the position as shown for the start point. 
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 Run a 3D Simulation of the finished part. 

53 Output the code as described in the previous chapter. 
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Tool Mapping 

You can open the Tool Mapping dialog in one of these ways:  

 Select Manufacturing > Tool Mapping from the menu.  

 Click NC Code  in the Steps panel, then click Re-map the tools to new 
tool slots in the NC Code dialog.  
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Custom Setup Sheet Add-In 

 You can create custom setup sheets for milling, turning, and turn/mill parts 
using the SetupSheet.dll add-in.  

 The add-in extracts information from the Part Documentation dialog and 
enables you to take images for each Setup.  

 You can use setup sheets to give information to the machine operator about 
the manufacturing, tooling, and toolpaths of a part.  

 To load and run the add-in:  

1 Select Options > Add-Ins from the menu. The Macro Add-ins dialog is 
displayed.  
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2 Click the  button and browse to the SetupSheet.dll file. If you 
installed FeatureCAM in the default location, the file is at C:\Program 
Files\Autodesk\FeatureCAM\Add ins\Setup Sheet\SetupSheet.dll.  

3 In the Macro Add-ins dialog, in the Add-In Files list, ensure that the check box 

to the left of the SetupSheet.dll file address is selected.  

4 Click OK. The Utilities toolbar is displayed, containing the Setup Sheet button  

 

5 Click the Setup Sheet button to run the add-in. The Setup Sheet Options dialog 
is displayed: 
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 Remember to set the Part Document information in File>Part 
Documentation. 

 The Title, Author, Note 1, Note 2, Company, Part/Drawing No., 
Revision, and Comments values are copied from the Documentation tab 
of the Part Documentation dialog and you can edit them there.  

 You can use this dialog to capture an image for each Setup in the current 
document, as well as an image to represent the whole document.  

6 To capture an image for a Setup, select the Setup name in the Setups list and 
click the Capture Setup Image button to capture the current contents of the 
graphics window.  

 First run a simulation only for the Setup you want to capture by 
deselecting other Setups in the Part View; then adjust the view to 
show a good orientation of the Setup, and open the Setup Sheet 
Options dialog to capture the image in the graphics window.  

 You must use a template to create the setup sheets. Click the Browse 
Template button to find and set the template you want to use. There 
is a template, SetupSheetTemplate.html, in the Add ins\Setup Sheet 
folder. 

7 To create the setup sheets, click the Create Setup Sheets button. The part is 
simulated to generate toolpaths and the setup sheet is displayed in your web 
browser. You can save the HTML file from your browser.  
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8 To open the setup sheet in the FeatureCAM Browser, select File > Open from 

the menu and browse to the setup sheet HTML file. 
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Procedure for machining a 2D part in from geometry 

1 Create a new Part document in FeatureCAM. 

2 Select the correct module that you will be working with. 

3 Cancel the material stock. 

4 Import a file, typical 2D formats to import are .dxf or .dwg or draw your 
Geometry using FeatureCAM geometry construction tools.   

5 If importing a file, use the Wizard to establish the Part orientation and Setup1 

position and Stock Material.  

6 If you have drawn the geometry establish your Material around the part using 
the Resize button in the Stock1 Properties. Adding depth to the required 
level. Add extra material to the depth if you are holding the part in a vice. 

Change the position of the Setup1 if required. 

7 Create the Curves from your Geometry using Closed Curve. Remember to 
select Pick pieces for open profiles. 

8 Create Features from the Curves by creating a New Feature (Ctrl+R). 

9 Add tooling if necessary to your Crib to machine your part. 

10 Re-order your process if required in the Operation list. Selecting the 
Automatic ordering options for example select Cut Higher operations 

first. 

11 Run the 3D Simulation to prove out your machining at each stage of the 
process. 

12 Select your Post and Crib and Material type. This can be done at any stage. 

If changed you will have to re-run the 3D Simulation again. 

13 Once you are happy with your machining process save your part document. 
The file extension will be an .fm (FeatureCAM) file. 

14 Select File>Save NC. Save the file to a known directory so you can upload 
this to your CNC machine. 

 You have now completed your part in FeatureCAM. 
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Geometry Creation Techniques  

Introduction 

This module will provide an understanding of how different Snapping Modes 
work and how Geometry is created within FeatureCAM. By the end of the 
module the user will be able to construct Geometry and understand how each 
Snapping Mode functions. 

Snapping 

 Snapping Mode commands can be accessed in two different areas of 
the user interface. Select the Options menu then Snapping Modes. 

 

 

 

 Snapping Modes may also be accessed through the Snap Mode 

Toolbar (to show the Snapping Toolbar. Go to the View menu then 
Toolbars, then check the Snap Mode checkbox and select OK) (See 
image on the next page). 
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 Looking at each icon from left to right we will give a short summary 
of each item’s function: 

 

 

The Snap to Grid Points  button displays a grid and enables snapping 
to the grid. Selecting snapping grids from the options menu controls the spacing 
of the grid.  Grid snaps to a point on a coordinate system that is laid out on the 
stock. The grid size can be modified from the Options menu. 

The Snap to Point  button snaps to a point object. 
  



              
 

                   
                       Geometry Creation Techniques      

 

                                                                                                                                      

                                                                                                              
 Autodesk FeatureCAM 2017   

2.4                                                                                                                  © Copyright 2016 Autodesk, Inc. All rights reserved 

The Snap to Endpoint  Snaps to the ends of lines or arcs. Endpoint 
also applies to the corners of the stock and verticals of a Solid. 

 

Snap to Midpoint  snaps to the middle points of lines and arcs. 

 

Snap to Section  snaps equal intervals of a finite line.  The number 
of sections is controlled by the Sections parameter of the Snapping Grids 
dialog box.  

  

 Snap to Intersection  snaps to the intersection of lines, arcs and 
circles.   

 

Snap to Centre  snaps to arc and circle centres. This setting also 
controls the display of circle and arc centre points.   

 

Snap to Quadrant  snaps to the four points on a circle 
corresponding to 0°, 90°, 180° and 270°.   

 

Snap to object  snaps to a point on another object. This includes lines 
of surfaces and is convenient for snapping points to locations on a surface or 

Solid model.   

 

Snap to Tangent  snaps the point so that the object you are creating 

will be tangent to the object you snapped to.   

 

Snap to Toolpath  snaps to toolpath lines. 

 

Snap to Cylinder  snaps to Cylinder centres, top and bottom points. 
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The Snap Discrimination  dialog button displays the Snap 
Discrimination dialog box whenever there is an ambiguous pick. This dialog box 
will list the possible points to snap to and ask you to pick the one you want. 

Drawing conventions when using Autodesk products. 

 

 When you start using Autodesk products and start to construct 
Geometry, the illustration above clearly shows you the directions of the 
cardinal drawing angles and positive and negative directions. This should 

help when creating the exercises in this chapter.  

User Interface 

Geometry constructor commands can be accessed in three different areas of 
the user interface.   

Commands can be accessed by clicking the Geometry  icon in 

Steps:  
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 This can also be accessed through the Construct Menu. 

 

 Or may be accessed by the Geometry Toolbar  

 

 To show the geometry toolbar click on View>Toolbars, then check 
the Geometry checkbox and press OK 
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                       Geometry Creation Techniques      

 

                                                                                                                                      

                                                                                                              
 Autodesk FeatureCAM 2017   

2.8                                                                                                                  © Copyright 2016 Autodesk, Inc. All rights reserved 

 

 

 The geometry toolbar uses flyout menus.  The last item previously 
selected is displayed as an icon in the tool bar. 

 

 Click on the triangle  to reveal the flyout menu. 

 These flyout menus are used throughout FeatureCAM and are 
useful for easy access to many program functions. 

 The following Menus show the Geometry creation options available. 
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Line 

 

 2 Pts: - Line created with two endpoints. 

 Connected: - Multiple lines created in succession.  Endpoint of one line 
becomes start point of next line. 

 Horizontal: - Infinite horizontal line created through a point. 

 Vertical: - Infinite vertical line created through a point. 

 Pt. Angle: - Infinite line created through a point at an angle specified in 
degrees. 

 Offset: - Line, Circle or Arc created offset from another.  New lines have 
the same length as original 

 

 Click on the Select  icon at the top of FeatureCAM on the Standard 
Toolbar to cancel the line drawing. Use this button at any time to exit 
selection mode. Or press the Esc key at any time. 

Circle 

 

 Centre, Radius:-  Creates a circle by clicking on the centre and specifying 
the radius or dragging the mouse to a radius 

 Centre, Edge:- Creates a circle by clicking once on the centre then again 
on the edge 

 Diameter:- Creates a circle with two points with the diameter being the 
distance between the two points 

 Tangent Two:- Circle created by snapping the circle's edge tangent to two 
objects 

 2 Pts, Radius:- Creates a circle by specifying two points and a radius 

 3 Pts:- Creates a circle from three points 
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Fillet 

 

  Corner Fillet: - Creates a Fillet in a corner originally defined by an 
intersection of lines or arcs. 

 Two point Fillet: - Creates a Fillet in a corner originally defined by an 
intersection of lines or arcs. 

 Three points: - Defines a fillet by selecting three points, similar to the three 
point circle. 

 Chamfer: - Creates a Chamfer in a corner originally defined by an 
intersection of lines or arcs. 

Arc 

 

  Three points: - Constructs an arc through a start point, edge point, and a 
finish point. 

 Two points, radius: - Constructs an arc through two points with a specific 
radius. 

 Centre, Beg, End: - Constructs an arc from a centre point and given 
beginning and end points. 

 Centre, Rad, Beg, End: - This selection constructs an arc with a specific 
centre and radius with the starting and ending points determined by angles. 

Curve 

 

 Curves are paths in 2D or 3D space. You can create them in FeatureCAM 
or Import them from a CAD system. Curves can be open, or closed. Open 
curves have end points that do not meet. You can use open curves in the 
following Features Side, Groove, Rounds and Chamfer Features. 
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Dimension 

 

 Horizontal: - creates dimension information based on the horizontal axis of 
the part. 

 Vertical: - creates dimension information based on the vertical axis of the 
part. 

 Linear: - creates dimension information based on the absolute distance 
between two points regardless of the angle of the dimensioned space. 

 Radius: - creates dimension information for the radius of the selected 

object. 

Diameter: - creates dimension information for the diameter of the 
selected object. 

Angle: - creates dimension information for the angle between two 
selected lines. 

Text label: - creates a text label entered in the dialogue bar 

Annotation: - places explanatory text, entered in the dialogue with an 

arrow of what is being explained 

Curvature: - samples the surface and computes the curvature in two 
directions to describe how the surface behaves at the point shown in the 
dialog bar. Unlike the other dimensioning tools, Curvature is a real-time 

rubber-banding effect where you traverse the surface to find the point with 
the smallest curvature radius. Knowing the smallest radius tells you the 
smallest tool to use to manufacture the surface. 

Interrogation: - This dialog helps you extract numbers from the graphics 
window using snap modes and pick filters. You can then cut and paste these 
values into other dialogs. 

Curvature 

 

 Curvature samples the surface/Solid and computes the Curvature in two 
directions to describe how the surface behaves at the point shown in the 
dialog bar. Unlike the other dimensioning tools, Curvature is a real-time 

rubber-banding effect where you traverse the surface to find the point with 
the smallest Curvature radius. Knowing the smallest radius tells you the 
smallest tool to use to manufacture the surface. 

 Select Construct > Dimension > Curvature from the menu.  
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 Move the cursor over the surface, particularly in the tight constrained 
areas of the surface or joints.  

 Note the smallest value shown for Curvature. That is the smallest tool 
end radius you need to accurately machine the surface.  

 Set up rough and finish passes for the surface feature based on this 
knowledge, and make sure the tool is available for production. 

 

Surface 

 

 To build and use 3D surfaces in FeatureCAM, you need to understand how 
FeatureCAM defines a surface. A surface is defined by irregular sets of 
points and a description of how the surface behaves at each point on the 
surface which determines the smoothness of the surface. The set of points 
determines the shape, of the surface. 

Solid 

 



 
 
Geometry Creation Techniques 

                           

 

      
Autodesk FeatureCAM 2017    

© Copyright 2016 Autodesk, Inc. All rights reserved           2.13 

 The FeatureCAM support of solids lets you work with imported CAD designs 

from solid modelling systems and create 3D solid models using 
FeatureCAM’s Solid Modelling Tools. Solids are a convenient 
representation for 3D parts because they group collections of surfaces into 
3D volumes. By working with a solid instead of all of the individual surfaces, 

you are provided with a more convenient representation and more powerful 
modelling tools. 

 After you have created your Solid Model you can then use AFR (Automatic 
Feature Recognition) or IFR (Interactive Feature Recognition) to create 
your toolpaths. 

Edit Geometry 

 

 Clip: - Clip removes a region of a line, arc, circle or curve. A region is defined 

as a portion of an object between two intersection points. 

 Trim/Extend: - Changes the length of a line or an arc. Trim/extend can be 
used   to lengthen or shorten lines and arcs as follows:  

 Infinite: - Changes the length of a line or an arc. 

Geometry Creation Exercise 1 (Class Exercise) 

Introduction 

 The exercise that follows will review most of the Snapping Modes 
on the Snapping Toolbar in no particular order, when complete it 
will provide a basic overview of the most commonly used snapping 
mode functions. 

 

1 Please start a New Part document in FeatureCAM. 

2 Select the FeatureCAM  Icon on your desktop or Taskbar. 

3 Select New File then Milling Setup and select Millimeters. 

 Typ means Typical for all dimensions that are the same unless 
otherwise stated. If in doubt ask 

 Do not worry about the stock size at this stage as we will resize this 
later. We are concentrating on Geometry creation techniques only. 

4 Hide the Stock, Right Click on the Stock boundary and select Hide Stock.  

 
  

mk:@MSITStore:C:/Program%20Files/Delcam/FeatureCAM/Program/Help/EZFM.chm::/76233.htm
mk:@MSITStore:C:/Program%20Files/Delcam/FeatureCAM/Program/Help/EZFM.chm::/105232.htm
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 We will create a Rectangle first. 

 

5  Go to Construct>Curve>Other Methods>Rectangle. 

 

 Enter the following values Width 100mm (c)  Height 125mm (D) 

 Remember to select Create as arcs and Lines. See image on the 
next page. 
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 This exercise will go through the most commonly used snapping 
modes to create the part. 

 We will now create four Circles by snapping a single circle to each 
corner of the Rectangle. 

6 Select Construct then Circle, Circle, Radius  or select the same Icon 
from the Geometry Toolbar. Enter the following values 16mm. 

 Metric 

 Please note that all Snapping mode functions can be switched on and off 
at any time. All of the snapping modes can be switched on together or 
used individually. 

7 We will use Snap to End Point  as the most efficient snap mode in this 
instance. Remember to snap to the four corners of the rectangle. Your 
image should look like the one on the next page. 
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8 We will now draw two lines across the diagonally opposite corners. 

9 Select Line from 2 Points  from the Geometry Toolbar. Use Snap to 

End Point  as the most efficient snap mode in this instance. 

 

 

10 Using  Offset we will offset the outer lines only 10mm towards the centre. 
Then whilst the Offset command is still active. Offset the diagonal lines 5mm 
either side of the lines as shown below. 
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11 Delete the 2 centre diagonal lines. To do this just select the lines and then  

12 Select Delete on your Keyboard. Then  Clip the middle diamond 

shape. This will allow you to Fillet the four pockets. The Fillet command will 
automatically Clip the profile. An image up to this stage is shown below. 
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13 We will now Fillet all pocket corners 6mm Select the Corner Fillet  Icon 
from the Geometry Toolbar and enter the values above. Present the cursor to 
each corner of the pockets until all corners are filleted. Clip the inner 4 corner 
radius and the four corners. Press Esc to finish the command. See image up to 

this stage below.  

 

14 Fillet the corners 6mm shown above.  Draw 4 circles in the corners of the part. 
Circle radius is 6mm. Snap to the circle centres. The finished image is shown 
below 

 

 If in doubt ask. 
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Dimensioning the part (Class Exercise) 

 We will change the Setup when we come to machine this later. 

 Next Select Dimension from the Construct menu, or the dimensioning 
flyout menu from the geometry toolbar. We will have a go at the different 
commands for example, Horizontal Distance, Vertical Distance etc. 

 The following text and images are a summary of what each item’s function 
is on the Dimensioning flyout menu. 

 Typ means Typical for all dimensions that are the same unless otherwise 
stated. If in doubt ask. 

 

Horizontal  

Creates dimension information based on the horizontal axis of the part. 

Vertical  

Creates dimension information based on the vertical axis of the part. 

Linear  

Creates dimension information based on the absolute distance between  

Two points regardless of the angle of the dimensioned space. 

Radius 

Creates dimension information for the radius of the selected object. 

Diameter  

Creates dimension information for the diameter of the selected object. 

Angle  

Creates dimension information for the angle between two selected lines. 

Text label  

Creates a text label entered in the dialogue bar. 

Annotation  

Places explanatory text, entered in the dialogue with an arrow of what is 

Being explained.  
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Curvature 

samples the surface and computes the curvature in two directions to 

Describe how the surface behaves at the point shown in the dialog bar. 

Unlike the other dimensioning tools, Curvature is a real-time rubber- 

banding effect where you traverse the surface to find the point with the 

Smallest curvature radius. Knowing the smallest radius tells you the 

Smallest tool to use to manufacture the surface. 

 

Interrogation  

This dialog helps you extract numbers from the graphics window using snap 

 Modes and pick filters. You can then cut and paste these values into other  

dialogs 

 When creating dimensions. Do not worry if you make a mistake. 

Select   undo or select Ctrl + Z then have another try. 

 Remember to save the part.  We will machine this later on in the 
course. 

 Save the file as “Construction Ex1” in the Course Work Folder. 

 C:\Training_Data\FeatureCAM Course Data 2017\Course 
work 

 

 If you want to machine this part later on the thickness=12mm. 
Pockets are 6mm deep and all holes are through. 
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Construction Exercise 2 (Class Exercise) 

 

 Please note that there is more than one way to create this example. 
For example you may decide to draw one quarter of the geometry 
and then reflect this about X0, Y0, this is the way we will create this 
example. 

 We will be creating this as a class exercise to give you the necessary 
skills to take back to your work place. The following pages give a step 
by step guide to creating this component. 

 

1 Open a new Milling document and choose Millimeters. 

2 Select Cancel to accept default Stock settings and then 

3 Hide Stock. In PartView select Stock by using the left Mouse button. Then 
Right click Stock again and then choose Hide Stock.  

 

4 All that should be on the screen is Setup1. We will define the Stock when we 
have finished the geometry creation. 
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Drawing Stages 

5 Construct a Rectangle using the Construct>Curve>Other methods 
>Rectangle Menu. 

 

6 Use Centre, Width and Height with the Centre Point of X0,Y0,Z0. Rectangle.                        
Width 170mm Height 120mm Radius 20mm. 

 Please Note: - Remember to select create as arcs and Lines. 

 

7 We will now construct a Circle using Centre, Radius   

 

8 Type in the following Radius value 20mm at X0, Y0, Z0. Select Enter. 
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 Remember to select Esc to cancel the construction mode. 

 

9 We will now create a Vertical and Horizontal line at X0, Y0, Z0. 

From the Line menu select  Vertical Line select Enter. 

From the Line menu select  Horizontal Line select Enter. This will  

Automatically default to X0, Y0, Z0. 

10 We will now Clip  the unwanted geometry so it looks like the 
image on the next page. 
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11 We will now offset the outer right hand corner shape by 10mm inwards and the 

centre Horizontal and Vertical Lines by 5mm. 

12 Select Offset  enter each value and pick the correct side of the line to 

offset the geometry as shown below. 

 

 We now have a problem, because the two lines do not intersect the 
centre radius we cannot Clip the geometry. So we will have to extend 
the geometry. 
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13 Select  Trim/Extend from the menu. 

14 Zoom into the centre area. To do this position the cursor in the centre and use 
the scroll button on the mouse. 

15 Select the line you want to extend, this will highlight green. Hold the left mouse 

button down and then move the pointer so it goes past the radius as shown in 
two places. 

 

16 We will now Clip  the unwanted geometry so it looks like the 
image below. 
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17 We will now Fillet the four corners by 5mm. Select  Corner Fillet. 
The image on the next page shows the fillets in the drawing. 

 

 

18 Next we will Construct a Circle using Centre, Radius select the Centre, Radius  

19 Icon   Type in the following values 10mm and snap to the inner top Right  

20 corner, using Snap to Centre  

 

 

21 Create 2 circles with radius 5mm using Tangent two,  

 It does not matter if you touch the line or circle first. 
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22 We now have to Clip  the unwanted geometry. Please note 
we have geometry on top of geometry. Make sure you remove this geometry. 

See image below. 

 

23 We now have to draw a circle with a radius of 3.4mm and position this in the 
top right hand corner as shown. 
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24 We will now Copy and Reflect this corner pocket first in X and then in Y. 

25 Highlight all of the pocket and the geometry inside only. Selection is Red. 

 

26 Select Edit from the main menu. Then select Transform select YZ. 

27 Select Ok. 

 

28 Then select Edit again and Transform. Then select Transform select XZ. 
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29 Select OK. 

 

30 Select Centre Radius  and create a circle with a Radius of 15mm and another 
circle with a Radius of 8mm both at X0, Y0, Z0. The geometry is now complete. 
See completed image on the next page. 

Completed image 

 

 If you are ahead of the class, then practice dimensioning this 
component yourself. Ask your instructor for help if needed.   
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31 Go to Construct Dimensioning and pick one at a time the available options. 

 After you have completed this exercise save the file. 

 Save the file as Construction Exercise 2 in the following Folder. 

 C:\Training_Data\FeatureCAM Course Data 2017\Course 
Work 

 We will be machining this on day 2 of the course. Just concentrate on 
geometry creation techniques. 

 Have a go at the exercises on the following pages. If you need help, 
ask your instructor as you work through the exercises. 
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Additional machining information 

 Product thickness 45mm 

 Centre hole 16mm Dia  

 6.8mm Dia holes are through. 

 Top Boss Radius 15mm Depth 10mm 

 Bottom Corner Radius values for Pockets and Boss are 3mm 

 If in doubt ask. 
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Construction Exercise 3 

 Have a go yourself at the following exercise. Please ask your 
instructor for help if required. See further Help on how to start this 

example shown below. 

 

 Before you start drawing this component spend time assimilating the 
information and decide what building blocks to draw first. A suggested 
process might be to start with the R25mm and R20mm Circles first and 
build the drawing from there. See the image below for a hint on what it 
should look like. 

 

 We will machine these components later on just concentrate on the 
geometry. 

Additional machining information 

 Product thickness is 25mm 

 9.5mm Diameter holes are through 
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 4.75mm Diameter and 3.2mm Diameter holes are 20mm deep.  

 A tip on creating this drawing is to create a single hole on the centre line 
of the 9.5mm diameter holes on the respective pitch circle diameter 
and then using Transform, copy and rotate it about a specific point. 
(Shown below) select the hole you want to rotate, go to the Edit menu 
select Transform and then Rotate and Copy. In the Angle field type in 
for example 360/5 = 72 and then you will need 4 copies which 
(Excludes the original). Remember to select the Rotation centre 
point. If you specify 5 copies you will get another circle on top of the 
original. When you come to drill the holes, you will get the same hole 
drilled twice. 

Using Transform 

 Use the Transform dialog to Move or Copy objects: 

 

1 Open the Transform dialog in one of these ways: 

2 Select at least one object and click the Transform button in the Standard  

3 Toolbar.  Or select Edit > Transform from the menu.  

4 Or right-click on an object and select Transform from the context menu. 

5 You can transform Geometry, Curves, Features, Surfaces, or Solids. 

 Features cannot be transformed using the Scale or To UCS 
methods. 

 Translate selected entity elements to a new location. You can move 
an absolute distance as specified in XYZ vectors, or you can move 
from point to point.  

 Rotate selected elements about a selected location to a specified 
angle, referenced from the positive X axis.  
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 Scale proportionally reduces or expands selected elements about a 
specified point. This option is not available for features.  

 Reflect mirrors the element about a line. The line can be an existing 
axis, or any other line including one created just for reflecting around. 
The object can be flipped top to bottom, left to right or even both 
depending on the line you choose to reflect around. Set whether you 
want to Move or Copy the original element. If you are copying, more 
fields appear for setting the number of copies you want in the new 
location.  

 There are additional optional exercises that follow. This will give you 
more practice drawing and using tools you have learned up to this 

point. 

Construction Exercise 4 (Optional Exercise) 

 

Additional machining information 

 Product thickness is 25mm 

 Large 16mm hole is through. 

 6mm holes are 20mm deep. 

 Counter bore on open profile is 5mm deep from top. 

 R12.7mm & R19mm Radius centres are the same as the top ø6mm 

diameter hole. 
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 If in doubt ask. 
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Construction Exercise 5 (Optional Exercise) 

 

 If in doubt ask. 
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 Product thickness is 40mm 

 260mm diameter bore is 17.5mm deep 

 Large closed pocket is 16mm deep. 

 70mm bores are through. 

 100mm x 90mm Pocket is 10mm deep. 

  50mm pocket is 16mm deep.   
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Construction Exercise 6 (Optional Exercise) 

 

Additional machining information 

 Product thickness is 35mm. All holes are through.  

 20 holes 12.7mm Dia  

 Chamfer all edges. 
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Tricks & Tips 

 When you want to Chamfer the corners of this example use Chamfer  

 Enter Width 6.35mm and Height 6.35mm 

 

 

 Then use the mouse pointer and move it to the corner as shown  

 Repeat this process for all chamfers. 

  

 See instructor for help with Chamfers at 135 degrees Construction 
Exercise 7 (Optional Exercise) 

 

 If in doubt ask. 
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Additional machining information 

 Product thickness is 45mm 

 All Holes are through. 

 170mm Radius centre is as follows X80 Y-70 Radius 170mm 

Construction Exercise 8 (Optional Exercise) 

 

Additional machining information 

 Datum point Lower Left corner. 

 Product thickness 50mm. 

 Section A – A machine 10mm deep, 

  Section B – B 20mm deep from the top surface. 

  50.8mm Diameter bores are through. 
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Completed Machined image 

 

 If in doubt ask. 
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Curve Creation 

Introduction 

 This module will provide a basic understanding of what curves are and how 
to create them within FeatureCAM. By the end of the module the user will 
be able to construct both open and closed curves. There are more advanced 

Curve creation options available. These will be covered later on as we 
progress through the training course. 

What is a Curve 

 Curves are paths in 2D or 3D space.  You can create them in FeatureCAM 
or import them from other CAD systems.  Curves can be open or closed. 
You can create Curves from Geometry lines and arcs, from other Curves, 
from Points, from CAM dimensions, from Windows™ fonts, or from 
Surface and Solid Models. 

 

Chaining 

 Lines, circles and arcs typically represent the shape of a part. To use a 
sequence of lines and arcs as the shape of a feature, you must Chain them 
into a Curve.  To make a Feature from more than a single line, arc or circle, 
you must connect the geometry into a Curve. Chaining is the primary way 
of creating Curves by connecting pieces of geometry.  In many cases you 
do not need to trim away pieces of geometry. Chaining will automatically 
prefer smooth, tangent-continuous paths since these paths are more 
conducive to manufacturing. 
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Closed Curves 

 Closed Curves have start and end points in the same location, and at 
least one other point (not in that location) included in the curve. The Closed 
Curve clearly defines an area as the interior of the curve and completely 

separates this area from the exterior of the curve. Any ambiguities, such as 
overlapping curve links or intersecting curve links, cause failures and 
unpredictable results in the machining routines in FeatureCAM.  To Chain 
Open curves the closed curve command may be used by simply double-
clicking the closed geometry using the Pick Pieces command. 

 

Open Curves 

 Open Curves have end points that do not meet. You can only use open 

curves in Side and Groove Features. To chain open curves we use the 
Pick Pieces command. The image below shows two Open Curves on a 
part. 

 

Curve Constructors 

 Curve constructors are used to create/modify curves using different 
methods. In this section there will be a short description of how each 
function works.  

 From the File menu click on Construct then on Curve. Let’s review these. 
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 There are four different methods for creating curves: From Curve, 
Other methods, From Surface and Chaining. 

From Curve 

 From the File menu click on Construct then Curve then From Curve. 

 

The Curve from Curve menu has functions that create new curves based on 
existing curves. 

Curve Join: - Connects a collection of curves, arcs or lines into a single 
curve. 

Curve Start/Reverse: -  changes direction and starting point of the curve 

Curve Offset: - offsets a curve in the direction you pick by the amount you 
set. 

Project to UCS: - projects flat curve or 3D curve to current UCS 

Extract Font Curve: - extracts curve segment from a font curve 

Smooth/Reduce Curve: - reduces the amount of data in a curve and  

Smooths out any bumps within a user specified tolerance. 

Unwrap: - unwraps a curve that has been wrapped around a cylinder 
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Other Methods 

 From the File menu click on: - Construct>Curve>Other Methods. 

 Curve from other methods gives you the ability to create curves using 
other types of constructors. 

 

Function: - creates user-defined mathematical relationships to generate a graphical 

figure. 

Cams: - creates the geometric profile of various reciprocating cams or cylindrical cams. 

Spline/Interpolation: - creates a continuous smooth curve between points. 

Text: - creates text curves from any TrueType installed for windows. 

Ellipse: - curve tool creates an elliptically-shaped curve in the plane of the current UCS. 

Rectangle: - creates a rectangular shaped curve in the plane of current UCS. 

Gear: - creates a 2D gear profile. 

From Surface 

 From the File menu click on: - Construct>Curve>From Surface. 

 The Curve from Surface menu has functions that create new curves from 
surfaces. 

 

Boundary - extracts the curve from a surface's boundary 

Trimmed Edge - extracts the trimmed edges of a surface 

Intersection - extracts curves from a surface-surface intersection 

Isoline - extracts surface row or column isoline 
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Project onto Surface - project existing curve onto a surface 

Surface Edges - extracts selected surface edges 

Surface Projection - extracts curves from all vertical walls 

Revolved Surface Boundary - extracts a revolved profile about the part’s index axis 

Chaining 

 Curve chaining commands can be accessed from three different areas of 
the user interface: 

 Curve chaining commands may be accessed through the Geometry 
toolbar. 

 

 May be accessed from the File menu by clicking on Construct>Curve> 
Chaining. 

 Or may be accessed by clicking on Curves  from the Steps 
Toolbox. 

 

Curve Wizard 

Curve Constructor commands can be accessed in three different areas of 
the user interface: 



 
 
Curve Creation 

                           

 

      
Autodesk FeatureCAM 2017    

© Copyright 2016 Autodesk, Inc. All rights reserved           3.7 

 Curve constructor commands are available through the Steps menu. 

 They may also be accessed through the File menu by clicking on 
Construct and Curve 

 May be accessed through the curve toolbar. 

 

 To show the curve toolbar, from the file menu click on View then 
Toolbars then check the Curves and Surfaces checkbox and press 
OK 

Tricks and Tips 

Curves can be extended just the same as Geometry when using Trim 

/Extend  this is useful on Curves that have been extracted from the 

Solid Model and you need to machine past a point.   

Changing a Curve - To Geometry 

 Whenever you want to change a Curve back to Geometry just select 
the Curve and then go to Construct >Curve and select To 
Geometry. 

 

 This will then create the Geometry so you can then manipulate it as 
normal Geometry. 



              
 

                   
                       
                                              Curve Creation   

 

                                                                                                                                      

                                                                                                              
 Autodesk FeatureCAM 2017   

3.8                                                                                                                  © Copyright 2016 Autodesk, Inc. All rights reserved 

 The curve will still be there in its original form. 

 Another good tip to think about if you are having trouble creating curves. 

 Select the Options tab as shown below. 

 

 The following menu will appear. 

 

 Change the Endpoint Tolerance to 0.1mm this will help. 

 Also the Double click Depth, change this to a higher number. This is ideal 
if you are having trouble creating curves from Splined circles which are 
faceted. 

Open Curves 

 Remember to use Pick Pieces   on Open Curves. 

 For example the image below is an Open Curve. Exercise 4 has an open 
Curve. 
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Creating Curves (Class Exercise) 

1 Open the file Construction Exercise 2.  
2 Go to File and select Open and select the following Folder location. 

3 C:\Training_Data\FeatureCAM Course Data 2017\Course Work. Within 
the Folder there will be the exercise you created on the first day called 
Construction Exercise 2. Open this file. 
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4 The image above shows Stock material around the Part. In PartView double 
click Stock1. 

 

 The image below shows the size of the current material. Select 
Resize. 
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5 Select the option Compute Stock size from the size of the part. 

 

 

6 Enter the Metric values shown above. Select Next and then Finish. 

7 In Part View Select Stock1 and then Right click and select Show Stock. 

Curve Creation 

 We have the ability to give curves a unique name; this can be beneficial 
if you have the time. As we progress through this exercise we will give 
the Curves relevant names for each Pocket or Boss. 

 The best view to look at our part is Top View or Ctrl + 5 please 
select this view. 

8 Please select the Closed Curve Icon   from the Geometry Menu. 

Tricks and Tips 

 Please see the example below showing a selection point. This is a good 
point to create a closed Curve in our example. Apply this technique to 
all pockets. 
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9 We will now select the Outer profile of our Part. A single click will now create 
the Curve. Rename the Curve as Outer_Large_Boss. 

10 Then Select the Larger center Circle and call this Inner_Small_Boss. 

11 If you look in Part View you will see the names of the curves you have just 
created. 

12 The next Curve we will create is from the larger top right pocket. 

13 Please select this pocket and then move in a counter clockwise direction 
selecting all of the similar pockets. 

14 The larger top right pocket will be called  Top_right_Large_pocket 

15 Work your way through all of the profiles. The naming convention should look 

like the image shown on the next page 3.13 
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 The image below shows all of the curves we have just created. This 
has been achieved by Hiding All Geometry from the View Menu. 
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 The image below shows a cross section view of Construction 
Exercise 2 

 

 Bottom Radius of the deepest pocket is 3mm  

 We will now move the smaller 4 circles in Z to Z-20mm 

16 Select Show and then Show All from the View Menu. 

17 Hold down the Ctrl key and select the four circles one at a time as shown. 

18 Or go to Edit/Select Circles. Select the Hyperlink in Blue and pick one of 
the smaller circles. 

19 Select Ok and all four circles will highlight. 
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20 Go to Edit/Transform. 

21 Then select Move and Translate. 

22 We will be moving all four circles in Z Only to Z-20mm 

 By translating the geometry when we come to drill the holes this 
will automatically start from Z-20mm. 

 See the Transform menu below. 

 

 

 

 We are now ready for machining. This will be covered in the next 
chapter. 

 Save the File as MC1.fm in your instructors chosen location. 
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Group exercise from Curves (Class Exercise) 
 Open File MC1.fm with Curves that we created in the Basic Curve Creation 

chapter.  

 The image below shows the depth dimensions for our part. Bottom 
pocket radius is 3mm and Boss bottom radius is 3mm. 

 

 We will machine the component using default settings showing each 
step as we work through the example. Tool Crib is 
Training_Crib_Metric. We will select a Post of our choice at the end 

of this example. 

 Please be aware that there is more than one way to machine this 
component. Time permitting your instructor will go through these 
other methods. 

Defining Stock Parameters 

 Before we can start creating our machining sequences we need to 
define our stock around our part. This may have been created in our 
previous chapter. 

 If not then please follow these instructions. 

1 Show Stock from the PartView menu by right clicking and selecting Show 
Stock. Double click on the Stock and the following menu will appear. Please 
select Compute stock from the size of the part. 
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2 Enter the following dimensions into the respective fields on your computer. The 
reason for the extra thickness is so we can hold the part in a vice on the extra 
5mm of material. 
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 The image below shows the Curves we created in the previous 
chapter. Plus Stock. Setup1 is from Centre + Top. 

 

 We have all the Curves listed in Part View as shown below. If not 
please create your curves. 
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 We will have to move the 4 corner holes (6.8mm dia holes)                
in Z to Z-20mm.  

3 Select Edit>Select Circles. Select Radius which is a hyperlink and select one 
of the 6.8mm dia holes circle diameters. Select OK. By selecting OK all of 

the same diameter holes will then be selected ready to create our Hole feature. 

 

4 Select Edit>Translate. 
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 You can see from the image below that the 6.8mm diameter holes 
have moved in Z to Z-20mm. 

5 Please select Hide all Geometry. 

 

 The first operation will be to machine the top Face. There are four 
ways in which to activate the New feature menu. 

6  Select Construct>New Feature  

7  Select Ctrl + R  

8 Select Steps and Features 

9 Select New Feature from the Advanced Tool bar to create a New Feature. 

 

10 Select Face. 
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11 Select Next to show the New Feature>Location menu. 

 

12 Select Next to show the New Feature>Dimensions Menu. 

 

  Accept the current values. Select Next. The following menu will 
appear. 
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 Here we have the option to Connect Stepovers with arc. This will 
increase the machining time but give a smoother transition on and 
off the work piece. We also have an option to select Rough pass. 

This is ideal if you have a lot of material to take off. For our example 
just leave it as shown. 

13 Select Next twice.  
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 FeatureCAM will give you the option to keep the tool selected or 
Search for another tool or make a new one. 

 Select the lower option. Search for another tool or make a new 
one. Then select Next. 

 FeatureCAM will give you the option to select a tool from the list. 

 

14 Choose a Facemill of your choice from the list. 

15 Select Finish and OK to close the menu.  = Default selection. 
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 The next operation will be to machine the Small Centre Boss 
feature. 

16 Select Ctrl + R or select Steps and Features to create a New Boss 
Feature. 
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17 Select Boss From Curve and select Next. 

18  Now select the Curve by either picking the Curve from the Screen using the 

 Pick Arrow icon. Or by selecting the inner_small_boss curve from Part 
View.  

 

19 Select Next. You will be presented with a New Feature - Location Menu. 

 

20 Because we are working from the top face in this instance the Offset from 
Curve Z location will be at Zero. 

21 Select Next. 
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 The Boss information is as follows Chamfer 0.5mm Height 10mm. 
Bottom Radius 3mm 

 

22 Select Next and the following menu will appear. 
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 New Feature – Strategies gives you the options for machining the 
feature in different ways.  

 Use default settings in this instance. 

23 Select Finish and the Boss Properties menu will appear. 

 

 By selecting the top menus this will give you more options. For 
example select Location and the following menu will appear. 
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24 Select Strategy and the following menu will appear. 
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25 Select Wall and the following menu will appear. 

 

26 Select Misc and the following menu will appear. 
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 This is a quick overview of the options in Misc. 

 Base Priority. Enter the priority that the operation takes in the 
document. The lower the number, the higher priority the operation takes. 

 Plunge clearance. Enter the distance above the operation at which the 
tool feeds 

 Z Rapid Plane. Enter the minimum safe distance in Z above your part. 

27 Select OK to hide the menu. Then run 3D Simulation to view the results. 

 

28 Eject the Simulation. 

 The next operation is to machine the larger 4 pockets 

29 Select Ctrl + R or select Steps and Features to create a New Feature. 

30 Select Pocket from Curve. 
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31 Select Next. 

 We need to select the four larger pockets. The next screen shot shows 
all four pockets selected. Showing the names of the pockets we 
created the day before. You can select them from Part View or we 
can select the Curves manually first selecting them one at a time. For 

manual selection we use the  Pick Arrow. 

 

32 Select Next. This will show you a menu where you change the Offset from 
Curve Z Location to -10mm 
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33 Select Next. 

 

 Pocket information. Chamfer 0.5mm  Depth 10mm  

34 Select Finish. This will use default tools from the tool Crib 
Training_Crib_Metric. 

35 The next operation will machine the 4 smaller pockets.  

36 Select Ctrl + R or select Steps and Features to create a New Feature. 

37 Select Pocket from Curve  

38 Select Next. 

 We need to select the four smaller pockets. The next screen shot 
shows all four pockets selected.  

39 Select Next. This will show you a menu where you can change the Offset 
from Curve Z Location to -20mm. 
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 Pocket information Depth 10mm Bottom Radius 3mm 

 

40 Select Finish. Run 3D Simulation. See 3D Simulation of the part below. 

41 Select Eject. 
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 We now have to drill the four holes. One in each corner plus the 
16mm diameter hole at X0,Y0. 

42 Select the Edit menu and then select Circles. Then Select the Blue Hyperlink 
Radius. Once you have selected this please select one 3.4mm radius circles on 
the screen. Select OK. All four circles of the same diameter will be highlighted. 

 

 

43 Then Select Ctrl + R or select Steps and Features to create a New 
Feature. 

44 Select Hole. Also select Make a Pattern from this Feature. 
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45 Select Next, Please select Tapped Hole and enter the following values. 

 

46 Select Next.  

 

47 Select Next. 

  FeatureCAM shows the Dimensions for each Hole. 



              
 

                   
                               Understanding Features      

 

                                                                                                                                      

                                                                                                              
 Autodesk FeatureCAM 2017   

4.22                                                                                                                 © Copyright 2016 Autodesk, Inc. All rights reserved 

 

 

 

48 Select Finish then select the Strategies Tab.  

 

 Change the options to suit your preferred machining style. For 
example if you do not want to Spot drill all holes just untick the 
option in the menu. 
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49 Select Finish accepting all default tooling. All of the selected holes will now be 

machined. 

 The next operation will be to machine the Centre hole 16mm 
Diameter plus chamfer. 

50 Select Ctrl + R or select Steps and Features to create a New Feature. 

51 Select Hole. Select the single hole by selecting the geometry with your cursor 
(Left hand mouse button). Select Next. 

 

52 Select Finish to accept all default tooling from your selected Crib. 

53 All we have to do now is machine the outside shape using Boss. 

54 Select Ctrl + R or select Steps and Features to create a New Feature. 

55 Select Boss. Select Next. 
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56 Select the outer Curve called Outer_Large_Boss. 

 

57 Select Next. 
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 The Offset from Curve Z Location is -10mm 

58 Select Next. 

 

59 Enter the Height as 35.5mm 

60 Select Next. 

61 Select Finish. Then select the strategy tab. Please select the following 
options. 
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62 Untick Rough pass and Ramp from top. Then select Semi-finish pass 
and helical side finish. With a helical pitch of 6mm. 

63 Select Wind Fan.  

 This is the Leadin/out movement for this operation. 

 Select the WindFan option in the menu, which shows a sub-menu 
as shown below. This produces the following toolpath 
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 Windfan at 135 degrees and 10mm Radius 

 

 Windfan at 180 degrees and 10mm Radius 

 



              
 

                   
                               Understanding Features      

 

                                                                                                                                      

                                                                                                              
 Autodesk FeatureCAM 2017   

4.28                                                                                                                 © Copyright 2016 Autodesk, Inc. All rights reserved 

 

 The position of the Leadin/out is not in the best position. The next 
menu gives you the option to change the start and end points. 

  We have created a Point as shown on the next page. This enables 
you to snap to this point to give a Start point and retract point. 

64 Select the Boss2 feature in PartView. Then select semi-finish and then 
select plunge. 

 

 This will update all Start points and Retract points. See following 
image. 
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 The part is now complete for side 1 See 3D Simulation  

 

65 Save the file as Exercise MC1 Method one in your instructors preferred 
location.  

66 Save the file again and call it MC2 Method two in the same location. 
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67 Delete the first pocketing Feature. 

68 Double click on Pocket2 and Set Offset from curve Z Location to -10mm 
then select Next. 

69 Set the following values in the Dimensions tab. 

 

70 Select Next. Then from the Strategies page, select Pre-drill and enter 
16mm 

 

71 Select Finish. 
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 Before we run a 3D Simulation. We need to define 4 small curves 
for the corner details. 

72 Select Ctrl+5 Top View. 

73 Select Hide All. 

74 Then select Show all Geometry. 

75 Create an Open Curve by using Pick pieces. 

76 Select the three elements shown and then apply this method to all four 
corners. 

 

77 Select Enter for each created Curve. 

78 Select Esc to Finish. 

79 Select Hide all Geometry. All that will be visible will be the four Curves that 
we have just created. 

80 Select the Four Curves on the screen. Use the Ctrl Key for group select. 

81 Select Ctrl+R New Feature. Select Side. 

82 Select Next Twice. 

83 Select the correct machining side for each Curve. 

84 Select Next and then set the Offset from Curve Z Location to -10mm 

85  Select Next and enter the following values. 
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86 Select Finish. 

 You will have to change the Minimum Rapid Distance from 400% 
to 50% this will allow the cutter to Rapid to the safe level height 
between moves. 

 Min. Rapid distance% - Enter the minimum distance, as a 
percentage of the tool diameter that the tool can use a rapid move 
for. Moves smaller than this distance use a feed move. 

 You can set the default value of this attribute for the current 
document in the Machining Attributes dialog. Set this in the Misc. 
tab.  

 NT toolpaths do not have the Min. rapid distance % attribute. 
They use Stepover rapid distance instead. 

 Stepover rapid distance — this option controls when to retract 
and plunge on Boss Stepovers for NT toolpaths. Enter an absolute 
distance. 

 Traditional toolpaths (Spiral and Zigzag) do not have the 
Stepover rapid distance attribute. They use Min rapid distance 
% instead. 

 If you get a collision on the part this means that the Minimum 
rapid distance is set to 400%. 

  

87 Go to Machining Attributes (Local Setting) and set the Minimum rapid 
distance to between 50% to 100%. This will allow the cutter to retract 
between moves. 

mk:@MSITStore:C:/Program%20Files/Delcam/FeatureCAM/Program/Help/EZFM.chm::/75935.htm
mk:@MSITStore:C:/Program%20Files/Delcam/FeatureCAM/Program/Help/EZFM.chm::/76001.htm
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 It would be a good idea to set this Parameter in your main 
Configuration. (Global Settings) This will prevent any further 
problems. Remember to set this value on all computers. 

88 Set the Base Priority for the following Features. 

 Base Priority = Enter the priority that the operation takes in the 
document. The lower the number, the higher priority the operation 
takes. 

 Face = Base Priority 1 

 Boss = Base Priority 2 

 Pockets = Base Priority 3 

Base priority 

 The default priority for features. Features are sorted by their priority to 
determine the order in which they are manufactured.  

 Set the Priority attribute on each feature to override the Base priority 
and order the features for manufacturing. For features that have the 
same priority value, FeatureCAM uses minimization of tool changes and 
other criteria to determine a manufacturing order.  

Minimize Tool Changes 

 

 Minimize tool changes groups operations together that use the 
same tool. This saves time for you by eliminating or reducing 
needless tool changes. 

 

javascript:toggleBlock('81711')
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                               Understanding Features      

 

                                                                                                                                      

                                                                                                              
 Autodesk FeatureCAM 2017   

4.34                                                                                                                 © Copyright 2016 Autodesk, Inc. All rights reserved 

Do Finish Cuts Last 

 

 Do finish cuts last moves the finish milling operations to the end of 
the setup without altering the order of the finishing operations? If you 
want to perform all rough milling operations before finish milling 
operations, select the Do finish cuts last attribute 

Cut higher operations first 
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 This attribute only affects milling setups. Select this check box to 
mill the features from the top of the stock first and work toward the 
bottom. 

 If you deselect this attribute, you should carefully graphically verify the 
toolpath before cutting your part. 

Minimize Rapid Distance 

 

 This attribute only affects milling setups and is the only ordering 
option that will change the order of features specified in the part 
view. Minimize Rapid Distance moves to the next closest feature 
that uses the same tool as the last operation. 

89 Run a 3D Simulation of the finished Part. 
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90  Save the File as MC2 Method two. Save the files in your Coursework 
folder. 

 We need to Face the opposite side of the part. 

91 To do this we need to create Setup2. 

92 Double click on Setup1 in PartView. Then select Align to Stock Face. 

 

93 Select Next. 
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94 Select Bottom and Center. 

 

95 Select Next. Then set the Z Offset to -5.00mm then select Finish. 
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 To have a look at the new Setup2 change the view to isometric. 

 

96 Create a Facing operation on Setup2. Remember to select the Rough 
option and set the Z Increment in the Milling tab to 2mm. 
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 Run a 3D Simulation to verify the machining in this setup. 

 

 

97 Select Eject or Esc to close the 3D Simulation. 

 This is the completed list in PartView. 
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 Save the File as MC2 Method two. Save the files in your 
Coursework folder. 

 Close this document and create a New file. 

Multiple Fixture Document 

1 Open a New Multiple Fixture Document. 

 

 From Multiple fixture documents the following menu will appear. 
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2 Select Parts List. 

3 Select Browse and add the two files shown. 

 

4 Select OK and then select Add. 
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5 Select Next. Create a new Fixture ID for each Setup. 
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6 Select Next. 

 We will leave the first Datum at Zero in X0,Y0,Z0 

 

7 Select Next. Then select Finish. 

8 Then Select Add and then select MC2. 
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9 Select Next. 

 

10 Select Next. Then change the X value to 400 and the Y value to 50 
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11 Select Next then Finish to accept. Run a 3D Simulation to see the results. 
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Basic Toolpath Terminology 

 Z Rapid Plane = 50mm (Default) Enter the minimum safe distance 

in Z above your part which could include clamps and fixtures. 

 Plunge Clearance = 3mm (Default) Enter the distance above the 
operation at which the tool feeds. 

 Tool Change Location = this is the point where the tip of the tool 
moves to prior to a tool change. (Post Options) 
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 Offset from curve Z location = If you want to change the top of 
the feature, enter a value for Offset from curve Z location. This 
can be a positive or negative number. 
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 Depth = Enter the distance cut into the material in Z. 

 

 Minimum Rapid Distance % = Enter the minimum distance, as a percentage 
of the tool diameter, that the tool can use a rapid move for. Moves smaller 
than this distance use a feed move. Please set this to 100%. Can be set in 
Machine Attributes or Machine configuration. If the next rapid move is 
greater than the diameter of the cutter as a percentage % then the tool will 

lift up to the Rapid plane clear of the work piece. 

 For example if you have a 20mm dia tool and the minimum rapid 
distance is set to 300% this will equate to 20mm x 3 = 60mm minimum 
rapid distance. 
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 You can see that the tool lifts up between cuts set at 300% 

 For example if you have a 20mm dia tool and the minimum rapid 
distance is set to 400% this will equate to 20mm x 4 = 80mm 
minimum rapid distance. As a guide I would always set the Minimum 
Rapid distance between 50% and 100%. (Default = 400%) 

 

 

 Please note that the tool will remain down and move at the current 
feedrate (G01). 
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 Rough pass Z increment: - This sets the depth of cut for the 

Rough pass.  

 Enter a depth Z increment for each pass that the roughing routine 
performs on the part. You can set the depth of cut in several places. 
Also Finish pass Z increment is available under the Finish Tab. 

 

 Depth of cut = 3mm (Endmill Tool Properties) 
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Understanding 2.5D Features 

What are Features? 

The easiest way to think of Features is as individual machining operations that 
the user would have to perform on a machine tool. For example, if the user 
wanted to face off the top of a block and then drill some holes at various points 
on that block. They would first need to put a Face mill into the machine tool and 

machine across the top of the block. This would be defined as a Face Feature. 
If they then wanted to drill some 10mm diameter holes, they would need to 
change the tool and then maybe centre-drill and drill the holes that were 10mm 
in diameter. This would be Hole Feature 1. If there were any more holes of a 

different size, these would need to be defined as another separate Feature, so 
the next Feature would be Hole Feature 2 and so, on until the job is complete. 

Feature Types 

FeatureCAM uses various Features to define any 2.5D shape and they are 
found on the New Features form which can be accessed via the Steps Toolbox. 
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 They are separated into Groups, depending upon how the user wishes to 

define the Features.  

 There is a From Dimensions group which uses dimensions that the user 
might take from a drawing to describe the shape. Or From Curve group 
which uses Curves to define the shape of the Feature. 

 All Features created inside of FeatureCAM are initially created using the 
New Feature Wizard. The New Feature Wizard can be accessed in 
several different areas of the user interface for example. Advanced 
Toolbar, Steps Toolbar or File Menu. 

 Within the From Dimensions Group are the following categories. 

 Hole, Rectangular Pocket, Slot, Step Bore, Thread Milling and Face. 

 We will work through all of Features listed and explain how they function. 

 Holes are created by Drilling or Boring and may have other characteristics 
such as a Chamfer or Tapped threads. They are manufactured using 
canned drilling cycles. 
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                               Understanding Features      

 

                                                                                                                                      

                                                                                                              
 Autodesk FeatureCAM 2017   

4.54                                                                                                                 © Copyright 2016 Autodesk, Inc. All rights reserved 

 We will start with the Plain Hole. 

 

 Select Next and you will be presented with a location menu 
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 Enter the coordinates for your hole. After the location menu has been 
displayed select Next and you will get the strategies menu which 
will allow you to customise the drilling sequence. 

 

 Select Finish. Your Hole Feature has been created and machined. 

Hole: Drill to depth (Information Only) 

 The actual depth of the twist drill operation is determined as follows: 

 Drilled Depth = depth + (diameter / 2) / tan (Angle of drill / 2)  

 For example, using a 20mm drill with 118 degree Rake angle. The depth 
is set to 25mm. Allowing for Drilled Depth = depth + (diameter / 2.0) 
/ tan (Angle of drill / 2.0) the actual drill depth will go to Z-31.009mm 
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Example Drill to Depth Hole 1 
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Example Drill to Depth Hole 2 
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 With Through selected then this adds 0.1*Diameter to the depth. The 
actual depth of the drill with Through selected is Z-33.009mm 

Example Drill to Depth Hole 3 

 If you want to force the depth from the drill point then select the 
Drilling Tab and enter the depth that you want to drill to from the drill 
point. 
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 Other Hole types are available for example Counter Bore. 

 

 

 Enter a Diameter value.  
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 If you are building holes from circles, select the circle before opening the 
wizard to pre-populate this field. 

 Enter how deep the hole is in the Depth field.  

 Depending on the type of hole you selected, you may have other 
dimensions to fill in such as Chamfer size and Drill Depth. For tapped 
holes, you can click the Standard Threads button and select a thread 
type. Each thread type sets the Thread depth, TPI, and Diameter 
dimensions. 

 Select Next to open the New Feature - Location page. Select whether 
you want to enter the location as XYZ or Polar.  

 For XYZ, enter the X, Y, and Z coordinates or pick the location in the 
Graphics window.  

 For Polar, enter the Radius (the distance along the X axis), the Angle, and 
the Z location. 

 Click Next to open the New Feature - Strategies page. The options on this 
page are the same as those on the Strategy tab of the Hole Feature 

Properties dialog.  

 Click Next to open the New Feature - Operations page.  

 Click Next to open the New Feature – Default Tool page.  

 Click Next to open the New Feature – Feeds/Speeds page.  

 Click Next to open the New Feature – Summary page.  

 Select Finish, to create the feature and exit the wizard or click Back to 
return to previous pages.  

Counter Sink (Information Only) 
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Counter Drill (Information Only) 

 

Tapped Hole (Information Only) 
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CD Tapped Hole (Information Only) 

 

Thread Milled Holes 
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Back Bore Hole (Information Only) 
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Combine similar holes into canned cycle 

 By selecting the Strategy Tab you have the option to select Combine 
similar holes into canned cycles which apply to drilling operations. 

 

 By default G83 is selected when drilling holes. This is a safety feature. If 
you want to change the Cycle to G81 select the Hole feature in PartView. 
Expand the Feature tree by selecting + next to Hole. Select Drill then in 
the Menu select Cycle and change the Drill Cycle to G81. (See image 
below) 
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Change Canned Cycle 

 

Rectangular Pocket (Class Exercise) 

1 Create a New Part Document using the Wizard. 

2 Select Millimeters and Select Finish. 

3 A stock dimensions form will appear, enter the dimensions of the Stock.  

4 Width (A) 100 

5 Length (B) 125 

6 Thickness (C) 50 

7  After entering your dimensions select Apply and OK to close the form. 

 



              
 

                   
                               Understanding Features      

 

                                                                                                                                      

                                                                                                              
 Autodesk FeatureCAM 2017   

4.66                                                                                                                 © Copyright 2016 Autodesk, Inc. All rights reserved 

 

8 Select OK and then Apply. 

9 Select Ctrl + 1 or Right click on the view screen and Select Isometric. 

10 Select Ctrl + R or select Features from Steps. Select Rectangular Pocket 

This machines a Rectangular Pocket with rounded corners. No Curve is needed 
for this Rectangular Pocket. Select Next. 
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11 Select Next. 

 

12 Enter the Length=100  

13 Enter the Width=75  

14 Enter the Depth=25, the distance cut into the Material. 

15 Rectangular Pockets have a Corner Radius that defines the four corners of 
the Pocket. Enter a value of 10mm for the Corner Radius. 

16 Set the Chamfer to 1mm. Default angle is 45 degrees for the Chamfer cut 
at the top edge of the Feature.  

17 Enter a Bottom Radius of 5mm Enter a Draft Angle of 5 Degrees. 

18 Select Next. We need to position the pocket central to the Stock. A location 
form will appear. Enter X12.5mm  Y12.5mm Z0 
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19 Select Finish. 

 

 Run a Centreline Simulation.  
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20 Save the file in your instructors chosen location. 

Slot (Information Only) 

 Slot is a straight slot with rounded ends. No Curve is needed for a 
Slot. 

1  Open a New Part Document. 

2 Create a new block Stock with Properties of 100mm x 100mm x 25mm. 

 

3 Select Ctrl + R or select Features from Steps. Select Slot from 
Dimensions. 
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 The Simple option simplifies the manufacturing strategy for the Slot. 
If it is selected, the slot is manufactured by making a single pass down 
the centre of the Slot with a tool whose radius is equal to the width of 
the slot.  

4 Enter the slot's Length. The width of a slot does not have to match the diameter 
of a standard available Endmill, unless you are making a Simple Slot. If an 
exact match cannot be found, then a smaller tool is selected and multiple 

horizontal passes are performed.  

5 Enter the slot's Width. Enter the Depth, the distance cut into the material. 

6 Chamfer sets the depth of a 45  Chamfer cut at the top edge of the Feature. 

Leave this value at 0, the default, for No Chamfer.  

7 Optionally enter a Bottom Radius. Optionally enter a Draft Angle. 

8 Select Next. Enter the following dimensions into your menu. Untick Simple. 
Length 75mm Width 12.7mm Chamfer 1mm Depth 12.7mm Bottom 

Radius 1mm. See image below. 

9 Select Next. Then enter Slot location details as X12.5mm, Y50mm. 

10 Select Finish and OK to close the form. 
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 Please select Show Centreline Simulation.  

 

11 Save the file in your instructors chosen location. 

 See image below. 
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Step Bore (Optional Exercise) 

1 Open a New Part Document. Millimeters. 

2 Create your Stock Material size to X100mm Y100mm Depth 50mm. 

  A Step Bore is a series of Round Pockets with a common Centre. No 
Curve is needed for a Step Bore. 

3 Select Ctrl + R or select Features from Steps and select Step Bore. 

 

 

4 Select Next and then enter the following Metric values as shown on the next 
page. Then select Finish. 
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5 Select Next and then enter the location information X50mm, Y50mm. 

 The image shows a cross section of the part. 

 

6 Run the 3D Simulation to see your finished part. 

7 Save the file in your instructors chosen location. 
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Thread Milling (Information Only) 

                                                                   

       ID Thread                            OD Thread 

 FeatureCAM follows this process to create a single Thread Milling 
Feature: 

 An appropriate tool is selected. The tool selected by default and has the 
same Pitch as the Thread.  

 The Internal/External classification matches the Feature.  
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 Enter the values and then select Finish. 
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Metric Thread Milling Exercise (Optional Exercise) 

1 Open a New Part Document. Millimeters. 

2 Create a Round Stock Material of 50mm Diameter, 75mm long in the Z 
Axis 

3 Create a Rectangular Pocket 35mm X 35mm R5mm Corners. Depth 
10mm Location X-17.5mm  Y-17.5mm  Z0 

4 Create a Step Bore Top Dia 35mm Depth 10mm Bottom Dia 28mm Depth 

25mm. 

5 Create a Thread Milling Feature 50mm OD Right hand 40mm Long 
1.5mm Pitch. 

6 Create an ID 30mm Thread 1.5mm Pitch Depth 20mm Location Z-10mm. 

 See Example below. Save the file as Metric Thread Milling Exercise. 

 

 

7 Run 3D Simulation. 

8 Save the file in your instructors chosen location. 
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Face Milling (Information Only) 

 Face is a milling operation to machine a face of the stock and to cut 
the Stock to an exact dimension. 

1 Open New Part Document Millimeters. Create a new block Stock with 
Properties of 300mm x 400mm x 51mm. 

 

2 Select Ctrl + R or Feature from Steps and select Face. 
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3 Select Next. 

 

4 Select Next 
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5 Select Next 

 

 You will notice that Connect Stepovers with arc has been ticked; 
this will link the toolpaths with an arc producing a smoother 
transition at high speed between cuts. 

 When you are using Face the operation will be re-positioned to the 
start of the machining in the Operations list as this has high 
priority. 

 You will notice the Face feature which denotes that the top is now 
finished to size. 

 

 

 Face Milling shown as 2D toolpath.  

 Please note we are using a 80mm Facemill instead of the default 
32mm 
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 Face Milling shown in 3D Simulation. 
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Face milling a multiface feature (Information Only) 

 New to FeatureCAM 2016, we now have the ability to machine a 
multiface feature. Make sure you select Extract with Feature 
Recognition. 

 

1 Select Next. Then select your face features. 

 

 

 FeatureCAM states that it has found multiple features. 
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2 Select yes to create all found features. Select Finish. 

 See the results in the image below.  

 Please note we have selected a 100mm Facemill. Note the large 
toolpath offset moving from face to face. 

 

 Run a Centreline Simulation. 
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User Defined Stock Exercise (Class Exercise) 

 Please note there is always more than one way to create the following 
example.  

 

1 Use the mouse pointer and select the Stock line, use the Left mouse 
button Click to select. 

 

 Right click to show the following menu. Then select Hide Stock. 

 Alternatively you can select Ctrl + J this will Hide All if shortcuts have 
been configured on your computer. 
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2 Go to Construct>Curve>Other Methods>Rectangle. 

 

 

 

 Use Top View or Ctrl+5 to orientate to the XY plane.  

3 Enter the following Co-ordinates Width 150mm Height 100mm 
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4 Remember to select create as arcs and lines. 

 We now have a Rectangle in the X Y plane that we can use to 
create our part 

5 The next step is to use Offset and offset the four edges inwards by 25mm 

6 Select Offset from the Construct menu as shown below. 

 

7 We will now set an Offset value of 25mm as shown. 

 

8 Use the Offset command to create parallel shapes of Lines, Circles, Arcs, and 
Ellipses etc. A copy of a selected entity is placed at a specified distance from 

the original entity. The original entity stays in position. Set the position by 
selecting either top or bottom left or right of the profile. 

 

9 Put the cursor on the inside of the line to denote the side the offset line will 
be.  
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10 Apply this to the four edges as shown. 

 

 

11 Now Clip the unwanted lines. Select the Clip command from the Construct / 
Edit Geometry Menu. 
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12 Clip the lines so the image is like the one shown below. 
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 We now need to Fillet the inner corners 5mm 

 

13 Select Corner Fillet Enter 5mm select the corners shown. 

14 It should look like the image shown below. 
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 Use the Closed Curve option to Chain the geometry into a 
closed boundary using a single mouse click. Rename the curve as 
Stock Curve. 

 

15 Select the Geometry and select Create to create the Closed Curve. 

16 Right-Click on the Stock from the Part View in the Toolbox at the left hand 

side of the FeatureCAM interface and choose Properties. 
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17  Press the Stock Curve button as shown below. 

 

18 Select Stock Curve when prompted in my case it is Curve1 but your Curve 
number may be different. Press Apply and OK. 
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 Remember to show stock. 

 The Stock should now look like the image shown below.  

 

 We will now create the 5 Counter Bores in this example  

19 Create the following Counter bore Features. Using the Features Menu press 
the following keys as a short cut, select Ctrl + R or select Steps and then 
Feature from the Steps menu. Create a New Hole Feature.  
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20 Select Next and select Counter Bore. All Counter Bores are 5mm deep. 
Enter the values shown in the Menu on the next page. 

 

 Bore Dia 16mm Bore Depth 5mm Diameter 10mm Depth 25mm 
Select Next so we can position the Counter Bore. 

 The menu shown on the next page allows you to enter the positions 
for the Counter Bore. The positions are as follows X12.5mm 
Y12.5mm 
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 We will now create all of the Counter Bores in their respective 
positions. We can either type in all of the co-ordinates manually or 
we can use the reflect command in Transform. This is because the 
hole positions are symmetrical about the Centre line. 

 Make sure you have highlighted the new Counter Bore Feature. The 
best way to do this is in the Part View Menu. 

 

21 Please select the Edit menu and select Transform.  
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22 The following menu will appear. 

 

 You will notice that the Reflect position is in the XZ type in 50mm 
this is the Reflect point in the Y direction. Enter your relative units 
and select OK. 

  We now need to reflect the two Counter Bores in the YZ Direction 
along the X direction. Highlight the two Counter Bores, select the 
first one and hold down the Ctrl Key, select the other one in the Part 
View. Both will be selected. Then select Edit then Transform as 
shown. Remember to select Copy and Reflect. Set the YZ Plane and 
enter the following values. X75mm. Select Preview if required, then 

select OK. 
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23 We just need to create the Counter Bore in the middle at X75mm Y50mm 

Select Ctrl+R or select Feature from the Steps menu. Select Hole as the New 
Feature and Counter Bore, and then enter 40mm for the top bore and 20mm 
for the hole through.  

 

24 After entering the values select Next. 

25 Now position the Counter Bore at X75mm Y50mm. Select Next. 
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26 Select Finish. 

 The job is now finished. 

27 Run the 3D Simulation as shown below. 

 Have a look at the Wireframe image plus Operation List. 

28 Select File>Save NC to Output CNC Code to a directory of your choice. 

29 Remember to Save the file in your Instructors preferred location. 

 

 

 FeatureCAM has created the toolpaths automatically from the 
Features you have created. With FeatureCAM you generate your 
part using Features such as a Tapped hole etc., operations are 
automatically created. FeatureCAM also manages the details of the 
manufacturing process such as Tool selection, Speed and Feed 

rates, and toolpaths. To modify any element of the part program, just 
change a few settings on a Feature and a whole new set of 
operations are generated to reflect your changes.  
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Pocket and Pattern Exercise (Optional Exercise) 

 A Pocket Feature is easily changed into a Pattern 

1 Open a New Part Document. Millimeters 

2  Define a Stock block of 200mm x 200mm x 50mm. Location X0,Y0,Z0. 

3 Select Top View or Ctrl + 5 to orientate the view into the X, Y, Plane. 

4 Select Ctrl+R New Feature. 

5 Create a Rectangular Pocket Feature from dimensions. 

 

6 Enter the above values into the Menu. Then select Next. 

7 Location. X5mm Y5mm 
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8 Select Finish. 

9 Create a Pattern. Select Ctrl+R select Pattern. 

10 In Part View select the Rectangular Pocket we have just created. 

 

11 Select Next. 

12 We need a Rectangular Pattern. 

13 Select Next. 

14 Select Local Offset. 

15 Enter the values as shown. 
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16 Select Finish and OK. 

17 Select Minimize Rapid Distances in the Automatic Ordering Options. 

18 Run 3D Simulation. See image on the next page. 

 

Pockets with Islands (Optional Exercise) 

1 Open a New Part Document. Millimeters 

2 Create a Material Block X400mm Y400mm Z40mm. Hide the material. 

3 Use Top View or Ctrl + 5 to set the correct View. 

4 Create a Rectangle X400mm Y400mm. Select Construct>Curve>Other 
Methods>Rectangle.  

 Remember to Create as Arcs and Lines. 

5 Offset the lines by 80mm to make an inner square. Make a Horizontal 
Line in the middle of the square at 200mm. 

6 Create Three Circles Radius 60mm as shown below. 
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7 Create a circle Tangent two with a radius of 300mm and snap to all 

circles.  Delete all Vertical or Horizontal Lines, and then Clip to trim 
back the unwanted Geometry.  

8 The Geometry should now look like this below. 
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9 To find the Centre of the defined shape create a circle from 3 points 
snapping to each of the larger radius points in turn. 

 

 

 This will create a centre point. We will use this to create a circle with 
a radius of 50mm then create 3 circles with a radius of 30mm and 
snap to the three points as shown below. 

 Delete the unwanted circle in the middle. Offset  all inner 
Geometry by 10mm to the inside of all the circles. Your drawing 
should look like this below. 
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10 Create a Closed Curve  for all of the geometries. 

11 Select CTRL + R to create a New Feature. Select Pocket from Curve. 

12 Select the Outer shape as the main profile. Select next then next and enter 
the following information. 

 

13 Select Finish and you will be presented with a new menu. 

14 Select Islands from the menu. 
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15 Select each of the outer curves for each Boss. Select OK and Apply 

 

 

16 Run the 3D Simulation to see the results. 
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 We need to finish off by creating the pockets through the four bosses 
.Create another pocket feature and select all the curves that are left. 

 

 

 The job is now finished. 
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Round & Chamfer Exercise (Optional Exercise) 

 Round: - This uses a user defined tool that has been pre-ground to 
a shape that will produce a radius on an edge. This will machine a 
rounding operation that follows a curve and is best described as a 
fillet radius around the top of a Boss or Side Feature. 

1 Open a New Part Document. Millimeters 

2 Create a material block 100mm wide x 200mm long 30mm thick. 

3 Press CTRL + 5 to orientate the view to Top or XY plane. 

4 Draw a circle Radius 35mm X55mm Y50mm Z0. Then draw another circle 
Radius 35mm X145mm Y50mm Z0. 

5 Draw a line snapping to the centres of the two circles. 

6 Offset the line up and down by 16mm and trim away the unwanted geometry 
using Clip. 

7 Fillet the corners 16mm. It should look like the image below. 

 

8 Create a closed Curve of the Geometry and create a Side Feature 12mm 
deep. 

9 Run the 3D simulation and then press Eject. 

10 Create a New Feature Round Select the Curve and make sure the Arrow is 
pointing on the outside. 
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11 Accept the 3mm radius and press finish. Your example should look like the 
one shown above. 

12 Save the Round Example and then undo the round operation. 

13 Create a new Feature Chamfer 3mm. Then save file as chamfer. 
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Groove (Simple) (Optional Exercise) 

 The Groove Feature provides the ability to apply grooves to the face 
with a flat or ball end mill, to the side using a side cutting milling tool 

or to perform engraving using a flat end mill, ball end mill or a 
Bevel/pointed tool. 

1 Open a New Part Document. Millimeters 

2 Create a material Block of 150mm x 150mm x 150mm Draw a circle 
60mm  Radius at location X75mm Y75mm 

3 Create a Curve from the circle, Use Closed Curve  

4 Press CTRL + R to activate the New Feature menu or select Steps and then 
Feature, select Groove and then Next. 



              
 

                   
                               Understanding Features      

 

                                                                                                                                      
                                                                                                              

 Autodesk FeatureCAM 2017   

4.108                                                                                                                  © Copyright 2016 Autodesk, Inc. All rights 
reserved 

 

5 Select the Curve. 

6 FeatureCAM will display another menu for location just leave this at zero 

7 Leave the selection on Face/ Simple (Engrave) 

 

8 Type in the following values Width 6mm Depth 5mm bottom rad 0 (Zero) 
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 Notice on the example above that the cutter path is on centre and 
uses a 6mm cutter to finish the slot. If you need to rough the slot 
out first copy and paste the original Groove Feature and change 
the first cutter to 4mm Diameter. 
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Groove (Simple unchecked) (Optional Exercise) 

 An Inside/Outside groove may be created on the outside of the 
part, or the inside of vertical walls using a side-cutting tool. When the 
tool is the same width as the groove, one rough and one finish pass 
is made. A single finish pass may also be used. 

 

 

 The example above shows three grooves the first one as illustrated 
shows an internal groove of 60mm Dia inside a bore of 50mm Dia 
60mm deep. The internal groove is Z-30mm the external groove is 
Z-40mm. 

Engraving (Optional Exercise) 

 The engraving text was created using Curve/Other 
Methods/Text using Machine Tool Gothic size 24.  

1 Create a curve and align the text to the curve. Copy the Feature and rotate it 
180 degrees using Translate. Use Simple groove to machine the text and 
use the following parameters Width 0.2 depth 0.4. 

  



 
 
Understanding Features 

                           

 

      
Autodesk FeatureCAM 2017    

© Copyright 2016 Autodesk, Inc. All rights reserved           4.111 

 

 

 

Feature from Feature Group Pattern exercise 1 

(Optional Exercise) 

1 Open a New Part Document. Millimeters. 

2 Create a material block Width 100mm Length 125mm and thickness 30mm. 

3 Create a hole from Dimensions 6mm Diameter 25mm deep 1mm Chamfer. 

4 Location X16mm Y16mm   
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5 Create a Rectangular Pocket 30mm x 30mm 10mm deep corner Rad 
5mm chamfer 1mm. 

6 Location X21mm Y21mm. 

7 Examine the features in setup1.  Currently there is a single hole and a 
Rectangular Pocket.  Say for example you would like to create a pattern by 
combining the hole & rectangular pocket together.  You could create a pattern 
of a hole, then a pattern of the pocket or you could group the hole and the 
pocket together and create a pattern of the group. 

8 Open the New Feature Wizard in the From Feature >Group select Group 
then click Next. 

 

9 Select the Features to be included in the group. Then select Next. 
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 You have the ability to move the order of machining up or down see 
below. 
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10 Select Finish 

 

11 Create a new Pattern Feature then select Next. 

 

12 Select the Hole and Pocket this is the Pattern base known as Group1 
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13 Select Next What Kind of Pattern would you like to make. Select 
Rectangular and then Next. 

 

14 Enter the following figures into the Dimensions form. 
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 Select Finish. Then run the 3D Simulation. 
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Feature from Feature Exercise 2 (Optional Exercise) 

 

1 From the file menu select File then Open select ToolpathEdit.fm in the 
examples folder then press Open. 

 Notice there is only a single face feature in this example located at 
Z0 

2 Run a Centreline Simulation of the current toolpath.  To do this press the  

3 Centreline Simulation Icon  on the Toolbar then press the Play 
button 
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 On this facing toolpath there are seven undesirable areas where we 
would like to change the toolpath.  For the toolpath representation 
there are both feed moves and rapid moves. Pink toolpath segments 
represent the feed moves while the green segments represent rapid 
moves.  Currently circled in Green are feed moves for the stepover 
between facing passes.  Since the stepover of the facing tool is off 
the stock it is safe for us to change these to rapid moves. 

4 Press Eject on the simulation toolbar 

5 Open the New Feature Wizard and select Toolpath in the From Feature 
section then press Next. 
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6 Press the Operation radio button select Face1, finish then press Next. 
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7 Select the first Y feed move from the list, and then press the Edit segment 
button. 

 

8 Check the Rapid checkbox then press OK. 
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 Locate the remaining Y stepover feed moves and change them to 
Rapid also then press Finish. 

9 Observe the Features in the Part View.  Now there should be a Facing 
Feature and a toolpath feature.  The toolpath feature is simply a copy of the 
original features toolpaths with the edited move. 

10 Uncheck face 1 in the Part View (so there are not two facing operations) 

11 Press Play on the Centreline Simulation  and observe the toolpath. 
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12 Now notice that the Stepover moves have been converted to Rapid moves 
that will reduce the cutting time of the part. 
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Advanced 2.5D Machining 
 

Introduction 

 In 2.5D milling there are more Advanced Features than just milling and 
drilling, such as X cross section, Work Planes, 4axis, etc. The user 
will learn how tapered walls and other shapes can be machined to 
emulate 3D milling surfaces using a ball end mill, but are still 2.5D 
machining.   

Cross Section (X section) 

 Side, Pocket and Boss Features. 

 When creating either a Boss, Pocket or Side features there is an option 
of selecting X section. This allows you to apply a shape, other than an 
angle, to the walls. FeatureCAM will even select a ball end mill where 
necessary. Surface or Solid models are NOT required, although the end 
result is similar to a 3D finished surface.   

Rules for an X-Section Curve 

 When using geometry for your cross section shape it does not have to 
be round. It can be other shapes as well.  

 Once you start drawing away from XYZ=0 you may not draw back 
towards the start point in the X or Y direction. This would create an 
undercut. 

 A straight line in the X or Y is ok as long as the end point continues away 
from XY=0. It must also remain planar. 

 Z elevation must stay at Z = 0  

 By drawing the shape, starting in the illustrated position (XYZ=0), it 
will attach to the top of the pocket and form the pocket walls identical 

to the X-section curve.  

 A Boss X-Section is the same, but if there are multiple bosses, and the 
bosses are NOT the same height, X Section CANNOT be used. 

Cross Section (X section) (Optional Exercise) 

1 Create a new document, Milling Setup, and Millimetres then Select Block and 
use Stock Dimensions of 150mm x 150mm x 150mm. Location X0,Y0,Z0 

2 Select Top View or Ctrl + 5 

3 Create a Pocket by drawing a 50mm radius circle, centred on Top View of 
the XY plane of the stock. Location X75mm Y75mm. 

4 For use in Cross (X Section), draw a 50mm radius circle, using Centre, 
Radius from the Geometry toolbar. Enter X-50.0mm and Y0. Using 
geometry, draw a Horizontal and Vertical line through the Centre of this new 
circle. The lines will be used for trimming. Trim the geometry until you have the 
lower right quadrant of the circle remaining as shown. 
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5 Chain both pieces of geometry. Use Closed Curve   chaining for the 
Circle  

6 And Rename this to Circle in PartView. Use Pick Pieces  for the Quadrant 
and Rename the Curve to Quadrant. 
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7 Press Feature in the Steps menu or press Ctrl + R to activate a New 
Feature Menu, select Side and then Next. 

 

8 Select the Circle Curve first. Then Next. If you have selected Side make 
sure the arrow is pointing to the Outside. If you need to change the direction 
select  

9 The Switch Machining Side Icon  then Select Next twice. 
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10 Enter 25mm for the depth. Then Next. 

11 You will be presented with the New Feature - Strategies menu. Select NT 
Spiral. NT stands for New Technology and uses the PowerMill machining 
Algorithms.  

 

12 Select Finish and the following menu will appear. 
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13 Select X Section. 

14 You will be presented with another form select X-Section and select the 
Quadrant Curve. 

 

15 Select OK and Apply. 

 

16 See finished image on the next page. 
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Creating a Concave Shape using Side (Optional Exercise) 

1 Save the previous example and then press Ctrl + Z or  to undo the previous 
example until you get to the Curve stage. Then get up to the same point where 
you change the Curve called Circle so it points inwards. Use the same depth 
and Finish. 

2 Select X-Section and pick the Quadrant curve. 

3 Select OK and Apply, the result should be the same as shown below. 
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Straight line chamfer using X-Section  

(Optional Exercise) 
 

1 Create a Stock Block 100mm x 100mm x 42mm deep. 

2 Hide Stock by selecting View>Hide>Hide Stock. 

3 Then Construct a Rectangle from Construct> Curve>other 

Methods>Rectangle. 100mm x 100mm.  

  Remember to select create as arcs and lines. 

4 Offset the lines inwards using Offset  from the Geometry Toolbar 25mm 
as shown below. 

 

5 Right click in the graphics area and select Front or Ctrl + 2 you will be looking 
end on along the X Axis. Snap to the first point for the left line as your first 
point. 

6 Select line from two points.  

7 Type in the following XYZ2 Metric co-ordinates. 25 for X2 Tab to the A Angle 
field and enter 225 then Tab to L and enter 42 then press enter to action this 
process. 
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 You should have the image as shown below. This is in Front View 
or Ctrl + 2. 

 
8 Now we will select the line and then using Transform we will reflect the line 

about the centre line in X as shown. 
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9 Select Copy and YZ Plane and enter 50mm. Select Apply. 

10 We will now use the lines in our X-Section machining example. 

 Remember to show stock. 

 Your image should look like the one shown below before machining. 

 

11 Select Features from the Steps Menu or press Ctrl + R and select Side then 
Next. 

 You will be presented with a Menu New Feature - Curves. This is 
where you select your Curves or Chain new Curves.  

12 Select Curve Chaining as shown. 

 

13 Select one of the longer top lines we created first. 
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14 Select Next. 

 

15 Make sure the arrow is pointing as shown. If not select the Switch 

Machining Side  Icon to change the direction. Select Finish. 

16 You will be presented with a menu showing Side properties. 

One of the buttons shows X-Section. Select this button.  

17 Select Side Curve. Select Ok and Apply. 
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 You have now finished this exercise and the feature is now machined. 
Apply this method of machining to the other Geometry. Then Run the 
3D Simulation. 

 

 Completed 3D Simulation showing X-Section machining.  
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Creating Machining Set-Ups 

 Before starting any machining operation, it is necessary to set a 

Machine Offset Zero position from which to work from. In 
FeatureCAM these positions are called Setups and this can be 
defined by using a number of techniques.  

Creating Setups from Stock (Optional Exercise) 

 The Stock represents the Material which is to be machined. The 
most common places that are used when defining the Setup on a 
standard Block are Top Centre of a Face or one of the Corners as 

shown below. 
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 When FeatureCAM opens a new Document, Stock is 
automatically displayed on the screen. Enter the values shown on 

the next page. 

18 Double click on the stock either in the Part View Toolbox or in the main 
Graphics area. 
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19 Fill in the Form as shown, Length 150mm, Width 150mm and Thickness 

40mm. 

 

 The X, Y, Z input fields at the bottom of the form are the position of 
the top face bottom left corner in the World Coordinate System as 

shown in the image above. 

1 Change the values in the input fields and watch how the Stock moves 
around. 

2 Reset the figures back to X0, Y0, Z0. 

3 To place the Setup in the Centre of the Block, it is simply a case of moving 
the Setup to the Centre of a Stock face and this is achieved by changing 
the position, using the Part View Toolbox. 

 At the left of the screen are the Toolboxes and depending upon which 
Toolbox is selected; it will either show the Part View or the Steps Toolbox. 
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 If you can only see the Part View Toolbox and not the Steps 
options as shown. Try looking at the bottom of the screen. (When it 
is not in use, the Steps Toolbox drops down to the bottom, just click 
on the Tab to reactivate the Toolbox.) 

1 Double click on Setup1 in the Part View and the menu appears as shown.  

 

 

2 On this form, the user can choose to create a New Setup or to Edit Change 
an existing one. 

3 Click on Edit. Then Next. 
  



 
 
Advanced Machining 

                           

 

      
Autodesk FeatureCAM 2017    

© Copyright 2016 Autodesk, Inc. All rights reserved           5.19 

 

4 Use Align to Stock Face. 
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 The form is divided into two areas and these are Stock Face and 
XYZ location. 
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 Stock Face is used to tell FeatureCAM on which Face to place the 
Setup. 

 XYZ Location is used to position the Setup on that Face. 

5 Select Top followed by Centre. Click Finish and then Close. 

 The screen should now look like the one shown below. 

 

 To get more familiar with creating new setups. Use the same method 
and create a new set up on the Front Face at the Upper Right 
Corner. 

Move Feature Locations 

 If you decide to change a Setup position after you have machined a 
Feature. The following menu will appear. 

 



              
 

                   
                               Advanced Machining      

 

                                                                                                                                      

                                                                                                              
 Autodesk FeatureCAM 2017   

5.22                                                                                                                 © Copyright 2016 Autodesk, Inc. All rights reserved 

 Keep the Features in the same location relative to the stock: - The 
Machine Offset Zero moves and everything else remains in the same 
position. 

 Move the Feature along with the setup: - This will move the Feature 
relative to the old Machine Offset Zero and move this to the new 
Machine Offset Zero. 

4th Axis Indexing (Information Only) 

 In 2.5D milling, 4th Axis indexing is standard, and can be accessed 
when opening a new document. The stock wizard allows you to 
choose 4th Axis, as multi-axis positioning. It can be accessed any 
time in the stock properties under the indexing tab. Your machine 

must have four axis capabilities, and a rotary table, or indexer. Also 
a 4th axis post processor must be loaded in FeatureCAM.   

 The part can be indexed around the X, Y or Z axis. The desired axis 

you wish to index around must be selected in the stock wizard 
(illustrated) while selecting the shape and size of your stock. 

 

 Your machine must have four axis capabilities, and a rotary table, or 
indexer. Also a 4 axis post processor must be loaded in FeatureCAM.   

 The part can be indexed around the X, Y or Z axis. The desired axis 
you wish to index around must be selected in the stock wizard 
(illustrated) while selecting the shape and size of your stock.  
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 The Stock Axis is not normally displayed but to view the Stock Axis 
click View and select Show Stock Axis from the View menu.  It is 
displayed as two vectors (blue). One shows the axis of rotation (X or 
Y) and the other indicates the orientation of a 0 degree rotation 
(pointing at the spindle). You must align your part centre of rotation 
to the rotation axis of the Stock Axis. 

 

 If the Stock Axis is not centred, any features that you will be adding 
to the part will be out of place.  When a block stock is being used the 
UCS and Stock Axis are many times together but not always centred.  

 The Stock axis CANNOT be moved, the stock must be positioned 
around it. 

1 Click on Options then Add-ins.   

 Check the box in front of the Macro called “Centre Indexed Stock.bas” and 
a little tool bar appears, usually by the Part View. 

2 Drag the toolbar to dock it to an area next to the one of the other toolbars. 
Click this new button.  

 This macro will Move and Centre the stock with the Stock Axis. 

 When a new document is opened, and round is selected, the UCS and 
Stock Axis will be merged and centred on the stock.  Now the 
features can be placed around the indexing axis.  The UCS may be 
moved for Feature creation, if desired. 
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 When indexing a part that is not round, FeatureCAM calculates the 
corners of the Stock rotation and retracts a little extra to clear the 
corners of the stock.  DO NOT use Retract to plunge clearance 
whenever there is a corner present on the part that will rotate under 
the tool, when indexed.  An example of this is when there is a circular 

bolt pattern on more than one face of a block stock. In this case you 
will index to another face using the same tool. After drilling the last 
hole there must be a retraction to the Z Rapid Plane to clear the 
corners. If Retract to plunge clearance is set the part will hit and 
break the drill, or CAUSE DAMAGE TO YOUR MACHINE. 

 Once you have completed the prior steps, you may begin creating 
and placing features on your part. 

 Once you have completed the prior steps, you may begin creating 
and placing features on your part.  All 2.5D, and 3D, features may 
be programmed on an indexed part. FeatureCAM can index from 
face to face and cut features, or machine a continuously wrapping 
feature. Geometry curves and features are applied in the same 

manner as in any 2.5D part programs. They are placed in relationship 
to the UCS the same way as non-indexed parts.  

 Wherever the UCS is located, for example the centre of the part, 

the Feature may be created at Z0, but must be moved up to the 
desired Z elevation to place it in the proper location.     

 Features May NOT be Transformed/Rotated/Copied around an 
Indexing Axis but Geometry and Curves can. You may also create 

patterns around an Indexing Axis. On block stock, the part is 
indexed to the desired face, and the features are applied to each face.   
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 On the indexing tab you may choose Tool Dominant or Setup 
Dominant.  Tool Dominant does all of the machining on every 
Feature that uses that particular tool before it changes the tool, 
more indexing, less tool changes.  Tool Dominant can have just one 
Setup for all of the Part Features.   

 Setup Dominant requires a separate Setup for each face to be 
programmed and it completes all Features for each Setup before 
indexing to the next Setup, more tool changes, less indexing.  

Creating Setups Using Geometry (Class Exercise) 

1 It is also possible to create Setups which are aligned to existing Geometry.  
Draw the wireframe geometry shown below. 

 

 

2 Double click on Setup1 in the PartView and the Setups menu will appear.  
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3 Select Setup1 from the drop down menu select Edit. 

 This will open the Setup Definitions form. 

4 Rename the Setups so that they are easier to manage. 

5 Enter the name Machine Offset Zero into the Setup Name: field. This name 

will appear in the Part View Toolbox. 

 

 The Fixture ID field is where the user tells FeatureCAM which 
machine offset to use.  
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 For example: If the machine uses G54, G55 then enter 54. If the 
machine tool uses P1, P2 etc. then enter 1. 

 FeatureCAM will automatically insert the correct Fixture ID for the 

next new Setup. 

 It can be useful for the Part / Product name to appear in the NC 
output file; this can be inserted in the Part Name: field. 

6 Click Next and select the Align to Part Geometry option. 

 

 By selecting the Align to Part Geometry option, FeatureCAM 
knows that it has to provide the user with some tools to help them 

set up or align the New Work Plane. There are five options shown 
below and depending on the geometry available; the user can choose 
one of these to align the Z axis. 

7 Pick two lines to define Z direction. 
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 The form will shrink to one side of the screen to allow access to the 
Geometry. 

 Two mouse clicks are used to define the Z Axis direction.  

8 Select the bottom point as shown, followed by the top point. The position of 
the second click in relation to the first is what controls the direction of the 
Axis. 

9 When the form returns click Next. Then select pick two points to define the X 
direction. 
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10 Or you can select Rotate X direction 90 degrees around Z Axis. See Below. 

 

11 Select Next.  

12 From the next Menu select Pick location. 
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13 Pick middle section top edge. 

 

 

14 Select Finish. This will be the new position Setup. Machine Offset Zero. 
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Create a new setup aligned to the angled face 

1 Double click on Setup select New followed by Next and then Align to part 
Geometry. Select Next. And then pick Align Z Perpendicular to a plane defined 
by 2 lines. 
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2 First Line selection. 

 

3 Second Line Selection. 

 You can see from the image below that the Z is pointing in the Wrong 
direction. Select Reverse Z on the same menu so that the Z points 
in the correct direction. 
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4 Select Next. 

5 Draw a Line from  a corner to the opposite corner of the angled face 
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6 Pick Snap to Midpoint  snapping to the Centre of the new Line. 

 

 Using the current Setup, use Face to machine off the surplus 
material.  Remember to select Rough to machine off the extra 
material. Then create a 10mm diameter Hole Feature 25mm deep 
in the middle at X0, Y0. Make sure you select Make a pattern from 
this feature. Select Next. Then select Radial in the setup XY 

plane. Select Next. Enter PCD Diameter to 50mm. Number=6, 
spacing =60. Select preview to see the result. Select Next. Accept 
the position of X0, Y0, Z0. Run a 3D Simulation. The image should 
appear like the one below. 
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If you get a gouge after running the Simulation have a look at the Tool change position? 
Adjust the Z position so it will clear the part. 

4 Axis index around the Stock Axis (Class exercise) 

1 Open a New Document and create a Stock (Block) with the dimensions, 
150mm Length, Width and Thickness.  
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2 Select Finish. We now need to set the position of Rotation for the Stock Axis 
at Y-75mm, Z75mm. 

 

3 Click on the Indexing tab and select 4th axis positioning. Select Index around 
the Stock X axis and Tool Dominant. Select OK. 

 

 Double click on Setup1 in Part View select Edit and then Next. 
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4 Select Align to Stock Face then select Next.  Pick TOP and Centre + 

 

5 With your Cursor select View>Show>Stock Axis. From the pop down 
menu. 
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6 Create a New Feature, Select Features in Steps or Select Ctrl + R. Select 
Hole from Dimension and Make a pattern from this feature. Select Next. 

 

7 Enter Plain Hole, Diameter and Depth of 25mm and check through. Click 
Next. 
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8 Pick Radial in the Setup XY plane. Select Next. 

 

9 Set the following options: - Diameter 100mm, Number 6, Spacing Angle 60, 
Angle 0.  This creates a pattern on one face and will be used to create the 
same pattern on the other 3 faces, a pattern within a pattern. Next. 
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10 Location is set to X0, Y0, Z0 Select Finish. 

 

11 Create a New Feature. Select Ctrl + R. Pattern will be automatically 
selected. Select Next.  
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12 Select Pattern1 

 

13 Select Radial Around the index axis. Select Next. 
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14 Number 4, Spacing Angle 90. Select Next. 

 

15 Select Finish. 

 You will notice that the Pattern is out of position. 
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 Select Location in the Pattern properties. Then unselect the Relative 

position. 

 

16 This places the (6) Hole pattern on four faces positioned the same as the 
original pattern.     
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Round Stock 

 The Stock Axis is in the centre of the part and so is the Setup. However, 
the Setup and UCS may be moved for programming purposes.  The same 
rules apply to round parts as those of the block stock parts.  Features 
CANNOT be Transformed/rotate/copied around the Stock Axis.  One 
Setup is commonly used, but other setups may be added if needed.  You 
may also wrap a Pocket and Groove features, including Engraving, 
around the Stock Axis. 

 To Wrap a Pocket you must first create the Pocket, and if the UCS is at 
the centre of the part, you must translate the feature in the Z direction to 
put the top of the feature at the outer radius of the stock.  

 On a round part the Feature can be applied as normal and then wrapped 

which is selected from within the feature.  The “Wrap feature around X 
axis” check box becomes visible on the Dimension tab when 4th axis is 
turned on.  If it is not visible usually two things happen, either 4th axis is 
turned off (stock, indexing tab) or the feature was created at the centre of 
the part and you failed to move it up to the desired radius on the part, it 

cannot wrap around the centre. 

Wrapping a Groove (Optional Exercise) 

1 Open a New Part Document - Milling Setup Metric, Round Stock, X axis, OD 
300mm, Length 300mm, and ID 0. 
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2 Select Finish and the following menu will appear. 

 

3 On the Indexing Tab select 4th axis Positioning and Index around the STOCK 
X Axis. 
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4 Select OK to close the form. 

5 Click on View from the top Menu bar. Show > Show Stock Axis. 

 

 The Stock Axis and the Setup/UCS are together in the centre of 
the part. The stock and length of the stock are aligned with the X 

axis. 

 When wrapping a groove you must first create the geometry for the 
grooving feature, and it must lie in the XY Plane. 

 Wrapping a Groove is like wrapping a label around a tin can.  The 
values entered as indicated below, will start the groove with the centre 
of the tool being on X0 end with no movement in the X direction. The Y 
is Pi*300 which will determine the length of the geometry and the part 

will then rotate 360 degrees. The Z150mm puts the top of the groove 
on the outside radius of the Stock. The Geometry is the path for the 
Groove, but does not create the Groove.  

6 From Construct select Line>2 pts draw a line to the dimensions shown 
below. 

 

7 Type in the following co-ordinates.  XYZ 1 X0.0 Y0.0 Z150.0  

  XYZ 2 X0.0 Y Pi*300 Z150.0 A180 Select Create. 
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 XYZ 1 sets the start point of the groove tool at the top or radius of 
the stock centred on the end where the Setup X 0.0 is located. Y 0.0 
means it starts on 0 in the Y direction. Z150mm means it starts at a 
150mm elevation in the Z direction above the centre on the 150mm 
radius of the stock.  

 XYZ 2 is the end of the groove geometry and also determines 
whether it travels in the X and how many times it wraps around. X 
0.0 – This means the tool will not travel in the X direction.  If there 
is a different value in X then the tool will move to that distance in the 
X direction as the part rotates. Y Pi*300 - This means the part will 

rotate once around the part.  Notice that the value is Pi*300, this 
means Pi times the diameter which is the circumference of the 
300mm diameter stock and FeatureCAM understands Pi and its 
value and the *(asterisk) is Multiplication.  

 Z150mm - This means the tool ends up at the same Z elevation as 
when it started. 
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8 Select Feature from Steps or CTRL+ R, Select Groove from Curve and 
select the Line.   
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9 Select Next twice. 

10 Double click the Groove feature in the Part View window. Check the “Wrap 
feature around the X axis “box at the bottom of the Groove properties tab. 
Click OK and then run a 3D simulation. This will produce a groove that travels 
once around the circumference. 
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11 Double click onto the 2D line and Change only the end point XYZ2 in the X to 

300mm = Length change the Y to 4*Pi*300 (4 =Number of Rotations) and 
Z150 is the depth of the slot, click Modify, run a 3D simulation. 

  

Wrapping a Pocket (Optional Exercise) 

 The Pocket may be created by drawing or importing Geometry or from 
Dimensions as you would normally create this feature.   

 It can be created at the centre of the stock and given a value in the Location 
Z direction while creating the feature so as to place the top of the feature on 
the radius of the stock. 

 The feature when completed may be Transformed/Translated in the Z 

direction to locate the top at the radius of the stock. 

 The UCS can be translated in the Z direction to the radius of the stock and 
then create the feature, then the Location in Z remains at 0. 

 Remember if the 4th axis is not checked, on the stock/indexing tab or the 

feature is located down on the centre when trying to wrap the “Wrap feature 
around the indexing axis” on the dimension tab this will not be visible. 

1 Open a New Milling Setup, Millimetres, Stock is Round, along the X axis.  

2 Diameter 150mm, Length 300mm, ID 0, Next, Next, 4th axis indexing around 
the Stock X axis. 

3 Rename Setup if you choose, observe that the fixture offset matches your 
machine requirement (54) and the Part Name if completed here we will place 
this information both in the code (Post Processor must be setup first) on the 

proper line to identify the program and also can be set when saving NC code 
so as to name the text file.  Use current location for alignment, Next and 
Finish. 

4 Create New Feature, Rectangular Pocket from Dimensions. Select Next. 
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5 Enter Dimensions, Length 80mm, Width 80mm, Corner Radius 6mm and 
Depth 12mm.   

6 Select Next. 

 

7 Select Radial about X axis and then enter the other information shown on 
the next page. 
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8 Enter X50mm, Y-40mm, Z75mm, this centres the pocket and places the top 
of the feature at the outside radius of the stock. Select Finish. 

9 Select Wrap feature around X axis. 
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10 Run 3D Simulation, See finished image on the next page. To make this more 
interesting, create a pattern from this feature. The details of which are shown 
after the first pocket Simulation. 

 

 

Pattern from the pocket Feature 

11 First of all eject the 3D Simulation. 

12 Then double click on stock and change the ID value to 120mm. We are 
essentially creating a tube. 

13 Select Ctrl+R or create a New Feature from Steps or the Advance toolbar. 

14 Pattern will be automatically selected. If not select Pattern. 
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15 Select Next. You will be presented with a New Feature – Pattern Base 
menu. Select the rect_pock1 feature from PartView. 

 

16 Select Next. Then select Radial around index axis as shown. 
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17 Select Next. Enter 5 for number then type in 360/5. FeatureCAM will 
calculate the angle. 

 

18 Select Finish. Then select OK to close the form. 
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Wrapped Engraving 

 Engraving around a cylinder can be accomplished by first creating 
the text and then applying a Grooving feature to the text curve. 

1 Open a New Milling Document, Millimetres, Round Stock, X axis, 4th axis 
indexing, Diameter 300mm, Length 300mm, ID 0, setup centred. 

2 Change to Top view or Ctrl + 5, Select Curves; click Create curves using 

the Curve Wizard. Select the Curve Wizard Icon.  

 

3 Select Other methods and Text. Select Next. 
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4 Type in the following information. Shown on the next page. The curve name 

may be different to your name. 

 

 

5 Centre X150mm Y0 Z150mm Radius 65mm. 

6 The Font we are going to use is Machine Tool SanSerif. Size 36. 
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7 Select New Feature or Ctrl+ R New Feature. Select Groove from Curve and 
then select next and select the Curve.   
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8 Pick Curve 

 

9 In this case my curve is curve1. Yours may be a different number. Select 
Finish. 
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10 Select Wrap feature around X axis.  

11 change the depth to 2mm and width to 3mm 

12 Select the 3D Simulation and press Play. 

 

 

Automatic Clamp Avoidance 

 In FeatureCAM you can now automatically avoid solid model clamps 
when using 2.5D NT-style toolpaths and 3D toolpaths. 

1 Open file Manifold plate with clamps.fm 
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2 Go to Manufacturing>Machining configuration and select the file Manifold plate 

with clamps.fm and select Edit. Select Clamp avoidance under Milling. Change 
the value to 5mm. 

 

 

 

 By setting this Value to 5mm all of the NT toolpaths will be re-
calculated and will stand off any clamps by this amount. 
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 To turn a solid model into a clamp right click on the solid model in 
PartView and select Use Solid as a clamp. FeatureCAM will then 
know to avoid this solid model. As shown on the next page. 

 The top surface machining is using an NT pocketing strategy. 
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Tooling Reference Guide 

 It is possible to create Tool libraries in FeatureCAM. These are called 

Tool Cribs.  The main reason for creating Tool Cribs is because in any 
machine shop there is normally a finite amount of tooling available 
and by creating a custom Tool Crib, FeatureCAM will know what 
tooling is available to choose from. This can be machine specific or a 
generic crib for all machines. 

Tool Manager 

 The Tool Manager is where information on your Crib is stored and 
allows you to edit and create new Cribs as well as creating new tools. 
The Tool Manager can be accessed by going to the Manufacturing 
Menu and down to Tool Manager. This will open the following form. 

 

 There are three tool Cribs loaded as standard. (Basic, Basicmetric 
and Tools) and these can be used as a starting point when the user 
first starts to look at setting up their own Cribs. 

 The window is divided into separate areas and at first glance can look 
a little intimidating, but by applying some simple rules it becomes 
much easier to work with. 
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 If the user divides the form in two down the middle of the form. The 
left side is used to select which Crib to copy from whereas the right 
hand side of the Form relates to the Crib that is current or the working 
Crib 

 Tool Group. The tools can be grouped together depending upon their 
type or use. 

 

 Also listed down the right hand side of the form are a number of 
options. Among these options are New Tool, New Crib, Delete Crib 
and Copy Crib.  

 

 These options do exactly what they say. 
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 New Tool is used to create a new tool type. 

 New Crib will create a new crib, ready for the user to insert their 
selection of tools. 

 Delete Crib will delete an existing crib  

 Copy Crib Copy Crib will produce a copy of an existing Crib. 

 Tool Grades is used to apply scaling to feeds/speeds to similar tool 
types that use different speeds/feeds 

 Import / Export allow the user, to either import or export tool cribs 
from one computer to another computer containing a copy of 
FeatureCAM. 

Tool Manager Exercise 

1 Start a New FeatureCAM Part File ignoring the stock set-up. 

2 Open the Tool Manager. Go to Manufacturing>Tool Manager. 

3 By selecting the New Tool Crib option, the following form will appear. Enter 
the name as Haas_VF6_BT40_Crib, and then click OK. 

 

 The New Tool Crib will now be listed in the Tool Manager on the left 
hand side The new Crib is empty so it is possible to copy tools from 
existing Cribs.  

4 Select the Basicmetric Crib from the From Crib Menu and the 
Haas_VF6_BT40_Crib Crib from the Current Tools: Crib Menu. 

5 In the Tool Group select End Mill and select EndmillM2000 long. This is a 
long series 20mm dia Endmill. 

6  Click on the Select All Button and then on the Add button 

 to transfer the selected tool over to 

Haas_VF6_BT40_Crib. 

7  Repeat this procedure for the different tool groups and add some 6mm, 
8mm, 10mm & 12mm Twist Drills and some Spotting and Center Drills. 

8 Click on the OK button and the following Menu will appear. 
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9 Select Yes and you will be presented with another menu. 

 

10 Select Yes to change from the tools Crib to the Haas_VF6_BT40_Crib Crib. 

 More tools can be added at a later date just by selecting them from 
the Tools Crib or defining New Tools based on Catalogue data and 
adding the tools as needed. 

 To set the Tool Crib so that it is used when calculating the tool path, 
go to Manufacturing, Set tool crib and select the crib from the list. 
Alternatively go to the bottom Right of the screen and click on the 
area indicated. 

11  Select the Crib required as shown. 
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Editing Tools 

 It is also possible to Edit Tools from within the Tool Manager. 
Double click on any End Mill to open the End Mill Tool Properties 

and change the name and End Radius to match the image below to 
create a new Bullnose Tool. This is the easiest way to create your 
custom tools.  

 

Setting Tool Overrides.  

 From Tool Properties it is also possible to set what each tool will be 
used for as well as setting specific Depths of Cut, Stepovers, Tool 
ID’s and other information. This is all done from the Overrides tab.  

12 With the Tool Manager still open select the Overrides tab and change the 
Operations drop down on the left hand side to be Rough Operations Only. 
When FeatureCAM now selects tools for toolpaths the Bullnose will only be 
used for roughing passes.  

13 Also check the depth of cut and stepover checkboxes and enter values to 
match the image below. You can also set the Tool ID from here to match which 
tool position your tools are set to in your machine by editing the Default Tool 
Registers. Do this as well.  



 
 
Tooling Reference Guide 

                           

 

      
Autodesk FeatureCAM 2017    

© Copyright 2016 Autodesk, Inc. All rights reserved           6.7 

 

 

14 Click on the OK button and the following Menu will appear. 

 

 

 

15 Select Yes to save the current Tool Crib after editing the tool. 
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End Mill Tool Properties 

 End mill length and diameter properties. 

 

A = Shank Diameter 12mm  

B = Overall Length 100mm  

C = Exposed Length  60mm  

D = Cutter Length (Flute Length) 30mm  

E = Cutter Diameter 10mm 
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Spindle and Tool Holders 

 This can be accessed by going to Manufacturing/Spindle and Tool 
Holders and allows you to create and edit Tool Holder Properties. 
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Tool Holder Exercise  

 One of the best ways to create a Holder in FeatureCAM is to import 
a Solid Model of the Tool Holder. 

1  Import the file Din 69871 Collet Chuck Holder.x_t into you current 
FeatureCAM document.  

2 Cancel the Import Wizard 

3 Hide the Stock. 

4 The Setup and Stock Axis are in the correct position. At the Holder base 
point in the center of the Solid Model. 

5 Right click and set the View to Front or Ctrl+2 

 

6 Open the Spindles and Tool Holders form from the Manufacturing tab and 
click the Create New Tool Holder icon shown.  
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7 Create a New name for the Holder. 

8 Select Use Solid to describe holder shape. 

9 Select the holder solid. 

10 Enter the Length from the Holder Gauge line to the Holder base center point. 

In our case the value is 68.604mm 

11 Your Holder is now in FeatureCAM and can be used for any available tool. 
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End mill - Properties / Holder / Mill 
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Face Mill - Tool Properties example. 

 

 There is a new option to specify a 45 degree chamfer for Face Mill 
tools: 

 This new option allows more accurate simulation and machining. 

Existing tools are classified as Round by default. To set a 45  
chamfer on a Face Mill tool: 

1 Select Chamfer as the Corner type.  

2 Enter an Effective Diameter greater than zero.  

3 Enter a Tip Radius greater than or equal to zero.  

4 Click the Apply button.  
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User defined Tools (Form Tools)  

 In this module the user will learn how to create Form Tools for milling 
with end mills and side cutting milling cutters. These tools may be 

used in Milling and Turn/MILL. At the end of the module the user will 
be able to draw the geometry for the shape of the tool and chain a 
curve to that shape for FeatureCAM to use to create a new tool in 
the tool crib and save it in a Tool Group called Form Tools that can 
be recalled at any time. 

Create a Chamfer Milling Tool  

1 Open a New Milling Document, Metric called Chamfer Form Tool.fm for 

reference. 

2 Hide Stock, 

3 Right Click in graphics window and View from the front.  The XZ plane. 

4 Select Front or select Ctrl +2 to view in the correct orientation 

 It is very important that the STOCK AXIS is located at XYZ 0.  If this 
is omitted, the curve will not be accessible when creating the form 
tool.  

5 To view the STOCK AXIS Click View in top menu, select View> 
Show>Show STOCK AXIS. 

 

 Another set of arrows (blue) will show up in the graphics window 
merged with the UCS. 

 The Z0 will be the bottom of the Chamfer Form Tool.  The X0 is the 
center of the tool and only half (radius) of the tool needs to be created 
(+ side of X).  The finish curve will be an open curve. 

6 Using the Geometry constructors Draw this shape and chain an open 
curve. (no centreline) 
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Create a side Milling Form Tool 

1 Open a New Milling Document, Metric called Side Milling Form Tool.fm for 
reference. 

2 Hide Stock.  

 Remember to view the stock axis as shown in blue on the previous 
example.  

3 Right Click in graphics window and View from the front.  The XZ plane. 

4 Select Front or select Ctrl +2 to view in the correct orientation. 

 It is very important that the STOCK AXIS is located at XYZ 0.  If this 
is omitted, the curve will not be accessible when creating the form 
tool.  

5 To view the STOCK AXIS Click View in top menu, select View> 

Show>Show STOCK AXIS. 

 

 Another set of arrows (blue) will show up in the graphics window 
merged with the UCS. 

 The Z0 will be the bottom of the Chamfer Form Tool.  The X0 is 
the center of the tool and only half (radius) of the tool needs to be 
created (+ side of X).  The finish curve will be an open curve. 

 Using the Geometry constructors Draw this shape and chain an 
open curve. (no centre line) 
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Tool Mapping 

 Tool mapping now supports 8-digit Diameter & Length offset registers. 

 This ability now supports more machine types because you can now enter 8 
digits for the tool Length offset register and Diameter offset register in the 
Tool Mapping dialog: 

 

 The Tool Mapping dialog is where you change the tool slot assigned 
to the selected tool. You can change the Cutter comp. offset register 

for any tool here too. The dialog has a table at the top. Each row of 
the table represents a tool. Select a tool to edit its values in the fields 
below the table. Double-click on a tool name, or click the + to the left 
of the tool name to see the list of operations that use that tool. Click 

the Add tool slots button at the top left of the table to open the 
Number of tool slots dialog. It enables you to increase the number of 
tool slots listed; you cannot reduce this number. Tool number 
corresponds to the first (grey) column in the table and is the current 

tool slot number for that tool. To move a tool to a different slot tool 
slot, enter a new Tool number and click the Set button, or drag-and-
drop the name of the tool in the table onto the tool slot number in 
the left column. More than one turning tool can occupy the same tool 
slot. 
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Tool Numbering 

FeatureCAM automatically selects tools from the active tool crib. 

These tools are assigned a tool number (also referred to as a tool Slot or tool 
pocket) for an automatic tool changer. The numbering is assigned according to 
these rules: 

 Use the number assigned in the Tool Mapping dialog. 

 This numbering is in effect for the current part only. 

 If no number has been assigned via tool mapping, then the number assigned 
to the tool in the crib (the Tool number field for milling tools or the Tool slot 
for turning tools), is used as the tool number. If two tools have the same 
permanent number in the crib, the first tool used is assigned the pre-set 

number and the other tool is given a new number. 

 If no number has been assigned via tool mapping or in the crib, 
FeatureCAM assigns a tool number. 

Tool Life 

To open the Tool Life dialog, select the tool you want to manage in the table in 
the Tool Mapping dialog and click the Tool Life button. The Tool Life dialog has 

different options depending on if the tool is a drill or a milling tool.  

 

 See help file for more details 
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Machining Configurations / Attributes 

Introduction 

 This module will provide the user with an understanding of what 
attributes are, characteristics and features and where they reside 
Also covering when an attribute is chosen, where it shows up in 

FeatureCAM, and how it affects the feature.    

  By the end of the module the user will be able to select, prior to 
creating the program, the machining configuration of attributes, as 
the defaults for the material and/or machine to be used.  This saves 

time in programming by not having to make the same repetitive 
entries for the choices you wish to be defaults when that particular 
material, or machine, is chosen.  It also eliminates having to 
remember the different settings. 

Machining Configurations 

 The Machining Configurations can be accessed from the Manufacturing 
drop down menu. 

 Machining Configurations are predetermined default functions that are 
selected, and used in all features that are created in the document. 

 A Machining Configuration contains approximately 150 settings. 

 An unlimited number of Machining Configurations may be created. 

 The user can name a Configuration to reference the material and/or machine 
to be used. 
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 “Initial Configuration for new documents”, is in the drop down menu at the 

bottom. 

 When a Machining Configuration is selected prior to programming, the 
attributes, so to speak, rain down into the new document just opened. These 
are used as the default settings. They are divorced from the Machining 
Configurations and become Machining Attributes, assigned to, and a 
permanent part of the new document. 

 

 

These settings may be changed in the document. You can click Manufacturing 
and Machining Attributes at any time. Changing any attributes will assign them 
to this document only, but does not affect the original, or default, Machining 

Configuration. 

In other words, these changes do not become the defaults and when a new 
document is opened the old defaults are active.  These settings stay with the 
document and are active anytime this same .fm document is opened.   
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What are Machining Attributes? 

 

 

 When an option in the Machining Attribute is selected, a box is 
checked or a value is entered, it becomes a default. This means that 
FeatureCAM uses this setting every time a feature requiring that 

particular setting is selected in a program. There is no input required 
from the user during programming, as it is now automatically set. 
However, it may be overridden and changed in the feature as needed. 

 Tabs are used to categorize the different operation types and 
necessary attribute settings. 

 Some selections are check boxes, some are numerical values, and 
some are specific functions.  The majority of these show up in the 
feature that they affect, but some settings do not. These settings may 
only be changed in the attributes. This is the reason it is so important 
to know where these settings reside, what their function is, and where 
they are located in the features.  
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 To apply the changes you have made, in the Attributes for the 
document, to become the defaults for any new documents they must 
also be changed in the Machining Configuration that opened with the 
file. Once set, and the next time a new document is opened, those 

changes will then take effect as the default settings. 

1 Open a New Document and click Manufacturing on the top menu and select 
Machining Configurations. 

2 Select the document you just opened. Usually there is only one document 

open but multiple documents may be opened. In this case, you would see 
multiple documents in the list. 

3 Click Copy and select the desired configuration from drop down menu. 
These defaults load into the new document.  

 

 To copy the changes from the document’s configuration into another 
configuration to be set as the defaults: 

4 Select the desired Configuration in the window. This is the configuration you 
want to copy the attributes to. 

5 Click Copy and select the document from drop down menu in the Copy 
Configuration dialog. 

6 Select OK to action Copy Configuration. 

 This reverses the copy and places the changes from the document 
Attributes into the configuration selected in the window of the 

Machining Configurations dialog. 

Creating Machining Configurations 

1 Open a New Milling Document. Click Manufacturing on Menu bar then 
Machining Configurations. 

2 Click on New and type the word Aluminium in the field. OK 

3 Repeat these steps to create a Stainless configuration. OK. 
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4 Double click on Stainless in the window. Select the Stepover Tab in the 
Machining Attributes dialog. Change the Rough Pass depth to 25%. 

 The Rough pass depth for milling was 100% of the diameter of the 
cutter. It is now 25%, so for a 25mm endmill the rough pass depth 

is set to take cuts at a depth of 6.25mm. 

 Note: You now have three separate Machining Configurations.  Each 
has approximately 150 settings. 

5 Select the Document you have open in the Machining Configurations dialog at 
the top of the window.  

6 Copy and select Aluminium from the Copy Configuration dialog. 

7  OK twice. These settings will be used in the new document. 

8 Open an existing file named Milling Attributes.fm, from the 2.5D Advanced 
Data folder, and run a 3D simulation.   

 The 12mm diameter milling cutter cuts to the bottom of the 12mm 
deep pocket in one pass because the default attribute specifies the 
depth of roughing passes is to be 100% of the diameter of the cutter.  

9 Click Manufacturing then Machining Configurations.  Select the document in the 

window on the left named Milling Attributes.fm. 

10 Press the Copy button. Select Stainless from the drop down list in the Copy 
Configuration dialog. Press OK twice. 

11 Using the same feature and by only changing the Machining Configuration the 
Attributes automatically change to the Stainless settings.  

12 Run a 3D simulation. 

 The setting for Stainless is 25% of the diameter of the cutter so now 
the tool makes four passes at 3.175mm depth of cut instead of one 
at 12.7mm with no further input from the user. 

Machining Attributes Explained 

 The rest of this document will be used to explain the attributes found in each 
of the tabs inside the Machining Attributes dialog. To follow along and 
compare, click Manufacturing then Machining Attributes to open the dialog. 

Drilling Tab 

 Spot drill:   All holes that are drilled will receive a spot or center drill 
operation before the hole is drilled. 

 Attempt chamfer w/spot:  When a chamfer is entered in a hole feature, 
a spot drilling tool is selected that is large enough to cut the chamfer as it 
center drills for the hole feature.  If the hole is too large, it will still be spot 
drilled but will give a warning that it was not able to achieve the chamfer 
and use a chamfer tool in addition to the center drill. 

 Use L/D Compensation:  As a hole is drilled deeper the feed and speed is 
adjusted to compensate for the additional depth.  This is true for holes that 
have a ratio of hole depth (L) to hole diameter (D) of greater than 2.5. The 
greater this ratio, the greater the speed/feed reduction becomes. 
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 Combine with similar holes into canned cycle: This Attribute serves 

two functions. First it creates more efficient NC code by entering canned 
cycle mode only once. It also causes the tool to retract to the lower Plunge 
Clearance plane after drilling each hole, typically .100 above the hole 
instead of the Z Rapid Plane which is usually set much higher to clear 

clamps, etc.  Retracting to the higher plane when necessary is possible on 
a per hole bases in the Results Window Op List by clicking on the green 
arrow of the selected hole. 

 Drill large counter drill first:  A counter drill hole has a second, larger 
hole drilled on top of a smaller hole.  You may select to drill the larger hole 
first to avoid drilling the same material with the smaller tool that will be 
removed with the larger tool.  The smaller tool will then rapid to the plunge 
clearance above where the first drill stopped drilling. 

 Ream before Chamfer:  Allows you to ream a hole before the chamfer to 

avoid pushing any kind of a burr or edge back up onto the chamfer in the 
event the chamfer is a sealing surface. 

 Pilot drill diameter: Set the diameter for a frequently used pilot drill size 
as a default. 

 Spot drill edge break:  If 0 chamfer is entered in a hole feature, this 
setting will cause the center drill to break the edge by this amount, typically 
.005. 

 Spot drill diameter: This percentage is used to select a spot drilling tool. 
A value of 100 specifies that the spot drill should be the same diameter as 
the hole. A smaller value will create only a starter hole. 

 Dwell:  The spot drill will dwell for this many seconds. 

 Max tap spindle RPM:  Sets the maximum spindle speed that 
FeatureCAM will select when tapping regardless of the size of the tap. 

 (Cycles) 

  Drill cycle:  Deep hole will peck and retract to the plunge clearance and 

return to previous depth and chip break only stops feeding in order to 
break the chip, both perform their function until hole is to depth.  

 Tap Cycle:  Floating (floating & tension-compression holders), Rigid 
which is most commonly available on today’s machine tools being sold, 

Deep hole and Chip break is the same as drilling.     

 Ream Cycle:  Ream cycle affects how a ream operation is performed. The 
choices are Ream FDF (feed-dwell-feed), Ream FF (feed-feed), and Ream 
FSR (feed-stop spindle-retract). 

 If you select Ream FF, the cycle is posted using the Bore (F-F) 
format in XBUILD. Ream FDF will use the Bore (F-D-F) format, 
and Ream FSR uses the Bore (F-S-R) format. 

FDF, feed down-dwell-feed up, FF, feed down-feed up, FSR, feed-stop-
retract. 

 Bore cycle:    FDF, feed down-dwell-feed up, FF, feed down-feed up, FSR, 
feed-stop-retract and No Drag shifts a designated amount in No drag X 
and Y shift so as not to touch the finished wall upon retract. 
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Pecking Tab 

 Drilling: Depth of the First, Second and Minimum peck may be entered by 
the % of the drill diameter. 

 Tapping:  Depth of the First, Second and Minimum peck may be entered 
by the % of the tap diameter. 

Milling Tab 

 Climb mill: With the milling cutter rotating clockwise if you follow behind 
the cutter in the direction of the travel of the tool and the cutter is on the 
left side of the curve it is climb milling and if it is on the right side it is 
conventional milling. 

 Bi-directional rough:  The rough passes alternate between climb milling 
and conventional milling.  When cutting a Boss feature on a square block, 
the cutter cuts across the corners first. When climb milling is selected in the 
strategies, the first pass is a climb cut, and then the tool alternates with 
conventional milling until the corners are finished. The cutter finishes the 

roughing cuts using climb milling. 

 Use finish tool:  When rough and finish milling, FeatureCAM uses the 
same cutter to rough and finish.  When Use finish tool is checked 
FeatureCAM will always add a second tool to do the finish operation. 

 Cutter Comp:  Whether cutter comp is selected or not FeatureCAM offsets 
the tool by the radius of the tool.  By selecting Cutter comp, it adds the 
necessary G40, G41and G42 to the NC code so the tool size for holding 
tolerances may be adjusted with the tool offset in the control by the user. 

 Part line program:  Instead of the cutter center being offset by 
FeatureCAM the program aligns the center of the tool on the curve. The 
NC code reflects this with the print dimensions.  All of the offsetting is done 
by the machine control. 

 Minimize tool retract:  For use when it is more desirable to feed the tool 
to another region of a feature instead of retracting and plunging. For 
example: in a pocket with islands, minimize tool retract will keep the tool 
from retracting and plunging. 

 Individual rough levels: Many roughing cuts are performed at multiple Z 
levels due to the depth of the feature. If you select Individual levels on the 
Strategy page, you will be able to customize the manufacturing attributes 
of each level. If you have a feature that is roughed in four levels there will 
be four z-levels listed in the feature instead of one. Note that each pass is 

listed underneath the rough operation. By clicking any of the passes, you 
can set attributes in the Milling tab.  If Individual level is not selected, then 
only the rough pass is listed in the tree view and you can only make changes 
to Milling tab attributes that will apply to all levels.  Individual levels also 

controls clipping of boss and side features against the stock model including 
both STL and solid stock models. With this attribute selected, the toolpaths 
are clipped against the stock boundary at each Z level. 
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 Depth-first machining:   Selecting the Depth first option will cut each 

region of the feature completely before moving on to another region. The 
toolpaths descend in Z. If this option is deselected, then all regions of a 
feature are cut at one Z level before descending to a deeper Z-level.  If you 
are using multiple roughing tools or multiple finishing tools, to efficiently 

rough out tight corners, Depth first is also useful.  The second tool that 
roughs the corners only will cut each corner to depth before retracting and 
moving to the next corner. 

 Reorder:  (Surface Milling) The Reorder attribute tells FeatureCAM to re-
sequence the toolpaths to minimize retractions while trying to avoid full 
width cuts. Use Reorder when you have a part where several separate 
regions are cut. If you want the toolpaths to move directly across a surface 
without worrying about retractions, deselect Reorder. 

 For Z-level operations (rough or finish), the Reorder attribute enables zone 

machining where the toolpaths descends in the Z (or -Z) direction. Use this 
if it is more efficient than cutting the entire part in complete Z levels. The 
phone handset example below shows that the toolpaths cut the top of the 
part in complete Z levels and then cut one side and the other. 

 

 Side roughing bottom up:  A 2.5D feature with a Draft Angle may be 
roughed from the bottom up instead of the normal top down.  

 Side finishing bottom up:  A 2.5D feature with a Draft Angle may be 
finished from the bottom up instead of the normal top down. 

 Toolpath corner (%):  This attribute rounds the corners of milled roughing 
passes. It is specified as a percentage of the tool diameter. Rounding the 
sharp corners of the toolpaths provides a more constant tool velocity and 
reduces the tool load. 

 It applies to all 2.5D milling features. The left figure shows a pocket without 
Toolpath corner % set and the right is set with Toolpath corner set to 98%: 
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 Use alternative 5 axis position:  Depending on the type of 5-Axis 
machine you are working with, there are often two ways of orienting the 
machine axes to address a particular face.  

 Hi speed machining technique.  The first rough Tool path corner at 500% 
flattens the tool path, usually faster feeds and speeds.  The second rough 
Tool path corner at 25% cleans up only what the first rougher left. The 25% 
value helps smooth out some of the sharp corners, but must not be too 
large, or there might be an excessive amount for the finishing tool.   
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 Trochoidal cut:  Simple grooves have an option of using a Trochoidal 
toolpath. Instead of a simple slotting cut, the tool uses a series of circles to 
clear away the metal, as shown. This toolpath has the advantage of 
maintaining a constant radial depth of cut which produces the same load on 
the tool at all times. 

 

Step over Tab 

 (Rough Pass) 

 Do rough pass creates a rough operation for ALL milling features. 

 Depth in the Z direction is a % of the diameter of the cutting tool for each 

pass.  

 Spiral is the Tool motion offset from the curve shape and the tool steps 
over as it moves radially toward the curve, this step over is a % of the tool 
diameter. (33% or less is recommended) 

 Zig-zag is how the tool travels parallel to X or Y or at an angle, the radial 
step over is a % of the diameter of cutter.  (Up to 55% is recommended) 

 (Semi-finish Pass) 

 Do semi-finish pass is selected if an additional finish pass is needed before 
the final finish pass and will be applied to all milling features. 

 Allowance is the amount of material left for the finish pass. 

 Bottom Allowance, if required, is the amount left on the bottom for the 
finisher to remove. 

 (Finish Pass) 

 Do finish pass is selected if a finish pass is desired and will be applied to 
all milling features. 

 Allowance is the amount left by the rougher for finishing. 

 No. of Passes made by the finish tool, additional passes may be added, 
they are considered spring passes the tool does not move in any further 

then the finish curve. 

 Overlap is the amount from where the tool ramps on for the finish cut and 
where it ramps off when complete.   

 Finish bottom is selected if fishing the bottom of the feature is desired and 

Wall pass is checked if it is to be included. 

 Spiral is the type of finish toolpath with a % of the tool diameter, radial 
step over.  
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 Zig-zag is the type of finish toolpath with a % of the tool diameter, radial 
step over.  

 Bottom allowance is the amount of material left by the rougher when 
finish bottom is selected.  

Lead/Ramp Tab 

 (Horizontal lead/ramp) 

 Extension distance pertains to Lead moves for cuts with open ends.  In 

the milling feature on the stepover tab, there are settings to extend the lead 
onto the feature without having to extend or change the feature.  An arc 
ramp may be added and a 90 degree approach that is perpendicular to the 
arc may also be included. 

 Lead distance is the distance the tool plunges from the end of the curve 
and is measured in a % of the tool diameter. 

 Lead in angle is the angle to the curve that the tool approaches the feature 
after plunging.  A 90 degree Lead in is perpendicular to the curve. 

 Lead out angle is the angle to the curve when the tool exits the feature 
before retracting.  A 90 degree Lead out would be perpendicular to the 
curve. 

 All Stepover applies the Lead in and Lead out to every step over. 

 Ramp type is the shape of the transition move when the tool steps over 
radially.  They include Direct (90 degrees) Arc, Line and S-shape.  S-shape 
provides very smooth transition, good for hi-speed machining. 

 Ramp diameter is measured as % of tool diameter and determines the arc 
size for the radial step over. 

 Minimum ramp distance controls the length of the ramp. 

 Wind fan finish plunges and retracts the finish tool in the same place and 

ramps on and off the finish curve in the same place with no overlap.   The 
arc size for ramping may be entered along with the angle move to the arc.  
To watch this in centreline simulation, it looks like a fan you would hold in 
your hand.  

 (Vertical ramp) 

 Minimum Z ramp dist. is the allowable minimum distance (radially) when 
ramping has been selected.  It may be 0 and if the tool doesn’t fit when 
ramping FeatureCAM will plunge straight down with no ramping to attempt 

to make it fit. 

 Max ramp angle is the maximum vertical angle the tool is allowed to 
plunge (rough op) 

 Max finish ramp angle is the maximum vertical angle the tool plunges 
(finish op) 

 Helical Ramping is a technique that plunges the tool into the material in a 
helical (circular, like a screw) motion and may be CW or CCW.   

 Linear Approx. may be used when helical is not applicable.  It uses short 

linear moves for the helical motions instead of arcs. (also thread milling) 

 Ramp diameter is the radial size of the helical arc that is used. (thread. 
milling) 

 (Arc lead)  
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 Arc lead, Use 90-deg Comp on/off and Distance are associated with 

Extension distance and pertains to Lead moves for cuts with open ends. 

Misc. Tab 

 Z rapid plane is the distance measured in the Z positive direction that the 
tool retracts to when either moving to the next hole for drilling or moving 
to another region to continue milling and usually considered a safe height 
for clearance of clamps, etc. 

 Plunge clearance is the distance in the Z direction above the part that a 
tool will rapid to and then go into feed rate to plunge or drill to depth. 

 Tap plunge clearance has the same purpose in a tap operation as for 
drilling and milling. 

 Z ramp clearance is the distance above the part in the Z direction that a 
milling tool feeds straight down to after plunging to the plunge clearance 
when ramping is being used so it doesn’t ramp above the part. 

 Spline Tolerance parameter controls the maximum deviation of the 
generated tool path from the theoretical spline contour. 

 Z index clearance is applicable on 4 axis indexing parts.  When for example 
a square part is indexed on a 4th axis table FeatureCAM takes into account 
the corners being higher than the flats during index and retracts the tool to 

the Z index clearance height above the corners which is safe for the corner 
to index under any tool. 

 Wrap tolerance also applicable to 4th axis parts.  Certain features can be 
created flat as normal and then wrapped around a cylinder on a 4 axis rotary 
table and this tolerance setting determines how close. 

 Chamfer depth is how far the point of the chamfer tool goes past the 
bottom of the chamfer on the part.  This is to make sure the point of the 
tool uses the full length of the cutting edge and not give a burr along the 
bottom edge because the point of the tool is possibly not sharp to the end. 

 Deburr radius is automatically applied to a sharp outside corner to remove 
the burr, for example on a boss feature where there is no radius on the 
corner.  It can be any size and if there is any radius whatsoever on the curve 
of the feature then FeatureCAM ignores the Deburr radius and the curve 

radius is applied instead. 

 Minimize corner radius is used to restrict the maximum size tool that 
FeatureCAM will pick when there is a square inside corner with no radius.  

 Minimum rapid distance is the distance determined by a percentage of 
the tool diameter as to whether the tool will feed or retract and rapid to the 
next region to be machined.  The smaller the setting the more retracting, 
the greater the number then it will feed to the next area to be machined.  

 Speed is the percentage of programmed spindle speed that the spindle will 
run in the program.  

 Feed is the percentage of programmed feed rate the tool will feed in the 
program. 

 Plunge feed is the percentage of the programmed feed rate that the tool 
will feed when plunging. 

 Use IPR/IPT will use inches per revolution or per tooth instead of inches 
per minute (IPM). 
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 Proportional plunge feed when selected determines the milling plunge 
feed rate according to the angle of ramping while plunging.  The steeper the 
angle the slower the feed rate and the more shallow the angle the higher 
the feed rate.  

 Peripheral Feed has various settings for inside and outside corners during 
milling to slow or increase the feed rates to help maintain a more consistent 
tool load and obtaining the optimum feed rate. 

 Post Variables provides the opportunity to pass data directly to the NC 
code in designated locations as laid out by the post variables built into the 

post processor. 

Operations Tab 

(Ordering) 

 Automatic Options has four functions: 

1 Minimize tool changes attempts to optimize tooling to do all the work for that 
tool on the entire part before changing tools, especially helpful when one tool 

can be used on several functions or features including 4th axis, more indexing 
and less tool changes. 

2 Do finish cuts last allows all of the roughing of milling features to be 
completed first and then does the finish cuts to avoid any possible movement 

of the part after a finish cut has been completed. 

3 Cut higher operations first completes for example a pocket with drilled holes 
in the bottom, pocket first then the drilled holes. 

4 Minimize rapid distance helps to find the most efficient path for the tooling by 
examining the distance of each move and then picking the shortest distance.   

 Base Priority is when you want to ensure that an individual feature is cut 
before anything else, you can set its Priority attribute in the Misc. tab. All 
features have a Priority manufacturing attribute. By default, the value is 10. 

To make sure that a feature is manufactured first, set its priority to a lower 
value and to make a feature last, set its priority to a higher value. For 
example, if you set the Priority of a pocket to 8, its roughing pass is the 
first operation performed, its finish pass is second, and the rest of the 
operations are ordered according to the scheme described above. 

 While you can specify the exact order of every feature by priority, you 
shouldn't do so casually because you lose the automatic optimization 
sequences built into FeatureMILL. It's harder to maintain or change the part 
too. 

 Time estimation has six settings including indexing speed of the 4th axis 
rotary table.  If care is taken to enter accurate figures, a very close 
estimation of the actual time it will take to run your part, excluding any 
operator intervention can be achieved.  A stop watch may have to be used 

instead of accepting speeds from manuals. 

Facing 

 Do rough pass when roughing passes are desired. 

 Do finish pass when a finish pass is desired?  May be used without rougher. 

 Finish allowance is the amount of material left by the roughing operation. 
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 Facing stepover is the radial step over perpendicular to the cut direction 

measured by a % of the cutter diameter. 

 Lateral overcut is how far, measured by a % of the cutter diameter, that 
the tool goes off the end of the part parallel to the direction of the cut. 

 Last pass overcut is how far by a % of the cutter diameter, that the tool 
goes off the part radially perpendicular to the cut direction on the final pass. 

 Max depth of cut is the maximum Z increment depth the cutter will take in 
one pass. 

 Connect stepover with arc provides a very smooth transition by changing 
the direct 90 degree stepover to an arc or loop.  This is also a high speed 
machining technique.  

 Zigzag angle is the angle that FeatureCAM uses to cut Face features. 

Tool Selection 
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 Counter bore: - will select a specific diameter counter bore tool.  An 
inventory of various sizes of counter bores is usually maintained. Counter 
Bore Eliminates an inventory of counter bore tools and can cut any size. 

 Automatic selects Endmill when counter bore tools are being used and the 
desired counter bore size is not available. 

 Spot Drill: - Prefer spot drill is used to cover a wider variety of hole sizes 
because it has one diameter and comes to a point. 

 Prefer center drill is usually selected for spotting a hole to be drilled, short 

and makes the initial plunge into the material with no wandering or 
movement. 

 Preferred spot drill diameter allows a specific size spot drill to be selected 
on ALL holes.  Size may be changed when needed. 

 Optimize spot drill tool selection will attempt to use a tool that will satisfy 
All holes when there is a variety of sizes to be drilled.  If attempting to 
chamfer holes when spot drilling one tool may not satisfy and an additional 
tool may be selected.   

 Optimize chamfer tool selection will attempt to use a chamfer tool that 
will satisfy All holes when there is a variety of sizes to be chamfered.  

 Tool diameter tolerance is a value not to exceed when selecting tools, for 
example, if the tolerance is set to .002 then if FeatureCAM doesn’t find a 

tool plus or minus .002 of the needed size it will show a red flag next to the 
operation indicating it doesn’t have a tool within the tolerance. 

 Drill % of ream/bore determines the size of the drill to be used for a ream 
or bore operation. 

 Thread % for tap drill (cut) determines the size of the drill to be used for 
the tapping operation to obtain a specific % of thread (example 77%) 

 Thread % for tap drill (rolled) determines the size of the drill to be used 
for the tapping operation to obtain a specific % of thread (example 65%).  

Rolled threads drilled hole size is very important because the thread is 
formed and material is pushed down into the root of the tap and if the hole 
is to small it will break the tap and if too large there is not enough to form 
an accurate thread.   

 Tap type lets you select the type of tapping you do most.  

 Tool % of arc radius (also Toolpath corner % in milling tab) is set to 100 
then a tool equal to the smallest corner radius is selected for a feature such 
as a pocket.  With Toolpath corner% set to 100 the tool dwells in the corners 

as it changes direction. This can sometimes nick the part. To avoid this 
problem, set Toolpath corner % to a slightly smaller number, such as 98. 
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 Multiple Roughing Tools gives you the opportunity to allow FeatureCAM 

to select additional roughing tools when, for example, you have a pocket 
with small radius corners and FeatureCAM chooses to rough the entire 
pocket with the small cutter.  When selecting Use multiple roughing tools 
from largest to smallest, stopping when the material is gone, you enter tools 

that you want FeatureCAM to select from when multiple cutters are 
necessary to make the operation efficient.  Starting with the largest tool and 
adding smaller tools separated by a comma, FeatureCAM will start with the 
largest tool that will fit.  It will also select a rougher that fits the corner so 
there will be the same amount of leave allowance in the corners as there is 
along the straights.  You may also restrict the minimum size tool to use as 
a rougher.  Remember though that if you are running small parts with small 
tools you may have a tool needed in your tool crib for a specific operation 
but it will never select it for roughing if it is smaller than the minimum tool 
diameter. 

 

Holder Clearance 

Use the Tool Holder Clearance dialog to specify an additional clearance for 
FeatureCAM's automatic tool selection to prevent tool holder gouges. 
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To specify a tool selection clearance: 

 In the Clearance Requirement list, select the clearance you want 
between the tool holder and the part. Select from: 

 None — select this option to leave no additional clearance. Old part 
files select the same tools as before. 

 Feature — Select this option to ensure the tool is long enough for the 
tool holder to clear the feature. 

 Setup — Select this option to ensure the tool is long enough for the 

tool holder to clear the total depth below the setup. 

 Stock — Select this option to ensure the tool is long enough for the tool 

holder to clear the total depth into the stock. 

 Enter an Extra allowance as a % of feature or setup depth to leave extra 
clearance of the tool holder above the feature, setup, or stock 

 Select how tool selection is affected if no matching tool is found: 

 Give an error if no tool meets requirements — FeatureCAM does not select 

a tool for the operation, so an error is shown during NC code generation. 

In the Operation List, a red exclamation point  is displayed beside 

operations with no tool selected. 

 Select tool closest to requirements if none match — this enables you to 
generate NC code, but it may result in tool holder gouges because a 
smaller tool may be used. 
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Surface Leadin 

Stepover type is the transition move the tool makes radially to make the 
next pass (usually bi-directional) this is perpendicular to the tool path 
direction. 

1 Direct is two 90 degree turns, stopping twice to change direction of 
180 degrees. 

 

2 Loop is a smooth rounding transition which does not stop to change 
direction.  Good hi-speed technique. 

 

 

(Lead-in/out parameters) 

 Use lead-in/out:  Never provides any leads, it uses plunge 
clearance and plunges to depth. 

 

 On all plunges/retracts or on first plunge/last retract applies 
the lead type, line or arc, to every plunge and retract or the first 
and last only.  
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 On all stepover, plunges & retracts applies the lead type to 
every transition move the tool makes. 

 

Surface normal applies the leads normal to the surface whether 
horizontal or vertical. 

Use arc ramp-in/out allows you to choose the ramp diameter and the 
ramp in/out angle. 

Use linear lead-in/out allows you to choose the lead-in/out angle and 
the lead-in/out length.  

Surface Mill Tab 

 Tolerance (Rough .005) (Finish .001) sets how close the milling will be 
to the mathematically ideal surface. This does not guarantee that your 
feature is machined to this tolerance in all locations if the tool you select is 
incapable of cutting within that tolerance in constrained areas. If your part 

shows a faceted appearance, set the tolerance to a lower value. 

 Scallop height stepover is the height between passes of a Ball End Mill 
for isoline milling, projection milling finishing passes and Z-level finishing. 
This distance is measured along the surface and represents the maximum 
cusp height between neighbouring passes as shown here.  The scallop height 
and stepover default values may also be entered but can be entered or 
changed in individual features also. 

 Parallel angle refers to parallel tool path strategies.  The value of 0 causes 
the tool to travel parallel to the X or to the Y axis. 

 Tool diameter allows a default tool diameter to be selected for Surface 
Milling 

 Tool end radius provides the opportunity to select the default for the cutter 

end, Ball, Flat or Bull Nose and also the diameter. 

 Finish allowance is the amount of material left by the rougher for the 
finisher to remove. 
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 Check allowance is how far away you wish the tool to stay away from 

selected surfaces or faces. 

 (Slope limitation angles) 

 Horizontal only cuts horizontal surfaces up to a desired slope angle. 

 Vertical only cuts vertical surfaces above a desired slope angle. 

 Swarf axial tolerance is for a relatively rare number of geometries where 
the tool axis can waver slightly as it positions accurately on the surfaces to 
be machined. This can be due to small but significant changes in the 

geometry as the tool moves from one position to another. To allow a degree 
of latitude for the command, this tolerance can be set to a value larger than 
the machining tolerance to allow the tool axis to be stabilized as it moves 
across this geometrically varying region. As a result excess material may be 
left on the surface involved but the load on the tool may be reduced. 

 

Edges contain four choices as to how you want the tool to react when it 
comes to the edge of a surface or face at the stock.   

Automatic, depending on the toolpath strategy being used, does much like 
don’t roll over the edges at all and therefore calculates a boundary but if a 
different boundary is used such as a curve, FeatureCAM won’t calculate for both. 

Don’t roll over the edge at all cuts 100 percent cleanly to the edge but does 
not roll over the edge. 

Cut top edge: Just roll over the top edge allows the ball only to roll over the 
edge.  

Cut to bottom:  Roll over the top edge and cut to bottom of stock/part basically 
turning off all boundaries and letting the tool cut until it runs out of part or 
stock. 

Thread Mill 

 (Wind Fan)  

 Wind fan is the same as a milling feature, it can plunge and retract and feed 
on and off in the same location plus the angle of approach and the ramping 

radius. 

 Linear ramping may also be applied using ramp distance, diameter and 
angle offset. 

 Feed direction can be either Negative Z or Positive Z. 

 Feed overrides for ramp in and ramp out. 

 Passes for Rough and Finish with Rough Stepover, Finish allowance and 
Spring passes.  

 Starts may be multiple if desired. 

 Start angle can be entered if necessary. 
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 Tooth overlap attribute controls the amount that one revolution of a multi-
thread tool will overlap the previous revolution. It is an integer that 
represents the number of threads. We recommend that you overlap at least 
one thread. 

 Tooth outside is the number of teeth that will be above (if feeding in 
negative Z) or below (if feeding in positive Z) the thread mill feature for the 
first pass. 

 Taper approx. angle is for tapered threads.   The toolpath is increasing in 
diameter as well as moving in Z. These moves are approximated with 3D 

arcs. The Taper approx. angle is the angle around the thread that will be 
approximated by a single arc. A 360 must be evenly divisible by the Taper 
approx. angle. For example, if set to 90, a single revolution of the tool will 
be broken into 4 arcs. 

 Feed to depth override may be set to a desired feed rate. 

 Linear Approx. attribute is associated with Helical ramping and Thread mill 
features. If Linear approx. is selected, then the arc moves are approximated 
by linear moves. Helix linear approx. tolerance controls how accurate the 

approximation is relative to the theoretical spiral. Set this tolerance to a 
smaller number to more accurately approximate the spiral. 

 Cutter comp to apply G40, G41 and G42 to the NC code so the control can 
adjust size with tool offset. 

 Part line program puts the center of the tool on the finish curve and the 
NC code reads to print dimensions and all offsetting is done by the control. 

 Through for thread milling is set if there is no material on the bottom of 
the thread. If Through is not set, the toolpaths will be generated to ensure 
that the tool will not cut past the end of the thread. 

 Use Finish Tool allows a separate tool to be used as a finisher. 

 Plunge to center plunges the tool on the center of the hole to assure 
clearance. 
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Cutter Compensation explained 

No Cutter Compensation (Information Only) 

 The following examples will explain the three main differences when using 
Cutter compensation. To make this example easy to follow. We have created 
a 100mm x 100mm x 25mm Block. We will be using an 18mm diameter 
cutter. When we look at the code output it will be obvious which strategy is 

used by looking at the cnc code. 

 The Post processor used is a Fanuc Robodrill.cnc to view the code output. 

 The first example will have No Cutter compensation active. (see image) 
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 This code output allows for the diameter of the cutter in the toolpath with 
No cutter compensation (G41/G42) 

 

 Code output Millimeters. This code output allows for the diameter 
of the cutter in the toolpath. Code is output with No cutter 

compensation. 

 
% 

O0001 

( FINISH  SIDE1 ) 

N25 G0 G40 G49 G80 G90 

N30 T1 M6 

N35 G54 X50.0 Y-19.0 

N40 M03 S5390 

N45 G43 H1 Z26.0 M8 

N50 Z3.0 

N55 G1 Z-25.0 F1164.24 

N60 X59.239 Y-15.173 F2328.48 
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N65 G3 X50.0 Y-9.0 I-9.239 J-3.827 F1225.52 

N70 G1 X0. F2328.48 

N75 G2 X-9.0 Y0. I0. J9.0 F3492.72 

N80 G1 Y100.0 F2328.48 

N85 G2 X0. Y109.0 I9.0 J0. F3492.72 

N90 G1 X100.0 F2328.48 

N95 G2 X109.0 Y100.0 I0. J-9.0 F3492.72 

N100 G1 Y0. F2328.48 

N105 G2 X100.0 Y-9.0 I-9.0 J0. F3492.72 

N110 G1 X50.0 F2328.48 

N115 G3 X40.761 Y-15.173 I0. J-10.0 F1225.52 

N120 G1 X50.0 Y-19.0 F2328.48 

N125 G0 Z26.0 

N130 X19.0 Y50.0 

N135 Z3.0 

N140 G1 Z-25.0 F1164.24 

N145 X15.173 Y40.761 F2328.48 

N150 G2 X9.0 Y50.0 I3.827 J9.239 F1225.52 

N155 G1 Y91.0 F2328.48 

N160 X91.0 

N165 Y9.0 

N170 X9.0 

N175 Y50.0 

N180 G2 X15.173 Y59.239 I10.0 J0. F1225.52 

N185 G1 X19.0 Y50.0 F2328.48 

N190 G0 Z26.0 

N195 M5 

N200 M9 

N205 G91 G28 Z0. 

N210 G90 G49 

N215 M30 
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Finish Cutter Comp (Information Only) 
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 Code output Millimeters. This code output allows for the diameter 

of the cutter in the toolpath. Code is output with cutter compensation 
(G41/G42) 

 
% 

O0001 

( FINISH  SIDE1 ) 

N25 G0 G40 G49 G80 G90 

N30 T1 M6 

N35 G54 X50.0 Y-19.0 

N40 M03 S5390 

N45 G43 H1 Z26.0 M8 

N50 Z3.0 

N55 G1 Z-25.0 F1164.24 

N60 G41 D1 X59.239 Y-15.173 F2328.48 

N65 G3 X50.0 Y-9.0 I-9.239 J-3.827 F1225.52 

N70 G1 X0. F2328.48 

N75 G2 X-9.0 Y0. I0. J9.0 F3492.72 

N80 G1 Y100.0 F2328.48 

N85 G2 X0. Y109.0 I9.0 J0. F3492.72 

N90 G1 X100.0 F2328.48 

N95 G2 X109.0 Y100.0 I0. J-9.0 F3492.72 

N100 G1 Y0. F2328.48 

N105 G2 X100.0 Y-9.0 I-9.0 J0. F3492.72 

N110 G1 X50.0 F2328.48 

N115 G3 X40.761 Y-15.173 I0. J-10.0 F1225.52 

N120 G1 G40 X50.0 Y-19.0 F2328.48 

N125 G0 Z26.0 

N130 X19.0 Y50.0 

N135 Z3.0 
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N140 G1 Z-25.0 F1164.24 

N145 G42 D1 X15.173 Y40.761 F2328.48 

N150 G2 X9.0 Y50.0 I3.827 J9.239 F1225.52 

N155 G1 Y91.0 F2328.48 

N160 X91.0  

N165 Y9.0  

N170 X9.0  

N175 Y50.0  

N180 G2 X15.173 Y59.239 I10.0 J0. F1225.52 

N185 G1 G40 X19.0 Y50.0 F2328.48 

N190 G0 Z26.0 

N195 M5 

N200 M9 

N205 G91 G28 Z0. 

N210 G90 G49 

N215 M30 

% 
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Partline program with Finish Cutter Comp 
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 Code output Millimeters. This code output Does Not allow for the 
diameter of the cutter in the toolpath The code is output with cutter 
compensation (G41/G42) 

 

% 
( FINISH  SIDE1 ) 
N25 G0 G40 G49 G80 G90 
N30 T1 M6 

N35 G54 X50.0 Y-19.0 
N40 M03 S5390 
N45 G43 H1 Z26.0 M8 
N50 Z3.0 

N55 G1 Z-25.0 F1164.24 
N60 G41 D1 X67.554 Y-11.729 F2328.48 
N65 G3 X50.0 Y0. I-17.554 J-7.271 F1225.52 
N70 G1 X0. F2328.48 
N75 Y100.0  

N80 X100.0  
N85 Y0.  
N90 X50.0  
N95 G3 X32.446 Y-11.729 I0. J-19.0 F1225.52 
N100 G1 G40 X50.0 Y-19.0 F2328.48 

N105 G0 Z26.0 
N110 X19.0 Y50.0 
N115 Z3.0 
N120 G1 Z-25.0 F1164.24 

N125 G42 D1 X11.729 Y32.446 F2328.48 
N130 G2 X0. Y50.0 I7.271 J17.554 F1225.52 
N135 G1 Y100.0 F2328.48 
N140 X100.0  
N145 Y0.  
N150 X0.  
N155 Y50.0  
N160 G2 X11.729 Y67.554 I19.0 J0. F1225.52 
N165 G1 G40 X19.0 Y50.0 F2328.48 
N170 G0 Z26.0 

N175 M5 
N180 M9 
N185 G91 G28 Z0. 
N190 G90 G49 
N195 M30 
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Speed Reduction on Corners. 

 Automatic speed reduction in corners is standard on all toolpaths. To 
access the settings for this option go to Machining Configurations/Misc 
then Peripheral Feed. 
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Options/Feature Recognition 

 Considerations when using Feature Recognition. 

 

 Please select the following options. Create hole as pattern. All 
similar holes will be grouped into a Pattern. This allows you to change 
one feature depth and all holes in that pattern are then changed. 
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Feature Recognition for Milling 

Introduction 

 This Module will provide an introduction to FeatureCAM’s Feature 
Recognition capabilities. When this module is complete you will 
know how to perform Automatic Feature Recognition (AFR), and 

Interactive Feature Recognition (IFR) and Feature Re-
recognition. 

 

 

 

Important things to consider when using AFR 

 The way AFR works is that it examines the model and looks for any 
flats on the part in Z axis.  AFR creates features by dividing the model 
into horizontal slices at these flats and automatically determines side 
control. 

 Any features (excluding holes) remaining will be cut using surface 
milling (if checked in the AFR Options) Notice that AFR creates a 
set of features that will completely cut the solid, but it may create 
more features than you might create if you have modeled the 
features yourself. 
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 The advantage of this method is that a part may be programmed 
quickly as it requires minimal user input.  This method could be useful 
for quickly programming prototypes, or to help users new to 
programming in FeatureCAM.  It can also be used by experienced 

users to create curves or to help get a better idea on how to cut the 
part 

 The disadvantages of this method are that the most efficient toolpath 
may not be created and the features created may not be exactly the 

way the programmer is used to cutting the part. 

 One last thing to remember is that a solid is required to run AFR.  
The reason for this is so that AFR is able to properly recognize side 
control and will cut on the correct side of the part. 

What is a Feature? 

 Features are the intelligent core entities that a machinist would use to make 
a certain shape in the material they are cutting.  Shapes such as a Hole, 
Boss, Slot, etc. Features are used to make toolpaths in FeatureCAM to 
create these shapes.  Features may consist of several operations to create 
the final result or shape.  These may consist of several operations including; 

Spot Drill, Centre Drill, Drill, Pre-Drill, Tap, Roughing, Semi-Finish 
and Finish Passes. FeatureCAM takes, for example, a tapped hole and 
combines the operations like the centre Drill, Drill and Tap and 
automatically selects the necessary Tooling, Feeds, Speeds, etc. 

What is Feature Recognition? Why is it necessary? 

 Feature Recognition has the ability to extract manufacturing 
Features and associated operations from an existing Solid or 

Surface model.  Geometry, Curves, and dimensional input are not 
required as this information is automatically extracted out of the 
design model. 

 Feature Recognition is beneficial to production for several reasons, 
the first being that the CAD data available is just a collection of 
surfaces and faces.  The CAD data (surfaces and faces) needs to be 
interpreted by the CAM software so useful features and subsequent 
operations may be Collected from this data to manufacture a part.  

For example Holes in a solid are just cylinders and a Pocket in a 
solid is just a collection of faces. 
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 The second reason Feature Recognition is beneficial to production 
is that in modern manufacturing the majority of the design software 
is used for part design is solid or surface based.  This valuable 
information contained in the model file has already been entered by 
the CAD engineer, why should the machinist re-enter information 
that is already available in the model?  A review of the manual process 
is listed below, which can show the process to be quite lengthy: 
 

1 Create Geometry 

2 Create Curves 

3 Select Feature Type 

4 Select Curve 

5 Specify Depth 

6 Enter manufacturing information 

7 Obtain wireframe visual display 

8 Obtain Feeds and Speeds, tools, toolpaths and NC code 

 

 The third reason Feature RECOGNITION is of benefit is that re-
entering the model data by the machinist is error prone as the model 
information needs to be completely re-entered. 

How does Feature Recognition Work? 

 There are two different types of Feature Recognition (FR) Automatic 
Feature Recognition (AFR) and Interactive Feature Recognition 
(IFR).  Both tools search the CAD data for (Pockets, Sides, Holes, 

Surfaces and Faces) and match them to FeatureCAM’s features so 
manufacturing operations may be generated.  These two techniques use 
different algorithms for identifying features.  Descriptions of the algorithms 
used will be described below. 

Requirements for FR 

1 In order to use Feature Recognition a Solid Model is required.  There are a 
wide variety of different formats that are supported: 

2 Igs, Acis, Parasolid, SolidWorks, Inventor, SolidEdge. 

3 Optional (Extra Cost) import plugins: Catia V4 & V5, Step, Unigraphics and 
Creo. 

4 There are several ways that the model can be imported directly into 
FeatureCAM. 

5 Click on File> Import. 

6 Locate the file, left click on the file to import, Alternatively hold the left 
mouse button down then drag and drop the file into FeatureCAM’s 
Graphics Window from any folder where the model resides (except a zip 
folder). 
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Importing a file one Setup. (Class Exercise) 

 When you import a file, FeatureCAM steps you through its Import 
wizard. The Import wizard pops up automatically and assists you 
in importing the file into FeatureCAM.  This wizard helps to: 

1 Import the file into FeatureCAM. 

2 Sizes the stock. 

3 Orientates the stock allowing for additional material if required. 

4 Positions the part program zero point. 

5 Sets up a milling part for indexing. 

6 For some solid formats, it even helps you recognize and suppress part 

features. 

AFR Example #1 (Class Exercise) 

1 Open a New Part Document. 

 

2 Select Milling Setup and select your Unit of Measurement in our case this is 

Millimetre then press OK. Select Cancel for Stock defaults. 

3 Click on File>Import. Under Files of type at the bottom of the screen select 
Parasolid (*.x_t, *.x_b). The file is called ex02ex02 Metric. X_t. 
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4  Find the file in C:\Training_Data\FeatureCAM Course Data 
2017\Milling Files to import.  

 

Import Results Wizard 

 

1 Import Results - Use the wizard to establish the initial setup location 
and stock size, this will be checked automatically then check the “Launch 
AFR after finish”.  

2 Select Next. 
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 To aid in aligning the model, when the model is first brought into the 
Graphics Window, right click and select View Top or Isometric and 
Shade the model so you can see how it is positioned in the window. 

(Shade-upper tool bar-button with two little Red Barrels)  

 Because the CAD model may have been saved in a position that is 
not aligned with your Z and X axis, FeatureCAM in the Pick Initial 
setup Z Direction form provides five tools to assist in aligning the 

model in the Z and X directions, which in turn aligns to the machine 
Spindle, Table Axis. 

 This model is not aligned correctly as you can see from the image 
on the previous page.  The model has been rotated 30 degrees in 
Z and 10 degrees in X.  

3 Select Next. 

4 The model needs to be aligned. Select - Pick two points to define Z 

direction. 
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5  Click twice on a vertical surface edge, starting low  then the second click 

at above will point to the spindle. 

6 Or you could use Align Z perpendicular to a horizontal surface.  Click on 
any known face that is flat and horizontal that you wish to be perpendicular to 
the spindle. See example below. Use this method to align the Z Axis. 

 

 

 Other options are available for example Align with centre of a 
revolved Surface such as a hole by selecting the arrow and clicking 
on the round surface. Can be used even when geometry alone is 
imported by clicking on the defined geometry. 

7 Select Next 
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8 Pick Initial Setup X Orientation offers assistance to align the setups X 
direction.   

9 Please select Pick two points to define X direction. This works the same as 
the Z, except the edge you click on will be parallel to the table X axis. 
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10 More Orientation options are available for example; you can rotate the X 
direction 90 degrees around Z axis. This will rotate the model 90 degrees 
for each click; three times will rotate 270 degrees.  

11 Select Next. 

12 Stock type gives you the choice of Block, Round or N-Sided such as 
hexagonal stock. Select Block and select Next. 

 

13 On the Stock Dimensions page check the radio button, compute stock size 
from the size of the part.  Enter dimensions as shown below. 
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 The Values above are Metric we have allowed 5mm for each side 
edge. We also have 1mm for Z+ Stock and 5mm for the –Z stock 
to hold in the Vice. 
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14 Select Next. 

15 Pick initial setup XYZ Location on the next form to appear. Please select 
Centre of revolved surface edge. 

 

 

16 Change the Z value from -17.066 mm to -1mm. 



 
 
Feature Recognition 

                           

 

      
Autodesk FeatureCAM 2017    

© Copyright 2016 Autodesk, Inc. All rights reserved           8.13 

17 Select Next. 

18 On the Is Part Indexed? Page choose No. This means it is only a 3 Axis 
part. Select Finish. 

 

 

 Because the “Launch AFR after Finish” box was checked on the 
initial Import form, the Automatic Feature Recognition pops up. 
It then identifies the solid just imported. 

 Please note we are only using One Setup for this job as there are 
no features to be machined on the opposite side. 

19 The Feature Recognition Wizard will go through and recognise features in 
Setup1. 

20 The AFR Wizard will guide you through the next process. 
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21 Select Next. 
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22 Select Finish. 

 Select Options>Feature Recognition. These options set how AFR 
will be performed. 
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 If for some reason the Feature Recognition fails. Try using the 
Edge-based FR. This could give you better results. 

23 Click OK for options and select Next. 

24 Setups can recognize multiple setups. Select Finish accepting all features. 

25 Run the 3D Simulation. 

26 If you see a gouge you will need to change the Automatic Ordering to Cut 
Higher Operations First. 

 

 See Automatic Ordering Options on the next Page. 

 

 All Features, tooling, feeds and speeds, coolant, depth of cut and 
Step overs, etc. have been created for the entire part in this Setup. 

 See finished image on the next page. 
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27 Click on File then Save as and use Windows Explorer to navigate to the Folder 
where your Instructor placed the files for your course. Name the file ex02ex02 
Metric.fm 

28 To output the NC Code make sure you have selected the correct Post and 

Tool Crib. For example.  

29 Go to File>Save NC. Select the directory of your choice to output the NC 
Code. 

30 Select OK. 
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IFR (Interactive Feature Recognition) 

IFR Example #1 

 IFR has three types of strategies available IFR Automatic by feature 
type, IFR using surfaces or faces and IFR chaining. 

 IFR Automatically examines the model for a particular feature such 
as a side, pocket, face, slot, hole and boss.  Side, pocket and boss 
features are not created using AFR side features but separate side, 
pocket and boss entities. 

 IFR using surfaces or faces extracts information about the 
highlighted entities extracting depth and feature contour. 
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 The IFR using chaining method takes a horizontal slice of the model 
then the slice profile may be chained into a curve. 

 Depending on the geometry of the feature to be extracted one 
technique may be more advantageous than others.  Usually when 
programming a part using a solid model a combination of these 
techniques is used. 

1 Using the same part which has already been aligned. Delete all of the 

Features in PartView. Delete all Curves. Rename part to exo2exo2 Metric 
IFR.fm 

2 Create a New Feature by selecting Ctrl+R and select Face. Check Extract 
with Feature RECOGNITION. 

3 Select Next. 

 

 

4 Left Click on the Top most horizontal face of the part and then click the 
Green + button to add it to the list. Then press the Finish button. 
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5 In the properties of the Face Mill Feature, Click the Finish Operation and 
the Milling Tab and change the Zig-Zag Angle to 90 and the Lateral 

overcut to %=200. This saves the tool feeding down onto the job. 

 This will cause the toolpath to cut along the Y axis. You will see that 
it leaves an area that is not machined on the right end of the part. 
Think of this as saving time during production since you are about to 

program to cut that step away in the next feature. 

6 Under the strategy tab select Connect Stepovers with arc. 

7  Select Apply and then OK to close the form. 
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8 Select Boss with Extract with Feature Recognition from the New Feature 
Wizard. 
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9 Select Next. Select “Use Horizontal surface”.  
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10 Then select Next. 

11 Rotate the Part view and select the Bottom horizontal face for the shape and 
One Vertical face to determine the Top and Bottom Z level. Use Horizontal 
Surface for both selected faces. 

 

12 Select Green “+” to add selection to the list. 

13 Select Finish. Then run a 3D Simulation. FeatureCAM will automatically 
select the required tools from the Tool Crib. This can be changed at any time. 

 

14 Select New Feature wizard and select Side with Extract with Feature 
Recognition. 
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15 Select Next. 

16 Then Select Automatic Recognition. 
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17 Only select the features shown. The best way to do this is to use Select All 

then un-select the outer profile. The will turn Blue. 

 

18 Select Finish. All open Features will be machined. 

19 You are probably thinking to yourself. Why are we machining these pockets as 
they are at the bottom of the part? All will be explained in the next section. 

20 Create a New Pocket Feature and Extract with Feature RECOGNITION. 

 

21 Select Automatic recognition. 
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 FeatureCAM using IFR and Automatic recognition will identify 
all pocket features. 

22 Select Next. 

23 Press the “Select All” button to select all identified features. 

 

 All selected pockets turn red when selected  

24 Select Finish. 
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25 Open the New Feature Wizard and select Hole and check Extract with Feature 

RECOGNITION. 

 

26 Select Next. Select the Recognize and construct multiple holes radio button. 

27 Check the Exclude holes with diameter > (greater than) and enter a value of 
25mm. 
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28 Select Next. 

 

29 Select, Select All.  

30 Select Finish. 

31 In Automatic ordering options. 

 If you see a gouge you will need to change the Automatic Ordering 
to Cut Higher Operations First. 

 

 See Automatic Ordering Options on the next Page. 

 

32 Run 3D Simulation. 
  



 
 
Feature Recognition 

                           

 

      
Autodesk FeatureCAM 2017    

© Copyright 2016 Autodesk, Inc. All rights reserved           8.29 

 

 Tip: Even though we had machined the pockets at a lower level. 
When we selected Cut Higher Operations First. This has re-
ordered the operation sequence. 

AFR Part 2 – 2 setups (Class Exercise) 

 

 The next example will show you how to machine a component with 
multiple setups. Setup1 for side one and Setup2 for side two using 
AFR. 

 

1 Import File ( AFR Part2.x_t ) (Parasolid) 

2 Use the Wizard to establish the initial Setup location and Stock size. 

3 Do not tick Launch AFR after finish. Select Next. 

4 Setup Z direction is ok. Select Next and Next. 

5 Stock Type is block. Select Next. 
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6 Use Compute stock size from the size of the part. Change extra stock to 
5mm for -X +X -Y +Y. 

7 Set Z- and Z+ to 2mm for stock size. Select Next. 

8 Set Z origin Top View centre + to -2mm. Select Next. 

9 Are you going to use Multi-Axis positioning to machine this part? No. Select 
Finish.  

10 Change Solid model Colour. Select Model in Part View. Go to Options and 
Select Change Selected>More Colours. Pick Colour and select Apply and 
then Done. 

11 Create Setup2 for Side 2 by double clicking on Setup1. New>Align to stock 
Face. Next. Select Bottom Centre +. 

12  Select Next. Change Z Offset to -2mm. Select Finish. 

13 Go to Construct and Run Automatic Feature Recognition for Setup1 and 
Setup2. Delete unwanted or duplicate operations on Setup2. 

14 Run 3D Simulation. 

15 Output Code. 

Import Wizard 

 When you import a file, FeatureCAM steps you through the import 
wizard.  The import wizard pops up automatically and assists you in 
importing the file into FeatureCAM. 

1 Go to File>Import> AFR Part2.x_t. Please navigate to 
C:\Training_Data\FeatureCAM Course Data 2017\Milling Files to 
import. Then select AFR Part2.x_t  
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 Do NOT use Launch AFR after Finish. Use the Wizard to establish 
the initial setup location and stock size. Select Next. The part is 
correctly orientated so Click Next until you get to Stock Type which 
is Block. 

2 On the Stock Dimensions page check the radio button, compute stock size 
from the size of the part.  Enter dimensions as shown on next page.  

 

3 The Units are in Metric and we have allowed 5mm for each side edge and 
2mm –Z and +Z. Select Next. 

4 Leave Setup1 in the same X, Y, position. Then change only the Z figure to 
-2. Select Next. 
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5 Is the part indexed? In this example the answer is No. Select Finish. 

 

6 We have to create another Setup called Setup2. 

7 Double click on Setup1 and select New. 

8 Select Align to Stock Face. 
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9 Select Next. 

10 Select Bottom then select Pick Location. 

 

11 Make sure you have snap to cylinder active. 

12 Snap to the centre of the same bore as shown below.  

 

13 Select Finish and Close. 

14 We now have Setup1 & Setup2 displayed. 
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 We are now going to change the colour of the model. 

15 Select the model in PartView under Solids. If you cannot see the model select 
the + button. This would be a good time to rename the solid model to a name 
of your choice. I have renamed it to AFR Part 2 Milling. Select the model 
then go to Options>Colouring>Change Selected>More Colours. 
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16 Select Ok, Apply, and Done. The model has now changed colour. 

 

17 Go to Construct and select Automatic Feature Recognition. 
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18 Set the AFR Options, Verify the Solid, Select Next. 

19 This will look at both Setups and machine both sides of the component. 

 

20 Select Next. 
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21 Select Next. Unselect the following Features. 

 

 

 We now have duplicate machining. In other words we have 
operations that do the same machining from both sides.  We can 
select each Feature and establish which machining operations we 

need to delete.  

22 Unselect hole1, side1, side3, side4, side5, side6. Your numbering 
sequence may be different. 

23 Select Finish.  
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24 Run 3D Simulation. 

25 Press Eject or Stop on the Simulation toolbar. Make any changes then Re-run 
the 3D Simulation to confirm that the part is finished. 

 Use existing curves to machine chamfers around each pocket. 

 

 

 

AFR Test. (Work through this on your own) 

 The following example is a test to see if you have learned how to 
machine a complex 2.5D part complete using AFR and IFR. 

 Import file New 2.5D Part for AFR & IFR Rotated X & Z.x_t 
from C:\Training_Data\FeatureCAM Course Data 
2017\Milling Files to import 
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 This file has been rotated in X & Z  

 Your challenge will be to rotate the part so the longest edge will be 
parallel in X and the bottom and Top faces are Horizontal to the XY 
Plane or Top View. Use the Tools in the Feature Recognition 
Wizard to align the part as described earlier on in the chapter. 

 Make sure you have created your Stock. 

 There is machining on both sides of this part. Create Setups for 
Op1 Setup1 & Op2 Setup2. 

 AFR will not recognise the groove around the outside. Machine this 
using IFR. 

 See the example below on how to machine the groove. 

The following guide will help machine the groove. 

1 After machining the part, select the lower bottom face of the groove as 
shown. 

 

2 Go to View>Hide>Hide Unselected. 
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 All that will be shown on the screen will be the face we selected 
earlier. 

3 Click on the screen anywhere to deselect the surface. 

4 Select Ctrl+5 or Right click on the screen and select Top. 
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5 Go to Construct>Curve>From Surface>Surface Edges. Then select the 

Edges Icon and then double click on the outer edge as shown. 

 

6 Select Apply and OK. We have now created our Curve all the way around our 
profile. 

7 Select the visible surface and Right click. Select Hide Selected. 

8 Select New Feature Wizard. Then select Groove from Curve. 
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9 Select Next. 

10 Show the Solid by selecting the Ps-Solid in Part View and Right Click and 
select Show Selected. 

11 Select Curve. Select Next. 

12 In the New Feature - Location menu  type in 2.5mm  

13 Select Next. 

14 Select the Inside/Outside radio button. Select Preview. Select Finish. 

 

15 You can see from the image below that the groove is now being machined. 
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AFR Example 3 (Feature Re-recognition)  

(Work through this on your own) 

1 In the New Part Document window select Milling Setup, Millimetres then 
press OK. 

2 Find the file in C:\Training_Data\FeatureCAM Course Data 2017\Milling 
Files to import from the files of type pull down menu select Parasolid 
(*.x_t,*.x_b).  Select the file named Original file - before. X_t then press 
the Open button. 

3 Select the Launch AFR after finish checkbox then press Next four times. 
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4 On the Stock Dimensions page check the Compute stock size from the 
size of the part and Zero the extra material fields. Then select Finish. 

5 From the (AFR) Automatic Feature Recognition press Next then Finish. 

 

6 Feature recognition completes the part by identifying all the features in the 
setup. Select Next then Select Finish. 

 

 

7 The next step is to import the similar solid model that has been revised into 
the same document as the first and perform Feature Re-Recognition. 

8 From the file menu click on File then Import. From file location 

C:\Training_Data\FeatureCAM Course Data 2017\Milling Files to 
import. Select the file named Original file - after. X_t. Then select Open. 
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 It is only shown like this for clarification to show you the difference 
between the two models. 

 Upon closer examination there should be a noticeable difference 
between the two solids. Some holes are removed and in a different 
location, as well as the depth and dimensions of the side and pocket 
features recognized using AFR. 

9 On the Import Results window select the top radio button, Uncheck Launch 
AFR after finish and Check Use the same alignment as last import. Select 
Finish.  
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 They will merge together.   

10 In the Part View on the left hand side under Solids click the plus sign to 
expand if necessary then toggle between each solid that is highlighted.  When 
the solid name is clicked in the part view. 

 

11 Click on Construct from the menu Bar above then select Re-Recognition 

Wizard at the bottom of the menu. Select Finish. 

 

12 The new model overrides the old one but is still visible. 
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13 From the solid pull down menu select the second, last imported, solid in the 
list then press Next twice. 

14 The Re-Recognition wizard will show you what has changed.  This is very 
useful so the programmer is not required to completely reprogram the part 

upon design changes. 

 This method is only effective for features that have been programmed 
using AFR or IFR.  Features created using curves will not be Re-
Recognized upon changes to the model. 

 

15 Depending on how your AFR Options are set you can get Varying results. 

16 It is suggested you use the same Options for both parts. 

17 Run 3D Simulation. 
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Chain Feature Curves 

 Lines, circles, and arcs typically represent the shape of a part. To use 
a sequence of lines and arcs to create a feature, you must chain them 
into a curve. Chaining is the primary way of creating curves by 
connecting pieces of geometry. In many cases you do not need to 
trim the geometry before creating a curve; chaining works better with 

smooth, tangent-continuous paths because these paths are more 
conducive to manufacturing. 

1 Import solid model Chain Feature Curves from directory 
C:\Training_Data\FeatureCAM Course Data 2017\Milling Files to 
Import\Chain Feature Curves. X_t 
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2 Unselect Launch AFR after Finish. 

3 Use the wizard to establish the initial setup location and stock size. 

4 Allow 5mm all-round 1mm on top face and zero on the bottom face. 

5 Setup is centre + and Z Offset is Z-1 

6 Create a Face Feature. 

7 Create a Side Feature using Extract with Feature Recognition. 

8 Orientate the view so you are looking from the Top. (Ctrl+5) 

9 Select Chain feature curves.  Select Elevation -8mm. Select Next. 

 

 You will see a form that asks you to start chaining now. Work your 
way around until you have completed the complete profile. 



              
 

                   
                             Feature Recognition      

 

                                                                                                                                      

                                                                                                              
 Autodesk FeatureCAM 2017   

8.50                                                                                                                 © Copyright 2016 Autodesk, Inc. All rights reserved 

 

 

10 Select Next which will give you the option to select the machining side. 

11 Select Next to set Top and Bottom Z locations. 

12 Top should be zero and Bottom should be -34mm enter this information or 
select the model to extract the information. 
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13  Select Next. 
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14 Change to the following settings and then select Finish. 

 



 
 
Feature Recognition 

                           

 

      
Autodesk FeatureCAM 2017    

© Copyright 2016 Autodesk, Inc. All rights reserved           8.53 

15 Using the same techniques work through this example on your own until all the 

features are machined. Create a Hole Feature to machine the holes using 
Feature Recognition. 

Milling Flats and Holes on a finished turned part 

Although we are moving towards a complete solution on new Turn-Mill centres. 
It is still a common method of first turning a part and then setting this up on a 
4 axis milling machine to machine flats and holes as a second setup. The 
following example will take you through this process in FeatureCAM. 

1 Please import the following model FC XZCY Axis Part. X_t into a Milling Setup. 
Import from C:\Training_Data\FeatureCAM Course Data 2017\Turning 
Files to import. 

 

 You will notice that the part is aligned in the Z Axis. This is correct as 
we need to extract the turned geometry from the solid model and this 
only works whilst the part is in the Z Axis. We will rotate the part and 
Geometry after we have extracted the turned geometry. 

2 Make sure you unselect Launch AFR after Finish. 

3 Please select Next until you get to the Stock Type menu. Please select 

Round and Z Axis. Select Next. 

 If the part is not on centre please select Centre of revolved surface 
and select a cylindrical surface on the solid model. This will align the 
part to X0, Y0. 

4 Select Next and go to Stock Dimensions. In this instance set all of the extra 
stock sizes to Zero. Select Next. 
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5 Select the Right Hand  this will reset the setup location to the 
end of the part. 

6 The image below shows the part with the setup at the end of the part. 

 

7 Please select Next. This will take you to the next menu. Is Part Indexed? 
Select the following. 
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 We are now going to extract a Revolved surface boundary. 

8 Select the Curve Wizard icon  

9 Then select Curve from surface and Revolved Boundary. 

 

10 Select Next. Select the following. 
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 If the part is complicated then you may have to reduce the 
tolerance to 0.05 within the Tolerances menu.  

11 Select Preview. Select Finish. This has now produced a Curve profile or 
section of the part. 

12 We now need to rotate our solid model and Curve so it is in alignment with 
the X Axis. 

13 Select the solid model in PartView. 

14 Select Edit/Transform. Then select the following. Select Apply to action the 
command. 

 

15 Then rotate the geometry so it is in alignment with the solid model. 

 

16 Select the Curve. Then select Apply to action the command. 

17 Then select Cancel. Hide the solid model.  

18 Double click on the Stock1 properties. Select X axis and Stock Curve. Select 
the Curve and this will then create a revolved stock. As shown on the next page. 
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19 Unhide the solid model. 
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20 To extract Features from the solid model we are going to use Interactive 
Feature Recognition. 

21 Create a new Side Feature and tick the box Extract with Feature 
Recognition. 

 

22 Select Next and then select the surfaces shown. Select Around the index 

axis and Normal to surface. Use the Pick surface icon to select face. 

 

23 Select Next. 

24 Use the Select Surface Icon as shown to select side surface. 
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25 Select Next. 

26 Select the four surfaces as shown. 

 

27 Select Next. 

28 You will be presented with a form that shown machining side accept as is. 

29 Select Next. 

30 Accept Top and Bottom location. 

31 Select Next. 

32 Choose the Bottom Radius Hyperlink and select the radius on the model. 

33 Then select Finish. 

34 Then create a new Pattern Feature Radial around the index axis Number 
3 and Spacing angle 270. 

35 Select Finish. 

 Apply the same technique to the large face and slot.  

 Create a Hole Feature and use Around the index axis and 
Automatic. 
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Stock Axis Example - (4 Axis). (Class Exercise) 

 

 

 The following example will show you the importance of positioning 
the Stock Axis (World Coordinates) With regard to your setup as 
shown in the example above. 

 We will Open a FeatureCAM file of a machine template for this 
exercise then Import – IFR Work Planes Milling Metric. X_t and 
position this into a machine vice by using the Translate and Rotate 
commands. Then create 3 Setups (Setup1) Top Face (Setup2) and 
(Setup3) for the angled faces. We will machine this when we start 
using Interactive Feature Recognition (IFR) on day three. 

1 Go to File >Open and navigate to C:\Training_Data\FeatureCAM Course 
Data 2017\Milling Data .fm Files and then select Machine & Points to 
snap too Metric.fm select Open. 

2 Select View>Hide All. 

3 Go to File >Import and navigate to C:\Training_Data\FeatureCAM 
Course Data 2017\Milling Files to import. Then select IFR Work Planes 
Milling Metric .x_t 

4 Select Cancel to Cancel Import Results. 

5 In PartView click on the + next to Solids, this will show you all the available 
solids. Select each solid in turn until you select the solid we are currently 
working on. It will turn red for selection. 

6 Right click on this solid and select Rename, Call the solid Part. 
  



 
 
Feature Recognition 

                           

 

      
Autodesk FeatureCAM 2017    

© Copyright 2016 Autodesk, Inc. All rights reserved           8.61 

 

 

7 You will notice that the default colour on import is Black; this is because we 
have created the part in PowerShape. We need to change this. Go to Part 
View and select Part, it will turn Red for selection, and then go to Options 

and Colouring. Then select Change Selected. 

 

8 Select the model then go to Options>Coloring>Change Selected>More 
Colours. 
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9 Select More Colours and select the colour of your choice. Then select Apply 
and then Done 

10 The solid Model Colour will change as shown on the next page. 

 

11 Select Top View or select Ctrl + 5. This will show the correct orientation of 
the Solid model. You will notice that the model is 90 Degrees out of position. 

12 We need to make the longest edge in the Y Direction. Select the Solid model 
in PartView. Select Edit>Transform. Set the following in the form shown 
below. Select OK. 

 

 You will notice that the Solid model is now orientated correctly. 
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13 Select View>Show>Select All. 

 We need to move the Solid model to the correct place relative to the 
vice. 

 There are a number of ways to locate this model. But for quickness 
we have created some points for you to snap too. You will see 5 
Points by the vice. 

14 Select the Part in PartView. Select Edit>Transform>Translate. Select From 

and pick point as shown. Make sure you have Snap to Object and Snap to 
Point active. 

 

15 We now need to position too my point as shown. 
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 The image below shows the part correctly translated into the correct 
position. 

 



 
 
Feature Recognition 

                           

 

      
Autodesk FeatureCAM 2017    

© Copyright 2016 Autodesk, Inc. All rights reserved           8.65 

 We need to set up for 4th Axis indexing. So we can Index the Part. 
Double click on Stock1 and from the Stock Properties select 
Indexing and then select 4th Axis Positioning>Indexing around 
the STOCK X Axis. This is already set for our example. 

 

 The Stock and Setup1 is already configured in our example. 
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16 We now need to create two more Machine Offsets (Setup2) G55 and (Setup3) 
G56 for the angled faces. 

17 Select Setup1 in PartView and then Right click and then select Properties. 
Select New and then Next. 

18 Select Align to Part Geometry. Select Next. 

19 Then select Align Z Perpendicular to a Horizontal Surface. 

20 At this stage you may have to reverse the Z direction. Select Reverse Z. 
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21 Select Next twice and then click Pick Location. Make sure you have Snap to 

Point highlighted. Then Snap to the point at Setup1. Select Finish. That is 
Setup 2 completed. 

Setup2 

 

 Repeat the process for Setup3 

Setup3 

 

 We have now finished all of our setups. 
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22 Save the file for IFR (Interactive Feature Recognition). We will now Machine 
the Part using Interactive Feature Recognition. 

23 Activate Setup1 in Part View. 

24 Press Ctrl + R New Feature. Select Face. Select Finish. 

25 Change the cutter to an 80mm Facemill with Zigzag direction at 90 degrees. 

26 We will now machine the outer edges of the part just slightly deeper than the 
actual bottom of the part but above the Vice jaws. To a depth of 105mm  

27 Press Ctrl + R or New Feature from the Steps menu and select Boss with 
Extract with Feature Recognition ticked. Select Next.  

28 Select Along the Setup Z Axis. Select Next. 

29 Select Use horizontal surface then Next and then select the base face and 
add this to the selection. Select Next. 

30 FeatureCAM will ask for a Top and Bottom dimension. You can select this 

from the model or enter the following dimensions. Top=0 Bottom=-105 select 
Finish. Make sure that the tool selected will achieve the depth required. 

31 By default the machining strategy will Ramp down to depth and then machine 
all around the part and repeat this at each level. This is very time consuming. 

Double click in Part View on the Boss Feature. Select Strategy unselect Rough 
Pass and select Semi-Finish pass and Helical side finish with a pitch of 6mm 
select Apply and then OK. 

32 We will now machine the large centre pocket using Side and Feature 
Recognition. Select the 4 side surfaces this includes the Radius surfaces. 

33 Press Ctrl + R or New Feature. Select Side with Extract with Feature 
Recognition ticked 

34 Select Along the Setup Z Axis. Select Next. 

35 Use Select Side Surfaces for the Feature Extraction. Select Next. 

36 In FeatureCAM 2017 we now have a new selection tool called Drag Select. 

 

37 Select the Side edges of the large centre pocket as shown. (Not the Vice) 

Select Next. 

 Make sure the Side machining arrow is pointing in the correct direction. If 
not select the change direction Icon. Select Next. 

  



 
 
Feature Recognition 

                           

 

      
Autodesk FeatureCAM 2017    

© Copyright 2016 Autodesk, Inc. All rights reserved           8.69 

 

 

38 Make sure you have the correct depth -50mm if not select the Bottom Icon 
and click on the bottom of the surface. Select Next. 

39 The next menu gives you the dimensions for this feature. 
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40 To extract the correct Radius dimension, select the blue Bottom Radius 
hyperlink in the form as shown above and then select the radius on the solid 
model. This will extract the correct radius (5mm). The centre large pocket is 
now machined to Z-50mm. 

41 The order of machining may change. If FeatureCAM machines this part in a 
different way to way you expected then we can change the Base priority as 
Follows Face Base priority=1 Boss Base priority=2 Side Base priority=3. To 
change this go to Part View and double click on Face go to Misc and change 
the Base priority.  

42 The next thing we need to do is machine the smaller lower pocket. 

43 With this Feature all you have to do is press Ctrl + R and select pocket with 
Extract with Feature Recognition. Next. 

44 Along the Z Axis. Next. 

45 Automatic recognition. Select all then Finish. The Feature is complete. 

46 Setup2 

47 We will now move onto Setup2. Select this in Part View. Once this has been 
selected all machining will be related to this Setup. 

48 The first machining operation will be to face the angled face. Press Ctrl + R to 
create a New Face Feature using Extract with Feature Recognition. Select 
Next. 

49 We will be using along the setup Z Axis. Select Next. Select the Pick Surface 

 Icon and move the cursor over the angled face and this will highlight green, 
use the left mouse button for selection; this will then turn Red to indicate your 

choice. By selecting this boundary this will reduce the amount of fresh air 
moves. Select Next twice until you get to the Strategies menu. Select 
Connect stepover with arc (ideal for high speed machining) although this will 
add time to the operation it will put less strain on the Facemill and machine. 
We also need to select Rough pass to machine at equal depths until roughed 

out. The finish pass will then take a last cut over the face. Select Finish. 

50 Now whilst the cutter is in the spindle we will machine the angled face in 
Setup3. 

51 You know what to do now. Machine the angled face in Setup3. 

52 While we are machining setup3 we can automatically machine the pocket on 
that face. Do not select all but highlight the Pocket by selecting with the left 
mouse button. Machine the pocket complete, you should know what to do by 
now if you have worked through this exercise. Complete the pocket in Setup2. 

53 The next thing to do in Setup2 and Setup3 is to machine the Hole features. 

54 Select Ctrl + R and select Hole with Extract with Feature Recognition 
ticked. Select Next. Along the setup Z-axis. Next. Next then Select, Select 
all. Select Finish. 

55 Select Setup2 and repeat the above procedure for machining the Hole 
features. 

56 Although there is machining still left on the underside. All you would have to do 

is turn the job over in the Vice and run the facing opp to machine the surplus 
material. The job is now complete. 
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4 Axis Unwrap curve options + 3D Chamfer 

1 Open the file 4 Axis Unwrapped Side Feature plus 3D Chamfer – 
Start.fm from C:\Training_Data\FeatureCAM Course Data 
2017\Milling Data .fm Files. 

 

 

 First of all we will extract a curve from the solid model and then 
change the start point on the curve so the machining starts in a place 
that we would like the Leadin/out to start from. 

2 Hide Stock. Please select Construct from the main menu. 

3 Select Curve>From Surface>Surface Edges 

4 Work your way around the edge of the solid model as shown on the image 
below. Once completed select Apply and Ok to close the form. 
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 We need to change the start point of the curve so we can decide 
where to lead in and out. 

5 Please select Construct>Curve>From Curve>Curve Start/Reverse 

6 Please select Modify existing curve and Set start point. Choose a point on 
the model where you want the start point to be. Or type in the values as shown 

below. Point 1 is the original start point. Point 2 is where it will be moved too. 

 

7  Select Apply and Ok to close the form. 

 We now need to unwrap the curve so we can create a Side Feature and 
machine around the profile. 

8 Please select the Curve1 in PartView. 

9 Please select Construct>Curve>From Curve>Unwrap 
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 This will unwrap the curve and create a new curve called Curve2. 
Select Apply. See lower image for the result. 

 

 

 We will now use this curve to machine around the profile. 

10 Please select Ctrl+R to create a new Side Feature. 

11 Select Next. Select Curve2. Select Next twice. 

12 Change the depth to 10mm and select Finish. 

13 Go to the Strategy page and unselect Rough Pass and Ramp from Top. 
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14 Please select Semi-finish pass. Select Apply and Ok to close the form. 

15 From the dimensions tab please select Wrap feature around x axis. 

16 Please select Wrap Options. Select the following options. If this option is not 
available select this from the special menu. Show Parallel wall wrap 

options. 

 

17 To activate this menu select the CTRL key and Right mouse click in the position 
as shown. Once selected a tick will appear next to this option. 
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18 Select Ok to close the form. Select Apply and Ok to close the main Side 
feature menu. If you want to change the tool to a 12mm diameter Endmill. 

 

 The Side profile is now machined parallel to the surface feature. 

 Have a go at creating the 3D Chamfer by extracting a curve from one of 
the Oval pockets. Create a chamfer feature from Curve and select the 
3D Chamfer option. Make sure you machine the Pocket first. 
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Boring Tool 4 Axis (Work through this on your own) 

FeatureCAM gives extraordinary results on solid models mounted on a 4 Axis 
indexer or rotary table. The part you will create is a special boring tool with 
pockets that will use carbide indexable inserts when finished.  You will begin by 
importing TWO solid models.  One is the Part and the other represents the 
Stock. The Stock material would logically be turned on a lathe to the size and 
shape of the finished holder and that is the state of the Stock when it comes to 
milling these secondary features. The Index axis will be around the Stock 
X Axis. 

 

1 Open a new Milling document in Millimeters. Click on File then Import and 
Navigate to the training files your instructor placed in the appropriate folders. 

2 C:\Training_Data\FeatureCAM Course Data 2017\Milling Files to 
import. Import the model named 2.5D Cutter horizontal slide-PART.x_t 

3 In the Import Results Select “Use the wizard to establish the initial setup 
location and stock size” and select an Isometric View by right clicking in the 
graphics window. 

4 Uncheck “Launch AFR after finish”. Select Next. 

5 Click somewhere in the Graphics Window to “de-select” the Solid model. The 
Solid model will turn from Red (Selection) to grey. 
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6 The part centreline must be aligned with the rotary table in the X Axis and 

perpendicular to the spindle. 

7 Select the pick Arrow for Align Z perpendicular to a horizontal surface and 
Click on the horizontal face shown. 

8 Select Ctrl + 5 or Top view.  If your selected surface is upside down Click on 
the Reverse Z button and Top view again. Select Next.  

 

9 The Z orientation is correct but we need to align the X Axis by selecting two 
points or by selecting Rotate X direction 90 degrees around Z Axis. Select 
this option. Keep selecting the button until you have the part in the correct 

orientation in X. See second image below. (Top View or Ctrl+5) This shows 
the part in the correct orientation. 
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10 Select Top View. Pockets are to the left as shown above. Select Next.  

11 You will be presented with the Stock Type menu. Select Round and the X 
direction as shown below. 

 

12 Select Next. You have the option to select the centre of the round stock. 

Select this option and the surface shown below. 

 

13 Select Next. You will be presented with the option to set the Stock 
dimensions. Although we will be using a solid model for stock later on in this 
exercise it is useful to create our stock so we can create our Setup1 in the 
correct position. 
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 Please select Compute Stock from the size of the Part. Make sure 
the Extra Stock Size for all options is set to zero.  

 

14 Select Next. 

15 We need to locate our Setup datum point to the left hand side of our Stock. 

16 Select the left hand pointer as shown on the above image. 

 The Setup is now set to the Stock Axis position. 

17 Select Next.  



              
 

                   
                             Feature Recognition      

 

                                                                                                                                      

                                                                                                              
 Autodesk FeatureCAM 2017   

8.80                                                                                                                 © Copyright 2016 Autodesk, Inc. All rights reserved 

18 This next menu will give you the ability to set the index axis rotation point. 
Select the option shown below. 

 

19 Select Finish. Then go to View from the main menu and select Show>Show 
Stock Axis. 

20 Repeat the Import process for the STOCK model for 2.5D Cutter horizontal 
slide-STOCK.x_t.  from location C:\Training_Data\FeatureCAM Course 
Data 2017\Milling Files to import. 

21 In the Import Results select the top radio button to Use the Wizard and check 
Use the same alignment as last import. 

22 Select Finish and the part will align to the original model as shown below. 

 

23 The two models now need to be merged and that means you will have to 

transform the STOCK model by Rotating and translating it to the PART 
model. 

24 Start by selecting Shade Surfaces.  
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25 Make sure you have Snap to end point and Snap to object active.  

26 We need to highlight the model from Part View and then activate Transform 
from the Edit menu. Select Translate and Move. Select the From Arrow, Snap 
to the end nearest the datum as shown. To X0, Y0, Z0. 

 

 We now have to rotate the stock 180 degrees about the Y Axis. 

 

27 Select Edit>Transform. Select Rotate and Move. About the Y axis 180 
degrees. 

28 Select Preview. Then Ok. Switch on both Models and you will see them 
merged together. 
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 Summary:  The purpose of Use same alignment as last import is 
to take advantage of assemblies and multiple models that are created 
and aligned or merged together when created in CAD. If the parts are 
not aligned when created, it does not matter because FeatureCAM 
provides all of the necessary tools to align the parts.  So you use the 
Import wizard to Align completely or as close as possible and finish 

off with these tools.   

29 We must now change the Stock solid model to Stock.  Double-Click on the wire 
frame of the stock in the graphics window.  Double click on Stock, select User 
defined and select the box for the Stock Solid. 
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30 Select the solid model then select OK and Apply. 

31 The main cutter solid model is now ready to be machined by applying 
Interactive Feature Recognition. 

32 From Part View select the Stock Solid in the list and Right Click on the model 
and select Hide Selected.  This is necessary so we just see the PART model we 
are going to machine. The STOCK model will be visible when running the 3D 
Simulation. 

33 Switch to Isometric view or select Ctrl + 1. Select Ctrl + R or select Steps and 
Feature. Select Side from Curve and check Extract with Feature 
Recognition. Select Next. 

 

34 Select Side and Extract with Feature Recognition. Select Next. 
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35 Select Around the index axis then Select the Normal to Surface radio 
button. Select the Pick Surface Icon and Pick surface as shown below. 

 

36 Select Next. 

37 Use the Drag select Icon  Select Surfaces. Select Next. 

 

38 Select Next. 
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39 Make sure the direction arrow is pointing in the correct direction. If not select 
the switch machining side icon. Select Finish and then Ok to close the form. 
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40 We can now make a pattern from the previous feature but should only be 
used when you are absolutely certain that the Features are identical and 

symmetrical. 

41 Press Ctrl + R this will present you with the New Feature Form. Select 
Pattern. 

42 Select Next. 

 

43 Select Side1. 
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44 Select Next. Then select Radial around the index axis. 

 

 We need two copies, which include the original, rotated at 180 
degrees 
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45 Select Finish. 
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 When milling cylindrical parts the side feature has to extend outside of the 
Stock far enough to satisfy the bottom of the feature but at the top, because 
of the shape of the material the tool is cutting fresh air on some passes.   

 To eliminate this, under the strategy tab in the milling feature select 
Individual Rough levels, apply and OK.  

 This creates control at each Z increment depth of cut and follows more 

closely to the shape of the material on each level.  Higher passes start 
their passes closer to the material and move out as the tool descends.  
FeatureCAM has also selected three tools now, the first pass is the 
shortest tool and each pass changes to a longer tool.  You may override 
this by selecting the same tool for all three cuts.   

 This will also make the part index on each level but can be eliminated by 
selecting “Cut higher operations first” from the results window (right side of 
graphics window), click on Automatic ordering options button at the top.  
This works only if the features are individual not a pattern. 

  

 Rotate the View so you can see the horizontal surface of the feature 
between the previous features just completed.  Continue with Side 
Feature using Recognition and select the arrow “Normal to surface”.  
Click on the horizontal surface that you rotated to.  The vertical surfaces 
that FeatureCAM is looking for are Normal to this horizontal surface. 

FeatureCAM uses the horizontal surface to index to and looks for any 
vertical surfaces with Recognition at this angle. 
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 Next we are going to machine the two smaller pockets that are 90 
degrees to the machining we have just completed. Select Ctrl + R to 
select a new feature. 

46 Select Side and select Extract with Feature Recognition. Select Next. 

 

47 Select Normal to surface & select the Pick Arrow then Pick surfaces. Select 
Next. 
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48 Pick the surface as shown. 

 

49 Select Chain Feature Curves. Set elevation to 31mm.  

 

50 Select Next. Chain around the open profile as shown on the next page. 
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  If you have difficulty with a section of the profile select smaller 
sections until you have completed the profile. Select Next and select 
the machining side. 

 

51 Once you selected the machining side select Next to see the location menu.  

52 Set the bottom dimension to zero. 
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 Select Next. 

 

 The main reason for using Side with the chain option is that the 
profile will be completely machined compared to using side surfaces 
or Horizontal face. 

 If you do use one of the other options you could always extend the 
curve afterwards which will increase the feature machining area. 
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 Apply the same technique to the smaller pocket or use Horizontal 
section. 
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53 Create a Pattern of the Group. Around the Index Axis. 

 

 

54 Create a New Side feature. 

55 Select Next 

56 Click on Slice location arrow and Click on the bottom of the same vertical 
face and this sets the Bottom of the feature. Select Next. 



              
 

                   
                             Feature Recognition      

 

                                                                                                                                      

                                                                                                              
 Autodesk FeatureCAM 2017   

8.96                                                                                                                 © Copyright 2016 Autodesk, Inc. All rights reserved 

57 Click on Switch to Top View and the part moves to a top view.  The geometry 
is readily visible and must be chained with an open curve.  Chain them with two 
open curves, not connected.  Click on Create at the bottom in the geometry 
dialog area after each open curve.  Select Next. 

 

58 Check the Machining Side arrows, they must point in.  Use the Icon to reverse 

the direction if necessary. Select Next. 

59 Confirm the Top and Bottom and change using the Top and Bottom arrows if 
necessary and extend the leads as before if necessary. Select Finish. 

 

 Complete all of the remaining side features. 
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60 Open a New Feature and Select Hole and Extract with Recognition.  Select 
Next. 
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61 Select Specify angles and click on the “Blue Words” Index Angle and Zoom 
in on the hole you choose.  If you un-shade it temporarily it exposes the line 
very clearly for easy picking.   

 

62 To achieve the correct angle remember to select on the Line from bottom to 
Top. This will give the correct Index Angle. Select Next. 
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63 Select Next. All holes have been selected at your chosen angle, even those on 

the other side that you don't want and that is because they are an open cylinder 
and could be drilled from this Z direction.  But would drill them from the 
underside. Which is not desirable as it is on the diameter. 

64 You simply choose only the holes you want.  The selected holes will turn red for 
selection.  The others remain blue and are not selected.    

 

65 Create a Group of the two holes and then create a pattern for each group. 
Rotate the Hole feature 180 degrees until all of the machining is complete as 
shown on the next page. 
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