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This educational supplement to the PartMaker SwissCAM manual is intended to 
provide additional training to the end user.   
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Chapter 1: PartMaker® SwissCAM™ 
Programming Tutorial Part 2 – Plug 
Introduction 

This tutorial is designed to help you learn the steps to go through in using 
PartMaker SwissCAM to program Swiss-type lathe parts. 

 Important! The tutorial below is presented in both inch and metric units, 
depending on how you are working with PartMaker.  The inch units of 
measure are given first, with the metric entries gives in parenthesis ( ). 

For example you may see instruction that says: Enter an X value 1 (25), 
where 1 is 1 inch and 25 is 25 mm. 

How you will create Part 2 – Plug using SwissCAM 
Here are the major steps you will follow to create the Swiss tutorial Part 2: 

 Start PartMaker SwissCAM 

 View tool information for the part 

 View cycle information for the part 

 Select a material for the part 

 Setup defaults for Swiss style manufacturing 

 Define the stock boundaries for the Face Window 

 Open new Face Windows for each operation type (Turning and Milling) 

 Create geometry 

 Perform turning operations on the main spindle 

 Perform a cut-off operation 

 Perform Milling on the main spindle 

 Perform cross drilling on the main spindle 

 Perform face drilling & tapping using driven tools on the sub-spindle 

 Create the Process Table 

 Synchronize machining operations on the main and sub-spindles 

 Simulate the Machining Process 

 Generate an NC Program 
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The drawings below show the part to be programmed: 

 

Inch Dimensions 

 

 
Metric Dimensions 
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When you complete this tutorial, you will have a part that looks like the pictures 
below. 
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Getting Started 
The first part of any multi-axis turning programming exercise with PartMaker 
SwissCAM is to decide which machining functions will be used for each part face to 
be programmed.  

The machining functions used in this tutorial are as follows:  

Turn – Main Spindle:  

Use turning tools to perform a variety of Swiss-turning operations on the main 
spindle including facing, threading, turning, grooving, drilling, and pick-off. 

Mill ZY – Main Spindle: 

Use a slotting mill to create a slot in the face of the part. 

Mill Polygon – Main Spindle: 

Use an end mill to create four flats .270 (6.8) wide towards the center of the part. 

Mill Diameter Index – Main Spindle: 

Use cross drilling tools to create holes in the side of the part. 

Mill End Index – Sub Spindle: 

Use drilling tools to create holes in the back face of the part. 

Programming Swiss-type lathe operations with PartMaker is performed in a unique 
manner. No matter what the orientation of the part in the guide bushing or sub 
spindle, PartMaker programs all Swiss operations as if being machined in a 
conventional lathe, i.e. all programming is carried out from right to left.  For this 
tutorial you are going to use a machine layout like the one shown below. 

 

 

 Note: This tutorial covers both general PartMaker programming techniques 
as well as those unique to Swiss-turning. For more information on using 
PartMaker to program CNC Milling, 2-axis turning and fixed-heastock turn-
mill applications, please see the manuals which correspond to those 
applications. 
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Now you will look in detail at the steps necessary to program each of the 
components of the finished part. The components of the completed Swiss tutorial 
part can be found in the following directories: 

 

Completed Job File: 

 C:\PartMaker\PM-Swiss\Swiss Tutorial 2\Inch-Swiss Tutorial 2\swiss2.job 

Completed Tools File: 

 C:\PartMaker\PM-Swiss\Swiss Tutorial 2\Inch-Swiss Tutorial 2\swiss2.tdb 

Completed Cycles File:  

 C:\PartMaker\PM-Swiss\Swiss Tutorial 2\Inch-Swiss Tutorial 2\swiss2.cdb 

Machine Data File: 

 C:\PartMaker\PM-Swiss\Swiss Tutorial 2\Inch-Swiss Tutorial 2\Swiss-demo.mch 

Post Configuration Files: 

 C:\PartMaker\PM-Swiss\Swiss Tutorial 2\Inch-Swiss Tutorial 2\Swiss-demo.pst 

C:\PartMaker\PM-Swiss\Swiss Tutorial 2\Inch-Swiss Tutorial 2\Swiss-demo.sub 

DXF files 

 C:\PartMaker\PM-Swiss\Swiss Tutorial 2\Inch-Swiss Tutorial 2\ 

Main_Spindle_Turn.DXF 

Mill_Diam_Index.DXF 

Mill_End_Index.DXF 

Mill_Polygon.DXF 

Mill_ZY.DXF 

Solid Model Files: 

 C:\PartMaker\PM-Swiss\Swiss Tutorial 2\Inch-Swiss Tutorial 2\swiss2.x_t 

C:\PartMaker\PM-Swiss\Swiss Tutorial 2\Inch-Swiss Tutorial 2\swiss2.SLDPRT 
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Starting PartMaker SwissCAM 
All programming for Swiss parts done with PartMaker should be done in the 
SwissCAM application. To start the PartMaker SwissCAM application: 

1 Double Click the SwissCAM icon on your desktop or choose SwissCAM from 
the PartMaker Group accessed through Programs under the Windows Start 
button. 

2 An icon containing the PartMaker logo will appear for a few moments. You 
will then see the Setup dialog shown below. You will use this dialog to 
describe your part later in this tutorial. Now click the <Close> button. 
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View the Tool Information 
The tool library for the Swiss tutorial Plug has already been created. To view the 
tools: 

1 Open the Tools file by choosing Open Tools File from the File menu. 

2 Select the Swiss Tutorial 2 >> Inch-Swiss Tutorial 2 (for metric use 
Metric-Swiss Tutorial 2) directory and click <Open>. 

3 Select the Swiss2.tdb (Swiss2_metric) file and click <Open>. 

 
4 Choose Tools from the ToolMinder menu, or Toolbox Icon:  

The tools to be used in the Swiss Part 2 tutorial are shown below: 

 
Note: The tools used in this chapter are for the tutorial only. As you begin to 
use PartMaker, you will create your own Tools Database. See Chapter 2 of 
the PartMaker SwissCAM manual for more information on creating your own 
tools. 

5 Click <Close> button to close the Tools dialog. 
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View the Cycles Information 
At this point, you should be familiar with the concept of Cycles in PartMaker. 
Cycles are sequences of repetitive operations used to machine a hole. The Cycles 
library for the Swiss tutorial has already been created.  

You can view the cycle that you will be using for this programming exercise. To do 
so:  

1 Open the Cycles file by choosing Open Cycles File from the File menu. 

2 Select the Swiss Tutorial 2 >> Inch-Swiss Tutorial 2 directory and click 
<Open>. 

3 Select the Swiss2.cdb file and click <Open>. 

 
4 Choose Cycles from the ToolMinder menu or icon: 

 
You will use several cycles to create holes on Part 2 in this Tutorial.   

If you are not familiar with the concept of creating and working with cycles, 
please refer to Chapter 2 of the PartMaker SwissCAM User Guide in the 
section titled Cycles Database now. 

5 Click <Close> to close the Cycles dialog. 
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Select a Material for the Part 
The work piece in this exercise will be machined from Free Machining Stainless 
Steel, Wrought. To load this material: 

1 Choose Open Material File from the File menu. 

2 Select st_fmstw.mdb as shown below. 

 
3 Click <Open> to open the Material file. 

You have now loaded the tools, cycle, and material files that were previously 
developed for the Swiss tutorial. PartMaker has also provided a completed job 
file. At this point, do not open the job file. You will be guided through a step-by-
step process to develop a job file for the tutorial.  
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Setting Defaults For Turning 
Before beginning the Swiss-tutorial, you will have to set certain turning defaults to 
facilitate the programming process: 

1 To access the dialog, select Defaults from the Job Optimizer menu. 

 
2 Click <Turning> button to access the Defaults for Turning dialog. 

 
Note: In Swiss machining, in order to avoid pulling stock back into the guide 
bushing it may be desirable not to start and return to a Cutting Point when 
programming in PartMaker. Therefore these normally are not checked by 
default. If required by a particular profile you can check these ON in the 
Profile Group Parameters for any process. 

3 Check the Diameter Programming checkbox which will allow you to define 
all geometry and feature programming in terms of diameter in a Turn Face 
Window, thus alleviating the need to divide measurements in half when 
programming or drawing on the X-axis. 

Note that Positive Z Programming box is checked. This tutorial is done 
with drawing and programming using positive Z style. This allows the Z-axis 
to be treated as it would be on the Swiss machine. This tutorial is created 
using the Positive Z Programming method. 

4 Set a default Line Length for your programmed Leads. For this tutorial the 
value should be .020 (1.0). In the Line Length: field, enter .020 (1.0) 

5 Thread Height. The following options are available: 

%Pitch: The user will enter the height as a percent and resulting height 
will be Pitch * Thread Height / 100. 

Part Units: The user will enter the actual measured height of the thread 
in the current part units. 

6 Click <OK>. 

Note: Setting a generally applicable lead as a default will save you a great 
deal of time when programming Swiss parts because you will not have to 
reenter the same data from feature to feature. 
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Setting Defaults For Milling 
Before beginning the Swiss-tutorial, you will have to set certain milling defaults to 
facilitate the programming process: 

1 To access the Defaults dialog, select Defaults from the Job Optimizer 
menu. 

 
2 Click <Milling> to access the Defaults for Milling dialog. 

 
3 Set the default values for your programmed Leads. In Milling the defaults for 

Arc Radius and Line Length become a percentage of the diameter of the 
milling tool. For the Swiss Tutorial Part 2 you will set the value for Arc 
Radius to 0%, the Line Length to 55% and the Lead Angle to 90 deg. 

4 Width of Cut. This parameter specifies whether the "Width of Cut" field in 
the Mill Profile Group Parameters Dialog will be defined in terms of 
percentage of tool diameter or an absolute value. Uncheck Corner 
Rounding option at the bottom right. 

Note: Setting a generally applicable leads as a default will save you a great 
deal of time when programming Swiss parts because you will not have to re-
enter the same data from feature to feature. 

Once you have looked at the tools and cycles databases, selected a material for the 
job, and setup the defaults for your job as shown above, you can move on to begin 
programming the Swiss Tutorial 2 Part. 
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Creating a Turning Operation - Main Spindle using the Turn 
Machining Function 

This section of the tutorial will instruct you in the steps necessary to perform the 
turning operations on the main spindle. 

Setting Up the Face Window 
In this section, you will set up the Face Window for the turning operations on the 
main spindle.  

To do so: 

1 Choose Setup from the View menu to view the Setup dialog (or click the 
Setup Icon in the upper left hand corner of the screen).  

In this dialog, you will define the machining methods, part boundaries, and 
location of the stock with respect to the programming origin.  

Note: The Main Spindle radio button is selected indicating this window will 
be used for Main Spindle processes. 

2 Rename the current Face Window by clicking the Rename to: field and 
enter Main Spindle – Turn. 

3 Click the <Apply> button. 

4 Now enter the parameters listed below in the appropriate fields on the Setup 
window: 

Length (L): 1.1 (28.0) 

OD: 0.5 (12.7) 

ID: 0 (0) 

Excess Stock (E): 0.01 (0.1) 

Guide Bushing Length (l): 0.75 (20.0) 

Guide Bushing Diameter (d): 1.25 (25.0) 

Tool Change X(Xc): 2.8 (15.0) 

Tool Change Z (Zc): 2.0 (0) 

5 When you are satisfied that your Setup dialog appears as the one below, 
click <Apply>. This will apply the parameters to the current Face Window. 
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6 Click <Close> to close the Setup dialog. 

7 Click anywhere in the Face Window to activate it. 

8 Choose Show Axes from the View menu or select the icon. This will display 
the horizontal and vertical axis lines which will help you create the geometry 
in the next section of the tutorial.  

9 Choose Show Boundaries from the View menu, or select the icon. This will 
display the boundaries of the part as you described in the Setup dialog. 

 

 Tip: You can get a better view of your part by zooming out (Shown 
Above). The best way to do so is to perform a FULL VIEW, then roll your 
mouse wheel just a little bit to move the stock away from the edges of the 
window. 

 Tip: If at any time the menu commands become grayed out and 
unusable, this indicates that the Face Window you are working in has 
become inactive. This will be evident if the top bar of your window (where 
the name of the window is displayed) has become gray. To reactivate the 
window, click anywhere within your Face Window. 

Before moving on, save your work! Do so by selecting Save from the File menu 
or using the shortcut key <Ctrl + S>, or click on the floppy disk icon.  

Give your job file the name Plug. 
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Creating Geometry in CAD Mode 
In this section, you will create the geometry for the turning operations to be 
performed on the main spindle.  If you wish to draw the geometry, skip to Method 2 
on the next page. 

Method 1: Import a .DXF file 

1 Choose Import DXF File from the File menu or click on the Import icon and 
select DXF.  

2 Select the Swiss Tutorial 2 >> Inch-Swiss Tutorial 2 (Metric-Swiss 
Tutorial 2, for metric) directory. 

 
3 Select Main_Spindle_Turn.DXF. 

4 Click <Open>. 

 Note: If you do not want to create the geometry for the Swiss tutorial in 
PartMaker, a .DXF file for each window is supplied in the Swiss_Tutorial2 
directory. 

Method 2: Create Geometry in PartMaker 

To create the geometry in PartMaker CAD: 

1 Click <CAD/CAM> switch in the lower left-hand corner of the window. The 
icon will change its appearance from a drill bit to a pencil. 

CAD CAM 

  

2 Select the Line Parallel Horizontal Axis Icon from the drawing icons on 
the left side of the window. This will be used to create Horizontal Parellel 
lines at specific coordinates.  

At the Bottom of the window, a input field will appear. 

 



 

Copyright @2014 Delcam Ltd  User Guide 1-15  

 

3 Input into this field the value which you need to place horizontal lines in our 
drawing for the turning operations. Follow the print for reference. After each 
entry, press the <Enter> key to place a horizontal line on the screen at the 
coordinate input. 

Input 0 (0) Press <Enter> 

Input 0.12 (3.0) Press <Enter> 

Input 0.16 (4.0) Press <Enter> 

Input 0.187 (4.75) Press <Enter> 

Input 0.25 (6.0) Press <Enter> 

Input 0.32 (8.1) Press <Enter> 

Input 0.48 (12.2) Press <Enter> 

You should have a drawing which appears below. 

 
4 Select the Line Parallel Vertical Axis Icon from the drawing icons on the 

left side of the window. This will be used to create Vertical Parallel lines at 
specific coordinates.  

5 Enter into this field the value which you need to place vertical lines in our 
drawing for the turning operations. Follow the print for reference. After each 
entry, press the <Enter> key to place a vertical line on the screen at the 
coordinate input. 

Input 0 (0) Press <Enter> 

Input 0.10 (2.5) Press <Enter> 

Input 0.22 (5.5) Press <Enter> 

Input 0.30 (7.62) Press <Enter> 

Input 0.35 (9.0) Press <Enter> 

Input 0.65 (16.5) Press <Enter> 

Input 1.1 (28.0) Press <Enter> 

6 After entering these coordinates, Use the View Menu and choose Hide 
Boundaries , then Hide Axis to get a better view of the CAD drawing. 

You should have a drawing which appears below. 
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7 Select the Remove Icon to delete the lines not needed. 

Note: The Remove Icon (scissors) will cut a line to it’s closest intersection 
with another geometry element. Please see the user manual for more 
information on the Remove Icon. 

Working from Right to Left, you want to trim away lines that have nothing to 
do with the actual contour of the part. For purpose of clarity, you can see 
below the contour outline in red with the drawing lines in blue.  

 Tip: If you can not tell which element is the correct element, you can choose 
the Selection Icon (the arrow in the upper left) and double click on any 
element to see the geometric location of that element. 

 
8 Continue trimming away lines until you final contour appears as seen below. 

Note that the line at X = .25 (6), which represents the top of the threads 
should remain. 

As best applies, use the REMOVE ICON or highlight a line, then press 
DELETE or BACKSPACE to remove any totally unwanted lines.  

With very little effort, your drawing should appear as seen here below: 

 
You will now place a 0.02 x 45 (.5 x 45) degree chamfer on the front of the part. 

1 To do so choose the Chamfer Icon.  

2 A field will then open up at the bottom of the window prompting you to enter 
the size of the chamfer.  Enter a value of  0.02 (.5) and press <Enter>. The 
mouse pointer will also change to a new arrow with a C in it. 

 
3 Place the point of the new mouse icon on the inside of the corner you want 

the chamfer to be placed and click the mouse to insert a chamfer. 
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4 Next, enter 0.01 into the field at the bottom of the screen for the 3 other 
chamfers. You will click the inside of each corner that requires the 0.01 
chamfer. 

 Note: You do not have to enter the 0.01 into the field for each chamfer. 
PartMaker will remember the last setting and use it each time you make a 
chamfer. 

 
1 Create a 45 degree angle from the groove up to the threaded area. Choose 

the Line on an Angle Icon.  

2 First you will decide how to choose a start point. For this in the upper part of 
the screen click the Closest Intersection Snap Mode.  

3 Click at the intersection at the bottom right hand corner of groove as shown 
below. 

4 Enter 45 into the field at the bottom of the screen for the degrees of the 
angle. 

5 Click the line you are drawing this angled line to. 

 
6 Now that the line is created, use the Remove Icon to cut away the geometry 

not required, as indicated by the arrows.  

 
The drawing should then look like this. 

 
You will now mirror the selected geometry to have a complete part on the screen. 
To do so: 

1 Select the geometry you have created by clicking on the Selection Icon and 
choosing Select All from the Edit menu. All the geometry should be 
highlighted on the screen.  
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Note: This mirroring is not required but will help you better visualize the 
part in the CAM mode and will help with clearances on internal processes.  

2 To mirror, select the whole geometry and choose Mirror from the Edit menu 
or select the icon.  Complete the Mirror dialog as shown below: 

 
3 When you have completed the dialog, click <Mirror> and <Close>. 

4 Click anywhere in the window with your mouse pointer to deselect the 
geometry. 

The completed drawing should appear as below: 

 
Note: Once you finish drawing your geometry for the Main Spindle Turn Face 
Window, you can either continue drawing the geometry for other Face 
Windows or switch to creating cutting profiles for each Face Window. For this 
tutorial you will create geometry and cutting profiles before moving to the 
next Face Window. 
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Defining the Profile for Face Turning 
The first turning operation to be performed on the Main Spindle is to face the stock. 

1 Click <CAD/CAM> switch to go to CAM mode. 

CAD  CAM 

 

2 Click anywhere in the Face Window to make it active.  

3 Choose New Profile Group from the Part Features menu to display the 
Profile Group Parameters dialog.  When selected, you should see a dialog 
which appears as the one below:   

 
4 From the Strategy menu, select Contouring (it should be chosen by 

default). 

5 From the Tool Location menu, select Face. 

6 Uncheck the Roughing Tool ID: box this will automatically cause the 
Finishing Tool ID: to be checked. 
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7 Click <Select Tools> and select the appropriate tool. PartMaker will present 
you a choice of two tools, one is mounted on the main spindle and the other 
is on the sub spindle as shown below: 

 
8 In this case you are doing main spindle work, so choose T001 and click 

<Select>.  You are choosing T001 because this tool has been setup up for 
work on the main spindle and the Tools Database has been designated as 
Gang Tool. 

9 In the field called Group Name, enter Face Part. Your dialog should now 
appear as shown below: 
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Leads In/Leads Out 
When programming parts in PartMaker, you have the ability to control how far and 
at what angle a tool feeds on and off of a part. These values are controlled via 
Leads. The Lead In is the distance from the part the tool will begin feeding before 
cutting. Likewise, the Lead Out is the distance that the tool will feed away from the 
material before tool change or rapidding to its next position. 

 Note: If you are using the same Leads In and Leads Out in most of your 
operations, you can set them as default values in the Defaults for Turning 
dialog accessed under the Job Optimizer menu.  Setting your own default 
Leads In and Out values will save time when programming in PartMaker. 

1 The Leads In and Out dialog box combine the settings for controlling the 
movement of the tool as it approaches (Leads In) and leaves (Leads Out) the 
stock. 

2 Set the Leads In values for the operation. 

3 You can also set the values from one Leads to the other by selecting the 
Copy Leads button.  

 
Press <OK> to return to the Profile Group Parameters dialog. 

Note:  The Lead angle is always set normal to the path of the tool by 
PartMaker.  Above, setting the Leads Out angle will allow the tool to 
retract in a manner perpendicular to the part.  For example, if turning a 45 
degree chamfer, a 0 degree lead angle would allow the tool to exit the stock 
on a 45 degree angle. 

4 Click the <Close> button to close the Profile Group Parameters dialog 
box. 

Notice, that by choosing a Tool Location of Face, PartMaker automatically 
applied your facing tool path to the part geometry. 
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Your completed profile should appear as below: 

 
Before moving on, save your work! Do so by selecting Save from the File menu or 
using the shortcut key <Ctrl + S>.  

Tool Path Verification 
Once a tool path is defined, you can verify its shape to gauge the accuracy of the 
cut you have defined. In PartMaker SwissCAM, for programming being done on 
the Main Spindle in a Face Window of Machining Function Turn, you have the 
option of performing two types of tool path verification: 

 Fixed headstock simulation  

 Or  

 Sliding headstock simulation (Stock Motion Simulation)   

Each type of verification has its relative merits. Fixed headstock simulation is 
excellent when focusing on the cut being made by a particular tool path. The sliding 
headstock simulation, referred to as Stock Motion Simulation, is excellent for 
seeing how your part will move through the guide bushing during machining and to 
assure that the Tool Shifts have been set properly.  

 Note: When performing, the Stock Motion Simulation, a guide bushing of 
the OD and Length described in the Setup dialog will be shown.  
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Fixed Headstock Simulation 

1 Select Verify Work Group Tool Path from the Part Features menu. You will be 
presented with the Tool Verification Options dialog.  

2 Check the Solid radio button 

3 Enter a delay between 0 and 9 (3 is a good starting number). The higher the 
number, the slower the verification will run. 

 
4 Click <OK> and you will see your tool path verified. 

5 Once you are satisfied with your tool path, choose Hide Work Group Tool 
Path from the Part Features menu.  

Note: Whenever you verify a tool path (or every tool path) you MUST 
choose Hide Work Group Tool Path from the Part Features menu before 
moving on and continuing to work in PartMaker.  Not doing so could 
hamper performance of your system.  To stop verification before it is 
complete, hit the <Esc> key. 

Sliding Headstock Simulation 

 Note: Sliding Headstock Simulation is only possible in a Face Window of 
Machining Function type Turn used for Main Spindle operations. 

1 Select Verify Every Tool Path from the Part Features menu. You will be 
prompted with the Tool Path Verification Options Menu.  

2 Check the Solid radio button and the Stock Motion Simulation. 

3 Enter a delay between 0 and 9 (3 is a good starting number). The higher the 
number, the slower the verification will run. 

 
4 Click <OK> and you will see your tool path verified with the stock moving 

and a Guide bushing drawn on the screen. 

Note: you may have to move and/or zoom out the part on the screen to 
view the simulation satisfactorily. 

5 Once you are satisfied with your tool path, choose Hide Every Tool Path 
from the Part Features menu.  
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Defining the 1st OD turning profile 
1 Click anywhere in the Face Window to make it active. 

2 Choose red from the Color Bar in the upper right corner.  

3 Choose New Profile Group from the Part Features menu, or icon to 
display the Profile Group Parameters dialog. 

4 From the Strategy menu, select Turning (The turning setting allows 
PartMaker to stop from Overcutting on certain profiles). 

5 From the Tool Location menu, select Out. 

6 From the Tool Orientation menu, select Right. 

7 Remove the check from the Roughing Tool ID: which will automatically 
cause the Finishing Tool ID: to be checked. 

8 Click <Select Tools> and select the appropriate tool.  

9 In this case you are doing main spindle work, so choose T001 and click 
<Select>.  You are choosing T001 because this tool has been setup up for 
work on the main spindle and in the Tool Database has been designated as a 
Gang Tool. 

10 In the upper right corner, select Part Profile Boundaries from the Cutting 
Limits defined By: drop-down list. 

Note: Selecting Part Profile Boundaries moves the Cutting Limits to the 
edges of the part profile. For more information see Cutting Limits in the 
user manual or Help files. 

11 In the field called Group Name, enter 1st Turn. Your dialog should now 
appear as shown below: 
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Leads  
1 Now you will set the lead in and lead out for your profile. Click the Leads 

button and Leads dialog will appear. Set the line lengths as they appear 
below:  

 
2 Click <OK> when done. 

3 You have now finished entering the parameters for the Face Part Profile 
Group. Click <Apply> and <Close> to accept all changes. 

Assign The Profile 
1 Select the Define Profile Icon and then the Closest Intersection Snap 

Mode icon  

2 Click near the intersections on the screen in the order indicated below to 
create the profile. You will notice as you click from point to point that the 
profile is being created. 

 
3 After clicking the last intersection, select the Screen Snap Mode icon.  

4 Now click on the screen out side of the part boundaries. 
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5 Click the Selection Icon on the left side of the screen. This will end the 
profile. Your completed profile should appear as shown here: 

 
Before moving on, save your work! Do so by selecting Save from the File menu or 
using the shortcut key <Ctrl + S>.  

Tool Path Verification 

Fixed Headstock Simulation 

1 Select Verify Work Group Path from the Part Features menu.  

2 Check the Hollow radio button 

3 Click <OK> and you will see your tool path verified.  

4 Once you are satisfied with your tool path, choose Hide Work Group Tool 
Path from the Part Features menu. 

Sliding Headstock Simulation 

1 Select Verify Every Tool Path from the Part Features menu. You will be 
prompted with the Tool Verification Options menu.  

2 Check the Solid radio button. 

3 Click <OK> and you will see your tool path verified with the stock moving 
and a Guide bushing drawn on the screen. 

Note: You may have to move and/or zoom out the part on the screen to 
view the simulation satisfactorily. 

 
4 Once you are satisfied with your tool path, choose Hide Every Tool Path 

from the Part Features menu.  
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Defining a Drilling Operation 
1 Click anywhere in the Face Window to make it active. 

2 Choose Cyan from the Color Bar in the upper right side.  

3 Choose New Hole Group from the Part Features menu to display the Hole 
Group Parameters dialog.  When selected, you should see a dialog which 
appears as the one below: 

 
4 Uncheck the Through Hole box. 

5 Under Major Cycle Operation set the Type of Operation to Drill. 

6 Under Major Cycle Operation enter .120 (3.0) in the Diameter field. 

Note: The Major Cycle Operation parameters are used by PartMaker to 
search the Cycles Database for an appropriate cycle. 

7 Enter 0.010 (1.0) into the Chamfer (C) field. PartMaker will calculate the 
depth of a Spot Drill according to the size of the Chamfer entered and the 
angle of the spot drill. 

8 Enter 0 into the Z_surf (S) field. 

9 Enter .050 (1.0) into the Face Clearance (Cf) field. 

10 Enter .220 (5.6) into the Nominal Depth (D) field. 

11 In the To: drop down menu under Nominal Depth (D), select Shoulder of 
Major Tool to indicate where PartMaker will calculate the depth of the 
tools. 
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12 Click <Cycle> and PartMaker will search the Cycles Database for the 
appropriate cycle to create the desired hole by clicking <Select>.  

 
13 You will notice a cycle is chosen and the tools and calculated depths are 

listed in the field in the lower left of the Hole Group Parameters. The 
dialog should now appear as below. 

 
14 Click <Verify Shape>. This will display a graphical representation of the 

cycle. 

 
15 Click <Hide Shape> when done, returning to the Hole Group Parameters. 
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16 Click <Apply> to accept all the information. 

17 Click <Close> to close the Hole Group Parameters. 

On the Screen you will now see a Profile of a Spot Drill and a Drill. Creating a Hole 
Group in a Turning window allows PartMaker to create the tool paths automatically 
from the information provided. 

 
Before moving on, save your work! Do so by selecting Save from the File menu or 
using the shortcut key <Ctrl + S>. 

Tool Path Verification 

Fixed Headstock Simulation 

1 Select Verify Work Group Tool Path from the Part Features menu. You will 
be prompted with the Tool Path Verification Options menu.  

2 Check the Hollow radio button 

3 Click <OK> and you will see your tool path verified. 

4 Once you are satisfied with your tool path, choose Hide Work Group Tool 
Path from the Part Features menu.  

Sliding Headstock Simulation 

1 Select Verify Every Tool Path from the Part Features menu. You will be 
prompted with the Tool Path Verification Options menu.  

2 Check the Solid radio button. 

3 Click <OK> and you will see your tool path verified with the stock moving 
and a Guide bushing drawn on the screen. 

Note: You may have to move and/or zoom out the part on the screen to 
view the simulation satisfactorily. 

 
4 Once you are satisfied with your tool path, choose Hide Every Tool Path 

from the Part Features menu.  
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Defining the ID Boring Operation 
1 Click anywhere in the Face Window to make it active. 

2 Choose yellow from the Color Bar in the upper right corner.  

3 Choose New Profile Group from the Part Features menu.  

4 From the Strategy menu, select Contouring. 

5 From the Tool Location menu, select In. 

6 Enter 0.0 into the Diameter Clearance (CD) field. 

7 Remove the check from the Roughing Tool ID: which will automatically 
cause the Finishing Tool ID: to be checked. 

8 Click <Select Tools> and select the appropriate tool. 

9 Click <Cutting Point (P):> button to display the Cutting Point dialog. 

 
10 Check Return to Cutting Point. 

 
Note: Placing a check by Return to Cutting Point will cause the tool to 
rapid to the defined cutting point after the lead out has been finished. 

11 In the field called Group Name:, enter ID Bore. 

12 Click <Apply> when done. 

The dialog should now appear as below. 
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Leads  
1 Next you would set the Lead in and Lead out for your profile. Click the 

Leads button and Leads dialog will appear. Set the line Lengths as they 
appear below: 

 
2 You have now finished entering the parameters for the Face Part Profile 

Group. Click <Apply> and <Close> to accept all changes. 

Assigning the Profile to the Geometry 
1 From the left-hand side of the screen select the Define Profile Icon. 
2 From the top of the screen, select the End of an Element Snap Mode icon. 

To define the tool path, click your left mouse on positions 1 through 4 as 
shown in the diagram below: 

 
After clicking the last intersection, select the Selection Icon on the left side 
of the screen. This will end the profile. 

Save your work  
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Tool Path Verification 
Use either method described above to make sure the tool paths you have defined 
are correct. 

 
Once you are satisfied with your tool path, choose Hide Every Tool Path from the 
Part Features menu.  
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Defining a Grooving Operation 
1 Click anywhere in the Face Window to make it active. 

2 Choose green from the Color Bar in the upper right corner.  

3 Choose New Profile Group from the Part Features menu to display the Profile 
Group Parameters dialog.  

4 From the Strategy menu, select Grooving. 

5 From the Tool Location menu, select Out. 

6 Set Profile Shape to Rectangular in the upper right hand corner of the 
dialog. 

7 Click <Select Tools> and PartMaker will prompt you to choose between 
the grooving style tools available in the Tools Database.  

8 In this case you are doing main spindle work, so choose T002 and click 
<Select>. This tool was previously set up in the Tools Database for you to 
use. 

9 Set the Depth of Cut (d) to .2 (5), Return Length to 0.05 (0.1), and 
Clearance to 0.05 (1.2) 

10 In the field called Group Name, enter Groove. Your dialog should now 
appear as shown below: 

 
You have now finished entering the parameters for the Groove Profile Group. 

11 Click <Apply> and <Close> to accept all changes. 
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Assigning the Profile to the Geometry 
1 From the left-hand side of the screen select the Define Profile icon. 
2 From the top of the screen, select the Closest Intersection Snap Mode. To 

define the tool path, click your left mouse on positions 1 through 4 as shown 
in the diagram below: 

 
3 After clicking the last intersection, click the Selection Icon on the left side of 

the screen. This will end the profile. 

4 Save your work. 

Tool Path Verification 

Fixed Headstock Simulation 

1 Select Verify Work Group Tool Path from the Part Features menu. You will be 
prompted with the Tool Path Verification Options menu.  

2 Check the Hollow radio button.  

3 Click <OK> and you will see your tool path verified. 

4 Once you are satisfied with your tool path, choose Hide Work Group Tool 
Path from the Part Features menu.  

Sliding Headstock Simulation 

1 Select Verify Every Tool Path from the Part Features menu. You will be 
prompted with the Tool Path Verification Options menu.  

2 Check the Solid radio button, and enter a delay between 0 and 9 (3 is a 
good starting number). The higher the number, the slower the verification 
will run. 

3 Click <OK> and you will see your tool path verified. 

Note: You may have to move and/or zoom out the part on the screen to 
view the simulation satisfactorily. 

 
4 Once you are satisfied with your tool path, choose Hide Every Tool Path 

from the Part Features menu.  
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Defining a Thread Profile 
1 Click anywhere in the Face Window to make it active. 

2 Choose a new color from the Color Bar which is in the upper right corner. If 
you are running out of colors, click on the icon as shown below. 

 

 
Note: For additional colors you can click on <Define Custom Colors> and 
pick a different color. 

 
3 Choose New Profile Group from the Part Features menu to display the Profile 

Group Parameters dialog.  

4 From the Strategy menu, select Threading. 

5 From the Tool Location menu, select Out. 

6 Select No Chamfer from the Toolpath Options: drop-down in the upper 
right hand corner of the dialog. 

7 Enter 0.005 (.1) in the First Infeed (i) field. 

8 Enter 1/28 (.75) in the Pitch (p) field. 

9 Enter 0.05 (1.0) in the Clearance (C) field. 

10 Enter 0.1 (1.0) in the Acceleration Dst (L1) field. 
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11 Click <Select Tools> and select the appropriate tool. 

 
12 In the field called Group Name, enter Thread. Your dialog should now 

appear as shown below: 

 
Note: The Thread Height = 61.34% of the pitch is standard for ANSI inch 
and ISO / DIN 60º thread form. 

13 You have now finished entering the parameters for the Thread Profile Group. 
Click <Apply> and <Close> to accept all changes. 
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Assigning the Profile to the Geometry 
1 You will now create the profile for this process. Select the Define Profile 

Icon from the icons on the left side of the screen.  

2 Select the Closest Intersection Snap Mode icon from the upper left.  

3 Click near the intersection where the major diameter and threads begin for 
the start of the thread profile.  

 
4 Now select ZX Coordinates Snap Mode icon from the upper left.  

5 Enter .315 (8.0) in the lower left Z field. Do not change the X field. 

 
6 Press <Enter> to accept. 

7 Select the Selection Icon in the upper left. The Thread Profile is now 
complete. 

 
Save your work. 
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Tool Path Verification 

Fixed Headstock Simulation 

1 Select Verify Work Group Tool Path from the Part Features menu. You 
will be prompted with the Tool Path Verification Options menu. 

2 Check the Hollow radio button.   

3 Click <OK> and you will see your tool path verified. 

4 Once you are satisfied with your tool path, choose Hide Work Group Tool 
Path from the Part Features menu. 

Sliding Headstock Simulation 

1 Select Verify Every Tool Path from the Part Features menu. You will be 
prompted with the Tool Path Verification Options menu. 

2 Check the Solid radio button. 

3 Click <OK> and you will see your tool path verified. 

Note: You may have to move and/or zoom out the part on the screen to 
view the simulation satisfactorily. 

 
4 Once you are satisfied with your tool path, choose Hide Every Tool Path 

from the Part Features menu.  
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Defining the 2nd Turning Operation 
1 Click anywhere in the Face Window to make it active. 

2 Choose green from the Color Bar.   

3 Choose New Profile Group from the Part Features menu to display the Profile 
Group Parameters dialog.  

4 From the Strategy menu, select Contouring. 

5 From the Tool Location menu, select Out. 

6 From the Tool Orientation menu, select Right. 

7 Uncheck the Roughing Tool ID: box which will automatically cause the 
Finishing Tool ID: to be checked. 

8 Click <Select Tools> and select the appropriate tool.  

9 In this case you are using the same tool as in the 1st Turn process, so 
choose T001 and click <Select>.  

10 In the field called Group Name, enter 2nd Turn. Your dialog should now 
appear as shown below: 
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Leads  
1 Now you will set the lead in and lead out for your profile. Click the Leads 

button and Leads dialog will appear. Set the line Lengths as they appear 
below:  

 
2 Click <OK> when done. 

3 You have now finished entering the parameters for the 2nd Turn Profile 
Group. Click <Apply> and <Close> to accept all changes. 

Assigning the Profile to the Geometry 
1 You will now create the profile for this process. Select the Define Profile 

Icon from the icons on the left side of the screen.  

2 Select the Closest Intersection Snap Mode icon from the upper left.  

3 Click near the intersection where the 2nd Turn profile will start. 

 
4 Now select ZX Coordinates Snap Mode icon from the upper left.  

5 Enter 1.2 (30.50) in the lower left Z field. Do not change the X coordinate 
value. 

 
6 Press <Enter> to accept. 

7 Select the Selection Icon in the upper left. 
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The 2nd Turn Profile is now complete. 

 

Save your work.  

Tool Path Verification 
Use either method described before to make sure the tool paths you have defined 
are correct. 

Once you are satisfied with your tool path, choose Hide Every Tool Path from the 
Part Features menu. 
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Defining the Cut Off Operation 
1 Click anywhere in the Face Window to make it active.  

2 Choose Magenta from the Color Bar.   

3 Choose New Profile Group from the Part Features menu to display the Profile 
Group Parameters dialog.  

4 From the Strategy menu, select Cut-Off. 

5 Select Insert Chamfer from Toolpath Options in the upper right hand 
corner of the dialog. 

6 Enter .01 (.2) into the Chamfer or Radius (q) field. 

7 Enter .240 (6.0) into the Start X Point (Xs) field. This is a RADIAL value 

8 Click <Select Tools> and select the appropriate tool. 

In this case you are doing main spindle work, so choose T011 and click 
<Select>.  You are choosing T011 because it is set up as the Cut Off tool. 

 
9 Check Optional Path 1->2->1. This will cause the Cut Off tool to rough out 

material before creating a chamfer. 

10 In the field called Group Name, enter Cut Off. Your dialog should now 
appear as shown below: 
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Leads In/ Leads Out 
1 Now you will set the lead in and lead out for your profile. Click the Leads 

button and the Leads dialog will appear. Set the line Lengths as they appear 
below:  

 
2 Click <OK> when done. 

3 You have now finished entering the parameters for the Cutoff Profile 
Group. Click <Apply> and <Close> to accept all changes. 

Note: After closing the Profile Group Parameters, PartMaker 
automatically created the profile on the screen based on the information 
given. 

 
Save your work. 
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Tool Path Verification 

Sliding Headstock Simulation 

1 Select Verify Every Tool Path from the Part Features menu. You will be 
prompted with the Tool Path Verification Options menu. 

2 Check the Solid radio button. 

3 Enter a delay of 2. 

4 Click <OK> and you will see your tool path verified. 

Note: You may have to move and/or zoom out the part on the screen to 
view the simulation satisfactorily. 

 
5 Once you are satisfied with your tool path, choose Hide Every Tool Path 

from the Part Features menu.  



 

Copyright @2014 Delcam Ltd  User Guide 1-45  

 

Milling a Slot on the Main Sub-spindle Using the Mill ZY Face 
Window  

This section of the tutorial will instruct you in the steps necessary to create the slot 
on the front of the part by performing milling in a Mill ZY Face Window. 

Setting Up the Face Window 
1 Choose Setup from the View Menu. 

2 Click <New> to create a new Face Window. 

3 Under Machining Function choose Mill ZY Plane. 

4 Enter Mill ZY into the Rename to: field. 

Your Setup dialog should appear as shown below. 

 
5 Click <Apply> and <Close> when finished. 
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Creating the Geometry for the Slot Milling Operation 
1 Click <CAD/CAM> switch in the lower left to switch to CAD mode.  

Copy the geometry already drawn in the Main Spindle – Turn Face 
Window. To do so: 

2 Select Main Spindle – Turn from the Window menu. 

3 Click <CAD/CAM> switch in the lower left corner of Main Spindle – Turn 
Window to switch to CAD mode. 

4 Choose Select All from the Edit menu or use the shortcut <Ctrl-A> to 
select all the geometry in the window. 

5 Select Copy from the Edit menu or use the shortcut <Ctrl-C> to copy the 
geometry. 

6 Select Mill ZY from the Window menu to switch to the Mill ZY Face 
Window. 

7 Select Paste from the Edit Menu or use <Ctrl-V> to paste the geometry 
into the Mill ZY Face Window. 

8 Click anywhere in the Face Window to deselect the geometry and make the 
window active. 

9 You now need to create a line for the Tool Path to follow. Select the Line 
Parallel Vertical Axis Icon on the left side of the screen. 

10 Enter .04 (.1) in the lower left field. 

 
11 Press <Enter> to create the vertical line. 

12 Next select the Remove Icon on the left side of the screen.   

13 Click Near the upper and lower portions of the vertical line you created to 
trim the line. 

 
14 Click the Selection Icon in the upper left. 
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Defining the Slot Milling Operation 
1 Click the CAD/CAM switch in the lower left to switch to CAM mode.  

2 Choose New Profile Group from the Part Features menu to display the 
Profile Group Parameters dialog.  When selected, you should see a dialog 
which appears as the one below:   

 
3 From the Strategy menu, select Contour Mill. 

4 From the Tool Position menu, select Left. 

5 Enter .125 (3.1) into the X_Surf (S) field. 

6 Enter 0.145(3.7) into the X_Depth (D) field. 

7 Uncheck from the Roughing Tool ID:, this will automatically cause the 
Finishing Tool ID: to be checked. 

8 Enter .5 (20.0) into the field under Diam (d). 

9 Enter T007 into the field under Tool ID. This is the Slotting Tool entered 
into the Tools Database for this operation. 

10 Click the <Apply> to selelct the slitting saw 

11 In the field called Group Name, enter Slot. 

Your dialog should now appear as shown below: 
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Leads In/ Leads Out 
1 Now you will set the lead in and lead out for your profile. Click the Leads 

button and the Leads dialog will appear. Set the line Lengths as they appear 
below:  

 
2 Click <OK> when done. 

3 You have now finished entering the parameters for the Slot Profile Group. 
Click <Apply> and <Close> to accept all changes. 

Assigning the Profile to the Geometry 
1 Select the Define Profile Icon from the icons on the left side of the screen. 

2 Select the Closest Intersection Snap Mode icon from the upper left. 

3 Click near the intersections on the screen in the order indicated below to 
create the profile. You will notice as you click from point to point that the 
profile is being created. 

 
4 After clicking the last intersection, select the Selection Icon on the left side 

of the screen. This will end the profile. 

5 Save your work  



 

Copyright @2014 Delcam Ltd  User Guide 1-49  

 

Tool Path Verification 
1 Select Verify Work Group Tool Path from the Part Features menu. You will be 

prompted with the Tool Path Verification Options menu. 

2 Check the Hollow radio button and enter a delay between 0 and 9 (3 is a 
good starting number). The higher the number, the slower the verification 
will run. 

3 Click <OK> and you will see your tool path verified.  

 
4 Once you are satisfied with your tool path, choose Hide Work Group Tool 

Path from the Part Features menu. 
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Milling the Square on the Main Spindle 
This section of the tutorial will instruct you in the steps necessary to perform milling 
in a Mill Polygon Face Window. 

 Note: All Milling Style Face Windows use Radius not Diameter style 
programming. 

Setting Up the Face Window  
1 Choose Setup from the View Menu. 

2 Click <New> to create a new Face Window. 

3 Under Machining Function choose Mill Polygon. 

4 Enter Mill Polygon into the Rename to: field. 

Your Setup dialog should appear as shown below. 

 
5 Click <Apply> and <Close> when finished. 
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Creating Geometry in CAD Mode 
In this section, you will create the geometry for the square profile to be milled. 

1 Click on the CAD/CAM switch to return to the CAD mode.  

2 Select the Polygon Icon. 

After doing so, a dialog will open prompting you to enter a distance and a 
number of sides. 

3 Enter a distance of .135*2 (3.375*2) and 4 for the number of sides. Click 
the <OK> button.  

Define Polygon By: 

Flat to Flat (D). Allows you to specify 
the distance between parallel sides. 

Center to Flat (d). Allows you to specify 
the distance between center and a side. 

Outer Circle Radius(R). Allows you to 
specify the radius of outer circle. 

Side Length (L). Allows you to specify 
the side length. 

Number of Sides (n). Specifies the 
number of sides in polygon. 

Orientation Angle (A).  Specifies the 
polygon angle with horizontal axis. 

Center:  

 z: Specifies the horizontal coordinate 
of the polygon center. 

 x: Specifies the vertical coordinate of 
the polygon center. 

Your screen should appear as shown below: 

 
Next, you will proceed to machine this square in CAM mode. 
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Creating the Square Profile  
In this section, you will define the profile to machine the hexagonal flats on the 
work piece. 

1 Click the CAD/CAM switch which will put you back into the CAM mode. 

2 In CAM mode, select red from the color bar.   

3 Select New Profile Group from the Part Features menu.  

4 In the Group Name box, type Mill Square. 

5 Choose Left Tool Edge (P1) in the To: drop down menu to define the 
Distance From Part Face from which the hex will be milled. 

6 Enter .550 (14.0) for P1, representing the distance from the part face 
machining will occur. 

7 Enter 0.375 (10.0) for Tool Diameter. 

8 Click on the <Select Tools> button. An end mill icon will appear to the right 
of the Tool ID box. The completed Profile Group Parameters dialog 
should appear as shown below: 

 
Now that you have completed setting up the profile group, take a moment to study 
this dialog, as it is unique to other PartMaker Milling Profile Group Parameters 
dialogs you have encountered. Understand the following unique parameters: 

Distance From Part Face 

To: Left Tool Edge (P1): Specifies the distance from the face of the part to 
the left edge of the tool.  

To: Tool Center (P2): Specifies the distance from the face of the part to 
tool center. 

To: Right Tool Edge (P3): Specifies the distance from the face of the part 
to the right edge of the tool. 

X_Surf:  The distance from the center of the cylinder to the edge of the 
diameter.  PartMaker calculates this parameter automatically based on the value 
you enter for the OD of the stock in the Setup dialog.  For the Swiss tutorial 2 
workpiece this is 0.5/2 or .25 (6.35). 

X_Rapid (R): Specifies the distance between the bottom tip of the tool and the 
part surface when tool performs Rapid Moves.  

Clearance (C): Specifies the distance between the bottom tip of the tool and 
the part surface when a tool starts feeding into the part.  

Tool Diam (d): Specifies diameters of tool.  

Click the <Close> button to close the Profile Group Parameters dialog box. 
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The next step is to develop the tool path.  To do so: 

1 Select the Chain Geometry Icon. 

2 Move your cursor above the top line of the square and slightly to the left of 
the horizontal axis line as indicated below. 

Click your mouse button and the screen should appear as shown below: 

 
The arrows display the direction of  the tool path.  The flats will be machined 
in this direction.  If you wish to machine the flats in the opposite direction, 
using the Selection icon, click anywhere on the tool path to select it.  
Choose Reverse from the Edit menu and the arrows displayed on the tool 
path will change direction.  

Before moving on, remember to save your work! Do so by selecting Save from the 
File menu or by using the shortcut key <Ctrl + S>. 

Tool Path Verification 
1 Select Verify Work Group Tool Path from the Part Features menu. You will be 

prompted with the Tool Path Verification Options menu. 

2 Check the Hollow radio button and enter a delay between 0 and 9 (3 is a 
good starting number). The higher the number, the slower the verification 
will run. 

3 Click <OK> and you will see your tool path verified.  

 
4 Once you are satisfied with your tool path, choose Hide Work Group Tool 

Path from the Part Features menu. 
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Drilling Cross (X Oriented) Holes - Main Spindle Using the Mill 
Diameter Index Machining Function 

This section of the tutorial will instruct you in the steps necessary to perform milling 
in a Mill Diameter Index Face Window. 

Setting Up the Face Window 
1 Choose Setup from the View Menu. 

2 Click <New> to create a new Face Window. 

3 Under Machining Function choose Mill Diam. Index. 

4 Enter Mill Diam Index into the Rename to: field. 

Your Setup dialog should appear as seen here. 

 
5 Click <Apply> and <Close> when finished. 
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Creating the Geometry for the Cross Drill Operation 
1 Click <CAD/CAM> switch in the lower left to switch to CAD mode. 

2 Choose Show Boundaries from the View Menu.  

3 Choose Show Axis from the View Menu.  

4 Select the Circle with a Known Radius and Center Icon from the left side 
of the screen. 

5 Enter .0625 (1.6) into the field at the bottom of the screen. 

 
6 Press <Enter> to accept the input. 

7 Enter .850 (21.60) in the Z field at the bottom of the screen. 

8 Enter 0 in the C field at the bottom of the screen. 

 
9 Press <Enter> to accept the input and place a circle on the screen. 

10 Choose the Selection Icon on the left side of the screen. 

11 Click the circle to select it. 

12 Choose Translate from the Edit > Transform menu.  

13 Check Multiple Copies option and enter 3 into the No. of Copies: field. 

14 Enter 0 into the Horizontal Distance (H): field. 

15 Enter 90 into the Vertical Distance (V): field. 
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16 Click <Translate> and <Close> to accept the inputs values and make 3 
more circles in the window. 

 
17 Click anywhere in the Face Window to deselect the circles 
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Defining the Cross Drilling Operation 
1 Click the green square in the Color Bar   

2 Choose New Hole Group from the Part Features menu to display the Hole 
Group Parameters dialog.  When selected, you should see a dialog which 
appears as the one below: 

 
3 Uncheck the Through Hole box. 

4 Under Major Cycle Operation set the Type of Operation to Drill. 

5 Under Major Cycle Operation enter .125 (3.175) into the Diameter field. 

Note: The Major Cycle Operation parameters are used by PartMaker to 
search the Cycles Database for an appropriate cycle. 

6 Enter .01 (.5) into the Chamfer (C) field. PartMaker will calculate the 
depth of a Spot Drill according to the size of the Chamfer indicated and 
based on the angle of the chamfering tool. 

7 Enter .240 (6.0) into the X_Surf (S) field. 

8 Enter .1 (2.5) into the X_Rapid (R) field> 

9 Enter .05 (1.0) into the X_Clear (Cl) field. 

10 Enter .150 (3.8)into the Nominal Depth (D) field. 

11 In the To: field under Nominal Depth (D), select Shoulder of Major Tool 
to indicate where PartMaker will calculate the depth of the tools. 
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12 Click the Cycle button and PartMaker will select the appropriate cycle to 
create the desired hole by clicking <Select>. The selected cycle should be 
Cross Drill .125 (Drill 3.5 X). 

 
13 The dialog should now appear as below. 

 
14 Review the dialog, then click <Verify Shape>. This will display a graphical 

representation of the cycle. 

 
15 Click <Hide Shape> when done, returning to the Hole Group Parameters. 

16 Click <Apply> and <Close> to close the Hole Group Parameters dialog. 
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Select the Holes 
1 From the left hand tool bar, select the Chain Circle icon.   

2 Click on any one of the four circles and PartMaker will select the other three. 
After doing so, your screen should appear as shown below:  

 
3 Choose the Selection Icon to finish selecting circles. 

4 Save your work. 

Tool Path Verification 
1 Select Verify Work Group Tool Path from the Part Features menu. You will be 

prompted with the Tool Path Verification Options menu. 

2 Check the Hollow radio button. 

3 Click <OK> and you will see your tool path verified. 

Note: You may have to move and/or zoom out the part on the screen to 
view the simulation satisfactorily. 

 
4 Once you are satisfied with your tool path, choose Hide Work Group Tool 

Path from the Part Features menu.  
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Drilling the Face Holes - Sub Spindle Using Mill End Index 
Machining Function  

This section of the tutorial will instruct you in the steps necessary to perform drilling 
in a Mill End Index Face Window on the Sub Spindle. 

 Note: In PartMaker all programming is done using the same convention 
whether it is done on the main spindle or sub spindle. In the following 
window, you will be looking at the end of the part as it would look in the Sub 
Spindle. 

Setting Up the Face Window 
1 Choose Setup from the View menu. 

2 Click <New> to create a new Face Window. 

3 Select Sub Spindle (red circle) as this will be an operation carried out on 
the Sub Spindle. 

4 Under Machining Function choose Mill End Index. 

5 Enter Mill End Index into the Rename to: field. Click <Apply>. 

Your Setup dialog should now look like this. 

 
6 Click <Close> when finished. 
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Creating the Geometry for the Face Drill Operation  
1 Click <CAD/CAM> switch in the lower left to switch to CAD mode. 

2 Choose Show Boundaries from the View menu. 

3 Choose Show Axis from the View menu. 

Note: The boundaries are round because you are looking at the end of the 
part.  

 
4 Select Circle with a Known Radius and Center Icon from the left side of 

the screen.  

5 Enter 0.0625/2 = .03125 (.75) into the field at the bottom of the screen. 

 
6 Press <Enter> to accept the input. 

7 Select the XY Coordinates Snap Mode Icon in the upper left of the screen.  

8 Enter .180 (4.5) in the X field at the bottom of the screen. 

9 Enter 0 in the Y field at the bottom of the screen. 

 
10 Press <Enter> to accept the input and place a circle on the screen .180 from 

the center of the part. 

11 Choose the Selection Icon on the left side of the screen.  

12 Click on the circle you just drew to select it. 

13 Choose Rotate from the Edit > Transform menu.  

14 Check Multiple Copies option and enter 3 into the No. of Copies: field. 

15 Enter 90 into the Angle: field. 

16 Enter 0 into the X: field indicating the rotation point. 
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17 Enter 0 into the Y: field indicating the rotation point. 

 
18 Click <Rotate> and <Close> to accept the input values and place 3 more 

circles in the window. 

Your screen will appear as below: 
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Defining the Face Drilling Operation for the Sub Spindle 
1 Click <CAD/CAM> switch in the lower left to switch to CAM mode.  

2 Choose New Hole Group from the Part Features menu to display the Hole 
Group Parameters dialog. 

3 Uncheck the Through Hole box. 

4 Under Major Cycle Operation set the Type of Operation to Drill. 

5 Under Major Cycle Operation enter .0625 (1.5) into the Diameter field. 

Note: The Major Cycle Operation parameters are used by PartMaker to 
search the Cycles Database for an appropriate cycle. 

6 Enter 0.005 (.1) into the Chamfer (C) field. PartMaker will calculate the 
depth of a Spot Drill according to the size of the Chamfer indicated. 

7 Enter 0.0 into the Z_Surf (S) field. 

8 Enter .250 (6.35) into the Nominal Depth (D) field. 

9 In the To field under Nominal Depth (D), select Shoulder of Major Tool 
to indicate where PartMaker will calculate the depth of the tools. 

10  Click the Cycle button and PartMaker will select the appropriate cycle to 
create the desired hole by clicking <Select>. The selected cycle should be 
Drill .0625-Sub  (Drill_1.5 z sub). 
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11 You will notice a cycle is chosen and the tools and calculated depths are 
listed in the field in the lower left of the Hole Group Parameters. The 
dialog should now appear as below. 

 
12 Review the dialog, then Click <Verify Shape>. This will display a graphical 

representation of the cycle. 

 
13 Click <Hide Shape> when done, returning to the Hole Group Parameters. 

14 Click <Apply> to accept all the information. 

15 Click <Close> to close the Hole Group Parameters. 

You are now ready program the holes. To do so:  

1 From the left hand tool bar, select the Chain Circles Icon. 

2 Click on any one of the four circles and PartMaker will select the other three. 
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After doing so, your screen should appear as shown below:  

 
3 Select the Selection Icon on the left side of the screen.  

Before moving on, remember to save your work.  Do so by selecting Save from the 
File menu or using the shortcut key <Ctrl + S>. 

Tool Path Verification 
1 Select Verify Work Group Tool Path from the Part Features menu. You will be 

prompted with the Tool Path Verification Options menu. 

2 Check the Hollow radio button. 

3 Click <OK> and you will see your tool path verified. Note: you may have to 
move and/or zoom out the part on the screen to view the simulation 
satisfactorily. 

Note: The arrows indicate order of holes. 

 
4 Once you are satisfied with your tool path, choose Hide Work Group Tool 

Path from the Part Features menu. 
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Creating an NC Program 
At this point, you have completed creating the three faces for the Swiss tutorial 
part. You are now prepared to take the final steps in developing your part program. 

The steps required for process plan development and program creation are 
described using the “generic” Fanuc-style Swiss-lathe post processor that comes 
standard with your PartMaker SwissCAM software. Synchronization and other 
processing related issues may vary slightly for different machine makers, but the 
steps below are instructive to help you build an understanding of process 
development in PartMaker SwissCAM. 

 Tip:  Refer to the Machine Specific Addendum that came with your 
PartMaker software for more information on process planning and post 
processing issues for the Swiss-type lathes in your shop. 

Generating a Process Table 
The first step in generating an NC program is creating a Process Table. A Process 
Table shows you all of the machining processes for a part.   

When PartMaker generates a Process Table, all cutting conditions such as feed rate 
and spindle speed (RPM) are calculated automatically based on the tools and 
material information previously entered. A time for each operation is shown, along 
with a total machining time for both the main and sub spindles. These time 
calculations give the user a sense of how closely “balanced” machining is for a part, 
i.e. how much cycle time is expended on both main and sub spindles in addition to 
the total time to cut the part. Time calculations in PartMaker include both “in-cut” 
time as well as tool change time. 

To create the Process Table: 

1 Choose Generate Process Table from the Job Optimizer menu.  Upon 
doing so, you will be prompted with the dialog below:  

 
2 Leave the boxes in the Process Table Options dialog checked and click on 

<OK>. 
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The Process Table will be display as below. 

 

 Notice the buttons on the right side of the screen. These open the Set 
Modes dialog for each process. These buttons also visually indicate the 
primary spindle for each process. You will use these buttons later to set 
Synchronization. 

 

Visual Process Synchronization and PartMaker Specific Modes 
When generating a Process Table, PartMaker starts by choosing the processes in 
the first Face Window you have created in the Setup dialog and executing all the 
part features in that Face Window in the order they have been created. The 
software then moves onto the next Face Window you have created and executes 
the processes defined in that Face Window. 

Of course, in Swiss machining, to conserve cycle time, many processes may be 
happening simultaneously, rather than in the sequential order in which you have 
created your tool paths in PartMaker. The Process Table accommodates this unique 
feature of Swiss machines allowing you to define the true order of processes defined 
in different Face Windows. It is in the Process Table that you synchronize 
operations being performed simultaneously with either different tool posts (i.e. 
gang, back working, turret etc) or on different spindles (main vs. sub) or some 
combination of the two. Such synchronization is done by pointing and clicking to 
place the order of processes and then by assigning different Synchronization Modes 
in the Set Modes dialog to link different processes to one another.   

More information on the Set Modes dialog can be found in Chapter 2, PartMaker 
Fundamentals of the SwissCAM User Guide. In addition, more information on 
synchronization supported by your machine can be found in the post processor 
reference guide that can be generated on demand. After select your post processor 
under the Job Optimzer menu, .choose Job Optimizer > Create Post Processor 
Reference Guide… and follow the prompts. 
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Arranging the Processes in the Process Table 
1 Click in the middle of the screen on Process P02 to select the 1st Turn 

Process. This is indicated by highlighting it as the selected process. 

 
2 You need to move this process to happen after Process P05 ID Bore. While 

Process P02 1st Turn is highlighted, click on the Arrow between Process 
P05 ID Bore and Process P06 Groove as shown. 

 
The Process Table should now appear as below: 
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3 Next you need to move Process P10 Slot up above Process P08 2nd 
Turn. Click in the middle of the screen on Process P10 Slot to select it. 

 
4 Click on the Arrow between Process P07 Thread and Process P08 2nd Turn to 

move Process P10 Slot above Process P08 2nd Turn. 

The Process Table should appear as below: 

 
5 Next you need to move Process P11 Mill Square up above Process P08 

2nd Turn. Click in the middle of the screen on Process P11 Mill Square to 
select it. 

 
6 Click on the Arrow between Process P10 Slot and Process P08 2nd Turn to 

move Process P11 Mill Square above Process P08 2nd Turn. 

The Process Table should now appear as below: 
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The full Process Table should appear as below: 

 



 

Copyright @2014 Delcam Ltd  User Guide 1-71  

 

Setting the Eject Process 
1 On Process P15 Drill .0625-Sub go to the right side of the screen and find 

the last sub spindle process.  

2 Click <Set Modes> (buttons on right of each process) for Process P15 Drill 
.0625-Sub. 

 
3 Find the Eject Part (E) check box inside the Set Modes dialog. 

 
4 Click <OK> when done. 
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Setting the Cut-off Process for Sub Spindle Support 
1 Select Process P09 Cut Off.  

 
2 Click on the Mode Switch for the cutoff process. 

3 Under Sub Spindle Mode, select Follow Support (SF). Notice the graphics 
change according to the mode. 

4 Enter 1.0 into the Sub-Spindle Support Z-Coordinate (Sz) field as shown 
below. 

 
5 Click <OK> when done. 
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Synchronizing Main and Sub Spindle Processes in the Process 
Table 

In this section you are going to synchronize Main Spindle processes and Sub 
Spindle processes to run at the same time to optimize the machine usage.  The 
following operations will be run “simultaneously”. 

Main Spindle Processes Gang Tools Sub Spindle Processes Back Tools 

P02 1st Turn P14 Drill .0625-Sub (Drill 1.5-Sub) 

P06 Groove P15 Drill .0625-Sub (Drill 1.5-Sub) 

P07 Thread  

P10 Slot  

P11 Mill Square  

P08 2nd Turn  

P12 Cross Drill .125 (Cross Drill 3.5)  

P13 Cross Drill .125 (Cross Drill 3.5)  

 Note:  Notice processes P01, P03, P04 and P05 are NOT being synchronized 
with the operations on the sub spindle.  The reason for this is that processes 
P03, P04 and P05 are being carried out by the End Working Tool Post and 
CANNOT work at the same time as the tools in processes P14 and P15, which 
are mounted on the Back Working Tool Post.  The machine layout assumed 
for this part on page 3 of this tutorial precluded End Working and Back 
Working Tool Posts from being used simultaneously. 

1 On Process P02 1st Turn go to the right side of the screen and click <Set 
Modes>. 

 
2 Under Sub Spindle Mode, select Machining with One Tool (S1). This will 

allow PartMaker to Synchronize Sub Spindle processes with this process. 
Notice the graphics change according to the mode. 
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3 At the bottom of the dialog, select Modify Modes for all Consecutive 
Processes with Same Mode. This will set all the modes following the 
Process you are setting that are M1S0 (Main Spindle One Tool, Sub Spindle 
Idle) to the new mode M1S1 (Main Spindle One Tool, Sub Spindle One Tool). 

 
4 Click <OK> when done. 

The Process Table should appear as below: 

Notice the Set Modes Buttons to the right have changed for all the processes 
following Process P02 1st Turn that were M1S0 to M1S1. 

 



 

Copyright @2014 Delcam Ltd  User Guide 1-75  

 

5 On Process P14 Drill .0625-Sub go to the right side of the screen and click 
<Set Modes>. 

 
6 Under Main Spindle Mode, select Machining with One Tool (S1). This 

will allow PartMaker to Synchronize Main Spindle processes with this 
process. Notice the graphics change according to the mode. 

 
7 At the bottom of the dialog, select Modify Modes for all Consecutive 

Processes with the Same Mode. This will set all the modes following the 
Process you are setting that are M0S1 (Main Spindle Idle, Sub Spindle One 
Tool) to the new mode M1S1 (Main Spindle One Tool, Sub Spindle One 
Tool). 

The Process Table should appear as below: 

Notice the Set Modes Buttons to the right have changed for all the processes 
following Process P14 Drill 1.5-Sub that were M0S1 to M1S1. 
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8 Click <Synchronize> in the upper right to create the synchronized groups. 

 
Notice the Sync Group number on the right hand side of the Process Table. 

 
9 Click < Time Chart> on the top of the Process Table to display the Time 

Chart. The Time Chart displays the “overlapping” operations, the result of 
your process synchronization; graphically showing just how much sub-
spindle machining time you are “getting for free.” 
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Simulating the Machining Process 
Having completed generating the Process Table, synchronizing operations and 
loading a post processor, you can now simulate the processes. The simulation will 
show your part being cut just how it would on your machine tool.  Simulation will 
show synchronization between your Main and Sub-Spindles. It will also show any 
collisions that may occur between the tooling, material, and/or Spindles. 

1 Click the <Simulation> button at the bottom left hand portion of the 
Process Table. 

2 Press the Space Bar or choose Simulation from the Simulation menu to 
begin the simulation.  

Viewing Basic Simulation 

 
When you are done viewing the simulation, select Show Finished Part from 
the Simulation menu. 
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Viewing Advanced Simulation 
Press the <Spacebar> to start simulation. 

 

 Note: In ADVANCED simulation, tools are shown held in PARAMETRIC tool 
holder blocks that represent the standard locations on Swiss machines: 
Gang, Turret, Front, Back 

Rotating, Zooming and Sectioning the part works exactly the same as it does in 
Basic Simulation. 
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Generating an NC Program 
Having selected a Post Configuration file, you are now ready to generate an NC 
Program.  To do so: 

1 Choose Generate NC Program from the Job Optimizer menu.  

Note:  Choosing the Generate NC Program command from the Job 
Optimizer menu has the same effect as clicking the Sync Group button on 
the Process Table if Sync Groups have not yet been created. 

2 You will next see the Post Options dialog.  Set the Post Options dialog as 
shown below: 

 
In the Post Options dialog you set certain parameters for assignment 
during post processing.  Please refer to your machine specific addendum for 
more information on how each of the fields in this dialog pertain to your 
Swiss turning equipment. 

3 Click <OK> in the Post Options Dialog to proceed to the Save NC 
Program dialog.  In this dialog, enter a name for your program.  Here you 
should enter “Plug.TXT”. 
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4 Click <Save> to generate the NC program. You will see your programs as 
shown below: 

 
 

You have just completed programming Swiss_Tutorial2 – Plug. 
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Chapter 2: PartMaker® SwissCAM™ 
Programming Tutorial Part 3 – Reamer 
Introduction 

This tutorial is designed to help you learn the steps to go through in using 
PartMaker SwissCAM to program Swiss-type lathe parts. The illustration on the 
following page represents a typical part that would be cut on a CNC Swiss type 
lathe.  

 Important! The tutorial below is presented in both inch and metric units, 
depending on how you are working with PartMaker.  The inch units of 
measure are given first, with the metric entries gives in parenthesis ( ). 

For example you may see instruction that says: Enter an X value 1 (25), 
where 1 is 1 inch and 25 is 25 mm. 

How you will create Part 3 – Reamer using SwissCAM 
Here are the major steps you will follow to create the Swiss tutorial part: 

 Start PartMaker 

 View tool information for the part 

 View cycle information for the part 

 Select a material for the part 

 Setup defaults for Swiss turning 

 Define the stock boundaries for the Face Window 

 Open a new Face Window 

 Create geometry 

 Perform turning operations on the main spindle 

 Perform milling operations in a ZY plane 

 Duplicating the Mill ZY window 

 Perform drilling operations on the sub or pick-off spindle 

 Create a Process Table 

 Synchronize machining operations on the main and sub-spindles 

 Simulate the Machining Process 

 Generate an NC Program 
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The print below shows the part to be programmed in this tutorial. 
 
Inch Dimensions 

 
 

 
Metric Dimensions 

 
 

When you complete this tutorial, you will have a part that looks like the picture 
below. 
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Getting Started 
The first part of any multi-axis turning programming exercise with PartMaker 
SwissCAM is to decide which machining functions will be used for each part face to 
be programmed. 

The machining functions used in this tutorial are as follows:  

Turn – Main Spindle:  

Use turning tools to perform a variety of Swiss-turning operations on the main 
spindle including facing, OD turning, and pick-off. 

Mill ZY Plane – Main Spindle: 

Use a 3/8 End mill to mill the part flat. 

Use a .156 End mill to mill the .08 Radius and the two Slots. 

Use a .0625 End mill to mill the two Slots. 

Duplicating a window: 

Using the Duplicate command to copy the features into another window. 

Turn – Sub Spindle: 

Use on centerline drilling tools to create a hole on the sub spindle. 

Programming Swiss-type lathe operations with PartMaker is performed in a unique 
manner. No matter what the orientation of the part in the guide bushing or sub 
spindle, PartMaker programs all Swiss operations as if being machined in a 
conventional lathe, i.e. all programming is carried out from right to left. For this 
tutorial you are going to use a machine layout like the one shown below. 

 

 Note: This tutorial covers both general PartMaker programming techniques 
as well as those unique to Swiss-turning.  For more information on using 
PartMaker to program CNC Milling, 2-axis turning and fixed-heastock turn-
mill applications, please see the manuals which correspond to those 
applications. 
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Now you will look in detail at the steps necessary to program each of the 
components of the finished part. The components of the completed Swiss tutorial 
part can be found in the following directories: 

 

Completed Job File: 

 C:\PartMaker\pm-swiss\Swiss Tutorial 3\Inch-Swiss Tutorial 3\Swiss3.job 

Completed Tools File: 

 C:\PartMaker\pm-swiss\Swiss Tutorial 3\Inch-Swiss Tutorial 3\Swiss3.tdb 

Completed Cycles File: 

 C:\PartMaker\pm-swiss\Swiss Tutorial 3\Inch-Swiss Tutorial 3\Swiss3.cdb 

Machine Data File: 

 C:\PartMaker\pm-swiss\Swiss Tutorial 3\Inch-Swiss Tutorial 3\Swiss-demo.mch 

Post Configuration File: 

 C:\PartMaker\pm-swiss\Swiss Tutorial 3\Inch-Swiss Tutorial 3\Swiss-demo.pst 

C:\PartMaker\pm-swiss\Swiss Tutorial 3\Inch-Swiss Tutorial 3\Swiss-demo.sub 

DXF files 

 C:\PartMaker\pm-swiss\Swiss Tutorial 3\Inch-Swiss Tutorial 3\mill_zy.dxf 

C:\PartMaker\pm-swiss\Swiss Tutorial 3\Inch-Swiss Tutorial 3\turn.dxf 
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Starting PartMaker SwissCAM 
All programming for Swiss parts done with PartMaker should be done in the 
SwissCAM application. To start the PartMaker SwissCAM application: 

1 Double click on the SwissCAM icon on your desktop or choose SwissCAM 
from the PartMaker Group accessed through Programs under the Windows 
Start button. 

2 An icon containing the PartMaker logo will appear for a few moments. You 
will then see the Setup definition dialog box shown below. Click the 
<Close> button.   

This dialog will be explained in greater depth starting on page 9. 
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View the Tool Information 
The tool library for the Swiss tutorial has already been created. To view the tools: 

1 Open the Tools file by choosing Open Tools File from the File menu. 

 
Click the Swiss Tutorial 3 folder(and go to inch or metric folder) and select 
swiss3.tdb file as shown above and click <Open>. 

2 Choose Tools from the ToolMinder menu  

The first of the tools to be used in the Swiss tutorial is shown below: 

 
Note: The tools used in this chapter are for the tutorial only. As you begin to 
use PartMaker, you will create your own tools database. See Chapter 2 for 
more information on creating your own tools. 

3 Click the <Close> button to close the Tools dialog. 
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View the Cycles Information 
At this point, you should be familiar with the concept of Cycles in PartMaker. 
Cycles are sequences of repetitive operations used to machine a hole  

The cycles library for the Swiss tutorial has already been created. To view the 
cycles: 

Open the Cycles file by choosing Open Cycles File from the File menu. 

1 Open the Cycles File  

 
2 Select swiss3.cdb file as shown above and click <Open>. 

3 Choose Cycles from the ToolMinder menu  

 
4 Click the <Close> button to close the Cycles dialog. 



 

2-8 PartMaker  Copyright @2014 Delcam Ltd 

 

Select a Material for the Part 
The work piece in this exercise will be machined from Free Machining Stainless 
Steel, Wrought. To load this material: 

1 Choose Open Material File from the File menu. 

2 Choose st_fmstw.mdb as shown below and click Open. 

 
You have now loaded the tools, cycle, and material files. You will be guided 
through a step-by-step process to develop a job file for this tutorial.  
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Setting Defaults 
Before beginning the Swiss-tutorial, you will have to set certain turning defaults to 
facilitate the programming process: 

1 To access the Defaults dialog, select Defaults from the Job Optimizer 
menu. After doing so you will see the dialog below: 

 
Click the <Turning> button to access the Turning defaults dialog. 

2 After doing so, you will see the dialog below: 

 
3 In Swiss machining, in order to avoid pulling stock back into the guide 

bushing it may be desirable not to Start and Return to a Cutting Point when 
programming in PartMaker. When not using Cutting Point to control the 
start and end point of the tools, you will be able to control tool entry and exit 
by setting Leads In and Leads Out in the Profile Group Parameters dialog 
for each operation. 

4 Make sure to check the Diameter Programming box. Checking this box will 
allow you to define all geometry and feature programming in terms of 
diameter, alleviating the need to divide measurements in half when 
programming or drawing on the X-axis in Turning Face Windows. 

5 Set a default Line Length for your programmed Leads. For the Swiss 
tutorial this value should be 0.02 (.1).   

Note: Setting a generally applicable lead as a default will save you a great 
deal of time when programming Swiss parts because you will not have to 
reenter the same data from feature to feature. 

6 Note that the Positive Z Programming button is checked.  This tutorial is 
done with drawing and programming done in the positive Z.  
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7 Thread Height. The following options are available 

%Pitch.The user will enter the height as a percent and resulting height 
will be Pitch * Thread Height / 100. 

Part Units. The user will enter the actual measured height of the thread 
in the current part units. 

Once you have looked at the tools and cycles databases, selected a material for the 
job, and setup the defaults for your job as shown above, you can move on to begin 
programming the tutorial part by clicking on <OK> to close out of this dialog. 
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Turning on the Main Spindle 
This section of the tutorial will instruct you in the steps necessary to perform the 
turning operations on the main spindle. 

Setting Up the Face Window 
In this section, you will set up the Face Window for the turning operations on the 
main spindle. To do so: 

1 Choose Setup from the View menu to view the Setup dialog box (or click 
the Shortcut to the Setup icon in the upper left hand corner of the screen).  
In this dialog, you will define the machining methods, part boundaries, and 
location of the stock with respect to the programming origin.  

The default Setup screen will appear as shown below. 

 
2 Rename the current Face Window in the List of Face Windows field by 

typing Main Spindle-Turn in the Rename To: field and click the <Apply> 
button. 

3 Now enter the parameters listed below in the appropriate fields: Press the 
<Tab> key to move from field to field.  

 

Length (L): 1.138 (29.0) 

OD: 0.4375 (10.0) 

ID: 0 (0) 

Excess Stock (E): 0.01 (0.1) 

Guide Bushing Length (l): 0.75 (12.0) 

Guide Bushing Diameter (d): 1.0 (20.0) 

Tool Change X(Xc): 1.5 (75.0) 

Tool Change Z (Zc): 1.0 (0) 
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Note:  In the dialog above, the Main Spindle radio button is checked.  This 
designates that this operation will be programmed on the main spindle of the 
machine. 

4 When you are satisfied that your Setup dialog appears as the one above, 
click the <Apply> button. This will apply the parameters to the current Face 
Window.  Click the <Close> button to close the Setup dialog. 

5 In the CAM Face Window, choose Show Axes from the View menu.  This 
will display the horizontal and vertical axis lines which will help you create 
the geometry in the next section of the tutorial. 

 Tip:  If at any time the menu commands become “grayed out” and 
unusable, this indicates that the Face Window you are working in has 
become inactive. This will be evident if the top bar of your window (where 
the name of the window is displayed) has become gray. To reactivate the 
window, click anywhere within your Face Window. 

6 Choose Show Boundaries and Show Axis icons from the main tool bar or 
the View menu.  Your screen should appear as shown below:  
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Creating Geometry in CAD Mode 
In this section, you will create the geometry for the turning operations to be 
performed on the main spindle. 

To create the geometry in PartMaker CAD:   

1 Click on the CAD/CAM switch in the lower left-hand corner of the window. 
The icon will change its appearance from a drill bit to a pencil. 

CAD CAM 

2 Select the Connected Lines Icon from the drawing icons on left side of the 
Face Window. Here, you will draw the part on the print on the second page 
of this chapter by plotting ZX coordinates, using the ZX Coordinates Snap 
Mode Icon from the Snap Modes icon bar at the top of the screen. 

After selecting the ZX Coordinates Snap Mode Icon two data entry fields 
will appear in the lower left hand corner of the Face Window. 

 Note:  When plotting coordinates in PartMaker CAD, you do not need to 
reenter a coordinate if it is the same as the last one entered.  You can 
simply leave the space blank and PartMaker will default to the last 
coordinate entered.  You can move between data entry fields by pressing 
the <Tab> button or using your mouse.  

Now enter the ZX coordinates as shown below, using the <Tab> button to 
move between data entry fields and pressing <Enter> after each: 

Z Coordinate X Coordinate  

0 0 <Enter> 

<default> 0.28 (7.2) <Enter> 

0.2 (5.0) <default> <Enter> 

0.2093 (5.286) 0.267 (6.8) <Enter> 

0.5996 (15.586) <default> <Enter> 

0.638 (16.5) 0.4 (10) <Enter> 

1.138 (29.0) <default> <Enter> 

<default> 0 <Enter> 

After entering these coordinates, you should have a drawing which appears 
as the profile below: 

 
3 You will now place a Radius on the front of the part.  To do so, select the 

Fillet icon.  A field will then open up at the bottom of the window prompting 
you to enter the size of the fillet.   

4 Enter a value of 0.05(1.0) and press <Enter>. 
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Note: If your geometry is too far over to the right to see the front of the part 
where the chamfer needs to be placed, you can pan to the left by holding 
down <Ctrl> button and tapping the <Left Arrow Key> at the same time.  
Panning is a very useful feature for Swiss parts which are very long but have 
small outside diameters (OD). 

To place the fillet, position your cursor on the inside of the intersection of the 
lines at the front of the part as shown below: 

 
When completed your picture should look like the one below. 

 
5 Select the geometry you have created by clicking on the selection icon and 

choosing Select All from the Edit menu.  

Note: In PartMaker selection always preceeds action.  Before you can 
manipulate an entity, be it a piece of geometry or a part feature, you must 
select it.  Selection must always be carried out in selection mode.  To be in 
selection mode, you must have the Selection icon chosen. 

6 You will now mirror the selected geometry by choosing Mirror from the Edit 
> Transform menu.  Complete the Mirror dialog as shown below:  

 
When you have completed the dialog as shown above, click the <Mirror> 
and <Close> button.  Click anywhere to deselect the geometry. The 
completed drawing should appear as below: 
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Creating the Part Feature for Face Turning 
The first turning operation to be performed on the Main Spindle is to face the stock. 

1 Click the CAD/CAM switch to go to CAM mode. 

CAD CAM 

2 Click anywhere in the Face Window to make it active. 

3 Choose the red square in the Color Bar.   

4 Choose New Profile Group from the Part Features menu to display the 
Profile Group Parameters dialog.  When selected, you should see a dialog 
which appears as the one below: 

 
5 From the Strategy menu, select Contouring (it should be chosen by 

default). 

6 From the Tool Location menu, select Face. 

7 Uncheck the box next to Roughing, so that Finishing is checked. 

8 Click the Select Tools button and allow PartMaker to select the appropriate 
tool. PartMaker will present you a choice of three tools, two are mounted on 
the gang for work on the main spindle and the other is on the back working 
slide for work on the sub spindle as shown below: 
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In this case you are doing main spindle work, so choose T010 and click 
<Select>.  You are choosing T010 because this tool has been setup up for 
work on the main spindle and the Tools Database has been designated as 
Gang Tool. 

9 In the field called Group Name: enter Face. Your dialog should now appear 
as shown below: 

 

 At this point, do not close the dialog box shown above. Proceed for 
instructions on how to complete setting up this profile group. 

Leads In/Leads Out 
When programming parts in PartMaker, you have the ability to control how far and 
at what angle a tool feeds on and off of a part. These values are controlled via 
Leads. The Lead In is the distance from the part the tool will begin feeding before 
cutting. Likewise, the Lead Out is the distance that the tool will feed away from the 
material before tool change or rapidding to its next position. 

 Note:  If you are using the same Leads In and Leads Out in most of your 
operations, you can set them as default values in the Defaults for Turning 
dialog accessed under the Job Optimizer menu.  Setting your own default 
Leads In and Out values will save time when programming in PartMaker. 

1 Leads In and Out are combined the settings for controlling the movement  
of the tool as it approaches (Leads In) and leaves (Leads Out) the stock into 
a single Leads dialog. 

2 Set the Leads In values for the operation.  Now set the Leads Out values 
for the operation. 
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3 You can also set the values from one Leads to the other by selecting the 
Copy Leads button.  

 
Press <OK> to return to the Profile Group Parameters dialog. 

Note:  The Lead angle is always set normal to the path of the tool by 
PartMaker.  Above, setting the Leads Out angle will allow the tool to 
retract in a manner perpendicular to the part.  For example, if turning a 45 
degree chamfer, a 0 degree lead angle would allow the tool to exit the stock 
on a 45 degree angle. 

Click the <Close> button to close the Profile Group Parameters dialog 
box. 

Developing the Tool Path 
Notice, that by choosing a Tool Location of Face, PartMaker automatically applied 
your facing tool path to the part geometry. 

Your completed profile should appear as below: 

 
Click the Selection icon to bring yourself to a home or neutral position. 

 Important! Before moving on, save your work! To do so:  

1 Choose Save from the File menu or use the shortcut key <Ctrl + S>.  

2 In the Save Job File as: dialog, give your job file a name. Here we are 
naming this job Reamer. 

3 Click the <Save> button to save the job. 

Note: When choosing <Save>, PartMaker also saves your tools, materials, 
and your cycles file in addition to your job file. 
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Tool Path Verification  
Once a tool path is defined, you can verify its shape to gauge the accuracy of the 
cut you have defined. In PartMaker SwissCAM, for programming being done on the 
Main Spindle in a Face Window of Machining Function Turn, you have the option 
of performing two types of tool path verification: 

 Standard verification (default choice)  

Or  

 Sliding headstock simulation (Stock Motion Simulation) 

Each type of verification has its relative merits. Standard verification simulation is 
excellent when focusing on the cut being made by a particular tool path. The sliding 
headstock simulation, referred to as Stock Motion Simulation, is excellent for 
seeing how your part will move through the guide bushing during machining and to 
assure that the “Tool Shifts” have been set properly and that proper support is 
being provided by the Guide Bushing during simulation.   

 Note: When performing, the Stock Motion Simulation, a guide bushing of the 
OD and Length described in the Setup dialog will be shown.  

For the facing operation, you will use the Standard verification. To do so:  

1 Select Verify Work Group Tool Path from the Part Features menu to 
check your work. You will be prompted with the Tool Verifications Options 
dialog as shown below: 

 
Check the Solid radio button and enter a delay between 0 and 9, zero being the 
fastest and nine the slowest, relative to the processor speed of your computer.  

Click <OK>. You should see your tool path verified. 

2 Once you are satisfied with your tool path, choose Hide Work Group Tool 
Path from the Part Features menu. 

Note: Whenever you verify a tool path (or every tool path) you MUST choose 
Hide Work Group Tool Path before moving on and continuing to work in 
PartMaker.  Not doing so could hamper performance of your system.  In 
order to stop verification before it is complete, hit the <Esc> key. 
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Defining the Profile for OD Turning 
The next operation to be performed will be OD turning, starting from the bottom of 
the Fillet on the face of the part. 

1 Click the blue square in the Color Bar.   

2 Choose New Profile Group from the Part Features menu to display the 
Profile Group Parameters dialog.  

3 From the Strategy menu, select Contouring (it should be chosen by 
default). 

4 From the Tool Location menu, select Out (it should be chosen by default). 

5 From the Tool Orientation menu, select Right (it should be chosen by 
default). 

6 Uncheck the Roughing tool and make sure the Finishing tool is check on. 

7 Click the Select Tools button and allow PartMaker to select the appropriate 
tool. Again, PartMaker will present you a choice of three tools, Two are 
mounted on the main spindle and the other is on the sub spindle. In this 
case you are going to choose the 35 degree tool doing the main spindle 
work, so choose T010 and click <Select>. 

8 In the field called Group Name: type 1st Turn. Your dialog should now 
appear as the one below. 
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Leads In/ Leads Out 
9 Now you will set the lead in and lead out for your profile. Click the Leads 

button and the Leads dialog will appear. Set the line Lengths as they appear 
below:  

 
Press <OK> to return to the Profile Group Parameters dialog. 

10 Click the <Close> button to return to the Face Window. 

Developing the Tool Path 
You can now assign the Front Turn cycle to the geometry you created.  

1  From the left-hand side of the screen select the Define Profile Icon.  

2  From the top of the screen, select the End of an Element Snap Mode icon. 
To define the Front Turn path, click your left mouse on positions 1 through 3 
as shown below:  

 
Note: You may find this exercise easier by zooming in on the area you are 
working on. (Zoom In from the Main tool bar, or use the mouse wheel to 
zoom in or out). 

When completed, you will have the tool path shown below: 

 
3 Click the Selection icon to deselect.  
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Tool Path Verification – Stock Motion Simulation (Sliding Headstock) 
With both the Facing and Front Turning tool paths defined, you can now perform 
stock motion simulation when verifying the motion of the tool. Stock Motion 
Simulation allows you to see the headstock moving through the guide bushing while 
cutting.  

 Note: Before performing Stock Motion Simulation it is generally advisable 
to move the part to the left on the screen using the panning function, i.e. 
hold down the <Ctrl> key and Left Arrow key at the same time. It may 
also be advisable to decrease the size of the part on screen by either 
choosing rolling the mouse wheel away from you, or Zoom Out from the 
View menu or by depressing the <F4> key to continuously zoom out. 

To do so:  

1 Select Verify Every Tool Path from the Part Features menu to check your 
work.  

2 You will be prompted with the Tool Path Verification Options dialog. 
Check the Solid button and the box marked Stock Motion Simulation as 
shown below. Also enter the desired Verification Delay. 

 
When you are satisfied your dialog appears as the one above, click <OK>. 
You should see the part cutting with stock sliding through the guide bushing 
as shown below. 

 
3 Once complete, choose Hide Every Tool Path from the Part Features 

menu, or press <Ctrl +H>, to hide the verification shown above.  
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Defining the Profile for the Second OD Turning Operation 
The next operation to be performed will be OD turning, starting from a Z length of 
0.200 (5.0) to the top of the 120-degree angle. 

1 Click the green square in the Color Bar.   

2 Choose New Profile Group from the Part Features menu to display the 
Profile Group Parameters dialog.  

3 From the Strategy menu, select Contouring (it should be chosen by 
default). 

4 From the Tool Location menu, select Out (it should be chosen by default). 

5 From the Tool Orientation menu, select Right (it should be chosen by 
default). 

6 Uncheck the Roughing tool and make sure the Finishing tool is check on. 

7 Click the Select Tools button and allow PartMaker to select the appropriate 
tool. Again, PartMaker will present you a choice of three tools, Two will be 
mounted on the main spindle and the other is on the sub spindle. In this 
case you are going to choose the 35 degree doing the main spindle work, so 
choose T010 and click <Select>. 

8 In the field called Group Name, type 2nd Turn.  

9 Click <Apply> and your dialog should now appear as the one below. 
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Leads In/ Leads Out 
10 Now you will set the lead in and lead out for your profile. Click the Leads 

button and the Leads dialog will appear. Set the line Lengths as they appear 
below:  

 
Press <OK> to return to the Profile Group Parameters dialog. 

11 Click the <Close> button to return to the Face Window. 

Developing the Tool Path 
Now that you have defined the cycle to be used, you must tell PartMaker the 
location of the tool path. You can now assign the 2nd Turn cycle to the geometry 
you created.  

1 From the left-hand side of the screen select the Define Profile icon. 

2 From the top of the screen, select the End of an Element snap mode. To 
define the rest of the 2nd OD Turn path, click your left mouse on positions 
1 through 4 in the diagram below:  

 
When completed, you will have the tool path shown below: 

 
3 Click the Selection icon to deselect.   
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Tool Path Verification – Stock Motion Simulation (Sliding Headstock) 
With the Facing, Front Turning and 2nd OD Turn tool paths defined, you can again 
perform stock motion simulation when verifying the motion of the tool. Stock Motion 
Simulation allows you to see the headstock moving through the guide bushing while 
cutting.  

 Note: Before performing Stock Motion Simulation it is generally advisable 
to move the part to the left on the screen using the panning function, i.e. 
hold down the <Ctrl> key and Left Arrow key at the same time. It may 
also be advisable to decrease the size of the part on screen by either 
choosing Zoom Out from the View menu or by depressing the <F4> key to 
continuously zoom out. 

To do so: 

1 Select Verify Every Tool Path from the Part Features menu to check your 
work.  

2 You will be prompted with the Tool Path Verification Options dialog. 
Check the Solid button and the box marked Stock Motion Simulation as 
shown below. Also enter the desired Verification Delay. 

 
When you are satisfied your dialog appears as the one above, click <OK>. 
You should see the part cutting with stock sliding through the guide bushing 
as shown on the following page. 

 
Once complete, choose Hide Every Tool Path from the Part Features menu to 
hide the verification shown above. 
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Defining the Profile for the Third OD Turning Operation 
In this operation you will perform OD turning operations starting from the end of 
the 120 angle to the overall length. 

1 In CAM mode, select light blue from the color bar.  

2 Select New Profile Group from the Part Features menu. 

3 From the Strategy menu, select Contouring (Default value).  

4 From the Tool Location menu, select Out (Default value). 

5 From the Tool Orientation menu, select Right (Default value). 

6 Uncheck the Roughing tool and make sure the Finishing tool is check on. 

7 Type 3rd Turn next to Cycle Name. 

8 After you have made these changes, click the <Select Tools> button and 
allow PartMaker to select the appropriate tool. As before PartMaker gives 
you a choice of two tools. Again, choose T010.  

9 Click  <Apply>.  The completed Profile Group Parameters dialog should 
appear as shown below: 

 
10 Set the Leads for the 3rd Turn by clicking the Leads button.  



 

2-26 PartMaker  Copyright @2014 Delcam Ltd 

 

Complete the dialog as shown below: 

 
Click <OK> to return to the Profile Group Parameters dialog. 

11 Close the Profile Group Parameters dialog for 3rd Turn by clicking the 
<Close> button. 

Developing the Tool Path 
Now that you have defined the cycle to be used, you must tell PartMaker the 
location of the tool path. You can now assign the 3rd Turn cycle to the geometry 
you created.  

1  From the left-hand side of the screen select the Profile icon.  

2 From the top of the screen, select the End of an Element snap mode. To 
define the rest of the 3rd Turn path, click your left mouse on positions 1 
and 2 in the diagram below:  

 

 Note: You may find this exercise easier by zooming in on the area you are 
working on (Zoom In from the View menu) and panning across to each 
point (<Ctrl> + Right Arrow key). 

When completed, you will have the tool path shown below: 

 
3 Click the Selection icon to deselect. 
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Tool Path Verification – Stock Motion Simulation (Sliding Headstock) 
With the Facing, Front Turning, 2nd Turn and 3rd Turn tool path defined, you can 
again perform stock motion simulation when verifying the motion of the tool. Stock 
Motion Simulation allows you to see the headstock moving through the guide 
bushing while cutting.  

 Note: Before performing Stock Motion Simulation it is generally advisable 
to move the part to the left on the screen using the panning function, i.e. 
hold down the <Ctrl> key and Left Arrow key at the same time. It may 
also be advisable to decrease the size of the part on screen by either 
choosing Zoom Out from the View menu or by depressing the <F4> key to 
continuously zoom out. 

To do so:  

1 Select Verify Every Tool Path from the Part Features menu to check your 
work.  

2 You will be prompted with the Tool Path Verification Options dialog. 
Check the Solid button and the box marked Stock Motion Simulation as 
shown below. Also enter the desired Verification Delay. 

 
When you are satisfied your dialog appears as the one above, click <OK>. 
You should see the part cutting with stock sliding through the guide bushing 
as shown below. 

 
Once completed, choose Hide Every Tool Path from the Part Features menu 
to hide the verification shown above.  
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Defining the Profile for Cut-Off 
In this operation you will perform a cut-off operation on the main spindle with a 
grooving tool. 

1 In CAM mode, select purple from the color bar.  

2 Select New Profile Group from the Part Features menu.  

3 From the Strategy: menu, select Cut-Off. 

4 Click Select Tools. Choose the tool titled Cut-Off when the dialog below 
appears and click <Select>. 

 
5 Enter a Cut-Off Z-Distance (D) of 1.138 (29.0). (It should be entered by 

default.) 

6 Enter 0.01 (.3) for Chamfer or Radius (q). 

7 Enter 0.2 (5.0) for Start X Point. 

8 Type Cutoff in the Group Name field. 

9 Check the <Optional Path 1->2->1> checkbox. 

Your completed Profile Group Parameters dialog should appear as the one 
below: 
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10 Set the Leads for the Cutoff by clicking the Leads button. 

Complete the dialog as shown below: 

 
11 Close the Profile Group Parameters dialog for the cutoff operation by 

clicking the <Close> button. 

Notice when using the cut-off cycle, PartMaker automatically creates the 
tool path for you. 

Your completed profile should appear as below: 

 
Before moving on, remember to save your work! Do so by selecting Save from the 
File menu or by using the shortcut key <Ctrl + S>.  
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Tool Path Verification – Stock Motion Simulation (Sliding Headstock) 
You have now completed the turning work on the main spindle. Now that all the 
programming in the Main Spindle - Turn Face Window is complete, take a 
moment to see exactly what you have programmed. 

1 Choose Verify Every Tool Path from the Part Features menu. In the 
Verification Options dialog, choose Solid and mark the Stock Motion 
Simulation box as shown below: 

 
PartMaker will show you exactly what you have programmed in a graphical 
manner as shown below: 

 
2 When you are satisfied your screen appears as the one above, choose Hide 

Every Tool Path from the Part Features menu. 

You have now completed the turning operations on the main spindle for the Swiss 
tutorial part. Before moving on, remember to save your work! Do so by selecting 
Save from the File menu or by using the shortcut key <Ctrl + S>. 
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Performing Milling Operations - Main Spindle using the Mill ZY 
Plane 

This section of the tutorial will instruct you in the steps necessary to perform milling 
on the main spindle using the Mill ZY Plane Face Window. 

Setting Up the Face Window 
The first step you will need to take is to set up the Face Window needed to 
perform the milling operations mentioned above. To do so: 

1 Choose Setup from the View menu to view the Setup dialog box or use the 
Shortcut to the Setup icon located above the profile icons on the left-hand 
side of the Face Window.  

2 Click the <New> button to create a new Face Window. 

3 From the Machining Function drop down menu select Mill ZY Plane. 

4 Type Mill Flat in the Rename To: field and press <Enter>. 

When you are finished, your Setup dialog should appear as shown below:  

 
Note:  In the dialog above, the Main Spindle box is checked.  This 
designates that this operation will be programmed on the main spindle of the 
machine. 

5 When you are satisfied that your Setup dialog appears as the one above, 
click the <Apply> button. This will apply the parameters to the current Face 
Window. 

6 Click the <Close> button to close the Setup dialog. 
7 To switch to the Mill Flat Face Window, choose Mill Flat from the 

Window menu. 
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8 Choose Show Axes from the View menu.  This will display the horizontal 
and vertical axes lines which will help you create the geometry in the next 
section of the tutorial. 

9 Choose Show Boundaries from the View menu.  Your screen should 
appear as shown below: 

 
Note:  If the image in the Face Window appears distorted or oblong, choose 
Full View from the View menu to refresh the screen for it to appear as 
shown above. 

Creating Geometry in CAD Mode 
In this section, you will create the geometry needed to assist you in defining the 
milling tool paths you will create in this section by copying the geometry from the 
Main Spindle Turn window to the Mill Flat window. To do so: 

1 Click on the CAD/CAM switch to return to the CAD mode. 

2 Select Main Spindle Turn from the Window menu. 

3 Choose Select All from the Edit menu 

4 Choose Copy from the Edit Menu 

5 Select Mill Flat from the Window Menu 

6 Choose Paste from the Edit Menu. Click anywhere in the Face Window to 
deselect your geometry. 

Your screen should appear as shown below: 

 
Next you will create the geometry for the milled notch on the front of the part. 

1 Click the Line Parallel to Vertical axis Icon 
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2 Enter .118 (2.5) in the field in the lower left hand of the screen. And press 
the <Enter> button. Your view should look like the one below. 

 
3 Click the Line Parallel to the Horizontal Axis. Enter a value of -.02 (-.5) 

 
4 Click the Fillet icon and enter a value of 0.08 (2.0)  

5 Click the intersection of the .118 (.5)Vertical Line and the -0.02 (-.5) you 
have just created. 

 
6 Click on the Remove icon and click on the line segment sticking out above 

the outside diameter of the drawing so it looks like the one shown below.  

 
Next you will create geometry for the milled slots. To do so 

1 Click on a Circle with a Known Radius and Center.  

2 Enter a value of the radius of the Circle of 0.0625/2 (.8). 

3 Click on ZY Snap mode.  

4 Enter a value of  .174 (4.4) for Z and 0.05 (1.3) for Y and press <Enter>. 

5 Press <Enter> again to confirm the same radius value. 

6 Enter a value of .524 (13.3) for Z and 0.05 (1.3)for Y and press <Enter>. 
Your drawing should look like the one shown below. 
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7 Click on the Line through Two Points Icon.  

8 Select Tangency Snap mode 

9 Click on the points shown in the view below.  

 
10 Click on the Remove Icon and trim the interior radii .  

 
You can now duplicate the Slot using the Mirror Function. To do so: 

1 Choose the Selection icon 

2 Drag a window around just the slot so that it is selected. 

3 Choose Mirror from the Edit > Transform menu  

4 Enter in the data as shown below. 

 
Your picture should look like the one show below. 

 
5 Click anywhere in the face window to deselect. 
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Creating a Mill Flat Profile 
In this section, you will define the profile to machine a flat on the work piece. 

1 Click the CAD/CAM switch such that it appears as a drill bit. This will put 
you back into the CAM mode. 

2 In CAM mode, select Red from the color bar.   

3 Select New Profile Group from the Part Features menu.  

4 From the Strategy drop down menu select Contour Mill. 

5 From the Tool Position: drop down menu choose Left. 

6 Enter 0.140 (5.0) for X_Surf(S), representing the .280 (10.0) you turned in 
the previous section divided by 2. X_Surf:  The distance from the center of 
the cylinder to the edge of the turned diameter.  

7 Enter 0.080 (3.5) for X_Depth(D), representing distance traveled from the 
X_Surf (S) 

8 X_Rapid (R) will be set to 0.150 (1.0) the tool will rapid to this value above 
the X Surf(S) value before it will perform its work 

9 X_Clear (Cl) will be set to .050 (1.0) the tool will rapid to this value above 
the X_Surf after it has completed its work. 

10 Bottom Finish (b) will be set to 0. 

11 Wall Finish (w) will be set to 0 

12 Uncheck the box next to Roughing 

13 Make sure that Finishing is checked on and enter a value of 0.375 (10) for 
Diam (d). 

14 Click on the <Select Tools> button and select the .375 (10) end mill.  

15 The dialog box should look like the one below. 

 
16 Change Group Name field to Mill 1st Flat 

17 Click the <Close> button to close the Profile Group Parameters dialog 
box. 
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The next step is to develop the tool path, to do this you are going to have to add 
some geometry. To do so: 

1 Switch to CAD mode by clicking on the CAD/CAM icon.  

2 Draw a vertical line by clicking on the Line Parallel to the Vertical Axis 
icon.  

3 Enter a value of  0.200 (5.0). This will represent the path of the endmill. 

The screen should appear as shown below: 

 
4 Switch back to CAM mode.  

5 Click on Chain Geometry Icon 

6 Click your cursor at the top of the vertical line that was drawn in the previous 
steps.  

Tool Path Verification  
In the Setup dialog for Machining Function: Turn that was used for the Facing, 
Front Turning, 2nd and 3rd toolpath, you were able to perform stock motion 
simulation when verifying the motion of the tool. In Machining Function: Mill ZY 
Stock Motion Simulation is not an option, only the milling path will be shown.  

 
1 Choose Verify Work Group Tool Path from Part Features. 

2 Your path should look like the one shown below 

 
3 Choose Hide Work Group Tool Path from the Part Features menu 
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Creating the 0.08 (2.0) Radius Profile 
In this section you will create the tool path for milling the notch on the front of the 
part. 

1 In CAM mode, select Yellow from the color bar.  

2 Select New Profile Group from the Part Features menu.  

3 From the Strategy box Select Contour Mill. 

4 From the Tool Position: drop down menu, choose Left. 

5 Enter 0.06 (1.5) for X_Surf(S), representing the distance from the center of 
the cylinder to the edge of the flat milled in the previous step.  

6 Enter 0.065 (1.2) for X_Depth(D), representing distance traveled from the 
X_Surf (S) 

7 Bottom Finish (b) will be set to 0. 

8 Wall Finish (w) will be set to 0.  

9 Check the <Roughing> and <Finishing> box. 

10 Enter a value of 0.0625 (1.5) in the Diam (d) fields for the roughing and 
finishing operations.  

11 Type Mill .080 Radius in the box under Group Name: 

12 Click the <Select Tools> button.  

13 Change the Axial Step value for roughing to .060 (1.1) 

Your completed dialog should appear as shown below. 

 
14 Click the <Close> button.  
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Define the Tool Path 
1 Click the Chain Geometry Icon.   

2 Select the .08 (2.0) radius as shown in the picture below by clicking on the 
upper left hand corner of radius. 

 
3 Click the Selection icon to deselect the tool path.  

Tool Path Verification  
In the Setup dialog for Machining Function: Turn that was used for the Facing, 
Front Turning, 2nd and 3rd toolpath, you were able to perform stock motion 
simulation when verifying the motion of the tool. In Machining Function: Mill ZY 
Stock Motion Simulation is not an option, only the milling path will be shown.  

1 Choose Verify Work Group Tool Path from Part Features 

 
2 Your path should look like the one shown below: 

 
3 Choose Hide Work Group Tool Path from the Part Features menu.  
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Creating a Second Mill Flat Profile  
In this section, you will define the profile to machine the second set of flats on the 
work piece. 

1 In CAM mode, select Green from the Color Bar.  

2 Select New Profile Group from the Part Features menu. 

3 In the Strategy box select Contour Mill. 

4 Choose On from the Tool Position: drop down menu. 

5 Enter 0.140 (5.0) for X_Surf(S), representing the .280 (10.0) you turned in 
the previous section divided by 2. X_Surf:  The distance from the center of 
the cylinder to the edge of the turned diameter.  

6 Enter 0.080 (3.5) for X_Depth(D), representing distance traveled from the 
X_Surf (S) 

7 X_Rapid (R) will be set to 0.150 (1.0) the tool will rapid to this value above 
the X Surf(S) value before it will perform its work 

8 X_Clear (Cl) will be set to .050 (1.0) the tool will rapid to this value above 
the X_Surf  after it has completed its work. 

9 Bottom Finish (b) will be set to 0. 

10 Uncheck the box next to Roughing 

11 Make sure that Finishing is checked on and enter a value of 0.375 (10) for 
Diam (d). 

12 Click on the <Select Tools> button and select the .375 (10) end mill.  

13 Type Mill 2nd Flat in the Group Name: field. 

14 Click on the <Select Tools> button.  

Your dialog should look like the one shown below: 

 
15 Click on the <Close> button when completed. 
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The next step is to develop the tool path.  To do so you are going to have to add 
some geometry.  

 Note: To make the construction of the milling path clearer, choose Hide Axis 
and Hide Boundaries from the View menu  

To add geometry: 

1 Switch to CAD mode by clicking on the lower left icon.    

2 Draw a vertical line by clicking on the Line Parallel to the Vertical Axis 
icon.  

3 Subtract 1/2 the diameter of the Endmill .1875 (5.0) from the Z position 
.5996 (15.58). Enter a value of  0.4121 (10.58). This will draw a line 
representing the center line of the endmill path. 

 
4 Select Line Parallel to the Horizontal Axis icon.  

5 Enter a value of 0. 

The screen should appear as shown below: 

 
6 Select the Remove icon and trim the drawing so it look like the picture 

below. 

 
7 Switch back to CAM mode 

8 Click Define Profile Icon. 

9 Select Closest Intersection Snap Mode Icon. 
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10 Click on the points outlined in the picture below. 

 
11 Your Path should look like the one shown below.  

 
12 Click the seletion icon to deselect. 

Tool Path Verification  
In the Setup dialog for Machining Function: Turn that was used for the Facing, 
Front Turning, 2nd and 3rd toolpath, you were able to perform stock motion 
simulation when verifying the motion of the tool. In Machining Function: Mill ZY 
Stock Motion Simulation is not an option, only the milling path will be shown.  

1 Choose Verify Work Group Tool Path from Part Features. 

 
2 Your Path should look like the one shown below.  

 
3 Choose Hide Work Group Tool Path from the Part Features menu. 
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Creating the Mill Slots Profile  
In this section, you will define the profile to machine the slots on the work piece. 

1 In the CAM mode, select blue from the Color Bar.  

2 Select New Profile Group from the Part Features menu.  

3 In the Strategy box select Contour Mill. 

4 Choose On from the Tool Position: drop down menu. 

5 Enter 0.060(1.5) for X_Surf(S)  

6 Enter 0.065 (1.6) for X_Depth(D), representing distance traveled from the 
X_Surf (S) 

7 X_Rapid (R) will be set to 0.150 (5.0) the tool will rapid to this value above 
the X Surf (S) value when making rapid moves. 

8 X_Clear (Cl) will be set to .050 (1.0) the tool will rapid to this value above 
the X_Surf then start to feed into the part.  

9 Bottom Finish (b) will be set to 0. 

10 Uncheck the box next to Roughing so that Finishing is checked. 

11 Enter a value of 0.0625 (1.5) for Diam (d) for finishing. 

12 Type Mill Slots in the Group Name: field. 

13 Click on the <Select Tools> button. Choose tool T012. 

Your dialog should look like the one shown below 

 
14 Click on <Close>. 
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Developing the Tool Path 
Next you will apply this part feature to the geometry to define the tool path. 

1 Click on Define Profile Icon.  

2 Select Circle Center Snap Mode icon. 

3 Start by clicking on points 1and 2 outlined in the picture below. 

 
4 Click on the Define Profile icon again for the second time to break away 

from the original path. 

5 Click on points 3 and 4 as indicated above. 

6 Click on your selection icon when finished. 

7 Your Path should look like the one shown below 

 

Tool Path Verification  
1 Choose Verify Work Group Tool Path from Part Features. 

2 Your tool path should look like the one shown below. 

 
3 Choose Hide Work Group Tool Path from the Part Features menu. 
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Duplicating Identical Face Windows 
Having programmed the Milling operations on one side of the outside diameter of 
the part, you now need to create the same feature on the other side of the part, i.e. 
180 degrees apart.  Instead of having to go through the process of recreating the 
feature in a new window, you can automatically duplicate it. To do so:  

1 Choose Setup from the View menu. 

2 In the Setup dialog, select the window called “Mill Flat” as shown below (it 
should already be selected). 

  
3 Click the <Duplicate…> button. 

4 In the Duplicate Face dialog, enter 1 in the Number of Copies (N) field 
and 180 in the Index Angle Increment (A) field. The completed dialog 
should appear as shown below: 

 
5 Leave the box labeled “Insert Into List of Faces” unchecked. 

6 Click the <OK> button in the Duplicate Face dialog. 
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Your completed Setup dialog should appear as shown below: 

 
Notice the name of the original Mill Flat Face Window has had a (1,180) 
appended to it. All of the processes included in this window will be duplicated 
at the Process Table. You will see a yellow block on the processes that have 
been duplicated. The advantage of duplicating the window with the “Insert 
Into List of Faces” unchecked is that any changes that need to be made to 
the milling is automatically done to all of the duplicated windows.  

If you check the box labeled “Insert Into List of Faces” the Mill Flat Face 
Window will have a _0 appended to it and the duplicated Face Window 
having been named Mill Flat_180.  At the Process Table there will be a 
separate process for each duplicated face window. Notice the Angle(C) field 
in the newly created window will be populated with a value of 180. 

7 Click the <Close> button to close the Setup dialog. 
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Turning on the Sub-Spindle 
This section of the tutorial will instruct you in the steps necessary to perform the 
drilling operations on the sub-spindle on the centerline. 

Setting Up the Face Window 
In this section, you will set up the Face Window needed to perform turning 
operations on the sub-spindle. To do so: 

1 Choose Setup from the View menu to view the Setup dialog box or use the 
Shortcut to Setup icon located above the profile icons on the left-hand side 
of the Face Window. 

2 Click the <New> button to create a new Face Window. 

3 From the Machining Function drop down menu select Turn. 

4 Check the radio button marked  Sub Spindle.  Notice how there is no guide 
bushing representation on the sub-spindle, as the stock is fixed when being 
held in the sub-spindle collet. 

5 Type Sub Spindle Turn in the Rename To: field and press <Enter>. 

When you are finished, your Setup dialog should appear as shown below: 

 
Note:  In the dialog above, the Sub Spindle radio button must be checked.  
This designates that this operation will be programmed on the sub-spindle of 
the machine. 

6 When you are satisfied that your Setup dialog appears as the one above, 
click the <Apply> button. This will apply the parameters to the current Face 
Window. 

7 Click the <Close> button to close the Setup dialog. 
8 Verify that the Sub Spindle Turn Face Window is selected by clicking it in 

the tree view to the left.  
9 Choose Show Axes from the View menu.  This will display the horizontal 

and vertical axes lines which will help you create the geometry in the next 
section of the tutorial. 

10 Choose Show Boundaries from the View menu.   
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Creating Geometry in the CAD Mode 
To quickly define geometry for the turning operations to be performed on the sub 
spindle, you can use the geometry already created in the Main Spindle Turn Face 
Window. Remember, in PartMaker, all programming is done as if being performed 
on a conventional lathe, i.e. all programming is carried out from right to left.   

As a result, you can copy the geometry previously created in the Main Spindle - 
Turn window and mirror it to create the desired geometry in the Sub Spindle Turn 
window.  

1 Choose Main Spindle Turn from the Window menu to return to the first 
window your created as shown below: 

 
2 In the Main Spindle Turn Face Window, to copy the geometry, click on the 

CAD/CAM switch to return to CAD mode.  The icon will change its 
appearance from a drill bit to a pencil. 

3 With the Selection icon highlighted, select the geometry you have created 
by choosing Select All from the Edit menu.(It may still be selected from the 
previous selection) 

4 With the geometry selected (it should be highlighted), choose Copy from the 
Edit menu. 

5 Return to the Sub Spindle Turn Face Window by choosing Sub Spindle 
Turn from the Window menu. 

6 In the Sub Spindle Turn Face Window, choose Paste from the Edit menu. 

Remembering the PartMaker convention that all programming is carried out 
from right to left, you will now mirror the geometry you just pasted. To do 
so: 

1 Make sure you are in CAD mode in the Sub Spindle Turn Face Window. 

2 With the Selection icon chosen, again, choose Select All from the Edit 
menu to select the geometry if it is not currently selected. 

3 With the geometry selected, choose Mirror from the Edit > Transform 
menu.  

Note: To flip the part in order to perform operations on the back, you will 
need to mirror with respect to the middle of the part.  

4 Uncheck Multiple Copies.  

5 Click the Vertical radio button. 

6 Enter 1.138/2 (29.0/2) in Center Z field (Part length 1.138 divided by two). 
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Your dialog box should appear as: 

 
7 Click <Mirror> and <Close>. 

The completed (mirrored) part should appear as shown below: 

 
8 Click the Selection icon to deselect your geometry. 
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Defining the Drilled Hole on the Sub-Spindle 
Here you will define the part feature for the drilled hole to be machined on the sub 
spindle. To do so (Make sure you are in CAM mode): 

1 Click the green square in the Color Bar.   

2 Choose New Hole Group from the Part Features menu to display the Hole 
Group Parameters dialog. 

3 Uncheck the Through Hole box.  

4 In the Major Cycle Operation drop down menu select Drill. 

5 Enter a Diameter of 0.25 (6.4) 

6 Other parameters should be set as follows: 

Chamfer (c): 0.01 (0.5) 

Z-Surf (S): 0.0 (0) 

Face Clearance (Cf): 0.05 (2.0)

Nominal Depth (D): 0.5 (12.0) 

7 In the To: drop downmenu, choose Tip of Largest Drill. 

8 Click the Cycle button and PartMaker will search for a cycle that matches 
the Major Cycle Operation and size of tool. Select the Drill_0.25(Drill 6.4) 
cycle. Your Hole Group Parameters should appear as shown below: 
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9 You can verify the shape of the drilled hole by clicking the <Verify Shape> 
button. If you entered the parameters correctly you should see the following: 

 
10 Click the <Hide Shape> button and the <Close> button to exit the Hole 

Group Parameters dialog. 

Your Face Window should now appear as shown below: 

 
Before moving on, remember to save your work! Do so by selecting Save from the 
File menu or using the shortcut key <Ctrl + S>. 



 

Copyright @2014 Delcam Ltd  User Guide 2-51  

 

Creating an NC Program 
At this point, you have completed creating the four faces for this tutorial part. You 
are now prepared to take the final steps in developing your part program. 

The steps required for process plan development and program creation are 
described using the “generic” Fanuc-style Swiss-lathe post processor that comes 
standard with your PartMaker SwissCAM software. Synchronization and other 
processing related issues may vary slightly for different machine makers, but the 
steps below are instructive to work through in developing an understanding of 
process development in PartMaker SwissCAM. 

For purposes of this tutorial it is assumed that we are using a machine with the 
architecture on page 3 on this tutorial. 

 Tip: Refer to the Machine Specific Addendum that came with your 
PartMaker software for more information on process planning and post 
processing issues for the Swiss-type lathes in your shop. 

Generating a Process Table 
The first step in generating an NC program is creating a Process Table. A Process 
Table shows you all of the machining processes for a part.   

When you generate a Process Table in PartMaker, all cutting conditions such as 
feed rate and spindle speed (RPM) are calculated automatically based on the tools 
and material information previously entered. A time for each operation is shown, 
along with a total machining time for both the main and sub spindles. These time 
calculations give the user a sense of how closely “balanced” machining is for a part, 
i.e. how much cycle time is expended on both main and sub spindles in addition to 
the total time to cut the part. Time calculations in PartMaker include both “in-cut” 
time as well as tool change time. 

To create the Process Table: 

1 Choose Generate Process Table from the Job Optimizer menu.  Upon 
doing so, you will be prompted with the dialog below: 

 
2 Click on <OK>. 
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The following Process Table will appear: 

 

Visual Process Synchronization and PartMaker Specific Modes 
When generating a Process Table, PartMaker will default to machining your part in 
the order in which you have programmed the part features. PartMaker starts by 
choosing the processes in the first Face Window you have created in the Setup 
dialog and executing all the part features in that Face Window in the order they 
have been created. The software then moves onto the next Face Window you have 
created and executes the processes defined in that Face Window. 

Of course, in Swiss machining, to conserve cycle time, many processes may be 
happening simultaneously, rather than in the sequential order in which you have 
created your tool paths in PartMaker. The Process Table accommodates this unique 
feature of Swiss machines allowing you to define the true order of processes defined 
in different Face Windows. It is in the Process Table window that you synchronize 
operations being performed simultaneously with either different tool posts (i.e. 
gang, back working, turret etc) or on different spindles (main vs. sub) or some 
combination of the two. Such synchronization is done by pointing and clicking to 
place the order of processes and then by assigning different Synchronization Modes 
in the Set Modes dialog to link different processes to one another.   

More information on the Set Modes dialog can be found in Chapter 2 of the 
PartMaker SwissCAM manual, PartMaker Fundamentals. In addition, more 
information on synchronization techniques can be found in the Machine Specific 
addendum that came with your PartMaker software. 
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Synchronizing Processes on the Main Spindle 
To synchronize the Main Spindle operations on the Process Table for this part: 

1 Click on the Set Modes icon to the right of process 1 as shown below: 

 
2 After doing so, you will see the Set Modes dialog appear as shown below: 

 
The Set Modes dialog allows you to visually determine the type of 
synchronization you want to perform. 
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3 In this case, you will be synchronizing a number of Main Spindle operations 
with all of the Sub Spindle operations.  To indicate that process 1 will be 
running simultaneously as a process on the Sub Spindle, click the 
Machining with One Tool (S1) radio button in the Sub-Spindle Mode 
area of the Set Modes dialog. After having done so, the Set Modes dialog 
should appear as shown below: 

 
Note: In the picture above, the double headed arrow indicates that the stock 
is moving in the guide bushing for the given process.  The yellow  colored 
tool represents the tool doing the cutting in the selected process, while the 
gray one is the that is being syncronized with. 

Once you are satisfied your dialog appears as the one above, click the <OK> 
button to return to the Process Table. 

Notice how the Set Modes icon now depicts two tools cutting, one on the 
Main Spindle and one on the Sub Spindle.  The Mode column is now filled in 
with M1S1, indicating that during this process one tool is cutting on the main 
spindle and one is cutting on the sub spindle at the same time. 

 
4 In order to quickly set the remaining Main Spindle Processes to M1S1 (i.e. 

simultaneous cutting on Main and Sub Spindle) click the Set Modes dialog 
associated with process 2.  Again, click the Machining with One Tool (S1) 
radio button in the Sub-Spindle Mode area of the Set Modes dialog. 

5 Next, click the Modify Modes for all Consecutive Processes with Same Mode 
radio button. 
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After having done so, the Set Modes dialog should appear as shown below: 

  
6 Click <OK> to return to the Process Table.  The Set Modes icons for all 

Main Spindle Processes should be automatically assigned and appear as 
shown below: 
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Synchronizing Processes on the Sub Spindle 
To synchronize the Sub Spindle operations with the Main Spindle operations 
discussed above on the Process Table for this part. 

1 Click on the set modes icon for Process 12, the first operation programmed 
on the Sub Spindle.  With Process 12 selected (it should have a rectangle 
around it) click the Set Modes icon. 

 
2 In the Set Modes dialog, click the Machining with One Tool (M1) radio 

button in the Main Spindle Mode area of the Set Modes dialog. To save time, 
click the Modify Modes for all Consecutive Processes with Same Mode 
radio button. 

After having done so, the Set Modes dialog should appear as shown below: 

 
3 Click the <OK> button to return to the Process Table. 
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Setting the Cut-Off Operation 
Having now properly synchronized the Main Spindle operations, you will now set-up 
the cut-off operation.  In Swiss machining, cut-off is typically programmed as the 
last operation when cutting a part that involves synchronous machining in both 
spindles. 

To properly set-up the cut-off and transfer from the main spindle to the sub spindle: 

1 Click the Set Modes icon associated with process 5 (the Cut-off operation) 
to enter the Set Modes dialog.  The proper mode for the Cut-Off operation is 
Cutting with One Tool (M1) on the Main Spindle while providing Follow 
Support (SF) with the sub-spindle, meaning the sub-spindle is moving in 
sync with the main spindle as the part is being cut. 

To set this mode of operation, check the Follow Support (SF) radio button 
in the Sub-Spindle Mode area of the Set Modes dialog. 

When setting this mode, enter a value of 0.9 (25) for the Sub-Spindle 
Support Z-Coordinate (Sz), the position at which the sub-spindle is 
gripping the part during transfer. 

After doing so your Set Modes dialog should appear as shown below: 

 
2 Click the <OK> button to return to the Process Table.  Notice the 

appearance of the Cut-Off process on the Process Table: 
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Creating Sync Groups 
With the Process Table generated and sequence of operations established, you can 
now verify that your synchronization approach is correct by creating Sync Groups, 
groups of processes being executed simultaneously. 

To do so: 

1 Click the Synchronize button in the upper right hand corner of the Process 
Table. 

 
2 If you have made any errors in process synchronization, PartMaker will 

prompt you at this time. If you have not made any errors, your Process 
Table should appear as shown below: 

 
On the Process Table above, processes 1 through 12 are all being executed 
at the same time and as a result are in the same Sync Group.   
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Spindle Balancing and Time Chart 
Once you have syncronized your operations, you can view the Time Chart by 
clicking the Show Time Chart button in the lower right hand corner of the process 
table. 

 
After clicking the Sync Group button, your time chart will show you graphically 
which operations are over lapping and where additional opportunities for saving 
cycle time are by combining them with other operations. 

Selecting a Post Processor 
Having finished generating the Process Table and synchronizing operations, you 
must now select a Post Configuration File before you can output an NC program.  
This post configuration file is stored in the PM-Swiss\Swiss tutorial 3 directory.  If 
you do not have any other post configuration files loaded in this directory the 
Swiss_demo.pst will be loaded automatically.  If you have other post configuration 
files in this directory: 

1 Choose Post Config File = ? from the Job Optimizer menu.  

2 Select Swiss-demo.pst post as shown below.  PartMaker SwissCAM comes 
standard with a post configuration for a Fanuc 18t control which supports live 
tooling, y-axis, c-axis and subspindle operations. 

 
3 Click <Open> to load the post processor. 
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Simulating the Process 
Having completed generating the Process Table, synchronizing operations and 
loading a post processor, you can now simulate the processes. The simulation will 
show your part being cut just how it would on your machine tool.  Simulation will 
show synchronization between your Main and Sub-Spindles. It will also show any 
collisions that may occur between the tooling, material, and/or Spindles.  

1 Click the <Simulation> button at the bottom left hand portion of the 
Process Table.   

2 Press the Space Bar or choose Start Simulation from the Simulation menu 
to begin the simulation.  

 
3 The simulation will be completed when the completed part is resting in the 

sub-spindle. 

4 Choose Show Finished Part from the Simulation menu, or right click on 
the Simulation window, choose Show Finished Part.  

5 Use the left mouse button to rotate the view of the finished part. 

 
Note: The simulation being shown here is part of PartMaker’s Basic 
Simulation function. If you have licensed Advanced Simulation, please 
proceed chapter 6 for more information on using Advanced simulation. 
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Generating an NC Program 
Having selected a Post Configuration file, you are now ready to generate an NC 
Program.  To do so: 

1 Choose Generate NC Program from the Job Optimizer menu.  

2 You will next see the Post Options dialog.  Set the Post Options dialog as 
shown below: 

 
In the Post Options dialog you set certain parameters for assignment during 
post processing.  Please refer to your machine specific addendum for more 
information on how each of the fields in this dialog pertain to your Swiss turning 
equipment. 

3 Click <OK> in the Post Options Dialog to proceed to the Save NC 
Program dialog.  In this dialog, enter a name for your program.  Here you 
should enter “Reamer”. 
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4 Click <Save> to generate the NC program. You will see your programs as 
shown below: 
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