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Sequence of Programming Steps for PartMaker TurnMill 
 

1. Specify part boundaries and the type of machining to be performed in the Setup dialog. It 
appears on the screen right after PartMaker logo when launching PartMaker.  Determine 
whether you will be working on the Main Spindle or Sub Spindle in this Face Window. 

2. Choose the Tools command from the ToolMinder menu to add new tools.  

3. Choose the Cycles command from the ToolMinder menu to add new cycles. 

4. Choose the Open Material File command from the File menu to open a material file from the 
Material directory. 

5. Create geometry in CAD mode or choose the Import command from the File menu if you want 
to import geometry from a CAD system. 

6. Switch back to CAM Mode by clicking the CAD/CAM switch. 

The CAD/CAM switch appears as 
 

in CAM Mode and as 
 

in CAD Mode 

7.Choose the New Hole Group command from 
the Part Features menu to create an axial 
hole.  You should see a dialog box as below: 

 

8. Choose the New Profile Group command from 
the Part Features menu to define a new profile 
group. You should see a dialog box as below: 

 

7.1. Enter your desired settings into the dialog. 
7.2. Click the Cycle button. 

8.1. Enter your desired settings into the dialog. 
8.2. Click the Select Tools button. 

9. Create tool paths using the Graphics Icons in the CAM mode 

10. Repeat steps 7 through 9 to create groups of all part features and machining function face 
windows required for the job. 

11. Choose the Open Post Configuration File command from the Job Optimizer menu and 
select the desired post configuration file. 

12. Choose the Generate Process Table command from the Job Optimizer menu to generate a 
Process Table. 

13. Optimize and Synchronize your operations by using the Set Modes dialog 

14. Simulate the generated program using PartMaker’s 3D Simulation software 

15. Choose the Generate NC Program command from the Job Optimizer menu to generate an 
NC Program 
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Important User Notices  
 
Copyright 1991-2014 Delcam Ltd. All rights reserved.  
 
Delcam Ltd has no control over the use made of the software described in this 
manual and cannot accept responsibility for any loss or damage howsoever 
caused as a result of using the software. Users are advised that all the results 
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with good quality control procedures.  
 
The functionality and user interface in this manual is subject to change without 
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Introduction 
Using CAM Software to Program NC Machines  

The invention of NC (Numerically Controlled) machines has revolutionized the metal 
cutting industry. Computer controlled machine tools are faster, have a higher 
degree of accuracy and repeatability. 

NC machines can be programmed manually, which means typing machine 
"language" motion and other instructions into a computer text file. Such a file, 
called a part program, is then loaded into the NC machine memory for execution.  

The following are the major deficiencies of manual programming:  

 • The languages of NC machines are cumbersome for humans and require a 
long learning curve. 

 • Geometric calculations must be performed to determine coordinates of 
points comprising the tool path. 

 • Typing is a time consuming process. 

 • The absence of adequate methods to prove out the program results in tools 
breakage and material waste. 

Since the earliest days of computer technology a significant effort has gone into 
automation of the programming process by utilizing CAM (Computer Aided 
Manufacturing) Software. CAM systems accept user input in an interactive manner 
and generate a part program file automatically. CAM Systems provide assistance in 
tool path calculations and verification. The overall productivity improvement 
resulting from a use of a particular CAM System depends on how long it takes to 
learn the software, how easy it is to use it and how much information a user has to 
enter during each programming session.  

How PartMaker Improves Productivity 
PartMaker relieves you from the tedious process of reentering the same tooling 
and process information over and over again in every program. It captures 
information about how to machine individual part features, namely, holes and 
profiles, and makes it available for future use. It allows shop personnel to benefit 
from the expertise of the most skilled programmer, who enters his or her knowledge 
into the software. Using PartMaker your parts can now be programmed faster, with 
higher precision and less cost.  

Intuitive Windows GUI Assures Quick Learning 
PartMaker features an intuitive user interface that complies fully with Windows GUI 
(Graphics User Interface) guidelines. The benefits of the Windows environment for a 
PartMaker user include Context Sensitive Help, pictorial explanation of parameter 
entry, the ability to Cut, Copy and Paste part features and/or geometry, and, most 
importantly, shorter learning time. 
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Tools Data Base Keeps Track of Tool Inventory 
A tools database allows the user to keep track of his current tool inventory. 
Geometric characteristics saved with each tool are used for the automatic 
determination of cutting conditions. The software performs automatic hole depth 
calculations by maintaining through hole clearance and blind hole relief distances for 
each tool. A pictorial representation of each tool in a separate window simplifies the 
entry of tool parameters. Corrective coefficients compensate for tool wear. Special 
fields are reserved for the customer's data that includes part numbers and 
reordering information among others.  The tools descriptions are kept in a tool file. 
The tools used on different machines may be kept in multiple tool files. 

Cycles Data Base Stores Sequences of Repetitive Operations 
A cycles database allows the user to create and store cycles, sequences of repetitive 
operations such as center drilling, drilling, tapping, boring, reaming, chamfering and 
circular hole milling. The cycles database links directly into the tools data base. A 
tool for each operation is selected automatically based on the hole diameter. 
Windows GUI makes creation and modification of cycles a simple task. A full 
description of the tools and operations included in a cycle is shown in one window, 
while the corresponding hole cross-section is shown in another window. Studies 
have indicated that over 70 percent of machine cycle time for an average CNC 
machining center is spent making holes. Therefore, PartMaker pays significant 
attention to holemaking in order to achieve the greatest gain in productivity. Often, 
the same or similar features belong to a group of products that are ordered by the 
same shop's customer. Since cycles may be customer specific the user has a choice 
of whether or not to store them in multiple cycle files. 

Materials Data Base Facilitates Automatic Feeds and Speeds 
Calculations 
A materials database allows the user to store materials data that is used in the 
automatic calculation of feed rates and spindle speeds. The software comes with an 
extensive materials database, recommending average cutting parameters. Feed rate 
and spindle speed are computed based on tool geometry (size, number of flutes. 
etc.) and machinability data. This data is presented in the form of flexible computer 
charts giving the user full control over the performance of his machine. The charts 
can be quickly modified via a drag and drop screen interaction. Machinability charts 
can be further optimized by automatic curve fitting through points of best 
performance. 

Patented Visual Programming Approach Simplifies Machining in 
Different Planes 
PartMaker’s Patented Visual Programming approach greatly simplifies 
programming parts involving both turning and milling operations in a single set-up, 
where such operations are being performed on multiple spindles. With this approach 
machining functions such as turning, plane milling and cylinder milling are carried 
out in separate 2D planes, allowing you to break down a part into its most basic 
elements when developing a part program. You can program machining operations 
in different faces (planes) and specify up to twenty-four different faces per part. A 
separate face window is associated with each face of a part.  
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Optimized Process Plan Generation Saves Programming Time 
Rather than creating a job plan in a conventional sequential manner, the 
programmer describes the placement of groups of part features on the surfaces of a 
machined part.  Once the part features description is entered into the computer, 
PartMaker automatically generates an optimized job plan. The results are 
summarized in a Process Table Window that can be reviewed on the screen or 
printed out. The Process Table lists tools and cutting conditions for each process. 
Feed rates, spindle speeds and cycle time are automatically calculated and 
displayed. The cycle time allows the programmer to quickly estimate the cost of 
machining a part. While reviewing the Process Table, the user can manually modify 
the sequence of processes as well as cutting conditions.  

Graphic Process Synchronization Simplifies Cycle Time Optimization 
Once you have laid out your various tool paths, PartMaker allows you to visually 
synchronize processes being performed on separate spindles or by different tool 
posts.  This eases the process of optimizing cycle time to assure your Turn-Mill 
Center is being used most productively.  This visual synchronization is accomplished 
via the Set Modes dialog on the Process Table.   A unique mode has been specified 
for each of the various types of synchronization today’s most advanced Turn-Mill 
Centers are capable of performing.  A picture accompanies each type of 
synchronization allowing the user to better understand the type of synchronization 
being performed 

User Customizable Output Format Eliminates Manual Editing 
When the user is satisfied with the views of the part and its job plan, he proceeds 
with the next step (known as postprocessing ) to automatically generate an NC 
program for a designated machine. The part program is optimized, using 
subroutines, to occupy minimum space in the machine tool memory and shorten 
transmission time. PartMaker eliminates the need for manual editing of the 
generated NC program - a well-known stumbling block of most CAM systems.  

The ability to generate editing-free programs results in an additional productivity 
gain. It is achieved by giving the user full control over the generated NC program 
format by means of a flexible ConfigPost application that allows the user to create 
and save custom postprocessor configuration files for virtually any Turn-Mill control. 
ConfigPost uses the familiar Windows interactive environment that enables the user 
to do output customization quickly and easily. 

Verification by Cutting Simulation Catches Programming Errors 
PartMaker comes with an integrated simulation module that graphically simulates 
the entire cutting process utilizing solid modeling techniques.  This allows the 
programmer to catch errors before expending machining time.  
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About This Guide 
Please read this section to determine which chapters in the PartMaker Turn-Mill User 
Guide address your needs. 

Chapter 1 “Getting Started With PartMaker” explains how to get started with 
PartMaker. This chapter includes a description of the hardware and software 
you need to run PartMaker and tells you how to install PartMaker and related 
files.  It also shows you how to access PartMaker on-line context sensitive help. 

  
Chapter 2 “PartMaker Fundamentals” discusses the unique programming approach 

PartMaker employs for programming Turn-Mill Centers. Concepts covered in 
this chapter include selecting the appropriate Face Window, setting up and 
working with PartMaker’s databases, PartMaker Synchronization modes and 
material control processes, using various PartMaker icons and Snap Modes and 
synchronizing processes being executed simultaneously on the machine.  

  
Chapter 3 “Programming the Turn-Mill Tutorial Part – Single Spindle” shows you 

how to create a sample part using some of the most popular features of 
PartMaker assuming you are working on a Turn-Mill with one spindle and one 
turret. We recommend you go through this chapter to familiarize yourself with 
the PartMaker application. 

  
Chapter 4 “Programming the Advanced Turn-Mill Tutorial Part – Twin Spindle, Twin 

Turret” shows you how to create a part on an 8-axis Turn-Mill Center 
highlighting advanced PartMaker features such as Material Control Processes and 
Process Synchronization.  Recommended to be done after reviewing Chapter 3. 

  
Chapter 5 “PartMaker Simulation” discusses how to use and the functionality of 

PartMaker’s 3-D Simulation module. 

What you will not find in this manual is an explanation of every PartMaker dialog 
and parameters.  For information on specific PartMaker dialogs, use the context 
sensitive help that comes with PartMaker.  This context sensitive help can be found 
by pressing the F1 key on your keyboard. 

This User Guide is also meant for use in conjunction with a machine specific 
programming addendum that may have also come with your PartMaker Turn-Mill 
software.  The Machine Specific addendum is meant to show you a layout of the 
machine you are working with as well as describe any machine or post processor 
specific programming strategies you should be aware of.  
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Chapter 1: Getting Started With 
PartMaker 
In Your Package 

 PartMaker DVD 

 PartMaker Manuals 

 Hardware lock 

You will receive a license file that works with the hardware lock.  For standalone 
licensing the file is called a Product Authorization File (PAF).  For network licensing 
the file is an RMS license file.  Obtaining and installing the PAF file will be discussed 
later in this chapter in the section titled PAF Installation Instructions.  The 
PartMaker Installation guide explains the RMS license file in detail. 

Technical Support 
Please use the following information when you wish to get Technical Support or 
more information about PartMaker’s products: 

Phone:  215-643-5077 

Fax:  215-653-0105 

e-mail:  support@partmaker.com  

Web Site:  http://www.PartMaker.com 

A Customer PIN has also come included with your PartMaker software. 

Before Using PartMaker... 
Before you begin working with PartMaker, you need a basic knowledge of Microsoft 
Windows operations. You should understand mouse techniques such as pointing, 
clicking, double clicking, dragging, choosing menu commands, and making dialog 
selections. If you are unfamiliar with basic Microsoft Windows terms or techniques, 
see your Microsoft Windows documentation for details. 
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System Requirements 
Please read the following sections to determine what you’ll need to get started with 
PartMaker. To use  PartMaker, you need a Windows-based PC with the following 
specifications: 

 

 
PartMaker 
Standard 

Parasolid 
Import Module 

(Solids)* 

Full Machine 
Simulation 

(FMS) 

Advanced 
Surface 

Machining (ASM) 

Processor Pentium 3 800 
MHz or higher 

Pentium 3 800 
MHz or higher 

Pentium 4 3 
GHz or higher 

Intel Core Duo 
processor or higher 

Memory 512 MB or more 1 GB or more 2 GB or more 4 GB or more 

Hard drive 40 GB 40 GB 40 GB 80 GB 

Independent 
video card 128 MB NVIDIA 512 MB NVIDIA 512 MB 

NVIDIA 1 GB NVIDIA 

 

64-bit and 32-bit versions of PartMaker are available and are supported on Windows 
7. Only the 64-bit version of PartMaker is compatible with Windows 8 PCs. 

Please take note that Microsoft has discontinued support for the Windows XP and 
Vista operating systems.  
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Starting PartMaker  
From your desktop, double-click the PartMaker TurnMill icon. 

A window containing information about PartMaker appears for a few moments. 

 
The PartMaker application window and the Setup dialog are displayed in the Face 
Window. 
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Installing Multi-Axis TurnMill Post Processors 
PartMaker TurnMill Version 2010 and higher features a unique capability for 
downloading your licensed TurnMill post processors and related files directly through 
the software’s user interfaces.  This feature is helpful for both new users installing 
the software for the first time and existing users who wish to update their post 
processors and related files to the most recent “distribution” Post Processors (see 
below for more information on “distribution” versus “non-distribution” post 
processors). 

 Important! You must be connected to the internet to automatically download 
and install your licensed post processors through the PartMaker interface. 

Once you have successfully launched the TurnMill application, you can install the 
TurnMill post processors that you have licensed directly from the PartMaker user 
interface.  

To do so: 

1 From the Help menu, choose Download Licensed Post Config Files…  

 
2 You will be presented with the dialog below (the actual post processors for 

your system may differ from those shown below): 
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3 Check the boxes to the left of the post processor(s) you wish to download as 
shown below: 

 
4 Once you have selected the items you wish to download, click the Download 

Selected Posts button to begin downloading those items into the directory 
specified in Step 2 of the Download Licensed Post Config Files dialog. 
Upon doing so, you will see a progress bar showing the status of your 
download. 

5 Once you have successfully downloaded the selected items, you will see the 
Download Status column will indicate “Successful” as shown below. 

 

 Note: If you receive any message other than “Successful” after this 
process, contact PartMaker technical support at support@partmaker.com 
or your local PartMaker support representative (outside North America). 

6 Once you successfully downloaded the requested files, click the <Close> 
button to continue using PartMaker. 
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What You Have Just Downloaded 
Once you have completed the steps above, you will have downloaded what are 
known as “distribution post processors.”  PartMaker post processors for multi-axis 
lathes are more than just standard post processors that come with a CAM system. 
They are highly engineered, actively supported, routinely maintained and well 
documented machine configuration files to assure you generate accurate NC code 
for your multi-axis lathes utilizing the full capability of your machine tool. 

In fact, you have download much more than just post processors.  You have 
downloaded the following items: 

1 The Post Processors your company has licensed – These include the 
*.pst and *.sub (for machines equipped with a sub spindle) 

2 Related Simulation Files – PartMaker’s Advanced and Full Machine 
simulation modules use additional files to allow you to simulate the 
architecture of your machine. You will need to use the *.MCH file 
corresponding to your post processor to view your machine’s working 
envelope when using Advanced Simulation.  If you have licensed Full 
Machine Simulation, you will need to use the *.FMS and *.MCH 
corresponding to your post processor to view your machine’s working 
envelope when using Full Simulation.  Please see the chapter in your user 
manual for information on using PartMaker Advanced and Full Machine 
Simulation modules. Included with these files are PartMaker Job (*.job), 
Tools (*.tdb) and Cycles (*.cdb) files that are configured to run in both 
Advanced and Full Machine Simulation.   

3 Post Processor Related Documentation – Documentation related to your 
licensed post processors and simulation files. 

4 Sample Files – Sample Job (*.job), Tools (*.tdb) and Cycles (*.cdb) files in 
both the inch and metric system corresponding to the tutorials in your 
PartMaker user guide and configured to your machine tool’s specific 
architecture are also provided. 

To see an example of this, let’s look at the files downloaded in this example: 

1 The picture below shows the result of the download above: 

 
2 Double clicking on the folder above called 0073_Mori-

ZL_____Decemeber__17__2014, reveals the following, where: 

1  The *.pst and *.sub, the post processor files themselves 

2  A *.TXT is a readme file explaining changes made in the most recent 
version of the post processor 

3  A folder containing the simulation, *.MCH and *.FMS referred to above 

4  A folder containing tutorial files in the metric system corresponding to 
the tutorial in the user guide 

5  A folder containing tutorial files in the inch system corresponding to 
the tutorial in the user guide 



 

Copyright @2014 Delcam Ltd  User Guide 1-7  

 

6  A folder containing the machine specific addendum and FMS reference 
kit referred to above 

 

 Tip: If using Advanced and/or Full Machine Simulation, you may wish to 
place the *.FMS and *.MCH in the same directory as the *.PST and *.SUB 
files.  This will allow your simulation files to open automatically when you 
load the post processor.  You may also wish to place the tutorial files (in the 
units of measure in which you work) in the same directory. 

More on Multi-Axis Turning Post Processors 
PartMaker Inc’s application staff maintains a library of well documented, well 
supported multi-axis post processors which includes virtually every TurnMill machine 
ever built.  Once you start to customize your own post processor using the 
ConfigPost application,  you create a “non-distribution” post processor. 

Please also note, PartMaker is constantly updating and improving its TurnMill post 
processors to add functionality and correct any possible reported errors. You can 
use the same procedure above to check for post processor updates periodically if 
you are experiencing difficulty with your post processor.  Even if you have 
customized your post processor and are using a “non distribution” post processor, 
you can quickly see any differences between your customized “non distribution” 
post processor and the most current “distribution” post processor using the 
Compare function in PartMaker’s ConfigPost application.  See the ConfigPost user 
guide that came with your software for more information on this function. 

Exiting PartMaker 
1 To exit PartMaker, choose Exit from the File menu. 

If you changed an open job file, a dialog prompts you to save the current job file 
before exiting. 

 
2 Do one of the following: 

 Click <Yes> to save the changes. 

 If the file is untitled, select a location and enter a file name in the dialog that 
appears, then click <OK>. 

 Click <No> to discard the changes and exit. 

 Click <Cancel> to return to the presentation window without exiting. 
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Using On-Line Help 
On-line help provides fast access to information about the application’s tools, 
commands, dialogs, and program features. Help commands are located in the Help 
menu in PartMaker: 

1 Choose Contents from the PartMaker Help menu, click the  icon on 
the toolbar or press <F1>. 

The Help window appears, displaying the Main Index. 

 
2 Click an index to view a list of help topics. 

3 Click the topic you want to read about. 

Information about the selected topic appears in the window. 

Note: Some topic lists include sub-lists from which you can select a help 
topic. 

4 To return to the last screen you viewed, click the <Back> button. 

5 To search for information, click the <Search> tab. 

6 Type in a key word to choose a topic and click the <List Topics> button. 
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7 Click the <Display> button to view the selected topic.  Your help screen will 
appear as below: 

 
8 When you are finished using help, choose Close from the help window’s 

Control menu. 

Using Context-Sensitive Help 
To view context-sensitive help while viewing any PartMaker dialog: 

1 Display any PartMaker dialog. 

2 Press <F1> to display the help topic for the dialog. 

Installing Updates 
PartMaker Version 2010 and higher allows you to update to more recent versions 
and service packs of the software automatically from the PartMaker environment. 
You can check for and download the most recent version of PartMaker by selecting 
Check for PartMaker Updates from the Help menu. 
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Working With Databases 
Databases are where you store tool, material, and cycle information for PartMaker 
jobs. PartMaker uses material, tools, and cycles databases to store the information 
needed for each job. 

Material Database 
A Materials Database allows you to store your shop’s accumulated materials data. 
Materials data is used by PartMaker in the automatic calculation of feedrates and 
spindle speeds. In addition, you can utilize material data in the extensive material 
library provided with PartMaker. 

Turn to Appendix A for a complete list of materials. 

Tools Database 
A Tools Database allows you to keep track of your current tool inventory. 
PartMaker uses geometric and cutting tool characteristics saved with each tool in 
the database for automatic cutting conditions and automatic depth calculation. 

Cycles Database 
PartMaker lets you combine a number of repetitive operations (center drilling, 
drilling, tapping, boring, etc.) into a single entity called a Cycle.  All cycles are saved 
in a Cycles Database. For each cycle operation, you can designate a tool from the 
Tools Database. Once a cycle is created, you can recall it at any time when you 
need to use it again. 

Working With Files 
PartMaker uses several kinds of files for storing tools, cycles, and material 
information as well as your jobs and the postprocessor files used to create NC 
programs for machining. 

 Information about tools in the tool crib is saved in Tools files that have the 
file extension .TDB. 

 Information about material characteristics needed to calculate feedrates and 
spindle speeds is saved in Material files that have the file extension .MDB. 

 Information about user-created machining cycles is saved in Cycles files that 
have the file extension .CDB . 

 Part geometry is saved in Job files that have the file extension .JOB. 

 Postprocessor configuration information is saved in Post Configuration files 
that have the file extension .PST. 
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Chapter 2: PartMaker® Fundamentals 
Introduction 

This chapter discusses the various components of PartMaker’s programming 
approach for TurnMill Centers. This chapter introduces the following topics: 

 Choosing the proper Machining Function Face Windows 

 Programming convention 

 Setting up and working with PartMaker’s Tools, Materials and Cycles 
databases 

 Using Icons 

 Process Synchronization Rules and Techniques 

 Material Control Processes 

Machining Function Selection 
TurnMill Centers are capable of performing a full set of turning operations: facing, 
turning, grooving and threading. Many TurnMill Centers are also capable of 
performing various types of milling as well as drilling holes on different surfaces. 
Multiple spindles in which such operations can be performed simultaneously further 
increase the machines' productivity and complexity.  

Milling capabilities of the TurnMill Center vary significantly and can be ranked in 
order of sophistication as follows:  

 Index milling/drilling 

 Milling on a selected ZX plane 

 Polar milling on the face of the part 

 XZC continuous milling on cylindrical surfaces  

 Milling interpolation in the YZ plane 

Programming of these powerful machines is, however, much more difficult than the 
programming of the individual mill or lathe. Despite significant efforts by many CAM 
vendors to develop an easy-to-use CAM system for programming multi-axis TurnMill 
Centers, the majority of programming today is still done manually.  

PartMaker CAM Software from PartMaker, Inc. applies a Patented ‘divide and 
conquer’ programming strategy to simplify programming of TurnMill Centers. 

PartMaker helps you separate a complicated part surface into a manageable set of 
faces that may be either planar or rotational in nature. All features are represented 
by a surface relative to which a set of part features is referenced.  

On each face, a set of features may be machined using a variety of cutting tools. 
The software takes advantage of the Microsoft Windows operating system, which 
allows multiple windows to be displayed and accessed simultaneously.  

A specific machining function such as turning, polar milling or cylindrical milling is 
assigned to each face. PartMaker lets you create a dedicated window that contains 
a workspace for the graphic representation of face features.  

A dialog box associated with each Face Window shows you the type of machining 
to be performed on a face, the location of the face boundaries and parameters 
defining the positioning of the face relative to the machine coordinate system.  
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Getting Started: The Setup Dialog 
PartMaker employs a programming methodology whereby each machine motion 
type can be separated into a different window dedicated to a specific machining 
function. Every one of these windows is known as a Face Window. Once created, 
each Face Window can be accessed from the Window menu. 

Once divided into much smaller, similar motion components, programming of a 
multi-axis TurnMill Center becomes a much easier task. To best explain how 
PartMaker handles this task, it is necessary to first explain how each of these 
individual-machining functions is defined.  

Selection of the various machining functions is carried out in the Setup dialog. The 
Setup dialog can be accessed from the View menu or by clicking on the shortcut to 
the Setup dialog located in the upper left hand corner of your Face Window. On 
Startup, or when accessing the Setup dialog for the first time, you will see the 
following dialog. Some of the important components of this dialog are explained 
below: 

 
1 The Main Spindle and Sub Spindle radio buttons allow you to select whether the 

programming carried out in a particular Face Window is being machined on the 
Main or Sub-Spindle. 

2 The Tool Change X and Z positions for a particular machine should be entered 
here. 

3 The Use Bar Stock indicates to PartMaker whether the part is being made from 
Bar or Slug.  This effects the display of the 3D part simulation. 

4 The Machining Function drop down menu allows you to select the type of 
machining motion being executed in a particular Face Window. The machining 
motions that can be defined in each selection from the Machining Function drop 
down menu are explained below.   

5 The List of Face Windows displays a list of Face Windows currently existing 
for a given job. 

6 The Rename To: field allows you to name the Face Window you are working 
with. Existing Face Windows can be selected from the Window menu based on 
the names assigned to them in this field of the Setup dialog. 
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7 Clicking the function buttons shown in the Setup dialog with the left-hand 
mouse button does the following: 

<New> 
Creates new face windows of different machining function 
types or on different spindles, adding to the List of Face 
Windows. 

<Delete> Deletes the currently selection from the List of Face 
Windows. 

<Duplicate
> 

Allows the user to duplicate a series of identical Mill ZX, ZY 
and Mill XY windows. Only active when one of these 
Windows is selected. 

<User 
Data> 

Allows the user view the User Data for a given post 
processor.  Only active if a post processor is loaded. 

<Apply> 
Accepts or applies any new parameters or data entered into 
the various fields in the Setup dialog, and the dialog remains 
open. 

<Close> Accepts or applies any new parameters or data entered into 
the various fields in the Setup dialog, and closes the dialog. 

The various selections under the Machining Function drop down menu are explained 
on the following pages. 

The Notes fields allow the user to enter notes about a specific job. These notes 
can be directly output into the NC program to improve documentation. 
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Machining Function: Turning  
The Turn machining function uses conventional turning tools moving in the X and Z-
axes. This machining function includes on centerline drilling where a drill is held 
stationary while the spindle holding the part rotates. All drilled holes must therefore 
be on the rotational centerline of the part.    

The picture below shows the appearance of the Setup dialog when performing 
Turning on the Main Spindle.  

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining 

Excess Stock (E) Rough stock left for facing on the front of the part  

Work Shift Specifies amount of the part exposed during 
machining 

Work Offset Specifies the work offset for the current face window 
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Machining Function: Mill XY Plane 
The Mill XY Plane machining function supports machining operations on the face of 
the part using the Y-axis capability of the machine. G-code output will be generated 
in the form of X and Y coordinates. Features that can be created by using this Face 
Window include off-center holes on the face of the part, pockets on the face of the 
part, and contours (such as CAM shapes) on the face of the part. 

Programming of this machining function requires that your TurnMill Center have a 
programmable Y-axis and that you have purchased the PartMaker Y-axis milling 
option. 

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining 

Work Offset Specifies the work offset for the current face 
window 
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Machining Function: Mill 5 Axis Plane 
The Mill 5 Axis Plane machining function supports angled machining operations 
using either a pivoting tool head or a fixed, angled tool.  Features that can be 
created by using this Face Window include any inclined feature including inclined 
holes, angled flats or any interpolation occurring on an angle. 

Use of this machining function requires that your TurnMill Centers has either a 
programmable tool head or the ability to be fitted with angeled tooling attachments 
and that you have purchased the PartMaker B-axis milling option. 

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining  
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Machining Function: Mill 5 Axis Plane (cont’d) 
Additionally, when using the Mill 5 Axis Plane Face Window, you will also be required 
to use the Face Options dialog which can be accessed by clicking the <Face 
Options> button in the Setup dialog. 

The Orientation Options section of the dialog is used to orient the part and set the 
local coordinate system being used for the features being machined in a given Mill 
5 Axis Plane Face Window. When working with a Solid Model, the parameters in 
the Orientation Options section of the dialog will be set automatically. 

 
Orientation Options 

Index Angle (C): Specifies the angle to which the c-axis is indexed in this face 
window.  

 

Inclination Angle (B):  Specifies the angle about the Z axis about which the 
toolhead or inclined too is tilted in this Face Window.  

 

Local Origin (Xo), Local Origin (Yo), Local Origin (Zo): These fields 
represent the co-ordinates for the local origin created to machine the planar 
face.   When working from a Solid Model, these values are determined by 
placing the local orgin in the mathematical center of the feature being machined. 

Arcs Output Options 

Break Arcs Into Lines: Checking this box indicates to break output for all arcs 
into small lines.  Checking this box is necessary for machines that do not have 
the ability to support a “local coordinate system” and cannot perform 
interpolation with an inclined tool.  

Arc Tolerance (T):  Specifies the sizes of “facets” when breaking arcs into 
lines.  
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Machining Function: Mill ZY Plane  
The Mill ZY Plane machining function is used to perform milling interpolation in the 
ZY plane when the spindle is locked at a discreet angular position.  All motions are 
performed with a tool oriented along the machine X-axis.  

Programming of this machining function requires that your TurnMill Center have a 
programmable Y-axis and that you have purchased the PartMaker Y-axis milling 
option. 

 
 

Angle (C)  Orientation angle of the stock to achieve the desired 
face position 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining  

Work Offset Specifies the work offset for the current face window 
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Machining Function: Mill ZX Plane 
The Mill ZX Plane machining function is used to perform milling in the Z and X 
planes only. Such operations typically involve following a turning profile with an end 
mill (often ball nose) with the machine spindle in a locked position. This window can 
not be used to machine crossholes. 

Programming of this machining function requires that your TurnMill Center have a 
programmable Y-axis and that you have purchased the PartMaker Y-axis milling 
option. 

 
 

Index Angle (C) Orientation angle of the stock to achieve the desired face 
position 

Y-coord (p) Y coordinate value measuring the distance from the 
centerline of the part the tool is offset during machining.  
This value should always be positive. 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before machining 

ID Starting inside diameter of bar stock before machining  

Work Offset Specifies the work offset for the current face window 
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Machining Function: Mill Polygon  
The Mill Polygon machining function allows you to create polygon shapes on the OD 
of a part using the Y-axis capability of your machine and a tool oriented along the 
X-axis of the machine. 

Programming of this machining function requires that your TurnMill Center have a 
programmable Y-axis and that you have purchased the PartMaker Y-axis milling 
option. 

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining  

Work Offset Specifies the work offset for the current face 
window 
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Machining Function: Mill End, Index  
The Mill End, Index machining functon is used when drilling holes and milling slots 
on the end face of the part. The holes are located in the XY plane and oriented 
along the Z-axis.  

The shapes that can be created with this machining function are:  

 Holes in the end of the work piece. created by Z-axis feed. This motion type 
supports off-center drilling on the end of the part, using C-axis indexing and 
X-axis positioning to locate the hole position.  

 Radial slots which are milled using C-axis indexing to position and hold the 
part while X-axis motion is used to cut the part. The tool would be a milling 
tool oriented along the Z-axis. 

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining  

Work Offset Specifies the work offset for the current face 
window 
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Machining Function: Mill Diam, Index  
The Mill Diam, Index machining function allows you  to create “cross holes” or radial 
slots on the OD of the part.  In order to support this machining function, your 
TurnMill Center must be able to support C-axis indexing, which may not be 
performed while the tool is in contact with the work.  

This machining function supports the following features cut on the outside diameter 
of the work using a tool oriented along the machine's X-axis:  

 Slots oriented along the length (Z-axis) of the stock. 

 Holes drilled anywhere along the cylinder except the end of the stock. 

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining  

Work Offset Specifies the work offset for the current face 
window 
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Machining Function: Mill End, Polar  
The Mill End, Polar machining function allows you to perform polar interpolation on 
the face of the part. This machining function assumes that the TurnMill Center has 
the ability to perform simultaneous feed motions with the X, Z and C-axes.  

Programming of this machining function requires that your TurnMill Center has a 
programmable C-axis and that you have purchased the PartMaker C-axis milling 
option. 

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining  

Work Offset Specifies the work offset for the current face 
window 



 

2-14 PartMaker  Copyright @2014 Delcam Ltd 

 

Machining Function: Mill Diam, Polar  
The Mill Diam, Polar machining function supports polar milling anywhere on the 
stock using an X-axis oriented milling tool. This machining function assumes that 
your TurnMill Center has the ability to perform simultaneous feed motions with the 
X, Z and C-axes. The Mill Diam, Polar machining function is most commonly used to 
machine polygon features on the OD of the part using continuous C-axis feed.  
Programming of this type in Face Windows is carried out in much the same 
manner as the Mill Polygon machining function. 

Programming of this machining function requires that your TurnMill Center has a 
programmable C-axis and that you have purchased the PartMaker C-axis milling 
option. 

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining  

Work Offset Specifies the work offset for the current face 
window 
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Machining Function: Mill Cylinder 
The Mill Cylinder machining function supports continuous milling on the outside 
diameter of the part.  Cylindrical milling assumes that your TurnMill Center has the 
ability to simultaneously feed in the X, Z and C axes. 

Using motions of this type, combined with a tool oriented along the X axis of the 
machine, profiles can be created on the outside diameter of the stock. 

Tool positioning is programmed using X, Z, and C axis coordinates.  The C position 
is programmed in terms of degrees of rotation relative to machine C=0 which is 
clearly shown in the graphic below. 

Programming of this machining function requires that your TurnMill Center has a 
programmable C-axis and that you have purchased the PartMaker C-axis milling 
option. 

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining  

Work Offset Specifies the work offset for the correct face 
window 
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PartMaker Programming Convention 
When using PartMaker TurnMill for creating part geometry and NC programs, it is 
important to understand that all work is done moving from right to left in the Z-
axis. This means all drawing and tool path generation is created by moving to the 
left in the Z negative direction, the same programming convention employed on a 
conventional 2-axis CNC Lathe.  The same programming convention also applies for 
work being performed on the sub-spindle. To summarize, PartMaker always 
assumes the collet or chuck to be to the left. 

It is important to keep the right to left programming convention in mind when 
drawing, creating tool paths, and when setting up tools. Tool orientation should 
always be assigned assuming programming in the same direction. 

Working with Files 
PartMaker uses several kinds of files for storing tools, cycles, and material 
information. Your jobs and post processor files used to create NC programs for 
machining can also be stored in their own files. 

 Part geometry, tool path, and process information is saved in Job files that 
have the file extension .JOB.   

 Information about tools in the tool crib is saved in Tools files that have the 
file extension .TDB. 

 Information about material characteristics needed to calculate feedrates and 
spindle speeds is saved in Material files that have the file extension .MDB. 

 Information about user-created machining cycles is saved in Cycles files that 
have the file extension .CDB. 

 Postprocessor configuration information is saved in Post Configuration files 
that have the file extension .PST. 

The Job File 
The Job file is the main file type used in PartMaker. Every job file must have a 
tools and cycle file associated with it. However, particular tools and cycles files can 
be (and should be) associated with many if not all of your job files. Job files have 
the extension .job. 

The name of the current job file you are working with is displayed at the top of the 
PartMaker screen as shown below: 
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Working With Databases 
Databases are where you store tool, material, and cycle information for PartMaker 
jobs. PartMaker uses material, tools, and cycles databases to store the information 
needed for each job. These three databases represent the knowledge-based 
components of PartMaker because they allow you to store shop specific 
information that can be reapplied to future jobs automatically, thus letting 
PartMaker learn from you. The more you use PartMaker, the smarter it gets! 

 Important! Before you begin programming a job, make sure you properly 
setup your databases in PartMaker. This means creating the tools you need 
for the job, selecting the material you are cutting, and setting-up the 
holemaking cycles you may need to machine the part. 

Tools Database 
A Tools Database allows you to keep track of your current tool inventory. 
PartMaker uses geometric and cutting tool characteristics saved with each tool in 
the database for automatic cutting conditions and automatic depth calculation. Each 
tool database can store up to 3,000 different tools. 

Note: Due to the unique nature of tool placement and off-set information required 
by different TurnMill Centers, when using PartMaker TurnMill, it is recommended 
that you set up one tools file for each TurnMill machine you are programming. Doing 
so will avoid a great deal of confusion. 

Please refer to the Machine Specific Addendum(s) that came with your TurnMill 
software for information on properly setting up tools for your machine. 

You can access PartMaker’s Tools Database by choosing Tools from the 
ToolMinder menu. The picture on the following page highlights some of the key 
elements of the Tool Data dialog for both turning and milling tools. Please take the 
time to review and understand these now. 
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Tools for Turning 
The turning tool below can be viewed by choosing Tools from the ToolMinder 
menu and choosing OD Turn-55. 

 
 The Tool Data dialog box title bar shows the directory path of the tools 

database. 

 The Type, Location and Orientation fields determine general appearance of 
the current tool. These fields apply to turning tools – turning, grooving and 
threading tools. It is important to be mindful of the tool orientation with respect 
to PartMaker TurnMill’s programming convention. You must remember 
programming is done assuming the collet or workholding to be to the left. 

 For Turning tools only. Insert allows you to choose the type of insert being 
used. 

 Material allows you to choose the material for the current tool. This selection 
will directly impact feed and speed calculations.   

 The Tool Post drop down menu allows you to choose the location or tool post in 
the TurnMill Center where a tool is mounted. Various TurnMill Center machines 
have different configurations, but all varieties are accommodated by using the 
selections from the Tool Post drop down menu. Be sure to designate the correct 
tool group when setting up a tool. Each tool group selection can be explained as 
follows: 

 Turret  #1 – For single turret machines, this tool post should always be 
selected. 

 Turret #2 – Indicates that the current tool resides in the second turret on 
the machine. For use with TurnMill Centers that have a two-turret structure. 

 Turret #3 – Indicates that the current tool resides in the third turret on the 
machine. For use with TurnMill Centers that have a three-turret structure 
(least common). 

 The List of Tools by: radio buttons allow you to list tools either by their Type 
or Tool ID, their unique catalogue number in the tool database. Tools will be 
shown sorted in the list based on their Tool ID and assigned name from the 
Rename To: field. 

 Clicking the function buttons shown in the Tool Data dialog with the left-hand 
mouse button does the following: 
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 <New> – Allows you to create new tools to be added to the tools database. 

 <Delete> – Allows you to remove or delete an existing tool from the tools 
database. 

 <Close> – Accepts or applies any new parameters or data entered into the 
various fields in the Tool Data dialog, and closes the dialog. 

 <Verify Shape> – Allows you to verify the shape of the currently selected 
tool according to the specified parameters. For the first tool shown, when 
clicking this button, you should see the following: 

 
Click <Hide Shape> to return to the Tool Data dialog. 

 <Tool Properties> - Clicking this button displays the Tool Properties 
dialog. The tool properties dialog allows you define tool specific offsets for 
each tool.  

 <Apply> - Accepts or applies any new parameters or data entered into the 
various fields in the Tool Data dialog, and the dialog remains open. 
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Tools for Milling and Holemaking 
Tools used for Holemaking and Milling are defined in the same way as turning tools. 
The major difference is the orientation. When setting up a milling or holemaking tool 
– regardless of whether it will be “live” or “dead” (used on centerline in Machining 
Function Window of Type Turning) you must specify its orientation with respect to 
the stock being machined. 

Tool T006 in the list of tools below is an End Mill. This end mill has been designated 
as a “Z Tool” meaning it is oriented horizontally with respect to the stock being 
machined. The type of Face Window in which a tool with a “Z Tool” orientation is 
applied will determine if it is live or dead. 

See Tools for Turning in the previous section of this chapter for more information 
on the functionality of this dialog. 

 
Next, look at tool T008 in the list of tools to select the End Mill. This end mill has 
been designated as an “X Tool” meaning it is oriented vertically with respect to the 
stock being machined. Tools with “X Tool” orientations are always “live” tools. 
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Material Database 
The Material Database allows you to store your shop’s accumulated materials 
data. PartMaker uses materials data in the automatic calculation of feedrates and 
spindle speeds. The Materials Database allows you to choose from a variety of 
different materials and even adjust them and store your changes in order to 
customize feeds and speeds to your shops requirements. 

Turn to Appendix A for a complete list of materials. You can also use the On-line 
Context Sensitive Help that comes with your PartMaker system to view a complete 
list of included material files, inclusive with various material grades for each. 

Selecting a Material File 
When creating a part, it is important to select a material. To do so: 

1 Choose Open Material File from the File menu to display the Open Material 
File dialog shown below:  

 
2 Locate and select ST_FMSTW (Free Machining Stainless Steel Wrought) from 

the list and click <Open>. You are returned to the Face Window. 

3 To view the cutting characteristics of the selected material, choose Material 
from the ToolMinder menu and you will the see the dialog shown below:  
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Customizing a Material File 
You can customize materials files in PartMaker by adjusting the feed and speed 
charts displayed in the Material dialog. To do so: 

1 Choose Material from the ToolMinder menu to display the Material File 
dialog shown below: 

 
2 Click the third radio button on the right hand side to display the feed chart. 

By clicking on and dragging the node points lying on the chart or the axes, 
you can customize feed rates for different sized drill. The same technique can 
be employed for spindle speeds as well for all the tools listed. 

3 Once you are satisfied with the changes you have made, you can save your 
changes by choosing Save Material File As… from the File menu. In the 
file name section, enter “303 Stainless” and click <Save> to save the 
material. 
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4 You will now notice the new name of the material file at the top of the 
Material File dialog as shown below: 

 

 Note: When saving changes to material files, you must give them a 
different name than the initial PartMaker material used. The material 
files that come with PartMaker are read-only files and cannot be 
overwritten. 

5 Click on the Ranges button to see how the chart is calculated. Notice how 
with each tool you can change parameters on which speeds and feeds are 
based as well as the speeds and feeds themselves. Click <OK> to close this 
dialog. 

 
6 Click the close box in the upper, right-hand corner of the Save Material File 

as: dialog box to return to the Face Window. 
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Cycles Database 
PartMaker lets you combine a number of repetitive operations (center drilling, 
drilling, tapping, boring, etc.) into a single entity called a Cycle. All cycles are saved 
in a Cycles Database. The Cycles Database can store up to 1,800 cycles. For each 
cycle operation, you can designate a tool from the Tools Database. Once a cycle is 
created, you can recall it at any time when you need to use it again. Cycles can be 
setup for both cross holes and holes on the face of the part, as well as for holes 
involving both live and dead tooling. 

Creating and Storing Cycles 
In this exercise, you will create a cycle for off-center holes on the face of a part 
using existing tools in the tools database. This cycle will contain a center drill and a 
drill. 

You can access PartMaker’s Cycles Database by choosing Cycles from the 
ToolMinder menu. Once you are in the Cycle Data dialog, to create a new cycle: 

1 Click the <New> button to create a new cycle. A blank cycle such as the 
one below will be displayed. 

 
2 The next step in creating a Cycle is determining how it will be used. You 

must determine if the cycle will use on-centerline tools or if it will use “live” 
tools and if these live tools will be used for face work (Z Tools) or for cross 
work (X Tools).   

The radio buttons at the top of the cycles dialog allow you to make this 
determination. By default the Mill and Z Tools radio button are checked. 

 
3 This configuration is correct for the off-center face hole. 

4 Next, choose the operations that will comprise the cycle. To do so, choose 
Center and Drill, respectively, from the Operation Type drop-down menu. 
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After doing so, your dialog should appear as shown below: 

 
5 Next, choose the corresponding Canned Cycles from the Canned Cycles drop 

menu for each of these operations, which will be DRILL and DRILL, 
respectively.  

Finally, specify the hole diameter for each tool.  In this case, the Center Drill 
should be 0.0938 and the Drill 0.125.  

After entering the parameters as specified above, your dialog should appear as 
shown below: 

 
6 Click the <Select Tools> button and PartMaker will prompt you for the 

tools being selected in the tools database: 
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7 Click the <Select> button to select each tool from the library. The Cycles 
Data dialog should now appear as shown below: 

 
8 In the Rename To: field, rename the cycle Drill 1/8 and click the <Apply> 

button. 

9 The completed Cycle Data dialog should appear as shown below: 

 
Notice that the column for depth has not been filled out. It has been 
intentionally left blank in order to allow PartMaker to calculate the depths of 
cut for each tool automatically when applied to the part. This automatic 
calculation is based on the nominal hole depth and specified geometric 
characteristics of the tools in the cycle.   

One cycle may be applied to many different jobs, and allowing PartMaker to 
calculate the depth of cut makes each cycle more flexible. It may at times be 
desirable to enter a value into the depth field. When doing so, be advised 
that this value will be “hard coded” and that whenever using the cycle, this 
tool will always travel to the depth specified in the Cycles Data dialog. 

10 Once you are satisfied that your dialog appears as the one above, click the 
<Close> button. 
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Working in a Face Window 
A Face Window is the work area in which you define groups machining features or 
tool paths. The main area of the window displays the part boundaries; the left frame 
displays the program groups in a tree format, which have the cycle name labels 
needed to machine the current part. Just to the left of the main screen area displays 
the Graphics Icons as well as the Short Cut to the Setup dialog icon. 

 

 

 
Show Axis 

You can display the axes in a Face 
Window by choosing Show Axes from 
the View menu. 

 Show Grid 
You can display the grid in a Face 
Window by choosing Show Grid from the 
View menu. 

 
Show Boundaries 

You can display the part boundaries in a 
Face Window by choosing Show 
Boundaries from the View menu. 

Using the CAD/CAM Switch 
 

 
This icon represents CAM mode. Clicking it will switch the program to the CAD mode. 

 

All tool path creation and process development is done in the CAM mode. All 
geometry creation and alteration is done in the CAD mode. 
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Using the Color Bar 

 
You use the color bar in the upper-right corner of a Face Window to select a color 
for group symbols. You can also use it to change the color of geometry. The group 
symbol or geometric element will have the color of the currently chosen Sample 
Color. 

 Note: If you want to change the color of a Group Symbol, select the Group 
Symbol in the Face Window, click a color on the color bar, and then click 
the Sample Color on the left side of the color bar. 

To change the color of a geometric element, select the geometry in the Face 
Window, click a color on the color bar, and then click the Sample Color on the left 
side of the color bar. 

Using the Icon Toolbars 
PartMaker Version 9 and higher provides Toolbars to speed up commonly used 
functions throughout the software. PartMaker supports four types of icon toolbars, a 
Main Toolbar which is available throughout a job file, a Face Window Toolbar 
which is associated with each Face Window, a Solids Window Toolbar which 
appears when working with an imported Solid Model and a Simulation Toolbar 
which appears when working in PartMaker’s 3D simulation.  Here, the Main Toolbar 
and Face Window Toolbar are explained.  Chapter 6 of this guide will explain the 
use of the Simulation Toolbar while Appendix C to this manual will explain the use of 
the Solids Window Toolbar. 

Main Toolbar 
The Main Toolbar lets you perform many of the functions in PartMaker’s menus 
with the click of a button.  The Main Toolbar will look the same throughout your 
PartMaker session and appears as below: 

 

 Note:  When holding your mouse over any of these icons, a “Tool Tip” will 
appear showing the function performed by that icon. Each command is 
explained in greater detail in Chapter 4 of this manual. 

Face Window Toolbar – CAM Mode 
The Face Window Toolbar lets you perform many of the functions in PartMaker’s 
menu’s with the click of a button.  The Face Window Toolbar applies only to the 
active Face Window and may look differently depending on the Machining 
Function Face Window being used. 

 

Face Window Toolbar – CAD Mode 

 

Displaying Toolbar Icons 
The display of the Toolbars can be manipulated by choosing Toolbars from the 
View menu.  When a toolbar is checked, it will appear.  When unchecked, it will not 
be visible. 
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Creating Groups of Part Features 
Groups of part features such as holes and profiles are created in PartMaker. The 
currently selected group icon or Group Symbol in a Face Window is the work 
group from which tool paths are being added.  Group Symbols are displayed on the 
left side of the screen on the Job Explorer Tree in the CAM mode 

To create a new Group Symbol: 

1 Click the desired color on the color bar. 

2 Choose New Profile or New Hole Group (depending on the type of Part 
Feature being created) from the Part Features menu to display the Group 
Parameters dialog. 

When you exit the dialog, the new group is created using the color you 
specified. 
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Using the Graphics Icons in PartMaker CAD mode 
You can create your part drawings in PartMaker in the CAD mode. Alternatively, 
you also import drawings from other CAD systems into PartMaker by using the 
Import command from the File menu. Imported geometry can be altered in 
PartMaker’s CAD mode. 

 
Geometry is created in PartMaker CAD using the Graphics Icons that include 
Drawing Icons and Snap Modes. 
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Geometry Drawing Icons 
Geometry Drawing icons allow you to create different types of geometric 
constructions such as lines and arcs. PartMaker’s geometry drawing icons are 
defined below. 

 

Selection Icon indicates that the system is in the selection mode. In this mode you can 
select lines, arcs and circles in the Face Window either by clicking on them or dragging a 
selection rectangle around them. 

 
Zero Icon allows you to define a new location for the zero point using Snap Modes. 

 
Trim/Extend Icon allows you to stretch or shorten an existing line or arc. 

 
Remove Icon allows you to remove portions of lines or arcs between intersection points. 

 
Line Thru Two Points Icon allows you to create a line between two points specified using 
Snap Modes. 

 
Connected Lines Icon allows you to create connected lines with end points specified using 
Snap Modes. 

 
Line Parallel Horizontal axis Icon allows you to create a line parallel to the Horizontal 
axis by specifying positive or negative offset. 

 
Line Parallel Vertical axis Icon allows you to create a line parallel to the Vertical axis by 
specifying positive or negative offset. 

 
Parallel Element Icon allows you to create a line, arc, or circle parallel to the cursor 
selected entity specifying an unsigned distance. 

 
Line on an Angle Icon allows you to create a line on an angle to a cursor-selected line 
passing through a point specified using Snap Modes. 

 
Fillet Icon allows you to insert a fillet between two cursor-selected lines or arcs. 

 
Chamfer Icon allows you to insert a chamfer between two cursor-selected lines or arcs. 

 
Circle with a Known Radius and Center Icon allows you to define a circle with a center 
specified using Snap Modes. 

 
Circle with a Known Radius and Two Points Icon allows you to define a circle with two 
points on the circumference specified using Snap Modes. 

 
Circle with a Known Center and a Point Icon allows you to define a circle with a center 
and a point on the circumference specified using Snap Modes. 

 
Circle Through Three Points Icon allows you to define a circle with three points specified 
using Snap Modes. 

 
Polygon Icon allows you to create a various rectangles by entering a flat-to-flat distance. 

 
Divide/Append Icon aids you in the “breaking” of segments at specific point within the 
geometry.  

 
Multiple Offset Icon allows you to offset the selected geometry chain through a user-
defined distance. 

 
Ellipse Icon allows you to create an approximate ellipse in the face window, using 
tangential circular arcs. 
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Dimensioning Icons 
The Dimensioning Icons appear in the PartMaker CAD mode.  These icons allow you 
to create dimension and annotations on your drawings in PartMaker. 

 Note Icon Allows you to create a note on a dimensioned drawing. 

 
Note with Leader Icon allows you create a note with an arrow leader to 
point to a specific item on your drawing you wish to annotate. 

 
Angular Dimension  This icon allows you to insert an Angular Dimension 
between two lines.. 

 
Circular Dimension Icon This icon allows you to insert a Circular 
Dimension on arc or circle. 

 

Horizontal Dimension Icon This icon allows you to insert a Horizontal 
Dimension between two points that are either end points of arcs and lines 
or centers of circles. 

 

Vertical Dimension Icon This icon allows you to insert a Vertical 
Dimension between two points that are either end points of arcs and lines 
or centers of circles. 

 

Linear Dimension Icon This icon allows you to insert a Linear Dimension 
between two points that are either end points of arcs and lines or centers 
of circles. 

 

Flexible Dimension Icon This icon allows you to insert a “Flexible 
Dimension” that is automatically set by the software to either Horizontal 
Dimension or Vertical Dimension or Linear Dimension depending on the 
cursor position when the text location is specified. 
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Snap Modes 
Snap modes are used in conjunction with geometry icons to define point location. 
PartMaker’s Snap Modes are defined below. Snap drawing modes are also used in 
the CAM mode to define tool path location. 

 

 

ZX Coordinates: Used for entering Cartesian coordinates. 
For Face Windows of various machining functions, this snap mode will change 
accordingly. 

 

ZX for Mill ZX Plane and Turn 
XY for Mill XY Plane, Mill Polygon, Mill End Index, Mill End Polar and Mill Diam 
Polar 
ZC for Mill Diam Index and Mill Cylinder 
ZY for Mill ZY Plane 

 Polar Coordinates: Used for entering Polar coordinates 

 
Point on a Circle: Clicking a point on an existing arc or circle and entering an 
Angle 

 Screen: Clicking a cursor location anywhere within the face window 

 

Grid: Clicking a grid location (grid can be turned on from the View Menu by 
choosing Show Grid. Grid size can be set in the Preferences dialog accessed from 
the View menu). 

 Circle Center: Clicking the center an existing circle 

 Closest Intersection: Clicking the closest intersection of geometric elements 

 End of an Element: Clicking the end of an existing line or arc 

 Middle of an Element: Clicking the middle of an existing line or arc 

 
Tangency: Clicking near the tangency point that will be calculated by the 
system 

 
Horizontal Constraint allows you to specify a point whose vertical coordinate 
remains constant, allowing changes in horizontal coordinate only. 

 
Vertical Constraint allows you to specify a point whose horizontal coordinate 
remains constant, allowing changes in vertical coordinate only. 
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Using the Graphics Icons in PartMaker CAM mode 
The Graphics Icons to the left of a CAM Face Window allow you to define and 
manipulate tool paths. The list of the Graphics Icons for use in assigning a particular 
part feature to your part (i.e. a Group Symbol) will have a different appearance 
depending on the Machining Function Face Window being used. 

The two icons below will have the same appearance and usage regardless of which 
machining function Face Window you are using. 

 
Selection Icon indicates that the system is in the selection mode. In this 
mode, you can select part features and tool paths in the Face Window either by 
clicking or dragging a selection rectangle around them. 

Selected profiles in a Face Window are highlighted; unselected profiles are not 
highlighted. Selected holes in a Face Window are highlighted; unselected holes 
are hollow.  You can delete selected elements by pressing the <Backspace> 
key on the keyboard or by choosing the Delete command from the Edit menu. 

 

Zero Icon allows you to define a new location for the zero point or origin using 
Snap Modes. 

The following icons will have the same function in any given Face Window.  
However, the list changes depending on which machining function Face Window 
you are using. 

 

Profile Icon enables you to specify that the currently active group symbol is to be 
applied to the profile described by either coordinate entry or by clicking on geometric 
elements. 

 

Chain Icon enables you to specify that the currently active group symbol is to be 
applied to a profile that is created when PartMaker automatically connects all the 
elements that form an unbroken chain when an initial line or arc is clicked. 

 

2-Point Chain Icon The 2-Point Chain icon allows you to define a profile by the start 
point in the chain, and the end point of the chain. 

 
Profile Info allows you to select an element (line or arc) on the profile curve and to 
display a Profile Info Dialog. This icon is available only if a profile group already exists. 

 
Single Hole Icon enables you to use Snap Modes to define the location on the 
geometry where a currently active Hole Group Symbol is to be executed. 

 

Define Profile Icon enables you to specify that the currently active group symbol is 
to be applied to the profile described by either coordinate entry or by clicking on 
geometric elements. 

 

Chain Geometry Icon enables you to specify that the currently active group symbol 
is to be applied to a profile that is created when PartMaker automatically connects all 
the elements that form an unbroken chain with an initial line or arc clicked. 

 

Profile Icon enables you to specify that the currently active group symbol is to be 
applied to the profile described by either coordinate entry or by clicking on geometric 
elements.  When performing indexing operations, the Profile Icon may only join two 
points during its usage. 

 

Chain Icon enables you to specify that the currently active group symbol is to be 
applied to a profile that is created when PartMaker automatically connects all the 
elements that form an unbroken chain with an initial line or arc clicked. When 
performing indexing operations, the Chain Icon may only join two points during its 
usage. 

 
Engrave Icon enables you to use the Engrave Data dialog box to create a profile 
containing numbers and letters. 
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Process Synchronization in PartMaker TurnMill 
After a part has been programmed in PartMaker TurnMill, the user has the 
opportunity to synchronize the processes defined in each of the Face Windows. 
Process synchronization is done visually by PartMaker via the Set Modes dialog 
accessed from the Process Table by clicking on the Set Modes icon to the right of 
every process. 

 

Introduction to Synchronization 
Generally speaking, today’s TurnMill Centers can allow five (5) types of synchronous 
machining: 

Type 1: The first type of synchronous machining, which can be performed on a 
TurnMill Center, is actually NOT synchronized at all. This involves machining on one 
spindle at a time with a single tool while the other spindle remains idle. This type of 
synchronous operation is represented by the following PartMaker modes: 

M1S0: Main Spindle Cutting with One Tool, Sub Spindle idle. This mode of 
operation involves cutting with only one tool on the main spindle, while no 
machining occurs on the sub-spindle. This mode may be used if a part only 
requires main spindle work, if all simultaneously occurring operations have 
already been synchronized, or if the machine does not allow synchronous 
operation under certain circumstances (i.e. when end working is being 
performed or when live tools are engaged). 

This mode of operation may only be assigned to processes defined in a Face 
Window created for work on the Main Spindle. 
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M0S1: Main Spindle Idle, Sub Spindle Cutting with One Tool. This mode of 
operation involves cutting with only one tool on the sub spindle, while no 
machining occurs on the main spindle. 

This mode of operation may only be assigned to processes defined in a Face 
Window created for work on the Sub Spindle. 

 
Type 2:  One tool cutting while the part is being supported with the sub-spindle.  
This type of synchronization is most often used during part cut-off and transfer from 
main to sub spindle. It is also used provide additional support when machining 
longer parts. 

M1SP: Main Spindle Cutting with One Tool, Part Support. This synchronous 
mode of operation involves the use of one tool cutting while the part is being 
supported with the sub spindle. 
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Type 3:  Two Tools working on different spindles simultaneously. This type of 
synchronous operation is represented by the following PartMaker modes: 

M1S1: Main Spindle Cutting with One Tool, Sub Spindle Cutting with One Tool. 
This synchronous mode of operation involves the use of two tools on separate 
turrets (as created in the PartMaker Tool Database), cutting on separate 
spindles. 

 
Type 4: Two Tools working simultaneously on the main spindle. This type of 
synchronization is often referred to as “Pinch Turning” or “Balance Turning” when it 
involves two outside diameter turning operations. It may also be used when 
performing turning on the outside diameter and inside diameter (ID boring or 
drilling on the end of a part) simultaneously. This type of synchronous operation is 
represented by the following PartMaker modes: 

M2S0: Main Spindle Cutting with Two Tools, Sub Idle. This synchronous mode of 
operation involves the use of two tools on separate turrets (as created in the 
PartMaker Tool Database) on the same spindle. These tools can either both be 
turning tools or one can be a turning tool while the other is a “dead” holemaking 
tool performing on centerline work on the end of the part. 
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M2SP: Main Spindle Cutting with Two Tools support with Sub-Spindle. This 
synchronous mode of operation involves the use of two tools on separate tool 
posts (as created in the PartMaker Tool Database) working on the same spindle 
while the sub-spindle is supporting the stock. In this case, the tools must both 
be working on the outside diameter. 

 
Type 5: Three tools working simultaneously, where two tools are working on the 
main spindle and one tool is working on the sub spindle. In such a case, two tools 
can be working simultaneously on the main spindle while a third is working on the 
sub-spindle. Only the most advanced TurnMill Centers on the market are capable of 
such operation. This type of synchronous operation is represented by the following 
PartMaker mode: 

M2S1: Main Spindle Cutting with Two Tools, Sub Spindle Cutting with One Tool. 
This synchronous mode operation involves the use of two tools on separate tool 
posts (as created in the PartMaker Tool Database) on the main spindle, while 
using a third tool mounted on a third tool post on the sub spindle. 
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Type 6:  Two Tools working simultaneously on the sub spindle. This type of 
synchronization is often referred to as “Pinch Turning” or “Balance Turning” when it 
involves two outside diameter turning operations. It may also be used when 
performing turning on the outside diameter and inside diameter (ID boring or 
drilling on the end of a part) simultaneously. This type of synchronous operation is 
represented by the following PartMaker modes: 

M0S2: Sub Spindle Machining with Two Tools, Main Idle. This synchronous 
mode of operation involves the use of two tools on separate tool posts (as 
created in the PartMaker Tool Database) on the same spindle. These tools can 
either both be turning tools or one can be a turning tool while the other is a 
“dead” hole making tool performing on centerline work on the end of the part. 

 
M1S2: Main Spindle Machining with One Tool, Sub Spindle Machining with Two 
Tools. This synchronous mode operation involves the use of two tools on 
separate tool posts (as created in the PartMaker Tool Database) on the sub 
spindle, while using a third tool mounted on a third tool post on the main 
spindle. 
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Working with Sync Groups 
Once the user has chosen the manner in which processes will be synchronized on 
the Process Table, he has to determine the order in which these processes must be 
grouped. A group of two or more consecutive processes being executed with the 
same PartMaker Synchronization Mode, as described in Synchronization Types 2 – 
4 above, is called a Sync Group. Sync Groups are created automatically when the 
Synchronize button is clicked or when the Generate NC Program command is 
chosen. Each Sync Group will have a number assigned to it, denoting separate 
groups of synchronous operations, such as those shown below: 

 
PartMaker will perform error checking when the Sync Groups are created. Error 
checking assures that groups of processes being executed simultaneously have 
been ordered correctly on the Process Table. This error checking also includes 
determining whether proper tool post assignments have been made. 

Determining the Active Tool in a Sync Group 

The user can differentiate between Active and 
Inactive Tools for any process in a Sync Group 
by noting the color of the tool in the Set 
Modes dialog assigned to that process. The 
tool in use during the current process will 
always be colored in yellow, while the tool that 
is not cutting will be shaded in gray as shown 
in the diagram to the right, taken from the 
M2S0 Set Modes dialog. 

Rules for Grouping Synchronized Operations 
Rules for grouping operations assigned various PartMaker Modes are explained 
below: 

M1S0: Main Spindle Cutting with One Tool, Sub Spindle idle. 

Processes assigned M1S0 modes must involve one or more sequential processes 
defined in Face Windows designated for work on the Main Spindle. Processes may 
use tools from any tool post capable of working on the main spindle. 

Process Table Example: 
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M0S1: Main Spindle Idle, Sub Spindle Cutting with One Tool. 

Processes assigned M0S1 modes must involve one or more sequential processes 
defined in Face Windows designated for work on the Sub Spindle. Processes may 
use tools from any tool post capable of working on the sub spindle. 

Process Table Example: 

 

M1S1: Main Spindle Cutting with One Tool, Sub Spindle Cutting with One Tool. 
Processes assigned M1S1 modes must involve one or more sequential processes 
defined in Face Windows designated for work on the Main Spindle followed by one 
or more sequential processes defined in Face Windows designated for work on the 
Sub Spindle. Within a group of processes labeled M1S1, PartMaker will generate an 
error if the same tool post is used on both a main spindle and sub spindle process. 
In addition, the stock should either be stationary or moving for all Main Spindle 
processes in an M1S1 sync group. 

Process Table Example: 

 

M1SP: Main Spindle Cutting with One Tool, Sub Spindle providing Part Support 
(Closed Sub-Spindle Collet) or Non-Following Support (Open Sub-Spindle Collet). 
Processes assigned M1SP modes must involve one or more sequential processes 
defined in Face Windows designated for work on the Main Spindle. Processes 
assigned these modes should use tools whose movements are independent of the 
sub-spindle. In addition, PartMaker will display errors if Sub-Spindle Support Z-
Coordinate (Sz) parameters are not provided, or if negative values are entered in 
this field. 

Process Table Example: 
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M2S0: Main Spindle Cutting with Two Tools, Sub Idle. This synchronous mode of 
operation involves the use of two tools on separate tool posts (as created in the 
PartMaker Tools Database) on the same spindle. Pinch Turning is handled in this 
mode and the M2S0 mode will be designated automatically on the process table if 
the Pinch Turning box for two groups is checked. Simultaneous OD and ID work is 
also programmed using this mode. 

Process Table Example: 

 

M2SP: These two synchronous modes of operation observe the same rules as the 
M2S0 Mode, except that they involve sub-spindle support during machining.  

Process Table Example: 

 

M2S1: Main Spindle Cutting with Two Tools, Sub Spindle Cutting with One Tool. A 
Sync Group with processes assigned the M2S1 mode must involve one processes 
defined in a Face Window designated for work on the Main Spindle involving a 
Primary Tool. This should then be followed by one processes designated for work 
on the Main Spindle involving a Secondary Tool. Finally, the main spindle operations 
should be followed by one or more sequential processes defined in Face Windows 
designated for work on the Sub Spindle. 

Three different turrets should be used within a Sync Group involving the M2S1 
mode.  

Process Table Example: 

 

More Information on Sync Groups 
You can learn more about using and applying Sync Groups for your machines by 
referring to the machine specific addendum, which came with your PartMaker 
TurnMill software. This addendum contains information about machine-specific 
synchronization techniques as well as which synchronous modes of operation your 
post processors support. 
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Material Control Processes 
Material Control Processes (MCPs) are turning processes which, do not involve 
material removal but do require NC programming.  MCPs can be inserted into the 
Process Table via the <Insert Material Control Process> command under the 
Job Optimizer menu.  Upon insertion into the Process Table, MCPs will be placed at 
the top of the Process Table by default.  MCP actual place in the process will be 
determined by clicking on the arrow beneath the cutting after which the MCP should 
be activated. 

The applications of each MCP available in PartMaker TurnMill are explained below 
along with an explanation of the parameters needed to activate it. 

 Note: Individual post processors may support certain MCPs but not others.  
Please consult your machine-specific addendum or PartMaker Technical 
Support to determine which MCP is supported by your post processors. 

Bar Feed 
The Bar Feed Material Control Process allows the user to insert code for feeding the 
bar stock out to a certain Z-coordinate and stopping with it a bar stop mounted in 
the turret. 

 
Tool Post: Choose the turret at which the Bar Stop is mounted. 

Turret #1 – Defined as the upper turret for slant bed lathes or the front 
turret for flat bed lathes. 

Turret #2 - Defined as the lower turret for slant bed lathes or the rear 
turret for flat bed lathes. 

Turret #3 – Defined as the third turret for three turret lathes – Please 
contact PartMaker Technical Support for more information on three-turret 
capability. 

 Note: If using a lathe with only one turret, select Turret #1. 

Tool No.: Enter the tool station number at which the Bar Stop is mounted. The 
number must be a one or two digit integer. 
Tool Offset: Enter the offset number for the Bar Stop. The number must be a 
one or two digit integer. 



 

2-44 PartMaker  Copyright @2014 Delcam Ltd 

 

Xr: Enter an absolute x coordinate (measured from the center of the spindle) to 
position the Bar Stop before stock is pushed out.  This number would typically 
be zero. 

 Note: If using the cutoff tool as the Bar Stop, enter a negative x 
coordinate in order to move the cutoff tool insert below the stock 
diameter. 

Zr: Enter an absolute z coordinate (measured from the face of the part) to 
position the bar stop before the stock is pushed out. For short parts, this 
number can be set to zero. For longer parts, it is preferred to set this number 
equal to the length of the part so that the stock does not ram into the Bar Stop 
after the collet opens. 
Process Time: Enter a time estimation from when the Bar Stop moves from its 
safe index position at the beginning of the process to when the Bar Stop moves 
back to its safe index position at the end of the process. Time can either be set 
to seconds or minutes – see Preferences on how to set time units. 

Pull with Side Gripper 
The Pull with Side Gripper Material Control Process allows the user to insert code for 
pulling the bar stock out to a certain Z-coordinate with a part gripper mounted in 
the turret which supports the part from the side. 

 
Tool Post: Choose the turret at which the Side Gripper is mounted. 

Turret #1 – Defined as the upper turret for slant bed lathes or the front 
turret for flat bed lathes. 

Turret #2 - Defined as the lower turret for slant bed lathes or the rear 
turret for flat bed lathes. 

Turret #3 – Defined as the third turret for a three turret lathe – Please 
contact PartMaker Technical Support for more information on three turret 
capability. 

 Note: If using a lathe with only one turret, select Turret #1. 
Tool No.: Enter the tool station number at which the Side Gripper is mounted. 
The number must be a one or two digit integer. 

Tool Offset: Enter the offset number for the Side Gripper. The number must be 
a one or two digit integer. 
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Xr: Enter an absolute x coordinate (measured from the center of the spindle) to 
position the Side Gripper above the bar stock before it moves to X0.0 to clamp 
the bar. This number is usually greater that the bar stock diameter.  

Zr: Enter an incremental z distance (measured from the final cutoff z 
coordinate) to position the Side Gripper above the bar stock before it moves in 
to clamp the bar. 
Pull Distance (Zp): Enter an incremental z distance from where the Side 
Gripper has clamped onto the bar to where the stock is to be pulled. 

Process Time: Enter a time estimation from when the Side Gripper moves from 
its safe index position at the beginning of the process to when the Side Gripper 
moves back to its safe index position at the end of the process. Time can either 
be set to seconds or minutes – see Preferences on how to set time units. 

Pull with Front Gripper 
The Pull with Front Gripper Material Control Process allows the user to insert code 
for pulling the bar stock out to a certain Z-coordinate with a part gripper mounted in 
the turret which supports the part from the front. 

 
Tool Post: Choose the turret at which the Front Gripper is mounted. 

Turret #1 – Defined as the upper turret for slant bed lathes or the front 
turret for flat bed lathes. 

Turret #2 - Defined as the lower turret for slant bed lathes or the rear 
turret for flat bed lathes. 

Turret #3 – Defined as the third turret for a three turret lathe – Please 
contact PartMaker Technical Support for more information on three turret 
capability. 

 Note: If using a lathe with only one turret, select Turret #1. 
Tool No.: Enter the tool station number at which the Front Gripper is mounted. 
The number must be a one or two digit integer. 
Tool Offset: Enter the offset number for the Front Gripper. The number must 
be a one or two digit integer. 
Grip Coord (Zg): Enter an incremental z distance (measured from the face of 
the bar stock) to where the Front Gripper is to clamp on to the bar.  
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Pull Distance (Zp): Enter an incremental z distance from where the Front 
Gripper has clamped onto the bar to where the stock is to be pulled. 
Process Time: Enter a time estimation from when the Front Gripper moves 
from its safe index position at the beginning of the process to when the Front 
Gripper moves back to its safe index position at the end of the process. Time 
can either be set to seconds or minutes – see Preferences on how to set time 
units. 

Tailstock Forward 
The Tail Stock Forward Material Control Process allows the user to insert code for 
bringing a tailstock forward for support as a steady rest.  This MCP is used for 
machines equipped with a hydraulic Tailstock. The tailstock will be in the advanced 
position until the Tailstock Retract MCP is activated. 

 
Process Time: Enter a time estimation during Tailstock advancement. Time can 
either be set to seconds or minutes – see Preferences on how to set time units. 

Tailstock Retract 
This Tailstock Retract Material Control process is used for machines equipped with a 
hydraulic tailstock. If selected, the tailstock retracts away from the face of the part. 
The tailstock will be in the retracted position until Tailstock Advance is activated. 

 
Process Time: Enter a time estimation during Tailstock retraction. Time can 
either be set to seconds or minutes – see Preferences on how to set time units. 
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Remove from Main Spindle 
The Remove from Main Spindle Material Control Process allows the user to insert 
code for removing a work piece from the main spindle using a part gripper mounted 
in the turret. 

 
Tool Post: Choose the turret at which the Part Ejector is mounted. 

Turret #1 – Defined as the upper turret for slant bed lathes or the front 
turret for flat bed lathes. 

Turret #2 - Defined as the lower turret for slant bed lathes or the rear 
turret for flat bed lathes. 

Turret #3 – Defined as the third turret for a three turret lathe – Please 
contact PartMaker Technical Support for more information on three turret 
capability. 

 Note: If using a lathe with only one turret, select Turret #1. 
Tool No.: Enter the tool station number at which the Part Ejector is mounted. 
The number must be a one or two digit integer. 
Tool Offset: Enter the offset number for the Part Ejector. The number must be 
a one or two digit integer. 
Grip Coord (Zg): Enter an incremental z distance (measured from the face of 
the work piece on the Main Spindle) to where the Part Ejector is to clamp on to 
the work piece. 

Process Time: Enter a time estimation from when the Part Ejector moves from 
its safe index position at the beginning of the process to when the Part Ejector 
moves back to its safe index position after it has released the work piece.  Time 
can either be set to seconds or minutes – see Preferences on how to set time 
units. 
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Remove from Sub Spindle 
The Remove from Sub Spindle Material Control Process allows the user to insert 
code for removing a work piece from the sub spindle using a part gripper mounted 
in the turret. 

 
Tool Post: Choose the turret at which the Part Ejector is mounted. 

Turret #1 – Defined as the upper turret for slant bed lathes or the front 
turret for flat bed lathes. 

Turret #2 - Defined as the lower turret for slant bed lathes or the rear 
turret for flat bed lathes. 

Turret #3 – Defined as the third turret for a three turret lathe – Please 
contact PartMaker Technical Support for more information on three turret 
capability. 

 Note: If using a lathe with only one turret, select Turret #1. 

Tool No.: Enter the tool station number at which the Part Ejector is mounted. 
The number must be a one or two digit integer. 
Tool Offset: Enter the offset number for the Part Ejector. The number must be 
a one or two digit integer. 
Grip Coord (Zg): Enter an incremental z distance (measured from the face of 
the work piece on the Sub Spindle) to where the Part Ejector is to clamp on to 
the work piece. 

Process Time: Enter a time estimation from when the Part Ejector moves from 
its safe index position at the beginning of the process to when the Part Ejector 
moves back to its safe index position after it has released the work piece. Time 
can either be set to seconds or minutes – see Preferences on how to set time 
units. 
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Pull with Sub Spindle 
The Pull with Sub Spindle Material Control Process allows the user to insert code for drawing bar 
stock out of the main spindle by clamping onto the part with the sub-spindle. 

 
Grip Coord (Zg): Enter an incremental z distance (measured from the face of 
the bar stock) to where the Sub Spindle is to clamp on to the bar.  
Pull Distance (Zp): Enter an incremental z distance from where the Sub 
Spindle has clamped onto the bar to where the stock is to be pulled. 

 Note: If pulling right before a cutoff/transfer process, the value entered 
should be the [part length + cutoff insert width + excess stock for facing 
on Sub Spindle (if necessary)] 

Process Time: Enter a time estimation from when the Sub Spindle moves from 
its home position at the beginning of the process to when the Sub Spindle 
moves back to its home position at the end of the process. Time can either be 
set to seconds or minutes – see Preferences on how to set time units. 
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Transfer from Main Spindle to Sub Spindle 
The Transfer from Main Spindle to Sub Spindle Material Control Process allows the 
user to insert code for transferring a work piece from the main to the sub spindle.  
This MCP should only be used when working with slug parts.   

 Note: Use the M1SP Mode for performing part transfers when working with 
Bar Stock. 

 
Grip Coord (Zg): Enter an incremental z distance (measured from the face of 
the work piece on the Main Spindle) to where the Sub Spindle is to clamp on to 
the work piece.  

Process Time: Enter a time estimation from when the Sub Spindle moves from 
its home position at the beginning of the process to when the Sub Spindle 
moves back to its home position at the end of the process. Time can either be 
set to seconds or minutes – see Preferences on how to set time units. 
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Chapter 3: TurnMill Tutorial Part: Single 
Spindle 
Introduction 

This tutorial will help you learn the steps to go through in using PartMaker to 
program TurnMill parts.  The emphasis in this tutorial will be on choosing the correct 
Machining Function when programming parts on a TurnMill center.  Once you have 
completed this chapter, you may choose to go on to Chapter 4, which contains 
another example focusing more on process synchronization and work on main and 
sub spindles. 

This tutorial is presented to cover both inch and metric data entry.  Inch units are 
presented as the primary unit to enter and metric values are presented in 
parentheses. 

How You Will Create the TurnMill Tutorial Part 
Here are the major steps you will follow to create the Swiss tutorial part: 

√ Start PartMaker 

√ View tool information for the part 

√ View cycle information for the part 

√ Select a material for the part 

√ Setup defaults for TurnMill 

√ Define the stock boundaries for the face window 

√ Open a new face window 

√ Create Geometry 

√ Perform Turning operations 

√ Perform Milling operations on the end of the part using C-axis 
indexing 

√ Perform polar milling operations 

√ Mill slots on the cylinder using C-axis indexing 

√ Perform continuous C-axis milling 

√ Generate the Process Table 

√ Simulate the cutting of the part 

√ Generate an NC Program 
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The print below shows the part to be programmed in this tutorial. 

Inch Units 
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Metric Units 
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Getting Started 
The first part of any programming exercise with PartMaker/TurnMill is to decide 
which machining functions will be used.  The machining functions used in this 
tutorial are as follows:  

Turning 
Use conventional turning tools and programming techniques to create the basic OD 
contour of the part.  

Mill End - Index 
Use a powered drill and the machine's C-axis indexing capabilities to drill the four 
holes arranged in the square pattern shown.  

Use a powered end mill with C-axis indexing to create the four radial slots.  

Mill End - Polar 
Create the rectangular pocket shown in the end of the stock. Programming of this 
pocket will use the simultaneous X and C-axis feed capabilities of the turn mill 
center.  

Mill Diameter - Index 
Use an X oriented, powered end mill, in conjunction with C-axis indexing to create 
the two longitudinal slots oriented at 90 and 270 degrees on the OD of the part.  

Mill Cylinder 
Use an X-axis oriented, powered end mill combined with X and C axis simultaneous 
feed to cut the rectangular groove on the OD of the cylinder.  

You will now look in detail at each of the steps necessary to program each of the 
components of the finished part.  The components of the completed tutorial TurnMill 
part can be found in your PartMaker TurnMill directory under the following file 
names: 

Completed Job File:  C:\PartMaker\PM-TM\Tm-demo.job 

Completed Tools Data Base: C:\PartMaker\PM-TM\Tm-demo.tdb 

Completed Cycles Data Base: C:\PartMaker\PM-TM\Tm-demo.cdb 

In the TurnMill tutorial, the default Tools Data Base and Cycles Data Base will be 
the same as Tm-demo.tdb and Tm-demo.cdb found in the PM-TM root directory.  
Although it is shown, you will not need to open a tools or cycles database at this 
point. 
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Starting PartMaker TurnMill 
All programming for TurnMill parts done with PartMaker should be done in the 
TurnMill application. To start the PartMaker TurnMill application: 

1 Double click on the TurnMill icon on your desktop or choose TurnMill from 
the PartMaker Group accessed through Programs under the Windows Start 
button. 

2 An icon containing the PartMaker logo will appear for a few moments. You 
will then see the Setup definition dialog box shown below. Click the 
<Close> button.   
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Opening the Tools file 
The tool library for the TurnMill tutorial has been created. 

1 Choose Open Tools File from the File menu. 
2 Open the Tm-demo.tdb from the C:\PartMaker\PM-TM directory as 

shown below: 

 
3 To view the tools, choose Tools from the ToolMinder menu.   

Look at the first two tools in the library.  Notice T001 below is an OD turning 
tool.  It is setup in the same manner of OD Turning as those used in 
conventional lathe operations. 
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Next, select T007.  Notice the Orientation field.  In PartMaker TurnMill, 
when defining milling tools, you must be careful to designate their 
orientation, either along the X-axis or Z-axis. 
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Opening the Cycles file 
The cycles library for the TurnMill tutorial has also been created.  

1 Choose Open Cycles File from the File menu. 
2 Open the Tm-demo.cdb from the C:\PartMaker\PM-TM directory as 

shown below: 

 
3 To view the cycles, choose Cycles from the ToolMinder menu. As with tool 

definition,  in PartMaker TurnMill, when defining holemaking cycles, you must 
be careful to designate their orientation, either along the X-axis or Z-axis.  
The cycle below will be used for machining holes on the face of the part.  You 
must also designate whether a cycle will be used in a Face Window of 
machining function Turn or one involving milling.  
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Selecting a Material for the Part 
The work piece in this exercise will be machined from Tool Steel, Wrought.  To 
load this material: 

1 Choose Open Material File from the File menu. 
2 Choose St_toolw.mdb as shown below and click <OK>. 

 

You have now loaded the tools, cycle, and material files that were previously 
developed for the TurnMill tutorial.  PartMaker has also provided a completed job 
file.  At this point you will not open the job file.  You will be guided through a step-
by-step process to develop a job file for the tutorial.  
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Setting Defaults 
Before beginning the TurnMill tutorial, you will have to set certain turning defaults 
to facilitate the programming process: 

1 To access the Defaults dialog, select Defaults from the Job Optimizer 
menu.   

2 After doing so you will see the dialog below: 

 
Click the <Turning> button to access the Turning defaults dialog. 

3 After doing so, you will see the dialog below: 

 

4 Make sure to check the Diameter Programming box. Checking this box will 
allow you to define all geometry and feature programming in terms of 
diameter, alleviating the need to divide measurements in half when 
programming or drawing on the X-axis in Turning Face Windows. 

5 Set a default Line Length for your programmed Leads. For the TurnMill 
tutorial this value should be 0.100 (2.5).   

 Note: Setting a generally applicable lead as a default will save you a great 
deal of time when programming because you will not have to reenter the 
same data from feature to feature. 

6 Set the Thread Height: There are two options available: 

%Pitch. The user will enter the height as a percent and resulting height 
will be Pitch * Thread Height / 100. 

Part Units. The user will enter the actual measured height of the thread 
in the current part units. 
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7 Access the Defaults dialog, select Defaults from the Job Optimizer menu.   

 
Click the <Milling> button to access the Milling defaults dialog. 

Set the Milling default as shown. 

 
Width of Cut. This parameter specifies whether the "Width of Cut" field in 
the Mill Profile Group Parameters Dialog will be defined in terms of 
percentage of tool diameter or an absolute value. 

Once you have looked at the tools and cycles databases, selected a material for the 
job, and setup the defaults for your job as shown above, you can move on to begin 
programming the TurnMill tutorial part. 
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Turning 
This section of the tutorial will instruct you in the steps necessary to perform the 
turning operations. 

Setting Up the Face Window 
In this section, you will set up the Face Window for the turning operations.  To do 
so: 

1 Choose Setup from the View menu to view the Setup dialog box.  In this 
dialog, you will define the machining function and  part boundaries and 
location of the stock with respect to the work holding.  

The default Setup screen will appear as shown below: 

 

2 Rename the current face window by clicking on Front in the List of Face 
Windows: field and type Turning in the Rename To: field and click the 
<Apply> button. 

3 Now enter the parameters listed below in the appropriate fields: 

Length (L) 3.0 (80.0) 

OD 3.125 (85.0) 

ID 0 (0) 

Excess Stock (E) 0.025 (0.5) 

Work Shift(l): 3.5 (100) 

Work Offset: G54  

Tool Change X (Xc) 3 (100) 

Tool Change Z (Zc) 2.0 (100) 
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When you are finished, your Setup dialog should appear as shown below:  

 

4 When you are satisfied that your Setup dialog appears as the one above, 
click the <Apply> button.  This will apply the parameters to the current face 
window.  Click the <Close> button to close the Setup dialog. 

5 In the CAM face window, choose Show Axes from the View menu.  This will 
display the horizontal and vertical axis lines which will help you create the 
geometry in the next section of the tutorial. 
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Creating Geometry in CAD Mode 
In this section, you will create the geometry for the turning operations. 

Since you should already be familiar with creating turning geometry from 
programming lathes with PartMaker, import the geometry for this operation from a 
.dxf file.  The .dxf file is called TM-TURN.DXF and is located in the \PM-TM 
directory.  

To import the geometry as follows:  

1 Choose Import DXF file from the File menu. 
2 Select Tm-turn.dxf from the C:\PartMaker\PM-TM directory as shown 

here:  

 
Your screen should now appear as shown below: 
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Defining the Profile for OD Turning 
The first profile to create will be the OD shape previously defined by the imported 
DXF geometry.  

1 Click the CAD/CAM switch to go to CAM mode. 

2 Choose the red square in the Color Bar   
3 Choose New Profile Group from the Part Features menu to display the 

Profile Parameters dialog. You should see the dialog below: 

 
4 From the Strategy menu, select Turning. 
5 From the Tool Location menu, select Out. 
6 From the Tool Orientation menu, select Right. 
7 Enter a Depth of Cut of 0.1 (2.5). 
8 In the Group Name: field enter OD TURN. 
9 Click the Select Tools button and allow PartMaker to select the appropriate 

tool.  

The completed Profile Group Parameters dialog should appear as shown 
below: 

 
When your dialog box appears as the one above, click the <Close> button. 
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10 Choose the Define Profile  icon and the End of an Element Snap Mode to 
select the profile to be cut as shown here, starting from the right and 
working toward the left, staring at point 1 and going to 5, click your cursor at 
the endpoint of each line, as shown below: 

 

 Before moving on, remember to save your work.  Do so by selecting Save 
from the File menu or using the shortcut key <Ctrl + S>.  Give your job file 
a name you will remember, such as TurnMill-Sample. 

 
Next, you will create the profile for the groove. 
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Defining the Profile for Grooving 
The next operation to be performed will create an OD groove.  

1 Click the blue square from the Color Bar. 
2 Choose New Profile Group from the Part Features menu.   
3 From the Strategy menu, select Grooving. 
4 From the Tool Location menu, select Out. 
5 Enter a Depth of Cut of 0.1 (2.5). 
6 In the Group Name: field enter OD GROOVE. 
7 Click the Select Tools button and allow PartMaker to select the appropriate 

tool. 

 

When you are satisfied that your dialog box appears as the one above, click 
the <Close> button. 

You can now assign the OD GROOVE operation to the geometry: 

1 With the OD GROOVE group symbol selected, select the Define Profile icon 
and the Closest Intersection Snap Mode. 

Note: To better focus on the grooving profile, choose Show Work Group 
Only from the View menu.  
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2 Click on the groove to be cut, starting at point one and finishing at point 4, 
then toward the left, as shown here:  

 

Before moving on, remember to save your work.  Do so by selecting Save from the 
File menu or using the shortcut key <Ctrl + S> or click on the save button. 
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Verifying the Tool Path 
You can now verify the tool paths of the operations you have just programmed.  To 
do so:  

1 Choose Show All from the View menu to show both part features on 
screen.   

2 Select Verify Work Group Tool Path from the Part Features menu to 
check your work.  

3 In the Verification Options dialog choose Do Not Show Tool. 
4 PartMaker should show you the following: 

 

5 When you are satisfied that your screen matches that of the picture above, 
return to the Part Features menu and select Hide Every Tool Path. 

You have finished the turning portion of this tutorial.  The next step is to program 
the end work using C-axis indexing programming.  
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Mill End, Index  
You will now program the four holes and four radial slots on the face of the part.  

Setting Up the Face Window 
In this section, you will set up the Face Window for to drill the holes and mill the 
slots on the end of the part.  To do so: 

1 Choose Setup from the View menu or use the Shortcut to the Setup icon 
located above the profile icons on the left-hand side of the Face Window.  

2 Click the <New> button to create a new face window. 
3 In the Rename to: dialog, enter the name Mill End Index.  
4 From the Machining Function drop down menu, select Mill End, Index.  

The size and origin location of the stock should remain the same as 
previously defined in the Turning Setup Window. When you are finished, the 
Setup dialog should appear as shown below:  

 

5 When you are satisfied that your Setup dialog appears as the one above, 
click the <Apply> button.  This will apply the parameters to the current 
Face Window.  Click the <Close> button to close the Setup dialog.  

 

6 Make sure you are in the correct face window by selecting the Mill End 
Index window under the Window menu as shown below: 

 
7 Choose Show Axes from the View menu.  
8 Choose Show Boundaries from the View menu.  

 Note: If the image in the face window appears distorted or oblong, choose 
Full View from the View menu to refresh the screen for it to appears as 
shown above. 

Notice in the lower left-hand corner of the window where the X-Y axis icon 
appears. This icon is used to remind you which axes are currently being used. 
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Creating Geometry in CAD Mode 
A DXF file of the necessary geometry has again been provided for this portion of the 
tutorial.  

The file to import is called Tm-face.dxf and is found in the C:\PartMaker\PM-TM 
directory. 

To import the geometry as follows:  

1 Choose Import DXF file from the File menu. 
2 Select Tm-face.dxf from the \PM-TM directory as shown here:  

 
Your display should look like this (the picture in the foreground below is 
shown in CAD mode:  

 

Before proceeding, click on the CAD/CAM switch and make it appear as a drill to 
make sure you are in CAM mode. 
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Programming Off-Center Holes 
The first step is to program the four drilled 1/8" (3.2mm) holes. PartMaker / 
TurnMill uses drilling cycles just like PartMaker / Mill and PartMaker / Turn.  

Using Milling Tools in PartMaker TurnMill 
The two tools that will be used to create the off-center holes are a center drill and a 
1/8" (3.2) drill. These tools have already been created and can be viewed by 
selecting Tools from the ToolMinder menu or clicking on the tool box icon.  Note 
the orientaton of these tools. 

Observe the two new tools as shown here: 

 
 

 

Once you have observed the tools as shown on the previous page, close the dialog 
box and from the ToolMinder menu, select Cycles. 

PartMaker holemaking cycles are also described in the same manner.  To see this, 
choose Cycles from the ToolMinder menu.  
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The cycle that will be used to drill the four holes has been defined like any other mill 
or lathe drilling cycle you may be used to.  Note however, that this cycle has been 
specified as a Mill cycle with component tools oriented along the Z-axis. Had the 
cycle been designated for use in turning Face Window (with the Turn radio button 
clicked) it would not have been necessary to designate orientation.  For Turn type 
holemaking cycles, tools may only move on center-line. 

 

Once again, this would be a good time to save your work.  Press <Ctrl+S>  to save 
your work up to this point. 

Once you feel comfortable with setting tools and cycles for TurnMill centers, proceed 
to program the four holes.  To do so: 

1 Click the red square from the Color Bar.  
2 Choose New Hole Group from the Part Features menu.   
3 Uncheck the Through Hole box 
4 In Major Cycle Operation select Drill (it may already be selected). 
5 Enter a diamter of 0.125 (3.2) 
6 Other parameters should be set as follows: 

Chamfer (c):   0 
Z-Surf (S):   0 
Z-Rapid (R):   0.05   (1.0) 
Z_Clear (Cl):   0.05   (1.0) 
Nominal Depth:  0.25 (10.00) 

PartMaker will calculate the necssary programmed depth from the desired 
nominal depth taking into account the diamter and point angle of the drill. 
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7 Press the Cycle button and PartMaker will select the appropriate cycle to 
create the desired hole.  The selected cycle should be Drill 1/8 (3.20). 

 
When you are satisfied your dialog appears as the one above, click the <Close> 
button. 

You are now ready program the holes.  To do so:  

1 From the left hand tool bar, select the Chain Circle icon.   
2 Click on any one of the four circles and PartMaker will select the other three. 

After doing so, your screen should appear as shown below:  

 

Before moving on, remember to save your work.  Do so by selecting Save from the 
File menu or using the shortcut key <Ctrl + S>.  



 

Copyright @2014 Delcam Ltd  User Guide 3-25  

 

Programming Radial Slots 
The next step of the programming process is to define the radial slots. 

1 Click the blue square from the Color Bar.   
2 Choose New Profile Group from the Part Features menu. 
3 In the Group Name box enter RADIAL SLOTS. 
4 From the Strategy drop down menu choose Contour Mill.  Choose a Tool 

Position of On. 
5 Other parameters should be set as follows: 

Z_Surf (S):   0 
Z_Depth (D):  0.375  (6.5) 
Z_Rapid (R):  0.05 (1.00) 
Z_Clear (C):   0.05 (1.00) 
Bottom Finish:  0 
Roughing:   0.125 (3.20) 

6 Click the Select Tools button and allow PartMaker to select the appropriate 
tool.  

 

When you are satisfied your dialog appears as the one above, click the <Close> 
button. 
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The next step is to actually define the path that the tool will be following. To do so: 

1 Choose the Linear Profile icon followed by the Point on an Circle snap 
mode.  

2 At the A <0> field located in the lower left hand corner of the screen, enter 
the number 0 at the prompt for an angle and press <Enter>.  

3 You will now be prompted to Select an Arc or Circle.  To do so,  click on 
point 1 as shown in the picture below: 

 

 Note: In the .dxf file imported above, a circle with a radius 0.2 inches 
larger than that of the radius to be milled has been included. (The inner 
circle with a radius of 1” represents the turned down radius from the 
previous face.)  In this example, in order to avoid having the tool begin 
cutting on the stock, you will use the outer circle to begin the tool’s feed 
away from the actual part. 

4 Next, select the Circle Center snap mode and click on the arc at the bottom 
of the slot at point 2 as shown below:  

 
Once you have done so choose the Selection Icon.  Select the slot you just 
defined by clicking on it with your cursor. 
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5 To mill the three remaining slots, with the first slot selected, choose Rotate 
from the Edit menu.  Complete the Rotate dialog as shown below: 

 
6 Having completed defining tool paths for the radial slots, select Verfiy Work 

Group Tool Path from the Part Features menu.  You should see the 
following: 

 

When you are satisified your screen appears as shown above select Hide Every 
Tool Path,  from the Part Features menu. 

Before moving on, remember to save your work.  Do so by selecting Save from the 
File menu or using the shortcut key <Ctrl + S>.  
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Polar Milling on the End 
The next feature to be programmed will be the rectangular pocket in the end of the 
part. The machining function used will be Mill End, Polar.  

Setting Up the Face Window 
In this section, you will set up the Face Window to drill the holes and mill the slots 
on the end of the part.  To do so: 

1 Choose Setup from the View menu or use the Shortcut to the Setup icon 
located above the profile icons on the left-hand side of the Face Window.  

2 Click the <New> button to create a new face window. 
3 In the Rename to: dialog, enter the name Mill End Polar.  
4 From the Machining Function drop down menu, select Mill End, Polar.  

The size and origin location of the stock should remain the same as 
previously defined in the Turning Setup Window. When you are finished, the 
Setup dialog should appear as shown below: 

 

5 When you are satisfied that your Setup dialog appears as the one above, 
click the <Apply> button.  This will apply the parameters to the current 
Face Window.  Click the <Close> button to close the Setup dialog.  

6 From the Window pull down menu, click on the menu item for the new 
window just created, as shown on the right:  
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Creating Geometry in CAD Mode 
Next, geometry to program is required.  The geometry previously imported into the 
Mill End, Index face contains what is needed, so again, import that geometry into 
PartMaker as you did in the previous section. 

The name of the file is \PM-TM\Tm-face.dxf 

Since you have already programmed the holes and radial slots, the only geometry 
to be concerned with is that of the diamond shaped pocket in the center of the face, 
as shown here.  

 

Programming the Pocket 
You will now program the pocket on the end of the part. 

1 Click the Green square from the Color Bar.    
2 Choose New Profile Group from the Part Features menu.   
3 In the Group Name box enter END POCKET. 
4 From the Strategy drop down menu choose Pocket Mill 
5 Other parameters should be set as follows: 

Z_Surf (S):   0 
Z_Depth (D):  0.125 (3.00) 
Z_Rapid (R):  0.05 (1.00) 
Z_Clear (C):   0.05 (1.00) 
Bottom Finish:  0 
Wall Finish:   0 
Diam (d):   0.25 (6.00) 
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6 Click the Select Tools button and allow PartMaker to select the appropriate 
tool. 

 
7 When you are satisfied that your dialog appears as the one above, click the 

<Close> button. 

The next step is to develop the tool path for the pocket: 

1 Select the Chain Geometry Icon.    
2 Select any portion of the diamond pocket as you would have with 

conventional milling, as shown here:  
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3 To check your work, select Verify Work Group Toolpath from the Part 
Features menu. Your completed pocket should appear as shown below: 

 

4 From Part Features choose Hide Every Tool Path when you are satisfied.  
 

Before moving on, remember to save your work.  Do so by selecting Save from the 
File menu or using the shortcut key <Ctrl + S>.  
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Mill Diameter, Index  
This section has been placed at the end of the tutorial because it incorporates 
drawing and programming concepts that are not encountered in basic milling or 
turning operations - the concept of ‘unwrapping’ a cylinder and programming it as a 
flat surface.  

To better understand the concept of unwrapping, imagine the outside diameter (OD) 
of the cylinder as a paper wrapper on a tin can.  Slit that wrapper and peel it off the 
can and lay it flat on the table.  This is how PartMaker handles cylindrical (OD) 
machining. Instead of using X and Y coordinates, programming is done with Z and 
C, where Z is the ‘length’ of the cylinder along the machine Z-axis and C represents 
the degrees of rotation, starting from 0 and progressing to 360 degrees.  

Setting Up the Face Window 
In this section, you will set up the Face Window to mill the slots on the OD of the 
part.  To do so:  

1 Choose Setup from the View menu or use the Shortcut to the Setup icon 
located above the profile icons on the left-hand side of the Face Window.  

2 Click the <New> button to create a new face window.  
3 From the Machining Function drop down menu, select Mill Diam, Index.  
4 In the Rename to dialog, enter the name Mill Diameter Index.  

The size and origin location of the stock should remain the same as 
previously defined in the Turning Setup Window. When you are finished, the 
Setup dialog should appear as shown below: 

 

5 When you are satisfied that your Setup dialog appears as the one above, 
click the <Apply> button.  This will apply the parameters to the current 
Face Window.  Click the <Close> button to close the Setup dialog. 
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6 Make sure you are in the correct face window by selecting the Mill Diameter 
Index window under the Window menu as shown below: 

 
7 Choose Show Axes from the View menu.    
8 Choose Show Boundaries from the View menu.   

Note how Z and C are used to define the position of the features (slots and 
holes) that can be programmed using this machining function.  

Creating Geometry in CAD Mode 
Since the concept of drawing and programming and an unwrapped cylinder is an 
entirely new concept, you will work through both the CAD creation and CAM 
programming of the desired features. 

At this point you can choose to either create the geometry or import a .DXF file. 

Method 1: Import a .DXF file 
A DXF file of the necessary geometry has again been provided for this portion of the 
tutorial.  

The file to import is called Tm-cyl.dxf and is found in the \ PM-TM directory.  If you choose to 
use this method: 

1 Import this file now by clicking <Import DXF File> from the File menu and 
choose  Tm-cyl.dxf. 

 
2 Please skip ahead to the section titled Programming Slots on the 

Cylinder. 

 Please note that the geometry you import will look slightly different from 
the one you will see in the Programming Slots on the Cylinder section 
because the imported geometry includes a square that will be used in the 
next section in which you will perform cylindrical milling.  You should 
ignore this square for the Programming Slots on the Cylinder section. 
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Method 2: Defining Geometry in PartMaker 
If you would like to create the geometry yourself, make sure you are in CAD mode.  
by clicking on the CAD/CAM switch in the lower left-hand corner of the screen, 
making sure it appears as a pencil. 

Look at the supplied drawing for the tutorial part on the second page of this 
chapter. Note that there are two longitudinal slots, oriented at 90 and 270 degrees.  
To draw the slots: 

1 Select the Circle with Known Radius and Center icon.  At the prompt in 
the lower left-hand corner of the screen, enter a value of 0.125 (3.00) for 
the radius and press <Enter>. 

2 Select the ZC Snap Mode icon from the snap mode icon bar.  Enter a value 
of -2.375 (-64.00) for Z.  Press the <Tab> key or use your cursor to 
advance to the <C> field.  Enter a value of 90 for C and press <Enter>. 

3 Create the second circle using the technique shown above, i.e. using the 
Circle with Known Radius and Center icon and ZC Snap Mode.  This 
time you need only change the C value from 90 to 270.  

You will now translate these two circles along the Z-axis.  To do so: 

1 Choose the Selection icon.  Holding down the <Shift> key, and click your 
cursor on each circle such that they are highlighted. 

2 With both circles selected (highlighted), choose Translate from the Edit > 
Transform menu.  Complete the dialog as shown below and click <OK>: Z 
1.0 (25) 

 
PartMaker will show the following: 
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You will now complete the slots. To do so:  

3 Select the Line Thru Two Points icon along with the Tangency snap mode.   
4 To close the slots click your mouse from point 1 to point 2, repeating this 

procedure from point 3 to 4, 5 to 6 and 7 to 8 as you move down the 
drawing. 

 
5 Once you have closed the slots, select the Remove icon to remove 

unnecessary geometry.   To do so, click you cursor on the on the interior of 
the slots. 

When you are finished, your slots should appear as shown here. 

 

When you are satisfied that the geometry has been correctly created and are 
confident in your understanding of the techniques used, switch to the CAM mode 
by clicking on the pencil icon in the lower left hand corner of the screen.   

If you are at all unsure that your geometry is correct, please go back to Method 
1 before proceeding to the next section. 

Before moving on, remember to save your work.  Do so by selecting Save from the 
File menu or using the shortcut key <Ctrl + S>. 



 

3-36 PartMaker  Copyright @2014 Delcam Ltd 

 

Programming Slots on the Cylinder  
The next operation is to program the tool motion to machine slots oriented along 
the Z-axis.  

1 Click the green square from the Color Bar.    
2 Choose New Profile Group from the Part Features menu.   
3 From the Strategy menu, select Contour Mill. 
4 In the Group Name box enter LONG SLOTS. 
5 Other parameters should be set as follows: 

X_Surf (S):   1.5 (40.00) 
X_Depth (D):  0.1 (3.00) 
X_Rapid (R):  0.05 (1.00) 
X_Clear (C):   0.05 (1.00) 
Bottom Finish:  0 
Diam (d):   0.25 (6.00) 

6 Click the Select Tools button and allow PartMaker to select the appropriate 
tool.  

 
Note: Notice that the (S) value is now shown as X_Surf and the (D) value is 
shown as X_Depth.  Note that the X_Surf value is shown as the radius of the 
part, not the diameter, and that the depth is programmed as a radius depth.  

7 When you are satisfied that your Setup dialog appears as the one above, 
click the <Close> button. 
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The next step is to develop the tool path for the slots.  To do so:  

1 Choose the Linear Profile icon and the Circle Center snap mode. 
2 Click you cursor on the inside of the arc starting at point 1 (as shown below) 

and then doing the same while moving from to point 2.  
3 With the Linear Profile icon and the Circle Center snap mode still selected 

do the same from point 3 to point 4.  Be sure to select both ends of one slot 
before moving to the next slot. 

 
4 When you are finished, and have selected Verify Workgroup Toolpath 

from the Job Optimizer Menu, your screen should appear as shown below: 

 

5 Select Hide Every Tool Path from the Part Features menu.  

 

Before moving on, remember to save your work.  Do so by selecting Save from the 
File menu or using the shortcut key <Ctrl + S>. 
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Cylindrical Milling  
A TurnMill center capable of cutting cylindrical milling geometry has the ability to 
simultaneously feed in X, Z and C-axes, often referred to as continuous C-Axis 
capability.  Looking at the tutorial drawing, you can see that a rectangular groove is 
to be machined on the OD. 

As you may have noticed in the previous example, if you are programming along 
the center line of the tool, it is not actually necessary to draw the groove - only the 
center line for the tool to follow. We will use this technique to simplify the geometry 
creation portion of this example.  

Setting Up the Face Window 
In this section, you will set up the Face Window for cylindrical milling. To do so: 

1 Choose Setup from the View menu to view the Setup dialog box or use the 
Shortcut to the Setup icon located above the profile icons on the left-hand 
side of the Face Window. 

2 Click the <New> button to create a new face window. 
3 In the Rename To: field, enter Mill Cylinder. 
4 From the Machining Function drop down menu select Mill Cylinder. 
5 When you are finished, your Setup dialog should appear as shown below: 

 

Once again, notice how PartMaker will be ‘unwrapping’ the cylindrical geometry 
and creating a flat layout, with coordinates of Z in linear units and C in degrees 
of rotation. 

6 When you are satisfied that your Setup dialog appears as the one above, 
click the <Apply> button.  This will apply the parameters to the current face 
window.  Click the <Close> button to close the Setup dialog. 
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7 To switch to the Mill Cylinder Face Window, choose Mill Cylinder from the 
Window menu. 

 
8 Choose Show Axes from the View menu.  This will display the horizontal 

and vertical axes lines which will help you create the geometry in the next 
section of the tutorial. 

9 Choose Show Boundaries from the View menu. 

Creating Geometry in CAD Mode 
Cylindrical milling geometry is created exactly like Mill Diameter, Index geometry. 
The difference is in the capabilities of the TMC, not PartMaker.  

At this point you can choose to either create the geometry or import a .DXF file. 

Method 1: Import a .DXF file 
A DXF file of the necessary geometry has again been provided for this portion of the 
tutorial.  To import this .DXF file: 

1 Choose Import DXF File from the File menu.   
2 Select tm-cyl.dxf from from the pm-tm\tutorial subdirectory. 

If you choose to use this method, import this file now and please skip ahead 
to the section titled Programming Cylindrical Milling.   

 

 Note:  The geometry you import will look slightly different from the one 
you will see in the Programming Cylindrical Milling section.  This is 
because the imported geometry includes the slots that were used in the 
previous section in which you performed only index milling on the 
cylinder.  You should ignore these slots for the Programming Mill 
Cylinder section. 
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Method 2: Defining Geometry in PartMaker 
Here you will create the CAD geometry for the rectangle:  

1 Start by selecting the CAD/CAM switch in the lower left hand corner of the 
screen and making sure it is a pencil.    

2 Click on the Connected Lines icon.  After doing so, select the ZC snap 
mode from the Snap Mode icon bar at the top of the Face Window. 

3 After selecting the ZC Snap Mode two data entry fields will appear in the 
lower left hand corner of the Face Window. 

Note:  Remember, when plotting coordinates in PartMaker CAD, you do not 
need to reenter a coordinate if it is the same as the last one entered.  You 
can simply leave the space blank and PartMaker will default to the last 
coordinate entered.  You can move between data entry fields by pressing the 
<Tab> button or using your mouse. 

Now enter the ZC coordinates as shown below, pressing <Enter> after each: 

Z Coordinate C Angle 

-2.4375 (-65.30) 160 

Default 220 

-1.3125 (-37.30) default 

Default 160 

-2.4375 (-65.30) default 

After entering these coordinates, you should have a drawing which appears as 
shown below: 

 
If you are not comfortable that your geometry resembles the one above, please 
revert to Method 1 of this section and import the appropriate DXF file before 
proceeding with programming this geometry. 
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Programming Cylindrical Milling 
The next operation is to program the tool motion to machine the rectangle oriented 
along the Z-axis.  

1 Click the CAD/CAM switch such that it appears as a drill bit. This will put you 
back into the CAM mode. 

2 Select New Profile Group from the Part Features menu.   
3 In the Group Name box type SQUARE GRV. 
4 Other parameters should be set as follows: 

X_Surf (S):   1.5 (40.00) 
X_Depth (D):  0.12 (3.0) 
X_Rapid (R):  0.05 (1.0) 
X_Clear (C):   0.05 (1.0) 
Bottom Finish:  0 
Diam (d):   0.125 (4.0) 

5 Click on the <Select Tools> button.  An end mill icon will appear to the 
right of the Tool ID box.  The completed Profile Group Parameters dialog 
should appear as shown below: 

 
6 When you are satisfied that your dialog appears as the one above, click the 

<Close> button. 
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The next step is to develop the tool path for the cylindrical milling operation: 

1 Use the Chain Geometry icon and click on the groove to be machined. 
2 Click the rectangular geometry with your cursor to assign the part feature to 

your geometry: 
3 Check your selection using Verify Workgroup Toolpath found in the Part 

Features pull down menu.  

Your PartMaker screen should appear as shown below:  

 
4 Select Hide Every Tool Path from the Part Features menu.  

 

Before moving on, remember to save your work.  Do so by selecting Save from the 
File menu or using the shortcut key <Ctrl + S>. 
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Creating an NC Program 
The programming portion of the tutorial is now complete.  At this point, all tool and 
machine motions necessary to create this part have been created.  

The remaining steps are:  

 Choose the control  

 Create the Process Table  

 Generate the NC code  

Generating a Process Table 
The first step in generating an NC program is creating a Process Table.  A Process 
Table shows you all of the machining processes for a part.  When PartMaker 
generates a process table, all cutting conditions such as feed rate and spindle speed 
(RPM) are calculated automatically based on the tools and material information 
previously entered. 

1 Choose Generate Process Table from the Job Optimizer menu. You will 
be promtped with Process Table Options dialog. 

 
Retain Process Parameters Modifications. Checking this box will retain 
previous modifications to the process table. Since this is your first time 
Generating the Process Table it will have no effect.  

Move Cut-Off Process to End of Process Table. Checking this box will 
automatically place your cut-off process at the end of the Process Table. 

Eject Part After Last Sub-Spindle Process. Checking this box will 
automatically place your eject after the last Sub-Spindle process. 

2 Click on <OK> to display the Process Table shown below: 
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Selecting a Post Processor 
Having generated a Process Table you must now select a Post Configuration File 
before you can output an NC progrm.  This post configuration file is stored in the 
Pm-tm\Samples\8_axis-demo directory.  If you do not have any other post 
configuration files loaded in this directory the Tm-demo.pst will be loaded 
automatically.  If you do have other post configuration files in this directory: 

1 Choose Post Config File = ? from the Job Optimizer menu. 
2 Select the TM_demo.pst post as shown below.  PartMaker for TurnMill 

comes standard with a post configuration for a Fanuc 18t control which 
supports, live tooling, c-axis and subspindle operations. 

 
3 Click <OK> to continue. 

Simulating the Part 
Once you are satisified with the order of operations on the Process Table, you can 
simulate your part.  This can be done by clicking the Simulation button in the 
lower left hand corner of the Process Table. 

 
Once in the Simulation window, choose Simulation from the Simulation menu or 
just press the <Space Bar>.  Your simulated part should appear as shown below: 

 
You can learn more about using PartMaker’s simulation module in Chapter 5. 
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Generating an NC Program 
Having selected a Post Configuration file, you are now ready to generate an NC 
Program.   

1 Choose Generate NC Program from the Job Optimizer menu.  Set the 
Post Options dialog as shown below.  Make sure to uncheck the Stop To 
Include User Input box.  More information about this dialog is contained in 
the machine specific addendum supplied with your PartMaker software. 

 
2 Click <OK> in the Post Options Dialog to proceed to the Save NC 

Program dialog.  In this dialog, enter a name for your program. 

 
3 Click <Save> to generate the NC program. 
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After you save to generate the NC Program this information will appear as 
shown below: 

 



 

Copyright @2014 Delcam Ltd  User Guide 4-1  

 

Chapter 4: TurnMill Tutorial Part: 8-Axis 
Twin Spindle Twin Turret 
Introduction 

This tutorial is designed to help you learn the steps to go through in using 
PartMaker TurnMill to program TurnMill lathe parts. The illustration on the 
following page represents a typical part that would be cut on a CNC TurnMill. 

This tutorial is presented to cover both inch and metric data entry.  Inch units are 
presented as the primary unit to enter and metric values are presented in 
parentheses. 

How you will create the advanced TurnMill tutorial part 
Here are the major steps you will follow to create the tutorial part: 

√ Start PartMaker 

√ View tool information for the part 

√ View cycle information for the part 

√ Select a material for the part 

√ Define the stock boundaries for the Face Window 

√ Open a new Face Window 

√ Create geometry 

√ Perform turning operations on the main spindle 

√ Perform turning operation on the sub-spindle 

√ Mill a hex on the sub-spindle 

√ Drill and tap on the sub-spindle 

√ Generate a Process Table 

√ Synchronize machining operations on the main and sub-spindles 

√ Simulate the cutting of the part 

√ Generate an NC Program 
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The print below shows the part to be programmed in this tutorial. 

Inch Units 

 

 



 

Copyright @2014 Delcam Ltd  User Guide 4-3  

 

Metric Units 

 

 
When you complete this tutorial, you will have a part that looks like the picture 
below. 
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Getting Started 
The first part of any multi-axis turning programming exercise with PartMaker 
TurnMill is to decide which machining functions will be used for each part face to be 
programmed.  

The machining functions used in this tutorial are as follows:  

Turn – Main Spindle 
Use turning tools to perform a variety of turning operations on the main spindle 
including facing, turning, grooving, and threading. 

Turn – Sub-Spindle 
Use turning tools to perform a variety of turning operations on the sub-spindle 
including facing and turning. 

Mill Polygon – Sub-Spindle 
Use an end mill to create a set of hexagonal flats 

Mill End Index – Sub-Spindle 
Use an end mill to create a set of hexagonal flats. 

Programming TurnMill lathe operations with PartMaker is performed in a unique 
manner. No matter what the orientation of the part in the main spindle or sub 
spindle, PartMaker programs all turning operations as if being machined in a 
conventional lathe, i.e. all programming is carried out from right to left. 

Note: This tutorial covers both general PartMaker programming techniques as well 
as those unique to TurnMill.  For more information on using PartMaker to program 
CNC Milling, 2-axis turning and Swiss-type applications, please see the manuals 
which correspond to those applications. 

Now you will look in detail at the steps necessary to program each of the 
components of the finished part. The components of the completed TurnMill tutorial 
part can be found in the following directories: 

Completed Job File: 

c:\partmaker\pm-tm\samples\8-axis_demo\Inch-8-axis_demo\8-axis_demo.job 

Completed Tools File: 

c:\partmaker\pm-tm\samples\8-axis_demo\Inch-8-axis_demo\8-axis_demo.tdb 

Completed Cycles File: 

c:\partmaker\pm-tm\samples\8-axis_demo\Inch-8-axis_demo\8-axis_demo.cdb 
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Starting PartMaker TurnMill 
All programming for TurnMill parts done with PartMaker should be done in the 
TurnMill Application. To start the PartMaker TurnMill application: 

1 Double click on the TurnMill icon on your desktop or choose TurnMill from 
the PartMaker Group accessed through Programs under the Windows Start 
button. 

2 An icon containing the PartMaker logo will appear for a few moments. You 
will then see the Setup definition dialog box shown below. Click the 
<Close> button. 
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Opening Files 
The tool library for the TurnMill tutorial has already been created.  

1 Open the Tools file by choosing Open Tools File from the File menu and 
choosing the 8-axis_demo.tdb from the c:\partmaker\pm-tm\samples\ 
8-axis_demo\ Inch-8-axis_demo directory. 

 
2 Click the 8-axis_demo.tdb file as shown above and press <Enter>. 

The cycles library for the TurnMill tutorial has already been created.  

3 Open the Cycles file by choosing Open Cycles File from the File menu and 
choosing the 8-axis_demo.cdb from the c:\partmaker\pm-tm\samples\ 
8-axis_demo\ Inch-8-axis_demo directory. 

 
4 Click the 8-axis_demo.cdb file as shown above and press <Enter>. 

The work piece in this exercise will be machined from Free Machining Stainless 
Steel, Wrought. To load this material: 
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5 Open the Material file by choosing Open Material File from the File menu. 

 
6 Choose st_fmstw.mdb as shown below and press <Enter>. 

You have now loaded the tools, cycle, and material files that were previously 
developed for the TurnMill tutorial. PartMaker has also provided a completed job 
file. At this point, do not open the job file. You will be guided through a step-by-step 
process to develop a job file for the tutorial.  
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Turning on the Main Spindle 
This section of the tutorial will instruct you in the steps necessary to perform the 
turning operations on the main spindle. 

Setting Up the Face Window 
In this section, you will set up the Face Window for the turning operations on the 
main spindle. To do so: 

1 Choose Setup from the View menu to view the Setup dialog box (or click 
the Shortcut to the Setup icon in the upper right hand corner of the 
screen).  The following default dialog will display: 

 
In this dialog, you will define the machining methods, part boundaries, and 
location of the stock with respect to the programming origin.  

2 Make sure Stock is to Bar 

3 Rename the current Face Window by clicking on Front in the List of Face 
Windows: field and type Turn– Main in the Rename To: field and click the 
<Apply> button. 

4 Now enter the parameters listed below in the appropriate fields: 

Length (L) 4.0 (102.0)

OD 3.0 (75.0) 

ID 0 (0) 

Excess Stock (E) 0.005 (0.5) 

Work Shift(l): 4.5 (125) 

Work Offset: G54  

Tool Change X (Xc) 10.0 (100) 

Tool Change Z (Zc) 10.0 (100) 
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Your completed Setup dialog should appear as shown below: 

 

 Note:  In the dialog above, the Main Spindle radio button is checked.  
This designates that this operation will be programmed on the main 
spindle of the machine. 

5 When you are satisfied that your Setup dialog appears as the one above, 
click the <Apply> button. This will apply the parameters to the current Face 
Window.  Click the <Close> button to close the Setup dialog.  

6 In the CAM Face Window, choose Show Axes  from the View menu.  This 
will display the horizontal and vertical axis lines which will help you create 
the geometry in the next section of the tutorial.  

 Tip:  If at any time the menu commands become “grayed out” and 
unusable, this indicates that the Face Window you are working in has 
become inactive. To reactivate the window, click anywhere within your 
Face Window. 



 

4-10 PartMaker  Copyright @2014 Delcam Ltd 

 

Creating Geometry in CAD Mode 
In this section, you will create the geometry for the turning operations to be 
performed on the main spindle.  You will either create the geometry for the turning 
operations to be performed on the main spindle or import a DXF file.  Here, you will 
create the part geometry in PartMaker CAD: 

To create the geometry in PartMaker CAD: 

1 Click on the CAD/CAM switch in the lower left-hand corner of the window. 
The icon will change its appearance from a tool bit to a pencil.    

2 Select the Connected Lines Icon from the drawing icons on left side of the 
Face Window. Here, you will draw the part in the print on the second page 
of this chapter by plotting ZX coordinates, using the ZX Snap Mode from 
the Snap Modes icon bar at the top of the screen. 

After selecting the ZX Snap Mode two data entry fields will appear in the 
lower left hand corner of the Face Window. 

 Note:  When plotting coordinates in PartMaker CAD, you do not need to 
reenter a coordinate if it is the same as the last one entered.  You can 
simply leave the space blank and PartMaker will default to the last 
coordinate entered.  You can move between data entry fields by pressing 
the <Tab> button or using your mouse. 

Now enter the ZX coordinates as shown below, pressing <Enter> after 
each: 

0, 0 

<default>, 1 (24) 

-3.187 (-82), <default> 

<default>, 0.843 (22) 

-3.438 (-90), <default> 

<default>, 2.875 (72) 

-4 (-102), <default> 

<default>, 0 

1.1 (28.0), <default> 

<default>, 0.146 (3.75) 

1.2 (30.5), <default> 

After entering these coordinates, you should have a drawing which appears 
as the profile below: 
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3 You will now place a chamfer on the front of the part.  To do so, select the 
Chamfer icon.  A field will then open up at the bottom of the window 
prompting you to enter the size of the chamfer.  Enter a value of 0.04 (1.0) 
and press <Enter>.  

To place the chamfer, position your cursor on the inside of the intersection of 
the lines at the front of the part as shown below: 

 
With your cursor in position, click the left mouse button and a chamfer will 
inserted as shown below: 

 
4 You will now place a second chamfer on the part, at a distance 3.187 (82) 

from the front of the part.  This time, however, no chamfer dimension is 
given on the print, but you do want to create 45 degree chamfer from the 
0.843 (22) diameter to the major thread diameter.   

Click on Line on an Angle Icon and select End of an Element Snap Mode 
icon.  Drag your cursor into place as shown below and click the left mouse 
button. 

 
You will now be prompted to enter an angle for this line.  At the prompt 
enter a value of 45 and press <Enter>. 

Move your cursor so the arrow is on the line as shown below and click the 
left mouse button. 
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Having done so, you will now have a drawing which appears as shown below. 

 
Now select the Remove icon and click the scissors on lines 1 and 2 in the 
picture below. 

 
After having done so, your geometry will appear as shown below: 

 
5 Next you will create the .08 (2.0) radius at the back of the relief groove.  To 

do so, choose the Fillet Icon. 

You will now be prompted to enter the arc radius.  At the prompt enter a 
value of .08(2.0) press <Enter>. 

Move your cursor so the arrow is at the inside of the intersection of the two 
lines at the back of the relief groove. 

 
Having done so, you will now have a drawing which appears as shown below. 
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6 Next, choose the Line Parallel horizontal axis icon. Enter a value of 2.5 
(1.5) and press <Enter>. A line as shown below will be created. 

 
7 Choose Line on an Angle Icon . Choose the Closest Intersection Snap 

Mode  icon and enter a value of 105 in the angle field. Select the point as 
shown in figure below and then click on the horizontal line above it as shown. 

 
The geometry should appear as shown below: 

 



 

4-14 PartMaker  Copyright @2014 Delcam Ltd 

 

8 Choose Line on an Angle Icon. Choose the Closest Intersection Snap 
Mode icon and enter a value of 75 in the angle field. Select the point as 
shown in figure below and then click on the horizontal line above it as shown.  

 
9 Now trim the irrelevant geometry using the scissors icon and the final 

geometry should look as below 

 
10 Once you have created the two chamfers, choose the Selection Icon and 

select the geometry you have created by choosing Select All from the Edit 
menu. 

 Note: In PartMaker selection always preceeds action.  Before you can 
manipulate an entity, be it a piece of geometry or a part feature, you 
must select it.  Selection must always be carried out in selection mode.  
To be in selection mode, you must have the Selection icon chosen. 
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11 You will now mirror the selected geometry by choosing Mirror from the Edit 
menu.  Complete the Mirror dialog as shown below: 

 
When you have completed the dialog as shown above, click the <Mirror> 
button and close the dialog.  Click anywhere to deselect the geometry. The 
completed drawing should appear as below: 
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Defining the Profile for Face Turning 
The first turning operation to be performed on the Main Spindle is to face the stock. 

1 Click the CAD/CAM switch to go to CAM mode.   

2 Click anywhere in the Main-Turn Face Window to make it active. 

3 Choose the red square in the Color Bar.  

4 Choose New Profile Group from the Part Features menu to display the 
Profile Group Parameters dialog, or select the button from the tool bar. 

5 Choose Contouring from the Strategy drop down menu. 

6 Choose Face from Tool Location. 

7 Deselect Roughing which will select Finishing automatically 

8 Click the Select Tools Button.  You will be prompted with a choice of three 
available turning tools.  Choose T002 and click <OK>. 

 
9 In Group Name type Face.  Your completed Profile Group Parameters 

dialog should appear as shown below: 

 
At this point, do not close the dialog box shown above. Proceed for instructions on 
how to complete setting up this profile group. 
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When programming parts in PartMaker, you have the ability to control how far and 
at what angle a tool feeds on and off of a part. These values are controlled via 
Leads. The Lead In is the distance from the part the tool will begin feeding before 
cutting. Likewise, the Lead Out is the distance that the tool will feed away from the 
material before tool change or rapidding to its next position. 

 Note:  If you are using the same Leads In and Leads Out in most of your 
operations, you can set them as default values in the Defaults for Turning 
dialog accessed under the Job Optimizer menu.  Setting your own default 
Leads In and Out values will save time when programming in PartMaker. 

1 The Leads In and Out dialog box combine the settings for controlling the 
movement of the tool as it approaches (Leads In) and leaves (Leads Out) the 
stock. 

2 Set the Leads In values for the operation.  Now set the Leads Out values 
for the operation. 

3 You can also set the values from one Leads to the other by selecting the 
Copy Leads button.  

 
Press <OK> to return to the Profile Group Parameters dialog. 

 Note:  The Lead angle is always set normal to the path of the tool by 
PartMaker.  Above, setting the Leads Out angle will allow the tool to 
retract in a manner perpendicular to the part.  For example, if turning a 
45 degree chamfer, a 0 degree lead angle would allow the tool to exit the 
stock on a 45 degree angle. 

Click the <Close> button to close the Profile Group Parameters dialog 
box. 
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Click the <Close> button to close the Profile Group Parameters dialog 
box. When you close the dialog box it will automatically create a tool path on 
the face of the part. 

 
Before moving on, save your work! Do so by selecting Save from the File menu or 
using the shortcut key <Ctrl + S>. Give your job file a name you will remember. 

Tool Path Verification 
Once a tool path is defined, you can verify its shape to gauge the accuracy of the 
cut you have defined. To do so:  

1 Select Verify Work Group Tool Path from the Part Features menu or the 
button: 

You will be prompted with the Tool Verifications Options dialog as shown 
below: 

 
2 Check the Solid or Hollow radio button and enter a delay between 0 and 9, 

zero being the fastest and nine the slowest, relative to the processor speed 
of your computer.  

3 Click <OK>. You should see your tool path verified. 

4 Once you are satisfied with your tool path, choose Hide Work Group Tool 
Path from the Part Features menu, or select the button. 

 Note: Whenever you verify a tool path (or every tool path) you MUST 
choose Hide Work Group Tool Path before moving on and continuing to 
work in PartMaker.  Not doing so could hamper performance of your 
system.  In order to stop verification before it is complete, hit the <Esc> 
key. 
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Defining the Profile for OD Turning 
The next operation to be performed will be OD turning, starting from the bottom of 
the chamfer on the face of the part. 

1 Choose the yellow square in the Color Bar.  

2 Choose New Profile Group from the Part Features menu to display the 
Profile Group Parameters dialog, or select the icon. 

3 From the Strategy menu, select Turning. 

4 From the Tool Location menu, select Out. 

5 From the Tool Orientation menu, select Right. 

6 Enter a Depth of Cut of 0.2 (2.4). 

7 In the Group Name: field enter OD Turn. 

8 Check the box labeled Finishing Tool ID to indicate that you want to 
perform a finishing opertation. 

9 Click the Select Tools button.  Click the <OK> button to choose T002 as 
the roughing tool. 

 
10 Upon doing so, you will be immediately be prompted with the same dialog, 

prompting you to select a finishing tool. Click on T003 from the list and click 
<OK>. 
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The completed Profile Group Parameters dialog should appear as shown 
below. 

 
Now that you have defined the cycle to be used, you must tell PartMaker the 
location of the tool path. Click <CLOSE> 

1 From the left-hand side of the screen select the Define Profile icon.  

2 From the top of the screen, select the End of an Element snap mode icon. 
To define the OD Turn path, click your left mouse on positions to match the 
diagram below. 
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3 To finish the tool path, use ZX Coordinates Snap Mode and enter a value 
of 3.0 (76) in X field.  The completed tool path should appear as shown 
below: 

 
4 Click the Selection icon to bring yourself to a home or neutral position 

5 Select Verify Work Group Tool Path from the Part Features menu to 
check your work., or select the tool-bar icon.  

6 Once you are satisfied with your tool path, choose Hide Work Group Tool 
Path from the Part Features menu, or the tool-bar icon. 

Defining the Profile for OD Grooving 
The next operation to be performed will be OD grooving. 

1 Choose the red square in the Color Bar.  

2 Choose New Profile Group from the Part Features menu to display the 
Profile Group Parameters dialog or select the icon. 

3 Change your Strategy to Grooving. 

4 Choose a Tool Location of Out. 

5 Look at the graphic. Notice that there are two options for Profile Shape: 
Rectangular and General. Rectangular would be used where the groove is 
a rectangular shape. General would be used if there were a contour your 
grooving tool would have to follow.  It would also be used if you wanted to 
take a rough and finish pass. Take a minute and look closely at both graphics 
and the parameters for each. When you are finished, leave this setting at 
General. 
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Click the Select Tools button.  You will be prompted with a choice of two 
tools. Choose T005 and click <OK>. 

 
6 Rename the group to Thread Relief.  Your completed profile group 

parameters dialog should now appear as shown below: 

 
7 Click <CLOSE> 
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Now that you have defined the cycle to be used, you must tell PartMaker the 
location of the tool path.  

1 From the left-hand side of the screen select the Define Profile icon.   

2 From the top of the screen, select the End of an Element snap mode icon. 
To define the Groove path, click your left mouse on positions to match the 
diagram below. 

 
The completed profile should appear as shown below: 

 
3 Click the Selection icon to bring yourself to a home or neutral position 

4 To check your work, select Verify Work Group Tool Path from the Part 
Features menu or select the icon. 

5 Once you are satisfied with your tool path, choose Hide Work Group Tool 
Path from the Part Features menu.  
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Defining the Profile for OD Threading 
In this operation you will create the OD thread on the main spindle. In PartMaker, 
threading operations are always programmed based on the crest diameter of the 
thread (i.e. major diameter on the OD, minor diameter on the ID). 

1 Choose green from the color bar.  

2 Select New Profile Group from the Part Features menu.  

3 From the Strategy menu, select Threading. 

4 Look at the graphic. Notice that there are two Toolpath Options: No 
Chamfer and Chamfer. No Chamfer would be used where there is a relief 
groove at the end of the thread. Chamfer would be used if there were no 
relief groove at the end of the thread. Take a minute and look closely at both 
graphics and the parameters for each. When you are finished, leave this 
setting at No Chamfer. 

5 Enter a Pitch of 1/13 (1.5).  You can enter the fractional value for the pitch 
in the field 

6 Click the Select Tools button and allow PartMaker to select the appropriate 
tool. 

7 In the Group Name: field enter Thread. 

 
8 Close the Profile Group Parameters dialog for Threading by clicking the 

<Close> button. 
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Before you assign the Threading cycle to the geometry, it is necessary to extend 
the line along which you will be threading into the middle of the relief groove.  This 
is a common technique when defining threading operations in PartMaker. To do so: 

1 Click on the CAD/CAM switch to enter the CAD mode. 

2 Choose the Trim and Extend icon on the left hand side of the screen. Click 
toward the left side of the 1 inch diameter along which you will be threading 
by positioning your cursor and clicking as shown below:  

 
3 Choose the Middle of an Element snap mode icon on the left hand side of 

the screen. Click toward the left side of the 1 inch diameter along which you 
will be threading and drag your cursor to the left and clicking near the middle 
of the bottom of the groove as shown below: 
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The completed geometry should appear as shown below: 

 
You can now assign the Threading cycle to the geometry you created. 

4 Return to CAM mode.  

5 From the View menu, choose Show Work Group Only to turn off all the 
other tool paths other than the one you are about to create. 

6 From the left-hand side of the screen select the Define Profile icon. 

7 From the top of the screen, select the End of an Element snap mode icon. 
Click on points 1 and 2 a shown below. 

 
8 Click the Selection icon to bring yourself to a home or neutral position 

9 Select Verify Work Group Tool Path from the Part Features menu or the 
icon to check your work. 

10 Once you are satisfied with your tool path, choose Hide Work Group Tool 
Path from the Part Features menu or use the icon. 

Note: To better focus on the Work Group you are currently working with, 
you can select Show Work Group Only from the View menu or the icon. 

This has been done above to isolate the area along which you will thread.  
You can see all the work groups again by selecting Show All or the icon:  

This programming methodology will be employed throughout this tutorial. 
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Defining the Profile for Cut-off 
The next operation to be performed will be the cut-off. 

1 Choose the cyan square in the Color Bar.    

2 Choose New Profile Group from the Part Features menu to display the 
Profile Group Parameters dialog, or select the icon. 

3 Change your Strategy to Cut-off. 

4 Click the Select Tools button.  You will be prompted with a choice of two 
tools. Choose the second tool on the list as shown below and click <OK> 

 
5 Look at the graphic. Notice that there are two options: Insert Chamfer and 

Insert Fillet. Insert Chamfer would be used when you would like to create 
a chamfer on the end of the part. Insert Fillet would be used when you 
would like to create a radius on the end of the part. Take a minute and look 
closely at both graphics and the parameters for each. When you are finished, 
leave this setting at Chamfer. 

6 In the Group Name: field enter Cutoff.  

7 To the Cut-Off Distance (D): field add 4.01 (.25) 

8 Your  Profile Group Parameters dialog should now appear as shown 
below: 
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Click the <Close> button to close the Profile Group Parameters dialog 
box. When you close the dialog box it will automatically create a tool path on 
the end of the part. Your tool path should look like the one in the diagram 
below. 

 
You have now completed the turning work on the main spindle. Now that all the 
programming in the Main Spindle - Turn Face Window is complete, take a 
moment to see exactly what you have programmed. 

1 Choose Verify Every Tool Path from the Part Features menu or the 
button  

In the Verification Options dialog, choose Hollow or Solid as shown in the 
box below and click <OK>: 
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PartMaker will show you exactly what you have programmed in a graphical 
manner as shown below: 

 
2 When you are satisfied your screen appears as the one above, choose Hide 

Every Tool Path from the Part Features menu, or use the button:  

You have now completed the turning operations on the main spindle for the TurnMill 
tutorial part. Before moving on, remember to save your work! Do so by selecting 
Save from the File menu or by using the shortcut key <Ctrl + S>. 
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Turning on the Sub-Spindle 
This section of the tutorial will instruct you in the steps necessary to perform a 
variety of turning operations on the sub-spindle. 

Setting Up the Face Window 
In this section, you will set up the Face Window needed to perform turning 
operations on the sub-spindle. To do so: 

1 Choose Setup from the View menu to view the Setup dialog box (or click 
the Shortcut to the Setup icon in the upper right hand corner of the 
screen). 

2 Click the <New> button to create a new face Window.  Because you will be 
doing turning in this window, the Machining Function will remain of type 
Turn. 

3 In the Rename to: dialog, enter the name Turn-Sub 

4 Check the Sub Spindle radio button to indicate that machining in this 
window will be carried out on the sub-spindle 

5 When you are satisfied that your Setup dialog appears as the one below 
click the <Apply> button. This will apply the parameters to the current Face 
Window.  Click the <Close> button to close the Setup dialog. 

The size and origin location of the stock should remain the same as 
previously defined in the Turning Setup Window. When you are finished, the 
Setup dialog should appear as shown below: 

 
To switch to the Sub Spindle - Turn Window, choose Turn-Sub from the 
Window menu. 
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Creating Geometry in the CAD Mode 
To quickly define geometry for the turning operations to be performed on the sub 
spindle, you can use the geometry already created in the Main Turn window. 
Remember, in PartMaker, all programming is done as if being performed on a 
conventional lathe, i.e. all programming is carried out from right to left.   

As a result, you can copy the geometry previously created in the Main Turn 
window and mirror it to create the desired geometry in the Turn-Sub window.  

1 Choose Main Spindle - Turn from the Window menu to return to the first 
window you created as shown below: 

 
In the Main-Turn Window, to copy geometry, click on the CAD/CAM 
switch to return to CAD mode.  The icon will change its appearance from a 
tool bit to a pencil.   

2 With the Selection icon highlighted, select the geometry you have created 
by choosing Select All from the Edit menu. 

3 With the geometry selected (it should be highlighted), choose Copy from the 
Edit menu. 

4 Return to the Turn-Sub Window by choosing Turn-Sub from the Window 
menu. 

5 In the Turn-Sub Window, choose Paste from the Edit menu. 

Remembering the PartMaker convention that all programming is carried out 
from right to left, as if on a conventional lathe, you will now mirror the geometry 
you just pasted.  

To do so: 

1 Make sure you are in CAD mode in the Turn-Sub Window.  

2 With the Selection icon chosen, again, choose Select All from the Edit 
menu to select the geometry if it is not currently selected. 
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3 With the geometry selected, choose Mirror from the Edit > Transform 
menu. To flip the part in order to perform operations on the back, you will 
need to mirror with respect to the middle of the part. To do so, complete the 
Mirror dialog as shown below: 

 
The completed (mirrored) part should appear as shown below: 
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Defining the Profile for Face Turning on the Sub-Spindle 
The first turning operation to be performed on the Main Spindle is to face the stock. 

1 Click the CAD/CAM switch to go to CAM mode.  

2 Choose the red square in the Color Bar.  

3 Choose New Profile Group from the Part Features menu to display the 
Profile Group Parameters dialog, or use the button:  

4 Fill out the apropriate information.  

5 Choose Contouring from the Strategy drop down menu. 

6 Choose Out from Tool Location. 

7 Choose Right from Tool Orientation 

8 Click the Select Tools Button.  You will be prompted with a choice of three 
available turning tools.  Choose T004 and click <OK>. 

 
9 In Group Name type Face.  Your completed Profile Group Parameters 

dialog should appear as shown below: 

 
Click the <Close> button to close the Profile Group Parameters dialog 
box. 
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You can now assign the Facing cycle to the geometry you created. 

1 From the left-hand side of the screen select the Define Profile icon.  

2 From the top of the screen, select the End of an Element snap mode icon. 
To define the turning tool path, click your left mouse on positions to match 
the diagram below. 

 
Your part should now appear as shown below: 

 
3 Click the Selection icon to bring yourself to a home or neutral position 

4 To check your work, select Verify Work Group Tool Path from the Part 
Features menu, or use the button. 

5 Once you are satisfied with your tool path, choose Hide Work Group Tool 
Path from the Part Features menu. 

Before moving on, save your work! Do so by selecting Save from the File menu or 
using the shortcut key <Ctrl + S>, or select the icon.  
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Defining the Profile for Turning the Head on the Sub-Spindle 
The first turning operation to be performed on the Main Spindle is to face the stock.  

1 Click the CAD/CAM switch to go to CAM mode.  

2 Choose the yellow square in the Color Bar.  

3 Choose New Profile Group from the Part Features menu or select the icon 
to display the Profile Group Parameters dialog.  Fill out the apropriate 
information.  

4 Choose Contouring from the Strategy drop down menu. 

5 Choose Out from Tool Location. 

6 Choose Right from Tool Orientation 

7 Click the Select Tools Button.  You will be prompted with a choice of three 
available turning tools.  Choose T004 and click <OK>. 

8 Uncheck the Roughing Tool ID and check the Finishing Tool ID. 

 
9 In Group Name type Turn Head.  Your completed Profile Group 

Parameters dialog should appear as shown below: 

 
Click the <Close> button to close the Profile Group Parameters dialog 
box. 
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You can now assign the Turning cycle to the geometry you created. 

1 From the left-hand side of the screen select the Define Profile icon.  

2 From the top of the screen, select the End of an Element snap mode icon. 
To define the turning tool path, click your left mouse on positions to match 
the diagram below. 

 
Your part should now appear as shown below: 

 
3 Click the Selection icon to bring yourself to a home or neutral position 

4 To check your work, select Verify Work Group Tool Path from the Part 
Features, or select the button. 

5 Once you are satisfied with your tool path, choose Hide Work Group Tool 
Path from the Part Features menu, or select the icon. 

Before moving on, save your work! Do so by selecting Save from the File menu or 
using the shortcut key <Ctrl + S>. 



 

Copyright @2014 Delcam Ltd  User Guide 4-37  

 

Milling the Hex on the Sub Spindle 
This section of the tutorial will instruct you in the steps necessary to perform a hex 
milling operation on the sub-spindle.  The methodology of programming shown here 
assumes your TurnMill Center is equipped with a Y-axis. 

Setting Up the Face Window 
1 Choose Setup from the View menu to view the Setup dialog box (or click 

the Shortcut to the Setup icon in the upper right hand corner of the 
screen).   

2 Click the <New> button to create a new face window. 

3 In the Rename to: dialog, enter the name Mill Hex - Sub 

4 From the Machining Function drop down menu, select Mill Polygon 

5 Check the Sub Spindle radio button to indicate that machining in this 
window will be carried out on the sub-spindle 

The size and origin location of the stock should remain the same as 
previously defined in the Turning Setup Window. When you are finished, the 
Setup dialog should appear as shown below: 

 
6 When you are satisfied that your Setup dialog appears as the one above, 

click the <Apply> button. This will apply the parameters to the current Face 
Window.  Click the <Close> button to close the Setup dialog. 

7 To switch to the Mill Hex – Sub window, choose Mill Hex – Sub from the 
Window menu. 
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Creating Geometry in CAD Mode 
In this section, you will create the geometry for the hex milling operations to be 
performed on the sub spindle. 
To create the geometry in PartMaker CAD: 

1 Click on the CAD/CAM switch in the lower left-hand corner of the Mill-Hex 
window. The icon will change its appearance from a tool bit to a pencil.  

2 From the left side of the screen, choose the Line Parallel to the Horizontal 
axis icon.   

3 Enter a value of 2.5/2 (72/2) at the prompt at the bottom of the screen and 
press <Enter> 

4 Choose the selection icon and select the horizontal line drawn on the screen 

5 From the Edit > Transform menu, choose Rotate.  Complete the rotate 
dialog as shown below and click <Rotate>: 

 
Your window should now appear as shown below: 
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6 Select the Remove icon and click on each extra line you wish to remove.  
Your completed Hex geometry should appear as shown below: 

 

Defining the Profile for Mill Polygon on the Sub-Spindle 
1 Click the CAD/CAM switch to return to CAM mode.   

2 Choose the red square in the Color Bar.   

3 Choose New Profile Group from the Part Features menu, or select the 
button icon to display the Profile Group Parameters dialog. 

4 From Distance from Part Face choose Tool Center (P2), positioning the 
tool in Z relative to the centerline of the flat.  Because you are now working 
in the sub-spindle the front of the hex is now at the Z=0 position. 

5 Enter a 0.3125 (6.0) for P2. 

6 Enter 0.625 (10) for Tool Diameter. 

7 Click on the <Select Tools> button. 

8 Cycle Name Type enter Mill Hex 

Click the <Close> button to close the Profile Group Parameters dialog 
box. 

Your profile group parameters should now appear as shown below: 
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You can now assign the Milling cycle to the geometry you created. 

1 From the left-hand side of the screen select the Chain Geometry icon.  

2 To define the milling tool path, click your left mouse on the upper right hand 
corner of your geometry. Your tool path should match the diagram below. 

 
3 Click the Selection icon to bring yourself to a home or neutral position.  

4 To check your work, select Verify Work Group Tool Path from the Part 
Features menu or select the button  

5 Once you are satisfied with your tool path, choose Hide Work Group Tool 
Path from the Part Features menu, or icon. 

Before moving on, save your work! Do so by selecting Save from the File menu or 
using the shortcut key <Ctrl + S>. 
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Drilling and Tapping on the Sub-spindle 
This section of the tutorial will instruct you in the steps necessary to perform drilling 
operations on the sub-spindle. 

Setting Up the Face Window 
In this section, you will set up the Face Window needed to perform milling 
operations on the sub-spindle. To do so: 

1 Choose Setup from the View menu to view the Setup dialog box (or click 
the Shortcut to the Setup icon in the upper right hand corner of the 
screen).   

2 Click the <New> button to create a new face window. 

3 In the Rename to: dialog, enter the name Face Holes - Sub 

4 From the Machining Function drop down menu, select Mill End, Index 

5 Check the Sub Spindle radio button to indicate that machining in this 
window will be carried out on the sub-spindle 

 
6 When you are satisfied that your Setup dialog appears as the one above, 

click the <Apply> button. This will apply the parameters to the current Face 
Window.  Click the <Close> button to close the Setup dialog. 

7 To switch to the Face Holes - Sub, choose Face Holes-Sub from the 
Window menu. 
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Creating Geometry in CAD Mode 
In this section, you will create the geometry for the off center holes to be tapped on 
the sub spindle.   To create the geometry in PartMaker CAD: 

1 Click on the CAD/CAM switch in the lower left-hand corner of the Face Hole-
sub window. The icon will change its appearance from a tool bit to a pencil.   

2 From the left side of the screen, choose the Circle with a Known Radius 
and Center icon.   

3 Enter a value of .25/2 (3) at the prompt at the bottom of the screen and 
press <Enter> 

4 Choose the XY Coordinates Snap Mode and enter a X value of 2.05/2 (25) 
and Y value of 0 and press <Enter> 

5 Choose the selection icon and select the circle drawn on the screen 

6 From the Edit > Transform menu, choose Rotate.  Complete the rotate 
dialog as shown below and click <Rotate>: 

 
Your window should now appear as shown below with Show Axes and Show 
Boundries: 
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Defining the Tapped Hole on the Sub-Spindle 
Here you will define the cycle and size of the tapped hole to be machined on the 
subspindle. To do so: 

1 Click the CAD/CAM switch to go to CAM mode.  

2 Choose the red square in the Color Bar.   

3 Choose New Hole Group from the Part Features menu to display the Hole 
Group Parameters dialog, or select the icon. 

4 Uncheck the Through Hole box. 

5 In the Major Cycle Operation drop down menu select Tap. 

6 Enter a Diameter (d) of .25 (6) 

7 Other parameters should be set as follows: 

Chamfer (c):   0.03 (1.0) 
Z-Surf (S):   0.0 
Z-Rapid (R):   0.1 (1) 
Z- Clear (C):   0.05 (1) 
Nominal Depth (D): 0.358 (8.0) 

Click the Cycle button and PartMaker will select the appropriate cycle to 
create the desired hole. The selected cycle should be Tap-1/4-20-Z (M6 x 
1 Tap). 

 
You can verify the shape of the tapped hole by pressing the Verify Shape 
button. If you entered the parameters correctly you should see the following: 

 
Press the <Hide Shape> button and the <Close> button to exit the Hole 
Group Parameters dialog. 
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You can now assign the Drilling cycle to the geometry you created. 

1 From the left-hand side of the screen select the Chain Circles Icon. 

2 To define the drilling tool path, click your left mouse on any hole on the 
screen. PartMaker will automatically find all holes of the same diameter. 
Your tool path should match the diagram below. 

 
3 Click the Selection icon to bring yourself to a home or neutral position 

Before moving on, save your work! Do so by selecting Save from the File menu or 
using the shortcut key <Ctrl + S> or select the icon. 
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Creating an NC Program 
At this point, you have completed creating the faces and laying out the tool paths 
for the 8-axis tutorial part. You are now prepared to take the final steps in 
developing your part program. 

The steps required for process plan development and program creation are 
described using the “generic” 8-axis TurnMill post processor that comes standard 
with your PartMaker TurnMill software. Synchronization and other processing 
related issues may vary slightly for different machine makers, but the steps below 
are instructive to work through in developing an understanding of process 
development in PartMaker TurnMill. 

 Tip:  Refer to the Machine Specific Addendum that came with your 
PartMaker software for more information on process planning and post 
processing issues for the TurnMills in your shop. 

Generating a Process Table 
The first step in generating an NC program is creating a Process Table. A Process 
Table shows you all of the machining processes for a part.   

When PartMaker generates a Process Table, all cutting conditions such as feed rate 
and spindle speed (RPM) are calculated automatically based on the tools and 
material information previously entered. A time for each operation is shown, along 
with a total machining time for both the main and sub spindles. These time 
calculations give the user a sense of how closely “balanced” machining is for a part, 
i.e. how much cycle time is expended on both main and sub spindles in addition to 
the total time to cut the part. Time calculations in PartMaker include both “in-cut” 
time as well as tool change time. 

To create the Process Table: 

4 Choose Generate Process Table from the Job Optimizer menu, or select 
the icon. 

Upon doing so, you will be prompted with the dialog below: 

 
Retain Process Parameters Modifications. Checking this box will retain 
previous modifications to the process table. Since this is your first time 
Generating the Process Table it will have no effect.  

Move Cut-Off Process to End of Process Table. Checking this box will 
automatically place your cut-off process at the end of the Process Table. 

Eject Part After Last Sub-Spindle Process. Checking this box will 
automatically place your eject after the last Sub-Spindle process. 
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The following Process Table will appear: 

 

Visual Process Synchronization and PartMaker Specific Modes 
When generating a Process Table, PartMaker will default to machining your part in 
the order in which you have programmed part features. PartMaker starts by 
choosing the processes in the first Face Window you have created in the Setup 
dialog and executing all the part features in that Face Window in the order they 
have been created. The software then moves onto the next Face Window you have 
created and executes the processes defined in that Face Window. 

Of course, in TurnMill, to conserve cycle time, many processes may be happening 
simultaneously, rather than in the sequential order in which you have created your 
tool paths in PartMaker. The Process Table accommodates this unique feature of 
TurnMills allowing you define the true order of processes defined in different Face 
Windows. It is on the Process Table that you synchronize operations being 
performed simultaneously with either different tool posts (i.e. turret 1, turret 2, 
backworking etc) or on different spindles (main vs. sub) or some combination of the 
two. Such synchronization is done by pointing and clicking to place the order of 
processes and then by assigning different Synchronization Modes in the Set Modes 
dialog to link different processes to one another.   

More information on the Set Modes dialog can be found in Chapter 2, PartMaker 
Fundamentals. In addition, more information on synchronization techniques can be 
found in the Machine Specific addendum that came with your PartMaker 
software. 
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Synchronizing Processes on the Main Spindle 
To synchronize the Main Spindle operations on the Process Table for the TurnMill: 

1 Click on the Set Modes icon to the right of Process 1 as shown below: 

 
2 After doing so, you will see the Set Modes dialog appear as shown below: 

 
The Set Modes dialog allows you to visually determine the type of 
synchronization you want to perform. 
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In this case, you will be synchronizing a number of Main Spindle (Turret 1) 
operations with all of the Sub Spindle (Turret 2) operations.  To indicate 
process 1 will be running simultaneously as a process on the Sub Spindle, 
click the Machining with One Tool (S1) radio button in the Sub-Spindle 
Mode area of the Set Modes dialog. After having done so, the Set Modes 
dialog should appear as shown below: 

 
Once you are satisfied your dialog appears as the one above, click the <OK> 
button to return to the Process Table. 

Notice how the Set Modes icon now depicts two tools cutting, one on the 
Main Spindle and one on the Sub Spindle.  The Mode column is now filled in 
with M1S1, indicating that during this process one tool is cutting on the main 
spindle and one is cutting on the sub spindle at the same time. 
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3 In order to quickly set the remaining Main Spindle Processes to M1S1 (i.e. 
simultaneous cutting on Main and Sub Spindle) click the Set Modes dialog 
associated with process 2.  Again, click the Machining with One Tool (S1) 
radio button in the Sub-Spindle Mode area of the Set Modes dialog. 

4 Next, click the Modify Modes for all Consecutive Processes with Same 
Mode radio button.  After having done so, the Set Modes dialog should 
appear as shown below: 

 
5 Click <OK> to return to the Process Table.  The Set Modes icons for all 

Main Spindle Processes should be automatically assigned and appear as 
shown below: 
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Synchronizing Processes on the Sub Spindle 
To synchronize the Sub Spindle operations with the Main Spindle operations 
discussed above on the Process Table for the 8-axis_demo.job: 

1 Click on Process 7, the first operation programmed on the Sub Spindle.  With 
Process 7 selected click the Set Modes icon. 

 
2 In the Set Modes dialog, click the Machining with One Tool (M1) radio button 

in the Main Spindle Mode area of the Set Modes dialog. To save time, click 
the Modify Modes for all Consecutive Processes with Same Mode radio 
button. 

After having done so, the Set Modes dialog should appear as shown below: 

 
3 Click the <OK> button to return to the Process Table. 



 

Copyright @2014 Delcam Ltd  User Guide 4-51  

 

Setting the Cut-Off Operation 
Having now properly Synchronized the Main Spindle and Sub-Spindle operations, 
you will now set-up the cut-off operation.  In TurnMill, cut-off is typically 
programmed as the last operation when cutting a part that involves synchronous 
machining on both spindles. 

To properly set-up the cut-off and transfer from the main spindle to the sub spindle: 

1 Click on the Set Modes icon associated with process 6 (the Cut-off 
operation) to enter the Set Modes dialog.  The proper mode for the Cut-Off 
operation is Cutting with One Tool (M1) on the Main Spindle while 
providing Part Support (SP) with the sub-spindle, meaning the sub-spindle 
is supporting while the part is being cut. 

To set this mode of operation, check the Part Support (SP) radio button in 
the Sub-Spindle Mode area of the Set Modes dialog. 

When setting this mode, enter a value of 3.0 (80) for the Sub-Spindle Grip 
Z-Coordinate (Zg), the position at which the sub-spindle is gripping the 
part during transfer. 

After doing so your Set Modes dialog should appear as shown below: 

 
2 Click the <OK> button to return to the Process Table. 
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Creating Sync (Synchronization) Groups 
With the Process Table generated and the sequence of operations established, you 
can now verify that your synchronization approach is correct by creating Sync 
Groups, groups of processes being executed simultaneously.  To do so: 

1 Click the Synchronize button in the upper right hand corner of the Process 
Table. 

 
2 If you have made any errors in process synchronization, PartMaker will 

prompt you at this time. If you have not made any errors, your Process 
Table should appear as shown below: 

 
On the Process Table above, processes 1 through 12 are all being executed 
at the same time (all be it sequentially) and as a result are in the same Sync 
Group.  Process 6 is happening independently and thus is not included in a 
Sync Group.   

Notice, once Sync Groups have been created, PartMaker displays a 
“balanced” cycle time for the entire operation, meaning the Total Time 
displayed is not necessarily a sum of the Main spindle time and the Sub 
spindle time, but actually takes the overlapping or synchronized operations 
into account. 

 
You can also visually verify the synchronization of the Main Spindle and Sub-
Spindle. To do so: 

1 Click the Show Time Chart button in the lower right hand corner of the 
Process Table to see a Graphic representation of your Process. You may also 
select the clock button. 

 
2 Click the Hide Time Chart button in the lower right hand corner of the 

Process Table to hide the time histogram, or click on the clock button again. 
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Selecting a Post Processor 
Having generated a Process Table you must now select a Post Configuration File 
before you can output an NC progrm.  This post configuration file is stored in the 
pm-tm root directory.  If you do not have any other post configuration files loaded 
in this directory the 8-axis_demo.pst will be loaded automatically.  If you do have 
other post configuration files in this directory: 

1 Choose Post Config File = ? from the Job Optimizer menu.  

2 Select the 8-axis_demo.pst post as shown below.  PartMaker for TurnMill 
comes standard with a post configuration for a Fanuc 18t control which 
supports, live tooling, c-axis and subspindle operations. 

 
Click <OK> to continue. 
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Simulating the Process 
Having completed generating the Process Table and synchronizing operations, you 
can now simulate the processes. The simulation will show your part being cut just 
how it would on your machine tool.  Simulation will show synchronization between 
your Main and Sub-Spindles. It will also show any collisions that may occur between 
the tooling, material, and/or Spindles.  

1 Click the <Simulation> button at the bottom left hand portion of the 
Process Table, or select the Simulation button:  

2 Press the Space Bar or choose Simulation from the Simulation menu to 
begin the simulation. Alternately, select the icon. 
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Generating an NC Program 
Having selected a Post Configuration file, you are now ready to generate an NC 
Program.  To do so: 

1 Choose Generate NC Program from the Job Optimizer menu.  

 Note:  Choosing the Generate NC Program command from the Job 
Optimizer menu has the same effect as clicking the Sync Group button 
on the Process Table if Sync Groups have not yet been created. 

2 You will next see the Post Options dialog.  Set the Post Options dialog as 
shown below: 

 
In the Post Options dialog you set certain parameters for assignment 
during post processing.  Please refer to your machine specific addendum for 
more information on how each of the fields in this dialog pertain to your 
TurnMill equipment. 

3 Click <OK> in the Post Options Dialog to proceed to the Save NC 
Program dialog.  In this dialog, enter a name for your program.  Here you 
should enter “tutorial”. 
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4 Click <Save> to generate the NC program.  The NC Programs will now be 
displayed. 
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Chapter 5: PartMaker® Simulation 
Introduction 

PartMaker Version 8 and higher comes with an integrated 3D solid modeling process 
simulation and verification module.  This module is available in three levels:  Basic 
Simulation, Advanced Simulation and Full Machine Simulation.  Basic Simulation 
comes standard with PartMaker Turn-Mill while both Advanced and Full Machine 
Simulation are available as optional modules with PartMaker Turn-Mill. 

PartMaker’s Basic Simulation Module allows you to: 

 Simulate all machining processes as they appear on the Process Table 

 Observe the results of any process synchronization 

 Examine a solid model of the part through dynamic rotation and cross-
sectioning 

PartMaker’s Advanced Simulation Module allows you to do all of the above and: 

 View a 3D parametric machine model for your specific machine 

 Automatically check that all tool numbers assigned in the tool database are 
assigned correctly for your specific machine model 

 Customize your machine through the manipulation of an MCH file 

 Detect crashes, collisions and errors between various machine components 
and the part 

 Detect any machine over travels on screen 

PartMaker’s Full Machine Simulation Module allows you to do all of the above and: 

 View a realistic 3D model of your machine and its tool holders and various 
components based on actual solid models versus just parametric descriptions 

 Import solid models for all simulated entities 

 Add components to these entities (i.e. turret slides) to model the kinematics 
of the machine. 

 Add tool holders to the simulation and mount multiple tools per holder. 

 Interactively specify how the machine is assembled. 

Users who have licensed the Advanced Simulation or Full Machine Simulation 
modules may still find it beneficial to use the Basic Simulation module to focus on 
only the part as it is being machined.  

You may choose between Basic, Advanced, of Full Machine Simulation by choosing 
Basic Simulation, Advanced Simulation, or Full Machine Simulation from the 
Simulation menu or by right mouse clicking on the Process Table and choosing 
either option.   

Whichever simulation option has been selected will determine which type of 
simulation will be launched. 
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The Simulation Toolbar 
Many of the common functions used in PartMaker’s 3D simulation can be accessed 
via the Toolbar that appears at the top of the Simulation Window as shown here: 

 
Each icon on the Simulation Toolbar is explained below.  The features each of 
these icons enable will be explained in greater depth throughout this chapter. 

 

 
Starts the simulation 

 
Pauses the simulation 

 
Resets the simulation 

 
Shows the finished 3D model of the part 

 
Allows the user to measure the completed part. 

 
Sets simulation to operate in Basic Simulation mode 

 
Sets simulation to operate in Advanced Simulation mode 

 
Sets simulation to operate in Full Machine Simulation mode 

 
Allows you to take cross sectional views of the completed part 

 
Allows you to show a full view of a part after sectioning 

 
Allows you to manipulate the view of machined part 

 
Allows you to see the Simulation Options dialog 

 
Allows you to see the Spindle Setting  dialog 

 
Shows the Machine Housing 
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Simulation Features 
PartMaker Simulation has a number of process and part analysis features available 
both during and after process simulation is complete.  These features are described 
here: 

Reset 
At any point you can reset the simulation to the initial screen by choosing Reset 
from the Simulation menu.  Alternatively, if you have suspended Simulation by 
pressing <Esc>, you can press <Esc> again to reset the simulation. 

The Reset command is also accessible by clicking the right mouse button when 
viewing the finished part (see below). 

Show Travel Limits 
Displays the travel limits for machine being simulated for each machine component 
depending on how the machine is equipped.  Travel limits for each machine 
components including main spindle, sub spindle and tool posts are set in the 
Machine Date File dialog accessed from the Toolminder menu. 

Show Finished Part 
By choosing the Show Finished Part command from the Simulation menu, you 
can see a 3D model of your programmed part.  You need not run the simulation 
prior to choosing Show Finished Part.  

When choosing Show Finished Part, the verified part alone will appear in the 
Simulation window as shown here: 

 

Save Finished Part As STL file 
This will save the finished part to an STL file format.  This can be then used again in 
PartMaker for Custom Stock or Surface Machining. 
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Compare Finished Part to Solid Model 
This will use the solid model specified in the Comparison Options Dialog to show 
a comparison of the part to the solid model. 

 

Comparison Options 
This will open the Comparison Options dialog.  This allows you to specify the 
comparison models as well as the over and undercut display colors. 
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View Setting Features 
PartMaker Basic Simulation allows you to automatically set a variety of views when 
simulation has been halted by using the <Esc> key or when using the Show 
Finished Part command.  Various view orientations are available from the View 
sub-menu under the Solids menu. 

Default 
Choosing Default sets the view in the simulation window to the default view 
when Simulation was launched. 

Best Fit 
Choosing Best Fit sets the view in the simulation window to the best fit relative 
to the Simulation window as determined automatically by PartMaker. 

XY View 
Choosing the XY View command sets the view in the simulation window normal 
to the cross sectional plane formed by XY axes.  The axes along which the part 
is defined are constantly active in the lower left hand corner of the simulation 
window. 

YZ View 
Choosing the YZ View command sets the view in the simulation window normal 
to the cross sectional plane formed by YZ axes.  The axes along which the part 
is defined are constantly active in the lower left hand corner of the simulation 
window. 

ZX View 
Choosing the ZX View command sets the view in the simulation window normal 
to the cross sectional plane formed by ZX axes.  The axes along which the part 
is defined are constantly active in the lower left hand corner of the simulation 
window. 

Isometric View 
Choosing the Isometric View command sets the view in the simulation window 
aligned to the X, Y and Z axes.  This view presents the part at a 45 degree 
angle. 

Show Coordinate Axes 
Checking this selection on allows the user to the axes symbol in lower left hand 
corner of PartMaker Simulation Window. 

Show Finished part Origin 
This will hide or show the 3-D axis on the finished part. 

Show Coordinate axis 
This will hide or show the 3-D coordinate system axes in the lower left hand side 
of the simulation window. 

Background Color 
Allows the user to choose the background color of the simulation.  The 
background may be set to gradient by choosing different colors for the Top and 
Bottom Gradient Color respectively. 

Datum Color 
Sets the color of each axis of the datum, X, Y and Z respectively. 
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View Manipulation Features: Rotate, Move and Zoom 
PartMaker simulation allows you to manipulate the view of either the entire process 
simulation or the finished part (when using Show Finished Part).  When using 
PartMaker, one of these commands will be activated, as denoted by a check next to 
it under the Change View sub menu under the Simulation menu.   

Whenever the Rotate, Move or Zoom command is checked, it can be activated by 
holding down the left mouse key and moving your mouse.   

It is advisable to always leave the Rotate command checked as both Move and 
Zoom can always be accessed using keyboard shortcut keys or the mouse.  For 
example, if the Rotate command is checked under the Change View sub menu 
under the Simulation menu, Rotate can be activated by clicking the left mouse 
button and moving the mouse, Move can be activated by holding down the mouse’s 
scroll wheel and moving the mouse and Zoom can be activated by simply scrolling 
the mouse’s scroll wheel. 

PartMaker provides fully dynamic simulation such that the Rotate, Move and Zoom 
commands can be accessed at any time during simulation. 

Rotate 
This command allows you to dynamically rotate the entire process simulation 
within the simulation window.  When using Show Finished Part, Rotate allows 
you to dynamically rotate the solid model of the completed part.   

When Rotate is active, you can rotate the process simulation or finished part by 
clicking the left hand mouse button and dragging your mouse in the orientation 
you would like to see the view. 

Rotate may only be used when it is activated from the Solids menu.  You can 
activate Rotate by choosing it from the Solids menu.  Its activation is denoted 
by a check next to it under the Simulation window. 

Move 
This command allows you to dynamically move the entire process simulation 
around the simulation window.  When using Show Finished Part, Rotate 
allows you to dynamically rotate the solid model of the completed part.   

When Move is active, you can move the process simulation or finished part by 
clicking the left hand mouse button and dragging your mouse in the direction 
you want to move the view.   

You can move the view if Move is NOT active by holding down the <Ctrl> + 
<Arrow> keys on your keyboard, with arrows denoting the direction in which 
the view will move.  These are the same keys used when performing panning in 
PartMaker. 

Additionally, Move can always be activated using the mouse by holding down 
the mouse wheel (if your mouse is so equipped) and dragging your mouse in the 
direction you want to move the view. 

You can activate Move by choosing it from the Solids menu.  Its activation is 
denoted by a check next to it under the Simulation window. 

Zoom 
This command allows you to dynamically size the entire process simulation 
within the simulation window when it has been halted by using the <Esc> key.  
When using Show Finished Part, Zoom allows you to dynamically size the 
solid model of the completed part.   
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When Zoom is active, you can scale the process simulation or finished part by 
clicking the left hand mouse button and dragging it upward to increase the size 
of the part and dragging downward to decrease the size of the part.   

You can scale the view if Scale is NOT active by pressing the <F4> key to 
decrease the size of the view or the <F5> key to increase the size of the view.  
These are the same keys used when performing Continuous Zoom In or Zoom 
Out in PartMaker. 

Additionally, Scale can always be activated using the mouse by scrolling the 
mouse wheel (if your mouse is so equipped) upward to zoom in and downward 
to zoom out. 

Sectioning Features 
PartMaker simulation allows you to section the solid view to inspect the interior of 
the part. Various sectioning options by choosing Sectional View from the 
Simulation menu.  Choosing Sectional View opens the Section Finished Part 
dialog as shown below: 

 
1 Sectioning Plane – The Sectioning Plane section of this dialog allows you to 

determine the plane across which sectioning will occur normal to. The use 
can section a finished part normal to the XY, ZY and ZX plane. The axes 
along which the part is defined are constantly active in the lower left hand 
corner of the simulation window.  

2 Dynamic Sectioning – Checking this box enables dynamic section, or the 
ability to see the part being sectioned as you adjust the location of the 
sectional plane.  If Dynamic Sectioning is unchecked, , you will be able to see 
the result of your sectioning by clicking the <Preview> button or by exiting 
this dialog by clicking <OK> 

3 Plane Coordinate - This area of the dialog allows you to adjust the level of 
the sectioning plane. 

4  Reverse Direction - This allows you to reverse the direction of sectional 
plane shown. 
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Simulation Options 
You can manipulate the appearance of simulation by choosing Options from the 
Simulation menu or by clicking the right mouse button in the Simulation Window 
and choosing Options.   

PartMaker Simulation allows you to change the appearance of the view in the 
simulation window when simulation has been halted by using the <Esc> key or 
when using the Show Finished Part command.   

The Options dialog as it appears in Basic Simulation for PartMaker Turn-Mill is 
displayed below: 

 

Pause On  
Never: Specifies that simulation should never pause during simulation 

Eject: Specifies that simulation should pause before part eject operation is 
performed 

Cut-off: Specifies that simulation should pause after the cut-off operation is 
performed 

Every Process: Specifies that simulation should pause at the beginning of every 
process in the current Process Table 

Selected Process: Specifies that simulation should pause at the beginning of a 
selected process in the current Process Table 

Every Move: Specifies that simulation should pause before every tool move 

Tool Collision: Specifies that simulation should pause every time a collision occurs 

Tool Overtravel: Specifies that simulation should pause every time tool post goes 
outside of its travel limits specified in the Machine File. 

Settings  
Turning Insert Thickness: Specifies the thickness of the turning insert 

Max ID Tool Holder Thickness: Specifies the maximum thickness of a tool holder for 
inside diameter tool. 
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Enable Collision Checking/Report Collision Types 
Checking the Enable Collision Checking checkbox allows you to detect the 
following collision types in Simulation: 

Tool with Stock(s) on Rapid Move: Specifies that PartMaker should check for 
collisions between the tool (or insert) and that stock in the main spindle as well 
as a part in sub-spindle 

Tool withGB and/or Sub-Spindle: Specifies that PartMaker should check for 
collisions between the tool (or insert) and the Guide Bushing and/or Sub-Spindle 

GB and Sub-Spindle: Specifies that PartMaker should check for collisions 
between the Guide Bushing and Sub-Spindle. 

Tool Holder Collision: Specifies that PartMaker should check for Tool Holder 
collisions with any part/stock as well as with the Main Spindle and Sub-Spindle 

Tool with Foreign Stock: Specifies that PartMaker should check for collisions 
between the tool (or insert) working on the Main Spindle with part in the Sub-
Spindle or between the tool (or insert) working on Sub-Spindle with the stock or 
part in the Main Spindle 

Tool with Tool: Specifies that PartMaker should check for collisions between two 
tools on the machine. This is for Advanced an Full Machine simulations only. 

Tool with Toolpost: Specifies that PartMaker should check for collisions between a 
tool and another tool post on the machine.  This is for Advanced and Full 
Machine simulations only. 

Toolpost with Toolpost: Specifies that PartMaker should check for collisions 
between tool posts on the machine.  This is for Advanced and Full Machine 
Simulations only. 

Toolpost with Stock: Specifies that PartMaker should check for collisions between 
a tool post and the stock being machined.  This is for Advanced and Full Machine 
Simulations only. 

Toolpost with Spindle:  Specifies that PartMaker should check for collisions 
between a tool post and the main or sub spindle.  This is for Advanced and Full 
Machine Simulations only. 

Non-Active Tool with Spindle:  Specifies that PartMaker should check for collisions 
between a tool not in the cut and the main or sub spindle.  This is for Advanced 
and Full Machine Simulations only. 

Non-Active Tool with Stock:  Specifies that PartMaker should check for collisions 
between a tool not in the cut and the stock.  This is for Advanced and Full 
Machine Simulations only. 

Tool with Machine Housing:  Specifies that PartMaker should check for collisions 
between a tool (or insert) and the machine housing.  This is for Full Machine 
Simulation only. 
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Display Control 
Time Delay (0...9): Specifies a time delay following every screen update for each tool 
motion. Negative numbers -9 to -1 may be used to speed simulation more than 0. 

Transparency of GB/Sub-Spindle: Specifies how transparent the Main Spindle and/or 
Sub-Spindle appear. 0% means solid appearance, 100% means ‘fully transparent’ 
appearance, i.e. Guide Bushing and/or Sub-Spindle will be invisible. 

Transparency of Stock/Part: Specifies how transparent the part and/or stock should 
appear. 0% means solid part, 100% means "fully transparent" part, i.e. an invisible 
part. 

Display Status: Specifies the current simulation status consisting of the Process ID 
and Tool Point coordinates will be displayed on the top of the Simulation window 

Run in a Loop: Specifies that Simulation will run in a continuous loop 

Hide Tool Holders: Specifies that Tool Holders for Turning Tools will not be displayed 
during Simulation 

Display Status:  Allow the Simulation to display coordinate and movement 
information at the top of the simulation window. 

Cosmetic Thread: Specifies that during Simulation every Multi-Pass helical thread will 
be replaced by a single pass in order to speed up simulation. 

Software Rendering: Specifies that Open GL software graphics libraries should be 
used instead of the hardware implementation of the Open GL drivers that are 
dependent on the actual Graphics Video card used in every computer. If you use a 
high performance AGP video card you may achieve a significant simulation speed 
improvement if you do not use Software Rendering 

Wireframe Display: Specifies that everything will be displayed using a wire frame 
representation instead of solid modeling. 

Show Tool Numbers on Tool Posts:  This will show all tool numbers available on 
a tool post on the solid for that tool post.   This is for Advanced Simulation only. 

Show Machine Housing:  This will show the Machine Housing Components specified in 
the Machine File. This is for Full Machine Simulation only. 

Display Quality 
Coarse: Specifies that solids will be displayed using relatively large facets to assure 
the fastest simulation 

Medium: Specifies that solids will be displayed using medium size facets that will 
result in lesser simulation speed 

Fine: Specifies that solids will be displayed using very small size facets that will 
result in further decrease in simulation speed 

Apply to All Machine Components: Specifies that solid models will be converted to 
simulation models with the specified Display Quality (Coarse, Medium, Fine), 
regardless of the quality specified in its model data.  These solid models can include 
custom stocks and tool posts. 

Colors and Textures 
Use Group Colors: Specifies that user-defined Group Colors will be used as cut 
colors. If this option is not checked a metallic gray color will be used as cut color for 
all tools 

Set Stock Color: Allows a user to choose the color of initial stock using a Windows 
standard dialog. 

Set Stock Texture: Opens the Texture Dialog for various stock texture options. 
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Using PartMaker Basic Simulation 
PartMaker Basic Simulation can be viewed at any point in the programming process.  
You need not complete programming a part to see the results of your work. 

 Important! To launch PartMaker Simulation you must have a Process Table 
generated.  To generate the Process Table, choose Generate Process 
Table from the Job Optimizer menu (ALT + P) or use the Generate 
Process Table icon from the Main Toolbar.  It is not necessary to 
complete synchronization of simultaneous operations before launching 
PartMaker Simulation. 

Launching Basic Simulation 
To launch PartMaker Basic Simulation: 

1 Click the Start Simulation icon from the Main Toolbar 

or 

Press the Simulation button in upper left hand corner of the Process Table 

or 

Choose Simulation from the Simulation menu 

 

2 Make sure the Basic Simulation icon on the Simulation Toolbar is 
checked or Basic Simulation is checked under the Simulation menu  

Upon launching simulation, you will see an uncut cylindrical work piece, and either 
one or two spindles depending on whether your part involves both main and sub 
spindle operations.  

A newly launched simulation window is shown below: 
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Running Simulation 
Once you have launched PartMaker Simulation, to start machining: 

1 Press the Start Simulation button on the Simulation Toolbar  

or 

Press the <Space Bar> on your keyboard  

or  

Select Start Simulation from the Simulation Menu 

2 Once simulation has started, you can suspend cutting by pressing the <Esc> 
button on your key board. Press the <Space Bar> to continue the 
simulation.  Below, is an example of suspending simulation in process: 
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Using PartMaker Advanced Simulation 
PartMaker Advanced Simulation can be viewed at any point in the programming 
process.  You need not complete programming a part to see the results of your 
work. 

Irrespective of which Turn-Mill machine you are using, PartMaker installs a number 
of “generic” machine configurations, which you may view.  These machine 
configurations can be viewed from the C:\PM-TM\Advanced_Simulation directory 
and consist of the following examples: 

Single_Turret_Single_Spindle: A “generic” machine with one turret and a 
main spindle 

Single_Turret_Twin_Spindle: A “generic” machine with one turret and a 
main and sub spindle 

Three_Turret_Twin_Spindle: A “generic” machine with three turrets and a 
main and sub spindle 

Tool_Head_Turret_Twin_Spindle: A “generic” machine with two turrets 
and a main and sub spindle 

Twin_Turret_Twin_Spindle: A “generic” machine with two turrets and a 
main and sub spindle 

None of the examples listed above are meant to represent a specific machine model 
such as a Hardinge Quest, Haas TL, Mori Seiki ZT, Miyano BNE etc.  You will be able 
to view a more machine specific model for your machine when loading the *.MCH 
file specifically tailored to the machine you are programming. 

Launching Advanced Simulation 

 Important!  For purposes of this tutorial, please load the *.job, *.tdb and 
*.cdb files called Twin_Turret_Twin_Spindle.job, 
Twin_Turret_Twin_Spindle.tdb and Twin_Turret_Twin_Spindle.cdb located in 
the C:\PM-TM\Advanced_Simulation\ Twin_Turret_Twin_Spindle directory. 

 Important! To launch PartMaker Advanced Simulation you must have an 
*.MCH (machine configuration file) loaded.  The MCH file contains a 
description of the Swiss machine you are using to machine the part. An MCH 
file will be loaded automatically when a post processor is loaded and the 
MCH file corresponding to that post processor is loaded in the same directory 
as the post processor. 

You will only be able to launch PartMaker Simulation when the Process Table is 
generated.  If you do not have a Process Table generated, choose Generate 
Process Table from the Job Optimizer menu. 

To launch PartMaker Advanced Simulation: 

1 Click the Start Simulation icon from the Main Toolbar 

or 

Press the Simulation button in lower left hand corner of the Process Table 

or 

Choose Simulation from the Simulation menu 

2 Make sure the Advanced Simulation icon on the Simulation Toolbar is 
checked or Advanced Simulation is checked under the Simulation menu  
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Upon launching simulation, you will see an uncut cylindrical work piece, tool posts 
with tools attached, and either one or two spindles depending on whether your part 
involves both main and sub spindle operations.  

A newly launched simulation window is shown below: 

 

Running Simulation 
Once you have launched PartMaker Simulation, to start machining: 

1 Press the Start Simulation button on the Simulation Toolbar  

or 

Press the <Space Bar> on your keyboard  

or  

Select Start Simulation from the Simulation Menu 

2 Once simulation has started, you can suspend cutting by pressing the <Esc> 
button on your keyboard. Press the <Space Bar> to continue the 
simulation. 

Below, is an example of suspending simulation in process: 
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Using PartMaker Full Machine Simulation 
PartMaker Full Machine Simulation can be viewed at any point in the programming 
process.  You need not complete programming a part to see the results of your 
work although it is highly recommended to do so.   

PartMaker installs a “generic” machine configuration, consisting of a Twin Turret 
Machine for you to view.  This machine configuration can be viewed from the C:\PM-
TM\Full_Machine_Simulation directory. 

 Note: For this tutorial, please load the *.job, *.tdb and *.cdb files called 
FMS_Turnmill_demo, from the C:\PM-TM\Full_Machine_Simulation\ 
directory. 

 Important!  To launch PartMaker Full Machine Simulation you must have an 
*.MCH (machine configuration file) loaded.  The MCH file contains a 
description of the Turn-Mill machine you are using to machine the part. This 
file will be loaded automatically when a post processor is loaded and the 
MCH file corresponding to that post processor is loaded in the same folder. 

Prior to running Full Machine Simulation, you will attach the holders specified in the 
Machine Data File to the tools used on the Process Table.  The tool post and 
component models will automatically be loaded into simulation. 

1 Select Tool Assembly from the Job Optimizer menu to open the Tool 
Assembly dialog. The tools on the process Table are displayed, sorted by 
tool post and tool number. 

 
2 Highlight the first tool on list, Tool Number 1 on Turret 1.  You will notice 

that in the Holder Name column, there is a “?” which means that a holder is 
expected to mount to this position. 

3 Press <Tool Assembly Preview> to see how the tool and tool post will look 
in simulation.  Notice that the tool is floating in air away from the Turret. 
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4 Press the “X” in the top left corner of the window to close the Preview. 

5 Press <Select Holder> to open the Select Holder Dialog for the 
highlighted tool. 

6 Choose “X_Turn_Main” to specify this holder to be used for simulation. 

 
7 Press <OK> to confirm this holder selection. 

8 Press <Tool Assembly Preview> to see how the final assembly with the 
holder will look when attached in simulation.  You will see if there are any 
issues with the holder that you have selected. 

 
9 Press the “X” in the top left corner to close the Preview. 

10 Repeat step 2 – step 9 for the remaining tools on Turret 1 and Turret 2. For 
the following tools, you will use the holders listed bellow: 

a Tool 2 on Turret 1: “X_Turn_main” 

b Tool 3 on Turret 1: “Z_Mill_Main” 

c Tool 4 on Turret 1: “Z_Mill_Main” 

d Tool 5 on Turret 1: “Z_Mill_Main” 

e Tool 6 on Turret 1: “Z_Mill_Main” 

f Tool 9 on Turret 1: “X_Turn_Main” 

g Tool 1 on Turret 2: “X_Turn_Sub” 
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h Tool 2 on Turret 2: “X_Turn_Main” 

i Tool 7 on Turret 2: “X_Mill_Sub” 

j Tool 8 on Turret 1: “X_Mill_Sub” 

11 Press <OK> in the Tool Assembly dialog to confirm all of your holder 
selections. 

Launching Full Machine Simulation 
Once all the holders have been attached to the respective tools on the process 
table, you can view the Full Machine Simulation.  The full machine simulation will 
include the models of the tool posts and their components, holders for the tools, 
and custom positioning of the tools and holders on the tool posts. 

To launch PartMaker Full Machine Simulation you must have a Process Table 
generated.  To generate the Process Table, choose Generate Process Table from 
the Job Optimizer menu (ALT + P).  It is not necessary to complete 
synchronization of simultaneous operations before launching PartMaker Simulation. 

To launch PartMaker Simulation: 

1 From the Simulation menu, choose Full Machine Simulation or right 
mouse click on the Process Table and choose Full Machine Simulation 
from the drop down menu that appears 

2 Press the Simulation button in lower left hand corner of the Process Table 

or 

Choose Advanced Simulation from the Simulation menu 

or 

Press the <Space Bar> on your keyboard 

Upon launching simulation, you will see an uncut cylindrical work piece, tool posts 
with tools and holders attached, and either one or two spindles depending on 
whether your part involves both main and sub spindle operations.  

A newly launched simulation window is shown below: 

 
Once simulation has started, you can suspend cutting by pressing the <Esc> 
button on your keyboard. Press the <Space Bar> to continue the simulation.  
Below, is an example of suspending simulation in mid-process. 
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Machine File for Advanced and Full Machine Simulation  
The machine you are seeing in PartMaker’s Advanced Simulation is described by a 
Machine Description stored in a *.MCH file.  Each machine architecture will have a 
separate Machine Description.  The Machine Description may be viewed 
graphically by choosing Machine… from the ToolMinder menu.  When doing so, 
the following dialog appears: 

 
See PartMaker Help for a more in depth explanation of each of the dialogs and 
parameters in the Machine Data File dialog. 
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When should you use Basic vs. Advanced Simulation? 
Basic and Advanced Machining Simulation are not mutually exclusive technologies.  

Basic Simulation may be preferable to use in certain circumstances over Advanced 
Simulation because it: 

 Provides more focus on just the part and cutting process because space is 
not taken up on screen with multiple machine components. 

 Can run faster then Advanced Simulation because it is less graphically 
intensive. 

Advanced Simulation will be preferable to use in certain circumstances over Basic 
Simulation because it: 

 Provides a machine specific simulation, i.e. supports right and left-handed 
machines, specific machine components, etc. 

 Provides additional crash and collision avoidance over Basic Simulation 

 Gives the user verification that all tools numbers are correct for a given 
machine 

As a rule of thumb, you may find Basic Simulation more beneficial for simulating 
your “first pass” at programming a part, while Advanced Simulation may be better 
when completing the programming of the entire component at which time you wish 
to see how the part will look as well as how it will run in its machine environment. 

When should you use Full Machine vs. Advanced Simulation? 
Full Machine and Advanced Simulation are not mutually exclusive technologies.  

Full Machine Simulation may be preferable to use in certain circumstances over 
Advanced Simulation because it: 

 Provides a photo realistic representation of the machine, thus enabling 
robust collision checking of holders, turrets, and other machine components.  

 Provides a virtual setup of the machine tool for training purposes. 

Advanced Simulation will be preferable to use in certain circumstances over Full 
Machine Simulation because it: 

 It will run faster since it is less graphically intensive. 

 Models may not be available for a particular machine tool. 

 You do not wish attach tools to holders is not required by the user. 

 You wish to see tool numbers clearly displayed on the machine model 

Although not much more, Full Machine Simulation does take more time to set up for 
use than Advanced Simulation.  It may be beneficial to make sure that the tools are 
set up correctly in Advanced Simulation, before taking the time to use Full Machine 
Simulation. 
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Advanced Simulation Limitations 
The machine model you are seeing in PartMaker’s Advanced Simulation is a 
parametrically defined model of the machine you are programming.  As it is based 
on parametric approximations, it may not simulate your machine exactly the way it 
looks.  The limitations you may find at this point are: 

Multiple Tool Stations  
Multiple Tool Stations only applicable to the tools on the Turret. A Multiple Tool 
Station is the station on the turret that has more than one tool with the same Tool 
Number defined in Tool Data Dialog. During Advanced Simulation only one tool on 
the tool stations is shown. Therefore the tools that belong to the multiple tool 
station will be switched on the Turret based on the sequence in the Process Table.  

Non-Standard Machine Architectures 
PartMaker Advanced Simulation may not support certain elements of Swiss-
machines with irregular architectures at this time.  Such architectures may include 
machines with an “L-shaped gang”, attached end working and back working arms 
and machines where the sub-spindle is mounted on a turret.  

Please consult PartMaker Technical Support for more information on any limitations 
you may encounter with respect to Advanced 3D Machining Simulation. 

Full Machine Simulation Limitations 
The machine model you are seeing in PartMaker’s Full Machine Simulation is a 
realistic model of the machine you are programming.  The limitations you may find 
at this point are: 

Material Control Process Simulation 
PartMaker Full Machine Simulation does not support the simulation Material Control 
Processes (MCP) as inserted under the Job Optimizer menu. These MCP actions 
include grippers on the turret and tailstocks.  
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Appendix A: Materials 
PartMaker Material Library 

This appendix contains a list of all material files and their abbreviations. 

File Description 

ALU_ALLC.MDB Aluminum Alloy, Cast 

ALU_ALLW.MDB Aluminum Alloy, Wrought 

CARBIDES.MDB Machinable Carbides  

CHNICKEL.MDB Chromium-Nickel, Alloy 

COP_ALLC.MDB Copper Alloy, Cast  

COP_ALLW.MDB Copper Alloy, Wrought 

IRON_DUC.MDB Ductile Iron, Cast  

IRON_GRC.MDB Gray Iron, Cast 

LEADALLC.MDB Lead Alloys, Cast  

MAG_ALLC.MDB Magnesium Alloys Cast 

MAG_ALLW.MDB Magnesium Alloys Wrought 

NICKELWC.MDB Nickel Alloys, Wrought and Cast 

ST_ALLOW.MDB Alloy Steels, Wrought 

ST_CARB.MDB Carbon Steels, Wrought 
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File Description 

ST_FMCAW.MDB Free Machining Carbon Steel, Wrought 

ST_FMSTW.MDB Free Machining Stainless Steel, Wrought 

ST_STAIC.MDB Stainless Steel, Cast 

ST_STAIW.MDB Stainless Steel, Wrought 

ST_STRUW.MDB Structural Steels, Wrought  

ST_TOOLW.MDB  Tool Steel, Wrought 

THERMOPL.MDB Thermoplastics 

TIN_ALLC.MDB Tin Alloys, Cast 

TIT_ALLC.MDB Titanium Alloys, Cast 

TIT_ALLW.MDB Titanium Alloys, Wrought 

ZINCALLC.MDB Zinc Alloy Cast 
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Appendix B: Family of Parts 
Programming Tutorial 
Introduction 

This tutorial will teach you how to use PartMaker’s Family of Parts Programming 
Feature. 

PartMaker Version 4.6 and higher features a unique Family of Parts Programming 
(FOP) capability, which greatly speeds CNC programming for parts created from 
tabulated drawings.  This feature allows a programmer to program one part in a 
family and then automatically substitute any variable parameters by manipulating a 
separate file containing parameter definitions.  A virtually unlimited number of 
parameter files (*.prm files) can be defined by the user.  

FOP is an available option with every PartMaker product, namely, PartMaker/Mill, 
PartMaker/Turn, PartMaker/Turn-Mill and PartMaker/SwissCAM. It applies to Turning 
as well as Milling faces. 

 The steps presented in this tutorial are carried out in PartMaker 
SwissCAM but can be used in any PartMaker application. 

Sequence of Steps for Family of Parts Programming 
The steps outlined below describe the sequence in which you should approach 
programming Families of Parts from tabulated drawings.  This programming tutorial 
follows the sequence of steps below in creating a typical family of parts. 

You can use this page as desk reference when programming a Family of Parts. 

1 Create Part Geometry for one part in the family using actual numbers.  It 
is not critical which part number in the family you choose. 

2 Setup PartMaker Databases appropriately, i.e. make sure all tools, 
materials and cycles files for the part have been set appropriately 

3 Assign part features to your geometry.  When doing so, make sure to 
assign toolpaths by snapping to existing geometry.  If you do not snap tool 
paths to existing and parameterized geometry, they will not be updated 
when you regenerate other parts in the family. 

4 Create the appropriate Parameter Files (*.prm) for each part in the 
family.  Each Parameter File contains the variable definitions for each part in 
the family. 

5 Setup PartMaker for Parametric Input by clicking the Parametric Input 
box in the  Family of Parts section of the Preferences dialog which can be 
found under the View menu. 

6 Parameterize your part by assigning variables to parametric geometric 
elements and part features such as thread pitch and hole depth. 

7 Set Part Boundaries Parametrically by choosing Set Parametric 
Boundaries from Family of Parts Programming accessed from the Edit Menu. 

8 Update Each Part in the Family by opening the respective Parameter File 
by choosing Open Parameter File from Family of Parts Programming, then 
choosing Apply Parametric Dimensions. 

9 Regenerate NC Code for each part in the family by choosing Generate 
Process Table from the Job Optimizer menu and then choosing Generate NC 
Program from the Job Optimizer menu. 
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Getting Started 
The blue print below represents a typical parametric part.   

 
 

Part # A B C D E F P/Pitch 
50-100 0.25 1.0 1.5 25 0.4 3.0 0.05 (20) 
50-200 0.25 0.8 1.0 15 0.38 2.5 0.03 (30) 
50-300 0.1875 0.7 0.75 25 0.3 2.0 0.05 (20) 
50-400 0.2 0.5 0.6 30 0.3 1.5 0.1 (10) 
50-500 0.3125 0.4 0.5 35 0.35 1.25 0.04 (25) 

When you complete this tutorial, you will have parts that looks like the picture 
below: 
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Create Part Geometry 
The first step in programming a part in a family of parts is to create the part 
geometry.  When doing so, you should pick one part number from the family.  In 
this case, the Part #50-100 in the table on page B-2 will be used. 

1 Double click on the SwissCAM icon on your desktop or choose SwissCAM 
from the PartMaker Group accessed through Programs under the Windows 
Start button. 

2 You will then see the Setup definition dialog box. 

3 Enter the enter the parameters listed below in the appropriate fields: 

• Length (L): 3.0 • OD: 0.4 

• Excess Stock (E): 0.0
1 

• ID: 0.0 

• GB Length (l): 1.0 • GB Dia (d): 0.75 

• Tool Change X(Xc): 2.8 • Tool Change Z (Zc): 0.0 

The setup dialog will then appear below.  

 
4 When you are satisfied that your Setup dialog appears as the one above, 

click the <Apply> button. This will apply the parameters to the current Face 
Window.  Click the <Close> button to close the Setup dialog. 

5 In the CAM Face Window, choose Show Axes from the View menu.  This 
will display the horizontal and vertical axis lines which will help you create 
the geometry. 

6 Click on the CAD/CAM switch in the lower left-hand corner of the window. 
The icon will change its appearance from cutting tools to a pencil. 

7 Select the Connected Lines Icon from the drawing icons on left side of the 
Face Window. Here, you will draw the part in the print on the second page 
of this chapter by plotting ZX coordinates, using the ZX Snap Mode from 
the Snap Modes icon bar at the top of the screen.  

After selecting the ZX Snap Mode two data entry fields will appear in the 
lower left hand corner of the Face Window.   
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Now enter the ZX coordinates as shown below, pressing <Enter> after 
each: 

default 0.25 

1 default 

default 0.4 

3 default 

default 0 

After entering these coordinates, you should have a drawing which appears as 
the profile below: 

 
8 You will now place the diagonal line represented by the “D” dimension on.  

To do so, select the Line on an Angle icon and select the End of Line snap 
mode.  

When doing so, you will be prompted to Select end point of line or arc.  
Drag your cursor into place as shown below and click the left mouse button. 

 
You will now be prompted to enter an angle for this line.  At the prompt 
enter a value of 155 (i.e. 180 – 25) and press <Enter>. 

Move your cursor so the arrow is on the line as shown below and click the 
left mouse button. 

 
Having done so, you will now have a drawing which appears as shown below. 

 
Now select the Remove icon and click the scissors on lines 1 and 2 in the 
picture below.  

 
After having done so, your geometry will appear as shown below: 

 

 Note: When programming Families of Parts, you SHOULD NOT mirror 
geometry for turning features about the Z-axis.  Doing so will cause the 
lower half of your part geometry to look derformed when you generate 
other parts in the family.  Alternatively, you could also parameterize the 
lower half of your part geometry (though this would entail additional 
work).  Parameterizing geometry will be discussed in Step 5. 
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Setup PartMaker Databases 
The second step in programming a part in a family of parts is make sure the proper 
Tools, Materials and Cycles have been created and loaded in PartMaker. 

1 Open the Tools file by choosing Open Tools File from the File menu. 

2 From the Family_of_Parts directory, choose shaft_inch.tdb and click <OK>. 

 
3 Open the Cycles file by choosing Open Cycles File from the File menu. 

4 From the Family_of_Parts directory, choose shaft_inch.cdb and click <OK> 

. 

5 Open the Materials file by choosing Open Material File from the File menu. 

6 Choose st_fmstw.mdb and click <Open> 

.  
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Assign Part Features 
Once you have created your part geometry and loaded the appropriate tools, 
materials and cycles files, you are ready to assign part features to your geometry.   

 Note: When programming Families of Parts, it is important to always assign 
part features to your part by snapping to geometry instead of using the ZX 
Snap Mode.  Tool paths not associated with geometry will not be rescaled 
when updated for other parts in a part family.  

1 Before assigning the facing operation to the part, it is necessary to create 
the geometry to which the facing tool path will be assigned. To do so, while 
still in the CAD Mode, choose the Line Through Two Points and ZX Snap 
Mode.  

Now enter the ZX coordinates as shown below, pressing <Enter> after 
each: 

(0,.4) 

(<default>,0) 

After having done so, your geometry will appear as shown below: 

 
2 Click on the CAD/CAM switch to return to the CAM mode and create the 

part feature for the facing operation by choosing New Profile Group from 
the Part Features menu. 

a From the Strategy menu, choose Contouring.  

b From the Tool Location menu, select Out.  

c From the Tool Orientation menu, select Right. 

d Click the Select Tools button and allow PartMaker to select the 
appropriate tool.  

e In the field called Group Name, enter Face Off. Your dialog should now 
appear as shown below: 

 
Click Apply and Close. 
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Now that you have defined the machining operation to be used, you must tell 
PartMaker where to place the tool path: 

1 From the left-hand side of the screen select the Define Profile icon.  

2 From the top of the screen, select the End of an Element snap mode.  

3 Click your cursor at points 1 and 2 below: 

 
Your completed profile should appear as below: 

 
4 Click the Selection icon to bring yourself to a home or neutral position.  

Before moving on, save your work! Do so by selecting Save from the File menu or 
using the shortcut key <Ctrl + S>. Give your job file a name you will remember. A 
good job file name for part families is Master. 

Next, you will program the first outside diameter turning feature. 

1 Create the first OD Turning tool path by choosing a new color and selecting 
New Profile Group from the Part Features menu. 

a From the Strategy menu, choose Contouring. 

b From the Tool Location menu, select Out. 

c From the Tool Orientation menu, select Right. 

d Click the Select Tools button and allow PartMaker to select the 
appropriate tool.  

e In the field called Group Name, enter OD Turn. Your dialog should now 
appear as shown below: 
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Now that you have defined the machining operation to be used, you must tell 
PartMaker where to place the tool path: 

2 From the left-hand side of the screen select the Define Profile icon. 

3 From the top of the screen, select the End of an Element snap mode.  

4 Click your cursor at points 1,2 and 3 below: 

 
Your completed profile should appear as shown below: 

 
Next, you will program the outside diameter threading feature. 

1 Create the OD Threading tool path by choosing a new color and selecting 
New Profile Group from the Part Features menu. 

a From the Strategy menu, choose Threading. 

b From the Tool Location menu, select Out.. 

c Select Chamfer on Exit from the Toolpath Options drop dop list.  

d Specify the pitch as 0.05. 

e Click the Select Tools button and allow PartMaker to select the 
appropriate tool.  

f In the field called Group Name, enter OD Thread. Your dialog should 
now appear as shown below: 

 
2 From the left-hand side of the screen select the Define Profile icon. 

3 From the top of the screen, select the Closest Intersection snap mode.  

4 Click your cursor at points 1 and 2 below: 

 
Your completed profile should appear as shown below: 

 



 

Copyright @2014 Delcam Ltd  User Guide B-9  

 

Next, you will program the drilled hole. 

1 Create the drilled hole by choosing a new color and selecting New Hole 
Group from the Part Features menu. 

a Uncheck the Through Hole box 

b From the Major Cycle Operation drop down menu, choose Drill 

c Enter .1 in the Diameter field 

d Enter .01 in the Chamfer field 

e Enter 1.5 in the Nominal Depth field 

f Click the Cycle button and allow PartMaker to select the appropriate 
cycle.  

Your completed Hole Group Parameters dialog should now appear as shown 
below: 

 
2 Your completed profile should appear as shown below: 

 
Next, you will program the second outside diameter turning feature. 

1 Create the second OD Turning tool path by choosing a new color and 
selecting New Profile Group from the Part Features menu. 

a From the Strategy menu, choose Contouring. 

b From the Tool Location menu, select Out. 

c From the Tool Orientation menu, select Right. 

d Click the Select Tools button and allow PartMaker to select the 
appropriate tool.  
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e In the field called Group Name, enter 2nd OD Turn. Your dialog should 
now appear as shown below: 

 
2 From the left-hand side of the screen select the Define Profile icon. 

3 From the top of the screen, select the End of an Element snap mode.  

4 Click your cursor at points 1 and 2 below: 

 
Your completed profile should appear as shown below: 

 
Finally, you will program the cut-off operation. 

When creating a cut-off operation using PartMaker’s Family of Parts programming 
feature, you will need to assign the part feature to the geometry instead of having 
PartMaker do so automatically for you as you would in conventional use of the 
software. 

5 Create the Cut-off tool path by choosing a new color and selecting New 
Profile Group from the Part Features menu. 

a From the Strategy menu, choose Cut-Off 

b In the Start X Point (Xs) enter .4/2 

c Click the Select Tools button and allow PartMaker to select the 
appropriate tool.  

d In the field called Group Name, enter Cut-off.  
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Your dialog should now appear as shown below: 

 
Your completed part should appear as shown below: 

 
6 Before continuing, choose the Selection icon a delete the tool path that has 

been automatically applied to the geometry. 

7 Using the Profile icon and End Of Element Snap Mode, reapply the tool path 
to the geometry by clicking at the start and end of the cut-off tool path.  
Your completed part will appear as shown below: 
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Creating Parameter (*.prm) files 
Once you have completed programming the “master” part in the family, you must 
now take a step back and setup files containing parameter definitions for each part 
in the family. These files can be created in any word processing program and then 
saving files with *.prm extension.  In this example, Notepad (which comes loaded 
on every Windows operating system) will be used 

1 Create the first parameter for the “master” part that has already been 
programmed.   

Note:  To make creating the first parameter file faster, start by 
manipulating an existing file, either from a part family you have made 
before or from the parameter files which came standard with your 
PartMaker installation. 

2 From the Start button on your Windows desktop, choose Accessories and 
launch the Notepad application. 

3 In Notepad, from the File menu, choose Open.  In the Open dialog, choose 
All Files *.* from Files of Type as shown below: 

 
4 Choose an existing parameter file . In this example, open the file titled 42-

100_inch.prm that can be found in the Family of Parts directory (located 
in the root directory of the PartMaker module you are working with.) 
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5 Edit the parameter file to reflect the parameters being used in the current 
Family of Parts. Replace the parameter values with those you have used in 
the creation of part 50-100 above. 

 Note:  All text and characters in parenthesis are comments and will not 
affect programming.  Comments will help you remember which 
parameters correspond to various features of your part. 

Once you have defined the parameters for the part, save your Parameter File as 
50-100.prm by choosing Save As from the File menu as shown below: 

 
6 Click <Save> to save your file.  The saved parameter file for 50-100 should 

appear as shown below: 

 



 

B-14 PartMaker  Copyright @2014 Delcam Ltd 

 

7 Having created the first parameter file, create a file for all other parts in the 
family by simply replacing parameter values and saving a *.prm file for each 
part in the family.  The parameter values for each part for this exercise can 
be found on page 2 of this appendix.  When finished, you should have five 
parameter files as shown below: 

 

Setup PartMaker for Parametric Input 
In order to be able to apply parametric dimensions to the part, you must enable 
Parametric Programming. 

1 Choose Preferences from the View menu and check the Parametric Input 
box as shown below: 

 
2 Once you have checked Parametric Input, click <OK>. 
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Parameterize Your Part 
Now that all the appropriate parameter files have been created, you can assign 
parametric variables to the master part in the family.  Before proceeding, make sure 
all parameter files have been saved and are closed. 

1 Click on the CAD/CAM switch to return to the CAD mode.  Any part 
parameterization exercise should always start in the CAD mode.   

2 Double click on the line segment drawn vertically along the face of the part 
as shown below: 

 
Doing so will allow you to access the Parametric Line Info dialog.  Define 
the parametric relationship as shown below: 

 
3 Once the dialog appears as above, click <OK>. 

The next geometric element to be parameterized will be the thread as shown 
below: 

 
4 Double click on the horizontal line segment along which the thread is applied 

to access the Parametric Line Info dialog.  Define the parametric 
relationship as shown below: 

 
5 Once your dialog appears as above, click <OK>. 

Note:  In PartMaker, all Z dimensions are programmed in negative. 
Whenever performing mathematical operations on parameters, always 
make sure to use parenthesis as shown here.  PartMaker observes 
standard mathematical order of operations for multiplication, division, 
addition, subtraction and the application of trigonometric functions. 
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The next geometric element to be parameterized will be the chamfer as shown 
below: 

 
6 Double click on the diagonal line segment of the chamfer to access the 

Parametric Line Info dialog.  Define the parametric relationship as shown 
below: 

 
Notice the use of the use of trigonometric relationships in Family of Parts 
programming. PartMaker data entry fields can accept trigonometric functions. 
Once your dialog appears as above, click <OK>. 

The next geometric element to be parameterized will be the largest horizontal 
diameter as shown below: 

 
7 Double click on the horizontal line segment of the OD to access the 

Parametric Line Info dialog.  Define the parametric relationship as shown 
below: 

 
8 Using the Copy and Paste functions from the Edit menu (standard windows 

accelerator keys Ctrl + C and Ctrl + V) you can copy and paste parametric 
relationships from one dialog to another. Once your dialog appears as above, 
click <OK>. 

The next geometric element to be parameterized will be the geometry along 
which the cut-off operation is defined: 
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Double click on the diagonal line segment of the chamfer to access the 
Parametric Line Info dialog.  Define the parametric relationship as shown 
below: 

 
Once your dialog appears as above, click <OK>. 

9 Click on the CAD/CAM switch to return to the CAM mode.  The 
parameterization exercise will be completed by applying parametric 
dimensions to programmed part features.   

Note: In Machining Function Face Windows of Type Turn, in the Profile 
Group Parameters dialog, Strategy types Threading and Cut-off allow 
for parametric input. In Milling Machining Function Face Window, all 
Profile Group Parameters cycles accept parametric input.  The Hole 
Group Parameters dialog also accepts parametric input. 

When using Parametric Input you will notice the appearance of Parametric 
Input icons. Clicking on these icons allows you to enter parametric data for 
part features. 

Double click on the OD Thread Group Symbol on the right hand side of the 
screen to enter the Profile Group Parameters dialog for threading as 
shown below: 

 
10 Click on the Set Parametric Pitch icon to insert a parametric value for 

Thread Pitch as shown below: 

 
11 Once your dialog appears as above, click <OK>.  Click <Close> in the 

Profile Group Parameters dialog to return to the CAM Face Window. 
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Next, parameterize the depth of the hole programmed on centerline.  To do so: 

12 Double click on the group symbol for the on-centerline drilled hole.   

 
13 Click on the Set Parametric Pitch icon to insert a parametric value for Z 

Depth as shown below: 

 
14 Once your dialog appears as above, click <OK>.  Click <Close> in the 

Profile Group Parameters dialog to return to the CAM Face Window. 
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Set Part Boundaries Parametrically 
The final step in setting up a parametric part is to set the part boundaries 
parametrically. To do so: 

1 Choose Family of Parts Programming from the Edit menu. 

2 Choose Set Parametric Boundaries… from the Family of Parts Programming 
menu as shown below: 

 
3 Complete the Set Parametric Boundaries dialog as shown below: 

 
Once the dialog appears as above, click <OK> to return to the CAM Face 
Window. 
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Update Each Part in the Family 
You have now completed setting up your master part and our now ready to 
automatically program each other part in the family.  To automatically reprogram 
other parts in the family: 

1 Choose Family of Parts Programming from the Edit menu. 

2 Choose Open Parameter File... from the Family of Parts Programming menu 
as shown below: 

 
Select the parameter file for the part you would like to program.  In this case, 
choose 50-500.prm as shown below: 

 
 Once the dialog appears as above, click <Open> to return to the CAM Face 
Window. 

3 Choose Apply Parametric Dimensions... from the Family of Parts 
Programming menu as shown below: 

 
You should now see your part change size on screen. 

Regenerate NC Code 
You can update your NC program for each part in the family by regenerating the 
Process Table and then choosing Generate NC Program. 
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Appendix C: Programming Directly on a 
Solid Model 
Introduction 

This document describes the process of programming directly on a Solid Model in 
PartMaker Turn-Mill, SwissCAM and Turn Version 9.1 and higher. 

 NOTE: The steps presented in this tutorial are carried out in PartMaker 
SwissCAM but can be used in any PartMaker application. 

Key Definitions 
Part Coordinate System (PCS):  A part coordinate system (PCS) is the coordinate 
system in which a solid model is oriented. Before any programming exercise begins, 
you should always set the PCS to be the same as the coordinate system of the 
machine you are programming.  You can use the Edit Coordinate System dialog 
to place the origin on the front of the part and set the axes to be coincident with the 
machine’s coordinate system. Being set initially the PCS should not change during 
the programming session. 

 
Face Coordinate System (FCS): This is a coordinate system with two axes in the 
Face Plane and the third axis perpendicular to the Face Plane. The Face Plane is a 
plane in which the tool paths in the active PartMaker Face Window are created. Each 
Face Window can have its own Face Plane. The Face Plane must be set in the 
correct place to properly program on the Solid Model.  The Face Plane can be 
displayed using the Show Face Plane icon. The Face Plane can be set and 
manipulated using the Define Face Plane dialog. 
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Face Plane Icons for Solid Model: 

 
Show Profiles and Holes on Solid Model: You will need to have this feature 
activated to program directly on the Solid Model. This will allow you to view the 
Profiles as they are created. 
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Solids Programming Tutorial 
This tutorial is designed to help you learn the steps to follow for using PartMaker 
SwissCAM, Turn-Mill and Turn to program on a Solid Model. 

The complete finished job files can be found in the following directories as incidated: 

SwissCAM   C:\PartMaker \PM-Swiss\Solids_Programming_Tutorial 

Turn-Mill  C:\PartMaker \PM-TM\Solids_Programming_Tutorial 

Turn  C:\PartMaker \PM-Turn\Solids_Programming_Tutorial 

How you will create the Sample part 
Here are the major steps you will follow to create the Swiss tutorial part: 

√ Start PartMaker 

√ Open Sample Program and Review 

√ View tool information for the part 

√ View cycle information for the part 

√ Select a material for the part 

√ Open a new Face Window 

√ Create Profile and Hole Groups 

√ Extract Information from the Solid Model 

√ Create a Process Table 

√ Simulate the Machining Process 

√ Generate an NC Program 
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The picture below shows the part to be programmed in this tutorial. 

 
 

 

When you complete this tutorial, you will have a part that looks like the picture 
below. 

 

Getting Started 
The machining functions used in this tutorial are as follows:  

Turn 
Use turning tools to perform a variety of turning operations including Facing, 
Threading, Grooving, Drilling, Tapping and Pick-off. 

Mill ZY 
Use an end mill to create a set of flats. 

Programming on the Solid Model can be accomplished for almost every Machining 
Function needed. In most cases you will not need to work in the 2D Face window at 
all. 

Now you will look in detail at the steps necessary to program a part. 
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Starting PartMaker 
1 Double click on the PartMaker SwissCAM icon 

2 You will see the Setup definition dialog box shown below. Click the <Close> 
button. 

This dialog is explained in greater depth starting on page 8 of this guide. 

 

View the Finished Sample 
1 Use the Open All Files Command from the File Menu. 

2 You will find the Job Files in the Follwing Directories. 

SwissCAM C:\PartMaker\PM-Swiss\Solids_Programming_Tutorial 

Turn-Mill C:\PartMaker\PM-TM\Solids_Programming_Tutorial 

Turn C:\PartMaker\PM-Turn\Solids_Programming_Tutorial 

 Note: This will also open the Sample Tools and Cycles files for you to use 
when you create your own Part. 

3 Look through the Sample Job file and familize yourself with the Profiles and 
Hole Groups. 

4 When Ready, choose New Job from the File Menu. 
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Select a Material for the Part 
The work piece in this exercise will be machined from Free Machining Stainless 
Steel, Wrought. To load this material: 

1 Choose Open Material File from the File menu. 

2 Choose st_fmstw.mdb as shown below and click <Open>. 

 
 

You have now loaded the tools, cycle, and material files that were previously 
developed for the Solid Model Programming Sample. 



 

Copyright @2014 Delcam Ltd  User Guide C-7  

 

Importing a Solid Model 
1 Select the Import icon and select the X_T Parasolid Transmit Text File 

option. 

 
 

2 Choose the Swiss_Solids_Programming_Tutorial.X_T file and click <Open> 
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Setting up the First Face Window 
In this section, you will set up the Face Window for the turning operations on the 
main spindle. To do so: 

1 When Programming with a Solid Model, many items will be set automatically 
from the information obtained from the Solid Model. To import settings into 
the Set-up Window, you will need to define a faceplane. Select the Define 
Face Plane icon from the Solids Tool Bar. 

2 For Swiss and Turn-Mill parts, you should define your Face Plane at an Angle 
which will allow you to select the Points you will need for Turning in this first 
window. Check the Set Face Plane box. Choose Parallel to ZX Plane from 
the Drop Down Menu. Enter 45 into the Turning Plane Angle field and click 
the Set Boundaries checkbox. 

 
3 Click the <Preview> button to see the Face Plane on the Solid Model 

update. 

 
4 Click <OK> 
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5 Open the Set-up Window. Note the Part Length and OD were imported from 
the Solid Model. You should now make any changes required for your Setup 
dialog. Make the following changes to the Setup Dialog. 

 

Spindle: Main Spindle 

Stock: Bar 

Machining Function: Turn 

OD: 0.59055118 (For Stock Size) 

Excess Stock: .03 
 

Your Set-up Window should appears as below: 

 
6 Click <Apply> and <Close> 
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Programming a Face Operation 

1 Select the New Profile Group icon. 

2 Change the Following settings in the Profile Group Parameters dialog and 
Leads Out, Finishing dialog 

Strategy Turning 

Tool Location Face 

Tool Orientation Left 

Remove Check Roughing 

Check Finishing 

Lead Out Angle (A2) 90 Degrees (click Leads button) 

 
3 Click <Select Tools> and choose the OD Turn - 55 Turning Tool. 
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4 Name the Group Face. Your dialog should look like the following. 

 
5 Click <Apply> and <Close> 

6 You should now see a Facing Profile created on the Solid Model. 

 
7 To verify the tool path for the Profile Group, Select the Verify Work Group 

Toolpath icon. 

8 The Verify Options Dialog will now Display. Make sure to check the Option for 
Enable Verification on Solid Model. 

 
9 Once the tool path has been verified, you can hide by using the Hide Work 

Group Toolpath icon 
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Programming a Tapping Cycle Operation 
1 Choose a new color for this operation in the upper right corner of the screen 

2 Select the New Hole Group icon. 

3 Select Tap from the Type drop down menu. 

4 Click the Extract Parameters from Solid checkbox. 

 
5 Click on the Major Hole Diameter. 

 
6 Click the <Extract> button to extract the feature data from the Solid Model: 
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7 Highlight and Select the 6-40 Tap Cycle. 

 
8 Click <Apply> and <Close> 

9 To verify the Profile Group, select the Verify Work Group Toolpath icon. 

10 The Verify Options Dialog will now Display. Make sure to check the Option for 
Enable Verification on Solid Model 

11 After Verifying the Tool Path, Click the Hide Every Tool Path icon to hide all 
verifications. 
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Programming a Turning Operation 
1 Choose a new color for this operation in the upper right corner of the screen. 

2 Select the New Profile Group icon. 

3 Change the following settings in the Profile Group. 

Cycle Type Turning 

X Finish .01 

Z Finish .01 

Check Finishing 

 

 
4 Click the <Select Tools> button and choose the OD Turn - 55 Turning Tool 

for both the Roughing and Finishing Operations. 
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5 Name the Group Turn. Your dialog should look like the following. 

 
6 Click <Apply> and <Close> 

7 Select Define Profile on Solid Model icon. The model will automatically 
section itself at the Angle chosen for the Face Plane.  

8 Next, choose the Edge Endpoint Snap Mode.  This will show the selectable 
points on the Solid Model as shown here. The points are numbered for the 
following instructions. 

 
9 Select Point 1 

10 Select Point 2 

 
11 Select the Horizontal Constraint icon. 

12 Select point 3 

 
13 De-select the Horizontal Constraint icon if needed. 
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14 Select point 4 

15 Select point 5 

 
16 Select ZX Coordinates Snap Mode icon. 

17 In the input field at the bottom of the screen, enter .625 into the X and 
press the <Enter> key to accept. 

 

 
18 Select the Selection icon. 

19 To verify the Profile Group, Select the Verify Work Group Tool path icon 

20 The Verify Options Dialog will now Display. Make sure to check the Option for 
Enable Verification on Solid Model.  The verification will appear as shown 
below: 

 
21 After Verifying the Tool Path, Click the Hide Every Tool Path icon to hide all 

verifications. 
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Programming a Grooving Operation 
1 Choose a new color for this operation in the upper right corner of the screen. 

2 Select the New Profile Group icon. 

3 Change the following settings in the Profile Group. 

Strategy Grooving 

Profile Shape General 

Check Roughing 

 

 
4 Click <Select Tools> and choose the OD Groove .0625 Grooving Tool  
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5 Name the Group Groove. Your dialog should appear as shown below: 

 
6 Click the <Apply> and <Close> buttons 

7 Select the Chain Profile on Solid Model icon. 

8 Select the Start Point of the profile. When choosing start point, click on the 
side of the point that you want the Chain to follow. This will determine the 
direction the chain will follow.  

 
9 Select End Point of the profile. 
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10 To verify the Profile Group, Select the Verify Work Group Toolpath  icon 

11 The Tool Path Verification Options dialog will now display. Make sure to 
check the option to Enable Verification on Solid Model. The verification 
will appear as shown below: 

 
12 After Verifying the Tool Path, Click the Hide Every Tool Path icon to hide all 

verifications. 
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Programming a Threading Operation 
1 Choose a new color for this operation in the upper right corner of the screen 

2 Select the New Profile Group icon 

3 Change the following settings in the Profile Group. 

 

Strategy Threading 

Pitch for 1/20 .05 

Acceleration Dst .1 

 
4 Click <Select Tools> and Choose the Thread Tool. 
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5 Name the Cycle Thread. Your dialog should look like the following: 

 
6 Click the <Apply> and <Close> button  

7 Select Define Profile on Solid Model icon. 

8 Choose the Edge End Point Snap Mode icon 

9 Select the Start Point of thread 

 
10 Select Edge Midpoint Snap Mode icon 

11 Select the Horizontal Constraint icon 
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12 Select End Point from bottom of groove area. 

 
13 De-Select the Horizontal Constraint icon 

14 Select the Selection  icon 

15 To verify the Profile Group, Select the Verify Work Group Toolpath icon 

16 The Tool Path Verifications Options dialog will now display. Make sure to 
check the Option for Enable Verification on Solid Model. The verification 
will appear as shown below: 

 
17 After Verifying the Tool Path, Click the Hide Every Tool Path icon to hide all 

verifications. 
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Programming a Cut Off Operation 
1 Choose a new color for this operation in the upper right corner of the screen 

2 Select the New Profile Group icon 

3 Change the following settings in the Profile Group dialog and Leads Out, 
Roughing. 

Strategy Cut Off 

End Point X .05 

Lead Out Line Length 0 

 

 
4 Click <Select Tools> and choose the Cut Off Tool .093 
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5 Name the Cycle Cut off. Your dialog should look like the following. 

 
6 Click <Apply> and <Close> 

7 The Profile will be created for you. 

 
 

8 To verify the Profile Group, select the Verify Work Group Tool path icon 

9 The Tool Path Verifications Options dialog will now Display. Make sure to 
check the Option for Enable Verification on Solid Model. 

 
10 After Verifying the Tool Path, click the Hide Every Tool Path icon to hide all 

verifications. 
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Programming a Milling Operation 
Note: This section only applies to PartMaker Turn-Mill and SwissCAM modules 

1 Select the Setup Dialog icon, then choose <New> to make a new Face 
Window. 

2 Change the Machining Function to Mill ZY Plane. Name the window Mill 
Flats. 

 
3 Click the <Apply> and <Close> button 

4 If you have not done so already, choose the Full Part View icon from the 
Solids toolbar to make sure you have a complete solid model shown and not 
a sectional view 

5 Select the Define Face Plane icon. 

6 In the Drop down Menu, choose Parallel to Selected Surface. 

 
7 Click on one of the Flats. Note Face Plane is set coincident with the Plane of 

the chosen flat. 

 
8 Click <OK> 
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9 Choose a new color from the colors pallet in the upper right hand corner of 
the screen 

10 Select the New Profile Group icon 

11 Change the Tool Position to Left 

12 Check the Extract Parameters from Solid check box as shown below: 

 
 

13 Uncheck the Roughing box so that  Finishing is checked 

14 Enter 0.5 in the Diam(d) field and click <Select Tools> 

 
15 With the Profile Group Parameters dialog open, click on the plane as 

shown below: 

 
16 Click the <Extract> button to extract the machining parameters directly 

from the model.   

17 Rename the Group to Flats 



 

Copyright @2014 Delcam Ltd  User Guide C-27  

 

18 The completed dialog will appear as shown below: 

 
19 Click the <Apply> and <Close> button. 

20 Choose the Define Profile on Solid Model icon 

21 Select the Edge Endpoint Snap Point icon 

22 Select the Start Point of the profile 

 
23 Select the End Point of the profile 
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24 Choose the Selection icon to end the profile 

 
 

25 To verify the Profile Group, select the Verify Work Group Tool path icon 

 
 

26 After Verifying the Tool Path, click the Hide Every Tool Path icon to hide all 
verifications. 
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Duplicating the Face Window 
Having programmed this milling path, you can now duplicate the window to create 
the second flat.  This can be done as follows: 

1 Open the Setup Dialog and click the <Duplicate> button 

2 Enter the following into the Duplicate Face dialog. 

Number of Copies 1 

Index Angle Increment 180 

The completed dialog should appear as shown below: 

 
3 Click <OK> 

4 Click the <Close> button to close the Setup dialog 

Generating the Process Table 
1 Choose the Generate Process Table icon 

2 Click <OK> for the Process Table Options 
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3 Your Process Table should appear as shown below: 

 

Simulating Machining in 3D 
Now that you have generated the Process Table, you can simulate the cutting of the 
part in 3D. To do so: 

1 Choose the Simulation icon to launch PartMaker’s 3D simulation 

2 Press the Start Simulation button to watch the part being machined in 3D 

3  Click the Show Finished Part icon to view the completed part: 
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Other Samples 

Turn Function Face Window Programming 
Describes Programming on a Solid Model in a Turn Function Face Window. This 
applies to PartMaker SwissCAM, TurnMill and Turn modules. 

Setting the Face Plane 
1 Open the Define Face Plane Dialog. 

 
2 Set Face Plane as required to be able to Select Points on this plane for the 

Profile. Note the features on the Part when setting and use the Preview 
button to preview the changes. 
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Creating the Profile Group 
Create Profile Group as Normal 

 
Selecting the Profile 

1 Select by choosing the Profile Points 

2 Choose the Define Profile on Solid Model Icon 

 
3 At this point you will see Red Points show on the Solid Model at the 

intersection of the Face Plane. Select these points to create your Profile. 
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4 Use the Snap Modes to choose the Profile Points on the Solid Model. 

 
5 Click on the Point to Start the Profile. 

 
6 Move the Mouse Curser to the Next Point of the Profile. There will be a 

Dotted Line indicating Profile and a Dot where next Point will be. Click to 
connect the profile to this Point. 

 
7 Continue selecting points for the Profile. 

 
8 Click the Selection icon when done. 
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Selecting by Chain 
You may chain a profile on a Solid Model by selecting the Chain Profile on Solid 
Model icon. 

To use this icon, you need to select the Starting Point and Direction.  

 Note: Depending on where you place the mouse curser, the starting point 
changes and the Direction Reverses. 

 
Select Endpoint of Chain. During Selection, a Dotted Line will indicate the Profile. 
Click the End Point to Finish Profile. 
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Using Horizontal and Vertical Constraints 
You can use the Horizontal and Vertical Constraints to Extend Profiles that may not 
have a Point to choose from on the Model. 

When selecting your Profile using the Define Profile on Solid Model icon, select 
either Horizontal or Vertical Constraint to lock the Profile in a Horizontal or 
Vertical move. 

 
1 Move the mouse curser over a Point that is not directly Horizontal or Vertical 

from the Currently Selected Point. You will see the Profile Extend to this point 
in a Horizontal or Vertical Line shown by a dashed line. 

 
2 Click the Point to Extend the Profile to this Point. 

 
3 Depress the Horizontal or Vertical Constant icon to turn off the constraint. 
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Creating a Hole Group 
1 Create New Hole Group Parameters dialog 

 
2 Check Extract Parameters from Solid. 

 
3 Select Major Cylinder for Hole on Solid Model. (Note: See Explanation at 

Bottom of Screen) 
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4 Click <Extract> 

 
Remove Check from Extract Parameters from Solid if editing of a Hole Group 
is required. 

5 Edit Hole Group as required 

6 Click <Cycle> and Select the cycle. 

 

 
7 Click <Apply> then <Close> 
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Milling Functions Face Window Programming 
Describes Programming on a Solid Model in Milling Functions Face Windows. This 
applies to PartMaker SwissCAM and Turn-Mill. 

Creating a New Profile Group (Mill ZY window shown) 
Setting the Face Plane 

1 Click the Define Face Plane icon to open the dialog. 

 
2 Choose desired method of Selecting the Face Plane. When choosing Parallel 

to Selected Surface, click on Surface to set as Face Plane. Use the Preview 
button to preview the changes. 

 

 
3 Click <OK> to accept Face Plane Setting. This will fill in the Set-up Window 

with the correct settings for the Face Plane. 
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Creating the Feature 
1 Create Profile Group as Normal 

 
2 Check Extract Parameters from Solid 
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3 Select Feature to Extract Properties from. 

 
4 Click <Extract>. This will extract the information to the Profile Group. 
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Creating the Profile 
1 Choose the Define Profile on Solid Model Icon 

 
2 Use the Snap Modes to choose the Profile Points on the Solid Model. 
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3 Click on the Cylinder Surface to select the center point as the Start of the 
Profile. 

 
4 Move the Mouse Curser to the Next Point of the Profile. There will be a 

Dotted Line indicating Profile and a Dot where next Point will be. Click to 
connect the profile to this Point. 
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5 Continue selecting points for the Profile until finished. 

 
6 Click the Selection Icon when done. 

 

Selecting by Chain 
You can chain a Profile on a Solid Model by selecting the Chain Profile on Solid 
Model icon. 

1 Select Starting Point and Direction  

 Note: Depending on where you place the Mouse Curser, the Starting 
Point changes and the Direction Reverses. 

2 Select Endpoint of Chain. During Selection, a Dotted Line will indicate the 
Profile. Click the End Point to Finish Profile 

3 You may use Horizontal and Vertical Constraints if required. 



 

C-44 PartMaker  Copyright @2014 Delcam Ltd 

 

Creating a Hole Group (Mill Diameter Index Face window shown) 
Setting the Face Plane 

1 Open the Define Face Plane Dialog. 

 
2 Choose desired method of selecting the Face Plane. When choosing Tangent 

to Selected Cylinder, click on the Cylinder to set as Face Plane. Use the 
<Preview> button to preview the changes. 

 

 
 

3 Click <OK> to accept Face Plane Setting. This will fill in the Set-up Window 
with the correct settings for the Face Plane. 
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Creating the Feature 
1 Create New Hole Group Parameters. 

 
2 Check Extract Parameters from Solid 

 
3 Select Major Cylinder for Hole on Solid Model. (Note: See Explanation at 

Bottom of Screen) 
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4 Click <Extract> 

 
5 Remove the check from the Extract Parameters from Solid box if editing 

of a Hole Group is required 

6 Edit Hole Group as Required 

7 Click <Cycle> and select a cycle 

 
8 Click <Apply> then <Close> 
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Selecting Single Holes 
1 Choose the Single Hole on Solid Model Icon. 

 

 
2 Select each hole that will be drilled. 
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Selecting by Chain 
1 Choose Chain Holes on Solid Model icon 

 
2 Select First Hole, PartMaker will then automatically select holes with the 

same feature in the Face Plane. 
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Appendix D: Practical Applications of 
Turn-Mill Machining Function Face 
Windows for Live Tooling Operations  
Introduction 

This appendix to the PartMaker Turn-Mill User Manual is intended to give you, the 
user, a more in-depth and practical understanding of applying PartMaker’s 
Machining Function Windows for use with Live Tooling Operations.  This Appendix is 
meant to supplement the information provided in Chapter 2 of your PartMaker Turn-
Mill Programming Manual titled “PartMaker Fundamentals.” 

This chapter will explain the following: 

 What types of Part Features Should be created in each Machining Function 
Face Window 

 Which Hole Group and Profile Groups Parameters options are available in 
each Machining Function Face Window 

 Which Graphics Icons are available in each Machining Function Face Window 

 How Part Features should be created in each Machining Function Face 
Window 

Many of the part examples provided in the pages to follow can be found in the 
various sub-directories labeled with machine names in the Sample Directory found 
in the Pm-Swiss directory in which PartMaker Turn-Mill is installed.  The file name 
and path for each file and specific *.job, *.tdb and *.cdb are provided where 
relevant for each example. 

Machining Function Selection 
Turn-Mill Machines are capable of performing a full set of turning operations: facing, 
turning, grooving and threading. Many Turn-Mills are also capable of performing 
various types of milling as well as drilling holes on different surfaces. Multiple 
spindles in which such operations can be performed simultaneously further increase 
the machines' productivity and complexity.  

Milling capabilities of a Turn-Mill vary significantly and can include:  

 Index milling/drilling 

 Milling on a selected ZX plane 

 Polar milling on the face of the part 

 XZC continuous milling on cylindrical surfaces  

 Milling interpolation in the YZ plane 

PartMaker CAM Software from PartMaker, Inc. applies a Patented ‘divide and 
conquer’ programming strategy to simplify programming of Turn-Mill Centers. 

PartMaker helps you separate a complicated part surface into a manageable set of 
faces that may be either planar or rotational in nature. All features are represented 
by a surface relative to which a set of part features is referenced.  

On each face, a set of features may be machined using a variety of cutting tools. 
The software takes advantage of the Microsoft Windows operating system, which 
allows multiple windows to be displayed and accessed simultaneously.  
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A specific machining function such as turning, polar milling or cylindrical milling is 
assigned to each face. PartMaker lets you create a dedicated window that contains 
a workspace for the graphic representation of face features.  

A dialog box associated with each Face Window shows you the type of machining 
to be performed on a face, the location of the face boundaries and parameters 
defining the positioning of the face relative to the machine coordinate system.  

Getting Started: The Setup Dialog 
PartMaker employs a programming methodology whereby each machine motion 
type can be separated into a different window dedicated to a specific machining 
function. Every one of these windows is known as a Face Window. Once created, 
each Face Window can be accessed from the Window menu. 

Once divided into much smaller, similar motion components, programming of a 
multi-axis Swiss-type lathe becomes a much easier task. To best explain how 
PartMaker handles this task, it is necessary to first explain how each of these 
individual-machining functions is defined.  

Selection of the various machining functions is carried out in the Setup dialog. The 
Setup dialog can be accessed from the View menu or by clicking on the shortcut to 
the Setup dialog located in the upper left hand corner of your Face Window. On 
Startup, or when accessing the Setup dialog for the first time, you will see the 
following dialog. Some of the important components of this dialog are explained 
below: 

 
1 The Main Spindle and Sub Spindle radio buttons allow you to select whether 

the programming carried out in a particular Face Window is being machined 
on the Main or Sub-Spindle. 

2 The Tool Change X and Z positions for a particular machine should be 
entered here. 

3 The Machining Function drop down menu allows you to select the type of 
machining motion being executed in a particular Face Window. The 
machining motions that can be defined in each selection from the Machining 
Function drop down menu are explained below. 
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4 The List of Face Windows displays the list of Face Windows currently 
existing for a given job. 

5 The Rename To: field allows you to name the Face Window you are 
working with. Existing Face Windows can be selected from the Window 
menu based on the names assigned to them in this field of the Setup dialog. 

6 Clicking the function buttons shown in the Setup dialog with the left-hand 
mouse button does the following: 

<Apply> Accepts or applies any new parameters or data 
entered into the various fields in the Setup dialog, and 
the dialog remains open. 

<New> Creates new face windows of different machining 
function types or on different spindles, adding to the 
List of Face Windows 

<Close> Accepts or applies any new parameters or data 
entered into the various fields in the Setup dialog, and 
closes the dialog. 

<Delete> Deletes the current selection from the List of Face 
Windows 

The various selections under the Machining Function drop down menu are 
explained on the following pages. 

7 The Notes fields allow the user to enter notes about a specific job. These 
notes can be directly output into the NC program to improve documentation. 
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Machining Function: Turning  
The Turn machining function uses conventional turning tools moving in the X and Z-
axes. Motion is programmed using X and Z coordinates. This machining function 
includes on centerline drilling where a drill is held stationary while the spindle 
holding the part rotates. All drilled holes must therefore be on the rotational 
centerline of the part.    

The picture below shows the appearance of the Setup dialog when performing 
Turning on the Main Spindle.  

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before machining 

Excess Stock (E) Rough stock left for facing on the front of the part 

Work Shift (l) The amount the material is exposed from the chuck 
face 

Work Offset The work offset assignment for the spindle 
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Machining Function: Mill XY Plane 
The Mill XY Plane machining function supports machining operations on the face of 
the part using the Y-axis capability of the machine. G-code output will be generated 
in the form of X and Y coordinates. Features that can be created by using this Face 
Window include off-center holes on the face of the part, pockets on the face of the 
part, and contours (such as CAM shapes) on the face of the part. 

Programming of this machining function requires that your Swiss-type lathe have a 
programmable Y-axis and that you have purchased the PartMaker Y-axis milling 
option. 

 
 

Index Angle (C) Orientation angle of the stock to achieve the 
desired face position 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining  
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Types of Features Created in Mill XY Machining Function Window 
The Mill XY window uses a Z-oriented “live” tool. There is no polar C-axis movement 
(the C-axis indexes and locks). 

 Note: Your machine must have Y-axis capability and also needs to have 
ample travel to machine in the negative quadrant of the part. 

The features shown on the parts below are representative examples of features that 
can be created in the Mill XY Window.  The *.job, *.cdb and *.tdb files used to 
create some of these parts can be found in the Samples directory which was 
installed when you initially installed PartMaker Turn-Mill.  Where relevant, the 
locations of these files have been provided. 

 
Figure 1: Milled Slots Figure 2.: Milled Pocket and Engraving 

(Relevant files: C:\PartMaker\Pm-
TM\Samples\Hardinge_TT-65\ TT-
65.job, TT-65.cdb, TT-65.tdb) 

(Relevant files: C:\PartMaker\Pm-
TM\Samples\Hitachi-
Seiki_HiCell\HiCell.job, HiCell.cdb, 
HiCell.tdb) 

  

 

Figure 3: Off-Center Holes Figure 4: Milled Cam 
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Part Features Dialogs Available in Mill XY Machining Function 
Both the New Hole Group and New Profile Group commands from the Part 
Features menu can be used in the Mill XY Machining Function Face Window.  

The Hole Group Parameters dialog will appear as shown below. Notice the 
orientation of the tool is in Z. 

 

Through Hole Check this box if you are drilling through the part 

Major Cycle Operation Indicates the major cycle operation as specified in 
the cycles database 

Diameter (d) Diameter of the tool, which is the major cycle 
operation. 

Chamfer(c) Specifies how much chamfer per side is needed 

Z_Surf (S) Establishes your Z-zero work plane 

Z_Rapid (R) Specifies how much clearance the tool will rapid 
to in front of your Z_Surf 

Z_Clear (C) Specifies the distance between the bottom tip of 
the tool and the part surface when a tool starts 
feeding into the part. 

Nominal Depth (D) The depth of the operation to be performed 
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The Mill XY machining function can be used to create both Contours and Pockets.  
Below, a Contour Mill cycle with Tool Position On centerline is shown.  To create a 
pocket, choose Pocket Mill from Strategy drop down menu. 

 

Strategy Indicates the type of feature to be milled, either a 
Contour Mill or Pocket Mill 

Tool Position 
For Contour Mill indicates the tool position during 
cutting, such as Left (climb milling), Right 
(conventional milling) or On (on centerline milling) 

Z_Surf (S) Establishes the Z-zero work plane i.e. a value 0 
indicates the face of the part, a negative value 
indicates a Z-zero along the length of the part 

Z_Depth (D) The depth of the operation to be performed 

Z_Rapid (R) Specifies how much clearance the tool will rapid to in 
front of your Z_Surf. 

Z_Clear (C) Specifies the distance between the bottom tip of the 
tool and the part surface when a tool starts feeding 
into the part. 

Bottom Finish (b) Amount of material left on the bottom of the feature 
for the finishing end mill to remove 

Wall Finish (w) Amount of material left on the side (or wall) of the 
feature for the finishing end mill to remove when tool 
position set to Left or Right {Not shown above} 

Roughing/Finishing Indicates whether a Roughing and/or Finishing Tool will 
be used 

Tool Entry Indicates the manner of entry of end mill into a 
feature, either Vertical, Helical, Sloped or Sloped 
Down and Return 
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Graphics Icons Available in the Mill XY Plane Machining Function 
The Mill XY Plane Machining Function Face Window uses the following icons to allow 
you to assign part features to created geometry in order to create a tool path. 

 
Single Hole Icon enables you to use Snap Modes to define the 
location on the geometry where a currently active Hole Group Symbol 
is to be executed. 

 

Chain Circle Icon enables you to click an enclosed circle on the 
geometry and specify that the currently active Hole Group Symbol is 
also to be automatically applied at the centers of all the other circles 
(holes) of the same size that appear on the geometry. 

 
Define Profile Icon enables you to specify that the currently active 
group symbol is to be applied to the profile described by either 
coordinate entry or by clicking on geometric elements. 

 
Chain Geometry Icon enables you to specify that the currently 
active group symbol is to be applied to a profile that is created when 
PartMaker automatically connects all the elements that form an 
unbroken chain with an initial line or arc clicked. 

 
2-Point Chain Icon enables you to specify a begin point and an end 
point to be chained together.  

 
Engrave Icon enables you to use the Engrave Data dialog box to 
create a profile containing numbers and letters. 
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Programming Example using Mill XY Plane Machining Function 

Square and Off-Center Hole on Face 
A practical programming application of the Mill XY Plane machining function has 
been provided below.  This example assumes you have a knowledge of creating part 
geometry in the PartMaker CAD mode as well as creating tools in PartMaker’s Tool’s 
Database and creating cycles in PartMaker’s Cycles Database. 

In the example given below, you will mill a ½ Inch Square with a ¼ inch End Mill 
and create a .1 diameter off-center hole. If you wish to complete this exercise on 
your own, make sure you have the following tools created in your PartMaker Tools 
Database (all tools used in the Mill XY Plane Face Window should have an 
orientation of Z Tool) 

 .25 Inch Diameter End Mill 

 .1 Inch Diameter Drill 

 Spot Drill with a diameter larger than .1 inch 

Also make sure you have cycle in PartMaker’s Cycles Database created to include 
both a .1 diameter drill and a spot drill. 

 

Features to be created: 

 

1. Mill a .5 inch square with a .25 dia 
end mill 

2. Spot Drill and Drill an off center 
hole with a .1 diameter drill 

Step 1. Create a Mill XY Plane Machining Function Face Window 

 Note: When creating a milled feature in PartMaker Turn-Mill, you must 
always start with a turning operation.  Thus you must have a face window 
of machining function Turn created and at least one Turning part feature 
and tool path created (such as a facing operation). 

Start by creating a Mill XY Plane Machining Function Face Window.  To do so: 

1 Enter the Setup dialog by choosing Setup from the View menu or by 
clicking on the Setup dialog icon in the upper left hand corner of the screen 

2 In the Setup dialog, click the New button to create a new Machining 
Function face Window 

3 From the Machining Function drop down menu, choose Mill XY Plane 
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4 Enter the setup parameters as shown below: 

 
5 Once the Setup dialog appears as above, click on Close 

Step 2. Create Part Geometry 
Start by entering the CAD mode in the Mill XY Plane Window. Draw the following 
features: 

1 Choose Show Axes from the View Menu 

2 Choose Show Boundaries from the View Menu 

3 Draw a ½ inch square 

4 Draw a .05 inch radius circle with a center location at X<-.15> and Y<-.15> 

Your completed geometry and CAD Face Window should appear as shown 
below: 

 

 Note: You can always go to a different Face Window in your *.job file by 
selecting from the Window menu.  Additionally, you can toggle between 
different Face Windows within the active Face Window by choosing Show 
Windows Icons from the View menu and double clicking on the icon 
representing the Window you want to view. 
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Step 3. Create Part Features and assign tool paths 
Start by entering the CAM mode in the Mill XY Plane Window. First you will create 
the tool path to mill the square. To do so: 

1 From the Part Features menu, choose New Profile Group 

2 Choose Contour Mill under Strategy 

3 Choose Left from Tool Position to indicate that climb milling will be 
performed 

4 Enter a Z_Depth of .5 

5 Enter a Tool Diameter of .25 and click <Select Tools> 

6 In the Group Name field, type Mill Square 

Your completed Profile Group Parameters dialog should appear as shown 
below: 

 
7 Assign the part feature to the square drawn earlier by clicking the Chain 

Geometry icon and clicking on the geometry to create the tool path.  It 
should appear as shown below: 
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8 From the Part Features menu, choose Verify Tool Path to see the tool path 
as shown below: 

 
9 Choose Hide Work Tool Path to hide the tool path. 

Next, you will create the off-center hole. To do so: 

1 From the Part Features menu, choose New Hole Group 

2 Uncheck the Through Hole checkbox 

3 Choose a Major Cycle Operation of Type: Drill 

4 Enter a Major Cycle Operation Diameter of .1 

5 Enter a Chamfer (c) of .01 

6 Enter a Nominal Depth (D) of 0.5 

7 Click the <Cycle> button. 

8 In the Group Name field, type Drill_0.1 

Your completed Hole Group Parameters dialog should appear as shown 
below: 
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Assign the part feature to circle by clicking the Chain Circle icon and clicking on 
the circle representing the hole to create the tool path.  It should appear as 
shown below: 
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Machining Function: Mill ZY Plane  
The Mill ZY Plane machining function is used to perform milling interpolation in the 
ZY plane when the spindle is locked at a discreet angular position.  All motions are 
performed with a tool oriented along the machines X-axis.  

Programming of this machining function requires that your Swiss-type lathe have a 
programmable Y-axis and that you have purchased the PartMaker Y-axis milling 
option. 

 
 

Index Angle (C) Orientation angle of the stock to achieve 
the desired face position 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock 
before machining 

ID Starting inside diameter of bar stock 
before machining  
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Types of Features Created in Mill ZY Machining Function Window 
The Mill ZY window uses an X-oriented “live” tool. There is no polar C-axis 
movement (the C-axis indexes and locks).  This window can be used for creating 
off-center cross-holes, flats on the diameter of the part and interpolated features. 
Saw Slots should also be created in this Face Window. 

The features shown on the parts below are representative examples of features that 
can be created in the Mill ZY Window.  The *.job, *.cdb and *.tdb files used to 
create some of these parts can be found on in the in the Sample directory which 
was installed when you initially installed PartMaker Turn-Mill.  Where relevant, the 
locations of these files have been provided. 

 

Figure 1.: Milled Flats and Cross 
Holes 

Figure 2.: Milled Radius ,Flats and Slot 

(Relevant files: C:\PartMaker\Pm-
TM\Samples\Hitachi-
Seiki_HiCell\HiCell.job, HiCell.cdb, 
HiCell.tdb) 

(Relevant files: C:\PartMaker\Pm-
TM\Samples\Mazak_SQT\SQT-MSY.job, SQT-
MSY.cdb, SQT-MSY.tdb) 

  

 

Figure 3: Off-Center Cross Hole Figure 4: Milled slot 
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Part Features Dialogs Available in Mill ZY Machining Function 
Both the New Hole Group and New Profile Group commands from the Part 
Features menu can be used in the Mill ZY Machining Function Face Window.  

The Hole Group Parameters dialog will appear as shown below. Notice the 
orientation of the tool is in X. 

 

Through Hole Check this box if you are drilling through the 
part 

Major Cycle Operation Indicates the major cycle operation as 
specified in the cycles database 

Diameter (d) Diameter of the tool, which is the major cycle 
operation. 

Chamfer(c) Specifies how much chamfer per side is 
needed 

X_Surf (S) Establishes your X-zero work plane on the OD 
of the part 

X_Rapid (R) Specifies how much clearance the tool will 
rapid above your X_Surf 

X_Clear (C) Specifies the distance between the bottom tip 
of the tool and the part surface when a tool 
starts feeding into the part. 

Nominal Depth (D) The depth of the operation to be performed 
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The Mill ZY machining function can be used to create both Contours and Pockets.  
Below, a Contour Mill cycle with tool motion on centerline is shown.  Cutter 
compensation can also be used by choosing Left or Right from the Tool Position 
drop down menu. 

 

Strategy Indicates the type of feature to be milled, either a 
Contour Mill or Pocket Mill 

Tool Position 
For Contour Mill indicates the tool position during 
cutting, such as Left (climb milling), Right 
(conventional milling) or On (on centerline milling) 

X_Surf (S) Establishes the X-zero work plane, i.e. a value 0.25 
indicates the X-zero work plane is .25 from the 
center of the part. 

X_Depth (D) The depth of the operation to be performed 

X_Rapid (R) Specifies how much clearance the tool will rapid to 
above of your X_Surf. 

X_Clear (C) Specifies the distance between the bottom tip of the 
tool and the part surface when a tool starts feeding 
into the part. 

Bottom Finish (b) Amount of material left on the bottom of the feature 
for the finishing end mill to remove 

Wall Finish (w) Amount of material left on the side (or wall) of the 
feature for the finishing end mill to remove when 
tool position set to Left or Right {Not shown above} 

Roughing/Finishing Indicates whether a Roughing and/or Finishing Tool 
will be used 

Tool Entry Indicates the manner of entry of end mill into a 
feature, either Vertical, Helical, Sloped or Sloped 
Down and Return 
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Graphics Icons – Machining Functions for Mill ZY Plane  
The Machining Functions Mill ZY Plane use some or all of the following icons to allow 
you to assign part features to created geometry in order to create a tool path. 

 
Single Hole Icon enables you to use Snap Modes to define the 
location on the geometry where a currently active Hole Group Symbol 
is to be executed. 

 

Chain Circle Icon enables you to click an enclosed circle on the 
geometry and specify that the currently active Hole Group Symbol is 
also to be automatically applied at the centers of all the other circles 
(holes) of the same size that appear on the geometry. 

 
Define Profile Icon enables you to specify that the currently active 
group symbol is to be applied to the profile described by either 
coordinate entry or by clicking on geometric elements. 

 
Chain Geometry Icon enables you to specify that the currently 
active group symbol is to be applied to a profile that is created when 
PartMaker automatically connects all the elements that form an 
unbroken chain with an initial line or arc clicked. 

 
2-Point Chain Icon enables you to specify a begin point and an end 
point to be chained together.  

 
Engrave Icon enables you to use the Engrave Data dialog box to 
create a profile containing numbers and letters. 

Programming Examples using Mill ZY Plane Machining Function 
Practical programming applications of the Mill ZY Plane machining function have 
been provided below.  This example assumes you have a knowledge of creating part 
geometry in the PartMaker CAD mode as well as creating tools in PartMaker’s Tool’s 
Database and creating cycles in PartMaker’s Cycles Database. 

Example A: Creating a single flat with 2 off-center holes 
In the example given below, you will mill a flat with a ½ inch End Mill and create 
two .1 diameter off-center holes. If you wish to complete this exercise on your own, 
make sure you have the following tools created in your PartMaker Tools Database 
(all tools used in the Mill ZY Plane Face Window should have an orientation of X 
Tool) 

 .500 Inch Diameter End Mill 

 .1 Diameter Drill 

 Spot Drill with a diameter larger than .1 inch 

Also make sure you have a cycle in PartMaker’s Cycles Database created to include 
both a .1-diameter drill and a spot drill. 

 

Features to be created: 

 

1. Mill a flat with a .500 dia end 
mill 

2. Spot Drill and Drill two off 
center holes with a .1 diameter 
drill 



 

D-20 PartMaker  Copyright @2014 Delcam Ltd 

 

Step 1. Create a Mill ZY Plane Machining Function Face Window 

 Note: When creating a milled feature in PartMaker Turn-Mill, you must 
always start with a turning operation.  Thus you must have a face window of 
machining function Turn created and at least one Turning part feature and 
tool path created (such as a facing operation). 

Start by creating a Mill ZY Plane Machining Function Face Window.  To do so: 

1 Enter the Setup dialog by choosing Setup from the View menu or by 
clicking on the Setup dialog icon in the upper left hand corner of the screen 

2 In the Setup dialog, click the New button create a new Machining Function 
face Window 

3 From the Machining Function drop down menu, choose Mill ZY Plane 

4 Enter the setup parameters as shown below: 

 
5 Once the Setup dialog appears as above, click on Close.   

Step 2. Create Part Geometry 
Start by entering the CAD mode in the Mill ZY Plane Window. Draw the following 
features: 

1 Choose Show Axes from the View Menu 

2 Choose Show Boundaries from the View Menu 

3 Draw one line at Z<-0.5> to represent the end of the flat. 

4 Draw two .05-inch radius circles with a center location at Z<-0 25> and Y<-
0.1875> and at Z<-0 25> and Y <0.1875>. 
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Your completed geometry and CAD Face Window should appear as shown 
below: 

 

 Note: You can always go to a different Face Window in your *.job file by 
selecting from the Window menu.  Additionally, you can toggle between 
different Face Windows within the active Face Window by choosing Show 
Windows Icons from the View menu and double clicking on the icon 
representing the Window you want to view. 

Step 3. Create Part Features and Assign Tool Paths 
Start by entering the CAM mode in the Mill ZY Plane Window. First you will create 
the tool path to mill the flat. To do so: 

1 From the Part Features menu, choose New Profile Group 

2 Choose Contour Mill under Strategy 

3 Choose Left from Tool Position to indicate that climb milling will be 
performed 

4 Enter an X_Surf of .375 

5 Enter an X_Depth of .375 (we want the tool to go to center) 

6 Enter a Tool Diameter of .5 and click on Select Tools. 

7 In the Group Name field, type Mill Half. 

Your completed Profile Group Parameters dialog should appear as shown 
below: 
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8 Assign the part feature to the flat drawn earlier by clicking the Chain 
Geometry icon and clicking on the geometry to create the tool path.  It 
should appear as shown below: 

 
9 From the Part Features menu, choose Verify Tool Path to see the tool path 

as shown below: 

 
10 Choose Hide Work Tool Path to hide the tool path. 

Next, you will create the off-center holes. To do so: 

1 From the Part Features menu, choose New Hole Group 

2 Uncheck the Through Hole Box 

3 Choose a Major Cycle Operation of Type: Drill 

4 Enter a Major Cycle Operation Diameter of .1 

5 Enter a Chamfer of .01 

6 Enter a Nominal Depth (D) of 0.2 

7 Click the Cycle button. 

8 In the Group Name field, type Drill_0.1  
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Your completed Hole Group Parameters dialog should appear as shown 
below: 

 
Assign the part feature to the circles by clicking the Chain Circle icon and 
clicking on the circle representing the holes to create the tool path.  It should 
appear as shown below: 
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Example B: Creating a Saw Slot 
In the example given below, you will mill a .050 wide slot with a 1-inch Diameter 
Slot Mill. If you wish to complete this exercise on your own, make sure you have the 
following tools created in your PartMaker Tools Database (all tools used in the Mill 
ZY Plane Window should have an orientation of X Tool) 

 Note: You will have needed to purchase the advanced tools option to 
create a Slotting Saw in your tools directory. 

 1 Inch Diameter Slot Mill 

 

Features to be created: 

 

Mill a .125 thick slot x ¼ deep 
along the face of the part. 

Step 1. Create a Mill ZY Plane Machining Function Face Window 

 Note: When creating a milled feature in PartMaker Turn-Mill, you must 
always start with a turning operation.  Thus you must have a face window 
of machining function Turn created and at least one Turning part feature 
and tool path created (such as a facing operation). 

Start by creating a Mill ZY Plane Machining Function Face Window.  To do so: 

1 Enter the Setup dialog by choosing Setup from the View menu or by 
clicking on the Setup dialog icon in the upper left hand corner of the screen 

2 In the Setup dialog, click the New button to create a new Machining 
Function face Window 

3 From the Machining Function drop down menu, choose Mill ZY Plane 

4 Enter the setup parameters as shown below: 

 
5 Once the Setup dialog appears as above, click on Close 
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Step 2. Create Part Geometry 
Start by entering the CAD mode in the Mill ZY Plane Window. Draw the following 
features: 

1 Choose Show Axes from the View Menu 

2 Choose Show Boundaries from the View Menu 

3 Draw a line that represents the .250 depth in Z for the end of the mill slot. 

Your completed geometry and CAD Face Window should appear as shown 
below: 

 

 Note: You can always go to a different Face Window in your *.job file by 
selecting from the Window menu.  Additionally, you can toggle between 
different Face Windows within the active Face Window by choosing Show 
Windows Icons from the View menu and double clicking on the icon 
representing the Window you want to view. 

Step 3. Create Part Features and assign tool paths 
Start by entering the CAM mode in the Mill ZY Plane Window. First you will create 
the tool path to mill the square. To do so: 

1 From the Part Features menu, choose New Profile Group 

2 Choose Contour Mill under Strategy 

3 Choose Left from Tool Position to indicate that climb milling will be 
performed 

4 Enter an X_Depth of .4375 (X_Surf + ½ thickness of the Slotting Saw.) 

5 Enter the Tool ID number of the Slotting Saw in the Tool ID box and then 
hit Apply. 

6 In the Group Name field, type Slotting Saw. 

7 Click on the Close Button 
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Your completed Profile Group Parameters dialog should appear as shown 
below: 

 
8 Assign the part feature to the square drawn earlier by clicking the Chain 

Geometry icon and clicking on the geometry to create the tool path.  It 
should appear as shown below: 
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9 From the Part Features menu, choose Verify Tool Path to see the tool path 
as shown below: 

 
10 Choose Hide Work Tool Path to hide the tool path. 
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Machining Function: Mill ZX Plane 
The Mill ZX Plane machining function is used to perform milling in the Z and X 
planes only. Such operations typically involve following a turning profile with an end 
mill (often ball nose) with the machine spindle in a locked position.  

Programming of this machining function requires that your Swiss-type lathe have a 
programmable Y-axis and that you have purchased the PartMaker Y-axis milling 
option. 

 

Index Angle (C) Orientation angle of the stock to achieve the 
desired face position 

Y-coord (p) Y coordinate value measuring the distance from 
the centerline of the part the tool is offset during 
machining. This value should always be positive. 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining  
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Types of Features Created in Mill ZX Machining Function Window 
The Mill ZX window uses an X-oriented “live” tool. There is no polar C-axis 
movement (the C-axis indexes and locks).  This window is mainly used for doing 
key slots and operations that require simultaneous Z-axis and X-axis moves. 

The features shown on the parts below are representative examples of features that 
can be created in the Mill ZX Window. 

 
Figure 1.  Milled Slot 

 
Figure 1a. (Cross section of milled slot) 

  

 
Figure 2. Milled slot 

 
Figure2a. (Cross section of milled slot) 
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Part Features Dialogs Available in Mill ZX Machining Function 
The Mill ZX machining function can be used to create Contours only.  Below, a 
Contour Mill cycle with tool motion on centerline is shown.  Cutter compensation can 
also be used by choosing Left or Right from the Tool Position drop down menu. 

 Note: In the Mill ZX window you are only allowed to use a New Profile Group. 
A New Hole group and Pocket Milling are not accessible. 

 

Strategy Indicates the type of feature to be milled. In the Mill ZX 
Face Window this must always be set to Contour Mill. 

Tool Position 
For Contour Mill indicates the tool position during 
cutting, such as Left (climb milling), Right (conventional 
milling) or On (on centerline milling). 

X_Surf (S) Establishes the X-zero work plane, i.e. a value 0.25 
indicates the X-zero work plane is .25 from the center of 
the part. 

X_Rapid (R) Specifies how much clearance the tool will rapid above 
your X_Surf 
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Graphics Icons – Machining Function Mill ZX Plane 
The Machining Function Mill ZX Plane uses the following icons to allow you to assign 
part features to created geometry in order to create a tool path. 

 Single Hole Icon Not applicable 

 
Profile Icon enables you to specify that the currently active group 
symbol is to be applied to the profile described by either coordinate 
entry or by clicking on geometric elements.  

 
Chain Icon enables you to specify that the currently active group 
symbol is to be applied to a profile that is created when PartMaker 
automatically connects all the elements that form an unbroken chain 
with an initial line or arc clicked. 

Programming Example using Mill ZX Plane Machining Function 
A practical programming application of the Mill ZX Plane machining function has 
been provided below.  This example assumes you have a knowledge of creating part 
geometry in the PartMaker CAD mode as well as creating tools in PartMaker’s Tool’s 
Database and creating cycles in PartMaker’s Cycles Database. 

In the example given below, you will mill a .125 wide slot down the length of the 
part and radius out. If you wish to complete this exercise on your own, make sure 
you have the following tools created in your PartMaker Tools Database (all tools 
used in the Mill ZX Plane Face Window should have an orientation of X Tool) 

 .125 Inch Diameter End Mill 

 

Features to be created: 

 

Slot running down the length of the 
part then radius out in X. 

Step 1. Create a Mill ZX Plane Machining Function Face Window 

 Note: When creating a milled feature in PartMaker Turn-Mill, you must 
always start with a turning operation.  Thus you must have a face window of 
machining function Turn created and at least one Turning part feature and 
tool path created (such as a facing operation). 

Start by creating a Mill ZX Plane Machining Function Face Window.  To do so: 

1 Enter the Setup dialog by choosing Setup from the View menu or by 
clicking on the Setup dialog icon in the upper left hand corner of the screen 

2 In the Setup dialog, click the New button to create a new Machining 
Function face Window 

3 From the Machining Function drop down menu, choose Mill ZX Plane 
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4 Enter the setup parameters as shown below: 

 

Step 2. Create Part Geometry 
Start by entering the CAD mode in the Mill ZX Plane Window. Draw the following 
features: 

5 Choose Show Axes from the View Menu 

6 Choose Show Boundaries from the View Menu 

7 Draw a horizontal line down the center of the part. Draw a vertical line 1 inch 
parallel to the face of the part. 

8 Choose the Fillet Icon and enter a value of .2 and click on the inside of the 
intersection you just created to generate a radius. 

Your completed geometry and CAD Face Window should appear as shown 
below: 

 

 Note: You can always go to a different Face Window in your *.job file by 
selecting from the Window menu.  Additionally, you can toggle between 
different Face Windows within the active face Window by choosing Show 
Windows Icons from the View menu and double clicking on the icon 
representing the Window you want to view. 
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Step 3. Create Part Features and assign tool paths 
Start by entering the CAM mode in the Mill ZX Plane Window. First you will create 
the tool path to mill the slot. To do so: 

1 From the Part Features menu, choose New Profile Group 

Strategy is set to Contour Mill by default. 

2 Choose On from Tool Position to indicate that we will be milling with the 
centerline of the tool. 

3 Enter X_Surf of 0.3125 

4 Enter a Tool Diameter of 0.125 and click Select Tools 

5 In the Group Name field, type Mill Slot 

Your completed Profile Group Parameters dialog should appear as shown below: 

 
6 Assign the part feature to the square drawn earlier by clicking the Chain 

Geometry icon and clicking on the geometry to create the tool path.  It 
should appear as shown below: 
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7 From the Part Features menu, choose Verify Tool Path to see the tool path 
as shown below: 

 
8 Choose Hide Work Tool Path to hide the tool path. 
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Machining Function: Mill Polygon  
The Mill Polygon machining function allows you to create polygon shapes on the OD 
of a part using the Y-axis capability of your machine and a tool oriented along the 
X-axis of the machine. 

Programming of this machining function requires that your Swiss-type lathe have a 
programmable Y-axis and that you have purchased the PartMaker Y-axis milling 
option. 

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining 
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Types of Features Created in Mill Polygon Machining Function 
Window 
The Mill Polygon window uses an X-oriented “live” tool. There is no polar C-axis 
movement (the C-axis indexes and locks).  This window is mainly used when 
creating multiple flats like a polygon, square or a hex. This operation does use bi-
directional cutting therefore it cuts in one direction and indexes then cut in the 
opposite direction.  

The features shown on the parts below are representative examples of features that 
can be created in the Mill Polygon Window.  The *.job, *.cdb and *.tdb files used to 
create some of these parts can be found on in the in the Sample directory which 
was installed when you initially installed PartMaker Turn-Mill.  Where relevant, the 
locations of these files have been provided. 

 
 

Figure 1.: Milled Hex Figure 2.: Milled Hex  

(Relevant files: C:\PartMaker\Pm-
TM\Samples\8-Axis_Demo\8-
Axis_Demo.job, 8-Axis_Demo.cdb, 8-
Axis_Demo.tdb) 

(Relevant files: C:\PartMaker\Pm-
TM\Samples\Nakamura_TW\TW.job, 
TW.cdb, TW.tdb) 

  

 

Figure 3.: Milled Hex Figure 4.: Milled Polygon 
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Part Features Dialogs Available in Mill Polygon Machining Function 
The Mill Polygon machining function can be used to create flats only.  Below, a 
Profile Group parameter window is shown. In the drop down menu you pick the tool 
edge you are going to use with respect to the part.   

 Note: In the Mill Polygon window you are only allowed to use New Profile 
Group. A New Hole Group is not accessible. 

 
 

Distance From 
Part Face, To: 

Indicates placement of tool with respect to the part 
face. The tool can be positioned with respect to the 
Left Tool Edge (P1), the Tool Center (P2) or the Right 
Tool Edge (P3). 

X_Surf (S) Establishes the X-zero work plane, i.e. a value 0.25 
indicates the X-zero work plane is .25 from the center 
of the part. 

X_Rapid (R) Specifies how much clearance the tool will rapid above 
your X_Surf 

Clearance(C) Specifies the clearance amount the tool will position to 
past the barstock diameter. 

Graphics Icons – Machining Function Mill Polygon 
The machining functions for Mill Polygon uses the following icons to allow you to 
assign part features to created geometry in order to create a tool path. 

 

Define Profile Icon enables you to specify that the currently 
active group symbol is to be applied to the profile described by 
either coordinate entry or by clicking on geometric elements. 

 

Chain Geometry Icon enables you to specify that the currently 
active group symbol is to be applied to a profile that is created 
when PartMaker automatically connects all the elements that 
form an unbroken chain with an initial line or arc clicked. 
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Programming Example using Mill Polygon Machining Function 

Milling a Hexagon 
A practical programming application of the Mill Polygon Plane machining function 
has been provided below.  This example assumes you have a knowledge of creating 
part geometry in the PartMaker CAD mode as well as creating tools in PartMaker’s 
Tool’s Database. 

In the example given below, you will mill a hexagon with a ¼ inch End Mill. If you 
wish to complete this exercise on your own, make sure you have the following tools 
created in your PartMaker Tools Database (all tools used in the Mill Polygon Face 
Window should have an orientation of X Tool) 

 .25 Inch Diameter End Mill 

 

Features to be created: 

 

Mill a hexagon with a .25 dia end 
mill 

Step 1. Create a Mill Polygon Plane Machining Function Face Window 

 Note: When creating a milled feature in PartMaker Turn-Mill, you must 
always start with a turning operation.  Thus you must have a face window of 
machining function Turn created and at least one Turning part feature and 
tool path created (such as a facing operation). 

Start by creating a Mill Polygon Plane Machining Function Face Window.  To do so: 

1 Enter the Setup dialog by choosing Setup from the View menu or by 
clicking on the Setup dialog icon in the upper left hand corner of the screen 

2 In the Setup dialog, click the New button create a new Machining Function 
face Window 

3 From the Machining Function drop down menu, choose Mill Polygon  

4 Enter the setup parameters as shown below: 

 
5 Once the Setup dialog appears as above, click on Close 
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Step 2. Create Part Geometry 
Start by entering the CAD mode in the Mill Polygon Window. Draw the following 
features: 

1 Choose Show Axes from the View Menu 

2 Choose Show Boundaries from the View Menu 

3 Choose the Hexagon Icon and enter .25 for the Center to Flat Distance 

Your completed geometry should appear as shown below: 

 

 Note: You can always go to a different Face Window in your *.job file by 
selecting from the Window menu.  Additionally, you can toggle between 
different Face Windows within the active face Window by choosing Show 
Windows Icons from the View menu and double clicking on the icon 
representing the Window you want to view. 

Step 3. Create Part Features and assign tool paths 
Start by entering the CAM mode in the Mill Polygon Window. First you will create the 
tool path to mill the hexagon. To do so: 

1 From the Part Features menu, choose New Profile Group 

2 Choose Left Tool Edge (P1) under Distance From Part Face 

3 Enter 0.2 For the P1 value 

4 Enter a Tool Diameter of .25 and click Select Tools 

5 In the Group Name field, type Mill Polygon 

Your completed dialog should appear as shown below: 
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6 Assign the part feature to the square drawn earlier by clicking the Chain 
Geometry icon and clicking on the geometry to create the tool path.  It 
should appear as shown below: 

 
7 From the Part Features menu, choose Verify Tool Path to see the tool path 

as shown below: 

 
8 Choose Hide Work Tool Path to hide the tool path. 
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Machining Function: Mill End, Index  
The Mill End, Index machining functon is used when drilling holes and milling slots 
on the end face of the part. The holes are located in the XY plane and oriented 
along the Z-axis.  

The shapes that can be created with this machining function are:  

 Holes in the end of the work created by Z-axis feed. This motion type 
supports off-center drilling on the end of the part, using C-axis indexing and 
X-axis positioning to locate the hole position.  

 Radial slots which are milled using C-axis indexing to position and hold the 
part while X-axis motion is used to cut the part. The tool would be a milling 
tool oriented along the Z-axis. 

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining  
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Types of Features Created in Mill End Index Machining Function 
Window 
The MILL END INDEX window uses a Z-oriented “live” tool. There is no polar C-axis 
movement (the C-axis indexes and locks).  This window is mainly used for doing 
any number of holes or slots using a Z-oriented tool.  

The features shown on the parts below are representative examples of features that 
can be created in the MILL END INDEX window 

Figure 1. Face holes Figure 2. Face holes and Slots 

(Relevant files: C:\PartMaker\Pm-
TM\Samples\Tm-demo\Tm-demo.job, 
Tm-demo.cdb, Tm-demo.tdb) 
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Part Features Dialogs Available in Mill End Index Machining Function 
Both the New Hole Group and New Profile Group commands from the Part 
Features menu can be used in the Mill End Index Machining Function Face 
Window.  

The Hole Group Parameters dialog will appear as shown below. Notice the 
orientation of the tool is in Z. 

 

Through Hole Check this box if you are drilling through the 
part 

Major Cycle Operation Indicates the major cycle operation as specified 
in the cycle’s database 

Diameter (d) Diameter of the tool, which is the major cycle 
operation 

Chamfer(c) Specifies how much chamfer per side is needed 

Z_Surf (S) Establishes your Z-zero work plane 

Z_Rapid (R) Specifies how much clearance the tool will 
rapid to in front of your Z_Surf 

Z_Clear (C) 
Specifies the distance between the bottom tip of the 
tool and the part surface when a tool starts feeding 
into the part. 

Inclination Angle 
Specifies the angle of the tool when making 
inclined holes (you must have a “B” axis or an 
angled attachment.) 

Nominal Depth (D) The depth of the operation to be performed 
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The Mill End Index machining function can be used to create Contours only.  Below, 
a Contour Mill cycle with tool motion on centerline is shown. 

 
 

Strategy Indicates the type of feature to be milled 
is a Contour Mill  

Tool Position 
For Contour Mill indicates the tool 
position during cutting, On (on centerline 
milling) 

Z_Surf (S) Establishes the Z-zero work plane i.e. a 
value 0 indicates the face of the part, a 
negative value indicates a Z-zero along 
the length of the part 

Z_Depth (D) The depth of the operation to be 
performed 

Z_Rapid (R) Specifies how much clearance the tool 
will rapid to in front of your Z_Surf. 

Z_Clear (C) Specifies the distance between the bottom tip 
of the tool and the part surface when a tool 
starts feeding into the part. 

Bottom Finish (b) Amount of material left on the bottom of 
the feature for the finishing end mill to 
remove 

Roughing/Finishing Indicates whether a Roughing and/or 
Finishing Tool will be used 

Tool Entry Does not apply to the Mill End Index 
machining function 
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Graphics Icons – Machining Functions Mill End Index 
The Machining Functions Mill End Index uses the following icons to allow you to 
assign part features to created geometry in order to create a tool path. 

 
Single Hole Icon enables you to use Snap Modes to define the 
location on the geometry where a currently Hole Group Symbol is to 
be executed. 

 

Chain Circle Icon enables you to click an enclosed circle on the 
geometry and specify that the currently active Hole Group Symbol is 
also to be automatically applied at the centers of all the other circles 
(holes) of the same size that appear on the geometry. 

 

Profile Icon enables you to specify that the currently active group 
symbol is to be applied to the profile described by either coordinate 
entry or by clicking on geometric elements.  When performing 
indexing operations, the Profile Icon may only join two points during 
its usage. 

 

Chain Icon enables you to specify that the currently active group 
symbol is to be applied to a profile that is created when PartMaker 
automatically connects all the elements that form an unbroken chain 
with an initial line or arc clicked. When performing indexing 
operations, the Chain Icon may only join two points during its usage. 
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Programming Example using Mill End Index Machining Function 

Bolt Hole Pattern on the Face 
A practical programming application of the Mill End Index machining function has 
been provided below.  This example assumes you have a knowledge of creating part 
geometry in the PartMaker CAD mode as well as creating tools in PartMaker’s Tool’s 
Database and creating cycles in PartMaker’s Cycles Database. 

In the example given below, you will drill  six .125 diameter holes on the face of the 
part. If you wish to complete this exercise on your own, make sure you have the 
following tools created in your PartMaker Tools Database (all tools used in the Mill 
End Index Face Window should have an orientation of Z Tool) 

 .125 Inch Diameter Drill 

 Spot Drill with a diameter larger than .125 inch 

Also make sure you have cycle in PartMaker’s Cycles Database created to include 
both a .125-inch drill and a spot drill. 

Features to be created: 

 

Spot Drill and Drill (6) holes with a 
.125 diameter drill 

Step 1. Create a Mill End Index Machining Function Face Window 

 Note: When creating a milled feature in PartMaker Turn-Mill, you must 
always start with a turning operation.  Thus you must have a face window of 
machining function Turn created and at least one Turning part feature and 
tool path created (such as a facing operation). 

Start by creating a Mill End Index Machining Function Face Window.  To do so: 

1 Enter the Setup dialog by choosing Setup from the View menu or by 
clicking on the Setup dialog icon in the upper left hand corner of the screen 

2 In the Setup dialog, click the New button to create a new Machining 
Function face Window 

3 From the Machining Function drop down menu, choose Mill End Index 
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4 Enter the setup parameters as shown below: 

 
5 Once the Setup dialog appears as above, click on Close 

Step 2. Create Part Geometry 
Start by entering the CAD mode in the Mill End Index Window. Draw the following 
features: 

1 Choose Show Axes from the View Menu 

2 Choose Show Boundaries from the View Menu 

3 Draw a .0625 inch radius circle with a center location at X<-.2> and Y<0> 

4 Choose the Rotate command and make 5 copies and rotate about the X<0> 
and Y<0> and with Angle (A) of 60. 

Your completed geometry and CAD Face Window should appear as shown 
below: 

 

 Note: You can always go to a different Face Window in your *.job file by 
selecting from the Window menu.  Additionally, you can toggle between 
different Face Windows within the active face Window by choosing Show 
Windows Icons from the View menu and double clicking on the icon 
representing the Window you want to view. 
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Step 3. Create Part Features and assign tool paths 
Start by entering the CAM mode in the Mill End Index Window. First you will create 
the 0.125 Boltholes, to do so: 

1 From the Part Features menu, choose New Hole Group 

2 Uncheck the Through Hole Box 

3 Choose a Major Cycle Operation of Type: Drill 

4 Enter a Major Cycle Operation Diameter of .125 

5 Enter a Chamfer of .01 

6 Enter a Nominal Depth (D) of 0.45 

7 Click the Cycle button. 

Your completed Hole Group Parameters dialog should appear as shown 
below: 

 
8 Assign the part feature to circle by clicking the Chain Circle icon and clicking 

on the circle representing the hole to create the tool path.  It should appear 
as shown below: 
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Machining Function: Mill Diam, Index  
The Mill Diam, Index machining function allows you  to create “cross holes” or radial 
slots on the OD of the part.  In order to support this machining function, your 
Swiss-type lathe must be able to support C-axis indexing, which may not be 
performed while the tool is in contact with the work.  

This machining function supports the following features cut on the outside diameter 
of the work using a tool oriented along the machine's X-axis:  

 Slots oriented along the length (Z-axis) of the stock. 

 Holes drilled anywhere along the cylinder except the end of the stock. 

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining  
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Types of Features Created in Mill Diam, Index Machining Function 
Window 
The Mill Diam, Index window uses a X-oriented “live” tool. There is no polar C-axis 
movement (the c-axis indexes and locks).  This window is mainly used for doing any 
number of holes or slots using a X-oriented tool.  

The features shown on the parts below are representative examples of features that 
can be created in the Mill Diam, Index window.   

  

Figure 1. Milled Slot 

 

(Relevant files: C:\PartMaker\Pm-
TM\Samples\Tm-demo\Tm-demo.job, Tm-
demo.cdb, Tm-demo.tdb) 

Figure 2. Cross holes 

 

(Relevant files: C:\PartMaker\Pm-
TM\Samples\Nakamura_TW\TW.job, 
TW.cdb, TW.tdb) 
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Part Features Dialogs Available in Mill Diam, Index Machining Function 
Both the New Hole Group and New Profile Group commands from the Part 
Features menu can be used in the Mill Diam, Index Machining Function Face 
Window.  

The Hole Group Parameters dialog will appear as shown below. Notice the 
orientation of the tool is in X. 

 

Through Hole Check this box if you are drilling through 
the part 

Major Cycle Operation Indicates the major cycle operation as 
specified in the cycle’s database. 

Diameter (d) Diameter of the tool, which is the major 
cycle operation. 

Chamfer(c) Specifies how much chamfer per side is 
needed 

X_Surf (S) Establishes your X-zero work plane. 

X_Rapid (R) Specifies how much clearance the tool will 
rapid to in front of your X_Surf. 

X_Clear (C) Specifies the distance between the bottom 
tip of the tool and the part surface when a 
tool starts feeding into the part. 

Nominal Depth (D) The depth of the operation to be performed 
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The Mill Diam,Index machining function can be used to create Contours only.  
Below, a Contour Mill cycle with tool motion on centerline is shown. 

 

 
Strategy Indicates the type of feature to be milled is a 

Contour Mill  

Tool Position For Contour Mill indicates the tool position 
during cutting, On (on centerline milling) 

X_Surf (S) Establishes the X-zero work plane, i.e. a value 
0.25 indicates the X-zero work plane is .25 
from the center of the part. 

X_Depth (D) The depth of the operation to be performed 

X_Rapid (R) Specifies how much clearance the tool will 
rapid to above your X_Surf. 

X_Clear (C) Specifies the distance between the bottom tip 
of the tool and the part surface when a tool 
starts feeding into the part. 

Bottom Finish (b) Amount of material left on the bottom of the 
feature for the finishing end mill to remove 

Roughing/Finishing Indicates whether a Roughing and/or Finishing 
Tool will be used 

Tool Entry Does not apply to the Mill Diam, Index 
machining function 
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Graphics Icons – Machining Functions for Mill Diam, Index 
The Machining Functions for Mill Diam, Index uses the following icons to allow you 
to assign part features to created geometry in order to create a tool path. 

 

Single Hole Icon enables you to use Snap Modes to define the 
location on the geometry where a currently Hole Group Symbol is to 
be executed. 

 

Chain Circle Icon enables you to click an enclosed circle on the 
geometry and specify that the currently active Hole Group Symbol is 
also to be automatically applied at the centers of all the other circles 
(holes) of the same size that appear on the geometry. 

 

Profile Icon enables you to specify that the currently active group 
symbol is to be applied to the profile described by either coordinate 
entry or by clicking on geometric elements.  When performing 
indexing operations, the Profile Icon may only join two points during 
its usage. 

 

Chain Icon enables you to specify that the currently active group 
symbol is to be applied to a profile that is created when PartMaker 
automatically connects all the elements that form an unbroken chain 
with an initial line or arc clicked. When performing indexing 
operations, the Chain Icon may only join two points during its usage. 

Programming Example using Mill Diameter Index Machining 
Function 

Creating Cross holes 
A practical programming application of the Mill Diameter Index machining function 
has been provided below.  This example assumes you have a knowledge of creating 
part geometry in the PartMaker CAD mode as well as creating tools in PartMaker’s 
Tool’s Database and creating cycles in PartMaker’s Cycles Database. 

In the example given below, you will Drill six holes with a .125 diameter drill. If you 
wish to complete this exercise on your own, make sure you have the following tools 
created in your PartMaker Tools Database (all tools used in the Mill Diameter Index 
Face Window should have an orientation of X Tool). 

 .125 Inch Diameter Drill 

 Spot Drill with a diameter larger than .125 inch 

Also make sure you have cycle in PartMaker’s Cycles Database created to include 
both a .125-inch drill and a spot drill. 

 

Features to be created: 

 

Spot Drill and Drill six holes on 
diameter with a .125 diameter drill 
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Step 1. Create a Mill Diameter Index Machining Function Face Window 

 Note: When creating a milled feature in PartMaker Turn-Mill, you must 
always start with a turning operation.  Thus you must have a face window of 
machining function Turn created and at least one Turning part feature and 
tool path created (such as a facing operation). 

Start by creating a Mill Diam, Index Machining Function Face Window.  To do so: 

1 Enter the Setup dialog by choosing Setup from the View menu or by 
clicking on the Setup dialog icon in the upper left hand corner of the screen 

2 In the Setup dialog, click the New button create a new Machining Function 
face Window 

3 From the Machining Function drop down menu, choose Mill Diam, Index 

4 Enter the setup parameters as shown below: 

 

Step 2. Create Part Geometry 
Start by entering the CAD mode in the Mill Diam, Index Window. Draw the following 
features: 

1 Choose Show Axes from the View Menu 

2 Choose Show Boundaries from the View Menu 

3 Draw a .0625-inch radius circle with a center location at Z<. 25. > and 
C<0>. 

4 Click on the Selection Icon and click on the circle you just created. 

5 Choose Translate from the Edit Menu and make 5 more copies with 
Horizontal Distance (H) of 0 and Vertical Distance (V) of 60 degrees. 
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Your completed geometry and CAD Face Window should appear as shown 
below: 

 

 Note: You can always go to a different Face Window in your *.job file by 
selecting from the Window menu.  Additionally, you can toggle between 
different Face Windows within the active Face Window by choosing Show 
Windows Icons from the View menu and double clicking on the icon 
representing the Window you want to view. 
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Step 3. Create Part Features and assign tool paths 
Start by entering the CAM mode in the Mill Diam, Index Window. First you will 
create the tool path to drill the cross holes. To do so: 

1 From the Part Features menu, choose New Hole Group 

2 Uncheck the Through Hole checkbox 

3 Choose a Major Cycle Operation of Type: Drill 

4 Enter a Major Cycle Operation Diameter of .125 

5 Enter a Chamfer (c)of .01 

6 Enter a Nominal Depth (D) of 0.3125 

7 Click the Cycle button. 

Your completed Hole Group Parameters dialog should appear as shown 
below: 

 
8 Assign the part feature to circle by clicking the Chain Circle icon and clicking 

on the circles representing the holes to create the tool path.  It should 
appear as shown below: 
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Machining Function: Mill End, Polar  
The Mill End, Polar machining function allows you to perform polar interpolation on 
the face of the part. This machining function assumes that the Swiss-type lathe has 
the ability to perform simultaneous feed motions with the X, Z and C-axes.  

The following rules apply to Mill End, Polar:  

 Tools must be oriented along the machine’s Z-axis.  

 Shapes created must not pass, or if extended, pass through the center of 
rotation of the stock (X=0). For example, the radial slots that are 
programmable in Mill End, Index may NOT be programmed using Mill End, 
Polar. Also, any arc move that intersects the X=0 center is NOT allowed to 
be programmed using this machining function. 

 Programming of this machining function requires that your Swiss-type lathe 
has a programmable C-axis and that you have purchased the PartMaker C-
axis milling option. 

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining  
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Types of Features Created in Mill End, Polar Machining Function 
Window 
The MILL END, POLAR window uses a Z-oriented “live” tool. There is polar C-Axis 
movement (the C-Axis does not lock).  This window is mainly used for milling 
profiles and pockets on the face of the part. 

The features shown on the parts below are representative examples of features that 
can be created in the MILL END, POLAR window.  The *.job, *.cdb and *.tdb files 
used to create some of these parts can be found on in the in the Sample directory 
which was installed when you initially installed PartMaker Turn-Mill.  Where 
relevant, the locations of these files have been provided. 

 
Figure 1. Milled Pockets Figure 2. Face Pocket 

(Relevant files: C:\PartMaker\Pm-
TM\Samples\Hardinge_TT-65\TT-
65.job, TT-65.cdb, TT-65.tdb) 

(Relevant files: C:\PartMaker\Pm-
TM\Samples\Tm-demo\Tm-demo.job, 
Tm-demo.cdb, Tm-demo.tdb) 

Figure 3. Milled Cam Figure 4. Milled Pocket on the Face
(Relevant files: C:\PartMaker\Pm-
TM\Samples\Citizen_FL\Citizen_FL_demo.
job, Citizen_FL_demo.cdb, 
Citizen_FL_demo.tdb) 
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Part Features Dialogs Available in Mill End, Polar Machining Function 
The Mill End, Polar machining function can be used to create both Contours and 
Pockets.  Below, a Contour Mill cycle with tool motion on centerline is shown. If you 
wish to create a pocket, choose Pocket Mill from Strategy drop down menu.  Cutter 
compensation can also be used by choosing Left or Right from the Tool Position 
drop down menu. 

 Note: In the Mill End, Polar window you are only allowed to use a New Profile 
Group. New Hole group is not accessible. 

 

Strategy Indicates the type of feature to be milled, either a Contour Mill or 
Pocket Mill 

Tool Position For Contour Mill indicates the tool position during cutting, such as 
Left (climb milling), Right (conventional milling) or On (on 
centerline milling) 

Z_Surf (S) Establishes the Z-zero work plane i.e. a value 0 indicates the face 
of the part, a negative value indicates a Z-zero along the length of 
the part 

Z_Depth (D) The depth of the operation to be performed 

Z_Rapid (R) Specifies how much clearance the tool will rapid to in front of your 
Z_Surf. 

Z_Clear (C) Specifies the distance between the bottom tip of the tool and the 
part surface when a tool starts feeding into the part. 

Bottom Finish (b) Amount of material left on the bottom of the feature for the 
finishing end mill to remove 

Wall Finish (w) Amount of material left on the side (or wall) of the feature for the 
finishing end mill to remove when tool position set to Left or Right 
{Not shown above} 

Roughing/Finishing Indicates whether a Roughing and/or Finishing Tool will be used 

Tool Entry Indicates the manner of entry of end mill into a feature, either 
Vertical, Helical, Sloped or Sloped Down and Return 
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Graphics Icons Available in the Mill End, Polar Machining Function 
The Machining Function Mill End, Polar, uses the following icons to allow you to 
assign part features to created geometry in order to create a tool path. 

 
Define Profile Icon enables you to specify that the currently active 
group symbol is to be applied to the profile described by either 
coordinate entry or by clicking on geometric elements. 

 
Chain Geometry Icon enables you to specify that the currently 
active group symbol is to be applied to a profile that is created when 
PartMaker automatically connects all the elements that form an 
unbroken chain with an initial line or arc clicked. 

 
2-Point Chain Icon enables you to specify a begin point and an end 
point to be chained together.  

 
Engrave Icon enables you to use the Engrave Data dialog box to 
create a profile containing numbers and letters. 

Programming Example using Mill End, Polar Machining Function 

Creating a Pocket on the Face of the Part 
A practical programming application of the Mill End, Polar machining function has 
been provided below.  This example assumes you have a knowledge of creating part 
geometry in the PartMaker CAD mode as well as creating tools in PartMaker’s Tool’s 
Database and creating cycles in PartMaker’s Cycles Database. 

In the example given below, you will mill a Square Pocket .400 from side to side 
with a .08 diameter End Mill. If you wish to complete this exercise on your own, 
make sure you have the following tools created in your PartMaker Tools Database 
(all tools used in the Mill End, Polar Face Window should have an orientation of Z 
Tool) 

 .080 Diameter End Mill 

 

Features to be created: 

 

Mill a square pocket with a .080 
dia. end mill 

Step 1. Create a Mill End, Polar Machining Function Face Window 

 Note: When creating a milled feature in PartMaker Turn-Mill, you must 
always start with a turning operation.  Thus you must have a face window of 
machining function Turn created and at least one Turning part feature and 
tool path created (such as a facing operation). 

Start by creating a Mill End, Polar Machining Function Face Window.  To do so: 

1 Enter the Setup dialog by choosing Setup from the View menu or by 
clicking on the Setup dialog icon in the upper left hand corner of the screen 

2 In the Setup dialog, click the New button create a new Machining Function 
face Window 
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3 From the Machining Function drop down menu, choose Mill End, Polar 

 
4 Once the Setup dialog appears as above, click on Close 

Step 2. Create Part Geometry 
Start by entering the CAD mode in the Mill End, Polar Window. Draw the following 
features: 

1 Choose Show Axes and Show Boundaries from the View Menu 

2 Draw a square that is .400 from flat to flat. 

3 Draw a .0625 inch radius using the Fillet Icon to round off each corner 

Your completed geometry and CAD Face Window should appear as shown 
below: 

 

 Note: You can always go to a different Face Window in your *.job file by 
selecting from the Window menu.  Additionally, you can toggle between 
different Face Windows within the active face Window by choosing Show 
Windows Icons from the View menu and double clicking on the icon 
representing the Window you want to view. 
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Step 3. Create Part Features and assign tool paths 
Start by entering the CAM mode in the Mill End, Polar Window. First you will create 
the tool path to mill the square. To do so: 

1 From the Part Features menu, choose New Profile Group 

2 Choose Pocket Mill under Strategy 

3 Choose Spiral for the type of pocket to be performed 

4 Enter a Z_Depth of 0.25 

5 Enter a Tool Diameter of .08 for the Roughing and Finishing and click Select 
Tools 

6 In the Group Name field, type Mill Pocket 

Your completed Profile Group Parameters dialog should appear as shown 
below: 

 
7 Assign the part feature to the square drawn earlier by clicking the Chain 

Geometry icon and clicking on the geometry to create the tool path.  It 
should appear as shown below: 
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8 From the Part Features menu, choose Verify Tool Path to see the tool path 
similar to the one below: 

 
9 Choose Hide Work Tool Path to hide the tool path. 
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Machining Function: Mill Diam, Polar  
The Mill Diam, Polar machining function supports polar milling anywhere on the 
stock using an X-axis oriented milling tool. This machining function assumes that 
your Swiss-type lathe has the ability to perform simultaneous feed motions with the 
X, Z and C-axes. The Mill Diam, Polar machining function is most commonly used to 
machine polygon features on the OD of the part using continuous C-axis feed.  
Programming of this type in Face Windows is carried out in much the same 
manner as the Mill Polygon machining function. 

 Programming of this machining function requires that your Swiss-type lathe 
has a programmable C-axis and that you have purchased the PartMaker C-
axis milling option. 

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining  
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Types of Features Created in Mill Diam Polar Machining Function 
Window 
The Mill Diam Polar window uses an X-oriented “live” tool. There is polar C-axis 
movement (the C-axis does not lock). The Mill Diam Polar window is not a 
commonly used window; it is typically used in Surface Machining applications. 
Please refer to the Advanced Surface Machining manual for more information. 

Part Features Dialogs Available in Mill Diam Polar Machining Function  
The Mill Diam Polar machining function can be used to create flats. Below, a Profile 
Group parameter window is shown.   

 Note: In the Mill Diam Polar window you are only allowed to use New Profile 
Group. A New Hole Group is not accessible, 

 

Distance From 
Part Face, To: 

Indicates placement of tool with respect to the part face.  The 
tool can be positioned with respect to the Left Tool Edge (P1), 
the Tool Center (P2) or the Right Tool Edge (P3). 

X_Surf (S) Establishes the X-zero work plane, i.e. a value 0.25 indicates the 
X-zero work plane is .25 from the center of the part. 

X_Rapid (R) Specifies how much clearance the tool will rapid above your 
X_Surf 

Clearance(C) Specifies the clearance amount the tool will position past the 
barstock diameter. 

Graphics Icons – Machining Functions for Mill Diam Polar  
The Machining Functions, Mill Diam Polar use some or all of the following icons to 
allow you to assign part features to created geometry in order to create a tool path. 

 

Define Profile Icon enables you to specify that the currently active group 
symbol is to be applied to the profile described by either coordinate entry or 
by clicking on geometric elements. 

 

Chain Geometry Icon enables you to specify that the currently active group 
symbol is to be applied to a profile that is created when PartMaker 
automatically connects all the elements that form an unbroken chain with an 
initial line or arc clicked. 

 

2-Point Chain Icon enables you to specify a begin point and an end point to 
be chained together.  



 

D-66 PartMaker  Copyright @2014 Delcam Ltd 

 

Machining Function: Mill Cylinder 
The Mill Cylinder machining function supports continuous milling on the outside 
diameter of the part.  Cylindrical milling assumes that your Swiss-type lathe has the 
ability to simultaneously feed in the X, Z and C axes. 

Using motions of this type, combined with a tool oriented along the X axis of the 
machine, profiles can be created on the outside diameter of the stock. 

Tool positioning is programmed using X, Z, and C axis coordinates.  The C position 
is programmed in terms of degrees of rotation relative to machine C=0 which is 
clearly shown in the graphic below. 

 Programming of this machining function requires that your Swiss-type lathe 
has a programmable C-axis and that you have purchased the PartMaker C-
axis milling option. 

 
 

Length (L) Length of the finished part 

OD Diameter of the surface to be machined 

ID Starting inside diameter of bar stock before 
machining  
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Types of Features Created in Mill Cylinder Machining Function 
Window 
The Mill Cylinder window uses an X-oriented “live” tool. There is polar C-axis 
movement (the C-axis does not lock).  This window is mainly used for doing 
contoured pockets and or slots as well as engraving.   

The features shown on the parts below are representative examples of features that 
can be created in the Mill Cylinder window.  The *.job, *.cdb and *.tdb files used to 
create some of these parts can be found on in the in the Sample directory which 
was installed when you initially installed PartMaker Turn-Mill.  Where relevant, the 
locations of these files have been provided. 

 

Figure 1.  Milled Slot Figure 2. Engraving 

(Relevant files: C:\PartMaker\Pm-
TM\Samples\Mori-Seiki_ZL\ZL.job, 
ZL.cdb, ZL.tdb) 

(Relevant files: C:\PartMaker\Pm-
TM\Samples\Hardinge_TT-65\TT-65.job, TT-
65.cdb, TT-65.tdb) 
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Part Features Dialogs Available in Mill Cylinder Machining Function 
The Mill Cylinder machining function can be used to create Contours, Pockets and 
Lettering on the outside diameter.  Below, a Contour Mill cycle with tool motion on 
centerline is shown.  Cutter compensation can also be used by choosing Left or 
Right from the Tool Position drop down menu. 

 

Strategy Indicates the type of feature to be milled, either a 
Contour Mill or Pocket Mill 

Tool Position 
For Contour Mill indicates the tool position during 
cutting, such as Left (climb milling), Right (conventional 
milling) or On (on centerline milling) 

X_Surf (S) Establishes the X-zero work plane, i.e. a value 0.25 
indicates the X-zero work plane is .25 from the center of 
the part. 

X_Depth (D) The depth of the operation to be performed 

X_Rapid (R) Specifies how much clearance the tool will rapid to 
above your X_Surf. 

X_Clear (C) Specifies the distance between the bottom tip of the tool 
and the part surface when a tool starts feeding into the 
part. 

Bottom Finish (b) Amount of material left on the bottom of the feature for 
the finishing end mill to remove 

Wall Finish (w) Amount of material left on the side (or wall) of the 
feature for the finishing end mill to remove when tool 
position set to Left or Right 

Roughing/Finishing Indicates whether a Roughing and/or Finishing Tool will 
be used 

Tool Entry Indicates the manner of entry of end mill into a feature, 
either Vertical, Helical, Sloped or Sloped Down and 
Return 
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Graphics Icons-Machining Functions for Mill Cylinder 
The Machining Functions for Mill Cylinder use some or all of the following icons to 
allow you to assign part features to created geometry in order to create a tool path. 

 
Define Profile Icon enables you to specify that the currently active 
group symbol is to be applied to the profile described by either 
coordinate entry or by clicking on geometric elements. 

 
Chain Geometry Icon enables you to specify that the currently 
active group symbol is to be applied to a profile that is created when 
PartMaker automatically connects all the elements that form an 
unbroken chain with an initial line or arc clicked.

 
2-Point Chain Icon enables you to specify a begin point and an end 
point to be chained together.  

 
Engrave Icon enables you to use the Engrave Data dialog box to 
create a profile containing numbers and letters. 

Programming Examples using Mill Cylinder Machining Function 
A practical programming application of the Mill Cylinder machining function has 
been provided below.  This example assumes you have a knowledge of creating part 
geometry in the PartMaker CAD mode as well as creating tools in PartMaker’s Tool’s 
Database and creating cycles in PartMaker’s Cycles Database. 

Example A: Engraving on the Outside Diameter 
In the example given below, you will engrave the words “PartMaker” with a ¼ inch 
Spot Drill. If you wish to complete this exercise on your own, make sure you have 
the following tools created in your PartMaker Tools Database (all tools used in the 
Mill Cylinder Face Window should have an orientation of X Tool) 

 .25 Inch Spot Drill 

 

Features to be created: 

 

Engraving with the words 
“PARTMAKER” on the Outside 
Diameter 

Step 1. Create a Mill Cylinder Machining Function Face Window 

 Note: When creating a milled feature in PartMaker Turn-Mill, you must 
always start with a turning operation.  Thus you must have a face window of 
machining function Turn created and at least one Turning part feature and 
tool path created (such as a facing operation). 

Start by creating a Mill Cylinder Machining Function Face Window.  To do so: 

1 Enter the Setup dialog by choosing Setup from the View menu or by 
clicking on the Setup dialog icon in the upper left hand corner of the screen 

2 In the Setup dialog, click the New button create a new Machining Function 
face Window 

3 From the Machining Function drop down menu, choose Mill Cylinder 
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4 Enter the setup parameters as shown below: 

 
5 Once the Setup dialog appears as above, click on Close 

Step 2. Create Part Features 

 Note: When performing engraving it is not necessary to create part 
geometry. 

Start by entering the CAM mode in the Mill Cylinder Window.  

1 Choose Show Axes from the View Menu 

2 Choose Show Boundaries from the View Menu 

3 From the Part Features menu, choose the New Profile Group. 

4 Choose Contour Mill under Strategy 

5 Choose ON from Tool Position to indicate that we will be working on 
centerline with the tool. 

6 Enter an X_Surf of 0.3125 

7 Enter an X_Depth of 0.025 

8 Enter the Tool ID number of the 0.25 diameter Spot Drill created and click on 
Select Tools  

 
9 When all of the necessary data has been entered click on Close. 
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Step 3. Create Text 
1 Click on the Engraving Icon and the Engrave Data dialog box will display. 

2 Type the word “Partmaker” in the box shown below then click on OK. 

 
3 Drag a window around the text “PartMaker” and choose the Rotate 

command under Edit menu you will get the following dialog box shown 
below. 

4 Fill in all the necessary information from the dialog box below. 

 
5 When all of the necessary data has been entered click on OK 
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Your completed geometry should appear as shown below: 

 
6 From the Part Features menu, choose Verify Tool Path to see the tool path 

as shown below: 

 
7 Choose Hide Work Tool Path to hide the tool path. 
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Example B: Milling a Contoured Pocket 
In the example given below, you will mill a contoured pocket on the diameter with a 
1/8-inch End Mill. If you wish to complete this exercise on your own, make sure you 
have the following tools created in your PartMaker Tools Database (all tools used in 
the Mill Cylinder Face Window should have an orientation of X Tool) 

 .125 Inch Diameter End Mill 

 

Features to be created: 

 

Mill a Contoured Pocket with a 
.125 diameter End Mill. 

Step 1. Create a Mill Cylinder Machining Function Face Window 

 Note: When creating a milled feature in PartMaker Turn-Mill, you must 
always start with a turning operation.  Thus you must have a face window of 
machining function Turn created and at least one Turning part feature and 
tool path created (such as a facing operation). 

Start by creating a Mill Cylinder Machining Function Face Window.  To do so: 

1 Enter the Setup dialog by choosing Setup from the View menu or by 
clicking on the Setup dialog icon in the upper left hand corner of the screen 

2 In the Setup dialog, click the New button create a new Machining Function 
face Window 

3 From the Machining Function drop down menu, choose Mill Cylinder 

4 Enter the setup parameters as shown below: 
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Step 2. Create Part Geometry 
Start by entering the CAD mode in the Mill Cylinder Window. Draw the following 
features: 

5 Choose Show Axes from the View Menu 

6 Choose Show Boundaries from the View Menu 

7 Draw a ½ square with .125 radius corners anywhere in the boundaries. 

Your completed geometry and CAD Face Window should appear as shown 
below: 

 

 Note: You can always go to a different Face Window in your *.job file by 
selecting from the Window menu.  Additionally, you can toggle between 
different Face Windows within the active Window by choosing Show 
Windows Icons from the View menu and double clicking on the icon 
representing the Window you want to view. 
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Step 3. Create Part Features and assign tool paths 
Start by entering the CAM mode in the Mill Cylinder Window. First you will create 
the tool path to mill the square. To do so: 

1 From the Part Features menu, choose New Profile Group 

2 Choose Pocket Mill under Strategy 

3 Enter a X_Depth of 0.15 

4 Enter a Tool Diameter of 0.125 and click Select Tools 

5 In the Group Name field, type Mill Pocket 

Your completed Profile Group Parameters dialog should appear as shown 
below: 

 
6 Assign the part feature to the square drawn earlier by clicking the Chain 

Geometry icon and clicking on the geometry to create the tool path.  It 
should appear as shown below: 
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7 From the Part Features menu, choose Verify Tool Path to see the tool path 
as shown below: 

 

 
8 Choose Hide Work Tool Path to hide the tool path. 
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