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PowerSHAPE Pro offers you “Tribid Modelling”. This means that you will be able to 

use the PowerSHAPE surface and solid modelling functionality with the reverse 

engineering and triangle modelling options. 

With PowerSHAPE Pro you can: 

 Move data captured and reverse engineer into the design environment 

easier and so incorporate additional features into any reverse engineered 

design quicker; 

 Easily create CAD surfaces from triangle data through new options added in 

the Automatic Surfacing and Mesh Segment dialog; 

 Use the Compare Analysis option to see the differences between any two 

objects (new to PowerSHAPE Pro 2015); 

 Perform Boolean operations between the triangle models and either 

surfaces or solid models. 

In this training course you will: 

 Generate triangles from scanned data; 

 Edit the point clouds to get the best triangulation result; 

 Fix, smooth and morph triangles; 

 Sculpt triangles; 

 Perform boolean operations between meshes and a mesh and a solid; 

 Wrap triangles onto a surface or solid; 

 Use the “tribid” modelling techniques to create surfaces or solids from 

mesh. 

1. Introduction 



1 Introduction  PowerSHAPE Pro 2015 

Copyright @ Delcam  1.2 

 

PowerSHAPE Pro User Interface 
1 Double-left-click with the on the PowerSHAPE Pro 2015 icon displayed on your 

desktop. 

2 The PowerSHAPE Pro 2015 interface is displayed and a New Model is 

immediately opened. 

PowerSHAPE Pro uses a Windows-style interface with pull-down menus, toolbars and 

flyouts. The following areas of the screen are identified as follows: 

 

 

 - Pull-down menus 

 - Main toolbar 

 - Viewing and shading options 

 - Status bar 

 - Command toolbar 

 - Graphics window 
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PowerSHAPE Pro automatically starts a new empty model. The model name is 

displayed at the top left corner. The new model is not stored externally. 

 

The model should be saved permanently (recommended) with a more appropriate 

name and stored to an external directory. One or more previously stored models 

can be opened within the same PowerSHAPE Pro session. 

At the top of the screen there are a series of pull-down menus.  

 

3 Select the File menu, using the left mouse button. 

 

In the File menu models can be created, saved, imported, exported and printed etc 

while further sub-menus are accessed by clicking on the  arrow. 

If the mouse is held over a button for a short period, a ‘tool tip’ box containing 

description of the command is displayed. 

 

Towards the bottom left of the main graphics area is the Levels menu. Entities 

and objects can be assigned to a level for long term organisation of the model. 

 



1 Introduction  PowerSHAPE Pro 2015 

Copyright @ Delcam  1.4 

 

At the bottom of the screen are the Workplane and Principal Plane selectors, 

the grid definition, the cursor position, the tolerance and the command input 

area. 

 

PowerSHAPE Pros Main toolbar  provides access to the Workplane, Line, 

Arc, Curve, Annotation, Surface, Solid, Feature, Assembly, and Wizard  entity 

creation toolbars. 

 

Beneath the pull-down menus are the Main toolbar buttons . When selected, 

these buttons display the relevant functions on the Command toolbar as a sub-

menu  to the left of the graphics area.   

This Command toolbar contains all of the main options for creating within the 

chosen function. 

4 From the PowerSHAPE Pro Main toolbar, select the Line  icon, which will 

display the following sub-menu to the left of the graphics area. 

 

On this side the top two icons are fixed and compromise of the selection  

icon and the quick select flyout menu. 

 

While the lower icon will either show the General Edits , Model Fixing  

and Model Analysis  sub-menus. 

A small black triangle in the lower right hand corner of an icon denotes and 

flyout menu will appear if the mouse is held over, while the equivalent triangle in 

red denotes the same flyout menu can be cycled by clicking the icon itself. 



PowerSHAPE Pro 2015  1 Introdruction 

1.5  Copyright @ Delcam 

 

 

Toolbars 
All the available toolbars, including any custom toolbars cab be shown or hidden 

from the View drop down menu in View>Toolbars. Any toolbar with a tick 

adjacent to the name is currently visible. A single click on the name will toggle 

between visible and hidden. 

 

The Surface/Curve, Solid and Mesh Edit toolbars will only tend to used and 

visible while a relevant object is selected and worked on in the graphics area, 

so these will come and go from above the graphics area with your selection. 
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PowerSHAPE Pro Options 
The Tools > Options page allows the user to configure PowerSHAPE Pro from the 

factory default settings. The options are stored within several main categories, 

accessible by clicking on the adjacent  symbol. 

It is possible to make changes to the factory default settings and store them as 

the new default settings to be active with subsequent PowerSHAPE Pro 

sessions. 
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Mouse buttons 
Each of the three mouse buttons performs a different operation in PowerSHAPE. By 
using the ALT, Ctrl or Shift key, these operations can be extended. 

Left Mouse button 1: Picking and selecting 

 

This button is used for selecting items off the Main pull-down menus, entering data, 

and selecting parts of the model. 

Middle Mouse button or wheel: Dynamics 

 

Zooming: Hold down the Ctrl key and middle button/wheel and move the mouse up 

and down to zoom in and out of the view. Hold down the Ctrl, Shift Key and middle 

button/wheel to select a framed area to zoom into. 

Panning: Hold down the Shift key with the button/wheel while moving the mouse, 

to move the view across the component.  

Rotating: Hold down the middle button/wheel and move the mouse. A tracker 

ball appears at the centre of rotation, as does the view orientation axis in the 
bottom left corner of the screen. If View Spinning is switched on (Tools > Options > 

Views) the view will spin around until the user executes a further mouse click. 

If available, the middle mouse wheel can be used to scroll text. 

 

Right Mouse button 3: Special Menus 

 

When this button is held down a local menu is opened. The contents of the menu 
depend on the entity selected. For example, when the cursor is over a line, the Line 

menu appears; when the cursor is in the graphics area, the View menu appears. 
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Exercise 1: Dynamic mouse controls. 
In this exercise you will Import an existing, stored model and change the views using 

the dynamic mouse options. 

1 From the main menu select File > Open or  to open an existing PowerSHAPE 

model (.psmodel). 

 

2 Open the model: 

.....\PowerSHAPE_Data\pump housing.psmodel 

 

When a model is imported into a new PowerSHAPE session, the default view is 

down the Z-axis. 

The model has opened in wireframe view as originally saved. Preferred shading 

options on opening models can be changed from Tools>Options>View>Views 

 

The view toolbar, on the right of the PowerSHAPE window contains three main 

areas 

 Views. 

 Dynamics. 

 Shading. 

3 Select the view Iso 1 , the model is now displayed using the first of 4 

isometric views. Surface or Solid entities of the model can be displayed as 

shaded if required. 

4 From the views toolbar open the Shaded view pull out menu.  
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5 From the available options pick Shaded View.  

 

The surfaces have been shaded to show the full extent of the surface area. The 

wireframe from which it is constructed can also be shown if required. The model 

can be rotated dynamically so that the user can view the underside detail. 

6 Hold down the middle mouse button and move the mouse to rotate the view to 

display the underside. 

7 Hold down the Shift key and middle mouse button and move the mouse to 

position (Pan) the view suitably. 

 When scrolling the middle button (wheel) to zoom, the position of the 

cursor is the focal point. 

 

The underside can now be seen clearly. There are many different options for 

viewing the model that you can select. There are also a variety of keyboard 

shortcuts that you can use. 
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8 Select View > Single [about selection]. 

 

The keyboard shortcuts for the views (and other functions) are listed, such as 

Ctrl+1 (Press Ctrl on keyboard then number 1) for the Iso 1 view. By pressing 

Num Lock on the keyboard, the number pad can be used with the Ctrl key to 

change the views. 

There is also an enhanced shading option that displays the model in a 

Perspective view with the lines running to a vanishing point as if on the horizon. 

9 Select Back [+Y]. 

 

Another view is displayed. The PowerSHAPE model needs to be closed. In this 

case it does not need to be saved, as the model has not been altered. 

 All PowerSHAPE help options and keyboard shortcuts are listed in chapter 13 

of the training manual. 
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Selecting Entities 
To be able to perform any edits, individual entities must first be selected.  

If an entity is selected with the left mouse button it will be displayed with a yellow 

colour. If a box is dragged across a group of entities they will all be selected (The 

default setting does not require an entity to be completely boxed). 

To select more than one item within a group, hold down the Shift key while selecting 

individual entities to add to the selection. To toggle a selected item on or off, the 
Ctrl key is depressed while using the left mouse key to pick the entities. 

The Select flyout (above command toolbar) reveal the following options. 

 

 

 

There are options within this Selection toolbar to enable the user to quickly select 

all items in the view of a particular type. They are Wireframes, Surfaces, Solids, 

Surfaces & Solids and components (assembly), meshes and point cloud. 

 

 

 

For more complex models, the selection filter  can be used to discriminate 

entities using a more specific combination of search criteria, such as the type of 

wireframe, colour, and line style. 
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Blanking Entities 
If one or more entities are selected, they can be temporarily removed from the 

graphics area by selecting Blank. This is available from the local menu (right mouse 

click) or selecting the Blank icon  from the Viewing and Shading toolbar. 

This command is useful when you want to temporarily undraw some objects from 

the current view where Levels is not appropriate. This is because, a level may 

contain objects you don’t want to be hidden and/or changing the levels may affect 

the model’s logical structure. 

Blanking allows you to remove selected objects from the screen. They are not 

deleted, but merely hidden and can be unblanked when required. This allows you to 

concentrate on the objects you need to work on without being hindered by other 

irrelevant entities. 

If it is required to temporarily keep the selected entities from the graphics area and 

hide the rest then Blank Except is applied. To return all entities back to the graphics 

area, Unblank is applied from the screen menu. Blank Toggle allows the user to 

toggle between the two views of Blanked and unblanked entities. 

 When using often, the shortcut keys are useful 

 

Ctrl+J Blank 

Ctrl+K Blank Except 

Ctrl+L   Unblank 

Ctrl+Y  Blank Toggle 

 

Each will be demonstrated using the current model 

 

10 Select the upper surface of the pump housing and its outline will change to a 

yellow colour. 

  

11 Select Ctrl+J to temporarily remove the upper surface from the graphics area as 

shown to the right (above). 

12 Select Ctrl+L to return the blanked surface back as the selected item. 



PowerSHAPE Pro 2015  1 Introdruction 

1.13  Copyright @ Delcam 

 

13 View the model from Left (–X) , then box select the flange surfaces as 

shown. 

 

 

14 Select Ctrl+K to keep these surfaces and temporarily hide all others. 

15 View in ISO 1.  

 

16 Select Ctrl+Y to blank toggle and view the blanked surfaces 
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17 Select Ctrl+Y to toggle the view again. 

18 Finally select Ctrl+L to return and show all surfaces. 

 

19 Select File > Close. 

 

A message box appears asking if it is required to save the changes. In this case 

no changes have been made to the model. 

20 Select No. The current model is now closed.  
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Help menu 
 

The Help menu provides the tools related to the on-line help system. 

 

 Contents and Index 

 What's New 

 Getting Started 

 Learning Assistant 

 Tutorials 

 PowerSHAPE updates 

 PAF updates 

 PowerSHAPE newsletter 

 User Forum 

 Delcam on the Web 

 About 
 

Help > Contents and Index 
Select this option to display the contents and index of the help file.  

The right hand frame displays the welcome page and provides links to further 

information about the program and the on-line tutorials. 

2. Help and Shortcuts  
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PowerSHAPE Help Contents 
PowerSHAPE has an extensive support that can be accessed by either selecting Help 

from the top menu or by pressing F1 on the keyboard. The  

1 Press F1 on the keyboard to launch the HTML browser window. 

 

The window displayed above is the welcome page and can be accessed by 

selecting the small home  tabbed icon at the top of the window. A number of 

other options are available to help navigate the information. 

  

 

2 Select the Learning assistant  to access an interactive list of common tasks. 

3 Select Tutorials to access free tutorials which can be downloaded or 

installed from the installation DVD. 

4 Select Help  to access the complete online reference help which allows you 

to search by index or keyword(s). 
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Topics are listed in the left-hand window and the specific help for a selected item 

is displayed in the right pane.  

The Hide button can be pressed to hide the topic list. The button then changes to 

Show which again redisplays the topic list. 

5 Close the browser window using the button at the top right corner. 

 

Help > What's New 
Use this option to view details of new features in the latest release. The What's New 

is displayed in one of the following ways: 

 If full documentation is not installed, What's New will appear in the browser 

window. 

 If full documentation is installed, What's New will appear in a new, floating 

window. 
 

Help > Getting Started 
Select this option to display the browser. Use the browser tabs to select the type of 

help you require. 
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Help > Learning Assistant 
This displays and removes the Learning Assistant window. 

 

The Learning Assistant lists common PowerSHAPE tasks. A series of dropdown 

menus provide interactive help as you work through the tasks. The help is context 

sensitive and will update automatically as you use the program. 

You can also use the Learning Assistant's drop down menus to execute a command. 

To create a single line using the Learning Assistant, 

1 In the Assistant window, click the Creating Objects drop down menu. 
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2 Click the Lines button. This will display a new list of options.  

 

3 Click How? to see details about creating a line.  
 

Help > Tutorials 
PS-Tutorials are a free add-on module. If you are using a non-English version of 

PowerSHAPE, the tutorials may be displayed in English. 
 

Help > Check for PowerSHAPE updates 
Use this option to check the Product Download site so that you can download the 

latest release version of our products. 
 

Help - Check for PAF updates 
Use this option to check the Product Download site for a new PAF to download. To 

check for a PAF updated you need to be connected to the internet and have a valid 

licence file. 
 

Help > Subscribe to the PowerSHAPE newsletter 
This generates an email using your default mail tool. When you click Send, your 

email address is added to the distribution list for the Delcam email newsletter for 

PowerSHAPE. 
 

Help > Visit the User Forum 
This links to the Power Solution User Forum on the www.delcam.com 

(http://www.delcam.com) website. 

The User Forum is intended for new and established users to join and participate in 

user discussions to share ideas and experiences of PowerSHAPE or other Power 

Solution products. 

 

http://www.delcam.com/
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Help > Delcam on the Web 
This gives options to quickly access our website (providing you have internet access 

from your computer). 

 

PowerSHAPE Home Page - This displays PowerSHAPE's home page 

www.powershape.com/powershape/powershape.htm 

(http://www.powershape.com/powershape/powershape.htm), which gives news and 

information on PowerSHAPE. 

Delcam Home Page - This displays our home page www.delcam.com 

(http://www.delcam.com). You can find here full PowerSolution news and 

information. 
 

Help > About 
Select this option to display a dialog showing the PowerSHAPE version and copyright 

details. 

The dialog also provides: 

 licence and user information. 

 the language set on your PC and that used by PowerSHAPE. 

 patent information. 

Click OK to close the dialog. 
 

 

http://www.powershape.com/powershape/powershape.htm
http://www.delcam.com/
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PowerSHAPE Shortcuts 

Shortcuts to menu options 
The keyboard can be used to access the menus. Every menu item has an underlined 

letter. 

1 Look at the menu bar and find the menu you wish to access. One of its 

characters is underlined. 

For example, F is underlined for the File menu. 

2 Hold down the Alt key and press the appropriate character to display the menu 

option. 

For example, Alt - f opens the File menu. 

3 Look at the option menu and find the option you wish to access. One of its 

characters is underlined. 

For example, O is underlined for the Open option. 

4 Press the character underlined in your required option. 

For example, O opens the Open dialog. 

If you prefer to use the keyboard, here are some other useful controls: 

 Once the Alt key has activated the menus, you can navigate using the arrow 

keys.  

 To accept a menu, press Enter. 

 To do nothing and close a menu, press Esc. 
 

Shortcuts to frequent commands 
The following table lists shortcuts to frequently used commands. These shortcuts 

also appear on the menus alongside their respective options. 

Menu option Shortcut* 

File - New Ctrl + n 

File - Open Ctrl + o 

File - Close Ctrl + F4 

File - Save Ctrl + s 

File - Print Ctrl + p 

File - Exit Alt + F4 

Edit - Undo Ctrl + z 

Edit - Cut Ctrl + x 

Edit - Copy Ctrl + c 

Edit - Paste Ctrl + v 

Edit - Paste Special Ctrl + e 

Edit - Select - Clear selection Ctrl + d 

Edit - Select - Select All Ctrl + a 

View - Single (of model) - Top Ctrl + keypad 5 
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Menu option Shortcut* 

View - Single (of model) - Bottom Ctrl + keypad 0 

View - Single (of model) - Left Ctrl + keypad 4 

View - Single (of model) - Right Ctrl + keypad 6 

View - Single (of model) - Front Ctrl + keypad 2 

View - Single (of model) - Back Ctrl + keypad 8 

View - Single (of model) - Iso 1 Ctrl + keypad 1 

View - Single (of model) - Iso 2 Ctrl + keypad 3 

View - Single (of model) - Iso 3 Ctrl + keypad 9 

View - Single (of model) - Iso 4 Ctrl + keypad 7 

View - Single (about selection) - Top Alt + keypad 5 

View - Single (about selection) - Bottom Alt + keypad 0 

View - Single (about selection) - Left Alt + keypad 4 

View - Single (about selection) - Right Alt + keypad 6 

View - Single (about selection) - Front Alt + keypad 2 

View - Single (about selection) - Back Alt + keypad 8 

View - Single (about selection) - Iso 1 Alt + keypad 1 

View - Single (about selection) - Iso 2 Alt + keypad 3 

View - Single (about selection) - Iso 3 Alt + keypad 9 

View - Single (about selection) - Iso 4 Alt + keypad 7 

View - Shading - Wireframe F2 

View - Shading - Shaded F3 

View - Shading - Transparent Shaded F4 

View - Shading - Transparent Shaded Wire F10 

View - Shading - Shaded Wire F11 

View - Shading - Dynamic Hidden Line F12 

View - Look From - Last View F5 

View - Zoom Full F6 

Tools - Model Analysis - Smoothness Shading F7 

Tools - Model Analysis - Undercut Shading F8 

Tools - Model Analysis - Minimum Radius Shading F9 

View - Blank - Blank Selected Ctrl + j 

View - Blank - Blank Except Ctrl + k 

View - Blank - Blank Toggle Ctrl + y 

View - Unblank Ctrl + l 

View - Refresh Ctrl + r 

Object - Surface - Smart Surfacer Ctrl + t 

Object - Surface - Fillet Ctrl + f 



PowerSHAPE Pro 2015 2 Help and Shortcuts 

Copyright © Delcam  2.9 

Menu option Shortcut* 

Object - Curve - Composite Curve Ctrl + h 

Macro - Run Ctrl + m 

Swap individual graphics windows in the Window menu Ctrl + F6 

Help - Contents F1 

* For the keyboard shortcuts to work, you must have Caps Lock Off and Num Lock 

On. 

Other shortcuts 

Operation Shortcut* 

Bold text Ctrl + b 

Italic text Ctrl + i 

Underline text Ctrl + u 

Diameter character in text Ctrl + Alt + d 

Degrees character in text Ctrl + Alt + s 

Plus/minus character in text Ctrl + Alt + p 

Interrupt current operation Esc 

Exiting a creation mode Esc 

Halt program (after accepting confirmation dialog) Esc - 3 times 

within 1 second 

* For the keyboard shortcuts to work, you must have Caps Lock Off and Num Lock 

On. 
 

Customising menu shortcuts 
You can create your own shortcuts for menu options. 

1 From the Tools menu, select Customise. 

2 Use the Menu Shortcuts tab of the Customise dialog to set up your own shortcuts. 

 

Menu - Select a menu from the list of the menus that appear at the top of the 

screen. . 

Menu Item - The options for the selected menu. Select the option for which you want 

to create a shortcut. 

Shortcut - The current shortcut for the selected option. If a shortcut does not exist, 

None is displayed in the box. 
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Replacement - The shortcut that you want to use for the selected menu option. 

Ctrl/Alt/Shift - Turn ON these options if you want to use any of these keys as part of 

the shortcut. 

Key - A list of keys you can use for the shortcut. If none of the Ctrl/Alt/Shift keys are 

selected, you can only choose one of the F function keys. If any of the Ctrl/Alt/Shift 

keys are selected, you can choose any alphanumeric character or an F function key. 

Create - Assigns the replacement shortcut to the select menu option. The 

replacement shortcut now appears in the Shortcut box. The new shortcut will also 

appear next to the menu option. If a shortcut already exists, you are asked if you 

want change its use. 

Remove - Removes the current shortcut for the selected menu option. None appears 

in the Shortcut box. 

Reset - Resets all the shortcuts back to the original shortcuts. 

OK - Removes the dialog from the screen. 
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Workplanes 
Workplanes are user-defined datums. They can be positioned and aligned as 

required to simplify model creation.  

 

An active workplane represents the current workspace and its origin. 

Any number of workplanes may exist in your model, but only up to one can be 

active at a time. You may activate and deactivate workplanes at any stage. 

When a workplane is active it becomes the XYZ datum, visually larger in size, 

and changes colour from grey to the coloured symbol above (when selected) or red. 

Model entities can be copied or cut from the currently active workplane and 

then pasted back in a different position, relative to a new active workplane. 

The main Workplane button  is located in the Main toolbar. When selected, it 

displays the following buttons in the workplane toolbar to the left of the graphics 

window. 

 

A simple wireframe box with angled top will be initially created to demonstrate the 

basic applications of workplanes. 

3. Workplanes 
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Box Example 
1 Open a new model. 

The wireframe for the dimensioned model (as shown below) will now be created. 

 

2 Select Single Workplane  and enter 0 into the Command Input window to 

position it on the default World datum. 

3 Select the view Iso1  

4 From the Line toolbar , select Rectangle . 

5 Enter 0 in the Command input box and press Enter. 

6 Enter 100 75 in the Command input box and press Enter. 

 

 The rectangle is not a single entity, but consists of 4 separate, wireframe 

lines. 

7 From the Line toolbar, select Continuous Lines.  

8 Snap the start of the line onto the workplane (or enter 0) 
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9 Enter 0 0 100 in the Command input box and press Enter. 

10 Enter abs 0 75 150 in the Command input box and press Enter. 

 Adding the prefix abs changes the input from the default relative to absolute 

coordinates. 

11 Snap (left-click) the end of the current line to the top-left corner of the rectangle 
(marked as End by the Intelligent Cursor below). 

 

12 Press the Esc key or click  to end creation mode.  

13 Select the last three lines generated. 

A copy will be moved to the other side. 

14 Select Move  to display the Move toolbar. 

15 Select Copy the selected items , enter 100 in the X input box, and press Enter to 

display the preview 

 

16 Select the green tick  to accept. 
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17 Use Single Lines  to complete the model by snapping to End points as 

shown. 

 

The main wireframe model is now complete. 

Creating and Editing Workplanes 

Workplanes within PowerSHAPE can be created in the following ways 

 Create a Single Workplane 

 Create Multiple Workplanes 

 Create a Workplane aligned with geometry 

 Create a Workplane Aligned with minimal depth of selection 

 Create a Workplane Aligned with the average normal of selection 

 Create a Single workplane at top of selection 

 Create a Single workplane at centre of selection 

 Create a Single workplane at bottom of selection 

 Create a Workplane from three points 

 Create a Workplane Aligned with the current view 

 Create a point 

Depending on the option selected, Workplanes can be created by:  

 Snapping onto the screen or geometry using the left mouse button.  
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 Entering the coordinates using the command input box 

 Generated from the geometry and option type selected. 

 

Workplanes can be edited using the Workplane dialog. This is accessed by double 

clicking on the workplane or selecting modify from the right click menu. 

 

Editing using Graphical handles 

  Single selecting a Workplane will display its graphical handles. 

 

 

For each graphical edit, the handle to select is shown and summarised below. 

To move the Workplane origin, select the centre point 

(sphere) and drag. The Confirm Drag dialog will appear for confirmation and/or 

changes.  

To change the direction of the X, Y or Z axes, select 

the end arrow head and release over an item. The selected axis will point in that 

direction.  
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To move the workplane along the X, Y or Z axes, 

select the handle of the axis itself and drag. 

To twist around the X axis, select any blue handle. 

 To twist around the Y axis, select any green handle. 

 To twist around the Z axis, select any red handle 

 

18 Select Single Workplane , and snap a new workplane to the top end of the 

line running up Z from the original Workplane. 
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The new workplane is now active displayed in red, with the previous 

workplane now deactivated (shown in grey). 

19 Ensure the graphical handles are displayed, then drag any of the blue handles on 

the +Y and release at the upper left corner as shown. 

 

By rotating about the +X axis, the +Y axis is in line with the angled face. 

With the workplane now in the correct orientation, it will now be centred 

within the top wireframe boundary. 

 

20 Use Ctrl and left-click to select the four lines that enclose the angled top-face 

of the model 

21 From the Workplane toolbar, select Single workplane at centre of selection.  
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A new workplane is created, central to the four selected lines. This 

workplane is both active and selected. 

22 Create a Full Arc (Circle) of radius 40, about the currently active workplane. 

 

The Radius 40 circle has been created on the XY face of the active 

workplane and is central to the angled-top face of the wireframe model.  
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Master Workplane 

1 Right-click on the active workplane to open the popup menu and then 
deselect Activate.  

 

There is no active workplane; all coordinates are now defaulted to the 

World coordinate system.  

 

If required, any Workplane can be assigned to be the Master Workplane. 

2 Right-click on the previous active workplane to open the popup menu and then 
select Master.  

 

 

 The Workplane is not currently active but has now been assigned as the 

Master Workplane. 
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3 Re-activate this Workplane. 

 

A previously created 2D model will now be copied and pasted onto the active 

workplane. 

4 Import the model: 

C:\\Training Data\PowerSHAPE Data\workplane feature.dgk 

 

Workplane toolbar 

In the bottom left corner of the graphics area, is a drop-down menu that 

provides an alternative means to control the naming and activation of 

workplanes. 

 

1 Select the small black arrow to reveal the workplanes currently available in 

this session. 



PowerSHAPE Pro 2015 3 Workplanes 

Copyright © Delcam  3.11 

 

Simply selecting the workplane in this menu makes it active. In addition, 

Workplanes can be renamed from the default number provided. 

2 Select Workplane 3 and rename it to centre face by typing over and pressing 

Enter. 

3 Rename Workplane 4 to feature. 

 

4 Activate the workplane renamed feature. 

 

5 Select all the wireframe above of the imported model then copy  from 

the main menu. 

The selected wireframe is copied to the clipboard. 

6 Activate the workplane renamed centre face using the Workplane toolbar. 

7 Select Paste from the local menu. 

 

The wireframe imported away from the main model is copied relative to the 

workplane central to the top-angle face of the main wireframe model.  
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 Data relative to an active workplane in one model can be copied and pasted 

relative to an active workplane in a different model. 

8 Save the model as: 

...... Workplane box.psmodel 

 

9 is an section of toolbar that includes a Workplane button  for creating 

temporary workplanes 

Temporary Workplanes 

If a permanent Workplane is not required, then PowerSHAPE provides the ability to 

create a temporary Workplane. The icon is visible next to the workplane toolbar. 

 

 

A temporary workplane cannot be aligned dynamically, nor does it have access to a 
local editing dialog, but it can be modified using the General Edits toolbar. It is 

automatically named Temporary and can be deleted using the local (right click) 

menu or by reselecting the Temporary Workplane button. 

Workplane alignment of molding component 
When a component model is imported, it may not be in a suitable orientation for 

such tasks as creating a tool around it, or for maximum accessibility to a 3-axis 

machining operation. In these cases, workplanes are applied to achieve a more 

suitable location and orientation for the model. To maintain dimensional 

accountability to the original component, it is essential to move workplanes around 

the model (as opposed to physically moving the model relative to the world datum). 

1 Close any previous PowerSHAPE models. 

2 Import the surface model: 

.....\PowerSHAPE_Data\InteriorTrim.dgk. 

3 If the model is not visible, select Resize to Fit  to centre in page. 



PowerSHAPE Pro 2015 3 Workplanes 

Copyright © Delcam  3.13 

 

The imported model of a plastic molding is not in a suitable orientation 

from which to create a mold tool. A suitably positioned workplane will be 

created to provide an appropriate tooling datum. 

The most obvious choice for a tooling alignment is normal to the base of the 

pocket. 

4 Use the middle mouse key to rotate the view to display the underside of the 

component. 

5 Select Single workplane aligned to geometry  and left-click anywhere on the 

flat surface defining the underside face of the pocket. 

 

The Z axis is normal to the surface. With this orientation, the centre of the 

pocket will be calculated. 

6 Select the surface only defining the underside face, the select Single workplane at 

top of selection.  

 

The workplane is positioned central to the selected surface. 
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7 Select and delete the original workplane used to create the alignment with the 

base of the pocket. 

8 View the model in all directions to check that a suitable tooling alignment has 

been achieved. 

  

It is possible that the model may need to be rotated 180 degrees about the X 

axis at some stage. This can be performed using the Workplane editing dialog. 

9 Right-click on the workplane, and select Modify in the popup menu. 

 

10 Select Twist X.   

11 Enter 180 in the Calculator dialog, and select OK.  

12 Select OK in the Workplane dialog. 

 

The model is now viewed the other way up, relative to the new orientation of the 

workplane. 

13 Save the model as: 

......\PowerSHAPE-Models\Interior Trim ex1 

14 Close the model. 
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Exercise 3: Workplane creation 
 

1 Open the surface model: 

.....\PowerSHAPE_Data\Exercise 3 model.psmodel 

2 View in ISO 1.  

 

3 Create a workplane at the centre of the pocket aligned to the top sloped face 

as shown. 

 

4 Rename the Workplane Angled left pocket. 
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5 Create a radius 15 circle in the position shown.  

 

6 Create a Workplane at the top centre (highest point) ensuring the +Z is 

directed towards the component as shown. 

 

 

 

7 Save the model as: 

....../PowerSHAPE-Models/Ex 3 Workplane creation.psmodel 
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Levels enable you to group model entities and help simplify the display and selection 

of items. Levels can be distinct groups of component surfaces, or different types of 

entity, and they can be renamed to identify the items they contain.  

Objects can be assigned to different levels, which can then be displayed or 

hidden to help manage the selection and visualisation of entities within a 

model. A typical use is to assign the inner wall surfaces of a component to a one 

level, and the outer wall surfaces to another.  

PowerSHAPE Pro supports up to 1000 levels (0 – 999), but levels 998 and 999 

are reserved for internal use.  

Example 
1 Open the model......PowerSHAPE Pro data/re-eng levels.psmodel 

As you can see this model contains a mixture of Solids, Surfaces and Mesh 

used to aid the reverse engineering process for this model. Currently all the 

different entities are visible and overlapping each other due to the nature of the 

process. Blanking (Ctrl+J) or Blank Except (Ctrl+K) certain entities is good for 

more short term requirements, however a more semi-permanent solution 

is best in this case. 

 

 

2 Ensure everything in the model is visible by unblanking all entities (Ctrl+L). 

4. Levels  
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3 From the lower-left side of the window open the Levels form.  

 

Each level has a number. Visible levels are indicated by .  Hidden levels are 

indicated by . You can turn ON a level by clicking  and OFF by clicking .  

PowerSHAPE Pro has a number of default levels (0 – 4), while a new level is 

created by simply typing a name into the name box adjacent to the level 

number. 

Level names can be edited by just modifying the existing name and are visible by 

hovering the mouse over the level number. 

4 In level 10, enter the name Mesh which will create a level called ‘Mesh’ on 

number 10 which is turned OFF by default. 

 

5 Select OK to close the dialog. 

6 From the Quick Select toolbar, select Quick Select All Mesh. 

 This will select ALL visible mesh in the model. 
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7 Click the middle mouse button over the level 10 icon on the levels toolbar at 

the bottom left of the window, to move the selected items to that level. 

 The Mesh, which is purple in PowerSHAPE Pro, should now disappear 

from the graphics window because the level is turned OFF. 

8 Toggle Level 10 ON and OFF to highlight that the Mesh has been successfully 

placed on the correct level. 

9 Open the Levels form and create a level called ‘Untrimmed Surfaces’ on 

number 20. 

 This has created a level to place the untrimmed surfaces creaed using 

the Automatic and Manual Mesh Segmenter tools that we will be 

using later in the notes. 

10 Select OK on the form. 

11 Quick Select All Surfaces from the Quick Select flyout menu. 

 

12 Place all the selected surfaces on level 20 using the middle mouse button. 

 Again, as the level is turned OFF the surfaces should disappear from 

view. 

13 Right-click over level 20 on the levels toolbar and select Solo. 

 This will turn ALL other levels OFF except level 20. Again this will 

highlight that the surfaces have been correctly located on the level. 

This model also contains a number of solids and some contruction wireframe 

making up different components of the same group of parts. We have the lower 

half of the mold and the complete component solid models in this session. 

When we would like to create a number of different levels to organise a family of 

parts and construction information we can Group Levels by defining an overall 

group name and then the individual levels names, separated by a colon. 

Grouping levels 

This model also contains a number of solids and some contruction wireframe 

making up different components of the same group of parts. We have the lower 

half of the mold and the complete component solid models in this session. 

When we would like to create a number of different levels to organise a family of 

parts and construction information we can Group Levels by defining an overall 

group name and then the individual levels names, separated by a colon. By 

grouping levels together, you can manage parts of the model more efficiently 

and effectively. 

1 From the lower-left side of the window, open the Levels form.  

2 In level 30, enter the name Component : Construction Lines. 

3 In level 31, enter the name Component : Solid Mold. 

4 In level 32, enter the name Component : Bottle. 
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 You may have become aware that we are leaving defined gaps between 

each of the separate ‘groups’ of levels we create, e.g 10, 20, 30 etc. 

This is because looking forward we may require levels in between such as 

11, 12, 13 for further objects and entities relevant to each ‘group’. 

 

The word Component is the group name and Wireframe and Solid are the level 

names. 

5 Select OK. 

The three new levels now belong to the group called Components.  

 

On the Levels toolbar, the buttons of levels 30, 31 and 32 have changed to purple. In 

addition, a new Levels Group button is displayed, also in blue . You can use this 

Levels Group button to turn all levels in the group ON and OFF simultaneously. 

 Each new group is assigned a different colour so you can distinguish 

between them.  

6 Select Quick select all wireframes  from the Select  toolbar. 

 

7 With all the wireframes highlighted, middle mouse button over level 30. 

8 Select the component mold solid and place it onto level 31. 

9 Repeat for the Bottle solid onto Level 32. 

10 Select  to switch off all the associated components levels. 
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Using Copy and Paste to make copies of entities 

In some instances, it is advisable to make safe/backup copies of solid, surface or 

wireframe entities. For this exercise, we will copy the mold solid and paste it onto 

the general level. 

1 Turn on level 31 (Component : Solid Mold) using the right-click solo 

function and select the solid. 

2 From the top toolbar, select Copy  and then Paste.   

Two identical solids are on level 31. 

3 Select one of the solids and move it to level 0 : General.  

4 Switch off level 31. Toggle level 0 on and off to see the new copy. 

5 File >Save as 

\PowerSHAPE Pro Models\Mold Levels Example.psmodel 
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Introduction 
PowerSHAPE can generate points, lines, arcs, and curves in 2D and 3D space, which 

are collectively known as Wireframes. These wireframes have several functions, 
which include being the basic framework for several types of surfaces and solids, 

and as the drawing entities in Delcam Draft. Wireframes can be exported in a variety 

of file formats for use in other software products. 

The buttons for generating Wireframe objects are located within the main toolbar. 

 

1 Select Line from the Object menu.  

 

The following Line creation options are available. 

 Single Lines 

 Continuous Lines 

 Rectangles 

 Polygons 

5. Wireframe Modelling 
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 Selection Box  

 Create the shortest line between two selected objects 

 Chamfers 

 Untrimmed chamfers 

 

2 Select Arc from the Object menu.  

 

 

The following Arc creation options are available. 

 Full arc (circle) 

 Create an arc through three points/items 

 Create an arc through centre, radius and span 

 Fillet arc 

 Untrimmed fillet arc 
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 The Intelligent Cursor 
The Intelligent Cursor provides dynamic assistance for its two primary functions: 

1 Point input - it activates construction lines and labels for dragging, snapping 

and for point creation. 

2 Selection - it highlights the object under the cursor ready for selection 

The Intelligent Cursor is ON by default. You can turn the Intelligent Cursor OFF (or 

back on) by using the options on the Intelligent Cursor flyout. 

 

1 Click  to turn the Intelligent Cursor off.  

2 Click  to turn the Intelligent Cursor on (default). 

 

When the Intelligent Cursor is turned on, objects are highlighted as you move the 

cursor over them. This shows which objects can be selected if you click at that point  

Key points and features available are: 

 End-point 

 Mid-point 

 Centre-point 

 Centre Key-point 

 On 

 In 

 Intersection 

 Tangent 

 End Closing a curve 
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Construction lines 

When you move the intelligent cursor over an important key point, construction 

lines are created from that key point. You can now drag the cursor along a 

construction line and see the appropriate labels display. Clicking causes the position 

to snap to that point.  

A simple box will be drawn to illustrate this: 

1 From the top Menu bar, select File > New, or click on Open New Model  

on the Main toolbar. A New Model is opened. 

2 Select the Workplane Icon  and type 0 into the Command Window and 

then press Enter. 

 This will create a Workplane at 0, 0, 0 to allow us to visualise the 

position of the World UCS. We will cover workplanes in full later in the 

course 

3 Select a View in (+Z).  

4 From the Line toolbar , select create a Continuous line.   

5 Click anywhere in the graphics area to start a line. 

Dynamic feedback on the cursor position indicates A for angle (from dashed 

line) and L for length.  

 

6 Drag along a horizontal construction line (A:0) and then click to create it. 
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7 Drag along a 90˚ construction line (A:90) and click. The line snaps to give a 

square intersection. 

 

8 Drag the cursor down to the original start point and hover. The cursor displays 

End (do not click). 

 

 

9 Drag along the vertical construction line until Intersection is shown. 
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10 Click to snap at the intersection point then finally back down to the start point 

when End is displayed. 

     

11 Select and delete all wireframes. 
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Wireframe Lines and Arcs Exercise 

The following exercise demonstrates basic Wireframe modelling by recreating the 

2D profile shown below. Lines and Arcs will be used to complete the design. 

 

Line Creation 

To begin, a single line will be created from 0 to Y40 to coincide with the R 15 arc 

centre shown above. 

1 From the Line toolbar , select create a single line.   

 

2 In the command input box, enter the value 0 followed by Enter.  

 

This defines the start coordinate for the single line (bottom left corner). 

3 Input the values 0 40 followed by Enter. 
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 The X Y Z coordinates are entered in this order by default. Each input must 

be separated by a space and if the second or third values are not given, they 

are treated as zeros.  

4 From the Line toolbar, select create a continuous line.   

5 Snap to the start point of the first line, or enter 0 in the command input box. 

6 Input the value 60 in the Command input box, then Enter. 

 

7 Input the value 40 40 in the Command input box, then Enter. 

 

With the continuous line mode still active, a construction line to locate the R30 

centre will be dragged dynamically while being monitored by the Intelligent 

Cursor.  

 

8 By moving the mouse further, drag the end of a new line to a distance of 30 

along the normal (90 degrees) direction and left-click to accept the line. 

 

9 Press the Esc key to exit line creation. 
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Arc Creation 

The remainder of the 2D model is to be created using various arc options. 

1 From the Arc toolbar , select Full Arc.   

2 Input the value r 15 in the Command box and press Enter. 

 

This input redefines the default radius 

 A space must be included between the command r and value. 

 

3 Move the cursor over the open end of the vertical line until the text End is 

displayed then left-click to snap the circle centre position.  

 

4 Press Esc to exit. 

 

Wireframe objects can be edited by: 

 Double left mouse clicking on the object. 

 Right mouse select on the object then Modify from the local menu. 

In both methods the editing form appears  

 

 

5 From the Arc toolbar , select Arc through centre, radius and span.  
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6 Snap on the open end of the construction line for the centre point as shown. 

 

7 Move the cursor to the other end of the line and left-click.  

 

The position is now set for the start of the arc. 

8 Release all mouse buttons and drag the arc around counter-clockwise. 

The intelligent cursor displays the current span angle. When you left-click, the 

arc is created. 

 

9 Left-click when the arc reaches about 250 degrees. 
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Next, a blend radius (R 60) will be generated between the arc and circle using 

Create an arc through three points. The first and second points will be 

snapped as tangencies to the existing full circle and arc with the third point 

being entered as the specified blend radius of 60. 

 

10 From the Arc toolbar , select Arc through three points.  

11 Use the Intelligent cursor to locate and click on the tangent point of the arc. 

 

12 Locate and click on the tangent point of the circle. 
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13 Drag the third radius point to the required shape and to a value as close as 

possible to 60, then left-click. 

14 If necessary, in the Arc Confirm dialog, modify the Radius value to 60 and 

toggle through Next Solution until the correct shape is achieved. Select OK. 

 

 

The new arc has been trimmed back to both the adjacent arc and circle.  

 

15 Use Arc through three points/items  to create the radius of 10 between 

the full circle and the vertical line.  

 

 

 

 

 

 

 

 



 PowerSHAPE Pro 2015 5 Wireframe Modelling 

Copyright © Delcam  5.13 

Wireframe Lines and Arcs Editing 
Once Lines or Arcs have been created there are two main ways which they can be then 

edited. This can be done Graphically from within the graphics window or using the 

Line/Arc Editor dialog. 

Line Edits 

As with all Objects* in PowerSHAPE a single left mouse click on the Object, in this 

case a Line enters the Graphical Edit mode with the 3D instrumentation to allow 

quick edits. 

 An Object within PowerSHAPE can be decribed as anything you create within 

the graphics window such as: Workplane, Line Arc, Curve, Sold, Surface, Mesh 
etc. 

 

Within this mode the Line is highlighted yellow with an arrow indicating the Direction of 

the line and text showing its current Length. 

The blue Arrow and Sphere at either end of the line allows you to edit the characteristics 

quickly and easily while the intelligent cursor shows the original position and allows 

you to snap to other objects. 

Clicking and dragging the spheres will allow either end of the line to move freely in 3D 

space to change both the length and direction, while using the blue arrows will only 

affect the length and keep the same axial direction. 

When using the end arrows to change the length of a line, once the mouse button is 

released, PowerSHAPE will give the opportunity to fine tune the length as seen in the 
next image. 
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To fully fine tune the Line, the most accurate option will be to enter the Line 

Editor dialog. Again, as with all Objects in PowerSHAPE a double left mouse click 

on the Object, in this case a Line enters the Editor dialog. This dialog is particularly 

useful for naming and editing the relative Azimuth (Apparent) and Elevation 

angles of the line accurately. 

 

Within this dialog we can edit the Name, Direction, Length, Start and End Point and 

Angles highly accurately. 

Arc Edit 
Similarly to Lines a single left mouse click on the Arc enters the Graphical Edit 

mode with the 3D instrumentation to allow quick edits. 

Within this mode the Arc is highlighted yellow with an arrow indicating its Direction and 

text showing its current Radius. 

The blue Sphere at either end of the span allows you to edit the characteristics quickly and 

easily while the intelligent cursor allows you to snap the span to other objects. 
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Clicking and dragging the spheres will allow either end of the arc to move in a fixed 

circular motion dictated by the radius in order to graphically edit the span 

angle of the arc. 

The bidirectional blue arrows at the centre of the span allow the user to edit the 

radius of the line from the fixed arc centre. 

When using the arrows or spheres edit the arcs characteristics, when the mouse 

button is released, PowerSHAPE will give the opportunity to fine tune these values such 

as span angle and radius. 

 

To fully fine tune the Arc, the most accurate option will be to enter the Arc Editor 

dialog. Again, as with all Objects in PowerSHAPE a double left mouse click on the 

Object, in this case an Arc enters the Editor dialog.  
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Curve toolbar 

 

The following Curve creation options are available in standard PowerSHAPE. 

 Bezier curve 

 Sketch a Bezier curve 

 G2-curve 

 B-spline curve 

 Ellipse 
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 Spiral 

 Helix 

 Fillet 

 Untrimmed blend 

 Trimmed Blend 

 Composite Curve 

 Draft curve 

 Curve by oblique sections 

 Surface or solid intersection 

 Curve projection 

 Curve wrapping 

 Curve unwrapping  

 

 

After creating geometry consisting of lines and arcs, it is often necessary (and good 

practice) to combine these into single entities, as wireframe curves. You will often 

require wireframe that is defined directly as complex curves.  

The most commonly used curve definitions are: 

Bezier curve - free form curve  

Composite curve – curve defined along existing wireframe and/or model edges. 
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Composite Curves 

In many applications, it is necessary for the required wireframe to be a single 

entity. This is achieved by creating the wireframe as a composite curve. 

 A composite curve can only be created along existing model entities. 

The basic wireframe shape is complete, but is made up of several 

separate lines and arcs. The extent of a composite curve can be limited 

between selected key points along the potential route (Define start 

point and Define end point).  

1 From the Curve toolbar,  select Composite curve.   

The Create Composite Curve toolbar appears. 

 

 

2 Select the Start Point option in the toolbar and left-click the lower-left corner 

on the wireframe model. 

 

3 Left-click on the bottom horizontal line. 



 PowerSHAPE Pro 2015 5 Wireframe Modelling 

Copyright © Delcam  5.19 

 

The composite curve is generated along the route until it hits a branch 

(intersection) point where optional directions will be arrowed for you to manually 

select the required route. 

 The asterisk at the start point indicates that the composite curve is 

currently open. 

4 Left-click along the R60 arc. 

 

The composite curve has continued around the wireframe back to the defined 

start point. 

 A circle at the start point indicates the composite curve is a closed form.  

5 On the toolbar, select Save  to accept the composite curve. 

The single composite curve is shown yellow in colour when highlighted.  
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6 Select Eject  to close the toolbar. 

7 Select Undo  to revert the last command (composite curve creation). 
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Exercise 1: Composite Curves 

1 From the main menu select File > Import  to import existing geometry 

into the current PowerSHAPE model. 

2 Import the model: 

.....\PowerSHAPE_Data\composite curve Ex1.dgk 

 

3 Use Composite curve  to generate the result shown below. 

 Use blanking to hide items not required. 

  

 

The wireframe is now complete and will be saved as a permanent model.  

 Composite curves can be converted back to wireframe by selecting 

Edit>Convert>To Wireframe from the main pull down menu. 

4 Select File > Save As. 

5 In the form save the model as: 

......\PowerSHAPE-Models\Ex 1 composite curves.psmodel 

6 Select File > Close. 
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Single Curve Point Edits 
Single points on curves can be edited directly in the graphics window using a variety 

of different graphical edit handles, as well as using the Command Box on the Status 

Bar. Use the handles on curve points to graphically modify single curve points. The 

handles will display only when a single point is selected. 

It is possible to change they different curve point handles within Edit>Surface and 
Curve Edits>Common Edits> Selected Point Graphical Handles or by right-clicking with a 
single point selected. 

The following types of handles are currently available to use: 

 Tangent and Magnitude graphic handles. 

 Tangent and Normal graphic handles. 

 Workplane graphic handles. 

 

Tangent and Magnitude graphic handles 

1 From the Curve Menu select Bezier Curve  and create a freeform curve within 
the Graphics Window. 

 

2 Select a point on the curve and right-click and ensure that Tangent and Magnitude 
graphic handles is selected in the menu. 

 

These handles allow the user to graphically edit the Tangency and Magnitude of the 

curve point.  
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The arced handles offset from the end will modify the tangent angle of the curve in a 

fixed circular motion, without affecting the magnitude as can be seen below. 

 

The arrows at the end of each handle will graphically modify the magnitude of the 

curve along a fixed tangent angle, in this case to help the user, PowerSHAPE will give 

interactive feedback of the magnitude. 

 

 

The Spherical handles will modify both the Tangent and Magnitude freely in 2D or 3D 

space. Again, PowerSHAPE will give interactive feedback of the magnitude to the user. 

 

Finally, the spherical handle at the selected curve point position at the centre will edit 

the position of the point, without affecting the direction or magnitude of the point. 

For increased usability the intelligent cursor will remember the original position, and 

give coordinates (X, Y, Z) of the movement. 
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Tangent and Normal graphic handles 

1 Select a point on the curve and right-click and ensure that Tangent and Normal 
graphic handles is selected in the menu. 

 

These handles allow the user to graphically edit the position of the selected point in 

fixed Normal or Tangent directions, and alternatively freely in a 2D plane. 

 

The arrow handles tangent to the curve will modify the position of the point in a 

fixed direction along the tangent direction. For accuracy the offset distance from 

the orginal location will be visible, as well as editable once the mouse button has 

been released. 
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Similarly, the arrow handles normal to the curve will modify the position of the 

point in a fixed direction along the normal direction. For accuracy the offset 

distance from the orginal location will be visible, as well as editable once the 

mouse button has been released. 

 

The 4 Planar Handles surrounding the point will allow you to move the point freely in 

a 2D plane while again the original location is kept visible throughout. 

 

 

 

 

Again, the central spherical handle at the centre will move the point freely in 3D 

space while showing X, Y, Z coordinates offset from its original location. 

 

 

 

 

 

Workplane graphic handles 

1 Select a point on the curve and right-click and ensure that Tangent and 

Normal graphic handles is selected in the menu. 
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Clicking and dragging the workplane axis arrow handles will move the point in a fixed 

axial (X, Y or Z) direction with a visible offset distance from the original position, 

with the option to further edit or fine tune the offset once the mouse button has 

been released. The workplane origin in this case allows the point to be moved freely 

in 3D space. 
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Wireframe Arcs Example 
This example demonstrates the use of arcs to create the lever design shown below. 

 

1 Start a New Model  

2 Select the Arc toolbar.  

3 Select create a full arc.  

When this button is selected, the centre position of the circle is defined first. This 

can be entered as a value or by snapping using the Intelligent Cursor. 

4 In the Command Input box, type 0 for the circle centre and then press Enter.  

 

 

A preview of a circle is generated with a radius of the default value. You can 

change the radius by dragging one of the displayed arrows to the required value.  

To accept the circle, press the Esc key. 

5 With the circle selected, click and hold the handles (arrows) and move the 

mouse to drag a new radius of 35. 
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 Alternatively open the arc editing form and modify the radius value. 

The circle now has the required radius. This method can be used to create the 

second circle at the same centre position, using the Intelligent Cursor. 

6 Select create a full arc.  

7 In the command input box enter r 20 then Enter. 

8 Position the cursor over the centre of the first circle so the word Centre 

appears. 

 By default, the new circle will be exactly the same initial radius as the first 

circle. To change the default radius, type the new radius into the 

Command Input window.  

9 Left-click to accept the centre of the new circle.  

 

The two basic circles are completed. Further circles are required for this model. 

Creating additional circles 

 Use the command input box to enter the circle centre if it cannot be 

snapped. 

10 Create a circle at centre 100 –20 with a radius of 50. 

11 Create a circle at centre 100 –20 with a radius to 35. 

12 Create a circle at centre 200 -40 with a radius of 20. 

13 Create a circle at centre 200 -40 with a radius of 10. 

14 Press Esc. 



 PowerSHAPE Pro 2015 5 Wireframe Modelling 

Copyright © Delcam  5.29 

 

The default option when creating tangent arcs is to trim back the associated 

geometry. In this case, it is not required, so the option (Trim Tangent Items) 

needs to be deselected.  

15 Select Tools > Options, expand Object then select Arcs. 

 

16 Deselect Trim Tangent items. 

  

17 Select OK. 

Creating the tangent arcs 

For the tangent arcs, the fitted arc option is the most suitable as it provides full 

dynamic control through all possible combinations. 

1 From the Arcs toolbar, select Create an arc through three 

points/items.  

2 Move the cursor over the outer left circle until the word Tangent appears and 

left-click. 
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3 Move the cursor over the middle outer circle so the word Tangent appears and 

left-click. 

 

4 Move the cursor over up and down to get the tangent arc in the correct place 

and left-click. 

 

The Arc Confirm dialog is displayed. This can be used to enter an exact radius. 

 

5 Enter a Radius of 75 and select OK.  

The tangent arc is drawn.  
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6 Create an arc through three points/items  of radius 225 between the 

middle and outer circles shown below. 

 

7 Create an arc between the left outer circle and the middle outer circle with a 

radius of 225. 

8 Create a three point arc between the right outer circle and the middle outer 

circle with a radius of 75. 

 

The model is complete 

9 Select Esc or click Select  to exit creation mode.  

10 Select File > Save As. 

11 In the form save the model as: 

.....\PowerSHAPE_Models\lever example 

12 Select File > Close. 
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General Edits example 

At the top of the left toolbar are two fixed buttons; the second button  includes 

access to the General Edits toolbar. The buttons on this toolbar allow for standard 

editing functions that apply to all object types.  

 

A number of key editing options will be demonstrated in the following example. 

1 Start a new model. 

2 Select File > Import and load in the wireframe model: 

.....\PowerSHAPE_Data\GeneralEdit_Wireframe.dgk 

 

The imported wireframe (shown above, left) will be modified using the General 

Edits options, to produce the 4 finished wireframes (shown above, right).  
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3 Click in the graphics area to deselect the wireframe.  

4 Select  to display the General Edits toolbar. 

5 Select the line that needs extending as shown 

 

6 Select the Point limit option.   

The Limit point toolbar is displayed, floating in the graphics window.  

 

The cursor also changes to a magnet symbol.  

7 Move the cursor to the End of the line to be extended. 

8 Hold down the left mouse button and drag the end of the line tangentially (along 

the preview line) until the word Intersection is displayed, then release the left 

mouse button. 

 

9 Select the Interactively limit wireframes option  from the General Edits 

toolbar. The Limit point toolbar will be closed automatically. 

10 Left-click the mid-span of any sections of the wireframe network that are to be 

trimmed away (as illustrated below). 
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11 Create a composite curve from the network of lines and arc wireframes. 

 A quick way to create a composite curve is to hold down the Alt key and 

left-click anywhere along the wireframe network.  

 

12 With the composite curve selected, select Move  from the General Edits 

toolbar. 

13 With the toolbar displayed, enter the coordinate values X 25 Y 25 in the position 

boxes as shown. A preview of the transformed item is displayed and if required, 

can be changed. 

 

14 Select the green tick  to accept the preview.  
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15 The composite curve is shifted by 25 mm along both X and Y relative to the 

World datum 

 Workplanes and datums will be discussed in the next chapter. 

16 With the composite curve still selected, select Rotate from the General 

edits toolbar.  

The Rotate toolbar is displayed. In addition, the blue arrow on the 

datum shows the current rotational axis (Z). In this example the wireframe will 

require rotation about the Y axis, so this must be changed. 

17 Select the Y button  to make Y the operational axis. The axis 

buttons are located at the bottom-left of graphics area.  

The rotational axis in the graphics area reflects this change.  

18 In the Rotate toolbar, select copy the selected item  (to keep original copy), 

Leave Copies as 1, and enter Angle of 180. Press Enter to display a preview. 

 

19 Select the green tick  to accept the preview.  
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A copy of the composite curve is rotated by 180 degrees about the active Y 

axis. 

 In this case, the same result would have been obtained if the curve had 

been mirrored about the YZ plane. 

20 With both curves selected, select Mirror  from the General edits toolbar. 

The preview shows the desired result. The selected wireframes are mirrored 

across the ZX plane (i.e. Y as operational axis). 

 

 

 

 

21 Select the green tick  to accept the preview. 

22 Close the Mirror toolbar.   
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Further General Edits options 
In addition to the General Edits options used, other options are used later in the 

course with other PowerSHAPE entities, such as surfaces and solids. 

Offset 

1 Select the composite curve located in the -X -Y quadrant. 

 

2 Select Offset from the General edits toolbar.  

 

3 Select the small red arrow on the curve to switch the positive direction 

outwards. 

 

4 Select Round discontinuities  and enter a Distance of 10. 
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5 Close the offset form by selecting the small cross in the corner.  

 

A 10mm offset with round corners has been applied. 

Scale 

1 Select the composite curve located in the X Y quadrant.  

 

 If not already, ensure ts to/from he operational axis is set to Z. 

2 Select Scale from the General edits toolbar 
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3 Enter a Scale factor of 0.5 to reduce the size of the composite curve to 50% of 

the original size. 

4 Select the green tick  to accept the preview. 

 

 Scaling is from active workplane, therefore vectors to the active 

workplane origin also scale. This can be repositioned as required within 

the scale dialog 

Create Pattern of objects 

1 With the scaled down composite curve selected, select Create Pattern of 

objects.  

 

The current settings are immediately previewed. 

 

2 Enter 3 rows along both Y and X with a Y pitch of 50 and X pitch of 75. 

3 Select OK. 

 

Rectangular is one of 4 main functions in the Pattern Edits dialog. The other 

three include Honeycomb, Circular, and along Wireframe.  



2 Wireframe Modelling PowerSHAPE Pro 2015 

5.40  Copyright © Delcam 

Honeycomb 

 

Circular 

 

Wireframe 

 

 Further layout options are available within each Pattern Edit tab. 

4 Select File > Save As. 

5 In the form save the model as: 

.....\PowerSHAPE_Models\General Edits 

6 Select File > Close. 
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Exercise 2: 2D Drawing 
1 Use the dimensions provided to generate a Wireframe drawing. 

 

 

2 Upon completion save the model as 

…/PowerSHAPE_Models/Exercise 2 2D Drawing.psmodel 
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Introduction 
Solid modelling applies a different approach to the creation of a CAD model 

compared to surface modelling studided later in the course. The main difference is 

that a surface model is formed by a hollow, zero thickness skin, whereas a solid 

model is a mass of material. The main advantages of using solid modelling are 

the model creation speed, parametric qualities and the history tree. The user 

can use the history tree to reposition or edit operations performed earlier, 

resulting in the automatic update of other affected items. PowerSHAPE is 

unique in the ability to convert solids to surfaces and surfaces to solids, 

depending on which approach is most suitable. Open surfaces can be converted to a 

solid, an extremely useful capability which is not available with dedicated solid-

modelling packages.  

Within the Main toolbar there are two buttons for creating and Editing Solids.  

When Solid options  is selected, it displays the following buttons in the toolbar 

to the left of the graphics window. 

 

 

 

6. Solid Modelling 
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Solid Primitives 

In addition to the primitive solids which are generated from wireframe items (e.g. 

Extrude, Rotate), the toolbar contains six pre-defined shapes. 

 

Primitive shapes can be edited dynamically with a single mouse click (select) 
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The workplane ‘type’ handles can be used to move, change orientation and 

twist about its axis. The blue handles can be dragged to edit the dimensions 

of the primitive solid. 

Alternatively, double clicking on the primitive solid will display the dialog in 

which edits can be applied. 

 

When Solid Features  is selected, it displays the following buttons in the 

toolbar to the left of the graphics window. 

 

 



6 Solid Modelling PowerSHAPE Pro 2015 

6.4  Copyright © Delcam 

 

Active and inactive solids 
In older versions of PowerSHAPE (Before 2015) many solid operations were 

performed on the currently active solid. 

 The active solid is usually the main component of your model  

 Only one solid can be active at any time 

 By default, the first solid you create automatically becomes the active solid and 

other solids are created as inactive  

 If you activate an inactive solid, the currently active solid (if any) becomes 

inactive 

The active solid is represented by the Red Flag in the solid history tree and by 

darker wireframe edges in the graphics area. 

Since PowerSHAPE 2015 the selected solid or the active solid can be used to 

perform solid feature operations. However it is still good practice to keep control 

over which solid is used as the active. 
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Boolean Operations 
 

Boolean operations define the relationship between entities. As a solid is built up, 

additional solids and surfaces can be absorbed into it. This behaviour is 

illustrated below using the three Boolean operations available from the solid 

features toolbar.  

Observe the two primitive shapes below. With transparent shading applied, the 

yellow cylinder can be seen fully intersecting the blue sphere. 

In this case the Sphere is the primary solid and the cylinder is selected only. 

 

 

Selecting Add will combine the selected solids. 

 

The two separate solids have merged into one solid object. The cylinder is 

joined onto, and becomes part of the solid sphere.  
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Selecting Remove will subtract the secondary solid from the primary solid. 

If the active solid is visible in the graphics area that will automatically 

selected as the primary, although this can then be overridden in the dialog. 

 

 

A hole appears through the solid sphere caused by the removal of the solid 

cylinder. The hole is now part of the active solid sphere. 

Selecting Intesect  keeps the intersection of the selected solids. 

 

The new solid becomes the common volume of both solids, producing a solid 

tube with spherical ends.  
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Snapping to Parasolids 
Following a recent update released in PowerSHAPE 2014 R2, solids now support 

much improved snapping options using the intelligent cursor to parasolids within the 

graphics window. 

The intelligent cursor now snaps to the following, and are only visible once in a 

relevant creation mode: 

 Corners 

 Centres of Planar Faces 

 Centres of Arc Edges 

 Midpoints of Straight Line Edges 

 Tangent to Arc Edges 

Examples of these can be seen on the image on the next page. 
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Solid Modelling Example 1 
The following example illustrates the creation of a simple solid model. It 

emphasises the benefits; the ease of creation, and the ability to 

retrospectively make changes to existing features causing the remainder of the 

solid to be automatically updated. 

 

1 Create a new model.  

2 Create a workplane at 0 and set the Principal Axis to Z. 

3 Select Solid  from the main toolbar. 

4 From the Solids menu, select Create Solid Block.  

5 Centre the base of the solid block about the workplane by typing 0 in the 

command box (or snapping to workplane origin) then pressing Enter. 

6 Press the Esc key to break out of the command. 

7 Double-click the solid block to open the Block dialog.  

8 Enter Length 100, Width 50, and Height 50.  

 

 Screen shots have transparent shading applied.  

9 Select OK to apply the changes and close the dialog. 

10 From the Solids menu select Create Solid Cylinder.  

11 In the Command Input box at the bottom-right of the graphics area, type 

the values 0 0 –20 to position the base of the solid cylinder. 
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12 Press the Esc key to break out of the command. 

13 Double-click the solid cylinder in the graphics area to open the Cylinder 

dialog and enter Radius 10mm and Length 90mm. 

 

14 Click OK to apply and close the dialog. 

15 Select Solid Features  from the main toolbar. 

16 Ensure the cylinder is selected then Boolean Subraction.   

 

 The selected cylinder is removed from the active block (created first) 

to leave the hole. Fillets will now be applied to the vertical edges. 

17 From the Solid Features toolbar , select Create solid fillet.   

 

18 In the Fillet dialog, enter a Radius of 5mm. Hold down the Ctrl key and click all 

the vertical edges of the solid block.  



6 Solid Modelling PowerSHAPE Pro 2015 

6.10  Copyright © Delcam 

 

19 When all the edges are selected (yellow), select OK to apply and close the 

dialog. 

 

 All four vertical edges now have a fillet of radius 5mm. 

20 Select File > Save As: 

.....\Training Data\Coursework\Solid Modelling Example 1 
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Solid Feature Tree 
The Solid Feature Tree contains the history of solid operations performed on 

the visible solids.  

Each solid operation is defined as a feature on the solid. 

When you create a solid, it is automatically added to the solid feature tree 

(also known as the solid history tree).  

When an additional feature is applied a branch representing that feature is added 

to the tree. The features are shown in reverise chronological order with the 

most recent one applied at the top and the earliest at the bottom.  

The solid feature tree is displayed in a dedicated window to the left of the 

graphics area. This can be viewed by selecting Show History Tree window  

from the Solid Edits Toolbar, which automatically launches when any solid is 

selected. 

 

 

Modifying items and operations stored in the Feature Tree automatically 

updates the solid in the graphics area (provided the changes are possible). It is 

also possible to defer updates to allow a series of changes to be implemented at 

the same time. 

1 Select Show tree  window from the Solid Edits toolbar. 

The current features are displayed. 

 

A solid can be activated or deactivated by simply toggling the flag symbol. A 

Red Flag indicates an active solid  and grey flag  a inactivate solid. 

Flags can be toggled from within the feature tree or from the Solid Edits toolbar. 

 

 

 

If sub-items are not shown, click  to display them. To hide the sub-items, 

click.  
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A solid and/or feature can be selected directly on the model or from the feature 

tree. When a feature is selected, the name is outlined in a blue box and blue on the 

model itself. 

 

 

 

2 Double-click on the solid fillet at the top of the tree.  

 

 The editing form for the fillet feature is displayed.        

3 Input a new Radius of 10mm and select OK. The selected fillet radius on the 

solid changes to 10mm and the solid model is re-trimmed to suit. 

 

 You can also select solid sub-items by double-clicking the solid in the 

graphics area. 
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Multiple Feature Edits 

In PowerSHAPE 2015 we can now make simultaneuous edits to multiple 

versions of different sizes of the same feature (ie Solid Fillets). 

1 In the Solid History Tree select all four fillet features. 

 

2 Right-click on the selected features and select Modify. 

 

This will raise the normal Feature Edit dialog appropriate to the feature type 

selected. The main difference when multiple different features are selected are: 

 The properties that differ between the selected features are highlighted in 

pink. 

 The properties that cannot be edited for ALL the selected features are 

unavailable. 

 The range of values for each of the different properties are displayed when 

your mouse is hovered over the input box. 

3 In the Radius box type 8mm then click OK. 

 This have converted both the 5mm and 10mm fillets to 8mm fillets in 

one operation. 

 

 

 



6 Solid Modelling PowerSHAPE Pro 2015 

6.14  Copyright © Delcam 

Editing preceding Boolean operations 

As well as the ability to modify the original parameters used in the creation of a 

sub-solid item, you can apply the General Edit options to preceding Boolean 

operations. 

1 Select only the Boolean Subtraction operation in the History Tree as 

indicated. 

 

 

The cylinder (Boolean operation) is highlighted in the graphics area. 

2 Select  to display the General Edits toolbar. 

3 Select Edit Sub Item  from the flyout. 

 

 

This ensures the next general edit will now apply to the selected sub-items only. In 

this case the cylinder and the Boolean Remove which created the hole through 

the block. 

 

4 Set X as the principle axis.  
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5 Select Rotate  from the General Edit toolbar. 

 

The blue arrow indicates the X axis as the rotational axis. However the 

rotation origin itself needs to be transformed to the centre of the cylinder 

in Z. 

6 On the rotate dialog select reposition rotation axis.  

7 In the command box enter 0 0 25 to position the rotation axis half way up the 

cylinder.  

 

8 In the dialog, select Copy the selected items (to keep original) and enter an 

Angle of 90°, press the Enter key to show a Preview.  

 

 

9 Press the green tick to accept. 
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The original sub-solid cylinder is copied and rotated within the solid. The new 

sub-solid cylinder appears at the top of the History Tree.  

 

 

10 Save  the model then close the session. 
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Solid modelling example 2 
In this next example the following component will be created. 

 

The Mounting Block base dimensions are Length (X) = 100mm, Width (Y) = 

75mm and Height (Z) = 50mm centrally positioned relative to the workplane at 

The Draft Angle on all 4 walls is 5°. 

A cylindrical section of Radius 15mm runs with its axis along and central to 

the sloping upper face. All fillets are Radius 5mm. 

1 Create a new model.  

2 Set the principal plane to Z and create a workplane at 0. 

3 Select Solid options  from the main toolbar. 

4 From the Solids menu select Create Solid Block.   

5 Centre the base of the solid block about the workplane by typing 0 in the 

command box (or snapping to the workplane). 

6 Double-click on the solid in the graphics area to raise the Block Edit dialog. 
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 A solid primitive block allows the draft angles to be applied 

immediately.     

7 Select the Workspace tab in the editing dialog. 

8 Enter -50mm in the third coordinate box (Z Axis) and select OK. 

   

 The block has been transformed 50mm in the –Z axis. This has resulted 

in the original workplane to be positioned on the top face of the 

solid block. 

Applying fillets to the block 
Prior to the fillets the upper face will be modified to create the slope. An 

extruded surface will be used to demonstrate the ability of PowerSHAPE to apply 

Boolean operations to solids using surfaces. 

 Primitive Surfaces are discussed in detail in the next chapter. 

1 From the Views toolbar, select a View from Front (-Y). 

 

 By default the Principal Axis automatically switches to the selected 

view.  

2 Select create a single line  from the Line menu. 

3 Enter the start point coordinates -50 -50 -25. 

4 Next, enter the absolute coordinates abs 50 -50 -10 to complete the line. 
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5 Select the angled line. 

6 From the Main toolbar, select Surface to display the Surface menu. 

 

7 From Surface toolbar, select Create a Surface Extrusion.     

 This training manual will cover surface modelling in the next chapter. 

 

With the line pre-selected, an extrusion surface is created immediately. 

 The upper side of the surface is shaded red (inside) while the 

underside is the current default colour for surfaces (outside).  

8 If the extrusion surface does not fully pass through the solid, double-click 
the surface to display the Extrusion dialog. Insert a Length of 95mm. 

9 Select OK. 
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 You can also change the length by dragging the arrow at the end of 

the selected extrusion surface. 

 

10 With the surface selected and the solid active, select Solid Features  

from the Main toolbar.  

11 Select Boolean Remove.   

 The Split Solid  button can also be used to same affect. 

The area of the solid on the red side of the surface is removed, with the 

surface removal registered in the Feature Tree. 

       

12 Apply a 5mm solid fillet  on each draft edge of the solid block. 
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13 Repeat the fillet of Radius 5mm on the sloped rectangular face. 

 

 By creating the fillets in two separate operations, the sidewall and 

top surface fillets are independent which makes it easier to make 

changes to the individual fillet groups at a later stage by control the 

grouping in the history tree. 
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Creating a cylinder 

A new solid cylinder will be created then removed from the existing solid.  

Before creating the cylinder a new workplane is required aligned to the sloping 

face and positioned at a known keypoint. 

14 Create a single Workplane aligned to geometry and place a 

workplane at the centre of the lower edge of the top sloping face to create 

a workplane with its Z axis normal to the sloping face of the solid. This can 

be done by snapping to the keypoint using the intelligent cursor. 

 

15 From the bottom-left of the graphics area, select X as the Principal Axis. 

 

16 From the Solid  toolbar, select Create Solid Cylinder.  

17 Left-click on the new workplane to locate the new solid cylinder on to it, or 

type 0 into the type command box and press the Enter key. 
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18 Modify the cylinder parameter to a Radius of 15mm and length of 125mm. 

19 In the Workspace tab of the cylinder dialog, modify the X coordinate to -20. 
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Using a Boolean operation to remove the cylinder 

1 Boolean Remove  the solid cylinder from the main block solid. 

 

2 Activate the original workplane (Workplane 1) at the top centre of the 

component. 

3 From the bottom-left of the graphics area, select the Z Axis as the principal 

axis.  

4 Create a Solid Cylinder  positioned at -35 -25 -50. 

5 Modify the Radius to 4mm and the Length to 40mm. 

 

 You now need to remove the new solid cylinder from the main solid 

using a Boolean Subtraction operation. 

6 Boolean Subtraction  the cylinder from the main solid. 



PowerSHAPE Pro 2015 6 Solid Modelling 

Copyright © Delcam  6.25 

 

Mirroring the hole feature 

The remaining hole features we require will be mirrored across for a more 

efficient process. 

1 Select the latest Boolean Subtraction feature displayed in the Feature Tree. 

 

2 Select  to display the General Edits toolbar. 

3 Select Edit Sub Item  from the flyout. 
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4 Mirror  the hole across the ZX plane.  

     

 

The new hole is displayed at the top of the Feature Tree. 

5 Ctrl + select (multi-select) the Boolean Subtraction feature for both 

holes in the Feature Tree. 

6 As before mirror the features but this time across the YZ plane. 
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Basic Solid Editing 
1 Double left-click on the original solid block symbol at the bottom of the Feature 

Tree. The Block dialog is displayed. 

      

2 Modify the value for Width (Y) from 75mm to 100mm, and all four Draft 
angles to -15° 

3 Select OK. 

The solid component is updated with the changes. 

 

The holes must now be moved clear of the fillets running around the upper 

sloping face. 

4 Zoom into the area containing the two latest holes in the +X direction. 
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5 Hold down Ctrl and click the two Boolean operations (holes) to select them 

both. The corresponding cylinders are highlighted in the CAD model. 

 

6 Select  to display the General Edits toolbar. 

7 Select Edit Sub Item  from the flyout. 

8 Select Move.  

9 In the X Input box, type -5 and press Enter, then green tick to confirm. 
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10 Select File > Save As: 

.....\Training Data\Coursework\Solid Modelling Example2 

11 Close the model. 
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Solid Modelling Example 3 – Die block 

1 Open a new model.  

2 Create a workplane at 0 and ensure the Principal Axis is set to Z. 

3 Create a solid block  at 0 0 -40.  

4 Modify the Length (X) 100mm, Width (Y) 150mm and Height (Z) 40mm.  

 

5 Set the Principal Axis to X. 

6 From the Solids menu select Create a solid cylinder  positioned at -55 0 

0. 

7 Modify the Radius to 2mm and the Length to 20mm. 

8 Create a solid cone  at co-ordinates -35 0 0. 

9 Modify the top radius to 1mm, Base radius to 2mm, and Length to 30mm.  

The model now contains three solids; the large block is currently the active 

solid, you should be able to see this in the Solid Feature Tree. 
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10 Select and Blank (Ctrl+J) the solid block. 

11 Boolean Add  the Solid cone to the solid cylinder. 

The combined solids create the ‘sprue’ for the die block. (The hole through 

which molten material is channelled into a mould). 

12 Unblank (Ctrl+K) the solid block. 

 

 The Feature Tree shows that the ‘sprue’ solid comprises the solid cone 

and the solid cylinder.  

 

Suppressing a feature 

Solid features can be temporarily suppressed (removed from the solid) left 

clicking on the green tick in the History Tree. The green tick changes to a 

red cross.  

 

PowerSHAPE remembers the details and history of the suppressed feature. 

The suppressed solid feature can be unsuppressed by clicking on the red cross 

which will a green tick and the feature is visible. 
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Importing the molded component 

The molded component to be sunk into the die will be imported as surfaces 

and then converted into a solid. 

1 Select and Blank all of the solids and Import the model: 

C:\\Training Data\PowerSHAPE Data\handle.dgk 

 

The imported model contains various surfaces, which will be used to create a 

single solid. 

2 Quick Select All Surfaces from the Selection menu. 

3 From the Solids toolbar  select Create a Solid from selected Surfaces. 

 

A single solid has been created and also listed in the Feature tree. 

 

4 Select Unblank (Ctrl+L) to redisplay the block and sprue solids. 
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During a Boolean Remove, the secondary solid is lost as it absorbs into the 

primary solid. In this case, a copy of the handle will be required for later use as 

the basis for an electrode. 

To achieve this a copy of the handle will be created and placed onto a separate 

level. 

5 From the lower-left corner of the window, open the levels form.  

 

6 Name level 5 as Handle copy and leave the level switched off.  Select OK. 

 

7 Select the handle solid. 

8 Select Copy from the main toolbar followed by Paste.  

A copy of the handle has been created with two identical handle solids in 

the feature tree. 

 

9 With one of the handles selected, middle mouse click over the level 5 icon 

in the levels toolbar. 

 

A solid handle has been transferred to the new level. With the level 5 

switched off the copy of the handle solid is now not visible. 

 

 

 

 

 



6 Solid Modelling PowerSHAPE Pro 2015 

6.34  Copyright © Delcam 

Creating cavity 

1 Boolean Add  the ‘sprue’ solid to the handle solid. 

 

2 To finally create the required cavity, use the Boolean Subtraction  

operation to remove the handle and sprue solid away from the block. 

 

 A single solid remains which has the handle and ‘sprue’ removed from 

the die block. 

Creating the electrode from the solid 

The copy of the handle solid you created earlier will now be used to create an 

electrode. 

1 Blank the main cavity solid and then switch ON level 5 to display the handle 

copy. 

 

 

2 Ensure Z is selected as the principal axis is selected. . 

The ability of a surface to split a solid will now be shown. 
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3 From the Main toolbar, select Surface to display the Surface menu. 

 

4 From Surface menu select Create a Plane primitive  and position on the 

Workplane at 0 0 0.   

5 Modify the parameters to Width (X) 80mm and Length (Y) 120mm. 

 

6 Blank ALL Solids EXCEPT the handle. 

 Select the handle and press Ctrl+K. 

7 With the surface selected, select Solid split  from the Solid Features 

toolbar . 

8 Select and delete the upper half of the handle. 

 

9 Create a composite curve around the upper edge of the remaining handle. 
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10 From the Solids  menu, Create a Solid Extrusion.  

11 Modify the extrusion and change its length to 15mm.  

 

12 Using the Boolean Addition  operation add the extrusion to the handle 

solid. 

 The solid extrusion forms a run off to provide clearance between the 

electrode and the back plate.  

13 Create a solid block  at position 0 0 15 with Length (X) 60mm, Width 

(Y) 130mm and Height (Z) 20mm. 

14 Boolean Addition the two solids together.  

       

15 Rename the solid as Cavity Electrode by right clicking the solid in the 

feature tree and selecting Rename. 

 

16 Switch OFF level 5.  
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Creating a slide 

A slide will be created to provide an undercut hole in the molding. 

1 Select Unblank to redisplay the main cavity solid. 

2 Ensure it is active and set principal axis as Y. 

3 Create a solid cone  positioned at 4 –52 -3. 

4 Modify to Top Radius 2mm, Bottom Radius 2.25mm and Length 5mm. 

 

5 Boolean Addition  the small cone to the main cavity block.  

The solid now has a localised undercut core that is to be separated onto a 

retractable slide. A workplane is required at the end of the core to assist with 

the separation of the slide. 

An extruded surface will be created and utilised again to split the solid and 

provide the required component. 

6 Zoom into the small cone solid and create a composite curve on the edge of 

the bottom flat as shown. 

 Switching to wireframe shaded or transparent view will display the 

edge clearer making it easier to select and trace. 

 

7 Create a single Workplane aligned to geometry and click and snap at 

the centre of the outer planar face of the small cone.  
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8 Select the composite curve and create a Surface extrusion.   

 

The surface needs to be extruded through the model including a taper angle. 

Both can be achieved simply from the extrusion form. 

9 Double-click on the extrusion surface to open the Extrusion dialog so you 

can edit the extrusion.  

10 Modify Direction Length 2 to 30mm then Direction 1 Length to 0mm. Tick 

the Draft angle box in Direction 2 and enter an angle of 5°. 

 

11 Select OK. 
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The extrusion surface will be used to split the main solid extracting the 

slide as a separate solid. 

12 Ensure the main solid is active and the extruded surface is selected. 

13 Select Solid Split  from the Solid Features toolbar . 

  

Both resultant solids retain their separate associations within the History Tree. 

14 Select File > Save As: 

.....\Training Data\Coursework\Solid Die.psmodel 

15 Close the model. 
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Burglar Alarm Box Example 

1 Open a new model.  

2 Create a workplane at 0 renamed Datum, and ensure the Principal Axis is 

set to Z. 

3 Create a solid block  at 0 0 0 of Length (X) 250mm, Width (Y) 

300mm, Height (Z) 130mm and Draft 340° on all four sides.  

       

This has formed the basic shape for the alarm box. 

Adding solid features 

Further solid features  will now be added. 

1 Create a rectangle  starting from -60 -80 130 to 120 160. 

2 Create a composite curve from the rectangle. 

3 Create a Radius 10mm fillet on all corners of the composite curve. 
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4 With the composite curve selected, select Create Solid cut  from the 

Solid Features toolbar.   

 

5 In the Type drop-down list, select Blind and enter Depth of 1mm and select 

OK. 

 

A recess of depth 1mm is created in the solid downwards from the composite 

curve into the solid. 

The next stage is to remove the sharp edges from the main body by adding 

solid fillets. 

6 Select Create Solid Fillet  from the Features toolbar. 

7 Apply a fillet of radius 10mm on the four vertical and top edges. 
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Create four screw apertures 

1 Create a solid cone  at 80 -135 5.  

2 Double-click on the cone to display the Cone Edit dialog and enter the values 

as shown in the form below. Select OK. 

 

 

3 Make the new solid cone active. 

4 Apply a solid fillet of radius 2 around the base of the cone. 

 You may need to use a transparent shaded view, or alternatively 

Blank (Ctrl+J) the main block. 
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5 Mirror  the cone across the XZ and YZ planes of the worklplane 'Datum’ to 

produce 4 cones. 

 

6 Use Boolean Subtraction  to subtract the 4 cones away from the block. 

 

7 Create a solid fillet of radius 1mm around the outer edge of each conical 

recess.  
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Hollowing out the base 

We now need to select the face from which the hollow solid process is to occur. 

To do this, the solid must be shaded so that is possible to select the base as the 

specified face. 

1 Select Hollow Solid  from the Solid Features toolbar.  

2 Select the bottom face of the model which will then be highlighted yellow. 

The red cross adjacent to Removal Face Selected is replaced by a green tick. 

 

3 In the All Faces box, type 3mm, and then select OK.  

 The solid now has a uniform wall thickness hollowed out from the 

original base 

 

Creating the air vents 
The next stage is to create air vent features on the side walls. 

1 Select View from left (+X)  which automatically sets the principal axis 

to X. 

2 Switch to Wireframe view.  

3 Create rectangle from 0 -7 12 to 0 14 88. 
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4 Fillet  both left corners with radius 10mm. 

5 Create a composite curve of the profile. 

 

6 Box-Select both the solid and the composite curve. 

7 Select Curve Projection  from the Curve menu.  

 

8 Select Through item then OK. The composite curve is projected through the 

entire solid in the direction of the Principal Axis (X). 

 

 Only the curves on the outside face are required. 
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1 Select and Delete the two curves which were projected onto the inner face 

and the original central curve. 

2 Select the remaining outside curves. 

3 Select Create solid boss  from the Solid Features toolbar .  

 

4 Change the Extrusion height to 2mm and enter an angle (applies draft)    

of - 60°. 

 

Select the new boss feature (created as one) from the feature tree as shown. 

 

5 Select Move  from the General Edits toolbar.  

6 Select Copy selected item and enter 30mm in the Y input box, then teh 

green tick to confirm. 

 

A copy of the boss features have been created to the side of the original. 
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7 With the Move dialog still open and the new boss features highlighted enter 

-60 in the Y input box to create a copy on the opposite side. 

 

8 Select View down from left (-X).  

9 Create a rectangle of lines  at 0 -7 12 with sides 0 4 88. 

10 Create a composite curve from the rectangle. 

11 Copy the composite curve by 30mm along the Y axis on both sides of the 

original. 

 

12 Select all 3 rectangular composite curves. 



6 Solid Modelling PowerSHAPE Pro 2015 

6.48  Copyright © Delcam 

13 Select Create Solid Cut  from the Solid Features menu.   

 

14 In the Type drop-down list, select Through and select the icon highlighted to 
Extrude both directions. Select OK.  

 

 

 The ventilation slots are cut out of the main solid. 

Creating a workplane for the mounting 

The next stage is to create a mounting for the strobe light on the end face of 

the alarm box. To assist alignment of the mounting, a workplane will be 

created aligned normal to the face. 

1 Select the Iso1 view.   

2 Select Workplane Aligned to Geometry  and select the face centre 

keypoint shown. 



PowerSHAPE Pro 2015 6 Solid Modelling 

Copyright © Delcam  6.49 

 

3 If necessary, Twist the workplane about Z so that its X axis is aligned towards 

the top of the alarm box. 

The Z axis of the new workplane is centrally aligned normal to the selected 

face. 

Creating a boss to provide access to the mounting 

A boss complete with through hole, will be created and aligned to the 
workplane Z Axis to provide access for a strobe light mounting. 

1 Generate a full arc (circle) of Radius 30 at the workplane 0 and create a solid 

extrusion of 10mm in both directions (Direction 1 and 2) 

2 Generate a solid block primitive at 0 0 -10 

3 Modify the block dimensions to Length 100, Width 40 and Height 20. 

 

4 Make the circular extrusion active and select the rectangle block.  

5 Boolean Intersect  the leave the combined solid. 
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Trimming the solid 

As seen below, the new solid is jutting beyond the inner wall of the main solid.  

 

The Solid Boolean Boss will be used to trim it back to the inside face and at the 

same time add the outer part to the main body solid as a Boss feature. 

1 Select the main casing solid and make it active. 

2 Select the intersected solid, and then select Solid Boolean Boss  from the 

Solid Features menu.   

3 The Boolean Boss dialog offers 2 possible solutions. It allows the intersected 

feature to be split to exist either on the outside face or on the inside of the 

s. 

     

4 Toggle to the solution (in this case 1) with the highlighted boss (blue) on the 

outside and select OK. 

 

The solid boss has been trimmed back.  
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Creating a hole for the wiring 

A hole for the wiring will now be created. With a single active solid, the hole will 

penetrate both the boss and casing.  

1 Create a Workplane Aligned to Geometry and snap it to the centre of the 

Boss face. 

2 Then select select the outer face of the boss to create a workplane at the centre 

of the outside face  

3 Select Create a Hole  from the Solid Features toolbar.    

4 Position the hole by snapping to the local workplane, or by typing 0 in the 

Command input box. 

 

5 For Hole Category, select Untoleranced. 

6 For Use select Plain. 

7 Enter a length of 50 and diameter of 16. Select OK. 

 

8 Select File > Save As: 

.....\Training Data\Coursework\Alarm Box.psmodel 

9 Close the model. 
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Plastic Handle Example 
1 Open the model: 

…\PowerSHAPE Data/toy_handle.psmodel 

The model contains a large handle solid along with six small rib feature 

solids, all of which are displayed in the History Tree.  

 

2 Select File > Save As and save the model to: 

…Training Data\Coursework\PlasticHandle.psmodel 

 

 

3 Make the main handle solid active in the Solid History Tree. 

4 From the Solid Features menu , select Solid Fillet .  
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 The Solid Fillet dialog is displayed. Unlike surface filleting, solid filleting 

uses the sharp edges on the solid as the filleting track. The order and 

extent to which solid fillets are created is important if the correct 

design specification is to be achieved. 

In this case, to provide the correct shape around the upper and lower edges of 

the D-shape, the vertical corner fillets must be created first. 

5 Set a Radius of 6mm and select the two outer vertical edges shown. 

 Hold down the Ctrl key to multi select edges. 

 

The fillet path runs until it finds a sharp edge (Discontinuity). 

6 Select Apply. 

 By selecting Apply the fillet dialog will stay open after the fillet has 

been created for further operations. 

7 Generate a radius 4mm fillet along the top and bottom faces of the solid. 

 

The outer edges are now complete.  

Modifying the D-shape 

The inner D-shape of the handle will now be modified to include a variable 

radius fillet of radius 4mm increasing to 6mm at the mid-point of the curved 

section. 

8 Zoom into the D-shape. 

9 Fillet the vertical internal corners with a radius of 4mm. 
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 Filletting these vertical edges first will provide one continuous edge 

around the entire D-shape. 

 

10 Select the top inner edge. 

11 Select the Advanced option in the Fillet dialog to display the Variable Radius 

Fillet dialog. 

 

This dialog allows you to use the mouse to select an arc that represents the 

radius of the fillet at a location around the curve representing the shape. This 

works in a similar way to variable radius filleting of surfaces covered later. 

When you move the mouse along the track, the word Key appears. Click at these 

points to easily generate a numbered arc. The size of this arc can then be 

stretched or modified in the dialog. 

12 Select a View from Top (Ctrl+5). 

13 Click on the track to define locations for radius 4mm and radius 6mm. 

 

14 Modify the arc radii as indicated on the image above and select OK to 

produce the variable radius fillet. 
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15 Generate the equivalent variable radius fillet on the underside of the solid. 

16 Close the Fillet dialog. 

 

The main fillets have been generated.  

Removing the solid ribs 

The solid ribs can now be removed from the main solid to produce a grip effect 

on the handle. 

17 Select ALL the solid ribs, then navigate to Boolean Subtraction  from 

the menu. The completed outer model is displayed. 

 

18 Select the Solid in the graphics area. 
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The outer must be cored with a 3 mm minimum wall thickness. Due to 

dimensional restrictions, some of the features must be suppressed before 

attempting to create a new solid to represent the inner. It is also necessary to 

perform additional material removal on the inner along the shaft to 

maintain the nominal wall thickness. 

In the History Tree click the green ticks next to all six ribs and the logo 

feature. 

 

 The ribs and logo recess are temporarily removed from the main 

handle solid. 

 

19 From the General Edits menu, Offset  a copy of the selected solid by    

-3mm to provide the inner wall (excluding the ribs and logo detail). 

 

Now that the basic model for the inner solid has been created, the original outer 

solid must be updated to include the rib and logo features again.  

20 In the History Tree click on all red crosses adjacent to the suppressed 

features to reinstate them onto the outer solid. 
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Changes to the inner core solid 

Some design modifications are now required on the inner core solid. These 

include extending the shaft through the end of the outer solid and creating a 

minimum wall thickness of 3mm below the logo recess. To show these 

requirements more clearly the Dynamic Sectioning option of Model Analysis will 

be used. 

21 Select both the inner and outer solid. 

22 Select Model Analysis  then select Dynamic Sectioning .  

23 In the Dynamic Sectioning dialog, select Y in the Axis list. 

 

24 Enter 0 to position the Back face slider halfway across model, and then select 

the Create Wireframe button as indicated above. Select Close. 

25 Select View from Front (Ctrl+2)  and set the Prinicipal Axis as Y. 

 

26 Quick select ALL wireframe  and select Blank Except (Ctrl+K). 

27 Check the wireframe for acceptable wall thickness and then select the two 

composite curves defining the section along the shaft centre. 

 As you should hopefully see at the logo recess the minimum wall 

thickness his reduced to 1mm due to the depth of the recess. 

 

28 Snap a wireframe line to the outer composite curve as shown above, then 

edit the length to pass through the end wall (for example, increase the length 

to 200mm). 

 

29 From the right hand end of the existing line create another line of suitable 

length (for example 15mm), at angle of 30° as shown above to create a taper 

internally and avoid sharp edges. 
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30 Select and Blank (Ctrl+J) the two composite curves. 

31 Create a composite curve along both lines. 

32 From the General Edits  toolbar, select Offset . Specify Round 
discontinuities, No. of Copies 1, and Distance 3mm, then press the Enter 

key. 

 

 

33 Select the new offset curve, create an extrusion surface  from the 

Surface  menu of Length 40mm (along Y). 

34 Double click on the Surface Extrusion to open the extrusion edit dialog. 

35 Select the Workspace tab and enter a Y coordinate value of -20 to centralise 

the surface across the shaft. 

           

36 Unblank (Ctrl+L) the solids. 

37 Blank (Ctrl+J) the Main solid. 

 

38 Make the inner-core solid active, and select the new extrusion surface. 
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 This may be easiest in the Solid History Tree. 

39 From the Feature  toolbar, select Boolean Subtracction  to remove 

everything to the red side of the surface from the solid. 

 The core solid illustrated below also includes the revised wireframe 

obtained from a further dynamic sectioning operation to show the 

new wall thickness. 

 

40 Create a composite curve around the end of the core solid shaft. 

 

41 Set the Principal Axis to X and select the new composite curve. 

42 Create a solid extrusion  and drag it along the -X direction until it has 

passed through the end of the outer solid (for example. Length 20mm). 

 

43 Make the main inner core solid active. 
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44 Select the new solid extrusion and, from the Feature  toolbar, select 

Boolean Addition .  

 You may find that PowerSHAPE will not initially add the extrusion to 

the inner core solid. This may be because the extrusion is of Version 8 

format (mainly found in older PowerSHAPE sessions). To fix this select 

the extrusion a from the Solid Edit toolbar, click on the Version 8 

Converter icon.  

 

45 Make the outer solid active. 

46 Select the inner core solid and, from the Feature  toolbar, select 

Boolean Remove .  

 

The completed solid spade handle component is a shown above. 

47 Select File > Save to update the content of the stored model file. 

48 Close the model. 
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Radial Solid Cut 
The Radial Solid Cut feature was new in PowerSHAPE 2014 R2 (available in 

PowerSHAPE Pro, Toolmaker Pro, PartMaker Modelling and PowerSHAPE 

Companion for FeatureCAM). It allows users to quickly wrap wireframe around 

cylindrical solid objects and cutout a pocket feature. Use this option to create 

a pocket that can be milled using a turn-mill machine. 

This is complete without any complex calculations by effectively unwrapping the 

selected face of the solid into a sketch plane, allowing wireframe to be created 

and then wrapped onto the solid face. This example will highlight the method 

used to create a Radial Solid Cut feature. 

Radial Pocket Example 
49 Open a New Model. 

50 Create a Workplane at 0. 

51 Import the file Radial Solid Cut.x_t from the data folder. 

52 Select an Isometric View (Ctrl + 1). 

 

53 Ensure the solid is selected by clicking on it with the graphics window or in 

the solid history tree. 

 The Radial Solid Cut feature works on a selected solid, however it is 

good practice to have this as the Active solid when you are editing it. The 

selected solid is represented by the yellow outlining of the solid. 

54 Click the Solid Feature  button to activate the associated Sub-Menu for 

solid editing. 

55 Select the Radial Solid Cut  button from the Solid Feature menu. This is 

located in the solid cut flyout. 
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This will open the Radial Solid Cut wizard which will guide you through a series of 

step by step windows enabling you to quickly and easily create a solid cut. 

 

The first window of the wizard requires a selection of the face(s) to be cut. Currently 

the wizard is best suited to cut separate faces at a time but can handle multiple 

cuts. 

To make a selection simply click your chosen face(s) in the graphics window, 

these will be highlighted in orange. In this first example we will create a 

rectangular pocket on the uppermost cylindrical face of the solid. 

56 Select the Upper Cylindrical Face on the solid as shown in the image on the 

next page. 

57 The two green ticks in the dialog box denotes when the selection is sufficient to 

move on to the next window. Note: The workplane will automatically be selected 

as the Active Workplane. 

 The Z Axis of the Active/Selected Workplane needs to be parallel to 

the axis of the cylindrical face(s) to be cut. 

 

 



PowerSHAPE Pro 2015 6 Solid Modelling 

Copyright © Delcam  6.63 

 

PowerSHAPE now unwraps the selected face of the solid into a plane. Its upper 

and lower edges outlined by horizontal lines, while also creating guidelines at 0, 

90°, 180°, 270° and 360° (same as 0° start and end) to help visualise the 

distance around the face. 

58 Select Next. 

59 Select a View from Top (Ctrl + 5). While in the wizard this will view down on 

the unwrapped face usng a temporary workplane normal the the sketch 

plane. 
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To further help position wireframe around the face of the solid, it is also possible to 

add further guidelines at any angle. Doing this will simply add extra vertical lines 

onto the sketch plane which can be used to snap to with the intelligent cursor. 

 

60 Within the wizard add guidelines at 135° and 250° by typing into the provided 

entry box and pressing the Enter key to accept each angle. Two new 

guidelines should appear in the view. 

 

 Note: Selecting Finish in the wizard at this point will simply create the 

guidelines as wireframe allowing the user to create the wireframe at a 

later stage and re-enter the wizard to create the cut. However in this 

example we will use the wizard throughout to create a Radial Cut. 

61 Click Next. 
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62 Select Sketch to hide the main wizard dialog and enter the sketch mode. 

 As noted above this will hide the main dialog to enable unobstructed 

sketching in the graphics window. Reducing down to a Save/Dismiss 

Changes sketch dialog seen below. 

 

63 By snapping to the 135° and 250° guidelines created, draw a rectangle of 

approximate height 4mm near to the centre of the solid face. The rectangle 

button from the line menu  is the most effective way of doing this. 

 The angle is measured in the XY plane from the positive X axis in a 

counter clockwise direction. 

 At this stage don’t focus on accuracy too much, as the process to create 

a radial cut using the wizard is the main aim of this first example. 

Although snapping the the correct guideline should give a length of 

20.07mm. 
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64 Create a composite curve from the rectangle. As with other solid feature 

function the use of composite curves is required to perform the function. The 

Composite curve creator  from the Curves menu  is required. Trying 

to use the ALT + Click shortcut in this case will likely fail in this case. 

65 Once you are happy with the shape and position of you composite curve, 

SELECT all required curve(s) that you wish to wrap/cut and click the 

green tick to accept the changes and re-enter the wizard. 

 

Accepting this form will also create a view of the wrapped curve(s) onto the 

model to show there position and size in direct relation to the solid model. 

 

66 Select Next within the dialog. 
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67 Within the final window of the wizard there are two main options; Cut or 

Wrap. 

 Wrap will simply create a wrapped curve onto the face of the solid, while the 

Offset option allows the curve to be projected at a distance away from the face 

of the solid. 

 Cut will apply the wrap and make a cut in to the solid at any specified depth, 

or through. It is important to note that this cut is normal to the face of the 

solid. 

68 Select Cut and a Depth of 1mm, then select Apply. 

 If after you select Apply, changes are required and you are still in the 

wizard the Remove button will delete the current cut, allowing edits to be 

made. 

 A Green Tick will notify you that the current selection is OK and ready to 

be cut. 
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69 As you can see the Cut has been performed successfully, Select Finish. 

 

Looking to the left at the Solid History Tree we can see that this feature has been 

created by effectively creating a solid from the wrapped curve and the using a 

Boolean Remove function to create the cut. 

The curve that was created on the unwrapped solid face in the wizard is also kept 

after the operation. This can be deleted altogether, or you could put it on a 

separate construction level. 

 As this is a solid the cut faces are easily edited using further Solid 

Features like solid fillet and wall draft. 

70 Ensure the solid is active which is denoted by the red flag next to the solid in 

the solid history tree. 

71 From within the Solid Feature sub-menu select the Solid Fillet . 

72 Enter a Radius of 0.5mm and select the option to Fillet a Face. 

 The Fillet a Face allows you to select faces of the solid and automatically 

select and fillet all the face edges to save time multi-selecting faces. 

 Currently solid edits to the radial cut feature are only supported after 

the feature has been created and once the wizard has been finished. 
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73 Select the face at the bottom of the radial cut pocket. 

 

74 Click Apply then OK to accept and save the changes and create the fillet. 
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Solid Base Groove 
Next we will create a complex radial groove round the lower cylindrical face of 

the solid. We can easily create a simple groove using a variety a solid feature 

methods, however for the groove to take a more complex path the Radial Solid 

Cut method simplifies this process. 

75 Ensure the Active Workplane has its Z Axis parallel to the axis of the 

cylindrical face you plan to cut using the Radial Solid Cut feature. 

 This should already be the in place from the previous example, however 

it is good practice to develop a process of checking everything is in place 

before you start the feature wizard. 

76 Select an Isometric View (Ctrl + 1). 

77 Ensure the solid is selected by clicking on it with the graphics window or in 

the solid history tree. 

78 Click the Solid Feature  button to activate the associated Sub-Menu for 

solid editing. 

79 Select the Radial Solid Cut  button from the Solid Feature menu. This is 

located in the solid cut flyout. 

 

Again, this will open the Radial Solid Cut wizard which will guide you through a 

series of step by step windows enabling you to quickly and easily create a solid cut. 

 

80 Select the Lowest “Base” Cylindrical Face on the solid as shown in the image 

on the next page. 

81 The two green ticks in the dialog box denotes when the selection is sufficient to 

move on to the next window. Note: The workplane will automatically be selected 

as the Active Workplane. 

 The Z Axis of the Active/Selected Workplane needs to be parallel to 

the axis of the cylindrical face(s) to be cut. 

 



PowerSHAPE Pro 2015 6 Solid Modelling 

Copyright © Delcam  6.71 

 

 

82 Click Next. 

83 Select a View from Top (Ctrl + 5). While in the wizard this will view down on 

the unwrapped face usng a temporary workplane normal the the sketch 

plane. 

 

This page of the wizard allows extra vertical guidelines to be created at any 

angle around the solid face beyond the default lines to further help position 

wireframe around the face of the solid. In this example we will use the default 

angular guidelines. 

84 Click Next. 
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85 Select Sketch to hide the main wizard dialog and enter the sketch mode. 

 This will hide the main dialog to enable unobstructed sketching in the 

graphics window. Reducing down to a Save/Dismiss Changes sketch 

dialog seen below. 

 

86 Using the Automatic Dimensioning  tool in Annotation Menu  

select a vertical guideline to measure the overall height of the base. 

 

87 Select and Delete the dimension. 

88 Select the lower horizontal line that represents the bottom edge of the solid 

face. 

89 From the General Edits  menu, choose Offset . Ensuring the orange 

arrow is pointing upwards from the line, Offset copies of the line 2.5mm & 

7.5mm, and then close the offset form.  

 Note how in the sketch mode within the wizard all of the required 

PowerSHAPE functionality is available. 
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 This is currently the most efficient option to create horizontal guidelines to 

aid wireframe creation. As you can see by offsetting the lower line 

upwards we have created guidelines at known values in Z that can be 

snapped to using the intelligent cursor. 

Next we will create a zig-zag line with a height varying between 2.5mm & 7.5mm 

from the lower edge of the face changing direction every 90°. 

90 From the Lines  menu on the Main Toolbar select Continuous Line . 

91 Starting from Y = 2.5mm (current workplane in view) create the line as shown. 

 

92 Convert the wireframe into a composite curve . 

93 With the curve selected, move the curve and create copies 0.5mm 

vertically (in Y in this case) in both directions and delete the orginal. 

 

94 Using the vertical guidelines that are already in place and the two composite 

curves, track a single closed composite curve around both zig-zag profiles. 

 Using the guidelines that are already in the sketch saves using having to 

create lines to close the curve off. Remember to Zoom In and Pan 

around the model while tracking the curve to ensure the correct curve is 

produced. 

95 Once the curve is closed as shown below, save the curve in the composite 

curve creator and eject to close the form. 
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96 Once you are happy with the shape and position of you composite curve, 

SELECT all required curve(s) that you wish to wrap/cut and click the 

green tick on the sketch dialog to accept the changes and re-enter the 

wizard. 

 

Accepting this form will also create a view of the wrapped curve(s) onto the 

model to show there position and size in direct relation to the solid model. 

 

97 Select Next within the dialog. 
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98 Select Cut and a Depth of 0.5mm, then select Apply. 

 If after you select Apply, changes are required and you are still in the 

wizard the Remove button will delete the current cut, allowing edits to be 

made. 

 A Green Tick will notify you that the current selection is OK and ready to 

be cut. 

 

99 As you can see the Cut has been performed successfully, Select Finish. 

100 The curve that was created on the unwrapped solid face in the wizard is also 

kept after the operation. This can be deleted altogether, or you could put it on a 

separate construction level. 

 As this is a solid the cut faces are easily edited using further Solid 

Features like solid fillet and wall draft. 

101 Ensure the solid is active which is denoted by the red flag next to the solid in 

the solid history tree. 
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102 From within the Solid Feature sub-menu select the Solid Fillet . 

103 Enter a Radius of 0.25mm. 

 

104 Select the ALL the edges surrounding the face at the bottom of the radial cut 

zig-zag groove. 

 

105 Click Apply then OK to accept and save the changes and create the fillet. 
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Exercise 4: Solid model 
 

1 Using the basic dimensions provided generate a solid model.  

 

 

1 Select File > Save As: 

.....\Training Data\Coursework\Exercise 4.psmodel 

Close the model.
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Exercise 5: Solid lever 
1 Open the previously completed wireframe model from Chapter 2 

.....\PowerSHAPE_Models\lever-example.psmodel 

 

2 Generate a solid model using the following dimensions. Use the inner three 

circles to create the through holes. 

 

 

3 Apply a 5mm fillet to both upper and lower intersecting features as shown 

 

 

4 Select File > Save As: 

.....\Training Data\Coursework\Exercise 5.psmodel 

5 Close the model. 
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Exercise 6: Assembly plate 
 

1 Generate a solid model using the dimensions provided.  

 

 

 

1 Select File > Save As: 

.....\Training Data\Coursework\Exercise 5.psmodel 

2 Close the model. 
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Introduction 
Direct Solid Modelling provides tools to: 

 Make rapid edits to history-free solids.  

 Recognise key solid features for simple editing (for example, fillets, pockets) 

 Add draft to faces and automatically extend and intersect all surrounding 

geometry to keep a closed solid.  

 Remove and heal to simplify geometry for downstream manufacturing 

operations or to accommodate design changes.  

 Edit faces, automatically extending and intersecting surrounding faces to 

maintain a closed solid. This lets you do operations like copying a 

strengthening rib or offsetting the side faces of a pocket. 

Direct Modelling is particularly efficient for operations that are typically performed 

using surface modelling and would require you to extend and intersect each 

surrounding faces manually to create a closed solid. 

These powerful tools will be demonstrated in the following example. 

1 Import  the solid model: 

.....\PowerSHAPE Data\Direct modelling plate.x_t  

 

2 Select the Solid to display the Solid Editing Toolbar. 

7. Direct Solid Modelling 
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Solid Edit Toolbar 
 

 

The following Solid Editing and a number of Direct Solid Modelling tools are 

available:  

 - Toggle display of the Solid Feature Tree. 

/  - Make the Solid Active/Inactive. 

 - Find and Fix faults in the solid. (Solid Doctor) 

 - Select a Feature on the solid.  

 - Select Individual Faces on the solid. 

 - Select Faces of Continuous Regions. 

 - Select Faces of Convex Regions. 

 - Select Faces of Concave Regions. 

 - Select Faces using a Continuous Lasso. 

 - Select Faces using a Discrete Lasso. 

 - Copy the Selected Faces. 

 - Extract the Selected Faces. 

 - Select and Sew items into the solid. 

 - Remove and Heal the Selected Faces. 

 - Merge Selected Faces. 

 - Divide the Selected Faces. 
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 - Draft Faces of the solid. 

 - Replace Faces of the solid. 

 - Divide Selected solid into Multiple Solids. 

 - Convert between Version 8 solid and Parasolid. 

 - Convert between Surfaces and Parasolid. 

 - Convert between Mesh and Parasolid. 

3 Select  to display the feature (history) tree of the imported solid.  

 

As you can see the solid has no features or history associated with it. 

Direct Solid Modelling demonstration 
Direct modelling functionality can fall into two categories. 

1 Direct editing - Tools which directly change or edit features without 

creating history (as a new feature). 

2 Feature recognition - Tools which create new features and history. These 

can then be edited as part of the active solid. 

Direct Editing 

Solid faces which require editing, must be selected first using one of the 

selection tools available in the Solid Edit toolbar. 

 

Once selected, the following General Edits  can be applied.  

 Move -  

 Rotate -  

 Mirror -  

 Offset -  

 Scale -  
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4 Select and highlight the large curved face shown in the next image. 

 

 By default, the surface select mode is Select individual faces.  

5 Select Offset  from the General Edits toolbar.  

 

6 Enter a value of 2mm on the Offset form. 

 

The face has been offset. More importantly however, all surrounding vertical 

faces have been retrimmed and reintersected automatically.  
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1 Select and highlight the top horizontal face. 

 

2 Select Move  from the General Edits toolbar.  

3 Enter a distance of 3mm in the Z axis and press Enter (for preview). 

 

As expected, the preview of the calculated result is displayed. 

4 Select the green tick  to accept. Note the effect in the region shown above.  

 

The top face has successfully moved by 3mm in the Z axis. All related vertical 

faces have reintersected and maintained the solid closure. The sloping face achieved 

this by extending its faces. 
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1 Rotate the part to view the bottom side and zoom into the region shown.  

 

2 Shift select the three faces highlighted. 

3 Select Rotate  from the General Edits toolbar.  

 

4 From the rotate form select Reposition  and click on the keypoint to 

specify the rotate origin. 

5 Select and drag only of the selected faces to dynamically preview the faces 

rotating about the origin. 
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6 Release the mouse and enter an angle of 345 before accepting the result.  

 

Only the selected faces have rotated to the specified angle. 

1 From the solid edit toolbar change the selection mode to faces of concave 

regions.  

2 Single click in the pocket to highlight all relevant faces. 

 

3 From the Solid Editing toolbar, Select Remove and Heal.  

 

This tool removes all selected faces and then closes the resulting gap by 

modifying the surrounding faces. 
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4 Remove the two holes and two fillets (indicated in the previous image) 

using Remove and heal.  

 

5 Select the top and cylindrical faces which define the boss feature. 

          

                                                         

6 Select Scale  from the General Edits toolbar.  

 

7 Select reposition scale origin  and snap to the centre of the face using 

the Arc-Centre keypoint. 

8 Lock the Z axis  and enter a scale factor of 1.5. Select the green tick  to 

confirm. 
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The boss feature has scaled in the X and Y axis by a factor of 1.5. 

 If the Z axis was not locked PowerSHAPE would still have automatically 

limited back the Z intersection and provided the same result. 

PowerSHAPE provides the ability to divide the default faces, thus providing 

more control over specific regions that require editing.  

 

1 Rotate the model to view the top and zoom into the area show. 

 

2 Create a single line approximately half way up the concave face, snapping 

the outside edges.  

 

3 Select the three vertical faces which define the concave recess. 
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4 From the Solid Editing toolbar, Select Divide faces.  

 

5 Select the single wireframe to nominate and update the Divide faces form. 

6 Keep the default projection mode of along face normal  then Apply. 

 

The curve is projected onto the selected faces and now the three faces become six. 

 New to PowerSHAPE 2014 R2 is the option to merge faces  on a 

solid. This will merge adjacent continuous faces into one continuous 

face, essentially the reverse of the operation to Divide Faces described 

above. 

7 Dismiss the form and delete the single line. 

8 Select the lower three faces then Offset  from the General Edits 

toolbar.  
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9 Enter an Offset distance of 3mm. 

 

A 3mm deep step has been generated with relevant faces trimmed correctly. A 

further three faces have been created to define the horizontal step face(s). 

1 Zoom into and select the three faces defining the corner pocket  

 

Direct modelling allows draft angles to be quickly applied to selected faces.   

2 From the Solid Editing toolbar, Select Draft faces.   

 

The red cross  indicates a required reference entity. This can be a face, Surface 

or a Workplane. 

3 Leave the default Face entity and select the top horizontal face. 
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The draft angle can be dynamically pulled to set and preview the required angle. 

4 Dynamically set or enter an Angle of 15° in the Draft faces form before 

selecting Apply. 

5 Dismiss the form to view the result. 

 

1 Rotate the part to view the bottom side and zoom into the region shown.  

 

2 Select the small flat surface defining the lug feature, as indicated. 

3 From the Solid Editing toolbar, Select Replace faces.   

This allows faces of a solid to be replaced with existing faces (as a reference). In 

this example, the length of the reinforcement lug will be extended. 

4 Select the face indicated to nominate as the replacement face. 
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5 Select Apply to confirm the preview then Dismiss the form. 

 

6 Repeat the above process to extend the lug on the opposite side. 

Feature Recognition 

The following Direct Modelling tools extract features and create history in the 

Solid Feature tree. 

1 Rotate the part and zoom into the area shown, then select Create a hole  

from the Solid features toolbar.  

 

2 From the top right hand corner of the Plain hole dialog, select Feature creation 

 to toggle to Feature recognition mode.  
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In this mode PowerSHAPE is capable of recognising the hole, the parameters 

that define it and then add it to the feature tree. 

 

3 Select hole.  

The hole is highlighted in blue and the dialog form displays its properties. 

4 Select Apply to accept the results. 

5 Repeat for hole.   

A counterbored tapped hole is recognised. 

 

The two hole features are now visible in the feature tree and can now be 

modified as a standard solid feature. 

6 Select Create a Solid pocket  from the Solid features toolbar.  

7 Toggle to Feature recognition mode.  

8 Zoom into the area shown and select the first pocket shown.  
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9 Select Apply to generate the pocket, then repeat for pockets  and . 

10 Do not close the pocket dialog. 

 

11 Attempt to select the adjacent pocket shown above. 

PowerSHAPE does not recognise the feature as a standard pocket. In this 

instance the feature will be extracted as a solid cut feature. 

12 Close the Solid pocket form then select Solid cut.  

13 Extract the feature to add it to the feature tree. 

 

The Solid cut feature is added to the bottom of the solid feature tree below the 

three solid pockets created earlier.  

The feature recognition of fillets is similar in method. 

1 Select Create a Solid fillet  from the Solid features toolbar.  

 

2 Extract and create the three fillet features shown above. 
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Modifying extracted features 

Recognised features are modified in the same manner as if they were initially 

created directly in PowerSHAPE.  All current features are displayed in the Solid 

feature tree.  

 

3 Display the dialog for the first pocket by double-clicking the item in the 

feature tree.  

 Or right-click>Modify... 

 

The pocket can now be modified dynamically using the drag handles or 

updating the Pocket dialog values themselves. 

 

4 Modify the overall dimensions as above and click OK the form to accept 

changes. 
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All other features can be edited using the same method. 

5 Display the Solid Cut dialog.  

 

In this example the actual profile of the cut will be modified by altering the 

sketch which defines it. This process was also demonstrated in the Surface 

Modelling chapter. 

A wireframe sketch was automatically created when the feature was 

generated. 

6 Select Edit on the Solid cut dialog.  

 

7 From the curve editing toolbar, Select Edit with active dimensions.  
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8 Double-click on the bottom right corner dimension (circled red above) to 

display the Dimension value form. 

9 Change the dimension from 4mm to 2mm. 

 

10 Select OK on the dimension form and the Solid cut dialogs. 

 

The solid cut feature has updated with the new 2mm corner radius. 

Smart Feature Manager 
PowerSHAPE also allows multiple features and feature types to be recognised 

at once to speed up the process of recreating the solid tree. The Smart Feature 

Manager  is found in the Solid Feature  sub-menu. Selecting the 

feature type (which can be filtered down to specific sizes, sub-types etc) and then 

choosing Scan will search the model for features, adding them into the tree. These 

features can then be grouped automatically. 

 

 The smart feature manager is a very powerful tool however it uses a lot 

of processing power. It is advisable to scan for single feature types at 

one time. 
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Maintaining Solid history  

At this stage, If any direct editing tools were to be applied (e.g. Offset, Draft face), 

then PowerSHAPE displays a warning to the user. 

 

Applying the edit now would now remove all previous feature history 

generated. However the following procedure shows how to apply the edit and 

maintain feature history. A rib feature will be thickened to outline this 

important step if required. 

1 Select the single face shown. 

 

2 Select Offset  from the General Edits toolbar  and enter a value of 

2mm. 

 

The information dialog is displayed. 

3 Select OK to accept. 

 

The offset has been applied but associated history removed.  

 This is because a non history edit was applied to a part containing history. 

4 Select Undo  to revert to previous condition.  

At the bottom of the feature tree, the original imported solid is displayed.  
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Maintaining the Solid Tree: Method 1 

5 Right-click on the original imported solid at the bottom of the history tree and 

select the option to Rewind to Here. 

 

 

This will rewind the recreated build history until the original featureless solid. 

Note this will also suppress the features that are greyed out in the solid tree. 

6 Select the face on the copied base solid and create on offset of 2mm to 

thicken the rib. 

 The same warning message will still appear however anything greyed out 

above the blue rewind position line will be unaffected. 

 If a feature in the solid tree needs to be edited using a non-history edit 

you can move that feature to the bottom of the tree, just above the base 

solid and rewind to just above to perform the edit. This will only remove 

a single feature which can be re-recognised easily. 
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To remove the Rewind Position simply right-click in the solid tree on any feature 

and select the option to Remove Rewind Position. 

Maintaining the Solid Tree: Method 2 

7 Double click to modify the base solid 1.  

 

8 Select Copy solid  then OK. 

 

A copy of the base solid has been copied out into the feature tree. Note this 

base solid copy has no history including all the feature recognition items created 

earlier (holes, pockets...). 

9 Select and Blank the main solid with feature history.  

10 Select the face on the copied base solid and create on offset of 2mm to thicken 

the rib. 
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11 Unblank to bring back the main original solid with history. 

 

12 As before, double click to modify the original base solid 1.  

 

13 Select Replace Solid. 

 

A replacement solid must be selected. 

14 Select the copied out base solid from the feature tree.  

15 Select OK. 
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The original base solid has been replaced with the modified solid (thickened 

rib) whilst maintaining the previous history.  

This shows the powerful ability of PowerSHAPE to combine direct and feature 

recognition features on a component which was imported with no history. 

16 Save the model as..... 

....\PowerSHAPE Data\Direct modelling plate.psmodel 
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 Exercise 10: Pump housing 
 

1 Open the surface model  

.....\PowerSHAPE_Data\pump housing.psmodel 

 

2 Select all the surfaces and convert to a solid.  

3 Using direct modelling to apply the following design changes to the pump 

housing. 

4 Remove the complete outer Rib feature. 
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5 Lower the inner step face by 5mm. 

 

 



7 Direct Solid Modelling PowerSHAPE Pro 2015 

8.26  Copyright © Delcam 

6 Thicken the end plate by an additional 5mm whilst maintaining the edge fillets 

and hole chamfers. 
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7 Change the outer bore diameter to 40mm. 
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8 Modify the base plate to have six holes (from four) on the same PCD (Pitch 

circle diameter).  

 

Ensure one of the holes is centrally located to the main vertical rib as shown 

below. 

 

9 Finally, apply a draft angle of 15 degrees to the bottom face plate as 

shown. 

 

10 Save the model as..... 

…/PowerSHAPE-Models/Ex10 pump housing.psmodel. 
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What is a Surface? 
A surface is a skin of negligible thickness stretched across a defined 2D or 3D 

area.  

There are 3 main types of surface supported by PowerSHAPE: Primitives, 

NURBS and Power Surfaces. Each surface type has different constructional 

attributes and editing capabilities.  

When Surface  is selected from the main menu, the following buttons are 

displayed to the left of the graphics area. 

 

8. Surface Modelling 
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A definition of each function is as follows. 
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Primitive Surfaces 
PowerSHAPE can quickly create a range of simple surfaces defined by a few basic 

parameters. These are Primitives; they include seven standard shapes, 

extruded surfaces and surfaces of revolution. Using primitive surfaces, only 

the basic dimensional parameters can be modified with the original defined 

shape being fixed. Other types of surfaces used in PowerSHAPE include NURB 

surfaces (frequently obtained from imported data) and Power Surfaces. NURB 

surfaces also have limited editing capability and along with primitive surfaces 

must be converted to Power Surfaces for more powerful and complete editing 

capability. 

The PowerSHAPE Primitive Surface options include: 

 

 Primitive - Plane, Block, Sphere, Cylinder, Cone, Torus. Helix. 

 Extruded surfaces (from pre-defined wireframe). 

 Surfaces of revolution (from pre-defined wireframe). 

 

The Primitive Cone Surface is shown selected with the Cone editing dialog 

displayed. 

 The Surface Cone is a skin with the top and base open. 

NURBS surfaces (Non-Uniform Rational B-Spline) 

It is common for a surface model created using a different CAD system to be 

imported into PowerSHAPE. For this to be possible, PowerSHAPE supports other 

types of surface definitions such as NURB surfaces. PowerSHAPE also creates 

NURBS Surfaces during certain applications or if specified by the user in 

PowerSHAPEs Surface options. 

Conversion of Primitives and NURB to Power 

Surfaces 

If you want to perform more complex modifications to the shape of a Primitive 

or NURB Surface, you must first convert it to a Power Surface. With a Power 

Surface, you have access to a full range of editing options through a 

comprehensive Surface/curve editing toolbar or Dynamic operations.  
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 You cannot convert a Power Surface to a Primitive or NURB Surface. 

Select Menu > Tools > Options > Objects > Surfaces ensure that in the section 

labelled Primitives that Create as NURBS is deselected if direct conversion 

from Primitives to Power Surfaces is required. Otherwise, when Convert 

Surface is applied to a Primitive, the surface becomes a NURBS which, in turn, 

will have to be converted to a Power Surface. 

 Several of the surface creation options directly create a Power Surface. 
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Power surfaces 
A Power Surface is based on a network of 4 sided wireframe elements appearing 

as curves along (longitudinals) and across (laterals) the surface. 

A Power Surface can generate complex forms while retaining full editing 

capability including the direction and magnitude through surface curve 

intersections (Control Points). 

To define holes within the surface area or an outside profile not compliant with 

a 4 sided wireframe structure, specialist trim curves called Boundaries are 

applied.  

The area of surface between adjacent pairs of laterals and longitudinals is 

called a patch.  

The curves on a Power Surface are called longitudinals (along the surface) and 

laterals (across the surface). In some cases another, optional curve exists called a 

spine. This generally runs along the longitudinal direction, often in free space 

controlling the orientation of the laterals. 
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Laterals  This surface contains the minimum, 2 laterals that run across 

the surface direction. 

Longitudinals  This surface contains a total of 7 longitudinals flowing from 

corresponding points from the first to the second lateral. 

Spine (Drive Curve)  The spine (shown dotted) is used to control the 

orientation of the laterals. A spine is not mandatory and can be created or 

deleted as required without changing the surface shape. It occurs automatically 

such as during the creation of fillet surfaces or as part of the controlled 

geometry of a Drive Curve surface. 

The Cato mark  This identifies the start point for Laterals and 

Longitudinals on a Power Surface. It is positioned a short distance from 

point 1 along lateral 1 with a short line pointing from it, representing the 

Longitudinal direction. 
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Standard Primitive Surfaces  
There are seven standard primitive surfaces in PowerSHAPE: Plane, Block, 

Sphere, Cylinder, Cone and Torus and Helix. Primitive surfaces are generated 

with minimal data input and can be an ideal starting point for many applications. 

Primitives are coloured blue or gold in the toolbar to distinguish them from other 

surface creation options. 

 

When you create a primitive, it is given a size that is proportional to the zoom of the 

screen. It can be modified as required. A primitive can be moved, copied, rotated, 

intersected and filleted. However, if you need to alter the defined shape by actions 

such as moving surface points or adding extra sections, you must first convert the 

primitive to a Power Surface. 

All primitives are created in the direction of the active Principal Axis (by default this 

is along the Z-Axis). 

Extrusion Surfaces  
This type of surface is formed as an extrusion of a wireframe entity, normal to the 

planer base of the wireframe (default). If required, it is possible to change the 

settings in Tools > Options > Objects > Surfaces for the extrusion surface to 

generate along the active X, Y, or Z axis. If several items are selected for extrusion, 

a series of separate surfaces are generated.  

As with standard primitives, you can change only basic parameters for an 

extrusion surface, unless you convert it to a Power Surface. 

By default, the wireframe used to create the extrusion surface is deleted. To retain 

the wireframe, select Tools > Options > Object > Surfaces and select- Keep 

wireframe (extrusions and revolutions). 
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Extrusion Example 1 
This example demonstrates creating a wireframe polygon which is then used to 

generate an octagonal extrusion surface. 

1 Open New Model.   

2 Select Polygon  from the Line toolbar.  

The Polygon dialog is displayed. This allows you to specify the Number of sides in 

the polygon. The option to Create composite curve provides the ability to create a 

polygon as a single entity. If this option is deselected, the sides of the polygon will 

consist of single lines. 

 

3 In the Number of sides box, type 8. Select Edge points and select Create 

composite curve. 

The start and end points of the first span need to be defined before closing the 

form. 

4 Enter 0 in the Command Input box and press Enter. 

5 Enter 50 in the Command Input box and press Enter. 

6 Select OK to close the Polygon dialog. 

 

The wireframe is completed as a single closed composite curve. This will be 

used as the shape of the Extrusion Surface. 

7 Select the composite curve and switch to View Iso1.  

8 Select Extrusion  from the Surface toolbar.  
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This produces an extrusion surface from the selected composite curve up the Z-

axis by a default value.  

The extrusion has a set of double arrows (indicated by yellow arrow above), 

which are used to change the length up or down the Z axis and, if required, to 

create a negative extrusion (lower set). The workplane handles can be used to 

dynamically edit the position and orientation of the surface. 

9 Drag the arrows to a length of 50. 

 

10 Alternatively Double-click on the surface to display the Extrusion dialog. This 

can be used to enter or modify the dimensional values. The extrusion can be 

given a positive or negative draft angle. 

 

Using the Workspace Tab the extrusion can be repositioned by entering new 

origin coordinates, and aligned to, or rotated about an axis. 
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11 Enter a length of 100mm and select OK. 

12 Deselect the surface by clicking away from it. The extrusion surface is 

completed. 

PowerSHAPE can also simultaneously extrude several separate geometry 

items to make individual surfaces. 

13 Select the extrusion surface. 

14 Right-click and select Delete from the popup menu. Alternatively, press the 

Delete key. 

The surface has now been deleted; the original composite curve does not exist 

either. This was deleted by default when the extrusion was created. To 

automatically retain curves, select Tools > Options > Object > Surfaces and 

select Keep wireframe (extrusions and revolutions). 

Extrusion Example 2 
 

A 3D wireframe can be used to create an extrusion surface. 

1 Import the model from: 

.....\PowerSHAPE Data\3D_Wireframe.dgk 

2 Activate Workplane 1 from the Workplane selector. 

 

An extrusion surface will be created from the imported 3D composite 

curve. 

3 Select the composite curve and create a surface extrusion  to a length 

of 50mm. 
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The extrusion direction is normal to the planar base. This default can be 

changed. 

4 Select Undo  to return to the stage prior to creating the extrusion surface. 

5 Select Tools > Options > Object > Surfaces. 

The Primitives section controls the default behaviour when primitives are 

generated. By default, Create extrusions normal to planar base is selected. 

 

6 Deselect Create extrusions normal to planar base and select OK. 

7 Select the Z Axis , and select the composite curve. 

8 As before, create a surface extrusion. 

 

9 Select File > Close without saving the model. 
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Surfaces of Revolution Example 
A surface of revolution is created by rotating single geometry or a composite 

curve around a specified Principal Axis.  

1 Open New Model  and create a Workplane at 0 on the XY ‘face’. 

 

This shape will be connected with a composite curve. This curve will then be 

rotated 360° around the workplane to generate a surface. The correct axis 

for rotation must be pre-selected using the principal axis selector. In this 

case, it can be clearly seen the Y axis is required for the correct revolution. 

2 Select the Y-Axis . 

3 Create a composite curve of the section geometry, and select the wireframe.  

4 Select Surface of Revolution  from the Surface menu.  
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 The selected composite curve is spun around the active axis (Y) 

producing the bottle shape.  

The red side of the surface represents the negative side. If the cylinder appears 

red following the revolution, then reverse the surface by selecting  from the 

Surface Edit toolbar, or alternatively right-click>reverse.  

An end cap will be created by generating a curve around the end profile, and 

applying the Fill-In surface option. 

5 Select the view Iso3 (Ctrl+7).  

6 Create a Composite Curve on the open edge.   

 

7 Select the new composite curve. 

A fill-in surface can be generated from a composite curve or a series of wireframe 

entities. It is useful for filling in gaps in models. 

8 Select the Smart Surfacer  from the Surface toolbar.  
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9 In the drop-down list, select Fill In (if not already selected). 

 

 This Wizard will be used in detail later in the chapter. 

10 Select OK. 

 The surface is generated but negative side up. 

11 Right-click and select Reverse from the menu. 

The surface is reversed showing the user-defined, coloured side, which is the 

outside. 

 

12 Select File > Save As and save the file as: 

.....\PowerSHAPE Models\Primitive cylinder.psmodel 

 When you save a model the undo/redo history is reset. Only changes 

made after the last save can be undone or redone. 

13 Close the model. 
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Wheel Example 
Create the following wheel shape section. This will then be altered using various 

commands. 

1 Open a New Model and Create a Workplane at 0. 

2 Select View from top.  

3 Generate the basic wireframe shape. 

 

4 From the Curve  menu create a Composite Curve  of the wireframe. 

 With simple composite curves with an obvious route, holding the Alt 

key and clicking the wireframe will create the composite curve. 

5 Select the composite curve and create a surface of revolution.  
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6 Double-click the surface. The Revolution dialog appears showing the 

workplane options as well as the Angle of Rotation. 

7 Change the Angle to 180° and select OK. The surface is generated through an 

angle of 180 degrees. 

 

 Due to the properties of surface models as described earlier, the ends of 

the primitive surface will not be capped. 

Changing the shape of the surface of revolution 

To alter the physical shape of the surface of revolution, the original wireframe must 

be altered. The wireframe can edited beforehand in the normal way or after the 

surface has been generated. Both methods will be shown. 

1 Click on Undo  twice to return to the original wireframe curve. 

2 Select Stretch Object  from the General Edits toolbar.    

 

3 Select the top half of the shape, by dragging a box over it as shown. 

 Ensure the geometry to select is completely is within the drag box. 

4 Enter 0 50 to move the selected parts 50 mm along Y, stretching the back and 

inner wall. 

The top half is dragged upwards and the connecting geometry is stretched. 
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5 Select all the wireframe and recreate a surface of revolution.  

 

6 Double-click the surface to display the Revolution dialog. 

 The surface will be modified by directly editing the wireframe.  

7 Select the Sketch tab. 

 

 If required, a copy of the original wireframe can be created. 

8 Select Edit Sketch... 

9 From the Surface/Curve editing toolbar, select Edit the curve using active 

dimensions.  
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PowerSHAPE undraws the surface and displays the dimensions for the 

wireframe.  

 

These dimensions can be double-clicked and editted. The surface editing 

toolbar now displays additional functionality. 

 

10 Select the upper 15 dimension then Edit active Dimension. . 

 

11 In the Value box, enter 35 and select OK. 

12 Change the 200mm dimension to 150mm. 
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13 In the Revolution dialog, select the Finish button . 

14 Select OK to accept and close the form.  

 

The surface revolution is updated to reflect the wireframe changes. 

15 Select File > Save As and save the file as: 

.....\PowerSHAPE-Models\Primitive wheel.psmodel 

16 Close the model 
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Exercise 7: Surface bottle 
1 Using the information provided, create the surface bottle shown. 

 

 The following wireframe defines the sectional shape of the body. 
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 The main bottle body is 200mm in height. 

 

 The following wireframe defines the profile of the bottle top. 

 

 Create the bottle top arc using arc through centre, radius and span from 

the circle menu.  

 

 Ensure fill in surfaces are applied to both top and bottom of the body. 

2 Save the model as: 

.....\PowerSHAPE Data\Ex7 Surface bottle.psmodel 

3 Close the model. 
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Power Surfaces from Wireframe 

Smart Surfacer  
Several of the PowerSHAPE surface creation options have been included into the 

Smart Surfacer. If you select wireframe before opening the wizard then the most 

likely surfacing method is selected ready to be previewed and/or applied. If an 

alternative, valid surfacing method is required, you can toggle to it by opening the 

list of options and clicking on the downward pointing chevron. 

 

Automatic Surfacing options covered in this section are: 

 Fill-In 

 From-Network 

 Drive-Curve 

 From Separate 

 Two Rails 

Fill-In Surface  

A Fill-in surface is usually created from one or more enclosed wireframes.  A Fill-in 

surface  can also be created from open-ended wireframes and point data. 

1 Create a new model. 

2 Create a Rectangle from the 0 datum with sides of X50 and Y75. 

3 Create R 15 fillets at both of the top corners. 
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4 Select all the wireframe entities. 

5 Select the Smart Surfacer  from the Surface toolbar.  

 

The dialog automatically selects the most likely surface creation options for the 

selected wireframes. In this case, a Fill-in surface. 

6 Select OK to accept the surface and close the form. 

7 Select and delete the fill-in surface. 

8 Select Create a point  from the Workplane menu.  

9 In the Command input box enter the following 5 coordinate positions, pressing 

the Enter key after each one to save them. 

 

 25   37.5   0 

 15   15      5 

 15   60      5 

 35   60      5 

 35   15      5 

 

10 Reselect all the wireframe, including the five 3D points. 

11 Select the Smart Surfacer  from the Surface toolbar.  
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A smooth Fill-in surface has been generated to include the point data. In this case, 

PowerSHAPE created a NURB surface. If required, the surface can be converted to a 

PowerSURFACE after. 

12 Select cancel then close the model 

Fill in Surface - Die Example 

A fill in surface can also be made up from several wireframes. When a fill-in surface 

is generated, the composite curve is used to create the trimmed area within a 

surface. 

1 Create a new model and Import the following data; 

.....\PowerSHAPE Data\Fill-in_Die.dgk 

 

A new Fill-in surface will be generated inside the rectangular wireframe and 

from composite curves traced around the top edges of the surface forms. 

2 Hold down  the Alt key, and left-click the upper edge of each surface form to 

create a new composite curve for each one. 

3 From the Selection toolbar, click Quick select all surfaces and then Blank 

(Ctrl+J) the selected surfaces. 

 

 

 

4 Select all the composite curves and right-click on one of them to open the popup 

menu. Select Delete Dependencies. 
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When a curve or composite curve is created on an object (for example, a surface), it 

may be dependent upon that object. This option removes any such relationships 

that may exist between the curve and in this case, the surfaces. 

 

5 Select all the composite curves, then the Smart Surfacer.   

 

6 Select OK to accept the fill in surface. 

7 Unblank (CTRL+L) the model. 

 

8 Save the model as 



8 Surface Modelling PowerSHAPE Pro 2015 

8.26  Copyright © Delcam 

.....\PowerSHAPE-Models\Surface Die example.psmodel 

9 Close the model 

3D Fill-in Surface Example 

A composite curve does not have to be created in advance because it can be 

generated within the Fill-in Surface form. 

1 Create a New Model and Workplane at 0.  

2 Start a single line at 50 0 0 and enter a relative end point using the coordinates   

-20 0 20. 

3  Create a surface of revolution  around the Z axis. 

 

 

4 Select the Smart Surfacer  

5 Select Composite Curve Creator and trace a composite curve around the top 

edge of the surface. 

 

6 Select Save and Eject to save the curve. 

When the composite curve is completed, the Wizard recognises that the curve is 

suitable for producing a fill-in surface. The surface creation dialog is updated, and 

a preview of the surface is displayed. In this case, the surface is flat, but in 

many cases, you need a new surface that is tangential to the surrounding surfaces. 
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Creating a tangential surface 

1 Select Tangent to surfaces in the Smart Surfacer dialog. 

 

 The preview is tangential to the adjacent surface. 

 

2 Select OK to accept the surface. 

3 Close the model without saving. 

Drive-curve Surface 

A drive-curve surface consists of a spine curve along which section curves, are 

aligned perpendicular, relative to the spine points. Below is a drive-curve surface 

using a two sections running along the whole length of the drive-curve.  The 

minimum requirement is one sectional wireframe, positioned anywhere along 

the single Drive-curve. 

 

Racket Example 

The first step is to create the wireframe for the drive-curve of the tennis racket.  

1 Open a New model. 

2 Create a workplane at 0 and then construct the following wireframe. 
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This shape will form the single drive-curve along which the surface will be 

generated.  

In this case, wireframe sections will be defined perpendicular to and at strategic 

positions along the drive-curve.  

Upper cross Section 

3 Create a new Workplane and position it at the midpoint at the top of the racket 

 

 

4 View from the Right (+X) and zoom in to the new Workplane. 
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5 Create the following wireframe section on the new Workplane.  

 

 

6 Select the Y principal plane. 

7 Generate two circles of radius 10 with their centres snapped to the end of the 

open lines. 

 

The drive-curve and each cross-section must be single entities before the 

required Drive-curve surface can be produced. The sections are already single Full 

Arc entities, but the drive-curve is a series of arcs and lines which must first be 

made into a single composite curves. 

8 Create a single composite curve out of the main drive-curve and upper 

cross section entities. 

9 Select all three sections and the drive-curve. 

10 Select the Smart Surfacer.   

 



8 Surface Modelling PowerSHAPE Pro 2015 

8.30  Copyright © Delcam 

The Smart Surfacer recognises that the wireframe selection is suitable for creating 

a drive-curve surface and changes the option in the drop-down list accordingly. A 

preview of the surface is displayed. 

11 Click OK to accept 

 

This generates a surface with a section that changes from the first circle to the 

defined section, and then back to the last circle. 

To maintain a particular cross-section at a position on the drive-curve, extra 

sections can be added.  

12 Select and delete only the surface. 

13 Select the composite curve section at the top of the racket and select the Z 

principal plane.  

14 Select Rotate items   from the General Edits toolbar.  

 

A blue arrow indicates the directional axis and position of rotation. Although 

the direction is correct, the position will need to be moved to the centre of the 

racket if the section is to be copied to the correct position.  

15 Select Reposition rotation axis  from the Rotate toolbar then snap to the 

centre key point of the circle racket as shown. 
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The Rotational axis has moved to the centre of the racket. 

16 Select Copy the selected item button, enter Angle as 90 then Enter. 

 

A copy of the original section is previewed. 

17 Select the green tick to confirm. 

18 Enter 180 in the rotate form then green tick to accept. 

 

19 Close the rotate form and reselect the drive curve and 5 section entities. 

20 Generate a surface from drive-curve using all five sections. 
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The elliptical shape is now constant between the three sections indicated. 

21 Select File > Save As: 

.....\PowerSHAPE-Models\surface racket 

22 Select File > Close. 

Surface from separate curves  

If separate curves are selected, the Smart Surfacer uses the Create a surface 

from separate curves option. 

      

The separate curves are defined across the surface (laterals), which are then 

linked with curves of best fit along the surface (longitudinals). 

Lateral Curve Example 

1 Create a new model and workplane at 0. 

2 Create a continuous line from the workplane, using the distances 10 in Y, 10 in 

X, and 10 in -Y to produce an n-shape. 

 

This section is the basis for the other sections, so the next step is to copy it up 

the Z-axis as individual lines:  
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3 Select the three lines, then Move/Copy items  from the General Edits 

toolbar.   

4 Enter 2 for the No.```` of copies and the value of 0 0 5 in the position 

window.  

 

5 Confirm the preview with the green tick. 

Each composite curve will be filleted by a different radius. 

6 Make composite curves from each set of lines (Alt key and left-click). 

7 Create a fillet radius of 1 on the bottom curve. 

8 Create a fillet radius of 2 on the middle curve. 

9 Create a fillet radius of 3 on the top curve. 

 

An additional two curves will be copied to produce a total of 5 curves. 

10 Select the lowest composite curve and Move/Copy it up the Z-axis by 20.  

11 Select the second from bottom composite curve, and Copy it up the Z-axis by 

10.  
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All of the shapes have been turned into composite curves, ready for surface 

generation. Each of the composite curves will be turned into a lateral on the 

surface. 

12 Select all of the composite curves then Smart Surfacer.  

13 Select Surface  and select Smart Surfacer  from the Surface toolbar. 

 

The Wizard analyses the selected wireframe and selects the surface type to be 

created as From Separate. 

14 Select OK to create the surface from separate curves. 

15 Close the file without saving. 
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Surface From Network of Curves 

Surface from Network creates one or more four-sided surface patches over a 

network of wireframe. Surface definition will not occur on any open ended parts of 

wireframe that extend beyond the network. 

         

Surface Gap Example 

The following example uses Automatic surfacing and applies a Surface From 

Network to blend across a significant gap in the model. 

1 Open a new model. 

2 Import the model. 

.....\PowerSHAPE_data\network_example.dgk 

3 View in ISO1  to show the gap to be filled. 

 

To fill the gap with a smooth surface, additional wireframe curves will be 

created. By default, the tangencies of the existing surfaces are used by 

composite curves defined along exiting surface edges.  

4 Switch to Wireframe view  so the internal geometry can be seen. 
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5 Select Create Composite Curve.    

 

The Composite Curve toolbar is displayed. 

6 Select Define Start Point, then click on the key-point on the corner of the 

surface shown. 

 

7 Select the bottom edge with the left mouse button to create the first part of the 

composite curve.  

 

The curve continues to the first branch point awaiting further interaction from the 

user. In this case, too far. 

8 On the Composite Curve toolbar, select Backwards  once to go back one 

span. 
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9 Left-click on the opposite corner indicated by the red arrow below. 

 

A dialog requests if the composite curve jump to this position? 

10 Select Yes. 

 

The composite curve jumps to the selected point while maintaining the 

tangencies relative to both surfaces. 

11 Select Save  on the Create Composite Curve toolbar. 

12 Create a second composite curve along the three edges shown.  

 

When a composite curve is created along a surface edge, it inherits the 

tangencies of the surface. These are reproduced if the curve is used to create a 

new surface from appropriate Smart Surfacer options.  

Although enough wireframe is now available to create a Surface - from Network, 

a more accurate alignment will be achieved by creating additional curves across the 

void. Existing lateral geometry will be used. 

13 Select and Blank the last composite curve. 
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14 Create a new composite curve along one of the intermediate curves on the 

right surface and as before attempt to bridge the gap to the corresponding curve 

on the left surface (as shown below). 

 

The end of the composite curve is aligning to the surface edge and not, as required, 

along the intermediate curve! 

15 On the Composite Curve toolbar, select Backwards  once to go back one 

span. 

16 Select Save  on the Create Composite Curve toolbar. 

17 Similarly, generate another composite curve along lateral above on the same 

surface as shown. 

 

18 Create two further composite curves along the corresponding surface curves 

on the left surface as shown below. 

 

19 Select and Blank all surfaces on the model. 
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20 Create a new composite curve with the start point at the start of the existing 

composite curve as shown. 

 

21 Click on the curve to include it as part of a new one and then click on the 

continuation at the end of the corresponding curve across the gap. 

22 Select Yes to use tangents. 

 

23 Save  the curve. 

24 Repeat on the curve(s) above. 

25 Delete the two curves that are not part of the required surface network. 

 

26 Unblank (CTRL+L) to bring back the surfaces and composite curve created 

earlier. 

27 Quick select all wireframe  and then Smart Surfacer.  
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The Wizard selects From Network as the most likely option to create a surface 

from the selected wireframe. 

28 Select OK. 

29 Select the new central curve running down the surface. Right-click the surface 

and select Free tangents and magnitudes in the local menu to provide a 

smoother transition. 

30 Deselect the curves. 

 

The gap in the model is filled in with the new surface which flows smoothly into 

the adjoining surfaces. 

31 Select File > Save As: 

.....\PowerSHAPE Data\network curve example.psmodel 

32 Select File > Close. 

Surface from Two Rails 

A surface can be generated from a section  that is scaled along two drive rails 

, defining the edge of the surface. 
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The section is scaled across corresponding points along the drive rails to generate 

the surface. Drive rail pairs must contain the same number of points and can both, 

if required, form a closed loop. The end points on an open section must be 

positioned exactly on the start point of each drive rail . Both the section and the 

drive rails must be defined as composite curves. 

 

Surface from Two Rails Example 

1 Import the model: 

.....\PowerSHAPE_data\two_rail_data.dgk. 

 

2 Select one of the drive rail curves to display the Curve Editing toolbar. 

 

3 Shift-select the other drive rail curve. 

4 Select Show point labels.   
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Each drive rail must have the same direction and number of points. In this this 

example, the opposite. 

5 Select just the top curve (10 points).  

6 From the Curve Editing toolbar, select Create a point. .  

The Insert point into curve form appears. For this example the Parameter Value 

tab is used. This enables you to insert a point positioned at a proportional distance 

between two existing ones. For example, 5.5 is half way between points 5 & 6. 

 

7 Select the Parameter tab and enter 5.5. Select Apply and then Dismiss. 

 It is easier to add points from the last number backwards because the 

curve is renumbered when each point is added. 

 

A point is added to the curve 

8 Select the bottom curve (6 points) then Reverse surface/curve.  

9 With the lower curve still selected, select Create a point. . 
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10 Select the Parameter tab and enter 4.5 then Apply. 

11 Enter 3.5 and select Apply. 

12 Enter 4.5 and select Apply. 

13 Enter 3.5 and select Apply. 

14 Enter 2.5 and select Apply and then Dismiss. 

15  Select both curves. 

Each curve has the same number of points so the generated surface aligns 

smoothly. 

 

16 Select all three composite curves then Smart Surfacer.  

 

The Wizard recognises that a Two Rails surface is the best choice for surface 

creation.  

However, the section height has scaled in proportion to the distance between 

the drive-curves at each section position. 

17 Select the Advanced button at the bottom right of the Smart Surfacer form. 

 

The Options for Surface from section and two rails dialog is displayed. It 

provides more control over the way in which the surface is defined from the selected 

wireframes. 
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18 Select the Maintain Depth option and select Preview. 

 

This time the height has been maintained to that of the original section. 

19 Select OK twice to accept. 

20 Select File > Save As: 

.....\PowerSHAPE-Models\two rail surface example 

21 Select File > Close. 

Limit selection 

Limit Surface using a Surface as the Cutting Object 

When the Limit selection option is applied with surfaces, they are trimmed 

back to their common intersection. The Next Solution option enables you to toggle 

through all possible trim combinations. When a surface has been included in the 

limit selection process, a boundary is created, and only the part of the surface either 

inside or outside is displayed. Several surfaces can be limited with a single cutting 

object. 

1 Create a new model and workplane at 0. 

2 Create a plane primitive surface  on the 0 datum of size X 50, Y 50. 

3 Create a cylinder primitive surface  of Length 40 and Radius 5 

positioned at Z-20. 

 

The cylinder will be limited by the plane. 

4 Select Limit selection  from the General Edits toolbar.  
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5 Select the Plane surface. 

 

The Plane has been assigned as the cutting object.  

6 Click anywhere on the top side of the cylinder surface. 

 

The plane and cylinder are automatically trimmed back to their common 

intersection. 

 This is one of several solutions; the others can be obtained by clicking 

Next Solution.   

7 Keep selecting Next Solution  until the following trim combination is 

displayed. 

 

8 Close the Limit selection form.  

 If the lower half of the cylinder is clicked during the original selection 

process, it would be the initial solution. 

9 Select Undo.  
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10 Select the plane surface first and then Select Limit selection.  

 

By selecting a surface first, the form opens with it assigned as the cutting object. 

 

11 Click  to change to the Keep both option.   

12 Select the cylinder surface.  

 

 When Keep both is active, Limit selection splits the secondary surface 

selection into two surfaces, one on each side of the Cutting Object. 

13 As before, close the form  then Undo.  

14 Select the plane surface first and then Select Limit selection.  

15 Click  to disable Trim both.  

16 Select the cylinder surface. 

 

 When Trim both is disabled, the Cutting Object (primary selection) is 

not trimmed back to the secondary selection. 

17 Close the model without saving. 
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Limit Surface using a Curve as the Cutting Object  

A wireframe entity can also be used as the Cutting object, This as shown in the 

following example.  

1 Open a new model and import the following data; 

.....\PowerSHAPE_Data\Limit2.dgk 

 

The imported model contains a component made up of six separated surfaces 

and some wireframes defining the 2D trimming requirements. 

2 Activate Workplane 1 located at the base of the component. 

 

3 Select X as the operational direction.  

4 Pre-select all the surfaces and the composite curve aligned on to the left (as 

shown above).  

5 Select Curve projection  from the Curve Toolbar.  
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6 Select the option Through item then OK. 

 

A composite curve has been generated through the component in the X axis. 

7 Select Z as the operational direction. 

8 Select the new composite curve then Limit selection.  

 The curve is the cutting object.  

 

9 Drag a box to select all the surfaces and, if required, click Next solution to 

produce a trim retaining the parts of the surfaces above the split curve. 

 

10 Close the form. 
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Limit Surface using a Workplane as the cutting 

object 

 

A Workplane can also be used as the cutting object as shown in this example. 

 

1 Activate Workplane 2 as shown. 

 

2 Select the Workplane itself then Limit selection.  

3 Box select all the surfaces and, if required, click Next solution to produce a 

trim retaining the parts of the surfaces below the workplane (-Z). 

 

4 Click the cross at the top-right corner to close the Limit selection toolbar. 

5 Close the model without saving. 
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Surface Filleting 
As with Solids, Surface filleting is mainly used to create a smooth join between 

two or more surfaces.  

A fillet surface is the developed outside contour of a ball if rolled between two or 

more surfaces. PowerSHAPE can create both fixed and variable radius fillets 

between surfaces. Where the ball makes contact defines the outer edges of the fillet 

to where, by default the original surfaces are trimmed back to the fillet edge. It is 

also possible to create a fillet between a composite curve and a selection of 

surfaces.   

PowerSHAPE creates concave fillets running from the outside (user-defined colour 

side) or convex fillets from the inside (red side) of the host surfaces. The concave 

filleting direction for each surface is marked by an arrow which, if clicked, reverses 

the surface causing a concave fillet to run from the other side. Otherwise, the 

convex option is applied. 

Basic Fillet Example 
This example demonstrates the basic filleting options between 2 surfaces. 

1 Create a new model. 

2 Create a plane primitive surface  of length 100 and width 100 at 0 0 0. 

3 Create a Cone Primitive of base radius 30, top radius 15 and length 

50 at 0 0 0. 

4 Right-click over the cone and select Convert Surface (converts to Power 

Surface). 

 

A selected Power Surface displays more information graphically and editing 

options the Surface editing toolbar. 
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The small arrow points outwards from the surface, indicating that this is the 

outside edge of the surface. The large arrow indicates the operational direction 

for editing surface points  

 The large arrow does not affect filleting. 

5 Select both surfaces and switch to Transparent Shading.   

6 Select Surface fillet from the Surface toolbar.  

 

The surface direction arrows are displayed. If clicked, these turn the surface inside 

out. The small arrow points away from the outside (user-defined colour) face of 

surface. 

7 Leave the default 5mm radius and concave setting, and select Preview on the 

Fillet Surface dialog. 

 

The fillet track is displayed as the centreline of the rolling ball as it runs along the 

selected surfaces. If it is acceptable, select OK, otherwise enter alternative values 

and select Preview again until the end result is acceptable. 

 

 

 

 

 

 

 

 



8 Surface Modelling PowerSHAPE Pro 2015 

8.52  Copyright © Delcam 

8 Select OK on the dialog. 

 

The Select Fillet Route dialog is displayed. 

The single drive curve now turns yellow to show that it is selected. As there is only 

one track available in this case, select OK to create the fillet.  

For examples with more than one track, no track is pre-selected. Select each one 

and Apply in turn, until all the required fillets have been created. Then, select OK to 

finish. 

9 Select Apply followed by OK in the dialog. 

 

The fillet surface is produced. The cone and plane are trimmed back to a 5mm 

concave fillet. 

 

10 Create a Plane Primitive at 0 0 40 with a length and width of 80. 

11 In the Workspace Tab of the Plane form, apply a Y Twist of 10 degrees. 

 

This top surface will be filleted to the cone, but this time the fillet is on the inside of 

the cone.  
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12 Select just the cone and the angled plane surface, then Surface fillet.   

 

13 Enter a Fillet Radius of 3 mm, select Convex and select Preview. 

 

14 Select OK (fillet surface) and then OK (Select fillet route). 

 

The fillet is produced trimming back the top of the cone and the plane. 

Fillets can also be produced with several surfaces. 

15 Select X as the operational axis and create a Cylinder Primitive positioned at –

30 0 20. 

16 Change the radius to 6, length to 60 and rotate it with an X-Twist of –15. 

17 Select and reverse the cylinder surface only (red on outside). 
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18 Select all of the surfaces except the lower base fillet and plane. Then Surface 

fillet.  

19 Enter a Fillet Radius of 2 mm, select Convex, and select Preview. 

 

The available fillet tracks are displayed. The cylinder was initially reversed to control 

where the fillet tracks appeared. 

20 Select OK. 

In this case, PowerSHAPE has identified two complete fillet tracks. PowerSHAPE 

allows you to specify which track you wish to use. Fillet tracks are created only 

between the two separate groups and not surfaces within the same group. 

21 Select the first fillet track nearest the plane (lowest one), which turns yellow. 

22 Select Apply. 

23 Select the second track nearest the top, select Apply. 
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The surface cylinder is limited back to the fillets. By reversing the cylinder, the fillets 

are produced internally and not on the outside. 

Filleting using Primary and Secondary sets of 

surfaces 

 

The Filleting option checks every selected surface to find all the potential tracks. 

Where there are a large number of surfaces involved, this can take some time, and 

it may be awkward to identify the required fillet tracks. 

By using the Secondary Selection option, it is possible to register the two 

separate sets of surfaces for the fillet to run between. With this option, the first pre-

selection of surfaces (yellow) is registered to the Primary (selected) set. If the 

Secondary box is then selected, any further surface selection is registered as the 

Secondary set of surfaces (pink). PowerSHAPE only attempts to create the fillet 

tracks between the separate groups.  

1 Select the lower plane and fillet and delete them. 

2 Select X as the operational axis and create a Plane Primitive at 0 0 20 with a 

width of 110 and a length of 60. 

3 Ensure the positive side of the surface is facing (+X) as shown. 

 

4 Select the Primitive plane surface then Surface fillet.  
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This surface is now assigned as the primary surface. 

 

This set of selected surfaces will become the secondary set. The fillet routes are 

calculated only for the intersection between the primary and secondary surfaces. 

This results in a quicker calculation for the fillet routes. As fewer routes are 

produced, it is also easier to select the correct ones. 

5 Drag a box over the surfaces on the left as shown, to assign as the secondary 

set. 

6 Set a Fillet radius of 2 mm and select Convex. 

7 Select OK. 

8 Select the first track and then select Apply. 

9 Select the last track and then select Apply. 

The fillets are produced and most of the other surfaces have been trimmed back. 

10 Delete the detached surface. 

 

11 Use a suitable method to limit the bottom of the plane back to complete the 

model. 
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12 Select File > Save As: 

.....\PowerSHAPE-Models\fillet example.psmodel 

13 Select File > Close. 

More filleting using Primary and Secondary 
surfaces  

The following example uses a simple tap design to demonstrate fillet creation 

between a Primary and Secondary set of surfaces. 

1 Create a New Model and Workplane at 0. 

2 Generate the following wireframe on the XY Plane. 
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3 Create a surface of revolution around the Y axis. 

4 Rotate the new surface 90 degrees about the X Axis to align it to the Z 

direction. 

 

5 Switch the operational axis to Z. 

6 Create a new workplane at 0 0 44. 

7 Generate a Sphere Primitive  of radius 7.5 at the new workplane. 

 

The lower half of the sphere will be limited to remove the overlapping surfaces. 

8 Select the workplane, then Limit selection.  

9 Select the Primitive Sphere, and, if necessary, select Next Solution to retain 

the top half before closing the dialog. 

 Ensure the correct operation axis is selected first! (Limiting occurs in the 

direction of the active Principal Plane) 
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The Primitive Sphere is limited back to the workplane with the top half being 

retained 

10 Select a view from Front (-Y) then create the following wireframe 

geometry for the tap lever shape around the workplane. 

 

11 Create a surface of revolution around the X Principal Plane. 

12 Rotate and copy this surface 3 times by 90 degrees around the Z Principal Plane 

to make the four levers. 
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The four arms need to be filleted to the central section. Make sure that when 

shaded, all the surfaces are positive. We do not want to fillet each arm to each 

other or to generate the route, so we are going to use the Secondary surfaces 

option. 

13 Select both the shaft and sphere surfaces then Surface fillet.  

 

With the primary surfaces pre-selected, the dialog now awaits the secondary 

surface selection.  

14 Select the four lever surfaces.  

15 Enter a Concave Fillet of Radius 2 then OK the fillet dialog. 

16 Select OK. 

 

The fillet tracks are displayed. 

17 Select and Apply each one to complete the exercise. 
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18 Select File > Save As: 

.....\PowerSHAPE Data\surface tap.psmodel 

19 Select File > Close. 

Variable Radius Fillets 

Variable radius fillets can be created along the fillet track using the mouse to 

identify key points or by applying specialist options to position the fillet arcs 

either by parametric, relative or absolute values.  

Example 

20 Select Create New Model and workplane at 0. 

21 Create two circles with radius 8.5 at X 30 and X -30.  

22 Create an arc through three points of radius 50 on both sides of the two 

circles to form the following shape. 

 

23 Create a Composite Curve from the wireframe. 

24 Generate a Surface Extrusion of length 60. 

When an Extrusion surface is created, the default option causes the wireframe 

used to be deleted. This default status can be altered to retain wireframes by 

selecting Tools > Options > Object > Surfaces>Keep wireframe (extrusions 

and revolutions). 
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Alternatively, the individual wireframe for an extrusion can be retrieved directly.  

25 From the sketch Tab, select Create a copy of the sketch then OK. 

This returns a copy of the original composite curve to be used to create a Fill in 

surface at the base of the extrusion. 

26 Select the new composite curve and create a Fill in surface. 

27 Reverse the surface so the red side is facing up the Z axis. 

 

28 Delete the composite curve. 

29 Select both surfaces then then Surface fillet.  

30 Input a Fillet radius of 3, select Convex and select OK. 

31 Select a View down +Z  and switch to wireframe view. 
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The fillet track is displayed (in yellow) with circles (in blue) showing Key points 

that can be snapped to using the mouse. By snapping at these Key points, an arc 

of the initial radius is created. The value of this radius can be modified in the 

Arc Radius area of the form.      

32 Snap to each of the 6 circles when the word Key appears. 

33 6 arcs have been created and can be selected from the Current Arc drop 

down list. 

A radius appears for each point and this becomes numbered in the current arc part 

of the form. Individual arcs can be selected from this form or by manually clicking 

on them. The radius can be changed in the form or dragged manually. 

Graphically, selected arcs are displayed in blue with unselected in red.  

 

New laterals are added either by clicking on the track, or, more accurately, by 

entering in the form as a parametric position. To add a lateral at a parametric 

position, select the adjacent laterals, and check their number on the form in the 

Current Arc box. Switch the ABS box to PAR, enter the required parametric 

position (such as 4.5 for midway between 4 and 5) and press Return.   

34 Select the correct arcs (displayed in blue) and insert two new radii between the 

two at each side, as shown. 
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While the form is active, the values for individual fillet arcs can be edited or 

deleted. The radius progressively changes between the two arcs assigned with 

different values. 

35 Select the new arcs in turn and change the radius to 5 mm. 

36 Select the arcs (in turn) on each side of the new larger arcs and select 

Delete on the dialog (4 arcs in total). 

 

When there is an arc, the fillet value is fixed at that point. If the next radius value is 

different, the radius changes smoothly along the distance. 

37 Select Apply to create a variable radius fillet. 

 

38 Close the model without saving. 
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Editing a Power surface 
A Power Surface is a surface created from wireframe items.  

If you create or select a power surface, the Surface Editing toolbar will be displayed 

and the options that are appropriate for your surface are made available. 

There are three entities that you can edit on a surface: 

 the surface itself. 

 the curves within the surface. 

 the points on the surface within the curves. 
 

Editing curves and points on a surface 
Editing curves and points within a surface use the same methods as wireframe 

curves. 

You can use Edit > Convert > To Wireframe to create wireframe curves from selected 

surface curves (laterals, longitudinals and spines). 
 

Editing the power surface 
You can edit a power surface in a number of ways, most simply: 

 With the power surface selected, use the graphical surface editing features to edit 

it. For example below, a control point is being dragged. 

 

 Select the surface to display the Surface and Curve Editing toolbars. 

 

9. Surface Editing  
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You must have curves selected for the following options to be available from the 

right mouse local menu. 

Convert to wireframe - A composite curve is created from the selected curve.  

You must have curves or points selected for the following options to be available. 

Edit tangent angles - This displays the Tangent Editor dialog, which allows you to 

edit the tangent directions and magnitudes of curves. 

Free magnitudes - This frees tangent magnitudes through selected points along 

the selected surface curve. If no points are selected, the whole curve is freed. 

Free tangent and magnitudes - This frees the tangent directions and magnitudes 

through selected points along the selected curve. If no points are selected, the 

whole curve is freed. 

Single Surface Curve Point Edits 
In the same way as curve editing covered earlier, single points on surface curves 

can be edited directly in the graphics window using a variety of different 

graphical edit handles, as well as using the Command Box on the Status Bar. 

Use the handles on curve points to graphically modify single surface curve points. 

The handles will display only when a single point is selected. 

It is possible to change they different curve point handles within Edit>Surface and 
Curve Edits>Common Edits> Selected Point Graphical Handles or by right-clicking with a 
single point selected. 

The following types of handles are currently available to use: 

 Tangent and Magnitude graphic handles. 

 Tangent and Normal graphic handles. 

 Workplane graphic handles. 
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Tangent and Magnitude graphic handles 

1 Select a point on the curve and right-click and ensure that Tangent and Magnitude 
graphic handles is selected in the menu. 

 

These handles allow the user to graphically edit the Tangency and Magnitude of the 

curve point.  

The arced handles offset from the end will modify the tangent angle of the curve in a 

fixed circular motion, without affecting the magnitude as can be seen below. 

 

The arrows at the end of each handle will graphically modify the magnitude of the 

curve along a fixed tangent angle, in this case to help the user, PowerSHAPE will give 

interactive feedback of the magnitude. 
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The Spherical handles will modify both the Tangent and Magnitude freely in 2D or 3D 

space. Again, PowerSHAPE will give interactive feedback of the magnitude to the user. 

 

Finally, the spherical handle at the selected curve point position at the centre will edit 

the position of the point, without affecting the direction or magnitude of the point. 

For increased usability the intelligent cursor will remember the original position, and 

give coordinates (X, Y, Z) of the movement. 

 

Tangent and Normal graphic handles 

1 Select a point on the curve and right-click and ensure that Tangent and Normal 
graphic handles is selected in the menu. 
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These handles allow the user to graphically edit the position of the selected point in 

fixed Normal or Tangent directions, and alternatively freely in a 2D plane. 

 

The arrow handles tangent to the curve will modify the position of the point in a 

fixed direction along the tangent direction. For accuracy the offset distance from 

the orginal location will be visible, as well as editable once the mouse button has 

been released. 

 

 

Similarly, the arrow handles normal to the curve will modify the position of the 

point in a fixed direction along the normal direction. For accuracy the offset 

distance from the orginal location will be visible, as well as editable once the 

mouse button has been released. 
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The 4 Planar Handles surrounding the point will allow you to move the point freely in 

a 2D plane while again the original location is kept visible throughout (1). 

 

Again, the central spherical handle at the centre will move the point freely in 3D 

space while showing X, Y, Z coordinates offset from its original location. 

 

Workplane graphic handles 

2 Select a point on the curve and right-click and ensure that Tangent and 

Normal graphic handles is selected in the menu. 

 

 



PowerSHAPE Pro 2015 9 Surface Editing 

Copyright © Delcam  9.7 

Clicking and dragging the workplane axis arrow handles will move the point in a fixed 

axial (X, Y or Z) direction with a visible offset distance from the original position, 

with the option to further edit or fine tune the offset once the mouse button has 

been released. The workplane origin in this case allows the point to be moved freely 

in 3D space. 

 

Graphically inserting a curve on a surface 

When any point on a surface is selected, the handles of the point will be 

displayed.  

 

 Hold down Ctrl, click on the instrumented point and drag the cursor to the 

position where you want to add the new curve.  

 Release Ctrl and the mouse button to input the curve. This also renumbers the 

other curves to reflect the change. 

 

 If you release the mouse over a lateral, only a longitudinal is inserted. If 

you release over a longitudinal, only a lateral is inserted. If you release 

the mouse at a position not on the surface, then no curve is inserted. 
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Graphically moving a point along a surface curve 

 

You can adjust the position of a point along its adjacent curves. 

When any point on a surface is selected, the handles of the point will be 

displayed.  

 

 Hold down the Shift key and drag the instrumented point along its adjacent 

surface curves. 

 

 Release the Shift key and the mouse button to move the point. 

The shape of the surface does not change. 

 

You can drag the point along a curve up to the next point on the surface. If you 

drag the point to any other position, the point is moved but the shape of the 

surface changes. 
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Editing a surface using the toolbar 

When you create or select a power surface, the Surface Editing toolbar will be 

displayed and the options that are appropriate for your surface are made available. 

 

Use the following table to identify the buttons on the toolbar.  
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Food Container Example 
The project starts by importing the model shown below left, and progresses to the 

finished outer form of the food container. Key surface editing techniques will be 

shown. 

        

1 Import the pre-defined CAD data located in: 

.....\PowerSHAPE_Data\SurfaceEditStart.dgk 

Conversion of primitive to Power Surface 

2 Select and Blank the wireframe only . 

3 Make Workplane 1 active.  

 Before any changes can be made, this primitive surface will be converted 

to a Power surface. 

4 Right-click on the surface and select Convert Surface in the local menu. 

     

 Depending on the settings, the surface is converted to a NURBS surface 

(the default) or directly to a Power surface. 

 The option can be changed in Tools>Options>Object>Surfaces. 
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With the default setting above, a Power Surface has been created with all of the 

surface editing toolbar options available. 

5 Select View From Top (+Z).   

6 Unblank to display all entities. 

Dynamic editing of a surface curve  

 

   

Two additional surface lateral curves will be added, using the lines above as a 

reference. Curves can be added in a number of ways. In this example curves will be 

added using the Workplane intersection option. The new curved will then be 

manipulated and aligned to the end points of the fillet radius along the route of the 

lip. 

1 Ensure that Workplane 1 is active. 

2 As shown on the right hand side image above, dynamically rotate it to align 
the Y Axis with the first of the construction lines that run from the centre to 

the ends of the radius on the modified corner geometry. 

3 Set the operational direction to X . 

4 Select the surface to display the Surface editing toolbar. 

5 Select Add curve.  

 

Four methods are available to add laterals or longitudinal curves. 

6 Select the Workplane intersection then lateral from the drop down list. 
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 If a cross-sectional surface curve itself was selected (not surface) prior to 

opening the form, the Insert option would have pre-set to Lateral. 

 

A red outline indicates the position of the new lateral. In this case on the XY 

plane of the active workplane.  

7 Select Apply to insert an additional lateral curve. 

 

 Image shaded here to show new curve generated. 

8 Rotate the workplane to align the Y Axis with the other of the construction lines 

that run from the centre to the ends of the radius on the modified corner 

geometry. 

9 Insert a second additional lateral, flush with the workplane YZ plane. 

10 Select and delete the three straight construction lines. 

 



PowerSHAPE Pro 2015 9 Surface Editing 

Copyright © Delcam  9.13 

11 Select the two original laterals that are not aligned to key points on the lip-

shaped composite curve.  

 

12 Select Delete curve  from the Surface/curve editing toolbar. 

13 Select any curve and ensure smoothing if OFF  from the curve editing 

toolbar.  

 If the option is ON  then smoothing is applied through all points 

including Powersurface editing. 

     

14 Select the middle surface point on the outer longitudinal in the top-right 

quadrant ,and dynamically drag it to the corresponding keypoint on the new 

lip-shaped composite curve (as shown below). 

 

15 Repeat the drag move on the adjacent surface points to create the following.  

 Ensure a keypoint (End) is selected on the compositive curve. 
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The tangency and magnitude through the 3 points requires freeing up to 

achieve the more natural transition through the points. If smoothing was ON 

 then this would have been achieved immediately. However this example 

will show how to smooth a surface after creation. 

 

16 Switch to Wireframe View . 

17 Use Shift Select to select the outer longitudinal line, followed by the 3 points 

through which correct alignment is required. 

18 Right-click on the longitudinal and select Free tangents and magnitudes in the 

menu. This creates the most natural geometric flow through the selected surface 

points taking into account the adjacent non-selected points. 

19 Shade the model. 

 

20 Select the longitudinal running around the inside of the rim (indicated above) 
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21 Select Break surface  to split the surface into two separate upper and lower 

halves. 

22 Select and delete the upper surface. 

 

23 Select a view from top (down Z), then select the alternate six surface points 

around the outside of the lid as shown below. 

 

If one or more surface curves or surface points are selected, it is possible to 
select the Edit sub-item option. This lets you apply the General Edit options to the 

selected sub items and not the surface as a whole.  

 

24 Select Edit sub items  from the General Edits Toolbar. 

25 Select Offset , enter a value -2 and press the Enter key. 
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The selected surface points have been offset inwards, normal to the surface. 

26 Select and Delete  the inner most surface longitudinal curve. 

27 Create a composite curve along the new inner most surface curve. 

 

28 Generate a Fill in surface using the Smart Surfacer.  
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29 Use the remaining composite curve defining the outer profile, and generate a 

surface of revolution.  

 

 

30 Save the model as 

.....\PowerSHAPE-Models\food container.psmodel 

31 Close the model. 
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Exercise 8 : Surface Jug 
1 Create a surface model of the outside of the jug shown below. 

 

 

2 Save the model as 

.....\PowerSHAPE-Models\Ex8 Surface Jug.psmodel 

3 Close the model 
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Surface Trim Region Editing  

Trim Boundaries 
A trim boundary on a surface defines the trim region of a surface.  

Trim boundaries are created automatically when: 

 creating fillet surfaces. 

 creating draft surfaces. 

 limiting surfaces using Limit Selection and Limit Point. 

A trim boundary consists of parameter curves (pcurves) and ultimately parameter 

points (ppoints) joined together to form a closed region of a surface. 
 
 

PowerSHAPE provides powerful tools to help you define and edit your trim region 

accurately.  

Parameter Curves (Pcurves) and Points (Ppoints) 
Parameter Curves (pcurves) are made up of linear spans that run between Parameter 

Points (ppoints). As moves between ppoints are linear, any curvature is controlled by 

the proximity of adjacent ppoints within the tolerance setting. 

Ppoints are defined as a proportional distance between surface points. A ppoint 
defined at 2.5 1.5 is half way between points 2 and 3 along the longitudinal (T) 

direction and halfway between points 1 and 2 along the lateral (U) direction. 

Individual pcurves and Trim boundaries are unique to a surface and can be accessed 

from the Surface Trim Region Editing toolbar, which can be opened by right-clicking 

on a surface for menu options or from the Surface Edits toolbar. 

 

The Previous Surface editing Toolbar is now replaced with two toolbars to edit the 
associated boundary or Pcurve on the selected surface. 
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Selecting Boundary mode  displays the following trim boundary options. 
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Selecting Pcurve mode  displays the Pcurve edit options. 

 

 

 

The following examples will help demonstrate the above.  
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Switch housing 
1 Open the model  

.....\PowerSHAPE_Data\switch_housing.psmodel 

 

 

2 Select the upper surface and then Blank Except. 

3 Select the surface to display the Surface Edits toolbar. 

 

By default, trimming ON  displays the surfaces in its trimmed state. To view 

a selected surface untrimmed, toggle this icon to Trimming OFF.  

 

4 Ensure Trimming is ON.  

5 Right-click on the surface and select Surface Trim Region Editing. The Trim Region 

Editing toolbar is now displayed. 

6 Select Boundary Edit Mode.   

The whole surface is displayed with the trimmed area identified by a mesh of 
grey detail lines. All boundaries are displayed, marking the edge of the trimmed, 

surface area. The pcurves are not displayed in this mode. 
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 If a boundary is deleted from a surface, the associated pcurves 

remain. 

7 Select Pcurve Edit Mode.  

The pcurves are displayed along with trimmed areas. The boundaries are not 

displayed in this mode. 

 

If a pcurve is deleted from a surface, any associated boundary is also 

deleted. 

8 Toggle back to Boundary Edit Mode,  then select the Boundary Selector.  
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When a boundary is highlighted in the form, it is displayed in orange on the 

surface. 

Several boundaries can be selected by holding down the Ctrl key while left-

clicking each boundary. Hold down the Up/Down keys to toggle the selection of a 

boundary. Boundaries can also be selected from within the graphics area. 

9 Select both boundaries by selecting them with the Ctrl key depressed. 

10 Select OK on the Boundaries form. 

11 Select Explode  to delete both boundaries. 

 

With the boundaries exploded, the trimming is removed to show the full original 

surface area. The pcurves remain intact, but are no longer in use as part of a 

boundary definition. 

 The pcurves still exist and can be displayed by toggling into Pcurve Edits. 
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12 Select Autocreate  regenerate the boundaries from the existing pcurves. 

 

One of the two boundaries has been regenerated. 

The second boundary did not appear due to the existence of a branch point 

along the network of pcurves that makes it impossible for PowerSHAPE to 

determine which route to take (similar to composite curve creation). 

Define the route 

The easiest way to create the required trim option is to manually define the route 

around the pcurve network as demonstrated in the following section. 

13 Select Recreate  to open the toolbar and display all unused pcurves on the 

surface. 

 

The Create Trim Boundary toolbar is displayed. Similar to Composite curve 

creator, this is used to trace along the pcurves to define a boundary.  

All of the pcurves are displayed on the surface and are available for selection. To 
form a boundary, the pcurve must form a closed route. The edges of a surface 

can also be used as part of the route of a boundary. 

14 Click on a pcurve along the require route and sequentially, click on the direction 

arrows to produce the required closed boundary. 
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15 Select Save  and then select Eject.  

16 Deselect the surface to see the trimmed surface more clearly. 

 

Removing excess pcurve data 

The next stage is a repeat of the above, but this time, excess pcurve data is 
removed, allowing Autocreate to make the trim boundaries automatically. 

 

1 Select the surface. 

2 Select all boundaries  then Explode.  

3 Select Pcurve Edit Mode.  

4 Select the long pcurve along the part not required for boundary definition. 

 

When a pcurve is selected, the ppoints are displayed. These can be labelled, 

selected, repositioned or and deleted, as required.  

5 Shift-Select the four extra ppoints circled above. 

6 Click Delete Point.  

7 Switch back to Boundary Edit Mode  then Autocreate.  
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Removing the unused ppoints enables future automatic trimming operations to 

immediately produce the desired results and not stray along a path defined by 

redundant pcurve data.  

8 Close the model without saving. 

Repair Incorrectly Trimmed Surfaces 
1 Open the model  

.....\PowerSHAPE_Data\locationlug.psmodel 

 

The model includes several incorrectly trimmed surfaces that require a combination of 

pcurve and boundary editing to correct the faults. 

The more complex the network of pcurves on a surface, the less likely it is to obtain 

a trimmed surface automatically. The following worked example shows the stages of 

pcurve and boundary editing required to produce the correctly trimmed model 

shown above right. 

 

2 Select the large curved base surface and Blank Except (Ctrl+K). 

3 Enter Trim Region Editing. 

4 Explode  the only existing boundary. 
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5 Switch to Pcurve Edit Mode.  

 

The surface contains two pcurves: one correctly defines the intersection with the 

vertical face of the location lug  ; the other, U-shaped pcurve defines the 

path of an old fillet prior to an amendment, and needs to be deleted. 

6 Select the U-shaped pcurve  and Delete a pcurve.  

7 Select Unblank (Ctrl+L). 

Creating a pcurve from a composite curve  

Pcurves can also be created from standard wireframe and composite curves. 

In this case, a composite curve will be created from the lower edge of the fillet. This 

new composite curve is then turned into a pcurve and projected onto the original 

curved surface to help trace a new boundary.  

8 Create a composite curve on the lower edge of the fillet surface as shown. 
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9 Blank all except the new composite curve and the curved surface. 

 

10 Select the curved surface and switch to Pcurve Edit Mode.  

11 Select Make pcurves from projecting wireframe.  

 

12 Select Projected then the composite curve. Select OK. 

 

13 Deselect the surface and delete the composite curve. 

14 Select the lower curved surface to display the pcurves on the surface. 

The linear pcurve needs to be extended to create a closed boundary. This will 

ultimately be traced as a D section. 

15 Select the straight pcurve then Extend pcurve.   
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16 In the Extend at list, select Both ends. In the Method list, select Tangentially to a 

pcurve. 

17 Select the other curved pcurve then OK. 

 

 The straight pcurve has extended to effectively create a closed boundary. 

Manually create a new boundary 

1 Switch back to Boundary Edit Mode  then Recreate.  

2 Trace the pcurves to define the new boundary as shown below. 
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 If the trimmed surface appears within the D-shape, select Reverse the 

Boundary  to create the result shown.  

 

3 Select Unblank (Ctrl+L). 

 

The new boundary has removed the overlap between the fillet and curved 

surface which previously existed. 

4 Blank all surfaces except the front vertical and fillet surfaces. 

Trimming the planar surface 

The planar surface needs to be correctly trimmed with the fillet. 

 

1 Explode  all boundaries on the vertical surface. 
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The vertical surface is untrimmed to its original size and will be limited to the 

fillet surface. 

2 Use limit select  to trim the surfaces and leave the solution below. 

 

The vertical surface to its full size was not available as a solution due to the 

complexity of the pcurve network in the surface. However a new boundary will 

be traced to include this. 

3 Select and Blank Except (Ctrl+K) the vertical surface. 

4 Explode  all boundaries on the vertical surface 

5 Switch to Pcurve Edit Mode to display all existing pcurves. 
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If required, a new boundary can simply be recreated  to include the vertical 

surface.  

However in this case the pcurves circled in red will be edited to leave a single 

closed path. With this, Autocreate  can then be used effectively. 

6 Select and delete  the horizontal pcurve.    

7 Zoom into region  select the vertical pcurve. 

8 Select Turn point labels on/off  to display the ppoint numbers. 

9 Shift select or use ppoint selector to select points 25 to 29 inclusive. 

 

10 Delete the ppoints  

 

Point 24 was not deleted. This will be moved up to the start of the fillet arc. 
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11 Select ppoint 24 and select Edit parametric value at ppoint.  

 

12 Click the point situated before ppoint 24 (shown as keypoint above) and note 
the updating of the values in the Edit ppoint position form (zoom in as close as 

possible). 

13 Select OK.  

 

 

The position of ppoint 24 updates to the new parametric values. The ppoint is 

now repositioned to join the start of the fillet arc. 

14 Repeat the above for the opposite side.  

15 Zoom into the bottom left corner region.   

16 Delete  just point 29 on the fillet pcurve. 
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The pcurve is trimmed back to point 28 which is also the intersection point with 

the adjoining pcurve. 

17 Repeat the above for the opposite side.     

18 Zoom into the top left corner region.   

19 Delete  just point 1 on the vertical pcurve. 

 

20 Repeat the above for the opposite side.   

 

A single pcurve path remains. 

 

21 Switch back to Boundary Edit Mode  then Autocreate.  

 

A single clean surface is generated. 



9 Surface Editing PowerSHAPE Pro 2015 

9.36  Copyright © Delcam 

22 Select Unblank (Ctrl+L). 

 

A final problem remains indicated by the arrow above. The vertical D section 

surface requires trimming back to the top edge of the fillet surface. An overlap 

can be clearly seen in transparent view. 

Trimming the vertical D-section 

It is possible in this instance that the trimming can be simply applied using Limit 

selection.   

 

23 Trace a composite curve along the top edge of the fillet surface. 

24 Using this curve as the cutting object, limit  the surface to leave the 

required result. 

 

25 Save the model as.....\PowerSHAPE-Models\Location Lug repaired.psmodel 
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Exercise 9: Region trim camera 
 

1 Open the model  

.....\PowerSHAPE_Data\camera repair.psmodel 

 

 

2 Use Trim Region editing ONLY * to repair the three areas highlighted on the 

surface model. 

 

 

1 Save the model as 

.....\PowerSHAPE-Models\Ex9 region trim camera.psmodel. 

2 Close the model. 

 

*Try not to use Limit Selection  or Smart Surfacer!!    
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Introduction – Method 1 
The following exercise will resurface the mesh of a handle using the 

alternative techniques using curve and surface creation rather than the newer, 

simpler Automatic and Manual mesh segment tools, which may not always 

produce desired results on vague or coarse mesh. Knowledge of these methods is 

still of great importance to enable you to successfully reverse engineer a mesh. 

This exercise will cover: 

 Creating curves from a mesh. 

 Creating surfaces from curves – from Revolution, from Separate and Drive 

Curve using the Smart Surfacer. 

 Complete the model by converting the surfaces into solids and create solid 

fillets. 

Resurfacing the Handle Mesh 
1 Select File>Import… 

2 Browse to: C:\Training Data\PowerSHAPE Pro Data and import the file 

handle.stl. 

3 Select a View from Top (Ctrl+5). 

 

10. Basic Resurfacing 
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We will now create a workplane at the centre of the hole so we can correctly 

create a curve and use the workplane to revolve around the axis. 

4 Select the mesh by clicking on it in the graphics area which will highlight the 

edges yellow and activate the Mesh Edit toolbar. 

5 Select the Paint Triangles  option from the Mesh Edit toolbar and from 

the drop down menu in the dialog select a green colour. 

 This option will apply a chosen colour to any selected triangles on the 

mesh which can be used to highlight specific areas of the mesh and 

also can be used as an alternative to divide the mesh into multiple 

mesh. 

6 Select the Select triangle area to discontinuity area  option from the 

Mesh Edit toolbar. 

7 Select the bottom of the mesh with the discontinuity angle set as 20 

degrees as default as seen below which will apply the green to the bottom 

face of the mesh.  

 The discontinuity angle in this instance will act as the threshold value 

when selecting adjoining triangles. In this case we can see that the 

bottom face is flat therefore a very small angle here would suffice, while a 

much higher angle will begin to select the adjoining chamfered edge if 

the discontinuity angle is set higher than the chamfer angle.   

 

8 Select OK on the Paint Triangles dialog. 

9 Select the Divide mesh into multiple meshes by colour  option. 

 The mesh has now been split into two separate meshes using the 

different colours applied to divide, this can be used as an alternative 

way than splitting by selection, and is particularly efficient when 

splitting into more than two mesh. 
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The next step will be creating a cat the centre of the green mesh. It was 

important to divide the mesh into two, to enable us to only select the new 

separate mesh. 

10 Select and Blank (Ctrl+J) the main handle mesh leaving only the green bottom 

face mesh. 

11 With the visible mesh selected in the graphics area. Create a single 

workplane at the centre of selection  from the Workplane  menu. 

 

12 Unblank (Ctrl+L) the other mesh. 

13 Select View From Top . 

Next, we will combine the two mesh into one complete mesh. 

14 From the selection flyout menu choose Quick select ALL mesh. 

 

15 Select Object>Mesh>Combine. 

We will now create an Oblique Curve through the mesh at the workplane using 

the YZ plane. 

16 Select X as the Principal Axis. 

17 Select Create an Oblique Curve  from the Curve  menu. 

18 Within the dialog choose a Distance of 0 (which will be from the principal 

plane ‘YZ’) and ensure that Create as composite curve is ticked. 
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19 Select Apply to create the curve, and then cancel. 

 This has create a section curve through the mesh at the point where it 

intersects the chosen section, in this case the YZ plane of the active 

workplane. 

20 Select and Blank (Ctrl+J) the mesh and Rotate the view to see the curves. 

 As you can see there are currently two curves where the mesh intersected 

the plane. To create a surface of revolution only one will be necessary. 

21 Select and delete one of the section curves, as they are both indentical for 

our requirements it is not important which curve is kept. 
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22 Right click on the curve and from the menu options, select Delete 

Dependencies. 

 Dependencies are relationships between geometrical objects, 

therefore this option will remove any of these relationships taken from 

the mesh. 

23 Select Y as the Principal Axis. 

24 With the curve selected, create a Surface of Revolution  from the 

Surface  menu. 
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25 Unblank the Mesh (Ctrl+L). 

26 Select the Surface in the graphics area. 

27 Using the middle mouse button place the surface on Level 1 – Surfaces and 

then Turn OFF the level. 

28 Select View From Top . 

The next step we will take is to create the curves to form the shaft of the handle. 

29 In the Model Analysis  menu select Dynamic Sectioning . 

 

 The Dynamic Section tool is also accessible through  

View>Dynamic Sectioning. 

 Dynamic Sectioning is a tool that enables the user to interactively 

view sections through an object in the graphics area. It can be done 

relative to the current View, or through or around the X, Y or Z axes. 

It also allows the user to create curves of the sections in the object. 

30 In the dynamic section dialog choose to take a section through the X Axis. 

31 Either using the Front slider or the adjacent text box enter a value of 20. 

 As you can see this sections the part down the X Axis at a location of 

20mm. 

Aswell as viewing the section PowerSHAPE Pro also has the ability to create curves 

of the sections using the create wireframe button highlighted in the image below. 

32 Select the create wireframe of selected item on the front plane  button 

in the dialog to create a section curve. 
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33 Repeat this method and create section curve at 30, 40, 50 and 60 in the X 

Axis on the Front plane. 

34 Blank (Ctrl+J) the mesh. 

35 With ALL the curves selected, right click on the curves and select delete 

dependencies. 

 

36 Box select the 5 curves and open the Smart Surfacer  from the Surface 

menu. 

37 In the dialog select that surface creation method as From Separate. 
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As you can see the smart surface tool has created a conical surface from the 

section curves. However, as the structure of the curve points varies greatly 

between each curve, this has created a ‘rippled’ surface and uneven structure 

to the surface. To combat this we need to repoint the curves so that there is the 

same number of points on each, evenly spread apart. 

38 Select the Advanced button in the dialog to open the advanced options for a 

From Separate surface. 

 

39 In the Edge Matching drop down menu choose repoint, then select Preview 

to see the effect of the changes. 

 In the graphics area hover the mouse over the surface and notice how 

the structure has changed to a much more even spread of 

longitudinal curves running the length of the surface. 

40 Select Apply to both the advanced options and smart surfacer to create the 

surface. 

41 Unblank the mesh (Ctrl+L). 

As you can see the surface has been created using the section curves derived 

from the mesh and has now produced a satisfactory result. However the current 

surface does not fully extend the length required to complete the model. Next, we 

will use the point limit function to achieve this. 

42 Select a View from Top (Ctrl+5). 

43 With the surface selected and the mesh still visible, from the General Edits 

menu select Point Limit.  

44 Click and drag the right hand end curve of the surface to extend it inside 

the spherical end of the handle as shown in the image below. 

 In this example we have extended the surface slightly further than 

necessary to ensure we can further trim it back at a later stage. The blue 

preview curve shows where the surface will extend to. 
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45 Repeat the above process for the other end of the cylindrical surface. In this 

case it is also important to ensure that the surface does not extend too far 

through to the hole through the part. 

 If you know exactly the distance required it is also possible to insert the 

value (in mm) into the dialog. 

 

46 Select the surface and place it on Level 1 – Surfaces using the middle 

mouse button. 

47 Open the Dynamic Sectioning  tool from the Model Analysis menu. 
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48 Choose to take a section down the Z Axis and use the slider/text box to set a 

value of 0 on the Front face with the create wireframe button.  

49 Blank the Mesh (Ctrl+J). 

 

50 Select and Delete the left hand side curve that we do not require for the next 

operation marked by the red box in the image above. 

51 Zoom into the circular area of the curve representing the end of the handle. 

52 Create a Single Line  connecting the two Keypoints defined by the 

edge the the radiused corner meets the handle shaft. 

 

53 From the midpoint of this new line, create a further single line running 

perpendicular until it intersects the arc. 
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54 Select the section curve and then open the Cut Object  function from 

the General Edits menu. 

 

55 Using the Intelligent Cursor snap to and cut the section curve in the two 

locations specified in the above image. 

56 At the point where the two straight lines intersects place a single 

workplane  and realign it to the lines. We will use this workplane to 

create a surface of revolution.  
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57 Set X as the Principal Axis. 

58 Select the Arc shaped curve above the new workplane. From the Surface 

 menu select Create a Surface of Revolution.  

 

59 Select the Surface of Revolution and place it onto Level 1 – Surfaces. 

60 From the Selection flyout menu choose Quick Select ALL Wireframes.  

61 Place all the wireframe onto Level 2 – Wireframes. 

62 From the Workplane selector drop down menu activate workplane 1. 

 

63 Turn ON Level 1 – Surfaces to show all of the surfaces we have recreated 

over the mesh. 

 Note that the mesh is still blanked from view at this point. 

64 Turn OFF Level 0 – General. 

 This will allow us to work solely with the created surfaces. 

65 Switch to Transparent View.  

 This will give the ability to select objects that are inside or hidden by 

others. 

66 From General Edits select Limit Selection.  

67 Select the Surface of Revolution as the Cutting Object and then cut the end 

of main shaft of the handle that is inside. 

 The Next Solution option is always available within the dialog if your 

selection is incorrect which will cycles through all possible solutions. 
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68 Activate Workplane 2. 

69 Select the cylindrical shaft surface and then Blank Except (Ctrl+K). 

70 Set X as the Principal Axis. 

71 Open the Limit Selection  dialog from the General Edits menu. 

72 Using the workplane (and appropriate principal axis) as the cutting object 

trim back the other end of this surface. 

 

73 Unblank ALL the Surfaces. 

74 From the Selection Flyout menu Quick Select ALL Surfaces.  

75 Select Create Solid from Surfaces  in the Solid Creation  menu. 
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Next we will create a 0.5mm fillet around the join shown above. 

76 From the Feature  menu select Solid Fillet.  

77 Input a Radius of 0.5mm and select the edge in the graphics area, then 

select Apply. 
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We have now completed the resurfacing of the model. 

78 Save the model as ResurfaceHandle.psmodel. 
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Introduction – Method 2 
The following exercise will resurface the mesh of a handle using the new 

Automatic and Manual mesh segment tools available in PowerSHAPE Pro. This 

exercise will cover: 

 Creating Surfaces using the Automatic Mesh Segment tool. 

 Creating Surfaces using the Manual Mesh Segment tool. 

 Creating Solids from Untrimmed Surfaces. 

Resurfacing the Handle using the Mesh Segment tools 
1 Select File>Import… 

2 Browse to: C:\Training Data\PowerSHAPE Pro Data and import the file 

handle.stl. 

3 Select a View from Top (Ctrl+5). 

 

The Mesh Segment tools can be used Automatic (where possible) or Manually to 

create surfaces ond/or solids different areas of the mesh to later be combined to 

recreate a model from the mesh. There are a variety of options relating to these 

tools which will allow us to further understand how we can successfully utilise this 

functionaility.  

4 Browse to Tools>Options>Object>Mesh. 
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The options in this menu relate to the Mesh Segmentation tools and are defined as 

follows: 

 Item type to fit: Select Surfaces or Solids to be the default item type to fit 

to the mesh when segmenting, this can be changed also within the tool dialogs. 

 Trim surfaces: Select this option to toggle between creating trimmed or 

untrimmed surfaces when segmenting. 

 Alignment angle: Enter a value to define the tolerance for aligning 

primitives with a principal plane. If an axis of a primitive is within the 

tolerance of a principal plane the axis is snapped to the principal plane. 

 Extension distance: Enter a value to define the distance by which a primitive 

is extended beyond the edge of its region. 

For this example we will leave the default options the same. 

5 Select the Mesh to activate the Mesh Edit toolbar. 

Automatically Segment Mesh and Fit Primitives 
The Automatically and Manually Segment Mesh options are located on the 

Mesh Edit toolbar organised into a flyout menu, shown below. 

 

As you would expect it is obviously worth using the Automatic Mesh Segment tool 

for all available and relevant surfaces before using the manual tool. However, 

as you will see on some mesh this may not find all objects you require to recreate 

the model, although a finer mesh may help. 

6 Select Refine Mesh  from the Mesh Edit toolbar. 

7 Using the option Split Each Edge, select Apply Twice. 

8 Click Cancel to Close the dialog. 

 This has simply split each edge of every triangle to quickly and easily 

produce a finer mesh to aid the use of the Automatic Segment tool in 

this case, obviously this is a compromise between working with a larger 

number of triangles and should be avoided on already large mesh. 

 Feel free to undo the refine mesh operations and then have a look at the 

primitive surfaces that are found with far less triangles. In this case it is 

because there are a small number of triangles in the mesh compared 

with the size of the mesh. 

9 Select the Automatically Segment Mesh  button to automatically search 

for primitives and open the Segment Mesh dialog. 
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As you can see now the Automatic Segmenter find and previews a large number 

of different primitives all over the mesh. While the dialog allows you to define a 

threshold similarity angle, of which a large value will suit more coarse mesh 

with stronger discontinuities and a smaller angle will generally reduce the 

unsuitable surfaces found on finer mesh. 

Within this dialog you can also choose which primitives you would like to look for 

at any instantaneous moment which can make this process simpler when there 

are a large amount of different primitives found by reducing the view. 

It is good practice to take a logical step by step approach to efficiently work 

through the Automatic Segment tool, therefore we will work through each 

primitive type individually. 

10 In the Segment Mesh dialog select Planes from Primitive Types, and then 

select Preview. 

 

 With a similarity angle of 1 PowerSHAPE Pro has found two planar 

surfaces, only one is relevant in this case. 
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11 Select the Plane marked in the above image and then select Apply. 

 With the surface selected, right-clicking on the surface will perform 

the same function as Apply. 

 Once applied, the area that have already been covered will be 

highlighted in white and will stop you from creating duplicate 

surfaces. 

12 Next, select Cylinder in the Primitive Types area. 

13 Select and Apply the Cylinder found on the mesh in the graphics area. 

 There are other cylinders that currently have not been recognised in 

the model. 

14 Increase the similarity angle to 4 using the slider, then select Preview. 

15 Select and Apply the two remaining cylinders on the mesh. 

 

16 Slide the Similarity Angle back to a value of 1. 

17 Select Cones from the primitive types. 
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18 Create the two correct Cones found by the Automatic Segment tool on the 

mesh. 

 The other cone has been found due to the fillets and chamfers around 

the model, there is no great need to create these now as we can simply 

create these as solid features later while also gaining a feature history 

in the process. 

19 Select to find Spheres in the primitive types, then Apply and Create the 

sphere at the end of the handle. 

Looking around the model the Automatically Segment Mesh tool has found 

nearly all the required surfaces. In this case there are only two planar surfaces 

(aswell as associated chamfers and fillets) that haven’t been found on the model. 

We will no use the Manually Segment Mesh tool to attempt to complete the 

surface creation for this model. 

Manually Segment Mesh and Fit Primitives 

The Manually Segment Mesh  tool is available directly from the flyout 

menu on the Mesh Edit toolbar described previously, and is also available directly 

from within the Automatic Segment dialog. 

20 Select the Manually Segment mesh option inside the dialog which will open its 

dialog below. 

 

This will also open the Set Triangle Area to Local Horizon menu to allow to select 

individual (multiple) triangles in the mesh. This dialog allows you to manually 

seek primitive object on the mesh using the drop down menu provided. 

 

 A discontinuity angle slider allows the user to change the threshold 

value which will increase the selection of triangles in a selection for a 

larger value by increasing the allowable discontinuity between 

triangles. In this case we are only selecting planar surfaces so we 

require a low value to avoid selecting further than required. 

21 Using the default values select the bottom face of the handle shown on the 

next image. 

Hoevering your mouse over the preview will show you the fit (in mm) between 

the preview surface and the selected area of the mesh. 
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22 Once you are happy with the preview select the green tick in the dialog to 

create the surface. Again, as with the automatic segment tool, the manual 

tool will create and immediately blank the surfaces until you are done inside 

the dialog while highlight the area already covered in white. 

23 Rotate the view and create the final planar surface on the top of the model 

using the same process. 

24 This has completed the process of creating the primitive surface required to 

create the model. Select the Red Cross to close the manual segmenter, and 

then cancel to close the automatically segment mesh dialog. 

25 Select and Blank (Ctrl+J) the Mesh. 

 

Above is an image of the surfaces that have been created using the Automatically 

Segment Mesh tool complimented later by the Manually Segment Mesh tool. We 

can see that it forms a complete inner shape while the extension distance has 

ensured that the untrimmed surfaces has extended far enough to create a complete 

inner close shape. 
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It is often important to pay close attention where possible to the orientation of 

the surface before we try and create a solid model from these surfaces, and 

ensure that they correctly overlap without forming any gaps in the model. We 

are ideally looking to see the blue ‘positive’ side of the surfaces as what we would 

consider as the outside of the solid. 

26 Quick Select ALL Surfaces.  

27 From the Solid  menu select Create Solid from Untrimmed Surfaces. 

 

28 This Automatic Trimming tool will attempt to create the most relevant solid 

from the selection of untrimmed surfaces. 

 

If the solid is not quite what you were expecting the slider will keep more of the 

surfaces or further delete more surfaces. Alternatively, it is possible to move 

the slider further towards ‘Keep’ and then manually delete as required. 

29 Press OK to create the Solid. 

30 Select the Solid in the graphics area to activate the Solid Edit toolbar. 

31 Ensure the new solid is the active solid  and then open the Solid History 

Tree.  

 Currently there will be no solid history but as we create further 

features this will build up as fully editable history within this window. 

32 Unblank the Mesh (Ctrl+K). 

33 From the Levels toolbar create a new Level 10 – Mesh. 

34 Place the Mesh on Level 10. 

35 From the Levels toolbar create a new Level 20 – Solid. 

36 Place the Solid on Level 20. 
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 The surfaces created earlier are already backed up on Level 800 as a 

result of the operation so they are accessible in the future if required. 

37 Turn ON Level 20 – Solid. 

38 Choose to create a 1mm Solid Chamfer  within the Solid Feature  

menu on the bottom face of the solid, as shown in the image. 

 

39 Select Apply to create the Chamfer then Cancel to close the form. 

40 From the Feature menu select Create a Solid Fillet.  

41 Create a 1mm Solid Fillet on the face below the previous chamfer as seen in 

the image below. 

42 Press Apply but do not close the fillet dialog. 

43 Create 0.5mm radius fillets at each end of the shaft of the handle. 

44 Again, Apply without closing the dialog. 

45 Finally, create a 1mm radius fillet on the top planar face of the handle. 

We have now completed the model using the Automatic and Manually 

Segment Mesh tools. Now you have the knowledge to recreate solid and surface 

models from mesh using a number of different methods. 
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The Mesh Edit Toolbar 
The Mesh Edit Toolbar will be activated above the grahpics area with a mesh 

selected in the session and its features are shown and described below. The toolbar 

is organised into groups of functionality and then sub groups using the flyout 

menus seen below. Throughout the course we will be using this toolbar heavily, 

some basic functions will be explained next.  

 

 Pick triangles on a mesh by box 

 Pick trianglles on a mesh using a continuous lasso 

 Pick triangles on a mesh using a discrete lasso 

 Select all triangles on top 

 Select visible triangles on top 

 Select all triangles 

 Select triangle area by colour 

 Select triangle area to discontinuity angle 

 Select triangle area to local horizon 

 Select triangle area to distance 

 Thicken mesh 

 Reduce mesh 

 Refine mesh 

 Smooth mesh 

 Paint triangles on a mesh 
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 Morph trianglles general 

 Morph triangle regions defined by planes 

 Morph triangle regions defined by curves 

 Automatically segment mesh and fit primitives 

 Manually segment mesh and fit surfaces or solids 

 Shrink-wrap a surface on to the select mesh 

 Divide the mesh into multiple mesh 

 Divide the mesh into multiple mesh by colour 

 Divide the mesh into multiple by selection 

 Reverse the mesh 

 Open the mesh doctor 

 Fix bad connections 

 Fix bad boundaries 

 Fix triangles with bad aspect ratio 

 Fix small triangles 

 Fix intersecting triangles 

 Show fixing status of the mesh  

 Fill holes in the mesh 

 Stitch mesh 
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 Resolve overlapping triangles 

 Apply Z-compensation to triangles 

 Mesk selected triangles on a mesh 

 Unmask select triangles on a mesh, allowing them to be used 

 Unmask all triangles on a mesh, allowing them to be used 

 Add a single triangle 

 Delete selected triangles 

 

In the following example we will look at the various mesh shading options 

available in PowerSHAPE Pro while reducing and refining a complete mesh to 

help improve the smoothness of the mesh, and also selecting triangles within a 

mesh using the Mesh Edit toolbar. 

1 Open the model Mask.psmodel from the PowerSHAPE Pro Data folder. 

2 If prompted, select close on the File Doctor. 

3 Select an Isometric View (Ctrl+1). 

4 Select the Mesh by clicking on it in the graphics area. 

 Note that selecting the mesh should show and/or activate the Mesh 

Edit toolbar above the graphics area. 

 



11 Mesh Edit Toolbar  PowerSHAPE Pro 2015 

Copyright @ Delcam  11.4 

 

 

 

Similar to a surface model, within PowerSHAPE Pro mesh have a 

negative/reverse side coloured in red by default. While the positive/normal 

side is set to shade as a predefined colour. The mesh is currently set to Shade 

Open Edges only which means that only the ‘open edges’ of each triangle (without 

adjoining triangles) are shaded and outlined. This triangle shading can be changed 

using the Mesh Shading flyout on the Views toolbar. These options will be 

discussed below: 

 

 Open edges only, shaded 

 Open and interior edges, shaded 

 Nodes and open edges, shaded 

 Open and interior dgse, hollow 

 Nodes and open edges, hollow 

5 Select the shading option to shade and outline Open and Interior edges 

 from the Mesh Shading flyout on the Views toolbar. 

 This option will outline ALL triangles in the mesh to give a clearer view 

of the scale and coarseness of the mesh visually and show the density of 

the triangles over the mesh. 
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6 Zoom closer into the Mesh to see the detail. 

 

 

 

 

 

 

 

Reduce and Refine Mesh 

7 From the Mesh Edit toolbar select Reduce Mesh  to raise the dialog to 

reduce the number of triangles in the mesh. 
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It is possible to reduce the number of triangles in a mesh firstly To Percentage or 

To Number of Triangles where entering either value will change the other 

accordingly. 

8 Select to reduce the number of triangles in a mesh by percentage to 50%, 

then click Apply. 

 Take note of the change in the number of triangles at the top of the dialog 

and the visual difference of the interior shading of the mesh. 

Alternatively to reduce the mesh By Tolerance by entering a defined tolerance to be 

used while reducing the mesh, aswell as this you can also limit the triangle edge 

length to specifiy the maximum edge length of the triangles to be used during the 

reduce operation.  

9 Select Cancel on the dialog and Undo  the last operation.  

10 Again, select Reduce Mesh to reopen the dialog. 

11 Select to Reduce Mesh to Tolerance of 0.01 and select Apply. 

 This has reduced the number of triangles in the mesh from 

approximately 159k to 90k keeping within a tolerance of 0.01. 

12 Select Cancel on the dialog and Undo  the last operation.  

13 Select the Refine Mesh  option from the Mesh Edit toolbar. 
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The Refine Mesh option can be used to increase the density of the triangles in the 

mesh by dividing the existing triangles and refining the triangles by curving the 

original triangles to create a smoother mesh. 

14 Ensure the Split Each Edge option is selected in the dialog, then select Apply. 
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 The Split each edge option subdivides each triangle into four new 

triangles by inserting new vertices at the midpoint of each edge. 

15 Select the Undo button located within the Refine Mesh dialog. 

16 Change the Refine Method to split edges greater than and enter a threshold 

value of 0.5, then select Apply. 

 

 The Split edges greater than option subdivides the triangles by 

inserting a new vertex at the midpoint of an edge when the length of 

the edge is greater than the specified threshold value leaving a very 

fine mesh. 

17 Select the Undo button located within the Refine Mesh dialog. 

18 Finally change the Refine Method to Split by Aspect Ratio and enter a 

threshold value of 0.1, then select Apply. 

 The Split by aspect ratio option subdivides triangles with an aspect ratio of 

less than the specified value. The aspect ratio is the ratio of the height of 

the triangle divided by the length of the edge. 

Next, we will look at the dividing the mesh into multiple mesh. For this we have 3 

options as seen earlier in this chapter, and repeated below. 

 Divide the mesh into multiple mesh: This option will divide largely 

unconnected regions of mesh into multiple mesh. 

 Divide the mesh into multiple mesh by colour: This option will divide a 

mesh into different mesh by colour, where colour can be added to selected 

triangles using the Paint Triangles  function. 

 Divide the mesh into multiple by selection: This option will divide a mesh 

into multiple mesh by selecting triangles in the mesh. 
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19 Select a View from Top (Ctrl+5). 

20 From the Mesh Edit toolbar select Pick Triangles by Discrete Lasso  

21 Using a number of clicks, select an area of the mesh. 

 

22 Close the bounding box formed by the lasso by clicking onto the first point. 

 This will then create the selection, and the selected triangles of the 

mesh will become highlighted blue. 

 

23 Divide the Mesh by choosing the option to Divide Mesh by Selection  

from the Mesh Edit toolbar. 
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As we know the dark outlines represent the open edges of the mesh which shows 

that these are now two separate mesh. We will now select and blank the larger main 

mesh. 

24 In the graphics area select the larger outer part of the mesh and select Blank 

(Ctrl+J). 

 

As we have successfully divided a single mesh into separate mesh means it is 

now possible to perform the mesh edits on small areas of mesh by highlighting 

a specific area and using the specialist select and divide mesh tools. 

25 Unblank (Ctrl+L) the other mesh. 

 

Next, we will stitch both mesh back together to again form a single mesh. 

26 In the graphics area select both mesh, or use the Quick Select ALL Mesh 

option from the quick select flyout menu. 

27 From the Mesh Edit toolbar select Stitch Mesh  which will raise the Stitch 

Mesh dialog. 
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 As these two mesh were originally one complete mesh, we know that 

there is a perfect fit between them and therefore we can use the default 

values successfully. 

28 Ensure that the option to Combine Selected Meshes at the bottom of the 

window is selected and then click OK to stitch and combine the two mesh 

together. 

 This option to Combine Selected Mesh will not only stitch any slight 

gaps in the mesh, it will then combine all the selected mesh into one 

complete mesh. 
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The Reverse Mesh option enables the “positive” side of the mesh to be quickly and 

easily be reversed, for instance to change a ‘Male’ cast to a ‘Female’ mold. 

29 Select an Isometric View (Ctrl+1). 

 

30 From the Mesh Edit toolbar select Reverse Mesh  to reverse all of the 

triangles of the mesh. 
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Introduction 
In this tutorial we will look at the many tools available within PowerSHAPE Pro 

2015 introduced previously for the purpose of, and to aid with the Reverse 

Engineering process of a part from the steering support assembly used in the 

Bloodhound SSC. 

 

 

 

 

 

 

 

 

 

 

12. Reverse Engineering 
Bloodhound Steering Support 
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1 Open the Bloodhound_steering_column.psmodel from the PowerSHAPE 

Pro Data folder. 

2 Create a Single Workplane  at 0 by typing 0 in the command box and 

then press the Enter key. 

 This allows us to visualise where the origin of the World Coordinate 

System is located in comparison to the mesh. This is important as our 

first step will be to try and realign the mesh with this coordinate 

system. 

 

You should hopefully see that the mesh needs to change location and 

orientation to realign with the coordinate system. If in any future session your 

mesh and workplane are far apart you can select and drag the mesh closer, 

and this will help you to align the part quicker and easier. 
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Reverse Engineering Notes 
At this point it is useful to look at the mesh, the physical part and any other 

information as a whole and make notes and plan the process to take while 

Reverse Engineering the part. 
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Aligning the Mesh 
To aid the Reverse Engineering process and make the best use of the mesh tools 

available within PowerSHAPE Pro 2015 the mesh should be aligned to a 

workplane X, Y and Z axes, in most cases the most relevant will be the World 

workplane.  

Correctly aligning the mesh is of importance to the entire Reverse Engineering 

process and ideally we should you the largest area and most simple shape to 

give the best and easiest results. In doing this the Mesh Segmentation tools will 

then have the ability to automatically adjust primitive shapes to the planes of the 

active workplane.  

Although this isn’t always possible it is best to align using the largest and most 

basic shape on the mesh. This will help to reduce and average any slight errors 

in the alignment over the whole model, preparing for the Best-fit alignment. 

3 From the Mesh Shading options on the View/Shading menu on the right 

hand side toolbar of the graphics area select the option to show Open and 

Interior edges, shaded triangles.  

 This will show the edges of the inner triangles allowing better clarity 

when selecting areas inside the mesh.  

Rotating the view and looking at the part from above shows a clear pattern of 4 

Holes which make a rectangular shape which we could use to align to a Surface 

Plane. Although we cannot use the actual holes, having to select points on the 

mesh, we could use locations close, or next to these features. 

In this example I am going to use memorable locations to the inside edge of the 

holes as shown in the image below. Showing the interior edges will help this 

greatly as we have to select each location multiple times. 

 

4 Ensure the Principal Axis is set to Z. 

5 From the Surface  menu select Surface Plane.  

6 Centre the Surface on the active workplane origin by typing 0 in the 

command box and then press the Enter key. 

7 Double-click on the surface to raise the surface edit dialog. 

8 Rotate and Zoom the View to look down on the top face of the part in the 

graphics area. 
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As before, to resize the surface using the measuring tool directly we can right-

click inside the text box adjacent to the width or height in the dialog. This will 

then open the calculator and allow measurement of the correct length and 

automatically fill the respective box. 

9 Right-click in the text box adjacent to the Width. 

 This will raise the Measure tool dialog and allow you to quickly measure 

objects inside the graphics area. 

10 Measure the Width (X) by clicking on the position shown on the previous 

image and its counterpart at the other end of the part to the inside of the 

hole, shown below. 

 

 Try to remember which corner triangles you selected as clicking these 

exactly again during the alignment phase will produce the best result.  

11 Click OK in the Calculator to use the measured value as the Width.  

12 Repeat the same process for the Length of the same face to fully resize the 

planar surface to fit. 

 

 If you’re values are slightly different to the values in the image above 

do not worry. Again, the best alignment will rely on selecting the 

same positions as you did to resize the surface when aligning.  

13 Select Align Items  from the General Edits  menu. 

 

 If the alignment and fixed objects are far apart in the graphics area 

this may cause problems while navigating the view. It is possible to 

simply drag move the alignment object, in this case the mesh closer 

to the surface.  

14 In the graphics area select the mesh as the Alignment Item, then select the 

surface plane as the Fixed Item. 
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Next, we have to select a number of points on the alignment object, and then 

repeat the same selection on the reference object. Note that the order and 

amount of the points selected must be the same for each object. For a rectangle a 

good selection order is “clockwise around width first then the length” this way 

you know that the selection will always be the same. 

15 Select the 3 points around the face of the Alignment Object, one near each 

hole as you selected to measure the surface earlier, and then repeat the 

selection on the Reference Object, the surface. 

 Note: The order and direction of your selected points must be the 

same for each object. 

 

16 When your selection is complete and correct all the 3 red crosses will 

become green ticks and the dialog will tell you that you are ready to perform 

the alignment operation. 

17 Select Apply and Cancel to close the dialog and view the results. 

18 Select an Isometric View (Ctrl+1). 
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The mesh has been aligned with the surface plane and due to its location, the 

world coordinate system. Further to this we can fine tune our alignment using 

the best fit alignment  tool from the same menu. 

19 From the General Edits  menu, select Best Fit Items.  

20 Again, select the mesh as the item to align and the surface as the fixed 

item. 

21 Edit the desired fit to 0.01mm and then select Apply. 

 

22 Press Cancel to close the dialog. 

 Using the View from…. toolbar to the right of the graphics area or using 

the keyboard shortcuts will allow you to visually inspect the 

alignment. 

23 Create a New Level on Level 997 called “Alignment Surface”. 
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 Here we have used such a high number as this is data we need to keep 

but are unlikely to need again unless we have an issue. Therefore it 

will always be at the end of the levels toolbar. 

24 In the graphics area select the surface we used to align the mesh, and place 

it on level 997 using the middle mouse button. 

25 Ensure Level 997 is switched OFF. 

Cleaning up the Mesh Data 
Next we will remove any disconnected areas of the mesh in an effort to begin to 

clean up the mesh and remove unwanted data to use the graphics most 

efficiently. This will also involved removing the areas of data were the 

workbench/fixture underneath has been captured also. 

 Note: A small portion of the scanned workbench/fixture will be 

useful to provide us with an overall depth of the part. 

26 Select the mesh to activate the Mesh Edit toolbar. 

27 Choose to Divide the Mesh into Multiple Meshes.  

28 Select and Blank (Ctrl+J) the main mesh. 

 You may have noticed the mesh has been split into 3 separate mesh by 

any disconnected outlying regions. By blanking the main mesh we 

can remove the extra disconnected regions easily. 

29 Quick Select ALL Mesh  from the Selection  flyout menu. 

30 Delete  the selected objects. 

31 Unblank (Ctrrl+L) the mesh. 

32 Take a View from Top (Ctrl+5). 

 We are going to select and divide a small area of the data captured 

of the workbench to allow us to to create a bottom face for the part. 

33 From the Mesh Edit toolbar select Pick Area of Triangles by Box.  

34 Drag select an area of triangles from consistent region of triangles 

representing the workbench. 

 These selected triangles will become highlighted blue inside the 

graphics area. 
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35 Divide the Mesh by Selection  located on the Mesh Edit toolbar. 

 This will divide the mesh into the main mesh and a small area 

consisting of the triangles selected 

36 Create a New Group of Levels called Mesh to help us to further organise our 

data. 

 Level 10 – Mesh : Mesh Part 

 Level 11 – Mesh : Base Mesh 
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37 Select the main mesh and place it on Level 10, then ensure the level is 

turned ON. 

38 Select the small mesh square and place it on Level 11, then ensure the level 

is turned OFF. 

39 Select to draw Open Edges Only  from the mesh shading options to 

the right of the graphics area. 

40 Take a View from Front (Ctrl+2). 

41 Zoom into the left of the part, as shown below. 

 

Removing any unwanted data in the mesh will reduce the overall mesh size 

and complexity and speed up the software graphics. We will do this using limit 

selection from a new workplane, and as we already have isolated a small 

section to provide the overall part depth and placed it on a separate level, we 

can remove the rest of the extra data. 

42 Ensure the Principal Axis is set to Z. 

 This will make sure that the new workplane we will create is in the same 

orientation as the current active workplane. 

43 Select to Create a Single Workplane  form the Workplane  menu. 

44 Create the new workplane in the location shown below. This will allow us to 

use the limit selection function to trim the excess data across the principal 

plane. 
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45 Ensure the Principal Axis of the new workplane is set to Z. 

46 Select the workplane in the graphics area. 

 This will show the workplane manipulation handles. 

47 From the General Edits  select the Limit Selection tool.  

 As the Principal Axis is set to Z and the workplane is selected the 

cutting object has automatically become the XY plane of the 

workplane. 

48 Select the area of the mesh below the workplane (cutting object). 

49 Take an Isometric View (Ctrl+1). 

 

We have successfully removed all the excess data that we do not require from 

the fixture underneath the part during the scanning process. However, we do 

still have the small section kept on Level 11 : Base Mesh in order to create a base 

surface to give the overall depth of the part. 

Now, we will begin to Reverse Engineer the part using PowerSHAPE Pro. As with 

the previous example we will use a variety of methods to best suit each step in 

the process. Working methodically, initially we will aim to create the main solid 

and then add/remove the features. 

Reverse Engineering the Part 

1 Select the mesh in the graphics area to activate the Mesh Edit toolbar. 

2 From the Mesh Edit toolbar select to Manually Segment mesh.  

3 In the manually segment mesh dialog select to fit Plane primitive surfaces, 

fit through the middle of the mesh. 
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4 Next, in the Set Angle dialog (Local Horizon) set the angle to 5° and select 

the longest front face of the part as shown in the below image. 

 This 5° value was found using the slider in the dialog as the minimum 

value to select triangles the full length of the face. 

 

5 Select Preview and then select the green tick to create the Plane primitive. 

 Do not close the dialog. After the surface is created it will not be 

visible while inside the manually segment mesh dialog to avoid 

obstructing the view, however the triangles used will be highlighted 

in white.  

6 Using the same values, select the triangles on the top face of the mesh. 

7 Select Preview and the green tick to create the surface. Do not close the 

dialog. 

 This may require multiple selections on the top face to select the 

entire area. Using the Ctrl+Click will enable you to make multiple 

selections. 

 

8 Rotate the part around to enable us to see and select the rear face(s) of the 

mesh to create the required surfaces. 

9 This time select the centre-face of the rear of the mesh that will be parallel 

with the front face as shown in the next image. 
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10 Select Preview and then the green tick to create the surface. 

11 Next select the triangles on one of the two other adjoining faces using the 

same values as before. We will only require one of the two as the part is 

symmetrical. 

 

12 Select Preview and then the green tick to create the surface. 

 We can later find the axis of symmetry in the part and Mirror this 

surface to quickly create an exact matching face. 

13 Zoom into one of the open sides of the part. 

14 Next, we need to fit a surface onto one of the side faces of the mesh.  

 Again, due to the symmetry on the part we only require one which we 

can later Mirror across. 

15 In the dialog choose fit outside as the mesh fit. 

 This will fit the plane primitive slightly outside the mesh which will 

allow us to fully round the edges and create the open pocket shape 

later. 

16 Using the Ctrl+Click multiple selection select the remaining small side 

edges that represent the side face. 
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 As we do not have much data for this particular side it is best to use as 

much of the limited data as possible. 

17 Select Preview within the dialog. 

 

18 Click the green tick to fit the surface. 

 This is also a surface which we can Mirror across the axis of symmetry 

to create the other end surface as required. 

We now have one further surface we need to create using the Manually 

Segment mesh tool, the bottom face. We will create this using the small mesh 

we divided from the fixture earlier that is hidden on Level 11 : Mesh:Base. 

To complete this we need to perform a similar operation with the manually 

segment mesh tool on the other mesh. 

19 In the dialog select the red cross to dismiss the form. 

 This will show all the surfaces we have just created. 

20 Turn ON Level 11 : Mesh:Base. 

21 In the graphics area select the small mesh we have just switched on. 

22 From the Mesh Edit toolbar select Manually Segment mesh tool.  

 We have had to exit out of this tool and show then select the other 

mesh as this tool will act on the selected mesh. 

23 Using the default values within the dialog select the triangles in the mesh. 

24 Select Preview and then the green tick to accept and create the surface. 

Then close the dialog. 
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25 Turn OFF the Level Group : Mesh.  

26 Open the Levels dialog. 

27 Create a New Level 20 : Model Surfaces. Ensure it is Switched OFF. 

28 Using the Selection  flyout menu, Quick Select ALL Surfaces.  

29 Using the middle mouse button, place the surfaces onto Level 20 : Model 

Surfaces. 

We are currently missing two surfaces that we need to Mirror across to complete 

the main model block. To do this we need to find the centreline/axis of 

symmetry of the part. To find this we will use Dynamic Section to create section 

curves in order to work out the midpoint of the width, which will be the axis of 

symmetry. 

30 Turn ON Level 10 : Mesh:Main. 

31 Select an Isometric View (Ctrl+1). 

32 Navigate to View>Dynamic Sectioning. 

33 Inside the dialog choose to take a section through the Z Axis and slide the 

slider to a value of -20mm and select to create wireframe from section. 

. Select the Arc Fitting tick box. 
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34 Turn OFF Level 10 : Mesh:Main. 

35 Take a View from Top (Ctrl+5). 

 

 Above shows an image of the section curves created using the 

dynamic section tool. To find the axis of symmetry from these curve 

we can use an equivalent point from each side, draw a line in between 

and use its midpoint. This method will be described next. 

36 Select and Blank (Ctrl+J) the two centre triangle feature shapes. 

 

37 Select ALL (Ctrl+A) and Delete the other section curves. 

38 Unblank (Ctrl+L) the hidden curves. 

To find the Midpoint in between these two curves, first, we will create a point on 

the straight area of one of the curves using a Parameter Value, and then a point 

closest to this on the other curve. 

 

39 Select the left hand curve. 
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40 From the Curve Edit toolbar, ensure Curve Numbering  is switched ON 

select Create a Point.  

41 Create a point using the Parameter Value method approximately halfway 

along the right hand straight edge. Click Apply. 

 In this case a value of 5.5 was used, although this may differ in your 

session. 

 

42 Dismiss the dialog. 

43 Now select the right hand section curve. 

44 From the Curve Edit toolbar select Create a Point.  

45 In the dialog select the Through Nearest Point tab and then in the graphics 

area select the location of the point we have just created (on the left hand 

curve). 

 This will automatically fill in the X, Y and Z values in the dialog and 

when you click Apply and point closest to this location will be created. 
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46 Click Apply to create the point and then Dismiss to close the dialog. 

We know have to points, one on each curve, directly next to each other. The 

midpoint of a line between these two points will be on the axis of symmetry. 

47 From the Line  menu, create a Single Line  joining the two curve 

points we have just created. 

48 Ensure the Principal Axis is set to Z. 

49 Next, from the Workplane  menu, create a single workplane  

and snap it to the Midpoint of the line using the Intelligent Cursor. 

 

This new workplane is now our Active Workplane and its Y Axis is the axis of 

symmetry. 

50 Quick Select ALL Wireframe  from the Selection flyout menu. 

51 Place the selected items on Level 2 : Wireframe and Switch the Level OFF. 

52 Turn ON Level 20 : Model Surfaces. 

We will now Mirror the two required surfaces across the YZ plane of the 

current active workplane. 

53 Ensure the Principal Axis is set to X (To use the YZ plane). 

54 Select the two surfaces in the graphics area. 

 Holding the Ctrl key will allow you to select multiple objects. 
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55 From the General Edits  menu select Mirror objects.  

56 Ensure YZ plane is selected, this will be automatic if the Principal Axis is X. 

57 Select the green tick to mirror the objects. 

 

58 Using Primitive Surface editing techniques described in the Surfaces chapter, 

edit all the surfaces to ensure adjoining surfaces overlap to create an 

enclosed internal cavity, and each surface is orientated with the positive 

(blue) side facing outwards in preparation for the Solid from Untrimmed 

Surfaces tool. 
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59 From the Selection flyout Quick Select ALL Surfaces.  

60 Next, select Create a Solid by Automatically Trimming Surfaces  from 

the Solid  menu. 

 

61 Check to make sure the solid is complete and closed by rotating the view. 

Click OK in the dialog to create the solid. 

We now have a created a solid forming the main block of the part. From this and 

the mesh we can now start to create and remove the features. First we will 

create a new solid level and group from the block. 

62 Raise the Levels dialog. 

63 Create a New Level 30 : Solid:Main Block. 

 This will create a level called main block and a group named solid. 

This will help later when we create and use further solids. 
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64 Select the solid in the graphics area and place it on Level 30 : Solid:Main 

Block. 

65 Ensure Level 30 : Solid:Main is turned ON. 

66 Select a View from Top (Ctrl+5). 

 

The above image shows the top down view of the main block before any 

features have been created. Before creating the features we will refine the 

dimensions of the block to fully Reverse Engineer the part. For this stage the 

more data we have including the physical part and the desgn intent of the part 

and each feature will ease this process. Scanning a part from raw data through 

to solid model may introduce minor deviations in size and location, and this 

process will allow us to react to this.  

To do this we will initially dimension the model and then use Direct Solid 

Modelling techniques to make the minor changes required to the solid model. 

67 Open the Annotation  menu and then select the Automatic Dimension 

tool.  

68 Dimension the Top Face as shown below. 

 

Now we will resize the part to the exact dimensions from the original (if 

known) using Direct Solid Modelling. These minor errors can stem from part 

wear to errors inherent in the scanner.  

69 Select the solid and then Select Inidividual Faces  from the Solid Edit 

toolbar. 

We know the overall width of the part is 488.00mm and we currently have 

measured it as 487.95mm. Therefore we need to extend the width by 0.05mm. 

However due to the part symmetry that will require each side face to be 

extended equally at 0.05/2mm. 

70 Take an Isometric View (Ctrl+I1) and zoom in on the end face. 
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71 Select the face, this should highlight orange on the solid. 

 

72 From the General Edits  menu select Move.  

 Taking a look at the Active Workplane orientation we will need to 

move this face in the –X direction. 

73 In move dialog X distance box type -0.025mm. 

 This value was derived from –(488.00-487.95)/2, it is also possible 

type the mathematical equation in also to create the value. Press 

Enter to Preview. 

 

74 Select the green tick. Do not close the dialog. 

75 Take a View from Top (Ctrl+5) and zoom into the area highlighted in the 

image at the top of the page. 

 

76 You may see that instead of following on the angled face, the software has 

created a different solution. If this is the case select the Next Solution icon 

highlighted above. 

 This will automatically update any associated dimensions. 
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77 Repeat this process for the opposite end face (+X direction). 

 This has now given an overall width (X) of 480.00mm. 

Next, we will address the length of the two side faces we have just moved. 

Currently they have a length of 106.84mm, whereas the actual length is 

107.00mm. The front face of the part will be moved to edit these faces. 

78 Select a View from Front (Ctrl+2). 

79 Select the front face of the solid, it will be highlighted orange in the 

graphics area. 

80 From the General Edits  menu select Move.  

 Taking a look at the Active Workplane orientation we will need to 

move this face in the –Y direction. 

81 In move dialog Y distance box type –(107.00-106.84) and then press Enter. 

 

 This will automatically calculate the movement distance from the 

equation. 

82 Select the green tick to move the face. 

83 Open the Annotation  menu and then select the Automatic Dimension 

tool.  Dimension the height (Z) of the model. 

 

 The dimension is measured as 30.39mm however after measuring 

the physical part we can see it is 30.00mm deep. 

84 Select an Isometric View (Ctrl+1). 

85 Select the Top Face of the part and then from the General Edits  menu 

select Move.  

86 In move dialog Z distance box type –(107.00-106.84) and then press Enter. 

87 Select the green tick to move the face. 

 Again, the dimension will automatically update. 



12 Bloodhound Steering Column  PowerSHAPE Pro 2015 

Copyright @ Delcam  12.24 

 

88 Select all the dimensions in the graphics area by holding the Ctrl key and 

select each dimension independently. 

89 Place the annotation on Level 3 : Annotation and ensure it is Switched OFF. 

90 Turn OFF Level 30 : Solid:Main Block and Turn ON Level 10 Mesh:Main. 

91 Select a View from Top (Ctrl+5). 

Looking at the mesh model we have a mirrored pattern of 4 features, we will 

create the features as separate solids and remove them from the main block 

using the Boolean Subtraction tool. We will create a solid for each feature 

separately. 

92 Select the mesh and then from the Mesh Edit toolbar select Manually 

Segment Mesh.  

93 In the Set Angle dialog reduce the angle to 5.0°.  

 We achieved this value using trial and error as the minimum value to 

achieve triangle selected across the length of each face. 

94 In the Manually Segment mesh dialog choose to Fit Mesh Outside. 

95 Select the face shown in the below image. Click Preview. 

 

96 Click the green tick to create the surface. Do not close the dialog. 

 This will create the surface and hide it until we close the dialog to allow 

us to continue fitting surfaces to the mesh without obstructing the 

view. 

97 Using the same method create the other two vertical surfaces that define 

this pocket feature. 

98 Using the Ctrl key to multi select areas on the mesh select the bottom face 

of each pocket. 

 This will provide an average of the entire area and will create a 

‘master’ surface that we can use to create each feature. 

99 Click the green tick to create the surface. 
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100 Click the red cross to close the dialog. 

 Although we have not created the ‘top’ surface to close the model, we 

can use an open solid to remove the feature. 

101 Turn OFF Level 10 : Mesh:Main. 

102 Reverse the surfaces so that the blue (selected colour) will form the outer 

faces of the open solid. 

103 Next, dynamically edit the size of each surface to create the required 

adjoining overlaps. Shown below. 

 

104 Quick Select ALL Surfaces.  

105 From the Solid  menu select Create Solid by Automatically Trimming 

Surfaces.  

 

This will create an open solid shape as above. You may have to refine your solid 

by moving the slider and manually deleting some segments. Alternatively, you 

can click Cancel to go back and edit your surfaces and try again. We will apply 

corner and bottom radius fillets later. 

106 Click OK in the dialog. 
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107 Raise the Levels dialog from the Levels toolbar. 

108 Create a New Level 31 : Solid:Open Solids and ensure it is Switched OFF. 

109 Place the open solid on the New Level 31 : Solid:Open Solids. 

110 Turn ON Level 10 : Mesh:Main. 

111 Using the Manually Segment mesh  tool create the 3 vertical surfaces 

for the feature highlighted in the image below using a Set Angle of 5.0° 

and Fit Mesh Outside. 

 

112 Close the dialog. 

 Although we only have the 3 side surfaces, we can retrieve the bottom 

surface that we created earlier from Level 799, which was 

automatically created when using the Solid from Untrimmed 

Surfaces tool. 

113 Turn OFF Level 10 : Mesh:Main and Turn ON Level 799. 

114 Select the horizontal (bottom face) surface and place it on Level 0 : 

General. 

115 Turn OFF Level 799. 

116 As before, Reverse the surfaces so that the blue (selected colour) will form 

the outer faces of the open solid. 

117 Next, dynamically edit the size of each surface to create the required 

adjoining overlaps.  

118 Quick Select ALL Surfaces.  

119 From the Solid  menu select Create Solid by Automatically Trimming 

Surfaces.  

This will create an open solid shape as seen below. You may have to refine your 

solid by moving the slider and manually deleting some segments. 

Alternatively, you can click Cancel to go back and edit your surfaces and try 

again. We will apply corner and bottom radius fillets later. 
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120 Place the new open solid on the New Level 31 : Solid:Open Solids. 

121 Turn ON Level 10 : Mesh:Main. 

122 Using the same method create the other open solid that define the basic 

shape of the other pocket on the left hand side of the part. 

 Note: This pocket has 4 sides. 

123 Turn OFF Level 10 : Mesh:Main. 

 

124 Place the new open solid on the New Level 31 : Solid:Open Solids. 

Finally, we need to create the open solid to represent the open side feature. This 

will be completed in a similar method, however this will have more than the one 

open face we have used earlier. 

125 Turn ON Level 10 : Mesh:Main. 

126 Select the mesh and then from the Mesh Edit toolbar select Manually 

Segment Mesh.  
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127 In the Set Angle dialog reduce the angle to 5.0°.  

128 In the Manually Segment  mesh dialog choose to Fit Mesh Outside. 

129 Select and create surfaces for the two faces indicated in the below image. 

 

130 Next, create the opposing two faces within the feature. 

131 Close the dialog by clicking the red cross. 

132 Turn OFF Level 100 : Mesh:Main and Turn ON Level 797. 

133 Select the horizontal (bottom face) surface and place it on Level 0 : 

General. 

134 Turn OFF Level 797. 

135 As before, Reverse the surfaces (if required) so that the blue (selected 

colour) will form the outer faces of the open solid. 

136 Next, dynamically edit the size of each surface to create the required 

adjoining overlaps.  
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 As with the actual feature on the mesh, this will have an open end. 

137 Quick Select ALL Surfaces.  

138 From the Solid  menu select Create Solid by Automatically Trimming 

Surfaces.  

 

This will create an open solid shape as seen above. You may have to refine your 

solid by moving the slider and manually deleting some segments. 

Alternatively, you can click Cancel to go back and edit your surfaces and try 

again. We will apply corner and bottom radius fillets later. 

139 Place the new open solid on the New Level 31 : Solid:Open Solids. 

140 Turn ON Level 31 : Solid:Open Solids. 
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141 Turn ON Level 10 : Mesh:Main and Turn OFF Level 31 : Solid:Open Solids. 

Looking at the mesh we can see that the features have a large corner radius 

joining each vertical face as well as bottom radius fillets. Using the Solid Fillet 

tool we can fillet our open solids to exactly represent the required feature shape 

before removing the features from the main block.  

First, the size of the fillets need to be determined by creating and measuring 

section curves using the dynamic section tool. 

142 Navigate to View>Dynamic Sectioning. 

 The Dynamic Section  tool is also available from the Model 

Analysis menu.  

143 Inside the Dynamic Section dialog, select to section through the Z Axis and 

tick the Draw Edges and Arc Fitting check boxes. 

 Draw Edges will highlight the edges of the section in white for better 

visibility of the section before section curves are created. 

 Arc Fitting will create a smoother curve fit to the section. 

144 Using the Front slider find a location where we have at least one complete 

radius to measure from, as all the radii in the case are the same size. 

145 Click Create Wireframe from section  to create the section curves. 

 

146 Select and Blank (Ctrl+J) the mesh. 

147 Take a View from Top (Ctrl+5). 

148 Using the 3 Point Arc from the Circle menu measure any one of the corner 

radii to determine the size of the corner fillets to apply. 
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Having measured a radius of approximately 12.00mm we will apply this fillet size 

to each of the vertical corners. You can check the radius on more of the corners 

to double check the sizing if required. 

149 Select ALL the section curves using Quick Select ALL Wireframe.  

150 Delete  the curves. 

151 Unblank (Ctrl+L) the mesh and then Turn OFF Level 10 Mesh:Main. 

152 Turn ON Level 31 : Solid:Open Solids. 

153 Using the Solid Fillet  tool from the Solid Feature  menu, apply a 

fillet of 12.00mm to all of the vertical corners on the 4 open solids. 

 

154 Using the same method as above (142 – 153) by taking a dynamic section 

down the X Axis, determine the bottom radius of the pocket features on the 

part (3.00mm) and then apply this value to the bottom of each of the open 

solids. 
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155 Turn ON Level 30 : Solid:Main Block. 

156 Open the Solid History Tree  from the Solid Edit toolbar. 

157 Ensure the main block is active. 

 This will automatically select the main block as the primary selection 

in the Boolean Subtraction operation. 

158 Quick Select ALL Solids.  

159 From the Solid Feature  menu select to perform a Boolean Subtraction. 
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Next, we will measure and refine the depth of the pockets, we know from the 

physical model that the wall thickness at the bottom of the pocket is 3.00mm. 

We can check this on the solid model in the graphics area using Surface 

Inspection/Model Analysis tools. To do this we need to set up the surface 

inspection options in the tools>options area. 

160 Navigate to Tools>Options>Tools>Analysis>Surface Analysis. 

161 In the surface cursor inspection area ensure Display Wall Thickness is 

ticked. Click OK. 

 

162 Select the solid in the graphics area. 

163 From the Model Analysis  menu select Surface Cursor Inspection. 

 

164 Place your cursor over the bottom of any of the pockets and click & hold to left 

mouse button to display the wall thickness at that location. 

 As we used the same surface for each feature the wall thickness will 

be constant throughout. 
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 This has given a wall thickness of 3.0534mm. Therefore we need to 

increase the depth of each feature by 0.0534mm using Direct Solid 

Modelling tools. 

165 Press the Esc key to exit surface inspection. 

166 From the Solid Edit toolbar choose to Select Concave Regions.  

 This will work in a similar way to the Select Individual Faces option by 

selecting faces and highlighting orange rather than Selecting 

Features. The upside to this is we can quickly and easily select entire 

concave regions (multiple faces) 

167 By holding the Ctrl key to multi select, select all the faces of the four pocket 

features. 

 

The next step will be to Move these faces in Z by a distance of -0.0534mm to 

give a constant 3.00mm wall thickness. 
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168 From the General Edits  menu select Move.  

 

169 Select the green tick to move the faces and allow the software to retrim a 

closed solid form. Close the dialog. 

170 Check the wall thickness now using the Surface Cursor Inspection  

tool in the Model Analysis menu.  

 

To create the features on the right hand side of the model we will mirror the 

faces across the axis of symmetry. To complete this we will create a new 

workplane which can form our Mirror plane. 

171 Ensure the Principal Axis to Z. 
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172 Select to Create a Single Workplane  from the Workplane menu. 

 

173 Create a single workplane snapped to the Face-Centre of the Top Face of 

the part as shown in the image below. 

 

174 From the Solid Edit toolbar choose to Select Concave Regions.  

175 By holding the Ctrl key to multi select, select all the faces of the four pocket 

features. 

 

176 Ensure the Principal Axis is set to X. 

 This may differ due to the workplane orientation in your session. 
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177 From the General Edits  menu select Mirror Objects.  

178 In the dialog ensure the YZ plane is selected as the Mirror plane. 

 

179 Click the green tick to accept and mirror the pocket features. Close the 

dialog. 

 

 The feature faces have successfully mirrored across the axis of 

symmetry to create the equivalent on the right hand side of the part. 
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The next step we will look at is to create the fillets around the outer edge of the 

block and into the open side pockets. Because we have already created the 

bottom radius fillets in these open pockets, we will need to suppress them in 

order to create the fillets on the vertical edges, this is to avoid the radii creating 

a continuous region. To suppress these features we need to re-recognise 

them as features, due to performing non-associative feature operations and 

losing our feature history. 

180 From the Solid Feature  menu select Solid Fillet.  

181 In the dialog choose to swtich to Feature Editing mode.  

182 In the graphics area select the 3mm bottom radius fillet on one of the open 

side pockets. Select Apply. 

 This will recognise the fillet size and track and create a solid feature 

inside the history tree. 

 

 

183 Repeat the previous step for the other open side pocket. 

184 In this Solid History Tree, delete both fillet features by clicking the 

adjacent green ticks. 

 We could have also use the Remove and Heal Selected Faces tool from 

the Solid Edit toolbar to remove these fillets without the need to re-

recognise the features. 

185 Using the Solid Fillet  tool from the Solid Feature  menu create 

fillets on each of the outer vertical edges of radius 12.00mm. Select Apply 

and OK to create and close the dialog. 
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 There are 10 edges, highlighted below, which also include the small 

angle changes of direction on the back faces of the part. 

 

186 We will now recreate the two bottom radius fillets we removed earlier. 

From the Solid Feature  menu select Solid Fillet.  

187 Create a 3mm fillet following the track we removed earlier using a Parabolic 

Cross-Sectional Shape, as shown below. Select Apply but do not close the 

dialog. 

 

188 Repeat the previous step for the same feature at the opposite end of the 

part. 
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 The main solid is now complete and awaiting finishing with holes. 

189 Turn OFF Level 30 : Solid:Main Block and Turn ON Level 10 Mesh:Main. 

190 Navigate to View>Dynamic Sectioning. 

191 Inside the dialog choose to take a section through the Z Axis and slide the 

slider to a location allowing to take a complete curve of one of the pattern of 

holes and select to create wireframe from section. . Select the Arc 

Fitting and Draw Edges tick box. 

 

192 Blank (Ctrl+J) the mesh. 

193 Select a View from Top (Ctrl+5). 



PowerSHAPE Pro 2015  12 Bloodhound Steering Column 

12.41  Copyright @ Delcam 

 

194 Zoom into any one of the circular arcs created to define the holes from the 

dynamic section. 

195 Using the 3 point radius  dimensioning tool from the Annotation  

menu, measure the the arc. 

 This tool works in the same way as the 3 point arc tool used earlier but 

will measure and create a dimension instead. 

 

 This tells us that the pattern of 4 holes through the part at the centre-

arc of each of the corners of the top face. 

196 Quick Select ALL Wireframe  and then Delete  to remove the 

section curves we no longer need. 

197 Unblank (Ctrl+L) the mesh. 

 

 The image above highlights the location of the holes. They are located 

at a keypoint, the Arc-Centre of the radius of the corner. 

Next, we will create a 6.00mm plain hole feature and then pattern it around the 

model. 

198 Turn OFF Level 10 Mesh:Main and Turn ON Level 30 : Solid:Main Block. 

199 From the Solid Feature  menu select Create a Hole.  
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200 In the dialog select Untoleranced > Plain hole as the Hole type. Select the 

Through Hole option with a Diameter of 6.00mm. 

201 Select Chamfers and in the next dialog apply a 0.25mm chamfer to the top 

edge. 

 

202 Snap to the Arc-Centre of the lower left hand corner radius as below, and 

then select Apply in the dialog to create the feature in the Solid History Tree. 
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To create the other holes in the pattern we could navigate around the model and 

apply 3 further holes of the same dimensions. This would create 4 separate 

features in the Solid History Tree. Instead, we will create a Pattern of features 

using General Edits, this method will only hold one feature, and therefore in the 

future any edits will be much quicker. 

To achieve this we first need to determine the X and Y translations for the 2 x 2 

pattern. 

203 Using the Automatic Dimension  tool from the Annotation  

toolbar, determine the distance between the Hole-Centre and the Arc-Centre 

for the other Hole locations. 

 The X distance = 464.00mm and the Y distance = 85.00mm. 

 

204 In the Solid History Tree select the Hole feature. 

 This will also highlight the feature blue in the graphics area. 

 

205 From the General Edits  tool choose to Create a Pattern.  

206 In the Pattern dialog select the Rectangular tab and create a 2 x 2 pattern 

using the dimensions we calculated previously.  
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207 Click OK in the dialog to create the pattern of features. 

 

 This has created a pattern based around the Hole feature we previously 

had made. This means any edits in the future can be done on one 

feature and applied to all in the pattern. 

208 Select an Isometric View (Ctrl+1) 

 

We have now completed the solid model.  

Save the model as bloodhound steering support.psmodel in your desired 

location. 
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Introduction 
In this tutorial we will look at the many tools available within PowerSHAPE Pro 

2015 for the purpose of, and to aid with the Reverse Engineering of a part from 

scan to a complete solid model.  

The part used for this tutorial is a Delcam demonstration block which will allow 

us to highlight all the tools available while guiding the user through most 

features and issues commonly seen during the reverse engineering process. 

  

Importing the Point Cloud 
We will start with point cloud data just as would be standard, exporting from 

the metrology software used to collect the data, or by using the PowerSHAPE 

Pro laser scanning and probing ability to collect point data. 

1 Import the file re eng point cloud.asc located in: 

C:\\Training Data\PowerSHAPE Pro data 

2 Select the Workplane Icon  from the Main toolbar, and then in the 

command box type 0 and press Enter. 

13. Reverse Engineering 
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 This will place a workplane at 0, 0, 0 (World) to highlight where the 

world datum is located. We can either align the part back to the world 

or to any other location and export back to the part datum. We will 

look at workplanes and alignments shortly in the course. 

3 Select an Isometric View (Crtl+1).  

 

 As you can see 

the scan data of 

the part is 

positioned away 

from the 

workplane 

origin and 

orientated off 

axis. Both these 

issues will 

require 

consideration by 

aligning the part, 

this is easier 

once we have 

created a mesh 

from the point 

cloud. 

4 Zoom into and select 

the point cloud, this will highlight as green in the graphics area and also will 

activate the Cloud Edit toolbar. 

 The data may consist of more than one point cloud, if this is the case use 

the Quick Select ALL Clouds  function from the selection flyout 

menu, and then the Combine Clouds  from the Cloud Edit 

toolbar, below. 

 

 

 

 

 

 Pick Points in a cloud by box 

 Pick Points in a cloud by discrete lasso 
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 Pick Points in a cloud by continuous lasso 

 Filter points in the selected cloud 

 Generate Mesh 

 Generate Curve 

 Divide cloud by selection 

 Combine clouds 

 Colour clouds uniquely 

 Reset to default colour 

 Delete selected points’ 

 

As you can see the cloud contains some noisy data and extra data from the 

fixture used to raise and hold the part to allow a more complete scan to be taken. 

We will now remove any data that we do not want to take forward. 

5 Rotate and Zoom into the anomalous data above the hemispherical cut on 

the top face of the part. 

6 From the Cloud Edit toolbar select pick points using discrete lasso  

(any preferred pick option may be used at this point). Then carefully select the 

extra data to be deleted. 
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7 Select the Delete Selection  icon from the Cloud Edit toolbar. 

8 Repeat this process for all other extra data that would you not like to be 

used in the generation of the mesh. Try using a variety of the different point 

selection methods. 

 NOTE: Limit Selection may also be used to remove the cloud data 

underneath the part caused by the fixture. 

9 Rotate the part to allow us to view the underside. Note that we can still see a 

small amount of data that shows capture of the bottom face of the part. There 

is no need to delete this data as it is useful to the reverse engineering 

process as it allows us to measure the depth of the part. 

 

10 From the Cloud Edit toolbar select Filter points in the selected cloud. 

 This dialog is used to reduce the density of points in the cloud by 

introducing a minimum distance between each point. There are 

currently slightly over 6.8 Million points in the cloud. 
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11 Enter a minimum distance between points of 0.5mm and then select Apply. 

 Note in the dialog that the cloud has been dramatically reduced down 

to 140,000 points without any noticeable loss of detail. This will help 

reduce the complexity and processing time required to generate the 

mesh. 

12 Cancel the dialog. 

Next we will generate a mesh from the point cloud. However first it is good 

practice to save the session. 

13 File>Save As… Choose a name relevant to the part & stage we are currently 

at in the model. Eg Demo block point cloud.psmodel 

14 Select Generate Mesh  on the Cloud Edit toolbar. 

 The default values in the Generate Mesh dialog are designed to 

minimise processing time and may not provide satisfactory results. 

15 Inside the generate mesh dialog change the stepover size to 0.6mm (just 

large than the filter points distance). Leave the hole fill diameter as default in 

this case. 

 

 If the mesh generation creates a Reversed (Red) mesh. It is possible 

to reverse the mesh by selecting the Reverse Meshes  option 

from the Mesh Edit toolbar. 

 Feel free to experiment with these values to get a feel for their 

response to edits.  

Stepover: - specifies the size of the triangles in the mesh. Smaller 

Stepover values give a finer and smoother mesh.  

Hole fill: - specifies the maximum diameter of holes that should be 

filled automatically. The mesh generator will attempt to fill holes that 

have a diameter equal to or smaller than the Hole fill value. 

 

16 From the Levels toolbar at the lower left hand corner of the window raise the 

levels dialog.  

17 Create a New Level on number 6 called “Point Cloud” and another on number 

7 called “Mesh” and then click OK to close the dialog. 
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18 Place the objects on the respective levels and then switch the mesh (level 7) 

ON. 

 

A mesh has been created from the filtered point cloud using a stepover size of 

0.6mm and a hole fill diameter size of 81.3mm. As you can see PowerSHAPE 

Pro has created a fine & clear mesh which will make the entire reverse 

engineering process much simpler. There are still some relatively small areas of 

noise and missing data on the mesh. This is mostly locate inside the holes. This 

issue is very common on scanned data and at this point it is necessary to decide 

whether any of this will cause errors later, while considering the design intent of 

the model. 
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Reverse Engineering Notes 
Before we go any further on how to use the reverse engineering & modelling 

tools available in PowerSHAPE Pro, use this page to have a look at the mesh and 

make notes on what you believe, using your knowledge, is the most efficient way 

to remodel this part.  
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Aligning the Mesh 
Correctly aligning the mesh is important to the entire Reverse Engineering 

process and ideally we should use the largest area and simplest shape to give 

the best results. This will allow the Mesh Segmentation tools to automatically 

adjust primitive shapes to the axes of the active workplane. 

1 From the Mesh Shading options on the View/Shading menu on the right 

hand side of the graphics area select the option to show Open and Interior 

edges, shaded triangles.  

 This will show the edges of the inner triangles allowing better clarity 

when selecting areas inside the mesh. 

In this example we will align with the raised step face on the left hand side of 

the mesh. We have 3 clear and definable corner points, which we can easily 

align with a planar surface. We can align objects using many primitive shapes. 

However the defined corner points of a plane makes it the ideal tool in this case. 

As this time we are using a much larger area, but only have 3 corners on the 

mesh we should produce an accurate alignment. 

 

 The image above highlights the 3 available corner points located on the 

upper face of the mesh as a rectangular formation. The alignment 

tools use a minimum of 3 points for each object to create an 

alignment so this will suffice. 

2 Ensure the Principal Axis in set to Z. 

3 From the Surface  menu select Create a Planar Surface.  

4 Place the surface on the workplane origin by typing 0 in the command box 

and then press Enter. 

5 Double click on the surface to open the surface edit dialog. 

6 Zoom into the top face of the mesh shown above. 



13 Reverse Engineering Demo Block PowerSHAPE Pro 2015 

Copyright @ Delcam  13.10 

 

To resize the surface using the measuring tool directly we can right-click inside 

the text box adjacent to the width or height in the dialog. This will then open the 

calculator and allow measurement of the correct length and automatically fill 

the respective box. 

7 Right-click in the Width text box. 

8 Measure the Width by clicking on the corners of the face in the graphics 

area. 

 Try to remember which corner triangles you selected as clicking these 

exactly again during the alignment phase will produce the best result.  

 

9 Click OK in the Calculator to use the measured value as the Width. 

10 Repeat the same process for the Length of the same face to fully resize the 

planar surface to fit. 

 

 If your values are slightly different to the values in the image above 

do not worry. Again, the best alignment will rely on selecting the 

same corner positions as you did to resize the surface when 

aligning. 
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In the graphics area we now have the mesh created from the 

imported/scanned point cloud and an alignment surface sized to fit the face 

we have chosen to use to help align with planar surface, and therefore the origin 

of the active workplane/world datum position. 

11 Select Align Items  from the General Edits  menu (This is located 

in the flyout menu with Move). 

 

 The Alignment Item is defined as the object that will move during the 

alignment operation. 

 The Fixed Item is defined as the object that will NOT move during the 

alignment operation. 

 If the alignment and fixed items are far apart in the graphics area this 

may cause problems while navigating the view. It is possible to simply 

drag move the alignment item, in this case the mesh closer to the 

surface. 

12 Click on the mesh to select it as the alignment item, then select the surface 

as the fixed item in the same way. 
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Next, we have to select a number of points on the alignment item, and then 

repeat the same selection on the reference item. Note that the order and 

amount of the points selected must be the same for each object. For a rectangle a 

common selection order is “clockwise, width first then the length” this way you 

know that the selection will always be the same. 

13 Select 3 points around the face of the Alignment Itme, one in each corner 

on the mesh and then repeat the selection on the Reference Item, the 

surface. 

 Note: The order and direction of your selected points must be the 

same for each object. 

 

14 When your selection is complete and correct all the red crosses will become 

green ticks and the dialog will tell you that you are ready to perform the 

alignment operation. 

15 Select Apply and Cancel to close the dialog and view the results. 
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As you can see we have successfully aligned the mesh with the surface and the 

origin of the active workplane. Further to this we can fine tune our alignment 

using the best fit alignment  tool from the same menu. 

16 From the General Edits  menu select Best Fit Items.  

 

17 In the Best-fit Align dialog select the Mesh as the item to align, select the 

surface as the fixed item. 

18 Click Apply, the mean distance is the average movement of the mesh to 

further best fit with the surface. 

19 Select Cancel to close the dialog. 

20 Raise the Levels dialog to create a new level on Level 997 called “Alignment 

Surface”. 

21 Select the surface we have used align the part in the graphics area and place 

it on level 997 : Alignment Surface. 

22 Turn OFF Level 997 : Alignment Surface. 

 The surface we have used for the alignment will unlikely to be required 

again, but is useful to keep as backup. Placing it on the final available 

level will mean that although still there, it will always appear at the end 

of the Levels toolbar, out of the way. 

As the mesh has been successfully aligned and further best fit to the surface we 

can now begin to Re-Engineer the part. 

 

 

 

 

 

 

 

 



13 Reverse Engineering Demo Block PowerSHAPE Pro 2015 

Copyright @ Delcam  13.14 

 

Reverse Engineering the Block 
We will start by using the Automatic & Manual Mesh Segment tools to find all 

the planar surfaces to enable the main shape of the model to be created. This 

and other tools will be used to create the part. 

First we will look at and setup the default options available to aid us using the 

Mesh Segment tools inside the Tools>Options area. 

23 Navigate to Tools>Options>Object>Mesh. 

 

 This area holds the mesh options, more specifically the options relating 

to the Mesh Segmentation tools and how they interact with the mesh 

and workspace. 

 Item type to fit: This option allows the user to fit surfaces or solid models 

when using the Automatic or Manual Mesh Segmentation tools. 

 Trim Surfaces: This option allows you to toggle between creating trimmed or 

full surfaces when segmenting the mesh. 

 Alignment Angle: This value will define the threshold tolerance (in degrees) 

for aligning primitives with a principal plane. If an axis of a primitive is 

less than this angle away from a plane of the active workplane, the axis of 

the primitive is snapped to that plane. 

 Extension Distance: The value to define the distance by which a primitive is 

extended beyond the edge of the selected region. 

 Fit Method: This defines the location in which the primitives are fitted to the 

average depth of the selected region; Inside, Outside or Middle. 
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1 From the Mesh Shading options on the View/Shading menu on the right 

hand side of the graphics area select the option to show Open Edges Only. 

 

2 Select an Isometric View (Ctrl+3). 

3 Select the mesh in the graphics area to activate the Mesh Edit toolbar 

above, and then open the Automatic Mesh Segment tool.  

4 As we are currently only looking to create a basic shape to work from, in the 

primitive types area select only Planes. 

5 With the default values select Preview. 

6 Select and Apply the two upper faces of the mesh indicated in the next 

image. 

In this case we will look at the freeform surface and other features later as 

currently we are only looking to create a basic block shape. As primitive 

surfaces are created we can later extend any shorter surfaces to suit our 

requirements. 

 

7 Next, select and Apply the next two vertical surfaces shown in the next 

image. 
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8 Inside the automatic segmenter dialog Adjust the Similarity angle, until you 

have selected all the triangles for the face. A value of 2 gives a good result 

in this case, and then select Preview. 

9 Select and Apply the long edge surface as well as the intersecting cut edge 

surface indicated below. 

 

10 Adjust the Similarity angle, until you have selected all the triangles for the 

face. A value of 6 gives a good result in this case, and then select Preview. 

11 In the image below are two further surfaces to create the main outer 

shape of the model from the mesh. Select them and click apply. 

 These surfaces may not intersect currently, however as mentioned 

earlier, we can simply dynamically drag edit them in the graphics area 

later to suit. Due to the coarse area of the mesh and the cut corner we 

will have to compromise in this case. 
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12 In the dialog select Cancel to close. 

 

The only surface for the main shape we are currently missing is the bottom 

face of the part. In the case of this mesh we have some data collected from the 

scan through the large hole through the part. To extract this surface we will use 

the Manually Segment Mesh  tool. 

If you are missing any of the surfaces the example has created above, you can 

use this tool to manually create them too. 

13 Quick Select ALL Surfaces  from the Selection flyout menu. 

14 Blank (Ctrl+J) the selected surfaces. 

15 Rotate the view to look down to the bottom of the hole. 
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16 Select the mesh and then open the Manually Segment Mesh  tool from 

the Mesh Edit toolbar. 

17 With Type: Plane chosen and the default horizon angle select the area at the 

bottom of the hole. 

 

18 Click Preview and Apply to create the surface and then Dismiss to close the 

dialog. 

19 Unblank (Ctrl+L) the other surfaces. 

20 Turn OFF the Level 7 – Mesh. 

 

These are currently all the surfaces required to form the main outer block using 

the function to Create Solids from Untrimmed Surfaces however we need to 

ensure that the model has no gaps by extending the primitives and orienting 

them correctly. 

21 Extend the surfaces in the graphics area to cover the gaps to create a closed 

region and orientate the surfaces with the positive “blue” side facing 

outwards. 
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 Ideally we are looking to see a group of untrimmed surfaces similar to 

above. The positive side of the surface is facing outwards and all 

adjoining surfaces are slightly overlapping. 

22 Quick Select ALL Surfaces.  

23 From the Solid  menu select Create Solids from Untrimmed Surfaces. 

 

 

24 Select OK.  

 This creates a Solid Model from the cavity inside the untrimmed 

surfaces. If your model is not a complete and closed solid this will be 

due to the orientation of one or more of the surfaces, or a missing 

overlap. Select Undo and check the affected area of the model. 
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25 Select and move the active workpane into the corner shown below and 

then reorientate it to ensure that the X & Y axis are parallel with both 

edges, which in turn will mean that these edges are perpendicular to each 

other. 

 

26 From the Levels toolbar create a new Level 10 – Solid Model. 

27 Place the Solid on Level 10 and ensure the level is OFF. 

28 Turn ON the Mesh on Level 7. 

As we now have created a basic solid shape it is good practice to dimension the 

part to allow us to ensure it is correctly sized. Reverse Engineering from the 

raw data scan of the part to an initial solid model will inherently introduce small 

errors which we can easily rectify using Solid Modelling and Direct Solid 

Modelling techiniques introduced earlier. 

Dimensioning the Solid 

We will now dimension the major elements of the solid to check the sizing, and 

further resize the part to suit requirements. In this step, having the physical part 

and background information including design intent will help produce an 

accurate part. 

29 Select the Automatic Dimension  tool located in the Annotation  

menu. 

 The Automatic Dimension tool is a multi-purpose dimensioning tool 

allowing dimensions to be created quickly and easily in a PowerSHAPE 

session. This tool picks up dimensions by hovering the mouse over the 

key areas such as solid edges. 

30 Select a View from Top (Ctrl+5). 

31 Once the dimensions are shown as a preview (in yellow, as above) a single 

mouse click will produce a dimension, while a further click will place the 

dimension under the cursor. 
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32 Continue to dimension the rest of the major elements of the model using 

the Automatic Dimension tool. 

 

 

As you can see from the above images the data has provided a mesh that has 

closely represented the part. Any number of variables can cause these small 

descrepencies in sizing. However if we are reverse engineering to recreate the 

exact model we can now use the Direct Solid Modelling techniques shown earlier 

to perform General Edits to individual faces of the solid model. 

 With a length of, for example, 249.91mm we can expect that the 

orginal length would have been 250.00mm unless further information 

can prove otherwise. 

 We can also see that a split length of 130.00mm and 119.92mm would 

require material to be added at the right hand edge face (looking from 

above). 

33 Select an Isometric View (Ctrl+3) to show the face we need to add 

material. 

34 Select the Face which will become highlighted in orange. 



13 Reverse Engineering Demo Block PowerSHAPE Pro 2015 

Copyright @ Delcam  13.22 

 

 

35 With the face selected select Move  from the General Edits  

menu. 

36 Inside the Move dialog insert a Y movement distance of 120.00-119.92 

(0.085mm).  

 Dependent on the orientation of your workplane. 

37 View the Preview of the Move operation by pressing the Enter key. Select the 

green tick to move the face. 

Next we will refine the Width of the Model. It is currently measured to be 

109.97mm. Therefore we expect an actual value of 110.00mm. 

38 Select the correct face to move in the graphics area.  

 This will again be highlighted in orange. 

39 Inside the Move dialog insert an X movement distance of 110.00-109.97 

(0.03mm).  

 Dependent on the orientation of your workplane. 

40 View the Preview of the Move operation by pressing the Enter key. Select the 

green tick to move the face. 
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 The dimensions will automatically update upon completing any of the 

Direct Solid Modelling operations. 

41 To complete this process we need to refine the block dimensions in Z 

(height) also. Attempt to do this yourself for the step height and overall 

height we dimensioned earlier using the same method described above. 

 Hint: Move the lower side of the step face to create a step height of 

10.00mm and then move the bottom face of the solid to refine the 

overall height to 45.00mm. 

 

This action is an important part of the reverse engineering process and should 

be completed right the way through to feature level size and positioning as will 

be demonstrated later in this tutorial. 

Now we have the main block correctly sized we can start to build up features 

using the Automatic Mesh Segment tool where possible and then the Manually 

Segment Mesh tool. 

First we will remodel the main large through holes through, one with a conical 

opening. 
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42 Open the Manually Segment Mesh  tool and select to fit primitive 

SOLID cylinders. Choose to recognise solid primitives by clicking the 

surface icon in the dialog, which will change to a solid. 

 By selecting to recognise primitive solids the Mesh Segment tools will 

create primitive solids in the graphics area, rather than the surfaces 

as we have seen before. 

43 Select to Fit Inside in the dialog. This will fit the primitives just below the 

surface of the mesh, most useful for areas such as holes where the data can 

create undersized holes. 

 

The options in this flyout menu are: 

 Fit Inside  - Select this option so that the primitive is fitted to lie just 

below the inside surface of the mesh. 

 Fit through Middle  - Select this option so that the primitive is fitted as 

close as possible to the centre of the mesh. 

 Fit Outside  Select this option so that the primitive is fitted to lie just 

above the outside surface of the mesh. 

44 Select the cylindrical area of the large countersunk hole in the centre of 

the raised face. Select Preview. 

 Holding the Ctrl key while selecting the triangles will allow you to multi 

select regions. 

 

45 Select the green tick to Apply and create the sold cylinder. Right-clicking 

the solid in the graphics area will also perform the same action (Apply). 

46 With type set to Cylinder, now select the area of triangles that represent the 

through hole on the formed face of the part. Select Preview. 
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47 Click the green tick in the dialog to create the Solid Cylinder. 

Next, we are going to create the Solid Cone to represent the countersink using 

the same process as above in the Manual Mesh Segment dialog. 

48 In the Manually Segment Mesh dialog change the Type to Solid Cone. 

Continue to Fit Inside, Solid Primitives. Select Preview. 

49 Select the green tick to Apply and create the sold cone. 

50 Click the red cross in the dialog to dismiss the form and show the solids 

created. 

51 Turn OFF Level 7 : Mesh. 

 

52 Turn ON Level 10 : Solid Model and ensure the primitive shapes extend 

beyond the outside of the main solid block. If at this point they do not you 

can extend the length of the primitives to make sure they do, as below. 

 

53 Turn OFF Level 10 : Solid Model. 

The next step is to refine the size and location of the primitive shapes in relation 

to the datum location, and each other. 

54 Double-click on the Solid Cylinder below the Cone. In the Dimensions tab 

refine the Radius to 12.5mm (Diameter 25mm) 

55 In the Workspace tab refine the X and Y coordinates to 55.00mm and 

80.00mm respectively. 
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It is important that the Solid Cone has the same X and Y location (as the previous 

cylinder) to provide a consistent countersink shape. 

56 Double-click on the Solid Cone and navigate to the Workspace tab of the 

Cone Edit dialog. Edit the values to X=55.00mm and Y=80.00mm. 

57 Select both these solids in the graphics area (Cone and Cylinder). 

58 From the Solid Feature  menu choose Boolean Addition  to 

combine the two solids. 

59 Open the Solid History tree.  

 

60 Double-click on the other Solid Cylinder in the graphics area. 

61 In the Dimensions tab refine the Radius to 10.00mm. 

62 Navigate to the Workspace tab and using the values below, refine the X and 

Y coordinates of the datum of the cylinder. 

 

63 Turn ON Level 10 : Solid Model. 

64 Ensure the main solid block is Active.  
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65 Quick Select ALL Solids  from the selection flyout. 

66 Perform a Boolean Remove  operation from the Solid Feature  

menu on the multiple solids selected using the main solid as the active. 

 

67 Turn ON Level 7 – Mesh and Turn OFF Level 10 – Solid Model. 

68 Select the mesh in the graphics area to activate the Mesh Edit toolbar and 

open the Automatic Mesh Segment  tool. 

69 In the dialog set the Similarity Angle to 3 and Primitive Types to Solid 

Spheres. Select Preview. 

 As before we have changed the similarity angle using the slider until 

we fitted this sphere, in this instance 3 gave a good result. 
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70 The hemispherical cut from the top face of the mesh has been recognised as 

a solid sphere. Select and Apply this primitive shape. 

71 Click Cancel to close the form. 

72 Turn OFF the Level 7 : Mesh and Turn ON the Level 10 : Solid Model. 

 

The image above highlights how the solid sphere we have created interacts with 

the solid block. We can now again refine the size and location of the solid 

sphere to Reverse Engineer the part. 

73 Double-click on the solid sphere to raise the sphere edit dialog. 

74 In the Dimensions tab edit the radius to 12.00mm. 

75 Select the Workspace tab and fill in the values from the image below. 
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 This time it is important to set the sphere centre Z location to 0. This 

will ensure the centre of the sphere is flush with the top face of the 

part. 

76 Select the solid sphere, and then select Boolean Subtract  from the 

Features  menu. 

 

There hemispherical cut has been created by using a Boolean Subtraction 

between the active solid (primary selection) and the solid sphere (secondary 

selection). 

77 Turn ON Level 7 – Mesh and Turn OFF Level 10 – Solid Model. 

78 Select the mesh in the graphics area to activate the Mesh Edit toolbar and 

open the Manually Mesh Segment  tool. 

79 In the dialog choose to fit Solid Cylinders using the Fit Inside method. 

80 Within the graphics area select the hole running horizontally through the 

width of the part. Use the Ctrl key to multi-select triangles to get a spread 

of data along the length of the hole. Select Preview. 
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81 Select the green tick in the dialog to create the solid cylinder, and then the 

red cross will dismiss the form. 

82 Double-click on the solid cylinder and then refine its radius to 6.5mm. 

 The alignment angle set inside our options file has, as with the other 

primitives, aligned the axis of this cylinder to an axis of the active 

workplane. 

83 Turn OFF Level 7 : Mesh and then Turn ON Level 10 : Solid Model. 

84 From the Solid Features  menu select Boolean Subtraction . The 

main solid block (active) will be the primary selection and select the 

cylinder as the secondary selection. 

 

85 Turn ON Level 7 : Mesh and then Turn OFF Level 10 : Solid Model. 

86 Select an Isometric View (Ctrl+3). 
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87 Select the mesh in the graphics area to activate the Mesh Edit toolbar and 

open the Manually Mesh Segment  tool. 

88 In the dialog choose to fit Solid Cylinders using the Fit Inside method. 

 

We are now going to fit primitives in order to create the PCD of holes on the 

part. To do this we need to fit a number of primitive cylinders to calculate the 

diameter of the pattern using a 3 point arc, which will also give us the centre 

point of the pattern. 

89 Using the Manual Mesh Segment tool fit a solid cylinder using one of the 

holes. 

 

90 Turn OFF Level 7 : Mesh and then Turn ON Level 10 : Solid Model. 

91 As you can see the scan data has not reached the bottom of the holes. 

However, we know from the physical model and its design intent that these 

holes have a Depth of 30mm. We can refine the location of the bottom of 

the cylinder to reflect this. 

92 Double-click on the cylinder in the graphics area. In the Dimensions tab 

edit the Radius to 6.5mm and the Length to 35mm. 

 The length of 35mm will ensure that when we include a Depth of 30mm 

the solid cylinders will break through the top face of the solid block. 

93 Select the Workspace tab and edit the Z location to -30mm. 
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The centre of the countersunk hole is the centre point of the PCD. Therefore, we 

will create a new workplane at this location and then pattern the hole around 

the workplane using the Pattern Feature. 

94 Select the solid cylinder and select to perform a Boolean Subtraction  

from the Solid Feature menu.  

 

95 From the Workplane  menu select Create a Single Workplane.  

96 Create a workplane at the Arc-Centre of the countersunk hole by 

automatically snapping to it using the intelligent cursor. 
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97 Select the Boolean Subtraction  operation of the 13mm Diameter hole 

we have just created in the History Tree. 

 This will also highlight the hole in blue in the graphics area as shown 

below. 

 

 

 

 

 

 

98 From the General Edits  menu select Create a Pattern.  

99 Within the Pattern dialog navigate to the Circular Pattern tab. 

100 Edit the Number of Elements to 5 and the Radius to 40mm. 

 The angle will automatically update in this dialog to create the pattern 

with equidistant spacing. 
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We have successfully create the PCD of holes of Depth 30mm and Diameter 

13mm. Next, we will divide the mesh to help us remodel the rectangular 

protrusion on the right hand side of the part, shown below. 

 

101 Turn OFF Level 10 – Solid Model and Turn ON Level 7 – Mesh. 

102 Take a View from Top (Ctrl+5). 

103 Select the Mesh to activate the Mesh Edit toolbar. 

104 Using the option to Pick Triangles in a Mesh by Box drag a box around the 

protrusion while also selecting extra triangles around the area as shown 

below to allow a complete solid to be created. 
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105 With the triangles selected choose to Divide the Mesh by Selection  

from the Mesh Edit toolbar. 

 

The major benefit for dividing this mesh is that we can blank the rest of the 

mesh and concentrate on this particular area of interest using the 

PowerSHAPE Pro Mesh Segment tools to fit primitive surfaces and then 

combine the two meshes back together later. 

106 Select and Blank (Ctrl+J) the rest of the mesh leaving only the protrusion 

area. 

107 Select Automatically Segment Mesh  from the Mesh Edit toolbar. 

108 In the dialog select Planes as the only Primitive Type, choose a Similarity 

Angle of 2, and then click Preview. 

109 Select and Apply the two surfaces identified in the next image. 

 

This will give us the Top face and one of the end faces. We also already have the 

bottom face which will join the main solid model automatically saved on Level 

800 from the Solid from Untrimmed Surfaces operation. We can create the 

other end face by offsetting the above surfaces the length of the protrustion. 

110 Change the Similarity Angle to 3 and click Preview in order to recognise and 

then Apply the side face shown below. 
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Although it is clear that the surface plane recognised here doesn’t cover the full 

length of the face we can simply extend it as a primitive shape later. 

111 Click Cancel to close the dialog. 

112 Quick Select ALL Surfaces  that we have created (3). 

113 Place these surfaces on Level 1 – Surfaces and turn OFF the level. 

114 Turn ON Level 800 and select the large face which will form the bottom of 

the protrusion to join with the main solid model and place it on Level 1 – 

Surfaces. 

115 Turn OFF Level 800. 

116 From the status bar at the bottom of the window, open the Measure  

form. 

 With this form open, measurements can quickly and easily be taken 

directly from the model, in this case a mesh. 

117 Measure the Length (60mm) and Width (11mm) of the protrusion. 

 These are the distances we will need to offset the current surfaces to 

create the missing faces to create the solid. Again design intent or 

the physical model will give us a better idea of these measurements if 

critical. 

118 Turn ON Level 1 – Surfaces. 

119 Select the End surface and from the General Edits  menu select Offset. 

 

 If required click the orange arrow to reverse the direction of the 

offset. 

120 In the Offset dialog type a distance of 60mm and press Enter, and then close 

the form. 
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121 Where the side surface is too short, select and dynamically extend the 

surface to ensure an overlap between this and the adjoining surfaces. 

 

122 Select this surface and choose to Offset  from the General Edits  

menu. 

123 As before, if it is required click the orange arrow to offset through to the other 

side of the mesh. 

124 In the Offset dialog type a distance of 11mm and press Enter, and then close 

the form. 

125 Next, reorientate the positive ‘blue’ side of the surfaces to face outwards 

before we attempt to create the solid. 

 

126 Quick Select ALL Surfaces.  

127 From the Solid  menu select Create Solid from Untrimmed Surfaces. 

 



13 Reverse Engineering Demo Block PowerSHAPE Pro 2015 

Copyright @ Delcam  13.38 

 

 

128 Once you are happy with the solid created click OK in the Automatic 

Trimming form. 

 If the selection of surfaces does not create a closed solid model select 

Cancel in the dialog and go back and check the orientation and 

overlap of the surfaces. 

129 Select the solid and place it on Level 10 – Solid Model using the middle 

mouse button. 

130 Unblank (Ctrl+L) the rest of the mesh. 

131 Select both mesh inside the graphics area. 

132 Select Stitch Mesh  from the Mesh Edit toolbar. 

133 Using the default values click OK to stitch the two mesh back together. 

134 Turn OFF Level 7 – Mesh and Turn ON Level 10 – Solid Model. 

135 Using Boolean Addition  add the two solid models together. 
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Hexagonal Cut 
Next we will aim to create the hexagonal feature cut into the top face of the 

model. To do this we will again divide the mesh down to just the area of 

interest for simplicity. 

136 Take a View from Top (Ctrl+5). 

137 Zoom in to the hexagonal feature. 

138 Select the mesh to activate the Mesh Edit toolbar. 

139 Choose the option to Pick Triangles on a Mesh by Discrete Lasso.  

140 Using the lasso select the area around and including the hexagonal cut 

similar to the below image. 

 

141 From the Mesh Edit toolbar and with the triangles selected choose Divide 

the Mesh by Selection.  

142 Select and Blank (Ctrl+J) than main mesh, as before. 

143 Select an Isometric View (Ctrl+1). 
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144 From the Mesh Edit toolbar choose to Automatically Segment Mesh.  

145 Inside the dialog change the Similarity Angle to 2 and search for only Planes 

as the Primitive Type then select Preview. 

 Again this value of 2 for similarity angle works for this part, and was 

found using the slider to give good results. 

 This time we will be looking to create a solid to then Boolean Subtract 

from the main block.  

146 Select and Apply the surface representing the bottom face of the cut. 

 

The PowerSHAPE Pro Automatic Mesh Segment tool has found 5 out of the 6 

vertical faces of the hexagonal pattern. If you rotate the view to see the face 

that is not found, you will see that a hole has been automatically filled which is 

likely the reason. 

147 Select and Apply the 5 vertical faces found of the hexagonal pattern. 

148 Click Cancel to close the dialog. 

149 Using the Measuring  tool found on the status bar below the graphics 

area. 

 Face to face we are looking to create a 26mm hexagonal solid from 

results of using the measuring tool. 

150 Using the Offset  tool (26mm) from the General Edits  menu and 

the surface opposite the missing face complete the hexagonal pattern of 

surfaces. 
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From here we can use an open solid by using a solid from untrimmed surfaces 

operation to enable us to remove the hexagonal feature. 

151 Unblank the main mesh and then Turn OFF Level 7 – Mesh. 

152 Reorientate the untrimmed surfaces so the positive/blue side faces 

outwards in preparation for the Solid from Untrimmed Surfaces function. 

 

153 Quick Select ALL Surfaces  from the Selection Flyout. 

154 From the Solids menu select Create Solid from Untrimmed Surfaces.  

155 Using the auto trimming dialog create the open hexagonal solid shown in 

the next image. 

156 Turn ON Level 10 – Solid and open the Solid Feature Tree from the Solid 

Edit menu. 
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157 Using the Boolean Subtract  function, remove the Hex from the Main 

Solid.  

 

158 Turn OFF Level 10 – Solid and Turn ON Level 7 – Mesh. 

Next we need to stitch the split segments of mesh back together, as they are 

originally from the same connected mesh this should be a simple operation. 

159 Navigate to, and select Quick Select ALL Mesh.  

160 From the Mesh Edit toolbar select Stitch Mesh.  

161 Within the dialog select OK using the default values. 
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Cylindrical Cut Corner 
Next we will create the cylindrical cut from the lower left hand corner of the top 

face of the part. Note also that we have already created the chamfered edge 

below when we created the main block. 

 

162 Activate the Mesh Edit toolbar by selecting the mesh in the graphics area. 

163 From the toolbar select to Automatically Segment Mesh and Fit Primitives. 

 

164 In the Segment Mesh dialog select only to fit primitive planes as this will help 

clear the clutter from the screen slightly. 

165 Select and Apply the primitive plane at the bottom of the cut. 

 

166 Cancel the Segment Mesh dialog. 
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Next we will use the Manually Segment Mesh and Fit Primitives  option to 

fit a primitive cylinder above the plane we just created to cut away from the main 

solid. 

167 From the Mesh Edit toolbar select Manually Segment Mesh and Fit 

Primitives.  

168 In the dialog, use the drop-down menu to select Cylinder as ‘Type’. 

169 Select the area on the mesh to fit the cylinder. 

 Holding the Ctrl key while clicking in the graphics area will allow you to 

make multiple selections to select the full area to fit. 

 

170 Preview the Cylinder. Once you are happy with the result select the green 

tick to create the cylinder, and then dismiss (red cross) the form. 
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We have now successfully fitted and created a partial cylinder. Next, we need to 

check the location of the centre point. On the model this should be where the two 

vertical edge faces would meet, therefore we will create a workplane at this 

location and then ensure that the X and Y coordinates of the primitive cylinder 

are 0. 

171 Turn OFF Level 7 : Mesh and Turn ON Level 10 : Solid. 

172 Using a Workplane Aligned to Geometry  and using the Workplane 

manipulation handles to move the workplane into the location below. 

 

 If you are having trouble positioning the workplane, please refer back to 

the workplanes chapter or ask the tutor. 

 The Z Axis of this workplane should line up exactly with the axis of the 

cylinder. Therefore this workplane will allow us to refine the location 

and size of the primitive. 

173 Open the cylinder properties dialog by double-clicking it in the graphics 

area. 
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174 Edit the Radius to 35mm. The length currently is not critical, as long as it 

extrudes above the top face of the solid. 

175 Select the Workspace tab to view the coordinates of the cylinder datum. 

 

As described earlier, we are expecting the X and Y values to be 0 to indicate the 

cylinder is centred in the correct location. We can now simply move it in to 

location by editing the values. 

176 Ensure the workspace drop-down menu is set to Workplane and then 

change the X and Y Coordinates to Zero. 

 As we are aligning the Z Axis with the axis of the cylinder, the Z 

location is irrelevant this situation. 
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We currently have two separate surfaces that form the cut. To enable us to 

remove this area in one operation we can utilise the Create a Solid by Trimming 

Surfaces  to form an open solid. 

177 Select and Blank (Ctrl+J) the Main Solid. 

178 From the Selection Flyout  choose Quick Select ALL Surfaces.  

179 Go to Create Solid by Trimming Selected Surfaces  from the Solid 

 menu. 

180 In the Automatic Trimming dialog move the slider across to keep, this will 

allow you to control which areas are removed manually. 

 

Now, we can go around the model manually selecting areas to keep or remove 

in the popup dialog. 

181 Select each segment and choose Keep/Delete until the solid looks similar to 

below and then select OK to accept the solid and close the dialog. 
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182 Unblank (Ctrl+K) the main solid. 

183 Right-click and Reverse the new open solid. 

 

 The solid was reversed here because when we perform the Boolean 

Subtraction operation with an open solid, the area of the primary 

solid to the red side will be removed. 

184 Ensure the Main Block is the active solid. 

185 Select Boolean Subtraction  from the Solid Feature  menu. 

186 The Main Solid will automatically become the primary selection. Select the 

open solid as the secondary by clicking on it in the graphics area, and then 

click OK. 

 

 We have now created theis cut succesfully, all that remains to complete 

this section is the fillet around the top edge which we will perform 

later. 

187 Save the Model. 



PowerSHAPE Pro 2015 13 Reverse Engineering Demo Block 

13.49  Copyright @ Delcam 

 

 

A similar method as the previous cut will be used to create this feature. A 

number of plane primitive surfaces will be fitted and joined to form an open 

solid, then removed use the Boolean Remove function. 

 

Importantly, taking a look at the right hand side vertical wall of the cut 

(above), we can see that due to some missing data and the hole being ‘filled’ 

when the mesh was created, the wall is not quite vertical. We can solve this issue 

by Moving a copy of the surface we generate from the opposite wall. 

 

188 Select the mesh to activate the Mesh Edit toolbar and then select to Manually 

Segment Mesh.  

189 Choose to fit Plane Primitives and select the sloped face of the slot as shown 

below. 
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190 Select Preview and then when you are happy with the result, click the green 

tick to create the surface. 

 As before, initially the surface will be hidden as to not obstruct the area 

you are working on, however the area you have created a surface over 

will be shaded white. 

191 While you are still in the Manually Segment Mesh tool select the left hand 

side vertical wall and apply a primitive plane. 

 As this is near vertical, the plane will automatically be snapped 

vertical with respect to the Active Workplane. This is done using the 

alignment angle in Tools>Options>Objects>Mesh. Its default value is 

set to 1°, meaning any primitive created using these tools with an angle 

of less than 1° to a plane, will snap to the plane. This value can be 

changed to suit your data. 
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192 Click the red cross to close the form. 

193 Take a View from Top (Ctrl+5). 

 This view will allow us to determine whether or not, with the current 

settings, the vertical plane we expected to has snapped to the 

vertical. If the surface hasn’t, increase the alignment angle to around 

2-3°. 

 

To allow us to create a solid to remove from the main block we are going require 

the Create Solid from Untrimmed Surfaces function we used earlier. For this we 

need to resize the left vertical surface to reach the complete length of the cut 

and then offset a copy across 20mm to act as the right hand wall. 

194 Select the vertical surface in the graphics area and by clicking and 

dragging the edge increase its width to fully intersect the angled face of 

the mesh. 

 

195 Select the vertical plane surface and navigate to the General Edits  

menu and choose the Move  function. 

196 Select create a single copy. 
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197 In the graphics area dynamically click against to opposite vertical wall. 

This will show a preview of the new surface. 

198 Edit the Y coordinate to move a distance of -20mm. 

 We are editing the Y Coordinate due to the orientation of the active 

workplane. This also makes the X and Z component irrelevant. 

 

199 Next we need to reorientate the surfaces so the negative ‘red’ side of the 

surfaces are facing inwards. Right-click on the two surfaces that are 

currently in the opposite direction and select reverse. 
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200 Blank the Mesh (Ctrl+J). 

201 Quick Select ALL Surfaces.  

202 Select Create a Solid from Untrimmed Surfaces  from the Solid  

menu. 

203 As before, move the slider across to Keep and manually delete the parts of 

the faces we do not require for this open solid. 

 We are looking for an open channel similar to below. 

 

204 Unblank the Mesh (Ctrl+K). 

205 Turn OFF Level : 7 Mesh and Turn ON Level : 10 Main Solid. 

206 Ensuring the Main Solid is Active use the Boolean Subtraction  to 

create the cut. 
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We have successfully created the cut. We can check the dimensions using the the 

dimensioning tools located in the Annotation  toolbar. To finish this cut 

we will create the fillets later. 

207 Turn ON Level 7 : Mesh. 
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Creating the Organic Face 
We have completed most of the standard geometrical features on this part and 

now we need to focus on the organic formed faces and track on the right hand 

side of the model. 

Firstly, to avoid any of the next surface/solid operations interacting with the other 

parts of the solid model we will split the solid to isolate the particular area of 

interest, this in turn will make the process much easier. On this part we will split 

the solid at the step along the Y Axis direction.  

 

208 Turn OFF Level 7 : Mesh. 

209 Select an Isometric View (Ctrl+3). 

210 Select the solid and then Select Individual Faces  from the Solid Edit 

Toolbar. This will allow you to select and then edit the faces of the solid. 

211 Select the vertical face forming the raised step in the part, as shown in the 

below image. 

 

212 From the Solid Feature  menu select Split Solid.  
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 This will split the solid using the plane of the selected face. As you 

have already made the selection the dialog will not appear and the 

operation will automatically be completed. 

This operation has split the active solid into two separate solids. This has helped 

us to isolate the solid area of interest, while allowing us greater control of the 

area affected by further solid operations. 

213 Raise the Levels Dialog and Create a new Level 11 called “Spare Solids”. 

214 Select the left hand solid and place it on Level 11 : Spare Solids. 

215 Ensure Level 20 is switched OFF. 

216 Blank (Ctrl+J) the solid. 

217 Select the Mesh. Then select Smooth Mesh  from the Mesh Edit 

Toobar. 

 

 This tolerance is a distance which determines the nodes that are 

affected by the smoothing operation. 

218 Using a smoothing tolerance of 1, select Apply. 

 This has smoothed the mesh surface which will allow us to create 

smoother curves using the Oblique Curve function from the mesh. 

219 Change the Principal Axis to X. 

220 Select the mesh in the graphics area. 

221 From the Curve  menu select Create an Oblique Curve.  

 The Oblique Curve tool allows us to easily create multiple section 

curves through a selected mesh, solid or surface model. 

222 In the Oblique Curve dialog select Distance and enter and distance of 

135mm. 

 This is the offset distance from the Active Workplane down the 

Principal Axis (X) until the first section curve. 

223 In the section settings area of the dialog on the right hand side select a 

Number of 12 and a Step of 10mm. 

 This will create 12 section curves at a spacing of 10mm between each 

curve. 

224 Select Preview to see the curves, the select Apply. 
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225 Turn OFF the Level 7 : Mesh. 

226 Select an Isometric View (Ctrl+1). 
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The curve method will create the best fitting surface for this type of free form 

shape. We have taken 12 section curves across as much of the surface as 

possible to give as much data as possible to create the best surface.  

In this example we will need to edit and repoint each of the curves in order to 

then create a surface. As we know from the surfacing chapter these curves and 

curve keypoints will become the Longitudinal and Laterals curves within the 

surface. We also require the curves to have similar start/end point, have the 

same direction and number of keypoints. 

Firstly, we will trim the curves at the start and end points to remove unwanted 

data and produce even start and end points. 

227 Select a View from Top (Ctrl+5). 

228 Using a Single Line tool create a line that intersects (when viewed from 

above), and is perpendicular to the section curves slightly in from one end as 

shown in the diagram. 

 

We will use this line and the limit selection tool to trim all the section curves 

and provide a uniform curve start point. 

229 Ensure the Principal Axis is set to Z. 

230 From the General Edits  toolbar select Limit Selection.  

231 In the dialog select the Line as the Cutting Object and click the padlock to 

lock the cutting object. 

232 Next, from the furthest right hand flyout menu in the dialog select 

Workplane Project Mode.  

 

233 In the graphics area, select and limit the ALL section curves to this line. 

The workplane projection mode will limit using a plane created by the line 

and the principal axis. 

 By locking the Cutting Object we will not have to keep reselecting it for 

each limit. 

234 Once complete repeat this process for at the other end to create uniform 

curve end points. 

 At this end some of the curves may not reach the line towards the 

right hand edge of the part. Don’t worry, we will extend these later. 

235 Delete the two lines. 

We will now edit each section curve independently. In this example we will walk 

through two, and you can complete the others on your own. 
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236 From the Levels dialog, create a New Level 20 : Section Curves. For the 

moment leave it Switched OFF. 

237 Select ALL the section curves in the graphics area, while avoiding any 

noisy data. 

 Use the CTRL key to multi select. 

238 Place the curves on the Level 20 : Section Curves. They will disappear from 

view as the level is currently OFF. 

239 Select and Delete the noisy data from graphics area. 

240 Turn ON Level 20 : Section Curves. 

241 Select the first section curve in the graphics area and Blank Except 

(Ctrl+K). 

242 Take a View from Left (Ctrl+4). 

243 From the Curve Edit toolbar turn ON curve numbering.  

 This will show the direction and number of curve points. 

As this section has created a curve with good quality data, we can use this to 

help create the further curves. 

244 Zoom into the flat area of the curve. 

 

245 Select and Delete the curve points 32 – 37. 

 Your data may have different points and number of points. Therefore 

delete the points inbetween the change of direction onto the flat 

surface up to (not including) the end point. 

246 Select the end point and ensure the tangent is pointing directly towards the 

next point using the handles. 

 

247 Repeat the above step to ensure the second last point is directed toward 

the end point. This will create a straight line for the top area. 

248 From the Curve Edit toolbar select Repoint Curve.  
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249 In the dialog select 20 for the Number of points in range. Click Apply. 

 This will repoint the curve to have an evenly spread 20 points along 

the curve. We will use this as a standard on the rest of the curves which 

will then form a smooth surface. This value is dependent on many 

variables including the complexity and average length of the curves 

used, in this case 20 points as a first interation of the surface. 

We now need a new level to split our original (Level 20) and edited section 

curves.  

250 Raise the Level dialog and create a New Level 21 : Section Curves Edited. 

Click OK to create and close the dialog. 

251 Ensure Level 21 is Turned OFF. 

252 In the graphics area select the edited section curve and place it Level 21. 

253 Unblank (Ctrl+L). 

254 Select the next section curve to edit and Blank Except (Ctrl+K). 

 This will blank everything else from the graphics area except from the 

single section curve. 

255 Take a View from Left (Ctrl+4). 

256 Switch ON Level 21 so we can compare the two curves. 

In this case we are comparing the edited first section curve with the second 

one which we are editing. Firstly, we need to create the uniform flat area at the 

top of the face and then need to remove the unwanted data from the section 

curves create by the recess tracks on the formed face. 

Point 17 in the image on the edited curve shows where the change of direction 

from the flat onto the formed face occurs. Therefore we require a curve point at 

the nearest location on the second curve to flatten the top face area. 

 

257 Select the second curve, then from the Curve Edit toolbar choose to Create 

Point.  

258 In the dialog select Through Nearest Point and then in the graphics area 

select the location of Point 17 on the first curve, this should highlight as a 

Keypoint. 
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 Selecting this location has automatically filled the dialog X, Y and Z 

Values and a new point will be created at the position on the second 

curve closest to this location. 

259 Click Apply to create the point and then dismiss to close the form. 

 

As you can see the new point created (Point 78) is adjacent. This means we can 

now create the flat inbetween this point and then end of the curve, which will 

match the first curve. 

260 Select the second curve (the one we are currently editing) in the graphics 

area. 

261 From the Curve Edit toolbar select the Point Selector option.  

 We will now remove all the points inbetween 1 and 78 (these points 

may differ in your session. These points represent either end of the flat 

area we wish to create to match the first curve. 

262 Inside the dialog select the points 2 – 77. Holding the Shift key and then 2, 

then 77 will select the entire continuous region. Select OK. 

263 From the Curve Edit toolbar select Delete Points  to remove the 

selection of points. 

 

 



13 Reverse Engineering Demo Block PowerSHAPE Pro 2015 

Copyright @ Delcam  13.62 

 

Next we need to flatten the curve between this area (Point 1 and 2) using the 

tangent handles by selecting each curve point and snapping the handles to 

the opposing point, we will now go through this next. 

264 Select the first point and then its tangent handle, click and drag it, snapping 

it to the second point to direct the angle of the curve from the first point 

exactly towards the second point. 

 This single step may not straighten this part of the curve straight away. 

This is due to the tangent and magnitude from point 2 to point 1, 

which will will edit next. 

265 Repeat the above step from the second point to the first point (opposite to 

before). 

 

The next step in the process is to remove the control points defining the area 

created from the recess track on the mesh, this will be completed in a similar way 

as we have just done on the previous operations. 

266 Turn OFF Level 21 : Section Curves Edited. 

267 Select a View from Left (Ctrl+4). 

268 Zoom into the area where the curve drops into the track. 

 

We can see that Point 9 in this image is the last point before the curve drops 

down into the recess section, so we would remove Point 10 onwards. 

269 Repeat this procedure at the other end of this section of the curve to 

determine the final point we will remove. In the current session it can will be 

Point 61 although you should use your discretion to determine this figure. 

270 Using the Point Selector , select Points 10 through to Point 60. 
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271 From the Curve Edit toolbar choose to Delete the Selected Points.  

 

As you can see we have removed the unwanted data from the second section 

curve by deleting the keypoints. The shape of the curve where the recess 

track is formed in the mesh is not critical, however it is important that the 

curve flows to avoid sharp discontinuities in the surface. We will next repoint 

the curve to have the same number of points as the first section curve, and 

ensure the same direction. 

272 Select the curve and then Repoint Curve  from the Curve Edit toolbar. 

273 As before edit the Number of Points in Range to 20. Select Apply. 

274 Select the curve in the graphics area once again and place it on Level 21 : 

Section Curves Edited. 

275 Unblank (Ctrl+L) the orginal section curves. 

276 Turn OFF Level 20 : Section Curves and Turn ON Level 21 : Section 

Curves Edited. 

If we compare the direction (start point to end point) of the first two 

completeted section curves, you may see they are different. We will now 

reverse the direction to ensure they all follow the same route to produce a 

surface. 

277 If your curve is reversed, select the second curve in the graphics area and 

select Reverse the Direction  from the Curve Edit toolbar. 

 It is not important which direction the curves are for this example, as 

long as they are all the same. 

278 On your own using the knowledge you have gained attempt to edit and 

recreate the remaining curves in order the complete the curves for the 

surface. 

 Ensure all the curves start and end at the same location as the edited 

versions, have the same direction and have the same number of 

keypoints. 

 If the curves are not joined together, these can be joined using a 

Bezier Curve  from the Curve menu.  

279 Ensure ALL the section curves are on Level 21 : Edited Section Curves. 

280 Turn OFF Level 20. 
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281 Turn ON Level 7 : Mesh. 

 

Once we have completed ALL the curves, as shown above, we are now ready to 

create the surface using the Smart Surface tool, we will do this next. 

282 Turn OFF Level 7 : Mesh 

283 From the Selection Flyout choose Quick Select ALL Wireframe.  

284 Select the Smart Surface  tool from the Surface menu.  

 The selection of 12 section curves should automatically create a 

preview of a surface ‘from separate’. If not ensure you have the 

correct selection and all the curves are correct and try again. 

 

The surface has been created by joining the curve keypoints together to create 

Longitudinals and the curves themselves as the Laterals. 
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285 Turn ON Level 10 : Solid Model and Turn OFF Level 21. 

286 Select a View from Top (Ctrl+5). 

 

As you can see from the image above, as we create the section curves slightly 

inwards from each edge of the surface, it does not extend fully outside each 

edge/face of the solid. Next the Limit Point operation will be used to extend the 

required surface edges beyond the edges of the solid. 

The rectangular boss will be removed when we use the surface and a Boolean 

Remove tool if no action is taken. To avoid this we can use split solid to create 

two separate solids before the Boolean Remove operation, this will separate it 

from the solid we are working on, and then Add them both together again. 

287 Select the Solid and Blank Except (Ctrl+K). 

288 Select the top face of the solid, it should be highlighted as orange. 

 

289 With this face selected, navigate to the Feature  menu and select Split 

Solid.   

 As we have made the selection the solid will automatically split 

without raising the dialog. 

290 Select the rectangular boss and place it on Level 11 : Spare Solids with the 

other solid we have split earlier. 
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291 Unblank (Ctrl+L) to show the surface. 

292 Select the surface in the graphics area and then navigate to Point Limit 

within the General Edits menu.  

 

The orange ring attached to one of the surfaces edges links with the selected 

Edge in the dialog, whereas the distance is the distance to extend this selected 

edge by. 

293 Extend Edge 1 by a distance of 6mm by typing 5 into the distance box and 

pressing the Enter key. 

294 Repeat the above process for edges 2-4 using a distance of 6mm. 

 This has ensured that all the edges of the surface extend beyond the 

extremeties of the solid in order to use the surface in a Boolean 

Remove operation. This figured was used after trial and error 

 

295 Right-click on the surface and select Reverse. 
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 From earlier we know that when using a surface in a Boolean 

Subtraction operation the area of the solid to the red (inside) of the 

surface will be removed. 

296 Select Boolean Subtraction  from the Feature menu  using the 

Solid as the Primary Selection and the Surface as the Secondary Selection. 

 

We have created the main formed face of the part. To complete this area we need 

to create the track recess, we will do this next. 

The inner and outer curves to define the shape of the track will be created using 

a curve snapped to the mesh. 

297 Turn OFF Level 10 : Solid Model and Turn ON Level 7 : Mesh. 

298 From the Curve  menu select Create a Curve Snapped to a Mesh. 

 

On the inside and outside of the recess walls, we will track a curve snapped to 

the mesh to provide the outline of the shape. It is advisable to keep the curve 

close to the top of the walls where possible to allow for any draft angle on the 

walls, where varying the height of the curve up the walls will change to affect the 

shape of the curve. 

299 Track the curve by clicking around the walls, during this process your mouse 

and keyboard can be used to reorientate the view. 
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300 When almost complete, the curve can be closed and created to double 

clicking on the first point. 

 

301 Repeat the same process as above for the inner wall curve. 
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302 Switch to activate Workplane 1 from the workplane selector. 

303 Ensure the Principal Axis is set to Z. 

304 Select both curves forming the inner and outer wall profiles. 

305 From the Curve  menu, select Curve Projection.  

 

306 From the Curve Projection dialog select to project along the Principal Axis 

(Z). 

 

 This will project the 3D curves and create 2D profile curves on the 

Principal Plane of the current active workplane. 

307 Select and Delete the curves snapped to the mesh. 

308 On your own, Repoint  both curves with 50 points in range. 

To enable us to create an open solid to cut away the outer recess into the face 

we also need to shrink wrap a surface forming the shape of the bottom of the 

recess. 

309 Select a View from Top (Ctrl+5). 

310 Select the mesh to activate the Mesh Edit toolbar and raise the Manually 

Segment mesh dialog.  

311 In the Manually Segment mesh dialog select Shrink Wrap as the Type and 

leave the horizon angle setting at 20.0°. 

312 Select Preview in the dialog to preview the fit of the surface created. 

313 Click the green tick to create the surface, and then dismiss the form. 

314 Turn OFF Level 7 : Mesh. 

This should leave only the surface and two curves. Before we extrude the outer 

curve in order to create the solid shape we should ensure that the bottom face 

surface extends beyond where the extrusion will intersect. 
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The limit point function will enable us to extend the surface in each required 

direction. 

315 Right-click on the surface and convert it to a Power Surface. 

As each edge of the surface is at the limits of the curve we will extend each edge 

by 5mm to ensure the surface extends beyond the outer curve. 

316 Navigate to the General Edits  menu and select Limit Point  from 

the limits flyout menu. 

317 In the Limit Point dialog select each edge (1-4) in the drop down menu and 

then choose to extend each edge individually by 5mm by pressing the Enter 

key. 

 

 



PowerSHAPE Pro 2015 13 Reverse Engineering Demo Block 

13.71  Copyright @ Delcam 

 

 Once each edge has been extended you should notice that, when taking 

a View from Top (Ctrl+5) the surface extends beyond the profile of the 

outer curve. 

Next we will extrude both profile curves as surfaces through the shrink wrap 

surface and use the Create Solid from Untrimmed Surfaces function to create 

an ‘open’ solid to cut out the recess in the face. 

318 Ensure the Principal Axis is set to Z. 

319 Select the outer profile curve in the graphics area. 

320 From the Surface  menu select Surface Extrusion.  

321 Extrude the surface down Z through completely through the shrink-wrap as 

shown in the below image. A length of 40mm will suffice. 

322 Right-click and Reverse the Shrink Wrap surface as it will be the area to the 

red (negative) side that will be removed. 

 

323 Repeat the same procedure with the inner profile curve. Reverse this 

surface if necessary to look similar to the below image. 
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As we have three separate untrimmed surfaces that will form the shape, we 

need to combine them into one complete surface. 

324 Select ALL (3) the surfaces. 

325 Navigate to the Solid  menu and select the option to Create Solid by 

Trimming Surfaces.  

326 Once you are happy with the ‘open’ solid created select OK in the dialog to 

create the shape. 

 The solid shape should look similar to below. You may have to move 

the slider to ‘keep’ and then manually select and delete each 

unwanted segment independently. This will help us because we can 

use what is effectively 3 separate surfaces as one complete object. 

 

327 Turn ON Level 10 : Solid Model. 

328 From the Solid Feature  menu select Boolean Subtraction.  

329 Select the main block as the Primary Selection and the open solid cutter as 

the Secondary Selection. Click OK. 
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 The Boolean Subtraction has been completed to create the track into 

the formed face of the part. Next we need to add together the separate 

solids to form one complete solid using the Boolean Addition tool. 

330 Turn ON Level 11 : Spare Solids. 

331 From the Selection  flyout choose to Quick Select ALL Solids.  

332 Select Boolean Addition  from the Feature menu.  Select OK in 

the dialog. 

333 Select the solid and ensure the Solid History tree  is shown. 

 

 We have now combined all the solids into one complete block. 
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334 Ensure the solid model is placed on Level 10 : Solid Model. 

335 Turn OFF Level 10 : Solid Model and Turn ON Level 7 : Mesh.  

 

336 On your own use a shrink wrap surface along with the knowledge you have 

gained throughout this example to remove this formed corner from the rear 

of the part. 

Finishing the Part (Fillets and Chamfers) 

 

To finish the model we can create any additional required fillets and chamfers 

using the solid feature operations. 

337 Ensure Workplane 1 is Active from the workplane selector. 

338 Turn OFF Level 10 : Solid Model and Turn ON Level 7 : Mesh. 

339 Select View>Dynamic Sectioning and within the dialog choose to take a 

section Around Z and then using the back plane slider choose an angle of 

315° and create wireframe. 

340 Select and Blank (Ctrl+J) the mesh. 
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341 Using a 3 point arc  from the Arc  menu measure the fillet radius 

from the cut at the lower left hand corner wireframe. You should get a value 

close to 10.00mm. 

 

Using the same dynamic sectioning method down the Y Axis we can also 

measure the 5mm fillets and 5mm chamfer in the location shown below. 

 

 

342 Create the features decribed above from the Solid Feature  menu. 
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