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FeatureCAM issues a major enhancement release in September, 
January, and May every year. For details of our developments in the 
last twelve months, see: 

What's New in FeatureCAM 2015 R3 (see page 2) 

What's New in FeatureCAM 2015 R2 (see page 36) 

What's New in FeatureCAM 2015 R1 (see page 79) 

Also, visit our website at http://www.delcam.tv/lz/ for up-to-the-
minute news and videos; and visit http://updates.delcam.com to 
download our latest service packs and enhancements. 

 

What's New 
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FeatureCAM 2015 R3 contains the following new features and 
enhancements: 

User interface 
 Improved icons (see page 5) — Several icon graphics across 

FeatureCAM have been updated. 

 Selecting objects (see page 6) — There is a new Select Partial 
mode. 

 Inserting Part Library features (see page 7) — You can now use 
the New Feature wizard to insert Part Library features into a 
document. 

 Pasting features using polar coordinates (see page 9) — You can 
now use polar coordinates to locate features in the Paste Special 
wizard. 

 Deleting unused curves (see page 10) — There is a new add-in 
that you can use to identify all unused curves in a model and 
delete them. 

Importing 
 Importing SolidWorks 2015 files (see page 12) — You can now 

import SolidWorks 2015 files into FeatureCAM. 

 Importing SolidEdge ST7 files (see page 13) — You can now 
import SolidEdge ST7 files. 

What's new in 
FeatureCAM 2015 R3 
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Milling 
 Creating Faces features using IFR (see page 15) — You can now 

automatically round the corners of Face features that are created 
using Interactive Feature Recognition. 

 Automatic tool selection (see page 17) — You can now specify an 
additional clearance on the automatic tool selection to ensure the 
tool holder does not collide with the stock. 

 Simulating tool holders (see page 19) — You can now simulate 
complicated tool holders more accurately. 

 Machine movement limits (see page 20) — You can now display a 
warning message when the machine exceeds its limits of 
movement during machine simulation. 

Turning and Turn/Mill 
 Indexing using a stock solid (see page 23) — You can now 

calculate the index height directly from the stock solid, instead of 
calculating it above a square bounding box. 

 Setting the program point for turnmilling tools (see page 25) — You 
can now specify the program point for turnmilling tools. 

5-axis machining 
 C-axis indexing (see page 27) — You can now specify the C-axis 

position of the part in the machine at the start of an operation. 

 5-axis engraving (see page 29) — You can now create 5-axis 
engraving features with the tool axis normal to the surface. 

Machine Design 
 Specifying machine movement limits (see page 32) — You can now 

set the limits of movement for solids in a Machine Design file. 

 Testing machine movements (see page 33) — You can now use 
machine jogging to simulate the movement of solids in a Machine 
Design document without having to use an FM file. 

 Simulating mini-turrets (see page 35) — You can now simulate 
mini-turrets, which are tools with multiple inserts where the tool 
rotates around the b-axis to access each tool. 
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User Interface 
FeatureCAM 2015 R3 contains the following changes and 
improvements to the user interface: 

 Improved icons (see page 5) — Several icon graphics across 
FeatureCAM have been updated. 

 Selecting objects (see page 6) — There is a new Select Partial 
mode. 

 Inserting Part Library features (see page 7) — You can now use 
the New Feature wizard to insert Part Library features into a 
document. 

 Pasting features using polar coordinates (see page 9) — You can 
now use polar coordinates to locate features in the Paste Special 
wizard. 

 Deleting unused curves (see page 10) — There is a new add-in 
that you can use to identify all unused curves in a model and 
delete them. 
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Improved icons 
Several icon graphics across FeatureCAM have been updated to 
improve the user interface, including: 

 Feature Properties dialog 
 Part View 
 Part Library 

 Tombstone Process Plan dialog 
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Selecting objects 
There is a new Select Partial mode, which enables you to box-select 
items by partially selecting them. This improves work-flow when 
selecting multiple items, and enables you to select items more 
easily in complicated documents. 

To enable the new Select Partial mode: 

 In the Standard toolbar, in the Select Menu, select Select Partial. 

 
 Select the Edit > Select > Box Select Partial menu option. 

Click and drag to select objects. You do not need to enclose an 
object to select it. In the example below, all three features are 
selected: 
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Inserting Part Library features 
You can now use the New Feature wizard to insert Part Library 
features into a document. 

Adding features to the Part Library 
To add a feature to the Part Library: 

1 Select the Construct > Part Library menu option. 

The Part Library dialog is displayed. 

2 Select a feature in the Tree View or graphics window. 

3 In the Part Library dialog, click Add Selected. 

The selected feature is added to the list in the Part Library dialog. 

4 Click OK to close the dialog. 
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Inserting features from the Part Library into the document 
To use the Part Library in the New Feature wizard: 

1 Click the Features  step in the Steps panel to display the New 
Feature wizard. 

2 In the New Feature wizard, under From Feature, select User and 
click Next. 
The User defined feature page is displayed. 

The Part Library features are displayed in the Registered features 
list. 

 
3 Select a feature in the list and click Next. 

The Paste Special dialog is displayed. 

4 Use the Paste Special dialog to insert the selected feature into 
the document, then click Finish to close the dialog. 

5 The User defined feature page of the New Feature wizard is 
displayed. 

6 Use the wizard to insert more features from the Part Library, or 
click Cancel to close the wizard. 
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Pasting features using polar coordinates 
You can now use polar coordinates to locate features in the Paste 
Special wizard. This gives you more control when duplicating 
features and when using the Part Library. 

 You can only use polar coordinates to locate individual 
features. 

To duplicate a feature into a new location using polar coordinates: 

1 Right-click a feature in the Part Tree, and select Copy. 

2 Select the Edit > Paste Special menu option. 

The Paste Special wizard is displayed. 

3 Select Paste the clipboard contents. Select a new location and click 
Next. 
The Reference page of the Paste Special wizard is displayed. 

4 Click Next. You do not need to specify a reference location. 

The Location page of the Paste Special wizard is displayed. 

5 Select the new Polar option. 

 
6 Enter the Radius and Angle to offset the new feature from the 

setup location. 

7 Enter the Z value to specify the Z height of the feature above the 
setup. 

8 Click Preview to display a preview of the new feature in the 
graphics window. 

9 Click Finish to create the new feature and close the wizard. 
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Deleting unused curves 
There is a new delete_curves.bas add-in that you can use to identify 
all unused curves in a model and delete them. 

To delete all unused curves in a document: 
1 Load the delete_curves.bas add-in using the Macro Add-ins dialog. 

2 In the Utilities toolbar, click deletecurves. 

3 The Curve Information dialog is displayed, which contains a list of 
unused curves in the document. 

4 Click OK to delete all unused curves and close the dialog. 

 



 

FeatureCAM 2015 R3 What's New What's new in FeatureCAM 2015 R3 • 11  

Importing 
FeatureCAM 2015 R3 contains these changes and improvements to 
importing files from external applications: 

 Importing SolidWorks 2015 files (see page 12) — You can now 
import SolidWorks 2015 files into FeatureCAM. 

 Importing SolidEdge ST7 files (see page 13) — You can now 
import SolidEdge ST7 files. 
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Importing SolidWorks 2015 files 
You can now import SolidWorks 2015 files into FeatureCAM. 

To import a SolidWorks file: 

1 Select the File > Import menu option. 

The Import dialog is displayed. 

2 Browse to the folder containing the file you want to open. 

3 In the Files of type list, select SolidWorks (*.sldprt;*.sldasm). 
Only SolidWorks documents are displayed in the Import dialog. 

4 Select a file to display a preview image on the right of the dialog. 

5 Click Open to import the file and close the dialog. 

The Import Results wizard is displayed, which you can use to 
specify the setup location and stock size, and to recognize 
features. 
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Importing SolidEdge ST7 files 
You can now import SolidEdge ST7 files. 

To import a SolidEdge file: 

1 Select the File > Import menu option. 

The Import dialog is displayed. 

2 Browse to the folder containing the file you want to open. 

3 In the Files of type list, select SolidEdge (*.par;*.psm:*.asm). 
Only SolidEdge files are displayed in the Import dialog. 

4 Select a file to display a preview image on the right of the dialog. 

Click Open to import the selected file and close the dialog. 

The Import Results wizard is displayed, which you can use to 
specify the setup location and stock size, and to recognize 
features. 
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Milling 
FeatureCAM 2015 R3 contains these changes and improvements to 
Milling: 

 Creating Face features using IFR (see page 15) — You can now 
automatically round the corners of Face features that are created 
using Interactive Feature Recognition. 

 Automatic tool selection (see page 17) — You can now specify an 
additional clearance on the automatic tool selection to ensure the 
tool holder does not collide with the stock. 

 Simulating tool holders (see page 19) — You can now simulate 
complicated tool holders more accurately. 

 Machine movement limits (see page 20) — You can now display a 
warning message when the machine exceeds its limits of 
movement during machine simulation. 
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Creating Face features using IFR 
You can now automatically round the corners of Face features that 
are created using Interactive Feature Recognition. 

This enables you to use a Face feature instead of a Side feature in 
some situations, which can reduce the machining time by reducing 
air cutting. This is especially useful when using cutter compensation 
and partline programming. 

  

In the example below, a Face feature is created on the orange 
surface, and a deburr radius is applied to round the outside corners 
of the feature during machining: 

 
 

To specify a corner radius for a Face feature: 

1 Create a Face feature using Interactive Feature Recognition. 

2 In the Face Properties dialog, in the Misc tab, select one of the 
new options. 
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Use the Deburr radius option to round the outside corners of the 
feature. 

Use the Min corner radius option to round the inside corners of 
the feature. 

3 In the New Value field, enter a new value and click Set to override 
the selected option. 

4 Click OK to accept your changes to the feature and close the 
dialog. 

 For Face features with multiple operations, you can set the 
Min. corner radius option separately for the rough operation 
and for each finish pass. 
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Automatic tool selection 
In FeatureCAM 2015 R2, the Tool Holder Clearance dialog (see page 
49) was added, which enables you to specify an additional clearance 
on the automatic tool selection to prevent tool holder gouges. 

There is a new Stock option in the Clearance Requirement list. Select 
this option to ensure the tool is long enough for the tool holder to 
clear the total depth into the stock. 

 
 
No additional clearance: Clearance above the stock: 
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To specify a tool holder clearance above the stock for automatic tool 
selection: 

1 Select the Manufacturing > Machining Attributes menu option to 
display the Machining Attributes dialog. 

2 On the Tool Selection tab of the Machining Attributes dialog, click 
Tool Holder Clearance. 

The new Tool Holder Clearance dialog is displayed. 

3 In the Clearance Requirement list, select Stock. 

4 Click OK to close the dialog. 
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Simulating tool holders 
You can now simulate complicated tool holders more accurately. 
This enables you to create better toolpaths that can access more 
material and check for gouges more accurately when using 
automatic tool holder clearance. 

Previously, the shape of the tool holder was approximated using 
either a cylinder or a cone. 

The tool holder shape does not take into account undercuts, for 
example: 
If the tool holder has this 
curve: 

The toolpaths are 
calculated with this tool 
holder shape: 
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Machine movement limits 
You can now display a warning message when the machine exceeds 
its limits of movement during machine simulation. 

There is a new Pause on limits option in the 2D/3D Shaded tab of the 
Simulation Options dialog. Select this option to pause the machine 
simulation if the machine moves outside the limits specified in the 
MD file. 

 
A new message dialog is displayed when the machine moves 
outside the specified limits. 

 
The Outside of Limits message dialog displays: 

 The solid name that has exceeded its limits. 

 The axis of movement. 

 The specified limit. 

 The solid's current position. 
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You can select these options in the Outside of Limits message 
dialog: 

 Don't pause for this solid again — Select this option to continue 
the machine simulation without pausing when this solid exceeds 
its limits. 

 Don't pause on limits again — Select this option to run machine 
simulations without pausing when any solids exceed their limits. 
This is the same as deselecting Pause on limits in the Simulation 
Options dialog. 

To specify a machine's limits of movement (see page 32), you need 
to edit the Machine Design file. 
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Turning and Turn/Mill 
FeatureCAM 2015 R3 contains these changes and improvements to 
Turning and Turn/Mill: 

 Indexing using a stock solid (see page 23) — You can now 
calculate the index height directly from the stock solid, instead of 
calculating it above a square bounding box. 

 Setting the program point for turnmilling tools (see page 25) — You 
can now specify the program point for turnmilling tools. 
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Indexing using a stock solid 
You can improve machining times for turn/mill parts with stock 
solids by reducing the distance above the part at which the tool 
indexes. There is a new Calculate index radius from solid stock outline 
option that enables you to calculate the index height directly from 
the stock solid, instead of calculating it above a square bounding 
box: 

  
Calculate index radius from 
solid stock outline off: 

Calculate index radius from solid 
stock outline on: 

 
 — Distance to bounding 

box 
 — Z rapid level attribute 

value 

 
 — Distance to stock boundary 
 — Z rapid level attribute value 
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The new option is displayed on the Misc tab of the Machining 
Attributes dialog. 
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Turnmilling program point 
You can now specify the program point for turnmilling tools. This 
enables you to touch-off the tool at the edge, and specify the insert 
radius compensation at the machine instead of in FeatureCAM. 
Previously, this option was available for turning tools only. 

In the Machining Attributes dialog, on the Misc tab, select an option 
under Turnmilling program point: 
 Tool tip edge — Select this option to adjust the tool program 

point by the tool radius in the NC code. 

 Tool tip center — Select this option to adjust the tool program 
point by the tool radius at the machine. 

 
This option does not affect turnmilling tools that are used for 
milling. 

To use a turnmilling tool, select the Turnmilling option in the 
Strategy tab of the Feature Properties dialog for a Turn feature. 
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5-axis machining 
FeatureCAM 2015 R3 contains these changes and improvements to 
5-axis machining: 

 C-axis indexing (see page 27) — You can now specify the C-axis 
position of the part in the machine at the start of an operation. 

 5-axis engraving (see page 29) — You can now create 5-axis 
engraving features with the tool axis normal to the surface. 
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C-axis indexing 
You can now specify the C-axis position of the part at the start of an 
operation. This is useful for large parts where the machine has 
limited travel, or to prevent machine collisions. 

There is a new Orientation angle option in the Milling or Drilling tab 
of the Feature Properties dialog. 

 
Use this option to specify the rotation of the X and Y axes about the 
Z-axis. This option only applies if the machine tool starts at the 
singularity (where the machine tool's Z-axis is aligned with the 
setup's Z-axis). 

If the machine tool is not at the singularity, you can specify the C-
axis orientation using these methods: 

 Use the Alternative 5-axis position option to specify a C-axis 
orientation of either 0 or 180 degrees. 

 Use the Use Origin of this Setup as the Touch-off Point option in the 
5 Axis Fixture Location dialog. This method applies the C-axis 
orientation to all setups in the part, instead of to individual 
operations. 
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For example: 
With an orientation angle of 
0, the groove is cut in the 
machine's Y direction. 

With an orientation angle of 
90, the groove is cut in the 
machine's X direction. 
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5-axis engraving 
The 5-Axis tab of the Feature Properties dialog is now available for 
2d spiral operations, which you can use to create 5-axis engraving 
features. This enables you to use a tool axis angle normal to the 
surface to ensure the engraving has a uniform cross-section and 
depth of cut. 

 
To create a 5-axis surface engraving feature: 

1 Create a surface below the stock boundary to determine the 
depth of the engraving, for example: 
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2 Create the curve to define the shape of the engraving feature, 
for example: 

 

 You can use the Construct > Curve > From Surface > Project 
onto Surface menu option to project a curve onto a surface. 

3 Create a surface milling feature with a 2D spiral operation. 

4 Double-click the feature in the Part View to display the Feature 
Properties dialog, and select spiral2d in the Tree View. 

5 On the Stock tab, under Choose the drive curve, select Select 
curves for boundaries and click Curve Options. 

The Boundary Curve dialog is displayed. 

6 Under Boundary curve type, select Wall only. 

This creates a toolpath along the curve. 

7 Under Boundary curves, click Boundaries. 

The Select Boundary Curves dialog is displayed. 

8 Select the curve that defines the shape of engraving, and click 
OK to close the Select Boundary Curves dialog. 

9 Click OK to close the Boundary curves dialog. 

10 On the 5-Axis tab, select Use Lead and Lean, and in the from list, 
select Contact normal. 
This keeps the tool axis normal to the surface. 

11 Click OK to close the Feature Properties dialog. 
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Machine Design 
FeatureCAM 2015 R3 contains these changes and improvements to 
Machine Design: 

 Specifying machine movement limits (see page 32) — You can now 
set the limits of movement for solids in a Machine Design file. 

 Testing machine movements (see page 33) — You can now use 
machine jogging to simulate the movement of solids in a Machine 
Design document without having to use an FM file. 

 Simulating mini-turrets (see page 35) — You can now simulate 
mini-turrets, which are tools with multiple inserts where the tool 
rotates around the b-axis to access each tool. 
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Specifying machine movement limits 
You can now set the limits of movement for solids in a Machine 
Design file. This gives you more control of machine simulations, and 
enables you to ensure the machine does not move beyond its limits 
during a simulation. 

To specify the limits of movement for a solid: 

1 In a Machine Design document, select the Machine Design > 
Specify Movement menu option. 

The Specify Movement dialog is displayed. 

2 Use the Specify Movement tab to select a solid and specify how it 
can move. 

3 Use the new Specify Limits tab to specify the Home Position and 
the linear and rotational limits of movement for the selected 
solid. 

 
4 Click OK to close the dialog. 

FeatureCAM can display a warning if a solid exceeds these limits 
during machine simulation (see page 20). 

 There are several new example MD files that have limits of 
movement set. These are located in 
\FeatureCAM\Examples\Machine Design\Axis Limits. 
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Testing machine movements 
You can now use machine jogging to simulate the movement of 
solids in a Machine Design document without having to use an FM 
file. This enables you to test the movement and ensure the limits 
are set correctly. 

To use machine jogging to test machine movements: 

1 Save any changes to your MD document. 

Any unsaved changes to the document are not displayed in the 
jogging simulation. 

2 Select the Machine Design > Jog Machine menu option. 

The new Jog Machine dialog is displayed. 

 
Each row displays an axis in which solids in the document can 
move. 

3 Select a solid in the list next to an axis name. 

The list is unavailable if there is only one solid that can move in 
that axis. 
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4 For the selected solid, move the slider between the minimum 
limit and the maximum limit. 

The solid's current position is shown in the middle field, and the 
solid's movement is simulated in the graphics window. 

 You can set the limits and home positions of the solids 
using the Specify Movement dialog (see page 32). 

5 To hide solids in the jogging simulation, click Select  in the 
Standard toolbar, then click solids in the graphics window. 

6 To return all solids to their default positions, click Reset All. 
7 When finished, close the dialog. The jogging simulation is 

cleared, and all solids are returned to their default positions. 
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Simulating mini-turrets 
You can now simulate mini-turrets, which are tools with multiple 
inserts where the tool rotates around the b-axis to access each 
insert. This enables you to create a more flexible tooling setup and 
perform faster tool changes. The tools are simulated 
simultaneously, which enables you to check for gouges with the 
tools that are not currently in use. 

 
To simulate a mini-turret: 

1 In the Machine Design file, create a solid and UCS to represent 
the mini-turret. The X-axis of the UCS must point towards the 
main spindle. 

2 Create a UCS for each tool location. The difference between the 
X-axis of the tool location and the turret UCS determines the 
angle that the mini-turret is rotated to use the tool. 

3 In the Tool Block dialog: 

a Select the turret solid under This solid is a tool block for solids. 

b Select the turret UCS under This UCS will match up with the tool 
location on the turret. 

c Use the Tool Locations tab to add each tool location UCS as a 
separate sub slot in the tool block. 

d Click OK to close the dialog. 

4 Save the Machine Design file. 

5 In the FM document, use the Tool Mapping dialog to specify 
which tool block to use for each feature. 

 



 

36 • What's new in FeatureCAM 2015 R2 FeatureCAM 2015 R3 What's New  

FeatureCAM 2015 R2 contains the following new features and 
enhancements: 

User interface 
 Changing the point size (see page 40) — You can now change the 

size of geometry point objects to make them easier to see. 

 Customizing the snapping cursor (see page 41) — You can now 
change the size and color of the snapping cursor. 

 Measuring curve length (see page 42) — You can now find the 
length of curves and geometry segments. 

 Creating internal gears (see page 43) — You can now perform 
analysis on internal gears curves. 

 Combining solids (see page 44) — You can now combine multiple 
solids. 

 Hiding rapid moves in centerline simulations (see page 45) — You 
can now hide rapid moves in centerline simulations. 

 Chip recognition size (see page 46) — You can now specify the 
size at which detached pieces of stock are considered to be chips 
and hidden from simulation. 

 Recognizing features on large parts (see page 47) — IFR now 
works more quickly for large parts. 

Milling 
 Automatic tool selection (see page 49) — You can now specify an 

additional clearance on the automatic tool selection to prevent 
tool holder gouges. 

What's new in 
FeatureCAM 2015 R2 
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 Vortex approaches flats from outside stock (see page 51) — Vortex 
toolpaths can approach flat areas from outside of stock instead of 
always ramping into it. 

 Output options for 2D NT toolpaths (see page 53) — The Output 
Options dialog is now available for 2D toolpaths that use NT or 
Vortex stepover types. 

 Previewing the toolpath point distribution (see page 55) — You can 
now preview the points of a surface milling toolpath to help with 
editing the point distribution. 

 Tool pecking depths (see page 56) — You can now specify the 
pecking depths for individual tools. 

 Changing the posting tolerance (see page 57) — You can now 
create more precise toolpaths, which is useful for machining 
small parts. 

 Helical side finish (see page 58) — Helical side finish operations 
are now machine at the feed rate, instead of the plunge feed 
rate. 

Turning 
 Removing undercuts in no-drag turning features (see page 60) — 

You can now remove undercuts in no-drag turning features to 
prevent gouges and simplify toolpaths. 

 Controlling steady rests (see page 61) — You can now open and 
close the jaws of a steady rest without moving it to the home 
position. 

 Simulating bar stock (see page 63) — You can now simulate bar 
stock in FeatureCAM by specifying the length of the stock 
displayed in simulation. 

 Custom turret names (MTT) (see page 64) — You can now use 
customized turret names to make FeatureCAM more consistent 
with your machine. 

XBUILD 
 Generating Post documentation (see page 65) — You can now 

output your CNC data file as HTML or XML to make it 
understandable. 

 Using macros in the post processor (see page 66) — The Disable 
Macros option in the Post Options dialog is now selected by 
default. 

Add-ins and extensions 
 Using Setup Sheets (see page 68) — There are new tags which 

you can use to create more detailed setup sheets. 
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 FeatureCAM to CAMplete TruePath add-in (see page 69) — You can 
export documents to CAMplete TruePath, which you can use to 
analyze, modify, optimize, simulate and post 5-Axis toolpaths. 

 Probing update options (see page 71) — When creating probing 
features, you can now select multiple update options, which 
enables you to perform multiple actions from a single probing 
cycle. 

 Support for Microsoft SQL 2014 (see page 71) — FeatureCAM now 
supports Microsoft SQL server 2014. 

Machine Simulation Design 
 Multi-tool blocks (see page 73) — You can now create multi-tool 

blocks and double-sided tool blocks in Machine Design files and 
use them in machine simulations. 

 Selecting the tool block (see page 76) — You can now select 
which tool block holds each tool within an FM file, which enables 
you to create accurate machining simulations more easily. 

 Protecting Machine Design documents (see page 78) — You can 
protect your Machine Design files from the extraction of solids, 
so that you can share them for simulation without anyone being 
able to extract the solids. 
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User Interface 
FeatureCAM 2015 R2 contains the following changes and 
improvements to the user interface: 

 Changing the point size (see page 40) — You can now change the 
size of geometry point objects to make them easier to see. 

 Customizing the snapping cursor (see page 41) — You can now 
change the size and color of the snapping cursor. 

 Measuring curve length (see page 42) — You can now find the 
length of curves and geometry segments. 

 Creating internal gears (see page 43) — You can now perform 
analysis on internal gears curves. 

 Combining solids (see page 44) — You can now combine multiple 
solids. 

 Hiding rapid moves in centerline simulations (see page 45) — You 
can now hide rapid moves in centerline simulations. 

 Chip recognition size (see page 46) — You can now specify the 
size at which detached pieces of stock are considered to be chips 
and hidden from simulation. 

 Recognizing features on large parts (see page 47) — IFR now 
works more quickly for large parts. 
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Changing the point size 
You can now change the size of geometry point objects to make 
them easier to see. 

To change the point size: 

1 Select the Options > Viewing menu option. 

The new Point size option is displayed in the Viewing Options 
dialog. 

 
2 Enter a Point size to specify the size of geometry point objects in 

the graphics window. 

3 Click OK to close the dialog. 
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Customizing the snapping cursor 
The snapping cursor shows you which object you are snapping to. 
You can now change the size and color of the snapping cursor to 
improve work flow when working with large, small or complex parts. 

To change the size of the snapping cursor: 

1 Select the Options > Viewing menu option. 

The new Snapping Point Size option is displayed in the Viewing 
Options dialog. 

 
2 Enter a Snapping Point Size to specify the size of the snapping 

cursor in the graphics window. 

3 Click OK to close the dialog. 

  

To change the color of the snapping cursor: 

1 Select the Options > Coloring > Default Colors menu option. 

The Default Colors dialog is displayed. 

2 Select Highlight in the list. 

3 Click More Colors to display the Color dialog. 

4 Select a color and click OK to close the dialog. 

The selected color is displayed in the Default Colors dialog. 

5 Click Apply to apply the color to the selected item. 

6 Click Done to close the dialog. 
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Measuring curve length 
You can now find the length of curves and geometry segments, 
which enables you to find important dimensions of complicated 
shapes easily. 

 
To find the length of a curve: 

1 Select the Construct > Dimension > Interrogation menu option. The 
Pick Dimension dialog is displayed. 

2 Under Pick type, select the new Length option. 

 

3 Click Pick Location  and select the curve you want to measure 
in the graphics window. 

The length of the selected curve is displayed in the Pick value 
field. 

4 To measure another curve, repeat the previous step. 

5 When you have finished, click OK to close the dialog. 

 



 

FeatureCAM 2015 R3 What's New What's new in FeatureCAM 2015 R2 • 43  

Creating internal gears 
In FeatureCAM 2015 R1, the Analysis tab was added to the Gears 
dialog (see page 96), which enables you to view the calculated 
dimensions of the gear, the calculated pin gauge diameter and the 
outside measurement over pins diameter. In FeatureCAM 2015 R2, 
the Analysis tab has been extended to enable you to find the 
measurement over pins value of an internal gear. 

 
To create and analyze an internal gear curve: 

1 Select the Construct > Curve > Other Methods > Gears menu 
option. 

The Gears dialog is displayed. 

2 In the Curve tab, specify the properties of the gear. 

3 Select the Analysis tab. 

The calculated dimensions of the gear are displayed under 
General calculations. 

4 Under Measurement over pins (MOP), select Internal Gear. 
The Ideal pin diameter and MOP ideal values are displayed. 

5 Enter the Actual pin diameter and click Recompute. 

The calculated measurement over pins value is displayed in the 
MOP actual field. 

6 Click OK to close the dialog. 
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Combining solids (SOLID) 
You can now combine multiple solids in different ways to create 
complicated shapes more easily. Previously, you could combine only 
two solids at once. 

 
To combine solids: 

1 Select the Construct > Solid > Modifiers > Combine solids menu 
option. 

The Combine Solids dialog is displayed. 

 This dialog was previously called the Boolean dialog. 

2 Enter a New solid name. 

3 Select an Operation: 

 Difference — Subtract a solid from another solid. You can 
combine only two solids with this operation. 

 Union — Merge multiple solids together. 

 Intersection — Create a solid at the intersection of multiple 
solids. 

4 Add the solids you want to combine: 

 To add a solid by name, select it in the Solid list and click Add 
item from list . 

 To add solids graphically, click Pick solid  and select them 
in the graphics window. 

5 Click OK to close the dialog. 
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Hiding rapid moves in centerline simulations 
You can now hide rapid moves in centerline simulations. This 
enables you to see the cutting moves more clearly in complicated 
toolpath simulations. 

  
Rapid moves shown: Rapid moves hidden: 

  

To hide rapid moves in centerline simulations, deselect the View > 
Simulation > Show Centerline Rapids menu option. The next time you 
run a centerline simulation, rapid moves are not displayed. 
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Chip recognition size 
You can now specify the size at which detached pieces of stock are 
considered chips and hidden from simulation. 

There is a new Chip recognition size option on the Round Stock tab 
of the Simulation Options dialog. 

 
For parts with large stock, you may want to reduce this value to 
ensure cutoffs are not hidden. 
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Recognizing features on large parts 
Interactive Feature Recognition (IFR) now works more quickly on 
large parts. 

Previously, IFR would validate the solid when recognizing features, 
which could take a long time for large parts. 

To verify that a solid is valid, select the solid in the Automatic 
Feature Recognition dialog and click Verify. 
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Milling 
FeatureCAM 2015 R2 contains the following changes and 
improvements to Milling: 

 Automatic tool selection (see page 49) — You can now specify an 
additional clearance on the automatic tool selection to prevent 
tool holder gouges. 

 Vortex approaches flats from outside stock (see page 51) — Vortex 
toolpaths can approach flat areas from outside of stock instead of 
always ramping into it. 

 Output options for 2D NT toolpaths (see page 53) — The Output 
Options dialog is now available for 2D toolpaths that use NT or 
Vortex stepover types. 

 Previewing the toolpath point distribution (see page 55) — You can 
now preview the points of a surface milling toolpath to help with 
editing the point distribution. 

 Tool pecking depths (see page 56) — You can now specify the 
pecking depths for individual tools. 

 Changing the posting tolerance (see page 57) — You can now 
create more precise toolpaths, which is useful for machining 
small parts. 

 Helical side finish (see page 58) — Helical side finish operations 
are now machine at the feed rate, instead of the plunge feed 
rate. 
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Automatic tool selection 
You can now specify an additional clearance on the automatic tool 
selection to prevent tool holder gouges. 

  
No additional clearance: Clearance above the Setup: 

  

To specify a tool holder clearance for automatic tool selection: 

1 Select the Manufacturing > Machining Attributes menu option to 
display the Machining Attributes dialog. 

2 On the Tool Selection tab of the Machining Attributes dialog, click 
Tool Holder Clearance. 

The new Tool Holder Clearance dialog is displayed. 
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3 In the Clearance Requirement list, select the clearance you want 
between the tool holder and the part. Select from: 

 None — Select this option to leave no additional clearance. 
Old part files still select the same tools as before. 

 Feature — Select this option to ensure the tool is long enough 
for the tool holder to clear the feature. 

 Setup — Select this option to ensure the tool is long enough 
for the tool holder to clear the total depth into the setup. 

4 Enter an Extra allowance as a % of feature or setup depth to leave 
extra clearance of the tool holder above the feature or Setup. 

5 Select how tool selection is affected if no matching tool is found: 

 Give an error if no tool meets requirements — FeatureCAM does 
not select a tool for the operation, so an error is shown during 
NC code generation. In the Operation List, a red exclamation 
point  is displayed beside operations with no tool selected. 

 Select tool closest to requirements if none match — this enables 
you to generate NC code, but it may result in tool holder 
gouges because a smaller tool may be used. 

6 Click OK to close the dialog. 
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Vortex approaches flats from outside stock 
Vortex toolpaths can approach flat areas from outside of stock 
instead of always ramping into it. This enables you to create Vortex 
toolpaths that are faster to machine and are compatible with a 
wider selection of tools. 
FeatureCAM 2015 R2 
The tool ramps into the part 

FeatureCAM 2015 R3 
The tool approaches from 
the outside 

  

To approach from outside the stock, FeatureCAM: 

 extends a section of the flat area beyond the stock and into an 
area already machined; and; 

 fills the extended section with cutting moves. 

 By extending the section to an area already machined, the 
machine tool can approach the flat area in open space. 
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  Edge of flat area 

  Stock  

  Extended section of flat area filled with cutting moves  

  Outside edge of extended section 

  Area already machined 

Criteria for toolpath to approach from outside stock 
FeatureCAM only extends a section of the flat area if the extended 
section: 

 has an outside edge that the machine tool can approach. 

 does not gouge the model. 

 is wide enough to be profile smoothed successfully.  

 can reach an area already machined within the distance of one 
tool diameter. 

If the extended section fails to meet the criteria, FeatureCAM does 
not extend the flat area and instead uses a ramp move to approach 
the toolpath. 
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Output options for 2D NT toolpaths 
The Output Options dialog is now available for 2D toolpaths that use 
NT or Vortex stepover types. This enables you to control how the 
points of 2D vortex and New Technology toolpaths are processed in 
the NC program. Previously, this was only available for 3D 
toolpaths. 

 
To display the Output Options dialog, click Output Options on the 
Milling tab of the Feature Properties dialog. 

The dialog contains these output options: 

 Filter linear moves — This automatically removes unnecessary 
points in the toolpath while maintaining tolerance. The points are 
not equispaced because unnecessary points are deleted. 

 Filter linear moves and convert arcs to linear — This is similar to 
the first option except that all arcs are replaced by straight line 
segments. This option is suitable for machine tools which do not 
handle arcs well. 

 Redistribute points after filtering linear moves. Convert arcs to linear 
— This option allows the insertion of new points. This ensures a 
constant distance between points, only inserting extra points if 
they are necessary to keep tolerance. This option may increase 
toolpath creation time, but reduce time on the machine tool. This 
option is suitable for machine tools that can handle large 
numbers of equispaced points. 
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 Approximate linear moves with arcs and lines — Select this option 
to create an arc line approximation for toolpaths that are 
contained in the XY, YZ, and XZ plane. This allows 3D programs 
to be smaller and to result in smoother surface finishes for 
certain types of parts. 

 Limit linear moves — Select this option to limit the distance 
between linear move points to the Maximum length value. 
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Previewing the toolpath point distribution 
You can now preview the points of a surface milling toolpath to help 
with editing the point distribution. 

To redistribute toolpath points: 

1 In the Surface Milling Properties dialog, on the Milling tab, click 
Output Options. 

The Output Options dialog is displayed. 

2 Under Output Filtering, specify the options for filtering linear 
moves in the toolpath. 

3 Click the new Preview button. The points of the toolpath are 
shown in blue in the graphics window. 

 
4 Modify the view in the graphics window to see the toolpath 

preview. 

5 When you have finished, click OK to close the dialog. 
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Tool pecking depths 
Pecking is used when drilling deep holes, where the tool retracts 
multiple times while drilling to clear debris from the hole. 

You can now specify the pecking depths for individual tools. 
Previously, you had to change the pecking depths for individual 
operations to override the global settings. 

To specify the pecking depths at which the drill retracts: 

 You can change the global pecking depths on the Pecking tab of 
the Machining Attributes dialog. 

 You can change the pecking depths for each tool on the new 
Pecking tab of the Tool Properties dialog: 

 

 Leave the values at 0% to use the global values in the 
Machining Attributes dialog. 

 You can see and edit each operation's absolute pecking depths 
on the Cycle tab of the Hole Feature Properties dialog. 

 
The peck style is specified in the .cnc file. This determines which of 
the tool's pecking values are used to calculate the absolute pecking 
depths for the operation. 
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Changing the Posting tolerance 
You can now control the tolerance with which toolpaths are created. 
This enables you to create more precise toolpaths, which is useful 
for machining small parts. 

There is a new Posting tolerance option in the Misc tab of the 
Machining Attributes dialog. 

 
Reduce the Posting tolerance for small parts to create more precise 
toolpaths. You must also adjust your post processor to output more 
digits. For example, if you adjust the posting tolerance from 0.001 
to 0.0001, then you must adjust the digit format in the post 
processor so that the extra decimal place is used in the NC code. 

Reducing the posting tolerance creates additional lines of NC code, 
so you should only do this for high-precision NC machines that can 
use the high-precision coordinates, when required for an 
application. 
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Helical side finish 
You can use the Helical side finish option to create a continuous 
spiral finishing toolpath for a 2.5D milling feature, which prevents 
tool marks on the surface. 

 
Helical side finish operations are now machined at the feed rate 
specified on the F/S tab of the Feature Properties dialog, previously 
they were machined using the plunge feed rate, specified by the 
Plunge feed override on the Plunge tab. 

To enable this option, select Helical side finish on the Strategy tab of 
the Feature Properties dialog, and enter a Pitch for the spiral. 
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Turning 
FeatureCAM 2015 R2 contains the following changes and 
improvements to Turning: 

 Removing undercuts in no-drag turning features (see page 60) — 
You can now remove undercuts in no-drag turning features to 
prevent gouges and simplify toolpaths. 

 Controlling steady rests (see page 61) — You can now open and 
close the jaws of a steady rest without moving it to the home 
position. 

 Simulating bar stock (see page 63) — You can now simulate bar 
stock in FeatureCAM by specifying the length of the stock 
displayed in simulation. 

 Custom turret names (MTT) (see page 64) — You can now use 
customized turret names to make FeatureCAM more consistent 
with your machine. 

 



 

60 • What's new in FeatureCAM 2015 R2 FeatureCAM 2015 R3 What's New  

Removing undercuts in no-drag turning features 
You can create turning features with a no-drag finishing strategy, 
where the tool does not cut the feature in a single movement, which 
reduces tool wear and prevents chips being dragged along the 
surface. 

You can now remove undercuts in no-drag turning features to 
prevent gouges and simplify toolpaths, which improves machining 
time and prevents unnecessary tool wear. Previously, this option 
was available only for features which use a conventional finishing 
strategy. 

  

To create a no-drag turning feature and remove undercuts: 

1 Create a Turn feature. 

2 In the Turn Properties dialog, on the Strategy tab, select No-Drag. 

3 Select an operation in the Tree View. 

4 On the Turning tab, select an option in the Undercuts list: 

 No checking — Select this option to not check the feature for 
undercuts. 

 Adjust to tool geometry — Select this option to clip undercuts 
that cause the tool to gouge the part. 

 Remove all undercuts — Select this option to remove all 
undercuts. 
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Controlling steady rests 
You can now open and close the jaws of a steady rest without 
moving it to the home position. 

This is useful for turning operations on long parts. For example, you 
can machine up to the steady rest, open the steady rest and 
machine past it, then close the steady rest and machine to the end 
of the part. 

Steady rest open: Steady rest closed: 

  

To control the jaws of a steady rest without moving it: 

1 Click the Features  step in the Steps panel to display the New 
Feature wizard. 

2 Select Part Handling and click Next. 
The Dimensions page is displayed. 

3 To close a steady rest, select Part Support On. 

To open a steady rest, select Part Support Off. 
4 Click Next. 

The Strategies page is displayed. 

5 In the Support type list, select Steadyrest. 
6 Select the new Jaws only option. 

 
7 Click Finish to close the wizard. 

8 To specify when the Part Handling feature is performed, click and 
drag the feature in Part View, or change the Base Priority 
attribute on the Misc tab of the Part Handling Properties dialog. 
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The Jaws only option is also displayed on the Strategy tab of the Part 
Handling Properties dialog. 

 
  

There is a new <JAWS-ONLY> reserved word in XBUILD. You must 
update your post Formats to use the reserved word to obtain the 
correct NC code that matches the new simulation. 
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Simulating bar stock 
You can now simulate bar stock in FeatureCAM by specifying the 
length of the stock displayed in simulation without changing the 
stock dimensions. 

Select the Options > Simulation menu option, and use the new 
Display Specific Stock Length option on the Round Stock tab of the 
Simulation Options dialog. 
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Custom turret names (MTT) 
You can now use customized turret names to make FeatureCAM 
more consistent with your machine. Previously, all turrets were 
called upper and lower turrets. 

The turret names are taken from the names of the turret or gang 
solids in the Machine Design file, and are used throughout 
FeatureCAM: 

 In the Part View panel. 

 
 In the Turrets tab of the Results panel. 

 
 In the Details tab of the Results panel. 

 In the NC program. 
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XBUILD 
FeatureCAM 2015 R2 contains the following XBUILD improvements: 

 Generating Post documentation (see page 65) — You can now 
output your CNC data file as HTML or XML to make it 
understandable. 

 Using macros in the post processor (see page 66) — The Disable 
Macros option in the Post Options dialog is now selected by 
default. 

 

Generating Post documentation 
In XBUILD, you can output your CNC data file as a text file. This file 
has a .cnx extension, and you can edit and print it with any text 
editor. 

You can now output your CNC data file as HTML or XML to make it 
more understandable. 

Select one of these File > Document CNC menu options: 

 CNX (Text) — Creates a .cnx file which can be read by any text 
editor. 

 HTML — Creates a .html file. This is the most readable 
document. 

 XML — Creates an .xml file. 
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Using macros in the post processor 
The Disable Macros option in the Post Options dialog is now selected 
by default. You must deselect this option to enable macro 
generation for the NC code. 
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Add-ins and extensions 
FeatureCAM 2015 R2 contains the following changes to add-ins and 
extensions: 

 Using Setup Sheets (see page 68) — There are new tags which 
you can use to create more detailed setup sheets. 

 FeatureCAM to CAMplete TruePath add-in (see page 69) — You can 
export documents to CAMplete TruePath, which you can use to 
analyze, modify, optimize, simulate and post 5-Axis toolpaths. 

 Probing update options (see page 71) — When creating probing 
features, you can now select multiple update options, which 
enables you to perform multiple actions from a single probing 
cycle. 

 Support for Microsoft SQL 2014 (see page 71) — FeatureCAM now 
supports Microsoft SQL server 2014. 
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Using Setup Sheets 
You can use the SetupSheet.dll add-in to generate html setup sheets 
from your document to give information to the machine operator 
about the manufacturing, tooling, and toolpaths of a part. 

There are new tags which you can use to create more useful setup 
sheets: 

 Machining allowances: 

 {operation.finish_allowance} — Finish Allowance. 

 {operation.bottom_finish_allowance} — Bottom Finish 
Allowance. 

 {operation.surface_finish_leave_allowance} — Finish 
Leave Allowance. 

 Stepover: 

 {operation.stepover} — 3D milling stepover. 

 Z increment: 

 {operation.finish_z_increment} — Finish Z Increment 

 {operation.surface_finish_z_increment} — Surface Finish 
Z Increment. 

 {operation.surface_rough_z_increment} — Surface Rough 
Z Increment. 

 Coolant: 

 {tool.coolant_override} — The tool's coolant override. 

 Depth of cut: 

 {operation.depth_of_cut} — Rough Z Pass Increment. 

 {operation.turn_depth_of_cut} — Rough Depth of Cut for 
turning operations. 
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FeatureCAM to CAMplete TruePath add-in 
CAMplete TruePath is an application that you can use to analyze, 
modify, optimize, simulate and post 5-Axis toolpaths. 

To export a document to use with CAMplete TruePath: 

1 License the CAMplete verification product component, and ensure 
it is selected in the Evaluation Options dialog. 

2 In the Post Options dialog, select the CAMplete_TruePath.cnc post 
in the /Posts/Mill/5-Axis folder. 

3 Load the FeatureCAMToCAMplete.dll add-in. 

4 In the Utilities toolbar, click FeatureCAMToCAMplete . 

The FeatureCAM to CAMplete dialog is displayed. 

 
5 Click Browse and select where you want to save the exported 

files. 

6 In the solids list, select solids you want to export as clamps. 

7 Click Export Part solid to export a solid to use as the part in 
CAMplete. 
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 To export a solid in the document as an .stl file, select Select 
solid to export as part, and select a solid from the list. 

 To use an .stl file, select Select existing .stl file and click 
Browse and select it in the Select part .stl file document. 

8 Select whether you want the post to use the Tool number or Tool 
ID to identify tools. 

9 Under Offset from the setup UCS to pallet, enter the offset 
distances in the X, Y and Z directions. 

10 Click Preview to display a point in the graphics window which 
shows the offset from the setup UCS. 

11 Click Export to export the document and close the dialog. The 
files are created in the selected output directory. 
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Probing update options 
When creating probing features, you can now select multiple update 
options. This enables you to perform multiple actions from a single 
probing cycle. 

To create a probing feature with multiple update options: 

1 Select the Options > Add-Ins menu option and use the Macro Add-
ins dialog to load the StandardProbing2.dll add-in. 

 This replaces the StandardProbing.dll add-in, but it is still 
available to enable backwards compatibility. 

2 Create a User Defined Feature, and select the feature type you 
want to measure, then click Next. 

3 Select an item in the Dimension list, enter a New Value, and click 
Set. 
You can enter the following values: 

 MCS — Enter the Machine Coordinate System you want to 
update. 

 Tool — Enter the tool number for the tool you want to update. 

 Store — Specify whether to store the results. 

 Print — Specify whether to print the results. 

4 Complete the wizard and click Finish to create the probing 
feature. 

 

Support for Microsoft SQL server 2014 
FeatureCAM now supports Microsoft SQL server 2014. 

You can use SQL server to improve the performance and reliability 
of your network database in FeatureCAM. 
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Machine Simulation Design 
FeatureCAM 2015 R2 contains the following changes and 
improvements to Machine Simulation design: 

 Multi-tool blocks (see page 73) — You can now create multi-tool 
blocks and double-sided tool blocks in Machine Design files and 
use them in machine simulations. 

 Selecting the tool block (see page 76) — You can now select 
which tool block holds each tool within an FM file, which enables 
you to create accurate machining simulations more easily. 

 Protecting Machine Design documents (see page 78) — You can 
protect your Machine Design files from the extraction of solids, 
so that you can share them for simulation without anyone being 
able to extract the solids. 
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Multi-tool blocks 
You can now create multi-tool blocks and double-sided tool blocks in 
Machine Design files and use them in machine simulation. 
Previously, each tool block could hold only one tool. 

 
To create a multi-tool block: 

1 Ensure that the Machine Design > Enable Millturn UI menu option 
is selected to access the lathe design options. 

2 Select the Machine Design > Tool Block for Turret menu option. 

The Tool Block tab of the Tool Block dialog is displayed. This tab 
has been updated. 

 
3 Select a solid to use as the tool block. 

4 Select a UCS for the tool location on the turret, or click New UCS 
Wizard and create one. 

5 Select which turrets the tool block can address. 

6 Select which tool locations on the turret the tool block can attach 
to. 
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7 Select the new Tool Locations tab. 

 
8 Click Add to add a new tool location. 

The new Tool Information dialog is displayed. 

 
9 Select a UCS to define the tool location, or click New UCS Wizard 

and create one. 

10 Select which of the spindles the tool addresses. 

11 Under Holds which tool type, select the tool types that can be 
used at this tool location. For OD Lathe tools, select the 
Handedness of the tool. 

12 Click OK to add the tool location and close the Tool Information 
dialog. 

13 To remove a tool location, select it and click Remove. 

14 To edit a tool location, select it and click Edit, or double-click it. 

15 Use the Move Up and Move Down buttons to change the order of 
the tool locations in the dialog. 

16 Click OK to close the Tool Block dialog. 
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Selecting the tool block 
You can now select which tool block holds each tool within an FM 
file, which enables you to create accurate machining simulations 
more easily. 

To select the tool block for a tool: 

1 Open a Turning or Turn/Mill document that contains toolpaths. 

2 Select the Manufacturing > Tool Mapping menu option. 

The Tool Mapping dialog is displayed. 

3 Select a tool in the list, and click the new Select Block button. 

 
The new Select Block dialog is displayed. 
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4 In the Tool block list, select the tool block solid from the Machine 
Design file that you want to hold the selected tool. 

5 Select the sub slot in the list that you want to hold the tool. 

6 Click OK to close the Tool Block Selection dialog. 

The tool block you selected is displayed in the tool mapping tree. 

 
7 Click OK to close the Tool Mapping dialog and save your changes. 
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Protecting solids in Machine Design documents 
You can protect your Machine Design files from the extraction of 
solids, so that you can share them for simulation without anyone 
being able to extract the solids. 

FeatureCAM comes with some locked Machine Design files. You can 
use these for simulation, but you cannot extract solids from them. 
When you open a locked file, a dialog is displayed explaining the 
restriction. 

 
You can lock your files, but you cannot unlock them. You should not 
lock an original file, instead create a copy of it and lock the copy. 

  

To lock a file: 

1 Use the File > Save As menu option to save a copy of your file. 

2 Select the File > Lock/Unlock menu option. 

The Lock or Unlock File dialog is displayed. 

 
3 Select Lock. 

 If you lock a file, you cannot unlock it. 

4 Click OK to close the dialog and save your changes. 
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FeatureCAM 2015 R1 contains the following new features and 
enhancements: 

User interface 
 Installing FeatureCAM (see page 84) — During installation, a 

dialog reminds you to prepare to update to Windows 8. 

 SQL server authentication (see page 85) — FeatureCAM can now 
record the credentials for accessing the tools databases held in 
SQL Server.  

 Accessing machining attributes (see page 86) — The Machining 
Attributes dialog can be opened directly from the Part View panel. 

 Customizing the Toolbox (see page 86) — The width each view in 
the Toolbox can be customized separately. 

 Adding new stock materials (see page 88) — The New Stock 
Material dialog prevents the creation of invalid stock names. 

 Improved feature recognition (see page 89) — Feature recognition 
automatically excludes clamps from solids. 

 Recognizing Face features (see page 90) — You can now 
recognize multiple Face features simultaneously. 

 Snapping modes (see page 91) — The Snap Mode toolbar includes 
a new option that allows the use of the centre points of cylinders 
and cones. 

 Creating solids (see page 92) — The Finish button of the Solid 
Wizard is configurable in the same way as the Features Wizard. 

 Polygonal curves (see page 94) — A new option is available for 
creating polygonal curves.  

What's new in 
FeatureCAM 2015 R1 
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 Creating gears (see page 96) — The Gears dialog now includes 
alternative methods of specifying curve information. A separate 
tab reports the properties of the calculated gear.  

 Command line options (see page 98) — FeatureCAM's command 
line interface has been extended. 

 Selecting surfaces (see page 99) — Selecting the surfaces of long 
narrow models has been improved. 

Milling 
 Tool Holder collision avoidance (see page 101) — You can now 

automatically clip toolpaths which would cause a tool holder 
collision or a gouge. 

 Machine maximum stock (see page 103) — A new machine 
maximum stock setting enables you to machine as much stock 
as possible without retracting the tool. 

 Isoline and Flowline features (see page 104) — A new sequence 
option for isoline and flowline milling gives greater control over 
the creation of toolpaths. 

 Configuring counterbore operations (see page 106) — A new 
Touch off at the shoulder option enables you to choose the z-zero 
position for a counterbore operation. 

 Default auto-chamfer tool (see page 108) — The Machining 
Attributes dialog includes the ability to set a default tool for 
chamfer operations. 

 Setting toolpath boundaries (see page 109) — You can use a 
clipping curve to restrict z-level roughing to a specific area of a 
part. 

 Creating 5-axis patterns (see page 111) — 5-axis milling patterns 
can be specified for any axis. 

Turning 
 Improved machining time for dips (see page 114) — FeatureCAM 

uses a rapid move to machine dips smaller than the depth of cut.  

 Synchronizing operations (see page 115) — Improved 
synchronization points for multi-turret machines make it easier 
to manage and update synchronization groups. 

 Turning curves (see page 117) — Follow and pinch turning are 
now available for the face and back-face cycles of curves. 

 Tool properties for multi-turret machining (see page 119) — You 
can assign operations to specific turrets in the Tool Properties 
dialog. 
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 Multiple part catchers (see page 120) — Multiple part catcher 
support is supported through the Cutoff Properties dialog and the 
FeatureCAM API. 

Wire EDM 
 Improved reliability for no-core machining (see page 122) — 

FeatureCAM can create no core toolpaths that ensure no material 
remains after machining. 

 Selecting cutting data (see page 123) — Two new conditions are 
available for selecting data. 

Importing 
 Using Inventor 2015 (see page 126) — FeatureCAM has been 

certified for use with Autodesk Inventor 2015. 

 Importing Pro/E files (see page 127) — The feature tree of 
imported Pro/E files can be displayed. 

 Importing JT files (see page 127) — You can load solids from JT 
files in addition to surfaces. 

 Importing PDF files (see page 128) — You can import curves from 
Acrobat files using Delcam Exchange. 

Add-ins and extensions 
 Using add-ins (see page 130) — The Macro Add-ins dialog has 

been updated to improve the management of add-ins and 
macros. 

 The Add-in Library (see page 132) — FeatureCAM now includes a 
catalog of add-ins that were previously only available on the 
website. The Add-in Library is a new feature that enables you to 
quickly view and select add-ins from the catalog. 

 Turn-curve tolerance (see page 134) — A new 
TurnCurveTolerance.bas add-in enables you to tolerance multiple 
segments in turned or internal bore features.  

 Exporting NC programs to NCSIMUL (see page 137) — The 
FeatureCAMToNCSIMUL.dll add-in can now export turn/mill 
programs as well as milling programs. 

 Extended machine support (see page 138) — Add-in support for 
traveling steady rests, bar fed mills, and the Mori Seiki NTX1000 
is available for FeatureCAM. 

XBUILD  
 Custom formats (see page 140) — The Custom Format Name 

dialog has an enhanced user interface to support the creation of 
naturalistic process names. 
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 Customizing cutting data from Wire EDM (see page 141) — You can 
now configure the headings of the cutting data table for use with 
Wire EDM. 

 Saving CNC files (see page 144) — Post numbers can be used to 
identify individual output files for Fanuc-style multi-turret lathes. 

 Configuring reserved words (see page 146) —The Word Info dialog 
includes a new option that enables you remove all non-significant 
zeros from numeric outputs. 

 Using the Reserved Words dialog (see page 147) — The Reserved 
Words dialog is easier and quicker to use.  
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User interface improvements 
FeatureCAM 2015 R1 contains the following changes and 
improvements to the user interface: 

 Installing FeatureCAM (see page 84) — During installation, a 
dialog reminds you to prepare to update to Windows 8. 

 SQL server authentication (see page 85) — FeatureCAM can now 
record the credentials for accessing the tools databases held in 
SQL Server.  

 Accessing machining attributes (see page 86) — The Machining 
Attributes dialog can be opened directly from the Part View panel. 

 Customizing the Toolbox (see page 86) — The width each view in 
the Toolbox can be customized separately. 

 Adding new stock materials (see page 88) — The New Stock 
Material dialog prevents the creation of invalid stock names. 

 Improved feature recognition (see page 89) — Feature recognition 
automatically excludes clamps from solids. 

 Recognizing Face features (see page 90) — You can now 
recognize multiple Face features simultaneously. 

 Snapping modes (see page 91) — The Snap Mode toolbar includes 
a new option that allows the use of the centre points of cylinders 
and cones. 

 Creating solids (see page 92) — The Finish button of the Solid 
Wizard is configurable in the same way as the Features Wizard. 

 Polygonal curves (see page 94) — A new option is available for 
creating polygonal curves.  

 Creating gears (see page 96) — The Gears dialog now includes 
alternative methods of specifying curve information. A separate 
tab reports the properties of the calculated gear.  

 Command line options (see page 98) — FeatureCAM's command 
line interface has been extended. 

 Selecting surfaces (see page 99) — Selecting the surfaces of long 
narrow models has been improved. 
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Installing FeatureCAM 
Following Microsoft's decision to withdraw support for Windows 7 in 
2015, Delcam will also be withdrawing support for this operating 
system. To enable you to prepare for this change, FeatureCAM 2015 
R1 displays the following reminder when it detects you are installing 
it on a computer running Windows 7. or a 32-bit version of Windows 
8: 

 
If you want to continue using FeatureCAM updates after June 2015, 
you must update your computer to a 64-bit version of Windows 8. 
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SQL server authentication 
You can now specify a username and password for SQL 
authentication. When you use SQL authentication, the Database 
Name list only displays databases to which you have access. 

There are new options in these places: 

 The Database tab of the File Options dialog: 

 
 In the INITDB window: 

 
To use SQL authentication: 

1 Display the Database tab of the File Options dialog or the INITDB 
window. 
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2 Select On a SQL server. 
3 Enter a Server Name. 

4 In the Authentication Mode list, select SQL Server. 
5 Enter a SQL Username and a SQL Password. 

6 In the Database Name list, select a database. The list displays 
only the databases for which you have access rights. 

 

Accessing machining attributes 
The Machining Attributes dialog can now be opened from the Parts 
View panel as well as from the Manufacturing > Machining Attributes 
menu option. This streamlines the document creation process by 
enabling you to quickly view and change the attributes of the part 
you are working with.  

To open the Machining Attributes dialog from the Part View:  

1 Double-click the Machining Attributes option below the document 
name. For example: 

 
2 Update the machining attributes, and then click OK to save your 

changes and close the dialog. 
 

Customizing the Toolbox 
FeatureCAM now remembers the last width change for each view in 
the Toolbox panel. This enables you to customize the display of the 
Steps, Part View, and Browser panels individually, and then have 
FeatureCAM automatically change the Toolbox width each time you 
switch between them. The separate widths are saved when you 
close the program, which means that your changes are remembered 
between sessions and can be shared across installations using the 
ezfm_ui.ini file. 

To resize the Toolbox views: 
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1 Select Part View. 

2 Position the cursor over the Toolbox border. When the cursor 
changes to , left-click and drag the border to its new position. 
For example: 

 
3 Repeat steps 1 and 2 for the Steps view and the Browser view. 
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Adding new stock materials 
To avoid creating names that cause errors, the names of new 
materials are now restricted to capital letters (A-Z), numbers (0-9), 
underscores (_), and dashes (-). To enable you to type normally, 
lower-case letters are automatically converted to upper-case, and 
spaces are automatically converted to underscores. 

To create a new stock material: 

1 Select the Manufacturing > Feeds/Speeds and Cutting Data Tables 
menu option. The Feeds/Speeds and Cutting Data Tables dialog is 
displayed. 

2 Click the New Stock Material  button. The New Stock Material 
dialog is displayed.  

 
3 Enter a name for the material and click OK to save your changes 

and close the dialog. The name is displayed in the Material list. 
4 Complete the details of the material in the Feeds/Speeds and 

Cutting Data Tables dialog. 

5 Click OK to save your changes and close the dialog. 
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Improved feature recognition 
Previously, feature recognition identified and selected clamps as 
well as features on the part itself. This meant that when using 
feature recognition on a model that included clamps, you would 
often need to deselect clamp features.  

In FeatureCAM 2015 R1, the feature recognition algorithm has been 
refined to automatically exclude the features of clamps from the 
recognition process, so cutting out unnecessary work and enabling 
you to create documents more quickly.  

 
For example, to identify sides using feature recognition: 

1 Open the solid. 

2 Right-click the clamps and select Use Solids as Clamp from the 
context menu.  

3 Open the New Feature Wizard.  

4 Under From Curve, select the Side option. 

5 Select the Extract with FeatureRECOGNITION check box, and click 
Next. 

6 In the Feature Extraction dialog, select Automatic recognition and 
click Next. The Feature Recognition Options dialog is displayed, 
and only the side features on the part are selected. 

7 Complete the wizard and click Finish. 
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Recognizing Face features 
You can now use FeatureRECOGNITION to recognize multiple Face 
features simultaneously. This makes it easier to program complex 
parts, because you no longer need to create Face features 
individually. 

 
To recognize Face features from surfaces: 

1 Open a part that contains multiple flat surfaces. 

2 In the Steps panel, click the Features  step. The New Feature 
wizard is displayed. 

3 In the From Dimensions section, select Face. 

4 Select the Extract with FeatureRECOGNITION check box, then click 
Next. The Surfaces page is displayed. 

5 Select all flat surfaces you want to recognize in the graphics 
window, and click  to add the selected surfaces. 

6 Click Next. 
A message asks if you want to create multiple features. 

7 Click Yes to create the features and close the wizard. 
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Snapping modes 
A new Snap to cylinder end points option has been added to the Snap 
Mode toolbar and the Snap Modes dialog. Use it to select and work 
with the center end points of cylinder and cone axes.  

To select the cylinder end points: 

1 Use one of these methods to select Snap to cylinder end points 
mode: 

 In the Snap Modes dialog, select . 

 In the Snap Mode toolbar, click the Snap to cylinder  button. 

In the Graphics view, selection points are displayed at the center 
end points on the axis of each cylinder and cone.  

2 Click the selection points to construct geometry or to display the 
distance between points. For example: 

 

 If the Snap to cylinder button is not shown in the Snap Mode 
toolbar, select the toolbar in the Toolbars tab of the Customize 
Toolbars dialog, and click Reset Selected. 
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Creating solids 
To improve usability, a new Finish button has been added to the 
Solid Wizard. It works in the same way as the Finish button in the 
Features Wizard, and enables you to speed up the creation of 
multiple solids. For example:  

 
To create solids using the Solid Wizard: 

1 Open the Solid Wizard. 

2 Select a method of solid construction. 

3 Select a constructor. 

4 When you have completed your setting changes, click the down 
arrow on the Finish button and choose an option. Select:  

 Finish to create the solid and close the wizard. 

 Finish and Edit Properties to close the wizard and open the 
properties dialog for the solid you created. You can then view 
and edit the settings. 

 Finish and Create More to create the solid and return to the 
start of the wizard. You can then create a new solid. 

FeatureCAM remembers your selection and, when you next use 
the wizard, the icon displayed on the button indicates its current 
state. For example:  indicates the button is currently in 
Finish and Edit Properties mode. 



 

FeatureCAM 2015 R3 What's New What's new in FeatureCAM 2015 R1 • 93  

Similarly, you can create multiple items when using the Solids 
toolbar to create items. For example: 

 
To create solids from the properties dialogs: 

1 Select an option in the Solid toolbar. The properties dialog for the 
solid is displayed. 

2 Edit the settings. 

3 Click the down arrow on the Apply button and choose an option. 
Select:  

 Apply and Edit Properties to save your changes and continue 
editing the current solid. 

 Apply and Create More to save your changes. Each time you 
click Apply, FeatureCAM creates a new solid. 

As with the Solid Wizard, FeatureCAM remembers your selection, 
and an icon indicates the button's current state. 
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Polygonal curves 
FeatureCAM 2015 R1 contains a new Polygon tool. Use it to create a 
curve in the shape of a regular polygon. 

To create a polygonal curve: 

1 Open the Polygon dialog in one of these ways: 

 In the Curve Wizard, select Other methods, select Polygon, and 
click Next. 

 On the Curves and Surfaces toolbar, click the Polygon  
button in the Curve menu. 

 Select Construct > Curve > Other Methods > Polygon. 

The Polygon dialog is displayed. 

 
2 Enter a Curve name. 

3 Enter the Number of sides in the polygon. For example, to create 
a regular hexagon, type 6. 

4 Enter the x and y coordinates of the Center point, or click  and 
select the location in the graphics window. 

5 To fillet the corners, enter a Corner Radius. 

6 To rotate the rectangle counter-clockwise from the X axis, enter 
an Angle in degrees. 

7 By default the curve is created on the UCS plane. If you want to 
position the curve on a parallel plane, enter an Elevation. 

8 Size the polygon using one of these methods: 

 In the Side length box, enter the length of the sides. 
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 In the Center to side box, enter the perpendicular distance 
between the curve center and the sides. 

 In the Center to corner box, enter the distance between the 
curve center and the corners. 

9 To convert the curve into arcs and lines, select the Create as 
curves and lines check box. 

10 Click Preview to display the polygon in the graphics window.  

11 Click OK or Finish to close the dialog. 
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Creating gears 
The Gears dialog has been extended to allow the use of alternative 
parameters to specify gear curves. You can now specify Outer 
diameter, Root diameter, and Diametric pitch or Module 
measurements, making it easier for you to create curves directly 
from the specification. In addition, a new Analysis tab enables you 
to view the properties of the calculated gear and the measurement 
over pins values.  

 
To create a gear curve: 

1 Open the Gears dialog in one of these ways: 

 In the Curve Wizard, select Other methods, then Gears, and 
click Next. 

 On the Curves and Surfaces toolbar, click the Gears  button 
in the Curve menu. 

 Select the Construct > Curve > Other Methods > Gears menu 
option. 

The Gears dialog displays the Curve tab. 

2 Enter a Name for the curve. 

3 Enter a Firmness value to determine the number of control points 
in the tooth profile. The smaller the value; the greater the 
number of control points used to sample the curve. 

4 Complete the gear specification: 

 Number of teeth — Enter the number of teeth on the gear. 

 Pressure angle — Enter the acute angle, in degrees, between 
the tangent to the two base circles and a normal to the line 
connecting the gear centers. 
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 Tip radius — Enter the radius of the tooth corner. 

 Addendum — Enter the radial distance from the pitch circle to 
the outermost point of the tooth. Alternatively, select Outer 
diameter and enter the outside diameter of the gear.  

 Dedendum — Enter the radial distance from the depth of the 
tooth trough to the pitch circle. Alternatively, select Root 
diameter and enter the root diameter of the gear. 

 Pitch diameter — Enter the diameter of the pitch circle. 
Alternatively, select Module and enter the pitch diameter 
divided by the number of teeth, or select Diametric pitch and 
enter the number of teeth divided by the pitch diameter.  

 Root fillet radius — Enter the radius of the fillet at the bottom 
of each tooth. 

 Center point —Enter the coordinates for the centre of the gear 
curve, or click  and pick the curve in the Graphics window. 

5 Select the Analysis tab to view the calculated dimensions of the 
gear, the calculated pin gauge diameter and the outside 
measurement over pins diameter. 

 

 The Analysis tab is not displayed when you create a gear 
using the Curve Wizard. 

6 If you want to change the calculated diameter of the pin gauge, 
enter a new value in the Actual pin diameter box, and click 
Recompute.  

7 Click OK (or Finish if you are using the wizard). 
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Command line options 
The command line interface for ezfm.exe, the FeatureCAM 
executable, has been extended. You can use it to control 
administrative functions, as well as to load customized user-
interface and manufacturing setups. The following commands are 
available: 

  
-b Load the specified VB add-in from the 

specified path. 

-c Run the script at the specified path. 

-dbug Send the debug output to the console. 

-debugtofile Send the debug output to file ezfm_debug.txt 
-help or -? List the command line options available for 

FeatureCAM. 

-i Load the settings from the specified 
FeatureCAM .ini file.  

-l Specify the network license for FeatureCAM. 

-m Load the manufacturing settings from the 
specified ezfm_mfg.ini file. For example: 
ezfm -uc:\ProgramData\FeatureCAM\ezfm_mfg.ini 

-noflex or  
-norms 

Skip the license checks.  

-regserver Register the FeatureCAM library 

-u Load the user-interface settings from the 
specified ezfm_ui.ini file. For example:  
ezfm -
uc:\ProgramData\FeatureCAM\ezfm_custom_ui.ini 

-viewal Send debug graphics to this ezfm instance  

  

To open FeatureCAM using a command line option: 

1 Open a Command Line window. 
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2 Type ezfm.exe, followed by the parameter. For example: 

 

 You must enter the full path of the executable and any 
specified files when they are not located in the currently 
selected directory.  

3 Press the Enter key to execute the command. 

 Commands are not case-sensitive. 
 

Selecting surfaces 
Previously, it could be difficult to select surfaces at each end of a 
long narrow model. This was because rotating the part would place 
the view point inside the model causing the outer surfaces to 
disappear. The problem has been fixed in FeatureCAM 2015 R1. 
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Milling Improvements 
FeatureCAM 2015 R1 contains the following changes and 
improvements to the Milling module: 

 Tool Holder collision avoidance (see page 101) — You can now 
automatically clip toolpaths which would cause a tool holder 
collision or a gouge. 

 Machine maximum stock (see page 103) — A new machine 
maximum stock setting enables you to machine as much stock 
as possible without retracting the tool. 

 Isoline and Flowline features (see page 104) — A new sequence 
option for isoline and flowline milling gives greater control over 
the creation of toolpaths. 

 Configuring counterbore operations (see page 106) — A new 
Touch off at the shoulder option enables you to choose the z-zero 
position for a counterbore operation. 

 Default auto-chamfer tool (see page 108) — The Machining 
Attributes dialog includes the ability to set a default tool for 
chamfer operations. 

 Setting toolpath boundaries (see page 109) — You can use a 
clipping curve to restrict z-level roughing to a specific area of a 
part. 

 Creating 5-axis patterns (see page 111) — 5-axis milling patterns 
can be specified for any axis. 
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Tool holder collision avoidance 
You can now automatically clip toolpaths which would cause a tool 
holder collision or a gouge. This makes it easier to program complex 
parts safely, and you can fix problems without having to simulate 
the toolpaths repeatedly to find the cause of collisions. 

 

 Holder collision clipping only checks for collisions between the 
tool holder and part surfaces or check surfaces, not remaining 
stock. 

To use tool holder collision and gouge avoidance: 

1 Create or open a part containing a Surface Milling feature. 

2 Double-click the feature in the Part View to display the Surface 
Milling Properties dialog. 

3 Select an operation in the Tree View. 

4 In the Strategy tab, select Holder collision clipping. 

5 Select a pass of the operation in the Tree View. 

6 In the Milling tab, enter a Holder clearance and Shank clearance. 
The toolpath is clipped when the holder or shank move within 
these distances of a surface. 

7 Click OK to accept. 
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8 Simulate the toolpath to show which areas have not been 
machined: 
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Machine maximum stock 
There is a new Machine maximum stock setting, which you can use 
with Holder collision clipping (see page 101) to machine as much 
stock as possible without the tool retracting. This creates smoother 
toolpaths with fewer retracts, which can improve the surface finish 
and reduce the machining time. 
Machine maximum stock 
deselected:  Machine maximum stock 

selected: 

 

 

 

On some parts, this may increase air cutting, which could increase 
the machining time. 

On the Strategy tab of the Surface Milling Properties dialog, select 
Holder collision clipping and Machine maximum stock: 
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Isoline and flowline features 
There is a new sequence option for Isoline and Flowline surface 
milling features, which gives you more control over the toolpaths. 
You can now create toolpaths which start at the center of the 
surface and cut outwards, such as for machining towards and up the 
walls of cavities. 

 
To create an Isoline or Flowline surface milling feature: 

1 Import or open a model with surfaces you want to machine. 

2 Click New Feature  on the Advanced toolbar. The New Feature 
dialog is displayed. 

3 In the From Surface area, select Surface Milling and click Next. 
4 In the Graphics window, select the surfaces you want to machine 

and click . Click Next. 
5 Select Choose a single operation and click Next. 
6 In the Finishing Strategies section, select Isoline or Flowline and 

click Finish. 

  

To change the Sequence for an Isoline or Flowline Surface Milling 
feature: 

1 In the Part View, double-click the feature to display the Surface 
Milling Properties dialog. 

2 Select the Isoline or Flowline operation in the Tree View. 
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The Sequence is displayed on the Surface control tab: 

 

3 Click Sequence  to cycle through the toolpath sequence 
options for the selected surfaces. Select: 

 None to create a toolpath that cuts across the surface in the 
same way as in FeatureCAM 2014 R3. This is selected by 
default. 

 In to out to create a toolpath that starts at the center of the 
surface and cuts outwards. 

 Out to in to create a toolpath that starts at the outside of the 
surface and cuts inwards. 

 The Continuous Spiral option on the Strategy tab overrides 
this setting. 

4 Click OK to save your changes. 
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Configuring counterbore operations 
By default, FeatureCAM calculates the z depth of an operation as 
the sum of the hole's Bore depth and the tool's Pilot length. In 
FeatureCAM 2015 R1, the Counterbore tab of the Counterbore Tool 
Properties dialog contains a new Touch off at the shoulder option, 
which enables you to locate the tool's z-zero position at the end of 
the tool flutes (the tool shoulder) instead of at the end of the pilot 
(the tool tip). This improves the accuracy of the toolpath in 2-axis 
drilling because it minimizes the effect of the pilot length, which is 
susceptible to greater variation in tolerance. 

 
To choose the z-zero position for a counterbore operation: 

1 Double-click the hole feature in the Part View. The Hole Feature 
Properties dialog is displayed. 

2 Select the Counterbore operation in the Tree view. 

3 On the Tools tab, double-click the counterbore tool you want to 
configure. The Counterbore Tool Properties dialog is displayed.  

4 On the Counterbore tab, select the Touch off at the shoulder check 
box to position the tool z-zero at the end of the flutes; deselect 
the check box to position the tool z-zero at the end of the pilot.  

5 Complete any other changes in the dialog.  

6 Click OK to save your changes and close the Counterbore Tool 
Properties dialog.  



 

FeatureCAM 2015 R3 What's New What's new in FeatureCAM 2015 R1 • 107  

7 Click OK to save your changes to the Hole Feature Properties 
dialog. 

 Selecting the Touch off at the shoulder check box has no effect 
on the simulation of the toolpath. 
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Default auto-chamfer tool 
You can now set a default tool for chamfer operations. This enables 
you to create multiple features without having to modify them 
individually to change the tool. 

To set a default chamfer tool: 

1 Select Manufacturing > Machining Attributes from the menu. The 
Machining Attributes dialog is displayed. 

2 In the Tool Selection tab, select a Default auto-chamfer tool from 
the list: 

 
3 Click OK to close the dialog. 

The selected tool is used for any new chamfer operations you 
create; any existing chamfer operations that use the default tool 
are updated. 
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Setting toolpath boundaries 
Previously, in 3D milling, the Stock Model option was a clipping-
curve alternative in the Stock tab of the Surface Milling Properties 
dialog. This meant that when you chose to use a stock model to 
determine the toolpath boundaries, the machining operation had to 
be applied to the whole part. In FeatureCAM 2015 R1, the Stock 
Model setting is selectable separately to the clipping curve, enabling 
you to limit operations to a specific area of a part for z-level rough, 
parallel rough, and 3-axis finishing strategies. 

To specify the boundaries of the toolpath: 

1 Double-click the feature in the Part View, or right-click the 
surface and select Properties. The Surface Milling Properties dialog 
is displayed. 

2 Select the strategy in the tree view. The strategy tabs are 
displayed. 

3 Select the Stock tab. 

 
4 Choose a clipping curve. Select: 

 Use part surface dimensions to create toolpaths on the surfaces 
regardless of the location of the stock. 

 Use stock dimensions to restrict the toolpaths to the portions 
of the surface feature that are within the stock.  
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 Use solid model to restrict toolpaths to be within the solid 
model or STL model that you choose.  

 Select curves for boundaries to use curves to restrict the 
toolpath boundaries, or to affect the shape of a spiral 
toolpath. 

5 To use the curve in combination with a stock model:  

a Select the Stock model check box.  

b Select the model from the list.  

c Select an entry in the Operations list. 

6 If you want to save the boundary for future use, click Save 
Combined Boundary. 

7 Click OK to save your changes and close the dialog.  
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Creating 5-axis patterns 
The New Feature Wizard now contains an additional option for 
creating 5-axis milling patterns. With the new Radial arbitrary index 
axis option on the Patterns page you can make a hole pattern 
around any axis, enabling you to program patterns in 5-axis parts 
quickly and easily. For example: 

 
To create a 5-axis pattern from a new hole: 

1 Create a stock using 5th axis positioning in the Stock Wizard, or 
select 5th axis positioning in the Indexing tab of the Stock 
Properties dialog. 

2 In the New Feature Wizard, select the Hole option, select the Make 
a pattern from this feature check box. Click Next. 

3 In the Dimensions page, enter the details of the hole you want to 
create. Click Next. 
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4 In the Patterns page, select the Radial arbitrary index axis option. 
Click Next.  

 
5 In the Location page, enter the vector of the central axis and the 

position of the hole. Click Next. 
6 In the Dimensions page, enter the Number of holes in the pattern 

and the Spacing angle between each hole. Click Next. 
7 In the Location page, enter the vector of the indexing axis and 

the position of its origin. Click Finish.  

  

To create a 5-axis pattern from an existing hole: 

1 Select 5th axis positioning in the Indexing tab of the Stock 
Properties dialog. 

2 In the New Feature Wizard, select the Pattern option. Click Next. 
3 In the Pattern Base page, select the hole from which you want to 

create the pattern. Click Next. 
4 In the Patterns page, select the Radial arbitrary index axis option. 

Click Next.  
5 In the Dimensions page, enter the Number of holes in the pattern 

and the Spacing angle between each hole. Click Next. 
6 In the Location page, enter the vector of the central axis and the 

position of the hole. Click Finish. 
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Turning improvements 
FeatureCAM 2015 R1 contains the following changes and 
improvements to the Turning module: 

 Improved machining time for undercuts (see page 114) — 
FeatureCAM uses a rapid move to machine undercuts smaller 
than the depth of cut. 

 Synchronizing operations (see page 115) — Improved 
synchronization points for multi-turret machines make it easier 
to manage and update synchronization groups. 

 Turning curves (see page 117) — Follow and pinch turning are 
now available for the face and back-face cycles of curves. 

 Tool properties for multi-turret machining (see page 119) — You 
can assign operations to specific turrets in the Tool Properties 
dialog. 

 Multiple part catchers (see page 120) — Multiple part catcher 
support is supported through the Cutoff Properties dialog and the 
FeatureCAM API. 
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Improved machining times for undercuts 
FeatureCAM now creates more efficient toolpaths for features that 
contain undercuts smaller than the depth of cut. Instead of feeding 
along a previous cut to machine the undercut, FeatureCAM now 
uses a rapid move. This prevents the tool from cutting the surface 
twice, and so reduces machining time, increases tool-life, and 
prevents problems such as work-hardening on the part. 

To machine a turning feature that includes a small undercut in 
FeatureCAM 2015 R1, the tool: 

1 Cuts the part to the correct diameters. 

 
2 Retracts and makes a rapid move to the undercut location. 

 
3 Cuts the undercut. 
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Synchronizing operations 
Synchronization points in the Turrets tab enable you to specify the 
order in which operations are performed on multi-turret machines. 
In FeatureCAM 2015 R1, synchronization points have been 
redesigned to be independent of operations in the tab, making it 
easier to change and update synchronization groups, and providing 
a simplified, more intuitive user interface.  

Adding operations to the sequences 
When you insert a feature into the Part View and Automatic Ordering 
is selected in the Ops List tab, FeatureCAM adds the feature's 
operation to the appropriate synchronization group. For example, a 
copy of the hole6 feature is automatically assigned to the same 
synchronization group and turret as the original hole.  
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Moving operations within the sequence 
When you drag operations within the Turrets tab, the cursor 
changes to ; when you drop the operations, they 
are added immediately after it. If the insertion point is at the 
boundary of two synchronization groups, the position of the mouse 
cursor above or below the boundary marker determines which 
group the operations are added to.  

 
In addition, when you drag one operation of an operation pair, both 
operations are moved together. 

 Operation pairs are created by FeatureCAM when a feature 
generates two linked operations. For example, linked 
operations are created by FeatureCAM's pinch turning feature. 

Removing operations from the sequence 
When you delete a feature, or exclude it by deselecting its check 
box in the Part View, FeatureCAM adjusts the remaining operations 
in the synchronization group. When you reselect a previously 
excluded feature, it is reinstated at its original position in the 
synchronization group.  
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Turning curves 
Follow and pinch turning are now available for the face and back-
face cycles of curves. This enables you reduce machining time and 
take full advantage of multi-turret lathes. 

To select the cutting method for a curve: 

1 Double-click the Turn feature in the Part View panel. The Turn 
Properties dialog is displayed. 

2 Select the Strategy tab. 

3 Select the Turning option. 

4 Under Operations, choose a cutting method for each pass you 
have enabled. Select:  

 Single turret to cut the feature using one turret.  

 Pinch turning to cut the feature using turrets positioned above 
and below the axis of rotation. The tools cut simultaneously: 
the first tool leaves a spiral of material and the second tool 
cuts the spiral of material left by the first tool. For example: 

 
 Follow turning to cut the feature using turrets positioned 

above and below the axis of rotation. Each turret uses a 
standard depth of cut, and the top tool leads the bottom tool. 
For example: 
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5 Click Apply. The details of the turrets are displayed in the tree 
view. For example: 

 
6 Click OK to save your changes and close the dialog. 
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Tool properties for multi-turret machining 
The Override tab of the Tool Properties dialog includes new turret 
options that enable you to set the tool registers for multiple turrets. 
Use them to quickly view and edit the overrides of tools that are 
assigned to different slot numbers on different turrets without using 
the Tool Mapping dialog. 

To specify the register settings of turrets in the Tool Properties 
dialog: 

1 Open the Tool Properties dialog for the tool. 

2 Select the Overrides tab.  

3 Select the Set all turrets option.  

4 In the Turret and spindle list, select the turret you want to work 
with. For example: 

 
5 Edit the Default tool registers settings for the turret.  

6 Repeat steps 4 through 5 for each turret on the machine. 

7 Click OK to save your changes and close the dialog.  

8 If you are asked whether to set the edited tool as override, click 
Yes to use the new tool for the operation; click No to continue 
using the original tool.  

 



 

120 • What's new in FeatureCAM 2015 R1 FeatureCAM 2015 R3 What's New  

Multiple part catchers 
FeatureCAM now supports multiple part catchers on Turnmill 
machines, such as the Nakamura WT-150. Cutoff catchers are 
supported by selecting the Part catcher check box in the Strategy tab 
of the Cutoff Properties dialog; other catchers can be implemented 
by creating user-defined features with FeatureCAM's application 
programming interface (API).  

 
For more information on implementing multiple part catchers, 
contact your sales representative. 
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Wire EDM improvements 
FeatureCAM 2015 R1 contains the following changes and 
improvements to the Wire EDM module: 

 Improved reliability for no-core machining (see page 122) — 
FeatureCAM can create no core toolpaths that ensure no material 
remains after machining. 

 Selecting cutting data (see page 123) — Two new conditions are 
available for selecting data. 
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Improved reliability for no-core machining 
You can create a no-core toolpath that machines an area without 
creating a slug. 

In FeatureCAM 2015 R1, no-core toolpaths are more reliable, and 
no material remains after machining. This eliminates the risk of 
loose pieces being left during cutting, which can cause the machine 
to stop and can damage the nozzle. 

 
To create a no-core toolpath: 

1 Create a 2-Axis Die feature. 

2 Display the Properties dialog for the Die feature. 

3 In the Strategy tab, select Pocketing or Zigzag in the Operations 
list. 

4 To add an unmachined area, click Islands and select a curve 
using the Select Islands dialog. 

5 Click OK to close the dialog. 
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Selecting cutting data 
The Condition dialog contains two new parameters: Nozzle Position 
and Fluid. If your machine supports different nozzle positions or 
different types of dielectric fluid, you can use these parameters to 
select machine register settings from the cut-data database. 

 
To select a machine condition for an existing document: 

1 Create a Wire EDM document, and open the Stock Properties 
dialog. 

2 On the Dimensions tab, click the Condition button. The new 
Nozzle Position and Fluid lists are shown at the bottom of the 
Condition dialog. 

3 In each list, select an option to identify the combination of 
conditions you want to use. If you want to create a new option 
for a list, click the adjacent button and enter its name. For 
example, to specify a new Nozzle Position option: 

a Click . The New Nozzle Position Type dialog is displayed. 

b Enter a name for the new position. 

c Click OK to save your change and close the dialog.  

The option is displayed in the Nozzle Position list.  

4 To check or specify the machine settings for the condition, click 
the Cutting Data button. The Feeds/Speeds and Cutting Data Tables 
dialog is displayed showing the condition you selected:  

 If you have selected a previously defined condition, the 
machine settings for each pass are displayed in the Wire EDM 
tab. To change a setting, double-click its cell in the table and 
overtype the value. 

 If you have selected an undefined condition, a message is 
displayed in the Wire EDM tab. Click New, select the number of 
passes required for this condition, and enter the setting values 
for the condition.  
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 You can customize the Wire EDM table using the Cutting 
Condition Names dialog (see page 141) in XBUILD. 

5 When you have finished, click OK to save your changes and close 
the dialog.  

6 In the Condition dialog, click OK. 

 You can also specify the condition in the Stock wizard. 
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Importing 
FeatureCAM 2015 R1 contains the following changes and 
improvements to importing files from external applications: 

 Using Inventor 2015 (see page 126) — FeatureCAM has been 
certified for use with Autodesk Inventor 2015. 

 Importing Pro/E files (see page 127) — The feature tree of 
imported Pro/E files can be displayed. 

 Importing JT files (see page 127) — You can load solids from JT 
files in addition to surfaces. 

 Importing PDF files (see page 128) — You can import curves from 
Acrobat files using Delcam Exchange. 
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Using FeatureCAM with Inventor 2015 
FeatureCAM has been certified for use with Autodesk Inventor 2015, 
an easy-to-use application for the design and documentation of 3D 
mechanical parts and assemblies. This enables you to use Inventor's 
latest design tools to create models, and then to quickly import 
them into FeatureCAM to create features that are ready for 
machining.   

To use Inventor designs in FeatureCAM: 

1 Open the New Part Document wizard.  

2 Select Open an existing file and click Next. The Open dialog is 
displayed. 

3 In the Files of type list, select Inventor (*.ipt, *.iam). 
4 Select the file you want to work with and click Open.  

5 In the New Part Document wizard, select the type of document 
you want to create, select the Wizard option, and click OK. The 
file is loaded and the Import Results dialog is displayed.  

6 Select Use the wizard to establish the initial setup location, stock 
size, and import features from Inventor. 

 When FeatureCAM is installed on the same computer as 
Inventor, it accesses the Inventor data and creates hole 
features as originally designed.  

7 Complete the wizard to create the part. 
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Importing ProE files 
FeatureCAM can now display the feature tree of imported Pro/E 
files. Only solid models are imported from Pro/E; the solid models 
are imported as surfaces or solids depending on the options you set 
in the Import/Export Options dialog. Only solids are read from a 
Pro/E file. Any curves or surfaces read must be part of a solid. 

 You must have the FeatureCAM ProE Import module to import 
Pro/E files. 

To import CAD files: 

1 Open a new or existing part file. You must have a part open to 
import geometry. 

2 Select the File > Import menu option. The Import dialog is 
displayed. 

3 Select the file you want to import and click Open. The Import 
Results dialog is displayed. 

 Files must have an extension of *.prt, *.prt.%number% (for 
example foo.prt.8), *.asm, or *.asm.%number% (for example 
bar.asm.23).  

 

Importing JT files 
Previously, FeatureCAM was only able to import surfaces from JT 
files even though the format supports other information, such as 
boundary representation surfaces (NURBS), Product and 
Manufacturing Information (PMI), and metadata. In FeatureCAM 
2015 R1, the interoperability of the import process has been 
extended and you can now also load solids from JT files. 

To import a JT file: 

1 Open a new or existing part file. You must have a part open to 
import geometry. 

2 Select the File > Import Using Exchange menu option. The Import 
dialog is displayed. 

3 Select the JT file you want to use, then click Open to import the 
data.  

 You must install Delcam Exchange to use this feature. Contact 
your sales representative for more information. 
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Importing PDF files 
The FeatureCAM license now includes the ability to import curves 
from Adobe Acrobat files using Delcam Exchange.  

For example, to import curves from an acrobat file: 

1 Create a document. 

2 Select the File > Import using exchange menu option. The Import 
dialog is displayed. 

3 In the Files of type list, select PDF Files (*.pdf).  
4 Locate and select the acrobat file containing the curves you want 

to import, then click Open.  

5 A message asks if you want to review the import log. Click Yes to 
view the log, or click No to continue. 

6 If the Import Units dialog is displayed to inform you the file was 
defined using different measurement units to those used in your 
document, select an option then click OK to continue. The Import 
Results dialog is displayed. 

7 Select Use the wizard to establish the initial setup location and stock 
size and click Next to create a part using the Import Wizard, or 
click Accept the imported data 'as is' and exit the wizard and click 
Finish to complete the import process.  

The curves are displayed in the Graphics view and listed in the 
Parts view. 
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Add-ins and extensions 
FeatureCAM 2015 R1 contains the following changes and 
improvements to its add-ins and extensions: 

 Using add-ins (see page 130) — The Macro Add-ins dialog has 
been updated to improve the management of add-ins and 
macros. 

 The Add-in Library (see page 132) — FeatureCAM now includes a 
catalog of add-ins that were previously only available on the 
website. The Add-in Library is a new feature that enables you to 
quickly view and select add-ins from the catalog. 

 Turn-curve tolerance (see page 134) — A new 
TurnCurveTolerance.bas add-in enables you to tolerance multiple 
segments in turned or internal bore features.  

 Exporting NC programs to NCSIMUL (see page 137) — The 
FeatureCAMToNCSIMUL.dll add-in can now export turn/mill 
programs as well as milling programs. 

 Extended machine support (see page 138) — Add-in support for 
traveling steady rests, bar fed mills, and the Mori Seiki NTX1000 
is available for FeatureCAM. 
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Using add-ins 
FeatureCAM 2015 R1 now ships with most of the catalog of add-ins 
available for customizing and extending its abilities. This enables 
you to quickly view and select all the applications that have been 
developed for general and specific purposes without the need to 
locate and download them from the Internet. To accommodate this 
expansion, the Macro Add-ins dialog has been updated to make it 
easier to control and select the add-ins you want to use. 

 
To choose the add-ins you want to use in FeatureCAM: 

1 Select the Options > Add-Ins menu option. The Macro Add-ins 
dialog is displayed.  

2 Select the check boxes of the add-ins you want to use. One or 
more buttons is added to the Macro toolbar for each add-in you 
can control manually.  

Alternatively, if the add-ins are not listed in the dialog, click 
Library (see page 132) to load them from the FeatureCAM 
library, or click  to load them from file. 

 Use the Customize Toolbars dialog to create or change the 
toolbar buttons of add-ins. 
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3 Deselect the check boxes of the add-ins you do not want to use.  

 To remove the selected add-in from the list, click . 

4 If you want to view or edit an add-in, click . The IDE Editor is 
displayed.  

5 Click OK to save your changes and close the dialog.  

To run an add-in, click its button on the Macro toolbar. 
Alternatively, select the View > Run Basic Macro menu option, select 
the macro in the Run Macro dialog, and click Run. 
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The Add-in Library 
The Add-in Library is a new feature for FeatureCAM 2015 R1. It 
contains most of the add-ins currently available for FeatureCAM 
together with descriptions of what they do and how they work. Use 
it to find out more about add-ins and to choose those you want to 
make available in the Macro Add-ins (see page 130) dialog. 

To use the Add-in Library: 

1 In the Macro Add-ins dialog, click the Library button. The Add-In 
Library dialog is displayed. 

 
The left column lists the available add-ins and macros, 
categorized by type; add-ins already available in the Macro Add-
ins dialog are marked by a check  icon.  

2 Choose one or more actions: 

 To show programming examples in the list, select the Include 
programming examples check box.  

 To search the list, type a string in the Search box. For 
example, to restrict the list to only those add-ins that include 
NCCode in their name, type NCCode. 

 To display the Description of an add-in, select its entry in the 
list. 
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 To add an add-in to the Macro Add-ins dialog, select its entry 
in the list and click Load. The entry is marked by a plus  
icon. 

 To remove an add-in from the Macro Add-ins dialog, select its 
entry in the list and click Unload. The entry is marked by a 
cross  icon.  

3 Click OK to save your changes and close the dialog. Loaded add-
ins are listed in the Macro Add-ins dialog; unloaded add-ins are 
removed from it.  
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Turn-curve tolerance 
TurnCurveTolerance.bas is a new add-in which enables you to 
tolerance turned or internal bore features according to ISO 282-2 
standards or custom tolerances specified in design documents. Use 
it to quickly resize features without redrawing the curve.  

To adjust a curve: 

1 Install the TurnCurveTolerance.bas add-in. 

2 Select the turning or internal bore feature in the Part View. 
3 In the Macros toolbar, click the add-in's button. The Fillet and 

Chamfer Limit dialog is displayed. 

 
4 Enter the size of the largest fillet or chamfer of the feature: 

 Diagonals and arcs shorter than or equal to this value are 
treated as chamfers and fillets. When neighboring segments 
are adjusted, the add-in translates them without changing 
their size or orientation.  

 Diagonals and arcs longer than this value are treated as 
stationary parts of the curve. They affect the tolerance limits 
of adjacent segments and are not translated. 
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5 Click OK. The Tolerance of Turned Segments dialog is displayed, 
and the vertical and horizontal segments are labeled in the 
Graphic View.  

 
6 Adjust the labels: 

 To change the label size, enter a new value in the Set text size 
box, and click Set.  

 To label only the currently selected segment, deselect the 
Segment labels on check box. 

7 In the Segments list, select the segment you want to adjust. The 
segment and its label are displayed in red. 

 
8 Specify the adjustment for the segment: 

 To calculate the adjustment from specified tolerances, select 
the Upper tolerance - Lower tolerance option and enter the 
tolerance values.  

 To calculate the adjustment from standard tolerances, select 
the Upper tolerance - Lower tolerance option, and select the 
tolerances in the ISO 286-2 list. 
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 To specify the adjustment, select Net tolerance, and enter the 
distance by which you want to move the segment. 

9 Click Apply Tolerance. The adjustment for the segment is 
displayed below the button. 

10 Repeat steps 7 through 9 for each segment you want to adjust. 

11 Click OK to apply your changes and close the dialog.  

FeatureCAM creates a new curve and feature, and displays the 
results in the Graphic window. For example: 
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Exporting NC programs to NCSIMUL 
FeatureCAMToNCSIMUL.dll is an add-in, which provides the ability 
to export NC code for simulation and optimization in NCSIMUL. In 
FeatureCAM 2015 R1, the add-in has been extended to enable the 
export of turn/mill programs as well as the original milling 
programs. 

To export a program to an NCSIMUL project: 

1 Install NCSIMUL on your computer and the NCSIMUL tool for 
reading FeatureCAM files. 

2 In FeatureCAM, open the milling or turn/mill document you want 
to export. 

3 Run a simulation and generate the NC code, Ensure the code has 
no errors. 

4 Select the Options > Add-Ins menu option. The Macro Add-ins 
dialog is displayed. 

5 Select the FeatureCAMToNCSIMUL.dll check box. 

 If the add-in is not listed in the dialog, you can load it from 
the Add-ins Library dialog. 

6 Click OK. The FeatureCAM to NCSIMUL add-in button is displayed 
in the Macros toolbar. 

7 Click the FeatureCAM to NCSIMUL button on the Macros toolbar. 
The FeatureCAM to NCSIMUL dialog is displayed. 

8 In the FeatureCAM to NCSIMUL dialog, select the export options 
for the document.  

9 Click Export to save the NC code to file. FeatureCAM simulates 
the part and exports the program files. When the export is 
finished, a message lists the files and their locations. 
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Extended machine support 
FeatureCAM now includes add-in support for the following machines 
and features: 

Mori Seiki NTX1000 
The Mori Seiki NTX1000 is an integrated mill turn center designed 
for machining small, precision parts. A new machine design (.md) 
file and post are available for programming the machine together 
with a user defined feature for controlling the actions of the 
workpiece discharge unit.  

Traveling steady rests 
A new TravelingSteadyRest. bas add-in enables you to program a 
steady rest to follow behind the tool while roughing bar stocks. This 
add-in is not available in the library as it requires a customized post 
and machine model for each installation. For more information, 
contact the post-processor department of your local support office. 

Bar-fed mills 
Bar-fed mills, such as the Willemin-Macodel 408MT, enable you to 
machine multiple parts automatically from bar stock, and to 
automatically transfer the machined slugs to the sub-spindle to 
machine the cut-off face. This eliminates the need for manually 
positioning the part, which can be a source of inaccuracy. 
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XBUILD improvements 
FeatureCAM 2015 R1 contains the following changes and 
improvements to the XBUILD module: 

 Custom formats (see page 140) — The Custom Format Name 
dialog has an enhanced user interface to support the creation of 
naturalistic process names. 

 Customizing cutting data from Wire EDM (see page 141) — You can 
now configure the headings of the cutting data table for use with 
Wire EDM. 

 Saving CNC files (see page 144) — Post numbers can be used to 
identify individual output files for Fanuc-style multi-turret lathes. 

 Configuring reserved words (see page 146) —The Word Info dialog 
includes a new option that enables you remove all non-significant 
zeros from numeric outputs 

 Using the Reserved Words dialog (see page 147) — The Reserved 
Words dialog is easier and quicker to use.  
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Custom Formats 
The Custom Format Name dialog now supports the use of 
underscores and periods in format names. This enables you to 
create more naturalistic process names and to accurately represent 
decimal measurements. In addition, space characters are 
automatically converted to underscores to ensure the names are 
unbroken. 

To create a Custom Format: 

1 In XBUILD, select the Formats > Custom > New menu option. The 
Custom Format Name dialog is displayed. 

2 Enter a name for the custom format. You can use any upper- or 
lower-case character, periods, and underscores. For example: 

 
3 Click OK to create the format and close the dialog. The XBUILD 

Editor is displayed with the format name in the Title bar. 

4 When you have finished creating the format, select the File > Quit 
menu option, and click Yes in the message dialog to save your 
changes. 
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Customizing cutting data for Wire EDM 
The Wire EDM tab (see page 123) in FeatureCAM has been extended 
to include customizable fields, which can be used to record 
machine-specific settings as well as the original Feed, Water, Comp-
num, and Comp-val values. To enable you to manage and customize 
all the fields, the Cutting Condition Names dialog has been 
redesigned, and it now lists the original settings followed by 16 
fields that can contain numeric information and 6 fields that can 
contain strings.  

To specify the condition names: 

1 In XBUILD, select the CNC-Info > Machine menu option. The 
Machine Information dialog is displayed.  

2 In the Machine type list, select Wire EDM and click OK to close the 
dialog. 

3 Select the CNC-Info > Cutting Condition Names menu option. The 
Cutting Condition Names dialog is displayed. 
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4 In the Reserved Word column, click the setting you want to 
customize, and type a name for it in the box at the bottom of the 
table. The name is displayed in the custom name column of the 
table. For example: 

 
5 Repeat step 4 for each setting you want to customize. 

6 Click OK to save your changes and close the dialog. 

7 Select the File > Save CNC or File > Save as CNC menu option to 
save the post file.  
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When you next view the stock settings, the field names you 
specified are displayed on the Wire EDM tab of the Feeds/Speeds And 
Cutting Data Tables dialog. For example:  
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Saving CNC files 
FeatureCAM 2014 R2 included the ability to display the post number 
of turrets throughout the user interface. In FeatureCAM 2015 R1, a 
new Use P numbers in NC file name option has been added to the 
Turret Information dialog that enables you to also include these post 
numbers in the names of saved NC files. In addition, a new NC File 
Extension box gives you the ability to customize the letter used as 
the post extension's prefix. 

 
To specify the turret identifier for the CNC files: 

1 In XBUILD, select the CNC-Info > Turrets menu option. The Turret 
Information dialog is displayed. 

2 In the Multi-turret programming list, choose an option to specify 
the type of NC Program files you want to create. Select:  

 None for lathes with one turret. 

 Okuma Style for multi-turret lathes that require one program 
file for all turrets.  

 Fanuc Style for multi-turret lathes that require a separate 
program file for each turret. 

3 By default, the turret identifier starts with P. If you want to use a 
different prefix, enter a new character in the NC file extension 
box. 
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4 Select the Use P numbers in NC file name check box to use the P 
number of each turret as the suffix of the NC file extension. 
Deselect the check box to use the default post numbers for the 
file extensions. 

5 Complete the settings, and click OK to save your changes and 
close the dialog. 

6 Save the post file. 

7 In FeatureCAM, generate the NC code for your part, and select 
the File > Save CNC menu option. The Save NC dialog is displayed. 

8 Enter the output settings and click OK to create the NC program 
files: 

 With Fanuc-style and Use P numbers in NC file name selected; 
the P numbers are 1, 3, 11, 20; and an NC file extension of T, 
FeatureCAM creates files named: %DocumentName%.T1.TXT, 
%DocumentName%.T3.TXT, %DocumentName%.T11.TXT, and 
%DocumentName%.T20.TXT. 

 With Fanuc -style selected and Use P numbers in NC file name 
deselected; P numbers of 1, 3, 11, 20; and an NC file extension 
of T, FeatureCAM creates files named: %DocumentName%.TXT, 
%DocumentName%.T2.TXT, %DocumentName%.T3.TXT, and 
%DocumentName%.T4.TXT. 

 With Okuma-style or None selected, only one file is created. 
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Configuring reserved words 
The Word Info dialog enables you to view and change the output 
format for reserved-word values. In FeatureCAM 2015 R1, the 
dialog has been redesigned, and now includes a Minimize width 
option, which allows you to omit all non-significant zeros from 
numeric outputs, and a Preview column, which displays the effect of 
the settings for each reserved word. 

 
To configure the output of reserved words: 

1 In XBUILD, select a Words option in the CNC-Info menu. The 
Words Info dialog displays the sub-set of reserved words for the 
option you selected. 

2 For each reserve word you want to update, select the Minimize 
width check box. This removes leading zeros from decimal-only 
outputs and trailing zeros from integer-only outputs. For 
example, when the check box is selected, the reserved word 
outputs 4 as 4, and 0.2 as .2; when the check box is deselected, 
4 is output as 4.0, and 0.2 is output as 0.2.  

3 Check the effect of your changes using the Preview column: 

 To test the effect of the settings on different outputs, type a 
new value in the box above the column. 

 To test the effects of the Inch format and Metric format 
settings, select the preview options below the column. 

4 Click OK to close the dialog and save your changes.  
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Using the Reserved Word dialog 
The Reserved Word dialog of the Formats editor enables you to 
quickly add variables to the format you are editing.  

 
In FeatureCAM 2015 R1, several new features have been added to 
the dialog that make it easier for you to find and add words to a 
format: 

 Words are now identified by category: string words are followed 
by (S); logical words are followed by (L): and numeric words are 
followed by (N); system words have no identifier. 

 Tabs across the top of the dialog enable you to restrict the list to 
a specific category of word. For example, to list only system 
words, select the System tab; to list all reserved words again, 
select the All tab. 

 In the All tab, words are listed in alphabetical order instead of by 
alphabetical order within category. This enables you to look for 
words by name without knowing the category it belongs to.  

 A new search box below the tabs enables you to list only those 
words that contain a specified string. For example, type spindle in 
the box to list only those words that contain the string "spindle". 
When you select a word, the box is automatically cleared and the 
list scrolls to display the word's entry. 

 In addition to being selectable, the Modal delimiters check box 
can now be toggled on and off using the Control key. To insert a 
word in modality brackets, press the Control key; select the word 
in the list, and release the key.  
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