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FeatureCAM issues a major enhancement release in September, 
January, and May every year. For details of our developments in the 
last twelve months, see: 

What's New in FeatureCAM 2016 R1 (see page 2) 

What's New in FeatureCAM 2015 R3 (see page 47) 

What's New in FeatureCAM 2015 R2 (see page 80) 

Also, visit our website at http://www.delcam.tv/lz/ for up-to-the-
minute news and videos; and visit http://updates.delcam.com to 
download our latest service packs and enhancements. 

 

What's New 
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FeatureCAM 2016 R1 contains the following new features and 
enhancements: 

User interface 
 Reference help PDF (see page 6) — The FeatureCAM Reference 

help is now available as a PDF file. 

 Highlighting objects from the Part View (see page 7) — You can 
now highlight objects in the graphics window by moving the 
cursor over the object's name in the Part View. 

 Creating Setups during IFR (see page 8) — You can now create 
Setups from within the New Feature wizard when using 
Interactive Feature Recognition. 

 Changing the simulation tool color (see page 9) — You can now 
manually change the tool color at any time in a simulation. 

 Displaying NC Code (see page 10) — NC code is now displayed 
using fixed width text, where all the characters line up vertically, 
to make it easier to read. 

 Creating curves (see page 11) — The images in the curve 
creation dialogs have been improved to make them easier to 
understand. 

What's new in 
FeatureCAM 2016 R1 
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Importing 
 Imported solid names (see page 13) — When you import a solid 

into FeatureCAM the solid name is now retained from the original 
program. 

 Importing AutoCAD files (see page 13) — You can now import 
ACIS solids from DWG files. 

 Spatial R25 SP2 Interop integrated (see page 14) — Spatial R25 
SP2 Interop is now integrated. 

 Parasolid v27.1 (see page 14) — FeatureCAM now supports 
parasolid v27.1. 

Milling 
 Vortex non-cutting moves (see page 16) — You now have more 

control over the non-cutting moves in vortex toolpaths. 

 Collision avoidance (see page 17) — Toolpaths are now collision-
checked between unmachined stock and the shank and holder. 

 Swarf machining Z limits (see page 18) — You can now limit Swarf 
operations to within a specified Z range on the surface. 

 5-Axis 2D spiral toolpaths (see page 20) — You can now specify 
axis smoothing options for 2D spiral toolpaths. 

 Side grooves (see page 21) — The toolpath calculation for ID and 
OD Grooves has been improved with several new options and 
supported functions. 

 Multiple coolant types (see page 23) — You can now use multiple 
coolant types for a single operation. 

 User Defined Stock for NT toolpaths (see page 24) — When using a 
stock solid and you create a 2D NT toolpath, FeatureCAM now 
calculates the toolpaths using the stock solid boundary to 
prevent air-cutting. 
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Turning 
 Turning tool orientation (see page 26) — You can now use a 

turning tool in multiple orientations without having to create a 
different tool in the database for each orientation. 

 Roughing engage angle (see page 28) — You can now specify the 
engage angle, lead in angle, and lead out angle for Turning 
roughing operations. 

 Negative leave allowance for grooves (see page 29) — You can 
now use a negative leave allowance for groove features created 
from curves. 

Add-ins and extensions 
 Setup Sheet add-in (see page 31) — There are new tags which 

you can use to create more useful setup sheets. 

 FeatureCAM to CAMplete (see page 32) — In the FeatureCAM to 
CAMplete dialog (see page 110), there is a new button that 
enables you to mark solids that are selected in the part as 
clamps. 

 API improvements (see page 32) — The API has been improved to 
support full machine architecture. 

XBUILD 
 Intermediate CNC files (see page 40) — You can now split the nc 

file into multiple intermediate files, and then combine these 
intermediate files in different ways to create multiple output files. 

 Multi-code coolant (see page 42) — You can now use different on 
and off codes for a single coolant type, depending on which 
turret and tool is being used. 

 5-axis untransformed coordinates (see page 44) — There are new 
milling reserved words that contain the untransformed X, Y, and 
Z coordinates in a 5-axis part. 

 Formatting reserved words (see page 45) — When formatting 
numeric reserved words in XBUILD, you can now remove trailing 
zeros from integer values without removing the decimal point. 

 CNC documentation (see page 46) — The HTML documentation 
has been improved to make the output more readable. 
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User Interface and work-flow 
FeatureCAM 2016 R1 contains the following changes and 
improvements to the user interface and work-flow: 

 Reference help PDF (see page 6) — The FeatureCAM Reference 
help is now available as a PDF file. 

 Highlighting objects from the Part View (see page 7) — You can 
now highlight objects in the graphics window by moving the 
cursor over the object's name in the Part View. 

 Creating Setups during IFR (see page 8) — You can now create 
Setups from within the New Feature wizard when using 
Interactive Feature Recognition. 

 Changing the simulation tool color (see page 9) — You can now 
manually change the tool color at any time in a simulation. 

 Displaying NC Code (see page 10) — NC code is now displayed 
using fixed width text, where all the characters line up vertically, 
to make it easier to read. 

 Creating curves (see page 11) — The images in the curve 
creation dialogs have been improved to make them easier to 
understand. 
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Reference help PDF 
The FeatureCAM Reference help is now available as a PDF file, which 
enables you to print it to use away from your computer. 

Select the new Help > Reference (PDF) to display the Reference help 
PDF. 
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Highlighting objects from the Part View 
You can now highlight objects in the graphics window by moving the 
cursor over the object's name in the Part View. This enables you to 
find features quickly and improves the work-flow in complex 
documents. 

For example, move the cursor over an object in the Part View: 

 
The object is highlighted in green in the graphics window: 

 
To turn off this option, deselect Show feature dynamic highlight on 
the General tab of the Viewing Options dialog. 
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Creating Setups during IFR 
When creating Milling and Wire EDM features using Interactive 
Feature Recognition, you can now create Setups from within the 
New Feature wizard. This enables you to program parts with multiple 
setups more quickly. 

To create a Setup using the New Feature wizard: 

1 In the New Feature wizard, select the feature type you want to 
recognize. 

2 Select Extract with FeatureRECOGNITION. 

3 Click the new Create new setup button. 

 
The Setup wizard is displayed. 

4 Use the Setup wizard to create a new setup, then click Finish. 

The New Feature wizard is displayed. 

You can use the Create new setup button to create more setups, 
or click Next and use the New Feature wizard to create features. 
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Incrementing tool color in simulation 
You can now manually change the tool color at any time in a 
simulation to make it easier to understand the toolpaths and see 
the tool simulation. For example you can use this to display 
different passes of an operation in different colors to check for air 
cutting. 

This is only available for 3D, 3D rapid cut and machine simulations. 

To change the tool color during a simulation: 

1 In the Simulation Options dialog, on the General tab, ensure Tool 
Colors is selected. 

2 Run a simulation. 

The tool color is displayed during the simulation. 

 

3 Click the new Change the Simulation Tool Color  button. 

4 Continue the 3D simulation. 

The tool color is changed in the simulation. 
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Displaying NC Code 
NC code is now displayed using fixed width text, where all the 
characters line up vertically, to make it easier to read. 

You can display the NC Code in a variable-width font by right-
clicking in the NC Code window and deselecting Fixed Width Font. 
Variable-width text requires less horizontal space. 
Variable width Fixed width 
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Creating curves 
The images in the curve creation dialogs have been improved to 
make them easier to understand. 

Letters are now used to show dimensions instead of arrows. 
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Importing 
FeatureCAM 2016 R1 contains the following changes and 
improvements to importing: 

 Imported solid names (see page 13) — When you import a solid 
into FeatureCAM the solid name is now retained from the original 
program. 

 Importing AutoCAD files (see page 13) — You can now import 
ACIS solids from DWG files. 

 Spatial R25 SP2 Interop integrated (see page 14) — Spatial R25 
SP2 Interop is now integrated. 

 Parasolid v27.1 (see page 14) — FeatureCAM now supports 
parasolid v27.1. 

 



 

FeatureCAM 2016 R1 What's New What's new in FeatureCAM 2016 R1 • 13  

Solid names 
When you import a solid into FeatureCAM the solid name is now 
retained from the original program. Previously, imported solids were 
named ps_solid and numbered sequentially. 

This applies when importing X_T, SolidWorks, SolidEdge files, when 
pasting from PowerSHAPE, and for any solids imported using 
Exchange. 

 You can turn this off with the importUseParasolidName 
variable in the INI file. 

 

Importing AutoCAD files 
You can now import AutoCAD files using the FeatureCAM native 
import. Previously you could only import using Exchange. The 
FeatureCAM native import is quicker, and enables you to import 
3DSOLID, REGION, and BODY entities as solids, instead of as a 
collection of surfaces. 

When you import an AutoCAD file that contains solids, the AutoCAD 
Import Method dialog is displayed. 

 
Select Natively within FeatureCAM... and click OK to use 
FeatureCAM's native import. 

For some files this may behave differently to the old method of 
importing using Exchange. To use the old method of importing, 
select the File > Import Using Exchange menu option. 
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Spatial R25 SP2 Interop integrated 
Spatial R25 SP2 Interop is now integrated. 

3D InterOp-enabled applications now support CATIA V5-6 R2015 
and NX 10. 

 
 

Parasolid v27.1 
FeatureCAM now supports parasolid v27.1. 
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Milling 
FeatureCAM 2016 R1 contains the following changes and 
improvements to milling: 

 Vortex non-cutting moves (see page 16) — You now have more 
control over the non-cutting moves in vortex toolpaths. 

 Collision avoidance (see page 17) — Toolpaths are now collision-
checked between unmachined stock and the shank and holder. 

 Swarf machining Z limits (see page 18) — You can now limit Swarf 
operations to within a specified Z range on the surface. 

 5-Axis 2D spiral toolpaths (see page 20) — You can now specify 
axis smoothing options for 2D spiral toolpaths. 

 Side grooves (see page 21) — The toolpath calculation for ID and 
OD Grooves has been improved with several new options and 
supported functions. 

 Multiple coolant types (see page 23) — You can now use multiple 
coolant types for a single operation. 

 User Defined Stock for NT toolpaths (see page 24) — When using a 
stock solid and you create a 2D NT toolpath, FeatureCAM now 
calculates the toolpaths using the stock solid boundary to 
prevent air-cutting. 
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Vortex non-cutting moves 
You now have more control over the non-cutting moves in vortex 
toolpaths, which enables you to reduce machining times. Use the 
new Vortex Non-Cutting Moves dialog to specify whether to retract 
and increase the feed rate on non-cutting moves. 

To display the Vortex Non-Cutting Moves dialog: 

 for 2D toolpaths, click Non-Cutting Moves in the Stepovers tab of 
the Feature Properties dialog. 

 for 3D toolpaths, click Non-Cutting Moves in the Strategy tab of 
the Feature Properties dialog. 

 to change the default options, click Non-Cutting Moves in the 
Milling tab of the Machining Attributes dialog. 

 
Under Retract on non-cutting moves, select whether you want the 
tool to retract on non-cutting moves: 

 Never — the tool does not retract on non-cutting moves. 

 Automatic — FeatureCAM will decide when the tool should retract 
on non-cutting moves. 

 Longer than — the tool retracts instead of making non-cutting 
moves larger than the value you enter. For example, the left 
image is a standard vortex toolpath and in the right image the 
non-cutting moves are replaced with retracts. 
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Select Increase feed rate for non-cutting moves to override the feed 
rate for non-cutting moves with the specified Non-cutting feed rate. If 
the Non-cutting feed rate is lower than the Feed rate specified on the 
F/S tab, the Non-cutting feed rate is ignored. 

 
 

Collision avoidance 
Toolpaths are now collision-checked between unmachined stock and 
the shank and holder. Previously, you could only collision-check the 
shank and holder against the model, not the stock. 

2016 R1 2015 R3 

  

  No collision   Collision 

  

To enable collision-checking against the shank and holder, select 
Holder collision clipping on the Strategy tab of the Feature Properties 
dialog. 
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Swarf machining Z limits 
You can now limit Swarf operations to within a specified Z range on 
the surface. This enables you to limit air cutting, such as by limiting 
the toolpath where part of a surface has already been machined, 
and gives you more control when using swarf machining with other 
operations. 

 
This was previously available for most 3D finish operations except 
swarf. 
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To specify the Z limits, use the new Z start and Z end attributes in 
the Milling tab of the Feature Properties dialog. 

 
Select Z start or Z end to display the location of the Z limits in the 
graphics window. 

The toolpath follows the isolines of the surface, but the toolpath is 
clipped above and below the specified Z level. 

5 Axis simultaneous 
For 5 axis simultaneous machining, you may not be able to enter 
values accurately for Z start and Z end depending on the rotation of 
the view and the axes, but you can use the Pick Z location button to 
pick the location in the graphics window and FeatureCAM will 
calculate the required value. 
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5-axis 2D spiral toolpaths 
In FeatureCAM 2015 R3, the 5-Axis tab was made available for 2D 
spiral toolpaths, which enables you to perform 5-axis engraving. 

You can now specify axis smoothing options using the Axis 
Smoothing tab, which enables you to create smoother toolpaths 
which give a better surface finish and reduce tool wear. 

 
To display the Axis Smoothing tab, ensure Tool axis smoothing is 
selected on the 5-Axis tab, then click Apply. 

 

 



 

FeatureCAM 2016 R1 What's New What's new in FeatureCAM 2016 R1 • 21  

Side grooves 
The toolpath calculation for ID and OD Grooves has been improved 
with several new options and supported functions. This gives you 
more control when creating side groove features, so you can create 
better and smoother toolpaths with better gouge checking. 

 
The new toolpath calculation is enabled by default. To disable it, 
deselect Use New ID/OD Groove on the Milling tab of the Machining 
Attributes dialog. 
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When this option is selected, these changes are made to side 
groove toolpaths: 

 The plunge and retract moves are checked for gouges. 

You can disable the gouge checking on plunge and retract moves 
by deselecting the Plunge gouge check option on the Strategy tab 
of the Feature Properties dialog. 

 You can use wind fan finishing for the finish operation. 

To specify the wind fan settings, click Wind Fan on the Strategy 
tab of the Feature Properties dialog, and use the Wind Fan Finish 
Options dialog. 

 You can use arc lead-in moves for the finish operations. 
Previously you could only use a linear lead-in move. 

To use an arc lead-in move, select Arc Lead on the Stepovers tab 
of the Feature Properties dialog. 

 You can set a start point for the finish pass. 

To set a start point, use the Start point attribute on the Plunge 
tab of the Feature Properties dialog. 

  

To create a side groove feature, create a Groove feature and select 
the Inside/Outside option on the Dimensions tab of the Feature 
Properties dialog. 
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Multiple coolant types 
You can now use multiple coolants for a single operation. Previously 
you could only use one type of coolant for an operation. 

There is a new Coolant tab where you can specify the types of 
coolant for an operation. Previously, you selected the coolant type 
from a list on different tabs depending on the operation type. 

The new Coolant tab is available in these places: 

 Set the coolant for an operation in the Feature Properties dialog. 

 
 Set the default coolant for a tool in the Tool Properties dialog. 
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 Set the default coolant for the document in the Machining 
Attributes dialog, for both Mill and Turn. 

 
 

User Defined Stock for NT toolpaths 
When using a stock solid and you create a 2D NT toolpath, 
FeatureCAM now calculates the toolpaths using the stock solid 
boundary to prevent air-cutting. Previously this was only available 
for OT toolpaths. 

In this example, a Boss feature is cut using a stock solid. 
2015 R3: 2016 R1 
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Turning 
FeatureCAM 2016 R1 contains the following changes and 
improvements to turning: 

 Turning tool orientation (see page 26) — You can now use a 
turning tool in multiple orientations without having to create a 
different tool in the database for each orientation. 

 Roughing engage angle (see page 28) — You can now specify the 
engage angle, lead in angle, and lead out angle for Turning 
roughing operations. 

 Negative leave allowance for grooves (see page 29) — You can 
now use a negative leave allowance for groove features created 
from curves. 
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Turning tool orientation 
You can now use a turning tool in multiple orientations without 
having to create a different tool in the database for each 
orientation. 

For example, this tool is used in two orientations, but only one tool 
is required in the tool database. 

 
Previously, to use a tool in multiple orientations you had to create 
duplicates of the tool, and select the tool orientation on the 
Orientation tab of the Tool Properties dialog. 
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Select the new Automatic tool orientation option in the Misc tab of 
the Machining Attributes dialog. 

 
When Automatic tool orientation is selected, only tools in the default 
orientation are available, but the specified tool orientation is ignored 
and a tool can be used in any orientation. 

For example, for OD turning operations, only tools with a SW 
orientation are available: 
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If you have any tools in the non-default orientation, specify the 
orientation as default and you can use it in any orientation, 
otherwise the tool will not be available. 

 
 

Roughing engage angle 
You can now specify the engage angle, lead in angle, and lead out 
angle for Turning roughing operations. Previously you could specify 
these options only for the finish pass. 

This enables you to prevent the tool from plunging directly into the 
stock, reducing the load on the tool. 

 

Engage angle 
To specify the engage angle for a roughing operation, set the new 
Engage angle option on the Turning, Facing, or Boring tab of the 
Feature Properties dialog. 

 
You can enter an Engage angle between 0 and 90. The tool engages 
the part at the specified angle for boundary moves, but a lower 
value may be used if the value you enter would be above the rapid 
level. 

Lead in and lead out angle 
To specify the lead in and lead out angles for a roughing operation, 
ensure the TNR comp option is selected on the Strategy tab of the 
Feature Properties dialog, and set a Lead in angle and Lead out angle 
on the Turning, Boring, or Facing tab. 

The tool engages the part at the lead in angle for boundary moves 
and disengages the part at the lead out angle. 
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Default values 
You can set the default values for these angles on the Turn/Bore tab 
of the Machining Attributes dialog. 

 
Previously you could set the default Engage angle, Lead in angle, and 
Lead out angle. You can now set these options separately for rough 
and finish operations. 

 
 

Negative leave allowance for grooves 
In FeatureCAM you can set a leave allowance to leave unmachined 
material after a finish pass, and you can set a negative leave 
allowance to machine past the feature boundary, such as to allow 
for shrinkage. 

You can now use a negative leave allowance for Groove features 
created from curves. Previously, this was only available for Grooves 
created from dimensions. 

You can edit the Leave allowance attribute for an operation on the 
Turning tab of the Feature Properties dialog. 

 
To change the default value, enter a Leave allowance on the Turning 
tab of the Machining Attributes dialog. 
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Add-ins and extensions 
FeatureCAM 2016 R1 contains the following changes and 
improvements to add-ins and extensions: 

 Setup Sheet add-in (see page 31) — There are new tags which 
you can use to create more useful setup sheets. 

 FeatureCAM to CAMplete (see page 32) — In the FeatureCAM to 
CAMplete dialog (see page 110), there is a new button that 
enables you to mark solids that are selected in the part as 
clamps. 

 API improvements (see page 32) — The API has been improved to 
support full machine architecture. 

 Nesting add-in (see page 34) — You can now use PowerSHAPE's 
nesting tool to nest parts in FeatureCAM. 

 Import Vise add-in (see page 36) — You can now import vises into 
FeatureCAM for 3D simulation and gouge checking. 

 Bar-fed mills support (see page 38) — Bar-fed mills are now 
supported, such as the Willemin-Macodel 408MT and Mazak 
integrex i-150. 
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Setup Sheet add-in 
You can use the SetupSheet.dll add-in to generate html setup sheets 
from your document to give information to the machine operator 
about the manufacturing, tooling, and toolpaths of a part. 

There are new tags which you can use to create more useful setup 
sheets: 

 Turn tool orientation 

 operation.tool_holder_orientation — tool holder 
orientation (for lathe and thread tools) 

You can use this with or without the new Automatic tool 
orientation option (see page 26). 

 Spot drill body diameter 

 use_order_tool.body_diameter — tool body diameter (User 
Order Tool Loop) 

 operation.tool_body_diameter — tool body diameter 
(Setup Loop) 

 tool.body_diameter — tool body diameter (Tool Loop) 

 Drill cycle and first peck 

 operation.drill_cycle_type — drill cycle type of the 
operation 

 operation.drill_peck_depth — peck depth of a drill 
operation 

 operation.drill_peck_depth2 — peck depth 2 of a drill 
operation 

 operation.drill_min_peck — min peck of a drill operation 

 Operation number 

 operation.number — the operation number displayed in the 
Details tab of the Results window in FeatureCAM 

 The CNC post processor file name 

 fm.cnc_file_name — The name of the cnc file used to 
generate the nc code. 
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 Tool list. See the Setup Sheet help for how to use these options. 

 Show a tool only once in the operation list, even when it is 
used in multiple operations. 

 List only the tools you have marked. You can mark tools by 
adding _SHOWTOOL to the Comments field in the Tool 
Properties dialog. 

To see the Setup Sheet help, click the Help button in the Setup 
Sheet Options dialog. 

 

FeatureCAM to CAMplete 
CAMplete TruePath is an application that you can use to analyze, 
modify, optimize, simulate and post 5-Axis toolpaths. You can use 
the FeatureCAM to CAMplete add-in to export a document to use 
with CAMplete TruePath. 

In the FeatureCAM to CAMplete dialog (see page 110), there is a new 
button that enables you to mark solids that are selected in the part 
as clamps. 

To mark selected solids as clamp solids, click Select solids selected in 
the part. 
The solids are selected in the Select solids to be exported as clamps 
list. 
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FeatureCAM API improvements 
The API has been improved to support full machine architecture: 

 pallet changes are now supported. 

 you can temporarily disable gouge checking between solids. 

 you can temporarily remove a solid from the machine heirarchy. 

 you can move the tool change location. 

 you can query the current operation, feature, tool and setup. 

See the FeatureCAM API help for more information. Select the Help 
> FeatureCAM API help menu option to display the FeatureCAM API 
help. 
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Nesting add-in 
There is a new Nesting add-in that you can use to nest multiple 
parts and machine them from a single stock using PowerSHAPE's 
nesting tool.  

You must have PowerSHAPE open to use the add-in, and you can 
only nest parts which have a solid model. 

To use the Nesting add-in: 

1 Load the Nesting.bas add-in. 

2 On the Utilities toolbar, click Nesting . 

The Nesting To FeatureCAM dialog is displayed. 

 
3 In the Stock list, select the block in which you want to nest the 

parts. 

Select an existing block to nest additional parts in a block you 
created previously, or select New Block to start a new block. 

4 In the fields around the stock diagram, enter the dimensions of 
the block in which you want to nest the parts. 

5 Enter the Distance between parts to specify the minimum distance 
you want to leave between the nested parts on the block. 
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6 Enter a Text height to specify the height of the label on each part. 

7 Click Add and use the Open dialog to select the parts you want to 
nest. 

8 Enter the Quantity to specify how many duplicates of each part 
you want to nest in the block. 

9 Enter the Priority to determine which parts to nest first. The parts 
with lowest Priority values are nested first. For parts with the 
same Priority value, the largest parts are nested first. 

10 Enter the Rotation increment to specify the smallest increment by 
which the part can be rotated when nesting. You may be able to 
fit more parts in a block by reducing the Rotation increment. 

11 To remove a part from the dialog, select the row and click Delete. 

12 Click OK to nest the parts. 

FeatureCAM opens each file and puts all the features into a 
group, then adds the features to a new FM file. The solids are 
sent to PowerSHAPE and nested using PowerSHAPE's nesting 
tool. 

When the nesting is completed in PowerSHAPE, a message dialog 
is displayed telling you to modify the positions of the parts in 
PowerSHAPE if necessary. 

13 Modify the position of the parts in POWERSHAPE, then click OK to 
close the message dialog. 

The positions of the parts are updated in FeatureCAM. 

A message dialog is displayed asking if you want to save the 
stock. 

14 Click Yes to run a 3D simulation and save the stock. This enables 
you to nest additional parts in this block later. 

You can select saved stocks in the Stock list in the Nesting To 
FeatureCAM dialog to nest additional parts in a saved stock. 

A message dialog is displayed saying the nesting is completed. 

15 Click OK to close the dialog. 

 

 



 

36 • What's new in FeatureCAM 2016 R1 FeatureCAM 2016 R1 What's New  

Import Vise add-in 
There is a new Import Vise add-in that you can use to import vises 
into FeatureCAM for 3D simulation and gouge checking. 

1 Load the Import_Vise.bas add-in. 

2 On the Utilities toolbar, click Import_Vise. 

The Import Vise dialog is displayed. 

 
3 In the Vise list, select the vise you want to import. 

A preview of the vise is displayed in the dialog. 

Vises 
1 Select an option in the Part position in vise list to specify how to 

align the part in the vise. 

2 Under Part along, select the axis that you want to be 
perpendicular to the jaws to specify the orientation of the part in 
the vise. 

3 Under X offset from position, enter the offset of the part along the 
axis parallel to the jaws. You can enter a negative value. 

For example, select a Part position in vise of Left and enter a X 
offset from position of -1 to extend the part by 1 inch past the left 
edge of the jaws. 

4 Under Hold the part on, enter the height at which to hold the part 
in the vise. 

5 Under Jaws position, select how you want to position the jaws to 
hold the part. 

For Selected Solid Faces, Selected Surfaces, and Selected 
geometry, select items in the graphics window. 
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6 For vises with multiple holding positions, select Alternative 
holding to use the alternative holding position. 

7 To add parallels to raise the part in the vise, select Add parallels 
and select the Parallels dimensions from the list. 

8 Click Import to import the vise. 

Turning chucks 
1 Under Part along, select the axis about which the chuck rotates to 

specify the orientation of the part in the vise. 

2 Under Z offset from position, enter an offset to raise or lower the 
part in the jaws. 

3 Under Part length from Jaws Faces, enter the length of part you 
want to extend past the top of the jaws. 

4 Under Jaws position, select how you want the jaws to hold the 
part. 

For Selected Solid Faces, select solid faces in the graphics 
window. 

5 Select the Jaws types you want to use. 

6 Click Import to import the vise. 
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Bar-fed mills support 
Bar-fed mills are now supported, such as the Willemin-Macodel 
408MT and Mazak integrex i-150. Bar-fed mills enable you to 
machine multiple parts from bar stock, and to automatically transfer 
the machined slugs to the sub-spindle to machine the cut-off face. 
This eliminates the need for manually positioning the part, which 
can be a source of inaccuracy. 

This requires a UDF add-in, and a customized MD file and post. 
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XBUILD 
FeatureCAM 2016 R1 contains the following changes and 
improvements to XBUILD: 

 Intermediate CNC files (see page 40) — You can now split the nc 
file into multiple intermediate files, and then combine these 
intermediate files in different ways to create multiple output files. 

 Multi-code coolant (see page 42) — You can now use different on 
and off codes for a single coolant type, depending on which 
turret and tool is being used. 

 5-axis untransformed coordinates (see page 44) — There are new 
milling reserved words that contain the untransformed X, Y, and 
Z coordinates in a 5-axis part. 

 Formatting reserved words (see page 45) — When formatting 
numeric reserved words in XBUILD, you can now remove trailing 
zeros from integer values without removing the decimal point. 

 CNC documentation (see page 46) — The HTML documentation 
has been improved to make the output more readable. 
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Intermediate CNC files 
You can now split the nc file into multiple intermediate files, and 
then combine these intermediate files in different ways to create 
multiple output files. This gives you more control over the nc code 
files you create. 

For example, you can use this to create a tool list at the start of the 
output file easily without needing to use a macro, by separating 
each line of tool information into an intermediate file, and placing it 
at the beginning of the output file. 

You can also use this to group Wait codes together and output them 
at a single point in the post, and avoid mismatched wait codes when 
outputting to multiple channels. 

  

To use multiple output streams for the nc code: 

1 In XBUILD, select the CNC-Info > Manage Files menu option to 
display the new Files dialog. 

 
2 Select Use Output Streams. 

3 Under Intermediate Files, select the intermediate nc files you want 
to create and enter a Name. 

Each intermediate file has a number, which you can use to send 
individual lines of the nc code into different intermediate files. 
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4 Under Output Files, specify the final nc files you want to create 
and output from FeatureCAM. 

a Enter the File Suffix and Ext to specify the suffix and extension 
that will be applied to the file you output. 

b Under Source List, enter the intermediate files you want to 
combine to create the output file. 

In the example above, the NC Code output file includes all the 
intermediate streams, and the ToolList output file includes 
only the tool list intermediate file. 

c Enter the Display Name. This is the name of the nc file when 
displayed in the NC Code tab of the Results window in 
FeatureCAM. 

5 Add the new reserved words to a format to separate the lines of 
nc code into the intermediate files. 

 <F1> to <F20> — Use this word at the start of a line to send 
the line to an intermediate file. 

 <SET-F1> to <SET-F20> — Use this word at the start of a line 
to send all proceeding information to an intermediate file, 
including in other formats. 

 Alternatively you can use the intermediate file name, such 
as <F:start> and <Set-F:start>. 

For example, use <F10> before the tool name in the Tool Change 
format to send the tool name to the tenth intermediate file. Use 
<SET-F1> at the beginning of the Program Start format to send 
all nc code except the tool names to the first intermediate file. 

6 Simulate the toolpaths in FeatureCAM. 

7 In the NC Code tab of the Results window, select an output file in 
the list to display it. 

 
8 Use the Save NC dialog to save the nc code output files. 
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Multi-code coolant 
You can now use different on and off codes for a single coolant type, 
depending on which turret and tool is being used. 

To use multi-code coolant: 

1 In XBUILD, in the Coolant dialog, select the new Multi-code option 
to enable multi-code coolant for a coolant type. 

 
2 Click Configure to display the Coolant Configuration dialog. 

 
3 For each row, select the Tool Posts for which you want to specify 

the On and Off Codes. 

4 Enter the Tool Range, the range of tool numbers for which you 
want to specify the On and Off Codes. 

5 Enter the On and Off Codes. 

6 If needed, click Add Row to add more rows. 

7 Click OK to close the dialog. 
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8 In the Coolant dialog, under Separate codes with, select an option 
to determine how to separate multiple codes when they are used 
together in the NC code. 

 
Newline — Select this option to use a line break between coolant 
codes in the NC code. 

Space — Select this option to use a space between coolant codes 
in the NC code. 

Nothing — Select this option to not separate coolant codes in the 
NC code. 

Other — Select this option and enter a string to use between 
coolant codes in the NC code. 

9 Click OK to close the dialog. 
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5-axis untransformed coordinates 
There are new milling reserved words that contain the 
untransformed X, Y, and Z coordinates in a 5-axis part. For 
example, you can use these in a post for positioning before turning 
on the RTCP transformation. 

The new reserved words are: 
 <UNXFORM-X-COORD> 

 <UNXFORM-Y-COORD> 

 <UNXFORM-Z-COORD> 

These are only valid in the Program Start, Segment Start and Tool 
Change formats. 
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Formatting reserved words 
When formatting numeric reserved words in XBUILD, you can now 
remove trailing zeros from integer values without removing the 
decimal point. Use this option to ensure numeric reserved words are 
interpreted correctly by your machine tool controller. 

In the Word Formatting dialog, select Minimize width to remove the 
trailing zeros and select the new Keep Decimal Points option to keep 
the decimal point. 

For example, when Keep Decimal Points is deselected, a value of 5 is 
output as 5, when Keep Decimal Points is selected, it is output as 5.. 

 
Keep Decimal Points 
deselected: 

Keep Decimal Points 
selected: 
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CNC documentation 
In XBUILD, you can select the File > Document CNC > HTML menu 
option to create HTML documentation about the CNC file. 

The HTML documentation has been improved to make the output 
more readable: 

 The CSS and HTML style has been modified to better present the 
output. 

 Sections of the documentation with no content are not displayed 
in the output. 

 Unnamed post variables are not displayed in the output. 

 Some sections of the documentation have been removed, such 
as Motion Commands, Spindle, Synchronize Spindles, 
Compensation Commands, Stop Commands, Airblast, and 
Circular Planes. 

 Unnecessary data has been removed from the General Info, 
Machine Info, Turret Info, Feeds and Speeds Info, Milling Cycle, 
and Turning Cycle sections. 

 Several section headers have been renamed, and table elements 
have been reworded to be more clear. 
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FeatureCAM 2015 R3 contains the following new features and 
enhancements: 

User interface 
 Improved icons (see page 50) — Several icon graphics across 

FeatureCAM have been updated. 

 Selecting objects (see page 50) — There is a new Select Partial 
mode. 

 Inserting Part Library features (see page 51) — You can now use 
the New Feature wizard to insert Part Library features into a 
document. 

 Pasting features using polar coordinates (see page 52) — You can 
now use polar coordinates to locate features in the Paste Special 
wizard. 

 Deleting unused curves (see page 53) — There is a new add-in 
that you can use to identify all unused curves in a model and 
delete them. 

Importing 
 Importing SolidWorks 2015 files (see page 55) — You can now 

import SolidWorks 2015 files into FeatureCAM. 

 Importing SolidEdge ST7 files (see page 55) — You can now 
import SolidEdge ST7 files. 

 Spatial R25 SP1 Interop integrated (see page 56) — Spatial R25 
SP1 Interop is now integrated. 

What's new in 
FeatureCAM 2015 R3 
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Milling 
 Creating Faces features using IFR (see page 58) — You can now 

automatically round the corners of Face features that are created 
using Interactive Feature Recognition. 

 Automatic tool selection (see page 59) — You can now specify an 
additional clearance on the automatic tool selection to ensure the 
tool holder does not collide with the stock. 

 Simulating tool holders (see page 60) — You can now simulate 
complicated tool holders more accurately. 

 Machine movement limits (see page 60) — You can now display a 
warning message when the machine exceeds its limits of 
movement during machine simulation. 

Turning and Turn/Mill 
 Indexing using a stock solid (see page 63) — You can now 

calculate the index height directly from the stock solid, instead of 
calculating it above a square bounding box. 

 Setting the program point for turnmilling tools (see page 65) — You 
can now specify the program point for turnmilling tools. 

 Turning head tool holders (see page 66) — Turning head tool 
holders are now supported. 

5-axis machining 
 C-axis indexing (see page 71) — You can now specify the C-axis 

position of the part in the machine at the start of an operation. 

 5-axis engraving (see page 73) — You can now create 5-axis 
engraving features with the tool axis normal to the surface. 

Machine Design 
 Specifying machine movement limits (see page 76) — You can now 

set the limits of movement for solids in a Machine Design file. 

 Testing machine movements (see page 77) — You can now use 
machine jogging to simulate the movement of solids in a Machine 
Design document without having to use an FM file. 

 Simulating mini-turrets (see page 79) — You can now simulate 
mini-turrets, which are tools with multiple inserts where the tool 
rotates around the b-axis to access each tool. 
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User Interface 
FeatureCAM 2015 R3 contains the following changes and 
improvements to the user interface: 

 Improved icons (see page 50) — Several icon graphics across 
FeatureCAM have been updated. 

 Selecting objects (see page 50) — There is a new Select Partial 
mode. 

 Inserting Part Library features (see page 51) — You can now use 
the New Feature wizard to insert Part Library features into a 
document. 

 Pasting features using polar coordinates (see page 52) — You can 
now use polar coordinates to locate features in the Paste Special 
wizard. 

 Deleting unused curves (see page 53) — There is a new add-in 
that you can use to identify all unused curves in a model and 
delete them. 
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Improved icons 
Several icon graphics across FeatureCAM have been updated to 
improve the user interface, including: 

 Feature Properties dialog 
 Part View 
 Part Library 

 Tombstone Process Plan dialog 

 

Selecting objects 
There is a new Select Partial mode, which enables you to box-select 
items by partially selecting them. This improves work-flow when 
selecting multiple items, and enables you to select items more 
easily in complicated documents. 

To enable the new Select Partial mode: 

 In the Standard toolbar, in the Select Menu, select Select Partial. 

 
 Select the Edit > Select > Box Select Partial menu option. 

Click and drag to select objects. You do not need to enclose an 
object to select it. In the example below, all three features are 
selected: 
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Inserting Part Library features 
You can now use the New Feature wizard to insert Part Library 
features into a document. 

Adding features to the Part Library 
To add a feature to the Part Library: 

1 Select the Construct > Part Library menu option. 

The Part Library dialog is displayed. 

2 Select a feature in the Tree View or graphics window. 

3 In the Part Library dialog, click Add Selected. 

The selected feature is added to the list in the Part Library dialog. 

4 Click OK to close the dialog. 

Inserting features from the Part Library into the document 
To use the Part Library in the New Feature wizard: 

1 Click the Features  step in the Steps panel to display the New 
Feature wizard. 

2 In the New Feature wizard, under From Feature, select User and 
click Next. 
The User defined feature page is displayed. 

The Part Library features are displayed in the Registered features 
list. 

 
3 Select a feature in the list and click Next. 

The Paste Special dialog is displayed. 

4 Use the Paste Special dialog to insert the selected feature into 
the document, then click Finish to close the dialog. 
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5 The User defined feature page of the New Feature wizard is 
displayed. 

6 Use the wizard to insert more features from the Part Library, or 
click Cancel to close the wizard. 

 

Pasting features using polar coordinates 
You can now use polar coordinates to locate features in the Paste 
Special wizard. This gives you more control when duplicating 
features and when using the Part Library. 

 You can only use polar coordinates to locate individual 
features. 

To duplicate a feature into a new location using polar coordinates: 

1 Right-click a feature in the Part Tree, and select Copy. 

2 Select the Edit > Paste Special menu option. 

The Paste Special wizard is displayed. 

3 Select Paste the clipboard contents. Select a new location and click 
Next. 
The Reference page of the Paste Special wizard is displayed. 

4 Click Next. You do not need to specify a reference location. 

The Location page of the Paste Special wizard is displayed. 

5 Select the new Polar option. 
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6 Enter the Radius and Angle to offset the new feature from the 
setup location. 

7 Enter the Z value to specify the Z height of the feature above the 
setup. 

8 Click Preview to display a preview of the new feature in the 
graphics window. 

9 Click Finish to create the new feature and close the wizard. 

 

Deleting unused curves 
There is a new delete_curves.bas add-in that you can use to identify 
all unused curves in a model and delete them. 

To delete all unused curves in a document: 

1 Load the delete_curves.bas add-in using the Macro Add-ins dialog. 

2 In the Utilities toolbar, click deletecurves. 

3 The Curve Information dialog is displayed, which contains a list of 
unused curves in the document. 

4 Click OK to delete all unused curves and close the dialog. 
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Importing 
FeatureCAM 2015 R3 contains these changes and improvements to 
importing files from external applications: 

 Importing SolidWorks 2015 files (see page 55) — You can now 
import SolidWorks 2015 files into FeatureCAM. 

 Importing SolidEdge ST7 files (see page 55) — You can now 
import SolidEdge ST7 files. 

 Spatial R25 SP1 Interop integrated (see page 56) — Spatial R25 
SP1 Interop is now integrated. 
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Importing SolidWorks 2015 files 
You can now import SolidWorks 2015 files into FeatureCAM. 

To import a SolidWorks file: 

1 Select the File > Import menu option. 

The Import dialog is displayed. 

2 Browse to the folder containing the file you want to open. 

3 In the Files of type list, select SolidWorks (*.sldprt;*.sldasm). 
Only SolidWorks documents are displayed in the Import dialog. 

4 Select a file to display a preview image on the right of the dialog. 

5 Click Open to import the file and close the dialog. 

The Import Results wizard is displayed, which you can use to 
specify the setup location and stock size, and to recognize 
features. 
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Importing SolidEdge ST7 files 
You can now import SolidEdge ST7 files. 

To import a SolidEdge file: 

1 Select the File > Import menu option. 

The Import dialog is displayed. 

2 Browse to the folder containing the file you want to open. 

3 In the Files of type list, select SolidEdge (*.par;*.psm:*.asm). 
Only SolidEdge files are displayed in the Import dialog. 

4 Select a file to display a preview image on the right of the dialog. 

Click Open to import the selected file and close the dialog. 

The Import Results wizard is displayed, which you can use to 
specify the setup location and stock size, and to recognize 
features. 

 
 

Spatial R25 SP1 Interop integrated 
Spatial R25 SP1 Interop is now integrated. 

InterOp now supports Creo 3.0 BREP, Assembly, PMI, and Graphical 
translation. 
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Milling 
FeatureCAM 2015 R3 contains these changes and improvements to 
Milling: 

 Creating Face features using IFR (see page 58) — You can now 
automatically round the corners of Face features that are created 
using Interactive Feature Recognition. 

 Automatic tool selection (see page 59) — You can now specify an 
additional clearance on the automatic tool selection to ensure the 
tool holder does not collide with the stock. 

 Simulating tool holders (see page 60) — You can now simulate 
complicated tool holders more accurately. 

 Machine movement limits (see page 60) — You can now display a 
warning message when the machine exceeds its limits of 
movement during machine simulation. 
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Creating Face features using IFR 
You can now automatically round the corners of Face features that 
are created using Interactive Feature Recognition. 

This enables you to use a Face feature instead of a Side feature in 
some situations, which can reduce the machining time by reducing 
air cutting. This is especially useful when using cutter compensation 
and partline programming. 

  

In the example below, a Face feature is created on the orange 
surface, and a deburr radius is applied to round the outside corners 
of the feature during machining: 

 
 

To specify a corner radius for a Face feature: 

1 Create a Face feature using Interactive Feature Recognition. 

2 In the Face Properties dialog, in the Misc tab, select one of the 
new options. 

 
Use the Deburr radius option to round the outside corners of the 
feature. 

Use the Min corner radius option to round the inside corners of 
the feature. 

3 In the New Value field, enter a new value and click Set to override 
the selected option. 
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4 Click OK to accept your changes to the feature and close the 
dialog. 

 For Face features with multiple operations, you can set the 
Min. corner radius option separately for the rough operation 
and for each finish pass. 

 

 

Automatic tool selection 
In FeatureCAM 2015 R2, the Tool Holder Clearance dialog (see page 
92) was added, which enables you to specify an additional clearance 
on the automatic tool selection to prevent tool holder gouges. 

There is a new Stock option in the Clearance Requirement list. Select 
this option to ensure the tool is long enough for the tool holder to 
clear the total depth into the stock. 

 
 
No additional clearance: Clearance above the stock: 
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To specify a tool holder clearance above the stock for automatic tool 
selection: 

1 Select the Manufacturing > Machining Attributes menu option to 
display the Machining Attributes dialog. 

2 On the Tool Selection tab of the Machining Attributes dialog, click 
Tool Holder Clearance. 

The new Tool Holder Clearance dialog is displayed. 

3 In the Clearance Requirement list, select Stock. 

4 Click OK to close the dialog. 

 

 

Simulating tool holders 
You can now simulate complicated tool holders more accurately. 
This enables you to create better toolpaths that can access more 
material and check for gouges more accurately when using 
automatic tool holder clearance. 

Previously, the shape of the tool holder was approximated using 
either a cylinder or a cone. 

The tool holder shape does not take into account undercuts, for 
example: 
If the tool holder has this 
curve: 

The toolpaths are 
calculated with this tool 
holder shape: 
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Machine movement limits 
You can now display a warning message when the machine exceeds 
its limits of movement during machine simulation. 

There is a new Pause on limits option in the 2D/3D Shaded tab of the 
Simulation Options dialog. Select this option to pause the machine 
simulation if the machine moves outside the limits specified in the 
MD file. 

 
A new message dialog is displayed when the machine moves 
outside the specified limits. 

 
The Outside of Limits message dialog displays: 

 The solid name that has exceeded its limits. 

 The axis of movement. 

 The specified limit. 

 The solid's current position. 

You can select these options in the Outside of Limits message 
dialog: 

 Don't pause for this solid again — Select this option to continue 
the machine simulation without pausing when this solid exceeds 
its limits. 

 Don't pause on limits again — Select this option to run machine 
simulations without pausing when any solids exceed their limits. 
This is the same as deselecting Pause on limits in the Simulation 
Options dialog. 

To specify a machine's limits of movement (see page 76), you need 
to edit the Machine Design file. 
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Turning and Turn/Mill 
FeatureCAM 2015 R3 contains these changes and improvements to 
Turning and Turn/Mill: 

 Indexing using a stock solid (see page 63) — You can now 
calculate the index height directly from the stock solid, instead of 
calculating it above a square bounding box. 

 Setting the program point for turnmilling tools (see page 65) — You 
can now specify the program point for turnmilling tools. 

 Turning head tool holders (see page 66) — Turning head tool 
holders are now supported. 
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Indexing using a stock solid 
You can improve machining times for turn/mill parts with stock 
solids by reducing the distance above the part at which the tool 
indexes. There is a new Calculate index radius from solid stock outline 
option that enables you to calculate the index height directly from 
the stock solid, instead of calculating it above a square bounding 
box: 

  
Calculate index radius from 
solid stock outline off: 

Calculate index radius from solid 
stock outline on: 

 
 — Distance to bounding 

box 
 — Z rapid level attribute 

value 

 
 — Distance to stock boundary 
 — Z rapid level attribute value 
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The new option is displayed on the Misc tab of the Machining 
Attributes dialog. 
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Turnmilling program point 
You can now specify the program point for turnmilling tools. This 
enables you to touch-off the tool at the edge, and specify the insert 
radius compensation at the machine instead of in FeatureCAM. 
Previously, this option was available for turning tools only. 

In the Machining Attributes dialog, on the Misc tab, select an option 
under Turnmilling program point: 
 Tool tip edge — Select this option to adjust the tool program 

point by the tool radius in the NC code. 

 Tool tip center — Select this option to adjust the tool program 
point by the tool radius at the machine. 

 
This option does not affect turnmilling tools that are used for 
milling. 

To use a turnmilling tool, select the Turnmilling option in the 
Strategy tab of the Feature Properties dialog for a Turn feature. 
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Turning head tool holder support 
Turning-head tool holders are supported in FeatureCAM, which 
enable you to perform turning and boring operations on a milling 
machine. 

For example, in the image below the piece is machined by rotating 
the tool around the stock. 

 
This requires the Advanced Turn/Mill (MTT) module, and it requires a 
modified post processor that provides the U coordinate. 

4-Axis indexing is supported, but 5-Axis positioning is not. 

To create a turning head feature: 

1 Create a Setup over the center of rotation of the turning head, so 
that the tool will rotate about the Setup Z axis. 

2 Create a curve in the XZ plane that defines the profile of the 
turned shape. 

3 Load the TurningHeadCS.dll add-in using the Macro Add-ins 
dialog. 

4 In the New Feature wizard, under From Feature, select User and 
click Next. 
The User defined feature page is displayed. 
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5 In the Registered features list, under Macro Add-ins, select Turn 
Head, and click Next. 

 
The Curves page is displayed. 

6 Select the curve in the graphics window and click Add from 
selected items . 

7 Click Next to display the Location page. 

8 Click Next to display the User defined feature page. 

 
9 Specify the parameters to define the feature. To change a 

parameter, select the parameter name, select an option in the 
New Value list, then click Set. 
Profile — Select a curve to define the turning feature profile. 

Toolpath Type — Select whether you want to create an Inside 
Diameter or Outside Diameter feature. 

Rough Stock Curve — Select the curve that defines the toolpath 
boundary for the feature. Leave this unset to machine to the 
stock boundary. 
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Rough Pass — Select True to include a rough operation. 

Finish Pass — Select True to include a finish operation. 

Cycle Type — Select the cycle type. 

In a Turn cycle, the roughing tool feeds along the Z axis while 
stepping down the X axis. 

In a Face cycle, the roughing tool feeds from the outside of the 
part to the center while stepping down in the negative Z 
direction. 

Cut Direction — Select the direction along the Z axis you want to 
cut the feature. 

10 Click Finish to create the Turn Head feature and close the dialog. 

11 Use the Tool Block Selection dialog to select the tool block solid 
as a tool block for the turning tools. 

12 You may need to adjust the Start point and End point on the 
Turning tab of the Turn Head Properties dialog for each operation 
to ensure the tool does not collide with the part at the start and 
end of the toolpath. 

13 Run a simulation to check for collisions. 

The rotation of the tool is not displayed in the simulation, but the 
tool is checked for collisions and gouges. For example, in this 
image the tool has gouged with the clamp at , and another 
gouge is displayed at . 
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Machine Design 
To modify a Machine Design file to support turning head tool 
holders: 

1 In the Machine Design document, ensure the Machine Design > 
Enable Turn/Mill UI is selected. 

2 Create or import solids to represent the turning head tool holder 
and the plate that moves in the U axis that holds the turning 
tool. 

 
3 Use the Parent/Child Relationships dialog to make the U plate 

solid a child of the turning head tool holder solid. 

4 Use the Specify Movement dialog to enable the U plate solid to 
move in +delta X. 

5 Create a UCS on the U plate solid to locate the tool. 

6 Using the Tool Block dialog, make the turning head tool holder 
solid a tool block, and create a tool location on the tool block 
using the UCS you created on the U plate solid. 
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5-axis machining 
FeatureCAM 2015 R3 contains these changes and improvements to 
5-axis machining: 

 C-axis indexing (see page 71) — You can now specify the C-axis 
position of the part in the machine at the start of an operation. 

 5-axis engraving (see page 73) — You can now create 5-axis 
engraving features with the tool axis normal to the surface. 
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C-axis indexing 
You can now specify the C-axis position of the part at the start of an 
operation. This is useful for large parts where the machine has 
limited travel, or to prevent machine collisions. 

There is a new Orientation angle option in the Milling or Drilling tab 
of the Feature Properties dialog. 

 
Use this option to specify the rotation of the X and Y axes about the 
Z-axis. This option only applies if the machine tool starts at the 
singularity (where the machine tool's Z-axis is aligned with the 
setup's Z-axis). 

If the machine tool is not at the singularity, you can specify the C-
axis orientation using these methods: 

 Use the Alternative 5-axis position option to specify a C-axis 
orientation of either 0 or 180 degrees. 

 Use the Use Origin of this Setup as the Touch-off Point option in the 
5 Axis Fixture Location dialog. This method applies the C-axis 
orientation to all setups in the part, instead of to individual 
operations. 
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For example: 
With an orientation angle of 
0, the groove is cut in the 
machine's Y direction. 

With an orientation angle of 
90, the groove is cut in the 
machine's X direction. 
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5-axis engraving 
The 5-Axis tab of the Feature Properties dialog is now available for 
2d spiral operations, which you can use to create 5-axis engraving 
features. This enables you to use a tool axis angle normal to the 
surface to ensure the engraving has a uniform cross-section and 
depth of cut. 

 
To create a 5-axis surface engraving feature: 

1 Create a surface below the stock boundary to determine the 
depth of the engraving, for example: 
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2 Create the curve to define the shape of the engraving feature, 
for example: 

 

 You can use the Construct > Curve > From Surface > Project 
onto Surface menu option to project a curve onto a surface. 

3 Create a surface milling feature with a 2D spiral operation. 

4 Double-click the feature in the Part View to display the Feature 
Properties dialog, and select spiral2d in the Tree View. 

5 On the Stock tab, under Choose the drive curve, select Select 
curves for boundaries and click Curve Options. 

The Boundary Curve dialog is displayed. 

6 Under Boundary curve type, select Wall only. 

This creates a toolpath along the curve. 

7 Under Boundary curves, click Boundaries. 

The Select Boundary Curves dialog is displayed. 

8 Select the curve that defines the shape of engraving, and click 
OK to close the Select Boundary Curves dialog. 

9 Click OK to close the Boundary curves dialog. 

10 On the 5-Axis tab, select Use Lead and Lean, and in the from list, 
select Contact normal. 
This keeps the tool axis normal to the surface. 

11 Click OK to close the Feature Properties dialog. 
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Machine Design 
FeatureCAM 2015 R3 contains these changes and improvements to 
Machine Design: 

 Specifying machine movement limits (see page 76) — You can now 
set the limits of movement for solids in a Machine Design file. 

 Testing machine movements (see page 77) — You can now use 
machine jogging to simulate the movement of solids in a Machine 
Design document without having to use an FM file. 

 Simulating mini-turrets (see page 79) — You can now simulate 
mini-turrets, which are tools with multiple inserts where the tool 
rotates around the b-axis to access each tool. 
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Specifying machine movement limits 
You can now set the limits of movement for solids in a Machine 
Design file. This gives you more control of machine simulations, and 
enables you to ensure the machine does not move beyond its limits 
during a simulation. 

To specify the limits of movement for a solid: 

1 In a Machine Design document, select the Machine Design > 
Specify Movement menu option. 

The Specify Movement dialog is displayed. 

2 Use the Specify Movement tab to select a solid and specify how it 
can move. 

3 Use the new Specify Limits tab to specify the Home Position and 
the linear and rotational limits of movement for the selected 
solid. 

 
4 Click OK to close the dialog. 

FeatureCAM can display a warning if a solid exceeds these limits 
during machine simulation (see page 60). 

 There are several new example MD files that have limits of 
movement set. These are located in 
\FeatureCAM\Examples\Machine Design\Axis Limits. 
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Testing machine movements 
You can now use machine jogging to simulate the movement of 
solids in a Machine Design document without having to use an FM 
file. This enables you to test the movement and ensure the limits 
are set correctly. 

To use machine jogging to test machine movements: 

1 Save any changes to your MD document. 

Any unsaved changes to the document are not displayed in the 
jogging simulation. 

2 Select the Machine Design > Jog Machine menu option. 

The new Jog Machine dialog is displayed. 

 
Each row displays an axis in which solids in the document can 
move. 

3 Select a solid in the list next to an axis name. 

The list is unavailable if there is only one solid that can move in 
that axis. 

4 For the selected solid, move the slider between the minimum 
limit and the maximum limit. 

The solid's current position is shown in the middle field, and the 
solid's movement is simulated in the graphics window. 
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 You can set the limits and home positions of the solids 
using the Specify Movement dialog (see page 76). 

5 To hide solids in the jogging simulation, click Select  in the 
Standard toolbar, then click solids in the graphics window. 

6 To return all solids to their default positions, click Reset All. 
7 When finished, close the dialog. The jogging simulation is 

cleared, and all solids are returned to their default positions. 
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Simulating mini-turrets 
You can now simulate mini-turrets, which are tools with multiple 
inserts where the tool rotates around the b-axis to access each 
insert. This enables you to create a more flexible tooling setup and 
perform faster tool changes. The tools are simulated 
simultaneously, which enables you to check for gouges with the 
tools that are not currently in use. 

 
To simulate a mini-turret: 

1 In the Machine Design file, create a solid and UCS to represent 
the mini-turret. The X-axis of the UCS must point towards the 
main spindle. 

2 Create a UCS for each tool location. The difference between the 
X-axis of the tool location and the turret UCS determines the 
angle that the mini-turret is rotated to use the tool. 

3 In the Tool Block dialog: 

a Select the turret solid under This solid is a tool block for solids. 

b Select the turret UCS under This UCS will match up with the tool 
location on the turret. 

c Use the Tool Locations tab to add each tool location UCS as a 
separate sub slot in the tool block. 

d Click OK to close the dialog. 

4 Save the Machine Design file. 

5 In the FM document, use the Tool Mapping dialog to specify 
which tool block to use for each feature. 
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FeatureCAM 2015 R2 contains the following new features and 
enhancements: 

User interface 
 Changing the point size (see page 84) — You can now change the 

size of geometry point objects to make them easier to see. 

 Customizing the snapping cursor (see page 85) — You can now 
change the size and color of the snapping cursor. 

 Measuring curve length (see page 86) — You can now find the 
length of curves and geometry segments. 

 Creating internal gears (see page 87) — You can now perform 
analysis on internal gears curves. 

 Combining solids (see page 88) — You can now combine multiple 
solids. 

 Hiding rapid moves in centerline simulations (see page 89) — You 
can now hide rapid moves in centerline simulations. 

 Chip recognition size (see page 90) — You can now specify the 
size at which detached pieces of stock are considered to be chips 
and hidden from simulation. 

 Recognizing features on large parts (see page 90) — IFR now 
works more quickly for large parts. 

What's new in 
FeatureCAM 2015 R2 



 

FeatureCAM 2016 R1 What's New What's new in FeatureCAM 2015 R2 • 81  

Milling 
 Automatic tool selection (see page 92) — You can now specify an 

additional clearance on the automatic tool selection to prevent 
tool holder gouges. 

 Vortex approaches flats from outside stock (see page 94) — Vortex 
toolpaths can approach flat areas from outside of stock instead of 
always ramping into it. 

 Output options for 2D NT toolpaths (see page 96) — The Output 
Options dialog is now available for 2D toolpaths that use NT or 
Vortex stepover types. 

 Previewing the toolpath point distribution (see page 97) — You can 
now preview the points of a surface milling toolpath to help with 
editing the point distribution. 

 Tool pecking depths (see page 98) — You can now specify the 
pecking depths for individual tools. 

 Changing the posting tolerance (see page 99) — You can now 
create more precise toolpaths, which is useful for machining 
small parts. 

 Helical side finish (see page 100) — Helical side finish operations 
are now machine at the feed rate, instead of the plunge feed 
rate. 

Turning 
 Removing undercuts in no-drag turning features (see page 102) — 

You can now remove undercuts in no-drag turning features to 
prevent gouges and simplify toolpaths. 

 Controlling steady rests (see page 103) — You can now open and 
close the jaws of a steady rest without moving it to the home 
position. 

 Simulating bar stock (see page 104) — You can now simulate bar 
stock in FeatureCAM by specifying the length of the stock 
displayed in simulation. 

 Custom turret names (MTT) (see page 105) — You can now use 
customized turret names to make FeatureCAM more consistent 
with your machine. 
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XBUILD 
 Generating Post documentation (see page 106) — You can now 

output your CNC data file as HTML or XML to make it 
understandable. 

 Using macros in the post processor (see page 107) — The Disable 
Macros option in the Post Options dialog is now selected by 
default. 

Add-ins and extensions 
 Using Setup Sheets (see page 109) — There are new tags which 

you can use to create more detailed setup sheets. 

 FeatureCAM to CAMplete TruePath add-in (see page 110) — You 
can export documents to CAMplete TruePath, which you can use 
to analyze, modify, optimize, simulate and post 5-Axis toolpaths. 

 Probing update options (see page 112) — When creating probing 
features, you can now select multiple update options, which 
enables you to perform multiple actions from a single probing 
cycle. 

 Support for Microsoft SQL 2014 (see page 112) — FeatureCAM 
now supports Microsoft SQL server 2014. 

Machine Simulation Design 
 Multi-tool blocks (see page 114) — You can now create multi-tool 

blocks and double-sided tool blocks in Machine Design files and 
use them in machine simulations. 

 Selecting the tool block (see page 116) — You can now select 
which tool block holds each tool within an FM file, which enables 
you to create accurate machining simulations more easily. 

 Protecting Machine Design documents (see page 118) — You can 
protect your Machine Design files from the extraction of solids, 
so that you can share them for simulation without anyone being 
able to extract the solids. 
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User Interface 
FeatureCAM 2015 R2 contains the following changes and 
improvements to the user interface: 

 Changing the point size (see page 84) — You can now change the 
size of geometry point objects to make them easier to see. 

 Customizing the snapping cursor (see page 85) — You can now 
change the size and color of the snapping cursor. 

 Measuring curve length (see page 86) — You can now find the 
length of curves and geometry segments. 

 Creating internal gears (see page 87) — You can now perform 
analysis on internal gears curves. 

 Combining solids (see page 88) — You can now combine multiple 
solids. 

 Hiding rapid moves in centerline simulations (see page 89) — You 
can now hide rapid moves in centerline simulations. 

 Chip recognition size (see page 90) — You can now specify the 
size at which detached pieces of stock are considered to be chips 
and hidden from simulation. 

 Recognizing features on large parts (see page 90) — IFR now 
works more quickly for large parts. 
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Changing the point size 
You can now change the size of geometry point objects to make 
them easier to see. 

To change the point size: 

1 Select the Options > Viewing menu option. 

The new Point size option is displayed in the Viewing Options 
dialog. 

 
2 Enter a Point size to specify the size of geometry point objects in 

the graphics window. 

3 Click OK to close the dialog. 
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Customizing the snapping cursor 
The snapping cursor shows you which object you are snapping to. 
You can now change the size and color of the snapping cursor to 
improve work flow when working with large, small or complex parts. 

To change the size of the snapping cursor: 

1 Select the Options > Viewing menu option. 

The new Snapping Point Size option is displayed in the Viewing 
Options dialog. 

 
2 Enter a Snapping Point Size to specify the size of the snapping 

cursor in the graphics window. 

3 Click OK to close the dialog. 

  

To change the color of the snapping cursor: 

1 Select the Options > Coloring > Default Colors menu option. 

The Default Colors dialog is displayed. 

2 Select Highlight in the list. 

3 Click More Colors to display the Color dialog. 

4 Select a color and click OK to close the dialog. 

The selected color is displayed in the Default Colors dialog. 

5 Click Apply to apply the color to the selected item. 

6 Click Done to close the dialog. 
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Measuring curve length 
You can now find the length of curves and geometry segments, 
which enables you to find important dimensions of complicated 
shapes easily. 

 
To find the length of a curve: 

1 Select the Construct > Dimension > Interrogation menu option. The 
Pick Dimension dialog is displayed. 

2 Under Pick type, select the new Length option. 

 

3 Click Pick Location  and select the curve you want to measure 
in the graphics window. 

The length of the selected curve is displayed in the Pick value 
field. 

4 To measure another curve, repeat the previous step. 

5 When you have finished, click OK to close the dialog. 
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Creating internal gears 
In FeatureCAM 2015 R1, the Analysis tab was added to the Gears 
dialog, which enables you to view the calculated dimensions of the 
gear, the calculated pin gauge diameter and the outside 
measurement over pins diameter. In FeatureCAM 2015 R2, the 
Analysis tab has been extended to enable you to find the 
measurement over pins value of an internal gear. 

 
To create and analyze an internal gear curve: 

1 Select the Construct > Curve > Other Methods > Gears menu 
option. 

The Gears dialog is displayed. 

2 In the Curve tab, specify the properties of the gear. 

3 Select the Analysis tab. 

The calculated dimensions of the gear are displayed under 
General calculations. 

4 Under Measurement over pins (MOP), select Internal Gear. 
The Ideal pin diameter and MOP ideal values are displayed. 

5 Enter the Actual pin diameter and click Recompute. 

The calculated measurement over pins value is displayed in the 
MOP actual field. 

6 Click OK to close the dialog. 
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Combining solids (SOLID) 
You can now combine multiple solids in different ways to create 
complicated shapes more easily. Previously, you could combine only 
two solids at once. 

 

To combine solids: 

1 Select the Construct > Solid > Modifiers > Combine solids menu 
option. 

The Combine Solids dialog is displayed. 

 This dialog was previously called the Boolean dialog. 

2 Enter a New solid name. 

3 Select an Operation: 

 Difference — Subtract a solid from another solid. You can 
combine only two solids with this operation. 

 Union — Merge multiple solids together. 

 Intersection — Create a solid at the intersection of multiple 
solids. 

4 Add the solids you want to combine: 

 To add a solid by name, select it in the Solid list and click Add 
item from list . 

 To add solids graphically, click Pick solid  and select them in 
the graphics window. 

5 Click OK to close the dialog. 
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Hiding rapid moves in centerline simulations 
You can now hide rapid moves in centerline simulations. This 
enables you to see the cutting moves more clearly in complicated 
toolpath simulations. 

  
Rapid moves shown: Rapid moves hidden: 

  

To hide rapid moves in centerline simulations, deselect the View > 
Simulation > Show Centerline Rapids menu option. The next time you 
run a centerline simulation, rapid moves are not displayed. 
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Chip recognition size 
You can now specify the size at which detached pieces of stock are 
considered chips and hidden from simulation. 

There is a new Chip recognition size option on the Round Stock tab 
of the Simulation Options dialog. 

 
For parts with large stock, you may want to reduce this value to 
ensure cutoffs are not hidden. 

 

Recognizing features on large parts 
Interactive Feature Recognition (IFR) now works more quickly on 
large parts. 

Previously, IFR would validate the solid when recognizing features, 
which could take a long time for large parts. 

To verify that a solid is valid, select the solid in the Automatic 
Feature Recognition dialog and click Verify. 
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Milling 
FeatureCAM 2015 R2 contains the following changes and 
improvements to Milling: 

 Automatic tool selection (see page 92) — You can now specify an 
additional clearance on the automatic tool selection to prevent 
tool holder gouges. 

 Vortex approaches flats from outside stock (see page 94) — Vortex 
toolpaths can approach flat areas from outside of stock instead of 
always ramping into it. 

 Output options for 2D NT toolpaths (see page 96) — The Output 
Options dialog is now available for 2D toolpaths that use NT or 
Vortex stepover types. 

 Previewing the toolpath point distribution (see page 97) — You can 
now preview the points of a surface milling toolpath to help with 
editing the point distribution. 

 Tool pecking depths (see page 98) — You can now specify the 
pecking depths for individual tools. 

 Changing the posting tolerance (see page 99) — You can now 
create more precise toolpaths, which is useful for machining 
small parts. 

 Helical side finish (see page 100) — Helical side finish operations 
are now machine at the feed rate, instead of the plunge feed 
rate. 
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Automatic tool selection 
You can now specify an additional clearance on the automatic tool 
selection to prevent tool holder gouges. 

  
No additional clearance: Clearance above the Setup: 

  

To specify a tool holder clearance for automatic tool selection: 

1 Select the Manufacturing > Machining Attributes menu option to 
display the Machining Attributes dialog. 

2 On the Tool Selection tab of the Machining Attributes dialog, click 
Tool Holder Clearance. 

The new Tool Holder Clearance dialog is displayed. 
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3 In the Clearance Requirement list, select the clearance you want 
between the tool holder and the part. Select from: 

 None — Select this option to leave no additional clearance. 
Old part files still select the same tools as before. 

 Feature — Select this option to ensure the tool is long enough 
for the tool holder to clear the feature. 

 Setup — Select this option to ensure the tool is long enough 
for the tool holder to clear the total depth into the setup. 

4 Enter an Extra allowance as a % of feature or setup depth to leave 
extra clearance of the tool holder above the feature or Setup. 

5 Select how tool selection is affected if no matching tool is found: 

 Give an error if no tool meets requirements — FeatureCAM does 
not select a tool for the operation, so an error is shown during 
NC code generation. In the Operation List, a red exclamation 
point  is displayed beside operations with no tool selected. 

 Select tool closest to requirements if none match — this enables 
you to generate NC code, but it may result in tool holder 
gouges because a smaller tool may be used. 

6 Click OK to close the dialog. 
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Vortex approaches flats from outside stock 
Vortex toolpaths can approach flat areas from outside of stock 
instead of always ramping into it. This enables you to create Vortex 
toolpaths that are faster to machine and are compatible with a 
wider selection of tools. 
FeatureCAM 2015 R3 
The tool ramps into the part 

FeatureCAM 2016 R1 
The tool approaches from 
the outside 

  

To approach from outside the stock, FeatureCAM: 

 extends a section of the flat area beyond the stock and into an 
area already machined; and; 

 fills the extended section with cutting moves. 

 By extending the section to an area already machined, the 
machine tool can approach the flat area in open space. 

 
  Edge of flat area 

  Stock  

  Extended section of flat area filled with cutting moves  

  Outside edge of extended section 

  Area already machined 
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Criteria for toolpath to approach from outside stock 
FeatureCAM only extends a section of the flat area if the extended 
section: 

 has an outside edge that the machine tool can approach. 

 does not gouge the model. 

 is wide enough to be profile smoothed successfully.  

 can reach an area already machined within the distance of one 
tool diameter. 

If the extended section fails to meet the criteria, FeatureCAM does 
not extend the flat area and instead uses a ramp move to approach 
the toolpath. 
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Output options for 2D NT toolpaths 
The Output Options dialog is now available for 2D toolpaths that use 
NT or Vortex stepover types. This enables you to control how the 
points of 2D vortex and New Technology toolpaths are processed in 
the NC program. Previously, this was only available for 3D 
toolpaths. 

 
To display the Output Options dialog, click Output Options on the 
Milling tab of the Feature Properties dialog. 

The dialog contains these output options: 

 Filter linear moves — This automatically removes unnecessary 
points in the toolpath while maintaining tolerance. The points are 
not equispaced because unnecessary points are deleted. 

 Filter linear moves and convert arcs to linear — This is similar to 
the first option except that all arcs are replaced by straight line 
segments. This option is suitable for machine tools which do not 
handle arcs well. 

 Redistribute points after filtering linear moves. Convert arcs to linear 
— This option allows the insertion of new points. This ensures a 
constant distance between points, only inserting extra points if 
they are necessary to keep tolerance. This option may increase 
toolpath creation time, but reduce time on the machine tool. This 
option is suitable for machine tools that can handle large 
numbers of equispaced points. 
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 Approximate linear moves with arcs and lines — Select this option 
to create an arc line approximation for toolpaths that are 
contained in the XY, YZ, and XZ plane. This allows 3D programs 
to be smaller and to result in smoother surface finishes for 
certain types of parts. 

 Limit linear moves — Select this option to limit the distance 
between linear move points to the Maximum length value. 

 

Previewing the toolpath point distribution 
You can now preview the points of a surface milling toolpath to help 
with editing the point distribution. 

To redistribute toolpath points: 

1 In the Surface Milling Properties dialog, on the Milling tab, click 
Output Options. 

The Output Options dialog is displayed. 

2 Under Output Filtering, specify the options for filtering linear 
moves in the toolpath. 

3 Click the new Preview button. The points of the toolpath are 
shown in blue in the graphics window. 

 
4 Modify the view in the graphics window to see the toolpath 

preview. 

5 When you have finished, click OK to close the dialog. 
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Tool pecking depths 
Pecking is used when drilling deep holes, where the tool retracts 
multiple times while drilling to clear debris from the hole. 

You can now specify the pecking depths for individual tools. 
Previously, you had to change the pecking depths for individual 
operations to override the global settings. 

To specify the pecking depths at which the drill retracts: 

 You can change the global pecking depths on the Pecking tab of 
the Machining Attributes dialog. 

 You can change the pecking depths for each tool on the new 
Pecking tab of the Tool Properties dialog: 

 

 Leave the values at 0% to use the global values in the 
Machining Attributes dialog. 

 You can see and edit each operation's absolute pecking depths 
on the Cycle tab of the Hole Feature Properties dialog. 

 
The peck style is specified in the .cnc file. This determines which of 
the tool's pecking values are used to calculate the absolute pecking 
depths for the operation. 
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Changing the Posting tolerance 
You can now control the tolerance with which toolpaths are created. 
This enables you to create more precise toolpaths, which is useful 
for machining small parts. 

There is a new Posting tolerance option in the Misc tab of the 
Machining Attributes dialog. 

 
Reduce the Posting tolerance for small parts to create more precise 
toolpaths. You must also adjust your post processor to output more 
digits. For example, if you adjust the posting tolerance from 0.001 
to 0.0001, then you must adjust the digit format in the post 
processor so that the extra decimal place is used in the NC code. 

Reducing the posting tolerance creates additional lines of NC code, 
so you should only do this for high-precision NC machines that can 
use the high-precision coordinates, when required for an 
application. 
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Helical side finish 
You can use the Helical side finish option to create a continuous 
spiral finishing toolpath for a 2.5D milling feature, which prevents 
tool marks on the surface. 

 
Helical side finish operations are now machined at the feed rate 
specified on the F/S tab of the Feature Properties dialog, previously 
they were machined using the plunge feed rate, specified by the 
Plunge feed override on the Plunge tab. 

To enable this option, select Helical side finish on the Strategy tab of 
the Feature Properties dialog, and enter a Pitch for the spiral. 
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Turning 
FeatureCAM 2015 R2 contains the following changes and 
improvements to Turning: 

 Removing undercuts in no-drag turning features (see page 102) — 
You can now remove undercuts in no-drag turning features to 
prevent gouges and simplify toolpaths. 

 Controlling steady rests (see page 103) — You can now open and 
close the jaws of a steady rest without moving it to the home 
position. 

 Simulating bar stock (see page 104) — You can now simulate bar 
stock in FeatureCAM by specifying the length of the stock 
displayed in simulation. 

 Custom turret names (MTT) (see page 105) — You can now use 
customized turret names to make FeatureCAM more consistent 
with your machine. 
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Removing undercuts in no-drag turning features 
You can create turning features with a no-drag finishing strategy, 
where the tool does not cut the feature in a single movement, which 
reduces tool wear and prevents chips being dragged along the 
surface. 

You can now remove undercuts in no-drag turning features to 
prevent gouges and simplify toolpaths, which improves machining 
time and prevents unnecessary tool wear. Previously, this option 
was available only for features which use a conventional finishing 
strategy. 

  

To create a no-drag turning feature and remove undercuts: 

1 Create a Turn feature. 

2 In the Turn Properties dialog, on the Strategy tab, select No-Drag. 

3 Select an operation in the Tree View. 

4 On the Turning tab, select an option in the Undercuts list: 

 No checking — Select this option to not check the feature for 
undercuts. 

 Adjust to tool geometry — Select this option to clip undercuts 
that cause the tool to gouge the part. 

 Remove all undercuts — Select this option to remove all 
undercuts. 
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Controlling steady rests 
You can now open and close the jaws of a steady rest without 
moving it to the home position. 

This is useful for turning operations on long parts. For example, you 
can machine up to the steady rest, open the steady rest and 
machine past it, then close the steady rest and machine to the end 
of the part. 

Steady rest open: Steady rest closed: 

  

To control the jaws of a steady rest without moving it: 

1 Click the Features  step in the Steps panel to display the New 
Feature wizard. 

2 Select Part Handling and click Next. 
The Dimensions page is displayed. 

3 To close a steady rest, select Part Support On. 

To open a steady rest, select Part Support Off. 
4 Click Next. 

The Strategies page is displayed. 

5 In the Support type list, select Steadyrest. 
6 Select the new Jaws only option. 

 
7 Click Finish to close the wizard. 

8 To specify when the Part Handling feature is performed, click and 
drag the feature in Part View, or change the Base Priority 
attribute on the Misc tab of the Part Handling Properties dialog. 
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The Jaws only option is also displayed on the Strategy tab of the Part 
Handling Properties dialog. 

 
  

There is a new <JAWS-ONLY> reserved word in XBUILD. You must 
update your post Formats to use the reserved word to obtain the 
correct NC code that matches the new simulation. 

 

Simulating bar stock 
You can now simulate bar stock in FeatureCAM by specifying the 
length of the stock displayed in simulation without changing the 
stock dimensions. 

Select the Options > Simulation menu option, and use the new 
Display Specific Stock Length option on the Round Stock tab of the 
Simulation Options dialog. 
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Custom turret names (MTT) 
You can now use customized turret names to make FeatureCAM 
more consistent with your machine. Previously, all turrets were 
called upper and lower turrets. 

The turret names are taken from the names of the turret or gang 
solids in the Machine Design file, and are used throughout 
FeatureCAM: 

 In the Part View panel. 

 
 In the Turrets tab of the Results panel. 

 
 In the Details tab of the Results panel. 

 In the NC program. 
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XBUILD 
FeatureCAM 2015 R2 contains the following XBUILD improvements: 

 Generating Post documentation (see page 106) — You can now 
output your CNC data file as HTML or XML to make it 
understandable. 

 Using macros in the post processor (see page 107) — The Disable 
Macros option in the Post Options dialog is now selected by 
default. 
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Generating Post documentation 
In XBUILD, you can output your CNC data file as a text file. This file 
has a .cnx extension, and you can edit and print it with any text 
editor. 

You can now output your CNC data file as HTML or XML to make it 
more understandable. 

Select one of these File > Document CNC menu options: 

 CNX (Text) — Creates a .cnx file which can be read by any text 
editor. 

 HTML — Creates a .html file. This is the most readable 
document. 

 XML — Creates an .xml file. 

 

 

Using macros in the post processor 
The Disable Macros option in the Post Options dialog is now selected 
by default. You must deselect this option to enable macro 
generation for the NC code. 
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Add-ins and extensions 
FeatureCAM 2015 R2 contains the following changes to add-ins and 
extensions: 

 Using Setup Sheets (see page 109) — There are new tags which 
you can use to create more detailed setup sheets. 

 FeatureCAM to CAMplete TruePath add-in (see page 110) — You 
can export documents to CAMplete TruePath, which you can use 
to analyze, modify, optimize, simulate and post 5-Axis toolpaths. 

 Probing update options (see page 112) — When creating probing 
features, you can now select multiple update options, which 
enables you to perform multiple actions from a single probing 
cycle. 

 Support for Microsoft SQL 2014 (see page 112) — FeatureCAM 
now supports Microsoft SQL server 2014. 
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Using Setup Sheets 
You can use the SetupSheet.dll add-in to generate html setup sheets 
from your document to give information to the machine operator 
about the manufacturing, tooling, and toolpaths of a part. 

There are new tags which you can use to create more useful setup 
sheets: 

 Machining allowances: 

 {operation.finish_allowance} — Finish Allowance. 

 {operation.bottom_finish_allowance} — Bottom Finish 
Allowance. 

 {operation.surface_finish_leave_allowance} — Finish 
Leave Allowance. 

 Stepover: 

 {operation.stepover} — 3D milling stepover. 

 Z increment: 

 {operation.finish_z_increment} — Finish Z Increment 

 {operation.surface_finish_z_increment} — Surface Finish 
Z Increment. 

 {operation.surface_rough_z_increment} — Surface Rough 
Z Increment. 

 Coolant: 

 {tool.coolant_override} — The tool's coolant override. 

 Depth of cut: 

 {operation.depth_of_cut} — Rough Z Pass Increment. 

 {operation.turn_depth_of_cut} — Rough Depth of Cut for 
turning operations. 
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FeatureCAM to CAMplete TruePath add-in 
CAMplete TruePath is an application that you can use to analyze, 
modify, optimize, simulate and post 5-Axis toolpaths. 

To export a document to use with CAMplete TruePath: 

1 License the CAMplete verification product component, and ensure 
it is selected in the Evaluation Options dialog. 

2 In the Post Options dialog, select the CAMplete_TruePath.cnc post 
in the /Posts/Mill/5-Axis folder. 

3 Load the FeatureCAMToCAMplete.dll add-in. 

4 In the Utilities toolbar, click FeatureCAMToCAMplete . 

The FeatureCAM to CAMplete dialog is displayed. 

 
5 Click Browse and select where you want to save the exported 

files. 

6 In the Select solids to be exported as clamps list, select solids you 
want to export as clamps and fixtures. 

You can export multiple clamp and fixture solids. 
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To mark multiple solids as clamps, select them in the graphics 
window and click Select solids selected in the part. 

7 Click Export Part solid to export a solid to use as the part in 
CAMplete. You can export only one part solid. 

 To export a solid in the document as an .stl file, select Select 
solid to export as part, and select a solid from the list. 

 To use an .stl file, select Select existing .stl file and click 
Browse and select it in the Select part .stl file document. 

 If want to machine a part made of multiple solids, you can 
use FeatureCAM's solid modelling to combine them. 

8 Select whether you want the post to use the Tool number or Tool 
ID to identify tools. 

9 Under Offset from the setup UCS to pallet, enter the offset 
distances in the X, Y and Z directions. 

10 Click Preview to display a point in the graphics window which 
shows the offset from the setup UCS. 

11 Click Export to export the document and close the dialog. The 
files are created in the selected output directory. 
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Probing update options 
When creating probing features, you can now select multiple update 
options. This enables you to perform multiple actions from a single 
probing cycle. 

To create a probing feature with multiple update options: 

1 Select the Options > Add-Ins menu option and use the Macro Add-
ins dialog to load the StandardProbing2.dll add-in. 

 This replaces the StandardProbing.dll add-in, but it is still 
available to enable backwards compatibility. 

2 Create a User Defined Feature, and select the feature type you 
want to measure, then click Next. 

3 Select an item in the Dimension list, enter a New Value, and click 
Set. 
You can enter the following values: 

 MCS — Enter the Machine Coordinate System you want to 
update. 

 Tool — Enter the tool number for the tool you want to update. 

 Store — Specify whether to store the results. 

 Print — Specify whether to print the results. 

4 Complete the wizard and click Finish to create the probing 
feature. 

 

Support for Microsoft SQL server 2014 
FeatureCAM now supports Microsoft SQL server 2014. 

You can use SQL server to improve the performance and reliability 
of your network database in FeatureCAM. 
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Machine Simulation Design 
FeatureCAM 2015 R2 contains the following changes and 
improvements to Machine Simulation design: 

 Multi-tool blocks (see page 114) — You can now create multi-tool 
blocks and double-sided tool blocks in Machine Design files and 
use them in machine simulations. 

 Selecting the tool block (see page 116) — You can now select 
which tool block holds each tool within an FM file, which enables 
you to create accurate machining simulations more easily. 

 Protecting Machine Design documents (see page 118) — You can 
protect your Machine Design files from the extraction of solids, 
so that you can share them for simulation without anyone being 
able to extract the solids. 
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Multi-tool blocks 
You can now create multi-tool blocks and double-sided tool blocks in 
Machine Design files and use them in machine simulation. 
Previously, each tool block could hold only one tool. 

 
To create a multi-tool block: 

1 Ensure that the Machine Design > Enable Millturn UI menu option 
is selected to access the lathe design options. 

2 Select the Machine Design > Tool Block for Turret menu option. 

The Tool Block tab of the Tool Block dialog is displayed. This tab 
has been updated. 

 
3 Select a solid to use as the tool block. 

4 Select a UCS for the tool location on the turret, or click New UCS 
Wizard and create one. 

5 Select which turrets the tool block can address. 

6 Select which tool locations on the turret the tool block can attach 
to. 
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7 Select the new Tool Locations tab. 

 
8 Click Add to add a new tool location. 

The new Tool Information dialog is displayed. 

 
9 Select a UCS to define the tool location, or click New UCS Wizard 

and create one. 

10 Select which of the spindles the tool addresses. 

11 Under Holds which tool type, select the tool types that can be 
used at this tool location. For OD Lathe tools, select the 
Handedness of the tool. 

12 Click OK to add the tool location and close the Tool Information 
dialog. 

13 To remove a tool location, select it and click Remove. 

14 To edit a tool location, select it and click Edit, or double-click it. 

15 Use the Move Up and Move Down buttons to change the order of 
the tool locations in the dialog. 

16 Click OK to close the Tool Block dialog. 



 

116 • What's new in FeatureCAM 2015 R2 FeatureCAM 2016 R1 What's New  

 

Selecting the tool block 
You can now select which tool block holds each tool within an FM 
file, which enables you to create accurate machining simulations 
more easily. 

To select the tool block for a tool: 

1 Open a Turning or Turn/Mill document that contains toolpaths. 

2 Select the Manufacturing > Tool Mapping menu option. 

The Tool Mapping dialog is displayed. 

3 Select a tool in the list, and click the new Select Block button. 

 
The new Select Block dialog is displayed. 
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4 In the Tool block list, select the tool block solid from the Machine 
Design file that you want to hold the selected tool. 

5 Select the sub slot in the list that you want to hold the tool. 

6 Click OK to close the Tool Block Selection dialog. 

The tool block you selected is displayed in the tool mapping tree. 

 
7 Click OK to close the Tool Mapping dialog and save your changes. 
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Protecting solids in Machine Design documents 
You can protect your Machine Design files from the extraction of 
solids, so that you can share them for simulation without anyone 
being able to extract the solids. 

FeatureCAM comes with some locked Machine Design files. You can 
use these for simulation, but you cannot extract solids from them. 
When you open a locked file, a dialog is displayed explaining the 
restriction. 

 
You can lock your files, but you cannot unlock them. You should not 
lock an original file, instead create a copy of it and lock the copy. 

  

To lock a file: 

1 Use the File > Save As menu option to save a copy of your file. 

2 Select the File > Lock/Unlock menu option. 

The Lock or Unlock File dialog is displayed. 

 
3 Select Lock. 

 If you lock a file, you cannot unlock it. 

4 Click OK to close the dialog and save your changes. 
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