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Introduction to FeatureCAM Turning 

 This module will familiarize you with Autodesk FeatureCAM’s 

history, describe what FeatureCAM is and show how it is 
advantageous over other CAM systems. 

 Increased shop productivity is the primary goal of all FeatureCAM 
products.  Traditional CAM systems are Operations Based and 
require you to program every operation, one at a time, to create your 
part. All the manufacturing details are left to the machinist. That 
means that you must specify the details for every Spot Drill, Drill, 
Ream and Roughing pass of your part.  
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 With FeatureCAM you generate your part using Features such as a 
Tapped Hole, Boss, or a Turned Groove and the operations are 
automatically created. FeatureCAM also manages the details of the 
manufacturing process such as Tool selection, Speed and Feed Rates, 

and Toolpaths. To modify any element of the part program, just 
change a few settings on a feature and a whole new set of operations 
are generated to reflect your changes.  

 Ease of use is another guiding principal of FeatureCAM products. 
Our system was originally developed as a graphical Windows-based 
program. FeatureCAM programs are full of graphical feedback, 
Step-by-Step Wizards and tutorial-style animations that run 
directly in the program dialog boxes. Ease of use has always been a 
FeatureCAM advantage and we continue to study ways to make our 
system even easier to learn and use. 

CAM Software Strategies 

 There are three main different types of CAM software strategies for 
creating toolpaths in today’s modern CAM software.  These strategies 
are Operation based, Processed based and Feature Based.  
Some of these strategies use Knowledge Based Machining (KBM).  

KBM is when machining intelligence is built right into the CAM 
software. KBM is used at various levels and degrees in different CAM 
systems. 

 Operations-based CAM systems require the user to go through 
multiple steps to machine each part. The user must select which type 
of operation to use, select the machining boundary and the type of 
toolpath, then manually select tools, feeds and speeds and multiple 
machining options such as stepover distance and the incremental 

step in Z. These multiple steps must be repeated one at a time for 
every operation on a part, making it a time-consuming process that 
is prone to error. These systems offer little or no KBM. 

 Process-based CAM systems attempt to reduce these steps by 
grouping operations in standard processes. KBM is used as the 
program remembers the used processes and repeats them for future 
operations. However, this method only works when a shop uses the 
same processes over and over for the same types of parts.  

 When a process is applied to different types of parts, or parts made 
of different materials, the CNC programmer must still verify that 
the correct operations were used and that the correct tools, stepover 

and speeds and feeds were selected because a static machining 
process does not automatically adapt to every part. 
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Below is a chart showing a comparison of the three different CAM strategies: 

Feature Based CAM  
Operations-Based CAM Process-Based CAM 

1. Draw or Import Your 
Part 

2. Identify Features 

3. Click Simulation 

      You Are Done! 

      FeatureCAM 
Automatically: 

 Determines Rough and 
Finish Operations 

 Selects ALL Tools Sizes 

 Calculates Feeds & 

Speeds 

 Determines Stepover & 
Z Increments 

 Generates Toolpath 

 Creates NC Code 

 

1. Import or draw part. 

2. Select a rough operation. 

3. Select rough boundary. 

4. Select type of toolpath. 

5. Select roughing tool. 

6. Select feeds and speeds 

7. Select stepover and Z steps. 

8. Select a finish operation. 

9. Select finish boundary 

10.Select type of toolpath 

11. Select a finishing tool. 

12. Select stepover and Z 
steps. 

13. Select feeds and speeds. 

14. Click simulation. 

15. Create NC code 

1. Import or draw part. 

2. Identify features. 

3. Select machining processes. 

4. Click simulation. 

5. Create NC code. 

???Are You Done? No. 

You must analyse and verify:  

Does the process have the 
correct operations?  

Does the process use the 
correct size tools?  

Are the correct feeds and 
speeds used?  

Does the process have the 
correct stepover and Z 
increments? 

  

Feature-based CAM systems use a set of interrelated machinable features to 
describe a complete part. The beauty of features is that they not only describe 
shape, but these also are made up of one or more associative operations that 
describe the preferred method for cutting that shape at the NC machine. A 
predefined set of machining rules and user preferences are applied to a part. 
KBM in these systems streamlines the manufacturing process by building the 
highest level of machining intelligence right into the CAM system. Machinable 
features contain information and rules describing how and where material 

removal should occur, cutting depths, whether to use climb cutting, whether to 
spot drill or Centre drill and preferred machining strategies for roughing and 
finishing. The CAM system evaluates the part geometry and part material, 
selects the most appropriate tools and operations, recommends machining 
strategies, calculates feeds and speeds, then automatically generates the NC 

code. 

Feature-Based Machining 

 Has many advantages such as:  

1 Dramatically shorter part programming times. 

2 Part revisions do not require reprogramming. 

3 NC code is consistent and predictable regardless of the CNC programmer. 

4 Tools are optimized and tool changes reduced. 

5 Toolpath is automatically optimized for faster machining. 
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 FeatureCAM is a Feature Based programming system with 
advantages listed above. Additionally FeatureCAM is very easy to 
use. A programmer new to FeatureCAM or new to programming can 
quickly learn the product and create G-code with the appropriate 

tools, feeds and speeds. 

Below is a list of key points that make FeatureCAM very easy to use. 

1 User Friendly Interface (Steps & Wizards). 

2 Automatic Tool Selection (2D & 3D). 

3 Automatic Feature RECOGNITION (AFR). 

4 Interactive Feature RECOGNITION (IFR). 

5 Standard Databases (Tools, Materials, Feeds & Speeds). 

6 Customizable Post Processors. 

7 Outstanding Technical Support. 

Built in intelligence 

 A major advantage of FeatureCAM is the users' ability to define their 
own set of machining preferences.  FeatureCAM comes with 

predefined machining rules programmed into the CAM system which 
are based on a standard set of material properties and standard tool 
cribs. You can then customize these settings for specific materials 
that you use and the tooling that you actually have available in your 
shop. Once you have these defined, you simply select a material for 
your work piece and the tool crib you want to work with and 
FeatureCAM will then make selections of tooling for a feature 
automatically. If you change the tool crib or the material then 
FeatureCAM automatically updates all of the toolpaths in the part. 

 This means that a part may be programmed for one machine with the 
tools available there and then shifted to another machine simply by 
changing the tool crib. Similarly if you wish to cut a test part in 
Aluminium and then cut the final part in Stainless Steel you program 

the part with Aluminium set as the material. Once you have cut the 
test piece you change the material to be Stainless Steel and 
FeatureCAM will update the toolpaths by changing feeds, speeds, 
depth of cut, stepover etc. without any further intervention from the 
operator. 

 By providing a set of standard machining rules already in place, it's 
easier for you to customize the software to reflect the machining 
preferences of your Machine shop. 

 Setting up your own machining preferences and rules in FeatureCAM 
not only reduces the time it takes to generate programs, but it also 
streamlines production because the approach to machining every part 
is predictable and consistent. Machine operators can rely on the fact 
that each job will be machined in a predictable manner regardless of 
who did the programming 
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Starting  FeatureCAM 

 

1 Select the FeatureCAM icon  from your desktop and select New File 
and Milling Setup and Millimetre. Select Finish twice and then Ok to close the 
Stock menus. The stock menu will be covered later on in the training notes. 

 

 

Evaluation Options 

 

2 Click on the shortcut  that is on the Desktop. This will start 
FeatureCAM. 

3 When it has finished cancel the new Part document wizard that is on the 
screen. 
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4 Go up to the top left of the screen and go to the File menu. Then Select 
Evaluation Options. 
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 FeatureCAM has now been split into three levels. Standard, 
Premium and Ultimate. The next few images show the available 
options for all modules. 

  The image below show the available options in Standard 
FeatureCAM 

 

 It is here that you will see the activated products that you have 
purchased.  
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 The image below show the available options in Premium 
FeatureCAM. 

 

 It is here that you will see the activated products that you have 
purchased.  
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 The image below show the available options in Ultimate 
FeatureCAM. 

 

 It is here that you will see the activated products that you have 
purchased.  
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Desktop Subscription 

 This is what you get when you subscribe:- 

 Individuals, teams and enterprises have more choices than ever before 
Regardless of the size of your business - small, mid-size or enterprise.  

 Autodesk offers the flexibility to choose the subscription options that best 
fit your business needs. 

 Try out new tools without making a big up-front investment. 

 Better manage changing software and budget needs. 

Access options 

 When subscribing, select the option for access and use of your 
software: 

 Single-user access - best for when software is needed for one person 

 Multi-user access - ideal for situations in which you need more than one 
person to share software licences 

Flexible term lengths 

With monthly, quarterly, annual and multi-year options, you can get exactly 
the software you need for as long as you need it. 

Access to the latest software 

 When you subscribe, you have instant access to the latest product 
releases and enhancements. 

 Stay current on the latest software rather than waiting for major product 
releases 

 Update software straightaway or choose a time that is right for your entire 
team 

More about updates and releases 

 Software when you need it, where you need it 

Use your software in more places with access to both current and 

preceding versions. 

 Access preceding versions :- 

You will be able to download and use preceding releases of most Autodesk 
software. 
More about preceding version rights :- 

 Use your software at home - Access both current and preceding versions 
of your software on your home computer. 
More about home use rights 

 Use your software when travelling :-  
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 Use your software and services globally when travelling outside of your 

home country. More about global travel rights 

Autodesk support 

 Let us help you to resolve issues quickly. You will have access to: 

 Senior Autodesk support specialists. 

 Moderated community support forums. 

 E-learning opportunities and exclusive training web casts New Part 
Document. 

Starting a new FeatureCAM part document. 

 Select File>New from the menu or select Ctrl + N keys. 

 

 

User Interface 

 FeatureCAM is a windows-based product and has been a windows based 

product since its inception unlike other CAM products. Many of the functions 
and keystroke shortcuts that you are familiar with in windows are available 
inside FeatureCAM. Examples are Ctrl+C to copy, Ctrl+V to paste, Ctrl+Z 
Undo last operation. etc. 
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Screen Layout 

 

Menu Bar - Located at the top. Like many other Windows based 
software, packages FeatureCAM includes a series of drop down menus.  
These menus are unique to FeatureCAM and provide one or more functions 

used to facilitate the constructing, manufacturing, viewing and editing of 
your part program. 

 

Tool Bars - usually located at the top but, may be docked in other 
locations.  Can consist of one or more buttons and used to create objects in 
the Graphics Window such as the Geometry constructors for drawing the 
shape of your part. 

Geometry and Snap Icons: - Use geometry constructors to create 2D 
geometry. Snapping is a CAD concept that helps you position lines, points 
or shapes as you construct geometry for the part. Entering points by 

coordinates is exact but not always convenient or feasible. Picking points 
with the mouse is not always precise enough. The bridge between the 
methods of point selection is snaps. From left to right, the buttons set the 
snap to: 
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Results - Located on the right side.  It contains the Operation list.  
Whereas the Part View contains all of the features, the Operation List 
contains all of the machining history.  It also provides the details of each 
operation, including a tool list. The NC code is also here.  All of the 
information residing in this area may be printed. 

 

Graphics Window - Located in the Centre.  This is where most of the 

activity is taking place, creating Stock, Importing Drawings, Creating Solid 
and Surface models, constructing Geometry, Chaining with Curves, 
creating Features and Simulating the tool path in 3D or using the 
Centreline Simulation. 

 In the Centre of the screen is the Graphics Window.  All drawings and 
toolpath simulations happen in this window. On the right is the 
Manufacturing Results Window. The automatically generated 
documentation and part programs are shown in this window. 

 At the bottom of the screen is the Assistance Bars for Geometry 
and Status. The Assistance Bar is where you are prompted when 
creating Geometry. 

 The screen shots shown above and on the next page show the 
Results Window. This shows you the order in which the machining 
is carried out. The Feature in which it is associated too, plus the Tools 
used in that sequence and the corresponding Feeds and Speeds. At 

the end you have the depth that the Tool will go to for example 
25mm 

 There are three tabs available on the results window at the bottom.   

 

 These are Op List, Details and NC Code.  
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 In the Part View Tool Box this contains the names of the objects that are 
created on the screen. Objects that can be contained in this area are Stock, 
Setups, Curves, Surfaces, and Solids, which can include Stl triangulated 
models. 

 

 Clicking on the objects in the Part View enables different functions.  
Left-click selects the object in the Graphics Window.  Right-click 
reveals menu of options available for the object. Clicking on a “+” 
will expand the view to reveal objects that are subordinate. 
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 Steps - Located on the left side. A systematic sequence to guide, especially the         
beginner, as to the order of which needs to be completed first, second, etc.  

 The Steps toolbar is an outline for the flow of the program. The Steps 

are numbered sequentially in the order they should be executed and 
can be a guide for creating your part.   

Steps Menu 

 

Steps to take to create a part in FeatureCAM 

Drawing a part in FeatureCAM 

1 Start FeatureCAM. 

2 Draw geometry in FeatureCAM. 

3 Resize Stock to fit part. 

4 Create and move Setup to desired location. 

5 Create curves. 

6 Create Features. 

7 Select Crib, Select Post, and Generate NC code. 
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Importing a file into FeatureCAM 

1 Start FeatureCAM. 

2 Import 2D or 3D files into FeatureCAM. 

3 Use Wizard to align part and create Setup. 

4 For Solid models use Automatic Feature Recognition (AFR) or use 
Interactive Feature Recognition (IFR) to create features. 

5 Select Crib, Select Post, and Generate NC code. 

 Another example of the steps to take. Suppose you have a 2D drawing 
on your desk and you would like to create a solid model and a CAM 
program. To do this, we would follow the steps sequentially:  

1 Specify type of stock and stock dimensions,  

2 Draw Geometry 

3 Create Curves from Geometry  

4 Create Surfaces  

5 Create Solid from Curves.  (Extra Cost Option) 

6 Use AFR (Automatic Feature Recognition) or IFR (Interactive Feature 

Recognition)  

7 Create Features  

8 View toolpaths and  

9 Select Crib, Select Post, and Generate NC code. 

 You can access the majority of FeatureCAM’s functions through 
these buttons.  A summary of each of the Steps function is listed 
below. 

 Tip: We recommend that if you are just starting out with the program 
or demonstrating it to others that you use the steps toolbox instead 
of toolbar buttons in other areas of the interface to keep the interface 
simple.  

Stock 

 The Stock Wizard steps you through entering the shape and 
dimensions of the stock, the stock material, part program zero and 
the coordinate system for modeling.   

 Geometry. This gives you the ability to create part shapes using a 
series of Geometry commands for example Points, Lines, Arcs, Clip, 
Fillet etc. These are used to define the overall shape of parts.  Many 
different geometry tools are available.  Geometry can also be 
imported from other CAD systems. 

 Curves. Shapes that involve more than a single line or arc are 
described as curves.  
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 Surfaces.  This opens the Surface Wizard. 

 Solids.  This opens the Solid Wizard. 

 AFR. (Automatic Feature Recognition) This creates 2.5D 
geometry from Solid Models ready for machining. IFR is also 
available. 

 Features.  This relates to common shop terms like Hole, Pocket, 
Slot or Thread Milling etc.  They are created from curves or 
dimensions.  These objects are created in 2.5D and are used to 
generate toolpaths.   

 Toolpaths. Toolpaths are generated from collections of features. You 
can simulate them in FeatureCAM using toolpath Centerlines, 2D 
shaded or 3D solid shaded simulations. Plus full Machine Tool 
Simulation. 

 NC Code. Machine-specific G-codes are generated from the 
toolpaths. Translators are provided for many different NC controls 
and include a program for creating new translators.   

Steps (See menu in PartView) 

 The following is a guide to help you choose the correct way in which 
to machine a component in FeatureCAM. 

1 Open FeatureCAM and select New File (Default). Select Next. Choose your 
module of choice and your units. Select Finish. Cancel the dimensions wizard. 
Hide the stock by selecting Stock in PartView, right click and select Hide Stock. 

Draw you part using geometry creation techniques. Select Show Stock in 
PartView. Create your stock around your geometry. Double click on the stock. 
Use the Resize button to create your stock boundary. Use Compute Stock from 
the size of the part. Re-establish your Setup1 position. Select your ToolCrib. 
Create Curves. Create Features, which in turn creates Toolpaths. Select your 

desired post. Set your tool change position. Run 2D centreline Simulation or 
3D Simulation. Check for errors. Output code to your desired location. 

2 Import 2D (.dxf) (.dwg) drawing and follow the steps above from resizing 
Stock. 

3 Import Solid Model. Follow the wizard for Stock size and Setup. Use either 
Automatic Feature Recognition for simple 2.5D plate work, i.e. 2D pockets 
and holes. Use Interactive Feature Recognition for more control over 
extracting features. Run 3D Simulation. Check for errors, Collisions. Output 
code. 

 

Browser - Located on the Left side”Toolbox” below Steps. Your computer 
must be connected to the Internet. The Browser provides a link to the Internet. 
Learn about the Browser by participating in the various sections with 
downloadable examples on the opening page, then click on the links and explore 
the contents. 
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 Geometry Bar - Located near the bottom.  This area is constantly used 
and is where the dimension boxes are used to locate the Geometry on your 
stock material in the Graphics Window. 

 

 Metric 

 Status Bar - Metric or Inch. This is Located at the very bottom of 
FeatureCAM.  It contains the plane you are working in (XY–XZ-YZ), the unit 
of measure (Inch or Metric), the layer you are working in, the Setup, Post 

Processor and the Tool Crib. Normally: - BasicMetric for Metric Tools. We 
also show the number of Cores Used. 

 

 Analyzing the above screenshot from the Status Bar. 

 XZ is the current drawing plane being used. Inch or Millimetres are 
the type of units being used e.g. length 100mm. Layer1 is the current 
active Layer. UCS_Setup1 is the current UCS (User Coordinated 

System) being used. Setup1 is the current active setup in which features 
are created. 

 Mori Seiki NZ 1500 TZY.CNC is the current Post Processor being used. 

 Mori Seiki NZ 1500 TZY.MD this is the Machine Simulation file. 

 This is the current Tool Crib and we are using 4 cores on this computer. 

Customize Manufacturing.  

 FeatureCAM automates the entire part programming process; you can 
customize all of the System Settings including Feed/Speed Tables, 
Tooling Databases or Feature settings.   
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 Note: Some Steps are displayed or not displayed depending on which 
options you have purchased or have turned on. 

 

 

 Operation List Tab: - This contains a table of different sequences in 
order of operation. 

 Details, gives you a breakdown of the sequence of operations. 

 Tool List. This gives a breakdown of the tools used. 

 NC Code. CNC code that will be output from the currently selected Post 
Processor. 

 Please note you have to run the Simulation before the NC Code is made 
available for output. 
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ViewCube  

The ViewCube is a new feature in FeatureCAM, which enables you to change 
and identify the viewpoint of the Graphics window. By clicking the ViewCube’s 
corners, faces, edges, and icons, you can use it to directly manipulate the view 
in the Graphics window. In addition, when you re-orient the view using a cube 

option, toolbar button, or keyboard shortcut, the ViewCube automatically 
reflects the new viewpoint.  

 

The ViewCube is displayed in the upper-right corner of the Graphics window. 
Click and drag the cube to re-orient the view in any direction. Alternatively, 
click:  

 A face to show it as an orthogonal view.  

 An edge to show the adjacent faces.  

 A corner to show the three adjacent faces.  

In addition, when you move the cursor near the cube, the Home icon is 
displayed. Click the icon to show the Home view.  

 

Manipulating orthogonal views 

When you select a single-face view and move the cursor near the cube, control 
icons are displayed: 

Click: 

To show the view of an adjacent face.  

To rotate the view clockwise through 90 degrees.  

To rotate the view counter-clockwise through 90 degrees.  
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Mouse buttons 

 Each of the three mouse buttons performs a different dynamic operation in 
FeatureCAM.  

 

Left mouse button Picking and selecting. 

 This button is used for Selecting Items of the pull down menus, options 
within forms, and entities in the graphics area. 
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Middle mouse button Dynamics. 

 In these options, you can set the behaviours to be specific viewing modes 
such as Trackball, Rotate, Pan, Zoom, Pan and Zoom, and so on, or 
choose the Current Viewing Mode option that allows the middle-mouse 

button (along with key combinations) to perform the viewing mode that is 
currently set in the toolbar. 

 The most commonly used mouse feature is to hold the Centre wheel down 
and moving the mouse, this will rotate your part. Hold the shift key down 
at the same time and you can Pan anywhere on the screen. Hold the shift 
key down and where ever the mouse is it will Zoom to that point by using 
the Wheel. This is excellent for looking closely at your component. 

 Zooming in and out: - Hold down the Shift key and mouse button 2. 
Move the mouse up and down to zoom in and out. 

 Pan around the model: -Click once with mouse button 2 to position in the 
Centre of the screen. Click and hold to zoom and then move the mouse in 
the required direction. 

 Zoom Box – Hold down mouse buttons 1 and then button 2, drag a box 
around the area to zoom. Release both buttons at the same time. Rotate 
mode: Hold down the Ctrl key and mouse button 2. Move the mouse up 
and down to zoom in and out. 

Right mouse button Special Menus & FeatureCAM Options. 
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 When this button is pressed it brings up a local menu relating to whatever 

the Mouse Pointer is over, such as a named item in the FeatureCAM Part 
View or a physical entity in the graphics area. If nothing specific is selected 
the View menu appears.  

Viewing Options 

 For those users who are already familiar with other Delcam ® products 
DON’T PANIC!  Just do the following. 

 View changes the way you interact with the view of the part. Selecting 
any of the options from the View menu puts you in view mode. 

 Dynamic Viewing Options. 

Dynamic Viewing Options tab, you have two choices to reset the settings to: 

Reset to FeatureCAM Settings  

 This button resets all the options in the dialog to FeatureCAM defaults, 
which are: 

Dynamic Viewing Choice upon FeatureCAM Start-Up - Pan and Zoom  

 Middle-mouse button behaviour - Current Viewing Mode  

 Middle-mouse button with Shift - Pan and Zoom  

 Middle-mouse button with Ctrl - Rotate  

 Middle-mouse button with Ctrl+Shift – Zoom 
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Reset to PowerMILL Settings  

 This button resets all the options in the dialog to PowerMILL defaults, 
which are: 

Dynamic Viewing Choice upon FeatureCAM Start-Up - Trackball  

 Middle-mouse button behaviour - Trackball  

 Middle-mouse button with Shift - Pan  

 Middle-mouse button with Ctrl - PowerMILL Pan & Zoom  

 Middle-mouse button with Ctrl+Shift - Box Zoom 

 This menu controls the default viewing mode when FeatureCAM first opens. 
For example, if you select Trackball, the next time FeatureCAM starts up, 

the viewing mode is Trackball. 

 

Viewing Options General 

 In the General Viewing Options we now have the ability to change the 
size of the Snapping point. By default this size is normally 4 pixels. 
In order to create larger points, change this to 8 pixels. 
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 An example of this is shown below 

 

Viewing Options Machine 

When viewing machine axis, by default the view is shown vertical: If you have 
a Horizontal machine or a Mill/Turn machine (Vertical turret lathe) use this 

option to change the view. 

 Milling — Select the type of milling machine from Vertical and Horizontal, 
to improve viewing during machine simulation and tool previews. 

 Turning — Select the type of turning machine from Slant bed lathe and 
Vertical turret lathe, to improve viewing during machine simulation and 
tool previews. 
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Display options 

 For the best Display Options for your computer set the N-Vidia ® 
Control Panel options to the following. 

 

 All of the viewing options are available via Right mouse button.  
Click in the Main Graphics Area 

Principle views 

  Changes to a view of the part from the front with no other 
surfaces visible. 

  Changes to a view of the part from the back with no other 
surfaces visible. 

  Changes to a view of the part from the left side with no other 
surfaces visible. 

  Changes to a view of the part from the Right side with no other 
surfaces visible. 

  Changes to a view of the part from the top only. Useful for 
drawing geometry, but harder to see the wireframe model of the part. 

  Changes the view to the bottom of the part. No sides of the 
part are visible from this perspective. 
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 Right Click in the graphics area to show this menu. 

 All the viewing modes are available, plus an option called Mode from 
Last Session. This option keeps track of the viewing mode last set 
before FeatureCAM was closed, and uses that viewing mode the next 
time FeatureCAM starts up. For example, if the option is set to Mode 
from Last Session, and you had set the viewing mode to rotate before 
you closed FeatureCAM, Rotate is the viewing mode that is set in the 

toolbar the next time you open FeatureCAM. 

 Isometric - changes the view to a three quarter view of the part 
showing the top and two sides with the current UCS near the bottom of 
the viewing area. 

 Perspective - If selected, the view is a perspective view. If 
deselected, the view is an orthographic view. 

 As on setup - If selected, the view is relative to the current setup. If 
deselected, the view is relative to the world coordinate system. 

 As on UCS - changes your view to that of the current UCS. 

 As on world - changes your view to that of the current UCS. 
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Keyboard shortcuts 

 You can use the keyboard to navigate around the menus. To do this, 
press and hold the Alt key, and then press the letters on your keyboard 
that correspond to the letters underlined on the Menu bar and in the 

menu options. For example, to rotate your part, press and hold the Alt 
key, press V for View menu, press V for Viewing Modes and press R for 
Rotate. 

 

Key sequence Action 

Alt+click-and-drag on any toolbar button Move button around in toolbar. 

Alt+1 (2,3,4) User View 1 (2,3,4) 

Alt+Enter Properties 

Alt+F1 Centreline simulation. 

Alt+F2 Play/pause simulation. 

Alt+F3 Single-step simulation. 

Alt+L Last view. 

Alt+R Refresh 

Alt+Shift+V Save view. 

Ctrl+click a column of any list box that does 

sorting 

Activates the second level of sorting. 

Ctrl+click a viewing mode button Stay in that viewing mode. 

Ctrl+click the 3D Simulation button. 

Release key and click the Play button. 

Run 3D simulation in hidden line 

mode and do continuous looping. 

Ctrl+click Fast Forward to End  
Stops the simulation when it 

encounters the next rapid (in 

addition to the next operation). 

Ctrl+click the Machine Simulation 

button. Release key and click the Play 

button. 

Run machine simulation in hidden 

line mode and do continuous 

looping. 

Ctrl+A Select all. 

Ctrl+C Copy 

Ctrl+E Centre selected. 

Ctrl+F Find (text in a text window). The 

cursor must be in a text window. 

Ctrl+H Replace (text in a text window). The 

cursor must be in a text window. 

Ctrl+L Centre all. 

Ctrl+N New file 

Ctrl+O Open file 

Ctrl+P Print 

Ctrl+R Opens the New Feature wizard. 

Ctrl+S Save file 

Ctrl+V Paste 

Ctrl+X Cut 

Ctrl+Y Redo 

Ctrl+Z Undo 
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Ctrl+click the Pick Curve button 
Causes the warp status for that 

dialog to toggle. 

Ctrl+click the Pick Curve button while a 

Key sequence 

Toggles between simulation of the 

selection feature and the entire 

setup. 

Ctrl+click the Play button 
Run simulation in hidden line mode. 

Hold Ctrl while toolpath is being computed Temporarily turns off Toolpath 

Computation Minimization. 

Toolpaths will be recomputed for all 

features even if that feature did not 

change. 

Ctrl+Alt+click-and-drag on any toolbar 

button 

Duplicate and move button around 

in toolbar. 

Ctrl+Shift+click the 3D Simulation 

button. Release keys and click the Play 

button. 

Continuous loop simulation for 3D 

simulation. 

Ctrl+Shift+click the Machine Simulation 

button. Release keys and click the Play 

button. 

Continuous loop simulation for 

machine simulation. 

Ctrl+Shift+A Shade selected. 

Ctrl+Shift+C Unshade all. 

Ctrl+Shift+N Unshade selected. 

Ctrl+Shift+P Toggles perspective. 

Delete Delete the selected object 

Double-click a simulation button 

 

Activate that simulation without 

clicking the play button.  

Esc Stop current simulation. 

F1 Context-sensitive help. 

Middle-click-and-drag in the graphics 

window 

Performs viewing based on the 

current viewing mode. 

The mouse wheel-click-and-drag 

also performs this function. 

Mouse scroll wheel Zoom 

Shift+click an edge when filleting Selects all edges of the face and 

adds them to the list. 

Shift+click the NC Code tab Show ACL instead of NC code. 

Shift+click while clipping when Multiple 

Region is On 

Removes the entire picked region 

instead of to the nearest 

intersection. 

Shift+right-click in graphics window Dynamic viewing using current view 

mode. 

Shift+click the Show button in the SCL 

dialog 

Brings up a dialog that shows the 

attributes of the model selected in 

SCL dialog. 
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Commonly used Ctrl Keys 

 New Feature Menu or Ctrl + R  

 Isometric View or Ctrl + 1 

 Top View or Ctrl + 5 

 Refresh Alt + R 

User interface: Keyboard shortcuts 

 There is a new tab in the Customize Toolbars dialog, Keyboard 
Shortcuts: 

 

 This tab lets you assign your own shortcut keys to the FeatureCAM 
menu commands. To set a new shortcut key: 

 Select a category from the Categories list.  

 Select a command from the Commands list.  

 If the command already has a shortcut, it is listed under Current 
keys. 

 To assign a new key, select the Press new shortcut key field and press 
the keys that you want to use as the shortcut.  

 Press the keys on the keyboard, for example, press and hold down the Alt 
key and press the N key; do not type ALT + N.  
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 A warning displays if the shortcut you entered is already assigned to a 

command. 

 Click the Assign button to save the new shortcut.  

 If you click Assign after receiving a warning that the shortcut is already 
assigned to a command, the shortcut is removed from the existing 
command and assigned to the new command. 

 Remove — Click this button to remove the shortcut assigned to the 
selected command. 

 Reset All — Click this button to reset all shortcuts to the FeatureCAM 
defaults. 

Blanking model entities 

 Use the Blank Selected (Ctrl + J) option to temporarily hide all visible 
components. 

 (Ctrl K) Hide Selected components 

 To re-display all of the components. Right-click in the graphics area and 
select Unblank (Ctrl L). The blanked model components are displayed. 
Please note this option will only work if you have set this up as explained in 
the previous chapter. 

Show menu 

 Show  functions help control what is displayed. This is useful as you place 
and model intricate features in a complex part. 

 You access the Show functions by selecting View > Show from the menu 
or using the Show Menu button on the Advanced toolbar: 

 

 Show All — Use this menu option to Show everything in the part model. 
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 Show All Geometry — Use this menu option to Show all geometry 

(points, lines, arcs, and circles). 

 Show All Dimensions — Use this menu option to Show all dimension 
information added with the Dimensions Tool. 

 Show All Curves — Use this menu option to Show all Curves. 

 Show All Surfaces — Use this menu option to Show all surfaces (available 
only in FeatureCAM 3D). 

 Show All Features — Use this menu option to Show all features. 

 Show All Solids — Use this menu option to Show all solids 

 Show All Vertical Surfaces — Use this menu option to Show the vertical 
surfaces in the model. This is useful for identifying surfaces that are part of 
2.5D features like holes or pockets contained in a surface or solid model. 

 Show Stock — Use this menu option to Show the stock outline. 

 Show Current UCS — Use this menu option to Show the current UCS icon. 

 Show Current Setup — Use this menu option to Show only the features 
and drawing elements that are in the current Setup. 

 Show Selected — Use this menu option to Show only the selected 
elements 

Hide Menu 

 Hide controls what is displayed at any given time. This is useful as you 
place and model intricate features in a complex part. Besides the display 

factors, you can’t snap, select or build curves from hidden entities. The Hide 
functions are not exclusive. You can click different buttons sequentially, 
hiding different entities until only the ones you want are still in view. 

 You access the Hide functions by selecting View > Hide from the menu or 
using the Hide Menu button on the Advanced toolbar: 
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 Hide All — Use this menu option to hide all geometry, curves, Features. The 

stock and axis icon remain visible. A common procedure is to Hide All, then 
Show only one type of entity, for example features. 

 Hide All Geometry — Use this menu option to hide all geometry. Other 
entities remain visible. 

 Hide All Dimensions — Use this menu option to hide all dimension 
information added with the FeatureCAM Dimension tools. 

 Hide All Curves — Use this menu option to hide all curves. Other entities 
remain visible. 

 Hide All Surfaces — Use this menu option to hide all surfaces in the part 
model. Only available in the 3D version. 

 Hide All Features — Use this menu option to hide all features. 

 Hide All Points — Use this menu option to hide all points. 

 Hide All Non-Vertical Surfaces — Use this menu option to hide all surfaces 
that are not vertical relative to the current setup. This is helpful if you want 
to isolate the surfaces that are part of 2.5D features in a surface or solid 

model. 

 Hide All Solids — Use this menu option to hide all of the solid models. 

 Hide Stock — Use this menu option to hide the stock outline. All other 
entities remain visible. 

 Hide Current UCS — Use this menu option to hide the current user 
coordinate system. 

 Hide Current Setup — Use this menu option to hide the axis of the 

current Setup. All other entities remain visible.  

 Hide Selected — Use this menu option to hide all selected entities. Non 
selected entities are still visible. 

 Hide Unselected — Use this menu option to hide all entities other than 
the selected ones. 

Setting file location options 

1 Open FeatureCAM by double clicking the FeatureCAM shortcut   

2 Select New File. Turn/Mill Setup. Select Finish. 
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3 Before we start please select Options/File Options/Existing Files. 

 

4  Select Browse. Then select the following location. 
C:\Training_Data\FeatureCAM Course Data 2017. 

5 Select Apply and Ok to close the form. When we save or import files 
FeatureCAM will take us to this location. 

6 Please save all files in Coursework. 

7 Tool Crib = BasicMetric. 

8 Post processor used = Fanuc 21i – T.cnc (2 Axis) 

What is a Feature? 

 If we look at a Part such as that shown on the next few pages and consider 
how we would manufacture it we can see that it can be broken down into a 
series of Machining Operations. For example we would probably want to 
start by Facing off the top of the part, then Turn the outside profile, and 

then drill and bore the centre Hole feature etc. 
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 FeatureCAM defines a part in terms of Features using common shop floor 

terminology for instance an area that looks like a Groove can be machined 
using a Groove Feature. When you define a profile as a Turn Feature, 
FeatureCAM will then automatically decide what operations to use to 
machine that profile. All you have to do is say “This is a Turn” profile and 

FeatureCAM will select suitable Roughing and Finishing Operations, 
Tooling, Speeds and Feeds. You are then free to modify these default 
values to suit your particular situation. By automating the generation of 
operations the overall time taken to program a part can be drastically 
reduced. 

 There are four different ways to activate the New Features menu. 

 Select Features  from the Steps menu. 

 Select Ctrl + R New Feature. 

 Select Construct>New Feature. 

 Select New Feature from the Advanced Toolbar then select Turning. 
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How is a Feature Created? 

 There are a number of different ways in which Features can be created in 
FeatureCAM, which method you choose will depend upon the data available 
to you. In broad terms the methods are: - From Dimensions and From 

Curve. 

 

From Dimensions 

 If you are working from a print (Paper Drawing) then often the 
quickest way of creating features is to pull the Dimensions from the 
drawing and enter them directly into FeatureCAM. For example you 
can create a Groove by entering its Location and Orientation and 
Position (Location). Additional attributes for the Feature can also 

be added such as Chamfer or Radius on the groove. 

 

 Hole Feature 

 Groove Feature 

 Thread Feature 

 Face feature 

 Cutoff feature 

 Bar Feed feature 
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From Curve 

 If you have a print or a 2D drawing of a part in electronic format 
you can create Curves for more irregularly shaped parts and then 

create the Feature from the Curve. Just select Pick Curve pieces 
select the 2D Geometry and select the Create button.  

 Turn Feature 

 Bore Feature 

 Groove Feature 

 Thread Feature 
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 Select 3D Simulation and then press Play  on the Simulation 
Toolbar. 

 Examine the diagram below of the Simulation ToolBar; Read the 
purpose of each button 

 

 Eject:  Erases the Simulation from the Graphics window.  

 Show Centreline: A line drawn at the Centre of the tip of the tool is displayed. 

 2D Simulation: A two-dimensional Simulation showing the regions cut by 

each operation is displayed. The view is changed to the top view automatically. 

 3D Simulation: A 3D solid Simulation is displayed where the tool is 
animated through all of its moves.  

Eject 

Centreline 

2D 
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 3D Rapid Cut: In this mode a 3D Simulation is performed but the tool is 
not animated. Only the final result is displayed. For most parts, the 
simulation takes only a few seconds to complete. Note this type of 
Simulation is only available in FeatureMILL3D. 

 Machine Simulation: A 3D solid Simulation is displayed where the tool is 
animated through all of its moves along with the machine tool 

 Stop: Cancels a Simulation.  

 Play: Starts the selected Simulation (Centreline, 2D, 3D or Rapid Cut), or 
restarts a paused Simulation. 

 Fast Forward to end: Skips to the end of the animation 

 Single step: Moves the Simulation ahead one tool move. The keyboard 
accelerator for this button is ALT+F3 or ALT+Right Arrow 

 Play to Next Operation: continues to simulate until the next operation. 
This button is actually a fly-out menu. By clicking on the triangle to the 
right of the button the following additional options are revealed. 

 

Next Rapid simulates until the next rapid tool move.  

Next Tool Change simulates until the next tool change.  

Next ZLevel will simulate the next Z of a Z level toolpath. For other 

toolpaths it will play the entire next operation 

 Clear Toolpath: Erases any Centreline toolpaths on the screen.  

 Region of interest limits the portion of the part that is simulated.  

 Show tool load indicates whether or not to display a graph of the tool 
load when the next 3D Simulation is performed. 

 

 Sim Speed: To adjust the speed of a Centreline, 2D or 3D Simulation, 
use the Slider on the right-hand side of the controls.  

 Slide to the right to speed up, and move to the left to slow down the 
Simulation. The Slider on the Simulation Toolbar also affects the 
display for Rapid Cut Simulation. If the Slider is all the way to the 
right, only the final Simulation result is displayed. Position the slider 
bar further to the left to see slower Rapid results.  
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 You should have a result similar to that shown below. 

 

 A Centreline display of the toolpath is shown above where the lines 
displayed represent the centre of the bottom of the tools 
movement.  Green lines represent rapid movement where blue lines 

show feed moves.  Press the Eject button to close the 
simulation. 

 The image shown is an isometric View of the Toolpath 
Simulation with different colours representing each operation. 

 Select the 3D Simulation button  and press Play  to show the 
image shown on the previous page. 

 Code can only be output after the Simulation has finished. If the 
simulation fails. NC code will not be output. 
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Saving your work 

 Question? What is the difference between Save and Save as? 

 Answer: When you are working on a document, it is a good idea to save 
your work every couple of minutes. In the File menu of the program, you 
will typically find the options "Save" and "Save As" 

 Choosing "Save" simply saves your work by updating the last saved version 
of the file to match the current version you see on your screen. 

 Choosing "Save As" brings up a prompt to save your work as a file with a 
different name. For example, you might choose to save a document called 
"FeatureCAM_opp1". This way, you can save you file at different stages 
and keep multiple versions on your hard drive. 

 Choosing "Save" and then "Save As" is also a good way to make a backup 
of your file. Just be sure to rename the file something new when you choose 
"Save As" or you will overwrite the current saved version, just like choosing 
the "Save" command would do. 

Save Options 

 In the File menu you have Save options. 

 See Save Options on the next page. Adjust your computer to the same 
as the options shown. 

 

Create backup copy: - Select this option to save a number of previous 
versions of your part as you work. Enter the Number of copies to keep and 
set the Backup location. When you save a file, the previous version(s) are 
saved to disk using the name, but prefixed with Backup of. The latest version 
of the file is always saved using the name of your FeatureCAM part.  

Compress file:- Select this option to reduce the size of the FeatureCAM files 
on disk.  
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 Compressed files cannot be read into earlier versions of 
FeatureCAM.  

Save preview picture in file: - Select this option to store an image of the 
part in the file. This image is displayed in the Open dialog. 

Save computed toolpath: - For certain parts, generating toolpaths can be 
time-consuming and you may want to save them for the next time you open a 
part. The setting of Save computed toolpath controls the default behaviour for 
saving toolpaths. Select from Always save, Never save, or Ask me to be 

prompted each time you save a part. The toolpath is saved as an .fmp file. 

 This is different than saving the NC text file that the NC machine 
reads. Instead you are saving the FeatureCAM internal toolpath 

representation.  

 If you upgrade to a newer version of FeatureCAM, the toolpath is 
disregarded and recomputed.  

 OK: - Click the OK button to save your settings and close the 
dialog.  

 Cancel: - Click the Cancel button to close the dialog without saving 
any changes.  

 Help: - Click the Help button to open this Help topic. 

Send Part Files dialog 

To display the Send Part Files dialog, select File > Send from the menu. 
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 Select the files you want to send from:  

Part document: - The current .fm file.  

Milling post: - The current milling .cnc file.  

Turning post: - The current turning .cnc file.  

Wire EDM post: - The current Wire EDM .cnc file.  

User interface settings: - The .ini file containing your user interface 
preferences.  

Machine design files (.md): - the current .md file.  

Crash and performance logs: - Select this option to create a separate .zip 
file of your system's crash and performance logs.  

Select how you want to send the files:  

As individual files: - The individual files are attached to a new email.  

As a zip file: - The files are zipped and the .zip file is attached to a new 
email.  

Save to desktop: - The files are zipped and the .zip file is saved to your 
desktop.  

Size confirmation  

If you are sending .zip files, a Size Confirmation warning dialog is 
displayed:  

The average email server limits attachments to 10 MB.  

The total size of the attachment(s) is: N (where N is the size of your 
attachment(s))  

Would you like to continue sending?  

Click Send to attach the files to an email.  

Click Don't Send to keep the files on your desktop.  

Click Cancel to discard the files.  

FeatureCAM file types 

You can save several different types of files for your part.  

 .op is the Manufacturing Operation Sheet and is the same information 
shown on the Details tab when you select Operation List.  

 .tl is the Manufacturing Tool Detail Sheet and is the same information 
shown on the Details tab when you select Tool List.  

 .txt is a text file containing the NC code for the particular part file.  

 .tdb is a FeatureCAM tooling database that contains just the tools you 
used to create the part.  

 .fdb is a FeatureCAM material database that contains the feed and speed 
tables used for the part.  

 .cdb is a FeatureCAM machine configuration database that contains the 
settings for default attributes.  
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Part Documentation 

The Part Documentation dialog enables you to add comments to the printed 
documentation and set a permanent preview picture for the part.  

 To display the Part Documentation dialog, select File > Part 
Documentation from the menu.  

The Part Documentation dialog contains two tabs:  

Documentation  

Preview Picture  

Documentation tab 

 On the Documentation tab of the Part Documentation dialog, optionally 
enter a Title, Author, Company, Part/Drawing No., Revision, Note 1, 
Note 2, and Comments.  

 To print these values along with the documentation, select Comments in 
the Printing Options dialog.  

 

 If you use the custom setup sheet add-in, these values are copied 
to the Setup Sheet Options dialog.  

Preview Picture tab  

On the Preview Picture tab of the Part Documentation (see page 95) 
dialog, you can set a permanent preview image for the part. This image is 
displayed in the preview pane in the File > Open dialog when you select a 
file.  
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This image is normally updated each time you save the part. If you want to 

store a permanent image with the part:  

9 Create the view of the part you want to store.  

10 Click Update preview picture  

 The current view in the graphics window is displayed as the 
Current preview picture, for example: 

 

11 Click OK to save the preview picture or Cancel to close the dialog 
without saving the preview picture.  

Saving your settings 

 FeatureCAM uses two .ini files to store your settings:  

 ezfm_ui.ini contains toolbars, dialog locations, graphics settings, colours, 

and other user settings.  

 ezfm_mfg.ini contains manufacturing defaults and .cfg settings.  

The ezfm_mfg.ini file contains default values for both inch and metric 
attributes. For example, there is an entry for zrapid in inches and also an 

entry for zrapid_mm in mm. In general, the name for the metric attributes is 
the same as the inch name, with a suffix of _mm.  
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 There are three items from the Options menu affect the 
communication with the ezfm_ui.ini and ezfm_mfg.ini files:  

 Options > Save Settings Now: - Writes the current settings to the files.  

 Options > Reload Settings: - Reads the settings contained in the files 
into the program.  

 Options > Save on Exit: - Saves the current settings when you exit the 
program. If this option is not selected, the settings for your current 
session are not saved to the files when you exit.  

Import/Export  

 You can import and export various file types into and from FeatureCAM.  

 The settings for import and export are in the Import/Export Options  

 To open this dialog select File > Import/Export Options from the menu. 

Import/Export Options 

The Import/Export Options dialog contains settings for importing and 
exporting.  

To display the Import/Export Options dialog select File > Import/Export 
Options from the menu.  

The dialog has three tabs:  

General  

Solid Import  

Digitized Data  

General tab 

The General tab controls how FeatureCAM Imports or Exports files. It 
contains the following options:  
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Always replace object on import: - Select this option to overwrite objects 

of the same name when you import. Deselected prompts for every 
replacement. You can’t have two objects with the same name. 

Smooth EZ-MILL curves: - Select this option to improve EZ-MILL curves on 
import because FeatureCAM has a higher resolution curve format.  

Keep IGES import log file: - Select this option to keep a log of the import 
process for later review or troubleshooting.  

IGES log file name: - Enter the path and filename for saving a record of the 
import process.  

Import IGES entity of type:  

Logically dependent: - can exist by itself but is also referenced by another 
entity (case of groups or grouping situation).  

Physically dependent: - generally, you should deselect this option to 
indicate you do not want physically dependent entities to be imported. But if 
you are having trouble with your IGES file and it is not importing properly, try 
selecting this option and re-importing. Entities in an IGES file are marked to 

be either physically dependent or not. Those that are marked to be physically 
dependent are entities that are used in the construction of other entities. For 
example, a trimming loop is physically dependent upon the trimmed surface 
that uses it. The trimming loop is not important all by itself, but is instead a 
building block of something else. The trimmed surface is in turn marked 

physically dependent to indicate that it is a building block of a parent entity, a 
solid. By selecting physically dependent, you cause FeatureCAM to show 
everything in the IGES file - not just the top-level entities that are usually 
shown, but also all of the lower-level building blocks. This is generally not 
what you want. Generally you want only the top-level entity, for example the 

solid.  

Both physically and logically dependent: - meets both logically and 
physically dependent criteria (is referenced by at least two other entities: - 
the parent for the logical link cannot be the parent for the physical as well).  

Centre stock automatically: - Select this option to automatically size and 
position the stock so that it covers the imported data.  

Number of decimal places in IGES export: - determines how finely data is 

exported to the IGES format. 

Solid import tab 

The Solid Import tab contains the following options: 
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Heal Catia solids: - Select this option to try to repair the faces or surfaces 
contained in the CATIA .mod file. This option can be time-consuming because 

it attempts to:  

 retrim the surfaces/faces against each other.  

 force edges of surfaces to actually lie on the surface.  

 Simplify surfaces like converting a general surface into a cylinder.  

Import hidden Catia V5 solids: - Select this option to import all parts 
contained in the CATIA file even if those parts are hidden.  

Import file as solids: - Select this option to import files as solid models. If 

this option is deselected, the models are imported as surface models. We 
recommend that you import models as solids. If this option is selected and the 
solid fails to import properly, you are asked if you would like to attempt to 
heal the solid to try and fix the import problem.  

Import work planes: - When selected, planar surfaces in solids are 
imported. When deselected, planar surfaces in solids are ignored.  

Stitch IGES surfaces into solids/sheets: - Select this option to try to 
create one or more solids or sheets from an IGES file. If an IGES file contains 

more than one solid or sheet, this is the most efficient way to create the 
multiple objects from the file. 

Importing Files 

1 Use the File > Import menu option to load a CAD model from file.  

2 To import a CAD model from a file:  
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3 Open a new or existing part file. You must have a part open to import 

geometry.  

4  If you want to set or change the import options, select File > Import/Export 
Options.  

5 Select File > Import from the menu. The Import dialog is displayed.  

6 Select the file you want to import, and click Open.  

7 A message asks if you want to review the log file: click Yes to display the 
results, or click No to continue. The Import Results wizard is displayed.  

8 Follow the instruction in the wizard to complete the process.  

 

 Unless you have specifically ordered the FeatureCAM .step or Stp 
file import, you might get an error to say that this option needs to 
be licenced.  

 If this is the case then use the Import using exhange where the 
.step file import option is free. 

 Wherever possible avoid importing .iges files as these are surfaces. 

 Please import solid models, where possible. The best option is 
Parasolid which has a file extension of x_t or x_b which is a binary 
file which is compressed. Another file format is .SLDPRT which is a 
solidworks file. 
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FeatureCAM Basic Turning 

Introduction   

 Double click on the FeatureCAM Icon  this will start 

FeatureCAM and allows you to create a new Part document. 

 
 

 

 

 In this FeatureTurn module the user will learn basic 2-axis  

 X and Z turning, boring, and grooving along with the basic user 

interface and different stock types.  At the end of the module the user 

will be able to generate a program for a simple 2 axis part.  

 This chapter will show the user the basic steps required to create a 

finished FeatureTURN Part. The following Tutorial is designed for 

Metric use.  
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Creating a New Turn/Mill Part Document 

 Open a New file> Turn/Mill Part Document, the following menu will 

appear. Select Next. 
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1 Select Finish. 

2 For your Stock enter Length 250mm and OD 105mm then Select Finish. 

 

3 We need to set excess stock at the front of the part after selecting 

Finish you will be presented with another form. See the image below. 
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4 Enter 1mm in Z as shown in the menu on the previous page. This will 

now set the Z Setup1 as shown below. 

 

5 Hide stock by selecting the Stock1 in PartView and Right click – 

Select Hide Stock. 

6 In the Z Offset enter -1mm this will move the Offset 1mm to the 

left of the material face leaving stock to be turned off later. 

Basic Turning Exercise  

1 Before we start please select Options/File Options/Existing Files. 

2 Select Browse. Then select the following location. 

C:\Training_Data\FeatureCAM Course Data 2017. 

3 Select Apply. When we save or import files FeatureCAM will take us to this 

location. 

4 Please save all files in Coursework. 

5 Tool Crib = Training_Crib_Metric. 

6 Post processor used = Fanuc21i-T.cnc 

 The part we are going to machine is shown below. 
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 The example shown is a simple turned part designed to introduce you 

to several of the drawing and machining tools available in 

FeatureTURN.  The tutorial walks you through creating the part and 

introduces you to FeatureTURN's automation and ease of use. 

 For this exercise the ID, OD and Face grooves do not have to be 

defined by creating geometry, these features will be created 

automatically later by creating Groove features from dimensions. 

Radius (RZ) 

 

Diameter (DZ) 
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7 Setup1 – Spindle Location, the Main Spindle will always be selected when 

there is no Sub Spindle being used.  

8 Select Main Spindle 

 A sub spindle is a second spindle at the tailstock end of the 

machine opposing the main spindle and used to run the 

second side of the part. Machine dependant. 

9 Select Finish. 

Turning Input Modes 

 Before we start to create out geometry we need to select 

Options>Turning input modes and select the following Radius 

(RZ) or Diameter (DZ) input modes. Our drawing is dimensioned in 

Radius (RZ) and Diameter (DZ) values. You choose your preferred 

values. 
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Geometry Creation Techniques 

 Radius (RZ) 

 

 Diameter (DZ) 
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 There are many ways to draw this job but the following method is by 

far the easiest. We are going to use Diameter values. 

10 From Geometry Tool Bar. Select Line Horizontal as shown. 

 

11 Input the following diameter Values 32mm, 50mm, 100mm. 

12 Then Select the Line vertical and input the following values 

 

13 0, -88mm, -94mm, -127mm. 

14 Clip  the surrounding lines as shown. 

 

15 Now Clip the unwanted geometry as shown on the next page. 
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16 Now add the Chamfers by using the Chamfer command. 

 

17 The large chamfer is 6mm x 6mm all other chamfers are 2mm x 2mm. We have 

one more item to change. 

 We need to extend the OD (Outside Diameter) to allow the Cut-Off 

tool to start at the correct diameter. 

18 To do this, select a Line from two points from the Geometry menu. Snap to 

the chamfer as shown. 

 

19 We now need to type in a few values as shown. Use the Tab key to move to the 

next field and type in an Angle of 180 and a length of 10mm 



              
 

                    FeatureCAM Basic Turning        

 

                                                                                                                                      
                                                                                                              

 Autodesk FeatureCAM 2017   

2.12                                                                                                                 © Copyright 2016 Autodesk, Inc. All rights reserved 

 

20 That is it the Geometry is now complete as shown. 

 

Curve Creation 

21 Select Pick Pieces from the Geometry Toolbar.  

22 Select the Pick Pieces Icon  Click on locations 1, 2, as shown in the image 

below. Each line segment will change colour when it is selected.  Name this curve 

"od profile" and press the ENTER key. Chain the Bore ID curve by clicking on 

locations 3 and 4.  Label it "bore profile" and press the ENTER key. Your 

drawing should look like the one on the next page. 

 

 Remember Curves are Blue and Geometry is Black. 

 



 
 
FeatureCAM Basic Turning 

                           

 

      
Autodesk FeatureCAM 2017    

© Copyright 2016 Autodesk, Inc. All rights reserved           2.13 

 

23 You should now have two Curves that will be shown in the Part View. 

24 There is no need to create the ID, OD and Face grooves in the 

geometry as we will use Feature from dimensions from the New 

Feature menu. 

 

 To have a more inclusive visual experience we are now going 

to import a solid chuck that gives a more realistic view when 

turning our part. 

1 Please Select Import from the File menu. The file required is called Chuck.x_t 

this file is located in C:\ Training_Data\FeatureCAM Course data 

2017\Turning files to import. 
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2 Please cancel the import wizard. 

3 In PartView please select all solids by using group select and right click on 

the solids, from the menu select Use Solids as Clamps. This will then allow you 

to visualise the chuck when you run the 3D Simulation. 

Creating a Face Feature 

 Select Features  from the Steps menu. 

 Select Ctrl + R New Feature. 

 Select Construct>New Feature. 

 Select New Feature from the Advanced Toolbar. 

 

4 Select Turning.  
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5 Select Next. 

6 FeatureCAM will show the following menu. Select Face from Dimensions. 
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7 Select Next. 

8 The following menu will appear. 

 

9 Negative is towards the chuck and Positive is away from the 

chuck. 

10 Thickness is the amount of material that FeatureCAM will machine 

away. 
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11 Select Next. The following menu will appear. 

 

12 Where do you want the Face to be located? Leave this at zero. 

13 Select Next. The menu is shown on the next page. 

14 Rough Pass is an option if you have a lot of material to turn away. 
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15 Notice that we have the ability to use Canned Cycles. The canned 

cycle will be output through the post. (If supported) This gives greater 

flexibility to the operator. He can then change this on the machine 

instead of having to go to the FeatureCAM programmer (Production 

Engineer) and re-output the code. A start point is required. This is 

explained later on in the chapter. 
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 If you have excess stock on the front face, select the Rough pass 

option in the menu. If you do so, you will have the ability to have 

separate roughing and finishing tools that can be separated in the 

operations list. 

16 Select Next twice. 

17 New Feature – Default Tool. You can select the default tool or 

search the tool database for a more suitable tool. See menu below. 
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18 Select Next twice. 

19 New Feature – Feeds/Speeds. This menu gives the ability to 

change the feeds and speeds etc. 

 

20 Select Next. 
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21 New Feature – Tool Usage. This menu allows you to select what 

coolant type also Turret type etc. Select Next for a summary of all 

the options. 

 

 

22 Select Finish to accept the default values for the rest of the dialog 

boxes.  Face will be the first operation. 
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23 Select the 3D Simulation Icon  and then the Play button.  

 

24 Select the Eject  button to return to the drawing view. 
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Creating a Turn Feature 

25 Select Ctrl + R or select Steps and Features to access the New 

Feature menu.  

26 Select Turning Select Next, Select Turn. 

 

27 Select Next and the following form will appear. 
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28 You can now pick the curve graphically. Click on the curve you have 

named “od profile” earlier.  Since this pick could be either the curve 

or the line you may see the Select dialog box.  This box helps to clarify 

a pick.  In this case, select “od profile” from the list and click OK and 

then select Next in the New Feature – Curve dialog box. Accept the 

default strategy settings by selecting Finish. 

 

29 We can now automatically Fillet external or internal sharp corners. For 

internal bore fillet corners use (Other side) 

30 Run the 3D simulation as shown.  
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31 Select the Eject  button to return to the drawing view. 

Multi –Turret options. 

Customers that have multi - turret machines can use the options of Pinch 

turning and Follow turning. These option are quick and easy to select. 
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Creating a Bore Feature 

32 Select New Feature or Ctrl+R. 

33 Select a Bore feature from curve, use the curve you named 

“idcurve”.    

 With this option we have the ability to specify a pre-drilled hole. 

This then created a drill cycle and inserts this before the boring bar. 

 

34 Select Next. 
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35 Select Next twice. 

 



              
 

                    FeatureCAM Basic Turning        

 

                                                                                                                                      
                                                                                                              

 Autodesk FeatureCAM 2017   

2.28                                                                                                                 © Copyright 2016 Autodesk, Inc. All rights reserved 

 

 Towards spindle machining is normal convention when turning 

towards the Chuck. The pre-drill diameter is 30mm which leaves 1mm 

each side to finish of the bore using a boring bar. 

36 Select Next. 
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37 Select Finish. 

 

38 Before we close this menu we can look at the bore operation in 

Single step mode. Select Preview as shown in the above menu. 

39 Have a look at the Simulation Menu. We have the following options. 

 Preview menu 

 Play selected. 

 Fast forward to End Selected. 

 Single Step selected. 

 Play to Next operation selected. 

40 Select single step mode and see the boring bar start from the middle. 

41 This will potentially crash the boring bar into the part. (Depending on 

the size of the boring bar). 

42 Double click on Bore1 in PartView. 

43 Select Rough. Select Boring. 

44 Select Min radius boundary. Enter 15 

45 Preview the changes you have just made. 

46 Select Esc to close the Preview Simulation. 
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Creating a Groove Feature 

47 Select New Feature or Ctrl+R. 

48 Select the Groove radio button in the From Dimensions group. 
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49 Select Next. 

50 On the Dimensions page set Location to ID, Orientation to X-axis, 

and Diameter to 32mm, and Depth to 3mm, and Width to 6mm. 

Chamfer settings at 0.5mm.  

 

51 Click Next and set Z-56mm. Click Finish. 
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52 Select Finish. We will now create a Face Groove. 

 

53 Select Ctrl+R New Feature, then select Turning and then Next. We need to 

select the Groove radio button in the From Dimensions group. On the 

Dimensions page set Location to OD, Orientation to Face, Diameter to 88mm, 

Depth to 3mm, and Width to 6 mm. Chamfer settings at 0.5mm. Click Next. 

The Groove is located at Z-88mm. 
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54 Select Next. Then enter a position of -88mm. Then select Finish. 
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Run a 3D Simulation to see the results below. 

 

 

 

 To View the simulation in a ¾ view select 

Options>Simulation>Round Stock – ¾ View with lathe ID 

work. 

 See image on next page. 
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Creating a Thread Feature 

55 Select Ctrl+R (New Feature) select Turning then the Thread 

radio button in the From Dimensions groups. 
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56 On the Dimension page, select Standard thread, click OD and select 

the M50-1.5 thread. Select Next.   

 

57 Location is at zero. Select Next twice. 

58 By default FeatureCAM will create a relief groove. Change the 

depth to 3mm and then change the number of passes to 5. 
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59 Select Finish. 

 

60 Run the 3D simulation as shown.  

 

 

61 Remember to select the Eject  button to clear the screen.   

62 Select Ctrl+R New Feature and select Turning. Select Cutoff.  
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63 On the Dimensions page set Chamfer to 2 then set Diameter to 

100mm and Inner Diameter to 0 and Width to 3.0 

 

64 Select Next and set Z-127mm. Select Finish. 
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65 Select Finish. Run a 3D Simulation  
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Results 

 

 NC Code can only be output after a complete simulation has 

been performed. If any errors are found. The Simulation will 

not continue. 

 The sample part is complete.  View the 2D Centreline 

Simulation followed by a 3D simulation to view the 

finished part.  

2D Simulation 
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3D Simulation 

 

Rapid moves to home position 
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Part View All Operations 
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 To output the code to your CNC machine follow these steps. 

1 Run the 3D Simulation to check for errors etc. 

2 From the File menu select SaveNC. 
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NC Code output example 
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Part Documentation 

FeatureTURN will automatically generate a Manufacturing Operation sheet and 

a Tool list.  The Manufacturing Operation sheet appears by default in the Results 

window.  It contains information such as machining time, tools selected, feeds 

and speeds, and horsepower requirements for the various operations.  A Tool 

list is also created that gives all the specification and slot assignments for the 

tools used to manufacture your part.   

1 Click on the Details tab at the bottom of the Results window.  Each operation of 

the process plan is listed in order.   

2 Click on the Tool List radio button at the top of the Details tab.  Now the tool 

list is presented in the Results window.  This document provides a summary of 

all the tools required for the job as well as details of each tool.   

3 You can print this documentation by selecting Print from the File menu.  NC Code 

4 After you have simulated the part, you can generate NC code. FeatureTURN 

comes with many post processors and the ability to create custom post 

processors as well. 

5 Before you can generate NC code for a part, you have to run a Simulation to 

calculate toolpaths. Simulate your part now. 

6 Click the NC code step  in the Steps toolbar.    

7 Click the Display the NC code  button in the dialog box to generate.  

 NC code. 

Changing Post Processors and Saving NC Code  

1 If you are running FeatureTURN, the default post processor is for a Bridgeport 

machine. Follow the remaining steps to change your post processor and save 

the NC code. 

2 From the Manufacturing menu, select Post Processor. 

3 Click Browse to view the post processors. 

4 The default directory is C:\Program Files\FeatureCAM\T-library\Metric or Inch. 

Select your processor and click Open. Click OK in the Post Options dialog box. 

Your processor is now selected. Run a simulation of the part to regenerate the 

NC code. 
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5 Clicking Close will not change your post processor.  

6 Click the NC code step  in the Steps toolbar.   

7  Click the Save NC button  from the dialog box. 

8 Accept the default filename and directory and click OK. 

9 Load your file onto your cnc machine via RS232 or Memory stick.   

10 You are ready to machine the part. 

11 Save the FeatureTURN Part 

12 Select the Save button  from the Standard toolbar.   

13 Select the directory and then type your part name and click OK.   

Tool Mapping 

 You can open the Tool Mapping dialog in one of these ways:  

14 Select Manufacturing > Tool Mapping from the menu.  

15 Click NC Code  in the Steps panel, then click Re-map the tools to new tool 

slots in the NC Code dialog.  
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 The Tool Mapping dialog is where you change the tool slot assigned to the 

selected tool. You can change the Cutter comp. offset register for any tool 

here too.  

 The dialog has a table at the top. Each row of the table represents a tool. 

Select a tool to edit its values in the fields below the table.  

 Double-click on a tool name, or click the + to the left of the tool name to 

see the list of operations that use that tool.  

 Click the Add tool slots  button at the top left of the table to open 

the Number of tool slots dialog. It enables you to increase the number of 

tool slots listed; you cannot reduce this number.  
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 Tool number -This corresponds to the first (grey) column in the table and 

is the current tool slot number for that tool. To move a tool to a different 

position, enter a new Tool number and click the Set button, or drag-and-

drop the name of the tool in the table onto the tool slot number in the left 

column. More than one turning tool can occupy the same tool slot. 

 Diameter offset register - Specifies the diameter cutter compensation 

offset register number for the tool. This value is passed to XBUILD as 

<COMP-NUM>. It corresponds to the Diameter column in the Tool 

Mapping table. Enter up to 8 digits.  

 Length offset register - Specifies the tool length offset register number. 

Most lathe controllers have a single register that contains the length and 

diameter offset values. In this case, the Length offset register is the 

important field to set in FeatureCAM. This value is passed to XBUILD as 

<OFFSET#>. It corresponds to the Length column in the Tool Mapping 

table. Enter up to 8 digits.  

 To set the Diameter offset register and the Length offset register by 

operation, select the operation in the table. You may need to expand the 

tool name to view the operation.  

 Most lathe controllers have a single register that contains the length and 

diameter offset values. In this case, the Length offset register number 

is the important field to set in FeatureCAM.  

 Tool ID - This corresponds to the ID column in the table and is the tool ID 

register for the tool. This is a seldom-used field that is used by Bridgeport 

lathes and occasionally for Cincinnati machines.  

 The Tool Mapping dialog has these buttons:  

 Same - This sets the cutter comp. offset registers for all tools to the value 

of their tool slot number.  

 Set - Select a tool in the table, enter a Tool number and click the Set 

button to assign this tool a number specific for this part.  

 This assignment is for the current part only. If you want to assign a tool to 

a default tool slot for all parts, use the Overrides tab of the Tool 

Properties dialog.  

 Save in Crib - This permanently assigns the tool number with the tool in 

the database. The tool is then locked in this position for all parts that use 

the tool.  

 Clear in Crib - The tool number slot for the selected crib is erased. This 

means you want FeatureCAM to assign a tool number automatically.   

 Set All - All tools numbers are set to their current values and are not 

changed.  

 Reset All - This returns all tool slot numbers and cutter comp offset 

registers to their initial values.  

 Select Block - Click this button to display the Tool Block Selection, which 

you can use to specify which tool block is used to hold the selected tool.  
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 Tool Life - Tool life management enables you to limit the use of a tool and 

automatically switch to another tool when that limit is reached. It is useful 

when cutting hard material that may wear out a tool during a single program 

run. The table in the Tool Mapping dialog displays the number of Holes 

that are cut by each drilling tool and the Time (number of minutes) that 

each milling tool is used during a single run of the NC program. Select a tool 

in the table and click the Tool Life button to open the Tool Life dialog.  

 This button is not available until after you have run a simulation.  

Tool Numbering 

FeatureCAM automatically selects tools from the active tool crib. These tools are assigned 

a tool number (also referred to as a tool slot or tool pocket) for an automatic tool changer. 

The numbering is assigned according to these rules:  

16 Use the number assigned in the Tool Mapping dialog.  

17 This numbering is in effect for the current part only.  

18 If no number has been assigned via tool mapping, then the number assigned to 

the tool in the crib (the Tool number field for milling tools or the Tool slot for 

turning tools), is used as the tool number. If two tools have the same permanent 

number in the crib, the first tool used is assigned the pre-set number and the 

other tool is given a new number.  

19 If no number has been assigned via tool mapping or in the crib, FeatureCAM 

assigns a tool number.  

Custom Setup Sheet Add-In 

You can create custom setup sheets for milling, turning, and turn/mill parts using the 

SetupSheet.dll add-in.  

The add-in extracts information from the Part Documentation dialog and enables you to 

take images for each Setup.  

You can use setup sheets to give information to the machine operator about the 

manufacturing, tooling, and toolpaths of a part.  

20 To load and run the add-in:  

21 Select Options > Add-Ins from the menu. The Macro Add-ins dialog is 

displayed.  

 



              
 

                    FeatureCAM Basic Turning        

 

                                                                                                                                      
                                                                                                              

 Autodesk FeatureCAM 2017   

2.50                                                                                                                 © Copyright 2016 Autodesk, Inc. All rights reserved 

 

22 Click the Browse  button and browse to the SetupSheet.dll file. If you 

installed FeatureCAM in the default location, the file is at 

C:\ProgramFiles\Autodesk\FeatureCAM\Addins\SetupSheet\SetupShe

et.dll.  

23 In the Macro Add-ins dialog, in the Add-In Files list, ensure that the check box to 

the left of the SetupSheet.dll file address is selected.  

24 Click OK. The Utilities toolbar is displayed, containing the SetupSheet button 

 

25 Click the SetupSheet button to run the add-in. The Setup Sheet Options dialog is 

displayed: 

26 Remember to set the Part Document information in File>Part Documentation. 

27 The Title, Author, Note 1, Note 2, Company, Part/Drawing No., Revision, and 

Comments values are copied from the Documentation tab of the Part 

Documentation dialog and you can edit them there.  
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28 Select Ok to close the dialog. 

29 Click OK. The Utilities toolbar is displayed, containing the SetupSheet button 

 

30 You can use this dialog to capture an image for each Setup in the current 

document, as well as an image to represent the whole document.  

31 To capture an image for a Setup, select the Setup name in the Setups list and 

click the Capture Setup Image button to capture the current contents of the 

graphics window.  
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 First run a simulation only for the Setup you want to capture by 

deselecting other Setups in the Part View; then adjust the view to 

show a good orientation of the Setup, and open the Setup Sheet 

Options dialog to capture the image in the graphics window.  

 You must use a template to create the setup sheets. Click the Browse 

Template button to find and set the template you want to use. There 

is a template, SetupSheetTemplate.html, in the Addins\SetupSheet 

folder. 

32 To create the setup sheets, click the Create Setup Sheets button. The 

part is simulated to generate toolpaths and the setup sheet is displayed 

in your web browser. You can save the HTML file from your browser.  

33 To open the setup sheet in the FeatureCAM Browser, select File > 

Open from the menu and browse to the setup sheet HTML file. 
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 Save your File and then close this document. 

Exercise 2  

The first exercise is now complete. Please select New file to 

create a new document. Select Next and then Turn/Mill. Select 

Finish. 

 
 

1 Cancel the Stock Wizard. 

2 Import – Turning Example 2.dxf select Open to import the file into 

FeatureTURN. (Class Exercise) 
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3 We are going to use the RealDWG Library file (see below) 

 

4 Select OK to action this command. 

 

5 Use the Wizard to establish the Stock Size and Setup1 position. 

 

6 Keep selecting Next until you get to the Stock Dimensions. 

7 Remember to use the option Compute stock size from the size of the part. 
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8 All we are going to use is Front 1 Back and OD are set to Zero. 

 

9 Select Finish. 

 

 The main reason for machining this part is to create 3 different 

machining methods for machining the same groove. We will be 

starting with Normal turning and back turning. Followed by Cut-

Grip and then for the last groove we will be using a more traditional 

machining strategy with conventional grooving. All 3 methods will 

produce the same result. When you are back at work you will use the 

machining strategy that suits your company. 
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 To chain your geometry pick each element in turn, after you have 

made your selection press the Create key so all of the elements will 

be joined together. Each selection will be given a unique name. If you 

select the wrong geometry, select Clear pieces and then reselect the 

elements again. 

 

 

10 On the illustration above, the Curves shown are the OD Curve, First 

Groove, Second Groove, and Third Groove. 

Turn Feature  

11 Cancel this command by pressing ESC. 

12 Hide the Geometry by selecting View>Hide>Hide all Geometry. 

13 Select Ctrl+R New Feature Select Turning, select next, select 

Face Select Finish. 

14 Select Ctrl+R New Feature and select Turning> Turn select next 

then select odcurve from the New Feature Curve menu. Select 

Finish. 

 New to FeatureCAM we can automatically Fillet external or internal 

sharp corners. For internal bore fillet corners use Other side. 
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 In the Properties, please select Rough and then the Tools tab. This is 

a listing of the tool that FeatureCAM picked as a default tool with a (D) 

Default in the check box and other tools that may be chosen to replace 

the 80 degree tool. 

 

 Typical inscribed circle diameters 9.52, 12.7, 15.88,19.05 

 

 The CNMG 80 degree diamond tool may be the most used style in 

the industry today.  It is strong and allows for turning and facing with 

the same tool because of the 5 degree relief on two sides of the insert. 
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 For the next operation we are going to machine the first groove using 

a turning operation and then create a back turning operation to finish 

the groove. 
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15 Create a new feature. Select Ctrl+R and select Turning and then 

Turn. Select Next. 

16 Select the first groove curve. Then select Finish. 

 

 In this case by introducing the undercut in the turning operation this 

tool is unable to even finish one end of the undercut.   

 

 FeatureCAM defaults to an 80 degree diamond insert tool.  A very 

common turning tool but in this case with the undercut in the OD. 

You can see that the integrity of the shape (curve) that you are 

cutting is protected so that the trailing side of the tool does not gouge 

the undercut.  FeatureCAM will cut as much as it can though.   
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 FeatureCAM allows for alternative tools to be selected from the tool 

crib so we can replace the 80 degree tool with a tool with more relief 

on the back side and this can be done on the fly as you create the 

feature.  We will exchange this tool for a 35 degree tool with much 

more clearance. 

17 First, in the Orientation box the tool is described as SW or South West. 

This is the orientation of the current tool and will be the same for the 

replacement. 

18 Drop the menu down in the Insert Shape box and select 35 Diamond. 

19 The presentation angle will remain the same.   

20 When you Clicked on the 35 Diamond, FeatureCAM shows you the 

35 Diamond tools but this does not select one, you must do that 

manually. 

21 Click on each tool description until you find the right tool displayed for 

the application. You must check the box to the left  of the tool to 

select the new tool. 

 

 The check in the box means the Default tool has been over ridden.  

FeatureCAM will change the finishing tool as well.  

22 Run the 3D Simulation.  It is readily visible that you can cut much 

more of the undercut now. 
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 You will notice that when FeatureCAM starts it cuts fresh air at the 

start.  

23 To change this Eject the simulation. Then double click on turn2 in 

PartView. Select Rough>Turning. Change the Max radius 

boundary to 62.5mm. Then select Set and Apply to action the new 

values. 

 The material in the corner on the right side of the undercut needs 

to be removed to finish the OD of the part. 

24 Create a copy of the first groove Feature in PartView. We need to 

change the Rough and Finish to cut in a Toward Face direction, away 

from the main spindle. 
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 By creating a copy of the original Feature the tooling and maximum 

radius boundary will be maintained. 

 Double click on the copy of the groove feature in PartView 

 

25 Double click on the Rough Operation. Then select Turning. The 

following menu will appear. Select boundary (Spindle side) and 

change this to -73mm. 
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26 Click on boundary (Spindle side) = and either Click on the Arrow 

next to the New Value box at the bottom and then click the location on 

the part in the Graphics Window where you want the finish cut to start 

or enter a dimension using a negative number measuring from the Left 

end of the Curve for example -73mm. The finishing tool will then start 

in that location and blend to the previous finish cut. 

 

 Boundary (Spindle side) as shown above. Select Apply and 

Finish. 

27 You may wish to set the Right boundary position. Activate the same 

menu again and set a value into the Boundary (face side) position. 

This will limit the amount the tool has to travel. 

28  Run 3D Simulation to see results. 
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 Special note: - Make sure you have selected the following option in 

your Machine Configuration. 

 

Cut-Grip 

 Cut-Grip is a specially designed strategy for turning (also grooving) 

and looks much like a standard grooving tool but because of the 

geometry of the insert and the design of the holder it can cut parallel 

to the Z axis almost as fast as a standard turning tool.  In large 

quantity production machining, speed is of the essence and the Cut-

Grip toolpath that FeatureCAM provides is a Zigzag cut, feeding 

toward the chuck and the Next pass feeds away from the chuck 

without retracting and starting at the end every time.  It also finishes 

the undercut without changing tools and having to perform a back 

turning feature, again saving time.  A standard grooving tool may be 

used in a Turn feature but does not Zigzag and is designated in the 

Tool Properties, Insert tab.  
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Second groove Feature using Cut-Grip 

29 The Next feature to consider is Cut-Grip.  Click on New Feature and 

select Turn from Curve. 

 

30 Select Next. 
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31 Select second groove. Your Curve may have a different name. 

32 Select Next. Accept the location. 

 

33 Select Next. 

34 New Feature Strategies 
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35 Select Cut-Grip then select Finish. 

36 Select Rough and Turning 

37 Select Maximum Radius Boundary and pick X location or enter 

62.5mm into the New value field. 

 

38 Pick Boundary edge. 

 

 Make sure you’re snapping Toolbar is active and snap to object is 

highlighted. 
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39 The Boundary is now adjusted to 62.5mm Radius 125mm Diameter. 

40 Shown below is the Boundary Adjusted. 

 

 The Cut-Grip groove is finished. You will need to adjust the 

deflection, click on the finish toolpath and adjust the value to 0 (See 

image on the next page) remember to select set to update the value. 

 

41 Cut-Grip is now completed 
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Groove from Curve 

 The third and last groove will be roughed and finished using a grooving 

strategy. This is probably one of the most commonly used strategies 

for removing material from a groove feature. 

42 Eject the Simulation. 

43 Click on New Feature and select Groove from Curve. Select Next. 

44 Select the Third Groove Curve. 

45 On the New Feature – Dimension menu make sure you select X-axis. 

46 Select Finish. Please select the strategy page. 

 

 The Negative option allows the tool to start from Right to left. 

Depth first allows the tool to plunge to full depth allowing for any 

corner rads and finishing allowances. Plunge centre first allows the 

tool to start from the middle and work out. Positive allows the tool 

to start from Left to right. Width first splits the cuts into two, still 

allowing for a finish allowance. 

 The part is now complete see image on the next page. 

 

Face Boring 

Face Boring is a series of facing moves from inside the drilled hole cutting 

parallel to X in a positive direction. 

Offset Boring 

Offset boring offsets the curve shape to the beginning of the cut.  Mostly 

used for a casting that has a similar shape to the finished curve. 

Boring below Centreline 

When boring below centreline, though possible in FeatureCAM, the boring bar 

must be inverted and mounted on the turret so the machine doesn’t exceed the 

travel limits in the X negative direction.   
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Boring with Canned Cycles 

Canned cycles can be generated in the NC code for nearly every turned 

feature. To generate these macros, your post processor must support them, 

and you must turn this function on for the post and for some features you must 

also activate the canned cycles on the feature level. 

Reuse path in canned cycle outputs the path geometry only once for both 

roughing and finishing.  

Tool Nose Radius Compensation 

Tool nose radius compensation ignores the tool radius when generating 

semi-finishing and finishing passes for turn, bore and facing features. The actual 

part geometry is output as the toolpath. It is assumed that the tool radius 

compensation will be performed by the operator at the machine tool when Tool 

nose radius compensation is activated. 

Back Face Boring 

Back face boring is usually used when a previous boring operation couldn’t 

clean up all of the material because of an undercut.  A special bar must be used 

specifically designed to cut with relief on the face. Moves are parallel to X 

positive. 

 

Back Boring 

Back Boring cuts parallel to the Z and is performed using a positive direction in 

Strategies. 
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Boring with a groove tool 

When there is an undercut in the bore, a groove tool can be used.  If Cut-Grip 

is checked in the tools properties on the Insert tab the tool path will be a zigzag 

motion, alternating negative and positive directions parallel to the Z.  If the box 

is not checked it will be all negative or all positive cuts according to the settings 

in the Strategies. 

 

Turning Exercise 3  

 

 

1 Open a New Turn Part Document. 

2 Round Stock.  OD 150mm, Length 175mm, ID 25mm Z Stock 1mm   
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3 Select Next. 

4 Select Stainless-304L Material. Select Next. 

5 No Multi-Axis. Select Next twice. 

6 Setup, Use current location. Select Next. 

7 Main Spindle.  Select Next.  

8 Select Finish. 
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Exercise 3 in detail 

9 Draw the part shown on the previous page using geometry 

constructors and then chain curves. 

 Remember that the geometry only needs to be drawn 

above the centreline 

10 Select New Feature or CTRL + R and select Face. Select Finish. 

11 Select New Feature or CTRL + R and select Turn from curve. 

12 Select Next, Select the curve then select Finish. 

 

Turning Properties – Rough - Turning 

 The cuts are straight but move up the face to remove the scallops left by 

the angle of the tool. 

 Depth of cut can be specified as a default in the attributes or click on the 

feature to open the properties.  Then click on rough>turning and select 

Depth of Cut.  It defaults to 5mm but may be changed by clicking on Depth 

of Cut>New Value at the bottom and entering the new depth and then 

click Set. 

 Constant Depth of Cut (DOC) The roughing operation leaves the specified 

finish allowance on all diameters but sometimes that makes some passes 

come between the 5mm depths.  FeatureCAM must cut each diameter to 

satisfy the leave allowance but the depth of cut might be less than 5mm.  It 

makes this pass but starts at the end of the part when it only needs to cut 

a short distance on the affected diameter.  It may also take extra full length 

cuts. 
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 Constant depth of cut always cuts at 5mm for the full length of the part 

and only cuts the affected diameters surface to the finish allowance when 

necessary and is a shorter cut.  This will reduce the number of full length 

passes reducing cycle time.  

 Skip Wall Pass moves the tool up each face that it cuts to smooth the face 

and can be turned off by checking the Skip Wall Pass box in the Turn Tab 

located on the right side. 

 Clearance is the distance from the part that the tool rapids too off the 

material and then goes into feed rate. 

 End Point is a specified location (vector) that the tool can be directed to 

retract to when operation is completed. 

 Max Radius Boundary is used to restrict the tool from starting the 

cuts from the stock boundary in the event the material has already been 

removed.      

 Priority can be used to set the order in which feature operations are 

executed.  You should use this sparingly because it can affect the ordering 

that FeatureCAM does automatically. 

 Start Point allows you to select a location for the tool to rapid too other 

than the normal clearance location it then rapids to the clearance location 

from the Start Point. Another selection associated with start point is feed 

from Start; the tool then feeds to the clearance location.  An example is 

when supporting with a tail stock, you might choose to rapid away from the 

tailstock and feed to the clearance to control its approach. 

 Withdraw Angle controls the angle at which the tool retracts at the end 

of the cut. 

 Withdraw Length controls the length that the tool retracts at the end of 

the cut. 

 X Finish Allowance is the amount of material left on the diameter by the 

rough tool to be removed by the finish tool. 

 Z Finish Allowance is the amount of material left on the face by the rough 

tool to be removed by the finish tool. 

 Auto Round simply rolls the tool around any sharp corner to remove the 

sharp edge.  If there is any radius at the corner then Auto Round is not 

active. 

 Post Variables can pass information directly to the NC code from the 

feature but the post processor must be setup for variables.  

Face Turning 

 Face turning roughs the part in facing moves starting from the outside 

and cuts toward the curve in the negative X axis direction instead of 

turning parallel to the Z axis.  If the last face does not go to the stock 

boundary in X you may need to use the Max Radius Boundary set to 

the stock diameter dimension to make the tool start outside the stock. 

 You may need to extend the geometry past the largest diameter 

above the stock and create your Curve from this. See example below. 
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 Offset Turning uses the shape of the curve and offsets it to the end 

of the part for the tool to follow.  It begins to cut the shape of the 

curve on the first pass and cuts parallel until finished.  Good for 

castings.    

 

Stock Curve 

 A stock curve can be used to represent a specific shape of the stock 

rather than bar stock.  An example is when a forging or casting is 

used for the stock.  The shape of the material is near the finished part 

shape with enough extra material to be turned down to the finish part 

size and shape. 

 To draw a stock shape and then chain a curve, hide all features, 

curves and stock.  Draw a horizontal line at 25mm diameter 
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 Offset all geometry by 6mm as illustrated on the next page. 

 

 Click on Stock in Part View then on the Dimension tab click on 

Stock Curve button and select the curve you have just created.  The 

stock now takes the shape of this curve and FeatureCAM recognizes 

this as the stock boundary instead of the bar stock and will rapid to 

the clearance distance and not cut fresh air.  Previous toolpath 

strategies apply. 
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Turning Setups Explained 

 Turning Setup: - for 2-axis turned parts. Your part can contain 

multiple setups and these setups can mix different manufacturing 

techniques. Adding setups to parts lets you work in different 

orientations on the same part. Or, if you have two parts that share 

most of the same design, you could create the common features in 

one setup, and the other different features in two other setups. Then, 

depending which setups you include in the plan and manufacture, you 

can have two parts with only slightly more work than one part. The 

description that follows is for information only. 

How do setups relate to UCSs? 

A User Coordinate System (UCS) is an origin and three vectors (X, Y, and Z) 

that determine a position and orientation in three-dimensional space. You can 

use multiple USC’s on a turned part to model the features to manufacture your 

part. 

UCS      Setup 

     

 One UCS is associated with a setup. A setup is an orientation and part 

program zero for a physical setup on the machine tool. The 

orientation and program zero are determined by the associated UCS 

and the setup contains additional information like the fixture ID and 

the name of the NC program that will be generated. 

 If setups are created directly by aligning with the stock, special UCSs 

are created with the string UCS appended to the setup name. For 

example a UCS called UCS_setup2 is automatically created for 

Setup2. These UCSs are used to store the location/orientation 

information for the setup. They cannot be deleted as long as their 

setup exists. 

Setups dialog 

 You use the Setups dialog to set the active setup, create new 

setups and edit existing setups. 

 You access the Setups dialog in one of these ways: 

 Select Manufacturing > Setups from the menu 
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 Click the Setups button  on the far right of the Advanced toolbar 

 

 To create a New setup click the New button and follow the steps in 

the wizard. 

 To edit an existing setup select it as the Current Setup and click 

the Edit button to open the Setups - Definition dialog. 

 To set active setup select the setup name from the Current Setup 

list and click the Close button. 

 You can also set or change the active setup in the Status 

bar. Click the existing setup name and select a different setup 

from the context menu. 

 

  



              
 

                    FeatureCAM Basic Turning        

 

                                                                                                                                      
                                                                                                              

 Autodesk FeatureCAM 2017   

2.82                                                                                                                 © Copyright 2016 Autodesk, Inc. All rights reserved 

Setup – Definition 

The Setup-Definition page lets you name the setup and specify the fixture ID. 

Optionally enter the Setup Name. This name is used only as a label for the setup 

 Verify the Fixture ID for the setup. The default value is usually correct 

because it is taken from the current *.cnc post processor template file. If 

the default value is not correct, enter the correct value 

 Fixture IDs allow the machine to offset the fixture to correspond to 

the program zero, instead of having to move the fixture to the spot 

where the program is. For machines that use NC codes G54 - G59 or 

registers 54 - 59, the default should be 54. For machines that use 

NC codes H1 - H3, the default should be 1. 

 Optionally enter a different Part Name for the part. This defaults to the file 

name, but you may need to override this for Fanuc controls to give the part 

a numeric part name 

 Setup – Definition includes Setup Name, any name may be 

entered or use the default setting  
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A few quick notes about Part Name 

  

The Part Name are inserted in and must be what is recognized in 

the NC code (00001).  The fixture ID comes from the post 

processor and the call is applied to the NC code, such as G-54.   

Also, the Part Name is used to identify the program text file when 

you “Save NC” (Use Setup Part Name) under the File menu located 

upper left.  

Creating a new Setup2 

 To create a new Setup2 for Main or Sub Spindle follow the 

guidelines shown below. 

1 Double click on Setup1 in PartView. The following menu will appear. 

 

2 Select New. Then select Next. 
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3 Choose Align to Stock Face 

4 Select Next 
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 Choose the Left hand Icon as shown on the next image. 

 

5 Select Next. I have entered -1 to move the Setup2 into the work piece. 
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6 Select Next. 

 

 Setup – Spindle Location, the Main Spindle will always be selected 

when there is no Sub Spindle being used.  
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7 Select Main Spindle or Sub Spindle. 

 A sub spindle is a second spindle at the tailstock end of the machine 

opposing the main spindle and used to run the second side of the part), 

covered later in this module. 

Specifying the machine simulation file 

The Machine Simulation file is associated with the Setup. For files where you 

simulate multiple setups such as indexed or turn/mill parts, you should 

associate the machine file with the first setup of a part. 

 At any time, when in a FeatureCAM document and the need may arise 

to specify a machine simulation file  

 Open the Setups dialog in one of the following four ways:  

 Select Manufacturing > Setups from the menu.  

 Double-click the Setup name in the Part View.  

 Select Properties from the Setup's context menu in the Part View.  

 Double-click the Setup in the graphics window. 

 Click the Edit button. 

 Click the Next button until the Setups > Simulation Information 

dialog is displayed.  

 Enter the Z Offset parameters. These represent offsets for loading the 

part onto the machine. For simulating single turning setups these offsets 

are applied to the setup after the part is aligned with the top-most 

location. 

 In the Simulation machine design file section, select one of these 

options:  

 Always use this one - if you want to identify a specific file. Browse to 

the location of the Machine Design file. 

 Remember that the number of turrets and locations of the turrets 

must match the selected post processor. 

 Use the one specified in the .cnc file - to use the machine specified 

in the post processor *.cnc file. 

Setting up a part for multi-spindle turning 

Setups 

 You need at least two setups for multi-spindle turning, one setup for the 

main spindle and a second setup for the sub spindle. The Z axes of the two 

setups must point in opposite directions. 

  If your NC controller requires that both coordinate systems point in 

the same direction, this adjustment is made in the post processor  

 The origin of the two setups can be positioned at any convenient point on 

the part. 

 FeatureCAM automatically creates setups with non-descriptive names like 

Setup1 or Setup2.  
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 For organizational purposes, you may want to rename your 

setups with more descriptive names like Main Spindle. 

 The first setup will automatically be assigned to the main spindle. If you 

want to perform the first operations on the sub spindle, you can do either 

of the following: 

 Drag the sub spindle setup above the main spindle setup in the Part View 

panel.  

 Go to Manufacturing > Process Plan in the menu and use the arrow 

buttons to change the order of the setups in the third list. 

Associating features with setups 

 Features are associated with the current setup. For multiple turret cutting, 

the setup associated with the feature will dictate which spindle will hold the 

part while the feature is being cut. You can see what setup the feature is 

associated with by looking in the part view. 

Moving the part 

 The part must be moved between the two spindles using a collection of sub 

spindle features and perhaps bar feed features. 

Machine Simulation 

 Machine simulation shows each setup cut twice if there is a sub spindle 

move. This is to verify that we do not crash into the part once it is on the 

sub-spindle. 

Sub spindle overview 

 Sub spindles can be used to support the part from both ends of the stock, 

or to change which spindle is used to hold the stock. To cut features on two 

different ends of your stock, you must first create setups at each end of 

your part with the Z directions pointing out from the stock, as shown below. 

(If your machine requires that the Z of each setup point in the same 

direction, this can be changed in the post.) 

 

Stock held by main spindle Stock held by sub spindle 
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Sub-Spindle                                                                                     Main spindle 

Creating a Sub spindle feature 

 

 To create a sub spindle feature: Select Features in the Steps panel.  

 If you are using the Turn/mill module, first select Turning 

as the Feature type and click Next. 

 Select Sub spindle as the Feature type and click Next to open the New 

Feature - Dimensions page  
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 Select which spindle you want to control, either the Main spindle or the 

Sub spindle. 

 

 Select the action you want to perform.  

 If you selected the action as:  

 Open the spindle, optionally select Extend the part catcher before 

opening spindle and optionally enter a Dwell after opening spindle.  

 Close the spindle; optionally enter a Dwell after closing spindle.  

 Orient the spindle; enter an angle for Set spindle angle to.  

 Turn the spindle on/off, select Off, CW (Clockwise), or CCW (Counter-

Clockwise). If you are turning on the spindle, you must enter the Spindle 

speed.  

 Position the spindle, the New Feature - Location page for a sub 

spindle opens.  

 Synchronize the spindles; specify the type of synchronization to use. 

 Click Next. 
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 Click Finish. 

 

Setting up a part for multi-turret turning 

 The following issues must be considered for multi-turret turning: 

 Multi-turret machining can be performed with as few as one setup 

The post processor that is loaded while you are creating your part 

must support multiple turrets For pinch or follow turning, your post 

processor must have opposing turrets 

 For appropriate machine simulation the post processor must have the 

same turret and spindle description as the machine design file With 

the exception of automatically synchronized features, features are 

automatically associated with the first turret. To move an operation 

to another turret, you must use the Turrets tab. 
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Turning Exercise 4 Lightbulb (Class exercise) 

 

 Work through this Exercise on your own. 

 

 The images above show an outline of the geometry in Blue. 

This is not a Curve.  

 Remember to create a Curve we use pick pieces. All Curves 

for Turning are open Curves. 

Lightbulb drawing exercise in detail 

 Please note the following drawing exercise can be created in many 

different ways 

1 Open a new Turn/Mill FeatureCAM document Millimeters. 

2 Start by creating the outer edges and then create the inner features later on. 

3 Work through this on your own. Ask your Instructor for help if needed. 

4 A larger drawing image on the next page can be taken out of the folder. 

5 Machine the opposite end by creating Setup2 and choosing Main or Sub-Spindle 

options. 
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Round Insert Strategy 

Round Insert— Round tool roughing toolpaths are designed to ease the tool 

more gently into a groove shape using a Button Style insert. 

 

1 Please load file - Round Insert Strategy.fm from the folder path shown below. 

C:\Training_Data\FeatureCAM Course Data 2017\Turning 

Data .fm Files  

 This exercise shows a simple turned profile with a slight 

undercut using a button insert tool. Notice the angled lines 

to the right showing the tool entry into the groove. 
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Basic Turning Attributes / Configurations 

Introduction 

This module will provide the user with an understanding of what attributes are, 

(characteristics and features) and where they reside Also covering when an 

attribute is chosen, where it shows up in FeatureCAM, and how it affects the 

feature. 

By the end of the module the user will be able to select, prior to creating the 

program, the machining configuration of attributes, as the defaults for the 

material and/or machine to be used.  This saves time in programming by not 

having to make the same repetitive entries for the choices you wish to be 

defaults when that particular material, or machine, is chosen.  It also eliminates 

having to remember the different settings. 

Machining Configurations 

 The Machining Configurations can be accessed from the 

Manufacturing drop down menu. 

 Machining Configurations are predetermined default functions that are 

selected, and used in all features that are created in the document. 

 A Machining Configuration contains approximately 100 settings. 

 An unlimited number of Machining Configurations may be created. 

 The user can name a Configuration to reference the material and/or 

machine to be used. 

 

 “Initial Configuration for new documents”, is in the drop down menu at the 

bottom. 
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 When a Machining Configuration is selected prior to programming, the 

attributes, so to speak, rain down into the new document just opened. These 

are used as the default settings. They are divorced from the Machining 

Configurations and become Machining Attributes, assigned to, and a 

permanent part of the new document.   

 

 These settings may be changed in the document. You can click 

Manufacturing and Machining Attributes at any time. Changing any 

attributes will assign them to this document only, but does not affect the 

original, or default, Machining Configuration. 

 In other words, these changes do not become the defaults and when a new 

document is opened the old defaults are active.  These settings stay with 

the document and are active anytime this same .fm document is opened. 
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Machining Attributes 

 

Drilling Tab 

Spot drill  

This operation has some wide-ranging effects, however, especially when used 

with the Attempt chamfer w/ spot and tool optimization. Of those three settings, 

tool optimization has the highest priority and its decisions override settings with 

a lower priority.  

For example, a spot drill operation could be performed with either a spot drill 

or a centre drill. Spot drills with a tip angle of 90 can also perform a chamfering 

operation. You specify a specific tool to cut the hole's chamfer and also turn on 

Attempt Chamfer /w Spot and tool optimization. If there is an appropriate spot 

drill in the tool crib, FeatureCAM optimizes things and use this tool in spite of 

your lower priority override. Even though you selected a specific tool, your other 

settings conflicted with and superseded your choice.  
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This is the advantage of the optimization and simulation functions in 

FeatureCAM. As you work through the optimization settings, and see where you 

can optimize automatically and where you cannot, you can find ways to group 

your parts for faster production, but still use specific tools for specific effects 

when needed.  

You can set this attribute for an individual feature in the Feature Properties 

dialog. Feature-level attributes override Machining. 

Spot drill edge break — to create an edge break or chamfer using the spot 

drill tool, enter the radial distance of the edge break/chamfer. The spot drill 

creates an edge break/chamfer by cutting deeper than it normally would to 

create the spot drill operation alone. The default value 0.0050" or 0.1 mm 

results in a chamfer 0.0100" or 0.2 mm greater than the hole size. The angle 

of the chamfer depends on the spot drill tool used.  

Enable this option to try to cut the chamfer during spot drilling. If no available 

tool can spot and chamfer without gouging the hole, a separate chamfer 

operation is created.  

Spot drill diameter %: - This percentage is used to select a spot drilling tool. 

A value of 100 specifies that the spot drill should be the same diameter as the 

hole. A smaller value creates only a starter hole.  

Use L/D compensation: - This reduces speed and feed for holes that have a 

ratio of hole depth (L) to hole diameter (D) of greater than 2.5. 

The greater this ratio, the greater the speed/feed reduction.  

Max tap spindle RPM: - This is the maximum speed (in RPM) for tapping.  

Tap cycle affects how a tap operation is performed. Select from:  

Floating: - Floating and tension-compression holders  

Rigid: - This is most commonly available on current machines  

Deep Hole: - The tool pecks and retracts to the Plunge clearance and returns 

to the previous depth.  

Chip Break: - The tool stops feeding only to break the chip.  

All cycles use the same Tap program format, but logical reserved words exist 

in XBUILD to distinguish the tap type.  

Pilot diameter(s): - This enables and sets a list of drill sizes used to drill pilot 

holes. Enter a comma-separated list of drill diameters. For example, entering 

12, 25, 40 in metric, causes holes to be pilot drilled with the 12mm drill for 

final hole sizes up to 25mm. A hole in excess of 40mm is pilot-drilled with all 

three of the specified drills before being drilled to size. No list of drill sizes turns 

off pilot drilling for the feature, although this attribute can also be set up as a 

default for all parts. 
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Pecking 

Pecking applies to Deep Hole, Chip Break, and Tap operations. FeatureCAM 

supports four styles of pecking. These styles are listed in the post processor. 

Three different attributes control the pecking and they are used differently 

depending on the style of pecking. FeatureCAM checks the pecking type in the 

currently loaded post processor to duplicate canned cycles when simulating 

toolpaths. Set these attributes separately for Drilling and Tapping operations:  

 First peck: - This is the depth of the first peck of a drilling/tapping 

operation specified as a percentage of tool diameters. If the depth of the 

hole is less than First peck, the hole is drilled in a single peck.  

 Second peck: - This is the depth of the second peck of a drilling/tapping 

operation specified as a percentage of tool diameter. The post handles the 

conversion.  

 Minimum peck: - This is the minimum step size for a peck used for value 

reduction pecking methods or factor reduction pecking methods.  
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Turn/Bore tab (Turn) 

 

Rough depth of cut  

Enter a step increment for each pass that the roughing routine performs on the 

part. The interpretation of Depth of cut depends on the Constant DOC setting 

in the Turn/Bore document-level options.  

If Constant DOC is deselected, the Depth of cut value you set is the maximum 

depth of cut for the feature. If the Depth of cut evenly divides the depth of your 

feature, your increment is used. If it results in a final pass that is quite shallow, 

the Depth of cut is adjusted to result in even roughing passes. For example if 

you have a feature that is 12mm  deep and specify a Depth of cut of 4mm, the 

feature is roughed in two even passes 6mm deep instead of one pass of depth 

10mm  and another pass with depth of 2mm 
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If Constant DOC is selected, the feature is cut using this depth for each pass. 

With Constant DOC selected, you can also list a series of depths, separated by 

commas, to control the depth of each cut. For example a Depth of cut 

specified as 6mm, 4mm, 2.5mm results in the first pass being cut at 6mm, 

the second at 4mm and the remaining pass at 2.5mm. If there are more cuts 

than depths specified, the last depth is repeated.  

Engage angle  

Enter the approach angle for the tool, measured away from the part. An angle 

of 0 degrees approaches along the path. An angle of 90 approaches 

perpendicular to the path. If the beginning of a scan line begins with a shoulder, 

a value of 90 is used automatically for that scan line. The only valid values are 

0 or 90 degrees.  

The Engage angle and Withdraw angle are specified from the path (or 

extension of the path), relative to the side of the path that the tool is on, and 

the direction in which the tool is traveling. 

Withdraw length: - This is the distance along the withdraw angle line in 

which the tool withdraws before returning for the next step. 

Use Clearance as finish with draw length: - When selected, the Clearance 

value is used as the approach and withdraw length for finishing moves. When 

deselected, the Withdraw length value is used.  

Auto round  

This turning attribute applies to both rough and finish passes. When Auto 

round is enabled, FeatureCAM automatically inserts arc moves to connect two 

non-tangent elements. The effects are:  

 Minimum of wasted motion by the machine; however, the posted part 

program may be slightly longer in the number of blocks used.  

 Burrs are removed, but otherwise the part has the same shape and 

dimensions given by the feature curve because the radius of the inserted 

arc is the same as the tool nose radius.  

 Machine motion is smoother.  

This is an example with Auto round turned off: 

 

This is the same example with Auto round turned on: 
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Tool nose radius compensation  

 Enable this option to ignore the tool radius when generating passes for Turn, 

Bore, and Face features. The actual part geometry is output as the toolpath. 

It is assumed that the tool radius compensation will be performed by the 

operator at the machine tool when this option is enabled.  

 Select whether you want TNR comp for Rough, Semi-Finish, and Finish 

operations. Enter the Lead-in angle, Lead-out angle, and Lead 

distance parameters for TNR comp.  

Use canned cycle  

Enable this option to perform the feature's operations using canned cycles. You 

must use a post that has support for roughing and finishing canned cycles.  

Canned cycles can be generated in the NC code for nearly every turned feature. 

To generate these macros, your post processor must support them, and you 

must turn this function on for the post and for some features you must also 

activate the canned cycles at feature level.  

Hole features  

If Enable drilled canned cycles is deselected in the Post options dialog, then all 

hole drilling operations are computed in the post. This includes spot drilling, 

drilling, bore, ream, and tapping operations. If Enable drilled canned cycles is 

selected, then canned cycles will be output if the post you are using has g-codes 

defined for the hole canned cycles. If the post does not have these G-codes 

defined, the hole operations will still be computed.  

There is no way to control the output of canned cycles on an individual feature 

basis.  

Turn/Bore features  

Canned cycles for Turn and Bore features must be enabled by selecting Enable 

turn canned cycles in the Post options dialog. You must then go to the 

Properties dialog for each Turn/Bore feature, click the Strategy tab and 

select Use canned cycle.  

Also select Reuse path in canned cycle if you want to output the path 

geometry only once for both roughing and finishing. You can also set these 

values in the default attributes, but remember these values will only apply to 

features you create after making this change.  

Groove features  

Enable grooving canned cycles in the Post options dialog by selecting Enable 

groove path canned cycle. Then turn on canned cycles for each groove by 

bringing up the feature's Property dialog, clicking the Strategy tab, and then 

clicking Use path canned cycle. You can also set this attribute on the Groove 

tab of the default attributes, but this will only apply to features you create after 

changing this setting.  

Thread features  

Thread features always use canned cycles.  
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You can set this attribute for an individual feature in the Feature Properties 

dialog. Feature-level attributes override Machining Attributes  

Reuse path in canned cycle: - Relates to Use canned cycle. Enable this option 

to output the curve to the NC file once and then reference it in both the Rough 

and Finish canned cycles. This option is enabled by default.  

Canned cycle clearance X and Z: - These attributes control the tool location 

before the start of a turning canned cycle. The tool location is obtained by 

applying the X and Z clearances to the start point of the curve.  

Constant DOC  

The Constant DOC option controls how the Depth of cut attribute is used to 

calculate the X depth of roughing passes.  

If Constant DOC is deselected, cuts are guaranteed not to exceed the Depth of 

cut, but some cuts may be less than that amount. A pass is performed at each 

step. The area above each step is divided into equal regions with a depth of less 
than the Depth of Cut.  

In the example below, the bottom three cutter paths are aligned with the steps. 

The top region is divided into two equal regions with shallow depths of cut.  

 

 Aligned with Steps 

 Shallow Cut 

If Constant DOC is selected, each pass is performed at a consistent depth of 

cut. If required, the pass also climbs and cleans up previous steps. In the figure 

below, the first cut is performed straight across at the specified Depth of cut.  

  

 Depth of cut 

In the next pass, the tool cuts across at the specified depth of cut and then 

the tool climbs up the wall and the previous step is cut to with the finish 

allowance.  
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 Clean up of previous steps 

Threading tab (Turn) 
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Some of the Threading attributes are shown in the diagram below:- 

 

 End Clearance     Infeed angle 

 Withdraw Angle     Height 

 Depth 

 Start Clearance 

 Clearance 

Rough turn and Finish turn — Select these options to automatically turn the piece 

down to the thread diameter. See How a thread feature is manufactured. 

OD Thread Feature 

 

 (Chamfer addi.) Depth 

 (Chamfer)  Angle 

ID Thread feature 

 

 



 
 
Turning Attributes 

                           

 

      
Autodesk FeatureCAM 2017    

© Copyright 2016 Autodesk, Inc. All rights reserved           3.13 

      (Chamfer addi.) Depth 

 (Chamfer)  Angle 

 

(Chamfer) Angle: - Enter the angle of the chamfer in degrees (between 0 and 

85) measured from vertical. The default angle is 30.  

(Chamfer addl.) Depth: - Optionally enter additional depth for the chamfer. 

The default depth is the same as the Thread Height. The minimum value is 0. 

Relief groove: - A Thread feature has an option of cutting a relief groove at 

the end of the thread. Enter the groove parameters in the Feature Properties 

dialog on the Strategy.  

Side wall angle: - This is the default angle of the relief groove of the thread.  

Groove addl. depth: - The depth of the relief groove is the depth of the thread 

plus the Groove addl. depth. This prevents the threading tool from dragging 

on the bottom of the groove.  

Start clearance: - This value is the position to which the tool traverses before 

engaging into the workpiece. 

Chamfer Angle: - Enter the angle of the chamfer in degrees (between 0 and 

85) measured from vertical. The default angle is 30.  

Chamfer add depth: - Optionally enter additional depth for the chamfer. The 

default depth is the same as the Thread Height. The minimum value is 0.  

End clearance: - Enter the distance that the tool feeds past the end of the 

thread (into the relief groove) before retracting from the part's surface.  

Infeed angle: - Enter an unsigned, incremental value from the positive Z 

axis.  

Withdraw angle  

This parameter specifies the angle between cross feed movement and the 

withdraw move. For both roughing and finishing passes this angle is measured 

against the roughing scanlines. 

An angle of 90 retracts perpendicular to the roughing pass. An angle of 45 pulls 

back away from the part and the chuck. An angle of 135 pulls toward the chuck. 

The withdraw angle for finishing is not dependent on the shape of the feature 

curve. Even if no roughing pass is created, the withdraw angle for finishing pass 

is measured against the roughing scanlines.  

The Engage angle and Withdraw angle are specified from the path (or 

extension of the path), relative to the side of the path that the tool is on, and 

the direction in which the tool is traveling.  

OD/ID Depth %: - The depth of a thread is based on the thread pitch. The 

thread depth is calculated as Depth% * pitch.  

Passes: - This is the number of steps to the bottom of the thread. Select either 

Fixed or Calculated.  

Fixed: - This refers to a fixed rate of material removal. As the tool cuts further 

into the part, the area of contact of the tool increases. FeatureCAM reduces the 

infeed on each pass so that the tool loading remains constant. Enter the number 

of passes in Count.  

Calculated: - the number of steps is calculated automatically by FeatureCAM.  
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Step1 is used to specify the incremental step for the first pass across the 

thread.  

Step2 specifies the second pass and is used by the system to determine 

subsequent passes on the thread, reducing in depth until the Min Infeed value 

is reached.  

Spring passes: - A spring pass is a duplicate of the final threading pass. Enter 

the number of spring passes that you want.  

Thread depth calculations - Select how you want FeatureCAM to calculate 

the Standard Threads for pre-populating the dimensions of a Thread (see 

page 1434) feature. Select from:  

Use tool tip radius: - This option takes into account the tool tip radius. For 

example the standard thread designation M20 x 2.5 outputs:  

OD thread: Thread Height 1.894, Major Diameter 19.791  

ID thread: Thread Height 1.625, Major Diameter 17.519  

Use tool tip zero radius — this option outputs the nominal diameter and 

actual thread depth. This method is more commonly used in Europe. With this 

option selected, the standard thread designation M20 x 2.5 outputs:  

OD thread: Thread Height 1.534, Major Diameter 20.000  

ID thread: Thread Height 1.534, Major Diameter 16.933  
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Grooving tab (Turn) 

 

Plunge centre first: - For groove features, if this option is selected, the 

straight portion of the groove is roughed first and then the angled portions are 

roughed separately. If Plunge centre first is set, the red region of this image 

is roughed first and then the yellow regions are roughed.  

Cut type  

A turned groove can be cut in two different styles. The regions in the following 

figure are used to show the differences.  
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Width first - regions are cut in the order: - , , , , ,  

Depth first - regions are cut in the order: - , , , , ,  

If Depth First and Plunge Center First are both enabled, then the groove is cut in 

the following order: , , , , , . If the groove were wider, the 

subsequent cuts would alternate from one side of the groove until the other 

until the entire groove is cut.  

Feed dir: - This is the direction the tool feeds. The choices are either Neg 

(negative, -Z direction) or Pos (positive, +Z direction). For finish, you can also 

set this to Opposite from rough dir.  

Side lift off dist: - Enter the distance to move the tool after a plunge cut, in 

the direction opposite to the cutting direction. This increases the tool's life and 

leaves a better finish on the part. This applies to a Groove feature. See also 

Side liftoff angle.  

This part has a Groove feature, shown in pink: 

 

The default behaviour is for the tool to lift off the part at 90, shown in the 

following image by , after each plunge cut. This results in tool contact with 

the uncut material, at , when the tool is retracting at a rapid feed rate 

along the X axis:  

 

You can avoid this by using the Side lift off dist. attribute, to move the tool 

back along the Z axis  , before lifting off.  
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Side lift-off dist. and Side lift-off angle are ignored for the retract move at 

the end of the first plunge. The lift-off move is performed at the plunge feed 

rate. If the groove is a round-bottomed groove, then lift-off is not used, even 

when specified.  

Side lift-off angle: - Enter the angle to lift the tool off the part after each 

plunge cut. This increases the tool's life and leaves a better finish on the part. 

This attribute applies to a Groove feature.  

Dwell: - The number of seconds the tool dwells after plunging during a groove 

roughing pass. It also applies to the roughing of the Cutoff chamfer.  

Stepover %: - Enter the distance, as a percentage of the tool's diameter that 

the tool shifts to position itself for the next plunge cut. This value specifies the 

maximum stepover distance. If this value evenly divides the width of the 

feature, it is used. If it results in a final pass that is quite shallow, the cut widths 

are adjusted to result in even roughing passes.  

Chamfer extend dist.: - This provides extra space for the tool so that the tool 

does not start on the material for the Groove finish pass.  

Peck retract dist.: - For Cutoff and Groove features, Peck retract dist. is the 

distance the tool retracts between plunges.  
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Cutoff tab (Turn) 

Peck retract dist.: - For Cutoff and Groove features, Peck retract dist. is 

the distance the tool retracts between plunges.  

Dwell: - The number of seconds the tool dwells after plunging during a 

groove roughing pass. It also applies to the roughing of the Cutoff chamfer.  

 

 

 You can set these attributes for an individual Cutoff feature in the 
Feature Properties dialog on the Cutoff tab.  
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Bar Feed tab (Turn) 

 

 Dwell: - The number of seconds you want the tool to dwell after 

plunging during a groove roughing pass. It also applies to the 

roughing of the Cutoff chamfer. 
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Coolant 

 

 Use the Coolant tab of the Machining Attributes dialog to specify 

the default coolants to use for an operation. 
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Misc. tab (Turn) 

 

Plunge clearance: - This is the distance above an operation at which the tool 

starts to feed. In the case of deep hole drilling, the drill retracts to this distance 

between pecks. For milling features, the default is to use the same value for 

roughing and finishing. As a result, the tool feeds from the top of a pocket to 

the floor before cutting. To make the tool feed down into the feature, set the 

Plunge clearance for an operation to a negative value, but make sure the 

value is above the floor of the feature.  

The Starting offset number for shared tool slots is the first length offset 

register to use for tools that share the same tool slot.  

Tool program point: - Specify the program point for turning tools, select from:  

 Tool tip edge: - Select this option to adjust the tool program point by the 

insert radius in the NC code. In this case, adjust the tool's program point by 

the radius compensation on the Program. Pt tab of the Tool Properties 

dialog.  
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 Tool tip centre: - Select this option to adjust the tool program point by the 

insert radius at the machine. In this case, set the tool's program point X 

Coordinate and Z Coordinate to 0, 0 on the Program. Pt tab of the Tool 

Properties dialog.  

 

 Turn-milling program point: - Specify the program point for turn milling 

tools, select from:  

 Tool tip edge: - Select this option to adjust the tool program point by the 

tool radius in the NC code.  

 Tool tip centre: - Select this option to adjust the tool program point by the 

tool radius at the machine.  

 

Post vars. dialog  

Feed from start point or curve — Select this option to use a feed move 

from the Start point or the end of the Start curve, to the beginning of the 

toolpath. If you are using a start curve, you have two further options:  

 Rapid on curve: - Select this option if you want to use a rapid move 

along the start curve.  

 Selecting Feed from start point or curve and Rapid on curve is the 

equivalent of selecting the Feed from start option on the Turning tab 

in previous versions of FeatureCAM.  

 Feed on curve: - Select this option if you want to use a feed move along 

the start curve. Enter the feed rate value(s). You can set the feed move as 

a single value, or use a comma separator to enter multiple values, for 

example 200, 100, 50. If you enter multiple values, the feeds are applied 

to the curve segments in reverse order. So with these values, the last 

segment has a feed rate of 50, the second last has a feed rate of 100 and 

any remaining segments have a feed rate of 200. If you do not enter any 

feed rate values, FeatureCAM uses the default feed rate.  

This example turned part has a Turn, Hole, and Groove feature: 

 

A 3D simulation with 3/4 view shows that the tool has to pass through a 

narrow channel to access the Groove feature:  

 

To control the movement of the tool through that narrow channel, you can 

create curves and set them as Start point and End point on the Turning tab.  
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Turret direction: - We recommend that you leave this as Auto so that FeatureCAM can 

calculate the best direction for a particular operation. You can also explicitly set this option 

to CW (clockwise) or CCW (counter-clockwise).  

RPM Range: - If your machine has explicit spindle speed ranges, you can set this option.  

Some turning centres have gear boxes that set the maximum spindle speed of the 

machine. The RPM Range list sets the gear box to a specific maximum range. If you set 

RPM Range to a value of 1-4, then the range is set explicitly. If RPM Range is set to 

Auto then FeatureCAM sets the range for you based on the following rules:  

If the feature is a turned Hole or another turned feature without Constant Surface Speed 

set, then the range is determined based on the Spindle Speed.  

If the feature is a turned feature with Constant Surface Speed set, then the range is 

determined based on the Max RPM.  

Remachining: -   This automatically sets the boundaries for subsequent operations that 

use the same curve. This minimizes air cutting and works between Turn features, Bore 

features and between Holes and Bore features. The same curve must be used in both 

features. ID features use the results of a previous turn drill operation if such a feature 

exists. The stock curve that results from the first operation is the result of undercut clipping 

with the tool geometry and nothing more than that.  

Constant Surface Speed: - Select this option to specify the speed as a constant surface 

speed.  

Use IPR/MMPR: - The default feed units are IPM (inches per minute) or MMPM (mm 

per minute). Select this option to use IPR (inches per revolution) or MMPR (mm per 

revolution).  

Do feed reduction for small moves: -   This attribute helps FeatureCAM cut small 

features properly. It is typically applied to small chamfers or small radii but affects any 

small move. If Do feed reduction for small moves is selected, then any move with 

fewer revolutions than the Threshold, is reduced by the Feed rate %.  

Automatic Tool Selection:- This option set the same tool in the appropriate direction for 

OD Turning and ID Turning, with respect to Main Spindle/Sub-Spindle. 

  



              
 

                                     Turning Attributes        

 

                                                                                                                                      
                                                                                                              

 Autodesk FeatureCAM 2017   

3.24                                                                                                                 © Copyright 2016 Autodesk, Inc. All rights reserved 

 Calculate index radius from solid stock outline: - Select this 

option to determine the index height directly from the stock solid, 

instead of calculating it above a square bounding box.  

  

    

 Distance to bounding box.     Distance to stock boundary  

 Z rapid level attribute value      Z rapid level attribute 

value 

 

Turret location  

The Turret location is kept in the *.cnc file, because there may be multiple turret 

locations.  

To change the locations:  

Select Manufacturing > Post Process from the menu.  

In the Post Options dialog, click the Turn/Mill tab.  

3 Click the Edit button and XBUILD opens. Select CNC-Info > Turrets from the menu. 

  

Calculate index radius 

from solid stock outline off  

Calculate index radius  

from solid stock outline on 
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Operations 
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Base priority  

Features are sorted by their Base priority to determine the order in which they 

are manufactured. For features that have the same Base priority value, the 

system uses the Automatic Ordering settings.  

To ensure that an individual feature is cut before anything else, you can set its 

Base priority attribute. All features have a default Base priority of 10. To ensure 

that a feature is manufactured first, set its priority to a lower value. To make a 

feature last, set its priority to a higher value. For example, if you set the Base 

priority of a pocket to 8, its roughing pass is the first operation performed, its 

finish pass is second, and the rest of the operations are ordered according to 

the Automatic Ordering or Manual Ordering settings.  

Although you can specify the order of every feature by priority, you should not 

do so casually because you lose the automatic optimization sequences built into 

the system and it is harder to maintain or change the part.  

The order of operations in the document is controlled by the operation-level 

Priority attribute. If you use the Op List to drag-and-drop operations to the 

order you want, the Priority is updated automatically.  

 

Don't ask at tool path generation: - This is a toggle for whether you are 

prompted with the dialog when you run a simulation. The Ordering dialog 

settings override the operation defaults set on this tab. 

Time estimation attributes: - Set these attributes to fit the behaviour of your 

particular machine. These attributes affect the machining time estimates 

printed in the operation sheets.  

Rapid traverse: - This is the feed per minute of rapid moves.  

Tool change: - This is the time in seconds it takes to change a tool (not 

including the rapid to get to tool change location).  

Go to start: - This is the time it takes for the tool head to move to the start 

location and the spindle or tool head to come to a stop.  

X-Y acceleration: - This is used in the formula to calculate the time for a 

particular tool move.  

Z acceleration: - This is used in the formula to calculate the time for a 

particular tool move.  

These attributes are the same as on the Operations tab for Mill with an 

additional option in the Automatic Ordering Options dialog, Use template: 
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Use Rules 

 

Automatic Options (TURN) 

These attributes are the same as on the Operations tab for Mill, with one 

additional option in the Automatic Ordering Options dialog. 

Use rules:  

Minimize tool changes: - This option groups operations together that use the 

same tool. This saves time for you by eliminating or reducing needless tool 

changes. You must select this option if you want to generate hole macros in the 

NC code.  

Do finish cuts last: - This option moves the finish milling operations to the end 

of the Setup without altering the order of the finishing operations? If you want 

to perform all rough milling operations before finish milling operations, select 

this option.  

Cut higher operations first: - This option affects only milling Setups. Select 

this option to mill the features from the top of the stock first and work toward 

the bottom. If you deselect this attribute, you should carefully graphically verify 

the toolpath before cutting your part.  

Sorting by Z coordinate is controlled by the Cut higher operations first attribute. 

If you deselect this attribute, graphically verify the toolpath before cutting your 

part.  

Minimize rapid distance: - This affects only milling Setups and is the only 

ordering option that changes the order of features specified in the part view. 

Minimize Rapid Distance moves to the next closest feature that uses the same 

tool as the last operation. You must deselect this option if you want to generate 

hole macros in the NC code.  

If you have selected all of the optimization options, the manufacturing order 

for operations that were derived from different features is determined like 

this:  

The operations are sorted by their top Z coordinate.  

Among operations with the same top Z coordinate, operations are grouped by 

the tool with which they are cut.  
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After an operation is cut, FeatureCAM moves to the next operation performed 

with the same tool that is the closest to the current operation.  

Use Template 

 

 This attribute is applicable only to turning setups. If you select Use 

template then the order of operations are determined by the outline of 

operations listed in the Feature Order dialog. Click Edit template to 

open the Feature Order dialog. See turn operation order. 
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What are Machining Attributes? 
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 When an option in the Machining Attribute is selected, a box is checked or 

a value is entered, it becomes a default. This means that FeatureCAM uses 

this setting every time a feature requiring that particular setting is selected 

in a program. There is no input required from the user during programming, 

as it is now automatically set. However, it may be overridden and changed 

in the feature as needed. 

 Tabs are used to categorize the different operation types and necessary 

attribute settings. 

 Some selections are check boxes, some are numerical values, and some are 

specific functions.  The majority of these show up in the feature that they 

affect, but some settings do not. These settings may only be changed in the 

attributes. This is the reason it is so important to know where these settings 

reside, what their function is, and where they are located in the features.  

 To apply the changes you have made, in the Attributes for the document, 

to become the defaults for any new documents they must also be changed 

in the Machining Configuration that opened with the file. Once set, and the 

next time a new document is opened, those changes will then take effect as 

the default settings. 

 Open a New Turn Document and click Manufacturing on the top menu and 

select Machining Configurations 

 Select the document you just opened. Usually there is only one document 

open but multiple documents may be opened. In this case, you would see 

multiple documents in the list 

 Click Copy and select the My Configuration from drop down menu. These 

defaults load into the new document 

 

 To copy the changes from the document’s configuration into another 

configuration to be set as the defaults: 
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 Select the My Configuration in the window. This is the configuration you 

want to copy the attributes to 

 Click Copy and select the document from drop down menu in the Copy 

Configuration dialog 

 Select OK. 

 This reverses the copy and places the changes, if we had made any, from 

the document Attributes into the configuration selected in the window of the 

Machining Configurations dialog. 

Creating Machining Configurations 

 Open a New Turning Document. Click Manufacturing on Menu bar then 

Machining Configurations 

 Click on New and type the word Aluminium in the field. OK 

 Repeat these steps to create a Stainless configuration. OK 

 Double click on Stainless in the window. Select the Turn/Bore Tab in 

the Machining Attributes dialog. Change the Rough depth of cut to 

2.5mm 

 The Rough Depth of cut for rough turning was 5mm per pass. It is 

now 2.5mm to account for the harder to machine Stainless steel. 

 Repeat the steps to change the Aluminium Configuration’s Rough depth 

of cut to 6mm this may be more than you would want to cut, even in 

Aluminium, so put whatever value makes you comfortable.  

 Note: You now have three separate Machining Configurations.  Each 

has approximately 100 settings. 

 Select the Document you have open in the Machining Configurations dialog 

at the top of the window 

 Copy and select Aluminium from the Copy Configuration dialog 

  OK twice. These settings will be used in the new document 

 Open an existing file named Turning Attributes.fm, from the Beginning 

Data folder, and run a 3D simulation 

 The Turning tool cuts in depth increments of 5mm to the shape of 

the curve, to rough the material to shape. The default attribute 

specifies the Rough depth of cut to be 5mm per pass.  

 Click Manufacturing then Machining Configurations.  Select the 

document in the window on the left named Turning Attributes.fm 

 Press the Copy button 

 Select Stainless from the drop down list in the Copy Configuration 

dialog 

 Press OK twice 

 Using the same feature and by only changing the Machining Configuration 

the Attributes automatically change to the Stainless settings.  

 Run a 3D simulation 
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 The setting for Stainless is 2.5mm Rough depth of cut, so now the 

tool makes ten passes at 2.5mm depth of cut instead of five at 

5mm with no further input from the user. 

The Attributes 

 We should take a look a bit more closely at what attributes are where and 

what settings are available in each grouping, or tab. Special attention will 

be drawn to the more common/important settings. 

Drilling Tab 

 The drilling tab has settings such as whether or not a spot drill is used, and 

other controls for that spot drill. There are some settings for how operations 

are ordered in a hole feature and active, such as Reaming before 

chamfering.  

 Most importantly there is a tap “cycle” setting that will be loaded as the 

default when a thread is cut: Floating, Rigid, or Deep tap.  

Pecking Tab 

The basic peck settings for both drilling and tapping operations.  

Turn/Bore  

The settings in the Turn/Bore tab are the most commonly used settings in 

FeatureCAM’s turning attributes. 

Settings such as Rough depth of cut, the semi-finish, and finish allowance 

settings and how undercuts are handled highlight the settings used in these 

feature types. 

Additionally, cutter comp, leads, and canned cycle settings are contained 

herein. 

Threading 

Material removal settings such as rough and finish turn in preparation to cut 

the threads are key settings.  

Relief settings are important in threading. 

Thread depth percentages and calculations also reside in this area. 

Grooving 

The settings here, obviously address the way grooving features are machined.  

Key settings are the default way you would prefer to handle the rough cuts 

with or without plunging and how those plunges are cut. 

Stepover and depth of cuts as well as canned cycles usage are located here. 

Cut-off and Bar Feed 

The Cut-off and bar feed settings are self-explanatory. 
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Miscellaneous 

The basics of turrets and spindles, as well as RPM and coolant types and offset 

registers are a part of the miscellaneous settings. 

CSS (constant surface speed) and the use of MMPR (Millimetres per 

revolution) by default are set here. 

Remachining is addressed a little later on in this module. 

Operations 

The way operations are handled in this tab, such as the way the automatic 

ordering of features is done. 

An integral part of FeatureCAM’s tools is the time estimation output in the 

results window. Many users use this as a base for quoting their customers for 

manufacturing of the parts. Key settings are your actual rapid traverse speeds 

and time taken at the machine tool for each tool change, among others. 

Help Contents 

Using the Contents, Index, or Search tabs is a great way to learn more about 

FeatureCAM and how to use it efficiently. The settings are found and 

explained in the Help files. 

 Open the file named Help File.fm 

 In this file you will notice there is a feature already created, turn1. 

There are a couple settings in the attributes the user can take 

advantage of to fine-tune the Toolpath. 

Use the help file to search a few of the attributes to decide which, if 

any, of the attribute settings available might be some changes you 

want to make and apply to the final Toolpath. 

 Double-click on turn1 in the Part View of the Toolbox to see the feature 

properties 

 Select Rough operation and the Turn tab 

 You see several attributes in the window of the dialog that may not 

make any sense to you at this point. Using the help file is a great 

way to learn what these settings do and how to apply them to this 

operation of the feature. 

 Click Help from the File Menu and Contents to access the help file 

 A New Window opens up that allows the user to use three methods 

in the FeatureCAM Reference Help section to learn more about 

FeatureCAM, including attributes. 

 

 

 Select the Search tab and type in the words “start point.”  

 Press the List Topics button 
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 The Select topic list shows all the topics where the key words Start 

and/or Point appear. Since we know that setting exists in the Turning 

tab of our feature we will want to choose that listing. 

 Double click the second item in the list, Turning tab (TURN) to update 

the window at the right of the Reference Help window to see how “Start 

Point” applies in relation to the Turn tab of an operation 

 Run a Centreline Simulation to see where the tool starts without any 

changes made 

 HINT: Use Single Step instead of play to see the initial move to the 

start point location. As shown on the next page. 

 In the rough operation Turning tab highlight Start point = and press the 

Pick Arrow to pick a new position for the tool to start, see below 

 

 Apply and OK 

 Run a Centreline Simulation, single step to see the change to the 

Toolpath 

 Notice the tool starts where you picked it to then rapids over to 

start the cut. 

 Try a few other settings after referencing the Help file. 

 
 



 
 
Tooling Reference Guide 

                           

 

      
Autodesk FeatureCAM 2017    

© Copyright 2016 Autodesk, Inc. All rights reserved           4.1 

Contents 

Turning Tool Reference Guide ........................................................................... 2 

Tooling ............................................................................................................... 2 

Overview of tooling ............................................................................................ 2 

Tooling database ............................................................................................... 3 

Turning Tool Orientation .................................................................................... 5 

Tool Groups. ...................................................................................................... 7 

Insert Shapes ..................................................................................................... 7 

Inserts for General Turning ................................................................................ 8 

CNMG Insert ..................................................................................................... 9 

DNMG Insert ................................................................................................... 10 

Insert Shape .................................................................................................... 13 

Holder .............................................................................................................. 14 

Orientation ....................................................................................................... 14 

Holder Drawing ................................................................................................ 16 

Overrides ......................................................................................................... 16 

Coolant ............................................................................................................ 17 

Feeds/Speeds .................................................................................................. 17 

Turning tool operation usage ....................................................................... 18 

Lathe - Bore Tool Properties example. ............................................................ 20 

Holder Information ........................................................................................... 20 

Boring Orientation ............................................................................................ 22 

Using an insert drill to drill and bore in the same program ............................... 23 

Lathe - Bore Programming Point ..................................................................... 24 

Lathe – Groove tool Properties example.......................................................... 24 

Lathe - Cutoff Tool Properties example ........................................................... 25 

Lathe - Groove/Cutoff  Holder tool Properties example ................................... 26 

Lathe – Thread Tool Properties example. ........................................................ 27 

Adding a Solid Model Turning Tool .................................................................. 28 

Mini-turrets ..................................................................................................... 32 
 

  



              
 

                    Tooling Reference Guide       

 

                                                                                                                                      
                                                                                                              

 Autodesk FeatureCAM 2017   

4.2                                                                                                                  © Copyright 2016 Autodesk, Inc. All rights reserved 

Turning Tool Reference Guide 
It is possible to create Tool libraries in FeatureCAM. These are called Tool Cribs.  The 

main reason for creating Tool Cribs is because in any machine shop there is normally a 

finite amount of tooling available and by creating a custom Tool Crib, FeatureCAM will 

know what tooling is available to choose from. 

Tooling 

FeatureCAM has extensive tooling databases and automatically selects tools 

for each manufacturing operation.  

Overview of tooling 

For each manufacturing operation created for the features of a part, a tool must 

be selected from the internal tooling database. This database is broken into 

separate tool cribs to represent individual collections of tools that your 

organisation might have. The image below shows the structure of the tooling 

database.  

 

 Tooling Database 

 Tool Cribs 

 Tool groups for example drills, taps, Endmill. 

 Tools 

FeatureCAM comes with three different built-in tool cribs when selecting both. 

This includes both Metric and Inch tool databases. The Basic crib is the default 

crib that contains standard available tools that most shops own. The Tools crib 

is a large crib containing hundreds of tools. This crib is most often used as a 

source to copy from into custom tool cribs or into the basic tool crib. 

BasicMetric is purely metric tools for the European market. 

Only one tool crib is available at a time and all tools are selected for a part from 

only the current tool crib. Tool cribs contain individual tools and they are 

classified into tool groups such as drills, end mills, and boring bars. You 

cannot create new tool groups, but you can create new tools to reflect the 

specific tools that your shop owns.  
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Each feature type has rules for tool selection.  

Double-click a feature in the graphics window or the Part View panel to display 

the Feature Properties dialog, then select an operation from the Tree View on 

the left of the dialog. On the Tools tab of the Feature Properties dialog, you 

can: See which tool is currently selected to perform the operation; or Change 

the tool used to perform the operation.  

Tooling database 

The tooling database defines the set of tools from which FeatureCAM selects 

tools to perform manufacturing operations. These tool sets are called cribs. 

FeatureCAM comes with two standard tool cribs, the Tools tool crib and the 

Basic tool crib. The Tools tool crib is a comprehensive tool crib that contains 

more tools than your shop probably owns. The Basic tool crib contains a smaller 

set of tools such as HSS endmill and standardly available drills. By default 

FeatureCAM is set to use the Basic tool crib. You should modify the cribs to 

reflect the tools your shop has. You can create a crib containing tools you 

commonly use, which can simplify setting up a part for machining.  

The name of the active tool crib is displayed on the status bar. To change the 

current tool crib you are currently using, click the crib name on the status bar. 

A list of tool cribs is displayed that you can select from.  

  Please note this document is part reference, with information taken 

from the help file.  

1 Open a new FeatureCAM part by selecting File, New. 

2 The following Menu shown on the next page will appear. Select Turn/Mill Set-

up and click OK. 
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 To create or modify a tool crib, you must have a part file open, then 

select Manufacturing > Tool Manager from the menu to display 

the Tool Manager 

3 Go up to the Manufacturing Menu and down to Tool Manager. This will open 

the following form. 

 

 There are three tool Cribs loaded as standard. (Basic, BasicMetric 

and Tools) and these can be used as a starting point when the user 

first starts to look at setting up their own Cribs. Another Crib is 

available BT40-Training-Crib-Metric on request or copied from the 

training material supplied with this course. This can be loaded as an 

.XML file into FeatureCAM via the Tool Manager. 

 The window is divided into separate areas and at first glance this can 

look a little intimidating, but by applying some simple rules it 

becomes much easier to work with. 

 If the user divides the form in two down the middle of the form. The 

left side is used to select which Crib to copy from whereas the right 

hand side of the Form relates to the Crib that is current or the working 

Crib.  
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Turning Tool Orientation 

You can now use a turning tool in multiple orientations without having to create 

a different tool in the database for each orientation. 

 

 To activate this option please set the following in your configuration 

file. 

 



              
 

                    Tooling Reference Guide       

 

                                                                                                                                      
                                                                                                              

 Autodesk FeatureCAM 2017   

4.6                                                                                                                  © Copyright 2016 Autodesk, Inc. All rights reserved 

 The tool orientation is split into two types. 

 OD Turning or ID Turning for Main- spindle or Sub-Spindle. 
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Tool Groups. 

  The tools can be grouped together depending upon their type or 

use. 

 

Insert Shapes 

Select the insert shape. 

For the Custom diamond insert shape, you must enter the Tip 
Angle.  

   

 

80 deg Diamond Square Triangle 35 Deg Diamond 

 

 

  

 

55 deg Diamond Round Insert 80 Deg Trigon Custom Diamond 
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Inserts for General Turning 
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CNMG Insert 

Tip Radius is the radius of the cutting tip of the insert.  

Tip Angle is the included angle of the insert.  

Inscribe Circle Diameter is the diameter of a circle that fits inside 
the insert shape.  

CNMG 12 04 08-PR 4225  

      

S = Insert Thickness 

RE = Corner Radius 

IC = Inscribed Circle Diameter 

 

FeatureCAM tool designation = SW_Turn_80m_RH 
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DNMG Insert 

   

 

S = Insert Thickness 

RE = Corner Radius 

IC = Inscribed Circle Diameter 

 

Tip Radius is the radius of the cutting tip of the insert.  

Tip Angle is the included angle of the insert.  

Inscribe Circle Diameter is the diameter of a circle that fits inside 
the insert shape.  

 

FeatureCAM tool designation = SW_Turn_55m_RH 
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VBMT Insert 

   

 

S = Insert Thickness 

RE = Corner Radius 

IC = Inscribed Circle Diameter 

Tip Radius is the radius of the cutting tip of the insert.  

Tip Angle is the included angle of the insert.  

Inscribe Circle Diameter is the diameter of a circle that fits inside 
the insert shape.  

 

FeatureCAM tool designation = SW_Turn_35m_RH 
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End Cut: - The tool cuts in a direction parallel with the length of the holder.  

Side Cut: - The tool cuts in a direction perpendicular with the length of the 

holder.  

 

 End Angle 

 End Clearance 

 Side Angle 

 Side Clearance 

 

 Shaft Width (A) 

 Length (C) 

 Tip to Back (F) 
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Exposed length: - This is the amount of the tool that sticks out of the Turret 

if the holder is simulated. Lathe - Turning Tool Properties example. 

 

 

Insert Shape 
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Holder 

 

Orientation 
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 On the Prog. Pt. (program point) tab you set the point of the insert 

that is actually programmed. You can set both the X Coordinate and 

the Z Coordinate. Tool tip centre - If both X Coordinate and the 

Z Coordinate are set to 0.0 then the centre point of the tip arc is 

programmed. In this case it is expected that you perform insert radius 

compensation at the machine tool. Tool tip edge - If you wish to 

perform insert radius compensation in FeatureCAM, set the X 

Coordinate and Z Coordinate to the radius compensation values 

provided with your tool. You should also set the default Tool 

program point attribute to Tool tip centre or Tool tip edge. 
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Holder Drawing 

 

Solid — you can select a solid to define the shape of the Tool Holder. This is 

the most accurate way to represent the tool holder. 

Overrides 

 



 
 
Tooling Reference Guide 

                           

 

      
Autodesk FeatureCAM 2017    

© Copyright 2016 Autodesk, Inc. All rights reserved           4.17 

Coolant 

 

Feeds/Speeds 
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Turning tool operation usage 

FeatureCAM gives you the ability to set turning tools operation type. Select 

Operations then select an entry in the list to specify the type of operation for 

which FeatureCAM can select this tool. You can override this setting by selecting 

the tool 

 

 Plunge clearance is the distance above an operation at which the 

tool starts to feed. In the case of deep hole drilling, the drill retracts 

to this distance between pecks. For milling features, the default is to 

use the same value for roughing and finishing. As a result, the tool 

feeds from the top of a pocket to the floor before cutting. To make 

the tool feed down into the feature, set the Plunge clearance for an 

operation to a negative value, but make sure the value is above the 

floor of the feature. 

 The Starting offset number for shared tool slots is the first length 

offset register to use for tools that share the same tool slot. 

 Tool program point - select from: 

Tool tip edge - select this option if you want to adjust the tool 

programming points by the insert radius compensation. In this case 

adjust the tool's programming point by the radius compensation. 

Tool tip centre - select this option if you want to adjust the tool 

touch-off points by the insert radius compensation at the machine. In 

this case set the tool's programming point X Coordinate and Z 

Coordinate to 0.0 on the tool's Prog. Pt. tab. 

Turret direction - we recommend that you leave this as Auto so that 

FeatureCAM can calculate the best direction for a particular operation. 

You can also explicitly set this option to CW (clockwise) or CCW 

(counter-clockwise). 



 
 
Tooling Reference Guide 

                           

 

      
Autodesk FeatureCAM 2017    

© Copyright 2016 Autodesk, Inc. All rights reserved           4.19 

 RPM Range 

Some turning centres have gear boxes that set the maximum spindle 

speed of the machine. The RPM Range list sets the gear box to a 

specific maximum range. If RPM Range is set to a value of 1-4, then 

the range is set explicitly. If RPM Range is set to Auto then 

FeatureCAM sets the range for you based on the following rules: 

 If the feature is a turned hole or another turned feature without 

Constant Surface Speed set, then the range is determined based on 

the Spindle Speed. 

 If the feature is a turned feature with Constant Surface Speed set, 

then the range is determined based on the MAX RPM. 

 Remachining - automatically sets the boundaries for subsequent 

operations that use the same curve. This minimizes air cutting and 

works between turn features, bore features and between holes and 

bore features. The same curve must be used in both features. ID 

features use the results of a previous turn drill operation if such a 

feature exists. The stock curve that results from the first operation is 

the result of undercut clipping with the tool geometry and nothing 

more than that. 

 Use IPR/MMPR - The default feed units are IPM (inches per minute) 

or MMPM (mm per minute). Select this option to use IPR (inches per 

revolution) or MMPR (mm per revolution). 

 Do feed reduction for small moves - This attribute helps 

FeatureCAM cut small features properly. It is typically applied to small 

chamfers or small radii but affects any small move. If Do feed 

reduction for small moves is selected, then any move with fewer 

revolutions than the Threshold, is reduced by the Feed rate % 
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Lathe - Bore Tool Properties example. 

 

Holder Information 
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 End Cut: - The tool cuts in a direction parallel with the length of the 

holder.  

 Side Cut: - The tool cuts in a direction perpendicular with the length 

of the holder. 

 

 

 End Angle 

 End Clearance 

 Side Angle 

 Side Clearance 
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 Z Axis 

 Min. Diameter (MD) 

 Length (C) 

 Shaft Diameter (D) 

Exposed length: - This is the amount of the tool that sticks out of the Turret 

if the holder is simulated. 

Boring Orientation 
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Using an insert drill to drill and bore in the same program 

1 Create the Hole feature and override the tool for the drilling operation to be an 

insert drill. 

2 Create the Bore feature and override the tool to be the same insert drill. 

3 If you view the tools in the Tool mapping dialog you see that there are two drills 

listed in the same tool slot, but they each have a different Length offset register. 

 

 

 Please note that you need to reduce the retract distance to avoid a 

collision inside the bore. This needs to be applied to roughing and 

finishing operations. 
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Lathe - Bore Programming Point 

 

Lathe – Groove tool Properties example 
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Lathe - Cutoff Tool Properties example 

 

 

Holder Type: - For grooves possible holder types are:  

 OD Groove: - Select this option for outer diameter grooving tools.  

 ID Groove: - Select this option for inner diameter grooving tools.  

 Face Groove: - Select this option for face grooving tools.  

 Cutting: - Select this option for Cutoff tools.  

End Cut: - The tool cuts in a direction parallel with the length of the holder.  

Side Cut: - The tool cuts in a direction perpendicular with the length of the 

holder. 

 

 End Angle  End Clearance  Side Angle  Side Clearance 
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 Shaft Diameter (D)  Length (C)  Tip Angle  Width  Tip Radius. 

 

Lathe - Groove/Cutoff  Holder tool Properties example 
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Lathe – Thread Tool Properties example. 

 

Name - is a string that identifies the tool. The name must be unique among 

all the tools in the crib. Tip Radius is the radius of the cutting tip of the 

insert. See diagram.  

For threading tools, 3D simulation simulates the tool with a tip radius of 0.0. 

This is just for visualization purposes only. The NC code or tool selection is 

not affected in any way. Tip Angle is the included angle of the insert. See 

diagram. 

Measure - indicates the units that are used for reporting the tool’s 

dimensions. Select inches for inches or deselect the box for millimetres. 

 This is for reference only. If you want to edit the Name of the tool, 

do it on the Insert tab. 

  

 Shaft Diameter  

 Length 

Holder Type - For threads possible holder types are: 

OD Threads - Select this value for outer diameter threading tools 

ID Threads - Select this value for inner diameter threading tools 
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End Cut - The tool cuts in a direction parallel with the length of the 

holder. 

Side Cut - The tool cuts in a direction perpendicular with the length 

of the holder. 

Adding a Solid Model Turning Tool 

FeatureCAM has the ability to use Solid model Turning Tools and add them to 

the tooling database. The following steps, take you through the importing of 

the Solid Model tool and transforming it to the correct position. Then adding the 

tool to the tool database. 

1 Open a new Turning document. 

 Import the solid model from C:\Training_Data\FeatureCAM Course Data 

2017\Tooling\Turning Tools  C6-SDJCR-45065-11-635.x_t 

 

2 Switch on the Stock axis in Part View. You will notice that the tool tip radius 

centre point 0.8 is not located in the correct position. The centre point of the tip 

radius must be at X0, Y0, Z0. (Stock Axis). 

3 Draw a circle on the tip radius. To do this use Circle from 3 points  from the 

geometry menu. Make sure you have snap to object switched on. 
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4 In PartView Select the solid model tool shape in the Solids directory. This will 

make it active. Then from the Edit menu select Transform/Translate/ 

5 Move-From. Snap to the circle centre To X0, Y0, Z0. 

6 Select Ok to action the process. 

7 Switch on the Stock Axis. You will see the following. 

 

 

 The bottom tool will be used for Back Turning. 

8 Open the Tool manager from the Manufacturing menu. 

9 Select the SW_Turn_55m_RH turning tool by double clicking on that tool. 
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10 Select the Holder drawing menu and select the first solid model as shown. 

 

11 Change the name of the Tool to SW_C6-SDJCR-RH 
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 The insert Inscribe circle is 9.0, insert Shape is 55deg Diamond. 
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Mini-turrets  

You can simulate mini-turrets, which are tools with multiple inserts where the 

tool rotates around the b-axis to access each insert. The tools are simulated 

simultaneously, which enables you to check for gouges with the tools that are 

not currently in use. 

 

 This is only available in the machine design file (Machine Tool 

Simulation) which is an extra cost option. 
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AFR Turning Example 1 - Part4 Turning 
Automatic Feature Recognition recognises different features on solid models 

and automatically creates toolpaths for different setups. FeatureCAM will select 

the relevant tooling, but will warn you if it cannot find the correct tooling. Using 

the AFR Wizard, this will guide you through the process from aligning the part 

to creating the stock and then creating the features for your part. We will go 

through this process on an actual job from the Turning Files to Import 

directory. C:\Training_Data\FeatureCAM Course Data 2017\Turning 

Files to import 

1 We will start off with a relatively easy part assuming that we have a simple 2 

axis cnc turning centre. The part will be created with two setups. 

 

 

2 We will start by importing the model. 

3 Go to File>Import C:\Training_Data\FeatureCAM Course Data 

2017\Turning Files to import. 
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4 Import the following part. Part4 Turning.SLDPRT 

 

5 The Wizard will guide you through the process. 
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6 Is the part properly aligned with the Z axis? In this case the answer is yes. 

 

 

7 Select Next. 
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8 The next Menu gives you the option to select the Stock Type. 

9 For our turned part select Round as shown. 

 

10 The next available menu will ask you to select the Centre of the round stock. 
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11 Select Next. 

12 The next available menu will give you two options. Option1- Enter specific 

stock dimensions or Option 2 – Compute stock size from the size of the 

part. Please select option 2. 

 

13 Enter the above coordinates. This allows 1mm on the front and back faces plus 

3mm on diameter. 

14 Select Next. You will notice that the Z datum shows -1.000. FeatureCAM knows 

how much material you have left on from the previous menu. 
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15 Select Next. 

 

16 Select Finish. The following menu will be shown. 

 

17 Select Next. 

18 You will be asked if you want to Recognise Hole Features now. Select No. 
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19 Select Next. 

20 Please select Select features for Setup1. 

 

21 Select Finish. 

22 In your operation list you will get a warning? 
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23 For the Hole1 Feature. Adjust the hole roughing tool to a 30mm Drill.  From 

the Training_Crib_Metric crib this will not exist, so create a new tool. Choose 

an existing drill of a smaller size and change the values. Remember to change 

the name so you can create a new tool. To do this double click the on the following 

***** this will open the tooling form. 

 

24 After changing the drill you may also have to change the minimum Radius 

boundary to 15mm in the Bore1 Feature. Change depth of cut to 2mm.  Run 

a 3D Simulation to view results from the Automatic Feature Recognition. 

25 Remember that a Bore Feature has a Pre-Drill option that combines the two 

strategies into one. 
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 Notice how the tool will machine as much as it can, which depends 

on which tool is selected. (see image) 

26 Try using Select left boundary and limit the length to the back shoulder. The 

chuck will be damaged if you have not left enough material at the back of the 

part. Select Turn1 by double clicking in Part View. Select Roughing. 

27 Select Pick Z Location. 

 

 The Z Value is -116.0 the * denotes that the value has changed. 

 

28 Re-Run the 3D Simulation.  
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 We can now create Setup2. Double click on Setup1 following menu will 

appear. 

 

29 Select New and the following menu on the next page will be displayed. 
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30 Select Next. 

 

31 Select Next. 
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32 Select the left hand as shown. 

33 Select Next. Then set the Z Offset to -1 as shown. 
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 This will set the new datum to the opposite face. This is when you 

take the job out of the chuck and turn it around if you only have one 

spindle. If you have a Sub-Spindle please select this option. You will 

have to use Part Handling to transfer the part into the Sub- Spindle. 

 FeatureCAM will ask if you want the main Spindle or Sub-Spindle. 

See menu on the next page. 

 

 

34 We are now ready to apply AFR for setup2. Select STEPS and select AFR. 

35 From the Construct menu please select Automatic Feature Recognition. 



 
 
AFR Basic Turning 

                           

 

      
Autodesk FeatureCAM 2017    

© Copyright 2016 Autodesk, Inc. All rights reserved           5.15 

 

36 Select Next. 

37 Unselect setup1 so it will only recognise setup2 

 

 If you select Setup1 and Setup2 this will duplicate operations.  

38 You will be given the option to select which Features are relevant to Setup2. 

39 Please unselect Bore 01 and Hole 01 as shown on the next page. 
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40 Select Finish. 

 

 

41 We need to adjust turn2 in Setup2. Double click on turn2 in Setup2. Select 

the Rough pass in the Operation list this will show the following menu. 
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42 This will now only allow the machining up to the point shown. See 3D 

Simulation. 

 

43 The component is now finished see image of both operations on the next page. 

Change the Post Processor and look at the code output. 
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AFR Turning Example 2 - Turnsolid 
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Turnsolid - Manipulating the model to the correct orientation 

ready for AFR. 

 

1 We will start by importing the model. 

2 Go to File>Import. C:\Training_Data\FeatureCAM Course Data 

2017\Turning Files to import 

 

3 Select the file TurnSolid.SLDPRT then select Open. Please select the Default 

Configuration only. 
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 The part needs to be orientated, we can Use the Wizard to establish 

the initial Setup location and stock size. This example needs to be 

rotated.  

 

 

4  Select Next. 
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5 Use Align Z with centre of Revolved Surface. 

6 Select a revolved Surface. 

 

7 Select Next twice and then set the Stock Type to Round (Default) 



              
 

                     
                                         AFR Basic Turning       

 

                                                                                                                                      
                                                                                                              

 Autodesk FeatureCAM 2017   

5.22                                                                                                                 © Copyright 2016 Autodesk, Inc. All rights reserved 

 

8 Select Next twice. 
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9 Select Next to set the Stock dimensions. 

10 Select Stock Size from the size of the part. 

 

11 Enter 1mm Extra Stock Front 

12 Enter 1mm Extra Stock Back 

13 Enter 3mm Extra Stock OD 

14 Select Next to align Setup1 to the front of the part. 

 

 

 

15 Select the Right Hand Icon; this will set the value to Zero. Type in -1mm  

16 Select Finish. 

17 The Wizard will guide you through the Feature extraction process. 
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18 Select Next to continue. 
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19 Select Yes and then Next. Accept the features created. 

 

20 Select Finish and Run 3D Simulation. 

 If you run the 3D Simulation we have two problems one the Tool 

that FeatureCAM has picked is too big for the actual groove plus in 

the process table we have two error messages see below. Which are 

related to the grooving tool 

 

 

 

21 To resolve the problems first of all we need to create a grooving tool 2mm 

R0.5 this will allow the tool to finish the job. 

22 Eject the 3D Simulation and double click on the groove 01 feature. The 

following menu will appear. Select Rough. Select Tools. 
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23 Double click on SW_cut_2 and from this tool create the tool as shown on the 

next page. Remember to change the name. 

 

24 Change the tool to the one shown and hit apply. This will update the machining 

process automatically. Double click on the tool that shows the error. See menu. 

Select the tool listed below. Re-run the 3D Simulation. 
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25 We now have to create a Cut-Off Feature manually to finish the part. Select 

New Features or (Ctrl+R) and then select Cut-off. 

 

26 Select Next. 

27 Enter the following information into the menu. 
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28 Select Next. 

29 The overall length should finish at -75mm 
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30 This is the finished part shown below. 

 

 

Using a Solid model for stock 

 The next exercise uses a Solid model to define the stock material. 

This method minimises the amount of toolpaths required as it only 

machines where the stock is located. 

 

1 Import: - Solid Stock-2 - All Models .x_t from. 

C:\Training_Data\FeatureCAM Course Data 2017\Turning Files to 

import\ Solid Stock-2 - All Models .x_t 
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 The following model is the Part 

 

 

 The following model is the Stock. 

 

2 Work through the Wizard. 
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3 Select Next. 

4 Use Align Z with centre of revolved surface. 

 

 

5 Select Next Twice. 
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6 Stock Type = Round. Select Next. 

7 Select Next Twice. 

8 Select Compute Stock size from the size of the part. Set all data fields to 

zero. 

 

9 Select Next. 

 

10 The datum will be -7mm. Leave this as it is as it will set to the Part which is 

inside the Stock solid. 
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11 Select Finish. Select No to Hole Features. 

 

12 Select Next. 

13 Say No to Automatic Feature recognition. 

 

 

14 Select Next. 

15 Select Yes to extract the turned profile.  

 Because we have two solid models. Both profiles are extracted. 
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 This will extract the 2D Geometry from the two solids we have 

imported. 

16 We can use this Geometry to create Curves to create Stock and machine the 

Part complete. 

17 Select Finish. 

 The geometry shown has been created from the Solid Models. 

 

 We have a number of ways to create Stock from the imported 

information. 

18 We can use the larger Solid model and define this solid as stock or 

Create a Curve from the outer shape Geometry and define this as a Stock Curve.  

19 Remember to hide the solid models so you can see the Geometry. 

20 In this case my stock Curve is called Curve5 your curve will be called a different 

Name. 

21 Double click on Stock1 in Part View. 
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22 Select Stock Curve. 
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23 Or alternatively use the User Defined button and select the Stock Solid. 

24 From the Geometry you have extracted have a go at machining the Part. 

25 Once completed have a go at  Solid Stock-3 - All Models .x_t 

Feature Recognise additional models   

 Location of files C:\Training_Data\FeatureCAM Course Data 

2017\Turning Files to import 

  

1036_Autodesk-A_01.x_t 

1036_Autodesk-B_01.x_t 

1036_Autodesk-C_01.x_t 

1294_Autodesk-D_01.x_t 
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