
Automated to make parts 
faster
Training Course





 
 
Introduction to FeatureCAM Wire 

                           

 

      
Autodesk FeatureCAM 2017    

© Copyright 2016 Autodesk, Inc. All rights reserved           1.1 

 

Contents 

  FeatureWIRE (EDM) ........................................................................................... 3 

Introduction ................................................................................................................. 3 

Electrical Discharge Machining ................................................................................... 4 

Starting  FeatureCAM ........................................................................................... 5 

Evaluation Options......................................................................................................... 5 

Desktop Subscription ..................................................................................................10 

Access options .............................................................................................................10 

Flexible term lengths ...................................................................................................10 

Access to the latest software .....................................................................................10 

More about updates and releases.............................................................................10 

Use your software in more places.............................................................................10 

Autodesk support .........................................................................................................11 

User Interface ...............................................................................................................11 

View Cube .....................................................................................................................12 

Manipulating orthogonal views ..................................................................................13 

Configuring the ViewCube..........................................................................................13 

Setting ViewCube options ..........................................................................................13 

Browser .........................................................................................................................14 

Steps ..............................................................................................................................14 

Saving your work .........................................................................................................17 

Save Options ................................................................................................................17 

Send Part Files dialog .................................................................................................18 

Size confirmation .........................................................................................................19 

FeatureCAM file types.................................................................................................20 

Documentation tab.......................................................................................................20 

Preview Picture tab......................................................................................................21 

Saving your settings ....................................................................................................22 

Import/Export ................................................................................................................23 

Import/Export Options .................................................................................................23 

General tab ...................................................................................................................23 

Solid import tab ............................................................................................................25 

Importing Files ..............................................................................................................26 

Mouse buttons ..............................................................................................................27 

Left mouse button Picking and selecting .................................................................27 

Middle mouse button Dynamics. ...............................................................................27 

Right mouse button Special Menus & FeatureCAM Options. ..............................28 

Viewing Options ...........................................................................................................29 

Reset to PowerMILL Settings ....................................................................................29 

Viewing Options General ............................................................................................30 

Viewing Options Machine ...........................................................................................31 

Display options .............................................................................................................32 

Principle views..............................................................................................................32 

Keyboard shortcuts......................................................................................................33 

Commonly used Ctrl Keys ..........................................................................................35 



              
 

                  
                 Introduction to FeatureCAM Wire 

 

                                                                                                                                      
                                                                                                              

 Autodesk FeatureCAM 2017   

1.2                                                                                                                  © Copyright 2016 Autodesk, Inc. All rights reserved 

User interface: Keyboard shortcuts...........................................................................36 

Blanking model entities ...............................................................................................37 

Show menu ...................................................................................................................37 

Hide Menu .....................................................................................................................38 

Highlighting objects from Part View  .........................................................................39 

Setting file location options.........................................................................................40 

Stock dimensions .........................................................................................................41 

Stock Types available (Information Only) ................................................................43 

N-Sided..........................................................................................................................45 

User Defined – Stock Solid ........................................................................................46 

Stock Curve ..................................................................................................................46 

Stock – Material ...........................................................................................................46 
 

  



 
 
Introduction to FeatureCAM Wire 

                           

 

      
Autodesk FeatureCAM 2017    

© Copyright 2016 Autodesk, Inc. All rights reserved           1.3 

 

   FeatureWIRE (EDM) 

Introduction   

This module will familiarize you with Autodesk FeatureCAM’s history, describes 

what FeatureCAM is and show how it is advantageous over other CAM systems. 

In this FeatureWIRE module the user will learn the basic user interface such as tool 

bars, menus and how to make certain functions become the default which can reduce 

programming time by using these predetermined settings.  You will learn about  

drawing with geometry and using curves and the added benefit of using solid models 

and Feature Recognition and each of these will be used to create simple 2Axis and 

more complicated 4Axis features.   

Ease of use is another guiding principal of FeatureCAM products. Our system was 

originally developed as a graphical Windows-based program. FeatureCAM programs 

are full of graphical feedback, Step-by-Step Wizards and tutorial-style animations 

that run directly in the program dialog boxes. Ease of use has always been a 

FeatureCAM advantage and we continue to study ways to make our system even 

easier to learn and use.  
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Electrical Discharge Machining 
 The process of wire erosion enables you to cut difficult to machine 

conductive materials with tremendous accuracy. Parts can be from 

less than 1mm up to 450mm in thickness and very small from a few 

grams up to 400kg in weight. Wire erosion can cut tungsten carbide, 

exotic steel alloys, titanium and aluminium – in fact as long as it 

conducts electricity it can be cut with Wire EDM. 

 With an electrically charged wire machine (EDM). A spark jumps 

from the wire to the work piece and the material is locally vaporized, 

the wire never contacts the part. The wire diameter is  typically 

0.025mm 

 Simply draw your shape and create the feature. 

 

  

  



 
 
Introduction to FeatureCAM Wire 

                           

 

      
Autodesk FeatureCAM 2017    

© Copyright 2016 Autodesk, Inc. All rights reserved           1.5 

Starting  FeatureCAM 

 

 Select the FeatureCAM icon  from your desktop and select New 

File and Wire EDM Setup and Millimetre. Select Finish twice and then 

Ok to close the Stock menus. The stock menu will be c overed later on in 

the training notes. 

 

 

Evaluation Options 

 

1 Click on the shortcut  that is on the Desktop. This will start 

FeatureCAM. 

2 When it has finished cancel the new Part document wizard that is on the 

screen. 
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3 Go up to the top left of the screen and go to the File menu. Then Select 

Evaluation Options. 
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 FeatureCAM has now been split into three levels. Standard, 

Premium and Ultimate. The next few images show the available 

options for all modules. 

  The image below show the available options in Standard 

FeatureCAM 

 

 It is here that you will see the activated products that you have 

purchased.  
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 The image below show the available options in Premium 

FeatureCAM. 

 

 It is here that you will see the activated products that you have 

purchased.  
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 The image below show the available options in Ultimate 

FeatureCAM. 

 

 It is here that you will see the activated products that you have 

purchased.  
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Desktop Subscription 

 This is what you get when you subscribe:- 

 Individuals, teams and enterprises have more choices than ever before 

Regardless of the size of your business - small, mid-size or enterprise.  

 Autodesk offers the flexibility to choose the subscription options that best 

fit your business needs. 

 Try out new tools without making a big up-front investment. 

 Better manage changing software and budget needs. 

Access options 

 When subscribing, select the option for access and use of your 

software: 

 Single-user access - best for when software is needed for one person 

 Multi-user access - ideal for situations in which you need more than one 

person to share software licences 

Flexible term lengths 

With monthly, quarterly, annual and multi-year options, you can get exactly 

the software you need for as long as you need it. 

Access to the latest software 

 When you subscribe, you have instant access to the latest product 

releases and enhancements. 

 Stay current on the latest software rather than waiting for major product 

releases 

 Update software straightaway or choose a time that is right for your entire 

team. 

More about updates and releases 

 Software when you need it, where you need it . 

Use your software in more places 

 Use your software in more places with access to both current and 

preceding versions. 

 Access preceding versions :- 

You will be able to download and use preceding releases of most Autodesk 

software. 

More about preceding version rights :- 

 Use your software at home - Access both current and preceding versions 

of your software on your home computer. 

More about home use rights. 
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 Use your software when travelling :-  

 Use your software and services globally when travelling outside of your 

home country. More about global travel rights 

Autodesk support 

 Let us help you to resolve issues quickly. You will have access to: 

 Senior Autodesk support specialists. 

 Moderated community support forums. 

 E-learning opportunities and exclusive training web casts New Part 

Document. 

User Interface 

 

 The user Interface is the entire viewing area of FeatureCAM and is designed 

to be intuitive, easy to use and provides the many functions to assist you in 

creating programs accurately and in the fastest possible time. 

 

 

  Menu Bar Located at the top. Like many other Windows based software; 

FeatureCAM includes a series of drop down menus.  These menus are unique 

to FeatureCAM and provide one or more functions used to facilitate the 

constructing, manufacturing, viewing and editing of your part program.   

 Part View Located behind the Steps.  This area gives a listing and provides 

access to the properties of the stock, setups, features, curves, (surfaces and 

solids when available). 
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 Steps Located on the left side.  A systematic sequence to guide, especially 

the beginner, as to the order of which needs to be completed first, second, etc. 

 Graphics Window Located in the center.  This is where most of the activity 

takes place. These activities include: creating stock, importing drawings, solid 

and surface models, constructing geometry, chaining with curves, creating 

features, and simulating the tool path in 3D or center line of the wire. 

 Geometry Bar Located near the bottom.  This area is constantly used and 

is where the dimension boxes are used to locate the geometry on your stock 

material in the Graphics Window. 

 Status Bar Located at the very bottom of FeatureCAM.  It displays the 

plane you are working in (XY–XZ-YZ), the unit of measure (Inch-Metric), the 

layer you are working in, the active setup, post processor, and how many CPU 

cores are being utilized. 

 Results Located on the right side.  It contains the Operation list.  Whereas 

the Part View contains all of the features, the Operation List contains all of the 

hits.  It also provides the details of each operation, including a tool list. The NC 

code is also here.  All of the information residing in this area may be printed. 

 View Cube 

View Cube 

 
The ViewCube is a new feature in FeatureCAM, which enables you to change 

and identify the viewpoint of the Graphics window. By clicking the ViewCube’s 

corners, faces, edges, and icons, you can use it to directly manipulate the view 

in the Graphics window. In addition, when you re-orient the view using a cube 

option, toolbar button, or keyboard shortcut, the ViewCube automatically 

reflects the new viewpoint.  

 

The ViewCube is displayed in the upper-right corner of the Graphics window. 

Click and drag the cube to re-orient the view in any direction. Alternatively, 

click:  

 A face to show it as an orthogonal view.  

 An edge to show the adjacent faces.  

 A corner to show the three adjacent faces.  
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In addition, when you move the cursor near the cube, the Home icon is 

displayed. Click the icon to show the Home view.  

Manipulating orthogonal views 

When you select a single-face view and move the cursor near the cube, control 

icons are displayed: 

Click: 

To show the view of an adjacent face.  

To rotate the view clockwise through 90 degrees.  

To rotate the view counter-clockwise through 90 degrees.  

Configuring the ViewCube 

To control the behaviour and appearance of the ViewCube, right -click the cube 

and choose a menu option. Select: 

 Set current view as home and keep scale to save the current orientation 

and magnification of the model as the Home view.  

 Set current view as home and scale to fit to save the current orientation 

of the model as the Home view, and scale it to fit the Graphics window.  

 Options to display and change the settings of the ViewCube. The 

ViewCube tab of the Viewing Options dialog is displayed. 

Setting ViewCube options 

To modify the behaviour and appearance of the ViewCube, set these options on 

the ViewCube tab of the Viewing Options dialog: 

 Show the ViewCube — Select this check box to show the ViewCube in the 

Graphics window. Deselect the check box to hide it.  

 ViewCube size — Select an option from the list to choose the size of the 

ViewCube in the Graphics window. Alternatively, select Automatic to resize 

the cube when you resize the Graphics window.  

 Keep model upright — Select this check box to prevent the view from 

being inverted. If you click an edge, corner, or face that would leave the 

view upside down, the Graphics window switches to the selected view and 

then rotates to leave the view upright. 

  Tool Bars Located in View and Toolbars. Tool Bars are usually located 

at the top but may be docked in other locations. Can consist of one or more 

buttons and are used to create objects in the Graphics Window, such as the 

Geometry constructors for drawing the shape of your part.   
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Browser  

Located on left side “Toolbox” below Steps.  Your computer must be 

connected to the internet and the Browser provides a direct link to the 

internet.  Learn about the Browser by participat ing in the various sections 

with downloadable examples on the opening page then Click on the links 

and explore the contents. 

 

Steps 

 The basic interface has three different sections.  On the left is the Steps 

toolbar.  

 The steps toolbar is an outline for the flow of the program.  The steps are 

numbered sequentially in the order they should be executed and can be a 

guide for creating your part.   

 For example suppose you have a 2D drawing on your desk and would like 

to create a solid model and a CAM program for it.  To do this we would follow 

the steps sequentially: 

  

 Specify type of stock and stock dimensions,  

 Draw Geometry 

 Create Curves from Geometry  

 Create Surfaces (ignored since creating a solid model)  

 Create Solid from Curves.   

 No AFR for Wire Features  

 To view toolpaths and  

 To generate NC Code 

 

 You can access a majority of FeatureCAM’s functions through these 

buttons.  A summary of each steps function follows. 
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 Note: We recommend that if you are just starting out with the program 

or demonstrating it to others that you use the steps toolbox instead of 

toolbar buttons in other areas of the interface to keep the interface 

simple.  

 

 Step 1 - Stock.   The Stock Wizard steps you through entering the shape 

and dimensions of the stock, the stock material, part program zero and the 

coordinate system for modeling.   

 Step 2 – Geometry.  Points, arcs, lines and other shapes are used to 

describe the overall shape of parts.  Many different geometry tools are 

available.  Geometry can also be imported from CAD systems. 

 Step 3 – Curves.   Shapes that involve more than a single line or arc are 

described as curves  

 Step 4 – Surfaces, opens the surface wizard 

 Step 5 – Solids, opens the solid wizard 

 Step 6 – Not available for Wire.  AFR (Automatic Feature Recognition) 

 Step7 – Features.   Features are common shop terms like pocket, or side.  

They are created from curves and dimensions.  These objects describe your 

part in 3D and are used to generate toolpaths.   
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 Step 8 – Toolpaths.  Toolpaths are generated from collections of features.  

You can simulate them in FeatureCAM using toolpath center lines, 2D 

shaded or 3D solid shaded simulations.   

 Step 9 – NC Code.  Machine-specific G-codes are generated from the 

toolpaths.  Translators are provided for many different NC controls and 

include a program for creating new translators.   

 Customize Manufacturing. FeatureCAM automates the entire part 

programming process; you can customize all of the system settings 

including feed/speed tables (Stock Properties), tooling databases (Tool 

Manager) or feature settings (Machining Configurations in another Module). 

 Note: In Steps, some steps may not be displayed depending on which 

options you have purchased or have turned on. 

 

 Above the Steps Toolbar is the Part View Tool Box.  This contains the 

names of the objects that are created on the screen. Objects that can be 

contained in this area are Stock, Setups, Curves, Surfaces, and Solids etc . 

 Clicking on the objects in the part view enable different functions.  Left-click 

selects the object in the graphics window.  Right-click reveals menu of 

options available for the object. Clicking on a “+” to expand the view will 

reveal objects that are subordinate. 

 On the right is the Manufacturing Results Window.  The automatically 

generated documentation and part programs are shown in this window.   
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Saving your work 

 Question? What is the difference between Save and Save as? 

 Answer: When you are working on a document, it is a good idea to save 

your work every couple of minutes. In the File menu of the program, you 

will typically find the options "Save" and "Save As" 

 Choosing "Save" simply saves your work by updating the last saved version 

of the file to match the current version you see on your screen. 

 Choosing "Save As" brings up a prompt to save your work as a file with a 

different name. For example, you might choose to save a document called 

"FeatureCAM_opp1". This way, you can save you file at different stages 

and keep multiple versions on your hard drive. 

 Choosing "Save" and then "Save As" is also a good way to make a backup 

of your file. Just be sure to rename the file something new when you choose 

"Save As" or you will overwrite the current saved version, just like choosing 

the "Save" command would do. 

Save Options 

 In the File menu you have save options. 

 

 See Save Options on the next page. Adjust your computer to the same 

as the options shown. 
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 Create backup copy: - Select this option to save a number of previous 

versions of your part as you work. Enter the Number of copies to keep 

and set the Backup location. When you save a file, the previous version(s) 

are saved to disk using the name, but prefixed with Backup of. The latest 

version of the file is always saved using the name of your FeatureCAM part.  

 Save preview picture in file: - Select this option to store an image of the 

part in the file. This image is displayed in the Open dialog. 

 Save computed toolpath: - For certain parts, generating toolpaths can be 

time-consuming and you may want to save them for the next time you open 

a part. The setting of save computed toolpath controls the default behaviour 

for saving toolpaths. Select from Always save, never save, or ask me to 

be prompted each time you save a part. The toolpath is saved as an .fmp 

file. 

 This is different than saving the NC text file that the NC machine 

reads. Instead you are saving the FeatureCAM internal toolpath 

representation.  

 If you upgrade to a newer version of FeatureCAM, the toolpath is 

disregarded and recomputed.  

 Click the OK button to save your settings and close the dialog.  

 Cancel: - Click the Cancel button to close the dialog without saving any 

changes.  

 Help: - Click the Help button to open this Help topic. 

Send Part Files dialog 

 To display the Send Part Files dialog, select File > Send from the 

menu. 
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Select the files you want to send from:  

 Part document: - The current .fm file.  

 Milling post: - The current milling .cnc file.  

 Turning post: - The current turning .cnc file.  

 Wire EDM post: - The current Wire EDM .cnc file.  

 User interface settings: - The .ini file containing your user interface 

preferences.  

 Machine design files (.md): - the current .md file.  

 Crash and performance logs: - Select this option to create a separate 

.zip file of your system's crash and performance logs.  

 Select how you want to send the files:  

 As individual files: - The individual files are attached to a new email.  

 As a zip file: - The files are zipped and the .zip file is attached to a new 

email.  

 Save to desktop: - The files are zipped and the .zip file is saved to your 

desktop.  

Size confirmation  

 If you are sending .zip files, a Size Confirmation warning dialog is 

displayed:  

 The average email server limits attachments to 10 MB.  

 The total size of the attachment(s) is: N (where N is the size of your 

attachment. 

 Would you like to continue sending?  
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 Click Send to attach the files to an email.  

 Click Don't Send to keep the files on your desktop.  

 Click Cancel to discard the files.  

FeatureCAM file types 

You can save several different types of files for your part.  

 .op is the Manufacturing Operation Sheet and is the same information 

shown on the Details tab when you select Operation List.  

 .tl is the Manufacturing Tool Detail Sheet and is the same information 

shown on the Details tab when you select Tool List.  

 .txt is a text file containing the NC code for the particular part file.  

 .tdb is a FeatureCAM tooling database that contains just the tools you 

used to create the part.  

 .fdb is a FeatureCAM material database that contains the feed and speed 

tables used for the part.  

 .cdb is a FeatureCAM machine configuration database that contains the 

settings for default attributes. Part Documentation 

The Part Documentation dialog enables you to add comments to the printed 

documentation and set a permanent preview picture for the part.  

 To display the Part Documentation dialog, select File > Part 

Documentation from the menu.  

 The Part Documentation dialog contains two tabs: Documentation and 

Preview Picture  

Documentation tab 

 On the Documentation tab of the Part Documentation dialog, optionally 

enter a Title, Author, Company, Part/Drawing No., Revision, Note 1, 

Note 2, and Comments.  

 To print these values along with the documentation, select Comments in 

the Printing Options dialog.  
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 If you use the custom setup sheet add-in, these values are copied 

to the Setup Sheet Options dialog.  

Preview Picture tab  

On the Preview Picture tab of the Part Documentation (see page 95) 

dialog, you can set a permanent preview image for the part. This image is 

displayed in the preview pane in the File > Open dialog when you select a 

file.  

This image is normally updated each time you save the part. If you want to 

store a permanent image with the part:  

1 Create the view of the part you want to store.  

2 Click Update preview picture  

 The current view in the graphics window is displayed as the 

Current preview picture, for example: 
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3 Click OK to save the preview picture or Cancel to close the dialog without 

saving the preview picture.  

Saving your settings 

 FeatureCAM uses two .ini files to store your settings:  

 Ezfm_ui.ini contains toolbars, dialog locations, graphics settings, colours, 

and other user settings.  

 Ezfm_mfg.ini contains manufacturing defaults and .cfg settings.  

The ezfm_mfg.ini file contains default values for both inch and metric  

attributes. For example, there is an entry for zrapid in inches and also an entry 

for zrapid_mm in mm. In general, the name for the metric attributes is the 

same as the inch name, with a suffix of _mm.  

 There are three items from the Options menu affect the 

communication with the ezfm_ui.ini and ezfm_mfg.ini files:  

 Options > Save Settings Now: - Writes the current settings to the files.  

 Options > Reload Settings: - Reads the settings contained in the files into 

the program.  

 Options > Save on Exit: - Saves the current settings when you exit the 

program. If this option is not selected, the settings for your current session 

are not saved to the files when you exit. 
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Import/Export  

 You can import and export various file types into and from FeatureCAM.  

 The settings for import and export are in the Import/Export Options  

 To open this dialog select File > Import/Export Options from the menu. 

Import/Export Options 

 The Import/Export Options dialog contains settings for importing and 

exporting.  

 To display the Import/Export Options dialog select File > 

Import/Export Options from the menu.  

 The dialog has three tabs:  

 General  

 Solid Import  

 Digitized Data  

General tab 

 The General tab controls how FeatureCAM Imports or Exports files. It 

contains the following options:  
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 Always replace object on import: - Select this option to overwrite 

objects of the same name when you import. Deselected prompts for every 

replacement. You can’t have two objects with the same name.  

 Smooth EZ-MILL curves: - Select this option to improve EZ-MILL curves 

on import because FeatureCAM has a higher resolution curve format.  

 Keep IGES import log file: - Select this option to keep a log of the 

import process for later review or troubleshooting.  

 IGES log file name: - Enter the path and filename for saving a record of 

the import process.  

 Import IGES entity of type:  

 Logically dependent: - can exist by itself but is also referenced by 

another entity (case of groups or grouping situation).  

 Physically dependent: - generally, you should deselect this option to 

indicate you do not want physically dependent entities to be imported. But 

if you are having trouble with your IGES file and it is not importing 

properly, try selecting this option and re-importing. Entities in an IGES file 

are marked to be either physically dependent or not. Those that are 

marked to be physically dependent are entities that are used in the 

construction of other entities. For example, a trimming loop is physically 

dependent upon the trimmed surface that uses it. The trimming loop is not 

important all by itself, but is instead a building block of something else. 

The trimmed surface is in turn marked physically dependent to indicate 

that it is a building block of a parent entity, a solid 
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 By selecting physically dependent, you cause FeatureCAM to show 

everything in the IGES file - not just the top-level entities that are usually 

shown, but also all of the lower-level building blocks. This is generally not 

what you want. Generally you want only the top-level entity, for example 

the solid.  

 Both physically and logically dependent: - meets both logically and 

physically dependent criteria (is referenced by at least two other entities: - 

the parent for the logical link cannot be the parent for the physical as well).  

 Centre stock automatically: - Select this option to automatically size and 

position the stock so that it covers the imported data.  

 Number of decimal places in IGES export: - determines how finely data 

is exported to the IGES format. 

Solid import tab 

The Solid Import tab contains the following options: 

 

 Heal Catia solids: - Select this option to try to repair the faces or surfaces 

contained in the CATIA .mod file. This option can be time-consuming 

because it attempts to:  

 Re-trim the surfaces/faces against each other.  

 Force edges of surfaces to actually lie on the surface.  

 Simplify surfaces like converting a general surface into a cylinder.  

 Import hidden Catia V5 solids: - Select this option to import all parts 

contained in the CATIA file even if those parts are hidden.  
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 Import file as solids: - Select this option to import files as solid models. 

If this option is deselected, the models are imported as surface models. We 

recommend that you import models as solids. If this option is selected and 

the solid fails to import properly, you are asked if you would like to attempt 

to heal the solid to try and fix the import problem.  

 Import work planes: - When selected, planar surfaces in solids are 

imported. When deselected planar surfaces in solids are ignored.  

 Stitch IGES surfaces into solids/sheets: - Select this option to try to 

create one or more solids or sheets from an IGES file. If an IGES file contains 

more than one solid or sheet, this is the most efficient way to create the 

multiple objects from the file. 

Importing Files 

Use the File > Import menu option to load a CAD model from file.  

To import a CAD model from a file:  

4 Open a new or existing part file. You must have a part open to import 

geometry.  

5  If you want to set or change the import options, select File > 

Import/Export Options.  

6 Select File > Import from the menu. The Import dialog is displayed.  

7 Select the file you want to import, and click Open.  

 A message asks if you want to review the log file: click Yes to 

display the results, or click No to continue. The Import Results 

wizard is displayed.  

8 Follow the instruction in the wizard to complete the process.  

 

 Please note that some of the file types are extra cost options 

 Unless you have specifically ordered the FeatureCAM .step or Stp 

file import, you might get an error to say that this option needs to 

be licenced.  

 If this is the case then use the Import using exchange where the 

.step file import option is free. 
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 Wherever possible avoid importing .iges files. 

 Please import solid models, where possible. The best option is 

Parasolid which has a file extension of x_t or x_b which is a binary 

file which is compressed. Another file format is .SLDPRT which is a 

SolidWorks file. 

Mouse buttons 

 Each of the three mouse buttons performs a different dynamic operation in 

FeatureCAM.  

 

 

Left mouse button Picking and selecting. 

 This button is used for Selecting Items of the pull down menus, options 

within forms, and entities in the graphics area. 

 

Middle mouse button Dynamics. 

 In these options, you can set the behaviours to be specific viewing modes 

such as Trackball, Rotate, Pan, Zoom, Pan and Zoom, and so on, or 

choose the Current Viewing Mode option that allows the middle-mouse 

button (along with key combinations) to perform the viewing mode that is 

currently set in the toolbar. 
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 The most commonly used mouse feature is to hold the Centre wheel down 

and moving the mouse, this will rotate your part. Hold the shift key down 

at the same time and you can Pan anywhere on the screen. Hold the shift 

key down and where ever the mouse is it will zoom to that point by using 

the Wheel. This is excellent for looking closely at your component. 

 Zooming in and out: - Hold down the Shift key and mouse button 2. 

Move the mouse up and down to zoom in and out. 

 Pan around the model: -Click once with mouse button 2 to position in the 

Centre of the screen. Click and hold to zoom and then move the mouse in 

the required direction. 

 Zoom Box – Hold down mouse buttons 1 and then button 2, drag a box 

around the area to zoom. Release both buttons at the same time. Rotate 

mode: Hold down the Ctrl key and mouse button 2. Move the mouse up 

and down to zoom in and out. 

Right mouse button Special Menus & FeatureCAM Options. 

 

 When this button is pressed it brings up a local menu relating to whatever 

the Mouse Pointer is over, such as a named item in the FeatureCAM Part 

View or a physical entity in the graphics area. If nothing specific is selected 

the View menu appears.  
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Viewing Options 

 

 For those users who are already familiar with other Autodesk ® products 

DON’T PANIC!  Just do the following. 

 View changes the way you interact with the view of the part. Selecting 

any of the options from the View menu puts you in view mode. 

 Dynamic Viewing Options. 

 Dynamic Viewing Options tab, you have two choices to reset the settings 

to: 

Reset to FeatureCAM Settings  

This button resets all the options in the dialog to FeatureCAM defaults, 

which are: 

 Dynamic Viewing Choice upon FeatureCAM Start-Up - Pan and Zoom  

 Middle-mouse button behaviour - Current Viewing Mode  

 Middle-mouse button with Shift - Pan and Zoom  

 Middle-mouse button with Ctrl - Rotate  

 Middle-mouse button with Ctrl+Shift – Zoom 

Reset to PowerMILL Settings  

 This button resets all the options in the dialog to PowerMILL defaults, 

which are: 

Dynamic Viewing Choice upon FeatureCAM Start-Up - Trackball  

 Middle-mouse button behaviour - Trackball  

 Middle-mouse button with Shift - Pan  

 Middle-mouse button with Ctrl - PowerMILL Pan & Zoom  
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 Middle-mouse button with Ctrl+Shift - Box Zoom 

 This menu controls the default viewing mode when FeatureCAM first opens. 

For example, if you select Trackball, the next time FeatureCAM starts up, 

the viewing mode is Trackball. 

Viewing Options General 

In the General Viewing Options we now have the ability to change the size of 

the Snapping point. By default this size is normally 4 pixels. In order to create 

larger points, change this to 8 pixels. 

 

 

 An example of this is shown below 
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Viewing Options Machine 

 When viewing machine axis, by default the view is shown vertical: If you 

have a Horizontal machine or a Mill/Turn machine (Vertical turret lathe) use 

this option to change the view. 

 Milling — Select the type of milling machine from Vertical and Horizontal, 

to improve viewing during machine simulation and tool previews. 

 Turning — Select the type of turning machine from Slant bed lathe and 

Vertical turret lathe, to improve viewing during machine simulation and 

tool previews. 

 Swiss turn, main spindle vertical y axis – This setting is used when 

using the FeatureCAM Swiss module. 
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Display options 

 For the best Display Options for your computer set the NVidia ® 

Control Panel options to the following. 

 

 All of the viewing options are available via Right mouse button.  

Click in the Main Graphics Area 

Principle views 

  Changes to a view of the part from the front with no other 

surfaces visible. 

  Changes to a view of the part from the back with no other 

surfaces visible. 

  Changes to a view of the part from the left side with no other 

surfaces visible. 

  Changes to a view of the part from the Right side with no 

other surfaces visible. 

  Changes to a view of the part from the top only. Useful for 

drawing geometry, but harder to see the wireframe model of the part. 

  Changes the view to the bottom of the part. No sides of the 

part are visible from this perspective. 
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 Right Click in the graphics area to show this menu. 

 All the viewing modes are available, plus an option called Mode from 

Last Session. This option keeps track of the viewing mode last set 

before FeatureCAM was closed, and uses that viewing mode the next  

time FeatureCAM starts up. For example, if the option is set to Mode 

from Last Session, and you had set the viewing mode to rotate before 

you closed FeatureCAM, Rotate is the viewing mode that is set in the 

toolbar the next time you open FeatureCAM. 

 Isometric - changes the view to a three quarter view of the part 

showing the top and two sides with the current UCS near the bottom of 

the viewing area. 

 Perspective - If selected, the view is a perspective view. If 

deselected, the view is an orthographic view. 

 As on setup - If selected, the view is relative to the current setup. If 

deselected, the view is relative to the world coordinate system. 

 As on UCS - changes your view to that of the current UCS. 

 As on world - changes your view to that of the current UCS. 

Keyboard shortcuts 

 You can use the keyboard to navigate around the menus. To do this, 

press and hold the Alt key, and then press the letters on your keyboard 

that correspond to the letters underlined on the Menu bar and in the 

menu options. For example, to rotate your part, press and hold the Alt 

key, press V for View menu, press V for Viewing Modes and press R for 

Rotate. 
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Key sequence Action 

Alt+click-and-drag on any toolbar button Move button around in toolbar. 

Alt+1 (2,3,4) User View 1 (2,3,4) 

Alt+Enter Properties 

Alt+F1 Centreline simulation. 

Alt+F2 Play/pause simulation. 

Alt+F3 Single-step simulation. 

Alt+L Last view. 

Alt+R Refresh 

Alt+Shift+V Save view. 

Ctrl+click a column of any list box that does 

sorting 

Activates the second level of sorting. 

Ctrl+click a viewing mode button Stay in that viewing mode. 

Ctrl+click the 3D Simulation button. 

Release key and click the Play button. 

Run 3D simulation in hidden line mode and 

do continuous looping. 

Ctrl+click Fast Forward to End  Stops the simulation when it encounters the 

next rapid (in addition to the next 

operation). 

Ctrl+click the Machine Simulation 

button. Release key and click the Play 

button. 

Run machine simulation in hidden line mode 

and do continuous looping. 

Ctrl+A Select all. 

Ctrl+C Copy 

Ctrl+E Centre selected. 

Ctrl+F Find (text in a text window). The cursor 

must be in a text window. 

Ctrl+H Replace (text in a text window). The cursor 

must be in a text window. 

Ctrl+L Centre all. 

Ctrl+N New file 

Ctrl+O Open file 

Ctrl+P Print 

Ctrl+R Opens the New Feature wizard. 

Ctrl+S Save file 

Ctrl+V Paste 

Ctrl+X Cut 

Ctrl+Y Redo 

Ctrl+Z Undo 

Ctrl+click the Pick Curve button Causes the warp status for that dialog to 

toggle. 

Ctrl+click the Pick Curve button while a 

Key sequence 

Toggles between simulation of the selection 

feature and the entire setup. 

Ctrl+click the Play button Run simulation in hidden line mode. 

Hold Ctrl while toolpath is being computed Temporarily turns off Toolpath Computation 

Minimization. Toolpaths will be recomputed 

for all features even if that feature did not 

change. 
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Ctrl+Alt+click-and-drag on any toolbar 

button 

Duplicate and move button around in 

toolbar. 

Ctrl+Shift+click the 3D Simulation 

button. Release keys and click the Play 

button. 

Continuous loop simulation for 3D 

simulation. 

Ctrl+Shift+click the Machine Simulation 

button. Release keys and click the Play 

button. 

Continuous loop simulation for machine 

simulation. 

Ctrl+Shift+A Shade selected. 

Ctrl+Shift+C Unshade all. 

Ctrl+Shift+N Unshade selected. 

Ctrl+Shift+P Toggles perspective. 

Delete Delete the selected object 

Double-click a simulation button 

 

Activate that simulation without clicking the 

play button.  

Esc Stop current simulation. 

F1 Context-sensitive help. 

Middle-click-and-drag in the graphics 

window 

Performs viewing based on the current 

viewing mode. 

The mouse wheel-click-and-drag also 

performs this function. 

Mouse scroll wheel Zoom 

Shift+click an edge when filleting Selects all edges of the face and adds them 

to the list. 

Shift+click the NC Code tab Show ACL instead of NC code. 

Shift+click while clipping when Multiple 

Region is On 

Removes the entire picked region instead of 

to the nearest intersection. 

Shift+right-click in graphics window Dynamic viewing using current view mode. 

Shift+click the Show button in the SCL 

dialog 

Brings up a dialog that shows the attributes 

of the model selected in SCL dialog. 

Commonly used Ctrl Keys 

 New Document - Ctrl + N 

 New Feature Menu or Ctrl + R  

 Isometric View or Ctrl + 1 

 Top View or Ctrl + 5 

 Refresh - Alt + R 
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User interface: Keyboard shortcuts 

 There is a new tab in the Customize Toolbars dialog, Keyboard 

Shortcuts: 

 

 This tab lets you assign your own shortcut keys to the FeatureCAM 

menu commands. To set a new shortcut key: 

 Select a category from the Categories list.  

 Select a command from the Commands list.  

 If the command already has a shortcut, it is listed under Current 

keys. 

 To assign a new key, select the Press new shortcut key field and press 

the keys that you want to use as the shortcut.  

 Press the keys on the keyboard, for example, press and hold down the Alt 

key and press the N key; do not type ALT + N.  

 A warning displays if the shortcut you entered is already assigned to a 

command. 

 Click the Assign button to save the new shortcut.  

 If you click Assign after receiving a warning that the shortcut is already 

assigned to a command, the shortcut is removed from the existing 

command and assigned to the new command. 
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 Remove — Click this button to remove the shortcut assigned to the 

selected command. 

 Reset All — Click this button to reset all shortcuts to the FeatureCAM 

defaults. 

Blanking model entities 

 Use the Blank Selected (Ctrl + J) option to temporarily hide all visible 

components. 

 (Ctrl K) Hide Selected components 

 To re-display all of the components. Right-click in the graphics area and 

select Unblank (Ctrl L). The blanked model components are displayed. 

Please note this option will only work if you have set this up as explained in 

the previous chapter. 

Show menu 

 Show  functions help control what is displayed. This is useful as you place 

and model intricate features in a complex part. 

 You access the Show functions by selecting View > Show from the menu 

or using the Show Menu button on the Advanced toolbar: 

 

 Show All — Use this menu option to Show everything in the part model. 

 Show All Geometry — Use this menu option to Show all geometry 

(points, lines, arcs, and circles). 

 Show All Dimensions — Use this menu option to Show all dimension 

information added with the Dimensions Tool. 

 Show All Curves — Use this menu option to Show all Curves. 

 Show All Surfaces — Use this menu option to Show all surfaces (available 

only in FeatureCAM 3D). 

 Show All Features — Use this menu option to Show all features. 
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 Show All Solids — Use this menu option to Show all solids 

 Show All Vertical Surfaces — Use this menu option to Show the vertical 

surfaces in the model. This is useful for identifying surfaces that are part of 

2.5D features like holes or pockets contained in a surface or solid model.  

 Show Stock — Use this menu option to Show the stock outline. 

 Show Current UCS — Use this menu option to Show the current UCS icon. 

 Show Current Setup — Use this menu option to Show only the features 

and drawing elements that are in the current Setup. 

 Show Selected — Use this menu option to Show only the selected 

elements 

Hide Menu 

 Hide controls what is displayed at any given time. This is useful as you 

place and model intricate features in a complex part. Besides the display 

factors, you can’t snap, select or build curves from hidden entities. The Hide 

functions are not exclusive. You can click different buttons sequentially, 

hiding different entities until only the ones you want are still in view. 

 You access the Hide functions by selecting View > Hide from the menu or 

using the Hide Menu button on the Advanced toolbar: 

 

 Hide All — Use this menu option to hide all geometry, curves, Features. The 

stock and axis icon remain visible. A common procedure is to Hide  All, then 

Show only one type of entity, for example features. 

 Hide All Geometry — Use this menu option to hide all geometry. Other 

entities remain visible. 

 Hide All Dimensions — Use this menu option to hide all dimension 

information added with the FeatureCAM Dimension tools. 

 Hide All Curves — Use this menu option to hide all curves. Other entities 

remain visible. 
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 Hide All Surfaces — Use this menu option to hide all surfaces in the part 

model. Only available in the 3D version. 

 Hide All Features — Use this menu option to hide all features. 

 Hide All Points — Use this menu option to hide all points. 

 Hide All Non-Vertical Surfaces — Use this menu option to hide all surfaces 

that are not vertical relative to the current setup. This is helpful if you want 

to isolate the surfaces that are part of 2.5D features in a surface or solid 

model. 

 Hide All Solids — Use this menu option to hide all of the solid models. 

 Hide Stock — Use this menu option to hide the stock outline. All other 

entities remain visible. 

 Hide Current UCS — Use this menu option to hide the current user 

coordinate system. 

 Hide Current Setup — Use this menu option to hide the axis of the 

current Setup. All other entities remain visible.  

 Hide Selected — Use this menu option to hide all selected entities. Non 

selected entities are still visible. 

 Hide Unselected — Use this menu option to hide all entities other than 

the selected ones. 

Highlighting objects from Part View 

You can now highlight objects in the graphics window by moving the cursor over 

the object's name in the Part View. This enables you to find features quickly 

and improves the work-flow in complex documents. 

For example, move the cursor over an object in the Part View: 
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Setting file location options 

 It is a good idea to set the file location for where you will save your 

files. Please select Options/File Options/Existing Files. 

 

 

9  Select Browse. Then select the following location. 

C:\Training_Data\FeatureCAM Course Data 2017. 

10 Select Apply and Ok to close the form. When we save or import files 

FeatureCAM will take us to this location. 

11 Please save all files in Coursework. 

12 Tool Crib = BasicMetric or Training_Crib_Metric 

13 Post processor used = Fanuc_Robodrill.cnc 
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Stock dimensions 

14 Open FeatureCAM by double clicking the FeatureCAM shortcut  

15 Select New File. Wire EDM Setup. Select Finish. 
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16 Enter the dimensions of the stock. Stock Size = 100mm x 100mm x 26mm 

thick into the dimensions menu. Select Finish and the following menu will 

appear. Enter 1mm for Z to allow material above the datum. Select Finish. 
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 Notice the 1mm in the Z Menu. This adds 1mm above the Z Datum for 

machining off later when creating a Face Feature. 

 

 

Stock Types available (Information Only) 

 

Block 
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Round 

 

    

N-sided 

 

 

User-defined 

 Inside a FeatureCAM milling document there are several different Stock 

types.  The stock can be defined as a block material, a round material or 

N-sided and user defined material. We have already gone through this 

procedure with our second exercise.dxf file and resized the material around 

the part. 

 Selecting the Round Radio button you have an option to create Round 

Stock as shown below. 

 Please note: - You can define this stock as a tube by typing in a value for 

the ID as well as the OD.  
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This option is ideal for work held in a 3 or 4 jaw chuck on a 3 or 4 Axis 

vertical machining Centre. 

N-Sided 

 Select the N-Sided Radio button. When this button is pressed the stock 

can be defined along a specific axis with a multiple number of sides. The 

dimensions shown are just an example only. 
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User Defined – Stock Solid 

 

 

Stock Curve 

 

Stock – Material 
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17 From the Stock wizard you can select the Material, Specific Cutting Forces, 

Hardness and Hardness Units.  You can also access the existing Feed and 

Speed tables for the material or create a new Material. 
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 On this page of the Stock wizard you can select the Material, Specific 

Cutting Forces, Hardness and Hardness Units.  You can also access 

the existing Feed and Speed tables for the material or create a new 

Material 

 As shown by selecting Next the multi-axis positioning options will 

appear. 
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Wire Geometry Creation Techniques  

Introduction 

This module will provide an understanding of how different Snapping Modes  

work and how Geometry is created within FeatureCAM. By the end of the 

module the user will be able to construct Geometry and understand how each 

Snapping Mode functions. 

Snapping 

 Snapping Mode commands can be accessed in two different areas of 

the user interface. Select the Options menu then Snapping Modes. 

 

 

 Snapping Modes may also be accessed through the Snap Mode 

Toolbar (to show the Snapping Toolbar. Go to the View menu then 

Toolbars, then check the Snap Mode checkbox and select OK) (See 

image on the next page). 
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 Looking at each icon from left to right we will give a short summary 

of each item’s function: 

 

 

The Snap to Grid Points button displays a grid and enables snapping 

to the grid. Selecting snapping grids from the options menu controls the spacing 

of the grid.  Grid snaps to a point on a coordinate system that is laid out on the 

stock. The grid size can be modified from the Options menu. 

The Snap to Point button snaps to a point object. 

The Snap to Endpoint  Snaps to the ends of lines or arcs. Endpoint 

also applies to the corners of the stock and verticals of a Solid. 
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Snap to Midpoint  snaps to the middle points of lines and arcs. 

 

Snap to Section snaps equal intervals of a finite line.  The number of 

sections is controlled by the Sections parameter of the Snapping Grids 

dialog box.  

  

 Snap to Intersection snaps to the intersection of lines, arcs and 

circles.   

 

Snap to Centre snaps to arc and circle centres. This setting also 

controls the display of circle and arc center points.   

 

Snap to Quadrant snaps to the four points on a circle corresponding 

to 0°, 90°, 180° and 270°.   

 

Snap to Object snaps to a point on another object. This includes lines 

of surfaces and is convenient for snapping points to locations on a surface or 

Solid model.   

 

Snap to Tangent  snaps the point so that the object you are creating 

will be tangent to the object you snapped to.   

 

Snap to Toolpath  snaps to toolpath lines. 

 

Snap to Cylinder  snaps to Cylinder centres, top and bottom points. 

 

The Snap Discrimination dialog button displays the Snap 

Discrimination dialog box whenever there is an ambiguous pick. This dialog box 

will list the possible points to snap to and ask you to pick the one you want.  
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Drawing conventions when using Autodesk products. 

 

 When you start using Autodesk products and start to construct 

Geometry, the illustration above clearly shows you the directions of the 

cardinal drawing angles and positive and negative directions. This should 

help when creating the exercises in this chapter.  

User Interface 

Geometry constructor commands can be accessed in three different areas of 

the user interface.   

 Commands can be accessed by clicking the Geometry  

icon in Steps:  
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 This can also be accessed through the Construct Menu. 

 

 Or may be accessed by the Geometry Toolbar  

 

 To show the geometry toolbar click on View>Toolbars, then check 

the Geometry checkbox and press OK 
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 The geometry toolbar uses flyout menus.  The last item previously 

selected is displayed as an icon in the tool bar. 

 

 Click on the triangle  to reveal the flyout menu. 

 These flyout menus are used throughout FeatureCAM and are 

useful for easy access to many program functions. 

 The following Menus show the Geometry creation options available. 

Line 
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 2 Pts: - Line created with two endpoints. 

 Connected: - Multiple lines created in succession.  Endpoint of one line 

becomes start point of next line. 

 Horizontal: - Infinite horizontal line created through a point. 

 Vertical: - Infinite vertical line created through a point. 

 Pt. Angle: - Infinite line created through a point at an angle specified in 

degrees. 

 Offset: - Line, Circle or Arc created offset from another.  New lines have 

the same length as original 

 

 Click on the Select  icon at the top of FeatureCAM on the Standard 

Toolbar to cancel the line drawing. Use this button at any time to exit 

selection mode. Or press the Esc key at any time. 

Circle 

 

 Center, Radius:-  Creates a circle by clicking on the center and specifying 

the radius or dragging the mouse to a radius 

 Center, Edge:- Creates a circle by clicking once on the center then again 

on the edge 

 Diameter:- Creates a circle with two points with the diameter being the 

distance between the two points 

 Tangent Two:- Circle created by snapping the circle's edge tangent to two 

objects 

 2 Pts, Radius:- Creates a circle by specifying two points and a radius 

 3 Pts:- Creates a circle from three points 

Fillet 

 

 Corner Fillet: - Creates a Fillet in a corner originally defined by an 

intersection of lines or arcs. 

 Two point Fillet: - Creates a Fillet in a corner originally defined by an 

intersection of lines or arcs. 
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 Three points: - Defines a fillet by selecting three points, similar to the three 

point circle. 

 Chamfer: - Creates a Chamfer in a corner originally defined by an 

intersection of lines or arcs. 

Arc 

 

 Three points: - Constructs an arc through a start point, edge point, and a 

finish point. 

 Two points, radius: - Constructs an arc through two points with a specific 

radius. 

 Center, Beg, End: - Constructs an arc from a center point and given 

beginning and end points. 

 Center, Rad, Beg, End: - This selection constructs an arc with a specific 

center and radius with the starting and ending points determined by angles.  

Curve 

 

 Curves are paths in 2D or 3D space. You can create them in FeatureCAM 

or Import them from a CAD system. Curves can be open, or closed. Open 

curves have end points that do not meet. You can use open curves in the 

following Features Side, Groove, Rounds and Chamfer Features. 

Dimension 

 

 Horizontal: - creates dimension information based on the horizontal axis of 

the part. 
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 Vertical: - creates dimension information based on the vertical axis of the 

part. 

 Linear: - creates dimension information based on the absolute distance 

between two points regardless of the angle of the dimensioned space. 

 Radius: - creates dimension information for the radius of the selected 

object. 

Diameter: - creates dimension information for the diameter of the 

selected object. 

Angle: - creates dimension information for the angle between two 

selected lines. 

Text label: - creates a text label entered in the dialogue bar 

Annotation: - places explanatory text, entered in the dialogue with an 

arrow of what is being explained 

Curvature: - samples the surface and computes the curvature in two 

directions to describe how the surface behaves at the point shown in the 

dialog bar. Unlike the other dimensioning tools, Curvature is a real-time 

rubber-banding effect where you traverse the surface to find the point with 

the smallest curvature radius. Knowing the smallest radius tells you the 

smallest tool to use to manufacture the surface. 

Interrogation: - This dialog helps you extract numbers from the graphics 

window using snap modes and pick filters. You can then cut and paste these 

values into other dialogs. 

Curvature 

 Curvature samples the surface/Solid and computes the Curvature in two 

directions to describe how the surface behaves at the point shown in the 

dialog bar. Unlike the other dimensioning tools, Curvature is a real-time 

rubber-banding effect where you traverse the surface to find the point with 

the smallest Curvature radius. Knowing the smallest radius tells you the 

smallest tool to use to manufacture the surface. 

 Select Construct > Dimension > Curvature from the menu.  

 Move the cursor over the surface, particularly in the tight constrained 

areas of the surface or joints.  

 Note the smallest value shown for Curvature. That is the smallest tool 

end radius you need to accurately machine the surface.  

 Set up rough and finish passes for the surface feature based on this 

knowledge, and make sure the tool is available for production. 
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Surface 

 

 To build and use 3D surfaces in FeatureCAM, you need to understand how 

FeatureCAM defines a surface. A surface is defined by irregular sets of 

points and a description of how the surface behaves at each point on the 

surface which determines the smoothness of the surface. The set of points 

determines the shape, of the surface. 

Solid 

 

 The FeatureCAM support of solids lets you work with imported CAD designs 

from solid modelling systems and create 3D solid models using 

FeatureCAM’s Solid Modelling Tools. Solids are a convenient 

representation for 3D parts because they group collections of surfaces into 

3D volumes. By working with a solid instead of all of the individual surfaces, 

you are provided with a more convenient representation and more powerful 

modelling tools. 

 After you have created your Solid Model you can then use AFR (Automatic 

Feature Recognition) or IFR (Interactive Feature Recognition) to create 

your toolpaths. 
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 Please Note that the Creation of Solid Models in FeatureCAM is an 

extra cost option and will be greyed out if you have not paid for this 

option. Please speak to your local sales representative for more details.  

Edit Geometry 

 

 Clip: - Clip removes a region of a line, arc, circle or curve. A region is defined 

as a portion of an object between two intersection points. 

 Trim/Extend: - Changes the length of a line or an arc. Trim/extend can be 

used   to lengthen or shorten lines and arcs as follows:  

 Infinite: - Changes the length of a line or an arc. 

Geometry Creation Exercise 1 (Class Exercise) 

Introduction 

The exercise that follows will review most of the Snapping Modes on the 

Snapping Toolbar in no particular order, when complete it will provide a basic  

overview of the most commonly used snapping mode functions. 

 

1 Please start a New File document in FeatureCAM. 

2 Select the FeatureCAM  Icon on your desktopp or Taskbar. 

3 Select New File then Milling Setup and select Millimeters. 

 Typ means Typical for all dimensions that are the same unless 

otherwise stated. If in doubt ask 

 Do not worry about the stock size at this stage as we will resize this 

later. We are concentrating on Geometry creation techniques only. 

4 Hide the Stock, Right Click on the Stock boundary and select Hide Stock.  
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5 We will create a Rectangle first, go to Construct>Curve>Other 

Methods>Rectangle. 

 

6 Enter the following values Width 100mm Height 125mm.  

 Remember to select Create as arcs and Lines. See image below. 
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 We will now create four Circles by snapping a single circle to each 

corner of the Rectangle.  

7 Select Construct then Circle, Circle, Radius . Or select the same Icon 

from the Geometry Toolbar. Enter the following values 16mm. 

 Metric 

 Please note that all Snapping mode functions can be switched on and off 

at any time. All of the snapping modes can be switched on together or 

used individually. 

8 We will use Snap to End Point  as the most efficient snap mode in this 

instance. Remember to snap to the four corners of the rectangle.  

 Your image should look like the one on the next page. 
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9 We will now draw two lines across the diagonally opposite corners. 

10 Select Line from 2 Points from the Geometry Toolbar. Use Snap to 

End Point  as the most efficient snap mode in this instance. 

 

11 Using Offset we will offset the outer lines only 10mm towards the centre. 

Then whilst the Offset command is still active. Offset the diagonal lines 5mm 

either side of the lines as shown on the next page. 



              
 

                  
                  
Geometry Creation Techniques Wire EDM 

 

                                                                                                                                      
                                                                                                              

 Autodesk FeatureCAM 2017   

2.16                                                                                                                 © Copyright 2016 Autodesk, Inc. All rights reserved 

 

12 Delete the 2 centre diagonal lines. To do this just select the lines and then 

Select Delete on your Keyboard. Then  Clip the middle diamond shape. This 

will allow us to Fillet the four pockets. The Fillet command will automatically 

Clip the profile. An image up to this stage is shown on the next page. 

 

 We will now Fillet all pocket corners 6mm 
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13 Select the Corner Fillet Icon from the Geometry Toolbar and enter the 

values above. Present the cursor to each corner of the pockets until all corners 

are filleted. Clip the inner 4 corner radius and the four corners. Press Esc to 

finish the command. See image up to this stage below.  

 

14 Fillet the corners 6mm shown above.  Draw 4 circles in the corners of the part. 

Circle radius is 6mm. Snap to the circle centres. The finished image is shown 

below. 

 

 If in doubt ask. 
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Dimensioning the part (Class Exercise) 

 We will change the Setup when we come to machine this later. 

1 Next Select Dimension from the Construct menu, or the dimensioning flyout 

menu from the geometry toolbar. We will have a go at the different commands 

for example, Horizontal Distance, Vertical Distance etc. 

 The following text and images are a summary of what each item’s 

function is on the Dimensioning flyout menu. 

 Typ means Typical for all dimensions that are the same unless 

otherwise stated. If in doubt ask. 

 

Horizontal  

Creates dimension information based on the horizontal axis of the part. 

Vertical  

Creates dimension information based on the vertical axis of the part.  

Linear  

Creates dimension information based on the absolute distance between   

two points regardless of the angle of the dimensioned space. 

Radius  

Creates dimension information for the radius of the selected object. 

Diameter  

Creates dimension information for the diameter of the selected object.  

Angle  

Creates dimension information for the angle between two selected lines. 

Text label  

creates a text label entered in the dialogue bar 

Annotation  

Places explanatory text, entered in the dialogue with an arrow of what is 

being explained 
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Curvature 

Samples the surface and computes the curvature in two directions to 

describe how the surface behaves at the point shown in the dialog bar. 

Unlike the other dimensioning tools, Curvature is a real-time rubber-

banding effect where you traverse the surface to find the point with the 

smallest curvature radius. Knowing the smallest radius tells you the smallest  

tool to use to manufacture the surface. 

Interrogation 

This dialog helps you extract numbers from the graphics window using snap 

modes and pick filters. You can then cut and paste these values into other 

dialogs. 

 When creating dimensions. Do not worry if you make a mistake. If 

you do, just select  undo or select Ctrl + Z then have another 

try. 

 Remember to save the part.  We will machine this later on in the course. 

 Save the file as “Construction Ex1” in the Course Work Folder. 

C:\Training_Data\FeatureCAM Course Data 2017\Course work 

 

 If you want to machine this part later on the thickness=12mm. 

Pockets are 6mm deep and all holes are through. 
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Construction Exercise 2 

 There are additional optional exercises that follow. This will give you 

more practice drawing and using tools you have learned up to this 

point. 

 Have a go yourself at the following exercise. Please ask your 

instructor for help if required. See further Help on how to start this 

example shown below. 

 

 Before you start drawing this component spend time assimilating the 

information and decide what building blocks to draw first. A suggested 

process might be to start with the R25mm and R20mm Circles first and 

build the drawing from there. See the image below for a hint on what it 

should look like. 

 

 We will machine these components later on just concentrate on the 

geometry. 
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Additional machining information 

 Product thickness is 25mm 

 9.5mm Diameter holes are through 

 4.75mm Diameter and 3.2mm Diameter holes are through. 

 A tip on creating this drawing is to create a single hole on the centre line 

of the 9.5mm diameter holes on the respective pitch circle diameter 

and then using Transform, copy and rotate it about a specific point. 

(Shown below) select the hole you want to rotate, go to the Edit menu 

select Transform and then Rotate and Copy. In the Angle field type in 

for example 360/5 = 72 and then you will need 4 copies which 

(Excludes the original). Remember to select the Rotation centre 

point. If you specify 5 copies you will get another circle on top of the 

original. When you come to drill the holes, you will get the same hole 

drilled twice. 

Using Transform 

 Use the Transform dialog to Move or Copy objects: 

 

2 Open the Transform dialog in one of these ways: 

3 Select at least one object and click the Transform button in the Standard  

4 Toolbar.  Or select Edit > Transform from the menu.  

5 Or right-click on an object and select Transform from the context menu. 

6 You can transform Geometry, Curves, Features, Surfaces, or Solids. 

 Features cannot be transformed using the Scale or To UCS 

methods. 
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 Translate selected entity elements to a new location. You can move 

an absolute distance as specified in XYZ vectors, or you can move 

from point to point.  

 Rotate selected elements about a selected location to a specified 

angle, referenced from the positive X axis.  

 Scale proportionally reduces or expands selected elements about a 

specified point. This option is not available for features.  

 Reflect mirrors the element about a line. The line can be an existing 

axis, or any other line including one created just for reflecting around. 

The object can be flipped top to bottom, left to right or even both 

depending on the line you choose to reflect around. Set whether you 

want to Move or Copy the original element. If you are copying, more 

fields appear for setting the number of copies you want in the new 

location.  

 There are additional optional exercises that follow. This will give you 

more practice drawing and using tools you have learned up to this 

point. 
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Construction Exercise 3 

 

 

Additional machining information 

 Product thickness is 35mm. All holes are through.  

 20 holes 12.7mm Dia  
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Construction Exercise 4  

 

Additional machining information 

 Product thickness is 45mm 

 All Holes are through. 
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First part exercise – Simple 2-Axis  

 

1 From the New Part Document Wizard Select New file then select Next 

then select Wire EDM Setup, Select Millimeter as unit of measure then 

select the Finish button. 

 

 Notice the different types of documents available.  The different types 

of documents available; depends on the modules that you own and are 

licensed for. 

Stock Dimensions Dialog 

2 In the stock dimensions dialogue, Select Block, Enter 150mm for the 

Width, 150mm for the Length and 25mm for the Thickness. 

3  Select Next.  



 
 
FeatureWIRE Machining Strategies  

                           

 

      
Autodesk FeatureCAM 2017    

© Copyright 2016 Autodesk, Inc. All rights reserved           3.3 

 

4 Select Next. 
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Stock - Condition dialog 

 The material, wire type, wire diameter and machine type for an EDM part is 

specified using the Stock Properties dialog. 

 To enter these values, select each field using the drop down list and make 

your selection, if you wish to change any category Click the Cutting Data 

button and enter the desired values. The Condition button also may be 

accessed from the Stock Properties.  The actual cutting conditions are on 

the machine and the cutting data in the feature is merely a call for that 

condition. 

 

 

5 Select Next. 

Setup Dialog 

6 Enter Setup Name, you may call it whatever you wish, FeatureCAM defaults to 

Setup 1 and in sequence.  Additional Setups may be designated for other sides 

on the part.  Use whatever Part Name you desire. 

7 Click Next 

Part Program Zero Dialog 

8 Align your Part Program Zero (UCS User Coordinate System) by Clicking on 

the desired selection available. (See image on the next page) 
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9 Select Next. 

Setup - Posting Dialog 

10 Enter the desired values for your machine and part location. This is shown on 

the next page. 
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11 Click Finish. 

 

12 Select OK to close the form. 

 You now have a Block of Stock of D2 Material, using Hard Brass Wire 

with a 0.250mm Diameter and the machine is a Fanuc which contains 

the Condition Values. 

13 Click on the Geometry Button from Steps and using the Geometry 

constructors 

14  Select  Circle from radius, center. 

15 Enter Radius of 50mm and X= 75mm, Y=75mm, Z=0. 
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 To activate a new Feature menu select from the following options. 

 There are four different ways to activate the New Features menu. 

 Select Features  from the Steps menu. 

 Select Ctrl + R New Feature. 

 Select Construct>New Feature. 

 Select New Feature from the Advanced Toolbar. 

 

16 Choose the option of choice to create a new Feature. The following menu will 

appear. 

17 Select Die under 2 Axis.  Click Next. 
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18 Select Next. 
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 We need to create a Curve. 

19  Select Curve chaining from the menu. 

20 Select the Geometry as shown. Select Next. The following menu will 

appear. 
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21 Select Next. Change the thickness to 25mm 
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22 Select Finish. The following menu will appear. 

 

23 Select Ok to close the form. 

 

24 Run a Centreline simulation. 
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 There are a couple of ways to change the Start point in the feature.  

25 First of all hide the die Feature in Part View. 

26 Select Offset from the geometry menu and offset the Circle inwards by 

10mm 

27 Create a 3mm Radius Circle. Snap to a quadrant. 
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28 To change the location of the start point  

29 Double-click the die feature in the Part View area of the Toolbox found at 

the left side of FeatureCAM’s User Interface.  

 Double clicking opens the feature’s properties.  

30 Select the Start tab 
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31 Use the Pick Arrow to pick the start point, in this case the Centre of the 

circle we used to create the feature, then select along the circle where you 

want the wire to start cutting the curve shape. 

 

 Or simply enter the dimensions for the start of the Wire path a 

known location along the curve shape. (Not Shown) 
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 Since Wire EDM processes can take a lot of time to cut the part it is 

wise to shorten the distance travelled by the wire, whenever 

possible. 

 An example of this is if you want to use an existing hole in the stock where 

the start point is closer in location to the curve shape. 
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More 2 Axis Features 

 There are four types of 2 Axis features to select from in a Wire part 

program. We have seen a simple 2 Axis Die feature so a quick review 

of the other types is appropriate. 

 

2 Axis Punch feature 

 The Punch feature requires one or more closed curves. The wire 

travels on the outside of the curve(s). 
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 A 2-axis punch feature can create a number of cutting operations. 

These are specified on the Strategy tab. A 2-axis punch feature can 

have a taper. 

 Creating a punch feature is done following the same steps as we 

have done for the die feature.  

 Open the file in the FeatureWIRE Metric data folder named 2 Axis 

Punch.fm C:\Training_Data\FeatureCAM Course Data 2017\FeatureWIRE 

Metric Data 

1 In the Steps window of the Toolbox choose Features to create a new 

feature. Choose Punch as the feature type.  

 

 

2 Select Next. 

3 You may wish to hide Geometry. To do this go to Hide and select Hide 

Geometry. 

4 Use the Pick Arrow and select Curve1 from the graphics window. 
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5 Select Next Twice. 

6 Set the Thickness to 25mm and leave the other parameters as shown. 
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7 Select Finish. 

 Please note: The thickness parameter is used to access the 

appropriate cutting data table.  

 The Punch Properties dialog opens to give you a chance to review 

the feature and make any changes you want to. This review of the 

properties happens each time you create a new feature.  

 

 

8 Press OK to accept the feature dimensions.  

9 Run a 3D Simulation to see the wire path in the graphics window. 
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 Notice you see the whole part still with the wire path through the 3D 

display of the stock and the feature. You can remove either the stock 

or the part from view by using the Select Arrow from the Advanced 

Toolbar. The select arrow is found under the word Options on the 

Menu Bar.  

 

 Click on the Select Arrow shown above and move your mouse 

cursor over the stock display in the graphics window. 

 

10 Click on the Stock and it disappears from view.  

 

 You can alternately click on the part itself to remove the part from 

view, but one item at least needs to remain in the graphics window 

when viewing 3D simulation results. 

11 Eject the Simulation by pressing the Eject Button on the Simulation 

Toolbar. 
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 Open the feature properties by double-clicking Punch1 from Part View 

in the Toolbox. 

 On the Dimensions tab of the feature change the Taper type to Constant 

with a 10 degree value entered in the field as shown. 

 Press the Preview button to see the change and updated feature shape. 

 

 As a review, toggle through each of the taper types 

 (Left, Right, ISO-Left, etc.) by using the pull-

down menu to Preview the feature shape changes in the graphics 

window.  

Types of Wire EDM Constant tapers 

 All left tapers are performed to the left of the curve (at the bottom of the 

feature) relative to the Primary Cut Direction, and all right tapers are 

performed to the right of the curve (at the bottom of the feature) relative 

to the Primary Cut Direction. 

 Left: Sharp corners tapered into sharp corners (G29 on a Charmilles 

machine) and arcs tapered into conical corners (G28).  
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 Right: Sharp corners tapered into sharp corners and arcs tapered into 

conical corners.  

 Rounded-Left: Sharp corners tapered into arcs (G28) and arcs tapered 

into conical corners (G28).  

 Rounded-Right: Sharp corners tapered into arcs and arcs tapered into 

conical corners.  

 ISO-Left: Arcs tapered into cylindrical corners (G29) and sharp corners 

tapered into sharp corners (G29).  

 ISO-Right: Arcs tapered into cylindrical corners and sharp corners tapered 

into sharp corners.  

 ISO/Rounded-Left: Arcs tapered into cylindrical corners (G29) and sharp 

corners tapered into arcs (G28).  

 ISO/Rounded-Right: Arcs tapered into cylindrical corners and sharp 

corners tapered into arcs. 

Variable taper table  

 If the feature has multiple curves, select the appropriate curve from the 

Curve list. The curve is broken down into arc  and line segments and each 

segment is represented by a row in the table. As you click a row of the table, 

the segment of the curve is highlighted in the Graphics window.  

 If you wish to find the row of the table that corresponds to a segment, click 

the Pick curve piece button and select the segment. The row of the table 

is then selected. 
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The columns of each table are: 

 

 Status - Double-click box in the status column to display a list of Types of 

wire EDM tapers. 

 First Angle - This is the taper angle, specified in degrees, for the first end 

point of the segment. 

 Second Angle - This is the taper angle, specified in degrees, for the 

second end point of the segment. 

 Taper reg - This is the register on the machine containing taper 

information for this segment. 

 If you want smooth walls on your part, the angle of one segment must 

match the first angle of the next segment. 
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 This is covered in an exercise later in this module 

 Close the file without saving. 

2-axis Side 

 

 The Side feature can use one or more closed or open curves. The Punch 

or Die features provide more cutting options for closed curves. You can 

optionally place the wire on either side of the curves. A side feature must  

have at least three arcs or lines in it including the lead moves. 

 The thickness parameter is used to access the appropriate cutting data 

table. 

 A 2-axis side feature can create a number of cutting operations. These 

are specified on the Strategy tab. 

 A 2-axis side feature can have a taper. 

 A side feature must have at least three moves in it including the lead moves. 

If it does not, then no feature is displayed in the start page that is displayed 

in the wizard. For example, if you are creating a feature from a single line, 

you must change the start point and end point so that the feature has three 

moves. If you add these moves and click the Next button in the wizard, the 

feature displays. 

 

1 Open the file named 2 Axis Side.fm from the Data folder. 

C:\Training_Data\FeatureCAM Course Data 2017\FeatureWIRE Metric 

Data 
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2 Run a 3D Simulation and use the Select Arrow to remove the piece to be 

removed from the part. 

Isometric View 

 

3 Open the side1 feature properties by double clicking the feature in the Part 

View, or the Graphics Window. 

4 Select the Side control tab. 

 

 Notice the wire path will cut along the inside of the curve as shown 

above right. 

 Press the Switch machining side button to change the side of the 

curve to be machined as shown. 
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 The lead moves have changed as a result of the change and the wire will 

follow the curve shape from the other side of the selected curve giving 

different results.  

 This exercise is merely to show the user how to use the side control 

functionality that is available in all curve driven features throughout 

FeatureCAM.  

2-Axis Rapid 

 A Rapid feature is used to rapid along the length of a curve to the start 

point of the next feature. You can use Rapid features to quickly move 

around a part using curves to avoid possible collision with fixtures. 

 FeatureCAM programs a Rapid in a very similar way to a Side feature. The 

wizard pages are similar, but fewer options are needed. 

1 Open the file named 2 Axis Rapid.fm in the Data folder.  

2 C:\Training_Data\FeatureCAM Course Data 2017\FeatureWIRE Metric 

Data 

  

 

 If you don’t see the toe clamps when the file opens: 

3 Choose View from the File Menu  - Show – Show All Solids 

 Notice the toe clamp solids in the file. The toe clamps are there to 

represent the fixture that is holding the part. There are two features 

in the file that need to be machined. This exercise shows us how to 

use the 2 Axis Rapid feature to control the rapid move of the wire 

to cut both features and avoid our fixtures.  
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 FeatureCAM has the capability to select solids that exist in the file 

and show them during a 3D simulation in order to help the user avoid 

colliding with the fixture during the machining operations. They can 

be toe clamps, vises, or custom fixtures. As long as you have a solid 

model to import into your FeatureWIRE project you can use them in 

the same way as this exercise.  

4 Right click on any face of the imported toe clamp solid and choose Use Solid 

as Clamp from the menu that pops up. If it is active to be visible in the 3D 

simulation, you will see a check mark next to it, as shown in the image below. 

5 Do this for BOTH solid toe clamps!  

6 Run a Centreline Simulation and choose Play to Next Operation. Do this 

until the simulation has completely cut the two side features. 

 We are going to run the side1 and side2 features ONLY. Do not 

activate the rapid1 feature yet.  

 

7 In the Part View window in the Toolbox press the + sign next to Curves to 

expand the list of curves in the file. Click the curve named rapid to see the 

curve in the Graphics Window. 

8 This curve begins where side1 feature finishes machining and ends where side2 

starts to approach, and machine the part. It is the curve that is used for the 

feature named rapid. 
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9 Hide the toe clamps. From the File Menu choose View – Hide - Hide All 

Solids to hide the toe clamps from view in the graphics window 

10 In the Part View activate the feature named Rapid and run a Centreline 

simulation. Notice how the rapid feature controls the wire path rapid around 

to machine the second side feature.  

 

11 Run a 3D Simulation to see the clamps in the graphics window and the 

machining operations.  

 Displaying the Solids used as clamps allows the user to program the 

part accordingly and avoid any collisions. 

More on Tapers and Start Points 

1 Open the file named snaggletooth.fm from the FeatureWIRE Metric Data 

folder. C:\Training_Data\FeatureCAM Course Data 2017\FeatureWIRE 

Metric Data 

2 Go to the top view.  

3 Run a 2D Centreline Simulation just to familiarize yourself with the 

component. 
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4 Open the die1 feature properties dialog.  

5 Go to the Start tab.  

6 Using the Pick Arrow select the Point located at (X22.225, Y-31.75) and 

then the bottom right horizontal line somewhere below the point . 

7 Apply and OK then Run a centreline Simulation to see the updated wire 

path. 

8 Open the die1 feature properties again. 

9 Go to the Start tab again and check the box Pick only perpendicular lead. 

10 Using the Pick arrow select the point again and anywhere on the line below.  

 Notice that it does not matter where you select along the line, only 

the perpendicular tangency is allowed to be created for the wire path 

approach move. 

11 Apply and OK. Run a centreline simulation to view the results. 

 Leave the file open for the rest of the exercise below. 

 

Constant Taper Exercise 

1 Open die1 feature properties 

2 Go to the Dimensions tab. 

3 Set taper to constant and Left. 10 degrees and Apply. 

4 Go to the isometric view.  

5 Set taper to constant and right. Press Apply. 

 FeatureWIRE supports ISO or cylindrical taper vs. the regular or 

conical taper.  

6 Go to isometric view.  

7 Set taper (10 deg.) to constant and ISO right.  
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8 Zoom in to the lower left corner of the feature to see the bottom arc. The 

taper is cylindrical (same radius).  

9 Switch back to constant and right to see the difference.  

 

 

Before 

 

 

After 

 

 Leave the file open for the rest of the exercise below. 

 

10 Hold the Control key and press “Q” on the keyboard to “Centre all” in the 

graphics window.  

11 In Die Properties select Variable. 
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12 Set taper to Variable and press the Variable Taper button. 

 

13 In the Variable Taper dialog, set the fields to (Right, 10, 10).  

 Make sure Auto fill down is checked 

 There is no need to set anything in Taper Reg. field for this 

exercise. 

14 Apply and OK in the Variable taper dialog. 
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15 Apply and OK in the Die Properties dialog. 

16 This is the same as setting a constant taper right 10 degrees.  

17 Open the Variable Taper dialog again and uncheck Auto fill down.  

 It is possible to change the angle of different segments of the curve 

profile. 

 For example one segment could be 20 degrees and all other 

segments could remain at 10 degrees. 

 

 Have a go at changing different segments to different angles. 

Skim Cuts 

 A common practice in cutting wire EDM parts is to make skim cuts for a 

better finish. This is to make multiple passes with a stepover to cut the part 

down to size.  

1 Open the file named Skim Cuts.fm from the FeatureWIRE Metric Data 

folder. C:\Training_Data\FeatureCAM Course Data 2017\FeatureWIRE 

Metric Data 

 In this die feature the taper is set to none to get a better visual of 

how the skim cuts work.  

2 Open the properties of the die1 feature. 
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3 Go to the Strategy tab.  

 There is only one operation in this feature, a Contour Operation. 

 When cutting with a contour operation the curve can be open or 

closed. A contour operation traces the entire length of the curve. The 

number of passes is determined by Contour passes.  

4 Select the Skim Pass Options button. 

 The number of passes is currently set to 1 so you will see only 1 

pass in the simulation. 
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5 Press OK twice to close the dialog and the feature. 

6 Go to an Isometric view. 

7 Run a 3D Simulation. 

8 Slide the simulation speed slider to the half-way point on the Simulation Toolbar 

speed so you can see this more clearly or select Alt+F3 Single step. 

9 Open the die1 feature properties again and on the Strategy tab press the 

Skim Pass Options button.  

10 Change Contour Passes to 3.  

11 Run a 3D simulation again.  

12 Right now we are using cutter comp as the offset method so the toolpath for 

the 3 passes are not offset. The NC code will have different cutter comps for 

each pass for the wire EDM machine to do the offsetting. 

13 Another way of making skim cuts is to actually generate offset toolpath. 

14 Open the die1 feature properties again and on the Strategy tab press the Skim 

Pass Options button. 

15 Change to Offset Toolpath.  

16 Set Contour Stock as shown. This is the amount of material left to cut away 

to the curve.  

17 Set the Stepover as shown. The wire will step over the specified amount after 

each pass. 
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18 Press OK and Apply and OK again to apply the changes to the feature. 

19 Go to the Top view.  

20 Run a Centreline Simulation.  

21 Zoom to a corner of the feature to see offset toolpath. 

22 Select Control and Q to Centre all.  

23 Leave the file open for the rest of the exercise below. 

Retract and Cutoff Operations 

 Another common practice in cutting wire EDM parts is to run the 

machine unattended so that most of the cutting can be done before 

human intervention is needed. We support this with the Retract and 

Cutoff operations. 

1 On the Strategy tab set the operations to Retract in the Operations field 

using the Pulldown menu. The Die Properties dialog box updates to allow other 

settings. 
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2 Check the box next to Cutoff.  

3 Press the Skim Pass Options button and change the setting back to Cutter 

Comp and the Total Passes to 3. 

 

4 Select OK, Apply OK. 

5 Go to an Isometric view.  
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6 Run a 3D simulation using Play to Next Operation.  

 

  Use the triangle pull-down menu to find this simulation button. 

 

7 Click the Play to Next Operation button again to finish the 3D Simulation.  

 Programming the feature in this manner creates a situation where the 

retract operation could be run overnight. When it is done, the machine 

would stop. The uncut region keeps the core in place to prevent the core 

from interfering with the wire movement. So in the morning, the 

operator reconfigures the fixture to hold the core, and finishes the 

cutting with the Cutoff operation. The retract move makes sure the burn 

mark from the wire changing cut direction is away from the part. A cutoff 

operation is normally used after this operation to cut the part of the 

contour that is not cut by the retract operation. The cutoff operation 

machines the left over part in the opposite direc tion to the machining 

curve. 

More about Retract 

 The retract operation is available for both 2-axis and 4-axis 

features. 

 The contour is not cut completely but is stopped shortly before the contour 

end point. The distance of this position from the contour end point is set in 

the Stop Length field. This option is generally used when cutting multiple 

contours whereby the cut part should not be separated from the work piece, 

such as when the program should run automatically overnight. 

 

 Retract length 

 Stop length 

 Wire path 

 Inserted end position 

 Normal contour start/end position 

 Contour 
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Pocketing and Zigzag  

 The following are two very useful operations. There are no-core 

operations meaning that the entire core is burned away." 

 

1 Start a New File from the File Menu – Select File > New file > Wire EDM 

Setup. Choose Millimeters as the Unit of Measure and press OK. 

2 Set the Stock as Block with the dimensions 150mm X 150mm X 25mm 

thick. 

3 Double click on Setup1 and Centre the Setup Axis. 

4 Select Finish and OK 

5 Switch to the Top view. Ctrl+5 

6 Create a 12mm Radius Circle from Rad, Centre at X0, Y0, Z0. 

 The Circle Constructors are available as discussed in the previous 

Snapping and Geometry chapter. 

7 Create a 2 Axis Die feature using the circle you just made. No taper on this 

feature. 

8 Create a Curve from the circle. Select Finish. On the Strategies page. Set 

operations to Pocketing. 
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 In the existing feature this can be changed in the Strategy tab.  

9 Select Finish/Apply and OK. 

10 Select Isometric View. 

 

 

 

11 Run a Centreline Simulation.  
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Pocketing 

 

 The pocketing operation enables contour parallel area clearance of a 

closed curve. This is only available for 2-axis features. 

 

 The start position of the cut is set automatically to a point on the boundary. 

The wire then feeds to the Centre of the pocket and then cuts from the 

inside toward the boundary.  

 If you wish to ensure that the wire starts in a particular position (to thread 

the wire for example) you should define a start point. The toolpath then 

starts at the start point and then feed to the Centre of the pocket. 

 Cutter compensation does not apply to a pocketing operation because it 

outputs a wire path that is already corrected (that is, no compensation is 

entered on the machine). 

 No attempt is made to check if the stepover value is larger or 

smaller than the wire diameter. 

12 Open the feature properties and change operations to Zigzag.  

13 Run a Centreline Simulation.  
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 Leave the file open for the next operation setting. 

Zigzag 

 

 The zigzag operation defines a zigzag area clearance cycle for a closed 

curve. It is available only for 2-axis features. 

 The start position of the cut is set automatically to a point on the 

boundary. The wire then feeds to the beginning of the zigzag pattern. 

 If you wish to ensure that the wire starts in a particular position (to thread 

the wire for example) you should define a start point. The toolpath then 

starts at the start point and then feeds to the beginning of the zigzag 

pattern. 

 

 

 

 By the definition of the Cut Angle you can control the direction of the wire 

path and also the start point of the cycle. 

 Cutter compensation does not apply to a pocketing operation because it 

outputs a wire path that is already corrected (that is, no compensation is 

entered on the machine). 

 No attempt is made to check if the stepover value is larger or 

smaller than the wire diameter. 
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Stop 

 The stop operation is available for both 2-axis and 4-axis features. 

 A stop command is inserted into the wire path together with a further stop 

at the end of the contour. The distance of the new stop position from the 

contour end point is defined in the Stop Length field. If you wish to overcut 

the contour end position, you can also define an Overlap. In Centreline 

simulation, the locations where the wire stops are shown as small squares.  

 A stop operation has two different locations where the wire stops: 

 

Lead types 

1 Open the file named Lead-in-out Metric Styles.fm from the FeatureWIRE 

Metric Data folder. 

2 Run a Centreline Simulation using only the die1_Teardrop feature as active. 

 The wire path starts at the Centre of the feature where the Start Point 

was generated and then move in an angular direction and starts onto 

the curve shape with an arc.  

 The wire path follows the curve shape around to where the 

approaching arc ended and started to cut the shape, then arcs off and 

make another linear move to the Start Point to finish the cut. The 

result is a teardrop shape as shown. 

3 Use the single step button on the Simulation Toolbar or use Alt+F3 to see 

this more clearly.  
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4 Open the die1_teardrop feature properties and select the contour operation. 

5 Go to the Leads Style tab. 

6 Notice the Diameter for lead moves is set to 5.00mm 

7 Change the Diameter to 10mm and apply the change. 

8 Run a Centreline Simulation again to observe the change in the wire path. 

 

9 Go to the Part View in the Toolbox 

10 Choose the feature named die1_direct and run Centreline Simulation 

again. 

 Direct is the only lead style that does not use the Diameter setting. 

11 Select each feature (run them individually) and observe the different lead 

moves for each. 
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Misc. Tab Setting - Wire cutting/threading 

 FeatureWIRE offers four settings to control the output of wire 

threading or wire cutting commands: 

 Off - No wire threading or wire cutting commands are output in the NC-

program. 

 Both - The commands to thread the wire and cut the wire are output 

automatically at the start and end of each operation within the feature.  

 Cut - The wire cutting command is output at the end of each operation 

within the feature (but no wire thread command at the start). When viewing 

the toolpath in center line simulation, the Cut location is denoted with a 

small circle. 

 Thread - The wire threading command is output at the start of each 

operation within the feature (but no cut wire command at the end). When 

viewing the toolpath in center line simulation, the Thread location is shown 

as a small plus sign. 
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Modify outside corners 

 A radius will be inserted into the wire path at each outside sharp 

corner. This can be useful for reducing unnecessary movements and 

for producing cleaner corners. 

 

Modify inside corners 

 Circular - A circle is inserted in the corners. The center of the circle 

lies on the corner point. 
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Triangular 

 The path follows a triangular shape at an inside corner. Specify the length 

and width of the triangle. 

 

Rounded 

 The path rounds inside corners. Specify the radius. 

 

Modifying both inside and outside corners 

 Both inside and outside corners are modified as shown below. 

 

Auto round 

 If Auto round is selected, arcs are inserted at all sharp corners. This is 

applicable only if Cutter comp is set and you have a leave allowance or if 

Cutter comp is not set. If you have selected Modify outside corners, it 

will not perform any further rounding on these corners.  

 It will round inside corners (even if Modify inside corners is selected) by 

inserting an arc before and after the circular corner as shown below: The 

radius of the inserted arcs is equal to the radius of the wire. 
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Four Axis Wire paths 

 4-axis Wire EDM requires two closed curves for Die and Punch 

features. The parts shape is controlled by a upper curve and a lower 

curve. 

 

1 Open the file 100 x 25.fm from the Data folder. 

C:\Training_Data\FeatureCAM Course Data 2017\FeatureWIRE Metric 

Data 

2 Create a new 4 Axis die feature. Select Next. 

3 Use the inner geometry for the upper curve and the Outer Curve for the 

Lower Curve. 

4 Because there are no curves in the file use the Curve chaining button to 

chain the curves. 
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5 Press Next after chaining each of the curves. 

6 Set Thickness to 50mm.  

7 The feature may appear to be twisted because we have not set the start points.  

8 Go to Top view.  

9 On the New Feature – Start page check the Pick perpendicular lead check box. 

10 Use the Pick arrow on the dialog and Set both upper and lower curve start points 

to the centre of the stock and the left edge of the curve.  

11 Press Preview to see the updated feature 

12 Select Finish and select Isometric View.  

13 Since the same number of geometry pieces is used on the upper and lower 

curves, the match points came out nicely. 

14 Run a 3D Simulation.  

15 Use the Select arrow to remove Centre core piece from view. 

16 Rotate the view to see the part from the bottom.  

 

 Leave the file open for the next exercise. 
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4-Axis Die 

 The 4-axis die feature needs two closed curves. It is assumed that 

the region outside of the curve is the part that you want to keep.  

 The wire travels on the inside of the curves. 

 

 The Thickness parameter is used to access the appropriate cutting data 

table. 

 The A parameter is used to rotate the feature around the Z-axis of the 

current setup. 

4-Axis Punch 

 The Punch feature requires two closed curves. The wire travels on the 

outside of the curves. 

 The Thickness parameter is used to access the appropriate cutting data 

table. 

1 The A parameter is used to rotate the feature around the Z-axis of the current 

setup. 

2 Using the part 100 x 25.fm again from the Data folder. 

3 Delete the die1 feature from the Part View (if you left the file open as 

instructed). 

4 Create a New 4 Axis Punch feature.  

5 Use the inner geometry for the upper curve.  

6 Use the outer geometry for the lower curve.  

7 Set Thickness to 50mm.  
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 Note: There is no need to use Curve chaining this time because the 

curves are already in the file from the previous exercise. If you closed 

the file you will need to use the Curve chaining method as shown in 

the previous exercise. 

 There is a Geometry Point at X70 Y0 Z0 

8 Set both upper and lower curve start points to the outside of the stock and 

the left edge of the curve using the point we have just created. 

9 Press the Apply button to see the updated feature. 

10 Run a 3D Simulation. 

 

 

11 Use the Select arrow to remove the outer portion, or the stock from view. 



              
 

                  
                  
              FeatureWIRE Machining Strategies 

 

                                                                                                                                      
                                                                                                              

 Autodesk FeatureCAM 2017   

3.52                                                                                                                 © Copyright 2016 Autodesk, Inc. All rights reserved 

 

 

12 Close the file without saving! 
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4-Axis Side 

 The side feature can use a closed or open curve. Punch or die 

features provide more cutting options for closed curves. You can 

optionally place the wire on either side of the curve. A side feature 

must have at least three arcs or lines in it including the lead 

moves. 

 

1 Open 4 Axis Side Metric.fm from the Data folder.  

 

2 Select Top view then Isometric view to see the feature. 

3 Run a 3D simulation on the existing feature saved with the file. 
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4 Use the Select arrow to remove the piece that is to fall away. 

 Notice the wire started vertically at the specified Start point, 

cuts the side feature, and finally ended vertically at the specified 

End point. The end and start points are in the exact location for 

this feature.  

 Hint: The exercise that follows will use an existing Geometry Point 

to snap to when setting Start and End points in the new feature. 

5 Create a new 4 Axis Side feature. 

6 Use the curves on the opposite corner of the part. Select Next twice. 

7 Thickness is 25.4. Select Next 

8 On the New Feature – Start page use the pick arrows to snap to the point 

near the corner of the part to set the Upper and Lower curves to set the 

Start and End Point for each curve.  

 You should see something similar to the image below. 

 

 

9 Uncheck the side4x2 feature that was already saved in the file (Part 

View) 

10 Run a 3D Simulation 
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11 Use the Select arrow to remove the excess piece. 

 Close the file without saving! 

 

4-axis rapid 

 A Rapid feature is used to rapid along the length of a curve to the start 

point of the next feature. You can use Rapid features to quickly move 

around a part using curves to avoid possible collision with fixtures. 

 FeatureCAM programs a Rapid in a very similar way to a Side feature. 

The wizard pages are similar, but fewer options are needed. 

 As an exercise, try to come up with a scenario where you would 

need to use a 4 Axis Rapid feature to maneuver the wire around 

and avoid collisions. This can be done at a later time, if you wish. 

3D Curve in 4-axis 

 This is useful when you get a model from someone and the surfaces 

that you want to cut do not give you planar curves. 

1 Open the file named 3d.fm from the Data folder. 

2 Shade the surface and rotate the view. 

3 Unshade the surface. 

4 Make a 4-axis side with Top-curve as upper and Btm - curve as lower. 

5 Using Resize set Top and Bottom to Zero. 

6 Select Finish.  

7 Shade the surface. 

 

 Rotate the part around to show that it matches with the surface.  
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 Note: If you were to actually want to wire this shape in the part you 

would need the surfaces to extend to the top and bottom of the 

stock. 

 Have a go at machining this part yourself. 

Examples of FeatureWIRE Features 

1 Open the file named Tutorial Features from the Data folder. 

 Please note that this document is in Inch units. 

 

 Click on each Setup and run a 3D simulation, one at a time, to 

see the feature examples included in the file for a better idea of 

what you could do with FeatureWIRE. 
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