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This guide is designed to quickly get you up to speed with FeatureCAM. 

By the time you finish this guide, you'll know enough about FeatureCAM 

to use it straight away. You may also find this guide useful, if you have 

upgraded FeatureCAM, and want to learn the new modules. 

FeatureCAM is very easy to use, and does not require any specialist 

computing knowledge. However, you need to know how to use the 

mouse, the keyboard, and the Windows environment. 

If you want to know more 

You can find details on using specific features in the online help system 

included with FeatureCAM. 

 

Introduction 
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Special features in this guide 
Names of dialogs, menus, toolbars, and menu options appear in 

boldface. 

The menu names are separated from the specific command on that menu 

with a '>'. For example, a phrase 'select View > Simulation' instructs 

you to open the View menu and select the Simulation option. 

Any text that you have to type in a dialog or a text box appears in blue 

boldface type. 

Icons 

 A note icon draws your attention to something that may not work the 

way you think it should, and helps you to avoid common errors or hidden 

pitfalls. 

 A tip icon is here to save you time, and shows you a more efficient 

way of doing things in FeatureCAM. 

 A warning icon tells you how to avoid serious problems. 
 

Tell us what you think 
Tell us what you think of this guide. We need your opinion. We want to 

know what we are doing right, and what we could do better. 

Email your thoughts to documentation@featurecam.com. 

Thank you for choosing FeatureCAM! 
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FeatureCAM is a CAD/CAM software suite that automates machining 

and minimizes programming times for parts on mills, lathes, and wire 

EDM. Unlike operations-based CAM systems, FeatureCAM generates 

toolpaths based on the features of the part, and automatically selects 

appropriate tools, determines roughing and finishing passes, and 

calculates feeds and speeds. The selections made can be based on the 

built-in machining knowledge that Delcam supplies 'out-of-the-box' with 

FeatureCAM, or from experience captured from your company, project or 

individual users' preferences. 

FeatureCAM includes five stand-alone modules: 

 MILL - 2.5D design and toolpath generation for 2- and 3-axis 

mills. 

 MILL3D - 3D surface modeling and 3-axis toolpath generation. 

 TURN - 2-axis design and toolpath generation for 2-axis lathes. 

 TURN/MILL - Supports lathes with C and Y-axis milling 

capabilities. 

 WIRE - 2- and 4-axis wire EDM toolpath creation. 

The following add-on modules are also available: 

 RECOGNITION - 3D surface and solid import and the 

recognition of 2.5D features from solid models. Accelerates 

making 2.5D and turned parts from solid models. 

 Solid Modeling - Solid modeling and tools for creating molds 

from solid models. 

 5-Axis Positioning - Manufacture 2.5D features from 5-axis 

orientations. 

FeatureCAM overview 
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 5-Axis Simultaneous - Manufacture 3D features while 

changing the tool axis. 

 Tombstone - Multiple part manufacturing for horizontal or 

vertical milling machines with indexers. 

 Native Import Modules - Native data can be read directly 

from SolidWorks, SolidWorks Assemblies, Autodesk Inventor, 

SolidEdge, CATIA, Unigraphics, Pro-Engineer, and STEP files. 

 Machine Simulation - Modeling and simulation of a CNC 

machine. 

 Advanced Turn/Mill - Includes support for TURN/MILL in 

addition to support for B-axis (5-axis positioning) and turret 

synchronization. 

 Network Database and Licensing - Flexible product 

licensing allows sharing FeatureCAM licenses across a network. 
 

Why creating toolpaths is so fast 
FeatureCAM has the unique ability to generate toolpaths and create NC 

code to run the machines with a minimum amount of user input. 

Traditional CAM systems are operations-based and require you to 

program every operation, one at a time, to create your part. FeatureCAM 

is feature-based; this means the part is created using features that describe 

that part, from simple holes, to complex pockets, to turned grooves. 

Machinable features contain information and rules describing how and 

where material removal should occur, cutting depths, whether to use 

climb cutting, whether to spot drill or center drill, and preferred 

machining strategies for roughing and finishing. This means that after you 

import or draw the part and identify its features, FeatureCAM 

automatically: 

 Selects the most appropriate tools and operations; 

 Recommends machining strategies; 

 Calculates speeds and feeds; 

 Generates toolpaths and creates the NC code. 

 You can customize this built-in 'intelligence' to your own style of 

cutting. 
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What's new in this release 
If you are an existing FeatureCAM user and want to find out about new 

functionality and other changes to FeatureCAM, see the What’s New 
section of the FeatureCAM help file. 

 

Website 
The website www.featurecam.com contains useful information for 

FeatureCAM users including: 

 New product announcements 

 Comprehensive database of technical tips 

 Maintenance releases 

 User forum 

 Evaluation copies of new software 

 Local dealer information 

 Trade shows where FeatureCAM is being exhibited 

 Software updates 
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As with any software program, the key to efficiency is being able to 

control the program effectively using its interface. This chapter covers 

FeatureCAM basics, such as starting FeatureCAM for the first time, 

getting help as you work, mastering different components of the 

FeatureCAM interface, and following the basic steps to create a part. 
 

Starting FeatureCAM for the first time 
1. From the Start menu, select All Programs > FeatureCAM > 

FeatureCAM. 

 You can also start the program by double-clicking the 

FeatureCAM  icon on the desktop. 

The first time you start FeatureCAM, it runs the INITDB 

Initialization program to create the tools and materials database. 

2. Click OK to begin the configuration. 

Using FeatureCAM 
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The Tool and Material Setup dialog opens. 

 

3. If you want to create a local database, select On my local 
computer. 

If you want multiple computers to have the ability to use the same 

tool and material information: 

a. Select On another computer that I will access over a 
network. 

b. Click the Browse button, and use the Database Location 

dialog to select the folder where the database is located. 

 You need to create a database folder on your network first, 

and then copy an empty MDB database from the 

FeatureCAM CD-ROM to this location. 

The default database is created by MS Access, and should be 

accessed using the MS Jet database driver. You may use a 

different database type, such as MS SQL Server. For more 

information, refer to the online help. 

 You need to have the Shared Network Database module 

to use this option. 

4. Click the Next button to continue. 
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5. Choose the tools to load: 

 

Inch - loads only the inch tools. 

Metric - loads only the metric tools. 

Both - loads both inch and metric tools. 

6. Click the Next button to continue. 

7. If you chose to load both tool types, you are asked which tool type 

you use more often. Select Inch or Metric, and click Next. 

8. Click Finish to initialize the database. 

 The tools database specifies the set of tools used by FeatureCAM to 

perform manufacturing operations. For best results, use the Tool 
Manager (available from the Manufacturing menu) to customize 

the database to reflect the tools in your shop. 
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Opening a part 
When you start FeatureCAM, by default, the New Part Document 
wizard is the first thing you see. 

 

To open an existing file: 

1. Select Open an existing file in the New Part Document 
wizard, and click the Next button to continue. 

2. In the Open dialog, select a part file to work with. 
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3. When the part file is selected, click the Open button to bring up 

that part in FeatureCAM. 

 Double-clicking the part name in the Open dialog (or 

Windows Explorer) automatically selects the part and starts it 

in FeatureCAM. This works whether you have FeatureCAM 

running or not. You can also drag-and-drop a part file into 

the open FeatureCAM Graphics window to start a part. 

To create a new file: 

1. Select New file in the New Part Document wizard, and click 

the Next button to continue. 

2. Choose the setup type for your part: 

 

Turn/Mill - for turning that supports live tooling. 

Milling - 2.5D or 3D milled parts. Select this type for 5-axis 

positioning as well. 

Wire EDM - for a 2- or 4-axis wire EDM part. 

Multiple Fixture - for laying out multiple parts on the table. This 

indicates that you will be mixing different milled parts for multiple 

part manufacturing. 

Tombstone Fixture - for parts that you will mass produce on a 

horizontal or vertical milling machine. 

Simulation Machine Design - to create a machine tool model 

for simulation. 



 

FeatureCAM 2011 Getting Started Using FeatureCAM • 11
  

 

 Your choices are limited by the FeatureCAM modules you 

have purchased. 

3. Select the Unit of Measure for your part (Inch or Millimeter). 

 You can change the default dimension units later, by 

selecting Options > File Options from the menu. 

4. Click Finish. 
 

Closing the Stock wizard 
The stock is the initial material from which you cut your part. By default, 

the Stock wizard (Dimensions page) opens on the screen as soon as 

you have created a new part. It lets you set the shape and dimensions for 

the stock, the stock material, part program zero, and the coordinate 

system for modeling. 

 

To close the Stock wizard, click the Cancel button. 
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Creating a simple part 
Let's create a basic part using default FeatureCAM behavior. This tutorial 

uses the Milling Setup. The measurements are in inches; the values in 

millimeters are shown in parentheses. 

1. Create the stock. 

a. Select the Stock  step from the Steps panel. 

b. In the Stock wizard (Dimensions page), set Width to 4 (100 

mm), Length to 4 (100 mm), and Thickness to 2 (50 mm). 

c. Click the triangle next to the Finish button, and select the 

Finish option to exit the wizard. 

2. Add a hole feature. 

a. Select the Features  step from the Steps panel. 

b. In the New Feature wizard, select the Hole option in the 

From Dimensions section, and click Next. 

c. Set Diameter to 1 (25 mm), Depth to 2 (50 mm), and click 

Next. 

d. Enter the hole location: X = 3 (75 mm), Y = 3 (75 mm), Z = 0. 

e. Click the triangle next to the Finish button, and select the 

Finish option to exit the wizard. 

3. Add a pocket feature. 

a. Select the Features  step from the Steps panel. 

b. In the New Feature wizard, select the Rectangular Pocket 
option in the From Dimensions frame, and click Next. 

c. Set Length to 2 (50 mm), Width to 2 (50 mm), Depth to 1 (25 

mm), and click Next. 

d. Enter the pocket location: X = 0.5 (12 mm), Y = 0.5 (12 mm), Z 

= 0, and click Finish. 
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4. Select View > Principal Views > Isometric from the menu. 

 

5. Select File > Save, and save your part as first1.fm. 

Your part should looks something like this: 

 

6. Create the toolpaths. 

a. Select the Toolpaths  step from the Steps panel. The 

Simulation toolbar opens. 

b. Click the Show Centerline  button, and then click the 

Play  button. Lines are drawn that represent the center of the 

tip of the tool. Rapid moves (G0) are shown in green and lines 

and arcs (G1, G2, and G3) are shown in black. 

c. Click the 3D Simulation  button, and then click the Play 

 button. This style shows a three dimensional shaded 

rendering of the initial stock and simulates material removal in 

3D. Any gouge caused by holder interference or the tool hitting 

the part during a rapid move is displayed in pink. 

d. Click the 2D Simulation  button, and then click the Play 

 button. For milling this style shows a flat (from the top) 

view of the part, with each tool being shown in a different color. 

For turning, this style shows a cross section of the part. 
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7. To view the generated NC code, click the NC Code tab in the 

Results window. 

You are now ready to take a quick interface tour (see page 15). 
 

Saving your work 

To save a FeatureCAM part file the first time: 

1. Select File > Save from the menu. 

2. In the Save As dialog, choose the folder to store your file. 

3. Enter the name in the File name field. By default, the file is called 

FM[N].fm, where N is an incremental number. 

 FeatureCAM automatically appends an fm suffix to your part 

file name - this identifies file as a FeatureCAM file. 

4. Click Save. 

In FeatureCAM, you have the option of saving a number of previous 

versions of your part as you work. 

To create a backup copy: 

1. Select Save Options from the File menu. 

2. In the Save Options dialog, select the Create Backup Copies 

option. 

3. Enter the Number of copies to keep, for example 1. 

4. Choose the backup location. 

5. Click OK. 

Now when you save your file, the last saved version is saved as 

Backup of <Filename>.fm in the same location as the original. 
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Interface tour 
The FeatureCAM interface contains a number of traditional Windows 

elements, such as toolbars, dialogs, context menus, and wizards. 

 

 - Title bar (see page 16) 

 - Menu bar (see page 16) 

 - Toolbars (see page 17) 

 - Graphics window (see page 26) 

 - Toolbox window with the Steps (see page 31) panel, Part View 

(see page 45) panel, and Browser (see page 47) 

 - Results (see page 49) window 

 - Assistance bar (see page 50) 

 - Feature/Geometry Edit bar (see page 50) 

 - Status bar (see page 50) 

As with other Windows programs, you can tell FeatureCAM what to do 

in several ways: 

 Select a button on a toolbar; 
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 Select an option from a menu; 

 Select an option from a context menu; 

 Press a keyboard shortcut. 

As you master FeatureCAM, try combining several methods of issuing 

commands to get your work done faster. 
 

Title bar 

Like most Windows applications, FeatureCAM has a Title bar at the top. 

At the left side of the bar is the control  icon, and at right side of the 

bar are three standard icons: minimize , maximize/restore , and 

close . 

 You can maximize the FeatureCAM window on the screen by 

double-clicking the Title bar. To restore its previous size and 

position, double-click it again. 

The type of part setup is shown in round brackets, for example: (Milling), 
and the name given to your part file is shown in square brackets, for 

example: [first1.fm]. When you have any unsaved changes in your part 

file, an asterisk (*) is displayed next to its name. 
 

Menu bar 

The Menu bar contains all commands available in FeatureCAM. Menus 

are grouped by similar  functionality. For example, all commands related 

to features and geometry are located under the Construct menu, all 

commands related to user assistance are located under the Help menu 

and so on. 

When a menu has a right-pointing arrow, such as , 

there is a submenu associated with that choice. 

When a menu item is followed by three dots, such as , there is a 

dialog or a wizard associated with that choice. 

You can use the keyboard to navigate around the menus. To do this, press 

and hold the Alt key, and then press the letters on your keyboard that 

correspond to the letters underlined on the Menu bar and in the menu 

options. For example, to rotate your part, press and hold the Alt key, 

press V for View menu, press V for Viewing Modes, and press R for 

Rotate. 
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This manual contains a full list of the keyboard shortcuts (see page 52). 

Typically, use the Ctrl-key shortcuts for standard Windows commands 

(Ctrl+N to create a file; Ctrl+S to save a file), and the Alt-key shortcuts 

to execute FeatureCAM-specific commands (Alt+R to refresh the view). 
 

Toolbars 

FeatureCAM toolbars provide quick access to frequently used commands. 

Every button on a toolbar includes a tooltip, which describes the function 

the button activates. As well as the tooltip, the Assistance bar (see page 

50) prompts you for the next step in the process. It senses your context, 

and helps you design geometry and features. 

You can rearrange, open and close toolbars: 

 To move a toolbar, click the double-dotted line at the edge of the 

toolbar, and drag it to a different location. 

 To open or close toolbars, right-click an empty area next to the last 

toolbar on the screen, and choose from the list of available 

toolbars, as shown below: 

 

In addition to rearranging the existing FeatureCAM toolbars, you can 

customize their appearance and content, and create your own toolbars. 

If a toolbar button has a down-pointing arrow next to it, such as , a 

submenu toolbar is associated with that choice. Click the triangle to open 

the menu, and select a specific option. As you move through the menu, 

additional help is displayed in the Status bar (see page 50). When the 

option is selected, it becomes the current command and is displayed as a 

button in the toolbar. To repeat the command, click the button in the 

toolbar. To choose a different command, click the triangle again. 



 

18 • Using FeatureCAM FeatureCAM 2011 Getting Started  

Some buttons on toolbars let you choose a program mode. For example, 

to create a circle, you need to be in circle-creation mode. To rotate your 

part, you need to be in rotation mode and so on. FeatureCAM remains in 

the selected mode until instructed otherwise. To identify the mode you 

are in, look at the buttons. A pale gray border around a button indicates 

that the corresponding mode is currently active. 

 

To leave the mode, usually you need to click the button again. 
 

Standard toolbar 

 The New Part Document button creates a new part 

file. You can control how files are created by selecting 

Options > File Options from the Menu bar, and 

customizing the settings on the New Files tab. 

 The Open button opens an existing file. You can 

control how files are opened by selecting Options > 
File Options from the Menu bar, and customizing 

the settings on the Existing Files tab. 

 The Save button saves the current file. You can 

control how files are saved by selecting File > Save 
Options from the Menu bar. 

 The View menu lets you select viewing modes for 

your part. Your cursor shows the same icon as the 

viewing mode you selected. 

 The Principal View menu lets you select one of 

seven predefined views for your part. 

 The Shade button toggles display of shaded surfaces 

for solid modeling. You need to have the Solid 

Modeling module to use this option. 

 The Undo button reverses the effect of the previous 

command. FeatureCAM remembers a long list of the 

commands that are performed, so you can undo more 

than one command. 

 The Delete button erases the object that is selected on 

the screen. The object is removed from the system. 
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 The Select button turns on select mode. When you are 

in select mode, the mouse appears as a standard arrow 

pointer in the Graphics window. In select mode, you 

can click objects to select them. 

 The Transform button opens the Transform dialog, 

and lets you move or copy the selected entity. 

 The Options Dialog button opens the Options 

dialog, and lets you customize FeatureCAM. 

 The Context Help button switches on context-

sensitive help. When the cursor has changed to a 

question mark (?), click a menu item, button or dialog 

to receive more information. 

 The FeatureCAM Help button opens online help. 

 
 

Advanced toolbar 

 The Show menu contains the object categories that 

can be displayed in the Graphics window. 

 The Hide menu contains the object categories that can 

be hidden in the Graphics window. Hiding objects 

does not delete them; it only removes them from 

display. 

 The Curve Wizard button opens the Curve wizard 

and lets you construct curves. The commands available 

in this wizard are also available from the Curves and 
Surfaces toolbar (see page 20). 

 The Surface Wizard button opens the Surface wizard 

and lets you construct surfaces. The commands 

available in this wizard are also available from the 

Curves and Surfaces toolbar (see page 20). 

 The Solid Wizard button opens the Solid wizard and 

lets you construct solids. This option is available if you 

have the Solid Modeling module. 

 The Toggle Geometry Bar button toggles the 

display of the Geometry toolbar (see page 22). 

 The Snap Modes button opens the Snap Modes 
dialog, which lets you set the locations for point 

snapping. 
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 The New Feature Wizard button opens the New 
Feature wizard, which lets you create features. 

 The UCS button opens the User Coordinate 
System dialog, and lets you create or change existing 

UCSs. 

 The Setups button opens the Setups dialog and lets 

you create or edit part program zero. 

 
 

Curves and Surfaces toolbar 

 The Curve menu lets you use predefined curves, such 

as ellipses or rectangles. 

 The Curve from Curve menu lets you construct 

curves from other curves. 

 The Curve from Surface menu lets you construct 

curves from surfaces. 

 The Surface Primitives menu lets you use 

predefined surfaces, such as spheres or cylinders. 

 The Surface from Curve menu lets you construct 

surfaces from curves. 

 The Surface from Surface menu lets you construct 

a surface from a single surface. 

 The Surface from Surfaces menu lets you 

construct a surface from multiple surfaces. 

 To construct surfaces, you need to have the MILL3D module. 
 

Snap Mode toolbar 

 The Snap to Grid button displays a grid and enables 

snapping to the grid. Selecting Snapping Grids from 

the Options menu controls the spacing of the grid. 

Grid snaps to a point on a coordinate system that is laid 

out on the stock. The grid size can be modified from the 

Options menu. 

 The Snap to Point button snaps to a point object. 

 The Snap to End Point button snaps to the end points 

of finite lines and arcs; it also applies to the corners of 

the stock. 
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 The Snap to Midpoint button snaps to the middle 

points of finite lines and arcs. 

 The Snap to Section button snaps equal intervals of a 

finite line. The number of sections is controlled by the 

Sections parameter of the Snapping Grids dialog. 

 The Snap to Intersection button snaps to the 

intersection of lines, arcs, and circles. 

 The Snap to Center button snaps to circle centers. 

This setting also controls the display of circle and arc 

center points. 

 The Snap to Quadrant button snaps to the four points 

on a circle corresponding to 0°, 90°, 180°, and 270°. 

 The Snap to Object button snaps to a point on another 

object. This includes lines of surfaces and is convenient 

for snapping points to locations on a surface. 

 The Snap to Tangent button snaps the point so that 

the object you are creating will be tangent to the object 

you snapped to. 

 The Snap to Toolpath button snaps to points on a 

centerline toolpath simulation. 

 The Snapping Discrimination Dialog button opens 

the Snap Discrimination dialog if the point you select 

could snap to more than one location. 

 
 

Display Mode toolbar 

 The Shade Selected button shades objects selected on 

the screen. This is the only way to shade features. 

 The Unshade Selected button removes shading from 

the selected objects, and returns them to line drawings. 

 The Unshade All button returns all objects to line 

drawings. 

 The Hidden Line button toggles the view of solids to 

hidden line mode. 

 The Draft Hidden Line button toggles the view of 

solids to draft hidden line mode. 
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 The Show Normals button shows the normals for 

selected surfaces in the model. 

 The Unshow Normals button hides the normals for 

selected surfaces in the model. 

 The 2D Turned Profiles button shows turning features 

as 2D profile. 

 
 

Geometry toolbar 

 The Point button creates a point at X Y Z 

coordinates. 

 The Line menu lets you create different types of 

lines. 

 The Circle menu lets you create different types of 

circles. 

 The Fillet menu lets you create different types of 

fillets. 

 The Arc menu lets you create different types of arcs. 

 The Dimension menu lets you create dimensions, or 

special text labels with attached lines to indicate your 

part's size. 

 The Edit menu lets you edit selected geometry. 

 The Chain menu lets you construct feature curves 

from selected geometry. 

 
 

Simulation toolbar 

 The Eject button removes the Simulation toolbar 

from the screen, and erases the simulation from the 

Graphics window. 

 The Show Centerline button selects a centerline 

simulation. When you click the Play button, the 

simulation is performed using the current view to draw 

the toolpaths. A line drawing representing the center of 

the tool tip is displayed. 
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 The 2D Simulation button selects 2D simulation. 

When you click the Play button, a two-dimensional 

color simulation is performed showing the regions cut 

by each operation. The view is changed to the top view 

automatically, and anything on the screen is 

temporarily erased until the simulation is complete. 

You can't change the view during the simulation. Once 

the simulation is complete you can change the view, 

but the toolpaths are erased. 

 The 3D Simulation button selects 3D simulation. 

When you click the Play button, a 3D shaded 

simulation is performed in the current view with the 

tool animated through all of its moves. You can 

dynamically change the view of the simulation at any 

point during or after the simulation. The simulation 

does not have to be recalculated, so the view change is 

instantaneous. 

 The 3D RapidCut button selects rapidcut simulation. 

When you click the Play button, a 3D simulation is 

performed without animating the tool. Only the final 

results are displayed. For most parts, the simulation 

takes only a few seconds to complete. This simulation 

can be viewed dynamically. 

This simulation type is available if you have the 

FeatureCAM3D module; it does not apply to turned 

parts. 

 The Machine Simulation button selects machine 

simulation. When you click the Play button, a full 

machine simulation is performed showing you how the 

machine will cut the part. Odd motions and collisions 

can be detected so that the program can be adjusted 

long before code is sent to the CNC machine. 

This simulation type is available if you have the 

Machine Simulation module. 

 The Stop button cancels a simulation. 

 The Play button starts a simulation, or resumes a 

paused simulation. 

 This button starts a simulation of the selected feature, 

or resumes a paused simulation. 
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 The Pause button pauses the simulation. It appears on 

the toolbar when you press the Play button. Clicking 

the Pause button transforms it back into the Play 
button. 

 The Fast Forward to End button speeds up the 

simulation, and fast forwards it to the end. 

 This button speeds up the simulation of selected 

feature, and fast forwards it to the end. 

 The Single Step button moves the simulation ahead 

by one tool move. The keyboard accelerator for this 

button is Alt+F3. 

 This button moves the simulation of selected feature 

ahead by one tool move. 

 The Simulation Next menu lets you specify how the 

simulation is played. 

 The Simulation Next menu lets you select how the 

simulation of selected feature is played. 

 The Clear Toolpath button erases any centerline 

toolpaths shown on the screen. 

 The Region of Interest button lets you limit the 

portion of the part that is rendered during a 3D solid 

simulation or a rapidcut simulation. 

 The Show Tool Load button displays the Tool 
Load dialog when the next 3D simulation is played. 

This dialog graphs the horsepower requirements of the 

part program, and displays the current simulation time 

and instantaneous horsepower. 

 The Sim Speed slider is used to adjust the simulation 

speed. Moving the bar to the right speeds up the 

simulation; moving the bar to the left slows it down. 
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Steps toolbar 

 

The buttons on the Steps panel (see page 31) in the Toolbox window 

are also available as the Steps toolbar. 

 Display this toolbar if you want to use the Part View panel (see 

page 45), but need an easy access to the buttons on the Steps 

panel. 
 

Solid toolbar 

 The Solid from Curve menu lets you construct 

solids from curves. 

 The Solid from Surfaces menu lets you construct 

solids from surfaces. 

 The Modify Solid menu lets you edit solids. 

 The Manufacturing Solids menu lets you select a 

manufacturing category. 

 
 

More Simulation toolbar 

 This button toggles the display of the Simulation 

toolbar (see page 22), and lets you preview the toolpaths 

from start point. 

 This button toggles the display of the Simulation 

toolbar, and lets you preview the toolpaths for selected Z 

level. 

 This button toggles break points in the simulation at 

toolpath level. 

 This button toggles break points in the simulation at Z 

level. 

 

 



 

26 • Using FeatureCAM FeatureCAM 2011 Getting Started  

Graphics window 

The Graphics window is your main working area. It shows the 

graphical representation of the part, and the graphical toolpath 

simulations. 

You can control how much space the Graphics window uses compared 

to the Toolbox and the Results windows by moving the sliders  from 

side to side. Alternatively, try expanding and collapsing the Toolbox and 

the Results windows by clicking the corresponding  and  icons. 

 In most cases, right-clicking in the Graphics window displays a 

context menu with some options for the current situation. 
 

Mouse buttons 

The left, middle, and right mouse buttons have specific uses in 

FeatureCAM. 

 Left mouse button selects objects, such as geometry, interface 

objects (buttons, tabs), and objects in the Part View panel. 

 Middle mouse button is used to dynamically view objects in the 

Graphics window. By default, holding the middle mouse button 

as you drag the mouse zooms the view. Using the Ctrl key and the 

middle mouse button rotates the view. Using the Ctrl+Shift keys 

and the middle mouse button pans the view. You can customize the 

middle mouse behavior by selecting Options > Viewing from the 

menu. 

 Right mouse button activates context-sensitive menus. For 

example, positioning the mouse cursor over the Steps panel, and 

right-clicking lets you customize the look of the buttons on the 

Steps panel. 
 

Mouse cursor 

The cursor shape may change to indicate the mode that is currently 

selected. 

In select mode, the cursor arrow indicates what you are selecting, or what 

the system expects you to select: 

 - Part View panel. 

 - Steps panel. 
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 - area that you can expand/collapse on the screen. 

 - editable area on the Status bar. 

 - stock. 

 - feature. 

 - geometry (point). 

 - geometry (line). 

 - geometry (circle, arc). 

 - geometry (fillet). 

 - geometry (dimension). 

 - geometry (surface). 

 

In view mode, the cursor takes a shape of the chosen option, showing you 

what you can do with the part: 

 - rotate along the X and Y axes. 

 - trackball. 

 - pan, that is move around without changing the magnification. The 

part is moved perpendicular to the viewing angle. 

 - zoom, that is change the display magnification. Moving the mouse to 

the right enlarges the part, moving the mouse to the left shrinks the part. 

 You can also zoom in and out using the mouse wheel. 

 - zoom to a box (selected area). The selected portion of the drawing is 

enlarged to fill the Graphics window. 

 - pan and zoom. The point where you click is centered on the screen, 

and then the part is zoomed with the mouse movement. 

 - rotate along the X axis. 

 - rotate along the Y axis. 

 - rotate along the Z axis. 

In geometry mode, the cursor changes to crosshairs . A number next to 

the cursor indicates the progress of the shape construction, for example, a 

construction of an arc, requires creating three points. 
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When you use snap mode, a small snap icon shadows the cursor. When 

snapping to a circle center, endpoint, midpoint, quadrant or section, the 

snap icon is a small box: 

 

When snapping tangent to a circle or arc, the icon is a small circle that 

can slide along the circle or arc while maintaining tangency: 

 

Snapping to a grid point, the icon is a small plus sign: 

 

When snapping to an object, the icon is a large dot: 

 

When you chain geometry, your mouse cursor looks like a target point: 

. 
 

Smart dialogs 

To provide you with more space in the Graphics window, FeatureCAM 

automatically minimizes some dialogs by default. For example, the 

Select Stock Curve dialog minimizes into a small title bar when you 

click the Pick Curve  button. 

When the dialog is minimized, the cursor shape changes to . This 

indicates you need to select an object in the Graphics window. When 

you select the object, the dialog is restored. If you want to restore the 

dialog without making a selection, click the  button in the small title 

bar. 

 To disable auto-minimization, deselect Options > Warp Dialogs 

in the menu. 
 

Selecting graphical objects 

Select mode is chosen by default. If you need to switch it on, click the 

Select  button on the Standard toolbar. 

To select objects in the Graphics window you can: 
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 Click the left mouse button on an object. This selects that object 

(by turning it red) and deselects any other object. 

 Hold down the Shift key and click the left mouse button on an 

object. This adds that object to the selected set of objects. This 

method allows you to select more than one object. 

 Click the left mouse button and drag the mouse before releasing the 

button. This method is called box select. As you drag the mouse, 

a box is displayed in the Graphics window. All objects that are 

completely enclosed in the box are selected. If you hold down the 

Shift key while selecting, the objects are added to the selected set 

of objects. 

 
 

Viewing and shading your part 

Viewing 

Viewing is performed interactively in FeatureCAM with the mouse. You 

can choose a number of viewing options from the View menu on the 

Standard toolbar. By default, each viewing command executes only 

once. To stay in the selected viewing mode, press the Ctrl key on your 

keyboard as you click the viewing command. The selected viewing option 

is now active until you deselect it on the toolbar. 

 Once you've selected a viewing option, you can activate it again, by 

holding the Shift key and pressing the right mouse button. 

Instead of zooming and panning to position your part, you can choose one 

of the pre-defined view from the Principal View menu on the 

Standard toolbar. You can also create up to four user views, and 

return to them to compare different aspects of your part. 

 To create a user view, position the part in a view you will want to 

return to, and select View > User Views > Save View. 
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Shading 

By default, everything that you create in FeatureCAM is displayed as a 

line drawing, for example: 

 

Objects can also be viewed as: 

3D shaded drawings 

 

3D hidden line drawings 

 

To control the current display mode, use the Display Mode toolbar. 
 

Deleting objects 

There are many ways to delete geometry, curves, surfaces and features: 

 Right-click the object in the Graphics window and choose the 

Delete option from the menu. 

 Select the object in the Graphics window, then press the Delete 

key on your keyboard. 

 Select the object in the Graphics window, then choose Edit - 
Delete from the Menu bar. 

 From the View menu, choose Entities, select the object row in the 

Entities dialog, and click the Delete button. 
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Steps panel 

The Steps panel contains an ordered list of steps for creating part 

programs. Each step is a wizard that presents a series of dialogs for each 

process. They are listed in the order in which you should use them during 

the process of creating a part program. The flowchart below illustrates 

this process. 

 

Step 1: Stock (see page 32). The Stock wizard steps you through 

entering the shape and dimensions of the stock, the stock material, part 

program zero and the coordinate system for modeling. 

Step 2: Geometry (see page 33). Points, arcs, lines and other shapes 

are used to describe the overall shape of parts. Many different geometry 

tools are available. Geometry can also be imported from CAD systems. 
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Step 3: Curves (see page 34). Shapes that involve more than a single 

line or arc are described as curves. For MILL3D customers, there are also 

Surfaces and Solids steps for creating 3D surface and solid models. 

Step 4: Features (see page 35). Features are common shop terms like 

pocket, or thread. They are created from curves and dimensions. These 

objects describe your part in 3D and are used to generate toolpaths. 

Step 5: Toolpaths (see page 36). Toolpaths are generated from 

collections of features. You can simulate them in FeatureCAM using 

toolpath centerlines, 2D shaded or 3D solid shaded simulations. 

Step 6: NC Code (see page 39). Machine-specific G-codes are 

generated from the toolpaths. Translators are provided for many different 

NC controls and include a program for creating new translators. 

Customize Manufacturing (see page 39). FeatureCAM automates the 

entire part programming process, you can customize all of the system 

settings including feed/speed tables, tooling databases or feature settings. 

 If you have 3D, Solid Modeling and RECOGNITION modules, the 

Steps panel may include extra steps (see page 44). 
 

Step 1: Stock 

The stock is the initial material from which you cut your part. It can be 

rectangular, circular, a more general extruded shape, or a solid model. 

The stock shape is used for 3D toolpath simulations and to control the 

extent of milling features like bosses. 

FeatureCAM has embedded feed/speed tables for many different stock 

materials, so that feeds and speeds can be automatically calculated based 

on the stock material. 

The Stock wizard provides step-by-step instructions for specifying or 

modifying the general stock shape, specific stock dimensions, fixture IDs, 

part program zero, and the origin of your modeling coordinate system. 
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To navigate through the wizard, enter the desired information on each 

page and click the Next button to move to the next page. 

 

After completing this step, if you want to create holes, rectangular 

pockets, slots, circular pockets, or thread mill features, you can skip to 

Step 4: Features (see page 35). 
 

Step 2: Geometry 

Each part starts with an initial design. You may already have a part 

drawing, a part sketch or you may want to use FeatureCAM to draw your 

part design from scratch. The geometry step gives you methods of 

creating points, lines, arcs, and circles. You can also clip geometry. 

If you want to create multiple objects, select the Create more than 
one option at the bottom of the Geometry Constructors dialog 

before selecting the type of object you want to create. 
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After selecting the type of object you want to create, you see instructions 

in the yellow Assistance bar at the bottom of the screen. Enter any 

numeric arguments that are required. Use the Tab key to move to the 

next field. For point coordinates, either type the individual X, Y and Z 

coordinates, or use the mouse to graphically locate them in the Graphics 
window. 

As you move the mouse around the Graphics window, the cursor snaps 

to discrete locations like circle centers or line endpoints. You control this 

location using the Snap Mode toolbar (see page 20). Alternatively, you 

can select Options > Snapping Modes from the menu, and use the 

Snap Modes dialog. 
 

Step 3: Curves 

This step groups arcs and lines into curves by automatically tracing 

smooth paths. If you want to make a feature from more than a single line, 

arc or circle, you must connect the geometry into a curve. 

 
This option creates closed curves (curves that form a 

loop) by clicking on one piece of geometry. An attempt 

is made to create a closed loop by following smooth 

paths. 

If this method does not result in the correct pieces, click 

the Clear Pieces button in the Feature/Geometry 
Edit bar, select the Curves step again, and use the 

Pick Curve Pieces command. 

 
This option creates curves by manually clicking on 

segments of the curves. To create an open curve (curves 

that do not form a loop), click the beginning of the 

curve and then click the end. If the resulting curve is 

not correct, click a number of intermediate positions to 

guide the process of creating curves. Closed curves can 

also be created with this technique by clicking back to 

the initial piece of geometry. 

 
This option opens the Curve wizard that provides step-

by-step instructions for creating curves using a variety 

of methods. 

 
This option lets you create curves using the projection 

of straight walled vertical surfaces. This method is only 

available if you have a licensed RECOGNITION 

module. 

 
 



 

FeatureCAM 2011 Getting Started Using FeatureCAM • 35
  

 

Step 4: Features 

These are examples of features: 

Hole Rectangular 
pocket 

Pocket Boss 

 
 

 

 

Step bore Side Turned 
groove 

OD turning 
feature 

 

 

  

Toolpaths are generated from features. For example, if you want a hole in 

your part, choose the Hole feature. If your part has a pocket, choose the 

Pocket feature. The New Feature wizard walks you through the 

process of creating features. 

 

One category of features is those that can be created solely from 

dimensions. These features include holes, rectangular-shaped pockets, 

threads, and round pockets (called step bores). 

Other features require curves to describe their shape. They are listed 

under the From Curve category. These features include pockets, bosses, 

grooves, chamfers, rounds, sides, and faces. 
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If you want to create a pattern of features, select the Make a pattern 
from this feature option. Click Next to step through the wizard. 

This wizard steps you through: 

 Selecting the feature type. 

 Optionally entering pattern dimensions. 

 Positioning the feature. 

 Specifying the manufacturing strategy. 

 Reviewing the automatically selected tools. 

 Reviewing the automatically calculated feeds and speeds. 

 Overriding the tooling and feed/speed values. 

 Changing manufacturing attributes. 

To modify a feature either double-click on it or select it and click the 

Properties button to open the Properties dialog. The dialog presents 

the pages of the New Feature wizard in a single dialog. The individual 

pages are separated into different tabs of the dialog. 
 

Step 5: Toolpaths 

This step displays the Simulation toolbar. This toolbar has two sections, 

simulation types and simulation controls. 

 

To run a simulation: 

1. Select the mode of simulation you would like to run from: 

 Centerline simulation displays lines that represent the center 

of the tool: 
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 2D shows a color simulation from the top view. Each operation 

is displayed in a different color: 

 

 

 3D shows a 3-dimensional solid shaded simulation: 

 

 

 RapidCut displays the final result without animating the tool. 

This option only applies to MILL3D module. 
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 Machine simulation displays the entire machine. This option is 

only available if you have the Machine Simulation module. 

 

 

2. Use the simulation controls to control the simulation: 

Click the Play button to run the simulation. After clicking the 

Play button, this button turns into the Pause button. Click this 

button again to pause the simulation. 

The Single Step button will display one toolpath move. The Fast 
Forward to End button, displays all the toolpaths for the part 

without animating the results. You can then view the toolpaths for 

each individual operation by clicking the Clear button and then 

clicking on an operation in the Operation List window. 

The Play to Next Operation button will display one complete 

operation such as a spot drill or a pocket roughing operation. This 

button is actually a menu. By clicking on the triangle to the right of 

the button the following additional options are revealed: 

 

The Next Rapid button simulates up to the next rapid move. 

The Next Tool Change button simulates up to the next tool 

change. 

Play to Next Z Level displays the next Z level of a Z level rough 

or finish operation. 
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Use the Erase button to erase the centerline toolpaths on the 

screen. The Region of Interest is used to limit the portion of the 

part that is simulated for 3D or Rapid Cut simulations. The 

Show tool load button indicates whether to display a graph of 

the tool load when the next 3D simulation is performed. The Eject 
button removes the toolbar and the simulation from the screen. The 

speed control slider controls how fast simulations run. Move the 

slider to the right to speed up, or to the left to slow down. 

3. If you see something in the simulation you want to change, you can 

override any of the tool choices, operation order, or the feeds and 

speeds if you wish. Continue to simulate and fine-tune the part 

until you have the settings exactly right. 
 

Step 6: NC Code 

You generate NC code in FeatureCAM using this step. The NC Code 

dialog opens. 

 
The Feed Optimization button evens out the load on 

the tool by adjusting the feedrate of each NC block. 

 
The View the NC Code button displays the code in the 

Results window. You can also display the tooling lists 

and operations sheets by clicking the tabs located at the 

bottom of the Results window. 

 
The Save NC button opens the Save NC dialog and lets 

you save the NC code to disk. You can also save 

additional documentation like tool lists, operations lists 

and part databases. 

 
The Tool Mapping button lets you change the locations 

of the selected tools in the tool changer. 

 
 

Customize manufacturing 

This step lets you customize the tools and materials databases, post 

options, and the default system parameters. The Customize 
Manufacturing dialog opens. 

 
The Machining Attributes button lets you configure 

machining preferences (see page 40). 

 
The Create tools and manage tool crib contents 

button lets you configure the tools database (see page 

42). 
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The Feeds/Speeds and Cutting Data Tables button 

lets you configure the materials database (see page 43). 

 
The Post Process Options button lets you customize 

post options (see page 44). 

 
 

Machining preferences 

Machining preferences, or attributes, control the way a feature is 

manufactured. FeatureCAM has two types of attributes: 

 Default - specify the defaults for values such as stepovers, 

ramping, canned cycle use, or operation ordering. These settings 

are used for all features that you create. 

To modify the default attributes, select the Customize Mfg.  

step on the Steps panel, and click the Set default feature 

attributes  button in the Customize Manufacturing 

dialog. This opens the Machining Attributes dialog. 

 

The configurable attributes are divided into three categories: 

Milling, Turning, and Wire. Select a option, and then modify the 

settings as desired. The settings are saved with the FeatureCAM 

file. 
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 Feature - apply to specific features, and override the default 

settings. For example you may set a default setting for climb 

milling, but override it for bi-directional roughing for a particular 

feature.  

To set feature attributes, select the feature in the Graphics 

window, and click the Properties button located below the 

Assistance bar. 

 

This opens the Properties dialog. Click on an operation in the 

tree view, to display tabs that are specific to the operation. Use this 

dialog to adjust the settings for the selected feature. 
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Tools database 

FeatureCAM supports all the tool types in your shop including drills, 

taps, reamers, end mills, boring bars, and face mills. Each tool type is 

described by a series of dimensions. Tools are grouped into tool cribs. 

FeatureCAM provides a comprehensive tools database and creates a basic 

tool crib for inch, or millimeter tools, or both. FeatureCAM selects tools 

from the active tool crib to manufacture the part. You can pick the tool 

crib you want to use for each part or machine. 

You can also create custom tool cribs with the Tool Manager to reflect 

the tools owned by your shop or to exactly represent the tools preloaded 

in your tool changer. 
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Materials database 

FeatureCAM comes standard with an integrated materials database. Feeds 

and speeds are stored in tables for each material. Each table contains the 

settings for different cutting operations. These tables can be customized 

to change the values or you can add tables for new materials. 
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Post options 

FeatureCAM has many post processors built-in. To tell FeatureCAM, 

which one you want, use the Post Options dialog. It lets you customize 

various settings for milling, turn/mill, or Wire EDM posts. 

 
 

Optional steps 

 - Surfaces. This step is available in MILL3D. This step launches 

the 3D Surface wizard which steps you through creating surfaces from 

curves, primitive surfaces, surfaces from one surface, and surfaces from 

multiple surfaces. 

 - Solids. This step is available in the Solid Modeling option. The 

Solids step initiates the Solids wizard which helps you create solids 

using numerous techniques. 

 - AFR. This step is available in the RECOGNITION option. AFR 

stands for Automatic Feature Recognition. This step automatically 

recognizes features from solid models. 
 



 

FeatureCAM 2011 Getting Started Using FeatureCAM • 45
  

 

Part View panel 

The Part View panel provides a hierarchical view of the part. 

 

Each setup is listed with each of the feature of the setup listed underneath. 

From this view you can select, show, hide, or modify features. 

All objects are represented in the part view with the exception of 

geometry. When you click on an object in the Part View panel, its icon 

is highlighted in red, for example . 

 

 Part icon represents the entire part. The part filename is also 

displayed in the tree view. 

 Stock icon represents the part stock. 

 Setup icon represents a setup. The features of a setup are listed 

underneath a setup. If you click a setup, it changes the current 

setup and current UCS. 

 Feature icon represents features. It can be a 2.5D, 3D or turn 

feature. The check box next to the feature can be used to exclude 

it from toolpath generation. The feature is not deleted; it is just 

ignored for toolpath generation. 

 Pattern icon represents patterns. It can be linear, radial, 

rectangular, or points pattern. Patterns lets you quickly create the 

same feature at multiple locations. The check box next to the 

pattern can be used to exclude associated features from toolpath 

generation. The feature is not deleted; it is just ignored for 

toolpath generation. 

 Curve icon represents a curve in the part model. 

 Surface icon represents surfaces. Surface milling features are 

classified as features, not surfaces. 

 Solid icon represents a solid. Individual design features are listed 

underneath. 
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 Turret icon represents a turret on a lathe. Selecting a specific 

turret displays the NC code for that turret. 

To navigate the Part View tree: 

 If an object has a + in its left margin, click it to expand the view to 

reveal objects that are subordinate. Click the - to collapse the view 

and hide the subordinate objects. Double-clicking on the object 

also performs the same function. 

 Clicking on an object in the tree view will select the object in the 

Graphics window. This selection method is good for 

distinguishing between overlapping objects in the Graphics 
window. Make sure you click the name and not the check box. 

 Clicking on an object also reveals the  button for that feature. 

Clicking this button brings up a menu of actions you can perform 

on the object. The actions available are dependent on the object 

type. Right-clicking on the object in the tree view also reveals this 

menu. 

 Features have check boxes. Deselecting the check box excludes the 

corresponding object from the next toolpath generation. 

 You can reorder these items by dragging a feature or setup. 

 Double-clicking on a feature displays its Properties dialog for 

editing. 
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Browser 

The Toolbox contains a Browser. 

 

To open the browser, click the Browser tab inside the Toolbox 

window. 

The Browser contains information on the latest features available in 

FeatureCAM, including example files that you can load straight into 

FeatureCAM. To load an example project from the Browser, click the 

preview picture. 
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Click the Folder  icon to open a folder containing more files. 

 To make the Browser wider, hover over the Toolbox border until 

the cursor changes to , then click and drag the border outwards. 

 

Browser buttons 

The Browser contains the following buttons at the top: 

 Home - Click to go home to the default Browser home page. 

 Website - Click to open the FeatureCAM website 

(www.featurecam.com). 

 Release Center - Click to open the FeatureCAM Release 

Center website (releasecenter.featurecam.com). 

 Forum - Click to open the FeatureCAM user forum 

(forum.featurecam.com). 

 Email - Click to email Delcam about non-support-related 

issues, or if you don't have the email address of your reseller. 

 You may need to go back to the top of the page to see these buttons 

by scrolling or using the Top button detailed below. 

 

And the following button at the bottom: 

 Top - click to go to the top of the current page. 

 

Context menu 

Right-click inside the browser to open a context menu that includes the 

following items: 

Back - the Browser returns to the previous page that you viewed. 

Select All - selects all the content on the Browser's current page. 

Print - prints the Browser's current page. 
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Refresh - reloads the page to include any changes that have been made 

to the page. 
 

Results window 

The Results window contains the automatically generated 

documentation including tooling lists, setup sheets, and the NC part 

programs. Selecting one of the tabs at the bottom of the window changes 

the content of this window. 
 

Op List tab 

The Operation List tab contains a table with manufacturing operations for 

your part. 

 

 

Each row displays the operation, feature that the operation came from, 

and the tool that will be used to cut the feature. As the toolpaths are 

simulated, the current operation is indicated with a yellow arrow in the 

left-hand margin. To edit a feature, double-click the corresponding row. If 

a manufacturing error is detected, a warning  sign is displayed in the 

left-hand side of the row. Double-clicking on the icon takes you to the 

description of the problem on the Details tab. 
 

Details tab 

The Manufacturing Details tab contains two sheets: 
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 Operations List lists the cut type, cut depth, center point, tool 

details, speed/override, feed/override and estimated manufacturing 

time for each manufacturing step. 

 Tool List provides in-depth information for the tools used to 

manufacture the part, including tool name, tool slot or tool pocket 

number, tool offset number and so on. 

To view a sheet, select the corresponding options. 
 

NC Code tab 

This tab contains the generated NC code for your part. The tab appears 

when you select the NC Code step from the Steps panel. If you select 

the NC Code step before you have generated toolpaths, FeatureCAM 

prompts you to create the toolpaths, and then opens the NC Code tab. 
 

Assistance bar 

The yellow Assistance bar displays step-by-step instructions for the 

current command. 
 

Feature/Geometry Edit bar 

The Feature/Geometry Edit bar is located below the Assistance bar. 

It is context-sensitive, and lets you select and edit a feature, or enter the 

point locations and parameters for geometry creation. 
 

Status bar 

The Status bar appears at the bottom of the FeatureCAM screen. It 

shows your current drawing units, toolcrib, and post processor settings, as 

well as your keyboard status and information about the simulation when 

you run one. 

 This is not a toolbar; you can't move it around, but you can turn it 

on and off by selecting View > Toolbars from the menu and using 

the check box in the Misc tab. You can also customize the 

simulation information by going to Options > Simulation, and 

selecting the options in the Status frame for all items that you want 

to be displayed. 

The Status bar contains: 

Cursor coordinates - the current X Y Z location of the cursor in the 

Graphics window. 
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Grid coordinates - the grid point X Y location of the cursor in the 

Graphics window. 

Drawing units 

Layers - the currently active layer. You can change the layer by double-

clicking it here. 

User Coordinate System (UCS) - the currently active UCS. UCS is 

an origin and three vectors (X, Y, and Z) that determine a position and 

orientation in 3-dimensional space. You can use an unlimited number of 

these to conveniently model your part. To change the currently active 

UCS, double-click its name. 

Setup - the currently active setup for your part. A setup is an orientation 

and part program zero for a physical setup on the machine tool. You 

change the setup by double-clicking its name. 

CNC file - the currently selected CNC file. Double-clicking it opens the 

Post Options dialog, and enables you to change the settings. 

Toolcrib - currently active toolcrib (set of tools in the tooling database). 

You can change the toolcrib by double-clicking its name. 

Keyboard status 

Simulation information, such as tools, feeds/speeds, elapsed time. 
 

Printing 
You can print the Manufacturing Operations and Manufacturing Tool 

Detail sheets, NC programs, and drawing for a part. The files are all 

ASCII text files that print like a text document. 

1. Select File > Print from the menu. 
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2. In the Print dialog, use the Print Range frame to choose what 

you want to print. 

 

 Some options may not be available. For example, if you 

haven't yet generated the NC code, you can't print it. 

3. If you are printing a drawing: 

 To print the toolpaths displayed in the Graphics window, 

select the Print Toolpath option. 

 To print the drawing at actual size, select the Print to Scale 

option. This means, that a 1 inch line segment, for example, will 

measure 1 inch on the paper. 

 To make the drawing fit the paper, leave the Print to Scale 

option deselected. 

4. Choose the Print Quality from the list. The specific options 

depend on your printer. 

5. Set the number of copies to print. 

6. Click OK. 
 

Keyboard shortcuts 
 

Key 
sequence 

Action 

Delete Delete the selected object 

Esc Stop current simulation 

F1 Context-sensitive help 

Alt + F1 Centerline simulation 
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Key 
sequence 

Action 

Alt + F2 Play or pause simulation 

Alt + F3 Single-step simulation 

Alt + 1 

(2,3,4) 

User View 1-4 

Alt + 

Enter 

Properties 

Alt + L Last view 

Alt + R Refresh 

Alt + Shift 
+ V 

Save view 

Ctrl + A Select all 

Ctrl + C Copy 

Ctrl + E Center selected 

Ctrl + F Find (text in a text window). The cursor must be in 

a text window. 

Ctrl + H Replace (text in a text window). The cursor must 

be in a text window. 

Ctrl + L Center all 

Ctrl + N New file 

Ctrl + O Open file 

Ctrl + R New feature 

Ctrl + S Save file 

Ctrl + P Print 

Ctrl + V Paste 

Ctrl + Z Undo 

Ctrl + Y Redo 

Ctrl + X Cut 

Ctrl + 

Shift + A 

Shade selected 

Ctrl + 

Shift + C 

Unshade all 
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Key 
sequence 

Action 

Ctrl + 

Shift + N 

Unshade selected 

Ctrl + 

Shift + P 

Toggles perspective 

 
 

Getting help 
FeatureCAM provides a variety of ways for you to get help as you work. 

Context-sensitive help gives you quick access to the information relevant 

to the tasks you are attempting to carry out. You can also refer to the 

numerous examples in the Examples folder, located in the FeatureCAM 

root directory. Finally, if you cannot find an answer to your question, you 

can visit our website or contact our technical support. 

User manuals 

User manuals are provided in Adobe's Portable Document Format (PDF), 

and can be accessed from the Help menu. 

Online help 

The online help documentation is your primary source for in-depth 

technical information about FeatureCAM. It covers all FeatureCAM 

modules, and can be accessed from the Help menu, or by clicking  on 

the toolbar. 

Three different tabs are available: 

 Contents tab provides an outline view of the help system. 

Double-click a book or a page to open it. 

 Index tab allows you to access the help file using index topics. 

Type the topic name in the top box and click the Display button. 

 Search tab provides search capabilities for all pages of the help 

file. Type the word you would like to find in the top box and then 

pick a topic in the bottom box. Click Display to view the page. 

Context-sensitive help 

You can use one of the following methods to get help relevant to the task 

you are carrying out: 
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 For some commands, FeatureCAM automatically displays the step-

by-step instructions in the Assistance bar. 

 

 When you hover the mouse over a toolbar icon for a few moments, 

a description of the icon is displayed. 

 

 Pressing F1 displays the relevant help page. 

 Most FeatureCAM dialogs have the Help button. Clicking it 

displays the relevant help page. 

 Click the Context Help  button on the toolbar. When the 

cursor has changed to a question mark (?), click a menu item, 

button or dialog for more information. 

Links 

You can find FeatureCAM information online via the Help menu: 

Select: 

 Help > FeatureCAM Training to book a training session. 

 Help > FeatureCAM on the Web for product news, online 

support, discussion forum, and mailing list. 

 Help > Check for New Version for product updates. 

Technical Support 

If you have any questions related to FeatureCAM, which you cannot find 

an answer to in the documentation, you can contact the Delcam technical 

support service. Email support@featurecam.com, describing your 

problem as precisely as possible. This support is free for the first 60 days 

after your initial purchase and 30 days after the purchase of an upgrade. 
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 You must have MILL2.5D to perform this tutorial. 

This tutorial uses a simple example to introduce you to: 

 Creating features 

 3D viewing 

 Generating toolpaths 

 3D toolpath simulation 

 Automatic tool selection, feed/speed calculation 

 Dynamically generated setup documentation 

The measurements in this tutorial are in inches; the values in millimeters 

are shown in brackets. 
 

Creating a part file 
 

1. Start FeatureCAM by double-clicking the FeatureCAM icon  

on the desktop. 

2. If the New Part Document wizard is displayed, select the New 
file option, and click Next. Select Milling Setup, click Inch or 

Millimeter, depending on your preference, and click Finish. 

Introduction to 2.5D 
milling 
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If the New Part Document wizard is not displayed, select File > 
New from the menu. Select Milling Setup, click Inch or 

Millimeter, depending on your preference, and click OK. 

3. In the Stock wizard (Dimensions page), enter 1 (25 mm) for 

Thickness, 4 (100 mm) for Width, 5 (120 mm) for Length, and 

click Finish. 

Next time you use MILL, it will remember the stock dimensions 

that you entered last. 

 In this tutorial, we assume that the stock has already been 

prepared. 

4. Click OK to close the Properties dialog. 

For reference, here is a dimensioned drawing of the sample part: 

English Units 

 

Metric Units 

 

5. Create a hole feature. 

a. Select the Features  step from the Steps panel. 

b. In the New Feature wizard, select Hole in the From 
Dimensions frame, and click Next. 

c. Enter 0.5 (12 mm) for the Diameter, and click Next. 
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d. Enter 1.0 (25 mm) for the X location of the hole center and 1.0 

(25 mm) for the Y location. 

e. Click Next. 

The Strategies page opens. This page provides control over 

the types of operations that will be used to cut the feature. The 

default operations for a hole are to spot drill and drill the hole. If 

the hole has a chamfer, the default is to cut the chamfer with the 

spot drill operation. 

f. Accept the default strategy settings by clicking Next. 

The Operations page shows a summary of the operations that 

will be created to cut the feature. The names of the tools that 

have been automatically selected and the feeds and speeds are 

also displayed. 

 

g. Click the triangle next to the Finish button, and select the 

Finish option. 

6. Create a pocket feature. 

a. Select the Features  step from the Steps panel. 

b. In the New Feature wizard, select Rectangular Pocket in 

the From Dimensions frame, and click Next. 

c. Accept the default dimensions by clicking Next. 

d. Enter 0.75 (15 mm) for X, 2.5 (60 mm) for Y and 0 for Z. Click 

Next. 
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The Strategies page indicates that rough and finish operations 

will be created. 

 

e. Click the Finish button. 

7. Use the Features  step to create a second 0.5 (12 mm) 

diameter hole at X=4 (95 mm) and Y=3 (75 mm). 

8. Use the Features  step to create another pocket just like the 

first, except positioned at X=2.5 (55 mm), Y=0.5 (15 mm). 

Your part in the Graphics window should look something like 

this: 

 

9. Select Save from the File menu, and save the part as milling.fm. 
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Viewing 
1. So far you have been viewing the part from the top view. Click the 

Isometric View  button on the Standard toolbar to get a 3-

dimensional view. 

 

2. The Isometric View  button is part of the Principle View 

menu. Click the triangle next to the button to access the menu, and 

select Front to display the front view of the part. 

 

3. Click Isometric to return to the isometric view. 

 See Interface tour (see page 15) for more information about 

pull-down menus. 

The sample part is complete. Now we will use the simulation features to 

see how the part will be manufactured. 
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Toolpaths 

1. Select the Toolpaths  step from the Steps panel. The 

Simulation toolbar is displayed. 

2. Click the 3D  button, and then click the Play  button to start 

the simulation. If the Automatic Ordering Options dialog 

appears, click OK to close it. The ordering options will be covered 

later. 

A solid 3D rendering of the cutting process is displayed. 

 

 MILL runs simulations best in 256 color mode or higher. 

Depending on your video settings, you might see a warning 

about this. You may ignore this warning for this tutorial. 
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3. Click the Play to Next Operation  button. The spot drill 

operation is displayed. 

 

4. Click this button to view each operation until the entire part is cut. 

5. Click Eject . The Simulation toolbar is removed from the 

screen. 
 

Order of manufacturing operations 
The Op List tab in the Results window shows all of the operations that 

the features are translated into. A yellow warning  sign next to an 

operation indicates a potential problem with that operation. If you see any 

warnings, ignore them. 

To use the automatic ordering options: 

1. Ensure that the Automatic Ordering option is selected on the 

Op List tab. 

This means that automatic rules are being applied to order the 

operations. 

2. Change automatic ordering to group together the operations which 

use the same tool. 

a. Click the Ordering Options  button. 
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b. In the Automatic Ordering Options dialog, ensure that only 

the Minimize tool changes option is selected, and click OK. 

 

3. Simulate the part. 

a. Select the Toolpaths  step from the Steps panel. 

The Simulation toolbar is displayed. 

b. Click the 3D Simulation  button, and then click the Play 

 button. 

If the Automatic Ordering Options dialog appears, click 

OK to close it. Notice that the simulation first performs all the 

spot-drills, then the drills, and then the rough and finish milling 

for the pockets. 

c. Click the Stop  button when simulation is complete to exit 

simulation mode. 

4. Change automatic ordering to move the finish operations to the end 

of the list. 

a. Click the Ordering Options  button. 

b. In the Automatic Ordering Options dialog, select Do 
Finish Cuts Last, deselect everything else, and click OK. 

 

The order of operations has changed in the Operation List. 

5. Simulate the part. 
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a. In the Simulation toolbar, click the Play  button. 

The finish cuts for the two pockets are now cut last. 

b. Click the Stop  button when simulation is complete. 

6. Change automatic ordering to match the order of the features in the 

Part View panel. 

a. Click the Ordering Options  button. 

b. Deselect everything, and click OK. 

c. Open the Part View panel. 

The tree view contains all the setups and features you have 

created. See Part View panel (see page 45) for more details. 

d. Click the rect_pock2 item in the Setup1 node, and drag it up 

above hole2. 

 

7. Simulate the part. 

a. In the Simulation toolbar, click the Play  button. 

The second pocket is now cut as the third feature. 

b. Click the Stop  button when simulation is complete. 

So far the order of the operations was determined automatically by a set 

of rules. You can also specify an exact ordering of operations manually. 

To use the manual ordering options: 

1. Select the Manual Ordering option on the Op. list tab. 
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2. In the Fixed Operation Ordering dialog, select Do Not Show 
This Warning Again, and click OK. 

 

3. Select the spotdrill operation for hole2 from the list, and drag it 

up ahead of the drill operation for hole1. 

 

4. Simulate the part. 

a. In the Simulation toolbar, click the Play  button. 

The simulation now performs the operations in the order that 

you had specified. 

b. Click the Stop  button when simulation is complete. 

5. Return to automatic ordering by selecting the Automatic 
Ordering option. 

6. Click OK to close the Automatic Ordering Options dialog. 

 If you want to erase the simulation and remove the 

Simulation toolbar, click the Eject  button. 
 

Part documentation 
Not only did the simulation model the manufacturing of the part, it also 

generated complete tool and operations lists. The tools selected are based 

on the tool cribs you design so you're always sure to simulate what you 

can produce with the tools at hand. The information is already 

computerized and can be printed for use as an operator's checklist. 
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1. Click the Details tab in the Results window. 

By default, the Manufacturing Operations sheet is shown. 

 

You can review this sheet using the scroll bars, or print it by 

selecting Print from the File menu. 

2. Select the Tool List option at the top of the Details tab to show 

the Manufacturing Tool Detail sheet. 
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It contains all of the tools used to create the part based on the crib 

you have selected. 

 You can print this documentation by selecting Print from the File 

menu. 
 

Controlling the automation 
1. Open the Part View panel, right-click hole1 under the Setup1 

node, and select the Properties option. 

 

2. In the Properties dialog, click the Strategy tab, deselect the 

Spot Drill option, and click OK. 

 

3. Select the Toolpaths  step from the Steps panel. 
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4. In the Simulation toolbar, click the 3D  button, and then click 

the Play  button to start the simulation. 

 There is no spot drilling for that hole this time. If you look 

through the operations list, notice there is now only one 

spotdrill operation listed. MILL can optimize the part 

manufacturing process for you, but you control the level of 

automatic optimization you want. 

5. Click Eject . The Simulation toolbar is removed from the 

screen. 
 

NC code 
The purpose of MILL is to generate NC code to manufacture parts with 

CNC machines. After you have simulated the part, you can generate NC 

code. Before you can generate NC code for a part, you have to run a 

simulation to calculate toolpaths. If you are starting this part of the 

tutorial without having just run the simulation described above, simulate 

your part now (see page 61). 

To generate NC code: 

1. Select the NC Code  step from the Steps panel. 

2. Click the View the NC Code  button in the NC Code dialog 

to generate the NC code. 

 If you are running an evaluation copy of MILL, a dongle, a 

device that attaches to the computer printer port, is necessary 

to generate NC code, or save or export files and is not 

available in the demonstration version. When you purchase 

MILL, a dongle is provided to you. 
 

Tool mapping 

1. Select the NC Code  step from the Steps panel. 

2. Click the Remap the Tools  button in the NC Code dialog. 
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3. The Tool Mapping dialog is displayed showing the current tool 

order. You can use it to modify the location of the tools in the tool 

changer. For example, let's move the center drill to the 5th position 

in the tool changer. 

 

a. Click Center_5 in the table. 

b. Change the Tool Number to 5 in the Slots frame. 

c. Click Set. 

 You can't change the number directly in the table. 

4. To save the changes, and close the Tool Mapping dialog, click 

OK. 
 

Changing post processors 
1. Select Manufacturing > Post Process from the menu. 

2. In the Post Options dialog, click the Browse button to view 

available post processors. 

The default folder for milling posts is C:\Program 
Files\FeatureCAM\M-LBRY\DUALUNITS. 

3. Select your processor and click Open. 
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The new processor is shown in the CNC File field. 

4. Click OK to exit the Post Options dialog and use the new post 

processor; click Close to exit the dialog and keep the original post 

processor. 

5. Select the Toolpaths  step from the Steps panel. 

6. Run a simulation of the part to regenerate the NC code. 
 

Saving NC code 

1. Select the NC Code  step from the Steps panel. 

2. Click the Save NC  button in the NC Code dialog. 

3. In the Save NC dialog, accept the default filename and folder, and 

click OK. You are now ready to machine the part. 

 

You have completed this tutorial. 
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 You must have MILL to perform this tutorial. We recommend that 

you complete the Introduction to 2.5D milling (see page 56) tutorial 

before starting this one. 

 

This tutorial builds on the one you just completed and introduces you to: 

 Creating geometry (lines, arcs, fillets, and so on) 

 Creating irregularly-shaped features 

 Contouring around a part and adjusting where the tool plunges 

 

Features from curves 
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Getting started 
In the next sections we will build a curve around the features. The curve 

is created with the layout tools and drawing tools. 

1. Select File > Open from the menu. 

2. In the Open dialog, browse to the part file you created in the 

Introduction to 2.5D milling (see page 56) tutorial. 

 

If you skipped the earlier tutorial, browse to the sample2.fm file 

(in inches), or the mtrc_gsg.fm file (in metric units). If you 

installed FeatureCAM in the default folder, these files are in 

C:\Program 
Files\FeatureCAM\Examples\Tutorials\Features from 
Curves. 

3. Click Open. 
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Setting the snaps 
1. Select Options > Snapping Modes from the menu. 

2. In the Snap Modes dialog, click the following buttons: Grid 
points, End points, Intersections, Circle centers, Tangent 
to objects, Display snap mode dialog. 

 

 Selected buttons have pale grey borders around them. 

3. Ensure the rest of the geometry creation buttons are not selected. 

 If you want to have the Snap Mode toolbar displayed on the 

screen, select the Show Snap Mode toolbar option. 

4. Click OK to close the dialog. 
 

Building circles 

1. Click the triangle next to the button in the Principal View  

menu in the Standard toolbar, and select the Top option. 

 It is usually easier to draw geometry in this view. For more 

information about the toolbar options, refer to the Interface 

tour (see page 15). 

2. Select the Geometry  step from the Steps panel. 
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3. In the Geometry Constructors dialog, select the Create more 
than one check box at the bottom of the dialog, and click the 

Circle from Rad, Center  button. 

4. In the Feature/Geometry Edit bar, enter R = 0.75 inch (20 mm). 

5. In the Graphics window, click near the center of one hole. The 

snap jumps to the grid at the hole's center. If you miss the hole 

center, click Undo  on the Standard toolbar and try again. 

 

Repeat this action for the other hole. Your part now looks similar 

to the figure below: 

 
 

Drawing lines 

1. Select the Geometry  step from the Steps panel. 

2. In the Geometry Constructors dialog, ensure the Create 
more than one check box is selected, and click the Line from 2 

Pts  button. 



 

FeatureCAM 2011 Getting Started Features from curves • 75
  

 

3. Use the diagram below to draw lines in the Graphics window: 

 

a. To create the first point x1, click the top of the right circle. 

If more than one snap possibility exists for the point you are 

creating, the Snap Discrimination dialog opens. Select the 

Tangent to circle option, and click OK. 

b. For the second point x2 click the upper left grid point. 

c. Continue building lines from point x2 to point x3, from point 

x4 to point x5, and from point x5 to point x6. 

4. Create corner fillets. 

a. Select the Geometry  step from the Steps panel. 

b. In the Geometry Constructors dialog, ensure the Create 
more than one check box is selected, and click the Corner 

Fillet  button. 

c. In the Feature/Geometry Edit bar, enter R = 0.75 inch (20 

mm). 

d. Position the mouse in the upper left corner, and click. A corner 

fillet appears automatically trimming the lines to fit. 
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e. Position the mouse in the lower right corner. A corner fillet 

appears automatically trimming the lines to fit. 

The drawing should look something like this: 

 
 

Chaining a curve 

1. Click the Curves  step from the Steps panel. 

2. In the Curves Creation dialog, select the Closed Curve  

button. 

3. In the Graphics window, click the bottom line. 

 

MILL automatically chains a closed curve, and chooses a smooth 

path so you don’t have to chain all curves manually. 
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Creating a feature from a curve 
1. With the curve still highlighted in the Graphics window, select 

the Features  step from the Steps panel. 

 

2. In the New Feature wizard, select Boss in the From Curve 

frame, and click Next. 

 

The curve you selected is already selected in the wizard. 

3. Keep clicking Next until you get to the Dimensions page. 

4. Set the Height to 0.75 (20 mm). 

5. Click Finish. 
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Simulating the part 
You are now ready to simulate your part. 

1. Click the Isometric View  button on the Standard toolbar to 

get a 3-dimensional view. 

2. Select the Toolpaths  step from the Steps panel. 

3. In the Simulation toolbar, click the 3D  button, and then click 

the Play  button to start the simulation. If the Automatic 
Ordering Options dialog appears, click OK to close it. 

The 3D simulation is displayed in the Graphics window. 

 

4. Click Eject . The Simulation toolbar is removed from the 

screen. 
 

Modifying the boss feature to contour 
around the part 

If you watched the simulation carefully, you saw that the boss feature 

performed both a roughing and finishing operation. To simply contour 

around the outer boundary of the part, you need to eliminate the roughing 

operation. The operations that are initially created for a feature are 

specified on the Strategies page of the New Feature wizard, but you 

can easily modify the strategy for any existing feature. 

To modify the feature's strategy: 

1. In the Graphics window, select the boss1 feature. 
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2. Click the Properties button in the Feature/Geometry Edit bar. 

The Properties dialog opens. It contains the pages of the New 
Feature wizard as separate tabs. 

3. Click the Strategy tab. Notice that the Rough and Finish check 

boxes are selected. Deselect the Rough option, and click OK. 

 

4. Select the Toolpaths  step, and simulate the part. 
 

Changing the plunge point 
During the simulation, you saw that the tool ramped on and off the part at 

the location where you chained the curve. At the moment, the tool is 

plunging on the stock. Let's modify the plunge point for this operation. 

To change the plunge point: 

1. Click the triangle next to the button in the Principal View  

menu in the Standard toolbar, and select the Top option. 

2. In the Graphics window, select the boss1 feature, and click the 

Properties button in the Feature/Geometry Edit bar. 
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The Properties dialog opens. The left-hand side of the dialog 

contains the tree view. It shows the feature with its operations 

listed underneath. By clicking on an operation in the tree view, you 

can modify an operation. 

 

3. Click the finish operation in the tree view. The tabs of the dialog 

change to represent information specific to the operation. 

4. Click the Milling tab. This tab contains the various attributes for 

changing the toolpaths that are generated for the operation. 

5. Select the Plunge points attribute, and click the Pick Location 

 button. 

The Properties dialog warps away, and the cursor point changes 

its shape. 

6. Click at a location below the part. 

 

7. Click OK to close the dialog. 

8. Simulate the part: 
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a. Select the Toolpaths  step from the Steps panel. 

b. In the Simulation toolbar, click the Show Centerline 

 button, and then click the Play  button to view the changes 

in the toolpath. 

 If you pick a location that is too close to the part, the plunge 

point is ignored, and the toolpaths will remain unchanged. 

You have completed this tutorial. 
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 You must have TURN or TURN/MILL to perform this tutorial. 

The example in this tutorial is a simple turned part designed to introduce 

you to several of the drawing and machining tools available in TURN. 

The tutorial walks you through creating the part and introduces you to 

TURN's automation and ease of use. 

The measurements in this tutorial are in inches; the values in millimeters 

are shown in brackets. 
 

Getting started 
In the next sections we will be using TURN. If you don't have a license 

for this module, but would like to evaluate it: 

1. Start FeatureCAM by double-clicking the FeatureCAM icon  

on the desktop. 

2. From the File menu, choose Evaluation Options, and make sure 

Turning is selected. 

3. Click OK. 
 

Create a part file 
1. If the New Part Document wizard is displayed, select the New 

File option, and click Next. Select Turn/Mill, select Inch or 

Millimeter, and click Finish. 

Introduction to turning 
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If the New Part Document wizard is not displayed, select File > 
New from the menu. Select Turn/Mill, click Inch or Millimeter, 

depending on your preference, and click OK. 

2. Create the stock. 

a. In the Stock wizard (Dimensions page), set the OD to 4 (100 

mm), Length to 5 (125 mm), and ID to 0, and click Next. 

A turning setup defaults to a round stock. 

b. Click the triangle next to the Finish button, and select the 

Finish and Edit Properties option. 

 

c. In the Properties dialog, set Z to 0.0625 (1.5 mm), and click 

OK. 

3. Select Options > Turning Input Modes > 3D (XYZ) from the 

menu. 

4. Select Manufacturing > Set Tool Crib from the menu, choose 

the Tools option in the Select Active Tool Crib dialog, and 

click OK. 

5. Click the triangle of the View  menu on the Standard 

toolbar, and choose the Center All option to bring your entire 

drawing into view. 

Your part should look something like this: 

 

6. Draw two lines: 

a. Select the Geometry  step from the Steps panel. 

b. In the Geometry Constructors dialog, ensure the Create 
more than one check box is selected, and click the Line 

from 2 pts  button. 
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c. In the Feature/Geometry Edit bar, enter the following values 

to create two lines that define the OD profile: 

point 1: X=2 (50 mm); Y=0, Z= -3.5 (-88 mm) 

point 2: X=1 (25 mm), Y=0, Z= -3.5 (-88 mm) 

Press Enter. A line is drawn in the Graphics window. 

d. Create a second line with the values: 

point 1: X=1 (25 mm), Y=0, Z= -3.5 (-88 mm) 

point 2: X=1 (25 mm), Y=0, Z=0 

Press Enter. Your part now looks something like this: 

 

7. Create a chamfer to trim your lines. 

a. Select the Geometry  step from the Steps panel. 

b. In the Geometry Constructors dialog, click the Chamfer 

 button in the list of Fillet commands. 

c. In the Feature/Geometry Edit bar, enter width=0.25 (6 mm) 

and height=0.25 (6 mm). 

d. Position your mouse close to the chamfer location as shown in 

the figure below. The chamfer snaps into place. 

 

e. Click once to place the chamfer on your drawing. The chamfer 

automatically trims your lines. 

8. Create third line. It will be used to create a bore feature later. 

a. Select the Geometry  step from the Steps panel. 

b. In the Geometry Constructors dialog, click the Line from 

2 pts  button. 
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c. In the Feature/Geometry Edit bar, enter the following 

values: 

point 1: X=0.625 (16 mm), Y=0, Z=0 

point 2: X=0.625 (16 mm), Y=0, Z= -3.75 (-94 mm) 

d. Press Enter. 

9. Chain the trimmed lines into curves. 

a. Select the Curves  step from the Steps panel. 

b. In the Curves Creation dialog, select the Pick Curve 

Pieces  button. 

c. In the Graphics window, click locations 1, 2, 3 as shown in 

the figure below. Each line segment changes color when it is 

selected. 

 

d. In the Feature/Geometry Edit bar, name the curve turn, and 

press Enter. 

10. Chain the Bore ID curve. 

a. Select the Curves  step from the Steps panel. 

b. In the Curves Creation dialog, click the Pick Curve Pieces 

 button. 

c. In the Graphics window, click locations 4 and 5, as shown 

above. 

d. In the Feature/Geometry Edit bar, name the curve bore, and 

press Enter. 
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Making features 

1. Use the 2D Turned Profiles  button, on the Display Mode 

toolbar, to switch to a simplified 2D representation of your part. 

2. Create a turn feature. 

a. Select the Features  step from the Steps panel. 

b. If you have the Turn/Mill module, the New Feature wizard 

asks you which type of feature you want to create. Select the 

Turning option, and click Next. 

 

c. Select Turn in the From Curve frame, and click Next. 

d. Select the curve graphically: 

In the Curve field select turn from the list. 

Click the Pick Curve  button. The dialog minimizes to 

reveal the Graphics window beneath. 
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Click the curve you named turn earlier. 

 

In this particular case, two objects are available for selection: a 

line and a curve. Whenever your selection needs to be clarified, 

FeatureCAM opens the Select dialog. 

In the Select dialog, choose turn, and click OK. 

e. Click Next. 

Your drawing should look something like this: 

 

f. Click the triangle next to the Finish button, and select the 

Finish and Create More option to continue creating features. 

3. Create a face feature. 

a. If the New Feature wizard asks you which type of feature you 

want to create, select the Turning option, and click Next. 

b. Select Face in the From Dimensions frame, and click Next. 

c. Set Outer Diameter to 4 (100 mm), Inner Diameter to 0, 

Thickness to 0.0625 (1.5 mm). 

A face feature automatically knows the OD and ID values from 

the stock properties. 

d. Click Finish. 

4. Create a hole feature. 
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a. If the New Feature wizard asks you which type of feature you 

want to create, select the Turning option, and click Next. 

b. Select Hole in the From Dimensions frame, and click Next. 

c. On the Dimensions page, set the Diameter to 1.0 (24 mm), 

Depth to 3.75 (94 mm). 

d. Click Next, and set Z to 0. 

Your drawing should look something like this: 

 

e. Click Finish. 

5. Create a bore feature by using the same process you used to create 

the turn feature. Use the curve you named Bore. 

 

6. Create a groove feature. 

a. If the New Feature wizard asks you which type of feature you 

want to create, select the Turning option, and click Next. 

b. Select Groove in the From Dimensions frame, and click 

Next. 

c. On the Dimensions page, set Location to ID, Orientation 
to X-axis, Diameter to 1.25 (31 mm), Depth to 0.125 (3 mm), 

Width to 0.250 (6 mm). Leave the other settings at 0. 

d. Click Next, and set Z to -3 (-75 mm). 
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Your drawing should look something like this: 

 

e. Click Finish. 

7. Create a thread feature. 

a. If the New Feature wizard asks you which type of feature you 

want to create, select the Turning option, and click Next. 

b. Select Thread in the From Dimensions frame, and click 

Next. 

c. On the Dimension page, select Get the thread dimensions 
from a standard thread, click OD, and select the 2.0000- 

4.5 UNC (M50-15 for metric) in the Designation field. 

d. Click Next. 

e. On the Dimensions page, set Thread to Right hand, 

Thread Length to1.0 (24 mm), and click Next. 

Your drawing should look something like this: 

 

f. Click Finish. 

8. Create a cutoff feature. 

a. If the New Feature wizard asks you which type of feature you 

want to create, select the Turning option, and click Next. 

b. Select Cutoff in the From Dimensions frame, and click 

Next. 
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c. On the Dimensions page, set Diameter to 4 (100 mm), 

Inner Diameter to 0, Width to 0.122 (3 mm). 

d. Click Next and set Z to –4.5 (–112 mm). 

Your drawing looks something like this: 

 

e. Click Finish. 
 

Viewing 

1. Click the 2D Turned Profiles  button, on the Display Mode 

toolbar, to return to a 3-dimensional view of the model. 

2. Click the Isometric View  button on the Standard toolbar. 

 

3. Shade the part. 

a. Open the Part View panel, and select bore1 under the Setup1 

node. 

b. Click the Shade Selected  button on the Display Mode 

toolbar. 
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c. Select thread1, and click the button again. 

 

4. Click the Unshade All  button on the Display Mode toolbar 

to return to the line drawing view. 

The sample part is complete. Now the simulation features will be used to 

see how the part will be manufactured. 
 

Toolpaths 

1. Select the Toolpaths  step from the Steps panel. The 

Simulation toolbar is displayed. 

2. Click the 3D  button, and then click the Play  button to start 

the simulation. If the Automatic Ordering Options dialog 

appears, click OK to close it. The ordering options will be covered 

later. 
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A solid 3D rendering of the cutting process is displayed. By 

default, the 3/4 view is shown when cutting or drilling the ID of the 

part. You can control this setting by selecting Options > 
Simulation from the menu. 

 

 FeatureCAM runs simulations best in 256 color mode or 

higher. Depending on your video settings, you might see a 

warning about this. You may ignore this warning for this 

tutorial. 

3. Click the Play to Next Operation  button. The face 

operation is displayed. 

4. Click this button to view each operation until the entire part is cut. 

5. Click Eject . The Simulation toolbar is removed from the 

screen. 
 

Ordering of operations 
The Op List tab in the Results window shows all of the operations that 

the features are translated into. A yellow warning  sign next to an 

operation indicates a potential problem with that operation. If you see any 

warnings, ignore them. 

The ordering can be automatic or manual. 

Automatic ordering 

You can control the automatic ordering of operations by using either rules 

or operation templates. Using rules is similar to the way you used 

automatic ordering in the 2.5D Milling tutorial (see page 62). 
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In this section we will change the automatic ordering by modifying the 

Turn Operation template. This template lists the manufacturing order 

of the various turning features. 

To modify the template: 

1. Click the Ordering options  button on the Op List tab in the 

Results window. 

The Automatic Ordering Options dialog opens. 

2. Select the Use template option, and click Edit template. 

3. In the Feature Order dialog, click Rough OD Turn. 

 

4. Click the down arrow until the item is located under the Finish ID 
Turn operation. 

5. Click Finish OD Turn, and click the down arrow until the item is 

located under Finish ID Turn. 

6. Click OK to close the Feature Order dialog. 

7. Click OK to close the Automatic Ordering Options dialog. 

8. Simulate the part. 

a. Select the Toolpaths  step from the Steps panel. The 

Simulation toolbar is displayed. 

b. Click the 3D  button, and then click the Play  button. 

Notice that the OD roughing and finishing now happen after the 

hole is drilled. 

c. Click the Stop  button when simulation is complete to exit 

simulation mode. 
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Manual ordering 

You can specify an exact ordering of operations manually, the same way 

as you did in the 2.5D Milling tutorial (see page 62). 
 

Part documentation 
TURN automatically generates the part documentation, which you can 

view by clicking the Details tab in the Results window. 

The Manufacturing Operation List is shown by default. It contains 

information such as machining time, selected tools, feeds and speeds, and 

horsepower requirements for the various operations. Each operation of 

the process plan is listed in order. 

The Tool List is displayed by selecting the Tool List option at the top of 

the Details tab. It contains a summary of all the tools needed for the job 

as well as details of each tool. 

 You can print this documentation by selecting Print from the File 

menu. 
 

NC code 
After you have simulated the part, you can generate NC code. TURN 

comes with many post processors and the ability to create custom post 

processors as well. 

Before you can generate NC code for a part, you have to run a simulation 

to calculate toolpaths. If you are starting this part of the tutorial without 

having just run the simulation described above, simulate your part now 

(see page 91). 

To generate NC code: 

1. Select the NC Code  step from the Steps panel. 

2. Click the View the NC code  button in the NC Code dialog 

to generate the NC code. 

 If you are running an evaluation copy of TURN, a dongle (a device 

that attaches to the computer printer port) is necessary to generate 

NC code, or save or export files and is not available in the 

demonstration version. When you purchase TURN, you will receive 

a dongle. 
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Changing post processors 
If you are running TURN, the default post processor is for a Bridgeport 

machine. Follow the steps to change your post processor and generate the 

NC code. 

1. From the Manufacturing menu, select the Post Process 

option. 

2. In the Post Options dialog, click the Browse button to view 

available post processors. 

The default folder is C:\Program Files\FeatureCAM\T-
lbry\Inch for English units. If you need a metric post, browse up 

one folder level to T-lbry. Then browse the Metric folder. 

3. Select your processor and click Open. 

The new processor is shown in the CNC File field. 

4. Click OK to exit the Post Options dialog and use the new post 

processor; click Close to exit the dialog, and keep the original post 

processor. 

5. Select the Toolpaths  step, and run a simulation of the part to 

regenerate the NC code. 
 

Saving NC code 

1. Select the NC Code  step from the Steps panel. 

2. Click the Save NC  button in the NC Code dialog. 
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3. In the Save NC dialog, accept the default filename and folder, and 

click OK. You are now ready to machine the part. 

 

You have completed this tutorial. 
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 You must have licensed the Turn/Mill option to run this tutorial. 

This tutorial is only available in inch units. 

This tutorial introduces you to: 

 Creating parts for lathes with milling capabilities. 

 Mixing turning and milling features. 

 Creating milling features on the OD and face of the part. 

 Simulating a turn/mill part. 
 

Getting started 

1. Start FeatureCAM by double-clicking the FeatureCAM icon  

on the desktop. 

2. If the New Part Document wizard is displayed, select the New 
file option, and click Next. Select Turn/Mill, click Inch, and click 

Finish. 

If the New Part Document wizard is not displayed, select File > 
New from the menu. Select Turn/Mill, click Inch, and click OK. 

3. In the Stock wizard (Dimensions page), enter 3 for the OD, 2 

for the Length, and 0 for the ID. 

If the wizard does not open automatically, select the Stock  

step from the Steps panel. 

Introduction to 
turn/mill 
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 A turn/mill setup defaults to a round stock. 

4. Click the triangle next to the Finish button, and select the Finish 

option. 

5. Click the triangle of the View  menu on the Standard 

toolbar, and choose the Center All option to bring your entire 

drawing into view. 

Your part should look something like this: 

 

6. Select Options > Turning Input Modes > Diameter from the 

menu. 
 

Creating a turn feature 
1. Draw three lines. 

a. Select the Geometry  step from the Steps panel. 

b. In the Geometry Constructors dialog, ensure the Create 
More Than One check box is selected, and click the 

Connected Lines  button. 

c. In the Feature/Geometry Edit bar, enter the following values 

to create lines that define the OD profile: 

point 1: D1=2.5, Z1= 0 

point 2: D2=2.5, Z= –1.5 

Press Enter. A line is drawn in the Graphics window. 

Create a second line with the values: 

point 2: D2=2.75, Z= –1.5 
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Press Enter. 

Create a third line: 

point 2: D2=2.75, Z= –2.0 

Press Enter. Your part now looks something like this: 

 

2. Create a corner fillet. 

a. Select the Geometry  step from the Steps panel. 

b. In the Geometry Constructors dialog, click the Corner 

Fillet  button. 

c. In the Feature/Geometry Edit bar, enter R = 0.125. 

d. Position the mouse in corner between the first and the second 

lines, and click. A corner fillet appears automatically trimming 

the lines to fit. 

 

3. Chain the lines into curves. 
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a. Select the Curves  step from the Steps panel. 

b. In the Curves Creation dialog, select the Pick Curve 

Pieces  button. 

c. In the Graphics window, click the first and third lines. 

 

d. In the Feature/Geometry Edit bar, name the curve Turn, and 

press Enter. 

4. Create a turn feature. 

a. Select the Features  step from the Steps panel. 

b. When the New Feature wizard asks you which type of feature 

you want to create, select the Turning option, and click Next. 

c. Select Turn in the From Curve frame, and click Next. 

The Turn curve is already selected in the Curve field. 

d. Click the triangle next to the Finish button, and select the 

Finish option. 
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Your drawing should look something like this: 

 
 

Viewing 

1. Click the Isometric View  button on the Standard toolbar. 

 

2. Open the Part View panel, and select turn1 under the Setup1 

node. 

3. Click the Shade Selected  button on the Display Mode 

toolbar to shade the feature. 
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If the toolbar is not displayed, select View > Toolbars from the 

Menu bar, and select the Display Mode check box in the 

Customize Toolbars dialog. 

 

4. Click the Unshade All  button on the Display Mode toolbar 

to return to the line drawing view. 

5. Click the triangle next to the button in the Principal View  

menu in the Standard toolbar, and select the Top option. 
 

Creating a radial hole pattern on the 
face 

1. Use the 2D Turned Profiles  button, on the Display Mode 

toolbar, to switch to a simplified 2D representation of your part. 

 

2. Create a hole. 

a. Select the Features  step from the Steps panel. 
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b. When the New Feature wizard asks you which type of feature 

you want to create, select the Turn/Mill option, and click Next. 

c. Select Hole in the From Dimensions field and click Next. 

d. Set Chamfer to 0.0, Depth to 1.0, and Diameter to 0.25. 

e. Click the triangle next to the Finish button, and select the 

Finish option. 

3. Create a pattern from feature: 

a. Select the Features  step from the Steps panel. 

b. When the New Feature wizard asks you which type of feature 

you want to create, select the Turn/Mill option, and click Next. 

c. Select Pattern in the From Feature field and click Next. 

d. Select the hole you just created to create the pattern from and 

click Next. 

e. Select the Radial in the setup XY plane option, and click 

Next. 

f. On the Pattern - Dimensions page, set Number to 3.0, 

Diameter to 2.0, Spacing Angle to 120, and Angle to 60. 

g. Click the triangle next to the Finish button, and select the 

Finish option. 

4. View the results. 

a. Click the 2D Turned Profiles  button, on the Display 
Mode toolbar, to return to 3D line drawing view. 

b. Click the Isometric View  button on the Standard toolbar. 

Your drawing should look something like this: 
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Engraving on the face 
1. Create a curve. 

a. Select the Curves  step from the Steps panel. 

b. In the Curves Creation dialog, select the Curve Wizard  

button. 

c. In the Curve wizard, select Other methods as the 

construction method, Text as the constructor, and click Next. 

 

d. On the Engraving Text page, configure the text properties. 

 

Enter TURNMILL as Text, select Linear as Path type. 

Enter 0.0, -0.045, 0.0 as the X, Y and Z locations. 

Enter -90 into the Angle field. 

Select Center in the Justification field. 
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Enter 0.4 for both the X and Y Scaling. 

Click the Font button, select Machine Tool Gothic for the font 

type, and 72 for the font size in the Font dialog, and click OK. 

e. Click Finish to close the wizard. 

2. Create a groove feature. 

a. Select the text string (curve1) in the Graphics window, and 

select the Features  step from the Steps panel. 

b. When the New Feature wizard asks you which type of feature 

you want to create, select the Turn/Mill option, and click Next. 

c. Select Groove in the From Curve field, and click Next until 

you get to the Dimensions page. 

d. On the Dimensions page, set Width to 0.0625, Depth to 

0.02, and ensure that the Simple option and the Face option 

are selected. 

e. Click the triangle next to the Finish button, and select the 

Finish option. 

Your part should look similar to this: 
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Creating a pattern of wrapped slots 

1. Select the Features  step from the Steps panel. 

2. Select Turn/Mill as the feature type, and click Next. 

3. Select Slot in the From Dimensions frame, select the Make a 
pattern from this feature option, and click Next. 

4. Set Length to 1.0, Width to 0.5, Depth to 0.25, and click Next. 

5. Select the Radial around index axis option, and click Next. 

6. Set B Angle to 90, Radius to 1.25, Z to 0.25 and click Next. 

7. Set Number to 3 and Spacing Angle to 120. 

8. Click the triangle next to the Finish button, and select the Finish 

option. 

Your part should look something like this: 

 
 

Simulating a turn/mill part 

1. Select the Toolpaths  step from the Steps panel. The 

Simulation toolbar is displayed. 

2. Click the 3D Simulation  button, and then click the Play  

button to start the simulation. If the Automatic Ordering 
Options dialog appears, click OK to close it. 
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A solid 3D rendering of the cutting process is displayed. Notice 

how the toolpaths are accurately simulated including the part 

rotations. 

 

 FeatureCAM runs simulations best in 256 color mode or 

higher. Depending on your video settings, you might see a 

warning about this. You may ignore this warning for this 

tutorial. 

3. Click Eject . The Simulation toolbar is removed from the 

screen. 

You have completed this tutorial. If you want to see more examples of 

turn/mill parts, look in the Examples/Turnmill folder. 
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 You must have MILL with the RECOGNITION option or MILL3D to 

perform this tutorial. You also need the Solid plugin installed. 

This tutorial is only available in metric units. 

In this tutorial you will learn how to: 

 Import 3D models. 

 Dynamically shade 3D models. 

 Create features directly from 3D solid models using both automatic 

feature recognition and more interactive methods. 
 

Getting started 

 You must have metric tools loaded into the tool database to perform 

this tutorial. 

To add metric tools to your database: 

1. Select Exit from the File menu to close FeatureCAM. 

2. From the Start menu, select All Programs > FeatureCAM > 
INITDB. 

 You can also run Initdb.exe from the folder where 

FeatureCAM is installed. 

3. In the Tool and Material Setup dialog, select the On my local 
computer option, and click Next. 

Creating features from 
3D CAD models 
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4. Select Both as the tools to load, and click Next. 

5. Select Inch or Metric to indicate which tool type you use more 

often, and click Next. 

6. Click Finish. 
 

Importing the CAD model 

1. Start FeatureCAM by double-clicking the FeatureCAM icon  

on the desktop. 

2. If the New Part Document wizard is displayed, select the New 
file option, and click Next. Select Milling Setup, click 

Millimeter, and click Finish. 

If the New Part Document wizard is not displayed, select File > 
New from the menu. Select Milling Setup, click Millimeter, and 

click OK. 

3. In the Stock wizard (Dimensions page), click the triangle next 

to the Finish button, and select the Finish option. 

4. Select File > Import/Export Options from the menu. 

5. In the Import/Export Options dialog, select the Center stock 
automatically option on the General tab. 
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6. Click the Solid Import tab, ensure the Import file as solids 

option is selected, and click OK. 

 

7. Select File > Import from the menu. 

8. In the Import dialog, select Acis as Files of type, and open the 

file Tutor9.sat. 

If you installed FeatureCAM in the default folder, the file should 

be in C:\Program 
Files\FeatureCAM\Examples\Tutorials\3D models. 

9. In the Import Results wizard, select the Use the wizard... 
option, and keep clicking Next until you get to the Stock 
Dimensions page. 

10. Select Use the wizard option in the Import Results dialog and 

keep clicking Next until you get to the Stock Dimensions page. 

11. Select Compute stock size from the size of the part, ensure 

all of the Extra stock size fields are set to 0 and click Finish. 
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12. The imported part should look something like this: 

 
 

Aligning the model 
1. Open the Part View panel, and select solid1 under the Solids 

node. 

 

This is the solid model you have just imported. 

2. Click the Isometric View  button on the Standard toolbar. 

The stock has been resized, but the setup is located at the center of 

the stock. 

 

3. Click the Setups  button on the Advanced toolbar. 
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 If the Advanced toolbar is not displayed, select View > 
Toolbars from the menu, select the Advanced option in the 

Customize Toolbars dialog, and click OK. 

4. In the Setups dialog, select Setup1 from the list, and click Edit. 

 

5. In the Setup wizard, click Next to get to the Setup - Part 
Program Zero page, select Align to Stock Face, and click 

Next. 

6. Click the LL  button in the XYZ Location section. 

 

7. Click Finish to close the wizard, and click Close to exit the 

Setups dialog. 

The stock has now been aligned to the stock face. 

8. Select Manufacturing > Set Tool Crib from the menu. 

9. In the Select Active Tool Crib dialog, select the tools crib, and 

click OK. 
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Shading the part 

1. Click the Shade  button on the Standard toolbar to shade the 

part. 

This shaded view makes it easier to see the cavities in the model. 

Remember, at this point the part model contains only surfaces. 

 

2. Click the Shade  button again to turn off the shading. 
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Automatic feature recognition 
This entire part can be automatically recognized using the automatic 

feature recognition (AFR) wizard. 

1. Select the AFR  step from the Steps panel. 

2. In the Automatic Feature Recognition wizard, click the Next 
button twice. 

 

The features that were recognized are listed. 

3. Click the Finish button. 

4. Select the Toolpaths  step from the Steps panel. The 

Simulation toolbar is displayed. 

5. Click the 3D  button, and then click the Play  button to start 

the simulation. If the Automatic Ordering Options dialog 

appears, click OK to close it. 

6. Click Eject . 

 All features of the model were automatically recognized and 

the part is ready to cut. With many parts automatic feature 

recognition is all you need to program your part, but with 

others, you may need to use some of the other feature 

recognition (FR) techniques. 

7. Click the Undo  button to remove the features you created so 

far. You are now ready to try additional recognition methods. 
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Recognizing holes 

1. Select the Features  step from the Steps panel. 

2. In the New Feature wizard, select Hole in the From 
Dimensions frame, select the Extract with RECOGNITION 

option, and click Next twice. 

 

3. Select Recognize and construct multiple holes, and click 

Next. 

The holes that are automatically recognized are shown on the 

screen. Three holes were recognized along with the circular pocket 

in the middle. 
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4. In the Graphics window, ignore the central pocket, and use the 

mouse to select the holes. (You may need to move the wizard out 

of the way by dragging its title bar.) 

 

5. Click the triangle next to the Finish button, and select the Finish 

option. 

The three holes have now been recognized. 

6. Click the Ordering Options  button on the Op List tab. 

7. In the Automatic Ordering Options dialog, select Minimize 
tool changes, Cut higher operations first and Minimize 
rapid distance, and click OK. 

 

8. Select the Toolpaths  step from the Steps panel. The 

Simulation toolbar is displayed. 
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9. Click the 3D Simulation  button, and then click the Play  

button to start the simulation. 

 

10. Click Eject . 
 

Recognizing pockets 

1. Select the Features  step from the Steps panel. 

2. In the New Feature wizard, select Pocket in the From Curve 

frame, select the Extract with RECOGNITION option, and click 

Next. 

 

3. Select Automatic recognition, and click Next. 
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The pockets that are automatically recognized are shown on the 

screen. 

4. Click the Select All button, and click Finish. 

Both pockets have now been recognized. 

 

5. Select the Toolpaths  step from the Steps panel. The 

Simulation toolbar is displayed. 

6. Click the 3D Simulation  button, and then click the Play  

button. 

 

7. Click Eject . 
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Creating a slot feature 

1. Select the Features  step from the Steps panel. 

2. In the New Feature wizard, select Slot in the From 
Dimensions frame, select the Extract with RECOGNITION 

option, and click Next. 

 

3. Click the Pick surface  button, and select the first location as 

shown below. 
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If the Select dialog opens, select the name that corresponds to the 

surface at this location, and click OK. The surfaces are highlighted 

in the graphics window as you select the names. 

4. Click the Pick surface  button again, and select the second 

location as shown below. 

 

5. Click Next, review the extracted slot dimensions, and click 

Finish. 
 

Creating a side feature 

1. Click the triangle next to the button in the Principal View  

menu in the Standard toolbar, and select the Top option. 

2. Box-select the region shown below. To do this, click the left mouse 

button and drag the mouse before releasing the button. 
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3. Select Isometric from the Principal View  menu. 

4. Click the Shade  button, on the Standard toolbar, to shade the 

part. The shaded view makes it easier to select faces on the surface. 

5. Hold down the Shift key and click the side of the hole pattern that 

is selected as shown in the image. 

 

This removes the hole pattern from the selected group. 

6. Select the Features  step from the Steps panel. 

7. In the New Feature wizard, select Side in the From Curve 

frame, select the Extract with RECOGNITION option, and click 

Next. 
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8. On the Feature Extraction page, choose the Select Side 
Surfaces method, and click Next twice to get to the Machining 
Side page. 

9. The blue arrow in the Graphics window should point to the 

outside of the part (to the side you wish to cut). 

 

If it points to the inside of the part, click the Switch Machining 

Side  button to reverse the machining side. 

10. Click Finish. 
 

Simulating the entire part 

1. Select the Toolpaths  step from the Steps panel. The 

Simulation toolbar is displayed. 
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2. Click the 3D Simulation  button, and then click the Play  

button. 

 

3. Click Eject  at the completion of the simulation. 

You have completed this tutorial. The features for the entire part have 

been created directly from the surfaces of the solid model. Using 

FeatureCAM’s feature-based manufacturing automation, this part can be 

created quickly and easily. 
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 You must have MILL3D to perform the examples in this chapter. 

These examples are only specified in inch units. You must have the 

basic tool crib installed. 

This tutorial introduces you to: 

 Modeling 3D surfaces. 

 Manufacturing surfaces using surface milling features. 

 Manufacturing operations. 

 Tool selection. 

 3D manufacturing attributes. 
 

Getting started 

1. Start FeatureCAM by double-clicking the FeatureCAM icon  

on the desktop. 

2. If the New Part Document wizard is displayed, select the New 
file option, and click Next. Select Milling Setup, click Inch, and 

click Finish. 

3. If the New Part Document wizard is not displayed, select File > 
New from the menu. Select Milling Setup, click Inch, and click 

Finish. 

4. In the Stock wizard (Dimensions page), enter 3 for Width, 6.25 

for Length, and 2.0 for Thickness. 

Introduction to 3D 
milling 
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 A milling setup defaults to a block stock. 

5. Click the triangle next to the Finish button, and select the Finish 

option. 

6. Select View > Toolbars from the Menu bar, ensure that the 

Advanced and Geometry check boxes are selected in the 

Customize Toolbars dialog, and click OK. 

7. Create three vertical lines. 

a. Select Vertical from the Line  menu on the Geometry 

toolbar. 

b. In the Feature/Geometry Edit bar, enter 1.0 for X, 0.0 for Z, 

and press Enter. 

c. Create two more lines at X= 5.25 and X = 6.0. 

Your part should look something like this: 

 

8. Create three horizontal lines. 

a. Select Horizontal from the Line  menu on the Geometry 

toolbar. 

b. Create horizontal lines at Y= 0.5, 1.125, and 1.5, and Z = 0. 

 

9. Create a through line. 

a. Select Pt, Angle from the Line  menu on the Geometry 

toolbar. 

b. In the Feature/Geometry Edit bar, enter 30 as the angle. 
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c. In the Graphics window, click at the intersection between the 

second horizontal and second vertical lines to create a through 

line. 

 

10. Create arcs. 

a. Select 2 Pts, Radius from the Arc  menu on the 

Geometry toolbar. 

b. In the Feature/Geometry Edit bar, enter R = 0.5, and click 

immediately below the intersection between the first vertical 

line and the second horizontal line to create the first arc point. 

Click to the right of the intersection between the first vertical 

and the third horizontal line to create the first arc. 

 

c. In the Feature/Geometry Edit bar, enter R = 1.0, and click 

the third horizontal line just to the left of the intersection with 

the through line to create the first arc point. Click the through 

line just above and to the right of the intersection to create the 

second arc. 
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d. Click the through line just to the left of the intersection with the 

second vertical line to create the first arc point. Click on the 

second horizontal line just to the right of the intersection with 

the through line to create the third arc. 

 

11. Chain geometry into curves. 

a. Select the Curves  step from the Steps panel. 

b. In the Curves Creation dialog, select the Pick Curve 

Pieces  button. 

c. Click the intersection between the third vertical line and the 

second horizontal line. 

d. Click the intersection between the first vertical and the first 

horizontal lines. 

Your part should look something like this: 

 
 

Creating the bottle surface 

1. Click the Surfaces  step from the Steps panel. 

2. In the Surface wizard, click Surface of Revolution, and click 

Next. 

3. On the Surface of Revolution page, enter 0.0 for Start Angle, 

and 180 for End Angle. 
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The curve you chained is automatically selected in the Curve 

field. 

4. Click the Pick line  button in the Axis field, and select the first 

horizontal line (the one at Y=1.5). 

 

5. Click Finish. 

Your part now looks something like this: 

 
 

Viewing 

1. Click the Isometric View  button on the Standard toolbar. 

 

2. Use the Viewing Options dialog to control how the part is 

displayed. 

a. Select Options > Viewing from the menu to open the 

Viewing Options dialog. 
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b. Select the Show surface boundaries only option, and click 

Apply. 

With this option enabled, surfaces are displayed as only their 

outer boundaries and trimmed loops. No additional lines will be 

drawn in the interior of the surface. This option makes the 

display of larger models much faster. 

c. Now deselect the Show surface boundaries only option, 

and click Apply. 

You should now see your part drawn with lines in the interior of 

the surface. For large models, this option makes the display of 

the part slower. 

d. Enter 20 for Wireframe, and click Apply. 

The surface is now drawn with more lines. Decreasing the value 

of Surface Fineness improves the display quality but can 

slow down the graphics. 

3. Select the Hide All Geometry option from the Hide  menu 

on the Advanced toolbar. 

4. Click the Shade  button, on the Standard toolbar, to shade the 

part. 
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Creating a surface milling feature 
To mill 3D surfaces you must create a surface milling feature. A surface 

milling feature lets you generate toolpaths for multiple surfaces using a 

number of 3D toolpath strategies. 

1. Click the Select  button, on the Standard toolbar, and select 

the surface (srf1). 

 

2. Select the Features  step from the Steps panel. 

3. In the New Feature wizard, select the Surface Milling option in 

the From Surface frame. 

4. Click Next twice to get to the New Strategy page, select the 

Choose Rough, Semi Finish, and Finish… option, and click 

Next. 

5. On the Rough page, select the Z Level Rough option, select 

Classify slices as 3D Pocket, and click Next. 
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6. On the Semi-Finish page, select None, and click Next. 

 

7. On the Finish page, select Isoline. 

 

8. Click the triangle next to the Finish button, and select the Finish 

option. 
 

Simulating the entire part 

1. Select the Toolpaths  step from the Steps panel. The 

Simulation toolbar is displayed. 
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2. Click the 3D  button, and then click the Play  button to start 

the simulation. FeatureCAM prepares the model, and processes the 

toolpaths. 

 

3. Click the 3D simulation  button and click Play . 

4. Click Eject . The Simulation toolbar is removed from the 

screen. 

You have completed this tutorial, and can move to the next tutorial for 

more advanced 3D manufacturing techniques. 
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 You must have 5-Axis Simultaneous and MILL3D to perform this 

tutorial. We recommend that you complete the Introduction to 3D 

milling (see page 124), Advanced 3D milling and Creating features 

from 3D CAD models (see page 108) tutorials before starting this 

one. 

This tutorial is only available in metric units. 

In this tutorial you will learn to: 

 Tilt the tool axis while cutting a 3D surface milling feature. 

 Recognize and drill 5-axis holes in a single setup. 
 

Getting started 

1. Start FeatureCAM by double-clicking the FeatureCAM icon  

on the desktop. 

2. If the New Part Document wizard is displayed, select the New 
file option, and click Next. Select Milling Setup, Millimeter, 

and click Finish. Close the Stock wizard (Dimensions page) by 

clicking the Cancel button. 

3. If the New Part Document wizard is not displayed, select File > 
New from the menu. Select Milling Setup, Millimeter, None, 

and click OK. 

4. From the Manufacturing menu, select Set Tool Crib. 

Introduction to 5-axis 
simultaneous 
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5. In the Select Active Tool Crib dialog, select the tools crib, and 

click OK. 
 

Creating a surface milling feature 
A 5-axis simultaneous surface milling feature requires your machine to 

have 5 degrees of freedom. For FeatureCAM, the 5 degrees of freedom 

are restricted to moving in X, Y and Z, and rotating in two single revolute 

rotational joints.  

 A single part of your machine can only rotate about one axis. 

Unlike the human wrist, for example, machine joints can only rotate 

about one mechanical axis. 

That is, you can define 5-axis features in a Turn/Mill document with a B-

axis enabled post (*.cnc file) so that your 5 degrees of freedom are X, Y, 

Z, B and C. This can be used, for instance, on a Mazak Integrex lathe that 

has a B-axis swiveling head. You can also use 5-axis features in a 5-axis 

indexed milling environment in a Milling document. 

To create a surface milling feature: 

1. Select File > Import from the menu. 

2. In the Import dialog, select ParaSolids as Files of type, and 

open the file myjayfilledholes_untrimmed.x_t. 

If you installed FeatureCAM in the default folder, the file should 

be in C:\Program Files\FeatureCAM\Examples\5axis 
simul. 

3. In the Import Results wizard, select the Use the wizard option, 

and keep clicking Next until you get to the Stock Dimensions 

page. 
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4. Select Compute stock size from the size of the part, allow 

3 extra millimeters in +Z, and then click Finish. 

 

5. Cancel the Automatic Feature Recognition wizard, if it opens. 

6. Select Edit > Select All from the menu. 

7. Select the Features  step from the Steps panel. 

8. In the New Feature wizard, select the Surface Milling option in 

the From Surface frame. 

9. Click Next twice to get to the New Strategy page, select the 

Choose a single operation option, and click Next. 
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10. Select the Z Level option in the Roughing Strategies frame, 

and click Next until you reach the Default Tool page. 

 

11. Select I want to search for another tool or make a new 
one, and click Next. 
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12. On the Tool Search page, click the Diam. column header to 

order the tools, choose the flat endmill tool with the largest 

diameter, and click Finish. 

 
 

Importing geometry 
1. Select File > Import from the menu. 

2. In the Import dialog, select IGES as Files of type, and open the 

file myjayfilledholes_gsg.igs. 

If you installed FeatureCAM in the default folder, the file should 

be in C:\Program Files\FeatureCAM\Examples\5axis 
simul. 

3. Select No when you are asked to review the IGES log. 

4. In the Import Results wizard, select the Accept the imported 
data ‘as is’ and exit the wizard option, and click Finish. 

The part with imported geometry should look something like this: 
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Adding flowline operation 
1. Open the Part View panel, select stock1, and on the 

Feature/Geometry Edit bar click the Properties  button. 

2. In the Properties dialog for stock1, click the Indexing tab, 

select the 5th Axis Positioning option, and click OK. 

3. Select srf_mill1 under the Setup1 node on the Part View panel, 

and click the Properties  button on the Feature/Geometry 
Edit bar. 

4. In the Properties dialog for srf_mill1, click the Process tab, 

and click the Add new operation  button. 

5. In the New Strategy wizard, select Flowline in the Finishing 
Strategies frame, and click Finish. 

 

6. In the Properties dialog, select the finish2 process for the 

flowline operation in the tree view. 
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7. Click the Milling tab, select the Stepover attribute, enter 3 as the 

New Value, and click Set. 

 

8. Add a new tool. 

a. Click the Tools tab, and select Bullnose Endmill in the Tool 
Group field. 

b. Select the tool with the biggest diameter, and click the New 

Tool  button. 

This opens the Tool Properties dialog with the currently 

selected tool used for the initial values for the new tool. 

c. Enter bullnose40 as the Name, and 40 as the Diameter. 
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d. Deselect the Ball-end check box, enter 4 as the End Radius, 

and click OK. 

 

e. Click Yes, when the system asks Set the new tool as 
override? 

The new tool is now selected. 

9. In the Properties dialog for srf_mill1, select the flowline 

operation in the tree view. 

10. Click the 5-Axis tab, select Use Lead and Lean, and click 

Apply. This ensures the tool is at a fixed angle relative to the 

direction of the toolpath. 
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Using a lead/lean strategy keeps the tool normal to the cutting 

surfaces and enables you to take large stepovers while leaving a 

good quality finish. 

11. Ensure the Retract to cylinder check box is not selected. 

Retracting to Cylinder will retract in X and Y, and in this example, 

we need to retract along the Z vector. 

12. Click the Surface control tab, and select the surface <ig_srf3> 

as the Flowline guide surface at the bottom of the tab. (The 

surface name may have a different number in your file.) 

13. Click the Set Isoline Row/Col  button until the value in the 

Start Curve column is set to First Col, and then click OK. 

 

14. Select the Toolpaths  step from the Steps panel. 

15. Click the 3D Simulation  button, and then click the Play  

button. 

 The 3D simulation of 5-axis simultaneous parts can be slow. To 

speed up 3D simulation, select Options > Simulation from the 

Menu bar, and use the fields on the 2D/3D Shaded tab in the 

Simulation Options dialog. We recommend setting a larger Tool 
cutting tolerance. Adjusting Turn/mill angular interpolation 

and Tool visual tolerance can also improve the simulation 

speed. 
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To accelerate the graphics, choose Options > Surface Shading 

from the Menu bar, and select the Use Graphics Hardware 

option. 
 

Recognizing holes 
1. Select Import from the File menu. 

2. In the Import dialog, select ParaSolids as Files of type, and 

open the finished ParaSolids part myjayfilledholes_gsg.x_t. 

If you installed FeatureCAM in the default folder, the file should 

be in C:\Program Files\FeatureCAM\Examples\5axis 
simul. 

3. In the Import Results wizard, select the Use the same 
alignment as last import option, and click Finish. 

4. Open the Part View panel, expand the Solids node, and select the 

solid part that contains holes (this should be the second solid in the 

list). 

 

5. From the Hide  menu on the Advanced toolbar, select Hide 
Unselected. 

The part in the Graphics window looks like this: 

 

6. Select the Features  step from the Steps panel. 
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7. In the New Feature wizard, select Hole in the From 
Dimensions frame, select the Extract with RECOGNITION 

option, and click Next. 

8. Select the Along a specific Vector option, select the 

Recognize all holes option, and keep clicking Next until you 

reach the Hole Recognition Options page. 

9. Click the Select All button, click the triangle next to the Finish 

button, and select the Finish and Create More option. 

The part in the Graphics window should look something like this: 

 
 

Recognizing side features 
1. Return to the New Feature wizard, select Side in the From 

Curve frame, select the Extract with RECOGNITION option, 

and click Next. 

 

2. Hide everything except the part you selected. Select View > Hide 
> Hide Unselected. 
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3. Select the Automatic Recognition option, and click Next. 

4. Click the Select All button, click the triangle next to the Finish 

button, and select the Finish option. The part in the Graphics 

wizard looks something like this: 

5. Open the Part View panel, and right-click the first side feature 

(side1) under the Setup1 node. 

 

6. In the Properties dialog for side1, click the Strategy tab, 

deselect the Rough check box, and click OK. 

This is the outer side feature, and, therefore, it does not need to be 

roughed. 

7. Select the Toolpaths  step from the Steps panel. 
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8. Click the 3D Simulation  button, and then click the Play  

button. 

 

You have completed this tutorial. 
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 You must have the Solid Modeling option to perform this tutorial. 

This tutorial introduces you to the solid modeling capabilities of 

FeatureCAM by creating a model of the simple computer speaker shown 

below. 

 

The tutorial is available only in metric units and introduces you to: 

 Extrude design features. 

 Hidden line graphics. 

 Loft design features. 

 Filleting solid models. 

 Core/cavity separation of a solid model. 

 Creating manufacturing features from solids. 

 

Solid modeling basics 
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Getting started 

1. Start FeatureCAM by double-clicking the FeatureCAM icon  

on the desktop. 

2. If the New Part Document wizard is displayed, select the New 
file option, and click Next. Select Milling Setup, Millimeter, 

None, and click Finish. 

3. If the New Part Document wizard is not displayed, select File > 
New from the menu. Select Milling Setup, Millimeter, None, 

and click OK. 

4. Select Toolbars from the View menu. 

5. In the Customize Toolbars dialog, select the Steps, Display 
Mode and Solid check boxes on the Toolbars tab, and click OK. 

This opens the toolbars you need for this tutorial. 
 

Creating the initial solid 

1. Select the Curves  step from the Steps panel. 

2. In the Curves Creation dialog, select the Curve Wizard  

button. 

3. In the Curve wizard, select Other methods as the construction 

method, Rectangle as the constructor, and click Next. 
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4. On the Rectangle page, select the Use corner, width, and 
height option, and enter 0.0 and 0.0 for the X and Y Corner 

coordinates. 

5. Set Width to 100 and Height to 65, select the Create as arcs 
and lines option, and click Finish. 

 

6. In the Graphics window, right-click the right vertical line, and 

select the Delete option. 

 

7. Select Options > Snapping Modes from the menu. 
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8. In the Snap Modes dialog, ensure the End points option is 

selected (selected buttons have pale grey borders around them), and 

click OK. 

 

9. Create an arc. 

a. Select 2Pts, Radius from the Arc  menu on the 

Geometry toolbar. 

b. In the Feature/Geometry Edit bar, enter R = 105. 

c. Click the two open points in the Graphics window where the 

vertical line was. 

 

10. Chain geometry into curves. 

a. Select the Curves  step from the Steps panel. 

b. In the Curves Creation dialog, select the Closed Curve 

 button, and click the arc you just created. 

c. Click the Create button on the Feature/Geometry Edit bar. 
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11. Click the Solid Wizard  button on the Advanced toolbar. 

12. In the Solid wizard, select Define a custom shape..., and click 

Next. 

13. Select From Curves as the method and Extrude as the 

constructor and click Next. 

 

14. On the Extruded Solid page, enter -50 as the Vector Z 
coordinate and -5 as the Draft Angle, and click Finish. 
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Your part in the Graphics window looks something like this: 

 

15. Open the Part View panel, and expand the Solids node to reveal 

solid4. This is the name of the solid we are creating. The number 

following the solid name may be different for you. 

16. Expand solid4 to reveals the features that make it up. There is 

only one feature called extbase1. A base feature is the initial 

feature for a solid. 

 
 

Hidden line graphics 
With solids there are additional graphics options available. By default, 

you are in line-drawing mode. With solids, hidden line graphics are 

available. 

1. Click the Isometric View  button on the Standard toolbar. 

2. Select the Hide Stock option from the Hide  menu on the 

Advanced toolbar. 
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The default view of your solid model is shown below. On this 

stage, it is impossible to tell if there is a top on the solid. 

 

3. Click the Hidden Line  button on the Display Mode toolbar. 

The view of your solid model changes, making it clear that there is 

a top on the solid. 

 

While hidden-line mode provides nice quality graphics, it is 

considerably slower than simple line drawings, and sometimes 

hides portions of the model you need to pick. 

4. To return back to line drawing mode, click the Hidden Line  

button again. 
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 Hidden line graphics are only available for solids. 
 

Creating the curved lower surface 

1. From the Show  menu on the Advanced toolbar, select 

Show Stock. 

2. In the Graphics window, double-click the stock to open the 

Properties dialog, and click the Resize button on the 

Dimensions tab. 

 

3. In the Stock wizard (Stock Dimensions page), select 

Compute stock size from the size of the part, and click 

Next. 

4. On the Resize page, select Move Stock, and click Finish. 

The view automatically changes to top view. 
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5. Select the Front option from the Principal View  menu on 

the Standard toolbar. 

 

6. Create two arcs. 

a. Select 2Pts, Radius from the Arc  menu on the 

Geometry toolbar. 

b. In the Feature/Geometry Edit bar, enter R = 400. 

c. Set X1 to 120, Y1 to 0 and Z1 to -20; set X2 to -10, Y2 to 0 and 

Z2 to -40, and click the Create button. 

The part in the Graphics window looks something like this: 

 

d. Entering R = 160 for the second arc. 
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e. Click the right endpoint of the first arc, and then click the left 

endpoint of the arc. The new arc should curve down. 

 

 If your arc curves up instead of down, select the arc, and 

click the Options button on the Feature/Geometry Edit 
bar. 

If the cursor is still in the arc create mode, click the Select 

 button on the Standard toolbar. Now you are able to 

click and select the arc. 

7. Select the first (top) arc, and click the Transform  button on 

the Standard toolbar. 

8. In the Transform dialog, select the Translate and Copy 
options, enter 70 in the Y coordinate of XYZ Distance, and click 

OK. 

 

9. Select the second (bottom) arc, and click the Transform  

button. 
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10. In the Transform dialog, select the Translate and the Move 
options, and enter 35 in the Y coordinate of XYZ Distance, and 

click OK. 

 

11. Select the Isometric option from the Principal View  menu 

on the Standard toolbar. 

12. Click the Solid Wizard  button on the Advanced toolbar. 

13. In the Solid wizard, select From Curves as the construction 

method and Lofted as the constructor, and click Next. 
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14. Since we want to use this design feature to remove material, on the 

Lofting page select the As Cut option, and click the Pick Curve 

 button, and select the arcs in the order shown in the figure. 

 

15. If the selected arcs appear out of order in the curve list, use the 

arrows to move the arcs up or down. 

16. Click Finish. 

 

The curves are used to create a lofted surface and then the surface 

is used to cut the solid. 

An additional design feature, called loftcut1 is now listed in the 

Part View panel. 
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Creating constant and variable radius 
fillets 

1. Click the Solid Wizard  button on the Advanced toolbar. 

2. In the Solid wizard, select Shape Modifiers as the construction 

method and Fillet Edges as the constructor, and click Next. 

 

3. On the Edge Fillet page, enter 5 as the Radius, click the Pick 

Curve  button, and select the bottom edges 1-4 as shown in the 

figure. 

 

4. Return to the wizard, click the Variable option, and enter 5 as the 

Begin radius and 10 as the End radius. 
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5. Return to the Graphics window, and select the vertical edges 5-8 

as shown in the figure. 

 

This creates a variable radius fillet on these edges. As you click 

each edge an arrow is displayed to show the edge direction. The 

first radius is applied to the tail of the arrow and the second to the 

head of the arrow. 

6. Click Finish. 
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The solid part looks something like this: 

 

The selected edges are filleted and the surrounding surfaces have 

been trimmed. The corners where the fillets meet are automatically 

filleted. 

An additional design feature, called fillet1 is now listed in the 

Part View panel. 
 

Adding thickness 

1. Click the Solid Wizard  button on the Advanced toolbar. 

2. In the Solid wizard, select Shape Modifiers as the construction 

method and Shell as the constructor, and click Next. 

 



 

FeatureCAM 2011 Getting Started Solid modeling basics • 161
  

 

3. On the Shell page, enter an Offset distance of -2, and click the 

Pick Surface  button. 

4. Click the top surface as shown in the figure. 

 

This surface will not be offset. If the Select dialog opens, select 

the name that corresponds to the top surface. The surfaces are 

highlighted in the Graphics window as you select the names. 

5. Click Finish. 

 

All faces of the solid except the top surface are now offset by 2mm 

to provide thickness to the part. An additional design feature, called 

shell1 is now listed in the Part View panel. 

6. Select the Hide All Geometry option from the Hide  menu 

on the Advanced toolbar. 
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7. Click the Hidden Line  button on the Display Mode toolbar 

to have a better view of the solid. 

 

At this point, the solid model of the speaker is complete. 
 

Creating a mold cavity 
Now the challenge is to create a mold from the solid model. For parts that 

can be created with two mold halves, FeatureCAM's core/cavity feature is 

a useful tool. 

1. Click the Solid Wizard  button on the Advanced toolbar. 



 

FeatureCAM 2011 Getting Started Solid modeling basics • 163
  

 

2. In the Solid wizard, select Manufacturing as the construction 

method and Select Core/Cavity as the constructor, and click 

Next. 

 

3. On the Select Core/Cavity page, select the Bottom option. 

4. Select the Make solid from result option. This creates a new 

solid that contains the cavity faces. 

5. Click Finish. 

 

 A new solid, called sheet1, is added to the Solids node on 

the Part View panel. 

6. Right-click the solid4 on the Part View panel, and select the 

Hide Selected option. You can now see the cavity. 

You have completed this tutorial. 
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 You must have WIRE to perform this tutorial. 

In this tutorial, you will learn the basics of creating wire EDM toolpaths 

using WIRE. This tutorial is only available in inch units. 

Specifically, you will learn how to: 

 Set up your material and wire thickness. 

 Create wire EDM features. 

 Specify a wire EDM cutting strategy. 

 Simulate wire EDM toolpaths. 
 

Getting started 

1. Start FeatureCAM by double-clicking the FeatureCAM icon  

on the desktop. 

2. If the New Part Document wizard is displayed, select the New 
file option, and click Next. Select Wire EDM Setup, Inch, 

Wizard, and click Finish. 

3. If the New Part Document wizard is not displayed, select File > 
New from the menu. Select Wire EDM Setup, Inch, Wizard, 

and click OK. 

4. In the Stock wizard (Dimensions page), set the stock Width 
and Length to 4.0 and the thickness to 0.5. 

5. Click the triangle next to the Finish button, and select the Finish 

option. 
 

Introduction to WIRE 
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Creating the profile 

1. Select the Curves  step from the Steps panel. 

2. In the Curves Creation dialog, select the Curve Wizard  

button. 

3. In the Curve wizard, select Other methods as the construction 

method and Rectangle as the constructor, and click Next. 

 

4. On the Rectangle page, select Use corner, width, and 
height. 

5. Set the corner point to 1, 1, 0. 

6. Set the corner radius to 0.5 and set the Width and Height to 2.0. 

7. Click Finish. 
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Your part in the Graphics window should look something like 

this: 
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Creating a wire EDM feature 

1. Select the Features  step from the Steps panel. 

2. In the New Feature wizard, select the Die option in the 2 Axis 
frame, and click Next. 

 

3. On the Curves page, click the Pick Curve  button, and select 

the curve you just created. 

 

4. Click Next until you get to the Dimensions page. 

5. Enter 0.5 as the Thickness and click Next twice to get to the 

Strategies page. 



 

168 • Introduction to WIRE FeatureCAM 2011 Getting Started  

6. Select Retract in the Operations field, and select the Cutoff and 

Contour options. 

 

7. Click the triangle next to the Finish button, and select the Finish 

option. 
 

Simulating a wire EDM toolpath 

1. Select the Toolpaths  step from the Steps panel. The 

Simulation toolbar is displayed. 

2. Click the 2D Simulation  button on the Simulation toolbar. 

3. Move the Sim Speed  slider to the middle so that the 

simulation is slowed down. 

4. Select the Play to Next Operation option from the Simulation 

Next  menu. 
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You’ll notice that the Retract operation makes two passes. If you 

need to slow down the simulation, drag the Sim Speed  

slider to the left. 

 

5. Click the Play to Next Operation  button again. The Cutoff 

operation now takes two passes. Slow down the simulation if you 

need to. 
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6. Click the Play to Next Operation  button once more. The 

final Contour operation is now simulated. 

 

7. Click Eject . 
 

Generating NC code 

1. Select the NC Code  step from the Steps panel. 

2. Click the Display the NC Code  button in the NC Code 

dialog to generate the NC code. 
 

Adding a taper angle 
1. Open the Part View panel, select the die1 feature from the 

Setup1 node, and click the Properties  button on the 

Feature/Geometry Edit toolbar. 
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2. In the Properties dialog for die1, select the Constant option, 

choose Left as the taper type, enter 10 as the taper angle in the 

Deg. field, and click Apply. 

 

3. Select the Hide Stock option from the Hide  menu on the 

Advanced toolbar, and click the Isometric View  button on 

the Standard toolbar to get a 3-dimensional view of the part. 

 

4. Return back to the Properties dialog, set the taper type to Right, 
and click Apply. View the new shape in Isometric view. 
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5. Change the taper type back to Left, and click OK to close the 

Properties dialog. 

6. Select the Toolpaths  step from the Steps panel. 

7. Click the 3D Simulation  button, and then click the Play  

button. 

Since this is a die feature, it is assumed that the region inside of the 

curve will be discarded. 

 

8. Click the Select  button on the Standard toolbar. 

9. Click the stock in the region inside of the curve. FeatureCAM 

deletes that part of the stock. 

 

10. Click Eject . 

11. From the Show  menu on the Advanced toolbar, select 

Show Stock. 
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12. Open the Part View panel, right-click the die1 feature, and select 

the Hide Selected option. Now the feature will not be displayed 

on the screen. 
 

Creating the second profile 

1. Select the Top option from the Principal View  menu on the 

Standard toolbar. 

2. Select the Curves  step from the Steps panel. 

3. In the Curves Creation dialog, select the Curve Wizard  

button. 

4. In the Curve wizard, select Other Methods as the construction 

method and Rectangle as the constructor, and click Next. 

 

5. On the Rectangle page, select Use corner, width and height. 

6. Set the corner point to 0.5, 0.5, 0.0. 
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7. Set the Width and Height to 3.0, and click Finish. 

 

Your part in the Graphics window should look something like 

this: 

 

 



 

FeatureCAM 2011 Getting Started Introduction to WIRE • 175
  

 

Creating a 4-axis wire EDM feature 

1. Select the Features  step from the Steps panel. 

2. In the New Feature wizard, select the Die option in the 4 Axis 
frame, and click Next. 

 

3. On the Upper Curve page, click the Pick Curve  button and 

select the curve that you just created. 

 

4. Click Next. 
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5. On the Lower Curve page, click the Pick curve  button and 

select the smaller curve that you created first. 

 

6. Keep clicking Next until you get to the Dimensions page. 

7. Enter 0.50 as the Thickness, click the triangle next to the Finish 

button, and select the Finish option. 
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The feature is twisted because the start points were not set. 

 
 

Modifying the start point 
1. Open the Part View panel, select the die4x1 feature from the 

Setup1 node, and click the Properties  button on the 

Feature/Geometry Edit bar. 

2. In the Properties dialog for die4x1, click the Start tab. 

3. Click the Pick Location  button for the Upper Curve 
Start/End Point. 

4. In the Graphics window, click a point in the center of the stock, 

and then click on the bottom horizontal line of the outer curve. You 

should notice a green line between the point and the edge of the 

curve. 
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5. Click the Pick location  button this time for the Lower 
Curve Start/End Point. 

6. Click in the center of the stock and click the bottom horizontal line 

of the inner curve. 

 

7. Click OK. The feature now should no longer be twisted. 

 
 

Matching the curves 
1. Open the Part View panel, select the die4x1 feature from the 

Setup1 node, and click the Properties  button on the 

Feature/Geometry Edit bar. 
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2. In the Properties dialog for die4x1, click the Dimensions tab 

and click the Match Curves button. 

 

3. In the Match Curves dialog, click the Pick Lower Curve 

Point  button. 

4. In the Graphics window, select the top right point on the lower 

curve, and then select the right corner point on the upper curve. 

You should see a green line between the two points. 
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5. Hold down the Shift key and select the upper-right point on the 

lower curve, and then select again the right corner point at location. 

 

Now you have matched both points on the lower curve to the single 

point on the upper curve. 

6. Click Apply, and then click OK to close the Match Curves 

dialog. 

7. Click OK in the Properties dialog. 

The part in the Graphics window looks something like this: 

 
 

Simulating the part 
1. Open the Part View panel and deselect the check box next to the 

die1 feature to exclude it from the simulation. 

2. Click the Isometric option from the Principal View  menu on 

the Standard toolbar. 
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3. Select the Toolpaths  step from the Steps panel. 

4. Click the 3D Simulation  button, and then click the Play  

button. 

 

5. Click the Select  button on the Standard toolbar. 

6. Click the stock in the region inside of the curve. FeatureCAM 

deletes that part of the stock. 

 

7. Click Eject . 

You have completed this tutorial. 
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