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FeatureCAM 2012 R3 offers all of the original features of 

FeatureCAM 2012 R2, but with numerous improvements. The most 
significant improvements are detailed in the following topics. 

General: Only one user can edit 
FeatureCAM files at a time 

In FeatureCAM 2012 R3, a file is locked when a user opens it. If a 
second user tries to open the file, a message is displayed: 

The requested file is locked by [user]. Would you like to open a read 
only copy? 

Files that are read-only display [Read Only] in the title bar after the 

name of the file. 

If you open a read-only copy, you can't save any changes using 
Save. (You can save a copy of the file using Save As.) 

What's New in 
FeatureCAM 2012 R3 
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General: Enter custom G-code into the 
NC program 

In FeatureCAM 2012 R3, you can enter G-code directly into the NC 
program, by using the new NC code text option for creating a 

Toolpath feature: 

 

Program stop code example 

To enter program stop code directly into the NC program: 

1 Click the Features  step in the Steps panel. The New Feature 

dialog opens. 
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2 In the From Feature section, select Toolpath and click Next. The 

New Feature - Curve or Operation page is displayed. 

 

3 Select the NC code text option and enter M00 (or M01). 

4 Click Next. The New Feature - Toolpath feature page is displayed. 

 

This page has the same toolpath editing buttons as the Toolpaths 

tab in the Toolpath Properties dialog. 

5 Click Finish. The Toolpath feature is listed in the Part View and on 

the Op List tab. 

6 Simulate the Toolpath feature. In this example, there are no 
toolpaths to see, but you must simulate the feature to produce 

the NC code. 

7 View the NC code on the NC Code tab. 

 If a Toolpath feature consists only of G-code, FeatureCAM 
does not display the Tools or F/S tabs in the Toolpath 

Properties dialog. 
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General: Soft errors 
FeatureCAM 2012 R3 introduces soft errors. A soft error does not 
prevent you from running a simulation and generating NC code, but 
it does prevent you saving the NC code (the File > Save NC menu 

option is unavailable). 

Soft errors are suffixed SE, for example FS001SE is the soft error for 

Feed and speed table not found. 
 

User interface: Set priority for multiple 
operations on the Op List 

In FeatureCAM 2012 R3, you can override the priority for multiple 
operations in the Operation List. To do this, SHIFT+select or 

CTRL+select multiple operations on the Op List tab, right-click and 
select Override priority to... in the context menu: 

 
 

Paste special: Copy attributes from one 
feature to many 

In FeatureCAM 2012 R3, you can copy the attributes from one 

feature to many features. 

To do this: 

1 Select the feature whose attributes you want to copy. 

2 Select Edit > Copy from the menu. 

3 Select Edit > Paste Special from the menu. 
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The Paste Special wizard is displayed. 

4 In the Paste Special wizard, select Copy the machining attributes 

from the feature on the clipboard to another feature. 

 

5 Click Next. The Paste Special - Attributes page is displayed: 

 

6 Select the types of attribute you want to copy from: 

 Feed/Speed overrides 

 Tool overrides 

 Machining Attributes 

7 Select whether you want to Copy only the attributes that were set 

on the feature or Copy all machining attributes in effect for the 

feature. 

8 Select the features you want to copy the attributes to. 

9 Click Finish. 
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Stock: Shaded and translucent 
FeatureCAM 2012 R3 can display stock as shaded and translucent. 
To do this, select Shade stock by default in the Shading Options 

dialog and enter a Stock Opacity of between 0 and 1. 

 

This is an example part with Shade stock by default deselected: 

 

And with Shade stock by default selected with a Stock Opacity of 0.3: 
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Import: New surface naming scheme 
groups surfaces 

In FeatureCAM 2012 R3, imported surfaces are named according to 
which solid they belong to. For example, the surfaces imported from 
a solid named solid1 are named solid1_1, solid1_2, solid1_3, and so 
on in the Part Tree; and the surfaces from a solid named solid2 are 

named solid2_1, solid2_2, solid2_3, and so on. 

This makes it easier to see which surfaces belong to which solid and 
to select all the surfaces from just one solid. This is useful if you 

want to stitch imported surfaces back into solids. 
 

Import: PTC Creo files supported 
In FeatureCAM 2012 R3, you can import PTC Creo files. 

 

Tool mapping: 8-digit Diameter & 
Length offset registers 

FeatureCAM 2012 R3 supports more machine types because you 
can enter 8 digits for the tool Length offset register and Diameter 

offset register in the Tool Mapping dialog: 
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Toolpath edit: Insert multiple lines of 
G-code 

In FeatureCAM 2012 R3, you can enter multiple lines of G-code. 

Click the Add NC code text  button on the Toolpaths tab to open 
the Add NC Code Text dialog: 

 

Single lines of NC code have the icon on the Toolpaths tab and 

multiple lines of code have the  icon. 
 

2.5D: Rough cutter comp. machining 
attribute 

In FeatureCAM 2012 R3, there is a new Rough cutter comp option on 
the Milling tab of Machining Attributes: 
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Select the Rough cutter comp option to enable cutter compensation 

for the rough pass of all milled features in the current document by 
default. 

 The Rough cutter comp option is not available until you 

select the Cutter comp option. 

You can disable it at feature-level on the Strategy tab: 

 

 
 

2.5D: New technology (NT) toolpaths 
for Side features 

In FeatureCAM 2012 R3, the NT toolpaths that were introduced in 

FeatureCAM 2012 R2 for Pocket and Boss features, are also 
available for Side features. 

The three new roughing Stepover types are: 

 NT Spiral - can use stepovers larger than 50% 

 NT Zigzag - uses an angle that is calculated automatically to cut 

the longest toolpaths 

 You can use NT Zigzag toolpaths only with features made 

from closed curves. If they are not closed and you select 
this option, FeatureCAM uses NT Spiral. 

 NT Continuous Spiral - eliminates nearly all stepovers 
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Set the default type in Machining Attributes on the Stepover tab: 

 

Click the new Stepover Options button to open the new Rough 

Stepover Options dialog: 

 

 A Stepover type of Zigzag is not available for Side features. 
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At feature level, set the Stepover type in the new menu on the 

Strategy tab of the feature's Properties dialog: 

 

You can override this at operation level on the Stepovers tab: 

 

If you are using Individual rough levels, you can set the Cut type for 

each individual rough pass. 
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NT Side example 

This example shows a centerline simulation of a Side feature using 
the traditional Spiral stepover type: 

 

Using NT Spiral gives a similar result, but the toolpaths and 

stepovers are smoother: 

 

Using NT Continuous Spiral, the closed part of the toolpath at the 

center of the feature (the teardrop shape) uses a continuous spiral 

and the rest of the toolpath uses a non-continuous spiral: 
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NT Zigzag applies only to closed curves, so with this example, the 

Side feature is made from a closed curve that goes around the edge 
of the Stock: 

 

 If you select a Stepover Type of NT Zigzag for an open curve, 

FeatureCAM uses NT Spiral. 

 

 

 
 

2.5D: Select Holes by depth or diameter 
In FeatureCAM 2012 R3, you can select all Holes in the part with the 
same depth and/or diameter. 

The Select by Color/Type dialog has two new options, Hole Depth and 
Hole Diameter. Select Edit > Select by Color/Type to open the dialog. 

 

Hole Depth — To select all Holes of a particular depth, first select a 

type of hole in the Entity Type menu, then enter the Hole Depth 

Value, and a Tolerance for how close to the Value the depth must be. 
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Hole Diameter — To select all Holes of a particular depth, first select 

a type of hole in the Entity Type menu, then enter the Hole Diameter 
Value and a Tolerance for how close to the Value the diameter must 

be. 

 Select a Hole on your part before opening the dialog to 
pre-populate the fields. 

 

Viewing modes: Horizontal milling and 
vertical lathe 

In FeatureCAM 2012 R3, there is a new Machine tab in the Viewing 

Options dialog: 

 

Milling — Select the type of milling machine from Vertical (the 

default and previous behavior) and Horizontal, to improve viewing 

during machine simulation. 

Turning — Select the type of turning machine from Slant bed lathe 

(the default and previous behavior) and Vertical turret lathe, to 

improve viewing during machine simulation. 
 

MTT: Better user interface 
In FeatureCAM 2012 R3, it is easier to access options that were 
previously available only on the right-click context menu. 
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Click the new  button on the Turrets tab to access the options 
Reset all opers to default turret and Remove all oper sync points: 

 
 

Tool database: FeatureCAM add-in to 
import TDM tools 

A new FeatureCAM add-in is available that can be run independently 

of the FeatureCAM MS-Access network database. It uses a 
tab-delimited file to read the FeatureCAM-TDM (Tool Data 

Management) tool mapping, and uses that to import tools from TDM 

into the FeatureCAM network database. These are a few benefits:  

 The script works with any version of FeatureCAM, as long as the 

map is correct for that version. 

 The FeatureCAM-TDM tool map and import script have been 

separated, making the script tool-agnostic. Also you don't have 
to deal with SQL and other technical details which can be 

frustrating. 

 The script creates a log of all the import failures. 

 The script is a FeatureCAM add-in, making it easy to run and 
automate if necessary. 

 

API: Help 
All new documentation for FeatureCAM's API is now available from 

the FeatureCAM help file, making writing FeatureCAM addins easier 
than ever before. Select Help > FeatureCAM API Help from the menu 

to access it. 
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FeatureCAM 2012 R2 offers all of the original features of 

FeatureCAM 2012, but with numerous improvements. The most 
significant improvements are detailed in the following topics. 

 

Network database: Shared machining 
configurations 

In FeatureCAM 2012 R2, you can share machining configurations 
across a network. 

There are now three types of configuration: 

 File (f) - Configurations for files that are currently open. 

 Personal (p) - Configurations that are independent of a particular 

file and are stored only on your PC. 

 Workgroup (w) - Configurations that are independent of a 

particular file and are stored on a network for sharing with 

colleagues. 

What's New in 
FeatureCAM 2012 R2 
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To create a Workgroup configuration, first enter a valid network 

path in the File Options dialog on the Configurations tab: 

 

In the Machining Configurations dialog, click New to open the New 

Configuration dialog 

You can now set a Configuration type of Workgroup: 

 

After you click OK, the new configuration is shown in the list of 

available configurations, with a group  icon and is followed by (w) 

in menu items: 

 

You can set the new Workgroup configuration as the Initial 

configuration for new documents. 
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Import improvements 
FeatureCAM 2012 R2 can read Pro/E Family Tables, which are 
multiple configurations of a given part. 

SolidEdge ST4 is now supported. 
 

User interface: Copy and paste from 
PowerSHAPE 

You can now copy and paste solids and surfaces from PowerSHAPE 

into FeatureCAM. Surfaces, curves, lines, and arcs are supported. 

You can also copy and paste solids from FeatureCAM into 

PowerSHAPE. 
 

 
 

2.5D: New technology (NT) toolpaths 
In FeatureCAM 2012 R2, there are three new roughing Stepover 
types: 

 NT Spiral - can use stepovers larger than 50% 

 NT Zigzag - uses an angle that is calculated automatically to cut 

the longest toolpaths 

 NT Continuous Spiral - eliminates nearly all stepovers 

The NT (new technology) toolpaths support Pocket, Rectangular 

Pocket, and Boss features. 
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Set the default type in Machining Attributes on the Stepover tab: 

 

Click the new Stepover Options button to open the new Rough 

Stepover Options dialog: 

 

The NT toolpaths are available in the Stepover menu along with the 

traditional Spiral and Zigzag toolpaths. 
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At feature level, set the Stepover type in the new menu on the 

Strategy tab of the feature's Properties dialog: 

 

You can override this at operation level on the Stepovers tab: 

 

If you are using Individual rough levels, you can set the Cut type for 

each individual rough pass. 

NT Spiral example 

This example part includes a Boss feature and a Pocket feature, 
outlined in red: 
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This is a centerline simulation of the Boss feature using the 
traditional Stepover type of Spiral: 

 

This is the same feature cut using the new technology Stepover type 

of NT Spiral: 

 

This is a centerline simulation of 
the left Pocket feature using the 
traditional Stepover type of Spiral: 

This is the right Pocket cut using 
the new technology Stepover type 

of NT Spiral: 
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There are three new attributes available on the roughing operation 
Milling tab of the Feature Properties dialog: 

 

HSM max tool overload % - instigates trochoidal machining. As the 

tool gets towards overload, FeatureCAM automatically puts in a 

trochoidal path to take away the overload.. 

HSM profile corner % - This allows the arc fitting of profile to avoid 

sharp changes in direction in internal corners. 

HSM smoothing allowance % - replaces the standard offset with a 

smoother one that can achieve higher feed rates. 

 Sharp rounded corners replace sharp corners. 



 

FeatureCAM 2012 R3 What's New What's New in FeatureCAM 2012 R2 • 23  

 The stepover is changed from a fixed to a variable distance. The 

percentage defines the maximum deviation from the specified 

stepover. The maximum percentage is 40% of stepover. So, if 

you have a 10 mm stepover the maximum deviation from the 
original to the smoothed offset is 4 mm. 

This replaces the standard offset with a smoother one that can 
achieve higher feed rates. 

 Sharp rounded corners replace sharp corners. 

The stepover is changed from a fixed to a variable distance. The 

percentage defines the maximum deviation from the specified 

stepover. The maximum percentage is 40% of stepover. So, if you 

have a 10 mm stepover the maximum deviation from the original to 
the smoothed offset is 4 mm. 

 

Differences between NT and traditional toolpaths 

Pre-drill differences 

There are some differences with how the Pre-drill operation works 

with the NT toolpaths compared to the traditional toolpaths. 

 You can use a Pre-drill operation with the NT Zigzag toolpath. It is 

not available for the traditional Zigzag toolpath. 

 With the NT toolpaths, zigzag ramping is automatically disabled 
when you use a Pre-drill operation. This is not supported for the 

original Spiral toolpath and you must set the Max. ramp angle to 0 

to disable zigzag ramping when using a Pre-drill operation. 

 The Pre-drill operation for the NT toolpaths includes the tops of 

multi-height islands. This is not supported for the original 

toolpaths. 

 The traditional Spiral toolpath supports manual plunge points for 

the pre-drill locations using the Plunge point(s) attribute. The NT 

toolpaths support only automatic locations. 

Stepover differences 

There are some differences in the attributes available for NT 
toolpaths on the feature Stepover tab: 

There are two Ramp type options for the NT toolpaths: 

 Smooth - similar to the traditional toolpath option S-type 

 Direct - similar to the traditional toolpath option Line. 
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You can specify separate Lead-in and Lead-out options for NT 

toolpaths: 

 

The NT toolpaths have a new attribute Approach from outside. This 

option automatically adds a very small lead-in whenever the tool is 

plunging off the stock. When you select this option, the lead-in 
options are disabled. Deselect it to manually specify the lead-in as a 

line, arc, and/or toolpath extension. 

 The Angle attribute for NT toolpaths supports only positive 

angles. The direction relative to the toolpath is automatically 

determined.  

Other differences 

On the Milling tab, NT toolpaths have a new attribute, Stepover rapid 

distance that controls when to retract and plunge on Boss 

stepovers. This is an absolute distance and replaces the Min. rapid 

distance % attribute used by the traditional toolpaths. 
 

Better Minimize tool retract with NT toolpaths 

Using the Minimize tool retract options with the NT toolpaths gives 

better results than with the traditional toolpaths. 

Pocket feature 

For a Pocket feature, the toolpath slot cuts following the offsets 

instead of just a straight line. There are fewer plunges than with 

traditional toolpaths. 
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Traditional toolpath example: 

 

NT toolpath example: 

 

Boss feature 

For a Boss feature, the toolpath has a lot fewer retracts and plunges 

at the edge of the Stock. 
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Traditional toolpath example: 
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NT toolpath example: 
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2.5D: Separate lead-in and lead-out 
distances 

In FeatureCAM 2012 R2, you can set lead-in and lead-out distances 
separately: 
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2.5D: Thread Mill tool hand 
FeatureCAM 2012 R2 supports either right-hand or left-hand thread 
milling tools: 

 

Select Right Hand or Left Hand for the Hand option. 

The Feed Dir attribute on the Strategy tab has also been updated: 
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2.5D: Face Mill tools for Chamfers 
In FeatureCAM 2012 R2, you can use a chamfered Face Mill tool to 
cut a Chamfer feature. Face Mill tools are now available in the Tool 

Group menu on the Tools tab: 

 

The benefit of this is that you can use fewer tools to machine a part. 

Example 

This example part has a Face and Chamfer features on the top and 

on the side: 

 

By default, this part uses three tools: 

 a Face Mill to cut the top Face, then indexed around to cut the 

side Face. 

 a Chamfer tool to cut the Chamfer around the top Face 
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 a Chamfer tool to cut the Chamfer around the side Face 

 

Instead of the default Face Mill, you can create a new Face Mill with 
a Chamfer, for example: 

 

Set this new tool as the override for the Face feature, and then use 
it to cut the Chamfer features, by overriding the default tools in the 

Op List. 

After simulating the part again, you can see that the new Face Mill 
tool cuts both the Face features and the Chamfers: 
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In this example, the chamfered Face Mill tool is too large to cut the 

Chamfer on the side of the part: 

 

FeatureCAM give a warning and you can change the tool for this 
Chamfer back to the default tool. 

Using a chamfered Face Mill tool, you can cut this particular part 
with two tools instead of three: 

 

 a chamfered Face Mill to cut the top Face, the top Chamfer, then 

indexed around to cut the side Face 

 a Chamfer tool to cut the Chamfer around the side Face 
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2.5D: Hole cycle G74 and G88 
FeatureCAM now supports the hole cycles G74 (left-handed tapping) 
and G88 (boring cycle). 

Enter the G-codes in the NC Codes dialog in XBUILD: 

 

 If you do not enter a G-code for the Reverse Tap cycle, 

computed canned moves are performed. If you do not enter a 
G-code for the Bore (FDSJ) cycle, the Bore (FF) cycle is used. 

The new Reverse Tap cycle is available on the Cycle tab of a Hole 
feature for a Tap operation and the Bore (FDSJ) cycle is available for 

a Bore operation. 
 

3D: Z-level finish: Flat surface support 
In FeatureCAM 2012 R2, you can now use flat surface support with 
Z-level finishing. This option inserts a final profile pass exactly at 
the base of a flat pocket. There is a new option, Flat srf support, in 
the Surface Milling Properties dialog on the Milling tab: 
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This example shows previous behavior, with Flat srf support 

disabled: 

 

With Flat Srf support enabled, FeatureCAM adds a final profile pass, 

: 

 

 
 

3D: Save boundary curve 
You can now save the boundary curve that has been calculated for 

an operation to use in subsequent operations. To save the boundary 
click the new Save Combined Boundary button on the Stock tab: 
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The boundary is saved as Curves, which are listed in the Part View. 

To use some or all of these curves as the boundary of another 
operation: 

1 Select the Select curves for boundaries option on the Stock tab of 

the second operation. 

2 Click the Curve Options button to open the Boundary Curve 

dialog. 

3 Click the Boundaries button to open the Select Boundary Curves 

dialog. 

4 Select the box(es) next to the curve(s) you want to use. 

 Hold down the Shift key to select multiple consecutive 

curves. 

5 Click OK to save and close the Select Boundary Curves dialog. 

6 Click OK to save and close the Boundary Curve dialog. 

7 Simulate the second operation. 

The simulation is quicker because FeatureCAM does not need to 

calculate the boundary again. 

Example 

This example part uses a Z-level finish operation restricted to the 
steep areas only, using the Vertical only option on the Slopes tab, 

followed by a 3D spiral operation on the shallow areas. 

1 Simulate the Z-level finish operation. 

FeatureCAM takes a short time to calculate the boundary and 
you see a Calculating boundary message on the progress bar. 

When it is complete, the toolpath looks like this: 

 

You can save this boundary to use in subsequent operations. 

2 On the Stock tab for the Z-level operation, click the Save 

Combined Boundary button. 
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3 Click Yes to save the boundary. The boundary curves are 

displayed in dark blue: 

 

For the next operation, we want to use a 3D spiral operation on 
the shallow areas of the part. 

4 On the Stock tab of the 3D spiral operation, select the Select 

curves for boundaries option. 

5 Click the Curve Options button to open the Boundary Curve 

dialog. 

6 In the Boundary Curve dialog, click the Boundaries button to open 

the Select Boundary Curve dialog, which displays a list of the 

curves you saved. 

7 Select the boxes next to the curves you want to use for the 

boundary. In this case we want to use all except the first curve, 
which runs around the top of the stock. 

8 Click OK to save and close the Select Boundary Curves dialog. 

9 Click OK to save and close the Boundary Curve dialog. 

10 Simulate the 3D spiral operation. FeatureCAM does not need to 

calculate the boundary again and goes straight into calculating 
the toolpath: 

 
 



 

FeatureCAM 2012 R3 What's New What's New in FeatureCAM 2012 R2 • 37  

5-axis: Turn/Mill B-axis alternative 
position 

In FeatureCAM 2012 R2, the Use alternative 5-axis position attribute 
is available on the Drilling and Milling tab for 2.5D milling operations 

in Turn/Mill parts. 

This means that you could cut 2.5D operations at, for example, 
B=-10 instead of the default +10 if the B-head has more clearance 

tilting up. 

 
 

Simulation: Step backward 
You can now step backward through a simulation. Select View > 

Simulation > Step Backward from the menu to go back one step, or 
use the keyboard shortcut Alt+Left. 

 

 This option is available only after you have used Step Forward 

from this menu or the Single Step  button on the 

Simulation toolbar. 
 

Simulation: Faster 3D simulation 
In FeatureCAM 2012 R2, 3D simulation and machine simulation is 

faster thanks to the use of multiple cores when doing simulation. 
Multiple cuts are performed simultaneously using multiple cores, 

and you see the end result much sooner. 
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You can also save the results of a 3D simulation to use as a starting 

point, to save calculation time during subsequent simulations. 
Select View > Simulation > Use Results as Starting Point to use the 

current simulation results. To clear the simulation results, select 
View > Simulation > Clear Starting Point. 

 

 To use this feature, you must select Save result files during 3D 

sim on the 2D/3D Shaded tab of the Simulation Options dialog. 
 

Simulation: New keyboard shortcuts 
There are two new keyboard shortcuts that you can use during 
simulation: 

Alt+Right - Press and hold the Alt key then click the right cursor 

arrow key to step forward once. 

Alt+Left - Press and hold the Alt key then click the left cursor arrow 

key to step backward (see page 37) once. 
 

Machine simulation: Better collision 
display 

FeatureCAM 2012 R3 has improved collision detection for machine 

simulation. 
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Whenever a named part of the machine collides with another solid, 

a flashing arrow is displayed and the display turns transparent, for 
example: 

 

 You must enable Pause on gouge on the 2D/3D Shaded tab of 
Simulation Options to see this feature. 

The first collision point only is marked. 

The display returns to normal when you continue the 
simulation. 

The arrow is not shown for tools colliding with stock. 

 
 

Turn/Mill: Cylindrical interpolation 
support 

FeatureCAM 2012 R2 supports cylindrical interpolation in the NC 
code for Turn/Mill and 4th-axis parts. This enables features that are 

wrapped around one of the index axes to use a cylindrically 

interpolated toolpath. The result is shorter NC code and better 
interpretation of cutter compensation. 
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To use it, select the new option Machine tool and post support 

cylindrical interpolation in the General Information dialog in XBUILD: 

 

Cylindrical interpolation uses these new reserved words: 

<CYL-INTERP> - logical, TRUE if cylindrical interpolation is used 

<WRAP-RADIUS> - numeric, the wrapping radius 

For example, this part has four Pockets wrapped around the Z axis: 

 

A 3D simulation looks like this: 
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After selecting the Machine tool and post support cylindrical 

interpolation option, the NC code uses G07 to turn on cylindrical 

interpolation for the Pocket operations. This makes the NC code 

shorter, and smaller in memory size. 
 

Turn/Mill: Separate fixture offset for 
each feature 

There are new attributes in FeatureCAM 2012 R3, on the Misc tab of 

the feature's Properties dialog, which let you use a separate fixture 

offset for each B-axis turn/mill Hole (or other feature). 

 

Subfixture ID - applies to B-axis turn/mill features and corresponds 

to the <SUBFIXTURE> reserved word in XBUILD. This lets you use a 

separate fixture offset for each Hole (or other feature). For 

example, if the Fixture ID is 54 and you enter a Subfixture ID of 1, the 

output is 54.1. 
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For patterns, enter a Subfixture ID start value and a Subfixture ID 

increment value. For example, if the Fixture ID is 54 and you enter a 

Subfixture ID start of 1 and a Subfixture ID increment of 1, the output 

is 54.1, 54.2, 54.3, and so on. 
 

XBUILD: Use Delcam post processor 
files 

You can now use *.pmopt and *.pmoptz files with XBUILD: 

 

 Some PMOPT capabilities are not supported by XBUILD. For 

example, XBUILD supports much wider variety of NC output 
for 2-axis milling than is currently unavailable in PMOPT.  So if 

you choose PMOPT you lose such control of your NC code. 
PMOPT files do not support Turning and Wire EDM. 

 
 

Probing: UDF available 
In FeatureCAM 2012 R2 you can preview a UDF-based probing 
capability that is available to purchase as a optional module. This 

module supports a variety of touch-probing capabilities such as 
setting of part location fixture offsets, setting of tool offsets, 

probing-and-recut, and so on. The software is developed as an 
add-in that works with a modified post processor, and is available 

by request to the Post department. 
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API: New functions 
This is a summary of the new API functions, for more information 
please see the API help file. 

FMToolpathPts.DeleteItem - Delete a toolpath point from list of 

points. 

FMToolpathPt.Dwell - Return and set the dwell time associated 

with the toolpath point. 

FMToolpathArc.Dwell - Return and set the dwell time associated 

with the toolpath arc. 

FMToolpathPts.AddtoolpathNCText - Create a toolpath NC text 

segment. 

FMToolpathNCText - A new class to represent the NC text segment. 

FMFeatures.AddToolpathFromOperation - Create a toolpath 

feature from an operation. 

Application.SetGraphicsWinLowerColor - Set graphics window 

lower background color. 

Application.SetGraphicsWinUpperColor - Set graphics window 

upper background color. 

FMCurves.AddFunctionCurve - Create curve from function. 

FMSurfaces.AddSurfaceCoons - Create a coons surface. 
 

Other improvements 
 Network database - The network database is now more reliable. 

 2.5D: Performance improvement for large STL stock. 

 Turn/Mill - The Disable Macros option is now available on the 

Turn/Mill tab in the Post Options dialog. 
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FeatureCAM 2012 offers all of the original features of FeatureCAM 

2011 R3 (V17.8), but with numerous improvements. The most 
significant improvements are detailed in the following topics. 

 
 

User interface: More isometric views 
There are now four isometric views available. As well as the existing 
Isometric view, there are also Isometric 2, Isometric 3, and Isometric 4 

views. Access the new views from the View > Principle Views menu: 

 

What's New in 
FeatureCAM 2012 
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Or from the Principle View menu on the Standard toolbar: 

 

The following example shows all four isometric views: 

Isometric: 

 

Isometric 2: 

 

Isometric 3: 

 

Isometric 4: 
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User interface: Keyboard shortcuts 
There is a new tab in the Customize Toolbars dialog, Keyboard 

Shortcuts: 

 

This tab lets you assign your own shortcut keys to the FeatureCAM 

menu commands. 

To set a new shortcut key: 

1 Select a category from the Categories list. 

2 Select a command from the Commands list. 

If the command already has a shortcut, it is listed under Current 

keys. 

3 To assign a new key, select the Press new shortcut key field and 

press the keys that you want to use as the shortcut. 

 Press the keys on the keyboard, for example, press and 

hold down the Alt key and press the N key; do not type ALT 

+ N. 

 A warning displays if the shortcut you entered is already 
assigned to a command. 

4 Click the Assign button to save the new shortcut. 

 If you click Assign after receiving a warning that the 

shortcut is already assigned to a command, the shortcut is 

removed from the existing command and assigned to the 
new command. 
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Remove — Click this button to remove the shortcut assigned to the 

selected command. 

Reset All — Click this button to reset all shortcuts to the FeatureCAM 

defaults. 

Document — Click this button to open a *.txt file, containing a list of 

the current shortcuts, in your text editor. You can print or save this 

file. 

 
 

User interface: Part view multiple 
select 

You can now select multiple items in the Part View using Shift + click 

to select consecutive items and Ctrl + click to select non-consecutive 

items. 

 
 

In the following example, we 
want to select all of the Hole 

features to add to a group: 

 To do this, select pattern1, hold 

down the Shift key and click 
pattern2, hold down the Ctrl key 

and click pattern3, hole4, and 

hole5: 
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Tooling: Better Face Mill tools 
There is a new option to specify a 45  chamfer for Face Mill tools: 

 

This new option allows more accurate simulation and machining. 

Existing tools are classified as Round by default. 

To set a 45  chamfer on a Face Mill tool: 

1 Select Chamfer as the Corner type. 

2 Enter an Effective Diameter greater than zero. 

3 Enter a Tip Radius greater than or equal to zero. 

4 Click the Apply button. 

The tool preview image on the right of the dialog updates to 
show the chamfer, for example: 
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Tooling: Cutting data by tool 
You can associate cutting data with individual tools in the tool 
database at two levels: 

 On the Overrides tab of the Tool Properties dialog. You can set 

cutting data for the tool for all materials and operations. 

 On the Feed/Speeds tab of the Tool Properties dialog. You can set 

cutting conditions by material, operation, and cut type. These 
override any settings on the Overrides tab. 

 You can override these settings at feature operation level. 

Tool overrides for all materials and operations 

The new parameters on the Overrides tab of the Tool Properties 
dialog are Depth of cut (Z-step increment), Stepover distance, and 

Ramp angle. 

Enter values to use with the current tool for all materials, except 
those overriden on the Feed/Speed tab, for example: 

 

Tool overrides by material, operation, and cut type 

As well as the previously available Speed and Feed settings, you can 

set Depth (of cut) and Stepover by Material, operation (Rough and 
Finish) and type of cut (Profile, Slot, Face, and Plunge Mill). 
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To do this, select the Feed/Speed tab of the Tool Properties dialog 

and click the Create new item  button: 

 

The Tool Specific Feeds and Speeds dialog opens. 

Select the Material name from the list and enter any Depth and 
Stepover overrides by operation and type of cut, for example: 
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Click OK. The material is listed on the Feed/Speed tab: 

 

These material-based settings take priority over any on the global 
Overrides tab. 

 

Tool cutting data example 

This example part has a Side feature with a Depth of 15 mm: 

 

We have the choice of three form tools to cut this Side feature: 

 A 90  insert with a cut depth of 10 mm: 
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 A 45  insert with a cut depth of 6.5 mm: 

 

 A 10  insert with a cut depth of 2 mm: 

 

Each of these tools has a different feed rate associated with it as 
well as a different cut depth. 

For the 90  insert tool with the depth of cut of 10 mm, we created a 

material-based maximum Depth (of cut) override of 8 mm for the 

Rough operation for ALUMINUM: 
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This is the centerline simulation of the 90  tool cutting the rough 

operation of the Side feature, with two toolpath passes: 

 

Viewing the simulation of the toolpath from the front, we can use 

the Vertical Distance  button on the Geometry toolbar to check 
that the 8 mm Depth override has been applied to the rough pass: 

 

For the 45  insert with a cut depth of 6.5 mm, we created a 

tool-specific maximum Depth (of cut) override of 3 mm and a 

Stepover override of 15 mm on the Overrides tab: 

 

These values are used unless you set any material-based overrides 
on the Feed/Speed tab. 
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This is the centerline simulation of the 45  tool cutting the rough 

operation of the Side feature: 

 

Using the same method as before, we can check that the 3 mm 
maximum Depth (of cut) override has been applied: 

 

For the 10  insert with a cut depth of 2 mm, we created two 
material-based overrides on the Feed/Speed tab: 
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For ALUMINUM, we set quite a high Feed rate, and a 1.5 mm 

maximum cut Depth: 

 

For TOOL_STEEL-MOLD_P20, we set a lower cut Depth of 1 mm, a 

lower Feed rate and a lower spindle Speed: 
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Again, we can check that the 1.5 mm maximum Depth (of cut) 

override has been applied to the ALUMINUM stock: 

 

If we change the stock to TOOL_STEEL-MOLD_P20 and run the 

simulation again, we see that the 1 mm maximum cut Depth 

override has been applied: 

 
 

Depth of cut precedence 

The Rough depth of cut is normally calculated as the tool Diameter 

multiplied by the Depth % attribute set on the Stepover tab of 
Machining Attributes. 
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The default Finish behavior is a single pass around the profile of the 
feature, up to the Cutter Length of the tool. This is to avoid leaving a 

mark on the side wall of the feature. 

 

You can override both the Rough and Finish depth of cut in several 
places, from lowest to highest precedence: 
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 Tool level: Depth attribute on the Overrides tab of the Tool 

Properties dialog. 
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 Tool level: Material-specific Depth attribute on the Feed/Speed tab 

of the Tool Properties dialog. 
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 Feature operation level: Rough/Finish pass Z increment on the 

Milling tab of the Feature Properties dialog. 

 

The final depth of cut depends on whether you have selected Equal 

depth of cut on the Misc. tab of the Feature Properties dialog. 
 

2.5D: Total stock for finish pass 
In FeatureCAM 2012, you can set a Total stock attribute for finish 

operations. Set it on the Milling tab for the finish operation: 
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Previously this attribute was available only for rough operations. 
 

2.5D: Toolpath feature improvements 

Quickly create a Toolpath feature from an operation in the Op List 

In FeatureCAM 2012, you can create a Toolpath feature by 
right-clicking on the operation in the Op List tab and selecting the 

new option, Create toolpath feature from the context menu, for 

example: 

 

Add a Dwell value to a toolpath point 

You can now add a dwell value to a toolpath point. To do this, open 
the Toolpath Properties dialog, and select the Toolpaths tab for the 

toolpath operation. Select the toolpath segment where you want to 

add the dwell and click the Edit segment  button. 

The new Dwell option is in the Edit Toolpath Segment dialog: 

 

Enter the Dwell value in seconds. 
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The dwell amount is displayed on the Toolpaths tab, for example: 

 

Add NC code text to a Toolpath feature 

There is a new button on the Toolpaths tab,  Add NC code text: 

 

This button opens the Add NC Code Text dialog: 

 

The Add NC Code Text dialog lets you insert NC code before the 

selected point and optionally add a comment. 

For example, you could enter a M00 conditional stop at a particular 

point in order to check the tool: 
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Click the Apply button, then the OK button, and the NC code and 

comment are added to the Toolpaths tab to the row above the 

selected row, for example: 

 

And after simulation, you can see the code on the NC Code tab, for 

example: 

 

 Your post must support dwell and EDF text to use these new 

features. 

Toolpath feature displayed as lines 

When you create a Toolpath feature and select the Toolpaths tab, 

you can now see the full lines of the toolpath, for example: 
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Previously, toolpath points only were displayed, for example: 

 

Toolpath lines are displayed by default, but you can turn them on 

and off in the context menu of the new Options  button. Select or 
deselect Display lines: 

 

Connection options after deleting toolpath segments 

In FeatureCAM 2012, when you delete toolpath segments, there are 
more options for connecting the remaining segments. The Delete 

Toolpath Segment dialog opens after you click the Delete segment  

button: 

 

Select from: 

 Direct move between the 2 segments (previous behavior) 

 Retract to rapid plane, rapid move to next segment 

 Retract to specified Z value, rapid move to next segment, and enter 

a Z value 

Undo toolpath edits 

You can now use the Undo  button on the Standard toolbar to 

undo edits that you make to a Toolpath feature. For example, if you 
delete some toolpath points, you can click the Undo button to 

restore the points. 
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2.5D: Exact Z step 
Currently FeatureCAM calculates the depth of cut like this: 

1 Divides the feature depth, for example 10 mm, by the depth of 

cut you set to get the number of steps. 

2 Divides the depth by the number of steps to get the actual depth 

of cut (the depth of cut for each step is equal). 

For example: 

If the feature depth is 10 mm and you set a depth of cut of 3 mm, 
the number of steps is calculated as (10/3) + 1 = 4 steps. The 

actual depth of cut is 10 / 4 = 2.5 mm. The steps are cut at 2.5 
mm, 5 mm, 7.5 mm, and 10 mm. 

There is a new option, Equal depth of cut, at feature level: 
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And at machine level: 

 

The new option is selected by default, so that FeatureCAM keeps 
previous behavior. 

To set an exact depth of cut, deselect Equal depth of cut. 

Using the same example, with Equal depth of cut deselected: 

If the feature depth is 10mm and you set a depth of cut of 3mm, 

the number of steps is calculated as (10/3) + 1 = 4 steps. 
FeatureCAM uses the actual depth of cut you set (3 mm) for each 

pass, then cuts any remainder depth. The steps are cut at 3 mm, 6 
mm, 9 mm, and 10 mm. 

These features support exact depth of cut: 

 Profile boss 

 Profile pocket 

 Profile side 

 Profile groove (Face groove 

only) 

 Slot 

 Rectangular pocket 

 Step bore 

 Counter bore hole 

 Plain hole with drill/mill 

roughing 

 Tapped hole with drill/mill 

roughing 

  
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2.5D: Back Bore holes 
In FeatureCAM 2012, you can create a back bore cycle (such as a 

Fanuc G87). The Back Bore hole type lets you machine back bore 

holes using a single Setup. 

 You must use a post processor that supports back bore holes. 

Back Bore Hole is a new hole type available in the Feature wizard: 

 

And on the Dimensions tab of the Feature Properties dialog: 

 

You must enter the Diameter, Depth, Bore Depth, and Bore Diameter 

dimensions for the Back Bore Hole. 
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When you create a Back Bore Hole, a backbore operation is created, 

with a Back Bore cycle on the Cycle tab: 

 

If your post processor supports it, you can select a Drill Cycle type 

and enter Dwell, X Shift, and Y Shift values. 
 

Simulation: Part compare extended 
In FeatureCAM 2012, Part compare is available for many more part 

types. You can now use Part Compare with these modules: 

 4-axis 

 5-axis positioning 

 5-axis simultaneous 

 Turning 

 Turn/mill 

 Wire 

To do a part compare: 

1 Right-click the solid part you want to use for the part compare 
and select Use Solid As Part Compare Target from the context 

menu. 

2 Run a 3D or RapidCut simulation on the part. 

 You can not run a RapidCut simulation on turned, indexed, 

or multiple-fixture parts. 

3 Select View > Simulation > Show Part Compare from the menu. 
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4 Check if there are any areas of your part that are shown in blue, 

these parts have not been cut or are undercut. Areas that have 
been cut correctly are shown in green. 

This example shows a 5-axis part after a 3D simulation: 

 

By using part compare, you can see that a chamfer has been 

missed when programming the part. This is the area shown in blue: 
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3D: Z-level spiral roughing 
There is a new option on the Strategy tab for Z-level roughing, 
Continuous Spiral: 

 

The Continuous Spiral option lets the tool move in a continuous, 

smooth motion, which reduces deceleration and acceleration, keeps 

a more constant chip load, and increases the tool life. 

This blow mold base example shows a single Z-level rough slice: 

 

Using the Offset option: Using the Continuous Spiral 

option: 
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Turn: Solid model as tool holder 
In FeatureCAM 2012 R3, you can set solid models as turning tool 
holder geometry. This gives much more accurate simulation of 

turning feature operations and colision checking, for example: 

 

There is a new option, Solid, on the Holder Drawing tab for turn 

tools. 

To set a solid model as a tool holder: 

1 Import the solid model that represents the tool holder. 

2 Position the solid model (see page 72) so that the point zero is in 

the correct place. 

3 On the Holder Drawing tab in the Tool Properties dialog, select 

Solid, and in the Set section, select the name of the solid holder 

you imported and click the Set selected button. 
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4 The solid holder is displayed in the preview window on the tab 

and you can see the insert position relative to the holder: 

 

The solid model holder is used in simulation. 
 

Solid tool holder example 

Here is an example of a FeatureCAM turning tool holder: 

 

To use a solid model of the tool holder that represents it more 

accurately: 

1 Import the solid model file of the tool holder. Click the Cancel 
button when the Solid Wizard opens. 
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In this example, a *.x_t solid file of the tool holder was imported. 

 

2 Optionally rename the solid in the Part View. 

3 You must now make sure that the imported solid model tool 
holder is positioned correctly. First, find the zero point (mounting 

point) of the solid model holder. You can do this using the 
following method: 

a Select the two faces that point towards the zero point, for 
example: 

 

b Hide everything that is unselected. 

 

c Using Line from two points, create two sketch lines along the 

mounting edge of the faces, for example: 

 

d Hide the two faces to show only the two sketch lines. 
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e Use the Trim/Extend tool to extend the lines until they 

intersect: 

 

f Use the Clip tool to clip the ends of the lines beyond the 

intersection: 

 

You are left with a sketch of the exact zero point to use to 

position the holder correctly. 

 

4 You now need a reference point to move the holder to. You can 

do this using the following method: 

a Select the Holder Drawing tab in the current Tool Properties 

dialog. 

b Select Curve and click the Paste Example button: 
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You can now see the pasted curve and the solid holder in the 

Graphics window: 

 

Turn off shading of the solid to compare them more easily. 

We need to move the zero point of the solid holder  that we 

sketched earlier, to the zero point of the pasted holder curve 

. 

5 Use the Transform tool to do this: 

a Select the solid holder. 

b Select Edit > Transform from the menu. 

The Transform dialog opens. 

c Select Translate and Move and under Distance from 2 points, 

click the From pick location button and select the zero point 

you sketched earlier: 

 

d Click the To pick location button and select the zero point of 

the pasted holder curve: 
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e Click the Preview button to check the new location of the solid 

holder. The preview is shown in blue: 

 

f Click OK to accept the new location. 

6 Turn the solid holder shading back on and you can see the 

position of the tool insert curve relative to the holder: 

 

7 You can now delete the holder curves you pasted earlier. 

8 If you look at the solid holder from the front, there is a recess 
where the insert sits: 

 

9 You must take this recess into account to achieve accurate 
simulation. To do this: 
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a Using the Linear Distance tool, take a measurement of the 

depth of the recess: 

 

In this example, it is approximately 2mm. 

b Select the solid holder. 

c Select Edit > Transform from the menu to open the Transform 

dialog. 

d In the XYZ Distance section, enter 0 for X, -2 for Y, and 0 for Z 

to move the holder down by 2mm in the Y direction. 

e Click OK. 

The solid holder is now in the correct position and ready to set 
as the holder on the tool's Holder Drawing tab. 

10 To set the solid as the holder for the tool: 

a Select the Holder Drawing tab in the Tool Properties dialog. 

b Select Solid, and in the Set section, select the name of the 

solid holder you imported and click the Set selected button. 
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c The solid holder is displayed in the preview window on the tab 

and you can see the insert position relative to the holder: 

 

d Click OK to accept the solid holder. 

The preview on the Tools tab updates too: 

 

e Click OK to continue. 

11 Hide the imported solid and show the part solid. 
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12 Run a 3D simulation. The solid model that you imported is now 

used as the tool holder and the simulation is more accurate: 

 

 

 
 

Turn: Better tool holder graphics 
In FeatureCAM 2012 R3, the graphical representation of tool holders 

is improved. 

The material behind the insert on the tool holder is now shown, for 

example: 

 

In previous versions, this material was not shown, for example: 

 

The new tool holder graphics increase the realism of simulations 
with the default tooling. 
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Turning leave allowance 
In FeatureCAM 2012, you can set X Leave Allowance and Z Leave 

Allowance attributes for a Turn feature finish pass, on the Turning 

tab of the Turn Properties dialog: 

This means you can undercut or overcut a part without having to 
remodel it. This is essential for situations such as fitting allowance. 

X Leave Allowance is the amount of material to leave after the finish 
pass, in the X direction, and Z Leave Allowance is the amount of 

material to leave after the finish pass, in the Z direction. 

The X Leave Allowance and Z Leave Allowance values can be positive 

or negative, but both must have the same sign (both positive or 

both negative). 
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