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PartMaker 2012 contains many new features and enhancements. 
 

Full Machine Simulation in 
PartMaker/Mill 

Simulation enables you to visualize the machining of the part you 
have programmed, so you can identify errors before machining.  

PartMaker/Mill 2012 offers a new Full Machine Simulation (FMS) 
module for you to visualize the following machine tool components 
during simulation: 

 the machine housing; 

 the machine table and its components; and 

 the tool spindle and its components. 

By saving details of the machine simulation to a Machine Data 
(.mchdat) file, you can use the same machine simulation with 
different .job files. 

PartMaker/Mill 2012 also includes a new setup assemblies feature 
(see page 7) that enables you to visualize the stock and any 
fixtures, such as clamps. By using Full Machine Simulation together 
with setup assemblies, you can now visualize the complete machine 
tool in PartMaker/Mill. 

 

Introduction 
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Setting up FMS 
To set up Full Machine Simulation in PartMaker/Mill for an existing 
.job file: 

1 Open a Machine Data (.mchdat) file in PartMaker. 

Select ToolMinder > Machine to display the Machine Data File 
dialog. If a .mchdat file is open, the filename is displayed in the 
title bar of the dialog. If no .mchdat file is open, or you want to 
select a different one, click Open Machine File and then select the 
.mchdat file you want to use. 

2 Details of the .mchdat file are displayed on the Machine Data File 
dialog. You can view, or modify, the following details: 

 The type of machine, including its axis configuration and table 
configuration. These details are displayed in the Milling 
Machine Configuration area of the dialog. 

 The machine table and its motion axes. Click Properties in the 
Table area of the dialog to display the Table Properties dialog. 

 The tool spindle and its motion axes. Click Properties in the 
Tool Spindle area of the dialog to display the Tool Spindle 
Properties dialog. 

 The components comprising the machine housing and their 
motion axes. Click Components to display the Components 
dialog. 

 The tool holders used. Click Holder Data to display the Holder 
Data dialog. 

 If you use solid models to represent parts of the milling 
machine, these models must meet the requirements listed 
in Creating solid models for FMS (see page 4). 

3 Attach any tool holders defined in the Machine Data file to tools 
that are used in the Process Table, so the holders appear during 
simulation. 

To attach tool holders to tools, select Job Optimizer > Tool 
Assembly to display the Tool Assembly dialog. The dialog displays 
a list of the tools used in the Process Table and the name of the 
tool holder to which each tool is attached. To attach a tool holder 
to a tool: 

a Select a tool from the list. 

b Click Select Holder to display the Select Holder dialog and then 
select a tool holder from the list. 

c Click OK to return to the Tool Assembly dialog. 
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d To check if the tool assembly is correct, click the Tool 
Assembly Preview to preview a 3D model of the tool and tool 
holder. 

 See Attaching a tool to a holder for FMS (see page 6) for 
details of how PartMaker attaches the tool to the holder and 
then mounts the holder into the tool spindle for Full 
Machine Simulation in PartMaker/Mill. 

4 Select Simulation > Simulation Options to display the Simulation 
Options dialog, where you can select options to control the 
simulation, for example the types of collisions detected. 

 For more details about any of the dialogs used to set up Full 
Machine Simulation in PartMaker/Mill, refer to the PartMaker 
Reference Help. 

 

Running FMS 
To run Full Machine Simulation in PartMaker/Mill: 

1 Select Simulation > Full Machine Simulation. 

2 Select Simulation > Simulation to display the Simulation window. 
The name of the Machine Data (.mchdat) file you are using is 
displayed in the window's title bar: 

 
3 To display the travel limits of the table and/or tool spindle during 

simulation, select the corresponding menu option(s) from the 
Simulation > Show Travel Limits menu: 

 

4 Click  on the Simulation window toolbar to start the simulation.  
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PartMaker uses the information in the Machine Data (.mchdat) file 
to display a visual representation of the part being machined on 
the milling machine. For example: 

 
 

Creating solid models for FMS 
When creating solid models for Full Machine Simulation in 
PartMaker/Mill, follow these rules: 

Machine Coordinate System 
 The Machine Origin must be at: 

 the zero point of the Top Table model for 5-axis milling tables 
when the table is in its home position. 

 the zero point of the Table model for tombstones, standard 
tables and 4-axis milling tables when the table is in its home 
position. 

 Ensure the Z axis is parallel with the tool axis. 
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Table Model Origin 
The Table Origin must be at: 

 the bottom-left corner of the top of the table for standard tables. 

 the top of the table on the axis of rotation of the tombstone for 
tombstones. 

 the top of the table on the axis of rotation for 4-axis milling 
tables. 

 the top of the table on the primary axis of rotation for 5-axis 
milling tables. 

The table model's axes must align with the Machine Coordinate 
System. 

Tool Spindle 
The Tool Spindle Origin must be coincident with the Holder to Tool 
Spindle Attachment Point. 

The Tool Spindle’s model axes must align with the Machine 
Coordinate System.  

Tool Holders 
You can define holders using a solid model or using a .dxf file: 
 Using a solid model 
 The holder can be in a different orientation to the Machine 

Coordinate System. PartMaker rotates the holder so the 
Holder to Tool Spindle Attachment direction aligns with the 
Tool to Holder Attachment direction.  

 Define all holder data in the Holder Coordinate System. 
 Using a .dxf file 

 Draw the holder in the XY plane in 2D. 

 The origin of the geometry must be at the Tool to Holder 
Attachment Point. 

 The axis of the holder must be along the Y axis. 

 The .dxf file units must match the, job file's Input Units (as 
specified on the Preferences dialog). 

Components 
Each component model's axes must align with the Machine 
Coordinate System. 
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Attaching a tool to a holder for FMS 
When using Full Machine Simulation in PartMaker/Mill, PartMaker 
mounts the tool to the holder and then mounts the holder into the 
tool spindle as follows: 

 If you use solid models to represent parts of the milling 
machine, the models must meet the requirements listed in 
Creating solid models for FMS in PartMaker/Mill (see page 4). 

1 The Holder is rotated so the Tool to Holder Attachment vector is 
along the negative Z axis: 

 
2 The Holder to Tool Spindle Attachment Point is positioned to the 

Tool Spindle's origin, then the Tool is positioned to the Tool to 
Holder Attachment Point: 
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3 The final result is shown below: 

 
 

Using setup assemblies in 
PartMaker/Mill 

In PartMaker/Mill 2012 you can now view setup assemblies in the 
Solids window. 

A setup assembly is a solid model file that can contain 3D 
representations of the stock, milling table and other machine 
fixtures, such as clamps. Using a setup assembly, you can view how 
the part appears on the milling table, with any fixtures attached, 
while you are programming and verifying toolpaths. You can also 
view the setup assembly during simulation. 

By using setup assemblies together with the new Full Machine 
Simulation module (see page 1), you can now visualize the 
complete machine tool during simulation. 

 To avoid confusion between setup assemblies and solid model 
files that contain an assembly of parts or surfaces, some 
menu options have been renamed in PartMaker 2012, as 
described in General improvements (see page 44). 

 

Using a solid part model and a setup assembly 
To use both a solid model of a part and a setup assembly when 
programming in PartMaker/Mill: 

1 Select File > New Job to create a new .job file. 

2 In the Setup dialog, select the type of table used on the machine 
from the Table drop-down list, and then complete the dialog. 
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3 Select ToolMinder > Setup Assembly > Import Setup Assembly, and 
select the file containing the setup assembly for this .job file. 
PartMaker imports the setup assembly (see page 12) into the 
Solids window in Setup Assembly mode. 

 Using the Solids > Utilities > Paste from PowerSHAPE option, 
you can paste solids from PowerSHAPE into PartMaker's 
Solids window to create a setup assembly. 

 The solid models you use to represent the setup assembly 
must meet the requirements listed in Creating solid models 
for setup assemblies (see page 9). 

4 Select ToolMinder > Setup Assembly > Component Properties to 
display the Component Properties dialog (see page 14). Use this 
dialog to identify each component in the setup assembly and 
specify how it appears in the Solids window. 

5 Select File > Import and select the file that contains the part 
model you want to use in the .job file. PartMaker imports the part 
model into the Solids window in Part mode. 

6 Program all the hole, profile and/or surface groups required to 
machine the part and verify the toolpaths.  

 Remember to switch between Part mode and Setup 
Assembly mode (see page 15), depending on what you 
want to see when programming and verifying the part. 

7 Repeat Steps 2–6 for any other Face windows you want to 
create. 

8 Select Job Optimizer > Generate Process Table to generate the 
Process Table containing all the processes needed to machine the 
part. 

9 Select Simulation > Simulation Options to display the Simulation 
Options dialog and select the Use Setup Assembly option to view 
the setup assembly during simulation. 

10 Select Simulation > Simulation to display the Simulation window, 
then select Simulation > Start Simulation to run the simulation 
(see page 17). 
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Creating solid models for setup assemblies 
When creating solid models for use in setup assemblies, follow 
these rules for setting up the setup assembly origin and coordinate 
axes: 

Standard Table 
With a standard table, set: 

 the origin at bottom left corner of the top of the table; and 

 the Z axis perpendicular to the table, directed outwards from the 
top face of the table. 

For example: 
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Tombstone 
With a Tombstone, set: 

 the origin on top of the table on the tombstone's axis of rotation; 
and 

 the Y axis parallel to the tombstone's axis of rotation of the 
tombstone, directed outwards from the top face of the table. 

For example: 
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4-Axis Table 
With a 4-Axis Table, set: 

 the origin on top of the table, on the table's axis of rotation; and 

 X axis parallel to the table's axis of rotation, directed outwards 
from the top face of the table. 

For example: 
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5-Axis Table 
With a 5-Axis Table, set: 

 the origin on top of the table, on the table's axis of rotation; and 

 the Z axis parallel to the table's axis of rotation, directed 
outwards from the top face of the table. 

For example: 

 
 

Importing a setup assembly 
To import a setup assembly into PartMaker/Mill: 

1 Select ToolMinder > Setup Assembly > Import Setup Assembly, then 
select the menu option for the type of file you want to import. 
You can import the following file types: 

 X_T Parasolid Transmit file. 

 X_B Parasolid Transmit Binary file. 

 SLDPRT SolidWorks Part file. 

 IPT AutoDesk Inventor Part file. 

 PRO/E file. 

 STEP file. 



 

PartMaker 2012 What's New Introduction • 13  

2 In the Import dialog, select the folder and filename of the file 
containing the setup assembly and click Open. 

PartMaker imports the file into the Solids window, for example: 

 
When you have imported a setup assembly, PartMaker saves it 
together with the .job file. 

 Using the Solids > Utilities > Paste from PowerSHAPE option, 
you can paste solids from PowerSHAPE into PartMaker's Solids 
window to create a setup assembly. 

 The solid models you use to represent the setup assembly 
must meet the requirements listed in Creating solid models 
for setup assemblies (see page 9). 
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Identifying the components in a setup assembly 
Use the Components Properties dialog to identify the different types 
of components (stock, table or fixture) in a setup assembly and 
specify how each component appears in the Solids window: 

 
1 To display the Component Properties dialog: 

 Select ToolMinder > Setup Assembly > Component Properties; or 

 Double-click a component in the Solids window when in Setup 
Assembly mode. 

2 Select the component you want to work with from the List of 
Components. If you double-clicked a component in the Solids 
window to display this dialog, PartMaker automatically selects 
this component in the list. 

3 PartMaker gives default names to the components in the setup 
assembly. To use a different name, enter a new name in the 
Name field. 

4 You can specify the following settings for the selected 
component: 

Type. Specify whether the component represents a Fixture, Stock 
or Table.  

Use Stock for Face. For Stock components, click this button to 
display the Use Stock For Face dialog, where you can select the 
Face window that uses this stock component.  
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Component Properties. These options control how the component 
appears in the Solids window: 

 Color. Click to display the Color dialog, where you can select 
the color of the component. 

 Transparency. Specify the transparency for the component. 
0% displays a solid component. 100% displays a fully 
transparent (invisible) component. 

 Visible. Select this option to display the component in the 
Solids window. 

5 Click Close to apply any changes and close the dialog. 

 Use the Save Component As button to save the selected 
component to a separate X_T Parasolid Transmit file, so you 
can use it with other setup assemblies. 

 

Switching modes in the Solids window 
In PartMaker 2012, the Solids window has separate modes for 
working with the part model and the setup assembly. To switch 
between modes: 

 Select Solids > Set View > Part Mode or click  on the Solids 
Window toolbar to view, and work with, the part model. 
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 Select Solids > Set View > Setup Assembly Mode or click  on the 
Solids Window toolbar to view, and work with, the setup 
assembly model. 

 
 

Viewing the setup assembly with toolpaths 
When you have imported a setup assembly into the Solids window, 
you can program and verify toolpaths while visualizing the part on 
the machine table with any fixtures attached. For example: 
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Viewing a setup assembly during simulation 
To display a setup assembly during simulation: 

1 Select Simulation > Simulation Options to display the Simulation 
Options dialog. 

2 Select the Use Setup Assembly option. 

3 Click OK to close the dialog. 

PartMaker displays the setup assembly during simulation, for 
example: 

 
 

Working with Solids 
PartMaker 2012 includes the following enhancements for working 
with solids: 

 Ability to view a 3D stock model in the Solids window (see 
page 18). 

 Enhanced copy and paste in the Solids window (see page 20). 

 View the rules for a model's Part Coordinate System (see 
page 21). 
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 When importing and exporting solids, PartMaker 2012 is now 
compatible with: 

 SolidWorks 2012 

 Parasolid v24.0 

PartMaker/Mill 2012 also enables you to display setup assemblies in 
the Solids window (see page 7). 

 

Displaying stock models in the Solids window 
In previous releases of PartMaker you could import a solid model of 
a part into the Solids window to see a 3D view of the toolpaths 
needed to machine the part. 

In PartMaker 2012 you can now display a stock model in the Solids 
window. This enables you to view toolpaths in 3D, without needing 
a solid model of the part. 

 Displaying stock models in the Solids window requires the 
Solid Modeling Input cost option. 

For more information, see: 

 Displaying toolpaths on a stock model (see page 18). 

 Working with a stock model in the Solids window (see page 19). 
 

Displaying toolpaths on a stock model 
To display toolpaths on a stock model in the Solids window: 

1 Open a .job file that contains toolpaths. The Face window 
displays a 2D representation of the toolpaths. 

2 Select Window > Solid Model to open a Solids window. 

3 Click  on the Solids Window toolbar and select the Show Stock 
option to display the stock in the Solids window. 
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4 Click  and select the Show Profiles and Holes on Solid Model 
option to display the toolpaths on the stock: 

 

 You can also verify toolpaths on a stock model if you enable 
toolpath verification on solid models using the Tool Path 
Verification Options dialog. 

 

Working with stock in the Solids window 
To work with stock models in the Solids window, use the buttons on 
the Solids Window toolbar or the options in the Solids menu. For 
example: 

 To change the appearance, or view, of the stock model, click  
on the Solids Window toolbar and select a different option from 
the menu: 
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 To define the face plane for the current Face window using the 
stock model: 

a Click on the stock model to select a plane. 

b Select Solids > Face Coordinate System > Define Face Plane to 
display the Define Face Plane dialog. 

c Complete the Define Face Plane dialog and click OK. 
 

Copy and paste in the Solids window 
The copy and paste functions in PartMaker have been extended to 
improve PartMaker's ability to work with other Delcam products.  

In PartMaker/Mill, for example, you can now paste solids directly 
from PowerSHAPE into the PartMaker Solids window to create a 
setup assembly (see page 7). 

To use copy and paste in the Solids window, click the Utilities 
button on the Solids Window toolbar or select Solids > Utilities to 
display the following options: 

 Select All Surfaces. Selects all of the surfaces in the solid model 
displayed in the PartMaker Solids window. 

 Copy to PowerSHAPE. Copies the selected surfaces or solids from 
the Solids window to the clipboard, ready for you to paste to 
your intended location. 

 Paste from PowerSHAPE. Pastes the selected surfaces or solids 
from the clipboard into the PartMaker Solids window. 

The following table describes where you can copy and paste solids 
or selected surfaces: 
Solids window mode Selection Copy/paste to 
Part mode Solids  PowerSHAPE 

 PowerMILL 
 Solids window - Setup 

Assembly mode 
(PartMaker/Mill only) 

Part mode Selected 
surfaces 

 PowerSHAPE 
 PowerMILL 

Setup Assembly 
mode (PartMaker/Mill 
only) 

Solids  PowerSHAPE 
 PowerMILL 
 Solids window - Part mode 

 
 



 

PartMaker 2012 What's New Introduction • 21  

Viewing PCS rules 
A Part Coordinate System (PCS) is the coordinate system in which a 
solid model is oriented. The rules for setting the PCS for a solid 
model depend on the type of stock and/or table you are using. 

In PartMaker 2012 you can display these rules while using the Edit 
Part Coordinate System dialog: 

1 Ensure the part model appears in the Solids window. 

2 Select Solids > Edit Part Coordinate System. PartMaker displays 
the Edit Part Coordinate System dialog. 

3 Click Part Coordinate System Rules to display the PartMaker 
Coordinate System Rules dialog. For example, when using Block 
stock on a Standard table in PartMaker/Mill, the following rules 
apply: 

 
4 Click Close to close the PartMaker Coordinate System Rules dialog. 

5 Use the options on the Edit Part Coordinate System dialog to set 
the coordinate system according to the rules.  

6 Click Close to close the Edit Part Coordinate System dialog. 
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Simulation 
Simulation enables you to visualize the machining of the part you 
have programmed, so you can identify errors before machining.  

PartMaker 2012 includes several enhancements to simulation: 

 Ability to display rotary attachments in PartMaker/SwissCAM (see 
page 22). 

 Enhanced collision checking in PartMaker/Mill (see page 24). 

 New way of displaying the machine housing during simulation 
(see page 24). 

 Improvements to the Components dialog (see page 24).  

 New way of specifying how sub-spindles and turrets rotate (see 
page 25). 

 Ability to display a sub-spindle attached to a tool head in 
simulation (see page 27). 

A new Full Machine Simulation module is also available in 
PartMaker/Mill (see page 1). 

 

Displaying rotary attachments in PartMaker/SwissCAM 
Some Swiss machines use rotary attachments to allow 5-axis 
simultaneous cutting and 3+2-axis cutting. In PartMaker/SwissCAM 
2012, you can now specify details of rotary attachments on a gang 
tool post for use in Full Machine Simulation. 

To specify details of a rotary attachment: 

1 Select the B option on the Machine Data File dialog to specify that 
the gang tool post using the rotary attachment can rotate around 
the B-axis. 

 
2 Click the Properties button to display the Tool Post Properties 

dialog for the gang. 
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3 On the Tool Post Properties dialog, click the Rotary Attachment 
button to display the Rotary Attachment dialog and specify details 
about the attachment: 

 
 Model Data. Click this button to display the Model Data dialog, 

where you can select a solid model to represent the rotary 
attachment during simulation. 

 Rotation Center (C). Enter values in the Cx, Cy, and Cz fields to 
specify the point about which the attachment rotates. 

 The model's origin must coincide with this point. 

 Rotary Axis. Select the axis around which the attachment 
rotates. 

4 Click OK to return to the Tool Post Properties dialog. 

5 On the Tool Post Properties dialog, click the Tool Post Layout 
button to display the Tool Post Layout dialog: 

a Select On Rotary Attachment to specify that the selected tool 
number is located on a rotary attachment.  

 
b Click OK to return to the Tool Post Properties dialog. 

6 When you have specified the tool post, click OK to return to the 
Machine Data File dialog. 
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Enhanced collision checking in PartMaker/Mill 
In PartMaker/Mill, a Stock Extension field has been added to the 4-
Axis Rotary Table Settings and 5-Axis Rotary Table Settings dialogs for 
specifying the length of stock section that protrudes from the chuck, 
or another fixture, on the machine. PartMaker uses this value for 
collision checking during simulation. 

 
 

Displaying the machine housing 
In PartMaker 2012 you can show or hide the machine housing 
during Full Machine Simulation by using: 

 the Simulation > Set View > Show Machine Housing menu option; 
or  

 the Show Machine Housing button on the Simulation Window 
toolbar: 

 

 The Show Machine Housing option on the Simulation Options 
dialog, which controlled the display of the machine housing in 
earlier versions of PartMaker, is no longer required and has 
been removed. 

 

Using the Components dialog 
The Components dialog specifies the machine-housing or machine-
part components displayed during Full Machine Simulation. 

PartMaker 2012 contains several improvements to this dialog: 

 A new layout for specifying the position of a component's solid 
model (see page 25). 

 New Rotation Axes options for turret and sub-spindle components 
(see page 25). 
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Specifying a solid model's position 
PartMaker 2012 uses a new layout in the Components dialog for 
specifying the origin of a component's solid model: 

 
Motion Axes. Select a check box (X, Y, or Z) if the component can 
move in that axis. 

Model Origin Coordinates. These specify the origin of the solid model 
for that component. PartMaker uses these values to position the 
component correctly during simulation. The values you specify 
depend on the component's motion axes: 

  The coordinate for a moving axis (Z) is relative to the 
machine part (in this example, Turret #1) origin, as denoted by 

. 

  The coordinate for a stationary axis (Y) is relative to the 
machine origin, as denoted by . 

 

Specifying how sub-spindles and turrets rotate 
PartMaker 2012 provides an easier, and more flexible, way of 
specifying how a sub-spindle or turret rotates for Full Machine 
Simulation in PartMaker/SwissCAM and PartMaker/Turn-Mill. For 
more details, see: 

 Specifying how a sub-spindle rotates (see page 26). 

 Specifying how a turret rotates (see page 27). 
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Specifying how a sub-spindle rotates 
To specify how a sub-spindle rotates for simulation: 

1 Select ToolMinder > Machine to display the Machine Data dialog. 
The dialog displays details of the current Machine Data (.mch) 
file. 

2 In the Sub-Spindle area of the dialog, select R to specify that the 
sub-spindle rotates. 

3 Click the Rotation Options button to display the Sub-Spindle 
Rotation Options dialog. In this dialog, specify: 

 Rotation Axis (R). This is the axis about which the sub-spindle 
rotates. This can be an axis that is parallel to the Y-axis or an 
axis inclined at 45 degrees in the ZX plane. 

 Rotation Center (C). This is the pivot point about which the 
sub-spindle rotates. PartMaker can calculate this automatically 
or you can specify that the point is the model origin of the 
first component (Component #1) attached to the sub-spindle. 

4 Click OK to close the Sub-Spindle Rotation Options dialog. 

5 To specify how components attached to the sub-spindle rotate, 
click the Properties button in the Sub-Spindle area of the Machine 
Data File dialog to display the Sub-Spindle Properties dialog. 

6 Click the Components button in the Sub-Spindle Properties dialog 
to display the Components dialog. 

7 Specify which components on the sub-spindle rotate by selecting 
R in the Rotation Axes area of the dialog: 

 

 The R option is available in the Components dialog only if 
the R option is selected as the rotation axis for the sub-
spindle in the Machine Data dialog.  

8 Click OK to close the dialogs. 
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Specifying how a turret rotates 
To specify how a turret rotates for simulation: 

1 Select ToolMinder > Machine to display the Machine Data dialog. 
The dialog displays details of the current Machine Data (.mch) 
file. 

2 In the Tool Posts area of the dialog, select B to specify that the 
turret can rotate about the B axis. 

3 Click the Properties button alongside the turret to display the Tool 
Post Properties dialog. 

4 Select XY Plane from the Turret Plane drop-down list, and then 
click the Component buttons in the Definition area of the dialog to 
display the Components dialog. 

5 Specify which components rotate by selecting B in the Rotation 
Axes area of the dialog: 

 

 The B rotation axis is available in the Components dialog 
only if the B motion axis option is selected for the turret in 
the Machine Data dialog and the XY Plane is specified as the 
turret plane in the Tool Post Properties, Turret dialog. 

6 Click OK to close the dialogs. 
 

Displaying a sub-spindle attached to a tool head 
If you are using a Bar-Fed Mill machine where the sub-spindle 
attaches directly to the tool head, you can now display this during 
simulation: 

1 On the Machine Data dialog, click Properties in the Sub-Spindle 
area of the dialog. PartMaker displays the Sub-Spindle Properties 
dialog. 

2 Select Tool Head Collet from the Work Holding drop-down list: 
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3 Click OK to close the dialog and return to the Machine Data 
dialog. 

 Setting up this type of machine architecture for programming 
a part is described in Specifying that the sub-spindle attaches 
to the tool head (see page 28). 

 

Bar-Fed Mill machines 
PartMaker/Turn-Mill 2012 now supports programming for Bar-Fed 
Mill (BFM) machines where: 

 the sub-spindle attaches to the tool head (see page 28); or 

 the sub-spindle work-holding device rotates to an orientation 
other than 0 or 90 degrees (see page 29). 

 

Specifying that the sub-spindle attaches to the tool 
head 

To specify that you are using a machine where the sub-spindle 
attaches to the tool head: 

1 Select Main Spindle on the Setup dialog, then click Settings to 
display the Spindle Settings dialog. 

2 Select Tool Head Collet as sub-spindle work holding in the Sub-
Spindle area of the dialog. 

 
3 Complete the Spindle Settings dialog, then click OK to return to 

the Setup dialog. 
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4 On the Setup dialog, select Sub-Spindle, then click the Machining 
Position icon to display the Sub-Spindle Machining Position dialog: 

 
5 To specify the machining position of the Tool Head Collet: 

a Select the orientation angle during machining from the Sub-
Spindle Orientation Angle drop-down list. 

b Enter the distance between the face of the main spindle and 
the face of the sub-spindle in the Machining Distance field. 

 Displaying this type of machine architecture in Full Machine 
Simulation is described in Displaying a sub-spindle attached 
to a tool head (see page 27). 

 

Specifying the work holding's orientation angle 
To specify that you are using a machine where the sub-spindle 
work-holding device rotates to an orientation other than 0 or 90 
degrees: 

1 Click the Machining Position icon (for example, ) in the Setup 
dialog for a sub-spindle Face window. PartMaker displays the 
Sub-Spindle Machining Position dialog. 

 This dialog is available only when Bar-Fed Mill is selected as 
the Machine Type in the Spindle Settings dialog in 
PartMaker/Turn-Mill. 
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2 Click the Sub-Spindle Orientation Angle drop-down list to display 
the available orientation angles for the selected work-holding 
device, and select the angle appropriate for your machine: 

 
3 Click OK to close the Sub-Spindle Machining Position dialog. 

PartMaker reflects the orientation angle you select on: 

 the Machining Position icon  in the Setup dialog; and  

 the Set Mode icon  in the Process Table for any 
processes programmed in the sub-spindle Face window. 

 Setting up rotating components for use in Full Machine 
simulation is described in Setting up rotating components 
(see page 25). 

 

Editing the Process Table 
The Process Table lists the processes required to machine a part.  

By default, PartMaker orders the processes in the Process Table 
according to the sequence in which you programmed the part. It 
starts by creating processes for all the part features in the first Face 
window you created, before moving onto the next Face window you 
created and so on. You can re-order the processes in the table if the 
default order does not reflect the machining sequence you want. 

PartMaker 2012 includes several enhancements to make it easier, 
and quicker, to re-order processes in the table: 

 Ability to select multiple processes (see page 31). 

 Improved appearance of selected and excluded processes (see 
page 31). 

 Ability to drag and drop processes (see page 32). 
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Selecting multiple processes 
In previous versions of PartMaker, you could select only one process 
at a time in the Process Table. PartMaker 2012 allows you to select 
multiple processes as follows: 
Selection type Mouse/keyboard action 
Selecting a group of 
consecutive processes. 

Click the first process in the group, 
hold down the Shift key and then click 
the last process in the group. 

Selecting non-consecutive 
processes. 

Hold down the Ctrl key, and then click 
each process you want to select. 

Selecting all processes. Ctrl+A. 

 
 

Appearance of processes 
PartMaker 2012 improves the appearance of selected and excluded 
processes as follows: 

 Selected processes are highlighted using a solid highlight color. 

 Processes that are excluded from simulation and post processing 
are now shown using a strikethrough line. 

The following example shows a Process Table with various selected 
and/or excluded processes: 
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Dragging and dropping processes 
In PartMaker 2012 you can now drag and drop processes to a new 
location in the Process Table: 

1 Click to select the process(es) you want to move, for example: 

 
2 Holding down the left mouse button, drag the selected 

process(es) to the new location. An arrow cursor indicates the 
new location, for example: 

 
3 Release the left mouse button to move the process(es) to the 

new location: 

 

 Use Ctrl+Z if you drop process(es) in the wrong location and 
want to undo this action.  
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Setup sheets 
Setup sheets provide specific instructions for the machine operators 
who run NC programs created in PartMaker. 

PartMaker 2012 includes several enhancements to setup sheets: 

 You can now use an Excel template to generate setup sheets 
(see page 33). 

 Four new setup sheet parameters are available: 
 {cut-off-sub-grip-z} 

 {sub-support-z} 

 {tool-second-offset} 

 {work-offset} 

 The PartMaker Reference Help now includes descriptions of the 
setup sheet parameters. 

 

Generating a setup sheet using an Excel template 
To generate a setup sheet using an Excel template: 

1 After generating the Process Table for your part, select File > 
Setup Sheets > Generate Setup Sheet to display the Generate Setup 
Sheet dialog. 

2 Click the Setup Sheet Viewer button to display the Setup Sheet 
Viewer dialog. In the Path field, enter the location where 
Microsoft Excel is installed on your computer: 

 

 If you do not specify a location, PartMaker uses Window's 
default spreadsheet program. 

3 Click OK to return to the Generate Setup Sheet dialog and select 
Excel to display the Excel templates available: 

 
4 To add job parameters or graphics to the setup sheet, use the 

Optional Job Parameters and Logos and Pictures buttons. 
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5 Click Generate to display the Save Setup Sheet File dialog. 

6 Specify a name and location for the setup sheet, then click Save. 
PartMaker generates the setup sheet and displays it in Microsoft 
Excel: 

 
 

Surface Machining Wizard (SMW) 
The Surface Machining Wizard (SMW) uses machining strategies to 
create toolpaths for milling free-shape surfaces. 

In PartMaker 2012 there is a new Radial Projection strategy for use 
in a Mill Cylinder Face window. This strategy enables you to perform 
3D surface machining for cylindrical interpolation and so create 
complex part features when using: 

 4-axis and 5-axis milling machines (PartMaker/Mill),  

 Turn-Mill Centers (PartMaker/Turn-Mill); and  

 Swiss-type lathes (PartMaker/SwissCAM). 
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To use this machining strategy: 

1 In a Mill Cylinder Face window, click  on the Face Window 
toolbar to create a surface group. 

PartMaker displays the Surface Group Parameters dialog with the 
Radial Projection strategy selected: 

 
2 In the Surface Group Parameters dialog, click Select Tools to 

select the tool you want to use for the operation and use the 
options in the Surface Selection area of the dialog to specify how 
to select the surfaces for this group. 

3 To view, or modify, the settings for the Radial Projection strategy, 
click the Options button to display the Surface Machining Options 
dialog. 

4 In the Face window, define a 2D profile (for example, by using 
the Define Profile icon). PartMaker projects the profile radially 
along the tool axis: 
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Tapered thread milling 
PartMaker 2012 includes a new Thread Mill Options dialog that 
enables you to: 

 Set the angle at which the thread starts; and 

 Specify a taper angle to machine a tapered thread. 

 The Thread Mill cycle is available in the Mill XY Plane, Mill 5 
Axis Plane, Mill ZY Plane and Mill End, Polar Face windows. 

When a Thread Mill cycle is selected in the Profile Group Parameters 
dialog or the Hole Group Parameters dialog, click the Thread Mill 
Options button to display the Thread Mill Options dialog. 

 
The following options are available: 

Thread Start. By default, PartMaker uses a start angle of 180 degrees 
for the thread. However, you can specify a different angle if you 
wish: 

Start Angle. You can specify the start angle in either of the 
following ways: 

 Select the quadrant angle (0, 90, 180 or 270) where you want 
the thread mill toolpath to lead in. 

 Select the Defined by Entry Angle option to define the Start 
Angle using the angle you specify in the Entry Angle field. 
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Entry Angle. Enter the angle you want to use. When you specify 
an Entry Angle, the thread crosses the Z_Surf (as specified on the 
Profile Group Parameters or the Hole Group Parameters dialog) at 
this angle. The Entry Angle does not specify where the toolpath 
leads in. 

Tapered Thread. A tapered thread toolpath increases in diameter at a 
specified angle: 

Tapered Thread. Select this option to use a tapered thread. 

Taper Angle (A). Enter the angle at which PartMaker applies the 
taper. 

 If you want the toolpaths in a Face window to use lines 
instead of arcs, use the Arc Output Options on the Face 
Options dialog. For Thread Mill toolpaths, PartMaker uses the 
Roughing Tolerance value to determine the length of lines in 
the toolpath. 

You can see the results of the thread milling options during 
simulation. The following example shows a thread tapered using a 
Taper Angle of 3 degrees: 

 
 

Defining Approach and Escape points 
Approach and escape points define the location of the tool at the 
start and end of a toolpath. 

PartMaker 2012 provides a new way of defining approach and 
escape points, so you can now select points interactively in the CAM 
Face window. Snap modes are also available to ensure that your 
selection 'snaps' to the correct location (for example, you may want 
your selection to snap to a grid location). 

 The method of defining approach and escape points by 
specifying coordinate values is still available if you wish to 
continue using it. 
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To define an approach or escape point interactively: 

1 In the CAM Face window, select the profile for which you want to 
define an approach and/or escape point. 

2 Click on the Face window toolbar to display the 
Approach/Escape dialog. 

3 Select Approach Point (A). This example describes how to define 
an approach point, but the same process is used to define escape 
points. 

PartMaker displays: 

 The current location of the approach point in the Face window 
(see ). 

 A cross-hair cursor that you can drag  to define a new location 
for the approach point (see ). 

 The Snap Modes toolbar so you can select a snap mode to 
position the cross-hair cursor (see ). 
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4 When the cross-hair cursor is positioned at the location for the 
approach point, click the left mouse button. PartMaker updates 
the display in the CAM Face window and updates the coordinate 
values displayed on the Approach/Escape dialog to reflect your 
selection: 

 
5 Click Close to save your changes and close the dialog. 

 

Installation 
PartMaker 2012 includes several enhancements to the PartMaker 
installation: 

 PartMaker 2012 is available in 32-bit and 64-bit versions. You 
can choose which version to use during the installation process. 

 The 64-bit version of PartMaker is supported only if you are 
using the Windows 7 operating system. 

 You no longer need to select a Workstation or a Network 
installation of PartMaker. PartMaker uses the same installation, 
but uses PAF licensing protection for a single PC and RMS 
licensing protection on a network. 

 When using RMS licensing protection, there is a new way of 
sharing licenses between PCs (see page 40). 
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Network licensing 
PartMaker 2012 includes a new way of managing licenses for 
PartMaker installations that use RMS licensing protection. For more 
details, see: 

Licensing multiple sessions of PartMaker (see page 40). 

Sharing licensed modules (see page 41). 

 To check if your PartMaker installation uses RMS licensing 
protection, select Help > License Info to display the License Info 
dialog. The type of licensing protection (RMS or PAF) is 
displayed in the Security area of the dialog. 

 

Licensing multiple sessions of PartMaker 
Each PartMaker license enables you to run two sessions of a 
PartMaker application on a computer. 

For example, if there are three PartMaker/SwissCAM licenses 
available and you run multiple sessions of PartMaker on a computer, 
the licenses are allocated as follows: 

1 SwissCAM session uses 1 license 
2 SwissCAM sessions use 1 license 
3 SwissCAM sessions use 2 licenses 
4 SwissCAM sessions use 2 licenses 
5 SwissCAM sessions use 3 licenses 
6 SwissCAM sessions use 3 licenses. 
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Sharing licensed modules 
RMS licensing also uses licensed modules that can be shared 
between different users on a network. By sharing licensed modules 
across the network, you can make full use of your PartMaker 
licenses. The following example shows how PartMaker/Mill licensed 
modules could be shared between users on a network: 

 
By default, PartMaker automatically allocates all of the licensed 
modules available for a product when the user starts that product 
on a client PC. However, you can share the licensed modules across 
the network using the following menu options: 

Help > Release Licenses (see page 42). 

Help > Request Licenses (see page 43). 
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Release Licenses 
Use this menu option to release one or more licensed modules so 
they are available to other PartMaker users on the network.  

 This option is available only at the start of a PartMaker 
session in PartMaker installations that use RMS security 
protection. 

When you start a PartMaker product on a client PC, PartMaker 
automatically allocates all available licensed modules for that 
product to your PartMaker session. To release a licensed module, 
select Help > Release Licenses and then select the licensed module 
you want to release from the submenu. For example: 

 
PartMaker automatically releases any licensed modules allocated to 
your PartMaker session when you close PartMaker. 

 The options available in the Help > Release Licenses submenu 
vary depending on which product you are using and the 
modules your company has licensed. 
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Request Licenses 
Use this menu option to request a licensed module, so you can use 
the features available in that module in your PartMaker session.  

 This option is available only at the start of a PartMaker 
session in PartMaker installations that use RMS security 
protection. 

When you start a PartMaker product on a client PC, PartMaker 
automatically allocates all available licensed modules for that 
product to your PartMaker session. However, if you need a licensed 
module that is being used by another user on the network, that user 
can release the licensed module (see page 42) and you can then 
request it for your PartMaker session.  

To request a licensed module, select Help > Request Licenses and 
then select the licensed module you want from the submenu. For 
example: 

 
PartMaker automatically releases any licensed modules allocated to 
your PartMaker session when you close PartMaker. 

 The options available in the Help > Request Licenses submenu 
vary depending on which product you are using and the 
modules your company has licensed. 
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General improvements 
PartMaker 2012 contains the following general improvements: 

 On the Defaults for Milling dialog, you can now define a default 
Width of Cut value if you choose to specify this value as a 
percentage of the tool diameter: 

 
PartMaker uses the value you specify as the default Width of Cut 
value on the Profile Group Parameters dialog when you create 
profile groups for pockets, contours and face milling: 

 
 The following menu options have been renamed to avoid 

confusion between the new setup assemblies feature in 
PartMaker/Mill 2012 and the functionality for working with solids 
models that contain an assembly of parts or surfaces: 

 Extract Part From Assembly renamed to Extract Part From  
Model. 

 Restore Assembly renamed to Restore Model. 
 In PartMaker/SwissCAM and PartMaker/Turn-Mill, the Set Modes 

dialog includes a new Sub-Spindle Z Distance From Home field to 
specify the machining position of a sub-spindle relative to its 
home position. This field is available for the M0S1, M1S1, M0S2, 
M1S2, or M2S1 synchronization modes for processes 
programmed on the sub-spindle. 

 

 The field is available only if the post processor uses the 
<sub-spindle-distance> reserved word (see page 45). 

 PartMaker 2012 can import PowerMILL project files created in 
PowerMILL 2012 when using the File > PowerMILL Interface > 
Import PowerMILL Project option. 
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ConfigPost enhancements 
PartMaker uses Post files to convert processes in the Process Table 
into NC program code. Using ConfigPost you can create and save 
custom Post files. 

In ConfigPost 2012, the <sub-spindle-distance> reserved word 
has been enhanced to support the new Sub-Spindle Z Distance From 
Home field on the Set Modes dialog in PartMaker/SwissCAM and 
PartMaker/Turn-Mill. You can use this field to specify the machining 
position of a sub-spindle relative to its home position (see page 44). 
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