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Important User Notices 

Copyright  1991-2013 Delcam plc. All rights reserved. 

Delcam plc has no control over the use made of the software 
described in this manual and cannot accept responsibility for any 

loss or damage howsoever caused as a result of using the software. 
Users are advised that all the results from the software should be 

checked by a competent person, in accordance with good quality 
control procedures. 

The functionality and user interface in this manual is subject to 
change without notice in future revisions of software.  

The software described in this manual is furnished under licence 
agreement and may be used or copied solely in accordance with the 

terms of such licence. 

Delcam plc grants permission for licensed users to print copies of 
this manual or portions of this manual for personal use only. 

Schools, colleges and universities that are licensed to use the 
software may make copies of this manual or portions of this manual 

for students currently registered for classes where the software is 
used. 
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PartMaker is the world's leading CAM system for automating the 

programming of production machining on CNC milling machines, 
lathes, Wire EDMs, Turn-Mill centers and Swiss-type lathes. 

PartMaker automates the tedious task of manual part programming 
by providing an easy-to-use graphical interface and powerful tools 

and features. 

With PartMaker you can quickly define part geometry, cycle, tool, 

and material information, and all other parameters associated with 
machining a part. What's more, you can also save frequently used 

tool, cycle, and material information in a database to recall and 
reuse at any time. 

Acquired by Delcam plc in 2006, PartMaker Inc. is a wholly owned 

subsidiary of Delcam plc, the world’s leading developer and supplier 
of complete CAD/CAM software solutions. 

About this guide 

Use this guide to find out about: 

 Installing PartMaker (see page 2). 

 What's new in PartMaker 2014 (see page 7). 

 Accessing help and support (see page 44). 

 

Introduction 
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To install PartMaker on a stand-alone PC: 

1 Before installing PartMaker, make sure you meet the system 
requirements (see page 3). 

2 Install PartMaker (see page 3). 

3 Install your license file (PAF) (see page 5). 

 If you use post processors for PartMaker/SwissCAM or 
PartMaker/Turn-Mill, you need to install the post processors 
you require (using the Help > Download Licensed Post Config 

Files menu option) before starting to use PartMaker. 

If you need further details about the installation process, or you are 

installing PartMaker for use on a network, refer to the Installation 

Guide on your PartMaker Documentation CD for more information. 

 

Installing PartMaker 
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System requirements 
The system requirements for PartMaker 2014 and higher are: 

 Standard 
PartMaker 

Parasolid 
Import 
Module 
(Solids)* 

Full 
Machine 
Simulation 
(FMS) 

Advanced 
Surface 
Machining 
(ASM) 

Processor Pentium 3 

800 MHz or 
higher 

Pentium 3 

800 MHz 
or higher 

Pentium 4 

3 GHz or 
higher 

Intel Core 

Duo 
processor 

or higher 

Memory 512 MB or 
more 

1 GB or 
more 

2 GB or 
more 

4 GB or 
more 

Hard drive 40 GB 40 GB 40 GB 80 GB 

Independent 
video card 

128 MB 
NVIDIA 

512 MB 
NVIDIA 

512 MB 
NVIDIA 

1 GB 
NVIDIA 

Operating systems 

64-bit and 32-bit versions of PartMaker are available and are 
supported on Windows 7. 

 PartMaker 2014 does not support Windows XP or Windows 

Vista. Although you may be able to run PartMaker 2014 on 
these operating systems, Delcam will not address any 

software performance issues found on Windows XP or 
Windows Vista that cannot be reproduced on Windows 7 or 

higher. 
 

Installing PartMaker on a stand-alone 
PC 

To install PartMaker:  

1 When you have started the computer and Microsoft Windows is 
running, insert the PartMaker Installation CD into the CD drive. 
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2 The Installer prompts you to select the language used on the 

dialogs displayed during the installation. The default selection is 
English. If PartMaker is available in the language you select, the 
translated version is installed. Select the language and click OK. 

 

3 The PartMaker Setup program starts and the PartMaker Setup 

screen is displayed: 

 

 If the Setup program does not start automatically, use My 

Computer (or Computer for users of Windows Vista and 

higher) to browse the contents of the CD and double-click 
setup.exe to start the Setup program. 

 Using Windows 7, you may see an AutoPlay dialog when the 

Installation CD is inserted. Click Install or Run Program to 

start the installation. If the Account Control Manager screen 

is displayed, click Allow to continue with the installation. 

4 Follow the on-screen installation instructions to complete the 

installation. 

5 When the installation is complete, install your license file (see 

page 5). 
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Installing the license file (PAF) 
PartMaker is protected using a combination of: 

 a dongle, which plugs into a USB or parallel port on the 

computer: 

 a Product Authorization File (PAF) license file, which you install 

onto the computer. 

PAFs are usually sent in an email from Delcam plc or from the 

PartMaker, Inc. division of Delcam. The email is sent to the email 
address that was registered when your company purchased 

PartMaker. You may receive the PartMaker installation software 
before you receive the PAF file. Because you can only use PartMaker 

if a valid PAF is installed, Delcam recommends that you do not 
install PartMaker until you have received your PAF. 

To install the license file (PAF): 

1 Close PartMaker and any other Delcam programs running on the 

computer. 

2 Open the email containing your PAF. The email has several 
attachments.  

 If the attachments are in a zip file (so they are accepted by 
your email's virus scanning software), unzip the file before 

continuing. 

3 Follow the instructions in the email to install the PAF, making 

sure you place your PAF in the correct folder: 

 On a 32-bit computer, place your PAF in C:\Program 

Files\Common Files\Delcam 

 If you have installed a 32-bit version of PartMaker on a 64-bit 
computer, place your PAF in  
C:\Program Files (x86)\Common Files\Delcam 

 If you have installed a 64-bit version of PartMaker on a 64-bit 

computer, place your PAF in  
C:\Program Files\Common Files\Delcam 

4 When you have installed the PAF and plugged in the dongle, you 
can start PartMaker by double-clicking the PartMaker desktop 

shortcut. For example, to start the 64-bit version of 
PartMaker/SwissCAM, double-click: 
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 If you use post processors for PartMaker/SwissCAM or 

PartMaker/Turn-Mill, you need to install the post processors 
you require (using the Help > Download Licensed Post Config 

Files menu option) before starting to use PartMaker. 
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PartMaker 2014 contains many new features and enhancements. 
 

Tool enhancements 
PartMaker 2014 includes the following enhancements to tools: 

 New tool types for Neutral Turn, Back Turn and Tapered End Mill 

tools (see page 7). 

 A new way of specifying the shape of an End Mill tool (see 

page 9). 

 Changes to the Manage Tools Files dialog to support the new tool 

types and tool shapes (see page 10). 
 

New tool types 

PartMaker 2014 includes new Neutral Turn, Back Turn and Tapered 

End Mill tool types in the Tool Data dialog: 

 

 New values are available for the <tool-type> reserved word 

in ConfigPost (see page 43) to support these new tools types. 

What's New in PartMaker 
2014 
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Neutral Turn tool 

The Neutral Turn tool is available for use with roughing and finishing 

operations in PartMaker/SwissCAM, PartMaker/Turn-Mill and 
PartMaker/Turn: 

 

 In the NC Program, the output point of a Neutral turn tool is 
the tip of the tool. 

Back Turn tool 

The Back Turn tool is available with the Advanced Tools licensing 

option. When licensed, the Back Turn tool is available for finishing 

operations in PartMaker/SwissCAM, PartMaker/Turn-Mill and 

PartMaker/Turn: 
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Tapered End Mill tool 

A Tapered End Mill tool (with a Tapered Spherical or a Tapered Tip 

shape) is available with the Advanced Tools licensing option. When 
licensed, the Tapered End Mill tool is available for Advanced Surface 

Machining (ASM), Advanced Milling Toolpaths (AMT) and for 

pocketing and contouring in PartMaker/SwissCAM, PartMaker/Turn-
Mill and PartMaker/Mill: 

       
 

End Mill tool shapes 

A new Shape selection box on the Tool Data and Edit Tool dialogs 

makes it easier to specify the shape (Flat, Bull Nosed or Ball Nosed) 

of an End Mill tool: 

 

In previous versions of PartMaker, you had to enter specific values 
in the Corner Radius field to specify the shape of the tool. 

The tool images displayed in PartMaker also reflect the shape you 
select. For example, on the Tool Data dialog: 
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Flat tool Bull Nosed Ball Nosed tool 

   
 

Manage Tools Files dialog 

The Manage Tools Files dialog includes options for the new tool types 

and tool shapes introduced in PartMaker 2014: 

 The new Neutral Turn, Back Turn and Tapered End Mill tool types 
are available in the Type selection box: 

 

 A new Shape field is available to select the tool shape for: 

 End Mill tools: 

 

 Tapered End Mill tools: 
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Working with solid models 
PartMaker 2014 contains the following enhancements for working 
with solid models: 

 Ability to set the transparency of solid models (see page 11). 

 PartMaker/Mill now displays the Face Plane and axis at the Z Face 

coordinate in the Solids window (see page 12). 

 When defining the Face plane of a dependent face from a solid 
model, PartMaker/Mill now calculates the Tombstone Index Angle 

for the dependent face automatically (see page 17). 

 When using the Mill Cylinder machining function in 

PartMaker/SwissCAM, PartMaker/Turn-Mill and PartMaker/Mill, 
you can now project the outlines and edges of non-cylindrical 

surfaces from a solid model onto the Face plane (see page 19). 

 When importing solid models, PartMaker 2014 is compatible 
with: 

 Solidworks 2014 

 Parasolid v24.0 
 

Setting transparency for solid models 

You can now set the transparency of a solid model displayed in the 
Solids window.  

Previously, PartMaker always displayed solid models as opaque (no 
transparency). For example: 

 

To set the transparency of a solid model: 

1 Click  on the Solids Window toolbar or select Solids > Solids 

Options to display the Solids Options dialog. 
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2 Enter a value in the Transparency field. Use a value between 0 

and 100, where 0 displays a solid (opaque) model and 100 

displays a fully transparent (invisible) model: 

 

3 Click OK to close the Solids Options dialog. PartMaker updates 

the display of the solid model to reflect the value you entered: 

 
 

Setting the Z Face coordinate in PartMaker/Mill 

PartMaker/Mill now displays the Face Plane and axis at the Z Face 

coordinate in the Solids window for all machining 
function/stock/milling table combinations that display this field. For 

example: 
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You can set the Z Face coordinate using the following dialogs: 

 Setup dialog (see page 13). 

 Define Face Plane dialog (see page 14). 

 Surface Info dialog (see page 16). 
 

Changes to the Setup dialog 

Previously, the Z Face field was available on the Setup dialog only 

when using the: 

 Mill XY Plane machining function for a Standard table. 

 Mill 4-Axis Plane machining function for a 4-Axis or 5-Axis Rotary 

table. 

In PartMaker/Mill 2014, you can now also enter a Z Face coordinate 

on the Setup dialog when using the Mill XY Plane machining function 
for Tombstone or 5-Axis Rotary tables. For example: 

 



 

14 • What's New in PartMaker 2014  PartMaker 2014  

PartMaker displays the Face Plane and axis at the Z Face coordinate 

specified: 

 
 

Using the Define Face Plane dialog 

When defining the Face Plane from a solid model, you can now 
specify a Z Face coordinate on the Define Face Plane dialog. The Z 

Face field is available when using the Parallel to XY Plane option with 

the following machining function/stock/table combinations: 

 Mill XY Plane machining function with Box or Cylinder stock on 
Standard or Tombstone tables. 

 Mill XY Plane machining function with Box stock on 5-Axis Rotary 

tables. 

 Mill 4-Axis Plane with Box stock on 4-Axis Rotary or 5-Axis Rotary 

tables. 
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For example, if you select the following surface (shown in green) 

and enter a Z Face value of 1: 

 

PartMaker updates the Solids window to display the Face Plane at 
the specified Z Face coordinate value and updates the Z Face field 
value on the Setup dialog to reflect the new value: 
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Using the Surface Info dialog 

When using the Surface Info dialog to define the Face Plane from the 

solid model, PartMaker/Mill 2014 now calculates the Z Face 

coordinate value from the selected surface when you use the 
following machining function/stock/table combinations: 

 Mill XY Plane machining function with Box or Cylinder stock on 

Standard or Tombstone tables. 

 Mill XY Plane machining function with Box stock on 5-Axis Rotary 

tables. 

 Mill 4-Axis Plane with Box stock on 4-Axis Rotary or 5-Axis Rotary 

tables. 

For example, when the following Face Plane is defined at the bottom 

of the part, the Z Face value on the Setup dialog is -1: 

 

You can change the Face Plane by double-clicking another surface 
on the part to display the Surface Info dialog. You can then select 

Set Face Plane as Selected and click Transfer Planar Geometry. 
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When transferring the planar geometry into the Face window, 
PartMaker resets the Face Plane and updates the Z Face coordinate 
value on the Setup dialog to reflect the new Z Face value: 

 
 

Calculating the Tombstone Index Angle for dependent 
faces 

When defining the Face plane of a dependent face from a solid 
model, PartMaker/Mill now calculates the index angle for the 
dependent face and displays this in the Tombstone Index Angle field 
on the Setup dialog. 

In previous versions of PartMaker/Mill, you had to calculate the 
index angle required and then enter it into the Tombstone Index 

Angle field on the Setup dialog. 

The following example shows how PartMaker/Mill 2014 calculates 
the Tombstone Index Angle: 

1 Create two Face windows — an Independent Face (FRONT, 

see  ) and a Dependent Face (LEFT see ): 
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2 On the solid model, select the plane to use as the Face plane for 
the LEFT Face, then right-click and select Define Face Plane to 
display the Define Face Plane dialog: 

 

3 When you click OK to confirm the Face plane, PartMaker 

calculates the Tombstone Index Angle required and updates this 
value on the Setup dialog. Select View > Setup to view the index 

angle that PartMaker has calculated: 
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Projecting non-cylindrical surfaces in a Mill Cylinder 
Face window 

In PartMaker/SwissCAM, PartMaker/Turn-Mill and PartMaker/Mill, 

you can now project the outlines and edges of non-cylindrical 
surfaces from a solid model onto the Face plane when using the Mill 

Cylinder machining function. 

Previously, this feature was available for other machining functions, 
but not for Mill Cylinder. 

When working in the Solids window, use the Solids > Selection 

Options menu to specify whether you want to select surfaces and/or 

edges on the solid model. You can then make your selection on the 

solid model and can project:  

 Outlines by clicking the Project Outline button on the Surface Info 

dialog or selecting the Solids > Project > Project Outline menu 

option. 

 Edges by clicking the Project button on the Curve Info dialog or 

selecting the Solids > Project > Project Edges menu option. 

For example, to project an outline of a planar surface into a Face 
window that uses the Mill Cylinder machining function: 

1 Double-click a planar surface on the solid model in the Solids 
window to display the Surface Info dialog: 
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2 Click Project Outline. PartMaker displays the Convert Curved Edges 

dialog, where you can specify how PartMaker converts the curved 
edges of the surface when projecting it into the Face window: 

 

3 Click OK to close the Convert Curved Edge dialog. PartMaker 

projects an outline of the selected surface into the Face window: 
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NC Program files 
PartMaker 2014 includes the following enhancements for working 
with NC Program files: 

 In PartMaker/SwissCAM and PartMaker/Turn-Mill, a new NC 

Program Info dialog replaces the NC Program Info window (see 

page 21).  

 A new NC Program window replaces the NC Program Viewer 
window(s) and includes: 

 A toolbar for accessing common tasks more easily (see 
page 22). 

 The ability to align multi-channel NC Program files in 
PartMaker/SwissCAM and PartMaker/Turn-Mill (see page 23). 

 The ability to search for text in NC Program files (see 
page 25). 

 The ability to set a user-defined point as the origin for the 
Global Coordinate system when using a 5-Axis Rotary table 

(see page 26). 

 On the Main toolbar, a new Show NC Program Window button 

displays the NC Program window. 
 

NC Program Info dialog 

PartMaker/SwissCAM and PartMaker/Turn-Mill include a new NC 

Program Info dialog that replaces the NC Program Info window in 

previous PartMaker versions. 

When you generate an NC Program file, PartMaker now displays: 

 The NC Program Info dialog if any informational messages are 

generated during postprocessing.  

 The NC Program window if no informational messages are 
generated during postprocessing. 

 The NC Program Info dialog is not displayed in PartMaker/Mill, 

PartMaker/Turn or PartMaker/WireEDM. These applications 
always display the NC Program window when you generate an 

NC Program file successfully. 
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The messages displayed in the NC Program Info dialog depend on 
the Post Configuration (.pst) file you are using. Both informational 

and error messages can be displayed. For example: 

 

When you have viewed the messages, you can select: 

 View NC Program to close the NC Program Info dialog and view the 

NC Program in the NC Program window. 

 Launch NC Program Editor to close the NC Program Info dialog and 

open the NC Program Editor application (as specified on the 
Preferences dialog) so you can edit the NC Program file. 

 Close to close the NC Program Info dialog. 
 

NC Program Window toolbar 

The new NC Program window includes a toolbar for accessing 
frequently used features: 

 

Button Description 

 
Displays the Post Options dialog, where 

you can specify how PartMaker creates 

NC Programs for the current part. 

 
Displays the Save NC Program file as 

dialog for you to specify a name for the 

NC Program file, and then generates an 
NC Program file for the current part. 

 
Displays the Find dialog, where you can 

enter the text you want to search for in 
the NC Program file(s). 
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Button Description 

 
Displays the Print Document dialog, 

where you can specify the page 
orientation and preview before printing. 

 
Zooms in to increase the size of the 

text in the NC Program window. 

 
Zooms out to decrease the size of the 

text in the NC Program window. 

 
Aligns the different channels in the NC 
Program file(s) according to the 'wait' 

and 'sync' codes (see page 23). 

 Available only in 

PartMaker/SwissCAM and 

PartMaker/Turn-Mill. 

 
Opens the NC Program file in the NC 

Program Editor (as specified on the 
Preferences dialog) for editing. 

 

Aligning multi-channel NC Programs 

In PartMaker/SwissCAM and PartMaker/Turn-Mill, some machines 

require multi-channel NC Program output. Depending on the 

machine and postprocessor used, PartMaker combines the channels 
into a single NC Program file or stores them in separate files. 

In previous versions, PartMaker displayed the NC Program output 
for multiple channels in separate NC Program windows For example: 

 

In PartMaker 2014, PartMaker can now display up to four channels 
within a single NC Program window and can align the content in all 

the channels using 'wait' and 'sync' codes.  
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To align the different channels, click . For example: 

 

 PartMaker aligns channels in the NC Program by matching 

identical 'wait' and 'sync' codes across the different channels. 
The majority of multi-channel machines for which PartMaker 

can provide licensed Post Configuration files use this method 
of synchronization. However, if you are using a machine that 

synchronizes using other methods (for example, by matching 
pre-defined, non-identical wait codes), the Align button is 

unavailable. 

Printing multi-channel output 

When the NC Program window displays aligned, multi-channel 
output, PartMaker also reflects this layout in printed output: 
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Searching NC Program files 

You can now search the NC Program file(s) displayed in the NC 

Program window. Previously, you could search only in the NC 

Program Editor. 

To search NC Program file(s): 

1 With the NC Program file(s) open in the NC Program window, 
display the Find dialog by: 

 Selecting Edit > Find from the menu; or  

 Clicking  on the NC Program Window toolbar. 

2 Enter the settings for your search in the Find dialog: 

 Find What — Enter the text you want find. If you selected text 

in the NC Program window before opening the Find dialog, the 

selected text is displayed in this field. 

 Match Case — Select to search only for text that matches the 

combination of upper- and lower-case characters used in the 
Find What field. 

 Direction — Select the direction (Up or Down) in which 

PartMaker searches the NC Program file(s). 

 Search In Channels — Specify whether PartMaker searches only 

the currently selected channel, or searches all channels, in the 

NC Program file(s). 

 Search In Channels is available only when viewing a multi-

channel NC Program file in PartMaker/SwissCAM or 

PartMaker/TurnMill. 

3 Click Find Next to search the NC Program file(s). 
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PartMaker highlights the text that matches your search criteria: 

 
 

Setting global coordinates for 5-axis NC Program 
output 

In PartMaker/Mill, you can now set a user-defined point as the 

origin for the Global Coordinate system when using a 5-axis rotary 
table. PartMaker/Mill outputs the NC coordinates in the NC Program 

file with respect to this point. 

To specify a user-defined point for NC coordinates: 

1 On the Post Options dialog, select User Defined from the Global 

Origin list in the Rotary 5 Axis Table Output area of the dialog. 

2 Specify the location of the point by entering its distance from the 
table's pivot point in the Z Distance from Pivot Point field: 

 

3 Click OK to confirm your selections and close the Post Options 

dialog. 
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New method of calculating pocketing 
toolpaths 

PartMaker 2014 includes a new, improved method of calculating 
pocketing toolpaths in PartMaker/SwissCAM, PartMaker/Turn-Mill 

and PartMaker/Mill. PartMaker automatically uses the new method 
to calculate all pocketing toolpaths when you create a pocketing 
toolpath using the Pocket Mill strategy on the Profile Group 

Parameters dialog.  

The new method automatically detects where material is left and 

generates clearance toolpaths accordingly. Therefore, it is unlikely 
that the toolpath will require a clean-up pass (as set using the 
Optional Pass option): 

 

The new-style pocketing toolpaths automatically attempt to keep 
the tool at the cutting level. Therefore, the Stay at Depth option has 

been replaced with a new Minimize Air Moves option: 

PartMaker 2013 PartMaker 2014 

  

When Minimize Air Moves is selected, PartMaker machines each area 

with one plunge at the start of the toolpath to minimize the number 
of lifts. 

 Minimize Air Moves is not available for linear-style pocketing 

toolpaths. 

Handling pocketing toolpaths created in earlier versions of PartMaker 

When using PartMaker 2014 to open a .job file that contains 

pocketing toolpaths created in an earlier version of PartMaker, a 
message is displayed prompting you to re-verify all the pocketing 

toolpaths before creating a NC program.  

You should re-verify all these pocketing toolpaths to ensure they 

produce the expected results. 
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User interface changes 
PartMaker 2014 includes the following improvements to the 
PartMaker user interface: 

 You can now undo and redo multiple actions when working in 
PartMaker (see page 28). 

 Leads In and Leads Out settings are now available in a single 
Leads dialog (see page 30). 

 PartMaker now displays unlicensed tools in the user interface 
(see page 31). 

 The Tool Data and Edit Tools dialogs now disable invalid settings 

for turning tools (see page 32). 

 The Profile Group Parameters, Turning dialogs have a new layout 

(see page 32). 

 PartMaker now remembers the View > Show Work Group Only 

menu option setting as you move between different work groups 

(see page 33). 

 The View menu has a new layout (see page 33), which is also 

reflected in the Face Window toolbar. 

 Some menu options have new keyboard shortcuts (see page 33). 

 The Setup dialog in PartMaker/Mill now displays the X Face field 

only when it is needed (see page 34). 
 

Undoing and redoing actions 

PartMaker 2014 enables you to undo and redo multiple actions. In 

previous versions of PartMaker, you could undo and redo only your 

most recent action. 

This enhancement also changes how some aspects of the 
Undo/Redo options work: 

 

 PartMaker 2013 PartMaker 2014 

Menu 
options 
and 
toolbar 
buttons 

A single toolbar button and 

menu option were available to 
toggle between undoing and 

redoing the most recent 
action: 

 button and Edit > Undo 

Different toolbar buttons and 

menu options are available for 
undoing and redoing multiple 

actions: 

Undo button and Edit > Undo 

Redo  button and Edit > Redo 
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 PartMaker 2013 PartMaker 2014 

Using in 
Face 
windows 

You could switch between 

Face windows and undo the 
most recent action in each 

window. 

You can undo multiple actions in 

the active Face window. 

Actions 
you can 
undo/redo 

You could undo and redo 

many types of actions 
performed by using a menu 

option, a toolbar button, a 

keyboard key, or selected 
dialogs. 

You can redo and undo the same 

actions as in previous PartMaker 
versions, as well as some new 

actions, including: 

 In CAD mode, you can undo 
actions performed using the 
Line Info, Arc Info and Circle 

Info dialogs. 

 In CAM mode, you can undo 

actions performed using the 
Hole Properties dialog. 

Action 
history 

PartMaker kept a history of 

the actions that could be 
undone/redone.  

PartMaker cleared the history 
when certain actions (such as 

opening a new job file or 
generating the Process Table) 

were performed.  

PartMaker stores and clears the 

undo/redo history as in previous 
releases, but there are now 

additional actions that clear the 
history, including: 

 Importing any file. 

 Using options from the View > 
Change Spindle and Convert 

Data menu. 

 Using the Zero button in 

CAD or CAM mode. 

 These changes do not affect the Undo buttons available on the 

Hole Group Parameters dialog, Profile Group Parameters dialogs 
for Contour and Pocket Cycles and the Edit Coordinate System 

dialog. These Undo buttons continue to work as in previous 

releases. 
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Leads In and Leads Out 

PartMaker 2014 combines the settings for controlling the movement 

of the tool as it approaches (Leads In) and leaves (Leads Out) the 
stock into a single Leads dialog. Previously, these settings were 
displayed on separate Leads In and Leads Out dialogs. 

To display the Leads dialog, click the Leads button on the Profile 

Group Parameters dialog. This button replaces the separate Leads In 
and Leads Out buttons available in previous versions: 

 

PartMaker 2013 PartMaker 2014 

  

The new Leads dialog enables you to view Leads In and Leads Out 

settings alongside each other: 

 

You can also copy values between the different types of moves 

using the following buttons: 
 

Button Description 

 
Copies the values specified for Lead In moves 

into the fields for Lead Out moves. 

 
Copies the values specified for Lead Out moves 

into the fields for Lead In moves. 
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Displaying unlicensed tools 

PartMaker now displays Advanced Tools in the user interface, even 

if they are unlicensed. However, you still require the Advanced 

Tools license option to create these types of tools. 

For example, PartMaker/SwissCAM displays (but does not allow you 

to select) the Back Turn, Tapered End Mill and Thread Whirl tools in 
the Tool Data dialog when the Advanced Tools option is not licensed: 

 

Similarly, PartMaker also displays unlicensed tool types on the 
Select Tool dialog, but does not allow you to select them using the 

Add New Tool button (Turning) or Add button (Milling): 
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Disabling invalid settings for Turning tools 

The Tool Data and Edit Tool dialogs for Turn, Groove or Thread tools 

in PartMaker/SwissCAM, PartMaker/Turn-Mill and PartMaker/Turn 

now update to reflect your previous selections. 

For example, ID Thread tools must have an Orientation of Right and 

a Shank Axis of Z-Axis, so PartMaker automatically selects these 

values and disables all other Orientation and Shank Axis values. 

 

PartMaker 2013 PartMaker 2014 

  
 

Profile Group Parameters, Turning dialogs 

The Profile Group Parameters, Turning dialogs have a new layout to 

make them consistent with the Profile Group Parameters, Milling 

dialogs and improve usability. 

The new layout organizes Operations, Tool ID and Leads settings as 

follows: 

 

For strategies (such as the Cut-Off strategy) that perform only 
roughing operations, PartMaker now displays, and automatically 
selects, the Roughing option: 

 

The dialog also contains a new Leads  button, which is 

described in Leads In and Leads Out (see page 30). 
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Displaying holes and profiles from the work group 

The View > Show Work Group Only menu option enables you to view 

only the holes and profiles for the currently selected group (that is, 

the work group) in the Face window. 

PartMaker 2014 remembers this menu option setting, so you can 

move between different work groups and view only the holes and 
profiles in each group in the Face window. PartMaker displays a 

check mark alongside this option when it is selected: 

 

In previous versions of PartMaker, you had to re-select the View > 

Show Work Group Only menu option each time you selected a new 

work group. 
 

New layout in the View menu 

The View menu has a new layout. The menu now displays all the 

menu options available for working in both CAM and CAD mode. 

Previously, PartMaker hid some menu options that were not 
applicable to your current mode. 

For example, although you can use the Show Work Group Only 

option only when working in CAM mode, the option is now displayed 
(but is not available for selection) when working in CAD mode: 

PartMaker 2013 CAD mode PartMaker 2014 CAD mode 
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The buttons on the Face Window toolbar have also been rearranged 
to match the order in which the menu options appear in the View 

menu. For example, when working in CAD mode: 

PartMaker 2013 PartMaker 2014 

  
 

Keyboard shortcuts for menu options 

Some menu options now have different keyboard shortcuts. These 
changes enable PartMaker to use standard Windows keyboard 
shortcuts for common operations, such as Find and Redo: 

 

Menu option PartMaker 2013 PartMaker 2014 

Edit > Find  

(NC Program window 

only) 

Menu option not 

available 

Ctrl+F 

View > Redo Menu option not 
available 

Ctrl+Y 

View > Show Sample 
Color Only 

Ctrl+W No keyboard 
shortcut * 

View > Full View Ctrl+F Ctrl+M 

Part Features > Verify 
Every Tool Path 

Ctrl+Y Ctrl+B 

* Previously, Ctrl+W was used as a keyboard shortcut for both the 

View > Work Group Only and View > Show Sample Color Only menu 

options. Now, it is used only for View > Show Work Group Only. 
 

Changes to the Setup dialog in PartMaker/Mill 

In PartMaker/Mill, the X Face field is no longer displayed in the 
Setup dialog when using the following machining functions with a 5-

Axis Rotary table and cylindrical stock: 

 Mill 4-Axis Plane 

 Mill Polygon 

 Mill Diam, Index 

 Mill Cylinder 
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Previously, the X Face field was displayed, but never enabled, for 

these machining function/stock/table combinations. For example, 
when using the Mill Polygon machining function: 

PartMaker 2013 PartMaker 2014 

   
 

Advanced Surface Machining (ASM) 
PartMaker 2014 includes the following enhancements to the Model 

Area Clearance strategy available in Advanced Surface Machining 

(ASM): 

 A new Vortex style is available for removing material (see 

page 36). This style rapidly removes material from a 3D part 

while controlling tool load. Vortex is best suited to solid carbide 
tools. 

 Step cutting settings are now available (see page 37). Use these 

settings to create intermediate toolpath slices to reduce 
terracing. 

Step cutting is particularly useful for Vortex-style toolpaths (see 
page 39). 

 Changes to the Tool orientation/Tool axis settings available when 
using the Pattern finishing strategy to create 4- and 5-axis 

simultaneous toolpaths. (see page 43) 

 ASM is available as a license option for PartMaker/SwissCAM, 
PartMaker/TurnMill and PartMaker/Mill. 

 PartMaker does not support Vortex toolpaths created in 
PowerMILL. If you import a PowerMILL project that contains 

Vortex toolpaths into PartMaker, the Vortex toolpaths may not 

be processed correctly. 
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Vortex-style toolpaths 

A new Style option of Vortex is available for the Model Area Clearance 

roughing strategy in Advanced Surface Machining (ASM). Using this 

style enables the rapid removal of material from a 3D part while 
controlling tool load.  

A Vortex-style toolpath produces an offset toolpath, which never 
exceeds the maximum tool engagement angle for optimum 

machining. As the tool approaches the maximum engagement 
angle, the toolpath changes to a trochoidal path to avoid tool 

overload. For example:  

 

Vortex-style toolpaths often work well with step cutting (see 

page 37). 

To create a Vortex-style toolpath: 

1 Select Roughing on the Surface Group Parameters dialog, and 

then click the Options button: 

 

PartMaker displays the Strategy dialog for Model Area Clearance. 

2 Select Vortex as the Style on the Model Area Clearance page: 
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3 Complete the settings on the Strategy dialog, noting that 

selecting Vortex: 

 Enables the Vortex page, which contains the settings required 

to define a Vortex toolpath. 

 Reduces the options available on the Wall finishing page.  

 Reduces the options available on the High speed page. 

 Provides additional options on the Approach page. 

 Disables the options on the First lead in page. 

 Disables the options on the Lead in page 

 Disables the Inward options on the Extensions page. 

 See the PartMaker Reference Help for more details about 
the settings in the Strategy dialogs. 

 

Step cutting settings 

A new Step cutting page is available on the Model Area Clearance 

Strategy dialog. Use the settings on this page to create intermediate 

toolpath slices that reduce terracing: 

 

 The first pass is a main slice. 

 The next pass is the lowest step-cutting slice. 

 The next pass is the next to lowest step cutting slice and so on 

up the part (shown by ) until the previous main slice is reached. 

 The next main slice. 

The main slices are cut from top to bottom as normal. The 
intermediate slices are cut from bottom to top. This is possible 

because the depth of cut is always less than the depth of cut (or 
Stepdown) for the main slice. This is the most efficient way of 

cutting the part as it reduces the number of passes and increases 
the depth of cut of each pass. 
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To use step cutting for a Model Area Clearance toolpath: 

1 Select Step cutting on the Model Area Clearance Strategy dialog to 
display the Step cutting page. 

2 Select the Step cutting option to enable step cutting: 

 

3 Complete the following fields: 

 Step up — Enter the distance between intermediate cutting 

levels. 

 Detect material thicker than — Enter a threshold value. 

PartMaker ignores rest material that is thinner than the 

specified threshold. This helps to avoid thin regions being rest 

machined, where the benefit of a second cut is negligible. 
These thin regions can be caused by cusps from the previous 

toolpath. 

 Expand area by — Enter the distance by which to expand the 

rest areas, measured along the surface. Use with the Detect 

material thicker than value to reduce the areas to be machined 

to the details (for examples, corners), and then to offset these 

areas slightly to ensure that all the detail (for example, on the 
corners) is machined. 

 See the PartMaker Reference Help for more details about 
the settings in the Step cutting page. 
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Example of using Vortex with step cutting 

Vortex-style toolpaths often work well with step cutting. This 

example shows how to combine Vortex machining with step cutting 
to rapidly remove material. 

As Vortex machining cuts with the side of the tool, it is designed for 
solid carbide tools, but there may be other types of tools suitable 

for Vortex. These tools work best when taking deep cuts with a 

relatively small stepover. 

 

To machine effectively when taking large depths of cut, you must 

ensure the tool engagement angle never exceeds the specified 
value. This eliminates excessive tool load and all full-width cuts. 

PartMaker achieves this by introducing trochoidal moves to prevent 
the tool from exceeding the maximum tool engagement value. 
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Using a 3D model: 

 

Creating a Vortex toolpath without step cutting. 
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This removes vast quantities of material quickly, but leaves large 

terraces of unmachined stock on the part.  

 

You can minimize the size of these terraces using the Step cutting 

options. 
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This adds extra machining slices up the part. Looking at a detail of 

the side view: 

 

  Original Vortex pass 

  Step cutting passes 

It also machines more of the excess stock. 
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Changes to the Pattern finishing strategy 

To ensure Pattern finishing toolpaths are calculated correctly for 4- 

and 5-axis simultaneous toolpaths, PartMaker 2014 now disables 

certain combinations of settings. 

When a Base position of Drive curve is selected (so the lowest 

position of the toolpath follows the pattern), the following options 

are no longer available: 

 For 4-axis simultaneous toolpaths, the Towards surface option is 

not available on the Tool orientation page. 

 

 For 5-axis simultaneous toolpaths, the Contact normal option is 
not available on the Tool axis page. 

 

 If you open a .job file created in a previous version of 

PartMaker that contains these combinations of settings, 

PartMaker displays a message prompting you to re-verify 
these toolpaths to ensure they produce the expected results. 

 

ConfigPost enhancements 
In ConfigPost 2014 additional values are available for the <tool-

type> reserved word to support the new tool types in PartMaker 

2014 (see page 7): 

 NT – Neutral Turn 

 BT – Back Turn 

 TE – Tapered End Mill 
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If you are a new PartMaker user, you may want to use the following 

resources to help you get started: 

 Help and documentation (see page 44). 

 Training (see page 45). 

If you experience any problems when installing or using PartMaker, 

contact technical support (see page 45). 

If you require any modifications to the Distribution Post files you 

have licensed, refer to the Post Processor modification policy. 
 

Help and documentation 
To help you get started, PartMaker is supplied with a comprehensive 
online Reference Help, which you can access from the Help menu. 

Further documentation is also provided on the PartMaker 
Documentation CD.  

You can also download documentation from the Delcam Customer 
Downloads Center (http://updates.delcam.com/login.php), as 

described in Technical support for PartMaker (see page 45). 

 

 

 

 

 

 
 

Help and support 

http://updates.delcam.com/login.php
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Training for PartMaker and ConfigPost 
A wide variety of PartMaker and ConfigPost training programs are 
available from PartMaker, Inc., Delcam plc and their sales agents as 

follows: 

In North America 

 PartMaker, Inc, see the Training section of the PartMaker website 

(www.partmaker.com). 

Outside of North America 

 Delcam plc, see the Training section of the Delcam website 

(www.delcam.com). 

 Delcam plc sales agents, contact your sales agent directly. The 

Delcam website (www.delcam.com) contains a list of sales 
agents and their contact details. 

 

Technical support for PartMaker 
Customers with an annual maintenance agreement can obtain 

technical support for PartMaker. This support may be provided by 
phone, email or by accessing technical support information available 

on the Internet. 

Before contacting technical support, please refer to the 

documentation and help supplied with PartMaker to see if you can 
find information to solve your query.  

Internet support 

You can also access software releases, documentation, technical 
notes and videos from the Delcam Customer Downloads Center 

(http://updates.delcam.com/login.php). 

Phone and email support 

If you are unable to resolve your query, make sure you do the 

following before contacting technical support: 

 You know the name and version of the PartMaker product you 

are using. 

 You are able to describe the problem in detail. You may find it 

useful to document exactly what happened. 

 If possible, be sure you can reproduce the problem. A support 
technician may ask you do this while you are on the phone. 

http://updates.delcam.com/login.php
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 Be prepared to submit job (.job), tools (.tdb), cycles (.cdb) and 

Post Configuration files (.pst and .sub), as well as sample NC 

programs as attachments to an email message. Always try to zip 

your files using the WinZip program to make it easier and 
quicker to send the files by email. 

 PartMaker will automatically zip the files if you use the Help 

> Technical Support option within PartMaker and select the 
Send Files button.  

To contact your local provider of technical support: 

 For PartMaker, Inc in the United States, email 
support@partmaker.com or phone 215-643-5077. 

 For Delcam plc in the United Kingdom, email 
support@delcam.com or call 0121 683 1010. 

 For other countries, contact your local sales agent. Contact 
details for Delcam sales agents are available on the Delcam 

website. 
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