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The following sections include information to enable you to install 
and start using PartMaker Modeling: 

Installing PartMaker Modeling (see page 4) 

Starting PartMaker Modeling (see page 14) 

Using the Browser window (see page 16) 

Getting help with PartMaker Modeling (see page 18) 

Basic modeling concepts (see page 103) 

 

Getting Started with 
PartMaker Modeling 2015 
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Getting Started 
The following sections include information to enable you to install 
and start using PartMaker Modeling: 

What is PartMaker Modeling? (see page 2) 

PartMaker Modeling functionality (see page 4) 

Installing PartMaker Modeling (see page 4) 

Starting PartMaker Modeling 

What is the Browser? (see page 16) 

Getting Help with PartMaker Modeling (see page 18) 

Example data (see page 21) 

Further information (see page 21) 
 

What is PartMaker Modeling? 
PartMaker Modeling uses PowerSHAPE to provide a powerful hybrid 
solid, surface and wireframe modeller for the design of products 
with complex shapes. 

 
You can use PartMaker Modeling to design products from scratch; 
particularly those with sculptured shapes. It is also ideally suited to 
preparing existing product models for manufacture — by importing 
a model from another CAD system and adding features for 
manufacture such as fillets, split, and draft surfaces. 

PartMaker Modeling releases 
PartMaker Modeling releases use a year-based title in the form 
PartMaker Modeling 2015. This title is used in the About dialog and 
the Main toolbar. 

For example: 

Delcam PartMaker Modeling for the first customer release after 
July 1st. 

Delcam PartMaker Modeling R2 for the second customer release 
after July 1st. 
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64-bit PartMaker Modeling 
PartMaker Modeling is available in two versions: 

 PartMaker Modeling 64-bit runs only on a 64-bit operating 
system and has no limit on the amount of available memory it 
can use. 

 PartMaker Modeling 32-bit runs on 32-bit and 64-bit operating 
systems but has a limit on the amount of memory it can use. 

The installation procedure enables you to select the version you 
want to install. 

Benefits of the 64-bit version 
Using a 64-bit version of PartMaker Modeling:  

 Enables you to handle much larger models because there is no 
limit on the amount of available memory it can access. 

 Improves calculation times. 

 Avoids "out of memory" errors. 

Using the 64-bit version 
The 64-bit version of PartMaker Modeling requires: 

 64-bit hardware (Intel/AMD) and operating system (Vista or 
Windows 7). 

 More memory on start-up and for operations like rendering 
(approximately 20% depending on usage). We recommend a 
minimum of 8 GB memory. 

PCs bought in the last few years should be capable of running a 64-
bit operating system. However, 32-bit Windows is still common. 

Using the 32-bit version 
It is possible to run the 32-bit version on a PC with a 64-bit 
operating system but you will only use up to 4 GB of memory. If 
you have a 64-bit PC you will need a 64-bit operating system and 
appropriate drivers for you hardware. 

If you have a 32-bit PC, the only option is to run the 32-bit version 
of PartMaker Modeling. This uses up to 2 GB of memory. 

Compatibility 
All data files are interchangeable between 32-bit and 64-bit 
versions.  

Computer issues 
Use one of the following links to help you find out if your PC and 
Operating System are 64-bit: 
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http://support.microsoft.com/kb/827218 

http://www.lytebyte.com/2009/08/04/how-to-check-if-my-
processor-is-x86-32-bit-or-x64-64-bit-in-windows  

To find out if you are running a 64-bit version of PartMaker 
Modeling look in the title bar or the dialog displayed from the Help > 
About menu. 

There are separate installers for the 64-bit and 32-bit versions of 
PartMaker Modeling. It is possible to have both versions installed on 
the same computer; there is a separate desktop shortcut for each 
version.  

64-bit issues 
The 64-bit version of PartMaker Modeling: 

 Supports dongle or paf licencing. 

 Does not support the flex network licencing system. 
 

PartMaker Modeling functionality 
PartMaker Modeling provides PartMaker users with functionality for 
creating and repairing 3D solid models.  

PartMaker Modeling includes the following functionality: 

 complete solid, surface, and wireframe modelling. 

 full 2D drafting capability using Delcam Drafting. 

 surface and solid morphing. 

 Direct Modelling. 

 assembly modelling.  

 import and export of a comprehensive range of file types. The 
PartMaker Solids Import module is also available. 

 

Installing PartMaker Modeling 
Use the following sections to install PartMaker Modeling: 

 Before you begin (see page 5). 

 Using the Installation Wizard (see page 5). 

 Installing your Product Authorisation File (PAF) (see page 9). 

 Installation options for advanced users (see page 9): 

 Changing the drawing standard (see page 13). 

 Upgrading an existing version of the software (see page 13). 

 Installation problems (see page 13). 
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 General installation information (see page 14). 

 Model version (see page 14) 

 Uninstalling PartMaker Modeling (see page 14). 
 

Before you begin 
1 To start PartMaker Modeling, you will require a Product 

Authorisation File (PAF). Please contact your Sales Agent for more 
details.  

2 By default, the installer will set up each user with their own 
private centralised shared data area. If you are happy with the 
default setup, proceed with installing PartMaker Modeling. For 
further details, see Installing PartMaker Modeling. 

However, if you are a system administrator and want to control 
where centralised shared data files are installed on your network, 
you need to set up registry entries before installing PartMaker 
Modeling. For further details, see Installation options for 
advanced users (see page 9). 

 In PartMaker Modeling, the centralised shared data files are 
called the shared database (DB) or shareddb for short. 

 

Using the Install Wizard 
1 Log in to your system as an administrator, insert the DVD in the 

drive and wait a few seconds. The Install Wizard is displayed. 

2 Use the folowing steps of the Install Wizard to install PartMaker 
Modeling: 

a Use the drop-down list to select English as the installation 
Language. 



 

6 • Getting Started with PartMaker Modeling 2015 PartMaker Modeling 2015 Getting Started  

b Click OK to display the Welcome page of the PartMaker 
Modeling Setup Wizard. 

 
c Click Next to display the License Agreement page of the 

PartMaker Modeling Setup Wizard. 

 
d Click I Agree. 

sct_us
Stamp



 

PartMaker Modeling 2015 Getting Started Getting Started with PartMaker Modeling 2015 • 7  

e Select the appropriate option for the version of the software 
you wish to install. If you have a 64-bit operating system, it is 
recommended that you select Install 64-bit software. 

 
f Click Next to display the Install Options page of the PartMaker 

Modeling Setup Wizard. 
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g If you normally work in inches, leave the Inch option selected 
and click Install to display the Installing page of the PartMaker 
Modeling Setup Wizard. This shows progress through the 
installation. 

 
When installation is complete, the final page of the PartMaker 
Modeling Setup Wizard.is displayed. 

 
h Click Finish to complete the installation. 

3 When installation is complete, restart your computer. 

 For details on default installation paths for your operating 
system, see:Windows 7 default installation paths (see page 9) 

 

sct_us
Typewritten Text
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Windows 7 default installation paths 
If your operating system is Windows 7 or later, by default, the 
installation wizard installs folders in the following locations: 
C:\Program Files\Delcam\XXXXX, (where XXXX is the product and 
product version) 
c:\Users\Public\Documents\Delcam\shareddb 

or displayed as c:\Users\Public\Public Documents\Delcam\shareddb 

c:\Users\Public\Documents\Delcam\parts 
or displayed as c:\Users\Public\Public Documents\Delcam\parts 
For 32-bit installations on a 64-bit operating system, the path is: 
C:\Program Files (x86)\Delcam\XXXXX, (where XXXXX is the product 
and product version) 

If you want to install the shared database and parts directory onto a 
different drive or directory, see Setting the shared database on a 
different drive using the Registry Editor (see page 11). 

 

Installing your Product Authorisation File (PAF) 
After you have installed PartMaker Modeling: 

1 Restart your computer. 

2 Locate the Product Authorisation File (PAF) provided by your sales 
agent. You may have received this file as an attachment to an 
email, on a USB drive, or on a CD/DVD disk. 

3 Copy the .paf file into the folder indicated in the email. 

4 When you have installed your PAF, start PartMaker Modeling. 

5 When PartMaker Modeling is running, click Help > Check for PAF 
updates to check for a new PAF to download. 

 You need to have a valid licence file and be connected to the 
Internet to use this option. 

 

Installation options for advanced users 
The following information is provided for advanced users with 
specific installation requirements. 

 Installing the shared database (see page 10): 

The shared database is installed by default during the installation 
process. Skip this section unless you are a system administrator, 
wanting to control the location of shared data files on a network. 
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 Setting the shared database on a different drive using the 
Registry Editor (see page 11): 

The location of the shareddb does not need to be changed for the 
program to work. Skip this section unless you are familiar with 
using the regedit command to edit the registry and you want to 
set the shared database database or parts directory on a 
different drive. 

 Location of user-specific files (see page 12): 

 Specify the location of user-specific files such as custom toolbars 
and shortcuts, so that the same location is used for future 
versions. 

 When you install PartMaker Modeling, you are asked to select 
your unit of working. If you select Inch (the default setting), the 
ANSI drawing standard is applied. If required, you can change 
the drawing standard that is used (see page 13). 

 

Installing the shared database 

 Important: The shareddb is installed by default during install. 
Skip this section unless you are a system administrator 
wanting to control the location of shared data files on a 
network. 

PartMaker Modeling allows a group of users to share information 
that is applicable to everyone in that group. For example, the index 
of models being created or company standards. This information is 
stored in a shared database (DB) area called shareddb. When you 
install PartMaker Modeling, by default, everyone has their own 
private shared database area and their own parts areas where 
models are stored by default. 

If you want to use these default paths and folders, proceed with 
installing the program. For further details, see Installing PartMaker 
Modeling. 

For details on the default installation paths for your operating 
system, see Windows 7 default installation paths (see page 9). 

If you want to install the shared database and parts directory onto a 
different drive or directory, you need to make sure the paths have 
been set in the registry before installing. For further details, see 
Setting the shared database on a different drive using the Registry 
Editor (see page 11). 
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Setting the shared database on a different drive using the Registry 
Editor 

WARNING 

 This section should only be attempted if you are familiar with 
using the regedit command to edit the registry. 

Incorrectly editing the registry may severely damage your 
system. At the very least, you should back up any valued data 
on the computer before making changes to the registry. 

 This operation should be completed before installing 
PartMaker Modeling. 

If you already have PartMaker Modeling installed, this version 
should be uninstalled before completing the steps shown in 
the next section. You will also need to manually delete the 
shareddb and parts directories. 

Setting the shareddb on a different drive 
This is a guide to setting the shared database database or parts 
directory on a different drive using the Registry Editor.  

 The location of the shareddb does not need to be changed for 
PartMaker Modeling to work. Skip this section unless you 
specifically want to set the shared database database or parts 
directory on a different drive and you are familiar with the 
regedit command. 

The installation path examples given use D: as the installation drive. 
The drive on your system may be different. 

If the shared database is intended to be shared, for example on a 
network, the path should include the following: 

\\name of machine\location of parts directory or shareddb\ 
The following are some example paths: 

\\server1\d\dcam\parts\ 
\\server1\d\dcam\shareddb\ 

1 In the Registry Editor, open the following directory to see if a 
Delcam branch exists: 

HKEY_LOCAL_MACHINE\SOFTWARE 

If you are using a 64-bit machine, open the following directory: 

HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432NODE 

If a Delcam branch exists continue with the following 
instructions. 



 

12 • Getting Started with PartMaker Modeling 2015 PartMaker Modeling 2015 Getting Started  

If a Delcam branch does not exist, create a new key in 
HKEY_LOCAL_MACHINE\SOFTWARE and call it Delcam.  

 
Continue with the following instructions: 

2 Open HKEY_LOCAL_MACHINE\SOFTWARE\Delcam and create a 
key called config. 

3 Open HKEY_LOCAL_MACHINE\SOFTWARE\Delcam\config and 
create a key called node. 

4 Open HKEY_LOCAL_MACHINE\SOFTWARE\Delcam\config\node 
and create a new string called parts. 

5 Set the Value data of parts to be, for example 
\\server1\d\dcam\parts\ 

6 Open HKEY_LOCAL_MACHINE\SOFTWARE\Delcam\config\node 
and create a new string called shareddb. 

7 Set the Value data of shareddb to be, for example 
\\server1\d\dcam\shareddb\ 

8 Exit the Registry Editor and proceed with installing the program. 
For further details, see Installing PartMaker Modeling. 

 

Location of user-specific files 
The location of the user-specific files (for example custom toolbars 
and shortcuts) is structured so that the same location will be used 
for all future versions. These files are stored in xxxx\PowerSHAPE 

where xxxx is: 
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C:\Users\[username]\AppData\Roaming    
the location that is indicated by your HOME variable.  

 

Changing the drawing standard 
The shared database contains details of all the drawing standards 
supported by PartMaker Modeling. One of these is set up as 
standard, so that every CAD model created will have this standard 
set by default. The standard contains the units that you are working 
in. So, for example, if you work to ANSI standard in inches it is 
important to choose the correct standard.  

When you install PartMaker Modeling, you are asked to select your 
unit of working. If you select Inch (the default setting), the ANSI 
drawing standard is applied. 

To change the default drawing standard on installation 
You can change the default drawing standard when you are 
installing PartMaker Modelingusing the Install Wizard (see page 5). 

To change the default drawing standard on an existing installation 
a Run the Install Wizard (see page 5) to change the default 

standard for an existing installation or computer that has had 
a previous version of PartMaker Modeling installed. 

 

Upgrading an existing version of PartMaker Modeling 
If you have an older version of the product and wish to install 
Delcam PartMaker Modeling 2015, insert the DVD into the disk drive 
and follow the installation instructions. The installation wizard will 
guide you through installing the new version. 

 

Installation problems 
Installation problems usually only happen if you attempt to bypass 
the installation process: For example, copying files manually rather 
than using the installation wizard. The installation wizard does extra 
work, such as setting up registry entries and should always be used 
in preference to manual copying. 

If you experience problems with your installation try uninstalling 
Delcam PartMaker Modeling and re-installing it using the installation 
wizard. 

If you still experience problems contact your sales agent. 
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General Installation Information 
 All programs appear as separate products in Start > Control Panel 

> Add or Remove Programs. 

 Shortcuts are created on the desktop and the other options are 
added to the Start menu. 

 

Model version 
All models opened in PartMaker Modeling 2015 use model version 
41. When PartMaker Modeling 2015 is installed and run for the first 
time, the initialisation work will open the latest 
NEW_MODEL_MASTER_XX you have (where XX <41) and save it as 
NEW_MODEL_MASTER_41. 

 

Uninstalling PartMaker Modeling 
1 To uninstall PartMaker Modeling select one of the following: 

 Start > Control Panel > Add or Remove programs (XP systems) 

 Computer > Uninstall or change a program (Vista or Windows 7 
systems) 

 From the Start menu select All Programs and use the sub-
menus to. select Delcam > PowerSHAPE PowerSHAPE 2015 > 
Uninstall PowerSHAPE2015. 

2 Select Delcam PowerSHAPEXXXXX (where XXXXX is the product 
version) and select Remove. 
This will remove Delcam PowerSHAPE only. Any sub-products will 
need to be removed separately. 

 The shareddb directory andthe parts directory are NOT 
removed. They are left permanently on the machine. 

The PAF file directory will also be unaffected. 
 

Starting PartMaker Modeling 
To start PartMaker Modeling: 

1 From the Start menu select All Programs and use the sub-menus 
to.  

a Select Delcam. 

b Select PowerSHAPE. 

c Select the PowerSHAPE 2015. 

d Select Modeling 2015. 
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Alternatively, double-click the PartMaker Modeling icon on your 

desktop  

After a brief wait, the program starts up. A new large window 
appears on the screen.  

This is PartMaker Modeling. 
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What is the Browser? 
The Browser is an additional support window in PartMaker Modeling 
where the HTML help, interactive help, and tutorials are displayed. 

 

Opening the Browser 
To open the Browser select one of the options from the Help menu, 
shown below. 

 
You can also select Browser from the Windows option on the View 
menu. 
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Using the Browser 
Navigation buttons are provided to assist you find the help you 
need. 

 
Click on a tab in the Browser to display the information: 

 

 Home — This displays a welcome information page for the 
PowerSHAPE product you are using. 

 Learning Assistant — This tab is inactive if a Delcam Toolmaker 
wizard is running. For further information on the Learning Assistant 
see Getting Help with PartMaker Modeling (see page 18). 

 Tutorial — For further information see Getting Help with 
PartMaker Modeling (see page 18). 

 Reference help — For further information see Getting Help with 
PartMaker Modeling (see page 18). 

 Delcam.com browser. 

 Delcam PS-Team — This is currently in development. 

 Delcam-Toolmaker — This tab is active only when a Delcam 
Toolmaker wizard is running in the Browser. 

 

Closing the Browser 
To close the Browser click the cross shown below: 
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Getting Help with PartMaker Modeling 
You can get help in one of the following ways: 

 Tooltips (see page 18) 

 Context-sensitive help (see page 18) 

 Status bar help (see page 18) 

 Reference help (see page 19) 

 Tutorials 

 Learning assistant (see page 19) 
 

Tooltips 
Placing the cursor over a button displays a brief description of the 
function of the button. 

 
 

Context-sensitive help 
Use Shift + F1 to access context-sensitive help on buttons. When 

you hold down the Shift key and press F1,  is displayed. Move 
this to the relevant button and click, for example: 

 

 Context-sensitive help is available on toolbar buttons and 
buttons on a flyout, but not on the flyout button itself. 

 

Status bar help 
The status bar displays information when you place the cursor over 
a button. 
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Reference help 
1 Select Help to display the options. 

 
2 Select Contents And Index to display the full Reference Help in the 

Browser. 

3 You can change the display by selecting the following: 

 Displays the help in the full width of the Browser. 

 Displays the Contents or Index. 
 

Learning Assistant 
Start the Learning Assistant in one of the following ways to display 
the options in the Browser: 

 Select Learning Assistant from the Help menu. 

 Select  tab in the Browser. 

 
The Learning Assistant explains the steps required to use each main 
function. Click on the steps to display drop-down interactive help to 
guide you through the tasks.  
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The help is context-sensitive and updates automatically as you use 
the software. 

 
Full information is available in the Getting Started section of the on-
line Reference Help. 

 

Using the Learning Assistant to create a single line 
1 Select Creating Objects to display the menu. 

 

2 Click Lines . 
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3 Click Single Line . You can get help on creating a single line 
by clicking How? 

4 Create the line in the graphics window. 

5 Click Exit line creation  to end line creation. 

The Learning Assistant displays Editing Lines options. 
 

Example data 
You can import sample data to use in PartMaker Modeling. The 
examples that are supplied are all deliberately simple models to 
make it easy for you to experiment with them.  

1 From the File menu, select Examples. 

2 Select a file and the data is imported. 

In some cases, a dialog is displayed to use with the data. 

The following example data is available: 

 Concept aircraft 

 Perfume bottle 

 Jigsaw piece 

 Milk bottle 

 Shoe sole 
 

Further information 
For details of the complete functionality, refer to the complete user 
documentation that is available in PartMaker Modeling. You can 
access these from the Help menu in PartMaker Modeling. 

 

Training courses 
Training courses are available. Please contact your Delcam Sales 
Partner for further details. 
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Tutorial - Designing a plate 
Use this tutorial to create a solid model of a plate by: 

 checking the drawing standards of the model  

 creating and editing lines  

 creating a composite curve  

 creating a solid extrusion from the composite curve  

 creating solid cut features  

 creating solid hole features 

 creating solid chamfers 

 changing the material of the model  
 

1. Check the tolerances of the models 
This tutorial is going to be completed using the ANSI drawing standard. 

 Standard = ANSI 

 Length = inches 

 Angle = degrees 

 Volume = ounces(US, liquid) 

 

1 Click Open new model . 

An empty model is opened and the Standard should be set to 
ANSI. 

2 Click Tools > Options from the Main menu. 

3 Click Units and Tolerances. 
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The values should be as displayed below: 

 
4 If the values aren't correct change to match the above image. 

General tolerance = 0.0001. 

5 Click View > Shading. 
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The values should be as displayed below: 

 
6 If the values aren't correct change to match the above image. 

Tolerance for shading = 0.001. 

7 Click Force Regeneration of Triangles. 

8 Click OK. 
 

2. Create a workplane 

1 Click Workplane . 
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2 Click Single workplane . 

 
3 Click in the Command Input box in the Status Bar and type: 

0 0 0 

 
4 Press Enter. 

 
5 Click anywhere in the graphics window to deselect the model. 

 

3. Create  lines 

1 Click Line . 
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2 Click Continuous Lines . 

 
3 Click in the Command Input box in the Status Bar and type: 

4  0  0 

4 Press Enter. 
4  3  0 

5 Press Enter. 
0  3  0 

6 Press Enter. 

7 Click Select . 
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8 Click Resize to Fit . 

 

9 Click Line . 

 

10 Click Continuous Lines . 

 
11 Click in the Command Input box in the Status Bar and type: 

0.5  0  0 

12 Press Enter. 
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0.5  2  0 

13 Press Enter. 
3  2  0  

14 Press Enter. 
3  0  0 

15 Press Enter. 

16 Click Select . 

17 Click anywhere in the graphics window to deselect the model. 

18 Your model should look like the one shown below: 

 
 

4. Create arcs 

1 Click Arc . 
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2 Click Create a Full Arc . 

 
3 Click in the Command Input box in the Status Bar and type: 

r 1 

4 Press Enter.  
3  2  0 

5 Press Enter. 
r 0.5 

6 Press Enter. 
3  2  0 

7 Click Select . 

8 Click anywhere in the graphics window to deselect the model. 
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Your model should look like the one shown below: 

 
 

5. Limit wireframes - 1 

1 Click Show General Edits Options . 
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 Keep clicking the button until the toolbar shown below is 
displayed. 
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2 Click Interactively Limit Wireframes .  

 
3 Click the positions shown below: 
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4 Click the positions shown below: 

 

5 Click Select . 

The lines and arcs are trimmed. 

 
 

6. Create fillet arcs - 1 

1 Click Arc . 
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2 Click Create a fillet arc . 

 
3 Click in the Command Input box in the Status Bar and type: 

r 0.25 

4 Press Enter. 
5 Click the pairs of lines and arcs shown below: 

 

6 Click Select . 

7 Click anywhere in the graphics window to deselect the model. 
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Your model should look like the one shown below: 

 
 

7. Mirror the wireframes 

1 Click Quick select all wireframes . 

 

 

2 Click Show General Edits Options . 
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 Keep clicking the button until the toolbar shown below is 
displayed. 
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3 Click Mirror/symmetrise object . 

 
4 Click Create multiple copies of the selected items . 

 
A preview of the mirror is drawn on the model. 
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5 Click Apply . 

6 Click Dismiss . 

7 Click Resize to Fit . 

8 Click anywhere in the graphics window to deselect the model. 

The geometry is mirrored across the 3 planes. 

 
 

8. Create a full arc - 1 

1 Click Arc . 

 

2 Click Create a Full Arc . 
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3 Click in the Command Input box in the Status Bar and type: 
r 1 

4 Press Enter. 
0  0  0 

5 Press Enter. 

6 Click Select . 

7 Click anywhere in the graphics window to deselect the model. 

Your model should look like the one shown below: 

 
 

9. Create fillet arcs  - 2 

1 Click Arc . 
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2 Click Create a fillet arc . 

 
3 Click in the Command Input box in the Status Bar and type: 

r 0.25 

4 Press Enter. 
5 Click the pairs of lines and arcs shown below: 

 

6 Click Select . 

7 Click anywhere in the graphics window to deselect the model. 
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Your model should look like the one shown below: 

 
 

10. Limit wireframes - 2 

1 Click Show General Edits Options . 
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 Keep clicking the button until the toolbar shown below is 
displayed. 
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2 Click Interactively Limit Wireframes .  

 
3 Click the positions shown below: 

 

4 Click Select . 

5 Click anywhere in the graphics window to deselect the model. 
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Your drawing should look as follows. 

 
 

11. Create a full arc - 2 

1 Click Arc . 

 

2 Click Create a Full Arc . 

 
3 Click in the Command Input box in the Status Bar and type: 

r 0.125 

4 Press Enter. 
0.650  0  0 



 

PartMaker Modeling 2015 Getting Started Getting Started with PartMaker Modeling 2015 • 45  

5 Press Enter. 

6 Click Select . 

 
 

 

12. Copy and rotate the arc 

1 Click Show General Edits Options . 
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 Keep clicking the button until the toolbar shown below is 
displayed. 
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2 Click Rotate items . 

 
The Rotate toolbar is displayed. 

 

3 Click Copy the selected items . 

4 Enter 7 in Copies. 

5 From the Angle drop-down list, click 45. 
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A preview of the rotation is drawn on the model. 

 
6 Click Apply . 

7 Click Dismiss . 

8 Click Select . 

9 Click anywhere in the graphics window to deselect the model. 
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13. Create composite curves 

1 Click Create a Composite Curve by tracing . 

 
The Create Composite Curve toolbar is displayed. 
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2 Click the line shown below: 

 
A composite curve is traced around the closed outline of the 
model. 

 
3 Click Save . 
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4 Click Eject . 

 
5 Hold down the ALT key and click the left mouse button, as shown 

below.  

 This is the shortcut for creating a composite curve. 

 
6 Click anywhere in the graphics window to deselect the model. 
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14. Create a solid extrusion 
1 Click the curve: 

 

2 Click Solid . 

 

3 Click Solid Extrusion . 
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4 Double click the extruded solid. 

 
The Extrusion dialog is displayed. 

5 Enter -1 in Length of Direction 1. 

 
6 Click OK. 
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7 Click View ISO1 .  

 
8 Click anywhere in the graphics window to deselect the model. 
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15. Create solid cut features 

1 Click Quick select all wireframes . 

 
All the wireframe is selected. 

 
2 Hold down the Control key and click the two composite curves, as 

shown below: 

 

3 Click Feature . 

 



 

56 • Getting Started with PartMaker Modeling 2015 PartMaker Modeling 2015 Getting Started  

4 Click Create Solid Cut Feature . 

 
The Solid cut dialog is displayed.  

5 From the Type drop-down list, click Through. 
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Preview graphics are drawn on the model. 

 
6 Click Apply. 

 
7 Click the composite curve. 
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8 Hold down the Shift key and click the composite curve. 

 
9 Click Add the currently selected sketch . 

10 From the Type drop-down list, click Blind. 

11 Enter a Depth of 0.5. 

 
12 Click OK. 
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Pockets have been cut into the solid. 

 
13 Click anywhere in the graphics window to deselect the model. 

 

16. Create solid chamfer features 

1 Click Feature . 

 

2 Click Create solid fillet  using the right mouse button 
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3 From the flyout click Create solid chamfer . 

 
The Chamfer dialog is displayed. 

 
4 Enter a Distance of 0.050. 
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5 Hold down the Shift key and click the 1 diameter cuts. 

 
6 Click Apply. 
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7 Hold down the Shift key, click the edges of the other cuts  and 
the edge of the extrusion. 

 
8 Click OK. 

9 Click anywhere in the graphics window to deselect the model. 

 
 

17. Create solid tapped holes 

1 Click Feature . 
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2 Click Create a Hole . 
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The Hole dialog is displayed. 

 
3 Click in the Command Input box in the Status Bar and type: 

0  2.5  0 

4 Press Enter. 
5 Click Hole category of General Machining (ISO) from the drop-down 

list. 

6 Click Use of Tapped from the drop-down list. 

7 Click Standard of Unified National Course from the drop-down list. 

8 Click Size of 1/2 inch from the drop-down list. 
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9 Enter 0.5 in Set tapping depth.  

 
10 Click Chamfers. 

The Chamfer dialog is displayed. 

11 Enter 0.05 to Set the hole base chamfer size. 

 
12 Click OK. 
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13 Click Apply. 

 
14 Click in the Command Input box in the Status Bar and type: 

0  -2.5  0 

15 Press Enter. 
16 Click OK. 

17 Click anywhere in the graphics window to deselect the model. 

 
 

18. Change the material 
1 Click the solid. 

2 From the main menu, click Format. 
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3 Click Materials... 

 
The Material Selection dialog is displayed. 

 
4 Do the following: 

 From the Material type drop-down list, click Metal. 
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 Click Steel. 

 
5 Click OK. 

6 Click anywhere in the graphics window to deselect the model. 
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19. Change the shading option 

1 Click Shaded View , using the right mouse button. 

 

2 From the flyout, click Enhanced Shading  
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3 Your model should look like the one shown below: 
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Tutorial - Designing a pin 
Use this tutorial to create a solid model of a pin using by: 

 checking the drawing standards of the model  

 creating and editing lines  

 creating a composite curve  

 creating a solid revolution from the composite curve  

 creating a wireframe polygon  

 creating a solid boss feature  

 creating a solid hole feature 

 creating solid chamfers 

 changing the material of the model  
 

1. Check the tolerances of the models 
This tutorial is going to be completed using the ANSI drawing standard. 

 Standard = ANSI 

 Length = inches 

 Angle = degrees 

 Volume = ounces(US, liquid) 

 

1 Click Open new model . 

An empty model is opened and the Standard should be set to 
ANSI. 

2 Click Tools > Options from the Main menu. 

3 Click Units and Tolerances. 
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The values should be as displayed below: 

 
4 If the values aren't correct change to match the above image. 

General tolerance = 0.0001. 

5 Click View > Shading. 
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The values should be as displayed below: 

 
6 If the values aren't correct change to match the above image. 

Tolerance for shading = 0.001. 

7 Click Force Regeneration of Triangles. 

8 Click OK. 
 

2. Create a workplane 

1 Click Workplane . 

 
2 Click in the Command Input box in the Status Bar and type: 
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0 0 0 

 
3 Press Enter. 

 
4 Click anywhere in the graphics window to deselect the model. 

 

3. Create lines 

1 Click Line . 
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2 Click Continuous Lines . 

 
3 Move the cursor over the axis of the workplane. 

4 When Key-point displays, click the left mouse button. 

 
This creates the first point of the line. 

5 Click in the Command Input box in the Status Bar and type: 

0  0.025  0 

6 Press Enter. 
0.23  0.025  0 

7 Press Enter. 
0.23  0.0437  0 

8 Press Enter. 
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9 Click Resize to Fit . 

 
0.76  0.0437  0 

10 Press Enter. 
0.76  0.115  0 

11 Press Enter. 
1  0.115  0 

12 Press Enter. 

 
1  0.104  0 

13 Press Enter. 
1.1  0.104  0 

14 Press Enter. 
1.1  0  0 

15 Press Enter. 

16 Click Select . 

17 Click Resize to Fit . 
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Your model should look like the one shown below: 

 
18 Click anywhere in the graphics window to deselect the model. 

 

4. Create a chamfer 

1 Click Line . 

 

2 Click Create a single line . 
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3 Move the cursor over the end of the line. When End displays, 
click the left mouse button. 

 
4 Move the cursor around the model. 

Construction lines and dimensions activate and display. 

 
5 When an angle of 60 is displayed and the line crosses the 

existing line, click the left mouse button. 

 

6 Click Select . 
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7 Click anywhere in the graphics window to deselect the model. 

 
 

5. Limit the lines 

1 Click Show General Edits Options . 

 Keep clicking the button until the toolbar shown below is 
displayed. 
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2 Click Interactively Limit Wireframes .  

 
3 Click the three positions shown below: 

 

4 Click Select . 



 

PartMaker Modeling 2015 Getting Started Getting Started with PartMaker Modeling 2015 • 81  

5 Click anywhere in the graphics window to deselect the model. 

 
 

6. Create a composite curve 

1 Click Curve . 

 

2 Click Create a Composite Curve by tracing . 
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The Create Composite Curve toolbar is displayed. 

 
3 Click the line shown below: 

 
4 Click Save . 

5 Click Eject . 

The lines are combined into one composite curve. 

 
6 Click anywhere in the graphics window to deselect the model. 

 

7. Create a solid revolution 
1 From the Status Bar at the bottom of the screen, click the X 

principal plane. 

  



 

PartMaker Modeling 2015 Getting Started Getting Started with PartMaker Modeling 2015 • 83  

2 Click the composite curve. 

 

3 Click Solid . 

 

4 Click Solid Revolution . 

 
A solid revolution is created from the composite curve. 
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5 Click anywhere in the graphics window to deselect the model. 
 

8. Create a wireframe polygon 

1 Click View ISO1 using the right mouse button .  
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2 From the flyout, click View ISO2 . 

 

 

3 Click Line . 

 

4 Click Create a polygon . 

 
5 Enter 6 in Number of sides. 
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6 Click Create composite curve. 

 
7 From the status bar, click Open the Position dialog . 

 
The Position dialog is displayed. 

 
8 Click Lock Y . 
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9 Click Lock Z . 

 
10 Click the position shown below; 

 
11 Click Apply. 
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12 Enter  0.07275 in Y. 

 
13 Click OK. 

14 Click OK. 

A polygon is created on the end face of the revolution. 
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9. Create a solid boss feature 

1 Click Feature . 

 

2 Click Create solid boss feature . 

 
The Boss dialog is displayed. 
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3 Enter a Height of 0.100. 

 
4 Click OK. 

5 Click Select . 

 
6 Click anywhere in the graphics window to deselect the model. 

 

10. Create a solid tapped hole feature 

1 Click Feature . 
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2 Click Create a Hole . 
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The Hole dialog is displayed. 

 
3 When Face -centre displays click the left mouse button. 

 
4 Click Hole category of General Machining (ISO) from the drop-down 

list. 

5 Click Use of Tapped from the drop-down list. 

6 Click Standard of Unified National Fine from the drop-down list. 
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7 Click Size of No. 0 from the drop-down list. 

 
8 Click Chamfers. 

The Chamfer dialog is displayed. 

9 Enter 0.01 to Set the hole base chamfer size. 

 
10 Click OK. 
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11 Click OK. 

 
 

11. Create solid chamfer features 

1 Click Feature . 

 

2 Click Create solid fillet  using the right mouse button 
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3 From the flyout click Create solid chamfer . 

 
The Chamfer dialog is displayed. 

  
4 Enter a Distance of 0.003. 
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5 Click View ISO1 .  

 
6 Click the .050 diameter face. 
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7 Click Apply. 

 
8 Enter a Distance of 0.005. 

9 From the flyout, click View ISO2 . 

 
10 Hold down the Shift key and click all the edges of the hexagon 

face, shown below; 

 
11 Click OK. 
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12 Click anywhere in the graphics window to deselect the model. 

 
 

12. Change the material 
1 Click the solid. 

2 From the main menu, click Format. 
3 Click Materials... 
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The Material Selection dialog is displayed. 

 
4 Do the following: 

 From the Material type drop-down list, click Metal. 
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 Click Steel. 

 
5 Click OK. 

6 Click anywhere in the graphics window to deselect the model. 
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13. Change the shading option 

1 Click Shaded View , using the right mouse button. 

 

2 From the flyout, click Enhanced Shading  
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3 Your model should look like the one shown below: 
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Basic modelling concepts 
Use the following sections to find information on basic modelling 
concepts: 

PartMaker Modeling (see page 103) 

User interface (see page 106) 

Intelligent Cursor (see page 147) 

Models (see page 161) 

The coordinate system (see page 200) 

Calculator and measuring 

Objects 

Parameters 
 

PartMaker Modeling 
PartMaker Modeling enables you to design complex shapes using 
the powerful 3D modelling tools in PowerSHAPE. It is ideally suited 
to preparing models for manufacture; either from scratch or by 
editing a part-complete model, imported from another CAD system. 

PartMaker Modeling supports standard Microsoft Windows 
functionality such as cut, copy and paste, drag-and-drop, and 
rubber-band editing of objects. You can also edit any modelling 
object (such as line, arc, curve) by right-clicking and using the 
context menus. The menus contain all the main operations available 
for the selected object. 

 

Ease-of-use 
Ease-of-use is central to PartMaker Modeling: 

 You can create most objects with one or two mouse clicks. 

 You can dynamically drag dimensions using an object's editing 
handles to create the desired size and shape. 

 You can also enter discrete dimension values using dialogs. 

 The Intelligent Cursor generates construction lines and 
highlights objects’ snap points and tangencies as the cursor 
passes over an object. 
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Modelling for manufacture 
PartMaker Modeling simplifies the addition of manufacturing 
features such as: 

 chamfers. 

 fillets. 

 split surfaces. 

 draft surfaces. 

The software is designed to handle a wide variety of parts and to 
deal with issues of modeling for manufacture. This ensures that the 
part designs that you receive, are easy and productive to 
manufacture, irrespective of the quality and complexity of the 
design. 

 

Surfacing tools 
PartMaker Modeling offers sophisticated surfacing tools, including 
surface creation from curves and dynamic surface manipulation, 
allowing quick and easy creation and subsequent modification of the 
CAD surfaces. 

 

Starting PartMaker Modeling 
To start PartMaker Modeling: 

1 From the Start menu select All Programs and use the sub-menus 
to.  

a Select Delcam. 

b Select PowerSHAPE. 

c Select the PowerSHAPE 2015. 

d Select Modeling 2015. 

Alternatively, double-click the PartMaker Modeling icon on your 

desktop  

After a brief wait, the program starts up. A new large window 
appears on the screen.  
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This is PartMaker Modeling. 
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User interface 
Use the following sections to find information on the user interface: 

Screen layout (see page 106) 

Menus overview (see page 107) 

Using the menus (see page 107) 

Toolbars overview (see page 110) 

Using the toolbars (see page 111) 

Status bar overview (see page 125) 

Dialog overview (see page 128) 

Using the mouse (see page 131) 

Using the keyboard (see page 143) 

PartMaker Modeling Graphics area (see page 143) 
 

Screen layout 

 
PartMaker Modeling uses a Windows-style interface with menus and 
toolbars. The areas of the screen are identified as follows: 

 Menu 

 Main toolbar 

 Sub-toolbars — When you select a button on the Main toolbar, in 
most cases an associated sub-toolbar is displayed. 
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 Graphics area 

 Views toolbar 

 Layers toolbar 

 Status bar 
 

Using PartMaker Modeling menus 
You can control most functionality in PartMaker Modeling on the 
menus. These expand from the menu bar that is permanently 
displayed across the top of the software. In most cases, 
functionality that is available on the menus is also available from 
one of the toolbars. 

Clicking on a menu option opens the selected menu (see page 107). 
This contains commands and further sub menus. Options are 
dimmed when not available. 

An arrow  icon shows that a menu option has a sub-menu. 

Using the keyboard 
 Navigate around the menus with the arrow keys to pre-select 

items.  

 Press Enter to select an item. 

 Press Esc to close the menus. 

 Use keyboard shortcuts to open menus. Hold down the Alt key 
and press an appropriate underlined character for the menu. For 
example, Alt+E opens the Edit menu. Combinations of keys are 
indicated using the + key. For example Alt+F+S is the same as 
selecting File > Save.  

 

PartMaker Modeling menus 
Use the following links for details of the tools and functions available 
from the menus. 
File Controls model file related tasks such as Open, 

Save, Close, and Delete.  

Edit Provides the Undo/Redo commands and tools for 
handling the clipboard such as Cut, Copy, and 
Paste. It also provides general editing tools 
applicable to most object types, such as Mirror 
and Rotate. 
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View Controls how the models are displayed in the 
graphics windows, providing a range of pre-set 
views. Select View Layout to display the View Edit 
dialog, which enables you to configure the view. 
You can display toolbars using View Toolbars. 

Object Provides tools for creating all the available object 
types, such as Workplane, Surface, and Line. The 
menu option for each type has a submenu 
showing the available creation methods for each 
one.  

Format Provides options to change line types, colours, 
and to assign display levels. Use levels to reduce 
screen clutter on complex models. 

Tools Provides miscellaneous tools including model 
fixing and model analysis. You can also set your 
preferences on how the program operates using 
Options.  

Macro Provides the controls for creating a macro of your 
modelling actions. The macros can be played back 
using Run.  

Module Use this menu to view and open the modules that 
you can run while using PartMaker Modeling.  

Window Lists all the open graphics windows and enables 
you to manage them. 

Help Enables you to access help and the Delcam 
websites, and check for updates. You can also 
view the software version and release details in 
the About dialog. 

  

Popup 
menus 
(see 
page 
108) 

Right-click an object to display a menu. This 
menu includes the commands appropriate for 
editing the object. Right clicking within a graphics 
window, but away from any objects displays a 
View menu.  

 
 

Popup menus 
Display popup menus by right-clicking in the graphics window.  

The menu options displayed correspond with what you click on.  
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If you right-click an object, a menu displays the common edit 
options for that object. At the top of the menu, the type, name of 
the object, and the level are displayed. 

 
Right-click in an empty area of the graphics window to display the 
View menu. This menu provides the shading options from the View 
menu and other common options. 
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If a mixture of objects is selected and you right-click one of these 
selected objects, the Selection menu is displayed. This menu 
provides some common edit commands. 

 
 

Toolbars overview 
Toolbars are areas of the screen that contain buttons. Click on 
buttons using the mouse to activate the functionality. In most 
cases, toolbar buttons provide shortcuts to options on the menus. 

The Main toolbar is always visible and is displayed across the top. 

 
The General Edits toolbar is displayed down the side by default.  

 
This is also where the following toolbars are displayed when you 
select a corresponding object, menu item, or button. 
 General Edits 
 Model Analysis 
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 Model Fixing 
 Object Creation 

You can: 

 Display or hide some toolbars according to the functions in use. 
For example the Surface Edit toolbar and the Curve Edit toolbar, 
shown in the image below, are displayed automatically when 
corresponding objects are selected. 

 
 Expand some toolbars using the flyout (see page 124) button to 

display similar items or functions grouped together. 

 Pin (see page 112) some toolbars anywhere on the screen, or 
dock them onto another toolbar using their pins to keep them 
visible when you display another toolbar. 

 Create your own toolbars (see page 114) to contain your 
favourite buttons, menu items, or functions. 

 Display a toolbar as follows: 

1 Right-click on an empty space on any toolbar to display a 
menu of available toolbars. 

2 Select the toolbar that you wish to display from the menu. 

 Display large or small buttons on the toolbars using the Toolbars 
options page of the Options dialog. 

 Reverse the display of the (view and editing) toolbars using the 
Toolbars options page of the Options dialog. 

 Remove some toolbars from the screen by clicking the Close   
button on the toolbar.  

 

Using the toolbars 
To use a toolbar: 

1 Position the cursor over a button. 

2 Left-click the button to activate the function. 

The buttons on toolbars can include: 

 an icon to represent the function  

 a text description 

 a shortcut to a Main menu item 

 flyouts (see page 124) to secondary toolbars. 

Some toolbars change according to the function selected, such as 
the General Edit toolbar. These have specific purposes and do not 
necessarily duplicate main menu options. 
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Pinned toolbars 
A pinned toolbar is always visible. You can move and reposition it 
anywhere on the screen, or dock it with another toolbar.  

Toolbars that are in their default location have the unpinned  
icon. 

 
You can pin the following toolbars: 
 General Edit 
 Model Analysis 
 Model Fixing 

 

Using pinned toolbars 
If you have not used pinned toolbars before, pinned toolbars remain 
in their default location in the software.  

If you have already pinned a toolbar, it displays at its last pinned 
position. 

You can: 

 Reposition a pinned toolbar in the graphics area (see page 113). 

 Dock a pinned toolbar with another toolbar (see page 113). 
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Repositioning a pinned toolbar 
To reposition a pinned toolbar in the graphics area: 

1 Click the pin  on the toolbar you wish to move, for example 
the General Edits toolbar. The whole pin is displayed only when 
the toolbar is in its default position. 

 
The pin icon changes to pinned , the toolbar undocks and 
displays in the graphics area ready to be repositioned.  

2 Click on the title bar of the toolbar and drag it to the required 
position in the graphics area.  

3 Click the pin again to return the toolbar automatically to its 
default location. The pin changes back to unpinned . 

The next time you click the pin on the toolbar, the pinned toolbar 
is displayed automatically in the last pinned position. 

 

Docking a pinned toolbar 
To dock a pinned toolbar with another toolbar: 
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1 Click the pin  button on the toolbar you wish to move, for 
example the General Edits toolbar. The whole pin is displayed 
only when the toolbar is in its default position. 

 
The pin icon changes to pinned , the toolbar undocks and 
displays in the graphics area ready to be repositioned.  

2 Click on the title bar of the toolbar and drag it over the edge of 
another toolbar. It snaps automatically into the toolbar area. You 
can also dock a toolbar at the edge of the screen. 

3 Click the pin again to return the toolbar automatically to its 
default location. The pin changes back to the unpinned  
icon. 

The next time you click the pin on the toolbar, the pinned toolbar 
is displayed automatically in the last pinned position. 

 

User-defined toolbars 
A user-defined toolbar is a toolbar that you create to contain your 
favourite buttons, menu items, or functions.  

 Your customised toolbar can contain both menu and toolbar 
items as well as command lines.  

 You can send your user-defined toolbar to other users. 



 

PartMaker Modeling 2015 Getting Started Getting Started with PartMaker Modeling 2015 • 115  

 You can group or separate options on your toolbar using the 
Customise dialog (see page 116).  

 You can add your own icons and you can customise buttons to be 
added to your toolbar using the Customise Picture dialog (see 
page 121). 

Using your personal toolbars 
Use the following sections to create and use your own toolbars: 

Create a user-defined toolbar (see page 115) 

Edit a user-defined toolbar  (see page 118) 

Display an existing user-defined toolbar (see page 118) 

Customise buttons for user-defined toolbars (see page 118) 

Sharing a user-defined toolbar and custom buttons (see page 
123) 

 

Creating a toolbar 
To create a toolbar: 

1 Right-click on an empty section of any toolbar and select 
Customise toolbar from the menu.  

 
The Customise dialog (see page 116) is displayed. 

2 On the Toolbars tab define your toolbar and select the items you 
want to add.  

3 Click Add to add each new item to the toolbar. 

4 Use the buttons on the dialog to order and organise the toolbar 
items. 

The example below describes adding a block primitive from the 
surface creation toolbar to a new custom toolbar. 
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 Select a toolbar and enter a new name, such as Surface items. 

 Select the Button Size size from: 
 Large 
 Small 
 As Options Page 

 For the Type, select Toolbar. 

 Select the Menu/Toolbar that contains the item you want to add 
to your toolbar, such as Surface/Solid Creation. 

 Select the Item to add, such as the Block Primitive  button. 

 Click Add to add the block to your toolbar.  

 Added items, for example the Block Primitive button, are 
displayed in the added items list.  

 Click OK. 

 
 

Customise dialog - Toolbars 
Use this dialog to define up to four customised toolbars. 

 
Toolbar — Enter a new name for a new toolbar or select an existing 
user-defined toolbar from the list. You can define up to four 
toolbars. 

Type — Select from the following: 
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 Menu — Select this option to add a menu item to your toolbar 
and select the menu from the Menu/Toolbar list. 

 Toolbar — Select this option to add a toolbar item to your toolbar 
and select the toolbar from the Menu/Toolbar list. 

 Command — Select this option to enter your own Command and 
Description to be added to your toolbar. 

Menu/Toolbar — Select the menu or toolbar that contains the option 
you want to add to your new toolbar. 

Item — Select the menu option or toolbar button that you want to 
add to your new toolbar. 

Add Group — Click this button to add a group marker. The group 
marker  icon is displayed in the list of added items at the right of 
the dialog. A group marker shows the beginning of a group of 
buttons, menu items, or commands. On the toolbar, the group 
marker is a toggle button: 

 Hide Group — Click this button to contract the items in the 
group. 

 Show Group — Click this button to expand the items in the 
group. 

Add Separator — Click this buttom to add a separator marker to 
divide up your toolbar items. The separator marker  icon is 
displayed in the list of added items at the right of the dialog. 

Add Gap — Click this button to add a small space between items on 
the toolbar. A gap is displayed in the list of added items at the right 
of the dialog. 

Add — Click this button to add the selected Item to the toolbar. The 
item is displayed in the list of added items at the right of the dialog. 

 Drag Crosshairs — Click and hold the mouse button and drag the 
crosshairs over a toolbar button. The button is added automatically 
to custom toolbar and is displayed on the dialog. 

 Remove — Click this button to remove the item selected in the 
added items list from your toolbar. 

 Move the item up the menu — Click this button to move the 
selected item up the order of items on the toolbar. 

 Move the item down the menu — Click this option to move it down 
the order of items on the toolbar. 
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 Change button icon — Click this button to change the icon for the 
button selected in the added items list. The Customise Button dialog 
(see page 120) is displayed. 

 

Edit a user-defined toolbar 
1 Select Customise toolbar from the popup menu, displayed when 

you right-click on an empty section of any toolbar. 

 
2 Select the Toolbars tab on the Customise dialog (see page 116). 

3 Select the toolbar you want to edit from the Toolbar drop-down 
list. 

4 Make your changes. 

5 Click OK. 
 

Displaying an existing user-defined toolbar 
1 Select View > Toolbars > Custom. 
2 Select the toolbar you want to display. 

 

Customising buttons for user-defined toolbars 
When you are creating or editing a user-defined toolbar, you can 
edit and customise buttons. You can: 

 customise an existing button on a user-defined toolbar (see page 
119). 

 create a new button to be added to the toolbar (see page 119). 

 select a new button on the Customise Button dialog (see page 
120). 

 use the bitmap editor on the Customise Picture dialog (see page 
121). 
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Customising a button on a user-defined toolbar 
To customise a button on an existing user-defined toolbar: 

1 On the Customise dialog (see page 116), select the button you 
want to customise in the added list. 

2 Click the Change Button  button to display the Customise 
Button dialog (see page 120). 

3 Select Customise. The Modify option becomes available and a 
small thumbnail of the selected button is displayed.  

4 Click Modify. 

5 Use the bitmap editing functions on the Customise Picture dialog 
(see page 121) to edit the bitmap picture. 

 

Creating a new button for a user-defined toolbar 
To create a new button to be added to a user-defined toolbar: 

1 Display the Customise Button dialog (see page 120). 

2 Select the Picture option. 

3 Select a picture or blank background. 

 
4 Select the Customise option. The Modify option activates and a 

small thumbnail of the selected picture is displayed. 

5 Click Modify. 

The Customise Picture dialog (see page 121) is displayed. 
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6 Use the bitmap editing functions to edit or customise your 
selected button. 

 

Customise Button dialog 
Use this dialog to: 

 enter text to display as the item's button. 

 select a picture to be displayed as the item's button. 

 select a picture to edit or customise using the bitmap editing 
functionality on the Customise Picture dialog (see page 121)  

 change the description of a command. This option is displayed 
only if you have selected Command from the Type list. 

 
Text — Select this option and enter text to be displayed as a button. 

Picture — Select this option and select an icon to be displayed as a 
button. 

Customise — If selected, the Modify button is displayed. 

Modify — Click this button to display the selected picture in the 
bitmap editor on the Customise Picture dialog (see page 121) to 
customise the picture before adding it to a user-defined toolbar.  

Command — The command is displayed and you can edit it. 

Description — The description for the command is displayed and you 
can edit it. 
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Customise Picture dialog 
Use the bitmap editing functions on this dialog to customise the 
button selected on the Customise Button dialog (see page 120). You 
can: 

 customise a button on an existing user-defined toolbar (see page 
119).  

 create a new button (see page 119) by selecting a picture or 
background button from those provided.  
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The selected button is displayed as a bitmap on a grid showing each 
pixel, ready for editing. 

 
At the top right of the dialog there is a preview of the button, which 
is updated as you make changes. 

 Undo — Undo the last command. 

 Redo — Reverse the last Undo command. 

 Paste — Click this button to paste the clipboard contents. You 
can copy an image from an image editor (for example MS-Paint), 
copy the image to the clipboard and then paste it this button. 

 Thumbnail — Click this button to use a thumbnail of the current 
model. 

 Brush — Select this option to change the colour of the pixels that 
you drag your mouse over to the selected Colour and Transparency. 

 Dropper — Select this option and click on the bitmap image to 
match the Colour setting to an existing colour. 

 Line — Select this tool to draw a straight line with your cursor. 
Set the Colour and Transparency of the line. 

 Box — Use this tool to draw a box. Set the Colour and 
Transparency of the box. 

 Colour — Use the colour chart to select a colour. 



 

PartMaker Modeling 2015 Getting Started Getting Started with PartMaker Modeling 2015 • 123  

 Transparency — Drag the slider between T (transparent) and 
O (opaque). 

OK — Click this button to save the edited image. 

Cancel — Click this button to close the dialog without saving your 
changes. 

 

Sharing a user-defined toolbar and custom buttons 
User-defined toolbars have a name in the format CustomToolbarX. 

Custom buttons have a name in the format ToolbarX_PictureY.bmp. 

To send a user-defined toolbar and its buttons to another user: 
1 Find the user-specific files. They are stored in xxxx\PowerSHAPE 

where xxxx is one of the following: 

 C:\Documents and Settings\[username]\Application Data    (XP 
installation) 

 C:\Users\[username]\AppData\Roaming\   (Windows 7 and Windows 
8 installation) 

 the location that is indicated by your HOME variable. 

 To find the Local config folder (PowerSHAPE), enter print 
app.paths in the command window. 

2 Select the required files. They include: 
 a file that contains the toolbar, for example CustomToolbar1. 
 one or more button files from the toolbar, for example 

Toolbar1_Picture1.bmp. 

3 Email the files to another user, with instructions to copy the files 
into the folder containing their user-specific files. 
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Flyouts overview 
A flyout toolbar is an extended part of a toolbar (see page 110). 

 
Access a flyout toolbar using a flyout button. Flyout buttons have a 
small triangle icon in the bottom right corner. There are two types 
of flyout buttons: 

 Red  icon — Flyouts with a red icon contain mode buttons. 
Right-click on the flyout button to display the flyout toolbar. 
Select a mode button to display the buttons for the mode on the 
toolbar. 

For example, if you select the Model Fixing  mode button 

from the General Edits  flyout, the toolbar displays the model-
fixing buttons.  

 You can cycle through the available modes by repeatedly 
clicking the flyout button. 

 Black  icon — Flyouts with a black icon group similar buttons, 

for example the Offset  flyout. Right-click on the flyout button 
to show the flyout toolbar and click the button you want. The 
most recently used button from the flyout toolbar is displayed as 
the flyout button. 

You can display a flyout toolbar in one of these ways: 
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 Hover your cursor over the flyout button. The flyout toolbar is 
hidden when you move your cursor away. 

 Right-click on the flyout button. The flyout toolbar is displayed 
until you click. 

 

Status bar overview 
The Status bar is displayed at the bottom of the screen.  

 
Use the Status bar to: 

 Set the default drawing plane (see page 200).  

 Set point-locking (see page 225). 

 Display the Intelligent Cursor flyout (see page 151). 

 Display the Grid (see page 224). 

 Enter point co-ordinates (see page 205). 

 Display the Position dialog (see page 208). 

 Display the Calculator. 

 Display the Measure dialog. 

 Connect/Disconnect the Arm. 

For further details, see Using the status bar (see page 125) 
 

Using the status bar 
The Status bar is fixed at the bottom of the screen. 

 
 
Key Object Name Description 

    Temporary 
workplane 

Click this button to create 
or remove a temporary 
workplane. For further 
details see, Creating a 
temporary workplane in 
the Wireframe modelling 
manual. 
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    Workplane Use this list to activate 
and de-activate 
workplanes. You can also 
use it to change the 
name of the selected 
workplane. For further 
details, see Workplane 
list. 

 
  
  

Current Level This displays the level of 
the selected item or the 
level you are working on. 
Use this to change the 
level of the selected 
items. Only named levels 
that appear in the Level 
dialog are displayed in 
this list. 
For further details, see 
View > Toolbars > Levels  

    Principal plane Select a button to set the 
principal plane of the 
current workspace. Each 
button displays the label 
of the axis that is normal 
to the principal plane. For 
example, the button with 
label Z represents the XY 
principal plane. 

  Point lock Toggle this button to 
enable or disable point-
locking when entering 
positions using the 
mouse. For further 
details, see Using point-
locking (see page 225). 

  
 

Intelligent 
Cursor 

Right-click this flyout 
button to display the 
Intelligent Cursor flyout 
toolbar (see page 151). 

   Grid on/off Toggle this button to 
enable or disable the 
grid. The cursor snaps to 
the grid lines Grid when 
positioning objects. 
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  Grid scale View and edit the scale of 
the grid (see page 224) 
when it is enabled. 

  Coordinates  The X, Y, and Z 
coordinates of the cursor 
are displayed 
respectively. 

   Position When you are creating 
objects, click this button 
to display the Position 
dialog (see page 208), 
where there are various 
tools for entering 
positions. 

   Calculator Click this button to open 
the Calculator. 

  Connect/Disco
nnect the Arm 

Use this flyout to connect 
or disconnect an arm. To 
connect an arm you need 
an appropriate licence file 
and drivers installed on 
your computer. 

   Tol The general tolerance 
variable is displayed. You 
can edit the value. 

  Command 
input 

Use this to: 
 enter data (see page 

127). 
 view previously 

entered data (see 
page 128). 

 display the Command 
window (see page 
128). 

 
 

Using the Status bar to enter data 
There are two ways to enter data. 

 Click in the Command input box. Enter the data and press Enter. 
 Move the cursor into the graphics window and enter the data. 

The data displays in the Command input box. Press Enter to enter 
the data. 
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Using the Status bar to view previously entered data 
Click in the Data entry box. 

1 Use the up and down arrow keys on the keyboard to display the 
previously entered data. 

 The up arrow key displays previously entered data upwards 
from the last entry. 

 The down arrow key displays previously entered data 
downwards from the first entry. 

2 If you want to enter any of the data again, press Enter when it is 
displayed in the Data entry box. 

 

Using the Status bar to display the command window 
Move the cursor into the Data entry box and double-click in the box.  

The Command window is displayed. 
 

Dialog overview 
 A dialog is a movable box that is displayed when you need to 

provide information to the software. Dialogs may contain: 

 data entry boxes 

 expandable lists 

 buttons  

 Most operations in a dialog are controlled by using the mouse or 
by using the menus. Some options and functions display other 
dialogs. For example, when you open a model a dialog is 
displayed for you to select a model from a list.  

 Options that are followed by , display dialogs for you to make 
choices and enter details. 

 Click OK to use the new information and close the box. 
 

Text boxes and data boxes 
 

Use these boxes to enter text or numbers. Click in the box, keeping 
the mouse cursor inside the box, then type the characters. The data 
is entered when you press Enter. 

A value that is defined with a parameter or expression is indicated 
by the use of = in addition to the value. 
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For example, if you enter Length as a=20 and Width values as a+35, 
the length and width values will be displayed in the dialog as =20 
and =55 respectively. 

 
 

Drop-down lists 
 

Enter your data in one of the following ways: 

 Click in the box and type in your data.  

 Click the arrow  to expand the box showing any previous 
entries. You can then click on the one you want.  

 

Option menus 
These appear as drop-down lists that expand to show a menu list. 

 
Click the arrow  to expand the list. Click on an option in the list to 
select it. The menu collapses to display the selected option. 

 

Value box 

 
Increase or decrease the value by clicking the up or down arrow. 
You can also type a new value into the box. 

 

Tabs 
Tabs are used in dialogs to show a different work page for each tab.  
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The example below shows the tabs on the Calculator dialog. 

 
 

Option selection buttons 
There are two types of option selection buttons. 

 
These buttons are small and placed next to their options. When one 
button is clicked, a dot appears in the button and the other 
previously clicked button pops out. Only one option button can be 
ON at any time and one option button must always be selected. It is 
not possible to have them all OFF. 

 
These options buttons are fully independent. A group of these can 
be any combination of ON and OFF. Click a button to set ON and 
click again to set OFF. 

 

Buttons 

 
Each button displays a unique image or text to represent a 
command. When clicked, the button appears to press-in and the 
associated command is activated. When the command is not 
available, the icon image or text appears grey and the button will 
not press-in when clicked. 

 

Apply button 

 
Click to make the changes required, but to leave the dialog 
displayed. 

When a dialog is displayed, you can click the right-mouse-button in 
the graphics area as a shortcut for Apply or Accept. 

 Apply has precedence over Accept, so when a dialog has both 
Apply and Accept buttons available, clicking the right mouse 
button is the same as clicking Apply. 
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OK button 

 
Click to make the changes required and close the dialog. 

 Pressing Enter is the same as clicking OK on a dialog. 
 

Cancel button 

 
This button closes the dialog, discarding any edits carried out on the 
model while it was displayed. 

 

Using the mouse 
The mouse is the main device for controlling the software. You can 
click buttons or objects with or without keyboard “modifier” keys 
(Alt, Shift, Ctrl) to alter the way you can create, select, move, edit 
or view models on the screen. The following terms are used in the 
documentation: 

 Click — Press and release the left mouse button (see page 134). 

 Double-click — Rapidly click the left mouse button twice. 

 Drag — Hold down the left mouse button and move the mouse 
while holding the button down. 

 Move — Move the mouse without selecting any of the mouse 
buttons. 

When other mouse buttons are to be used the required button is 
specified; for example  
 Middle-click  
 Middle-drag 
 Right-click 

The mouse controls such as double-click speed and hit radius are 
set to default values, but can be specified on the Mouse page of the 
Options dialog. 

The cursor that is displayed when you use the mouse indicates the 
operation that you are doing. 

 

Context-sensitive cursors 
The cursor that is displayed when you use the mouse reflects the 
operation that is being carried out. Context-sensitive cursors are 
available in the following areas: 
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Annotation (see page 132) 

Curve toolbar (see page 132) 

Drafting (see page 132) 

General edits toolbar (see page 133) 

View toolbar (see page 133) 

Other (see page 133) 
 

Context sensitive cursors — Annotation toolbar 

 — Add text along a curve. 

 — Add text (horizontally or vertically). 
 

Context sensitive cursors — Curve toolbar 

 — Stop curve. 

 — Close curve. 

 — Sketch curve. 

 — Select start and end point (composite curve). 
 

Context sensitive cursors — Drafting 

 — Activate view. 

 — View selection. 

 — Drawing selection. 

Arc and line lengths are displayed on the cursor when creating 
dimensions. 
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Context sensitive cursors — General edits 

 — Limit cut. 

 — Limit point. 

 — Move/copy/stretch (also used for drag-move). 

 — Rotate items. 

 — Mirror items. 

 — Mirror items across a user defined plane. 

 — Mirror items in a wireframe line. 

 — Offset items. 

 — Scale items. 
 

Context sensitive cursors — View toolbar 

 — Zoom to box. 

 — Zoom. 

 — Rotate. 

 — Pan. 
 

Context sensitive cursors — Other 

 — Warning/error. 

 — Cursor selection/edge-pick hand. 

 — Add component. 

 — Principal plane-lock toggled. 

 — Action not allowed. 

 — Action not allowed, plane. 

 — Action not allowed, arc. 

 — Paste attributes. 

 — Selection filter. 
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Using the left mouse button 

 
This is the main mouse button for selecting menu 
options, clicking buttons on toolbars and dialogs 
and for editing model objects. It has different 
effects according to where the cursor is 
positioned. 

You can use the left mouse button: 

 over a menu (see page 134) 

 over a non-active graphics window (see page 135) 

 over an active graphics window (see page 135) 

 on an object (see page 138) 

 in a dialog (see page 136) 

 after a Cut or Copy (see page 142). 
 

Over a menu 

 
 

Single Click highlights and selects menu options. 

 
 

Double Click has no particular effect over menus. 
PartMaker Modeling assumes you intended to 
single click. 

 
 

Drag by holding down the left mouse button and 
moving the mouse to move the cursor. You can:  
 Drag the cursor over objects in the graphics 

window to highlight them for selection.  
 Edit and create dimensions by dragging them 

to the required position.  
 Edit objects by dragging their handles.  
 

 
 

Move the cursor over the different options, 
highlighting the ones that are available. You can: 
 Move the cursor over menus to display 

submenus where they are available.  
 Move the cursor over toolbars to display 

flyouts where they are available. 
 Activate construction lines when the intelligent 

cursor is active. 
 Move the cursor along construction lines.  
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Over a non-active graphics window 

 
Single-click in a non-active graphics window 
activates the window. The title of the active 
window is highlighted. 

 
 

Over an active graphics window 

 
Single Click in an active graphics window usually 
signifies an attempt to select an object or to enter 
a position. Click away from any object to clear the 
current selection. 
When entering positions, click away from any 
object to input a position on the principal plane of 
the active workplane. 

 
 

Double-click has no effect unless you are pointing 
at an object. 

 
 

Drag (hold down the Left mouse button while 
dragging) to draw a rubber band box. Objects 
within the box are selected, indicated by their 
yellow highlight colour and handles.  
Note:  
 Any other objects already selected and not 

within the box become deselected.  
 If the box contains no objects, the current 

selection is cleared. 
 When more than one object is selected, the 

graphical handles are not displayed. 
 

 
 

Shift-Drag (hold down the Shift key while 
dragging) draws a rubber band box. Objects 
within the box are added to the current selection. 

 
 

Ctrl-Drag (hold down the Ctrl key while dragging) 
draws a rubber band box. Objects within the box 
are added to the current selection or deselected if 
they are already selected. 
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Ctrl-Shift-Drag (hold down both the Ctrl and Shift 
keys while dragging) draws a rubber band box. 
Objects within the box are deselected from the 
current selection. 

 

Shift-Alt-Drag (hold down the Shift and Alt keys 
while dragging) rotates the view around the X 
axis. 

 
 

In a dialog 

 
Single click to select options and press buttons. 
On slider controls, clicks on the track cause the 
slider to step towards the cursor. 

 
Double-click is not effective on all dialogs. 
Double click in a text box to select all the text. If 
you then type new text, the selected text is 
replaced by the new text. 
Double click on an item in a list to select the item 
and accept the dialog. For example, double 
clicking a file name in the Open Model dialog, 
accepts the dialog and opens the model. 

 

Shift-click (hold down the Shift key while clicking) 
to select multiple items in a list. All items between 
the last item selected and the current item clicked 
become selected. 

 

Drag slider controls to move the slider button. 

 
 

Using the middle mouse button 
Use this mouse button with keyboard “modifier” keys to control the 
view of your model. It is not used within the dialog and does not 
alter a model’s design. 

 If you have a two button mouse, operations using the middle 
mouse button are available using the other two buttons. For 
further details, see Right-hand mouse button (see page 140) 
and Left and right mouse buttons (see page 142). 
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Middle-click to Rotate the view, hold down the 
middle button and move the mouse. The model 
turns as if the cursor is pushing and pulling on the 
outer surface of a ball and a ball graphic appears 
over the centre of rotation to show what is 
happening. 

 
Middle-click to change Orientation. Position the 
cursor to the side of the model and click the 
middle mouse button. The model will be rotated 
so that you are viewing the model from the 
position of the cursor. 

 

 

Shift+Middle-click to Pan a particular point to the 
centre of the view, hold down the Shift key and 
click the point in the model you want to appear in 
the middle of the view. 

 

Ctrl+Middle-click to Pan a particular point to the 
centre of the view, hold down the Control key and 
click the point in the model you want to appear in 
the middle of the view. 

 

Shift+Middle-click+drag to Pan the view, hold down 
the Shift key and drag the middle button. The 
view follows the mouse movements. 

 
 

Ctrl+Middle-click+drag to Zoom the view, hold 
down the Control key and drag the middle button. 
Moving up the screen magnifies the view. Moving 
down the screen reduces the view 

 
 

Ctrl+Shift+Middle-click+Drag to Zoom to a box, hold 
down the Shift and Ctrl keys and drag the middle 
button. A rubber-band box appears. When you 
release the mouse button, the view zooms to the 
box size. 
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Shift+Alt+Middle-click+drag (holding down both the 
Shift and Alt keys while dragging) to rotate the 
view around the Y axis. 

 
 

On an object 
When selected, objects are displayed with additional edit handles. 
For example: 

 Lines have key points at each end. 

 Curves have key points on arms extending from the selected 
control point on the curve. 

 Arcs have key points at the centre and at the start and end of 
the arc sector. 

 Workplanes have a “control rectangle” and origin. 

If you drag a key point, only the aspect of the object controlled by 
the point will move.  

To move the whole object, be careful to click on the object itself, 
but away from any of its key points. 

 
Single-click over an unselected object to select it. 
The object turns yellow with its key points shown 
as graphical “handles”. The selected object’s key 
point closest to the cursor when selected becomes 
its anchor point. 
Any other objects already selected become 
deselected. 
If the Intelligent Cursor is ON, the cursor changes 
as you move over objects and current selections. 

 
Double-click to select the object, but also to send 
the command to display a dialog or toolbar 
allowing you to edit the object’s properties. For 
further details, see Modifying an object in the 
Menus and Toolbars manual.  
When entering a series of points (for example, for 
a series of lines or a curve), double click to finish 
the series. A subsequent single click starts a new 
series. 
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Drag a selected object to move it. While the 
button is pressed, the object follows the mouse. 
When you release the button, the Confirm Drag 
dialog is displayed for you to confirm the x, y, z 
coordinates for the move. Although the object 
appears to continue to move with the cursor, the 
coordinates are fixed where you released the 
mouse button. 
Click OK to confirm the coordinate 

 

 The move is relative to the active workplane. 

 

 

Shift+click (hold down the Shift key while clicking) 
to add objects to the current selection. 

 
 

Ctrl+click (hold down the Ctrl key while clicking) to 
add objects to the current selection or deselect 
those already selected. 

 
Alt+click (hold down the Alt key while clicking) to 
create composite curves. For further details, see 
Creating a composite curve by tracing in the 
Wireframe modelling manual.  

 
 

Ctrl+Shift+click (hold down both the Ctrl and Shift 
keys while clicking) to deselect objects from the 
current selection. 
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Ctrl+Drag (hold down the Ctrl key while dragging) 
to copy the selected objects. The copy is dropped 
when you release the mouse button. 
This copy does not overwrite data already on the 
Cut/Copy clipboard. The Confirm Drag dialog is 
displayed where you confirm the x, y, z 
coordinates for the move.  

 The move is relative to the active 
workplane. 

 
 

 

Using the right mouse button 
You can use the right mouse button: 

 Over an object (see page 141) 

 In a text box (see page 141) 

 Over an active graphics window (see page 141) 

 When a dialog is displayed, you can click the right-mouse button 
in the graphics area as a shortcut for Apply or Accept. If Apply 
and Accept are unavailable, clciking the tigh mousse button will 
close the dialog without making any changes. 

 Apply has precedence over Accept, so when a dialog has 
both Apply and Accept buttons available, clicking the right 
mouse button is the same as clicking Apply. 

 
Click with this mouse button to display popup 
menus and the calculator. You can also use this 
button to pan, zoom and drag the view. 
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Over an object 

 
Single right click in the active model window to 
display popup menus. These contain various 
options including Cut, Copy, Paste and Delete. Click 
over different object types or a blank space to 
display options on the popup menu that are 
relevant to the object type. For further details, see 
popup menus (see page 108). 

 
 

In a text box 

 
Single right-click in a numeric text box to display 
the calculator. The calculation results are 
displayed automatically in the text box when you 
press the Enter key or move the mouse outside 
the numeric text box. 
In a text box, this displays a popup menu with 
options Undo, Cut, Copy, Paste, Delete and Select 
All. You can use these options on the data in the 
box. 

 

Shift+right-click in a numeric text box to display a 
popup menu with options Undo, Cut, Copy, Paste, 
Delete, and Select All. You can use these options 
on the data in the box. 

 
 

Over an active graphics window 

 

Shift+right-click to Pan a particular point to the 
centre of the view, hold down the Shift key and 
click the point in the model you want to appear in 
the middle of the view. 

 

Ctrl+right-click to Pan a particular point to the 
centre of the view, hold down the Control key and 
click the point in the model you want to appear in 
the middle of the view. 

 

Shift+right-click+Drag to Pan the view, hold down 
the Shift key and drag the right button. The view 
follows the mouse movements. 
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Ctrl+right-click+Drag to Zoom the view, hold down 
the Ctrl key and drag the right button. Moving up 
the screen magnifies the view. Moving down the 
screen reduces the view 

 

Alt+right-click-Drag to Zoom to a box, hold down 
the Alt key and drag the right button. A rubber-
band box appears. When you release the mouse 
button, the view zooms to the box size. 

 

Ctrl+Shift+right-click+Drag (hold down both the Ctrl 
and Shift keys while dragging the right mouse) to 
rotate the view. The model turns as if the cursor 
is pushing and pulling on the outer surface of a 
ball and a ball graphic appears over the centre of 
rotation to show what is happening. 

 

Shift+Alt+right-click+Drag (holding down the Shift 
and Alt keys while dragging) to rotate the view 
around the Z axis. 

 
 

After a Cut or Copy operation 

 

Ctrl+Alt+Click (hold down the Ctrl and Alt keys 
while clicking) to enter an anchor point for Paste 
Special.  

 
 

Left and right mouse buttons 

 
 

Shift+Alt+Drag (hold down the Shift and Alt keys 
while dragging) to rotate the view around the Y 
axis. 

 
Left-click+right-click to rotate the view, hold down 
both the left and right buttons and move the 
mouse. The model turns as if the cursor is 
pushing and pulling on the outer surface of a ball 
and a ball graphic appears over the centre of 
rotation to show what is happening. 
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Using the keyboard 
The keyboard is usually used to enter information into a dialog. This 
might be when you want to create or edit an object to a specific size 
and position. 

Certain "modifier" keys are also used with the mouse to change the 
way the mouse behaves. For further details, see Using the mouse 
(see page 131). 

There are also a number of keyboard shortcuts that allow you to do 
a variety of operations such as open and close models. For further 
details, see Shortcuts to menu options. 

 

PartMaker Modeling graphics area 
PartMaker Modeling runs within its own window containing: 

 Menus (see page 107) 

 Toolbars (see page 110) 

 Status bar (see page 125) 

 Graphics area (see page 143) 

For further details, see Screen layout (see page 106) and The 
coordinate system (see page 200) 

The graphics area may be: 

 a single modelling window that fills the graphics area. 

 several modelling windows that overlay each other in the 
graphics area. These windows can be placed anywhere on the 
screen, not necessarily within the graphics area. For further 
details, see Window menu overview. 

Each modelling window displays views of a single model. You can 
open as many modelling windows for each model as you like, but 
closing a model’s last window also closes the model. 

 

Modelling windows in the graphics area 
Use the Window menu to control the content displayed in the 
graphics area: 

 Create new modelling windows. 

 Swap between modelling windows. 

 Make a different modelling window active. To do this click on the 
window or select it from the menu. Only one modelling window is 
active at any time and this is indicated by the window's 
highlighted title. 

 Change the display of modelling windows.  
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Use the View menu to: 

 Change the view shown in modelling windows.  

 Increase the visible modelling area by selecting Full Screen or 
Full Screen Preview. 

Displaying modelling windows 
 Use Single window mode (see page 144) to display a single 

working modelling window that fills the whole area. 

 Use Multi-window mode (see page 145) to display several 
overlapping modelling windows.  

 Display several tiled model windows that are tiled vertically or 
tiled horizontally. 

Closing modelling windows 

Click  at the top corner of the window.  

Resizing modelling windows 
Windows have resize handles at the corners and borders. Drag them 
to change the window size. For more information, see your 
operating system documentation. 

Full screen mode 
Use the following typed commands to make PartMaker Modeling 
stretch to fill the screen: 

GUI FULLSCREEN ON/OFF removes the taskbar and puts menu 
off the top of the screen. 

GUI PREVIEWSCREEN ON/OFF removes the taskbar, puts menu 
off the top of the screen.and removes all toolbars. 

The menus can still be accessed off the top of the screen. 

 
 

Single window mode 

Click Windows fix/float  to fill the graphics area (see page 143) 
with the active modelling window. To display a different modelling 
window, select it from the list on the Window menu. 

For further details, see Window menu overview. 
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Multi-window mode 
When the modelling window fills the graphics area, click Windows 
fix/float  to display each window in their own frames. These 
modelling windows are moveable and resizable. Each has a banner 
across the top showing the window name.  

Click on the banner (or the border) of a window to bring the window 
to the front of other windows. Drag the banner to move the window 
around the screen.  

For further details, see Window menu overview in the Menus and 
Toolbars manual 

 

Tile vertically 
This displays open modelling windows vertically so they are all 
visible within the graphics area. Their individual sizes depend on the 
number of windows open. 

 
Tiled modelling windows can be resized and moved in the same way 
as any other window controlled by the operating system. However, 
moving one will almost certainly cause it to overlap some other 
windows. 
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Click on the Maximise button on a Tiled window to revert to a single 
window display. 

 
 

Tile horizontally 
This displays open modelling windows horizontally so they are all 
visible within the graphics area. Their individual sizes depend on the 
number of windows open. 

 
Tiled modelling windows can be resized and moved in the same way 
as any other window controlled by the operating system. However, 
moving one will almost certainly cause it to overlap other windows. 



 

PartMaker Modeling 2015 Getting Started Getting Started with PartMaker Modeling 2015 • 147  

Click on the Maximise button on a Tiled window to revert to a single 
window display. 

 
 

Intelligent Cursor 
Use the following sections for information on using the Intelligent 
Cursor: 

What is the Intelligent Cursor? (see page 147) 

Construction lines (see page 149) 

Intelligent Cursor flyout (see page 151) 

Entering positions (see page 153) 

Selection (see page 155) 

Using a locked axis (see page 155) 

Editing objects (see page 159) 
 

What is the Intelligent Cursor? 
The Intelligent Cursor provides dynamic assistance for its two 
primary functions: 

 Point input — It activates construction lines and labels for 
dragging, snapping and for point creation. 

 Selection — It highlights the object under the cursor ready for 
selection. For further details, see Selection using the Intelligent 
Cursor (see page 155) 

The cursor icon changes to assist you when selecting and editing 
objects. For further details, see Intelligent Cursor construction 
labels  (see page 153) 

 

Using the Intelligent Cursor 
The Intelligent Cursor is enabled by default. You can enable and 
disable the Intelligent Cursor in one of these ways: 

 Turning the Intelligent Cursor off or on (see page 148) 

 Popup menu (see page 148) 
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 The Mouse page of the Options dialog (see page 149) 
 

Turning the Intelligent cursor on or off 
The Intelligent Cursor is enabled by default. You can enable and 
disable the Intelligent Cursor using the options on the Intelligent 
Cursor flyout (see page 151) on the status bar. 

1 Right-click the Intelligent Cursor  button on the status bar to 
display the Intelligent Cursor flyout. 

 

2 Click the Intelligent Cursor Off  button to disable the Intelligent 
Cursor.  

3 Click the Intelligent Cursor On  button to enable the Intelligent 
Cursor. 

 

View popup menu 
1 In modelling mode, right-click in an empty space in the graphics 

window to display the View menu (see page 108). 

2 Deselect the Intelligent Cursor option to disable it.  

3 Select it again to enable the Intelligent Cursor. 
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Mouse page of the Options dialog 
Use the Active option to toggle the Intelligent Cursor. This option is 
selected by default. 

 
The Intelligent Cursor displays in the graphics window: 

 various cursor types 

 construction lines 

 construction labels 

 construction distances  

When you click OK, PartMaker Modeling uses the new Intelligent 
Cursor settings. For further details on Intelligent Cursor options, see 
Mouse options. 

 

Construction lines 
When you hover the Intelligent Cursor over an important key point 
(one that displays any of the construction labels (see page 153)), 
construction lines are created from that key point. You can now 
drag the cursor along a construction line and see the appropriate 
labels display. Clicking causes the position to snap to that point.  

The following example draws a box: 

1 On the Main toolbar, select the Line  button. 

2 On the Line toolbar, select the Continuous  button. 
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3 Click to start a line. 

 
Drag along a construction line and click. 

 
4 Drag along a 90  construction line and click. The line snaps to 

give a square intersection. 

 
5 Drag the cursor down to the original start point and hover. The 

cursor displays End and the construction lines display. 

 
6 Drag along the vertical construction line until Intersection is 

shown. 

 
7 Snap to the start and finish with one more click when End is 

displayed. 

 
If the Intelligent Cursor Gridding is enabled, the label On in the 
above diagrams is replaced by a distance from the last point 
selected. For example: 

 
This provides a convenient way to enter accurate dimensions. 
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 To disable construction lines temporarily, press and hold the 
Shift key. 

 

Turning construction lines on or off 
The Intelligent Cursor's construction lines are enabled by default. To 

disable construction lines, click the Construction Lines  button 
from the Intelligent Cursor flyout (see page 151) on the Status bar. 
The construction lines are not displayed until they are turned back 
on. All functionality is still available. 

 

Intelligent Cursor flyout 
1 Click  (Status bar) using the right mouse button to display the 

Intelligent Cursor flyout. 

2 Select the Intelligent Cursor option you require. 

 The Intelligent Cursor options are for point entry only (not 
selection). 

 

 Intelligent Cursor on (default) (see page 148). 

 Intelligent Cursor off (see page 148). 

 Snap to keypoints (see page 152). 

 Snap to centre keypoints (see page 152). 

 Construction lines on/off (see page 151). 

 Click this button to snap the cursor to the nearest node 
instead of the exact point on the mesh. 

3 Click  (Status bar) to return to the default flyout setting when 
you have finished using the Intelligent Cursor options. 
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Snap to keypoints 
Use Snap to keypoints to detect only keypoints in your model when 
entering points. Anything that is not a keypoint is ignored by the 
functionality in use. On wireframe items the cursor will snap to the 
nearest keypoint. 

When this option is selected, the cursor changes to  as a 
reminder that point entry is restricted to keypoints. 

To activate Snap to keypoints: 

1 Click  (Status bar) using the right mouse button to display the 
Intelligent Cursor flyout (see page 151). 

2 Click  Snap to keypoints. 
 

Snap to centre keypoints 
Snap to centre keypoints is a restrictive option that filters out all 
point input except circle and hole centres. This is particularly useful 
when dimensioning a large number of holes. 

When the option is selected, the cursor changes to  as a 
reminder that point entry is restricted to centre keypoints. 

Any point on the geometry of circles will snap to the centre of that 
arc. For example,  

1 Hover the cursor over an arc  
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2 Click to snap the centre of that arc.  

 
It is not necessary to select the centre of the arc directly. 

 This is a useful technique when working with overlapping or 
concentric circles where the centre is not easily identifiable. 

To activate Snap to centre keypoints: 

1 Click  (status bar) using the right mouse button to display the 
Intelligent Cursor flyout (see page 152). 

2 Click  to activate Snap to centre keypoints. 
 

Entering positions using the Intelligent Cursor 
The Intelligent Cursor shows additional information to help you to 
define the position you want when entering positions.  

When you move the cursor over an object, construction labels (see 
page 153) are displayed by the Intelligent Cursor. These 
construction labels: 

 are shown and hidden as you move the cursor over them. 

 indicate what happens if you click while the label is displayed. 

 make snapping with the cursor more accurate. The labels display 
when key points are within snap range of key positions in the 
model. You can click when a label (see page 153) is displayed to 
snap to the cursor at the labelled position.  

 The Intelligent Cursor (see page 148) is enabled by default. 
 

Intelligent Cursor construction labels 
The labels you may see displayed by the Intelligent Cursor include: 
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 End  — Shows that the position will snap to the end point of a 
line, arc, curve, or profile. 

 Mid-point — Shows that the position will snap to a point mid way 
between the start and end points of a line or arc. 

 Centre — Shows that the position will snap to the centre of an arc 
or circle, or hole feature. The name of the feature is also 
displayed. 

 Key-point — Shows the keypoints on curves and surfaces where 
they can be manipulated. The position will snap to the nearest 
keypoint on the object under the cursor (for example, a surface 
patch corner or a curve key point).  This label can also show the 
origin of a workplane. 

 On — Shows that the cursor is on a line and the position will snap 
to a point that lies exactly on the object, but not at one of its key 
points (for example, end, corner, centre points). 

If the Background Grid option is ON, a number representing a 
distance along the object from the last key point visited by the 
cursor is displayed. The values are rounded to the nearest sensible 
value. Zoom out to see coarser increments. Zoom in to see finer 
increments. 
 In 

Shows that the position will snap to a point on the inside of a 
surface patch or a solid face (not one of the keypoints or 
positions along a curve). 

 Intersection 
Shows where two objects cross and that the position will snap to 
the intersection between the two objects under the cursor. 

 Tangent 
Displays when a tangent to an arc can be made. The position will 
be calculated so that the line or arc being created is tangential to 
the line or arc under the cursor. The position will not necessarily 
be under the cursor. This works whether you are placing a line to 
an arc, an arc to a line or an arc to an arc. 

 End sign  

This displays when clicking will complete a curve or continuous 
series of lines. 

 Closing a curve  

This displays when clicking will create a closed curve. 

 We strongly recommend that you normally work with the 
Construction Level switched OFF. For further details, see 
Format > Levels. 
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Selection using the Intelligent Cursor 
When the Intelligent Cursor is enabled, objects are highlighted as 
you move the cursor over them. This shows which objects can be 
selected if you click at that point. For further details, see Turning 
the Intelligent cursor on or off (see page 148). 

When several objects are under the cursor and one of them is 
selected, the Intelligent Cursor highlights the next object from the 
database at that position. A click now deselects the selected object, 
selects the highlighted object, and highlights the next one. This 
enables you to select the correct object from the group. 

You can also right-click to display the object's menu and click Next 
Selection to select the next object. 

The Intelligent Cursor option is displayed on the popup menu. 
Select or Deselect to toggle the Intelligent Cursor on and off.  
Selecting this option is the same as selecting the Intelligent Cursor 
Active option from the Mouse options page of the Options dialog. 

 

Using a locked axis with the Intelligent Cursor 
The Intelligent Cursor can be an effective tool when used with a 
locked axis. 

 Intelligent Cursor modification keys (see page 155) 

 Creation using a locked axis (see page 156) 

 Dragging on a locked axis (see page 157) 

 Moving points on a locked axis (see page 157) 

 Snapping to points using a locked axis (see page 158) 
 

Intelligent Cursor modification keys 
The following keys on the keyboard can be used to modify the use 
of the Intelligent Cursor.  

X — Press and hold the X key on the keyboard to lock the X axis 
whilst in any construction mode, dragging objects and moving 
points.   

Y — Press and hold the Y key on the keyboard to lock the Y axis 
whilst in any construction mode, dragging objects and moving 
points.   

Z — Press and hold the Z key on the keyboard to lock the Z axis 
whilst in any construction mode, dragging objects and moving 
points.   

N — Press and hold the N key on the keyboard to move points 
locked on the axis of the normal of the surface. 
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Creation using a locked axis 
As an alternative to using construction lines during line creation, 
you can use the X, Y, and Z keyboard modifier keys to lock the 
corresponding orthogonal axis. This can be useful for additional 
precision in complex models to control the direction of item 
construction. 

When you are creating in free space, the cursor grids the distance 
along the locked axis as you move the mouse. 

1 Select Line . 

2 Enter a point. 

3 Press and hold down the required X, Y or  Z  key to lock the X, 
Y, or Z axis. 

 You may need to change the plane you are working in to 
lock the required axis. For example, to lock the Z axis you 
need to be entering points in the XZ or YZ plane (not XY). 

4 Move the cursor to create the line to the required length.  

The example below shows the construction line displaying along the 
X axis, whilst the mouse cursor is above. The potential line creation 
result is displayed at an angle of 25 . 

 
The example below shows a similar mouse position above the x 
axis, but the X key has been held down to force the line creation to 
be locked onto the X axis, despite the cursor position located above 
the X axis. 
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Dragging on a locked axis 
You can drag existing objects along a locked axis, by pressing and 
holding the corresponding keyboard modifier key X, Y, or Z when 
you start to drag. The intelligent cursor remembers where the drag 
started and locks that axis.  

All objects in the selection are dragged along the corresponding 
locked axis, allowing multiple items to be moved together. 

 

Moving points on a locked axis 
When moving points on a power surface, you can use the N 
keyboard key to lock the axis to guarantee the point is being moved 
in a perpendicular direction from the surface. The locked axis is the 
original point's surface normal. 

When you use the N key, the drag point is locked on the axis, 
normal to the surface from where you picked the original point. 

 This does not work if you are using a view that looks down 
the surface normal. Change views to see the point moving 
perpendicular to the surface. 

In these examples, both corner points on the surfaces have been 
dragged to change their shape from a standard plane. The N 
keyboard key was used for the image on the right to move the 
surface in a perpendicular direction to the surface normal. 
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The effect is not truly visible until the surfaces are rotated, seen in 
the following rotated examples.  

 
 

Snapping to points using a locked axis 
When pressing and holding one of the keyboard keys X, Y, or Z to 
lock the axis during line construction, drag selected objects or move 
points, you can still move the cursor to a nearby point to snap to it. 
The axis remains locked as the intelligent cursor projects the 
resulting point from the snapped point to the locked axis. 

The example below shows a plane with a selected corner, ready to 
snap to the centre of the circle in the direction shown by the arrow.  

 
The example below shows the corner point dragged and snapped to 
the circle centre. 
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The example below shows the corner point dragged to the circle 
centre, but using the X key to lock the X axis.  

 
 

Editing objects using the Intelligent Cursor 
When you start to drag an object, a group of objects or an editing 
handle of an object, the cursor feeds back information about points 
you can snap to. 

The Intelligent Cursor: 

 finds intersections between wireframe items and a surface or 
solid. 

 snaps to the projected intersection of wireframe items and 
surfaces. 

 snaps bezier curves to triangles in a symbol imported as a solid. 
For further details, see STL/DMT options in the Menus and 
Toolbars manual. 

 snaps to triangles in symbols (not applicable to components).  

For further details, see Using the Intelligent Cursor to enter 
positions (see page 153) and Selection using the Intelligent Cursor 
(see page 155). 

 

Object highlighting 
When the intelligent cursor is enabled, objects that you can select 
are highlighted when you move the cursor over them. 
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The two keypoints nearest the cursor on a curve are highlighted and 
are displayed as small circles when you move the cursor over them. 
This helps you find them more easily and quickly. The keypoint 
markers display in both creation and edit modes. 

 
For further details, see Selection using the Intelligent Cursor (see 
page 155).  
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Models 
A model is a representation of a “real life” (usually engineering) 
component, built on the computer. You build models from a set of 
geometric objects (lines, arcs, curves, and surfaces) which together 
represent the components. 

You can view a model from any angle and shade it to look very 
similar to the real component. You can also model other properties 
such as weight and volume. 

 

Creating a model 
1 Select File > New from the menu. 

This creates a new model file and opens a new graphics window. 
The new window automatically becomes the active window. The 
window title shows the model name (in this case New_Model) 
and a sequential number. 

2 The first time you save this model, the Save Model As dialog is 
displayed, which prompts you to enter a name for your model. 
For further details, see Saving a model with a new name (see 
page 161). 

 

Saving a model 
When you want to keep your work, 

1 Select File > Save. 

If a model was originally opened with write access, it is 
automatically saved, overwriting the stored version. 

2 For a new or read-only model, you must use File > Save As to 
save the model with a new name. (see page 161) 

 
 

Saving a model with a new name 
When you want to keep your work but don’t want to overwrite an 
existing model, you can save the model using a new name. The 
location of the model you save is defined in the Tools > Options > 
File > Model dialog. As well as the path to the model, the Always 
save and open from outside the database option defines if the model is 
saved inside or outside the database. 

1 Select File > Save As from the menu.  

2 The dialog that is displayed depends on the setting of the Always 
save and open from outside the database option: 
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 When you first use the program, the Always save and open 
from outside the database option is selected by default and you 
automatically use the standard Windows Save As dialog to 
save models outside the database.  

 To save models in the shareddb database, select Tools > 
Options > File > Model and deselect the Always save and open 
from outside the database option. 

Selecting Save As from the File menu now displays the Save 
Model As dialog. 

 
3 Use the dialog to save your model using a new name. 

 If your models are single files and stored outside the 
database, you can display the Save As dialog instead of the 
Save Model As dialog. To do this, select the Always save and 
open from outside the database option. 

 

Checking for corruption 
To spot any corruption as soon as possible after it has occurred, the 
File Doctor is run whenever you save a model. For further details, 
see Tools > Model Fixing. 

If File Doctor finds any problems, you are asked to save the model 
under a new name or run File Doctor in fix mode to correct the 
problem. 

To stop running File Doctor on every save, deselect the Check Model 
Before Save option on the Model page of the Options dialog. 

A set of options is available from the Model page of the Options 
dialog. You can select which ones to use when using File Doctor. For 
further details, see Model options. 

 

Closing a model 
1 If you have more than one model open, make active the model 

you want to close by clicking in its graphics window or selecting 
the model from the Window menu. 

2 Select File > Close from the menu. 
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The active graphics window closes.  

3 You will be prompted to save changes you have made to the 
model: 

 Click Yes to save the changes to the original file name. 

 Click No to close the file and lose any changes that you have 
not saved. 

4 The model is checked to see if the data can be compressed. If 
the program decides that compression is possible, a dialog is 
displayed:  

 Click Yes to compress the model data and close the file. 

 Click No to close without compressing the model data. 

 To save an edited file to a new filename you need to use File 
> Save As (see page 161). 

 

Other ways to close a model 
A model is also closed if you do one of the following: 

 Close the last open graphics window of the model (by selecting 
Close from the Window menu). 

 Exit the program. 

 Using the File > Close and Zip command. 

In all cases, you are prompted to save any unsaved edits. 
 

Opening a model 
Each model you open is displayed in a separate graphics window on 
the screen. You can also show each model in a number of windows 
and can have up to 20 models open at the same time. 

You can open a model and select its read/write status. 

1 Select File > Open from the menu. 

The Open Model dialog is displayed 

2 Use the dialog to open a model. 

For further details, see Open Model dialog (see page 164). 

If your models are single files and stored outside the database, you 
can always display the standard Windows Open Model dialog. To do 
this, turn on the Always save and open from outside the database 
option on the Model page of the Options dialog. For further details, 
see Model options. 
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Open Model dialog 
Use this dialog to open models. 

 
Models - Select a model name from the list. 

If you select any item, you can use the keyboard arrow keys  to 
move to the next model. 

 Models of the form NEW_MODEL_<number> are created 
when File - New is selected. These only appear in the Models 
list if you have system administrator security. 

Filter - When the list of model names becomes very long, it can be 
difficult to find the model you want. Entering a filter reduces the list 
to only those models which match the filter pattern, for example, 
entering a filter of *.vl will list only those models which have the 
extension .vl. 

We suggest that you use a designer’s initials for model name 
extensions. For example, mymodel.vl. 
The filter is not case sensitive. Entering a filter of *.VL will list 
models that have the extension .VL as well as those with the 
extension .vl. For further details, see Filter options (Menus and 
Toolbars). 

Clear - This clears the text in the Filter box. 

Password - If the model is protected by a password, enter it in the 
text box. 
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Read Only - If you want to open the model, but prevent it from being 
overwritten, click the Read Only box until it shows a tick. 

If you decide to save any changes, you will need to save the model 
under a new name using File - Save As. For further details, see 
Saving a model with a new name (see page 161). 

Check & Fix - When ON, File Doctor examines the selected model 
and corrects any errors before opening the model. For further 
details, see Tools - Model Fixing - File doctor (Menus and Toolbars). 

Preview Picture and Properties - If a thumbnail of the model has been 
saved, it is displayed in the top window. Information about the 
model appears in the bottom window, including file dates, size and 
description. 

Browse - This opens models stored as single files and not in the 
database. Click the Browse button to display the standard Windows 
Open Model dialog. Use this dialog to select and open a model. 

Models stored in the directory format and not in the database must 
be imported. 

Search - This allows you to create a filter based on the fields used 
for temporary and vault models. It is only available if you have a 
naming_convention.mac file in your shareddb folder. 

The naming_convention.mac file allows you to save vault and 
temporary models. For further details, see Defining your naming 
scheme (Managing your PowerSHAPE system). 

Click Search to display the Search for files dialog. 

Recover - This button only appears if you select a model that was 
not closed properly, for example, if there was a power failure while 
working on the model. Recover opens the model and restores it 
back to its state before the failure. 

Open - The selected model is opened. If the model you are opening 
is shaded, you can open the model in wireframe mode by pressing 
the  button next to the progress bar on the status bar. 

Cancel - Removes the dialog from the screen without opening a 
model. 

 

Starting up PartMaker Modeling and opening a model 
When you start up PartMaker Modeling at the command prompt, 
you can open an existing model at the same time by typing: 

powershape model_name 
For further details, see Other ways of opening psmodels in 
PartMaker Modeling (see page 166). 
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 For the above commands to work, you must have FILE OPEN 
IFNONE in your login macro.  

 

Other ways of opening psmodels in PartMaker Modeling 
As well as using the File Open command to open models in the 
single file format (.psmodel), you can also: 

 Double-click a .psmodel file. If the program is not running, it will 
start up and then open the model. 

 Right-click the .psmodel file in Windows Explorer and select Open. 
You can open a selection of models in this way. 

 Drag and drop one or more .psmodel files into the program 
window. 

 Double-click a PartMaker Modeling.exe shortcut. 

 Double-click a .psmodel shortcut. 

 In a web browser, click on a URL to a .psmodel; for example, 
file://pshape/models/bottle_example.psmodel. You can either open the 
model immediately or download it and open it later. 

 

Recently opened models 
Select the Recent Files option at the bottom of the File menu to see 
the last four models listed. The read or write status when they were 
opened is also shown. 

To open a recently opened model, select the File menu and click the 
model name you want. It will open with the same read or write 
status as last time. 

If the model is not listed or you want a different read/write status, 
use the File > Open option. For further details, see Opening a model 
(see page 163) 

 

Closing and opening zipped models 
Files can be compressed to make them take less disk space. This is 
known as zipping a file. By zipping a model, you can save about 
60% of disk space, but it takes longer to open as it needs time to 
unzip. 
To close and zip a model, 
1 Save the model if you haven't already done so. 

2 Select File > Close and Zip from the menu. 

The model file is stored in a zip file and the original file of the 
model is deleted. 

To open a zipped model, 
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1 Select File > Open from the menu. 

The Open Model dialog is displayed. 

2 Select the model using the dialog. 

3 If the model is stored outside the model database, click the 
Browse button to display the Open dialog. Use this dialog to 
select and open the zipped model. You may need to select Zip 
from the Files of type menu. 

4 Click Open. 

A copy of the model is extracted from the zip file and stored in 
the same folder as the zip file. While the model is open, any 
changes are saved to the copy. 

 Zipped directory models are opened using File Import. 
When you finish working on the model, you can close it using: 

 File > Close — This saves the copy you are working on and 
deletes the zip file. 

 File > Close and Zip — This adds the copy to the zip file and then 
deletes the copy. 

 

Changing the view of a model 
Each window can contain: 

 a single view of the model. 

 two views of the model splitting the model window vertically. 

 four views of the model splitting the model window vertically and 
horizontally. 

Each of these views can be from any direction, at any scale, and can 
be parallel, isometric or perspective projections. Surfaces can be 
drawn as wireframe or shaded and objects can be blanked from 
specific views to reduce clutter. 

To change the view of a model: 

 Use the Window menu to create, delete and select windows. 

 Use the View menu commands to alter the view of the model in 
the active window. 

Select View > Layout to display the View Edit dialog which allows you 
to set up customised view arrangements. For further details, see 
View Edit dialog (Menus and Toolbars). 

Select View > Toolbars > Views to display the Views toolbar, which 
provides many options to change the view. For further details, see 
View > Toolbars > Views (Menus and Toolbars). 
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 Use the middle mouse button (used with certain keyboard 
modifier keys) to dynamically alter the view by rotating, zooming 
and panning. For further details, see Middle mouse button (see 
page 136). 

 Quick Rotation allows rotation of the selected object when you 
hold down the R on the keyboard and scroll the mouse-wheel. 
The object is rotated about its principal axis by 1 degree for each 
notch on the mouse-wheel.  

 

Resetting a model 
You can delete all the changes you have made to a model since you 
last saved it. 

 Reset permanently removes all unsaved edits from the active 
model. A warning is displayed, but once you click Yes, it 
cannot be undone. 

1 From the File menu, select Reset. A warning is displayed. 

2 Click Yes to lose the edits. The model is reset. 

Click No to keep the edits. The reset command is ignored. 
 

Changing the password of a model 
You can change the password of a model as follows: 

1 Open the model with read-write permissions. 

2 In a graphics window of the model, click in an empty space to 
make sure nothing is selected. 

3 From the File menu, select Properties to display the File 
Properties dialog 

4 Use the dialog to edit the details and password of the model. 
 

Finding out what a model contains 
You can find out how many objects are stored, details of current 
levels and levels of objects in the selected model. You can edit 
details and information about a model and you can change the 
password of a model. 

From the File menu, click Properties to display the File Properties 
dialog.  

This contains the following tabs: 
 Details 

 Properties (see page 170) 
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 Custom (see page 171) 
 

File Properties dialog - Details 
The Details page of the File Properties dialog contains information 
about levels and objects for the current model in PartMaker 
Modeling. 

 
The Details page tells you the following: 

 Which levels are turned on and off. 

 The current creation levels for objects. 

 The number of objects of a particular type in the model. 

 The levels on which particular types of objects lie. 

 Totals for objects if they lie on more than one level. 

Some of the information is automatically generated by the program. 
This includes: 
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 Details about when the model was created, last modified and last 
accessed. The length of time that the model has been open is 
also included. 

 Path of the model. 

OK - This removes the dialog from the screen. 

 To print the information that is displayed, right click in the 
dialog and select Print from the popup. 
To save the information that is displayed, right click in the 
dialog and select Save To File. 

 

File properties dialog - Properties 
The Properties page of the File Properties dialog displays information 
about the model.  
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Name - Enter the name of the custom property and click Enter. 
Other parameters now become available and the name is added to 
the custom property list.  

 -Click to add a property.  

 - Highlight a name in the list and click this button to remove a 
name from the list. 

Type - The default property type is Text, but you can also choose 
Date, Number, Yes or No from the drop down list. The custom 
property list is updated to reflect your selection. 

Value - Enter an appropriate value. The custom property list is 
updated accordingly. 

OK - When you have entered all your custom properties, click OK. 

You can enter information in this dialog so that it can be included in 
text on your model or drawing. In addition, you can also use some 
information that is automatically generated by the program when 
you save a model. 

 

File properties dialog - Electrode Properties 
Use Electrode Properties to create setup strings that can be used to 
add custom electrode text to a drawing.  

You can enter information in this dialog so that it can be 
incorporated into text on your electrode model or drawing. In 
addition, you can also use some information that is automatically 
generated by the program when you save a model.  
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Information in this dialog is used when adding an electrode 
substitution string to a drawing template. 

 
Name - Enter the name of the property and click Enter. Other 
parameters now become available and the name is added to the 
property list.  

 - Click to add a property.  

 - Highlight a name in the list and click this button to remove a 
name from the list. 

 - Create a copy of the substitution string. on the Windows 
clipboard so it is ready to paste elsewhere. 
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Remember - Select Yes or No from the drop down list. If you select 
Yes, then the value for that property is automatically entered in the 
Additional Electrode Details dialog The custom property list is 
updated to reflect your selection. 

Value - Enter an appropriate value. The property list is updated 
accordingly. 

OK - When you have entered all your properties, click OK. 
 

Deleting a model 
You can delete unwanted models that are stored in the database. 
Models stored outside the database can be deleted like any other 
file using Windows Explorer. 

1 From the File menu, select Delete to display the Delete Model 
dialog (see page 173). 

2 Use the dialog to delete the model. 

 WARNING: Deleted models are permanently removed and 
cannot be recovered. 

 

Delete Model dialog 
Use this dialog to delete models. 
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Models — Click on a listed model name (to select it) and the item is 
highlighted. If you select any item, you can use the keyboard arrow 
keys  to move the highlight and scroll the list. The graphical 
tooltip displays a thumbnail of the model and file information. 

 

 Models of the form NEW_MODEL_<number> are created 
when you select File > New. These are displayed in the Models 
list only if you have system administrator security. 

Select multiple listed model names to be deleted using the standard 

SHIFT-Click  or CTRL-Click  technique to select them. 
Move the cursor over the selection to see the individual thumbnails. 

Filter — When the list of model names becomes very long, it can be 
difficult to find the model you want. Entering a filter reduces the list 
to only those models which match the filter pattern, for example, 
entering a filter of *.vl will list only those models which have the 
extension .vl. 

The filter is not case sensitive. Entering a filter of *.vl will list 
models that have the extension .VL as well as those with the 
extension .vl.  

For further details, see Filter options (Menus and Toolbars). 

We suggest that you use a designer’s initials for model name 
extensions. For example, mymodel.vnl. 
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Password — If the model is protected by a password, enter it in the 
text box. 

Delete — When you click this button, a confirmation message is 
displayed: 

 
Click Yes to remove the model from the database and return to 
the Delete Model dialog. If the Use Recycle Bin option is selected 
on the Model page of the Options dialog, the model is sent to the 
Recycle Bin (providing the bin is not full). Otherwise, the model 
is permanently removed from the system. 

Click No to do nothing and return to the dialog. 

Close — When you have finished deleting models, click Close to 
remove the Delete Model dialog from the screen. 

 

Finding out information about a model 
You can find certain information about a model, without opening it. 

1 In Windows Explorer, select a psmodel. 
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2 From the File menu, select Properties to display the File 
Properties dialog for the model. 

 
The different tabs display information that is stored whenever a 
model is saved as a psmodel. For example: 

 Date of creation 

 Application name 

 The name of the model and its description 

 Current user as the Author (on the Summary page) 

 Version of PartMaker Modeling in the Comments section (on the 
Summary page) 

When opening a psmodel, the following will be read from the 
Windows Explorer's File > Properties dialog and stored by PartMaker 
Modeling: 

 title 

 subject 

 author 

 keywords 

 comments 

 last saved by 

 revision number 
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 manager 

 company information 

This information can be used when creating text.  
 

Comparing two models 
You may have two models of the same component and want to see 
what the differences are between the two models. 

1 Open the two models you wish to compare. 

2 Suppose we have the following two models. 

 
3 Click in the graphics window of the model in which you want to 

display the differences. This makes the graphics window active. 

4 In our example, we made Model_1 the active model. 

 

5 Select Model Analysis  on the General edits  flyout. 

6 Click Model Compare (model analysis toolbar). 

7 Use the Model Compare dialogue box (see page 178) to complete 
the comparison. 
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Model Compare dialog 
Use this dialog to compare models. 

 
Primary selection - This is used to choose the model in which the 
differences are shown. On the right of this, the name of the model 
is displayed. When you first display this dialog, the Primary selection 
is the model of the active graphics window. You can change the 
Primary selection if you want. Do this by pressing down the button 
on the left of Primary, if it not already pressed down, and then 
clicking in another graphics window. The name of the model of the 
new selection is displayed. We will call this model the primary model. 
Secondary selection - This is used to choose the second model in the 
comparison. On the right of this, you can see a cross. This indicates 
that no model is selected yet. To select the second model, press the 
button to the left of the Secondary button and click in the graphics 
window of the model you want to compare. We will call this model 
the secondary model. 
Surface Trimming Comparison - You can choose how to compare 
surfaces with trim boundaries and p-curves. There are three 
options: 

Exact - This option finds surfaces with exactly the same pcurves 
and trim boundaries. 

Boundaries - This option finds surfaces with exactly the same 
trim boundaries. Any p-curve not part of a trim boundary is 
ignored in the comparison. 

None - This option treats two surfaces as the same if the 
untrimmed surfaces are the same - even if they have different 
trimmed regions. 
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OK - Compares the two models. All objects, which are in the 
primary model and not in the secondary model, are highlighted as 
selected in the primary model. 

 

 Objects that are in the secondary model but not in the 
primary model are not shown. To show these objects, simply 
carry out the above steps with the secondary model as the 
primary model and the primary model as the secondary. 

 Warning: Models are compared on the basis of positional 
information (XYZ coordinates) only. Differences, for example, 
in tangent direction, colour and level, are not picked up. This 
is done for reasons of speed. This command can be a useful 
tool to aid comparison of models, but you must use it with 
care and check manually for small differences that the 
command may not pick up. 

 

Finding duplicate objects in a model 
Sometimes, you may have a copy of an object on top of itself. Use 
this command to highlight any duplicate objects in the model. 

1 Click in the graphics window of the model in which you wish to 
find any duplicate objects. This makes the graphics window 
active. 

2 Select objects if you want to find duplicates in the current 
selection. 

3 Click Model Fixing  on the General edits  flyout. 

4 Click  (model fixing toolbar) to display the Find Duplicates 
dialogue box. (see page 180) 

5 Use the dialogue box to help you check if you have any duplicate 
objects. 
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Find Duplicates dialog 
Use this dialog to find duplicate objects within a model. 

 
Selection - This displays the name of the model to find duplicates 
objects in. By default, it is the active model. You can choose 
another open model by either clicking in its graphics window or 
selecting it from the Window menu to make it active. 

Find duplicates in the current selection - If on, duplicates are found 
only in the objects which are currently selected. Otherwise, the 
whole model is checked. 

Select first instances - If on, any instance of the object before the 
last is considered to be a duplicate. If off, any instance of the object 
after the first is considered to be a duplicated. 

Find Duplicates Method - Duplicate surfaces are selected depending 
on the two options below. 

All - This selects duplicate surfaces depending on the Surface 
Trimming Comparison option. 

Untrimmed - If all duplicate surfaces are untrimmed, this option 
selects all the duplicates. If some of the duplicate surfaces are 
trimmed, it selects all of those duplicates which are untrimmed. 

In some imported models, each surface is supplied untrimmed 
and trimmed. This command allows you to select all the 
untrimmed surfaces. 

Surface Trimming Comparison - You can choose how to compare 
surfaces with trim boundaries and p-curves. There are three 
options: 

Exact - This option finds surfaces with exactly the same pcurves 
and trim boundaries. 

Boundaries - This option finds surfaces with exactly the same 
trim boundaries. Any p-curve not part of a trim boundary is 
ignored in the comparison. 
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None - This option treats two surfaces as the same if the 
untrimmed surfaces are the same - even if they have different 
trimmed regions. 

OK- The dialog is removed from the screen. All duplicated objects 
are highlighted as selected and an information box is displayed 
showing how many items are duplicates. 

 For each set of duplicate objects, one is not selected. This 
allows you to operate on all duplicates within a model. For 

example, you can now delete them all by clicking Delete . 

 Warning: Duplicates are detected on the basis of positional 
information (XYZ coordinates) only. Objects may be selected 
as duplicates even if they differ in level, colour, tangent 
direction, or other non-positional ways. 

 

Tools > File doctor 
This option provides tools to check and repair model files and the 
shared database. File Doctor is automatically opened if there have 
been errors in the session and you try to save an model using Save 
As or Save. This gives you the opportunity to correct errors and will 
help prevent you working with a model that is already corrupt.  

 File Doctor contains powerful tools. If it is used incorrectly, 
serious damage can be caused to your model or to your 
shared database. Consult Delcam Customer Support before 
using File Doctor on the shared database and always make a 
Full system backup before proceeding. Ensure you have back-
up copies or duplicate models before using File Doctor on 
models. 
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1 From the Tools menu, select File Doctor to display the File Doctor 
dialog. 

 
2 Use the File Doctor dialog (see page 185) or File Doctor 

(Advanced Mode) dialog (see page 187) to check the model. 

 When a model is recovered a copy of the original is kept. The 
settings that control the action and the location of the copy 
can be changed by editing powershape.con. The default 
settings keep a copy of the original in the temp directory. 

 

Using the File Doctor - step by step 

 If you position the mouse in the information window of the 
File Doctor dialog and click the right mouse button, the popup 
menu that is displayed includes printing and saving options.  

 
1 Ensure that the corrupt model is open. We recommend that this 

is the only model open. 
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2 Select Tools - File Doctor to display the standard File Doctor 
dialog (see page 185). 

 
3 Click Run. The File Doctor tries to identify the problem and uses 

the dialog to tell you what is wrong with the model. 
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4 Click Save As. This is the recommended selection so that you 
have a ‘safe’ copy. 

 
5 The dialog that is displayed includes a suggestion of a fix that 

could be applied. 

The type of fix offered by the File Doctor depends on the errors 
that are detected in the model. If possible, File Doctor will offer a 
fix that does not delete model geometry, such as replaying or 
removing the solid history tree. 

 Whilst replaying a solid history tree can fix some problems, 
it is possible that certain errors could cause PowerSHAPE to 
hang or crash whilst replaying. If this should happen, 

1. Restart PowerSHAPE. 

2. Reload the model that was saved before the fix (step 4). 

3. Run File Doctor and when offered to replay the solid(s), 
choose No. 

4. You are now offered the choice of keeping the surface 
geometry (but losing the solid history tree) or keeping as 
much of the history tree as possible (but losing some 
features from the tree). 
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6 At the end of the process, File Doctor will tell you the geometry 
(if any) that had to be deleted to fix the model. 

 
7 Click Close to exit File Doctor. 

8 Check the model carefully and save it if you are satisfied with the 
fix.  

 Recovery from a crash is not possible until you have saved 
the fixed model. 

 

File Doctor dialog 
The standard version of the File Doctor dialog displays problems that 
are found with the model and suggested fixes. 
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The initial layout of buttons is shown. The buttons that are initially 
shown as Run and Advanced will change depending on the stage of 
the process. 

The following buttons may be displayed at the bottom of the dialog: 

Run - Start File Doctor check on the current model. 

Advanced - Switch to advanced version of the File Doctor and 
display the File Doctor (Advanced Mode) dialog (see page 187). This 
mode gives full control over the checks and fixes that are run by the 
File Doctor. Only experienced users should use this option. 

Save As - Save the model under a new name before proceeding with 
the File Doctor fixes. 

Skip Save - Skip saving the model under a new name and move 
onto the fixing stage of the File Doctor. 

Yes - Apply the possible fix. 

No - Skip the fix. 

Keep geometry - Fix a solid by maintaining surface geometry but 
removing the solid feature tree. 

Keep history - Fix a solid by removing features with errors from the 
feature tree. 

Reset - Reload the model that was saved before the File Doctor fix. 
This option is only available if the model was saved before the fix. 

Close - Finish File Doctor. 

 If you position the mouse in the information window of the 
File Doctor dialog and click the right mouse button, the popup 
menu that is displayed includes printing and saving options.  
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File Doctor (Advanced Mode) dialog 
File doctor allows you to recover damaged models which would 
otherwise be unusable. If you would prefer to use the standard File 
Doctor dialog, type Standard in the command input box on the 
Status bar. 

 

 - Options from this menu automatically turn on 
the checks on the dialog. Use this menu to select one of the 
following: 

Quick Check of Model - This selects only the Integrity check in the 
Quick Model section. 

Full Check of Model - This selects the Integrity check and all the 
checks in the Full Model section. 

Check Shared Database - This selects the Integrity check and all 
the checks in the Shared Database section. 

User-defined - This allows you to select any check. It is also 
selected if you change the checks after selecting one of the three 
options above. 

Quick Model - This section contains the following check: 

Integrity check - This checks if any objects within the model refer 
to missing objects and explicit indexes. 

If you select Check, an information window is displayed showing 
a list of errors. You will be alerted to any missing indexes. 
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If you select Check & Fix, the objects containing errors are 
deleted from the model. File Doctor displays an information 
window, showing the list of faults (if any) within the model that 
have been cured and any missing indexes that have been 
created. However, under some circumstances (such as where 
many objects refers to a missing object), automatic fixing can 
cause considerable damage. We therefore recommend that 
Check & Fix is used only when you have made a backup copy of 
the model. 

Replay active solid (slow) and Replay all solids (very slow) allow you 
replay the solid feature trees. 

Full Model - This section contains the following checks: 

 Rebuild indexes - All models contain index files. This option clears 
the model indexes and builds new ones, but only when Check & 
Fix is clicked. There is no Check option for indexes. 

 Rebuild Graphical Reps - ensures that each object geometry 
definition has a matching and valid graphical representation. The 
option is only available under the Check & Fix option. To explain 
what it does: 
Each object in PartMaker Modeling (such as lines and arcs) has 
two main components. These are the geometry definition and the 
graphical representation. The latter describes how the object is 
currently displayed in the various views on the screen. It can 
sometimes become corrupted (e.g. missing or incorrect) while 
the geometry definition is correct. Typical problems are that the 
object displays incorrectly or not at all or is not selectable. 

 Rebuild General Attributes - If you choose Check, you are told if 
there are any errors in the styles of the objects. If you select 
Check & Fix, the styles with errors are replaced with a solid, 
foreground colour and width 0.3 style. 

 Dependencies - If you choose Check, you are told if there are any 
errors in surface and vector dependencies. Dependencies are 
relationships between geometric objects. For example, a solid 
block or cylinder has a relationship between the main surface 
and the two capping surfaces. Surface primitives have 
dependencies between the surface and the set of parameters (for 
example, length and diameter) that define them. 

If you select Check & Fix, File Doctor deletes any bad 
dependencies. 

 We recommend you first run Rebuild Indexes from this section 
as database table indexes are often corrupt when surface 
dependencies are corrupt. 
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With Check & Fix, editing dependencies of some objects may 
alter the dependencies of other objects. We advise you to run 
Check & Fix repeatedly until no further dependency errors are 
reported. 

 Rezone - The model is divided into zones. When an object is 
picked, only the zones beneath the cursor are searched, which 
considerably speeds-up the picking operation. If an object 
becomes incorrectly zoned (as can happen occasionally), it 
displays correctly, but cannot be picked. This option regenerates 
these zones, curing most of the problems associated with 
unpickable objects. It is only available with Check & Fix. 

 Check Drawability - PartMaker Modeling should be able to draw 
(on the screen) every object within a model. This option checks 
each object and deletes any that cannot be drawn. This option 
also checks for items that are undisplayable. If the File Doctor is 
run in Check & Fix mode, the undisplayable items are deleted. 

 Drawability in this context has no connection with "drawing" 
as used in Drafting. 

 Check Surface Trimming - If you choose Check, you are told if 
there are any trimming problems on the surfaces. If you select 
Check & Fix, then PartMaker Modeling attempts to repair the 
surfaces. If some boundaries can't be repaired, they are deleted 
and you are told which ones are deleted. 

Select the Check all trimming option on the Advanced File Doctor 
dialog to ignore any previous surface trimming checks and re-
check and fix every surface. 

 Check Names - If you choose Check, you are told if objects have 
duplicate or invalid names. If you select Check & Fix, PartMaker 
Modeling renames objects with duplicate or invalid names. 

 Check Arcs - A valid arc has a start, end, mid and centre point 
and each point has a different ID and is owned by the arc. If you 
choose Check, you are told if any arc in the model is invalid. If 
you select Check & Fix, PartMaker Modeling deletes invalid arcs. 

 Check Solids - This checks solids and their feature trees for 
corruption. If you select Check & Fix, the corruption is repaired. If 
the corruption is caused by one of the features in the solid tree, 
PartMaker Modeling tries to fix this feature. If this is not possible, 
the feature tree for the solid is deleted. 

 Check Assembly Objects - This checks components and 
component definitions for corruption. If you select Check & Fix, 
the corruption is repaired. If this is not possible, data that cannot 
be repaired will be deleted. 
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 Check Orphaned Drawing Items - Some model items that are 
displayed in a drawing view but not displayed in model windows, 
such as centrelines, can be orphaned if the drawing view is 
deleted. This option checks for and removes any orphaned 
drawing items.  

Shared Database - This section contains the following checks: 

 Integrity check - This does a full integrity check/fix on the shared 
database. 

 Rebuild indexes - This deletes and rebuilds the shared database 
indexes. These can sometimes become corrupted. For example, a 
hardware or software problem (such as insufficient disk space) 
occurring while creating, saving or deleting a model can cause 
damage. Affected models disappear from the menu list (as if 
deleted) or can appear twice. Regenerating usually solves these 
problems. The option is only available with Check & Fix. 

 Page Files - rebuilds the page files, ensuring all are correct. It is 
available only with Check & Fix. To explain the purpose of the 
files: 
The database tables keep a temporary copy of their current state 
in page files, from which data is paged in and out from core 
memory. These files can be damaged by a hardware or software 
problem occurring during a database update. The damage will 
affect all Delcam programs which use that database. 

 We recommend that all users stop working with Delcam 
products before any option from the Shared Database section 
is used. 

Simple Fixing -  If ON, simple fixes will be carried out when running 
File Doctor checks. Any corrupted data will be deleted. If OFF, the 
File Doctor will attempt to work round the corrupted data. For 
example, it will attempt to remove a single corrupt feature from the 
solid tree instead of removing the entire tree. Using Simple Fixing is 
more reliable, but it may delete a lot more of the model data. 

Check - This checks and displays a report of any faults found by the 
File Doctor routine(s). 

 The Check only option is more useful to Delcam Technical 
Support staff than to regular users. You may find the errors 
reported rather unintelligible. 

Check & Fix - This checks and repairs the data within the model. 
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 WARNING: All errors found by File Doctor are potentially 
serious and could cause the program to crash or malfunction 
(perhaps causing further corruption). You should always 
remove the errors with Check & Fix before continuing. In 
many cases, it works by deleting faulty objects. If this deletes 
large portions of your model, contact Delcam Technical 
Support, who may be able to retrieve some of the lost data. 
However, do NOT continue working on a corrupt model or 
database. 

 

Submitting model information 
When a database error is detected a dialog is displayed with a 
request to submit your model and macros to Delcam. 

 
1 Click Yes to create the zip file. It is recommended that you create 

as requested.  

 
2 Click OK to complete the operation. 

3 Send the file to your local Delcam supplier. 

 Note that the date and the time are included in the filename. 
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Importing and Exporting a model 
Use the following sections to import and export data: 

Exporting data from a model (see page 192) 

Importing data into a model (see page 197) 
 

Exporting data from a model 
You can export models to formats other than PartMaker Modeling. 

1 Select the model or the specific objects you want to export. 

2 Select File > Export from the menu to display the first page of 
the Export Wizard. 

3 Use the Export Wizard to select the target system and settings 
for exporting files. Alternatively, click Finish to export the data 
using the following defaults: 

 export selected items, or the entire model if nothing is 
selected. 

 if a workplane is active, export the geometry to active, 
otherwise, export to World. 

 if a drawing window is active, export the converted drawings. 

 The default for .dgk is to export to World. You can use the 
Export Wizard to export .dgk to the active workplane.  

For advanced modelling concepts, see: 

 Using Delcam Exchange to translate data 

 Exporting data without a licence 

 Exporting materials 
 

Using the Export Wizard 
Use the Export Wizard to: 

 export selected model items, visible items or all items. 

 export relative to an active workplane or World. 

 export drawings. 
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1 Select File > Export to display the Export Wizard. 

 
2 Select the target system for export from the list. 

3 Click Next to display the Export File dialog. 

The file name of your model is automatically displayed as the 
filename. Change the File name as required and select the file 
type from the Save as type list. 

4 Click Save. The subsequent pages that are displayed depends on 
your export: 

 if you are exporting a model that includes at least one 
drawing, page 2 is displayed (see page 195). 

 if you are exporting a model that does not include drawings, 
page 3 is displayed (see page 195). 

 if your model includes workplanes, page 4 is displayed (see 
page 196). 

 if you are exporting a model that includes mutiple drawings, 
page 5 is displayed (see page 197). 

5 Select the appropriate options on the export pages that are 
displayed. 

6 Click Finish to complete the export. 
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Export File dialog 
Use this dialog to export files in the format selected on the Export 
dialog. 

 
1 Select the correct Save in folder. If necessary, use the following 

to locate the required folder: 

 Click  to go up one level in the folder structure. 

 Click  to create a new folder. 

 Click  to display a menu containing options on how to 
display the files in the dialog. 

2 Enter the File name. If you enter a file name with no extension, 
the Save as type extension is automatically added.  

If you enter a filename with a valid export extension, the Save as 
type extension type overrides the type entered in the file's name. 

3 Select the required export file type from the Save as type list. 

4 Click one of the following: 

 Save to export data as specified. 

 Cancel to remove the dialog from the screen without exporting 
any files. 

 You can use either the PartMaker Modeling internal translators 
or Delcam Exchange to export data. 
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You cannot export badly trimmed surfaces. PartMaker 
Modeling tells you if badly trimmed surfaces are detected on 
export and gives you two options: 

 Export the selection with the offending surfaces untrimmed. 

 Abandon the export. This allows you to fix the surfaces using 
the trim region editing tools. 

 

Page 2 - Exporting a model that includes drawings 
Use this page to export a model that includes drawings. 

 
1 Select one of the options to specify the items to be exported: 

 model geometry only 

 drawings 

 drawings and associated model geometry 

2 Click Next or Finish. 
 

Page 3 - Exporting a model 
Use this page to specify the model items that you want to export. 
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1 Select one of the options to specify the items to be exported: 

 If you pre-selected some items, then Selected is the default 
option. 

 Visible exports items that are visible on the screen; if an item 
is blanked it is not exported. This option is useful for 
exporting the workplanes with a model. 

 All is the default option and is automatically selected if there 
are no pre-selected items. 

2 Click Next or Finish. 
 

Page 4 - Exporting workplanes 
Use this page to specify the workplane to be used at export.  

 
1 Select the option to be used when exporting: 

 Export relative to Active workplane. 

 Export relative to World. 

2 Click Next or Finish. 
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Page 5 - Selecting a drawing to export 
Use this page to select the drawings to be exported. This page is 
displayed only if there are multiple drawings associated with the 
model. 

 
1 Select the drawings to be exported. 

2 Click Finish. 
 

Importing data into a model 
When you import a model, it is automatically opened as a new 
model. However if you import any other file, it is opened in the 
current model window. 

 When you import a file, the model is zoomed to full, so the 
geometry is visible. This is particularly useful if the items are 
not close to the origin. 

You can use one of the following methods to import data: 

 Select File > Import. 
 Click Import (see page 197) on the Main toolbar. 

 Use the Advanced Import options to set up the data. 

 Drag and drop files into the graphics area to import them. 

For advanced modelling concepts, see: 

 Advanced Import options 

 Importing data without a licence 

 Importing Materials 
 

Using the Import option 
1 Select File > Import.  
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This is the same as clicking Import  on the Main toolbar. 

2 Browse to the folder containing the file you want to import. 

 
3 Click Open. 

The file is imported and opened. 

For further details, see Importing data into a model (see page 197). 
 

Import dialog 
Use this dialog to select files to import. 

 
1 Select the correct Look in folder. If necessary, use the following 

to locate the required folder: 
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 Click  to go up one level in the folder structure. 

 Click  to create a new folder. 

 Click  to display a menu containing options on how to 
display the files in the dialog. 

2 Enter the File name.  

3 Select the required import file type from the Files of type list. 

This displays the filter pattern which filter the file names of the 
current directory. By default, the pattern is *.* which displays all 
files. This selector lists the default filters for the file types that 
can be imported. You can select a filter from the list. When a 
filter is selected, files satisfying that filter are displayed. 

 Files of type is used only to help find files more easily. It 
does not determine the type of file to be imported. When a 
file is imported, the program looks at the contents of the 
file to determine its type and not its name. For example, if 
Files of type is set to *.pic, you can still import an IGES file 
by typing in the name in the File name text box. If an IGES 
file is called file.pic, this filter will help find it, but the file 
will still be imported as an IGES file. 

When importing IGES files, the program uses its own default 
tolerance values. You can change the defaults on the Options 
dialog before importing. The new values affect only the current 
model. Remember, large tolerances produce poor quality 
surfaces and small tolerances make the application run slowly. 
You may need to experiment to find the best balance for your 
models. 

4 Click one of the following: 

 Open to import data as specified. 

When you import certain files, a log file is generated 
containing details about the import. This log file is added to 
either the directory containing the imported file or the temp 
directory. 

If you import a model that has the same name as one already 
in the model database, its name is appended with [n] where n 
is an integer. The integer starts at 1 and increases as other 
models with the same name are imported. When such a 
model is imported, you need to open it using the Open Model 
dialog. (see page 164) 

Generally, models are automatically opened in the program 
when they are imported. 
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 Cancel to remove the dialog from the screen without 
importing any files. 

 If you import files into a new model, the name of the last 
imported file (minus its extension) is automatically displayed 
as the Model Name in the Save Model As dialog when you save 
the model. For example, if the name of the last file imported 
is handle.igs, the Model Name is handle in the Save Model As 
dialog. This name is also displayed in the banner of the 
model's window, next to the new model's name. For example, 
NEW_MODEL_1(handle). 

 You can use either PartMaker Modeling's internal translators 
or Delcam Exchange to import data. For further details, see 
Using Delcam Exchange to translate data. 

 

The coordinate system 
The coordinate system defines the position of every object within 
the global workspace. The coordinate system contains the three 
axes X, Y, and Z which meet in the centre of the workspace, at a 
position called the origin.  

All models are created within the global workspace. Every position 
in a model is defined as three coordinates. For example, a position 
of 9,5,3 means 9 along the X axis, 5 along the Y axis and 3 along the 
Z axis. These coordinates are shown in the image below: 

 X = 9 

 Y = 5 

 Z = 3 
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 Position 9,5,3 

 
You create a model while working entirely within the global 
workspace, selecting the default drawing plane (also known as the 
principal plane) and entering coordinate values when necessary.  

However, models can contain many angled faces and it is often 
easier to specify coordinates relative to a face rather than to the 
model as a whole. You can do this using workplanes (see page 
201), shown in the image below: 

 Dimensional axes X,Y,Z 

 Origin 

 
For further details, see Creating a workplane in the Wireframe 
modelling manual. 

 

Workplanes and the coordinate system 
A workplane is a graphical object defining a local coordinate system.  

You can:  

 have as many workplanes as you like. 
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 place workplanes anywhere in the model. 

 rotate the axes to align conveniently with features of the model. 

The image below shows example of a local coordinate system: 

 
 Local coordinate system (Workplane). Convenient for: 

 Face D. 

 Angled feature E. 

 Local coordinates 20,0,0. Global coordinates 437,62.8,28.7 

 Global workspace coordinate system for faces A, B, C. 

 Local coordinate system (Workplane). Ideal for faces A,B,C 

Only one workplane can be active at a time, which is known as the 
active workplane. It is shown in red in the default colour scheme. 
Inactive workplanes are grey. 

Any specified coordinates apply to this workplane, not to the global 
workspace. PartMaker Modeling converts the local values to global 
values automatically and invisibly. 

The three axes of a workspace listed below define three planes. 
These are known as the principal planes (see page 203). 

 the XY plane lies through the X and Y axes 

 the ZX plane lies through the X and Z axes 

 the YZ plane lies through the Y and Z axes 
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Principal planes and the coordinate system 
The Principal plane buttons  on the Status bar (see page 
125) define which plane is the principal plane of the workspace. You 
can see this graphically as the axis of the rotation tracker updates 
in the modelling window. When clicking the mouse to enter 
positions in an empty space, the positions lie on the principal plane. 

 Each button displays the label of the axis which is normal to 
the principal plane. 

 

Entering positions 
To create an object, you need to specify its position in the 
workspace. Entering positions is one of the most common and 
important operations use the following methods for entering 
positions:  

Entering positions using the cursor (see page 203) 

Entering positions using the Intelligent Cursor (see page 153) 

Entering positions using the status bar  (see page 205) 

Entering positions using dialogs (see page 207) 

You can also create point objects to mark locations in your model.  
 

Entering positions using the cursor 
As the cursor moves across the principal plane (see page 203) (for 
example XY of the active workplane or global workspace), its 
coordinates with respect to the active workplane are shown in the 
status bar (see page 125). To enter a new position, move the cursor 
and click. 

If the cursor is clicked within a certain radius of an existing object, 
the cursor snaps to the closest key point that exists on the object or 
snaps to a point of intersection between objects. This radius is 
known as the hit radius. 

 

Entering positions using the Intelligent Cursor 
The Intelligent Cursor shows additional information to help you to 
define the position you want when entering positions.  

When you move the cursor over an object, construction labels (see 
page 153) are displayed by the Intelligent Cursor. These 
construction labels: 

 are shown and hidden as you move the cursor over them. 

 indicate what happens if you click while the label is displayed. 
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 make snapping with the cursor more accurate. The labels display 
when key points are within snap range of key positions in the 
model. You can click when a label (see page 153) is displayed to 
snap to the cursor at the labelled position.  

 The Intelligent Cursor (see page 148) is enabled by default. 
 

Construction lines 
When you hover the Intelligent Cursor over an important key point 
(one that displays any of the construction labels (see page 153)), 
construction lines are created from that key point. You can now 
drag the cursor along a construction line and see the appropriate 
labels display. Clicking causes the position to snap to that point.  

The following example draws a box: 

1 On the Main toolbar, select the Line  button. 

2 On the Line toolbar, select the Continuous  button. 

3 Click to start a line. 

 
Drag along a construction line and click. 

 
4 Drag along a 90  construction line and click. The line snaps to 

give a square intersection. 

 
5 Drag the cursor down to the original start point and hover. The 

cursor displays End and the construction lines display. 
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6 Drag along the vertical construction line until Intersection is 
shown. 

 
7 Snap to the start and finish with one more click when End is 

displayed. 

 
If the Intelligent Cursor Gridding is enabled, the label On in the 
above diagrams is replaced by a distance from the last point 
selected. For example: 

 
This provides a convenient way to enter accurate dimensions. 

 To disable construction lines temporarily, press and hold the 
Shift key. 

 

Entering positions using the status bar 
You can enter Cartesian (see page 205) and polar (see page 206) 
positions in the Data entry box on the Status Bar (see page 125). 

You can also type the coordinates in the graphics window and they 
are entered automatically into the Data entry box on the status bar. 
When you press the Enter key, coordinates are entered into 
PartMaker Modeling.  

For more complex constructions click the Position  button on the 
Status Bar, to display the Position dialog (see page 208). 

 

Entering Cartesian positions 
The syntax for entering Cartesian positions (using the status bar) is 
as follows: 

[workspace] X [Y [Z]] [units] 
Square brackets [ ] show elements that are optional. 

workspace specifies the origin from which to measure the 
coordinates. 
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You can use the following options: 

 world = world workspace. You can abbreviate world to w. 

 absolute or @ = absolute workspace. This uses the origin of 
the current workspace. You can abbreviate absolute to abs. 

 relative = relative workspace. This uses the last point entered 
as the origin. You can abbreviate relative to re. 

X [Y [Z]] - These are the X Y and Z coordinates and are entered in 
this order by default. If the second and third values are not given, 
they are treated as zeros. 

The order of the X Y and Z coordinates is determined by the Local 
point input option on the Workplane page of the Options dialog. For 
further details, see Workplane options (Menus and Toolbars). 

units - You can enter the type of units, for example, mm or inches. 
Default units are used if none are specified. 

Examples of Cartesian coordinates are given below. 

20 30 40 

w 15 

@ 25 60.8 mm 

abs 50 mm 

re -30.7 0 90 

You can also enter polar positions. For further details, see Entering 
polar positions (see page 206). 

 

Entering polar positions 
The syntax for entering polar positions (using the status bar) is as 
follows: 

> angle [angle_units] length [length_units] 
Square brackets [ ] show elements which are optional. 

> indicates that polar coordinates are being entered. 

angle is the value of the angle. 

angle_units is the unit type, for example, degrees. 

length is the value of the length. 

length_units is the unit type, for example, mm. 

Examples of polar coordinates are given below. 

> 45 30 

> 45 degrees 30 mm 
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> 30 2.5 inches 
You can also enter Cartesian positions (see page 205). 

 

Entering positions using dialogs 
Where a dialog expects a position to be entered, separate text 
boxes for the X, Y, and Z axes are provided. Click the Position  
button to display the Position dialog (see page 208) for more 
complex point entry tools. 

 
To enter a position as three coordinate values directly into a dialog: 

1 Click in the X axis box to select it and enter the value  

2 Press the tab key to select the Y axis box, or click in the box.  

3 Enter the value and repeat to enter the value for the Z axis box. 

4 Click OK on the dialog to store the values. 
 

Position dialog overview 
When it is not sufficient to enter positions using the cursor, the 
status bar, or dialogs, use the tools on the Position dialog (see page 
208) to assist with more complex constructions. For example, you 
may want to specify a point at a particular proportion along an 
object. 

the values for the X, Y, Z axes 

Display the Position dialog (see page 208) using one of the following 
methods: 

 Click Position  on the status bar (see page 125) 

 Click  on a dialog.  

For further details, see Entering positions using dialogs (see page 
207). 

 The Position  button is active only when positions are 
required by the program. For example, when in object 
creation mode or when editing objects. 
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Position dialog 
Use the tools on the Position dialog to specify positions and 
constructions (see page 203). 

 
Click a tab on the dialog to display the relevant page of position 
entry tools: 

Cartesian (see page 208) 

Polar (see page 210) 

Along (see page 212) 

Between (see page 214) 

Intersect (see page 215) 

Normal (see page 217) 

KeyPoint (see page 219) 

Vector (see page 221) 

Circle 
 

Cartesian tab 
Use the Cartesian tab of the Position dialog (see page 208) to enter 
positions in the separate entry boxes provided for each axis. You 
can lock each individually by clicking . 

Usually you can enter a value in a box without affecting the other 
values. However if you have locked some components on the Polar 
tab (see page 210), then the values of the other fields may change 
to comply with the constraints created by the locks. 
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If you click a position in the graphics window, its Cartesian 
coordinates are displayed in the dialog. 

 
Workspace — Select the workspace you are working in. The 
available options are:  

Relative — The position being defined is relative to another 
position which becomes the origin of the workspace. The 
positions are aligned with the active workplane or the global 
workspace if no workplane is active. 

Relative mode is not always available since there may not be a 
suitable relative co-ordinate. In this case, select a suitable 
position (such as the intersection of two lines) and make it the 
origin of a relative workspace with the Become Origin option. 

Workplane — The position being defined is relative to the 
active workplane if one exists. 

World — The position being defined is relative to the global 
coordinate system. 

 If any items are locked, the locks are discarded when you 
select a different workspace. 

Current Plane — Use this drop down list to select one of the three 
principal planes. The current plane is relative to the selected 
Workspace option. 

 Locked and  Unlocked — Click to toggle between Locked and 
Unlocked. Locking a value ensures that it remains fixed regardless 
of what happens to other components. The lock remains ON until 
you click again to unlock it. When an editing box is affected by a 
lock, it is dimmed to show that it is unavailable. 
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 Unlock all — Click this button to unlock all of the values above. 

Become origin — Click this button for the coordinates of the position 
defined by the dialog to become the origin. Any relative coordinates 
are measured from this origin. 

Apply — Inputs the position. If the current operation allows multiple 
points, the dialog remains displayed ready for you to enter more 
points. Otherwise, the dialog is removed from the screen. 

OK — Inputs the position and removes the dialog. 

Cancel — Aborts the position entry. 
 

Polar tab 
The Polar tab of the Position dialog (see page 208) is affected by the 
Current plane setting, which determines how the coordinates are 
calculated from the Angle and Elevation/Height fields. 

Click a position in the graphics window to enter Polar coordinates 
into the dialog. 

 
Workspace — Select the workspace you are working in. The 
available options are:  
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Relative — The position being defined is relative to another 
position which becomes the origin of the workspace. The 
positions are aligned with the active workplane or the global 
workspace if no workplane is active. 

Relative mode is not always available since there may not be a 
suitable relative co-ordinate. In this case, select a suitable 
position (such as the intersection of two lines) and make it the 
origin of a relative workspace with the Become Origin option. 

Workplane — The position being defined is relative to the 
active workplane if one exists. 

World — The position being defined is relative to the global 
coordinate system. 

 If any items are locked, the locks are discarded when you 
select a different workspace. 

Current Plane — Use this drop down list to select one of the three 
principal planes. The current plane is relative to the selected 
Workspace option. 

Angle — Enter the polar angle from the origin in the currently 
selected plane in the selected workspace.  

Distance — Select one of the following options from the drop-down 
list: 

 Distance — Enter the distance from the workplane origin. 

 X, Y, or Z — Enter a distance on the axis on the current active 
plane. 

Elevation — Select one of the following options from the drop-down 
list: 

 Elevation — Enter the angle of elevation above the active plane 
from the origin of the workspace. 

 Height — Enter the distance perpendicular to the selected plane. 
For example, the Z component when the XY plane is selected. 

 Locked and  Unlocked — Click to toggle between Locked and 
Unlocked. Locking a value ensures that it remains fixed regardless 
of what happens to other components. The lock remains ON until 
you click again to unlock it. When an editing box is affected by a 
lock, it is dimmed to show that it is unavailable. 

 Unlock all — Click this button to unlock all of the values above. 

Become origin — Click this button for the coordinates of the position 
defined by the dialog to become the origin. Any relative coordinates 
are measured from this origin. 
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Apply — Inputs the position. If the current operation allows multiple 
points, the dialog remains displayed ready for you to enter more 
points. Otherwise, the dialog is removed from the screen. 

OK — Inputs the position and removes the dialog. 

Cancel — Aborts the position entry. 
 

Along tab 
Use the Along tab of the Position dialog (see page 208) to create a 
position at a chosen parameter along a selected object. 

 You can select composite curves when you are using the 
Along tab of the Position dialog: 

 
Workspace — Select the workspace you are working in. The 
available options are:  

Relative — The position being defined is relative to another 
position which becomes the origin of the workspace. The 
positions are aligned with the active workplane or the global 
workspace if no workplane is active. 

Relative mode is not always available since there may not be a 
suitable relative co-ordinate. In this case, select a suitable 
position (such as the intersection of two lines) and make it the 
origin of a relative workspace with the Become Origin option. 

Workplane — The position being defined is relative to the 
active workplane if one exists. 

World — The position being defined is relative to the global 
coordinate system. 
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 If any items are locked, the locks are discarded when you 
select a different workspace. 

Object — Select an object using the mouse. When an object is 
selected, its name is displayed in the text box. 

Select one of the following options and enter a value, or use the 
slider: 

Proportion — Enter a measurement for the proportional distance 
from the start of the object. For example, enter 0.5 for half way 
along or enter 0.25 for a quarter (or 25%) of the way along from 
the start of the object.  

Distance — Enter a measurement from the start of the object. 

The slider indicates the portion from the start of the object. By 
default, the slider has 10 divisions. You can change the number of 

graduations on the slider by using . Use the arrows to select 
a value or type a value into the box. 

 Locked and  Unlocked — Click to toggle between Locked and 
Unlocked. Locking a value ensures that it remains fixed regardless 
of what happens to other components. The lock remains ON until 
you click again to unlock it. When an editing box is affected by a 
lock, it is dimmed to show that it is unavailable. 

 Unlock all — Click this button to unlock all of the values above. 

Become origin — Click this button for the coordinates of the position 
defined by the dialog to become the origin. Any relative coordinates 
are measured from this origin. 

Apply — Inputs the position. If the current operation allows multiple 
points, the dialog remains displayed ready for you to enter more 
points. Otherwise, the dialog is removed from the screen. 

OK — Inputs the position and removes the dialog. 

Cancel — Aborts the position entry. 
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Between tab 
Use the Between tab of the Position dialog (see page 208) in the 
same way as the Along tab (see page 212), but instead of using 
points at the ends of an object, select the start and end points 
which need not be on the same object. This allows accurate 
placement of a position between two connected or unconnected 
positions. 

 
Workspace — Select the workspace you are working in. The 
available options are:  

Relative — The position being defined is relative to another 
position which becomes the origin of the workspace. The 
positions are aligned with the active workplane or the global 
workspace if no workplane is active. 

Relative mode is not always available since there may not be a 
suitable relative co-ordinate. In this case, select a suitable 
position (such as the intersection of two lines) and make it the 
origin of a relative workspace with the Become Origin option. 

Workplane — The position being defined is relative to the 
active workplane if one exists. 

World — The position being defined is relative to the global 
coordinate system. 



 

PartMaker Modeling 2015 Getting Started Getting Started with PartMaker Modeling 2015 • 215  

 If any items are locked, the locks are discarded when you 
select a different workspace. 

Current Plane — Use this drop down list to select one of the three 
principal planes. The current plane is relative to the selected 
Workspace option. 

Click two positions in the model to enter the values for the following 
options: 

First point — This displays the coordinates of the first click. 

Second point — This displays the coordinates of the second click. 

Select one of the following options and enter a value, or use the 
slider: 

Proportion — Enter a measurement for the proportional distance 
from the start of the object. For example, enter 0.5 for half way 
along or enter 0.25 for a quarter (or 25%) of the way along from 
the start of the object.  

Distance — Enter a measurement from the start of the object. 

The slider indicates the portion from the start of the object. By 
default, the slider has 10 divisions. You can change the number 

of graduations on the slider by using . Use the arrows to 
select a value or type a value into the box. 

Resultant point — This displays the coordinates of the between value 
as defined by the dialog. 

 Reset — Click this button to reset the values on the page. 

Become origin — Click this button for the coordinates of the position 
defined by the dialog to become the origin. Any relative coordinates 
are measured from this origin. 

Apply — Inputs the position. If the current operation allows multiple 
points, the dialog remains displayed ready for you to enter more 
points. Otherwise, the dialog is removed from the screen. 

OK — Inputs the position and removes the dialog. 

Cancel — Aborts the position entry. 
 

Intersect tab 
Use the Intersect tab of the Position dialog (see page 208) to find 
the position where two objects intersect. 
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 You can select composite curves when you are using the 
Intersect page of the Position dialog: 

 
Workspace — Select the workspace you are working in. The 
available options are:  

Relative — The position being defined is relative to another 
position which becomes the origin of the workspace. The 
positions are aligned with the active workplane or the global 
workspace if no workplane is active. 

Relative mode is not always available since there may not be a 
suitable relative co-ordinate. In this case, select a suitable 
position (such as the intersection of two lines) and make it the 
origin of a relative workspace with the Become Origin option. 

Workplane — The position being defined is relative to the 
active workplane if one exists. 

World — The position being defined is relative to the global 
coordinate system. 

 If any items are locked, the locks are discarded when you 
select a different workspace. 

Select two objects in the model to find the intersection. The names 
of the selected objects are displayed in the following options: 

One — The name of one of the objects selected is displayed. 

Two — The name of the other object selected is displayed. 

In order to find intersections, PartMaker Modeling does the 
following: 

 If the position does not lie on either object, the objects are 
extended. 
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 Lines are treated as if they are of infinite length. 

The intersection point of two lines that don't cross is shown 
below. 

 
 Arcs are treated as full circles. 

 If there are two possible intersections, the intersection position is 
the one closest to the last mouse click. 

 Curves are extended by maintaining the curvature at the end 
point. 

 
Become origin — Click this button for the coordinates of the position 
defined by the dialog to become the origin. Any relative coordinates 
are measured from this origin. 

Apply — Inputs the position. If the current operation allows multiple 
points, the dialog remains displayed ready for you to enter more 
points. Otherwise, the dialog is removed from the screen. 

OK — Inputs the position and removes the dialog. 

Cancel — Aborts the position entry. 
 

Normal tab 
Use the normal tab of the Position dialog (see page 208) to enter a 
position which is perpendicular to an object from the origin of the 
workspace displayed on the dialog. 
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 You can select composite curves when you are using the 
Normal tab of the Position dialog: 

 
Workspace — Select the workspace you are working in. The 
available options are:  

Relative — The position being defined is relative to another 
position which becomes the origin of the workspace. The 
positions are aligned with the active workplane or the global 
workspace if no workplane is active. 

Relative mode is not always available since there may not be a 
suitable relative co-ordinate. In this case, select a suitable 
position (such as the intersection of two lines) and make it the 
origin of a relative workspace with the Become Origin option. 

Workplane — The position being defined is relative to the 
active workplane if one exists. 

World — The position being defined is relative to the global 
coordinate system. 

 If any items are locked, the locks are discarded when you 
select a different workspace. 

Normal to object — Click the object you want the position to be 
normal to. The name of the object is displayed in the box and the 
cursor moves to the position normal to the object. 

To allow positions to be found that do not lie on the object, 
PartMaker Modeling does the following: 

 Lines are treated as if they are of infinite length  

 Arcs are treated as full circles. 

 An error dialog is displayed if a position cannot be found 
normal to the selected object. 
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Become origin — Click this button for the coordinates of the position 
defined by the dialog to become the origin. Any relative coordinates 
are measured from this origin. 

Apply — Inputs the position. If the current operation allows multiple 
points, the dialog remains displayed ready for you to enter more 
points. Otherwise, the dialog is removed from the screen. 

OK — Inputs the position and removes the dialog. 

Cancel — Aborts the position entry. 
 

Key point tab 
Use the Key point tab of the Position dialog (see page 208) to select 
a position at a specific key point on the selected object. This is 
useful where more than one object has key points at the same 
position and (for example) you want to snap to a hidden key point 
on a specific object. Key points are a quick and convenient method 
for selecting specific objects. 

 You can select composite curves when you are using the Key 
point page of the Position dialog: 

 
Workspace — Select the workspace you are working in. The 
available options are:  
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Relative — The position being defined is relative to another 
position which becomes the origin of the workspace. The 
positions are aligned with the active workplane or the global 
workspace if no workplane is active. 

Relative mode is not always available since there may not be a 
suitable relative co-ordinate. In this case, select a suitable 
position (such as the intersection of two lines) and make it the 
origin of a relative workspace with the Become Origin option. 

Workplane — The position being defined is relative to the 
active workplane if one exists. 

World — The position being defined is relative to the global 
coordinate system. 

 If any items are locked, the locks are discarded when you 
select a different workspace. 

Object — Select an object. The name of the object is displayed. 

Key point — This determines which point on the object is selected. 
Select from the following options: 

Centre — This applies to the centre point of arcs and circles. 

Start and End — This can apply to any object as they all have 
start and end positions. 

Point Number — This is intended for use with curves that can 
have many positions along their length. The Point Number box 
activates where you enter a number. 

Become origin — Click this button for the coordinates of the position 
defined by the dialog to become the origin. Any relative coordinates 
are measured from this origin. 

Apply — Inputs the position. If the current operation allows multiple 
points, the dialog remains displayed ready for you to enter more 
points. Otherwise, the dialog is removed from the screen. 

OK — Inputs the position and removes the dialog. 

Cancel — Aborts the position entry. 
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Vector tab 
Use the Vector tab of the Position dialog (see page 208) to measure 
a vector between two points and use it to define a position. The 
offsets, angles, length, and elevation between the two points are 
displayed. 

 
Workspace — Select the workspace you are working in. The 
available options are:  

Relative — The position being defined is relative to another 
position which becomes the origin of the workspace. The 
positions are aligned with the active workplane or the global 
workspace if no workplane is active. 

Relative mode is not always available since there may not be a 
suitable relative co-ordinate. In this case, select a suitable 
position (such as the intersection of two lines) and make it the 
origin of a relative workspace with the Become Origin option. 

Workplane — The position being defined is relative to the 
active workplane if one exists. 

World — The position being defined is relative to the global 
coordinate system. 
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 If any items are locked, the locks are discarded when you 
select a different workspace. 

Current Plane — Use this drop down list to select one of the three 
principal planes. The current plane is relative to the selected 
Workspace option. 

You must already have a starting position from which the new 
position is entered. 

First point — Enter the first point of the vector or click on a point 
on the model to enter its coordinates. This point is displayed in 
pink on the screen (using the default colour scheme). 

Second point — Enter the second point of the vector or click on a 
point on the model to enter its coordinates. This point is 
displayed in red on the screen (using the default colour scheme). 

When you click OK or Apply, a new position is entered by going 
along the vector from the start position. 

Information from the two positions of the vector is displayed 
automatically in the boxes for the following options: 

Difference — These are the differences in the X, Y, and Z values of 
the first and second points of the vector. 

Apparent Angles — The apparent angle is measured between the 
projection of the vector onto a plane and the selected axis. If the 
axis is X, the plane is XY. For Y the plane is YZ and for Z it is ZX. An 
example is shown below of the apparent angle for the X axis: 

 

 Reset — Click this button to reset the values on the page. 

Length — This is the true length (in 3D) between the points. 
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Elevation — This is the elevation angle of the new vector from the 
current plane. 

 
Become origin — Click this button for the coordinates of the position 
defined by the dialog to become the origin. Any relative coordinates 
are measured from this origin. 

Apply — Inputs the position. If the current operation allows multiple 
points, the dialog remains displayed ready for you to enter more 
points. Otherwise, the dialog is removed from the screen. 

OK — Inputs the position and removes the dialog. 

Cancel — Aborts the position entry. 
 

Entering angles 
Enter an angle using degrees, minutes, and seconds in any dialog 
that expects an angle. The format is one of the following: 

> d;m;s 
>-d;m;s    (for negative angle) 

>-(d;m;s)  (for negative angle) 

where d, m, and s are numbers. 

 This syntax does not work for the Calculator dialog, or for the 
calculator that is embedded in the Parameter dialog. 

 

The grid 
A grid is an array of points joined by lines. Use the grid as a guide 
to quickly enter positions by snapping to its points. 
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Using the grid 
To use the grid turn the grid ON (see page 224).  

The grid is drawn on the principal plane. If you change the principal 
plane, the grid automatically redraws on the new plane. The 
principal plane is displayed on the grid. Also displayed is the arrow 
at the origin of the current workspace. This shows the axis normal 
to the principal plane.  

 
You can:  

 Snap to the intersections of grid lines as if they are key points. 

View the grid as either ruled or dotted lines by changing the Grid type 
option on the View page of the Options dialogs 
The scale of the current grid is displayed in the Status bar (see page 
125). The scale can be locked (see page 125) in the status bar to fix 
the scale. The scale is locked by default to a value of 10. You can 
set your own grid scale by typing your value into the grid scale text 
box in the Status bar (see page 125). The grid scale is locked 
automatically to that value. 

To zoom in and out on a locked grid scale: 

 Click Zoom in  to increase the scale. 

 Click Zoom out  to decrease the scale. 

To unlock the scale, deselect the user defined scale option on the 
Blanking and Grid page of the Options dialog. For further details, see 
Blanking and Grid in the Menus and Toolbars manual. 

 

Turning the grid On and Off 

To turn ON the grid 

From the Status bar (see page 125), click Grid on/off  to draw the 
grid on the screen. 

To turn OFF the grid 

From the Status bar (see page 125), click Grid on/off  to remove 
the grid from the screen. 
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Using point-locking 
When point-locking is ON, every position you enter using the mouse 
is locked onto the principal plane. For example, if the principal plane 
is XY, every point you enter using the mouse will have a Z 
coordinate of zero. 

You can: 

 Turn point-locking on (see page 225) 

 Turn point-locking off (see page 226) 
 

Turning point-locking on 
From the Status bar, click the Point lock button . (It changes to a 
shut lock ). 

Point-locking affects only points entered using the mouse.  

To enter a position that is not on the principal plane, you can: 

 Use the Position dialog (see page 208). 

 Type in the coordinates. 

If you snap to a key point which does not lie on the principal plane 
(as shown below), 

 
then the new position is projected onto the principal plane. 

 
When you hover the intelligent cursor (see page 153) over such a 
key point, it changes to show that clicking the key point will project 
any new position onto the principal plane. 
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Turning point-locking off 
From the Status bar, click the Point lock button . (It changes to 
an open lock ). 
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