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This Getting Started guide provides step-by-step instructions to 

guide you through the process of programming a part in 

PartMaker/SwissCAM. 

 This guide assumes that you know how to operate your 

machine and how to select suitable tools and cutting 
conditions. If you are unsure about any aspect of operating your 
machine, consult an expert or seek advice from your machine 

supplier. 

 The machining parameters used in the examples in this guide 

have been selected to illustrate the effects of various settings 
in PartMaker. These values may not be suitable for cutting on 
your particular CNC machine. If you want to machine any parts 
based on the examples given, carefully review and adjust the 
parameters to ensure safe cutting conditions. 

To find out more about PartMaker/SwissCAM, click  on 
PartMaker's Main toolbar to display the PartMaker online help. 

 

About this guide 
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PartMaker/SwissCAM automates the tedious task of manually 
programming parts for sliding headstock, Swiss-type lathes. The 

key stages involved in programming a part in PartMaker are: 

Programming the part 

PartMaker's patented visual approach to programming enables you 

set up machining functions, such as turning, plane milling, and 

cylinder milling, in separate 2D planes (known as Face windows). In 

this way, you can break a part down into a series of much simpler 
operations. 

You can create your part geometry within PartMaker or you can 

import CAD files that have been created in other CAD programs. 

Creating a Process Table 

When you have programmed the toolpaths for a part, you can 

generate a Process Table to view the processes required to machine 

the part you have programmed. By modifying the Process Table, 

you can synchronize processes being performed on separate 
spindles or by different tool posts, thus maximizing the efficiency 

and productivity of your CNC machine. 

Simulating toolpaths 

Once you have generated a Process Table, you can view a 3D 

simulation of the processes shown in the Process Table. This 

enables you to identify any errors before the part is machined. 

Creating an NC Program 

When you are happy with the toolpaths and the simulation, the next 

step is to generate an NC Program for a specific machine. This 

process is often referred to as post processing, because PartMaker 
uses a post configuration (.pst) file to convert the information in the 

Process Table into an NC Program. The Post Configuration files 
available to you depend on your PartMaker/SwissCAM license.  

 

Introduction to PartMaker 
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About PartMaker files 
When working in PartMaker, you use the following types of files: 

 Tools database (.tdb) files — These store information about tools 

in the tool crib and so enable you to keep track of your current 

tool inventory. 

 Cycles database (.cdb) files — In PartMaker, you can combine 

several repetitive operations (such as, center drilling, drilling, 

tapping, and boring) into a single entity called a cycle. You can 

also allocate a specific tool from the Tools database to a cycle.  

 Materials database (.mdb) files — These store information about 

the materials you use. PartMaker uses the information from the 

Materials database to automatically calculate feed rates and 
spindle speeds. 

 Job (.job) files — These store details of the toolpaths you create 

to machine the part. Each job file references database files for 

tools, cycles and materials, so it is easy to reuse tool, cycle, and 

material information in many different job files. 

 Postprocessor configuration (.pst) files — These store the 

information required to convert the details shown in PartMaker's 

Process Table into an NC Program file that is suitable for a 
particular machine. 

PartMaker also enables you to: 

 Import information from files created in other programs. For 

example, importing 3D solid models created in other CAM 

programs. 

 Export information from PartMaker to files that can be used by 

other programs. For example, exporting geometry created in 
PartMaker to .dxf files suitable for use with AutoCAD. 
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About the main PartMaker window 

 

  The PartMaker menu bar contains menu options for performing 

tasks within PartMaker.  

  Use the Main toolbar to open and close files and to control the 

display of windows within the main PartMaker window. 

  Use the CAM window toolbar to create new part features, verify 

toolpaths and modify the view within the Face window. 

  This area displays the Color Palette for selecting the color of 

profiles or geometry. It also displays buttons for controling the size 

of fixed Face windows 

  The 2D Face window displays the 2D part geometry and this is 

where you assign profiles to toolpaths. 

  The 3D Solids window displays a 3D solid model. 

  Use the Solids Window toolbar to work with solids models and 

control the view within the Solids window. 

  The Job Explorer pane lists the Face windows in the .job file, and 

the part features programmed in each Face window. 

  Use the Profile toolbar to create profiles for toolpaths. 

  Use CAD/CAM Switch button to move between CAD and CAM 

modes. 
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Using the mouse in PartMaker 

 Mouse button 1 (usually the left mouse button) 

Use the left mouse button to perform the following actions: 

Window Action 

Face 
window 

Click to select a profile in the 2D wireframe view. 

Solids 
window 

Click to select an element (such as surfaces, curves and 
vertices) on the solid model. 

Double-click to display details of the element you have 

selected. 

Hold down this button and drag the mouse to rotate the 

solid model. 

Simulation 
window 

Hold down this button and drag the mouse to rotate the 
view displayed in this window. 

 Mouse button 2 (usually the center scroll wheel) 

Use the center mouse button to perform the following actions: 

Window Action 

Face 
window 

Rotate this button to zoom in and out of the wireframe 
view. 

Hold down this button and drag the mouse to reposition 
the wireframe view.  

Solids 
window 

Rotate this button to zoom in and out of the Solids view. 

Hold down this button and drag the mouse to reposition 
the Solids view.  

Simulation 
window 

Rotate this button to zoom in and out of the Simulation 
view. 

Hold down this button and drag the mouse to reposition 

the Simulation view.  

 Mouse button 3 (usually the right mouse button) 

Click the right mouse button to display a context menu, which 

displays menu options relevant to the window in which you are 

working. 
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1 Double-click the PartMaker/SwissCAM shortcut on your desktop: 

 

PartMaker opens and the Setup dialog is displayed. 

2 Click the Close button to close the Setup dialog. You will learn 

how to use this dialog later in this Getting Started guide. 

A Face window, called Front, is displayed ready for you to work in 

PartMaker. 

3 Before programming the part, you need to open the Tools and 

Cycles files you want to work with. To do this: 

a Select Files > Open Tools File to display the Open Tools File 

dialog. Browse to your PartMaker User Files folder and select 
the getting_started_metric.tdb file in the Getting_Started_Tutorial 

subfolder. 

b Select Files > Open Cycles File to display the Open Cycles File 

dialog. Browse to your PartMaker installation folder and select 
the getting_started_metric.cdb file in the Getting_Started_Tutorial 

subfolder. 

You will learn how to add new tools and cycles to these files later 

in this Getting Started guide. 

 

Starting 
PartMaker/SwissCAM 
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The geometry of a part is a key element to creating the toolpaths 
that define how the part will be machined. 

In PartMaker, you can create geometry in any of the following 

ways: 

 Import a 3D solid model file, as described in Importing a 3D solid 
model and extracting geometry (see page 7). 

 Import a 2D (.dxf) file, as described in Importing a 2D file (see 

page 10). 

 Create CAD geometry within PartMaker using its CAD mode. For 

details of how to create CAD geometry directly within PartMaker, 

refer to PartMaker's online help. 

 The ability to import a 3D solid model into PartMaker is 
available as a cost option. 

 

Importing a 3D solid model and 
extracting geometry 

This section describes how to import a 3D solid model into 

PartMaker and extract geometry from the model. 

 If your PartMaker installation does not allow you to import 

solid models, or you prefer to work in 2D, skip this section 
and follow the instructions in Importing a 2D files (see page 

10). 

1 Select File > Import > X_T Parasolid Text File to display the Import 

Parasolid X_T File dialog. 

In the Getting Started folder of your PartMaker installation, select 

the getting_started_metric.x_t file and click Open. 

Creating geometry 
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PartMaker displays the solid model in the 3D area of the graphics 

window: 

 

2 Click the Extract Turn Geometry button on the Solids toolbar to 
display the Extract Turn Geometry dialog. 

 

3 Complete Extract Turn Geometry dialog as shown, then click OK. 
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PartMaker displays a copy of the 2D profile in the Face window: 

 

4 Click the Show Axes and Show Boundaries buttons to display axes 

and boundaries in the PartMaker window: 
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Importing a 2D geometry file 
This section describes how to import a 2D .DXF file containing part 

geometry into PartMaker. You need to perform these steps only if 
your PartMaker installation does not allow you to import solid 

models, or if you prefer to work in 2D. 

1 Select File > Import > DXF File to display the Import DXF File 

dialog. 

In the Getting Started folder of your PartMaker installation, select 

the turn_profile_metric.dxf file and click Open. 

PartMaker displays the 2D geometry in the PartMaker window. 

2 Select View > Setup to display the Setup dialog and change the 

Length and OD values to those shown below:  

 

3 Click Close. 
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This section describes how to program and verify the toolpaths 

required to machine the part. 

If you are using an imported 3D model, check that the Solids > 

Show Profiles and Holes on Solid Model option is selected so you will 

be able to view toolpath profiles on the solid model: 

 

 Important programming convention 

 
When creating geometry, setting up tools and programming 

toolpaths in PartMaker/SwissCAM, it is important to remember 

that PartMaker assumes that all work is done moving from 

right to left in the Z- axis (that is, it assumes that the collet or 
chuck is always on the left). This convention applies 

regardless of the physical construction of the machine. 

PartMaker makes sure that the NC Program is created in the 

required coordinate system for your machine during the 

postprocessing process. 
 

Programming and 
verifying toolpaths 
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Creating a turning profile group – 
facing 

This section describes how to create a profile group for the facing 

operation. 

1 Click the New Profile Group button to display the Profile Group 

Parameters, Turn dialog. 

 

2 Complete the Profile Group Parameters, Turn dialog, as shown, 
then click Close. 

 

 To complete the Finishing Tool ID field, click Select Tools 

and select T001 on the Select Tool dialog. Clicking Select 

closes the Select Tool dialog and returns you to the Profile 

Group Parameters, Turn dialog. 
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Because you selected a Tool Location of Face, PartMaker 

automatically completes the profile by applying the facing 

toolpath to the part geometry and the 3D model: 

 

In the toolpath, the circle indicates the start point; the arrow 
indicates the direction of travel; and the square represents the 

next ‘point’ to be cut (which, in this case, is also the last point). 

3 To check the accuracy of the cut you have defined, click the 
Verify Work Group Toolpath button to display the Tool Path 

Verification Options dialog. 
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4 Complete the Tool Path Verification Options dialog as shown, then 

click OK. 

 

PartMaker displays a 2D representation of the tool moving across 

the face of the part and display results in the PartMaker window: 

 

5 Click the Hide Every Toolpath button to remove the verification 

details from the display. 
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Creating a turning profile group – 
outside diameter 

This section describes how to create a profile group for the outside 

diameter of the part: 

1 Select the color you want to use for this toolpath from the Color 

Palette:  

 

Using different colors for your toolpaths makes it easier to 

identify the toolpaths you have programmed when viewing the 

part geometry, or the solid model, in the PartMaker window. 

2 Click the New Profile Group button to display the Profile Group 

Parameters, Turn dialog. 

 

3 Complete the Profile Group Parameters, Turn dialog as shown, 

then click Close. 
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4 Click the Define Profile button, so you can specify where the 

profile goes on the part.  

 

 PartMaker automatically defines profiles for facing and 

cut-off operations. For other operations, you need to define 

the profile. 

5 Click the End of an Element Snap Mode button to specify that you 

want to define the profile by using the part's geometry as 'snap 

points' for the toolpath: 

 

6 Click on the part geometry to specify the following snap points in 
the order shown: 

 

7 Click the Selection button to save the profile. 

 

8 To verify the toolpath click the Verify Work Group Toolpath button, 
then click OK on the Tool Path Verification Options dialog. 
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You can now visualize the toolpath:  

 

9 Click the Hide Every Toolpath button to remove the verification 

details from the display. 
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Creating a turning profile group – 
grooves 

This section describes how to program the two grooves on the 

turned diameter of the part: 

 

Before programming this toolpath, you must create a new tool, as 

no suitable tool currently exists in the Tools database. 

1 Click the Tools button to display the Tool Data dialog. 
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2 On the Tool Data dialog, click New, then complete the dialog as 

shown: 

 

3 Select a colour for the toolpath from the Color Palette, then click 
the New Profile Group button to display the Profile Group 

Parameters, Turn dialog. 
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4 Complete the Profile Group Parameters, Turn dialog, as shown: 

 

 Use the Select Tools button to select the new tool you 

created in Step 2. 

5 Click the Define Profile  button, then click the End of an 

Element Snap Mode button: 

 

6 You can now define the profile using snap points. Follow the 
order shown below, including clicking the Selection button (see 

5) when you have finished the first profile, to ‘break’ the profiles 
into two distinct pieces: 
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7 To verify the toolpath, click the Verify Work Group Toolpath 

button, then click OK on the Tool Path Verification Options dialog. 

 

You can now visualize the toolpath: 

 

8 Click the Hide Every Toolpath button to remove the verification 

details from the display. 
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Creating a turning hole group – 
through hole 

This section describes how to program the hole through the center 

of the part: 

1 Select a colour for the toolpath from the Color Palette, then click 
the New Hole Group button to display the Hole Group Parameters 

dialog. 

 

2 Complete the Hole Group Parameters dialog as shown, then click 

Cycle to display the Cycle dialog. 

 

3 On the Select Cycle dialog, click Add New Cycle to display the Edit 

Cycle dialog. 
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4 Click Insert operation, then complete the Edit Cycle dialog as 

shown: 

 

5 Click Select Tools, change the New Tool Diameter to 6 and then 

click Add. 
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6 Complete the Edit Tool dialog, as shown, noticing that the 

Orientation and Tool Post values have changed. Click OK when 

you have finished. 
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7 You now need to create a new drill tool suitable for the diameter 
of this hole To do this, click Add on the Select Tool dialog, then 

complete the Edit Tool dialog as shown: 
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8 When you have completed the Edit Tool dialog, click OK to 

confirm your changes. PartMaker returns to the Edit Cycle dialog: 

 

9 Click OK on the Edit Cycle dialog to return to the Hole Group 

Parameters dialog: 

 

10 On the Hole Group Parameters dialog, click Apply, then Close.  
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You can now visualize the toolpath: 
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Creating a turning cut-off toolpath 
This section describes how to create a toolpath for the cut-off 

operation. 

1 Select a colour for the toolpath from the Color Palette, then click 
the New Profile Group button. 

 

2 Complete the Profile Group Parameters, Turn dialog, making sure 

Optional Path 1>-2->1 is selected, then click Close. 

 

PartMaker automatically completes the profile by applying the 

cut-off toolpath to the part geometry and the 3D model. 
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Simulating the turning toolpaths 
This section describes how to view a 3D simulation, which shows 

how the toolpaths will be machined. Now you have created all the 

turning profile groups for the part, this is a good time to run a 

simulation. 

1 Click the Generate Process Table button to create a Process Table, 

which lists the processes required to machine the toolpaths. 

 

2 Complete the Process Table Options dialog as shown, then click 

OK. 

 

 If PartMaker displays a warning that no ejection is 
programmed, click Yes to continue. 

3 View the Process Table, then click . 
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4 In the Simulation window, click Play to start the simulation. 

 

 If <PRODUCT, displays a warning that no eject operation is 
programmed, click Yes to continue. 

5 When the simulation is complete, click the Show Finished Part 

button. 

 

PartMaker displays a 3D representation of the finished part: 
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Creating a milling profile group – 
hexagon 

This section describes how to create a milling toolpath to mill the 

hexagon on the part. 

This section shows you how to create the toolpath using geometry 

extracted from a 3D solid model. If, however, you want to use 
geometry from an imported 2D .DXF file instead, select File > Import 

> DXF File to display the Import DXF File dialog and then select the 

hex_profile_metric.dxf file from the Getting Started folder of your 

PartMaker installation. PartMaker displays the 2D geometry in the 

PartMaker window. You can then follow the steps described in this 
section. 

So far, you have created turning toolpaths in the Front face window. 

To create a toolpath that uses a different machining function 

(milling), you need to create a new Face window.  

1 Select View > Setup and then click New.  

2 Complete the Setup dialog as shown, then click Close to finish. 

 

3 Click the New Profile Group button on the toolbar to display the 

Profile Group Parameters dialog.  
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 If you are using the imported 3D solid model, complete the 
dialog as shown, by selecting the Extract Parameters From 

Solid option, selecting the plane in the Solids window and then 
clicking Extract. 

 

 

 If you are using the imported hex_profile_metric.dxf file, 

complete the dialog as shown: 
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4 Click Select Tools to display the Select Tool dialog, then select All 

Diameters. Notice that only a 3mm milling cutter is available, 

which is too wide for the 2.8mm hexagonal slot. To specify that 
you want to create a new 2.8mm tool, complete the New Tool 

Diameter field as shown below, then click Add. 

 

5 To create a 2.8mm milling tool, complete the Edit Tool dialog as 

shown and then click OK. 
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6 Check the details shown on the Profile Group Parameters dialog 

and click Close. If you are using an:  

 imported 3D solid model, continue at Step 6. 

 imported 2D .DXF file, continue at Step 7. 

 

7 When using a 3D solid model, you need to transfer the planar 

geometry from the solid model into the 2D area of the PartMaker 
window before you can create the profile for that geometry. To 

transfer the geometry, double-click the surface on the solid 
model to display the Surface Info dialog, then click Transfer Planar 

Geometry. 
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8 Click the Chain Geometry button in the Profile toolbar to specify 

that you want to create the profile by selecting the end point of 

the hexagon. 

 

9 Click on any of the points on the hexagon to create the profile: 

 

10 To verify the profile group, click the Verify Work Group Toolpath 

button, then click OK on the Tool Path Verification Options dialog. 
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You can now visualize the toolpath: 

 

11 Click the Hide Every Toolpath button to remove the verification 

details from the display. 
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Creating a turning hole group on the 
sub-spindle – counterbored hole 

This section describes how to program the counterbored hole on the 

rear of the part. 

As this toolpath will be machined using the sub-spindle, you first 

need to create a new Face window.  

1 Select View > Setup and then click New.  

2 Complete the Setup dialog, as shown, remembering to select 

Sub-Spindle: 

 

3 Select a color for the toolpath from the Color Palette, then click 
the New Hole Group button to display the Hole Group Parameters 

dialog. 
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4 Complete the dialog as shown, by selecting the Extract 

Parameters From Solid option, selecting the hole in the Solids 

window, and then clicking Extract. 

 

 If you are not using a solid model file and so cannot extract 

the hole values automatically, you need to enter the values 
shown in the green boxes above directly into the Hole 

Group Parameters dialog. 

5 Click Apply on the Hole Group Parameters dialog. PartMaker 
displays the Select Cycle dialog. 

6 As no suitable cycle already exists, click Add New Cycle to display 

the Edit Cycle dialog. 
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7 Click Select Tools to display the Select Tools dialog. As no 

suitable tool exists in the Tools database, click Add to add a new 

tool: 
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8 Complete the Edit Tool dialog as shown, then click OK. 

 

9 Select OK to return to the Hole Group Parameters dialog, then 
click Close. PartMaker displays the drill toolpath in the 2D 

window: 
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This section describes how to generate the final Process Table 

containing details of the processes required to machine all the 

toolpaths you have programmed. 

1 Click the Generate Process Table button on the toolbar: 

 

2 Complete the Process Table Options dialog as shown, then click 
OK. 

 

Generating the final 
Process Table 
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3 When viewing the Process Table, you can see that the cut-off 

process is not the last process in the table. To move this process 

to the end of the table, select the cut-off process so it is 
highlighted, then drag-and-drop it to below the drill_4 process. 

 

The Process Table now shows the processes in the order in which 
you want them to be machined: 
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4 To change the mode of the machine for the cut-off, click the 
Mode button alongside the cut-off process, complete the Set 

Modes dialog as shown, then click OK. 

 

5 Add a part eject operation to the last sub-spindle process: 

 

6 To view a 3D simulation of the machining process, click 
Simulation in the Process Table. 
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7 In the Simulation window, click Play to start the simulation. 

 

8 When the simulation is complete, click the Show Finished Part 

button. 

 

PartMaker displays a 3D representation of the finished part: 
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This section describes how to convert the information stored in the 

Process Table into an NC Program.  

This section uses the demonstration post processor (swiss-demo.pst) 

supplied with PartMaker. This is a generic post processor that is 

provided for demonstration purposes only. Therefore, the contents 
of the NC Program file will not reflect the code required for a specific 

machine and you will not be able to save, or run, the NC Program 

files that PartMaker has created. 

1 Select Job Optimizer > Post Config File to display the Open Post 

Configuration File dialog. Select the swiss-demo.pst file in the 

PM-Swiss folder of your PartMaker installation and click Open. 

2 Click the Generate NC Code button on the Main toolbar, then click 

OK on the Post Options dialog to use the default options for 

postprocessing. 

 

Generating NC Program 
code 
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 If PartMaker displays a warning that no ejection is 
programmed, click Yes to continue. 

 

3 On the Name NC Program File As dialog, enter a name for the file 

where PartMaker saves the NC Program code, then click Save. 

 In this case, because you are using a demonstration post 

processor, PartMaker will not save the NC Program files. 

PartMaker creates demonstration NC program code: 
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This section describes how to save your work and close PartMaker. 

1 If you imported the 3D solid model provided for this example, 
check that the File > Save Solid Model with Job File is selected, so 

the solid model will be saved with the PartMaker .JOB file. 

2 Select Save on the Main toolbar to save the job file, Tools 

database file and Cycles database file that are currently open. 

 

3 When the Save Job File As dialog is displayed, select the folder 

where you want PartMaker to save the file, enter a filename in 
the File Name field, and then click Save. 

4 If you have finished using PartMaker, select File > Exit to exit. 

 

Saving your work 
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