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Sequence of Programming Steps for PartMaker SwissCAM 
 

1. Specify part boundaries and the type of machining to be performed in the Setup dialog. It 
appears on the screen right after PartMaker logo when launching PartMaker.  Determine 
whether you will be working in the Main Spindle or Sub Spindle in this Face Window.  

2. Choose the Tools command from the ToolMinder menu to add new tools.  

3. Choose the Cycles command from the ToolMinder menu to add new cycles. 

4. Choose the Open Material File command from the File menu to open a material file from the 
Material directory. 

5. Create geometry in CAD mode or choose the Import DXF File command from the File menu if 
you want to import geometry from a CAD system. 

6. Switch back to CAM Mode by clicking the CAD/CAM switch. 

The CAD/CAM switch appears as in CAM Mode and as 
 

in CAD Mode 

7. Choose the New Hole Group command 
from the Part Features menu to create 
an axial hole.  You should see a dialog 
box as below: 

 
 

8. Choose the New Profile Group command 
from the Part Features menu to define a 
new profile group. You should see a dialog 
box as below: 

  
 

7.1. Enter your desired settings into the dialog. 
7.2. Click the Cycle button. 

8.1. Enter your desired settings into the dialog. 
8.2. Click the Select Tools button. 

9. Create tool paths using the Graphics Icons in the CAM mode 

10. Repeat steps 7 through 9 to create groups of all part features and machining function face windows 
required for the job. 

11. Choose the Post Config File=? Command from the Job Optimizer menu and select the desired 
post processor for your machine. 

12. Choose the Generate Process Table command from the Job Optimizer menu to generate a 
Process Table. 

13. Optimize and synchronize your operations by using the Set Modes dialog. 

14. Simulate the generated program using PartMaker’s 3D Simulation software. 

15. Choose the Generate NC Program command from the Job Optimizer menu to generate an NC 
Program. 
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Introduction 
Using CAM Software to Program NC Machines 

The invention of NC (Numerically Controlled) machines has revolutionized the metal 
cutting industry. Computer controlled machine tools are faster, have a higher 
degree of accuracy and repeatability. 

NC machines can be programmed manually, which means typing machine 
"language" motion and other instructions into a computer text file. Such a file, 
called a part program, is then loaded into the NC machine memory for execution.  

The following are the major deficiencies of manual programming:  

 The languages of NC machines are cumbersome for humans and require a long 
learning curve. 

 Geometric calculations must be performed to determine coordinates of points 
comprising the tool path. 

 Typing is a time consuming process. 

 The absence of adequate methods to prove out the program results in tools 
breakage and material waste. 

Since the earliest days of computer technology a significant effort has gone into 
automation of the programming process by utilizing CAM (Computer Aided 
Manufacturing) Software. CAM systems accept user input in an interactive manner 
and generate a part program file automatically. CAM Systems provide assistance in 
tool path calculations and verification. The overall productivity improvement 
resulting from a use of a particular CAM System depends on how long it takes to 
learn the software, how easy it is to use it and how much information a user has to 
enter during each programming session.  

How PartMaker Improves Productivity 
PartMaker relieves you from the tedious process of reentering the same tooling and 
process information over and over again in every program. It captures information 
about how to machine individual part features, namely, holes and profiles, and 
makes it available for future use. It allows shop personnel to benefit from the 
expertise of the most skilled programmer, who enters his or her knowledge into the 
software. Using PartMaker your parts can now be programmed faster, with higher 
precision and less cost.  

Intuitive Windows GUI Assures Quick Learning 
PartMaker features an intuitive user interface that complies fully with Windows GUI 
(Graphics User Interface) guidelines. The benefits of the Windows environment for a 
PartMaker user include Context Sensitive Help, pictorial explanation of parameter 
entry, the ability to Cut, Copy and Paste part features and/or geometry, and, most 
importantly, shorter learning time. 
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Tools Data Base Keeps Track of Tool Inventory 
A tools database allows the user to keep track of his current tool inventory. 
Geometric characteristics saved with each tool are used for the automatic 
determination of cutting conditions. The software performs automatic hole depth 
calculations by maintaining through hole clearance and blind hole relief distances for 
each tool. A pictorial representation of each tool in a separate window simplifies the 
entry of tool parameters. Corrective coefficients compensate for tool wear. Special 
fields are reserved for the customer's data which includes part numbers and 
reordering information among others.  The tools descriptions are kept in a tool file. 
The tools used on different machines may be kept in multiple tool files. 

Cycles Data Base Stores Sequences of Repetitive 
Operations 

A cycles database allows the user to create and store cycles, sequences of repetitive 
operations such as center drilling, drilling, tapping, boring, reaming, chamfering and 
circular hole milling. The cycles database links directly into the tools data base. A 
tool for each operation is selected automatically based on the hole diameter. 
Windows GUI makes creation and modification of cycles a simple task. A full 
description of the tools and operations included in a cycle is shown in one window, 
while the corresponding hole cross-section is shown in another window. Studies 
have indicated that over 70 percent of machine cycle time for an average CNC 
machining center is spent making holes. Therefore, PartMaker pays significant 
attention to hole making in order to achieve the greatest gain in productivity. Often, 
the same or similar features belong to a group of products that are ordered by the 
same shop's customer. Since cycles may be customer specific the user has a choice 
of whether or not to store them in multiple cycle files. 

Materials Data Base Facilitates Automatic Feeds and Speeds 
Calculations 

A materials database allows the user to store materials data that is used in the 
automatic calculation of feed rates and spindle speeds. The software comes with an 
extensive materials data base, recommending average cutting parameters. Feed 
rate and spindle speed are computed based on tool geometry (size, number of 
flutes. etc.) and machinability data. This data is presented in the form of flexible 
computer charts giving the user full control over the performance of his machine. 
The charts can be quickly modified via a drag and drop screen interaction. 
Machinability charts can be further optimized by automatic curve fitting through 
points of best performance. 

Patented Visual Programming Approach Simplifies 
Machining in Different Planes 

PartMaker’s Patented Visual Programming approach greatly simplifies programming 
parts involving both turning and milling operations in a single set-up, where such 
operations are being performed on multiple spindles. With this approach machining 
functions such as turning, plane milling and cylinder milling are carried out in 
separate 2D planes, allowing you to break down a part into its most basic elements 
when developing a part program. You can program machining operations in different 
faces (planes) and specify up to twenty-four different faces per part. A separate face 
window is associated with each face of a part.  
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Optimized Process Plan Generation Saves Programming 
Time 

Rather than creating a job plan in a conventional sequential manner, the 
programmer describes the placement of groups of part features on the surfaces of a 
machined part.  Once the part features description is entered into the computer, 
PartMaker automatically generates an optimized job plan. The results are 
summarized in a Process Table Window that can be reviewed on the screen or 
printed out. The Process Table lists tools and cutting conditions for each process. 
Feed rates, spindle speeds and cycle time are automatically calculated and 
displayed. The cycle time allows the programmer to quickly estimate the cost of 
machining a part. While reviewing the Process Table, the user can manually modify 
the sequence of processes as well as cutting conditions. 

Graphic Process Synchronization Simplifies Cycle Time 
Optimization 

Once you have laid out your various tool paths, PartMaker allows you to visually 
synchronize processes being performed on separate spindles or by different tool 
posts.  This eases the process of optimizing cycle time to assure your CNC Swiss-
type lathe is being used most productively.  This visual synchronization is 
accomplished via the Set Modes dialog on the Process Table.   A unique mode has 
been specified for each of the various types of synchronization today’s most 
advanced CNC Swiss-type lathes are capable of performing.  A picture accompanies 
each type of synchronization allowing the user to better understand the type of 
synchronization being performed. 

User Customizable Output Format Eliminates Manual Editing 
When the user is satisfied with the views of the part and its job plan, he proceeds 
with the next step (known as post processing) to automatically generate an NC 
program for a designated machine. The part program is optimized, using 
subroutines, to occupy minimum space in the machine tool memory and shorten 
transmission time. PartMaker eliminates the need for manual editing of the 
generated NC program - a well-known stumbling block of most CAM systems.  

The ability to generate editing-free programs results in an additional productivity 
gain. It is achieved by giving the user full control over the generated NC program 
format by means of flexible ConfigPost application that allows the user to create and 
save custom postprocessor configuration files for virtually any CNC control. 
ConfigPost uses the familiar Windows interactive environment that enables the user 
to do output customization quickly and easily. 

Verification by Cutting Simulation Catches Programming 
Errors 

PartMaker comes with an integrated simulation module that graphically depicts the 
entire cutting process, utilizing solid modeling techniques.  This allows the 
programmer to catch errors before expending machining time.  
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About This Guide 
Please read this section to determine which chapters in the PartMaker SwissCAM 
User Guide address your needs. 

Chapter 1: “Getting Started With PartMaker” explains how to get started with 
PartMaker. This chapter includes a description of the hardware and software you 
need to run PartMaker and tells you how to install PartMaker and related files.  It 
also shows you how to access PartMaker on-line context sensitive help. 

Chapter 2: “PartMaker Fundamentals” discusses the unique programming 
approach PartMaker employs for programming CNC Swiss-type lathes. Concepts 
covered in this chapter include selecting the appropriate Face Window and setting 
up and working with PartMaker’s databases.  

Chapter 3: “SwissCAM Programming Tutorial” shows you how to create a 
sample part using some of the most popular features of PartMaker. We recommend 
you go through this chapter to familiarize yourself with the PartMaker application. 

Chapter 4: “PartMaker Simulation” discusses how to use and the functionality of 
PartMaker’s 3-D Simulation module. 

What you will not find in this manual is an explanation of every PartMaker dialog 
and parameter.  For information on specific PartMaker dialogs, use the context 
sensitive help that comes with PartMaker.  This context sensitive help can be found 
by pressing the F1 key on your keyboard. 

This User Guide is also meant for use in conjunction with a machine specific 
programming addendum that may have also come with your PartMaker SwissCAM 
software.  The Machine Specific addendum is meant to show you a layout of the 
machine you are working with as well as describe any machine or post processor 
specific programming strategies you should be aware of. 
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Chapter 1: Getting Started With 
PartMaker® 
In Your Package 

 PartMaker CD-ROMs 

 PartMaker Manuals 

 Hardware lock 

You will receive a license file that works with the hardware lock.  For standalone 
licensing the file is called a Product Authorization File (PAF).  For network licensing 
the file is an RMS license file.  Obtaining and installing the PAF file will be discussed 
later in this chapter in the section titled PAF Installation Instructions.  The RMS 
Installation Guide explains the RMS license file in detail. 

Technical Support 
Please use the following information when you wish to get Technical Support or 
more information about PartMaker’s products: 

Phone:  215-643-5077 

Fax:   215-653-0105  

E-mail:  support@partmaker.com  

Web Site: http://www.PartMaker.com 

A Customer PIN has also been assigned for use with your PartMaker software.   

Before Using PartMaker... 
Before you begin working with PartMaker, you need a basic knowledge of Microsoft 
Windows operations. You should understand mouse techniques such as pointing, 
clicking, double clicking, dragging, choosing menu commands, and making dialog 
selections. If you are unfamiliar with basic Microsoft Windows terms or techniques, 
see your Microsoft Windows documentation for details. 
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System Requirements 
Please read the following sections to determine what you’ll need to get started with 
PartMaker. To use PartMaker, you need a Windows-based PC with the following 
specifications: 

 

 
PartMaker 
Standard 

Parasolid 
Import Module 

(Solids)* 

Full Machine 
Simulation 

(FMS) 

Advanced 
Surface 

Machining (ASM) 

Processor Pentium 3 800 
MHz or higher 

Pentium 3 800 
MHz or higher 

Pentium 4 3 
GHz or higher 

Intel Core Duo 
processor or higher 

Memory 512 MB or more 1 GB or more 2 GB or more 4 GB or more 

Hard drive 40 GB 40 GB 40 GB 80 GB 

Independent 
video card 128 MB NVIDIA 512 MB NVIDIA 512 MB 

NVIDIA 1 GB NVIDIA 

 

64-bit and 32-bit versions of PartMaker are available and are supported on Windows 
7. Only the 64-bit version of PartMaker is compatible with Windows 8 PCs. 

Please take note that Microsoft has discontinued support for the Windows XP and 
Vista operating systems. 
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Starting PartMaker  
From your desktop, double-click the PartMaker SwissCAM icon. 

A window containing information about PartMaker appears for a few moments. 

 
The PartMaker application window and the Setup dialog are displayed in the Face 
Window. 
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Installing Your SwissCAM Post Processors 
PartMaker SwissCAM Version 2010 and higher features a unique capability for 
downloading your licensed SwissCAM post processors and related files directly 
through the software’s user interfaces.  This feature is helpful for both new users 
installing the software for the first time and existing users who wish to update their 
post processors and related files to the most recent “distribution” Post Processors 
(see below for more information on “distribution” versus “non-distribution” post 
processors). 

Important! You must be connected to the internet to automatically download and 
install your licensed post processors through the PartMaker interface as described 
below. 

Once you have successfully launched the SwissCAM application, you can install the 
SwissCAM post processors that you have licensed directly from the PartMaker user 
interface. 

To do so: 

1 From the Help menu, choose Download Licensed Post Config Files… 

 
2 You will be presented with the dialog below: 
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3 Check the boxes to the left corresponding to the post processor(s) you wish 
to download as shown below: 

 
4 Once you have selected the items you wish to download, click the Download 

Selected Posts button to begin downloading the specified items into the 
directory specified in Step 2 of the Download Licensed Post Config Files 
dialog. Upon doing so, you will see a progress bar showing the status of your 
download. 

5 Once you have successfully downloaded the selected items, you will see the 
Download Status column will indicate “Successful” as shown below. 

 

 If you receive any message other than “Successful” after this process, 
contact PartMaker technical support at support@partmaker.com or your 
local PartMaker support representative (outside North America). 

6 Once you successfully downloaded the requested files, click the <Close> 
button to continue using PartMaker. 
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What You Have Just Downloaded 
Once you have completed the previous steps, you will have downloaded what are 
known as “distribution post processors,” the library post processor support by 
PartMaker Inc. for particular machine-control combinations.  PartMaker post 
processors for multi-axis lathes are more than just standard post processors that 
come with a CAM system. They are highly engineered, actively supported, routinely 
maintained and well documented machine configuration files to assure you generate 
accurate NC code for your multi-axis lathes utilizing the full capability of your 
machine tool.  All PartMaker post processors are customizable, by you, the user. 

In the process above, you have downloaded much more than just post processors.  
You have downloaded the following items: 

1 The Post Processors your company has licensed – These include the 
*.pst and *.sub files (for machines equipped with a sub spindle). PartMaker 
defines a post processor as a machine, control combination. 

2 Related Simulation Files – PartMaker’s Advanced and Full Machine 
simulation (FMS) modules use additional files to simulate the architecture of 
your machine.  You will need to use the *.MCH corresponding to your post 
processor to view your machine’s working envelope when using Advanced 
Simulation.  If you have licensed FMS, you will need to use the *.FMS and 
*.MCH corresponding to your post processor to view your machine’s working 
envelope when using Full Simulation.  Please see the Chapter 4 of this 
manual for information on using PartMaker’s Advanced and Full Machine 
Simulation modules. Included with these files are PartMaker Job (*.job), 
Tools (*.tdb) and Cycles (*.cdb) files that are configured to run in both 
Advanced and Full Machine Simulation. 

3 Post Processor Related Documentation – Documentation related to your 
licensed post processors and simulation files. 

4 Sample Files – Sample Job (*.job), Tools (*.tdb) and Cycles (*.cdb) files in 
both the inch and metric system corresponding to the tutorials in your 
PartMaker user guide and configured to your machine tool’s specific 
architecture are also provided. 

To see an example, of this, let’s look at the files download in this example: 

1 The picture below shows the result of the download above:  

 
2 Double clicking the folder, 0003_Citizen_C16_T6___October_13_2014, 

above reveals the following where: 

1 A *.TXT is a readme file explaining changes made in the most recent 
version of the post processor 

2 The *.pst and *.sub, the post processor files themselves 

3 A folder containing the simulation, *.MCH and *.FMS referred to above 

4 A folder containing the machine specific addendum and FMS reference kit 
referred to above 
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5 A folder containing tutorial files in the inch system corresponding to the 
tutorial in the user guide 

6 A folder containing tutorial files in the metric system corresponding to the 
tutorial in the user guide 

 

 Tip: If using Advanced and/or Full Machine Simulation, placing the *.FMS 
and *.MCH in the same directory as the *.PST and *.SUB files will allow 
your simulation files to open automatically when loading the post 
processor. 

More on SwissCAM Post Processors 
PartMaker Inc’s application staff maintains a library of well documented well 
supported multi-axis post processors which include virtually every Swiss machine 
ever built.  Once you start to customize your own post processor using the 
ConfigPost application, you create a “non-distribution” or ND post processor. 

Please also note, PartMaker is constantly updating and improving its SwissCAM post 
processors to add functionality and correct any possible reported errors. You can 
use the same procedure above to check for post processor updates periodically if 
you are experiencing difficulty with your post processor.  Even if you have 
customized your post processor and are using a “non distribution” post processor, 
you can quickly see any differences between your customized “non distribution” post 
processor and the most current “distribution” post processor using the Compare 
function in PartMaker’s ConfigPost application.  See the ConfigPost user guide that 
came with your software for more information on this function. 

Exiting PartMaker 
To exit PartMaker, choose Exit from the File menu.  If you changed an open job file, 
a dialog prompts you to save the current job file before exiting. 

 
Do one of the following: 

1 Click <Yes> to save the changes. 

2 If the file is untitled, select a location and enter a file name in the dialog that 
appears, then click <OK>. 

3 Click <No> to discard the changes and exit. 

4 Click <Cancel> to return to the presentation window without exiting. 



 

1-8 PartMaker  Copyright @2014 Delcam 

 

Using On-Line Help 
On-line help provides fast access to information about the application’s tools, 
commands, dialogs, and program features. Help commands are located in the Help 
menu in PartMaker: 

1 Choose Contents from the PartMaker Help menu, click the  icon on 
the toolbar or press <F1>. 

The Help window appears, displaying the Main Index (shown on the following 
page). 

 
2 Click an index to view a list of help topics. 

3 Click the topic you want to read about. 

 Information about the selected topic appears in the window. 

 Note: Some topic lists include sub-lists from which you can select a help 
topic. 

4 To return to the last screen you viewed, click the <Back> button. 

5 To search for information, click the <Search> tab. 

6 Type in a key word to choose a topic and click the <List Topics> button. 
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7 Click the <Display> button to view the selected topic.  Your help screen will 
appear as below: 

 
8 When you are finished using help, choose Close from the help window’s 

Control menu. 

Using Context-Sensitive Help 
To view context-sensitive help while viewing any PartMaker dialog: 

1 Display any PartMaker dialog. 

2 Press <F1> to display the help topic for the dialog. 

Installing Updates 
PartMaker Version 2010 and higher allows you to check for and download more 
recent versions and service packs of the software automatically from the PartMaker 
environment. You do so by selecting Check for PartMaker Updates from the Help 
menu. 



 

1-10 PartMaker  Copyright @2014 Delcam 

 

Working With Databases 
Databases are where PartMaker stores tool, material, and cycle information that you 
will use for PartMaker jobs. 

Material Database 
A Materials Database allows you to store your shop’s accumulated materials data. 
Materials data is used by PartMaker in the automatic calculation of feed rates and 
spindle speeds. In addition, you can utilize material data in the extensive material 
library provided with PartMaker. 

Turn to Appendix A for a complete list of materials. 

Tools Database 
A Tools Database allows you to keep track of your current tool inventory. PartMaker 
uses geometric and cutting tool characteristics saved with each tool in the database 
for automatic cutting conditions and automatic depth calculation. 

Cycles Database 
PartMaker lets you combine a number of repetitive operations (center drilling, 
drilling, tapping, boring, etc.) into a single entity called a Cycle.  All cycles are saved 
in a Cycles Database. For each cycle operation, you can designate a tool from the 
Tools Database. Once a cycle is created, you can recall it at any time when you 
need to use it again. 

Working With Files 
PartMaker uses several kinds of files for storing tools, cycles, and material 
information as well as your jobs and the postprocessor files used to create NC 
programs for machining. 

 Information about tools in the tool crib is saved in Tools files that have the 
file extension .TDB. 

 Information about material characteristics needed to calculate feedrates and 
spindle speeds is saved in Material files that have the file extension .MDB. 

 Information about user-created machining cycles is saved in Cycles files that 
have the file extension .CDB. 

 Part geometry is saved in Job files that have the file extension .JOB. 

 Postprocessor configuration information is saved in Post Configuration files 
that have the file extension .PST. 
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Chapter 2: PartMaker® Fundamentals 
Introduction 

This chapter discusses the various components of PartMaker’s programming 
approach for CNC Swiss-type lathes. This chapter introduces the following topics: 

 Choosing the proper Machining Function Face Windows 

 Programming convention 

 Setting up and working with PartMaker’s Tools, Materials and Cycles databases 

 Using Icons 

 Process Synchronization Rules and Techniques 

Machining Function Selection 
CNC Swiss-type lathes are capable of performing a full set of turning operations: 
facing, turning, grooving and threading. Many Swiss-type lathes are also capable of 
performing various types of milling as well as drilling holes on different surfaces. 
Multiple spindles in which such operations can be performed simultaneously further 
increase the machines' productivity and complexity.  

Milling capabilities of the CNC Swiss vary significantly and can be ranked in order of 
sophistication as follows:  

 Index milling/drilling 

 Milling on a selected ZX plane 

 Polar milling on the face of the part 

 XZC continuous milling on cylindrical surfaces  

 Milling interpolation in the YZ plane 

Programming of these powerful machines is, however, much more difficult than the 
programming of the individual mill or lathe. Despite significant efforts by many CAM 
vendors to develop an easy-to-use CAM system for programming multi-axis Swiss-
type lathes, the majority of programming today is still done manually.  

PartMaker CAM Software from PartMaker, Inc. applies a Patented "divide and 
conquer" programming strategy to simplify programming of Swiss-type lathes. 

PartMaker helps you separate a complicated part surface into a manageable set of 
faces that may be either planar or rotational in nature. All features are represented 
by a surface relative to which a set of part features is referenced.  

On each face, a set of features may be machined using a variety of cutting tools. 
The software takes advantage of the Microsoft Windows operating system, which 
allows multiple windows to be displayed and accessed simultaneously.  

A specific machining function such as turning, polar milling or cylindrical milling is 
assigned to each face. PartMaker lets you create a dedicated window that contains 
a workspace for the graphic representation of face features.  

A dialog box associated with each Face Window shows you the type of machining 
to be performed on a face, the location of the face boundaries and parameters 
defining the positioning of the face relative to the machine coordinate system.  
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Getting Started: The Setup Dialog 
PartMaker employs a programming methodology whereby each machine motion 
type can be separated into a different window dedicated to a specific machining 
function. Every one of these windows is known as a Face Window. Once created, 
each Face Window can be accessed from the Window menu. 

Once divided into much smaller, similar motion components, programming of a 
multi-axis Swiss-type lathe becomes a much easier task. To best explain how 
PartMaker handles this task, it is necessary to first explain how each of these 
individual-machining functions is defined.  

Selection of the various machining functions is carried out in the Setup dialog. The 
Setup dialog can be accessed from the View menu or by clicking on the shortcut to 
the Setup dialog located in the upper left hand corner of your Face Window. On 
Startup, or when accessing the Setup dialog for the first time, you will see the 
following dialog. Some of the important components of this dialog are explained 
below: 

 
1 The Main Spindle and Sub Spindle radio buttons allow you to select whether 

the programming carried out in a particular Face Window is being machined 
on the Main or Sub-Spindle. 

2 The Tool Change X and Z positions for a particular machine should be 
entered here. 

3 The Machining Function drop down menu allows you to select the type of 
machining motion being executed in a particular Face Window. The 
machining motions that can be defined in each selection from the Machining 
Function drop down menu are explained below.   

4 The List of Face Windows displays a list of Face Windows currently 
existing for a given job. 

5 The Rename To: field allows you to name the Face Window you are 
working with. Existing Face Windows can be selected from the Window 
menu based on the names assigned to them in this field of the Setup dialog. 
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6 Clicking the function buttons shown in the Setup dialog with the left-hand 
mouse button does the following: 

 

<New> 
Creates new face windows of different machining function 
types or on different spindles, adding to the List of Face 
Windows. 

<Delete> Deletes the currently selection from the List of Face 
Windows. 

<Duplicate> 
Allows the user to duplicate a series of identical Mill ZX, ZY 
and Mill XY windows. Only active when one of these 
Windows is selected. 

<User Data> Allows the user view the User Data for a given post 
processor.  Only active if a post processor is loaded. 

<Apply> 
Accepts or applies any new parameters or data entered into 
the various fields in the Setup dialog, and the dialog 
remains open. 

<Close> Accepts or applies any new parameters or data entered into 
the various fields in the Setup dialog, and closes the dialog. 

The various selections under the Machining Function drop down menu are 
explained on the following pages. 
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The Spindle Settings Dialog 
The Spindle Settings dialog can be accessed from the first Face Window created 
in the Setup dialog by clicking on the <Settings> button in the Spindle section of 
the Setup dialog.  This dialog is used the set the stroke of the machine, whether or 
not it uses a guide bushing, the sub spindle position and the properties of an 
extended nose collet being used on the sub-spindle. 

 
Main Spindle Home Z Distance (Z): Specifies the location of the face of the main 
spindle in reference to the face of the guide bushing.  This parameter sets the 
stroke of the machine. 

Guide Bushing Used: When checked, indicates using a conventional Swiss-
machine.  This box should be unchecked when working on a Swiss without a 
guide bushing.  

Sub-Spindle Home Z Distance (Zh): Specifies the Z-distance from the face of the 
Guide Bushing to the Sub-Spindle in Basic Simulation.  This is not used in Advanced 
Simulation.  

Sub-Spindle Home X Distance (Xh): Specifies the X-distance from Sub-Spindle 
center line to X=0 line in Basic Simulation. This is not used in Advanced Simulation.  

Extended Collet Nose: Parameters in this section of the spindle settings dialog are 
used to establish the size of the extended nose collet. 

Max Diameter (d1): Specifies the maximum diameter of a conically-shaped 
extended nose collet. 

Min Diameter (d2): Specifies the minimum diameter of a conically-shaped 
extended nose collet.  

Extension (E): Specifies the distance between the collet face and the Sub 
Spindle face. 

Spindle(s) Transparency:  Specifies how transparent the spindle(s) should 
appear. 0% means solid table, 100% means "fully transparent" spindle(s), that is 
invisible spindle(s).  

Spindle(s) Color: Allows a user to choose the color of spindle(s) using Window 
standard dialog. 
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Machining Function: Turning  
The Turn machining function uses conventional turning tools moving in the X and Z-
axes. Motion is programmed using X and Z coordinates. This machining function 
includes on centerline drilling where a drill is held stationary while the spindle 
holding the part rotates. All drilled holes must therefore be on the rotational 
centerline of the part.    

The picture below shows the appearance of the Setup dialog when performing 
Turning on the Main Spindle. Notice when turning on the main spindle, it is 
necessary to describe the length and diameter of the guide bushing being used. 

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock 
before machining 

ID Starting inside diameter of bar stock 
before machining  

Excess Stock (E) Rough stock left for facing on the front of 
the part 

Guide Bushing Length (l) 
Length of the “land area” of the guide 
bushing mechanism controlling the motion 
of the headstock through the main spindle 

Guide Bushing Diameter (d)
Outside diameter of the guide bushing 
mechanism controlling the motion of the 
headstock through the main spindle 
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The picture below shows the appearance of the Setup dialog when performing 
Turning on the Sub Spindle. Notice when turning on the sub spindle, it is NOT 
necessary to describe the length and diameter of the guide bushing being used as 
such operations involve a fixed headstock. 

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining  

Excess Stock (E) 
Rough stock left for facing on the front of the part, 
typically the distance past the of the part which the 
cut-off tool path has been programmed 
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Machining Function: Mill XY Plane 
The Mill XY Plane machining function supports machining operations on the face of 
the part using the Y-axis capability of the machine. G-code output will be generated 
in the form of X and Y coordinates. Features that can be created by using this Face 
Window include off-center holes on the face of the part, pockets on the face of the 
part, and contours (such as CAM shapes) on the face of the part. 

Programming of this machining function requires that your CNC Swiss-type lathe 
have a programmable Y-axis and that you have purchased the PartMaker Y-axis 
milling option. 

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining  

Index Angle (C) Specifies the angle to which the c-axis is 
indexed in this face window 
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Machining Function: Mill 5 Axis Plane 
The Mill 5 Axis Plane machining function supports angled machining operations 
using either a pivoting tool head or a fixed, angled tool.  Features that can be 
created by using this Face Window include any inclined feature including inclined 
holes, angled flats or any interpolation occurring on an angle. 

Use of this machining function requires that your CNC Swiss-type lathe has either a 
programmable tool head or the ability to be fitted with angeled tooling attachments 
and that you have purchased the PartMaker B-axis milling option. 

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining  
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Machining Function: Mill 5 Axis Plane (cont’d) 
Additionally, when using the Mill 5 Axis Plane Face Window, you will also be required 
to use the Face Options dialog which can be accessed by clicking the <Face 
Options> button in the Setup dialog. 

The Orientation Options section of the dialog is used to orient the part and set the 
local coordinate system being used for the features being machined in a given Mill 
5 Axis Plane Face Window. When working with a Solid Model, the parameters in 
the Orientation Options section of the dialog will be set automatically. 

 
Orientation Options 

Index Angle (C): Specifies the angle to which the c-axis is indexed in this face 
window.  

Inclination Angle (B):  Specifies the angle about the Z axis about which the 
toolhead or inclined too is tilted in this Face Window.  

Local Origin (Xo), Local Origin (Yo), Local Origin (Zo): These fields represent 
the co-ordinates for the local origin created to machine the planar face.   When 
working from a Solid Model, these values are determined by placing the local orgin 
in the mathematical center of the feature being machined. 

Arcs Output Options 

Break Arcs Into Lines: Checking this box indicates to break output for all arcs into 
small lines.  Checking this box is necessary for machines that do not have the ability 
to support a “local coordinate system” and cannot perform interpolation with an 
inclined tool.  

Arc Tolerance (T):  Specifies the sizes of “facets” when breaking arcs into lines. 
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Machining Function: Mill ZY Plane 
The Mill ZY Plane machining function is used to perform milling interpolation in the 
ZY plane when the spindle is locked at a discreet angular position.  All motions are 
performed with a tool oriented along the machine X-axis.  

Programming of this machining function requires that your CNC Swiss-type lathe 
have a programmable Y-axis and that you have purchased the PartMaker Y-axis 
milling option. 

 
 

Index Angle (C)  Orientation angle of the stock to achieve the 
desired face position 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining  
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Machining Function: Mill ZX Plane  
The Mill ZX Plane machining function is used to perform milling in the Z and X 
planes only. Such operations typically involve following a turning profile with an end 
mill (often ball nose) with the machine spindle in a locked position. This window can 
not be used to machine crossholes. 

Programming of this machining function requires that your CNC Swiss-type lathe 
have a programmable Y-axis and that you have purchased the PartMaker Y-axis 
milling option. 

 
 

Index Angle (C)  Orientation angle of the stock to achieve the desired face 
position 

Y-coord (p) Y coordinate value measuring the distance from the 
centerline of the part the tool is offset during machining.  
This value should always be positive. 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before machining 

ID Starting inside diameter of bar stock before machining  
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Machining Function: Mill Polygon  
The Mill Polygon machining function allows you to create polygon shapes on the OD 
of a part using the Y-axis capability of your machine and a tool oriented along the 
X-axis of the machine. 

Programming of this machining function requires that your CNC Swiss-type lathe 
have a programmable Y-axis and that you have purchased the PartMaker Y-axis 
milling option. 

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before machining 

ID Starting inside diameter of bar stock before machining  
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Machining Function: Mill End, Index  
The Mill End, Index machining functon is used when drilling holes and milling slots 
on the end face of the part. The holes are located in the XY plane and oriented along 
the Z-axis.  

The shapes that can be created with this machining function are:  

 Holes in the end of the work created by Z-axis feed. This motion type supports 
off-center drilling on the end of the part, using C-axis indexing and X-axis 
positioning to locate the hole position.  

 Radial slots which are milled using C-axis indexing to position and hold the part 
while X-axis motion is used to cut the part. The tool would be a milling tool 
oriented along the Z-axis. 

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before machining 



 

2-14 PartMaker  Copyright @2014 Delcam Ltd 

 

Machining Function: Mill Diam, Index  
The Mill Diam, Index machining function allows you  to create “cross holes” or radial 
slots on the OD of the part.  In order to support this machining function, your CNC 
Swiss-type lathe must be able to support C-axis indexing, which may not be 
performed while the tool is in contact with the work.  

This machining function supports the following features cut on the outside diameter 
of the work using a tool oriented along the machine's X-axis:  

 Slots oriented along the length (Z-axis) of the stock. 

 Holes drilled anywhere along the cylinder except the end of the stock. 

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before machining 

ID Starting inside diameter of bar stock before machining  
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Machining Function: Mill End, Polar  
The Mill End, Polar machining function allows you to perform polar interpolation on 
the face of the part. This machining function assumes that the CNC Swiss-type lathe 
has the ability to perform simultaneous feed motions with the X, Z and C-axes. 
Tools must be oriented along the machine’s Z-axis.  

Programming of this machining function requires that your CNC Swiss-type lathe 
has a programmable C-axis and that you have purchased the PartMaker C-axis 
milling option. 

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining 
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Machining Function: Mill Diam, Polar  
The Mill Diam, Polar machining function supports polar milling anywhere on the 
stock using an X-axis oriented milling tool. This machining function assumes that 
your CNC Swiss-type lathe has the ability to perform simultaneous feed motions 
with the X, Z and C-axes. The Mill Diam, Polar machining function is most commonly 
used to machine polygon features on the OD of the part using continuous C-axis 
feed.  Programming of this type in Face Windows is carried out in much the same 
manner as the Mill Polygon machining function. 

Programming of this machining function requires that your CNC Swiss-type lathe 
has a programmable C-axis and that you have purchased the PartMaker C-axis 
milling option. 

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before machining 

ID Starting inside diameter of bar stock before machining  
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Machining Function: Mill Cylinder 
The Mill Cylinder machining function supports continuous milling on the outside 
diameter of the part.  Cylindrical milling assumes that your CNC Swiss-type lathe 
has the ability to simultaneously feed in the X, Z and C axes. 

Using motions of this type, combined with a tool oriented along the X axis of the 
machine, profiles can be created on the outside diameter of the stock. 

Tool positioning is programmed using X, Z, and C axis coordinates.  The C position 
is programmed in terms of degrees of rotation relative to machine C=0 which is 
clearly shown in the graphic below. 

Programming of this machining function requires that your CNC Swiss-type lathe 
has a programmable C-axis and that you have purchased the PartMaker C-axis 
milling option. 

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before machining 

ID Starting inside diameter of bar stock before machining  
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PartMaker Programming Convention 
When using PartMaker SwissCAM for creating part geometry and NC programs, it 
is important to understand that all work is done moving from right to left in the Z-
axis. This means all drawing and tool path generation is created by moving to the 
left. This programming convention applies regardless of the physical construction of 
the machine, i.e. whether the guide bushing is on the left or right hand side of the 
machine. The same programming convention also applies for work being performed 
on the sub-spindle. To summarize, PartMaker always assumes the collet or chuck 
to be to the left. 

It is important to keep the right to left programming convention in mind when 
drawing, creating tool paths, and when setting up tools. Tool orientation should 
always be assigned assuming programming in the same direction. 

Working With Files 
PartMaker uses several kinds of files for storing tools, cycles, and material 
information. Your jobs and post processor files used to create NC programs for 
machining can also be stored in their own files. 

 Part geometry, tool path, and process information is saved in Job files that have 
the file extension .JOB.   

 Information about tools in the tool crib is saved in Tools files that have the file 
extension .TDB. 

 Information about material characteristics needed to calculate feed rates and 
spindle speeds is saved in Material files that have the file extension .MDB. 

 Information about user-created machining cycles is saved in Cycles files that 
have the file extension .CDB. 

 Postprocessor configuration information is saved in Post Configuration files 
that have the file extension .PST. 

The Job File 
The Job file is the main file type used in PartMaker. Every job file must have a 
tools and cycle file associated with it. However, particular tools and cycles files can 
be (and should be) associated with many if not all of your job files. Job files have 
the extension *.job. 

The name of the current job file you are working with is displayed at the top of the 
PartMaker screen as shown below: 
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Working With Databases 
Databases are where you store tool, material, and cycle information for PartMaker 
jobs. PartMaker accesses material, tools, and cycles databases for the information 
needed for each job. These three databases represent the knowledge-based 
components of PartMaker because they allow you to store shop specific 
information that can be reapplied to future jobs automatically, thus letting 
PartMaker learn from you. The more you use PartMaker, the smarter it gets! 

 Important! Before you begin programming a job, make sure you properly 
set up your databases in PartMaker. This means creating the tools you 
need for the job, selecting the material you are cutting and setting-up the 
hole making cycles you may need to machine the part. 

Tools Database 
A Tools Database allows you to keep track of your current tool inventory. 
PartMaker uses geometric and cutting tool characteristics saved with each tool in 
the database for automatic cutting conditions and automatic depth calculation. Each 
tool database can store up to 3,000 different tools. 

 Note: Due to the unique nature of tool placement and off-set information 
required by different Swiss-type lathes, when using PartMaker SwissCAM it 
is recommended that you setup one tools file for each Swiss machine you 
are programming. Doing so will avoid a great deal of confusion. 

You can access PartMaker’s Tools Database by choosing Tools from the 
ToolMinder menu. The picture on the following page highlights some of the key 
elements of the Tool Data dialog for both turning and milling tools. Please take the 
time to review and understand these now. 

Tools for Turning 
The turning tool below can be viewed by choosing Tools from the ToolMinder menu 
and choosing OD Turn 80-Right. 

 
1 The Type, Location and Orientation fields determine general appearance 

of the current tool. These fields apply to turning tools – turning, grooving 
and threading tools. It is important to be mindful of the tool orientation with 
respect to PartMaker SwissCAM’s programming convention. You must 
remember programming is done assuming the collet or workholding to be to 
the left. 



 

2-20 PartMaker  Copyright @2014 Delcam Ltd 

 

2 For Turning tools only, the type of insert can be specified in the Insert drop 
down menu. 

3 The Material drop down menu allows you to choose the material for the 
current tool. This selection will directly impact feed and speed calculations. 

4 The Tool Post drop down menu allows you to choose the location or tool 
post in the Swiss-lathe where a tool is mounted. Various Swiss machines 
have different configurations, but all varieties are accommodated by using 
the selections from the Tool Post drop down menu. Be sure to designate the 
correct tool group when setting up a tool. Each tool group selection can be 
explained as follows: 

 Gang Slide – Indicates that the current tool resides in the gang tool 
slide. Most new Swiss-type lathes have at least one such tool post. 

 Turret – Indicates that the current tool resides in the turret, if the 
machine is so equipped. Many very advanced Swiss-machines come 
equipped with a turret in addition to other tools posts. Many slightly older 
vintage Swiss-type lathes also come equipped with turret-type tool posts. 

 End Working – Indicates that the current tool is capable of working on 
the end of the part while the part is being held in the main spindle. 

 Back Working – Indicates that the current tool is designated for 
machining on the back of the part while the part is being held the in sub-
spindle. 

 Gang Slide #2 – Indicates that the current tool resides in the second 
gang tool slide on the machine. For use with Swiss-type lathes that have 
two independently programmable gang slides. 

 Turret #2 – Indicates that the current tool resides in the second turret 
on the machine. For use with Swiss-type lathes that have a two-turret 
structure. 

 Turret #3 – Indicates that the current tool resides in the third turret on 
the machine. For use with Swiss-type lathes that have a three-turret 
structure. 

 Tool Head – Indicates that the current tool resides in a “tool head”.  A tool 
head is for Swiss machine with Tool Changers. 

5 The List of Tools by: radio button allows you to list tools either by their 
Type or Tool ID, their unique catalogue number in the tool database. Tools 
will be shown sorted in the list based on their Tool ID and assigned name 
from the Rename To: field. 

6 Left clicking the buttons shown in the Tool Data dialog does the following: 

 <New> – Allows you to create new tools to be added to the tools 
database. 

 <Delete> – Allows you to remove or delete an existing tool from the 
tools database. 

 <Close> – Accepts or applies any new parameters or data entered into 
the various fields in the Tool Data dialog, and closes the dialog. 

 <Verify Shape> – Allows you to verify the shape in 2D of the currently 
selected tool according to the specified parameters.  

 <Shape Preview> – Allows you to verify the shape in 3D of the 
currently selected tool according to the specified parameters. 

 <Tool Properties> - Clicking this button displays the Tool Properties dialog. 
The tool properties dialog allows you define tool specific offsets for each tool.  
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7 Clicking the <Set Default Z-Shift> button in Tool Properties dialog looks at 
the currently selected tool and assigns a “Tool Shift” automatically. A tool 
shift is most commonly the distance the stock must be pushed out of the 
guide bushing to reach the programmable point of the tool. 

 
8 Click <OK> to return to the Tool Data dialog. 

 <Apply> - Accepts or applies any new parameters or data entered into 
the various fields in the Tool Data dialog and the dialog remains open. 

Tools for Milling and Holemaking 
Tools used for Holemaking and Milling are defined in the same way as turning tools. 
The major difference is the orientation. When setting up a milling or hole making 
tool – regardless of whether it will be “live” or “dead” (used on centerline in 
Machining Function Window of Type Turning) you must specify its orientation with 
respect to the stock being machined. 

Tool T009 in the list of tools below is a Tap. This tap has been designated as a “Z 
Tool” meaning it is oriented horizontally with respect to the stock being machined. 
The type of Face Window in which a tool with a “Z Tool” orientation is applied will 
determine if it is live or dead. 

See Tools for Turning in the previous section of this chapter for more information 
on the functionality of this dialog. 
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Next, look at tool T006 in the list of tools to select the End Mill. This end mill has 
been designated as an “X Tool” meaning it is oriented vertically with respect to the 
stock being machined. Tools with “X Tool” orientations are always “live” tools.  

 

Lock Tool Parameters 
Once you are finished editing the tool information, select the Lock Parameters 
check box to disable any changes to the parameters for that particular tool. Each 
tool can be individually locked to prevent modification. 

 
 

When you are finished viewing tool information, click the <Close> button. 
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Material Database 
The Material Database allows you to store your shop’s accumulated materials 
data. PartMaker uses this data in the automatic calculation of feed rates and spindle 
speeds. The Materials Database allows you to choose from a variety of different 
materials and even adjust them and store your changes in order to customize feeds 
and speeds to your shops requirements. 

Turn to Appendix A for a complete list of materials. You can also use the On-line 
Context Sensitive Help that comes with your PartMaker system to view a complete 
list of included material files, inclusive with various material grades for each. 

Selecting a Material File 
When creating a part, it is important to select a material. To do so: 

1 Choose Open Material File from the File menu to display the dialog shown 
below: 

 
2 Locate and select ST_FMSTW (Free Machining Stainless Steel Wrought) from 

the list and click <OK>. You are returned to the Face Window. 
3 To view the cutting characteristics of the selected material, choose Material 

from the ToolMinder menu and you will the see the dialog shown below: 
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Customizing a Material File 
You can customize materials files in PartMaker by adjusting the feed and speed 
charts displayed in the Material dialog. To do so: 

1 Choose Material from the ToolMinder menu to display the Material File 
dialog. 

 
2 Click the third radio button on the right hand side to display the feed chart. 

By clicking on and dragging the node points lying on the chart or the axes, 
you can customize feed rates for different sized drill. The same technique can 
be employed for spindle speeds as well for all the tools listed.  The graph 
below now shows a change: 

3 Once you are satisfied with the changes you have made, you can save your 
changes by choosing Save Material File As… from the File menu. In the 
file name section, enter “swiss_303” and click <OK> to save the material. 
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4 You will now notice the new name of the material file at the top of the 
Material File dialog as shown below:  

 

 Note: When saving changes to material files, you must give them a 
different name than the initial PartMaker material used. The material files 
that come with PartMaker are read-only files and cannot be overwritten. 

5 Click on the Ranges button to see how the chart is calculated. Notice how 
with each tool you can change parameters on which speeds and feeds are 
based as well as the speeds and feeds themselves. Click <OK> to close this 
dialog. 

6 Click the close box in the upper right hand corner of the dialog to return to 
the Face Window. 
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Cycles Database 
PartMaker lets you combine a number of repetitive operations (center drilling, 
drilling, tapping, boring, etc.) into a single entity called a Cycle. All cycles are saved 
in a Cycles Database. The Cycles Database can store up to 1,800 cycles. For each 
cycle operation, you can designate a tool from the Tools Database. Once a cycle is 
created, you can recall it at any time when you need to use it again. Cycles can be 
setup for both cross holes and holes on the face of the part, as well as for holes 
involving both live and dead tooling. 

Creating and Storing Cycles 
In this exercise, you will create a cycle for an on-center line tapped hole using 
existing tools in the tools database. This cycle will contain a spot drill (for spotting 
and chamfering), a drill and a tap. In Chapter 3, you will learn how to apply this 
cycle to a typical Swiss part. 

You can access PartMaker’s Cycles Database by choosing Cycles from the 
ToolMinder menu. Once you are in the Cycle Data dialog, to create a new cycle: 

1 Click the <New> button to create a new cycle. A blank cycle such as the 
one below will be displayed. 

 
2 The next step in creating a Cycle is determining how it will be used. You 

must determine if the cycle will use on-centerline tools or if it will use “live” 
tools and if these live tools will be used for face work (Z Tools) or for cross 
work (X Tools).   

The radio buttons at the bottom of the cycles dialog allow you to make this 
determination. By default the Mill and Z Tools radio button are checked. 

 
3 Here you will create a cycle that will use on-centerline or dead tools. The first 

step in creating this cycle is to indicate this is a cycle to be used in a Face 
Window of Machining Function Turn. To do so, click the Turn radio button as 
shown below:   
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4 Next, choose the operations that will comprise the cycle. To do so choose 
Spot Drill, Drill and Tap respectively from the Operation Type drop down 
menu. After doing so, your dialog should appear as shown below: 

 
5 Next, choose the corresponding Canned Cycles from the Canned Cycles drop 

menu for each of these operations, which will be DRILL, DRILL and RIGID 
TAP respectively.  

Finally, specify the diameter for each tool. In this case, the Spot Drill should 
be 0.06, the Drill 0.048 and the Tap 0.06.  

 Note: When defining tools that will perform chamfering operations in the 
cycles database, the specified hole diameter should be equal to that of the 
Major Operation.  

After entering the parameters as specified above, your dialog should appear as 
shown below: 
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6 Click the <Select Tools> button and PartMaker will select the tools in tools 
database corresponding to each operation as shown below. 

 
7 In the Rename To: field, rename the cycle Tap .06 and click the <Apply> 

button. 
8 Finally, click the radio button to the left of the Tap Operation Type to indicate 

the major operation of this cycle is tapping as shown below:   

 
9 The completed Cycle Data dialog should appear as shown below: 

 
Notice that the column for depth has not been filled out. It has been 
intentionally left blank in order to allow PartMaker to calculate the depths of 
cut for each tool automatically when applied to the part. This automatic 
calculation is based on the nominal hole depth and specified geometric 
characteristics of the tools in the cycle.   

 Note: One cycle may be applied to many different jobs, and allowing 
PartMaker to calculate the depth of cut makes each cycle more flexible. 
It may at times be desirable to enter a value into the depth field. When 
doing so, be advised that this value will be “hard coded” and that 
whenever using the cycle, this tool will always travel to the depth 
specified in the Cycles Data dialog. 

10 Once you are satisfied that your dialog appears as the one above, click the 
<Close> button. 
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Working in a Face Window 
A Face Window is the work area in which you define groups machining features or 
tool paths. The main area of the window displays the part boundaries; the left frame 
displays the program groups in a tree format, which have the cycle name labels 
needed to machine the current part. Just to the left of the main screen area displays 
the Graphics Icons as well as the Short Cut to the Setup dialog icon. 

 
Additionally, Face Windows can display icon toolbars to help speed-up many tasks in 
PartMaker.  See more on Toolbars in the section titled Using the Icon Toolbars. 

 

 

Displaying the 
Axes 

To display the axes in a Face Window by choose Show 
Axes from the View menu or click the Show Axis icon 
from the Face Window Toolbar. 

 

Displaying the 
Boundaries 

To display the part boundaries in a Face Window choose 
Show Boundaries from the View menu or click the Show 
Boundaries Icon from the Face Window Toolbar 

Using the CAD/CAM Switch 

 
The left icon represents CAM mode. Clicking on it will switch to the 
CAD mode represented by the icon on the right. 

 

All tool path creation and process development is done in the CAM mode. All 
geometry creation and alteration is done in the CAD mode. 

Using the Color Bar 
The color bar in the upper-right corner of a Face Window is used to select a color for 
group symbols. It is also used to change the color of geometry. The group symbol 
or geometric element will have the currently chosen Sample Color. 

 Note: If you want to change the color of a Group Symbol, select the Group 
Symbol in the Face Window, click a color on the color bar, and then click the 
Sample Color on the left side of the color bar. 

To change the color of a geometric element, select the geometry in the Face 
Window, click a color on the color bar, and then click the Sample Color on the left 
side of the color bar. 

Sample Color 
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Using the Icon Toolbars 
PartMaker Version 9 and higher provides Toolbars to speed up commonly used 
functions throughout the software. PartMaker supports four types of icon toolbars:  

 Main Toolbar which is available throughout a job file, 

 Face Window Toolbar which is associated with each Face Window, 

 Solids Window Toolbar which appears when working with an imported Solid 
Model 

 Simulation Toolbar which appears when working in PartMaker’s 3D simulation. 

Here, the Main Toolbar and Face Window Toolbar are explained.  Chapter 4 of this 
guide will explain the use of the Simulation Toolbar while Appendix C to this manual 
will explain the use of the Solids Window Toolbar. 

Main Toolbar 
The Main Toolbar lets you perform many of the functions in PartMaker’s menus with 
the click of a button.  The Main Toolbar will look the same throughout your 
PartMaker session and appears as below: 

 

 Note:  When hovering over any of these icons, a “Tool Tip” will appear 
showing the function performed by that icon. Each command is explained in 
greater detail in Chapter 4 of this manual. 

Face Window Toolbar – CAM Mode 
The Face Window Toolbar lets you perform many of the functions in PartMaker’s 
menu’s with the click of a button.  The toolbar applies only to the active Face 
Window and may look different depending on the Machining Function Face Window 
being used. 

 

Face Window Toolbar – CAD Mode 

 

Displaying Toolbar Icons 
The display of the Toolbars can be manipulated by choosing Toolbars from the View 
menu.  When a toolbar is checked, it will appear.  When unchecked, it will not be 
visible. 
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Creating Groups of Part Features 
Groups of part features such as holes and profiles are created in PartMaker. The 
currently selected group icon or Group Symbol in a Face Window is the work group 
from which tool paths are being added. 

To create a new Group Symbol: 
1 Click the desired color on the color bar. 
2 Choose New Profile or New Hole Group (depending on the type of Part 

Feature being created) from the Part Features menu to display the Group 
Parameters dialog. When you exit the dialog, the new group is created using 
the color you specified. 

 

Using the Graphics Icons in PartMaker CAD mode 
You can create your part drawings in PartMaker in the CAD mode. Alternatively, 
you also import drawings from other CAD systems into PartMaker by using the 
Import command from the File menu. Imported geometry can be altered in 
PartMaker’s CAD mode. 

 

Geometry is created in PartMaker CAD using the Graphics Icons that include 
Drawing Icons and Snap Modes. 
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Geometry Drawing Icons  
Geometry Drawing icons allow you to create different types of geometric 
constructions such as lines and arcs. PartMaker’s geometry drawing icons are 
defined below. 

 

Selection Icon indicates that the system is in the selection mode. In this 
mode you can select lines, arcs and circles in the Face Window either by 
clicking on them or dragging a selection rectangle around them. 

 
Zero Icon allows you to define a new location for the zero point using Snap 
Modes. 

 
Trim/Extend Icon allows you to stretch or shorten an existing line or arc. 

 
Remove Icon allows you to remove portions of lines or arcs between 
intersection points. 

 
Line Thru Two Points Icon allows you to create a line between two points 
specified using Snap Modes. 

 
Connected Lines Icon allows you to create connected lines with end points 
specified using Snap Modes. 

 
Line Parallel Horizontal axis Icon allows you to create a line parallel to the 
Horizontal axis by specifying positive or negative offset. 

 
Line Parallel Vertical axis Icon allows you to create a line parallel to the 
Vertical axis by specifying positive or negative offset. 

 
Parallel Element Icon allows you to create a line, arc, or circle parallel to the 
cursor selected entity specifying an unsigned distance. 

 
Line on an Angle Icon allows you to create a line on an angle to a cursor-
selected line passing through a point specified using Snap Modes. 

 
Fillet Icon allows you to insert a fillet between two cursor-selected lines or 
arcs. 

 
Chamfer Icon allows you to insert a chamfer between two cursor-selected 
lines or arcs. 

 
Circle with a Known Radius and Center Icon allows you to define a circle 
with a center specified using Snap Modes. 

 
Circle with a Known Radius and Two Points Icon allows you to define a 
circle with two points on the circumference specified using Snap Modes. 

 
Circle with a Known Center and a Point Icon allows you to define a circle 
with a center and a point on the circumference specified using Snap Modes. 

 
Circle Through Three Points Icon allows you to define a circle with three 
points specified using Snap Modes. 

 
Polygon Icon allows you to create a various rectangles by entering a flat-to-
flat distance. 

 
Divide/Append Icon aids you in the “breaking” of segments at specific point 
within the geometry.  

 
Multiple Offset Icon allows you to offset the selected geometry chain through 
a user-defined distance. 

 
Ellipse Icon allows you to create an approximate ellipse in the face window, 
using tangential circular arcs. 
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Dimensioning Icons 
The Dimensioning Icons appear in the PartMaker CAD mode.  These icons allow you 
to create dimension and annotations on your drawings in PartMaker. 

 Note Icon Allows you to create a note on a dimensioned drawing. 

 

Note with Leader Icon allows you create a note with an arrow leader to 
point to a specific item on your drawing you wish to annotate. 

 

 

Angular Dimension This icon allows you to insert an Angular Dimension 
between two lines.. 

 

 

Circular Dimension Icon This icon allows you to insert a Circular 
Dimension on arc or circle. 

 

 

Horizontal Dimension Icon This icon allows you to insert a Horizontal 
Dimension between two points that are either end points of arcs and lines 
or centers of circles. 

 

 

Vertical Dimension Icon This icon allows you to insert a Vertical 
Dimension between two points that are either end points of arcs and lines 
or centers of circles. 

 

 

Linear Dimension Icon This icon allows you to insert a Linear Dimension 
between two points that are either end points of arcs and lines or centers 
of circles. 

 

 

Flexible Dimension Icon This icon allows you to insert a “Flexible 
Dimension” that is automatically set by the software to either Horizontal 
Dimension or Vertical Dimension or Linear Dimension depending on the 
cursor position when the text location is specified. 
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Snap Modes 
Snap modes are used in conjunction with geometry icons to define point location. 
PartMaker’s Snap Modes are defined below. Snap drawing modes are also used in 
the CAM mode to define tool path location. 

 

 
 

ZX Coordinates: Used for entering Cartesian coordinates. 
For Face Windows of various machining functions, this snap mode will appear 
differently. 

 

ZX for Mill ZX Plane and Turn 
XY for Mill XY Plane, Mill Polygon, Mill End Index, Mill End Polar and Mill 
Diam Polar 
ZC for Mill Diam Index and Mill Cylinder 
ZY for Mill ZY Plane 

 Polar Coordinates: Used for entering Polar coordinates 

 
Point on a Circle: Clicking a point on an existing arc or circle and entering an 
Angle 

 Screen: Clicking a cursor location anywhere within the face window 

 

Grid: Clicking a grid location (grid can be turned on from the View Menu by 
choosing Show Grid. Grid size can be set in the Preferences dialog accessed 
from the View menu). 

 Circle Center: Clicking the center an existing circle 

 Closest Intersection: Clicking the closest intersection of geometric elements 

 End of an Element: Clicking the end of an existing line or arc 

 Middle of an Element: Clicking the middle of an existing line or arc 

 
Tangency: Clicking near the tangency point that will be calculated by the 
system 

 
Horizontal Constraint allows you to specify a point whose vertical coordinate 
remains constant, allowing changes in horizontal coordinate only. 

 
Vertical Constraint allows you to specify a point whose horizontal coordinate 
remains constant, allowing changes in vertical coordinate only. 
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Using the Graphics Icons in PartMaker CAM mode 
The Graphics Icons to the left of a CAM Face Window allow you to define and 
manipulate tool paths. The list of the Graphics Icons for use in assigning a particular 
part feature to your part (i.e. a Group Symbol) will have a different appearance 
depending on the Machining Function Face Window being used. 

The two icons below will have the same appearance and usage regardless of which 
machining function Face Window you are using. 

 

Selection Icon indicates that the system is in the selection mode. In this mode, 
you can select part features and tool paths in the Face Window either by clicking 
or dragging a selection rectangle around them. 

Selected profiles in a Face Window are highlighted; unselected profiles are not 
highlighted. Selected holes in a Face Window are highlighted; unselected holes 
are hollow.  You can delete selected elements by pressing the <Backspace> key 
on the keyboard or by choosing the Delete command from the Edit menu.

 
Zero Icon allows you to define a new location for the zero point or origin using 
Snap Modes. 

The following icons will have the same function in any given Face Window.  
However, the list changes depending on which machining function Face Window 
you are using. 

 
Profile Icon enables you to specify that the currently active group symbol is to 
be applied to the profile described by either coordinate entry or by clicking on 
geometric elements.

 
Chain Icon enables you to specify that the currently active group symbol is to 
be applied to a profile that is created when PartMaker automatically connects all 
the elements that form an unbroken chain when an initial line or arc is clicked.

 
2-Point Chain Icon The 2-Point Chain icon allows you to define a profile by the 
start point in the chain, and the end point of the chain. 

 
Profile Info allows you to select an element (line or arc) on the profile curve 
and to display a Profile Info Dialog. This icon is available only if a profile group 
already exists. 

 
Single Hole Icon enables you to use Snap Modes to define the location on the 
geometry where a currently active Hole Group Symbol is to be executed. 

 
Define Profile Icon enables you to specify that the currently active group 
symbol is to be applied to the profile described by either coordinate entry or by 
clicking on geometric elements.

 
Chain Geometry Icon enables you to specify that the currently active group 
symbol is to be applied to a profile that is created when PartMaker automatically 
connects all the elements that form an unbroken chain with an initial line or arc 

 
Profile Icon enables you to specify that the currently active group symbol is to 
be applied to the profile described by either coordinate entry or by clicking on 
geometric elements.  When performing indexing operations, the Profile Icon 

 
Chain Icon enables you to specify that the currently active group symbol is to 
be applied to a profile that is created when PartMaker automatically connects all 
the elements that form an unbroken chain with an initial line or arc clicked. 

 
Engrave Icon enables you to use the Engrave Data dialog box to create a 
profile containing numbers and letters. 
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Process Synchronization in PartMaker SwissCAM 
After a part has been programmed in PartMaker SwissCAM, the user has the 
opportunity to synchronize the processes defined in each of the Face Windows. 
Process synchronization is done visually by PartMaker via the Set Modes dialog 
accessed from the Process Table by clicking on the Set Modes icon to the right of 
every process. 

 

Introduction to Synchronization 
Generally speaking, today’s CNC Swiss-type lathes can allow four types of 
synchronous machining: 

Type 1:  The first type of synchronous machining which can be performed on a CNC 
Swiss is actually NOT synchronized at all. This involves machining on one spindle at 
a time with a single tool while the other spindle remains idle. This type of 
synchronous operation is represented by the following PartMaker modes: 

M1S0: Main Spindle Machining with One Tool, Sub Spindle idle. This mode of 
operation involves cutting with only one tool on the main spindle, while no 
machining occurs on the sub-spindle. This mode may be used if a part only 
requires main spindle work, if all simultaneously occurring operations have 
already been synchronized, or if the machine does not allow synchronous 
operation under certain circumstances (i.e. when end working is being 
performed or when live tools are engaged). 

This mode of operation may only be assigned to processes defined in a Face 
Window created for work on the Main Spindle. 

 

Set Modes Icon 
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M0S1: Main Spindle Idle, Sub Spindle Machining with One Tool. This mode of 
operation   involves cutting with only one tool on the sub spindle, while no 
machining occurs on the main spindle. 

This mode of operation may only be assigned to processes defined in a Face 
Window created for work on the Sub Spindle. 

 

Type 2:  Two Tools working on different spindles simultaneously. This type of 
synchronous operation is represented by the following PartMaker modes: 

M1S1: Main Spindle Cutting with One Tool, Sub Spindle Machining with One 
Tool. This synchronous mode operation involves the use of two tools on separate 
tool posts (as created in the PartMaker Tool Database), cutting on separate 
spindles. 
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M1SD: Double ended drilling, or performing on centerline drilling on the Main 
and Sub Spindle at the same time. On some machines, this synchronous mode 
of operation involves the use of two tools on separate tool posts (as created in 
the PartMaker Tool Database). On other Swiss-type lathes, this type of 
operation may be performed using a special double-ended tool holder on a single 
tool post. 

 

Type 3:  Two Tools working simultaneously on the main spindle. This type of 
synchronization is often referred to as “Pinch Turning” or “Balance Turning” when it 
involves two outside diameter turning operations. It may also be used when 
performing turning on the outside diameter and inside diameter (ID boring or 
drilling on the end of a part) simultaneously. This type of synchronous operation is 
represented by the following PartMaker modes: 

M2S0: Main Spindle Machining with Two Tools, Sub Idle. This synchronous mode 
of operation involves the use of two tools on separate tool posts (as created in 
the PartMaker Tool Database) on the same spindle. These tools can either both 
be turning tools or one can be a turning tool while the other is a “dead” hole 
making tool performing on centerline work on the end of the part. 
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M2SF/M2SN: Main Spindle Machining with Two Tools, Sub performing Follow 
Support (closed collet) or Non-Follow Support (open collet). This synchronous 
mode of operation involves the use of two tools on separate tool posts (as 
created in the PartMaker Tool Database) working on the same spindle while the 
sub-spindle is supporting the stock. In this case, the tools must both be working 
on the outside diameter. 

  
Type 4:  Three tools working simultaneously, where two tools are working on the 
main spindle and one tool is working on the sub spindle. In such a case, two tools 
can be working simultaneously on the main spindle while a third is working on the 
sub-spindle. Only the most advanced Swiss machines on the market are capable of 
such operation. This type of synchronous operation is represented by the following 
PartMaker modes: 

M2S1: Main Spindle Machining with Two Tools, Sub Spindle Machining with One 
Tool. This synchronous mode operation involves the use of two tools on separate 
tool posts (as created in the PartMaker Tool Database) on the main spindle, 
while using a third tool mounted on a third tool post on the sub spindle. 
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M2SD: Double ended drilling, or performing on centerline drilling on the Main 
and Sub Spindle at the same time while turning the outside diameter on the 
main spindle. On some machines, this synchronous mode of operation involves 
the use of three tools on separate tool posts (as created in the PartMaker Tool 
Database). On other Swiss-type lathes, this type of operation may be performed 
using a special double-ended tool holder on a single tool post while turning on 
the outside diameter is done with a separate tool post. 

 
Type 5:  Two Tools working simultaneously on the sub spindle. This type of 
synchronization is often referred to as “Pinch Turning” or “Balance Turning” when it 
involves two outside diameter turning operations. It may also be used when 
performing turning on the outside diameter and inside diameter (ID boring or 
drilling on the end of a part) simultaneously. This type of synchronous operation is 
represented by the following PartMaker modes: 

M0S2: Sub Spindle Machining with Two Tools, Main Idle. This synchronous mode 
of operation involves the use of two tools on separate tool posts (as created in 
the PartMaker Tool Database) on the same spindle. These tools can either both 
be turning tools or one can be a turning tool while the other is a “dead” hole 
making tool performing on centerline work on the end of the part. 
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M1S2: Main Spindle Machining with One Tool, Sub Spindle Machining with Two 
Tools. This synchronous mode operation involves the use of two tools on 
separate tool posts (as created in the PartMaker Tool Database) on the sub 
spindle, while using a third tool mounted on a third tool post on the main 
spindle. 

 



 

2-42 PartMaker  Copyright @2014 Delcam Ltd 

 

Working with Sync Groups 
Once the user has chosen the manner in which processes will be synchronized on 
the Process Table, he has to determine the order in which these processes must be 
grouped. A group of two or more consecutive processes being executed with the 
same PartMaker Synchronization Mode, as described in Synchronization Types 2 – 
4 above, is called a Sync Group. Sync Groups are created automatically when the 
Synchronize button is clicked or when the Generate NC Program command is 
chosen. Each Sync Group will have a number assigned to it, denoting separate 
groups of synchronous operations, such as those shown below: 

 

PartMaker will perform error checking when the Sync Groups are created. Error 
checking assures that groups of processes being executed simultaneously have been 
ordered correctly on the Process Table. This error checking also includes 
determining whether proper tool post assignments have been made. 

Primary vs. Secondary Tools 
When working with synchronized operations on the Main Spindle, PartMaker 
differentiates between the Primary and Secondary Tool in a Sync Group. The 
Primary Tool is defined as the tool performing the work in the first process in the 
Sync Group.  Parameters such as feed rate and spindle speed are typically dictated 
by the Primary Tool.  The Secondary Tool is the tool being synchronized with the 
Primary Tool but represented by another process on the Process Table. This concept 
is applied in the synchronization of Type 3 and Type 4 described above. For 
machines with gang slide tooling configurations, the gang tool in a given Sync 
Group will always be the Primary Tool. 

Determining the Active Tool in a Sync Group 

The user can differentiate between Primary and 
Secondary Tools for any process in a  Sync 
Group by noting the color of the tool in the Set 
Modes dialog assigned to that process. The tool 
in use during the current process will always be 
colored in yellow, while the tool that is not 
cutting will be shaded in gray as shown in the 
diagram to the right, taken from the M2S0 Set 
Modes dialog. 
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Rules for Grouping Synchronized Operations 
Rules for grouping operations assigned various PartMaker Modes are explained 
below: 

M1S0: Main Spindle Machining with One Tool, Sub Spindle idle. 

Processes assigned M1S0 modes must involve one or more sequential processes 
defined in Face Windows designated for work on the Main Spindle. Processes may 
use tools from any tool post capable of working on the main spindle. 

Process Table Example: 

 
M0S1: Main Spindle Idle, Sub Spindle Machining with One Tool. 

Processes assigned M0S1 modes must involve one or more sequential processes 
defined in Face Windows designated for work on the Sub Spindle. Processes may 
use tools from any tool post capable of working on the sub spindle. 

Process Table Example: 

 
M1S1: Main Spindle Machining with One Tool, Sub Spindle Machining with One Tool. 

Processes assigned M1S1 modes must involve one or more sequential processes 
defined in Face Windows designated for work on the Main Spindle followed by one 
or more sequential processes defined in Face Windows designated for work on the 
Sub Spindle. Within a group of processes labeled M1S1, PartMaker will generate an 
error if the same tool post is used on both a main spindle and sub spindle process. 
In addition, the stock should either be stationary or moving for all Main Spindle 
processes in an M1S1 sync group. 

Process Table Example: 
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M1SF/M1SN: Main Spindle Machining with One Tool, Sub Spindle providing 
Following Support (Closed Sub-Spindle Collet) or Non-Following Support (Open Sub-
Spindle Collet). 

Processes assigned M1SF/M1SN modes must involve one or more sequential 
processes defined in Face Windows designated for work on the Main Spindle. 
Processes assigned these modes should use tools whose movements are 
independent of the sub-spindle. In addition, PartMaker will display errors if Sub-
Spindle Support Z-Coordinate (Sz) parameters are not provided, or if negative 
values are entered in this field. 

Process Table Example: 

 
M1SD: Double Ended Drilling, or performing on centerline drilling on the Main and 
Sub Spindle at the same time. 

Processes assigned the M1SD mode must involve exactly one centerline hole making 
process defined in a Main Spindle Turning Face Window followed by exactly one 
centerline hole making process defined in a Face Window designated for work on 
the Sub Spindle. Depending on the machine configuration, tools used in this Sync 
Group may be on the same tool post or on different ones. 

Process Table Example: 

 
M2S0: Main Spindle Machining with Two Tools, Sub Idle. 

This synchronous mode of operation involves the use of two tools on separate tool 
posts (as created in the PartMaker Tools Database) on the same spindle. Pinch 
Turning is handled in this mode and the M2S0 mode will be designated 
automatically on the process table if the Pinch Turning box for two groups is 
checked. Simultaneous OD and ID work is also programmed using this mode. 

Processes assigned M2S0 modes must involve one or more sequential processes 
involving a Primary Tool followed by one or more sequential processes using a 
Secondary Tool. The Primary and Secondary Tools used in this Sync Group must 
be assigned to different Tool Posts. In addition, the stock should either be stationary 
or moving for all Main Spindle processes in an M2S0 sync group. 

Process Table Example: 
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M2SN/M2SF: These two synchronous modes of operation observe the same rules 
as the M2S0 Mode, except that they involve sub-spindle support during machining. 

In addition, because the sub-spindle is providing support during the modes, 
processes assigned the M2SN or M2SF may not involve tools mounted on the sub-
spindle, i.e. end working tools. 

Process Table Example: 

 
M2S1: Main Spindle Machining with Two Tools, Sub Spindle Machining with One 
Tool. 

A Sync Group with processes assigned the M2S1 mode must involve one or more 
sequential processes defined in Face Windows designated for work on the Main 
Spindle involving a Primary Tool. This operation should be followed by one or more 
sequential processes designated for work on the Main Spindle involving a Secondary 
Tool. Finally, the main spindle operations should be followed by one or more 
sequential processes defined in Face Windows designated for work on the Sub 
Spindle using the Back Working Tool Post. 

Within a group of processes labeled M2S1, PartMaker will generate an error if the 
same tool post is used with either the Primary Tool or Secondary Tool on the 
main spindle and/or with tools being used on the sub spindle.  Three tool posts 
should be used within a Sync Group involving the M2S1 mode. In addition, the stock 
should either be stationary or moving for all Main Spindle processes in an M2S1 
sync group. 

Process Table Example: 
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M2SD: Main Spindle Machining with Two Tools, Double Ended Drilling. 

A Sync group with processes assigned the M2SD mode must involve one or more 
sequential processes defined in Face Windows designated for work on the Main 
Spindle involving a Primary Tool followed by a single process defined in a Turning 
Face Window designated for work on the Main Spindle involving a Secondary 
Tool.  The Primary Tools should be involved in an OD process, while the 
Secondary Tool should be an on centerline holemaking tool.  The main spindle 
processes should be followed by a single on centerline holemaking process defined 
in a Face Window designated for work on the Sub Spindle. 

Within a group of processes labeled M2SD, PartMaker will generate an error if the 
same tool post is used with either the Primary Tool or Secondary Tool on the 
main spindle, although the tool being used on the sub spindle may be mounted in 
the same tool post as the Secondary Tool.  The stock should be moving for all 
Main Spindle processes in an M2SD sync group. 

Process Table Example: 

 

More Information on Sync Groups 
You can learn more about using and applying Sync Groups for your machines by 
referring to the machine specific addendum, which came with your PartMaker 
SwissCAM software. This addendum contains information about machine-specific 
synchronization techniques as well as which synchronous modes of operation your 
post processors support. 
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Material Control Processes 
Material Control Processes (MCPs) are processes that do not involve material 
removal but do require NC programming.  MCPs can be inserted into the Process 
Table via the <Insert Material Control Process> command under the Job 
Optimizer menu.  Upon insertion into the Process Table, MCPs will be placed at the 
top of the Process Table by default.  MCP actual place in the process will be 
determined by clicking on the arrow beneath the cutting after which the MCP should 
be activated. 

MCPs – When Use Guide Bushing is Checked 
In PartMaker SwissCAM, when the Use Guide Bushing box is checked, the only 
available MCP pertains to rechuck, i.e. the process of regripping the bar stock with 
the main spindle to support the machining of parts longer than the stroke of the 
machine.  

Rechuck 

 
Grip Coord (Zg): Specifies the z position on the part that the sub-spindle grips 
during rechuck. 
Pull Distance (Zp): The amount of main spindle collet retraction during the 
rechuck operation. 
Position Point (Zr): Specifies the Z-coordinate of the stock to be pushed out of 
the guide bushing before rechucking occurs. 

Process Time: Enter a time estimation from when the Bar Stop moves from its safe 
index position at the beginning of the process to when the Bar Stop moves back to 
its safe index position at the end of the process. Time can either be set to seconds 
or minutes – see Preferences on how to set time units. 

 Note: Individual post processors may or may not support rechuck.  Please 
consult your machine-specific addendum or PartMaker Technical Support to 
determine if your post processor supports rechuck. 
 

MCPs – When Use Guide Bushing is Not Checked 
In PartMaker SwissCAM, when the Use Guide Bushing box is NOT checked, a 
number of Material Control Processes become available to the user due to the 
capability of “guide bushing-less” Swiss machines which are a hybrid between 
conventional Swiss-type lathes and Turn-Mills. 
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Bar Feed 
The Bar Feed Material Control Process allows the user to insert code for feeding the 
bar stock out to a certain Z-coordinate and stopping with it a bar stop mounted in 
the turret. 

 
Tool Post: Choose the Tool Post on which the Bar Stop is mounted.  A bar stop can 
be mounted on any of the following tool posts: Turret, End Working, Back 
Working, Gang Slide #2, Turret #2 or Turret #3. 

Tool No.: Enter the tool station number at which the Bar Stop is mounted. The 
number must be a one or two digit integer. 
Tool Offset: Enter the offset number for the Bar Stop. The number must be a one 
or two digit integer. 

Xr: Enter an absolute x coordinate (measured from the center of the spindle) to 
position the Bar Stop before stock is pushed out.  This number would typically be 
zero. 

 Note: If using the cutoff tool as the Bar Stop, enter a negative x coordinate 
in order to move the cutoff tool insert below the stock diameter. 
 

Zr: Enter an absolute z coordinate (measured from the face of the part) to position 
the bar stop before the stock is pushed out. For short parts, this number can be set 
to zero. For longer parts, it is preferred to set this number equal to the length of the 
part so that the stock does not ram into the Bar Stop after the collet opens. 

Process Time: Enter a time estimation from when the Bar Stop moves from its 
safe index position at the beginning of the process to when the Bar Stop moves 
back to its safe index position at the end of the process. Time can either be set to 
seconds or minutes – see Preferences on how to set time units. 
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Pull with Side Gripper 
The Pull with Side Gripper Material Control Process allows the user to insert code for 
pulling the bar stock out to a certain Z-coordinate with a part gripper mounted in 
the turret which supports the part from the side. 

 
Tool Post: Choose the Tool Post on which the Bar Stop is mounted.  A bar stop can 
be mounted on any of the following tool posts: Turret, End Working, Back 
Working, Gang Slide #2, Turret #2 or Turret #3. 

Tool No.: Enter the tool station number at which the Side Gripper is mounted. The 
number must be a one or two digit integer. 

Tool Offset: Enter the offset number for the Side Gripper. The number must be a 
one or two digit integer. 
Xr: Enter an absolute x coordinate (measured from the center of the spindle) to 
position the Side Gripper above the bar stock before it moves to X0.0 to clamp the 
bar. This number is usually greater that the bar stock diameter.  

Zr: Enter an incremental z distance (measured from the final cutoff z coordinate) to 
position the Side Gripper above the bar stock before it moves in to clamp the bar. 
Pull Distance (Zp): Enter an incremental z distance from where the Side Gripper 
has clamped onto the bar to where the stock is to be pulled. 

Process Time: Enter time estimation from when the Side Gripper moves from its 
safe index position at the beginning of the process to when the Side Gripper moves 
back to its safe index position at the end of the process. Time can either be set to 
seconds or minutes – see the Preferences dialog on how to set time units. 
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Pull with Front Gripper 
The Pull with Front Gripper Material Control Process allows the user to insert code 
for pulling the bar stock out to a certain Z-coordinate with a part gripper mounted in 
the turret which supports the part from the front. 

 

Tool Post: Choose the Tool Post on which the Bar Stop is mounted.  A bar stop can 
be mounted on any of the following tool posts: Turret, End Working, Back Working, 
Gang Slide #2, Turret #2 or Turret #3. 

Tool No.: Enter the tool station number at which the Front Gripper is mounted. The 
number must be a one or two digit integer. 
Tool Offset: Enter the offset number for the Front Gripper. The number must be a 
one or two digit integer. 
Grip Coord (Zg): Enter an incremental z distance (measured from the face of the 
bar stock) to where the Front Gripper is to clamp on to the bar.  
Pull Distance (Zp): Enter an incremental z distance from where the Front Gripper 
has clamped onto the bar to where the stock is to be pulled. 
Process Time: Enter a time estimation from when the Front Gripper moves from its 
safe index position at the beginning of the process to when the Front Gripper moves 
back to its safe index position at the end of the process. Time can either be set to 
seconds or minutes – see Preferences on how to set time units. 
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Remove from Main Spindle 
The Remove from Main Spindle Material Control Process allows the user to insert 
code for removing a work piece from the main spindle using a part gripper mounted 
in the turret. 

 
Tool Post: Choose the Tool Post on which the Bar Stop is mounted.  A bar stop can 
be mounted on any of the following tool posts: Turret, End Working, Back Working, 
Gang Slide #2, Turret #2 or Turret #3. 

Tool No.: Enter the tool station number at which the Part Ejector is mounted. The 
number must be a one or two digit integer. 
Tool Offset: Enter the offset number for the Part Ejector. The number must be a 
one or two digit integer. 
Grip Coord (Zg): Enter an incremental z distance (measured from the face of the 
work piece on the Main Spindle) to where the Part Ejector is to clamp on to the work 
piece. 

Process Time: Enter a time estimation from when the Part Ejector moves from its 
safe index position at the beginning of the process to when the Part Ejector moves 
back to its safe index position after it has released the work piece.  Time can either 
be set to seconds or minutes – see Preferences on how to set time units. 
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Remove from Sub Spindle 
The Remove from Sub Spindle Material Control Process allows the user to insert 
code for removing a work piece from the sub spindle using a part gripper mounted 
in the turret.  

 
Tool Post: Choose the Tool Post on which the Bar Stop is mounted.  A bar stop can 
be mounted on any of the following tool posts: Turret, End Working, Back 
Working, Gang Slide #2, Turret #2 or Turret #3. 

Tool No.: Enter the tool station number at which the Part Ejector is mounted. The 
number must be a one or two digit integer. 
Tool Offset: Enter the offset number for the Part Ejector. The number must be a 
one or two digit integer. 
Grip Coord (Zg): Enter an incremental z distance (measured from the face of the 
work piece on the Sub Spindle) to where the Part Ejector is to clamp on to the work 
piece. 

Process Time: Enter a time estimation from when the Part Ejector moves from its 
safe index position at the beginning of the process to when the Part Ejector moves 
back to its safe index position after it has released the work piece. Time can either 
be set to seconds or minutes – see Preferences on how to set time units. 
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Pull with Sub Spindle 
The Pull with Sub Spindle Material Control Process allows the user to insert code for 
drawing bar stock out of the main spindle by clamping onto the part with the 
subspindle. 

 
Grip Coord (Zg): Enter an incremental z distance (measured from the face of the 
bar stock) to where the Sub Spindle is to clamp on to the bar.  
Pull Distance (Zp): Enter an incremental z distance from where the Sub Spindle 
has clamped onto the bar to where the stock is to be pulled. 

 Note: If pulling right before a cutoff/transfer process, the value entered 
should be the [part length + cutoff insert width + excess stock for facing on 
Sub Spindle (if necessary)] 

Process Time: Enter a time estimation from when the Sub Spindle moves from its 
home position at the beginning of the process to when the Sub Spindle moves back 
to its home position at the end of the process. Time can either be set to seconds or 
minutes – see Preferences on how to set time units. 
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Transfer from Main Spindle to Sub Spindle 
The Transfer from Main Spindle to Sub Spindle Material Control Process allows the 
user to insert code for transferring a work piece from the main to the sub spindle.  
This MCP should only be used when working with slug parts.   

 Note: Use the M1SF Mode for performing part transfers when working with 
Bar Stock. 

 
Grip Coord (Zg): Enter an incremental z distance (measured from the face of the 
work piece on the Main Spindle) to where the Sub Spindle is to clamp on to the 
work piece.  

Process Time: Enter a time estimation from when the Sub Spindle moves from its 
home position at the beginning of the process to when the Sub Spindle moves back 
to its home position at the end of the process. Time can either be set to seconds or 
minutes – see Preferences on how to set time units. 



 

Copyright @2014 Delcam Ltd  User Guide 3-1  

 

Chapter 3: PartMaker® SwissCAM™ 
Programming Tutorial 
Introduction 

This tutorial is designed to help you learn the steps to go through in using 
PartMaker SwissCAM to program Swiss-type lathe parts. The illustration on the 
following page represents a typical part that would be cut on a CNC Swiss-type 
lathe. 

This tutorial is presented to cover both inch and metric data entry.  Inch units are 
presented as the primary unit to enter and metric values are presented in 
parentheses. 

How you will create the Swiss tutorial part 
Here are the major steps you will follow to create the Swiss tutorial part: 

 

√ Start PartMaker 
√ View tool information for the part 
√ View cycle information for the part 
√ Select a material for the part 
√ Setup defaults for Swiss turning 
√ Define the stock boundaries for the Face Window 
√ Open a new Face Window 
√ Create geometry 
√ Perform turning operations on the main spindle 
√ Perform a cut-off operation 
√ Mill a hexagon on the main spindle 
√ Perform turning operations on the sub or pick-off spindle 
√ Define a tapped hole on the sub-spindle 
√ Create a Process Table 
√ Synchronize machining operations on the main and sub-spindles 
√ Simulate the Machining Process 
√ Generate an NC Program 
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The print below shows the part to be programmed in this tutorial. 

 
Inch Dimensions 
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Metric Dimensions 
 

 
 

When you complete this tutorial, you will have a part that looks like the picture 
below. 
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Getting Started 
The first part of any multi-axis turning programming exercise with PartMaker 
SwissCAM is to decide which machining functions will be used for each part face to 
be programmed.  

The machining functions used in this tutorial are as follows: 

Turn – Main Spindle:  
Use turning tools to perform a variety of Swiss-turning operations on the main 
spindle including facing, threading, front and back turning, and pick-off. 

Mill Polygon – Main Spindle: 
Use an end mill to create a set of hexagonal flats that begin 1.1” from the front of 
the part. 

Turn – Sub-Spindle: 
Use turning tools to perform a variety of lathe operations on the sub-spindle 
including facing and creating a tapped hole. 

Programming Swiss-type lathe operations with PartMaker is performed in a unique 
manner. No matter what the orientation of the part in the guide bushing or sub 
spindle, PartMaker programs all Swiss operations as if being machined in a 
conventional lathe, i.e. all programming is carried out from right to left. 

 Note: This tutorial covers both general PartMaker programming techniques 
as well as those unique to Swiss-turning.  For more information on using 
PartMaker to program CNC Milling, 2-axis turning and fixed-heastock turn-
mill applications, please see the manuals which correspond to those 
applications. 

Now you will look in detail at the steps necessary to program each of the 
components of the finished part. The components of the completed Swiss tutorial 
part can be found in the following directories: 

Completed Job File:    C:\PartMaker\PM-Swiss\swiss_inch.job 

Completed Tools File:    C: \PartMaker\PM-Swiss\swiss_inch.tdb 

Completed Cycles File:    C: \PartMaker\PM-Swiss\swiss_inch.cdb 

Throughout this tutorial menu selections are used.  Whenever a toolbar icon is 
available, the corresponding icon will be placed to the left of that instruction 
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Starting PartMaker SwissCAM 
All programming for Swiss parts done with PartMaker should be done in the 
SwissCAM application. To start the PartMaker SwissCAM application: 

1 Double click on the SwissCAM icon on your desktop or choose SwissCAM 
from the PartMaker Group accessed through Programs under the Windows 
Start button.   

2 An icon containing the PartMaker logo will appear for a few moments. You 
will then see the Setup definition dialog box shown below. Click the 
<Close> button.   

This dialog will be explained in greater depth starting on page 3-11. 
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View the Tool Information 
The tool library for the Swiss tutorial has already been created. To view the tools: 

3 Open the Tools file by choosing Open Tools File from the File menu. 

 
Click the swiss_inch.tdb file as shown above and click <Open>. 

4 Choose Tools from the ToolMinder menu. The first of the tools to be used 
in the Swiss tutorial is shown below: 

 

Note: The tools used in this chapter are for the tutorial only. As you begin to 
use PartMaker, you will create your own tools database. See Chapter 2 for 
more information on creating your own tools. 

5 Click the <Close> button to close the Tools dialog. 
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View the Cycles Information 
At this point, you should be familiar with the concept of Cycles in PartMaker. 
Cycles are sequences of repetitive operations used to machine a hole. The Cycles 
library for the Swiss tutorial has already been created.  

You can view the cycle that you will be using for this programming exercise. To do 
so:  

1 Open the Cycles file by choosing Open Cycles File from the File menu. Click 
the swiss_inch.cdb file in a similar manner as shown above and click 
<Open>. 

2 Choose Cycles from the ToolMinder menu. 

 
You will use the cycle titled Tap_Sub 0-80 to create a tapped hole on the 
sub-spindle.  

Note: The cycle shown here has been created in Chapter 2 in the section 
titled “Cycles Database”. If you are not familiar with the concept of creating 
and working with cycles, please refer to this section now. 

3 Click the <Close> button to close the Cycles dialog. 
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Select a Material for the Part 
The work piece in this exercise will be machined from Free Machining Stainless 
Steel, Wrought. To load this material: 

1 Choose Open Material File from the File menu. 

2 Choose st_fmstw.mdb as shown below and click <Open>. 

 
You have now loaded the tools, cycle, and material files that were previously 
developed for the Swiss tutorial. PartMaker has also provided a completed job file. 
At this point, do not open the job file. You will be guided through a step-by-step 
process to develop a job file for the tutorial.  



 

Copyright @2014 Delcam Ltd  User Guide 3-9  

 

Setting Defaults 
Before beginning the Swiss-tutorial, you will have to set certain turning defaults to 
facilitate the programming process: 

1 To access the Defaults dialog, select Defaults from the Job Optimizer 
menu.   

2 After doing so you will see the dialog below: 

 
Click the <Turning> button to access the Turning defaults dialog. 

3 After doing so, you will see the dialog below:  

 
4 In Swiss machining, in order to avoid pulling stock back into the guide 

bushing it may be desirable not to start and return to a Cutting Point when 
programming in PartMaker. When not using Cutting Point to control the 
start and end point of the tools, you will be able to control tool entry and exit 
by setting Leads In and Leads Out in the Profile Group Parameters dialog 
for each operation. 

5 Make sure to check the Diameter Programming box. Checking this box will 
allow you to define all geometry and feature programming in terms of 
diameter, alleviating the need to divide measurements in half when 
programming or drawing on the X-axis in Turning Face Windows. 

6 Set a default Line Length for your programmed Leads. For the swiss tutorial 
this value should be 0.02 (1.0).   

Note: Setting a generally applicable lead as a default will save you a great 
deal of time when programming Swiss parts because you will not have to 
reenter the same data from feature to feature. 

Note that the Positive Z Programming button is checked.  This tutorial is 
done with drawing and programming done in the positive Z.  Unlike 
conventional lathes, Swiss-type lathes are typically programmed into the 
positive Z direction.  Checking this box allows the programmer to enter data 
into the positive Z direction. 
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7 Set the Thread Height: There are two options available: 

%Pitch. The user will enter the height as a percent and resulting height 
will be Pitch * Thread Height / 100. 

Part Units. The user will enter the actual measured height of the thread 
in the current part units 

8 Access the Defaults dialog, select Defaults from the Job Optimizer menu. 

9 Click the <Milling> button to access the Milling defaults dialog. 

 

Set the Milling default as shown. 

 

Width of Cut. This parameter specifies whether the "Width of Cut" field in 
the Mill Profile Group Parameters Dialog will be defined in terms of 
percentage of tool diameter or an absolute value. 

Once you have looked at the tools and cycles databases, selected a material for the 
job, and setup the defaults for your job as shown above, you can move on to begin 
programming the Swiss tutorial part. 
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Turning on the Main Spindle 
This section of the tutorial will instruct you in the steps necessary to perform the 
turning operations on the main spindle. 

Setting Up the Face Window 
In this section, you will set up the Face Window for the turning operations on the 
main spindle. To do so: 

1 Choose Setup from the View menu to view the Setup dialog box (or click 
the Shortcut to the Setup icon in the upper right hand corner of the 
screen).  In this dialog, you will define the machining methods, part 
boundaries, and location of the stock with respect to the programming origin.  

The default Setup screen will appear as shown below. 

 
2 Rename the current Face Window by clicking on Front in the List of Face 

Windows: field and type Main Spindle – Turn in the Rename To: field 
and click the <Apply> button. 

3 Now enter the parameters listed below in the appropriate fields: 

Length (L) 1.2 (30.5)

OD 0.25 (6)

ID 0 (0)

Excess Stock (E) 0.01 (0.5)

Guide Bushing Length (l) 0.75 (20)

Guide Bushing Diameter (d) 0.75 (15)

Tool Change X (Xc) 2.8 (20)

Tool Change Z (Zc) 1.0 (10)
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When you are finished, your Setup dialog should appear as shown below:  

 

 Note:  In the dialog above, the Main Spindle radio button is checked.  This 
designates that this operation will be programmed on the main spindle of the 
machine. 

4 When you are satisfied that your Setup dialog appears as the one above, 
click the <Apply> button. This will apply the parameters to the current Face 
Window.  Click the <Close> button to close the Setup dialog. 

5 In the CAM Face Window, choose Show Axes from the View menu.  This 
will display the horizontal and vertical axis lines which will help you create 
the geometry in the next section of the tutorial.  

 Tip:  If at any time the menu commands become “grayed out” and 
unusable, this indicates that the Face Window you are working in has 
become inactive. This will be evident if the top bar of your window (where 
the name of the window is displayed) has become gray. To reactivate the 
window, click anywhere within your Face Window. 
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6 Choose Show Boundaries from the View menu.  Your screen should 
appear as shown below:  

 
You can get a better view of your part by zooming out.  The best way to do 
so is to perform a continuous Zoom Out by rolling the scroll wheel of your 
mouse downward or by pressing down the <F4> key or clicking it a number 
of times.  The zoomed out view appears as shown below: 
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Creating Geometry in CAD Mode 
In this section, you will create the geometry for the turning operations to be 
performed on the main spindle. 

Method 1: Import a .DXF file 
If you do not want to create the geometry for the Swiss tutorial in PartMaker, a 
.DXF file of the necessary geometry has already been created. To import this .DXF 
file: 

1 Choose Import  DXF File from the File menu. 

2 Select swiss_inch.dxf from from the pm-swiss directory as shown below: 

 
If you have chosen to import a .DXF file, proceed to page 3-18 at this time to 
begin the programming exercise. 

Method 2: Create Geometry in PartMaker 
To create the geometry in PartMaker CAD: 

1 Click on the CAD/CAM switch in the lower left-hand corner of the window. 
The icon will change its appearance from a drill bit to a pencil. 

2 Select the Connected Lines Icon from the drawing icons on left side of the 
Face Window. Here, you will draw the part in the print on the second page 
of this chapter by plotting ZX coordinates, using the ZX Snap Mode from 
the Snap Modes icon bar at the top of the screen. 

After selecting the ZX Snap Mode two data entry fields will appear in the 
lower left hand corner of the Face Window.   

 Note:  When plotting coordinates in PartMaker CAD, you do not need to 
reenter a coordinate if it is the same as the last one entered.  You can simply 
leave the space blank and PartMaker will default to the last coordinate 
entered.  You can move between data entry fields by pressing the <Tab> 
button or using your mouse. 
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Now enter the ZX coordinates as shown below, pressing <Enter> after 
each: 

0, 0 
<default>, 0.05 (1.5) 
0.232 (5.9), <default> 
<default>, 0.0874 (2.5) 
0.76 (19.0), <default> 
<default>, 0.23 (6.0) 
1 (25.5), <default> 
<default>, 0.208 (5.0) 
1.1 (28.0), <default> 
<default>, 0.146 (3.75) 
1.2 (30.5), <default> 

After entering these coordinates, you should have a drawing which appears 
as the profile below: 

 
3 You will now place a chamfer on the front of the part.  To do so, select the 

Chamfer icon.  A field will then open up at the bottom of the window 
prompting you to enter the size of the chamfer.  Enter a value of 0.005 (.1) 
and press <Enter>. 

Note: If your geometry is too far over to the right to see the front of the part 
where the chamfer needs to be placed, use PartMaker’s panning to the left 
by holding down <Ctrl> button and tapping the <Left Arrow Key> at the 
same time. Panning can also be achieved with your mouse by pressing the 
scroll wheel and moving the mouse. Panning is a very useful feature for 
Swiss parts which are very long but have small outside diameters (OD). 

To place the chamfer, position your cursor on the inside of the intersection of 
the lines at the front of the part as shown below: 

 
With your cursor in position, click the left mouse button and a chamfer will 
inserted as shown below: 

 
4 You will now place a second chamfer on the part, at a distance 0.232 (5.9) 

inches from the front of the part.  This time, however, the intersection of the 
lines does not afford the room to use the Chamfer icon, so begin by 
selecting the Line on an Angle icon and selecting the End of Line snap 
mode. 

When doing so, you will be prompted to Select end point of line or arc.  
Drag your cursor into place as shown below and click the left mouse button. 

 
You will now be prompted to enter an angle for this line.  At the prompt enter 
a value of 135 and press <Enter>. 
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Move your cursor so the arrow is on the line as shown below and click the 
left mouse button. 

 
Having done so, you will now have a drawing which appears as shown below. 

 
Now select the Remove icon and click the scissors on lines 1 and 2 in the 
picture below. 

 
After having done so, your geometry will appear as shown below: 

 
5 You will now employ the same technique to create the 120 degree line 

beginning 0.76 (19.0) inches from the front of the part. Again, select the 
Line on an Angle icon and select the End of Line Snap Mode Icon. 

When doing so, you will be prompted to Select end point of line or arc.  
Drag your cursor into place as shown below and click the left mouse button. 

 
You will now be prompted to enter an angle for this line.  At the prompt enter 
a value of 120 and press <Enter>. 

Move your cursor so the arrow is on the line as shown below and click the 
left mouse button. 

 
Having done so, you will now have a drawing which appears as shown below. 

 
Now select the Remove icon and click the scissors on lines 1 and 2 as 
shown. 

 
After having done so, your picture will appear like the one below. 
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6 Next, you will remove the geometry from the face of the part.  To do so 
select the Remove icon and click the mouse with the cursor on point 1 
shown below. 

 
7 Once you have removed the excess geometry from the face of the part, 

select the geometry you have created by clicking on the selection icon and 
choosing Select All from the Edit menu. 

 Note: In PartMaker selection always preceeds action.  Before you can 
manipulate an entity, be it a piece of geometry or a part feature, you must 
select it.  Selection must always be carried out in selection mode.  To be in 
selection mode, you must have the Selection icon chosen. 

8 You will now mirror the selected geometry by choosing Mirror from the 
Transfrom sub menu under the Edit menu.  Complete the Mirror dialog as 
shown below:  

 

 Note: When performing mirroring operations in PartMaker, always enter an 
Angle value of 0 when mirroring with respect to the horizontal axis and an 
Angle value of 90 when mirroring with respect to the vertical axis. 

When you have completed the dialog as shown above, click the <OK> 
button.  Click anywhere to deselect the geometry. The completed drawing 
should appear as below: 

 



 

3-18 PartMaker  Copyright @2014 Delcam Ltd 

 

Defining the Profile for Face Turning 
The first turning operation to be performed on the Main Spindle is to face the stock. 

1 Click the CAD/CAM switch to go to CAM mode. 

2 Click anywhere in the Face Window to make it active. 

3 Choose the red square in the Color Bar.   

4 Choose New Profile Group from the Part Features menu to display the 
Profile Group Parameters dialog.  When selected, you should see a dialog 
which appears as the one below:   

 
5 From the Strategy menu, select Contouring (it should be chosen by 

default). 

6 From the Tool Location menu, select Face. 

7 Uncheck the box called Roughing Tool ID so Finishing Tool ID is checked. 

8 Click the Select Tools button and allow PartMaker to select the appropriate 
tool. PartMaker will present you a choice of two tools, one is mounted on the 
main spindle and the other is on the sub spindle as shown below:  

 
In this case you are doing main spindle work, so choose T001 and click 
<OK>.  You are choosing T001 because this tool has been setup up for work 
on the main spindle and the Tools Database has been designated as Gang 
Tool. 
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9 In the field called Group Name, enter Face Off. Your dialog should now 
appear as shown below: 

 
At this point, do not close the dialog box shown above. Proceed for instructions 
on how to complete setting up this profile group. 

When programming parts in PartMaker, you have the ability to control how far 
and at what angle a tool feeds on and off of a part. These values are controlled 
via Leads. The Lead In is the distance from the part the tool will begin feeding 
before cutting. Likewise, the Lead Out is the distance that the tool will feed 
away from the material before tool change or rapidding to its next position. 

Note: If you are using the same Leads In and Leads Out in most of your 
operations, you can set them as default values in the Defaults for Turning 
dialog accessed under the Job Optimizer menu.  Setting your default Leads 
In and Out values will save time when programming in PartMaker. 

10 The Leads In and Out dialog box combine the settings for controlling the 
movement of the tool as it approaches (Leads In) and leaves (Leads Out) the 
stock. 

11 Set the Leads In values for the operation.  Now set the Leads Out values 
for the operation. 

12 You can also set the values from one Leads to the other by selecting the 
Copy Leads button.  
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Press <OK> to return to the Profile Group Parameters dialog. 

Note:  The Lead angle is always set normal to the path of the tool by 
PartMaker.  Above, setting the Leads Out angle will allow the tool to 
retract in a manner perpendicular to the part.  For example, if turning a 45 
degree chamfer, a 0 degree lead angle would allow the tool to exit the stock 
on a 45 degree angle. 

Click the <Close> button to close the Profile Group Parameters dialog box. 

Notice, that by choosing a Tool Location of Face, PartMaker automatically 
applied your facing tool path to the part geometry. 

Your completed profile should appear as below: 

 
13 Click the Selection icon to bring yourself to a home or neutral position. 

Before moving on, save your work! Do so by selecting Save from the File menu 
or using the shortcut key <Ctrl + S>. Give your job file a name you will 
remember. 

Here, we have chosen to call the job file “tutorial”, as shown below: 
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Tool Path Verification – Fixed Headstock 
Once a tool path is defined, you can verify its shape to gauge the accuracy of the 
cut you have defined. In PartMaker SwissCAM, for programming being done on the 
Main Spindle in a Face Window of Machining Function Turn, you have the option 
of performing two types of tool path verification: 

 Fixed headstock simulation  

Or 

 Sliding headstock simulation (Stock Motion Simulation) 

Each type of verification has its relative merits. Fixed headstock simulation is 
excellent when focusing on the cut being made by a particular tool path. The sliding 
headstock simulation, referred to as Stock Motion Simulation, is excellent for 
seeing how your part will move through the guide bushing during machining and to 
assure that the “Tool Shifts” have been set properly.   

When performing, the Stock Motion Simulation, a guide bushing of the OD and 
Length described in the Setup dialog will be shown.  

For the facing operation, you will use the fixed-head stock simulation. To do so: 

1 Select Verify Work Group Tool Path from the Part Features menu to 
check your work. You will be prompted with the Tool Verifications Options 
dialog as shown below: 

 
Check the Solid radio button and enter a delay between 0 and 9, zero being 
the fastest and nine the slowest, relative to the processor speed of your 
computer.  

Click <OK>. You should see your tool path verified. 

2 Once you are satisfied with your tool path, choose Hide Work Group Tool 
Path from the Part Features menu. 

Note: Whenever you verify a tool path (or every tool path) you MUST choose 
Hide Every Tool Path before moving on and continuing to work in 
PartMaker.  Not doing so could hamper performance of your system.  In 
order to stop verification before it is complete, hit the <Esc> key. 
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Defining the Profile for OD Turning 
The next operation to be performed will be OD turning, starting from the bottom of 
the chamfer on the face of the part. 

1 Click the yellow square in the Color Bar   

2 Choose New Profile Group from the Part Features menu to display the 
Profile Group Parameters dialog. 

3 From the Strategy menu, select Contouring (it should be chosen by 
default). 

4 From the Tool Location menu, select Out (it should be chosen by default). 

5 From the Tool Orientation menu, select Right (it should be chosen by 
default). 

6 Click the Select Tools button and allow PartMaker to select the appropriate 
tool. Again, PartMaker will present you a choice of two tools, one is 
mounted on the main spindle and the other is on the sub spindle. In this 
case you are doing main spindle work, so choose T001 and click <OK> 

7 Uncheck Roughing Tool ID so Finishing Tool ID is checked 

8 In the field called Group Name, type Front Turn. Your dialog should now 
appear as the one below.  
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9 Set the Lead Out for the Front Turn operation. To do so, click the Leads 
button to access the Leads Out dialog. Complete the dialog as shown below: 

 
Press <OK> to return to the Profile Group Parameters dialog. 

10 Click the <Close> button to return to the Face Window. 

Now that you have defined the cycle to be used, you must tell PartMaker the 
location of the tool path. 

Before you move on to assign the profile to the geometry, there are a few quick 
changes you need to make to your geometry to facilitate this process. Here you 
will insert two vertical lines, the first you will use as a guide for the threading 
operation defined in the next section and the second as a guide for the Front 
Turn profile group defined above. 

 

1 Click the CAD/CAM switch to return to CAD mode. 

2 In CAD mode, select the Line Parallel to the Vertical Axis icon. You will be 
prompted to Enter a Signed Distance from the Vertical Axis.  At the 
prompt enter a value of 0.45 ( 11.5) and press <Enter>.  Your picture will 
appear as the one shown below: 

 
3 You will now create a second vertical line. To do so, select the Parallel 

Element icon. You will be prompted to Type unsigned distance. In the 
field, enter a value of 0.03 (.7) inches and press <Enter>. 

4 Drag your cursor to the left of the previously created vertical line you created 
and click the left mouse button to insert the line. After doing so, your picture 
should appear as shown below. 
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5 You now must remove some excess geometry. To do so, select the Remove 
icon. Dragging your cursor from points 1 to 4, click your mouse at each 
point. 

 
Your completed geometry should appear as below: 

 
 

You can now assign the Front Turn cycle to the geometry you created. 

1 Return to the CAM mode by clicking on the CAD/CAM switch 

2 From the left-hand side of the screen select the Define Profile icon. 

3 From the top of the screen, select the End of an Element snap mode. To 
define the rest of the Front Turn path, click your left mouse on positions 1 
through 4 in the diagram below: 

 
Note: You may find this exercise easier by zooming in on the area you are 
working on (Zoom In from the View menu) and panning across to each 
point (<Ctrl> + Right Arrow key). 

4 To complete the tool path, with the Define Profile icon still selected, choose 
the Closest Intersection snap mode and click your left mouse button on 
position 5 in the diagram below: 

 
When completed, you will have the tool path shown below: 

 
5 Click the Selection icon to bring yourself to a home or neutral position 
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Tool Path Verification – Stock Motion Simulation (Sliding Headstock) 
With both the Facing and Front Turning toolpaths defined, you can now perform 
stock motion simulation when verifying the motion of the tool. Stock Motion 
Simulation allows you to see the headstock moving through the guide bushing while 
cutting.  

 Note: Before performing Stock Motion Simulation it is generally advisable 
to move the part to the left on the screen using the panning function, i.e. 
hold down the <Ctrl> key and Left Arrow key at the same time or hold 
down the scroll wheel of your mouse. It may also be advisable to decrease 
the size of the part on screen by either choosing Zoom Out from the View 
menu or by depressing the <F4> key to continuously zoom out. 

To do so: 

1 Select Verify Every Tool Path from the Part Features menu to check your 
work.  

2 You will be prompted with the Tool Path Verification Options dialog. 
Check the Solid button and the box marked Stock Motion Simulation as 
shown below. Also enter the desired Verification Delay. 

 

When you are satisfied your dialog appears as the one above, click <OK>. 
You should see the part cutting with stock sliding through the guide bushing 
as shown on the following page. 

 
3 Once complete, choose Hide Every Tool Path from the Part Features 

menu to hide the verification shown above. 
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Defining the Profile for OD Threading 
In this operation you will create the OD thread on the main spindle. In PartMaker, 
threading operations are always programmed based on the crest diameter of the 
thread (i.e. major diameter on the OD, minor diameter on the ID). 

1 In CAM mode, select green from the color bar.  

2 Select New Profile Group from the Part Features menu. 

3 From the Strategy menu, select Threading. 

4 From the Tool Location menu, select Out. 

5 Look at the graphic. Notice that there are two options: 

 No Chamfer would be used where there is a relief groove at the end of 
the thread. 

 Chamfer on Exit would be used if there were no relief groove at the end 
of the thread. 

Take a minute and look closely at both graphics and the parameters for each. 
When you are finished, leave this setting at Chamfer on Exit. 

6 Type Threading next to Group Name. 

7 Note the default First Infeed is 0.02. Change this value to 0.001 (.1). 

8 Note the default pitch is 0.125 inches. The desired pitch for this operation is 
56 threads/inch. Change the Pitch to 1/56 inches (.35) (PartMaker will do 
the math for you!) 

9 Enter a Chamfer Length (L2) equal to one pitch, i.e. enter 1/56 (.35) in 
this field as well. 

10 After making these changes, click the <Select Tools> button and allow 
PartMaker to select the appropriate tool. In this case, T007. The completed 
Profile Group Parameters dialog should appear as shown on the following 
page.  

 
11 Close the Profile Group Parameters dialog for Threading by clicking the 

<Close> button. 
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You can now assign the Threading cycle to the geometry you created. 

1 From the left-hand side of the screen select the Define Profile icon. 

2 From the top of the screen, select the Closest Intersection snap mode 
icon. To create the threading path, click your left mouse button on cursor 
positions 1 and 2 in the diagram below: 

 

 Note: To better focus on the Work Group you are currently working with, 
you can select Show Work Group Only from the View menu.  This has 
been done above to isolate the area along which you will thread.  You can 
see all the work groups again by selecting Show All.  This programming 
methodology will be employed throughout this tutorial. 
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Tool Path Verification – Stock Motion Simulation (Sliding Headstock) 
Stock motion simulation tool path verification can be especially helpful when 
verifying threading operations because threads typically require a number of passes 
to be made, thus requiring the stock to move in and out of the guide bushing on 
each subsequent pass. Using stock motion simulation for threading is ideal for 
verifying that your part does not retract past the length of the guide bushing and 
result in error.   

In addition, threading tools require a ‘tool shift’ to be set when creating the tool 
(see Chapter 2, Tools for Turning). If your ‘tool shift’ has not been properly set, you 
will see the tool overcutting into the guide bushing.  

To perform this verification: 

1 Select Verify Every Tool Path from the Part Features menu to check your 
work.  

2 You will be prompted with the Tool Path Verification Options dialog. 
Check the Solid button and the box marked Stock Motion Simulation as 
shown below. Also enter the desired Verification Delay. 

 
When you are satisfied your dialog appears as the one above, click <OK>. 
You should see the part cutting with stock sliding as shown here: 

 
3 Choose Hide Every Tool Path from the Part Features menu to hide the 

verification shown above.  

Note: In the stock motion simulation you performed here, notice how the 
‘tool shift’ has been set properly, avoiding collision. 
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Defining the Profile for Finish Turning 
In this operation you will perform OD finish turning operations on the main spindle. 

1 In CAM mode, select magenta from the color bar.  

2 Select New Profile Group from the Part Features menu. 

3 From the Strategy menu, select Contouring (it should be chosen by 
default). 

4 From the Tool Location menu, select Out (it should be chosen by default). 

5 From the Tool Orientation menu, select Right (it should be chosen by 
default). 

6 Type Finish Turn next to Group Name. 

7 Uncheck Roughing so Finishing is checked. 

8 After you have made these changes, click the <Select Tools> button and 
allow PartMaker to select the appropriate tool. As before PartMaker gives 
you a choice of two tools. Again, choose T001. The completed Profile 
Group Parameters dialog should appear as shown below: 

 
9 Set the Leads for the Finish Turn by clicking the Leads button to access 

the Leads In and Out dialog. Complete the dialog as shown below: 

 
Press <OK> to return to the Profile Group Parameters dialog. 
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10 Close the Profile Group Parameters dialog for Finish Turning by clicking 
the <Close> button. 

Before you move on to assign the Finish Turn cycle to the geometry, there are a 
few quick changes you will need to make to the geometry to facilitate this process. 
Here you will insert a line at the back of the part, the top of which you will snap to. 

11 Click the CAD/CAM switch to return to CAD mode. 

12 In CAD mode, from left hand side of the screen click the Line Thru Two 
Points icon. From the snap modes at the top of the screen, select the ZX 
snap mode. 

Now enter the ZX coordinates as shown below, pressing <Enter> after 
each.: 

1.2 (30.5), 0.23 (6.0) 

<default>, 0.02 (0.1) 

Your picture should appear as shown below: 

 
You can now assign the Finish Turn cycle to the geometry you created. 

1 Click the CAD/CAM switch to return to CAM mode 

2 From the left-hand side of the screen select the Define Profile icon. 

3 From the top of the screen, select the Closest Intersection snap mode. To 
begin defining the path for Finish Turn, click your left mouse button on 
position 1 in the diagram below: 

 
4 Now switch to the End of Line snap mode and click your left mouse on 

positions 2 through 4 as shown in the diagram below: 

 
5 Click the Selection icon to bring yourself to a home or neutral position 

Before moving on, remember to save your work! Do so by selecting Save from the 
File menu or using the shortcut key <Ctrl + S>.  

Tool Path Verification 
Use either method described above to make sure the tool paths you have defined 
are correct. 
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Defining the Profile for Back Turning 
In this operation you will perform OD back turning operations on the main spindle 
with a grooving tool. 

1 In CAM mode, select cyan from the color bar.  

2 Select New Profile Group from the Part Features menu. 

3 From the Strategy menu, select Contouring (it should be chosen by 
default). 

4 From the Tool Location menu, select Out (it should be chosen by default). 

5 From the Tool Orientation menu, select Left. 

6 Type Back Turning next in the Group Name field. 

7 Uncheck Roughing Tool ID. 

8 Because you need to use a grooving tool to perform the Back Turning 
operations, you must press the <Select Tools> button and change the Tool 
Type to Groove.  You will then be able to select tool T002 for Back Turning. 
Your completed Profile Group Parameters dialog should appear as the one 
below: 
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9 Set the Leads Out for the Back Turning operation. To do so, click the 
Leads button to access the dialog. Complete the dialog as shown below.  

 
Press <OK> to return to the Profile Group Parameters dialog. 

10 Close the Profile Group Parameters dialog for Back Turning by clicking 
the <Close> button. 

You can now assign the Back Turning cycle to the geometry you created. 

1 From the left-hand side of the screen select the Define Profile icon. 

2 From the top of the screen, select the End of an Element snap mode. To 
define the rest of the Back Turning path, click your left mouse on positions 
1 through 5 in the diagram below: 

 
3 Click the Selection icon to bring yourself to a home or neutral position. 

Tool Path Verification 
Use either method described above to make sure the tool paths you have defined 
are correct. 
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Defining the Profile for Cut-Off 
In this operation you will perform a cut-off operation on the main spindle with a 
grooving tool. 

1 In CAM mode, select blue from the color bar.   

2 Select New Profile Group from the Part Features menu. 

3 From the Strategy menu, select Cut-Off. 

4 Click Select Tools. Choose the tool titled Cut-Off when the dialog below 
appears and click Select. 

 
5 Enter a Cut-Off Z-Distance (D) of 1.21 (30.6). All other numerical values 

can remain at their default values. 

6 Type Cut Off in the Group Name field. 

Your completed dialog should appear as the one below: 

 
Press <OK> to return to the Profile Group Parameters dialog. 

7 Close the Profile Group Parameters dialog for Cut-Off by clicking the 
<Close> button. 

Notice when using the cut-off cycle, PartMaker automatically creates the 
tool path for you. 

Note: When performing cut-off operations, you should define the tool path to 
cut past the end of the part in Z if you want leave stock for facing on the 
sub-spindle. You should set the programmed Z-distance past the end of part 
equal to the amount of material you want to face off (Excess Stock) when 
working on the sub-spindle.   
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Define the location of the tool path to be at the exact end of the part if you 
do not want to perform a facing operation on the sub-spindle. 

Your completed profile should appear as below: 

 
Before moving on, remember to save your work! Do so by selecting Save from the 
File menu or by using the shortcut key <Ctrl + S>. Give your job file a name you 
will remember. 

You have now completed the turning work on the main spindle. Now that all the 
programming in the Main Spindle - Turn Face Window is complete, take a 
moment to see exactly what you have programmed. 

1 Choose Verify Every Tool Path from the Part Features menu. In the 
Verification Options dialog, choose Solid and mark the Stock Motion 
Simulation box as shown below:  

 
PartMaker will show you exactly what you have programmed in a graphical 
manner as shown below: 

 

 Note:  Stock Motion Simulation visually displays the Tool Shift set in the Tool 
Properties dialog, showing how much the stock must be pushed from the 
guide bushing before cutting to meet the programmable point of the tool. 

 Tip: To best see the whole part during stock motion simulation, pan the part 
to the left of the screen (<Ctrl> + Left Arrow) and Zoom Out from the part 
(you can do continuous Zooming by holding down the F4 key. 

2 When you are satisfied your screen appears as the one above, choose Hide 
Every Tool Path from the Part Features menu. 

You have now completed the turning operations on the main spindle for the Swiss 
tutorial part. Before moving on, remember to save your work! Do so by selecting 
Save from the File menu or by using the shortcut key <Ctrl + S>. 
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Milling the Hex on the Main Spindle 
This section of the tutorial will instruct you in the steps necessary to mill the 
hexagon on the main spindle. 

Setting Up the Face Window 
In this section, you will set up the Face Window needed to mill the hexagon on the 
main spindle. To do so: 

1 Choose Setup from the View menu to view the Setup dialog box or use the 
Shortcut to the Setup icon located above the profile icons on the left-hand 
side of the Face Window.  

2 Click the <New> button to create a new Face Window. 

3 From the Machining Function drop down menu select Mill Polygon. 

4 Type Mill-Hex in the Rename To: field and click <Apply>. 

When you are finished, your Setup dialog should appear as shown below:  

 
Note:  In the dialog above, the Main Spindle box is checked.  This 
designates that this operation will be programmed on the main spindle of the 
machine. 

5 When you are satisfied that your Setup dialog appears as the one above, 
click the <Apply> button. This will apply the parameters to the current Face 
Window.  Click the <Close> button to close the Setup dialog. 
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6 To switch to the Mill Hex Face Window, choose Mill Hex from the Window 
menu. 

 
7 Choose Show Axes from the View menu.  This will display the horizontal 

and vertical axes lines which will help you create the geometry in the next 
section of the tutorial. 

8 Choose Show Boundaries from the View menu.  Your screen should 
appear as shown below:  

 

 
Note:  If the image in the Face Window appears distorted or oblong, choose 
Full View from the View menu to refresh the screen for it to appear as 
shown above. 
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Creating Geometry in CAD Mode 
In this section, you will create the geometry for the hexagonal profile to be milled. 

1 Click on the CAD/CAM switch to return to the CAD mode.  

2 Select the Polygon icon.  

3 After doing so, a dialog will open prompting you to enter a distance and a 
number of sides. Enter a distance of .126 (3.0) and 6 for the number of 
sides. Click the  <OK> button.  

 

Define Polygon By: 

Flat to Flat (D). Allows you to specify the 
distance between parallel sides. 
Center to Flat (d). Allows you to specify the 
distance between center and a side. 
Outer Circle Radius(R). Allows you to specify 
the radius of outer circle. 
Side Length (L). Allows you to specify the side 
length. 
Number of Sides (n). Specifies the number of 
sides in polygon. 
Orientation Angle (A).  Specifies the polygon 
angle with horizontal axis. 

Center: 

z: Specifies the horizontal coordinate of the 
polygon center. 

x: Specifies the vertical coordinate of the 
polygon center. 

Your screen should appear as shown below: 

 
Next, you will proceed to machine this hexagon in CAM mode. 
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Creating the Hexagonal Profile  
In this section, you will define the profile to machine the hexagonal flats on the 
work piece. 

1 Click the CAD/CAM switch such that it appears as a drill bit and turning tool. 
This will put you back into the CAM mode. 

2 In CAM mode, select red from the color bar.   

3 Select New Profile Group from the Part Features menu.  

1 In the Group Name box type Mill Hexagon. 

4 Choose Right Tool Edge (P3) in the To: drop down menu to define the 
Distance From Part Face from which the hex will be milled 

5 Enter 1.1 (28.0) for P3, representing the distance from the part face 
machining will occur. 

6 Enter 0.156 (3.0) for Tool Diameter. 

7 Click on the <Select Tools> button. An end mill icon will appear to the right 
of the Tool ID box. The completed Profile Group Parameters dialog 
should appear as shown below: 

 
Now that you have completed setting up the profile group, take a moment to study 
this dialog, as it is unique to other PartMaker Milling Profile Group Parameters 
dialogs you have encountered. 

Understand the following unique parameters: 

Distance From Part Face  

To: Left Tool Edge (P1): Specifies the distance from the face of the part to 
the left edge of the tool.  

To: Tool Center (P2): Specifies the distance from the face of the part to 
tool center.  

To: Right Tool Edge (P3): Specifies the distance from the face of the part 
to the right edge of the tool.  

X_Surf:  The distance from the center of the cylinder to the edge of the 
diameter.  PartMaker calculates this parameter automatically based on the value 
you enter for the OD of the stock in the Setup dialog.  For the Swiss tutorial 
workpiece this is 0.25/2 or .125 (3.5). 
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X_Rapid (R): Specifies the distance between the bottom tip of the tool and the 
part surface when tool performs Rapid Moves.  

Clearance (C): Specifies the distance between the bottom tip of the tool and 
the part surface when a tool starts feeding into the part.  

Tool Diam (d): Specifies diameters of tool.  

Click the <Close> button to close the Profile Group Parameters dialog box. 

 

The next step is to develop the tool path.  To do so: 

1 Select the Chain Geometry icon.   

2 Move your cursor above the top line of the hex and slightly to the left of the 
vertical axis line as indicated by the words Click Here.  

Click your mouse button and the screen should appear as shown below: 

 
The arrows display the direction of the tool path.  The flats will be machined 
in this direction.  If you wish to machine the flats in the opposite direction, 
using the Selection icon, click anywhere on the tool path to select it.  
Choose Reverse from the Edit menu and the arrows displayed on the tool 
path will change direction.  

You have now completed all the operations on the main spindle for the Swiss 
tutorial part. Before moving on, remember to save your work! Do so by selecting 
Save from the File menu or by using the shortcut key <Ctrl + S>. 
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Turning on the Sub-Spindle 
This section of the tutorial will instruct you in the steps necessary to perform a 
variety of turning operations on the sub-spindle. 

Setting Up the Face Window 
In this section, you will set up the Face Window needed to perform turning 
operations on the sub-spindle. To do so: 

1 Choose Setup from the View menu to view the Setup dialog box or use the 
Shortcut to Setup icon located above the profile icons on the left-hand side 
of the Face Window. 

2 Click the <New> button to create a new Face Window. 

3 From the Machining Function drop down menu select Turn. 

4 Check the radio button marked Sub Spindle.  Notice how there is no guide 
bushing representation on the sub-spindle, as the stock is fixed when being 
held in the sub-spindle collet. 

5 Type Sub Spindle - Turn in the Rename To: field and press <Enter>. 

When you are finished, your Setup dialog should appear as shown below:  

 
Note:  In the dialog above, the Sub Spindle radio button must be checked.  
This designates that this operation will be programmed on the sub-spindle of 
the machine. 

6 When you are satisfied that your Setup dialog appears as the one above, 
click the <Apply> button. This will apply the parameters to the current Face 
Window.  Click the <Close> button to close the Setup dialog. 
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7 To switch to the Sub Spindle - Turn Face Window, choose Sub Spindle - Turn 
from the Window menu. 

 
8 Choose Show Axes from the View menu.  This will display the horizontal 

and vertical axes lines which will help you create the geometry in the next 
section of the tutorial. 

9 Choose Show Boundaries from the View menu. 
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Creating Geometry in the CAD Mode 
To quickly define geometry for the turning operations to be performed on the sub 
spindle, you can use the geometry already created in the Main Spindle - Turn 
Face Window. Remember, in PartMaker, all programming is done as if being 
performed on a conventional lathe, i.e. all programming is carried out from right to 
left. 

As a result, you can copy the geometry previously created in the Main Spindle - 
Turn window and mirror it to create the desired geometry in the Sub Spindle – 
Turn window.  

1 Choose Main Spindle - Turn from the Window menu to return to the first 
window your created as shown below: 

 
2 In the Main Spindle - Turn Face Window, to copy geometry, click on the 

CAD/CAM switch to return to CAD mode.  The icon will change its 
appearance from a drill bit/turning tool to a pencil.  

3 With the Selection icon highlighted, select the geometry you have created 
by choosing Select All from the Edit menu.  

4 With the geometry selected (it should be highlighted), choose Copy from the 
Edit menu. 

5 Return to the Sub Spindle - Turn Face Window by choosing Sub Spindle - 
Turn from the Window menu. 

6 In the Sub Spindle - Turn Face Window, choose Paste from the Edit menu. 

 

Remembering the PartMaker convention that all programming is carried out from 
right to left, as if on a conventional lathe, you will now mirror the geometry you just 
pasted. To do so: 

1 Make sure you are in CAD mode in the Sub Spindle - Turn Face Window. 

2 With the Selection icon chosen, again, choose Select All from the Edit 
menu to select the geometry if it is not currently selected.  
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With the geometry selected, choose Mirror from the Transform sub menu 
from the Edit menu. To flip the part in order to perform operations on the 
back, you will need to mirror with respect to the middle of the part. To do so, 
complete the Mirror dialog as shown below:  

 
The completed (mirrored) part should appear as shown below: 

 
3 Click the Selection icon to deselect your geometry. 

You will now need to make two modifications before you can complete machining on 
the sub-spindle. 

1 Choose the Remove icon to remove the excess geometry by positioning 
your cursor and clicking the mouse as shown below:  

 
2 You will now insert a chamfer on the back of the part. To do so, select the 

Chamfer icon.  After doing so, a field will open up at the bottom of the 
window prompting you to enter the size of the chamfer.  Enter a value of 
0.005 (.125) and press <Enter>. 

To place the chamfer drag your cursor such that the arrow is on the inside of 
the intersection of the lines at the front of the part as shown below and click 
your left mouse button: 

 
The completed geometry should now appear as shown below: 

 



 

3-44 PartMaker  Copyright @2014 Delcam Ltd 

 

Defining the Profile for Face Turning (Sub-Spindle) 
The first operation is to face the stock to the desired finished length of 1.2 inches: 

1 Click the CAD/CAM switch to go to CAM mode.  

2 Choose the red square from the color bar    

3 Choose New Profile Group from the Part Features menu to display the 
Profile Parameters dialog. 

4 From the Strategy menu, select Contouring. 

5 From the Tool Location menu, select Face 

6 Uncheck Roughing Tool ID. 

7 Click the Select Tools button and allow PartMaker to select the appropriate 
tool.  PartMaker will again present you with two choices.  This time choose 
T003, which is mounted for work on the sub-spindle as shown below and 
click <Select> 

 
8 In the field called Group Name, type Face Off - Sub. Your dialog should 

now appear as the one below. 
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9  Set the Lead Out for the Face Off-Sub operation. To do so, click the 
Leads button to access the dialog. Complete the dialog as shown below:  

 
Press <OK> to return to the Profile Group Parameters dialog. 

10 Click the <Close> button to return to the Face Window. 

Notice, that by choosing a Tool Location of Face, PartMaker automatically 
applied your facing tool path to the part geometry. 

Your completed profile should appear as below: 

 
Before moving on, remember to save your work! Do so by selecting Save from the 
File menu or using the shortcut key <Ctrl + S>. 
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Defining the Profile for OD Turning (Sub Spindle) 
The next operation you will perform on the sub spindle is to turn the chamfer you 
just created. In order to do so, you can just duplicate the group you just created. To 
do so: 

1 With the Face Off-Sub group symbol highlighted, choose Duplicate Group 
from the Part Features menu. 

2 Replace Face Off – Sub in the Group Name: with Turn Out - Sub and click the 
<Apply> button. 

3 Change Tool Location to Out 

4 Change Tool Orientation to Right 

The completed dialog should now appear as the one below. 

 
5 Click <Apply> and then the <Close> button to return to the Face 

Window. 

6 Change the color of the group symbol to blue by choosing blue from the color 
bar and clicking blue when it appears in the Sample Color box. 

 
You can now assign the Turn Out - Sub cycle to the geometry you created. 

1 From the left-hand side of the screen select the Define Profile Icon.  

2 From the top of the screen, select the End of an Element Snap Mode icon. 
To define the rest of the face path, click your left mouse button with your 
cursor in positions 1 and 2 as shown below. (You may want to zoom in on 
this area when doing so. To do so, choose Zoom In from the View menu 
and drag a box around the chamfer.) 
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Defining the Tapped Hole on the Sub-Spindle 
Here you will define the cycle and size of the tapped hole to be machined on the 
subspindle. To do so: 

1 Click the green square in the Color Bar   

2 Choose New Hole Group from the Part Features menu to display the Hole 
Group Parameters dialog. 

 
3 Uncheck the Through Hole box. 

4 In the Major Cycle Operation drop down menu select Tap. 

5 Enter a Diameter of 0.06 (1.6). 

6 Other parameters should be set as follows: 

Chamfer (c): 0.01 (0.25) 

Z-Surf (S): 0.00 

Face Clearance (Cf): 0.05 (1.0) 

Nominal Depth (D): 0.2 (5.0) 

7 Click the Cycle button and PartMaker will select the appropriate cycle to 
create the desired hole by clicking <Select>. The selected cycle should be 
Tap_Sub_0-80 (Tap_Sub .35 x 1.6). 
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Your completed dialog should appear as the one below: 

 
8 You can verify the shape of the tapped hole by pressing the Verify Shape 

button. If you entered the parameters correctly you should see the following: 

 
9 Press the Hide Shape button and the Close button to exit the Hole Group 

Parameters dialog. 

Your Face Window should now appear as shown below: 

 
Before moving on, remember to save your work! Do so by selecting Save from the 
File menu or using the shortcut key <Ctrl + S>. Give your job file a name you will 
remember. 
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Creating an NC Program 
At this point, you have completed creating the three faces for the Swiss tutorial 
part. You are now prepared to take the final steps in developing your part program. 

The steps required for process plan development and program creation are 
described using the “generic” Fanuc-style Swiss-lathe post processor that comes 
standard with your PartMaker SwissCAM software. Synchronization and other 
processing related issues may vary slightly for different machine makers, but the 
steps below are instructive to work through in developing an understanding of 
process development in PartMaker SwissCAM. 

 Tip:  Refer to the Machine Specific Addendum that came with your 
PartMaker software for more information on process planning and post 
processing issues for the Swiss-type lathes in your shop. 

Generating a Process Table 
The first step in generating an NC program is creating a Process Table. A Process 
Table shows you all of the machining processes for a part.   

When PartMaker generates a Process Table, all cutting conditions such as feed rate 
and spindle speed (RPM) are calculated automatically based on the tools and 
material information previously entered. A time for each operation is shown, along 
with a total machining time for both the main and sub spindles. These time 
calculations give the user a sense of how closely “balanced” machining is for a part, 
i.e. how much cycle time is expended on both main and sub spindles in addition to 
the total time to cut the part. Time calculations in PartMaker include both “in-cut” 
time as well as tool change time. 

To create the Process Table: 

1 Choose Generate Process Table from the Job Optimizer menu.  Upon 
doing so, you will be prompted with the dialog below:  

 
2 Leave the boxes in the Process Table Options dialog unchecked and click 

on <OK>. 
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The following Process Table will appear: 

 

Visual Process Synchronization and PartMaker Specific Modes 
When generating a Process Table, PartMaker will default to machining your part in 
the order in which you have programmed part features. PartMaker starts by 
choosing the processes in the first Face Window you have created in the Setup 
dialog and executing all the part features in that Face Window in the order they 
have been created. The software then moves onto the next Face Window you have 
created and executes the processes defined in that Face Window. 

Of course, in Swiss machining, to conserve cycle time, many processes may be 
happening simultaneously, rather than in the sequential order in which you have 
created your tool paths in PartMaker. The Process Table accommodates this unique 
feature of Swiss machines allowing you to define the true order of processes defined 
in different Face Windows. It is in the Process Table that you synchronize 
operations being performed simultaneously with either different tool posts (i.e. 
gang, back working, turret etc) or on different spindles (main vs. sub) or some 
combination of the two. Such synchronization is done by pointing and clicking to 
place the order of processes and then by assigning different Synchronization Modes 
in the Set Modes dialog to link different processes to one another.   

More information on the Set Modes dialog can be found in Chapter 2, PartMaker 
Fundamentals. In addition, more information on synchronization techniques can be 
found in the Machine Specific addendum that came with your PartMaker 
software. 
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Synchronizing Processes on the Main Spindle 
To synchronize the Main Spindle operations on the Process Table for the swiss.job: 

1 Click on the Set Modes dialog to the right of process 1 as shown below: 

 
2 After doing so, you will see the Set Modes dialog appear as shown below: 

 
The Set Modes dialog allows you to visually determine the type of synchronization 
you want to perform. 

3 In this case, you will be synchronizing a number of Main Spindle operations 
with all of the Sub Spindle operations.  To indicate process 1 will be running 
simultaneously as a process on the Sub Spindle, click the Machining with 
One Tool (S1) radio button in the Sub-Spindle Mode area of the Set 
Modes dialog. After having done so, the Set Modes dialog should appear as 
shown below: 
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 Note: In the picture above, the double headed arrow indicates that the stock 
is moving in the guide bushing for the given process.  The lighter colored 
tool represents the tool doing the cutting in the selected process. 

Once you are satisfied your dialog appears as the one above, click the <OK> button 
to return to the Process Table. 

Notice how the Set Modes icon now depicts two tools cutting, one on the Main 
Spindle and one on the Sub Spindle.  The Mode column is now filled in with M1S1, 
indicating that during this process one tool is cutting on the main spindle and one is 
cutting on the sub spindle at the same time. 

 
4 In order to quickly set the remaining Main Spindle Processes to M1S1 (i.e. 

simultaneous cutting on Main and Sub Spindle) click the Set Modes icon 
associated with process 2.  Again, click the Machining with One Tool (S1) 
radio button in the Sub-Spindle Mode area of the Set Modes dialog. 

5 Next, click the Modify Modes for all Consecutive Processes with Same 
Mode radio button.  After having done so, the Set Modes dialog should 
appear as shown below: 

 
6 Click <OK> to return to the Process Table.  The Set Modes icons for all 

Main Spindle Processes should be automatically assigned and appear as 
shown below: 
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Setting the Cut-Off Operation 
Having now properly Synchronized the Main Spindle operations, you will now set-up 
the cut-off operation.  In Swiss machining, cut-off is typically programmed as the 
last operation when cutting a part that involves synchronous machining in both 
spindles. 

To properly set-up the cut-off and transfer from the main spindle to the sub spindle: 

1 Click on process 6, the Cut-Off operation. It will be highlighted with a box 
around it as shown below: 

 
2 Make the Cut-Off operation the last process on the Process Table by clicking 

on the arrow below process 12.  Your Process Table will now appear as 
shown below: 
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3 Now click the Set Modes icon associated with process 6 (the Cut-off 
operation) to enter the Set Modes dialog.  The proper mode for the Cut-Off 
operation is Cutting with One Tool (M1) on the Main Spindle while 
providing Follow Support (SF) with the sub-spindle, meaning the sub-
spindle is moving in sync with the main spindle as the part is being cut. 

To set this mode of operation, check the Follow Support (SF) radio button 
in the Sub-Spindle Mode area of the Set Modes dialog. 

When setting this mode, enter a value of 0.9 (25.0) for the Sub-Spindle 
Support Z-Coordinate (Sz), the position at which the sub-spindle is 
gripping the part during transfer. 

After doing so your Set Modes dialog should appear as shown below: 

 

4 Click the <OK> button to return to the Process Table.  Notice the 
appearance of the   Cut-Off process on the Process Table: 

 

 Tip:  In the future, to save yourself time, check the Move Cut-Off Process 
to End of Process Table button in the Process Table Options dialog 
which appears before the Process Table is generated.  Checking this box will 
automatically place your cut-off process at the end of the Process Table. 
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Synchronizing Processes on the Sub Spindle 
To synchronize the Sub Spindle operations with the Main Spindle operations 
discussed above on the Process Table for the swiss.job: 

1 Click on Process 8, the first operation programmed on the Sub Spindle.  With 
Process 8 selected (it should have a rectangle around it) click the Set Modes 
icon.   

 
2 In the Set Modes dialog, click the Machining with One Tool (M1) radio button 

in the Main Spindle Mode area of the Set Modes dialog. To save time, click 
the Modify Modes for all Consecutive Processes with Same Mode radio 
button. 

After having done so, the Set Modes dialog should appear as shown below: 

 
3 Click the <OK> button to return to the Process Table. 
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Ejecting the Part from the Sub Spindle 
Before this operation can be completed, you must eject the part from the Sub 
Spindle.  To do so: 

1 Click the Set Modes icon for the Process 12, the tapping operation, the last 
operation to be performed on the Sub Spindle.   

2 In the Set Modes dialog for Process 12, click the Eject Part box as shown 
below: 

 
3 Click the <OK> button to return to the Process Table. 
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Supporting With the Sub-Spindle 
Because of the length of the part being machined in this example, it may be 
advantageous to support the part with the sub-spindle while milling the hexagon on 
the back of the part. Such a technique is very common in Swiss-type turning. 

To do so: 

1 Select process number 7 by clicking anywhere on it, such that it is 
highlighted. 

2 Move process number 7, the Hexagon milling process just after Process 12, 
the last operation on the sub spindle, by clicking on the arrow just below 
process number 12.  

After doing so, your process table should appear as shown below: 

 
To support with the sub-spindle, it is suggested to use Machining with One 
Tool on the Main (M1) and Non-Follow Support (SN) mode. In this 
mode, the sub-spindle collet remains open to give the part additional support 
during machining. To establish this mode: 

3 Click the Set Modes icon to the right of Process 7. To support with sub-
spindle, click the Non-Follow Support (SN) mode in the Sub-Spindle 
Mode area of the Set Modes dialog. 

4 Enter a value of 0.8 (20.3) for the Sub-Spindle Support Z-Coordinate 
(Sz). Notice from the picture that this value represents the distance between 
the main spindle and the sub spindle during support. 
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When complete, the Set Modes dialog for Process 7 should appear as shown 
below: 

 
5 Your completed Process Table should appear as shown below: 
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Creating Sync Groups 
With the Process Table generated and sequence of operations established, you can 
now verify that your synchronization approach is correct by creating Sync Groups, 
groups of processes being executed simultaneously. 

To do so: 

1 Click the Synchronize button in the upper right hand corner of the Process 
Table. 

 
2 If you have made any errors in process synchronization, PartMaker will 

prompt you at this time. If you have not made any errors, your Process 
Table should appear as shown below: 

 
On the Process Table above, processes 1 through 12 are all being executed 
at the same time (all be it sequentially) and as a result are in the same Sync 
Group.  Processes 6 and 7 are happening independently and thus are not 
included in a Sync Group.   

Notice, once Sync Groups have been created, PartMaker displays a “balanced” 
cycle time for the entire operation, meaning the Total Time displayed is not 
necessarily a sum of the Main spindle time and the Sub spindle time, but 
actually takes the overlapping or synchronized operations into account. 

 
See Chapter 2, PartMaker Fundamentals for more information on the Set Modes 
dialog, Rules for Process Syncronization and Sync Groups. 
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Spindle Balancing and the Time Chart 
Once you have syncronized your operations, you can see how effective your 
syncronization strategies were by viewing the the Time Chart.  Before 
syncronization through the Set Modes dialog your time chart will appear as below:  

 
After clicking the Sync Group button, your Time Chart will show you graphically 
which operations are overlapping and where additional opportunities for saving cycle 
time by overlapping other operations: 

 

 Note: The time chart can be viewed by clicking the Show Time Chart 
button in the lower right hand corner of the Process Table. 
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Selecting a Post Processor 
Having finished generating the Process Table and synchronizing operations, you 
must now select a Post Configuration File before you can output an NC program.  
This post configuration file is stored in the pm-swiss root directory.  If you do not 
have any other post configuration files loaded in this directory the 
Swiss_demo.pst will be loaded automatically.  If you have other post configuration 
files in this directory: 

1 Choose Post Config File = ? from the Job Optimizer menu.  

2 Select Swiss-demo.pst post as shown below.  PartMaker SwissCAM comes 
standard with a post configuration for a Fanuc 18t control which supports live 
tooling, y-axis,  c-axis and subspindle operations. 

 
3 Click <Open> to load the post processor. 
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Simulating the Process 
Having completed generating the Process Table, synchronizing operations and 
loading a post processor, you can now simulate the processes. The simulation will 
show your part being cut just how it would on your machine tool.  Simulation will 
show synchronization between your Main and Sub-Spindles. It will also show any 
collisions that may occur between the tooling, material, and/or Spindles.  

1 Click the <Simulation> button at the bottom left hand portion of the 
Process Table.   

2 Press the Space Bar or choose Simulation from the Simulation menu to 
begin the simulation.  
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Generating an NC Program 
Having selected a Post Configuration file, you are now ready to generate an NC 
Program.  To do so: 

1 Choose Generate NC Program from the Job Optimizer menu.  

Note:  Choosing the Generate NC Program command from the Job 
Optimizer menu has the same effect as clicking the Sync Group button on 
the Process Table if Sync Groups have not yet been created. 

2 You will next see the Post Options dialog.  Set the Post Options dialog as 
shown below: 

 
In the Post Options dialog you set certain parameters for assignment 
during post processing.  Please refer to your machine specific addendum for 
more information on how each of the fields in this dialog pertain to your 
Swiss turning equipment. 
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3 Click <OK> in the Post Options Dialog to proceed to the Save NC 
Program dialog.  In this dialog, enter a name for your program.  Here you 
should enter “tutorial”. 

 
4 Click <Save> to generate the NC program. You will see your programs as 

shown below: 
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Chapter 4: PartMaker® Simulation 
Introduction 

PartMaker Version 8 and higher comes with an integrated 3D solid modeling process 
simulation and verification module.  This module is available in three levels:  Basic 
Simulation, Advanced Simulation and Full Machine Simulation.  Basic Simulation and 
Advanced Simulation come standard with PartMaker SwissCAM while Full Machine 
Simulation is available as an optional module with PartMaker SwissCAM. 

PartMaker’s Basic Simulation Module allows you to: 

 Simulate all machining processes as they appear on the Process Table 

 Observe the results of any process synchronization 

 Examine a solid model of the part through dynamic rotation and cross-
sectioning 

PartMaker’s Advanced Simulation Module allows you to do all of the above and: 

 View a 3D parametric machine model for your specific machine 

 Automatically check that all tool numbers assigned in the tool database are 
assigned correctly for your specific machine model 

 Customize your machine through the manipulation of an MCH file 

 Detect crashes, collisions and errors between various machine components 
and the part 

 Detect any machine over travels on screen 

PartMaker’s Full Machine Simulation Module allows you to do all of the above and: 

 View a realistic 3D model of your machine and its tool holders and various 
components based on actual solid models versus just parametric descriptions 

 Import solid models for all simulated entities 

 Add components to these entities (i.e. turret slides) to model the kinematics 
of the machine. 

 Add tool holders to the simulation and mount multiple tools per holder. 

 Interactively specify how the machine is assembled. 

Users who have licensed the Full Machine Simulation module may still find it 
beneficial to use the Basic Simulation module to focus on only the part as it is being 
machined.  

You may choose between Basic, Advanced, of Full Machine Simulation by choosing 
Basic Simulation, Advanced Simulation, or Full Machine Simulation from the 
Simulation menu or by right mouse clicking on the Process Table and choosing 
either option.   

Whichever simulation option has been selected will determine which type of 
simulation will be launched. 



 

4-2 PartMaker  Copyright @2014 Delcam Ltd 

 

The Simulation Toolbar 
Many of the common functions used in PartMaker’s 3D simulation can be accessed 
via the Toolbar that appears at the top of the Simulation Window as shown here: 

 
Each icon on the Simulation Toolbar is explained below.  The features each of 
these icons enable will be explained in greater depth throughout this chapter. 

 

 
Starts the simulation 

 
Pauses the simulation 

 
Resets the simulation 

 
Shows the finished 3D model of the part 

 
Allows the user to measure the completed part. 

 
Sets simulation to operate in Basic Simulation mode 

 
Sets simulation to operate in Advanced Simulation mode 

 
Sets simulation to operate in Full Machine Simulation mode 

 
Allows you to take cross sectional views of the completed part 

 
Allows you to show a full view of a part after sectioning 

 
Allows you to manipulate the view of machined part 

 
Allows you to see the Simulation Options dialog 

 
Allows you to see the Spindle Setting  dialog 

 
Shows the Machine Housing 
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Simulation Features 
PartMaker Simulation has a number of process and part analysis features available 
both during and after process simulation is complete. 

Reset 
At any point you can reset the simulation to the initial screen by choosing Reset 
from the Simulation menu.  Alternatively, if you have suspended Simulation by 
pressing <Esc>, you can press <Esc> again to reset the simulation. 

The Reset command is also accessible by clicking the right mouse button when 
viewing the finished part (see below). 

Show Travel Limits 
Displays the travel limits for machine being simulated for each machine component 
depending on how the machine is equipped.  Travel limits for each machine 
components including main spindle, sub spindle and tool posts are set in the 
Machine Date File dialog accessed from the Toolminder menu. 

Show Finished Part 
By choosing the Show Finished Part command from the Simulation menu, you 
can see a 3D model of your programmed part.  You need not run the simulation 
prior to choosing Show Finished Part.  

When choosing Show Finished Part, the verified part alone will appear in the 
Simulation window as shown here: 

 

Save Finished Part As STL file 
This will save the finished part to an STL file format.  This can be then used again in 
PartMaker for Custom Stock or Surface Machining. 

Compare Finished Part to Solid Model 
This will use the solid model specified in the Comparison Options Dialog to show 
a comparison of the part to the solid model. 

Comparison Options 
This will open the Comparison Options dialog.  This allows you to specify the 
comparison models as well as the over and undercut display colors. 
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View Setting Features 
PartMaker Basic Simulation allows you to automatically set a variety of views when 
simulation has been halted by using the <Esc> key or when using the Show 
Finished Part command.  Various view orientations are available from the View 
sub-menu under the Simulation menu. 

Default 
Choosing Default sets the view in the simulation window to the default view 
when Simulation was launched. 

Best Fit 
Choosing Best Fit sets the view in the simulation window to the best fit relative 
to the Simulation window as determined automatically by PartMaker. 

XY View 
Choosing the XY View command sets the view in the simulation window normal 
to the cross sectional plane formed by XY axes.  The axes along which the part 
is defined are constantly active in the upper left hand corner of the simulation 
window. 

YZ View 
Choosing the YZ View command sets the view in the simulation window normal 
to the cross sectional plane formed by YZ axes.  The axes along which the part 
is defined are constantly active in the upper left hand corner of the simulation 
window. 

ZX View 
Choosing the ZX View command sets the view in the simulation window normal 
to the cross sectional plane formed by ZX axes.  The axes along which the part 
is defined are constantly active in the upper left hand corner of the simulation 
window. 

Isometric View 
Choosing the Isometric View command sets the view in the simulation window 
aligned to the X, Y and Z axes.  This view presents the part at a 45 degree 
angle. 

Show Coordinate Axes 
Setting this selection to On allows the user to manipulate the axes symbol in 
upper left hand corner of PartMaker Simulation Window. 

Show Finished Part Origin 
This will hide or show the 3-D axis on the finished part. 

Background Color 
This allows the user to choose the background color of the simulation.  The 
background may be set to gradient by choosing different colors for the Top and 
Bottom Gradient Color respectively. 

Datum Color 
This sets the color of each axis of the datum, X, Y and Z respectively. 

Show Machine Housing 
This shows the Machine Housing.  



 

Copyright @2014 Delcam Ltd  User Guide 4-5  

 

View Manipulation Features: Rotate, Move and Zoom 
PartMaker simulation allows you to manipulate the view of either the entire process 
simulation or the finished part (when using Show Finished Part).  When using 
PartMaker, one of these commands will be activated, as denoted by a check next to 
it under the Change View sub menu under the Simulation menu.   

Whenever the Rotate, Move or Zoom command is checked, it can be activated by 
holding down the left mouse key and moving your mouse.   

It is advisable to always leave the Rotate command checked as both Move and 
Zoom can always be accessed using keyboard shortcut keys or the mouse.  For 
example, if the Rotate command is checked under the Change View sub menu 
under the Simulation menu, Rotate can be activated by clicking the left mouse 
button and moving the mouse, Move can be activated by holding down the mouse’s 
scroll wheel and moving the mouse and Zoom can be activated by simply scrolling 
the mouse’s scroll wheel. 

PartMaker provides fully dynamic simulation such that the Rotate, Move and Zoom 
commands can be accessed at any time during simulation. 

Rotate 
This command allows you to dynamically rotate the entire process simulation 
within the simulation window.  When using Show Finished Part, Rotate allows 
you to dynamically rotate the solid model of the completed part.   

When Rotate is active, you can rotate the process simulation or finished part by 
clicking the left hand mouse button and dragging your mouse in the orientation 
you would like to see the view. 

Rotate may only be used when it is activated from the Solids menu.  You can 
activate Rotate by choosing it from the Solids menu.  Its activation is denoted 
by a check next to it under the Simulation window. 

Move 
This command allows you to dynamically move the entire process simulation 
around the simulation window.  When using Show Finished Part, Rotate 
allows you to dynamically rotate the solid model of the completed part.   

When Move is active, you can move the process simulation or finished part by 
clicking the left hand mouse button and dragging your mouse in the direction 
you want to move the view.   

You can move the view if Move is NOT active by holding down the <Ctrl> + 
<Arrow> keys on your keyboard, with arrows denoting the direction in which 
the view will move.  These are the same keys used when performing panning in 
PartMaker. 

Additionally, Move can always be activated using the mouse by holding down 
the mouse wheel (if your mouse is so equipped) and dragging your mouse in the 
direction you want to move the view. 

You can activate Move by choosing it from the Solids menu.  Its activation is 
denoted by a check next to it under the Simulation window. 

Zoom 
This command allows you to dynamically size the entire process simulation 
within the simulation window when it has been halted by using the <Esc> key.  
When using Show Finished Part, Zoom allows you to dynamically size the 
solid model of the completed part.   
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When Zoom is active, you can scale the process simulation or finished part by 
clicking the left hand mouse button and dragging it upward to increase the size 
of the part and dragging downward to decrease the size of the part.   

You can scale the view if Scale is NOT active by pressing the <F4> key to 
decrease the size of the view or the <F5> key to increase the size of the view.  
These are the same keys used when performing Continuous Zoom In or Zoom 
Out in PartMaker. 

Additionally, Scale can always be activated using the mouse by scrolling the 
mouse wheel (if your mouse is so equipped) upward to zoom in and downward 
to zoom out. 

Sectioning Features 
PartMaker simulation allows you to section the solid view to inspect the interior of 
the part. Various sectioning options are available by choosing Sectional Part View 
from the Simulation menu.  Choosing Sectional Part View opens the Section 
Finished Part dialog as shown below: 

 
1 Sectioning Plane - The Sectioning Plane section of this dialog allows you to 

determine the plane across which sectioning will occur normal to. The user 
can section a finished part normal to the XY, ZY and ZX plane. The axes 
along which the part is defined are constantly active in the upper left hand 
corner of the simulation window. 

2 Dynamic Sectioning – Checking this box enables dynamic section, or the 
ability to see the part being sectioned as you adjust the location of the 
sectional plane.  If Dynamic Sectioning is unchecked, you will be able to see 
the result of your sectioning by clicking the <Preview> button or by exiting 
this dialog by clicking <OK> 

3 Plane Coordinate - This area of the dialog allows you to adjust the level of 
the sectioning plane. 

4 Reverse Direction - This allows you to reverse the direction of sectional 
plane shown. 
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Simulation Options 
You can manipulate the appearance of simulation by choosing Options from the 
Simulation menu or by clicking the right mouse button in the Simulation Window 
and choosing Options.   

PartMaker Simulation allows you to change the appearance of the view in the 
simulation window when simulation has been halted by using the <Esc> key or 
when using the Show Finished Part command.   

The Options dialog as it appears in Basic Simulation for PartMaker SwissCAM is 
displayed below: 

 

Pause On  
Never: Specifies that simulation should never pause during simulation 

Eject: Specifies that simulation should pause before part eject operation is 
performed 

Cut-off: Specifies that simulation should pause after the cut-off operation is 
performed 

Every Process: Specifies that simulation should pause at the beginning of every 
process in the current Process Table 

Selected Process: Specifies that simulation should pause at the beginning of a 
selected process in the current Process Table 

Every Move: Specifies that simulation should pause before every tool move 

Tool Collision: Specifies that simulation should pause every time a collision occurs 

Tool Overtravel: Specifies that simulation should pause every time tool post goes 
outside of its travel limits specified in the Machine File. 

Settings  
Turning Insert Thickness: Specifies the thickness of the turning insert 
Max ID Tool Holder Thickness: Specifies the maximum thickness of a tool holder 
for inside diameter tool. 
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Enable Collision Checking/Report Collision Types 
Checking the Enable Collision Checking box allows you to detect the following 
collision types in Simulation: 

Tool with Stock(s) on Rapid Move: Specifies that PartMaker should check for 
collisions between the tool (or insert) and that stock in the main spindle as well 
as a part in sub-spindle 

Tool with GB and/or Sub-Spindle: Specifies that PartMaker should check for 
collisions between the tool (or insert) and the Guide Bushing and/or Sub-Spindle 

GB and Sub-Spindle: Specifies that PartMaker should check for collisions 
between the Guide Bushing and Sub-Spindle. 
Tool Holder Collision: Specifies that PartMaker should check for Tool Holder 
collisions with any part/stock as well as with the Main Spindle and Sub-Spindle 

Tool with Foreign Stock: Specifies that PartMaker should check for collisions 
between the tool (or insert) working on the Main Spindle with part in the Sub-
Spindle or between the tool (or insert) working on Sub-Spindle with the stock or 
part in the Main Spindle 

Tool with Tool: Specifies that PartMaker should check for collisions between two 
tools on the machine. This is for Advanced an Full Machine simulations only. 

Tool with Toolpost: Specifies that PartMaker should check for collisions between 
a tool and another tool post on the machine.  This is for Advanced and Full 
Machine simulations only. 

Toolpost with Toolpost: Specifies that PartMaker should check for collisions 
between tool posts on the machine.  This is for Advanced and Full Machine 
Simulations only. 

Toolpost with Stock: Specifies that PartMaker should check for collisions 
between a tool post and the stock being machined.  This is for Advanced and Full 
Machine Simulations only. 

Toolpost with Spindle:  Specifies that PartMaker should check for collisions 
between a tool post and the main or sub spindle.  This is for Advanced and Full 
Machine Simulations only. 

Non-Active Tool with Spindle:  Specifies that PartMaker should check for 
collisions between a tool not in the cut and the main or sub spindle.  This is for 
Advanced and Full Machine Simulations only. 

Non-Active Tool with Stock:  Specifies that PartMaker should check for collisions 
between a tool not in the cut and the stock.  This is for Advanced and Full 
Machine Simulations only. 

Tool with Machine Housing:  Specifies that PartMaker should check for collisions 
between a tool (or insert) and the machine housing.  This is for Full Machine 
Simulation only. 
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Display Control 
Time Delay (0...9): Specifies a time delay following every screen update for each 
tool motion.  Negative numbers -9 to -1 may also be used to speed simulation more 
than 0. 

Transparency of Stock/Part: Specifies how transparent the part and/or stock should 
appear. 0% means solid part, 100% means "fully transparent" part, i.e. an invisible 
part. 

Run in a Loop: Specifies that Simulation will run in a continuous loop 

Hide Tool Holders: Specifies that Tool Holders for Turning Tools will not be 
displayed during Simulation 

Display Status:  Allow the Simulation to display coordinate and movement 
information at the top of the simulation window. 

Cosmetic Thread: Specifies that during Simulation a single pass will replace every 
Multi-Pass helical thread in order to speed up simulation. 

Software Rendering: Specifies that Open GL software graphics libraries should be 
used instead of the hardware implementation of the Open GL drivers that are 
dependent on the actual Graphics Video card used in every computer. If you use a 
high performance AGP video card you may achieve a significant simulation speed 
improvement if you do not use Software Rendering 
Wireframe Display: Specifies that everything will be displayed using a wire frame 
representation instead of solid modeling. 

Show Tool Numbers on Tool Posts:  This will show all tool numbers available on 
a tool post on the solid for that tool post.   This is for Advanced Simulation only. 

Display Quality 
Coarse: Specifies that solids will be displayed using relatively large facets to assure 
the fastest simulation 

Medium: Specifies that solids will be displayed using medium size facets that will 
result in lesser simulation speed 

Fine: Specifies that solids will be displayed using very small size facets that will 
result in further decrease in simulation speed 

Apply to All Machine Components: Specifies that solid models will be converted to 
simulation models with the specified Display Quality (Coarse, Medium, Fine), 
regardless of the quality specified in its model data.  These solid models can include 
custom stocks and tool posts. 

Colors and Textures 
Use Group Colors: Specifies that user-defined Group Colors will be used as cut 
colors. If option not checked, a metallic gray color will be used as cut color for all 
tools 

Set Stock Color: Allows a user to choose the color of initial stock using a Windows 
standard dialog. 
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Using PartMaker Basic Simulation 
PartMaker Basic Simulation can be viewed at any point in the programming process.  
You need not complete programming a part to see the results of your work. 

 Important! To launch PartMaker Simulation you must have a Process Table 
generated.  To generate the Process Table, choose Generate Process 
Table from the Job Optimizer menu (ALT + P) or use the Generate 
Process Table icon from the Main Toolbar.  It is not necessary to 
complete synchronization of simultaneous operations before launching 
PartMaker Simulation. 

Launching Basic Simulation 
To launch PartMaker Basic Simulation: 

1 Click the Start Simulation icon from the Main Toolbar 

or 

Press the Simulation button in upper left hand corner of the Process Table 

or 

Choose Simulation from the Simulation menu 

 

2 Make sure the Basic Simulation icon on the Simulation Toolbar is 
checked or Basic Simulation is checked under the Simulation menu  

Upon launching simulation, you will see an uncut cylindrical work piece, and 
either one or two spindles depending on whether your part involves both main 
and sub spindle operations.  

A newly launched simulation window is shown below: 
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Running Simulation 
Once you have launched PartMaker Simulation, to start machining: 

1 Press the Start Simulation button on the Simulation Toolbar  

or 

Press the <Space Bar> on your keyboard  

or  

Select Start Simulation from the Simulation Menu 

2 Once simulation has started, you can suspend cutting by pressing the <Esc> 
button on your key board. Press the <Space Bar> to continue the 
simulation.  Below is an example of suspending simulation in process: 
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Using PartMaker Advanced Simulation 
PartMaker Advanced Simulation can be viewed at any point in the programming 
process.  You need not complete programming a part to see the results of your 
work. 

Irrespective of which Swiss machine you are using, PartMaker installs a number of 
“generic” machine configurations which you may view.  These machine 
configurations can be viewed from the C:\PartMaker\PM-
Swiss\Advanced_Simulation directory and consist of the following examples: 

2_Gangs_End_Backworking: A “generic” machine with two gang tool 
posts, an end working tool post and a backworking tool post 

Gang_End_Backworking: A “generic” machine with one gang tool post, an 
end working tool post and a backworking tool post 

Gang_Turret: A “generic” machine with one gang tool post and one turret 
tool post 

Gang_Turret_Backworking: A “generic” machine with one gang tool post, 
one turret tool post and a backworking tool post 

None of the examples listed above are meant to represent a specific machine model 
such as a Citizen L, Star SV, Tsugami BS, Tornos Deco etc.  You will be able to view 
a more machine specific model for your machine when loading the *.MCH file 
specifically tailored to the machine you are programming. 

Launching Advanced Simulation 

 Important!  For purposes of this tutorial, please load the *.job, *.tdb and 
*.cdb files called Gang_Turret_Backworking.job, 
Gang_Turret_Backworking.tdb and Gang_Turret_Backworking.cdb located in 
the C:\PartMaker\PM-Swiss\Advanced_Simulation\ 
Gang_Turret_Backworking directory. 

 Important! To launch PartMaker Advanced Simulation you must have an 
*.MCH (machine configuration file) loaded.  The MCH file contains a 
description of the Swiss machine you are using to machine the part. An MCH 
file will be loaded automatically when a post processor is loaded and the 
MCH file corresponding to that post processor is loaded in the same directory 
as the post processor. 

You will only be able to launch PartMaker Simulation when the Process Table is 
generated.  If you do not have a Process Table generated, choose Generate 
Process Table from the Job Optimizer menu. 

To launch PartMaker Advanced Simulation: 

1 Click the Start Simulation icon from the Main Toolbar 

or 

Press the Simulation button in upper left hand corner of the Process Table 

or 

Choose Simulation from the Simulation menu 

2 Make sure the Advanced Simulation icon on the Simulation Toolbar is 
checked or Advanced Simulation is checked under the Simulation menu  

Upon launching simulation, you will see an uncut cylindrical work piece, tool posts 
with tools attached, and either one or two spindles depending on whether your part 
involves both main and sub spindle operations.  
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A newly launched simulation window is shown below: 

 

Running Simulation 
Once you have launched PartMaker Simulation, to start machining: 

1 Press the Start Simulation button on the Simulation Toolbar  

or 

Press the <Space Bar> on your keyboard  

or  

Select Start Simulation from the Simulation Menu 

2 Once simulation has started, you can suspend cutting by pressing the <Esc> 
button on your key board. Press the <Space Bar> to continue the 
simulation.  Below, is an example of suspending a simulation in process: 
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Using PartMaker Full Machine Simulation 
PartMaker Full Machine Simulation can be viewed at any point in the programming 
process.  You need not complete programming a part to see the results of your work 
although it is highly recommended to do so.   

PartMaker installs a “generic” machine configuration, consisting of a Gang and End 
Working Slide for you to view.  This machine configuration can be viewed from the 
C:\PartMaker\PM-Swiss\Full_Machine_Simulation directory. 

 Important!  For purposes of this tutorial, please load the *.job, *.tdb and 
*.cdb files called FMS_swiss_inch, located in the C:\PartMaker\PM-
Swiss\Full_Machine_Simulation\ directory. 

 Important!  To launch PartMaker Full Machine Simulation you must have an 
*.MCH (machine configuration file) loaded.  The MCH file contains a 
description of the Swiss machine you are using to machine the part. An MCH 
file will be loaded automatically when a post processor is loaded and the 
MCH file corresponding to that post processor is loaded in the same directory 
as the post processor. 

Prior to running Full Machine Simulation, you will attach the holders specified in the 
Machine Data File to the tools used on the Process Table.  The tool post and 
component models will automatically be loaded into simulation.  To do so: 

1 Select Tool Assembly from the Job Optimizer menu to open the Tool 
Assembly dialog. The tools on the Process Table are displayed, sorted by 
tool post and tool number. 

 
2 Highlight the first tool on list. This is Tool Number 1 on the Gang. 

Note: The Holder Name column may contain “Not Used”.  You are not 
required to put a holder in this station. 
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3 Press <Tool Assembly Preview> to see how the tool and tool post will look 
in simulation. 

 
4 Press the “X” in the top left corner of the window to close the Preview. 

5 Highlight the Tool Number 8 on the Gang Slide.  Notice that in the Holder 
Name column, there is a “?”.  This means that a holder is expected to 
mount to this position. 

 
6 Press <Tool Assembly Preview> to see how the tool and tool post will look 

in simulation.  Notice that the tool is floating in air away from the Gang.  

 
7 Press the “X” in the top left corner to close the Preview. 
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8 Press <Select Holder> to open the Select Holder Dialog for the 
highlighted tool. 

9 Choose “Gang Live Collet” to specify this holder to be used for simulation. 

 
10 Press <OK> to confirm this holder selection. 

11 Press <Tool Assembly Preview> to see how the final assembly with the 
holder will look when attached in simulation.  You will see if there are any 
issues with the holder that you have selected. 

 
12 Press the “X” in the top left corner to close the Preview. 

13 Repeat step 6 – step 12 for Tool Numbers 41-43 on the Back Working Slide. 
For all of these tools, you will use the “Back Working Collet” 

14 Press <OK> in the Tool Assembly dialog to confirm all of your holder 
selections. 
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Launching Full Machine Simulation 
Once all the holders have been attached to the respective tools on the process 
table, you can view the Full Machine Simulation.  The full machine simulation will 
include the models of the tool posts and their components, holders for the tools, 
and custom positioning of the tools and holders on the tool posts. 

To launch PartMaker Full Machine Simulation you must have a Process Table 
generated.  To generate the Process Table, choose Generate Process Table from 
the Job Optimizer menu (ALT + P) or click the Generate Process Table icon from 
the Main Toolbar.  It is not necessary to complete synchronization of simultaneous 
operations before launching PartMaker Simulation. 

To launch PartMaker Full Machine Simulation: 

1 Click the Start Simulation icon from the Main Toolbar 

or 

Press the Simulation button in upper left hand corner of the Process Table 

or 

Choose Simulation from the Simulation menu 

2 Make sure the Full Machine Simulation icon on the Simulation Toolbar is 
checked or Full Machine Simulation is checked under the Simulation menu  

Upon launching simulation, you will see an uncut cylindrical work piece, tool posts 
with tools and holders attached, and either one or two spindles depending on 
whether your part involves both main and sub spindle operations.  

A newly launched simulation window is shown below: 
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Machine File for Advanced and Full Machine Simulation  
The machine you are seeing in PartMaker’s Advanced and Full Machine Simulation is 
described by a Machine Description stored in a *.MCH file.  Each machine 
architecture will have a separate Machine Description.  The Machine Description 
may be viewed graphically by choosing Machine… from the ToolMinder menu.  
When doing so, the following dialog appears: 

 
See PartMaker Help for a more in depth explanation of each of the dialogs and 
parameters in the Machine Data File dialog. 
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When should you use Basic vs. Advanced Simulation? 
Basic and Advanced Machining Simulation are not mutually exclusive technologies.  

Basic Simulation may be preferable to use in certain circumstances over Advanced 
Simulation because it: 

 Provides more focus on just the part and cutting process because space is 
not taken up on screen with multiple machine components. 

 Can run faster than Advanced Simulation because it is less graphically 
intensive. 

Advanced Simulation will be preferable to use in certain circumstances over Basic 
Simulation because it: 

 Provides a machine specific simulation, i.e. supports right and left handed 
machines, specific machine components, etc. 

 Provides additional crash and collision avoidance over Basic Simulation 

 Gives the user verification that all tools numbers are correct for a given 
machine 

As a rule of thumb, you may find Basic Simulation more beneficial for simulating 
your “first pass” at programming a part, while Advanced Simulation may be better 
when completing the programming of the entire component at which time you wish 
to see how the part will look as well as how it will run in its machine environment. 
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When should you use Full Machine vs. Advanced Simulation? 
Full Machine and Advanced Simulation are not mutually exclusive technologies.  

Full Machine Simulation may be preferable to use in certain circumstances over 
Advanced Simulation because it: 

 Provides a photo realistic representation of the machine, thus enabling 
robust collision checking of holders, turrets, and other machine components.  

 Provides a virtual setup of the machine tool for training purposes. 

Advanced Simulation will be preferable to use in certain circumstances over Full 
Machine Simulation because it: 

 It will run faster since it is less graphically intensive. 

 Models may not be available for a particular machine tool. 

 You do not wish attach tools to holders  

 You wish to see tool numbers clearly displayed on the machine model 

Although not much more, Full Machine Simulation does take more time to set up for 
use than Advanced Simulation.  It may be beneficial to make sure that the tools are 
set up correctly in Advanced Simulation, before taking the time to use up Full 
Machine Simulation. 

Advanced Simulation Limitations 
The machine model you are seeing in PartMaker’s Advanced Simulation is a 
parametrically defined model of the machine you are programming.  As it is based 
on parametric approximations, it may not simulate your machine exactly the way it 
looks.  The limitations you may find at this point are: 

Multiple Tool Stations  
Multiple Tool Stations only applicable to the tools on the Turret. A Multiple Tool 
Station is the station on the turret that has more than one tool with the same Tool 
Number defined in Tool Data Dialog. During Advanced Simulation only one tool on 
the tool stations is shown. Therefore the tools which belong to the multiple tool 
station will be switched on the Turret based on the sequence in the Process Table.  

Non-Standard Machine Architectures 
PartMaker Advanced Simulation may not support certain elements of Swiss-
machines with irregular architectures at this time.  Such architectures may include 
machines with an “L-shaped gang”, attached end working and back working arms 
and machines where the sub-spindle is mounted on a turret.  

Please consult PartMaker Technical Support for more information on any limitations 
you may encounter with respect to Advanced 3D Machining Simulation. 

Full Machine Simulation Limitations 

The machine model you are seeing in PartMaker’s Full Machine Simulation is a 
realistic model of the machine you are programming.  The limitations you may find 
at this point are: 

Material Control Process Simulation 
PartMaker Full Machine Simulation does not support the simulation Material Control 
Processes (MCP) as inserted under the Job Optimizer menu. These MCP actions 
include grippers on the turret and tail stocks.  
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Appendix A:Materials 
PartMaker Material Library 

This appendix contains a list of all material files and their abbreviations. 

 

File Description 

ALU_ALLC.MDB Aluminum Alloy, Cast 

ALU_ALLW.MDB Aluminum Alloy, Wrought 

CARBIDES.MDB Machinable Carbides  

CHNICKEL.MDB Chromium-Nickel, Alloy 

COP_ALLC.MDB Copper Alloy, Cast  

COP_ALLW.MDB Copper Alloy, Wrought 

IRON_DUC.MDB Ductile Iron, Cast  

IRON_GRC.MDB Gray Iron, Cast 

LEADALLC.MDB Lead Alloys, Cast  

MAG_ALLC.MDB Magnesium Alloys Cast 

MAG_ALLW.MDB Magnesium Alloys Wrought 

NICKELWC.MDB Nickel Alloys, Wrought and Cast 

ST_ALLOW.MDB Alloy Steels, Wrought 

ST_CARB.MDB Carbon Steels, Wrought 
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File Description 

ST_FMCAW.MDB Free Machining Carbon Steel, Wrought 

ST_FMSTW.MDB Free Machining Stainless Steel, Wrought 

ST_STAIC.MDB Stainless Steel, Cast 

ST_STAIW.MDB Stainless Steel, Wrought 

ST_STRUW.MDB Structural Steels, Wrought  

ST_TOOLW.MDB  Tool Steel, Wrought 

THERMOPL.MDB Thermoplastics 

TIN_ALLC.MDB Tin Alloys, Cast 

TIT_ALLC.MDB Titanium Alloys, Cast 

TIT_ALLW.MDB Titanium Alloys, Wrought 

ZINCALLC.MDB Zinc Alloy Cast 
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Appendix B: Family of Parts 
Programming Tutorial 
Introduction 

This tutorial will teach you how to use PartMaker’s Family of Parts Programming 
Feature. 

PartMaker Version 4.6 and higher features a unique Family of Parts Programming 
(FOP) capability, which greatly speeds CNC programming for parts created from 
tabulated drawings.  This feature allows a programmer to program one part in a 
family and then automatically substitute any variable parameters by manipulating a 
separate file containing parameter definitions.  A virtually unlimited number of 
parameter files (*.prm files) can be defined by the user.  

FOP is an available option with every PartMaker product, namely, PartMaker/Mill, 
PartMaker/Turn, PartMaker/Turn-Mill and PartMaker/SwissCAM. It applies to Turning 
as well as Milling faces. 

 The steps presented in this tutorial are carried out in PartMaker 
SwissCAM but can be used in any PartMaker application. 

Sequence of Steps for Family of Parts Programming 
The steps outlined below describe the sequence in which you should approach 
programming Families of Parts from tabulated drawings.  This programming tutorial 
follows the sequence of steps below in creating a typical family of parts. 

You can use this page as desk reference when programming a Family of Parts. 

1 Create Part Geometry for one part in the family using actual numbers.  It 
is not critical which part number in the family you choose. 

2 Setup PartMaker Databases appropriately, i.e. make sure all tools, 
materials and cycles files for the part have been set appropriately 

3 Assign part features to your geometry.  When doing so, make sure to 
assign toolpaths by snapping to existing geometry.  If you do not snap tool 
paths to existing and parameterized geometry, they will not be updated 
when you regenerate other parts in the family. 

4 Create the appropriate Parameter Files (*.prm) for each part in the 
family.  Each Parameter File contains the variable definitions for each part in 
the family. 

5 Setup PartMaker for Parametric Input by clicking the Parametric Input 
box in the  Family of Parts section of the Preferences dialog which can be 
found under the View menu. 

6 Parameterize your part by assigning variables to parametric geometric 
elements and part features such as thread pitch and hole depth. 

7 Set Part Boundaries Parametrically by choosing Set Parametric 
Boundaries from Family of Parts Programming accessed from the Edit Menu. 

8 Update Each Part in the Family by opening the respective Parameter File 
by choosing Open Parameter File from Family of Parts Programming, then 
choosing Apply Parametric Dimensions. 

9 Regenerate NC Code for each part in the family by choosing Generate 
Process Table from the Job Optimizer menu and then choosing Generate NC 
Program from the Job Optimizer menu. 
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Getting Started 
The blue print below represents a typical parametric part.   

 
 

Part # A B C D E F P/Pitch 
50-100 0.25 1.0 1.5 25 0.4 3.0 0.05 (20) 
50-200 0.25 0.8 1.0 15 0.38 2.5 0.03 (30) 
50-300 0.1875 0.7 0.75 25 0.3 2.0 0.05 (20) 
50-400 0.2 0.5 0.6 30 0.3 1.5 0.1 (10) 
50-500 0.3125 0.4 0.5 35 0.35 1.25 0.04 (25) 

When you complete this tutorial, you will have parts that looks like the picture 
below: 
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Create Part Geometry 
The first step in programming a part in a family of parts is to create the part 
geometry.  When doing so, you should pick one part number from the family.  In 
this case, the Part #50-100 in the table on page B-2 will be used. 

1 Double click on the SwissCAM icon on your desktop or choose SwissCAM 
from the PartMaker Group accessed through Programs under the Windows 
Start button. 

2 You will then see the Setup definition dialog box. 

3 Enter the enter the parameters listed below in the appropriate fields: 

• Length (L): 3.0 • OD: 0.4 

• Excess Stock (E): 0.0
1 

• ID: 0.0 

• GB Length (l): 1.0 • GB Dia (d): 0.75 

• Tool Change X(Xc): 2.8 • Tool Change Z (Zc): 0.0 

The setup dialog will then appear below.  

 
4 When you are satisfied that your Setup dialog appears as the one above, 

click the <Apply> button. This will apply the parameters to the current Face 
Window.  Click the <Close> button to close the Setup dialog. 

5 In the CAM Face Window, choose Show Axes from the View menu.  This 
will display the horizontal and vertical axis lines which will help you create 
the geometry. 

6 Click on the CAD/CAM switch in the lower left-hand corner of the window. 
The icon will change its appearance from cutting tools to a pencil. 

7 Select the Connected Lines Icon from the drawing icons on left side of the 
Face Window. Here, you will draw the part in the print on the second page 
of this chapter by plotting ZX coordinates, using the ZX Snap Mode from 
the Snap Modes icon bar at the top of the screen.  

After selecting the ZX Snap Mode two data entry fields will appear in the 
lower left hand corner of the Face Window.   
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Now enter the ZX coordinates as shown below, pressing <Enter> after 
each: 

default 0.25 

1 default 

default 0.4 

3 default 

default 0 

After entering these coordinates, you should have a drawing which appears as 
the profile below: 

 
8 You will now place the diagonal line represented by the “D” dimension on.  

To do so, select the Line on an Angle icon and select the End of Line snap 
mode.  

When doing so, you will be prompted to Select end point of line or arc.  
Drag your cursor into place as shown below and click the left mouse button. 

 
You will now be prompted to enter an angle for this line.  At the prompt 
enter a value of 155 (i.e. 180 – 25) and press <Enter>. 

Move your cursor so the arrow is on the line as shown below and click the 
left mouse button. 

 
Having done so, you will now have a drawing which appears as shown below. 

 
Now select the Remove icon and click the scissors on lines 1 and 2 in the 
picture below.  

 
After having done so, your geometry will appear as shown below: 

 

 Note: When programming Families of Parts, you SHOULD NOT mirror 
geometry for turning features about the Z-axis.  Doing so will cause the 
lower half of your part geometry to look derformed when you generate 
other parts in the family.  Alternatively, you could also parameterize the 
lower half of your part geometry (though this would entail additional 
work).  Parameterizing geometry will be discussed in Step 5. 
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Setup PartMaker Databases 
The second step in programming a part in a family of parts is make sure the proper 
Tools, Materials and Cycles have been created and loaded in PartMaker. 

1 Open the Tools file by choosing Open Tools File from the File menu. 

2 From the Family_of_Parts directory, choose shaft_inch.tdb and click <OK>. 

 
3 Open the Cycles file by choosing Open Cycles File from the File menu. 

4 From the Family_of_Parts directory, choose shaft_inch.cdb and click <OK> 

. 

5 Open the Materials file by choosing Open Material File from the File menu. 

6 Choose st_fmstw.mdb and click <Open> 

.  
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Assign Part Features 
Once you have created your part geometry and loaded the appropriate tools, 
materials and cycles files, you are ready to assign part features to your geometry.   

 Note: When programming Families of Parts, it is important to always assign 
part features to your part by snapping to geometry instead of using the ZX 
Snap Mode.  Tool paths not associated with geometry will not be rescaled 
when updated for other parts in a part family.  

1 Before assigning the facing operation to the part, it is necessary to create 
the geometry to which the facing tool path will be assigned. To do so, while 
still in the CAD Mode, choose the Line Through Two Points and ZX Snap 
Mode.  

Now enter the ZX coordinates as shown below, pressing <Enter> after 
each: 

(0,.4) 

(<default>,0) 

After having done so, your geometry will appear as shown below: 

 
2 Click on the CAD/CAM switch to return to the CAM mode and create the 

part feature for the facing operation by choosing New Profile Group from 
the Part Features menu. 

a From the Strategy menu, choose Contouring.  

b From the Tool Location menu, select Out.  

c From the Tool Orientation menu, select Right. 

d Click the Select Tools button and allow PartMaker to select the 
appropriate tool.  

e In the field called Group Name, enter Face Off. Your dialog should now 
appear as shown below: 

 
Click Apply and Close. 
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Now that you have defined the machining operation to be used, you must tell 
PartMaker where to place the tool path: 

1 From the left-hand side of the screen select the Define Profile icon.  

2 From the top of the screen, select the End of an Element snap mode.  

3 Click your cursor at points 1 and 2 below: 

 
Your completed profile should appear as below: 

 
4 Click the Selection icon to bring yourself to a home or neutral position.  

Before moving on, save your work! Do so by selecting Save from the File menu or 
using the shortcut key <Ctrl + S>. Give your job file a name you will remember. A 
good job file name for part families is Master. 

Next, you will program the first outside diameter turning feature. 

1 Create the first OD Turning tool path by choosing a new color and selecting 
New Profile Group from the Part Features menu. 

a From the Strategy menu, choose Contouring. 

b From the Tool Location menu, select Out. 

c From the Tool Orientation menu, select Right. 

d Click the Select Tools button and allow PartMaker to select the 
appropriate tool.  

e In the field called Group Name, enter OD Turn. Your dialog should now 
appear as shown below: 
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Now that you have defined the machining operation to be used, you must tell 
PartMaker where to place the tool path: 

2 From the left-hand side of the screen select the Define Profile icon. 

3 From the top of the screen, select the End of an Element snap mode.  

4 Click your cursor at points 1,2 and 3 below: 

 
Your completed profile should appear as shown below: 

 
Next, you will program the outside diameter threading feature. 

1 Create the OD Threading tool path by choosing a new color and selecting 
New Profile Group from the Part Features menu. 

a From the Strategy menu, choose Threading. 

b From the Tool Location menu, select Out.. 

c Select Chamfer on Exit from the Toolpath Options drop dop list.  

d Specify the pitch as 0.05. 

e Click the Select Tools button and allow PartMaker to select the 
appropriate tool.  

f In the field called Group Name, enter OD Thread. Your dialog should 
now appear as shown below: 

 
2 From the left-hand side of the screen select the Define Profile icon. 

3 From the top of the screen, select the Closest Intersection snap mode.  

4 Click your cursor at points 1 and 2 below: 

 
Your completed profile should appear as shown below: 
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Next, you will program the drilled hole. 

1 Create the drilled hole by choosing a new color and selecting New Hole 
Group from the Part Features menu. 

a Uncheck the Through Hole box 

b From the Major Cycle Operation drop down menu, choose Drill 

c Enter .1 in the Diameter field 

d Enter .01 in the Chamfer field 

e Enter 1.5 in the Nominal Depth field 

f Click the Cycle button and allow PartMaker to select the appropriate 
cycle.  

Your completed Hole Group Parameters dialog should now appear as shown 
below: 

 
2 Your completed profile should appear as shown below: 

 
Next, you will program the second outside diameter turning feature. 

1 Create the second OD Turning tool path by choosing a new color and 
selecting New Profile Group from the Part Features menu. 

a From the Strategy menu, choose Contouring. 

b From the Tool Location menu, select Out. 

c From the Tool Orientation menu, select Right. 

d Click the Select Tools button and allow PartMaker to select the 
appropriate tool.  



 

B-10 PartMaker  Copyright @2014 Delcam Ltd 

 

e In the field called Group Name, enter 2nd OD Turn. Your dialog should 
now appear as shown below: 

 
2 From the left-hand side of the screen select the Define Profile icon. 

3 From the top of the screen, select the End of an Element snap mode.  

4 Click your cursor at points 1 and 2 below: 

 
Your completed profile should appear as shown below: 

 
Finally, you will program the cut-off operation. 

When creating a cut-off operation using PartMaker’s Family of Parts programming 
feature, you will need to assign the part feature to the geometry instead of having 
PartMaker do so automatically for you as you would in conventional use of the 
software. 

5 Create the Cut-off tool path by choosing a new color and selecting New 
Profile Group from the Part Features menu. 

a From the Strategy menu, choose Cut-Off 

b In the Start X Point (Xs) enter .4/2 

c Click the Select Tools button and allow PartMaker to select the 
appropriate tool.  

d In the field called Group Name, enter Cut-off.  
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Your dialog should now appear as shown below: 

 
Your completed part should appear as shown below: 

 
6 Before continuing, choose the Selection icon a delete the tool path that has 

been automatically applied to the geometry. 

7 Using the Profile icon and End Of Element Snap Mode, reapply the tool path 
to the geometry by clicking at the start and end of the cut-off tool path.  
Your completed part will appear as shown below: 
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Creating Parameter (*.prm) files 
Once you have completed programming the “master” part in the family, you must 
now take a step back and setup files containing parameter definitions for each part 
in the family. These files can be created in any word processing program and then 
saving files with *.prm extension.  In this example, Notepad (which comes loaded 
on every Windows operating system) will be used 

1 Create the first parameter for the “master” part that has already been 
programmed.   

Note:  To make creating the first parameter file faster, start by 
manipulating an existing file, either from a part family you have made 
before or from the parameter files which came standard with your 
PartMaker installation. 

2 From the Start button on your Windows desktop, choose Accessories and 
launch the Notepad application. 

3 In Notepad, from the File menu, choose Open.  In the Open dialog, choose 
All Files *.* from Files of Type as shown below: 

 
4 Choose an existing parameter file . In this example, open the file titled 42-

100_inch.prm that can be found in the Family of Parts directory (located 
in the root directory of the PartMaker module you are working with.) 
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5 Edit the parameter file to reflect the parameters being used in the current 
Family of Parts. Replace the parameter values with those you have used in 
the creation of part 50-100 above. 

 Note:  All text and characters in parenthesis are comments and will not 
affect programming.  Comments will help you remember which 
parameters correspond to various features of your part. 

Once you have defined the parameters for the part, save your Parameter File as 
50-100.prm by choosing Save As from the File menu as shown below: 

 
6 Click <Save> to save your file.  The saved parameter file for 50-100 should 

appear as shown below: 
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7 Having created the first parameter file, create a file for all other parts in the 
family by simply replacing parameter values and saving a *.prm file for each 
part in the family.  The parameter values for each part for this exercise can 
be found on page 2 of this appendix.  When finished, you should have five 
parameter files as shown below: 

 

Setup PartMaker for Parametric Input 
In order to be able to apply parametric dimensions to the part, you must enable 
Parametric Programming. 

1 Choose Preferences from the View menu and check the Parametric Input 
box as shown below: 

 
2 Once you have checked Parametric Input, click <OK>. 
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Parameterize Your Part 
Now that all the appropriate parameter files have been created, you can assign 
parametric variables to the master part in the family.  Before proceeding, make sure 
all parameter files have been saved and are closed. 

1 Click on the CAD/CAM switch to return to the CAD mode.  Any part 
parameterization exercise should always start in the CAD mode.   

2 Double click on the line segment drawn vertically along the face of the part 
as shown below: 

 
Doing so will allow you to access the Parametric Line Info dialog.  Define 
the parametric relationship as shown below: 

 
3 Once the dialog appears as above, click <OK>. 

The next geometric element to be parameterized will be the thread as shown 
below: 

 
4 Double click on the horizontal line segment along which the thread is applied 

to access the Parametric Line Info dialog.  Define the parametric 
relationship as shown below: 

 
5 Once your dialog appears as above, click <OK>. 

Note:  In PartMaker, all Z dimensions are programmed in negative. 
Whenever performing mathematical operations on parameters, always 
make sure to use parenthesis as shown here.  PartMaker observes 
standard mathematical order of operations for multiplication, division, 
addition, subtraction and the application of trigonometric functions. 
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The next geometric element to be parameterized will be the chamfer as shown 
below: 

 
6 Double click on the diagonal line segment of the chamfer to access the 

Parametric Line Info dialog.  Define the parametric relationship as shown 
below: 

 
Notice the use of the use of trigonometric relationships in Family of Parts 
programming. PartMaker data entry fields can accept trigonometric functions. 
Once your dialog appears as above, click <OK>. 

The next geometric element to be parameterized will be the largest horizontal 
diameter as shown below: 

 
7 Double click on the horizontal line segment of the OD to access the 

Parametric Line Info dialog.  Define the parametric relationship as shown 
below: 

 
8 Using the Copy and Paste functions from the Edit menu (standard windows 

accelerator keys Ctrl + C and Ctrl + V) you can copy and paste parametric 
relationships from one dialog to another. Once your dialog appears as above, 
click <OK>. 

The next geometric element to be parameterized will be the geometry along 
which the cut-off operation is defined: 
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Double click on the diagonal line segment of the chamfer to access the 
Parametric Line Info dialog.  Define the parametric relationship as shown 
below: 

 
Once your dialog appears as above, click <OK>. 

9 Click on the CAD/CAM switch to return to the CAM mode.  The 
parameterization exercise will be completed by applying parametric 
dimensions to programmed part features.   

Note: In Machining Function Face Windows of Type Turn, in the Profile 
Group Parameters dialog, Strategy types Threading and Cut-off allow 
for parametric input. In Milling Machining Function Face Window, all 
Profile Group Parameters cycles accept parametric input.  The Hole 
Group Parameters dialog also accepts parametric input. 

When using Parametric Input you will notice the appearance of Parametric 
Input icons. Clicking on these icons allows you to enter parametric data for 
part features. 

Double click on the OD Thread Group Symbol on the right hand side of the 
screen to enter the Profile Group Parameters dialog for threading as 
shown below: 

 
10 Click on the Set Parametric Pitch icon to insert a parametric value for 

Thread Pitch as shown below: 

 
11 Once your dialog appears as above, click <OK>.  Click <Close> in the 

Profile Group Parameters dialog to return to the CAM Face Window. 
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Next, parameterize the depth of the hole programmed on centerline.  To do so: 

12 Double click on the group symbol for the on-centerline drilled hole.   

 
13 Click on the Set Parametric Pitch icon to insert a parametric value for Z 

Depth as shown below: 

 
14 Once your dialog appears as above, click <OK>.  Click <Close> in the 

Profile Group Parameters dialog to return to the CAM Face Window. 
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Set Part Boundaries Parametrically 
The final step in setting up a parametric part is to set the part boundaries 
parametrically. To do so: 

1 Choose Family of Parts Programming from the Edit menu. 

2 Choose Set Parametric Boundaries… from the Family of Parts Programming 
menu as shown below: 

 
3 Complete the Set Parametric Boundaries dialog as shown below: 

 
Once the dialog appears as above, click <OK> to return to the CAM Face 
Window. 
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Update Each Part in the Family 
You have now completed setting up your master part and our now ready to 
automatically program each other part in the family.  To automatically reprogram 
other parts in the family: 

1 Choose Family of Parts Programming from the Edit menu. 

2 Choose Open Parameter File... from the Family of Parts Programming menu 
as shown below: 

 
Select the parameter file for the part you would like to program.  In this case, 
choose 50-500.prm as shown below: 

 
 Once the dialog appears as above, click <Open> to return to the CAM Face 
Window. 

3 Choose Apply Parametric Dimensions... from the Family of Parts 
Programming menu as shown below: 

 
You should now see your part change size on screen. 

Regenerate NC Code 
You can update your NC program for each part in the family by regenerating the 
Process Table and then choosing Generate NC Program. 
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Appendix C: Programming Directly on a 
Solid Model 
Introduction 

This document describes the process of programming directly on a Solid Model in 
PartMaker Turn-Mill, SwissCAM and Turn Version 9.1 and higher. 

 NOTE: The steps presented in this tutorial are carried out in PartMaker 
SwissCAM but can be used in any PartMaker application. 

Key Definitions 
Part Coordinate System (PCS):  A part coordinate system (PCS) is the coordinate 
system in which a solid model is oriented. Before any programming exercise begins, 
you should always set the PCS to be the same as the coordinate system of the 
machine you are programming.  You can use the Edit Coordinate System dialog 
to place the origin on the front of the part and set the axes to be coincident with the 
machine’s coordinate system. Being set initially the PCS should not change during 
the programming session. 

 
Face Coordinate System (FCS): This is a coordinate system with two axes in the 
Face Plane and the third axis perpendicular to the Face Plane. The Face Plane is a 
plane in which the tool paths in the active PartMaker Face Window are created. Each 
Face Window can have its own Face Plane. The Face Plane must be set in the 
correct place to properly program on the Solid Model.  The Face Plane can be 
displayed using the Show Face Plane icon. The Face Plane can be set and 
manipulated using the Define Face Plane dialog. 
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Face Plane Icons for Solid Model: 

 
Show Profiles and Holes on Solid Model: You will need to have this feature 
activated to program directly on the Solid Model. This will allow you to view the 
Profiles as they are created. 
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Solids Programming Tutorial 
This tutorial is designed to help you learn the steps to follow for using PartMaker 
SwissCAM, Turn-Mill and Turn to program on a Solid Model. 

The complete finished job files can be found in the following directories as incidated: 

SwissCAM   C:\PartMaker \PM-Swiss\Solids_Programming_Tutorial 

Turn-Mill  C:\PartMaker \PM-TM\Solids_Programming_Tutorial 

Turn  C:\PartMaker \PM-Turn\Solids_Programming_Tutorial 

How you will create the Sample part 
Here are the major steps you will follow to create the Swiss tutorial part: 

√ Start PartMaker 

√ Open Sample Program and Review 

√ View tool information for the part 

√ View cycle information for the part 

√ Select a material for the part 

√ Open a new Face Window 

√ Create Profile and Hole Groups 

√ Extract Information from the Solid Model 

√ Create a Process Table 

√ Simulate the Machining Process 

√ Generate an NC Program 
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The picture below shows the part to be programmed in this tutorial. 

 
 

 

When you complete this tutorial, you will have a part that looks like the picture 
below. 

 

Getting Started 
The machining functions used in this tutorial are as follows:  

Turn 
Use turning tools to perform a variety of turning operations including Facing, 
Threading, Grooving, Drilling, Tapping and Pick-off. 

Mill ZY 
Use an end mill to create a set of flats. 

Programming on the Solid Model can be accomplished for almost every Machining 
Function needed. In most cases you will not need to work in the 2D Face window at 
all. 

Now you will look in detail at the steps necessary to program a part. 
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Starting PartMaker 
1 Double click on the PartMaker SwissCAM icon 

2 You will see the Setup definition dialog box shown below. Click the <Close> 
button. 

This dialog is explained in greater depth starting on page 8 of this guide. 

 

View the Finished Sample 
1 Use the Open All Files Command from the File Menu. 

2 You will find the Job Files in the Follwing Directories. 

SwissCAM C:\PartMaker\PM-Swiss\Solids_Programming_Tutorial 

Turn-Mill C:\PartMaker\PM-TM\Solids_Programming_Tutorial 

Turn C:\PartMaker\PM-Turn\Solids_Programming_Tutorial 

 Note: This will also open the Sample Tools and Cycles files for you to use 
when you create your own Part. 

3 Look through the Sample Job file and familize yourself with the Profiles and 
Hole Groups. 

4 When Ready, choose New Job from the File Menu. 
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Select a Material for the Part 
The work piece in this exercise will be machined from Free Machining Stainless 
Steel, Wrought. To load this material: 

1 Choose Open Material File from the File menu. 

2 Choose st_fmstw.mdb as shown below and click <Open>. 

 
 

You have now loaded the tools, cycle, and material files that were previously 
developed for the Solid Model Programming Sample. 
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Importing a Solid Model 
1 Select the Import icon and select the X_T Parasolid Transmit Text File 

option. 

 
 

2 Choose the Swiss_Solids_Programming_Tutorial.X_T file and click <Open> 
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Setting up the First Face Window 
In this section, you will set up the Face Window for the turning operations on the 
main spindle. To do so: 

1 When Programming with a Solid Model, many items will be set automatically 
from the information obtained from the Solid Model. To import settings into 
the Set-up Window, you will need to define a faceplane. Select the Define 
Face Plane icon from the Solids Tool Bar. 

2 For Swiss and Turn-Mill parts, you should define your Face Plane at an Angle 
which will allow you to select the Points you will need for Turning in this first 
window. Check the Set Face Plane box. Choose Parallel to ZX Plane from 
the Drop Down Menu. Enter 45 into the Turning Plane Angle field and click 
the Set Boundaries checkbox. 

 
3 Click the <Preview> button to see the Face Plane on the Solid Model 

update. 

 
4 Click <OK> 
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5 Open the Set-up Window. Note the Part Length and OD were imported from 
the Solid Model. You should now make any changes required for your Setup 
dialog. Make the following changes to the Setup Dialog. 

 

Spindle: Main Spindle 

Stock: Bar 

Machining Function: Turn 

OD: 0.59055118 (For Stock Size) 

Excess Stock: .03 
 

Your Set-up Window should appears as below: 

 
6 Click <Apply> and <Close> 
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Programming a Face Operation 

1 Select the New Profile Group icon. 

2 Change the Following settings in the Profile Group Parameters dialog and 
Leads Out, Finishing dialog 

Strategy Turning 

Tool Location Face 

Tool Orientation Left 

Remove Check Roughing 

Check Finishing 

Lead Out Angle (A2) 90 Degrees (click Leads button) 

 
3 Click <Select Tools> and choose the OD Turn - 55 Turning Tool. 
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4 Name the Group Face. Your dialog should look like the following. 

 
5 Click <Apply> and <Close> 

6 You should now see a Facing Profile created on the Solid Model. 

 
7 To verify the tool path for the Profile Group, Select the Verify Work Group 

Toolpath icon. 

8 The Verify Options Dialog will now Display. Make sure to check the Option for 
Enable Verification on Solid Model. 

 
9 Once the tool path has been verified, you can hide by using the Hide Work 

Group Toolpath icon 
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Programming a Tapping Cycle Operation 
1 Choose a new color for this operation in the upper right corner of the screen 

2 Select the New Hole Group icon. 

3 Select Tap from the Type drop down menu. 

4 Click the Extract Parameters from Solid checkbox. 

 
5 Click on the Major Hole Diameter. 

 
6 Click the <Extract> button to extract the feature data from the Solid Model: 
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7 Highlight and Select the 6-40 Tap Cycle. 

 
8 Click <Apply> and <Close> 

9 To verify the Profile Group, select the Verify Work Group Toolpath icon. 

10 The Verify Options Dialog will now Display. Make sure to check the Option for 
Enable Verification on Solid Model 

11 After Verifying the Tool Path, Click the Hide Every Tool Path icon to hide all 
verifications. 
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Programming a Turning Operation 
1 Choose a new color for this operation in the upper right corner of the screen. 

2 Select the New Profile Group icon. 

3 Change the following settings in the Profile Group. 

Cycle Type Turning 

X Finish .01 

Z Finish .01 

Check Finishing 

 

 
4 Click the <Select Tools> button and choose the OD Turn - 55 Turning Tool 

for both the Roughing and Finishing Operations. 
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5 Name the Group Turn. Your dialog should look like the following. 

 
6 Click <Apply> and <Close> 

7 Select Define Profile on Solid Model icon. The model will automatically 
section itself at the Angle chosen for the Face Plane.  

8 Next, choose the Edge Endpoint Snap Mode.  This will show the selectable 
points on the Solid Model as shown here. The points are numbered for the 
following instructions. 

 
9 Select Point 1 

10 Select Point 2 

 
11 Select the Horizontal Constraint icon. 

12 Select point 3 

 
13 De-select the Horizontal Constraint icon if needed. 
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14 Select point 4 

15 Select point 5 

 
16 Select ZX Coordinates Snap Mode icon. 

17 In the input field at the bottom of the screen, enter .625 into the X and 
press the <Enter> key to accept. 

 

 
18 Select the Selection icon. 

19 To verify the Profile Group, Select the Verify Work Group Tool path icon 

20 The Verify Options Dialog will now Display. Make sure to check the Option for 
Enable Verification on Solid Model.  The verification will appear as shown 
below: 

 
21 After Verifying the Tool Path, Click the Hide Every Tool Path icon to hide all 

verifications. 
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Programming a Grooving Operation 
1 Choose a new color for this operation in the upper right corner of the screen. 

2 Select the New Profile Group icon. 

3 Change the following settings in the Profile Group. 

Strategy Grooving 

Profile Shape General 

Check Roughing 

 

 
4 Click <Select Tools> and choose the OD Groove .0625 Grooving Tool  
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5 Name the Group Groove. Your dialog should appear as shown below: 

 
6 Click the <Apply> and <Close> buttons 

7 Select the Chain Profile on Solid Model icon. 

8 Select the Start Point of the profile. When choosing start point, click on the 
side of the point that you want the Chain to follow. This will determine the 
direction the chain will follow.  

 
9 Select End Point of the profile. 
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10 To verify the Profile Group, Select the Verify Work Group Toolpath  icon 

11 The Tool Path Verification Options dialog will now display. Make sure to 
check the option to Enable Verification on Solid Model. The verification 
will appear as shown below: 

 
12 After Verifying the Tool Path, Click the Hide Every Tool Path icon to hide all 

verifications. 
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Programming a Threading Operation 
1 Choose a new color for this operation in the upper right corner of the screen 

2 Select the New Profile Group icon 

3 Change the following settings in the Profile Group. 

 

Strategy Threading 

Pitch for 1/20 .05 

Acceleration Dst .1 

 
4 Click <Select Tools> and Choose the Thread Tool. 
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5 Name the Cycle Thread. Your dialog should look like the following: 

 
6 Click the <Apply> and <Close> button  

7 Select Define Profile on Solid Model icon. 

8 Choose the Edge End Point Snap Mode icon 

9 Select the Start Point of thread 

 
10 Select Edge Midpoint Snap Mode icon 

11 Select the Horizontal Constraint icon 
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12 Select End Point from bottom of groove area. 

 
13 De-Select the Horizontal Constraint icon 

14 Select the Selection  icon 

15 To verify the Profile Group, Select the Verify Work Group Toolpath icon 

16 The Tool Path Verifications Options dialog will now display. Make sure to 
check the Option for Enable Verification on Solid Model. The verification 
will appear as shown below: 

 
17 After Verifying the Tool Path, Click the Hide Every Tool Path icon to hide all 

verifications. 
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Programming a Cut Off Operation 
1 Choose a new color for this operation in the upper right corner of the screen 

2 Select the New Profile Group icon 

3 Change the following settings in the Profile Group dialog and Leads Out, 
Roughing. 

Strategy Cut Off 

End Point X .05 

Lead Out Line Length 0 

 

 
4 Click <Select Tools> and choose the Cut Off Tool .093 
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5 Name the Cycle Cut off. Your dialog should look like the following. 

 
6 Click <Apply> and <Close> 

7 The Profile will be created for you. 

 
 

8 To verify the Profile Group, select the Verify Work Group Tool path icon 

9 The Tool Path Verifications Options dialog will now Display. Make sure to 
check the Option for Enable Verification on Solid Model. 

 
10 After Verifying the Tool Path, click the Hide Every Tool Path icon to hide all 

verifications. 
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Programming a Milling Operation 
Note: This section only applies to PartMaker Turn-Mill and SwissCAM modules 

1 Select the Setup Dialog icon, then choose <New> to make a new Face 
Window. 

2 Change the Machining Function to Mill ZY Plane. Name the window Mill 
Flats. 

 
3 Click the <Apply> and <Close> button 

4 If you have not done so already, choose the Full Part View icon from the 
Solids toolbar to make sure you have a complete solid model shown and not 
a sectional view 

5 Select the Define Face Plane icon. 

6 In the Drop down Menu, choose Parallel to Selected Surface. 

 
7 Click on one of the Flats. Note Face Plane is set coincident with the Plane of 

the chosen flat. 

 
8 Click <OK> 
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9 Choose a new color from the colors pallet in the upper right hand corner of 
the screen 

10 Select the New Profile Group icon 

11 Change the Tool Position to Left 

12 Check the Extract Parameters from Solid check box as shown below: 

 
 

13 Uncheck the Roughing box so that  Finishing is checked 

14 Enter 0.5 in the Diam(d) field and click <Select Tools> 

 
15 With the Profile Group Parameters dialog open, click on the plane as 

shown below: 

 
16 Click the <Extract> button to extract the machining parameters directly 

from the model.   

17 Rename the Group to Flats 
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18 The completed dialog will appear as shown below: 

 
19 Click the <Apply> and <Close> button. 

20 Choose the Define Profile on Solid Model icon 

21 Select the Edge Endpoint Snap Point icon 

22 Select the Start Point of the profile 

 
23 Select the End Point of the profile 
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24 Choose the Selection icon to end the profile 

 
 

25 To verify the Profile Group, select the Verify Work Group Tool path icon 

 
 

26 After Verifying the Tool Path, click the Hide Every Tool Path icon to hide all 
verifications. 
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Duplicating the Face Window 
Having programmed this milling path, you can now duplicate the window to create 
the second flat.  This can be done as follows: 

1 Open the Setup Dialog and click the <Duplicate> button 

2 Enter the following into the Duplicate Face dialog. 

Number of Copies 1 

Index Angle Increment 180 

The completed dialog should appear as shown below: 

 
3 Click <OK> 

4 Click the <Close> button to close the Setup dialog 

Generating the Process Table 
1 Choose the Generate Process Table icon 

2 Click <OK> for the Process Table Options 
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3 Your Process Table should appear as shown below: 

 

Simulating Machining in 3D 
Now that you have generated the Process Table, you can simulate the cutting of the 
part in 3D. To do so: 

1 Choose the Simulation icon to launch PartMaker’s 3D simulation 

2 Press the Start Simulation button to watch the part being machined in 3D 

3  Click the Show Finished Part icon to view the completed part: 
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Other Samples 

Turn Function Face Window Programming 
Describes Programming on a Solid Model in a Turn Function Face Window. This 
applies to PartMaker SwissCAM, TurnMill and Turn modules. 

Setting the Face Plane 
1 Open the Define Face Plane Dialog. 

 
2 Set Face Plane as required to be able to Select Points on this plane for the 

Profile. Note the features on the Part when setting and use the Preview 
button to preview the changes. 
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Creating the Profile Group 
Create Profile Group as Normal 

 
Selecting the Profile 

1 Select by choosing the Profile Points 

2 Choose the Define Profile on Solid Model Icon 

 
3 At this point you will see Red Points show on the Solid Model at the 

intersection of the Face Plane. Select these points to create your Profile. 
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4 Use the Snap Modes to choose the Profile Points on the Solid Model. 

 
5 Click on the Point to Start the Profile. 

 
6 Move the Mouse Curser to the Next Point of the Profile. There will be a 

Dotted Line indicating Profile and a Dot where next Point will be. Click to 
connect the profile to this Point. 

 
7 Continue selecting points for the Profile. 

 
8 Click the Selection icon when done. 
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Selecting by Chain 
You may chain a profile on a Solid Model by selecting the Chain Profile on Solid 
Model icon. 

To use this icon, you need to select the Starting Point and Direction.  

 Note: Depending on where you place the mouse curser, the starting point 
changes and the Direction Reverses. 

 
Select Endpoint of Chain. During Selection, a Dotted Line will indicate the Profile. 
Click the End Point to Finish Profile. 
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Using Horizontal and Vertical Constraints 
You can use the Horizontal and Vertical Constraints to Extend Profiles that may not 
have a Point to choose from on the Model. 

When selecting your Profile using the Define Profile on Solid Model icon, select 
either Horizontal or Vertical Constraint to lock the Profile in a Horizontal or 
Vertical move. 

 
1 Move the mouse curser over a Point that is not directly Horizontal or Vertical 

from the Currently Selected Point. You will see the Profile Extend to this point 
in a Horizontal or Vertical Line shown by a dashed line. 

 
2 Click the Point to Extend the Profile to this Point. 

 
3 Depress the Horizontal or Vertical Constant icon to turn off the constraint. 
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Creating a Hole Group 
1 Create New Hole Group Parameters dialog 

 
2 Check Extract Parameters from Solid. 

 
3 Select Major Cylinder for Hole on Solid Model. (Note: See Explanation at 

Bottom of Screen) 
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4 Click <Extract> 

 
Remove Check from Extract Parameters from Solid if editing of a Hole Group 
is required. 

5 Edit Hole Group as required 

6 Click <Cycle> and Select the cycle. 

 

 
7 Click <Apply> then <Close> 
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Milling Functions Face Window Programming 
Describes Programming on a Solid Model in Milling Functions Face Windows. This 
applies to PartMaker SwissCAM and Turn-Mill. 

Creating a New Profile Group (Mill ZY window shown) 
Setting the Face Plane 

1 Click the Define Face Plane icon to open the dialog. 

 
2 Choose desired method of Selecting the Face Plane. When choosing Parallel 

to Selected Surface, click on Surface to set as Face Plane. Use the Preview 
button to preview the changes. 

 

 
3 Click <OK> to accept Face Plane Setting. This will fill in the Set-up Window 

with the correct settings for the Face Plane. 
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Creating the Feature 
1 Create Profile Group as Normal 

 
2 Check Extract Parameters from Solid 
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3 Select Feature to Extract Properties from. 

 
4 Click <Extract>. This will extract the information to the Profile Group. 
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Creating the Profile 
1 Choose the Define Profile on Solid Model Icon 

 
2 Use the Snap Modes to choose the Profile Points on the Solid Model. 

 



 

C-42 PartMaker  Copyright @2014 Delcam Ltd 

 

3 Click on the Cylinder Surface to select the center point as the Start of the 
Profile. 

 
4 Move the Mouse Curser to the Next Point of the Profile. There will be a 

Dotted Line indicating Profile and a Dot where next Point will be. Click to 
connect the profile to this Point. 
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5 Continue selecting points for the Profile until finished. 

 
6 Click the Selection Icon when done. 

 

Selecting by Chain 
You can chain a Profile on a Solid Model by selecting the Chain Profile on Solid 
Model icon. 

1 Select Starting Point and Direction  

 Note: Depending on where you place the Mouse Curser, the Starting 
Point changes and the Direction Reverses. 

2 Select Endpoint of Chain. During Selection, a Dotted Line will indicate the 
Profile. Click the End Point to Finish Profile 

3 You may use Horizontal and Vertical Constraints if required. 
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Creating a Hole Group (Mill Diameter Index Face window shown) 
Setting the Face Plane 

1 Open the Define Face Plane Dialog. 

 
2 Choose desired method of selecting the Face Plane. When choosing Tangent 

to Selected Cylinder, click on the Cylinder to set as Face Plane. Use the 
<Preview> button to preview the changes. 

 

 
 

3 Click <OK> to accept Face Plane Setting. This will fill in the Set-up Window 
with the correct settings for the Face Plane. 
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Creating the Feature 
1 Create New Hole Group Parameters. 

 
2 Check Extract Parameters from Solid 

 
3 Select Major Cylinder for Hole on Solid Model. (Note: See Explanation at 

Bottom of Screen) 
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4 Click <Extract> 

 
5 Remove the check from the Extract Parameters from Solid box if editing 

of a Hole Group is required 

6 Edit Hole Group as Required 

7 Click <Cycle> and select a cycle 

 
8 Click <Apply> then <Close> 
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Selecting Single Holes 
1 Choose the Single Hole on Solid Model Icon. 

 

 
2 Select each hole that will be drilled. 
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Selecting by Chain 
1 Choose Chain Holes on Solid Model icon 

 
2 Select First Hole, PartMaker will then automatically select holes with the 

same feature in the Face Plane. 
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Appendix D: Practical Applications of 
SwissCAM Machining Function Face 
Windows for Live Tooling Operations 
Introduction 

This appendix to the PartMaker SwissCAM User Manual is intended to give you, the 
user, a more in-depth and practical understanding of applying PartMaker’s 
Machining Function Windows for use with Live Tooling Operations.  It is meant to 
supplement the information provided in Chapter 2 of your PartMaker SwissCAM 
Programming Manual titled “PartMaker Fundamentals.” 

This chapter will explain the following: 

 What types of Part Features Should be created in each Machining Function 
Face Window 

 Which Hole Group and Profile Groups Parameters options are available in 
each Machining Function Face Window 

 Which Graphics Icons are available in each Machining Function Face Window 

 How Part Features should be created in each Machining Function Face 
Window 

Many of the part examples provided in the pages to follow can be found in the 
various sub-directories labeled with machine names in the Sample Directory found 
in the Pm-Swiss directory in which PartMaker SwissCAM is installed.  The file name 
and path for each file and specific *.job, *.tdb and *.cdb are provided where 
relevant for each example. 

Machining Function Selection 
Swiss Machines are capable of performing a full set of turning operations: facing, 
turning, grooving and threading. Many Swiss Machines are also capable of 
performing various types of milling as well as drilling holes on different surfaces. 
Multiple spindles in which such operations can be performed simultaneously further 
increase the machines' productivity and complexity.  

Milling capabilities of a Swiss lathe vary significantly and can include:  

 Index milling/drilling 

 Milling on a selected ZX plane 

 Polar milling on the face of the part 

 XZC continuous milling on cylindrical surfaces  

 Milling interpolation in the YZ plane 

PartMaker CAM Software from PartMaker, Inc. applies a Patented ‘divide and 
conquer’ programming strategy to simplify programming of Swiss Type Lathes. 

PartMaker helps you separate a complicated part surface into a manageable set of 
faces that may be either planar or rotational in nature. All features are represented 
by a surface relative to which a set of part features is referenced.  

On each face, a set of features may be machined using a variety of cutting tools. 
The software takes advantage of the Microsoft Windows operating system, which 
allows multiple windows to be displayed and accessed simultaneously.  
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A specific machining function such as turning, polar milling or cylindrical milling is 
assigned to each face. PartMaker lets you create a dedicated window that contains 
a workspace for the graphic representation of face features.  

A dialog box associated with each Face Window shows you the type of machining 
to be performed on a face, the location of the face boundaries and parameters 
defining the positioning of the face relative to the machine coordinate system.  

Getting Started: The Setup Dialog 
PartMaker employs a programming methodology whereby each machine motion 
type can be separated into a different window dedicated to a specific machining 
function. Every one of these windows is known as a Face Window. Once created, 
each Face Window can be accessed from the Window menu. 

Once divided into much smaller, similar motion components, programming of a 
multi-axis Swiss-type lathe becomes a much easier task. To best explain how 
PartMaker handles this task, it is necessary to first explain how each of these 
individual-machining functions is defined.  

Selection of the various machining functions is carried out in the Setup dialog. The 
Setup dialog can be accessed from the View menu or by clicking on the shortcut to 
the Setup dialog located in the upper left hand corner of your Face Window. On 
Startup, or when accessing the Setup dialog for the first time, you will see the 
following dialog. Some of the important components of this dialog are explained 
below: 

 
1 The Main Spindle and Sub Spindle radio buttons allow you to select whether 

the programming carried out in a particular Face Window is being machined 
on the Main or Sub-Spindle. 

2 The Tool Change X and Z positions for a particular machine should be 
entered here. 

3 The Machining Function drop down menu allows you to select the type of 
machining motion being executed in a particular Face Window. The 
machining motions that can be defined in each selection from the Machining 
Function drop down menu are explained below.   
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4 The List of Face Windows displays the list of Face Windows currently 
existing for a given job. 

5 The Rename To: field allows you to name the Face Window you are 
working with. Existing Face Windows can be selected from the Window 
menu based on the names assigned to them in this field of the Setup dialog. 

6 Clicking the function buttons shown in the Setup dialog with the left-hand 
mouse button does the following: 

 

<Apply> Accepts or applies any new parameters or data 
entered into the various fields in the Setup dialog, and 
the dialog remains open. 

<New> Creates new face windows of different machining 
function types or on different spindles, adding to the 
List of Face Windows 

<Close> Accepts or applies any new parameters or data 
entered into the various fields in the Setup dialog, and 
closes the dialog. 

<Delete> Deletes the current selection from the List of Face 
Windows 

The various selections under the Machining Function drop down menu are 
explained on the following pages. 

7 The Notes fields allow the user to enter notes about a specific job. These 
notes can be directly output into the NC program to improve documentation. 
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Machining Function: Turning  
The Turn machining function uses conventional turning tools moving in the X and Z-
axes. Motion is programmed using X and Z coordinates. This machining function 
includes on centerline drilling where a drill is held stationary while the spindle 
holding the part rotates. All drilled holes must therefore be on the rotational 
centerline of the part.    

The picture below shows the appearance of the Setup dialog when performing 
Turning on the Main Spindle.  

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining  

Excess Stock (E) Rough stock left for facing on the front of the part 

Guide Bushing Length (l) 
Length of the “land area” of the guide bushing 
mechanism controlling the motion of the headstock 
through the main spindle 

Guide Bushing Dia (d) Outside diameter of the guide bushing mechanism 
controlling the motion of the headstock through 
the main spindle 
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Machining Function: Mill XY Plane  
The Mill XY Plane machining function supports machining operations on the face of 
the part using the Y-axis capability of the machine. G-code output will be generated 
in the form of X and Y coordinates. Features that can be created by using this Face 
Window include off-center holes on the face of the part, pockets on the face of the 
part, and contours (such as CAM shapes) on the face of the part. 

Programming of this machining function requires that your Swiss-type lathe have a 
programmable Y-axis and that you have purchased the PartMaker Y-axis milling 
option. 

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining  
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Types of Features Created in Mill XY Machining Function Window 
The Mill XY window uses a Z-oriented “live” tool. There is no polar C-axis movement 
(the C-axis indexes and locks). 

 Note: Your machine must have Y-axis capability and also needs to have 
ample travel to machine in the negative quadrant of the part. 

The features shown on the parts below are representative examples of features that 
can be created in the Mill XY Window.  The *.job, *.cdb and *.tdb files used to 
create some of these parts can be found in the Samples directory which was 
installed when you initially installed PartMaker SwissCAM.  Where relevant, the 
locations of these files have been provided. 

 

 

Figure 1: Milled Cam Figure 2.: Milled Cam  
(Relevant files: C:\PartMaker\Pm-
Swiss\Samples\Citizen_M\CitizenM.job, 
CitizenM.cdb, CitizenM.tdb) 

  

 

Figure 3: Off-Center Holes  
(Relevant files: C:\PartMaker\Pm-
Swiss\Samples\Star_SV\StarSV.job, 
StarSV.cdb, StarSV.tdb)

Figure 4: Milled Cam 
(Relevant files: C:\PartMaker\Pm-
Swiss\Samples\Star_SV\StarSV.job, 
StarSV.cdb, StarSV.tdb)
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Part Features Dialogs Available in Mill XY Machining Function 
Both the New Hole Group and New Profile Group commands from the Part 
Features menu can be used in the Mill XY Machining Function Face Window.  

The Hole Group Parameters dialog will appear as shown below. Notice the 
orientation of the tool is in Z. 

 

 
Through Hole Check this box if you are drilling through the 

part 

Major Cycle Operation Indicates the major cycle operation as 
specified in the cycles database 

Diameter (d) Diameter of the tool, which is the major cycle 
operation. 

Chamfer(c) Specifies how much chamfer per side is 
needed 

Z_Surf (S) Establishes your Z-zero work plane 

Z_Rapid (R) Specifies how much clearance the tool will 
rapid to in front of your Z_Surf 

Z_Clear (C) Specifies the distance between the bottom tip 
of the tool and the part surface when a tool 
starts feeding into the part. 

Nominal Depth (D) The depth of the operation to be performed 
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The Mill XY machining function can be used to create both Contours and Pockets.  
Below, a Contour Mill cycle with Tool Position On centerline is shown.  To create a 
pocket, choose Pocket Mill from Strategy drop down menu. 

 

Strategy Indicates the type of feature to be milled, either a 
Contour Mill or Pocket Mill 

Tool Position 
For Contour Mill indicates the tool position during 
cutting, such as Left (climb milling), Right 
(conventional milling) or On (on centerline milling) 

Z_Surf (S) Establishes the Z-zero work plane i.e. a value 0 
indicates the face of the part, a negative value 
indicates a Z-zero along the length of the part 

Z_Depth (D) The depth of the operation to be performed 

Z_Rapid (R) Specifies how much clearance the tool will rapid to 
in front of your Z_Surf. 

Z_Clear (C) Specifies the distance between the bottom tip of the 
tool and the part surface when a tool starts feeding 
into the part. 

Bottom Finish (b) Amount of material left on the bottom of the feature 
for the finishing end mill to remove 

Wall Finish (w) Amount of material left on the side(or wall) of the 
feature for the finishing end mill to remove when 
tool position set to Left or Right 

Roughing/Finishing Indicates whether a Roughing and/or Finishing Tool 
will be used 

Tool Entry Indicates the manner of entry of end mill into a 
feature, either Vertical, Helical, Sloped or Sloped 
Down and Return 
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Graphics Icons Available in the Mill XY Plane Machining Function 
The Mill XY Plane Machining Function Face Window uses the following icons to allow 
you to assign part features to created geometry in order to create a tool path. 

 

 

Single Hole Icon enables you to use Snap Modes to define the 
location on the geometry where a currently active Hole Group Symbol 
is to be executed. 

 

Chain Circle Icon enables you to click an enclosed circle on the 
geometry and specify that the currently active Hole Group Symbol is 
also to be automatically applied at the centers of all the other circles 
(holes) of the same size that appear on the geometry. 

 

Define Profile Icon enables you to specify that the currently active 
group symbol is to be applied to the profile described by either 
coordinate entry or by clicking on geometric elements. 

 

Chain Geometry Icon enables you to specify that the currently 
active group symbol is to be applied to a profile that is created when 
PartMaker automatically connects all the elements that form an 
unbroken chain with an initial line or arc clicked. 

 
2-Point Chain Icon enables you to specify a begin point and an end 
point to be chained together.  

 
Engrave Icon enables you to use the Engrave Data dialog box to 
create a profile containing numbers and letters. 
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Programming Example using Mill XY Plane Machining Function 
Square and Off-Center Hole on Face 
A practical programming application of the Mill XY Plane machining function has 
been provided below.  This example assumes you have a knowledge of creating part 
geometry in the PartMaker CAD mode as well as creating tools in PartMaker’s Tool’s 
Database and creating cycles in PartMaker’s Cycles Database. 

In the example given below, you will mill a ½ Inch Square with a ¼ inch End Mill 
and create a .1 diameter off-center hole. If you wish to complete this exercise on 
your own, make sure you have the following tools created in your PartMaker Tools 
Database (all tools used in the Mill XY Plane Face Window should have an 
orientation of Z Tool) 

 .25 Inch Diameter End Mill 
 .1 Inch Diameter Drill 
 Spot Drill with a diameter larger than .1 inch 

Also make sure you have cycle in PartMaker’s Cycles Database created to include 
both a .1 diameter drill and a spot drill. 

 

Features to be created: 

 

1. Mill a .5 inch square with a .25 dia end mill 

2. Spot Drill and Drill an off center hole with a 
.1 diameter drill 

Step 1. Create a Mill XY Plane Machining Function Face Window 

 Note: When creating a milled feature in PartMaker SwissCAM, you must 
always start with a turning operation.  Thus you must have a face window of 
machining function Turn created and at least one Turning part feature and 
tool path created (such as a facing operation). 

Start by creating a Mill XY Plane Machining Function Face Window.  To do so: 

1 Enter the Setup dialog by choosing Setup from the View menu or by 
clicking on the Setup dialog icon in the upper left hand corner of the screen 

2 In the Setup dialog, click the New button to create a new Machining 
Function face Window 

3 From the Machining Function drop down menu, choose Mill XY Plane 
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4 Enter the setup parameters as shown below: 

 
5 Once the Setup dialog appears as above, click on Close 

Step 2. Create Part Geometry 
Start by entering the CAD mode in the Mill XY Plane Window. Draw the following 
features: 

1 Choose Show Axes from the View Menu 

2 Choose Show Boundaries from the View Menu 

3 Draw a ½ inch square 

4 Draw a .05 inch radius circle with a center location at X<-.15> and Y<-.15> 

Your completed geometry and CAD Face Window should appear as shown below: 

 
Note: You can always go to a different Face Window in your *.job file by 
selecting from the Window menu.  Additionally, you can toggle between 
different Face Windows within the active Face Window by choosing Show 
Windows Icons from the View menu and double clicking on the icon 
representing the Window you want to view. 

Step 3. Create Part Features and assign tool paths 
Start by entering the CAM mode in the Mill XY Plane Window. First you will create 
the tool path to mill the square. To do so: 

1 From the Part Features menu, choose New Profile Group 

2 Choose Contour Mill under Strategy 
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3 Choose Left from Tool Position to indicate that climb milling will be 
performed 

4 Enter a Z_Depth of .5 

5 Enter a Tool Diameter of .25 and click Select Tools 

6 In the Group Name field, type Mill Square 

Your completed Profile Group Parameters dialog should appear as shown below: 

 
7 Assign the part feature to the square drawn earlier by clicking the Chain 

Geometry icon and clicking on the geometry to create the tool path.  It 
should appear as shown below: 
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8 From the Part Features menu, choose Verify Tool Path to see the tool path 
as shown below: 

 
9 Choose Hide Work Tool Path to hide the tool path. 

Next, you will create the off-center hole. To do so: 

1 From the Part Features menu, choose New Hole Group 

2 Uncheck the Through Hole Box 

3 Choose a Major Cycle Operation of Type: Drill 

4 Enter a Major Cycle Operation Diameter of .1 

5 Enter a Chamfer of .01 

6 Enter a Nominal Depth (D) of 0.5 

7 Click the Cycle button. 

8 In the Group Name field, type Drill_0.1 

Your completed Hole Group Parameters dialog should appear as shown below: 
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9 Assign the part feature to circle by clicking the Chain Circle icon and clicking 
on the circle representing the hole to create the tool path.  It should appear 
as shown below: 
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Machining Function: Mill ZY Plane  
The Mill ZY Plane machining function is used to perform milling interpolation in the 
ZY plane when the spindle is locked at a discreet angular position.  All motions are 
performed with a tool oriented along the machines X-axis.  

Programming of this machining function requires that your Swiss-type lathe have a 
programmable Y-axis and that you have purchased the PartMaker Y-axis milling 
option. 

 
 

Index Angle (C)  Orientation angle of the stock to achieve the 
desired face position 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining  
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Types of Features Created in Mill ZY Machining Function Window 
The Mill ZY window uses an X-oriented “live” tool. There is no polar C-axis 
movement (the C-axis indexes and locks).  This window can be used for creating 
off-center cross-holes, flats on the diameter of the part and interpolated features. 
Saw Slots should also be created in this Face Window. 

The features shown on the parts below are representative examples of features that 
can be created in the Mill ZY Window.  The *.job, *.cdb and *.tdb files used to 
create some of these parts can be found on in the in the Sample directory which 
was installed when you initially installed PartMaker SwissCAM.  Where relevant, the 
locations of these files have been provided. 

 

Figure 1.: Milled Cylinder  
(Relevant files: C:\PartMaker\Pm-
Swiss\Samples\Citizen_L\CitizenL-
Yaxis.job, CitizenL-Yaxis.cdb, CitizenL-
Yaxis.tdb) 

Figure 2.: Milled Flats  
(Relevant files: C:\PartMaker\Pm-
Swiss\Samples\Citizen_L\CitizenL.job, 
CitizenL.cdb, CitizenL.tdb) 

 
 

Figure 3: Off-Center Cross Hole  
(Relevant files: C:\PartMaker\Pm-
Swiss\Samples\Star_SV\StarSV.job, 
StarSV.cdb, StarSV.tdb)

Figure 4: Milled slot 
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Part Features Dialogs Available in Mill ZY Machining Function 
Both the New Hole Group and New Profile Group commands from the Part 
Features menu can be used in the Mill ZY Machining Function Face Window.  

The Hole Group Parameters dialog will appear as shown below. Notice the 
orientation of the tool is in X. 

 
 

Through Hole Check this box if you are drilling through the 
part 

Major Cycle Operation Indicates the major cycle operation as 
specified in the cycles database 

Diameter (d) Diameter of the tool, which is the major cycle 
operation. 

Chamfer(c) Specifies how much chamfer per side is 
needed 

X_Surf (S) Establishes your X-zero work plane on the OD 
of the part 

X_Rapid (R) Specifies how much clearance the tool will 
rapid above your X_Surf 

X_Clear (C) Specifies the distance between the bottom tip 
of the tool and the part surface when a tool 
starts feeding into the part. 

Nominal Depth (D) The depth of the operation to be performed 
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The Mill ZY machining function can be used to create both Contours and Pockets.  
Below, a Contour Mill cycle with tool motion on centerline is shown.  Cutter 
compensation can also be used by choosing Left or Right from the Tool Position 
drop down menu. 

 

 
Strategy Indicates the type of feature to be milled, either a Contour 

Mill or Pocket Mill 

Tool Position 
For Contour Mill indicates the tool position during cutting, 
such as Left (climb milling), Right (conventional milling) or 
On (on centerline milling) 

X_Surf (S) Establishes the X-zero work plane, i.e. a value 0.25 
indicates the X-zero work plane is .25 from the center of 
the part. 

X_Depth (D) The depth of the operation to be performed 

X_Rapid (R) Specifies how much clearance the tool will rapid to above 
of your X_Surf. 

X_Clear (C) Specifies the distance between the bottom tip of the tool 
and the part surface when a tool starts feeding into the 
part. 

Bottom Finish (b) Amount of material left on the bottom of the feature for 
the finishing end mill to remove 

Wall Finish (w) Amount of material left on the side (or wall) of the feature 
for the finishing end mill to remove when tool position set 
to Left or Right 

Roughing/Finishing Indicates whether a Roughing and/or Finishing Tool will be 
used 

Tool Entry Indicates the manner of entry of end mill into a feature, 
either Vertical, Helical, Sloped or Sloped Down and Return 
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Graphics Icons – Machining Functions for Mill ZY Plane  
The Machining Functions Mill ZY Plane use some or all of the following icons to allow 
you to assign part features to created geometry in order to create a tool path. 

 
Single Hole Icon enables you to use Snap Modes to define the 
location on the geometry where a currently active Hole Group 
Symbol is to be executed. 

 

Chain Circle Icon enables you to click an enclosed circle on the 
geometry and specify that the currently active Hole Group Symbol 
is also to be automatically applied at the centers of all the other 
circles (holes) of the same size that appear on the geometry. 

 
Define Profile Icon enables you to specify that the currently 
active group symbol is to be applied to the profile described by 
either coordinate entry or by clicking on geometric elements. 

 
Chain Geometry Icon enables you to specify that the currently 
active group symbol is to be applied to a profile that is created 
when PartMaker automatically connects all the elements that form 
an unbroken chain with an initial line or arc clicked. 

 
2-Point Chain Icon enables you to specify a begin point and an 
end point to be chained together.  

 
Engrave Icon enables you to use the Engrave Data dialog box to 
create a profile containing numbers and letters. 

Programming Example using the Mill ZY Plane Machining Function 
Practical programming applications of the Mill ZY Plane machining function have 
been provided below.  This example assumes you have a knowledge of creating part 
geometry in the PartMaker CAD mode as well as creating tools in PartMaker’s Tool’s 
Database and creating cycles in PartMaker’s Cycles Database. 

Example A: Creating a single flat with 2 off-center holes 
In the example given below, you will mill a flat with a ½ inch End Mill and create 
two .1 diameter off-center holes. If you wish to complete this exercise on your own, 
make sure you have the following tools created in your PartMaker Tools Database 
(all tools used in the Mill ZY Plane Face Window should have an orientation of X 
Tool) 

 .500 Inch Diameter End Mill 
 .1 Diameter Drill 
 Spot Drill with a diameter larger than .1 inch 

Also make sure you have a cycle in PartMaker’s Cycles Database created to include 
both a .1-diameter drill and a spot drill. 

 

Features to be created: 

 

1. Mill a flat with a .500 dia end mill 

2. Spot Drill and Drill two off center 
holes with a .1 diameter drill 
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Step 1. Create a Mill ZY Plane Machining Function Face Window 

 Note: When creating a milled feature in PartMaker SwissCAM, you must 
always start with a turning operation.  Thus you must have a face window of 
machining function Turn created and at least one Turning part feature and 
tool path created (such as a facing operation). 

Start by creating a Mill ZY Plane Machining Function Face Window.  To do so: 

1 Enter the Setup dialog by choosing Setup from the View menu or by 
clicking on the Setup dialog icon in the upper left hand corner of the screen 

2 In the Setup dialog, click the New button create a new Machining Function 
face Window 

3 From the Machining Function drop down menu, choose Mill ZY Plane 

4 Enter the setup parameters as shown below: 

 
Once the Setup dialog appears as above, click on Close.   

Step 2. Create Part Geometry 
Start by entering the CAD mode in the Mill ZY Plane Window. Draw the following 
features: 

1 Choose Show Axes from the View Menu 

2 Choose Show Boundaries from the View Menu 

3 Draw one line at Z<.5> to represent the end of the flat. 

4 Draw two .05-inch radius circles with a center location at Z<. 25> and Y<-
.1875> and at Z<. 25> and Y <. 1875>. 
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Your completed geometry and CAD Face Window should appear as shown below: 

 
Note: You can always go to a different Face Window in your *.job file by 
selecting from the Window menu.  Additionally, you can toggle between 
different Face Windows within the active Face Window by choosing Show 
Windows Icons from the View menu and double clicking on the icon 
representing the Window you want to view. 

Step 3. Create Part Features and Assign Tool Paths 
Start by entering the CAM mode in the Mill ZY Plane Window. First you will create 
the tool path to mill the flat. To do so: 

1 From the Part Features menu, choose New Profile Group 

2 Choose Contour Mill under Strategy 

3 Choose Left from Tool Position to indicate that climb milling will be 
performed 

4 Enter an X_Surf of .375 

5 Enter an X_Depth of .375 (we want the tool to go to center) 

6 Enter a Tool Diameter of .5 and click on Select Tools. 

7 In the Group Name field, type Mill Half. 

Your completed Profile Group Parameters dialog should appear as shown below: 
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8 Assign the part feature to the flat drawn earlier by clicking the Chain 
Geometry icon and clicking on the geometry to create the tool path.  It 
should appear as shown below: 

 
9 From the Part Features menu, choose Verify Tool Path to see the tool path 

as shown below: 

 
Choose Hide Work Tool Path to hide the tool path. 

Next, you will create the off-center holes. To do so: 

1 From the Part Features menu, choose New Hole Group 

2 Uncheck the Through Hole Box 

3 Choose a Major Cycle Operation of Type: Drill 

4 Enter a Major Cycle Operation Diameter of .1 

5 Enter a Chamfer of .01 

6 Enter a Nominal Depth (D) of 0.2 

7 Click the Cycle button. 

8 In the Group Name field, type Drill_0.1  
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Your completed Hole Group Parameters dialog should appear as shown below: 

 
1 Assign the part feature to the circles by clicking the Chain Circle icon and 

clicking on the circle representing the holes to create the tool path.  It should 
appear as shown below: 
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Example B: Creating a Saw Slot 
In the example given below, you will mill a .050 wide slot with a 1-inch Diameter 
Slot Mill. If you wish to complete this exercise on your own, make sure you have 
the following tools created in your PartMaker Tools Database (all tools used in 
the Mill ZY Plane Window should have an orientation of X Tool) 

Note: You will have needed to purchase the advanced tools option to 
create a Slotting Saw in your tools directory. 

 1 Inch Diameter Slot Mill 

Features to be created: 

 

Mill a .125 thick slot x ¼ 
deep along the face of the 
part.  

 

Step 1. Create a Mill ZY Plane Machining Function Face Window 

 Note: When creating a milled feature in PartMaker SwissCAM, you must 
always start with a turning operation.  Thus you must have a face window of 
machining function Turn created and at least one Turning part feature and 
tool path created (such as a facing operation). 

Start by creating a Mill ZY Plane Machining Function Face Window.  To do so: 

1 Enter the Setup dialog by choosing Setup from the View menu or by 
clicking on the Setup dialog icon in the upper left hand corner of the screen 

2 In the Setup dialog, click the New button to create a new Machining 
Function face Window 

3 From the Machining Function drop down menu, choose Mill ZY Plane 

4 Enter the setup parameters as shown below: 

 
Once the Setup dialog appears as above, click on Close 
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Step 2. Create Part Geometry 
Start by entering the CAD mode in the Mill ZY Plane Window. Draw the following 
features: 

1 Choose Show Axes from the View Menu 

2 Choose Show Boundaries from the View Menu 

3 Draw a line that represents the .250 depth in Z for the end of the mill slot. 

Your completed geometry and CAD Face Window should appear as shown below: 

 

 Note: You can always go to a different Face Window in your *.job file by 
selecting from the Window menu.  Additionally, you can toggle between 
different Face Windows within the active Face Window by choosing Show 
Windows Icons from the View menu and double clicking on the icon 
representing the Window you want to view. 

Step 3. Create Part Features and assign tool paths 
Start by entering the CAM mode in the Mill ZY Plane Window. First you will create 
the tool path to mill the square. To do so: 

1 From the Part Features menu, choose New Profile Group 

2 Choose Contour Mill under Strategy 

3 Choose Left from Tool Position to indicate that climb milling will be 
performed 

4 Enter an X_Depth of .4375 (X_Surf + ½ thickness of the Slotting Saw.) 

5 Enter the Tool ID of the Slotting Saw in the Tool ID box and then hit Apply. 

6 In the Group Name field, type Slotting Saw. 

7 Click on the Close Button 

Your completed Profile Group Parameters dialog should appear as shown below: 
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8 Assign the part feature to the square drawn earlier by clicking the Chain 
Geometry icon and clicking on the geometry to create the tool path.  It 
should appear as shown below: 

 
9 From the Part Features menu, choose Verify Tool Path to see the tool path 

as shown below: 

 
Choose Hide Work Tool Path to hide the tool path. 
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Machining Function: Mill ZX Plane 
The Mill ZX Plane machining function is used to perform milling in the Z and X 
planes only. Such operations typically involve following a turning profile with an end 
mill (often ball nose) with the machine spindle in a locked position.  

Programming of this machining function requires that your Swiss-type lathe have a 
programmable Y-axis and that you have purchased the PartMaker Y-axis milling 
option. 

 
 

Angle (C)  Orientation angle of the stock to achieve the 
desired face position 

Y-coord (p) Y coordinate value measuring the distance from 
the centerline of the part the tool is offset during 
machining.  This value should always be positive. 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining  
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Types of Features Created in Mill ZX Machining Function Window 
The Mill ZX window uses an X-oriented “live” tool. There is no polar C-axis 
movement (the C-axis indexes and locks).  This window is mainly used for doing 
key slots and operations that require simultaneous Z-axis and X-axis moves. 

The features shown on the parts below are representative examples of features that 
can be created in the Mill ZX Window. 

 

 
Figure 1.  Milled Slot 

 
Figure 1a. (Cross section of milled slot) 

  

 
Figure 2. Milled slot 

 
Figure2a. (Cross section of milled slot) 
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Part Features Dialogs Available in Mill ZX Machining Function 
The Mill ZX machining function can be used to create Contours only.  Below, a 
Contour Mill cycle with tool motion on centerline is shown.  Cutter compensation 
can also be used by choosing Left or Right from the Tool Position drop down 
menu. 

 Note: In the Mill ZX window you are only allowed to use a New Profile Group. 
A New Hole group and Pocket Milling are not accessible. 

 
 

Strategy Indicates the type of feature to be milled. In the Mill 
ZX Face Window this must always be set to Contour 
Mill. 

Tool Position 
For Contour Mill indicates the tool position during 
cutting, such as Left (climb milling), Right 
(conventional milling) or On (on centerline milling). 

X_Surf (S) Establishes the X-zero work plane, i.e. a value 0.25 
indicates the X-zero work plane is .25 from the center 
of the part. 

X_Rapid (R) Specifies how much clearance the tool will rapid 
above your X_Surf 
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Graphics Icons – Machining Function Mill ZX Plane 
The Machining Function Mill ZX Plane uses the following icons to allow you to assign 
part features to created geometry in order to create a tool path. 

 

 Single Hole Icon Not applicable 

 

Profile Icon enables you to specify that the currently active group 
symbol is to be applied to the profile described by either coordinate 
entry or by clicking on geometric elements.  

 

Chain Icon enables you to specify that the currently active group 
symbol is to be applied to a profile that is created when PartMaker 
automatically connects all the elements that form an unbroken 
chain with an initial line or arc clicked. 
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Programming Example using the Mill ZX Plane Machining Function 
A practical programming application of the Mill ZX Plane machining function has 
been provided below.  This example assumes you have a knowledge of creating part 
geometry in the PartMaker CAD mode as well as creating tools in PartMaker’s Tool’s 
Database and creating cycles in PartMaker’s Cycles Database. 

In the example given below, you will mill a .125 wide slot down the length of the 
part and radius out. If you wish to complete this exercise on your own, make sure 
you have the following tools created in your PartMaker Tools Database (all tools 
used in the Mill ZX Plane Face Window should have an orientation of X Tool) 

 .125 Inch Diameter End Mill 

 

 

Step 1. Create a Mill ZX Plane Machining Function Face Window 

 Note: When creating a milled feature in PartMaker SwissCAM, you must 
always start with a turning operation.  Thus you must have a face window of 
machining function Turn created and at least one Turning part feature and 
tool path created (such as a facing operation). 

Start by creating a Mill ZX Plane Machining Function Face Window.  To do so: 

1 Enter the Setup dialog by choosing Setup from the View menu or by 
clicking on the Setup dialog icon in the upper left hand corner of the screen 

2 In the Setup dialog, click the New button to create a new Machining 
Function face Window 

3 From the Machining Function drop down menu, choose Mill ZX Plane 

4 Enter the setup parameters as shown below: 

 

 

Features to be created: 

 

Slot running down the length 
of the part then radius out in 
X. 
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Step 2. Create Part Geometry 
Start by entering the CAD mode in the Mill ZX Plane Window. Draw the following 
features: 

1 Choose Show Axes from the View Menu 

2 Choose Show Boundaries from the View Menu 

3 Draw a horizontal line down the center of the part. Draw a vertical line 1 inch 
parallel to the face of the part. 

4 Choose the Fillet Icon and enter a value of .2 and click on the inside of the 
intersection you just created to generate a radius. 

Your completed geometry and CAD Face Window should appear as shown below: 

 

 Note: You can always go to a different Face Window in your *.job file by 
selecting from the Window menu.  Additionally, you can toggle between 
different Face Windows within the active face Window by choosing Show 
Windows Icons from the View menu and double clicking on the icon 
representing the Window you want to view. 

Step 3. Create Part Features and assign tool paths 
Start by entering the CAM mode in the Mill ZX Plane Window. First you will create 
the tool path to mill the slot. To do so: 

1 From the Part Features menu, choose New Profile Group 

2 Choose Contour Mill under Strategy 

3 Choose On from Tool Position to indicate that we will be milling with the 
centerline of the tool. 

4 Enter X_Surf of 0.3125 

5 Enter a Tool Diameter of 0.125 and click Select Tools 

6 In the Group Name field, type Mill Slot 
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Your completed Profile Group Parameters dialog should appear as shown below: 

 
7 Assign the part feature to the square drawn earlier by clicking the Chain 

Geometry icon and clicking on the geometry to create the tool path.  It 
should appear as shown below: 

 
8 From the Part Features menu, choose Verify Tool Path to see the tool path 

as shown below: 

 
Choose Hide Work Tool Path to hide the tool path. 
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Machining Function: Mill Polygon  
The Mill Polygon machining function allows you to create polygon shapes on the OD 
of a part using the Y-axis capability of your machine and a tool oriented along the 
X-axis of the machine. 

Programming of this machining function requires that your Swiss-type lathe have a 
programmable Y-axis and that you have purchased the PartMaker Y-axis milling 
option. 

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining  
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Types of Features Created in Mill Polygon Machining Function 
Window 
The Mill Polygon window uses an X-oriented “live” tool. There is no polar C-axis 
movement (the C-axis indexes and locks).  This window is mainly used when 
creating multiple flats like a polygon, square or a hex. This operation does use bi-
directional cutting therefore it cuts in one direction and indexes then cut in the 
opposite direction.  

The features shown on the parts below are representative examples of features that 
can be created in the Mill Polygon Window.  The *.job, *.cdb and *.tdb files used to 
create some of these parts can be found on in the in the Sample directory which 
was installed when you initially installed PartMaker SwissCAM.  Where relevant, the 
locations of these files have been provided. 

  

Figure 1.: Milled Hex 
(Relevant files: C:\PartMaker\Pm-
Swiss\Samples\Citizen_L\CitizenL.job, 
CitizenL.cdb, CitizenL.tdb) 

Figure 2.: Milled square  
(Relevant files: C:\PartMaker\Pm-
Swiss\Samples\Citizen_L\CitizenL-
Yaxis.job, CitizenL-Yaxis.cdb, CitizenL-
Yaxis.tdb) 

  

Figure 3.: Milled Hex  
(Relevant files: C:\PartMaker\Pm-
Swiss\Samples\Citizen_L\Citizen_L_Swiss.jo
b, Citizen_L_Swiss.cdb, Citizen_L_Swiss.tdb) 

Figure 4.: Milled Polygon  
(Relevant files: C:\PartMaker\Pm-
Swiss\Samples\Hardinge ST\Hardinge-
Caxis.job, Hardinge-Caxis.cdb, Hardinge-
Caxis.tdb) 
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Part Features Dialogs Available in Mill Polygon Machining Function 
The Mill Polygon machining function can be used to create flats only.  Below, a 
Profile Group parameter window is shown. In the drop down menu you pick the tool 
edge you are going to use with respect to the part.   

 Note: In the Mill Polygon window you are only allowed to use New Profile 
Group. A New Hole Group is not accessible. 

 
 

Distance From Part 
Face, To: 

Indicates placement of tool with respect to the 
part face.  The tool can be positioned with 
respect to the Left Tool Edge (P1), the Tool 
Center (P2) or the Right Tool Edge (P3).   

X_Surf (S) Establishes the X-zero work plane, i.e. a value 
0.25 indicates the X-zero work plane is .25 
from the center of the part. 

X_Rapid (R) Specifies how much clearance the tool will 
rapid above your X_Surf 

Clearance(C) Specifies the clearance amount the tool will 
position to past the barstock diameter. 

Graphics Icons – Machining Function Mill Polygon 
The machining functions for Mill Polygon uses the following icons to allow you to 
assign part features to created geometry in order to create a tool path. 

   
Define Profile Icon enables you to specify that the currently active 
group symbol is to be applied to the profile described by either 
coordinate entry or by clicking on geometric elements. 

 

Chain Geometry Icon enables you to specify that the currently 
active group symbol is to be applied to a profile that is created when 
PartMaker automatically connects all the elements that form an 
unbroken chain with an initial line or arc clicked. 
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Programming Example using the Mill Polygon Machining Function 
Milling a Hexagon 
A practical programming application of the Mill Polygon Plane machining function 
has been provided below.  This example assumes you have a knowledge of creating 
part geometry in the PartMaker CAD mode as well as creating tools in PartMaker’s 
Tool’s Database. 

In the example given below, you will mill a hexagon with a ¼ inch End Mill. If you 
wish to complete this exercise on your own, make sure you have the following tools 
created in your PartMaker Tools Database (all tools used in the Mill Polygon Face 
Window should have an orientation of X Tool) 

 .25 Inch Diameter End Mill 

 

Features to be created: 

 

Mill a hexagon with a .25 
dia end mill 

 

Step 1. Create a Mill Polygon Plane Machining Function Face Window 

 Note: When creating a milled feature in PartMaker SwissCAM, you must 
always start with a turning operation.  Thus you must have a face window of 
machining function Turn created and at least one Turning part feature and 
tool path created (such as a facing operation). 

Start by creating a Mill Polygon Plane Machining Function Face Window.  To do so: 

1 Enter the Setup dialog by choosing Setup from the View menu or by 
clicking on the Setup dialog icon in the upper left hand corner of the screen 

2 In the Setup dialog, click the New button create a new Machining Function 
face Window 

3 From the Machining Function drop down menu, choose Mill Polygon  

4 Enter the setup parameters as shown below: 

 
Once the Setup dialog appears as above, click on Close 
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Step 2. Create Part Geometry 
Start by entering the CAD mode in the Mill Polygon Window. Draw the following 
features: 

1 Choose Show Axes from the View Menu 

2 Choose Show Boundaries from the View Menu 

3 Choose the Hexagon Icon and enter .25 for the Center to Flat Distance 

Your completed geometry and CAD Face Window should appear as shown below: 

 

 Note: You can always go to a different Face Window in your *.job file by 
selecting from the Window menu.  Additionally, you can toggle between 
different Face Windows within the active face Window by choosing Show 
Windows Icons from the View menu and double clicking on the icon 
representing the Window you want to view. 

Step 3. Create Part Features and assign tool paths 
Start by entering the CAM mode in the Mill Polygon Window. First you will create the 
tool path to mill the hexagon. To do so: 

1 From the Part Features menu, choose New Profile Group 

2 Choose Left Tool Edge (P1) under Distance From Part Face 

3 Enter 0.2 For the P1 value 

4 Enter a Tool Diameter of .25 and click Select Tools 

5 In the Group Name field, type Mill Polygon 

Your completed Profile Group Parameters dialog should appear as shown below: 
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6 Assign the part feature to the square drawn earlier by clicking the Chain 
Geometry icon and clicking on the geometry to create the tool path.  It 
should appear as shown below: 

 
7 From the Part Features menu, choose Verify Tool Path to see the tool path 

as shown below: 

 
Choose Hide Work Tool Path to hide the tool path. 
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Machining Function: Mill End, Index  
The Mill End, Index machining functon is used when drilling holes and milling slots 
on the end face of the part. The holes are located in the XY plane and oriented 
along the Z-axis.  

The shapes that can be created with this machining function are:  

 Holes in the end of the work created by Z-axis feed. This motion type supports 
off-center drilling on the end of the part, using C-axis indexing and X-axis 
positioning to locate the hole position.  

 Radial slots which are milled using C-axis indexing to position and hold the part 
while X-axis motion is used to cut the part. The tool would be a milling tool 
oriented along the Z-axis. 

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before machining 

ID Starting inside diameter of bar stock before machining  
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Types of Features Created in Mill End Index Machining Function 
Window 
The MILL END INDEX window uses a Z-oriented “live” tool. There is no polar C-axis 
movement (the C-axis indexes and locks).  This window is mainly used for doing 
any number of holes or slots using a Z-oriented tool.  

The features shown on the parts below are representative examples of features that 
can be created in the MILL END INDEX window 
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Part Features Dialogs Available in Mill End Index Machining Function 
Both the New Hole Group and New Profile Group commands from the Part 
Features menu can be used in the Mill End Index Machining Function Face 
Window.  

The Hole Group Parameters dialog will appear as shown below. Notice the 
orientation of the tool is in Z. 

 
 

Through Hole Check this box if you are drilling through the 
part 

Major Cycle Operation Indicates the major cycle operation as 
specified in the cycle’s database 

Diameter (d) Diameter of the tool, which is the major cycle 
operation 

Chamfer(c) Specifies how much chamfer per side is 
needed 

Z_Surf (S) 
Establishes your Z-zero work plane 

 

Z_Rapid (R) Specifies how much clearance the tool will 
rapid to in front of your Z_Surf 

Z_Clear (C) 
Specifies the distance between the bottom tip of 
the tool and the part surface when a tool starts 
feeding into the part. 

 Inclination Angle 
Specifies the angle of the tool when making 
inclined holes (you must have a “B” axis or an 
angled attachment.) 

Nominal Depth (D) The depth of the operation to be performed 
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The Mill End Index machining function can be used to create Contours only.  Below, 
a Contour Mill cycle with tool motion on centerline is shown. 

 

 
Strategy Indicates the type of feature to be milled 

is a Contour Mill  

Tool Position 
For Contour Mill indicates the tool 
position during cutting, On (on centerline 
milling) 

Z_Surf (S) Establishes the Z-zero work plane i.e. a 
value 0 indicates the face of the part, a 
negative value indicates a Z-zero along 
the length of the part 

Z_Depth (D) The depth of the operation to be 
performed 

Z_Rapid (R) Specifies how much clearance the tool 
will rapid to in front of your Z_Surf. 

Z_Clear (C) Specifies the distance between the bottom tip 
of the tool and the part surface when a tool 
starts feeding into the part. 

Bottom Finish (b) Amount of material left on the bottom of 
the feature for the finishing end mill to 
remove 

Roughing/Finishing Indicates whether a Roughing and/or 
Finishing Tool will be used 

Tool Entry Does not apply to the Mill End Index 
machining function 
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Graphics Icons – Machining Functions Mill End Index  

 
Single Hole Icon enables you to use Snap Modes to define the 
location on the geometry where a currently Hole Group Symbol is to 
be executed. 

 
Chain Circle Icon enables you to click an enclosed circle on the 
geometry and specify that the currently active Hole Group Symbol is 
also to be automatically applied at the centers of all the other circles 
(holes) of the same size that appear on the geometry. 

 
Profile Icon enables you to specify that the currently active group 
symbol is to be applied to the profile described by either coordinate 
entry or by clicking on geometric elements.  When performing 
indexing operations, the Profile Icon may only join two points during 
its usage. 

 
Chain Icon enables you to specify that the currently active group 
symbol is to be applied to a profile that is created when PartMaker 
automatically connects all the elements that form an unbroken chain 
with an initial line or arc clicked. When performing indexing 
operations, the Chain Icon may only join two points during its usage. 

The Machining Functions Mill End Index uses the following icons to allow you to 
assign part features to created geometry in order to create a tool path. 

Programming Example using the Mill End Index Machining Function 
Bolt Hole Pattern on the Face 
A practical programming application of the Mill End Index machining function has 
been provided below.  This example assumes you have a knowledge of creating part 
geometry in the PartMaker CAD mode as well as creating tools in PartMaker’s Tool’s 
Database and creating cycles in PartMaker’s Cycles Database. 

In the example given below, you will drill  six .125 diameter holes on the face of the 
part. If you wish to complete this exercise on your own, make sure you have the 
following tools created in your PartMaker Tools Database (all tools used in the Mill 
End Index Face Window should have an orientation of Z Tool) 

 .125 Inch Diameter Drill 
 Spot Drill with a diameter larger than .125 inch 

Also make sure you have cycle in PartMaker’s Cycles Database created to include 
both a .125-inch drill and a spot drill. 

 

 

Features to be created: 
 
Spot Drill and Drill (6) holes with a .125 
diameter drill 
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Step 1. Create a Mill End Index Machining Function Face Window 

 Note: When creating a milled feature in PartMaker SwissCAM, you must 
always start with a turning operation.  Thus you must have a face window of 
machining function Turn created and at least one Turning part feature and 
tool path created (such as a facing operation). 

Start by creating a Mill End Index Machining Function Face Window.  To do so: 

1 Enter the Setup dialog by choosing Setup from the View menu or by 
clicking on the Setup dialog icon in the upper left hand corner of the screen 

2 In the Setup dialog, click the New button create a new Machining Function 
face Window 

3 From the Machining Function drop down menu, choose Mill End Index 

4 Enter the setup parameters as shown below: 

 
Once the Setup dialog appears as above, click on Close 

Step 2. Create Part Geometry 
Start by entering the CAD mode in the Mill End Index Window. Draw the following 
features: 

1 Choose Show Axes from the View Menu 

2 Choose Show Boundaries from the View Menu 

3 Draw a .0625 inch radius circle with a center location at X<-.2> and Y<0> 

4 Choose the Rotate command and make 5 copies and rotate about the X<0> 
and Y<0>. 
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Your completed geometry and CAD Face Window should appear as shown below: 

 
Note: You can always go to a different Face Window in your *.job file by 
selecting from the Window menu.  Additionally, you can toggle between 
different Face Windows within the active face Window by choosing Show 
Windows Icons from the View menu and double clicking on the icon 
representing the Window you want to view. 

Step 3. Create Part Features and assign tool paths 
Start by entering the CAM mode in the Mill End Index Window. First you will create 
the 0.125 Boltholes, to do so: 

1 From the Part Features menu, choose New Hole Group 

2 Uncheck the Through Hole Box 

3 Choose a Major Cycle Operation of Type: Drill 

4 Enter a Major Cycle Operation Diameter of .125 

5 Enter a Chamfer of .01 

6 Enter a Nominal Depth (D) of 0.450 

7 Click the Cycle button. 
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Your completed Hole Group Parameters dialog should appear as shown below: 

 
8 Assign the part feature to circle by clicking the Chain Circle icon and clicking 

on the circle representing the hole to create the tool path.  It should appear 
as shown below: 
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Machining Function: Mill Diam, Index  
The Mill Diam, Index machining function allows you  to create “cross holes” or radial 
slots on the OD of the part.  In order to support this machining function, your 
Swiss-type lathe must be able to support C-axis indexing, which may not be 
performed while the tool is in contact with the work.  

This machining function supports the following features cut on the outside diameter 
of the work using a tool oriented along the machine's X-axis:  

 Slots oriented along the length (Z-axis) of the stock. 

 Holes drilled anywhere along the cylinder except the end of the stock. 

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining 
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Types of Features Created in Mill Diam, Index Machining Function 
Window 
The Mill Diam, Index window uses a X-oriented “live” tool. There is no polar C-axis 
movement (the c-axis indexes and locks).  This window is mainly used for doing any 
number of holes or slots using a X-oriented tool.  

The features shown on the parts below are representative examples of features that 
can be created in the Mill Diam, Index window. 
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Part Features Dialogs Available in Mill Diam, Index Machining Function 
Both the New Hole Group and New Profile Group commands from the Part 
Features menu can be used in the Mill Diam, Index Machining Function Face 
Window.  

The Hole Group Parameters dialog will appear as shown below. Notice the 
orientation of the tool is in X. 

 

 
Through Hole Check this box if you are drilling through the 

part 

Major Cycle Operation Indicates the major cycle operation as 
specified in the cycle’s database. 

Diameter (d) Diameter of the tool, which is the major cycle 
operation. 

Chamfer(c) Specifies how much chamfer per side is 
needed 

X_Surf (S) Establishes your X-zero work plane. 

X_Rapid (R) Specifies how much clearance the tool will 
rapid to in front of your X_Surf. 

X_Clear (C) Specifies the distance between the bottom tip 
of the tool and the part surface when a tool 
starts feeding into the part. 

Nominal Depth (D) The depth of the operation to be performed 
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The Mill Diam,Index machining function can be used to create Contours only.  
Below, a Contour Mill cycle with tool motion on centerline is shown. 

 
 

Strategy Indicates the type of feature to be milled is a 
Contour Mill  

Tool Position For Contour Mill indicates the tool position during 
cutting, On (on centerline milling) 

X_Surf (S) 
Establishes the X-zero work plane, i.e. a value 
0.25 indicates the X-zero work plane is .25 from 
the center of the part. 

X_Depth (D) The depth of the operation to be performed 

X_Rapid (R) Specifies how much clearance the tool will rapid to 
above your X_Surf. 

X_Clear (C) 
Specifies the distance between the bottom tip of 
the tool and the part surface when a tool starts 
feeding into the part. 

Bottom Finish (b) Amount of material left on the bottom of the 
feature for the finishing end mill to remove 

Roughing/Finishing Indicates whether a Roughing and/or Finishing 
Tool will be used 

Tool Entry Does not apply to the Mill Diam, Index machining 
function 
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Graphics Icons – Machining Functions for Mill Diam, Index 
The Machining Functions for Mill Diam, Index uses the following icons to allow you 
to assign part features to created geometry in order to create a tool path. 

 

 

Single Hole Icon enables you to use Snap Modes to define the 
location on the geometry where a currently Hole Group Symbol is 
to be executed. 

 

Chain Circle Icon enables you to click an enclosed circle on the 
geometry and specify that the currently active Hole Group Symbol 
is also to be automatically applied at the centers of all the other 
circles (holes) of the same size that appear on the geometry. 

 

Profile Icon enables you to specify that the currently active group 
symbol is to be applied to the profile described by either 
coordinate entry or by clicking on geometric elements.  When 
performing indexing operations, the Profile Icon may only join two 
points during its usage. 

 

Chain Icon enables you to specify that the currently active group 
symbol is to be applied to a profile that is created when PartMaker 
automatically connects all the elements that form an unbroken 
chain with an initial line or arc clicked. When performing indexing 
operations, the Chain Icon may only join two points during its 
usage. 



 

Copyright @2014 Delcam Ltd  User Guide D-53  

 

Programming Example using Mill Diameter Index Machining 
Function 
Creating Cross holes 
A practical programming application of the Mill Diameter Index machining function 
has been provided below.  This example assumes you have a knowledge of creating 
part geometry in the PartMaker CAD mode as well as creating tools in PartMaker’s 
Tool’s Database and creating cycles in PartMaker’s Cycles Database. 

In the example given below, you will Drill six holes with a .125 diameter drill. If you 
wish to complete this exercise on your own, make sure you have the following tools 
created in your PartMaker Tools Database (all tools used in the Mill Diameter Index 
Face Window should have an orientation of X Tool). 

 .125 Inch Diameter Drill 
 Spot Drill with a diameter larger than .125 inch 

Also make sure you have cycle in PartMaker’s Cycles Database created to include 
both a .125-inch drill and a spot drill. 

 

Features to be created: 
 

Spot Drill and Drill six holes on 
diameter with a .125 diameter drill

 

Step 1. Create a Mill Diameter Index Machining Function Face Window 

 Note: When creating a milled feature in PartMaker, you must always start 
with a turning operation.  Thus you must have a face window of machining 
function Turn created and at least one Turning part feature and tool path 
created (such as a facing operation). 

Start by creating a Mill Diam, Index Machining Function Face Window.  To do so: 

1 Enter the Setup dialog by choosing Setup from the View menu or by 
clicking on the Setup dialog icon in the upper left hand corner of the screen 

2 In the Setup dialog, click the New button to create a new Machining 
Function face Window 

3 From the Machining Function drop down menu, choose Mill Diam, Index 

4 Enter the setup parameters as shown below: 
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Step 2. Create Part Geometry 
Start by entering the CAD mode in the Mill Diam, Index Window. Draw the following 
features: 

1 Choose Show Axes from the View Menu 

2 Choose Show Boundaries from the View Menu 

3 Draw a .0625-inch radius circle with a center location at Z<. 25. > and 
C<0>. 

4 Click on the Selection Icon and click on the circle you just created. 

5 Choose Translate from the Edit Menu and make 5 more copies, Z distance 
is 0 and C Distance of 60 degrees. 

Your completed geometry and CAD Face Window should appear as shown 
below: 

 

 Note: You can always go to a different Face Window in your *.job file by 
selecting from the Window menu.  Additionally, you can toggle between 
different Face Windows within the active Face Window by choosing Show 
Windows Icons from the View menu and double clicking on the icon 
representing the Window you want to view. 
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Step 3. Create Part Features and assign tool paths 
Start by entering the CAM mode in the Mill Diam, Index Window. First you will 
create the tool path to drill the cross holes. To do so: 

1 From the Part Features menu, choose New Hole Group 

2 Uncheck the Through Hole Box 

3 Choose a Major Cycle Operation of Type: Drill 

4 Enter a Major Cycle Operation Diameter of .125 

5 Enter a Chamfer of .01 

6 Enter a Nominal Depth (D) of 0.3125 

7 Click the Cycle button. 

Your completed Hole Group Parameters dialog should appear as shown 
below: 

 
8 Assign the part feature to circle by clicking the Chain Circle icon and clicking 

on the circles representing the holes to create the tool path.  It should 
appear as shown below: 
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Machining Function: Mill End, Polar  
The Mill End, Polar machining function allows you to perform polar interpolation on 
the face of the part. This machining function assumes that the Swiss-type lathe has 
the ability to perform simultaneous feed motions with the X, Z and C-axes.  

The following rules apply to Mill End, Polar:  

 Tools must be oriented along the machine’s Z-axis.  

 Shapes created must not pass, or if extended, pass through the center of 
rotation of the stock (X=0). For example, the radial slots that are 
programmable in Mill End, Index may NOT be programmed using Mill End, 
Polar. Also, any arc move that intersects the X=0 center is NOT allowed to 
be programmed using this machining function. 

Programming of this machining function requires that your Swiss-type lathe has a 
programmable C-axis and that you have purchased the PartMaker C-axis milling 
option. 

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining  
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Types of Features Created in Mill End, Polar Machining Function 
Window 
The MILL END, POLAR window uses a Z-oriented “live” tool. There is polar C-Axis 
movement (the C-Axis does not lock).  This window is mainly used for milling 
profiles and pockets on the face of the part. 

The features shown on the parts below are representative examples of features that 
can be created in the MILL END, POLAR window.  The *.job, *.cdb and *.tdb files 
used to create some of these parts can be found on in the in the Sample directory 
which was installed when you initially installed PartMaker SwissCAM.  Where 
relevant, the locations of these files have been provided. 

 

  

Figure 1. Milled slot 
(Relevant files: C:\PartMaker\Pm-
Swiss\Samples\Star_SV\StarSV.job, 
StarSV.cdb, StarSV.tdb) 

Figure 2. Milled Cam 
(Relevant files: C:\PartMaker\Pm-
Swiss\Samples\Citizen_M\CitizenM.job, 
CitizenM.cdb, CitizenM.tdb) 

  

  

Figure 3. Milled Cam 
(Relevant files: C:\PartMaker\Pm-
Swiss\Samples\Hardinge_ST\Hardinge-
Caxis.job, Hardinge-Caxis.cdb, Hardinge-
Caxis.tdb) 

Figure 4. Milled Pocket on the face 
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Part Features Dialogs Available in Mill End, Polar Machining Function 
The Mill End, Polar machining function can be used to create both Contours and 
Pockets.  Below, a Contour Mill cycle with tool motion on centerline is shown. If you 
wish to create a pocket, choose Pocket Mill from Strategy drop down menu.  Cutter 
compensation can also be used by choosing Left or Right from the Tool Position 
drop down menu. 

 Note: In the Mill End, Polar window you are only allowed to use a New Profile 
Group. New Hole group is not accessible. 

 
 

Strategy Indicates the type of feature to be milled, either a Contour Mill 
or Pocket Mill 

Tool Position For Contour Mill indicates the tool position during cutting, such 
as Left (climb milling), Right (conventional milling) or On (on 
centerline milling) 

Z_Surf (S) Establishes the Z-zero work plane i.e. a value 0 indicates the 
face of the part, a negative value indicates a Z-zero along the 
length of the part 

Z_Depth (D) The depth of the operation to be performed 

Z_Rapid (R) Specifies how much clearance the tool will rapid to in front of 
your Z_Surf. 

Z_Clear (C) Specifies the distance between the bottom tip of the tool and 
the part surface when a tool starts feeding into the part. 

Bottom Finish (b) Amount of material left on the bottom of the feature for the 
finishing end mill to remove 

Wall Finish (w) Amount of material left on the side (or wall) of the feature for 
the finishing end mill to remove when tool position set to Left 
or Right 

Roughing/Finishing Indicates whether a Roughing and/or Finishing Tool will be used

Tool Entry Indicates the manner of entry of end mill into a feature, either 
Vertical, Helical, Sloped or Sloped Down and Return 
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Graphics Icons Available in the Mill End, Polar Machining Function 
The Machining Function Mill End, Polar, uses the following icons to allow you to 
assign part features to created geometry in order to create a tool path. 

 

 
Define Profile Icon enables you to specify that the currently active 
group symbol is to be applied to the profile described by either 
coordinate entry or by clicking on geometric elements. 

 
Chain Geometry Icon enables you to specify that the currently 
active group symbol is to be applied to a profile that is created when 
PartMaker automatically connects all the elements that form an 
unbroken chain with an initial line or arc clicked. 

 
2-Point Chain Icon enables you to specify a begin point and an end 
point to be chained together.  

 
Engrave Icon enables you to use the Engrave Data dialog box to 
create a profile containing numbers and letters. 

Programming Example using the Mill End, Polar Machining Function 
Creating a Pocket on the Face of the Part 
A practical programming application of the Mill End, Polar machining function has 
been provided below.  This example assumes you have a knowledge of creating part 
geometry in the PartMaker CAD mode as well as creating tools in PartMaker’s Tool’s 
Database and creating cycles in PartMaker’s Cycles Database. 

In the example given below, you will mill a Square Pocket .400 from side to side 
with a .08 diameter End Mill. If you wish to complete this exercise on your own, 
make sure you have the following tools created in your PartMaker Tools Database 
(all tools used in the Mill End, Polar Face Window should have an orientation of Z 
Tool) 

 .080 Diameter End Mill 

 

Features to be created: 

 

Mill a square pocket with a .080 
dia. end mill 

 

Step 1. Create a Mill End, Polar Machining Function Face Window 

 Note: When creating a milled feature in PartMaker SwissCAM, you must 
always start with a turning operation.  Thus you must have a face window of 
machining function Turn created and at least one Turning part feature and 
tool path created (such as a facing operation). 

Start by creating a Mill End, Polar Machining Function Face Window.  To do so: 

1 Enter the Setup dialog by choosing Setup from the View menu or by 
clicking on the Setup dialog icon in the upper left hand corner of the screen 
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2 In the Setup dialog, click the New button create a new Machining Function 
face Window 

3 From the Machining Function drop down menu, choose Mill End, Polar 

 
4 Once the Setup dialog appears as above, click on Close 

Step 2. Create Part Geometry 
Start by entering the CAD mode in the Mill End, Polar Window. Draw the following 
features: 

1 Choose Show Axes from the View Menu 

2 Choose Show Boundaries from the View Menu 

3 Draw a square that is .400 from flat to flat. 

4 Draw a .0625 inch radius using the Fillet Icon to round off each corner 

Your completed geometry and CAD Face Window should appear as shown 
below: 

 

 Note: You can always go to a different Face Window in your *.job file by 
selecting from the Window menu.  Additionally, you can toggle between 
different Face Windows within the active face Window by choosing Show 
Windows Icons from the View menu and double clicking on the icon 
representing the Window you want to view. 
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Step 3. Create Part Features and assign tool paths 
Start by entering the CAM mode in the Mill End, Polar Window. First you will create 
the tool path to mill the square. To do so: 

1 From the Part Features menu, choose New Profile Group 

2 Choose Pocket Mill under Strategy 

3 Choose Spiral for the type of pocket to be performed 

4 Enter a Z_Depth of 0.25 

5 Enter a Tool Diameter of .08 for the Roughing and Finishing and click Select 
Tools 

6 In the Group Name field, type Mill Pocket 

Your completed Profile Group Parameters dialog should appear as shown 
below: 

 
7 Assign the part feature to the square drawn earlier by clicking the Chain 

Geometry icon and clicking on the geometry to create the tool path.  It 
should appear as shown below: 
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8 From the Part Features menu, choose Verify Tool Path to see the tool path 
as shown below: 

 
Choose Hide Work Tool Path to hide the tool path. 
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Machining Function: Mill Diam, Polar  
The Mill Diam, Polar machining function supports polar milling anywhere on the 
stock using an X-axis oriented milling tool. This machining function assumes that 
your Swiss-type lathe has the ability to perform simultaneous feed motions with the 
X, Z and C-axes. The Mill Diam, Polar machining function is most commonly used to 
machine polygon features on the OD of the part using continuous C-axis feed.  
Programming of this type in Face Windows is carried out in much the same 
manner as the Mill Polygon machining function. 

Programming of this machining function requires that your Swiss-type lathe has a 
programmable C-axis and that you have purchased the PartMaker C-axis milling 
option. 

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock before 
machining 

ID Starting inside diameter of bar stock before 
machining  
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Types of Features Created in Mill Diam Polar Machining Function 
Window 
The Mill Diam Polar window uses an X-oriented “live” tool. There is polar C-axis 
movement (the C-axis does not lock).  The Mill Diam Polar window is not a 
commonly used window; it is typically used in Surface Machining applications.  
Please see the manual on using PartMaker’s Surface Machining Wizard for more 
information. 

Part Features Dialogs Available in Mill Diam Polar Machining Function  
The Mill Diam Polar machining function can be used to create flats. Below, a Profile 
Group parameter window is shown.   

 Note: In the Mill Diam Polar window you are only allowed to use New Profile 
Group. A New Hole Group is not accessible, 

 
 

Distance From 
Part Face, To: 

Indicates placement of tool with respect to the part face.  
The tool can be positioned with respect to the Left Tool 
Edge (P1), the Tool Center (P2) or the Right Tool Edge 
(P3).   

X_Surf (S) Establishes the X-zero work plane, i.e. a value 0.25 
indicates the X-zero work plane is .25 from the center of 
the part. 

X_Rapid (R) Specifies how much clearance the tool will rapid above 
your X_Surf 

Clearance(C) Specifies the clearance amount the tool will position past 
the barstock diameter. 
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Graphics Icons – Machining Functions for Mill Diam Polar  
The Machining Functions, Mill Diam Polar use some or all of the following icons to 
allow you to assign part features to created geometry in order to create a tool path. 

 

Define Profile Icon enables you to specify that the currently 
active group symbol is to be applied to the profile described by 
either coordinate entry or by clicking on geometric elements. 

 

Chain Geometry Icon enables you to specify that the 
currently active group symbol is to be applied to a profile that 
is created when PartMaker automatically connects all the 
elements that form an unbroken chain with an initial line or arc 
clicked. 

 
2-Point Chain Icon enables you to specify a begin point and 
an end point to be chained together.  
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Machining Function: Mill Cylinder 
The Mill Cylinder machining function supports continuous milling on the outside 
diameter of the part.  Cylindrical milling assumes that your Swiss-type lathe has the 
ability to simultaneously feed in the X, Z and C axes. 

Using motions of this type, combined with a tool oriented along the X axis of the 
machine, profiles can be created on the outside diameter of the stock. 

Tool positioning is programmed using X, Z, and C axis coordinates.  The C position 
is programmed in terms of degrees of rotation relative to machine C=0 which is 
clearly shown in the graphic below. 

Programming of this machining function requires that your Swiss-type lathe has a 
programmable C-axis and that you have purchased the PartMaker C-axis milling 
option. 

 
 

Length (L) Length of the finished part 

OD Diameter of the surface to be machined 

ID Starting inside diameter of bar stock before 
machining  
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Types of Features Created in Mill Cylinder Machining Function 
Window 
The Mill Cylinder window uses an X-oriented “live” tool. There is polar C-axis 
movement (the C-axis does not lock).  This window is mainly used for doing 
contoured pockets and or slots as well as engraving.   

The features shown on the parts below are representative examples of features that 
can be created in the Mill Cylinder window.  The *.job, *.cdb and *.tdb files used to 
create some of these parts can be found on in the in the Sample directory which 
was installed when you initially installed PartMaker SwissCAM.  Where relevant, the 
locations of these files have been provided. 

 

  

Figure 1. J-Slot 
(Relevant files: C:\PartMaker\Pm-
Swiss\Samples\Hardinge_ST\HardingeS
T.job, HardingeST.cdb, HardingeST.tdb) 

Figure 2. Engraving 
(Relevant files: C:\PartMaker\Pm-
Swiss\Samples\Hardinge_ST\Hardinge-Caxis.job, 
Hardinge-Caxis.cdb, Hardinge-Caxis.tdb) 
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Part Features Dialogs Available in Mill Cylinder Machining Function 
The Mill Cylinder machining function can be used to create Contours, Pockets and 
Lettering on the outside diameter.  Below, a Contour Mill cycle with tool motion on 
centerline is shown.  Cutter compensation can also be used by choosing Left or 
Right from the Tool Position drop down menu. 

 
 

Strategy Indicates the type of feature to be milled, either a 
Contour Mill or Pocket Mill 

Tool Position 

For Contour Mill indicates the tool position during 
cutting, such as Left (climb milling), Right 
(conventional milling) or On (on centerline 
milling) 

X_Surf (S) Establishes the X-zero work plane, i.e. a value 
0.25 indicates the X-zero work plane is .25 from 
the center of the part. 

X_Depth (D) The depth of the operation to be performed 

X_Rapid (R) Specifies how much clearance the tool will rapid 
to above your X_Surf. 

X_Clear (C) Specifies the distance between the bottom tip of 
the tool and the part surface when a tool starts 
feeding into the part. 

Bottom Finish (b) Amount of material left on the bottom of the 
feature for the finishing end mill to remove 

Wall Finish (w) Amount of material left on the side (or wall) of 
the feature for the finishing end mill to remove 
when tool position set to Left or Right 

Roughing/Finishing Indicates whether a Roughing and/or Finishing 
Tool will be used 

Tool Entry Indicates the manner of entry of end mill into a 
feature, either Vertical, Helical, Sloped or Sloped 
Down and Return 
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Graphics Icons-Machining Functions for Mill Cylinder 
The Machining Functions for Mill Cylinder use some or all of the following icons to 
allow you to assign part features to created geometry in order to create a tool path. 

 

 

Define Profile Icon enables you to specify that the currently active 
group symbol is to be applied to the profile described by either 
coordinate entry or by clicking on geometric elements. 

 

Chain Geometry Icon enables you to specify that the currently 
active group symbol is to be applied to a profile that is created when 
PartMaker automatically connects all the elements that form an 
unbroken chain with an initial line or arc clicked. 

 
2-Point Chain Icon enables you to specify a begin point and an end 
point to be chained together.  

 
Engrave Icon enables you to use the Engrave Data dialog box to 
create a profile containing numbers and letters. 

Programming Examples using the Mill Cylinder Machining Function 
A practical programming application of the Mill Cylinder machining function has 
been provided below.  This example assumes you have a knowledge of creating part 
geometry in the PartMaker CAD mode as well as creating tools in PartMaker’s Tool’s 
Database and creating cycles in PartMaker’s Cycles Database. 

Example A: Engraving on the Outside Diameter 
In the example given below, you will engrave the words “PartMaker” with a ¼ inch 
Spot Drill. If you wish to complete this exercise on your own, make sure you have 
the following tools created in your PartMaker Tools Database (all tools used in the 
Mill Cylinder Face Window should have an orientation of X Tool) 

 .25 Inch Spot Drill 

 

Features to be created: 
 

Engraving with the words 
“PARTMAKER” on theOutside 
Diameter 

 

Step 1. Create a Mill Cylinder Machining Function Face Window 

 Note: When creating a milled feature in PartMaker SwissCAM, you must 
always start with a turning operation.  Thus you must have a face window of 
machining function Turn created and at least one Turning part feature and 
tool path created (such as a facing operation). 

Start by creating a Mill Cylinder Machining Function Face Window.  To do so: 

1 Enter the Setup dialog by choosing Setup from the View menu or by 
clicking on the Setup dialog icon in the upper left hand corner of the screen 

2 In the Setup dialog, click the New button create a new Machining Function 
face Window 

3 From the Machining Function drop down menu, choose Mill Cylinder 
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4 Enter the setup parameters as shown below: 

 
Once the Setup dialog appears as above, click on Close 

Step 2. Create Part Features 

 Note: When performing engraving it is not necessary to create part 
geometry. 

Start by entering the CAM mode in the Mill Cylinder Window.  

1 Choose Show Axes from the View Menu 

2 Choose Show Boundaries from the View Menu 

3 From the Part Features menu, choose the New Profile Group. 

4 Choose Contour Mill under Strategy 

5 Choose ON from Tool Position to indicate that we will be working on 
centerline with the tool. 

6 Enter an X_Surf of 0.3125 

7 Enter an X_Depth of 0.025 

8 Enter the Tool ID number of the 0.25 diameter Spot Drill created and click on 
Select Tools  

9 When all of the necessary data has been entered click on Close 
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Step 3. Create Text 
1 Click on the Engraving Icon and you will get the following dialog box shown 

below. 

2 Type the word “Partmaker” in the box shown below then click on OK. 

 

 
3 Drag a window around the text “PartMaker” and choose the Rotate 

command under Edit menu you will get the following dialog box shown 
below. 

4 Fill in all the necessary information from the dialog box below. 

 
5 When all of the necessary data has been entered click on OK 
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Your completed geometry should appear as shown below: 

 
1 From the Part Features menu, choose Verify Tool Path to see the tool path 

as shown below: 

 
2 Choose Hide Work Tool Path to hide the tool path. 
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Example B: Milling a Contoured Pocket 
In the example given below, you will mill a contoured pocket on the diameter with a 
1/8-inch End Mill. If you wish to complete this exercise on your own, make sure you 
have the following tools created in your PartMaker Tools Database (all tools used in 
the Mill Cylinder Face Window should have an orientation of X Tool) 

 .125 Inch Diameter End Mill 

 

Features to be created: 

 

Mill a Contoured Pocket with a 
.125 diameter End Mill. 

 

Step 1. Create a Mill Cylinder Machining Function Face Window 

 Note: When creating a milled feature in PartMaker SwissCAM, you must 
always start with a turning operation.  Thus you must have a face window of 
machining function Turn created and at least one Turning part feature and 
tool path created (such as a facing operation). 

Start by creating a Mill Cylinder Machining Function Face Window.  To do so: 

1 Enter the Setup dialog by choosing Setup from the View menu or by 
clicking on the Setup dialog icon in the upper left hand corner of the screen 

2 In the Setup dialog, click the New button create a new Machining Function 
face Window 

3 From the Machining Function drop down menu, choose Mill Cylinder 

4 Enter the setup parameters as shown below: 
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Step 2. Create Part Geometry 
Start by entering the CAD mode in the Mill Cylinder Window. Draw the following 
features: 

1 Choose Show Axes from the View Menu 

2 Choose Show Boundaries from the View Menu 

3 Draw a ½ square with .125 radius corners anywhere in the boundaries. 

Your completed geometry and CAD Face Window should appear as shown below: 

 

 Note: You can always go to a different Face Window in your *.job file by 
selecting from the Window menu.  Additionally, you can toggle between 
different Face Windows within the active Window by choosing Show 
Windows Icons from the View menu and double clicking on the icon 
representing the Window you want to view. 

Step 3. Create Part Features and assign tool paths 
Start by entering the CAM mode in the Mill Cylinder Window. First you will create 
the tool path to mill the square. To do so: 

1 From the Part Features menu, choose New Profile Group 

2 Choose Pocket Mill under Strategy 

3 Enter a X_Depth of 0.15 

4 Enter a Tool Diameter of 0.125 and click Select Tools 

5 In the Group Name field, type Mill Pocket 
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Your completed Profile Group Parameters dialog should appear as shown below: 

 
6 Assign the part feature to the square drawn earlier by clicking the Chain 

Geometry icon and clicking on the geometry to create the tool path.  It 
should appear as shown below: 
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7 From the Part Features menu, choose Verify Tool Path to see the tool path 
as shown below: 

 
8 Choose Hide Work Tool Path to hide the tool path. 
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