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Sequence of Programming Steps for PartMaker Turn 
 

1. Specify part boundaries and the type of machining to be performed in the Setup dialog. It 
appears on the screen right after PartMaker logo when launching PartMaker.  Determine 
whether you will be working on the Main Spindle or Sub Spindle in this Face Window. 

2. Choose the Tools command from the ToolMinder menu to add new tools.  

3. Choose the Cycles command from the ToolMinder menu to add new cycles. 

4. Choose the Open Material File command from the File menu to open a material file from the 
Material directory. 

5. Create geometry in CAD mode or choose the Import command from the File menu if you want 
to import geometry from a CAD system. 

6. Switch back to CAM Mode by clicking the CAD/CAM switch. 

The CAD/CAM switch appears as 
 

in CAM Mode and as 
 

in CAD Mode 

7.Choose the New Hole Group command from 
the Part Features menu to create an axial 
hole.  You should see a dialog box as below: 

 

8. Choose the New Profile Group command from 
the Part Features menu to define a new profile 
group. You should see a dialog box as below: 

 

7.1. Enter your desired settings into the dialog. 
7.2. Click the Cycle button. 

8.1. Enter your desired settings into the dialog. 
8.2. Click the Select Tools button. 

9. Create tool paths using the Graphics Icons in the CAM mode 

10. Repeat steps 7 through 9 to create groups of all part features and machining function face 
windows required for the job. 

11. Choose the Open Post Configuration File command from the Job Optimizer menu and 
select the desired post configuration file from the PostLib Directory. 

12. Choose the Generate Process Table command from the Job Optimizer menu to generate a 
Process Table. 

13. Optimize and Synchronize your operations by using the Set Modes dialog 

14. Simulate the generated program using PartMaker’s 3D Simulation software 

15. Choose the Generate NC Program command from the Job Optimizer menu to generate an 
NC Program 
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Important User Notices  
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manual and cannot accept responsibility for any loss or damage howsoever 
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from the software should be checked by a competent person, in accordance 
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Introduction 
Using CAM Software to Program NC Machines 

The invention of NC (Numerically Controlled) machines has revolutionized the metal 
cutting industry. Computer controlled machine tools are faster, have a higher 
degree of accuracy and repeatability.  

NC machines can be programmed manually, which means typing machine 
"language" motion and other instructions into a computer text file. Such a file, 
called a part program, is then loaded into the NC machine memory for execution.  

The following are the major deficiencies of manual programming:  

 The languages of NC machines are cumbersome for humans and require a 
long learning curve. 

 Geometric calculations must be performed to determine coordinates of points 
comprising the tool path. 

 Typing is a time consuming process. 

 The absence of adequate methods to prove out the program results in tools 
breakage and material waste. 

Since the earliest days of computer technology a significant effort has gone into 
automation of the programming process by utilizing CAM (Computer Aided 
Manufacturing) Software. CAM systems accept user input in an interactive manner 
and generate a part program file automatically. CAM Systems provide assistance in 
tool path calculations and verification. The overall productivity improvement 
resulting from a use of a particular CAM System depends on how long it takes to 
learn the software, how easy it is to use it and how much information a user has to 
enter during each programming session.  

How PartMaker Improves Productivity 
PartMaker relieves you from the tedious process of reentering the same tooling 
and process information over and over again in every program. It captures 
information about how to machine individual part features, namely, holes and 
profiles, and makes it available for future use. It allows shop personnel to benefit 
from the expertise of the most skilled programmer, who enters his or her knowledge 
into the software. Using PartMaker your parts can now be programmed faster, with 
higher precision and less cost.  

Intuitive Windows GUI Assures Quick Learning 
PartMaker features an intuitive user interface that complies fully with Windows GUI 
(Graphics User Interface) guidelines. The benefits of the Windows environment for a 
PartMaker user include Context Sensitive Help, pictorial explanation of parameter 
entry, the ability to Cut, Copy and Paste part features and/or geometry, and, most 
importantly, shorter learning time. 
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Tools Data Base Keeps Track of Tool Inventory 
A tools database allows the user to keep track of his current tool inventory. 
Geometric characteristics saved with each tool are used for the automatic 
determination of cutting conditions. The software performs automatic hole depth 
calculations by maintaining through hole clearance and blind hole relief distances for 
each tool. A pictorial representation of each tool in a separate window simplifies the 
entry of tool parameters. Corrective coefficients compensate for tool wear. Special 
fields are reserved for the customer's data that includes part numbers and 
reordering information among others.  The tools descriptions are kept in a tool file. 
The tools used on different machines may be kept in multiple tool files. 

Cycles Data Base Stores Sequences of Repetitive Operations 
A cycles database allows the user to create and store cycles, sequences of repetitive 
operations such as center drilling, drilling, tapping, boring, reaming, chamfering and 
circular hole milling. The cycles database links directly into the tools database. A 
tool for each operation is selected automatically based on the hole diameter. 
Windows GUI makes creation and modification of cycles a simple task. A full 
description of the tools and operations included in a cycle is shown in one window, 
while the corresponding hole cross-section is shown in another window. Studies 
have indicated that over 70 percent of machine cycle time for an average CNC 
machining center is spent making holes. Therefore, PartMaker pays significant 
attention to holemaking in order to achieve the greatest gain in productivity. Often, 
the same or similar features belong to a group of products that are ordered by the 
same shop's customer. Since cycles may be customer specific the user has a choice 
of whether or not to store them in multiple cycle files. 

Materials Data Base Facilitates Automatic Feeds and Speeds 
Calculations  
A materials database allows the user to store materials data that is used in the 
automatic calculation of feed rates and spindle speeds. The software comes with an 
extensive materials database, recommending average cutting parameters. Feed rate 
and spindle speed are computed based on tool geometry (size, number of flutes. 
etc.) and machinability data. This data is presented in the form of flexible computer 
charts giving the user full control over the performance of his machine. The charts 
can be quickly modified via a drag and drop screen interaction. Machinability charts 
can be further optimized by automatic curve fitting through points of best 
performance. 

Patented Visual Programming Approach Simplifies Machining in 
Different Planes 
PartMaker’s Patented Visual Programming approach greatly simplifies 
programming parts involving both turning and milling operations in a single set-up, 
where such operations are being performed on multiple spindles. With this approach 
machining functions such as turning, plane milling and cylinder milling are carried 
out in separate 2D planes, allowing you to break down a part into its most basic 
elements when developing a part program. You can program machining operations 
in different faces (planes) and specify up to twenty-four different faces per part. A 
separate face window is associated with each face of a part.  
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Optimized Process Plan Generation Saves Programming Time 
Rather than creating a job plan in a conventional sequential manner, the 
programmer describes the placement of groups of part features on the surfaces of a 
machined part.  Once the part features description is entered into the computer, 
PartMaker automatically generates an optimized job plan. The results are 
summarized in a Process Table Window that can be reviewed on the screen or 
printed out. The Process Table lists tools and cutting conditions for each process. 
Feed rates, spindle speeds and cycle time are automatically calculated and 
displayed. The cycle time allows the programmer to quickly estimate the cost of 
machining a part. While reviewing the Process Table, the user can manually modify 
the sequence of processes as well as cutting conditions.  

Graphic Process Synchronization Simplifies Cycle Time Optimization 
Once you have laid out your various tool paths, PartMaker allows you to visually 
synchronize processes being performed on separate spindles or by different tool 
posts.  This eases the process of optimizing cycle time to assure your Turn-Mill 
Center is being used most productively.  This visual synchronization is accomplished 
via the Set Modes dialog on the Process Table.   A unique mode has been specified 
for each of the various types of synchronization today’s most advanced Turn-Mill 
Centers are capable of performing.  A picture accompanies each type of 
synchronization allowing the user to better understand the type of synchronization 
being performed.  

User Customizable Output Format Eliminates Manual Editing 
When the user is satisfied with the views of the part and its job plan, he proceeds 
with the next step (known as postprocessing ) to automatically generate an NC 
program for a designated machine. The part program is optimized, using 
subroutines, to occupy minimum space in the machine tool memory and shorten 
transmission time. PartMaker eliminates the need for manual editing of the 
generated NC program - a well-known stumbling block of most CAM systems.  

The ability to generate editing-free programs results in an additional productivity 
gain. It is achieved by giving the user full control over the generated NC program 
format by means of a flexible ConfigPost application that allows the user to create 
and save custom postprocessor configuration files for virtually any Turn-Mill control. 
ConfigPost uses the familiar Windows interactive environment that enables the user 
to do output customization quickly and easily. 

Verification by Cutting Simulation Catches Programming Errors 
PartMaker comes with an integrated simulation module that graphically simulates 
the entire cutting process-utilizing solid modeling techniques.  This allows the 
programmer to catch errors before expending machining time.  
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About This Guide 
Please read this section to determine which chapters in the PartMaker User Guide 
address your needs. 

Chapter 1 “Getting Started With PartMaker” explains how to get started with 
PartMaker. This chapter includes a description of the hardware and software 
you need to run PartMaker and tells you how to install PartMaker and related 
files.  It also shows you how to access PartMaker on-line context sensitive help. 

  
Chapter 2 “PartMaker Fundamentals” discusses the unique programming approach 

PartMaker employs for programming Turning Centers. Concepts covered in this 
chapter include selecting the appropriate Face Window, setting up and working 
with PartMaker’s databases, PartMaker Synchronization modes and material 
control processes, using various PartMaker icons and Snap Modes and 
synchronizing processes being executed simultaneously on the machine.  

  
Chapter 3 “Programming the Turn Tutorial Part” shows you how to create a sample 

part using some of the most popular features of PartMaker. We recommend you 
go through this chapter to familiarize yourself with the PartMaker application. 

  
Chapter 4 “PartMaker Simulation” discusses how to use and the functionality of 

PartMaker’s 3-D Simulation module. 

What you will not find in this manual is an explanation of every PartMaker dialog 
and parameters.  For information on specific PartMaker dialogs, use the context 
sensitive help that comes with PartMaker.  This context sensitive help can be found 
by pressing the F1 key on your keyboard. 
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Chapter 1: Getting Started With 
PartMaker 
In Your Package 

 PartMaker CD-ROMs 

 PartMaker Manuals 

 Hardware lock  

You will receive a license file that works with the hardware lock.  For standalone 
licensing the file is called a Product Authorization File (PAF).  For network licensing 
the file is an RMS license file.  Obtaining and installing the PAF file will be discussed 
later in this chapter in the section titled PAF Installation Instructions.  The 
PartMaker Installation guide explains the RMS license file in detail. 

Technical Support 
Please use the following information when you wish to get Technical Support or 
more information about PartMaker’s products: 

Phone:  215-643-5077 

Fax:  215-653-0105 

E-mail:  support@partmaker.com 

Web Site: http://www.PartMaker.com 
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Before Using PartMaker... 
Before you begin working with PartMaker, you need a basic knowledge of Microsoft 
Windows operations. You should understand mouse techniques such as pointing, 
clicking, double clicking, dragging, choosing menu commands, and making dialog 
selections. If you are unfamiliar with basic Microsoft Windows terms or techniques, 
see your Microsoft Windows documentation for details. 

System Requirements 
Please read the following sections to determine what you’ll need to get started with 
PartMaker. To use  PartMaker, you need a Windows-based PC with the following 
specifications: 

 
PartMaker 
Standard 

Parasolid 
Import Module 

(Solids)* 

Full Machine 
Simulation 

(FMS) 

Advanced 
Surface 

Machining (ASM) 

Processor Pentium 3 800 
MHz or higher 

Pentium 3 800 
MHz or higher 

Pentium 4 3 
GHz or higher 

Intel Core Duo 
processor or higher 

Memory 512 MB or more 1 GB or more 2 GB or more 4 GB or more 

Hard drive 40 GB 40 GB 40 GB 80 GB 

Independent 
video card 128 MB NVIDIA 512 MB NVIDIA 512 MB 

NVIDIA 1 GB NVIDIA 

 

64-bit and 32-bit versions of PartMaker are available and are supported on Windows 
7. Only the 64-bit version of PartMaker is compatible with Windows 8 PCs. 

Please take note that Microsoft has discontinued support for the Windows XP and 
Vista operating systems.  
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Starting PartMaker  
From your desktop, double-click the PartMaker Mill icon. 

A window containing information about PartMaker appears for a few moments. 

 
The PartMaker application window and the Setup dialog are displayed in the Face 
Window. 

 

Exiting PartMaker 
1 To exit PartMaker, choose Exit from the File menu. 

If you changed an open job file, a dialog prompts you to save the current job 
file before exiting. 

 
2 Do one of the following: 

a Click <Yes> to save the changes. 

b If the file is untitled, select a location and enter a file name in the dialog 
that appears, then click <OK>. 

c Click <No> to discard the changes and exit. 

d Click <Cancel> to return to the presentation window without exiting. 
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Using On-Line Help 
On-line help provides fast access to information about the application’s tools, 
commands, dialogs, and program features. Help commands are located in the Help 
menu in PartMaker: 

1 Choose Help Topics from the PartMaker Help menu or press <F1>. 

The Help window appears, displaying the Main Index. 

 
2 Click an index to view a list of help topics. 

3 Click the topic you want to read about. 

Information about the selected topic appears in the window. 

Note: Some topic lists include sub-lists from which you can select a help topic. 

4 To return to the last screen you viewed, click the <Back> button. 

5 To search for information, click the <Search> tab. 

6 Type in a key word to choose a topic and click the <List Topics> button. 
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7 Click the <Display> button to view the selected topic.  Your help screen will 
appear as below: 

 
8 When you are finished using help, choose Close from the help window’s 

Control menu. 

Using Context-Sensitive Help 
To view context-sensitive help while viewing any PartMaker dialog: 

1 Display any PartMaker dialog. 

2 Press <F1> to display the help topic for the dialog. 

Installing Updates 
PartMaker Version 2010 and higher allows you to update to more recent versions 
and service packs of the software automatically from the PartMaker environment. 
You can check for and download the most recent version of PartMaker by selecting 
Check for PartMaker Updates from the Help menu. 
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Working With Databases 
Databases are where you store tool, material, and cycle information for 
PartMaker jobs. PartMaker uses material, tools, and cycles databases to store the 
information needed for each job. 

Material Database 
A Materials Database allows you to store your shop’s accumulated materials data. 
Materials data is used by PartMaker in the automatic calculation of feedrates and 
spindle speeds. In addition, you can utilize material data in the extensive material 
library provided with PartMaker. 

Turn to Appendix A for a complete list of materials. 

Tools Database 
A Tools Database allows you to keep track of your current tool inventory. PartMaker 
uses geometric and cutting tool characteristics saved with each tool in the database 
for automatic cutting conditions and automatic depth calculation. 

Cycles Database 
PartMaker lets you combine a number of repetitive operations (center drilling, 
drilling, tapping, boring, etc.) into a single entity called a Cycle.  All cycles are saved 
in a Cycles Database. For each cycle operation, you can designate a tool from the 
Tools Database. Once a cycle is created, you can recall it at any time when you 
need to use it again. 

Working with Files 
PartMaker uses several kinds of files for storing tools, cycles, and material 
information as well as your jobs and the postprocessor files used to create NC 
programs for machining. 

 Information about tools in the tool crib is saved in Tools files that have the 
file extension .TDB. 

 Information about material characteristics needed to calculate feedrates and 
spindle speeds is saved in Material files that have the file extension .MDB. 

 Information about user-created machining cycles is saved in Cycles files that 
have the file extension .CDB . 

 Part geometry is saved in Job files that have the file extension .JOB. 

 Postprocessor configuration information is saved in Post Configuration files 
that have the file extension .PST. 
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Chapter 2: PartMaker® Fundamentals 
Introduction 

This chapter discusses the various components of PartMaker’s programming 
approach for Turn Centers. This chapter introduces the following topics: 

 Choosing the proper Machining Function Face Windows 

 Programming convention 

 Setting up and working with PartMaker’s Tools, Materials and Cycles 
databases 

 Using Icons 

 Process Synchronization Rules and Techniques 

 Material Control Processes 

Machining Function Selection 
CNC laths are capable of performing a full set of turning operations: facing, turning, 
grooving and threading.  

PartMaker CAM Software from PartMaker, Inc. applies a Patented ‘divide and 
conquer’ programming strategy to simplify programming of Turn-Mill Centers. 

PartMaker helps you separate a complicated part surface into a manageable set of 
faces that may be either planar or rotational in nature. All features are represented 
by a surface relative to which a set of part features is referenced.  

On each face, a set of features may be machined using a variety of cutting tools. 
The software takes advantage of the Microsoft Windows operating system, which 
allows multiple windows to be displayed and accessed simultaneously.  
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Getting Started: The Setup Dialog 
PartMaker employs a programming methodology whereby each machine motion 
type can be separated into a different window dedicated to a specific machining 
function. Every one of these windows is known as a Face Window. Once created, 
each Face Window can be accessed from the Window menu. 

Selection of the various machining functions is carried out in the Setup dialog. The 
Setup dialog can be accessed from the View menu or by clicking on the shortcut to 
the Setup dialog located in the upper left hand corner of your Face Window. On 
Startup, or when accessing the Setup dialog for the first time, you will see the 
following dialog. Some of the important components of this dialog are explained 
below: 

 
1 Settings: Allows you to access the Spindle Settings dialog.  The Spindle 

Settings dialog allows you determine if you wish to use a chuck or a collet.  

The Main Spindle and Sub Spindle radio buttons are disabled in PartMaker 
Turn as this module assumes you are working on a single spindle lathe.  If 
performing work on a twin spindle lathe, please use the PartMaker Turn-Mill 
module. 

2 Stock: Determines the type of stock being machined, either a prismatic Slug 
or Bar stock.  Once the setup dialog has been completed, you can use 
PartMaker’s Define Custom Stock Shape command to create a custom, 
user defined stock. 

3 List of Face Windows: Presents the list of Face Windows created for a 
particular job file. 

4 Rename To: States the name of a given Face Window.  You should give 
each Face Window you are working with an appropriate name based on the 
machining occurring within that Face Window. The number on the left of this 
field determines the order of the Face Window when you have a number of 
Face Windows in a particular job file. Generally speaking, you will only need 
one machining Face Window in PartMaker Turn. 
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5 Function Buttons: These buttons allow you to perform the following 
operations in the Setup dialog: 

New: Creates a new Face Window. 

Delete: Deletes an existing Face Window.  This button will only be active 
when you have more than one Face Window and DO NOT have a Process 
Table generated. 

Duplicate: Not enabled in PartMaker Turn. 

Apply: Applies any changes made within the Setup dialog and leaves the 
dialog open. 

Close: Applies any changes made within the Setup dialog and closes the 
dialog and places you into a Face Window. 

6 Boundaries: Used to set the stock boundaries of your part.  The parameters 
used to do so are explained here: 

Length (L): Length of the finished stock 

OD: Outside diameter of the stock 

ID: The starting inside diameter when using tube stock  

Excess Stock (E): The amount of material to be removed from the stock 
to create the desired finished length. PartMaker takes excess stock into 
account only for facing operations.  

Work Shift (I): Specifies distance of the stock face from the chuck or 
collet face. 

Work Offset: If used by the post processor, inserts a work offset code 
into the part program. This option may be used with Fanuc and similar 
controls that make use of work offset codes. Consult the documentation 
for your control for specific information about work offset codes.  See the 
ConfigPost User Guide for more information on configuring your post 
processor output. 

7 Orientation: Used to set the tool change position in X and Z for the tools in 
the job.  These fields may or may not be used by the post processor, 
depending on the tool change NC code requirements of your particular 
machine tool.  See the ConfigPost User Guide for more information on 
configuring your post processor output. 

Tool Change X (Xc): The tool change position along the X axis. 

Tool Change Z (Zc): The tool change position along the Z axis. 

8 Notes: Allows you to specify notes about a particular Job or Face Window.  
Depending on the configuration of the post processor you choose, the 
contents of these fields can be output into your NC program.  See the 
ConfigPost User Guide that came with your PartMaker Software for more 
information on post processor configuration. 
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Machining Function: Turning  
The Turn machining function uses conventional turning tools moving in the X and Z-
axes. Motion is programmed using X and Z coordinates. This machining function 
includes on centerline drilling where a drill is held stationary while the spindle 
holding the part rotates. All drilled holes must therefore be on the rotational 
centerline of the part. 

The picture below shows the appearance of the Setup dialog when performing 
Turning on the Main Spindle.  

 
 

Length (L) Length of the finished part 

OD Starting outside diameter of bar stock 
before machining 

ID Starting inside diameter of bar stock 
before machining 

Excess Stock (E) Rough stock left for facing on the front of 
the part  

Work Shift(l) Specifies amount of the part protruding 
from the chuck during machining 

Work Offset Specifies the work offset for the current 
face window 
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PartMaker Programming Convention 
When using PartMaker Turn for creating part geometry and NC programs, it is 
important to understand that all work is done moving from right to left in the Z-
axis, this means all drawing and tool path generation is created by moving to the 
left in the Z negative direction. To summarize, PartMaker always assumes the collet 
or chuck to be to the left. 

It is important to keep the right to left programming convention in mind when 
drawing, creating tool paths, and when setting up tools. Tool orientation should 
always be assigned assuming programming in the same direction. 

Working with Files 
PartMaker uses several kinds of files for storing tools, cycles, and material 
information. Your jobs and post processor files used to create NC programs for 
machining can also be stored in their own files. 

 Part geometry, tool path, and process information is saved in Job files that 
have the file extension .JOB.   

 Information about tools in the tool crib is saved in Tools files that have the 
file extension .TDB. 

 Information about material characteristics needed to calculate feedrates and 
spindle speeds is saved in Material files that have the file extension .MDB. 

 Information about user-created machining cycles is saved in Cycles files that 
have the file extension .CDB. 

• Postprocessor configuration information is saved in Post 
Configuration files that have the file extension .PST. 

The Job File 
The Job file is the main file type used in PartMaker. Every job file must have a 
tools and cycle file associated with it. However, particular tools and cycles files 
can be (and should be) associated with many if not all of your job files. Job files 
have the extension .job. 

The name of the current job file you are working with is displayed at the top of 
the PartMaker screen as shown below: 
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Working With Databases 
Databases are where you store tool, material, and cycle information for PartMaker 
jobs. PartMaker uses tools, materials, and cycles databases to store the 
information needed for each job. 

Material Database 
A Materials Database allows you to store your shop’s accumulated materials 
data. Materials data is used by PartMaker in the automatic calculation of feed 
rates and spindle speeds. In addition, you can utilize material data in the 
extensive material library provided with PartMaker. 

Turn to Appendix A for a complete list of materials. 

Tools Database 
A Tools Database allows you to keep track of your current tool inventory. 
PartMaker uses geometric and cutting tool characteristics saved with each tool 
in the database for automatic cutting conditions and automatic depth 
calculation. 

Cycles Database 
PartMaker lets you combine a number of repetitive operations (center drilling, 
drilling, tapping, boring, etc.) into a single entity called a Cycle.  All cycles are 
saved in a Cycles Database. For each cycle operation, you can designate a tool 
from the Tools Database. Once a cycle is created, you can recall it at any time 
when you need to use it again. 

Material Database 
The Material Database allows you to store your shop’s accumulated materials 
data. PartMaker uses materials data in the automatic calculation of feedrates and 
spindle speeds. The Materials Database allows you to choose from a variety of 
different materials and even adjust them and store your changes in order to 
customize feeds and speeds to your shops requirements. 

Turn to Appendix A for a complete list of materials. You can also use the On-line 
Context Sensitive Help that comes with your PartMaker system to view a complete 
list of included material files, inclusive with various material grades for each. 

Selecting a Material File 
When creating a part, it is important to select a material. To do so: 

1 Choose Open Material File from the File menu to display the Open Material 
File dialog shown below: 
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2 Locate and select ST_FMSTW (Free Machining Stainless Steel Wrought) from 
the list and click <Open>. You are returned to the Face Window. 

3 To view the cutting characteristics of the selected material, choose Material 
from the ToolMinder menu and you will the see the dialog shown below:  

 

Customizing a Material File 
You can customize materials files in PartMaker by adjusting the feed and speed 
charts displayed in the Material dialog. To do so: 

1 Choose Material from the ToolMinder menu to display the Material File 
dialog shown below: 

 
2 Click the third radio button on the right hand side to display the feed chart. 

By clicking on and dragging the node points lying on the chart or the axes, 
you can customize feed rates for different sized drill. The same technique can 
be employed for spindle speeds as well for all the tools listed. 
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3 Once you are satisfied with the changes you have made, you can save your 
changes by choosing Save Material File As… from the File menu. In the 
file name section, enter “steel_303” and click <Save> to save the material 
as shown below: 

 
You will now notice the new name of the material file at the top of the Material 
File dialog as shown below: 

 

 Note: When saving changes to material files, you must give them a 
different name than the initial PartMaker material used. The material 
files that come with PartMaker are read-only files and cannot be 
overwritten. 

4 Click on the Ranges button to see how the chart is calculated. Notice how 
with each tool you can change parameters on which speeds and feeds are 
based as well as the speeds and feeds themselves. Click <OK> to close this 
dialog. 

 
5 Click the close box in the upper, right-hand corner of the Save Material File 

as: dialog box to return to the Face Window. 
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Cycles Database 
PartMaker lets you combine a number of repetitive operations (center drilling, 
drilling, tapping, boring, etc.) into a single entity called a Cycle. All cycles are saved 
in a Cycles Database. The Cycles Database can store up to 1,800 cycles. For each 
cycle operation, you can designate a tool from the Tools Database. Once a cycle is 
created, you can recall it at any time when you need to use it again. Cycles can be 
setup for both cross holes and holes on the face of the part, as well as for holes 
involving both live and dead tooling. 

Creating and Storing Cycles 
In this exercise, you will create a cycle for on-center hole on the face of a part 
using existing tools in the tools database. This cycle will contain a center drill 
and a drill. 

You can access PartMaker’s Cycles Database by choosing Cycles from the 
ToolMinder menu. Once you are in the Cycle Data dialog, to create a new 
cycle: 

1 Click the <New> button to create a new cycle. A blank cycle such as the 
one below will be displayed. 

 
2 Next, choose the operations that will comprise the cycle. To do so, choose 

center drill and drill, respectively, from the Operation Type drop-down menu. 
After doing so, your dialog should appear as shown below: 
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3 Next, choose the corresponding Canned Cycles from the Canned Cycles drop 
menu for each of these operations, which will be DRILL and DRILL, 
respectively.  

Finally, specify the hole diameter for each tool.  In this case, the Center Drill 
should be 0.0938 and the Drill 0.125.  

After entering the parameters as specified above, your dialog should appear as 
shown below: 

 
4 Click the <Select Tools> button to select or add tools for the corresponding 

operations as shown below: 

 
5 In the Rename To: field, rename the cycle Drill 1/8 and click the <Apply> 

button. 
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6 The completed Cycle Data dialog should appear as shown below: 

 
Notice that the column for depth has not been filled out. It has been 
intentionally left blank in order to allow PartMaker to calculate the depths of 
cut for each tool automatically when applied to the part. This automatic 
calculation is based on the nominal hole depth and specified geometric 
characteristics of the tools in the cycle.   

One cycle may be applied to many different jobs, and allowing PartMaker to 
calculate the depth of cut makes each cycle more flexible. It may at times be 
desirable to enter a value into the depth field. When doing so, be advised 
that this value will be “hard coded” and that whenever using the cycle, this 
tool will always travel to the depth specified in the Cycles Data dialog. 

7 Once you are satisfied that your dialog appears as the one above, click the 
<Close> button. 
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Using the CAD/CAM Switch 

 
This icon represents CAM mode. Clicking it will switch the program to the CAD mode. 

 

All tool path creation and process development is done in the CAM mode. All 
geometry creation and alteration is done in the CAD mode. 

Using the Color Bar 

 
You use the color bar in the upper-right corner of a Face Window to select a color 
for group symbols. You can also use it to change the color of geometry. The group 
symbol or geometric element will have the color of the currently chosen Sample 
Color. 

 Note: If you want to change the color of a Group Symbol, select the Group 
Symbol in the Job Explorer, click a color on the color bar, and then click the 
Sample Color on the left side of the color bar. 

To change the color of a geometric element, select the geometry in the Face 
Window, click a color on the color bar, and then click the Sample Color on the left 
side of the color bar. 
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Using the Icon Toolbars 
PartMaker Version 9 and higher provides Toolbars to speed up commonly used 
functions throughout the software. PartMaker supports four types of icon toolbars, a 
Main Toolbar which is available throughout a job file, a Face Window Toolbar 
which is associated with each Face Window, a Solids Window Toolbar which 
appears when working with an imported Solid Model and a Simulation Toolbar 
which appears when working in PartMaker’s 3D simulation.  Here, the Main Toolbar 
and Face Window Toolbar are explained.  Chapter 4 of this guide will explain the 
use of the Simulation Toolbar while Appendix C to this manual will explain the use of 
the Solids Window Toolbar. 

Main Toolbar 
The Main Toolbar lets you perform many of the functions in PartMaker’s menus 
with the click of a button.  The Main Toolbar will look the same throughout your 
PartMaker session and appears as below: 

 

 Note:  When holding your mouse over any of these icons, a “Tool Tip” will 
appear showing the function performed by that icon.  

Face Window Toolbar – CAM Mode 
The Face Window Toolbar lets you perform many of the functions in PartMaker’s 
menu’s with the click of a button.  The Face Window Toolbar applies only to the 
active Face Window and may look differently depending on the Machining 
Function Face Window being used. 

 

Face Window Toolbar – CAD Mode 

 

Displaying Toolbar Icons 
The display of the Toolbars can be manipulated by choosing Toolbars from the 
View menu.  When a toolbar is checked, it will appear.  When unchecked, it will 
not be visible.   
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Creating Groups of Part Features 
Groups of part features such as holes and profiles are created in PartMaker. The 
currently selected group icon or Group Symbol in a Face Window is the work 
group from which tool paths are being added. 

To create a new Group Symbol: 

1 Click the desired color on the color bar. 

2 Choose New Profile or New Hole Group (depending on the type of Part 
Feature being created) from the Part Features menu to display the Group 
Parameters dialog. 

When you exit the dialog, the new group is created using the color you 
specified as shown in the image below. 

 

Using the Graphics Icons in PartMaker CAD mode 
You can create your part drawings in PartMaker in the CAD mode. Alternatively, 
you also import drawings from other CAD systems into PartMaker by using the 
Import command from the File menu. Imported geometry can be altered in 
PartMaker’s CAD mode. 

 
Geometry is created in PartMaker CAD using the Graphics Icons that include 
Drawing Icons and Snap Modes. 
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Geometry Drawing Icons 
Geometry Drawing icons allow you to create different types of geometric 
constructions such as lines and arcs. PartMaker’s icons are defined below. 

 

Selection Icon indicates that the system is in the selection mode. In this mode you can 
select lines, arcs and circles in the Face Window either by clicking on them or dragging a 
selection rectangle around them. 

 
Zero Icon allows you to define a new location for the zero point using Snap Modes. 

 
Trim/Extend Icon allows you to stretch or shorten an existing line or arc. 

 
Remove Icon allows you to remove portions of lines or arcs between intersection points. 

 
Line Thru Two Points Icon allows you to create a line between two points specified 
using Snap Modes. 

 
Connected Lines Icon allows you to create connected lines with end points specified 
using Snap Modes. 

 
Line Parallel Horizontal axis Icon allows you to create a line parallel to the Horizontal 
axis by specifying positive or negative offset. 

 
Line Parallel Vertical axis Icon allows you to create a line parallel to the Vertical axis 
by specifying positive or negative offset. 

 
Parallel Element Icon allows you to create a line, arc, or circle parallel to the cursor 
selected entity specifying an unsigned distance. 

 
Line on an Angle Icon allows you to create a line on an angle to a cursor-selected line 
passing through a point specified using Snap Modes. 

 
Fillet Icon allows you to insert a fillet between two cursor-selected lines or arcs. 

 
Chamfer Icon allows you to insert a chamfer between two cursor-selected lines or arcs. 

 
Circle with a Known Radius and Center Icon allows you to define a circle with a 
center specified using Snap Modes. 

 
Circle with a Known Radius and Two Points Icon allows you to define a circle with 
two points on the circumference specified using Snap Modes. 

 
Circle with a Known Center and a Point Icon allows you to define a circle with a 
center and a point on the circumference specified using Snap Modes. 

 
Circle Through Three Points Icon allows you to define a circle with three points 
specified using Snap Modes. 

 
Polygon Icon allows you to create a various rectangles by entering a flat-to-flat 
distance. 

 
Divide/Append Icon aids you in the “breaking” of segments at specific point within the 
geometry.  

 
Multiple Offset Icon allows you to offset the selected geometry chain through a user-
defined distance. 

 
Ellipse Icon allows you to create an approximate ellipse in the face window, using 
tangential circular arcs. 
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Dimensioning Icons 
The Dimensioning Icons appear in the PartMaker CAD mode.  These icons allow you 
to create dimension and annotations on your drawings in PartMaker. 

 
Note Icon allows you to create a note on a dimensioned drawing. 

 
Note with Leader Icon allows you create a note with an arrow leader to 
point to a specific item on your drawing you wish to annotate. 

 
Angular Dimension allows you to insert an Angular Dimension between 
two lines.. 

 
Circular Dimension Icon allows you to insert a Circular Dimension on arc 
or circle. 

 

Horizontal Dimension Icon allows you to insert a Horizontal Dimension 
between two points that are either end points of arcs and lines or centers 
of circles. 

 

Vertical Dimension Icon allows you to insert a Vertical Dimension 
between two points that are either end points of arcs and lines or centers 
of circles. 

 
Linear Dimension Icon allows you to insert a Linear Dimension between 
two points that are either end points of arcs and lines or centers of circles. 

 

Flexible Dimension Icon allows you to insert a “Flexible Dimension” that 
is automatically set by the software to either Horizontal Dimension or 
Vertical Dimension or Linear Dimension depending on the cursor position 
when the text location is specified. 
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Snap Modes 
Snap modes are used in conjunction with geometry icons to define point location. 
PartMaker’s Snap Modes are defined below. Snap drawing modes are also used in 
the CAM mode to define tool path location. 

 

 

ZX Coordinates: Used for entering Cartesian coordinates. 
For Face Windows of various machining functions, this icon will change 
accordingly. 

 

ZX for Mill ZX Plane and Turn 
XY for Mill XY Plane, Mill Polygon, Mill End Index, Mill End Polar and Mill 
Diam Polar 
ZC for Mill Diam Index and Mill Cylinder 
ZY for Mill ZY Plane 

 Polar Coordinates: Used for entering Polar coordinates 

 
Point on a Circle: Clicking a point on an existing arc or circle and entering 
an Angle 

 Screen: Clicking a cursor location anywhere within the face window 

 

Grid: Clicking a grid location (grid can be turned on from the View Menu by 
choosing Show Grid. Grid size can be set in the Preferences dialog accessed 
from the View menu). 

 Circle Center: Clicking the center an existing circle 

 Closest Intersection: Clicking the closest intersection of geometric elements

 End of an Element: Clicking the end of an existing line or arc 

 Middle of an Element: Clicking the middle of an existing line or arc 

 
Tangency: Clicking near the tangency point that will be calculated by the 
system 

 

Horizontal Constraint allows you to specify a point whose vertical 
coordinate remains constant, allowing changes in horizontal coordinate only. 

 

Vertical Constraint allows you to specify a point whose horizontal 
coordinate remains constant, allowing changes in vertical coordinate only. 
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Using the Graphics Icons in PartMaker CAM mode 
The Graphics Icons on the left side of a CAM Face Window allow you to define and 
manipulate tool paths. Certain Graphics Icons for use in assigning a particular part 
feature to your part (i.e. a Group Symbol) will have a different appearance and 
function depending on the Machining Function Face Window being used. 

The two icons below will have the same appearance and usage regardless of which 
machining function Face Window you are using. 

 
Selection Icon indicates that the system is in the selection mode. In 
this mode, you can select part features and tool paths in the Face 
Window either by clicking or dragging a selection rectangle around 
them. 

Selected profiles in a Face Window are highlighted; unselected profiles 
are not highlighted. Selected holes in a Face Window are highlighted; 
unselected holes are hollow.  You can delete selected elements by pressing 
the <Backspace> key on the keyboard or by choosing the Delete 
command from the Edit menu. 

 
Zero Icon allows you to define a new location for the zero point or 
origin using Snap Modes. 

Graphics Icons – Machining Function Turn 
The Machining Function Turn Face Window uses two icons to allow you to assign 
part features location in order to create tool paths. 

 

Profile Icon enables you to specify that the currently active group symbol is to be 
applied to the profile described by either coordinate entry or by clicking on geometric 
elements. 

 

Chain Icon enables you to specify that the currently active group symbol is to be 
applied to a profile that is created when PartMaker automatically connects all the 
elements that form an unbroken chain when an initial line or arc is clicked. 

 

2-Point Chain Icon The 2-Point Chain icon allows you to define a profile by the start 
point in the chain, and the end point of the chain. 

 

Profile Info allows you to select an element (line or arc) on the profile curve and to 
display a Profile Info Dialog. This icon is available only if a profile group already exists. 
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Material Control Processes 
Material Control Processes (MCPs) are turning processes that do not involve 
material removal but do require NC programming.  MCPs can be inserted into the 
Process Table via the <Insert Material Control Process> command under the 
Job Optimizer menu.  Upon insertion into the Process Table, MCPs will be placed at 
the top of the Process Table by default.  MCP actual place in the process will be 
determined by clicking on the arrow beneath the cutting after which the MCP should 
be activated. 

The applications of each MCP available in PartMaker Turn are explained below along 
with an explanation of the parameters needed to activate it. 

 Note: Individual post processors may support certain MCPs but not others.  
Please consult your machine-specific addendum or PartMaker Technical 
Support to determine which MCP is supported by your post processors. 

Bar Feed 
The Bar Feed MCP allows the user to insert code for feeding the bar stock out to a 
certain Z-coordinate and stopping with it a bar stop mounted in the turret. 

 
Tool No.: Enter the tool station number at which the Bar Stop is mounted. The 
number must be a one or two digit integer. 
Tool Offset: Enter the offset number for the Bar Stop. The number must be a one 
or two digit integer. 

Process Time: Enter a time estimation from when the Bar Stop moves from its 
safe index position at the beginning of the process to when the Bar Stop moves 
back to its safe index position at the end of the process. Time can either be set to 
seconds or minutes – see Preferences on how to set time units. 

Xr: Enter an absolute x coordinate (measured from the center of the spindle) to 
position the Bar Stop before stock is pushed out.  This number would typically be 
zero. 

 Note: If using the cutoff tool as the Bar Stop, enter a negative x 
coordinate in order to move the cutoff tool insert below the stock 
diameter. 

Zr: Enter an absolute z coordinate (measured from the face of the part) to position 
the bar stop before the stock is pushed out. For short parts, this number can be set 
to zero. For longer parts, it is preferred to set this number equal to the length of the 
part so that the stock does not ram into the Bar Stop after the collet opens. 
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Pull with Side Gripper 
The Pull with Side Gripper Material Control Process allows the user to insert code for 
pulling the bar stock out to a certain Z-coordinate with a part gripper mounted in 
the turret which supports the part from the side. 

 
Tool No.: Enter the tool station number at which the Side Gripper is mounted. The 
number must be a one or two digit integer. 

Tool Offset: Enter the offset number for the Side Gripper. The number must be a 
one or two digit integer. 

Pull Distance (Zp): Enter an incremental z distance from where the Side Gripper 
has clamped onto the bar to where the stock is to be pulled. 

Process Time: Enter a time estimation from when the Side Gripper moves from its 
safe index position at the beginning of the process to when the Side Gripper moves 
back to its safe index position at the end of the process. Time can either be set to 
seconds or minutes – see Preferences on how to set time units. 
Xr: Enter an absolute x coordinate (measured from the center of the spindle) to 
position the Side Gripper above the bar stock before it moves to X0.0 to clamp the 
bar. This number is usually greater that the bar stock diameter.  

Zr: Enter an incremental z distance (measured from the final cutoff z coordinate) to 
position the Side Gripper above the bar stock before it moves in to clamp the bar. 



 

Copyright @2014 Delcam Ltd  User Guide 2-21  

 

Pull with Front Gripper 
The Pull with Front Gripper Material Control Process allows the user to insert code 
for pulling the bar stock out to a certain Z-coordinate with a part gripper mounted in 
the turret which supports the part from the front. 

 
Grip Coord (Zg): Enter an incremental z distance (measured from the face of the 
bar stock) to where the Front Gripper is to clamp on to the bar. 
Tool No.: Enter the tool station number at which the Front Gripper is mounted. The 
number must be a one or two digit integer. 
Tool Offset: Enter the offset number for the Front Gripper. The number must be a 
one or two digit integer. 
Pull Distance (Zp): Enter an incremental z distance from where the Front Gripper 
has clamped onto the bar to where the stock is to be pulled. 
Process Time: Enter a time estimation from when the Front Gripper moves from its 
safe index position at the beginning of the process to when the Front Gripper moves 
back to its safe index position at the end of the process. Time can either be set to 
seconds or minutes – see Preferences on how to set time units. 
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Tailstock Forward 
The Tail Stock Forward Material Control Process allows the user to insert code for 
bringing a tailstock forward for support as a steady rest.  This MCP is used for 
machines equipped with a hydraulic Tailstock. The tailstock will be in the advanced 
position until the Tailstock Retract MCP is activated. 

 
Process Time: Enter a time estimation during Tailstock advancement. Time can 
either be set to seconds or minutes – see Preferences on how to set time units. 



 

Copyright @2014 Delcam Ltd  User Guide 2-23  

 

Tailstock Retract 
This Tailstock Retract Material Control process is used for machines equipped with a 
hydraulic tailstock. If selected, the tailstock retracts away from the face of the part. 
The tailstock will be in the retracted position until Tailstock Advance is activated. 

 
Process Time: Enter a time estimation during Tailstock retraction. Time can either 
be set to seconds or minutes – see Preferences on how to set time units. 
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Remove from Main Spindle 
The Remove from Main Spindle Material Control Process allows the user to insert 
code for removing a work piece from the main spindle using a part gripper mounted 
in the turret. 

 
Tool No.: Enter the tool station number at which the Part Ejector is mounted. The 
number must be a one or two digit integer. 
Tool Offset: Enter the offset number for the Part Ejector. The number must be a 
one or two digit integer. 
Grip Coord (Zg): Enter an incremental z distance (measured from the face of the 
work piece on the Main Spindle) to where the Part Ejector is to clamp on to the work 
piece. 

Process Time: Enter a time estimation from when the Part Ejector moves from its 
safe index position at the beginning of the process to when the Part Ejector moves 
back to its safe index position after it has released the work piece.  Time can either 
be set to seconds or minutes – see Preferences on how to set time units. 
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Chapter 3: Turn Tutorial Part 
Introduction 

This tutorial is designed to help you learn some of the most common PartMaker 
commands and features you’ll use every day.  The illustration on the following page 
represents a typical task you might perform. The name of this part is Turndemo. 
You’ll create the Turndemo part in this chapter using PartMaker. 

This tutorial is presented to cover both inch and metric data entry.  Inch units are 
presented as the primary unit to enter and metric values are presented in 
parentheses. 

How You’ll Create Turndemo 
Here are the major steps you will follow to create the Turn tutorial part: 

√ Start PartMaker 

√ Define the stock boundaries for the face window 

√ View tool information for the part 

√ View cycle information for the part 

√ Select a material for the part 

√ Setup defaults for Turn 

√ Create Geometry 

√ Perform Turning operations 

√ Face the front of the part to finished length 

√ Define the hole for a drilling cycle 

√ Define the profile for an external turning cycle 

√ Define a groove for an internal grooving cycle 

√ Define an internal threading cycle 

√ Create a cut-off operation 

√ Generate the Process Table 

√ Simulate the cutting of the part 

√ Select a post processor  

√ Generate an NC Program 
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Inch Units 

 
 

Metric Units 

 
The major operations involved in producing the part shown in TURNDEMO are as 
follows: 

 Face the front of the part using Face Turning 

 Center drill and drill the 1.00-inch diameter hole in the center using a Drilling 
Cycle. 

 Rough and finish the OD profile using OD Turning 

 Bore the ID profile and create the chamfer using ID Turning 

 Groove the thread relief using an ID Grooving cycle 

 Cut the ID Threads using ID Threading 

 Cut-off the part 

You may find it useful to refer to the above illustration as you program Turndemo. 
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Starting PartMaker Turn 
You will now look in detail at each of the steps necessary to program each of the 
components of the finished part.  The components of the completed tutorial Turn 
part can be found in your PartMaker Turn directory under the following file names: 

Completed Job File:  C:\PartMaker\PM-Turn\Turndemo.job 

Completed Tools Data Base: C:\PartMaker\ PM-Turn\Tools.tdb 

Completed Cycles Data Base: C:\PartMaker\ PM-Turn\Cycles.cdb 

1 Double click the desktop icon to start the PartMaker application. 

A window containing the PartMaker logo appears. 

2 After a few seconds, you will see the Setup definition dialog box open as 
seen in the next section. 

Setup Part Boundaries 
In this section you’ll specify the part boundaries for the Face Window.  

The first dialog you see when you start PartMaker is the Setup dialog, shown 
below. 

 
To manually open this dialog, choose Setup from the View menu. 

 Tip: To advance from one numeric entry field to another in a dialog, press 
the <Tab> key. You can also press the <Tab> key to advance from the 
Z coordinate field to the X coordinate field when a numeric prompt 
appears at the bottom of a Face Window. 
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The first step in creating any part and/or part program is to complete the Setup 
dialog.  To do so for Turndemo part: 

1 From the Stock drop down menu, choose Bar to indicate you wish to work 
from.  

2 Next, define the size of the stock for Turndemo.job which is 3.0" (76.0) long, 
3.5" (90.0) diameter by making the following entries: 

Length (L): Length of the finished stock 3 (76.0)
OD: Outside diameter of the stock 3.5 (90.0)
ID: The unmachined stock has no center hole 0 (0.0)

Excess Stock (E): The amount of material to be removed from 
the stock to create the desired finished length 0.3 (0.5)

Work Shift (l): 

The amount of stock exposed from the work 
holding (chuck for slug work, collet for bar 
work). Since you are working from Bar Stock, 
this should be greater than the overall length 
of the part to accommodate for width of the 
cut-off tool. 

3.5 (90.0)

Tool Change X (Xc): Default tool change position X-axis coordinate 10 (100.0)
Tool Change Z (Zc): Default tool change position Z-axis coordinate 10 (100.0)

 

 
After you are sure all your entries are as shown above, click <Close>. 
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View the Tool Information 
The tool library for the Turn tutorial has been created. 

1 Choose Open Tools File from the File menu.  

2 Open the Tools.tdb from the C:\PartMaker\PM-Turn directory as shown 
below: 

3 Choose Tools from the ToolMinder menu to display the Tool Data dialog. 

4 Select the tool ID T001 from the list shown on the right side of the dialog to 
view a graphic display of the tool and its characteristics. 

 
Notice on the color graphic that there is a pair of intersecting pink lines. The 
intersection point of these lines is the default tool programming point used 
by PartMaker. 

Each tool has many parameters that need to be fully defined so that PartMaker can 
accurately program your parts. 

In the upper left-hand corner of the dialog is a pull down menu called Type. This 
menu is used to select the basic tool types. For turning operations, these types are 
typically: Turn, Groove, Thread, Center, Spot Drill, Chamfer, Tap and Ream. 

 
The Location menu describes the tool locations of In, Out and Face. 

The Orientation menu describes the tool orientations of Left and Right. 
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In the center, top of the dialog, is a pull down menu that defines the basic insert 
shape. Open this list to see the available shapes. The defined shape for T001 is 
Diamond, shown on the following page. 

In a vertical column in the center of the dialog is a list of the parameters that are 
used to define the exact shape of th99e tool and its holder.  

The color graphic to the left clearly shows what each of the parameters describes, 
except for the following, which will be given special attention: 

 Material: defines the cutting insert material, typically either HSS or 
Carbide. 

 Tool ID: A unique ID number that is used by PartMaker to keep track of 
the tools you have defined. 

 Tool No.: The number as it appears in the actual part program.  

 Comp No.: The tool nose radius compensation number used for the tool. 

 Offset No.: The offset register number used to define the length and 
diameter offset values for the defined tool. 

 Depth of Cut: The value used as the default depth of cut at any time this 
tool is used. The programmer may change this value at any time during the 
programming process as needed. 

Below is a button labeled Verify Shape this button is used to display the exact 
shape of the tool defined by the user parameters. Press this button now to see the 
exact shape of the Edge-80 tool. 

 
5 Click on the Hide Shape button to close the dialog. 

There are three other items of interest on this dialog for you to note before 
proceeding: 

 Speed Factor: User adjustment for the spindle speed calculated by the 
software. 

 Feed Factor: User adjustment for the feed rates calculated by the software. 

 Dwell (sec): Dwell time for the defined tool. 

 Note: The tools used in this chapter are for the Turndemo tutorial only. As 
you begin to use PartMaker, you will create your own tools database. 

Once you are finished editing the tool information select the Lock Parameters 
check box to disable all parameters for that particular tool. Each tool can be 
individually locked to prevent modification. 

 
6 When you are finished viewing tool information, click the <Close> button. 
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View the Cycle Information 
PartMaker lets you combine a number of repetitive operations (center drilling & 
drilling for example) into a single entity called a cycle. The Cycle information you 
create is saved in a Cycle Database for easy retrieval. 

The cycles library for the Turn-Mill tutorial has also been created.  

1 Choose Open Cycles File from the File menu. 

2 Open the Cycles.cdb from the C:\PartMaker\PM-Turn directory as shown 
below: 

3 To view the cycles, choose Cycles from the ToolMinder menu. 
4 Select DRILL_1 (Drill_25) on the right side of the dialog to view the 

information relating to this cycle that will be used in Turndeno.JOB tutorial.  

  Note: If left blank, the Depth for each operation is calculated 
automatically by PartMaker. 

 
Note that the DRILL_1 cycle consists of two operations: Center Drilling and 
Drilling. 

Notice that there is a specific depth for the center drill 0.125 (3.0) and no 
depth specified for the deep hole drill. This is because PartMaker will 
automatically determine the depth of the deep hole when the cycle is applied 
in the program. 

5 When you are finished looking at Drill_1 (Drill_25) cycle, close the dialog 
box. 
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Select a Material for the Part 
Before you create a part program for Turndemo, you must select the type of 
material to be machined in the Open Material File dialog. Turndemo is to be cut 
from 303 Stainless steel, which is classified as Free Machining Stainless Steel. 

PartMaker has a materials database from which you can select a variety of 
material types with different characteristics. A materials database allows you to 
store your shop’s accumulated materials data. PartMaker uses this data to 
automatically calculate feed rates and spindle speeds. 

To tell PartMaker that you want to cut a part from for this material: 

1 Choose Open Material File from the File menu to display the Open Material 
File dialog, shown below: 

 
2 2. Locate and select ST_FMSTW (Free Machining Stainless Steel Wrought) 

from the list on the left side of the dialog, then click <OK>. You are returned 
to the Face Window. 

If you wish to learn more about material files, do the following: 

1 Go to the Help menu and select Index 

2 Select Material Library 

Notice the abbreviated and complete descriptive names for each material 
library. 

3 Click on ST_FMSTW.MDB and you will see a list of the different grades of 
stainless steel to which the database applies. In this case, you will see 303 
as one of the grades. 
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View the Material Characteristics 
In this section, you will view the characteristics of the material you selected with 
respect to feed rate and/or speed, and the operation type. 

The Material dialog lets you view and/or change surface speed and feed 
information for each operation based on the currently open material file. For 
each material and operation, you enter data by dragging points on the graph. 
(Points are initially positioned on the X-axis of the graph.) 

1 Choose Material from the ToolMinder menu to display the Material dialog. 

 
2 Click the <Feed> button to see how the feed varies for the currently 

selected operation. 

3 Click an Operation Type to see the feed for that operation. 

4 Drag a point on the graph in the dialog to see how you can change the feed 
for the selected operation. 

5 Click the <Ranges> button to see how the chart is calculated. Notice at the 
bottom of the Ranges dialog how the First Pass and Last Pass threading 
infeed defaults are defined. 

6 Click the <Cancel> button to close the Ranges dialog. 

7 Double-click the close box in the upper-left corner of the dialog to return to 
the Face Window. 



 

3-10 PartMaker  Copyright @2014 Delcam Ltd 

 

Setting Defaults 
Before beginning the Turn tutorial, you will have to set certain turning defaults to 
facilitate the programming process: 

1 To access the Defaults dialog, select Defaults from the Job Optimizer 
menu.  After doing so, you will see the dialog below: 

 
2 Make sure to check the Diameter Programming box. Checking this box will 

allow you to define all geometry and feature programming in terms of 
diameter, alleviating the need to divide measurements in half when 
programming or drawing on the X-axis in Turning Face Windows. 

3 Select Thread Height. The following options are available: 

%Pitch. The user will enter the height as a percent and resulting height 
will be Pitch * Thread Height / 100. 

Part Units. The user will enter the actual measured height of the thread 
in the current part units. 

4 Set a default Line Length for your programmed Leads. For the Turn tutorial 
this value should be 0.100 (2.5) 

 Note: Setting a generally applicable lead as a default will save you a great 
deal of time when programming because you will not have to reenter the 
same data from feature to feature. 
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Turning 
This section of the tutorial will instruct you in the steps necessary to perform the 
turning operations. 

Setting Up the Face Window 
In this section, you will set up the Face Window for the turning operations.  To do 
so: 

1 Choose Setup from the View menu to view the Setup dialog box.  In this 
dialog, you will define the machining function and  part boundaries and 
location of the stock with respect to the work holding.  

The default Setup screen will appear as shown below: 

 
2 Rename the current face window by clicking on Front in the List of Face 

Windows: field and type Turning in the Rename To: field and click the 
<Apply> button. 

3 When you are satisfied that your Setup dialog appears as the one above, 
click the <Apply> button.  This will apply the parameters to the current face 
window.  Click the <Close> button to close the Setup dialog. 

4 In the CAM face window, choose Show Axes from the View menu.  This will 
display the horizontal and vertical axis lines which will help you create the 
geometry in the next section of the tutorial. 
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Creating Geometry 
There are two methods to create Geometry in the PartMaker. You can either import 
Geometry from a CAD file (method 1) or define Geometry using PartMaker's own 
CAD mode (method 2).  Here we will show how to define geometry in both ways.  
Additionally, at the end of this chapter we will demonstrate another way of creating 
the geometry for our tutorial part in PartMaker CAD mode. 

Method 1: Import Geometry from a CAD system via DXF file 
Import the geometry as follows:  

1 Choose Import DXF file from the File menu. 

2 Select Turndemo.dxf from the C:\PartMaker\PM-Turn directory as 
shown here:  

 
Your screen should now appear as shown below: 
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Now that you have a drawing in the Face Window, take a few minutes to explore 
some of the basic features of PartMaker that you will be using. 

From the View menu, you have the following Zoom options available: (Not all 
options have a corresponding icon.) 

 
Select Full View to expand the drawing to fill the screen.  

Select Previous View to return the screen display to the previous setting.  

Select Zoom In and use any mouse button to drag opposite corners of a 
rectangle that you want to magnify.  

Select Zoom Out to shrink the drawing on the screen  

Select Continuous Zoom to magnify the drawing at a steady rate. You can 
do this by pressing <Ctrl> and the <+> or <–> key. 

Select Continuous Pan to move the drawing to the left or right at a steady 
rate. You can do this by pressing  <Ctrl> and the directional keys. 

Select Show Axes to show the current X0 Z0 location. Select Hide Axes to 
turn them off again.  

Show and Hide Grid is used to display a user definable grid that can be 
used to locate convenient points on the screen. 

Show and Hide Boundaries is used to show the boundaries of the rough 
stock being turned.  

Depending on your needs, any or all of these display options may be activated at 
any time during the drawing (CAD) or programming (CAM) process. 



 

3-14 PartMaker  Copyright @2014 Delcam Ltd 

 

Method 2: Create Geometry in PartMaker CAD 
Now that you are familiar with geometry imported via a DXF file, we will now show 
you how to create the geometry using PartMaker CAD functions. 

The method that we will demonstrate in the following pages will demonstrate how 
geometry can quickly and easily be created in PartMaker CAD.  At the end of the 
chapter, we demonstrate another series of steps for drawing the same part.  This 
second exercise will give you an overview of as many CAD features as possible with 
the sample part.  It is recommended you try drawing the part with both exercises to 
gain a fuller understanding of the capabilities of PartMaker CAD. 

1 First, create a new job by selecting New Job from the File Menu.  

2 Make sure you have setup your part defaults correctly as shown below.  
From the View menu, select Setup. 

3 Make sure the Setup dialog box is set exactly as you did in the previous 
section of the Turndemo sample.  A copy of the finished dialog is again 
provided for your reference: 

 
4 To create the profile of the TURNDEMO part in PartMaker CAD, first make 

sure you are in CAD mode. You can switch between CAM and CAD mode by 
clicking on the button in the lower left-hand corner of the screen.  

The button looks like this in CAM mode. 

The button looks like this in CAD mode. 
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The window you are in should be empty and look like this: 

 
Now that you are in CAD mode you will want to show the X and Z axes as well as 
the boundaries of your part.  To do so, 

5 Select the Show boundaries icon and the Show Axis icon from the 
Toolbar. 

After doing so, your window should show the Z and X axes as well as the 
boundaries of your part as shown below. 

 
Once you begin drawing you may choose to hide the boundaries and axes. 

6 Now we are ready to begin drawing the profile of our part.  To begin drawing 
we select the Connected Lines Icon from the drawing tools on the left of the 
Face Window.  

We will use the coordinate snap mode to begin drawing the profile.  When 
prompted enter the following Z, X coordinates: 

0, 1.5 (0, 35) 

0, 2.0 (0, 76) 
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 Note:  To switch between diameter and radius programming in CAD, 
choose the Defaults command from the Job Optimizer menu and check 
the Diameter Programming box. 

7 We will now draw a line to the next point relative to the last point we have 
entered.  Staying with the Connected Lines Icon, enter <@-0.5> (<@-
12.7>) in the Z coordinate prompt when it appears at the bottom of the 
screen.  Here you do not need to enter anything for the X.  Entering an ‘@’ 
sign before a coordinate in the coordinate snap mode will plot a point relative 
to the last point plotted and not relative to the absolute axes.   

 Note: You can make the ‘@’ symbol by pressing  <Shift+2>. 

 Note:  If you are plotting coordinates in PartMaker you do not need to 
reenter a coordinate if it is the same as the last one entered.  You can 
simply leave the space blank and PartMaker will default to the last 
coordinate entered. 

Once you have performed this step, enter the following ZX coordinates  

-1.875, 3 (-47.0,76.0) 

-2.5, <default> (-63.35, <default>) 

<default>,3.5 (<default>, 90.0) 

-3.0, <default> (-76.0, <default>) 

 Note:  To quickly switch between entry prompts in PartMaker, use the 
<Tab> button instead of pointing and clicking with the mouse. 

After entering these coordinates your drawing should like the one below: 

 
8  Once you have drawn the geometry shown above, choose the Selection 

Icon to break the continuity of the point-to-point drawing mode and move 
your cursor about the screen freely. 

9 To draw the under side of the profile, we again select the Connected Lines 
Icon.  Then select the End of an Element snap mode icon and clicking on 
the bottom right hand corner of the drawing as depicted below: 
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10  Next select the coordinate snap mode again and enter the following 
coordinates to complete the file: 

-1.875, 1.5 (-47.0,35.0) 

<default>,1.75 (<default>, 44.6) 

@-2.5, <default> (@-63.35, <default>) 

<default>,1.0 (<default>, 25.0) 

-3.0, <default> (-76.0, <default>) 

After doing so, your profile should look like the drawing below: 

 
We will now enter a 0.125 (3.5) radius fillet as specified by the drawing. To do 
so: 

11 Select the Fillet icon, enter 0.125 (3.5) for the radius and drag the cursor to 
the area where you want to insert the fillet as shown below. 

 
12 Click the cursor over this area to add the fillet.  Your drawing should now 

look like this: 
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13 We will now add a small chamfer to the end of our geometry.  To do so, 
select the Chamfer icon.   Enter a chamfer of 0.05 (1.0) when prompted and 
press <Enter>.  Move the cursor over the area where the chamfer is to be 
inserted as shown below. 

 
14 Once you have moved the cursor into this position, just click your left mouse 

button to add the chamfer. 

15 At this point our drawing is nearly complete. We now need only remove the 
excess geometry. To do so, we select the Scissors Icon and click on the 
unwanted geometry as shown below:  

 
We will now be able to quickly create the lower half of the profile.  To do so: 

16 You will first need to select the geometry you have drawn.  In PartMaker 
CAD there are many ways to select geometry.  Here we will demonstrate two 
techniques of selection: 

Technique 1: 

Choose the Selection icon and then while holding down the left mouse 
button, drag a box around the entire picture and release the mouse button.  
You will have selected the entire picture when your part now looks like the 
picture below: 

 
Technique 2: 

Click anywhere in the Face Window to deselect the geometry. Again, 
choose the Selection Icon. This time, under the Edit menu, choose 
<Select All> or press <Ctrl+A> and you will achieve the same results as in 
Technique 1. 
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17 With the geometry selected, you can make a mirror image, as it will appear 
below the centerline.  From the Edit menu, choose Mirror. 

18 Enter the Mirror dialog values as shown below: 

 
PartMaker will then create the following drawing: 

 
Now that you have completed the drawing, save your work by choosing  <Save> 
from the file menu. When doing so, you will be prompted with the dialog below: 
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Alternate Method 2: Create Geometry in PartMaker CAD 
Now that you are familiar with creating a program using PartMaker and geometry 
imported via a DXF file, we will now show you another way to create the geometry 
using PartMaker CAD functions. 

The methods that we will demonstrate to you in this section will give you an 
overview of as many CAD features as possible with the sample part. 

1 First, you need to start a new Job. From the File menu select New Job. 

2 From the View menu, select Setup. 

3 Set up the dialog exactly as you did in the previous section of the 
TURNDEMO sample. A copy of the finished dialog is again provided for your 
reference: 

 
4 Now that you are in CAD mode you will want to show the X and Z axes as 

well as the boundaries of your part.  To do so, select the Show boundaries 
icon and the Show Axis icon from the Toolbar. 
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After doing so, your window should show the Z and X axes as well as the 
boundaries of your part as shown below. 

 
The boundaries are the rectangular area. The axes are the heavy black 
vertical and horizontal lines on the right and center of the diagram 
respectively. 

Creating the Outside Profile of the Sample Part 
1 To create the profile of the outside, begin by using the Line Parallel to 

Horizontal Axis icon. 

2 Select the icon and type the number 0 in the box and press <Enter>. 
PartMaker will draw a line along the centerline of the part. 

3 Next, enter the number 3.5 (90.00).  

Note how PartMaker will draw the OD of the part without you having to 
divide the diameter by two. 

4 Enter the remaining two dimensions for the OD profile of the part: 3” (76.00) 
and 2” (50.00). 

5 Now, click on the Line Parallel to Vertical Axis icon.  

6 Make the following entries when prompted: 0 <enter>, -0.5 (–12.7) 
<enter>,  -1.875 (-47.00) <enter>, -2.5 (-63.35) <enter>, -3.0 (-76.00) 
<enter>. 
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Your graphics window should look like this: 

 
7 Next, draw the angled line representing the taper. Choose the Line Thru 2 

Points icon. 

8 Choose the Closest Intersection snap mode and select the two points 
shown below to draw the taper: 

 
9 Draw the fillet using the Fillet icon. 

10 Type 0.125 (3.5) in the box for the fillet radius and press <Enter>. 

11 Click on the part just above and to the right of the intersection where the 
fillet is to be drawn, as shown here: 

 



 

Copyright @2014 Delcam Ltd  User Guide 3-23  

 

The result will be: 

 
12 Next, choose the Scissors Icon and trim away the lines and parts of lines 

that are no longer needed. Note that some of the vertical line at the left hand 
end of the taper will remain. 

 
The resulting profile should appear as shown below: 

 
You are now finished creating the OD profile of the part.  

Now is a good time to save your work.  Choose a new name that you have not 
previously used. 
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Creating the ID Profile of the Sample Part 
Before drawing the ID geometry of the part, it is a good idea to select a new color. 
For this example we will use red. Choose the color red from the color bar at the 
upper right hand corner of the screen. 

1 First we will create the only remaining vertical line needed for the ID.  Select 
the Parallel Element Icon.  

2 Type 0.25 (7.00) in the box and press <Enter>.Click with the mouse just to 
the left of the vertical line as shown here. 

 
The result will be: 
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3 Now, using the Line Parallel to Z Axis Icon make the following entries: 

1.00 (25.00)<Enter>,  1.750 (44.600) <Enter>, 1.490 (35.00) <Enter>. 
The result will be: 

 
4 Choose Hide Boundaries from the View menu and use the Scissors to 

trim away all unneeded lines that still remain. This includes the vertical lines 
at either end of the part.: 

5  Using the Scissors, cut away the lines that are not needed until the drawing 
appears as shown here: 

 
6 The next operation is to draw the chamfer. Choose the Chamfer Icon and 

enter 0.05 in the box and press <Enter>.  

7 Click inside the corner shown here: 

 

 Note: Always remove vertical connecting lines between the OD and ID of 
part profiles. This action is necessary to prevent any closed loops from 
confusing the profile-chaining tool. 
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The next operation is to Mirror the drawn profiles so that they appear below the 
centerline From the Edit menu, choose Select All then Mirror. 

The Mirror dialog values are: 

 
PartMaker will then create: 

 
Now you have completed the drawing, save your work by choosing <Save> from 
the File menu. 
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Creating TURNDEMO in PartMaker CAM Mode 
Now that you have created the geometry for TURNDEMO, you are ready to begin 
working in PartMaker CAM mode.  To do so, you must first switch to the CAM 
mode.  You are in CAM mode when the CAD/CAM switch in the lower left-hand 
corner of the screen appears as as the one to the left. 

 

For those of you who chose to create geometry via Method 2, you should select 
New Job from the File Menu.  Having done so, choose Import DXF file from the 
File Menu and choose Turndemo.dxf as in Method 1 to insure you are working 
with same drawing which will be shown in the pages to come. 

Before proceeding, your Face Window should appear as the one below, with your 
geometry appearing as a gray outline on the screen: 
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Define Group 1: Profile for Face Turning 
The first operation in TURNDEMO is to face the stock to the desired finished 
length of 3.0 inches. 

1 Click anywhere in the Face Window to make it active. 

2 Click the blue square in the Color Bar  

3 Choose New Profile Group from the Part Features menu to display the 
Profile Group Parameters dialog.  

 
4 From the Strategy menu, select Turning 

5 From the Tool Location menu, select Face 

6 Click on the Select Tools button and allow PartMaker to select the 
appropriate tool. In this case, T001. 

 Note:  In the color graphic, there are areas in gray representing roughing 
and areas in red representing finishing. For this operation, we will only be 
roughing, so do NOT check the Finishing Tool box. 
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In the field called Group Name, enter a short description such as Face Stock. 
When you are finished, click on Close. This description is for your reference only, 
and has no specific meaning to PartMaker. When you are finished, the dialog 
should appear as shown here: 

 
7 Click <Close> after viewing the group parameters to return to the Face 

Window. 

A square displaying the cycle name Face Stock appears in Job Explorer as 
shown below. The square is a group symbol. Each part you create in PartMaker 
will display one or more group icons in the Job Explorer to indicate the various 
features. 

 
8 Double click on the group symbol to return to the dialog. 

9 Click the <Close> button. 
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Tool Path Verification for Face Stock Group 
Because you have chosen a tool location of Face in the profile group parameters 
dialog, PartMaker has automatically assigned your tool path to the part 
geometry, creating the tool path for you. 

To check your work, go to the Part Features menu and select Verify Work 
Group Tool Path and watch as PartMaker displays the operations to be 
performed. When you do so, you will be prompted with the dialog below: 

 
Click <OK> and your screen will appear as shown below: 

 
Choose Hide Every Tool Path from the Part Features menu to clear the 
programmed tool paths from the screen. 

Verification options include showing the tool as either Hollow, Solid or Do Not 
Show Tool. You can also insert Delay Times into each program step. Delay 
times are relative to each computer and will require some user experimentation 
to determine which is best for each particular computer system. 

Dotted lines are used to display rapid moves while solid lines are used to display 
feed moves. 

The next step is to drill the 1-inch hole in the center of the part. 
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Define Group 2: Hole for Drilling Cycle 
This section of the TURNDEMO tutorial will define the cycle and size of the hole to be 
drilled in the stock. From the drawing, you can see that the hole is 1.0” (25.00) in 
diameter and extends completely through the part. 

To properly instruct PartMaker how to perform this operation, use the following 
steps: 

1 Choose the color red from the Color Bar   

2 From the Part Features menu, select New Hole Group.  

3 Check Through Hole. 

4 Enter the desired diameter of 1.0 (25.00) 

5 In Major Cycle Operation select <Drill>. 

6 Other parameters should be set as show here: 

Chamfer 0.0  

Z_Surf 0.0  

Face Clearance (Cf) 0.05 (2.0) 

Nominal Depth (D) 3.0 (76.0) 

PartMaker will calculate the necessary programmed depth from the desired 
nominal depth taking into account the diameter and point angle of the drill. 

7 Press the Cycle button and PartMaker will select the appropriate cycle to 
create the desired hole. This selected cycle should be Drill_1 (Drill_25.00) 

8 Notice in the box in the lower left-hand corner of the dialog that PartMaker 
has displayed each tool to be used along with the appropriate depths 
required. 

9 To verify the shape of the hole, click the Verify Shape button. When you are 
finished viewing the hole shape, click on the Hide Shape button. 

Your dialog should appear as shown below: 
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10 Click on the Edit Cycle button in Hole Group Parameters dialog to access the 
selected cycle. Only the selected cycle will be available for modification, any 
changes that are made will automatically update the Hole Group Parameters 

11 When you are satisfied that you have correctly defined the Group 
Parameters, Close the dialog. 

PartMaker should now display the drilled hole in the Face Window as shown 
here: 

 
At this time, it is a good idea to save your work. To do so, select the <Save> 
command from the File menu.  

Define Group 3: OD Turning 
In this section, you will learn how to cut the OD profile of the sample part. 

1 Click on the green square in the Color Bar.  

2 Select New Profile Group from the Part Features menu to display the Profile 
Group Parameters Dialog.  
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You will define the profile to be turned using the turning cycle 

1 You will be finishing the part with the same tool, so click on the Finishing 
Tool ID check box. 

2 Click on the Select Tools button and allow PartMaker to select the 
appropriate tools from the library. For this example, PartMaker will select 
T002 for both operations. 

If you want to see detailed information about the selected tool, you can do 
so by clicking on the small, colored graphic of the tool. PartMaker will 
display the tool details. 

 Note: After you clicked the Select Tools button, PartMaker has 
automatically set the Depth of Cut to <0.1> inches (.250). This value 
comes from the tool database.  

3 In the Surface Roughness field, enter 63 (1.6). This will set the 
appropriate feed rate for the finishing operation. 

4 Set the Finish X (Fx) and Finish Z (Fz) values to 0.01 (.1) respectively. 

5 In the Group Name, enter Turn OD and click <Close> button to return to 
the Face Window. 

6 Click on the Chain Profile icon on the left side of the screen.  

7 Using the cursor click on the OD profile that you wish to turn. Your selection 
point should be on the profile, all the way to the right, close to Z=0 as shown 
here: 

 
PartMaker will highlight the profile in Green and create arrows showing the 
direction of cut. 

8 Verify your work by selecting Verify Work Group Tool Path from the Part 
Features menu. PartMaker will show you each and every move required to 
create the profile. 

 
9 When you are finished, select Hide Work Group Tool Path. 

The next operation is to bore the ID in preparation for threading. 
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Define Group 4: ID Turning 
In this section we will define the cycle and select the profile to be bored on the 
ID of the part. 

1 First, you will want to again change the working color on the screen. Click on 

the cyan (light blue) color square in the Color Bar.  

2  Select New Profile Group from the Part Features menu.  

3 Set the Strategy to Turning. 

4 Set the Tool Location to In. 

5 Click on the Select Tool button. 

6 PartMaker should pick T004 from the tool database. 

7 Type Turn_ID in the Group Name field. 

8 Once you are satisfied that you have set up the Group parameters as shown 
below, press <Close>. 

 Note: Since we are only preparing the bore for threading, it is not 
necessary to finish the bore, so we will not use a finishing tool. 

 
9 Choose the Chain Profile icon.  

10 Select the ID geometry by clicking at the face of the part: 

As before, PartMaker will highlight the profile as you see above. 
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11 To verify your work, select Verify Work Group Tool Path under the Part 
Features menu. If you have selected Do Not Show Tools under 
Verification Options, your screen should appear as below: 

 
Notice how PartMaker has not only turned the bore, but also removed as 
much material as possible from the groove area without violating the finished 
part. 

12  When you are finished, select Hide Work Group Tool Path. 

The next operation will be to cut the thread clearance groove. 

Now is a good time to save your work. From the File menu, select <Save> or 
simply press <Ctrl S>. 

Define Group 5: ID Grooving 
The next step in programming TURNDEMO part is to clean out the ID groove at 
the bottom of the threads. 

1 As with previous operations, begin this one by selecting a new color. Select 

Green for this operation.   

2 Select New Profile Group from the Part Features menu.  

3 From the Strategy  menu, select Grooving 

4 From the Tool Location menu, select In 

5 Notice that you now have a new pair of definitions: Rectangle or General. 
A rectangular groove is what we are cutting. A general groove is any 
profile shape that you want to machine using grooving operations. For this 
example, leave the selection as Rectangular. 

6 Click on Select Tools and PartMaker will select the ID grooving tool 
defined in the tool database: T005 

7 Type Groove ID in the Group Name box. 
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8 Take a minute and familiarize yourself with the parameters required for this 
cycle. For now, leave them at the defaults. Your dialog should appear as 
shown: 

 
9 When you are satisfied that you have defined the Group Parameters 

correctly, Close the dialog. 

10 Choose the Define Profile icon to select the desired elements defining the 
groove. Use of this icon allows you to individually select the lines and arcs to 
be included in the groove shape. 

11 Select the End of an Element snap mode on the top of the screen. 

12 In the Face Window, begin selecting the lines that define the groove, by 
Click on each endpoint (1, 2, 3, and 4) in succession until you have defined 
the groove by selecting 4 endpoints as shown here: 

 
Your drawing should appear as below: 
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13 Select Verify Work Group Tool Path command from the Part Features 
menu. You should see what is shown below:  

 
14 Choose Hide Every Tool Path to clear the tool path from the Face 

Window. 

Define Group 6: ID Threading 
The next operation to be performed is to cut the ID thread. 

1 Select the color magenta from the color bar.  

2 Select New Profile Group from the Part Features menu. 

3 From the Strategy menu, select Threading. 

4 From the Tool Location menu, select In.  

5 Look at the graphic. Notice that there are two options: No Chamfer and 
Chamfer. No Chamfer would be used in our case where there is a relief 
groove at the end of the thread. Chamfer would be used if there is no relief 
groove at the end of the thread. Take a minute and look closely at both 
graphics and the user parameters for each. When you are finished, leave this 
setting at No Chamfer. 

6 Click the Select Tools button. PartMaker will pick the appropriate ID 
threading tool from the tool database. In this case, the tool is T006. 

7 Type Thread ID next to Group Name. 

8 Note the default Pitch of 0.125” (3). The desired pitch for this operation is 
10 threads / inch  (2/mm). Change the pitch to 0.1” (2).  
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9 The final Profile Group Parameters should appear as shown below:  

 
10 10. Click on <Close> to close the Profile Group Parameters dialog when 

you are sure that all settings are correct. 

Defining the geometry for the threading cycle is a bit more involved than 
previous operations, so follow along carefully. 

The geometry for the threading cycle is not currently defined on the screen, so 
we will have to define it first. While there are many ways to define the 
geometry, we will use a new method to help familiarize you with as many 
features of PartMaker as possible. 

11 In the lower left-hand corner of the screen click on the CAM mode icon. It 
will change to the CAD icon as  shown to the left. 

12 Click on the Trim / Extend icon.  

13 Click on the horizontal line that represents the minor diameter of the thread. 
Click near the left-hand end of the line. 

 
Notice that as you move the cursor left and right you change the length of 
the selected line, which is now shown in pink. 
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14 To extend the line horizontally to the center of the groove, PartMaker has a 
snap tool that can find the exact point required. Click on the Midpoint snap 
mode. 

The goal of this exercise is to extend the selected line so that it ends in the 
center of the groove along the Z-axis. While it is quite possible to 'eyeball' a 
point that is close enough for some cases, it is better to learn to use exact 
coordinates. 

15 Use the cursor to select the line representing the bottom of the groove as 
shown here: 

 
The resulting face window will appear as shown below: 

 
16 You are now finished with CAD mode. Click on the CAD icon in the lower left-

hand corner of the screen to return to the CAM mode. 

17 Choose the Define Profile   icon and the End of an Element  snap mode. 
First click on the right end, then the left end of the line, which you just 
modified. 

PartMaker will highlight the line as shown: 

 
18 Choose Verify Work Group Tool Path from the Part Features menu. 

 
If you are satisfied with what you see, you are finished with the definition of all 
part features for this job. Hide Every Tool Path  to complete this phase.  

Choose Save from the File menu or press <Ctrl + S> to save your work. 
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Define Group 7: Cutoff 
The final operation to be performed is to cut the part off. 

1 Select the blue square from the color bar.  

2  Select New Profile Group from the Part Features menu.  

3  From the Strategy menu, select Cut-Off  

4 Click the Select Tools button. PartMaker will pick the appropriate Cut-off tool 
from the tool database. In this case, the tool is T008. 

5 Type Cut-Off next to Group Name.  

Your Profile Group Parameters dialog should now appear as shown below: 

 
6 Click on <Close> to close the Profile Group Parameters dialog when you are 

sure that all settings are correct. 

7 As with the facing operation, PartMaker will automatically apply the cut-off 
tool path to your geometry. 
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Now that all the programming is complete, it would be a good idea to see exactly 
what you have programmed. 

1 From the View menu, select Show All.  

2 From the Part Features menu, select Verify Every Tool Path. Partaker will 
show you exactly what you have programmed in a graphical manner that is 
easy to recognize and check for errors. 

3 Set the Show Tool As option to Solid. 

 

 
4 When you are finished, select Hide Every Tool Path from the Part 

Features menu.  
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Choose a Post Processor 
The next step is to choose a Post Configuration File or Post Processor.  To do so: 

1 In the Job Optimizer menu, select Post Config File=? 

2 From the postlib directory, select FANUC_6.pst as shown here:  

 

Generate a Process Table 
The next step is to generate a Process Table of all the operations you have just 
defined. 

1 Select Generate Process Table from the Job Optimizer menu. Use the 
defaults shown and click on OK.  

PartMaker will generate a table showing each process to be programmed. 

 
Take a minute and look carefully at all the information shown in the Process Table. 
Shown on each line, in order of operation, is the tool information, turret position, 
process description, group number, face name, feed rates, spindle speed, and total 
turning time. 

If you wish to observe more information related to the tool, click on the colored tool 
icon. All details about the tool will be shown to you in the Tool Data dialog. 

If you want more information about each process, double click on the text, 
anywhere in the line. The details of the process are displayed in an open dialog box. 
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Simulating the Part 
Once you are satisified with the order of operations on the Process Table, you can 
simulate your part.  This can be done by clicking the Simulation button in the 
upper left hand corner of the Process Table or by selecting the Simulation button on 
the main tool bar. 

 
1 Once in the Simulation window, choose Start Simulation from the tool bar 

menu or just press the <Space Bar>.  Your simulated part should appear as 
shown below: 

 
You can learn more about using PartMaker’s simulation module in Chapter 4. 
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Generate NC Code 
It is now time to Generate NC Code for the TURNDEMO sample. 

1 From the Job Optimizer menu, select Generate NC Program  

2 Next dialog to appear is Post Options as seen below:  

 
Look at the options - program number and line numbering variables, and click 
<OK> when you are finished. 

3 You will next be prompted for a name for the NC code file. Enter the name 
TURNDEMO. The file extension .TXT will automatically be added to the file: 

 
PartMaker will generate your NC file and display it on the screen.  An example is 
shown below: 
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Printing the Results 
The Print command in the File Menu allows you to print the active (front most) 
window, or print a specific window (a specific face window, for example). 

 
Choose NC Program from the Print menu to print the part program so you can 
examine it more closely. 

As you can surmise, there are many different ways to draw the same profiles, 
some easier, some more difficult. We strongly recommend that you use this 
example as a place to experiment with different methods of creating geometry – 
so that when you get into a production situation where you HAVE to use another 
method, you will know all of the available options. 
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Chapter 4: PartMaker® Simulation 
Introduction 

PartMaker Version 8 and higher comes with an integrated 3D solid modeling process 
simulation and verification module.  This module is available in two levels:  Basic 
Simulation and  Advanced Simulation.  Basic Simulation comes standard with 
PartMaker Turn while Advanced Simulation is available as an optional module with 
PartMaker Turn. 

PartMaker’s Basic Simulation Module allows you to: 

 Simulate all machining processes as they appear on the Process Table 

 Observe the results of any process synchronization 

 Examine a solid model of the part through dynamic rotation and cross-
sectioning 

PartMaker’s Advanced Simulation Module allows you to do all of the above and: 

 View a 3D parametric machine model for your specific machine 

 Automatically check that all tool numbers assigned in the tool database are 
assigned correctly for your specific machine model 

 Customize your machine through the manipulation of an MCH file 

 Detect crashes, collisions and errors between various machine components 
and the part 

 Detect any machine over travels on screen 

Users who have licensed the Advanced Simulation or Full Machine Simulation 
modules may still find it beneficial to use the Basic Simulation module to focus on 
only the part as it is being machined.  

You may choose between Basic and Advanced Simulation by choosing either Basic 
Simulation or Advanced Simulation from the Simulation menu or by right 
mouse clicking on the Process Table and choosing either option.   

Whichever simulation option has been selected will determine which type of 
simulation will be launched. 
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The Simulation Toolbar 
Many of the common functions used in PartMaker’s 3D simulation can be accessed 
via the Toolbar that appears at the top of the Simulation Window as shown here: 

 
Each icon on the Simulation Toolbar is explained below.  The features each of 
these icons enable will be explained in greater depth throughout this chapter. 

 
Starts the simulation 

 
Pauses the simulation 

 
Resets the simulation 

 
Shows the finished 3D model of the part 

 
Allows the user to measure the completed part. 

 
Sets simulation to operate in Basic Simulation mode 

 
Sets simulation to operate in Advanced Simulation mode 

 
Sets simulation to operate in Full Machine Simulation mode 

 
Allows you to take cross sectional views of the completed part 

 
Allows you to show a full view of a part after sectioning 

 
Allows you to manipulate the view of machined part 

 
Allows you to see the Simulation Options dialog 

 
Allows you to see the Spindle Setting  dialog 

 
Shows the Machine Housing 
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Simulation Features 
PartMaker Simulation has a number of process and part analysis features available 
both during and after process simulation is complete.  These features are described 
here: 

Reset 
At any point you can reset the simulation to the initial screen by choosing Reset 
from the Simulation menu.  Alternatively, if you have suspended Simulation by 
pressing <Esc>, you can press <Esc> again to reset the simulation. 

The Reset command is also accessible by clicking the right mouse button when 
viewing the finished part (see below). 

Show Travel Limits 
Displays the travel limits for machine being simulated for each machine component 
depending on how the machine is equipped.  Travel limits for each machine 
components including main spindle, sub spindle and tool posts are set in the 
Machine Date File dialog accessed from the Toolminder menu. 

Show Finished Part 
By choosing the Show Finished Part command from the Simulation menu, you 
can see a 3D model of your programmed part.  You need not run the simulation 
prior to choosing Show Finished Part.  

When choosing Show Finished Part, the verified part alone will appear in the 
Simulation window as shown here: 
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Save Finished Part As STL file 
This will save the finished part to an STL file format.  This can be then used again in 
PartMaker for Custom Stock or Surface Machining. 

Compare Finished Part to Solid Model 
This will use the solid model specified in the Comparison Options Dialog to show 
a comparison of the part to the solid model. 

 

Comparison Options 
This will open the Comparison Options dialog.  This allows you to specify the 
comparison models as well as the over and undercut display colors. 
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View Setting Features 
PartMaker Basic Simulation allows you to automatically set a variety of views when 
simulation has been halted by using the <Esc> key or when using the Show 
Finished Part command.  Various view orientations are available from the View 
sub-menu under the Solids menu. 

Default 
Choosing Default sets the view in the simulation window to the default view 
when Simulation was launched. 

Best Fit 
Choosing Best Fit sets the view in the simulation window to the best fit relative 
to the Simulation window as determined automatically by PartMaker. 

XY View 
Choosing the XY View command sets the view in the simulation window normal 
to the cross sectional plane formed by XY axes.  The axes along which the part 
is defined are constantly active in the lower left hand corner of the simulation 
window. 

YZ View 
Choosing the YZ View command sets the view in the simulation window normal 
to the cross sectional plane formed by YZ axes.  The axes along which the part 
is defined are constantly active in the lower left hand corner of the simulation 
window. 

ZX View 
Choosing the ZX View command sets the view in the simulation window normal 
to the cross sectional plane formed by ZX axes.  The axes along which the part 
is defined are constantly active in the lower left hand corner of the simulation 
window. 

Isometric View 
Choosing the Isometric View command sets the view in the simulation window 
aligned to the X, Y and Z axes.  This view presents the part at a 45 degree 
angle. 

Show Coordinate Axes 
Checking this selection on allows the user to the axes symbol in lower left hand 
corner of PartMaker Simulation Window. 

Show Finished part Origin 
This will hide or show the 3-D axis on the finished part. 

Show Coordinate axis 
This will hide or show the 3-D coordinate system axes in the lower left hand side 
of the simulation window. 

Background Color 
Allows the user to choose the background color of the simulation.  The 
background may be set to gradient by choosing different colors for the Top and 
Bottom Gradient Color respectively. 

Datum Color 
Sets the color of each axis of the datum, X, Y and Z respectively. 
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View Manipulation Features: Rotate, Move and Zoom 
PartMaker simulation allows you to manipulate the view of either the entire process 
simulation or the finished part (when using Show Finished Part).  When using 
PartMaker, one of these commands will be activated, as denoted by a check next to 
it under the Change View sub menu under the Simulation menu.   

Whenever the Rotate, Move or Zoom command is checked, it can be activated by 
holding down the left mouse key and moving your mouse.   

It is advisable to always leave the Rotate command checked as both Move and 
Zoom can always be accessed using keyboard shortcut keys or the mouse.  For 
example, if the Rotate command is checked under the Change View sub menu 
under the Simulation menu, Rotate can be activated by clicking the left mouse 
button and moving the mouse, Move can be activated by holding down the mouse’s 
scroll wheel and moving the mouse and Zoom can be activated by simply scrolling 
the mouse’s scroll wheel. 

PartMaker provides fully dynamic simulation such that the Rotate, Move and Zoom 
commands can be accessed at any time during simulation. 

Rotate 
This command allows you to dynamically rotate the entire process simulation 
within the simulation window.  When using Show Finished Part, Rotate allows 
you to dynamically rotate the solid model of the completed part. 

When Rotate is active, you can rotate the process simulation or finished part by 
clicking the left hand mouse button and dragging your mouse in the orientation 
you would like to see the view. 

Rotate may only be used when it is activated from the Solids menu.  You can 
activate Rotate by choosing it from the Solids menu.  Its activation is denoted 
by a check next to it under the Simulation window. 

Move 
This command allows you to dynamically move the entire process simulation 
around the simulation window.  When using Show Finished Part, Rotate 
allows you to dynamically rotate the solid model of the completed part.   

When Move is active, you can move the process simulation or finished part by 
clicking the left hand mouse button and dragging your mouse in the direction 
you want to move the view.   

You can move the view if Move is NOT active by holding down the <Ctrl> + 
<Arrow> keys on your keyboard, with arrows denoting the direction in which 
the view will move.  These are the same keys used when performing panning in 
PartMaker. 

Additionally, Move can always be activated using the mouse by holding down 
the mouse wheel (if your mouse is so equipped) and dragging your mouse in the 
direction you want to move the view. 

You can activate Move by choosing it from the Solids menu.  Its activation is 
denoted by a check next to it under the Simulation window. 

Zoom 
This command allows you to dynamically size the entire process simulation 
within the simulation window when it has been halted by using the <Esc> key.  
When using Show Finished Part, Zoom allows you to dynamically size the 
solid model of the completed part.   

When Zoom is active, you can scale the process simulation or finished part by 
clicking the left hand mouse button and dragging it upward to increase the size 
of the part and dragging downward to decrease the size of the part.   
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You can scale the view if Scale is NOT active by pressing the <F4> key to 
decrease the size of the view or the <F5> key to increase the size of the view.  
These are the same keys used when performing Continuous Zoom In or Zoom 
Out in PartMaker. 

Additionally, Scale can always be activated using the mouse by scrolling the 
mouse wheel (if your mouse is so equipped) upward to zoom in and downward 
to zoom out. 

Sectioning Features 
PartMaker simulation allows you to section the solid view to inspect the interior of 
the part. Various sectioning options are available by choosing Sectional View from 
the Simulation menu.  Choosing Sectional View opens the Section Finished 
Part dialog as shown below: 

 
1 Sectioning Plane – The Sectioning Plane section of this dialog allows you to 

determine the plane across which sectioning will occur normal to. The use 
can section a finished part normal to the XY, ZY and ZX plane. The axes 
along which the part is defined are constantly active in the lower left hand 
corner of the simulation window.  

2 Dynamic Sectioning – Checking this box enables dynamic section, or the 
ability to see the part being sectioned as you adjust the location of the 
sectional plane.  If Dynamic Sectioning is unchecked, , you will be able to see 
the result of your sectioning by clicking the <Preview> button or by exiting 
this dialog by clicking <OK> 

3 Plane Coordinate - This area of the dialog allows you to adjust the level of 
the sectioning plane. 

4  Reverse Direction - This allows you to reverse the direction of sectional 
plane shown. 
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Simulation Options 
You can manipulate the appearance of simulation by choosing Options from the 
Simulation menu or by clicking the right mouse button in the Simulation Window 
and choosing Options.   

PartMaker Simulation allows you to change the appearance of the view in the 
simulation window when simulation has been halted by using the <Esc> key or 
when using the Show Finished Part command. 

The Options dialog as it appears in Basic Simulation for PartMaker Turn is displayed 
below: 

 

Pause On  
Never: Specifies that simulation should never pause during simulation 

Eject: Specifies that simulation should pause before part eject operation is 
performed 

Cut-off: Specifies that simulation should pause after the cut-off operation is 
performed  

Every Process: Specifies that simulation should pause at the beginning of every 
process in the current Process Table 

Selected Process: Specifies that simulation should pause at the beginning of a 
selected process in the current Process Table  

Every Move: Specifies that simulation should pause before every tool move 

Tool Collision: Specifies that simulation should pause every time a collision 
occurs 

Tool Overtravel: Specifies that simulation should pause every time tool post 
goes outside of its travel limits specified in the Machine File. 

Settings  
Turning Insert Thickness: Specifies the thickness of the turning insert 
Max ID Tool Holder Thickness: Specifies the maximum thickness of a tool 
holder for inside diameter tool. 
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Enable Collision Checking/Report Collision Types 
Checking the Enable Collision Checking box allows you to detect the following 
collision types in Simulation: 

Tool with Stock(s) on Rapid Move: Specifies that PartMaker should check for 
collisions between the tool (or insert) and that stock in the main spindle as well 
as a part in sub-spindle 

Tool with GB and/or Sub-Spindle: Specifies that PartMaker should check for 
collisions between the tool (or insert) and the Guide Bushing and/or Sub-Spindle 

GB and Sub-Spindle: Specifies that PartMaker should check for collisions 
between the Guide Bushing and Sub-Spindle. 
Tool Holder Collision: Specifies that PartMaker should check for Tool Holder 
collisions with any part/stock as well as with the Main Spindle and Sub-Spindle 

Tool with Foreign Stock: Specifies that PartMaker should check for collisions 
between the tool (or insert) working on the Main Spindle with part in the Sub-
Spindle or between the tool (or insert) working on Sub-Spindle with the stock or 
part in the Main Spindle 

Tool with Tool: Specifies that PartMaker should check for collisions between two 
tools on the machine. This is for Advanced an Full Machine simulations only. 

Tool with Toolpost: Specifies that PartMaker should check for collisions between 
a tool and another tool post on the machine.  This is for Advanced and Full 
Machine simulations only. 

Toolpost with Toolpost: Specifies that PartMaker should check for collisions 
between tool posts on the machine.  This is for Advanced and Full Machine 
Simulations only. 

Toolpost with Stock: Specifies that PartMaker should check for collisions 
between a tool post and the stock being machined.  This is for Advanced and Full 
Machine Simulations only. 

Toolpost with Spindle:  Specifies that PartMaker should check for collisions 
between a tool post and the main or sub spindle.  This is for Advanced and Full 
Machine Simulations only. 

Non-Active Tool with Spindle:  Specifies that PartMaker should check for 
collisions between a tool not in the cut and the main or sub spindle.  This is for 
Advanced and Full Machine Simulations only. 

Non-Active Tool with Stock:  Specifies that PartMaker should check for collisions 
between a tool not in the cut and the stock.  This is for Advanced and Full 
Machine Simulations only. 

Tool with Machine Housing:  Specifies that PartMaker should check for collisions 
between a tool (or insert) and the machine housing.  This is for Full Machine 
Simulation only. 

Display Control 
Time Delay (0...9): Specifies a time delay following every screen update for 
every tool motion.  Negative number -9 to -1 may also be used to speed 
simulation more then 0. 

Transparency of GB/Sub-Spindle: Specifies how transparent the Main Spindle 
and/or Sub-Spindle should appear. 0% means solid appearance, 100% means 
‘fully transparent’ appearance, i.e. the Guide Bushing and/or Sub-Spindle will 
become invisible. 
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Transparency of Stock/Part: Specifies how transparent the part and/or stock 
should appear. 0% means solid part, 100% means "fully transparent" part, i.e. 
an invisible part. 

Display Status: Specifies that the current simulation status consisting of the 
Process ID and current Tool Point coordinates will be displayed on the top of the 
Simulation window 

Run in a Loop: Specifies that Simulation will run in a continuous loop 

Hide Tool Holders:  Specifies that Tool Holders for Turning Tools will not be 
displayed during Simulation 

Display Status:  Allow the Simulation to display coordinate and movement 
information at the top of the simulation window. 

Cosmetic Thread: Specifies that during Simulation every Multi-Pass helical 
thread will be replaced by a single pass in order to speed up simulation. 

Software Rendering: Specifies that Open GL software graphics libraries should 
be used instead of the hardware implementation of the Open GL drivers that are 
dependent on the actual Graphics Video card used in every computer. If you use 
a high performance AGP video card you may achieve a significant simulation 
speed improvement if you do not use Software Rendering 
Wireframe Display: Specifies that everything will be displayed using a wire 
frame representation instead of solid modeling. 

Show Tool Numbers on Tool Posts:  This will show all tool numbers available 
on a tool post on the solid for that tool post.   This is for Advanced Simulation 
only. 

Show Machine Housing:  This will show the Machine Housing Components 
specified in the Machine File. This is for Full Machine Simulation only. 

Display Quality 
Coarse: Specifies that solids will be displayed using relatively large facets to 
assure the fastest simulation 

Medium: Specifies that solids will be displayed using medium size facets that will 
result in lesser simulation speed 

Fine: Specifies that solids will be displayed using very small size facets that will 
result in further decrease in simulation speed 

Apply to All Machine Components: Specifies that solid models will be 
converted to simulation models with the specified Display Quality (Coarse, 
Medium, Fine), regardless of the quality specified in its model data.  These solid 
models can include custom stocks and tool posts. 

Colors and Textures 
Use Group Colors: Specifies that user-defined Group Colors will be used as cut 
colors. If this option is not checked a metallic gray color will be used as cut color 
for all tools 

Set Stock Color: Allows a user to choose the color of initial stock using a 
Windows standard dialog. 

Set Stock Texture: Opens the Texture Dialog for various texture options for 
the stock. 
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Using PartMaker Basic Simulation 
PartMaker Basic Simulation can be viewed at any point in the programming process.  
You need not complete programming a part to see the results of your work. 

Important! To launch PartMaker Simulation you must have a Process Table 
generated.  To generate the Process Table, choose Generate Process Table from 
the Job Optimizer menu (ALT + P) or use the Generate Process Table icon from 
the Main Toolbar.  It is not necessary to complete synchronization of simultaneous 
operations before launching PartMaker Simulation. 

Launching Basic Simulation 
To launch PartMaker Basic Simulation: 

1 Click the Start Simulation icon from the Main Toolbar 

or 

Press the Simulation button in lower left hand corner of the Process Table 

or 

Choose Simulation from the Simulation menu 

2 Make sure the Basic Simulation icon on the Simulation Toolbar is 
checked or Basic Simulation is checked under the Simulation menu  

Upon launching simulation, you will see an uncut cylindrical work piece. 

A newly launched simulation window is shown below: 
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Running Simulation 
Once you have launched PartMaker Simulation, to start machining: 

1 Press the Start Simulation  button on the Simulation Toolbar  

or 

Press the <Space Bar> on your keyboard  

or  

Select Start Simulation from the Simulation Menu 

2 Once simulation has started, you can suspend cutting by pressing the <Esc> 
button on your key board. Press the <Space Bar> to continue the 
simulation.  Below, is an example of suspending simulation in process: 
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Using PartMaker Advanced Simulation 
PartMaker Advanced Simulation can be viewed at any point in the programming 
process.  You need not complete programming a part to see the results of your 
work. 

None of the examples listed above is meant to represent a specific machine model. 
You will be able to view a more machine specific model for your machine when 
loading the *.MCH file specifically tailored to the machine you are programming. 

Launching Advanced Simulation 

 Important!  For purposes of this tutorial, please load the *.job, *.tdb and 
*.cdb files called Turndemo.job, Tools.tdb and Cycles.cdb located in the 
C:\PartMaker\pm-turn directory. 

Important! To launch PartMaker Advanced Simulation you must have an 
*.MCH (machine configuration file) loaded.  The MCH file contains a 
description of the machine you are using to machine the part. 

You will only be able to launch PartMaker Simulation when the Process Table is 
generated.  If you do not have a Process Table generated, choose Generate 
Process Table from the Job Optimizer menu. 

To launch PartMaker Advanced Simulation: 

3 Click the Start Simulation icon from the Main Toolbar 

or 

Press the Simulation button in lower left hand corner of the Process Table 

or 

Choose Simulation from the Simulation menu 

4 Make sure the Advanced Simulation icon on the Simulation Toolbar is 
checked or Advanced Simulation is checked under the Simulation menu  

Upon launching simulation, you will see an uncut cylindrical work piece, tool 
posts with tools attached, and either one or two spindles depending on whether 
your part involves both main and sub spindle operations. 

A newly launched simulation window is shown below: 
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Running Simulation 
Once you have launched PartMaker Simulation, to start machining: 

5 Press the Start Simulation button on the Simulation Toolbar  

or 

Press the <Space Bar> on your keyboard  

or  

Select Start Simulation from the Simulation Menu 

6 Once simulation has started, you can suspend cutting by pressing the <Esc> 
button on your keyboard. Press the <Space Bar> to continue the 
simulation.  Below, is an example of suspending simulation in process: 
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Machine File for Advanced Simulation  
The machine you are seeing in PartMaker’s Advanced Simulation is described by a 
Machine Description stored in a *.MCH file.  Each machine architecture will have a 
separate Machine Description.  The Machine Description may be viewed 
graphically by choosing Machine… from the ToolMinder menu.  When doing so, 
the following dialog appears: 

 
See PartMaker Help for a more in depth explanation of each of the dialogs and 
parameters in the Machine Data File dialog. 
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When should you use Basic vs. Advanced Simulation? 
Basic and Advanced Machining Simulation are not mutually exclusive technologies.  

Basic Simulation may be preferable to use in certain circumstances over Advanced 
Simulation because it: 

 Provides more focus on just the part and cutting process because space is 
not taken up on screen with multiple machine components. 

 Can run faster then Advanced Simulation because it is less graphically 
intensive. 

Advanced Simulation will be preferable to use in certain circumstances over Basic 
Simulation because it: 

 Provides a machine specific simulation, i.e. supports right and left-handed 
machines, specific machine components, etc. 

 Provides additional crash and collision avoidance over Basic Simulation 

 Gives the user verification that all tools numbers are correct for a given 
machine 

As a rule of thumb, you may find Basic Simulation more beneficial for simulating 
your “first pass” at programming a part, while Advanced Simulation may be better 
when completing the programming of the entire component at which time you wish 
to see how the part will look as well as how it will run in its machine environment. 

Advanced Simulation Limitations 
The machine model you are seeing in PartMaker’s Advanced Simulation is a 
parametrically defined model of the machine you are programming.  As it is 
based on parametric approximations, it may not simulate your machine exactly 
the way it looks.  The limitations you may find at this point are: 

Multiple Tool Stations 
Multiple Tool Stations only applicable to the tools on the Turret. A Multiple 
Tool Station is the station on the turret that has more than one tool with the 
same Tool Number defined in Tool Data Dialog. During Advanced Simulation 
only one tool on the tool stations is shown. Therefore the tools that belong to 
the multiple tool station will be switched on the Turret based on the 
sequence in the Process Table.  

Non-Standard Machine Architectures 

PartMaker Advanced Simulation may not support certain elements of 
machines with irregular architectures at this time. 

Please consult PartMaker Technical Support for more information on any 
limitations you may encounter with respect to Advanced 3D Machining 
Simulation. 
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Appendix A: Materials 
PartMaker Material Library 

This appendix contains a list of all material files and their abbreviations. 

File Description 

ALU_ALLC.MDB Aluminum Alloy, Cast 

ALU_ALLW.MDB Aluminum Alloy, Wrought 

CARBIDES.MDB Machinable Carbides  

CHNICKEL.MDB Chromium-Nickel, Alloy 

COP_ALLC.MDB Copper Alloy, Cast  

COP_ALLW.MDB Copper Alloy, Wrought 

IRON_DUC.MDB Ductile Iron, Cast  

IRON_GRC.MDB Gray Iron, Cast 

LEADALLC.MDB Lead Alloys, Cast  

MAG_ALLC.MDB Magnesium Alloys Cast 

MAG_ALLW.MDB Magnesium Alloys Wrought 

NICKELWC.MDB Nickel Alloys, Wrought and Cast 

ST_ALLOW.MDB Alloy Steels, Wrought 

ST_CARB.MDB Carbon Steels, Wrought 
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File Description 

ST_FMCAW.MDB Free Machining Carbon Steel, Wrought 

ST_FMSTW.MDB Free Machining Stainless Steel, Wrought 

ST_STAIC.MDB Stainless Steel, Cast 

ST_STAIW.MDB Stainless Steel, Wrought 

ST_STRUW.MDB Structural Steels, Wrought  

ST_TOOLW.MDB  Tool Steel, Wrought 

THERMOPL.MDB Thermoplastics 

TIN_ALLC.MDB Tin Alloys, Cast 

TIT_ALLC.MDB Titanium Alloys, Cast 

TIT_ALLW.MDB Titanium Alloys, Wrought 

ZINCALLC.MDB Zinc Alloy Cast 
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Appendix B: Family of Parts 
Programming Tutorial 
Introduction 

This tutorial will teach you how to use PartMaker’s Family of Parts Programming 
Feature. 

PartMaker Version 4.6 and higher features a unique Family of Parts Programming 
(FOP) capability, which greatly speeds CNC programming for parts created from 
tabulated drawings.  This feature allows a programmer to program one part in a 
family and then automatically substitute any variable parameters by manipulating a 
separate file containing parameter definitions.  A virtually unlimited number of 
parameter files (*.prm files) can be defined by the user.  

FOP is an available option with every PartMaker product, namely, PartMaker/Mill, 
PartMaker/Turn, PartMaker/Turn-Mill and PartMaker/SwissCAM. It applies to Turning 
as well as Milling faces. 

 The steps presented in this tutorial are carried out in PartMaker 
SwissCAM but can be used in any PartMaker application. 

Sequence of Steps for Family of Parts Programming 
The steps outlined below describe the sequence in which you should approach 
programming Families of Parts from tabulated drawings.  This programming tutorial 
follows the sequence of steps below in creating a typical family of parts. 

You can use this page as desk reference when programming a Family of Parts. 

1 Create Part Geometry for one part in the family using actual numbers.  It 
is not critical which part number in the family you choose. 

2 Setup PartMaker Databases appropriately, i.e. make sure all tools, 
materials and cycles files for the part have been set appropriately 

3 Assign part features to your geometry.  When doing so, make sure to 
assign toolpaths by snapping to existing geometry.  If you do not snap tool 
paths to existing and parameterized geometry, they will not be updated 
when you regenerate other parts in the family. 

4 Create the appropriate Parameter Files (*.prm) for each part in the 
family.  Each Parameter File contains the variable definitions for each part in 
the family. 

5 Setup PartMaker for Parametric Input by clicking the Parametric Input 
box in the  Family of Parts section of the Preferences dialog which can be 
found under the View menu. 

6 Parameterize your part by assigning variables to parametric geometric 
elements and part features such as thread pitch and hole depth. 

7 Set Part Boundaries Parametrically by choosing Set Parametric 
Boundaries from Family of Parts Programming accessed from the Edit Menu. 

8 Update Each Part in the Family by opening the respective Parameter File 
by choosing Open Parameter File from Family of Parts Programming, then 
choosing Apply Parametric Dimensions. 

9 Regenerate NC Code for each part in the family by choosing Generate 
Process Table from the Job Optimizer menu and then choosing Generate NC 
Program from the Job Optimizer menu. 
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Getting Started 
The blue print below represents a typical parametric part.   

 
 

Part # A B C D E F P/Pitch 

50-100 0.25 1.0 1.5 25 0.4 3.0 0.05 (20) 
50-200 0.25 0.8 1.0 15 0.38 2.5 0.03 (30) 
50-300 0.1875 0.7 0.75 25 0.3 2.0 0.05 (20) 
50-400 0.2 0.5 0.6 30 0.3 1.5 0.1 (10) 
50-500 0.3125 0.4 0.5 35 0.35 1.25 0.04 (25) 

When you complete this tutorial, you will have parts that looks like the picture 
below: 
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Create Part Geometry 
The first step in programming a part in a family of parts is to create the part 
geometry.  When doing so, you should pick one part number from the family.  In 
this case, the Part #50-100 in the table on page B-2 will be used. 

1 Double click on the SwissCAM icon on your desktop or choose SwissCAM 
from the PartMaker Group accessed through Programs under the Windows 
Start button. 

2 You will then see the Setup definition dialog box. 

3 Enter the enter the parameters listed below in the appropriate fields: 

• Length (L): 3.0 • OD: 0.4 

• Excess Stock (E): 0.0
1 

• ID: 0.0 

• GB Length (l): 1.0 • GB Dia (d): 0.75 

• Tool Change X(Xc): 2.8 • Tool Change Z (Zc): 0.0 

The setup dialog will then appear below.  

 
4 When you are satisfied that your Setup dialog appears as the one above, 

click the <Apply> button. This will apply the parameters to the current Face 
Window.  Click the <Close> button to close the Setup dialog. 

5 In the CAM Face Window, choose Show Axes from the View menu.  This 
will display the horizontal and vertical axis lines which will help you create 
the geometry. 

6 Click on the CAD/CAM switch in the lower left-hand corner of the window. 
The icon will change its appearance from cutting tools to a pencil. 

7 Select the Connected Lines Icon from the drawing icons on left side of the 
Face Window. Here, you will draw the part in the print on the second page 
of this chapter by plotting ZX coordinates, using the ZX Snap Mode from 
the Snap Modes icon bar at the top of the screen.  

After selecting the ZX Snap Mode two data entry fields will appear in the 
lower left hand corner of the Face Window.   
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Now enter the ZX coordinates as shown below, pressing <Enter> after 
each: 

default 0.25 

1 default 

default 0.4 

3 default 

default 0 

After entering these coordinates, you should have a drawing which appears as 
the profile below: 

 
8 You will now place the diagonal line represented by the “D” dimension on.  

To do so, select the Line on an Angle icon and select the End of Line snap 
mode.  

When doing so, you will be prompted to Select end point of line or arc.  
Drag your cursor into place as shown below and click the left mouse button. 

 
You will now be prompted to enter an angle for this line.  At the prompt 
enter a value of 155 (i.e. 180 – 25) and press <Enter>. 

Move your cursor so the arrow is on the line as shown below and click the 
left mouse button. 

 
Having done so, you will now have a drawing which appears as shown below. 

 
Now select the Remove icon and click the scissors on lines 1 and 2 in the 
picture below.  

 
After having done so, your geometry will appear as shown below: 

 

 Note: When programming Families of Parts, you SHOULD NOT mirror 
geometry for turning features about the Z-axis.  Doing so will cause the 
lower half of your part geometry to look derformed when you generate 
other parts in the family.  Alternatively, you could also parameterize the 
lower half of your part geometry (though this would entail additional 
work).  Parameterizing geometry will be discussed in Step 5. 
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Setup PartMaker Databases 
The second step in programming a part in a family of parts is make sure the proper 
Tools, Materials and Cycles have been created and loaded in PartMaker. 

1 Open the Tools file by choosing Open Tools File from the File menu. 

2 From the Family_of_Parts directory, choose shaft_inch.tdb and click <OK>. 

 
3 Open the Cycles file by choosing Open Cycles File from the File menu. 

4 From the Family_of_Parts directory, choose shaft_inch.cdb and click <OK> 

. 

5 Open the Materials file by choosing Open Material File from the File menu. 

6 Choose st_fmstw.mdb and click <Open> 

.  
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Assign Part Features 
Once you have created your part geometry and loaded the appropriate tools, 
materials and cycles files, you are ready to assign part features to your geometry.   

 Note: When programming Families of Parts, it is important to always assign 
part features to your part by snapping to geometry instead of using the ZX 
Snap Mode.  Tool paths not associated with geometry will not be rescaled 
when updated for other parts in a part family.  

1 Before assigning the facing operation to the part, it is necessary to create 
the geometry to which the facing tool path will be assigned. To do so, while 
still in the CAD Mode, choose the Line Through Two Points and ZX Snap 
Mode.  

Now enter the ZX coordinates as shown below, pressing <Enter> after 
each: 

(0,.4) 

(<default>,0) 

After having done so, your geometry will appear as shown below: 

 
2 Click on the CAD/CAM switch to return to the CAM mode and create the 

part feature for the facing operation by choosing New Profile Group from 
the Part Features menu. 

a From the Strategy menu, choose Contouring.  

b From the Tool Location menu, select Out.  

c From the Tool Orientation menu, select Right. 

d Click the Select Tools button and allow PartMaker to select the 
appropriate tool.  

e In the field called Group Name, enter Face Off. Your dialog should now 
appear as shown below: 

 
Click Apply and Close. 
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Now that you have defined the machining operation to be used, you must tell 
PartMaker where to place the tool path: 

1 From the left-hand side of the screen select the Define Profile icon.  

2 From the top of the screen, select the End of an Element snap mode.  

3 Click your cursor at points 1 and 2 below: 

 
Your completed profile should appear as below: 

 
4 Click the Selection icon to bring yourself to a home or neutral position.  

Before moving on, save your work! Do so by selecting Save from the File menu or 
using the shortcut key <Ctrl + S>. Give your job file a name you will remember. A 
good job file name for part families is Master. 

Next, you will program the first outside diameter turning feature. 

1 Create the first OD Turning tool path by choosing a new color and selecting 
New Profile Group from the Part Features menu. 

a From the Strategy menu, choose Contouring. 

b From the Tool Location menu, select Out. 

c From the Tool Orientation menu, select Right. 

d Click the Select Tools button and allow PartMaker to select the 
appropriate tool.  

e In the field called Group Name, enter OD Turn. Your dialog should now 
appear as shown below: 
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Now that you have defined the machining operation to be used, you must tell 
PartMaker where to place the tool path: 

2 From the left-hand side of the screen select the Define Profile icon. 

3 From the top of the screen, select the End of an Element snap mode.  

4 Click your cursor at points 1,2 and 3 below: 

 
Your completed profile should appear as shown below: 

 
Next, you will program the outside diameter threading feature. 

1 Create the OD Threading tool path by choosing a new color and selecting 
New Profile Group from the Part Features menu. 

a From the Strategy menu, choose Threading. 

b From the Tool Location menu, select Out.. 

c Select Chamfer on Exit from the Toolpath Options drop dop list.  

d Specify the pitch as 0.05. 

e Click the Select Tools button and allow PartMaker to select the 
appropriate tool.  

f In the field called Group Name, enter OD Thread. Your dialog should 
now appear as shown below: 

 
2 From the left-hand side of the screen select the Define Profile icon. 

3 From the top of the screen, select the Closest Intersection snap mode.  

4 Click your cursor at points 1 and 2 below: 

 
Your completed profile should appear as shown below: 
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Next, you will program the drilled hole. 

1 Create the drilled hole by choosing a new color and selecting New Hole 
Group from the Part Features menu. 

a Uncheck the Through Hole box 

b From the Major Cycle Operation drop down menu, choose Drill 

c Enter .1 in the Diameter field 

d Enter .01 in the Chamfer field 

e Enter 1.5 in the Nominal Depth field 

f Click the Cycle button and allow PartMaker to select the appropriate 
cycle.  

Your completed Hole Group Parameters dialog should now appear as shown 
below: 

 
2 Your completed profile should appear as shown below: 

 
Next, you will program the second outside diameter turning feature. 

1 Create the second OD Turning tool path by choosing a new color and 
selecting New Profile Group from the Part Features menu. 

a From the Strategy menu, choose Contouring. 

b From the Tool Location menu, select Out. 

c From the Tool Orientation menu, select Right. 

d Click the Select Tools button and allow PartMaker to select the 
appropriate tool.  
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e In the field called Group Name, enter 2nd OD Turn. Your dialog should 
now appear as shown below: 

 
2 From the left-hand side of the screen select the Define Profile icon. 

3 From the top of the screen, select the End of an Element snap mode.  

4 Click your cursor at points 1 and 2 below: 

 
Your completed profile should appear as shown below: 

 
Finally, you will program the cut-off operation. 

When creating a cut-off operation using PartMaker’s Family of Parts programming 
feature, you will need to assign the part feature to the geometry instead of having 
PartMaker do so automatically for you as you would in conventional use of the 
software. 

5 Create the Cut-off tool path by choosing a new color and selecting New 
Profile Group from the Part Features menu. 

a From the Strategy menu, choose Cut-Off 

b In the Start X Point (Xs) enter .4/2 

c Click the Select Tools button and allow PartMaker to select the 
appropriate tool.  

d In the field called Group Name, enter Cut-off.  
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Your dialog should now appear as shown below: 

 
Your completed part should appear as shown below: 

 
6 Before continuing, choose the Selection icon a delete the tool path that has 

been automatically applied to the geometry. 

7 Using the Profile icon and End Of Element Snap Mode, reapply the tool path 
to the geometry by clicking at the start and end of the cut-off tool path.  
Your completed part will appear as shown below: 
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Creating Parameter (*.prm) files 
Once you have completed programming the “master” part in the family, you must 
now take a step back and setup files containing parameter definitions for each part 
in the family. These files can be created in any word processing program and then 
saving files with *.prm extension.  In this example, Notepad (which comes loaded 
on every Windows operating system) will be used 

1 Create the first parameter for the “master” part that has already been 
programmed.   

Note:  To make creating the first parameter file faster, start by 
manipulating an existing file, either from a part family you have made 
before or from the parameter files which came standard with your 
PartMaker installation. 

2 From the Start button on your Windows desktop, choose Accessories and 
launch the Notepad application. 

3 In Notepad, from the File menu, choose Open.  In the Open dialog, choose 
All Files *.* from Files of Type as shown below: 

 
4 Choose an existing parameter file . In this example, open the file titled 42-

100_inch.prm that can be found in the Family of Parts directory (located 
in the root directory of the PartMaker module you are working with.) 
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5 Edit the parameter file to reflect the parameters being used in the current 
Family of Parts. Replace the parameter values with those you have used in 
the creation of part 50-100 above. 

 Note:  All text and characters in parenthesis are comments and will not 
affect programming.  Comments will help you remember which 
parameters correspond to various features of your part. 

Once you have defined the parameters for the part, save your Parameter File as 
50-100.prm by choosing Save As from the File menu as shown below: 

 
6 Click <Save> to save your file.  The saved parameter file for 50-100 should 

appear as shown below: 
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7 Having created the first parameter file, create a file for all other parts in the 
family by simply replacing parameter values and saving a *.prm file for each 
part in the family.  The parameter values for each part for this exercise can 
be found on page 2 of this appendix.  When finished, you should have five 
parameter files as shown below: 

 

Setup PartMaker for Parametric Input 
In order to be able to apply parametric dimensions to the part, you must enable 
Parametric Programming. 

1 Choose Preferences from the View menu and check the Parametric Input 
box as shown below: 

 
2 Once you have checked Parametric Input, click <OK>. 
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Parameterize Your Part 
Now that all the appropriate parameter files have been created, you can assign 
parametric variables to the master part in the family.  Before proceeding, make sure 
all parameter files have been saved and are closed. 

1 Click on the CAD/CAM switch to return to the CAD mode.  Any part 
parameterization exercise should always start in the CAD mode.   

2 Double click on the line segment drawn vertically along the face of the part 
as shown below: 

 
Doing so will allow you to access the Parametric Line Info dialog.  Define 
the parametric relationship as shown below: 

 
3 Once the dialog appears as above, click <OK>. 

The next geometric element to be parameterized will be the thread as shown 
below: 

 
4 Double click on the horizontal line segment along which the thread is applied 

to access the Parametric Line Info dialog.  Define the parametric 
relationship as shown below: 

 
5 Once your dialog appears as above, click <OK>. 

Note:  In PartMaker, all Z dimensions are programmed in negative. 
Whenever performing mathematical operations on parameters, always 
make sure to use parenthesis as shown here.  PartMaker observes 
standard mathematical order of operations for multiplication, division, 
addition, subtraction and the application of trigonometric functions. 
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The next geometric element to be parameterized will be the chamfer as shown 
below: 

 
6 Double click on the diagonal line segment of the chamfer to access the 

Parametric Line Info dialog.  Define the parametric relationship as shown 
below: 

 
Notice the use of the use of trigonometric relationships in Family of Parts 
programming. PartMaker data entry fields can accept trigonometric functions. 
Once your dialog appears as above, click <OK>. 

The next geometric element to be parameterized will be the largest horizontal 
diameter as shown below: 

 
7 Double click on the horizontal line segment of the OD to access the 

Parametric Line Info dialog.  Define the parametric relationship as shown 
below: 

 
8 Using the Copy and Paste functions from the Edit menu (standard windows 

accelerator keys Ctrl + C and Ctrl + V) you can copy and paste parametric 
relationships from one dialog to another. Once your dialog appears as above, 
click <OK>. 

The next geometric element to be parameterized will be the geometry along 
which the cut-off operation is defined: 

 



 

Copyright @2014 Delcam Ltd  User Guide B-17  

 

Double click on the diagonal line segment of the chamfer to access the 
Parametric Line Info dialog.  Define the parametric relationship as shown 
below: 

 
Once your dialog appears as above, click <OK>. 

9 Click on the CAD/CAM switch to return to the CAM mode.  The 
parameterization exercise will be completed by applying parametric 
dimensions to programmed part features.   

Note: In Machining Function Face Windows of Type Turn, in the Profile 
Group Parameters dialog, Strategy types Threading and Cut-off allow 
for parametric input. In Milling Machining Function Face Window, all 
Profile Group Parameters cycles accept parametric input.  The Hole 
Group Parameters dialog also accepts parametric input. 

When using Parametric Input you will notice the appearance of Parametric 
Input icons. Clicking on these icons allows you to enter parametric data for 
part features. 

Double click on the OD Thread Group Symbol on the right hand side of the 
screen to enter the Profile Group Parameters dialog for threading as 
shown below: 

 
10 Click on the Set Parametric Pitch icon to insert a parametric value for 

Thread Pitch as shown below: 

 
11 Once your dialog appears as above, click <OK>.  Click <Close> in the 

Profile Group Parameters dialog to return to the CAM Face Window. 
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Next, parameterize the depth of the hole programmed on centerline.  To do so: 

12 Double click on the group symbol for the on-centerline drilled hole.   

 
13 Click on the Set Parametric Pitch icon to insert a parametric value for Z 

Depth as shown below: 

 
14 Once your dialog appears as above, click <OK>.  Click <Close> in the 

Profile Group Parameters dialog to return to the CAM Face Window. 
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Set Part Boundaries Parametrically 
The final step in setting up a parametric part is to set the part boundaries 
parametrically. To do so: 

1 Choose Family of Parts Programming from the Edit menu. 

2 Choose Set Parametric Boundaries… from the Family of Parts Programming 
menu as shown below: 

 
3 Complete the Set Parametric Boundaries dialog as shown below: 

 
Once the dialog appears as above, click <OK> to return to the CAM Face 
Window. 
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Update Each Part in the Family 
You have now completed setting up your master part and our now ready to 
automatically program each other part in the family.  To automatically reprogram 
other parts in the family: 

1 Choose Family of Parts Programming from the Edit menu. 

2 Choose Open Parameter File... from the Family of Parts Programming menu 
as shown below: 

 
Select the parameter file for the part you would like to program.  In this case, 
choose 50-500.prm as shown below: 

 
 Once the dialog appears as above, click <Open> to return to the CAM Face 
Window. 

3 Choose Apply Parametric Dimensions... from the Family of Parts 
Programming menu as shown below: 

 
You should now see your part change size on screen. 

Regenerate NC Code 
You can update your NC program for each part in the family by regenerating the 
Process Table and then choosing Generate NC Program. 
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Appendix C: Programming Directly on a 
Solid Model 
Introduction 

This document describes the process of programming directly on a Solid Model in 
PartMaker Turn-Mill, SwissCAM and Turn Version 9.1 and higher. 

 NOTE: The steps presented in this tutorial are carried out in PartMaker 
SwissCAM but can be used in any PartMaker application. 

Key Definitions 
Part Coordinate System (PCS):  A part coordinate system (PCS) is the coordinate 
system in which a solid model is oriented. Before any programming exercise begins, 
you should always set the PCS to be the same as the coordinate system of the 
machine you are programming.  You can use the Edit Coordinate System dialog 
to place the origin on the front of the part and set the axes to be coincident with the 
machine’s coordinate system. Being set initially the PCS should not change during 
the programming session. 

 
Face Coordinate System (FCS): This is a coordinate system with two axes in the 
Face Plane and the third axis perpendicular to the Face Plane. The Face Plane is a 
plane in which the tool paths in the active PartMaker Face Window are created. Each 
Face Window can have its own Face Plane. The Face Plane must be set in the 
correct place to properly program on the Solid Model.  The Face Plane can be 
displayed using the Show Face Plane icon. The Face Plane can be set and 
manipulated using the Define Face Plane dialog. 
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Face Plane Icons for Solid Model: 

 
Show Profiles and Holes on Solid Model: You will need to have this feature 
activated to program directly on the Solid Model. This will allow you to view the 
Profiles as they are created. 
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Solids Programming Tutorial 
This tutorial is designed to help you learn the steps to follow for using PartMaker 
SwissCAM, Turn-Mill and Turn to program on a Solid Model. 

The complete finished job files can be found in the following directories as incidated: 

SwissCAM   C:\PartMaker \PM-Swiss\Solids_Programming_Tutorial 

Turn-Mill  C:\PartMaker \PM-TM\Solids_Programming_Tutorial 

Turn  C:\PartMaker \PM-Turn\Solids_Programming_Tutorial 

How you will create the Sample part 
Here are the major steps you will follow to create the Swiss tutorial part: 

√ Start PartMaker 

√ Open Sample Program and Review 

√ View tool information for the part 

√ View cycle information for the part 

√ Select a material for the part 

√ Open a new Face Window 

√ Create Profile and Hole Groups 

√ Extract Information from the Solid Model 

√ Create a Process Table 

√ Simulate the Machining Process 

√ Generate an NC Program 
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The picture below shows the part to be programmed in this tutorial. 

 
 

 

When you complete this tutorial, you will have a part that looks like the picture 
below. 

 

Getting Started 
The machining functions used in this tutorial are as follows:  

Turn 
Use turning tools to perform a variety of turning operations including Facing, 
Threading, Grooving, Drilling, Tapping and Pick-off. 

Mill ZY 
Use an end mill to create a set of flats. 

Programming on the Solid Model can be accomplished for almost every Machining 
Function needed. In most cases you will not need to work in the 2D Face window at 
all. 

Now you will look in detail at the steps necessary to program a part. 
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Starting PartMaker 
1 Double click on the PartMaker SwissCAM icon 

2 You will see the Setup definition dialog box shown below. Click the <Close> 
button. 

This dialog is explained in greater depth starting on page 8 of this guide. 

 

View the Finished Sample 
1 Use the Open All Files Command from the File Menu. 

2 You will find the Job Files in the Follwing Directories. 

SwissCAM C:\PartMaker\PM-Swiss\Solids_Programming_Tutorial 

Turn-Mill C:\PartMaker\PM-TM\Solids_Programming_Tutorial 

Turn C:\PartMaker\PM-Turn\Solids_Programming_Tutorial 

 Note: This will also open the Sample Tools and Cycles files for you to use 
when you create your own Part. 

3 Look through the Sample Job file and familize yourself with the Profiles and 
Hole Groups. 

4 When Ready, choose New Job from the File Menu. 
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Select a Material for the Part 
The work piece in this exercise will be machined from Free Machining Stainless 
Steel, Wrought. To load this material: 

1 Choose Open Material File from the File menu. 

2 Choose st_fmstw.mdb as shown below and click <Open>. 

 
 

You have now loaded the tools, cycle, and material files that were previously 
developed for the Solid Model Programming Sample. 
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Importing a Solid Model 
1 Select the Import icon and select the X_T Parasolid Transmit Text File 

option. 

 
 

2 Choose the Swiss_Solids_Programming_Tutorial.X_T file and click <Open> 
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Setting up the First Face Window 
In this section, you will set up the Face Window for the turning operations on the 
main spindle. To do so: 

1 When Programming with a Solid Model, many items will be set automatically 
from the information obtained from the Solid Model. To import settings into 
the Set-up Window, you will need to define a faceplane. Select the Define 
Face Plane icon from the Solids Tool Bar. 

2 For Swiss and Turn-Mill parts, you should define your Face Plane at an Angle 
which will allow you to select the Points you will need for Turning in this first 
window. Check the Set Face Plane box. Choose Parallel to ZX Plane from 
the Drop Down Menu. Enter 45 into the Turning Plane Angle field and click 
the Set Boundaries checkbox. 

 
3 Click the <Preview> button to see the Face Plane on the Solid Model 

update. 

 
4 Click <OK> 
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5 Open the Set-up Window. Note the Part Length and OD were imported from 
the Solid Model. You should now make any changes required for your Setup 
dialog. Make the following changes to the Setup Dialog. 

 

Spindle: Main Spindle 

Stock: Bar 

Machining Function: Turn 

OD: 0.59055118 (For Stock Size) 

Excess Stock: .03 
 

Your Set-up Window should appears as below: 

 
6 Click <Apply> and <Close> 
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Programming a Face Operation 

1 Select the New Profile Group icon. 

2 Change the Following settings in the Profile Group Parameters dialog and 
Leads Out, Finishing dialog 

Strategy Turning 

Tool Location Face 

Tool Orientation Left 

Remove Check Roughing 

Check Finishing 

Lead Out Angle (A2) 90 Degrees (click Leads button) 

 
3 Click <Select Tools> and choose the OD Turn - 55 Turning Tool. 

 



 

Copyright @2014 Delcam Ltd  User Guide C-11  

 

4 Name the Group Face. Your dialog should look like the following. 

 
5 Click <Apply> and <Close> 

6 You should now see a Facing Profile created on the Solid Model. 

 
7 To verify the tool path for the Profile Group, Select the Verify Work Group 

Toolpath icon. 

8 The Verify Options Dialog will now Display. Make sure to check the Option for 
Enable Verification on Solid Model. 

 
9 Once the tool path has been verified, you can hide by using the Hide Work 

Group Toolpath icon 
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Programming a Tapping Cycle Operation 
1 Choose a new color for this operation in the upper right corner of the screen 

2 Select the New Hole Group icon. 

3 Select Tap from the Type drop down menu. 

4 Click the Extract Parameters from Solid checkbox. 

 
5 Click on the Major Hole Diameter. 

 
6 Click the <Extract> button to extract the feature data from the Solid Model: 
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7 Highlight and Select the 6-40 Tap Cycle. 

 
8 Click <Apply> and <Close> 

9 To verify the Profile Group, select the Verify Work Group Toolpath icon. 

10 The Verify Options Dialog will now Display. Make sure to check the Option for 
Enable Verification on Solid Model 

11 After Verifying the Tool Path, Click the Hide Every Tool Path icon to hide all 
verifications. 
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Programming a Turning Operation 
1 Choose a new color for this operation in the upper right corner of the screen. 

2 Select the New Profile Group icon. 

3 Change the following settings in the Profile Group. 

Cycle Type Turning 

X Finish .01 

Z Finish .01 

Check Finishing 

 

 
4 Click the <Select Tools> button and choose the OD Turn - 55 Turning Tool 

for both the Roughing and Finishing Operations. 
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5 Name the Group Turn. Your dialog should look like the following. 

 
6 Click <Apply> and <Close> 

7 Select Define Profile on Solid Model icon. The model will automatically 
section itself at the Angle chosen for the Face Plane.  

8 Next, choose the Edge Endpoint Snap Mode.  This will show the selectable 
points on the Solid Model as shown here. The points are numbered for the 
following instructions. 

 
9 Select Point 1 

10 Select Point 2 

 
11 Select the Horizontal Constraint icon. 

12 Select point 3 

 
13 De-select the Horizontal Constraint icon if needed. 
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14 Select point 4 

15 Select point 5 

 
16 Select ZX Coordinates Snap Mode icon. 

17 In the input field at the bottom of the screen, enter .625 into the X and 
press the <Enter> key to accept. 

 

 
18 Select the Selection icon. 

19 To verify the Profile Group, Select the Verify Work Group Tool path icon 

20 The Verify Options Dialog will now Display. Make sure to check the Option for 
Enable Verification on Solid Model.  The verification will appear as shown 
below: 

 
21 After Verifying the Tool Path, Click the Hide Every Tool Path icon to hide all 

verifications. 
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Programming a Grooving Operation 
1 Choose a new color for this operation in the upper right corner of the screen. 

2 Select the New Profile Group icon. 

3 Change the following settings in the Profile Group. 

Strategy Grooving 

Profile Shape General 

Check Roughing 

 

 
4 Click <Select Tools> and choose the OD Groove .0625 Grooving Tool  
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5 Name the Group Groove. Your dialog should appear as shown below: 

 
6 Click the <Apply> and <Close> buttons 

7 Select the Chain Profile on Solid Model icon. 

8 Select the Start Point of the profile. When choosing start point, click on the 
side of the point that you want the Chain to follow. This will determine the 
direction the chain will follow.  

 
9 Select End Point of the profile. 
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10 To verify the Profile Group, Select the Verify Work Group Toolpath  icon 

11 The Tool Path Verification Options dialog will now display. Make sure to 
check the option to Enable Verification on Solid Model. The verification 
will appear as shown below: 

 
12 After Verifying the Tool Path, Click the Hide Every Tool Path icon to hide all 

verifications. 
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Programming a Threading Operation 
1 Choose a new color for this operation in the upper right corner of the screen 

2 Select the New Profile Group icon 

3 Change the following settings in the Profile Group. 

 

Strategy Threading 

Pitch for 1/20 .05 

Acceleration Dst .1 

 
4 Click <Select Tools> and Choose the Thread Tool. 
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5 Name the Cycle Thread. Your dialog should look like the following: 

 
6 Click the <Apply> and <Close> button  

7 Select Define Profile on Solid Model icon. 

8 Choose the Edge End Point Snap Mode icon 

9 Select the Start Point of thread 

 
10 Select Edge Midpoint Snap Mode icon 

11 Select the Horizontal Constraint icon 
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12 Select End Point from bottom of groove area. 

 
13 De-Select the Horizontal Constraint icon 

14 Select the Selection  icon 

15 To verify the Profile Group, Select the Verify Work Group Toolpath icon 

16 The Tool Path Verifications Options dialog will now display. Make sure to 
check the Option for Enable Verification on Solid Model. The verification 
will appear as shown below: 

 
17 After Verifying the Tool Path, Click the Hide Every Tool Path icon to hide all 

verifications. 
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Programming a Cut Off Operation 
1 Choose a new color for this operation in the upper right corner of the screen 

2 Select the New Profile Group icon 

3 Change the following settings in the Profile Group dialog and Leads Out, 
Roughing. 

Strategy Cut Off 

End Point X .05 

Lead Out Line Length 0 

 

 
4 Click <Select Tools> and choose the Cut Off Tool .093 
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5 Name the Cycle Cut off. Your dialog should look like the following. 

 
6 Click <Apply> and <Close> 

7 The Profile will be created for you. 

 
 

8 To verify the Profile Group, select the Verify Work Group Tool path icon 

9 The Tool Path Verifications Options dialog will now Display. Make sure to 
check the Option for Enable Verification on Solid Model. 

 
10 After Verifying the Tool Path, click the Hide Every Tool Path icon to hide all 

verifications. 
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Programming a Milling Operation 
Note: This section only applies to PartMaker Turn-Mill and SwissCAM modules 

1 Select the Setup Dialog icon, then choose <New> to make a new Face 
Window. 

2 Change the Machining Function to Mill ZY Plane. Name the window Mill 
Flats. 

 
3 Click the <Apply> and <Close> button 

4 If you have not done so already, choose the Full Part View icon from the 
Solids toolbar to make sure you have a complete solid model shown and not 
a sectional view 

5 Select the Define Face Plane icon. 

6 In the Drop down Menu, choose Parallel to Selected Surface. 

 
7 Click on one of the Flats. Note Face Plane is set coincident with the Plane of 

the chosen flat. 

 
8 Click <OK> 
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9 Choose a new color from the colors pallet in the upper right hand corner of 
the screen 

10 Select the New Profile Group icon 

11 Change the Tool Position to Left 

12 Check the Extract Parameters from Solid check box as shown below: 

 
 

13 Uncheck the Roughing box so that  Finishing is checked 

14 Enter 0.5 in the Diam(d) field and click <Select Tools> 

 
15 With the Profile Group Parameters dialog open, click on the plane as 

shown below: 

 
16 Click the <Extract> button to extract the machining parameters directly 

from the model.   

17 Rename the Group to Flats 
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18 The completed dialog will appear as shown below: 

 
19 Click the <Apply> and <Close> button. 

20 Choose the Define Profile on Solid Model icon 

21 Select the Edge Endpoint Snap Point icon 

22 Select the Start Point of the profile 

 
23 Select the End Point of the profile 
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24 Choose the Selection icon to end the profile 

 
 

25 To verify the Profile Group, select the Verify Work Group Tool path icon 

 
 

26 After Verifying the Tool Path, click the Hide Every Tool Path icon to hide all 
verifications. 
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Duplicating the Face Window 
Having programmed this milling path, you can now duplicate the window to create 
the second flat.  This can be done as follows: 

1 Open the Setup Dialog and click the <Duplicate> button 

2 Enter the following into the Duplicate Face dialog. 

Number of Copies 1 

Index Angle Increment 180 

The completed dialog should appear as shown below: 

 
3 Click <OK> 

4 Click the <Close> button to close the Setup dialog 

Generating the Process Table 
1 Choose the Generate Process Table icon 

2 Click <OK> for the Process Table Options 
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3 Your Process Table should appear as shown below: 

 

Simulating Machining in 3D 
Now that you have generated the Process Table, you can simulate the cutting of the 
part in 3D. To do so: 

1 Choose the Simulation icon to launch PartMaker’s 3D simulation 

2 Press the Start Simulation button to watch the part being machined in 3D 

3  Click the Show Finished Part icon to view the completed part: 

 
 



 

Copyright @2014 Delcam Ltd  User Guide C-31  

 

Other Samples 

Turn Function Face Window Programming 
Describes Programming on a Solid Model in a Turn Function Face Window. This 
applies to PartMaker SwissCAM, TurnMill and Turn modules. 

Setting the Face Plane 
1 Open the Define Face Plane Dialog. 

 
2 Set Face Plane as required to be able to Select Points on this plane for the 

Profile. Note the features on the Part when setting and use the Preview 
button to preview the changes. 
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Creating the Profile Group 
Create Profile Group as Normal 

 
Selecting the Profile 

1 Select by choosing the Profile Points 

2 Choose the Define Profile on Solid Model Icon 

 
3 At this point you will see Red Points show on the Solid Model at the 

intersection of the Face Plane. Select these points to create your Profile. 
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4 Use the Snap Modes to choose the Profile Points on the Solid Model. 

 
5 Click on the Point to Start the Profile. 

 
6 Move the Mouse Curser to the Next Point of the Profile. There will be a 

Dotted Line indicating Profile and a Dot where next Point will be. Click to 
connect the profile to this Point. 

 
7 Continue selecting points for the Profile. 

 
8 Click the Selection icon when done. 
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Selecting by Chain 
You may chain a profile on a Solid Model by selecting the Chain Profile on Solid 
Model icon. 

To use this icon, you need to select the Starting Point and Direction.  

 Note: Depending on where you place the mouse curser, the starting point 
changes and the Direction Reverses. 

 
Select Endpoint of Chain. During Selection, a Dotted Line will indicate the Profile. 
Click the End Point to Finish Profile. 
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Using Horizontal and Vertical Constraints 
You can use the Horizontal and Vertical Constraints to Extend Profiles that may not 
have a Point to choose from on the Model. 

When selecting your Profile using the Define Profile on Solid Model icon, select 
either Horizontal or Vertical Constraint to lock the Profile in a Horizontal or 
Vertical move. 

 
1 Move the mouse curser over a Point that is not directly Horizontal or Vertical 

from the Currently Selected Point. You will see the Profile Extend to this point 
in a Horizontal or Vertical Line shown by a dashed line. 

 
2 Click the Point to Extend the Profile to this Point. 

 
3 Depress the Horizontal or Vertical Constant icon to turn off the constraint. 
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Creating a Hole Group 
1 Create New Hole Group Parameters dialog 

 
2 Check Extract Parameters from Solid. 

 
3 Select Major Cylinder for Hole on Solid Model. (Note: See Explanation at 

Bottom of Screen) 
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4 Click <Extract> 

 
Remove Check from Extract Parameters from Solid if editing of a Hole Group 
is required. 

5 Edit Hole Group as required 

6 Click <Cycle> and Select the cycle. 

 

 
7 Click <Apply> then <Close> 
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Milling Functions Face Window Programming 
Describes Programming on a Solid Model in Milling Functions Face Windows. This 
applies to PartMaker SwissCAM and Turn-Mill. 

Creating a New Profile Group (Mill ZY window shown) 
Setting the Face Plane 

1 Click the Define Face Plane icon to open the dialog. 

 
2 Choose desired method of Selecting the Face Plane. When choosing Parallel 

to Selected Surface, click on Surface to set as Face Plane. Use the Preview 
button to preview the changes. 

 

 
3 Click <OK> to accept Face Plane Setting. This will fill in the Set-up Window 

with the correct settings for the Face Plane. 
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Creating the Feature 
1 Create Profile Group as Normal 

 
2 Check Extract Parameters from Solid 
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3 Select Feature to Extract Properties from. 

 
4 Click <Extract>. This will extract the information to the Profile Group. 
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Creating the Profile 
1 Choose the Define Profile on Solid Model Icon 

 
2 Use the Snap Modes to choose the Profile Points on the Solid Model. 
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3 Click on the Cylinder Surface to select the center point as the Start of the 
Profile. 

 
4 Move the Mouse Curser to the Next Point of the Profile. There will be a 

Dotted Line indicating Profile and a Dot where next Point will be. Click to 
connect the profile to this Point. 
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5 Continue selecting points for the Profile until finished. 

 
6 Click the Selection Icon when done. 

 

Selecting by Chain 
You can chain a Profile on a Solid Model by selecting the Chain Profile on Solid 
Model icon. 

1 Select Starting Point and Direction  

 Note: Depending on where you place the Mouse Curser, the Starting 
Point changes and the Direction Reverses. 

2 Select Endpoint of Chain. During Selection, a Dotted Line will indicate the 
Profile. Click the End Point to Finish Profile 

3 You may use Horizontal and Vertical Constraints if required. 
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Creating a Hole Group (Mill Diameter Index Face window shown) 
Setting the Face Plane 

1 Open the Define Face Plane Dialog. 

 
2 Choose desired method of selecting the Face Plane. When choosing Tangent 

to Selected Cylinder, click on the Cylinder to set as Face Plane. Use the 
<Preview> button to preview the changes. 

 

 
 

3 Click <OK> to accept Face Plane Setting. This will fill in the Set-up Window 
with the correct settings for the Face Plane. 



 

Copyright @2014 Delcam Ltd  User Guide C-45  

 

Creating the Feature 
1 Create New Hole Group Parameters. 

 
2 Check Extract Parameters from Solid 

 
3 Select Major Cylinder for Hole on Solid Model. (Note: See Explanation at 

Bottom of Screen) 
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4 Click <Extract> 

 
5 Remove the check from the Extract Parameters from Solid box if editing 

of a Hole Group is required 

6 Edit Hole Group as Required 

7 Click <Cycle> and select a cycle 

 
8 Click <Apply> then <Close> 
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Selecting Single Holes 
1 Choose the Single Hole on Solid Model Icon. 

 

 
2 Select each hole that will be drilled. 
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Selecting by Chain 
1 Choose Chain Holes on Solid Model icon 

 
2 Select First Hole, PartMaker will then automatically select holes with the 

same feature in the Face Plane. 
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