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Important Notice 
 

 

 

 

This document is supplied as part of a Delcam Training Course. It is not intended to 

be distance-learning material: rather as an aid for Tutors when presenting material 

to course delegates and as a subsequent aid memoir to those delegates. 

 

Delcam does not accept responsibility for any personal belongings / valuables whilst 

on the premises. Delegates are advised to keep their belongings on their person at 

all times. 

 

Delcam plc. has no control over the use of the software described in 

this document and cannot accept any responsibility for any loss or 
damage howsoever caused as a result of using the software. Users 

are advised that all results from the software are checked by a 
competent person in accordance with good quality control 
procedures. 

 

The software described in this document is furnished under a license agreement and 

may be used only in accordance with the terms of this license. 

 

Copyright 2013 – Delcam plc. All rights reserved. 
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This course covers the 3-Axis functionality available in PowerMILL. Additional Five 
Axis license options are covered on a separate course. 

PowerMILL can quickly create gouge-free cutter paths on imported component 

data. It supports Wireframe, Triangle, Surface, and Solid models created by other 
Delcam products or from neutral formats such as IGES. If the relevant PS-Exchange 

translators are purchased, PowerMILL will also directly import data created by other 

of proprietary CAD packages. 

Start PowerMILL 

1 Double-click the PowerMILL shortcut on the desktop:  

 On the training PC, the icon will be displayed as PowerMILL. 

The PowerMILL screen is displayed: 

 

The screen is divided into the following main areas: 

a Main menu 

 

1. Getting Started 
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Click one of the menu names on this bar (for example, File) to open a pull-down 

menu list of associated commands and sub-menus. A sub-menu is indicated by a 
small arrow to the right of the text (for example File - Recent Projects >). 

Highlighting this arrow generates a list of commands/names specific to that sub-
menu (for example, File - Recent Projects displays a list of recently opened 

projects that opens directly when selected). 

b Main Toolbar 

 

This provides quick access to the most commonly used commands in 

PowerMILL. 

c Explorer  

 

The PowerMILL explorer provides control options and storage of PowerMILL 
entities created during the session. 

d Graphics Window 

This is the large, visual display area to the right of the Explorer (Look at the 

illustration on previous page). 

e View Toolbar  

 

Provides quick access to standard view and shading options in PowerMILL. 

f Information Toolbar  

 

This area provides a reminder of some of the active setup options. 

g Tool Toolbar 

 

Facilitates the rapid creation of tools in PowerMILL. 
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The other toolbars are not factory defaults, and are therefore not shown at initial 

startup. To display any of these, select them under View > Toolbar.  

For example, select View > Toolbar > Toolpath to display the Toolpath 
Toolbar. 

 

 

 

To change the background colour of the graphics area, select Tools > Customise 
Colours and select View Background. The Top and/or Bottom colours can be 

changed independently and Reset using Restore Defaults to restore to the original 

settings: 
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PowerMILL remembers Toolbar and colour selections from one session to the next. 
For example, if the Toolpath Toolbar is open when the session is closed, it will 

appear the next time PowerMILL is opened. 
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Mouse buttons 
Each of the three mouse buttons performs a different dynamic operation in 
PowerMILL. 

Mouse button 1: Pick and Select 

 

This button is used for selecting items on menus, options on dialogs, and entities in 

the graphics area. 

The method of selection is controlled by 2 options accessed from the Viewing 

toolbar, the default being Select using a Box. 

 

Select using a box 

 

If the cursor is positioned on an entity, such as part of a surface model, and if the 

mouse is clicked, then the item turns yellow indicating that it is selected.  

 If you select another surface, all currently selected items are de-selected. 

� If you want to select more surfaces to add to the currently selected surface, 
then, while making selections, hold down the Shift key on your keyboard. 

� If you want to remove a surface from your current selections, hold down the Ctrl 

key on your keyboard and click on the surface that you want to remove. 

Select by dragging the cursor 

 

Use this option to select multiple entities by dragging the cursor across the required 
items. This is ideal for quickly selecting multiple surfaces on a model. To deselect 
entities, press the Ctrl key when dragging across an entity. 

Mouse button 2: Dynamics 

 

� Zooming in and out: Hold down the Ctrl key and mouse button 2. Move the 
mouse up and down to zoom in and out. 
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� Pan around the model: Hold down the Shift key with mouse button 2. Move the 

mouse in the required direction. 

� Zoom Box: Hold down the Ctrl and Shift key, drag a box around the area to 
zoom into using the middle mouse button. 

� Rotate mode: Hold down mouse button 2 and move the mouse, and the 
rotation is centred about the trackerball. 

� View Spinning: Dynamically rotate the view and quickly release the mouse. 

The faster the mouse movement, the faster it will spin. This feature is switched 
off by default. Select Tools > Options > View > 3D Graphics and select the 

Spin View option to enable it. 

 

Mouse button 3: Special Menus & PowerMILL Explorer 
Options 

 

When this button is pressed it brings up a local menu relating to whatever the 
mouse is over, such as a named item in the PowerMILL explorer or a physical 

entity in the graphics area. If nothing specific is selected, the View menu appears.  
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HELP! 
PowerMILL provides you with help in a number of ways: 

� Tooltips: Place the mouse cursor over a menu button. A description is of what 

the button does is displayed.  

� Online Help: Select Help > Contents from the Main Toolbar to access the online 

help documents.  There is a full index and search facility provided. 

� To see a summary of all new functionality available in the current version of 
PowerMILL, select Help > What’s New. 

 

� Context Sensitive Help: Press the F1 key to display the help page for the 

currently active dialog. Click the  button in the top right hand corner of the 

dialog, followed by a left click in any of the input fields to focus on the help topic 
for that part of the dialog. 

� PowerMILL User Forum: On the Main toolbar, select Help > Visit the User 

Forum, to participate in web-based user discussions on PowerMILL issues.  

� The link to access the forum from any other internet connection is: 

http://forum.delcam.com/ 

� Telephone and Email Support: UK customers with up-to-date software 

maintenance can call 01216831010 or mail support@delcam.com to get help or 

advice on specific application problems. 
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Simplified PowerMILL Example  
This example provides a quick overview of the machining process. It shows how to 

create and output a couple of simple toolpaths on a model of a valve chamber using 

default settings wherever possible. 

The basic procedure is: 

a Start up PowerMILL. 

b Import a Model. 

c Define the Block from which the part will be cut. 

d Define the cutting Tools to be used. 

e Define set up options (Rapid Move Heights – Start and End Point). 

f Create a Roughing Strategy. 

g Create a Finishing Strategy. 

h Simulate the toolpaths. 

i Create an NC Program and output as a post-processed NC data file. 

j Save the PowerMILL Project to an external directory. 

 

Import a Model 
2 From the Main menu select File > Import Model and browse for the model 

file: 

......\PowerMILL_Data\Models\PmillGettingStarted.dgk 
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Blanking model entities 
Use the Blank Selected (Ctrl + J) option available on the Model context menu to 

temporarily hide the selected model components. 

In the illustrations below, the light blue surfaces are selected. 

 

Use the Blank Except (Ctrl K) option available on the Model context menu to 

temporarily hide all model components except the selected ones. 

The 2 selected items are light blue. 

 

To re-display all model components, right-click in the graphics area and select 

Unblank (Ctrl L). The blanked model components are displayed and selected (back 
to the left hand image above). 

You can also toggle between the blanked and unblanked status of model 

components. Select the Blank Toggle (Ctrl Y) option to switch between the 
Blanked and Unblanked components of the model. 
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Defining a Block 
The Block dialog is used to define the 3D working limits. This could be the actual 

raw material size or a user-defined volume, localised to a particular part of the 

component. 

The settings on the Block dialog are set by default to Defined by – Box. Individual 

values in the dialog can be edited or locked (greyed out) as required. Enter a value 

in the Expansion field to include an offset in the block calculation.  

Click the Calculate button to define a block around the model dimensions. 

1 Click the Block  button on the Main toolbar to display the Block dialog. 

 

2 Click the Calculate button. 

3 Click Accept. 
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Defining a Cutting Tool 
The Tool dialogs are accessed using the various tool buttons on the Tool toolbar. 

This is located to the bottom left corner of the graphics area.  

For this example, 2 tools will be created, A Tip Radiused tool for roughing out and 
a Ball Nosed tool for finishing. 

1 Click the down arrow to display all the Tool options . 

2 Place the cursor over a tool to view the description of the tool type (Tool tips).  

 

3 Select the Create a Tip Radiused tool button . 

The Tip Radiused Tool dialog is displayed. 

 

4 In the Tip Radiused Tool dialog, enter: 
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a Name – D12TR1 It is recommended that the tool is renamed with a more 

relevant identification. 

b Diameter – 12 When you enter a value for the Diameter, the tool Length 
automatically defaults to five times this value. You can edit this value if 

needed. 

c Tip Radius – 1 

d Tool Number – 1, A Tool Number can be output to the NC Program. If 

the machine has a tool changer, this number will represent the location in 
the carousel. 

e Click Close on the Tip Radiused Tool dialog.  

5 Define another tool, this time, select the Create a Ball Nosed tool button and 
in the Ball Nosed Tool dialog, enter: 

a Name – BN12 

b Diameter – 12 

c Tool Number – 2 

d Click Close on the Ball Nosed Tool dialog.  

6 In the PowerMILL explorer panel on the left of the screen, open Tools and 

right mouse click D12TR1 tool to raise the local menu and select Activate. 

 

 Only one tool can be active at any one time and the word Activate in the 

tool context menu is prefixed with a tick . The active tool is 
automatically included in a strategy dialog when the strategy is created. 

In the PowerMILL explorer, the Active tool is displayed in bold text 

and prefixed with ‘>‘. 

Rapid Move Heights 

The Rapid move heights  options provide safe control rapid tool movements 
across the component. 

� Safe Z is the height above the job at which the tool can move at a rapid 
feedrate, clear of any obstructions such as the work piece or clamps. 

� Start Z is the height to which the tool will descend, at rapid feed rate prior to 
applying the plunge feed rate. 

PowerMILL displays rapid moves as dotted red lines, plunge moves as pale blue, 

and cutting moves as green. 
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Setting up Rapid Move Heights 

1 On the Main toolbar, click the Rapid Move Heights button to open the 
Rapid Move Heights dialog. 

 

2 Click Calculate. 

3 Click Accept. 

This automatically sets the absolute Safe Z and Start Z values to be above the 

block by the distance in the incremental height fields shown at the bottom of the 
dialog. 

An Absolute setting will always cause the tool to feed down from the same 

height. 
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Tool Start and End Point 
The Start and End Point dialog allows you to define a position where the tool 

travels to before and after a machining strategy.  

Click the tool Start and End Point button  on the Main toolbar to display 
the Start and End Point dialog. 

By default, the tool Start Point is set to Block Centre Safe and the End Point is 
set to Last Point Safe. 

     

 

Other Start and End Point settings are configured by selecting the different 

options in the Method area on the dialog. 

These include Block Centre Safe, First/Last Point Safe, First/Last Point, and 
Absolute. 

For now, click Accept to use with the default settings. 

 

The D12TR1 tool is placed at the Block Centre Safe position ready for you to 

create the first toolpath. 
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Creating a Roughing Strategy 
1  From the Main toolbar select the Toolpath Strategies button. 

 

2 Select the 3D Area Clearance tab. 

 

3 Select the Model Area Clearance strategy.  This displays the Model Area 

Clearance strategy dialog. 

 

4 In the Model Area Clearance strategy dialog: 
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a In the Toolpath name field, enter D12TR1-ModelAreaClear. 

b Select Style - Raster. 

c Edit the Thickness value to be 0.5 (This is the amount of material that will 
be left on the job). 

d Edit the Stepover value to be 10 (This is the distance between each raster 
pass (the width of cut)). 

e The Stepdown value (depth of cut) is left at the default value of 5. 

f Click Calculate to process the machining strategy. 

  

Simulating the toolpath 
5 From the PowerMILL explorer right mouse click on the Toolpath          

D12TR1-ModelAreaClear and from the local menu select, Simulate from 

Start. 

 

The Simulation toolbar will appear just above the graphics area. 

6 From the Simulation toolbar click the Play button   to run the Simulation. 

 

 

 The other buttons in the Simulation toolbar allow you to perform other 
actions such as Pause, Step, Search, Goto. 
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Creating a Finishing Strategy 
7 In the PowerMILL explorer, right click the BN12 tool and select Activate (or 

double left click on the tool’s, PowerMILL explorer, icon). 

8 From the Main toolbar select the Toolpath Strategies button. 

 

9 Select the Finishing tab. 

 

10 Select the Raster Finishing strategy and click OK.  
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11 In the Raster Finishing strategy dialog: 

a For the Toolpath Name, enter BN12-RasterFinish. 

b Edit the Stepover value to 0.5 

c Click Calculate to process the machining strategy. 

 

The Raster Finishing pattern is projected down Z onto the component, taking 

into account tool geometry and machining settings. 

 The toolpath link moves, clear of the job, are not displayed in this illustration 
for clarity. 

Toolpath Simulation and ViewMILL 
PowerMILL provides two levels of options for simulating toolpaths:  

� The first level Simulates the cutting tool movement along the toolpath. 

� The second level (ViewMILL) includes a shaded image of the stock material 
being progressively reduced  as the tool moves along the toolpath. 

Toolpath Simulation 

12 In the PowerMILL explorer, right-click on the toolpath                        

D12TR1-ModelAreaClear and from the local menu select Activate. 

 

The Active toolpath is displayed in bold text and prefixed with a > symbol. 

13 In the PowerMILL explorer, right-click on the roughing toolpath           

D12TR1-ModelAreaClear and select Simulate from Start. 
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14 The Toolpath Simulation toolbar is displayed at the top of the screen. This 
displays the name of the toolpath and tool, together with buttons to control the 

simulation. 

 

Using the simulation control buttons, you can: 

�  Play - start the simulation and play it in continuous mode. 

�  Pause - pause the simulation. 

�  Step Back - step the simulation back by tool moves. Click the Play button 

to resume continuous mode. 

�  Step Forward – step the simulation by tool moves. The faster the speed 

(defined using  Speed Control) the bigger the step. Click the Step 
Forward button again to see the next move or click the Play button to resume 

continuous mode. 

�  Search Backward - step the simulation back to the previous toolpath 

segment.  

�  Search Forward - step the simulation to the next toolpath segment. Click 
the Search Forward button again to see the next component or click the Play 

button to resume continuous mode. 

�  Go to Beginning - moves to the start of the toolpath. 

�  Go to End - moves to the end of the toolpath. 

�  Speed Control - controls the speed of the simulation. The fastest 

setting is by having the slider at the right, the slowest at the left. 

 

�           Select Point to Point (toolpath points per second) or Feedrate (a            

                                    multiple of the stored federate) as the basis for the simulation                                                 

                                     feedrate.  

 

15 Click the Play button  and Simulate the toolpath. 

16 Activate the finishing toolpath BN12-RasterFinish and repeat the simulation 

process. 
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ViewMILL 
1 Activate the roughing toolpath D12TR1-ModelAreaClear and select it in the 

Simulation Toolbar. 

2 From the Main pull down menus, select View > Toolbars > ViewMILL to raise 
the ViewMILL Toolbar. 

 

The ViewMILL toolbar is displayed. Initially, all the buttons are greyed out. 

 

3 Click the  button to toggle the graphics window into the ViewMILL mode  

(The ViewMILL toolbar buttons are now active). 

 

4 Click the  button to select a Plain Shaded Image. 
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5 Click the Tool button  to display the tool. 

6 Click the Play button  to start the ViewMILL simulation. 

 

 

 

7 After the simulation has finished, select the toolpath BN12-RasterFinish on 

the Simulation toolbar, followed by the tool button . 

8 Click the Play button  again to view the continued simulation of material 

removal by the finishing toolpath. 

 

9 In the Simulation toolbar, select the Close button  to delete the 

ViewMILL session. 
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NC Programs (Post-Processing and NC data Output) 
1 From the Main menu, select Tools > Customise Paths to open the 

PowerMILL Paths dialog. 

  

This displays the PowerMILL Paths dialog. 

  

2 In the PowerMILL Paths dialog, select the option NC Programs Output. 

  

This controls where the post-processed, NC data files are output ready to 
download to a machine tool controller. 

3 Click the Add path to top of list button. 

4 In the Select Path dialog which appears, browse to the required location 

C:\Temp\NCPrograms and click OK. 

5 In the PowerMILL explorer, right-click NC Programs and select Preferences 
to display the NC Preferences dialog. 
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NC Preferences enables you to control the content of output files to download 
to a machine tool. 

 

The Output Folder defaults to the location already defined in Tools > 

Customise Paths. 

6 In the NC Preferences dialog, click Machine Option File button. This displays 

the Select Machine Option Filename dialog. 
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7 Select heid400.opt and click Open. This selects the heid400.opt file and 

returns you back to the NC Preferences dialog. 

8 Click Apply and then Accept on the NC Preferences dialog. 

9 In the PowerMILL explorer, right-click NC Programs and select Create NC 

Program. 

 

An empty NC Program appears in the PowerMILL explorer and the NC 

Program dialog is displayed. 

10 In the PowerMILL explorer, use the left mouse to select and drag the toolpath 

D12TR1- ModelAreaClear onto NC Program 1. 

 Alternatively, right-click on the toolpath D12TR1-ModelAreaClear and select 
Add to > NC Program. 

 

A copy of the toolpath name will appear in the NC Program indicating that it 

has been assigned as part of the output file. 
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11 In the PowerMILL explorer, click and drag the toolpath BN12-RasterFinish 

onto NC Program 1. 

Click the small + box to expand and view the contents of the NC Program.  

 

The toolpath names are listed in the NC Program ready to be post-processed. 

12 In the NC Program dialog displayed in the graphics area, click the Write button 

to start the post processing operation. An Information dialog is displayed with a 

progress and confirmation summary. 

 

13 Close both the NC Program and Information dialogs. 

14 You can find the created NC data file 1.tap under C:\temp\NCPrograms on 
your computer. 

Saving the Project 
1 On the Main toolbar, click the Save button. 

     

This displays the Save Project As dialog. 
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If the Project has been Saved before, then it will simply be updated.  

2 From the Main menu , select File > Save Project As:- 

......\COURSEWORK\PowerMILL-Projects\PmillGettingStarted 

3 From the Main menu, select File > Delete All, followed by Tools > Reset 
Forms. 

The content of PowerMILL explorer is deleted and all dialogs are reset to their 

default settings.  

The externally stored copy of the Project (PmillGettingStarted) can be reopened 

as required. 

Additional Exercise 

4 Import the Model:- 

......\PowerMILL_data\Models\facia.dgk  

 

5 Save the Project as: 

......\COURSEWORK\PowerMILL_Projects\Facia-1 

6 Use the same Tools and machining strategies to those in the previous 
Project (PmillGettingStarted). 

7 Once you have completed the exercise and saved the project, from the Main 

menu, select File > Delete All followed by Tools > Reset Forms. 
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In the previous section, the toolpaths were created using the default values 
wherever possible.  

We will now look at the machining Setup options in more detail.  

In particular: 

� Setting up direct access to regularly used files. 

� Use of Workplanes (Positional datums) to create appropriate machining set ups. 

� Different methods of creating Workplanes and alignment using the workplane 
Editor. 

� Workplane Aligned to Geometry. 

� Tool and Holder definition. 

� Material Block Definition. 

� Safe Z Heights.  

PowerMILL Panes 
On the left hand side of the screen above the explorer are the PowerMILL panes. 

 

� The first pane  displays the PowerMILL explorer (as shown above). 

� The second pane  displays the HTML browser used for viewing HTML files 

including Help files. 

� The third pane  opens the PowerMILL Recycle Bin. 

 

2. Machining Setup 
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Setting up direct access to regularly used folders 
1 To Import a Model via the Main pull down menus, select File > Import 

Model.  

 

The Import Model dialog is displayed. 

 

 

 

�  - changes the directory to the current Project directory.  

�  - changes the directory to the Examples directory.   

This folder contains a selection of sample model files which are installed 
within PowerMILL in a directory called Examples.  

�  - changes the directory to the first user-defined directory. 

�  - changes the directory to the second user-defined directory. 

 

To customise the paths for user-defined directory folders:  
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2 From the Main menu select Tools > Customise Paths. The PowerMILL 

Paths dialog is displayed. 

 

3 Select the File Dialog Button 1 option from the drop-down list. 

4 Click the Add path to top of list  button and browse to: 

           ......\PowerMILL_Data\Models 

 

5 Click OK. 

6 Repeat steps 2 and 3, but this time select the File Dialog Button 2 option to 

link directly to: 

           ......\PowerMILL_Data 

 Outside the training environment, the location of the PowerMILL_Data 

directory will depend on where you have installed it! 
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Loading a model into PowerMILL 
1 From the Main menu, select File > Import Model. 

2 Use Shortcut Button 1 or browse to: 

......\PowerMILL_Data\Models 

 

 A variety of Model formats can be imported into PowerMILL. Use the Files of 

type filter to widen or narrow your choice. 

 

 Please note:  direct transfer - file formats (eg: CATIA, ProENGINEER, etc) 
are only available as a cost option.  

 

3 Back in the main form, select the file WorkplanesExample1.dgk and then 
click Open. 

4 From the Viewing toolbar (Right of graphics area) select View from top (Z) 

 followed by Resize to fit   . 

The model is displayed in the PowerMILL graphics as viewed down the Z-axis with X 

aligned from left to right, and Y from bottom to top. 
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In most cases, the X dimension of a machine tool table will be greater than Y; in 

which case, the longer side of the component may exceed of the travel limits in Y. 

If this is the case, it will be required to align the component with the longest side 

along X to ensure that it can be positioned within the travel limits. 

Saving the Project 
It is good practice to create a Project as soon as possible and then to Save it at 

regular intervals during the session. 

1 On the Main menu, select File > Save Project As: 

......\COURSEWORK\PowerMILL-Projects\WorkplaneExample1-EX1 

Viewing the Model 
Although the model is displayed, it is a good idea to look at it from all angles to fully 
understand its size and features. 

 

 

                Above is the Views toolbar (shown aligned horizontally). 

 

By default, the Viewing toolbar is aligned to the right hand side of the graphics 
area. These options mainly include basic visual orientations along with several 
shading modes, many of which provide specialist analysis of the model. 

1 From the View toolbar, select an isometric ISO 1  view. 
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Setting Feed rates 
The current Feed rate values are applied directly to a newly created toolpath. The 
Feed rate values can be stored in a Tool definition to update the Feed rate dialog 

accordingly on Tool activation. At this stage we will look at manually setting the 

feed rate individually. Click the Feeds and Speeds button  on the main 

toolbar to display the Feeds and Speeds dialog. 

 

The default values (as shown above) can be modified as required and Accept 
selected for them to be the default for future toolpaths.  Apply is used to update 

the Feeds and Speeds of an active toolpath. Note Apply is  ‘greyed out’ (as 
above) if there is currently no active toolpath.   
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Creation and Application of Workplanes. 
When a model is imported into PowerMILL it is more than likely that the original 
global datum (Transform) will not provide a suitable position/orientation for tool 
setting or applying machining strategies.  

Workplanes provide the ideal method of creating suitable machining datums and 

alignments without having to resort to physically moving the component model. 

Workplanes are additional datums that can be moved and/or orientated within the 
global environment. Only one workplane can be active at any one time. If there is 

no active workplane then the original global Transform is the datum. 

By deactivating a workplane, the original coordinate set-up can easily be re-
activated for tasks such as checking original dimensions or for importing a ‘new 

issue’ updated model. 

Creating a new Workplane at top of Selection 
1 Press the left mouse button and drag a box over the entire model to select. 

2 In PowerMILL explorer, right-click Workplanes and select Create and 

Orientate Workplane > Workplane at top of Selection. 

 

A Workplane is created and appears at the top-centre of the selected model. 

The new Workplane 1 is also registered in PowerMILL explorer.  

3 Right-click the newly renamed workplane - 1 and select Activate. 

 

 

The next step will be to rotate the new Active - Workplane - 1 to re-orientate the 

model such that the longer side is aligned to the X-Axis. 

1 From the same local menu, select Workplane Editor to display the 

Workplane editing toolbar. 
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2 Double click the Twist about Z button. This displays the Twist dialog. 

3 Enter Angle 270 and click Accept. 

 

4 Click the Green Tick   on the Workplane toolbar to accept the changes. 

 

5 Select a View from top (Z) to see the effect of the rotated, Active Workplane 

providing a more suitable machining position for the model. 

 

The Workplane is shown positioned on the top of the model, which has the longer 

edge aligned to X. 

 

Workplane Positioned using the Block 
Next, the same Workplane alignment as above will be demonstrated using a 

different method. 

1 Right click on the Workplane 1 (either in the PowerMILL explorer or 
directly in the graphics area) and from the local menu select Delete 

Workplane. 

Another method of creating a Workplane is from key points on the defined 

Block. 
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2 From the main menu, select the Block Icon  the following form will 

appear select Active Workplane press Calculate followed by Accept. 

 

3 In the PowerMILL explorer, Right mouse click on Workplanes to access 

the following menus. 

 

4 Select Workplane Positioned using Block from the above menu. 

 

5 Click the new workplane on to the green sphere at the centre of the top 

face of the block. 
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 To enable easy identification, it is recommended to rename, created entities 
with a name relevant to their application. 

 

6 In the PowerMILL explorer, right-click the newly created Workplane and 
select Rename. 

 

 

7 Change the name to OP1.      

 

8 Right click on the workplane and from the local menu, select Activate. 

 

 

9 Then from the local menu select Workplane Editor. 

 

10 Double click on Z Axis Twist and enter 270 to orientate the workplane as 
shown below. 
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This action will cause the Block to be aligned 90 degrees out of position, relative to 

the model (as shown on the next page). The safest way of correcting this is to 

Calculate the Block again while the new workplane is active. If the user de-
activates the workplane then the Block will again move out of position. This is an 

ideal warning to prevent the user inadvertently machining relative to the wrong 
datum. 

 

 

1 From the main menu, select the Block Icon  the following form will 
appear select Active Workplane press Calculate followed by Accept. 

 

  

 

The Block is now re-aligned to the model relative to the active Workplane. 
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Create second workplane for OP2 
We will now create a second workplane for the opposite side for OP2. You can only 

have one workplane active at one time. So the machining Strategies require a 

suitable naming convention to identify which active workplane they relate to. 

 

2 With the left mouse key depressed, drag a box over the entire model to 

select. 

3 In the PowerMILL explorer, right-click Workplanes and select Create 

and Orientate Workplane > Workplane at bottom of Selection. 

4 Rename the new Workplane as OP2. 

5 Hold down the centre wheel on the mouse and rotate the view around the 

model. 

 

6 Double click on the X Twist and enter 180 degrees so that the new 

workplane is normal to the underside of the model. 

 

7 Select Accept  for the new workplane OP2 to be updated. 

8 Select File - Save Project:-  

The contents of the Project saved earlier will be updated. 

9 Select File - Delete all followed by Tools - Reset forms. 

The contents of the PowerMILL explorer will be deleted and all forms will be 
returned to the default, factory settings. 
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Workplane Aligned to Geometry 
 

A very powerful tool for aligning components is to create a Workplane 

perpendicular to a face using Workplane aligned to Geometry. The next example 
shows this in detail. (See original model orientation) 

 

1 Import the Model:- 

             ......\PowerMILL_Data\Models\InteriorTrim.dgk 

2 While the centre mouse wheel is depressed, move the mouse to rotate the 

view of the model so that the base of the pocket is fully visible. 

 

3 Right click on Workplanes and select Create and Orientate Workplane 
followed by Workplane aligned to Geometry. 
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4 Left mouse click to locate a Workplane on the base of the pocket as shown. 

 

5 Right click on the new workplane and select Activate. 

 

 

6 With the left mouse key depressed, click on the bottom face of the pocket to 

make it selected (shaded light blue below). 

7 Then right click on Workplanes to open the local menus below. 

 

 

 

8 From Create and Orientate Workplane, select Workplane at Top of 
Selection. 

9 The new workplane will be centrally located at the base of the pocket.  

10 Rename the new workplane as Datum and make it Active. 

11 Delete the original workplane. 
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The new datum is from the centre of the pocket as shown below. 

 

12 Save the Project as:-  

......\COURSEWORK\PowerMILL_Projects\Workplane-Example2 

13 Select File – Delete all followed by Tools – Reset forms. 

Speaker Core Example - Set Up 
1 Import the Model:-    ......\PowerMILL_Data\Models\speaker_core.dgk 

 Use Button 1   in the Import Model dialog for quick access! 

 

For this example it is required for the long side of the component to be aligned to 

the X direction and not Y as shown above.  
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2 Depress the left mouse key and drag a box across the whole model to select 

all Surfaces. 

3 Select Create and Orientate Workplane – Workplane at Top of 
Selection. 

4 In the PowerMILL explorer right mouse click on the new Workplane and 
from the local menu select Workplane Editor. 

 

 

5 In the toolbar, click on the Z-Twist option and enter 90 in the form for the 
Workplane rotation angle. 

 

6 Accept the Twist form and then click on the Green tick on the toolbar to 

exit the Workplane Editor (and finally accept the changes). 

7 Activate the new Workplane 1. 

8 Select an ISO 1 view. 

 

The long side of the component is now running along the X direction. 

Now that the component model is suitably aligned, the next stage is to create 
some suitable cutting Tools ready to carry out the machining process. 
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Tool and Holder Definition 
9 From the PowerMILL explorer select Tools - Create Tool - Tip Radiused. 

 

10 In the Tip Radiused Tool dialog, define a Dia 50 Tiprad 6 - Length 60 - 

Named D50TR6 - Tool Number 1. 

 

11 In the Shank dialog, click the Add a shank component icon and enter: 
Upper/Lower Diameter 50 and Length 40. 
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12 In the Holder dialog, click the Add holder component button and enter: 

� Upper Diameter – 80 

� Lower Diameter – 65 

�  Length – 50 

� Overhang - 100 

 The Overhang is the vertical distance from the bottom of the holder to the 

tip of the cutter. 

 

13 In the Holder dialog, click the Add holder component button . Enter: 

� Upper Diameter – 80 

� Lower Diameter – 80 

�  Length – 50 

� Overhang –100 

 

14 In the Holder dialog, click the Add holder component button Enter: 
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� Upper Diameter – 120 

� Lower Diameter – 120 

�  Length – 15 

� Overhang - 100 

 

15 Close the dialog. 

 You can control the style in which the tool is displayed in the graphics 
window. In the PowerMILL explorer, right-click on the Tool - D50TR6 

and from the local menu,  select Shaded. 
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Block Definition 
16 Calculate a Block using Defined by - Box and Type - Model. 

 

The default option for Block is Box (A rectangular volume). Other options 
include Cylinder (a cylindrical volume), a Triangle model (eg Casting), and 

Picture/Boundary (Extruded 2D wireframe contours). 

The dimensions of the Block can be entered manually or calculated directly to 

the Type of entity: Model, Boundary, Pattern, or Feature. 

The Opacity slider controls the degree of shading (from the left, initially 
wireframe and then graduating from clear to dense). 

Rapid Move Heights 
The Rapid Move Heights options enable safe rapid moves between tool tracks 

clear of the top of the Model or Block (whichever is the higher).  

17 In the Rapid Move Heights dialog, click the Calculate tab to set Safe Z 
and Start Z to the default values of 10 and 5 respectively above the Model 

or Block. 
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Start and End Point 
The Start Point and End Point define the first and last points on a toolpath. These 

can be controlled using 4 different positional options. 

 

18 In the Start and End Point dialog, Accept the default settings : 

a Start Point - Block Centre Safe 

b End Point - Last Point Safe 

                                                        

Save Project 
19 It is essential to regularly Save your work outside the PowerMILL session. 

By saving to a Project the contents of the PowerMILL explorer are saved 

into an external folder. 

20 Select File - Save Project As:- 

......\COURSEWORK\PowerMILL-Projects\Spkr-Core 

 

 Do Not Close the Project as it will be continued in the following chapter. 
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The main strategies for roughing a 3D component model are called 3D Area 

Clearance. These provide a choice of 2D material removal methods, which 
progressively machine the area (Slice), up to the component contour, down a 

sequence of user-defined Z Heights. 

 

 

Thickness and Tolerance (Applied to 3D Area Clearance) 
Suitable values are required to control the accuracy and amount of excess material 
to be left on a component by a toolpath. The parameters used for this purpose are 
preset and are called Thickness and Tolerance.  

Thickness is the amount of extra material specified to remain on the work-piece 
after machining. This can be applied generally (as shown), or independently as 
separate Radial and Axial values within the machining options. 

 

3.  3D Area Clearance 
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Raster – Model Area Clearance example 
The Raster (Model Area Clearance) strategy follows a series of linear moves across the 

Block limiting to the component form at the active Z height. It then, (by default) 

performs a Profile pass around the component to leave a constant thickness around 

the Slice. Other options provide the ability to further fine tune the final strategy. 

1 Ensure that the Project saved at the end of the last chapter is still active. 

2 Activate the Workplane 1. 

3 From the main toolbar select Block  and using, Defined by Box – Type 
Model select Calculate followed by accept. 

4 From the main toolbar select Rapid Move Heights  and in the form select 

Calculate followed by Accept. 

5 From the Main toolbar select Toolpath Strategies .  

6 Select the 3D Area Clearance tab followed by Model Area Clearance. 

 

7 Select OK to open the Model Area Clearance strategy form. 
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 As soon as the Model Area Clearance dialog is opened, the unprocessed 
Toolpath appears in the PowerMILL explorer. 

 

8 In the Model Area Clearance strategy dialog: 

a Enter the Toolpath name as D50TR6-A1 

b Select Style as Raster. 

c Set Thickness to 0.5 

d Set Stepover to 20 

e Set Stepdown to 10 

f Keep all other values as default, Calculate the strategy. 

g After the Toolpath has been created, close the dialog. 

 

 

 Double-click individual toolpaths to activate or de-activate them. 

Click the small + box to expand and view data used to create the toolpath.  
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Rapid Move Heights in detail 
You can modify the Safe Z and Start Z values using the Rapid Move Heights dialog.  

 

1 Click the Calculate button to set the Safe Z and Start Z to be at safe distances 

above the top of the Model (whole or selected) or Block (whichever is the 
highest).  

 Safe Z is always above Start Z. 

� Safe Z specifies a fixed height at which rapid moves across the work piece can 

safely occur. 

� Start Z specifies a fixed height at which the slower, plunge feed rate is applied 

before the tool cuts into the work piece. 

Rapid Move Heights works in conjunction with the Leads and Links dialog , which 

in turn, provides a more flexible choice of toolpath link moves. 
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� Safe – is selected by default, and applies the plunge feed rate at a specific height 

above the job. This is more predictable and reassuring, but the non-cutting (air) 

moves takes more time and is inefficient, especially in the case of large, deep 
components. 

 

 

 

� Skim - enables the downward, rapid feed rate to continue to a specified 
Incremental Start Z above the full plunge depth before the slow plunge feed rate 

‘cuts in’. Skim then applies a rapid retract to an Incremental Safe Z above the 

highest point on the component ‘in line’ with a linear link move to the next 
plunge position. To cater for all types of machine tools, this move is a Skim Feed 

Rate (G1) (solid purple line), instead of a Rapid (G0) (dashed red line). 

     

 

 

� Incremental - applies the rapid feed rate all the way down to an Incremental Start 
Z measured from the full plunge depth, at which point, the slow plunge feed rate 

‘cuts in’. The Plunge option differs from Skim in that all rapid link moves occur at 

the Absolute Safe Z. 
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Feed Rates  
The Feeds and Speeds dialog uses the Style and Colour of elements along a toolpath 

to register the correct Rapid Move or Feed Rate values.  

� Fixed (G0) Rapid moves =  Red Dashed, Toolpath elements 

� Variable (G1) Feed Rate moves = Green/Orange, Toolpath elements. 

� Plunge (G1) Feed Rate moves = Pale Blue, Toolpath elements 

� Skim (G1) Feed Rate moves = Purple, Toolpath elements. 

1 From the Main toolbar, select the Feeds and Speeds button  and enter the 

values (shown below) in the Cutting Conditons area of the dialog. 

 

2 Click Apply to assign these values in the active Toolpath (D50TR6-A1) and then 

select Accept to close the dialog. 

3 In the PowerMILL explorer, right-click the toolpath and select Settings…. 

 

 The toolpath can also be activated or deactivated using the Activate option in 

the context menu.  

4 This reopens the Model Area Clearance dialog. 

5 Click the make a copy of the Toolpath  button. 

6 On the left of the Model Area Clearance dialog is a local explorer window. 
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When a local explorer option is selected the individual page is displayed in the 

main dialog. This makes it easier to navigate specifically through the pages for 

the required strategy. 

 

7 From the local explorer, select the  to the left of Leads and links to access 
the further options Lead in, Lead out, and Links.  

 

8 Select the Links page and change the Short, Long, and Default Links to 

Skim.  

9 Click Calculate to create a new Toolpath with the modified settings. Once 

processing is complete, close the dialog. 

 

The tool now plunges locally (pale blue move) from the defined Incremental - 

Start Z relative to each slice and rapid across the roughed areas using an 
Incremental - Safe Z (purple move). 
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Statistics 
Provides you with essential information about the active toolpath and associated 

parameters. 

1 In the PowerMILL explorer, right-click the original Toolpath D50TR6-A1 and 
from the local menu select Activate. 

2 In the same menu, select Statistics. 

The dialog with information about the toolpath and its associated settings is 
displayed. 

          

In this case, the total machining time is around 11hrs 34mins.  

3 Right mouse click on the the second Toolpath D50TR6-A1_1 and from the 
local menu select and view the Statistics. 

In this case, the total machining time is around 4hrs 59mins.  

This large saving is achieved simply by using Skim in the Links dialog. In the 
original toolpath, Safe was used, resulting in an excessive amount of Toolpath 

link moves being in the air. 
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Simulating the toolpath’ 
1 Perform both a toolpath and ViewMILL simulation on the final Raster Area Clearance 

toolpath. 

 

2 Switch the ViewMILL to No Image  to return to the PowerMILL session 

and disconnect ViewMILL  from the simulation process.  

When you toggle back to PowerMILL, the ViewMILL session still exists in the 
background, so that any subsequent toolpaths can later be used to continue the 
simulation. 

If the ViewMILL session is still connected, then, even though it is set to No 

Image, the ViewMILL simulation will continue to update in parallel with any 

further toolpath simulations. 

Saving the Project 
1 From the Main menu, select File > Save Project.  

The Project (......\COURSEWORK\PowerMILL-Projects\Spkr-Core) is now 
updated.  

2 Do Not Close the Project as it is to be continued in the next example. 

Offset All – Model Area Clearance example 
The Offset All strategy starts by following the contour of the both the Block and 

Component form at the active Z height. It then progressively offsets into the 

remaining areas of stock. The process will tend to include plunge moves within the 
defined Block. 

1 From the Main toolbar click the Toolpath Strategies button . 

2 Select the 3D Area Clearance tab. 
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3 Select Model Area Clearance to display the strategy dialog. 

 

4 In the strategy dialog:  

a Enter Toolpath Name as D50TR6-A2 

b Select Style – Offset all. 

c Set Thickness to 0.5 

d Set Stepover to 20 

e Set Stepdown to 10 

f Keep all other values as default. 

5 Select Calculate and when the Toolpath is processed, close the dialog. 

6 Close the current Viewmill simulation . 

7 Perform both a Toolpath and ViewMILL simulation on the final toolpath. 
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8 Click the ViewMILL suspend button  and No Image button  to return 

to the PowerMILL session. 

9 From the Main menu, select File > Save Project.  

The Project (......\COURSEWORK\PowerMILL-Projects\Spkr-Core) is now 
updated to include the 3D Area Clearance toolpaths. 

10 From the Main menu, select File > Delete All. 

11 From the Main menu, select Tools > Reset Forms. 

 

Offset Model – Model Area Clearance example 
This variant of the Offset Area Clearance is primarily designed for High Speed 

Machining. It provides very consistent tool loading at the expense of increased 
number of rapid air moves across the component. This strategy, if applied correctly, 

can dramatically help minimise wear to both tooling and machine. 

The strategy is based on the profile around the component at each Z Height, being 
continually offset outwards, to be trimmed to the limits of the material Block.  

1 Import the Model: 

......\PowerMILL_Data\models\Handle.dgk 

2 Save Project As: 

......\COURSEWORK\PowerMILL_Projects\Handle 

 

 

3 Create a Dia 16, Tiprad 3, Tool named D16TR3. 

4 Calculate a Block  to the full model dimensions. Lock the Z max and Z 

min values, enter an Expansion value of 10 and Calculate. 

5 In the Rapid Move Heights  dialog, select Calculate.  

6 Select Toolpath Strategies , and from 3D Area Clearance, open a Model 
Area Clearance strategy. 
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7 Select Stepdown > Manual and click the Z Heights  button to display the 

Area Clearance Z Heights dialog. 

8 In the Area Clearance Z Heights dialog, select Defined by - Value and enter 
0.5. 

 

a Click Calculate.  

 If Z Heights already exist, click  to delete them. 

b Close the Area Clearance Z Heights dialog. 
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9 Select the Offset page and tick the Spiral option. 

 

10 At the bottom of the dialog, click Calculate to create the Toolpath.  

11 Close the dialog and select an ISO 1 view. 

 

 The toolpath is displayed above with the Leads and Links undrawn. 

12 In PowerMILL explorer, right-click the Toolpath and select Simulate from 

Start to display the Simulation toolbar. 

 

13 On the Simulation toolbar, select Play  to view the toolpath simulation. 

 To stop the simulation, press the Esc key on your keyboard. 

The tool continuously, climb mills, starting each tool track at a distance from the 
material block to allow the tool to reach optimum Feed Rate before contact. Each 

pass will benefit from having a consistent material removal rate. The strategy 

can be further improved using advanced settings to progressively smooth away 
sharp corners and straighten tool tracks as they offset further away from the 

component form.  
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14 In the PowerMILL explorer, right-click the active D16TR3-hsm toolpath and 

select Settings to reopen the Model Area Clearance dialog. 

15 Click  and create a copy of the toolpath. 

16 In the Model Area Clearance dialog, select the High speed page. 

 

a Select Profile smoothing and set Radius (TDU) to the maximum slider 

value of 0.2  

b Select Raceline Smoothing and set the slider value to 25 (%). 

c Click Calculate to create a new toolpath D16TR3_hsm1_1 with the 

improved smoothing characteristics. 

 

Compare the Model Area Clearance toolpaths. Note the progressive straightening 

of tool tracks on the second strategy with the 25% Raceline Smoothing 

applied. 

17 Select File - Save Project to update the contents of:- 

                  ......\COURSEWORK\PowerMILL_Projects\Handle 

18 From the Main pull down menus, select File > Delete All.  

19 From the Main pull down menus, select Tools > Reset Forms. 
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Area Clearance – Unsafe Segment Removal 
This option is designed to filter out machining of confined areas that involves a small 

movement of the cutting tool.  In the following example, it is applied to prevent a 

relatively large tool attempting to plunge into a deep pocket area where a smaller 
tool would be a better choice.  

1 Open the read-only Project:  

......\PowerMILL_Data\Projects\MountingBlock-Start 

2 Save Project As:  

......\COURSEWORK\PowerMILL-Projects\MountingBlock 

3 Activate the Toolpath named No-AreaFilter. 

 

The existing toolpath allows the cutter to machine into confined areas. This 

results in sudden sharp changes of cutting direction and excess loading on the 
tool. 

4 Right-click on the toolpath named No-AreaFilter and from the local menu, 
select Settings to open the original Offset Area Clearance dialog. 

5 Click the Create a new toolpath based on this one button, to create a copy 

of the toolpath. 

 

6 Rename the copy of the toolpath as AreaFilter. 

7 In the toolpath dialog, select the Unsafe segment removal page.  

8 Input a Threshold (tool diameter units) value of 0.5 

9 Un-tick the Only remove segments from enclosed areas option. 
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All tool tracks spanning a distance less than the Tool Diameter (TDU) are filtered 

out and will not appear in the final toolpath. 

10 Calculate the Offset Area Clear Model dialog and once processing is 

complete, close the dialog. 

 

Unsafe Segment removal has been applied to prevent the cutter 

attemp ting to 

plunge into and machine confined areas. 

However, there are a couple of undesirable spikes on the remaining toolpath. 

These can be reduced by applying the High Speed - Profile Smoothing option. 

1 In the PowerMILL explorer, right-click the toolpath named AreaFilter and select 
Settings to open the original Offset Area Clearance dialog. 

2 Click Create a new toolpath based on this one button, to create a copy of 

the toolpath. 

 

3 Rename the copy of the toolpath as AreaFilter-ProfileSmooth. 

4 Keep the same Unsafe Segment Removal settings switched on, and in High 

Speed, select the Profile Smoothing option with the Radius (Tool Diameter 

Units) value set to 0.2 
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5 Calculate the Model Area Clearance toolpath and once processing is 

complete, close the dialog. 

 

The previously sharp corners around the toolpath outer profile are now 
smoothed. 

6 From the Main pull down menus, select File > Save Project to update the 

stored data (......\COURSEWORK\PowerMILL-Projects\MountingBlock).  

7 From the Main pull down menus select File > Delete All. 

8 From the Main pull down menus select Tools > Reset Forms. 
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Model Rest Area Clearance example 
It is generally good practice to use as larger diameter tool as possible for the initial 
Area Clearance operation. This ensures that the maximum amount of material is 
removed as quickly as possible. However, the large diameter tool may not have full 
access to certain internal corners or pockets within the component. As a result, 

these areas will require further roughing out with one or more, smaller diameter 

tools before running the Finishing strategies. 

In the Model Rest Area Clearance options, a smaller Tool is referenced either to 

an existing Toolpath or a Stock Model, such that tool tracks will only be produced 

locally within the remaining material (stock). 

9 Import the model: 

......\PowerMILL_Data\models\WingMirrorDie.dgk 

 

10 Save Project as: 

......\COURSEWORK\PowerMILL-Projects\Wing_Mirror_Die  

11 Create a Tip Radiused tool of Dia 40 tiprad 6 and Name D40TR6. 

12 From the Main toolbar open the Block dialog and Calculate using the Defined 

by - Box to and Type - Model. 

13 Using the default settings, select Calculate in the Rapid Move Heights. 
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14 From the Main toolbar, select Toolpath Strategies .  

15 In 3D Area Clearance tab, select the Model Area Clearance strategy. 

 

16 In the Model Area Clearance strategy dialog: 

a Enter Toolpath name - D40TR6-D1 

b Select Style - Offset Model 

c Input Thickness 0.5 

d Input Stepover 25 

e Input Stepdown 10 

 

17 In the local explorer, select the Limits page, and set the Block - Limit to 

Limit tool centre to block edge. 

 

 

18 In the local explorer, expand the Leads and Links options, and then select 

Lead In. 
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19 In the Lead in window, select 1st Choice - Ramp -  

 

20 Input the following Ramp Options: 

 

21 Click Calculate to process the Model Area Clearance toolpath. 

 

The Offset Model - Area Clearance strategy follows the model contours while 

gradually offsetting into the remaining material at each Z Height.  

22 Right-click the toolpath and select Simulate from Start to display the 
Simulation toolbar. 

 

 

 

23 Ensure that the ViewMILL toolbar is also active. 
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24 Switch the ViewMILL On/Suspend to a green sphere , and then select the 

shiny shaded image button . 

25 Press the Play  button to start the simulation. 

 

 Undrawing the tool will speed up the simulation. You can control the display 
of the tool using the light bulb on the tool entity in explorer. 

   

The finished result indicates that the current tool has not been able to remove 
enough material from some areas of the model. 

 

As a result, a further area clearance strategy is required using a smaller tool to 
continue locally into the remaining areas. This technique is known as Rest 

Machining. 

26 Click  to suspend ViewMILL.   

27 Click  to return to the PowerMILL window. 

Rest Roughing using a Reference Toolpath 

1 Create a Tip Radiused tool of Diameter 16, Tip Radius 3 and Name it as D16TR3. 

2 In the PowerMILL explorer, right-click on the toolpath D40TR6-D1 and select 

Settings to open the Model Area Clearance dialog. 
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3 Click Create a new toolpath based on this one button, to create a copy of 

the existing toolpath. 

 

All settings originally used to create the toolpath are re-activated. 

4 In the Model Rest Area Clearance dialog: 

 

a Enter a new Toolpath name D16TR3-D1 

b Enter Thickness as 0.5 

c Enter Stepover as 1.0 

d Enter Stepdown as 5.0 

e Tick the Rest machining option to display the Rest page  in the 

toolpath dialog. 
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f Select the Rest machining type as Toolpath, enter D40TR6-D1 as the 

reference toolpath, and input Detect material thicker than as 0.5 

 

g In the local explorer, select Unsafe segment removal page and un-tick 

the Remove segments smaller than threshold option. 

 

h Activate the D16TR3 tool to be used in the new toolpath.  

i Click Calculate to process and create the additional Offset Model - Area 
Clearance toolpath. 

 

j Close the dialog. 

 

5 From the Main pull down menus select File - Save Project to update: 

......\COURSEWORK\PowerMILL-Projects\Wing_Mirror_Die  

6 Switch the ViewMILL On/Suspend button to a green sphere .  
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7 Select the Rainbow Shaded Image . 

8 Select the toolpath D16TR3-D1 and Play the simulation. 

 

The ViewMILL simulation shows this toolpath shaded in a different colour where 

it has machined in areas the previous toolpath did not cover. 

 

The Reference Toolpath has roughed out material closer to the component form. 

This will reduce the risk of excessive wear or damage to tools used for the 

subsequent finishing operations. 

9 Click the ViewMILL On/Suspend button to a red sphere  and then click 

to return to the PowerMILL window. 

 

Rest Machining using a Stock Model 

An alternative method for rest machining is the use of a Stock Model instead of a 

reference toolpath. 

The benefits of using a Stock Model compared to a reference toolpath are: 

� The remaining surplus material can be visualised and registered along with the 
associated toolpaths.  

� A rest machining strategy referenced to a Stock Model will account for all 
previous operations currently registered to that Stock Model. 

� A reference machining strategy created to a different workplane (for example, 
multi-axis) can be referenced to a Stock Model.  

 It is not possible to apply a rest machining strategy referenced to a 
toolpath that was created to a different workplane. 

This example first creates and displays a Stock Model for the D40TR6-D1 
toolpath. Then, a copy of the D16TR3-D1 toolpath is created to use the Stock 

Model as the rest machining reference. 



 

PowerMILL 2013 3.  3D Area Clearance 

 Copyright © Delcam plc  3 - 25 

1 In the PowerMILL explorer, Activate the toolpath D40TR6-D1. 

 

2 In the PowerMILL explorer, right-click Stock Models and select Create 
Stock Model. 

 

3 Accept the above default values for the triangle mesh creation. 

4 In the PowerMILL explorer, right-click the newly created Stock Model 1 and 
select Apply > Active Toolpath First. 

 

5 From the same menu, select Calculate to create the Stock Model. 
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A triangular mesh will appear representing the state of the material after the effect 

of the first machining strategy, D40TR6-D1. 

In the next two actions, The Stock Model will be changed to:- 

a Visually remove the component form (Show Rest Material). 

b Visually change the style from triangle mesh to a shaded form (Shaded). 

6 From the same menu, select Drawing Options > Show Rest Material. 

 

 

7 From the same menu, select Drawing Options > Shaded to display the shaded 
view of the Stock Model. 
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8 In the PowerMILL explorer, Activate the toolpath D16TR3_D1. 

9 Right-click on the toolpath D16TR3_D1 and select Settings to open the Model 

Rest Area Clearance strategy dialog. 

10 Click  to create a copy of the toolpath. 

11 Select the Rest page and modify the settings as below using Stock model 1. 

 

12 Click Calculate to create an alternative and more efficient Rest Machining 
toolpath named D16TR3-D1_1. 

13 Close the machining strategy dialog.  

 

Although the toolpath D16TR-D1_1 appears as a referenced entity in the Stock 

Model list, the resultant machining effect is not automatically added.  
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14 In the PowerMILL explorer, right-click the toolpath, D16TR3-D1_1 and select 

Add to > Stock Model. 

 

 At this stage, the Stock Model will disappear from the screen. 

 

15 Right-click the active Stock Model and select Calculate to update it. 

 

 

16 From the Main pull down menus, select File > Save Project to update: 

......\COURSEWORK\PowerMILL-Projects\WingMirrorDie  
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Exercise 

Area clearance with both unsafe segment removal and 
rest roughing 

1 Import the Model: 

......\PowerMILL_Data\Models\Cowling 

 

Machining setup 
2 Create the following tools: 

� Tip Radiused tool – Name D16TR3, Diameter 16, Tip Radius 3. 

� Tip Radiused tool – Name D12TR1, Diameter 12, Tip Radius 1. 

3 Create a Workplane and centrally position it to the top centre of the Model as 
a more suitable machining datum. 

4 Calculate a Block using Defined by – Box and Type - Model. 

5 Calculate the Rapid Move Heights using the default settings. 
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Area Clearance Strategies 
1 Create a Model Area Clearance strategy using: 

a The D16TR3 tool. 

b The Style as Offset All. 

c Stepover 8 and Stepdown 12 

d A Thickness of 0.5 

e The Unsafe segment removal option to prevent the D16TR3 tool from 

attempting to machine into the central pocket. 

 

2 Create another Model Area Clearance strategy using: 

a The D12TR1 tool. 

b The Style as Offset Model. 

c Stepover 2 and Stepdown 3 

d Enable the Rest machining page and reference to the previous toolpath. 

e Disable the Unsafe segment removal option. 

 

3 Save Project As: 

......\COURSEWORK\PowerMILL_Projects\ModelAreaClear-Exercise 
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ViewMILL Simulation 

1 Perform a ViewMILL simulation with the Rainbow Shaded Image option  

active on both of the Model Area Clearance toolpaths.  

 

2 From the Main pull down menus, select File > Delete All. 

3 From the Main pull down menus, select Tools > Reset Forms. 

Area Clearance using the Step option 
If a large stepdown is used in the Area Clearance strategies then the bulk of the 
waste material will be removed as quickly as possible. This will inevitably leave large 

steps on the remaining stock that will need to be reduced using a separate rest 

roughing operation. If it is acceptable to use the same Tool then the Step option 
provides a form of rest machining within the same Area Clearance strategy. 

Additional passes are applied (where required) that step upwards between the 

original Z Heights   

 

1 Select File – Open Project (Read only):- 

...\PowerMILL_Data\Projects\StepRoughing_Start 

 

2 Save Project As: 

 ...\COURSEWORK\PowerMILL_Projects\StepRoughing-EX1 
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The Project contains the Speaker_Core model and a Model Area Clearance 

strategy (D25TR3-RGH1) with Machine flats – Area active.  

 

3 Activate the toolpath D25TR3-RGH1 to restore the settings used. 

4 Calculate the Block to the Model dimensions. 

5 Run a ViewMILL simulation on the toolpath D25TR3-RGH1. 

 

The original strategy has used a large stepdown and ignored the flat areas so 
that the bulk of the material is removed as quickly as possible. This has left a 

large amount of stock on the both the steps and flat areas as shown in 
ViewMILL. To accommodate this, the same strategy will be re-cycled and 

appropriate Step options applied to produce a form that is closer to the model 
shape. 

6 Select Exit ViewMILL  to close the session. 

7 Right mouse click on the active toolpath D25TR3-RGH1 and from the local 
menu select Settings. 

8 Select the ‘Re-cycle’ toolpath option  . 

9 In the Model Area Clearance dialog, local explorer, select the Step option. 

10 Tick the Step cutting box and enter values exactly as shown below. 
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11 Select Calculate to process the modified strategy. 

 

 

12 Run a new ViewMILL simulation on the toolpath D25TR3-RGH1. 

 

The above image shows the first slice being fully machined. 

 

The above image shows the effect of the Step cutting option tracking upwards 

from the first slice to get closer to the model form.  
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The Component has been ‘Roughed Out’ with maximum efficiency, close to the 

final shape within the same toolpath. 

 

13 Save the Project. 

14 From the main pulldown menus select File - Delete All and Tools – Reset 

Forms. 

Machining Flats within Model Area Clearance 
The Model Area Clearance strategies in PowerMILL include options to control the 
way in which flat areas of the component model are machined. These are accessed 

from the Machine Flats page on the dialog. 

1 Import the Model: 

......\PowerMILL_Data\Models\Flats.dgk 

 

2 Select File - Save Project As: 

......\COURSEWORK\PowerMILL-Projects\AreaClearFlats  

3 Create a 12mm diameter End Mill tool named EM12. 

4 Calculate the Block using the default settings. 
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5 Calculate default Rapid Move Heights. 

6 Keep the Start and End Point settings as default. 

7 In the Strategy Selector, select the 3D Area Clearance tab, and then open 
the Model Area Clearance strategy form. 

 

8 In the Model Area Clearance strategy dialog: 

a Enter the Name as EM12-FlatsOFF. 

b Set Thickness to 0.5 

c Set Stepover to 5 

d Set Stepdown to 12 

e Select the Flat machining page and set Machine flats to Off. 

 

 

9 Click Calculate to process the toolpath and then Close the dialog. 
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When the Machine flats option is set to Off, the toolpath totally ignores the flat 
surfaces of the model. It maintains the defined Stepdown value and performs area 

clearance across the material Block at each Z Height. 

1 Right-click the active toolpath and select Settings. 

2 Click  to create a copy of the toolpath. 

3 Change the new toolpath name to EM12-FlatsLEVEL. 

4 On the Flat machining page, change Machine flats to Level. 

5 Calculate to process the toolpath and then Close the dialog. 

 

At the Flat area heights now removes material across the whole block area leaving 0.6mm 
stock above each Flat face (The Thickness plus the Tolerance values). 

6 Right-click the active toolpath and select Settings.  

7 Click  to create a copy of the toolpath. 

8 Change the toolpath name to EM12-FlatsAREA. 
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9 On the Flat machining page, change Machine flats to Area. 

10 Calculate to process the toolpath and then Close the dialog. 

 

The Model Area Clearance toolpath now removes material locally across each 
Flat face leaving 0.6mm stock (The Thickness plus the Tolerance). 

11 Select File - Save Project As: 

......\COURSEWORK\PowerMILL-Projects\AreaClearFlats 

 

 

 

 

 

Machining Flats separately using Slice Area Clearance 
In PowerMILL Pro it is possible to use Slice Area Clearance to separately 

machine the flat areas of a model to their exact height. This could be used: 

a As a final finishing strategy, applied to the flat areas after a Model Area 
Clearance where machine flats was set to Level or Area. 

b As a secondary roughing strategy, applied to the flat areas only, that follows 

on from a Model Area Clearance where Machine flats was set to Off. 

12 Right-click on the EM12-FlatsArea toolpath and select Activate to reinstate all 

settings and parameters used.  

13 On the Main toolbar, click Toolpath Strategies . 

14 Select 3D Area Clearance tab and from the options, select Slice Area 
Clearance to open the following dialog: 
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a Enter Name as EM12-SliceAC. 

b Set Slices as Flat. 

c Set Style as Offset all. 

d Set Tolerance 0.02 

e Set Thickness 0 

f Set Stepover 5 

15 Select the Flat machining page and: 

a Select a tick in the Allow tool outside flat box. 

 

16 Select Calculate to process the toolpath and then Close the dialog. 
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The Area Clearance now creates only Flat areas. 

At the moment, the cutter profiles around the edge of the holes located on a flat 

area. If preferred, the strategy can be changed to Ignore Holes causing the tool to 

pass straight across them. 

17 Right-click on the Active toolpath and select Settings to re-open the Slice 

Area Clearance dialog. 

18 Click on  to create a copy of the toolpath. 

19 Rename the toolpath as EM12-SliceAC-IgnoreHoles and then select the Flat 
machining page. 

 

20 Select a Tick in the Ignore holes box. 

The Threshold (tool diameter units) defines the maximum size of holes to ignore. 

With the tool EM12 selected and the Threshold set to 2, holes that are greater 
than Dia 24mm will not be ingored. 
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21 Select Calculate to process the toolpath and then Cancel the dialog. 

 

The cutter now passes across the top of the holes without lifting, producing a 
smoother toolpath.  

 Ignore Holes refers to the slice definition at the top of the holes. The flat base 

of any hole will still be machined. 

If there is a large amount of material remaining on the top of the flat areas, then 
the strategy can be set to be applied at a series of different heights to reduce the 
tool loading during Area Clearance. 

1 Right-click the Active toolpath and select Settings to re-open the Slice Area 
Clearance dialog. 

2 Click on  to create a copy of the toolpath. 

3 Rename the toolpath as EM12-SliceAC-MultipleCuts and then select the Flat 

machining page. 

 

a Select the Multiple cuts option and set the Number of cuts as 3. 

b Input the Stepdown as 2.0 

c Select the Final stepdown option and input 1.0 

 



 

PowerMILL 2013 3.  3D Area Clearance 

 Copyright © Delcam plc  3 - 41 

4 Select Calculate to process the toolpath and then Close the dialog. 

 

 The ‘D’ shaped Flat area at the very top level does not use Multiple Cuts as 
the top of the Block is the overall Z limit for the strategy. 

 

 

 

 

Further information on Area Clearance 
Machining 

The following is reference information for the many different options contained in 
the Area Clearance dialogs. This can also be found by using Help. 

Restrict Tool Overload – Trochoidal moves  
This option is available to Area Clearance strategies in which Style - Offset model is 

set. The dialog for activating and entering the Maximum overload value (%) is 

located on the High speed options page. 

  

If the tool reaches a specified overload situation, PowerMILL automatically inputs a 

trochoidal path to eliminate full width cuts. This will occur in corners, narrow 

channels, slots, etc. The degree of movement is controlled with the slider as a 
percentage value in the form. 
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Thickness 

Click the Thickness button  in strategy dialogs to enter separate Radial  and 

Axial  thicknesses. 

�  

 - Radial Thickness 

 - Axial Thickness 

Z Heights – Manual entry 

To manually enter Z heights in a strategy, select Manual from the Stepdown list. 

 

Click  to display the Area Clearance Z Heights dialog.  

Defined by defines how Z heights are specified. You can define a Z height by: 

� Number - divides the block equally into the defined number of Z heights, the 

lowest of which will be at the bottom of the block. 

� Stepdown – creates a Z height at the top of the block and then steps down a 

defined height in Z. The final Z Height will be at the bottom of the block. 

If the Constant Stepdown option is selected, the distance between all Z height 

levels remain constant. To achieve this, the actual stepdown value will more 
than likely have to be automatically modified to be less than the nominal 

value. 

� Value - creates a single Z Height at the defined value. 

� Flat - Identifies flat areas of the model and creates a Z height (+ thickness) at 

these values. It can also be set to machine the specific flat areas instead of the 

whole of the slice. 

� Intermediate - adds a specified number of Z Heights between the current ones. 

Append Z Heights - Z Heights can be also be appended from an existing Model Area 

Clearance toolpath using the Reference section of the Area Clearance Z Height dialog. 
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Profiling  

A profile move can be performed at each level to remove steps that are left by the 
cutter Before, During, or After a Raster - Model Area Clearance strategy. Additional 
profile passes can be applied when machining either on Every Z or the Last Z level 

with Offset, Profile, or Raster strategies. 

When  

The When settings on a Raster page in an Area Clearance strategy dialog allow you to 

determine when the profiling pass occurs during machining. 

None – No profiling pass is performed 

Before – The profiling pass is performed before the Raster path. 

During – The profiling is performed at suitable intervals during the Raster path. 

After – The profiling pass is performed last. 

 

 

 

 

 

Cut Direction  

The Cut Direction settings control the direction of the tool along the toolpath: 

Any – This instructs the cutter to machine in both directions.  

Climb – This instructs the cutter to profile such that the material is to the right of 

the direction of travel (Climb milling). 

Conventional – This instructs the cutter to profile such that the material is to the 

left of the direction of travel (Conventional milling). 

 

Wall Finishing 

The Wall Finishing page in the Model Area Clearance strategy dialog allows you to 

make an additional, final profiling pass to further reduce tool wear. 

 

Allow tool outside block 

The Allow tool outside block setting is available on the Limit page of the Model Area 
Clearance dialog. 

This option enables the first pass of an Area Clearance strategy to be performed to 

the specified Stepover  rather than the full radius of the tool  
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 Flat Machining  

The Flat Machining page of the Model Area Clearance dialog contains options to 

control if and how the flat areas of a component are machined. These include Off, 
Area, and Level. 

Level - Flat Machining occurs across the whole area defined by the Block. 

The nominal Stepdown value is locally reduced as required to accommodate 

each Flat area as part of an equally spaced group.  

Area - Flat Machining is confined to the individual Flat area.  

The nominal Stepdown value remains constant (independent of the Flat 

areas). 

Ramping  

The Ramp option is available on the Leads and Links dialog to use where it is 

impossible to approach from outside the Block at the full machining depth (for 

example, within a pocket). 

� There are 3 different options for the type of ramp move - Toolpath, Circle, and 

Line. These can be used to lead on to the start of a tool track. 

� The Zig angle is the angle of descent along the machining direction as the tool 
ramps into the material. If the length of the Zig angle is limited to a finite 

distance, a ramp move in the opposite direction (Zag angle) can also be applied. 

 

� The Ramp Length is defined as Tool Diameter Units (TDU). For example, A Ramp 
Length of 2 TDU would equal 20 mm for a Dia 10 mm tool. 

� If Approach outside allowance is set on the Flat machining page of strategy dialog, 

it will take priority over Ramping. 

� If the defined geometry for a Ramp move is such that it would cause a gouge, 
then the tool approaches using a default Plunge move. 
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Finishing strategies machine the actual component form, and where applicable, 
follow on from the Area Clearance operation. Suitable values are required to 

control the accuracy and amount of excess material to be left on a component by a 

toolpath. The parameters used for this purpose are called Thickness and 
Tolerance. 

Thickness is the amount of extra material specified to remain on the work-piece 

after machining. This can be applied generally as an offset from the model (as 
shown), or independently as separate Radial and Axial values within the machining 

options. 

 

 It is also possible to assign additional Thickness values to groups of 
surfaces on the model (Component Thickness). 

Tolerance controls the accuracy to which the cutter path follows the shape of the 
work-piece. For roughing, use a Coarse tolerance, and for finishing use a Fine 
tolerance. 

 

 A positive Thickness value should always be greater than the Tolerance 
value. 

4. Finishing Strategies 
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Raster, Radial, Spiral, and Pattern 
Finishing 

These four types of strategy generate toolpaths by projecting a wireframe, pattern 
down the Z-axis onto the model. The standard patterns applied in Raster, Radial, 

and Spiral are achieved by entering values directly into the Finishing dialog. Select 
Preview to view the resultant pattern. If you are satisfied with the preview, click 

Calculate to process the toolpath. 

The Pattern strategy uses an existing, pre-defined Pattern or Toolpath, which is 
either projected down Z onto the model or used in situ to generate a new toolpath. 

Typical previews of the four pattern strategies are shown below as viewed down Z. 

 

The Raster finishing strategy is used as an example in the next section. 

 

Raster Finishing 
1 From the Main pull down menus select File - Delete All and Tools - Reset 

Forms. 

2  Then select File > Open Project: 

......\PowerMILL_Data\Projects\chamber_start 

 



PowerMILL 2013 4. Finishing Strategies 

Copyright © Delcam plc  4 - 3 

 

The Read-Only Project contains a component model and a Dia 12 Ball Nose 
tool. 

3 From the Main menu , select File >Save Project As: 

......\COURSEWORK\PowerMILL-Projects\chamber 

 

4 Calculate a Block using the default settings. 

5 Calculate the Rapid Move Heights using the default settings to ensure 
link moves occur at a safe height above the model. 

6 On the Main toolbar, click  to open the Toolpath Strategies dialog. 

7 On the Strategy Selector, click the Finishing tab and then the Raster 
Finishing strategy. 

 

8 Click OK to display the Raster Finishing strategy dialog and enter the following 

settings and values. 
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a Name the toolpath bn12-RasterBasic. 

b Enter the Tolerance as 0.02 and Thickness as 0 

c Select Ordering - Style as Two Way. 

d Enter a  Stepover of 1 

e Click the Preview tab to display the pattern (as shown below). 
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9 Click Calculate to process the toolpath and then Close the dialog. 

 

On closer inspection, the toolpath contains sharp corners along the vertical plane 
direction. These can be arc fitted within the strategy form. 

 

In the Raster Finishing, High speed page the Arc fit corners option in the dialog arc 

fits these to a maximum radius of 0.2 TDU (Tool Diameter Units). 

 

10 In PowerMILL explorer, right-click the bn12-RasterBasic toolpath and select 

Settings. 

11 Click  to create a copy of the toolpath. 

12 On the strategy dialog: 

a Rename the new toolpath as bn12-RasterArcfit. 

b Open the High speed page. 

 

 

 

c Select the Arc Fit option and edit the Arc Radius to the maximum value 0.2 

d Click Calculate to process the toolpath and then Close the dialog. 
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13 Zoom into the toolpath to view the arc fitted tooltracks: 

 

The value 0.2 (TDU), multiplied by the tool diameter (12 mm) produces a 

radius of 2.4 mm. 

At the end of each tool track, the cutter retracts to the Safe Z height. This is a 

waste of time as these lifts are unnecessary. To make the toolpath more efficient, 
alternative Link options will be applied. 

1 From the Main toolbar, select  Leads and Links . 

2 Select the Links tab on the Leads and Links dialog. 

 

a Set the Short/Long threshold to 3.0 

b Set the Short links to Circular Arc. 

c Set the Long links to Skim and Default links to Incremental. 

 If the distance from the end of a tool track is within 3 mm from the start 
of the next, then the Short links option (Circular Arc) applies. 

 

3 Apply and then Accept the dialog. 

 

All unnecessary retract moves are eliminated with a circular arc move now 

forming the link between adjacent tool tracks. 

The next stage is to simulate the latest, active toolpath, bn12-RasterArcfit. 
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Pattern Finishing 
This strategy requires a user-defined Pattern for projection onto the model as a 

toolpath. This option can be used for applications such as scribe lines, text, and 

custom strategies. A Pattern is created either from within PowerMILL or from 
imported wireframe data. 

1 Select File - Delete All followed by Tools - Reset Forms. 

2 Import the Model: 

......\PowerMILL_Data\Models\swheel.dgk 

 

Since the component is circular, a Block Defined by Cylinder will be used. 

3 Click the Block button  on the Main toolbar to open the Block dialog. 

 

4 Calculate a Block, Defined by Cylinder using Type Model. 
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5 To provide more stock on the base, modify the Min Z value to –1, Lock the 

value, and click Accept. 

 

Move the slider  to change the Opacity of the Block. 

  

Before the Pattern finishing strategy is created, an Area Clearance strategy is 

required to remove the bulk of the material, using a Thickness of 0.5, followed by a 

Semi-Finishing strategy with a Thickness of 0.2. 

 

6 Define a Tip Radius tool: 

a Name -  D10TR1 

b Diameter 10 

c Tip Radius 1 

d Tool Number 1 

7  Define a Ball Nose tool: 

a Name - BN6 

b Diameter 6  

c Tool Number 2 

 

8 Activate the D10TR1 Tip Radius tool. 

9 Calculate the Rapid Move Heights . 

10 Calculate a Model Area Clearance toolpath using the following parameters: 

a Name – D10TR1-RoughOP1 

b Style - Offset all 

c Cut Direction – Climb (Both Profile and Area). 

d Tolerance  0.1 

e Thickness  0.5 

f Stepover  5.0 

g Stepdown  1.0 
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11 Simulate the toolpath in ViewMILL: 

 

12 Click  and return the ViewMILL display to No Image. 

13 In PowerMILL explorer, activate the BN6 Ball Nose tool. 

14 Calculate a Spiral Finishing toolpath using the following parameters: 

a Name - BN6-SemiFinishOP1 

b Centre Point - X  0, Y  0 

c Radius - Start 62.0, End 0.0 

d Direction - Clockwise 

e Tolerance 0.1 

f Thickness 0.2 

g Stepover 1.0 

15 Simulate the new toolpath in ViewMILL: 

 

16 Click  and return the ViewMILL display to No Image. 

17 In the PowerMILL explorer, right-click the SemiFinishOP1 toolpath and 
select Settings. 
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18 Click  and create a copy of the toolpath. 

19 Enter:- 

a Name - BN6-FinishOP1 

b Tolerance - 0.01 

c Thickness - 0.0 

d Stepover - 0.3 

20 Click Calculate and when processed Close the dialog. 

21 Simulate the final finishing toolpath in ViewMILL: 

 

Next, some text will be engraved into the above finished, wheel form. 

 

1 Click  to return the ViewMILL display to No Image. 

2 In the PowerMILL explorer, right-click Patterns and select Create Pattern. 

 

A new, empty Pattern is created.  

 

 

3  Right mouse click on the new empty Pattern and from the local menu select 

Insert - File to access the Open Pattern dialog. 

4  Click button 2 (Shown inside red border below) on the Open Pattern dialog: 
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5 Double click the Patterns folder and then select the Engrave1.dgk file. 

 

6 Click Open. 

The imported Pattern is made up of 2D geometry and is positioned at Z 0. This 
2D geometry will be projected down Z onto the 3D model to create a single 
toolpath with a negative Thickness value. 

 

7 Define a Ball Nose tool of diameter 1, named BN1, with Tool Number 3. 

8 Create a Pattern Finishing toolpath. 



4. Finishing Strategies PowerMILL 2013 

4 - 12  Copyright © Delcam plc  

 

a Enter the Toolpath name BN1-EngraveOp1 

b Input Pattern 1 (if not already selected). 

c With the Base position set to either Automatic or Vertical, the Pattern 
form will be projected down Z onto the model. 

d Enter a Tolerance 0.02 and Thickness -0.4 

 

9 Select Calculate to process the toolpath then Close the dialog. 

The Pattern is machined to an offset depth of -0.4 into the finished model 
form. 
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 It is not possible to use a –ve thickness value that is greater than the Tool 
Tip Radius. There is, however, an alternative way to achieve this (Chapter 

11 Patterns, page 20 - Deep Pattern Machining). 

10 Simulate the engraving toolpath in ViewMILL. 

 

11 Select File - Save Project As: 

......\COURSEWORK\PowerMILL-Projects\PatternMachining 

Pattern Exercise 
In this exercise you are to use same imported Pattern (Engrave1) to machine text 

into a telephone handset Model.  
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1 Select File - Save Project As: 

......\COURSEWORK\PowerMILL-Projects\PhoneEngrave 

2 Delete the 2 toolpaths, BN6-SemiFinishOP1 and BN6-FinishOP1. 

3 Right-click Models on the PowerMILL explorer and select Delete All. 

4 Import the Model:-    ......\PowerMILL_Data\Models\phone.dgk 

5 Recycle the Model Area Clearance toolpath D10TR1-RoughOP1 using a 

Block Defined by Box, and with the Rapid Move Heights re-calculated. 

 

6 Create a new Raster finishing toolpath using the following parameters: 

Name - BN6-SemiFinishOP1 

Tolerance 0.1 

Thickness 0.2 

Stepover 1.0 

 

7 Create a new Raster finishing toolpath using the following parameters: 

Name - BN6-FinishOP1 

Tolerance 0.01 

Thickness 0 

Stepover 0.3 

 

8 Recycle the Pattern Finishing toolpath EngraveOp1 using a Block Defined 

by Box, and with the Rapid Move Heights re-calculated. 

9 Perform a full ViewMILL simulation on all 4 toolpaths. 

 

 

10 Select File - Save Project  
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3D Offset and Constant Z Finishing 
In this section, 3D Offset and Constant Z finishing strategies are applied to a 

model that consists of a combination of flat and steep areas plus a pocket with 

vertical walls. The two strategies are limited to where they are most compatible. 

A Boundary is created and used to limit the 3D Offset toolpath to the flatter areas 

leaving the remaining steep areas to be machined using the Constant Z strategy. 

3D Offset Finishing 
3D Offset Finishing creates the tool stepover relative to the 3D Model surface 

providing consistency over both flat areas and steep sidewalls. 

 In this exercise, it is not recommended to apply this toolpath to the 
complete model without using Boundaries. Although this toolpath 

maintains a constant Stepover, there is nothing to prevent the tool 

plunging with a full width cut into the deep pocket area. 

1 Select File - Delete All and File - Reset Forms. 

2 Select File - Open Project and in the dialog browse to: 

......\PowerMILL_Data\Projects\camera_start 

The Project is locked and subsequent changes cannot be saved unless the 

included lock file is deleted. 

 

3 Select OK to continue loading the Project into the PowerMILL session. 

4 From the Main pull down menus, select File > Save Project As: 

......\COURSEWORK\PowerMILL_Projects\Camera_Example 

The Project already contains a Tip Radiused tool and an Offset Area Clearance 

toolpath along with the associated settings. 

 

1 Activate the existing Model Area Clearance, toolpath, and perform a 

ViewMILL simulation. 
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Use of Shallow Boundary to define specific machining 
areas 

Specific finishing strategies are more effective on either Steep or Shallow parts of 

a 3D component model. For example, Constant Z finishing is most effective on 
steep sidewalls while Raster Finishing is most effective in shallow areas. 

A Shallow Boundary creates segments around areas of the model that are 
defined by an Upper and Lower threshold angle. It is therefore specifically suited 

to steep walled and shallow surface machining techniques. 

 There are several other types of Boundary options available to suit various 
applications and these are covered later in Chapter 6. 

 

In the below example, a Shallow Boundary is used to discriminate areas most 

suited to the individual machining strategies. This type of Boundary is calculated, 

taking the active Tool into consideration. 

 

1 Define a Ball Nose tool of Diameter 10 called BN10. 

2 In the PowerMILL explorer, right-click Boundaries and select Create 

Boundary > Shallow. 
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3 In the displayed Shallow Boundary dialog: 

 

a Enter the Name as ShallowBN10 

b Enter Upper Angle 30 and Lower Angle 0 

c Enter Tolerance as 0.02 

d Enter Thickness as 0 

e Ensure the correct tool BN10 is Active. 

f Un-tick the box, Allow boundary to be private. 

g Apply and Accept the dialog. 

 With Radial Thickness set to 0.5 the stock thickness left on the sidewalls 

from roughing is not machined at this stage. 

With the model, Tool, and toolpaths undrawn, the Boundary can be viewed 
as shown: 

 

This boundary is made up of numerous segments; each one dividing the model into 

steep and shallow areas. Any of these segments can be selected and individually 

deleted at any time, except when it is assigned to a toolpath and locked.  
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1 From the Main toolbar, click the Toolpath Strategies  button. 

2 From the Finishing tab, select 3D Offset Finishing strategy and click OK. 

 

3 In the 3D Offset Finishing strategy dialog:  

a Enter Toolpath name as BN10-3DOffset 

b Set the Cut Direction to Climb 

c Enter a Tolerance of 0.02 

d Enter a Thickness of 0 

e Enter a Stepover of 1.0 

4 On the 3D Offset finishing dialog, select the Limit page 

 

5 Select the Boundary - ShallowBN10. 
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6 Select Calculate to create the toolpath and then Close the dialog. 

The Toolpath follows the contours of the Boundary segments and is produced only 

within the shallow areas of the model (Inside the Boundary). 

 

7 Click the Leads and Links  button from the top of the screen. 

8 Select the Links tab and: 

a In Lead in, Un-tick Add leads to short links, change the 1st Choice to 

Vertical Arc, Angle 90 and Radius 5. 

b Click the Lead Out the same as lead in button.  

a In Links input 4 in Short/Long threshold, change the Short to On Surface, 

Long to Skim, and default to Incremental. 

 

9 Apply and Accept the dialog. 

The toolpath now is more efficient with the rapid moves at skim height and the 

short links being forced onto the surface. 

 

10 Simulate the 3D Offset Finishing toolpath in ViewMILL. 
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Constant Z Finishing 
Constant Z Finishing projects each tool track horizontally onto the component at 

fixed heights defined by the Stepdown. 

 

As the component surface becomes shallow, the actual tool stepover increases until 

it becomes non-existent on flat areas. 

1 Click the Strategy Selector  button on the Main toolbar. 

2 From the Finishing tab, select the Constant Z Finishing strategy and click OK. 

 



PowerMILL 2013 4. Finishing Strategies 

Copyright © Delcam plc  4 - 21 

3 In the Constant Z Finishing dialog: 

a Enter a Toolpath name - BN10-ConstantZ 

b Enter a Tolerance of 0.02 

c Set the Cut Direction to Climb. 

d Enter a Stepdown of 1 

4 On Constant Z finishing dialog, select the Limit page and set Trimming to 

Keep outside. 

 

5 Click Calculate to process the toolpath and then Close the dialog. 

By using the Boundary - Trimming option as Keep outside, the toolpath is 
limited to the steep areas of the model.  

 If a Boundary had not been used, parts of the toolpath on the shallow areas 
would have an excessive Stepover as shown below: 

 

1 Click the Leads and Links button  on the Main toolbar. 

2 Select the Lead In tab and: 

e In Lead in, change the 1st Choice to Horizontal Arc, Angle 90 and 

Radius 5 

f Click the Lead Out the same as lead in button.  
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3 Apply and Accept the dialog. 

The tool now leads in and out of the toolpath with a horizontal arc. 

If the tool lifts, it will only lift by the skim distance taken from the first page of 

the Leads and Links dialog (Z Heights tab). 

The rapid feed moves at skim height are purple in colour while the plunge 

feed moves are light blue. 

 

4 Simulate the toolpath in ViewMILL. 

 

5 Select File - Save Project:  

To update:- ......\COURSEWORK\PowerMILL-Projects\Camera_Example  

 

 Note: The above saved Project will be re-opened later so a copy will now 
be saved for the next example!  

 

6 Select File - Save Project: 

 ......\COURSEWORK\PowerMILL-Projects\New-Template 
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Saving a Project as a re-useable Template 
If the Settings and Strategies used in a particular Project could be regularly used 

over a range of components the process can be saved as a re-useable Template. 

7 Look at the contents of the current Project in the PowerMILL explorer. 

 

Entities such as NC Programs, un-processed Toolpaths, Tools, Boundaries could 

be re-used on a range of different jobs, hence would be ideal for storing in a 

Template. 

Entities such as Workplanes, Models would be unique to different components 

hence should not be stored in a Template. 

8 In the PowerMILL explorer, right mouse click on Models and from the local 
menu select Delete All. 

9 In the PowerMILL explorer, right mouse click on Toolpaths and from the 
local menu select Invalidate All.  

10 In the PowerMILL explorer, right mouse click on Levels and from the local 

menu select Delete Empty Levels and Sets. 

11 In the PowerMILL explorer, right mouse click on Workplanes and from the 

local menu select Delete All. 

12 In the PowerMILL explorer, right mouse click on the Boundary 
ShallowBN10 and from the local menu select Edit - Make Invalid. 

13 From the main pull down menus select, File – Save Template Objects. 

 

14 In the browser, Save the Template as:-  

......\COURSEWORK\PowerMILL_Projects\MasterProject-SteepShallow 

The required components of the Project are stored in a Template. 

15 Select File - Save Project to update: 

 ......\COURSEWORK\PowerMILL-Projects\New-Template 
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Exercise – Apply the Template to a different Model 

1 From the Main menu, select File – Delete All and Tools – Reset Forms. 

2 Import the Model:-       ......\PowerMILL_Data\Models\Chamber.dgk 

 

3 From the Main menu, select Insert – Template Object. 

4 In the browser, Open the Template:-  

......\COURSEWORK\PowerMILL_Projects\MasterProject-SteepShallow.ptf 

5 Create a Block around the new model using the default settings. 

6 Calculate the Rapid Move Heights. 

7 Activate the BN10 tool. 

8 Right mouse click on the Boundary - ShallowBN10 and select Settings. 

9 In the dialog select Apply to create the correct Shallow Boundary for the new 

model and then Accept to close. 

10 Activate the new Boundary. 

11 In the PowerMILL explorer select all 3 unprocessed toolpaths and right 

mouse click on them. 
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12 From the local menu select Edit – Set Named Parameter and in the dialog 

input Block. 

 

13 From the same local menu select Edit – Set Rapid Moves. 

 The Block, Rapid Move Heights, and Active boundary will be now 
embedded in the 3 unprocessed toolpaths. 

 

14 In the PowerMILL explorer right mouse click on Toolpaths and from the local 

menu select Batch Process. 

15 Run a ViewMILL simulation on all of the 3 toolpaths. 

 

 

16 Select File - Save Project to update:- 

......\COURSEWORK\PowerMILL_Projects\ChamberFromTemplate 
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3D Offset Finishing – Spiral and Smoothing Options 
17 Select File – Delete All and Tools – Reset forms. 

18 Open the (recently saved) Project:- 

......\COURSEWORK\PowerMILL-Projects\Camera_Example 

 

19 In the PowerMILL explorer, right-click the BN10-3Doffset toolpath and 
select Settings. 

20 Click  to create a copy of the toolpath. 

 

a Rename the toolpath as BN10-3Doffset-Spiral. 

b Tick the Spiral option. 

c The Spiral option is essential for HSM (High Speed Machining) applications 
where toolpaths should ideally be as continuous as possible. 

21 Select Calculate and when the toolpath is created, Close the dialog. 
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To further improve the compatibility of this strategy for HSM, you can select the 

Smoothing option. This results in sharp corners being replaced with a smooth 

blend wherever possible. 

 

22 In the PowerMILL explorer, right mouse click on the BN10-3Doffset_Spiral 

toolpath and select Settings. 

23 Click  to create a copy of the toolpath. 

24 In the 3D Offset Finishing strategy dialog: 

a Rename the new toolpath as BN10-3Doffset-Spiral_Smooth. 

b Tick the Smoothing option. 

c Click Calculate and when the toolpath is created, Close the dialog. 

 

 

25 Select File - Save Project to update (but do not close!):- 

......\COURSEWORK\PowerMILL-Projects\Camera_Example 
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Optimised Constant Z Finishing 
This strategy is a mixture of Constant Z and 3D Offset machining; Constant Z is 

applied to steep areas and, 3D Offset is applied to other areas. 

 

1 Deactivate the Boundary, ShallowBN10 in the PowerMILL explorer. 

2 Select the Toolpath Strategies dialog  and from Finishing tab, select 

Optimised constant Z finishing and then OK. 

3 In the Optimised constant Z finishing dialog: 

 

a Enter Toolpath name as BN10-OptCZ 

b Select the Spiral, Closed Offsets, and Smoothing options. 

c Enter the Tolerance as 0.02 

d Set the Cut direction to Climb. 

e Enter a Stepover value of 1 

f On the Limit page, make sure that the Boundary is not selected. 

 

4 Select Calculate and when the toolpath is created, Close the dialog. 
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Note the consistent Stepover between tool tracks across the whole component. 

 

 

5 From the Main menu, click the Leads and Links button to display the Leads 

and Links dialog and then, select the Links tab. 

 

a Change the Short/Long Threshold to 2. 

b Change the Short links to On Surface. 

c Change the Long and Default links to Skim. 

 

6 Apply and Accept the dialog. 

7 Select File - Save Project to update (but do not close):- 

......\COURSEWORK\PowerMILL-Projects\Camera_Example 
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Steep and Shallow Finishing 
This is an alternative strategy to Optimised Constant Z with different options which 

include a user-defined Threshold Angle between the Constant Z, and 3D Offset areas 

of the toolpath as well as an option to specify an Overlap value between them. 

1 From the Finishing strategies tab in the Strategy Selector dialog, select 
Steep and Shallow finishing. 

2 Enter the values exactly as shown: 

 

a Enter Toolpath name as BN10-SteepAndShallow 

3 Select Calculate to process the toolpath and then Close the dialog. 

 

You can control the angular threshold between the 3D Offset and Constant Z 

components of the hybrid Steep and Shallow finishing strategy. 

4 Select File - Save Project to update:- 

......\COURSEWORK\PowerMILL-Projects\Camera_Example 
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Optimised Constant Z and Steep and Shallow finishing 
with separate Shallow Stepover 

Both Optimised Constant Z and Steep and Shallow strategies have an option to 
apply a separate, larger Stepover across shallow areas. This option is designed to 
enable a more efficient machining of shallow areas with a Tip Radiused tool. 

 

1 Delete All and Reset Forms. 

2 Select File - Open Project and in the dialog browse to: 

......\PowerMILL_Data\Projects\ADV-Opt-ConstZ-Start 

 

3 Click OK to load the Project into PowerMILL. 

4 Save Project As: 

......\COURSEWORK\PowerMILL_Projects\ADV-CZ-example 

5 In the PowerMILL explorer, right-click toolpath D16t3-OptConstZ and select 
Settings. 

The component form includes 2 flat areas which are currently machined with the 
same small stepover as the angled walls. For more efficiency, an option is 

available for a larger stepover to be independently applied to the shallow flat 

areas. 
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6 Click Recycle  to enable edits to the existing toolpath. 

 

a Un-tick Closed offsets. 

b Select the Use separate shallow stepover option. 

c Enter a Shallow stepover of 6.0 

7 Click Calculate to process the toolpath and then Close the dialog. 

 

The flat areas are machined using a large stepover while the steep areas use 
a small stepover. 

 

 

8 Open a new Steep and Shallow finishing strategy and enter data exactly as 

shown below. 
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9 Click Calculate to process the toolpath, and then Close the dialog. 

 

 

10 Select File - Save Project, to update:- 

......\COURSEWORK\PowerMILL_Projects\ADV-CZ-example 
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Constant Z Finishing – Additional Stock option 
The Additional Stock option causes a Constant Z strategy to locally switch the 

Order by from Region to Level below the point where the width of a deep, angled 

slot reaches a specified width. 

Above this point, the tool will continuously machine down each individual, angled 

face. Below this point the tool will alternate machining from one angled face to the 

other as the strategy steps downwards. 

11 Select File - Delete All and Tools - Reset Forms. 

12 Select File - Open Project and in the dialog browse to: 

......\PowerMILL_Data\Projects\CZ_AddStock-Start 

 

13 Select OK in the PowerMILL Warning dialog and Save Project As: 

......\COURSEWORK\PowerMILL-Projects\CZ_AddStock-EX1 

 

14 Right-click the Roughing toolpath and from the local menu select Activate to 

reinstate the original Block. 

15 Right-click the Roughing toolpath again and select Simulate from Start. 

16 From the Main toolbar, select View > Toolbar > ViewMILL to access the 

ViewMILL toolbar (if not already displayed). 

17 On the ViewMILL toolbar click the Red sphere  to switch ViewMILL on (Green 

sphere). 

 

 

18 Click Rainbow Shading button  on the ViewMILL toolbar and then click 

Play on the Simulation Toolbar. 
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The Roughing strategy has not fully machined a large volume of stock towards 
the base of the slot. This will have to be removed as part of a Constant Z 

finishing strategy. 

19 Right mouse click on the 0_AdditionalStock toolpath and select Simulate 
from Start followed by Play button on the Simulation Toolbar. 

 

You can see that the existing Constant Z finishing strategy ploughs into the 

stock that was inaccessible to the previously simulated Roughing toolpath. The 

excessive loading is likely to result in tool breakage.  

To avoid this problem, re-calculate the Constant Z strategy to include suitable 

settings in the Add Stock option. 

20  In the ViewMILL toolbar select the No Image  button and switch 

ViewMILL On/Suspend back to red  . 

21 Activate the 0_AdditionalStock toolpath.  

22 Right mouse click on the toolpath, and from the local menu select Settings to 

open the original Constant Z Finishing dialog. 

23  Click  to create a copy of the toolpath. 

24 Rename the new toolpath as 8_AdditionalStock and in the Additional Stock 

box input the value 8.0  
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25 Click Calculate toolpath and then Close the dialog. 

 The choice of the selected Additional Stock value requires your 
intervention in estimating the width of the slot, just above the depth of 

material inaccessible to the Roughing strategy. 

26 Repeat the ViewMILL simulation, starting with the Roughing strategy as 
before, but then following on with the toolpath 8_AdditionalStock. 

 

The new Constant Z finishing strategy orders the tool tracks to machine 
continuously down each individual sidewall to a height just above the remaining 

stock.  Below this point, the tool tracks alternate from wall to wall into the 

remaining stock. 

 

 

27 Select File - Save Project to update:- 

......\COURSEWORK\PowerMILL-Projects\CZ_AddStock-EX1 
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Corner Finishing 
Corner Finishing strategies identify and remove material in corners that are 
inaccessible to previously used, larger tools. There are 3 independent types of 

strategy: Along, Stitch, and Automatic.  

All Corner Finishing strategies include a Threshold Angle option. When you select the 
Output type either as Steep or as Shallow, the Threshold Angle determines the angle 

from the horizontal at which steep and shallow portions are split.  

You can modify the Threshold Angle to prevent the tool running up or down steep 
slopes.  For example, you could apply a Stitch strategy to track across the steep 

areas, while using the Along strategy in shallow areas. 

                   

All the Corner Finishing strategies, (except for Pencil) are based on machining the 
area between the Reference tool (2) and the Active tool (1) as in the diagram. 

 

In the following example, the reference tool is a Dia 10 Ball-nose and the Corner 
finishing is continues with a diameter Dia 5 Ball-nose. 

 

1 Select File - Delete All and Tools - Reset Forms. 

2 From the Main menu, Select File - Open Project and select: 

......\PowerMILL_Data\Projects\CornerFinish_Start 

 

3 From the Main menu, select File - Save Project As: 

......\COURSEWORK\PowerMILL-Projects\CornerFinish 
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Corner Along Finishing 
4 Select an ISO2 view. 

 

5 Activate the toolpath, D16T3-rghA1 to restore the settings. 

6 Define a diameter 5 ball nose tool named BN5 

7 Click  and open the Toolpath strategies dialog, and from the Finishing tab, 

select Corner Finishing. 

8 In the Corner Finishing strategy dialog: 

 

a Enter Toolpath name as CornerAlong_Shallow 

b Change Output to Shallow and Strategy to Along. 

c Set Cusp to 0.03 

d Set Cut direction to Climb. 

e On the Tool page, check that the BN5 tool is selected. 

 

 

f Select the Corner detection page and select the Reference tool as BN10. 
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9  Calculate to process the toolpath and then Close the dialog. 

10 Simulate the toolpath and observe the order of the machining: 

 

Note: With Output set to Shallow, the toolpath has stayed within the shallow 
areas of the model (between horizontal and a downward angle of 30 Degrees).  

 Use a Threshold angle of 90 for the Shallow option to apply in all valid 
rest areas. This would also result in the Steep option area to be non-

existent. 
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Corner Stitch Finishing 
1 From the Finishing strategies tab, select Corner Finishing. 

2 In the Corner Finishing strategy dialog: 

 

a Enter Toolpath name as CornerStitch_Steep 

b Change Output to Steep and Strategy to Stitch. 

c Check that the BN5 tool is active on the Tool page. 

d Check that the Reference tool is BN10 on the Corner detection page. 

3 Calculate to process the toolpath and then Close the dialog. 

 

This time, only the steep areas are machined. 

 

4 From the Main menu select File > Save Project to update:- 

......\COURSEWORK\Projects\CornerFinish 
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Corner Automatic Finishing 
1 From the Toolpath strategies dialog, select the Corner Finishing strategy 

and enter the data into the dialog exactly as shown below: 

 

a Use Strategy - Automatic. 

b Change Output to Both. 

c Change the Threshold angle back to 30.0 

 

2 Click Calculate to process the toolpath and then Close the dialog. 

 

This strategy automatically uses Along for the Shallow areas and Stitch for the 

Steep areas. 
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Corner Pencil Finishing 
Corner Pencil creates a single toolpath along the actual intersection between non-

tangential faces on the model.  

 

1 From the Toolpath Strategies dialog, select and open the Corner Pencil 

Finishing strategy. 

2 In the Corner Pencil Finishing strategy dialog: 

 

a Change Output to Shallow. 

b Change the Threshold Angle to 90 

 Note: With a Threshold Angle of 90 the Steep angle will not exist, so only 
Output with Shallow or Both selected will enable a toolpath to be created. 

c On the Tool page, make the BN5 tool active. 

3 Select Calculate to process the toolpath, and then Close the dialog. 
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Corner Multi-pencil Finishing 
Corner Multi-pencil Finishing creates a multi-track, rest finishing, toolpath based on 

the Pencil Finishing strategy. On creation it visually looks similar to a Corner 

Finishing - Along toolpath, but on closer inspection there are subtle differences to 
the toolpath order and the fact it includes tool tracks along the actual model 

intersections.  

1 From the Toolpath Strategies dialog, select and open the Corner Multi-
Pencil Finishing strategy. 

2 In the Corner Multi-Pencil Finishing strategy dialog: 

 

d Change Output to Both. 

 Note: With a Threshold Angle of 90 the Steep angle will not exist, so 
only Output with Shallow or Both selected will enable a toolpath to be 

created. 

e Change the Threshold Angle to 90 

f On the Tool page, make the BN5 tool active. 

g In the Corner detection page check that BN10 is selected. 

3 Calculate to process the toolpath and then Close the dialog. 

            

4 From the Main menu select File > Save Project to update:- 

......\COURSEWORK\Projects\CornerFinish 
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Flat Finishing 
These strategies apply to purely flat surfaces only. Flat areas within a variable 

height surface are not recognised. The minor discrepancies in the flatness of a 

surface is controlled by a Flat Tolerance value. 

 

1 Delete All and Reset Forms. 

2 From the Main menu, select File - Open Project: 

......\PowerMILL_Data\Projects\FlatFinish_Start 

3 Select File - Save Project As: 

......\COURSEWORK\PowerMILL-Projects\FlatFinish-Example1 

Offset Flat Finishing 
1 In the PowerMILL explorer, Activate the Dia 16 End Mill (EM16) tool. 

2 In the Strategy Selector dialog, select the Finishing tab, and select Offset 
Flat Finishing. 

3 Fill in the Offset Flat Finishing dialog exactly as shown. 

 

4 Select Calculate and when completed, Close the dialog. 
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In this case, suitable Leads have been applied retrospectively: 

Lead In/Out: 

1st choice - Pocket Centre 

2nd Choice - Horizontal Arc  - Angle 90 - Radius 8  

The imported Project contains both an Offset Area Clear roughing strategy and 

an Optimised Constant Z finishing strategy. It is recommended that Offset Flats 
(EM16Flats-a1) is run directly after the 3D Area Clearance (D16t3-a1). For this 

reason, it would make good sense to move it up the toolpath order in the 
PowerMILL explorer. 

1 In the PowerMILL explorer, left click and drag the Offset Flats Finishing 

toolpath (EM16Flats-a1) to the new position. 

 

2 Perform a ViewMILL simulation on all 3 toolpaths to check that the method and 
result of removed material is acceptable. 

 

The ViewMILL simulation after the Offset Flat Finishing strategy is shown above. 
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Raster Flat Finishing 
1 In the Strategy Selector, from the Finishing tab, select Raster Flat 

Finishing. 

2 Fill in the dialog exactly as shown and click Calculate. 

 

3 Select Calculate and when completed, Close the dialog. 

 

4 From the Main menu select File > Save Project to update:- 

......\COURSEWORK\PowerMILL-Projects\FlatFinish-Example1 
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Flat Machining example 
1 Select File - Delete All and Tools - Reset Forms. 

2 Select File - Import Model: 

......\PowerMILL_Data\Models\Flats.dgk 

 

3 Create a 20mm diameter End Mill tool named EM20. 

4 Calculate the (default) Block and then reset the Safe Heights. 

5 Open an Offset Flat Finishing strategy and: 

 

a Name the toolpath EM20-FlatFin. 

b Click the use Axial Thickness button and enter separate Thickness values 

for Radial 0.5 and Axial 0 

c Calculate to process the toolpath and then Close the dialog. 
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The Flat areas are finish machined, apart from between the ‘D’ shaped and oval 

Bosses as well as at the base of the holes due to the 20mm diameter tool being too 

large. We will now use a smaller tool to Rest machine these areas. 

 

6 Create a Dia 10 End Mill, named EM10. 

7 Activate the Toolpath, EM20-FlatFin and then select Settings. 

1 Click  and create a copy of the toolpath. 

2 In the main page of the strategy dialog:  

 

a Enter Toolpath name as EM10-FlatFinRest. 

b Enter Stepover as 3.0 

c Activate the EM10 tool. 

d Tick the Rest machining box and then select the Rest page. 
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e On the Rest page, select the reference Toolpath as EM20-FlatFin. 

 

3 Calculate the toolpath and when created, Close the dialog. 

The final finishing passes at the base of the holes and the area behind the boss 

are now created: 

 

 

 

4 From the Main menu select File > Save Project to update:- 

......\COURSEWORK\FlatFinishing-Example2 
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Surface Finishing Example 1 
The Surface Finishing strategy creates tool tracks that follow the natural, surface 

curves on a single, selected, Surface. 

 The tool tracks in a Surface Finishing strategy will not run parallel to the 
edges of a trimmed, surface. 

1 From the Main menu, select File - Delete All and Tools - Reset Forms. 

2 Open the read-only Project:- 

        ......\PowerMILL_Data\Projects\EditToolpaths_3 

3 From the Main menu , select File - Save Project As: 

......\COURSEWORK\PowerMILL-Projects\PunchForm_3 

 

4 Activate the existing toolpath 1 to reinstate all the original settings  

All you need from the original settings is the original; Active Workplane, 

Block, Rapid Move Heights, and the Tiprad tool named D10t1. 

 

5 De-Activate toolpath 1, Boundary 1, and Pattern 1.  

6 Select the upper surface on the punch model (as displayed above). 
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7 Open the Surface Finishing strategy and enter values as shown below. 

 

8 Select the Pattern page: 

 

a Set Pattern direction – U 

b Select - Two way 

c Select - Min U max V 

 

9 Select Calculate to create the toolpath and then Close the dialog. 
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10 From the Main toolbar, click the Leads and Links  button. 

11 On the Links page: 

 

a Enter Short/Long - Threshold 3.0 

b Select Short - Circular Arc 

c Select Long - Skim 

d Select Default – Incremental 

 

12 Apply the dialog  to update the active toolpath. 

 

Where the Link move from the end of a tool track to the start of the next is 

within 3 mm, an (orange) arc move will be implemented. 
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In the resultant toolpath, the natural order of the tool tracks and link moves 

across the 2 narrow areas is not very efficient. 

This can be fixed by applying suitable toolpath Edit - Reorder options. 

13 Right-click on the toolpath and from the local menu, select Edit > Reorder. 

14 In the Toolpath Listing dialog, click the Automatic reorder and reverse  

button. 

 

The toolpath follows the curves of the selected surface. 

The illustrated toolpath is created with a 1 mm Stepover to help with visualisation. 

It has also been edited using the Automatic Reorder and Reverse option to 
eliminate as many air moves as possible. 

To further improve the efficiency of this strategy, several of the tool tracks on the 

upper flat area can be deleted to take advantage of using a bigger Stepover for the 
Dia 10 mm flat area of the tool used. 
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1 From the Main menu, select Draw > Cursor > Tool to help with the 

visualisation for the next action. 

2 Select groups of 6 tool tracks leaving the single tool track outside each set as 
shown below: 

 

The Tool outline is displayed above to visualise suitable Stepover (Draw > 

Cursor > Tool). 

3 Right-click the toolpath and select Edit > Delete Selected Components to 

remove the selected tool tracks. 

4 From the Main menu select File > Save Project to update:- 

......\COURSEWORK\PowerMILL-Projects\PunchForm_3 

Surface Finishing - Example 2 
The direction of the curves on the selected surface dictates whether the tool tracks 

are aligned along or across the model dialog. 

1 Activate the Tip Radiused tool, D10t1 

2 Create a Surface Finishing strategy with the pocket sidewall surface selected  
and using a 1 mm Stepover as shown: 

 

Due to the natural direction based on along or across the surface, the tool tracks 

run up and down the sidewalls. 

This is not the correct choice as it is required for the tool to contour down the 
sidewalls. 
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3 Recycle the above Surface Finishing strategy and change the Pattern 

Direction option from U to V and then select Calculate. 

 

The toolpath now follows a direction, parallel to the base of the selected surface. 

Note that the tool tracks do not run parallel to the trimmed top edge of the 

sidewall surface. 

 A Spiral option is available on the Pattern page of the Surface Finishing 

strategy dialog. This can be applied for a continuous tool track down closed 

pocket or upstand areas. 

 

 

4 From the Main menu select File > Save Project to update:- 

......\COURSEWORK\PowerMILL-Projects\PunchForm_3 
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Geometric input of data values into a Strategy dialog 
 

Where applicable, the data input boxes on the PowerMILL dialogs can be filled 

automatically with values measured interactively on the model geometry. These are 
labelled in blue text which when selected will cause the Measure toolbar to 

appear. 

 

The Measure toolbar contains a range of geometric options enabling the user to 
dynamically trap the relevant dimensional values. 

 If the imported Project was created in versions earlier than PowerMILL 
2012, the dialogs for the existing entities will not support geometric input. 

5 In the main menu select File – Delete All and Tools – Reset Forms. 

6 Open the read-only Project:- 

        ......\PowerMILL_Data\Projects\TriSlot-Billet-Start 

 

7 Save Project As:- 

        ......\COURSEWORK\PowerMILL_Projects\TriSlotBillet-EX1 

The Project contains all the necessary toolpaths to fully machine the 

component apart from a 0.5 Axial Thickness remaining in the 3 Angled 
slots. 

This final operation will be applied using 3 separate Raster finishing 

strategies, each aligned parallel to the slot, sidewalls. 
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8 Select an ISO 1 view. 

9 Right mouse click on the NC Program 1 and from the local menu select 

Simulate from Start. 

10 Open the Block form and Calculate the Block as Defined by - Box and Type - 

Model. 

11 Run a full ViewMILL simulation on the NC Program 1. 

 

12 Save the ViewMILL model at this stage.  

13 Return to the PowerMILL (No Image) view  and disconnect ViewMILL 

from the simulation (Switch the Green Sphere to Red).  

14 Activate the BN10 tool. 

15 Select a View down Z and zoom into the area around the lower left slot. 
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16 Select the 3 surfaces in the slot defining the base and fillets. 

 

17 In the PowerMILL explorer right mouse click on Boundaries and from the 
local menu left mouse click Create Boundary - Selected Surface. 

 

18 Input the Name SlotA, input the Tolerance 0.01, Thickness 0 and un-tick 
Allow boundary to be private, before clicking on Apply. 

This Boundary SlotA (as shown in diagram at the top of the page) will be 

used to limit the final Raster Finishing strategy to the required area within 
the Slot.  

The Raster Finishing strategy will be arranged to run parallel with the slot 

the exact angle being obtained dynamically using the Geometric Input 

option. 

 

19 Select the 3 flat upper faces of the model to provide an accurate reference, on a 
fixed Z height for dynamically extracting Angular geometric values. 
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20 Use the keys, Ctrl K (Blank Except) to remove all but the selected surfaces from 
the view. 

 

21 Select a View down Z. 
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22 On the Main Toolbar, click  to display the Toolpath Strategies dialog. 

23 On the Strategy Selector, click the Finishing tab and select the Raster Finishing 

strategy. 

24 Enter data into the displayed pages of the form exactly as shown below. 

 

 

 

 

25 Select a Wireframe view for the displayed Model. 
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26 Select Preview to display the current Pattern for the Raster Strategy. 

 

27 Back on the Raster Finishing main page click on the blue text, Angle beside 
the associated input box (Top right of dialog). 

 

The Measure mode toolbar will appear. 

28 In the toolbar select the Minor Angle option.  

 

29 Use the cursor to locate the Key-point at the base of the angle and ‘snap’ with 

the left mouse key to define the 1st point of the Angle. 

 

30 Hover the cursor on the key-point again and drag the cursor to the right to 
pick up the horizontal angle, and ‘snap’ a 2nd point along this at a suitable 

distance. 

31 Move the cursor to a suitable position along the line running at an angle from 
the original key-point and ‘snap’ the 3rd point to obtain the required Angle 

value.  
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The Geometric Input value obtained dynamically is automatically inserted 

into the Angle input box. 

32 Calculate the Raster Finishing strategy and then Close the dialog. 

 

 The Measure - Mode Toolbar will close automatically when the toolpath 
starts to process. 

 

EXERCISE 

 

33 Create similar Selected Surface Boundaries (named SlotB and SlotC) and 

Raster Finishing strategies (named SlotB-FIN1 and SlotC-FIN1) for the 
other 2 Slots. 

 

34 Select File - Save Project to update:- 

......\COURSEWORK\PowerMILL_Projects\TriSlotBillet-EX1 
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Toolpath Z-Limits  
 

All Toolpath types, except drilling, can now be limited to applied maximum and 

minimum Z values within the defined Block.  

 

1 In the main menu select File – Delete All and Tools – Reset Forms. 

2 Open the read-only Project:- 

        ......\PowerMILL_Data\Projects\Zlimits-Start 

 

3 Save Project As:- 

        ......\COURSEWORK\Zlimits-EX1 

 

The Project already contains 7 Toolpaths, 5 of which have been put in a 
sub-folder named OP1. The 2 remaining Toolpaths require modification as 

they are both duplicating areas already included in other strategies. This will 

become evident during a ViewMILL simulation.  



4. Finishing Strategies PowerMILL 2013 

4 - 64  Copyright © Delcam plc  

4 Calculate a Block to the Model dimensions. 

5 Calculate the Rapid Move Heights using default settings. 

6 Run a ViewMILL simulation on the existing NC Program OP1.  

7 Once completed save the ViewMILL model at this stage.  

 

The angled face and lower recesses have yet to be finish machined. The 2 

remaining toolpaths both operate over the full extent of the Block. 

 

 

D20TR3-ConstZ-FIN1 needs to be localised to operate down the angled face 

to the top of the lower recesses.  

BN10-OptConstZ-FIN1 needs to be localised to operate inside the 2 lower 
recesses. 

This will easily be achieved for both toolpaths within the strategy dialog using 

the Z-Limits option. 
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8 Return to the PowerMILL (No Image) view  and disconnect from the 

simulation (Switch the Green Sphere to Red).   

9 In the PowerMILL explorer Right mouse click on the toolpath D20TR3-

ConstZ-FIN1 and from the local menu, select Activate followed by Settings to 
open the strategy dialog. 

 

 

10 Select the Recycle option followed by the Limit page and tick both the 

Maximum and Minimum boxes. 

11 For The Maximum select Pick the highest Z Value option.   

 

 

12 Snap the key-point (shown above) at the top corner of the angled face to 

collect and insert the value -11.82394. 

13 For The Minimum select Pick the lowest Z Value option.   
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14 Snap the key-point (shown above) on the top of the flat area to collect and 

insert the value -40. 

15 Back in the dialog select Calculate to re-process the updated Constant Z 

finishing strategy and then Close the dialog. 

16 In the PowerMILL explorer Right mouse click on the toolpath BN8-
OptConstZ-FIN1 and from the local menu, select Activate followed by 

Settings to open the strategy dialog. 

17 Select the Recycle option followed by the Limit page and this time tick just the 
Maximum box. 

 

18 Input the value -40.02 in the Maximum box. 

19 Back in the main form select Calculate to re-process the updated Optimised 

Constant Z finishing strategy and then Close the dialog. 
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20 Re-connect ViewMILL and continue the existing simulation with the 2 updated 

toolpaths;  D20tR3-ConstZ-FIN1 followed by BN8-OptConstZ-FIN1. 

 

The Component is now fully machined. 

21 Select File – Save Project to update:-     

 ......\COURSEWORK\PowerMILL_Projects\Zlimits-EX1 

 

Toolpath Processing Options  

Calculate 

When all the settings and values are input ready to create a toolpath, the Calculate 
button can be clicked  to start the toolpath calculation process. 

 

 You cannot use other PowerMILL options while the toolpaths are being 
calculated. 

Queue  

If the Queue option is applied the user can continue working in PowerMILL while 
the toolpath is processed in the background. Several strategies can be put in the 

queue to be calculated in the background, in sequential order.  

To Queue a toolpath for calculation, you can, either: 

� Click the Queue button in a strategy dialog, or,  

� Right-click on a toolpath and select Queue from the local menu. 
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 The ‘Calculator’ symbol changes to the ‘Queue’ symbol when the 
toolpath is queued.  

 Batch Process 

Once all data has been entered into a strategy dialog, click the OK button to save 

the settings and close as an un-processed toolpath.  

You can save one or more un-processed, machining strategies to be sequentially 

calculated at a later time. 

To Batch Process toolpaths, right-click a toolpath and select Batch Process. 

 

 

Toolpath Processing Queue 
The Toolpath - Queue option allows you to continue working in PowerMILL while 

the toolpath is being processed in the background. One or more strategies can be 
added to the Queue and they are calculated in the background, in sequential order.  

The following ‘start up’ Project contains two unprocessed toolpaths. The dialog for 
each one will be opened in turn, but Queue will be used instead of Calculate. This 

enables you to continue work on a new Corner finishing - Along strategy while 

the original toolpaths are processed in the background. 

1 Select File - Delete All and Tools - Reset Forms. 

2 Select File – Open Project: 

......\PowerMILL_Data\Projects\ToolpathProcessing-Start 
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3 Select File - Save Project As: 

......\COURSEWORK\PowerMILL-Projects\ToolQueue-ex1 

4 In the PowerMILL explorer, right-click the toolpath named D25t3-rgh and 

select Queue. 

5 Repeat this on the Toolpath named BN16-fin1 

 

6 While the original toolpaths are being processed in the background, Activate 

the tool BN6. 

7 Open the Corner Finishing strategy and set the Strategy to Along. Enter the 

other values exactly as shown below. 
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8 Select the Corner detection page and select the Reference tool as BN16 

 

9 Click Calculate to process the toolpath and then Close the dialog. 

 The latest Corner Finishing strategy starts processing immediately and 

is likely to be completed before the Steep and Shallow finishing strategy 
currently pending in the Queue. 

When a toolpath is added to the Queue, and is in an unprocessed status, the 
Calculator symbol on the Toolpath in the PowerMILL explorer changes to 

the Queue symbol . 

             

 

 

10 Select File - Save Project to update: 

......\COURSEWORK\PowerMILL-Projects\ToolQueue-ex1 
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If a tool is allowed to start machining directly at the start of a tool track, it first 
plunges down into the remaining stock, and then suddenly changes direction to run 

along the tool track. This is likely to result in machining marks, vibration, and 

excess wear on both the tool and machinery. 

To avoid sudden loading on the tool, appropriate Lead moves (at cutting feedrate) 

on and off tool tracks can be applied. 

Air moves (Link) between individual tool tracks can add significant amount of extra 
time to a machining operation. This can be greatly reduced by applying alternative, 

Link move options. 

 

Click  on the Main toolbar to display the Leads and Links dialog and options. 
You can also access the Leads and Links dialog from within a strategy dialog. Note 

that Leads and Links can be retrospectively applied to an existing toolpath. 

Z Heights 
Skim and Plunge distance - Provides variable control of rapid move heights within 
a component. These operate in conjunction with Safe Z and Start Z to minimise slow 

and unnecessary air moves while machining the component form. 

Skim distance – An incremental distance above the model where rapid feed moves 
occur from the end of one tool track to the start of the next. The tool traverses at a 

high feed rate across the model, clearing the highest point along its route by the 

Skim value. 

Plunge distance – An incremental distance above the local, component surface 

where a downward rapid movement of a tool changes to plunge feed move.  

5. Toolpath Leads & Links 
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Lead In/Lead out Moves 
Lead In controls the tool movement onto the start of a tool track and Lead Out 
controls the movement away from the end of a tool track.  

Available Lead In and Lead Out moves are:  

� None  

� Surface normal arc 

� Vertical Arc  

� Horizontal Arc  

� Horizontal Arc Left  

� Horizontal Arc Right  

� Extended Move  

� Boxed 

� Straight 

� Ramp  

� Pocket centre 

 

In the above illustration:- 

 - Lead In = Vertical Arc 

 - Lead Out = Vertical Arc 

 - Link move = Skim 

Toolpath colour codes: 

� Purple - Rapid Skim Feed Rate G1 

� Pale Blue - Plunging Feed Rate G1 

� Green/Orange - Cutting Feed Rate G1 

� Dotted Red - Full Rapid G0 

 

Leads and Links are effectively extensions to tool tracks and must be gouge 
protected. Gouge check is set as default and any Lead that would result in a 

gouge is not created. 

On tooltracks where the 1st Choice cannot be applied, then the 2nd Choice is 
used. If it is not possible to apply either then the Lead options are applied as None. 

The current Leads and Links settings are automatically applied when creating new 

machining strategies.  
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Example 
The following example illustrates the retrospective addition of suitable Leads and 

Links to finishing toolpaths. The project contains one Roughing toolpath and three 

Finishing toolpaths. 

1 Select File - Delete All and Tools - Reset Forms.  

2 Select File - Open Project:           

     ...\PowerMILL_Data\Projects\LeadsLinks-Start 

 

3 Select File - Save Project As: 

......\COURSEWORK\PowerMILL-Projects\LeadsLinks-example 

4 Select an ISO2 view. 

 

5 Activate the toolpath, BN6-fin1. 
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Vertical Arc Leads 
Vertical Arc - Leads create a circular movement downward at the start and 

upward at the end of each individual tool track. By default, with the Gouge check 

option selected, the additional moves are not made if a gouge might occur. 

 

 

 - Toolpath segment 

 - Radius 

 - Lead 

 - Tangent angle 

1 On the Main toolbar, click  to open the Leads and Links dialog. 

2 On the Leads and Links dialog, select the Lead In tab and:  

 

a Select Vertical Arc from the 1st Choice list.  

b Enter an Angle of 90.0 and a Radius of 6.0 

c Click Apply. 

There is now a Vertical Arc leading onto most of the tool tracks.  

 

 The new (gouge protected) Vertical leads have not been created on the tool 
tracks that stop close to a raised area of the model. 
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3 Click the Copy to Lead Out button. 

 

4 Click Apply to update the active toolpath. 

 

Where gouge free, a Lead Out move is applied at the end of each tool track. 

 

5 Select Vertical Arc from the 2nd Choice list.  

a Enter an Angle of 90.0 and a reduced value Radius of 4.0. 

b As before, click the Copy to Lead Out button. 

c  Click Apply. 

 

Wherever it is gouge free on the above toolpath a 1st Choice of Lead In/Out 

with a Vertical Arc is applied.  
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If this is not possible without a gouge occurring, then the 2nd Choice of a Radius 

4, Vertical Arc is attempted. 

If neither the 1st or 2nd Choice is possible without a gouge occurring, then no 
Lead In/Out is applied to that part of the toolpath. 

Horizontal Arc Leads 
This produces circular leads on the horizontal plane, and the Radius and Angle value 

is similar to that for the Vertical Arc. This type of lead is frequently used for 
toolpaths running at constant Z, or with only small changes in Z height. 

 

 Toolpath segment 

 Radius 

 Lead 

 Tangent angle 

1 From the Main menu, select Tools - Reset Forms to return the Leads and Links 

settings to default. 

2 In the PowerMILL explorer, right-click the BN6-fin2 toolpath and select 
Activate. 

3 Select an ISO1 View. 

4 Click  on the Main toolbar to open the Leads and Links dialog. 

 

5 Select the Lead In tab, and change 1st Choice to Horizontal Arc with an 

Angle of 45 and a Radius of  3.0  

6 Click Copy to Lead Out and then Apply. 
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 There is no need to utilise the 2nd choice options as the 1st Choice of 
Horizontal Arc - Leads In/Out have appeared on all the tool tracks.  

 

7 In the existing 1st Choice - Lead In page input a value of 5 for the Distance 

and select Apply. 

 

 An additional (Distance) extension move is inserted before the start of the 
tool track and after the original Lead in - Vertical Arc. 
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Extensions 
Extensions are additional lead options that are applied outside the existing Lead 

In/Out moves.  

1 Select an ISO2 view. 

2 In the Leads and Links dialog, select the Extensions tab and for both the 

Inward and Outward options, enter a Vertical Arc with Angle 90.0 and 

Radius 5.0 

 

3 Click Apply. 

 

A Vertical Arc - Extension is added to all of the Lead In/Out moves. 

 

Links 
A Link move is the movement of the tool from the end of a tool track to the start of 
the next. For efficient tool moves across the model, you can reduce the height of 

the link moves to be closer to the local model form. 

� Short/Long threshold - This defines the distance limit up to which the Short -

Links apply. Any move from the end of a tool track to the start of the next, 

which exceeds this distance is defined by the Long - Link move. 

� For Short links, the available options include Safe Z, Incremental, Skim, On 

Surface, Stepdown, Straight, and Circular Arc. 

� For Long links, the available options include Safe Z, Incremental, and Skim. 

� For Default (first and last) links the available options include Safe Z, 

Incremental, and Skim. 

� Arc fit rapid moves can be applied, if compatible with a machine control 
system.  
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1 From the Main menu, select Tools - Reset Forms to reset the Leads and Links 

settings to the factory defaults. 

2 Activate the toolpath bn6-fin1. 

3 Select an ISO 2 view. 

4 Click  and open the Leads and Links dialog. 

5 Select the Z Heights tab to access the Skim and Plunge distance options. 

 

� Skim Distance - is the incremental height at which the tool clears the 

highest point on the model between tool tracks. 

� Plunge Distance - is the Incremental height above the model at which the 
tool rapids down to before using the Plunge Feed Rate. 

6 Select the Links tab. 

 

a Enter the Short/Long threshold as 3 

b Link move distances less than this value will use the Short options and those 

greater will use the Long options. 

c Select Short as Circular and Long and Default as Skim. 

7 Click Apply. 
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 The distance between the ends of adjacent tool tracks is greater than the 
Short/Long threshold value in several areas of the toolpath (In these 

instances Skim moves apply). 

8 Change the Short/Long threshold to 5 

9 Click Apply. 

 

 By increasing the value of the Short/Long threshold, the number of 
occurances of Short Link - Circular Arcs has increased. 

The remaining Link moves would benefit from Vertical Arc - Lead In/Out 

moves, but not on the existing Circular Arc Links.  

 

10 Apply a Vertical Arc to both Lead In and Lead Out as shown: 
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 The Vertical Arc - Leads are also added to the Circular Arc - Short link 
moves. This can be prevented by un-ticking the Add leads to short links 

option. 

11 Un-tick the Add leads to short links option. 

 

 

12 Click Apply.  

 

The Lead moves exist on the Long links but not on the Short links. 

 

 

Applying Leads and Links locally to individual tool tracks 
13 Use the left mouse key to select one of the individual link moves where the 

Lead is currently a Vertical Arc. 

14 In the Leads and Links dialog, select the Lead In tab and select 1st Choice as 

Extended Move with Distance 10. 

15 Select the Copy to Lead Out tab. 

16 Click Apply. 

17 The selected Vertical Arc lead move is changed to an Extended move. 
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18 Select File - Save Project to update: 

......\COURSEWORK\PowerMILL-Projects\LeadsLinks-example 

Additional Short Links options 
In addition to Safe, Incremental, and Skim, the following options are also 
available in the Short link section. These additions are not available in the Long 

link options. 

� On Surface - This links the tool tracks with a gouge free, direct move that 
follows the surface form. 

� Stepdown - The link move remains at a constant height and performs a gouge-

checked move to the start of the next tool track, where it then feeds down onto 
the surface. 

� Straight - In this case, the link is a gouge-checked, direct linear move to the 
start of the next tool track. 

� Circular Arc - This links the tool tracks with a gouge-free circular move that 

follows the surface form. 

Exercise 
1 Activate the BN6-fin3 toolpath and Apply the Leads and Links as follows: 

a Links: Long/Short/Default – Skim. 

b Lead In: 1st Choice - Ramp - Options - Max Zig Angle 4, Follow 

Toolpath, and Height 1 

c Lead Out: 1st Choice - Vertical Arc - Angle 90 - Radius 3  

 

The Links have been visually removed to enable a better view of the Leads. 
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2 In the Leads and Links dialog select the Lead in page and input 0.5 in the box 

named Overlap distance (tool diameter units). 

3 Apply the Leads and Links dialog. 

 

Overlap Distance causes the cutter to continue beyond the natural end point along 
the original toolpath by a specified distance based on the Tool Diameter (TDU). In 

this case the distance is 3mm (0.5 TDU). 

 

Arc Fitting Rapid Moves 

Leads and Links 
Arc Fitting works on all Rapid Moves including Skim moves. This option is ideal 
for applications where you want to avoid sharp changes in direction; for example, 

High Speed Machining.  

Note; not all machine tool controllers will support this option. 

 

  

 

� The Arc Fit Rapid Moves option is located in the Links dialog. 

� The Arc fit rapid moves box must be ticked. 

� The Arc radius is defined as a proportion of the active, Tool Diameter (TDU). 
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A Boundary consists of one or more closed wireframe segments. Boundaries are 

mainly used to limit machining strategies to specific areas of the component.  

Earlier in the course, Boundaries were utilised to limit machining strategies, so 
that they occur in more compatible areas of the component.  

For example, Constant Z finishing is more effective on steep sidewalls and Raster 

finishing on shallow areas. 

There are several options available for creating boundaries. Most involve interaction 
with other PowerMILL entities (eg Tools, Thickness, Stock Model, etc), while 

User Defined will access a separate dialog for direct input of exisiting geometric, 

entities. 

 

Switch off the Private Boundaries creation option 
1 From the main pulldown menus select Tools – Options and in the dialog select 
Boundaries – Private boundaries. 

 

2 Un-tick the box named Allow new boundaries to be private. 

3 Select Accept to close the Options dialog. 

6. Boundaries 



6. Boundaries PowerMILL 2013 

6 - 2  Copyright © Delcam plc 

User Defined Boundary 
To access the User Defined – Boundary options, go to the PowerMILL explorer, 

and select Boundaries > Create Boundary > User Defined. 

This will access a separate sub-menu in which the range of options, generally 
involve direct input of existing wireframe entities. 

 

 

 Insert File - Opens the browser to locate an externally stored geometry file. 

The Boundary, Pattern, and Toolpath buttons are disabled unless a compatible 

entity is selected in the adjacent input box. 

 Model - Inserts the edge of the selected model. 

 Sketch - Opens the Curve Editor mode toolbar. 

 Curve Modelling - Opens the composite curve generator. 

 Wireframe Modelling - Provides access to the PowerSHAPE wireframe 
module.  

 

4  From the Main menu, select File - Delete All. 

5 Select File - Save Project As: 

......\COURSEWORK\PowerMILL_Projects\BoundaryBasics 

 

6  Select File - Import Model... 

......\PowerMILL_Data\Models\cowling 
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7 Select the surfaces defining the central pocket and fillet. 

 

 

8 In the PowerMILL explorer, right-click Boundaries and select Create - User 

Defined.  

9 In the User Defined Boundary dialog, click the Model button. 

 

A Boundary segment is created around the edge of the selected part of the 
model. 

 

10 Select a View from top (Z) and switch off the shaded view but retain the 

wireframe view. 
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11 In the PowerMILL explorer, right-click Boundaries and select Create 
Boundary - User Defined. 

12 In the User Defined Boundary dialog, click the Sketch button  
to open the Curve Editor mode toolbar. 

 

13 On the Curve Editor mode toolbar, click the following button  to open the 
Options dialog. 

14 Un-tick Intelligent Cursor - Snapping Options  to switch off the 

Intelligent Cursor  enabling ‘free form’ sketching. 

 

15 Click Accept to keep the changes. 

16 From the Curve Editor toolbar, select Create a Bezier curve .  

17 Using the left mouse key, click points within the model to create a sketched 

Boundary.  
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 If required, use Undo  to sequentially remove any invalid points. 

 While the Intelligent cursor is switched off do not attempt to close the 

segment by trying to snap the ‘final span’ back on to the start point.  

18 On the Curve Editor toolbar, click  to open the Options dialog. 

19 Select Intelligent Cursor - Snapping Options and tick - Use Intelligent 
Cursor.  

20 Then snap the final span of the Bezier Curve onto the original start point. 

21 On the Curve Editor toolbar, click  to accept the changes and close the 
session. 

22 If the Boundary segment is not smooth enough, right mouse click on it and 
from the local menu, select Edit - Spline Selected to open the Spline fitting 

tolerance dialog. 

 

23 Enter the value 2 and click  to apply and close the dialog. 

 

The Boundary segment is splined through the polyline points as a curve 

maintaining the original form to within a maximum deviation of 2. 

In instances where the required deviation would be greater than 2, a tangency 

will remain either side of the affected points. 
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Selected Surface Boundary 
A Selected Surface Boundary defines one or more segments around where the 

active tool would fully machine the selected surfaces. The segments represent the 

tip positon of the active tool. 

1 Create a Block - Defined by Box using Type - Model. 

2 Create a Ball Nosed tool of Diameter 16 with the Name BN16. 

3 Select the surfaces defining the central pocket, including the fillet. 

 

4 In the PowerMILL explorer, right-click Boundaries and select Create 
Boundary - Selected Surface. 

 

5 Using the above settings, click Apply to create a single segment, Selected 

Surface Boundary. 
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Shallow Boundary 
A Shallow Boundary defines one or more segments where the model drops 

through a specified Upper Angle downwards from the horizontal plane. It is 

designed to differentiate steep and shallow areas where Constant Z and Pattern 
strategies are more effective.  The boundary is calculated relative to the active tool 

parameters.   

1 In the PowerMILL explorer, right-click Boundaries and using the default 
settings, Create Boundary - Shallow. 

 

 - Typical area more suited to a Pattern strategy (above 35 degrees). 

 - Typical area more suited to a Constant Z strategy (below 35 degrees). 

2 Using the above settings, click Apply to create the above Boundary segments. 

 

Silhouette Boundary 
A Silhouette Boundary defines the outline around the maximum dimensions 
selected model, offset by the tool radius. 

1 Select the following surfaces on the model: 

 

 Use the Shift key on your keyboard to select multiple surfaces. 
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2 Right-click the Model and select Edit - Delete Selected Components. 

3 With the selected areas now deleted, in the PowerMILL explorer, right-click 

Boundaries and select Create Boundary - Silhouette. 

 

Rest Boundary 
A Rest Boundary defines the area inaccessible to a specified reference tool. It also 

requires a smaller active tool to be specified otherwise it will not generate 
segments. 

1 Create a Ball Nosed tool of Diameter 8 with the Name BN8. 

2 In the PowerMILL explorer, right-click Models and select Delete All to 
remove the incomplete component. 

3 Import the original Model back into the Project:     

......\PowerMILL_Data\Models\cowling  
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4 In the PowerMILL explorer, right-click Boundaries and select Create 

Boundary - Rest to open the Rest Boundary dialog. 

 

5 Input Expand Area - 0, select Tool - BN8, and Reference Tool - BN16.  

6 Ensure that Limit is set with tool centre to block edge.  

7 Click Apply to create the following Rest Boundary. 

8 Click Accept to close the dialog. 

9 Save the Project to update:- 

......\COURSEWORK\PowerMILL_Projects\BoundaryBasics 

 

10 Select a View down the Z Axis  and Un-draw the model.  

 

The above Boundary identifies areas on the component that are inaccessible to 
the BN16 tool geometry to be locally machined with the BN8 tool. 

On closer inspection, the central pocket area would be more effectively 

machined with a flat bottomed tool and a smoother, more continuous toolpath, 
can be created if the 2 spurs were removed from the outer segment to be 

machined later as a separate toolpath. 
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Editing Boundaries 
It is often necessary to edit the original geometry defined by Boundary segments. 
The best way to achieve this in PowerMILL is via the dedicated Curve Editor tool.  
As it is not exclusive to Boundaries, a more detailed range of Curve Editor, 
options and applications are covered in Chapter 11. 

1 In the PowerMILL explorer, right-click the Rest Boundary (6) entity and in 

the local menu select Edit - Copy Boundary to create a copy named (6_1). 

2 In the PowerMILL explorer, right-click the original Rest Boundary (6) and 

Rename it as Master. 

3 Rename the new copy of the Rest Boundary (6_1) as Rest. 

4 In the PowerMILL explorer, click the light bulb adjacent to Master to stop it 

from being displayed in the graphics area. 

5 Select the 2 inner segments on the Rest boundary (Rest) by dragging a box 
around, and then press the Delete key on your keyboard to delete them. 

 

The next stage is to remove the two spurs, which will be carried out after an 

explanation of the Boundary Editor dialog. 

 

Boundary – Access to the Curve Editor 
Once created, you can modify a Boundary segment using the options available on 

the Boundary Toolbar.  

 

Click  on the Boundary toolbar to activate the Curve Editor toolbar.  

 

 You can also double-click a boundary segment to activate the Curve 
Editor Toolbar. 
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Curve Point - editing 

The Point editing options  can only be applied to Continuous Line 

(Polygonised) segments. 

 

1 In the PowerMILL explorer, right-click Boundaries and from the local menu 
select Toolbar. 

2 On the Boundary toolbar, click the Curve Editor button  to display the 
Curve Editor toolbar. 

3 Select the outer boundary segment in the graphics area. 

 

The points are displayed on the selected boundary segment. 

 

4 Zoom into the area of the selected segment and select all the points that define 
the spur. 

 

 To select multiple points, hold down the Shift key while selecting the 

points with the mouse.  

5 On the Curve Editor toolbar, click Delete points  to remove the spur 
from the segment. 

6 Repeat the procedure on the other spur. 
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 Ensure that all segments are either selected or not selected before leaving 
the editor (If some segments are selected then it will result in the remainder 
being discarded when exiting the editor). 

7 Click , to accept changes and exit the Curve Editor.  

Other boundary editing options 
Right-click on a Boundary in the graphics area or in the PowerMILL explorer and 
from the local menu, select Edit to view other boundary editing options. 
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Edit > Spline Selected 

1 In the graphics window, select the outer segment of the boundary Rest. 

2 In the PowerMILL explorer, right-click the Boundary Rest and select Edit > 
Spline Selected. 

3 In the Spline fitting tolerance dialog, enter 0.1 and click  to apply. 

4 Re-select the outer segment to view the effect of the Spline. 

                                  

 

The selected segment is now Splined (Curve fitted and the points re-distributed 

within the specified tolerance value) to produce a smoother form with unnecessary 

points removed. This improves the quality of subsequent operations such as 
offsetting of the boundary. 

Edit > Transform 

1 In the PowerMILL explorer, right-click on the boundary Rest and from the 
local menu, select Curve Editor. 

2 In the Curve Editor toolbar select the Offset option  

 

3 In the Offset toolbar, select the 3D Smooth button, input a Distance of 1 and 
then press the Return key. 

 

4 Click  in the Curve Editor toolbar, to accept the changes and exit.  
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5 In the PowerMILL explorer, click the light bulb next to the copy of the original 

boundary Master created earlier. The original boundary is displayed alongside 

the edited boundary, Rest illustrating the effect of the 1mm 3D Offset. 

 

6 Activate the BN8 tool and Boundary named Rest. 

7 On the Main toolbar, click  to display the Strategy Selector. 

8 From the Finishing tab, select the 3D Offset Finishing strategy. 

9 In the 3D Offset Finishing strategy dialog, enter data as below. 

 

10 Click Calculate to process the toolpath and then Close to exit the dialog.   
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11 Undraw the BN8-RestFin toolpath and boundary Rest by switching off the 

respective light bulb symbols in the PowerMILL explorer. 

12 Switch on the respective light bulb to display the boundary named Master. 

13 In the graphics area, select the outer segment of the displayed Boundary 

named Master.  

14 In the PowerMILL explorer, right-click the boundary Master and select Edit - 

Copy Boundary (selected only) to create a new boundary Master_1 
consisting of the outer segment only. 

15 Rename the boundary Master_1 as Spur1. 

16 Select a view from top Z. 

17 In the PowerMILL explorer, turn off the light bulb adjacent to the boundary 

Master to remove it from view. 

        

18 In the PowerMILL explorer, right-click the boundary Spur1 and select 
Activate. 

19 In the graphics area, double-click the boundary segment to activate the Curve 

Editor toolbar. 

20 Select all points along the boundary segment except those which define the 

rectangular part of the upper spur. 

 Use the Shift key on your keyboard to select multiple points on the 

boundary segment.  

 Use the CTRL key on your keyboard to deselect one or more of the 

selected points on the boundary segment. 
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 If you want, you can select the points in stages. This gives you better control 
when viewing selected points. 

21 On the Curve Editor toolbar: 

a Click the Delete Points button  to delete all the selected 

points. 

b Click the Join Close button  to close the open rectangular segment. 

c Press Shift on your keyboard and select the points at the base of the 
rectangular segment. 

d On the status bar below the graphics area, click the Relative Move button 

 and enter 0 -2 in the data box and press Enter on your keyboard. 

 

The selected points are moved by a distance of Y-2. 

 

22 Click  to exit the Curve Editor toolbar. 

23 Click the light bulbs on to display both Boundaries Rest and Spur1, and then 

Resize the View . 
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24 In the graphics area, double-click the Boundary Spur1 to activate the Curve 
Editor toolbar. 

25 Form the Curve editor toolbar, select Transformations - Mirror option .  

26 On the Mirror toolbar select Origin at the active workplane.   

27 Ensure that the Keep Original option is set.   

 

28 From the Mirror toolbar, click the Mirror in ZX button . 

29 Click   on the Mirror toolbar to accept and close. 

30 On the Boundary Transform toolbar, click  to accept and exit the toolbar. 

 

The boundary named Spur1 now contains 2 segments. 

 

1 Make sure that the tool BN8 and boundary Spur1 are both Active. 

2 From the Strategy Selector, Finishing tab, select the Raster Finishing 

strategy and enter data as shown: 
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3 Click Calculate to process the toolpath, and then Close the dialog. 

 

The machining strategies are localised and the tool track shape controlled with 

the help of edited Boundaries originating from a single Rest Boundary. 
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4 Save the Project to update:- 

......\COURSEWORK\PowerMILL_Projects\BoundaryBasics 

 

 

 

 

 

 

Creating Blanking Surfaces using 
Boundaries 

Blanking surfaces are used to cap holes and pockets in a model to prevent the tool 
from machining into those areas. You can create three types of planes in 

PowerMILL. 

� Block – creates a plane, at a specific Z Height, after the material block is 
defined. 

� Best Fit – creates two planes, one touching the boundary at its highest point, 
and the other through its lowest point. The planes are parallel to the best fit 
plane (the plane that has the smallest maximum distance from the boundary). 

� Projected – creates a plane parallel to the XY axis of the active workplane. The 

plane will have the Z Height of the highest point of the boundary. 

Example 
1 Select File - Delete All and Tools - Reset Forms. 
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2 Import the Model: 

......\PowerMILL_Data\Models\pockets.dgk 

 

3 Calculate the Block defined by Box to the Model Min/Max limits. 

4 Select the top surface of the model (shown shaded).  

5 In the PowerMILL explorer, right mouse click on Boundaries and from the 

local menu select Create Boundary – User Defined. 

 

6 Click the Model icon and then select Accept to close the dialog. 

7 Un-draw the model to enable a clear view of the boundary. 

The Boundary produced has 4 segments. For this example, only the two 
smallest segments are required. 

8 Select the two highlighted segments by dragging the cursor over them. 

               

9 In the PowerMILL explorer, right-click Models and from the local menu select 

Create Plane - Projected. 



PowerMILL 2013 6. Boundaries 

Copyright © Delcam plc  6 - 21 

10 Planer Surfaces have been created inside the boundary segments. 

                

 No need to Save the Project this time! 

11 Select File - Delete All and Tools - Reset Forms. 

Exercise 
Import the Model …\PowerMILL_Data\Models\bucket.dgk and generate 4 

surface planes to cover the foot recesses on the upper base surface. 

                            

Private Boundaries 
All Boundary types will (by default) be created as private. This makes the 

Boundary exclusively owned by an individual machining strategy. If the 

parameters or entities used in the strategy are modified, then the associated 
private boundary will automatically adjust on calculation. 

Private Boundaries are of particular use in Templates as they will automatically 

regenerate when the host toolpath is calculated on a new model. 

A private boundary is not suitable in cases where the segments will need to be 

deleted or geometrically edited once assigned to the host strategy. It is however 
possible to create a copy on which you can switch off the Allow boundary to be 

private option. 

It is possible to prevent boundaries from originally being created as private:- 

From the main pull down menus select Tools – Options – Boundaries - Private 

Boundaries, and un-tick Allow new boundaries to be private. 
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Private Boundaries – Example:- 
1 Select File - Delete All and Tools - Reset Forms. 

2 Open the (readonly) Project:- 

......\PowerMILL_Data\Projects\PrivateBoundaries_Start 

 

3 Save Project As:- 

......\COURSEWORK\PowerMILL_Projects\PrivateBoundaries-EX1 

The Project includes a Constant Z and a 3DOffset finishing toolpaths both of 

which currently apply over the whole of the Block area. To localise the 2 finishing 
toolpaths to areas of the model where they are most effective both strategies will be 
recycled to include a Shallow – private boundary. 

4 From the main pulldown menus select Tools - Options - Boundaries - Private 

boundaries:- 

 

5 Tick the box named Allow new boundaries to be private. 

6 Select Accept to close the Options dialog. 

7 Activate the toolpath, BN10-CZ-SEM1. 

8 From the toolpath, Bn10-CZ-SEM1 local menu select settings, followed by the 
Recycle option. 

9 In the Constant Z dialog select the Limit page. 
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10 From the Boundary pull down options select Create a shallow boundary. 

 

11 Using the default settings Apply the Shallow Boundary dialog. 

 

Initially the new Boundary 1 will exist in the PowerMILL explorer until the 

toolpath is calculated. At that point it will disappear (become invisible) from the 
Boundary folder. However, the folder name, Boundary will still be displayed in 

bold text to identify the existence of the hidden private Boundary 1. 

 



6. Boundaries PowerMILL 2013 

6 - 24  Copyright © Delcam plc 

 The private Boundary will be displayed in the PowerMILL explorer if 
the above option is ticked in the local Boundaries menu. 

12 Select the Limit page and set Trimming to Keep outside. 

 

13 Calculate (but do not Close) the Constant Z Finishing strategy. 

 

The Constant Z strategy BN10-CZ-SEM1 is now limited to be outside the 

segments of private Boundary 1. 

 

14 Select the ‘create a copy’ option   in the Constant Z Finishing dialog. 
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15 Edit the Toolpath Name to BN10-CZ-FIN1, input Tolerance 0.01, Thickness 

0, and Minimum stepdown 0.3 

16 Calculate the new toolpath and Close the dialog. 

 

 

17 A new private Boundary will automatically, be created with the same 

parameters (Tolerance, Thickness, etc) as used in the main page of the 

Constant Z Finishing dialog.  
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18 In the PowerMILL explorer, right mouse click on Boundaries and from the 

local menu select Create Boundary > Shallow. 

 

 

19 Using the above default settings Apply the dialog to create a new, (un-
assigned) private Boundary. 

 

Initially this new private Boundary will be displayed in the PowerMILL 

explorer but will become hidden once it has been applied in a new toolpath 
calculation. 
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Exercise 
20 In the PowerMILL explorer, Activate the toolpath and then select Settings to 

open the dialog. 

21 Recycle with the new private Boundary 2, Active and with Trimming set to 

Keep inside. 

 

22 Make a Copy of the above toolpath with the new Name BN10-3Doff-FIN1 and 
with Tolerance 0.01, Thickness 0 and Stepover 0.3  

 

23 From the main pulldown menus select Tools – Options and in the dialog select 
Boundaries – Private boundaries. 

24 Tick the box named Display private boundaries in the explorer. 

 

 

 

 This demonstrates that if a toolpath containing a Private Boundary is 
copied then the new one will contain a separate Private Boundary.  
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Levels and Sets allow you to control the selection and display of model 
components in the PowerMILL graphics area. 

You can Acquire components from the currently imported Model to a Level or Set. 

Once acquired to a Level or Set, you can select, de-select, display, or hide Model 
components from the individual Level or Set context menus. 

The subtle differences between Levels and Sets are illustrated using the following 
examples. 

Creating Levels 
1 From the Main menu, select File > Delete All and Tools > Reset Forms. 

2 Select File > Import Model: 

......\PowerMILL_Data\Models\CowlingWithClamps.dgk 

 

The imported Model includes clamps, which: 

� must be avoided by all machining strategies created in the Project.  

� are not included during the calculation of the Block. 

To make the model, component selection easier, a new Level named Clamps is 
created and all clamp surfaces are assigned to it. Another Level, named Splits is 

created and all 6 split surfaces are assigned to it. 

� Create a Dia 16 tool with a 3 Tip Radius named D16tr3. 

� In the PowerMILL explorer, right-click Levels and Sets and select Create 

Level. 

7. Levels and Sets 
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3 Rename the new Level as Clamps. 

 

4 Create another new Level and Rename it as Splits. 

 

All model components are currently acquired to the default General Level. 

If the original CAD model has components already assigned to different Levels, 
then these will be recreated when the model is imported into the PowerMILL 

project. 

Acquiring model entities to a Level 
5 In the PowerMILL explorer, click on the bulb to switch off the Level named 

Clamps. 

 Any items acquired to this level will no longer be displayed. 

6 In the graphics area, hold down the left mouse and Shift keys while selecting 

the surfaces that define the clamps. 

 

7 In the PowerMILL explorer, right-click on the level named Clamps and select 

Acquire Selected Model Geometry.  

The clamps disappear from the view (The Level is switched off). 
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8 Select the 6 Surfaces defining the split face and Acquire them to the level 

named Splits.  

9 Switch off the level named Splits to visually check that the correct surfaces 
have been acquired. 

 

10 Switch on all levels (The clamps and split surfaces reappear).  

 

Now, create a Selected Surface Boundary to protect the clamps from being 

machined. 

1 In the PowerMILL explorer, right-click the Level, General and choose Select 
Surfaces. The main component surfaces excluding the split faces are selected. 

2 While still in the PowerMILL explorer, right-click the Splits level and choose 

Select Surfaces. The split face surfaces are added to the current selection. 

3 Calculate a Block using the default Box and Model options. 

4 Use the default Rapid Move Heights and Start and End Point options. 
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The Block is created to the dimensions of the selected surfaces. 

5 Left mouse click in the graphics area away from the model to deselect all 
entities. 

6 In the PowerMILL explorer, click on the Level, General, and with the Ctrl 

key held down, click on the Splits level. 

Both the selected levels will be highlighted in the PowerMILL explorer. 

 

7 Right-click on one of the highlighted levels and choose Select Surfaces. All 

surfaces excluding the clamps are selected. 

8 Apply a Selected Surface Boundary with Radial Thickness 2, Limit set to 
Block Edge, with Allow boundary to be private un-ticked. 
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9 Manually select the surfaces defining the central pocket, including the fillet. 

                      

10 Right-click the existing Boundary (1) and from the local menu, select Insert > 
Model to add a new segment. 

   

11 Check that both the Tool and Boundary are Active so that they will be 
automatically included when a new machining strategy is created. 

12 From the Strategy Selector select the Finishing tab and in the dialog select, 

Raster Finishing.  

13 In the Raster Finishing dialog, enter data exactly as shown in the following 

illustration. 
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14 Click Calculate to process the toolpath and then Close the dialog. 

 

The Radial Thickness of 2 used in the outer boundary segment provides suitable 

clearance around the clamps. 

 

 



PowerMILL 2013 7. Levels and Sets 

Copyright © Delcam plc  7 - 7 

Switching Off a Level 
1 In the PowerMILL explorer, switch off the light bulbs on both the General and 

Splits levels. 

 

Only the Clamp Surfaces are displayed in the graphics area. 

2 Right-click the toolpath and select Settings to re-open the dialog. 

3 Select create a Copy and click Calculate to process a new toolpath. 

4 Close the Raster Finishing dialog. 

 

 Even if a level is switched off, PowerMILL will still create a toolpath over 
all (including un-displayed) parts of the model. 
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Sets 
A Model entity will always exist on a Level but not on more than one at the same 

time. You cannot delete a Level while Model entities are acquired to it. 

A Model entity can co-exist on more than one Set at the same time. You can delete 
a Set while Model entities are acquired to it. 

 

1 From the Main menu, click File > Delete All and Tools Reset Forms. 

2 From the Main pulldown menus File > Import Model and select: 

......\PowerMILL_Data\Models\YogurtTray.dgk 

 

3 Create a Set and rename it as AllPkts-Set. 

 

4 Manually select all surfaces defining the 9 pockets. 

 

5 With the 9 pockets still selected, right-click AllPkts-Set and select Acquire 
Selected Model Geometry. 

6 Manually select all surfaces defining the bottom left pocket. 
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The selected surfaces will soon be acquired to two Sets simultaneously. 

7 Create a new Set and rename it as Pkt1-Set. 

8 Right-click Pkt1-Set and select Acquire Selected Model Geometry. 

9 Switch off both the level General and the Set Pkt1-Set. 

10 Switch on AllPkts-Set. 

 

All surfaces currently acquired to AllPkts-Set are displayed, including those 
that exist on the visually ‘switched off’ Set. 

11 Switch off the Set AllPkts-Set and then switch on the Set Pkt1-Set. 

 

All surfaces acquired to Pkt1-Set are displayed. These are also displayed when the 

AllPkts-Set is switched on and Pkt1-Set is switched off. This illustrates that model 
entities can be acquired to more than one Set at the same time. 

1 Switch off Pkt1-Set and then switch on AllPkts-Set. 

2 Right-click AllPkts-Set and from the local menu click Select Surfaces. 

3 Create a new Level and rename it as AllPkts-Lev. 

4 In the PowerMILL explorer, right-click Level AllPkts-Lev and select Acquire 

Selected Model Geometry. 

5 Switch off all Levels and Sets except AllPkts-Lev. 

 

All surfaces acquired to AllPkts-Lev are displayed. 
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6 Create a new Level, rename it as Pkt1-Lev, and then switch it off. 

7 Manually select all surfaces defining the bottom left pocket. 

 

8 In the PowerMILL explorer, right-click Pkt1-Lev and from the pop-up menu 

select Acquire Selected Model Geometry. 

 

All surfaces defining the bottom left pocket disappear from the view on being 
acquired to the (switched off) level Pkt1-Lev. This illustrates that unlike Sets, it is 

not possible for model entities to exist in more than one Level at any one time. 

Switch on the level Pkt1-Lev and the bottom left pocket surfaces are displayed 
again. 

 When using a combination of Levels and Sets it is good practice to keep 
the Sets visually switched off. If you want to select items from a 

particular Set, then, right-click on it and use one of the Select options 
from the context menu. 

 This prevents confusion if you switch a Level off only to find the included 
items are still visible due to a Set containing the same items being 

switched on. 
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Edit > Transform 
The Transform option allows you to Move, Rotate, and Mirror toolpaths relative 

to an active workplane. 

To access the options right-click on a toolpath and select Edit > Transform. 

 

� Transform > Move - The Move function allows a selected toolpath to be 

moved by a user-defined Distance along a selected axis. 

 

� Transform > Rotate - The Rotate function allows the rotation of a selected 

toolpath by a user-defined Angle around a selected X, Y, or Z axis. 

 

� Transform > Mirror - This provides 3 options to Mirror a selected toolpath 

across the XY, XZ, or YZ planes. When a toolpath is mirrored, PowerMILL 
identifies the gouge status to be unknown, so it is advisable to check for gouges.  

 It is important to note that when a toolpath is mirrored, the cutting 
direction effectively becomes reversed. 

 

In the following example a single toolpath is created and then the Transform > 

Move option applied to copy toolpaths into the remaining cavities.  

1 Select File - Delete All and Tools - Reset Forms. 

2 Select File > Open Project:- 

         ......\PowerMILL_Data\Projects\EditToolpaths_1 

8. Editing Toolpaths 
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The Project contains a multi-cavity die and a Dia 10 Ball Nosed tool. 

A toolpath will be created in the lower left cavity that is limited to be inside a 

Selected Surface Boundary. 

3 Save Project As: 

          ......\COURSEWORK\PowerMILL-Projects\Transform 

4 Create a Block using Defined by > Box and Type > Model. 

5 Reset the Rapid Move Heights. 

6 Select all of the surfaces (including the fillet) that define the bottom left pocket. 

 

                         

7 In the PowerMILL explorer, right-click Boundaries and select Create 

Boundary > Selected Surfaces. 

 

8 In the Selected Surface Boundary dialog, tick Roll Over and enter a 

Tolerance 0.02 
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9 Click Apply and Accept the dialog. 

A Selected Surfaces Boundary defines the limit where the selected tool and 

associated parameters would fully machine the selected surfaces. 

10 Open the Optimised Constant Z Finishing strategy and enter the values and 
settings exactly as shown in the 2 pages below: 

 

 

 

11 Click Calculate to process the toolpath and then Close the dialog. 
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12 In the PowerMILL explorer, right-click the toolpath BN10-Pocket and select 

Simulate from Start, and click Play  in the Simulation toolbar. 

Transforming toolpaths 
Before transforming toolpaths, it is advisable to create a master copy of the original. 

1 Right-click the BN10-Pocket toolpath and select Edit > Copy Toolpath and 

Rename the copy BN10-Pocket_1 as BN10-Master. 

2 In the PowerMILL explorer select the toolpath BN10-Master and with the left 

mouse key depressed, drag it onto Toolpaths to move it to the top of the list. 

 

3 In the PowerMILL explorer, right-click on the toolpath BN10-Pocket and 
select Edit > Transform to display the Toolpath Transform toolbar. 

 

4 On the Toolpath Transform toolbar, click Move . 

5 On the Move toolbar, click Keep original with No. of Copies as 2. 

 

6 In the data entry box  located below the graphics area, enter the relative 
distance along X as 80, and press Enter on your keyboard. 

 

 X Y Z values (separated by a space) are entered into this box as required.  

7 In the Transform toolbar, click  to close and accept the changes. 
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A new toolpath named Pocket_1 has been created that includes 3 copies including 

the original, transformed along X by a distance of 80. 

 

Gouge checking a toolpath 

A  next to the toolpath indicates that it has not been gouge checked directly to 

the model. 

 

 

1 In the PowerMILL explorer, activate the toolpath BN10-Pocket_1. 

2 Right-click on the toolpath BN10-Pocket_1 and from the local menu select 
Verify > Toolpath. 

3 In Check select the Gouges option. 

                    

4 Apply the Toolpath Verification dialog. 
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A PowerMILL information box is displayed to inform of the gouge check 

status. In this instance, No gouges were found.  

 

In the PowerMILL explorer, the style of the icon also updates indicating that 
the toolpath is gouge free. 

 

 

Exercise  
5 Delete the toolpath BN10-Pocket_1. 

6 Use the Multiple Transform option  to create 9 copies of the toolpath 
BN10-Pocket1 as a 3x3 matrix along X and Y with an incremental value of 80. 

 

7 Apply Verify on the new toolpath BN10-Pocket_1 to check for for gouges. 

8 Save Project As: 

       ......\COURSEWORK\PowerMILL-Projects\Transform 
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Edit > Limit…  
Edit > Limit provides a series of options to retrospectively, trim a toolpath to a 
Plane, Polygon, or Boundary.  

Edit > Limit > To a Plane 
Edit > Limit to - Plane allows the user to select a plane at specified distance along 

the X, Y, or Z axis.  

 

 

 

 

The Edit > Limit to - Arbitrary option allows the user to specify an X,Y,Z Point 

and a user defined, Normal vector for the limiting plane. 
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Edit > Limit > to a Polygon 
Using the mouse, you can sketch polygons with any number of sides. 

This allows complex areas to be defined, with the option to save the Inside, Outside, 

or Both sides of the polygon. 

 Before making a polygon ensure that the snap filter is set to pick Anywhere. 

 

 

 

Edit > Limit > to a Boundary 
This provides the option to limit the toolpath to areas defined by an existing 

Boundary. Again, the option exists to save the Inside, Outside, or Both toolpath 
areas. 

1 Select File - Delete All and Tools - Reset Forms. 

2 Import the model: 

     ......\PowerMILL_Data\Models\Handle.dgk 

 

3 Calculate a Block to the Max/Min Limits of the model and then: 

a Lock the Z Min and Z Max. 

b Enter Expansion 10.  

c Click Calculate again.  

4 Define a Dia 10mm Ball Nose named BN10. 

5 In the Rapid Move Heights dialog, click Calculate to reset the tool to a safe 
height. 

6 From the Strategy Selector > Finishing options, open the Constant Z 

Finishing dialog and enter data exactly as shown in the next illustration.  
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7 Calculate the toolpath and then Close the dialog. 

 

The created Constant Z finishing strategy is not suitable for shallow areas of 
the component.  

                    

To improve the toolpath, a Boundary will be created and the toolpath will then 

be retrospectively limited to the steep areas. 

 

8 Select the main upper surface of the model. 

9 In the PowerMILL explorer, right-click Boundaries and select Create 
Boundary - Selected Surface to open the Selected Surface Boundary 
dialog. 

10 Enter the data exactly as shown in the dialog and click Apply and then Accept 
to close the dialog. 
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11 In the PowerMILL explorer, right-click on the active toolpath and select Edit 

> Limit. 

12 In the Toolpath Limit dialog which appears: 

a From the Limit to, select Boundary. 

b In the Boundary input list select 1. 

c Select Save – Outer and then click Apply to create a copy of the toolpath 

outside Boundary 1. 

 

The toolpath has been retrospectively limited to be outside the Boundary. 

 If the Delete Original option is selected, it causes the deletion of the 

original toolpath once the new toolpath is created.  

 If the toolpath is re-Calculated any retrospective limiting will not apply to 
the new or edited strategy.  
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Changing the Order and Direction within Toolpaths – EX1 
 

For toolpaths containing internal link moves, the order and direction of the tool 

tracks can be changed. For example, if a machining sequence starts at the bottom 
of the part, and progresses upwards, reversing the order will change the tool track 

sequence to start at the top of the part and make it progress downwards. 

 

1 Select File - Delete All and Tools - Reset Forms. 

2 From File > Open Project select the read-only Project: 

           ......\PowerMILL_Data\Projects\EditToolpath_2 

 

3 Select File > Save Project As: 

......\COURSEWORK\PowerMILL-Projects\EditToolpath-EX1 

4 In the PowerMILL explorer, right mouse click on the toolpath bn12-finish-

a1 and then from the local menu select Simulate from Start. 

                  

The tool Climb Mills across the form, stepping downwards to the base before 

stepping up the other side. 
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1 Left-click to select all tool tracks on bn12-finish-a1 beyond the centre of the 

form (Yellow in the illustration above). 

2 In the PowerMILL explorer, right-click the active toolpath, bn12-finish-a1 

and from the local menu select Edit > Reorder to open the following dialog. 

 

All existing tool tracks (identified by number) are listed in the current order of 
machining. 

 The selected tool tracks are highlighted (blue) in the dialog. 

3 Click on the Reverse Order button  to reverse the sequence of the selected 

tool tracks. 

4 Click on the Reverse Direction button  to reverse the direction of each 

selected tool track. 
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The Order and Direction of the toolpath has been edited so that it tracks from 

the outer edges of the form downwards towards the centre of the base. 

 Lead In - Vertical Arc and Lead Out - Extended Move have been 
applied to the above toolpath to identify the directional differences. 

5 Save Project As: 

......\COURSEWORK\powerMILL-Projects\EditToolpath-EX1 

 

 

Changing the Order and Direction within Toolpaths – EX2 
1 From the main menu, select File - Delete All and Tools - Reset Forms. 

2 Open the read-only Project:- 

        ......\PowerMILL_Data\Projects\EditToolpaths_3 

 

3 Save Project As: 

......\COURSEWORK\PowerMILL-Projects\EditToolpath-EX2 

The Project contains a Dia 10 Rad 1 Tipped Tool, and a 3D Offset finishing 

toolpath controlled by both Boundary and Pattern segments. 



8. Editing Toolpaths PowerMILL 2013 

8 - 14  Copyright © Delcam plc 

4 Simulate the Toolpath using the Slow setting. 

 

Observe the current direction and ordering of the strategy considering potential 
improvements.  

For example, the lower area machining would benefit from climb milling inwards 

towards the component form and the pocket machining could start central and climb 
mill outwards towards the sidewall. 

 

5 From the Main menu, select View > Toolbar > Toolpath to display the 
Toolpath Toolbar. 

 

6 On the Toolpath Toolbar Click the Reorder Toolpath  button. This 

displays the Toolpath Listing on the Toolpath Toolbar dialog. 

 

The selected segments are shown highlighted in the dialog. 

 

Each segment is listed in the order of execution. If a toolpath segment is 

selected on the list, the corresponding segment is highlighted in the graphics 

area (and vice versa). You can modify or move the selected toolpath to 
another position in the pecking order. 

You can use the buttons on the left hand side of the dialog for changing the 

order and direction of selected segments. If no segments are selected, the 
whole ot the toolpath will be edited. 
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The 2 buttons to the lower left of the dialog are Automatic Reorder  and 

Automatic Reorder and Reverse . These can only be applied to the whole 

toolpath and not on selected tool tracks. They are designed purely to 
minimise air moves, since unnecessary air moves are detrimental to the 

order or direction of tool tracks. 

 

7 Select all tool tracks in the lower area and select Reverse Order. This part of 

the strategy should now climb mill inwards, towards the main component dialog. 
If not ‘climb milling’, then apply Reverse Direction. 

 

8 Select the tool tracks in the central pocket and again select Reverse Order 

followed by Reverse Direction. This part of the strategy should now climb mill 

from the centre of the pocket outwards. 

 

 Extra care is required when using the Spiral option in the selected 

finishing strategy as these are continuous tool tracks and can only be 
reversed and not internally reordered (If a spiral track is created to Climb 
Mill outwards then it can only be modified to Climb Mill inwards). 
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Moving Start Points 
Start points on the tool tracks can be moved to provide a more suitable position for 
applying leads. This is achieved by defining a line that crosses the new start 

positions on the toolpath.  

1 Select File - Delete All and Tools - Reset forms. 

2 Select File - Open Project: 

......\PowerMILL_Data\Projects\limiting-example 

3 Select an ISO1 view. 

 

The toolpath start point  needs to be moved to . 

4 Select a View from top (Z).  

5 Right-click toolpath 1 and select Edit > Move Start Points. Click and select the 

two points as shown. 

 

6 Click  to accept the change. 

 

This has moved the start position. 
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Moving multiple points 
It is possible to apply the Move start points option on the toolpath to more than one 

position. 

1 Select File - Delete All and Tools - Reset Forms. 

2 Open the Project: 

......\PowerMILL_Data\Projects\PunchForm10-Start 

3 Save Project As: 

......\COURSEWORK\PowerMILL_Projects\PunchForm10 

4 Select a View from top (Z). 

       

5 Right-click the active toolpath and from the local menu select Edit > Move 

Start Points (The Move Start Points toolbar is displayed).  

6 If not already selected, on the toolbar, click the Move Start Points by drawing a 
line button. 

  

7 On each of the three locations shown below, in the listed order, click and select 
2 points on both sides of the tool tracks.  

�  - First move point selection points. 

 

�  - Second move point selection points. 
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�  - Third move point selection points. 

 

 

The final output looks similar to this: 

 

 The tool tracks are coloured blue while the Move Start Points toolbar is 
active. 

8 Click  on the Move Start Point toolbar to accept the changes. 
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Feeds and Speeds 
You can modify Feed Rates using the Feeds and Speeds dialog to retrospectively 
Apply them to the Active toolpath. 

 

 

1 Select File - Delete All and Tools - Reset Forms. 

2 Select File > Open Project: 

......\PowerMILL_Data\Projects\ExtraFeedrates-Start 

 

 

3 Select File > Save Project As: 

......\COURSEWORK\PowerMILL-Projects\ExtraFeedrates-example 

 

4 Undraw the Model, Block, Workplane, and Tool to display the Toolpath and 

3 Boundaries. 

5 Activate both the Toolpath and Boundary 2. 

6 Right-click the Toolpath and select Edit > Update Feed Rate Inside 

Boundary. 

7 Enter value as 50 and click  to apply the percentage difference to the Feed 

Rate within the Active Boundary. 
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The Toolpath is split into two different coloured areas that are allocated a 

separate Feed Rate as a percentage of the original.  

 

 The original Cutting Feedrate assigned to the toolpath was 450 mm/min. 

8 Activate both the Toolpath and Boundary 3. 

9 Right-click the Toolpath and from the local menu select Edit > Update Feed 

Rate Inside Boundary. 

10 Enter the value 100 and click  to apply the percentage difference to the Feed 
Rate within the Active Boundary. 

 

The central part of the Toolpath area, clear of the side wall, has changed back 
to the nominal Feed Rate value. 

 

11 To check the actual Feed Rate values assigned to the coloured areas of the 
toolpath, in the PowerMILL explorer, double-click on a Light bulb adjacent to 

the Toolpath.  

 

In this case, the nominal Feed Rate is 450 mm/min and the modified section 

near the intersection of the Base and Sidewall of the pocket is reduced by 50% 

to 225 mm/min. The colour of the values displayed in the Information dialog is 
the same as the colours displayed on the toolpath. 



PowerMILL 2013 8. Editing Toolpaths 

Copyright © Delcam plc  8 - 21 

Safe Z and Start Z Positions 
The tool Rapid Move Heights can be changed in the dialog and applied 

retrospectively to the Active toolpath. 

 

Editing Tool Start and End Point Positions 
The tool Start Point/End Point can be changed in the dialog and applied 

retrospectively to the Active toolpath. 
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Collision Checking 
Collision Checking can be applied retrospectively, as long as a tool Shank and 
Holder are defined with the Active Tool. If the option Verify > Collisions is 
applied, two additional toolpaths will be created from the original, one being 

collision safe, and the other being in collision. At the same time a copy of the 
Tool complete with appropriate modifications will be substituted into the 

Original and Collision status toolpaths. 

1 Select File > Delete all and Tools > Reset Forms. 

2 Import the Model:- 

     ...\PowerMILL_Data\Models\cowling.dgk 

3 Calculate the Block to Min/Max limits. 

4 Calculate both the Rapid Move Heights and the tool Start and End 
Points. 

5 Create a Dia 5mm Ball Nose tool named BN5 with a length of 10 and tool 

number of 1. 

 

9. Tool Holder Collision 
Checking 
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6 Select the Shank tab. 

7 Select Add a shank component . 

8 Fill in the dialog exactly as shown in the image below. 

                  

9 Select the Holder tab. 

10 Select Add holder component . 

11 Fill in the form for the first Holder element exactly as shown in the image 

below. 

 

                    

12 Select Add holder component . 
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13 Enter an Upper Diameter of 22, a Lower Diameter of 20 and a Length of 

10. 

14 Select Add holder component . 

15 Enter an Upper Diameter of 30, a Lower Diameter of 30, a Length of 10 

and an Overhang of 15. 

             

 If it is required to modify or delete a Holder element, select (left click) on 
one of them in the assembly illustration and it will turn pale. The current 
values for that element will be displayed and available for modification. 

 The same procedure applies to modify a Shank element. 

16 Click Close. 

17 Select Toolpath Strategies  on the main toolbar. 

18 From the Finishing options select a Raster Finishing strategy. 
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19 Enter the name as BN5-RasterFinish, Angle 45, and Stepover 1. 

20 Select Start Corner - Lower Left. 

21 Select Style - Two way. 

22 In the Leads and Links , Lead In and Lead Out options, set 1st and 

2nd Choices to None. 

23 In the Leads and Links - Links options, enter a Short/Long Threshold of 
2, set Short to Circular Arc and Long to Skim. 

          

24 Click Calculate to process the toolpath and then Close the dialog. 

 

The new toolpath is gouge free, but at this stage no collision checking 
has been applied in relation to the Shank and Holder. 
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25 From the Main toolbar select Toolpath Verification . 

                           

The two available, independent Check options are Collisions and Gouges. 

Shank Clearance and Holder Clearance, allow the user to specify a value 

for an additional, safe thickness around the tool Shank and Holder elements. 

26 In the Check box select Collisions. 

27 Input values in the Shank Clearance 2 and Holder Clearance 3. 

28 Click Apply. 

           

The above PowerMILL Information box appears with information on the 

status of the original tool and required dimensional changes. The default 
settings will result in a modified tool (BN5_1) being created along with 2 

new toolpaths (The collision and non-collision parts of the original). The new 

tool (BN5_1) will then automatically exist in both the original and new 
(collision warning area) toolpath. The original tool (BN5) will remain in the 

new (collision safe area) toolpath. 

29 Click OK. 

30 Click Accept on the Toolpath Verification dialog. 
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PowerMILL has created two new toolpaths, BN5-Raster Finish_1 and 
BN5-RasterFinish_2. A new tool named BN5_1 has also been created in 

the Tools area of the PowerMILL explorer. This new tool has been created 

with the new valid adjustments made i.e. Overhang 26.4 

31 Activate the toolpath RasterFinish_1 in the Explorer. 

        

This toolpath contains the ‘collision free’ segments of RasterFinish, along 

with the original tool BN5.  

 

32 Activate the toolpath RasterFinish_2 in the PowerMILL explorer. 

 

This toolpath contains the ‘collision’ segments of the Raster Finish if it 
were machined with the original BN5 tool. 
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33 Activate the original toolpath, BN5-RasterFinish, in the PowerMILL 

explorer. 

 

 PowerMILL has substituted a newly created Tool, BN5_1 (with an 
extended overhang) into BN5-RasterFinish and BN5-RasterFinish_2. 

 

34 Select File > Save Project As: 

      ......\COURSEWORK\PowerMILL-Projects\ToolCollisionExample 

         

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



9. Tool Holder Collision Checking PowerMILL 2013  

9 - 8  Copyright © Delcam plc 

Automatic Collision Checking 
Tool Holder Collision Checking can also be applied during Toolpath 
calculation. 

If the Toolpath is calculated with a Tool definition that includes a Shank and 
Holder any part of the toolpath segments that would otherwise be in a 

collision condition will not appear. These missing segments can then be 

machined later using a modified Tool in conjunction with a Collision Safe 
Boundary. 

1 Select File > Delete All and Tools > Reset Forms. 

2 Open the Project: 

       ......\PowerMILL_Data\Projects\ToolCollision_Start 

 

3 Save Project As:  

......\COURSEWORK\PowerMILL-Projects\ToolCollision-Auto 

4 Right-click on the RasterFinish toolpath in the PowerMILL explorer. 

5 From the local menu, select Activate followed by Settings and in the Raster 

Finishing dialog select the Copy toolpath icon . 

6 Select the Automatic Verification page  to open the following dialog: 

 



PowerMILL 2013 9. Tool Holder Collision Checking 

Copyright © Delcam plc  9  - 9 

7 Tick the Automatic collision checking box, and for both Shank Clearance 

and Holder Clearance input 1.0 

8 Calculate the Raster Finishing strategy to directly create a collision free 
toolpath, RasterFinish_1. 

 

 This method does not produce any advice for the user or automatically 
create a new compatible tool (BN5_1) that would perform collision safe 
machining over the whole strategy. 

Machine maximum stock 
If the additional option Machine maximum stock is ticked then a full toolpath 

will be created with a varying increased thickness over the previously 
inaccessible areas. 

 

9 Right-click on the toolpath RasterFinish in the PowerMILL explorer. 

10 From the local menu, select Activate followed by Settings and in the Raster 

Finishing dialog select the Copy toolpath icon . 

11 With the Raster Finishing dialog open, select the Automatic Verification 

page  to access the following dialog: 
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12 Tick - Automatic collision checking, input Shank Clearance 1.0, Holder 

Clearance 2.0, and tick - Machine maximum stock. 

13 Calculate the Raster Finishing dialog to directly create a continous, 
collision free toolpath, RasterFinish_1_1. 

 

 An additional strategy with a compatible (collision free) tool definition is 
required to remove the remaining stock. 

Collision Safe Boundary 
A toolpath for the remaining areas will require a new Dia 5 Ball Nosed tool 
with increased Shank length. The additional Toolpath will be calculated to 
limits set by a Collision Safe Boundary based on the current tool (BN5). 

14 Ensure that the tool BN5 is Active. 

15 In the PowerMILL explorer, right-click Boundaries, and from the local 
menu select Create Boundary > Collision Safe. 

          

16 Apply the dialog. 



PowerMILL 2013 9. Tool Holder Collision Checking 

Copyright © Delcam plc  9  - 11 

The lower part of the central pocket is more suited to be finish machined using an 

End Mill. 

       

17 Select and Delete all segments except the 2 running along the outside of the 

component form as shown below. 

                        

In the PowerMILL explorer, right-click the Tool, BN5, and from the local 

menu select Edit > Copy Tool (to create BN5-1). 

 

18 Right-click over the new tool BN5-1 and from the local menu, select Activate 

followed by Settings. 

 

 

19 In the Ball Nosed Tool dialog select the Holder tab and change the 

Overhang to 30.0 and then Close the form. 

20 Select Toolpath Strategies  on the main toolbar. 

21 Activate the new ‘long reach’ Tool BN5_1 

22 From the Finishing options select a 3D Offset Finishing strategy and enter 
data as shown in the following form. 
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23 Select the Limit page and select Boundary 1 with Trimming > Keep 

inside. 

                      

 

24 Select the Automatic Verification page and tick Automatic collision 

checking, input 1 for both Shank and Holder clearances, un-tick Machine 

maximum stock. 

                       

 

25 Calculate the toolpath and then Close the dialog. 



PowerMILL 2013 9. Tool Holder Collision Checking 

Copyright © Delcam plc  9  - 13 

 

 Note that Automatic Collision Checking is still active and as can be 
seen in the above illustration there is no evidence of the toolpath being 

fragmented.  

 

Toolpath Gouge/Collision - Safety Status 
 

When a Toolpath is calculated the symbol to the left of the light bulb in the 

PowerMILL explorer indicates the Safety Status for Gouges (Tip/Flutes) or 
Collisions (Shank/Holder). 

 

 

To display the 4 different levels of Safety Status, position the mouse over a 

symbol   in the PowerMILL explorer and the information form 
will open (shown above right). 
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Introduction 
Patterns are 2D or 3D Wireframe entities used primarily for the control and 

creation of toolpaths. A selection of Pattern creation and manipulation options are 
provided in a dedicated Toolbar (as shown below). 

 

 

 

Below is a summary of the Pattern - toolbar options: 

 - Create Pattern (empty). 

 - Activate the picked pattern. 

 - Pick curves to add to the active Pattern. 

 - Automatic Pattern Generation (Open the Pattern Maker form). 

 - Insert File into Active Pattern (eg. dgk, pic, dxf, iges). 

 - Save Active Pattern as a file (dgk pic dxf). 

10. Patterns 
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 - Insert Boundary into Active Pattern. 

 - Insert Active Toolpath into Active Pattern. 

 - Insert Model into Active Pattern (Selected Model). 

 - Curve modelling. 

 - Wireframe modelling (PS-Sketcher). 

 - Transform pattern 

 - Curve Editor. 

- Clear 

 

 The Pattern segments can be edited directly from local menu options, or via 
the Curve Editor. Unlike Boundaries, Patterns can contain open 
segments.  

When an empty Pattern is created it is automatically assigned a number and made 

Active as shown in the PowerMILL explorer. 

 

 

Automatic Pattern Generation 
The Automatic Pattern Generation icon opens the Pattern Maker dialog. This 
provides options for the user to construct a range of wireframe layouts that can be 

used in the Pattern Finishing strategy.  

1 Select File > Delete All and Tools > Reset Forms. 

2 Import the Model: 

      ......\PowerMILL_Data\Models\phone.dgk 

 

3 Select Block  and Calculate using the default settings. 

4 Define a dia 12mm Ball Nose tool named BN12. 

5 Reset the Rapid Move Heights . 

6 Calculate the Start and End Points  using the default settings. 

7 Select an ISO1 view to display the model. 
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8 Select the ‘shutout’ surface as shown above. 

9 Right-click on Boundaries, and from the local menu select the option Selected 

Surface and enter the values shown below. 

 

10 Apply the dialog. 

11 Create a new (empty) Pattern . 

12 Select the inner Boundary segment. 

13 In the Pattern toolbar select the option to Insert Boundary into Active 

Pattern . 

14 Input the Boundary name (1) and then click  to accept. 

 

15 Undraw the Boundary. 
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The selected Boundary segment will be copied as a Pattern segment as shown 

below. 

 

16 Right-click on the Pattern segment and from the local menu, select Curve 

Editor.  

 

17 In the toolbar move the cursor over Transformations  and from the 

exposed vertical toolbar, select the Offset option . 

 

18 Select Keep Original , the Round Corners option, and input Distance 50 
before clicking the Enter key. 

19 In the Curve Editor toolbar, click  to accept. 

 

20 Right-click on the Pattern and from the local menu, select Instrument to 
display the direction arrows on the segments as shown in the image above. 
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21 Select the inner Pattern segment and from the local menu select Edit > 

Reverse Selected (Both Pattern segments should now run in the same 

direction). 

The Automatic Pattern Generator will be used to create a new Pattern with a 

series of segments merged between the 2 segments of the original Pattern. The 
resultant toolpath will follow the contour of the component form as well as creating 

corner free, tool tracks with a constant material removal rate.   

22 From the Pattern toolbar, select Create Pattern  to create a new Pattern. 

23 Select Automatic Pattern Generation . 

24 With the new (empty) Pattern activated and the original Pattern displayed, 

select both visible segments. 

25 Select Create Pattern along ‘one-way curves’ with a Stepover 1.0 

 

The form allows the user to create a range of multi-segment Pattern styles from 

either 1 or 2 drive curves. 

26 Click Apply, followed by Accept. 

 

The new Pattern has been generated independently; between the two selected 

segments of the original, de-activated Pattern (the previous illustration shows a 
2mm Stepover for visual reasons).  

The new Pattern will now be used in a Pattern Finishing strategy. 
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27 Select a Pattern Finishing strategy. 

 

28 Ensure that the Boundary is not Active. 

 

29 Enter the data into the above form exactly as shown below, click Calculate, and 

then Close the form. 
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30 Undraw the Model, Boundary, and Patterns for a better view of the toolpath. 

 

The Pattern Finishing toolpath is limited to exist within the defined material 
Block. 

Exercise 
31 Right mouse click on the new toolpath from the local menu, and use the Edit > 

Reorder options to make the above strategy start from the outside and Climb 
Mill towards the centre of the model. 

32 Save the Project. 

Trochoidal Pattern Generator 
In areas where a full width cut would otherwise be required, the Trochoidal 

Pattern is applied to produce a progression of advancing loops. This in turn will 
restrict the tool contact area to only a part of its circumference. 

Since the tool is no longer cutting at full width, the problem of tool overload is 
greatly reduced. This is essential in applications where coated carbide cutters are 

used in High Speed Machining of hardened steel. 

1 Select File > Delete All and Tools > Reset Forms. 

2 Select File > Import Model: 

......\PowerMILL_DATA\Models\dashboard.dgk 

3 Select an ISO1 view. 

 

The above Slot will be machined using a Trochoidal Pattern. 
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4 Define the Block  to Min/Max limits. 

5 In the PowerMILL explorer, right-click on Patterns and select Toolbar. 

6 Select Create Pattern  from the Patterns toolbar. 

7 Select Insert File into Active Pattern  from the Patterns toolbar and load 

in the file: 

......\PowerMILL_DATA\Patterns\trochoidal_pattern.pic 

8 Select Create Pattern  (again) from the Patterns toolbar. 

9 Select Insert File into Active Pattern  from the Patterns toolbar and load 
in the file: 

......\PowerMILL_DATA\Patterns\StartHole.pic 

 

Before producing a Slot, a Helically drilled hole of diameter 8mm must be machined 
to create clearance for a Slot drill to plunge down to the full Slot depth. This is 

achieved by using Feature Sets (Covered in more detail in the next chapter). 

1 Define a Ball Nose tool of 6 Diameter named BN6. 

2 In the PowerMILL explorer, right-click over Feature Sets, and select Create 

Feature Set to open the new Feature dialog. 

3 Select the vertical Pattern. 

 

 

4 On the Feature form select the Create option and enter the values as shown in 

the above image, and then select Apply followed by Close.                 

A new Feature will be created that includes a DIA10 the hole ready for helical 

drilling. 
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5 Click Apply, Click Toolpath Strategies  on the main toolbar and then select 
the Drilling tab.  

6 Select the Drilling option from the Drilling dialog. 

  

7 In the graphics area, depress the left mouse key, and select the new Hole 

Feature. 

       

8 In the Drilling dialog, select Cycle type - Helical, input a Pitch 1 and then 

click Calculate, followed by Close. 

9 Run a toolpath simulation and observe the Helical drilling strategy. 
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You can see on the simulation that the tool is Climb Milling in an anti-clockwise 

direction. The 10mm Diameter hole has now provided some clearance for a 

smaller tool to plunge into the Slot before performing a Trochoidal milling 
operation. 

 Feature Set machining oprerations are not gouge checked to a Surface 
model. 

10 Create an End Mill of Diameter 6mm called EM6. 

11 De-activate Pattern 1 (trochoidal_curve), but keep it displayed by toggling the 

light bulb. 

12 Create another empty Pattern  (3) which will become Active. 

13 Select the (de-activated) curved Pattern (1) with the left mouse button. 

14 Right mouse click on Pattern (3) Select Automatic Pattern Generation . 

15 In the Pattern Maker dialog, select the Trochoidal option and enter the data 
exactly as shown below. Click Apply, and then Accept. 

 



PowerMILL 2013 10. Patterns 

Copyright © Delcam plc  10 - 11 

          

 The Radius value must not be greater than half of the Width value. A 
fine Stepover is required when applying to High Speed Machining of 

hardened steel. 

 

16 Select Toolpath Strategies . 

17 On the Finishing tab, select the Pattern Finishing strategy to open the 

Pattern Finishing dialog. 

18 Enter the values exactly as shown in the image below. 

 

19 Click Calculate to create the toolpath and then Close the dialog. 
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The 6mm End Mill tool will plunge into the previously created 8.5mm clearance 

Hole. 

The Trochoidal toolpath defaults to a Climb Mill direction and is ideally suited to 
High Speed Machining applications. 

20 Activate the toolpath 1 (drilling) in the PowerMILL explorer. 

21 Open the Block  form and then manually input values exactly as shown 

below to create a Block definition locally along the back half the slot width. 

                 

22 Click Accept. 
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23 Dynamically position the View (as shown below) in the graphics area in 

preparation for a ViewMILL simulation. 

24 Select ViewMILL On/Suspend  on the ViewMill toolbar. 

25  Select Plain Shaded Image . 

26 Visually check both the Helical and Trochoidal toolpaths in turn with 

ViewMILL. 

 

Helical drill toolpath. 

 

Trochoidal mill toolpath. 

 

27 Save the Project. 
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Patterns applied to 3D Offset machining 
 

A Pattern can be used as the form to be offset across the area of a 3D Offset 

Finishing strategy.  

1 Select File > Delete All and Tools > Reset Forms  

2 Import the model: 

......\PowerMILL_Data\Models\speaker.dgk 

3 Save Project As: 

      ......\COURSEWORK\PowerMILL_Projects\SpeakerPattern-EX1.dgk 

 

4 Define a Dia 6 Ball Nose tool with the name BN6. 

5 Define a Block to the default Min/Max limits. 

6 Calculate the Rapid Move Heights to the default settings. 

7 Select an ISO3 view.  

8 Select the 3 shaded Surfaces as shown in the following diagram. 

 

9 Create a Selected Surface, Boundary with allow boundaries to be private 

un-ticked, and with a Tolerance value of 0.02 
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10 From the Pattern toolbar click Create Pattern  followed by Insert 

Boundary into Active Pattern  (Input Boundary name into the dialog!). 

11 Undraw the Tool, Block, Model and Boundary to visually isolate the new 
Pattern. 

 

 Only the leading edge of the Pattern is required. The remaining parts are 
to be removed. 

12 Right mouse click on the Pattern and from the local menu, select Curve Editor 

to open the following toolbar: 

 

 

13 Select the option Cut Item.  

14 Select the Pattern segment using the left mouse key. 

 While performing the next operation it is essential to zoom in as close as 
possible to the end of the pattern segment! 

 

15 Move the cursor over the left hand end of the leading edge to locate the Key 

Point and then left click to cut the segment at this point. 

 

16 Select the leading edge, segment again, locate the Key Point and cut exactly at 

the right hand end of the leading edge. 
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17 Click on the option Cut Item  again to de-select it. 

18 Select and Delete the Pattern segments outside the leading edge. 

 

19 Click the green tick  to Save the new segment and close the Curve Editor 
toolbar. 

20 Right mouse click on the Pattern segment and from the local menu, select 

Instrument to display the direction of the segment. 

21 If it is not running in the direction (shown above), right mouse click on the 

Pattern segment and from the local menu select Edit > Reverse Selected. 

22 Re-draw the Tool, Model and the Active Boundary. 
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23 Select a 3D Offset Finishing strategy and enter data into the dialog exactly as 

shown below. 

 

24 Click Calculate to create the toolpath and then Close the dialog. 

 

Leads and Links are un-displayed to provide a clearer view of the toolpath. 

The above toolpath starts at the lowest point following the Pattern while offsetting 

across the limiting Boundary in a Climb Milling direction. With the addition of 

suitable Lead In and Lead Out moves this is an ideal strategy for High Speed 
Machining applications. 
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If a Pattern is not selected in the 3D Offset dialog, machining strategy follows the 
shape of the Boundary segment, as shown above. 

25 Save the Project. 

 

Exercise - 3D Offset Finishing controlled by Pattern 
It is not compulsory for the pattern used to control the toolpath to be coincident 
with the limiting Boundary. In the following exercise it is required that you create a 

toolpath trimmed inside a Boundary with the tool tracks following a Pattern that 

runs centrally along the base of a curved recess: 

1 Select File > Delete All and Tools > Reset Forms  

2 Open the Project: 

......\PowerMILL_Data\Projects\PatternBlock_Start 

 

3 Click OK to close the PowerMILL Warning and Save Project As:  

......\COURSEWORK\PowerMILL-Projects\PatternBlock_ex1 
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4 Calculate the Block using the default settings. 

5 Calculate the Rapid Move Heights to the default settings. 

6 Create a Pattern using Insert Model on the wireframe arc (included with the 
Model) running centrally along the recessed form. 

7 Select the 5 surfaces that define the recessed form and create a Selected 
Surface, Boundary using a 0.01 tolerance, with the BN16 tool active. 

8 Create a 3D Offset Finishing strategy that is limited Inside the Boundary 

with the order and shape of the tool tracks controlled by the Pattern. 

 

 

9 Save Project As: 

      ......\COURSEWORK\PowerMILL_Projects\PatternBlock-EX1 
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Deep Pattern machining 
If Pattern Finishing is applied with a –ve Thickness it will only create tool tracks 

where the –ve Thickness value is less than the tool, tip radius. As an example, 

this makes it impossible to use a –ve Thickness value less than zero where an End 
Mill is being used. 

It is, however, possible to produce a Pattern Finishing strategy that machines 

deeper into the model if Axial Offset is used in place of a –ve Thickness value. 
This is achieved by first projecting the Pattern onto the surface (relative to the tool 

geometry). Pattern Finishing is then applied using the Drive Curve option with a 

–ve, Axial Offset value while gouge checking is unticked. 

 The strategy produced will not be based on a 3D offset of the model form but 
a series of copies of the Drive Curve stacked downwards. 

1 Select File > Delete All and Tools > Reset Forms. 

2 Open the read only Project: 

...... \PowerMILL_Data\Projects\DeepPattern_Start 

 

 

 

3 Click OK to close the PowerMILL Warning and Save Project As: 

......\COURSEWORK\PowerMILL-Projects\DeepPattern-EX1 

The Project consists of component surfaces and a Pattern on Z0 representing the 
text ‘RH’ ready to be engraved into the component form to a depth of -3. 

4 Calculate a Block, Defined By - Box, using Type - Model. 

5 Create a Dia 5 Ball Nosed tool with the name BN5. 

6 Calculate the Rapid Move Heights to the default settings. 

7 In the PowerMILL explorer, right-click over the Pattern 1 and from the local 

menu select, Edit > Drop to project it downwards onto the model. 

 This projects the Pattern down Z, while compensating for the tooling 
parameters. 
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8 From the main toolbar, select Toolpath Strategies  and in the dialog select 
Finishing followed by the Pattern Finishing option. 

9 Enter the data into the dialog exactly as shown, using Base Position 

Automatic with Thickness -3 and then click Calculate. 

 

The Thickness of -3.0 exceeds the Tip Radius of the Dia 5 Ball Nosed tool 
hence instead of a toolpath appearing, the following PowerMILL Error form is 

displayed. 

 

10 Click OK to close the PowerMILL Error message and recycle the Pattern 

Finishing toolpath using the data as shown in the following image. 
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Base Position - Drive Curve 

Axial Offset  -3.0 

Gouge Check – un-ticked 

Thickness  0 

11 Select the Multiple cuts page and input data exactly as shown below. 

 

Mode - Offset down 

Upper limit – Ticked with value -1.0 (First pass at 1mm below the Pattern) 

Maximum Stepdown 1.0 

12 Click Calculate to create the toolpath and then Close the dialog. 
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The Reversed lettering, Pattern ‘RH’ is now recessed into the Punch form to a depth 
of 3mm. 

 The Toolpath will initially be identified in the PowerMILL explorer with a 
yellow warning.  

 

 

13 Right mouse click on the Toolpath and from the local menu select Verify > 

Toolpath. 

14 In the Toolpath Verification dialog (with the default Check – Gouges set) 
select Apply. 

 

Once verified for gouges, the above Toolpath BN5-Engrave will then be identified 
in the PowerMILL explorer with a red warning. 

        

 

15 Save the Project. 
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Introduction 
This is a wireframe constructor within PowerMILL that provides the user with a 

powerful set of tools for the creation and modification of Boundaries and Patterns. 
It is accessed via the local Boundary or Pattern menu option, Curve Editor... 

During construction, the Intelligent Cursor option allows geometry items to be 

snapped onto key points on a displayed CAD model.  

Boundary modifications using the Curve Editor 
A Shallow Boundary will be created in the following example and although correct 
to the settings applied, it will benefit from further modification to provide improved 

machining strategies. The modifications aim to make the toolpaths, continuously 
follow the lower, component contour by bridging the gap between the 2 outer 

segments as well as smoothing any jagged sections of the segments. Due to 

technical limitations, it is not possible to directly apply Boundary editing for these 
changes. The easiest and most effective method is to make use the powerful tools 

available in the Curve Editor. 

1 Select File > Delete All and Tools > Reset Forms. 

2 Import the Model: 

......\PowerMILL_Data\models\cowling.dgk 

 

3 Calculate a Block using Defined by - Box and Type Model. 

4 Create a Ball Nose cutter of Diameter 10mm named BN10. 

5 Calculate the Rapid Move Heights using the default settings. 

11. Curve Editor 



11. Curve Editor PowerMILL 2013 

11 - 2  Copyright © Delcam plc 

6 Use the defalult Start and End Point values. 

7 In the PowerMill explorer, right-click Boundaries and from the local menu 

select Create Boundary > Shallow 

 

8 Input Tolerance 0.02 

9 Set limit tool centre to block edge.  

10 Un-tick Allow boundary to be private. 

11 Select Apply followed by Accept. 

12 Undraw the model to view the new Boundary. 

 

The Boundary will be modified so that the gap is removed between the 2 outer, 

closed, segments to form separate inner and outer segments. In addition to this, 
two of the other segments, which contain jagged sections, will be smoothed. 

13 Right-click Boundary 1 in the PowerMILL explorer and from the menu options 
select Curve Editor. 

The Curve Editor toolbar will appear above the graphics area. 

 

 Some licensed icons are temporarily greyed out, only becoming available 
when a related entity is selected.  
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14 Select a view down Z for a top view of the inserted boundary. 

15 Click Line  from the toolbar then select Create a single line . 

                                                      

 Note: It is essential that the Intelligent Cursor is active (ticked):-  

If not, this is set in the Curve Editor > Options menu:-  

   -- Intelligent Cursor -- Snapping Options -- (Tick all boxes). 

 

16 Using the left mouse button, snap (Key points) to create single lines across the 
ends of the four gaps, as shown in the image below.  

 

17 Select the Single Line option  to switch it off. 

18 To remove redundant spans on the curves, click the Limits option  to access 

Interactively limit wireframes.  

                                                        

 

19 Click Interactively limit wireframes  and using the left mouse button, 

select the parts of the curve (arrowed) to be removed. 
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20 Select the Interactively limit wireframes option  again to switch it off. 

21 Zoom into the middle of the area covered by the 3 inner segments. 

 Note the jagged effect along these curves. 

 

22 Create 4 single lines, snapped to key points and pointing outwards from the 

curve outside the jagged regions (as shown above).  

These will be used as markers to provide a start and end point for new, 

replacement smoothed curves along the jagged sections. The markers will then 
be used as the limit to trim away the unwanted, jagged sections of the original 

curve. 

23 Click Curve  on the toolbar then select Create a Bezier Curve  from the 
Curve toolbar. 

24 For the upper section, generate a new, smoother, curve by snapping 

strategically placed key points within this region, starting and ending by 
snapping to the ends (Key Point) of the marker lines. 

 The selection of suitable key points requires a certain amount of skill on the 
part of the user. Where it is required to follow the original form closely input 

several, equispaced points. Where the original shape needs to be smoothed 
out input the minimum of equispaced points along the form.  



PowerMILL 2013 11. Curve Editor 

Copyright © Delcam plc  11 - 5 

 

25 Repeat this process for the lower section. 

26 Select the upper, original curve and select the Cut Item option.   

 

27 Click the key points at the lower end of each line to cut the original curve. 

 

 

28 Repeat the above process on the lower, original curve then select and Delete 

 all the unwanted segments between the 2 pairs of lines.  

29 Then, select and Delete the 4 vertical lines. 

 

30 Right-click away from the wireframe and select Unblank from the flyout menu. 



11. Curve Editor PowerMILL 2013 

11 - 6  Copyright © Delcam plc 

 

31 Create a new smooth Bezier Curve to replace the one indicated above. 

 The Curves used in the above wireframes will consist of open or closed 
segments, but if they are to be used to recreate a boundary they must form 

single entity, closed loops. Only closed forms will appear as boundary 

segments when returned to PowerMILL. 

 

1 Select all boundary segments by dragging a box over them with the left hand 

mouse key depressed. 

2 Select the option Merge selected segments  to join together all groups of 

curves that butt up to each other. 

                                      

 

 The wireframe will now consist of five single segments as reported in the 
PowerMILL Information box (above right). 

 

3 Left click in the graphics area away from the segments to deselect them. 

 If any segments are selected then the remainder will no longer exist on 
return to the main PowerMILL window. 
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4 Select  to Accept changes and export the wireframe back to PowerMILL to 

replace the original boundary. 

 

The modified boundary is positioned back over the model close to its original 3D 

form. The new smoothed contours are now a more suitable shape for use in the 3D 

Offset Finishing strategy. 

5 Generate a Constant Z Finishing toolpath with Stepdown 1 and in the Limit 

page set the Boundary - Trimming option to Keep outside (Steep areas). 

6 Generate a 3D Offset Finishing toolpath with Stepover 1 and in the Limit 

page set the Boundary - Trimming option to Keep inside (Shallow areas). 

7 Select File > Save Project As: 

          .....\COURSEWORK\PowerMILL-Projects\Boundary-mod 

 

These are the resultant toolpaths with the Leads and Links undrawn. 

 The techniques used in this example can equally be applied to Patterns, 
which also have the added advantage on being able to exist both as open or 

closed segments (Boundaries cannot contain open segments). 

 The same Curve Editor toolbar is accessed via the local Pattern menu. 
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Input of Drawing detail as a Pattern using the Curve 
Editor 

An empty Pattern can be inserted into the Curve editor thereby providing the user 
with an effective way to input Drawing Detail which could in turn be used in the 
creation of 2.5D Feature Sets. 

 

1 Select File - Delete All and Tools > Reset Forms. 

2 In the PowerMILL explorer select Workplanes - Create Workplane. 

 

 

3 The Workplane editor toolbar will become active as soon as a new workplane 

is created on the global datum. 

 

 

4 Select the green tick to exit the Workplane Editor toolbar. 

5 From the PowerMILL explorer, create an empty pattern, right mouse click on 
it and from the local menu select Curve Editor. 
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6 From the Curve Editor select Rectangle option. 

 

7 Input 0 in the Command Input box (located to the right and below the 

graphics area) and press the return key to accept. 

 

This will fix the corner of the Rectangle of Lines to the active XYZ datum. 

8 Input 155 100 in the Command Input box and press the return key to accept 
the X and Y dimensions of the rectangle. 

 

9 Select the corner Radius option and input 10. 

 

10 Create a new Rectangle of lines using 100 25 to define the start corner. 

11  In the data input box, switch from Absolute  to Relative  input and 

enter 40 50 for the X and Y dimensions. 
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12 From the Create a circle options select the full Circle option. 

              

13 Input a Radius value of 25.  

14 Input 50 50 in the Command Input box followed by the return key. 

 

15 Create another Circle with a centre at 50 90 and a radius value of 3. 

16 Click on  to close the Circle creation options. 

17 With the new Dia 6 circle selected, open the Transforms options and select 

Create pattern of objects . 
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18 On the dialog, select the Circular tab and enter Angle 30, Number 12 and 

select Reposition rotation axis  , and snap to the centre of the large 
circle. 

 

19 Select Accept on the Multiple Transform dialog. 

 

The geometry creation is now complete and is ready to be returned to the 
PowerMILL Project as the contents of the Pattern. 

20 Left click in the graphics area away from the segments to deselect them. 

 If any segments are selected then the remainder will no longer exist on 
return to the main PowerMILL window. 

 

21 Select  to accept changes and export the wireframe back to PowerMILL to 

replace the original boundary. 
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22 Select File > Save Project As: 

......\COURSEWORK\PowerMILL-Projects\2DModel 
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Introduction 
PowerMILL offers a range of 2D strategies that include 2D Curve machining, 

Chamfer Milling, Face Milling, and 2.5D Feature machining. The original 
wireframe can either be Pattern or Model entities.  

 

Feature Machining 
Features are wireframe entities that are extruded along Z. During creation they are 

specifically defined as a Pocket, Slot, Boss, Hole, Circular pocket, or Circular 
boss. It is also possible to extract Hole features directly from the 3D model. They 

can also be created during 3D Area Clearance strategies to enable the pre-drilling 
of plunge move, positions. Groups of Features are created within a Feature Set. It 

is essential that a Feature Set includes all separate Features that need to work 

together to create a 2.5D Feature machining strategy.  

On completion of a Feature Set, the 4 Feature Set options in the 2.5D Area 

Clearance strategies will create roughing, semi finishing, and finishing strategies.  

Drilling stategies can only be applied to Hole Features. A comprehensive, list of 
cycle types are supported that include; Standard drilling, Boring, Helical milling, 

Tapping and Thread Milling. 

 

The six different types of Feature include:- 

� Pocket:- Machining will only occur fully inside this type of closed Feature. 

� Slot:- Machining will occur with the tool running central, left, or right of this 
type of open/closed Feature. 

� Boss:- Machining will only occur fully outside this type of closed Feature. 

� Hole, this type of Feature is specifically used by the Drilling strategies. 

� Circular Pocket - a circular pocket is defined from points, circles or curves. 

� Circular Boss - a circular boss is defined from points, circles or curves. 

 It is not possible to change an existing a Feature to one of a different type. 

 

 

 

12. 2D Machining 
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Creating Features from Pattern segments 
1 Select File > Delete All and Tools > Reset Forms. 

2 Open the Read-Only Project: 

                        ......\PowerMILL_Data\Projects\2D-Drawing 

 

The imported Project contains a Pattern defining 2D geometry ready to be 

used to create a Feature Set.  

3 Select File > Save Project As: 

......\COURSEWORK\PowerMILL-Projects\2DPatternExample 

4 In the PowerMILL explorer, right-click on Feature Sets and from the local 

menu, select Create Feature Set. 

                

A new (empty) Feature Set - 1 will appear in the PowerMILL explorer and the 

Feature dialog will open ready to build the 2.5D form. 

5 Select the larger, rectangular Pattern segment and enter values exactly as 

shown in the above right Feature dialog before clicking Apply (Do not close the 

dialog). 
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The first Feature is the outer component body defined as a Boss (as shown 

above). 

 

 

 

6 Select both, the rectangular segment (with corner fillets) and the large 
circular segment. 

7  Enter values exactly as shown in the above left Feature dialog before selecting 

Apply (Do not close the form). 

 If you close the Feature dialog it can be re-opened in the PowerMILL 
explorer by a right click on the Feature and then from the local menu 

select Settings. 
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8 Select all of the Dia 6 circles (12) and enter values exactly as shown in the 

above left Feature dialog before selecting Apply. 

                                       

The contents of the Feature Set (1) should be similar to the above illustration 
(Note: A naming system has been deployed where a Boss is prefixed with a B, a 

Pocket with a P, and a Hole with an H). 

The Feature Set is now complete and ready for the creation of suitable 2.5D 
machining and Drilling strategies. 

2D Feature Set Machining 
1 Define a Dia 10 - tiprad 1 - Length 50 tool named D10TR1. 

2 Click  to open the Block dialog, set the Type as Feature and the select 
Calculate. 

3 Click  to open the Rapid Move Heights dialog and select Calculate. 

4 Click  to open the Toolpath Strategies dialog and select 2.5D Area 
Clearance. 

5 Select Feature Set Area Clearance and input the data exactly as shown in the 

following dialog. 
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6 Click Calculate to process the toolpath and then click Cancel to close the 

dialog. 

             

7 Select Feature Set Profile and input data exactly as shown in the following 
dialog. 
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8 Select Calculate to process the toolpath and then Close the dialog. 

             

 Note the tool is plunging directly onto the form down Z. This situation will be 
changed retrospectively by applying appropriate options in the Leads and 

Links dialog. 

9 In the main toolbar select  to open the Leads and Links dialog.  

10 For Lead In - 1st Choice select Pocket Centre and then select the Copy to 

Lead Out option followed by Apply. 
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11 Define a Dia 6 Drill of Length 50 and named Drill6. 

12 Click  to open the Strategy selector dialog and select the Drilling tab. 

 

 

13 From the list, select Drilling to open the Drilling dialog (below) and then click 

Select to open the Feature Selection dialog.        
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14 In the Feature Selection dialog, click Select to include all of the defined holes 
in the Feature Set. 

 

15 Enter other data into the Drilling dialog exactly as shown above before clicking 
Calculate. 

16 Close the Feature Selection and Drilling dialogs. 
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2D Machining Exercise 
For this exercise the following 2D drawing will be used: 

 

1 Select File > Delete All and Tools > Reset Forms  

2 Import the 2D wireframe model (as shown above): 

......\Powermill_Data\Models\2d_Wizard_Example.dgk  

3 Save Project As:- 

......\COURSEWORK\PowerMILL_Projects\2D_Wizard_EX1 

 

4 Create appropriate Feature Sets to the above drawing dimensions. 

               

1st Feature Set 

The outer square and small tapered, central upstand are created as Boss Features. 

The intermediate square is created as a tapered Pocket Feature. 

The four Dia 15 circles are created as Hole Features. 

2nd Feature Set 

The Slot Feature is best created in a second Feature Set. 
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5 Create a Dia10 End Mill named EM10 (Roughing, Semi-finishing of main Pocket 

and Finishing of Slot Feature). 

6 Create a Dia 10 Tapered Tipped tool named D10Tr3A5, with Tip Radius 3, 
Taper Angle 5Deg, Length 25, Taper Diameter 7.5 (Final Finishing of tapered 

walls Main Pocket and small Boss). 

7 Create a Shank of length 30 and 2 Holder entities (Lower Dia 20 and Upper Dia 

30) both of length 25.  

       

 To calculate the Taper Height based on the Taper Angle and base Taper 

Diameter, the Manual Input icon , adjacent to the Taper Height, is clicked 

to apply the Calculate option  to this parameter. 

                                   

8 Create a Dia 15 Drill named Drill15. 

9 Create suitable 2D machining strategies to produce an end result similar to 

that shown in the following ViewMill simulation. 
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Suggested Strategies: 

Main Block and Central Pocket 

EM10 - Feature Set Area Clear – Offset all 

                     

               

D10Tr3A5 - Feature set Profile  

 

                

Drill15 - Drilling 
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The Slot will be machined independently from the main pocket and for this 

reason it will be created it in a separate Feature Set.  

 The Y dimension of the existing Block will have to be adjusted to fully, 
include the Slot Feature. 

 

EM10  - Feature Set Profile 

                

 

The required Slot width is achieved by creating 3 toolpaths using the 3 
different Slot cutting options, starting with Centreline, followed by Keep 

left, and then Keep right. 

 

 



PowerMILL 2013 12.   2D machining 

Copyright © Delcam plc  12 - 13 

Creating Features directly from holes in the Model 
As well as being able to use imported 2D geometry, Hole Features can be 

automatically defined from selected Holes in the 3D Surface or Solid model. 

1 Select File > Delete All and Tools > Reset Forms. 

2 Select File > Import Model: 

......\PowerMILL_Data\Models\3Axis-drilling 

 

3 Make sure the Block is not defined at this stage, as the top of the Hole 

Features will be created at the nearest Z dimension (Max or Min) of the Block. 
This is more than likely to result in some holes being created the wrong way up 

(It is however possible to reverse a Hole Feature). 

4 Select the whole model. 

5 In the PowerMILL explorer, right-click Feature Sets and from the local menu 

select Recognise Holes in Model. 

 

6 Input data into the Feature dialog exactly as shown above and click Apply. 

7 Undraw the model. 
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A Hole Feature is created for each of the 33 selected, Hole elements within the 

model (including the Chamfers and Counter-bores as separate Features). 

Hole Feature creation using Compound Holes 

8 De-Activate and un-draw the Feature (1). 

9 Draw and select the whole Model again. 

10 In the PowerMILL explorer, right-click Feature Sets and from the local menu 
select Recognise Holes in Model. 

 

 

11 Input data into the Feature dialog exactly as shown above and click Apply. 

This time 17 items are created in Feature Set (2), with the Chamfers and Counter-

bores being contained as compound items within the relevant Hole Features. 
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For example; The Compound Hole Feature H_11 consists of a Chamfer, 
Counterbore, and the main Hole. If required all of these sub-items can be 

dimensionally modified independently of each other. 

 

Left click on one of the sub-items on the image in the above Feature dialog and the 

specific dimensions can be edited as required. 

 

12 Calculate a Block using Defined by - Box and Type - model. 

13 Calculate the (default) Rapid Move Heights. 

Before suitable tooling can be selected to perform appropriate Drilling operations it 
is necessary to obtain dimensional information from the Hole Features. This can be 

obtained by opening up the individual Features in the PowerMILL explorer.  

 

 

Alternatively, if it is just the different Diameters that are required then this can be 

obtained from the Select filter in the Drilling strategy dialog. 

 

14 Click  to open the Toolpath Strategies dialog and select Drilling. 

15 From the Drilling options select Drilling. 

16 In the Drillling dialog left click on the Select tab to open the hole selection 

filter. 
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In the Feature Selection dialog an individual Component of a compound hole 
Feature can be selected. The full list of Component options include:- Largest, 

Last, First, Second, Third, Forth, Fifth. This selection is in addition to the Select 

by:- Diameter, Depth, etc, options. 

 

EXERCISE 

17 Define suitable tools, then drill and counter bore the Holes using the Drilling 
dialog options. 
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Hole Capping 

Hole Features can be used as the basis for capping holes in the 3D model. If the 

intersection of the hole and the top face is non-planar, PowerMILL will cap the hole 
with a surface that follows the tangency of the surrounding 3D model.  

Example 

The following example illustrates the process of capping cylindrical Hole Features 

defined from a 3D model. 

1 Select File > Delete All and Tools > Reset Forms. 

2 Import the model: 

......\PowerMILL_Data\ Block_with_holes.dgk 

            

 

3 Calculate a Block using Defined by - Box and Type - Model (In this case the 

Hole Features will be created upside down). 

4 Select the whole model by by dragging a box over it while the left mouse button 
is depressed. 

5 Select Recognise Holes in Model. 
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In this case the tops of the Hole Features are positioned at the shortest 

distance from the face of the Block. In this case all Hole Features are created 

upside down.  If the Block had not been defined prior to this, then the Hole 
Features would have been created the ‘right way up’ relative to the Z Axis. 

Any Hole Features that are created to a different orientation from the original Z 
Axis, will automatically be assigned to a separate Feature Set and assigned 

Workplane. 

In this case the holes were deliberately created upside down to illustrate the 
Reverse Holes editing option. 

         

6 Right-click Feature Set 1 and in the menu click Select All followed by Edit > 

Reverse Selected Holes. 

 

7 Finally, select the top surface of the Model and in the PowerMILL explorer, 

right-click Feature Set 1 and select the Cap Holes option. 



PowerMILL 2013 12.   2D machining 

Copyright © Delcam plc  12 - 19 

The new Capping Surfaces will be generated (Tangential to the selected top 

surface) in a new model called Capping Surfaces created along with a new level 

of the same name.  

 

8 Click the light bulb to undraw Feature Set 1 ( ). 

9 Expand Levels by clicking on the + symbol ( ). 

10 Click the light bulb to undraw main surfaces ( ). 

The new Capping Surfaces may be created inside out (Surface Normals reversed). 

If required they can be selected and from the local Surfaces menu, Reverse 
Selected can be applied. 

 

 

 The Capping Surfaces are automatically assigned to the new Level for 
easy selection. 

 

11 Click on the light bulb on the Block with holes level to re-display the main 
model. 
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Thread Milling 

 

Thread Milling is included as one of the options in the Drilling dialog. 

If the Cycle Type - Thread Milling option is selected, the tool plunges centrally to 
a specified depth, leads on to the sidewall, and then pitches upwards before leading 

off. 

Within the options it is possible to apply a number of passes (stepping outwards by 
an allowance value) to avoid tool overload. It is also possible to choose either a 

Right Hand or Left Hand thread. 

1 Select File > Delete All and Tools > Reset forms. 

2 Open the Project: 

......\PowerMILL_Data\Projects\ThreadMILL1-Start 

 

 

3 Select File > Save Project As: 

.....\COURSEWORK\PowerMILL-Projects\ThreadMILL-Example1 

4 Activate the Thread Milling Tool named M40-Coarse-Pitch-5. 
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5 Activate the Pocket Feature around the centre wall of the component. 

6 Select Toolpath Strategies  and in the Strategy Selector dialog, select 
Drilling. 

      

7 In The Drilling dialog, set the Cycle Type to Thread milling, Radial 

Thickness -3, Pitch 5, Name M40-RH-Thread, leaving all other parameters as 

default (as shown below). 

 

8 Calculate the form and then Close the dialog. 
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9 Calculate a new Block using Defined by - Box and Type - Model. 

10 Right-click the NC Program MC-All (Do not activate it) and in the local menu 

select Simulate from Start.  

11 Open a new ViewMILL session and run a simulation of all toolpaths. (Do not 

activate the toolpath, otherwise the current Block definition will change). 

 

The completed ViewMILL simulation is as shown above. 

 

12 Select File - Save Project. 
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2D Curve Machining 
PowerMILL contains 4 strategies that directly operate on 2D Pattern segments. 

These include: 

� Face Milling. 

� 2D Curve Area Clearance. 

� 2D Curve Profile. 

� Chamfer Milling. 

Example 1  
1 Select File > Delete All and Tools > Reset Forms. 

2 Open the Project: 

......\PowerMILL_Data\Projects\Pro-2DMachiningStart 

 

 

3 Select File > Save Project As: 

......\COURSEWORK\PowerMILL-Projects\PRO-2DMachining 

 

4 Activate the Pattern named CurveAll.  

5 Calculate a Block using Defined by - Box and Type - Active Pattern (Do not 

close the dialog). 

6 In the Maximum Z co-ordinate box input 22 before selecting Accept to close 

the dialog. 
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7 In the Rapid Move Heights dialog select Calculate. 

8 Activate the Face Milling tool named D50T6. 

9 From the 2.5D Area Clearance options select Face Milling and enter data into 

the dialog exactly as shown below. 

 

10 Click Calculate to create the toolpath and then Close the dialog. 
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11 Activate the Tip Radiused tool named D16T3. 

12 In the 2.5D Area Clearance options select 2D Curve Area Clearance and 

enter data into the form exactly as shown below. 

        

13 Select the Cut distances page and input Stepdown 10. 
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14 From the main Curve area clearance page, Curves definition, select 

Interactively modify machinable sections . 

These options enable the user to have full control of direction of cut and the areas 
to be machined. 

 

 While the Curve Area Clearance form is open, the areas to be machined 
are displayed as a shaded preview. 

15 Select  to exit the Edit Machininable sections toolbar. 

16 Select Calculate to create the toolpath and then Close the dialog. 

17 Activate the End Mill named EM16. 

18 From the 2.5D Area Clearance options select 2D Curve Profile and enter data 

into the dialog exactly as shown below. 
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19 Select the Cut distances page and input Stepdown 25.  

 

20 Click Calculate to process the toolpath and then Close the dialog. 

 

21 Activate the Chamfer Tool named D25TrA45. 
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22 From the 2.5D Area Clearance options select Chamfer milling and enter data 

into the dialog exactly as shown below. 

 

23 Select the Cut distances page and input Number of cuts as 1. 

 

 

24 Click Calculate to process the toolpath (Do not close the dialog). 
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The resultant Chamfer milling strategy has appeared (incorrectly) on the outside 

of the Pattern segments. 

The toolpath needs to be recycled with the Chamfer Milling tool tracks changed to 
appear on the inside of the Pattern segments. 

 

25 In the Chamfer milling dialog, select the Recycle icon to enable changes to be 

made to the above strategy. 

26 Select Interactively modify machinable sections  to access the Edit 

Machinable Sections toolbar. 

27 Select the Reverse machining side option, followed by  to accept the 

changes and close the toolbar. 

 

28 In the main Chamfer milling dialog, select Calculate to create the toolpath 
and then Close the dialog. 

 

The Chamfer milling options selected result in the angled part of the tool 

overlapping the base of the chamfer by 1mm. 
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A 3D model of the finished component has been imported to provide a visual 

check of the Chamfer machining.  

29 Run a ViewMILL simulation of the whole machining process. 

 

 

 

Cutter Compensation Example 
Where applicable a Cutter Compensation page is available in a 2.5D Machining 
Strategy dialog explorer options. 

30 Select File - Delete All and Tools - Reset forms. 

31 In the PowerMILL explorer right click on Patterns and from the local menu 
select Create Pattern. 

32 Rename the Pattern as Profile1. 

33 Right click on the new Pattern and from the local menu select Curve Editor. 

 

34 Select Rectangle  from the lines options. 

                                    

35 In the data input box (below the graphics area) input 0 to set the 1st corner of 

the rectangle, followed by 100 50 to define the X Y dimensions. 
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36 Select Rectangle  from the lines options again to deselect it. 

37 Select the green tick to close the Curve Editor and accept the rectangular 

Pattern. 

38 In the PowerMILL explorer right click on Workplanes and from the local 

menu select Create Workplane.  

39 In the Workplane Editor toolbar, select the green tick save the new 

Workplane the default 0 coordinate position. 

40 Activate the new Workplane. 

41 Create a Dia 10 End Mill named EM10.  

42 Calculate a Block using Defined by – Box and Type – Active Pattern. 

43 Input the value Min Z as -20 and then lock  both Min Z and Max Z values. 

                 

44 Input Expansion 15 and then select Calculate to add stock to the X and Y 
dimensions of the Block. 
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45 In the Rapid Move Heights dialog select Calculate. 

46 In the Strategy Selector form select the 2.5D Area Clearance options. 

47 Then select the 2D Curve Profile strategy and enter data as shown in the 
following illustration.  

 

 

48 Select the Cut Distances page and input 20 for both the Stock depth and the 

Stepdown. 

 

49 Return to the Curve Profile page and select the Edit Machining Sections 
options. 

 

50 If required, select Reverse machining side   to move the profiling pass to 
the outside of the Pattern. 
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The above preview shows the cutter being switched from the inside to the outside of 
the Pattern prior to calculating the toolpath.  

 This toolpath will not contain any data that relates to Tool Compensation 
output. 

 

51 Select the green tick to accept the changes and exit Edit Machining Sections. 

52 Calculate the Curve Profile toolpath. 

     

53 Open the Leads and Links form and select Lead in – Horizontal Arc – Angle 

110 and Rad 10. 

54 Copy the Lead In settings to Lead Out.  

55 Select Extensions and input Extended move 10 for both Inward and 
Outward. 

56 Apply the Leads and Links settings to the active toolpath. 

57 Right click on the active toolpath (EM10-Profile-NoComp) and from the local 

menu select Settings to open the Curve Profile dialog. 

58 Once the Curve Profile dialog is open select the Make a Copy option.  

59 Rename the new toolpath as EM10-Profile-FullComp. 

60 Select the Cutter Compensation page, tick the CNC cutter compensation 

box, and select Type as Full radius. 
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61 Calculate the new Curve Profile toolpath, but do not close the form. 

62 Select the Make a Copy option again.  

63 Rename the new toolpath as EM10-Profile-WearComp. 

64 Select the Cutter Compensation page, tick the CNC cutter compensation 
box, and select Type as Tool wear. 

 

65 Calculate the new Curve Profile toolpath, and then Close the dialog. 

 The cutting moves for EM10-Profile-FullComp using the Full Radius 

compensation are output dimensionally on the actual 2D Curve. 

The cutting moves for EM10-Profile-WearComp and EM10-Profile-

NoComp are dimensionally output to include the tool radius offset from the 
original curve.  

For the 2 toolpaths with compensation applied, the heid NCData output file 

will include an RL code. This allows the operator to input and apply 
compensation values into the machine tool controller, registry as required. 

 

66 Save Project As:-  

 ......\COURSEWORK\PowerMILL-Projects\ToolCompExample 
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Viewing the NCData output files for a heid controller 

67 In the PowerMILL explorer, right mouse click on NC Programs and from the 

local menu select Preferences. 

 

68 Open the folder containing the Machine Tool Option files and from the list 

select the file heid.opt and click the Open tab. 

69 Apply and Accept the NC Preferences dialog. 

70 In the PowerMILL explorer right mouse click on Toolpaths and from the local 

menu select Create Individual NC Programs. 

71 Right mouse click on NC Programs and from the local menu select Write All. 

72 Minimise the PowerMILL window to access the Desktop options and select 

Windows explorer. 

 

73 Once Windows explorer has opened browse to C:\temp\NCPrograms. 

 

 

74 In Windows explorer, right mouse click on an NCdata output file and from the 

local menu select Open with – Wordpad. 

75 Repeat stage 73-74 for all 3 NCdata output files and compare the output. 
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Full Compensation                                      Wear Compensation 

             

 The output file using Full Compensation is exactly matching the geometry 
of the 100 X 50 rectangular Pattern. 

 The output file using Wear Compensation is offset by 10mm (the cutter 
radius) outside the 100 X 50 rectangular Pattern. 

Displaying the compensated toolpath for Full radius 

The cutting moves for EM10-Profile-FullComp with the Full Radius compensation 

can be displayed in PowerMILL as would be output to an NCdata output file. 

 

76 Activate the toolpath EM10-Profile-FullComp. 

 

77 Select   on the Toolpath toolbar. 

 

The fully compensated toolpath, EM10-Profile-FullComp is visually displayed as 

shown above.  

78 Save Project As:-  

 ......\COURSEWORK\PowerMILL-Projects\ToolCompExample 
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Protected Cutter Compensation 

 

With Type – Full radius selected any internal (concave) corners will require a 

suitable Minimum radius value included to allow for corner radii that are less than 

the required full offset value. 
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2D Curve Machining Example – Inc. Clamp Avoidance  
1 Select File > Delete All and Tools > Reset forms. 

2 Open Project: 

......\PowerMILL_Data\Projects\2DCurveProfileSplit-Start 

 

The imported Project also contains a Dia25 End Mill and a Pattern defining the 2D 
geometry used in the existing 2D Machining Strategy.  

 

3 Select File > Save Project As: 

......\COURSEWORK\PowerMILL-Projects\2DCurveProfileSplit-EX1 

 

 

The existing 2D Curve profile toolpath is clearly passing straight through the defined 

clamp positions. This will be fixed by applying the Split Section option that is 
accessed from the 2D Curve Profile form. 

 

4 Select a View down Z. 

5 Ensure that the Pattern - OuterForm is displayed (PowerMILL explorer, light 

bulb on). 
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6  Right click on the toolpath EM25-FullProfile and from the local menu ensure 

Activate is ticked, and then select Settings. 

7 Once the Curve Profile form is open select the Make a Copy option.  

8 Rename the new toolpath as EM25-SplitProfile. 

 

9 On the Curve Profile page select Interactively modify machinable sections. 

 

 

10 While the above toolbar is open, move the cursor to a point on the left hand side 
of the Pattern segment, and then right click to open the local menu. 

 

11 From the local menu select Split Section and an extra start and end point will 

be created on the Pattern at this point. 
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12 From the main pull down menus select Draw – Cursor – Cross Hair (Ctrl H). 

 The cross hair will be displayed on the cursor to assist with alignment of 
start and end point. 

13 Using the left mouse key, drag the new green - start point along the Pattern to 
a position to the right of the upper left clamp (as shown below). 

 

 

14 Locate and drag the corresponding red - end point to a position to the right of 

the lower left clamp (as shown above). 

15 Repeat the process on the other span and drag the start and end points to the 

left hand side of the Pattern (as shown above). 

16 Split the toolpath again twice, to the left of both the upper and lower right 
clamps (as shown below). 

 

17 Move the new start and end points to form 4 distinct spans along the Pattern as 

shown in the following diagram. 

 For accurate alignment use the displayed cross hairs and key points. 
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18 Once the 4 new spans have been aligned, select the green tick in the Edit 
Machining Sections toolbar to accept the modifications. 

19 Back in the Curve Profile machining form select Calculate to process the new 

EM25-SplitProfile toolpath and then Close the dialog. 

 

To check visually check the toolpath for collisions, a triangle model of the stock 

along with the clamps will be imported and used as the ViewMILL block. 

 

20 Select an ISO1 view. 

21 Right mouse click on the toolpath EM25-SplitProfile in the PowerMILL 
explorer and from the local menu select Simulate from start. 

22 Open the Block form and select Defined by – Triangles and Coordinate 
System - Global Transform (See diagram on next page). 

23 Select the Load block from file option  and browse to the model:-          

     ......\PowerMILL_Data\Triangles\2DCurveprofileSplit.dmt 

24 Accept the Block form. 
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The Block will appear as shown below (Opacity slider set to full)) 

 

 

 

25 Connect ViewMILL to the toolpath simulation and run with the Rainbow 

Shaded Image option set. 

 

The tool is no longer crashing through the clamp positions. 

26 Select File - Save to update the stored Project. 
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Introduction 
Once a series of toolpaths have been generated their names can be listed in an NC Program file 

to be post processed as an output file for a specific NC machine control. Any number of 

toolpaths can be included and reordered as required depending on the limitations of the 

particular NC machine along with the associated post processor. 

If the NC machine has a tool change facility then toolpaths created with different cutter sizes can 

be included in the same NC Program. 

If the NC machine does not have a tool change facility then only toolpaths created with the 

same cutter can be included in the same NC Program. 

1 Select File > Delete All and Tools > Reset Forms. 

2 Open the ‘read only’ Project:  

......\PowerMILL_Data\Projects\NCProgram-Start 

3 Select File > Save Project As:- 

......\COURSEWORK\PowerMILL-Projects\NCProgram-ex1 

4 From the top menu bar, select Tools > Customise Paths. 

5 In the PowerMILL Paths dialog, select NC Program Output followed by Add 

path to top of list . 

It is now required to define a path to where the Post Processed files (NCdata) 

are to be stored. 

 

6 In the PowerMILL Paths dialog, Select NC Program Output and add the new 

path C:\temp\NCPrograms. 

13. NC Programs 
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 The destination folder for NCPrograms must exist on your pc otherwise it 

will not be possible to output the NC Program files. 

 

7 Click OK.  

The Use Project - On option 

An alternative method to control the destination for NCdata output is to set the active 

Project as the default, destination for outputting NC Data files. In the NCPrograms - 

Preferences form, switch Use Project to ON. 

 

On applying the Write command on an NC Program a folder named NC Programs will be 

created in the individual Project folder containing the associated NCdata output file.  
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Setting the NC Preferences 
1 In the PowerMILL explorer, right-click NC Programs and select Preferences. 

 

2 In the NC Preferences dialog, select the folder icon to access the machine tool, 

Option File list. 

 

3 From the Select Machine Option Filename dialog (below), select the 

heid426.opt and click the Open tab. 

 



13. NC Programs PowerMILL 2013  

13 - 4  Copyright © Delcam plc 

The selected option file determines which Machine Tool output language is 

applied to the NC Program. 

 It is not unusual to have more than one Option File for the same machine 

tool to allow for different operational requirements. 

4 Click Accept on the NC Preferences dialog. 

Creating the NC Program 
1 In the PowerMILL explorer, right-click on NC Program and from the local 

menu, select Create NC Program. 

 

2 Enter the name Job_646_top and click Accept. 

 

3 In the PowerMILL explorer select the +/- box by NC Programs to toggle a 

display of the contents (Job_646_top) on or off.  
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One or more Toolpaths can be added to the active, NC Program. 

4 Select the Area Clearance icon with the left mouse button and keeping it held 

down drag the mouse to the right (The cursor will display ghosted icons). 

 

5 Continue to drag the toolpath onto the active NC Program, Job_646_top and 

release the mouse button. In the PowerMILL explorer, NC Programs area 

select the +/- box by Job_646_top to toggle a display of the contents 

(Roughing_16). 

6 Drag the other toolpaths into the last file in the active NC program area to 

maintain the required machining order. 

 

 You can remove individual toolpaths from the NC Program list. 

 

7 Right-click any of the toolpaths in the current NC Program to access the local 

Toolpath options, but do not apply any of the options at this stage. 
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8 Right-click on the NC Program (Job_646_top) and select Settings. 

 

 You can open (and edit) the NC Program form current by selecting 

Settings from the local right click menu. 

 

 Several of the settings assigned to a specific toolpath can be changed in 

the above dialog. The toolpath row is selected and relevant values (Tool 

Number, Coolant, etc) are then modified before clicking Apply. These local 

eidts do not affect the original toolpath.  

9 Click Accept. 
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10 Right-click on the NC Program, Job_646_top and select Write to create the 

Post-Processed output file. 

During the translation an Information window appears containing a progress 

report. 

 

Newly created Toolpaths are automatically added to the Active NC program. 

It can be useful to Create and Activate an NC Program prior to toolpath 

creation to save having to drag them in later as a separate operation. 

11 De-activate the NC Program, Job_646_top in the PowerMILL explorer. 

12 Calculate a 3D Offset Finishing toolpath, named 3Doffset-test1 using the 

settings and values as shown below. 
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 It is not always required to output all toolpaths in one NC Program. As a 

result it is possible to create an NC Program directly from an individual 

toolpath entity. 

13 Right-click on the toolpath named 3Doffset-test1 and select Create Individual 

NC Programs. 

 

14 A new NC Program is created. Select the + symbol to the left of NC Program 1 to 

access its contents (the + symbol will change to a - symbol). 

 

15 Right-click on the NC Program, 3Doffset-test1 and select Write to output the 

post-processed file. 
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Viewing the NC-Data output 
Once Post-processed, the NC Data output file can be viewed directly from the local menu. 

� Right-click on the NC Program, Job_646_top and from the local menu, select 

View File. 

 

An Information dialog will open to enable the user to view (but not edit) the 

contents of the NC Data output file.  

Manually Editing the NC-Data output 
If the user needs to edit the code manually, then the NC-Data output file will have to be edited 

in Wordpad. 

1 From Windows Explorer, browse to C:\temp\NCPrograms to where the NC-

Data files are downloaded.  

2 Right-click on one of the NC-Data files and from the local menu, select Open 

With > Wordpad. 

 

3 From the main (top) toolbar select File > Save to update the Project followed 

by Close. 
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Introduction 
All the Setup data required from a PowerMILL Project such as cutter 

definitions, images and information relating to toolpaths can be downloaded as 
HTML files and then printed out as required. This is essential for the CNC Operators 

who will be running the programs. 

1 Select Delete > All and Tools > Reset forms. 

2 Open the Project:  

......\PowerMILL_Data\Projects\SetupSheet-Start 

 

3 Select Save Project As: 

......\COURSEWORK\PowerMILL_Projects\SetupSheet-ex1 

4 From the main pulldown menus select Tools > Options > Setup Sheets > 
Setup Sheets, and tick the box Load Setup Sheets with Project.  

 

5 Accept the form. 

14. Setup Sheets  
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6 In the PowerMILL explorer right-click on NC Programs and select Setup 

Sheets > Settings… 

 

 

7 In the Project Settings dialog, enter the information as shown below and select 
Close. 

 

 There are 2 other tabs for the user to input further information as User 
Defined Settings and Project Notes. 
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8 Ensure that no tools or toolpaths are visible and only the shaded model and 

wireframe Block (minimum Opacity) are displayed in an ISO 1 view. 

 

9 Right-click on the NC Program named MC-All and from the local menu select 
Setup Sheets > Snapshot > Current View. 

 

An image of the model has now been captured and will be automatically used on 
the front page of the setup sheet. 

10 Undraw the model leaving the wireframe block as the only displayed item. 

11 Ensure that the NCProgram - MC-All is displayed (light bulb icon on). 

12 Right-click on the NC Program - MC-All again and select Setup Sheets > 

Snapshot > All Toolpaths > Iso View. 
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Images of all the toolpaths in the selected NC program have now been 

captured. 

Each toolpath will have a separate page on the Setup Sheet. 

13 Right-click on the NC Program - MC-All again and select Setup Sheets - 

Preview. 

This action will create the Setup Sheet, HTML files. 

The PowerMILL Setup Sheets: Index is displayed on the left side of the 

screen. 

 

 

14 In the above Index dialog left click on Project Setup Sheet-ex1 to display the 

following sheet. 

 

 

15 From the Index page select the Toolpath and Summary pages in turn and 

view the content. 
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 Each HTML page can be printed out as individual items. Right-click on the 
page and from the local menu, select Print Picture. 

 

The 1st sheet of the Summary Page is as shown below. 

 

16 Right-click on the NC Program - MC-All and select Setup Sheets > Export. 

 

 Export stores all the Setup Sheets as HTML documents into the current 
Project Folder. 

Setup Sheets can be printed internally from PowerMILL or externally from 
the Exported HTML documents. 
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Inputting of Text onto a Setup Sheet > Toolpath Page 
1 In the NC Program, MC-All, right-click on EM16-Rgh-A1 and from the local 

menu, select Setup Sheets > Snapshot >Enter Snapshot Mode. 

 

2 Once the Snapshot context toolbar appears left mouse click in the graphics area 

to open the Edit Snapshot Annotation.  

 

3 Change the Font Size to Large, input the above text, and in the Graphics area, 

left mouse click at the required position before clicking Accept. 

 

 

4 Select the Save snapshot as current view option.  

5 Select the Green tick to accept and close the Annotation toolbar. 

The setup sheet will be re-processed to include the above text.  
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6 To view the modified snapshot, right-click on Roughing_16F in the NC 

Program and select Setup Sheets > Snapshot > Preview. 

 

The toolpath and text image shown on the previous page will be displayed in the 
Preview. 

7 Switch from the Preview window  back to the PowerMILL explorer . 

8 From NC Programs, right-click on MC-All and from the menus select Setup 
Sheets > Preview. 

 

 

9 From the Index, select the Toolpath EM16-Rgh-A1 to display the relevant 

HTML setup sheet page. 
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Customising Setup Sheets 
By editing the HTML templates it is possible to customise the output of the Setup 

Sheets. 

The use of HTML editing software is the recommended method to implement 
changes to the Setup Sheet output. There are free downloads available from the 

web. Microsoft Word can also be used but this can give unpredictable results. 

 Always create a copy of the template document so that the original is still 
available if things go wrong. 

In the following example an alternative template will be substituted into the Setup 

Sheet Toolpath Template search paths. 

1 Right-click on the NC Program named MC-All and select the option Setup 
Sheets > Paths. 

 

2 On the Paths tab select the folder icon in the Toolpath > Write field. 
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3 Browse to ......\PowerMILL_Data\setup-sheets and Open the 

Toolpath2.html file (customised template). 

 

4 Close the form. 

5 Click Close on the Setup Sheets dialog. 

6 Right-click on the NC Program named MC-All select the option, Setup Sheets 

> Preview and re-run the Setup Sheets using the new template. 

7 On the Index page select the new page for the toolpath Roughing_16F 

(Shown below) 
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Projection Machining. 
Projection Finishing provides greater control of the projection direction of 

machining strategies onto a component. Applications include the machining of 
undercut features using specialist tooling and a more accurate finish for features 

positioned at complex angles to the tool axis. Projection Finishing is also an 

essential strategy for use with Five Axis tool alignment applications. 

There are five different strategies Point, Line, Plane, Curve, and Surface 

Projection. 

 

The simplest way to understand the principle of projection machining is to regard 

the first four strategies comparable to beams of light radiating into or away from a 

defined source.  

� A Point strategy is similar to light radiating from a single light bulb. 

� A Plane strategy is similar to light radiating from a rectangular floodlight. 

� A Line strategy is similar to light radiating from a fluorescent tube. 

15. Specialist Finishing 
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� A Curve projection strategy is similar to light radiating from a curved neon tube. 

� A Surface projection projects the tool Inwards or Outwards along the normals of 

a selected surface. 

In the Finishing dialog, the projection Direction can be toggled between 

Outwards and Inwards from the user defined plane.  

In the Projection Finishing forms, angular definitions are input using Azimuth 

and Elevation. By using a combination of the two any complex 3D angle can be 

defined. 

� Azimuth Angle:- Starting from +X = 0 this is the angle anticlockwise around 

the Z axis. 

 

This is shown on the chamber model, with a view looking down the Z-axis. 

� Elevation Angle - this is the upward angle from the XY plane 

 

This is shown on the chamber model, with a view looking down the X-axis. 
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Plane Projection Example 
All five Projection Finishing strategies can be used to machine undercut features 

if used with suitable tooling such as Disc or Spherical. The following example shows 

an undercut application using the Plane Projection strategy. 

1 Select File - Delete All and Tools - Reset Forms. 

2 Select File > Open Project: 

......\PowerMILL_Data\Projects\Heatsink-Ucut-Start 

 

3 Save the Project As: 

......\COURSEWORK\PowerMILL_Projects\ Heatsink-Ucut-EX1 

4 Open the Block form and with Defined by - Box and Type - Model set select 
Calculate. 

5 Simulate both of the existing toolpaths in ViewMILL. 
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6 Return the ViewMILL simulation to the No-Image view . 

7 Disconnect ViewMILL from the simulation . 

8 Activate the D75-H4-T1 Disc Cutter. 

9 In the Block dialog lock the X and Z values. 

10 Calculate the Y values of the Block with an Expansion value of 40. 

 

11 In the Strategy Selector - Finishing dialog, select Projection Plane 

Finishing and fill in the pages of the dialog exactly as shown below.  

 

The Location is the local datum for the projection strategy. All other coordinates 

entered in the dialog are relative to this point. 
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The values for the Start and End heights can be obtained by viewing the model 

in the X direction and using the cursor position to display Z values at the bottom 
right of the screen.  

12 Select Preview to view the Plane Projection pattern. 

 

The Projection Plane > Preview is displayed as shown and the user can 
dynamically alter the view to visually check for potential adjustments. 

When using projection finishing, (Point, Line or Plane), the Anchor Point 

must be positioned (along the projection direction) away from the model by at 
least the cutter radius. 

13 Select Calculate to create the toolpath and then Close the dialog. 
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Observe that the tool is gouging through the fins when it retracts at the end of 

each pass. This is confirmed by the red toolpath, icon displaying an exclamation 

mark in the explorer. 

 

In this case suitable Leads and Links will be applied to easily rectify the problem. 

1 Open the Leads and Links dialog and select the Lead In tab. 
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2 Input the following information: 

1st Choice - Straight 

Distance 45 

Angle  0 

3 Select the Lead Out the same as Lead in tab.  

4 Apply and Accept the dialog. 

 

The toolpath Lead moves are now updated and the red warning icon in the 

PowerMILL explorer has automatically updated to white. 

5 Save, but do not close, the Project as it is to be continued in the next section. 

Surface Projection Example 
Surface Projection will be used for the finishing strategy as it will provide a 

consistent stepover within the undercut regions. To allow this a specially created, 

single, reference surface will be imported (To create this surface the user would 
require the services of a suitable CAD package such as PowerSHAPE). The 

reference surface does not necessarily have to represent the true shape of the 
finished component. In practice it could be positioned inside, outside, or flush with 

the actual model surfaces to be machined. In this example the reference surface 

is flush with the existing model. 

1 Import the additional model: 

......\PowerMILL_data\models\heatsink-ref.dgk 

 

The new imported surface appears as a separate item in the Models section of the 
explorer. This will assist when selecting it as the reference surface to be used with 

the Surface Projection dialog. 
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2 From the main pull down tabs select View - Toolbar - Command to open the 

command input window below the graphics area and type in the following 3 

lines:- 

EDIT SURFPROJ AUTORANGE OFF 

EDIT SURFPROJ RANGEMIN –1 

EDIT SURFPROJ RANGEMAX 1 

This is to restrict the tool projection distance to within 0.5mm of the reference 
surface. Otherwise it would be projected from infinity onto non-undercut faces 

on the outside of the model. 

 

 The default setting is restored by typing EDIT SURFPROJ AUTORANGE 

ON. 

3 From the Toolpath Strategies dialog, select Projection Surface Finishing. 

4 In the PowerMILL explorer, right-click the model, Heatsink-ref and from the 

local pull down menu click Select Surfaces. 
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5 In the Surface Projection Finishing dialog input the settings and data exactly 

as shown below. 

 

 

6 Select Ordering as One way. 

7 Set the Start Corner as: Max U max V 

8 Select Preview. 
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The Preview pattern for the strategy is displayed on the reference surface 
(for clarity, a stepover value of 3 was used in this illustration).  

9 Calculate the toolpath and then Close the dialog. 

 

 The unidirectional toolpath is shown here without the defined Leads and 
Links displayed. 

A suitable Lead In and Lead Out must be applied to prevent the tool 

from gouging through the overhang. 

The application of Surface Projection Finishing has produced a strategy with a 
consistant stepover across all of the undercut areas. 

10 Select File > Save to update the stored Project. 
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Line Projection Example 
1 Select File > Delete All and Tools > Reset Forms. 

2 Select File > Open Project: 

......\PowerMILL_Data\Projects\ucut_proj 

 

3 Select File > Save Project As: 

......\COURSEWORK\PowerMILL-Projects\Line-Projection 

4 Select an ISO 3 view. 

The imported Project (training_ucut_proj) contains a Model, Block, Roughing 
and Semi-Finishing strategies with 1 and 0.3 thickness values respectively. The 

undercut regions have not yet been machined. 

 

5 Activate the toolpath (Rough) to reinstate the settings and then simulate both 
existing toolpaths in ViewMILL. 

Tipped Disc cutters will be used for machining the undercut areas. The toolpath will 

be created by projecting a suitable strategy inwards, towards a vertical line, located 
at the lower, left corner. 

6 Select a View from Top (Z). 

7 Place the cursor over the lower left, corner point without clicking and read the X 

& Y values from the information toolbar located below the graphics area. 
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 The Intelligent Cursor will accurately lock onto the corner providing 

accurate coordinate values. 

 

8 Activate the TD30 cutting tool. 

9 From the Toolpath strategies dialog, select Line Projection Finishing. 

10 Fill in the pages of the strategy dialog exactly as shown below. 
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The values for the Start and End heights were obtained by dynamically moving 

the cursor over the model to obtain the Z values in the cursor coordinate 

boxes at the bottom right of the graphics area. 

 

11 Select Preview. 

The Preview shows the location of the projection line with arrows showing an 
inward projection direction from the pattern. 

 

12 Calculate the toolpath and then Close the dialog. 
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The tool is currently gouging through the overhang at the end of each pass. 

This is indicated by the red colour of the toolpath icon as displayed in the 

PowerMILL explorer. 

 

13 Open the Leads and Links dialog. 

 

14 Select the Lead In tab. 

15 Input the following information: 

1st Choice - Horizontal Arc 

Distance - 5.0 

Radius - 2.0 

Angle - 90 

16 Select the Lead out the same as lead in tab.  

17 Click Apply and then Accept to close the dialog. 
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 The extension value in Leads and Links must be more than the tool 
radius to prevent gouging. 

The red warning icon in the PowerMILL explorer will now have changed 
to green. 

18 Select File > Save to update the stored Project. 
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Point Projection Example 
1 Select File > Delete All and Tools > Reset Forms. 

2 Select File > Import Model: 

......\PowerMILL_Data\Models\radknob.dgk 

3 Select File > Save Project As: 

......\COURSEWORK\PowerMILL_Projects\PointProj-ex1 

4 In the PowerMILL explorer, right-click Workplane 1 and from the local menu 

select Activate followed by Workplane Editor to display the following toolbar: 

 

5 From the toolbar select Twist about Y  to open the the Twist dialog. 

 

6 In Angle, enter 180 and click Accept. 

7 Click the Green tick to accept the changes and close the toolbar. 

 

The Workplane is rotated 180 degrees about Y to provide vertical machining 
access to the inner wall.  However, machining is currently impossible due to the 

pocket being shielded by an untrimmed planer surface (shown part shaded). 
This example will apply Component Thickness options to set this surface to 

be ignored while applying the machining strategy. 

 

8 Create a Dia 16 ball nosed cutter named BN16. 

9 Calculate a Block using Defined by - Box and Type - Model. 

10 Calculate the Rapid Move Heights using the default settings. 

11 From the Strategy Selector dialog, select Projection Point Finishing. 
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12 Fill in the page of the dialog exactly as shown above and select Preview to 

observe the Point Projection setup. 



15. Specialist Finishing PowerMILL 2013 

15 - 18  Copyright © Delcam plc 

 

13 In the main page of the Point Projection Finishing dialog select the 

Component Thickness icon  and I the dialog select the Surfaces tab. 

 

14 Click on any of the 8 rows to display a coloured box at the start. In the graphics 

area, ensure that the only the untrimmed planar, surface is selected. 
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15 Click the Acquire Components icon  to add the selected untrimmed, planar 
surface to the row. 

16 Select Ignore in the Machining Mode box. 

17 Apply and Accept the Component Thickness dialog. 

18 Calculate the Projection Point Finishing toolpath and then Close the dialog. 

 

The inside of the pocket has successfully been machined. This would not have 

happened if the untrimmed surface, blocking access had not been included in a 

Component Thickness list with the Machining Mode set to Ignore. 

19 Select File > Save to update the stored Project. 
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Curve Projection Example 
1 Select File > Delete All and Tools > Reset forms. 

2 Select File - Import Model and select: 

......\PowerMILL_Data\Models\ crvproj_3D.dgk 

(Note the model also includes a wireframe curve running centrally along the 

slot). 

3 Select File > Save Project As:- 

......\COURSEWORK\PowerMILL_Projects\CurveProj-Ex1 

 

4 Calculate the Block using Defined by - Box and Type - Model. 

5 Define a Dia 16 Ball Nosed tool called BN16. 

6 Calculate Rapid Move Heights using the default settings. 

7 In the PowerMILL explorer, right-click Pattern and from the local menu select 

Create Pattern. 

8 Select the wireframe curve running centrally along the slot on the Model 

(Note; The Wireframe view  must be active for the curve to be visible). 

 

9 In the PowerMILL explorer, right-click on the new Pattern (1) and in the 
local menu select Insert > Model. 

10 From the Strategy Selector dialog, select Projection Curve Finishing. 

11 Fill in the page of the dialog exactly as shown above and select Preview to 

observe the Curve Projection setup. 
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Visually the preview strategy is somewhat of a mess, containing crossovers and 

loops along the path. The actual toolpath however should not suffer the same 

problem, with the projection distance to the machining areas being a lot shorter 
(well before loops or crossovers start to appear). 

 

12 Calculate the Projection Curve toolpath and then Close the dialog. 

 

 The Curve used as the basis for the strategy will in the majority of cases 

be created in a CAD package as part of the Model. In these cases the 
imported wireframe curve must then be inserted into a Pattern. 

 

13 Select File > Save to update the stored Project. 
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Swarf Finishing 
Swarf Finishing is specifically designed to machine down one or more surfaces 
where a linear transition exists along the tool alignment direction. It will not work 

where the transition is concave or convex. 

The strategy can be set to create either single (default) or multiple passes, exactly 

following the upper edge, lower edge, or both (merging). 

In the following example the Spar sidewalls will be selected and Swarf machined. 
This will provide a strategy similar in appearance to Constant Z but applied locally to 

the selected surfaces and guaranteed to run the final pass exactly along the bottom 

edge (subject to gouge checking). 

1 Select File > Delete All and Tools > Reset forms. 

2 From File > Open Project select the (read-only) Project: 

......\PowerMILL_Data\Projects\3Axis_SwarfStart1 

 

 

 

3 Select OK in the PowerMILL Warning dialog. 

4 From File select Save Project As: 

......\COURSEWORK\PowerMILL-Projects\3AxisSwarfExample 

5 In the PowerMILL explorer, activate the workplane mc-Datum. 

6 In the PowerMILL explorer, activate the Dia 16 End Mill (EM16). 

7 Calculate a Block using Defined by - Box and Type - Model. 

8 Calculate the Rapid Move Heights using the default settings. 

9 In the PowerMILL explorer, click the [+] adjacent to Levels to display all of 
the named levels. 

10 Right-click on the Level Swarf-MC and click Select Surfaces from the local 

menu. 
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All Surfaces on Level Swarf-MC will be selected (light blue) to be included in the 
Swarf strategy. 

11 Select the Strategy Selector and select the Finishing tab in the dialog. 

12 Select the Swarf Finishing strategy and enter data exactly as shown in the 
following 2 pages of the dialog. 
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13 Select Calculate to create the Swarf Finishing toolpath and then Close the 

dialog. 

 

 The tool tracks that machine the base of the selected surfaces have 

progressively offset upwards (by the stepdown value) until fragmentation 

occurs when the upper edge is exceeded. This can be prevented by using, 
Mode Merge instead of Offset Up. 

 

14 In the PowerMILL explorer, right-click the toolpath EM16-Swarf_OffsetUp 

and select Settings. 

15 Select the Copy Toolpath icon from the dialog . 

16 Rename the new Toolpath as EM16-Swarf_Merge. 

17 In the page labelled Multiple Cuts change the Mode to Merge and with all 

surfaces on the Level Swarf-mc selected, Calculate the strategy. 
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 Merge will use a variable stepdown to exactly track the selected surfaces, 

upper and lower edges and minimize the number of lift moves. 

18 Right-click the last toolpath EM16-Swarf_Merge, in the PowerMILL 

explorer and select Settings. 

19 Select the Copy Toolpath  option. 

20 Rename the new toolpath as EM16-Swarf_SinglePass. 

21 On the Multiple Cuts page, change the Mode to Off. 
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22 With all surfaces on the Level Swarf-mc selected, Calculate the strategy. 

 

23 Close the Swarf Finishing dialog. 

24 Select File > Save to update the stored Project. 

           ......\COURSEWORK\PowerMILL-Projects\3AxisSwarfExample 
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Parametric Offset Finishing 
Parametric Offset Finishing creates a strategy that tracks between two individual 

Patterns with a stepover that adjusts to the shape of the selected surfaces. The 

tool tracks can be created parallel (along) or span between (across) the Pattern 
segments. 

 

1 Select File > Delete All and Tools > Reset forms. 

2 Open the read-only Project: 

......\PowerMILL_Data\Projects\EditToolpaths_3 

 

3 Click OK in the PowerMILL Warning dialog and Save Project As: 

......\COURSEWORK\PowerMILL-Projects\ParaOffset-ex1 

4 Activate the Dia 16 Rad 3 Tip Radiused tool named D16TR3. 

5 With the new tool active, and the surfaces shown (below left) selected, create 

a Selected Surface Boundary. 
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6 Create an empty Pattern, named Upper and Insert the upper Boundary 
segment into it. 

7 Create another empty Pattern, named Lower and Insert the lower Boundary 

segment into it. 

 

 

It is not necessary for both of the Pattern segments to run in the same 

direction as the Upper one will control the toolpath direction. 

 

8 Make sure that no Boundaries are Active. 

9 Open the Parametric Offset Finishing dialog and fill in as shown below. 
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10 Select Calculate to create the toolpath and then Close the dialog. 

 

11 Select File > Save to update the stored Project. 

12 Do not delete the Project as it will be continued in the next section. 
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Parametric Spiral Machining  
This strategy starts from a Pattern and merges a spiral toolpath towards an 

Outer limit which is either defined by the Block or to one or more surfaces 

acquired to a Level or Set. 

 

The direction of the toolpath created in the Parametric Spiral Finishing strategy 

is contolled by the Cut Direction Anticlockwise/Clockwise. The direction of the 
central Pattern has no control over the toolpath direction. 

If the Pocket option is ticked the resultant toolpath will start at the Outer limit. 

 

1 In the PowerMILL explorer right mouse click on Levels and Sets and from 

the local menu select Create Set. 

 

2 Select the base Surfaces and from the new Set (1), local menu select Acquire 

Selected Model Geometry. 

3 Make sure that no Boundaries are Active or displayed. 
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4 Open the Parametric Spiral Finishing dialog and fill in as shown below. 

 

 

 

5 Select Calculate to create the toolpath then Close the dialog. 
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6 Select File > Save to update the stored Project. 
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Wireframe Profile Machining  
Wireframe Profile machining is designed to machine to the left or right of the 

selected curves of a 3D Wireframe. The following example is a pressing that 

requires the outer form and recesses to be finish profiled. As the main imported 
model is in STL (triangle) format it is incompatible with Boundary options that 

operate on selected surfaces. It is also impossible to create the necessary 3D 

Wireframe curves direct from the STL model in PowerMILL. To resolve, the 
stored 3D Curves will be imported into a pattern to be applied in the Wireframe 
Profile Machining strategy. 

 

1 Select File - Delete All and Tools - Reset Forms. 

2 Select File and Import the Model: 

......\PowerMILL_Data\Models\3D-Curve-TriModel.stl 

 

3 Select File > Save Project As: 

......\COURSEWORK\PowerMILL-Projects\3D-WireframeProfile 

4 Create a Dia 5 End Mill named EM5. 

5 Create an empty Pattern, right-click on it, and from the local menu, select 

Insert > File: 

......\PowerMILL_Data\Models\3D-Curve-Wire.dxf 

6 Rename the Pattern as 3Dwire. 

7 With the left mouse click on the model to select it. 

8 In the PowerMILL explorer, right-click on Workplanes and from the local 
menu, select Create and Orientate Workplane - Workplane at Bottom of 

Selection. 

9 Rename the Workplane as MC-Datum. 

10 Right-click on the Workplane (MC-Datum) and from the local menu, select 

Workplane Editor to open the Workplane Editing toolbar. 

 

11 Click Twist about Z  to open the following dialog.  
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12 Enter the value 90 and click Accept. 

13 Click  on the Workplane Editor toolbar to accept the changes and Close. 

14 Activate the workplane (MC-Datum) and select an ISO 1 view. 

 

 The changes will not be physically active until the Workplane Editor toolbar 
has been closed. 

15 Calculate a Block using Defined by Box and Type Model. 

16 Lock the Maximum Z value only and then input an expansion value of 10 

before re-selecting Calculate. 
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The final task prior to machining is to check the directions of the Pattern segments 

and to reverse any that will cause the tool to machine on the wrong side of a 

profile. 

 

17 Right-click on the Pattern (3Dwire) and from the local menu, select 
Instrument to display directional arrows on the individual segments. 

 

Two of the segments (indicated above) must be reversed for the Wireframe 
Profile Machining to Climb Mill to the left of the direction while remaining inside 

the aperture forms on the STL model. 

18 Select the 2 segments (arrowed on the previous diagram) and from the local 

Pattern menu apply Edit > Reverse Selected. 

 

19 Calculate the Rapid Move Heights using the default settings. 

20 Select the Strategy Selector and select the Finishing tab in the dialog. 
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21 Select the Wireframe Profile Machining strategy and enter data exactly as 

shown on the following 2 pages of the dialog. 

 

Curve side controls which side of the Pattern segment direction the tool 
operates. 

Axial offset controls the depth of machining below the wireframe curves. 

 

22 Select Calculate to create the toolpath and then Close the dialog. 
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The Wireframe Profile Machining performs the profiling of the Pattern 

segments in 3D. 

23 Select File > Save to update the stored Project. 
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The Component Thickness dialog enables the user to apply varying Thickness 
and Machining Mode to different parts of the component. This can either be pre-

defined in the Thickness Preference dialog or applied independently within an 

individual toolpath. 

 

The Component Thickness tab allows individual surfaces or solid faces to be 

assigned with different thickness values (Axial and Radial) within a toolpath.  

Other important features in this dialog include the Machining Mode options, 
Ignore or Collision to control machining status on selected parts of the 

component. This is available from the pull-down list consisting of three options: 

� Machine (default) is used to define specific areas of the component to be 
machined with a different Thickness to that that in the main strategy dialog. 

� Collision is used to define areas of the component to be completely avoided by 

the machining process (such as a clamp). 

� Ignore is used to define areas of the component to be made invisible to the 

machining process so that the toolpath will pass through them (such as a 
blanking surface used to prevent toolpath moves into a hole or pocket during 

earlier machining strategies). 

� The Component Thickness options are also available in Boundary creation 
options that include an active Tool as part of the calculation. 

16. Component Thickness 
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Component Thickness Example 
1 Select File > Delete all and Tools > Reset Forms. 

2 From File > Open Project select the read-only Project: 

.....\PowerMILL-Data\Projects\CompThic_Start 

 

The Project contains an unprocessed Interleaved Constant Z machining strategy 
along with a Dia 8 Ball Nosed tool and all essential parameter settings.  

3 Select File > Save Project As: 

.....\COURSEWORK\PowerMILL-Projects\CompThickness-1 

 

 To make selection easier the Clamps will be transferred to a new Level 
(Clamps) while the split surfaces will be copied to a new Set (Splits). 

 

4 In the PowerMILL explorer, create a new Level and rename it as Clamps and 

then create a new Set and rename it as Split. 

 

5 With the clamp surfaces selected, right-click on the Level named Clamps in the 
PowerMILL explorer and from the local menu select, Acquire Selected 

Model Geometry. 

 It will be easier to select and Blank (Ctrl J) all the other surfaces first 
before simply dragging a box over all of the remaining clamp surfaces. 
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6 With the split surfaces selected, right-click on the Set named Splits in the 

PowerMILL explorer and from the local menu select, Acquire Selected 
Model Geometry. 

7 In the PowerMILL explorer switch off the light bulb next to the Set named 

Splits (This is to prevent them still being displayed if the light bulb for the Level 
General is still switched on). 

8 In the PowerMILL explorer, right-click on the unprocessed, Toolpath BN8-a1 
and in the local menu, select Settings to open the Steep and Shallow 
Finishing dialog. 

 

9 Select Component Thickness  to open the following form. 
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With the Machining Mode set to Collision, a Thickness value of 2 will be applied. 

At this safe distance the active tool will either retract or profile around the clamps. 

10 Select the 1st row of the Component Thickness table and a square, colour 
coded symbol (in this case blue) will appear at the start of the row. 

11 With the 1st row still selected, change the Machining Mode to Collision with a 
Thickness value of 2. 

12 Select Smart Selection  to open the following dialog: 

 

13 Switch Select by from Colour to Level or Set. 

14 With Clamps selected in the Levels or Sets box click  to acquire the clamp 

surfaces to the 1st row of the main dialog, and then Close the Selection dialog. 
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The 44 Clamp Surfaces are acquired to the 1st row. 

 

 

15 Apply the Component Thickness dialog to update the settings. 
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16 Select the 2nd row and a square, colour coded symbol (in this case purple) will 

appear at the start of the row. 

 

The Thickness value of 1.0 will control how much stock is left on the acquired 
split surfaces for this strategy. 

 This is in addition to a Thickness value specified in the main machining 
strategy dialog. In the above Component Thickness dialog the sum of 

these is displayed in the Total Thickness column. 

17 With the 2nd row still selected, keep the Machining Mode as Machine but with 

a Thickness of 1. 

 

18 In Smart Selection  select Splits in the Levels or Sets box and click the 

arrow icon  to assign them in the second row of the main dialog. 
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19 Select the 3rd row and a square, colour coded symbol (in this case red) will 

appear at the start of the row. 

 

The cap surface must be ignored during the creation of this toolpath. 

20 With the 3rd row still selected, change the Machining Mode to Ignore with a 

Thickness value of 0. 

21 Use the left mouse key to manually select the cap surface and click on Acquire 

Components  to include it in the 3rd row. 

22 Apply the Component Thickness dialog. 

 

While the Component Thickness form is open, Toolpath Thickness Shade mode 

will be active. Acquired surfaces are shaded in the same colour as the row. 
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23 In the Viewing toolbar select the Toolpath Machining Mode Shade. 

 

 

 

This time, relevant parts of the model are colour coded in Red (Ignore) or Yellow 
(Collision). Where applicable, these colour codes also appear at the end of a row. 

 

24 Accept the Component Thickness dialog. 

25 Select Calculate to create the toolpath and then Close the dialog. 

 

26 Select File > Save to update the stored Project. 

27 Do not close the Project as it will be continued in the next section. 
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Cloning the Component Thickness settings from an 
existing Toolpath 

A Corner Finishing strategy BN5-a1 will now be created using ‘cloned’ 
Component Thickness settings as used in BN8-a1. 

1 From the Toolpath Strategies  select the Finishing option, Corner 
Finishing, and input settings exactly as shown below: 

 

 

 

 

 

2 Select Calculate and have a look at the resultant toolpath in the graphics area. 
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For the moment the Corner Finishing strategy is unable to access the base of the 

central pocket and has also produced unwanted tool tracks around the front edge 
of the clamps. This will be rectified by cloning the Component Thickness from 
the toolpath BN8-a1. 

3 Back in the Corner finishing page, select Component Thickness . 

4 In the Clone area of the form use the downward chevron to display and then 

select the toolpath Bn8-a1. 

 

 

5 Select the Copy Thickness Data icon to Clone the Component Thickness 

settings into the dialog. 
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The Component Thickness settings originally used in BN8-a1 are now cloned 

into the strategy dialog for BN5-a1. 

 The process is not complete until the Apply button has been clicked. 

6 Select Apply followed by Accept to fully update the Component Thickness 

settings in the strategy BN5-a1. 

7 Calculate the Corner Finishing strategy and then Close the dialog. 

 

8 Select File > Save Project 

This will update:-     

.....\COURSEWORK\PowerMILL-Projects\CompThickness-1 
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Modification of existing strategies to allow for 
interchangeable clamping bolts. 

 

The following Project already includes some Strategies to create the 3D 

component form on a pre-machined material Block. All except the initial Face 

Milling strategy need to be modified to accommodate 2 interchangeable pairs of 
clamping bolts aligned along  X and Y respectively.  

 

1 Select File > Delete all and Tools > Reset Forms. 

2 From File > Open Project select the read-only Project: 

.....\PowerMILL-Data\Projects\CompThic-2_Start 

 

 

The individual parts (Component Model, Capping Surfaces, Fixture Plate, and 
Clamping Bolts) are already acquired to suitable Levels. 

 

3 Select File > Save Project As: 

.....\COURSEWORK\PowerMILL-Projects\CompThickness-2 

 

4 Select an ISO 1 view (as shown in the above image). 

5 In the PowerMILL explorer, right mouse click on the Toolpath               
EM25-FaceMill-Top and from the local menu select Activate. 

6 In the PowerMILL explorer, right mouse click on the Toolpath               

EM25-FaceMill-Top and from the local menu select Simulate from Start. 

 

 Before performing a ViewMILL simulation the Block will be modified to 
use a model of the pre-machined material. 
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7 From the main toolbar select the Block dialog. 

 

 

8 Select Defined by > Triangles and Coordinate System > Global before 

selecting the option Load block from file . 

9 In the Open Block from Triangles dialog browse to:- 

C:\Training_Data\PowerMILL_Data\Triangles\CompThic-2_Block.stl and 
select Open.  

 

This Block definition is an accurate model of the pre-machined component. 

 

10 Toggle into ViewMILL and select the Rainbow Shaded Image. 

11 In the Simulation toolbar select the Play button. 

 

12 Select the No Image option  to return to the PowerMILL window and for 

the time being disconnect ViewMILL  from the Simulation. 
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13 From the main menu select the Block option and in the dialog move the 

Opacity slider all the way to the left (wireframe). 

14 In the Viewing toolbar select the option Multicolour Shade. 

 

15 Activate the Toolpath D16TR3-Rgh1. 

 

This toolpath will be modified to Ignore the purple, clamping blots along the X-

Axis (These are to be physically removed when this toolpath is run). 

This toolpath will also be modified to apply Collision status to the green, clamping 
bolts from a 2mm distance. 

 

16 Right mouse click on the Toolpath D16TR3-Rgh1 and select Settings to open 
the Model Area Clearance dialog. 

17 Select the Re-cycle option  to enable editing to occur. 

18 In the main page of the Model Area Clearance dialog, select the Component 

Thickness dialog . 

19 In the dialog use Smart Selection to acquire the data stored on the Level 
ClampingBolts-X to one of the colour coded rows. 

 

 

20 Set the row with Machining Mode > Ignore. 
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21 Select one of the other colour coded rows and use Smart Selection to acquire 

the data stored on the Level ClampingBolts-Y. 

 

22 Set the row with Machining Mode > Collision with a Thickness > 2.0 and the 
select Apply. 

 

 The parts of the model acquired to a row will be shaded in the same 
colour. 

 

23 Accept the Component Thickness dialog and then Calculate the toolpath. 

 

The updated toolpath (D16TR3-Rgh1) now runs straight through the X-Axis 
clamping bolt area and clears the Y-Axis clamping bolts by a full 2mm. 
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We now require a copy of the Toolpath (D16TR3-Rgh1) that locally machines the 

remainder of the component in the clamping bolt area along the Y-Axis. 

 

24 Right mouse click on the Toolpath D16TR3-Rgh1 and select Settings to open 

the Model Area Clearance dialog. 

25 Select the Make a Copy option and in the Model Area Clearance dialog 

rename it as D16TR3-Rgh2. 

As the new toolpath is a direct copy, the Component Thickness settings will be 
exactly the same as in D16TR1-Rgh1. 

26 In the main page tick the Rest machining box and then open the Rest page of 
the dialog. 

 

 

27 In the above dialog, insert the reference Toolpath > D16TR3-Rgh1 and fill in 

the other values exactly as shown. 

28 In the main page of the Model Area Clearance dialog, select the Component 

Thickness dialog . 

29 Swap over the settings between the 2 existing rows (as shown below). 

 

 

 

30 Accept the Component Thickness dialog and then Calculate the toolpath. 
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The updated Rest Roughing, toolpath (D16TR3-Rgh2) now runs straight through 
the Y-Axis clamping bolts. 

 

31 Activate the Toolpath BN10-Fin1 and then select Settings from the local 
menu to open the Steep and Shallow Finishing dialog. 

32 Select the Re-cycle option  to enable editing to occur. 

33 In the main page of the Steep and Shallow Finishing dialog, select the 

Component Thickness dialog . 

34 In the Clone pull down select the Toolpath D16TR3-Rgh1 and the click on the 

Copy Thickness Data icon.  

 

35 Accept the Component Thickness dialog and then Calculate the toolpath. 
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36 The updated toolpath (BN10-Fin1) now runs straight through the X-Axis 

clamping bolt area and clears the Y-Axis clamping bolts by a full 2mm. 

The next stage is to create a copy of the above toolpath (BN10-Fin1) that locally 
machines the remaining areas within the two Y-Axis clamping bolts.  

 

37 Right mouse click on the Toolpath BN10-Fin1 and select Settings to open the 
Steep and Shallow Finishing dialog. 

38 Select the Make a Copy option and in the Model Area Clearance dialog 
rename it as BN10-Fin2. 

As the new toolpath is a direct copy, the Component Thickness settings will be 

exactly the same as in BN10-Fin1. In this case the required Component 
Thickness settings will be cloned from the Toolpath D16TR3-Rgh2. 

 

39 In the main page of the Steep and Shallow Finishing dialog, select the 

Component Thickness dialog . 

40 In the Clone pull down select the Toolpath D16TR3-Rgh1 and the click on the 

Copy Thickness Data icon.  

41 Accept the Component Thickness dialog. 

 

42 In the Steep and Shallow Finishing dialog select the Block page and lock 
both the Min Z value (-35) and Max Z value (0). Keep the Block page open. 

43 In the PowerMILL explorer, right mouse click on the Level named 

ClampingBolts-Y and from the local menu click on Select All. 
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44 Back in the Block dialog enter an Expansion of 10 and Calculate. 

45 Unlock the Z Max value and manually input the value -26. 

 

 

46 Finally select Calculate at the bottom of the main Steep and Shallow 
Finishing dialog to create the new toolpath BN10-Fin2. 

47 Cancel the Steep and Shallow Finishing dialog. 

 

 

48 Save the Project (but do not close it). 
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Exercise 
 

1 Activate the existing Constant Z Finishing toolpath D8TR1-Fin1. 

 

2 Select Settings and Recycle on the above toolpath. 

3  Use the Component Thickness options to Ignore the surfaces on Level 
ClampingBolts-X (purple), and Machine with a 4mm thickness around the 

surfaces on Level ClampingBolts-Y (green). 

4 Calculate the changes to toolpath D8TR1-Fin1. 

 

 

5 Select Settings and Make a Copy for the toolpath D8TR1-Fin1. 

6 Rename the copy as D8TR1-Fin2. 
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7  Use the Component Thickness options to Ignore the surfaces on Level 

ClampingBolts-Y (green), and Machine with a 4mm thickness around the 

surfaces on Level ClampingBolts-X (purple). 

8 Modify the X dimensions of the Block to keep the Constant Z Finishing 

D8TR1-Fin2 inside the area already machined with D8TR1-Fin1. 

9 Calculate the toolpath D8TR1-Fin2. 

 

 

 

10 In the PowerMILL explorer re-order the Toolpaths to keep them grouped for 

the same pair of clamping bolts. 

 

 

11 Save the Project to update:-  

     .....\COURSEWORK\PowerMILL-Projects\CompThickness-2 
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Introduction 
A Stock Model provides both a visual and physical record of the remaining material 

after such entities as the material block and selected toolpaths have been 
considered. 

Stock Model Rest Roughing 
1 Select File > Delete All and Tools > Reset Forms. 

2 Select File > Open Project: 

......\PowerMILL_Data\Projects\StockModel_1 

3 Select OK in the PowerMILL Warning dialog. 

 

4 Select File - Save Project As: 

......\ COURSEWORK\PowerMILL-Projects\StockModelExample 

5 In the PowerMILL explorer select Stock Models > Create Stock Model. 

 

An empty Stock Model entity appears in the PowerMILL explorer and an 
associated Stock Model settings dialog appears in the graphics area.                                                                                                    

17. Stock Models 
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The default settings for triangulation of the Stock Model are displayed. In this case 

we will modify the settings to create a more accurate Triangle Mesh for the Stock 

Model. Once the Stock Model is physically created then these inherent settings 
cannot be retrospectively altered. 

 

6 Modify the values in the Stock Model settings to be exactly as shown above and 

then Accept the dialog. 

 

The displayed settings in the Stock Model will change accordingly. 

7 Right mouse click on the toolpath D20t3-RGH-a1 and from the local menu 
select Add to > Stock Model. 

 

The toolpath and associated Block are included in the Stock Model tree but at 

this stage are not calculated. 

 

8 In the PowerMILL explorer, in the Stock Models area, right mouse click on 

 and from the local menu select Calculate.  
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The Stock Model will display the visual effect of toolpath D12t3-RGH-a1 as a 

purple wireframe mesh. 

9 Right-click on Stock Model - 1 and from the local menu, select Drawing 

Options, and then tick both, Shaded and Show Rest Material. 

10 From the Viewing toolbar, undraw the model (both Shaded and Wireframe). 

 

The Stock Model is now displayed as shown with the component model and 
applied toolpath both taken into account. 

This represents the remaining material outside the component form after the 

taking into account the toolpath D20t3-RGH-a1. 

 

 If Block is made active in the Stock Model tree then this is the stage of the 
machining process that will be displayed. 
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11 From the Strategy Selector , Finishing options select the Offset Flat 
Finishing strategy and enter data in the 3 pages exactly as shown below. 

 

a Note: Add approaches from outside is un-ticked to enable independent 
Leads to be applied. 

b The strategy will use Rest Machining (ticked) to the Stock Model to 
prevent the 4 upper flat areas from being included. 

c By ticking this option the Rest page will become available for selection in the 

local browser. 

 

d Select Stock Model as 1. 
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12 In the main toolbar, Leads and Links options set the Lead in options exactly as 

shown below. 

 

13 Then set the Lead out options exactly as shown below. 

 

14 Accept the Leads and Links dialog. 

15 Calculate the Offset Flat finishing strategy and then Close the dialog. 
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 The latest Toolpath - D20t2-Flats-a1 is automatically added as a 
reference item in the Stock Model list but not as a physical entity.  

 

16 In the PowerMILL explorer, right-click over the Toolpath - D20t3-FLATS-a1 

and in the local menu select Add to > Stock Model. 

 

17 In the PowerMILL explorer, right-click on the Stock Model named 1 and in 

the local menu select Calculate. 

 

After the calculation, the Stock Model will be displayed again only this time with 
the Offset Flats Finishing included. 

 

18 Activate the toolpath D20t3-RGH-a1 and in the local menu select Settings… 

to open the Model Area Clearance dialog. 
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19 Select Create a new toolpath based on this one  and input new data 
into the dialog exactly as shown on the following page. 

 

a Input the Toolpath name as D10t1-RGH-a1  

b Set the Style as Offset model. 

c Tick the Rest machining box. 

 

d Select the D10t1 tool. 
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e In Rest Machining use Stock Model - 1 

20 Select Calculate on the Model Area Clearance dialog to machine within the 

limits of the specified Stock Model. 

 

21 Close the Model Area Clearance dialog. 

22 The latest Toolpath – D10t1-RGH-a1 is automatically added as a reference 
item in the Stock Model list but not as a physical entity.  

23 In the PowerMILL explorer use the left mouse button to drag the Toolpath 

D10t1-RGH-a1 to the bottom of the list. 

 

24 In the PowerMILL explorer, right-click over the Toolpath – D10t1-RGH-a1 

and in the local menu select Add to > Stock Model. 

25 In the PowerMILL explorer, right-click on the Stock Model named 1 and in 
the local menu select Calculate. 
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The Stock Model is now displayed as shown with the latest toolpath removed.  

Now that the bulk of the material is removed, the main component form is now 

ready to be Finish machined. 

26 Select and Blank all except the following surfaces: 

 

27 Using the left mouse button, drag a box across the displayed model above to 
select all surfaces. 

28 Activate the tool BN8. 

29 In the PowerMILL explorer, right-click on Boundaries and in the local menu, 

select the Selected Surface option. 
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30 Enter data exactly as shown above and then Apply to create the Boundary. 

31 Check that both Boundary 1 and the BN8 tool are both Active. 

32 Select the Toolpath Strategies  and select the Finishing tab in the dialog. 

33 Select the Optimised Constant Z Finishing option and enter data into the 

dialog exactly as shown below: 

 

 

 

34 Select the Limit page and enter data exactly as shown in the following image: 
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35 Select Calculate to create the Toolpath and then Close the dialog. 

 The Toolpath BN8-FIN-a1 has been limited to be inside the Boundary. 
 

 

36 In the PowerMILL explorer, right-click the toolpath BN8-FIN-a1 and in the 
local menu select Add to > Stock Model. 

37 In the PowerMILL explorer right-click on Stock Model – 1 and select 
Calculate to update. 
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The remaining Stock Model is displayed as shown above. 

Stock Model Rest Boundary 
The Finishing strategies do not have a direct Rest Machining option that relates 
to the Stock Model. 

It is however possible to create a Stock Model Rest Boundary to define the areas 

with material left on. This can then be used to limit a finishing strategy such that 
only the remaining stock is removed. 

1 In the PowerMILL explorer, right-click on Boundaries and in the local menu 
select Stock Model Rest. 

 

2 Enter data exactly as shown in the above image and Apply and then Cancel. 
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 Boundary segments will only be created where the BN4 tool is able to 
access the model form. 

 

The Stock Model Rest Boundary identifies the area of the remaining Stock 
Model. 

3 Select the Toolpath Strategies  and select the Finishing tab in the dialog. 

4 Check that the new Boundary BN4-StockModelRest and the BN4 tool are 

both Active. 

5 Select the 3D Offset Finishing strategy and enter data exactly as shown 

below: 

 

 

6 Select the Limit page and enter data exactly as shown in the following image: 
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7 Select Calculate to create the toolpath and then Close the dialog. 

 

8 In the PowerMILL explorer, right-click the toolpath BN4-FIN-a1 and in the 
local menu select Add to > Stock Model. 

9 In the PowerMILL explorer, right-click on the Stock Model and select 

Calculate to update. 

 

 The Stock Model displayed with Show Rest Material set will have 
visually disappeared apart from perhaps, a few tiny, insignificant patches. 

 If a previous toolpath in the Stock Model tree is selected then the status 
of the material at that point will be displayed. 
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10 In the PowerMILL explorer, Stock Model - 1 tree, Activate the toolpath 

named D20t3-RGH-a1. 

 

11 In the PowerMILL explorer, Stock Model - 1 tree, Activate the toolpath 
named BN4-FIN-a1. 

 The Stock Model will visually disappear while the Show Rest Material 
option is active. 

12 Right-click on the Stock Model and in the local menu, switch on (tick) the 
option Show All Material. 

 

The Stock Model is now exactly the same shape and size as the model. 

 

13 Select File > Save Project to update the stored Project. 



17. Stock Models PowerMILL 2013 

17 - 16  Copyright © Delcam plc 

Stock Model starting from a complex block. 
 

If a casting is to be machined then it is not possible to directly add the complex 

shape to a Stock Model. It is however possible to import a Triangle model of the 
original casting as the initial Block and then use it as the first entity in a Stock 

Model. The Stock Model can then be used as the referenced entity in an intial 

Rest Roughing strategy. 

On import the Block must use the option, Coordinate System as Global 
Transform (Exported Triangle models do not support Workplanes). 

 

1 Select File > Delete All and Tools > Reset Forms. 

2 Select File > Open Project: 

......\PowerMILL_Data\Projects\StockModelCasting_Start 

 

3 Select OK in the PowerMILL Warning dialog. 

4 Select File - Save Project As: 

......\ COURSEWORK\PowerMILL-Projects\StockModelCasting 

 

5 Open the Block form and set Coordinate System to Global Transform. 

6 Select Defined by – Triangles and browse to and Open:- 

C:\Training_Data\PowerMILL_Data\Triangles\StockModel-Casting.dmt 
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7 Open the Rapid Move Heights form and select Calculate. 

8 Activate the tool D25TR3. 

9 Create a new Stock Model. 

10 Right mouse click on the new Stock Model and from the local menu select 

Apply Block. 

 

The complex Block is added as the first entity in the Stock Model. 

 

11 Right mouse click on the new Stock Model and from the local menu select 
Calculate. 

12 Right mouse click on the new Stock Model and from the local menu select 

Drawing Options and tick both Shaded and Show Rest Material. 

 

The model form is visually removed from the Stock Model. 

Exercise: 
13 Calculate a Block of Type - Cylinder and Defined by - Model. 

14 Create a Model Rest Area Clearance – Offset Model strategy using the above 
Stock Model as the reference item and the D25TR3 tool. 
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