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www.delcam-ams.com 

 

Whether you are a new or long-term user of Delcam products, you 
may not be aware of the complementary technologies available 
from Delcam that could improve your company’s productivity. 

 

Delcam Advanced Manufacturing Solutions offers a complete and 
diverse range of CADCAM software solutions to integrate every 
aspect of your production life-cycle – from designing a complex 
concept, to manufacturing it and inspecting the final output – 
providing you with unrivalled speed, flexibility, and ease-of-use 
throughout your product development process. 

 

Adding to your suite of Delcam solutions minimises the impact on 
your daily production operations while also enabling you to enter 
new markets or automate your processes with our advanced 
functionality. 

 

All products work independently or together as one complete 
manufacturing solution tailored to your specific needs. 

 
  

Powering your productivity 



 

 

 
www.powershape.com 

PowerSHAPE provides a complete environment to manipulate 
surface form, build from wireframe, and add solid features for 
prismatic parts. 

 Import/export Parasolid-based systems with no translation. 

 Create complex molds from solid models, complete with split 
surfaces. 

 Powerful surface and face-editing tools quickly repair imported 
data. 

 Tools to perform non-feature-based edits quickly and efficiently. 

 

 
www.powermill.com 

PowerMILL is the world’s leading specialist NC CAM software for the 
manufacture of complex shapes, providing advanced-machining 
strategies to minimise machining time and maximise finish quality. 

 World-leading high-speed machining strategies. 

 Advanced 5-axis machining techniques. 

 Support for 64-bit platforms and multi-threading. 

 Innovative collision-avoidance methods. 

 Powerful toolpath editing and tool-axis stabilisation. 

 

 
www.featurecam.com 

FeatureCAM is a unique CAM system that uses feature-based and 
knowledge-based technologies for automated machining, minimising 
programming times for mills, lathes, turn/mill, and wire machines. 

 Easy to use. 

 Single interface for multiple machine platforms. 

 Powerful turning and milling operations from 2.5D to 5-axis. 

 Multi-threading capabilities. 

 



 

 

 

 

www.delcamforsolidworks.com 

Delcam for SolidWorks is a SolidWorks Certified Gold Product that 
revolutionises CAM programming inside SolidWorks. 

 Integrates the feature-based technology from FeatureCAM. 

 Multi-threaded toolpath algorithms from PowerMILL. 

 2-axis, 3-axis, and 5-axis positional milling and drilling. 

 Turning, turn/mill, and wire EDM capabilities. 

 Automatic selection of cutting tools, machining strategies, and 
feeds and speeds. 

 Exceptional toolpath-calculation speeds. 

 Set-up wizards. 

 Full-machine simulation. 

 

 
www.partmaker.com 

PartMaker applies a patented Visual Programming approach to 
automate the programming of multi-axis Swiss-type lathes and 
Turn-Mill Centres. 

 Easier programming of turning with live tooling via the Divide-
and-Conquer programming approach. 

 Automatic process synchronisation. 

 Vivid 3D simulation and crash detection. 

 Wide array of proven post processors for Turn-Mill Centres and 
Swiss-type lathes. 

  



 

 

 
www.powerinspect.com 

PowerINSPECT leads the way in today’s inspection market. It 
delivers a complete CAD-based inspection solution that can accept 
data from all types of hardware, including manual and CNC 
coordinate measuring machines, portable arms, optical measuring 
devices, and CNC machine tools. 

 Part comparison against all mainstream CAD formats. 

 Support for all types of measuring devices. 

 Market-leading inspection reports that are quick to create and 
easy to understand. 

 IGES export of measured features, including digitized curves. 

 Additional modules for part alignment, laser line inspection, and 
tube inspection. 

 

 

www.artcam.com 

ArtCAM is a unique application that combines the benefits of 
computerised design and CNC machining in a simple-to-use format 
to create decorative products from artwork. 

 Import 3D models, clipart, and other CAD system formats. 

 Add geometric shapes, weaves, and textures. 

 Choose from extensive visualisation and rendering materials. 

 Use the comprehensive and customisable tool database for fast 
toolpath-calculation. 

 Powerful toolpath simulation verifies machining times and 
materials. 

 Design in the 3D view. 

 

Delcam also provides a range of healthcare CADCAM solutions for 
the dental, custom orthotic insoles, medical implants, and 
orthopaedic footwear industries, as well as CADCAM solutions for 
footwear design and manufacturing. 

 

You can connect with Delcam in a variety of ways: 
visit: www.delcam.com | watch: www.delcam.tv | learn: www.delcam.tv/lz 
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Copyright  1996 - 2013 Delcam plc. All rights reserved. 

Delcam plc has no control over the use made of the software 
described in this manual and cannot accept responsibility for any 
loss or damage howsoever caused as a result of using the software. 
Users are advised that all the results from the software should be 
checked by a competent person, in accordance with good quality 
control procedures. 

The functionality and user interface in this manual is subject to 
change without notice in future revisions of software.  

The software described in this manual is furnished under licence 
agreement and may be used or copied solely in accordance with the 
terms of such licence. 

Delcam plc grants permission for licensed users to print copies of 
this manual or portions of this manual for personal use only. 
Schools, colleges and universities that are licensed to use the 
software may make copies of this manual or portions of this manual 
for students currently registered for classes where the software is 
used. 
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The Raceline smoothing functionality is subject to patent 
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PowerMILL is the leading NC CAM software specialising in the 
manufacture of complex shapes typically found in the toolmaking, 
automotive, and aerospace industries. PowerMILL 2013 offers all of 
the original features of PowerMILL 2012 R2, but with numerous 
improvements. This document describes the most significant 
improvements. 

 

Toolpath preparation 
There is a new Reorder Segments  button which lists all the curve 
segments and enables you to change the order of the segments in a 
boundary or pattern (see page 4). 

There is a new type of boundary called a private boundary. A 
private boundary is linked to a specific toolpath and cannot be used 
by any other entities (see page 10). 

The tool axis definitions are now consistent across all toolpath 
strategies. The options available to measure the tool axis vary with 
the strategy but always include the option used in previous versions 
(see page 16). 

There is a new undercut option which selects surfaces that are 
entirely or partially undercut (see page 24). 

There is a new Transform  button on the Boundary toolbar and 
Pattern toolbar (see page 26). 

Transformations all require an origin. Now each transformation type 
has its own default origin (see page 31). 

You can now import and export pockets, slots, and bosses from an 
XML file from/to PowerSHAPE (see page 31). Previously this 
functionality was available only for holes.  

 

Summary of new features 
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Toolpath generation 
When creating an area clearance toolpath, you now always have the 
choice of using either a precise stepdown or a constant stepdown 
(see page 32). 

There is a new offsetting option available when creating a blisk area 
clearance strategy with a trochoidal toolpath (see page 34). The 
offsets are of constant height and radius between blades, but with 
the edges rounded off. Each pass loops before joining the next one 
to create a trochoidal path. 

All spiral toolpaths, area clearance or finishing toolpaths, are now 
much smoother (see page 38). 

There is improved tool axis movement in contact-point based 
strategies (such as flowline toolpaths). This smooths the tool axis 
while maintaining the same contact point (see page 39). 

You can now see a history of your toolpath edits (see page 40). 
 

Toolpath verification 
When a component of a machine tool collides with another 
component of the machine tool or the workpiece, the colliding 
component(s) of the machine tool change colour (see page 43). 

Viewmill simulation is up to three times faster. 

There are new simulation defaults (see page 45). 

When simulating toolpaths, new keyboard shortcuts provide an 
option for smaller toolpath steps (see page 45). 

 

Toolpath output 
There is a new Reorder option on the individual NC program context 
menu. This enables you to automatically reorder the toolpaths in an 
NC program (see page 47). 

 

User interface 
There is a new concept of a mode toolbar which makes it more 
obvious when you enter a graphics mode (see page 49). 

PowerMILL now saves any custom colours in the colour palette, so 
they are available the next time you use PowerMILL (see page 52). 
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Automation 
There is a new horizontal plugin window which enables plugins to be 
designed with a horizontal layout (see page 54).  

The macro programming language now includes the ability to: 

 Create entity variables. 

 Execute a macro string as a command using DOCOMMAND. 

For more information, see the Macro Programming Guide. 
 

General enhancements 
PowerMILL now makes more effective use of memory. This 
improves machining times on large parts (see page 56). 

Improved calculation times of area clearance toolpaths on large 
parts. 

There is less fragmentation of toolpaths when rest roughing a stock 
model. 

Arc fitting is much improved and more reliable (see page 56). 

When using stock engagement, ordering Constant Z toolpaths is 
now safer and more efficient. 

You can now export models as .stl files even when no machine 
operations have taken place (see page 56). 

New parameters are available for tool holder and tool shank 
components (see page 56). 

Toolpath strategy dialogs open twice as fast (see page 56). 

You can now convert a model to a reference model (see page 56). 

The Delete Selected menu option has moved from the File menu to 
the View menu (see page 56). 

The Measure dialog now includes the ability to easily measure the 
apparent angles of a defined line (see page 57). 
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Reordering curve segments 
There is a new Reorder Segments  button on the Curve Editor 
mode toolbar which lists all the curve segments and enables you to 
change the order of the segments in a boundary or pattern. This is 
very similar to the Reorder Toolpath option. 

 
The curve segment order is important when a toolpath uses a 
pattern to define its path. For example, pattern engraving of text 
where you need to reorder segments so the order reflects the 
correct letter order. 

Selecting components within the list also selects them graphically, 
turning them yellow. Similarly, selecting a segment from the 
graphics window moves to that segment in the list. The columns in 
the list are: 

Toolpath preparation 
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 — The segment number. 

 Any movement or removal of segments renumbers the 
affected segments. So the segment number is a temporary, 
not a permanent, number and you cannot use it to identify 
a specific segment. 

— The coordinates of the segment start point. 

— The coordinates of the segment end point. 

  — The segment length. 

 — The number of points in the segment. 

The Reorder toolbar on the left side of the dialog enables you to 
reorder the selected segments. 

 Delete Selected — Click to delete the selected segments. 

 Move to Start — Click to move the selected segments to the start 
of the toolpath. 

 Move Up — Click to move the selected segments up one 
position. 

 Move Down — Click to move the selected segments down one 
position. 

 Move to End — Click to move the selected segments to the end. 

 Reverse Order — Click to move the order of the selected 
segments. If no segments are selected then this reverses all 
segments. 

 Reverse Direction — Click to reverse the direction of each 
selected segment, so the start and end points are switched round. If 
no segments are selected then this reverses the direction of the 
whole curve. 
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 Sort in X — Click to sort the curves along the X direction. 

It converts this: 

 
to this: 

 

 Click Number Segments  to see the order. 
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 Sort in Y — Click to sort the curves along the Y direction. 

It converts this: 

 
to this: 

 

 Click Number Segments  to see the order. 
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 Sort in Z — Click to sort the curves along the Z direction. 

 Number segments — Click to number the segments in the 
selected curve. 

It converts this: 

 
to this: 
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 Instrumentation — All curves have a direction. Click to 
instrument a curve, which places an arrow on each segment 
(pointing towards the end of the segment) and an 'X' at the end 
of each segment. 

It converts this: 

 
to this: 
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 If you want to undo an operation on the Reorder Segments 

dialog, use the Undo  button on the Curve Editor mode 
toolbar. 

 You cannot reorder a locked boundary or pattern. 
 

Private boundaries 
There is a new type of boundary called a private boundary. A 
private boundary is linked to a specific toolpath and cannot be used 
by any other entities. To use the same boundary elsewhere, you 
must duplicate it. 

By default, all boundaries are created as private boundaries.  

 A private boundary uses the tolerance, thickness, and tool of its 
associated toolpath. The private boundary controls all other 
properties (such as limits, collision checking, and block). 

 When you create a boundary you can indicate if you want to 
allow it to become private. It isn't private at this stage but 
becomes private when it is used by either a toolpath or stock 
model.  

 When creating a toolpath using a private boundary, the toolpath 
takes ownership of the boundary and the boundary is removed 
from the boundaries branch of the explorer. However, it is still 
accessible from the individual toolpath branch of the explorer and 
from the Limits page of the toolpath dialog.  

 
 A private boundary icon is a different colour to an ordinary 

boundary. For a selected surface boundary, an ordinary 
boundary is represented by  and a private boundary by . 

 When you delete a toolpath using a private boundary, the 
boundary is deleted along with the toolpath. 

 If you change the private boundary associated with a toolpath, 
the toolpath releases the boundary and it re-appears in the 
boundaries branch of the explorer. 

 To display private boundaries in the Boundaries branch of the 
explorer, from the Tools menu select Options > Boundaries > 
Private boundaries > Display private boundaries in the explorer. 
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 If you display private boundaries in the Boundaries branch of the 
explorer, you can see the toolpath that uses it. 

 
 

Options > Boundaries 
The Boundaries items define the default boundary options. 

Private Boundaries 

 
Allow new boundaries to be private — When selected, PowerMILL 
creates boundaries that can be made private. They are not private 
on creation, but as soon as they are attached to a toolpath, or stock 
model, they become private. When deselected, creates ordinary 
boundaries that can be used by many toolpaths and stock models. 
This option determines the default behaviour, but you can override 
this on boundary creation. 

Display private boundaries in the explorer — When selected, 
PowerMILL displays private boundaries in the boundaries branch of 
the explorer as well as in the individual toolpath branch of the 
explorer. When deselected, displays private boundaries only in the 
individual toolpath branch of the explorer. 

 Groups always display any private boundaries placed in them. 

Automatically delete unused private boundaries — When selected, 
PowerMILL automatically deletes unused private boundaries. For 
example, if you have a toolpath using a private boundary and then 
you edit the toolpath to use a different boundary, the original 
boundary is deleted. 
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Using private boundaries 
This example uses the 5_axis_Test.dgk model in the Examples folder. 

 

1 Create a Block  and define a 10 mm ball nosed Tool . 

 Ensure the block extends above the top of the model. 

2 Select the top surface. 

3 From the Boundaries context menu, select Create Boundary > 
Contact Point. This displays the Contact Point dialog. 
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a Click the Model  button. 

b Select the Allow boundary to be private option. 

c Click Accept. 

 
For more information, see Example of Contact Point Boundary. 

The boundary appears in the Boundaries branch of the explorer. 

 
4 Create a Raster Finishing toolpath using the Contact Point 

Boundary. 
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The boundary is no longer displayed in the Boundaries branch of 
the explorer. Instead, it is displayed in the individual toolpath 
branch of the explorer. 

 
The icon changes from  to . 

5 In the Options dialog (accessed from Tools > Options > Boundaries 
> Private boundaries), select Display private boundaries in the 
explorer to display this boundary in the Boundaries branch of the 
explorer. 
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6 If you try to create another toolpath which uses this private 
boundary, the new toolpath creates a copy of the private 
boundary. 

 
7 If you delete a toolpath which uses a private boundary, the 

private boundary is deleted along with the toolpath. 
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Tool axis definitions 
The tool axis definitions are now consistent across all toolpath 
strategies. To achieve this, there is an additional Mode option on the 
Definitions tab of the Tool Axis dialog. The options available in the 
Mode list vary with the strategy. These options always include the 
measuring method used in previous versions, but this may not be 
the default value. The default value gives the best results in most 
instances. 

These new options provide more flexibility but still enable you to 
maintain existing behaviour. 

 
The Mode options define how to measure the tool axis. 

With a Tool Axis of Lead/Lean, the Lead angle is measured with 
respect to the reference direction in the direction of travel. The Lean 
angle is measured with respect to the plane containing the reference 
direction and the tool movement direction. So, with a Lead of 0 and 
a Lean of 0, the tool is aligned with the reference direction. 
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Contact normal — This measures the lead angle from the toolpath 
contact normal. This is the default option. 

This example uses a constant Z toolpath with a Tool axis of: 

Lead angle of 0  

Lean angle of 0  

Mode of Contact normal. 

 
Vertical — This measures the lead angle from the Z axis. 

This example uses a constant Z toolpath with a Tool axis of: 

Lead angle of 0  

Lean angle of 0  

Mode of Vertical. 
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This example uses a constant Z toolpath with a Tool axis of: 

Lead angle of 20  

Lean angle of 0  

Mode of Vertical. 

 
PowerMILL 2012 R2 — The behaviour available in PowerMILL 2012R2 
which, in most cases, used a Mode of Vertical.  
The strategies which used a Mode other than Vertical are: 

 
Strategy PowerMILL 2012 R2 mode 
Embedded pattern Contact normal 

Flowline Contact normal 

Parametric spiral Undercut angle 

Pattern, using toolpath Reference tool axis 

Profile Contact normal 

Projection (curve, line, plane, 
point, surface) 

Preview frame normal 

Surface machining Contact normal 
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Preview frame normal — This measures the lead angle from the 
normal to the pattern that forms the preview frame. 

This example uses a line projection toolpath with a Tool axis of: 

Lead angle of 0  

Lean angle of 0  

Mode of Preview frame normal. 

 
 Preview frame 

The tool is normal to the pattern (or preview frame). 
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Reference tool axis — This measures the lead angle from the tool 
axis used by the reference toolpath. This option is available only for 
pattern finishing toolpaths which use a toolpath as the drive curve. 

This example uses a pattern toolpath which uses a reference 
toolpath as the drive curve, and a Tool axis of: 

Lead angle of 30  

Lean angle of 0  

Mode of Reference tool axis. 

 
 Lead angle 

 Tool axis of reference toolpath 

Tangent normal — This measures the lead angle from the 
perpendicular to the tangent direction of the reference curve. This 
option is available only for pattern finishing toolpaths which use a 
pattern as the drive curve. 

This example uses a pattern toolpath with a Tool axis of: 

Lead angle of 0  

Lean angle of 0  

Mode of Tangent normal. 
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Undercut angle — This measures the lead angle from the projection 
direction corresponding to the specified degree of undercut. This 
option is available only for parametric spiral toolpaths. 

This example uses a line parametric spiral toolpath with an 
Undercut Angle of 10  and a Tool axis of: 

Lead angle of 0  

Lean angle of -20  
Mode of Undercut Angle. 

 
With the same options except: 

Mode of Vertical. 
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Tool Axis of Towards... or From... 
With a Tool Axis of Towards... or From... the Mode options are: 

Preview frame — The tool axis is defined on the preview frame and 
then the toolpath is projected onto the model. 

A Tool axis of From point 
A Mode of Preview Frame 

 

 the From point 
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The tool axis doesn't pass through the From point. However, if you 
offset the tool to the preview frame it would pass through the From 
point. 

 
Toolpath — The toolpath is projected onto the model and then the 
tool axis is defined on the model. 

A Tool axis of From point 
A Mode of Toolpath 

 

 The tool axis passes through the From point. 
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Selecting undercut surfaces 
There is a new undercut option on the Model context menu of 
Selection tools > Select undercut components. This option selects 
surfaces that are entirely or partially undercut.  

This example uses the 5_axis_test.dgk model in the Examples file to 
show the effects of this option. 

 

Selecting Draft Angle Shade  on the shade toolbar displays: 

 
Selecting Selection tools > Select undercut components displays the 
Select Undercut Surfaces dialog. 
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The Select Undercut Components dialog selects surfaces that are 
entirely or partially undercut. 

 

 Undercut shading requires the correct surface orientation of 
the model.  

The Orient surface options enable you to correctly orient your model. 

Orient all — Click to automatically reverse the orientation of all the 
surfaces which are incorrectly oriented in the current view. 

Orient selected — Click to automatically reverse the orientation of all 
the selected surfaces which are incorrectly oriented in the current 
view. 

Draft Angle — Enter the draft angle. This is an angle incorporated 
into a wall of a mold, so the opening of the cavity is wider than the 
base, which allows for easier ejection of the part. This option selects 
undercut surfaces less than, or equal to this value. 

Match draft angle — When selected, undercut surfaces equal to the 
draft angle are selected (undercut surfaces less than the draft angle 
are not selected). 

Include partially undercut surfaces — When selected, any surface 
which has an undercut region is selected. 
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When deselected, any surface which is wholly undercut is selected. 

 

 Selecting Include partially undercut surfaces selects at least as 
many surfaces as when deselected.  

 Selecting either of these options adds to your current 
selection, so, the undercut surfaces are selected, as well as 
any previously selected components. 

 

Transforming boundaries and patterns 
There is a new Transform  button on the Boundary toolbar and 
Pattern toolbar. This works in a very similar way to the Transform 

 button on the Toolpath toolbar.  

Selecting Transform from the individual boundary menu, or clicking 

 on the Boundary toolbar, displays the Boundary Transform mode 
toolbar. 

 

Selecting Transform from the individual pattern menu, or clicking  
on the Pattern toolbar, displays the Pattern Transform mode toolbar. 

 
The transformations allow you to move, rotate, or mirror curves. 

This is very similar to the Toolpath Transform mode toolbar and 
Workplane Transform toolbar. 
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Activating a mode disables most of PowerMILL's functionality until 
you exit from the mode. For more information, see Mode toolbars. 

These options are very similar to those on the  Transformations 
toolbar on the Curve editor mode toolbar. 

 Move — Click to transform the curves by the specified 
coordinates. 

 

 Keep original — This determines whether the entities are copied 
or replaced when transformed. 

 Replace original — When selected, the original entities are 
replaced with the transformed ones. 

 Keep original — When selected, keeps both the original and 
transformed entities. 

No. of copies — Enter the number of copies. 

 Workplane origin — When selected, the active workplane is the 
origin. If no workplane is active then the global coordinate system is 
the origin. 

 Bounding box origin — When selected, the origin is the centre of 
the bounding box containing all the entities. 

 Move origin — When selected, you can move the origin 

graphically by dragging or by entering coordinates using , , or 

 and  in the Status bar. 

 Finish — Click to accept the changes and close the toolbar. 

For more information, see the moving curves example, the moving 
toolpaths example, or the moving workplanes example. 

 Rotate — Click to rotate the curves around the specified axis by 
the selected angle. 

 

 Keep original — This determines whether the entities are copied 
or replaced when transformed. 
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 Replace original — When selected, the original entities are 
replaced with the transformed ones. 

 Keep original — When selected, keeps both the original and 
transformed entities. 

No. of copies — Enter the number of copies. 

Angle — Enter the rotation angle in degrees. 

 Workplane origin — When selected, the active workplane is the 
origin. If no workplane is active, then the global coordinate system 
is the origin. 

 Bounding box origin — When selected, the origin is the centre of 
the bounding box containing all the entities. 

 Move origin — When selected, enables you to move the origin 

graphically by dragging or by entering coordinates using , , or 

 and  in the Status bar. 

 Finish — Click to accept the changes and closes the toolbar. 

For more information, see the rotating curves example, the rotating 
toolpaths example, or the rotating workplanes example. 

 Mirror — Click to mirror the curves along one of the principal 
planes of the active workplane or along an arbitrary mirror line. If 
no workplane is active, the mirroring is about the relevant plane of 
the global coordinate system. 

 

 Keep original — This determines whether the entities are copied 
or replaced when transformed. 

 Replace original — When selected, the original entities are 
replaced with the transformed ones. 

 Keep original — When selected, keeps both the original and 
transformed entities. 

 Mirror in XY — Click to mirror the entity in the XY plane. 

 Mirror in YZ — Click to mirror the entity in the YZ plane. 

 Mirror in ZX — Click to mirror the entity in the ZX plane. 

 Mirror in line — Click to mirror the entity in a plane defined by 
selecting either an existing line or two points. 
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 Workplane origin — When selected, the active workplane is the 
origin. If no workplane is active, then the global coordinate system 
is the origin. 

 Bounding box origin — When selected, the origin is the centre of 
the bounding box containing all the entities. 

 Move origin — When selected, enables you to move the origin 

graphically by dragging or by entering coordinates using , , or 

 and  in the Status bar. 

 Finish — Click to accept the changes and closes the toolbar. 

 Multiple transform — Click to perform multiple Moves  or 

Rotations . 

 Transform to workplane — Click to move the curves so they are 
in the same place relative to the active workplane as they were to 
the global transform. 

 

Converts this: 

 
to this: 
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 Transform to world — Click to move the curves so they are in the 
same place relative to the global transform as they were to the 
active workplane. 

 

Converts this: 

 
to this: 

 
 

 Undo — Click to revert to what it was before the last change. 

 Redo — Click to reinstate the edit you have just undone. 

 Accept changes — Click to accept and keep all the created 
curves. 

 Cancel changes — Click to delete all the created curves. 
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Transformation origin 
All transformations require an origin. This can be either a Workplane 
origin or a Bounding box origin. In PowerMILL 2012 R2 there was 
one default for all transformation types. In PowerMILL 2013, each 
transformation type has its own default.  
Transformation Default origin 

Move  Bounding box 

Rotate  Workplane 

Mirror  Workplane 

Scale  Bounding box 

Multiple transform  - 
Rectangular 

Bounding box 

Multiple transform  - 
Circular 

Bounding box 

 
 

Importing features from PowerSHAPE 
In previous versions, you could read a hole from an .xml file into a 
feature set and export a hole in a feature set to an .xml file. 

In PowerMILL 2013, you can now import pockets, slots, and bosses 
from an .xml file from PowerSHAPE. Previously, this functionality 
was available only for holes. You can also export them to a .xml file 
and import them in PowerSHAPE. 
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Area clearance stepdown 
When creating an area clearance toolpath, you can now always 
choose whether to use the precise stepdown or a constant 
stepdown. In previous versions, this choice was only available if you 
selected a Stepdown of Manual. 

 
Constant Stepdown — When selected, all the machining levels are 
equispaced, and the Stepdown value is a maximum stepdown. When 
deselected, the difference between consecutive machining levels is 
the Stepdown value for all levels except the last one which is at the 
bottom of the block. 

Toolpath generation 



 

PowerMILL 2013 What's New Toolpath generation • 33  

Constant Stepdown deselected: 

 
With a Stepdown of 20, the Z heights are at 15, -5, and -10. 

The stepdown is the amount specified for all levels (in this case 20) 
except for the last one, which is at the bottom of the block (in this 
case a Stepdown of 5). 

Constant Stepdown selected: 

 
With a Stepdown of 20, the Z heights are at 20, 5, and-10. This 
gives an effective stepdown of 15. 

The stepdown is the same between all levels but isn't necessarily 
the amount specified. In this case, PowerMILL uses a Stepdown of 
15 rather than 20. 
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Blisk area clearance offsets 
You can now specify the type of offsetting when creating a blisk 
area clearance strategy.  

The Machining page has an additional option of Method. 

 
Method — These options determine the offsetting method between 
the two blades. 

Parallel — The offsets are approximately parallel to the blades. 
This was the only option in previous versions. 
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Looking in detail: 

 
Trochoidal — The offsets are of constant height and radius 
moving between blades, but with the edges rounded off. Each 
pass loops before joining the next one to create something 
resembling a trochoidal path. Selecting this option enables the 
Trochoids area of the dialog. 
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Looking in detail: 

 
Looking in even more detail: 

 

  shows the trochoidal cutting moves. 

 shows the loop to connect to the next cutting path. This 
portion of the toolpath is air cutting. 



 

PowerMILL 2013 What's New Toolpath generation • 37  

Trochoids 
Radius — Enter the preferred radius for the rounding at corners. 

Minimum radius — Enter the minimum radius for the rounding at 
corners. 

Connection clearance — Enter the tool retract distance for the back 
of the trochoids (the portion of the toolpath which is air cutting). 
 
Connection clearance of 20 

 
Connection clearance of 5 

  
 
 
 

 

Overlap — Enter the overlap distance between consecutive passes. 
This enables each pass to start before the previous pass curves 
away from the edge. 

 

 First pass 

 Second pass 

 Overlap 
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Spiral toolpath improvements 
All spiral toolpaths (whether area clearance or finishing toolpaths) 
are now much smoother. This improvement has no speed 
implications, so spiral toolpaths are calculated just as quickly in 
PowerMILL 2013 as in PowerMILL 2012 R2. 

Looking in detail at a spiral toolpath created in PowerMILL 2012 R2 
where the toolpath isn't smooth: 

 
The improved toolpath created in PowerMILL 2013 still follows the 
outer contour but smooths the inner contours: 

 

 The smoothing takes place automatically on toolpath creation.  
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Flowline toolpath improvements 
PowerMILL 2013 provides improved tool axis movement in contact-
point based strategies. This smooths the tool axis while maintaining 
the same contact point. This includes flowline toolpaths and any 
other strategies that use an embedded pattern. 

You can see the improvements in a flowline toolpath on the Die.dgk 
model in the Examples folder. 

 
Looking in detail at the toolpath created in PowerMILL 2012 R2: 
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and the improved toolpath created in PowerMILL 2013: 

 

 The smoothing takes place automatically on toolpath creation.  
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Toolpath editing history 
You can now see a history of your toolpath edits. The Toolpath 
Editing History dialog is available from the individual toolpath Edit > 
Toolpath Editing History menu or from  on the Toolpath toolbar. 

 
Toolpath — Select the toolpath to review its edits. 

Edits — The pane displays a list of all the edits performed on the 
toolpath. The most recent edit is at the top of the list and the 
original toolpath is at the bottom of the list. 

The right side of the dialog displays information on the selected 
edit. In this case, you can see the edit moved the toolpath by 100 
mm in Y. 
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If you select the toolpath, rather than an edit the right hand side of 
the dialog displays the toolpath Notes. 

Notes — Type any specific notes to help you understand the edit. 

 This functionality records the edits on a toolpath but doesn't 
allow you to change or edit them. 
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Machine tool collisions 
When machine tool components collide with each other, or with the 
workpiece, all the colliding components are highlighted red. 
Previously, only two components could be highlighted, even if there 
were more involved in the collision. 

 

Toolpath verification 
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You can change the default collision colour on the Customised Colour 
dialog (accessed from Tools > Customise Colours).  

 
In this case, the collision colour has been changed to orange: 
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Simulation enhancements 
Viewmill simulation is up to three times faster. 

There are new simulation defaults of Point-to-point simulation  

with the Speed control set to the maximum speed. If the 
simulation is too fast (especially without ViewMill), reduce the speed 
using the controller. 

When simulating toolpaths you can use: 

 the buttons on the Simulation toolbar; or, 

 
 the keyboard shortcuts. 

The keyboard shortcuts now give an option for smaller toolpath 
steps. 

If you select Point-to-point simulation , the step sizes are 
dependent on the point spacing. If you select Feed rate simulation 

, the step sizes are based on the feed rate. The keyboard 
shortcuts are: 
Key Description 

 Steps forwards through the 
simulation. 

 + CTRL Makes a long step through the 
simulation. 

 + CTRL + Shift Makes an extra long step through the 
simulation 

 + Shift Makes a short step through the 
simulation. 

 Steps backwards through the 
simulation. 

 + CTRL Makes a long step back through the 
simulation. 

 + CTRL + Shift Makes an extra long step back 
through the simulation. 

 + Shift Makes a short step back through the 
simulation. 
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Key Description 

Page Down Moves the tool to the start of the 
next toolpath segment. 

Page Up Moves the tool to the start of the 
current toolpath segment, or to the 
beginning of the previous one if the 
tool is already at the start. 

End Moves the tool to the end of the 
toolpath. 

Home Moves the tool to the start of the 
toolpath. 

 

 Since feed rate stepping doesn't stop on every point, it may 
appear as if it skips the odd point. Since arcs are smashed for 
simulation, the tool doesn't follow arcs exactly. 
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Reordering toolpaths in an NC program 
There is a new Reorder option on the individual NC program context 
menu. This enables you to automatically reorder the toolpaths in an 
NC program. Previously you could only reorder toolpaths manually. 

This is particularly useful when you want to minimise tool changes, 
as changing tools on a machine can be slow and often involves a 
long move back to the tool change position. 

There are three Reorder options: 

 
by Tool Number — Select to sort the toolpaths by their tool number 
and place the toolpath with the smallest tool number first. 

 You must define all your tool numbers to use this option.  

by Tool Diameter — Select to sort the toolpaths by their tool 
diameter and place the toolpath with the largest tool diameter first. 

by Workplane — Select to sort the toolpaths by their workplane Z 
axis and place the toolpaths with the Z axis most closely aligned to 
the global coordinate system first. 

Undo — Select to revert to what it was before the last change. 

Toolpath output 
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For example, starting with these toolpaths: 

 

If you look at the Toolpath List dialog (available from  on the NC 
Program dialog) you can see the tool number and diameter of each 
toolpath. 

 
Selecting Reorder > by Tool Number changes the toolpath order to: 

  

 Although the RestRoughing toolpath has a tool number of 2, it 
appears last in the list as it cannot be calculated until the 
Roughing toolpath is calculated because it uses the Roughing 
toolpath as a reference toolpath. 

Selecting Reorder > by Tool Diameter changes the toolpath order to: 
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Mode toolbars 
There is a new concept of a mode toolbar which makes it more 
obvious when you enter a graphics mode. A mode toolbar makes it 
easier to use the graphics modes within PowerMILL. There is a 
separate mode toolbar for each mode. This is similar to a normal 
toolbar except: 

 It is in a fixed location at the top of the graphics window. 

 It displays the title and icon of the mode. 

 It disables most other PowerMILL functionality. 

Activating a mode disables most of PowerMILL's functionality until 
you exit from the mode. This includes disabling: 

 the menu bar 

 most toolbars 

 the explorer's context menus 

 the graphics area's context menus 

 most commands 

A mode toolbar is displayed just above the graphics window. 

 

User interface 
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The mode toolbars display the toolbar name and icon on the left 

.  

If the mode toolbar is too wide for the graphics window: 

 Initially, the toolbar icon isn't displayed, ; or, 

 If reduced further, the icon is displayed, but the name isn't 

; or, 

 If reduced still further, neither the name nor the icon are 

displayed . 

The mode toolbar always displays the Accept  and Cancel  
buttons. If possible, PowerMILL displays the whole mode toolbar: 

 
But, if the graphics window is too narrow, PowerMILL removes the 

buttons immediately to the left of the Accept  and Cancel  
buttons. 

 

 Accept changes — Click to accept and keep all the changes. This 
mode toolbar closes, which enables the main PowerMILL 
functionality. 

 Cancel changes — Click to delete all the changes. This mode 
toolbar closes, which enables the main PowerMILL functionality. 

The mode toolbars are: 

 
Block Editor  

 
Boundary 
Transform  

Create 
Workplane  The icon on the left side 

depends on the create workplane option selected 
on the Workplane toolbar. 

Curve Editor 
 

Feature Set 
Editor  

Measure Mode 
 



 

PowerMILL 2013 What's New User interface • 51  

Measure 
Difference Mode  

Move Start 
Points  

Pattern Collect 
 

Pattern 
Decoration  

Pattern 
Transform  

Pick Entity 
 

Pick Tool Pattern 
 

Activate Picked 
Entity   

Snapshot Mode 
 

Toolpath 
Transform  

Workplane 
Editor  

Workplane 
Transform  

 

The functionality and options on the toolbars remain unchanged. 
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Saving custom colours 
PowerMILL now saves any custom colours in the colour palette 
between sessions. You can define custom colours by going to either: 

 The Tools > Customise Colours menu, and selecting one of the 
options in the tree, say Selection > Wireframe Selection, and then 
selecting Edit to display the Customise Colour dialog. 

  
 The Draw > Model menu, and selecting either Colour or Shade 

Colour to display the Select Colour dialog. 

 

 The custom colours are the same in both instances. 
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Plugin enhancements 
A new horizontal plugin window has been added to PowerMILL. Now 
PowerMILL features both a horizontal and a vertical plugin window. 

 
  Vertical plugin window 

  Horizontal plugin window 

Automation 
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The horizontal layout of the new plugin window provides developers 
with a greater amount of flexibility when designing plugins. 

 Plugins are either displayed in the horizontal plugin window or 
the vertical plugin window. 

You cannot change where a plugin is displayed; this is 
determined by the developer. 

To display the plugin window's 'context menu', right-click on a 
plugin tab. 

  
Hide single tab — Select to only display plugin tabs when there are 
two or more plugins enabled. 

Manage plugins — Select to display the Plugin Manager. The Plugin 
Manager enables you to manage the plugins that are currently 
installed on your PC. 

To specify the plugin windows' default settings, use the new Plugin 
Windows page. 
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Macro programming enhancements 
The macro programming language now includes the ability to: 

 Create entity variables. 

 Execute a macro string as a command using DOCOMMAND. 

 Allow users to select multiple entities from a list. 

 Pause a running macro to allow user selection and picking. The 
command to do this is: 
MACRO PAUSE "User help instructions" 

For more information, see the Macro Programming Guide. 
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There are a few general enhancements: 

 PowerMILL now makes more effective use of memory. This 
improves calculation times of area clearance toolpaths on large 
parts. 

 There is less fragmentation of toolpaths when stock model rest 
roughing. 

 Arc fitting is much improved and more reliable. Arc fitting is 
available from the high speed pages of area clearance, constant 
Z and raster strategies. 

 When using stock engagement, much improved safety and 
efficiency of ordering of constant Z toolpaths . 

 You can now export models as .stl files even when no machine 
operations have taken place. You can determine the Triangle 
export tolerance on the Options dialog (available from Tools > 
Options > Export > Model menu).  

 
Triangle export tolerance determines the accuracy used to 
translate from the dgk format to an stl format. 

 New parameters are available for tool holder and tool shank 
components. You can use these parameters in macros and setup 
sheets.  

For example: 

tool.ShankSetValues[0].UpperDiameter for the upper 
diameter of the first shank component.  

General enhancements 
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tool.HolderSetValues[2].Length for the length of the third 
holder component. 

 Toolpath strategy dialogs open twice as fast in PowerMILL 2013 
as in 2012 R2. 

 There is a new option on the individual Model > Edit menu of 
Convert to Reference Model. This converts the model to a 
reference model. A reference model contains geometry which 
isn't considered for machining, but may be used for construction 
purposes or clamp arrangements. This option allows you to 
create geometry ion PowerSHAPE and import it into PowerMILL 
and then convert it to a reference model. 

 The Delete Selected menu option has moved from the File menu 
to the View menu. This option deletes selected items in the 
graphics view, excluding model components and toolpath 
segments. 

 

Measurer enhancements 
The Measure dialog now includes the ability to easily measure the 
apparent angles of the defined line (or two points). Although it was 
possible to find the apparent angle in version 2012 R2, it wasn't as 
easy to use as the old Measurer dialog (version 2011). 
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Clicking  displays the Measure Difference mode toolbar. 

 
Click two points on the model to measure the distance and see the 
apparent angles.  

For example: 

 
The Measure Difference mode toolbar closes and updates the 
Measure dialog with the distance between the two points and the 
apparent angles. 
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