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This course covers the 3-Axis functionality available in PowerMILL. Additional Five 

Axis license options are covered on a separate course. 

PowerMILL can quickly create gouge-free cutter paths on imported component 

data. It supports Wireframe, Triangle, Surface, and Solid models created by other 

Delcam products or from neutral formats such as IGES. If the relevant Delcam 

Exchange translators are purchased, PowerMILL will also directly import data 

created by other proprietary CAD packages. 

Start PowerMILL 

1 Double-click the PowerMILL shortcut on the desktop:  

 On the training PC, the icon will be displayed as PowerMILL. 

The PowerMILL screen is displayed: 

 

The screen is divided into the following main areas: 

a Main menu 

 

1. Getting Started 
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Click one of the menu names on this bar (for example, File) to open a pull-down 

menu list of associated commands and sub-menus. A sub-menu is indicated by a 
small arrow to the right of the text (for example File - Recent Projects >). 

Highlighting this arrow generates a list of commands/names specific to that sub-
menu (for example, File - Recent Projects displays a list of recently opened 

projects that open directly when selected). 

b Main Toolbar (shown un-docked) 

 

This provides quick access to the most commonly used commands in 

PowerMILL. 

c Explorer  

 

The PowerMILL explorer provides access and storage of PowerMILL entities 

created during the session. 

d Graphics Window 

This is the large, visual display area to the right of the Explorer (Look at the 

illustration on previous page). 

e View Toolbar (shown as horizontal) 

 

Provides quick access to standard view and shading options in PowerMILL. 

f Information Toolbar  

 

This area provides a reminder of some of the active setup options. 

g Tool Toolbar 

 

Facilitates the rapid creation of tools in PowerMILL. 

Most available toolbars are not factory defaults, and are therefore not shown at 

initial start-up. To display any of these, select them under View > Toolbar.  
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For example, select View > Toolbar > Toolpath to display the Toolpath 

Toolbar. 

 

 

 

 

The Toolpath toolbar appears (as shown below). 
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Changing the Background Colour. 

To change the background colour of the graphics area, select Tools > 

Customise Colours and from the dialog select View Background.  

 

 

The Top and/or Bottom colours can be changed independently and reset using 

Restore Defaults to restore to the original settings: 

 

PowerMILL remembers Toolbar and colour selections from one session to the 

next. For example, if a Toolbar is open when the session is closed, it will appear 

the next time PowerMILL is opened. 
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Mouse buttons 
Each of the three mouse buttons performs a different dynamic operation in 

PowerMILL. 

Mouse button 1: Pick and Select 

 

This button is used for selecting items on menus, options on dialogs, and entities in 

the graphics area. 

The method of selection is controlled by 2 options accessed from the Viewing 

toolbar, the default being Select using a Box. 

 

Select using a box 

 

If the cursor is positioned on an entity, such as part of a surface model, and if the 

mouse is clicked, then the item turns yellow indicating that it is selected.  

 If you select another surface, all currently selected items are de-selected. 

� If you want to select more surfaces to add to the currently selected surface, 
then, while making selections, hold down the Shift key on your keyboard. 

� If you want to remove a surface from your current selections, hold down the Ctrl 

key on your keyboard and click on the surface that you want to remove. 

Select by dragging the cursor 

 

Use this option to select multiple entities by dragging the cursor across the required 

items. This is ideal for quickly selecting multiple surfaces on a model. To deselect 
entities, press the Ctrl key when dragging across an entity. 

Mouse button 2: Dynamics 

 

� Zooming in and out: Hold down the Ctrl key and mouse button 2. Move the 

mouse up and down to zoom in and out. 
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� Pan around the model: Hold down the Shift key with mouse button 2. Move the 

mouse in the required direction. 

� Zoom Box: Hold down the Ctrl and Shift key, drag a box around the area to 

zoom into using the middle mouse button. 

� Rotate mode: Hold down mouse button 2 and move the mouse, and the 

rotation is centred about the tracker ball. 

� View Spinning: Dynamically rotate the view and quickly release the mouse. 

The faster the mouse movement, the faster it will spin. This feature is switched 

off by default. Select Tools > Options > View > 3D Graphics and select the 

Spin View option to enable it. 

 

 

 

Mouse button 3: Special Menus & PowerMILL Explorer 
Options 

 

When this button is pressed it brings up a local menu relating to whatever the 

mouse is over, such as a named item in the PowerMILL explorer or a physical 

entity in the graphics area. If nothing specific is selected, the View menu appears.  
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HELP! 
PowerMILL provides you with help in a number of ways: 

� Tooltips: Place the mouse cursor over a menu button. A description is of what 

the button does is displayed.  

� Online Help: Select Help > Contents from the Main Toolbar to access the online 

help documents.  There is a full index and search facility provided. 

� To see a summary of all new functionality available in the current version of 

PowerMILL, select Help > What’s New. 

 

� Context Sensitive Help: Press the F1 key to display the help page for the 

currently active dialog. Click the  button in the top right hand corner of the 

dialog, followed by a left click in any of the input fields to focus on the help topic 

for that part of the dialog. 

� PowerMILL User Forum: On the Main toolbar, select Help > Visit the User 

Forum, to participate in web-based user discussions on PowerMILL issues.  

� The link to access the forum from any other internet connection is: 

http://forum.delcam.com/ 

� Telephone and Email Support: UK customers with up-to-date software 

maintenance can call 01216831010 or mail support@delcam.com to get help or 

advice on specific application problems. 
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Simplified PowerMILL Example  
This example provides a quick overview of the machining process. It shows how to 

create and output a couple of simple toolpaths on a model of a valve chamber using 

default settings wherever possible. 

The basic procedure is: 

a Start up PowerMILL. 

b Import a Model. 

c Define the Block that defines the material size (or 3D machining limits). 

d Define the cutting Tools to be used. 

e Define set up options (Rapid Move Heights – Start and End Point). 

f Create a Roughing Strategy. 

g Create a Finishing Strategy. 

h Simulate the toolpaths. 

i Create an NC Program and output as a post-processed NC data file. 

j Save the PowerMILL Project to an external directory. 

 

Import a Model 
2 From the Main menu select File > Import Model and browse for the model 

file: 

              .....\PowerMILL_Data\Models\PmillGettingStarted.dgk 

 

3 Select an ISO 1 view.  
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Blanking model entities 
Use the Blank Selected (Ctrl + J) option available on the Model context menu to 

temporarily hide the selected model components. 

In the illustrations below, the light blue surfaces are selected. 

 

Use the Blank Except (Ctrl K) option available on the Model context menu to 

temporarily hide all model components except the selected ones. 

The 2 selected items are light blue. 

 

To re-display all model components, right-click in the graphics area and select 

Unblank (Ctrl L). The blanked model components are displayed and selected (back 
to the left hand image above). 

You can also toggle between the blanked and unblanked status of model 

components. Select the Blank Toggle (Ctrl Y) option to switch between the 

Blanked and Unblanked components of the model. 
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Defining a Block 
The Block dialog is used to define the 3D working limits. This could be the actual 

raw material size or a user-defined volume, localised to a particular part of the 

component. 

The settings on the Block dialog are set by default to Defined by – Box. Individual 

values in the dialog can be edited or locked (greyed out) as required. Enter a value 

in the Expansion field to include an offset in the block calculation.  

Click the Calculate button to define a block around the model dimensions. 

1 Click the Block  button on the Main toolbar to display the Block dialog. 

 

2 Click the Calculate button. 

3 Click Accept. 
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Defining a Cutting Tool 
The Tool dialogs are accessed using the various tool buttons on the Tool toolbar. 

This is located to the bottom left corner of the graphics area.  

For this example, 2 tools will be created, A Tip Radiused tool for roughing out and 

a Ball Nosed tool for finishing. 

1 Click the down arrow to display all the Tool options . 

2 Place the cursor over a tool to view the description of the tool type (Tool tips).  

 

3 Select the Create a Tip Radiused tool button . 

The Tip Radiused Tool dialog is displayed.  

 

4 In the Tip Radiused Tool dialog, enter: 
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a Name – D12TR1 It is recommended that the tool is renamed with a more 

relevant identification. 

b Diameter – 12 When you enter a value for the Diameter, the tool Length 

automatically defaults to five times this value. You can edit this value if 

needed. 

c Tip Radius – 1 

d Tool Number – 1, A Tool Number can be output to the NC Program. If 

the machine has a tool changer, this number will represent the location in 

the carousel. 

e Click Close on the Tip Radiused Tool dialog.  

5 Define another tool, this time, select the Create a Ball Nosed tool button and 

in the Ball Nosed Tool dialog, enter: 

a Name – BN12 

b Diameter – 12 

c Tool Number – 2 

d Click Close on the Ball Nosed Tool dialog.  

6 In the PowerMILL explorer panel on the left of the screen, open Tools and 

right mouse click D12TR1 tool to raise the local menu and select Activate. 

 

 Only one tool can be active at any one time and the word Activate in the 

tool context menu is prefixed with a tick . The active tool is 

automatically included in a strategy dialog when the strategy is created. 

In the PowerMILL explorer, the Active tool is displayed in bold text 

and prefixed with ‘>‘. 

Rapid Move Heights 

The Rapid move heights  options provide safe control rapid tool movements 

across the component. 

� Safe Z is the height above the job at which the tool can move at a rapid 

feedrate, clear of any obstructions such as the work piece or clamps. 

� Start Z is the height to which the tool will descend, at rapid feed rate prior to 

applying the plunge feed rate. 

PowerMILL displays rapid moves as dotted red lines, plunge moves as pale blue, 

and cutting moves as green. 
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Setting up Rapid Move Heights 

1 On the Main toolbar, click the Rapid Move Heights button  to open the 

Rapid Move Heights dialog. 

 

2 Click Calculate. 

3 Click Accept. 

 

This sets the absolute Safe Z and Start Z values to be above the Model or 

Block by the incremental distances, displayed in the Calculate dimensions 

area of the dialog. 
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Tool Start and End Point 
The Start and End Point dialog allows you to define a position where the tool 

travels to before and after a machining strategy.  

Click the tool Start and End Point button  on the Main toolbar to display the 

Start and End Point dialog. 

By default, the tool Start Point is set to Block Centre Safe and the End Point is 

set to Last Point Safe. 

 

 

Other Start and End Point settings are configured by selecting the different 

options in the Method area on the dialog. 

These include Block Centre Safe, First/Last Point Safe, First/Last Point, and 

Absolute. 

For now, click Accept to use with the default settings. 

 

The D12TR1 tool is placed at the Block Centre Safe position ready for you to 

create the first toolpath. 
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Creating a Roughing Strategy 
1  From the Main toolbar select the Toolpath Strategies button. 

 

2 From the left hand list select 3D Area Clearance 

 

3 From the right hand list select the Model Area Clearance strategy. This 

displays the Model Area Clearance strategy dialog. 

 

4 In the Model Area Clearance strategy dialog: 
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a In the Toolpath name field, enter D12TR1-RGH1. 

b Select Style – Raster with Profile - Climb and Area - Any. 

c Edit the Thickness value to be 0.5 (This is the amount of material that will 

be left on the job). 

d Edit the Stepover value to be 8 (This is the distance between each raster 

pass (the width of cut)). 

e The Stepdown value (depth of cut) is left at the default value of 5. 

f Click Calculate to process the machining strategy. 

 

Simulating the toolpath 
5 From the PowerMILL explorer right mouse click on the Toolpath          

D12TR1-RGH1 and from the local menu select, Simulate from Start. 

 

The Simulation toolbar will appear just above the graphics area. 

6 From the Simulation toolbar click the Play button   to run the Simulation. 

 

 

 The buttons beyond Play enable other actions such as Pause, Step, 

Search, and Go to. 
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Creating a Finishing Strategy 
7 In the PowerMILL explorer, right click the BN12 tool and select Activate (or 

double left click on the tool’s, PowerMILL explorer, icon). 

8 From the Main toolbar select the Toolpath Strategies button. 

 

9 From the left hand list select Finishing. 

 

10 From the right hand list select the Raster Finishing strategy and click OK.  
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11 In the Raster Finishing strategy dialog: 

a For the Toolpath Name, enter BN12-FIN1. 

b Edit the Stepover value to 0.3 

c Click Calculate to process the machining strategy. 

 

The Raster Finishing pattern is projected down Z onto the component, taking 

into account tool geometry and machining settings. 

 The toolpath link moves, clear of the job, are not displayed in this illustration 

for clarity. 

Toolpath Simulation and ViewMILL 
PowerMILL provides two levels of options for simulating toolpaths:  

� The first level Simulates the cutting tool movement along the toolpath. 

� The second level (ViewMILL) includes a shaded image of the stock material 

being progressively reduced as the tool moves along the toolpath. 

Toolpath Simulation 

12 In the PowerMILL explorer, right-click on the toolpath                        
D12TR1-ModelAreaClear and from the local menu select Activate. 

 

The Active toolpath is displayed in bold text and prefixed with a > symbol. 

13 In the PowerMILL explorer, right-click on the roughing toolpath           

D12TR1-ModelAreaClear and select Simulate from Start. 
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14 The Toolpath Simulation toolbar is displayed at the top of the screen. This 

displays the name of the toolpath and tool, together with buttons to control the 
simulation. 

 

Using the simulation control buttons, you can: 

�  Play - start the simulation and play it in continuous mode. 

�  Pause - pause the simulation. 

�  Step Back - step the simulation back by tool moves. Click the Play button 

to resume continuous mode. 

�  Step Forward – step the simulation by tool moves. The faster the speed 

(defined using  Speed Control) the bigger the step. Click the Step 

Forward button again to see the next move or click the Play button to resume 

continuous mode. 

�  Search Backward - step the simulation back to the previous toolpath 

segment.  

�  Search Forward - step the simulation to the next toolpath segment. Click 
the Search Forward button again to see the next component or click the Play 

button to resume continuous mode. 

�  Go to Beginning - moves to the start of the toolpath. 

�  Go to End - moves to the end of the toolpath. 

�  Speed Control - controls the speed of the simulation. The fastest 

setting is by having the slider at the right, the slowest at the left. 

�  Select Point to Point (toolpath points per second) or Feedrate (a 

multiple of the stored federate) as the basis for the simulation 

feedrate. 

15 Click the Play button  and Simulate the toolpath. 

16 Activate the finishing toolpath BN12-FIN1 and repeat the simulation process. 
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ViewMILL 
1 Activate the roughing toolpath D12TR1-RGH1 and select it in the Simulation 

Toolbar. 

2 From the Main pull down menus, select View > Toolbars > ViewMILL to raise 

the ViewMILL Toolbar. 

 

The ViewMILL toolbar is displayed. Initially, all the buttons are greyed out. 

 

3 Click the  button to toggle the graphics window into the ViewMILL mode  

(The ViewMILL toolbar buttons are now active). 

 

4 Click the  button to select a Plain Shaded Image. 

 



PowerMILL 2016 1. Getting Started 

 Copyright © Delcam Ltd  1 - 21 

5 Click the Tool button  to display the tool. 

6 Click the Play button  to start the ViewMILL simulation. 

 

 

 

7 After the simulation has finished, select the toolpath BN12-FIN1 on the 

Simulation toolbar, followed by the tool button . 

8 Click the Play button  again to view the continued simulation of material 

removal by the finishing toolpath. 

 

9 In the Simulation toolbar, select the Close button  to delete the 

ViewMILL session. 
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NC Programs (Post-Processing and NC data Output) 
1 From the Main menu, select Tools > Customise Paths to open the 

PowerMILL Paths dialog. 

 

This displays the PowerMILL Paths dialog. 

 

2 In the PowerMILL Paths dialog, select the option NC Programs Output. 

 

This controls where the post-processed, NC data files are output ready to 

download to a machine tool controller. 

3 Click the Add path to top of list button. 

4 In the Select Path dialog which appears, browse to the required location 

C:\Temp\NCPrograms and click OK. 

5 In the PowerMILL explorer, right-click NC Programs and select Preferences 

to display the NC Preferences dialog. 



PowerMILL 2016 1. Getting Started 

 Copyright © Delcam Ltd  1 - 23 

 

NC Preferences enables you to control the content of output files to download 

to a machine tool. 

 

The Output Folder defaults to the location already defined in Tools > 

Customise Paths. 

6 In the NC Preferences dialog, click Machine Option File button. This displays 

the Select Machine Option Filename dialog. 
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7 Select heid400.opt and click Open. This selects the heid400.opt file and 

returns you back to the NC Preferences dialog. 

8 Close the NC Preferences dialog. 

9 In the PowerMILL explorer, right-click NC Programs and select Create NC 

Program. 

 

An empty NC Program appears in the PowerMILL explorer and the NC 

Program dialog is displayed. 

10 Within the PowerMILL explorer, use the left mouse to select and drag the 

toolpath D12TR1- ModelAreaClear onto the NC Program 1. 

 Alternatively, right-click on the toolpath D12TR1-RGH1 and select Add to > NC 

Program. 

 

A copy of the toolpath name will appear in the NC Program indicating that it 

has been assigned as part of the output file. 
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11 In the PowerMILL explorer, click and drag the toolpath BN12-RasterFinish 

onto NC Program 1. 

Click the small + box to expand and view the contents of the NC Program.  

 

The toolpath names are listed in the NC Program ready to be post-processed. 

12 In the NC Program dialog displayed in the graphics area, click the Write button 

to start the post processing operation. An Information dialog is displayed with a 

progress and confirmation summary. 

 

13 Close both the NC Program and Information dialogs. 

14 You can find the created NC data file 1.tap under C:\temp\NCPrograms on 
your computer. 

 

Saving the Project 
15 On the Main toolbar, click the Save button. 

 

 As this is the first time that this Project is saved, the Save Project As 

dialog will open. 
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If the Project has been Saved before, then it will simply be updated.  

16 From the Main menu , select File > Save Project As:- 

......\COURSEWORK\PowerMILL-Projects\PmillGettingStarted 

17 From the pulldown menus, select File > Delete All, followed by Tools > 

Reset Forms. 

The content of PowerMILL explorer is deleted and all dialogs are reset to their 

default settings.  

The externally stored copy of the Project (PmillGettingStarted) can be 

reopened as required. 

Additional Exercise 

1 Import the Model:- 

......\PowerMILL_Data\Models\facia.dgk  

 

2 Save the Project as: 

......\COURSEWORK\PowerMILL_Projects\Facia-1 

3 Use the same Tools and machining strategies to those in the previous 
Project (PmillGettingStarted). 

4 Once this exercise is completed (and saved as a Project) locate the pulldown 

menus, and select File > Delete All followed by Tools > Reset Forms. 
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In the previous section, the toolpaths were created using the default values 

wherever possible.  

We will now look at the machining Setup options in more detail.  

In particular: 

� Setting up direct access to regularly used files using Customise Paths. 

� Setting Feed rates. 

� Workplanes (Positional datums) to create appropriate machining set ups. 

� Tool with Shank and Holder definition. 

 

PowerMILL Panes 
The PowerMILL panes are located above the PowerMILL explorer area. 

 

 

� The first pane  displays the PowerMILL explorer (as shown above). 

 

� The second pane  displays the HTML browser used for viewing Help files. 

 

� The third pane  opens the PowerMILL Recycle Bin. Entities deleted from 

the PowerMILL explorer can be recovered from the Recycle Bin. 

 

2. Machining Setup 
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Setting up direct access to regularly used folders 
1 To Import a Model via the Main pull down menus, select File > Import 

Model.  

 

The Import Model dialog is displayed. 

 

 

 

�  - changes the directory to the current Project directory.  

�  - changes the directory to the Examples directory.   

This folder contains a selection of sample model files which are installed 
within the PowerMILL installation in a directory called Examples.  

�  - changes the directory to the first user-defined directory. 

�  - changes the directory to the second user-defined directory. 

 

To customise the paths for user-defined directory folders:  
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2 From the Main menu select Tools > Customise Paths. The PowerMILL 

Paths dialog is displayed. 

 

3 Select the File Dialog Button 1 option from the drop-down list. 

4 Click the Add path to top of list  button and browse to: 

           ......\PowerMILL_Data\Models 

 

5 Click OK. 

6 Repeat steps 2 and 3, but this time select the File Dialog Button 2 option 

to link directly to: 

           ....\PowerMILL_Data 

 Outside the training environment, the location of the PowerMILL_Data 

directory will depend on where you have installed it! 
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Loading a model into PowerMILL 
1 From the Main menu, select File > Import Model. 

2 Use Shortcut Button 1 or browse to: 

....\PowerMILL_Data\Models 

 

 A variety of Model formats can be imported into PowerMILL. Use the Files 

of type filter to widen or narrow your choice. 

 

 Please note:  direct transfer - file formats (eg: CATIA, ProENGINEER, etc) 

are only available as a cost option.  

 

3 Back in the main form, select the file WorkplanesExample1.dgk and then 

click Open. 

4 From the Viewing toolbar (Right of graphics area) select Resize to fit   

. 

 

The model is re-scaled to fit within the PowerMILL graphic area. 
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Viewing the Model 
Although the model is displayed, it is a good idea to look at it from all angles to 

fully understand its size and features. 

 

 

                Above is the Views toolbar (shown aligned horizontally). 

 

By default, the Viewing toolbar is aligned to the right hand side of the graphics 

area. These options mainly include basic visual orientations along with several 

shading modes, many of which provide specialist analysis of the model. 

5 From the View toolbar, select an isometric ISO 1  view. 

 

In most cases, the X dimension of a machine tool table will be greater than Y; in 

which case, the longer side of the component may exceed of the travel limits in Y. 

If this is the case, it will be required to align the component with the longest side 

along X to ensure that it can be positioned within the travel limits. 

Saving the Project 
It is good practice to create a Project as soon as possible and then to Save it at 

regular intervals during the session. 

 

6 On the Main menu, select File > Save Project As: 

....\COURSEWORK\PowerMILL-Projects\WorkplaneExample1-EX1 
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Setting Feed rates 
The current Feed rate values are applied directly to a newly created toolpath. The 

Feed rate values can be stored in a Tool definition to update the Feed rate dialog 

accordingly on Tool activation. At this stage we will look at manually setting the 

feed rate individually. Click the Feeds and Speeds button  on the main 

toolbar to display the Feeds and Speeds dialog. 

 

The default values (as shown above) can be modified as required and Accept 

selected for them to be the default for future toolpaths.  Apply is used to update 

the Feeds and Speeds of an active toolpath. Note Apply is  ‘greyed out’ if there 

is currently no active toolpath.   

 

 

Creation and Application of Workplanes. 
When a model is imported into PowerMILL it is more than likely that the original 

global datum (Transform) will not provide a suitable position/orientation for tool 

setting or applying machining strategies.  

Workplanes provide the ideal method of creating suitable machining datums and 

alignments without having to physically move the component model. 

Workplanes are additional datums that can be moved and/or orientated within the 

global environment. Only one workplane can be active at any one time. If no 

workplane is active, then the original global Transform is the datum. 

By deactivating a workplane, the original coordinate set-up can easily be re-

activated for tasks such as checking original dimensions or for importing a ‘new 

issue’ updated model. 
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Workplane (1) - At Top of Selection 
7 With the left mouse button depressed, drag a box over the entire model to 

select it. 

8 In PowerMILL explorer, right-click Workplanes and select Create and 

Orientate Workplane > Workplane at top of Selection. 

 

A Workplane is created and appears at the top-centre of the selected model. 

The new Workplane 1 also appears as an entity in the PowerMILL explorer.  

9 Right-click the newly renamed Workplane 1 and from the local menu 

select Activate. 

 

The next step will be to rotate the new Active - Workplane - 1 to re-orientate 

the model such that the longer side is aligned to the X-Axis. 

10 From the same local menu, select Workplane Editor to display the 

Workplane editing toolbar. 

 

11 Double click the Twist about Z button. This displays the Twist dialog. 

12 Enter Angle 270 and click Accept. 

 

13 Click the Green Tick   located to the right of the Workplane toolbar 

to accept the changes. 
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14 Select a View from top (Z) to see the effect of the rotated, Active 

Workplane providing a more suitable machining position for the model. 

 

The Workplane is shown positioned on the top of the model, which has the 

longer edge aligned to X. 

Workplane (2) - Positioned using the Block 
Another method of creating a Workplane is from key points on the defined 

Block. 

15 From the main menu, select the Block Icon  the following form will 

appear select Active Workplane press Calculate followed by Accept. 
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16 In the PowerMILL explorer, Right mouse click on Workplanes to access 

the following menus. 

 

17 Select Workplane Positioned using Block from the above menu. 

18 Click the new Workplane on to the orange sphere located at the centre of 

the bottom face of the Block. 

 

 The new workplane will inherit the default name 2. 

 

19 Right click on workplane 2 and from the local menu, select Activate. 
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 Note that Block definition moves relative to the active datum. 

 

20 Activate the new Workplane and from the local menu select the 

Workplane Editor. 

 

21 Select X Twist, and in the dialog enter 180 degrees to make the new 

workplane normal to the underside of the model. 

22 Select Accept  for the new workplane 2 to be updated. 

 

The Block returns to the correct position relative to the model which in this case is 

dimensionally the same for both Workplanes 1 and 2 when either is Active.  

 

23 De-activate Workplane 2. 
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The Block is now dimensionally positioned relative to the global Transform. 

 

24 Select File - Save Project:-  

 

The contents of the Project saved earlier will be updated. 

 

Block Coordinate System 
The above type of Block Co-ordinate, definition (Active Workplane) is ideal for 3 

Axis applications. The physical re-positioning of the Block will provide a useful 

visual warning if the machining datum, Workplane is de-activated. 

 

 

Other Coordinate System options become essential for advanced applications such 

as multi-axis, 3Plus2 set ups. In this case the Block definition can be fixed to 

either the Global Transform or a Named Workplane.  

 

 



2. Machining Setup in Detail PowerMILL 2016 

2 - 12  Copyright © Delcam Ltd  

Workplane Aligned to Geometry 
This option enables the user to create a Workplane perpendicular to a face using 

Workplane aligned to Geometry. The next example shows this in detail. (See 

original model orientation).  

1 Select File - Delete all followed by Tools - Reset forms. 

 

2 Import the Model:- 

             ......\PowerMILL_Data\Models\InteriorTrim.dgk 

3 With the centre mouse wheel held down, move the mouse to rotate the 

view of the Model so that the base of the pocket is fully visible. 

 

4 Right click on Workplanes and select Create and Orientate Workplane 

followed by Workplane aligned to Geometry. 
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5 Left mouse click on the base of the pocket (as shown below) to locate a 

new Workplane (with its Z-axis normal to the surface). 

 

6 In the PowerMILL explorer, right click on the new workplane and select 

Activate. 

 

 

7 Use the left mouse and click on the bottom face of the pocket to make it 

selected (shaded light blue below right). 

8 Then right click on Workplanes to open the local menus below. 

 

 

9 From Create and Orientate Workplane, select Workplane at Top of 

Selection. 

10 The new Workplane will be centrally located at the base of the pocket.  

11 Rename the new Workplane as Datum and make it Active. 

12 Delete the original Workplane. 
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The new Workplane is central to the pocket base as shown below. 

 

13 Save the Project as:-  

......\COURSEWORK\PowerMILL_Projects\Workplane-Example2 

14 Select File – Delete all followed by Tools – Reset forms. 

 

Other local Workplane menu, creation options  
 

a Create Workplane produces a single Workplane on the current active 
datum and opens the Workplane Editor context toolbar. 

b Create and Orientate Workplane opens the following form, that provides 

a selection of specialised Workplane creation options. 
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Speaker Core Example - Set Up 
1 Import the Model:-    

 ......\PowerMILL_Data\Models\speaker_core.dgk 

 Use Button 1   in the Import Model dialog for quick access! 

 

For this example it is required for the long side of the component to be aligned to 

the X direction and not Y as shown above.  

2 Depress the left mouse key and drag a box across the whole model to 

select all Surfaces. 

3 From the PowerMILL explorer, select Workplanes - Create and 

Orientate Workplane – Workplane at Top of Selection. 

4 In the PowerMILL explorer right mouse click on the new Workplane and 
from the local menu select Workplane Editor. 

 

 

5 In the above toolbar, click on the Z-Twist option and enter 90 in the form 

for the Workplane rotation angle. 

 

6 Accept the Twist form and then click on the Green tick on the toolbar to 

exit the Workplane Editor (and finally accept the changes). 

7 Activate the new Workplane 1. 
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8 Select an ISO 1 view. 

 

The long side of the component is now running along the X direction. 

Now that the component model is suitably aligned, the next stage is to create 
some suitable cutting Tools ready to carry out the machining process. 

 

Tool and Holder Definition 
For the cutting Tools in this example the Shank and Holder will be included as 

part of the overall definition.  

Note it is also possible to store specific feeds and speed values in a Tool 

definition. Not a default setting, but PowerMILL can be set to recognise these 

and automatically update the Feeds and Speed dialog on activation of the 

Tool. 

 

9 From the PowerMILL explorer select Tools - Create Tool - Tip 

Radiused. 
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10 In the Tip Radiused Tool dialog, input a Name D50TR6 - Diameter 50 - 

Tip Radius 6 - Length 160 - Tool Number 1. 

 

11 In the Shank dialog, click Add a shank component  and enter: 

Upper/Lower Diameter 50 and Length 100. 

 

12 In the Holder dialog, click Add holder component   and input: 

� Upper Diameter – 120 

� Lower Diameter – 90 

� Length – 50 

� Overhang - 200 
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 The Overhang is the vertical distance from the bottom of the Holder to 

the bottom of the tool Tip. 

 

13 In the Holder dialog, click the Add holder component button . Enter: 

� Upper Diameter – 120 

� Lower Diameter – 120 

� Length – 50 

 

14 In the Holder dialog, click the Add holder component button Enter: 

� Upper Diameter – 150 

� Lower Diameter – 150 

� Length – 25 
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15 Close the dialog. 

 

 You can control the style in which the tool is displayed in the graphics 

window. In the PowerMILL explorer, right-click on the Tool - D50TR6 

and from the local menu,  select Shaded. 

 

 A Tool can be saved outside PowerMILL as a permanently stored 

template (.ptf).  

 

 The tool must be the only item in the PowerMILL explorer as all 

saveable entities will also be added to the template file. 
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Block Definition 

The default option for Block  is Box (A rectangular volume). Other options 

include Cylinder (a cylindrical volume), a Triangle model (eg Casting), and 

Picture/Boundary (Extruded 2D wireframe contours). 

The dimensions of the Block can be entered manually or calculated directly to 

the Type of entity: Model, Boundary, Pattern, or Feature. 

The Opacity slider controls the degree of shading (from the left, initially 

wireframe and then graduating from clear to dense). 

 

16 Calculate a Block using Defined by - Box and Type - Model. 

 

17 Move the Opacity slider fully to the left for a wireframe Block. 
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Rapid Move Heights 

The Rapid Move Heights  options enable safe rapid moves between tool 

tracks clear of the top of the Model or Block (whichever is the higher).  

18 In the Rapid Move Heights dialog, click the Calculate tab to set Safe Z 

and Start Z to the default values of 10 and 5 respectively above the Model 

or Block. 

 

 The Rapid Move Heights are calculated relative to the highest point on 

the Block or Model.  

 If parts of the model are selected, then the de-selected parts will be 

ignored when the Rapid Move Heights are calculated! 

 

 

By default the Tool will traverse across Safe Z and then drop to Start Z using a 

Rapid move (eg G0). It will then continue downwards at the Plunging Feed 

Rate (eg G1). 
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Start and End Point 

The Start Point and End Point define the first and last points on a toolpath. 

These can be controlled using 4 different positional options. 

 

 

19 In the Start and End Point dialog, Accept the default settings : 

c Start Point - Block Centre Safe 

d End Point - Last Point Safe 

 

                                                      

Save Project 
20 It is essential to regularly Save your work outside the PowerMILL session. 

By saving to a Project the contents of the PowerMILL explorer are saved 

into an external folder. 

21 Select File - Save Project As:- 

         ....\COURSEWORK\PowerMILL-Projects\Spkr-Core 

 

 Do Not Close the Project as it will be continued in the following chapter. 
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The main strategies for roughing a 3D component model are called 3D Area 

Clearance. These provide a choice of 2D material removal methods, which 

progressively machine the area (Slice), up to the component contour, down a 

sequence of user-defined Z Heights. 

 

 

Thickness and Tolerance (Applied to 3D Area Clearance) 
Suitable values are required to control the accuracy and amount of excess material 

to be left on a component by a toolpath. The parameters used for this purpose are 
preset and are called Thickness and Tolerance.  

Thickness is the amount of extra material specified to remain on the work-piece 

after machining. This can be applied generally (as shown), or independently as 
separate Radial and Axial values within the machining options. 

 

3.  3D Area Clearance 
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Raster – Model Area Clearance example 
The Raster (Model Area Clearance) strategy follows a series of linear moves 

across the Block limiting to the component form at the active Z height. It then, (by 

default) performs a Profile pass around the component to leave a constant 

thickness around the Slice.  

1 Ensure that the recently saved Project (Spkr-Core) is still active. 

2 Activate both the Workplane and the tool D50TR6.  

3 From the main toolbar select Block  and using, Defined by Box – Type 

Model select Calculate followed by accept. 

4 From the main toolbar select Rapid Move Heights  and in the form select 

Calculate followed by Accept. 

5 From the Main toolbar select Toolpath Strategies  and from 3D Area 

Clearance open a Model Area Clearance strategy. 

 

6 Select OK to open the Model Area Clearance strategy form. 

 

 As soon as the Model Area Clearance dialog is opened, the unprocessed 

Toolpath appears in the PowerMILL explorer. 
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7 In the Model Area Clearance dialog: 

a Enter the Toolpath name as D50TR6-A1 

b Select Style as Raster. 

c For Cut direction - Area select Any 

d Set Thickness to 0.5 

e Set Stepover to 20 

f Set Stepdown to 10 

8 In the Model Area Clearance local explorer select Limit. 

 

9 In the Limit options, Block category, switch to limit tool center to block edge. 

10 Keeping all other values as default, Calculate the strategy. 

11 After the Toolpath has been created, close the dialog. 

 

 

 Double left mouse click on the explorer symbol (in this case ) to 

activate or de-activate the Toolpath. 

Click the small + box to expand and view data used to create the toolpath.  
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Rapid Move Heights combined with Leads and Links 
You can modify the basic Safe Z and Start Z from the Rapid Move Heights dialog.  

 

Click the Calculate button to set the Safe Z and Start Z to be at safe distances 

above the top of the Model (whole or selected) or Block (whichever is the highest).  

 Safe Z is always above Start Z. 

� Safe Z specifies a fixed height at which rapid moves across the work piece can 

safely occur. 

� Start Z specifies a fixed height at which the slower, plunge feed rate is applied 

before the tool cuts into the work piece. 

Rapid Move Heights works in conjunction with the Leads and Links dialog , 

providing a more comprehensive choice of Toolpath link options. 
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� Safe – Applies the plunge feed rate from a fixed height above the job. This is 

more predictable and reassuring, but the non-cutting (air) moves takes more 
time and is inefficient, especially in the case of large, deep components. 

 

 

 

� Skim - enables the downward, rapid feed rate to continue to a specified 

incremental Start Z above the full plunge depth before the slow plunge feed 

rate ‘cuts in’. Skim then applies a rapid retract to an incremental Safe Z above 

the highest point on the component ‘in line’ with a linear link move to the next 

plunge position. To cater for all types of machine tools, this move is a Skim 

Feed Rate (G1) (solid purple line), instead of a Rapid (G0) (dashed red line). 

 

 

 

� Incremental - applies the rapid feed rate all the way down to an incremental 

Start Z measured from the full plunge depth, at which point, the slow Plunge 

Feed Rate ‘cuts in’. The Plunge option differs from Skim in that all rapid link 

moves occur at the Absolute Safe Z. 

 

 The default Link move settings in the Model Area Clearance strategy 

template are Short/Long = Skim and Default = Incremental. 
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Feed Rates  
The Feeds and Speeds dialog uses the Style and Colour of elements along a 

toolpath to register the correct Rapid Move or Feed Rate values.  

� Fixed (G0) Rapid moves =  Red Dashed, Toolpath elements 

� Variable (G1) Feed Rate moves = Green/Orange, Toolpath elements. 

� Plunge (G1) Feed Rate moves = Pale Blue, Toolpath elements 

� Skim (G1) Feed Rate moves = Purple, Toolpath elements. 

1 From the Main toolbar, select the Feeds and Speeds button  and enter the 

values (shown below) in the Cutting Conditions area of the dialog. 

 

2 Click Apply to assign these values to the active Toolpath (D50TR6-A1) and then 

select Accept to close the dialog. 

3 In the PowerMILL explorer, right-click on the toolpath and select Settings…. 

 

 The toolpath can also be activated or deactivated using the Activate option in 

the context menu.  

4 This reopens the Model Area Clearance dialog. 

5 Select the make a copy of the Toolpath  button. 

6 On the left of the Model Area Clearance dialog is a local explorer window. 
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When a local explorer option is selected the individual page is displayed in the 

main dialog. This makes it easier to navigate specifically through the pages for 
the required strategy. 

 

7 From the local explorer, select the  to the left of Leads and links to access the 

further options Lead in, Lead out, and Links.  

 

8 In the Links page change the Short, Long, and Default link moves to Safe.  

9 Click Calculate to create a new Toolpath with the modified settings. Once 

processing is complete, close the dialog. 

 

The Tool now performs rapid moves (dashed red) at a fixed height (Safe Z) 

above the part (Default height is 10). 

All Plunge feedrate (pale blue) moves start from a height between the Safe Z 

and the top of the part (default height is 5) 
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Statistics 
Provides you with essential information about the active toolpath and associated 

parameters. 

1 In the PowerMILL explorer, right-click the latest Toolpath D50TR6-A1_1 and 

from the local menu select Statistics. 

The dialog with information about the toolpath and its associated settings is 

displayed. 

 

In this case, the total machining time is around 2hrs 40mins 

2 Right mouse click on the original Toolpath D50TR6-A1 and from the local menu 

select and view the Statistics. 

In this case, the total machining time is around 2hrs.  

This large time saving is achieved simply by using Skim in the Links dialog. In 

the original toolpath, Safe was used, resulting in an excessive amount of the 
Link moves being in fresh air. 

Simulating the toolpath 
3 Right mouse click on the Toolpath D50TR6-A1 and from the local menu select 

Simulate from Start.  

 

 If not already displayed the above Simulation toolbar will appear 

automatically. 

4 Use the Play button  to run the simulation and control the speed with the 

slider bar. 

5 If the ViewMILL toolbar is not already open, from the main pulldown menus 

select View – Toolbar – ViewMILL. 
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6 In the ViewMILL toolbar, select the Red sphere to connect ViewMILL to the 

simulation controls (The sphere will now be Green and the current Block will be 
loaded into ViewMILL). 

 

7 Select the Plain Shaded Image option and run the simulation again 

 

8 Switch the ViewMILL to No Image  to return to the PowerMILL session 

and then disconnect ViewMILL  from the simulation process.  

 

When you toggle back to PowerMILL, the ViewMILL session still exists in the 

background, ready to include further toolpaths as required. 

If the ViewMILL session is still connected, then, even though it is set to No 

Image, ViewMILL will continue to update it in parallel with any further toolpath 

simulations. 

Saving the Project 
9 From the Main menu, select File > Save Project.  

The Project (....\COURSEWORK\PowerMILL-Projects\Spkr-Core) is now 

updated.  

 

We will now delete the contents of the PowerMILL explorer and return the 

PowerMILL session back to the original default settings. 

10 From the Main menu, select File > Delete All. 

11 From the Main menu, select Tools > Reset Forms. 
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Other Model Area Clearance - Style examples 
There are 4 different Style options in the Model Area Clearance strategy. 

 

We have already used Style – Raster in the previous example. So for the next 

section we will simply show the basics of other 3 options (Offset Model, Offset All, 

and Vortex) on a single Z level. 

Offset Model – Basic example 
This variant of the Offset Area Clearance is primarily designed for High Speed 

Machining. It provides very consistent tool loading at the expense of increased 

number of rapid air moves across the component. This strategy, if applied correctly, 

can go a long way to minimise wear to both tooling and machine. 

The strategy is based on the profile around the component at each Z Height, being 

continually offset outwards, to be trimmed to the limits of the material Block.  

1 Import the Model: 

......\PowerMILL_Data\models\Handle.dgk 

2 Save Project As: 

......\COURSEWORK\PowerMILL_Projects\Handle 

 

 

3 Create a Dia 16, Tiprad 3, Tool named D16TR3. 

4 Calculate a Block  to the full model dimensions.  

5 Lock  the Z max and Z min values, enter an Expansion value of 10 and 

Calculate. 

6 In the Rapid Move Heights  dialog, select Calculate.  
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7 Select Toolpath Strategies , and from 3D Area Clearance open a Model 

Area Clearance strategy. 

8 Input data into the pages of the form exactly as shown below. 

 

9 Select the Offset page and tick the Spiral option. 

 

10 Select the Flat machining page and select Machine flats - Off. 

 

11 At the bottom of the dialog, click Calculate to create the Toolpath.  

12 Close the dialog and select an ISO 1 view. 
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 The toolpath is displayed above with the Leads and Links undrawn. 

13 In PowerMILL explorer, right-click the Toolpath and select Simulate from 

Start to display the Simulation toolbar. 

 

14 On the Simulation toolbar, select Play  to view the toolpath simulation. 

 To stop the simulation, press the Esc key on your keyboard. 

 

The tool continuously, climb mills, starting each tool track at a distance from the 

material Block to allow the tool to reach optimum Feed Rate before contact. 

The material removal rate in this type of strategy is generally very consistent. 

The strategy can be further improved using advanced settings to progressively 

smooth away sharp corners and straighten the toolpath geometry as it offsets 

further away from the component form.  

 

15 In the PowerMILL explorer, right-click the active D16TR3-OffsetModel 

toolpath and select Settings to reopen the Model Area Clearance dialog. 

16 Click  to create an active copy of the toolpath. 

17 In the Model Area Clearance dialog, select the High speed page. 
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a Select Profile smoothing and set Radius (TDU) to the maximum slider 

value of 0.2 

b Select Raceline Smoothing and set the slider value to 25 (%). 

c Click Calculate to create a new toolpath D16TR3_OffsetModel_HSM with 

the improved smoothing characteristics. 

 

Compare the Model Area Clearance toolpaths. Note the progressive 

straightening of tool tracks on the second strategy with 25% Raceline 

smoothing applied. 

 

 



 

3.  3D Area Clearance PowerMILL 2016 

3 - 14  Copyright © Delcam Ltd  

Offset All – Basic example 
This variant of the Offset Area Clearance is better suited to softer materials such 

as modelling foam, resins etc. It will remove material with a larger stepover and 

the minimum amount of lifts, but this is more than likely to result in the tooltracks 

containing sharp changes of direction and an inconsistent removal rate. 

 

1 In the PowerMILL explorer, right-click the active D16TR3-OffsetModel 

Toolpath and select Settings to reopen the Model Area Clearance dialog. 

2 Click  to create a copy of the Toolpath. 

3 Rename the new toolpath as D16TR3-OffsetAll. 

4 In the Model Area Clearance dialog, main page select Style – Offset All and 

then input data as shown below. 

 

 

 

5 In the Model Area Clearance dialog, select the High speed page and update the 

data as shown in the following illustration. 

 

 



 

PowerMILL 2016 3.  3D Area Clearance 

 Copyright © Delcam Ltd  3 - 15 

 

 

6 At the bottom of the dialog, click Calculate to create the Toolpath.  

7 Close the dialog and select an ISO 1 view. 

8 Perform a toolpath Simulation to observe the tool movement in this strategy. 

 

 

In the above Offset-All style toolpath, the tool plunges into the individual areas 

and profiles it’s way outwards following both the component model and Block 

forms. 
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Vortex - Basic example 
This specialist, variant of Model Area Clearance is primarily designed for use with 

solid carbide tools on hard materials. Wherever necessary the Vortex strategy 

applies complex, optimised trochoidal, movement to achieve the ultimate control 

over the loading on a cutting tool. 

 

1 In the PowerMILL explorer, right-click the active D16TR3-hsm_1 Toolpath 

and select Settings to reopen the Model Area Clearance dialog. 

2 Click  and create a copy of the Toolpath. 

3 In the Model Area Clearance dialog, main page select Style – Vortex. 

 

a Input Thickness 0.5 

b Input Stepover 1  

c Input Stepdown 20 

4 Select the Flat machining page and set Machine flats to Off. 
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5 Select the Vortex Page and set Minimum Radius (r) to 3.0 

 

Increasing the Minimum Radius value will enlarge the inherent Trochoidal 

moves which should in turn enable a higher Feedrate to be used with the 
Vortex strategy.  

6 Select the Unsafe segment removal page, tick Remove segments smaller 

than threshold and input a Threshold (TDU) value of 0.5 

 

7 At the bottom of the dialog, click Calculate to create the Toolpath.  

8 Close the dialog and select an ISO 1 view. 
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9 Select File - Save Project to update the contents of:- 

                  ......\COURSEWORK\PowerMILL_Projects\Handle 

 

10 From the Main pull down menus, select File > Delete All.  

11 From the Main pull down menus, select Tools > Reset Forms. 
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Area Clearance – Unsafe Segment Removal 
This option is designed to filter out machining of confined areas that involves a small 

movement of the cutting tool.  In the following example, it is applied to prevent a 

relatively large tool attempting to plunge into a deep pocket area where a smaller 

tool would be a better choice.  

1 Open the read-only Project:  

......\PowerMILL_Data\Projects\MountingBlock-Start 

2 Save Project As:  

......\COURSEWORK\PowerMILL-Projects\MountingBlock 

3 Activate the Toolpath named No-AreaFilter. 

 

The existing toolpath allows the cutter to machine into confined areas. This 

results in sudden sharp changes of cutting direction and excess loading on the 

tool. 

4 Right-click on the toolpath named No-AreaFilter and from the local menu, select 

Settings to open the original Model Area Clearance dialog. 

5 Click the Create a new toolpath based on this one button, to create a copy of 

the toolpath. 

 

 

6 Rename the copy of the toolpath as AreaFilter. 

7 In the Model Area Clearance dialog, select the Unsafe segment removal page.  

8 Tick the option, Remove segments smaller than threshold. 

9 Input a Threshold (tool diameter units) value of 0.5 

10 Un-tick the Only remove segments from enclosed areas option. 
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All tool tracks spanning a distance less than the Tool Diameter (TDU) are filtered 

out and will not appear in the final toolpath. 

11 Calculate the Model Area Clearance dialog and once processing is complete, 

close the dialog. 

 

Unsafe Segment removal has been applied to prevent the cutter attempting to 

plunge into and machine confined areas (Pockets). 

However, there are a couple of undesirable spikes on the remaining toolpath. 

These can be reduced by applying the High Speed - Profile Smoothing option. 

 

12 In the PowerMILL explorer, right-click the toolpath named AreaFilter and select 

Settings to open the original Model Area Clearance dialog. 

13 Click Create a new toolpath based on this one button, to create a copy of the 

toolpath. 

 

14 Rename the copy of the toolpath as AreaFilter-ProfileSmooth. 

15 In the Model Area Clearance dialog, select the High Speed page.  

16 Select the Profile Smoothing option with the Radius (Tool Diameter Units) 

value set to 0.2 
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17 Calculate the Model Area Clearance toolpath and once processing is complete, 

close the dialog. 

 

The internal, sharp corners around the toolpath outer profile are now smoothed. 

 

18 From the Main pull down menus, select File > Save Project to update the stored 

data (......\COURSEWORK\PowerMILL-Projects\MountingBlock).  

19 From the Main pull down menus select File > Delete All. 

20 From the Main pull down menus select Tools > Reset Forms. 
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Model Rest Area Clearance example 
It is generally good practice to use as larger diameter tool as possible for the initial 

Area Clearance operation. This ensures that the maximum amount of material is 

removed as quickly as possible. However, the large diameter tool may not have full 

access to certain internal corners or pockets within the component. As a result, 

these areas will require further roughing out with one or more, smaller diameter 

tools before running the Finishing strategies. 

In the Model Rest Area Clearance options, a smaller Tool is referenced either to 

an existing Toolpath or a Stock Model, such that tool tracks will only be produced 

locally within the remaining material (stock). 

1 Import the model: 

......\PowerMILL_Data\models\WingMirrorDie.dgk 

 

2 Save Project as: 

......\COURSEWORK\PowerMILL-Projects\WingMirrorDie-Ex1  

3 Create a Tip Radiused tool of Dia 40 tiprad 6 and Name D40TR6. 

4 From the Main toolbar open the Block dialog and Calculate using the default 

settings, Defined by - Box to and Type - Model. 

5 Using the default settings, select Calculate in the Rapid Move Heights. 
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6 Select Toolpath Strategies , and from 3D Area Clearance open a Model 

Area Clearance strategy. 

 

7 In the Model Area Clearance strategy dialog: 

a Enter Toolpath name - D40TR6-D1 

b Select Style - Offset Model 

c Input Thickness 0.5 

d Input Stepover 20 

e Input Stepdown 10 

 

8 In the local explorer, select the Limits page, and set the Block - Limit to Limit 

tool centre to block edge. 

 

 

9 In the local explorer, expand the Leads and Links options, and then select Lead 

In. 
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10 In the Lead in window, select 1st Choice - Ramp -  

 

11 Input the following Ramp Options: 

 

12 Click Calculate to process the Model Area Clearance toolpath. 

13 Select an ISO 2 view. 

 

The Offset Model - Area Clearance strategy follows the model contours while 

gradually offsetting into the remaining material at each Z Height. 

  

14 Right-click the toolpath and select Simulate from Start to display the 

Simulation toolbar. 
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15 Ensure that the ViewMILL toolbar is also active. 

 

16 Switch the ViewMILL On/Suspend setting to a green sphere , and then 

select the shiny shaded image icon . 

17 Press the Play  button to start the simulation. 

 

 Undrawing the tool will speed up the simulation. You can control the display 

of the tool by left clicking on the tool entity, light bulb in explorer. 

 

 

The finished result indicates that in some areas of the model there is still too much 

material for the finishing strategies to cope with. 

 

As a result, a further area clearance strategy is required using a smaller tool to 

continue locally into the remaining areas. This technique is known as Rest 

machining. 

 

18 Click  to suspend ViewMILL.   

19 Click  to return to the PowerMILL window. 
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Rest Roughing using a Reference Toolpath 
1 Create a Tip Radiused tool of Diameter 16, Tip Radius 3 and name it as D16TR3. 

2 Select Toolpath Strategies , and from 3D Area Clearance open a Model 

Rest Area Clearance strategy. 

 

By directly selecting Model Rest Area Clearance, the Rest machining options 

and the most suitable style, Offset Model will already be active in dialog.  

 

a Enter a new Toolpath name D16TR3-D1 

b Keep the Thickness as 0.5 

c Enter Stepover as 1 

d Enter Stepdown as 5 

e Select the Rest page from the strategy explorer. 
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f Set the Rest machining type as Toolpath, enter D40TR6-D1 as the 

reference toolpath, and input Detect material thicker than as 0.6 

 

 

g In the local explorer, select Unsafe segment removal page and if set, un-

tick the Remove segments smaller than threshold option. 

 

 

h Activate the D16TR3 tool to be used in the new toolpath.  

3 Click Calculate to process and create the additional Offset Model - Area 

Clearance toolpath and then Close the dialog. 

 

4 From the Main pull down menus select File - Save Project to update: 

......\COURSEWORK\PowerMILL-Projects\Wing_Mirror_Die  
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5 Switch the ViewMILL On/Suspend button to a green sphere .  

6 Select the Rainbow Shaded Image . 

7 Right mouse click on the toolpath D16TR3-D1 and select Simulate from Start. 

8 Press the Play  button to start the simulation. 

 

The ViewMILL simulation shows this toolpath shaded in a different colour where 

it has machined in areas the previous toolpath did not cover. 

 

The Reference toolpath has successfully accessed material closer to the 

component form. 

This will reduce the risk of excessive wear or damage to tools used for the 

subsequent finishing operations. 

9 Click the ViewMILL On/Suspend button to a red sphere  and then click 

to return to the PowerMILL window. 

Rest Machining using a Stock Model 

An alternative method for rest roughing is the use of a Stock Model instead of a 

Reference toolpath. 

The benefits of using a Stock Model compared to a reference toolpath are: 

� The remaining surplus material can be visualised and registered along with the 

associated toolpaths.  

� A rest machining strategy referenced to a Stock Model will include the effect of 

all previous toolpaths currently registered to that Stock Model. 

� A toolpath that was created to a different workplane (for example, multi-axis) 
can be referenced to a Stock Model.  

 It is not possible to apply a rest machining strategy referenced to a 

toolpath that was created to a different workplane. 
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In this example a Stock Model is created to initially include the D40TR6-D1 

toolpath. Then, a copy of the toolpath, D16TR3-D1 is created using the Stock 
Model for the rest machining reference. 

1 In the PowerMILL explorer, Activate the toolpath D40TR6-D1. 

 

2 In the PowerMILL explorer, right-click Stock Models and select Create Stock 

Model. 

 

3 Accept the above default values for the triangle mesh creation. 

4 In the PowerMILL explorer, right-click the newly created Stock Model 1 and 

select Apply > Active Toolpath First. 

 

 

Both the currently active Toolpath and Block are added to Stock Model. 

 

 

5 From the same menu, select Calculate to physically update the Stock Model. 



 

3.  3D Area Clearance PowerMILL 2016 

3 - 30  Copyright © Delcam Ltd  

 

A triangular mesh will appear representing the state of the material after the effect 

of the first machining strategy, D40TR6-D1. 

In the next two actions, The Stock Model will be changed to:- 

a Visually remove the component form (Show Rest Material). 

b Visually change the style from triangle mesh to a shaded form (Shaded). 

6 From the same menu, select Drawing Options > Show Rest Material. 

 

 

7 From the same menu, select Drawing Options > Shaded to display the shaded 

view of the Stock Model. 
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8 In the PowerMILL explorer, Activate the toolpath D16TR3_D1. 

9 Right-click on the toolpath D16TR3_D1 and select Settings to open the Model 

Rest Area Clearance strategy dialog. 

10 Click  to create a copy of the toolpath. 

11 Select the Rest page and modify the settings as below using Stock model 1. 

 

12 Click Calculate to create an alternative and more efficient Rest Machining 

toolpath named D16TR3-D1_1. 

13 Close the machining strategy dialog.  
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Although the toolpath D16TR-D1_1 appears (coloured purple) as a referenced 

entity in the Stock Model list, the resultant machining effect is not included.  

 

 

14 In the PowerMILL explorer, right-click the toolpath, D16TR3-D1_1 and select 

Add to > Stock Model. 

 

 At this stage, the Stock Model will disappear from the screen. 
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15 Right-click the active Stock Model and select Calculate to update it. 

 

16 From the Main pull down menus, select File > Save Project to update: 

......\COURSEWORK\PowerMILL-Projects\WingMirrorDie  

 

17 From the Main pull down menus select File > Delete All. 

18 From the Main pull down menus select Tools > Reset Forms. 

 

 

Exercise 

Area clearance with both unsafe segment removal and 
rest roughing 

 

1 Import the Model: 

......\PowerMILL_Data\Models\Cowling.dgk 

 

2 Select an ISO 1 view. 
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Machining setup 
3 Create the following tools: 

� Tip Radiused tool – Name D16TR3, Diameter 16 Tip Radius 3 

� Tip Radiused tool – Name D12TR1, Diameter 12 Tip Radius 1 

 

4 Create a Workplane centrally position at the top centre of the Model, and then 

Activate it. 

5 Calculate a Block using Defined by – Box and Type – Model, then change the 

Min Z value to -80 and lock it by selecting the adjacent padlock. 

6 Calculate the Rapid Move Heights using the default settings. 

 

 

Area Clearance Strategies 
1 Create a Model Area Clearance strategy named D16TR3-RGH1 using: 

a The D16TR3 tool. 

b The Style as Offset All. 

c A Thickness of 0.5 

d Stepover 8 and Stepdown 12 

e In the Flat Machining page use Level. 

f Select the Unsafe segment removal page. 

g Tick the box Remove segments smaller than threshold and leave the 

other settings as default. 
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2 Create another Model Area Clearance strategy named D12TR1-RGH1 using: 

a The D12TR1 tool. 

b The Style as Offset Model. 

c Stepover 2 and Stepdown 3 

d In the Flat Machining page use Area. 

e Enable the Rest machining page and reference to the previous toolpath. 

f Disable the Unsafe segment removal option. 

 

3 Save Project As: 

......\COURSEWORK\PowerMILL_Projects\ModelAreaClear-Exercise 
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ViewMILL Simulation 

4 Perform a ViewMILL simulation with the Rainbow Shaded Image option  

active on both of the Model Area Clearance toolpaths.  

 

5 Select Exit ViewMILL  to close the current session. 

 

 Do not close the Project as it will be continued in the following section. 

Area Clearance using the Step option 
If a large stepdown is used in the Area Clearance strategies then the bulk of the 

waste material will be removed as quickly as possible. This will inevitably leave large 

steps on the remaining stock that would normally be reduced using a separate rest 

roughing operation. However, if it is acceptable to use the same Tool then the Step 

option will provide rest machining within the same Area Clearance strategy. In this 

case additional passes are applied (where required) that step upwards between the 

original Z Heights.   
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1 Activate the existing toolpath D16TR3-RGH1 to restore the settings used. 

2 Run a new ViewMILL simulation (as shown above) on the toolpath D16TR3-
RGH1. 

3 Select Exit ViewMILL  to close the current session. 

4 Right mouse click on the active toolpath D16TR3-RGH1 and from the local menu 

select Settings. 

5 Select the ‘Make a Copy’ of the toolpath option . 

6 Rename the new toolpath as D16TR3_Step-RGH1 

7 In the main page of the dialog change the Style to Offset model. 

8 In the Model Area Clearance, local explorer, select Step cutting. 

9 Tick the Step cutting box and enter values exactly as shown below. 

 

 

10 Select Calculate to create the toolpath D16TR3_Step-RGH1. 

 

11 Run a new ViewMILL simulation on the toolpath D16TR3_Step-RGH1. 
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The above image shows the effect of the Step cutting option tracking upwards 

from the first slice to get closer to the model form.  

 

The Component has been ‘Roughed Out’ with maximum efficiency, close to the 

final shape within the same strategy. 

 

12 Save the Project. 

13 From the Main pull down menus select File > Delete All. 

14 From the Main pull down menus select Tools > Reset Forms. 
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Model Area Clearance – Vortex example 
 

Vortex machining is an area clearance strategy which rapidly removes material 

from a 3D part while controlling tool load. Vortex is best suited to solid carbide 

tools and is frequently used in combination with step cutting. 

The engagement angle never exceeds that produced by a straight line cut with a 

given stepover. This eliminates excessive tool load and all full-width cuts. This 

enables you to increase feed rates. As the tool approaches the maximum 

engagement angle, the strategy automatically changes to use a trochoidal path to 

avoid tool overload. 

 

1 Open the (read-only) Project:- 

                ……\PowerMILL_Data\Projects\Vortex2-Start 

 

 

2 Save Project As:- 

                ……\COURSEWORK\PowerMILL_Projects\Vortex2 

 

3 Activate the workplane, TopCentre-datum. 

4 From the main toolbar select Block  and using, Defined by Box – Type 

Model select Calculate followed by accept. 

5 From the main toolbar select Rapid Move Heights  and in the form select 

Calculate followed by Accept. 

 

6 Select Toolpath Strategies , and from 3D Area Clearance open a Model 

Area Clearance strategy. 
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7 In the Model area clearance page of the strategy dialog: 

a Enter Toolpath name – D16TR3-Vortex-RGH1 

b Select Style – Vortex 

c Set Cut direction – Both Profile and Area - Climb 

d Input Thickness 0.5 

e Input Stepover 3.0 

f Input Stepdown 12.0 

8 Open the Vortex page of the strategy dialog: 

 

a Input Minimum radius (r) as 3.0 
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9 Open the Step cutting page of the strategy dialog: 

 

a Tick the Step cutting box and then input a Stepup value of 1.0 

 

10 Open the Flat machining page of the strategy dialog: 

 

a Set Machine flats to Level. 

 

11 Open the Approach page of the strategy dialog: 

 

 

12 In the Helical ramp options window, select Max zig angle 4 with a Circle 

diameter 0.65 and Height 5. 

 

13 At the bottom of the dialogue select Calculate to process the Vortex - Model 

Area Clearance toolpath. 
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14 Perform a ViewMILL simulation on the toolpath to observe the Vortex strategy. 

 

15 Save the Project. 
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Machining Flat features within Model Area Clearance 
The Model Area Clearance strategies in PowerMILL include options to control the 

way in which flat areas of the component model are machined. These are accessed 

from the Machine Flats page on the dialog. 

 

1 Select File - Delete All and Tools - Reset Forms. 

2 Import the Model: 

......\PowerMILL_Data\Models\Flats.dgk 

 

 

3 Select File - Save Project As: 

......\COURSEWORK\PowerMILL-Projects\AreaClearFlats  

 

4 Create a 12mm diameter End Mill tool named EM12. 

5 Calculate the Block using the default settings. 

6 Calculate default Rapid Move Heights. 

7 Keep the Start and End Point settings as default. 

8 Select Toolpath Strategies , and from 3D Area Clearance open a Model 

Area Clearance strategy. 
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9 In the Model Area Clearance strategy dialog: 

a Enter the Name as EM12-FlatsOFF. 

b Set Thickness to 0.5 

c Set Stepover to 5 

d Set Stepdown to 12  

e Select the Flat machining page and set Machine flats to Off. 

 

 

10 Click Calculate to process the toolpath and then Close the dialog. 
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When the Machine flats option is set to Off, the toolpath totally ignores the flat 

surfaces of the model. It maintains the defined Stepdown value and performs area 

clearance across the material Block at each Z Height. 

1 Right-click the active toolpath, EM12-FlatsOFF and select Settings. 

2 Click  to create a copy of the toolpath. 

3 Change the new toolpath name to EM12-FlatsLEVEL. 

4 On the Flat machining page, change Machine flats to Level. 

5 Calculate to process the toolpath and then Close the dialog. 

 

When the Machine Flats option is set to Level, the toolpath machines the whole 

Block area for each flat area. The Stepdowns are reduced as required to be 

constant between individual flat areas. 

 

6 Right-click the active toolpath and select Settings.  

7 Click  to create a copy of the toolpath. 

8 Change the toolpath name to EM12-FlatsAREA. 
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9 On the Flat machining page, change Machine flats to Area. 

10 Calculate to process the toolpath and then Close the dialog. 

 

The Model Area Clearance toolpath now removes material locally on each 

individual flat area leaving a total of 0.6mm stock (The Thickness plus the 

Tolerance). The nominal stepdown remains constant with flat area machining 

occurring separately between these levels. 

 

11 Select File - Save Project to update:- 

......\COURSEWORK\PowerMILL-Projects\AreaClearFlats 

 

Machining Flats separately using Slice Area Clearance 
In PowerMILL Pro it is possible to use Slice Area Clearance to separately 

machine the flat areas of a model to their exact height. This could be used: 

a As a finishing strategy, applied to the flat areas after a Model Area 

Clearance roughing strategy where Machine flats was set to Level or 

Area. 

b As a secondary roughing strategy, applied to the flat areas only, that follows 

on from a Model Area Clearance where Machine flats was set to Off. 

There are several types of 2D entity that are supported in the Slices options:- 
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12 Right-click on the EM12-FlatsArea toolpath and select Activate to reinstate all 

settings and parameters used.  

13 Select Toolpath Strategies , and from 3D Area Clearance open a Slice 

Area Clearance strategy. 

 

a Enter Name as EM12-SliceAC. 

b Set Slices as Flat. 

c Set Style as Offset all. 

d Set Tolerance 0.02 

e Set Thickness 0  

f Set Stepover 5  

 

14 Select the Flat machining page (Available when Slices Flat is active) and: 

 

a Check that the Allow tool outside flat box is unticked. 

 

 

 

15 Select Calculate to process the toolpath and then Close the dialog. 
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This Slice Area Clearance strategy is confined to the Flat areas only. 

At the moment, the cutter profiles around the edge of the holes located within a 

flat area. If preferred, the strategy can be changed to Ignore Holes (below a 

specified Diameter) causing the tool to pass straight across them. 

16 Right-click on the Active toolpath and select Settings to re-open the Slice Area 

Clearance dialog. 

17 Click on  to create a copy of the toolpath. 

18 Rename the toolpath as EM12-SliceAC-IgnoreHoles and then select the Flat 

machining page. 

 

19 Select a Tick in the Ignore holes box. 

The Threshold (tool diameter units) defines the maximum size of holes to 

ignore. With the tool EM12 selected and the Threshold set to 2, holes that are 
greater than Dia 24mm will not be ignored. 

 

20 Select Calculate to process the toolpath and then Cancel the dialog. 
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The cutter now passes across the top of the holes without lifting, producing a 

smoother, more efficient, toolpath.  

 Ignore Holes refers to the area defined by the slice definition at the top of 

the holes. The flat base of any hole will still be machined. 

21 Right-click the Active toolpath and select Settings to re-open the Slice Area 

Clearance dialog. 

22 Click on  to create a copy of the toolpath. 

23 Rename the toolpath as EM12-SliceAC-MultipleCuts and then select the Flat 

machining page. 

 

a Select the Multiple cuts option and set the Number of cuts as 3. 

b Input the Stepdown as 2.0 

c Select the Final stepdown option and input 1.0  

 

24 Select Calculate to process the toolpath and then Close the dialog. 
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If there is a large amount of material remaining above the flat areas, then the 

Multiple Cuts option is applied to reduce the tool loading during Area 

Clearance. 

 

 The ‘D’ shaped Flat area at the very top level does not use Multiple Cuts as 

the top of the Block is the overall Z limit for the strategy. 

 Select File - Save Project to update:- 

               (......\COURSEWORK\PowerMILL-Projects\AreaClearFlats) 
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Further information on Area Clearance 
Machining 

The following is reference information for the many different options contained in 

the Area Clearance dialogs. This can also be found by using Help. 

Restrict Tool Overload – Trochoidal moves  
This option is available to Area Clearance strategies in which Style - Offset 

model is set. The dialog for activating and entering the Maximum overload value 

(%) is located on the High speed options page. 

  

If the tool reaches a specified overload situation, PowerMILL automatically inputs a 

trochoidal path to eliminate full width cuts. This will occur in corners, narrow 

channels, slots, etc. The degree of movement is controlled with the slider as a 

percentage value of the specified stepover. 

 

Thickness 

Click the Thickness button  in strategy dialogs to enter separate Radial  

and Axial  thicknesses. 

 

 - Radial Thickness 

 - Axial Thickness 
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Z Heights – Manual entry 

To manually enter Z heights in a strategy, select Manual from the Stepdown list. 

 

Click  to display the Area Clearance Z Heights dialog.  

Defined by defines how Z heights are specified. You can define a Z height by: 

� Number - divides the block equally into the defined number of Z heights, the 

lowest of which will be at the bottom of the block. 

� Stepdown – creates a Z height at the top of the block and then steps down a 

defined height in Z. The final Z Height will be at the bottom of the block. 

If the Constant Stepdown option is selected, the distance between all Z 

height levels remain constant. To achieve this, the actual stepdown value will 

more than likely have to be automatically modified to be less than the 

nominal value. 

� Value - creates a single Z Height at the defined value. 

� Flat - Identifies flat areas of the model and creates a Z height (+ thickness) at 

these values. It can also be set to machine the specific flat areas instead of the 

whole of the slice. 

� Intermediate - adds a specified number of Z Heights between the current ones. 

Append All - Z Heights can be also be appended from an existing Model Area 

Clearance toolpath using the Reference section of the Area Clearance Z Heights 

dialog. 

 

Profiling  

A profile move can be performed at each level to remove steps that are left by the 

cutter Before, During, or After a Raster - Model Area Clearance strategy. 

Additional profile passes can be applied when machining either on Every Z or the 

Last Z level with Offset, Profile, or Raster strategies. 

 

When  

The When settings on a Raster page in an Area Clearance strategy dialog allow 

you to determine when the profiling pass occurs during machining. 

None – No profiling pass is performed 

Before – The profiling pass is performed before the Raster path. 

During – The profiling is performed at suitable intervals during the Raster path. 

After – The profiling pass is performed last. 
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Cut Direction  

The Cut Direction settings control the direction of the tool along the toolpath: 

Any – This instructs the cutter to machine in both directions.  

Climb – This instructs the cutter to profile such that the material is to the right 

of the direction of travel (Climb milling). 

Conventional – This instructs the cutter to profile such that the material is to 

the left of the direction of travel (Conventional milling). 

 

Wall Finishing 

The Wall Finishing page in the Model Area Clearance strategy dialog allows you 

to make an additional, final profiling pass to further reduce tool wear. 

 

Allow tool outside block 

The Allow tool outside block setting is available on the Limit page of the Model 

Area Clearance dialog. 

This enables the strategy to exist outside the Block by the tool radius value.  

  

This option limits the strategy with the tool centre flush with the Block. 

 

 

 Flat Machining  

The Flat Machining page of the Model Area Clearance dialog contains options to 

control if and how the flat areas of a component are machined. These include Off, 
Area, and Level. 

Level - Flat Machining occurs across the whole area defined by the Block. 

The nominal Stepdown value is locally reduced as required to accommodate 

each Flat area as part of an equally spaced group.  

Area - Flat Machining is confined to the individual Flat areas.  

The nominal Stepdown value remains constant (independent of the Flat areas). 

Ramping  

The Ramp option is available on the Leads and Links dialog to use where it is 

impossible to approach from outside the Block at the full machining depth (for 

example, within a pocket). 

� There are 3 different options for the type of Ramp move - Toolpath, Circle, 

and Line. These can be used to lead on to the start of a tool track. 

� The Zig angle is the angle of descent along the machining direction as the tool 

ramps into the material. If the length of the Zig angle is limited to a finite 

distance, a ramp move in the opposite direction (Zag angle) can also be applied. 
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� The Ramp Length is defined as Tool Diameter Units (TDU). For example, A 

Ramp Length of 2 TDU would equal 20 mm for a Dia 10 mm tool. 

� If Add approaches from outside is set, it will take priority over Ramping. 

� If the defined geometry for a Ramp move is such that it would cause a gouge, 

then the tool approaches using a default Plunge move. 

 

 

 

 

 

 

 

 

 

 

 

 



PowerMILL 2016 4. Finishing Strategies 

Copyright © Delcam Ltd  4 - 1 

Finishing strategies machine the actual component form, and where applicable, 

follow on from the Area Clearance operation. Suitable values are required to 

control the accuracy and amount of excess material to be left on a component by a 

toolpath. The parameters used for this purpose are called Thickness and 

Tolerance. 

Thickness is the amount of extra material specified to remain on the work-piece 

after machining. This can be applied generally as an offset from the model (as 

shown), or independently as separate Radial and Axial values within the machining 

options. 

 

 It is also possible to assign additional Thickness values to selected 

surfaces on the model (Component Thickness). 

Tolerance controls the accuracy to which the cutter path follows the shape of the 

work-piece. For roughing, use a coarse tolerance, and for finishing use a fine 

tolerance. 

 

 A positive Thickness value should always be greater than the Tolerance 

value. 

4. Finishing Strategies 
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Raster Finishing and Pattern Finishing 
Raster Finishing works by projecting a wireframe, Pattern down the Z-axis onto 

the model. The standard pattern applied in Raster Finishing is obtained by 

entering values directly into the Finishing dialog. Two other types of standard 

pattern strategy (not covered in this course) include Radial and Spiral. 

The Pattern Finishing strategy uses an existing, pre-defined Pattern or 

Toolpath, which is either projected down Z onto the model or used in situ as a 

Drive Curve to generate the toolpath. 

Typical previews of all 4 available pattern strategies are shown below as viewed 

down Z. 

 

The Raster finishing strategy is used as an example in the next section. 

 

 

 

Raster Finishing 
1 From the Main pull down menus select File - Delete All and Tools - Reset 

Forms. 

2  Then select File > Open Project: 

…...\PowerMILL_Data\Projects\Handset_Start 
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3 From the Main menu , select File >Save Project As: 

   ......\COURSEWORK\PowerMILL-Projects\Handset_PatternMC 

 

4 Activate the existing toolpath D25TR3-RGH1 to restore all the set-up settings. 

5 Activate the tool BN12. 

6 From the main toolbar, select Toolpath Strategies  and from Finishing 

open a Raster Finishing strategy. 

 

7 Click OK to display the Raster Finishing strategy dialog and enter the following 

settings and values.  
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a Name the toolpath BN12-Raster-SEM1. 

b Enter the Tolerance as 0.1 and Thickness as 0.4 

c Select Ordering - Style as Two Way. 

d Enter a  Stepover of 2 

e Click the Preview tab to display the pattern (as shown below). 

 



PowerMILL 2016 4. Finishing Strategies 

Copyright © Delcam Ltd  4 - 5 

Several options exist to add lead and link moves at the start and end of each 

individual tooltrack. The aim is to provide a smoother transition for the tool to 
approach tangentially onto the component form instead of simply plunging directly 

down the Z-axis. 

 

8 In the Raster Finishing dialog open the Leads and Links options (left click on 

the small box containing +). 

9 Select the Lead in page and select 1st choice as Vertical arc, input Angle 90, 

Radius 6.0, and un-tick the option Add leads to short links. 

 

 

10 Select Lead out the same as lead in.  

11 Select the Links page and input the value and options exactly as shown in the 

following image. 

 

12 Click Calculate to process the toolpath and then Close the dialog. 
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The above toolpath contains sharp corners along the vertical plane. These can be 

arc fitted within the Raster Finishing dialog. 

In the Raster Finishing, High speed page the Arc fit corners option inserts a 

radius in the vertical plane (maximum  0.2 Tool Diameter Units). 

 

13 In PowerMILL explorer, right-click the BN12-Raster-SEM1 toolpath and 

select Settings. 

14 Click  to enable the toolpath BN12-Raster-SEM1 to be edited. 

15 On the strategy dialog: 

a Open the High speed page. 

 

 

b Select the Arc Fit option and edit the Arc Radius to the maximum value 0.2  

c Click Calculate to process the toolpath and then Close the dialog. 

16 Zoom into the toolpath to view the arc fitted tooltracks: 
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The value 0.2 (TDU), multiplied by the tool diameter (12) produces a radius of 2.4 

 

 

17 In PowerMILL explorer, right-click the BN12-Raster-SEM1 toolpath and 

select Settings. 

18 Click  to create a copy of  the toolpath named BN12-Raster-SEM1_1 

19 Rename the new toolpath as BN12-Raster-FIN1 and input suitable finishing 

values as shown in the following image. 

 

20 Click Calculate to process the toolpath and then Close the dialog. 
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If the raster pattern is projected downwards parallel to a steep wall then the 

actual distance between the tooltracks is likely to become unacceptably large. 

For this reason the raster pattern in BN12-Raster-FIN1 has been created at a 
135 Angle to minimise where the tooltracks run parallel to steep walls. 

 

21 Run a full ViewMILL simulation on all 3 existing toolpaths. 

 

 

22 Disconnect ViewMILL from the simulation process (Change the sphere from 

green to red) and then select No Image   to return to the PowerMILL 

view. 
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Pattern Finishing 
This strategy requires a user-defined Pattern to be projected onto the model as a 

toolpath. This option can be used for applications such as scribe lines, text, and 

custom strategies. A Pattern is created either from within PowerMILL or from 

imported wireframe CAD data. 

 

23 In the PowerMILL explorer, right-click Patterns and select Create Pattern. 

 

 

A new, empty Pattern is created.  

 

 

24  Right mouse click on the new empty Pattern and from the local menu select 

Insert - File to access the Open Pattern dialog. 

25  Click button 2 (Shown inside red border below) on the Open Pattern dialog: 

 

 

26 Double click the Patterns folder and then select the Engrave1.dgk file. 
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27 Click Open. 

 

The imported Pattern is made up of 2D geometry and is positioned relative to 

the Transform (World co-ordinates).  

 

Next this 2D geometry will be projected along Z onto the 3D model to create a 

single Pattern Finishing toolpath with a negative Thickness value. 

 

 

28 Activate the tool BN1. 

29 From the main toolbar, select Toolpath Strategies  and from Finishing 

open a Pattern Finishing strategy. 
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a Enter the Toolpath name BN1-Engrave 

b Input Pattern 1. 

c In 3-Axis applications the Base position can be set to either Automatic or 

Vertical, for the Pattern form to be projected down Z onto the model. 

d Enter a Tolerance 0.02 and Thickness -0.4 

 

30 Select the Lead in page and select 1st choice as None. 

31 Select the option Lead out the same as lead in.  

32 Select the Links page and input the value and options exactly as shown in the 

following image. 

 

33 Select Calculate to process the toolpath then Close the dialog. 
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The Pattern is machined to an offset depth of -0.4 into the finished model 

form. 

 

 It is not possible to use a –ve thickness value that is greater than the Tool 

Tip Radius. There is, however, an alternative way to achieve this (Chapter 

10 Patterns, page 20 - Deep Pattern Machining). 

 

34 Simulate the engraving toolpath in ViewMILL. 

 

35 Select File - Save Project to update the contents of: 

......\COURSEWORK\PowerMILL-Projects\Handset_PatternMC 
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3D Offset and Constant Z Finishing 
In this section, 3D Offset and Constant Z finishing strategies are applied to a 

model that consists of a combination of flat and steep areas plus a pocket with 

vertical walls. In this example a Boundary will be created and used to limit the two 

strategies to where they are most effective. 

 

1 Select File - Delete All and File - Reset Forms. 

2 Select File - Open Project and in the dialog browse to: 

…...\PowerMILL_Data\Projects\camera_start 

 

The Project is locked and subsequent changes cannot be saved unless the 

included lock file is deleted. 

 

 

3 Select OK to continue loading the Project into the PowerMILL session. 

4 From the Main pull down menus, select File > Save Project As: 

......\COURSEWORK\PowerMILL_Projects\Camera_Example 

 

The Project already contains a Tip Radiused tool and a Model Area Clearance 

toolpath along with the associated settings. 
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Creation of a Shallow Boundary to define specific 
machining areas 

A Shallow Boundary creates segments around areas of the model that are 

defined by an Upper and Lower threshold angle. It is therefore specifically suited 

to steep walled and shallow surface machining techniques. 

 There are several other types of Boundary options available to suit 

various applications and these are covered later in Chapter 6. 

 

In the below example, a Shallow Boundary is used to discriminate areas most 
suited to the individual machining strategies. This type of Boundary is calculated, 

taking the Active Tool, Thickness, and Tolerance into consideration. 

 

1 Define a Ball Nose tool of Diameter 10 called BN10. 

2 In the PowerMILL explorer, right-click Boundaries and select Create 

Boundary > Shallow. 

 

 

3 In the displayed Shallow Boundary dialog: 
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a Enter the Name as ShallowBN10 

b Enter Upper Angle 30 and Lower Angle 0  

c Enter Tolerance as 0.02  

d Enter Thickness as 0  

e Ensure the correct tool BN10 is Active. 

f Un-tick the box, Allow boundary to be private. 

g Apply and Accept the dialog. 

 

With the model, Tool, and toolpaths undrawn, the Boundary can be viewed 

as shown: 

 

This boundary is made up of numerous segments; each one dividing the model into 

steep and shallow areas. Any of these segments can be selected and individually 

deleted at any time, except when it is assigned to a toolpath and locked.  
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Constant Z Finishing 
Constant Z Finishing projects each tool track horizontally onto the component at 

fixed heights defined by the Stepdown. 

 

As the component surface becomes shallow, the actual tool stepover increases until 

it becomes non-existent on flat areas. 

1 From the main toolbar, select Toolpath Strategies  and from Finishing 

open a Constant Z Finishing strategy. 

 

2 In the Constant Z Finishing dialog: 

a Enter a Toolpath name – BN10-ConstantZ   

b Tick the Spiral option. 

c Enter a Tolerance of 0.02 

d Set the Cut Direction to Climb. 

e Enter a Stepdown of 0.5 
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3 On Constant Z finishing dialog, select the Limit page and with the Boundary 

ShallowBN10 active, set Trimming to Keep outside. 

 

4 Click Calculate to process the toolpath and then Close the dialog. 

 

By using the Boundary - Trimming option as Keep outside, the toolpath is 

limited to the steep areas of the model.  
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Introduction to Leads and Links 
The current toolpath (BN10-ConstantZ) has inherited circular Ramp lead moves 

(pale blue) from the previously activated toolpath RoughOp1. From the main 

toolbar we will open the Leads and Links dialogue and apply Horizontal Arcs to 

both the start and end of the Long link moves and On Surface to the Short link 

moves (< 4). 

 

1 Click the Leads and Links button  on the Main toolbar. 

2 Select the Lead In tab and: 

a In Lead in, change the 1st Choice to Horizontal Arc, Angle 90 and 

Radius 5 

b Tick the Add leads to short links box. 

c Click the Lead Out the same as lead in button.  

 

3 Apply and Accept the dialog. 

 

The tool now leads in and out of the active toolpath with a Horizontal arc. 

If the tool lifts, it will only lift by the skim distance taken from the first page of 

the Leads and Links dialog (Z Heights tab). 

The rapid feed moves at skim height are purple in colour while the plunge 

feed moves are light blue. 

 

 

 

 

 



PowerMILL 2016 4. Finishing Strategies 

Copyright © Delcam Ltd  4 - 19 

3D Offset Finishing 
3D Offset Finishing creates the toolpath stepover relative to the 3D Model 

providing consistency over both flat and steep areas. To produce an improved tool 

movement over the model a Shallow Boundary will be used to limit this strategy 

to where it is most effective. 

 

1 From the main toolbar, select Toolpath Strategies  and from Finishing 

open a 3D Offset Finishing strategy. 

 

 

2 In the 3D Offset Finishing strategy dialog:  

a Enter Toolpath name as BN10-3Doffset 

b Tick the Spiral option 

c Set the Cut Direction to Climb 

d Enter a Tolerance of 0.02 

e Enter a Thickness of 0 

f Enter a Stepover of 0.5 
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3 On the 3D Offset finishing dialog, select the Limit page 

 

4 Select the Boundary - ShallowBN10. 

5 Select Calculate to create the toolpath and then Close the dialog. 

 

The Toolpath follows the contours of the Boundary segments and is produced 

only within the shallow areas of the model (Inside the Boundary). 

 

This toolpath has inherited the current settings in the Leads and Links dialog, 

as applied to the previous toolpath BN10-ConstantZ.  A more suitable option 

for bot Lead in and Lead out would be Vertical arc. 

6 Click the Leads and Links  button from the top of the screen. 

7 Select the Lead in tab and: 

a Un-tick Add leads to short links, change the 1st Choice to Vertical Arc, 

Angle 90 and Radius 5. 

b Click the Lead Out the same as lead in button.  

 

8 Apply and Accept the dialog. 
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The toolpath now is more efficient with the rapid moves at skim height, the long 

links using Vertical Arc Leads, and the short links being linked along the surface. 

 

 To further improve this 3D Offset strategy, you can tick the Smoothing 

option. This results in sharp corners being replaced with a smooth blend 

wherever possible. 

 

9 Simulate all of the toolpaths in ViewMILL. 

 

10 Select File – Save Project to update (but do not close):-  

To update:- ......\COURSEWORK\PowerMILL-Projects\Camera_Example  
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Optimised Constant Z Finishing 
This strategy is a mixture of Constant Z and 3D Offset machining; Constant Z is 

applied to steep areas and, 3D Offset is applied to other areas. 

 

11 De-activate the Boundary, ShallowBN10 in the PowerMILL explorer. 

12 From the main toolbar, select Toolpath Strategies  and from Finishing 

open an Optimised constant Z Finishing strategy. 

 

a Enter Toolpath name as BN10-OptCZ 

b Tick the Spiral, Closed Offsets, and Smoothing options. 

c Enter the Tolerance as 0.02 

d Set the Cut direction to Climb. 

e Enter a Stepover value of 1 

f On the Limit page, make sure that the Boundary is not selected. 

 

13 Select Calculate and when the toolpath is created, Close the dialog. 

Note the consistent 3D Stepover across the whole component. 
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14 From the Main menu, click the Leads and Links button to display the Leads 

and Links dialog and then, select the Links tab. 

 

a Change the Short/Long Threshold to 2. 

b Change the Short links to On Surface. 

c Change the Long and Default links to Skim. 

15 Apply and Accept the dialog. 

 

16 Select File - Save Project to update (but do not close):- 

......\COURSEWORK\PowerMILL-Projects\Camera_Example 



4. Finishing Strategies PowerMILL 2016 

4 - 24  Copyright © Delcam Ltd  

Steep and Shallow Finishing 
This strategy includes the following additional options:-  

The option to input a Threshold Angle to control the extent of the Constant Z and 

3D Offset areas of the toolpath. 

The option to input a steep shallow overlap value between the Constant Z and 

3D Offset areas. 

1 From the main toolbar, select Toolpath Strategies  and from Finishing 

open a Steep and Shallow Finishing strategy. 

2 Enter the values exactly as shown: 

 

a Enter Toolpath name as BN10-SteepAndShallow.  

b For the Order select Steep first. 

c For the Threshold angle input 30. 

d Tick both of the Spiral boxes. 

e For both the Stepdown and Stepover input 1. 

f For Type (shallow) select 3D offset. 

g Tick the Smoothing box. 

 

3 Select Calculate to process the toolpath and then Close the dialog. 
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4 Select File - Save Project to update:- 

......\COURSEWORK\PowerMILL-Projects\Camera_Example 

Steep and Shallow finishing with separate Shallow 
Stepover 

Both Optimised Constant Z and Steep and Shallow strategies have an option to 

apply a separate, larger Stepover across shallow areas. This option is designed to 

enable a more efficient machining of shallow areas with a Tip Radiused tool. 

The main advantage with the Steep and Shallow strategy is that the Threshold 

Angle is user defined. This can be set to 0 making the large stepover apply over 

flat areas only.  

1 Delete All and Reset Forms. 

2 Select File - Open Project and in the dialog browse to: 

......\PowerMILL_Data\Projects\ADV-SteepShallow-Start 

 

3 Click OK to load the read-only Project into PowerMILL. 

4 Save Project As: 

......\COURSEWORK\PowerMILL_Projects\ADV-SteepShallow-EX1 

 

5 In the PowerMILL explorer, right-click on the existing toolpath             

D16t3-SteepShallow-FIN and select Settings. 
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The component form includes 2 flat areas which are currently finished with the 

same small stepover as the angled walls. For more efficiency, an option is 
available for a larger stepover to be independently applied to the shallow flat 

areas. 

 

6 Click Recycle  to enable edits to the existing toolpath. 

7 Update the main page of the dialog exactly as shown below. 

 

a Select Order as Steep first. 

b Input the Threshold angle as 0 

c Tick the Calculate using cusp box and input . 

d Input a Stepdown of 0.01 and a Maximum stepdown of 0.3 

e For the shallow regions, enter a Stepover of 6 
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8 Click Calculate to process the toolpath and then Close the dialog. 

 

 

The flat areas are machined more efficiently using a large stepover while the 
steep areas use a small, variable stepdown based on the cusp height. This 

provides an efficiently produced, consistent finish over the whole form. 

9 Run a ViewMILL simulation on both the Roughing and Finishing toolpaths. 

 

 

 

10 Select File - Save Project, to update:- 

......\COURSEWORK\PowerMILL_Projects\ADV-SteepShallow-EX1 
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Corner Finishing 
Corner Finishing strategies identify and remove material in corners that are 

inaccessible to previously used, larger tools. There are 3 independent types of 

strategy: Along, Stitch, and Automatic.  

All Corner Finishing strategies include a Threshold Angle option. This is the 

angle down from the horizontal, where the steep and shallow portions meet.  

The Threshold Angle can be defined to prevent the tool running up or down steep 

slopes.  For example, you could apply a Stitch strategy to track across the steep 

areas, while using the Along strategy in shallow areas. 

 

 If the Threshold Angle is 90 then the Steep area will not exist. 

 

The Corner Finishing and Multi-Pencil strategies machine the areas that are 

inaccessible to the Reference tool (2) but are accessible to the active tool, as in the 

diagram.  

 

In the following example, the Corner Finishing strategy uses a Dia 10 Ball Nose 

for the reference tool, and a diameter Dia 5 Ball-nose to perform  the rest 
machining. 

 

1 Select File - Delete All and Tools - Reset Forms. 

2 From the Main menu, Select File - Open Project and select: 

......\PowerMILL_Data\Projects\CornerFinish_start 

 

3 From the Main menu, select File - Save Project As: 

......\COURSEWORK\PowerMILL-Projects\CornerFinish 
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Corner Along Finishing 
4 Select an ISO2 view. 

 

5 Activate the toolpath, D16T3-rghA1 to restore the settings. 

6 Create a Dia 5 ball nose tool named BN5. 

7 From the main toolbar, select Toolpath Strategies  and from Finishing 

open a Corner Finishing strategy. 

 

a Enter Toolpath name as BN5-CornerAlong_Shallow. 

b Change Output to Shallow and Strategy to Along. 

c Set Cusp to 0.03 

d Set Cut direction to Climb. 

e On the Tool page, check that the BN5 tool is Active. 

 

 

f Select the Corner detection page and select the Reference tool as BN10. 
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8 Select the Lead in page and set the 1st Choice to None. 

9 Calculate to process the toolpath and then Close the dialog. 

10 Simulate the toolpath and observe the order of the machining: 

 

Note: With Output set to Shallow, the toolpath has stayed within the shallow 

areas of the model (between horizontal and a downward angle of 30 Degrees).  

 If a Threshold angle of 90 is used, the Shallow option will apply to all 

valid rest areas. In this case the Steep option is non-existent. 
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Corner Stitch Finishing 

1 From the main toolbar, select Toolpath Strategies  and from Finishing 
open a Corner Finishing strategy. 

 

a Enter Toolpath name as BN5-CornerStitch_Steep. 

b Change Output to Steep and Strategy to Stitch. 

c Check that the BN5 tool is active on the Tool page. 

d Check that the Reference tool is BN10 on the Corner detection page. 

2 Calculate to process the toolpath and then Close the dialog. 

 

This time, only the steep areas are machined. 

 

3 From the Main menu select File > Save Project to update:- 

......\COURSEWORK\Projects\CornerFinish 
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Corner Automatic Finishing 

1 From the main toolbar, select Toolpath Strategies  and from Finishing 
open a Corner Finishing strategy. 

 

a Enter Toolpath name as BN5-CornerBoth_Automatic. 

b Use Strategy - Automatic. 

c Change Output to Both. 

d Change the Threshold angle back to 30.0 

 

2 Click Calculate to process the toolpath and then Close the dialog. 

 

This strategy automatically uses Along for the Shallow areas and Stitch for the 

Steep areas. 
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Corner Pencil Finishing 
Corner Pencil Finishing creates a single toolpath along the actual intersection 

between non-tangential faces on the model.  

1 From the main toolbar, select Toolpath Strategies  and from Finishing 

open a Corner Pencil Finishing strategy. 

 

a Enter Toolpath name as BN5-CornerPencil. 

b Change Output to Shallow. 

c Change the Threshold Angle to 90 

 Note: With a Threshold Angle of 90 the Steep angle will not exist, so only 

Output with Shallow or Both selected will enable a toolpath to be created. 

 

d On the Tool page, make the BN5 tool active. 

2 Select Calculate to process the toolpath, and then Close the dialog. 
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Corner Multi-pencil Finishing 
Corner Multi-Pencil Finishing creates a multi-track, rest finishing, toolpath based 

on the Pencil Finishing strategy. On creation it visually looks similar to a Corner 

Finishing toolpath, but on closer inspection there are subtle differences to the 

toolpath order and that it includes tool tracks along the model intersections.  

1 From the main toolbar, select Toolpath Strategies  and from Finishing 

open a Multi-Pencil Finishing strategy. 

 

e Enter Toolpath name as BN5-CornerMultiPencil. 

f Change Output to Both. 

g Change the Threshold Angle to 90 

h On the Tool page, make the BN5 tool active. 

i In the Corner detection page check that BN10 is selected. 

2 Calculate to process the toolpath and then Close the dialog. 

 

3 From the Main menu select File > Save Project to update:- 

......\COURSEWORK\Projects\CornerFinish 
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Flat Finishing 
These strategies apply to purely flat surfaces only. Flat areas within a variable 

height surface are not recognised. The minor discrepancies in the flatness of a 

surface is controlled by a Flat Tolerance value. 

 

1 Delete All and Reset Forms. 

2 From the Main menu, select File - Open Project: 

......\PowerMILL_Data\Projects\FlatFinish_Start 

3 Select File - Save Project As: 

......\COURSEWORK\PowerMILL-Projects\FlatFinish-Example1 

Offset Flat Finishing 
1 In the PowerMILL explorer, Activate the Toolpath D16TR3-RGH1. 

2 Activate the Dia 16 End Mill (EM16) Tool. 

3 De-Activate Boundary 1. 

4 From the main toolbar, select Toolpath Strategies  and from Finishing 

open an Offset Flat Finishing strategy. 

 

5 Select Calculate and when completed, Close the dialog. 
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The imported Project contains both an Offset Area Clear roughing strategy and 

an Optimised Constant Z finishing strategy. It is recommended that Offset Flats 

(EM16-OffsetFlats-FIN1) is run directly after the 3D Area Clearance (D16t3-

RGH1). For this reason, it would make good sense to move it up the toolpath order 

in the PowerMILL explorer. 

1 In the PowerMILL explorer, hold the left mouse key down on the toolpath 

EM16-OffsetFlats-FIN1 while dragging and releasing it onto D16TR3-RGH1. 

 

 

2 Perform a ViewMILL simulation on all 3 toolpaths to check that the Toolpath 
order is acceptable. 

 

The ViewMILL simulation after the Offset Flat Finishing strategy is shown above. 
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Raster Flat Finishing 

1 From the main toolbar, select Toolpath Strategies  and from Finishing 
open a Raster Flat Finishing strategy. 

 

2 Select Calculate and when completed, Close the dialog. 

 

3 From the Main menu select File > Save Project to update:- 

......\COURSEWORK\PowerMILL-Projects\FlatFinish-Example1 
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Flat Machining example 
1 Select File - Delete All and Tools - Reset Forms. 

2 Select File - Import Model:- 

......\PowerMILL_Data\Models\Flats.dgk 

 

3 Save the Project as:- 

    ......\COURSEWORK\PowerMILL_Projects\FlatFinishing-Example2 

4 Create a 20mm diameter End Mill tool named EM20. 

5 Calculate the (default) Block and then reset the Rapid Move Heights. 

6 Open an Offset Flat Finishing strategy and:- 

 

a Name the toolpath EM20-FlatFin.  

b Untick the Rest machining box. 

c Click the use Axial Thickness button and enter separate Thickness values 

for Radial 0.5 and Axial 0 

d Calculate to process the toolpath and then Close the dialog. 
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Most of the Flat areas are finish machined, apart from the gap between the 

Upstands and inside the holes due to the 20mm diameter tool being too large. We 
will now use a smaller tool to Rest machine these areas. 

 

7 Create a Dia 10 End Mill, named EM10. 

8 Activate the Toolpath, EM20-FlatFin and then select Settings. 

1 Click  to create a copy of the strategy. 

2 In the main Offset flat finishing page of the strategy dialog:  

 

a Enter Toolpath name as EM10-FlatFinRest. 

b Enter Stepover as 3.0 

c Activate the EM10 tool. 

d Tick the Rest machining box and then select the Rest page. 
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e On the Rest page, select the reference Toolpath as EM20-FlatFin. 

 

3 Calculate the toolpath and when created, Close the dialog. 

The final finishing passes at the base of the holes and the area behind the boss 

are now created: 

 

 

 

4 From the Main menu select File > Save Project to update:- 

......\COURSEWORK\FlatFinishing-Example2 
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Surface Finishing Example 1 
The Surface Finishing strategy creates tool tracks that follow the natural, surface 

curves on a single, selected, Surface. 

 The tool tracks in a Surface Finishing strategy will not run parallel to the 

edges of a trimmed, surface. 

1 From the Main menu, select File - Delete All and Tools - Reset Forms. 

2 Open the read-only Project:- 

        ......\PowerMILL_Data\Projects\EditToolpaths_3 

3 From the Main menu , select File - Save Project As: 

......\COURSEWORK\PowerMILL-Projects\PunchForm_3 

 

4 Activate the toolpath D10TR1-FIN1 to reinstate all the original settings.  

All you need from the original settings is the original; Active Workplane, 

Block, Rapid Move Heights, and the Tiprad tool named D10TR1. 

 

5 De-Activate both the Toolpath D10TR1-FIN1, and Boundary 1.   

6 Select the upper surface on the punch model (as displayed above). 
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7 Open a Surface Finishing strategy and enter values as shown below. 

 

8 Select the Pattern page: 

 

a Set Pattern direction – U 

b Un-tick Spiral, and then select Ordering - Two way 

c Select Start corner - Min U max V 

 

9 Select the Preview tab to display the Pattern along its start point (arrow) 

10 Select Calculate to create the toolpath and then Close the dialog. 
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11 From the Main toolbar, click the Leads and Links  button. 

12 On the Links page: 

 

a Enter Short/Long – Threshold 3.0  

b Select Short - Circular Arc 

c Select Long - Skim 

d Select Default – Incremental 

 

13 Apply the dialog  to update the active toolpath. 

 

Where the Link move from the end of a tool track to the start of the next is 

within 3 mm, an (orange) arc move will be applied. 
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In the resultant toolpath, the natural order of the tool tracks and link moves 

across the 2 narrow areas is not very efficient. 

This can be fixed by applying suitable toolpath, Edit - Reorder options. 

14 Right-click on the toolpath and from the local menu, select Edit > Reorder. 

15 In the Toolpath Listing dialog, click the Automatic reorder and reverse  

button. 

 

The toolpath follows the curves of the selected surface. 

The illustrated toolpath is created with a 1 mm Stepover to help with visualisation. 

It has also been edited using the Automatic Reorder and Reverse option to 

eliminate as many air moves as possible. 

To further improve the efficiency of this strategy, several of the tool tracks on the 

upper flat area can be deleted to take advantage of using a bigger Stepover for the 

Dia 10 mm flat area of the active Tool. 
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1 From the Main menu, select Draw > Cursor > Tool to help with the 

visualisation for the next action. 

2 Using the Shift key and left mouse key select groups tool tracks leaving a 

single pass within the tool diameter range, outside each set as shown below: 

 

The Tool outline is displayed above to visualise suitable Stepover (Draw > 

Cursor > Tool). 

 If it is necessary to de-select tool tracks form the current selection use 

the Ctrl Key and left mouse key. 

 

3 Right-click the toolpath and select Edit > Delete Selected Components to 

remove the selected tool tracks. 

4 In the Leads and Links dialog select the Links options and change the 

Short/Long threshold to 15 before selecting Apply. 

 

 

5 From the Main menu select File > Save Project to update:- 

......\COURSEWORK\PowerMILL-Projects\PunchForm_3 
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Toolpath Z-Limits  
 

All Toolpath types, except drilling, can now be limited to applied maximum and 

minimum Z values within the defined Block.  

 

1 From the main menus, select File – Delete All and Tools – Reset Forms. 

2 Open the read-only Project:- 

        ......\PowerMILL_Data\Projects\Zlimits-Start 

 

3 Save Project As:- 

        ......\COURSEWORK\Zlimits-EX1 

 

The Project already contains 8 Toolpaths, 6 of which have been put in a 

sub-folder named OP1. The 2 remaining Toolpaths require modification as 

they are both duplicating areas already included in other strategies. This will 

become evident during a ViewMILL simulation.  
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4 Activate the toolpath D20TR3-ConstantZ-FIN1 to reinstate the original Block 

and settings. 

5 Run a ViewMILL simulation on the existing NC Program OP1.  

6 Once completed save the ViewMILL model at this stage.  

 

The angled face and lower recesses have yet to be finish machined. The 2 

remaining toolpaths both operate over the full extent of the Block. 

 

 

D20TR3-ConstZ-FIN1 needs to be localised to operate down the angled face 

to the top of the lower recesses.  

BN8-OptConstZ-FIN1 needs to be localised to operate inside the 2 lower 

recesses. 

This will easily be achieved for both toolpaths within the strategy dialog using 

the Z-Limits option. 
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7 Return to the PowerMILL (No Image) view  and disconnect ViewMILL 

from the simulation (Switch the Green Sphere to Red).   

8 In the PowerMILL explorer, right mouse click on the toolpath D20TR3-

ConstZ-FIN1 and from the local menu, select Activate followed by Settings 

to open the strategy dialog. 

 

 

9 Select Recycle  followed by the Limit page and tick both the Maximum 

and Minimum boxes. 

10 For The Maximum select Pick the highest Z Value option.   

 

11 Snap the key-point (shown above) at the top corner of the angled face to 

collect and insert the value -11.82394. 

12 For The Minimum select Pick the lowest Z Value option.   
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13 Snap the key-point (shown above) on the top of the flat area to collect and 

insert the value -40. 

14 Back in the dialog select Calculate to re-process the updated Constant Z 

finishing strategy and then Close the dialog. 

15 In the PowerMILL explorer Right mouse click on the toolpath BN8-

OptConstZ-FIN1 and from the local menu, select Activate followed by 

Settings to open the strategy dialog. 

16 Select Recycle  followed by the Limit page and this time tick just the 

Maximum box. 

 

17 Input the value -40.02 in the Maximum box. 

18 Back in the main form select Calculate to re-process the updated Optimised 

Constant Z finishing strategy and then Close the dialog. 
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19 Re-connect ViewMILL and continue the existing simulation with the 2 updated 

toolpaths;  D20tR3-ConstZ-FIN1 followed by BN8-OptConstZ-FIN1. 

 

The Component is now fully machined. 

20 Select File – Save Project to update:-     

 ......\COURSEWORK\PowerMILL_Projects\Zlimits-EX1 
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Toolpath Processing Options  

Calculate 

When all the settings and values are input ready to create a toolpath, the Calculate 

button can be clicked  to start the toolpath calculation process. 

 

 You cannot use other PowerMILL options while the toolpaths are being 

calculated. 

Queue  

If the Queue option is applied the user can continue working in PowerMILL while 

the toolpath is processed in the background. Several strategies can be put in the 

queue to be calculated in the background, in sequential order.  

To Queue a toolpath for calculation, you can, either: 

� Click the Queue button in a strategy dialog, or,  

� Right-click on a toolpath and select Queue from the local menu. 

   

 The ‘Calculator’ symbol changes to the ‘Queue’ symbol when the 

toolpath is queued.  

 Batch Process 

Once all data has been entered into a strategy dialog, click the OK button to save 

the settings and close as an un-processed toolpath.  

You can save one or more un-processed, machining strategies to be sequentially 

calculated at a later time. 

To Batch Process toolpaths, right-click a toolpath and select Batch Process. 
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Toolpath Processing Queue 
The Toolpath - Queue option allows you to continue working in PowerMILL while 

the toolpath is being processed in the background. One or more strategies can be 

added to the Queue and they are calculated in the background, in sequential order.  

The following ‘start up’ Project contains two unprocessed toolpaths. The dialog for 

each one will be opened in turn, but Queue will be used instead of Calculate. This 

enables you to continue work on a new Corner finishing - Along strategy while 

the original toolpaths are processed in the background. 

1 Select File - Delete All and Tools - Reset Forms. 

2 Select File – Open Project: 

......\PowerMILL_Data\Projects\ToolpathProcessing-start 

 

3 Select File - Save Project As: 

......\COURSEWORK\PowerMILL-Projects\ToolQueue-ex1 

4 In the PowerMILL explorer, right-click the toolpath named D25t3-rgh and 

select Queue. 

5 Repeat this on the Toolpath named BN16-fin1. 



PowerMILL 2016 4. Finishing Strategies 

Copyright © Delcam Ltd  4 - 53 

 

 

6 While the original toolpaths are being processed in the background, Activate 

the tool BN6. 

7 Open a Corner Finishing strategy and set the Strategy to Along. Enter the 
other values exactly as shown below. 

 

 

8 Select the Corner detection page and select the Reference tool as BN16 

 

9 Click Calculate to process the toolpath and then Close the dialog. 

 

 The latest Corner Finishing strategy starts processing immediately and 

is likely to be completed before the Steep and Shallow finishing strategy 

currently pending in the Queue. 
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When a toolpath is added to the Queue, and is in an unprocessed status, the 

Calculator symbol on the Toolpath in the PowerMILL explorer changes to 

the Queue symbol . 

 

             

 

 

10 Select File - Save Project to update: 

......\COURSEWORK\PowerMILL-Projects\ToolQueue-ex1 
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If a tool is allowed to start machining directly at the start of a tool track, it first 

plunges down into the remaining stock, and then suddenly changes direction to run 

along the tool track. This is likely to result in machining marks, vibration, and 

excess wear on both the tool and machinery. 

To avoid sudden loading on the tool, appropriate Lead moves (at cutting feedrate) 

on and off tool tracks can be applied. 

Air moves (Link) between individual tool tracks can add significant amount of extra 

time to a machining operation. This can be greatly reduced by applying alternative, 

Link move options. 

 

Click  on the Main toolbar to display the Leads and Links dialog and options. 

You can also access the Leads and Links dialog from within a strategy dialog. Note 
that Leads and Links can be retrospectively applied to an existing toolpath. 

Z Heights 
Skim and Plunge distance - Provides variable control of rapid move heights within 

a component. These operate in conjunction with Safe Z and Start Z to minimise slow 

and unnecessary air moves while machining the component form. 

Skim distance – An incremental distance above the model where rapid feed moves 

occur from the end of one tool track to the start of the next. The tool traverses at a 

high feed rate across the model, clearing the highest point along its route by the 

Skim value. 

Plunge distance – An incremental distance above the local, component surface 

where a downward rapid movement of a tool changes to plunge feed move.  

5. Toolpath Leads & Links 
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Lead In/Lead out Moves 
Lead In controls the tool movement onto the start of a tool track and Lead Out 

controls the movement away from the end of a tool track.  

Available Lead In and Lead Out moves are:  

� None  

� Surface normal arc 

� Vertical Arc  

� Horizontal Arc  

� Horizontal Arc Left  

� Horizontal Arc Right  

� Extended Move  

� Boxed 

� Straight 

� Ramp  

� Pocket centre 

 

In the above illustration:- 

 - Lead In = Vertical Arc 

 - Lead Out = Vertical Arc 

 - Link move = Skim 

Toolpath colour codes: 

� Purple - Rapid Skim Feed Rate G1 

� Pale Blue - Plunging Feed Rate G1 

� Green/Orange - Cutting Feed Rate G1 

� Dotted Red - Full Rapid G0 

 

Leads and Links are effectively extensions to tool tracks and must be gouge 

protected. Gouge check is set as default and any Lead that would result in a 

gouge is not created. 

On tooltracks where the 1st Choice cannot be applied, then the 2nd Choice is 

used. If it is not possible to apply either then the Lead options are applied as None. 

The current Leads and Links settings are automatically applied when creating new 
machining strategies.  
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Example 
The following example illustrates the retrospective addition of suitable Leads and 

Links to finishing toolpaths. The project contains one Roughing toolpath and three 

Finishing toolpaths. 

1 Select File - Delete All and Tools - Reset Forms.  

2 Select File - Open Project:           

     ...\PowerMILL_Data\Projects\LeadsLinks-Start 

 

3 Select File - Save Project As: 

......\COURSEWORK\PowerMILL-Projects\LeadsLinks-example 

 

4 Select an ISO2 view. 

 

 

5 Activate the toolpath, BN6-fin1. 
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Vertical Arc Leads 
Vertical Arc - Leads create a circular movement downward at the start and 

upward at the end of each individual tool track. By default, with the Gouge check 

option selected, the additional moves are not made if a gouge might occur. 

 

 - Toolpath segment 

 - Radius 

 - Tangent angle 

 - Lead 

6  On the Main toolbar, click  to open the Leads and Links dialog. 

7 On the Leads and Links dialog, select the Lead In tab and:  

 

a Select Vertical Arc from the 1st Choice list.  

b Enter an Angle of 90.0 and a Radius of 6.0  

c Click Apply. 

There is now a Vertical Arc leading onto most of the tool tracks.  

 

 The new (gouge protected) Vertical leads have not been created on the tool 

tracks that stop close to a raised area of the model. 
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8 Click the Copy to Lead Out button. 

 

9 Click Apply to update the active toolpath. 

 

Where gouge free, a Lead Out move is applied at the end of each tool track. 

 

10 Select Vertical Arc from the 2nd Choice list.  

a Enter an Angle of 90.0 and a reduced value Radius of 4.0 

b Click the Copy to Lead Out button. 

c  Click Apply. 

 

Wherever it is gouge free on the above toolpath a 1st Choice of Lead In/Out 

with a Vertical Arc is applied.  
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If this is not possible without a gouge occurring, then the 2nd Choice of a 

Radius 4, Vertical Arc is attempted. 

If neither the 1st or 2nd Choice is possible without a gouge occurring, then no 

Lead In/Out is applied to that part of the toolpath. 

 

Links 
A Link move is the movement of the tool from the end of a tool track to the start of 

the next. For efficient tool moves across the model, you can reduce the height of 

the link moves to be closer to the local model form. 

� Short/Long threshold - This defines the distance limit up to which the Short -

Links apply. Any move from the end of a tool track to the start of the next, 

which exceeds this distance is defined by the Long - Link move. 

� For Short links, the available options include Safe Z, Incremental, Skim, On 

Surface, Stepdown, Straight, and Circular Arc. 

� For Long links, the available options include Safe Z, Incremental, and Skim. 

� For Default (first and last) links the available options include Safe Z, 

Incremental, and Skim. 

� Arc fit rapid moves can be applied, if compatible with a machine control 

system.  

 

11 Activate the toolpath BN6-fin1. 

12 Click  and open the Leads and Links dialog. 

13 Select the Z Heights tab to access the Skim and Plunge distance options. 

 

� Skim Distance - is the incremental height at which the tool clears the 

highest point on the model between tool tracks. 

� Plunge Distance - is the Incremental height above the model at which the 

tool rapids down to before using the Plunge Feed Rate. 

14 Select the Links tab. 
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a Enter the Short/Long threshold as 3 

b Link move distances less than this value will use the Short options and those 

greater will use the Long options. 

c Select Short as Circular arc, Long as Skim, and Default as Incremental. 

15 Click Apply. 

 

 The distance between the ends of adjacent tool tracks is greater than the 

Short/Long threshold value in several areas of the toolpath (In these 

instances Skim moves apply). 

16 Increase the value for Short/Long threshold to 8. 

17 Click Apply. 

 

 By increasing the value of the Short/Long threshold, the number of 

occurrences of Short Link - Circular Arcs has increased. 

The remaining Link moves would benefit from Vertical Arc - Lead In/Out 

moves, but not on the existing Circular Arc Links.  
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18 Open either the Lead in or Lead out page. 

19 Un-tick the Add leads to short links option. 

 

 

20 Click Apply.  

 

The Lead moves exist on the Long links but not on the Short links. 
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Applying Leads and Links locally to individual tool tracks 
21 Use the left mouse key to select one of the individual link moves where the 

Lead is currently a Vertical Arc. 

22 In the Leads and Links dialog, select the Lead In tab and select 1st Choice as 

Extended Move with Distance 10. 

23 Select the Copy to Lead Out tab. 

24 Click Apply. 

25 The selected Vertical Arc lead move is changed to an Extended move. 

 

26 Select File - Save Project to update: 

......\COURSEWORK\PowerMILL-Projects\LeadsLinks-example 

 

Horizontal Arc Leads 
This produces circular leads on the horizontal plane. This type of lead is frequently 

used for toolpaths running at constant Z, or with only small changes in Z height. 

 

 Toolpath segment 

 Radius 

 Lead 

 Tangent angle 

 

27 From the Main menu, select Tools - Reset Forms to return the Leads and 

Links settings to default. 

28 In the PowerMILL explorer, right-click the BN6-fin2 toolpath and select 

Activate. 

29 Select an ISO1 View. 
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30 Click  on the Main toolbar to open the Leads and Links dialog. 

 

31 Select the Lead In tab, and change 1st Choice to Horizontal Arc with an 

Angle of 45 and a Radius of 3.0 

32 Click Copy to Lead Out and then Apply. 

 

 There is no need to utilise the 2nd choice options as the 1st Choice of 

Horizontal Arc - Leads In/Out have appeared on all the tool tracks.  

 

33 In the existing 1st Choice - Lead In page input a value of 5 for the Distance 

and select Apply. 
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Extensions 
Extensions are additional lead options that are applied outside the existing Lead 

In/Out moves.  

34 Select an ISO 4 view. 

35 In the Leads and Links dialog, select the Extensions tab and for both the 

Inward and Outward options, enter a Vertical Arc with Angle 90.0 and 

Radius 5.0 

 

36 Click Apply. 

 

A Vertical Arc - Extension is added to all of the Lead In/Out moves. 

 

Additional Short Links options 
In addition to Safe, Incremental, and Skim, the following options are also 

available in the Short link section. These additions are not available in the Long 

link options. 

� On Surface - This links the tool tracks with a gouge free, direct move that 

follows the surface form. 

� Stepdown - The link move remains at a constant height and performs a gouge-

checked move to the start of the next tool track, where it then feeds down onto 

the surface. 

� Straight - In this case, the link is a gouge-checked, direct linear move to the 

start of the next tool track. 

� Circular Arc - This links the tool tracks with a gouge-free circular move that 
follows the surface form. 
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Exercise 
1 Activate the BN6-fin3 toolpath and Apply the Leads and Links as follows: 

a Links: Long/Short/Default – Skim. 

b Lead In: 1st Choice - Ramp - Options - Max Zig Angle 4, Follow 

Toolpath, and Height 1 

c Lead Out: 1st Choice - Vertical Arc – Angle 90 – Radius 3  

 

 

The Links have been visually removed to enable a better view of the Leads. 

2 In the Leads and Links dialog select the Lead in page and input 0.5 in the box 
named Overlap distance (tool diameter units). 

3 Apply the Leads and Links dialog. 

 

 

Overlap Distance causes the cutter to continue beyond the natural end point along 

the original toolpath by a specified distance based on the Tool Diameter (TDU). In 

this case the distance is 3mm (0.5 TDU). 
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Arc Fitting Rapid Moves 

Leads and Links 
Arc Fitting works on all Rapid Moves including Skim moves. This option is ideal 

for applications where you want to avoid sharp changes in direction; for example, 
High Speed Machining.  

 Not all machine tool controllers will support this option. 

 

  

 

� The Arc Fit Rapid Moves option is located in the Links dialog. 

� The Arc fit rapid moves box must be ticked. 

� The Arc radius is defined as a proportion of the active, Tool Diameter (TDU). 
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A Boundary consists of one or more closed wireframe segments. Boundaries are 

mainly used to limit machining strategies to specific areas of the component.  

Earlier in the course, Boundaries were utilised to limit machining strategies, so 

that they occur in more compatible areas of the component.  

For example, Constant Z finishing is more effective on steep sidewalls and Raster 

finishing on shallow areas. 

There are several options available for creating boundaries. Most involve interaction 

with other PowerMILL entities (eg Tools, Thickness, Stock Model, etc), while 

User Defined will access a separate dialog for direct input of existing geometric, 

entities. 

 

Switch off the Private Boundaries creation option 
1 From the Main menu, select File - Delete All and Tools - Reset Forms. 

2 From the main pulldown menus select Tools – Options and in the dialog select 

Boundaries – Private boundaries. 

 

3 Un-tick the box named Allow new boundaries to be private. 

4 Select Accept to close the Options dialog. 

6. Boundaries 
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User Defined Boundary 
To access the User Defined – Boundary options, go to the PowerMILL explorer, 

and select Boundaries > Create Boundary > User Defined. 

This will access a separate sub-menu in which the range of options, generally 

involve direct input of existing wireframe entities. 

 

 

 Insert File - Opens the browser to locate an externally stored geometry file. 

The Boundary, Pattern, and Toolpath buttons are disabled unless a compatible 

entity is selected in the adjacent input box. 

 Model - Inserts the edge of the selected model. 

 Sketch - Opens the Curve Editor toolbar. 

 Composite curve - Opens the Create Composite Curve toolbar. 

 Wireframe Modelling - Provides access to the PowerSHAPE wireframe 

module.  

 

 

5 Select File - Save Project As: 

......\COURSEWORK\PowerMILL_Projects\BoundaryBasics 

 

6  Select File - Import Model... 

......\PowerMILL_Data\Models\cowling.dgk 
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7 Select the surfaces defining the central pocket and fillet. 

 

 

8 In the PowerMILL explorer, right-click Boundaries and select Create - User 

Defined.  

9 In the User Defined Boundary dialog, click the Model button. 

 

A Boundary segment is created around the edge of the selected part of the 
model. 

 

10 Select a View from top (Z) and switch off the shaded view but retain the 

wireframe view. 
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11 In the PowerMILL explorer, right-click Boundaries and select Create 

Boundary - User Defined. 

12 In the User Defined Boundary dialog, click the Sketch button  

to open the Curve Editor toolbar. 

 

13 On the Curve Editor toolbar, click the following button  to open the 

Options dialog. 

14 Un-tick Intelligent Cursor - Snapping Options  to switch off the 

Intelligent Cursor  enabling ‘free form’ sketching. 

 

15 Click Accept to keep the changes. 

16 From the Curve Editor toolbar, select Create a Bezier curve .  

17 Using the left mouse key, click points within the model to create a sketched 

Boundary.  
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 If required, use Undo  to sequentially remove any invalid points. 

 While the Intelligent cursor is switched off do not attempt to close the 

segment by trying to snap the ‘final span’ back on to the start point.  

18 On the Curve Editor toolbar click  to open the Options dialog. 

19 Select Intelligent Cursor - Snapping Options and tick - Use Intelligent 

Cursor.  

20 Then snap the final span of the Bezier Curve onto the original start point. 

21 On the Curve Editor toolbar click  to accept the changes and close the 

session. 

22 If the Boundary segment is not smooth enough, right mouse click on it and 

from the local menu, select Edit - Spline Selected to open the Spline fitting 
tolerance dialog. 

 

23 Enter the value 2 and click  to apply and close the dialog. 

 

The Boundary segment is splined through the polyline points as a curve 

maintaining the original form to within a maximum deviation of 2. 

In instances where the required deviation would be greater than 2, a tangency 

will remain either side of the affected points. 
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Selected Surface Boundary 
A Selected Surface Boundary defines one or more segments around where the 

active tool would fully machine the selected surfaces. The segments represent the 

tip position of the active tool. 

1 Create a Block - Defined by Box using Type - Model. 

2 Create a Ball Nosed tool of Diameter 16 with the Name BN16. 

3 Select the surfaces defining the central pocket, including the fillet. 

 

4 In the PowerMILL explorer, right-click Boundaries and select Create 

Boundary - Selected Surface. 

 

5 Using the above settings, click Apply to create a single segment, Selected 

Surface Boundary. 
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Shallow Boundary 
A Shallow Boundary defines one or more segments where the model drops 

through a specified Upper Angle downwards from the horizontal plane. It is 

designed to differentiate steep and shallow areas where Constant Z and Pattern 

strategies are more effective.  The boundary is calculated relative to the active tool 

parameters.   

1 In the PowerMILL explorer, right-click Boundaries and using the default 

settings, Create Boundary - Shallow. 

 

 - Shallow area more suited to Raster Finishing (above 30 degrees). 

 - Steep area more suited to a Constant Z Finishing (below 30 degrees). 

2 Apply the form to create the above Boundary segments. 

Silhouette Boundary 
A Silhouette Boundary defines the outline around the maximum dimensions 

selected model, offset by the tool radius. 

1 Select the following surfaces on the model: 

 

 Use the Shift key on your keyboard to select multiple surfaces. 
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2 Right-click the Model and select Edit - Delete Selected Components. 

3 With the selected areas now deleted, in the PowerMILL explorer, right-click 
Boundaries and select Create Boundary - Silhouette. 

 

Rest Boundary 
A Rest Boundary defines the area inaccessible to a specified reference tool. It also 

requires a smaller active tool to be specified otherwise it will not generate 

segments. 

1 Create a Ball Nosed tool of Diameter 8 with the Name BN8. 

2 In the PowerMILL explorer, right-click Models and select Delete All to 

remove the incomplete component. 

3 Import the original Model back into the Project:     

......\PowerMILL_Data\Models\cowling  
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4 In the PowerMILL explorer, right-click Boundaries and select Create 

Boundary - Rest to open the Rest Boundary dialog. 

 

5 Input Expand Area 0, select Tool BN8, and Reference Tool BN16.  

6 Set with Limit tool centre to block edge.  

7 Click Apply to create the following Rest Boundary. 

8 Click Accept to close the dialog. 

9 Save the Project to update:- 

......\COURSEWORK\PowerMILL_Projects\BoundaryBasics 

 

10 Select a View down the Z Axis  and Un-draw the model.  

 

The above Boundary identifies areas on the component that are inaccessible to 

the BN16 tool geometry to be locally machined with the BN8 tool. 

On closer inspection, the central pocket area would be more effectively 

machined with a flat bottomed tool and a smoother, more continuous toolpath, 

can be created if the 2 spurs are removed from the outer segment (to be 

machined later as a separate toolpath). 
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Editing Boundaries 
It is often necessary to edit the original geometry defined by Boundary segments. 

The best way to achieve this in PowerMILL is via the dedicated Curve Editor tool.  

As it is not exclusive to Boundaries, a more detailed range of Curve Editor, 

options and applications are covered in Chapter 11. 

1 In the PowerMILL explorer, right-click the Rest Boundary (6) entity and in 

the local menu select Edit - Copy Boundary to create a copy named (6_1). 

2 In the PowerMILL explorer, right-click the original Rest Boundary (6) and 

Rename it as Master. 

3 Rename the new copy of the Rest Boundary (6_1) as Rest. 

4 Activate the Boundary named Rest. 

5 Select the 2 inner segments on the Rest boundary (Rest) by dragging a box 

over them, and then press the Delete key on your keyboard to delete them. 

 

The next stage will be to Offset the Boundary and then remove the two spurs, which 

will be carried out after an explanation of the Boundary Editor dialog. 

 

Boundary – Access to the Curve Editor 
Once created, you can modify a Boundary segment using the options available on 

the Boundary Toolbar.  

 

 

Click  on the Boundary toolbar to activate the Curve Editor toolbar.  

 

 You can also double-click a boundary segment to activate the Curve 

Editor Toolbar. 
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Edit > Transform 

1 In the PowerMILL explorer, right-click on the boundary Rest and from the 

local menu, select Curve Editor. 

2 In the Curve Editor toolbar select the Offset option  

 

3 In the Offset toolbar, select the 3D Smooth button, input a Distance of 1 and 

then press the Return key. 

 

4 Click  in the Curve Editor toolbar to accept the changes and exit.  
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Curve Point - editing 
The Point editing options are located towards the right hand side of the Curve 

Editor toolbar   . 

 

1 In the PowerMILL explorer, right-click Boundaries and from the local menu 

select Toolbar. 

2 On the Boundary toolbar, click the Curve Editor button  to display the 

Curve Editor toolbar. 

3 Select (Left click) the outer boundary segment in the graphics area. 

 

The points are displayed on the selected boundary segment. 

 

4 Zoom into the area of the selected segment and select all the points that define 

the spur. 

 

 To select multiple points, hold down the Shift key while selecting the 

points with the mouse.  

5 On the Curve Editor toolbar, click Delete points  to remove the spur 

from the segment. 

6 Repeat the procedure on the other spur. 
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7 Click , to accept changes and exit the Curve Editor.  

Other boundary editing options 
Right-click on a Boundary in the graphics area or in the PowerMILL explorer and 

from the local menu, select Edit to view other boundary editing options. 

 

 

Review the modified Boundary 

8 In the PowerMILL explorer, click the light bulb next to the copy of the original 

boundary Master created earlier. The original boundary is displayed alongside 

the edited boundary, Rest illustrating the effect of the 1mm 3D Offset. 
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Create a 3D Offset strategy limited to the modified Boundary 

 

9 Activate the BN8 tool and Boundary named Rest. 

10 On the Main toolbar, click  to display the Strategy Selector. 

11 From the Finishing options, select the 3D Offset Finishing strategy. 

12 In the 3D Offset Finishing strategy dialog, enter data as below. 

 

13 Click Calculate to process the toolpath and then Close to exit the dialog.   
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Create a Boundary for the original side branches. 

 

14 Undraw the Toolpath BN8-FIN1 and Boundary Rest by switching off the 

respective light bulb symbols in the PowerMILL explorer. 

15 Switch on the respective light bulb to display the Boundary named Master. 

16 In the graphics area, select the outer segment of the displayed Boundary 

named Master.  

17 In the PowerMILL explorer, right-click the Boundary Master and select Edit 

- Copy Boundary (selected only) to create a new boundary Master_1 

consisting of the outer segment only. 

18 Rename the boundary Master_1 as Spur1. 

19 Select a view from top Z. 

20 In the PowerMILL explorer, turn off the light bulb adjacent to the boundary 

Master to remove it from view. 

 

21 In the PowerMILL explorer, right-click the boundary Spur1 and select 

Activate. 

22 In the graphics area, double-click the boundary segment to activate the Curve 

Editor toolbar. 

23 Select all points along the boundary segment except those which define the 

rectangular part of the upper spur. 
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 Use the Shift key on your keyboard to select multiple points on the 

boundary segment.  

 Use the CTRL key on your keyboard to deselect one or more of the 

selected points on the boundary segment. 

                 

 If preferred it is okay to select and delete the points in stages.  

24 On the Curve Editor toolbar: 

a Click the Delete Points button  to delete all the selected 

points. 

b Select the points at the base of the rectangular segment. 

c On the status bar (below the graphics area), click the Relative Move 

button  and enter 0 -2 (for the X and Y move, values) in the data box 

and press Enter on your keyboard. 

 

The selected points are moved by a distance of Y-2. 

 

25 Click  to exit the Curve Editor toolbar. 

26 Click the light bulbs on to display both Boundaries Rest and Spur1, and then 

Resize the View . 
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27 In the graphics area, double-click the Boundary Spur1 to activate the Curve 

Editor toolbar. 

28 Form the Curve editor toolbar, select Transformations - Mirror option .  

29 On the Mirror toolbar select Origin at the active workplane.   

30 Ensure that the Keep Original option is set.   

 

31 From the Mirror toolbar, click the Mirror in ZX button . 

32 Click   on the Mirror toolbar to accept and close. 

33 On the Boundary Transform toolbar, click  to accept and exit the toolbar. 

 

The Boundary named Spur1 now contains 2 segments. 

 

1 Make sure that the tool BN8 and boundary Spur1 are both Active. 

2 From the Strategy Selector, Finishing options, select the Raster Finishing 

strategy and enter data as shown on the following page: 
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3 Click Calculate to process the toolpath, and then Close the dialog. 

 

The machining strategies are localised with the help of edited Boundaries 

originating from the original Rest Boundary (Master). 
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4 Save the Project to update:- 

......\COURSEWORK\PowerMILL_Projects\BoundaryBasics 

 

 

 

 

Creating Blanking Surfaces using 
Boundaries 

Blanking surfaces are used to cap holes and pockets in a model to prevent the tool 

from machining into those areas. You can create three types of planes in 

PowerMILL. 

� Block – creates a plane, at a specific Z Height, after the material block is 

defined. 

� Best Fit – creates two planes, one touching the boundary at its highest point, 

and the other through its lowest point. The planes are parallel to the best fit 

plane (the plane that has the smallest maximum distance from the boundary). 

� Projected – creates a plane parallel to the XY axis of the active workplane. The 

plane will have the Z Height of the highest point of the boundary. 

 

Example 
1 Select File - Delete All and Tools - Reset Forms. 
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2 Import the Model: 

......\PowerMILL_Data\Models\pockets.dgk 

 

3 Calculate the Block defined by Box to the Model Min/Max limits. 

 

4 Select the top surface of the model (shown shaded).  

5 In the PowerMILL explorer, right mouse click on Boundaries and from the 

local menu select Create Boundary – User Defined. 

 

 

6 Click the Model icon and then select Accept to close the dialog. 

7 Un-draw the model to enable a clear view of the boundary. 

The Boundary produced has 4 segments. For this example, only the two 

smallest segments are required. 

8 Select the two highlighted segments by dragging the cursor over them. 
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9 In the PowerMILL explorer, right-click Models and from the local menu select 

Create Plane - Projected. 

10 Switch on the Plain Shade model option.  

11 Planer Surfaces have been created inside the selected boundary segments. 

 

 No need to Save the Project this time! 

12 Select File - Delete All and Tools - Reset Forms. 
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Exercise 
Import the Model …\PowerMILL_Data\Models\bucket.dgk and generate 4 

surface planes to cover the foot recesses on the upper base surface. 

 

 

 No need to Save the Project this time! 

1 Select File - Delete All and Tools - Reset Forms. 
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Block defined by Boundary 
An existing Project will be opened that contains multiple components that will be 

roughed out using a complex Block arrangement defined by Boundary segments. 

 

2 Select File – Delete All and Tools - Reset Forms. 

3 Open the (read-only) Project:- 

…\PowerMILL_Data\Projects\MultiBlock_Start 

 

4 Save the Project as:- 

           .…\COURSEWORK\PowerMILL_Projects\MultiPart_Block 

 

5 Select all of the component models (Drag a box over all surfaces). 

6 In the PowerMILL explorer right mouse click on Boundaries and from the 

local menu select Create Boundary - User Defined. 

7 In the User Defined Boundary dialog ensure that the Allow Boundary to be 

private box is un-ticked and then click on the Model icon . 

 

8 Select Accept to close the User Defined Boundary dialog. 

9 Activate the new Boundary. 

 

10 From the main toolbar select the Block options . 

11 In the dialog select Defined by - Boundary and Type – Model followed by 

Calculate. 
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12 Select Accept to close the Block dialog. 

 

The complex Block is as shown above consisting of localised triangle models 

around each individual component. 
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13 De-activate the Boundary. 

14 In the PowerMILL explorer right mouse click on the existing, un-processed 
toolpath D12TR1-RGH1 and from the local menu select Edit – Set Named 

Parameter. 

 

15 Input Block and select the green tick to accept. 

The current Block definition will now be active within the unprocessed Model 

Area Clearance strategy. 

16 In the PowerMILL explorer right mouse click on Toolpaths and from the local 

menu select Batch Process. 

 

Batch Process will sequentially run down the toolpath list (in this case 1) and 

Calculate all valid, un-processed strategies. 

 

17 Select File - Save Project to update:- 

…\COURSEWORK\PowerMILL_Projects\MultiPart_Block 
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Private Boundaries 
All Boundary types will (by default) be created as private. This makes the 

Boundary exclusively owned by an individual machining strategy. If the 

parameters or entities used in the strategy are modified, then the associated 

private boundary will automatically adjust on calculation. 

Private Boundaries are of particular use in Templates as they will automatically 

regenerate when the host toolpath is calculated on a new model. 

A private boundary is not suitable in cases where the segments will need to be 

deleted or geometrically edited once assigned to the host strategy. It is however 

possible to create a copy on which you can switch off the Allow boundary to be 

private option within the dialog. 

It is also possible to prevent Boundaries from being created as private:- 

From the main pull down menus select Tools – Options – Boundaries - Private 

Boundaries, and un-tick Allow new boundaries to be private. 

 

Private Boundaries – Example:- 
1 Select File - Delete All and Tools - Reset Forms. 

2 Open the (readonly) Project:- 

......\PowerMILL_Data\Projects\PrivateBoundaries_Start 

 

3 Save Project As:- 

......\COURSEWORK\PowerMILL_Projects\PrivateBoundaries-EX1 
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The Project includes a Constant Z and a 3DOffset finishing toolpaths both of 

which currently apply over the whole of the Block area. To localise the 2 finishing 
toolpaths to areas of the model where they are most effective both strategies will be 

recycled to include a Shallow – private boundary. 

4 From the main pulldown menus select Tools - Options - Boundaries - Private 

boundaries:- 

 

5 Tick the box named Allow new boundaries to be private. 

6 Select Accept to close the Options dialog. 

7 Activate the toolpath, BN10-CZ-SEM1. 

8 From the toolpath, Bn10-CZ-SEM1 local menu select Settings, followed by 

the Recycle option. 

9 In the Constant Z dialog select the Limit page. 

 

10 From the Boundary pull down options select Create a shallow boundary. 
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11 Using the default settings Apply and Accept the Shallow Boundary dialog. 

 

Initially the new Boundary 1 will exist in the PowerMILL explorer until the 
toolpath is calculated. At that point it will disappear (become invisible) from the 

Boundary folder. However, the folder name, Boundary will still be displayed in 

bold text to identify the existence of the hidden private Boundary 1  

 

 The private Boundary will be displayed in the PowerMILL explorer if 

the above option is ticked in the local Boundaries menu. 

12 Select the Limit page and set Trimming to Keep outside. 

 

13 Calculate (but do not Close) the Constant Z Finishing strategy. 

 

The Constant Z strategy BN10-CZ-SEM1 is now limited to be outside the 

segments of private Boundary 1 
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14 Select the ‘create a copy’ option   in the Constant Z Finishing dialog. 

 

 

15 Modify the Toolpath Name to BN10-CZ-FIN1, input Tolerance 0.01, 

Thickness 0, and Minimum stepdown 0.3 

16 Calculate the new toolpath and Close the dialog. 

 

 

17 A new private Boundary will automatically, be created with the same 

parameters (Tolerance, Thickness, etc) as used in the main page of the 
Constant Z Finishing dialog.  
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18 In the PowerMILL explorer, right mouse click on Boundaries and from the 

local menu tick the option Display private Boundaries. 

 

 

19 With the 2 existing private Boundaries displayed, right mouse click on either 

and from the local menu select Edit – Copy Boundary. 

 

 

20 Right mouse click on Boundaries and from the local menu untick the option 

Display private Boundaries. 

 

Only the new private Boundary will be displayed in the PowerMILL explorer 

but will later become hidden once it has been applied in a new toolpath 

calculation. 

Exercise 
21 In the PowerMILL explorer, Activate the toolpath BN10-3Doff-SEM1 and 

then select Settings to open the dialog. 

22 Recycle with the new private Boundary 1_1_1, Active and with Trimming 

set to Keep inside. 
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23 Calculate a Copy of the above toolpath with the new Name BN10-3Doff-FIN1 

and with Tolerance 0.01, Thickness 0, and Stepover 0.3  

 

24 From the main pulldown menus select Tools – Options and in the dialog select 

Boundaries – Private boundaries. 

25 Tick the box named Display private boundaries in the explorer. 

 

 This demonstrates that if a toolpath containing a Private Boundary is 

copied then the new one will contain a separate Private Boundary.  
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Levels and Sets allow you to control the selection and display of model 

components in the PowerMILL graphics area. 

You can Acquire components from the currently imported Model to a Level or Set. 

Once acquired to a Level or Set, you can select, de-select, display, or hide Model 

components from the individual Level or Set context menus. 

The subtle differences between Levels and Sets are illustrated using the following 
examples. 

Creating Levels 
1 From the Main menu, select File > Delete All and Tools > Reset Forms. 

2 Select File > Import Model: 

......\PowerMILL_Data\Models\CowlingWithClamps.dgk 

 

The imported Model includes clamps, which: 

� Must be avoided by all machining strategies created in the Project.  

� Must not be included in the calculation of the Block. 

To make the model selection easier, a new Level named Clamps will be created 

and all clamp surfaces assigned to it. Another Level, named Splits will be created 

and all 6 split surfaces assigned to it. 

 

3 In the PowerMILL explorer, right-click Levels and Sets and select Create 

Level. 

7. Levels and Sets 
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4 Rename the new Level as Clamps. 

 

5 Create another new Level and Rename it as Splits. 

 

All model components are currently acquired to the default General Level. 

If the original CAD model has components already assigned to different Levels, 

then these will be recreated when the model is imported into the PowerMILL 

project. 

Acquiring model entities to a Level 
6 In the PowerMILL explorer, click the ‘light bulb’ off next to the Level named 

Clamps. 

 Any items acquired to this level will no longer be displayed. 

7 In the graphics area, use the left mouse and Shift keys to select all surfaces 

except the clamps. 

 

8 On the keyboard select Ctrl J to blank the selected Surfaces. 
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9 Select the Clamp surfaces (Hold down the left hand mouse key while dragging a 

box over them). 

10 In the PowerMILL explorer, right-click on the level named Clamps and select 

Acquire Selected Model Geometry.  

The clamps disappear from the view (The Level is switched off). 

 

11 On the keyboard select Ctrl L to unblank all eligible Surfaces. 

 

12 Select the 6 Surfaces defining the split face and Acquire them to the level 

named Splits.  

13 Switch off the level named Splits to visually check that the correct surfaces 

have been acquired. 

 

14 Switch on all levels (The clamps and split surfaces reappear).  
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A Selected Surface Boundary will now be created to limit the clamps from being 

machined. 

1 In the PowerMILL explorer, right-click the Level, General and choose Select 

Surfaces. The main component surfaces excluding the split faces are selected. 

2 While still in the PowerMILL explorer, right-click the Splits level and choose 

Select Surfaces. The split face surfaces are added to the current selection. 

3 Create a Dia 12 Ball Nose tool named BN12. 

4 Calculate a Block using the default Box and Model options. 

5 Use the default Rapid Move Heights and Start and End Point options. 

 

The Block is created to the dimensions of the selected surfaces. 

 

6 Left mouse click in the graphics area away from the model to deselect all 

entities. 

7 In the PowerMILL explorer, click on the Level, General, and with the Ctrl 

key held down, click on the Splits level. 

Both the selected levels will be highlighted in the PowerMILL explorer. 

 

 

8 Right-click on one of the highlighted levels and choose Select Surfaces. All 

surfaces excluding the clamps are selected. 

9 Right mouse click on Boundaries in the PowerMILL explorer. 

10 From the local menu select Create Boundary - Selected Surface Boundary 

with Radial Thickness 2, Limit set to Block Edge, with Allow boundary to 

be private un-ticked. 
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11 Check that both the Tool BN12 and Boundary 1 are Active so that they will be 

automatically included when a new machining strategy is created. 

12 From the main toolbar, select Toolpath Strategies  and from Finishing 

open a Steep and Shallow Finishing strategy.  

13 In the Steep and Shallow Finishing dialog, enter data exactly as shown in the 

following illustration. 
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14 Click Calculate to process the toolpath and then Close the dialog. 

 

The Radial Thickness of 2 used in the outer Boundary segment provides a 

suitable clearance around the clamps. 
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Switching Off a Level 
1 In the PowerMILL explorer, switch off the light bulbs on both the General and 

Splits levels. 

 

Only the Clamp Surfaces are displayed in the graphics area. 

2 Right-click the toolpath and select Settings to re-open the dialog. 

3 Select create a Copy and click Calculate to process a new toolpath. 

4 Close the Raster Finishing dialog. 

 

 Even if a level is switched off, PowerMILL will still create a toolpath over 
all (including un-displayed) parts of the model. 



7. Levels and Sets PowerMILL 2016 

7 - 8  Copyright © Delcam Ltd 

Sets 
A Model entity will always exist on a Level but not on more than one at the same 

time. You cannot delete a Level while Model entities are acquired to it. 

A Model entity can co-exist on more than one Set at the same time. You can delete 

a Set while Model entities are acquired to it. 

 

1 From the Main menu, click File > Delete All and Tools Reset Forms. 

2 From the Main pulldown menus File > Import Model and select: 

......\PowerMILL_Data\Models\YogurtTray.dgk 

 

3 In the PowerMILL explorer right mouse click on Levels and Sets. 

4 From the local menu, select Create Set and rename it as AllPkts-Set. 

 

5 Manually select all surfaces defining the 9 pockets. 

 

6 With the 9 pockets still selected, right-click AllPkts-Set and select Acquire 

Selected Model Geometry. 

7 Manually select all surfaces defining the bottom left pocket. 
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8 Create a new Set and rename it as Pkt1-Set. 

9 Right-click Pkt1-Set and select Acquire Selected Model Geometry. 

10 On the keyboard select Ctrl L to unblank all invisible Surfaces. 

11 Switch off both the level General and the Set Pkt1-Set. 

12 Switch on AllPkts-Set. 

 

The surfaces currently acquired to AllPkts-Set are displayed, including those 

that exist on the visually ‘switched off’ Set. 

13 Switch off the Set AllPkts-Set and then switch on the Set Pkt1-Set. 

 

 The surfaces acquired to Pkt1-Set are displayed. They are also displayed when 

the AllPkts-Set is switched on and Pkt1-Set is switched off. This illustrates that 

model entities can be acquired to more than one Set at the same time. 

 

1 Switch off both Sets and switch on the Level General. 

2 In the PowerMILL explorer right-click on Pkt1-Set and from the local menu 

click Select Surfaces. 

 

3 Create a new Level and rename it as Pkt1-Level. 
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4 Switch of the light bulb symbol next to the new Level Pkt1-Level. 

5 In the PowerMILL explorer, right-click Pkt1-Level and select Acquire 
Selected Model Geometry. 

 

The surfaces defining the bottom left pocket disappear from the view on being 

acquired to the (switched off) level Pkt1-Lev. This illustrates that unlike Sets, it is 

not possible for model entities to co-exist on more than one Level at any one time. 

6 Switch on the level Pkt1-Lev and the bottom left pocket surfaces are displayed 

again. 

 

 

 When using a combination of Levels and Sets it is good practice to keep 

the Sets visually switched off. If you want to select items from a 

particular Set, then, right-click on it and use one of the Select options 

from the context menu. 

 This prevents confusion if you switch a Level off only to find the included 

items are still visible due to a Set containing the same items being 

switched on. 
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There is a large selection of Toolpath editing options that can be applied 

retrospectively.  

 

Many of the Toolpath editing options are accessed from the local menus (as shown 

above). Most of these edits will no longer apply if a Toolpath is subsequently re-

calculated. 

Edit > Transform 
The Transform option allows you to Move, Rotate, and Mirror toolpaths relative 

to the Transform (Global datum) or an active workplane. 

To access the options right-click on a toolpath and select Edit > Transform. 

 

� Transform > Move - The Move function allows a selected toolpath to be 

moved by a user-defined Distance along a selected axis. 

8. Editing Toolpaths 
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� Transform > Rotate - The Rotate function allows the rotation of a selected 

toolpath by a user-defined Angle around a selected X, Y, or Z axis. 

 

� Transform > Mirror - This provides 3 options to Mirror a selected toolpath 

across the XY, XZ, or YZ planes. When a toolpath is mirrored, PowerMILL 

identifies the gouge status to be unknown, so it is advisable to check for gouges.  

 It is important to note that when a toolpath is mirrored, the cutting 

direction effectively becomes reversed. 

 

In the following example a single toolpath is created and then the Transform > 

Move option applied to copy toolpaths into the remaining cavities.  

 

1 Select File - Delete All and Tools - Reset Forms. 

2 Select File > Open Project:- 

         ......\PowerMILL_Data\Projects\EditToolpaths_1 

 

The Project contains a multi-cavity die and a Dia 10 Ball Nosed tool. 

A toolpath will be created in the lower left cavity that is limited to be inside a 

Selected Surface Boundary. 

3 Save Project As: 

          ......\COURSEWORK\PowerMILL-Projects\Transform 

4 Create a Block using Defined by > Box and Type > Model. 

5 Calculate the Rapid Move Heights using the default settings. 
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6 Select all of the surfaces (including the fillet) that define the bottom left pocket. 

 

                         

7 In the PowerMILL explorer, right-click Boundaries and select Create 

Boundary > Selected Surfaces. 

 

8 In the Selected Surface Boundary dialog, tick Roll Over and enter a 

Tolerance 0.02 and un-tick, Allow boundary to be private. 

              

9 Click Apply and Accept the dialog. 

A Selected Surfaces Boundary defines the limit where the active Tool and 

associated parameters would fully machine the selected surfaces. 

10 Open the Optimised Constant Z Finishing strategy and enter the values and 
settings exactly as shown in the 2 dialog pages below: 
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11 Click Calculate to process the toolpath and then Close the dialog. 

 

12 In the PowerMILL explorer, right-click the toolpath BN10-Pocket and select 

Simulate from Start, and click Play  in the Simulation toolbar. 
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Transforming toolpaths 
Before transforming toolpaths, it is advisable to create a master copy of the original. 

1 Right-click the BN10-Pocket toolpath and select Edit > Copy Toolpath and 

then Rename the copy BN10-Pocket_1 as BN10-Master. 

2 In the PowerMILL explorer select the toolpath BN10-Master and with the left 

mouse key depressed, drag it onto Toolpaths to move it to the top of the list. 

 

3 In the PowerMILL explorer, right-click on the toolpath BN10-Pocket and 

select Edit > Transform to display the Toolpath Transform toolbar. 

 

4 Switch off the ‘append toolpaths’ option . 

5 On the Toolpath Transform toolbar, click Move . 

6 On the Move toolbar, click Keep original with No. of Copies as 2. 

 

7 In the data entry box  located below the graphics area, enter the relative 

distance along X as 80, and press Enter on your keyboard. 

 

 X Y Z values (separated by a space) are entered into this box as required.  

8 In the Transform toolbar, click  to close and accept the changes. 

Two new copies of the original toolpath named BN10-Pocket_1 and BN10-

Pocket_2 are created and transformed along X by a relative distance of 80. 
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Note: It is possible to directly append all of tool tracks into a new, single toolpath 

BN10-Pocket_1. 

 

This is achieved by selecting the Automatically append transformed toolpaths 

option  before applying the transform values. 

 

Gouge checking a toolpath 

A  next to the toolpath indicates that it has not been gouge checked directly to 

the model. 

 

1 Activate the toolpath BN10-Pocket_1. 

2 Right-click on the toolpath BN10-Pocket_1 and from the local menu select 

Verify > Toolpath. 

3 In Check select the Gouges option. 

 

4 Apply the Toolpath Verification dialog. 
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A PowerMILL information box is displayed to inform of the gouge checking 

status. In this instance, No gouges were found.  

 

In the PowerMILL explorer, the style of the icon also updates indicating that 

the toolpath is gouge free. 

 

 

5 Repeat the Verify > Toolpath process on BN10-Pocket_2 

Multiple Transform   
6 Delete both of the toolpaths BN10-Pocket_1 and BN10-Pocket_2. 

7 Right mouse click on toolpath BN10-Pocket and from the local menu select 

Edit > Transform. 

8 Select the option Automatically append transformed toolpaths.  

9 Select the option Multiple Transform to open the following dialog. 

 

10 Enter 3 for number of copies and a pitch of 80 for both in X and Y before 

selecting Accept. 
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11 In the Transform toolbar, click  to close and accept the changes. 

 

 

 A new toolpath (BN10-Pocket_1) is created that machines all 9 pockets. 

 

 

12 Activate and Verify the new toolpath BN10-Pocket_1 to check for gouges. 

13 Select File - Save Project to update: 

       ......\COURSEWORK\PowerMILL-Projects\Transform 

 

 

 

 

Edit > Limit…  
Edit > Limit provides a series of options to retrospectively, trim a toolpath to a 

Plane, Polygon, or Boundary.  

 These types of retrospective limiting will be undone if the Strategy is re-
calculated. 

For more permanent toolpath limiting use a Boundary as part of the original 

Strategy calculation. 

A typical application for retrospective Toolpath limiting would be the (one off) re-

machining of a local area that has been welded. 
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Edit > Limit > To a Plane 
Edit > Limit to - Plane allows the user to select a plane at specified distance along 

the X, Y, or Z axis.  

 

 

 

The Edit > Limit to - Arbitrary option allows the user to specify an X,Y,Z Point 

and a user defined, Normal vector for the limiting plane. 
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Edit > Limit > to a Polygon 
Using the mouse, you can sketch polygons with any number of sides. 

This allows complex areas to be defined, with the option to save the Inside, Outside, 

or Both sides of the polygon. 

 Before making a polygon ensure that the snap filter is set to pick Anywhere. 

 

 

 

 

Edit > Limit > to a Boundary 
This provides the option to retrospectively limit a toolpath to an existing 

Boundary. This is okay if a temporary, quick solution is acceptable, otherwise the 

Boundary should ultimately be included within the strategy calculation for a 

permanent solution. A typical application for this would be the ‘one off’ machining of 

an area that has been welded due to a previous gouging error. 
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 If the Delete Original option is selected, it causes the deletion of the 

original toolpath once the new toolpath is created.  

 If the toolpath is re-Calculated any retrospective limiting will not apply to 

the new or edited strategy.  
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Changing the Order and Direction within Toolpaths – EX1 
 

For toolpaths containing internal link moves, the order and direction of the tool 

tracks can be changed. For example, if a machining sequence starts at the bottom 

of the part, and progresses upwards, reversing the order will change the tool track 

sequence to start at the top of the part and make it progress downwards. 

 

1 Select File - Delete All and Tools - Reset Forms. 

2 From File > Open Project select the read-only Project: 

           ......\PowerMILL_Data\Projects\EditToolpaths_2 

 

3 Select File > Save Project As: 

......\COURSEWORK\PowerMILL-Projects\EditToolpaths-EX1 

4 In the PowerMILL explorer, right mouse click on the toolpath bn12-finish-
a1 and then from the local menu select Simulate from Start. 

                  

The tool Climb Mills across the form, stepping downwards to the base before 

stepping up the other side. 
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5 Left-click to select all tool tracks on bn12-finish-a1 beyond the centre of the 

form (Yellow in the illustration above). 

6 In the PowerMILL explorer, right-click the active toolpath, bn12-finish-a1 

and from the local menu select Edit > Reorder to open the following dialog. 

 

The selected segments are shown highlighted (blue) in the dialog. 

Each segment is listed in the order of execution. If a toolpath segment is 

selected on the list, the corresponding segment is highlighted in the graphics 

area (and vice versa). You can modify or move the selected toolpath to 

another position in the pecking order. 

You can use the buttons on the left hand side of the dialog for changing the 

order and direction of selected segments. If no segments are selected, the 

whole of the toolpath will be edited. 

The 2 buttons to the lower left of the dialog are Automatic Reorder  

and Automatic Reorder and Reverse . These can only be applied to 

the whole toolpath and not on selected tool tracks. They are designed purely 

to minimise unnecessary air moves. 
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7 Click on the Reverse Order button  to reverse the sequence of the selected 

tool tracks. 

8 Click on the Reverse Direction button  to reverse the direction of each 
selected tool track. 

9 Open the Leads and Links dialog and Apply:- 

Vertical arc:- Lead in with Angle 90 and Radius 6 and 

Lead out with Extended move with Distance 10 

 

The Order and Direction of the toolpath has been edited so that it tracks from 

the outer edges of the form downwards towards the centre of the base. 

 Lead In - Vertical Arc and Lead Out - Extended Move has been 

applied to the above toolpath to identify the directional differences. 

10 Save Project As: 

......\COURSEWORK\PowerMILL-Projects\EditToolpath-EX1 
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Changing the Order and Direction within Toolpaths – EX2 
1 From the main menu, select File - Delete All and Tools - Reset Forms. 

2 Open the read-only Project:- 

        ......\PowerMILL_Data\Projects\EditToolpaths_3 

 

3 Save Project As: 

......\COURSEWORK\PowerMILL-Projects\EditToolpaths-EX2 

 

The Project includes a 3D Offset finishing toolpath D10TR1-FIN1 controlled 

by both Boundary and Pattern segments. 

4 Simulate the Toolpath using a slow setting. 

 

Observe the current direction and ordering of the strategy considering potential 

improvements.  

For example, the lower area machining would benefit from climb milling inwards 

towards the component form and the pocket machining could start central and climb 

mill outwards towards the sidewall. 
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5 From the Main menu, select View > Toolbar > Toolpath to display the 

Toolpath Toolbar. 

 

 

6 Select all tool tracks in the lower area and select Reverse Order . This part 

of the strategy should now climb mill inwards, towards the main component 

dialog. If not ‘climb milling’, then apply Reverse Direction . 

 

7 Select the tool tracks in the central pocket and again select Reverse Order 

followed by Reverse Direction. This part of the strategy should now climb mill 

from the centre of the pocket outwards. 

 

 Extra care is required when using the Spiral option in the selected 

finishing strategy as these are continuous tool tracks and can only be 
reversed and not internally reordered (If a spiral track is created to Climb 

Mill outwards then it can only be modified to Climb Mill inwards). 
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Moving Start Points 
Start points on the tool tracks can be moved to provide a more suitable position for 

applying leads. This is achieved by defining a line that crosses the new start 

positions on the toolpath.  

1 Select File - Delete All and Tools - Reset forms. 

2 Select File - Open Project: 

......\PowerMILL_Data\Projects\limiting-example 

3 Save Project As: 

......\COURSEWORK\PowerMILL-Projects\MoveStartPoint-EX1 

4 Select an ISO1 view. 

 

The toolpath start point  needs to be moved to position . 

5 Select a View from top (Z).  

6 Right-click toolpath 1 and select Edit > Move Start Points and from the 

toolbar select Move start point by clicking a toolpath segment . 
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7 Click a point along the toolpath segment and then  to accept the change. 

 

This has moved the toolpath start point. 

8 Save the Project to update:- 

       ......\COURSEWORK\PowerMILL-Projects\MoveStartPoint-EX1 

 

 

Moving multiple points 
It is possible to apply the Move start points option on the toolpath to multiple 

positions. 

1 Select File - Delete All and Tools - Reset Forms. 

2 Open the Project: 

......\PowerMILL_Data\Projects\PunchForm10-Start 

3 Save Project As: 

......\COURSEWORK\PowerMILL_Projects\PunchForm10 

4 Select a View from top (Z). 

 

 

5 Right-click the active toolpath and from the local menu select Edit > Move 

Start Points (The Move Start Points toolbar is displayed).  

6 If not already selected, on the toolbar, click the Move Start Points by 

drawing a line button. 
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7 On each of the three locations shown below, in the listed order, click and select 

2 points on both sides of the tool tracks.  

 

�  - First move point selection points. 

 

 

�  - Second move point selection points. 

 

 

�  - Third move point selection points. 

 

 

The final output looks similar to this: 
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 The tool tracks are coloured blue while the Move Start Points toolbar is 

active. 

8 Click  on the Move Start Point toolbar to accept the changes. 

9 Save the Project to update:- 

      ......\COURSEWORK\PowerMILL-Projects\ PunchForm10 

 

 

Feeds and Speeds 
You can modify Feed Rates using the Feeds and Speeds dialog to retrospectively 

Apply them to the Active toolpath. 
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1 Select File - Delete All and Tools - Reset Forms. 

2 Select File > Open Project: 

......\PowerMILL_Data\Projects\ExtraFeedrates-Start 

 

3 Select File > Save Project As: 

......\COURSEWORK\PowerMILL-Projects\ExtraFeedrates-Example 

 

4 Undraw the Model, Block, Workplane, and Tool to display the Toolpath and 

3 Boundaries. 

 

5 Activate both the Toolpath and Boundary 2 (The middle one of the 3). 

6 Right-click the Toolpath and select Edit > Update Feed Rate Inside 

Boundary. 

7 Enter value as 50 and click  to apply the percentage difference to the Feed 

Rate within the Active Boundary. 

 

The Toolpath is split into two different coloured areas that are allocated a 

separate Feed Rate as a percentage of the original. The colour coded 

Feedrates are displayed in an Information dialog that appears automatically. 
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8 The Feedrates Information dialog can also be opened by:- 

a Selecting View Feedrates from the local toolpath (BN10-A1) menu.  

b By double-clicking on a Light bulb adjacent to a toolpath (BN10-A1) in the 

PowerMILL explorer.  

 

 The original Cutting Feedrate assigned to the toolpath was 450 mm/min. 

9 Activate both the Toolpath and Boundary 3. 

10 Right-click the Toolpath and from the local menu select Edit > Update Feed 

Rate Inside Boundary. 

11 Enter the value 100 and click  to apply the percentage difference to the Feed 

Rate within the Active Boundary. 

 

The central part of the Toolpath area, clear of the side wall, has changed back 

to the nominal Feed Rate value. 

 

12 The Feedrates Information dialog can also be opened by double-clicking on a 

Light bulb adjacent to a Toolpath in the PowerMILL explorer.  

 

In this case, the nominal Feed Rate is 450 mm/min, and the modified section 

(near the intersection of the Base and Sidewall of the pocket) is reduced by 50% 

to 225 mm/min. The colour of the values displayed in the Information dialog is 

the same as the colours displayed on the toolpath. 
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Safe Z and Start Z Positions 
The tool Rapid Move Heights can be modified in the dialog and applied 

retrospectively to the Active toolpath. 

 

Editing Tool Start and End Point Positions 
The tool Start Point/End Point can be modified in the dialog and applied 

retrospectively to the Active toolpath. 
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Collision Checking 
Collision Checking can either be applied retrospectively or directly during toolpath 

creation, as long as a tool Shank and Holder are defined with the Active Tool.  

Retrospective Collision Checking (Verify -Toolpath) 
If the toolpath menu option, Verify > Toolpath - (Collisions) is applied, two 

additional toolpaths will be created from the original, one being collision safe, and 

the other being in collision. At the same time a copy of the Tool complete with 

appropriate modifications will be substituted into the Original and Collision 

status toolpaths. 

1 Select File > Delete all and Tools > Reset Forms. 

2 Import the Model:- 

     ...\PowerMILL_Data\Models\cowling.dgk  

 

 

3 Calculate the Block to Min/Max limits. 

4 Calculate both the Rapid Move Heights and the tool Start and End 

Points. 

5 Create a Dia 5mm Ball Nose tool named BN5-Short with a length of 10 and 

tool number of 1. 

9. Tool Holder Collision 
Checking 
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6 Select the Shank tab. 

7 Select Add a shank component . 

8 Fill in the dialog exactly as shown in the image below. 

 

9 Select the Holder tab. 

10 Select Add holder component . 

11 Fill in the form for the first Holder element exactly as shown in the following 

image. 
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12 Select Add holder component . 

13 Enter an Upper Diameter of 22, Lower Diameter of 20, and Length of 
10. 

14 Select Add holder component . 

15 Enter an Upper Diameter of 30, Lower Diameter of 30, Length of 10, 
and an Overhang of 15. 

 

 If it is required to modify or delete a Holder element, select (left click) on 

one of them in the assembly illustration and it will turn pale. The current 

values for that element will be displayed and available for modification. 

 The same procedure applies to modify a Shank element. 

16 Click Close. 
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17 From the main toolbar, select Toolpath Strategies  and from 

Finishing open a Raster Finishing strategy. 

 

18 Enter Toolpath name as BN5-RasterFinish, Angle 45, and Stepover 1. 

19 Select Start Corner - Lower Left. 

20 Select Style - Two way. 

21 In the Leads and Links , set both Lead in and Lead out with 1st 

choice as Surface normal arc with Angle 90 and Radius 3. 

22 In the Leads and links - Links page, enter a Short/Long Threshold of 4, 

set Short to Circular Arc, Long to Skim, and Default to Incremental. 

23 In Lead in and Lead out pages, untick the option Add leads to short links. 

 

24 Click Calculate to process the toolpath and then Close the dialog. 
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25 In the PowerMILL explorer hold the cursor over the small box to the left of 

the toolpath lightbulb symbol.  

 

26 The Safety Status window will appear. 

 

The new toolpath is gouge free as far as the Tip (cutting part) of the 

tool is concerned, but up to this stage no collision checking has been 

applied in relation to the Shank and Holder. 

27 From the Main toolbar select Toolpath Verification . 

                           

The two available, independent Check options are Collisions and Gouges. 

Shank Clearance and Holder Clearance, allow the user to specify a value 

for an additional, safe thickness around the tool Shank and Holder elements. 
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28 In the Check box select Collisions. 

29 Input values in the Shank Clearance 2 and Holder Clearance 3. 

30 Click Apply. 

 

The above PowerMILL Information box appears with information on the 

status of the original tool and required dimensional changes. The default 

settings will result in a modified tool (BN5_1) being created along with 2 

new toolpaths (The collision and non-collision parts of the original). The new 

tool (BN5_1) will then automatically exist in both the original and new 

(collision warning area) toolpath. The original tool (BN5) will remain in the 

new (collision safe area) toolpath. 

31 Click OK. 

32 Click Accept on the Toolpath Verification dialog. 

 

PowerMILL has created two new toolpaths, BN5-Raster Finish_1 and 

BN5-RasterFinish_2. A new tool named BN5_1 has also been created in 

the Tools area of the PowerMILL explorer. This new tool has been created 

with the new valid adjustments made i.e. Overhang 26.4 

33 Activate the toolpath RasterFinish_1 in the Explorer. 

        

This toolpath contains the ‘collision free’ segments of RasterFinish, along 

with the original tool BN5.  
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34 Activate the toolpath RasterFinish_2 in the PowerMILL explorer. 

 

This toolpath contains the ‘collision’ segments of the Raster Finish if it 

were machined with the original BN5 tool. 

35 Activate the original toolpath, BN5-RasterFinish, in the PowerMILL 

explorer. 

 

 PowerMILL has substituted a newly created Tool, BN5_1 (with an 

extended overhang) into BN5-RasterFinish and BN5-RasterFinish_2. 

 

36 Select File > Save Project As: 

      ......\COURSEWORK\PowerMILL-Projects\ToolCollisionExample 
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Direct Collision Checking (Automatic Verification) 
Tool Holder Collision Checking can also be applied during Toolpath 

calculation. 

If the Toolpath is calculated with a Tool definition that includes a Shank and 

Holder any part of the toolpath segments that would otherwise be in a 

collision condition will not appear. These missing segments can then be 

machined later using a modified Tool in conjunction with a Collision Safe 

Boundary. 

1 Select File > Delete All and Tools > Reset Forms. 

2 Select an ISO 2 view. 

3 Open the Project: 

       ......\PowerMILL_Data\Projects\ToolCollision_Start 

 

4 Save Project As:  

......\COURSEWORK\PowerMILL-Projects\ToolCollision-Auto 

5 Right-click on the RasterFinish toolpath in the PowerMILL explorer. 

6 From the local menu, select Activate followed by Settings and in the Raster 

Finishing dialog select the Copy toolpath icon . 

7 Select the Automatic Verification page  to open the following dialog: 
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8 Tick the Automatic collision checking box, then input the, Holder 

Clearance as 3 and Shank Clearance as 2. 

9 Calculate the Raster Finishing strategy to directly create a collision free 

toolpath, RasterFinish_1. 

 

 This method does not produce any information for the user or 

automatically create a new collision free tool (BN5_1). 

Machine maximum stock 
If the additional option Machine maximum stock is ticked then a full toolpath 

will be created with a varying increased thickness over the previously 

inaccessible areas. 

 

10 Right-click on the toolpath RasterFinish_1 in the PowerMILL explorer. 

11 From the local menu, select Activate followed by Settings and in the Raster 

Finishing dialog select the Copy toolpath icon . 

12 With the Raster Finishing dialog open, select the Automatic Verification 

page  to access the following dialog: 
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13 Tick - Automatic collision checking, input Shank Clearance 2.0, Holder 

Clearance 3.0, and tick - Machine maximum stock. 

14 Calculate the Raster Finishing dialog to directly create a continuous, 

collision free toolpath, RasterFinish_1_1. 

 

 An additional strategy with a compatible (collision free) tool is required 

to remove the remaining stock. 

Collision Safe Boundary 
A toolpath for the remaining areas will require a new Dia 5 Ball Nosed tool 

with increased Shank length. The additional Toolpath will be calculated to 

limits set by a Collision Safe Boundary based on the current tool (BN5). 

15 Ensure that the tool BN5 is Active. 

16 In the PowerMILL explorer, right-click Boundaries, and from the local 

menu select Create Boundary > Collision Safe. 

 

17 Use the above settings and Apply the dialog. 
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18 Select and Delete all segments except the 2 shown below. 

 

19 Create an empty Pattern and copy the outer Boundary segment to it.  

 With the outer Boundary segment selected, use left mouse key and 

CTRL key to drag and drop Boundary (1) into Pattern (1) from within 

the PowerMILL explorer. 

 

20 Right mouse click on the new Pattern and from the local menu select 

Instrument to display the direction with an arrow.  

 

 

21 Select the Pattern segment and if necessary, select Edit – Reverse 

selected to set it to comply with a climb milling direction. 
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22 In the PowerMILL explorer, right-click the Tool, BN5, and from the local 

menu select Edit > Copy Tool (to create BN5-1). 

 

 

23 Right-click over the new tool BN5-1 and from the local menu, select Activate 

followed by Settings to open the Ball nosed tool dialog. 

24 For the Tip change the length to 15. 

25 Select the Holder tab and change the Overhang to 30. 

26  Close the form. 

27 Activate the new ‘long reach’ Tool BN5_1 

28 Select Toolpath Strategies  on the main toolbar. 

29 From the Finishing options select a 3D Offset Finishing strategy and enter 

data as shown in the following form. 

 

30 Select the Limit page and select Boundary 1 with Trimming > Keep 

inside. 
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31 Select the Automatic Verification page and tick Automatic collision 

checking, input 1 for both Shank and Holder clearances, un-tick Machine 
maximum stock. 

 

 

32 Calculate the toolpath and then Close the dialog. 

 

 The new toolpath does not exhibit any fragmentation, showing that the 

active Automatic Collision Checking has not detected any problems. 

 

33 Select Save Project to update:  

      ......\COURSEWORK\PowerMILL-Projects\ToolCollision-Auto 
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Toolpath Gouge/Collision - Safety Status 
 

When a Toolpath is calculated the symbol to the left of the light bulb in the 

PowerMILL explorer indicates the Safety Status for Gouges (Tip/Flutes) or 

Collisions (Shank/Holder). 

 

 

To display the 4 different levels of Safety Status, position the mouse over a 

symbol   in the PowerMILL explorer and the information form 

will open (shown above right). 
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Introduction 
Patterns are 2D or 3D Wireframe entities used primarily for the control and 

creation of toolpaths. A selection of Pattern creation and manipulation options are 

provided in a dedicated Toolbar (as shown below). 

 

 

 

Below is a summary of the Pattern - toolbar options: 

 - Create Pattern (empty). This will also make the other toolbar options 

active. 

 - Activate the picked pattern. 

 - Pick curves to add to the active Pattern. 

 - Automatic Pattern Generation (Open the Pattern Maker form). 

 - Insert File into Active Pattern (eg. dgk, pic, dxf, iges). 

10. Patterns 
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 - Save Active Pattern as a file (dgk pic dxf). 

 - Insert Boundary into Active Pattern. 

 - Insert Active Toolpath into Active Pattern. 

 - Insert Model into Active Pattern (Selected Model). 

 - Curve modelling. 

 - Wireframe modelling (PS-Sketcher). 

 - Transform pattern 

 - Curve Editor. 

- Clear 

 

 The Pattern segments can be edited directly from local menu options, or via 

the Curve Editor. Unlike Boundaries, Patterns can contain open 

segments.  

When an empty Pattern is created it is automatically assigned a number and made 

Active as shown in the PowerMILL explorer. 

 

 

Automatic Pattern Generation 

The Automatic Pattern Generation icon  opens the Pattern Maker dialog. 

This provides options for the user to construct a range of wireframe layouts that can 

be used in the Pattern Finishing strategy.  

1 Select File > Delete All and Tools > Reset Forms. 

2 Import the Model: 

      ......\PowerMILL_Data\Models\phone.dgk 

 

3 Select Block  and Calculate using the default settings. 

4 Define a dia 12mm Ball Nose tool named BN12. 

5 Reset the Rapid Move Heights . 

6 Select an ISO1 view to display the model. 
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7 Select the ‘shutout’ surface as shown above. 

8 In the PowerMILL explorer, right-click on Boundaries, and from the local 

menu select the option Selected Surface and enter the values shown below. 

 

9 Apply the dialog to create 2 Boundary segments. 

 

 

10 In the PowerMILL explorer, right click on Patterns and from the local menu 

select Toolbar. 
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11  In the Patterns toolbar select, Create a new (empty) Pattern . 

 

12 In the graphics area, select the inner Boundary segment. 

13  In the Patterns toolbar select the option to Insert Boundary into Active 

Pattern . 

14 Delete the Boundary. 

Once the selected Boundary segment is copied as a Pattern segment the 

Boundary is no longer of use. 

 

 

15 Right-click on the Pattern segment and from the local menu, select Curve 

Editor.  

 

 

16 In the toolbar move the cursor over Transformations  and from the 

attached vertical toolbar, select the Offset option . 

 

17 Select Keep Original , the Round Corners option, and input Distance 50 

before clicking the Enter key. 

18 In the Curve Editor toolbar, click  to accept. 
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19 Right-click on the Pattern and from the local menu, select Instrument to 

display the direction arrows on the segments as shown in the image above. 

20 Select the inner Pattern segment and from the local menu select Edit > 

Reverse Selected (Both Pattern segments should now run in the same 

direction). 

The Automatic Pattern Generator will be used to create a new Pattern with a 

series of segments merged between the 2 segments from the original Pattern. The 

resultant toolpath will follow the contour of the component form as well as creating 

corner free, tool tracks with a constant material removal rate.   

21 From the Pattern toolbar, select Create Pattern  to create a new Pattern. 

22 Select Automatic Pattern Generation . 

23 With the new (empty) Pattern activated and the original Pattern displayed, 

select both visible segments. 

24 Select Create Pattern along ‘one-way curves’ with a Stepover 1.0 

 

The form allows the user to create a range of multi-segment Pattern styles from 

either 1 or 2 drive curves. 

25 Click Apply, followed by Accept. 
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The new Pattern has been generated independently; between the two selected 

segments of the original, de-activated Pattern (the above illustration shows a 

larger 2mm Stepover for visual reasons).  

The new Pattern will now be used in a Pattern Finishing strategy. 

26 In the Strategy Selector, Finishing options, select a Pattern Finishing 

strategy. 

 

27 Enter the data into the above form exactly as shown above, click Calculate, and 

then Close the form. 
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The Pattern Finishing toolpath is limited to exist within the defined material 

Block. 

Exercise 
28 Right mouse click on the new toolpath and from the local menu select Edit > 

Reorder. 

29  Use both the Reverse Order and Reverse Direction editing options for the 

Toolpath to start from the outside, Climb Milling towards the centre of the 

model. 

30 Save the Project. 
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Patterns applied to 3D Offset machining 
 

A Pattern can be used as a curve to be offset across the area of a 3D Offset 

Finishing strategy.  

1 Select File > Delete All and Tools > Reset Forms  

2 Import the model: 

......\PowerMILL_Data\Models\speaker.dgk 

3 Save Project As: 

      ......\COURSEWORK\PowerMILL_Projects\SpeakerPattern-EX1.dgk 

 

4 Define a Dia 6 Ball Nose tool with the name BN6. 

5 Define a Block to the default Min/Max limits. 

6 Calculate the Rapid Move Heights to the default settings. 

7 Select an ISO3 view.  

8 Select the 3 shaded Surfaces as shown in the following diagram. 

 

9 Create a Selected Surface, Boundary with allow boundaries to be private 

un-ticked, and with a Tolerance value of 0.02 
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10 From the Pattern toolbar click Create Pattern  followed by Insert 

Boundary into Active Pattern  (Input Boundary name into the dialog!). 

11 Undraw the Tool, Block, Model and Boundary to visually isolate the new 

Pattern. 

 

 Only the leading edge of the Pattern is required. The remaining parts are 

to be removed. 

12 Select the Pattern segment using the left mouse key. 

13 Right mouse click on the Pattern and from the local menu, select Curve Editor 
to open the following toolbar: 

 

 

14 Select the option Cut Item.  

 While performing the next operation it is essential to zoom in as close as 

possible to the end of the pattern segment! 

 

15 Move the cursor over the left hand end of the leading edge to locate the Key 

Point and then left click to cut the segment at this point. 

 

16 Select the leading edge, segment again, locate the Key Point and cut exactly at 

the right hand end of the leading edge. 



10. Patterns PowerMILL 2016 

10 - 10  Copyright © Delcam Ltd  

 

17 Click on the option Cut Item  again to de-select it. 

18 Select the Pattern segments away from the leading edge, and Delete . 

 

19 Click the green tick  to Save the above new segment and close the Curve 

Editor toolbar. 

20 Right mouse click on the Pattern segment and from the local menu, select 

Instrument to display the direction of the segment. 

21 If it is not running in the direction (shown above), right mouse click on the 

Pattern segment and from the local menu select Edit > Reverse Selected. 

22 Re-draw the Tool, Model and the Active Boundary. 

 

 



PowerMILL 2016 10. Patterns 

Copyright © Delcam Ltd  10 - 11 

23 Select a 3D Offset Finishing strategy and enter data into the dialog exactly as 

shown below. 

 

24 Click Calculate to create the toolpath and then Close the dialog. 

 

Leads and Links are not displayed to provide a clearer view of the toolpath. 

The above toolpath starts at the lowest point following the Pattern while offsetting 

across the limiting Boundary in a Climb Milling direction. With the addition of 

suitable Lead In and Lead Out moves this is an ideal strategy for High Speed 

Machining applications. 
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If a Pattern is not selected in the 3D Offset dialog, machining strategy follows the 

shape of the Boundary segment, as shown above. 

25 Save the Project. 

 

Exercise - 3D Offset Finishing controlled by Pattern 
It is not compulsory for the Pattern for controlling the toolpath to be coincident 

with the limiting Boundary. In the following exercise a 3D Offset Finishing will be 

controlled by a Pattern that runs centrally along the base of a curved recess: 

1 Select File > Delete All and Tools > Reset Forms  

2 Open the Project: 

......\PowerMILL_Data\Projects\PatternBlock_Start 

 

3 Click OK to close the PowerMILL Warning and Save Project As:  

......\COURSEWORK\PowerMILL-Projects\PatternBlock_ex1 

4 Calculate the Block using the default settings. 
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5 Calculate the Rapid Move Heights to the default settings. 

6 In the Viewing toolbar switch on display Wireframe . 

7 Create a Pattern using Insert Model on the wireframe arc (included with the 

Model) running centrally along the recessed form. 

8 Select the 5 surfaces that define the recessed form and create a Selected 

Surface, Boundary using a 0.01 tolerance, with the BN16 tool active. 

9 Create a 3D Offset Finishing strategy that is limited Inside the Boundary 

with the order and shape of the tool tracks controlled by the Pattern. 

 

 

10 Save Project As: 

      ......\COURSEWORK\PowerMILL_Projects\PatternBlock-EX1 
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Deep Pattern machining 
If Pattern Finishing is applied with a –ve Thickness it will only create tool tracks 

where the –ve Thickness value is less than the tool, tip radius. As an example, 

this makes it impossible to use a –ve Thickness value less than zero where an End 

Mill is being used. 

It is, however, possible to produce a Pattern Finishing strategy that machines 

deeper into the model if Axial Offset is used in place of a –ve Thickness value. 

This is achieved by first projecting the Pattern onto the surface (relative to the tool 

geometry). Pattern Finishing is then applied using the Drive Curve option with a 

–ve, Axial Offset value while gouge checking is unticked. 

 The strategy produced will not be based on a 3D offset of the model form but 

a series of copies of the Drive Curve stacked downwards. 

1 Select File > Delete All and Tools > Reset Forms. 

2 Open the read only Project: 

...... \PowerMILL_Data\Projects\DeepPattern_Start 

 

 

 

3 Click OK to close the PowerMILL Warning and Save Project As: 

......\COURSEWORK\PowerMILL-Projects\DeepPattern-EX1 

The Project consists of component surfaces and a Pattern on Z0 representing the 

text ‘RH’ ready to be engraved into the component form to a depth of -3. 

4 Calculate a Block, Defined By - Box, using Type - Model. 

5 Create a Dia 5 Ball Nosed tool with the name BN5. 

6 Calculate the Rapid Move Heights to the default settings. 

7 In the PowerMILL explorer, right-click over the Pattern 1 and from the local 

menu select, Edit > Drop to project it downwards onto the model. 

 This projects the Pattern down Z, while compensating for the tooling 

parameters. 
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8 From the main toolbar, select Toolpath Strategies  and in the dialog select 

Finishing followed by the Pattern Finishing option. 

9 Enter the data into the dialog exactly as shown, using Base Position 

Automatic with Thickness -3 and then click Calculate. 

 

 

 The Thickness of -3.0 exceeds the Tip Radius of the Dia 5 Ball Nosed tool 

hence instead of a toolpath appearing, the following PowerMILL Error form 

is displayed. 

 

10 Click OK to close the PowerMILL Error message and recycle the Pattern 

Finishing toolpath using the data as shown in the following image. 
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Base Position - Drive Curve 

Axial Offset  -3.0 

Gouge Check – un-ticked 

Thickness  0 

11 Select the Multiple cuts page and input data exactly as shown below. 

 

Mode - Offset down 

Upper limit – Ticked with value -1.0 (First pass at 1mm below the Pattern) 

Maximum Stepdown 1.0 

12 Click Calculate to create the toolpath and then Close the dialog. 
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The Reversed lettering, Pattern ‘RH’ is now recessed into the Punch form to a depth 

of 3mm. 

 The Toolpath will initially be identified in the PowerMILL explorer with a 

yellow warning.  

 

 

13 Right mouse click on the Toolpath and from the local menu select Verify > 

Toolpath. 

14 In the Toolpath Verification dialog (with the default Check – Gouges set) 

select Apply. 

 

Once verified for gouges, the above Toolpath BN5-Engrave will then be identified 

in the PowerMILL explorer with a red warning. 

        

 

15 Save the Project. 
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Introduction 
This is a wireframe constructor within PowerMILL that provides the user with a 

powerful set of tools for the creation and modification of Boundaries and Patterns. 

It is accessed via the local Boundary or Pattern menu option, Curve Editor... 

During construction, the Intelligent Cursor option allows geometry items to be 

snapped onto key points on a displayed CAD model.  

Input of Drawing detail as a Pattern using the Curve 
Editor 

An empty Pattern can be inserted into the Curve editor thereby providing the user 
with an effective way to input Drawing Detail which could in turn be used in the 

creation of 2.5D Feature Sets. 

 

11. Curve Editor 
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1 Select File - Delete All and Tools - Reset Forms. 

2 In the PowerMILL explorer select Workplanes - Create Workplane. 

 

 

3 The Workplane editor toolbar will become active as soon as a new workplane 

is created on the global datum. 

 

 

4 Select the green tick to exit the Workplane Editor toolbar. 

5 Activate the Workplane. 

6 Select a view down Z. 

7 From the PowerMILL explorer, right mouse click on Patterns and from the 

local menu select Curve Editor. 

 

 

8 From the Curve Editor select Rectangle option. 

 

9 Input 0 in the Command Input box (located to the right and below the 

graphics area) and press the return key to accept. 

 

This will fix the corner of the Rectangle of Lines to the active XYZ datum. 

10 Input 155 100 in the Command Input box and press the return key to accept 

the X and Y dimensions of the rectangle. 

 

11 Select the corner Radius option and input 10. 
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12 Create a new Rectangle of lines using 100 25 to define the start corner. 

13  In the data input box, switch from Absolute  to Relative  input and 

enter 40 50 for the X and Y dimensions. 

 

 

14 From the Create a circle options select the full Circle option. 

 

15 Input a Radius value of 25.  

16 Input 50 50 in the Command Input box followed by the return key. 

 

17 Create another Circle with a centre at 50 90 and a radius value of 3. 

18 Click on  to close the Circle creation options. 

19 Select the Dia 6 Circle. 
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20 With the new Dia 6 Circle selected, open the Transforms options and select 

Create pattern of objects . 

                                       

21 On the dialog, select the Circular tab and enter Angle 30, Number 12 and 

select Reposition rotation axis , and drag it to the centre of the large 

circle. 

 

22 Select Accept on the Multiple Transform dialog. 
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The geometry creation is now complete and is ready to be returned to the 

PowerMILL Project as the contents of the Pattern. 

23 Left click in the graphics area away from the segments to deselect them. 

 If any segments are selected then the remainder will no longer exist on 

return to the main PowerMILL window. 

 

24 Select  to accept changes and export the wireframe back to PowerMILL to 

replace the original boundary. 

 

25 Select File > Save Project As: 

......\COURSEWORK\PowerMILL-Projects\2DModel 
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Boundary modifications using the Curve Editor 
A Shallow Boundary will be created in the following example and although correct 

to the settings applied, it will benefit from further modification to provide improved 

machining strategies. The modifications aim to make the toolpaths, continuously 

follow the lower, component contour by bridging the gap between the 2 outer 

segments as well as smoothing any jagged sections of the segments. The easiest 

and most effective method is to make use the Curve Editor. 

1 Select File - Delete All and Tools - Reset Forms. 

2 Import the Model: 

......\PowerMILL_Data\models\cowling.dgk 

 

3 Calculate a Block using Defined by - Box and Type Model. 

4 Create a Ball Nose cutter of Diameter 10mm named BN10. 

5 Calculate the Rapid Move Heights using the default settings. 

6 Use the default Start and End Point values. 

7 In the PowerMILL explorer, right-click Boundaries and from the local menu 

select Create Boundary > Shallow 

 

8 Input Tolerance 0.02 
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9 Set limit tool centre to block edge.  

10 Un-tick Allow boundary to be private. 

11 Select Apply followed by Accept. 

12 Undraw the model to view the new Boundary. 

 

The Boundary will be modified so that the gap is removed between the 2 outer, 

closed, segments to form separate inner and outer segments. In addition to this, 

two of the other segments, which contain jagged sections, will be smoothed. 

13 Right-click Boundary 1 in the PowerMILL explorer and from the menu 

options select Curve Editor. 

The Curve Editor toolbar will appear above the graphics area. 

 

 Some licensed icons are temporarily greyed out, only becoming available 

when a related entity is selected.  

14 Select a view down Z for a top view of the inserted boundary. 

15 Click Line  from the toolbar then select Create a single line . 

                                                      

 Note: It is essential that the Intelligent Cursor is active (ticked):-  

If not, this is set in the Curve Editor > Options menu:-  

   -- Intelligent Cursor -- Snapping Options -- (Tick all boxes). 

 

16 Using the left mouse button, snap (Key points) to create single lines across the 

ends of the four gaps, as shown in the image below.  
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17 Select the Single Line option  to switch it off. 

18 To remove redundant spans on the curves, click the Limits option  to access 

Interactively limit wireframes.  

                                                        

 

19 Click Interactively limit wireframes  and using the left mouse button, 

select the parts of the curve (arrowed) to be removed. 

 

 

20 Select the Interactively limit wireframes option  again to switch it off. 

21 Zoom into the middle of the area covered by the 3 inner segments. 

 Note the jagged effect along these curves. 
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22 Create 4 single lines, snapped to key points and pointing outwards from the 

curve outside the jagged regions (as shown above).  

These will be used as markers to provide a start and end point for new, 

replacement smoothed curves along the jagged sections. The markers will then 

be used as the limit to trim away the unwanted, jagged sections of the original 

curve. 

23 Click Curve  on the toolbar then select Create a Bezier Curve  from the 

Curve toolbar. 

24 For the upper section, generate a new, smoother, curve by snapping 

strategically placed key points within this region, starting and ending by 

snapping to the ends (Key Point) of the marker lines. 

 The selection of suitable key points requires a certain amount of skill on the 

part of the user. Where it is required to follow the original form closely input 

several, equispaced points. Where the original shape needs to be smoothed 

out input the minimum of equispaced points along the form.  

 

25 Repeat this process for the lower section. 

26 Select the upper, original curve and select the Cut Item option.   

 

27 Click the key points at the lower end of each line to cut the original curve. 
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28 Repeat the above process on the lower, original curve then select and Delete 

 all the unwanted segments between the 2 pairs of lines.  

29 Then, select and Delete the 4 vertical lines. 

 

 

30 Create a new smooth Bezier Curve to replace the one indicated below. 

 

 The Curves used in the above wireframes will consist of open or closed 

segments, but if they are to be used to recreate a boundary they must form 

single entity, closed loops. Only closed forms will appear as boundary 

segments when returned to PowerMILL. 

 

31 Select all boundary segments by dragging a box over them with the left hand 
mouse key depressed. 
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32 Select the option Merge selected segments  to join together all groups of 

curves that butt up to each other. 

 

 

 The wireframe will now consist of five single segments as reported in the 

PowerMILL Information box (above right). 

 

33 Left click in the graphics area away from the segments to deselect them. 

 If any segments are selected then the remainder will no longer exist on 

return to the main PowerMILL window. 

 

34 Select  to Accept changes and export the wireframe back to PowerMILL to 

replace the original boundary. 

 

The modified Boundary is positioned back over the model close to its original 3D 

form. The new smoothed contours are now a more suitable shape for use in the 3D 

Offset Finishing strategy. 

35 Generate a Constant Z Finishing toolpath with Stepdown 1 and in the Limit 

page set the Boundary - Trimming option to Keep outside (Steep areas). 

36 Generate a 3D Offset Finishing toolpath with Stepover 1 and in the Limit 

page set the Boundary - Trimming option to Keep inside (Shallow areas). 

37 Select File > Save Project As: 

          .....\COURSEWORK\PowerMILL-Projects\Boundary-mod 
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These are the resultant toolpaths with the Leads and Links undrawn. 

 The techniques used in this example can equally be applied to Patterns, 

which also have the added advantage on being able to exist both as open or 

closed segments (Boundaries cannot contain open segments). 

 The same Curve Editor toolbar is accessed via the local Pattern menu. 
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Introduction 
PowerMILL offers a range of 2D machining strategies that include 2.5D Feature 

machining (including Drilling), 2D Curve machining (including Chamfer Milling), 

and Face Milling.  

 

Feature Machining 
Features are wireframe entities that are extruded along Z. During creation they are 

specifically defined as a Pocket, Slot, Boss, Hole, Circular pocket, or Circular 

boss. It is also possible to extract Hole features directly from the 3D model. Hole 

Features can also be created during 3D Area Clearance strategies to enable the 

pre-drilling of plunge move, positions. It is essential that a Feature Set includes all 

Features that need to work together to create a 2.5D Feature machining strategy.  

On completion of a Feature Set, the 4 Feature Set options in the 2.5D Area 

Clearance strategies will create roughing, semi finishing, and finishing strategies.  

Drilling strategies can only be applied to Hole Features. A comprehensive, list of 

cycle types are supported that include; Standard Drilling, Boring, Helical/Profile 

milling, Tapping, and Thread Milling. 

 

The six different types of Feature include:- 

� Pocket:- Machining will only occur fully inside this type of closed Feature. 

� Slot:- Machining will occur with the tool running central, left, or right of this 

type of open/closed Feature. 

� Boss:- Machining will only occur fully outside this type of closed Feature. 

� Hole, this type of Feature is specifically used by the Drilling strategies. 

� Circular Pocket - a circular pocket is defined from points, circles or curves. 

� Circular Boss - a circular boss is defined from points, circles or curves. 

 

 It is not possible to change an existing a Feature to one of a different type. 

 

 

 

12. 2D Machining 
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Creating Features from Pattern segments 
1 Select File > Delete All and Tools > Reset Forms. 

2 Open the Read-Only Project: 

                        ......\PowerMILL_Data\Projects\2D-Drawing 

 

The imported Project contains a Pattern defining 2D geometry ready to be 

used to create a Feature Set.  

3 Select File > Save Project As: 

......\COURSEWORK\PowerMILL-Projects\2DPatternExample 

4 In the PowerMILL explorer, right-click on Feature Sets and from the local 

menu, select Create Features. 

The Feature dialogue will appear in the graphics area.  

 

5 Select the large, outer, rectangular Pattern segment and enter values exactly 

as shown (using Type Boss) in the above Feature dialog before clicking Apply 

(Do not close the dialog).  
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The first Feature is the outer component body defined as a Boss (as shown 

above). 

 

 

6 Select both, the rectangular segment (with corner fillets) and the large 

circular segment. 

7 Enter values exactly as shown in the above Feature dialog (using Type Pocket) 

before selecting Apply (Do not close the form). 

 If you close the Feature dialog it can be re-opened in the PowerMILL 

explorer by a right click on the Feature and then from the local menu 

select Create Features. 

 

8 Close the Feature creation dialog. 

9 Right mouse click on the new Feature Set – 1 and from the local menu select 

Create Holes. 
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10 Select all of the Dia 6 circles (12) and enter values exactly as shown in the 

above left Feature dialog (using Type Hole) before selecting Apply. 

                                       

The contents of the Feature Set (1) should be similar to the above illustration 

(Note: A naming system has been deployed where a Boss is prefixed with a B, a 

Pocket with a P, and a Hole with an H). 

11 Close the Hole creation dialog. 

The Feature Set is now complete and ready for the creation of suitable 2.5D 

machining and Drilling strategies. 

2D Feature Set Machining 
1 Define a Dia 10 - tiprad 1 - Length 50 tool named D10TR1. 

2 Click  to open the Block dialog, set the Type as Feature and the select 

Calculate. 

3 Click  to open the Rapid Move Heights dialog and select Calculate. 

 



PowerMILL 2016 12.   2D machining 

Copyright © Delcam Ltd  12 - 5 

4 Click  to open the Toolpath Strategies dialog and select 2.5D Area 

Clearance. 

5 Select Feature Set Area Clearance and input the data exactly as shown in the 

following dialog. 

 

6 In the Offset page tick Spiral. 
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7 In the Leads and Links – Lead in page select:- 

1st choice > Ramp  

Ramp Options > Follow Circle – Circle diameter (TDU) 0.65 

 

 

8 Select Calculate to process the toolpath and then select Cancel to close the 

dialog. 

 

 The Pocket Features are machined with 0.5 stock left on the sidewalls 

and 0 stock on the base (Radial thickness 0.5 and Axial thickness 0).  

 

 

 

9 Click  to open the Toolpath Strategies dialog and select 2.5D Area 

Clearance. 

10 Select Feature Set Profile and input data exactly as shown in the following 

dialog. 
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11 Select the Lead In page and for 1st Choice select Pocket Centre and then 

select the Lead out same as lead in option . 

12 Select Calculate to process the toolpath and then Close the dialog. 
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13 Create a Dia 3 Drill of Length 30, named Drill3. 

14 Click  to open the Strategy selector dialog and select the Drilling tab. 

15 From the list, select Single Peck to open the Drilling dialog (below).  

 

 

16 Select Calculate and all Hole Features will automatically be selected before 

the Drilling toolpath is processed.  

17 Select Cancel to close the dialog. 
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18 Create a Dia 6 Drill of Length 50 and named Drill6. 

19 Click  to open the Strategy selector dialog and select the Drilling tab. 

20 From the list, select Break Chip to open the Drilling dialog (below) and then 

click Select to open the Feature Selection dialog.        

 

21 Select Calculate and all of the contained Hole Features will automatically be 

selected before the Drilling toolpath is processed.  

22 Select Cancel to close the dialog. 
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23 Run a full ViewMILL simulation on all 4 toolpaths. 

 

24 Save the Project. 

2D Machining Exercise 
For this exercise the following 2D drawing will be used along with the imported 2D 
wireframe Pattern: 

 

1 Select File > Delete All and Tools > Reset Forms  

2 Create an empty Pattern and Insert - File: 

    .....\PowerMILL_Data\Models\2d_Wizard_Example.dgk  

3 Save Project As:- 

          .....\COURSEWORK\PowerMILL_Projects\2D_Wizard_EX1 

 



PowerMILL 2016 12.   2D machining 

Copyright © Delcam Ltd  12 - 11 

4 Create a Feature Set (1) and create appropriate Features using the above 

drawing dimensions. 

 

a The outer square and small tapered, central upstand are created as Boss 

Features. 

b The intermediate square is created as a tapered Pocket Feature. 

c The four Dia 15 circles are created as Hole Features. 

d The single red line on the drawing is used to define a Slot Feature (This 

should be created in a separate Feature Set (1_1)). 

 

5 Create a Dia 10 with 3 Tip Radius tool named D10TR3 (Roughing, Semi-

finishing within the main Pocket Feature including the small Boss). 

6 Create a Dia 10 Tapered Tipped tool named D10TR3A5, with Tip Radius 3, 

Taper Angle 5 Deg, Length 25, Taper Diameter 7.5 (Final Finishing of tapered 

walls Main Pocket and small Boss). 

7 Create a Shank of Dia 10 - Length 30.  

8 Create 2 Holder with Overhang 50 and entities:- 

a  Lower Dia 20 - Upper Dia 30 and length 25.  

b Upper/Lower Dia 30 and Length 25. 
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 To calculate the Taper Height based on the Taper Angle and base Taper 

Diameter, the Manual Input icon , adjacent to the Taper Height, is clicked 

to apply the Calculate option  to this parameter. 

                                   

 

9 Create a Dia 15 Drill named Drill15. 

10 Create an End Mill of Dia 10 named EM10. 

 

 

11 Activate the tool D10TR3. 

12 Activate, Feature Set 1 and create a Block (Type - Feature). 

 

13 Calculate default Rapid Move Heights ready to create the 2D Feature 

machining strategies. 
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Main Block and Central Pocket 

D10TR3 - Feature Set Area Clearance – Offset Model    

14 Click  to open the Toolpath Strategies dialog and select 2.5D Area 

Clearance. 

15 Select Feature Set Area Clearance and input the data exactly as shown in the 

following dialog. 

 

16 Calculate the toolpath and perform a ViewMILL simulation as shown below.   
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D10Tr3A5 - Feature set Profile  

17 Click  to open the Toolpath Strategies dialog and select 2.5D Area 

Clearance. 

Select Feature Set Profile and input the data exactly as shown in the following 

dialog. 

 

18 Calculate the toolpath and continue the ViewMILL simulation (as shown 

below).   
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Drill15 – Drilling 

19 Click  to open the Toolpath Strategies dialog and select Drilling. 

20 Select Deep Drill and input the data exactly as shown in the following dialog. 

 

21 Calculate the toolpath and continue the ViewMILL simulation (as shown 

below).   
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EM10 - Feature Set Profile 

 The Y dimension of the existing Block will need to be adjusted to fully, 

include the Slot Feature. 

 

22 Open the Block dialog and input 60 for the Max Y value before selecting 

Accept (Do not select Calculate in the Block dialog). 

23 Activate Feature Set 2. 

24 Click  to open the Toolpath Strategies dialog and select 2.5D Area 

Clearance. 

25 Select Feature Set Profile and input the data exactly as shown in the following 

dialog. 

 

 

26 Select the Slot Feature only and then Calculate the toolpath. 

27 Create 2 more copies of this strategy using Slot Cutting Keep left and Keep 

right respectively. 
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28 Continue the ViewMILL simulation on the last 3 toolpaths (as shown below). 

                

 

 

The required Slot width is achieved by creating 3 separate toolpaths using 

the 3 different Slot cutting options, starting with Centreline, followed by 

Keep left, and then Keep right. 

 

29 Save the Project. 
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Creating Features directly from holes in the Model 
As well as being able to use imported 2D geometry, Hole Features can be 

automatically defined from selected Holes in the 3D Surface or Solid model. 

1 Select File > Delete All and Tools > Reset Forms. 

2 Select File > Import Model: 

......\PowerMILL_Data\Models\3Axis-Drilling 

 

3 Save Project As:- 

......\COURSEWORK\PowerMILL-Projects\DrilledHoles-Example 

 

4 Make sure the Block is not defined at this stage, as the top of the Hole 

Features will be created at the nearest Z dimension (Max or Min) of the Block. 

This is more than likely to result in some holes being created the wrong way up 

(It is however possible to reverse a Hole Feature). 

5 Activate the Workplane MC-datum. 

6 Select the whole model. 

7 In the PowerMILL explorer, right-click on Feature Sets and from the local 

menu select Create holes. 
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8 Input data into the Feature dialog exactly as shown on previous page, and click 

Apply. 

9 Undraw the model. 

 

A Hole Feature is created for each of the 33 selected, Hole elements within the 

model (including the Chamfers and Counter-bores as separate Features). 

 

EXERCISE 

10 Define suitable tools, then Drill and Counter Bore the Holes using the Drilling 
dialog options. 

 

11 Save the Project. 
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Hole Capping 

Hole Features can be used as the basis for capping holes in the 3D model. If the 

intersection of the hole and the top face is non-planar, PowerMILL will cap the hole 

with a surface that follows the tangency of the surrounding 3D model.  

Example 

The following example illustrates the process of capping cylindrical Hole Features 

defined from a 3D model. 

1 Select File > Delete All and Tools > Reset Forms. 

2 Import the model: 

......\PowerMILL_Data\Models\Block_with_holes.dgk 

 

3 Calculate a Block using Defined by - Box and Type - Model (In this case the 

Hole Features will be created upside down). 

4 Select the whole model by dragging a box over it while the left mouse button is 

depressed. 

5 Right mouse click on Feature Sets and from the local menu select Create 

Holes. 

 

6 In the Feature dialogue enter Name root H and select Apply. 
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In this case the tops of the Hole Features are positioned at the shortest 

distance from the face of the Block. This results in all of the Hole Features 

being created upside down.   

 If the Block had not been defined prior to this, then the Hole Features 

would have been created the ‘right way up’ relative to the Z Axis. 

It is also possible to control the resultant direction from within the Create Holes 

dialogue. This is achieved if ‘Use active workplane only’ is ticked along with 

selecting the option ‘Find holes going down’. 

 Any Hole Features that are created to a different orientation from the 

original Z Axis, will automatically be assigned to a separate Feature Set 

and associated Workplane. 

In this case the holes were deliberately created upside down to demonstrate the 

Reverse Holes editing option. 

 

 

7 Right-click Feature Set 1 and in the menu click Select All and then from the 

same menu, select Edit > Reverse Selected Holes. 

 

8 Finally, select the top surface of the Model and in the PowerMILL explorer, 

right-click Feature Set 1 and from the local menu select Edit - Cap Holes. 
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The new Capping Surfaces will be generated (Tangential to the selected top 

surface) in a new model called Capping Surfaces created along with a new level 
of the same name.  

 

9 Click the light bulb to undraw Feature Set 1 ( ). 

10 Expand Levels by clicking on the + symbol ( ). 

11 Click the light bulb to undraw main surfaces ( ). 

The new Capping Surfaces may be created inside out (Surface Normals reversed). 

If required they can be selected and from the local Surfaces menu, Reverse 

Selected can be applied. 

 

 The Capping Surfaces are automatically assigned to the new Level for 

easy selection. 

 

12 Click on the light bulb on the Block with holes level to re-display the main 

model. 
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Internal Thread Milling 

 

Thread Milling is included as one of the options in the Drilling dialog. 

If the Cycle Type - Thread Milling option is selected, the tool plunges centrally to 

a specified depth, leads on to the sidewall, and then pitches upwards before leading 
off. 

Within the options it is possible to apply a number of passes (stepping outwards by 

an allowance value) to avoid tool overload. It is also possible to choose either a 

Right Hand or Left Hand thread. 

1 Select File > Delete All and Tools > Reset forms. 

2 Open the Project: 

    ....\PowerMILL_Data\Projects\ThreadMILL_2014-Start 

 

3 Select File > Save Project As: 

.....\COURSEWORK\PowerMILL-Projects\ThreadMILL-Example1 

 

4 Activate the Thread Milling Tool named M40-Coarse-Pitch-5. 

5 Activate the Feature Set named Pocket (This defines the large central hole). 
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6 Select Toolpath Strategies  and in the Strategy Selector dialog, select the 

Drilling tab followed by the Thread Mill option. 

7 In The Drilling dialog set both Radial and Axial Thickness -3, Pitch 5, Name 

M40-RH-IntThread, leaving all other parameters as default (shown below). 

 

8 Select the Cutter Compensation page. 

9 Tick the CNC cutter compensation box and select Type Tool wear. 

 

10 Calculate the form and then Close the dialog. 
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11 Calculate a new Block using Defined by - Box and Type - Model. 

12 Right-click the NC Program MC-All and in the local menu select Simulate 

from Start.  

13 Open a new ViewMILL session and run a simulation of all toolpaths. (Do not 

activate any of the toolpaths, otherwise the current Block will become oversize). 

 

The completed ViewMILL simulation is as shown above. 

 

14 Disconnect ViewMILL from the simulation (but do not apply Exit ViewMILL), 

and return to the PowerMILL window. 

 

External Thread Milling 
 

15 Activate the Feature Set named Boss (This defines the outside of the central 

boss). 

16 Select Toolpath Strategies  and in the Strategy Selector dialog, select the 

Drilling tab followed by the External Thread option. 
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17 In The Drilling dialog, set the Cycle Type to External Thread, both Radial 

and Axial Thickness -3, Pitch 5, Name M40-RH-IntThread, leaving all other 
parameters as default (as shown below). 

 

18 Select the Threading page and select the Use a 45 degree arc lead option. 

 

19 Calculate the form and then Close the dialog. 

20 Re-open and re-connect the ViewMILL session and run a simulation of the 

latest toolpath M40_RH-ExtThread. 
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21 Select File - Save Project. 
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2D Curve Machining 
PowerMILL contains 3 strategies that directly machine relative to 2D Pattern 

segments. These include: 

� 2D Curve Area Clearance. 

� 2D Curve Profile. 

� Chamfer Milling. 

There is also a dedicated Face Milling strategy that calculates relative to the Block 

dimensions. 

Example 1  
1 Select File > Delete All and Tools > Reset Forms. 

2 Open the Project: 

......\PowerMILL_Data\Projects\2DCurve-2015mc-Start 

 

 

3 Select File > Save Project As: 

......\COURSEWORK\PowerMILL-Projects\2DCurve-Machining 

4 Activate the Pattern named CurveAll.  

5 Calculate a Block using Defined by - Box and Type - Active Pattern (Do not 
close the dialog). 

6 In the Minimum Z co-ordinate box input -22 before selecting Accept to close 

the dialog. 
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7 In the Rapid Move Heights dialog select Calculate. 

8 Activate the Face Milling tool named D50T6. 

9 From the 2.5D Area Clearance options select Face Milling and enter data into 

the dialog exactly as shown below. 

 

10 In the Leads and Links – Links page and set the Short/Long threshold as 

40 and Short as Circular Arc. 

11 Click Calculate to create the toolpath and then Close the dialog. 
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12 Activate the Tip Radiused tool named D16T3. 

13 In the 2.5D Area Clearance options select 2D Curve Area Clearance and 
enter data into the form exactly as shown below. 

 

14 Select the Cut distances page and input Stepdown 10. 
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15 In the Leads and Links – Lead in page select:- 

1st choice > Ramp  

Ramp Options > Follow Circle - Max zig angle 4 - Circle diameter (TDU) 

0.65 

 

16 From the main Curve area clearance page, Curves definition, select 

Interactively modify machinable sections . 

 

These options enable the user to have full control of direction of cut and the areas 

to be machined. 

 

 While the Curve Area Clearance form is open, the areas to be machined 

are displayed as a shaded preview. 

17 Select  to exit the Interactively modify machinable sections toolbar. 

18 Select Calculate to create the toolpath and then Close the dialog. 
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19 Activate the End Mill named EM16. 

20 From the 2.5D Area Clearance options select 2D Curve Profile and enter data 
into the dialog exactly as shown below. 

 

 

21 Select the Cut distances page and input Stepdown 25.  

 

22 Select the Lead in page and for 1st Choice select Pocket Centre and then 

select the Lead out same as lead in option . 

23 Click Calculate to process the toolpath and then Close the dialog. 
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 For the leads to work in this case it is necessary to apply Edit - Move Start 

Points 

 

 

24 Activate the Chamfer Tool named D25Tr1A45. 

25 From the 2.5D Area Clearance options select Chamfer milling and enter data 

into the dialog exactly as shown below (Do not select Calculate yet!). 
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26 Select the Cut distances page and input Number of cuts as 1. 

 

 

27 Click Calculate to process the toolpath (Do not close the dialog). 

 

The resultant Chamfer milling strategy has appeared (incorrectly) on the outside 

of the Pattern segments. 

The toolpath needs to be recycled with the Chamfer Milling tool tracks changed to 

appear on the inside of the Pattern segments. 

 

28 In the Chamfer milling dialog, select the Recycle icon to enable changes to be 

made to the above strategy. 

29 Select Interactively modify machinable sections  to access the Edit 

Machinable Sections toolbar. 

30 Select the Reverse machining side option, followed by  to accept the 

changes and close the toolbar. 

 

31 In the main Chamfer milling dialog, select Calculate to create the toolpath 

and then Close the dialog. 
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The Chamfer milling options selected result in the angled part of the tool 

overlapping the base of the chamfer by 1mm. 

 

A 3D model of the finished component has been imported to provide a visual 

check of the Chamfer machining.  

32 Run a ViewMILL simulation of the whole machining process. 
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Cutter Compensation Example 
Where applicable a Cutter Compensation page is available in a 2.5D Machining 

Strategy dialog explorer options. 

1 Select File - Delete All and Tools - Reset forms. 

2 In the PowerMILL explorer right click on Patterns and from the local menu 

select Create Pattern. 

3 Rename the Pattern as Profile1. 

4 Right click on the new Pattern and from the local menu select Curve Editor. 

 

5 Select Rectangle  from the lines options. 

 

6 In the data input box (below the graphics area) input 0 to set the 1st corner of 

the rectangle, followed by 100 50 to define the X Y dimensions. 

7 Select Rectangle  from the lines options again to deselect it. 

8 Select the green tick to close the Curve Editor and accept the rectangular 

Pattern. 

9 In the PowerMILL explorer right click on Workplanes and from the local 

menu select Create Workplane.  

10 In the Workplane Editor toolbar, select the green tick save.  

11 Activate the new Workplane. 

12 Create a Dia 10 End Mill named EM10.  

13 Calculate a Block using Defined by – Box and Type – Active Pattern. 

14 Input the value Min Z as -20 and then lock  both Min Z and Max Z values.             

15 Input Expansion 15 and then select Calculate to add stock to the X and Y 

dimensions of the Block. 
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16 In the Rapid Move Heights dialog select Calculate. 

17 In the Strategy Selector form select the 2.5D Area Clearance options. 

18 Then select the 2D Curve Profile strategy and enter data as shown in the 

following illustration.  

 

 

19 Select the Cut Distances page and input 20 for both the Stock depth and the 

Stepdown. 

 

20 Return to the Curve Profile page and select the Edit Machining Sections 

options. 

 

21 If required, select Reverse machining side   to move the profiling pass to 

the outside of the Pattern. 
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The above preview shows the cutter being switched from the inside to the outside of 

the Pattern prior to calculating the toolpath.  

 This toolpath will not contain any data that relates to Tool Compensation 

output. 

 

22 Select the green tick to accept the changes and exit Edit Machining Sections. 

23 Calculate the Curve Profile toolpath. 

     

24 Open the Leads and Links form and select Lead in – Horizontal Arc – Angle 

110 and Rad 10. 

25 Copy the Lead In settings to Lead Out.  

26 Select Extensions and input an Extended move of 10 for both Inward and 

Outward. 

27 Apply the Leads and Links settings to the active toolpath. 

28 Right click on the active toolpath (EM10-Profile-NoComp) and from the local 

menu select Settings to open the Curve Profile dialog. 

29 Once the Curve Profile dialog is open select the Make a Copy option.  

30 Rename the new toolpath as EM10-Profile-FullComp. 

31 Select the Cutter Compensation page, tick the CNC cutter compensation 
box, and select Type as Full radius. 
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32 Calculate the new Curve Profile toolpath, but do not close the form. 

33 To test the validity of the applied tool compensation the Toolpath toolbar needs 

to be active (Main pulldown menu:- View – Toolbar – Toolpath). 

 

 

34 In the Toolpath toolbar select the Draw compensated toolpath option.  

 

If Full Compensation is successfully applied it is displayed as a thicker green 

toolpath but offset inwards to the same XY dimensions as the Pattern (If the 

toolpath is displayed in red then the compensation is not geometrically valid).  
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35 Select the Make a Copy option again.  

36 Rename the new toolpath as EM10-Profile-WearComp.  

37 Select the Cutter Compensation page, tick the CNC cutter compensation 

box, and select Type as Tool wear. 

 

 

38 Calculate the new Curve Profile toolpath, and then Close the dialog. 

39 In the Toolpath toolbar select the Draw compensated toolpath option.  

 

 

If Wear Compensation is successfully applied it is displayed as a thicker green 

version of the original toolpath.  

 

40 Save Project As:-  

 ......\COURSEWORK\PowerMILL-Projects\ToolCompExample 
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Viewing the NCData output files for a heid controller 

41 In the PowerMILL explorer, right mouse click on NC Programs and from the 

local menu select Preferences. 

 

42 Open the folder containing the Machine Option File and from the list select the 

file heid.opt and click the Open tab. 

43 Close the NC Preferences dialog. 

44 In the PowerMILL explorer right mouse click on Toolpaths and from the local 

menu select Create Individual NC Programs. 

45 Right mouse click on NC Programs and from the local menu select Write All. 

46 Minimise the PowerMILL window to access the Desktop options and select 

Windows explorer (Or for Windows 8 use File explorer). 

 

47 Once Windows explorer has opened browse to C:\temp\NCPrograms. 

 

 

48 In Windows explorer, right mouse click on an NCdata output file and from the 

local menu select Open with – WordPad. 

49 Repeat stage 73-74 for all 3 NCdata output files and compare the output. 
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Full Compensation                                      Wear Compensation 

             

 The output file using Full Compensation is exactly matching the geometry 

of the 100 X 50 rectangular Pattern. 

 The output file using Wear Compensation is offset by 10mm (the cutter 

radius) outside the 100 X 50 rectangular Pattern. 

50 Save Project As:-  

 ......\COURSEWORK\PowerMILL-Projects\ToolCompExample 

 

Protected Cutter Compensation 

 

With Type – Full radius selected any internal (concave) corners will require a 

suitable Minimum radius value included to allow for corner radii that are less than 

the required full offset value. 
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2D Curve Machining Example – Inc. Clamp Avoidance  
1 Select File > Delete All and Tools > Reset forms. 

2 Open Project: 

......\PowerMILL_Data\Projects\2DCurveProfileSplit-Start 

 

The imported Project also contains a Dia25 End Mill and a Pattern defining the 2D 

geometry used in the existing 2D Machining Strategy.  

 

3 Select File > Save Project As: 

......\COURSEWORK\PowerMILL-Projects\2DCurveProfileSplit-EX1 

 

 

The existing 2D Curve profile toolpath is clearly passing straight through the defined 

clamp positions. This will be fixed by applying the Split Section option that is 

accessed from the 2D Curve Profile form. 

 

4 Select a View down Z. 

5 From the Main pulldown menus select, Draw - Cursor - Tool and Draw - 

Cursor - Cross Hair (Or use the shortcuts Crtl T and Ctrl H). 

6 Ensure that the Pattern - OuterForm is displayed (PowerMILL explorer, light 

bulb on). 
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7  Right click on the toolpath EM25-FullProfile and from the local menu ensure 

Activate is ticked, and then select Settings. 

8 Once the Curve Profile form is open select the Make a Copy option.  

9 Rename the new toolpath as EM25-SplitProfile. 

 

10 On the Curve Profile page select Interactively modify machinable sections. 

 

11 While the above toolbar is open, move the cursor to a point on the left hand side 

of the Pattern segment, and then right click to open the local menu. 

 

12 From the local menu select Split Section and an extra start and end point will 

be created on the Pattern at this point. 

 

13 From the main pull down menus select Draw – Cursor – Cross Hair (Ctrl H). 
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 The cross hair will be displayed on the cursor to assist with alignment of 

start and end point. 

14 Using the left mouse key, drag the new green - start point along the Pattern to 
a position to the right of the upper left clamp (as shown below). 

 

 

15 Locate and drag the corresponding red - end point to a position to the right of 

the lower left clamp (as shown above). 

16 Repeat the process on the other (Left hand) span and drag the start and end 

points to the left hand side of the Pattern (as shown above). 

17 Split the toolpath again twice, to the left of both the upper and lower right 

clamps (as shown below). 

 

18 Move the new start and end points to form 4 distinct spans along the Pattern as 

shown in the following diagram. 

 For accurate alignment use the displayed cross hairs and key points. 
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19 Once the 4 new spans have been aligned, select the green tick in the Edit 

Machining Sections toolbar to accept the modifications. 

20 Back in the Curve Profile machining form select Calculate to process the new 

EM25-SplitProfile toolpath and then Close the dialog. 

 

To check visually check the toolpath for collisions, a triangle model of the stock 

along with the clamps will be imported and used as the ViewMILL block. 

 

21 Select an ISO1 view. 

22 Right mouse click on the toolpath EM25-SplitProfile in the PowerMILL 

explorer and from the local menu select Simulate from start. 

23 Open the Block form and select Defined by – Triangles and Coordinate 

System - Global Transform (See diagram on next page). 

24 Select the Load block from file option  and browse to the model:-          

     ....\PowerMILL_Data\Triangles\2DCurveprofileSplit.dmt 

25 Accept the Block form. 
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The Block will appear as shown below (Opacity slider set to full)) 

 

 

 

26 Connect ViewMILL to the toolpath simulation and run with the Rainbow 

Shaded Image option set. 

 

The tool is no longer crashing through the clamp positions. 

27 Select File - Save to update the stored Project. 
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Introduction 
Once a series of toolpaths have been generated their names can be listed in an NC Program 

file to be post processed as an output file for a specific NC machine control. Any number of 

toolpaths can be included and reordered as required depending on the limitations of the 

particular NC machine along with the associated post processor. 

If the NC machine has a tool change facility then toolpaths created with different cutter sizes 

can be included in the same NC Program. 

If the NC machine does not have a tool change facility then only toolpaths created with the 

same cutter can be included in the same NC Program. 

1 Select File > Delete All and Tools > Reset Forms. 

2 Open the ‘read only’ Project:  

......\PowerMILL_Data\Projects\NCProgram-Start 

 

 

3 Select File > Save Project As:- 

......\COURSEWORK\PowerMILL-Projects\NCProgram-ex1 

13. NC Programs 
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Defined PowerMILL Paths – NC Program output 

4 From the top pulldown menu bar, select Tools > Customise Paths. 

5 In the PowerMILL Paths dialog, select NC Program Output followed by Add 

path to top of list . 

If not already defined, it is now required to set up a path to where the Post 

Processed files (NCPrograms) are to be stored.  

 

6 In the PowerMILL Paths dialog, Select NC Program Output and (if it is not 

already displayed) add the new path C:\Temp\NCPrograms. 

 If this method is used the destination folder for NCPrograms must exist 

on your pc otherwise it will not be possible to output the NCProgram 

files. 

 

7 Click OK to accept and close the above dialog.  

8 Close the PowerMILL Paths dialogue. 
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Use Project On - NC Program output 

An alternative method to control the destination for NCdata output is to use the active 

Project as the default, destination for outputting NC Data files. In the NCPrograms - 

Preferences form, switch Use Project to ON. 

 

On applying the Write command on an NC Program a folder named NC Programs will be 

created in the currently active Project folder. This will not work if a PowerMILL Project has 

not yet been created (Save Project). 

 

 

Setting the NC Preferences 
1 In the PowerMILL explorer, right-click NC Programs and select Preferences. 

 

2 In the NC Preferences dialog, select the folder icon to access the machine tool, 

Option File list. 
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3 From the Select Machine Option Filename dialog (below), select the 

heid426.opt and click the Open tab. 

 

The selected option file translates the output to the correct Machine Tool output 

format. 

 It is not unknown to have more than one Option File for the same 

machine tool to allow for different operational requirements. 

4 Click Accept on the NC Preferences dialog. 

Creating the NC Program 
1 In the PowerMILL explorer, right-click on NC Program and from the local 

menu, select Create NC Program. 
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2 Enter the name Job_646_Top and click Accept. 

 

3 In the PowerMILL explorer select the +/- box by NC Programs to toggle the 

display of the existing NCPrograms.  

 

One or more Toolpaths can be added to the active, NC Program. 

4 Select the Area Clearance icon with the left mouse button and keeping it held 

down drag the mouse to the right (The cursor will display ghosted icons). 

 

5 Continue to drag the toolpath onto the active NC Program, Job_646_Top and 

release the mouse button. In the PowerMILL explorer, NC Programs area 

select the +/- box by Job_646_Top to toggle a display of the contents 

(Roughing_16). 
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6 Drag the other toolpaths into the last file in the active NC program area to 

maintain the required machining order. 

 

Add to – NC Program (alternative method) 

It is also possible to add several toolpaths to the active NC Program. In the 

PowerMILL explorer, select one or more toolpaths and then Right Mouse 

Click on one to open the local Toolpaths menu. 

 

Select Add to – NC Program and all of the selected toolpaths will be added to 

the NC Program list. 

7 Right-click on any of the toolpaths in the current NC Program to access the local 

Toolpath options, but do not apply any of the options at this stage. 
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8 Right-click on the NC Program (Job_646_top) and select Settings. 

 

 You can open (and edit) the NC Program form current by selecting 

Settings from the local right click menu. 

 

 Several of the settings assigned to a specific toolpath can be changed in 

the above dialog. The toolpath row is selected and relevant values (Tool 

Number, Coolant, etc) are then modified before clicking Apply. These local 

edits do not affect the original toolpath.  
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9 Click Accept. 

10 Right-click on the NC Program, Job_646_Top and select Write to create the 

Post-Processed output file. 

During the translation an Information window appears containing a progress 

report. 

 

Newly created Toolpaths are automatically added to the Active NC program. 

It can be useful to Create and Activate an NC Program prior to toolpath 

creation to save having to drag them in later as a separate operation. 

11 De-activate the NC Program, Job_646_Top in the PowerMILL explorer. 

12 Activate the existing Dia 10 Ball nose tool named 10_B. 

13 Calculate a 3D Offset Finishing toolpath, named 3Doffset-test1 using the 

settings and values as shown below. 
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 It is not always required to output all toolpaths in one NC Program. As a 

result it is possible to create an NC Program directly from an individual 

toolpath entity. 

14 Right-click on the toolpath named 3Doffset-test1 and select Create 

Individual NC Programs. 

 

15 A new NC Program is created. Select the + symbol to the left of NC Program 1 to 

access its contents (the + symbol will change to a - symbol). 

 

 The NCProgram icon for 3Doffset-test1 will remain blue until the 

output file is processed (Write). The icon will then turn to green. 
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Viewing the NC-Data output 
Once Post-processed, the NC Data output file can be viewed directly from the local menu. 

� Right-click on the NC Program, Job_646_top and from the local menu, select 

View File. 

 

An Information dialog will open to enable the user to view (but not edit) the 

contents of the NC Data output file.  

Manually Editing the NC-Data output 
If the user needs to edit the code manually, then the NC-Data output file will have to be edited 

in Wordpad. 

1 From Windows Explorer, browse to C:\temp\NCPrograms to where the NC-

Data files are downloaded.  

2 Right-click on one of the NC-Data files and from the local menu, select Open 

With > Wordpad. 

 

3 From the main (top) toolbar select File > Save to update the Project followed 

by Close. 
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Introduction 
All the Setup data required from a PowerMILL Project such as cutter 

definitions, images and information relating to toolpaths can be downloaded as 

HTML files and then printed out as required. This is essential for the CNC Operators 

who will be running the programs. 

1 Select Delete > All and Tools > Reset forms. 

2 Open the Project:  

......\PowerMILL_Data\Projects\SetupSheet-Start 

 

3 Select Save Project As: 

......\COURSEWORK\PowerMILL_Projects\SetupSheet-ex1 

4 From the main pulldown menus select Tools > Options > Setup Sheets > 

Setup Sheets, and tick the box Load Setup Sheets with Project.  

 

5 Accept the form. 

14. Setup Sheets  
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6 From the main pulldown menus select File – Project Settings to open the 

following dialogue. 

 

7 Input Customer, Part Name, and Order Number details as shown above and 

then Close the dialogue. 

 

 There are 2 other tabs for the user to input additional information as User 

Defined Settings and Project Notes. 

 

8 Activate one of the toolpaths to reinstate the original setup (Block, Workplane, 

Rapid Move Heights, etc).  

9 Ensure that no tools or toolpaths are visible and only the shaded model and 
wireframe Block (minimum Opacity) are displayed in an ISO 1 view. 
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10 Right-click on the NC Program named MC-All and from the local menu select 

Setup Sheets > Project Snapshot > Current View. 

 

An image of the model has now been captured and will be automatically used on 

the front page of the setup sheet. 

 

11 Undraw the model leaving the Workplane and wireframe Block as the only 

displayed items. 

12 Right-click on the NC Program - MC-All again and select Setup Sheets > 

Snapshot > All Toolpaths > Iso View. 

 

Images of all the toolpaths in the selected NC program have now been 

captured. 

Each toolpath will have a separate page on the Setup Sheet. 

 

13 Right-click on the NC Program - MC-All again and select Setup Sheets - 

Preview. 

This action will create the Setup Sheet, HTML files. 

The PowerMILL Setup Sheets: Index is displayed on the left side of the 

screen. 
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14 In the above Index dialog left click on Project Setup Sheet-ex1 to display the 

following sheet. 

 Once a page has been selected the text will change from red to blue. 
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15 From the Index page select the Toolpath and Summary pages in turn and 

view the content. 
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 Each HTML page can be printed out as individual items. Right-click on the 

page and from the local menu, select Print Picture. 

The 1st sheet of the Summary Page is as shown below. 

 

 

16 Return to the display to show the PowerMILL explorer again.  

17 Right-click on the NC Program - MC-All and select Setup Sheets > Export. 

 

 Export stores all the Setup Sheets as HTML documents into the current 

Project Folder. 

Setup Sheets can be printed internally from PowerMILL or externally from 

the Exported HTML documents. 
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Customising Setup Sheets 
By editing the HTML templates it is possible to customise the output of the Setup 

Sheets. 

The use of HTML editing software is the recommended method to implement 

changes to the Setup Sheet output. There are free downloads available from the 

web. Microsoft Word can also be used but this can give unpredictable results. 

 Always create a copy of the template document so that the original is still 

available if things go wrong. 

In the following example an alternative template will be substituted into the Setup 

Sheet Toolpath Template search paths. 

1 Right-click on the NC Program named MC-All and select the option Setup 

Sheets > Paths. 

 

2 On the Paths tab select the folder icon in the Toolpath > Write field. 
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3 Browse to ......\PowerMILL_Data\setup-sheets and Open the 

Toolpath2.html file (customised template). 

 

4 Click Close on the Setup Sheets dialog. 

5 Right-click on the NC Program named MC-All select the option, Setup Sheets 

> Preview and re-run the Setup Sheets using the new template. 

6 On the Index page select the new page for the toolpath Roughing_16F 
(Shown below) 

 

 



PowerMILL 2016 15. Specialist Finishing 

Copyright © Delcam Ltd  15 - 1 

Projection Machining. 
Projection Finishing provides greater control of the projection direction of 

machining strategies onto a component. Applications include the machining of 

undercut features using specialist tooling and a more accurate finish for features 

positioned at complex angles to the tool axis. Projection Finishing also provides 

essential strategies for use with Five Axis tool alignment applications. 

There are five different strategies Point, Line, Plane, Curve, and Surface 

Projection. 

 

The simplest way to understand the principle of projection machining is to regard 

the first four strategies comparable to beams of light radiating into or away from a 

defined source (Only the areas visible to the theoretical light source will be 

machined).  

� A Point strategy is similar to light radiating from a single light bulb. 

� A Plane strategy is similar to light radiating from a rectangular floodlight. 

� A Line strategy is similar to light radiating from a fluorescent tube. 

15. Specialist Finishing 
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� A Curve projection strategy is similar to light radiating from a curved neon tube. 

� A Surface projection projects the tool Inwards or Outwards along the normals 
of a selected surface. 

In the Finishing dialog, the projection Direction can be toggled between 

Outwards and Inwards from the user defined plane.  

In the Projection Finishing forms, angular definitions are input using Azimuth 

and Elevation. By using a combination of the two any complex 3D angle can be 

defined. 

� Azimuth Angle:- Starting from +X = 0 this is the angle anticlockwise around 

the Z axis. 

 

This is shown on the chamber model, with a view looking down the Z-axis. 

� Elevation Angle - this is the upward angle from the XY plane 

 

This is shown on the chamber model, with a view looking down the X-axis. 
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Plane Projection Example 
All five Projection Finishing strategies can be used to machine undercut features 

if used with suitable tooling such as Disc or Spherical. The following example shows 

an undercut application using the Plane Projection strategy. 

1 Select File - Delete All and Tools - Reset Forms. 

2 Select File > Open Project: 

......\PowerMILL_Data\Projects\Heatsink-Ucut2-Start 

 

3 Save the Project As: 

......\COURSEWORK\PowerMILL_Projects\ Heatsink-Ucut2-EX1 

4 Open the Block form and with Defined by - Box and Type - Model set select 

Calculate. 

5 Simulate the NCProgram (all of the existing toolpaths) in ViewMILL. 
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6 Return the ViewMILL simulation to the No-Image view . 

7 Disconnect ViewMILL from the toolpath simulation . 

8 Activate the D75-H6-T2 Disc Cutter. 

9 In the Block dialog lock all 4 of the X and Z values. 

10 Calculate the Y values of the Block with an Expansion value of 40. 

 

11 In the Strategy Selector - Finishing dialog, select Projection Plane 

Finishing and fill in the pages of the dialog exactly as shown below.  

 

The Location is the local datum for the projection strategy. All other coordinates 

entered in the dialog are relative to this point. 
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The values for the Start and End heights can be obtained by viewing the model 

in the X direction and using the cursor position to display Z values at the bottom 

right of the screen.  

12 Select Preview to view the Plane Projection pattern. 

 

The Projection Plane > Preview is displayed as shown and the user can 

dynamically alter the view to visually check for potential adjustments. 

When using projection finishing, (Point, Line or Plane), the Anchor Point 

must be positioned (along the projection direction) away from the model by at 

least the cutter radius. 

 

13 Select Calculate to create the toolpath and then Close the dialog. 
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Observe that the tool is gouging through the fins when it retracts at the end of 

each pass. This is confirmed by the red toolpath, icon displaying an exclamation 

mark in the explorer. 

 

In this case suitable Leads and Links will be applied to easily rectify the 

problem. 

1 Open the Leads and Links dialog and select the Lead in tab. 
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2 Input the following in the Lead in page: 

1st Choice - Straight 

Distance 45 

Angle 0  

3 Select the Lead Out the same as Lead in tab.  

4 Apply and Accept the dialog. 

 

The toolpath Lead moves are now updated and the red warning icon in the 

PowerMILL explorer has automatically updated to white. 

5 Save, but do not close, the Project as it is to be continued in the next section. 

Surface Projection Example 
Surface Projection will be used for the finishing strategy as it will provide a 

consistent stepover within the undercut regions. To allow this a specially created, 

single, reference surface will be imported (To create this surface the user would 

require the services of a suitable CAD package such as PowerSHAPE). The 

reference surface does not necessarily have to represent the true shape of the 

finished component. In practice it could be positioned inside, outside, or flush with 

the actual model surfaces to be machined. In this example the reference surface 

is flush with the existing model. 

1 Import the additional model: 

......\PowerMILL_data\models\heatsink-ref.dgk 

 

The new imported surface appears as a separate item in the Models section of the 

PowerMILL explorer. This will be useful when selecting it as the reference 

surface to be used with the Surface Projection dialog. 
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2 From the main pull down menus select View - Toolbar - Command to open 

the command input window below the graphics area and type in the following 
3 lines:- 

EDIT SURFPROJ AUTORANGE OFF 

EDIT SURFPROJ RANGEMIN –1 

EDIT SURFPROJ RANGEMAX 1 

This is to restrict the tool projection distance to within 0.5mm of the reference 

surface. Otherwise it would be projected from infinity onto non-undercut faces 

on the outside of the model. 

 

 The default setting is restored by typing:- 

 EDIT SURFPROJ AUTORANGE ON 

3 From the Toolpath Strategies dialog, select Projection Surface Finishing. 

4 In the PowerMILL explorer, right-click the model, Heatsink-ref and from the 

local pull down menu click Select Surfaces. 
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5 In the Surface Projection Finishing dialog input the settings and data exactly 

as shown below. 

 

 

 

6 Select Ordering as One way. 

7 Set the Start Corner as: Max U max V 

8 Select Preview. 
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The Preview pattern for the strategy is displayed on the reference surface 

(for clarity, a stepover value of 3 was used in this illustration).  

9 Calculate the toolpath and then Close the dialog. 

 

 The unidirectional toolpath is shown here without the defined Leads and 

Links displayed. 

A suitable Lead In and Lead Out must be applied to prevent the tool 

from gouging through the overhang. 

The application of Surface Projection Finishing has produced a strategy with a 

consistent stepover across all of the undercut areas. 

10 Select File > Save to update the stored Project. 
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Line Projection Example 
1 Select File > Delete All and Tools > Reset Forms. 

2 Select File > Open Project: 

......\PowerMILL_Data\Projects\ucut_proj 

 

3 Select File > Save Project As: 

......\COURSEWORK\PowerMILL-Projects\Line-Projection 

4 Select an ISO 3 view. 

The imported Project (training_ucut_proj) contains a Model, Tooling, Roughing, 

and Semi-Finishing strategies with 1 and 0.3 thickness values respectively. The 

undercut regions have not yet been machined. 

 

5 Activate the toolpath (Rough) to reinstate the settings and then simulate both 

existing toolpaths in ViewMILL. 

Tipped Disc cutters will be used for machining the undercut areas. The toolpath will 

be created by projecting a suitable strategy inwards, towards a vertical line, located 

at the lower, left corner. 

6 Select a View from Top (Z). 

7 Place the cursor over the lower left, corner point without clicking and read the X 

& Y values from the information toolbar located below the graphics area. 

 

 The Intelligent Cursor will accurately lock onto the corner providing 

accurate coordinate values. 
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8 Activate the TD30 cutting tool. 

9 From the Toolpath strategies dialog, select Projection Line Finishing. 

10 Fill in the pages of the strategy dialog exactly as shown below. 

 

The values for the Start and End heights were obtained by dynamically moving 

the cursor over the model to obtain the Z values in the cursor coordinate 

boxes at the bottom right of the graphics area. 

 

11 Select Preview. 
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The Preview shows the location of the projection line with arrows showing an 

inward projection direction from the pattern. 

 

12 Calculate the toolpath and then Close the dialog. 

 

The tool is currently gouging through the overhang at the end of each pass. 

This is indicated by the red colour of the toolpath icon as displayed in the 

PowerMILL explorer. 

 

13 Open the Leads and Links dialog. 

 

14 Select the Lead In tab. 
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15 Input the following information: 

1st Choice > Horizontal Arc 

Distance > 5 

Angle > 90 

Radius > 10 

 

16 Select the Lead out the same as lead in tab.  

17 Click Apply and then Accept to close the dialog. 

 

 The extension value in Leads and Links must be more than the tool 

radius to prevent gouging. 

The red warning icon in the PowerMILL explorer will now have changed 

to green. 

18 Select File > Save to update the stored Project. 
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Point Projection Example 
1 Select File > Delete All and Tools > Reset Forms. 

2 Select File > Import Model: 

......\PowerMILL_Data\Models\radknob.dgk 

3 Select File > Save Project As: 

......\COURSEWORK\PowerMILL_Projects\PointProj-ex1 

4 In the PowerMILL explorer, right-click Workplane 1 and from the local menu 

select Activate followed by Workplane Editor to display the following toolbar: 

 

5 From the toolbar select Twist about Y  to open the Twist dialog. 

 

6 In Angle, enter 180 and click Accept. 

7 Click the Green tick to accept the changes and close the toolbar. 

 

The Workplane is rotated 180 degrees about Y to provide vertical machining 

access to the inner wall.  However, machining is currently impossible due to the 

pocket being shielded by an untrimmed planer surface (shown part shaded). 

This example will apply Component Thickness options to set this surface to 

be ignored while applying the machining strategy. 

 

8 Create a Dia 16 ball nosed cutter named BN16. 

9 Calculate a Block using Defined by - Box and Type - Model. 

10 Calculate the Rapid Move Heights using the default settings. 

11 From the Strategy Selector dialog, select Projection Point Finishing. 



15. Specialist Finishing PowerMILL 2016 

15 - 16  Copyright © Delcam Ltd 

 

 

 

12 Fill in the page of the dialog exactly as shown above and select Preview to 

observe the Point Projection setup. 
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13 In the main page of the Point Projection Finishing dialog select the 

Component Thickness icon  and in the dialog select the Surfaces tab. 

 

14 Click on any of the 8 rows to display a coloured box at the start. In the graphics 

area, ensure that the only the untrimmed planar, surface is selected. 
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15 Click the Acquire Components icon  to add the selected, planar surface to 

the row. 

16 Select Ignore in the Machining Mode box. 

17 Apply and Accept the Component Thickness dialog. 

18 Calculate the Projection Point Finishing toolpath and then Close the dialog. 

 

The inside of the pocket has successfully been machined. This would not have 

happened if the untrimmed surface, blocking access had not been included in a 

Component Thickness list with the Machining Mode set to Ignore. 

19 Select File > Save to update the stored Project. 
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Curve Projection Example 
1 Select File > Delete All and Tools > Reset forms. 

2 Select File - Import Model and select: 

......\PowerMILL_Data\Models\ crvproj_3D.dgk 

(Note the model also includes a wireframe curve running centrally along the 

slot). 

3 Select File > Save Project As:- 

......\COURSEWORK\PowerMILL_Projects\CurveProj-Ex1 

 

4 Calculate the Block using Defined by - Box and Type - Model. 

5 Define a Dia 16 Ball Nosed tool called BN16. 

6 Calculate Rapid Move Heights using the default settings. 

7 In the PowerMILL explorer, right-click Pattern and from the local menu select 

Create Pattern. 

8 Select the wireframe curve (coloured green) running centrally along the slot 

on the Model (Note; The Wireframe view  must be active for the curve to 

be visible). 

 

9 In the PowerMILL explorer, right-click on the new Pattern (1) and in the 

local menu select Insert > Model. 

10 From the Strategy Selector dialog, select Projection Curve Finishing. 
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11 Fill in the page of the dialog exactly as shown below and select Preview to 

observe the Curve Projection setup. 
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Visually the preview is somewhat of a mess, containing crossovers and loops 

along the path. The actual toolpath however should not suffer the same 
problem, with the projection distance to the machining areas being a lot shorter 

(well before loops or crossovers start to appear). 

 

12 Calculate the Projection Curve toolpath and then Close the dialog. 

 

 The Curve used as the basis for the strategy will in the majority of cases 

be created in a CAD package as part of the Model. In these cases the 

imported wireframe curve must then be inserted into a Pattern. 

 

13 Select File > Save to update the stored Project. 
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Swarf Finishing 
Swarf Finishing is specifically designed to machine down one or more surfaces 

where a linear transition exists along the tool alignment direction. It will not work 

where the transition is concave or convex. 

For 3 Axis applications the tool axis  must be set to Vertical. 

 

The strategy can be set to create either single (default) or multiple passes, exactly 

following the upper edge, lower edge, or both (merging). 

In the following example the Spar sidewalls will be selected and Swarf machined. 

This will provide a strategy similar in appearance to Constant Z but applied locally to 

the selected surfaces and guaranteed to run the final pass exactly along the bottom 

edge (subject to gouge checking). 

1 Select File > Delete All and Tools > Reset forms. 

2 From File > Open Project select the (read-only) Project: 

......\PowerMILL_Data\Projects\3Axis_SwarfStart1 

 

 

3 From File select Save Project As: 

......\COURSEWORK\PowerMILL-Projects\3AxisSwarfExample 

4 In the PowerMILL explorer, activate the workplane mc-Datum. 

5 In the PowerMILL explorer, activate the Dia 16 End Mill (EM16). 

6 Calculate a Block using Defined by - Box and Type - Model. 

7 Calculate the Rapid Move Heights using the default settings. 
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8 In the PowerMILL explorer, click the [+] adjacent to Levels and Sets to 

access all of the existing Levels. 

9 Right-click on the Level Swarf-MC and click Select Surfaces from the local 

menu. 

 

All Surfaces on Level Swarf-MC will be selected (light blue) to be included in the 

Swarf strategy. 

10 In the Strategy Selector, select the Finishing tab, and then select the Swarf 

Finishing strategy. 

11  Enter data exactly as shown in the following 2 pages of the dialog. 
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12 Select Calculate to create the Swarf Finishing toolpath and then Close the 

dialog. 

 

 The tool tracks that machine the base of the selected surfaces have 

progressively offset upwards (by the stepdown value) until fragmentation 

occurs when the upper edge is exceeded. This can be prevented by using, 
Mode Merge instead of Offset Up. 

 

13 In the PowerMILL explorer, right-click the toolpath EM16-Swarf_OffsetUp 

and select Settings. 

14 Select the Copy Toolpath icon from the dialog . 

15 Rename the new Toolpath as EM16-Swarf_Merge. 

16 In the page labelled Multiple Cuts change the Mode to Merge and with all 

surfaces on the Level Swarf-mc selected, Calculate the strategy. 
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 Merge will use a variable stepdown to exactly track the selected surfaces, 

upper and lower edges and minimize the number of lift moves. 

17 Right-click the last toolpath EM16-Swarf_Merge, in the PowerMILL 

explorer and select Settings. 

18 Select the Copy Toolpath  option. 

19 Rename the new toolpath as EM16-Swarf_SinglePass. 

20 On the Multiple Cuts page, change the Mode to Off. 
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21 With all surfaces on the Level Swarf-mc selected, Calculate the strategy. 

 

22 Close the Swarf Finishing dialog. 

23 Select File > Save to update the stored Project. 

           ......\COURSEWORK\PowerMILL-Projects\3AxisSwarfExample 
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Parametric Offset Finishing 
Parametric Offset Finishing creates a strategy that tracks between two individual 

Patterns with a stepover that adjusts to the shape of the selected surfaces. The 

tool tracks can be created parallel (along) or span between (across) the Pattern 

segments. 

 

1 Select File > Delete All and Tools > Reset forms. 

2 Open the read-only Project: 

......\PowerMILL_Data\Projects\EditToolpaths_3 

 

3 Click OK in the PowerMILL Warning dialog and Save Project As: 

......\COURSEWORK\PowerMILL-Projects\ParaOffset-ex1 

4 Activate the Dia 16 Rad 3 Tip Radiused tool named D16TR3. 

5 With the new tool active, and the surfaces shown (below left) selected, create 

a Selected Surface Boundary. 
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6 Create an empty Pattern, named Upper and Insert the upper Boundary 

segment into it. 

7 Create another empty Pattern, named Lower and Insert the lower Boundary 

segment into it. 

 

 

It is not necessary for both of the Pattern segments to run in the same 

direction as the Upper one will control the toolpath direction. 

 

8 Make sure that no Boundaries are Active. 

9 Open the Parametric Offset Finishing dialog and fill in as shown below. 
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10 Select Calculate to create the toolpath and then Close the dialog. 

 

11 Select File > Save to update the stored Project. 

12 Do not delete the Project as it will be continued in the next section. 
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Parametric Spiral Machining  
This strategy starts from a Pattern and merges a spiral toolpath towards an 

Outer limit which is either defined by the Block or to one or more surfaces 

acquired to a Level or Set. 

 

The direction of the toolpath created in the Parametric Spiral Finishing strategy 

is controlled by the Cut Direction Anticlockwise/Clockwise. The direction of the 

central Pattern has no control over the toolpath direction. 

If the Pocket option is ticked the resultant toolpath will start at the Outer limit. 

 

1 In the PowerMILL explorer right mouse click on Levels and Sets and from 

the local menu select Create Set. 

 

2 Select the upper base Surface and from the new Set (1), local menu select 

Acquire Selected Model Geometry. 

3 Make sure that no Boundaries are Active or displayed. 

4 Open the Parametric Spiral Finishing dialog and fill in as shown below. 
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5 Select Calculate to create the toolpath then Close the dialog. 
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6 Select File > Save to update the stored Project. 
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Wireframe Profile Machining  
Wireframe Profile machining is designed to machine to the left or right of the 

selected curves of a 3D Wireframe. The following example is a pressing that 

requires the outer form and recesses to be finish profiled. As the main imported 

model is in STL (triangle) format it is incompatible with Boundary options that 

operate on selected surfaces. It is also impossible to create the necessary 3D 

Wireframe curves direct from the STL model in PowerMILL. To resolve, the 

stored 3D Curves will be imported into a pattern to be applied in the Wireframe 

Profile Machining strategy. 

 

1 Select File - Delete All and Tools - Reset Forms. 

2 Select File and Import the Model: 

......\PowerMILL_Data\Models\3D-Curve-TriModel.stl 

 

3 Select File > Save Project As: 

......\COURSEWORK\PowerMILL-Projects\3D-WireframeProfile 

4 Create a Dia 5 End Mill named EM5. 

5 Create an empty Pattern, right-click on it, and from the local menu, select 
Insert > File: 

......\PowerMILL_Data\Models\3D-Curve-Wire.dxf 

6 Rename the Pattern as 3Dwire. 

7 With the left mouse click on the model to select it. 

8 In the PowerMILL explorer, right-click on Workplanes and from the local 

menu, select Create and Orientate Workplane - Workplane at Bottom of 

Selection. 

9 Rename the Workplane as MC-Datum. 

10 Right-click on the Workplane (MC-Datum) and from the local menu, select 

Workplane Editor to open the Workplane Editing toolbar. 

 

11 Click Twist about Z  to open the following dialog.  
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12 Enter the value 90 and click Accept. 

13 Click  on the Workplane Editor toolbar to accept the changes and Close. 

14 Activate the workplane (MC-Datum) and select an ISO 1 view. 

 

 The changes will not be physically active until the Workplane Editor toolbar 

has been closed. 

15 Calculate a Block using Defined by Box and Type Model. 

16 Lock the Maximum Z value only and then input an expansion value of 10 

before re-selecting Calculate. 
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The final task prior to machining is to check the directions of the Pattern segments 

and to reverse any that will cause the tool to machine on the wrong side of a 
profile. 

 

17 Right-click on the Pattern (3Dwire) and from the local menu, select 

Instrument to display directional arrows on the individual segments. 

 

Two of the segments (indicated above) must be reversed for the Wireframe 

Profile Machining to Climb Mill to the left of the direction while remaining inside 

the aperture forms on the STL model. 

18 Select the 2 segments (arrowed on the previous diagram) and from the local 

Pattern menu apply Edit > Reverse Selected. 

 

19 Calculate the Rapid Move Heights using the default settings. 

20 Select the Strategy Selector and select the Finishing tab in the dialog. 
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21 Select the Wireframe Profile Machining strategy and enter data exactly as 

shown on the following 2 pages of the dialog. 

 

Curve side controls which side of the Pattern segment direction the tool 

operates. 

Axial offset controls the depth of machining below the wireframe curves. 

 

22 Select Calculate to create the toolpath and then Close the dialog. 
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The Wireframe Profile Machining performs the profiling of the Pattern 

segments in 3D. 

23 Select File > Save to update the stored Project. 
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The Component Thickness options enable the user to apply varying Thickness 

and Machining Mode options to different parts of the component. These can be 

pre-defined as default settings in the Thickness Preferences dialog ready to copy 

into individual toolpath strategies. They can also be defined independantly within 

individual toolpath strategies using the Component Thickness dialog. 

 

The Component Thickness tab allows individual surfaces or solid faces to be 

assigned with different thickness values (Axial and Radial) within a toolpath.  

Other important features in this dialog include the Machining Mode options, 

Ignore or Collision to control machining status on selected parts of the 

component. This is available from the pull-down list consisting of three options: 

� Machine (default) is used to define specific areas of the component to be 

machined with a different Thickness to that that in the main strategy dialog. 

� Collision is used to define areas of the component to be avoided by the 
machining process (such as a clamp). 

� Ignore is used to define areas of the component to be made invisible to the 

machining process so that the toolpath will pass through them (such as a 

blanking surface used to prevent toolpath moves into a hole or pocket during 

earlier machining strategies). 

� The Component Thickness options are also available in Boundary creation 

options that include an active Tool as part of the calculation. 

16 Component Thickness 
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Component Thickness Example 
1 Select File > Delete all and Tools > Reset Forms. 

2 From File > Open Project select the read-only Project: 

.....\PowerMILL-Data\Projects\CompThic_Start 

 

The Project contains an unprocessed Interleaved Constant Z machining strategy 

along with a Dia 8 Ball Nosed tool and all essential parameter settings.  

3 Select File > Save Project As: 

.....\COURSEWORK\PowerMILL-Projects\CompThickness-1 

 

 To make selection easier the Clamps will be transferred to a new Level 

(Clamps) while the split surfaces will be copied to a new Set (Splits). 

 

4 In the PowerMILL explorer, create a new Level and rename it as Clamps and 

then create a new Set and rename it as Split. 

 

5 With the clamp surfaces selected, right-click on the Level named Clamps in 

the PowerMILL explorer and from the local menu select, Acquire Selected 

Model Geometry. 

 It will be easier to select and Blank (Ctrl J) all the other surfaces first 
before simply dragging a box over all of the remaining clamp surfaces. 
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6 With the split surfaces selected, right-click on the Set named Splits in the 

PowerMILL explorer and from the local menu select, Acquire Selected 

Model Geometry. 

7 In the PowerMILL explorer switch off the light bulb next to the Set named 

Splits (This is to prevent them still being displayed if the light bulb for the Level 

General is still switched on). 

8 In the PowerMILL explorer, right-click on the unprocessed, Toolpath BN8-a1 

and in the local menu, select Settings to open the Steep and Shallow 

Finishing dialog. 

 

9 Select Component Thickness  to open the following form. 



16. Component Thickness PowerMILL 2016 

16 - 4  Copyright © Delcam Ltd 

 

With the Machining Mode set to Collision, a Thickness value of 2 will be applied. 

At this safe distance the active tool will either retract or profile around the clamps. 

10 Select the 1st row of the Component Thickness table and a square, colour 

coded symbol (in this case blue) will appear at the start of the row. 

11 With the 1st row still selected, change the Machining Mode to Collision with a 

Thickness value of 2. 

12 Select Smart Selection  to open the following dialog: 

 

13 Switch Select by from Colour to Level or Set. 

14 With Clamps selected in the Levels or Sets box click  to acquire the clamp 

surfaces to the 1st row of the main dialog, and then Close the Selection dialog. 
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The 44 Clamp Surfaces are acquired to the 1st row. 

 

 

15 Apply the Component Thickness dialog to update the settings. 

 

 In the above Component Thickness dialog, it is not necessary to use the 

8 available rows in sequential order! 
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16 Select the 2nd row and a square, colour coded symbol (in this case purple) will 

appear at the start of the row. 

 

The Thickness value of 1.0 will control how much stock is left on the acquired 

split surfaces for this strategy. 

 This is in addition to a Thickness value specified in the main machining 

strategy dialog. In the above Component Thickness dialog the sum of 

these is displayed in the Total Thickness column. 

17 With the 2nd row still selected, keep the Machining Mode as Machine but with 
a Thickness of 1. 

 

18 In Smart Selection  select Splits in the Levels or Sets box and click the 

arrow icon  to assign them in the second row of the main dialog. 
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19 Select the 4th row and a square, colour coded symbol (in this case orange) will 

appear at the start of the row. 

 

The cap surface must be ignored during the creation of this toolpath. 

20 With the 4th row still selected, change the Machining Mode to Ignore with a 

Thickness value of 0. 

21 Use the left mouse key to manually select the cap surface and click on 

Acquire Components  to include it in the 4th row. 

22 Apply the Component Thickness dialog. 

 

While the Component Thickness form is open, Toolpath Thickness Shade mode 
will be active. Acquired surfaces are shaded in the same colour as the row. 
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23 In the Viewing toolbar select the Toolpath Machining Mode Shade. 

 

 

 

This time, relevant parts of the model are colour coded in Red (Ignore) or Yellow 

(Collision). Where applicable, these colour codes also appear at the end of a row. 

 

24 Accept the Component Thickness dialog. 

25 Select Calculate to create the toolpath and then Close the dialog. 

 

26 Select File > Save to update the stored Project. 

27 Do not close the Project as it will be continued in the next section. 
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Cloning the Component Thickness settings from an 
existing Toolpath 

A Corner Finishing strategy BN5-a1 will now be created using ‘cloned’ 

Component Thickness settings as used in BN8-a1. 

1 From the Toolpath Strategies  select the Finishing option, Corner 

Finishing, and input settings exactly as shown below: 

 

 

 

 

 

2 Select Calculate and have a look at the resultant toolpath in the graphics area. 
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For the moment the Corner Finishing strategy is unable to access the base of the 

central pocket and has also produced unwanted tool tracks around the front edge 

of the clamps. This will be rectified by cloning the Component Thickness from 

the toolpath BN8-a1. 

3 Back in the Corner finishing page, select Component Thickness . 

4 In the Clone area of the form use the downward chevron to display and then 

select the toolpath Bn8-a1. 

 

 

5 Select the Copy Thickness Data icon  to Clone the Component 

Thickness settings into the dialog. 
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The Component Thickness settings originally used in BN8-a1 are now cloned 

into the strategy dialog for BN5-a1. 

 The process is not complete until the Apply button has been clicked. 

6 Select Apply followed by Accept to fully update the Component Thickness 

settings in the strategy BN5-a1. 

7 Calculate the Corner Finishing strategy and then Close the dialog. 

 

8 Select File > Save Project 

This will update:-     

.....\COURSEWORK\PowerMILL-Projects\CompThickness-1 



16. Component Thickness PowerMILL 2016 

16 - 12  Copyright © Delcam Ltd 

Modification of existing strategies to allow for 
interchangeable clamping bolts. 

 

The following Project already includes some Strategies to create the 3D 

component form on a pre-machined material Block. All except the initial Face 

Milling strategy need to be modified to accommodate 2 interchangeable pairs of 

clamping bolts aligned along  X and Y respectively.  

 

1 Select File > Delete all and Tools > Reset Forms. 

2 From File > Open Project select the read-only Project: 

.....\PowerMILL-Data\Projects\CompThic-2_Start 

 

 

The individual parts (Component Model, Capping Surfaces, Fixture Plate, and 

Clamping Bolts) are already acquired to suitable Levels. 

 

3 Select File > Save Project As: 

.....\COURSEWORK\PowerMILL-Projects\CompThickness-2 

 

4 Select an ISO 1 view (as shown in the above image). 

5 In the PowerMILL explorer, right mouse click on the Toolpath               

EM25-FaceMill-Top and from the local menu select Activate. 

6 In the PowerMILL explorer, right mouse click on the Toolpath               

EM25-FaceMill-Top and from the local menu select Simulate from Start. 

 

 Before performing a ViewMILL simulation the Block will be modified to 

use a model of the pre-machined material. 
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7 From the main toolbar select the Block dialog. 

 

 

8 Select Defined by > Triangles and Coordinate System > Global before 

selecting the option Load block from file . 

9 In the Open Block from Triangles dialog browse to:- 

C:\Training_Data\PowerMILL_Data\Triangles\CompThic-2_Block.stl and 

select Open.  

 

This Block definition is an accurate model of the pre-machined component. 

 

10 Toggle into ViewMILL and select the Rainbow Shaded Image. 

11 In the Simulation toolbar select the Play button. 

 

12 Select the No Image option  to return to the PowerMILL window and for 

the time being disconnect ViewMILL  from the Simulation. 
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13 From the main menu select the Block option and in the dialog move the 

Opacity slider all the way to the left (wireframe). 

14 In the Viewing toolbar select the option Multicolour Shade. 

 

15 Activate the Toolpath D16TR3-Rgh1. 

 

This toolpath will be modified to Ignore the purple, clamping bolts along the X-

Axis (These are to be physically removed when this toolpath is run). 

This toolpath will also be modified to apply Collision status to the green, clamping 

bolts from a 2mm distance. 

 

16 Right mouse click on the Toolpath D16TR3-Rgh1 and select Settings to open 

the Model Area Clearance dialog. 

17 Select the Re-cycle option  to enable editing to occur. 

18 In the main page of the Model Area Clearance dialog, select the Component 

Thickness dialog . 

19 In the dialog use Smart Selection to acquire the data stored on the Level 

ClampingBolts-X to one of the colour coded rows. 

 

 

20 Set the row with Machining Mode > Ignore. 
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21 Select one of the other colour coded rows and use Smart Selection to acquire 

the data stored on the Level ClampingBolts-Y. 

 

22 Set the row with Machining Mode > Collision with a Thickness > 2.0 and 

then select Apply. 

 

 The parts of the model acquired to a row will be shaded in the same 
colour. 

 

23 Accept the Component Thickness dialog and then Calculate the toolpath. 

 

The updated toolpath (D16TR3-Rgh1) now runs straight through the X-Axis 

clamping bolt area and clears the Y-Axis clamping bolts by a full 2mm. 
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We now require a copy of the Toolpath (D16TR3-Rgh1) that locally machines the 

remainder of the component in the clamping bolt area along the Y-Axis. 

 

24 Right mouse click on the Toolpath D16TR3-Rgh1 and select Settings to open 

the Model Area Clearance dialog. 

25 Select the Make a Copy option and in the Model Area Clearance dialog 

rename it as D16TR3-Rgh2. 

 As the new toolpath is a direct copy, the Component Thickness 

settings will be exactly the same as in D16TR1-Rgh1. 

26 In the main page tick the Rest machining box and then open the Rest page of 

the dialog. 

 

 

27 In the above dialog, insert the reference Toolpath > D16TR3-Rgh1 and fill in 

the other values exactly as shown. 

28 In the main page of the Model Area Clearance dialog, select the Component 

Thickness dialog . 

29 Swap over the settings between the 2 existing rows (as shown below). 

 

 

 

30 Accept the Component Thickness dialog and then Calculate the toolpath. 



PowerMILL 2016 16.  Component Thickness 

Copyright © Delcam Ltd  16 - 17 

 

The updated Rest Roughing, toolpath (D16TR3-Rgh2) now runs straight through 

the Y-Axis clamping bolts. 

 

31 Activate the Toolpath BN10-Fin1 and then select Settings from the local 

menu to open the Steep and Shallow Finishing dialog. 

32 Select the Re-cycle option  to enable editing to occur. 

33 In the main page of the Steep and Shallow Finishing dialog, select the 

Component Thickness dialog . 

34 In the Clone pull down select the Toolpath D16TR3-Rgh1 and the click on the 

Copy Thickness Data icon.  

 

35 Accept the Component Thickness dialog and then Calculate the toolpath. 
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36 The updated toolpath (BN10-Fin1) now runs straight through the X-Axis 

clamping bolt area and clears the Y-Axis clamping bolts by a full 2mm. 

The next stage is to create a copy of the above toolpath (BN10-Fin1) that locally 

machines the remaining areas within the two Y-Axis clamping bolts.  

 

37 Right mouse click on the Toolpath BN10-Fin1 and select Settings to open the 

Steep and Shallow Finishing dialog. 

38 Select the Make a Copy option and in the Model Area Clearance dialog 

rename it as BN10-Fin2. 

 As the new toolpath is a direct copy, the Component Thickness all of the 

current settings will be exactly the same as in BN10-Fin1. In this case the 
required Component Thickness settings can be cloned from the Toolpath 

D16TR3-Rgh2. 

 

39 In the main page of the Steep and Shallow Finishing dialog, select the 

Component Thickness dialog . 

40 In the Clone pull down select the Toolpath D16TR3-Rgh2 and the click on the 

Copy Thickness Data icon.  

41 Accept the Component Thickness dialog. 

 

42 In the Steep and Shallow Finishing dialog select the Block page and lock 

both the Min Z value (-35) and Max Z value (0). Keep the Block page open. 

43 In the PowerMILL explorer, right mouse click on the Level named 

ClampingBolts-Y and from the local menu click on Select All. 
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44 Back in the Block dialog enter an Expansion of 10 and Calculate. 

45 Unlock the Z Max value and manually input the value -26. 

 

 

46 Finally select Calculate at the bottom of the main Steep and Shallow 

Finishing dialog to create the new toolpath BN10-Fin2. 

47 Cancel the Steep and Shallow Finishing dialog. 

 

 

48 Save the Project (but do not close it). 
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Exercise 
 

1 Activate the existing Constant Z Finishing toolpath D8TR1-Fin1. 

 

2 Select Settings and Recycle on the above toolpath. 

3  Use the Component Thickness options to Ignore the surfaces on Level 

ClampingBolts-X (purple), and Machine with a 4mm thickness around the 

surfaces on Level ClampingBolts-Y (green). 

4 Calculate the changes to toolpath D8TR1-Fin1. 

 

 

5 Select Settings and Make a Copy for the toolpath D8TR1-Fin1. 

6 Rename the copy as D8TR1-Fin2. 
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7  Use the Component Thickness options to Ignore the surfaces on Level 

ClampingBolts-Y (green), and Machine with a 4mm thickness around the 
surfaces on Level ClampingBolts-X (purple). 

8 Modify the X dimensions of the Block to keep the Constant Z Finishing 

D8TR1-Fin2 inside the area already machined with D8TR1-Fin1. 

9 Calculate the toolpath D8TR1-Fin2. 

 

 

 

10 In the PowerMILL explorer re-order the Toolpaths to keep them grouped for 

the same pair of clamping bolts. 

 

 

11 Save the Project to update:-  

     .....\COURSEWORK\PowerMILL-Projects\CompThickness-2 
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Introduction 
A Stock Model provides both a visual and physical record of the remaining material 

after such entities as the material block and selected toolpaths have been 

considered. 

Stock Model Rest Roughing 
1 Select File > Delete All and Tools > Reset Forms. 

2 Select File > Open Project: 

......\PowerMILL_Data\Projects\StockModel_1 

3 Select OK in the PowerMILL Warning dialog. 

 

4 Select File - Save Project As: 

......\ COURSEWORK\PowerMILL-Projects\StockModelExample 

5 In the PowerMILL explorer select Stock Models > Create Stock Model. 

 

An empty Stock Model entity appears in the PowerMILL explorer and an 

associated Stock Model settings dialog appears in the graphics area.                                                                                                    

17. Stock Models 
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The default settings for triangulation of the Stock Model are displayed. In this case 

we will modify the settings to create a more accurate Triangle Mesh for the Stock 

Model. Once the Stock Model is physically created then these inherent settings 

cannot be retrospectively altered. 

 

6 Modify the values in the Stock Model settings to be exactly as shown above and 

then Accept the dialog. 

 

The displayed settings in the Stock Model will change accordingly. 

7 Right mouse click on the toolpath D20t3-RGH-a1 and from the local menu 

select Add to > Stock Model. 

 

The toolpath and associated Block are included in the Stock Model tree but at 

this stage are not calculated. 

 

8 In the PowerMILL explorer, Stock Models area, right mouse click on 

 and from the local menu select Calculate.  
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The Stock Model will display the visual effect of toolpath D12t3-RGH-a1 as a 

purple wireframe mesh. 

9 Right-click on Stock Model - 1 and from the local menu, select Drawing 

Options, and then tick both, Shaded and Show Rest Material. 

10 From the Viewing toolbar, undraw the model (both Shaded and Wireframe). 

 

The Stock Model is now displayed as shown with the component model and 

applied toolpath both taken into account. 

This represents the remaining material outside the component form after the 

taking into account the toolpath D20t3-RGH-a1. 

 

 If Block is made active in the Stock Model tree then this is the stage of the 

machining process that will be displayed. 
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11 From the Strategy Selector , Finishing options select the Offset Flat 

Finishing strategy and enter data in the 3 pages exactly as shown below. 

 

a Note: Add approaches from outside is un-ticked to enable fully 

independent Leads to be applied. 

b Allow tool outside flats is un-ticked to limit the toolpath exactly to the X 

Y dimensions of the Block. 

c The Rest Machining box (Rest machining to Stock Model) is ticked to 

prevent the already finished, upper flat areas from being included in the 
toolpath. 

d By ticking this option the Rest page will become available for selection in the 

local browser. 

 

12 In the above dialogue select the Stock Model as 1. 
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13 In the main toolbar, Leads and Links options set the Lead in options exactly 

as shown below. 

 

14 Then copy the Lead in options to the Lead out . 

15 Accept the Leads and Links dialog. 

 

 

16 Calculate the Offset Flat finishing strategy and then Close the dialog. 
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 The latest Toolpath - D20t2-Flats-a1 is automatically added as a 

reference item in the Stock Model list but not as a physical entity.  

 

17 In the PowerMILL explorer, right-click over the Toolpath - D20t3-FLATS-a1 

and in the local menu select Add to > Stock Model. 

 

18 In the PowerMILL explorer, right-click on the Stock Model named 1 and in 

the local menu select Calculate. 

 

After the calculation, the Stock Model will be displayed again only this time with 

the Offset Flats Finishing included. 

 

19 Activate the toolpath D20t3-RGH-a1 and in the local menu select Settings… 

to open the Model Area Clearance dialog. 
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20 Select Create a new toolpath based on this one  and input new data 

into the dialog exactly as shown on the following page. 

 

a Input the Toolpath name as D10t1-RGH-a1  

21 Activate the D10t1 tool. 

22 Set the Style as Offset model. 

23 Tick the Rest machining box. 

24 Select the Rest page and in Rest Machining use Stock Model – 1. 
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25 Select Calculate on the Model Area Clearance dialog to machine within the 

limits of the specified Stock Model. 

 

26 Close the Model Area Clearance dialog. 

27 The latest Toolpath – D10t1-RGH-a1 is automatically added as a reference 

item in the Stock Model list but not as a physical entity.  

28 In the PowerMILL explorer use the left mouse button to drag the Toolpath 

D10t1-RGH-a1 to the bottom of the list. 

 

29 In the PowerMILL explorer, right-click over the Toolpath – D10t1-RGH-a1 

and in the local menu select Add to > Stock Model. 

30 In the PowerMILL explorer, right-click on the Stock Model named 1 and in 

the local menu select Calculate. 

 

The Stock Model is now displayed as shown with the latest toolpath removed.  
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Now that the bulk of the material is removed, the main component form is now 

ready to be Finish machined. 

31 Un-draw the Stock Model. 

32 Select and Blank all except the following surfaces: 

 

33 Using the left mouse button, drag a box across the model above to select all 

displayed surfaces. 

34 Activate the tool BN8. 

35 In the PowerMILL explorer, right-click on Boundaries and in the local menu, 

select the Selected Surface option. 

 

36 Enter data exactly as shown above and then Apply to create the Boundary. 

37 Check that both Boundary 1 and the BN8 tool are both Active. 
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38 Select the Toolpath Strategies  and open the Finishing page. 

39 Select the Steep and Shallow Finishing option and enter data into the dialog 

exactly as shown below: 

 

 

40 Select the Limit page and enter data exactly as shown in the following image: 

 

41 Select Calculate to create the Toolpath and then Close the dialog. 
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 The Toolpath BN8-FIN-a1 has been limited to be inside the Boundary. 

 

42 In the PowerMILL explorer, right-click the toolpath BN8-FIN-a1 and in the 

local menu select Add to > Stock Model. 

43 In the PowerMILL explorer right-click on Stock Model – 1 and select 

Calculate to update. 

 

The remaining Stock Model is displayed as shown above. 
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Stock Model Rest Boundary 
The Finishing strategies do not have a direct Rest Machining option that relates 

to the Stock Model. 

It is however possible to create a Stock Model Rest Boundary to define the areas 

with material left on. This can then be used to limit a finishing strategy such that 

only the remaining stock is removed. 

1 In the PowerMILL explorer, right-click on Boundaries and in the local menu 

select Stock Model Rest. 

 

2 Enter data exactly as shown in the above image and Apply and then Cancel. 

 Boundary segments will only be created where the BN4 tool is able to 

access the model form. 

 

The Stock Model Rest Boundary identifies the area of the remaining Stock 

Model. 
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3 Select the Toolpath Strategies  and select the Finishing tab in the dialog. 

4 Check that the new Boundary BN4-StockModelRest and the BN4 tool are 

both Active. 

5 Select the 3D Offset Finishing strategy and enter data exactly as shown 

below: 

 

 

6 Select the Limit page and enter data exactly as shown in the following image: 

 

7 Select Calculate to create the toolpath and then Close the dialog. 

8 In the Leads and Links options Apply (1st Choice) Lead in/out as Surface 

Normal Arc with Angle 90 and Radius 3. 
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9 In the PowerMILL explorer, right-click the toolpath BN4-FIN-a1 and in the 

local menu select Add to > Stock Model. 

10 In the PowerMILL explorer, right-click on the Stock Model and select 

Calculate to update. 

 

 The Stock Model displayed with Show Rest Material set will have 

visually disappeared apart from perhaps, a few tiny, insignificant patches. 

 If a previous toolpath in the Stock Model tree is selected then the status 

of the material at that point will be displayed. 

 

11 In the PowerMILL explorer, Stock Model - 1 tree, Activate the toolpath 

named D20t3-RGH-a1. 
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12 In the PowerMILL explorer, Stock Model - 1 tree, Activate the toolpath 

named BN4-FIN-a1. 

 The Stock Model will visually disappear while the Show Rest Material 
option is active. 

13 Right-click on the Stock Model and in the local menu, switch on (tick) the 

option Show All Material. 

 

The Stock Model is now exactly the same shape and size as the model. 

 

14 Select File > Save Project to update the stored Project. 
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Stock Model starting from a complex block. 
 

If a casting is to be machined then it is not possible to directly add the complex 

shape to a Stock Model. It is however possible to import a Triangle model of the 

original casting as the initial Block and then use it as the first entity in a Stock 

Model. The Stock Model can then be used as the referenced entity in an intial 

Rest Roughing strategy. 

On import the Block must use the option, Coordinate System as Global 

Transform (Exported Triangle models do not support Workplanes). 

 

1 Select File > Delete All and Tools > Reset Forms. 

2 Select File > Open Project: 

......\PowerMILL_Data\Projects\StockModelCasting_Start 

 

3 Select OK in the PowerMILL Warning dialog. 

4 Select File - Save Project As: 

......\ COURSEWORK\PowerMILL-Projects\StockModelCasting 

 

5 Open the Block form and set Coordinate System to Global Transform. 

 

 

6 Select Defined by – Triangles, select and browse to the triangle model:-  

C:\Training_Data\PowerMILL_Data\Triangles\StockModel-Casting.dmt 
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7 Open the Rapid Move Heights form and select Calculate. 

8 Activate the tool D25TR3. 

9 Create a new Stock Model. 

10 Right mouse click on the new Stock Model and from the local menu select 

Settings. 

 

11 Edit the dialogue with above values and Accept. 

12 Right mouse click on the new Stock Model and from the local menu select 
Apply Block. 

 

The complex Block is added as the first entity in the Stock Model. 

 

13 Right mouse click on the new Stock Model and from the local menu select 

Calculate. 

14 Undraw the Block. 

15 Right mouse click on the new Stock Model and from the local menu select 

Drawing Options and tick both Shaded and Show Rest Material. 
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The model form is visually removed from the Stock Model. 

Exercise: 
16 Calculate a Block of Type - Cylinder and Defined by - Model. 

17 Create a Model Rest Area Clearance – Offset Model strategy with the 

D25TR3 tool, using the Stock Model as the reference item. 

 

 

The Area Clearance - Rest strategy is created within the defined volume of the 

Stock Model. 
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Introduction 
There are various ways in which the user can customise PowerMILL. This chapter 

looks at the creation of: 

� Macros 

� User Menus 

  

Home Area 
The usual method to enable the User Menu to be recognised by PowerMILL is to 

set up and use a home area in Windows. This can be located to any convenient 

area on the hard disk. In the following example the home area is:-  

                                                C: 

 

To check if a Home area already exists on a computer; 

1 Open File Explorer . 

In the local explorer, right-click on This PC and select Properties to open the 

System dialog. 

 

 

18. Macros & User Menu 
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 Alternatively, at the lower left corner of the screen, right mouse click on 

Start  and from the local menu select System. 

 

2 In the System dialog select the Advanced system settings option and then in 

the System Properties dialog, select Environment Variables. 

 

3 If the home area is not already defined as shown below, select New…  

 

4 In the User Variables dialog, enter home in the Variable name field and C:\ in 

the Value field. 

5 Click OK. 

 You must have Admin rights to create a New User Variable. 

6 If it does not already exist, create a folder named pmill2 in the required home 

area (C:\pmill2). 

 If the pmuser.mac, user_menu and any other macros are being stored 

in this folder, then PowerMILL will have immediate access through the 

default Macro search paths. 
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Macros 
A Macro is a text file, which contains a sequence of commands to drive 

PowerMILL operations. These can be created by recording each command or by 

typing in the commands directly. Macros (which have a .mac extension) can then 

be run from the PowerMILL explorer or from a user defined menu. 

When PowerMILL starts up, it will attempt to identify and run the initialisation 

macro (if it exists!) called pmuser.mac. By adding customised PowerMILL 

commands to the initialisation macro, the user can set up their own default settings 

and parameters.  

For immediate use a pmuser.mac can be placed in the pmill2 folder, directly 

below the users Home area. The pmill2 directory is also a convenient location for 

storing other user-defined macros ideally arranged in suitable sub-folders. This will 

be covered later. 

Creating a pmuser macro 
Macros are created in PowerMILL by recording the operations as they occur. Only 

flags or parameters that are physically changed will be recorded into the macro; 

therefore to record a value that is already set, it must be re-entered or a flag re-

switched. For example, if the finishing tolerance is currently set to 0.1mm, and it is 

required that the macro stores the same value, then it must be re-entered over the 

existing copy in the form during recording. 

1 Select File > Delete All. 

2 To start recording, right-click on Macros in the PowerMILL explorer and select 

Record. 

 

3 Save pmuser.mac by first clicking on the existing folder displayed in Save in. 

 

4 Then, in the resultant dialog, browse to C:\pmill2 and at the bottom of the dialog 

enter the file name, pmuser before clicking Save. 
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 The Macro icon changes to red while recording is in progress 

. 

The pmuser.mac automatically runs whenever PowerMILL starts up, thereby 

providing the user with custom default settings. It can also be run at any time 

during a session to reinstate the initialisation settings without having to restart 
PowerMILL. 

 All required data or options must be set or selected if they are to be 

included in a macro (Even if it is necessary to overwrite or switch them off 

first).  

5 From the Main pull-down menus select Tools > Options. 

6 Select Tools > Feeds and Speeds, change the Feed Rate Plunge Factor to 

0.2, tick the Auto Load Feed Rate box, and Accept the dialog. 

 

 

7 Open the Leads and Links dialog and input Short/Long Threshold as 3, both 

Short and Long as Skim, and Default as Incremental. 

 

8 Accept the Leads and Links dialog. 
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9 In the PowerMILL explorer, right-click on NC Programs, and select 

Preferences. 

 

10 On the NC Preferences dialog Output page, select the Machine Option File as 

heid400.opt. 

11 Even if already set, select: 

Use Project - On  

Tool Value - Tip 

Automatic Tool Alignment - On 

Connection Moves - Move, Rotate 

12 Select the Toolpath page and even if already set, select:- 

Tool Change - On New Tool 

Tool Numbering - As Specified 

Tool Change Position - After Connection 

Cutter Compensation: Length - Off  

Radius - None 

13 Select Apply, followed by Accept. 

 It is important to remember to Accept and not to Apply forms that are 

opened while creating an Initialisation Macro, the only exception being the 

creation of NC Program Preferences (An initialisation file is for pre-setting 

forms but at this stage without executing the commands). 

14 Select Stop from the local Macros menu to stop the recording process. 

 

15 Select the plus (+) sign next to Macros in the PowerMILL explorer to open the 

tree. 

16 Right-click pmuser, then select Edit. 
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This is a standard Wordpad document that can be edited with new values and 

then saved. 

To try this out you will need to exit and re-open PowerMILL. 

17 Select File > Exit and restart PowerMILL to check that the settings from 

pmuser.mac have been activated. 

Other Typical Macro Applications 

Apart from tailoring PowerMILL by the creation of an initialisation macro other 

useful applications include macros for un-draw, draw and resetting Leads and 

Links, locating and inserting tooling Templates, setting NC Preferences, regularly 

used machining sequences or settings, and input of preview, commands not yet 

available on the GUI. Note the pmuser macro can be run through the browser at any 

time during a PowerMILL session to restore your settings. 

Creating NC Preference macros 

1 From the PowerMILL explorer, record a macro called Fanuc6m_prefs and 

save it in:-   

C:\pmill2\NCpreferences\... 

2 In the NC Programs > Preferences > Output tab select the Machine Option 

File as fanuc6m.opt. 

3 Input the remaining settings exactly as set earlier for the Heid400 in the pmuser 

macro. 

4 Stop the Macro recording process. 
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 Even if already set it is essential to re-specify settings if they are to be 

recorded into the macro. 

A macro file (Fanuc6m_prefs.mac) is now created that sets up NC Preferences 
for a post-processor option file and the command lines are shown below.  

 

Exercise 

5 Create two more independent NC Preference macros for the Hied400 and Mazak 

option (Use the filenames h400_prefs.mac and mazak_prefs.mac respectively 

for the macros), and save them to: 

C:\pmill2\NCpreferences\... 
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User Menu 
In PowerMILL it is possible to create a user menu enabling the user to further 

streamline and customize the command structure. To access the user menu, right 

mouse click within an empty area of the PowerMILL explorer. 

1 Right-click in an empty area of the PowerMILL explorer to access the current 

user_menu (if it exists). 

This menu is created from a text file called user_menu. It must be in the 

directory pmill2 in the Home area of the computer for the individual user, and 

saved as a text file (not a word Document) and with no extension. If available it 

is easier to obtain a copy of an existing user_menu and modify it as required. 

A user menu can be setup to provide easy access to existing PowerMILL 

commands, Macros and Templates. 

2 Load the in-active user_menu file (which is in the pmill2 folder) into Wordpad. 

Below are instructions for the user_menu command line input (these exist in 

the sample file). 

 

 

A command line will be added to the above user_menu to run the h400_prefs 

macro. 

I "heid400" 1 "macro C:\pmill2\ncpreferences\h400_prefs" 

3 Add the above command line to run the h400_prefs macro directly from the 

user_menu. 

This line locates and runs the file h400_prefs.mac created earlier in this 

chapter. It needs to include the correct drive and path where the macro is 

located. All lettering must be in the correct upper or lower case and include the 

inverted commas and hyphens. 

A more complete version of a typical user_menu is as shown below: 
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This is the user_menu file as displayed in the Wordpad. 

 

Note the NC-Preferences section uses a sub-menu: 

M denotes the start of the sub-menu.  

Z denotes the end of the sub-menu. 
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Y-Branch  
1 Select File > Delete All and Tools > Reset Forms 

2 Import the Model:-  

….\PowerMILL_Data\Models\Y-BranchDuct.dgk 

 

3 Save Project As: 

….\COURSEWORK\PowerMILL_Projects\Y-Branch-MC 

 

4 Create the following Tools:- 

Dia 16 with a 3 Tip Radius named D16TR3 

Dia 12 End Mill named EM12 

Dia 12 Ball Nose named BN12 

Dia 5 Ball Nose named BN5 

 

5 Create an Active NC Program. 

Newly processed Toolpaths are automatically added to an Active NC Program. 

6 Activate the existing Workplane 1, then using the default settings Calculate a 

suitable Block, and Rapid Move Heights. 

19. Tutorials 
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7 Create a 3D Model Area Clearance Toolpath using the Tool D16TR3. 

8 Create an Offset Flat Finishing Toolpath on the base of the Y-form using the 
Tool EM12. 

9 Create two suitable Boundaries (Selected Surface) to limit the Finishing 

Toolpaths for the BN12 and BN5 tools. (Note:- For the BN5 tool select all of the 

end recess surfaces, including the vertical faces, and Tick the box marked Top in 

the Boundary dialogue). 

 

10 Activate the Tool BN12.  

11 Create a Constant Z Finishing Toolpath (limited to be inside the BN12 

Boundary) using both a Min (0.01) and Max (0.5) stepdown combined with a 

suitable Cusp height (0.03) with the Machine down to flats box ticked. 

12 Activate the Tool BN5. 

13 Create a suitable 3D Offset Finishing Toolpath (limited to be inside the BN5 

Boundary) using a Stepover of 0.25, and with both Spiral and Smoothing 

ticked.  

14 Perform a full ViewMILL simulation on the Active NC Program. 

 

Save the Project. 
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Corner Bowl 
 

1 Select File > Delete All and Tools > Reset Forms 

2 Open the (read only) Project:-  

….\PowerMILL_Data\Projects\CnrBwl-Start 

 

 

3 Save Project As: 

….\COURSEWORK\PowerMILL_Projects\CornerBowl-Example 

 

The Project contains; a Model, 2 Workplanes, 9 Tools (including a Form Tool 

along with the Pattern used to create it), 7 Toolpaths that fully machine the 

underside (OP1), and an NC-Program named OP1-CnrBwl-All. 

Setup 

4 Activate the Workplane named MC-Datum-OP2. 

5 Create a new NC Program named OP2-CnrBwl-All. 

 The New NC Program will be Active on creation. Newly processed 

Toolpaths are automatically added to an Active NC Program. 

 

6 Using the default settings, Defined by Box and Type Model, Calculate a Block, 

change the Max Z value to 0 and lock it before selecting Accept.  

7 In the Rapid Move Heights dialog enter the Workplane MC-Datum-OP2 and 

Calculate before selecting Accept. 

 



19. Tutorials PowerMILL 2016 

19 - 4  Copyright © Delcam Ltd 

Area Clearance – Tool D25TR3 

1 Activate the Tool D25TR3. 

2 From the Strategy Selector, open the 3D Area Clearance strategy dialog and 

select a Model Area Clearance strategy. 

3 Enter the Toolpath name OP2-D25TR3-RGH1.  

4 In the Limit page ensure that no Boundary is Active and then select Allow tool 

centre outside the block . 

 

5 In the Model area clearance page, use Style Offset model, with Thickness 

0.5, Stepover 5, Stepdown 25. 

6 In the Offset page, tick Spiral. 

7 In the Step cutting page, tick Step Cutting and input Step-up 2, Detect 
material thicker than 0, and Expand area by 0. 

8 In the Unsafe segment removal page, tick Remove segments smaller than 

threshold, with Threshold 0.95, and un-tick Only remove segments from 

enclosed areas. 

9 In the Flat machining page, set Machine flats to Level. 

10 In the Approach page, tick Add approaches from outside. 

11  In the main Leads and Links dialog set:- 

� Lead in/out 1st choice set Vertical arc with Distance 15, Angle 90, Radius 

8. 

� Lead in 2nd choice select Ramp, and in the Ramp options dialog set Follow 

Circle, Max zig angle 4, Circle Diameter (TDU) 0.65. 

12 Accept the Leads and Links dialog. 

13 Select Calculate in the main Area Clearance dialog to create the Toolpath. 

14 Close the Area Clearance dialog. 

 

 The toolpath is automatically added to the Active NC Program list. 
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Finish Machining – Tool BN16 

 

1 Activate the Tool BN16. 

2 In the PowerMILL explorer select Boundaries – Create Boundary – Shallow. 

 

 

3 Enter data exactly as shown above, and un-tick the box Allow boundaries to be 
private in the Shallow Boundary dialog before selecting Apply. 

 

4 Select and Delete all except the 2 innermost Boundary segments. 
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5 Right mouse click on the new Boundary Flat-BN16 and from the local menu 

select Curve Editor. 

6 In the Curve editor select the outer Boundary segment and apply an Offset of 

2. 

 

 

7 Then select the inner Boundary segment and apply an Offset of -6. 

8 Select the Green tick at the far right of the Curve Editor, toolbar to accept and 

return the changes back to PowerMILL. 

9 From the Strategy Selector, open the Finishing dialog and select a Steep and 

Shallow Finishing strategy. 

10 In the Shallow Finishing dialog enter the Toolpath name OP2-BN16-FIN1. 

11 In the Limit page, select the Boundary Flat-BN16 with Trimming set to Keep 

inside. 

12 In the Steep and Shallow finishing page enter data exactly as shown below. 
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13 In the main Leads and Links dialog select Lead in/out 1st choice set Vertical 

arc with Distance 0, Angle 90, Radius 8. 

14 Accept the Leads and Links dialog. 

15 Select Calculate in the main Steep and Shallow finishing dialog to create the 

Toolpath. 

16 Close the Steep and shallow finishing dialog. 
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Finish Machining – Tool EM30 

1 Ensure that no Boundary is Active. 

2 Activate the Tool EM30. 

3 From the Strategy Selector, open the Finishing strategy dialog and select an 

Offset Flat Finishing strategy. 

4 In the Offset Flat Finishing dialog enter Toolpath name OP2-EM30-FlatFIN1.  

 

5 In the Limit page, select Limit tool centre to block edge . 

 

 

6 In the Offset flat finishing page, enter data exactly as shown below (Note the 

tick box settings!). 

 

 

7 In the main Leads and Links dialog select Lead in/out 1st choice set Vertical 

arc with Distance 15, Angle 90, Radius 12. 

8 Accept the Leads and Links dialog. 

9 Select Calculate in the main Offset flat finishing dialog to create the Toolpath. 

10 Close the Offset Flat Finishing dialog. 
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Finish Machining – Tool D16TR3 

 

1 Activate the Tool D16TR3. 

2 Select the upper edge of the Surface Model 3D form. 

 

3 In the PowerMILL explorer select, Boundaries – Create Boundary – User 

Defined. 
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4 In the above User defined Boundary dialog un-tick the box Allow boundaries 

to be private before selecting the Insert Model option . 

 

5 Rename the Boundary as OP2-Form-TopEdge before selecting Accept to close 

the dialog. 

 

 

6 Select and Delete the inner Boundary segment (as shown above). 

 

 

7 From the Strategy Selector, open the Finishing dialog and select a Constant Z 

Finishing strategy. 

8 In the Constant Z Finishing dialog enter the Toolpath name OP2-D16TR3-FIN1. 
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9 In the Limit page select the Boundary Form-TopEdge with Trimming set to 

Keep Outside. 

10 In the Limit page Z Limits:- 

� Tick the Minimum box and use the picking option  to 

trap and insert the value -85 (left mouse click within the top of the base 

surface). 

� Tick the Maximum box and insert the value -79 (this is 6mm above the top of 

the base surface). 

 

11 In the Constant Z finishing page, enter data exactly as shown below (Note the 

tick box settings!).  

 

 

12 In the main Leads and Links dialog:- 

� In Lead in 1st choice set Surface normal arc with Distance 0, Angle 90, 

Radius 8. 

� In Lead out 1st choice set Vertical arc with Distance 0, Angle 90, Radius 

8. 

13 Accept the Leads and Links dialog. 

14 Select Calculate in the main Constant Z finishing dialog to create the Toolpath. 

15 Close the Constant Z finishing dialog. 
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Finish Machining – Tool EM16 

 

1 Re-open the OP2-D16TR3-FIN1 toolpath dialog and select Create a new 

toolpath based on this one .  

2 Rename the new toolpath as OP2-EM16-FIN1. 

3 Activate the Tool EM16. 

4 In the Limit page, Z Limits section, update the Maximum value to -82 (this is 

approx. 3mm above the top of the base surface). 

5 In the Constant Z finishing page, Stepdown section, enter the data exactly as 

shown below. 

 

 

6 Select Calculate in the main Constant Z finishing dialog to create the Toolpath. 
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Finish Machining – Tool FormTool-1 

 

The 40 Degree angle on top of the step near the bottom of the 3D form will be 

machined with a Form Tool. The profile for the tool tip was created from a 

Pattern which in turn was constructed using the Curve Editor options. 

 

The Pattern must be created in the +ve  X and Y quadrant, relative to the 

Transform (Global Datum) for it to be valid when used in Form Tool creation 

options. Once the Form Tool has been created it will no longer be dependent on the 

Pattern. 

 The above Tool and original Pattern already exists in the start up 

Project. 
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1 Select a View down Z and un-draw all items except the existing Pattern 

FormTool-1. 

2 Zoom into the lower area of the Pattern and from the main toolbar select the 

Measurer .  

 

3 With the Measure tab selected, click on the Open the position input option . 

 

4 In the Position dialog select the Between tab  

5 On the Pattern in the graphics area, left click on key point 1 followed by key 

point 2 (shown above left). 

6 Make a note of the displayed End point values 7.5 and 2.517299. 

  

Next a new Pattern segment will be created along the top, inner edge of the 40 

Degree chamfer (corresponding to key point 2 above). The above values will be 

used to offset (7.5) and move (Z-2.517299) the new Pattern segment to provide 
a path for the form tool centre (key point 1). 
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7 Select all of the surfaces that form the top face of the step near the bottom of the 

3D form (shown shaded light below). 

 

 

8 In the PowerMILL explorer right mouse click on Patterns and from the local 

menu select Create Pattern. 

9 Rename the new Pattern as OP2-Chamfer40Deg. 

10 Right mouse click on the new Pattern and from the local menu select Insert - 

Model (Pattern segments will be created along the open edges of the selected 

model). 

 

11 Select and Delete the outer Pattern segment (as shown above). 

12 Right mouse click on the Pattern and from the local menu select Curve Editor. 

13 Select the Pattern segment. 

14 In the Curve Editor toolbar select Offset item (2D Round) 

 

 

15 Input a Distance value of 7.5 and press return to accept the action. 

16 Select the Pattern segment. 
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17 In the Curve Editor toolbar select Move item. 

 

18 In the Data Input box below the main graphics area enter and return the relative 

XYZ move values 0 0 -2.517299. 

 

19 Select the green tick to accept the changes and return the Pattern to 
PowerMILL. 

20 Right click on the Pattern, segment and from the local menu select Instrument to 

display the direction arrow. 

21 If the arrow is pointing along the upcut direction (anticlockwise if viewed from 

above) select Edit - Reverse Selected. 

 

The Pattern is now suitably positioned for use as a tool centre, drive curve to be 

used in either a 2D Curve Profile or Pattern Finishing strategy. 

22 Ensure that no Boundary is Active. 

23 Activate the Tool FormTool-1. 

24 From the Strategy Selector, open the 2.5D Area Clearance strategy dialog and 

select the 2D Curve Profile strategy. 

25 In the 2D Curve Profile dialog enter the Toolpath name as:-                       
OP2-FormTool1-Chamfer.  

 

26 Set the Position option to The centre of the tool follows the pattern . 
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27 Select the Pick the lowest Z Height option  and snap at any point along the 

drive curve, Pattern segment. 

 

 The snapped Z height value is inserted into the Lower limit box. 

 

28 In the main Leads and Links dialog select Lead in/out 1st choice set 

Horizontal arc with Distance 0, Angle 90, Radius 12. 

29 Accept the Leads and Links dialog. 

30 Select Calculate in the main Offset flat finishing dialog to create the Toolpath. 

 

The Form tool is accurately aligned to the angle across the top of the step. 

31 Close the 2D Curve Profile dialog. 
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Hole Feature – Drilling  

Drilling strategies can only be performed on Hole Features and not directly on the 

component Model. 

 To ensure that the Hole Features are created vertical relative to the 

active Z axis the Block must first be deleted. 

 

 

1 From the main toolbar select the Block dialog and click on the blue cross to 

delete the current Block definition. 

2 Select the whole of the component model. 

3 In the PowerMILL explorer, right mouse click on Feature Sets and from the 

local menu select Create Holes.  

 

4 Enter the data into the Feature dialog exactly as shown above before selecting 

Apply. 
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The Feature Set contains a total of 12 defined Hole Features.  

 Most of the Hole detail has been dealt with in OP1 so the only remaining 

Features that require machining from this side are the 2 Counterbores.  

 

5 Rename the new Feature Set as OP2-Holes. 

6 Activate the toolpath OP2-D16TR3-FIN1 to reinstate the Block and activate the 

Tool D16TR3. 

7 From the Strategy Selector, open the Drilling strategy dialog and select the 

Drilling strategy. 
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8 Select Cycle type Helical and input remaining data into the Drilling dialog 

exactly as shown above and then click on the Select tab. 

 

9 In the Diameter box select 22.00 and click on   to add these holes to the 

Selection Filter box. 

10 Close the Feature Selection dialog and select Calculate in the main Drilling 

strategy dialog. 

 

11 Make a Copy of the last Drilling Toolpath named OP2-EM16-CBores and this 

time use the Tool EM16 and Cycle Type - Profile on both of the counterbore 

Features. 



PowerMILL 2016 19. Tutorials 

Copyright © Declaim Ltd  19 - 21 

 

12 Input data into the Drilling dialog exactly as shown above and Calculate. 

 

 

13 Perform ViewMILL simulations for both OP1 and OP2. 
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14 Save the Project to update:- 

             ….\COURSEWORK\PowerMILL_Projects\CornerBowl-Example 
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2.5D Machining Example 
 

1 Select File > Delete All and Tools > Reset Forms 

2 Open the (read only) Project:-  

….\PowerMILL_Data\Projects\ 2DCurveMachining-2-Start 

 

3 Save Project As: 

                        ….\COURSEWORK\PowerMILL_Projects\2DCurveMachining-2 

 

The Project already includes Toolpaths to rough and finish machine the 3D model 

form. It is however required to create additional recesses into the top face (7.5 deep 

with 10 Deg Draft) and front wall (25 deep – No draft) and 4 Dia 12 holes near the 

corners of the base (offset 15 from the outside of the base).  
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Create individual Patterns for the Top Recess, Front Recess, 
and Base Corner Holes:- 

 

The Model also includes 2D curves which can be made visible by switching on 

Wireframe  in the Views toolbar. 

 

4 Create a new Pattern (1). 

5 Select both of the closed wireframe curves on the Model. 

6 In the PowerMILL explorer right mouse click on the new Pattern and from the 

local menu select Insert – Model. 

 

7 Create another new Pattern (2) and this time Insert the open wireframe curve 

into it. 
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8 Create another new Pattern (3). 

9 Select the upper base surface on the Shaded model and Insert it into the new 
Pattern. 

 

10 Select and Delete the inner Pattern segment. 

 

11 Double left mouse click on the remaining Pattern segment in the graphics area to 

access the Curve Editing toolbar. 

12 Offset the selected segment inwards by 15. 

 

 

 

13 To accept the edits, select the green tick at the end on the Curve Editor toolbar. 
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Machine the top recess with a 10 degree draft angle:- 

 

14 Activate one of the existing toolpaths to reinstate the settings (Workplane, Block, 

and Rapid Move Heights). 

15 Activate the D12TR1 tool. 

16 From Toolpath strategies open the 2D Curve Area Clearance dialog. 

 

 

17 Input the data and settings exactly as shown in the following images. 

 

18 Select  to preview and if required apply the Pattern Decoration options to 

modify the machining area and directions. 
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19 Select Calculate to process the toolpath and then Close the dialog. 
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20 Activate the D6TR1 Tool. 

21 From Toolpath strategies open the 2D Curve Area Clearance dialog. 

22 Input the data and settings exactly as shown in the following images. 
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23 Select Calculate to process the toolpath and then Close the dialog. 
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24 From Toolpath strategies open the 2D Curve Profile dialog. 

25 Input the data and settings exactly as shown in the following images. 

 

 

 

26 Select Calculate to process the toolpath and then Close the dialog 
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The next stage is to machine the vertical, front recess:- 

 

27 Activate the EM12 Tool. 

28 From Toolpath strategies open the 2D Curve Profile dialog. 

29 Input the data and settings exactly as shown in the following images. 
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30 Select Calculate to process the toolpath and then Close the dialog. 
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Drill four Dia 12 holes offset 15mm from the base walls:- 

 

The next stage is to create a Feature Set defining four Dia 12 through holes down 

from the corners of Pattern 3. 

 

 

31 Select the rectanglar Pattern 3 located on top of the base surface. 

32 In the PowerMILL explorer right mouse click on Feature Sets and from the 

local menu select Create Holes.  
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33 In the Create Holes dialog select the option create from Points. 

34 Input the Absolute values -50 (top) and -75 (bottom). 

 

 

35 Select Apply to create four Dia 12 Hole Features. 

 

 

 

36 Activate the Dia 3 Drill. 

37 From Toolpath strategies select the Drilling – Single Peck option. 

38 Input the data and settings exactly as shown in the following image. 
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39 Calculate the Drilling toolpath and then select Re-cycle  the strategy. 
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40 Activate the Dia 12 Drill. 

41 Input the data and settings exactly as shown in the following image. 

 

42 Calculate the Drilling toolpath and then Close the above dialog. 

 

43 Save the Project to update:- 

           ….\COURSEWORK\PowerMILL_Projects\2DCurveMachining-2 


