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Introduction 
3 + 2 Axis Machining involves indexing the head and\or bed to re-align the tool at 

a fixed angular, orientation, before performing standard X Y Z transitions. This is 

achieved either by manual adjustment or as part of the CNC control. 

The most common method of creating a 3 + 2 Axis is by using Workplane with 

the Z-Axis arranged at an appropriate Tool Axis alignment. Standard 3 Axis 

strategies and their plunge and retract moves will occur relative to the 

Workplane.  

 3 + 2 Axis machining enables:-  

a All faces of a component (except the base) can be machined in one set-up, 

relative to a common tool setting datum. 

b Access to deep sidewalls with standard length tooling. 

c Access to undercut features. 

3 + 2 Axis - Machining Example 
1 Open the following Project: 

...\PowerMILL_Data\five_axis\3plus2_as_5axis\3Plus2-ex1-Start 

 

2 Save the Project as: 

...\COURSEWORK\PowerMILL-Projects\3Plus2-ex1 

1.  3 + 2 Axis Machining 
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 A 3-Axis Roughing and two Finishing strategies already exist in the 

imported Project. 

Also, a series of workplanes are already included in the Project, with 
one just above the top of the model at Z175 above the Transform. This 

workplane will be used as the main machining datum. The other 4 

workplanes will be used later to control positional movements between 

multi-axis machining strategies. 

3 Select an ISO 1 view and consider the machining options. 

 Note the relatively high sides of the component and the orientation of the 

three recesses making it impossible to machine as 3 Axis (with the 

tooling aligned to the Z-Axis). 

 

The pocket located along the X direction will be the first to be assigned with a 

new workplane to control one of the 3 Plus 2 - Tool Axis alignments. 

4 From the PowerMILL explorer select Workplane > Create and Orientate 

Workplane > Workplane Aligned to Geometry. 

5 Using the left mouse button, snap or box the wireframe crossover at the base of 

the first pocket (located along X from workplane ztop-175_A). 
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6 Activate the new Workplane 1. 

The workplane is automatically aligned to the wireframe with the Z Axis 

normal to the surface. It still requires further editing as it is advisable for the X-

Axis to align anticlockwise around the component in reference to the global 

coordinates. 

 

7 From the PowerMILL explorer, right-click on Workplane 1 and from the local 

menu, select the workplane editor option to open the following toolbar. 

 

8 Select Twist about Z  and in the dialog, input an Angle of -90 (normal to 

the base of the recess). 

 

The X-Axis of the workplane should be pointing anticlockwise relative to the 

Transform (Global Datum) as viewed from the top of the component (If not 

already the case). 

9 Select  to save the changes and exit the Workplane Editor toolbar. 

10 Rename Workplane 1 as Align_B. 

11 Activate the Workplane - ztop-175_A. 

12 Right-click on the Workplane, Align_B, and from the local menu select 

Transform. 

 

13 Select the Rotate workplane options (shown arrowed below). 
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14 In the Rotate dialog, select Keep original.  

15 Input No. of Copies 2, Angle 120, to create two new workplanes (Positioned 

normal to the base of the next pocket in an anticlockwise direction as viewed 
from the top). 

 

16 Select the small cross on the right of the toolbar to exit the dialog. 

 

17 Select  at the end of the Workplane Editor toolbar to accept the new 

workplanes (Align_B_1 & Align_B_2). 

18 Rename the 2 new Workplanes (in anticlockwise order) as Align_C and 

Align_D respectively. 

The component is now ready to have the 3 Plus 2 machining strategies created, 

relative to the three new workplane alignments. (Align_B, Align_C, and Align_D). 

For each of the 3 Pockets a rectangular material Block will be created locally, 

relative to the aligned 3+2 workplane. A Model Boundary will also be created 

around each pocket to provide even more control of the machining strategy limits. 

1 Activate the workplane Align_B. 

2 Select the 2 surfaces that define the pocket around workplane Align_B. 

3 Create a Block (Defined by box) to Type Model (Model). 
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4 Ensure that the pocket surfaces are still selected so that the Rapid Move 

Heights calculation ignores the de-selected surfaces. 

5 In Rapid Move Heights  input the operational Workplane as Align_B and 

select Calculate to create values for Safe Z and Start Z aligned to the correct 

coordinate system. 

 

 Input the Workplane (Align_B) to achieve the correct Rapid Move 

Heights alignment. 

 Rapid Move Heights are calculated based on the Model or Block, 

whichever has the maximum Z height. 

If a group of surfaces are selected, the remainder will not be included in 

the calculation. 
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6 Create a User Defined - Model - Boundary named Pkt-B1 around the top 

edge of the pocket (surfaces still selected!) that surrounds the Workplane 
(Align_B). 

7 Activate the existing Tiprad tool D10TR1. 

8 Set Lead In to Ramp with Ramp Options as Zig Angle 4, Follow Circle, and 

Diameter (TDU) 0.6 

9 In the Strategy Selector dialog in 3D Area Clearance select Model Area 

Clearance and fill in the options in the pages, exactly as shown below: 

 

Toolpath name: D10TR1-Rgh-B1 

Style: Offset model. 

10 In the Limit page input the Boundary Pkt-B1 and set Limit tool periphery to 

boundary. 

 

11 Select Calculate to create the toolpath and then Cancel the dialog. 
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The toolpath plunge moves are aligned to the Active workplane’s, Z Axis. 

12 Use Copy to create cloned strategies on the other two recesses, adjusting the 

values and settings as required to create toolpaths, D10t1-Rgh-C1 and 

D10t1-Rgh-D1. 

a Rapid Move Heights must be defined separately for each toolpath with the 

correct Workplane selected in the dialog (Remember to include the correct 

Workplane in the dialog). 

 

 

b Don’t forget to create and activate the appropriate User defined - Model - 

Boundaries named Pkt-C1 and Pkt-D1. 
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After the creation of toolpaths for 3 + 2 Axis valid ncdata can only be output 

using a compatible, post-processor. For programs containing multi-alignment 
toolpaths the NC Programs output options create the ncdata from one datum (In 

this case the Workplane - ztop175_A). This option is selected in the NC 

Preferences or NC Program Settings dialog. 

13 In the PowerMILL explorer, right-click on NC Programs and select 

Preferences. 

14 From the Machine Option File select MS-GV503-1.opt as the controller. 

15 For the Output Workplane select ztop-175_A. 

 

16 Close the dialog. 
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17 In the PowerMILL explorer, NCPrograms, select Create NC Program and 

add to it the toolpaths, D10TR1-Rgh-B1, D10TR1-Rgh-C1, and D10TR1-
Rgh-D1. 

 

 The link moves between the three individual ‘3Plus2’ toolpaths are displayed 

in the NC Program and in this case are passing straight through the 

component! 

 

Automatic gouge protection only exists within a toolpath (Between the Start and 

End Point). After inserting the toolpaths into an NC Program, it is essential to 

independently control the Positional Moves outside the toolpaths to eliminate any 

collisions with the component and fixtures. 
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Link moves controlled by Absolute Start and End points 
 

This method of creating safe link moves between separate 3 Plus 2 toolpaths 

is the most universal and safest method for all types of application and post-

processor. The start and end point for each toolpath is defined as an 

absolute coordinate position above the maximum Z height of the component. 

 

18 Activate the toolpath D10TR1-Rgh-B1. 

19 Select a View from right (X). 

 

20 Switch on both Draw - Cursor – Crosshair (Ctrl H) and Tool (Ctrl T). 

21 Move the cursor to a suitable Start/End point above the top of the model. 

 

The X, Y, and Z coordinate values are displayed in the information toolbar located 

below the graphics area. 

 

22 Make a note of the individual Y and Z values as integers 130 and 100. 
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The Rapid Move - Safe Z value must now be matched to the Z value in Start and 

End Point dialog. 

 

23 Open the Rapid Move Heights dialog, edit the Safe Z value to 100 before 

selecting Apply (to update the toolpath). 

 

24 Open the Start and End Point dialog  

 

25 For the Method select Use - Absolute and input the new Y value (130). 

26 Select Apply Start Point (to update the toolpath). 

27 Select the End Point tab, repeat stage 25 above, and then select Apply End 

Point (to update the toolpath). 
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28 Repeat stages 19 to 27 on toolpaths D10TR1-Rgh-C1 and D10TR1-Rgh-D1 

this time using the values 130 and 130. 

 Note the new values (eg 130 130) will be different due to these pockets 

being in the corners of the main section. 
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29 Select File > Save to update the contents of the previously stored Project. 
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3+2 Axis – Stock Model Application 
The Stock Model represents the un-machined material at any point in the 

machining process. An empty Stock Model is created, followed by applying the 

material Block and\or any number toolpaths to be considered in the process. The 

Stock Model is then updated by selecting Calculate, to display the current ‘un-

machined’ material remaining. 

1 Select File - Delete All and Tools - Reset forms. 

2 Import the Model: 

...\PowerMILL_Data\five_axis\AnglePad\StockModelRest.dgk 

3 Save Project As: 

...\COURSEWORK\PowerMILL_Projects\StockModel-3Plus2 

 

The model includes undercut features which for a normal 3-Axis application, 

would require the component to be machined in two separate set ups. However, 

by applying 3+2 with separate workplanes controlling the tool alignments, 

the whole project can be completed in one setup. During an initial 3-Axis 

operation, the undercut pockets will be partially machined which provides an 

application for using Stock Model to enable the user to optimise the 3+2 

machining. 

4 Open the Block dialog and Calculate using Defined by – Box, Type - Model, 

and the Coordinate System set to Global Transform. 

 

5 Accept the dialog. 

 By creating and locking the material Block to the Global Transform 

(world co-ordinate system), the orientation and position will remain 

unchanged if a Workplane is made Active. 
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6 Create a Dia 16 - tip radius 3 tool named D16TR3 

7 Create a Dia 12 - tip radius 1 tool named D12TR1 

8 Activate the tool D16TR3 

9 In the Rapid Move Heights dialog  select Calculate. 

10 Use the default settings for both the Start and End Points . 

11 Select the Strategy Selector  and from 3D Area Clearance select Model 

Area Clearance filling in the options in the pages, exactly as shown below: 

 

 

 

12 In the strategy explorer, select the Lead in option and in the new page select 

1st choice Ramp followed by Ramp options . 
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13 In the Ramp Options dialog, Input Max Zig Angle 4 using a Circle with 0.65 

(TDU). 

 

14 Accept both the Ramp Options and Leads and Links dialogs. 

15 Back in the main dialog, select Calculate to create the toolpath and then 

Close. 

16 Select an Iso1 view. 

17 Activate > Workplane 2 (The Block remains in situ!). 

18 In the PowerMILL explorer, right-click on Stock Models and from the local 

menu, select Create Stock Model to open the following dialog. 

 

19 Input the above values and Accept the dialog. 

20 In the PowerMILL explorer, right-click over the toolpath D16TR3-TopRgh 

and from the local menu select, Add to - Stock Model. 
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21 In the PowerMILL explorer, right-click over the new Stock Model 1 and from 

the local menu, select Calculate. 

22 With the local Stock Model menu still open, select, Drawing Options > 

Shaded and Show Rest Material. 

 

The 3-Axis Roughing operation has removed all accessible material leaving a 0.5 

thickness on the component form. This is clearly visible on the displayed Stock 

Model. 

 

 

23 Activate Workplane 2 to change the set up to a 3+2 orientation. 

24 Activate the tool D12TR1. 

25 From the main toolbar select Rapid Move Heights  and input the correct 

Workplane (2) into the dialog before selecting Calculate, followed by Accept. 
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26 Select the Strategy Selector  and from 3D Area Clearance select Model 

Rest Area Clearance and input settings exactly as shown in the following 

illustration: 

 

27 In the local explorer select the Rest page and input Rest Machining - 

Toolpath - D16t3-TopRgh. 

28 Select Calculate to request the toolpath to be created. 

 

 The strategy fails to calculate and the following PowerMILL Error message 
box appears! 
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 It is not possible to apply Area Clearance - Rest machining using a 

reference toolpath that has been generated relative to a different 

Workplane alignment. 

 It is however possible to use a Stock Model as the reference item for rest 

machining. 

 

29 Select OK to close the PowerMILL Error message and return to the strategy 

(that is still in Recycle  mode). 

Set the option Rest machining as Stock model using 1, and input Detect 

material thicker than 0.6 as shown in the following illustration. 

 

30 In the local strategy explorer, open the Limit page and select Limit tool 

centre to block edge     . 

31 Select Calculate to create the toolpath and then Close. 

 

The modified Rest Roughing toolpath now successfully operates within the 

defined Stock Model volume (as shown above left). 

The material removed by the toolpath, although referenced, is not physically 

included as part of the Stock Model at this stage. 

32 In the PowerMILL explorer, right-click on the Toolpath D12TR1-AngleRgh 

and from the local menu select, Add to - Stock Model. 
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33 In the PowerMILL explorer, right-click over the new Stock Model 1 and from 

the local menu, select Calculate. 

 

The Stock Model now displays the remaining material after both the 3-Axis 

Roughing and 3+2 Roughing operations. 

 Unlike Area Clearance, Finishing strategies cannot be directly rest 

machined to a Stock Model. However it is possible to create and apply 

Stock Model Rest Boundaries where required, providing suitable rest 

limits for subsequent finishing operations. 

 

34 Activate the toolpath D16TR3-TopRgh to reinstate the settings used. 

35 Create a Dia 6 Ball Nosed Tool named BN6. 

36 Un-draw the Stock Model (click the light bulb off). 

37 Select the Surfaces (shown shaded below) required for initial finish machining 

relative to Workplane 1. 
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38 In the PowerMILL explorer, right-click over Boundaries and select Create 

Boundary followed by Selected Surface to open the following dialog. 

 

39 Input data in the Selected Surface Boundary dialog exactly (as shown above) 

with a tick in the box named Top and the Limit option set to Limit tool centre 
to block edge. 

 

40 Select Apply and when processed, Cancel the dialog. 

 

When created, the new Boundary will be Active and by default included as the 

limits (keep inside) in the following finishing strategy. 

41 Select the Strategy Selector  and from the Finishing dialog select the 

Steep and Shallow finishing option. 

42 Enter the name BN6-TopFin along with the remaining values and settings 

exactly as shown below before selecting Apply. 
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43 Set both Lead In and Lead Out to Surface normal arc (Angle 90, Radius 3). 

44 Select Calculate to create the toolpath and then Close the dialog. 

 

All of the features accessible from the top have now been finish machined. This 

finishing strategy will be added to the Stock Model ready for a Stock Model 

Rest Boundary to be created and applied to a 3+2 finishing strategy along 

Workplane 2. 
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45 In the PowerMILL explorer, right-click on the Toolpath BN6-TopFin and 

from the local menu select, Add to - Stock Model. 

46 In the PowerMILL explorer, right-click over the new Stock Model 1 and from 

the local menu, select Calculate. 

47 With the local Stock Model menu still open, select Show Rest Material, 

followed by Drawing Options - Shaded, and finally Calculate. 

48 Select an ISO 1. 

49 Activate Workplane 2. 

50 From the main toolbar select Rapid Move Heights and input the correct 

workplane (2) in the dialog before selecting Calculate. 

 

51 In the PowerMILL explorer, right-click Boundaries and select Create 

Boundary followed by Stock Model Rest to open the following dialog. 

 

52 Input data in the Stock Model Rest Boundary dialog exactly as shown above. 
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53 Apply and when processed, Cancel. 

54 Select and Delete the narrow segment at the base of the lower vertical wall. 

55 Ensure that new Boundary 2 is Active. 

56 Select the Strategy Selector  and from the Finishing dialog, select the 

Steep and Shallow finishing option. 

57 Enter the name BN6-AngFin along with the remaining values and settings 

exactly as shown below. 

 

58 Select Calculate to create the toolpath and then Close the dialog. 
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The resultant toolpath will be added to the Stock Model mainly to confirm 

whether machining is now complete. 

59 In the PowerMILL explorer, right-click on the Toolpath BN6-AngleFin and 

from the local menu select, Add to - Stock Model. 

60 In the PowerMILL explorer, right-click over the new Stock Model 1 and from 

the local menu, select Calculate. 

 

There are now 2 areas remaining as part of the Stock Model. As both include 

sharp internal corners they will need to be finished off using an End Mill. 

61 Create a Dia 12 End Mill named EM12. 

62 In the PowerMILL explorer, right-click over Boundaries and select Create 

Boundary followed by Stock Model Rest to open the following dialog. 
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63 Input data in the Stock Model Rest Boundary dialog exactly as shown above. 

64 Apply and when processed, Cancel the dialog. 

 

 A new Stock Model Rest Boundary has appeared where the remaining 

material is accessible to the EM12 tool. 

 This area is not accessible to the EM12 tool, and as a result Boundary 

segments will not be created. 

 

65 Ensure that the new Boundary (3) is Active. 

66 Select Toolpath Strategies  and from the Finishing dialog, select the 

Constant Z option. 

67 Enter the name EM12-AngleFin along with the remaining values and settings 

exactly as shown on the following page before selecting Apply. 
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68 Select Calculate to create the toolpath and then Close the dialoq. 

 

The angled pocket is now fully machined and the latest toolpath will now be added 

to the Stock Model. 

 

69 In the PowerMILL explorer, right-click on the Toolpath EM12-AngleFin and 

from the local menu select, Add to - Stock Model. 

70 In the PowerMILL explorer, right-click over the new Stock Model 1 and from 

the local menu, select Calculate.  

71 Activate the toolpath D16TR3-TopRgh to reinstate the settings used. 

72 De-activate the toolpath D16TR3-TopRgh and activate the EM12 tool. 
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73 Create a Swarf Finishing strategy named EM12-TopFin on the selected, 

vertical surface (shown shaded above). 

 

 

74 Set both Lead In and Lead Out to Vertical arc with Distance 6, Angle 90, 

and Radius 4. 

75 Add the new toolpath EM12-TopFin to the Stock Model and Calculate to 

visually confirm that all excess material has now been removed. 
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 The Stock Model is only visible when the Show Rest Material option is un-

ticked. 

76 Select File > Save to update the contents of the previously stored Project. 
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3+2 Axis - Drilling Example  
The PowerMILL - Drilling options operate on Hole Features and not directly on 

the Model. This enables drilling to take place without the need to modify or trim 

back the existing surface data. When the Multi-Axis option is ticked the Hole 

Features at different alignments will be created to a common workplane. 

1 Select File - Delete All and Tools - Reset Forms. 

2 Import the Model:  

...\PowerMILL_Data\five_axis\drill_5axis\drill5ax_ex1.dgk 

 

3 Select File - Save Project As: 

...\COURSEWORK\PowerMILL-Projects\MultiAxisDrill-ex1 

 

The first stage is to create a Feature Set into which all cylindrical surfaces in the 

selected model are inserted as Hole features. 

Any cylindrical surfaces within the selection will automatically be recognised as a 

Hole Feature. It is important that no Block exists to ensure that the Hole 

Features are arranged with the top at the maximum Z height.  

 The existence of a Block will affect the orientation of individual Hole 

Features in that they are more likely to be created to an unsuitable 

alignment. 

 

4 Use the left mouse to select all of the surfaces. 

5 In the PowerMILL explorer, right mouse click on Feature Sets, and from the 

local menu select Create Holes. 

6 Enter data into the Feature form exactly as shown. 
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The Group holes by axis option must be un-ticked for a Multi Axis Hole > 

Feature Set to be created (All of the Hole Features including those at different 

orientations will be input into a single Feature Set). 

7 Apply and Close the dialog. 

 All cylindrical surfaces within the selection will automatically be recognised 

as Multiaxis Hole Features. 

8 Undraw the model to view the newly created Features. 

 

All 17 Holes in the Feature Set are correctly aligned, with the cross at the base 

representing the bottom of the hole. 

 

9 Create a material Block using Defined by - Box and Type - Model. 

10 In the Rapid Move Heights  dialog, select Calculate. 

11 Create a Dia 3 Drill named Drill3 of Length 40. 

12 Add a Shank component Upper\Lower Dia 3 Length 40. 

13 Add a Holder component Upper Dia 30 Lower Dia 30 Length 30 Overhang 60. 

14 Select Toolpath Strategies  and in the Strategy Selector dialog, select 

Drilling.  

15 In the Drilling dialog, select the option Drilling. 

16 Rename the toolpath CentreDrill-Dia3. 
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17 Back in the main Drilling page select Calculate to create the Centre Drilling 

toolpath, and then Cancel the dialog. 

18 Simulate the toolpath. 
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The Multiaxis option has created all of the Hole Features aligned at different 

elevations in a single Feature Set.  

The two Dia 6 Hole Features are to be drilled to depth with a Dia 5 Drill and then 

Tapped. To allow for the inevitable point angle at the bottom of the blind holes the 

Tapping operation needs to stop short of the full depth by applying a suitable Axial 

Thickness value. 

 

19 Create a Dia 5 Drill named DRILL5 of Length 60  

20 Add a Shank, Upper Dia 5, Lower Dia 5, Length 30. 

21 Add a Holder, Upper Dia 30, Lower Dia 30, Length 30, Overhang 50. 

22 Select Toolpath Strategies  and in the Strategy Selector dialog select 

Drilling.  

23 In the Drilling dialog select the option Break Chip. 

24 Rename the toolpath as Drill5. 

 

 

25 Select the two Dia 6 Hole Features (shown coloured orange below). 
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26 Close the Feature Selection dialog. 

27 Select Calculate to create the Drilling toolpath, then Cancel the dialog. 

28 Simulate the toolpath. 

 

The two Dia 6 Holes have now been drilled to full depth using a Dia 5 Drill. 

They will now be Tapped to a depth of 5 (Axial thickness) from the base of 

each Dia 6 Hole using a Dia 6 Tap with a 1mm Pitch. 

 

29 Create a Dia 6 Tap (Named M6Coarse-TAP) with Pitch 1 and Length 25. 

30 Add a Shank, Upper Dia 4, Lower Dia 4, Length 30. 

31 Add a Holder, Upper Dia 30, Lower Dia 30, Length 30, Overhang 50 

32 Select Toolpath Strategies  and in the Strategy Selector dialog select 

Drilling. 

33 In the Drilling dialog select the option Tap. 

34 Rename the toolpath as M6-Tap. 
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35 Select the two Dia 6 Hole Features. 

36 In the Drilling dialog select the option Tapping. 

37 Rename the toolpath as M6-Tap. 

38 Set Cycle Type - Tapping, Operation - Drill to hole Depth, and Pitch 1. 

39 Input an Axial Thickness value of 5. 

40 Select the two Dia 6 Hole Features. 

41 Select Calculate to create the toolpath and then Close the dialog. 

42 Select a View from front (-Y). 

 

The selected holes have been Tapped to a distance of 5mm short of the full 

depth. 

 

43 From the main pulldown menus, select File > Save to update the contents of 

the previously stored Project. 
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Positional Tool Moves – Essential Information 

When performing multi-axis, Positional Tool Moves, it is the user’s responsibility 

to pay careful attention and take appropriate action to prevent collisions.  

� All individual toolpaths should be created such that the Start and End Points 

are clear of any undercut features in the CAD model. 

� PowerMILL does not gouge check positional moves before and after an 

individual toolpath. These Pale Blue dashed connection moves are only visible 

if the NCProgram is drawn (as shown below). 

 

� Neither, PowerMILL, or a Postprocessor will be aware of any obstructions 

within the confines of a machine tool. 

� The Positional moves displayed in a PowerMILL toolpath simulation will not 

necessarily match all moves performed by the actual machine tool.  

� For a more accurate simulation a Machine Tool Model along with an associated 

mtd file can be created. It must be stressed that a machine tool simulation is 

essentially a visual animation and not an ncprogram, verification.  

 

Three suggested methods in PowerMILL to create Positional Tool Moves include: 

a Use of Absolute coordinates in the toolpath Start and End Point dialog. 

b The insertion of a Drive Curve - Pattern Finishing strategy suitably 

positioned in 3D space. 

c The insertion of strategically placed Workplanes into an NC Program. 

2. Positional Tool Moves 
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Postprocessor option file – Safe Z Positional Moves 

There are two different ways that a specific Postprocessor Option file can be 

created to deal with positional moves (Method 1 is the default). 

a Method 1 – The Postprocessor Option file automatically outputs moves 

from/to the Machine Tool, maximum Z height (Home) at the start and 

end of each Toolpath. Note! In this case any Workplanes inserted into the 

NC Program (Item c on the previous page) are completely ignored. 

The name for a typical Postprocessor Option file using Method 1 includes ZMAX 

at the end of the name:-      DMG_DMU10p_H530_ZMAX.pmopt  

 

b Method 2 – The Postprocessor Option file does not automatically output 

Machine Tool Safe Z moves. All additional, safe positional, moves must be 

added by the user in PowerMILL (In this case a network of workplanes 

can be used as shown in the illustration below). 

The name for a typical Postprocessor Option file using Method 2 will not include 

ZMAX at the end of the name:-      DMG_DMU10p_H530.pmopt  

 

Tool Move with Start and End Point 

Positional Tool Moves can be controlled in the Start and End Point dialog  

by use of Absolute (along with specific XYZ coordinates). 

 

Start and End Points input as Absolute coordinates, above the component where 

it is safe to re-align the tool and/or perform rapid XY moves.  
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Tool Moves using a Pattern Finishing in 3D Space 

Positional Tool Moves can be controlled by running the tool along a Pattern 

Finishing strategy used as a Drive Curve in 3D space.  

  A lean angle can be applied to maintain an angular tool alignment during 

transit. 

 

 

 

Tool Move via Workplanes in an NC Program 

Positional Tool Moves can be controlled by strategically placed Workplanes 

inserted between the Toolpaths in the NC Program list. A Workplane in the 

ncprogram list can also be registered as a Toolchange Point if required. 

 This method is only applicable to non-ZMAX post-processor 

applications. 

 

While a tool moves to a Workplane, it will simultaneously re-align to align to the 

Workplane - Z Axis (Simultaneous is the NC Preferences - default setting). 

The following 4 illustrations show the tool movements to 3 workplanes including a 

rotational move prior to performing the machining strategy. 
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Example 

An existing Project will be opened that contains 4 separate 3 Plus 2, finishing 

toolpaths ready to be added to an NC Program. Once included in the NC Program, 

appropriate positional moves must be added to prevent the tool from passing 
through the component form while moving between toolpaths. 

 

1 Select File - Open Project:- 

....\PowerMILL_Data\FiveAxis\PositionalMoves\AngledPockets-Start 

 

2 Select File - Save Project As:-  

….\COURSEWORK\PowerMILL_Projects\AngledPockets 
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Connection moves using a Safe Z calculated to a 3-Axis 
Workplane 

 

 

3 In the PowerMILL explorer, right-click on NC Programs and from the local 

menu, select Preferences. 

 

4 Select a suitable Five Axis, Post-Processor Option File: 

C:\dcam\config\xtra-posts\MS-GV503-1.opt 

5 Select Close (The NC Preferences settings will be updated). 

6 Create a new NC Program (It will be Active on creation). 

7 Select the four 3plus2 Toolpaths (D10t1-pkt….) then right-click over them 

and in the local menu select Add to > NC Progam. 
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8 Select an ISO 4 view. 

9 Run a ViewMILL simulation on the first two, 3 Axis toolpaths; d40t6-rgh1, 

BN16-sem1, followed by the NC Program containing the four 3plus2 toolpaths. 

 On closer inspection it will be observed that the 3plus2 - Positional Tool 
Moves have ploughed through the component between the individual 

machining strategies. 

 

 If the Model is displayed as wireframe then the displayed NC Program 

will also include the link moves (Pale Blue dashed lines) between the 4 

stored Toolpaths.  
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10 Activate the workplane MainDatum-top. 

11 Calculate a Block using Defined by Box to the Model dimensions. 

12 Open the Rapid Move Heights dialog. 

 

 

13 Input Workplane MainDatum-top and Calculate before selecting Accept. 

14 In the PowerMILL explorer use the Shift key to multi-select the four, 3+2 

toolpaths.  

 

 

15 Right mouse click anywhere on the four selected toolpaths, and from the local 

menu select Edit – Set Rapid Moves. 
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The Tool will now perform rapid moves above the top of the model, relative to 

workplane MainDatum-top. 

 

 

16 Run a ViewMILL simulation on the first two, 3 Axis toolpaths; D40t6-rgh1, 

Bn16-sem1, followed by the NC Program containing the four 3plus2 toolpaths. 

 

The toolpath connection moves no longer collide with the model. 
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Connection moves using (Drive Curve) Pattern toolpaths 

 

17 From the Strategy Selector  - Finishing select the Pattern finishing 

strategy and enter data exactly as shown below. 

 

 

18 Select the Tool Axis page, and input a Tool axis Lead/Lean with Mode 

Vertical selected and a Lean value of 60. 

 

 

 

 

 



2. Positional Tool Moves  PowerMILL 2016 

2 - 10  Copyright © Delcam Ltd  

19 Select the Start point page, and Use First point with Approach distance 0. 

 

20 Select the End point page and Use Last Point with Approach distance 0.  

21 In Leads and links set both Lead in and Lead out to None. 

22 Calculate the Pattern finishing toolpath. 

 

The Tool ‘winds’ along the Pattern Finishing strategy creating a collision safe, 

transition around the component. 

 

23 Insert the Pattern Finishing strategy (ToolMove-Pkt1-Pkt2) between the 

toolpaths, D10t1-pkt1 and D10t1-pkt2. 
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Exercise 
24 Create 2 more suitably positioned, tool move Pattern Finishing toolpaths 

named ToolMove_Pkt2-Pkt3 and ToolMove_Pkt3-Pkt4. 

 

 Check the direction of each new Pattern Strategy and if necessary, reverse. 

 

25 Insert the new Pattern Finishing toolpaths into the NC Program. 

 

 

Tool Axis ‘Rewind’ Move 

 

 A useful application for using a Pattern as a Positional Tool Move is in cases 

where a rotary axis limit has been reached. A circular, Pattern Finishing 

strategy can be use to ‘Rewind’ the tool in 3D space, back to the start of its 

rotary travel limits. 
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Introduction 
For 5-Axis applications where the machine tool head and\or table, are required to 

perform both linear and rotational axis moves simultaneously, PowerMILL 

provides a range of appropriate Tool Axis Alignments and Machining Strategies. 

Five Axis Tool Alignment and Machining 
Options 

By default the Tool Axis alignment in PowerMILL is set to Vertical for 3-Axis 

applications and other options will only be available to users with a multiaxis 

licence. 

 Some strategies only support multiaxis Tool Axis alignments when 

operating with Ballnose or Spherical tools. 

The Tool Axis Direction dialog is accessed via the Tool Axis icon  located in 

the Main toolbar or directly from supported Machining Strategy forms.  

The dialog provides a list of basic Tool Axis alignment options which are further 

controlled by a Strategy dependent selection of Mode options.  

 

 

3. Five Axis Tool 
Alignment 
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Tool Axis alignment - Mode options 

 

a Contact Normal - This measures a Lead angle relative to the toolpath 

contact normal. 

b Vertical - This measures a Lead angle relative to the Z Axis. 

c PowerMILL 2012 R2 - Reverts back to this version that did not offer a 

choice of Mode options (The actual Mode options used is strategy specific). 

d Preview frame normal - This measures a Lead angle relative to the 

projection direction to or from the normal to the Projection Strategy, 

Preview pattern. 

e Reference tool axis – This measures the Lead angle form the tool axis 

used in a reference toolpath used as the Drive curve in a Pattern Finishing 

strategy.  

f Tangent Normal - This measures the Lead angle relative to the 
perpendicular to the tangent direction of a Pattern used as the Drive curve 

in a Pattern Finishing strategy. 

g Undercut angle – This measures the Lead angle from the projection 

direction corresponding to the specified undercut angle in a Parametric 

Spiral strategy. 

h Toolpath - For a basic Tool Axis of From or Towards the actual alignment 

is relative to the model surface instead of the Preview pattern. 

i Preview frame - For a basic Tool Axis of From or Towards the actual 

alignment is relative to the Projection Strategy, Preview pattern. 

Lead/Lean - Example1 
Lead allows the tool to be aligned to a specified angle along the toolpath 

direction and Lean a specified angle across the toolpath direction. If both 

angles are zero the tool will be aligned along the direction that a toolpath is 

projected onto the model during creation. For Pattern finishing this will always be 

vertical and for Projection Finishing it will vary depending on the defined strategy 

projection options.  

 

 

 

 

1 From the main pull down menus select File - Delete all and Tools - Reset 

forms. 
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2 Open the (Read Only) Project:- 

      ….\Five_Axis\ToolAlignments\PlaneAlignments_Start 

 

3 Save Project As:- 

      ….\COURSEWORK\PowerMILL_Projects\PlaneAlignments_Demo 

 

4 Simulate the Toolpath BN5-Vertical. 

 

The above Raster toolpath is machined with the tool aligned to the vertical 

axis. 

 

5 Right-click the Toolpath - Raster Vertical in the PowerMILL explorer and 

select Settings to open the original Raster Finishing dialog. 

6 Make a Copy  of the Toolpath and rename it as BN5-Lead30. 

7 Select the Tool axis page, with the Tool axis as Lead\Lean, with Lead -30, 

and use Mode Vertical. 

 

8 Calculate the Toolpath and then Close the dialog. 

9 Simulate the Toolpath (BN5-Lead30). 
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A Raster toolpath has been created with the Tool axis direction set to Lead at 

-30 degrees relative to the vertical axis (Z). 

 With the Two Way option, the Tool Axis direction will switch on 
opposing passes. This is due to the Lead angle being dependant on the 

tool track direction. 

10 In the PowerMILL explorer, right-click on the toolpath BN5-Lead30 and select 

Settings to open the Raster Finishing dialog. 

11 Select Re-cycle  and change Style to One Way. 

12 Calculate the Toolpath and then Close the dialog. 

 

 With the Style set to One Way the Tool Axis direction remains fixed. 

 

13 Right-click the toolpath BN5-Lead30 in the PowerMILL explorer and then 

select Settings to open the toolpath dialog. 

14  Select Make a Copy  of the Toolpath and rename it as BN5-Lean45. 

15 Select the Tool Axis icon  to open the Tool Axis Direction dialog. 

16 In the Tool Axis page, change the Lead angle to 0, and input Lean 45. 
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17 Calculate the Toolpath and then select Cancel to close the dialog. 

18 Simulate the Toolpath. 

 

A Raster toolpath has been created with the Tool Axis Direction set to Lean 

45 degrees across the toolpath. 

 

 

If a Two Way had been directly applied in the strategy dialog, the tool axis 

would lean in the opposite direction across alternate tool tracks. 

 

It is possible to create a Two Way strategy with a constant Lean direction by 

retrospectively editing a one way - Toolpath. 

 

 

19 Right-click on the (One Way) Toolpath BN5-Lean45 and from the local 

menu, select Edit > Reorder to open the Reorder Toolpath Segments dialog. 

20 Select the Alternate directions option  (All tool tracks will be edited). 
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21 Select OK to close the above PowerMILL Warning dialog. 

 

 

 

22 Save Project to update:- 

      ….\COURSEWORK\PowerMILL_Projects\PlaneAlignments_Demo 
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Lead/Lean - Example2 

1 Select File - Delete all and Tools - Reset Forms. 

2 Open the Project (saved earlier during Chapter 1) from: 

                      ....\COURSEWORK\PowerMILL-Projects\3Plus2-EX1 

 

 

3 Define a Dia 15mm Ball Nose cutter named BN15. 

4 Activate the Workplane - ztop175_A. 

5 Create a material Block defined by Box to the Max\Min Limits of the Model 

and then edit the following values as shown below:  

Xmin -70  Xmax-52.5  Ymin -50  Ymax 50 

 

6 Open the Rapid Move Heights dialog and select Calculate, then Accept. 

7 In the Start and End Point dialog in Start Point set First Point Safe and in 

End Point set Last Point Safe. 

8 Set Leads\Links  as follows: 

Z heights: Skim 15, Plunge 5 

Lead In\Out: Vertical Arc: Angle 90, Radius 6 

Links: Short\Long Skim and Default Incremental 

 

9 Ensure that no Boundary is Active. 

 

An area of the component will be machined using Raster Finishing. The Tool Axis 

will be aligned to a fixed Lean angle of 40 degrees relative to the Vertical axis. 
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10 Select the Toolpath Strategies icon  and in the Strategy Selector dialog, 

select the Finishing tab. 

11 Select the Raster Finishing dialog and enter data exactly as shown below: 

 

 

12 Select the Tool axis page and enter data into the dialog exactly as shown in the 

following illustration. 
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13 From Leads and links select the Links dialog and enter data exactly as shown 

in the following illustration. 

 

14 Calculate the Toolpath and then Cancel to close the dialog. 

 

The resultant toolpath starts at the lower corner and progresses towards the 

centre using a climb milling action (One Way). If it is required for the strategy 

to be Two Way then it can only be retrospectively changed using Edit > 

Reorder > Alternate Direction. 

 

To compare the effect of applying a different machining strategy, the same area of 

the component will be machined using Projection Plane Finishing. This time the 

Tool Axis will be aligned using a Lean of 0 degrees relative to the projection 

direction of the strategy. 

 

15 Calculate a Block, Defined by - Cylinder using Type - Model, to the 

Coordinate System - Named Workplane - ztop175_A. 

16 Select the Toolpath Strategies icon  and in the Strategy Selector dialog 

select the Finishing tab. 

17 In the Finishing options select Projection Plane Finishing. 
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18 Enter data into the following 3 pages of the Plane Projection Finishing dialog, 

exactly as shown below: 

 

� Set Azimuth to 270 

� Set Elevation to 50 

 

 

19 Set Pattern direction to U 
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20 Calculate the toolpath and then Close the dialog. 

21 Simulate the toolpath and observe the associated tool alignment. 

 

 The resultant toolpath starts at the lower corner and progresses towards the 

centre with a Lead in and Lean out both set to 0 creating tool alignment 

relative to the projection direction. Due to Lead and Lean being 0 a directly 

calculated Two way strategy is a feasible option. 

 

22 Select a view along the Y Axis and then Simulate both toolpaths in turn to 

visually, compare both strategies.  

 The tool alignment is the same for both toolpaths due to a suitable Lean 

value of 40 being applied to the Raster strategy. 

 

23 Select File - Save Project. 
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Lead/Lean - Example 3 

1 Select File - Delete all and Tools - Reset forms. 

2 Import the model: 

...\PowerMILL_Data\five_axis\joint_5axismc\joint5axis.dgk 

 

3 Save the Project As:- 

      ...\COURSEWORK\PowerMILL_Projects\Joint-EX1 

 

4 Create the material Block using Defined by - Box to the Model dimensions and 

then expand it by 15 in X and Y only. 

5 Create a Dia 25 Ball Nosed cutter (BN25). 

6 Select Calculate in the Rapid Move Heights dialog. 

7 Use the Start and End Point default settings. 

 

8 Modify the settings in Leads and Links  as follows: 

� For Z heights use Skim 45 and Plunge 10 

� For Links set both Short and Long - Links to Skim. 
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9 Select the Toolpath Strategies icon  and in the New Strategies dialog, 

select the Finishing tab. 

10 Select Projection Line Finishing and enter data exactly as shown in the 

following 3 pages of the dialog. 

 

� Set Azimuth to 0 

� Set Elevation to 0 
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11 Calculate the Toolpath and then Cancel to close the dialog. 

 

 The next section continues with the machining of the upper part of this 

component. 

12 Save the Project (but do not close it down). 
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Toward \ From Point 
These options allow the Tool Axis alignment to be based on a user-defined point 

during the generation of toolpaths (In this case Towards Point). If Mode - 

Preview frame normal is used then the actual alignment is taken relative to the 

Preview pattern for the strategy and not the final toolpath.  

 

 

 

13 Set Leads/Links  as follows: 

� Z heights:           Skim 45  Plunge 10  

� Lead In/Out:     Surface normal arc, Angle 90  Radius 6  

� Extensions: Inwards/Outwards, Extended Move, Distance 30 

Links:  Skim 

�  

14 Select the Toolpath Strategies icon  and select the Finishing tab located in 

the new Strategy Selector dialog. 

15 Select the Projection Point Finishing option. 

16 In the Point Projection Finishing dialog main page, enter data exactly as 

shown in the following illustration. 
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17 Select the Pattern page and enter data into the dialog exactly as shown in the 

following illustration. 

 

18 Input Elevation Angle data as:-   Start 90 and  End 0 



PowerMILL 2016  3. Five Axis Tool Alignment 

Copyright © Delcam Ltd  3 - 17 

19 Select the Tool Axis page and enter data into the dialog exactly as shown in the 

following illustration. 

 

20 Calculate the Toolpath but do not close the dialog. 

 

 

 The Tool Alignment point is approximately 20mm below the Projection 

Finishing focal point to ensure that the spindle axis remains at an elevation 

angle to the machine tool table during machining hence avoiding collision. 

 

Mode – Preview Plane:- The actual Tool alignment occurs on the Projection 

Point Finishing - Preview pattern, after which the tool is then projected on to 

the model (towards the strategy - focal point). 
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21 In the Point Projection dialog select Re-cycle  and then open the Tool 

Axis page. 

22 Change the Tool axis Mode to Toolpath. 

 

23 Calculate the Toolpath and then Cancel to close the dialog. 

 

 

Mode – Toolpath:- The Tool alignment is applied directly on to the finished 

toolpath (towards the strategy focal point). 

 

24 Select File - Save Project. 
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Toward\From Line 
These options allow tool axis alignment to be towards or from a user-defined 

line, specified by a Vector direction through a suitably positioned XYZ coordinate.  

 

1 Select File - Delete all and Tools - Reset forms. 

2 Import the Model:- 

...\PowerMILL_Data\five_axis\Casing\from-line-model.dgk 

 

3 Save the Project As: 

...\COURSEWORK\PowerMILL_Projects\CameraCasing 

 

4 Create a Dia 12 Ball Nose cutter named BN12 of Length 55 with:- 

� Shank of Dia 12 - Length 40. 

� 1st Holder - Lower Dia 25 - Upper Dia 40 - Length 40.  

� 2nd Holder - Upper/Lower Dia 40 - Length 60 - Overhang 90. 

 

5 Define the Block (use Box) to the Model limits. 

6 Select Calculate in the Rapid Move Heights dialog. 

7 Set Leads\Links  as follows: 

� Z heights:  Skim 5, Plunge 5 

� Lead In/Out:     1st Choice – Surface normal arc, Angle 45, Radius 5.0   

� Links:  Threshold 3, Short – Circular Arc, and Long – Skim. 

 



3. Five Axis Tool Alignment PowerMILL 2016  

3 - 20  Copyright © Delcam Ltd 

8 Select the Toolpath Strategies icon  and in the new Strategy Selector 

dialog, select the Finishing tab. 

9 Select the Projection Line Finishing option. 

10  In the Line Projection Finishing, Pattern, and Tool Axis pages enter data 

exactly as shown in the following illustrations. 

 

� Set Style to Circular 

� Input Location as 0 0 75 

� Set Azimuth to 0 

� Set Elevation to 90 

� Set Direction Outwards 

� Use Tolerance 0.01 

� Use Stepover 1 
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11 Back in the main Line projection page, select Component Thickness . 

12 Select any one of the 8 rows in the Component Thickness dialog.  
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13 Select all of the edge surfaces on the Model and acquire   them to the 

selected row in the Component Thickness dialog. 

14 Set the Machining Mode to Collision. 

15 Apply and Accept the Component Thickness dialog. 

16 Back in the Line Projection dialog select the Tool Axis page and enter data 

exactly as shown below. 

 

 

17 Tick the Draw Tool Axis box  to display the red, Tool Alignment 

line relative to the Model (as shown in the following image). 
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18 Click the Preview tab to view the strategy before selecting Calculate to create 

the Toolpath.  

19 Close the Line Projection Finishing dialog. 

The end result (with a larger stepover) is as shown in the following illustration: 

 

The use of Tool Axis – From line with Mode – Preview frame has ensured 

that the whole of the internal form, including the undercut areas, is fully 

accessible. Note that in this case it gives a better result than if Mode – 

Toolpath had been used. 

20 Save the Project. 
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Toward\From Curve 
These options allow the tool axis alignment to be through a user-defined curve 

(Pattern).  

The following example will use the Surface Finishing strategy. This is possible due 

to each of the two different blade areas to be machined being smooth, single 

surfaces with the edges aligned to the surface curves (The resultant tool tracks 

will be aligned to these curves).  

1 Select File - Delete all and Tools - Reset forms. 

2 Import the Model: 

                       ....\PowerMILL_Data\five_axis\Impeller\ impeller+Curve.dgk 

3 Save the Project as: 

....\COURSEWORK\PowerMILL_Projects\ Impeller+Curve-EX1 

4 Create an empty Pattern and rename it as Align2Curve. 

5 In the graphics area, select the wireframe, alignment curve that has been 

imported with the Model (Ensure that both the Plain Shade and Wireframe 

views are switched on!).  

6 Right mouse click on the Pattern (Align2Curve) and from the local menu, select 

Insert > Model to copy the selected alignment curve as a Pattern segment.  

 

7 Create a Dia 3 Ball Nosed cutter (named BN3-LR) of Length 35 with the 

following Shank and Holder dimensions: 

� Shank - Upper\Lower Dia 3 - Length 25 

� Holder 1 - Upper Dia 15 - Lower Dia 10 - Length 50 

� Holder 2 - Upper\Lower Dia 15 - Length 35 

� Overhang 50 

 

8 Create a Block defined by Cylinder to the Model dimensions. 

9 Set Links as Short/Long to Skim and Default to Incremental. 

10 In the Rapid Move Heights dialog select Calculate. 
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11 Select the underside face of the blade (nearest to the Pattern) to be used in the 

1st Surface Finishing strategy. 

 

 

12 Select the Toolpath Strategies icon  and in the Strategy Selector dialog 

select the Finishing tab. 

13 Select Surface Finishing and fill in the pages of the dialog exactly as shown in 

the following illustration. 

 

� Surface side - Outside 
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� Pattern direction - V 

� Ordering - One way 

� Start corner - Max U min V 

 

 

 

14 For both Lead in and Lead out use the following for 1st and 2nd choice. 

 

 

15 Click the Preview tab and view the strategy before selecting Calculate to create 

the Toolpath.  

16 Close the Surface Finishing dialog. 
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The Tool Axis is always aligned through the specified Pattern (Curve) while 

performing the Surface Finishing strategy. 

 

17 Right-click on the existing Surface Finishing strategy and from the local menu, 

select Settings to re-open the dialog. 

18 In the dialog, select Make a copy of the Toolpath . 

19 Select the upper side, blade surface (nearest to the Pattern) to be used as the 

Reference Surface in the 2nd Surface Finishing strategy. 

 

 

 

20 Open the Surface Finishing and Tool Axis dialogs, entering the data exactly as 

shown on the next page and select Calculate. 
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� Pattern direction - V 

� Start corner - Min U max V 

 

21 Click the Preview tab to view the strategy before selecting Calculate to create 

the Toolpath. 

22 Close the Surface Finishing dialog. 
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The Tool Axis is always aligned through the specified Pattern (Tool Alignment 

Curve) while performing the chosen machining strategy (Surface Finishing). 

 

A small area on the latest toolpath is fragmenting along the top edge as arrowed 

above. This is caused by one of the other blades getting in the way of the 

projection process at this point. In this instance an easy fix can be applied by 

using a copy of the existing Pattern and moving it upwards by 1.5. 

 

23 Create a copy of Pattern Align2Curve which will automatically be named as 

Align2Curve-1.  

24 Move the new Pattern upwards by 1.5mm. 

25 Recycle the toolpath BN3-UprBlade-FIN with the Tool axis – from curve 

options using Pattern Align2Curve-1. 
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The toolpath fragmentation on the upper edge has now been fixed. 

 

26 Activate and Verify each toolpath in turn, checking both the Gouge and 

Collision status (Use a Shank Clearance of 1 and a Holder Clearance of 2). 

 

 

 If all is safe the Verify process will result in a Blue tick box adjacent to 

each toolpath in the PowerMILL explorer. 

 

27 Save the Project. 
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Fixed Direction 
This allows the Tool Axis to be set to a fixed angle, specified as a user defined, 

Vector. In this case it is applied to the finishing of an angled recess on the supplied 

Model. 

Angle to Vector conversion table 
Fixed Direction Tool Alignment – Vectors\Angular equivalents 

The table represents angular directions and vectors on the XY plane (Z=0). 

ANGLE    VECTORS 

(Degrees)  (I      J        K) 

0   1 0.0000  0 

5   1 0.0875  0 

10   1 0.1760  0 

15   1 0.2680  0 

20   1 0.3640  0 

25   1 0.4660  0 

30   1 0.5770  0 

35   1 0.7000  0 

40   1 0.8390  0 

45   1 1.0000  0 

50   1 1.1920  0 

55   1 1.4280  0 

60   1 1.7320  0 

65   1 2.1450  0 

70   1 2.7470  0 

75   1 3.7320  0 

80   1 5.6710  0 

85   1 11.4300 0 

90   0 1.0000  0 
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The Tool Alignment is set to a Fixed Direction relative to the currently active 

Workplane by inputting suitable values as an I J K vector along the Tool Axis 
(towards the spindle). Although the correct values for a vector may require the 

user to exercise their trigonometry skills, this method does provide full flexibility for 

defining compound angles. 

1 From the main pull down menus, select File - Delete All and Tools - Reset 

Forms. 

2 Open the (read only) Project: 

...\PowerMILL_Data\five_axis\AngledFrame\ToolAxisFixed1-Start 

 

3 Save the Project As: 

...\COURSEWORK\PowerMILL_Projects\ToolAxisFixed-EX1 

4 Activate and then de-activate the Toolpath D12t1-ruf-TOP. 

5 This will restore the settings (Workplane, Rapid Move Heights, etc) ready to 

apply a finishing strategy on the corrugated angled form. 

6 Activate the BN6 tool. 

7 Select the undulating Surface on the base of the angled recess. 
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8 Select the Toolpath Strategies icon  and in the Strategy Selector dialog 

select the Finishing tab. 

9 Select the Surface Finishing option and fill in the pages of the dialog exactly as 

shown in the following illustrations. 

 

� Surface Side - Outside 

� Stepover - 0.5 

 

� Pattern direction - V 

� Ordering - Two way 
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10 Set the Tool Axis to Fixed direction. 

11 Input the vector Direction values:  I 0   J -1  K 0.577 

 

12 Tick the Draw tool axis box.  

 
13 From Leads and links select the Links dialog and enter data exactly as shown 

in the following illustration. 
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14 Click the Preview tab to view the strategy before selecting Calculate to create 

the Toolpath. 

15 Close the Surface Finishing dialog. 

 

 For viewing purposes, the toolpath shown in the illustration has been created 

using a 2mm Stepover. 

 

16 From the main pulldown menu, select File - Save to update the stored Project: 

...\COURSEWORK\PowerMILL_Projects\ToolAxisFixed-EX1 
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Introduction 
In a Projection Surface Finishing the strategy is projected Inwards or 

Outwards along the normals of a single Reference Surface. For five axis 

applications an appropriate tool alignment is used. The toolpath runs either across 

or along the natural Reference Surface directions (U or V) with the Stepover 

being defined by unit Distance or Parametric division between Surface Curves. 

In some cases the Reference Surface may form part or all, of the component to 
be machined. 

To create a Reference Surface the user will require the services of a suitable 

Surface Modeller, ideally PowerSHAPE. For the following example the Reference 

Surface has already been created and stored as a separate dgk file to be imported 

as required. A reference surface should be as smooth and simple as possible. It 

should also be as close as possible to the actual surfaces that are to be machined.  

1 Open the (Read Only) Project:- 

...\PowerMILL_Data\five_axis\CornerFixing\ProjectionSurfaceEX1-Start 

 

2 Save the Project as: 

...\COURSEWORK\PowerMILL_Projects\ProjectionSurface-Example1 

3 Activate the toolpath D25TR3-RGH1 to reinstate the settings. 

4. Projection Surface 
Finishing 
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 The Block used in the toolpath D25TR3-RGH1 is defined from an imported 

Triangle model (dmt file) of a Casting. 

 

4 Run a ViewMILL simulation on the toolpath D25TR3-RGH1. 

 

5 Save the ViewMILL model at this stage.  

6 Return to the PowerMILL window  and temporarily suspend 

ViewMILL.  

7 Calculate a new Block - Defined by - Box using Type – Model. 

8 Import the Model:- 

       …..\PowerMILL_Data\five_axis\CornerFixing\CornerFixingRefSurf1.dgk 
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9 In the PowerMILL explorer, Activate the BN16 tool. 

10 In the PowerMILL explorer right mouse click on the model named 
CornerFixingRefSurf1 and from the local menu select Select All. 

 

The newly imported (reference) surface (shown shaded above) is fully located 

inside the original component model. 

11 From the main toolbar select the Toolpath Strategies . 

12 From the dialog select the Finishing tab followed by the Projection 

Surface Finishing option. 

13 Enter the values into the main page of the Surface Projection Finishing 

exactly as shown below. 
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14 Enter the values into the Pattern page of the Surface Projection 

Finishing exactly as shown below. 

 

� Pattern direction – U 

� Start corner – Min U max V 

� Limits (Distance) –  V (ticked):-  Start 0   End 95 

 

15 Enter the values into the Tool axis page of the Surface Projection 

Finishing exactly as shown below. 

 

16 In the Tool Axis page select Lead/Lean with both values set to 0. 
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17 Enter the values into the Tool axis page of the Surface Projection 

Finishing exactly as shown below. 

 

18 In the Leads and Links pages set:- 

� Set both Lead in and Lead out – Vertical Arc – Distance 3, Angle 90, 

Radius 8. 

 

19 Select Calculate to create the toolpath, but do not close the dialog. 

 

 For visual reasons a larger Stepover has been used on the Toolpath shown 

in the illustration 

20 In the Surface Projection dialog select Make a Copy   to re-activate 

the Settings. 

 

It is possible for all or part, of the Reference Surface to exist outside of the 

component to be machined. In this case the option, Import Reference Surface 

will be used as it is not a part of the component model to be machined. 
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21 Right-click on Models in the PowerMILL explorer and select Import 

Reference Surfaces. 

22 In the Reference Surface dialog, select the Model: 

...\PowerMILL_Data\five_axis\ CornerFixing\CornerFixingRefSurf3.dgk 

 

 The new Reference Surface exists outside the component to be 

machined. As a result of using the command Import Reference 

Surfaces, the Machining Mode is permanently set to Ignore for the 

Reference Surface.  

 

 The imported Reference Surface is displayed in the PowerMILL 

explorer with a different colour (grey). 

23 Select the Reference Surface - CornerFixingRefSurf3. 

24 Rename the Toolpath as BN16-FIN2. 

25 In the Pattern page change the Limits (Distance) V as shown in the 

image below. 

 

 

26 Calculate the copied, Projection Surface Strategy. 
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27 To update the stored Project, select File > Save Project: 

...\COURSEWORK\PowerMILL_Projects\ProjectionSurface-Example1 

Exercise 
28 Create a new Projection Surface Finishing (named BN16-FIN3) starting 

at the centre of the top face to complete the other side of the component 

model (as shown below). 

 
29 To update the stored Project, select File > Save Project:  
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Surface Projection Range. 
Depending on the application, it may be necesary to limit the infinite projection 

range while applying the Surface Projection strategy. This situation occurs where 

the part of the model to be machined is shielded by other surfaces that are in the 

projection path. This command is, at present, only available via typed input into the 

PowerMILL Command Window. A more efficient way would be to store the 

command lines for a range of different distances in a series of macros, which in 

turn could be accessed via a user defined menu.  

 

1 Select File - Delete all and Tools - Reset forms. 

2 Open the (Read Only) Project: 

...\PowerMILL_Data\five_axis\ImpellerType2\ImpellerType2-Start 

 

3 Save the Project as:- 

….\COURSEWORK\PowerMILL_Projects\ImpellerType2-EX1 

 

The imported Project already contains 3 Roughing Toolpaths, and a Stock 

Model. 

 

4 Select an ISO 1 view. 

The next stage is to finish machine the 2 main faces of the blade positioned 

along the –Y direction (Shown shaded light blue in the above image). If the 2 

main faces were single surfaces then it would be possible to directly apply the 

Surface Machining strategy (which is not affected by Projection Range). This 

option is not practical in this case as the main faces of the blade consist of 

several surfaces. As a result it is necessary to obtain 2 suitable single, reference 

surfaces created using CAD (ideally PowerSHAPE). These will purely be used as 

reference surfaces in the Projection Surface Finishing strategy and will not 

be physically machined. 
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5 In the PowerMILL explorer right mouse click on Models and from the 

local menu select Import Reference Surfaces. 

 

6 In the dialog browse to:- 

...\PowerMILL_Data\five_axis\ImpellerType2\ImpellerType2-RefSurfs.dgk 

7 In the dialog select Open to import 2 reference surfaces (shown below). 

 

 By using this import method the 2 reference surfaces will always be 

ignored by a machining strategy during the calculation of a toolpath. 

 

 The reference surfaces are already acquired to appropriate levels   

(Ref-Surface1 and Ref-Surface2) this being inherited from the CAD 

process. 

 

8 Calculate a Block using a Cylinder to the full Model dimensions. 

9 Calculate the Rapid Move Heights using the default settings. 

10 Switch off the Level, Ref-Surface2. 

11 Select the reference Surface stored on the level, Ref-Surface1. 

12 Activate the Workplane TopFace. 

13 From the PowerMILL explorer, Activate the BN16 tool. 
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14 Set Lead In and Out to use Surface normal arc.  

 

 

15 From the main toolbar select the Toolpath Strategies . 

16 From the dialog select the Finishing tab followed by the Projection 

Surface Finishing option. 

17 Enter data into the following 3 pages of the Surface Projection dialog 

exactly as shown below. 
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18 Select Calculate in the Surface Projection Finishing dialog to produce 

the following toolpath, and then Close the dialog. 

 

 With the Projection Range set to OFF (default), ie. No limit, the 

toolpath is projected inwards towards the surface to be machined from 

outside the model limits. As the strategy is projected some of it will 

appear on neighbouring surfaces instead of those intended to be 

machined and create the toolpath as shown. 
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This problem can be resolved by switching to the Projection Range ON 

option and assigning suitable + and – distance values. 

19 Right mouse click on the toolpath BN16-Blade1A-FIN and from the local 

menu select Settings to re-open the strategy dialog. 

20 Select Recycle . 

21 From the main pull down menus select: View > Toolbar > Command. 

22 Enter the following commands into the Command Window that has 

appeared at the below of the graphics area: 

 

EDIT  SURFPROJ  AUTORANGE  OFF 

EDIT  SURFPROJ  RANGEMIN  -3 

EDIT  SURFPROJ  RANGEMAX  3 

 

The above command input limits the Surface Projection Range to + and - 

3mm. 

 

23 Select Calculate to create the new toolpath. 
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24 Simulate the toolpath to observe the effect of the limited - Projection 

Range. 

25 Create a Copy of this Surface Projection strategy on the other side of the 

blade (Use the reference Surface stored on Level, Ref-Surface2). 

 

 

26 In the Command Window type the following to restore the default, 

infinite Projection Range: 

EDIT SURFPROJ AUTORANGE ON 

 This command returns to the default infinite limit for the Surface 

Projection distance range. 

 

27 select File > Save Project to update the stored Project: 

...\COURSEWORK\PowerMILL_Projects\Ref-Surfs-Blades 
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Surface Finishing and Surface 
Projection - Spiral  

Both the Surface Finishing and Surface Projection Finishing strategies include 

the option to create a spiral toolpath: 

� The stepover is automatically adjusted so that the final cut finishes exactly on 

the Surface edge at the end of the toolpath. 

If you select a Surface Units of Distance, then the first and last passes will match 

the edges of the surface. To achieve this, the intermediate passes will adjust to less 

than or equal to the specified stepover.  

Projection Surface - Spiral Example 
1 Select File - Delete All and Tools - Reset Forms. 

2 Open the (read-only) Project: 

...\PowerMILL_Data\five_axis\ProjSurf-Blade\SurfProjSpiral-Start 

 

3 Save the Project as: 

...\COURSEWORK\PowerMILL_Projects\SurfMachine-Spiral 

 The Strategy in the above Project is unprocessed (indicated by the 

Calculator icon). 

 

4 In the PowerMILL explorer, right-click on Toolpaths to open the local 

menu and select Batch Process to create the toolpath. 
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The strategy automatically reinstates the original selected surface used on a 

previous occasion. The resultant Toolpath contains independent, stacked tool 

tracks and Surface Normal Arcs for Lead In/Out. For this strategy it, would be 

both possible and more appropriate to use the Spiral option. 

 

5 Right-click on the Active toolpath to open the local menu and select 

Settings to open the original Surface Projection Finishing dialog. 

6 Select Make a Copy   to re-activate the Settings. 

7 Select the Pattern page in the Surface Projection Finishing dialog. 

 

8 Rename the strategy as SurfaceProjectionSPIRAL, tick the Spiral box, 

and check that the reference surface is selected, before selecting 

Calculate. 
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This time the Projection Surface strategy consists of a single Spiral tool track, 

providing optimum efficiency and a smooth, consistent material removal. 

9 Close the dialog. 

10 Select File - Save Project to update the stored Project:- 

             ...\COURSEWORK\PowerMILL_Projects\SurfMachine-Spiral 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



PowerMILL 2016 5. Embedded Pattern Finishing 

Copyright © Delcam Ltd  5 - 1 

Introduction 
This Five Axis strategy not only tracks along the Embedded Pattern but 

automatically applies a Tool Axis alignment relative to the Surface Normals.  

An Embedded Pattern is created as a projection of an ordinary Pattern using the 

Edit - Embed option. The Pattern projection can be performed down the active Z 

Axis or towards the closest point on the model. 

Embedded Pattern Finishing - Engraving 
1 Open the (Read only) Project: 

...\PowerMILL_Data\five_axis\ 5axis_Embedded_Pattern\TrimPart-Start 

 

The model includes some wireframe Text and a ‘scribe line’ curve running 

around the form. 

These will each be used create separate Patterns. The corresponding 

Embedded Patterns can then created from the 2 new Patterns. 

2 Select File > Save Project As: 

...\COURSEWORK\PowerMILL-Projects\Trim-Part 

5. Embedded Pattern 
Finishing  
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3 Activate the toolpath, BN16-Form-FIN to reinstate suitable Parameters and 

Settings for the Embedded Pattern. 

4 Activate the Tool BN2. 

5 Ensure that none of the stored Boundaries are active. 

6 In the graphics area, select the part of the model named ‘TYPE 1’. 

7 In the PowerMILL explorer, right-click on Patterns and from the local menu, 

select Create Pattern. 

8 Right-click on the new (empty) Pattern and from the local menu, select Insert - 

Model to inherit the selected wireframe text, ‘TYPE 1’. 

 

The first Pattern contains the text ‘TYPE 1’ and is positioned above the Model. 

This Pattern is then used to create an Embedded Pattern which projects down 

Z onto the model. The Embedded Pattern will also pick up and store the 

Surface Normals. 

9 Rename the Pattern as ‘Text’. 

10 In the PowerMILL explorer, right-click on the Pattern and from the local menu 

select Edit > Embed.  

11 From the local menu, select Method - Drop and Apply the dialog. 

 

 An Embedded Pattern called Text_1 is created as projected down Z and is 

identified by the icon  in the explorer. The original Pattern is retained. 
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12 Select Toolpath Strategies  and from the Strategy Selector dialog sect 

the Finishing tab. 

13 From the Finishing options, select the Embedded Pattern Finishing. 

14 Enter the values into the following pages of the Embedded Pattern Finishing 

dialog exactly as shown. 

 

� Drive curve  Text_1 

� Axial offset  -3 

� Untick  Gouge Check 
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15 Tick Upper limit with a value of -1 

 

 

16 Set the Tool Axis to Lead/Lean both with 0 angles. 

 

It is necessary to ensure that the tool plunges and retracts along the Tool axis 

during Embedded Pattern finishing (Retract and Approach distance 5). 

17 Under Leads and Links, select the Links page. 

 

18 In both Retract and Approach distance, enter 5 (as shown above). 
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19 Accept the Leads and Links dialog. 

20 Back in the main dialog select Calculate to create the Toolpath. 

 

The text ‘TYPE 1’ is machined to a total depth of -3 with the tool aligned to the 

Surface Normals. 

21 Perform a ViewMILL Simulation on all of the Toolpaths. 

The Embedded Pattern toolpath has been produced with the tool aligned normal 

to the surface model. 

 If the toolpath is verified for gouges it will take on a Red ‘gouge’ warning. 

It is not possible to create a toolpath using a -ve thickness value that is 

higher than the tool tip radius while Gouge check is switched on. 

This is in technical terms a ‘deliberate gouge’ and will be ignored. 

 

22 Create a new Pattern named ScribeLine and Insert the wireframe Curve, 

running around the upper wall of the model. 

23 Create an Embedded Pattern from the Pattern (ScribeLine) but this time 

select Closest Point in the dialog. 

 

This time the Embedded Pattern results from a projection towards the nearest 

point on the Model (Normals) from the original Pattern.  
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24 Open a new Embedded Pattern strategy named BN2-ScribeLine-FIN using 

Drive curve - ScribeLine_1. 

 

� Axial offset:  0  

� Gouge check:  Ticked  

� Thickness:  -0.75  
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This time the required Depth Of Cut is less than the Tool Tip Radius allowing the 

Thickness option to be used instead of Axial offset. 

 

� Set Mode: Off 

� Upper Limit: Un-ticked  

 

25 Select Calculate to create the Embedded Pattern toolpath. 

26 Continue the ViewMILL Simulation on the new toolpath. 

 

27 Select File > Save Project. 
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Introduction 
Five Axis - Swarf Finishing is designed to create a toolpath where the selected 

surfaces are machined with the side of the tool (the default Tool Alignment 

option is Automatic). A Swarf Finishing toolpath will only exist where the tool is 

able to remain in full contact with the selected surfaces along the whole cutting 

depth. In other words, the tool must always be able to find a Linear path across the 

surfaces. It is possible for the user to apply a different tool alignment (For 
example, Vertical or Lead\Lean) but the selected surfaces must still be 

Swarfable for machining to occur.  

In cases where imported surfaces are supposed to be Swarfable but are not of a 

suitable quality, the upper and lower edges can be created as separate (wireframe) 

Patterns to be used with Wireframe Swarf Finishing. 

Swarf Finishing - example 1 
1 Select File > Delete All followed by Tools > Reset Forms. 

2 Import the model: 

...\PowerMILL_Data\five_axis\swarf_mc\swarf_model.dgk 

 

3 Create a Block using Type - Box and Defined by - Model. 

4 Create a Dia 12, tiprad 1, tool named D12TR1. 

6. Five Axis Swarf 
Machining 



6. Five Axis Swarf Machining                                                                                                                 PowerMILL 2016 

6-2  Copyright @ Delcam Ltd 

5 Calculate the Rapid Move Heights. 

6 Change the View to ISO 4  and select the local surfaces to be Swarf 

machined (as shown below shaded). 

 

 

7 Select Toolpath Strategies  and from the Finishing dialog select the 

Swarf Finishing option. 

8 Enter the values into the main page of the dialog exactly as shown below and 

Calculate.  

 The default Tool Alignment is Automatic for this strategy. 
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9 Open the Leads and links dialog via the icon  and Apply the following 

settings: 

Lead In/Out:      Vertical Arc – Distance 10 – Angle 90 – Radius 5.0 

Links:         Short\Long – Skim     Default – Incremental 

 

10 Deselect the local surfaces, Simulate the resultant toolpath, and observe the 

changing tool alignment as it Swarf machines the selected surfaces. 

11 Select Settings to reopen the existing (active) Swarf Finishing strategy and 

then create a Copy  named D12TR1-Swarf2. 

 

12 Select the, upper sidewall, surface (as shown above). 
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13 Select the Position page and set Base position - Bottom with Offset -2. 

 

 

14 Select the Multiple cuts page, with the Mode set to Merge with Maximum 

stepdown 1. 

 

 

15 Select the Tool Axis page and use the default, Tool Axis - Automatic. 

 

16 Select Calculate at the bottom of the dialog to create the toolpath. 
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17 Open the Leads and links dialog via the icon  and Apply the following 

settings: 

Lead In/Out:      Surface normal arc – Distance 0 – Angle 90 – Radius 5.0  

Links:  Short\Long – Skim     Default – Incremental 

 

 

The new Swarf Finishing strategy steps down the selected surfaces while 

merging the stepover between the Upper and Lower contours.  

Exercise  

1 Create a Dia 10 End Mill (EM10). 

2 Create a Copy of the original, single pass, Swarf Finishing strategy to create a 
machining path, this time using the Dia 10 End Mill and aligned to the 

underside of the undercut selected, recess surface on the outer sidewall. 

 

3 Deselect the local surfaces, Simulate the resultant toolpath and observe the 

changing angle of the tool as it Swarf machines the selected surface. 

4 Select File > Save Project As: 

...\COURSEWORK\PowerMILL-Projects\Swarf-Example 

5 Select File > Delete All and Tools > Reset Forms.  
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Swarf Finishing - Example 2 

1 Open the Project (created earlier): 

...\COURSEWORK\PowerMILL-Projects\3Plus2-EX1 

 

2 Activate the Dia 10 tiprad 1 tool (D10T1). 

3 Activate the workplane - ztop175_A. 

4 Make sure that no Boundary is Active. 

5 Open the Block dialog and select the option Defined by - Cylinder before 

selecting Calculate (A cylindrical Block to the Model dimensions will be 

created). 

 

6 Open the Rapid Move Heights dialog and set Safe area Cylinder and enter 

data into the dialog exactly as shown below, before selecting Calculate. 

 

� Input the Workplane ztop-175_A and set a Direction (vector)  0  0  1   

The use of Safe area - Cylinder will produce smoother link moves around the 

cylindrical form instead of point to point, linear moves. 
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7 Set both Lead in/out to Surface normal arc with Angle 90 and Radius 4. 

8 Select all three sidewall surfaces for the three pockets. 

 

9 Select Toolpath Strategies  and select the Finishing option located in the 

Strategy Selector dialog. 

10 Enter the values into the pages of the Swarf Finishing dialog exactly as shown. 
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� Mode - Merge provides continuous tool tracks as variable offsets between 

the upper and lower edges of the swarfable, surfaces. 

� Use: Maximum stepdown 1.0 

 The default Tool Axis setting for Swarf Finishing is Automatic.  

11 Select Calculate to process the Toolpath. 

 

Note the link moves follow a cylindrical path as defined in the Rapid Move 
Heights dialog. This will provide both smoother tool link and re-orientation 

moves between separate machining areas. 

12 Simulate the toolpath (D10TR1-FinPkts) and observe the changing angle of 

the tool as it Swarf machines the selected surfaces. 

13 Select File > Save Project to update: 

 ...\COURSEWORK\PowerMILL-Projects\3+2example 
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Swarf Finishing - Example 3 
There are situations where swarfable surfaces do not provide an acceptable tool 

alignment around the component form.  In these cases the only obvious solution is 

to use a separate CAD package (eg PowerSHAPE) to re-model the affected 

surfaces.  

In the following example a Swarf Finishing strategy will be applied on 5 selected 

surfaces (As shown, shaded pale blue in the following illustration). Due to the way 

the Surfaces have been designed the resultant toolpath will not produce an 

acceptable tool track along the existing form. To fix this a new ‘fit for purpose’ 

surface model of the swarfable face will be imported and used to produce a much 

improved Swarf Finishing toolpath. 

 

1 Select File > Delete All and Tools > Reset forms. 

2 Select File > Import Model: 

...\PowerMILL_Data\five_axis\swarf_mc\SwarfSurfModel-A.dgk 

 

3 Select File > Save Project As: 

...\COURSEWORK\PowerMILL-Projects\SwarfSurf-EX3 

 

4 Activate the Workplane TopCentre. 

5 Calculate a Block, Defined by – Box and using Type – model. 

6 In the Block dialog, Lock the Z values, input an expansion 10, and Calculate 

again,  

7 Create a Dia 12 End Mill (named EM12). 

8 Calculate the Rapid Move Heights. 

9 Set the Start Point to First Point Safe and End Point to Last Point Safe. 

10 Set both the Lead in and Lead out to Surface normal arc with Angle 90 and 

radius 6. 

11 Select the 5 Surfaces required to be Swarf machined as shown pale blue in 

the above illustration. 
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12 Select Toolpath Strategies  and select the Finishing option located in 

the Strategy Selector dialog. 

13 Enter the values into the main page of the Swarf Finishing dialog exactly as 

shown. 

 

 

14 Select the Position page and input Offset  -1.0 

 

 

15 Select Calculate to process the toolpath. 
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16 Run a slow, Point to Point , Simulation and observe the 

changes in tool alignment as it runs along the tool track.  

 

The Swarf Finishing toolpath visually looks okay at first until it is run through a 

simulation. This reveals that the Tool (EM12) is running at an acute angle 

relative to the swarfable surfaces in some areas (as shown in the above 

illustration). Also, the cutter closely follows the lower edge, causing it to 

suddenly drop and lift while running around the step. 

This strategy can be improved by using different Surfaces that are specifically 

designed to provide a better tool alignment during Swarf Finishing.  

 

The original 5 reference Surfaces used in the toolpath EM12-Swarf-1 are as 

shown above. These will be replaced by new Surfaces of exactly the same 

shape within the original model area, but designed specifically to work more 

effectively with the Swarf Finishing strategy. 

 

17 Select File > Import Model: 

18 ...\PowerMILL_Data\five_axis\Swarf_mc\NewSwarfSurf-B.dgk 
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The new Surfaces are designed with surface curves aligned to match the 

required tool alignment. It is also exactly the same shape as the 5 surfaces 

used in the original Swarf Finishing toolpath. Compared with the original 5 

surfaces, the lower edge has been extended with a smooth transition 

constructed along the lower edge of the form. 

 Do Not Delete the 5 surfaces used in the original Swarf Finishing 

strategy. They are still required for accurate gouge checking. 

 

19 Right mouse click on the toolpath EM12-Swarf-1 and from the local menu 

select Settings to open the strategy dialog. 

20 In the Swarf Finishing dialog select the option, make a Copy . 

21 Select the new, imported reference Surfaces. 

22 In the main page select Follow surface laterals to make the tool to align to 

the surface curves wherever possible. 

 

 

23 Select Calculate to process the new toolpath (EM12-Swarf-1_1). 

24 Run a slow, Point to Point , Simulation and observe the 

changes in tool alignment as it runs along the tool track.  
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This time the Tool is more suitably aligned to the swarfable surface as it runs 

along the Toolpath (EM12-Swarf-1_1). 

 

25 Select File > Save Project to update: 

 ...\COURSEWORK\PowerMILL-Projects\SwarfSurf-EX3 
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Swarf Finishing - Example 4 
In the following example a Swarf Finishing strategy will be applied to trim the 

edges of an angled plate. Due to the way the original edge Surfaces have been 

designed the tool is unable to maintain a suitable alignment to the model form. To 

fix this a different set of swarfable edges will be used instead to produce a much 

improved Swarf Finishing toolpath. These surfaces have been created using 

PowerSHAPE. 

 

1 Select File > Delete All and Tools > Reset forms. 

2 Select File > Open Project:- 

....\PowerMILL_Data\five_axis\swarf_mc\AnglePlate4-Swarf-Start 

 

3 Select File > Save Project As: 

...\COURSEWORK\PowerMILL-Projects\ AnglePlate4-Swarf-EX1 

 

4 Activate the existing drilling Toolpath Drill20-Thro. 

5 From the Main toolbar select Block.  

6 In the Block dialog select Defined by Triangles with the Coordinate System 

set to Global Transform. 

 

7 Select the Load block from file option.  

8 In the Open Block from Triangles dialog and select the file:- 

....\PowerMILL_Data\five_axis\swarf_mc\AnglePlate4-Material.dmt 

 

9 Select Accept to close the dialog. 
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10 Right mouse click on the Toolpath Drill20 and from the local menu select 

Simulate from Start. 

11 Ensure that the ViewMILL toolbar is displayed and click the Red button to 

connect it to the simulation. 

12 Run a ViewMILL simulation on the 2 existing drilling toolpaths Drill20-Thro 

and EM16-Dia24_Helical. 

 

 

 

13 Save the ViewMILL session  at this stage, put it on suspend , and 

select the No image  option. 

14 Activate the Tool EM10. 

15 In the Leads and Links dialog set both Lead in and Lead out to Vertical arc 

with Angle 90 and Radius 5. 

16 In the PowerMILL explorer, Levels and Sets folder, right mouse click on the 
Set OriginalEdges and from the local menu click on Select Surfaces. 
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17 Select Toolpath Strategies  and select the Finishing option located in the 

Strategy Selector dialog. 

18 Enter the values into the pages of the Swarf Finishing dialog exactly as shown 

below. 

 

 

 

 

19 Select Calculate to process the toolpath and then Close the dialog. 

20 Run a Toolpath simulation and observe the alignment of the Tool as it tracks 

along the selected surfaces. 
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Due to the component edges being planer the alignment of the EM12 tool is not 

compelled to remain Normal to the main Angle Plate surfaces. In the above image 

the tool has remained cranked over after tracking around a curve in the edge form. 

There are too many choices for the cutter to use a linear alignment across the 

swarfable surfaces. 

 

21 Right mouse click on the toolpath and from the local menu select Settings. 

22 Select the option to Recycle  the toolpath. 

23 In the Swarf finishing page tick the box Follow surface laterals. 

 

 

24 In the PowerMILL explorer, Levels and Sets folder, right mouse click on the 

Level NewEdges and from the local menu click on Select Surfaces. 

25 Calculate the updated Swarf finishing strategy. 
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This time the tool is aligned to the laterals of the replacement swarfable surfaces. 

These have been re-designed using PowerSHAPE surface modelling and have been 

designed with laterals that produce the above tool alignment.  

 

26 Reconnect the existing ViewMILL session and simulate the latest Swarf 

Finishing strategy. 

 

 

 

27 Select File - Save Project to update the stored Project. 
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Wireframe Swarf Finishing 
In some cases imported surfaces to be used in Swarf Machining could be of a 

poor quality. This would typically include such problems as mis-matching edges 

and/or un-intentional curves across the surfaces. These problems will 

undoubtedly result in part or complete failure to create a Swarf Finishing strategy. 

One solution is to re-model the affected Surfaces (assuming the user has access to 

a suitable CAD system (eg PowerSHAPE)).   

The other alternative is to create 2 separate Patterns that define both edges 

running along the area to be swarf machined. The user can then use the 

Wireframe Swarf Finishing strategy. 

The model used in the following example contains a pocket in which part of the 

sidewall is un-swarfable due to being slightly convex between the top and bottom 
edges. 

 

1 Select File > Delete All and Tools > Reset Forms. 

2 Import the Model: 

...\PowerMILL_Data\five_axis\Swarf_mc\Wfrm-Swarf.dgk 

 

3 Select File > Save Project As: 

...\COURSEWORK\PowerMILL-Projects\Wframe-Swarf 

 

4 Activate the Workplane - Datum. 

5 Calculate a Block using Defined by - Box to the model dimensions. 

6 Create a Dia 5 End Mill (EM5) using the following dimensions: 

Tool           Dia 5   Length 35 

Shank           Lower Dia 5 Upper Dia 5 Length 15 

Holder-1 Lower Dia 15   Upper Dia 25  Length 15 

Holder-2 Lower Dia 25  Upper Dia 25  Length 15  

Overhang 50  

 

7 Calculate the Rapid Move Heights. 
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8 Select the sidewall surfaces on each of the 3 pockets in the component. 

 

9 Select Toolpath Strategies  and from the Finishing tab select the Swarf 

Finishing option. 

10 Enter the values into the 2 pages of the Swarf Finishing dialog exactly as 

shown. 
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� Mode – Merge  and Max Stepdown - 3.0 

11 Calculate the toolpath. 

 

The Swarf Finishing strategy has failed to machine one of the selected 

surfaces due to part of the sidewall being un-swarfable.  
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On closer inspection it is evident that some of the curves linking across the 

sidewall surface are convex and as a result make this area un-swarfable. 

 

This problem will be fixed by creating separate Patterns along the upper and 

lower edges of the sidewall surface of the affected pocket. The 2 Patterns will 

then be used in a Wireframe Swarf Finishing strategy. 

 

12 Select the Surface defining the angled sidewall of the left hand pocket (shown 
above). 

13 Create a Pattern named Upper and right-click over it in the PowerMILL 

explorer selecting Insert > Model from the local menu. 

 

 

 

14 Select the lower Pattern segment. 

 

15 Right-click on the Pattern named Upper and from the local menu, select the 

option Edit - Copy Pattern (selected only). 

16 Rename the new, copied Pattern as Lower. 

17 Select and Delete the lower segment from the Pattern named Upper. 

 For Wireframe Swarf Finishing to function correctly the two Patterns 

must travel in the same direction. 
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It is not compulsory to align the start points on the upper and lower 

Patterns. It is the first point on the lower Pattern that defines the start 
position of the resultant toolpath. 

 

18 To identify whether the two patterns are suitable for use, right click each one in 

turn and select Instrument to display the start point and direction. 

 

 As can be clearly seen the two segments travel in opposite directions 

creating the need for one to be reversed. 

In this case, to create a Climb milling strategy, the lower segment must 
be reversed. 

 

 

19 Select the lower Pattern segment and right mouse click on it to open the 

local menu. 

20 From the local menu, select Edit > Reverse Selected. 

21 Select the Toolpath Strategies  and from the Strategy Selector > 

Finishing options, select Wireframe Swarf Finishing. 

22 Enter the values into the dialog exactly as shown below: 
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23 Select Component Thickness  to open the following dialog. 

24 Select both the sidewall and fillet surface (flanked by the Patterns) and 

acquire them to a selected row (with the Machining Mode set to Ignore) in 

the Component Thickness dialog. 

 

25 Apply the Component Thickness dialog. 
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26 Calculate the Wireframe Swarf Finishing strategy. 

 

The new Wireframe swarf finishing strategy has successfully been applied 

between the Upper and Lower Patterns.  

 

27 Select File > Save Project to update the Project: 

...\COURSEWORK\PowerMILL-Projects\Wframe-Swarf 
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Swarfable Surface Design 
When designing a component certain factors will dictate how successfully a Swarf 

finishing strategy can be applied to what appear to be visibly suitable surfaces. 

The fundamental rule is that Swarf finishing will only occur where the side of the 

tool can be in full contact from one side of a surface to the other (Linear). This 

works fine if the swarfable surfaces are twisting and turning and the tool is able to 

find a specific linear alignment at all times. If however a surface is totally planer 

then the linear tool alignment can occur at any angle across the swarfable edges. 

 

 

 

 A tick box option exists in the strategy to force the tool to Follow surface laterals 

(natural surface curves). For this to work it is likely that the existing planer 

swarfable surfaces will need to be re-modelled. This task has to be done using a 

suitable CAD software such as PowerSHAPE. 

 

 

The above planer surface has been designed with the laterals aligned to match the 

required tool axis. The initial angular move is the required transition to or from the 

end of another selected swarfable surface. 
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Flowline Finishing 
Flowline Finishing is designed to machine multiple surfaces. The strategy uses 2 

drive curves and either 1 (closed form) or 2 (open form) end curves to define a 

virtual surface area. Intermediate drive curves can be added to further control the 

flowline shape. This strategy provides evenly spaced tool passes, irrespective of the 

underlying geometry. 

Advantages over existing toolpaths include: 

� Multiple surfaces can be machined.  

� Machining of undercut regions is possible.  

� The toolpath passes are not determined by the surface parameterisation.  

� The region being machined is not forced to be an entire surface or parametric 

box.  

� The stepover is defined in 3D, giving total control over the maximum value. 

Flowline Finishing Example  
1 Select File > Delete All followed by Tools > Reset Forms. 

2 Open the Project: 

....\PowerMILL_Data\five_axis\Flowline\Flowline_EX4-Start 

 

3 Select File > Save Project As: 

...\COURSEWORK\PowerMILL-Projects\Flowline-EX4 

7. Flowline Finishing 
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4 Activate the Workplane MC-Datum. 

5 Activate the BN12 tool. 

6 Calculate a Block Using Defined by Box and Type Model. 

7 Calculate the Rapid Move Heights using the default settings. 

8 Select the following 5 Surfaces and Blank the rest (Ctrl K). 

 

9 Display the Model as Wireframe only. 

10 Create a new (empty) Pattern 1. 

 

11 With the above Surfaces selected, Right click on the Pattern and from the local 

menu select Insert – Model. 

 

 A Pattern extracted from a selection of surfaces will automatically become 

Embedded (Inherits the surface normals etc). 

 

 

 The Pattern symbol changes to identify it as being Embedded. 
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12 Right click on the Pattern and from the local menu select Curve Editor. 

13 Select the Composite Curve option from the Curve Editor toolbar. 

 

 

14 With the Create Composite Curve toolbar open click near to the upper end of 

the first surface lateral (As shown arrowed below). 

 

15 In the toolbar select the red disc followed by the green tick to both accept the 

new segment and close the toolbar.  

 

The new Embedded Pattern (1) is now made up of 3 segments (2 closed and 1 

open).  
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16 From Toolpath Strategies  open the Finishing options and from the 

dialog select Flowline Finishing. 

17 Enter data into the main page exactly as shown below. 

 

 

18 Still on the main page select the Interactively select pattern segments for 

the strategy options.  

 

 

The options in the above form enable the toolpath ordering, directions, etc to be 

controlled before the toolpath is calculated. However, no changes are required in 

this instance. 
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19 Select the Tool axis page and select the Lead/Lean option with both the Lead 

and Lean angles as 0. 

 

20 Select Calculate to create the following Flowline Finishing toolpath. 

 If the Flowline Finishing toolpath should fail to calculate try to Embed 

the Pattern again using Closest point with Distance 0.1 and 

Tolerance 0.01 

 

 For visual reasons the above toolpath has been created with a 2mm 

stepover. 

 

21 Right mouse click on the toolpath BN12-Flowline-FIN1 and from the local 

menu select Simulate from Start.  

22 From the Simulation toolbar select Play  and observe the Flowline 

Finishing process. 

23 Select File - Save Project. 

24 Select File - Delete All and Tools - Reset Forms. 
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Exercise 
The purpose of this exercise is to create a suitable Embedded Pattern and use 

Five Axis - Flowline Finishing to machine the fillet surfaces running around the 

upper edge of a component model form. 

a A single segment, Embedded Pattern will be directly created along the 

edges of the fillet surfaces.  

b The Embedded Pattern will then be split into 4 suitable segments using the 

Curve Editor options. 

c The user will then be asked to create a suitable Flowline Finishing strategy 

using the Embedded Pattern. 

 

1 Import the Model:- 

....\PowerMILL_Data\Models\Vortex2.dgk 

 

2 Select File > Save Project As: 

...\COURSEWORK\PowerMILL-Projects\FlowLineFillet-EX1 

 

3 Select the whole of the Model and the select Create and Orientate 

Workplane – Workplane at Top of Selection. 

4 Activate the new Workplane. 

5 Create a Dia 8 - Ball Nose Tool, named BN8.  

6 Create a Block using Defined by Box and Type Model. 

7 Calculate the Rapid Move Heights using the default settings. 

8 Select all of the Surfaces that define the fillet along the upper edge of the main 

3D form (As shown below). 



PowerMILL 2016                                                                                                                               7. Flowline Finishing 

Copyright @ Delcam Ltd                                                                                                                                           7 - 7 

 

9 In the PowerMILL explorer right mouse click on Patterns and from the local 

menu select Create Pattern. 

10 From the same menu select Insert – Model. 

 This will automatically become an Embedded Pattern as it inherits the 

required data from the edges of the selected Surfaces. 

 

11 Select and Blank the whole of the Model and Un-draw the Tool and Block. 

12 Right mouse click on the Embedded Pattern and from the local menu select 

Curve Editor. 

13 Use Cut item to break the Pattern into separate segments at the four corners 

of the fillet form. 

 

 In this example the Embedded Pattern must consist of 4 segments 

that specifically define the 2 ends and 2 sides of the enclosed fillet. 

 

14 Select any multiple segments that define a single, drive or end curve and 

then use Merge selected to reduce these to a single segment. 

 



7. Flowline Finishing                                                                                                                               PowerMILL 2016 

7 - 8  Copyright @ Delcam Ltd 

15 Accept the changes (Green tick) and return the Embedded Pattern from the 

Curve Editor. 

16 Use the (4 segment) Embedded Pattern in a Flowline Finishing strategy to 

five axis machine (Tool Axis - Lead/Lean 0 using Mode - Contact normal) 

the enclosed surfaces of the fillet form. 

17 Use the options in Interactively select pattern segments for the strategy   

to control the required toolpath order and direction. 

 

 

 

 

 

 

18 Select File > Save Project As: 

...\COURSEWORK\PowerMILL-Projects\FlowLineFillet-EX1 
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Flowline with intermediate drive curves Example  
1 Select File > Delete All followed by Tools > Reset Forms. 

2 Open the Project: 

....\PowerMILL_Data\five_axis\Flowline\FlowLine-ExtraDriveCurves-Start 

 

3 Select File > Save Project As: 

...\COURSEWORK\PowerMILL-Projects\FlowlineWithExtraDriveCurve 

4 Select an ISO 1 view.  

5 Activate the toolpath BN16-Flowline-4Curves-All.  
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Note that this basic 4 segment, Flowline toolpath does not follow the intermediate 
flowlines of the variable fillet within the model form. 

 

This can be changed if intermediate drive curves are included in the Embedded 

Pattern. 

 

6 Right mouse click on the active toolpath BN16-Flowline-4Curves-All and from 

the local menu select Settings to open the Flowline Finishing dialog. 

7 Select the Copy toolpath  option and then rename the new toolpath as 

BN16-LH-Flowline-ExtraCurves. 

8 In Curves definition, change the selected Embedded pattern to 9Segment. 
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9 Select Interactively select pattern segments for the strategy.  

 

 

 

10 Select the Reset button to clear the default, segment selection. 

 

 

11 Select the upper central curve as the start drive curve (green) 

12 Select the bottom left curve as the end drive curve (red). 

13 Shift – select the 2 end curves (blue). 

14 Shift select the 2 nearest intermediate curves (purple). 

 

15 Select the Next button to return to the full preview stage. 
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16 Select the Finish button to return to the main Flowline finishing dialog. 

17 Select Calculate to generate the new toolpath then select Close. 

 

Note that this 6 segment, Flowline toolpath follows the intermediate flowlines of 

the variable fillet within the model form. 

Exercise 
18 Create a Copy of the above toolpath named BN16-RH-Flowline-ExtraCurves 

and modify to machine the RH side of the component form. 

 

19 Select File – Save Project. 

20 Select File - Delete All and Tools - Reset Forms. 
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Introduction 
Automatic Collision Avoidance can be applied to Vertical alignment operations 

in cases where the Shank would otherwise be rubbing on a sidewall and\or the 

Holder would clash with the component. If parts of the component still cannot be 

machined without a tool collision occurring then these areas will not be included as 

part of the toolpath. Note: Automatic Collision Avoidance is not applicable to 

Swarf Finishing. 

 

1 Open the Project: 

...\PowerMILL_Data\five_axis\CollisionAvoidance\AutoCollisionAvoid1_Start 

 

2 Select File > Save Project as: 

...\COURSEWORK\PowerMILL-Projects\AutoCollisionAvoid_1 

8. Auto Collision 

Avoidance 



8. Auto Collision Avoidance                                                                                                                    PowerMILL 2016 

8 - 2  Copyright @ Delcam Ltd 

The Project contains 3 toolpaths all of which have had Collision Checking applied 

with Shank and Holder clearances values of 1 and 2 respectively. 

 

The Area Clearance strategy is Gouge and Collision safe while the two 3D  

Offset finishing strategies although Gouge free are not Collision safe relative to 

the Shank and Holder. 

 

3 In the PowerMILL explorer, activate the toolpath BN5-Walls-fin1. 

4 Right mouse click on the toolpath BN5-Walls-fin1 and from the local menu 

select Settings. 

5 Select Recycle  in the 3D Offset Finishing dialog and select the Tool 

Axis page. 

 Note that the selected Tool Axis option is Vertical. 

 

6 Select the newly available Collision Avoidance page (Below Tool axis). 
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� Input the Tilt method as Lean. 

� Input Shank and Holder clearances of 1 and 2 along with a smoothing 

distance of 10. 

 

7 Calculate the 3D offset Finishing toolpath. 

8 Apply Lead In and Lead Out with the same 1st/2nd choice – Surface normal 

arc as shown in the following dialog. 

 

 

This recycled 3D Offset Finishing toolpath will need to be retrospectively edited to 

make the strategy ordering start at the top of the walls.  
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9 Right mouse click on the toolpath and from the local menu select Edit – 

Reorder. 

 

 

10 In the Reorder Toolpath Segments dialog select Reverse Order. 

11 Select a View from front  and Simulate the toolpath to observe the 

Automatic Collision Avoidance in action. 

 

12 In the PowerMILL explorer, activate the toolpath BN5-Floor-fin2. 

13 Right mouse click on the toolpath BN5-Floor-fin2 and from the local menu 

select Settings. 

14 Select Recycle  in the 3D Offset Finishing dialog and select the Tool 

Axis page. 
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 Note that the selected Tool Axis option is Vertical. 

 

 

15 Select the Collision Avoidance page. 

 

� Input the Tilt method as Lean. 

� Input Shank and Holder clearances of 1 and 2 along with a smoothing 

distance of 5. 

 

16 Calculate the 3D Offset Finishing toolpath. 

 

17 Apply Lead In and Lead Out as 1st choice – Surface normal Arc as used in 

the previous toolpath (BN5-Walls-fin1). 
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18 Select a View from front  and Simulate the toolpath to observe the 

Automatic Collision Avoidance in action. 

 

Vertical tool alignment is applied as default and the Lean angle is progressively 

changed as required in areas where a collision would otherwise occur. 

 

 

19 Select File > Save Project. 
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EXAMPLE 2 
1 Select File - Delete All and Tools - Reset Forms. 

2 Open the (read only) Project: 

....\PowerMILL_Data\five_axis\CollisionAvoidance\DashboardPanel-A1_Start 

 

3 Select File > Save Project as: 

....\COURSEWORK\PowerMILL-Projects\Dashboard-A1_EX1 

 

The Project contains 11 toolpaths all of which have had Collision Checking 

applied with Shank and Holder clearances values of 1 and 2 respectively. 

 

All have been confirmed to be safe with the exception of BN3-FIN1-OP2. 

The toolpath is gouge free relative to the flutes but not collision safe relative 

to the Shank and Holder. 

 

4 Activate the 5th toolpath, D16TR3-RGH1-OP2 to reinstate the OP2 setup. 

5 Select an ISO1 view. 
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6 Run a full ViewMILL simulation on both NCPrograms OP1 and OP2. 

 

The final toolpath BN3-FIN1-OP2 is not currently included in the OP2 

ncprogram. The above ViewMILL simulation displays the result of all toolpaths 

except BN3-FIN1-OP2. 

 

7 Put ViewMILL on suspend and return the graphics area to the PowerMILL 

page.  

8 Activate the toolpath BN3-FIN1-OP2 and from the local menu select 

Settings. 

9 In the Tool axis page tick the box named Automatic collision avoidance. 

 

The Collision avoidance page appears in the local explorer. 

 

 

 

10 Select the Collision avoidance page. 

11 Set Tilt Method to Lean with a Holder clearance of 2.0, Shank clearance of 

1.0, and Smoothing distance 3.0. 
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12 Select Calculate and note that the collision status of the toolpath BN3-FIN1-

OP2 (as displayed in the local explorer) changes from a Red to Blue. 

 

13 Run a ViewMILL simulation on the toolpath BN3-FIN1-OP2. 

If a potential collision situation is encountered the tool automatically leans away 

from the wall (as shown in the above image). 

 

14 Save the Project. 
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Introduction 
It is possible to control the Tool axis limits of the machine tool within 

PowerMILL. This enables the rotary working envelope of a specific machine not to 

be exceeded when creating multi-axis toolpaths. The angular limits are defined in 

terms of Azimuth and Elevation angles in PowerMILL. 

Azimuth and Elevation 
The Azimuth is the angle from X 0° anticlockwise around the XY plane. The 

Elevation is the angle that is lifted upwards (+90°) or downwards (-90°) from the 

XY plane. 

 

The Tool Axis Limits dialog is accessed from within the Tool Axis direction dialog. 

Tool Axis Limits are accessible if the Tool Axis box is ticked. This tick box will 

not be available if the Tool axis is set to Vertical or Fixed Direction. 

 

9. Tool Axis Limits 
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1 Select File - Delete all and Tools - Reset Forms. 

2 Open the ‘read only’ Project: 

...\PowerMILL_Data\five_axis\Tool_Limit\JoyStick_Start 

3 Select File > Save Project As: 

...\COURSEWORK\PowerMILL-Projects\JoyStick-Example 

4 In the graphics area, right-click on the toolpath at the underside of the sphere, 

and from the local menu select, Simulate from Nearest Point. 

 

 Note that the tool is cranked over way beyond the rotational limits of the 

machine tool and the tool holder is visibly colliding with the base form. 

To further illustrate the machining process exceeding the rotary limits, the strategy 

will be simulated using a DMU50 Evolution machine tool. 

5 In the PowerMILL explorer, right mouse click on the Toolpath                 

BN16-NoToolAxisLimits and from the local menu select Simulate from Start. 

This command will raise the Simulation toolbar (if it is not already open). 

 

6 In the PowerMILL explorer right mouse click on Machine Tools and from the 

local menu select Toolbar. 

 

 

7 Select Import the Machine Tool Model  and select the file: 

....\PowerMILL Data\Machine Data\DMU\dmu50v.mtd 
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8 Ensure the Draw\Undraw machine tool icon  is on to display the machine tool 

model. 

 

The current component datum (Transform) is matched to that of the Machine 

Tool model (Top - Centre of Table). As a result, the base of the component is 

currently embedded into the machine tool bed. To compensate for this, a new, 

suitably positioned Workplane is created. This new Workplane is then used in 

the Machine Tool definition toolbar. 

 

9 Create a new Workplane named MTD-datum and move it by Z-50. 

10 Input the new Workplane, MTD-datum into the Machine Tool definition 

dialog. 

 It is not necessary to activate the new workplane. 

 

The component will immediately be repositioned, relative to the new 

Workplane. 
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11 Select Floor View  on the Machine Tool toolbar. 

 

12 Start the Simulation  to observe the virtual machining of the component. 

The DMU50 angular limits are X ±90 Y ±360 and this information is stored in the 

MTD file. This translates to Azimuth angle limits of 0 to 360 and Elevation angle 

limits of 0 to 90. When the toolpath simulation attempts to go beyond this range 

an error message will be displayed indicating that the machine, Tool Axis Limits 

will be exceeded. 

 

 To allow for this appropriate Tool Axis Limits will be applied to the toolpath 

during calculation. 
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13 In the PowerMILL explorer, Machine Tools folder right mouse click on dmu50v 

and from the local menu select Go Home to return the machine tool model to the 
home position. 

14 Make a Copy  of the original toolpath and rename it as BN16-LimitsSet. 

15 In the local explorer below Tool Axis, select the Tool Axis - Limits option to 

activate the Tool Axis Limits page. 

16 Enter the values into the dialog exactly as shown (select Mode - Remove 

toolpath and tick the Draw limits box). 

 

 

The green area of the sphere represents the permissible angular alignment of 

the Tool Axis. 

 

17 With the same Reference Surface selected, Calculate and Close the dialog. 

18 Right-click the Toolpath, BN16-LimitsSet, in the PowerMILL explorer and 

select Simulate from Start. 
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19 Select Play . 

 

 With Mode set to Remove Toolpath in the Limits dialog, only the 

portion of the surface within the rotary Tool Axis Limit range is 

machined. 

20 Right-click on the toolpath, BN16-LimitsSet, and select Settings to access the 

Surface Projection Finishing dialog. 

21 Select recycle  and from the Tool Axis dialog  select the Limits page and 

enter the values into the form exactly as shown below (select Mode – Move tool 

axis). 

 

22 With the original reference surface selected, Calculate the toolpath. 

23 Right-click the Toolpath BN16-LimitsSet, in the PowerMILL explorer and 

select Simulate from Start. 

24 Select Play . 
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With Mode set to Move tool axis in the Limits dialog, the surface is fully 

machined with the Tool Axis becoming fixed when it reaches the maximum, Tool 

Axis Limit.  

25 Select File > Save Project to update the stored data. 

Defining Limits for a Multi-Axis Machine 
The Tool Axis Limits option allows the user to control the angular limits of a tool 

while creating a multi-axis toolpath. The specified limits will differ in format 

depending on the type of rotary axis configuration. As a result they will have to be 

translated as universal Azimuth and Elevation angles to be compatible with 

PowerMILL. 

The configuration of the rotary axes varies widely, however the differences between 

many of these are relatively minor and there are really only three fundamentally 

different machine configurations: 

Table – Table Both rotary axes move the table. 

Head – Head Both rotary axes move the head. 

Head – Table One rotary axis moves the head, the other moves the table. 

The next examples will show how to transpose angular limits of a machine tool into 

Azimuth and Elevation angles. 

1 Select File Delete all and tools Reset Forms. 

2 Select the Tool Axis icon  from the main toolbar. 

3 Define Tool Axis as Lead\Lean and set both Lead and Lean angles to 0. 

4 Select the Tool axis limits option  to activate the Limits tab. 

5 Open the Limits tab. 

6 Select the Draw Limits option from the dialog. 
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7 Select view ISO 1. 

 

With the Draw Limits option selected a sphere will be displayed in the graphics 

window representing the angular machining limits available. 

Green indicates a machinable portion and Red a non-machinable portion. With 

the default settings selected the total machining range is covered so the whole 

sphere will be Green. 

Table – Table 

Both rotary axes operate on a table. 

 

With the above Table-Table machine tool the angular limits are specified as: 

X ± 30 

Z ± 360 

The machine tool Y limits are equivalent to the Azimuth angle or the angular limits 

normal to the XY plane. The Y limit of ± 360 translates to Azimuth angle limits of 

0 to 360. 

The machine tool X limits are equivalent to the Elevation angle above the XY 

plane. However they are not the same angle. This is best described using the 

diagram below. The machine tool measures the angular range relative to the Z Axis 

and PowerMILL measures it relative to the XY plane, therefore the angle required 

for the limit in PowerMILL is the complementary angle to the one given for the 
machine tool. 



PowerMILL 2016                                                                                                                             9. Tool Axis Limits 

Copyright @ Delcam Ltd                                                                                                                                         9 - 9 

 

This means that the X limit of ±30 translates to Elevation angle limits of 60 to 90. 

1 Retain the default Azimuth Angle and modify the Elevation Angle values in the form 

as shown below to update the machining limits. 

 

 

 

The Tool Axis Limits sphere has been visually updated with the modified values. 

An Alternative Table -Table machine tool has the following angular limits: 

X ± 100  

Y ± 360 

This translates to Azimuth Angle limits of 0 to 360 and Elevation Angle limits of   

–10 to 90. 

 

2 Modify the Elevation Angle values (-10 to 90) in the Angle Limits dialog to 

update the machining limits (as shown). 
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The Tool Axis Limits sphere has been visually updated with the modified values. 

Head – Head 

Both rotary axes move the head. 

 

With the above Head-Head machine tool the angular limits are specified as: 

X ± 60 

Z ± 360 

The machine tool Z limits are equivalent to the Azimuth Angle or the angular limits 

normal to the XY plane. In PowerMILL the Z limit of ± 360 translates to Azimuth 

angle limits of 0 to 360. 

The machine tool X limits are equivalent to the Elevation Angle above the XY 

plane. The angular range of the machine tool is relative to the Z axis, however 

PowerMILL measures it relative to the XY plane. Therefore the angle required for 

the limit in PowerMILL is the complementary angle to the one given for the 

machine tool. The X limit of ± 60 translates to Elevation Angle limits of 30 to 90. 

 

Alternative Head-Head machine tool angular limits: 

X –50 to +60 

Z ± 360 
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This translates to Azimuth Angle limits of 0 to 360 and Elevation Angle limits of 

30 to 90. In this case the machine tool limits across the XZ plane differ. 
PowerMILL will use the largest rotational value (+60). This is allowed by rotating 

the head 180º about Z to provide access to the maximum range +60 (which 

otherwise would be -50). 

1 Modify the Elevation Angle values (30 to 90) in the dialog to update the 

machining limits as shown. 

 

The Tool Axis Limits sphere has been visually updated with the modified values. 

Head – Table 

One rotary axis moves the head, and the other moves the table. 

 

With the above Head-Table machine tool, the angular limits are specified as: 

X ± 40 

Z ± 360 

The machine tool Z limits are equivalent to the Azimuth Angle or the angular limits 

in the XY plane. The Z limit of ±360 translates to Azimuth Angle limits of 0 to 
360. 

The machine tool X limits are equivalent to the Elevation Angle above the XY 

plane. It is the complimentary angle to the Elevation Angle. The X limit of ± 40 

translates to Elevation Angle limits of 50 to 90. 

1 Modify the Elevation Angle values (50 to 90) in the dialog to update the 

machining limits as shown below. 
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The Tool Axis Limits sphere has been visually updated with the modified values. 

Applying tool Axis limits on a Steep Sidewall base Fillet 
1 Select File - Delete all and Tools - Reset Forms. 

2 Import the Model:  

...\PowerMILL_Data\five-axis\punch2\punch2_insert.dgk 

 

3 Select File > Save Project As: 

...\COURSEWORK\PowerMILL-Projects\Punch2-ToolAxisLimits 

 

4 Create a Diameter 20 Ballnose tool - Length 50 - named BN20. 

5 Add a Shank component - Upper Dia 20 - Lower Dia 20 - Length 40 

6 Add a Holder component - Upper Dia 70 - Lower Dia 40 - Length 40 

7 Add a Holder component - Upper Dia 70 - Lower Dia 70 - Length 60 - Overhang 

80 

8 Calculate a Block using Defined by - Box and Type - Model. 

9 Calculate the Rapid Move Heights using the default settings. 
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10 Select the fillet running around the base of the main component sidewalls. 

 

11 Select the Toolpath Strategies icon  and in the Strategy Selector - 

Finishing options select the Surface Finishing. 

12 Input data into the Surface Finishing dialog exactly as shown: 

 

� Toolpath name:  BN20-Fillet-FIN 

� Stepover:  0.5 
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� Pattern Direction: U 

� Spiral: Ticked 

 

13 Select Calculate to create the Surface Finishing toolpath. 

 

� The Tool Holder is in Collision with the Base. 

14 From the local toolpath menu, select Verify – Toolpath to open the Toolpath 

Verification dialog. 

15 Un-tick both Split Toolpath and Adjust Tool. 

16 Then check for Collisions using a Shank Clearance of 1 and a Holder 

Clearance of 2. 
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� The Tool Holder is also in collision with the Sidewall. 

�  During Projection Surface Finishing the tool (BN20) is aligned normal to 

the Fillet Surface (if default Lead\Lean 0 is applied). This is creating a 

Collision situation with both the sidewall and the base. Tool Axis limits will 

be applied to prevent this immediate problem as well as to keep the tool 
alignment within the machine tool rotary limits. 

 

17 In the PowerMILL explorer, right-click the toolpath, BN20-Fillet-FIN, and 

select Settings to re-open the Surface Finishing dialog. 

18 In the Surface Finishing dialog select  to create a ‘copy’ and enter the 

toolpath name BN20-Fillet-FIN-LIM30.  

 

19 Tick Tool Axis limits and move to the Tool axis limits page. 

20 In Mode, select Move tool axis and for Elevation angle input:-  Start 30 and 

End 60. 

21 Select Calculate to create the new toolpath. 
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With the Tool Axis Limits applied the alignment will be restricted to operate 
between 30 and 60 degrees (Elevation Angle) relative to the XY plane. The 

sphere displaying the Tool Axis alignment limits (shaded green and pink) 

becomes visible when the box labelled Draw Limits is ticked.  

 The two illustrations below show the toolpath with the tool attached on 

the upper and lower tracks and the effect of the specified limits. 

 

 

� The Tool Holder is no longer in collision with the Base or Sidewalls. 

22 Save the Project. 
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Applying Tool Axis limits to maintain a 4-Axis toolpath. 
1 Select File - Delete all and Tools - Reset Forms. 

2 Open the ‘read only’ Project: 

....\PowerMILL_Data\five_axis\Tool_Limit\FixTo4Axis_Start 

 

3 Select File > Save Project As: 

....\COURSEWORK\PowerMILL-Projects\FixTo4Axis-example1 

 

4 If not already displayed, from the main pull down menus select View - Toolbar 

and tick Machine Tool. 

5 In the PowerMILL explorer open the Machine Tools folder and activate the 

RotaryMachine (double left click the icon   ). 

 

6 Input workplane 1 as the Machine Tool output datum. 

7 Select an ISO 2 view. 
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The Project contains a model of a 4-Axis Rotary Machine and two toolpaths. 

The first toolpath is inherently 4 Axis while the second toolpath is 5 Axis. 

The Rotary Machine is unable to produce the Tool Axis moves required by the 

second Five Axis toolpath. This toolpath can however easily be converted to 

4-Axis using the Tool Axis Limits options. 

 

8 In the PowerMILL explorer, right mouse click on the toolpath                  

BN16-Base-SEM1 and select Activate followed by Simulate from Start. 

9 Click the Play  button and the simulation successfully runs all the way to the 

end. 

 

10 In the PowerMILL explorer, right mouse click on the toolpath BN16-Form-

SEM2 and select Simulate from Start. 

11 Click the Play  button and the simulation immediately fails to proceed with 

the following message being displayed. 

 

As the toolpath is fully Five Axis it impossible for the Rotary Machine to 

perform a simulation. 

 

12 Abandon the simulation. 

13 Right mouse click on the toolpath BN16-Form-SEM2 and from the local menu 
select Activate it before selecting Settings to open the Projection Surface 

dialog. 

14 In the Projection Surface dialog select the Recycle toolpath option . 
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15 In the local explorer select Tool axis and tick the Tool axis limits box. 

 

The Tool axis limits page will become available in the local explorer. 

 

16 Select the Tool axis limits page and enter data exactly as shown below. 

 

 

With Project to plane ticked the Tool axis limits are flattened to create a 4 

axis limit (about the global transform in this case). A zero Damping angle will 

ensure that the 4 axis alignment is fully maintained. 

 

17 In the Tool axis limits page, un-tick Draw limits. 

18 With the 3D form, surface selected Calculate the new 4-Axis toolpath. 
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19 In the local explorer, right mouse click on Rotary Machine and from the local 

menu select Go Home. 

20 From the PowerMILL explorer, right mouse click on the new toolpath BN16-

Form-SEM2 and from the local menu select Simulate from Start. 

21 Click the Play  button and the 4-Axis toolpath simulation successfully runs all 

the way to the end. 

 

 

22 Save the Project. 
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Exercise 1 
1 Select File - Delete all and Tools - Reset forms. 

2 Open the ‘read only’  Project: 

...\PowerMILL_Data\five_axis\Punch3\Punch3_Start 

 

3 Save the Project As:- 

      ...\COURSEWORK\PowerMILL_Projects\Punch3_EX1 

 

The Project contains a Steep and Shallow Finishing toolpath BN16-StpShlw 

with a Tool Axis set to Vertical. The Tool is too short to safely machine some 

areas of the sidewalls. These potential collisions are avoided by the using 

Automatic verification (Shank clearance 1 and Holder clearance 5). 

The upper base surface is set with Machining Mode as Collision with a 

Thickness value of 0.5. 

 

The object of the exercise is to create 2 copies of the existing toolpath the first 

with a suitable Toward Point - Tool Axis alignment applied and the second 

that is further limited to being 4 Axis only (applied about the X axis). 
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4 Activate the toolpath BN16-StpShlw and from the local menu select Settings to 

re-open the strategy dialog. 

5 Create a Copy of the toolpath and rename it as BN16-StpShlw_TwdPt 

6 Select the Tool Axis page and select the option, Towards Point with the X Y Z 

positional values as 0 50 -350. 

 

7 Calculate the new toolpath. 

 

With a suitable Toward Point - Tool Axis alignment applied the Tool is now 

angled away from the sidewalls providing collision free access to the deeper 

areas. 
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8 Activate the toolpath BN16-StpShlw_TwdPt and from the local menu select 

Settings to re-open the strategy dialog. 

9 Create a Copy of the toolpath and rename it as BN16-StpShlw_TwdPt_4Axis 

10 Select the Tool Axis page and tick the Tool axis limits box. 

11 Select the newly appeared Tool axis limits page in the local explorer and input 

the data into the dialog exactly as shown below. 

 

12 Calculate the new toolpath. 

 

This strategy is limited to operate as 4 Axis only. 

 

13 Save the Project. 
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Exercise 2 
14 Select File - Delete all and Tools - Reset forms. 

15 Open the ‘read only’  Project: 

...\PowerMILL_Data\five_axis\joint_5axismc\JointAxisLimits_Start 

 

16 Save Project As:- 

      ...\COURSEWORK\PowerMILL_Projects\JointAxisLimits-EX1 

 

The Project contains a Surface Finishing toolpath with a Tool Axis setting of 

Lead 0 and Lean 0. This causes the Tool to be aligned to the surface normals 

at all points on the toolpath adjacent to the selected surface. The tool 

alignment is not prevented from exceeding the machine tool, rotary limits or to 

clear overhanging areas of the model.  

 

17 Recycle the Surface finishing on the selected Surface using Tool axis limits 

between Elevation Angles of 15 and 65 degrees using Mode - Move tool axis.  

18 Perform a toolpath Simulation followed by a full Gouge and Collision (Shank 

Clearance 2 – Holder Clearance 3) check on the modified Surfacing 

Finishing toolpath.  

 

19 Save the Project. 
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Introduction. 
In some applications the type of Tool Alignment option applied to a Five Axis 

strategy can result in unnecessary, exaggerated rotary movements while the cutter 

runs along a toolpath. 

In some cases, these exaggerated movements can result in Tool Holder or 

Machine Tool collisions. To reduce this, it is possible to edit the toolpath to have an 

alternative Tool Alignment within a user defined, area.  

1 Open ‘read only’ the Project: 

....\PowerMILL_Data \five_axis\ToolAxisEditing\EditToolAxis_Start 

 

The Project contains a Corner Along strategy created using a Dia 5 Ball Nosed 

tool with a Lean Angle of 45 Degrees applied. 

 

2 From the main pulldown menus select File > Save Project as: 

....\COURSEWORK\PowerMILL-Projects\EditToolAxis 

3 In the main pull down menus select View > Toolbars > Machine Tool to raise 

the Machine Tool definition toolbar. 

 

10. Tool Axis Editing 
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4 Click on the Import Machine Tool Model icon  and from the 

...\PowerMILL_Data\MachineData directory, select the file dmu50v.mtd. 

 

5 Input the workplane Base as the datum for the Machine Tool Simulation. 

6 Ensure the Draw\Undraw machine tool icon  is selected to display the 

machine tool. 

7 Select an ISO 1 view and zoom the machining area. 

8 Select Floor View  from the Simulation toolbar. 

9 Right-click on the toolpath BN5-Rest-Lean45 and from the local menu, select 

Simulate from Start. 

 

10 Move the simulation speed, slider to a slow setting and then click the Play icon 

and observe the machine tool movement. 

 

In addition to there being an excessive amount of table rotation while the 

undulating sidewall is machined there is also a Tool Holder collision on the 

sidewall internal corner (see above right graphic). 

 

11 From the local BN5-Rest-Lean5 toolpath menu, select Verify - Toolpath and 

in the dialog, un-tick both Split Toolpath and Adjust Tool. 

12 Select Check Collisions, with a Shank Clearance 1 and Holder Clearance 2 

and Apply the dialog.  

 

The Toolpath is now displayed red in the PowerMILL explorer confirming that 

the Shank and/or Holder are colliding with the model. 
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 The 2 issues will be fixed by applying localised Tool Axis alignment 

modifications on the toolpath. To enable normal viewing while the changes 
are made, the Machine Tool model will temporarily be removed from the 

Machine Tool Simulation toolbar. 

 

13 In the Machine Tool Simulation toolbar select None to remove dmu50v.mtd 

from the selection input box leaving it blank. 

 

 

14 Select a View from top ready for snapping the corners of a polygon to define 

the first area of the toolpath to undergo Tool Axis Editing. 

15 On the keyboard select Ctrl H to display the Cross Hair on the cursor position. 

16 In the PowerMILL explorer, right-click on the toolpath BN5-Rest-Lean45 and 

select Edit > Edit Within Region from the local menus to access the following 

dialogs. 

17 In the (default) Select Region dialog set Define Region By - Polygon and 

Side - Inner (as shown below left). 

 

 

18 Select the Specify Changes tab, and set Tool Axis as Fixed Direction and 

input a Blend Distance of 5, before selecting the Tool Axis icon . 
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19 Input values into the Direction vector (Along the tool axis) as:- 

I   0.0     J  -1.0     K  1.0 

20 In the Tool Axis dialog, tick the Draw Tool Axis box before selecting Accept 

(to return to the Edit Toolpath Within Region dialog). 

21 From the main pulldown menus select Draw > Cursor > Cross Hair. 

 This will display cross hairs running through the cursor position, to assist 

visual alignment when ‘snapping’ points. 

 

22 Click on the Select Regions tab to access the original options. 

23 Left-click to snap 4 corners of the Polygon inside where the Tool Axis Edit is to 

occur, and click Apply. 

 

The above illustration is at the stage where the user is ready to snap the 4th and 

final point on the Polygon (Cross hairs are mid grey). 
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24 Select an ISO 1 view and simulate the toolpath to observe that the Tool Axis 

Alignment is no longer performing a series of rotary movements along the 
undulating sidewall. 

 

25 Select a View from top. 

26 In the PowerMILL explorer, right-click on the toolpath BN5-Rest-Lean45 and 

select Edit > Edit Within Region to open the Edit Toolpath Within Region 

dialog again. 

27 In Select Regions select Polygon with Side - Inner, and then click the 

Specify Changes tab. 

 

28 Set Tool Axis - From Point with the coordinate values X-15 Y 25 Z-25, and 

then tick the box labelled Draw Tool Axis before selecting Accept. 
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29 This time snap 4 corners of the polygon to form a square, aligned as close as 

possible to the Tool Axis Alignment point, and click Apply. 

 

30 Select an ISO 1 view. 

31 From the local BN5-Rest-Lean5 toolpath menu, select Verify - Toolpath and 

in the dialog, un-tick both Split Toolpath and Adjust Tool. 

32 Select Check Collisions, with a Shank Clearance 1 and Holder Clearance 2 

and Apply the dialog.  

33 Select Check Gouges and Apply the dialog. 

The Toolpath is now displayed green in the PowerMILL explorer confirming 

that the toolpath is free of both Gouges and Collisions. 
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34 Simulate the toolpath to observe that with the new Tool Axis Alignment the 

tool holder is no longer in a collision condition with the sidewall internal 
corners. 

 

35 Perform a Machine Tool Simulation again using the DMU50V with the Floor 

View selected. 

 

This time the unnecessary, ‘rocking’ movements about the rotary axis are 

minimised and the Tool Holder collision removed. 

36 Select File - Save Project.
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Introduction 
The ability to check for potential Machine Tool - Component collisions is an 

essential requirement for Five Axis applications. To provide this capability 

PowerMILL contains an additional Machine Tool toolbar for use with the toolpath 

Simulation options.  

 

The standard Machine Tool Simulation is purely visual and it is the user’s 

responsibility to identify collisions. An additional, ‘cost option’ is available where the 

Machine Tool Simulation will stop if a collision situation is identified. At this point 

a warning box will be displayed. The tool along with the affected parts of the 

Machine Tool model will turn red, and once acknowledged (by clicking OK) all 

moves in a collision condition will be registered in a list. 

The individual component parts of a machine tool (eg; Main Body, Head, Rotary 

Table, Cradle, etc) are stored as a set of individual triangle models. These are 

registered within an mtd file that controls the orientation and position of the 

individual triangle models during a simulation. 

Three basic, multi-axis Machine Tool Simulation (.mtd) files are supplied within 

the PowerMILL installation data. A typical location for a C drive install: 

C:\Program Files\Delcam\PowerMILL13.0.06\file\examples\MachineData 

A further selection of sample mtd files, based on actual machine tools are located 

on the training PCs in: 

                 ….\PowerMILL_Data\MachineData 

 It is essential that all models along with controlling moves and limits used in 

a Machine Tool Simulation (.mtd) file are an accurate copy of the actual 

Post-Processor and machine tool in use. Due to design variations, different 

set up criteria, and tolerance issues, each Machine Tool Simulation (.mtd) 

file and associated models must be tailor made and fine-tuned for each 

individual application. 

1 Select File - Delete all and Tools - Reset forms. 

11. Machine Tool 
Simulation and 
Verification 
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2 Open the read only Project: 

....\PowerMILL_Data\five_axis\Collision_Simulation\Swarf_check 

 

3 Select File - Save Project As: 

....\COURSEWORK\PowerMILL-Projects\MCTool-simulation 

4 In the PowerMILL explorer, right mouse click the toolpath Outer Swarf and 

select Simulate from Start. 

 

5 The Simulation toolbar will appear (if it is not already displayed). 

 

 

6 In the PowerMILL explorer right mouse click on Machine Tools and from the 

local menu select Toolbar. 

 

 

7 Select the Import the Machine Tool Model icon  and select the file 

dmu50v.mtd from: 

            ….\PowerMILL_Data\Machine Data\DMU\dmu50.mtd  
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The MTD file contains the Positional and Rotational details for the individual, 

Machine Tool. 

It is normal practice to create the machine tool model, with the global datum 

(Transform) positioned at the Top - Centre of the table. 

The active cutting Tool is automatically positioned in the machine tool head. 

 

8 Ensure the Draw\Undraw machine tool icon  is selected to display the 

machine tool. 

9 Select an ISO 1 view and zoom into the machining area. 

10 Select the Floor View icon from the Simulation toolbar.  

 

11 Select Display the machine tool issues  from the Simulation toolbar.  

 

During a toolpath Simulation, the Machine Tool Simulation Issues dialog will 

display information on collision positions. 

With the Position tab selected machine tool positions will be displayed. The 

values on the left hand side refer to the Axis Address Letters and their 
associated values. 

This machine tool has five axes, A and B are rotary with X, Y and Z as linear. 

12 Start the Simulation  to observe the virtual machining of the component. 
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A collision has been detected and a PowerMILL Warning message displayed.  

The warning message is only displayed for the first collision.  

13 Select OK to close the PowerMILL Warning dialog. 

 

The first collision move is registered and displayed in the Issues found pane. 

At present only the first collision is displayed until the Simulation is continued. 

14 Continue the Simulation.  

 

 

On completion of the simulation the machine tool is displayed in the normal 

colour scheme. 
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15 Select a Collision Move from the list. 

 

The simulation will move directly to the selected position in the form so that 

the collision (top right corner of component) can be viewed. 

 

16 Select View and adjust the Machine Tool position  from the Simulation 

toolbar.  

 

The current positional values are displayed in the Machine Tool Position 

dialog. 
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With a clear view of the collision, the user can assess how best to make the 

appropriate changes to avoid it. In this case, substituting the cutter with one 
with increased Tool Length would be the easiest solution. 

 

17 In the PowerMILL explorer right mouse click on the tool D10TR3 and select 

Settings. 

 

18 Select the Holder tab on the tool dialog and modify the Overhang to 50. 

 

19 Close the dialog and in the PowerMILL explorer select Simulate from Start 

on the toolpath named ‘Outer Swarf’. 

 

20 Select Switch on the Machine Tool Display  from the Simulation 

toolbar.  

21 Select the Collisions tab on the dialog. 

22 Select Clear on the dialog to clear any existing collisions. 
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23 Start the Simulation . 

 

The Machine Tool Collisions dialog remains blank indicating that no collisions 

have been detected. 

 

24 Select File > Save Project. 

25 Select File – Delete All and Tools – Reset Forms. 
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NCProgram Verification (Including a Machine Tool Model) 
 

It is possible to Verify the whole contents of an NC Program including an option to collision 

check a Machine Tool Model. 

 

1 Open the read only Project: 

              ....\PowerMILL_Data\five_axis\Collision_Simulation\AnglePockets-FullVerify_Start 

 

Select File - Save Project As: 

                        ....\COURSEWORK\PowerMILL-Projects\AnglePockets-FullVerify 

 

2 In the PowerMILL explorer right mouse click on Machine Tools and from the 

local menu select Toolbar. 

 

 

3 Select the Import the Machine Tool Model icon  and select the file 

PMPOST-CMS_Ares48-18.mtd from: 

                   ….\PowerMILL_Data\MachineData\CMS\......  
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4 In the PowerMILL explorer right mouse click on the Machine Tool PMPOST-

CMS_Ares48-18 and fro the local menu select Settings. 

 

5 In the dialog, select Part and move the Opacity slider fully to the left to make 

the static machine tool parts almost invisible. 

6 Apply and Accept the dialog. 
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7 In the Machine Tool toolbar select the Workplane MC-Table-location. 

 

 

8 In the PowerMILL explorer, right mouse click the NC Program named          

All-Pkts-plus-RetrackMoves-1 and from the local menu select Simulate 

from Start. 

 

 

 

 

9 In the simulation toolbar set the speed slider to medium before selecting Play. 

 

 Observe that the total CMS machine’s Head rotation (C Axis) is currently 450 

degrees (This CMS has a maximum C axis rotation limit of 360 degrees). 

 

10 Right mouse click on the NC Program All-Pkts-plus-RetrackMoves-1 and 

from the local menu select Settings to open the NC Program dialog. 

11 In the Machine Tool box select the PMPOST-CMS_Ares48-18 and for Model 

Location select MC-Table-location. 



PowerMILL 2016                                                                                                                  11. Machine Tool Simulation 

Copyright @ Delcam Ltd  11 - 11 

 

12 At the base of the dialog select Apply followed by Accept. 

13 In the PowerMILL explorer right mouse click on the NC Program  

All-Pkts-plus-RetracMoves-1 and from the local menu select Verify. 

14 In the NC program verification dialog input the Machine Tool, Holder, Shank 

clearances as 5 2 and 1 respectively before selecting the Verify tab. 

 

 

In the above NC Program dialog it has been reported that one of the toolpaths is 

causing the rotary limits to be exceeded. This CMS machine tool can only perform a 

total of one 360 Degrees rotation about the C axis. The total of C Axis rotation 

currently required by the NC Program is 450 Deg.  
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This can be fixed by using a different positional move toolpath at the ends of the NC 

Program that will start well within the main machining areas and re-track the tool 

back to the original start position. 

 

15 In the PowerMILL explorer right mouse click on the NC Program  

All-Pkts-plus-RetracMoves-1 and from the local menu select Clear 

Verification. 

16 In the NC Program All-Pkts-plus-RetracMoves-1 replace the common first 

and last positioning toolpath (Pkt4-Pkt1-C) with Pkt2-Pkt1 and Pkt4-Pkt1-CC 

respectively. 

 

The replacement toolpaths preform repositioning with counter clockwise rotation 

about the C axis. This will keep the total C rotation moves well within the CMS 
machine limits. 

 

17 In the PowerMILL explorer right mouse click on the updated NC Program 

All-Pkts-plus-RetracMoves-1 and from the local menu select Verify. 
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This time all toolpaths are displayed with a green verification status  and no 

issues are reported in the NC program verification dialog. The green status also 

confirms that within the NC Program the Machine Tool is collision safe in addition 

to the included, gouge free toolpaths.  

 

18 Run another NC Program simulation and observe that this time the whole 

process is now contained within a total C axis rotation of 270 degrees (max 

permissible 360 degrees). 

 

 

19 Select File > Save Project. 

20 Select File – Delete All and Tools – Reset Forms. 
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Introduction. 
The PowerMILL verification options will ensure collision safe, toolpaths relative to 

the Tooling components. However, In 5 Axis applications it is also essential to 

check that the actual moving parts of the Machine Tool are also collision safe. For 

this to work effectively, a suitable machine tool model (MTD file) is required in the 

simulation process. If a collision between the component part and machine tool 

model is detected then the user can recycle the strategy with appropriate Machine 

Axis Control options applied. 

Machine Axis Control options allow the user to avoid collisions by controlling the 

orientation/movement of the independent parts of a machine tool within the 
machining strategy.  

Machine Axis Control is not just used for collision avoidance but can also be used 

to enable an oversized component to be machined by applying Polar to force the 

use of a rotary axis in preference to a linear axis. This option can also used in 

cases where it is simply more efficient for a specific machine tool to use a rotary 

axis in place of a linear axis. 

Tool Axis Control - Re-Orientation - Example  
1 Open ‘read only’ the Project: 

….\PowerMILL_Data \five_axis\MachineAxisCtrl\CMS-AxisControl_Start           

 

2 From the main pull down menus select File > Save Project as: 

….\COURSEWORK\PowerMILL-Projects\ CMS-AxisControl-ex1 

12. Machine Axis Control 
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The Project contains 2 NC Programs that contain the same machining 

toolpaths. If the NCProgram No-OrientationMoves is run in a machine tool 
simulation the Machine Tool Head clashes with the component.  

 

If the NCProgram With-External-OrientationMoves is run in a machine 

tool simulation there are no collisions between the machine tool parts and 

component. This is due to the addition of repositioning toolpaths inserted as 
necessary to provide machine tool head re-orientation.    

 

Although the last NC program provides an acceptable collision free solution the 

method is labour intensive and dependant on the user correctly creating and 

inserting positional move toolpaths in the correct order. 

 

3 Select an ISO 2 view. 

4 In the PowerMILL explorer right mouse click on Machine Tools and from the 

local menu select Toolbar. 

5 Input Base-Centre in the workplane input box of the Machine Tool toolbar. 

6 In the Machine Tool toolbar input the machine tool model:- 

....\PowerMILL_Data\MachineData\CMS\PMPOST-CMS_Ares48-18.mtd 
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7 In the PowerMILL explorer, right mouse click Machine Tools > PMPOST-

CMS_Ares48-18, to open the local menu. 

8 In the local menu select Settings. 

 

9 In the dialog select the item, named Part and then move the Opacity slider to 

make the static part of the machine tool model, translucent. 

 

10 Accept the Machine Tool dialog. 

11 In the PowerMILL explorer, right mouse click on the NC Program              

No-Orientation Moves and from the local menu select Simulate from Start. 

12  Select the Play button in the simulation toolbar. 

 

After several passes the machine tool head is in collision with the component. 

The machine tool head changes colour to red and a PowerMILL Warning box 

appears as soon as the first collision is detected.  

13 Select OK and the simulation will continue even though the head is still colliding 

(The head will change colour to red during each collision).  

 Collision checking and reporting to a Machine Tool Model simulation is a cost 

option. Otherwise the checking process is purely visual. 
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When the NC Program simulation moves to the other side of rib, the machine 

tool head happens to be in a collision safe, orientation relative to the 

component. This is not easily predictable and could easily change to a collision 

situation on switching the order or inserting new toolpaths into the NC 

Program. 

14 In the PowerMILL explorer, right mouse click on the NC Program              

WithExternal-OrientationMoves and from the local menu select Simulate 

from Start. 

 

This time the machine tool head is collision safe throughout the simulation. 

 

In this case, drive curve toolpaths have been inserted as required into the NC 

Program to force appropriate re-orientation moves to occur. 

The only problem is that these moves are added retrospectively and as 

mentioned earlier, will be unpredictable if the toolpath order is changed or 

additional toolpaths are inserted into the NC Program. 

A more efficient and direct method to apply machine tool head alignment within 

an individual strategy is to use the Machine axis control dialog.  
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15 Ensure that neither NC Program is active. 

16 Activate and then select Settings from the local menu for toolpath 
No_Orientation_1. 

17 In the Constant Z strategy dialog, select Make a Copy   and rename the 

new toolpath as Orientation_AZ180. 

18 Select the Machine axis control page in the dialog and select the Orientation 

type as Orientation vector, Orientation vector as Fixed direction, and input 

a Direction - Azimuth 180. 

 

By changing the default Orientation type from Free to Orientation vector the 

machine head alignment will now be controlled directly within the strategy. The 

Machine axis control will cause the head to be rotated by 180 Degrees about 

the Z axis compared with the original toolpath. 

19 Select Calculate to create the new toolpath and close the dialog. 

20 Activate and then select Settings from the local menu for toolpath 

No_Orientation_2. 

21 In the Constant Z strategy dialog, select Make a Copy  and rename the 

new toolpath as Orientation_AZ0. 

22 Select the Machine axis control page in the dialog and enter data exactly as 

shown below but this time with Direction - Azimuth 0. 

 

The Machine axis control will use the default values for an Orientation 

Vector of Azimuth 0 and Elevation 0. 

23 Select Calculate to create the new toolpath and close the dialog. 
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24 Create a new NC Program named Internal-OrientationControl containing the 

2 new toolpaths Orientation_A180 and Orientation_A0. 

25 With the machine tool model, PMPOST-CMS_Ares48-18 still active, run a full 

simulation on the new NC Program and check that the head movement is 

collision free throughout. 

26 Reverse the order of the toolpaths in the NC-Program named Internal-

OrientationControl and run the full simulation again and check that the head 

movement is collision free throughout. 

 

The application of Machine axis control directly in the strategies has 

eliminated the need for the additional positioning toolpaths. As shown in the 

above illustration, the machine axis control is now independently controlled 

within the 2 new strategies.  

 

 

 

 Dynamic Machine Control (Requires the Advanced 
Simulation cost option) 

 

The Dynamic Machine Control options  are accessed from the Machine Tool 

toolbar. 

 

 

It is possible to apply machine axis control dynamically using options from the 

Dynamic machine control toolbar (shown below).  
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Visual checking for Machine Tool accessibility 

The active Tool and Machine Tool head can be dynamically moved around the 

part to visually check for accessibility relative to the current orientation 

 

1 In the PowerMILL explorer right mouse click on the Toolpath 

No_Orientation_2 and select Simulate from start. 

2 Jog the tool to the start of the fixed machining alignment position and then from 

the Machine Tool toolbar select The Dynamic Machine Control.  

 

 

3 In the Dynamic machine control toolbar select use tool positioning 

graphics.  

4 Left click on the tip of the Tool and then dynamically move it down the angled 

model, undercut towards the base of the recess. 
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5 Rotate the view to observe the new position from different angles. 

 

 

6 Dynamically drag the Tool to a ‘key point’ on the opposite side of the model. 

 

If any part clashes with the model the machine tool head will change colour to 

red. 

7 Select the green tick  at the end of the Dynamic machine control toolbar 

to exit with the tool still displayed in the final position.  

 

 The above final Tool position is cancelled if a new Toolpath simulation 

is selected, or if Go Home is selected in the Machine Tool menu. 

 

 If the red cross  is selected then the tool will be positioned as it was 

before the Dynamic machine control toolbar was opened. 
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Dymamic Machine Tool re-orientation applied to a Toolpath. 

 

 

The default setting in the Dynamic machine control toolbar is Use machine 

tool graphics. 

The rotary axis components of the machine tool can be dynamically re-

orientated and applied retrospectively to the active toolpath. 

Other options include:- 

a Use machine tool graphics  - Applies dynamic rotation and linear 

moves relative to the Machine Tool model datum (Default). 

b Active workplane graphics mode  - Applies dynamic rotation and 

linear moves relative to the active workplane. 

c Lock tool axis direction  - This locks the current rotary axis orientation, 

allowing only dynamic linear axis, moves to take place when used with a or b 

above. 

  

1 From the local PowerMILL explorer - Toolpaths, right mouse click on 

No_Orientation_1 and from the local menu select Edit - Copy Toolpath. 

2 Rename the new Toolpath as Dynamic_Orientation_1. 

3 Activate the new toolpath and run a Machine Tool simulation until the 

collision with the Head is first detected.   

 

 

4 Select OK in the PowerMILL Warning dialog. 
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5 On the Machine Tool, toolbar select Dynamic machine control . 

 

6 Use the default Use machine tool graphics option . 

 

 

7 Use the upper circular handle to rotate the head to the above left, alignment, 

followed by the lower circular handle to re-orientate the tool to the above right 
alignment. 

8 Once a suitable Machine Tool Orientation has been achieved select the 

Update Toolpath  option. 

9 Select the green tick to accept the changes and close the Dynamic machine 

control toolbar. 

 The toolpath is now displaying gouge and collision status as Unknown. 

 

 

 

10 Verify the modified Toolpath Dynamic_Orientation_1 for both Gouges and 
Collisions (Clearances:- Holder 2 and Shank 1). 

 

 

The Toolpath is now confirmed to be both Gouge and Collision safe relative to 

the Tool assembly.  
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11 Right mouse click on the machine tool model and from the local menu select 

Collisions. 

 

 

 

 

12 In the dialog input a suitable clearance value for the Machine Tool head. 

13 Clear the issues found, list and perform further machine tool simulation to 

confirm that the Head assembly also collision safe. 

 During a simulation the machine tool Head will change colour yellow if a 

collision situation is identified. 

 

14 Save the Project. 

15 Select File - Delete All and Tools - Reset Forms. 
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Tool Axis Control - Polar - Example  
The start up Project contains a BN16 tool, 3 Axis toolpath, Mazak Variaxis 

Machine Tool model, and component model. The component model has a 

length dimension that exceeds the X axis and maximum Y, travel limits for the 

Mazak machine. However the model could be machined in 4 stages if the longest 

dimension, is controlled to align within the minimum Y axis travel limits. This 

will be achieved by applying the Tool Axis Control – Polar options to convert 

all X linear moves to C Axis, rotary moves (about the Z Axis). 

 

1 Open ‘read only’ the Project: 

...\PowerMILL_Data \five_axis\MachineAxisCtrl\Mazak-OversizeCompt_Start           

 

2 From the main pull down menus select File > Save Project as: 

...\COURSEWORK\PowerMILL-Projects\ Mazak-OversizeCompt-ex1 

 

3 In the PowerMILL explorer - Machine Tools area, activate the machine tool 

model, PMPOST-Mazak_Variaxis_630PSA. 

4 From the main pull down menus select View – Toolbar and from the resultant 

menu ensure that the Simulation, and Machine Tool options are all ticked. 

5 In the Machine Tool toolbar, input the machine tool named PMPOST-

Mazak_Variaxis_630PSA and the workplane named TableDatum. 
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6 In the PowerMILL explorer right mouse click on the Machine Tool - 

PMPOST-Mazak_Variaxis_630PSA and from the local menu select Settings. 

 

7 In the dialog, select A and move the Opacity slider to the left until the moving 

parts can be clearly seen behind the opaque, static parts of the Machine Tool 

Model. 

8 From the PowerMILL explorer, right mouse click on the existing toolpath and 

from the local menu, select Simulate from Start. 

 

9 In the Simulation toolbar, select the Play button and the following PowerMILL 

Error dialog will open. 

 

The X co-ordinates at the ends of the above toolpath are outside the X axis, 

travel limits. Note, the travel limits are included in the machine tool model 

definition. 
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10 In the PowerMILL explorer, right mouse click on the existing toolpath and 

from the local menu select Activate followed by Settings to open the dialog. 

11 In the Line Projection Finishing dialog select the ‘make a copy’ option . 

12 In the dialog, Rename the new toolpath as BN16-Vert-Orientation-Polar_A. 

13 In the local dialog explorer, select the Machine axis control page and input 

data as shown below. 

 

14 Select the icon  to change to the links page and input data with Use polar 

links - ticked as shown below. 

 

15 Calculate the dialog to create the new toolpath. 
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16 From the PowerMILL explorer, right mouse click on the new toolpath and from 

the local menu, select Simulate from Start. 

 

17 In the Simulation toolbar, select the Play button and this time the strategy will 

successfully run from start to end. 

 

 

All the X-Axis cutting moves in the original toolpath have been converted to C-

Axis rotary moves in the new toolpath. This has resulted in tool moves being 

confined to the area from the table centre towards the min Y travel limit. 

18 Select File - Save Project. 

 

Exercise 
1 Create a copy of the above toolpath named BN16-Vert-Orientation-Polar-B.  

2 Calculate after inputting the appropriate data to finish machine the other half of 

the component model keeping within the Tool Axis limits for the Mazak 

machine tool. 

3 Select File - Save Project. 
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Introduction. 
The PowerMILL toolpath simulation process can be expanded to include a 

Machine Tool Model. This capability becomes extremely important for multi-axis 

applications. 

First of all triangle models (eg dmt or stl format) need to be obtained of all the 

independent moving parts of the machine tool. It is essential that the user obtains 

accurate dimensions along with any other details relating to the set up of a specific 

machine tool.  

These separate Triangle files are stored in a folder adjacent to a Machine Tool 

Simulation schema file (mtd) 

To create a new mtd file it is easier to modify a copy of an existing one based on a 

machine tool of similar configuration. 

It is essential that the kinematics of a Machine Tool Simulation model, is the 

same as the relevant Post-Processor output. 

How to configure a Machine Tool for simulation 
The first stage is to create the separate component models (ideally in 

PowerSHAPE) for each moveable axis for the machine tool. These must be 

exported as individual triangle models to be compatible for use in an mtd file. For 

the following example the models have already been created and are ready to be 
registered to a new mtd file. 

 

An mtd file contains information that describes the kinematics of a particular 

machine.  

For mtd files to work, they must be accompanied in the same folder by the schema 

file, pmillmt.xsd. 

In the same location, a sub-folder must exist that contains separate triangle 

models dmt of all the necessary static and moving machine tool components.  

 

13. Machine Tool Models  
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Machine Tool Model for a dmu80t Five Axis  

 

The above illustration identifies 6 separate triangle models that form a dmu80t 

five axis machine tool. Also shown are the vertical distances from the top of the 

table to the base of the head (421.6716), and the centre of the rotational axes 

(925.00). 

machine_part 

The mtd file is made up of objects called machine_part. There are 2 compulsory 
machine_part objects which must be identified as “head” and “table”. Note; their 

names in the mtd file must be in lower case. 

In the above machine tool the X, Y, and A axis (rotation about Y) are controlled on 

the “head”, and the Z and B axis (rotation about Z) are controlled on the “table”. 

Linear Axis Controls 

X, Y, and Z must exist and only right handed axis systems are supported. 

These can be in any orientation as long as they are orthogonal. 

Type of axis that can be configured is:- 

Simple_linear:- The definition requires direction. 

Rotary Axis Controls 

Rotary controls are typically defined by A, B, or C and ideally should be selected to 

match the same output as output in the associated Post-Processor. Note; where 

applicable, angular limits can be assigned to an individual rotary axis.   

Type of axis that can be configured is:- 

 simple_rotary:- The definition requires position and direction. 
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MTD file initial state 

Although all the separate triangle models are correctly positioned relative to the 

assembled machine tool model, it is still required to input key dimensions into the 

mtd file. In this example, these include the ‘gauge’ distance from the top of the 

table (0 0 0) to the base of the head (0 0 421.6716), and the coordinates of the 

centre of the rotary axes (0 0 925). 

EXAMPLE:- MTD file for a Mazak five axis machine 
 

1 Select File - Open Project:- 

....\PowerMILL_Data\five_axis\MachineToolModels\MTD-Mazak-Ex1_Start 

 

2 Select File – Save Project As:- 

....\COURSEWORK\PowerMILL_Projects\MTD-Example1 

 

A Machine Tool Model will be loaded into the above Project that correctly 

defines:- 

a The position of all the separate machine tool components. 

b The direction of rotation for the 2 rotary and +/- movement for the 3 linear 

axes. 

c The max/min travel limits for each of the 5 axes. 

 

3 From the main pull down menus select View – Toolbar – Machine Tool to open 

the Machine Tool toolbar (Or alternatively right click on Machine Tools in the 

PowerMILL explorer and from the local menu select Toolbar). 

 

In the Machine Tool toolbar select the Import Machine Tool Model  option. 
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4 In the dialog select the Machine Tool Model file:- 

….\PowerMILL_Data\five_axis\MachineToolModels\PMPOST-

Mazak_Variaxis_630PSA.mtd 

 

 

5 In the PowerMILL explorer right mouse click on the Machine Tool Model 

name PMPOST-Mazak_Variaxis_630PSA and from the local menu select 

Activate followed by Settings. 

 

 

6 In the Machine Tool dialog select Part. 

 

 

7 Move the Opacity slider to the left until the Machine Tool Body is almost 

invisible. 
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8 Right mouse click on the toolpath EM12-FinPkts and from the local menu select 

Simulate from Start. 

9 In the Machine Tool toolbar select the Machine Tool Display  options. 

 

10 Select the Cursor on the X row slider and drag it to the required position, and/or 

use the keyboard arrow keys for exact 0.5 incremental moves. 
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11 On the keyboard hold while holding down the Shift key, press the left hand 

Arrow key to perform continuous, incremental -ve X moves on the machine 
tool model.  

 

12 Repeat 8, but this time, while holding down the Shift key, press the right hand 
Arrow key to perform a +ve X move on the machine Tool Model. 

13 On the keyboard press the downward, Arrow key to move down to the next row 

(or simply click on the Y row, cursor).  

14 As in 8 and 9 above check the -ve and +ve Y moves on the Machine Tool 

Model. 

15 Systematically move down the rows and check out the movement of the 

remaining 3 axes on the Machine Tool Model. 

 

 

 

 

The above movements are exactly the same as on the actual Mazak machine 

tool to which the MTD file relates. 

A full simulation will provide a visual confirmation of the all moves performed 

on the toolpath. It is also possible to check for Machine Tool component 

collisions (if an additional cost option is purchased). 
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16 Close the Machine Tool Position dialog and then perform a full Simulation on 

the toolpath EM12-FinPkts. 

 

17 In the PowerMILL explorer right mouse click on the machine tool, PMPOST-

Mazak_Variaxis_630PSA and from the local menu select Go Home. 

 

Correcting a faulty MTD File:- 

18 In the Machine Tool toolbar select the Import Machine Tool Model  

option. 

19 In the dialog select the Machine Tool Model file:- 

….\PowerMILL_Data\five_axis\MachineToolModels\PMPOST-

Mazak_Variaxis_630PSA-Faulty.mtd 

 

20 As before open the Settings dialog from the local menu and turn down the 

Opacity of the non-moving parts of the Machine Tool Model. 

21 In the dialog select Open to import the new Machine Tool Model. 

 

The newly imported Machine Tool Model file should perform exactly as the 

existing one. However the MTD file contains some incorrect values which need 
to identified and fixed. The user will need to systematically check the linear and 

rotary axis movements and the relative location of the trunnion and rotary table.  

 

22 In the Machine Tool toolbar select the Machine Tool Display  option. 

23 Use the Jog options to check the +ve and –ve movement of all 5 axes (They 

should be the same as the Machine Tool Model imported with the original 

Project). 
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 The following C-Axis faults are exposed in the currently active MTD file:- 

 

a The +ve/-ve rotational moves for the Rotary Table - C-Axis are reversed 

compared with the Machine Tool Model imported with the original Project. 

b The Rotary Table rotational centre (C-Axis) is incorrectly aligned at some 

point along the active Workplane, Y direction. 

 

24 From the Desktop open a File Explorer dialog and browse to the folder:- 

….\PowerMILL_Data\five_axis\MachineToolModels 

25 Create a copy of the mtd file:- PMPOST-Mazak_Variaxis_630PSA-Faulty.mtd    

and rename it as:-  PMPOST-Mbazak_Variaxis_630PSA-Update.mtd 

 If an MTD file of the same name already exists overwrite it. 

 

26 Open the new copy of the mtd file in Wordpad and look for incorrect data in the 

section of the mtd file that defines the Rotary Table – C-Axis. 

<machine_part> 

<axis> 

<control_info ADDRESS="C" /> 

<simple_rotary X="0" Y="250" Z="0" I="0" J="0" K="-1" /> 

</axis> 

<model_list> 

<dmt_file> 

<path FILE="Mazak_Variaxis_630/table.dmt" /> 

<rgb R="200" G="200" B="200" /> 



PowerMILL 2016                                                                                                                                          13. MTD files 

Copyright @ Delcam Ltd                                                                                                                                        13 - 9 

 

The previous row that defines the C-Axis requires the XYZ position to be in the 
centre of the table, and the +ve/-ve rotation directions to be reversed. 

 

27 Modify the above incorrect values to those shown below:- 

<simple_rotary X="0" Y="0" Z="0" I="0" J="0" K="1" /> 

 

28 Save the updated mtd file (but do not close it). 

 This latest update will now be tested in the PowerMILL Project. 

29 In the Machine Tool toolbar select the Import Machine Tool Model  

option. 

30 In the dialog select the Machine Tool Model file:- 

….\PowerMILL_Data\five_axis\MachineToolModels\PMPOST-

Mazak_Variaxis_630PSA-Update.mtd 

 

 

31 Turn down the Opacity on the static parts of the Machine Tool model. 

32 In the Machine Tool toolbar select the Machine Tool Display  option. 

33 Use the Jog options to check the +ve and –ve movement of the Rotary Table – 

C-Axis. 

 

The updated Rotary Table – C-Axis movement is now exactly the same as in 

the original Machine Tool Model (PMPOST-Mazak_Variaxis_630PSA). 
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The next stage is to use a Simulation to check that all of the linear and rotary 

travel limits on the Machine Tool Model are correct. 

 

34 Right mouse click on the toolpath EM12-FinPkts and from the local menu select 

Simulate from Start. 

35 On the Simulation toolbar select the Play  button.  

 

Not only has the Trunnion unexpectedly rotated towards the back of the 

machine but the Simulation has also stalled due to one of the travel limits 

being exceeded.  

 It cannot be assumed that these are due to the same error in the mtd file. 

36 Return to the file in Wordpad and look for incorrect data in the section of the 

mtd file that defines the Table – A-Axis. 

 

 <!-- The table --> 

 <machine_part> 

 <axis> 

 <control_info ADDRESS="A" MIN="-30" MAX="120" /> 

 <simple_rotary X="0" Y="0" Z="50" I="-1" J="0" K="0" /> 

 </axis> 

 <model_list> 

 <dmt_file> 

 <path FILE="Mazak_Variaxis_630/Trunion1.dmt" /> 

  <rgb R="210 " G="210" B="255" /> 

 

The above row that defines the A-Axis rotational travel limits and simply requires 

the MIN and MAX numbers to be swapped (The correct movement for +ve and -

ve rotation has already been checked and confirmed to be okay). 

 



PowerMILL 2016                                                                                                                                          13. MTD files 

Copyright @ Delcam Ltd                                                                                                                                        13 - 11 

37 Modify the above incorrect values to those shown below:- 

<control_info ADDRESS="A" MIN="-120" MAX="30" /> 

 

38 Save the updated mtd file (but do not close it). 

 This latest update will now be tested in the PowerMILL Project. 

 

39 In the PowerMILL explorer right mouse click on the Machine Tool PMPOST-

Mazak_Variaxis_630PSA-Update and from the local menu select Delete. 

 It is necessary to re-import the updated MTD file into the Project. 

40 In the Machine Tool toolbar select the Import Machine Tool Model  

option. 

41 In the dialog select the Machine Tool Model file:- 

….\PowerMILL_Data\five_axis\MachineToolModels\PMPOST-

Mazak_Variaxis_630PSA-Update.mtd 

 

42 Turn down the Opacity on the static parts of the Machine Tool model. 

43 Right mouse click on the toolpath EM12-FinPkts and from the local menu select 

Simulate from Start. 

44 On the Simulation toolbar select the Play  button.  

 

The Simulation immediately stalls and the PowerMILL Error dialog is displayed. 

45 Select OK in the PowerMILL Error box and keep clicking on the Step Forward 

 button and keep by-passing (OK) the warnings until they are no longer being 

displayed. 
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Note that the head is currently positioned along the +ve Y direction. 

 

46 Continue to Step Forward and observe that all moves in the –ve X direction are 

stalling the Simulation while moves in +ve X and -ve/+ve Y are all okay. 

47 Return to the file in Wordpad and look for incorrect data in ‘The head’ section 

of the mtd file that defines the X axis travel limits. 

 

    <!-- The head --> 

    <machine_part> 

    <axis> 

    <control_info ADDRESS="X" MIN="-20" MAX="315" /> 

    <simple_linear I="1" J="0" K="0" /> 

    </axis> 

    <machine_part> 

    <axis> 

    <control_info ADDRESS="Y" MIN="-450" MAX="315" /> 

    <simple_linear I="0" J="1" K="0" /> 

     </axis> 

     <machine_part> 

The above row defining the MIN X travel limits contains an incorrect value of "-20". 

This value must be changed to "-315". 

 

 

48 Modify the above incorrect value to that shown below:- 

<control_info ADDRESS="X" MIN="-315" MAX="315" /> 

 

49 Save the file. 

 This final update will now be tested in the PowerMILL Project. 

 

50 In the PowerMILL explorer right mouse click on the Machine Tool -  

PMPOST-Mazak_Variaxis_630PSA-Update and from the local menu select 

Delete. 
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 It is necessary to re-import the updated MTD file into the Project. 

51 In the Machine Tool toolbar select the Import Machine Tool Model  

option. 

52 In the dialog select the Machine Tool Model file:- 

….\PowerMILL_Data\five_axis\MachineToolModels\PMPOST-

Mazak_Variaxis_630PSA-Update.mtd 

 

53 Turn down the Opacity on the static parts of the Machine Tool model. 

54 Right mouse click on the toolpath EM12-FinPkts and from the local menu select 

Simulate from Start. 

55 On the Simulation toolbar select the Play  button.  

 

The simulation will now successfully run from start to finish without stalling. All 

linear and rotary moves should be an exact match comaperd with the original 
mtd file, PMPOST-Mazak_Variaxis_630PSA. 

 

56 Select File - Save Project  

 

 

 

 

 

 

 

 

 

 



13. MTD files                                                                                                                               PowerMILL 2016 

13 - 14  Copyright @ Delcam Ltd 

 



PowerMILL 2016                                                                                                               14. Four Axis Rotary Finishing 

Copyright @ Delcam Ltd  14 - 1 

Introduction. 
This Finishing strategy is designed for machining a component mounted on a 

single, programmable Rotary Axis. During milling, the component rotates around 

the rotational X-axis while the cutter performs simultaneous 3-Axis movements. 

 

The main options are summarised below. 

X Limits 

The X Limits define the absolute limits of the finishing path along the rotational, X-

axis. These can be manually defined, or automatically set to the limits of the block.  

Pattern 

This enables the cutting method to be specified for rotary milling either Circular, 

Line, or Spiral. 

14. Four Axis Rotary 
Finishing 
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Y Offset 

A Y Offset distance can be specified to avoid cutting with the tip of the tool. This 

view along the X-axis shows how the Y Offset (if active) is applied to the Rotary 

form: 

 

Angular Limits  

The Angular Limits section of the dialog is only available when using the Style as 

Circular or Line. The Angular limits are defined between a Start and End angle.  

 

The angular limits are measured in an anti-clockwise direction when viewed along 

the positive X-axis. The area machined is between the start and end angles. 

Cut Direction 

This option determines whether Climb, Conventional, or Any milling directions are 

used. 

Stepover 

In the case of Circular and Spiral this is defined as the pitch for each programmed 

revolution of the component. For Line this is defined as the angular, stepover 

between adjacent tool tracks. 
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Circular Rotary Machining 
In this example a model of a bottle with its centre along the X-axis will be used. 

Using the Style as Circular, the job rotates with the tool aligned to a fixed 

direction. While the component rotates, the tool moves back and forth along its axis 

to generate the sectional form. The tool then steps over by the Pitch value and the 

rotational machining process is repeated. 

1 Select Delete All and Reset forms. 

2 Import the Model: 

...\PowerMILL_Data\Models\rotary_bottle.dgk 

 
3 Calculate the Block using Defined by - Box and Type - model. 

4 Create a Dia 10 Ball nosed tool named BN10. 

5 In the Rapid Move Heights dialog select Calculate. 

6 In the Start and End Point dialog Use – Absolute using the coordinates 20 0 

40.  

7 Set the Short/Long Links to Skim and Default Links to Incremental. 

8 In the Strategy Selector  select Finishing > Rotary Finishing. 
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� Enter Name: BN10-Rotary-Circular  

� Click on Defines X limits as block limits.  

� Set Style: Circular  

� Select Cut Direction: Climb 

� Input Stepover: 2 

9 Select Calculate to create the toolpath then Cancel the dialog.  

10 In the PowerMILL explorer right mouse click the toolpath Rotary1_BN10 and 

select Simulate from Start to open the Simulation Toolbar. 

11 On the Simulation toolbar select the Tool View icon . 

12 Select the Play button on the Simulation toolbar . 

 

 By applying Tool view point the rotation of the component is simulated 

(As if viewing the actual machine tool). 

 

In the above example each section is machined in the same Climb milling direction. 

The entire length of the job is machined since the X Limits are set to the Block 

limits. Selecting Conventional will produce tool tracks travelling in the reverse 
direction and Any will produce alternate Climb and Conventional tool tracks along 

the job. 

 

13 Recycle the toolpath, select Any for the Cut direction and select Calculate to 

create the toolpath before selecting Cancel to close the dialog. 

14 Simulate the toolpath as before to observe the effect of the toolpath reversing 

direction with every new section machined. 
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Line Rotary Machining 
Using the Style as Line, the tool feeds in the X direction following the component 

form. At the end of each pass the tool retracts and moves above the start of the 

next pass. At the same time the rotary axis indexes by the angular stepover and the 

tool then leads onto the next machining move. 

 

15 Make a Copy of the previous toolpath named BN10-Rotary-Line and select 

Style - Line using Cut Direction > Climb milling. 

16 For Angular Limits - Start Angle, enter 90 and End Angle, enter -90.   

17 In the Leads and Links dialog set the Z Heights - Skim distance to 20 and 

all of the Links to Skim. 

18 Click on Calculate and Close the dialog. 

 

19 Simulate the new, uni-directional toolpath (shown above with a larger step 

over). 

20 Make a Copy of the previous toolpath and name it as:- 

 BN10-Rotary-Line-2way. 

 

21  Change the Cut Direction to Any. 

22 Apply the dialog and Simulate the new, bi-directional toolpath. 
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Spiral Rotary Machining 
Using the Spiral technique, a continuous toolpath is generated around the form as 

the tool advances along the X-axis. To ensure a clean finish the toolpath starts and 

finishes with a constant X position, sectional pass. Due to a Spiral toolpath being a 

single, continuous track the cutting direction will be either Climb or Conventional 

milling. For the same reason the Angular Limits option is not viable and as a result 

is blanked out. 

 

23 Make a Copy of the previous toolpath and name it as BN10-Rotary-Spiral and 

select Style - Spiral using Cut Direction > Climb milling. 

24 Click on Calculate to produce the toolpath shown below. 

 

25 Simulate the new toolpath. 

26 Save the Project as:- 

...\COURSEWORK\PowerMILL_Projects\ Rotary_Bottle-EX1 
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Introduction  
In the Strategy Selector the Ports option provides 3 specialist strategies, 

designed for machining cylinder head, inlet/outlet ports.  

 

 

The Port Machining options automatically provide multi-axis, Tool Alignments 

where this is possible. A warning will be displayed if impossible alignment limits are 

reached and the port is not fully machined.  

 

 

 

 

 

15. Port Machining 
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Basic Single Port Example 
1 Open the ‘read-only’ Project: 

...\PowerMILL_Data\five_axis\Ports\SinglePort2-Start 

 

2 Save Project As:- 

...\COURSEWORK\PowerMILL-Projects\SinglePort2-ex1 

 

 The Project already contains all required cutting Tools, and preliminary 

3Plus2 Toolpaths. 

 

The following section will take the user through the specialist Port Area Clearance 

and Port Spiral Finishing options.  

A Pattern (4) is included running down the centre of the Port. This is required to 

control the extent and alignment of the Port Machining strategies. 

 

3 Activate the existing Toolpath 1 to reinstate all the settings. 

4 Activate the BN10 tool. 

5 In Toolpath Strategies select Ports > Port Area Clearance and fill in the 3 

pages of the dialog exactly as shown below. 
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� Insert Pattern: 4 

� Input Tool Clearance: 1.0  

 

 

 

 

� Tick Spiral. 

� Tick Partial slices. 
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6 Calculate and note the following advisory warning message: 

 

The message is advising that the Tool is unable to fully machine the form to the 

current settings. 

Later a visual check with ViewMILL will show that enough material has been 

removed to allow the finishing strategies to run. 

 

7 Select OK to the message and wait for the toolpath to finish processing. 

8 Close the dialog. 

9 Activate Toolpath 1  

10 Right mouse click on toolpath 1 and from the local menu select Simulate from 

start. 

11 Open the Block dialog and change the Max Z value from 40 to 0 before 

selecting Accept.  

 By defining the Block to be half the height of the model it will be possible 

to visualise the lower half of the port being machined. 

 

12 Select an ISO 2 view and run a ViewMILL simulation on all the remaining 

toolpaths in sequential order.  

 

 If the Partial Slices option had not been ticked then the Toolpath would 

have been created as shown below with a wall of material remaining in the 

middle of the port. 
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13 Activate the SPHR12.5 tool. 

14 In Toolpath Strategies select Ports > Port Spiral Finishing and fill in the 

two featured pages of the dialog exactly as shown below. 

 

 

 

The above Merge settings causes the thickness to gradually increase to 0.3 as 

it merges into the areas previously machined from the first end. This is to 

compensate for the cutter tending to dig in when the loading decreases. 
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15 Select Calculate and once the toolpath has been created select Cancel. 

16 Perform a ViewMILL simulation on the latest toolpath, Sphr12_5-PortSpiral. 

 

 

 Note the 0.3mm step where the machining from the second end of the port 

has gradually moved away from the form over the last 10mm to the blend 

point. 

 

If the Lift Height is 0 then there will not be a visible step appearing on the 
toolpath running from the second end. 

There is however a high risk of the Tool digging into this area if this Toolpath 

was to be run on the machine tool. 

17 Select File > Save Project. 
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Twin Port Example 
Only one Port at a time can be processed within the Port machining strategies. For 

this example, 2 reference surfaces have been created to blank access to the extra 

port while applying the Port machining strategies to the remaining single Port setups. 

1 Select File > Delete All and Tools > Reset Forms. 

2 Open the read only Project: 

...\PowerMILL_Data\five_axis\Ports\DualPort_Start 

 

3 Save Project As: 

...\COURSEWORK\PowerMILL-Projects\DualPort-ex1 

4 Activate the existing toolpath RghPort-3Axis to reinstate all the settings. 

5 Activate the BN16 tool. 

6 Calculate a new Block to the full Model dimensions. 

7 In Toolpath Strategies select Ports > Port Area Clearance and fill in the 

pages of the dialog exactly as shown below. 
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8 Switch on the Level named reference. 

 

 

9 From the Port Area Clearance main page, select the Component Thickness 

icon . 

 

10 In the Component Thickness dialog, select and acquire the left hand 

reference surface (Shaded purple above right) to a row with the Machining 

Mode set to Ignore. 

11 Apply the dialog. 

 

 

 

 

12 In the Order page tick Spiral. 
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13 Calculate the Port area clearance dialog. 

 

 

 

14 Activate the SPHR25 tool. 
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15 In Toolpath Strategies select Ports > Port Spiral Finishing and fill in the 

pages of the dialog exactly as shown below. 

 

 

 

 

16 From the Port Area Clearance main page, select the Component Thickness 

icon . 
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17 As shown in the following diagram, Clone  the Component Thickness 

settings from the previously created toolpath BN16-RghPort. 

 

18 Apply and Accept the Component Thickness dialog, and then Calculate the 

Port spiral finishing strategy. 

 

19 Activate the Workplane mc-OUTPUT. 

20 Activate the Boundary 1.  

21 Calculate a Block - Defined by - Boundary and Type - Model. 
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22 Change the Max Z value to -75.0. 

23 Select an ISO 3 view, open and run a ViewMILL simulation of all the 
toolpaths.  

 

 Note the 0.3mm step where the machining from the second end of the Port 

has gradually moved away from the form over the last 10mm to the blend 

point. 

 

24 Select File > Save Project. 
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Introduction  
In new strategies, the Blisks option provides 3 specialist strategies for machining 

Impellers. 

 

Impeller Example 
1 Select File > Delete All and Tools > Reset Forms. 

2 Open the ‘read only’ Project: 

...\PowerMILL_Data\FiveAxis\Blisks\BliskSimple_Start 

 

3 Select File > Save Project As: 

...\COURSEWORK\PowerMILL_Projects\FiveAxis\Blisks\Blisk_Example 

4 Activate Workplane 1. 

5 Create a Cylindrical Block to the Model dimensions. 

16. Blisks 
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6 Calculate the Rapid Move Heights. 

7 Set both Start and End Points to First/Last Point Safe. 

8 In the Leads and Links dialog, set Links to Short/Long Skim and Default 

Incremental. 

To be able to apply the Blisks machining options the component surfaces must first 

be acquired to a series of specifically named levels. In this example the surfaces in 

the imported model are already acquired to appropriate levels. 

 

9 Activate the existing Ball Nosed tool named BN25. 

10 From the main toolbar, select Default Thickness  and in the Thickness 

Preferences dialog, select the Surface Defaults tab. 

 

11 Select the single Shroud Surface and acquire  it to the first row in the 

above dialog. 

12 Set the first row to Machining Mode - Ignore and Apply the settings, before 

closing the dialog by clicking Accept.  

13 In the Leads and Links options input Z heights - Skim distance 15.  

14 For both Lead in and Lead out, input 1st choice – Extended move 10 and 2nd 

choice – Surface normal arc – Angle 90 and Radius 5. 
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15 In the Toolpath Strategies dialog, select Blisks and from the three available 

options, select Blisk Area Clearance. 

16 Enter data exactly as shown below with the Fillets and Splitter Blade options 

left blank. 

 

 

 

 

 

 



16. Blisks                                                                                                                                                PowerMILL 2016 

16 - 4  Copyright @ Delcam Ltd 

17 Select Queue in the dialog to commence background toolpath processing. 

 

18 Activate the existing Ball Nosed tool named BN15. 

19 In the Toolpath Strategies dialog, select Blisks and from the three available 

options, select Blade Finishing. 

20 Enter data into the pages of the dialog exactly as shown below with the Fillets 

and Splitter Blade options left blank. 
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21 Select Queue in the dialog to commence background toolpath processing. 
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22 In the Toolpath Strategies dialog, select Blisks and from the three available 

options, select Hub Finishing. 

23 Enter data exactly as shown below with the Fillets and Splitter Blade options 

left blank. 

 

 

 

 

 

24 Select Queue in the form to commence background toolpath processing. 
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The next stage is to perform a full ViewMILL simulation of all 3 toolpaths. 

Before running ViewMILL it is necessary to define the Block as a Triangle model 

of the pre-turned, Shroud for an accurate representation of the material prior to 

milling. 

25 Activate and right mouse click on the toolpath BN25-RGH-a1 and from the 
local menu select the option Simulate from Start. 

26 Before starting the Simulation, open the Block dialog and select Defined By > 

Triangles followed by select the Load block from file icon. 

 

 

27 Browse and select the Triangle file: 

...\PowerMILL_Data\FiveAxis\Blisks\TurnedShroud.dmt 

 

 

28 With the complex Block active, switch on a ViewMILL simulation. 
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29 Select the Play button in the toolpath Simulation toolbar and observe the 

machining process for the toolpath BN25-RGH-a1. 

 

30 Continue the ViewMILL Simulation on toolpath BN15-fin-a1. 

 

31 Continue the ViewMILL Simulation on toolpath BN15-finHUB-a1. 
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The final image (below) shows the result of a ViewMILL simulation including 17 

copies of the toolpaths rotated by 20 Degree increments around Z. 
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1 Select File > Delete All and Tools > Reset Forms 

2 Open the (read-only) Project:-  

….\PowerMILL_Data\FiveAxis\Cowling\Cowling-5Axis-Start.dgk 

 

3 Save Project As: 

….\COURSEWORK\PowerMILL_Projects\Cowling-5Axis 

 

The Project currently contains 8, 3-Axis Toolpaths. 

This has left remaining areas that are either more suited to, or can only be 

machined using 5-Axis strategies. 

 

4 Select an ISO2 view. 

5 Activate the Toolpath D16TR6-RGH1_step to restore the Block used in the 

strategy. 

6 Perform a full ViewMILL simulation on the NC Program 1. 

17. Five Axis-Tutorial 
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The remaining areas that require Five Axis machining include the central pocket 

(Swarf Machining), and the intersection between the main form and the 3D run-off 

(Embedded Pattern and Surface Finishing). 

 

7 Select the ViewMILL No-Image display option and disconnect from the 

simulation process. 

Central Pocket 

8 Activate the tool EM12. 

 

 

 

9 Select the Pocket wall. 

10 Select the Toolpath Strategies dialog  select the Finishing tab. 

11 From the list of strategies select Swarf Finishing and then OK. 



PowerMILL 2016 17. 5Axis-Tutorial 

Copyright © Delcam Ltd  17 - 3 

12 In the Swarf Finishing dialog enter data exactly as shown below: 

 

 

13 For both the Lead in and Lead out input Surface normal arc with Angle 180 

and Radius 2, then Calculate the toolpath. 

 

The Swarf Finishing strategy is created as Five Axis by default (The Tool axis 

option is set to Automatic). As shown in the above image this results in a wedge of 

material remaining on the flat base of the pocket. This can be removed with a 

second Swarf Finishing toolpath but this time with the Tool Axis set to Vertical. 
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14 Make a copy of the Swarf Finishing strategy named EM12-SwarfPktBase-

FIN2 but this time set the Tool Axis to Vertical before selecting Calculate. 

 

15 Change the Lead in move onto this toolpath to a circular Ramp with Angle 4, 

Circle Dia (TDU) 0.65 and Ramp Height 2. 

 

 

The Pocket is now fully machined. 

 

16 Save (but do not close) the Project. 
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Main Form – Base Intersection 

17 Activate the EM5 tool. 

 

18 Select the main form surface (as shown in the above image). 

19 Select the Toolpath Strategies dialog  select the Finishing tab. 

20 From the list of strategies select Surface Finishing and then OK. 

21 In the Surface Finishing page enter data exactly as shown in the image below. 
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22 Select the Tool Axis page and again enter data exactly as shown in the image 

below. 

 

 

23 Select the Pattern page and again enter data exactly as shown in the image 

below. 

 

 

 The values shown in the above page were finally arrived at after a trial 

and error process. The actual values are unit distance along and across 

the surface, curve network (U V). 

 

24 Select Preview to visualise the defined pattern on the Surface. 
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25 Select Calculate to process the toolpath. 

 

 To help visualisation the above images show the preview with a larger 
area and stepover than specified in the instructions. 

 

26 Apply the following Lead in and Lead Out settings. 
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27 Make a copy of the Surface Finishing toolpath and rename it as EM5-

MainForm-FIN2. 

 

28 Modify the original settings in the Pattern Page and select Calculate to perform 

the same strategy on the other side of the main form. 

 

 

 The last 2 Surface Finishing strategies deliberately stop just short of the 

run-off surfaces. A more accurate, final pass will be created normal to the 

run-off surfaces using a separate Embedded Pattern Finishing. 

 

 

29 Save (but do not close) the Project. 
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Final Pass around Main Form - Base Intersection 

 

30 Activate the EM3 tool. 

 

31 Select the main form and Pocket surfaces (as shown in the above image). 

 

32 Create a Selected Surface Boundary (with Roll Over ticked). 

33 Create an empty Pattern and insert the above Boundary segment into it. 

34 De-Activate the Boundary. 
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35 Use the Curve Editor to trim the Pattern into 2 segments that define the 

required extent for an Embedded Pattern Finishing strategy. 

 

36 Reverse the Pattern segments as required to produce a Climb Milling direction 

(Material to the right of the tool feed direction). 

37 Right mouse click on the new Pattern and from the local menu select Edit – 

Embed. 

 

38 In the above dialog select Method as Drop with a Tolerance of 0.01 before 

selecting Apply. 

A copy of the original Pattern 1 is projected down Z onto the model as an 

Embedded Pattern 1_1 (contains the surface normal). 

39 Select the Toolpath Strategies dialog  select the Finishing tab. 

40 From the list of strategies select Embedded Pattern Finishing and then OK. 
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41 In the Embedded Pattern Finishing page enter data exactly as shown in the 

image below. 

 

42 Open the Component Thickness dialog and acquire the Main Form surface to 

one of the rows.  

 

43 Set the selected row to Machining Mode Ignore and Apply. 

The Main Form surface is set to be ignored as it would otherwise result in the 

toolpath to fragment. This will result in the tool very marginally gouging the main 

form surface. If checked both visually and using the gouge checking options the 

actual results will be negligible. 
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44 Back in the main Embedded Pattern Finishing dialog, open the Tool Axis page 

and select Lead/Lean both with a 0 angle. 

 

45 Set all Link moves (Short/Long/Default) to Incremental. 

 This is to prevent the toolpath from linking straight through the main cowling 

surface (Component Thickness set to Ignore). 

 

46 Calculate the Embedded Pattern toolpath. 

 

47 Run a full ViewMILL simulation (Final EM3-FIN1 toolpath show below). 

 

48 Save the Project. 


