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PowerMill is the world's leading specialist NC CAM software for 
manufacturing complex shapes typically found in the toolmaking, 
automotive, and aerospace industries. 

Key features: 

 Wide range of milling strategies which include high-efficiency 
roughing, high-speed finishing, and 5-axis machining techniques. 

 Fast calculation times for toolpath creation and postprocessing. 

 Powerful editing tools to ensure optimum performance on the 
machine tool. 

This Getting Started guide provides step-by-step instructions that 
highlight some of the features of this versatile software. 

 It is assumed that you know how to operate your machine 
tool and how to select suitable tools and cutting conditions. If 
you are unsure about any aspect of operating your machine tool, 
consult an expert or seek advice from your machine tool supplier. 

 The machining parameters used in the examples in this guide 
illustrate the effects of different commands and options in 
PowerMill. The values given are not necessarily suitable for 
cutting on a CNC machine. If you wish to machine any parts 
based on the examples given, carefully review and adjust the 
parameters to ensure safe cutting conditions.  

 

Introduction 
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Setting up your working directories 
To make project management easier, it is recommended that you 
define a home folder and default directory paths before starting any 
work with PowerMill: 

 Setting up a Home folder in Windows 7 for user-defined macros 
(see page 2). 

 Specifying PowerMill default directory paths (see page 3). 

 PowerMill temporary file area (see page 4). 
 

Setting up a Home folder in Windows 7 for user-defined 
macros 

PowerMill checks for the value defined in the Windows environment 
variable Home for directions to the user-defined macros folder. 
Decide where you want the Home environment variable to point to, 
for example, E:\PowerMill_Projects, and set up a Windows 
environment variable: 

1 Open Windows Control Panel and click System > Advanced system 
settings. This displays the System Properties dialog. 

2 Click the Advanced tab. 

3 Click Environment Variables. 

4 To add a new variable name and value, click New to display the 
New User Variable dialog. 

a In the Variable Name field, enter Home. 

b In the Variable Value field, enter the path where you want your 
home folder to be. For example, E:\PowerMill_Projects. 

5 Click OK in all open dialogs to save changes and close them. 

6 Create a folder called pmill inside the Home directory. For 
example, E:\PowerMill_Projects\pmill. 

When user-defined macros are created or called, PowerMill 
automatically locates the user-created macros in this folder. 

 



 

Autodesk PowerMill 2017  Introduction • 3  

Specifying PowerMill Default Directory paths 
To specify the Default Directory path in PowerMill: 

1 From the Menu bar, select Tools > Customise Paths. This displays 
the PowerMill Paths dialog. 

2 Select Default Directory from the drop-down list. 

 

3 To add a Default Directory path, click  and use the Select Path 
dialog to select the desired location. The path is added to the list. 
You can add multiple paths to the Default Directory list. 

 You can have only one active Default Directory path. 
PowerMill enables you to add multiple paths to the Default 
Directory list to help you efficiently organise multiple 
projects across different folders. To change the Default 
Directory load order, select the directory path you want to 

change, and use the  and  buttons to promote or 
demote the path. 

4 Click Close. 

Your default working directory is changed to the directory path you 
selected and all your file operations (Open Project, Save Project, 
Import Model, Export Model) are changed to this location. 
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Specifying PowerMill temporary file area 
By default, PowerMill projects use the default Windows temp folder 
(defined in your Windows System Properties) as the temporary area. 

To define a custom PowerMill temporary file area: 

1 Right-click My Computer, and then click Properties. This displays 
the System Properties dialog. 

2 Click the Advanced tab. 

3 Click Environment variables. 

4 Click New to add a new variable name and value. 

a In the Variable Name field, enter 
POWERMILL_USER_TEMPDIR. 

b In the Variable Value field, enter the path where you want your 
PowerMill temporary folder to be. For example, 
E:\PowerMill_Projects\TemporaryFiles. 

5 Click OK in all open dialogs to save changes and close them. 

6 Create the temporary folder in Windows to the path where you 
specified the variable. For example 
E:\PowerMill_Projects\TemporaryFiles. 

 If there are any problems with the variable you have 
specified, PowerMill reverts to the default Windows temporary 
file area. 
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To start PowerMill: 

 Select Start > All Programs > Autodesk > PowerMill > PowerMill 
2017; or, 

 Double-click the PowerMill shortcut on your desktop: 

 
This displays the Startup (see page 6) window. 

To exit PowerMill: 

 Select File > Exit from the menu; or, 

 Click the Close button  in the top right-hand corner of the 
PowerMill window. 

If you have not saved your project, the following message is 
displayed: 

 
Click Yes to save the project before exiting from PowerMill. 

 

Start and close PowerMill 
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Startup window 
The following window is displayed when you start PowerMill: 

 
The screen is divided into the following main areas: 

  Menu bar provides access to a number of menus. Selecting a 
menu, such as File, opens a list of associated options and sub-
menus. Sub-menus are indicated by a small arrow to the right of 
the text. For example, selecting File > Recent Projects  displays a list 
of recently used projects. 

  Main toolbar provides quick access to the most commonly used 
commands in PowerMill. 

  Explorer (see page 10) provides control over all PowerMill 
entities. 

  Graphics window is the working area of the screen. 

  View toolbar provides quick access to standard views and 
shading options in PowerMill. 
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  ViewCube enables you to interactively orientate the contents of 
the graphics window. 

  Status and Information toolbar enables you to create and activate 
workplanes, display various preset fields and display user defined 
fields. If you hover the cursor over a button, help is displayed rather 
than the information toolbar. The help can be, for example, a brief 
description of the item beneath the cursor, or information about the 
calculation that is in progress. 

  Tool toolbar enables the rapid creation of tools in PowerMill. 
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 PowerMill features many toolbars which are not, by default, 
displayed at startup. To display one of PowerMill's extra 
toolbars, select View > Toolbar and the toolbar you want to 
display, for example Toolpath. A  next to a toolbar name 
indicates the toolbar is currently displayed. 
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 If you want to change background colours, select Tools > 
Customise Colours and choose View Background. You can 
change the Top and/or Bottom colours and Reset them or 
Restore Defaults if you change your mind afterwards. 

 

 PowerMill remembers your toolbar and colour selections from 
one session to the next. For example, if you have the Toolpath 
toolbar displayed when you exit a session, it is displayed the 
next time you start PowerMill. 
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Explorer 
The Explorer displays the entities used in a PowerMill project. (The 
term entity broadly refers to all entries in the Explorer.) The entities 
in the Explorer are grouped together by type, for example, 
toolpaths are grouped in the Toolpaths branch and tools are 
grouped in the Tools branch. Because a PowerMill project often 
contains a lot of entities, the Explorer uses an Active  system to 
indicate which entities have focus. 

 

Making an entity active (shortcut) 

Double-click an entity to make it active (you need to click the 
entity's icon and not its name). The new active entity is displayed in 
bold and proceeded by an angle bracket (>). 

 

 Each branch can only have one active entity at a time. 

Drawing/unbarring an entity in the graphics area 

You can draw or undraw entities in the graphics area. Click an 
entity's light bulb to specify its display setting: 

 — Entity is always undrawn. 

 — Entity is drawn only when active. 

 — Entity is always drawn. 
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Duplicating an entity (shortcut) 

1 Press Ctrl and drag the entity onto the title of its branch (when 
you drag the entity, position the mouse over the entity's icon). 

 
2 Release the left mouse button when  changes to . 

This creates a copy of the entity with the suffix _1. If you 
duplicate the entity again the suffix is _2 and so on. 

 

Displaying the context menus 

There are two types of context menus available in the Explorer: 
general context menus and specific context menus. To display the 
context menus: 

General — Right-click the title of an entity branch. The menu 
options are relevant to all the entities in the branch. 

Specific — Right-click an individual entity. The menu options are 
relevant only to the entity. 

Deleting an entity 

Right-click the entity and select the delete menu option, for 
example, Delete Toolpath. The entity is placed in the Recycle Bin.  

To permanently delete an entity: 

 select the entity and press Shift+Delete; or 

 right-click the entity and select the delete menu option while 
pressing Shift. 

 Permanently deleting entities reduces PowerMill's memory 
requirements. 

Repositioning the Explorer pane 

Like all toolbars in PowerMill, you can float and reposition the 
Explorer pane: 

Double-click the top of the Explorer pane to float the pane and then 
drag it to a new position. To dock the pane on the opposite side of 
the window, drag the pane over the side of the window and release 
the left mouse button — the pane 'snaps' into position. 
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Unit System 
By default, PowerMill uses metric units. You can change the unit 
system before any project entities are created. 

 This guide uses metric (mm) units. 

To change the default units before you start work, for example, 
from Metric to Imperial: 

1 From the Tools menu, select Options. This displays the Options 
dialog. 

2 Select Unit System and click  to expand the tree to view 
available options. 

3 Select the Unit System sub-item. This displays the Unit System 
page. 

4 Select Imperial (inches). 

 
5 Click Accept to save changes. 
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 Changing the unit system automatically resets all the default 
values on the dialogs to match the selected unit system. 
PowerMill does not convert the values between the unit 
systems; instead, it chooses an appropriate set of default 
values (metric or imperial). 

 

Accessing Help 
PowerMill offers the following forms of help: 

 Tooltips (see page 13) 

 Status bar help (see page 13) 

 Context-sensitive online help (see page 13) 

 Manuals (see page 14) 

For more information see Using the help window. 
 

Tooltips 
Tooltips are displayed by hovering the cursor over the required 
buttons. 

Each tooltip gives a brief description of the function of the 
associated button, for example: 

 
 

Status bar help 
When you hover the cursor over a button, help is displayed in the 
Status bar, which is located at the bottom of the screen. So, when 

you place the cursor over the Rapid Moves  button, help is 
displayed in the Status bar as well as the tooltip. 

 
 

Context-sensitive online help 
Pressing the F1 key displays help for the area of the screen that has 
current focus, such as a display pane (Explorer or graphics window), 
a dialog, or a dialog tab. Where there is no focus, the contents page 
for the main Help is displayed, so you can navigate from there. 
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To display the help topic relating to an element on the main 
PowerMill screen (a toolbar button, an Explorer entity), hold down 
the Shift key and press F1. When the cursor changes to , click the 

item of interest to open the help topic:  

 If you want to cancel context-sensitive mode, press Esc. 

To display context-sensitive help for an item within a PowerMill 
dialog (such as a field or a button), click  and when the cursor 
changes to , click the item to open the associated help topic: 

 
 

Manuals 
The PowerMill manuals offer additional help. 

The documents are: 

 What's New and Getting Started PDFs available for download. 

 Online Reference help, What's New and Getting Started. 
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This example shows how to generate and output the basic toolpaths 
used to machine a cavity mold. 

1 Start PowerMill (see page 5). 

2 Load the model (see page 16). 

3 Save the project (see page 20). 

4 View the model and block (see page 21). 

5 Create an NC program (see page 26). 

6 Create, simulate, and output each toolpath: 

 Roughing (see page 31) — Use this toolpath to rapidly remove 
the majority of excess material. 

 Rest roughing (see page 44) — Use this toolpath to remove 
material which the roughing toolpath is unable to remove. The 
toolpath uses the same strategy as the roughing toolpath but 
with a smaller tool to remove additional material. 

 Finishing (see page 52) — Use this toolpath to machine steep 
and shallow areas of the part. 

 Corner Finishing (see page 69) — Use this toolpath to smooth 
areas of the part which the previous toolpaths are unable to 
machine, for example corners between non-tangential 
surfaces. 

 

Cavity mold example 
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Loading the model 
The example model is a cavity mold which is located in the Examples 
folder. 

To load the model: 

1 Select File > Examples. 

 
The Open Examples dialog is displayed, automatically opening the 
drive and folder where the tutorial files are installed: 

 
2 In the Files of type field, select *.dgk from the drop-down list. 

3 Select the cavity mold called die.dgk, and then click Open. 

PowerMill loads the file. 
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4 Click the Resize to Fit  button on the View toolbar to fit the 
model within the display. 

 

5 To change the display to an isometric view, select the ISO 1  
button on the same toolbar. The model looks like this: 

 

 More information on view manipulation is provided later 
(see page 21). 



 

18 • Cavity mold example  Getting Started  

6 The model is currently displayed with only the wireframe 

selected. To add shading, click the Plain Shade  button on the 
View toolbar. 

 

7 Remove the wireframe by clicking the Wireframe  button 
(located near the bottom of the View toolbar). 

 Click the Wireframe  or Plain Shade  buttons to toggle 
between Wireframe, Plain Shade, Wireframe and Shaded, and 
No Model views. 

For this exercise, keep the model shaded. 
 

Defining the block around the die 
The block defines the stock size. The part is then machined from the 
block. In this case, the block is a rectangular cuboid. 

To define the block: 

1 Click the Block button  on the Main toolbar. 

2 In the Block dialog, check that: 

a Defined by is set to Box. 

b Coordinate System is set to Active Workplane. 

c In the Estimate Limits area, Expansion is set to 0 and Type to 
Model. 



 

Autodesk PowerMill 2017  Cavity mold example • 19  

d Draw is selected. 

 
3 Click Calculate to define a cuboid enclosing the die. Click Accept 

to close the dialog. 

 

 To toggle the display of the block on and off, click the Block 

 button on the View toolbar. 
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Saving the project for the first time 
PowerMill saves all the entities, together with a copy of the model, 
as a single project. 

To save a project: 

1 Click the Save button  on the Main toolbar. Since you have not 
previously saved the project, the Save Project As dialog is 
displayed. 

 
2 Open the directory that you created for your projects (see page 

2), and enter a name for your project in the File name field, for 
example forging_die_mold. 

3 Click Save. 

The PowerMill window header now displays the name of the 
project. 

 
An associated file structure is created: 
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 Do not manually edit these files because you will corrupt your 
data. 

 From now on, click Save  on the Main toolbar to update the 
saved version of the project. 

 

Viewing the model and block 
To look at a specific area of the model or block, you can either 
select one of the predefined views (see page 21) on the View 
toolbar, or use the mouse. 

It is recommended that you use a three-button mouse. By holding 
down the middle button and moving the cursor in the graphics area, 
you can control the view of the model. When you move the mouse 
(with the middle button pressed), the trackball is displayed. 

 
Start with the cursor in the middle of the window and press the 
middle mouse button, then drag the cursor up the screen. The 
image moves as you move the mouse. 

 

Predefined views 
The View toolbar is loaded by default when PowerMill is started and 
is often the best starting point for dynamically manipulating model 
views. There are several fixed viewing directions available from the 
View toolbar. 

 If the View toolbar is not currently displayed, select View > 
Toolbar > Viewing from the menu. 

 

 

Use the View Mode buttons to switch between milling and 
turning view modes. These modes determine how the 
model is orientated in the graphics window. Toggle the 
button to switch between view modes. 
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Use the View Along options to orientate the view so the 
model is viewed along the X, Y, or Z axis. Hover on any 
of these buttons to display a 2D view toolbar which has 
additional view options along the primary axes. 

 Use the ISO View option to change the view angle to any 
of the isometric views. Hover on the button to display 
other isometric view options. 
Isometric views are often the best starting point for 
dynamically manipulating the view using the mouse. 

 Use the Previous View option to view model as previously 
displayed. 

 Use the Refresh option to redraw all currently displayed 
components, repairing any damage to the current view. 
This is useful if the view loses definition as items are 
created, modified, or deleted. 

 Use the Resize to Fit (see page 24) option to adjust the 
view so the entire model can be seen. Depending on the 
current view, PowerMill zooms in or out to achieve the 
new view. Hover on the button to view the Zoom In (see 
page 24) and Zoom Out (see page 24) buttons. 

 Use the Zoom to Box (see page 24) option to zoom in on 
a specific area of the model. Click and drag the mouse to 
create a box over a part of the model you want to zoom 
in to. PowerMill adjusts the view to zoom in on the 
selected boxed area. 

 Use the Block option to show or hide the block. 

 Use the Plain Shade option to show or hide the shaded 
representation of the model. 
Hover on the Plain Shade button to show the other 
shading options available on the Shading toolbar. 

 Use the Wireframe option to show or hide the wireframe 
representation of the model. 

 Use the Box Selection mode to select entities with the 
mouse. Click and drag the mouse to create a box over 
the entities you want to select. 
To deselect entities from a group of selected entities, 
hold down the Ctrl key and click the entities you want to 
deselect. 
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 Use the Drag Selection button to select multiple entities 

with the mouse. Hover on the Box Selection  button to 

display the Drag Selection  button. Click the Drag 

Selection  button and click and select the relevant 
entities. 

 Use the Previous Selection option to revert to the 
previous selection made with the Box Selection or Drag 
Selection options. 
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Zoom 

Use the Zoom options   on the View toolbar to resize 
the model. 

This is a pull-out toolbar. Hovering on the currently selected zoom 

button (in this case,  Resize to Fit) displays the Zoom toolbar. 

Resize to Fit  — Use this option to adjust the view to see the 
entire model. 

It converts this: 

 
into this: 

 
This zooms in or out as required. So, it also zooms a microscopic 
image on the screen to one that just fits inside the window. 

 If you cannot see your model, click the Resize to Fit  button 
to centre the model at the middle of the screen. 
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Zoom In  — Use this option to zoom in to the model. Click 
repeatedly until desired view is achieved. This zooms the model 
about the centre of the graphics window. 

Zoom Out  — Use this option to zoom out from the model. Click 
repeatedly until desired view is achieved. This zooms the model 
about the centre of the graphics window. 

Zoom to Box  — Use the option to zoom in to a specific area of 
the image. Click and then use the left mouse button to drag a zoom 
box over a section of the model. PowerMill zooms in to the boxed 
area. 

It converts this: 

 
into this: 

 

  Zoom box 

 You can also resize a model by holding down the Ctrl key and 
the middle (or right) mouse button, and then dragging the 
mouse up to Zoom In or down to Zoom Out. 
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Panning 
You can Pan the model by holding down the Shift key and the 
middle (or right) mouse button, and then dragging the mouse in the 
direction in which you want to move the image. 

 

NC program 
An NC program contains the commands and output settings that 
specify how the machine controller machines the part. 

It is advisable to create an NC program, and set the preferences for 
it before generating any toolpaths. However, it's just as easy to add 
generated toolpaths to the NC programs later (see page 79). 

 

Setting NC program preferences 
1 In the Explorer, right-click NC Programs and select Preferences. 

 
This displays the NC Preferences dialog. 

2 On the Output tab of the NC Preferences dialog, select Use Project 
- On to write the NC program file into the PowerMill project 
folder. 
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 Select Use Project - Off to write the NC program file to a 
different folder. You need to specify it in the Output Folder 
field. 

3 Enter the output file name to be used by default in the Output 
File field. 

 The variable %[ncprogram] gives the output file the same 
name as the NC program. You can add your file name to 
this variable. 

 

4 Click  (next to the Machine Option File field) to open the Select 
Machine Option Filename dialog. 
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5 Browse to the folder where the option files are stored, select the 
machine option file (in this case Heid400.pmoptz) and click Open. 

 
This closes the Select Machine Option Filename dialog and returns 
you to the NC Preferences dialog. 

6 Click Accept to save your changes and close the dialog. 
 

Creating an NC program 
1 From the NC Programs context menu, select Create NC Program. 

This displays the NC Program dialog. 
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2 In the Name field, enter the name you want to call the NC 
program. For example Cavity_Mold. 

 

3 In the NC Program dialog, click the Options  button. The 
Options dialog is displayed. 

4 On the Output tab: 

a If selected, deselect the Write File for Each Toolpath option. As 
a result, the Output File is displayed at the top of the NC 
Program dialog instead of the Root Name. 

b Select Option File as heid400. 

c Enter Output File Extension as pmoptz. 
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d Click Accept to update and close the Options dialog. 

 

 If you want separate output files for each toolpath, select 
Write File for Each Toolpath option. This changes the Output 
File field to Root Name in the NC Program dialog and 
displays the default path and file name in the Output File 
field at the bottom of the dialog. 

The default path in the Output File field is based on the settings 
in the NC Preferences dialog. If you want to change this path, 

click the open folder  button, browse to the appropriate folder, 
and enter the new file name (the file extension is determined by 
the settings you made in step 4b). If you used the %[ncprogram] 
variable in the NC Preferences dialog, hover over the path to see 
how the file name is displayed in PowerMill. 

5 Click Accept in the NC Program dialog to accept your selections 
and close the dialog. 
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6 To see the entity that you have just created, click  to expand 
the NC Programs node. The entity is automatically active 
(signified by bold text preceded by the > symbol). 

 

 Any toolpaths you create are automatically added to the 
currently active NC program. 

 

Creating a roughing toolpath 
A Model Area Clearance strategy with the roughing Style set as Offset 
all is used to rapidly remove the majority of excess material on the 
model. This clears the area with contours that are generated by 
repeatedly offsetting the initial contour until no further offsetting is 
possible. It then steps down to the next level and repeats the 
offsetting until the bottom of the part is reached. 

To create a roughing toolpath: 

1 On the Main toolbar, from the Create Toolpath list, select Model 
Area Clearance. 
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This displays the Model Area Clearance dialog. 

 
Use the various tabs to enter parameters for the toolpath. 

2 Give the toolpath an appropriate Name, for example Roughing. 

3 Define the roughing tool geometry (see page 32). 

4 Define the tolerances (see page 37). 

5 Specify rapid move heights (see page 37). 

6 Specify tool start points (see page 38). 

7 Generate the roughing toolpath (see page 39). 

8 Display the roughing toolpath (see page 40). 

9 Simulate the roughing toolpath (see page 43). 
 

Defining the roughing tool geometry 
The next stage involves selecting a tool and defining its geometry. 
This example uses a 16 mm (5/8 inch) tip-radiused tool. 
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1 In the Model Area Clearance strategy dialog, click  to 
display the Tool page. 

2 On the Tool page: 

a Click the  arrow next to the Create Tool  button in the 
Tool area. 

b From the tool list, select  to create a Tip Radiused Tool. 

3 On the Tool page, click  to display the Tip Radiused Tool 
dialog. 

 
4 In the Tip Radiused Tool dialog, enter: 

a Name: D16T1 

b Length: 30 mm 

c Tip Radius: 1 mm 

d Diameter : 16 mm 
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e Tool Number : 1 

 

5 Select the Shank tab, click  to add a shank component. Enter: 

a Upper Diameter : 16 mm 

b Length: 70 mm 

 The Lower Diameter automatically defaults to the Upper 
Diameter. This can be accepted for the current tool. 
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6 Click Close. 

The tool is automatically aligned with the Z axis: 

 
You can view and edit the created tool: 

 In the Explorer, expand  to see the tool you have 
created. Expand the tool node to see the tool's specific details. 

 
 In the Tool tab on the Model Area Clearance dialog: 

 
 On the Tool toolbar: 
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Tool length overview 
The diagram shows a cutting tool, made up of a tip (yellow) and 
shank (green), mounted in a holder (red). The tool is mounted in 
the spindle of a machine (grey). 

 The colours used here correspond to those used in the 
PowerMill Tool dialogs. 

 
 

  Spindle 
  Holder length 
  Gauge face 
  Overhang 
  Cutting length 
  Gauge length 

The Cutting length represents the part of the cutter that removes 
material. This is the Tip length. 

The Overhang is the amount by which the cutter protrudes from the 
tool holder. This typically includes part of the Shank length. The 
Overhang is fixed when the cutter is mounted in the holder. 

 To obtain maximum tool life, keep the Overhang to the 
minimum length necessary to prevent the holder from hitting 
the part or unmachined stock. 

The Holder length is the total length of all parts of the holder 
assembly that protrude from the spindle when the holder is 
mounted in the machine. 

The Gauge length is the total length of the cutter and holder 
assembly when it is mounted in the machine. It is measured from 
the tip of the tool to the Gauge face, which is the ground face of the 
spindle. 
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Defining the tolerances 
On the Model area clearance page of the strategy: 

1 In Tolerances, enter: 0.2 mm. 

2 Click on the Thickness  button to enable the Radial thickness 
and Axial thickness fields. 

3 Enter a Radial thickness  of 0.5 mm. 

4 Enter an Axial thickness  of 0.1 mm. 

5 In Stepover, enter: 7.0 mm. 

6 In Stepdown, enter: 4.0 mm. 

7 In the stepdown list, select Automatic. 

 The Z Heights are created automatically when the toolpath 
is calculated, and any existing Z Heights values are deleted. 

 The accuracy of the machined part produced by PowerMill is 
limited by the accuracy of the model read into the program. 
The original model must have been produced to an adequate 
tolerance. 

 

Specifying rapid move heights 
The heights at which the tool can move safely without hitting the 
part or clamps are called rapid move heights. 

Use the Rapid moves page on a strategy dialog to define the Safe Z 
and Start Z tool heights. 

 To change rapid move heights after a toolpath is calculated, 

click the Rapid Moves  button on the Main toolbar to display 
the Safe area tab of the Toolpath connections dialog. 

To specify rapid move heights 

1 Select the Rapid Moves page  on the Model Area 
Clearance strategy dialog. 

2 On the Rapid Moves page: 

a Check that Safe area Type is set to Plane. 
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b Click Calculate. 

 
 

Specifying tool start point 
1 Select the Start point page  on the Model Area Clearance 

strategy dialog. 

2 On the Start Point page, in the Use list, select Block Centre Safe. 
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This resets the tool X and Y values to the centre of the block 
model, with the Z coordinate at Safe Z. 

 
 

Generating the roughing toolpath 
On the Model Area Clearance strategy dialog: 

1 Select and expand the Leads and links page: 

a Select the Lead in sub page. 

b From the 1st choice list, select Ramp. 

2 Select the High speed page: 

a Select the Profile smoothing option. Leave the default Corner 
Radius as 0.05. 

b Select Raceline smoothing, and adjust it to a small value, such 
as 5%. 

3 Click Calculate to generate the toolpath. 

Progress is shown on the Status bar at the bottom of the screen. 
The generation may take a minute or so, depending on the 
processing power of your PC. 

4 After the toolpath is generated, Close the strategy dialog. 
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Displaying the roughing toolpath 
To improve the visual representation of the toolpath, you can: 

 Click the Plain Shade  and Wireframe  buttons to draw and 
undraw the model or wireframe. 

 

 To zoom in to the model, hold down the Ctrl key and the 
middle (or right) mouse button, and drag the mouse 
upwards. 

 Click the Block  button on the View toolbar to undraw the 
block. 
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 Click  to expand the Toolpaths branch in the Explorer. The new 
toolpath is shown in bold and preceded by the > symbol to 
indicate it's active. 

 
 Click the light bulb  next to the toolpath to toggle toolpath 

display on  or off . 
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 Click  (next to the toolpath) to expand and view the parameters 
and their specific details used to create the toolpath. 

 

 The Safety Status icon  at the top of the toolpath tree shows 
the toolpath is gouge-checked, but not checked for holder 
details. To see more information, expand the Toolpath Safety 
Parameters node in the toolpath tree. 

 

Saving project changes 
When you have unsaved changes (in this case, the toolpath 
information) in your project, an asterisk (*) is displayed in the title 
bar. 

 

Click Save  on the Main toolbar to save the project changes and 
overwrite the previous file. The toolpath information is added to 
your project, and the asterisk disappears from the project header: 
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Simulating the roughing toolpath 

To view a simulation of the toolpath: 

1 Click the ISO1  button on the View toolbar to reset the view. 

2 On the ViewMill toolbar, click the Toggle ViewMill Window  

button. It turns green , and activates the simulation window, 
which initially shows a light grey block on the current 
background. 

 

 If the Simulation toolbar is not already displayed, select 
View > Toolbar > Simulation. 

3 Select the current toolpath in the first of the two drop-down lists. 
The associated tool is selected automatically, and the Play 
buttons are highlighted: 

 

4 The buttons on the ViewMill toolbar  control 
the display of the simulation. Select the Rainbow Shaded Image 
option  for the best visual representation of material being 
removed by different toolpaths, for example roughing and rest 
roughing. 
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5 To start the simulation, click the Play  button. Allow the 
simulation to run through to the end. 

 
 

Creating the rest roughing toolpath 
The rest roughing toolpath uses a smaller tool to eliminate the large 
terraces and to rough areas of the model that the large roughing 
tool could not reach, such as pockets and corners. 

To create a rest roughing toolpath: 

1 Display the Settings for the previous toolpath. 

 

2 Click the Create a new toolpath based on this one  button. 

3 A copy of the toolpath is created with the suffix '_1'. Enter 
RestRoughing in the Toolpath name field to rename it. 
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4 Select the Rest Machining option. This switches the strategy to 
Model rest area clearance strategy and enables the Rest page. 

 
5 Define the rest roughing tool geometry (see page 45). 

6 Change the Stepover and Stepdown values (see page 47). 

7 Complete the Model rest area clearance strategy dialog, and 
generate the rest roughing toolpath (see page 47). 

8 Display the rest roughing toolpath (see page 48). 

9 Simulate the rest roughing toolpath (see page 49). 
 

Defining the rest roughing tool geometry 
You can base the rest roughing tool on the existing roughing tool, 
although it needs a smaller diameter and larger tip radius. 

This example uses a 10 mm (3/8 inch) tip radiused tool. 

1 On the Tool page of the Model Rest Area Clearance dialog (of the 

RestRoughing toolpath), click the Edit  button. 

 

2 In the Tip Radiused Tool dialog, click  to create a new tool 
entity based on the existing roughing tool. It is given the default 
name of D16T1_1. 

3 Rename the tool to D10T2. 

4 In the other fields, enter: 

a Length: 10 mm 

b Tip Radius: 3 mm 

c Diameter: 10 mm 
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d Tool Number: 2 

 
5 Select the Shank tab and change the values to: 

a Upper Diameter: 10 

b Length: 40 

The Lower Diameter automatically defaults to the Upper 
Diameter. This can be accepted for the current tool. 
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6 Click Close. 

 To see the rest roughing tool more clearly, click the light 
bulb icons for the roughing toolpath and tool, (toggle them 
to ). This undraws (but does not delete) the entities from 
the project.  

 
 

Changing the Stepover and Stepdown values 
On the Model rest area clearance page: 

1 Enter a Stepover of 3.0 mm. 

2 Enter a Stepdown of 1.5 mm. 
 

Generating the rest roughing toolpath 
On the Model Rest Area Clearance dialog: 

1 Select the Rest page, and: 

a From Rest Machining type list, select Toolpath. 

b From the Toolpath list, select Roughing (the name of your 
roughing toolpath). 

c In the Detect Material Thicker Than field, enter 0.2 mm. The 
calculation ignores rest material thinner than 0.2 mm. This 
helps to avoid thin regions being rest roughed where the 
benefit of a second cut is negligible. 

d In the Expand Area By field, enter: 0.2 mm. The rest areas are 
expanded by 0.2 mm (measured along the surface). This can 
be used in conjunction with Detect Material Thicker Than to 
reduce the areas to be machined to the essentials (such as, 
corners), and then to offset these areas slightly to ensure that 
all details (for example, on the corners) are machined. 

2 Click Calculate to generate the toolpath. 

Progress is shown on the Status bar at the bottom of the screen. 
The generation may take a minute or so, depending on the 
processing power of your PC. 

3 After the toolpath is generated, Close the strategy dialog. 
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Displaying the rest roughing toolpath 

Use the Plain Shade , Wireframe , and Block  buttons to 
undraw the model and the block, and then zoom in to view the 
toolpath: 

 
Click  to expand the Toolpaths branch in the Explorer. The new 
toolpath is shown in bold and preceded by the > symbol to indicate 
it's active. 

 

 The Safety Status icon  at the top of the toolpath tree shows 
the toolpath is gouge-checked, but not checked for holder 
details. To see more information, expand the Toolpath Safety 
Parameters node in the toolpath tree. 

To save project changes, click  on the Main toolbar. 

 



 

Autodesk PowerMill 2017  Cavity mold example • 49  

Simulating the rest roughing toolpath 
To view a simulation of the rest roughing toolpath: 

1 On the Simulation toolbar, select the current toolpath in the first 
of the two drop-down lists. The tool is selected automatically and 
the Play buttons are highlighted: 

 

2 To start the simulation, click the Play  button. Allow the 
simulation to run through to the end. 

 

 If you have not started another session since creating the 
roughing toolpath, the rest roughing toolpath is shown in a 
different colour, overlaid on the roughing simulation (see 
page 43). 

3 Click the Exit ViewMill  button, and select Yes to stop the 

simulation. The Toggle ViewMill button changes from green  to 

red , and the standard PowerMill graphics window is 
displayed. 
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Closing the roughing session 
Now you have generated the roughing toolpath. Save the project 
and close PowerMill until you are ready to create the finishing 
strategies. 

To save project changes, click  on the Main toolbar. 

To exit PowerMill, either select File > Exit from the menu, or click the 
Close button  in the top right-hand corner of the PowerMill 
window. 

 

Re-opening the project 
1 Restart PowerMill; this automatically loads your toolbar and 

colour selections from the previous session. 

2 Select File > Recent Projects from the menu, and then select the 
project containing the forging die example: 
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3 When the project is reloaded, adjust the model size and 
orientation as required. 

 
 

Checking which entities are active 
Before you create the finishing toolpaths, you can ensure they are 
automatically added to an NC program: 

1 Check if the NC program in the Explorer is shown in bold and 
preceded by the > symbol to indicate it's active. If it's not active, 
right-click the NC program name, and select the Activate option. 

2 Expand the Toolpaths node and click the light bulb icon (until it 
shows ). This undraws each of the roughing toolpaths. Now you 
can easily see the new finishing toolpaths as you create them. 
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Creating a finishing toolpath 
1 Click  on the Main toolbar to display the Strategy Selector 

dialog. 

2 On the Finishing tab, select the Steep and Shallow Finishing 
strategy and click OK. 

 
3 In the Steep and Shallow Finishing dialog: 

a In the Toolpath Name field, enter SteepAndShallow. 

b Select Climb from the Cut direction field. 
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c Change the Stepover value to 0.5. 

 
 

Defining the finishing tool geometry 
The tool currently selected for the Steep and Shallow Finishing 
strategy dialog is the same tool that was used for the rest roughing 
toolpath. This tool is not appropriate for the current toolpath 
strategy, and must be changed. This example uses an 8 mm (5/16 
inch) ball nosed tool. 

1 In the Steep and Shallow Finishing strategy dialog, click to 
select the Tool page. 

2 On the Tool page, from the tool list, select  to create a Ball 
Nosed Tool. 

3 On the Tool page, click  to display the Ball Nosed Tool dialog. 

4 In the Ball Nosed Tool dialog, enter: 

a Name: 8 Ball_LS_TH 
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b Length: 20 mm 

c Diameter: 8 mm 

d Tool Number: 3 

 

5 Select the Shank tab, click  to add a shank component. Enter: 

a Upper Diameter: 12 

b Lower Diameter: 8 
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c Length: 25 

 

6 Click the  button to add a second shank component. Enter: 

a Upper Diameter: 12 

b Lower Diameter: 12 



 

56 • Cavity mold example  Getting Started  

c Length: 30 

 

7 Select the Holder tab, and click the  button to add a holder 
component. Enter: 

a Name: 8 mm Ball Holder 

b Upper Diameter: 20 

c Lower Diameter: 20 

d Length: 20 
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e Overhang: 55 

 

8 Click the  button to add the upper part of the holder. Enter: 

a Upper Diameter: 60 

b Lower Diameter: 60 

c Length: 10 
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d Overhang: 55 

 
9 Click Close to update the Tool page with the new tool. 

 The new tool is shown in the Explorer, and on the Tool 
toolbar, and it's also drawn in the graphics window, where 
it is automatically aligned with the Z axis. 
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The toolpath is not yet complete as it needs to reference a 
boundary, but you can close the dialog without generating the 
toolpath. 

10 Click OK to close the toolpath dialog. 
 

Creating the boundary for the selected surface 
As it is only the cavity that needs to be finished by this toolpath, 
you can create a boundary for the cavity. 

1 Undraw the 8 Ball_LS_TH tool by toggling the light bulb icon to  
in the Explorer. 

 

2 Click the Block  button to undraw the block, and use the 

Wireframe  button to undraw the wireframe. 

3 Use the mouse to select only the cavity surfaces. 

 

 You can use the Drag Selection Mode  on the View toolbar 
to select multiple surfaces. 
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4 In the Boundaries context menu, select Create Boundary > 
Selected Surface. 

 
5 In the Selected Surface Boundary dialog: 

a In the Name field, enter Cavity. 



 

Autodesk PowerMill 2017  Cavity mold example • 61  

b In the Tool list, select 8 Ball_LS_TH. 

 
6 Click Apply. 

7 The boundary is calculated. By default, it's displayed in white. 

 

 Selected Surface Boundaries are recalculated if the selected 
surfaces change. This means that they behave like 
toolpaths in the way they take account of the selection 
state at the time of calculation. 

8 Click Accept to close the boundary dialog. 
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Completing and generating the finishing toolpath 
You now need to add the created boundary to the Steep and Shallow 
Finishing toolpath together with the appropriate leads and links. 

1 In the Explorer, expand Toolpaths and select the 
SteepAndShallow toolpath. 

2 Right-click and select Settings from the context menu. 

 
3 On the Steep and Shallow Finishing strategy dialog: 

a Select the Limit page and: 

From the Boundary list, select Cavity. 
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From the Trimming list, select Keep inside. 

 
b Expand the Leads and Links page, select the Lead in sub-page 

and: 
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In the 1st Choice list, select None. 

 
c Select the Links sub-page to define link moves between the 

cutting moves in the toolpath and: 
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In the 1st choice list, select On surface to define the type of 
link moves used to connect adjacent passes. 

 
4 Click Calculate to generate the toolpath. 

Progress is shown on the Status bar at the bottom of the screen. 
The generation may take a minute or so, depending on the 
processing power of your PC. 

5 After the toolpath is generated, Close the strategy dialog. 
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Displaying the finishing toolpath 
When the toolpath is generated, it is displayed on the screen: 

 
Click  to expand the Toolpaths branch in the Explorer. The new 
toolpath is shown in bold and preceded by the > symbol to indicate 
it's active. 

 

To save project changes, click  on the Main toolbar. 
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Simulating the NC program with generated toolpaths 
The new toolpath is automatically added to the active NC program. 
If for some reason, your toolpath is not there, use the mouse to 
drag the toolpath under the NC program manually. 

 

To simulate the NC program: 

1 Click the ISO1  button on the View toolbar to reset the view. 

2 On the ViewMill toolbar, click the Toggle ViewMill Window  

button. It turns green , and activates the simulation window, 
which initially shows a light grey block on the current 
background. 

3 From the ViewMill Toolbar , select the 
Rainbow Shaded Image option  so the differences between 
toolpaths are seen more easily. 

4 In the Explorer, right-click the NC program Cavity_Mold, and 
select Simulate from Start from the context menu. 

 
The NC program is automatically selected on the Simulation 
Toolbar, and the Play buttons enabled. 
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5 Click the Play  button, and allow the simulation to run through 
to the end. 

 
6 Zoom into the unmachined areas. You can see that some of the 

corners need cleaning up, particularly between non-tangential 
surfaces. 

 

7 Click the Exit ViewMill  button, and select Yes to stop the 

simulation. The Toggle ViewMill button changes from green  to 

red , and the standard PowerMill graphics window is 
displayed. 
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Creating the Corner Finishing toolpath 
The Corner Finishing toolpath uses a smaller tool to machine the 
remaining corners, particularly between non-tangential surfaces. 

To create the Corner Finishing toolpath: 

1 Click  on the Main toolbar to bring up the Strategy Selector 
dialog. 

2 Select the Corner Finishing strategy on the Finishing tab, and 
click OK. 

 
3 In the Corner Finishing dialog: 

a In the Toolpath name field, enter CornerFinishing_Auto. 



 

70 • Cavity mold example  Getting Started  

b Select the Limit page and choose None from the boundary list. 

 
 

Defining the Corner Finishing tool geometry 
You can base the Corner Finishing tool on the tool used for the 
SteepAndShallow strategy, although it needs a smaller diameter. 
This example uses a 6 mm (1/8 inch) ball nosed tool. 

1 Select the Tool page in the Corner Finishing dialog. 

2 From the tool list, select 8 Ball_LS_TH, and click the Edit  
button. 

3 In the Ball Nosed Tool dialog which appears, on the Tip tab, click 

 to create a new tool entity based on the existing tool. 

It is given the default name of 8 Ball_LS_TH_1. 

a Rename the tool to 6 Ball. 

b Enter a Length of 15 mm. 

c Enter a Diameter of 6 mm. 
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d Enter the Tool Number as 4. 
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4 To adjust the shank to match the tip, select the Shank tab, click 
the bottom shank component (it turns pale green), and enter 6 in 
the Lower Diameter field. 

 
5 You can leave the Holder as it is. Click Close to update the 

toolpath dialog with the new tool. 

The new tool is shown in the Explorer, and on the Tool toolbar, 
and it's also drawn in the graphics window, where it is 
automatically aligned with the Z axis. 

 

Completing and generating the Corner Finishing 
toolpath 

In the Corner Finishing strategy dialog: 

1 Select the Corner finishing page and: 

a From the Output list, select Both. This creates two separate 
toolpaths for steep and shallow regions. 

b Enter a Threshold Angle of 65. This specifies the angle, 
measured from the horizontal, that determines the split 
between steep and shallow portions of the surface slope. 
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c Enter a Cusp of 0.01. This defines the maximum allowable 
cusp height. The stepover between tool passes is 
automatically calculated from this value and the geometry of 
the tool and part. 

d From the Cut direction list, select Any. This uses both the 
Climb and Conventional methods of milling. 

2 Select the Corner detection page and: 

a Select 8 Ball_LS_TH from the Reference tool list. The Corner 
Finishing toolpath makes a comparison between the current 
and previous tools, and automatically machines the corners 
that the previous tool was unable to access. 

b Enter an Overlap of 0.5. This indicates how far the toolpath is 
extended beyond the borders of the unmachined region. It is 
also used as the overlap value between the steep and shallow 
portions of the toolpath. 

c Enter a Detection limit of 165. This specifies the angle at which 
PowerMill finds corners. Only corners less than the specified 
angle are machined. 

3 Click Calculate to generate the toolpath. 

Progress is shown on the Status bar at the bottom of the screen. 
The generation may take a minute or so, depending on the 
processing power of your PC. 

4 After the toolpath is generated, Close the strategy dialog. 
 

Displaying the Corner Finishing toolpath 
When the toolpath is generated, it is displayed on the screen: 
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Click  to expand the Toolpaths branch in the Explorer. The new 
toolpath is shown in bold and preceded by the > symbol to indicate 
it's active. 

If the NC program Cavity_Mold remains active, the toolpath is 
automatically added to it: 

 

To save project changes, click  on the Main toolbar. 
 

Simulating the Corner finishing toolpath 

1 Click the ISO1  button on the View toolbar to reset the view. 

2 On the ViewMill toolbar, click the Toggle ViewMill Window  

button. It turns green , and activates the simulation window, 
which initially shows a light grey block on the current 
background. 

3 From the ViewMill Toolbar , select the 
Rainbow Shaded Image option  so the differences between 
toolpaths are seen more easily. 



 

Autodesk PowerMill 2017  Cavity mold example • 75  

4 In the Explorer, right-click the NC program Cavity_Mold, and 
select Simulate from Start from the context menu. 

 
The NC program is automatically selected on the Simulation 
toolbar, and the Play buttons enabled. 

 



 

76 • Cavity mold example  Getting Started  

5 Click the Play  button, and allow the simulation to run through 
to the end. 

 
6 Zoom into the machined areas to view the cleaning up of the 

non-tangential surfaces. 

 
This compares the previous finishing toolpath which left some 
material in the corners. 
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7 Click the Exit ViewMill  button, and select Yes to stop the 

simulation. The Toggle ViewMill button changes from green  to 

red , and the standard PowerMill graphics window is 
displayed. 

 

Writing NC programs 
When the toolpaths are generated, you can add them to an NC 
program to be postprocessed as an output file for a specific NC 
machine controller. Any number of toolpaths can be included and 
reordered, as required, depending on the limitations of the 
particular NC machine and the postprocessor. 

By default, all toolpaths in an NC program are saved to a single NC 
program file. The following examples show you how to: 

 Write each toolpath as a separate NC program file (see page 77). 

 Write two NC program files (see page 79) with the toolpaths 
grouped by their functionality. 

 

Writing each toolpath as a separate NC program file 
This procedure shows how to generate separate NC program files 
for each toolpath in an NC program. 

 To have separate NC program files for each of your toolpaths, 
the Write File for Each Toolpath option must be selected on the 
Output tab available from Tools > Options > NC Programs. 

1 In the Explorer, right-click the NC program, Cavity_Mold, and 
select Write from the context menu. 
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 The tool symbol  next to a toolpath indicates a tool 
change. It is always displayed for the first tool in the 
sequence. It is also displayed when a different tool is used. 

2 PowerMill postprocesses the toolpaths using the specified 
parameters, and displays a confirmation window showing where 
the files are saved. 

 
3 Click  to close the Information window. 

4 The colour of the NC program Cavity_Mold in the Explorer 
changes to a bright green colour, , to show it has 
been calculated correctly. 

5 To save project changes, click  on the Main toolbar. 
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Writing two NC program files 
This example shows how to generate two NC program files, one 
with two roughing toolpaths, and another with the two finishing 
toolpaths. 

1 From the NC Programs context menu, select Create NC Program. 

 
This displays the NC Program dialog. 

2 In the Name field, enter Cavity_Roughing. 

3 In the NC Program dialog, click the Options  button. The 
Options dialog is displayed. 

4 On the Output tab: 

a If selected, deselect the Write File for Each Toolpath option. As 
a result, the Output File is displayed at the top of the NC 
Program dialog instead of the Root Name. 

b Select Option File as heid400. 

c Enter Output File Extension as pmoptz. 
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d Click Accept to update and close the Options dialog. 

 
5 Click the Accept button at the bottom of the NC Program dialog to 

create a new roughing NC program. 

6 From the individual NC Program, Cavity_Roughing, context menu, 
and select Edit > Copy NC Program. 

7 A new entity is added to the NC Programs list with the default 
name of Cavity_Roughing_1. Right-click it and Rename it as 
Cavity_Finishing. 

 

 To identify which NC program is currently active, expand 
the NC Programs node in the Explorer; the active program 
is shown in bold and preceded by the > symbol. 
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8 In the Explorer, move the two roughing toolpaths under 
Cavity_Roughing, and the two finishing toolpaths under 
Cavity_Finishing. 

 
9 Select the Cavity_Roughing and Cavity_Finishing NC programs. 

Right-click and select Write Selected. 
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10 PowerMill postprocesses the NC programs using the specified 
parameters, and displays a confirmation window showing where 
the programs are saved. 

 

 Two NC programs are written: Cavity_Roughing.tap 
containing both roughing toolpaths, and Cavity_Finishing.tap 
containing both finishing toolpaths. 

11 Click  to close the Information window. 

12 To save project changes, click  on the Main toolbar. 
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3 
3D offset moves • 15 

A 
Along moves • 69 
Area clearance 

Offset • 31, 44 
Tool geometry • 32, 45 

C 
Cavity mold example • 15 
Constant Z moves • 15 
Contour offsetting • 15, 49 
Corner finishing • 69, 74 
Creating tree objects •  See Entities 
Cutting length • 36 

D 
Defining block • 18 
Displaying toolpaths • 40, 48, 66, 73 

E 
Entities 

Verifying active • 51 

F 
Finishing toolpaths 

Interleaved constant Z • 52 
Tool geometry • 53, 70 

Forging die mold •  See Cavity mold 
example 

G 
Gauge length • 36 
Graphics window • 6 

H 
Holder length • 36 

I 
Imperial units • 5, 12 
Isometric vews • 21 

M 
Metric units • 5, 12 
Models 

Opening • 16 
Resizing to fit • 21, 24 
Shading • 21 
Viewing • 21 

N 
NC programs 

Creating • 26 
Setting preferences • 26 
Writing • 77, 79 

Index 



 

84 • Index  Getting Started  

O 
Opening 

Models • 16 
Projects • 50 

Overhang • 36 

P 
PowerMill 

Closing • 5 
Context help • 13 
Entities • 10, 12 
Explorer • 10, 51 
Manuals • 14 
Projects 

Opening • 50 
Saving • 20, 42 

Starting • 5 
Startup window • 6 
Status bar • 13 
Toolbars 

Main • 6, 31 
Tooltips • 13 
Units 

About • 5, 12 
Changing to imperial • 12 

R 
Rapid move heights • 13, 37 
Resizing to fit • 21, 24 
Roughing toolpaths 

Rest roughing • 44 
Roughing • 31 
Tool geometry • 32, 45 

S 
Screen layout • 6 
Selected surface boundary • 59 
Shank length • 36, 45 
Stepdown • 37, 47 
Stepover • 37, 47 
Stitch moves • 69 
Surfaces 

Non-tangential, machining • 69 
Selecting • 59 

T 
Temporary file area • 4 
Tip length • 36, 45, 70 
Toggle Simulation window • 43, 49, 67, 

74 
Tolerance • 37 
Tool geometry • 32, 45, 53, 70 
Toolbars 

Main • 6, 31 
Toolpath 

Displaying • 40, 48, 66, 73 
Finishing • 52, 62, 69 
Roughing • 31, 44 
Simulating • 43, 49, 67, 74 
Writing • 77, 79 

Tools 
Ball nosed tool • 53, 70 
Length definitions • 36 
Start point • 38 
Tip radiused • 32, 45 

Tooltips • 13 

V 
ViewMill • 43, 49, 67, 74 
Views 

Isometric • 21 
Locating • 24 
Panning • 26 
Predefined • 21 
Zoom in and out • 24 

W 
Wireframe • 21, 40, 48, 59, 66, 73 
Working directories • 2 

Setting up a Home environment in 
Windows • 2 
Setting up your working directories • 
2, 4 
Specifying PowerMill Default 
Directory paths • 3 
Specifying PowerMill temporary file 
area • 4 

 


