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1. 3+2 Axis Machining
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1. 3+2 Axis Machining

Introduction

3+2 Axis Machining involves indexing the head and\or bed to re-align the tool at
a fixed angular, orientation, to perform machining strategies. The 3+2 alignment is
actioned either by manual adjustment or as part of the CNC control.

The most common method of creating a 3+2 Axis is by using a Workplane with
the Z-Axis arranged at an appropriate Tool Axis alignment. Standard 3 Axis
strategies and their plunge and retract moves will occur relative to the
Workplane.

3+2 Axis machining enables:-

a

All faces of a component (except the base) can be machined in one set-up,
relative to a common tool setting datum.

Access to deep sidewalls with standard length tooling.

Access to undercut features.

3+2 Axis - Machining Example

1 Open the following Project:
~.\PowerMill_Data\five_axis\3plus2_as_5axis\3Plus2-ex1-Start

P Autodesk PowerMill Ultimate 2017 [ Read-Only Project * 3plus2-ex1-Start |

File View Insert Draw Tools Help

BH S STTIVE ST & & B
It ®

B3 Active
2 Machine Tools
&30 NC Programs
-8 Toolpaths
() § & DA0TRE-TopRuf-A1
7 B DA0TR6-TopFin-Al
9 B8 DA0TR6-TopFin-A2
i Tools
7 || > Da0TRE
9 L ootra
(D Boundaries
..... 4§ Patterns
) Hole Feature Sets
{4 Feature Groups
1 Workplanes
Wil > ztop-175.A
1 12 Posn-B-C-top
2 12 Posn-C-top
% 12 Posn-D-top
2 12 Posn-D-B-top
£ Levels and Sets
@ Models
& Stock Models
¥ Groups
&8 Macros

v kZ @

2 Save the Project as:
+\COURSEWORK\PowerMill-Projects\3Plus2-ex1
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1. 3+2 Axis Machining

A 3-Axis Roughing strategy and two 3-Axis Finishing strategies

already exist in the imported Project.

Also, a series of workplanes are already included in the Project, with
one just above the top of the model at Ztop-175_A at 750mm above the
Transform. This workplane will be used as the main machining datum.

Note the relatively high sides of the component and the orientation of the

three recesses making it impossible to machine them as 3 Axis with the
tooling aligned to the vertical axis.

S
<

The pocket located along the X direction will be the first to be assigned with a new
workplane to control one of the 3+2 - Tool Axis alignments.

3 From the PowerMill explorer select Workplane > Create and Orientate
Workplane > Workplane Aligned to Geometry.

4 Using the left mouse button, snap or box the wireframe crossover at the base of
the first pocket (located along X from workplane ztop-175_A).

e Workplanes
Create Workplane...
Get Workplanes from Model...
Create and Orientate Workplane
Workplane Names

FEER

* @ Lw;ls an

+- g Models
& Stock Mo
(7 Groups

-5 Macros

Felder Names
Deactivate
Draw All
Undraw All

5 Activate the new Workplane 1.

>
>

»

Workplane at Point...
Multiple Workplanes...

Werkplane from Three Points...
Werkplane from Three Arc Points...
Werkplane Aligned to Geometry...

Workplane from Revolved Surface...

Snap to Wireframe

— |

1 -2 Autodesk PowerMill 2017

Copyright © Autodesk



{\ AUTODESK.

1. 3+2 Axis Machining

The workplane is automatically aligned to the wireframe with the Z Axis
normal to the surface. It still requires further editing as it is advisable for the X-
Axis to align anticlockwise as viewed from the top of the component

= E‘f Workplanes
1, top-175.A
i E, Posn-B-C-top
fi B_f‘_, Posn-C-top
i E‘."- Posn-D-top
i lr‘_, Posn-D-B-top

A

T é? Levels and & 1

+- i@ Models
& Stock Mode Workplane Editor... |}
IS Tenmelnoma

6 From the PowerMill explorer, right-click on Workplane 1 and from the local
menu, select the Workplane Editor toolbar to open the following toolbar.

D Mame 1 gﬁg@%ggg @"%"méﬂ.ﬂ‘

7 Select Twist about 2 @ and in the dialog, input an Angle of =90 (normal to
the base of the recess).

P Twist ? X
Angle
®
Accept Cancel

The X-Axis of the workplane should be pointing anticlockwise relative to the
Transform (Global Datum) as viewed from the top of the component (If not already
the case).

8 Select \/ to save the changes and exit the Workplane Editor toolbar.
Rename Workplane 1 as Align_B.
10 Activate the Workplane - ztop-175_A.

11 Right-click on the Workplane, Align_B, and from the local menu select

Transform.
5 e Y Align_B |
i-£7 Levels and Align_B
i@ Models -
-4 Stock Mod Workplane Editor...
-r” Groups Transform...
-7 Macros %

12 Select the Rotate workplanes option (shown arrowed below).

B9 e &R
ﬁlle
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1. 3+2 Axis Machining

13 In the Rotate dialog, select Keep original. ||:D

14 Input No. of Copies 2, Angle 120, to create two new workplanes (Positioned
normal to the base of the next pocket in an anticlockwise direction as viewed
from the top).

Rotate

[DND.D'FCDFHES 2 ~  Angle 120 ~ I% @@ X

15 Select the small cross on the right of the toolbar to exit the dialog.

Align_B_1

Align_B

Align_B_2

16 Select ».f at the end of the Workplane Editor toolbar to accept the new
Workplanes (Align_B_1 & Align_B_2).

17 Rename the 2 new Workplanes (in anticlockwise order) as Align_C and
Align_D respectively.

The component is nhow ready to have the 3 Plus 2 machining strategies created,
relative to the three new workplane alignments. (Align_B, Align_C, and Align_D).

For each of the 3 Pockets a rectangular material Block will be created locally,
relative to the aligned 3+2 workplane. A Model Boundary will also be created
around each pocket to provide even more control of the machining strategy limits.

18 Activate the Workplane Align_B.
19 Select the 2 surfaces that define the pocket around Workplane Align_B.
20 Calculate a Block using Defined by, Box and Type, Model.

1-4 Autodesk PowerMill 2017 Copyright © Autodesk
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P Block ? X
Defined by
= J pExees

Coordinate System

| Active Workplane B I
Limnits
Min Max Length

x[-264m391] Ry [26473911] | 52947822 @5

v [-1atou0] B0 [138ss620] §g [28050123 @y

z[-00 | G| [19368158] §5| [19368158] By

= ES
Estimate limits
Tolerance Expansion Type
CC

[ Include reference surfaces

21 Ensure that the pocket surfaces are still selected so that the Rapid move
heights calculation ignores the de-selected surfaces.

22 In Rapid move heights :—ﬁ input the operational Workplane as Align_B and
select Calculate to create values for Safe Z and Start Z aligned to the
appropriate coordinate system.

P Toolpath connections ? X

Safearea Moves and clearances Start and end point  Lead ins Lead outs  Links  Point distribution

Safe area Calculate dimensions

Type | Plane v Meazured frond] Block and Model

‘ Workplane | Align_B ' w Rapid clearance

PIungecIearance
Mormal
2 | |0IO | |1.0 | Calculate

Rapid height
Plunge height

Use polar links

I=O Input the Workplane (Align_B) for a Rapid move height plane that is
parallel to the pocket base.

I:C? Rapid move heights are calculated from the maximum Z value of the
Block and Model (or selected Model entities), whichever has the
maximum Z height.

23 Create a User Defined - Model - Boundary named Pkt-B1 around the top

edge of the pocket (surfaces still selected!) that surrounds the Workplane
(Align_B).

24 Activate the existing Tiprad tool D10TR1.
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25 Set the 1st Choice, Lead In to Ramp with Ramp Options as Zig Angle 4,
Follow Circle, and Diameter (TDU) 0.6.

26 In the Strategy Selector dialog in 3D Area Clearance select Model Area
Clearance and fill in the options in the pages, exactly as shown below:

P Model Area Clearance

*

. Toolpath name |D‘|{3TR‘|-Rgh-B'I

----- 12, Workplane e [Model area clearance ]
-l Block
----- U Tool e
----- I Machine tool
----- o8 Limit
[-].--f Model area clearance
...l Offset
.."ng Step cutting | DRt . |
Wall finishi
@} Wallfinishing Cut direction
ﬂ Unzafe segrﬁent removal Profile Area
=l Fl_at machining | Climb V| | Climb v|
--TF High speed
=
/_-\';r Order Tolerance
-y Approach
o
- Automatic verification
j{ Cutter compensation Thickness
----- #+ Point distributicn
----- E Tool axis D =
----- i@ Machine axis control
[j--gf Rapid Moves ik
-1 Leads and links
@4l Start point
..ol End point b 7 Do
|Autu:rmatic V| 3.0
Constant stepdown

[ Rest machining

Calculate Queue 0K Cancel

= Toolpath name: D10TR1-Rgh-B1
= Style: Offset model

27 In the Limit page input the Boundary Pkt-B1 and set Limit tool periphery to
boundary.

Lirnit

o5 |
![:.:‘-J;

c|

28 Select Calculate to create the toolpath and then Cancel the dialog.
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1. 3+2 Axis Machining

The toolpath plunge moves are aligned to the Active workplane’s, Z Axis.

29 Use Copy [_H to create cloned strategies for the other two recesses, adjusting

the values and settings as required to create toolpaths, D10t1-Rgh-C1 and
D10t1-Rgh-D1.

a Rapid Move Heights must be defined separately for each toolpath with an
appropriate Workplane selected in the dialog (Remember to check for the correct
Workplane in the dialog).

P Model Area Clearance ? *

132 |[Im Toolpath name [ DIDTRI-Rgh-Ct ]
L]

12 Workplane ~ W
@ Block

] Teol Safe area
B, Machine tool T)’l“l Plane V}
¥ Limit = ]
5 & Model area clearance Workplane | Align_C -
| - Offset
~-"ag Step cutting
@) wall finishing
—dib Unsafe segment removal Normal
| @ Flst machining 0.0 | [00 | [10 ‘ ﬂ
ﬂf High speed
:;; ::::a " Rapid height [ 45.012328
| W Automatic verification Plunge height | 40.012328
B Cutter compensation Use polar links
| 1} :LT:(:'"DW“ Calculate di i
# Machine axis control Messured from | Block and Model =
-3 g Aapid e 20|
.= Moves and clearances
110 Leads and links Plunge clearance
| Start point b

rég.

Calculate

Draw rapid surface []
Draw plunge surface []

[Caiculate | | Queve | [ ok | | Cancel |
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30 Don't forget to create and activate the correct User defined - Model -
Boundaries named Pkt-C1 and Pkt-D1.

After the creation of toolpaths for 3 + 2 Axis valid ncdata can only be output
using a compatible, post-processor. For programs containing multi-alignment
toolpaths the NC Programs output options create the ncdata from one datum (In
this case the Workplane - ztop175_A). This option is selected in the NC
Preferences or NC Program Settings dialog.

31 In the PowerMill explorer, right-click on NC Programs and select
Preferences.

32 From the Machine Option File select Mazak_Variaxis_5axis_ref.pmoptz as
the controller.

33 For the Output Workplane select ztop-175_A.
Output  Toolpath = Fixture offset  Verification

Changes made here will not change existing NC Programs

Use Project Output Folder| ChTermp\MNCPrograms | B‘A

Output Filel {ncprogram} |

Machine Option File | C:\dcam\com‘ig\ductpost\Mazak_\n‘ariaxis_fraxis_rul @)

Machine Tool ~ Model Location b
Output Workplane ztop-175_A i % Part Mame I:I

Automatic ToolAlignment Connection Moves | Mowve, Rotate R

Close

34 Close the dialog.

1-8 Autodesk PowerMill 2017 Copyright © Autodesk
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1. 3+2 Axis Machining

35 In the PowerMill explorer, NCPrograms, select Create an NC Program and
add the toolpaths, D10TR1-Rgh-B1, D10TR1-Rgh-C1, and D10TR1-Rgh-D1.

= Toolpaths

w-¢) § £ DAOTRE-TopRuf-Al
¢} ¢ BB DA0TRE-TopFin-A1
) ¢ B8 DAOTR6-TopFin-A2

B0 § & D10TRI- F‘gh B1
EROLE 4 :
EE@TSE 1> D10TR1- Toolpaths (3]
g "Too; U DAOTRE Draw Selected
q U > D10TR1 Undraw Selected
=-{) Boundaries Add to 3 Stock Model
T o Pkt-B1 Create Individual NC Programs MNC Program
?Q pkf_:q__ Load Tool Cutting Data Group h
= X
4 Neme 1 e
Output Fie C:\Temp\NCPrograms\(ncprogram) a
Machine Option File  C:\dcami,configatra-posts\MS-GVS03- 1.opt - @ ..;\ ?E
Machine Toel v Model Location v
Output Workplane zop-1TS.4 Part Name 1
Program Number 1 Tool Value Tip v

Automatic Tool Alignment On v Connection Moves  Move Rotate w

Toolpath MNum.. Diame.. Tip Gauge Overha.. Toleran.. Theckn.. TeollD

DIOTRI-Ruf-B1 1 10 1 130 n 01 05 D0TR1

DIOTRI-Rud-C1 (1) 10 1 130 ] o1 05 DI0TR1

DIOTRI-Rud-D1 (1) 10 1 130 ] o1 05 DI0TR1

€ ¥
ToolChange On MewToal  « Tool Numbering 45 Specified v

u H Reset Tool Change Position | After Connection

36 In the NCProgram:1 dialog select Write to successfully create the Output File
but note the red warning messages in the displayed Information dialog.

P Information ? *
A

Complete

Write NC Program

NC program : C:Temp/NCPrograms/1 tap

NC program potentially has safety problems, inspect the NC program
verification form for more information

Toolpath D10TR1-Rgh-B1

Toolpath D10TR1-Rgh-C1

The toolpath Z axis has changed.

Toolpath D10TR1-Rgh-D1

The toolpath Z axis has changed.

Postprocessed.

Copyright © Autodesk Autodesk PowerMill 2017 1-9
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1. 3+2 Axis Machining

37 In the PowerMill explorer switch on the lightbulb adjacent to NCProgram 1 to
display it in the graphics area.

Y
& The link moves between the three individual 3+2 toolpaths are

displayed in the NC Program and in this case are shown to be passing
straight through the component!

T

Automatic gouge protection only exists within a toolpath (Between the Start and
End Point). After inserting the toolpaths into an NC Program, it is essential for the
user to independently control the Positional Moves outside the toolpaths to
eliminate any collisions with the component and fixtures.

1-10 Autodesk PowerMill 2017 Copyright © Autodesk
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1. 3+2 Axis Machining

Link moves controlled by Absolute Start and End points

This method of creating safe link moves between separate 3+2 toolpaths is the
most universal and reliable method for all types of application and post-processor.
The start and end point for each toolpath is defined with absolute coordinates
positioned above the maximum Z height of the component.

38 Activate the toolpath D10TR1-Rgh-B1.
39 Select a View from right (X).

40 Switch on both Draw - Cursor - Crosshair (Ctrl H) and Tool (Ctrl T).
41 Move the cursor to a suitable Start/End point above the top of the model.

Lo

The X, Y, and Z coordinate values are displayed in the information toolbar located
below the graphics area.

0 130.32 100.049

Copyright © Autodesk Autodesk PowerMill 2017 1 - 11
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1. 3+2 Axis Machining

42 Make a note of the individual Y and Z values as integers eg. 130 and 100.

The Rapid Move - Safe Z value must now be matched to the Z value in Start and
End Point dialog.

43 Open the Rapid Move Heights dialog, edit the Safe Z value to 100 before
selecting Apply at the bottom of the dialog (to update the toolpath).

P Toolpath connections ? bd

Safearea Moves and clearances  Start and end point Leadins Lead outs Links Point distribution

Safe area Calculate dimensions

Type | Plane W Measured from | Block and Model v|

Workplane |Align_B v Rapid clearance
Plunge clearance

MNormal
T | O
Calculate

Rapid height
Plunge height

Use polar links

44 Open the Start and end Point dialog
P Toolpath connections ? X

Safearea Moves and clearances Start and end point | ead ins Lead outs Links  Point distribution

Start point End point

‘ Use |Ab50IL_|9 v| ‘Use |Abso|u_19 v|

Incremental plunge ]

Direct move[] Direct move []
Override tool axis Override tool axis
Separate approach Separate retract
Approach distance Retract distance

Incremental plunge distance

Distance

Coordinates Coordinates

o (i (g:

Tool axis Teol axis

o o % R s | i —
Apply start Apply end

[+] Gouge check Apply both

Apply Accept Cancel

45 For both the Start point and End point select Use - Absolute and input the
new Y value (130).

46 Select Apply both(to update the toolpath).

1-12 Autodesk PowerMill 2017 Copyright © Autodesk
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1. 3+2 Axis Machining

47 Repeat the above editing process on the other two 3+2 toolpaths D10TR1-
Rgh-C1 and D10TR1-Rgh-D1 but this time use the values 130 and 120.

Y
&  Note the new values (eg 130 120) due to these pockets being in the
corners of the main section with more of the main body to clear.

Start Point | End Point

Method

Override Tool Axis

Approach Distance

Coordinates
[-0022823 | [1300  |[1300 | [iF

Tool Axis
[0 |00 [[10

R |

Apply Start Point |

|| Accept || Cancel |

Copyright © Autodesk Autodesk PowerMill 2017 1-13
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4

48 Select File > Save to update the contents of the previously stored Project.

1-14 Autodesk PowerMill 2017 Copyright © Autodesk
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1. 3+2 Axis Machining

3+2 Axis — Stock Model Application

The Stock Model represents the un-machined material at any point in the
machining process. An empty Stock Model is created, followed by applying the
material Block and\or any number toolpaths to be considered in the process. The
Stock Model is then updated by selecting Calculate, to display the current ‘un-
machined’ material remaining.

1 Select File - Delete All and Tools - Reset forms.

2 Import the Model:
...\PowerMill_Data\five_axis\AnglePad\StockModelRest.dgk

3 Save Project As:
+\COURSEWORK\PowerMill_Projects\StockModel-3Plus2

The model includes undercut features which for a normal 3-Axis application,
would require the component to be machined in two separate set ups. However,
by applying 3+2 with separate workplanes controlling the tool alignments,
the whole project can be completed in one setup. During an initial 3-Axis
operation, the undercut pockets will be partially machined which provides an
application for using Stock Model to enable the user to optimise the 3+2
machining.

4 Calculate a Block using Defined by - Box, Type - Model, and the
Coordinate System set to Global Transform.

P Block

Defined by

|Box vl

Coordinate System
Active Workplane |v

Active Workplane

Gleobal Transform k

Mamed Workplane
T

ToTER

5 Accept the dialog.

=z By creating and locking the material Block to the Global Transform (world
co-ordinate system), the orientation and position will remain unchanged if
a Workplane is made Active.

Copyright © Autodesk Autodesk PowerMill 2017 1 - 15
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Create a Dia 16 - tip radius 3 tool named D16TR3.
Create a Dia 12 - tip radius 1 tool named D12TR1.
Activate the tool D16TR3.

Activate Workplane 1.

© 00 N o

10 In the Rapid Move Heights dialog E select Calculate.
11 Use the default settings for both the Start point and End point @

12 Select the Strategy Selector g and from 3D Area Clearance select Model
Area Clearance filling in the options in the pages, exactly as shown below:

P Model Area Clearance ? %
! Toolpath name |D16TR3—TopRgh |
----- 12, Workplane e [Model area clearance ]
- Block
----- U Teol s
..... 2, Machine tool
..... o Limit
[—j$ Meodel area clearance
----- & Offset
..... g Step cutting | Ll ve] V|
..... @&l wall finishing Cut directi
ut direction
ﬂ Unsafe segment removal Profile Area
-.g@» Flat machining | Climb V| | Climb v|
..... ﬁ= High speed
-
..... % Order Tolerance
..... Approach
v -
----- w Autematic verification _
Q_ Cutter compensation Thickness
..... 2 Point distribution i
..... E Tool axis g =
----- & Machine axis control
[j--j Rapid Moves AP
[j]l Leads and links
e{’f Start point
..ol End point Y Sepdony
Automatic ~ El\p 3.0
Constant stepdown

[[] Rest machining

Calculate Queue 0] 4 Cancel

Lead in ]

-

eads and links

‘r:' _.. 1st choice
T Lead out Ramp ¥
<>

13 In the strategy explorer, select the Lead in option and in the new page select

1st choice Ramp followed by Ramp options <>

1-16 Autodesk PowerMill 2017 Copyright © Autodesk
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14

15
16

17
18
19

20
21

In the Ramp Options dialog, Input Max zig angle 4 using a Circle with a
diameter of 0.65 (TDU).

P Lead In Ramp Options ? »

1st Choice  2nd Choice

Follow Max zig angle
| Circle v 40
Circle diameter (TDU)
Closed segments only
Ramp height
Type Height

|Incrementa| v| 5.0

Accept both the Ramp Options and Leads and Links dialogs.

Back in the main strategy dialog, select Calculate to create the toolpath and
then Close.

Select an ISO 1 view.
Activate Workplane 2 (The Block remains in situ!).

In the PowerMill explorer, right-click on Stock Models and from the local
menu, select Create Stock Model to open the following dialog.

a:'

MName

K |
Tolerance Stepover

Rest thickness Workplane

a -

Accept Cancel

Input the above values and Accept the dialog.

In the PowerMill explorer, right-click over the toolpath D16TR3-TopRgh and
from the local menu select, Add to - Stock Model.

-6 Toolpaths
oYy
=-ilf Tools D16TR3-TopRgh
- || = D16TR3
m- ¢ ) D12TRT Simulate from Start
(:] Boundaries )
_____ E‘fﬁ Patterns ' Activate
_____ @ Hole Eeature Sets Activate Workplane
Add to ¥ Stock Model [} |
Crnntn ladeadual AT Menoaraon. - LTl i

Copyright © Autodesk
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22 In the PowerMill explorer, right-click over the new Stock Model 1 and from
the local menu, select Calculate.

23 With the local Stock Model menu still open, select, Drawing Options >
Shaded and Show Rest Material.

The 3-Axis Roughing operation has removed all accessible material leaving a 0.5
thickness on the component form. This is clearly visible on the displayed Stock

Model.

24 Activate the tool D12TR1.

25 From the main toolbar select Rapid Move Heights i and input the correct
Workplane definition 2 or Toolpath Workplane into the dialog before
selecting Calculate, followed by Accept.

P Toolpath connections

Safe area

Safearea Moves and clearances Start and end point  Lead ins  Lead outs

Type | Plane V|
Workplane | Toolpath workplane V|
MNormal
0.0 | [0 | [10 |

Rapid height
Plunge height

Use polar links

Calculate dimensions

Measured from

Links  Point distribution

Block and Model ~

Rapid clearance
Plunge clearance

1-18 Autodesk PowerMill 2017
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26 Select the Strategy Selector g and from 3D Area Clearance select Model
Rest Area Clearance and input settings exactly as shown in the following
illustration:

P Model Rest Area Clearance ? X
| Toolpath name | D12TR1-AngleRgh |
----- 12, Workplane 2 [Model rest area clearance 1
g Block
----- U Tool ke
----- 2, Machine tool
..... o Limit
i~
@ Rest
e ol | Offset model V|
- Step cutting Cut direction
-} Wall finishing Profile Area
H Unsafe segment removal | Climb v| | Climb Vl
¢ Flat machining
ﬁ; High speed Tolerance
e Order
i’ Approach
% Automatic verification Thickness

----- % Point distribution
----- E Tool axis '"'D k=10

----- & Machine axis control

=1 Rapid Moves Stepover
-7 Leads and links 'E'»
é_’f Start point
_----m"’f End point W Stepdown
[Avomatic | ] [59
Constant stepdown

Rest machining

Calculate Cueue oK Cancel

27 In the local explorer select the Rest page and input Rest Machining -
Toolpath - D16t3-TopRgh.

28 Select Calculate to create the toolpath.

----- k, Workplane ~ [ ]
- §§ Block Rest

..... |] Tool Rest machining
..... Machine tool
= Machine too |T00Ipath ~| | D16TR3-TopRgh ~

e E&t w
St ti b v
"M Step cutting Expand area b

& wall finishing

a The strategy fails to calculate and the following PowerMill Error message
box appears!

P PowerMill Error: H
Reference workplane differs
from current workplane,

Copyright © Autodesk Autodesk PowerMill 2017 1-19
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b It is not possible to apply Area Clearance - Rest machining using a
reference toolpath that has been generated relative to a different
Workplane alignment.

c It is however possible to use a Stock Model as the reference item for rest
machining.

29 Select OK to close the PowerMill Error message and return to the strategy
(that is still in Recycle @ mode).

30 Set the option Rest machining as Stock model using 1, and input Detect
material thicker than 0.6 as shown in the following illustration.

- [

- Offset

-mg Step cutting

-l wall finishing

ﬂ Unsafe segment removal
. Flat machining

..... 12, Werkplane & [R&St 1

- Block

----- l_J Tool Rest machining

----- E Machine tool

----- & Limit | Stock model ~ 1 b
[—j-‘ Muodel rest area clearance

Stock Model state | D16TR3-TopRgh ~

Detect material thicker than

Expand area b}[
Minimum gap length

31 In the local strategy explorer, open the Limit page and select Limit tool

32 Select Calculate to create the toolpath and then Close the dialog.

Limit

centre to block edge

The modified Rest Roughing toolpath now successfully operates within the
defined Stock Model volume (as shown above left).

The material removed by the toolpath, although referenced, is not physically
included as part of the Stock Model at this stage.

33 In the PowerMill explorer, right-click on the Toolpath D12TR1-AngleRgh

and from the local menu select, Add to - Stock Model.

1-20 Autodesk PowerMill 2017 Copyright © Autodesk
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34 In the PowerMill explorer, right-click over the new Stock Model 1 and from
the local menu, select Calculate.

= ‘ Stock Models
= veH
i @ Tolerance : 0.05
» Stepover : 1
» Rest Thickness : 0.1
- WA 2
@ [=§ Block
. [*&¥ D16TRI-TopRgh
[-r‘ D12TR1-AngleRgh
[=& D12TR1-AngleRgh >

The Stock Model now displays the remaining material after both the 3-Axis
Roughing and 3+2 Roughing operations.
& Unlike Area Clearance, Finishing strategies cannot be directly rest
machined to a Stock Model. However it is possible to create and apply
Stock Model Rest Boundaries where required, providing suitable rest
limits for subsequent finishing operations.

35 Activate the toolpath D16TR3-TopRgh to reinstate the settings used.
36 Create a Dia 6 Ball Nosed Tool named BN6.
37 Un-draw the Stock Model (click the light bulb off).

38 Select the Surfaces (shown shaded below) required for initial finish machining
relative to Workplane 1.
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39 In the PowerMill explorer, right-click over Boundaries and select Create
Boundary followed by Selected Surface to open the following dialog.

¥ Selected Surface Boundary ? "

%8 Neme
Top [ [ Limit Boundary
Inside
Roll Over [] )
Outside
Tolerances
Tolerance
Thickness

c&z

Use Avial Thickness[] [] Automatic Collision Checking

Too

Block
Private )
] Allow boundary to be private 0

40 Input data in the Selected Surface Boundary dialog exactly (as shown above)
with the box named Top ticked and the Limit option set to Limit tool centre to
block edge.

Lirnit {:1 e

41 Select Apply and when processed, Cancel the dialog.

N

L

When created, the new Boundary will be Active and by default included as the
limits (keep inside) in the following finishing strategy.

42 Select the Strategy Selector ﬁ and from the Finishing dialog select the
Steep and Shallow finishing option.

43 Enter the name BN6-TopFin along with the remaining values and settings
exactly as shown below before selecting Apply.
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P Steep and Shallow Finishing

Toolpath name | BMNE-TopFin

Tolerance

0.0

Thickness

-l

:Calculate: , Queue |

% :‘;‘”t“'a”e [Steep and shallow finishing
ocl
Order Additional stock
----- U Tool
----- E Machine tool
""" ﬁ ;mlr( : Threshold angle Steep shallow overlap
..... ock engagemen
[—]‘ Steep and shallow finishing
... T Automatic verification Steep Shallow
----- 4'\\: Point distribution [ spiral [ spiral
""" 1 Tool axis Cut direction Cut direction
----- @ Machine axis control - -
[]--j Rapid Moves | Ehimh Vl | Chiib V|
[]11 Leads and links Stepdown Stepover
Q?(f Start point . .
03 0.3
Beind ¥ ¥
[]---ﬁ Feeds and speeds A 0007509 A [o.007509
_____ o oy [.07509
----- ] Notes and Description 0 -
- Calculate using cusp
----- E. User defined settings Type

Smoothing

| | Cancel |

44 Set both Lead In and Lead Out to Surface normal arc (Angle 90, Radius 3).

45 Select Calculate to create the toolpath and then Close the dialog.

All of the features accessible from the top have now been finish machined. This
finishing strategy will be added to the Stock Model ready for a Stock Model

Rest Boundary to be created and applied to a 3+2 finishing strategy along
Workplane 2.
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46 In the PowerMill explorer, right-click on the Toolpath BN6-TopFin and from
the local menu select, Add to - Stock Model.

47 In the PowerMill explorer, right-click over the new Stock Model 1 and from
the local menu, select Calculate.

48 With the local Stock Model menu still open, select Show Rest Material,
followed by Drawing Options - Shaded, and finally Calculate.

49 Select an ISO 1.
50 Activate Workplane 2.

51 From the main toolbar select Rapid Move Heights and input the correct
workplane definition 2 or Toolpath Workplane into the dialog before selecting
Calculate.

52 In the PowerMill explorer, right-click Boundaries and select Create
Boundary followed by Stock Model Rest to open the following dialog.

P Stock Model Rest Boundan 7 x
% e o
Stock Model 1 .| [JLimit Boundary
Inside
Stock Model State BME-TopFin ~ ~ Outsid
utside
Detect Material Thicker Than
Expand Area By
Tolerances
Tolerance [[] Automatic Collision Checking
Thickness 0.0
A Use Axial Thickness [ ] Block
T

ool Limi

1t w
= .
Private
[] Allow boundary to be private 0
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53 Input data in the Stock Model Rest Boundary dialog exactly as shown above.

54 Apply and when processed, Cancel.

55 Select and delete the narrow segment at the base of the lower vertical wall.

56 Ensure that new Boundary 2 is Active.

57 Select the Strategy Selector g and from the Finishing dialog, select the
Steep and Shallow finishing option.
58 Enter the name BN6-AngFin along with the remaining values and settings
exactly as shown below.
P Steep and Shallow Finishing ? X
Toolpath name | BNE-AngleFin |
% :‘Irmt”'a”e [Steep and shallow finishing 1
oc
----- |‘_,| Tool e =
----- & oo
""" o Limit Threshold angle Steep shallow overlap
----- 3 Stock engagement
O Y ond sl fmshing]
...Wg Automatic verification Steep Shallow
..... < Point distribution [ spiral [ spiral
""" 12 Tool axis Cut direction Cut direction
----- @ Machine axis control - -
[]--j Rapid Moves | ehmy v| | Climb Vl
-1 II Leads and links Stepdown Stepover
-l Start point
& p
eﬁ' End point E" E*
E]...IE- Le.eds and speeds A A
..... =l History
----- [2] Notes and Description CalcLate i
..... 2. User defined settings L |Eaksincremng g Type
[ Smoothing
Tolerance
0.0
Thickness
-0 &
Calculate Queue oK Cancel
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59 Select Calculate to create the toolpath and then Close the dialog.

The resultant toolpath will be added to the Stock Model mainly to confirm
whether machining is now complete.

60 In the PowerMill explorer, right-click on the Toolpath BN6-AngleFin and
from the local menu select, Add to - Stock Model.

61 In the PowerMill explorer, right-click over the new Stock Model 1 and from
the local menu, select Calculate.

There are now 2 areas remaining as part of the Stock Model. As both include
sharp internal corners they will need to be finished off using an End Mill.

62 Create a Dia 12 End Mill named EM12.

63 In the PowerMill explorer, right-click over Boundaries and select Create
Boundary followed by Stock Model Rest to open the following dialog.
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P Stock Model Rest Boundary

& e
Stock Model 1 ~
Stock Model State BNB-AngleFin ~

Detect Material Thicker Than
Expand Area By

Tolerances

Tolerance
Thickness
0 Al Thickness | 0.0
=1 Use Axial Thickness[ ]

Tool

EM12 v

Private

[] Allow boundary to be private

Edit History
Apply edit history on calculation

Lirniting Boundary

[] Automatic Collision Checking
Holder Clearance | 0.0

Shank Clearance| 0.0

? *

Limit
o
©

64 Input data in the Stock Model Rest Boundary dialog exactly as shown above.

65 Apply and when processed, Cancel the dialog.

G) A new Stock Model Rest Boundary has appeared where the remaining

material is accessible to the EM12 tool.

@ This area is not accessible to the EM12 tool, and as a result Boundary

segments will not be created.

66 Ensure that the new Boundary (3) is Active.

67 Select Toolpath Strategies ﬁ and from the Finishing dialog, select the

Constant Z option.

68 Enter the name EM12-AngleFin along with the remaining values and settings

exactly as shown on the following page.
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P Constant Z Finishing

? X

Toolpath name | EM12-AngleFin

----- 12, Workplane
- Block

----- o8 Limit
----- 3 Stock engagement
(=¥ ] Constant Z finishing

H Unsafe segment removal
... Ty Automatic verification

----- 'Qo Point distributicn

----- I.;; Tool axis

----- @ Machine axis control

[j--:j Rapid Moves

@1 Leads and links

et.f Start point

e‘f End point

(-5 Feeds and speeds

----- ] Motes and Description
----- ,E,. User defined settings

[Constant Z finishing

Order by
Spiral

Machine down to flats

Tolerance

Thickness

.0

Stepdown

Additional stock
[JUndercut

Flat tolerance

Cut direction

Minimum stepdown

69 Select Calculate and then Close the dialog.

Calculate using cusp []

The angled pocket is now fully machined and the latest toolpath will now be added
to the Stock Model.

70

7

72
73

In the PowerMill explorer, right-click on the toolpath EM12-AngleFin and
from the local menu select, Add to - Stock Model.

In the PowerMill explorer, right-click over the new Stock Model 1 and from
the local menu, select Calculate.

Activate the toolpath D16TR3-TopRgh to reinstate the settings used.
De-activate the toolpath D16 TR3-TopRgh and activate the EM12 tool.
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74 Create a Swarf Finishing strategy named EM12-TopFin on the selected,

vertical surface (shown shaded above).

P Swarf Finishing

-

Teeolpath name | EM12-TopFin

- fgl Block
|_| Tool

[, Machine tool
o Limit

-3 Stock engagement
=la\] swart inishing

... Pasition

% Gouge avoidance

&= Multiple cuts
= High speed

\\.- Peint distribution
-.1& Tool axis

-.{#) Machine axis control
[j--:j Rapid Maoves

...... U Point distribution
..ol Start noint

W Automatic verification

& [Swarf finishing

Drive curve

Gouge avoidance

Telerance

.

Thickness

.0

Calculate

Preview

Queue

Radial offset [ 00 |

Minimum fanning distance

Fan at end on planes []
Reverse axis[_|

Follow surface laterals []

Surface joining tolerance

0

i

Gouge check[]

Degouge tolerance

Cut direction

[ Draw

oK Cancel

75 Set both Lead In and Lead Out to Vertical arc with Distance 6, Angle 90,

and Radius 4.

76 Add the new toolpath EM12-TopFin to the Stock Model and Calculate to
visually confirm that all excess material has now been removed.
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[T

&  The Stock Model is only visible when the Show Rest Material option is un-
ticked.

77 Select File > Save to update the contents of the previously stored Project.
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3+2 Axis - Drilling Example

The PowerMill - Drilling options operate on Hole Features and not directly on the
Model. This enables drilling to take place without the need to modify or trim back
the existing surface data. When the Multi-Axis option is ticked the Hole Features
at different alignments will be created to a common workplane.

1 Select File - Delete All and Tools - Reset Forms.
2 Import the Model:
.\PowerMill_Data\five_axis\drill_Saxis\drillSax_ex1.dgk

3 Select File - Save Project As:
.\COURSEWORK\PowerMill-Projects\MultiAxisDrill-ex1

The first stage is to create a Hole Feature Set into which all cylindrical surfaces in
the selected model are inserted as Hole features.

Any cylindrical surfaces within the selection will automatically be recognised as a
Hole Feature. It is important that no Block exists to ensure that the Hole
Features are arranged with the top at the maximum Z height.

&  The existence of a Block will affect the orientation of individual Hole
Features in that they are more likely to be created to an unsuitable
alignment.

4 Use the left mouse to select all of the surfaces.

5 In the PowerMill explorer, right mouse click on Hole Feature Sets, and from
the local menu select Create Holes.
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6

7

8

10
11
12
13

14

15
16

Enter data into the Create Holes form exactly as shown.

¥ Create Holes ? =

Mame root

[H |

Create from Tolerance

Maodel ks 0.1 {@}

[] Create compound holes

[[]Use active workplane only
Find holes in both directions
Find holes going down
Find holes going up

[] Group holes by axis

[] Create holes from partial cylinders

[Jignore capped cylinders

[] Edit after creaticn

Apply Close

The Group holes by axis option must be un-ticked for a Multi Axis Hole >
Feature Set to be created (All of the Hole Features including those at different
orientations will be input into a single Feature Set).

Apply and Close the dialog.

All cylindrical surfaces within the selection will automatically be recognised
as Multiaxis Hole Features.

Undraw the model to view the newly created Features.

All 17 Holes in the Feature Set are correctly aligned, with the cross at the base
representing the bottom of the hole.

Create a material Block using Defined by - Box and Type - Model.

In the Rapid Move Heights E dialog, select Calculate.

Create a Dia 3 Drill named Drill3 of Length 40.

Add a Shank component Upper\Lower Dia 3 Length 40.

Add a Holder component Upper Dia 30 Lower Dia 30 Length 30 Overhang 60.

Select Toolpath Strategies ﬁ and in the Strategy Selector dialog, select
Drilling.

In the Drilling dialog, select the option Drilling.
Rename the toolpath CentreDrill-Dia3.
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P Drilling ? b4

..... B Holes ﬁ
----- k Workplane -

Toolpath name | CentreDrill-Dia3 |

g Block Cycle type
----- U Tool | Break chip a1 |
..... B, Machine tool :
Elﬁ Define top by
! g Retraction | Hole top ¥ |
ﬁ Feed rate reduction g
-y Pecking Hemin

= Order | Centre drill w |
Automatic verification

----- Tool axis

Clearance
----- ) Machine axis control -5.0
|:|--§I Rapid Moves
[]--II! Leads and links Eeciiifepth
a Start point
a End point
[-fr Feeds and speeds
..... B History
-:-3 Motes and Description
----- z.', User defined settings Tolerance
Thickness
¥
[ Drilling cycle output [ Draw
| Calculate | | Queue | | OK | | Cancel |

17 Back in the main Drilling page select Calculate to create the Centre Drilling
toolpath, and then Cancel the dialog.

18 Simulate the toolpath.

The Multiaxis option has created all of the Hole Features aligned at different
elevations in a single Feature Set.
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The two Dia 6 Hole Features are to be drilled to depth with a Dia 5 Drill and then
Tapped. To allow for the inevitable point angle at the bottom of the blind holes the
Tapping operation needs to stop short of the full depth by applying a suitable Axial
Thickness value.

19 Create a Dia 5 Drill named DRILLS5 of Length 60
20 Add a Shank, Upper Dia 5, Lower Dia 5, Length 30.
21 Add a Holder, Upper Dia 30, Lower Dia 30, Length 30, Overhang 50.

22 Select Toolpath Strategies ﬁ and in the Strategy Selector dialog select
Drilling.

23 In the Drilling dialog select the option Break Chip.
24 Rename the toolpath as Drill5.

P Drilling ) a
Toolpath name | Drill3 |
----- B Holes (Drilling ]
..... 12, Workplane
- Block Cycle type
..... U Tool | Break chip V|
..... 2, Machine tool :
El__'&m Define top by
31' Retraction | Hole top v|
i Feed rate reduction )
Ty Packing Operation
¥ Order [ Drill to hole depth ~|
.. T Automatic verification
..... }; Tool axis Clearance
----- # Machine axis control
G-=3 Rapid Moves
[j...]f{-, Leads and links Peck Depth
-~ Start point
- End point
[y Feeds and speeds
..... E History
----- [] Motes and Description
----- z_ User defined settings Tolerance
Thickness
Drilling cycle output []Draw
Select...
Calculate Queue OK Cancel

25 Select the two Dia 6 Hole Features (shown coloured orange below).
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P Feature Selection ? >
Select By | Diameter ~
Minimum Diameter
e E—
Diameter Selection Filter
| 8.00 =3 Diameter
10.00 — 6
12.00
<
- - &
Tolerance Component
0.01 | Largest - |
Select Close

26
27
28

29
30
31

32

33
34

Close the Feature Selection dialog.
Select Calculate to create the Drilling toolpath, then Cancel the dialog.

Simulate the toolpath.

The two Dia 6 Holes have now been drilled to full depth using a Dia 5 Drill.

They will now be Tapped to a depth of 5 (Axial thickness) from the base of
each Dia 6 Hole using a Dia 6 Tap with a 1mm Pitch.

Create a Dia 6 Tap (Named M6Coarse-TAP) with Pitch 1 and Length 25.
Add a Shank, Upper Dia 4, Lower Dia 4, Length 30.
Add a Holder, Upper Dia 30, Lower Dia 30, Length 30, Overhang 50

Select Toolpath Strategies ﬁ and in the Strategy Selector dialog select
Drilling.

In the Drilling dialog select the option Tap.
Rename the toolpath as M6-Tap.
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35
36
37
38
39
40
M
42

43

P Drilling T >
3 Toolpath name |M6—Tap |
----- © Holes [Drilling ]
----- If, Workplane
[ Block Cycle type
..... i Tool |Tapping V|
Define top by
| Hole top v|
Operation
[ Drill to hole depth ~]
----- # Machine axis control
[]--gjt Rapid Moves Clearance -y Start
[]...]:l;[, Leads and links - i -
éf Start point
.4 End point Depth
[]---ﬁr Feeds and speeds
----- =l Histo
----- g Notesr);nd Description Bitch 2o
- z. User defined settings
Tolerance
et hand
Thickness
¥ ¥
Drilling cycle output [ Draw

Select the two Dia 6 Hole Features.

In the Drilling dialog select the option Tapping.

Rename the toolpath as M6-Tap.

Set Cycle Type - Tapping, Operation - Drill to hole Depth, and Pitch 1.

Input an Axial Thickness value of 5.

Select the two Dia 6 Hole Features.

Select Calculate to create the toolpath and then Close the dialog.

Select a View from front (-Y).

The selected holes have been Tapped to a distance of 5mm short of the full

depth.

From the main pulldown menus, select File > Save to update the contents of

the stored Project.
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2. Positional Tool Moves

Positional Tool Moves — Essential Information

When performing multi-axis, Positional Tool Moves, it is the user’s responsibility
to pay careful attention and take appropriate action to prevent collisions.

= All individual toolpaths should be created such that the Start and End Points
are clear of any undercut features in the CAD model.

= PowerMill does not gouge check positional moves before and after an
individual toolpath. These Pale Blue dashed connection moves are only visible
if the NCProgram is drawn (as shown below).

= Neither, PowerMill, or a Postprocessor will be aware of any obstructions
within the confines of a machine tool.

= The Positional moves displayed in a PowerMill toolpath simulation will not
necessarily match all moves performed by the actual machine tool.

= For a more accurate simulation a Machine Tool Model along with an associated
mtd file can be created. It must be stressed that a machine tool simulation is
essentially a visual animation and not an ncprogram, verification.

Three suggested methods in PowerMill to create Positional Tool Moves include:
a Use of Absolute coordinates in the toolpath Start and End Point dialog.

b The insertion of a Drive Curve - Pattern Finishing strategy suitably
positioned in 3D space.

¢ The insertion of strategically placed Workplanes into an NC Program.
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Postprocessor option file — Safe Z Positional Moves

There are two different ways that a specific Postprocessor Option file can be
created to deal with positional moves (Method 1 is the default).

a Method 1 - The Postprocessor Option file automatically outputs moves
from/to the Machine Tool, maximum Z height (Home) at the start and
end of each Toolpath. Note! In this case any Workplanes inserted into the
NC Program (Item c on the previous page) are completely ignored.

The name for a typical Postprocessor Option file using Method 1 includes ZMAX
at the end of the name:- DMG_DMU10p_H530_ZMAX.pmopt

b Method 2 - The Postprocessor Option file does not automatically output
Machine Tool Safe Z moves. All additional, safe positional, moves must be
added by the user in PowerMill (In this case a network of workplanes can
be used as shown in the illustration below).

The name for a typical Postprocessor Option file using Method 2 will not include
ZMAX at the end of the name:- DMG_DMU10p_H530.pmopt

-5 NC Programs
e e
L pkti-top
a8 D10t1-pktl
12, pltl-top
32, pht2-top
w48 D10t1-pkt2
¢, pkt2-top
42, pkt3-top
a8 D10t1-pkt2
wly, pkt3-top
42 pltd-top
48 D10t1-pktd
47, pktd-top

Tool Move with Start and End Point

Positional Tool Moves can be controlled in the Start and End Point dialog @
by use of Absolute (along with specific XYZ coordinates).

Start and End Points input as Absolute coordinates, above the component where
it is safe to re-align the tool and/or perform rapid XY moves.
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Tool Moves using a Pattern Finishing in 3D Space

Positional Tool Moves can be controlled by running the tool along a Pattern
Finishing strategy used as a Drive Curve in 3D space.

|=O A lean angle can be applied to maintain an angular tool alignment during
transit.

- | @] |
=] ﬂ NC Programs.
= ¥ E':..-:] >1
L] pkta-top
17, pke1
@8 D10t1pkt1

¥ D10t1pki2
1z, pkt2
1z, pkt2-top

Tool Move via Workplanes in an NC Program

Positional Tool Moves can be controlled by strategically placed Workplanes
inserted between the Toolpaths in the NC Program list. A Workplane in the
ncprogram list can also be registered as a Toolchange Point if required.

“&  This method is only applicable to non-ZMAX post-processor
applications.

[ | @] |

=-£3l NC Programs
E| il =1
..... 17, MainDatum-top
.1z, pkti-top
. dr, pktt
w48 D10t1-pkt1

- E pkt1

While a tool moves to a Workplane, it will simultaneously re-align to align to the
Workplane - Z Axis (Simultaneous is the NC Preferences - default setting).

The following 4 illustrations show the tool movements to 3 workplanes including a
rotational move prior to performing the machining strategy.
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Tool at MainDatum-Top Tool moved to pktl-tep

Tool moved to pktl Tool Rotated at pktl

Example

An existing Project will be opened that contains 4 separate 3 Plus 2, finishing
toolpaths ready to be added to an NC Program. Once included in the NC Program,
appropriate positional moves must be added to prevent the tool from passing
through the component form while moving between toolpaths.

1 Select File - Open Project:-
«..\PowerMill_Data\FiveAxis\PositionalMoves\AngledPockets-Start

P PowerMill Warning: >

Project 'AngledPockets-5Start' is open read-only.
It is being edited by user 'dfb’ on computer 'DELCAM/DFB1".

It can be saved only under another name, using 'Save Project As...'

oK

2 Select File - Save Project As:-
.....COURSEWORK\PowerMill_Projects\AngledPockets
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Connection moves using a Safe Z calculated to a 3-Axis
Workplane

3 In the PowerMill explorer, right-click on NC Programs and from the local
menu, select Preferences.

P
Cutput  Toolpath Fixture offset  Verification

Changes made here will not change existing MNC Programs

Use Project Cutput Folderl CATernp'MCPrograms | @

Cutput File| {ncprogram} |

Machine Opticn File | sonfighductpost\Mazak_Variaxis_Saxis_ref. pmoptz | @

Machine Tool i Model Location v
Output Workplane MainDaturmn-top % Part Mame I:l

Automatic ToolAIignment Connection Moves

Close

4 Select a suitable Five Axis, Post-Processor Option File:

C:\dcam\config\xtra-posts\ Mazak_Variaxis_5axis_ref.pmoptz

Select Close (The NC Preferences settings will be updated).
Create a new NC Program (It will be Active on creation).

7 Select the four 3plus2 Toolpaths (D10t1-pkt....) then right-click over them
and in the local menu select Add to > NC Progam.
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@ NC Programs
Ep@ Toolpaths E‘@ NC Programs
) ¢ & daDt6-rght B 1

: (-8 D10tl-pktl
iy

7 B8 BN16-sem1
B D10tL-pkt2

18 D10tl-pkt3
-8 D10tL-pktd

Toolpaths 4

Draw Selected

Undraw Selected

| Add to ’ Stock Model
g H ;N[?Ilo-n create|ndmdua||\|c ngrams N ng’am = L\\) "
D__o Boundaries Load Tool Cutting Data Group
(-7 Patterns Edit 5 Folder

..[§? Feature Sets
rﬂﬁ;. Workplanes
[ ta

Delete Toolpaths

B e N Y IR )

8 Select an ISO 4 view.

Run a ViewMILL simulation on the first two, 3 Axis toolpaths; d40t6-rgh1l,
BN16-sem1, followed by the NC Program containing the four 3plus2 toolpaths.

“&  0On closer inspection it will be observed that the 3plus2 - Positional Tool
Moves have ploughed through the component between the individual
machining strategies.

& If the Model is displayed as wireframe then the displayed NC Program
will also include the link moves (Pale Blue dashed lines) between the 4
stored Toolpaths.
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10 Activate the workplane MainDatum-top.
11 Calculate a Block using Defined by Box to the Model dimensions.
12 Open the Rapid Move Heights dialog.

P Toolpath connections ? X

Safearea Moves and clearances  Start and end point  Lead ins Lead outs  Links  Point distribution

Safe area Calculate dimensions
Type | Plane ~ Measured from | Block and Model ~ |
Workplane |MainDatum-top v Rapid clearance
Plunge clearance
MNermal
[ Jw][w

Rapid height

Plunge height | -7.287618

Use polar links

13 Input Workplane MainDatum-top and Calculate before selecting Accept.

14 In the PowerMill explorer use the Shift key to multi-select the four, 3+2
toolpaths.

BA& Toolpaths

G-) § SF d40t6-rgh
E-) § BB BN16-sem
[E3] ’\'é') i D10t1-pkd
w0 ¢ 68 LS Toolpaths )
=0 v @ by
E]--’:{) s g oot Draw Selected
=5 Tools Undraw Selected
@~ ¢ | D40TE Add to »
By H > D10 Create Individual NC Programs
et i e Load Tool Cutting Data
- Boundaries
-£4 Patterns Edit > Transform...
----- @ Hole Feature Set ;
1:‘? R Delete Toolpaths Invalidate Toolpaths
B f Workplanes Set Mamed Parameter...
%12, > MainDatum-top Set Start Point
¥ k‘ Base-centre Set End Point
v 12 phtt Set Rapid Moves
v % p,kt% Set Feed Rates

15 Right mouse click anywhere on the four selected toolpaths, and from the local
menu select Edit - Set Rapid Moves.
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The Tool will now perform rapid moves above the top of the model, relative to
workplane MainDatum-top.

16 Run a ViewMILL simulation on the first two, 3 Axis toolpaths; D40t6-rgh1,
Bn16-sem1l, followed by the NC Program containing the four 3plus2 toolpaths.

The toolpath connection moves no longer collide with the model.
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Connection moves using (Drive Curve) Pattern toolpaths

17 From the Strategy Selector g - Finishing select the Pattern finishing
strategy and enter data exactly as shown below.

P Pattern Finishing 7 x
Toolpath name | ToolMove Pkt1-Pki2 |

..... 12, Workplane {Pattern finishing }
-l Block
----- E Tool Drive curve
----- Machine tocl
..... & Limit [] Use toolpath
----- Stock t

Elij;’] ock engagemen ﬁ PR1_PKE2 = )E m t_-:}

‘i Multiple cuts

Lower limit

..... 3 Point distribution Base positicn | Drive curve = |
----- # Tool axis

----- # Machine axis control Auial offset

[]--:rj Rapid Moves

-1 U] Leads and links Gouge avoidance

d’_}' Start point Gouge check [+]
67! End point
U"'Isfi' Feeds and speeds Tolerance Ordering

..... E—j‘ History Pattern V|
----- =] Motes and Description

----- & User defined settings Thickness

18 Select the Tool Axis page, and input a Tool axis Lead/Lean with Mode
Vertical selected and a Lean value of 60.

P Pattern Finishing ? >
| Toolpath name | ToolMaowve_Pkt1-Pkt2 |

..... 12, Workplane [T{)[ﬂ axis ]
-l Block
..... U Tool Tool axis
----- 2, Machine teol |Leadeean ~
----- 88 Limit Lead/Lean angles
----- 3 Stock engagement Lead £an

o patern g

= Multiple cuts
T Automatic verification
----- < Point distribution Mode | Vertical |v

= .
----- #, Tool axis

Contact normal
----- # Machine axis control
[-=3 Rapid Moves Fixed angle Tangent ndrmal

[]—--]f.[', Leads and links Mone ~ |PowerMill 2012 R2
<l Start point
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2. Positional Tool Moves

19 Select the Start point page, and Use First point.

P Pattern Finishing

? X

Toolpath name | ToolMove_Pkt1-Pkt2 |

----- k. Workplane
- §gl Block
..... U Tool

----- B, Machine tool

----- 3% Stock engagement
gag

[-jﬁ Pattern finishing

‘gm Multiple cuts

..... £y Paint distribution

..... E Tool axis

----- @ Machine axis control

[j--j Rapid Moves

-1 7] Leads and links
o XTI

611 End point

[-fir Feeds and speeds

[S'tart‘ point ]

>

Incremental plunge ]

Direct move

Override tool axis [_]

Mation | Simultaneous V|

[[]5eparate approach
Approach along | Tool axis

Approach distance | 5.0

Incremental plunge distance

Distance

20 Select the End point page and Use Last Point.

21 In Leads and links set both Lead in and Lead out to None.

22 Calculate the Pattern finishing toolpath.

&4

The Tool ‘winds’ along the Pattern Finishing strategy creating a collision safe,

transition around the component.

23 Insert the Pattern Finishing strategy (ToolMove-Pkt1-Pkt2) between the

toolpaths, D10t1-pktl and D10t1-pkt2.

E@ NC Programs
DoEe > 1

2-¥ S8 D10t1-pktl

=3}

w- QFB DI0tl-pke2
@~ 58 D10tl-pkt3
@- @58 DI0t1-pktd

7 58 ToolMove_Pkt1-Pkt2

2-10 Autodesk PowerMill 2017
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2. Positional Tool Moves

Exercise

1 Create 2 more suitably positioned, tool move Pattern Finishing toolpaths
named ToolMove_Pkt2-Pkt3 and ToolMove_Pkt3-Pkt4.

B,

& Check the direction of each new Pattern Strategy and if necessary, reverse.

2 Insert the new Pattern Finishing toolpaths into the NC Program.

=-£5) NC Programs
B > 1

5-¥ Q98 D10t1-pkt1
7 5 ToolMove_Pkt1-Pkt2
2 5B D10t1-pkt2
2 5@ ToolMove_Pkt2-Pkt3
2 5B D10t1-pkt3
2 58 ToolMove_Pkt3-Pktd
¢ 8 D10t1-pktd

®

&

Tool Axis ‘Rewind’ Move

!
|=Q A useful application for using a Pattern as a Positional Tool Move is in cases
where a rotary axis limit has been reached. A circular, Pattern Finishing
strategy can be used to 'Rewind’ the tool in 3D space, back to the start of its
rotary travel limits.
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3. Five Axis Tool Alignment

{\ AUTODESK.

3. Five Axis Tool

Alighment

Introduction

For 5-Axis applications where the machine tool head and\or table, are required to
perform both linear and rotational axis moves simultaneously, PowerMill
provides a range of appropriate Tool Axis Alignments and Machining Strategies.

Five Axis Tool Alignment and Machining

Options

By default the Tool Axis alignment in PowerMill is set to Vertical for 3-Axis
applications and other options will only be available to users with a multiaxis

licence.

&  Some strategies only support multiaxis Tool Axis alignments if used with

Ballnose or Spherical tools.

The Tool Axis Direction dialog is accessed via the Tool Axis icon Ig located in
the Main toolbar or directly from supported Machining Strategy forms.

The dialog provides a list of basic Tool Axis alignment options which are further
controlled by a Strategy dependent selection of Mode options.

Lead/Lean ~

Lead/Lean angles
Lead Lean

P Tool fsis ?
Smaoothing Machine axis control
Definition Limits Collision avoidance
Tool axis

Vertical

X

P Tool Asis ? X
Smeothing Machine axis contrel
Definition Limits Collision awvoidance

Tool axis
Point
[0 ] 00 | 0.0 =

Fired Angle PowerMill 2012 R2 Fixed Angle P mg
Mone “ 0.0 None ¥ |PowerMill 2012 R2
Copyright © Autodesk Autodesk PowerMill 2017 3 -1
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3. Five Axis Tool Alignment

Tool Axis alignment - Mode options

a Contact Normal - This measures a Lead angle relative to the toolpath
contact normal.

b Vertical - This measures a Lead angle relative to the Z Axis.

¢ PowerMill 2012 R2 - Reverts back to this version that did not offer a choice
of Mode options (The actual Mode options used is strategy specific).

d Preview frame normal - This measures a Lead angle relative to the
projection direction to or from the normal to the Projection Strategy,
Preview pattern.

e Toolpath - For a basic Tool Axis of From or Towards the actual alignment
is relative to the model surface instead of the Preview pattern.

f Preview frame - For a basic Tool Axis of From or Towards the actual
alignment is relative to the Projection Strategy, Preview pattern.

g Reference tool axis - This measures the Lead angle form the tool axis
used in a reference toolpath used as the Drive curve in a Pattern Finishing
strategy.

h Tangent Normal - This measures the Lead angle relative to the
perpendicular to the tangent direction of a Pattern used as the Drive curve
in a Pattern Finishing strategy.

i Undercut angle - This measures the Lead angle from the projection
direction corresponding to the specified undercut angle in a Parametric
Spiral strategy.

Lead/Lean - Example1

Lead allows the tool to be aligned to a specified angle along the toolpath
direction and Lean a specified angle across the toolpath direction. If both
angles are zero the tool will be aligned along the direction that a toolpath is
projected onto the model during creation. For Pattern finishing this will always be
vertical and for Projection Finishing it will vary depending on the defined strategy
projection options.

yred[oo ], sso10y
FTIONVY Nv31

LEAD ANGLE
Along Toolpath

1 From the main pull down menus select File - Delete All and Tools - Reset
Forms.
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{\ AUTODESK.

2 Open the (Read Only) Project:-

....\Five_Axis\ToolAlignments\PlaneAlignments_Start

3 Save Project As:-

.....COURSEWORK\PowerMill_Projects\PlaneAlignments_Demo

4 Activate and then Simulate the toolpath BN5-Vertical.

The above Raster toolpath is machined with the tool aligned to the vertical

axis.

5 Right-click the Toolpath - Raster Vertical in the PowerMill explorer and
select Settings to open the original Raster Finishing dialog.

Make a Copy of the Toolpath and rename it as BN5-Lead30.

7 Select the Tool axis page, with the Tool axis as Lead\Lean, with Lead -30,

and use Mode Vertical.

| P Raster Finishing

? x
Toolpath name | EN5-Lead30 |
If, Woarkplane [TDD' axis ]
i Block
|‘ ’| Tool Tool axis
B, Machine tool |Lead..-‘Lear1 ~
: o Lirmit Lead/Lean angles
3 Stock engagement Lead Lean
-¥g Automatic verification
Bt distribution Maode | Contact normal |v
Tool axis Contact normal
ar- € axis control
= Rapid Moves (=3 sngl= [Powerhitt 2012 R2
1;.[ Leads and links | Mane Vl oy
L= R -

8 Calculate the Toolpath and then Close the dialog.

Copyright © Autodesk
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3. Five Axis Tool Alignment

9 Simulate the Toolpath (BN5-Lead30).

A Raster toolpath has been created with the Tool axis direction set to Lead at
-30 degrees relative to the vertical axis (Z).

Q With the Two Way option, the Tool Axis direction will switch on
opposing passes. This is due to the Lead angle being dependant on the
tool track direction.

10 In the PowerMill explorer, right-click on the toolpath BN5-Lead30 and select
Settings to open the Raster Finishing dialog.

11 Select Re-cycle @ and change Style to One Way.
12 Calculate the Toolpath and then Close the dialog.

Q With the Style set to One Way the Tool Axis direction remains fixed.

13 Right-click the toolpath BN5-Lead30 in the PowerMill explorer and then
select Settings to open the toolpath dialog.

LH

14 Select Make a Copy of the Toolpath and rename it as BN5-Lean45.

15 Select the Tool Axis icon to open the Tool Axis Direction dialog.
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3. Five Axis Tool Alignment

16 In the Tool Axis page, change the Lead angle to 0, and input Lean 45.

12, Workplane [TDD' axis ]
-l Block
| J Tool Toaol axis
{2, Machine tool |Lead_f'Lear1 ~
b Limnit Lead/Lean angles
-3 Stock engagement Lead Lean
=-E Raster finishing 45.0
... F High speed
... T Autornatic verification
o int distribution Meode | Vertical |V
< & Contact normal
ine axis control
#-=3 Rapid Moves Fixed angle PowerMilt2012 R2
-1 71 Leads and links | Mone Vll s
. -

17 Calculate the Toolpath and then select Cancel to close the dialog.
18 Simulate the Toolpath.

View from left -X

A Raster toolpath has been created with the Tool Axis Direction set to Lean
45 degrees across the toolpath.

If a Two Way had been directly applied in the strategy dialog, the tool axis
would lean in the opposite direction across alternate tool tracks.

It is possible to create a Two Way strategy with a constant Lean direction by
retrospectively editing a one way - Toolpath.

19 Right-click on the (One Way) toolpath BN5-Lean45 and from the local menu,
select Edit > Reorder to open the Reorder Toolpath Segments dialog.

20 Select the Alternate directions option E‘ (All tool tracks will be edited).
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3. Five Axis Tool Alignment

P Reorder Toolpath Segments

et

--

[F= - R I = R e = ]

Start point

-50.00, -22.50, -9.27
50.00, -17.50, -9.27
-30.00, -12.50, -9.27
50.00, -7.50, -9.27
-50.00, -2.50, -9.27
50.00, 2.50, -9.27
-50.00, 7.50, -9.27
50.00, 12.50, -9.27
-50.00, 17.50, -9.27
50.00, 22.50, -9.27

End point

50.00, -22.50, -9.27
-50.00, -17.50, -9.27
50.00, -12.50, -9.27
-50.00, -7.50, -9.27
50.00, -2.50, -9.27
-50.00, 2,50, -9.27
50.00, 7.50, -9.27
-50.00, 12.50, -9.27
50.00, 17.50, -9.27
-50.00, 22.50, -9.27

Length
100.00
100.00
100.00
100.00
100.00
100.00
100.00
100.00
100.00
100.00

Poi

P P P P P Pa P P Pa P

P PowerMill Wamning:

Please note that the orientatien of the tecl-axis is not changed when
the direction of the
toolpaths are reversed and se may no longer comply with the original
lead and lean settings

21 Select OK to close the above PowerMill Warning dialog.

22 Save Project to update:-
.....COURSEWORK\PowerMill_Projects\PlaneAlignments_Demo

3 -6 Autodesk PowerMill 2017
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Lead/Lean - Example2

23

Select File - Delete all and Tools - Reset Forms.

24 Open the Project (saved earlier during Chapter 1) from:

25
26
27

28
29

30

31

..\COURSEWORK\PowerMill-Projects\3Plus2-EX1

I

Define a Dia 15mm Ball Nose cutter named BN15.
Activate the Workplane - ztop175_A.

Create a material Block defined by Box to the Max\Min Limits of the Model
and then edit the following values as shown below:

Xmin -95 Xmax -52.5 Ymin -50 Ymax 50

Open the Rapid Move Heights dialog and select Calculate, then Accept.

In the Start and End Point dialog in Start Point set First Point Safe and in
End Point set Last Point Safe.

i@
Select Leads\Links and in the Toolpath connections dialog set:-
Moves and Clearances:

Axial clearance 15, Incremental plunge distance 5

Lead In\Out: Vertical Arc: Angle 90, Radius 6

Links: 1st choice\2nd choice: Skim and Default: Incremental

Ensure that no Boundary is Active.

An area of the component will be machined using Raster Finishing. The Tool Axis
will be aligned to a fixed Lean angle of 40 degrees relative to the Vertical axis.
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3. Five Axis Tool Alignment

32 Select the Toolpath Strategies icon @ and in the Strategy Selector dialog,

select the Finishing tab.

33 Select the Raster Finishing dialog and enter data exactly as shown below:

| P Raster Finishing

4 bt

Toolpath name | BN15-Raster-Leandd

3 Stock engagement
=E

ﬁ? High speed

.. Automatic verification
-+ Point distribution

1 Tool axis

- Machine axis control
[j--:_("f Rapid Moves

[]...]K Leads and links

6_1' Start point

@il End point

-7 Feeds and speeds
5 History

..[=] Notes and Description
E. User defined settings

% g”tp'a”e [Raster finishing

oc|

|‘_| Tool

E Machine tecl Fized direction

o8 Limit Angle

Start corner | Upper left ~ |

Perpendicular pass

Ordering

Tolerance

Thickness

iy

Stepover

Preview

Calculate Queue

Perpendicular pass[_]
Shallowe angle | 30.0

Optimise parallel pass

Style One way e

Arc radius | 0.0

A
] Draw

oK Cancel

34 Select the Tool axis page and enter data into the dialog exactly as shown in the

following illustration.

P Raster Finishing

Toolpath name | BM15-Raster-Leandd

= "
L’-" Teool axis

4% Point distribution

12, Workplane [TOD' axis }

-l Block

ol Toal Tool axis

-[I2, Machine tool |Leadeean ~

068 Lirnit Lead/Lean angles

.3 Stock engagement Lead Lean

-5 Raster finishing m
... F High speed
T Automatic verification

Mode |‘urertical v|

3-8 Autodesk PowerMill 2017

Copyright © Autodesk



{\ AUTODESK.

3. Five Axis Tool Alignment

35 In the Limit page, Z limits, tick Minimum and input the value -155.

Ti‘ Workpiane ~

The resultant toolpath starts at the lower corner and progresses towards the centre
using a climb milling action (One Way). If it is required for the strategy to be Two
Way then it can only be retrospectively changed using Edit > Reorder >
Alternate Direction.

To compare the effect of applying a different machining strategy, the same area of
the component will be machined using Projection Plane Finishing. This time the
Tool Axis will be aligned using a Lean of 0 degrees relative to the projection
direction of the strategy.

37 Calculate a Block, Defined by - Box using Type - Model.

38 Select the Toolpath Strategies icon @ and in the Strategy Selector dialog
select the Finishing tab.

39 In the Finishing options select Projection Plane Finishing.

40 Enter data into the following 3 pages of the Plane Projection Finishing dialog,
exactly as shown below:
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P Plane Projection Finishing

? =
Toolpath name | BM15-ProjPlane-Lean |
..... 17, Workplane [P| i i ]
ane projection
-l Block i
..... E Tool Location
..... Machine tocl ;
..... o Limit [~maan §oo | B
..... 3% Stock engagement Pornaith
[—j% Plane projection
I -_ET'D.O
..... % Point distribution EESStios
..... 1 Tool axis I
..... # Machine axis control
Ej..:_(? Rapid Mowves Projection
[j--]E Leads and links Diirection | Cubtwards V|
qg_l' Start point
i;." End point Tolerance
i Feeds and speeds _
E History i
..... ] Motes and Description Thickness
- X : [ ]
..... &= User defined settings = g
Stepover

Lo ] ALEm

Preview |:| Drraw

| Calculate Cueue [ Ok | Cancel

= Set Azimuth to 270.
= Set Elevation to 50.

P Plane Projection Finishing

Toolpath name | BMN15-ProjPlane-Lean0 |

----- k_ Workplane [P ]
attern
-l Block

----- |\_| Tool
..... E Machine tool Pattern

: Pattern direction
..... 3 Stock engagement :
[_]% Plane projection e | iz

U5

..... +» Point distribution Limits
----- E Tool axis Height

----- # Machine axis control -m

[]..gf Rapid Moves start =
- U Leads and links Width
Q}_f Start point

6_5' End point stars

[-fqr Feeds and speeds

Sequence | MNone V|

25.0

(=1

rm
=
[«

41 Set Pattern direction to U.
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----- 1z, Workplane [Tool axis ]
-l Block

..... | ,l Tool Tool axis

----- 2, Machine tool |Lead,.‘Lear1 o

..... b8 Limnit Lead/Lean angles

----- 5 Stock engagement Lead Lo
[_j‘%y Plane projection

i ¥7% Pattern

L.y Automatic verification
""" Q" Point distribution Mode | Preview frame normal |v
----- E Tool axis Contact normal
----- # Machine axis control Vertical
E-=4 Rapid Moves Fixed angle p 0
w-171 Leads and links | None | PowerMill 2012 R2

A Start nnint

42 Calculate the toolpath and then Close the dialog.
43 Simulate the toolpath and observe the associated tool alignment.

&  The resultant toolpath starts at the lower corner and progresses towards the
centre with a Lead in and Lean out both set to 0 creating tool alignment
relative to the projection direction. Due to Lead and Lean being 0 a directly
calculated Two way strategy is a feasible option.

44 Select a view along the Y Axis and then Simulate both toolpaths in turn to
visually, compare both strategies.

& The tool alignment is the same for both toolpaths due to a Lean value of
40 being applied to the Raster strategy.

RASTER L PROJECTION

45 Select File - Save Project.
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Lead/Lean - Example 3
1 Select File - Delete all and Tools - Reset forms.
2 Import the model:

...\PowerMill_Data\five_axis\joint_Saxismc\jointSaxis.dgk

3 Save Project As:-
+\COURSEWORK\PowerMill_Projects\Joint-EX1

4 Create the material Block using Defined by - Box to the Model dimensions
and then expand it by 15 in X and Y only.

5 Create a Dia 25 Ball Nosed cutter (BN25).
Select Calculate in the Rapid Move Heights dialog.
Use the Start and End Point default settings.

8 Select Leads and Links EJ and input the following settings:

= In Moves and clearances: Tick the box Automatically extend with
Maximum length 50, input Incremental plunge distance 10, and Axial
clearance 45.

= In Start and end point: Tick the box Incremental plunge.
= For Links set both 15t choice and 2" choice to Skim.
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9 Select the Toolpath Strategies icon @ and in the New Strategies dialog,
select the Finishing tab.

10 Select Projection Line Finishing and enter data exactly as shown in the
following 3 pages of the dialog.

P Line Projection Finishing

. Toolpath name |BN25-LineProj-1

—~
<

-1, Workplane {Line projection W
-l Block
1 Tool Pattern
-2, Machine tool Style | Spiral
--p88 Limit
-3 Stock engagement Location
WA v pojcon] [0 [0 J[z0 |
2% Pattern :
\w Automatic verification Azimuth
- Point distribution -I:-
E Tool axis I
D_@s; :‘Iac.zmMe axis control i
-=J Rapid Moves -m
-] Leads and links I
e';‘f Start point S
é?f End point Projection
(-3 Feeds and speeds Ll
.5 History
--[=] Notes and Description Tolerance
E. User defined settings
Thickness
Stepover
A [G0E
Preview | [ ]Draw
Calculate Queue 0K Cancel
= Set Azimuth to 0
= Set Elevation to 0
..... k’ Wnrkplane [Pattern ]
-l Block
----- |\_| Tool
----- 2, Machine tool Pattern
..... o Limit Style |Spira| v|
----- tock engagement
¥ Stock engag
£1-# Line projection Direction | Clockwise V|
A Pattern
Aut ti ificati
T Automatic verification Lirmits

..... £ Point distribution
----- E Tool axis Height

..... # Machine axis control Start
[]—-3&' Rapid Mowves -
-1 Leads and links
e';’f Start point
d’f End point

e

i

Preview Draw
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£-#» Line projection

5‘3 Pattern

... Wy Automatic verification
4% Point distribution

Do

-1 Workplane Tool axis ]
-fjl Block

U Tool Tool axis

[, Machine tool |Lead,."Lear1 V|

g8 Limnit Lead/Lean angles

-3 Stock engagement Lead Lean

Mode | Preview frame normal v|

11 Calculate the Toolpath and then Cancel to close the dialog.

B,

&  The next section continues with the machining of the upper part of this

component.

12 Save the Project (but do not close it down).

3- 14 Autodesk PowerMill 2017
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Toward \ From Point

These options allow the Tool Axis alignment to be based on a user-defined point
during the generation of toolpaths (In this case Towards Point). If Mode -
Preview frame normal is used then the actual alignment is taken relative to the
Preview pattern for the strategy and not the final toolpath.

TOOL AXIS -TOWARD POINT with MODE - PREVIEW FRAME

TOOLPATH PREVIEW

TOOLPATH PROJECTION POINT

- . -—'_-'.___"_,.--"
__.ﬂ—-"""r.r.’
%;—f’" ~T0OL ALIGNMENT

TOOL ALIGNMENT POINT

-

@
13 Set Leads/Links

|
* as follows:

= In Moves and clearances: Tick the box Automatically extend with
Maximum length 50, input Incremental plunge distance 10, and Axial
clearance 45.

= Lead In/Out:
= Lead In/Out Extensions:
= Links:

Surface normal arc, Angle 90 Radius 6
Extended Move, Distance 30
Skim

5
14 Select the Toolpath Strategies icon S‘ and select the Finishing tab located
in the new Strategy Selector dialog.

15 Select the Projection Point Finishing option.

16 In the Point Projection Finishing dialog main page, enter data exactly as
shown in the following illustration.

Copyright © Autodesk
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P Point Projection Finishing R =
. Toolpath name | BN25-PointProj-2 |
----- 12, Workplane [Point projection }
-l Block
..... | J| Tool Pattern
----- E, Machine tool .
..... o Limit iyl |Sprl |
..... i tck enagment Fncation
J -
... T Automatic verification o
..... & Point distribution Fricdion
----- E Tool axis Direction | Inwards V|
----- @ Machine axis control
[]--gf Rapid Moves Tolerance
-1 Leads and links _.'D?_
e?f Start point
'ﬂf End point Thickness
[-fr Feeds and speeds il @"
----- El History . -

----- [~] Motes and Description
----- E. User defined settings

Angular stepover

Preview [ ] Draw

Calculate Queue . 0K Cancel

17 Select the Pattern page and enter data into the dialog exactly as shown in the

following illustration.

----- Ir:, Workplane

-fjgll Block

----- |‘_J| Tool
..... 2 Machine tool
..... o Limit
..... 5 Stock engagement
|:—:|¢'e\ Point projection
Bdpeitcn
% Automatic verification
..... £ Point distribution
..... # Tool axis
..... # Machine axis control
[j.-gf Rapid Moves
517 Leads and links
e‘;‘f Start point
é‘f End point

[Pattern ‘

Pattern

Style | Spiral v|

Direction |Cloclmtise v‘

Lirits

Elevation angle

Preview Drraw

18 Input Elevation Angle data as:- Start 90 and End O.
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19 Select the Tool Axis page and enter data into the dialog exactly as shown in the

following illustration.

..... % Stock engagement
|:_j'*'¢3 Point projection

------ T Automatic verification
..... < Point distribution

----- X

----- # Machine axis control
[j--j Rapid Moves

[j---]m Leads and links
A Chark maink

% ;Tortplane [TOD' axis ]
o)

..... U Tool Tool axis

----- &, Machine tool |Towards point V|

..... off Limit Point

0 ] o] [0 @
Mode | Preview frame v|

Fixed angle

|None v| 50.0

20 Calculate the Toolpath but do not close the dialog.

TOOL ALIGNMENT -

TOWARDS POINT using
MODE - PREVIEW FRAME

&  The Tool Alignment point is approximately 20mm below the Projection
Finishing focal point to ensure that the spindle axis remains at an
elevation angle to the machine tool table during machining hence avoiding

collision.

Mode - Preview Plane:- The actual Tool alignment occurs on the Projection
Point Finishing - Preview pattern, after which the tool is then projected on to
the model (towards the strategy - focal point).

Copyright © Autodesk
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21 In the Point Projection dialog select Re-cycle @ and then open the Tool

AXxis page.
22 Change the Tool axis Mode to Toolpath.
----- 1z, Workplane | Tool axis J
-l Block
U Tool Tool axis
..... fi2, Machine tool |Towards point V|
----- o Limit Point
----- 3 Stock engagement [ 0.0 | [0.0 | [ 50.0 | i=
=% Point projection
----- ¥7% Pattern
i T Automatic verification
..... s Point distribution
_____ E Mode |Toolpath V|
----- # Machine axis control
D"ﬁ Rapid Moves Fixed angle
-1 ¥ Leads and links None V| s0.0
A Chart mnint

23 Calculate the Toolpath and then Cancel to close the dialog.

TOOL ALIGNMENT -
TOWARDS POINT using

MODE - TOOLPATH

Mode - Toolpath:- The Tool alignment is applied directly on to the finished
toolpath (towards the strategy focal point).

24 Select File - Save Project.
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Toward\From Line

These options allow tool axis alignment to be towards or from a user-defined
line, specified by a Vector direction through a suitably positioned XYZ coordinate.

1 Select File - Delete all and Tools - Reset forms.
2 Import the Model:-

...\PowerMill_Data\five_axis\Casing\from-line-model.dgk

3 Save Project As:
+\COURSEWORK\PowerMill_Projects\CameraCasing

4 Create a Dia 12 Ball Nose cutter named BN12 of Length 55 with:-
= Shank of Dia 12 - Length 40.
= 1st Holder - Lower Dia 25 - Upper Dia 40 - Length 40.
= 2nd Holder - Upper/Lower Dia 40 - Length 60 - Overhang 90.

Define the Block (use Box) to the Model limits.
6 Select Calculate in the Rapid Move Heights dialog.

7 Set Leads\Links ]EJ as follows:
= Z heights: Skim 5, Plunge 5
= Lead In/Out: 15t Choice - Surface normal arc, Angle 45, Radius 5.0
= Links: 1st choice - Circular Arc, Tick Apply constraints
with Distance < 3, and 2nd choice - Skim.
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3. Five Axis Tool Alignment

8 Select the Toolpath Strategies icon @ and in the new Strategy Selector
dialog, select the Finishing tab.

9 Select the Projection Line Finishing option.

10 In the Line Projection Finishing, Pattern, and Tool Axis pages enter data
exactly as shown in the following illustrations.

P Line Projection Finishing ? ey
Toolpath name [ BN12-LineProj-FINT |
""" 12, Workplane [Line projection ]
-l Block
----- [] Tool e
----- E
..... o Limit
----- 3 Stock engagement Location
=R Line projection| [00 | [00 | [750 |
ga Pattern
... T Automatic verification nnin

..... £ Point distribution -m
..... E Tool axis I

----- @) Machine axis control

[j--g'f Rapid Moves Flevation
[]—--]3,[: Leads and links I
ﬁ"f Start point
eq[.f End point Projection
E]“'ﬁl' Feeds and speeds Direction
----- E] History
----- ] Notes and Description Tolerance
----- E, User defined settings
Thickness
0

Stepover

A [z

Preview [] Draw

Calculate Queue 0K Cancel

= Set Style to Circular

= Input Location as 0 0 75
= Set Azimuth to 0

= Set Elevation to 90

= Set Direction Outwards
= Use Tolerance 0.01

= Use Stepover 1
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----- k, Workplane

-l Block

----- |‘_J Tool

..... f, Machine tool

..... o8 Limit

..... 3 Stock engagement
[_]/"p Line projection

g@A]patiern

...... % Automatic verification
..... 3 Point distribution
----- # Tool axis

----- @ Machine axis control
[j--gf Rapid Moves

- U Leads and links
é_’r Start point

- End point

[-fr Feeds and speeds

----- ] Motes and Description
----- E. User defined settings

[Pattern ]

Pattern

Style |Circu|ar V|

Ordering | Two way w |

Sequence |N0ne v|

Lirnits
Azimuth angle

st [00 | End

Height

start[00 |

[+
(K=
8 H
=

i
=
(=1

Draw

Preview

11 Back in the main Line projection page, select Component Thickness =4 .

12 Select any one of the 8 rows in the Component Thickness dialog.

P Component Thickness

Surfaces  Verification Surface Defaults

Entity

BM12-LineProj-FINT

“E’:},' @ @ % [ Use Axial Thickness

Machining Mode

Collision ~

Ed

<
G o

Thickness

Set Mode

@CI Machine
@1 Machine
@F’_ Machine
@3 Machine
S cotiision
@5 Machine
@6 Machine
@? Machine
K Machine

Thickness  Axial

(=TT = = T~ = T~ =]

e

Total Thickness  Total Axial

'
= =T~ =]
ra

o o o o o oo oo
'

Apply

Accept Cancel
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3. Five Axis Tool Alignment

13

Select all of the edge surfaces on the Model and acquire them to the

selected row in the Component Thickness dialog.

14
15

16
exactly as shown below.

Set the Machining Mode to Collision.
Apply and Accept the Component Thickness dialog.

Back in the Line Projection dialog select the Tool Axis page and enter data

P Line Projection Finishing

W

Toolpath name | BMN12-LineProj-FIMN1 |

-] Start point
.4 End point
G- Feeds and speeds

----- ] Notes and Description
----- z,-? User defined settings

..... 12, Workpine Toolas
il Block
..... U Tool Tool axis
----- & Machine tool
----- o8 Limit Point
----- %" Stock engagement | 0.0 | | 0.0 |
£1-#@» Line projection
83 Pattern Direction
Ty Automatic verification 1.0 0.0 !
..... < Point distribution :
[]...l.f Mode | Preview frame
----- # Machine axis control
[]--j Rapid Moves Fixed angle
[]--l}] Leads and links | MNone 90.0

v]

Reotary axis configuration

| Toolpath

17 Tick the Draw Tool Axis box

[] Draw tool axis

[ Tool axis limits
] Automatic collision avoidance
[[1Tool axis smoothing

[ Draw tool axis

to display the red, Tool Alignment

line relative to the Model (as shown in the following image).
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3. Five Axis Tool Alignment

Tool Alisnment
From (red) Line

Finishing Strategy
From (black) Line
Projection

18 Click the Preview tab to view the strategy before selecting Calculate to create
the Toolpath.

19 Close the Line Projection Finishing dialog.
The end result (with a larger stepover) is as shown in the following illustration:

The use of Tool Axis — From line with Mode - Preview frame has ensured
that the whole of the internal form, including the undercut areas, is fully
accessible. Note that in this case it gives a better result than if Mode -
Toolpath had been used.

20 Save the Project.
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3. Five Axis Tool Alignment

Toward\From Curve

These options allow the tool axis alignment to be through a user-defined curve
(Pattern).

The following example will use the Surface Finishing strategy. This is possible due
to each of the two different blade areas to be machined being smooth, single
surfaces with the edges aligned to the surface curves (The resultant tool tracks
will be aligned to these curves).

1
2

8
9

Select File - Delete all and Tools - Reset forms.
Import the Model:

....\PowerMill_Data\five_axis\Impeller\ impeller+Curve.dgk

Save Project as:

«..\COURSEWORK\PowerMill_Projects\ Impeller+Curve-EX1

Create an empty Pattern and rename it as Align2Curve.

In the graphics area, select the wireframe, alignment curve that has been
imported with the Model (Ensure that both the Plain Shade and Wireframe
views are switched on!).

Right mouse click on the Pattern (Align2Curve) and from the local menu,
select Insert > Model to copy the selected alignment curve as a Pattern
segment.

Pattern
(Tool Alignment Curve)

Create a Dia 3 Ball Nosed cutter (named BN3-LR) of Length 35 with the
following Shank and Holder dimensions:

= Shank - Upper\Lower Dia 3 - Length 25

= Holder 1 - Upper Dia 15 - Lower Dia 10 - Length 50
= Holder 2 - Upper\Lower Dia 15 - Length 35

= Overhang 50

Create a Block defined by Cylinder to the Model dimensions.

Set Links as 1st choice/2nd choice to Skim and Default to Incremental.

10 In the Rapid Move Heights dialog select Calculate.
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11 Select the underside face of the blade (nearest to the Pattern) to be used in the

first Surface Finishing strategy.

T+
pr=i

P T ]
e - e
—_— ‘ o

Pattern

12 Select the Toolpath Strategies icon @ and in the Strategy Selector dialog

select the Finishing tab.

13 Select Surface Finishing and fill in the pages of the dialog exactly as shown in

the following illustration.

P Surface Finishing

) Toolpath name |BN3—LerIade—FIN |

----- 111 Workplane

- Block

----- |\_,| Tool

..... E Machine tool

..... o Limit

----- 3% Stock engagement
S
..87 Pattern

i w Automatic verification
..... <3 Point distribution

----- E Tool axis

----- @& Machine axis control
[]..g-f Rapid Moves

@110 Leads and links

-] Start point

@"_j' End point

[].-.ﬁ- Feeds and speeds

----- ] Motes and Description
----- E. User defined settings

= Surface side - Outside

[Surface finishing }

Surface

Degouge tolerance

Tolerance

0.02

Thickness

0
Stepover (Distance)

A, [o015076

=

Preview [ Draw

Calculate Queue QK Cancel
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.12, Workplane

- { Block

|_| Tool

B, Machine tool

g Limit

-3 Stock engagement
[_]w Surface finishing
] pattern

W Autornatic verification
-4 Point distribution
k Tool axis

-.(#) Machine axis control
= panid Moscar

= Pattern direction - V

= Ordering - One way

Pattern

Pattern

Pattern direction

Ordering
Start corner

Sequence

= Start corner - Max U min V

v

Spiral []

I

One way

Max U min ¥ w

MNone

----- 12, Workplane
- §l Block

----- |_| Tool
..... . Machine tool
..... o Limit
..... 3 Stock engagement
[_]Jé) Surface finishing
473 Pattern
... T Automatic verification
..... £ Point distribution

1 :
----- k Tool axis

..... @) Machine axis control

[TDDI axis

Tool axis

From curve ~

Pattern
ﬂ Align2Curve

v| 2 3F) =5

Toolpath

14 For both Lead in and Lead out use the following for 1st and 2nd choice.
----- h Workplane ~ [L . l
ead in
[ Block
..... |_’| Tool 1st choice
----- @, Machine tool Surface normal arc v|
----- o Limit _
----- 3 Stock engagement Hineaiiniove
E-47 Surface finishing Angle
Ty Autornatic verification Radius %
..... % Point distribution L] Apply constraints
----- 1Z Tool axis Distance 5 10.0
----- # Machine axis control
[]—-gf Rapid Moves
[—]11 Leads and links
| :r'[ 2nd choice
1:1',[ Lead out Wertical arc v|
f,[ First and last leads )
1;{ Lead extensions HineaiiTiovs
| sagic [207 ]
T Point distribution
@il start point Radius
d_f End point [] Apply constraints
L

fl-isar Feeds and sneeds

-V

Distance

an
10.0

15 Click the Preview tab and view the strategy before selecting Calculate to

create the Toolpath.

16 Close the Surface Finishing dialog.
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3. Five Axis Tool Alignment

The Tool Axis is always aligned through the specified Pattern (Curve) while
performing the Surface Finishing strategy.

17 Right-click on the existing Surface Finishing strategy and from the local menu,
select Settings to re-open the dialog.

18 In the dialog, select Make a copy of the Toolpath .

19 Select the upper side, blade surface (nearest to the Pattern) to be used as the

20 Open the Surface Finishing and Tool Axis dialogs, entering the data exactly
as shown on the next page and select Calculate.
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3. Five Axis Tool Alignment

21

22

P Surface Finishing

[ et

Toolpath name | BM3-UpprBlade-FIM

|:_ij Surface finishing

------ T Automatic verification
..... < Point distribution

----- E Tool axis

----- # Machine axis control
E]__j Rapid Moves

7] Leads and links

e‘{f Start point

g4 End point

[-fqr Feeds and speeds

----- [] Motes and Description
----- E.. User defined settings

Degouge tolerance

Tolerance

Thickness

.

Stepover (Distance)

A

Preview

----- Lz, Workplane [Surface finishing ]
-l Block

----- |‘_J Tool Surface

..... 2, Machine tool Surface side| Outside V|

----- o Limit

----- :f’ Stock engagement Surface units | Distance V|

0.015076

[ Draw

----- k, Workplane
- Block

----- w8 Limit

----- 5 Stock engagement
[—jw Surface finishing
L T Automatic verification
..... £ Point distribution

----- # Tool axis

----- & Machine axis control
35' Rapid move heights

= Pattern direction - V

[Pattern

Pattern

Pattern direction  V -

Spiral [7]

Ordering  Oneway A

Start corner

Sequence

= Start corner - Min U max V

Min U max V -

MNane -

Click the Preview tab to view the strategy before selecting Calculate to create

the Toolpath.

Close the Surface Finishing dialog.
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3. Five Axis Tool Alignment

The Tool Axis is always aligned through the specified Pattern (Tool Alignment
Curve) while performing the chosen machining strategy (Surface Finishing).

A small area on the latest toolpath is fragmenting along the top edge as arrowed
above. This is caused by one of the other blades getting in the way of the
projection process at this point. In this instance an easy fix can be applied by
using a copy of the existing Pattern and moving it upwards by 1.5.

23 Create a copy of Pattern Align2Curve which will automatically be named as
Align2Curve-1.

24 Move the new Pattern upwards by 1.5mm.

25 Recycle the toolpath BN3-UprBlade-FIN with the Tool axis - from curve
options using Pattern Align2Curve-1.
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3. Five Axis Tool Alignment

The toolpath fragmentation on the upper edge has now been fixed.

26 Activate and Verify each toolpath in turn, checking both the Gouge and
Collision status (Use a Shank Clearance of 1 and a Holder Clearance of 2).

&> Toolpaths £18 Toolpaths
060 ) > BNI-LwrBlade FIN ey - § & BN3-LwBlade-FIN
-00) § 4 BN3-UprBlade-FIN - @@ ¢ > BN3-UprBlade-FIN

& Ifall is safe the Verify process will result in a Blue tick box adjacent to
each toolpath in the PowerMill explorer.

27 Save the Project.
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3. Five Axis Tool Alignment

Fixed Direction

This allows the Tool Axis to be set to a fixed angle, specified as a user defined,
Vector. In this case it is applied to the finishing of an angled recess on the supplied
Model.

Angle to Vector conversion table

Fixed Direction Tool Alignment - Vectors\Angular equivalents
The table represents angular directions and vectors on the XY plane (Z=0).

ANGLE VECTORS
(Degrees) (I J K)
0 1 0.0000 0
5 1 0.0875 0
10 1 0.1760 0
15 1 0.2680 0
20 1 0.3640 0
25 1 0.4660 0
30 1 0.5770 0
35 1 0.7000 0
40 1 0.8390 0
45 1 1.0000 0
50 1 1.1920 0
55 1 1.4280 0
60 1 1.7320 0
65 1 2.1450 0
70 1 2.7470 0
75 1 3.7320 0
80 1 5.6710 0
85 1 11.4300 0
90 0 1.0000 0

e opposite

Tan (Angle) =( = osite) 7 j value

,_/"ﬂ;'ngle \
Adjacenti =1
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3. Five Axis Tool Alignment

The Tool Alignment is set to a Fixed Direction relative to the currently active
Workplane by inputting suitable values as an I J K vector along the Tool Axis
(towards the spindle). Although the correct values for a vector may require the
user to exercise their trigonometry skills, this method does provide full flexibility for
defining compound angles.

1 From the main pull down menus, select File - Delete All and Tools - Reset
Forms.

2 Open the (read only) Project:
~.\PowerMill_Data\five_axis\AngledFrame\ToolAxisFixed1-Start

3 Save Project As:
..\COURSEWORK\PowerMill_Projects\ToolAxisFixed-EX1
4 Activate and then de-activate the Toolpath D12t1-ruf-TOP.

This will restore the settings (Workplane, Rapid Move Heights, etc) ready to
apply a finishing strategy on the corrugated angled form.

5 Activate the BN6 tool.

6 Select the undulating Surface on the base of the angled recess.
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Select the Toolpath Strategies icon @ and in the Strategy Selector dialog

select the Finishing tab.

Select the Surface Finishing option and fill in the pages of the dialog exactly as
shown in the following illustrations.

P Surface Finishing

? X

1 Toolpath name |BN6-fin-ANGLE |

..... 12, Workplane
-l Block
----- |\_,| Tool
----- 2, Machine tool
..... o Limit
..... 3 Stock engagement
b
gg Pattern
"Wy Automatic verification
..... 3 Point distribution
----- E Tool axis
----- @ Machine axis control
[]..gf Rapid Moves
17! Leads and links
e‘f Start point

[Surface finishing ]

Surface

Surface side | Qutside

Surface units | Distance

Degouge tolerance

Tolerance

Thickness

etf End point ....D
&#-Fir Feeds and speeds § N
""" ::? History o Stepover (Distance)
----- =| Motes and Description
----- E. User defined settings A 0020906
Preview [ Draw
Calculate Queue 0K Cancel
= Surface Side - Outside
= Stepover - 0.5
.12, Workplane [Pattern ]
[ Block
|_| Tool
B, Machine tool Pattern
o8 Limit Pattern direction

.3 Stock engagement
HU} Surface finishing

W Automatic verification
% Point distribution
k Tool axis
.ig Machine axis control
w-=H Rapid Moves

= Pattern direction - V

= Ordering - TWo way

Spiral (]
Ordering | Two way
Start corner | Min U min V ~

Sequence |Mone
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..... 3 Point distribution

..... 17 Tool axis|

----- i# Machine axis control
[j--gf Rapid Moves

-1 Leads and links
e';’}' Start point

@4 End point

-5 Feeds and speeds
El History

----- = Motes and Description
..... E. User defined settings

----- 12, Workplane [Tool axis ]
-l Block

..... I\_’l Tool Tool axis

..... IE, Machine tool |Fixed direction v

..... W8 Limit

..... 3 Stock engagement
[_jw! Surface finishing

ES Pattern Direction
00| [0 | [osm

Tool axis limits
[] Automatic collisicn avoidance
[]Tool axis smoothing
Draw tool axis

9 Set the Tool Axis to Fixed direction.

10 Input the vector Direction values: I0 J-1 K0.577

11 Tick the Draw tool axis box.

Draw tool axis

12 From Leads and links select the Links dialog and enter data exactly as shown

in the following illustration.
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3. Five Axis Tool Alignment

----- k, Warkplane -~ [Links ]
-l Block

..... LJ Tool 1st choice

----- @ Machine tool | On surface Vl

..... w8 Limit

Motion |Simultaneous Vl
..... 37 Stock engagement

[_ju} Surface finishing

Apply constraints

..... &% Point distribution EEEE 4 [

..... 1.’2: Tool axis | ~ | <
----- # Machine axis control
[j--j Rapid Moves 2nd choice
=17 Leads and links
H Lead in

1 e Maticn | Simultanecus V|
11[: First and last leads
! Lead extensions .
- H [] Apply constraints

LW Point distribution <
6‘_" Start point

é_" End point

.. Feeds and sneeds xe

|Skim v|

Default

| Incremental ~ |

Motion | Simultanecus V|

Gouge check [~]

13 Click the Preview tab to view the strategy before selecting Calculate to create
the Toolpath.

14 Close the Surface Finishing dialog.

Draw Tool Axis —
-

& For viewing purposes, the toolpath shown in the illustration has been
created using a 2mm Stepover.

15 From the main pulldown menu, select File - Save to update the stored
Project:

+\COURSEWORK\PowerMill_Projects\ToolAxisFixed-EX1
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4. Projection Surface Finishing

4. Projection Surface
Finishing

Introduction

In a Projection Surface Finishing the strategy is projected Inwards or
Outwards along the normals of a single Reference Surface. For five axis
applications an appropriate tool alignment is used. The toolpath runs either across
or along the natural Reference Surface directions (U or V) with the Stepover
being defined by unit Distance or Parametric division between Surface Curves.
In some cases the Reference Surface may form part or all, of the component to
be machined.

To create a Reference Surface the user will require the services of a suitable
Surface Modeller, ideally PowerSHAPE. For the following example the Reference
Surface has already been created and stored as a separate dgk file to be imported
as required. A reference surface should be as smooth and simple as possible. It
should also be as close as possible to the actual surfaces that are to be machined.

1 Open the (Read Only) Project:-
...\PowerMill_Data\five_axis\CornerFixing\ProjectionSurfaceEX1-Start

2 Save Project As:
«.\COURSEWORK\PowerMill_Projects\ProjectionSurface-Examplel
3 Activate the toolpath D25TR3-RGH1 to reinstate the settings.
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4. Projection Surface Finishing

&  The Block used in the toolpath D25TR3-RGH1 is defined from an
imported Triangle model (dmt file) of a Casting.

4 Run a ViewMILL simulation on the toolpath D25TR3-RGH1.

b

5 Save the ViewMILL model at this stage.

6 Return to the PowerMill window §| and temporarily suspend

ViewMILL. @

Calculate a new Block - Defined by - Box using Type - Model.
Import the Model:-
....\PowerMill_Data\five_axis\CornerFixing\CornerFixingRefSurf1.dgk
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4. Projection Surface Finishing

9 In the PowerMill explorer, activate the BN16 tool.

10 In the PowerMill explorer right mouse click on the model named
CornerFixingRefSurfl and from the local menu select Select All.

The newly imported (reference) surface (shown shaded above) is fully located
inside the original component model.

2

11 From the main toolbar select the Toolpath Strategies

12 From the dialog select the Finishing tab followed by the Projection Surface
Finishing option.

13 Enter the values into the main page of the Surface Projection Finishing
exactly as shown below.

P Surface Projection Finishing ? X

. Toolpath name | BN16-FIN1 |

..... 12, Workplane

-l Block

----- |_| Tool

----- 2, Machine tool

..... o Limit

----- 3 Stock engagement

Bl e poecton
E:g Pattern Angular smoothing tolerance
... W@ Automatic verification

..... <3 Paint distribution Projection

_____ E Tool axis Direction | Inwards

----- # Machine axis control

-2 Rapid Moves Tolerance

@11 Leads and links

e'ﬂ' Start point

@ End point Thickness
[1-fqr Feeds and speeds

..... B History -
----- ] Motes and Description
----- E. User defined settings

[Surface projection }

Surface

Surface units | Distance

I

Smoothing tolerance | 0.1

&= I

Stepover (Distance)

Preview [] Draw
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4. Projection Surface Finishing

14 Enter the values into the Pattern page of the Surface Projection Finishing

exactly as shown below.

P Surface Projection Finishing

? X

Toolpath name | BM1E-FIN1

-3 Stock engagement
£ Surface projection
------ T Automatic verification
—#us Point distribution
E Tool axis

() Machine axis control
Ej.-gf Rapid Moves

-7 Leads and links
é’f Start point

e‘{f End point

[-fr Feeds and speeds
-5 History

-..[-] Motes and Description

,E. User defined settings

= Pattern direction - U

% ‘éﬁ.lfortplane [Pattern ]
oc

|_| Tool

[, Machine tool Pattern

8 Limit Pattern direction

Spiral []

Ordering | One way ~|
Stert comer |MinUmaxV |
Sequence | None v]

Lirnits (Distance)

Ju

=
=

Start

End | 1.0

Preview

= Start corner - Min U max V
= Limits (Distance) - V (ticked):- Start 0 End 95

v

95.0

Draw

15 Enter the values into the Tool axis page of the Surface Projection Finishing

exactly as shown below.

P Surface Projection Finishing

Toolpath name | BM16-FIN1

£ Surface projection

4% Point distribution
E Tool axis
@ Machine axis control
[]--3’? Rapid Moves

-1 U] Leads and links

A Chark mnint

.12, Workplane {TDDI axis ]
gl Block

| J| Tool Tool axis

[B, Machinetool |LeadlLean v

8 Limit Lead/Lean angles

-3 Stock engagement Lead Lean

Mede | Preview frame normal |v

Fixed angle

Contact normal
Vertical

|N|:|r1e

PowerMill 2012 R2

<

16 In the Tool Axis page select Lead/Lean with both values set to O.
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4. Projection Surface Finishing

17 Enter the values into the Tool axis page of the Surface Projection Finishing
exactly as shown below.

P Surface Projection Finishing

Toolpath name | BM16-FIM1 |

..... 12, Workplane - P

-l Block

U Tool 1st choice
..... 2, Machine tool | Vertical arc

----- of8 Limit
Linear mowve

..... 3 Stock engagement

H...t%,-gﬁ;::t:;ojection Angle

.. T Automatic verification
..... “ Point distribution [ Apply constraints

----- Tool axis Distance vl > ~

----- @ Machine axis control
o > I

[]..g Rapid Moves
=7 Leads and links

II! 2nd choice
II! Lead out | Mane v|
17! First and lact leads

18 In the Leads and Links pages set:-
= Set both Lead in and Lead out - Vertical Arc - Distance 3, Angle 90,
Radius 8.

jd |

10.0

19 Select Calculate to create the toolpath, but do not close the dialog.

Y
& For visual reasons a larger Stepover has been used on the Toolpath

shown in the illustration

20 In the Surface Projection dialog select Make a Copy to re-activate the
Settings.
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4. Projection Surface Finishing

It is possible for all or part, of the Reference Surface to exist outside of the
component to be machined. In this case the option, Import Reference Surface
will be used as it is not a part of the component model to be machined.

21 Right-click on Models in the PowerMill explorer and select Import Reference
Surfaces.

22 1In the Reference Surface dialog, select the Model:
....\PowerMill_Data\five_axis\ CornerFixing\CornerFixingRefSurf3.dgk

“&  The new Reference Surface exists outside the component to be
machined. As a result of using the command Import Reference
Surfaces, the Machining Mode is permanently set to Ignore for the
Reference Surface.

=@l Models

' CorerFixingModel
. CornerFixingRefSurfl
- ComerFixingRefSurf3

& The imported Reference Surface is displayed in the PowerMill
explorer with a different colour (grey).

23 Select the Reference Surface - CornerFixingRefSurf3.
24 Rename the Toolpath as BN16-FIN2.
25 In the Pattern page change the Limits (Distance) V as shown in the image

below.
Limits (Distance)
[u F
Start | 0.0 0.0
End | 1.0 130.0
oo

26 Calculate the copied, Projection Surface Strategy.

4 -6 Autodesk PowerMill 2017 Copyright © Autodesk



{\ AUTODESK.

4. Projection Surface Finishing

27 To update the stored Project, select File > Save Project:
«....COURSEWORK\PowerMill_Projects\ProjectionSurface-Examplel

Exercise

28 Create a new Projection Surface Finishing (named BN16-FIN3) starting at
the centre of the top face to complete the other side of the component model (as
shown below).

29 To update the stored Project, select File > Save Project:
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Surface Projection Range.

Depending on the application, it may be necessary to limit the infinite projection
range while applying the Surface Projection strategy. This situation occurs where
the part of the model to be machined is shielded by other surfaces that are in the
projection path. This command is, at present, only available via typed input into the
PowerMill Command Window. A more efficient way would be to store the
command lines for a range of different distances in a series of macros, which in
turn could be accessed via a user defined menu.

1 Select File - Delete all and Tools - Reset forms.
2 Open the (Read Only) Project:
....\PowerMill_Data\five_axis\ImpellerType2\Impeller Type2-Start

3 Save Project As:-
.....COURSEWORK\PowerMill_Projects\Impeller Type2-EX1

The imported Project already contains 3 Roughing Toolpaths, and a Stock
Model.

4 Select an ISO 1 view.

The next stage is to finish machine the 2 main faces of the blade positioned along
the =Y direction (Shown shaded light blue in the above image). If the 2 main faces
were single surfaces then it would be possible to directly apply the Surface
Machining strategy (which is not affected by Projection Range). This option is
not practical in this case as the main faces of the blade consist of several surfaces.
As a result it is necessary to obtain 2 suitable single, reference surfaces created
using CAD (ideally PowerSHAPE). These will purely be used as reference surfaces
in the Projection Surface Finishing strategy and will not be physically machined.
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4. Projection Surface Finishing

5 In the PowerMill explorer right mouse click on Models and from the local
menu select Import Reference Surfaces.

B‘m ) | P Import Reference Surfaces
- Iri Models

e . Q| ook [ mpdoTpe2
Paste as new Model ) Name .
Import Model... Impe!leﬂypeZ-Start
Import Reference Surfaces.., I} ——-_——' || Impeller-type2.dgk

| ImpellerType2-RefSurfs.dgk h

6 In the dialog browse to:-
..\PowerMill_Data\five_axis\Impeller Type2\Impeller Type2-RefSurfs.dgk

7 In the dialog select Open to import 2 reference surfaces (shown below).

& By using this import method the 2 reference surfaces will always be
ignored by a machining strategy during the calculation of a toolpath.

E@' Levels and Sets
----- .@’ General
- 7 £ 3Blades

L U Ref-Surfacel

L U7 Ref-Surface2
=@ Models

‘ Impeller-type2

@ ImpellerType2-RefSurfs

& The reference surfaces are already acquired to appropriate levels
(Ref-Surfacel and Ref-Surface2) this being inherited from the CAD
process.

8 Calculate a Block using a Cylinder to the full Model dimensions.
9 Calculate the Rapid Move Heights using the default settings.

10 Switch off the Level, Ref-Surface2.

11 Select the reference Surface stored on the level, Ref-Surfacel.
12 Activate the Workplane TopFace.

13 From the PowerMill explorer, Activate the BN16 tool.
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4. Projection Surface Finishing

14 Set Lead In and Out, 1st choice to use Surface normal arc.

15
16

17

P Toolpath connections ? *

Safearea Moves and clearances  Start and end point  Lead ins  Lead outs  Links  Point distribution

Lead ins [ Separate first lead in

1st choice Mone

Surface normal arc |

[ Apply constraints
Linear move [ 8 0o
I | S
- «

2nd choice Lead in extension

Mone w
Vertical arc |

]
[ Apply constraints
Linear move - Dictonee 8 0o
angee [900 |
Radius 2

T (| S
“» || @
o || S
“w || &

Overlap distance (tool diameter units)

From the main toolbar select the Toolpath Strategies @ .

From the dialog select the Finishing tab followed by the Projection Surface
Finishing option.

Enter data into the following 3 pages of the Surface Projection dialog exactly as
shown below.

P Surface Projection Finishing ? X

Toolpath name ‘ BN16-BladelA-FIN \

k Woarkplane
- Block

|_| Teol Surface
B, Machine tool Surface units
g8 Limit

B Stock engagement Smoothing tolerance

o occion]

gg Pattern Angular smoothing tolerance

[Surface projection }

T Automatic verification
..+ Point distribution Projection

{# Machine axis control
& = Rapid MDV?S Tolerance
[]...]i, Leads and links

ﬂ'f Start point

et,f End point Thickness
[-fqr Feeds and speeds

H
2 History o) )
] Notes and Description

E. User defined settings Stepover (Distance)

Preview ] Draw
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P Surface Projection Finishing

Toolpath name | BN16-BladelA-FIN

-3 Stock engagement
-4 Surface projection

Q- Point distribution
I; Tool axis
i Machine axis control

P Surface Projection Finishing

% ;‘.lfortplane [Pattern }
oc

|_| Tool

-2 Machine tool Pattem

Pattern direction | U

Spiral (]

I

Ordering | One way
Start corner | Min U min V w

Sequence | Mone

]
< <

Toolpath name | BN16-BladelA-FIN

+71 Pattern
..Wg Autornatic verification
Q- Point distribution

# Machine axis control

following toolpath, and then Close the dialog.

.12, Workplane [TDO' axis }
- Block

| Toal Tool axis

-2, Machine tool |Lead,a‘Lear1

o688 Limit Lead/Lean angles

.3 Stock engagement Lead Lean
=% Surface projection

Mode | Preview frame normal v|

18 Select Calculate in the Surface Projection Finishing dialog to produce the

“&  With the Projection Range set to OFF (default), ie. No limit, the
toolpath is projected inwards towards the surface to be machined from
outside the model limits. As the strategy is projected some of it will
appear on neighbouring surfaces instead of those intended to be

machined and create the toolpath as shown.
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4. Projection Surface Finishing

Projection Range (Unlimited)

_:'-qL-._.__‘_‘_ Tool tracks are created on the first face of the
- maodel, in line with the projection direction.

This problem can be resolved by switching to the Projection Range ON option
and assigning suitable + and - distance values.

19 Right mouse click on the toolpath BN16-BladelA-FIN and from the local menu
select Settings to re-open the strategy dialog.

20 Select Recycle \@

21 From the main pull down menus select: View > Toolbar > Command.

22 Enter the following commands into the Command Window that has appeared at
the below of the graphics area:

EDIT SURFPROJ AUTORANGE OFF
EDIT SURFPROJ RANGEMIN -3
EDIT SURFPROJ RANGEMAX 3

o, ECQ}'D
/@%
S47]

The above command input limits the Surface Projection Range to + and - 3mm.

23 Select Calculate to create the new toolpath.
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4. Projection Surface Finishing

24 Simulate the toolpath to observe the effect of the limited - Projection Range.

25 Create a Copy of this Surface Projection strategy on the other side of the blade
(Use the reference Surface stored on Level, Ref-Surface2).

26 In the Command Window type the following to restore the default, infinite
Projection Range:

EDIT SURFPROJ AUTORANGE ON
=7 This command returns to the default infinite limit for the Surface
Projection distance range.

27 select File > Save Project to update the stored Project:
+\COURSEWORK\PowerMill_Projects\Ref-Surfs-Blades
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4. Projection Surface Finishing

Surface Finishing and Surface
Projection - Spiral

Both the Surface Finishing and Surface Projection Finishing strategies include
the option to create a spiral toolpath:

& The stepover is automatically adjusted so that the final cut finishes
exactly on the surface edge at the end of the toolpath.

If you select a Surface Units of Distance, then the first and last passes will match
the edges of the surface. To achieve this, the intermediate passes will adjust to less
than or equal to the specified stepover.

Projection Surface - Spiral Example

1 Select File - Delete All and Tools - Reset Forms.
2 Open the (read-only) Project:

«...\PowerMill_Data\five_axis\ProjSurf-Blade\SurfProjSpiral-Start

3 Save Project As:

.....COURSEWORK\PowerMill_Projects\SurfMachine-Spiral

&  The Strategy in the above Project is unprocessed (As indicated by the
Calculator icon).

4 In the PowerMill explorer, right-click on Toolpaths to open the local menu and
select Batch Process to create the toolpath.

B'@‘ Toolpaths |
OB Toolpaths
257 Tools
B gl Toolbar
O Bounds Create Toolpath...
- Pattern
B Hole F: Toolpath Names »
E‘? Feature Folder Mames ¥
_Jé;' Wo:kp Batch Process
Q b by
b5 Levels ¢
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4. Projection Surface Finishing

The strategy automatically reinstates the original selected surface used on a
previous occasion. The resultant Toolpath contains independent, stacked tool
tracks and Surface Normal Arcs for Lead In/Out. For this strategy it, would be
both possible and more appropriate to use the Spiral option.

5 Right-click on the Active toolpath to open the local menu and select Settings to
open the original Surface Projection Finishing dialog.

6 Select Make a Copy to re-activate the Settings.

7 Select the Pattern page in the Surface Projection Finishing dialog.

P Surface Projection Finishing ? >

1 Teelpath name |SurfaceProjectionSPIRAL |

!g Workplane [P }
attern
- Block

|\_| Tool
{12, Machinetool Pattern

g Limit Pattern direction
.3 Stock engagement ’
=% Surface projection i

Sﬁm ] o Ordering | One way

... T Automatic verification B
\'\; Point distribution Start corner | Min U min V V|
}’: Tool axis }
-.{# Machine axis control Sequence | None

8 Rename the strategy as SurfaceProjectionSPIRAL, tick the Spiral box, and
check that the reference surface is selected, before selecting Calculate.
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4. Projection Surface Finishing

This time the Projection Surface strategy consists of a single Spiral tool track,
providing optimum efficiency and a smooth, consistent material removal.

9 Close the dialog.
10 Select File - Save Project to update:-
«...COURSEWORK\PowerMill_Projects\SurfMachine-Spiral
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5. Embedded Pattern
Finishing

Introduction

This Five Axis strategy not only tracks along the Embedded Pattern but
automatically applies a Tool Axis alignment relative to the Surface Normals.

An Embedded Pattern is created as a projection of an ordinary Pattern using the
Edit - Embed option. The Pattern projection can be performed down the active Z
Axis or towards the closest point on the model.

Embedded Pattern Finishing - Engraving
1 Open the (Read only) Project:
..\PowerMill_Data\five_axis\ 5axis_ Embedded_Pattern\TrimPart-Start

The model includes some wireframe Text and a ‘scribe line’ curve running
around the form.

These will each be used create separate Patterns. The corresponding
Embedded Patterns can then created from the 2 new Patterns.

2 Select File > Save Project As:

+....COURSEWORK\PowerMill-Projects\Trim-Part
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5. Embedded Pattern Finishining

3 Activate the toolpath, BN16-Form-FIN to reinstate suitable settings for the

Embedded Pattern.
Activate the tool BN2.

N o o s

select Create Pattern.

Ensure that none of the stored Boundaries are active.
In the graphics area, select the wireframe part of the model named ‘'TYPE 1'.

In the PowerMill explorer, right-click on Patterns and from the local menu,

8 Right-click on the new (empty) Pattern and from the local menu, select Insert
- Model to inherit the selected wireframe text, ‘TYPE 1'.

The first Pattern contains the text ‘'TYPE 1’ and is positioned above the Model.
This Pattern is then used to create an Embedded Pattern which projects down
Z onto the model. The Embedded Pattern will also pick up and store the

Surface Normals.

9 Rename the Pattern as ‘Text'.

10 In the PowerMill explorer, right-click on the Pattern and from the local menu

select Edit > Embed.

11 From the local menu, select Method - Drop and Apply the dialog.

P Embed Pattern

Apply

?

Method TN -

n a0
e Wl

Tolerance | 0.1

Cancel

X

=% Patterns
i 03 Text
7 & >Text_1

&  An Embedded Pattern called Text_1 s created as projected down Z and

is identified by the icon

retained.

&3

in the explorer. The original Pattern is

5-2 Autodesk PowerMill 2017
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5. Embedded Pattern Finishing

12 Select Toolpath Strategies @ and from the Strategy Selector dialog sect
the Finishing tab.

13 From the Finishing options, select the Embedded Pattern Finishing.

14 Enter the values into the following pages of the Embedded Pattern Finishing
dialog exactly as shown.

P Ernbedded Pattern Finishing 1 X
Toolpath name | BMNZ-Text-FIM |
----- 12, Workplane {Embedded pattern finishing ]
i Block
..... E Tool Drive curve
..... Machine tool
..... o Limit 31 [ Tet v = I =
..... 3 Stock engagement
[—j\é) Embedded pattern finishing el

i-E& Multiple cuts Axial offset “

... Automatic verification
..... % Point distribution

_____ E Tool axis Gouge aveidance
----- % Mac_hine axis control I Decpuime Gouge check[ ]
Mo BRI Degouge tolerance

w17 Leads and links
e‘{f Start point

ﬂf End point Tolerance
G-y Feeds and speeds
..... & History e

----- [ Motes and Description

£ . : Thickness
..... ¢+ User defined settings

fy

=

Calculate Queue 0K Cancel

= Drive curve Text_1
= Axial offset -3
= Untick Gouge Check
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5. Embedded Pattern Finishining

"

P Embedded Pattern Finishing ?

Toolpath name | BM2-Text-FIN |

% ‘;\Ifortp'aﬂe [Multiple cuts 1
ac

----- |\_,| Tool
----- [, Machinetool Mode
----- w8 Limnit

..... r—

[-j\@ Embedded pattern finishing [ Maximum number of cuts
[

10

..... \\.- Point distribution
----- }_, Tool axis Upper limit
----- # Machine axis control -
-D
[j--;-'f Rapid Moves
[}-]ﬂ: Leads and links
6-f Start point

& End ot 7.

[]---ﬁ- Feeds and speeds

Maximum stepdown

15 Tick Upper limit with a value of -1.

P Embedded Pattern Finishing ?

Teolpath name | BM2-Text-FIM |

..... 12, Workplane [TDD| axis 1
- Block

..... || Teol Tool axis

----- 2 woctine o

..... i Lirmit Lead/Lean angles
..... 3 Stock engagement Lead Lean
[-j&) Embedded pattern finishing m

&= Multiple cuts
T Automatic verification
----- % Point distribution

Mode | Contact normal v|
----- O] ool
16 Set the Tool Axis to Lead/Lean both with 0 angles.

It is necessary to ensure that the tool plunges and retracts along the Tool axis

during Embedded Pattern finishing (Retract distance 5 and Approach
distance 5).

17 From the main toolbar select Leads and Links, select the Moves and
clearances page.

—
r
Safearea Moves and clearances  Start and end point Leadins Lead outs  Links  Point distribution

Retract and approach moves Clearances

Awial clearance

Radial clearance | 90

[ Automatically extend

Maximum length

Incremental plunge distance

Distance

18 In both Minimum retract/approach distance, enter 5 (as shown above).
19 Accept the Leads and Links dialog.
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20 Back in the main strategy dialog select Calculate to create the Toolpath.

The text ‘'TYPE 1’ is machined to a total depth of -3 with the tool aligned to the
Surface Normals.

21 Perform a ViewMILL Simulation on all of the Toolpaths.

The Embedded Pattern toolpath has been produced with the tool aligned
normal to the surface model.

& Ifthe toolpath is verified for gouges it will take on a Red 'gouge’
warning. It is not possible to create a toolpath using a -ve thickness value

that is higher than the tool tip radius while Gouge check is switched on.

This is in technical terms a ‘deliberate gouge’ and will be ignored.

El«@ Toolpaths

| B g & D25t3-RGH

-V ¢ @8 D16t3-Flats-FIN
- ¢ g BN16-Form-FIN

- =@, > BN2-Text-FIN

22 Create a new Pattern named ScribelLine and Insert the wireframe Curve,
running around the upper wall of the model.

23 Create an Embedded Pattern from the Pattern (ScribelLine) but this time

select Closest Point in the dialog.

P Embed Pattern ot

?
Distance
Tolerance

Apply Cancel

This time the Embedded Pattern results from a projection towards the nearest
point on the Model (Normals) from the original Pattern.
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5. Embedded Pattern Finishining

24 Open a new Embedded Pattern strategy named BN2-ScribeLine-FIN using

Drive curve - ScribeLine_1.

P Embedded Pattern Finishing ’ =
Toclpath name | M2-Scribeline-FIN |
12, Workplane [Embedded pattern finishing ]
-l Block
-] Tool Drive curve
{8, Machine teol ol | el g [ |
A Limit I scribetine | V] [ B¥ &R
B Stock engagement
Lower limit

B\.‘Qj} Embedded pattern finishing

L5 Gouge avoidance

‘= Multiple cuts
i..Tg Automatic verification

st Point distribution

12 Tool axis

-{# Machine axis control

[j--gf Rapid Moves

w17 Leads and links

e? Start point

- End point

- Feeds and speeds

-5 History

.| Motes and Description

E. User defined settings

= Axial offset. 0
= Gouge check: Ticked
= Thickness: -0.75

Jodial offset

Gouge avoidance

Gouge check
|+| Degouge
Degouge tolerance
Tolerance
Thickness

o

This time the required Depth Of Cut is less than the Tool Tip Radius allowing the
Thickness option to be used instead of Axial offset.
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| P Embedded Pattern Finishing 7

" Toolpath name |N?_—ScribeLine—FlN |

I'L ‘;'-l'ortplaﬂe [Multiple cuts }
oC

..... |_| Tool
..... 2, Machine tool

Maode | Off v|

----- 3 Stock engagement Order by | Region o |

[—j\&_&) Embedded pattern finishing Maximurm number of cuts
F7 Gouge avoidance

=4 Multiple cuts s

% Automatic verification
..... 3 Point distribution [ Upper limit
----- E Tool axis 10
----- @ Machine axis control
D"g{ Rapid MO“_ES Maximum stepdown
w1 Leads and links
@? Start point ﬁl 1.0

ei_f End point
= Set Mode: Off
= Upper Limit: Un-ticked

25 Select Calculate to create the Embedded Pattern toolpath.
26 Continue the ViewMILL Simulation on the new toolpath.

27 Select File > Save Project.

Copyright © Autodesk Autodesk PowerMill 2017 5-7



- {\ AUTODESK.

5. Embedded Pattern Finishining

5-8 Autodesk PowerMill 2017 Copyright © Autodesk



{\ AUTODESK.

6. Five Axis Swarf Machining

6. Five Axis Swarf
Machining

Introduction

Five Axis - Swarf Finishing is designed to create a toolpath where the selected
surfaces are machined with the side of the tool (the default Tool Alignment
option is Automatic). A Swarf Finishing toolpath will only exist where the tool is
able to remain in full contact with the selected surfaces along the whole cutting
depth. In other words, the tool must always be able to find a Linear path across the
surfaces. It is possible for the user to apply a different tool alignment (For
example, Vertical or Lead\Lean) but the selected surfaces must still be
Swarfable for machining to occur.

In cases where imported surfaces are supposed to be Swarfable but are not of a
suitable quality, the upper and lower edges can be created as separate (wireframe)
Patterns to be used with Wireframe Swarf Finishing.

Swarf Finishing - example 1

1 Select File > Delete All followed by Tools > Reset Forms.
2 Import the model:

«...\PowerMill_Data\five_axis\swarf mc\swarf_model.dgk

3 Create a Block using Type - Box and Defined by - Model.
4 Create a Dia 12, tiprad 1, tool named D12TR1.
5 Calculate the Rapid move heights.
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6 Change the view to ISO 4 ﬁj and select the local surfaces to be Swarf
machined (as shown below shaded).

7 Select Toolpath strategies @ and from the Finishing dialog select the
Swarf Finishing option.

8 Enter the values into the main page of the dialog exactly as shown below and
Calculate.

[ 9

=2

P Swarf Finishing

-

The default Tool Alignment is Automatic for this strategy.

Toolpath name | D12TR1-5warf1

k_ Workplane

-l Block
U Tool

-3, Machine tool

4 Limit

.3 Stock engagement
-\ sviarf finishing|

..... .~ Position

7% Gouge avoidance
-&= Multiple cuts
-[JF High speed

... Wy Automatic verification
.4 Point distribution
E Tool axis

(g Machine axis control
&-=1 Rapid Moves

- U1 Leads and links

6’_? Start point

é’f End point

&-fqr Feeds and speeds
-5 History

-.=| Motes and Description

.8 lser defined settinas

~

[Swarf finishing

Drive curve

Surface side

Minimum fanning distance

Surface joining tolerance

Gouge avoidance

Tolerance

Thickness

iy

Preview

Calculate Queue

Fan at end on planes []

Reverse axis [_|

Follow surface laterals [ ]

0

i

Gouge check
Degouge tolerance

Cut direction
Climb

] Draw

QK

Cancel

E‘I
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6. Five Axis Swarf Machining

|
9 Open the Leads and links dialog via the icon EJ and Apply the following

settings:
Lead in/out: Vertical Arc - Distance 10 - Angle 90 - Radius 5.0
Links: 1st/2nd choice - Skim Default - Incremental

10 Deselect the local surfaces, Simulate the resultant toolpath, and observe the
constantly changing tool alignment as it Swarf machines the selected
surfaces.

11 Select Settings to reopen the existing (active) Swarf Finishing strategy and

then create a Copy named D12TR1-Swarf2.

12 Select the, upper sidewall, surface (as shown above).
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13 Select the Position page and set Base position - Bottom with Offset -2.

P Swarf Finishing

-

? X

Toclpath name | D12TR1-Swarf2

..... 3" Stock engagement

-} Swarf finishing
L

Gouge aveoidance

&= Multiple cuts

% :.lfortplane - [P[)Siti[)n ]
oc

..... [ ] Teal

..... 2, Machine tool Lower limit

..... W Limit -

Workplane

14 Select the Multiple cuts page, with the Mode set to Merge with Maximum

stepdown 1.

P Swarf Finishing

Toolpath name | D12TR1-Swarf2

----- k Waerkplane
-l Block
----- U Tool

----- 2, Machine tool

..... 3% Stock engagement
211} Swarf finishing

: & Position

75 Gouge avoidance
=

= High speed

T8 Automatic verification
..... 3 Point distribution

..... 1% Tool axis

..... # Machine axis control
@-=1 Rapid Moves

-1 Leads and links

d‘_f Start point
i Uy e

”~

[Multi ple cuts

[ Maximum number of cuts

Maximum stepdown

%[0 |

Mode | Merge

Order by | Region

=~
{ < <

Upper limit | Top

Wiorkplane

15 Select the Tool Axis page and use the default, Tool axis - Automatic.

P Swarf Finishing

? X

1 Toclpath name |D12TR1—Swarf2

B Stock engagement
[—j--&\_ll Swarf finishing

~ Position
E Gouge avoidance
Multiple cuts
High speed

=

.4 Point distribution

) "
A Tool axis

-.{#) Machine axis control

lé ‘.IB".lrorl;:(pIane ~ [TDD' axis ]
oc

U Tool Tool axis

ot Limit

16 Select Calculate at the bottom of the dialog to create the toolpath.

6 -4 Autodesk PowerMill 2017

Copyright © Autodesk



{\ AUTODESK.

6. Five Axis Swarf Machining

17 Open the Leads and links dialog via the icon m and Apply the following

settings:
Lead in/out: Surface normal arc - Distance 0 - Angle 90 - Radius 5.0
Links: 1st/2nd choice - Skim Default - Incremental

The new Swarf Finishing strategy steps down the selected surfaces while
merging the stepover between the Upper and Lower contours.

Exercise
1 Create a Dia 10 End Mill (EM10).

2 Create a Copy of the original, single pass, Swarf Finishing strategy to create a
new toolpath aligned to the underside of the undercut recess on the outer
sidewall.

3 Deselect the local surfaces, Simulate the resultant toolpath and observe the
changing angle of the tool as it Swarf machines the selected surface.

4 Select File > Save Project As:
.....COURSEWORK\PowerMill-Projects\Swarf-Example

5 Select File > Delete All and Tools > Reset Forms.
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Swarf Finishing - Example 2
1 Open the Project (created earlier):
«...COURSEWORK\PowerMill-Projects\3Plus2-EX1

Activate the Dia 10 tiprad 1 tool (D10T1).
Activate the workplane - ztop175_A.
Make sure that no Boundary is Active.

a A ODN

Open the Block dialog and select the option Defined by - Cylinder before
selecting Calculate (A cylindrical Block to the Model dimensions will be

created).
P Block ? b
Defined by
[ Cylinder ~] H 52| &8 =
Coordinate System
| Active Workplane R |
Limits
Centre X Centre ¥
[oo00s20 | Bg| [-0.00m47] (G5
Diameter Inner Diameter
[17460261 Bg [00 | &
Min Max Length
[(7s0 | &g [ozsee3] (B [17a74673] (B
Estimate limits

Tolerance Expansion Type
L] oo
[JInclude reference surfaces Calculate

[ Draw Opacity [ |

Accept Cancel

6 Open the Rapid Move Heights dialog and set Safe area Cylinder and enter
data into the dialog exactly as shown below, before selecting Calculate.

P Toolpath connections % 7 b4

Safearea Moves and clearances Start and end point Lead ins Lead outs Links  Point distribution

Safe area Calculate dimensions
Type | Cylinder v Measured from | Block and Model v]
Workplane | Toolpath workplane ~ Rapid clearance
Position Plunge clearance
[-o.000045 | [-0.000112 | [-185.0 |
Direction
o J[ [

Rapid radius | 97.301948
Plunge radius | 92.301948
Polygonisation tolerance

= Input the Workplane ztop-175_A and set a Direction (vector) 0 0 1

The use of Safe area - Cylinder will produce smoother link moves around the
cylindrical form instead of point to point, linear moves.
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7 Set both Lead in/out to Surface normal arc with Angle 90 and Radius 4.

8 Select all three sidewall surfaces for the three pockets.

9 Select Toolpath Strategies @ and select the Finishing option located in the
Strategy Selector dialog.

10 Enter the values into the pages of the Swarf Finishing dialog exactly as shown.

P Swarf Finishing

? X

Toolpath name | D10TR1-FinPkts

y;, Workplane

-l Block

U Tool

2, Machine tool
o Limnit
3 Stock engagement

-6\ EEIEmT

g Position

-5 Multiple cuts

= High speed

75 Gouge avoidance

2 [Swarf finishing

Drive curve

Minimum fanning distance

Fan at end on planes []

Reverse axis[_|

Follow surface laterals [

% Automatic verification
..... \\.s Paint distribution
..... 1 Tool axis
..... # Machine axis control
[j--;f Rapid Mowves
w17 Leads and links
-4 Start point

Surface joining tolerance

Gouge avoidance

- End point
G-fr Feeds and speeds
""" ;3 History Tolerance
----- Motes and Description
= 0.03
----- 2. Llcer defined settinns it
Thickness

iy

0

i

Gouge check [+]

Degouge tolerance

Cut direction

i
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P Swarf Finishing

Toolpath name | D10TR1-FinPkts

IL‘ Workplane
-4l Block
U Tool

--f2, Machine tool

g8 Limit

.3 Stock engagement

[—]--m Swarf finishing
g’ Position

7 Gouge avoidance

=

ﬁ? High speed

% Automatic verification
.4 Point distribution

E Tool axis

.. Machine axis control
G-=1 Rapid Moves

[j]l Leads and links

ﬁ Start point

~

(I.V'Iulltiple cuts

Mode | Merge
Order by | Region

Upper limit | Top

-3
E £ o <

Wiorkplane

Offset

[ Maximum number of cuts
10

Maximum stepdown

= Mode - Merge provides continuous tool tracks as variable offsets between
the upper and lower edges of the swarfable, surfaces.

= Use: Maximum stepdown 1.0

B,

& The default Tool Axis setting for Swarf Finishing is Automatic.

11 Select Calculate to process the Toolpath.

Note the link moves follow a cylindrical path as defined in the Rapid Move
Heights dialog. This will provide both smoother tool link and re-orientation
moves between separate machining areas.

12 Simulate the toolpath (D10TR1-FinPkts) and observe the changing angle of
the tool as it Swarf machines the selected surfaces.

13 Select File > Save Project to update:
.....COURSEWORK\PowerMill-Projects\3+2example
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Swarf Finishing - Example 3

There are situations where swarfable surfaces do not provide an acceptable tool
alignment around the component form. In these cases the only obvious solution is
to use a separate CAD package (eg PowerSHAPE) to re-model the affected
surfaces.

In the following example a Swarf Finishing strategy will be applied on 5 selected
surfaces (As shown, shaded pale blue in the following illustration). Due to the way
the Surfaces have been designed the resultant toolpath will not produce an
acceptable tool track along the existing form. To fix this a new *fit for purpose’
surface model of the swarfable face will be imported and used to produce a much
improved Swarf Finishing toolpath.

1 Select File > Delete All and Tools > Reset forms.
2 Select File > Import Model:
..\PowerMill_Data\five_axis\swarf mc\SwarfSurfModel-A.dgk

3 Select File > Save Project As:
.....COURSEWORK\PowerMill-Projects\SwarfSurf-EX3

4 Activate the Workplane TopCentre.
Calculate a Block, Defined by - Box and using Type - Model.

Still in the Block dialog, Lock the Z values, input an expansion 10, and
Calculate again,

7 Create a Dia 12 End Mill (named EM12).
Calculate the Rapid Move Heights.
Set the Start Point to First Point Safe and End Point to Last Point Safe.

10 Set both the Lead in and Lead out to Surface normal arc with Angle 90 and
radius 6.

11 Select the 5 Surfaces required to be Swarf machined as shown pale blue in
the above illustration.

Copyright © Autodesk Autodesk PowerMill 2017 6-9
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12 Select Toolpath Strategies @
the Strategy Selector dialog.

and select the Finishing option located in

13 Enter the values into the main page of the Swarf Finishing dialog exactly as

shown.
P Swarf Finishing ? b
1 Toolpath name |EM1?_-Swarf-1 |
- 12, Workplane s [Swarf finishing }
il Block
|_| Tool Drive curve

9 Limit Radial offset [00 |

-3 Stock engagement
E—J--m Minimum fanning distance

g Position
77 Gouge avoidance Fan at end on planes[/]
= Multiple cuts Reverse axis[ ]
= High speed

T Automatic verification
~.#% Point distribution

E Tool axis

(g Machine axis control

[ g‘f Rapid Mowves

[ ]E Leads and links

Follow surface laterals[_]

Surface joining tolerance
0

i

Gouge aveidance

ﬁ Start point Gouge check [+]
e‘f End point Degouge tolerance
[]—--ﬁr Feeds and speeds
E? History Tolerance Cut direction
Notes and Description :
.2 User defined =ettinas i i

Thickness

.0 0

Preview | []Draw

Calculate Queue . OK Cancel

14 Select the Position page and input Offset -1.0

warf Finishin 7
P Swarf Finishing ? b
] Toolpath narme | EMI12-Swarf-1 |
""" J, Workplane = [Position 1
-l Block
----- |_| Tool
----- I, Machine tool Lower limit

-----

----- 3 Stock engagement
-8 Swarf finishing Wiorkplane

Oftee

--#75 Gouge avoidance

[ R P

15 Select Calculate to process the toolpath.
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16 Run a slow I Simulation and observe the changes in tool
alignment as it runs along the tool track.

The Swarf Finishing toolpath visually looks okay at first until it is run through a
simulation. This reveals that the Tool (EM12) is running at an acute angle
relative to the swarfable surfaces in some areas (as shown in the above
illustration). Also, the cutter closely follows the lower edge, causing it to
suddenly drop and lift while running around the step.

This strategy can be improved by using different Surfaces that are specifically
designed to provide a better tool alignment during Swarf Finishing.

The original 5 reference Surfaces used in the toolpath EM12-Swarf-1 are as
shown above. These will be replaced by new Surfaces of exactly the same
shape within the original model area, but designed specifically to work more
effectively with the Swarf Finishing strategy.

17 Select File > Import Model:
....\PowerMill_Data\five_axis\Swarf_mc\NewSwarfSurf-B.dgk
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6. Five Axis Swarf Machining

The new Surfaces are designed with surface curves aligned to match the
required tool alignment. It is also exactly the same shape as the 5 surfaces
used in the original Swarf Finishing toolpath. Compared with the original 5
surfaces, the lower edge has been extended with a smooth transition

constructed along the lower edge of the form.

& Do Not delete the 5 surfaces used in the original Swarf Finishing
strategy. They are still required for accurate gouge checking.

18 Right mouse click on the toolpath EM12-Swarf-1 and from the local menu

select Settings to open the strategy dialog.

19 In the Swarf Finishing dialog select the option, make a Copy .

20 Select the new, imported reference surfaces.

21 In the main Swarf finishing page, tick the box Follow surface laterals to

force the tool align to the actual surface curves.

P Swarf Finishing

Toolpath name | EM12-Swarf-1_1

Ly ? x

----- T;. Workplane

-l Block
----- |_| Tool

..... 2, Machine tool

----- :'_F Stock engagement

o€ BT

----- g Position

1 Multiple cuts
= High speed

. W TG PR | EPARE [ S,

5 Gouge avoidance

"~

------ % Autematic verification

[Swarf finishing

Surface side | Qutside V|

Radial offset [ 0.0 |

Minimum fanning distance

Fan at end on planes []

axis [
Follow surface laterals [~]

22 Select Calculate to process the new toolpath (EM12-Swarf-1_1).

23 Run a slow I

Simulation and observe the changes in tool
alignment as it runs along the tool track.

6 - 12 Autodesk PowerMill 2017
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This time the Tool is more suitably aligned to the swarfable surface as it runs
along the Toolpath (EM12-Swarf-1_1).

24 Select File > Save Project to update:
.....COURSEWORK\PowerMill-Projects\SwarfSurf-EX3
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Swarf Finishing - Example 4

In the following example a Swarf Finishing strategy will be applied to trim the
edges of an angled plate. Due to the way the original edge Surfaces have been
designed the tool is unable to maintain a suitable alignment to the model form. To
fix this a different set of swarfable edges will be used instead to produce a much
improved Swarf Finishing toolpath. These surfaces have been created using
PowerSHAPE.

1 Select File > Delete All and Tools > Reset forms.
2 Select File > Open Project:-
....\PowerMill_Data\five_axis\swarf mc\AnglePlate4-Swarf-Start

3 Select File > Save Project As:
.....COURSEWORK\PowerMill-Projects\ AnglePlate4-Swarf-EX1

4 Activate the existing drilling Toolpath Drill20-Thro.

From the Main toolbar select Block. @

In the Block dialog select Defined by Triangles with the Coordinate System
set to Global Transform.

P Block

Defined by

|Triang|es V| 3@. i:% G
]

g

*

Coordinate System

| Glabal Transform

7 Select the Load block from file option. @
8 In the Open Block from Triangles dialog and select the file:-
....\PowerMill_Data\five_axis\swarf_mc\AnglePlate4-Material.dmt
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9 Select Accept to close the dialog.

10 Right mouse click on the toolpath Drill20 and from the local menu select
Simulate from Start.

11 Ensure that the ViewMILL toolbar is displayed and click the Red button (will
change to Green) to connect it to the simulation.

12 Run a ViewMILL simulation on the 2 existing drilling toolpaths Drill20-Thro
and EM16-Dia24_Helical.

9|

13 Save the ViewMILL session gl at this stage, put it on suspend , and

select the No image ‘ option.

14 Activate the tool EM10.

15 In the Leads and Links dialog set both Lead in and Lead out to Vertical arc
with Angle 90 and Radius 5.
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16 In the PowerMill explorer, Levels and Sets folder, right mouse click on the
Set OriginalEdges and from the local menu click on Select Surfaces.

17 From Toolpath Strategies @ , select the Finishing option located in the
Strategy Selector dialog.

18 Select Swarf fininshing and enter the values into the pages of the dialog
exactly as shown below.

P Swarf Finishing

? X

Toolpath name | EM10-TrimEdges-FIN1

P Swarf Finishing

% :‘Ir”'tp'a”e c [Swarf finishing
oc
|_| Teol Dirive curve
I8, Machine tool Surface side | Outside v|
k8 Limnit .
Radial offset
B Stack engagement
E'Jm Swarf finishing Minimum fanning distance
e 27 Position
Y
75 Gouge avoidance Fan at end on planes ]
‘= Multiple cuts Reverse axis[_]
F High speed Follow surface laterals []
Ta Autornatic verification
\:“ _I?—mnlt det”bUtmn Surface joining tolerance
-1, Tool axis
-{# Machine axis control
[j--g‘ji Rapid Mowves ]
-1 7/ Leads and links Setge denkdnLe
] Start point Gouge check []
g End point Degouge tolerance
[j---ﬁr Feeds and speeds
g —?:'11 History Telerance Cut direction
MNotes and Description z
=) 0.02 Climb ~
.. User defined settinns et | iy |
Thickness

Toolpath name ‘ EM10-TrimEdges-FIN1

----- 1{, Workplane
-l Block
----- |_| Tool

..... £, Machine tool

..... o8 Limit

..... 3 Stock engagement
=) Swarf finishing

g osition

£ Gouge avoidance

= RA il ke

]

[Pusition

Lower limit

Base position | Bottom V|

Ottt

19 Select Calculate to process the toolpath and then Close the dialog.
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20 Run a toolpath simulation and observe the alignment of the tool as it tracks
along the selected surfaces.

Due to the component edges being planer the alignment of the EM12 tool is not
compelled to remain Normal to the main Angle Plate surfaces. In the above image
the tool has remained cranked over after tracking around a curve in the edge form.
There are too many choices for the cutter to use a linear alignment across the
swarfable surfaces.

21 Right mouse click on the toolpath and from the local menu select Settings.

22 Select the option to Recycle @ the toolpath.
23 In the Swarf finishing page tick the box Follow surface laterals.

P Swarf Finishing ? o

Toolpath name | EM10-TrimEdges-FIN |

I.; ‘;‘-lfortplaﬂe ~ {Swarf finishing }

..... |_| Tool Drrive curve
----- [E Machine tool Surface side | Qutside v|

..... o Limit Radial offset [ 00 |

----- 3" Stock engagement
SR §\] Swarf finishing Minimum fanning distance -m
i = Position ]
Y

£5 Gouge avoidance
= Multiple cuts Reverse axis [ |
F High speed Follow surface laterals [+]

... Ty Automatic verification
M Drint Adictributinn

Fan at end on planes [+]

24 In the PowerMill explorer, Levels and Sets folder, right mouse click on the
Level NewEdges and from the local menu click on Select Surfaces.

25 Calculate the updated Swarf finishing strategy.
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This time the tool is aligned to the laterals of the replacement swarfable surfaces.
These have been re-designed using PowerSHAPE surface modelling to produce the
above tool alignment.

26 Reconnect the existing ViewMILL session and simulate the latest Swarf
finishing strategy.

27 Select File - Save Project.
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Wireframe Swarf Finishing

In some cases imported surfaces to be used in Swarf Machining could be of a
poor quality. This would typically include such problems as mis-matching edges
and/or un-intentional curves across the surfaces. These problems will
undoubtedly result in part or complete failure to create a Swarf Finishing strategy.

One solution is to re-model the affected Surfaces (assuming the user has access to
a suitable CAD system (eg PowerSHAPE)).

The other alternative is to create 2 separate Patterns that define both edges
running along the area to be swarf machined. The user can then use the
Wireframe Swarf Finishing strategy.

The model used in the following example contains a pocket in which part of the
sidewall is un-swarfable due to being slightly convex between the top and bottom
edges.

1 Select File > Delete All and Tools > Reset Forms.
2 Import the Model:
....\PowerMill_Data\five_axis\swarf_mc\Wfrm-Swarf.dgk

3 Select File > Save Project As:
«...COURSEWORK\PowerMill-Projects\Wframe-Swarf

Activate the Workplane named Datum.

Calculate a Block using Defined by - Box and Type - Model.
6 Create a Dia 5 End Mill (EM5) using the following dimensions:

Tool Dia5 Length 35

Shank Lower Dia 5 Upper Dia 5 Length 25

Holder-1 Lower Dia 15 Upper Dia 25 Length 15

Holder-2 Lower Dia 25 Upper Dia 25 Length 15

Overhang 50

7 Calculate the Rapid Move Heights.
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8 Select the sidewall surfaces on each of the 3 pockets in the component.

9 Select Toolpath strategies @ and from the Finishing tab select the Swarf

Finishing option.

10 Enter the values into the 2 pages of the Swarf Finishing dialog exactly as

shown.

: P SwarfFi

Toclpath name | EM3-5SwarfPkts

----- I.f, Workplane
g Block
----- |_| Tool

..... =, Machine tool

..... & Limit

..... 37 Stock engagement
[_j..m Swarf finishing
-.% Position

&= Multiple cuts
ﬁ:’ High speed

..... < Point distribution

----- E Tool axis

----- @ Machine axis control
[]--gf Rapid Moves

-] Leads and links
ﬁ Start peint

@1 End point

G-fir Feeds and speeds

----- & History

75 Gouge avoidance

il

----- ] Motes and Description
.2 User defined settinns

{Swarf finishing

Calculate

Drive curve

Minimum fanning distance
Fan at end on planes [v]
Reverse axis [

Follow surface laterals[ ]

Surface joining tolerance
0

i

Gouge avoidance
Gouge check []

Degouge tolerance

Cut direction
Climb

Tolerance
0.02

Thickness

Ky

= I

Preview

[ Draw

Queue [ ok Cancel
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P Swarf Finishing

Toolpath name

----- k Workplane ~
-l Block

..... £ Point distribution

----- E Tool axis

0-=1 Rapid Moves
]II! Leads and links
d Start point

= R

£} Swarf finishing

u Tool

2, Machine tool

3 Stock engagement

£ Gouge avoidance

=4 Multiple cuts
[F High speed
T Automatic verification

# Machine axis control

EM3-5SwarfPkts

[ Maximum number of cuts

Maximum stepdown

P2l

= Mode - Merge and Max Stepdown -3.0

11 Calculate the toolpath.

ontry
“Workplane
Offset

10

The Swarf Finishing strategy has failed to machine one of the selected
surfaces due to part of the sidewall being un-swarfable.

Copyright © Autodesk
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On closer inspection it is evident that some of the curves linking across the
sidewall surface are convex and as a result make this area un-swarfable.

This problem will be fixed by creating separate Patterns along the upper and
lower edges of the sidewall surface of the affected pocket. The 2 Patterns will
then be used in a Wireframe Swarf Finishing strategy.

12 Select the Surface defining the angled sidewall of the left hand pocket (shown
above).

13 Create a Pattern named Upper and right-click over it in the PowerMill
explorer selecting Insert > Model from the local menu.

14 Select the lower Pattern segment.

15 Right-click on the Pattern named Upper and from the local menu, select the
option Edit - Copy Pattern (selected only).

16 Rename the new, copied Pattern as Lower.
17 Select and Delete the lower segment from the Pattern named Upper.

[

&  For Wireframe Swarf Finishing to function correctly the two Patterns must
travel in the same direction.

It is not compulsory to align the start points on the upper and lower
Patterns. It is the first point on the lower Pattern that defines the start
position of the resultant toolpath.
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18 To identify whether the two Patterns are suitable for use, right click each one in
turn and select Instrument to display the start point and direction.

&  As can be clearly seen the two segments travel in opposite directions
creating the need for one to be reversed.

In this case, to create a Climb milling strategy, the lower segment must
be reversed.

19 Select the lower Pattern segment and right mouse click on it to open the local
menu.

20 From the local menu, select Edit > Reverse Selected.

21 Select the Toolpath Strategies g and from the Strategy Selector >
Finishing options, select Wireframe Swarf Finishing.

22 Enter the values into the dialog exactly as shown below:
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P Wireframe Swarf Finishing ? =
3 Toolpath name | EM3-WireframeSwarfPlkt1 |
""" 12, Workplane < [Wireframe swarf finishing ]
-l Block
----- |_| Tool Drive curve
----- 2, Machine tool Top pattern
----- o Limit - z
..... 3 Stock engagement ﬁ o = m m é"}
[—jé'j Wireframe swarf finishing Bottom pattern
-~ Position
ey B
75 Gouge avoidance ﬁ Lower B E”f m C:I'}

== Multiple cuts
= High speed

..... 3 Point distribution

----- E Tool axis

----- # Machine axis control
D..gf Rapid Mowves

-1 U] Leads and links

ﬁ"f Start point

é’_f End point

[-fr Feeds and speeds

----- & History

----- | MNotes and Description

.8 User defined cettinas ™

{l

Wireframe side

Left

I

Angular rulings tolerance | 2

Minimum fanning distance

Radial offset

Gouge avoidance

Tolerance

Fan at end on planes [/]

Gouge check []

Degouge tolerance

Cut directicn

1
23 Select Component Thickness to open the following dialog.

24 Select both the sidewall and fillet surface (flanked by the Patterns) and acquire
them to a selected row (with the Machining Mode set to Ignore) in the

Component Thickness dialog.

P Component Thickness

Surfaces Verification Surface Defaults

Entity

Machining Mode

Ignare w

Clone

HE& @ @ % [JUse Axial Thickness

Thickness

gl
&
&

et Mode Thickness  Axial
30 Machine 0

@n Ignere

0
32 Machine 0
33 Machine 0

Total Thickness  Total Axial

0 -

0
0 -
0

25 Apply the Component Thickness dialog.

3

0
0
0
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P Wireframe Swarf Finishing

Toclpath name | EM3-WireframeSwarfPkt1

12, Workplane

- fll Block
|_| Tool

B, Machine tool

gl Lirnit

B Stock engagement
[—jé‘_\ Wireframe swarf finishing
----- ~ Position

..#% Gouge avoidance

o [JF High speed

i T Automatic verification
- Point distribution

}_’: Tool axis

@ Machine axis control
[j--;.'? Rapid Moves

E:I'"]:ri..- Leads and links

- Start point

y

[Multiple cuts

Mode | Merge

Order b}-’ | Region

Upper limit |Top

Offet

] Maximum number of cuts

Maximum stepdown

Bl 30 |

26 Calculate the Wireframe Swarf Finishing strategy.

The new Wireframe swarf finishing strategy has successfully been applied

between the Upper and Lower Patterns.

27 Select File > Save Project to update the Project:
... \.COURSEWORK\PowerMill-Projects\Wframe-Swarf
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Swarfable Surface Design

When designing a component certain factors will dictate how successfully a Swarf
finishing strategy can be applied to what appear to be visibly suitable surfaces.
The fundamental rule is that Swarf finishing will only occur where the side of the
tool can be in full contact from one side of a surface to the other (Linear). This
works fine if the swarfable surfaces are twisting and turning and the tool is able to
find a specific linear alignment at all times. If however a surface is totally planer
then the linear tool alignment can occur at any angle across the swarfable edges.

S

A tick box option exists in the strategy to force the tool to Follow surface
laterals (natural surface curves). For this to work it is likely that the existing planer
swarfable surfaces will need to be re-modelled. This task has to be done using a
suitable CAD software such as PowerSHAPE.

—T= 1~

/,

The above planer surface has been designed with the laterals aligned to match the
required tool axis. The initial angular move is the required transition to or from the
end of another selected swarfable surface.
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7. Flowline Finishing

Flowline Finishing

Flowline Finishing is designed to machine multiple surfaces. The strategy uses 2
drive curves and either 1 (closed form) or 2 (open form) end curves to define a
virtual surface area. Intermediate drive curves can be added to further control the
flowline shape. This strategy provides evenly spaced tool passes, irrespective of the
underlying geometry.

Advantages over existing toolpaths include:

= Multiple surfaces can be machined.

= Machining of undercut regions is possible.

= The toolpath passes are not determined by the surface parameterisation.

= The region being machined is not forced to be an entire surface or parametric
box.

= The stepover is defined in 3D, giving total control over the maximum value.

Flowline Finishing Example

1 Select File > Delete All followed by Tools > Reset Forms.
2 Open the Project:

...\PowerMill_Data\five axis\Flowline\Flowline EX4-Start

3 Select File > Save Project As:
.....COURSEWORK\PowerMill-Projects\Flowline-EX4
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Activate the Workplane MC-Datum.

Activate the BN12 tool.

Calculate a Block Using Defined by Box and Type Model.
Calculate the Rapid Move Heights using the default settings.

0 N o o

Select the following 5 surfaces and Blank the rest (Ctrl K).

“Le

A

9 Display the Model as Wireframe only.

10 Create a new (empty) Pattern 1.
2-£f Patterns
P gi3=1

11 With the above Surfaces selected, Right click on the Pattern and from the local
menu select Insert - Model.

& A Pattern extracted from a selection of surfaces will automatically become
Embedded (Inherits the surface normals etc).

B,

& The Pattern symbol changes to identify it as being Embedded.
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12 Right click on the Pattern and from the local menu select Curve Editor.

13 Select the Composite Curve option from the Curve Editor toolbar.
|$$ X, f}‘ m | T

ol

14 With the Create Composite Curve toolbar open click near to the upper end of
the first surface lateral (As shown arrowed below).

15 In the toolbar select the red disc followed by the green tick to both accept
the new segment and close the toolbar.

The new Embedded Pattern (1) is now made up of 3 segments (2 closed and 1
open).
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16 From Toolpath Strategies @ open the Finishing options and from the
dialog select Flowline Finishing.

17 Enter data into the main page exactly as shown below.

P Flowline Finishing ? x

] Toolpath name |Bn12-FIowIine-FIN1 |

----- 1& Warkplane
-l Block

----- I Tool Curves definition

----- [, Machinetool Ermnbedded pattern

----- ¥ Limit ~ =

..... 3 Stock engagement m 1 }:‘g m * g
T Automatic verification Status I‘/alld
..... « Paint distribution
----- & Tool axis

----- @ Machine axis control Sequence | Slone v|
[j--g’f Rapid Moves
-7 Leads and links
é‘f Start point

@i End point

[j---ﬁ'_r Feeds and speeds

[Flowline finishing ]

Ordering |Twc1 way v|

Surface joining tolerance | 0.3 |

----- ] MNotes and Description

£ ! | Tolerance | 0.02 |
----- &= User defined settings

Thickness

iy &
Stepowver
PN

18 Still on the main page select the Interactively select pattern segments for

the strategy options. @

P Flowline Curve Definition: Step 5 of 5 ? X

v" Start drive curve selected
{ End drive curve selected

( 1 limit curve selected

( Mo intermediate drive curves selected

Curve configuration

= g ¥ X

Reset Finish Cancel

The options in the above form enable the toolpath ordering, directions, etc to be
controlled before the toolpath is calculated. However, no changes are required in
this instance.
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19 Select the Tool axis page and select the Lead/Lean option with both the Lead
and Lean angles as 0.

P Flowline Finishing ? X
EE}J Toolpath name | En12-Flowline-FIN1 |
12, Workplane ool axis
-l Block
U Tool Tool axis
-2, Machine tocl | Lead/Lean V|
ol Limit Lead/Lean angles
-3 Stock engagement Lead Fean
=8 Flowline finishing
... Wy Autornatic verification
-4 Point distribution
E Mode | Contact normal w |
@ Machine axis control

20 Select Calculate to create the following Flowline Finishing toolpath.
Y

-l;ﬁ

If the Flowline Finishing toolpath should fail to calculate try to Embed

the Pattern again using Closest point with Distance 0.1 and
Tolerance 0.01

Y
& For visual reasons the above toolpath has been created with a 2mm
stepover.

21 Right mouse click on the toolpath BN12-Flowline-FIN1 and from the local
menu select Simulate from Start.

22 From the Simulation toolbar select Play |£| and observe the Flowline
Finishing process.

23 Select File - Save Project.

24 Select File - Delete All and Tools - Reset Forms.
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Exercise

The purpose of this exercise is to create a suitable Embedded Pattern and use
Five Axis - Flowline Finishing to machine the fillet surfaces running around the
upper edge of a component model form.

a A single segment, Embedded Pattern will be directly created along the
edges of the fillet surfaces.

b The Embedded Pattern will then be split into 4 suitable segments using the
Curve Editor options.

¢ The user will then be asked to create a suitable Flowline Finishing strategy
using the Embedded Pattern.

1 Import the Model:-
....\PowerMill_Data\Models\Vortex2.dgk

2 Select File > Save Project As:
+\COURSEWORK\PowerMill-Projects\FlowLineFillet-EX1

3 Select the whole of the Model and the select Create and Orientate
Workplane - Workplane at Top of Selection.

Activate the new Workplane.

Create a Dia 8 - Ball Nose Tool, named BNS8.

Create a Block using Defined by Box and Type Model.
Calculate the Rapid Move Heights using the default settings.

0o N o o »

Select all of the Surfaces that define the fillet along the upper edge of the main
3D form (As shown below).
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10

11
12

13

14

In the PowerMill explorer right mouse click on Patterns and from the local
menu select Create Pattern.

From the same menu select Insert - Model.

=& This will automatically become an Embedded Pattern as it inherits the
required data from the edges of the selected Surfaces.
Bﬁ Patterns
L @1

Select and Blank the whole of the Model and Un-draw the Tool and Block.

Right mouse click on the Embedded Pattern and from the local menu select
Curve Editor.

Use Cut item to break the Pattern into separate segments at the four corners
of the fillet form.

FIREZEA /OB ES ¥ %N -

¥ Cut item

[ 9

& Inthis example the Embedded Pattern must consist of 4 segments that
specifically define the 2 ends and 2 sides of the enclosed fillet.

If any of the drive or end curves contain multiple segments, select them and use
Merge to reduce them to a single segment.

;C'S‘B %Asggcﬁfzﬁaﬁ&@@f QQN“@A(J

Merge Selected
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7. Flowline Finishing

15 Accept the changes (Green tick) and return the Embedded Pattern from the
Curve Editor.

16 Use the (4 segment) Embedded Pattern in a Flowline Finishing strategy to
five axis machine (Tool Axis - Lead/Lean 0 using Mode - Contact normal)
the enclosed surfaces of the fillet form.

17 Use the options in Interactively select pattern segments for the strategy
to control the required toolpath order and direction.

Curves definition
Embedded pattern

pIE 4HHE@

hirza

P Flowline Curve Definition: Step 5 of 5 ? X

{ Start drive curve selected

f End drive curve selected

f 2 limit curves selected

f Mo intermediate drive curves selected

Curve configuration

» 8 B EHE ®

Reset | Finish | | Cancel

18 Select File > Save Project As:
..\COURSEWORK\PowerMill-Projects\FlowLineFillet-EX1
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Flowline with intermediate drive curves Example
1 Select File - Delete All followed by Tools - Reset Forms.
2 Open the Project:

...\PowerMill_Data\five axis\Flowline\FlowLine-ExtraDriveCurves-Start

3 Select File - Save Project As:
«..\COURSEWORK\PowerMill-Projects\Flowline WithExtraDriveCurves

T

4 Select an ISO 1 view. A
5 Activate the toolpath BN16-Flowline-4Curves-All.
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Note that this basic 4 segment, Flowline toolpath does not follow the intermediate
flowlines of the variable fillet within the model form.

L]

=1

= = J'.
= - e e Tl

= T Ty T

This can be changed if intermediate drive curves are included in the Embedded
Pattern.

P o S &

6 Right mouse click on the active toolpath BN16-Flowline-4Curves-All and from
the local menu select Settings to open the Flowline Finishing dialog.

7 Select the Copy toolpath option and then rename the new toolpath as
BN16-LH-Flowline-ExtraCurves.

8 In Curves definition, change the selected Embedded pattern to 9Segment.

P Flowline Finishing 7 x

E;f) Toolpath name ‘BN1E—LH—FIowIine—E:ctraCurves

12, Workplane

-l Block

U Teool

[, Machine tocl
k8 Limit

-3 Stock engagement

(=%-=4 Flowline finishing

------ TR Automatic verification
-4 Point distribution

) R =3
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9 Select Interactively select pattern segments for the strategy. @

Start drive curve selected

End drive curve selected

2 limit curves selected

< < <<

Mo intermediate drive curves selected

Curve configuration

> & E H K

Previous Finish Cancel

10 Select the Reset button to clear the default, segment selection.

= ?( Select start drive curve

Curve configuration

Reset Previous Mext Cancel

11 Select the upper central curve as the start drive curve (green)
12 Select the bottom left curve as the end drive curve (red).

13 Shift — select the 2 end curves (blue).

14 Shift select the 2 nearest intermediate curves (purple).

P

{ Start drive curve selected
( End drive curve selected
v’ 2 limit curves selected

2 intermediate drive curves selected

Curve configuration

Reset Previous Next Cancel

15 Select the Next button to return to the full preview stage.
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P Flowline Curve Definition: Step 5 of 5 ? X

( Start drive curve selected
( End drive curve selected

( 2 limit curves selected

( No intermediate drive curves selected

Curve configuration

> B8 8 ¥ &

Reset :Prwinus; Cancel

16 Select the Finish button to return to the main Flowline finishing dialog.
17 Select Calculate to generate the new toolpath then select Close.

Note that this 6 segment, Flowline toolpath follows the intermediate flowlines of
the variable fillet within the model form.

Exercise

18 Create a Copy of the above toolpath named BN16-RH-Flowline-ExtraCurves
and modify to machine the RH side of the component form.

19 Select File - Save Project.
20 Select File - Delete All and Tools - Reset Forms.
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8. Auto Collision
Avoidance

Introduction

Automatic Collision Avoidance can be applied to Vertical alignment operations
in cases where the Shank would otherwise be rubbing on a sidewall and\or the
Holder would clash with the component. If parts of the component still cannot be
machined without a tool collision occurring then these areas will not be included as

part of the toolpath. Note: Automatic Collision Avoidance is not applicable to
Swarf Finishing.

1 Open the Project:
...\PowerMill_Data\five_axis\CollisionAvoidance\AutoCollisionAvoidl_Start

2 Select File > Save Project as:

+\COURSEWORK\PowerMill-Projects\AutoCollisionAvoid_1
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The Project contains 3 toolpaths all of which have had Collision Checking applied
with Shank and Holder clearances values of 1 and 2 respectively.

-8 Toolpaths

2@
- w-@ ¢ 8 BN5-Walls-fin1
w-@ ¢ & BN5-Floor-fin2

The Area Clearance strategy is Gouge and Collision safe while the two 3D

Offset finishing strategies although Gouge free are not Collision safe relative to
the Shank and Holder.

3 In the PowerMill explorer, activate the toolpath BN5-Walls-fin1.

4 Right mouse click on the toolpath BN5-Walls-finl and from the local menu
select Settings.

5 Select Recycle
Axis page.

in the 3D Offset Finishing dialog and select the Tool

& Note that the selected Tool Axis option is Vertical.

P 3D Offset Finishing ? *
Toolpath name | BM35-Walls-fin1 |
..... l& Workplane [T[)D‘l axis ]
il Block
..... |‘_J| Teol Tool axis
----- 2, Machine tool |‘u’ertica| ~
----- o8 Limit
----- 3" Stock engagement
£ 3D offset finishing
.. Ty Automatic verification
----- #» Point distributicn
8 Tool o
----- # Machine axis control
[]—-"j Rapid Moves
-7 Leads and links Fixed angle
i Start point | MNone v 90.0
%‘f End point
- Feeds and speeds Rotary axis configuration
..... & History |Tno|path
----- | Motes and Description
..... & User defined settings i
i. Automatic collision avoidance >
[ | Tool a:is smaothing
[] Draw tool axis

Calculate

Queue oK Cancel
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6 Select the newly available Collision Avoidance page (Below Tool axis).

P 3D Offset Finishing ? *

FE:J Toolpath name |BN5-WaIIs—fin1 |

% ‘;'l"”tp'a”e Collision Avoidance

oc

U Tool - L

[, Machine tool Tift method | = v|

8 Limit Tool clearances

-3 Stock engagement Holder clearance

=-£3 3D offset finishing Shank clearance -m
L ﬁ Automatic verification

s Point distribution

[_]lé; Taol axic Smoothing distance _'I'EI.O
(- }f‘, Collision Avoidance

--{#) Machine axis control

= Input the Tilt method as Lean.

= Input Shank and Holder clearances of 1 and 2 along with a smoothing
distance of 10.

7 Calculate the 3D Offset Finishing toolpath.

8 Select a View from front D'/ and Simulate the toolpath to observe the
Automatic Collision Avoidance in action.
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8. Auto Collision Avoidance

9 In the PowerMill explorer, activate the toolpath BN5-Floor-fin2.

10 Right mouse click on the toolpath BN5-Floor-fin2 and from the local menu
select Settings.

11 Select Recycle g in the 3D Offset Finishing dialog and select the Tool
Axis page.

& Note that the selected Tool Axis option is Vertical.

P 3D Offset Finishing T X
Toolpath name | BM5-Floor-fin2 |
-12, Workplane [Tool axis 1
- Block
-] Tool Tool axis
[, Machine tool |Vertica| w
g8 Limit

.3 Stock engagermnent

-} 3D offset finishing

w Automatic verification
\\.- Point distribution

a1

--{#) Machine axis control
[]---.j Rapid Mowves

[j---]f.f, Leads and links Fixed angle
e‘f Start point | Mone ¥ 90.0
- End point

EJ---ﬁf Feeds and speeds Rotary axis configuration
--E History | Toclpath

‘| Motes and Description
gy User defined settings

Automatic collision avoidance
[]Tool axis smoothing

[] Draw tool axis

12 Select the Collision Avoidance page.

P 3D Offset Finishing ? x

Toolpath name | BN3-Floor-fin2 |

% :'Irmtplane [Collision Avoidance }
oc

----- |\_’| Tool _ 5

----- [ Machinetool Tilt methed | an v|

..... o Limit Tool clearances

,,,,, 3 Stock engagement Holder clearance

£1-£ 3D offset finishing Shank clearance

? -I.D
...Tg Automatic verification
..... % Point distribution
Ell‘—a- Tool axis Smoothing distance

}_,_ Collision Avoidance

----- @) Machine axis control

= Input the Tilt method as Lean.

= Input Holder and Shank clearances of 2 and 1 along with a smoothing
distance of 5.

13 Calculate the 3D Offset Finishing toolpath.
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8. Auto Collision Avoidance

14 Select a View from front d and Simulate the toolpath to observe the
Automatic Collision Avoidance in action.

Vertical tool alignment is applied as default and the Lean angle is progressively
changed as required in areas where a collision would otherwise occur.

15 Select File > Save Project.
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EXAMPLE 2

1 Select File - Delete All and Tools - Reset Forms.
2 Open the (read only) Project:
...\PowerMill_Data\five_axis\CollisionAvoidance\DashboardPanel-A1_Start

3 Select File > Save Project as:
«...\.COURSEWORK\PowerMill-Projects\Dashboard-A1_EX1

The Project contains 11 toolpaths all of which have had Collision Checking
applied with Shank and Holder clearances values of 1 and 2 respectively.

-S> Toolpaths

- 7 & DI6TR3-RGH1-OP1
- ¢ & D10TR1-RestRGH1-OP1
- 7 @ BN10-SEM1-OP1
- ¢ g BN10-FIN1-OP1

w-@ ¢ & D16TRI-RGH1-0P2
- 7 & DI0TRI-RestRGH1-0P2
- ¢ g BN10-5EM-0P2

- 7 @ BN6-FINT-OP2

- ¢ BE| BN6-Ends-FINT-OP2
w-@ ¢ B BN6-Sides-FIN1-0P2
w8 7 @& > BN3-FIN1-OP2

All have been confirmed to be safe with the exception of BN3-FIN1-OP2.

The toolpath is gouge free relative to the flutes but not collision safe relative
to the Shank and Holder.

4 Activate the 5% toolpath, D16TR3-RGH1-OP2 to reinstate the OP2 setup.
5 Select an ISO1 view.
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8. Auto Collision Avoidance

6 Run a full ViewMILL simulation on both NCPrograms OP1 and OP2.

The final toolpath BN3-FIN1-0OP2 is not currently included in the OP2
ncprogram. The above ViewMILL simulation displays the result of all toolpaths
except BN3-FIN1-OP2.

7 Put ViewMILL on suspend and return the graphics area to the PowerMill page.
0 [@

8 Activate the toolpath BN3-FIN1-OP2 and from the local menu select
Settings.

9 Select Recycle @- in the Steep and Shallow Finishing dialog and select the
Tool Axis page.

10 In the Tool axis page tick the box named Automatic collision avoidance.

- . ] Toel axis limits
# Machine axis control —+
:;-"f Rapid move heights

= T cade and linke [ Tool axis smoothing

Automatic collision avoidance
(] Draw tool axis

The Collision avoidance page appears in the local explorer.

e I_; Collision avoidance

------ @ Machine axis control

_f Rapid mowve heights

T e o il

11 Select the Collision avoidance page.

12 Set Tilt Method to Lean with a Holder clearance of 2.0, Shank clearance of
1.0, and Smoothing distance 3.0.
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P Steep and Shallow Finishing ? *

@ E_” Toolpath name [ BN3-FIN1-0P2 |

----- . Vorsin Colson Avoigance )
-l Block
----- l:] Tool .
----- 2, Machine tool [t | Lean v|
_____ o Limit Tool clearances
_____ 3 Stock engagement Holder clearance
[—]‘ Steep and shallow finishing
L.%g Automatic verification Shenlcclesrence
..... £ Point distribution L
E‘]E Tool axis Smoothing distance
NP Collision Avoidance
----- # Machine axis control

13 Select Calculate and note that the collision status of the toolpath BN3-FIN1-
OP2 (as displayed in the local explorer) changes from a Red to Blue.

14 Run a ViewMILL simulation on the toolpath BN3-FIN1-OP2.

If a potential collision situation is encountered the tool automatically leans away
from the wall (as shown in the above image).

15 Save the Project.
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9. Tool Axis Limits

Introduction

It is possible to control the rotary Tool axis limits of a machine tool within
PowerMill. This enables the rotary working envelope of a specific machine not to
be exceeded when creating multi-axis toolpaths. The angular limits are defined in
terms of Azimuth and Elevation angles.

Azimuth and Elevation

The Azimuth is the angle from X 0° anticlockwise around the XY plane. The
Elevation is the angle that is lifted upwards (+90°) or downwards (-90°) from the
XY plane.

The Tool Axis Limits dialog is accessed from within the Tool Axis direction dialog.
Tool Axis Limits are accessible if the Tool Axis box is ticked. This tick box will not
be available if the Tool axis is set to Vertical or Fixed Direction.

P Tool Axis ? > P Tool Axis ? >
Smecthing Machine axis control Smoothing Mzchine axs control
Definition Limits g Collision avoidance Definition Limits Collision avoidence
Tool axis Mode [Remove wolpath

~
Leadl/Lean angles [[] Use machine tool wher possible G
Lead Lean Orientation | Manual ~]
[0
Workplane -~
Mode
Angle limits

Azimuth angle
Fixed Angle Start End | 360.0
[Mene ~] fe Elevation angle
[ Toolpath

L [ Tool axis limits,
[ Autormatic collisicn avoidance

[ 7ol axis smoothing

[] Draw too! axis

[]Project to plane

w
=]

[] Draw limits

Copy from machine tool

Accept Cancel Accept Cancel
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1 Select File - Delete all and Tools - Reset Forms.

2 Open the ‘read only’ Project:
....\PowerMill_Data\five_axis\Tool_Limit\JoyStick_Start

3 Select File > Save Project As:
.....COURSEWORK\PowerMill-Projects\JoyStick-Example

4 In the graphics area, right-click on the toolpath at the underside of the sphere,
and from the local menu select, Simulate from Here.

&  Note that the tool is cranked over way beyond the rotational limits of the
machine tool and the tool holder is visibly colliding with the base form.

To further illustrate the machining process exceeding the rotary limits, the
strategy will be simulated using a DMU50 Evolution machine tool.

5 In the PowerMill explorer, right mouse click on the Toolpath BN16~-
NoToolAxisLimits and from the local menu select Simulate from Start.

This command will raise the Simulation toolbar (if it is not already open).

& BNI6-NoTooldxisli v i BN16 vy v kA b, 1 EE ~

6 In the PowerMill explorer right mouse click on Machine Tools and from the

local menu select Toolbar.
E © v | &) x

B dmusov e

A~

B

7 Select Import the Machine Tool Model |—E| and select the file:
....\PowerMill Data\Machine Data\DM U\dmu50v.mtd
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P Import Machine Tool x
Q’ Lookin: [ | | DMU Yo @ e mr
. Mame . Date modified Type Size
oy dmuSiv 24/11/2015 08:54 File folder
k= 4 5 dmusov.mtd I 07/11/2003 15:20 MTD File 4KB
e
'\1\;‘;

File name: dmuS0v mtd v| | Open |
Files of type: | Machine Tool Formats (*.mtd;* pmoptz) ~ Cancel
OB
8 Ensure the Draw\Undraw machine tool icon |-L is on to display the machine
tool model.

The current component datum (Transform) is matched to that of the Machine
Tool model (Top - Centre of Table). As a result, the base of the component is
currently embedded into the machine tool bed. To compensate for this, a new,
suitably positioned Workplane is created. This new Workplane is then used in
the Machine Tool definition toolbar.

9 Create a new Workplane named MTD-datum and move it by 2-50.

10 Input the new Workplane, MTD-datum into the Machine Tool definition
dialog.

& Itis not necessary to activate the new Workplane.

= B E | @ WD-datum v | & x

The component will immediately be repositioned, relative to the new Workplane.

B dmusov v K%

-
A
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11 Select Floor View

=

on the Machine Tool toolbar.

=
(22

[

12 Start the simulation b to observe the virtual machining of the component.

The DMUS5O0 angular limits are X £90 Y £360 and this information is stored in
the MTD file. This translates to Azimuth Angle limits of 0 to 360 and
Elevation Angle limits of 0 to 90. When the toolpath simulation attempts to go
beyond this range an error message will be displayed indicating that the
machine, Tool Axis Limits will be exceeded.

P PowerMill Warning:

I The machine cannot reach the location.

The simulation has been stopped.

& To allow for this appropriate Tool Axis Limits will be applied to the
toolpath during calculation.

9 -4 Autodesk PowerMill 2017
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13 In the PowerMill explorer, Machine Tools folder right mouse click on dmu50v
and from the local menu select Go Home to return the machine tool model to
the home position.

14 Make a Copy of the original toolpath and rename it as BN16-LimitsSet.

15 In the local explorer Tool Axis folder, select the Tool Axis - Limits option to
activate the Tool Axis Limits page.

16 Enter the values into the dialog exactly as shown (select Mode - Remove
toolpath and tick the Draw limits box).

P Surface Projection Finishing ? >

3 Toolpath name |BN16—LimitsSet |

ka Workplane
il Block

|_| Tool
I2, Machine tool
88 Limit [] Use machine tool when possible 0
3% Stock engagement
-+ Surface projection
573 Pattern

T Automatic verification

[Tool axis limits 1

Mode | Rernowve toolpath vl

QOrientation | Manual vl

Workplane |4 ~

.4 Point distribution
=12 Tool axis

{1 Machine axis control
[j-.;_?r Rapid Moves

w17 Leads and links

Angle limits
Azimuth angle

Start

Elevation angle

sa[00 |

End | 360.0

gf Start point

e?_f End peint
-5 Feeds and speeds

.5 History

--1=| Motes and Description
E. User defined settings

[JProject to plane

“' o : 3.0

larnping angle

e

Draw limits

Translucency (percentage)

The green area of the sphere represents the permissible angular alignment of
the Tool Axis.
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17 With the same Reference Surface selected, Calculate and Close the dialog.

18 In the PowerMill explorer right-click the toolpath, BN16-LimitsSet and from
the local menu select Simulate from Start.

19 Select Play [} .

&  With Mode set to Remove Toolpath in the Limits dialog, only the
portion of the surface within the rotary Tool Axis Limit range is
machined.

20 Right-click on the toolpath, BN16-LimitsSet, and select Settings to access the
Surface Projection Finishing dialog.

21 Select recycle @ and in the Tool axis page @ select the Tool axis limits
and enter the values into the form exactly as shown below (select Mode - Move
tool axis).

P Surface Projection Finishing T >

Toolpath name | BM16-LimitsSet |

----- 111 Waorkplane
-l Block

----- |‘_,| Tool

[Tool axis limits

..... o8 Limit [] Use machine tool when possible

ik Orientation | Manual v|
[_j\.fé-u Surface projection
----- 23 Pattern
...%g Automatic verification Wetplate 2
----- \\.o Point distributicn Angle limits
[—j}_:: TED| axis Azimuth angle
R ] 1ol ais imits sat[00 ] fnd

----- # Machine axis control
Ej-.—:{ Rapid Moves Elevation angle
-1 T Leads and links

d’{ Start point M End m

22 With the original reference surface selected, Calculate the toolpath.

23 Right-click the toolpath BN16-LimitsSet, in the PowerMill explorer and select
Simulate from Start.

24 Select Play [} .
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With Mode set to Move tool axis in the Limits dialog, the surface is fully
machined with the Tool Axis becoming fixed when it exceeds the maximum rotary
Limit.

25 Select File > Save Project to update the stored data.

Defining Limits for a Multi-Axis Machine

The Tool Axis Limits option allows the user to control the angular limits of a tool
while creating a multi-axis toolpath. The specified limits will differ in format
depending on the type of rotary axis configuration. As a result they will have to be
translated as universal Azimuth and Elevation angles to be compatible with
PowerMill.

The configuration of the rotary axes varies widely, however the differences between
many of these are relatively minor and there are really only three fundamentally
different machine configurations:

Table - Table Both rotary axes move the table.
Head - Head Both rotary axes move the head.
Head - Table One rotary axis moves the head, the other moves the table.

The next examples will show how to transpose angular limits of a machine tool into
Azimuth and Elevation angles.

1 Select File - Delete all and Tools - Reset Forms.

2 Select the Tool Axis icon @ from the main toolbar.

Define Tool Axis as Lead\Lean and set both the Lead and Lean angles to 0.

o . [¥] Tool axis limits ) o
4 Select the Tool axis limits option to activate the Limits
tab.
Open the Limits tab.
6 Select the Draw Limits option from the dialog.
Draw limits
Translucency (percentage)

0.0
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7 Select view ISO 1.

With the Draw Limits option selected a sphere will be displayed in the graphics
window representing the angular machining limits available.

Green indicates a machinable portion and Red a non-machinable portion. With
the default settings selected the total machining range is covered so the whole
sphere will be Green.

Table — Table

Both rotary axes operate on a table.

With the above Table-Table machine tool the angular limits are specified as:
X £ 30
Z + 360

The machine tool Y limits are equivalent to the Azimuth Angle or the angular limits
normal to the XY plane. The Y limit of £ 360 translates to Azimuth Angle limits of
0 to 360.

The machine tool X limits are equivalent to the Elevation angle above the XY
plane. However they are not the same angle. This is best described using the
diagram below. The machine tool measures the angular range relative to the Z Axis
and PowerMill measures it relative to the XY plane, therefore the angle required
for the limit in PowerMill is the complementary angle to the one given for the
machine tool.
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Machine Tool's 3

angle {range = * 30,
gg  PowerMLL's

elevation angle

(range = 60to 30,

X

The X limit of £30 translates to Elevation angle limits of 60 to 90.

1 Retain the default Azimuth Angle and modify the Elevation Angle values in
the form as shown below to update the machining limits.

Angle limits
Azimuth angle
Start End
0.0 360.0

Elevation angle
Start End

60.0 90.0

The Tool Axis Limits sphere has been visually updated with the modified values.

An Alternative Table -Table machine tool has the following angular limits:

X + 100
Y £ 360
This translates to Azimuth Angle limits of 0 to 360 and Elevation Angle limits of
-10 to 90.
Z Machine Tool's ¥ angle
0 (range = 100).
FowerlILL's elevation
angle (range = -10 to 90},
— o 0

-10

2 Modify the Elevation Angle values (-10 to 90) in the Angle Limits dialog to
update the machining limits (as shown).
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The Tool Axis Limits sphere has been visually updated with the modified values.

Head — Head

Both rotary axes move the head.

With the above Head-Head machine tool the angular limits are specified as:
X + 60
Z + 360

The machine tool Z limits are equivalent to the Azimuth Angle or the angular limits
normal to the XY plane. In PowerMill the Z limit of £ 360 translates to Azimuth
Angle limits of 0 to 360.

The machine tool X limits are equivalent to the Elevation Angle above the XY
plane. The angular range of the machine tool is relative to the Z axis, however
PowerMill measures it relative to the XY plane. Therefore the angle required for
the limit in PowerMill is the complementary angle to the one given for the machine
tool. The X limit of + 60 translates to Elevation Angle limits of 30 to 90.

Z Machine Tool's X
90 angle (range = * 60).
PowerMILL's

elevation angle

frange = 30 to 20).
30

X

Alternative Head-Head machine tool angular limits:
X -50 to +60
Z + 360
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This translates to Azimuth Angle limits of 0 to 360 and Elevation Angle limits
of 30 to 90. In this case the machine tool limits across the XZ plane differ.
PowerMill will use the largest rotational value (+60). This is allowed by
rotating the head 180° about Z to provide access to the maximum range +60
(which otherwise would be -50).

1 Modify the Elevation Angle values (30 to 90) in the dialog to update the
machining limits as shown.

The Tool Axis Limits sphere has been visually updated with the modified values.

Head — Table

One rotary axis moves the head, and the other moves the table.

With the above Head-Table machine tool, the angular limits are specified as:
X £ 40
Z + 360

The machine tool Z limits are equivalent to the Azimuth Angle or the angular limits
in the XY plane. The Z limit of £360 translates to Azimuth Angle limits of 0 to
360.

The machine tool X limits are equivalent to the Elevation Angle above the XY
plane. It is the complimentary angle to the Elevation Angle. The X limit of + 40
translates to Elevation Angle limits of 50 to 90.

1 Modify the Elevation Angle values (50 to 90) in the dialog to update the
machining limits as shown below.
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The Tool Axis Limits sphere has been visually updated with the modified values.

Applying tool Axis limits on a Steep Sidewall base Fillet

1 Select File - Delete all and Tools - Reset Forms.
2 Import the Model:
...\PowerMill_Data\five-axis\punch2\punch2_insert.dgk

3 Select File > Save Project As:
+\COURSEWORK\PowerMill-Projects\Punch2-ToolAxisLimits

Create a Diameter 20 Ballnose tool - Length 50 - named BN20.
Add a Shank component - Upper Dia 20 - Lower Dia 20 - Length 40
Add a Holder component - Upper Dia 70 - Lower Dia 40 - Length 40

Add a Holder component - Upper Dia 70 - Lower Dia 70 - Length 60 -
Overhang 80

Calculate a Block using Defined by - Box and Type - Model.

N o o b

o

Calculate the Rapid Move Heights using the default settings.
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10 Select the fillet running around the base of the main component sidewalls.

11 Select the Toolpath Strategies icon @ and in the Strategy Selector -

Finishing options select Surface Finishing.

12 Input data into the Surface Finishing dialog exactly as shown:

P Surface Finishing

-

Toolpath name | BM20-Fillet-FIN

[_]Ur'} Surface finishing
573 Pattern

..... #3# Point distribution
..... E Tool axis

[]--gl' Rapid Moves
w17 Leads and links
ﬂf Start point

ef_’f End point

[-fqr Feeds and speeds

..... 3 Stock engagement

.- T Automatic verification

----- # Machine axis control

----- ] Motes and Description
----- E. User defined settings

% gortnlane [Surface finishing

..... [] Tool Surface

..... % El’lachinetocrl Surface side| Outside V|
..... o imit

Surface units | Distance

Degouge tolerance

Tolerance

Thickness

5
Stepover (Distance)

A [555%

Preview [ Draw

= Toolpath name: BN20-Fillet-FIN

= Stepover: 0.5

=

=]

Copyright © Autodesk
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| P surface Finishing

_ Teolpath name |BN?_0—FiIIet—FIN |

..... 12, Workplane {Pattern ]
-l Block

----- | Tool
----- 2, Machine tool Pattern

""" o Limit Pattern direction

----- 3" Stock engagement

[—jw Surface finishing Spiral []
A Pattern Ordering [Oneway

T Automatic verification oy =

..... ' Point distribution Start comer

----- E Tool axis

----- # Machine axis control Sequence | None

= Ranid kaseac

= Pattern Direction: U
= Spiral: Ticked

P Surface Finishing

Toolpath name | BN20-Fillet-FIN |

..... 12, Workplane [T(}Cﬂ axis ]
il Block

..... || Teol Tool axis
| Lead/Lean ~

Lead/Lean angles
----- 3 Stock engagement Lead

[—ij Surface finishing
373 Pattern

—
m
"]
=1

..... #3 Point distribution

Mode | Contact normal vl
----- D ool v

----- @ Machine axis control

13 Select Calculate to create the Surface Finishing toolpath.

= The Tool Holder is in Collision with the Base.

14 From the local toolpath menu, select Verify - Toolpath to open the Toolpath
Verification dialog.

15 Un-tick both Split Toolpath and Adjust Tool.

16 Then check for Collisions using a Shank Clearance of 1 and a Holder
Clearance of 2.
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= The Tool Holder is also in collision with the Sidewall.

= During Projection Surface Finishing the tool (BN20) is alighed normal to
the Fillet Surface (if default Lead\Lean 0 is applied). This is creating a
Collision situation with both the sidewall and the base. Tool Axis limits will
be applied to prevent this immediate problem as well as to keep the tool
alignment within the machine tool rotary limits.

17 In the PowerMill explorer, right-click the toolpath, BN20-Fillet-FIN, and
select Settings to re-open the Surface Finishing dialog.

18 In the Surface Finishing dialog select to create a ‘copy’ and enter the
toolpath name BN20-Fillet-FIN-LIM30.

| P surface Finishing ? X

= Toolpath name | BNZ0-Fillet-FIN_LIM3D |

- 12, Workplane [Tool axis limits 1
- il Block

|_| Teol

.2, Machine tool
8 Limit Use machine tool when possible 0
.3 Stock engagement

[_]J.-f) Surface finishing

: 23 Pattern

T Automatic verification
~#% Point distribution Angle limits

[_jE Tool axis Azimuth angle

) sa[06 ] pau 3600
(@ Machine axis control
[]--j Rapid Mowves

4 Elevation _ga
[311 Leads and links

6’_’ End point
[#-fqr Feeds and speeds

Mode | Move tool axis v|

Orientation | Manual v|

Workplane |

19 Tick Tool Axis limits and move to the Tool axis limits page.

20 In Mode, select Move tool axis and for Elevation angle input:- Start 30 and
End 60.

21 Select Calculate to create the new toolpath.
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With the Tool Axis Limits applied the alignment will be restricted to operate
between 30 and 60 degrees (Elevation Angle) relative to the XY plane. The
sphere displaying the Tool Axis alignment limits (shaded green and pink)
becomes visible when the box labelled Draw Limits is ticked.

& The two illustrations below show the toolpath with the tool attached on
the upper and lower tracks and the effect of the specified limits.

= The Tool Holder is no longer in collision with the Base or Sidewalls.
22 Save the Project.
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Applying Tool Axis limits to maintain a 4-Axis toolpath.
1 Select File - Delete all and Tools - Reset Forms.
2 Open the ‘read only’ Project:
...\PowerMill_Data\five_axis\Tool_Limit\FixTo4Axis_Start

3 Select File > Save Project As:
....COURSEWORK\PowerMill-Projects\FixTo4Axis-examplel

4 If not already displayed, from the main pull down menus select View - Toolbar
and tick Machine Tool.

5 In the PowerMill explorer open the Machine Tools folder and activate the
RotaryMachine (double left click the icon E ).

E| @ RotaryMachine ~ ':"ii | §| @ > |a x‘
5 ¥
b @

- B Active
2-[E, Machine Tools

RS Y > RotaryMachine
Input workplane 1 as the Machine Tool output datum.
7 Select an ISO 2 view.
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9. Tool Axis Limits

The Project contains a model of a 4-Axis Rotary Machine and two toolpaths.
The first toolpath is inherently 4 Axis while the second toolpath is 5 Axis.

The Rotary Machine is unable to produce the Tool Axis moves required by the
second Five Axis toolpath. This toolpath can however easily be converted to 4-
Axis using the appropriate Tool Axis Limits options.

8 In the PowerMill explorer, right mouse click on the toolpath BN16-Base-
SEM1 and select Activate followed by Simulate from Start.

9 Click the Play |£| button and the simulation successfully runs all the way to
the end.

10 In the PowerMill explorer, right mouse click on the toolpath BN16-Form-
SEM2 and select Simulate from Start.

11 Click the Play |£| button and the simulation immediately fails to proceed with
the following message being displayed.

P PowerMill Warning: X

The machine cannot reach the location.

The simulation has been stopped.

0K

As the toolpath is fully Five Axis it impossible for the Rotary Machine to
perform a simulation.

12 Abandon the simulation.

13 Right mouse click on the toolpath BN16-Form-SEM2 and from the local menu
select Activate it before selecting Settings to open the Projection Surface
dialog.
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14 In the Projection Surface dialog select the Recycle toolpath option
15 In the local explorer select Tool axis and tick the Tool axis limits box.

Pow

I:;‘ Tool axis limits
The Tool axis limits page will become available in the local explorer.

16 Select the Tool axis limits page and enter data exactly as shown below.
? ®

P Surface Projection Finishing

Toolpath name |BN16—Form—SEM2
----- 12, Workplane [Tool axis limits }
-l Block
----- || Tool . Mode |M0\.ret00| axis V|
----- 2, Machine tool
..... ¥ Limit [] Use machine tocl when possible ‘;
----- 3 Stock engagement Orientation | Manual ~]

< Surface projection
Workplane e

: m Pattern

... W Automatic verification
----- #% Point distribution

= .’- Tool axis Azimuth angle
RS i £ [3500

----- # Machine axis control
[j--gf Rapid Moves
[j---]H_-, Leads and links Lo e
..gul Start point =
d’f End point
[j---ﬁ-_r Feeds and speeds
----- G History

Motes and Description
. User defined settings

Angle limits

Elevation angle

n

ERL

[4] Project to plane
Damping angle
[] Draw limits
anslucency (percentage)

Copy from machine tool

Cueue (8] 4 Cancel

With Project to plane ticked the Tool axis limits are flattened to create a 4
axis limit (about the global transform in this case). A zero Damping angle will

ensure that the 4 axis alignment is fully maintained.
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17 In the Tool axis limits page, un-tick Draw limits.
18 With the 3D form, surface selected Calculate the new 4-Axis toolpath.

@B Active
=-[I%, Machine Tools
=PI e -8 > RotaryMachine
@ MC Programs RotaryMachine
H@ Toolpaths
ﬂ:‘:% BN Export Machine Tool...
B 7 <k > Bh Reconnect Models...
Elﬁ Tools .
G il >y Settings
() Boundaries | GoHome |
..... #F Patterns Collisi
AP Foatiras Sote oliistans

19 In the local explorer, right mouse click on Rotary Machine and from the local
menu select Go Home.

20 From the PowerMill explorer, right mouse click on the new toolpath BN16-
Form-SEM2 and from the local menu select Simulate from Start.

21 Click the Play @ button and the 4-Axis toolpath simulation successfully runs
all the way to the end.

22 Save the Project.
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Exercise 1

1 Select File - Delete all and Tools - Reset forms.
2 Open the ‘read only’ Project:
....\PowerMill_Data\five_ axis\Punch3\Punch3_Start

3 Save Project As:-
«..\COURSEWORK\PowerMill_Projects\Punch3_EX1

The Project contains a Steep and Shallow Finishing toolpath BN16-StpShiw
with a Tool Axis set to Vertical. The Tool is too short to safely machine some
areas of the sidewalls. These potential collisions are avoided by the using
Automatic verification (Shank clearance 1 and Holder clearance 5).

The upper base surface is set with Machining Mode as Collision with a
Thickness value of 0.5.

P Steep and Shallow Finishing 7 *
Tocolpath name | BMN16-5tpShiw |
----- k. Workplane : : :
Automatic verification
- figll Block
----- |\_| Tool
----- i, Machine tool Head clearance | 600.0
----- w8 Limit
_____ 3 Stock engagement Automatic collisicn checking
[—ja Steep and shallow finishing Collision checking against
=
Holder ¢l 5.0
----- % Point distribution nleideleaidiee
----- E Tool axis Shank clearance
----- # Machine axis control 0
- Machine maximum stock
- Rapid Moves
3 Rerid Moves

The object of the exercise is to create 2 copies of the existing toolpath the first
with a suitable Toward Point - Tool Axis alignment applied and the second
that is further limited to being 4 Axis only (applied about the X axis).
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4 Activate the toolpath BN16-StpShlw and from the local menu select Settings

to re-open the strategy dialog.

Create a Copy of the toolpath and rename it as BN16-StpShiw_TwdPt.

Select the Tool Axis page and select the option, Towards Point with the XY Z

positional values as 0 50 -350.

P Steep and Shallow Finishing

Toelpath name | BN16-StpShiw_TwdPt

----- ] Motes and Description
E. User defined settings

7 Calculate the new toolpath.

..... k‘ WOI’kp|EI'1E [Tool ax|s ']
gl Block

Ll Tool Tool axis

----- 2, Machine tool

..... ¥ Limit Point

..... % Stock engagement [00 | [ 500 | [-350.0
[—j—-‘ Steep and shallow finishing

... Automatic verification

..... % Point distribution

----- ot ]

----- @ Wachine axis control Iode | Toolpath
[j|--§I Rapid Mowves
G- 1 Leads and links Fixed angle

@i Start point | None v 90.0
éf End point i . .

-5 Feeds and speeds Rotary axis configuration

..... 5 History | Teolpath

[ Tool axis limits

[] Autematic cellision avoidance
[ Tool axis smoothing

[ Draw tool axis

With a suitable Toward Point - Tool Axis alignment applied the Tool is how
angled away from the sidewalls providing collision free access to the deeper

areas.

8 Activate the toolpath BN16-StpShlw_TwdPt and from the local menu select
Settings to re-open the strategy dialog.
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9 Create a Copy of the toolpath and rename it as BN16-StpShilw_TwdPt_4Axis.
10 Select the Tool Axis page and tick the Tool axis limits box.

11 Select the newly appeared Tool axis limits page in the local explorer and
input the data into the dialog exactly as shown below.

P Steep and Shallow Finishing

&5

Toolpath name | BMN16-5tpShiw_TwdPt_4A:xis |

----- &:, Workplane
- Block
LJ Tool

..... B, Machine tocl

..... 3 Stock engagement
[—]--‘ Steep and shallow finishing
\..Tg Automatic verification
..... A Point distribution
Qié: Tool axis
"y [
----- @ Machine axis control
[j--j Rapid Moves
-1 U] Leads and links
ei_i Start point
- End point

----- =] Motes and Description
% User defined settings

12 Calculate the new toolpath.

[T:i)(ilw-axis limits ]

Made | Move tool axis v|

[] Use machine tool when possible 6

Orientation | Manual V|

Workplane | X_Direction |

Angle limits
Azirmuth angle

star[00 | gnd [3600

Elevation angle

Start| -90.0 End | 90.0

Project to plane

Damping angle

Draw limits

Translucency (percentage)

This strategy is limited to operate as 4 Axis only.

13 Save the Project.
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Exercise 2

14 Select File - Delete all and Tools - Reset forms.
15 Open the ‘read only’ Project:

....\PowerMill_Data\five_axis\joint_Saxismc\JointAxisLimits_Start

16 Save Project As:-
.....COURSEWORK\PowerMill_Projects\JointAxisLimits-EX1

The Project contains a Surface Finishing toolpath with a Tool Axis setting of
Lead 0 and Lean 0. This causes the Tool to be aligned to the surface normals
at all points on the toolpath adjacent to the selected surface. The tool alignment
is not prevented from exceeding the machine tool, rotary limits or to clear
overhanging areas of the model.

17 Recycle the Surface finishing toolpath using Tool axis limits between
Elevation Angles of 15 and 65 degrees using Mode - Move tool axis.

18 Perform a toolpath Simulation followed by a full Gouge and Collision (Shank
Clearance 2 - Holder Clearance 3) check on the modified Surfacing
Finishing toolpath.

19 Save the Project.
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10. Tool Axis Editing

Introduction.

In some applications the type of Tool Alignment option applied to a Five Axis
strategy can result in unnecessary, exaggerated rotary movements while the cutter
runs along a toolpath.

In some cases, these exaggerated movements can result in Tool Holder or
Machine Tool collisions. To reduce this, it is possible to edit the toolpath to have an
alternative Tool Alignment within a user defined, area.

1 Open ‘read only’ the Project:
«..\PowerMill_Data \five_axis\ToolAxisEditing\EditToolAxis_Start

The Project contains a Corner Along strategy created using a Dia 5 Ball Nosed
tool with a Lean Angle of 45 Degrees applied.

2 From the main pulldown menus select File > Save Project as:
«...\.COURSEWORK\PowerMill-Projects\EditTool Axis

3 In the main pull down menus select View > Toolbars > Machine Tool to raise
the Machine Tool definition toolbar.
B | &~

= L
EE & v Bk
| A
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4 Click on the Import Machine Tool Model icon @ and from the
...\PowerMill_Data\MachineData directory, select the file dmu50v.mtd.

IE @dmuﬁd}v v—:{:.‘:-|g|@ﬂase V|a x

5 Input the workplane Base as the datum for the Machine Tool Simulation.

—_

AH™

6 Ensure the Draw\Undraw machine tool icon |-
machine tool.

is selected to display the

7 Select an ISO 1 view and zoom the machining area.

8 Select Floor View % from the Simulation toolbar.

Right-click on the toolpath BN5-Rest-Lean45 and from the local menu, select
Simulate from Start.

& BNSRestleands v ff BNS Short v Qv b, DM | B x

10 Move the simulation speed, slider to a slow setting and then click the Play icon
and observe the machine tool movement.

Collision

In addition to there being an excessive amount of table rotation while the
undulating sidewall is machined there is also a Tool Holder collision on the
sidewall internal corner (see above right graphic).

11 From the local BN5-Rest-Lean45 toolpath menu, select Verify - Toolpath
and in the dialog, un-tick both Split Toolpath and Adjust Tool.

12 Select Check Collisions, with a Shank Clearance 1 and Holder Clearance 2
and Apply the dialog.

The Toolpath is now displayed red in the PowerMill explorer confirming that
the Shank and/or Holder are colliding with the model.

£-§» Toolpaths
- - > BN5-Rest-Leand5
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& The 2 issues will be fixed by applying localised Tool Axis alignment
modifications on the toolpath. To enable normal viewing while the
changes are made, the Machine Tool model will temporarily be removed
from the Machine Tool Simulation toolbar.

13 In the Machine Tool Simulation toolbar select None to remove dmu50v.mtd
from the selection input box leaving it blank.

I B B | @ oese (P =

14 Select a View from top ready for snapping the corners of a polygon to define
the first area of the toolpath to undergo Tool Axis Editing.

15 On the keyboard select Ctrl H to display the Cross Hair on the cursor position.

16 In the PowerMill explorer, right-click on the toolpath BN5-Rest-Lean45 and
select Edit > Edit Within Region from the local menus to access the following
dialogs.

17 In the (default) Select Region dialog set Define Region By - Polygon and
Side - Inner (as shown below left).

P Edit Tcolpath Within Fegon ? b4 P
select Regions  Specify Changas Select Regions Soecify Changes
e —
efine Reciof®y | ETTTEIMMNN Type of Editing
e —————
Slane [ Mew Axis Definition v
Plane X . . .
Point Rotany Axis Configuration
0.0 0.0 450 | Too path B
Mzrmal
Tool Axis

1.0 0.0 0.0

T .
Souncary . ‘ Fied Direction i IQ
e —

Orientatior

Active Workplane | Free | IQ
.
Sid‘ nner l b [ Pein: Distribution
Type
| Tolerarce And Keep Arcs | 0:;0
Sawve Selection Elend Distancd l

Clezr Szlection

Apply Cancel Apply Cancel

18 Select the Specify Changes tab, and set Tool Axis as Fixed Direction and

;.‘T

input a Blend Distance of 5, before selecting the Tool Axis icon ==,
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19

20

21

22
23

P Tool Axis

Smoothing

Definition Lirnits

Tool axis

Fixed direction |12

Direction

0.0 | [-10

Tool axis limits

[ Automatic collision avoidance

[ Tool axis smoothing
Draw tool axis

Accept

7 >

Machine axis control
Collision avoidance

Input values into the Direction vector (Along the tool axis) as:-

I 00 J-10 K 1.0

In the Tool Axis dialog, tick the Draw Tool Axis box before selecting Accept
(to return to the Edit Toolpath Within Region dialog).

From the main pulldown menus select Draw > Cursor > Cross Hair.

& This will display cross hairs running through the cursor position, to assist

visual alignment when ‘snapping’ points.

Click on the Select Regions tab to access the original options.

Left-click to snap 4 corners of the Polygon inside where the Tool Axis Edit is to

occur, and click Apply.

The above illustration is at the stage where the user is ready to snap the 4th and
final point on the Polygon (Cross hairs are mid grey).

10 - 4 Autodesk PowerMill 2017
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24 Select an ISO 1 view and simulate the toolpath to observe that the Tool Axis
Alignment is no longer performing a series of rotary movements along the
undulating sidewall.

25 Select a View from top.

26 In the PowerMill explorer, right-click on the toolpath BN5-Rest-Lean45 and
select Edit > Edit Within Region to open the Edit Toolpath Within Region
dialog again.

27 In Select Regions select Polygon with Side - Inner, and then click the
Specify Changes tab.

P Edit Teclpath Within Region ? ot P =dit Toopath Within Region ? >
Select Regions Specify Changes Select Regions Specity Changes
Define Region By | Palygon ~ Type of Editing
Plane Mew fods Definition ~
Type | Plane ¥ . . i
Point Rotary Lxis Configuration
0.0 0.0 250 E [ T2clpath |
Mormal )
10 00 o0 Tool Axis
Teol Axs
Boundary | From Foint |Ie
Joundany Orientation
Projzction Plare | Active Weorkplane | Free |Ig
Sice [A Peint Distribution
Type
| Tolerance And Keep Arcs | Q
Save Selection | Blend Distance
Clear Selection
Uada
Apply Cancel Apply Cancel

28 Set Tool Axis - From Point with the coordinate values X-15 Y 25 Z-25, and
then tick the box labelled Draw Tool Axis before selecting Accept.
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Collisien avoidance

7

|

P Tool Axis
Smoothing Machine axis control
Definition Limits

Tool axis

Point

[-50 ] [350 ] [-250

Mode | Toolpath
Fixed Angle
| MNone w 90.0

Rotary axis configuration

| Toolpath

[ Tool axis limits

[ Automatic collision avoidance
[ Tool axis smouothing

Draw tool axis

Tool Axis alignment point

29 This time snap 4 corners of the polygon to form a square, aligned as close as
possible to the Tool Axis Alignment point, and click Apply.

Tool Axis alignment point

30 Select an ISO 1 view.

31 From the local BN5-Rest-Lean5 toolpath menu, select Verify - Toolpath and
in the dialog, un-tick both Split Toolpath and Adjust Tool.

32 Select Check Collisions, with a Shank Clearance 1 and Holder Clearance 2

and Apply the dialog.

33 Select Check Gouges and Apply the dialog.

The Toolpath is now displayed green in the PowerMill explorer confirming
that the toolpath is free of both Gouges and Collisions.

-4 Toolpaths
. =- 7 U > BN5-Rest-Leand5
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34 Simulate the toolpath to observe that with the new Tool Axis Alignment the
tool holder is no longer in a collision condition with the sidewall internal
corners.

35 Perform a Machine Tool Simulation again using the DMU50V with the Floor
View selected.

This time the unnecessary, ‘rocking” movements about the rotary axis are
minimised and the Tool Holder collision removed.

36 Select File - Save Project.
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11. Machine Tool Simulation

11. Machine Tool
Simulation and
Verification

Introduction

The ability to check for potential Machine Tool - Component collisions is an
essential requirement for Five Axis applications. To provide this capability
PowerMill contains an additional Machine Tool toolbar for use with the toolpath
Simulation options.

EE e v B @ v x

The standard Machine Tool Simulation is purely visual and it is the user’s
responsibility to identify collisions. An additional, ‘cost option’ is available where the
Machine Tool Simulation will stop if a collision situation is identified. At this point
a warning box will be displayed. The tool along with the affected parts of the
Machine Tool model will turn red, and once acknowledged (by clicking OK) all
moves in a collision condition will be registered in a list.

The individual component parts of a machine tool (eg; Main Body, Head, Rotary
Table, Cradle, etc) are stored as a set of individual triangle models. These are
registered within an mtd file that controls the orientation and position of the
individual triangle models during a simulation.

Three basic, multi-axis Machine Tool Simulation (.mtd) files are supplied within
the PowerMill installation data. A typical location for a C drive install:

C:\Program Files\Delcam\PowerMill13.0.06\file\examples\MachineData

A further selection of sample mtd files, based on actual machine tools are located
on the training PCs in:

....\PowerMill_Data\MachineData

& Itis essential that all models along with controlling moves and limits used in
a Machine Tool Simulation (.mtd) file are an accurate copy of the actual
Post-Processor and machine tool in use. Due to design variations, different
set up criteria, and tolerance issues, each Machine Tool Simulation (.mtd)
file and associated models must be tailor made and fine-tuned for each
individual application.

1 Select File - Delete all and Tools - Reset forms.
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2 Open the read only Project:

...\PowerMill_Data\five axis\Collision_Simulation\Swarf check

3 Select File - Save Project As:
«..\COURSEWORK\PowerMill-Projects\M CTool-simulation

4 1In the PowerMill explorer, right mouse click the toolpath Outer Swarf and
select Simulate from Start.

- ®

- B3 Active
..... E, Machine Tools
@ MC Programs
-8 Toolpaths
5@e0
E|‘-Rj1' Tools Outer Swarf
w7 L] »D10TR3
(2 Boundaries Simulate from Start %

" Activate

5 The Simulation toolbar will appear (if it is not already displayed).

& Outer Swarf v il D10TR3 v @l Y-~ LD, PPN BEEE

6 In the PowerMill explorer right mouse click on Machine Tools and from the
local menu select Toolbar.

EHESR & B & 2 ar e
7 Select the Import the Machine Tool Model icon

dmu50v.mtd from:
....\PowerMill_Data\Machine Data\DMU\dmu50.mtd

and select the file

11 -2 Autodesk PowerMill 2017 Copyright © Autodesk



{\ AUTODESK.

11. Machine Tool Simulation

The MTD file contains the Positional and Rotational details for the individual,
Machine Tool.

It is normal practice to create the machine tool model, with the global datum
(Transform) positioned at the Top - Centre of the table.

The active cutting Tool is automatically positioned in the machine tool head.

w s

8 Ensure the Draw\Undraw machine tool icon |l is selected to display the
machine tool.

9 Select an ISO 1 view and zoom into the machining area.
10 Select the Floor View icon from the Simulation toolbar.

11 Select Display the simulation issues @ from the Simulation toolbar.

During a toolpath Simulation, the Simulation Issues dialog will display
information on collision positions.

With the Position tab selected machine tool positions will be displayed. The
values on the left hand side refer to the Axis Address Letters and their
associated values.

This machine tool has five axes, A and B are rotary with X, Y and Z as linear.

12 Start the Simulation D to observe the virtual machining of the component.
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P PowerMill Warning: X

Collision between head and model,

The simulation has been stopped.

A collision has been detected and a PowerMill Warning message displayed.

The warning message is only displayed for the first collision.
13 Select OK to close the PowerMill Warning dialog.

P simulation Issues

? ke

B [dmusov

Check for collisions.
Machine tool clearance

[ Check the tool and holder

©

Haolder clearance 0o
Shank clearance 00
Check for reconfiguration moves
[Pause on the first issue of each type ~
Issues found:
# ltem Description
@ 1 & outerswarf Collision between head and model.

The first collision move is registered and displayed in the Issues found pane.

At present only the first collision is displayed until the Simulation is continued.

14 Continue the Simulation. b

P Simulation Issues

B, [dmusty

Check for collisions
Machine tool clearance

[ Check the tool and holder

Holder clearance 0y
Shank clearance 0.0
Check for recanfiguration meves
[Pause on the first issue of each type -

Issues found

ftem
Outer Swarf
Outer Swarf
Outer Swarf
Outer Swarf
Outer Swarf
Outer Swarf
Outer Swarf
Outer Swarf
Outer Swarf
Outer Swarf
Outer Swarf

L IR RV Sy

ceeeeeeeeee
oL OLLLY

2z

Description

Collision between head and model,
Collision between head and model
Collision between head and model
Collision between head and model
Collision between head and model
Collision between head and model
Collision between head and model
Collision between head and model
Collision between head and model,
Collision between head and model,
Collision between head and model,

Clear

On completion of the simulation the machine tool is displayed in the normal

colour scheme.

15 Select a Collision

Move from the list.
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P Simulation Issues ? =

&= | dmusow ]

Check for collisions

o

Machine tool clearance
[ Check the tool and holder
Holder clearance 0.0

Shank clearance 0.0

Check for reconfiguration moves

‘Pausﬁ on the first issue of each type P

Issues found:

# Item Description ~
@ 1 < Outerswarf Collision between head and model.
@ 2 <8 OuterSwarf Collision between head and model.
@ 3 & outerSwarf Collision between head and model.
@ 4 <& OuterSwarf Collision between head and model.
§: 5 = Outer Swarf Collision between head and model.
@ & <8 OuterSwarf Collision between head and model.
@ 7 8§ oOuterSwarf Collision between head and model.
@ 2 8§ OuterSwarf Caollision between head and model.
@ 9 <& OuterSwarf Collision between head and model.
@ 10 <8  OuterSwarf Collision between head and model.
@ 11 8§ OuterSwarf Collision between head and medel. &

Clear

The simulation will move directly to the selected position in the form so that
the collision (top right corner of component) can be viewed.

16 Select View and adjust the Machine Tool position from the Simulation

toolbar.

P Machine Tool Position ?
dmu50v
~
-58.4683 60.8203
— -530 471
-43.1728 20.1664
Y &
— -4 -42.53593 438
142.974 500
Z . E
— 0
0 64.187
A . -
-180 180
Q Min -180 Max 180
0 1193.88
Q = 0
]
2

The current positional values are displayed in the Machine Tool Position

dialog.
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With a clear view of the collision, the user can assess how best to make the
appropriate changes to avoid it. In this case, substituting the cutter with one
with increased Tool Length would be the easiest solution.

17 In the PowerMill explorer right mouse click on the tool D10TR3 and select

Settings.
- Tools
- S -AA] - D10TR3
o Boundaries D10TR3
% Patterns
-3 Hole Feature Set | Activate
E‘P Feature Groups e
-5 Werkplanes [,\@
S TR T Y. -

18 Select the Holder tab on the tool dialog and modify the Overhang to 50.
P Tip radiused tool ? 3

Tip Shank Holder Holder profile Cutting data  User Defined Settings Description

Components Tool assembly
Holder name | dummy toolholder name | [} [l

Dimensions

|
§ S R @A :
|
|

Ignare

50.0 =
Gauge length

Connection
S S
:
(=] i %

Close

19 Close the dialog and in the PowerMill explorer select Simulate from Start on
the toolpath named ‘Outer Swarf'.

- @

=B Active

-, Machine Tools
@ MC Programs

45> Toolpaths

RICYEY ovter Svart
-9 Tools

S @ gl >p10
‘ {2 Boundaries Simulate from Start I}
L.P8 Patterns

----- 1 Hole Feature Sel

Outer Swarf

~ Activate
20 Select Switch on the Machine Tool Display from the Simulation
toolbar.

21 Select the Collisions tab on the dialog.

22 Select Clear on the dialog to clear any existing collisions.
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23 Start the Simulation D .

B i

o

E | dmu50v

[ Check for collisions
Machine tool clearance 2.0
[#] Check the tool and holder

Holder clearance 20

Shank clearance 0

Check for reconfiguration moves

| Pause on the first issue of each type

Issues found:

2 Item Description

Clear

Close

The Machine Tool Collisions dialog remains blank indicating that no collisions
have been detected.

24 Select File > Save Project.

25 Select File - Delete All and Tools - Reset Forms.
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NCProgram Verification (Including a Machine Tool Model)

It is possible to Verify the whole contents of an NC Program including an option to collision
check a Machine Tool Model.

1 Open the read only Project:
....\PowerMill_Data\five_axis\Collision_Simulation\AnglePockets-FullVerify_Start

Select File - Save Project As:
«....COURSEWORK\PowerMill-Projects\AnglePockets-Full Verify

2 In the PowerMill explorer right mouse click on Machine Tools and from the
local menu select Toolbar.
B © v | x

EE & ¥

3 Select the Import the Machine Tool Model icon |—E| and select the file
PMPOST-CMS_Ares48-18.mtd from:

....\PowerMill_Data\MachineData\CMS\......
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4 In the PowerMill explorer right mouse click on the Machine Tool PMPOST-
CMS_Ares48-18 and fro the local menu select Settings.

i @

=B Active
=12, Machine Tools

[ wS - > PMPOST-CMS_Ares48-18
-3 NC Programs PMPOST-CMS_Ares48-18
[—j!@ Toolpaths
@ L ’ d40tE-rgh Export Machine Tool...
@ 7 &8 BN16-sem1 Reconnect Models...
=@ ¢ & D10t1-pkt!
5@ ¢ @ Dioripkz || Setings |
=@ ¢ & D1onple Go Home

5 In the dialog, select Part and move the Opacity slider fully to the left to make
the static machine tool parts almost invisible.

6 Apply and Accept the dialog.
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7 In the Machine Tool toolbar select the Workplane MC-Table-location.

B3 Bl E pwrosT-cMs are v 00 | [ | (@ MC-Table-location v | &) x

8 In the PowerMill explorer, right mouse click the NC Program named
All-Pkts-plus-RetrackMoves-1 and from the local menu select Simulate
from Start.

0 @

- Active
E| E‘ Machlne Tools
E > PMPOST-CMS_Ares48-18

@] NC Pro-g rams

w2 7] = All-Pkts-plus-RetrackMove

EI ~‘§‘- Toolpaths All-Pkts-plus-RetrackMoves-1
| ) g SF dADt6-rc
\Zé g BM16-ze Simulate from Start [}
- @ E D1ot1-p Write
EZ}  All-Pkts-plus-Retra v il DIOTI I I AL | =B -

9 In the simulation toolbar set the speed slider to medium before selecting Play.

[ 9

“&  Observe that the total CMS machine’s Head rotation (C Axis) is currently 450
degrees (This CMS has a maximum C axis rotation limit of 360 degrees).

10 Right mouse click on the NC Program All-Pkts-plus-RetrackMoves-1 and
from the local menu select Settings to open the NC Program dialog.

11 In the Machine Tool box select the PMPOST-CMS_Ares48-18 and for Model
Location select MC-Table-location.
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P NC Program : All-Pkts-plus-RetrackMoves-1 ? x
l'e: MName |AII-Plcts-plus-RetrackMo\res-'l | ﬁg
Output File |C:\Temp\NCF’rograms\{ncprogram} | @

Machine Option File | ChdcamconfighPMPOSTVCMS_Head-Head_Fanuc31i_Saxis_. v| @

Machine Tool | PMPOST-CMS. ~ Model Location | MC-Table-loca ~
Output Workplane @ <Nene> MName
LB, > PMPOST-CMS_Ares48-18,
Program Murmnber Ik‘ | Value
Automatic Tool Ali Moves
Toolpath Mum... Di o Thickn.. Aal Tk ™
Pltd-Pkt1-C 1 10 0
D10t1-pkt1 m 10 1 130 70 0.01 0
Pkt1-Pkt2 m 10 1 130 70 0.01 0
D10t1-pkt2 4] 10 1 130 70 0.01 0 b4
£ >

12 At the base of the dialog select Apply followed by Accept.
13 In the PowerMill explorer right mouse click on the NC Program
All-Pkts-plus-RetrackMoves-1 and from the local menu select Verify.

14 In the NC program verification dialog input the Machine Tool, Holder, Shank
clearances as 5, 2 and 1 respectively before selecting the Verify tab.

P NC program verification ? b

All-Pkts-plus-RetrackMow «

IE, [PMPOST-CMS_Aresde-18 | 1 [MCTable-location \
Verify the machine tool

Verify toolpaths [/]

Verify connection moves []

Machine toel clearance

Verify the tool against the model
Verify toolpaths []

Keep existing toolpath clearances v|

Verify connection moves []

Holder clearance
Shank clearance
\?) Verified. Potential issues found.
# NC item Description
\?D 1 53'] MNC program’s machine tool and the option file's machine tool differ: The transforms on the linear axes differ.
\?) 2 @ Pltd-Pht1-C A retract and reconfigure is required,
< >
ey :
XYZ| Load issue

In the above NC Program dialog it has been reported that one of the toolpaths is
causing the rotary limits to be exceeded. This CMS machine tool can only perform a
total of one 360 Degrees rotation about the C axis. The total of C Axis rotation
currently required by the NC Program is 450 Deg.
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BE@] MC Programs

EI’:!;'). '- All-Pkts-plus-RetrackMoves-1
- 7 5E ¥ Pltd-Pkt1-C
- 7 B D10t1-pkt1
w1 7 B Pkt1-Pki2
w- 7 5B D10t1-pki2
- 7 B Pit2-Pkt3
- 7 5B D10t1-pkt3
- 7 B Pkt3-Phid
w0 B D10K1-pktd
w2 7 5| Pkt4-Pki1-C

This can be fixed by using different positional move toolpaths at the ends of the NC
Program that will start well within the main machining areas and then re-track the
tool back to the original start position.

15 In the PowerMill explorer right mouse click on the NC Program

All-Pkts-plus-RetracMoves-1 and from the local menu select Clear
Verification.

16 In the NC Program All-Pkts-plus-RetracMoves-1 replace the common first
and last positioning toolpath (Pkt4-Pkt1-C) with Pkt2-Pkt1l and Pkt4-Pkt1-CC
respectively.

EI@] NC Programs

-4, > All-Pkts-plus-RetrackMoves-1
- ¢ 5E ¥ Pre2-pitt
- 7 #B D10t1-pkt
- ¢ B Pkt1-PKt2
- 7 B D10t1-pkt2
- § B Prt2-Pkt3
- 7 5B D10t1-pkt3
- 7 5| Pit3-Pkts
- 7 5B D10t1-phid
- 7 5 Pkta-PKt1-CC

The replacement toolpaths preform repositioning with counter clockwise rotation
about the C axis. This will keep the total C rotation moves well within the CMS
machine limits.

17 In the PowerMill explorer right mouse click on the updated NC Program All-
Pkts-plus-RetracMoves-1 and from the local menu select Verify.

El@ MNC Programs

=i E# > All-Pkts-plus-RetrackMoves-1
-l 7 5E ¥ Pki2-Pktl
-l 7 5B D10t1-pkt1
- 7 5| Prt1-PRi2
- 7 9B D10t1-pkt2
w7 B Pki2-Pkt3
- 7 9B D10t1-pkt3
- 3 B Pki3-Pkts
- 7 5B D10t1-pktd
- 7 B Pktd-Pit1-CC
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This time all toolpaths are displayed with a green verification status o and no
issues are reported in the NC program verification dialog. The green status also
confirms that within the NC Program the Machine Tool is collision safe in addition
to the included, gouge free toolpaths.

18 Run another NC Program simulation and observe that this time the whole
process is now contained within a total C axis rotation of 270 degrees (max
permissible 360 degrees).

»
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19 Select File > Save Project.

20 Select File - Delete All and Tools - Reset Forms.
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12. Machine Axis Control

Introduction.

The PowerMill verification options will ensure collision safe, toolpaths relative to
the Tooling components. However, In 5 Axis applications it is also essential to
check that the actual moving parts of the Machine Tool are also collision safe. For
this to work effectively, a suitable machine tool model (MTD file) is required in the
simulation process. If a collision between the component part and machine tool
model is detected then the user can recycle the strategy with appropriate Machine
Axis Control options applied.

Machine Axis Control options allow the user to avoid collisions by controlling the
orientation/movement of the independent parts of a machine tool within the
machining strategy.

Machine Axis Control is not just used for collision avoidance but can also be used
to enable an oversized component to be machined by applying Polar to force the
use of a rotary axis in preference to a linear axis. This option can also be used in
cases where it is simply more efficient for a specific machine tool to use a rotary
axis in place of a linear axis.

Tool Axis Control - Re-Orientation - Example

1 Open ‘read only’ the Project:
....\PowerMill_Data \five_axis\MachineAxisCtrI\CMS-AxisControl_Start

2 From the main pull down menus select File > Save Project as:
.....COURSEWORK\PowerMill-Projects\ CMS-AxisControl-ex1
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The Project contains 2 NC Programs that contain the same machining
toolpaths. If the NCProgram No-OrientationMoves is run in a machine tool
simulation the Machine Tool Head clashes with the component.

If the NCProgram With-External-OrientationMoves is run in a machine
tool simulation there are no collisions between the machine tool parts and
component. This is due to the addition of repositioning toolpaths inserted as
necessary to provide machine tool head re-orientation.

Although the last NC program provides an acceptable collision free solution the
method is labour intensive and dependant on the user correctly creating and
inserting positional move toolpaths in the correct order.

3 Select an ISO 2 view.

4 1In the PowerMill explorer right mouse click on Machine Tools and from the
local menu select Toolbar.

Input Base-Centre in the workplane input box of the Machine Tool toolbar.
6 In the Machine Tool toolbar input the machine tool model:-
...\PowerMill_Data\MachineData\CMS\PMPOST-CMS_Ares48-18.mtd

BEE & eweost-cmsae v [ F,| (@ BaseCentre v & x
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7 In the PowerMill explorer, right mouse click Machine Tools > PMPOST-
CMS_Ares48-18, to open the local menu.

8 In the local menu select Settings.

BE Machine Tools

T o3 -N > PMPOST-CMS Ares48-18

& £ NCPrograms PMPOST-CMS_Ares48-18
- @ 2,fE > No-Orientationl

CoEe fjl_ﬂ WithExternal-Orien Export Machine Tool...
"@’ Toolpaths Reconnect Models...

-5 Tools —
1) > 20bn  Settings [

o o

9 In the dialog select the item, named Part and then move the Opacity slider to
make the static part of the machine tool model, translucent.

P Machine Tool : 3 x
= Machine Tool PMPOST-CMS_Ares48-18 Axis MachineDNA
B-X
S Novement
gz
=B
BA

Filename Colour ~
logonero Black

logobianco White

Iogoblu Blue

piedini2 DarkSlateGrey
piedini DarkSlateGrey
carena Gainsboro
base DimGrey v L
< >
e
Opacity ‘}
Apply Accept Cancel

10 Accept the Machine Tool dialog.

11 In the PowerMill explorer, right mouse click on the NC Program named
No-Orientation Moves and from the local menu select Simulate from Start.

12 Select the Play button in the simulation toolbar.

P PowerMill Warning: =

Collisien between head and model,

The simulation has been stopped.

After several passes the machine tool head is in collision with the component.
The machine tool head changes colour to red and a PowerMill Warning box
appears as soon as the first collision is detected.

13 Select OK and the simulation will continue even though the head is still colliding
(The head will change colour to red during each collision).

& Collision checking and reporting to a Machine Tool Model simulation is a cost
option.
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14

When the NC Program simulation moves to the other side of rib, the machine
tool head happens to be in a collision safe, orientation relative to the
component. This is not easily predictable and could easily change to a collision
situation on switching the order or inserting new toolpaths into the NC
Program.

In the PowerMill explorer, right mouse click on the NC Program
WithExternal-OrientationMoves and from the local menu select Simulate
from Start.

This time the machine tool head is collision safe throughout the simulation.

B@ MNC Programs

EI { [E] Mo-OrientationControl

a Mo_Crientation_1

3 Mo_Crientation_2

=8 . [#] > Bxternal-OrientationControl.
@ Positioning_toolpath_CW1
5 Mo_Orientation_1
ﬁ Positicning_toolpath_ACW2
ﬁ Positicning_toolpath_CW2
ﬂ Mo_Orientation_2

In this case, drive curve toolpaths have been inserted as required into the NC
Program to force appropriate re-orientation moves to occur.

The only problem is that these moves are added retrospectively and as
mentioned earlier, will be unpredictable if the toolpath order is changed or
additional toolpaths are inserted into the NC Program.

A more efficient and direct method to apply machine tool head alignment within
an individual strategy is to use the Machine axis control dialog.

12 -4 Autodesk PowerMill 2017 Copyright © Autodesk



{\ AUTODESK.

12. Machine Axis Control

15 Ensure that neither NC Program is active.

16 Activate the toolpath No_Orientation_1 and then select Settings from the
local menu.

17 In the Constant Z Finishing dialog, select Make a Copy rﬂ and rename the
new toolpath as Orientation_AZ180.

18 Select the Machine axis control page in the dialog and select the Orientation
type as Orientation vector, the Orientation vector as Fixed direction, and
input a Direction - Azimuth 180.

P Constant Z Finishing T s
Toolpath name | Me_Orientation_AZ180 |
12, Workplane {Machine axis control ]
i Block
..... |\_'| Tool Orientation type
Machine tool £
_____ R vecinetos o
----- 3" Stock engagement Orientation vector Offset angle
=] g Constant Z finishing Fixed direction - 0.0
fee ﬁ:: High speed
LWy Automatic verification Direction
..... 3 Point distribution Azimuth Elevation
..... 1% Tool axis
Y
M/ #) Machine axis control 100

) Rapid Moves Components

[ ,T‘ eads and links =
6f I;ta:poi:tl ‘ | 10 | | 00 | | 00 |
By changing the default Orientation type from Free to Orientation vector the
machine head alignment will now be controlled directly within the strategy. The
Machine axis control will cause the head to be rotated by 180 Degrees about
the Z axis compared with the original toolpath.

19 Select Calculate to create the new toolpath and close the dialog.

20 Activate the toolpath No_Orientation_2 and then select Settings from the
local menu.

21 In the Constant Z Finishing strategy dialog, select Make a Copy rﬂ and
rename the new toolpath as Orientation_AZO.

22 Select the Machine axis control page in the dialog and enter data exactly as
shown below but this time with Direction - Azimuth 0.

P Constant Z Finishing ? =
Toolpath name | Mo_Orientation_&70 |
""" 1z, Workplane {Machine axis control 1
i Block
..... |7| Tool Orientation type
----- E, Machinetool ; ; 1
_____ o
..... 2 Stock engagement Orientation vector Offset angle
9--@ Constant Z finishing Fixed direction v 0.0

= High speed

T Automatic verification Direction
..... < Point distribution Azimuth Elevation
... Machine axis control

i Rapid Moves Components

3] If Leads and links | 10 | | 0.0 | | 0.0 |

[Eag
e‘f Start point

The Machine axis control will use the default values for an Orientation
Vector of Azimuth 0 and Elevation 0.

23 Select Calculate to create the new toolpath and close the dialog.
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24 Create a new NC Program named Internal-OrientationControl containing the
2 new toolpaths Orientation_A180 and Orientation_AO.

25 With the machine tool model, PMPOST-CMS_Ares48-18 still active, run a full
simulation on the new NC Program and check that the head movement is
collision free throughout.

26 Reverse the order of the toolpaths in the NC-Program named Internal-
OrientationControl and run the full simulation again and check that the head
movement is collision free throughout.

The application of Machine axis control directly in the strategies has
eliminated the need for the additional positioning toolpaths. As shown in the
above illustration, the machine axis control is now independently controlled
within the 2 new strategies.

Dynamic Machine Control (Requires VeriCL - The
Advanced Simulation cost option)

The Dynamic Machine Control options a are accessed from the Machine Tool

toolbar.

IE [/ PMPOST-CMS_Are ~ ':.: % @Ease-(entre w g}\ w
g

ax|

It is possible to apply machine axis control dynamically using options from the
Dynamic machine control toolbar (shown below).

i |200n FaERLEERS YYS 2O
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Visual checking for Machine Tool accessibility

The active Tool and Machine Tool head can be dynamically moved around the
part to visually check for accessibility relative to the current orientation

1 In the PowerMill explorer right mouse click on the toolpath
No_Orientation_2 and select Simulate from start.

2 Jog the tool to the start of the fixed machining alignment position and then from

3

the Machine Tool toolbar select Dynamic Machine Control.

3 In the Dynamic machine control toolbar select use tool positioning
i
graphics.

4 Left click on the tip of the tool and then dynamically move it down the angled
model, undercut towards the base of the recess.
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5 Rotate the view to observe the new position from different angles.

6 Dynamically drag the tool to a ‘key point’ on the opposite side of the model.

If any part clashes with the model the machine tool head will change colour to
red.

7 Select the green tick ‘{ at the end of the Dynamic machine control toolbar
to exit with the tool still displayed in the final position.

“&  The above final Tool position is cancelled if a new Toolpath simulation
is selected, or if Go Home is selected in the Machine Tool menu.

&  Ifthe red cross ?‘ is selected then the tool will be positioned as it was
before the Dynamic machine control toolbar was opened.

8 Right mouse click on the machine tool model, PMPOST-CMS_Ares48-18 and
from the local menu select Go Home.
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Dynamic Machine Tool re-orientation applied to a Toolpath.

i [206n RS EERR MES Pkt

The default setting in the Dynamic machine control toolbar is Use machine
tool graphics.

The rotary axis components of the machine tool can be dynamically re-
orientated and applied retrospectively to the active toolpath.

Other options include:-

T
a Use machine tool graphics - Applies dynamic rotation and linear
moves relative to the Machine Tool model datum (Default).

b Active workplane graphics mode I@‘ - Applies dynamic rotation and
linear moves relative to the active workplane.

¢ Lock tool axis direction @ - This locks the current rotary axis orientation,
allowing only dynamic linear axis, moves to take place when used with a or b
above.

1 From the local PowerMill explorer - Toolpaths, right mouse click on
No_Orientation_1 and from the local menu select Edit - Copy Toolpath.

Rename the new toolpath as Dynamic_Orientation_1.

3 Activate the new toolpath and run a Machine Tool simulation until the collision
with the Head is first detected.

P PowerMill Warning:

Collision between head and model.

The simulation has been stopped.

4 Select OK in the PowerMill Warning dialog.
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X

5 On the Machine Tool, toolbar select Dynamic machine contro

|'%if@¢£¢» BEEERR LSS

6 Use the default Use machine tool graphics option .

7 Use the upper circular handle to rotate the head to the above left, alignment,
followed by the lower circular handle to re-orientate the tool to the above right
alignment.

8 Once a suitable Machine Tool Orientation has been achieved select the

Update Toolpath @ |

9 Select the green tick to accept the changes and close the Dynamic machine
control toolbar.

option.

& The toolpath is now displaying gouge and collision status as Unknown.
& Toolpaths
: ..f— ¢ B8 No_Orientation_1
{2 7 & > Dynamic_Orientation_1

10 Verify the modified toolpath Dynamic_Orientation_1 for both Gouges and
Collisions (Clearances:- Holder 2 and Shank 1).

&) Toolpaths
L | g MNo_Orientation_1
-4 7 B > Dynamic_Orientation_1

The Toolpath is now confirmed to be both Gouge and Collision safe relative to
the Tool assembly.
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11 Right mouse click on the machine tool model and from the local menu select
Issues to open the following dialog.

P Simulation Issues ? X

B, [ PMPOST-CMS_Ares42-18 |

Check for collisions

Machine toel clearance G
Check the tool and holder
Holder clearance
Shank clearance
Check for reconfiguration moves
‘Pausenntheﬂrsti;sueofea(htypa “

Issues found:

E3 Item Description

Clear

Close

12 In the dialog input a suitable clearance value for the machine tool head (eg 5).

13 Clear the issues found, list and perform further machine tool simulation to
confirm that the head assembly is also collision safe (The Holder and Shank
clearances (eg 2 and 1) can also be included in the same dialog).

= During a simulation the machine tool Head will change colour yellow if a
collision situation is identified and it will also be registered in the above
dialog .

Issues found:

k4 Item Description
\Z} 1 @ Dynamic_Orie..  Less than 50mm between model and head.

14 Save the Project.
15 Select File - Delete All and Tools - Reset Forms.
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Tool Axis Control - Polar - Example

The start up Project contains a BN16 tool, 3 Axis toolpath, Mazak Variaxis
Machine Tool model, and component model. The component model has a
length dimension that exceeds the X axis and maximum Y, travel limits for the
Mazak machine. However the model could be machined in 4 stages if the longest
dimension, is controlled to align within the minimum Y axis travel limits. This
will be achieved by applying the Tool Axis Control - Polar options to convert
all X linear moves to C Axis, rotary moves (about the Z Axis).

1 Open ‘read only’ the Project:
...\PowerMill_Data \five_axis\MachineAxisCtrl\Mazak-OversizeCompt_Start

2 From the main pull down menus select File > Save Project as:
«\COURSEWORK\PowerMill-Projects\ Mazak-OversizeCompt-ex1

3 In the PowerMill explorer - Machine Tools area, activate the machine tool
model, PMPOST-Mazak_Variaxis_630PSA.

4 From the main pull down menus select View - Toolbar and from the resultant
menu ensure that the Simulation, and Machine Tool options are all ticked.

5 In the Machine Tool toolbar, input the machine tool named PMPOST-
Mazak_Variaxis_630PSA and the workplane named TableDatum.

B E& [ PMPOST-Mazak v v @ ® TableDatum v | & x
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6 In the PowerMill explorer right mouse click on the Machine Tool - PMPOST-
Mazak_Variaxis_630PSA and from the local menu select Settings.

P Machine Tool

? X

=t N_IachineTooI PMPOST-Mazak_Variaxis_f2 Axis  MachineDMA

Filename Calour

swarf-gutter DarkGrey
door-handles Lavender
doors DarkSlateGrey
main-casing White

base Teal

Accept Cancel

7 In the dialog, select A and move the Opacity slider to the left until the moving
parts can be clearly seen behind the opaque, static parts of the Machine Tool

Model.

8 From the PowerMill explorer, right mouse click on the existing toolpath and
from the local menu, select Simulate from Start.

9 In the Simulation toolbar, select the Play button and immediately the following
PowerMill Error dialog will open.

P PowerMill Warning: X
I Machine X needs to get to -341.34, minimum is -313.
The simulation has been stopped.

The X co-ordinates at the ends of the above toolpath are outside the X axis,
travel limits. Note, the travel limits are included in the machine tool model

definition.

Copyright © Autodesk
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10 In the PowerMill explorer, right mouse click on the existing toolpath and from
the local menu select Activate followed by Settings to open the dialog.

11 In the Line Projection Finishing dialog select the ‘make a copy’ option .
12 In the dialog, Rename the new toolpath as BN16-Vert-Orientation-Polar_A.

13 In the local explorer, select the Machine axis control page and input data as
shown below.

P Line Projection Finishing 7 x
Toolpath name | BM16-Vert-Orientation-Polar_A |
""" 12, Workplane {Machine axis control ]
-l Block
..... |_| Tool Orientation type
----- Machine tool
e
----- obf Limit
..... 3% Stock engagement Rotation centre

[E1-#» Line projection

E:S Pattern

... W Automatic verification Lock
..... Q. Paint distribution Asis Offset
..... 1._; Tool axis

..... i iz conol

[j—--_;,“"i Rapid Moves
[]...1H_', Leads and links
e‘f Start point [Juse complementary angle
6? End point

[-fqr Feeds and speeds

= /b You have not chosen polar links.
----- & History _—E

14 1In the above dialog select :—ﬁ to change to the Rapid Moves page and then
tick the box, Use polar links as shown below.

*

P Line Projection Finishing ?

Toolpath name | BM16-Vert-Orientation-Polar_A |

..... 12, Workplane e [Rapid Moves
-Jigl Block

..... ] Tool Safe area
----- E Machine tool Type| Plane -
----- o8 Limit
..... 3 Stock engagement Workplane  MCdatum ~
[—]/@ Line projection

: gg Pattern

—_

T8 Automatic verification

----- % Point distribution Nermal

12 Tool axis 0.0 | [00 | [10 |
----- # Machine axis control

— -

- aP'd Moves Rapid height | 9.998021
H :,-f Moves and clearances
5117/ Leads and links Plunge height | 4938021

1! Lead in Use polar links []
T Lead out

T First and last leads
]ﬂ Lead extensions
1] Links Rapid clearance
T Point distributicn
e‘f Start peint

Calculate dimensions
Measured from |Blockand Model

Plunge clearance | 5.0

15 Calculate the dialog to create the new toolpath.
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16 From the PowerMill explorer, right mouse click on the new toolpath and from
the local menu, select Simulate from Start.

17 In the Simulation toolbar, select the Play button and this time the strategy will
successfully run from start to end.

All the X-Axis cutting moves in the original toolpath have been converted to C-
Axis rotary moves in the new toolpath. This has resulted in tool moves being
confined to the area from the table centre towards the min Y travel limit.

18 Select File - Save Project.

Exercise

1 Create a copy of the above toolpath named BN16-Vert-Orientation-Polar-B.

2 Calculate after inputting the appropriate data to finish machine the other half of
the component model keeping within the Tool Axis limits for the Mazak
machine tool.

3 Select File - Save Project.
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13. Machine Tool Models

Introduction.

The PowerMill toolpath simulation process can be expanded to include a Machine
Tool Model. This capability becomes extremely important for multi-axis
applications.

First of all triangle models (eg dmt or stl format) need to be obtained of all the
independent moving parts of the machine tool. It is essential that the user obtains
accurate dimensions along with any other details relating to the setup of a specific
machine tool.

These separate Triangle files are stored in a folder adjacent to a Machine Tool
Simulation schema file (mtd)

To create a new mtd file it is easier to modify a copy of an existing one based on a
machine tool of similar configuration.

It is essential that the kinematics of a Machine Tool Simulation model, is the
same as the relevant Post-Processor output.

How to configure a Machine Tool for simulation

The first stage is to create the separate component models (ideally in
PowerSHAPE) for each moveable axis for the machine tool. These must be
exported as individual triangle models to be compatible for use in an mtd file. For
the following example the models have already been created and are ready to be
registered to a new mtd file.

An mtd file contains information that describes the kinematics of a particular
machine.

For mtd files to work, they must be accompanied in the same folder by the schema
file, pmillmt.xsd.

In the same location, a sub-folder must exist that contains separate triangle
models dmt of all the necessary static and moving machine tool components.

. dmuB0t ) body.dmt
;pmillmt.xN fﬂ'cnlumn_a.dmt
7| PMPOST-dmug0t.mtd &) column_b.dmt
=) logo.dmt
(=) table.dmt

=) yslide.dmt
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Machine Tool Model for a dmu80t Five Axis

yslide.dmt

/ column_a.dmt

4&— column_b.dmt

logo.dmt
e 109

[ 421.6716

925.00
table.dmt

body.dmt

The above illustration identifies 6 separate triangle models that form a dmu80t
five axis machine tool. Also shown are the vertical distances from the top of the
table to the base of the head (421.6716), and the centre of the rotational axes
(925.00).

machine_part

The mtd file is made up of objects called machine_part. There are 2 compulsory
machine_part objects which must be identified as "head” and “table”. Note; their
names in the mtd file must be in lower case.

In the above machine tool the X, Y, and A axis (rotation about Y) are controlled on
the “head”, and the Z and B axis (rotation about Z) are controlled on the “table”.

Linear Axis Controls
X, Y, and Z must exist and only right handed axis systems are supported.
These can be in any orientation as long as they are orthogonal.
Type of axis that can be configured is:-
Simple_linear:- The definition requires direction.

Rotary Axis Controls

Rotary controls are typically defined by A, B, or C and ideally should be selected to
match the same output as output in the associated Post-Processor. Note; where
applicable, angular limits can be assigned to an individual rotary axis.

Type of axis that can be configured is:-
simple_rotary:- The definition requires position and direction.
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MTD file initial state

Although all the separate triangle models are correctly positioned relative to the
assembled machine tool model, it is still required to input key dimensions into the
mtd file. In this example, these include the ‘gauge’ distance from the top of the
table (0 0 0) to the base of the head (0 0 421.6716), and the coordinates of the
centre of the rotary axes (0 0 925).

EXAMPLE:- MTD file for a Mazak five axis machine

1 Select File - Open Project:-
...\PowerMill Data\five axis\MachineToolModels\MTD-Mazak-Ex1_ Start

2 Select File - Save Project As:-
«..COURSEWORK\PowerMill_Projects\M TD-Examplel

A Machine Tool Model will be loaded into the above Project that correctly
defines:-

a The position of all the separate machine tool components.

b The direction of rotation for the 2 rotary and +/- movement for the 3 linear
axes.

¢ The max/min travel limits for each of the 5 axes.

3 From the main pull down menus select View — Toolbar - Machine Tool to
open the Machine Tool toolbar (Or alternatively right click on Machine Tools
in the PowerMill explorer and from the local menu select Toolbar).

A v ] | 2 v x
=

4 In the Machine Tool toolbar select the Import Machine Tool Model
option.
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5

In the dialog select the Machine Tool Model file:-

....\PowerMill_Data\five axis\MachineToolModels\PMPOST-
Mazak_ Variaxis_ 630PSA.mtd

5 PMPOST-Mazak i ~ 0 | [B; | [@ 2

6 Select Workplane 2 as the Current Model location point.

7

St

& x

In the PowerMill explorer right mouse click on the Machine Tool Model

name PMPOST-Mazak_Variaxis_630PSA and from the local menu select
Activate followed by Settings.

8

=B Active

-2, Machine Tools

@] MNC Pragrams

-85 Toolpaths

L omt) = EMT

=4 Tools
me g || > Em

w7 Boundaries

----- *4 Patterns
A -

P Machine Tool

po il > PMPOST-Mazak_V.

PMPOST-Mazak_Variaxis_630P5A

Export Machine To

Reconnect Models

-Settings

Go Home

In the Machine Tool dialog select Part.

=~ Machine Tool PMPOST-Mazak_Variaxis_6:

Apply

ol...

[

T
Axis MachineDNA
Part name |
Movermnent | Static
Filename Colour
swarf-gutter DarkGrey
door-handles Lavender
doors DarkSlateGrey
main-casing White
base Teal
Opacity I
>
Accept Cancel

9 Move the Opacity slider to the left until the Machine Tool Body is almost

invisible.
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10 Right mouse click on the toolpath EM12-FinPkts and from the local menu select
Simulate from Start.

11 In the Machine Tool toolbar select the Machine Tool Display E | options.

P Machine Tool Position ? X
PMPOST-Mazak_Variaxis_620PSA
~
-190.278 197
X N .
215 215
—
Min -315 157 Max 315
00
! i a
. -450 315
Min -450 lIl Max 315
287.712 287.712
z [
—* 3 287.71238] 26t
00
& ]
-120 30
O Min -120 II' Max 30
00
< ]
Q ™ [e1 ™
v
o B B
Close

12 To test the X-Axis travel, select the Cursor on the X row slider and drag it to
the left, and/or use the LH/RH keyboard arrow keys for exact 0.5 incremental
moves.
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13 On the keyboard hold while holding down the Shift key, press the left hand
arrow key to perform continuous, incremental -ve X moves on the machine
tool model.

14 While holding down the Shift key, press the RH keyboard arrow key to perform
a +ve X move on the machine Tool Model.

15 On the keyboard press the downward, arrow key to move down to the next row
(or simply click on the Y row, cursor).

16 As before visually check both the -ve and +ve Y moves on the Machine Tool
Model.

17 Systematically move down the rows and check out the movement of the
remaining 3 axes (Z, A, and C) on the Machine Tool Model.

A-AXIS z .
, A-AXIS
.VE ROTATION +VE ROTATIO

C-AXIS
+VE ROTATION

The above movements are exactly the same as on the actual Mazak machine
tool to which the MTD file relates.

A full simulation will provide a visual confirmation of the all moves performed
on the toolpath. It is also possible to check for Machine Tool component
collisions (if an additional cost option is purchased).
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18 Close the Machine Tool Position dialog and then perform a full Simulation on
the toolpath EM12-FinPkts.

19 In the PowerMill explorer right mouse click on the machine tool, PMPOST-
Mazak_Variaxis_630PSA and from the local menu select Go Home.

Correcting a faulty MTD File:-

20 In the Machine Tool toolbar select the Import Machine Tool Model @
option.

21 In the dialog select the Machine Tool Model file:-

....\PowerMill_Data\five axis\MachineToolModels\PMPOST-
Mazak_Variaxis_630PSA-Faulty.mtd

22 As before open the Settings dialog from the local menu and turn down the
Opacity of the non-moving parts of the Machine Tool Model.

23 In the dialog select Open to import the new Machine Tool Model.

B B eveost-Mezak v - [ B | L r X
b |

- Machine Tools
C @ ¢ B PMPOST-Mazak Variaxis 630PSA
/B > PMPOST-Mazak_Variaxis_630PSA-Faulty

The newly imported Machine Tool Model file should perform exactly as the
existing one. However the MTD file contains some incorrect values which need
to identified and fixed. The user will need to systematically check the linear and
rotary axis movements and the relative location of the trunnion and rotary table.

24 In the Machine Tool toolbar select the Machine Tool Display IE | option.

25 Use the Jog options to check the +ve and —ve movement of all 5 axes (They
should be the same as the Machine Tool Model imported with the original
Project).
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P Machine Tool Position 7 =

PMPOST-Mazak_Variaxis_630PSA-Faulty - Copy - Copy

X ; 5

— -20 315
Min -20 S13 Max 31

-450 315

v 5 5

— -450 315
Min 450 Mo 31

182 716

z E 5

— 0 13 1000
20 120

Close

The following C-Axis faults are exposed in the currently active MTD file: -

a The +ve/-ve rotational moves for the Rotary Table C Axis are reversed
compared with the Machine Tool Model imported with the original Project.

b The Rotary Table rotational centre (C-AXxis) is incorrectly aligned.

¢ The —ve X Axis moves are incorrectly limited to just beyond the table
centre.

26 From the Desktop open a File Explorer dialog and browse to the folder:-
....\PowerMill_Data\five_axis\MachineToolModels

27 Create a copy of the mtd file:- PMPOST-Mazak_Variaxis_630PSA-
Faulty.mtd and rename it as:- PMPOST-Mazak_Variaxis_630PSA-
Update.mtd

[

“&  If an MTD file of the same name already exists overwrite it.

28 Open the new copy of the mtd file in Wordpad and look for incorrect data in
the section of the mtd file that defines the Rotary Table - C-Axis.

<machine_part>

<axis>

<control_info ADDRESS="C" />

<simple_rotary X="0" Y="250" Zz="0" I="0" J="0" K="-1" />
</axis>

<model_list>

<dmt_file>

<path FILE="Mazak_Variaxis_630/table.dmt" />
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29

30

31

32

33

34
35

<rgb R="200" G="200" B="200" />

The previous row that defines the C-Axis requires the XYZ position to be in the
centre of the table, and the +ve/-ve rotation directions to be reversed.

Modify the above incorrect values to those shown below:-
<simple_rotary X="0" Y="0" Zz="0" I="0" J="0" K="1" />

Save the updated mtd file (but do not close it).

& This latest update will now be tested in the PowerMill Project.

In the Machine Tool toolbar select the Import Machine Tool Model |@|
option.

In the dialog select the Machine Tool Model file:-

....\PowerMill_Data\five axis\MachineToolModels\PMPOST-
Mazak_Variaxis_630PSA-Update.mtd

Turn down the Opacity on the static parts of the Machine Tool model.

In the Machine Tool toolbar select the Machine Tool Display E | option.

Use the Jog options to check the +ve and —ve movement of the Rotary Table
- C-Axis.

PMPOST-Mazak_Variaxis_630PSA-Update

X -
— -20 I ) 1 315
Min -20 - - Max 315
o0
Y -
— -450 T ) 1 315
Min -450 - - Max 315
500 500
Zz -
— 0 500 1000
00
A -
0 -30 ) 120
Min -30 Max 120

Close
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The updated Rotary Table - C-Axis movement is how exactly the same as in
the original Machine Tool Model (PMPOST-Mazak_Variaxis_630PSA).

The next stage is to use a Simulation to check that all of the linear and rotary
travel limits on the Machine Tool Model are correct.

36 Right mouse click on the toolpath EM12-FinPkts and from the local menu select
Simulate from Start.

37 On the Simulation toolbar select the Play [} button.

I Machine X needs to get to -190.28, minimum is -20.

The simulation has been stopped.

The Simulation has immediately stalled due to one of the defined X axis the
travel limits being exceeded.

38 Press the Play button again to allow the Simulation to continue but note that
the A axis trunnion has been able to incorrectly rotate well beyond its 30 deg
limit towards the back of the machine.

39 Return to the file in Wordpad and look for incorrect data in the section of the
mtd file that defines the Table - A-Axis.

<!-- The table -->

<machine_part>

<axis>

<control_info ADDRESS="A" MIN="-30" MAX="120" />
<simple_rotary X="0" Y="0" z="50" I="-1" J="0" K="0" />
</axis>

<model_list>

<dmt_file>

<path FILE="Mazak_Variaxis_630/Trunionl.dmt" />

<rgb R="210" G="210" B="255" />
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The above row that defines the A-Axis rotational travel limits and simply requires
the MIN and MAX numbers to be swapped (The correct movement for +ve and -
ve rotation has already been checked and confirmed to be okay).

40 Modify the above incorrect values to those shown below:-
<control_info ADDRESS="A" MIN="-120" MAX="30" />

41 Save the updated mtd file (but do not close it).
This latest update will now be tested in the PowerMill Project.

42 In the PowerMill explorer right mouse click on the machine tool PMPOST-
Mazak_Variaxis_630PSA-Update and from the local menu select Delete.

[

& Itis necessary to re-import the updated MTD file into the Project.

43 In the Machine Tool toolbar select the Import Machine Tool Model @
option.

44 In the dialog select the Machine Tool Model file:-

....\PowerMill_Data\five axis\MachineToolModels\PMPOST-
Mazak_Variaxis_630PSA-Update.mtd

45 Turn down the Opacity on the static parts of the Machine Tool model.

46 Right mouse click on the toolpath EM12-FinPkts and from the local menu select
Simulate from Start.

47 On the Simulation toolbar select the Play D button.

P PowerMill Warning:

Machine X needs to get to -190.28, minimum is -20.

The simulation has been stopped.

The Simulation immediately stalls and the PowerMill Error dialog is displayed
informing that the current minimum limit for X is -20.

48 Select OK in the PowerMill Error box.
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‘/ |
Start Position |°
K
%

Note that the head is currently unable to move to the -ve X start position.

49 Continue to Step Forward and observe that the Machine Tool Model is only
performing moves that exist from X-20 to X315.

50 Return to the file in Wordpad and look for incorrect data in ‘'The head’ section
of the mtd file that defines the X axis travel limits.

<!-- The head -->

<machine_part>

<axis>

<control_info ADDRESS="X" MIN="-20" MAX="315" />

<simple_linear I="1" J="0" K="0" />

</axis>

<machine_part>

<axis>

<control_info ADDRESS="Y" MIN="-450" MAX="315" />

<simple_linear I="0" J="1" K="0" />

</axis>

<machine_part>
The above row defining the MIN X travel limits contains an incorrect value of "-20".
This value must be changed to "-315".

51 Modify the above incorrect value to that shown below:-
<control_info ADDRESS="X" MIN="-315" MAX="315" />

52 Save the file.

“&  This final update will now be tested in the PowerMill Project.

53 In the PowerMill explorer right mouse click on the machine tool PMPOST-
Mazak_Variaxis_630PSA-Update and from the local menu select Delete.
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It is necessary to re-import the updated MTD file into the Project.

54 In the Machine Tool toolbar select the Import Machine Tool Model |@|
option.

55 In the dialog select the Machine Tool Model file:-

.....PowerMill_Data\five axis\MachineToolModels\PMPOST-
Mazak_Variaxis_630PSA-Update.mtd

56 Turn down the Opacity on the static parts of the Machine Tool model.

57 Right mouse click on the toolpath EM12-FinPkts and from the local menu select
Simulate from Start.

58 On the Simulation toolbar select the Play |£| button.

A
~

The simulation will now successfully runs from start to finish without stalling. All
linear and rotary moves should be an exact match compared with the original
mtd file, PMPOST-Mazak_Variaxis_630PSA.

59 Select File - Save Project
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14. Four Axis Rotary
Finishing

Introduction.

This Finishing strategy is designed for machining a component mounted on a
single, programmable Rotary Axis. During milling, the component rotates around
the rotational X-axis while the cutter performs simultaneous 3-Axis movements.

The main options are summarised below.

X Limits

The X Limits define the absolute limits of the finishing path along the rotational, X-
axis. These can be manually defined, or automatically set to the limits of the block.

Pattern

This enables the cutting method to be specified for rotary milling either Circular,
Line, or Spiral.
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Y Offset

A 'Y Offset distance can be specified to avoid cutting with the tip of the tool. This
view along the X-axis shows how the Y Offset (if active) is applied to the Rotary
form:

L lYOFFSET

Angular Limits

The Angular Limits section of the dialog is only available when using the Style as
Circular or Line. The Angular limits are defined between a Start and End angle.

Start angle A

The angular limits are measured in an anti-clockwise direction when viewed along
the positive X-axis. The area machined is between the start and end angles.

Cut Direction

This option determines whether Climb, Conventional, or Any milling directions are
used.

Stepover

In the case of Circular and Spiral this is defined as the pitch for each programmed
revolution of the component. For Line this is defined as the angular, stepover
between adjacent tool tracks.
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Circular Rotary Machining

In this example a model of a bottle with its centre along the X-axis will be used.
Using the Style as Circular, the job rotates with the tool aligned to a fixed
direction. While the component rotates, the tool moves back and forth along its axis
to generate the sectional form. The tool then steps over by the Pitch value and the
rotational machining process is repeated.

1 Select Delete All and Reset forms.
2 Import the Model:
.\PowerMill_Data\Models\rotary_bottle.dgk

Calculate the Block using Defined by - Box and Type - model.
Create a Dia 10 Ball nosed tool named BN10.
In the Rapid Move Heights dialog select Calculate.

o o A~ W

In the Start and End Point dialog Use - Absolute using the coordinates 20 0
40.

7 Set the Short/Long Links to Skim and Default Links to Incremental.

8 In the Strategy Selector @ select Finishing > Rotary Finishing.

P Rotary Finishing ? *

£ | Toolpath name |BN10-Rotary-CircuIar |

----- Ir:, Workplane
il Block

..... L] Tool X lirmits

----- B, Machine tool Start | -115.067

..... o Limit
----- 5 Stock engagement
B8 Yoty fnishing) pee

e T Automatic verification i
----- \’} Point distribution ¥ offset
----- # Machine axis control
[]..g’f Rapid Moves
-1 7] Leads and links

[Rotary finishing 1

|rr|
=
o

Angular limits

il tart point Start End -
e"d End point
[j---ﬁ- Feeds and speeds Tolerance Cut direction
----- 3 tinory
----- | Motes and Description
----- E User defined settings Thickness

0 &

Stepover
A [
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9 Select Calculate to create the toolpath then Cancel the dialog.

Enter Name: BN10-Rotary-Circular

Click on Defines X limits as block limits.
Set Style: Circular
Select Cut Direction: Climb

Input Stepover: 2

10 Right mouse click the toolpath Rotaryl_BN10 and from the local menu select
Simulate from Start to open the Simulation Toolbar.

11 Select the Play button on the Simulation toolbar D .

=z By applying Tool view point the rotation of the component is simulated

(As if viewing the actual machine tool).

In the above example each section is machined in the same Climb milling direction.
The entire length of the job is machined since the X Limits are set to the Block
limits. Selecting Conventional will produce tool tracks travelling in the reverse
direction and Any will produce alternate Climb and Conventional tool tracks along
the job.

12 Recycle the toolpath, select Any for the Cut direction and select Calculate to
create the toolpath before selecting Cancel to close the dialog.

13 Simulate the toolpath as before to observe the effect of the toolpath reversing
direction with every new section machined.
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Line Rotary Machining

Using the Style as Line, the tool feeds in the X direction following the component
form. At the end of each pass the tool retracts and moves above the start of the
next pass. At the same time the rotary axis indexes by the angular stepover and the
tool then leads onto the next machining move.

14 Make a Copy of the previous toolpath named BN10-Rotary-Line and select
Style - Line using Cut Direction > Climb milling.

15 For Angular Limits - Start Angle, enter 90 and End Angle, enter -90.

16 From the main toolbar select Leads and Links and set all of the Links to
Skim.

17 From the same dialog, select Moves and Clearances and set the Axial
clearance to 20.

18 Click on Calculate and Close the dialog.

19 Simulate the new, uni-directional toolpath (shown above with a larger step
over).

20 Make a Copy of the previous toolpath and name it as:-
BN10-Rotary-Line-2way.

21 Change the Cut Direction to Any.
22 Apply the dialog and Simulate the new, bi-directional toolpath.
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Spiral Rotary Machining

Using the Spiral technique, a continuous toolpath is generated around the form as
the tool advances along the X-axis. To ensure a clean finish the toolpath starts and
finishes with a constant X position, sectional pass. Due to a Spiral toolpath being a
single, continuous track the cutting direction will be either Climb or Conventional
milling. For the same reason the Angular Limits option is not viable and as a result
is blanked out.

23 Make a Copy of the previous toolpath and name it as BN10-Rotary-Spiral and
select Style - Spiral using Cut Direction > Climb milling.

24 Click on Calculate to produce the toolpath shown below.

25 Simulate the new toolpath.
26 Save the Project as:-
«...\.COURSEWORK\PowerMill_Projects\ Rotary_Bottle-EX1

14 -6 Autodesk PowerMill 2017 Copyright © Autodesk



15. Port Machining

{\ AUTODESK.

15. Port Machining

Introduction

In the Strategy Selector the Ports option provides 3 specialist strategies, designed for
machining cylinder head, inlet/outlet ports.

P Strategy Selector

B 25| 2

Q|

Favourites
..dj 3D Area Clearance
QB Curve Machining
= .
Feature Machining
‘Jﬂ Finishing
[f| oriting

i Drilling Methods

ﬁ Blisks

I'U] Ribs

::|p Turning
E MyStrategies

i @ Port Area Clearance
-::-yf Port Plunge Finishing
i, pﬁ Port Spiral Finishing

Preview

GK . ] | (.Zancel.

The Port Machining options automatically provide multi-axis, tool alignments
where this is possible. A warning will be displayed if impossible alignment limits are
reached and the port is not fully machined.

P PowerMill Warning:

| Some slices leave rest material.

*
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15. Port Machining

Basic Single Port Example
1 Open the ‘read-only’ Project:
.\PowerMill_Data\five_axis\Ports\SinglePort1-Start

2 Save Project As:-
.\COURSEWORK\PowerMill-Projects\SinglePort1-ex1

& The Project already contains all required cutting Tools, and preliminary
3Plus2 toolpaths.

The following section will take the user through the specialist Port Area Clearance
and Port Spiral Finishing options.

A Pattern (1) is included running down the centre of the Port. This is required to
control the extent and alignment of the Port Machining strategies.

3 Activate the existing Toolpath 1 to reinstate all the settings.
4 Activate the BN10 tool.

5 In Toolpath Strategies select Ports > Port Area Clearance and fill in the 3
pages of the dialog exactly as shown below.
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P Port Area Clearance

Toolpath name | BN10-PortAreaClear

B o e ciearnce
: k Workplane limits
4 Ramping

: g Order

... Automatic verification
..... 3 Point distribution

..... 1 Tool axis

----- @ Machine axis control
[j.-:_r(;f Rapid Moves

17! Leads and links

@? Start point

QE End point

F-fqr Feeds and speeds

..... ] Motes and Description
----- E. User defined settings

% ‘;Tortplﬂﬂe [Port area clearance }
..... | | Tool Pattern

..... B, Machine tool |

..... o Limit

Tool clearance

Cut direction | Climb

Tolerance

Thickness
Stepover

Stepdown

Preview []Draw

| Caleulate | | Queve | | OK | | Cancel |
a Insert Pattern: 4
b Input Tool Clearance: 0.5
k,Workplane =
§h Block [Ramplng ]
|\_f| Tool Ramping

2, Machine tool

W Limit

B@ Port area clearance
k_ Workplane limits

R framping

Slope angle | 10.0

Ramp diameter (TDU)

----- k' Waorkplane
-l Block

----- L.I Taool
..... 2, Machine tool

[-j--@ Port area clearance
2 Workplane limits
@ Ramping

Redori- ]
a Tick Spiral.

b Untick Partial slices.

[Order ]

Order

Machine | Maximum from start v|

Spiral

Partial slices [
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15. Port Machining

6 Calculate and note the following advisory warning message:

P

| Unable to machine all slices.

oK

The message is advising that the Tool is unable to fully machine the form to the
current settings.

Later a visual check with ViewMILL will show that enough material has been
removed to allow the finishing strategies to run.

7 Select OK to the message and wait for the toolpath to finish processing.
8 Close the dialog.
9 Activate Toolpath 1.

10 Right mouse click on toolpath 1 and from the local menu select Simulate from
start.

11 Open the Block dialog and change the Max Z value from 40 to 0 before
selecting Accept.

“& By defining the Block to be half the height of the model it will be possible
to visualise the lower half of the port being machined.

12 Select an ISO 2 view and run a ViewMILL simulation on all of the remaining
toolpaths in sequential order.

13 Activate the SPHR12.5 tool.

14 In Toolpath Strategies select Ports > Port Spiral Finishing and fill in the
two featured pages of the dialog exactly as shown below.
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P Port Spiral Finishing

-
X

Toolpath name | Sphri2_5-PortSpiral

% ‘;‘-l’mtp'a”e [Port spiral finishing W
oc
..... lJ;[l Tool Pattern
----- 2, Machine tool £
1 v
_____ B vl b v R I |52
=R -4 Port spiral finishing Tool clearance
Ig' Workplane limits
‘Gg Merge irecti i
| o Cut direct
LT Automatic verification Vi -
----- \\_- Paoint distribution Joksnce
..... }_—’: Teol axis
----- #) Machine axis control :
[J--E" T — Thickness
@171 Leads and links @r
e‘f Start point 5
G‘-? End point Stepover
#-fir Feeds and speeds T
----- El History : -
----- ] Motes and Description
..... & User defined settings e
Preview [] Draw
Calculate Cueue oK Cancel
If_, Workplane [Merge }
- Block
|J;L| Tool Merge
- [IB, Machine tool Merge point
8 Limit
[—]--iﬁ Port spiral finishing Lift start | 100

~.. 12 Workplane limits

Overlep
Litheight

The above Merge settings enable the thickness to gradually increase as it
merges into the areas previously machined from the first end. This is to
compensate for the cutter tending to dig in when the loading decreases.

...Th Automatic verification
4% Point distribution

In this case a Lift height of 0 has been applied.

15 Select Calculate and once the toolpath has been created select Cancel.
16 Perform a ViewMILL simulation on the latest toolpath, Sphr12_5-PortSpiral.
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15. Port Machining

Note the 0.3mm step where the machining from the second end of the port has
gradually moved away from the form over the last 10mm to the blend point.

If the Lift Height is O then there will not be a visible step appearing on the
toolpath running from the second end.

There is however a high risk of the Tool digging into this area if this Toolpath
was to be run on the machine tool.

17 Select File > Save Project.
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Twin Port Example

Only one Port at a time can be processed within the Port machining strategies. For
this example, 2 reference surfaces have been created to blank access to the extra
port while applying the Port machining strategies to the remaining single Port

setups.

1 Select File > Delete All and Tools > Reset Forms.

2 Open the read only Project:

..\PowerMill_Data\five_axis\Ports\DualPort_Start

3 Save Project As:
«\COURSEWORK\PowerMill-Projects\DualPort-ex1

N o o b

Activate the existing toolpath RghPort-3Axis to reinstate all the settings.
Activate the BN16 tool.
Calculate a new Block to the full Model dimensions.

In Toolpath Strategies select Ports > Port Area Clearance and fill in the

pages of the dialog exactly as shown below.

| P Port Area Clearance

aila

? X
i Toolpath name | Bn16-RghPort |
----- 1z, Workplane [Port area clearance 1
il Block
..... |;| Tool Pattern
Tool clearance
Cut direction | Climb
Tolerance
..... 3 Paint distribution
..... B Tool axis -
----- @ Machine axis control T :
[]..g Rapid Moves &
w17 Leads and links .
..l Start point Stepover
61? End point -
o111 Feeds and speeds al
..... & History
----- [ Notes and Description AEpzoay
----- E User defined settings

Preview [ Draw
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15. Port Machining

8 Switch on the Level named reference.

EI@’ Levv.;_ls_aﬁd Sets

S ‘£ InletPort

“H

’@ reference

“H

L

9 From the Port Area Clearance main page, select the Component Thickness
4]
icon .

P Component Thickness 7 *

Surfaces  Verification Surface Defaults

Entity Clone

Bn16-RghPort o

f% t}g [ Use &ial Thickness

Machining Mede Thickness

Set  Mode Thickness  Axial Total Thickness  Total Axial
S0 Machine
S Ignore
32 Machine 0
33 Machine 0
'{%4 Machine 0
0
0
0

0
0

@5 Machine
@6 Machine
&7 Machine
X Machine

cocoocooocofGtlo

Apply Accept Cancel

10 In the Component Thickness dialog, select and acquire the left hand reference
surface (Shaded purple above right) to a row with the Machining Mode set to
Ignore.

11 Apply the dialog.

..... Workplane i

% Block Ramplng }
..... I‘_’I Tool Ramping

----- 2, Machine tool Slope angle | 10.0

..... o Limit

E—:I@ Port area clearance Ramp diameter (TDU)

----- lf, Workplane 0 ]
rder
-l Block

----- |_| Tool Order
----- &, Machine tool
----- W Limit

[—]@ Port area clearance Spiral [
E, Workplane limits o
-k Ramping Partial slices (]

Machine | Maximum from end v|

12 In the Order page tick Spiral.
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..... k Workplane

gl Block

..... U Tool

..... fi2, Machine tool

..... o8 Limit

[_j.-@ Port area clearance
E Workplane limits

T Automatic verification
..... £ Point distribution

..... * Tool axis

----- # Machine axis control
AT i Mover

g Cylindrical safe area

[]--II! Leads and links

ﬂ Start point
ﬁ End point
- Feeds and speeds

----- ] Motes and Description
..... 2. llcer defined <ettinas

Safe area
Type| Cylinder v|
Workplane TOP-CENTRE v
Position
[00 | [-850 | [-70.000326 |
Direction

o e e @

Rapid radius | 153.26564
Plunge radius | 148.26564
Polygonisation tolerance

Calculate dimensions

Measured from | Block and Model W |

Rapid clearance
Plunge clearance

Draw rapid surface [ ]
Draw plunge surface ]

ICaIcula‘leI | Queue | | 0K | | Cancel |

13 Calculate the Port area clearance dialog.
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15. Port Machining

14 Activate the SPHR25 tool.

15 In Toolpath Strategies seclect Ports > Port Spiral Finishing and fill in the
pages of the dialog exactly as shown below.

P Port Spiral Finishing

]

*

Toolpath name ‘ Sphr23-FinPort

k_ Workplane
- il Block
‘J;L, Tool

B, Machine tool
.08 Limit
[-]p{ﬁ’ Port spiral finishing

Ia:, Workplane limits

4% Point distribution
E Tool axis

- Machine axis control
[]--:_r(f Rapid Moves

[]..]I Leads and links
e? Start point

e? End point

G-fqr Feeds and speeds
.5 History

-.[=] Notes and Description
E. User defined settings

[Port spiral finishing

Pattern

ﬂ_1

Tolerance

Thickness

Stepowver

= | 5.0

Stepdown

Preview

| Calculate Queue

g
=

S
Tool clearance

[JDraw

oK | . Canc_el .

[_]\é’ Port spiral finishing

o qeroe

------ T Automatic verification
..... <3 Point distribution

----- k Workplane Merge

-l Block

..... lJ_l' Tool Merge

..... 2, Machinetool Merge point 500
..... s Limnit

Lift start | 10.0

Overlap 10.0

Lift height | 0.3

16 From the Port Area Clearance main page, select the Component Thickness

icon .
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15. Port Machining

17 As shown in the following diagram, Clone the Component Thickness

settings from the previously created toolpath BN16-RghPort.

P Component Thickness ? X

Surfaces  Verification Surface Defaults

Entity Clene

Sphr25-FinPort v BN16-RghPort
N
.E% u [JUse Axial Thickness

Machining Mode Thickness

o0 | 2k

Set Mode Thickness  Axial Total Thickness  Total Axial z
30 Machine 0 - 0 - 0

W1 Ignore 0 0 |
@2 Machine
@ 3 Machine

0
0
54 Machine 0
0
0
0

@ 5 Machine
@ & Machine
Q%T Machine
K Machine

===~ - = ]
=R =T = = I = I =]

Apply Accept Cancel

18 Apply and Accept the Component Thickness dialog, and then Calculate the
Port spiral finishing strategy.

19 Activate Workplane mc-OUTPUT.
20 Activate Boundary 1.
21 Calculate a Block - Defined by - Boundary and Type - Model.
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15. Port Machining

22 Change the Max Z value to -75.0.

23 Select an ISO 3 view, open and run a ViewMILL simulation of all the
toolpaths.

N

24 Note the 0.3mm step where the machining from the second end of the Port has
gradually moved away from the form over the last 10mm to the blend point.

25 Select File > Save Project.
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16. Blisks

Introduction

In toolpath strategies, the Blisks option provides 4 specialist strategies for

machining Impellers.

P Strategy Selector

Preview

Feature Machining
"] Finishing

|E| Drilling
TE Drilling Methods
(ﬂ Ports
L+ Blisks

Impeller Example

1 Select File > Delete All and Tools > Reset Forms.

Favourites % Blade Finishing
o, Blisk Area CI
F"'j 3D Area Clearance o @ 15 .re.a - earance
B '+ I Hub Finishing
533 Ciirve Machining /% Single Blade Finishing

2 Open the ‘read only’ Project:

..\PowerMill_Data\FiveAxis\Blisks\BliskSimple_Start

3 Select File > Save Project As:
«\COURSEWORK\PowerMill_Projects\FiveAxis\Blisks\Blisk_Example

4 Activate Workplane 1.
5 Create a Cylindrical Block to the Model dimensions.
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16. Blisks

6 Calculate the Rapid Move Heights.
7 Set both Start and End Points to First/Last Point Safe.

8 In the Leads and Links dialog, set 1stand 2nd choice, Links to Short/Long
Skim and Default Incremental.

To be able to apply the Blisk machining options the component surfaces must first
be acquired to a series of specifically named levels. In this example the surfaces in
the imported model are already acquired to appropriate levels.

HUB RH ELADE LH BLADE SHROUD

9 Activate the existing Ball Nosed tool named BN25.

10 From the main toolbar, select Default Thickness ==l and in the Thickness
Preferences dialog, select the Surface Defaults tab.

P Thickness Preferences ? #
Surfaces Verification Surface Defaults
Clone

By @ @ % [] Use Avial Thickness

Machining Mode Thickness

&

Set  Mode Thickness  Axial Components

Cloe o S

31 Machine 1] 1]

32 Machine 0 0

3£3  Machine 0 0

3+£4  Machine 1] 1]

3£5 Machine 0 0

36  Machine 0 i}

37  Machine 1] - 1]

# Machine - - 143

Apply Accept Cancel

11 Select the single Shroud Surface and acquire @ it to the first row in the
above dialog.

12 Set the first row to Machining Mode - Ignore and Apply the settings, before
closing the dialog by clicking Accept.

13 In the Leads and Links options input Moves and clearances set the Axial
clearance to 15, and set Planar skim moves to Plane - Safe Area.
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14 For both Lead in and Lead out, input 1st choice - Extended move 10 and
2nd choice - Surface normal arc - Angle 90 and Radius 5.

15 In the Toolpath Strategies dialog, select Blisks and from the four available
options, select Blisk Area Clearance.

16 Enter data exactly as shown below with the Fillets and Splitter Blade options

left blank.
P Blisk Area Clearance 7 X
. Toolpath nare | BN25-RGH-al |

----- 1z, Workplane [Blisk area clearance }

-l Block

..... U Tool Blisk definition

----- & Machine tool Hub  Hub i

----- of L"t Shroud | Shroud e
[—j@ Blisk area clearance

=% Tool axis elevation Ml ke
@ Machining Hlad=s
...... g Automatic verification Left blade | Left Blade i

..... {\’: Point distribution Right blade |Right Blade A

..... E Tool axis .

..... # Machine axis control SR tiade b
[}-j Rapid Moves Machine | One blade ~
[j--]:;[', Leads and links o D Calculate

é’f Start point e

é’f End point Tol

olerance
[y Feeds and speeds
..... E Hi;tor_\,r
.= Not d Descripti
2 otes ar? escn_p ion s
----- £+ User defined settings 1
Stepover
L
Stepdown
Calculate Queue . 0K Cancel

----- 12, Werkplane [Tml axis elevation }
gl Block
----- L| Tool Tool axis elevation
----- = I'\-.’Iac.hmetool From |A\rerage hub normal V|
..... ol Limit
[—j@ Blisk area clearance £ngle | 00

T ool 2 clevaton
; @ Machining

..... l.f; Workplane [M ni }

achinin

--fl Block g
----- |_| Teol Machining
""" Es I'\;.’Iac.hinetool Cut direction |C|imb Vl
..... o8 Limit

[_]@ Blick area clearance Offset | Offset up Vl
; @ Tool axis elevation Method | Parallel v|

B i
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16. Blisks

17 Select Queue in the dialog to commence background toolpath processing.

18
19

20

Activate the existing Ball Nosed tool hamed BN15.

In the Toolpath Strategies dialog, select Blisks and from the three available

options, select Blade Finishing.

Enter data into the pages of the dialog exactly as shown below with the Fillets
and Splitter Blade options left blank.

P Blade Finishing ? X
Toelpath name | BM15-FIM-a1 |
4, Workplane ['Bl'ade finishing ]
-l Block
il .'| Toal Blisk definition
{2, Machine tool Hub EHub |
D%é‘?@'ém Shroud ?Shroud vl
ﬁ Tool axis elevation Fillets i v
& Machining Blades - )
Ty Automatic verification Left blade | Left Blade V|
'l:: i""‘lt Estbs Right blade | Right Blade v|
ool axis )
- Machine axis control Splitter blade | Vl|
[j--g? Rapid Moves Machine | Cne blade v|
AT Leads and link: .
o é S::rtsp}i?nt e Total nurmber | 0 ~ Calculate
ﬁ End point —
[j---ﬁr Feeds and speeds L
=] Motes ar.1d Descrl.ptmn Thickness
E. User defined settings A
&
Stepover
i 50
Stepdown
;Calculate-; ! Queue i | oK . Cancel -;
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_____ 1, Workplane foolaiis levation |
-l Block

16. Blisks

..... U Tool Tool axis elevation
----- [, Machine tool

From | Hub normal v|

Angle | 0.0

..... 12, Workplane Machiing
-l Block

..... U Tool Machining

----- B, Machinetool

Cut direction |Climb v|

- Blade finishing Offset | Merge v
ﬁ Tool axis elevation
M echning

LTy Automatic verification
..... % Point distribution

..... " Tool axis Spiral []
----- @l Machine axis control P
[]—-jI Rapid Moves

Operation | Machine all faces v|

21 Select Queue in the dialog to commence background toolpath processing.
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16. Blisks

22 In the Toolpath Strategies dialog, select Blisks and from the four available
options, select Hub Finishing.

23 Enter data exactly as shown below with the Fillets and Splitter Blade options

left blank.
P Hub Finishing ? x
. Taalpath name |EN15-FINhub-a‘I |
""" J2, Warkplane {Hub finishing }
il Block
..... |\_,| Tool Blisk definition
----- B, Machine tool Hub | Hub -
----- o Limit
Shroud | Shroud (v
L5 v |
,ﬁ Tool axis elevation Fillets i
_ J% Machining Blades
.. T Automatic verification Left blade | Left Blade ~
..... a'\\ Point distribution Right blade | Right Blade =
----- k Tool axis )
----- # Machine axis control pintex back b
[j--:_(‘f Rapid Moves Machine | One blade ~
7! Leads and link
Ly % 5 sar.'| e Total number | 0 Calculate
- Start point
sf End point o
[]---Hr Feeds and speeds e
..... B History
----- ;, Motes ar.|d Descri_ptiun e
----- ¢+ User defined settings
Y
Stepover
Stepdown
i iEE
Calculate Clueue oK Cancel

----- 17, Workplane
-l Block

|_,| Tool
----- 2, Machine tool

=L Hub finishing

[ IE Tool axis elevation

- Jj Machining

[Tool axis elevation

Tool axis elevation

From | Average hub normal v|

Angle

0.0

1& Workplane

il Block

|_| Tool

[, Machine tool

- Limit

95 Hub finishing

5 Tool axis elevation

W coiog

{Machining

Machining

Cut direction

Climb

24 Select Queue in the form to commence background toolpath processing.
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The next stage is to perform a full ViewMILL simulation of all 3 toolpaths.

Before running ViewMILL it is necessary to define the Block as a Triangle model

of the pre-turned, Shroud for an accurate representation of the material prior to
milling.

25 Activate and right mouse click on the toolpath BN25-RGH-al and from the local
menu select the option Simulate from Start.

26 Before starting the Simulation, open the Block dialog and select Defined By >
Triangles followed by select the Load block from file icon.

— =)
Defined by  Triangles A

Coordinate System
Active Workplane - | - |

Limits

27 Browse and select the Triangle file:
..\PowerMill_Data\FiveAxis\Blisks\TurnedShroud.dmt

28 With the complex Block active, switch on a ViewMILL simulation.
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16. Blisks

Der@Beed I uvE @ ¥

29 Select the Play button in the toolpath simulation toolbar and observe the
machining process for the toolpath BN25-RGH-a1l.

30 Continue the ViewMILL simulation on toolpath BN15-fin-al.

31 Continue the ViewMILL simulation on toolpath BN15-finHUB-al.
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16. Blisks

The final image (below) shows the result of a ViewMILL simulation including 17
copies of the toolpaths rotated by 20 Degree increments around Z.
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17. FiveAxisTutorial

17. Five Axis-Tutorial

1 Select File > Delete All and Tools > Reset Forms.
2 Open the (read-only) Project:-
....\PowerMill_Data\FiveAxis\Cowling\Cowling-5Axis-Start.dgk

3 Save Project As:
.....COURSEWORK\PowerMill_Projects\Cowling-5Axis

The Project currently contains 8, 3-Axis Toolpaths.

This has left remaining areas that are either more suited to, or can only be
machined using 5-Axis strategies.

Select an ISO2 view.

5 Activate the toolpath D16TR6-RGH1_step to restore the Block used in the
strategy.

6 Perform a full ViewMILL simulation on the NC Program named 1.
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17. FiveAxisTutorial

The remaining areas that require Five Axis machining include the central pocket
(Swarf Machining), and the intersection between the main form and the 3D run-off
(Embedded Pattern and Surface Finishing).

CeedN (I, WA @ ¥

7 Select the ViewMILL No-Image display option to disconnect it from the
simulation process.

Central Pocket
8 Activate the tool EM12.

9 Select the pocket wall.

10 Select the Toolpath Strategies dialog @ select the Finishing tab.
11 From the list of strategies select Swarf Finishing and then OK.
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12 In the Swarf Finishing dialog enter data exactly as shown below:

P Swarf Finishing

-

Toclpath name | EM12-SwarfPktWall-FIN1

----- k‘, Workplane
-l Block
..... |_| Tool

..... 2, Machine tool

..... 3 Stock engagement

st finsing
g Position

% Gouge avoidance
= Multiple cuts

- ﬁ—: High speed

..... +% Point distribution

----- k Tool axis

----- # Machine axis control
[j--gf Rapid Moves

[j..]:g[: Leads and links
et,’r Start point

e‘{f End point

G- Feeds and speeds

------ T Automatic verification

2 [Swarf finishing

Drive curve

Surface side |Outside V|

Radial offset[ 00 |

Surface joining tolerance

Gouge avoidance

Tolerance

.

Thickness

iy

Preview

Calculate Queue

Minimurm fanning distance

Fan at end on planes[-]
Reverse axis[_]

Follow surface laterals [

Gouge check []

Degouge tolerance

Cut direction
| Climb v]
&
] Draw
OK Cancel

13 For both the Lead in and Lead out input Surface normal arc with Angle 180
and Radius 2, then Calculate the toolpath.

The Swarf Finishing strategy is created as Five Axis by default (The Tool axis
option is set to Automatic). As shown in the above image this results in a wedge of
material remaining on the flat base of the pocket. This can be removed with a
second Swarf Finishing toolpath but this time with the Tool Axis set to Vertical.
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17. FiveAxisTutorial

14 Make a copy of the Swarf Finishing strategy named EM12-SwarfPktBase-
FIN2 but this time set the Tool Axis to Vertical before selecting Calculate.

P Swarf Finishing ? x
Toolpath name | EM12-SwarfPktWall-FIN2 ‘
..... 12, Workplane & [TDD| axis W
- Block
..... |_| Tool Tool axis
..... 2, Machine tool |‘vfertica| ~
..... & Limit

----- 5 Stock engagement
2L} Swarf finishing

g Position

E Gouge avoidance

e Multiple cuts

= High speed
... T Automatic verification
----- \'\; Point distribution Fixed angle
----- o o None 2 NED

----- # Machine axis control

15 Change the 1st choice, Lead in move onto this toolpath to a circular Ramp with
Angle 4, Circle Dia (TDU) 0.65 and Ramp Height 2.

The Pocket is now fully machined.

16 Save (but do not close) the Project.
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17. FiveAxisTutorial

Main Form — Base Intersection
17 Activate the EM5 tool.

18 Select the main form surface (as shown in the above image).

19 Select the Toolpath Strategies dialog @ select the Finishing tab.
20 From the list of strategies select Surface Finishing and then OK.
21 In the Surface Finishing page enter data exactly as shown in the image below.

P Surface Finishing ? s
f Toolpath name |EM5—MainForm-FIN1 |
----- 12, Workplane [Surface finishing ]
gl Block
..... |_| Tool Surface
..... [, Machine tool Surface side
----- o8 Limit
----- ¥ Stock engogement et
[_jU;) Surface finishing
23 Pattern Degouge tolerance
.. Automatic verification
..... 3 Point distribution
----- E Tool axis
; : Tolerance
----- @ Machine axis control
[#-=1 Rapid Moves el
- 01 Leads and links
é’_! Start point Thickness —
QE End point é....D- &
({5 Feeds and speeds S i
""" & History o Stepover (Distance)
----- =] Motes and Description
z. User defined settings Al 0212132
|“ Preview | [1Draw
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17. FiveAxisTutorial

22 Select the Tool Axis page and again enter data exactly as shown in the image

below.
P Surface Finishing ? *
Toolpath name. | EMS-MainForm-FIN |
..... 12, Workplane [TDD' axis }
-l Block
..... |_| Tool Tool axis
----- 2, Machine tool |Lead)’Lean ~
..... o Limit Lead/Lean angles
----- 3 Stock engagement Lead Lean
- Surface finishing %00 |
.78 Pattern
T Automatic verification
----- Q- Point distribution Made | Contact normal V|

----- D oo

----- # Machine axis control

23 Select the Pattern page and again enter data exactly as shown in the image

below.

P Surface Finishing

? pod

Toolpath name | EM5-MainForm-FINT |

k Workplane
-l Block
|_| Tool

{8, Machine tool
-8 Lirmit

.3 Stock engagement
[_]Lb Surface finishing
i T Automatic verification
\\_o Point distribution

}_»: Tool axis

-.{# Machine axis control
[]--gf Rapid Moves

-1 J1 Leads and links

et_f Start point

-4 End point

[-fqr Feeds and speeds

.5 History

E] Motes and Description
z, User defined settings

[Pattern }

Pattern

Pattern direction

Spiral (]

Ordering |'Clr1EWF!:-r v|
Start comer |MaxUmaxV |
Sequence | None v|

Lirnits (Distance)

kAU v
Start | 60.0 | [02 |
End [ 1675 | [27 |
Preview [ ] Draw

& The values shown in the above page were finally arrived at after a trial
and error process. The actual values are unit distance along and across
the surface, curve network (U V).

24 Select Preview to visualise the defined pattern on the surface.
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17. FiveAxisTutorial

25 Select Calculate to process the toolpath.

& To help visualisation the above images show the preview with a larger
area and stepover than specified in the instructions.

|
26 From the main toolbar select the Leads and Links dialog. EJ

27 For both Lead in and Lead out, apply 1st choice as Vertical arc - Angle 90 -
radius 2 and 2nd choice as Vertical arc - Angle 90 - radius 0.5.
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28 Make a copy of the Surface Finishing toolpath and rename it as EM5-
MainForm-FIN2.

P Surface Finishing T *

. Toolpath name | EMS-MeinForm-FINZ |

111 Workplane [P }
attern
-l Block

|_| Tool

[, Machine tool Pattern

g Limit Pattern direction
BF Stock engagement
-4 Surface finishing o

..%g Automatic verification e —
\\.v Point distribution ‘ Start corner -
E Tool axis :

(@ Machine axis contral Sequence 2
[j--g'f Rapid Moves
7] Leads and links Limits (Distance)
ﬁ_‘f Start point

e‘;’f End point

[j---ﬁr Feeds and speeds
.5 Histary

=] Motes and Description
E. User defined settings

U v
start [60.0 | [923 ]

End | 1675 [543

Preview [ Draw

29 Modify the original settings in the Pattern page and select Calculate to perform
the same strategy on the other side of the main form.

& The last 2 Surface Finishing strategies deliberately stop just short of the
run-off surfaces. A more accurate, final pass will be created normal to the
run-off surfaces using a separate Embedded Pattern Finishing.

30 Save (but do not close) the Project.
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Final Pass around Main Form - Base Intersection

31 Activate the EM3 tool.

32 Select the main form and pocket surfaces (as shown in the above image).

Name | EM3-SeleSurf

Top[]
Rall Qver [+

Tolerances
Tolerance | 0.01 I
Thickness |0_0 I

fixial Thickness | 0.0
&

= Use Axial Thickness [

Tool

L]j M2 vl

Private

[] Allow boundary to be private

Edit History
Apply edit history on calculation

[[] Limit Boundary

Lirniting Boundary

[] Automatic Collision Checking
Haolder Clearance | 0.0

Shank Clearance | 0.0

Limit| g \,J!

| Apply || Queue || Accept || Cancel |

33 Create a Selected Surface Boundary (with Roll Over ticked).

34 Create an empty Pattern and insert the above Boundary segment into it.

35 Delete the Boundary.

Copyright © Autodesk
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36 Use the Curve Editor to trim the Pattern into 2 segments (Merge if required)
suitable for an Embedded Pattern Finishing strategy.

37 Reverse the Pattern segments as required to produce a Climb Milling direction
(Material to the right of the tool feed direction).

38 Right mouse click on the new Pattern and from the local menu select Edit -

Embed.

P Embed Pattern

Apply

? X

Distance | 0.1

Tolerance

Cancel

39 In the above dialog select Method as Drop with a Tolerance of 0.01 before

selecting Apply.

A copy of the original Pattern 1 is projected down Z onto the model as an
Embedded Pattern 1_1 (contains the surface normal).

40 Select the Toolpath Strategies dialog @ select the Finishing tab.

41 From the list of strategies select Embedded Pattern Finishing and then OK.
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42 In the Embedded Pattern Finishing page enter data exactly as shown in the

image below.

P Embedded Pattern Finishing i X
. Toolpath name [ EM3-FINT |
----- 12, Workplane [Embedded pattern finishing }
gl Block
..... |_| Tool Drive curve
----- B Machine tool
..... o Limit pI iR v I =R
..... 3 Stock engagement
=B\ Embedded pattern finishing Coweriumt
&= Multiple cuts
..T Automatic verification = i
----- Q- Point distribution PATE ARSEAREE G heck [~]
s . ouge checl
..... 1# Tool axis || Degouge
..... # Machine axis contral Degouge tolerance
Ej--j Rapid Moves o
-1 Leads and links
e:j; Start point Tolerance
- End point
G- Feeds and speeds
History Thickness

| Notes and Description
----- E. User defined settings

i

43 Open the Component Thickness dialog and acquire the Main Form surface to

one of the rows.

P Component Thickness

Surfaces  Verification Surface Defaults

Entity

EM3-FIN1 ~

B @ @ % [ Use Axial Thickness

Machining Mode

Ignore w

Clone

Thickness

Set Mode Thickness  Axial Total Thickness  Total Axial #
&S0 Machine 0 0 0
&1 Machine 0 0 - 0
&2 Machine 0 0 0

SE Ignore 0 0 1
84 Machine 0 0 0
85  Machine 0 0 0
&6 Machine 0 0 0
37 Machine 0 0 0
#5  Machine - 0 9

Apply Accept Cancel

44 Set the selected row to Machining Mode Ignore and Apply.

The main form surface is set to be ignored as it would otherwise result in the
toolpath to fragment. This in turn will result in the tool very marginally gouging the
main form surface. If checked both visually and using the gouge checking options

the actual results will be negligible.
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45 Back in the main Embedded Pattern Finishing dialog, open the Tool Axis page
and select Lead/Lean both with a 0 angle.

P Embedded Pattern Finishing

? *
Teolpath name | EM3-FIMN1

|
----- 12, Workplane [Tc-ol axis }
-l Block
..... || Toel Tool axis
..... E Machine tool |LEEE|_-"LEEI"I e
..... o8 Limit Lead/Lean angles
----- 3 Stock engagement Lead Lean
[—j\ﬁ) Embedded pattern finishing m
--#75 Gouge avoidance
L& Multiple cuts
... ¥y Automatic verification Mode | Centact normal V|
----- #» Point distribution
----- D ot

{# Machine axis control

Fixed angle
46 Set all Link moves (1st choice/2nd choice/Default) to Incremental.

& Thisis to prevent the toolpath from linking straight through the main
cowling surface (Component Thickness set to Ignore).

47 Calculate the Embedded Pattern toolpath.

48 Run a full ViewMILL simulation (Final EM3-FIN1 toolpath show below).

49 Save the Project.
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