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Use the following sections to find information on basic modelling 
concepts: 

PowerSHAPE (see page 4) 

User interface (see page 11) 

Intelligent Cursor (see page 52) 

Models (see page 66) 

The coordinate system (see page 111) 

Calculator and measuring (see page 139) 

Objects (see page 162) 

Parameters (see page 178) 
 

PowerSHAPE 
PowerSHAPE enables you to design complex shapes using the 
powerful 3D modelling tools in PowerSHAPE. It is ideally suited to 
preparing models for manufacture; either from scratch or by editing 
a part-complete model, imported from another CAD system. 

PowerSHAPE supports standard Microsoft Windows functionality 
such as cut, copy and paste, drag-and-drop, and rubber-band 
editing of objects. You can also edit any modelling object (such as 
line, arc, curve) by right-clicking and using the context menus. The 
menus contain all the main operations available for the selected 
object. 

 

Power Solution 
PowerSHAPE is integrated with all the other Power Solution 
products. For example: PowerMILL, which prepares NC data to cut 
PowerSHAPE models on a CNC machine tool. 

Basic modelling concepts 
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Over the years, DUCT has grown, from its roots at Cambridge 
University in England, into the market-leading software for the 
design and manufacture of molds, tools, and dies around the world. 

The Power Solution products retain the power and flexibility of 
Delcam’s DUCT5 CAD/CAM system, but with a modern Microsoft 
Windows style interface. The DUCT range of integrated CAD/CAM 
products have been continuously developed for over 20 years. 

 

Ease-of-use 
Ease-of-use is central to PowerSHAPE: 

 You can create most objects with one or two mouse clicks. 

 You can dynamically drag dimensions using an object's editing 
handles to create the desired size and shape. 

 You can also enter discrete dimension values using dialogs. 

 The Intelligent Cursor generates construction lines and 
highlights objects’ snap points and tangencies as the cursor 
passes over an object. 

 

Modelling for manufacture 
PowerSHAPE simplifies the addition of manufacturing features such 
as: 

 chamfers. 

 fillets. 

 split surfaces. 

 draft surfaces. 

The software is designed to handle components with complex 
surface geometry, making it an excellent tool for designing molds, 
dies, electrodes, and patterns. 

 

Surfacing tools 
PowerSHAPE offers sophisticated surfacing tools, including surface 
creation from curves and dynamic surface manipulation, allowing 
quick and easy creation and subsequent modification of the CAD 
surfaces. 

 

Starting PowerSHAPE 
To start PowerSHAPE: 

1 From the Start menu select All Programs.  
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2 Select Delcam. 

3 Select PowerSHAPE. 

4 Select PowerSHAPE 2015 R2. 

After a brief wait, the program starts up. A new large window 
appears on the screen.  

This is PowerSHAPE. 

 
Alternatively, you can double-click the PowerSHAPE icon on your 

desktop  to start PowerSHAPE. 

For advanced start-up options see: 

 Starting PowerSHAPE in different modes (see page 188). 

 Table of PowerSHAPE start modes (see page 190). 

 Memory allocation. 

 Licensing information. 
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PowerSHAPE functionality 
The PowerSHAPE product is available in the following forms: 

1 PowerSHAPE (see page 8) — This is the standard product, 
including wireframe, surface, and solid modelling. 

2 PowerSHAPE Pro (see page 8) includes: 

 rendering 

 triangle modelling 

 assembly modelling 

 drafting, morphing 

 reverse engineering functionality 

 Delcam's unique "Total Modelling" functionality for adding 3D 
artwork and textures to designs. 

3 PowerSHAPE-e (see page 9) is a completely free version of 
PowerSHAPE-Pro.  

4 Delcam Designer (see page 9) is the solid and surface modelling 
companion for ArtCAM JewelSmith. 

5 PowerMILL Modelling (see page 10) provides easy-to-use surface 
modelling tools to prepare models for machining. 

6 PowerSHAPE Companion provides users with functionality for 
creating and repairing 3D solid models.  

7 PartMaker Modeling uses PowerSHAPE to design products from 
scratch and to preparing existing product models for 
manufacture 

The following are also available: 

1 Delcam Toolmaker includes  

 PowerSHAPE Pro 

 toolmaking functionality 

 assembly modelling 

 drafting functionality 

2 Delcam Electrode gives access to the electrode wizard. A copy of 
PowerSHAPE, PowerSHAPE Pro, or Toolmaker is required. 

3 Delcam Drafting allows the creation of drawings with hidden detail 
sections, annotations, and Bill of Materials. 

4 Delcam Crispin SoleEngineer includes: 

 PowerSHAPE 
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 grading wizards 

 heel wizards 

 If you have not purchased a licence for any option, you can 
still try the functionality by running PowerSHAPE-e.  

 

PowerSHAPE 

 
This contains the core functionality, including basic surface, solid, 
triangle, and wireframe modelling. It also includes generating 
engineering drawings using drafting functionality. 

 

PowerSHAPE Pro 

 
This contains: 

 PowerSHAPE 

 Additional triangle modelling features 

 Assembly modelling to connect components together  

 Rendering to creates photo-realistic images 

 Morphing for whole-body edits 

 Total modelling to add wrapped 3D artwork and textures to 
designs 

 Reverse engineering features 
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PowerSHAPE-e 

 
PowerSHAPE-e is a free version of PowerSHAPE-Pro that you can 
use to evaluate design concepts, or share models with your supply 
chain. It is ideal for use in education for CAD teaching or research 
and you can also use it to evaluate PowerSHAPE functionality before 
buying. You can print only small drawings (not full engineering 
drawings) and you cannot export files (for example for 
manufacture) except on a pay-per-use basis. 

 

Delcam Designer 

 
Delcam Designer is a companion for ArtCAM and is intended for 
users designing models from scratch, instead of working from 
imported models.  

Delcam Designer does not include: 

 modelling for manufacture commands (such as creation of draft 
curves and draft surfaces). 

 flattening/unwrapping of curves and surfaces. 
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PowerMILL Modelling 

 
PowerMILL Modelling provides easy-to-use surface modelling tools 
to prepare models for machining. Solids are not available in 
PowerMILL Modelling. 

 

More about PowerSHAPE 
You can find the latest information on PowerSHAPE from the Delcam 
website www.powershape.com. 
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User interface 
Use the following sections to find information on the user interface: 

Screen layout (see page 11) 

Menus overview (see page 12) 

Using the menus (see page 12) 

Toolbars overview (see page 15) 

Using the toolbars (see page 16) 

Status bar overview (see page 30) 

Dialog overview (see page 33) 

Using the mouse (see page 36) 

Using the keyboard (see page 49) 

PowerSHAPE Graphics area (see page 49) 
 

Screen layout 

 
PowerSHAPE uses a Windows-style interface with menus and 
toolbars. The areas of the screen are identified as follows: 

 Menu 

 Main toolbar 

 Sub-toolbars — When you select a button on the Main toolbar, in 
most cases an associated sub-toolbar is displayed. 
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 Graphics area 

 Views toolbar 

 Layers toolbar 

 Status bar 
 

Using PowerSHAPE menus 
You can control most functionality in PowerSHAPE on the menus. 
These expand from the menu bar that is permanently displayed 
across the top of the software. In most cases, functionality that is 
available on the menus is also available from one of the toolbars. 

Clicking on a menu option opens the selected menu (see page 12). 
This contains commands and further sub menus. Options are 
dimmed when not available. 

An arrow  icon shows that a menu option has a sub-menu. 

Using the keyboard 
 Navigate around the menus with the arrow keys to pre-select 

items.  

 Press Enter to select an item. 

 Press Esc to close the menus. 

 Use keyboard shortcuts to open menus. Hold down the Alt key 
and press an appropriate underlined character for the menu. For 
example, Alt+E opens the Edit menu. Combinations of keys are 
indicated using the + key. For example Alt+F+S is the same as 
selecting File > Save.  

 

PowerSHAPE menus 
Use the following links for details of the tools and functions available 
from the menus. 
File Controls model file related tasks such as Open, 

Save, Close, and Delete.  

Edit Provides the Undo/Redo commands and tools for 
handling the clipboard such as Cut, Copy, and 
Paste. It also provides general editing tools 
applicable to most object types, such as Mirror 
and Rotate. 
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View Controls how the models are displayed in the 
graphics windows, providing a range of pre-set 
views. Select View Layout to display the View Edit 
dialog, which enables you to configure the view. 
You can display toolbars using View Toolbars. 

Object Provides tools for creating all the available object 
types, such as Workplane, Surface, and Line. The 
menu option for each type has a submenu 
showing the available creation methods for each 
one.  

Format Provides options to change line types, colours, 
and to assign display levels. Use levels to reduce 
screen clutter on complex models. 

Tools Provides miscellaneous tools including model 
fixing and model analysis. You can also set your 
preferences on how the program operates using 
Options.  

Macro Provides the controls for creating a macro of your 
modelling actions. The macros can be played back 
using Run.  

Module Use this menu to view and open the modules that 
you can run while using PowerSHAPE.  

Window Lists all the open graphics windows and enables 
you to manage them. 

Help Enables you to access help and the Delcam 
websites, and check for updates. You can also 
view the software version and release details in 
the About dialog. 

  

Context 
menus 
(see 
page 
13) 

Right-click an object to display a menu. This 
menu includes the commands appropriate for 
editing the object. Right clicking within a graphics 
window, but away from any objects displays a 
View menu.  

 
 

Context menus 
Display context menus by right-clicking in the graphics window.  

The menu options displayed correspond with what you click on.  
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If you right-click an object, a menu displays the common edit 
options for that object. At the top of the menu, the type, name of 
the object, and the level are displayed. 

 
Right-click in an empty area of the graphics window to display the 
View menu. This menu provides the shading options from the View 
menu and other common options. 
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If a mixture of objects is selected and you right-click one of these 
selected objects, the Selection menu is displayed. This menu 
provides some common edit commands. 

 
 

Toolbars overview 
Toolbars are areas of the screen that contain buttons. Click on 
buttons using the mouse to activate the functionality. In most 
cases, toolbar buttons provide shortcuts to options on the menus. 

The Main toolbar is always visible and is displayed across the top. 

 
The General Edits toolbar is displayed down the side by default.  

 
This is also where the following toolbars are displayed when you 
select a corresponding object, menu item, or button. 
 General Edits 
 Model Analysis 
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 Model Fixing 
 Object Creation 

You can: 

 Display or hide some toolbars according to the functions in use. 
For example the Surface Edit toolbar and the Curve Edit toolbar, 
shown in the image below, are displayed automatically when 
corresponding objects are selected. 

 
 Expand some toolbars using the flyout (see page 29) button to 

display similar items or functions grouped together. 

 Pin (see page 17) some toolbars anywhere on the screen, or 
dock them onto another toolbar using their pins to keep them 
visible when you display another toolbar. 

 Create your own toolbars (see page 19) to contain your favourite 
buttons, menu items, or functions. 

 Display a toolbar as follows: 

1 Right-click on an empty space on any toolbar to display a 
menu of available toolbars. 

2 Select the toolbar that you wish to display from the menu. 

 Display large or small buttons on the toolbars using the Toolbars 
options page of the Options dialog. 

 Reverse the display of the (view and editing) toolbars using the 
Toolbars options page of the Options dialog. 

 Remove some toolbars from the screen by clicking the Close   
button on the toolbar.  

 

Using the toolbars 
To use a toolbar: 

1 Position the cursor over a button. 

2 Left-click the button to activate the function. 

The buttons on toolbars can include: 

 an icon to represent the function  

 a text description 

 a shortcut to a Main menu item 

 flyouts (see page 29) to secondary toolbars. 

Some toolbars change according to the function selected, such as 
the General Edit toolbar. These have specific purposes and do not 
necessarily duplicate main menu options. 
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Pinned toolbars 
A pinned toolbar is always visible. You can move and reposition it 
anywhere on the screen, or dock it with another toolbar.  

Toolbars that are in their default location have the unpinned  
icon. 

 
You can pin the following toolbars: 
 General Edit 
 Model Analysis 
 Model Fixing 

 

Using pinned toolbars 
If you have not used pinned toolbars before, pinned toolbars remain 
in their default location in the software.  

If you have already pinned a toolbar, it displays at its last pinned 
position. 

You can: 

 Reposition a pinned toolbar in the graphics area (see page 18). 

 Dock a pinned toolbar with another toolbar (see page 18). 
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Repositioning a pinned toolbar 
To reposition a pinned toolbar in the graphics area: 

1 Click the pin  on the toolbar you wish to move, for example 
the General Edits toolbar. The whole pin is displayed only when 
the toolbar is in its default position. 

 
The pin icon changes to pinned , the toolbar undocks and 
displays in the graphics area ready to be repositioned.  

2 Click on the title bar of the toolbar and drag it to the required 
position in the graphics area.  

3 Click the pin again to return the toolbar automatically to its 
default location. The pin changes back to unpinned . 

The next time you click the pin on the toolbar, the pinned toolbar 
is displayed automatically in the last pinned position. 

 

Docking a pinned toolbar 
To dock a pinned toolbar with another toolbar: 



 

PowerSHAPE 2015 R2 Reference Help Basic modelling concepts • 19  

1 Click the pin  button on the toolbar you wish to move, for 
example the General Edits toolbar. The whole pin is displayed 
only when the toolbar is in its default position. 

 
The pin icon changes to pinned , the toolbar undocks and 
displays in the graphics area ready to be repositioned.  

2 Click on the title bar of the toolbar and drag it over the edge of 
another toolbar. It snaps automatically into the toolbar area. You 
can also dock a toolbar at the edge of the screen. 

3 Click the pin again to return the toolbar automatically to its 
default location. The pin changes back to the unpinned  
icon. 

The next time you click the pin on the toolbar, the pinned toolbar 
is displayed automatically in the last pinned position. 

 

User-defined toolbars 
A user-defined toolbar is a toolbar that you create to contain your 
favourite buttons, menu items, or functions.  

 Your customised toolbar can contain both menu and toolbar 
items as well as command lines.  

 You can send your user-defined toolbar to other users. 
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 You can group or separate options on your toolbar using the 
Customise dialog (see page 21).  

 You can add your own icons and you can customise buttons to be 
added to your toolbar using the Customise Picture dialog (see 
page 26). 

Using your personal toolbars 
Use the following sections to create and use your own toolbars: 

Create a user-defined toolbar (see page 20) 

Edit a user-defined toolbar  (see page 23) 

Display an existing user-defined toolbar (see page 23) 

Customise buttons for user-defined toolbars (see page 23) 

Sharing a user-defined toolbar and custom buttons (see page 28) 
 

Creating a toolbar 
To create a toolbar: 

1 Right-click on an empty section of any toolbar and select 
Customise toolbar from the menu.  

 
The Customise dialog (see page 21) is displayed. 

2 On the Toolbars tab define your toolbar and select the items you 
want to add.  

3 Click Add to add each new item to the toolbar. 

4 Use the buttons on the dialog to order and organise the toolbar 
items. 

The example below describes adding a block primitive from the 
surface creation toolbar to a new custom toolbar. 

 Select a toolbar and enter a new name, such as Surface items. 
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 Select the Button Size size from: 
 Large 
 Small 
 As Options Page 

 For the Type, select Toolbar. 

 Select the Menu/Toolbar that contains the item you want to add 
to your toolbar, such as Surface/Solid Creation. 

 Select the Item to add, such as the Block Primitive  button. 

 Click Add to add the block to your toolbar.  

 Added items, for example the Block Primitive button, are 
displayed in the added items list.  

 Click OK. 

 
 

Customise dialog - Toolbars 
Use this dialog to define up to four customised toolbars. 

 
Toolbar — Enter a new name for a new toolbar or select an existing 
user-defined toolbar from the list. You can define up to four 
toolbars. 

Type — Select from the following: 
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 Menu — Select this option to add a menu item to your toolbar 
and select the menu from the Menu/Toolbar list. 

 Toolbar — Select this option to add a toolbar item to your toolbar 
and select the toolbar from the Menu/Toolbar list. 

 Command — Select this option to enter your own Command and 
Description to be added to your toolbar. 

Menu/Toolbar — Select the menu or toolbar that contains the option 
you want to add to your new toolbar. 

Item — Select the menu option or toolbar button that you want to 
add to your new toolbar. 

Add Group — Click this button to add a group marker. The group 
marker  icon is displayed in the list of added items at the right of 
the dialog. A group marker shows the beginning of a group of 
buttons, menu items, or commands. On the toolbar, the group 
marker is a toggle button: 

 Hide Group — Click this button to contract the items in the 
group. 

 Show Group — Click this button to expand the items in the 
group. 

Add Separator — Click this buttom to add a separator marker to 
divide up your toolbar items. The separator marker  icon is 
displayed in the list of added items at the right of the dialog. 

Add Gap — Click this button to add a small space between items on 
the toolbar. A gap is displayed in the list of added items at the right 
of the dialog. 

Add — Click this button to add the selected Item to the toolbar. The 
item is displayed in the list of added items at the right of the dialog. 

 Drag Crosshairs — Click and hold the mouse button and drag the 
crosshairs over a toolbar button. The button is added automatically 
to custom toolbar and is displayed on the dialog. 

 Remove — Click this button to remove the item selected in the 
added items list from your toolbar. 

 Move the item up the menu — Click this button to move the 
selected item up the order of items on the toolbar. 

 Move the item down the menu — Click this option to move it down 
the order of items on the toolbar. 
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 Change button icon — Click this button to change the icon for the 
button selected in the added items list. The Customise Button dialog 
(see page 25) is displayed. 

 

Edit a user-defined toolbar 
1 Select Customise toolbar from the context menu, displayed when 

you right-click on an empty section of any toolbar. 

 
2 Select the Toolbars tab on the Customise dialog (see page 21). 

3 Select the toolbar you want to edit from the Toolbar drop-down 
list. 

4 Make your changes. 

5 Click OK. 
 

Displaying an existing user-defined toolbar 
1 Select View > Toolbars > Custom. 
2 Select the toolbar you want to display. 

 

Customising buttons for user-defined toolbars 
When you are creating or editing a user-defined toolbar, you can 
edit and customise buttons. You can: 

 customise an existing button on a user-defined toolbar (see page 
24). 

 create a new button to be added to the toolbar (see page 24). 

 select a new button on the Customise Button dialog (see page 
25). 

 use the bitmap editor on the Customise Picture dialog (see page 
26). 
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Customising a button on a user-defined toolbar 
To customise a button on an existing user-defined toolbar: 

1 On the Customise dialog (see page 21), select the button you 
want to customise in the added list. 

2 Click the Change Button  button to display the Customise 
Button dialog (see page 25). 

3 Select Customise. The Modify option becomes available and a 
small thumbnail of the selected button is displayed.  

4 Click Modify. 

5 Use the bitmap editing functions on the Customise Picture dialog 
(see page 26) to edit the bitmap picture. 

 

Creating a new button for a user-defined toolbar 
To create a new button to be added to a user-defined toolbar: 

1 Display the Customise Button dialog (see page 25). 

2 Select the Picture option. 

3 Select a picture or blank background. 

 
4 Select the Customise option. The Modify option activates and a 

small thumbnail of the selected picture is displayed. 

5 Click Modify. 

The Customise Picture dialog (see page 26) is displayed. 
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6 Use the bitmap editing functions to edit or customise your 
selected button. 

 

Customise Button dialog 
Use this dialog to: 

 enter text to display as the item's button. 

 select a picture to be displayed as the item's button. 

 select a picture to edit or customise using the bitmap editing 
functionality on the Customise Picture dialog (see page 26)  

 change the description of a command. This option is displayed 
only if you have selected Command from the Type list. 

 
Text — Select this option and enter text to be displayed as a button. 

Picture — Select this option and select an icon to be displayed as a 
button. 

Customise — If selected, the Modify button is displayed. 

Modify — Click this button to display the selected picture in the 
bitmap editor on the Customise Picture dialog (see page 26) to 
customise the picture before adding it to a user-defined toolbar.  

Command — The command is displayed and you can edit it. 
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Description — The description for the command is displayed and you 
can edit it. 

 

Customise Picture dialog 
Use the bitmap editing functions on this dialog to customise the 
button selected on the Customise Button dialog (see page 25). You 
can: 

 customise a button on an existing user-defined toolbar (see page 
24).  

 create a new button (see page 24) by selecting a picture or 
background button from those provided.  
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The selected button is displayed as a bitmap on a grid showing each 
pixel, ready for editing. 

 
At the top right of the dialog there is a preview of the button, which 
is updated as you make changes. 

 Undo — Undo the last command. 

 Redo — Reverse the last Undo command. 

 Paste — Click this button to paste the clipboard contents. You 
can copy an image from an image editor (for example MS-Paint), 
copy the image to the clipboard and then paste it this button. 

 Thumbnail — Click this button to use a thumbnail of the current 
model. 

 Brush — Select this option to change the colour of the pixels that 
you drag your mouse over to the selected Colour and Transparency. 

 Dropper — Select this option and click on the bitmap image to 
match the Colour setting to an existing colour. 

 Line — Select this tool to draw a straight line with your cursor. 
Set the Colour and Transparency of the line. 

 Box — Use this tool to draw a box. Set the Colour and 
Transparency of the box. 

 Colour — Use the colour chart to select a colour. 
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 Transparency — Drag the slider between T (transparent) and 
O (opaque). 

OK — Click this button to save the edited image. 

Cancel — Click this button to close the dialog without saving your 
changes. 

 

Sharing a user-defined toolbar and custom buttons 
User-defined toolbars have a name in the format CustomToolbarX. 

Custom buttons have a name in the format ToolbarX_PictureY.bmp. 

To send a user-defined toolbar and its buttons to another user: 
1 Find the user-specific files. They are stored in xxxx\PowerSHAPE 

where xxxx is one of the following: 

 C:\Documents and Settings\[username]\Application Data    (XP 
installation) 

 C:\Users\[username]\AppData\Roaming\   (Windows 7 and Windows 
8 installation) 

 the location that is indicated by your HOME variable. 

 To find the Local config folder (PowerSHAPE), enter print 
app.paths in the command window. 

2 Select the required files. They include: 
 a file that contains the toolbar, for example CustomToolbar1. 
 one or more button files from the toolbar, for example 

Toolbar1_Picture1.bmp. 

3 Email the files to another user, with instructions to copy the files 
into the folder containing their user-specific files. 
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Flyouts overview 
A flyout toolbar is an extended part of a toolbar (see page 15). 

 
Access a flyout toolbar using a flyout button. Flyout buttons have a 
small triangle icon in the bottom right corner. There are two types 
of flyout buttons: 

 Red  icon — Flyouts with a red icon contain mode buttons. 
Right-click on the flyout button to display the flyout toolbar. 
Select a mode button to display the buttons for the mode on the 
toolbar. 

For example, if you select the Model Fixing  mode button 

from the General Edits  flyout, the toolbar displays the model-
fixing buttons.  

 You can cycle through the available modes by repeatedly 
clicking the flyout button. 

 Black  icon — Flyouts with a black icon group similar buttons, 

for example the Offset  flyout. Right-click on the flyout button 
to show the flyout toolbar and click the button you want. The 
most recently used button from the flyout toolbar is displayed as 
the flyout button. 

You can display a flyout toolbar in one of these ways: 
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 Hover your cursor over the flyout button. The flyout toolbar is 
hidden when you move your cursor away. 

 Right-click on the flyout button. The flyout toolbar is displayed 
until you click. 

 

Status bar overview 
The Status bar is displayed at the bottom of the screen.  

 
Use the Status bar to: 

 Set the default drawing plane (see page 111).  

 Set point-locking (see page 137). 

 Display the Intelligent Cursor flyout (see page 56). 

 Display the Grid (see page 136). 

 Enter point co-ordinates (see page 116). 

 Display the Position dialog (see page 119). 

 Display the Calculator (see page 140). 

 Display the Measure dialog (see page 160). 

 Connect/Disconnect the Arm (see page 225). 

For further details, see Using the status bar (see page 30) 
 

Using the status bar 
The Status bar is fixed at the bottom of the screen. 

 
 
Key Object Name Description 

    Temporary 
workplane 

Click this button to create 
or remove a temporary 
workplane. For further 
details see, Creating a 
temporary workplane in 
the Wireframe modelling 
manual. 
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    Workplane Use this list to activate 
and de-activate 
workplanes. You can also 
use it to change the 
name of the selected 
workplane. For further 
details, see Workplane 
list. 

 
  
  

Current Level This displays the level of 
the selected item or the 
level you are working on. 
Use this to change the 
level of the selected 
items. Only named levels 
that appear in the Level 
dialog are displayed in 
this list. 
For further details, see 
View > Toolbars > Levels  

    Principal plane Select a button to set the 
principal plane of the 
current workspace. Each 
button displays the label 
of the axis that is normal 
to the principal plane. For 
example, the button with 
label Z represents the XY 
principal plane. 

  Point lock Toggle this button to 
enable or disable point-
locking when entering 
positions using the 
mouse. For further 
details, see Using point-
locking (see page 137). 

  
 

Intelligent 
Cursor 

Right-click this flyout 
button to display the 
Intelligent Cursor flyout 
toolbar (see page 56). 

   Grid on/off Toggle this button to 
enable or disable the 
grid. The cursor snaps to 
the grid lines Grid when 
positioning objects. 
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  Grid scale View and edit the scale of 
the grid (see page 136) 
when it is enabled. 

  Coordinates  The X, Y, and Z 
coordinates of the cursor 
are displayed 
respectively. 

   Position When you are creating 
objects, click this button 
to display the Position 
dialog (see page 119), 
where there are various 
tools for entering 
positions. 

   Calculator Click this button to open 
the Calculator (see page 
139). 

  Connect/Disco
nnect the Arm 

Use this flyout to connect 
or disconnect an arm 
(see page 225). To 
connect an arm you need 
an appropriate licence file 
and drivers installed on 
your computer. 

   Tol The general tolerance 
variable is displayed. You 
can edit the value. 

  Command 
input 

Use this to: 
 enter data (see page 

32). 
 view previously 

entered data (see 
page 33). 

 display the Command 
window (see page 
33). 

 
 

Using the Status bar to enter data 
There are two ways to enter data. 

 Click in the Command input box. Enter the data and press Enter. 
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 Move the cursor into the graphics window and enter the data. 
The data displays in the Command input box. Press Enter to enter 
the data. 

 

Using the Status bar to view previously entered data 
Click in the Data entry box. 

1 Use the up and down arrow keys on the keyboard to display the 
previously entered data. 

 The up arrow key displays previously entered data upwards 
from the last entry. 

 The down arrow key displays previously entered data 
downwards from the first entry. 

2 If you want to enter any of the data again, press Enter when it is 
displayed in the Data entry box. 

 

Using the Status bar to display the command window 
Move the cursor into the Data entry box and double-click in the box.  

The Command window is displayed. 
 

Dialog overview 
 A dialog is a movable box that is displayed when you need to 

provide information to the software. Dialogs may contain: 

 data entry boxes 

 expandable lists 

 buttons  

 Most operations in a dialog are controlled by using the mouse or 
by using the menus. Some options and functions display other 
dialogs. For example, when you open a model a dialog is 
displayed for you to select a model from a list.  

 Options that are followed by , display dialogs for you to make 
choices and enter details. 

 Click OK to use the new information and close the box. 
 

Text boxes and data boxes 
 

Use these boxes to enter text or numbers. Click in the box, keeping 
the mouse cursor inside the box, then type the characters. The data 
is entered when you press Enter. 
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A value that is defined with a parameter or expression is indicated 
by the use of = in addition to the value. 

For example, if you enter Length as a=20 and Width values as a+35, 
the length and width values will be displayed in the dialog as =20 
and =55 respectively. 

 
 

Drop-down lists 
 

Enter your data in one of the following ways: 

 Click in the box and type in your data.  

 Click the arrow  to expand the box showing any previous 
entries. You can then click on the one you want.  

 

Option menus 
These are displayed as drop-down lists that expand to show a menu 
list. 

 
Click the arrow  to expand the list. Click on an option in the list to 
select it. The menu collapses to display the selected option. 

 

Value box 

 
Increase or decrease the value by clicking the up or down arrow. 
You can also type a new value into the box. 
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Tabs 
Tabs are used in dialogs to show a different work page for each tab.  

The example below shows the tabs on the Calculator dialog. 

 
 

Option selection buttons 
There are two types of option selection buttons. 

 
These buttons are small and placed next to their options. When one 
button is clicked, a dot appears in the button and the other 
previously clicked button pops out. Only one option button can be 
ON at any time and one option button must always be selected. It is 
not possible to have them all OFF. 

 
These options buttons are fully independent. A group of these can 
be any combination of ON and OFF. Click a button to set ON and 
click again to set OFF. 

 

Buttons 
 

Each button displays a unique image or text to represent a 
command. When clicked, the button appears to press-in and the 
associated command is activated. When the command is not 
available, the icon image or text appears grey and the button will 
not press-in when clicked. 

 

Apply button 
 

Click to make the changes required, but to leave the dialog 
displayed. 

When a dialog is displayed, you can click the right-mouse-button in 
the graphics area as a shortcut for Apply or Accept. 
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 Apply has precedence over Accept, so when a dialog has both 
Apply and Accept buttons available, clicking the right mouse 
button is the same as clicking Apply. 

 

OK button 
 

Click to make the changes required and close the dialog. 

 Pressing Enter is the same as clicking OK on a dialog. 
 

Cancel button 
 

This button closes the dialog, discarding any edits carried out on the 
model while it was displayed. 

 

Using the mouse 
The mouse is the main device for controlling the software. You can 
click buttons or objects with or without keyboard modifier keys (Alt, 
Shift, or Ctrl) to alter the way you can create, select, move, edit, or 
view models on the screen. The following terms are used in the 
documentation: 

 Click — Press and release the left mouse button (see page 39). 

 Double-click — Rapidly click the left mouse button twice. 

 Drag — Hold down the left mouse button and move the mouse 
while holding the button down. 

 Move — Move the mouse without pressing any of the mouse 
buttons. 

When other mouse buttons are to be used the required button is 
specified; for example  
 Middle-click  
 Middle-drag 
 Right-click 

The mouse controls such as double-click speed and hit radius are 
set to default values, but can be specified on the Mouse page of the 
Options dialog. 

The cursor that is displayed when you use the mouse indicates the 
operation that you are doing. 
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Context-sensitive cursors 
The cursor that is displayed when you use the mouse reflects the 
operation that is being carried out. Context-sensitive cursors are 
available in the following areas: 

Annotation (see page 37) 

Curve toolbar (see page 37) 

Drafting (see page 37) 

General edits toolbar (see page 38) 

View toolbar (see page 38) 

Other (see page 38) 
 

Context sensitive cursors — Annotation toolbar 

 — Add text along a curve. 

 — Add text (horizontally or vertically). 
 

Context sensitive cursors — Curve toolbar 

 — Stop curve. 

 — Close curve. 

 — Sketch curve. 

 — Select start and end point (composite curve). 
 

Context sensitive cursors — Drafting 

 — Activate view. 

 — View selection. 

 — Drawing selection. 
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Arc and line lengths are displayed on the cursor when creating 
dimensions. 

        
 

Context sensitive cursors — General edits 

 — Limit cut. 

 — Limit point. 

 — Move/copy/stretch (also used for drag-move). 

 — Rotate items. 

 — Mirror items. 

 — Mirror items across a user defined plane. 

 — Mirror items in a wireframe line. 

 — Offset items. 

 — Scale items. 
 

Context sensitive cursors — View toolbar 

 — Zoom to box. 

 — Zoom. 

 — Rotate. 

 — Pan. 
 

Context sensitive cursors — Other 

 — Warning/error. 
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 — Cursor selection/edge-pick hand. 

 — Add component. 

 — Principal plane-lock toggled. 

 — Action not allowed. 

 — Action not allowed, plane. 

 — Action not allowed, arc. 

 — Paste attributes. 

 — Selection filter. 
 

Using the left mouse button 

 
This is the main mouse button for selecting menu 
options, clicking buttons on toolbars and dialogs, 
and for editing model objects. It has different 
effects according to where the cursor is 
positioned. 

You can use the left mouse button: 

 over a menu (see page 39) 

 over a non-active graphics window (see page 40) 

 over an active graphics window (see page 40) 

 on an object (see page 44) 

 in a dialog (see page 41) 

 after a Cut or Copy (see page 48). 
 

Over a menu 

 
 

Single Click highlights and selects menu options. 

 
 

Double Click has no particular effect over menus. 
PowerSHAPE assumes you intended to single 
click. 



 

40 • Basic modelling concepts PowerSHAPE 2015 R2 Reference Help  

 
 

Drag by holding down the left mouse button and 
moving the mouse to move the cursor. You can:  
 Drag the cursor over objects in the graphics 

window to highlight them for selection.  
 Edit and create dimensions by dragging them 

to the required position.  
 Edit objects by dragging their handles.  
 

 
 

Move the cursor over the different options, 
highlighting the ones that are available. You can: 
 Move the cursor over menus to display 

submenus where they are available.  
 Move the cursor over toolbars to display 

flyouts where they are available. 
 Activate construction lines when the intelligent 

cursor is active. 
 Move the cursor along construction lines.  

 
 

Over a non-active graphics window 

 
Single-click in a non-active graphics window 
activates the window. The title of the active 
window is highlighted. 

 
 

Over an active graphics window 

 
Single Click in an active graphics window usually 
signifies an attempt to select an object or to enter 
a position. Click away from any object to clear the 
current selection. 
When entering positions, click away from any 
object to input a position on the principal plane of 
the active workplane. 

 
 

Double-click has no effect unless you are pointing 
at an object. 
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Drag (hold down the Left mouse button while 
dragging) to draw a rubber band box. Objects 
within the box are selected, indicated by their 
yellow highlight colour and handles.  
Note:  
 Any other objects already selected and not 

within the box become deselected.  
 If the box contains no objects, the current 

selection is cleared. 
 When more than one object is selected, the 

graphical handles are not displayed. 
 

 
 

Shift-Drag (hold down the Shift key while 
dragging) draws a rubber band box. Objects 
within the box are added to the current selection. 

 
 

Ctrl-Drag (hold down the Ctrl key while dragging) 
draws a rubber band box. Objects within the box 
are added to the current selection or deselected if 
they are already selected. 

 
 

Ctrl-Shift-Drag (hold down both the Ctrl and Shift 
keys while dragging) draws a rubber band box. 
Objects within the box are deselected from the 
current selection. 

 

Shift-Alt-Drag (hold down the Shift and Alt keys 
while dragging) rotates the view around the X 
axis. 

 
 

In a dialog 

 
Single click to select options and press buttons. 
On slider controls, clicks on the track cause the slider 
to step towards the cursor. 



 

42 • Basic modelling concepts PowerSHAPE 2015 R2 Reference Help  

 
Double-click is not effective on all dialogs. 
Double-click in a text box to select all the text. If you 
then type new text, the selected text is replaced by 
the new text. 
Double-click on an item in a list to select the item and 
accept the dialog. For example, double-clicking a file 
name in the Open Model dialog, accepts the dialog and 
opens the model. 

 
Shift-click (press and hold the Shift key while clicking) 
to select multiple items in a list. All items between the 
last item selected and the current item clicked become 
selected. 

 
Drag slider controls to move the slider button. 

 
 

Using the middle mouse button 
Use this mouse button with keyboard “modifier” keys to control the 
view of your model. It is not used within the dialog and does not 
alter a model’s design. 

 If you have a two button mouse, operations using the middle 
mouse button are available using the other two buttons. For 
further details, see Right-hand mouse button (see page 46) 
and Left and right mouse buttons (see page 48). 

 
Middle-click to Rotate the view, hold down the 
middle button and move the mouse. The model 
turns as if the cursor is pushing and pulling on the 
outer surface of a ball and a ball graphic appears 
over the centre of rotation to show what is 
happening. 
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Middle-click to change Orientation. Position the 
cursor to the side of the model and click the 
middle mouse button. The model will be rotated 
so that you are viewing the model from the 
position of the cursor. 

 

 

Shift+Middle-click to Pan a particular point to the 
centre of the view, hold down the Shift key and 
click the point in the model you want to appear in 
the middle of the view. 

 

Ctrl+Middle-click to Pan a particular point to the 
centre of the view, hold down the Control key and 
click the point in the model you want to appear in 
the middle of the view. 

 

Shift+Middle-click+drag to Pan the view, hold down 
the Shift key and drag the middle button. The 
view follows the mouse movements. 

 
 

Ctrl+Middle-click+drag to Zoom the view, hold 
down the Control key and drag the middle button. 
Moving up the screen magnifies the view. Moving 
down the screen reduces the view 

 
 

Ctrl+Shift+Middle-click+Drag to Zoom to a box, hold 
down the Shift and Ctrl keys and drag the middle 
button. A rubber-band box appears. When you 
release the mouse button, the view zooms to the 
box size. 

 

Shift+Alt+Middle-click+drag (holding down both the 
Shift and Alt keys while dragging) to rotate the 
view around the Y axis. 
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On an object 
When selected, objects are displayed with additional edit handles. 
For example: 

 Lines have key points at each end. 

 Curves have key points on arms extending from the selected 
control point on the curve. 

 Arcs have key points at the centre and at the start and end of 
the arc sector. 

 Workplanes have a “control rectangle” and origin. 

If you drag a key point, only the aspect of the object controlled by 
the point will move.  

To move the whole object, be careful to click on the object itself, 
but away from any of its key points. 

 
Single-click over an unselected object to select it. 
The object turns yellow with its key points shown 
as graphical “handles”. The selected object’s key 
point closest to the cursor when selected becomes 
its anchor point. 
Any other objects already selected become 
deselected. 
If the Intelligent Cursor is ON, the cursor changes 
as you move over objects and current selections. 

 
Double-click to select the object, but also to send 
the command to display a dialog or toolbar 
allowing you to edit the object’s properties. For 
further details, see Modifying an object in the 
Menus and Toolbars manual.  
When entering a series of points (for example, for 
a series of lines or a curve), double click to finish 
the series. A subsequent single click starts a new 
series. 
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Drag a selected object to move it. While the 
button is pressed, the object follows the mouse. 
When you release the button, the Confirm Drag 
dialog is displayed for you to confirm the x, y, z 
coordinates for the move. Although the object 
appears to continue to move with the cursor, the 
coordinates are fixed where you released the 
mouse button. 
Click OK to confirm the coordinate 

 

 The move is relative to the active workplane. 

 

 
Shift+click (hold down the Shift key while clicking) 
to add objects to the current selection. 

 
 

Ctrl+click (hold down the Ctrl key while clicking) to 
add objects to the current selection or deselect 
those already selected. 

 
Alt+click (hold down the Alt key while clicking) to 
create composite curves. For further details, see 
Creating a composite curve by tracing in the 
Wireframe modelling manual.  

 
 

Ctrl+Shift+click (hold down both the Ctrl and Shift 
keys while clicking) to deselect objects from the 
current selection. 
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Ctrl+Drag (hold down the Ctrl key while dragging) 
to copy the selected objects. The copy is dropped 
when you release the mouse button. 
This copy does not overwrite data already on the 
Cut/Copy clipboard. The Confirm Drag dialog is 
displayed where you confirm the x, y, z 
coordinates for the move.  

 The move is relative to the active 
workplane. 

 
 

 

Using the right mouse button 
You can use the right mouse button: 

 Over an object (see page 47) 

 In a text box (see page 47) 

 Over an active graphics window (see page 47) 

 When a dialog is displayed, you can click the right-mouse button 
in the graphics area as a shortcut for Apply or Accept. If Apply 
and Accept are unavailable, clciking the tigh mousse button will 
close the dialog without making any changes. 

 Apply has precedence over Accept, so when a dialog has 
both Apply and Accept buttons available, clicking the right 
mouse button is the same as clicking Apply. 

 
Click with this mouse button to display context 
menus and the calculator. You can also use this 
button to pan, zoom and drag the view. 

 
 



 

PowerSHAPE 2015 R2 Reference Help Basic modelling concepts • 47  

Over an object 

 
Single right click in the active model window to 
display context menus. These contain various 
options including Cut, Copy, Paste and Delete. Click 
over different object types or a blank space to 
display options on the context menu that are 
relevant to the object type. For further details, see 
context menus (see page 13). 

 
 

In a text box 

 
Single right-click in a numeric text box to display 
the calculator. The calculation results are 
displayed automatically in the text box when you 
press the Enter key or move the mouse outside 
the numeric text box. 
In a text box, this displays a context menu with 
options Undo, Cut, Copy, Paste, Delete and Select 
All. You can use these options on the data in the 
box. 

 

Shift+right-click in a numeric text box to display a 
context menu with options Undo, Cut, Copy, 
Paste, Delete, and Select All. You can use these 
options on the data in the box. 

 
 

Over an active graphics window 

 

Shift+right-click to Pan a particular point to the 
centre of the view, hold down the Shift key and 
click the point in the model you want to appear in 
the middle of the view. 

 

Ctrl+right-click to Pan a particular point to the 
centre of the view, hold down the Control key and 
click the point in the model you want to appear in 
the middle of the view. 

 

Shift+right-click+Drag to Pan the view, hold down 
the Shift key and drag the right button. The view 
follows the mouse movements. 
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Ctrl+right-click+Drag to Zoom the view, hold down 
the Ctrl key and drag the right button. Moving up 
the screen magnifies the view. Moving down the 
screen reduces the view 

 

Alt+right-click-Drag to Zoom to a box, hold down 
the Alt key and drag the right button. A rubber-
band box appears. When you release the mouse 
button, the view zooms to the box size. 

 

Ctrl+Shift+right-click+Drag (hold down both the Ctrl 
and Shift keys while dragging the right mouse) to 
rotate the view. The model turns as if the cursor 
is pushing and pulling on the outer surface of a 
ball and a ball graphic appears over the centre of 
rotation to show what is happening. 

 

Shift+Alt+right-click+Drag (holding down the Shift 
and Alt keys while dragging) to rotate the view 
around the Z axis. 

 
 

After a Cut or Copy operation 

 

Ctrl+Alt+Click (hold down the Ctrl and Alt keys 
while clicking) to enter an anchor point for Paste 
Special.  

 
 

Left and right mouse buttons 

 
 

Shift+Alt+Drag (hold down the Shift and Alt keys 
while dragging) to rotate the view around the Y 
axis. 

 
Left-click+right-click to rotate the view, hold down 
both the left and right buttons and move the 
mouse. The model turns as if the cursor is 
pushing and pulling on the outer surface of a ball 
and a ball graphic appears over the centre of 
rotation to show what is happening. 
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Using the keyboard 
The keyboard is usually used to enter information into a dialog. This 
might be when you want to create or edit an object to a specific size 
and position. 

Certain "modifier" keys are also used with the mouse to change the 
way the mouse behaves. For further details, see Using the mouse 
(see page 36). 

There are also a number of keyboard shortcuts that allow you to do 
a variety of operations such as open and close models. For further 
details, see Shortcuts to menu options. 

 

Graphics area 
PowerSHAPE runs within its own window containing: 

 Menus (see page 12) 

 Toolbars (see page 15) 

 Status bar (see page 30) 

 Graphics area (see page 49) 

For further details, see Screen layout (see page 11) and The 
coordinate system (see page 111) 

The graphics area may be: 

 a single modelling window that fills the graphics area. 

 several modelling windows that overlay each other in the 
graphics area. These windows can be placed anywhere on the 
screen, not necessarily within the graphics area. For further 
details, see Window menu overview. 

Each modelling window displays views of a single model. You can 
open as many modelling windows for each model as you like, but 
closing a model’s last window also closes the model. 

 

Modelling windows in the graphics area 
Use the Window menu to control the content displayed in the 
graphics area: 

 Create new modelling windows. 

 Swap between modelling windows. 

 Make a different modelling window active. To do this click on the 
window or select it from the menu. Only one modelling window is 
active at any time and this is indicated by the window's 
highlighted title. 
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 Change the display of modelling windows.  

Use the View menu to: 

 Change the view shown in modelling windows.  

 Increase the visible modelling area by selecting Full Screen or 
Full Screen Preview. 

Displaying modelling windows 
 Use Single window mode (see page 50) to display a single 

working modelling window that fills the whole area. 

 Use Multi-window mode (see page 51) to display several 
overlapping modelling windows.  

 Display several tiled model windows that are tiled vertically or 
tiled horizontally. 

Closing modelling windows 

Click  at the top corner of the window.  

Resizing modelling windows 
Windows have resize handles at the corners and borders. Drag them 
to change the window size. For more information, see your 
operating system documentation. 

Full screen mode 
Use the following typed commands to make PowerSHAPE stretch to 
fill the screen: 

GUI FULLSCREEN ON/OFF removes the taskbar and puts menu 
off the top of the screen. 

GUI PREVIEWSCREEN ON/OFF removes the taskbar, puts menu 
off the top of the screen.and removes all toolbars. 

The menus can still be accessed off the top of the screen. 

 
 

Single window mode 
Click Windows fix/float  to fill the graphics area (see page 49) 
with the active modelling window. To display a different modelling 
window, select it from the list on the Window menu. 

For further details, see Window menu overview. 
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Multi-window mode 
When the modelling window fills the graphics area, click Windows 
fix/float  to display each window in their own frames. These 
modelling windows are moveable and resizable. Each has a banner 
across the top showing the window name.  

Click on the banner (or the border) of a window to bring the window 
to the front of other windows. Drag the banner to move the window 
around the screen.  

For further details, see Window menu overview in the Menus and 
Toolbars manual 

 

Tile vertically 
This displays open model windows vertically so they are all visible 
within the graphics area. The sizes of each window depends on the 
number of windows open. 

 
You can resize and move tiled modelling windows. 

Click the Maximise  button on a tiled window to revert to a single 
window display. 
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Tile horizontally 
This displays open modelling windows horizontally so they are all 
visible within the graphics area. Their individual sizes depend on the 
number of windows open. 

 
You can resize and move tiled modelling windows. 

Click the Maximise  button on a tiled window to revert to a single 
window display. 

 

Intelligent Cursor 
Use the following sections for information on using the Intelligent 
Cursor: 

What is the Intelligent Cursor? (see page 53) 

Construction lines (see page 55) 

Intelligent Cursor flyout (see page 56) 

Entering positions (see page 58) 

Selection (see page 60) 

Using a locked axis (see page 60) 

Editing objects (see page 65) 
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What is the Intelligent Cursor? 
The Intelligent Cursor provides dynamic assistance for its two 
primary functions: 

 Point input — It activates construction lines and labels for 
dragging, snapping and for point creation. 

 Selection — It highlights the object under the cursor ready for 
selection. For further details, see Selection using the Intelligent 
Cursor (see page 60) 

The cursor icon changes to assist you when selecting and editing 
objects. For further details, see Intelligent Cursor construction 
labels  (see page 59) 

 

Using the Intelligent Cursor 
The Intelligent Cursor is enabled by default. You can enable and 
disable the Intelligent Cursor in one of these ways: 

 Turning the Intelligent Cursor off or on (see page 53) 

 Context menu (see page 54) 

 The Mouse page of the Options dialog (see page 54) 
 

Turning the Intelligent cursor on or off 
The Intelligent Cursor is enabled by default. You can enable and 
disable the Intelligent Cursor using the options on the Intelligent 
Cursor flyout (see page 56) on the status bar. 

1 Right-click the Intelligent Cursor  button on the status bar to 
display the Intelligent Cursor flyout. 

 

2 Click the Intelligent Cursor Off  button to disable the Intelligent 
Cursor.  

3 Click the Intelligent Cursor On  button to enable the Intelligent 
Cursor. 
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View context menu 
1 In modelling mode, right-click in an empty space in the graphics 

window to display the View menu (see page 13). 

2 Deselect the Intelligent Cursor option to disable it.  

3 Select it again to enable the Intelligent Cursor. 
 

Mouse page of the Options dialog 
Use the Active option to toggle the Intelligent Cursor. This option is 
selected by default. 

 
The Intelligent Cursor displays in the graphics window: 

 various cursor types 

 construction lines 

 construction labels 

 construction distances  

When you click OK, PowerSHAPE uses the new Intelligent Cursor 
settings. For further details on Intelligent Cursor options, see Mouse 
options. 
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Construction lines 
When you hover the Intelligent Cursor over an important key point 
(one that displays any of the construction labels (see page 59)), 
construction lines are created from that key point. You can now 
drag the cursor along a construction line and see the appropriate 
labels display. Clicking causes the position to snap to that point.  

The following example draws a box: 

1 On the Main toolbar, select the Line  button. 

2 On the Line toolbar, select the Continuous  button. 

3 Click to start a line. 

 
Drag along a construction line and click. 

 
4 Drag along a 90  construction line and click. The line snaps to 

give a square intersection. 

 
5 Drag the cursor down to the original start point and hover. The 

cursor displays End and the construction lines display. 

 
6 Drag along the vertical construction line until Intersection is 

shown. 
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7 Snap to the start and finish with one more click when End is 
displayed. 

 
If the Intelligent Cursor Gridding is enabled, the label On in the 
above diagrams is replaced by a distance from the last point 
selected. For example: 

 
This provides a convenient way to enter accurate dimensions. 

 To disable construction lines temporarily, press and hold the 
Shift key. 

 

Turning construction lines on or off 
The Intelligent Cursor's construction lines are enabled by default. To 

disable construction lines, click the Construction Lines  button 
from the Intelligent Cursor flyout (see page 56) on the Status bar. 
The construction lines are not displayed until they are turned back 
on. All functionality is still available. 

 

Intelligent Cursor flyout 
1 Click  (Status bar) using the right mouse button to display the 

Intelligent Cursor flyout. 

2 Select the Intelligent Cursor option you require. 

 The Intelligent Cursor options are for point entry only (not 
selection). 

 

 Intelligent Cursor on (default) (see page 53). 

 Intelligent Cursor off (see page 53). 
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 Snap to keypoints (see page 57). 

 Snap to centre keypoints (see page 57). 

 Construction lines on/off (see page 56). 

 Click this button to snap the cursor to the nearest node 
instead of the exact point on the mesh. 

3 Click  (Status bar) to return to the default flyout setting when 
you have finished using the Intelligent Cursor options. 

 

Snap to keypoints 
Use Snap to keypoints to detect only keypoints in your model when 
entering points. Anything that is not a keypoint is ignored by the 
functionality in use. On wireframe items the cursor will snap to the 
nearest keypoint. 

When this option is selected, the cursor changes to  as a 
reminder that point entry is restricted to keypoints. 

To activate Snap to keypoints: 

1 Click  (Status bar) using the right mouse button to display the 
Intelligent Cursor flyout (see page 56). 

2 Click  Snap to keypoints. 
 

Snap to centre keypoints 
Snap to centre keypoints is a restrictive option that filters out all 
point input except circle and hole centres. This is particularly useful 
when dimensioning a large number of holes. 

When the option is selected, the cursor changes to  as a 
reminder that point entry is restricted to centre keypoints. 

Any point on the geometry of circles will snap to the centre of that 
arc. For example,  
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1 Hover the cursor over an arc  

 
2 Click to snap the centre of that arc.  

 
It is not necessary to select the centre of the arc directly. 

 This is a useful technique when working with overlapping or 
concentric circles where the centre is not easily identifiable. 

To activate Snap to centre keypoints: 

1 Click  (status bar) using the right mouse button to display the 
Intelligent Cursor flyout (see page 57). 

2 Click  to activate Snap to centre keypoints. 
 

Entering positions using the Intelligent Cursor 
The Intelligent Cursor shows additional information to help you to 
define the position you want when entering positions.  
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When you move the cursor over an object, construction labels (see 
page 59) are displayed by the Intelligent Cursor. These construction 
labels: 

 are shown and hidden as you move the cursor over them. 

 indicate what happens if you click while the label is displayed. 

 make snapping with the cursor more accurate. The labels display 
when key points are within snap range of key positions in the 
model. You can click when a label (see page 59) is displayed to 
snap to the cursor at the labelled position.  

 The Intelligent Cursor (see page 53) is enabled by default. 
 

Intelligent Cursor construction labels 
The labels you may see displayed by the Intelligent Cursor include: 

 End  — Shows that the position will snap to the end point of a 
line, arc, curve, or profile. 

 Mid-point — Shows that the position will snap to a point mid way 
between the start and end points of a line or arc. 

 Centre — Shows that the position will snap to the centre of an arc 
or circle, or hole feature. The name of the feature is also 
displayed. 

 Key-point — Shows the keypoints on curves and surfaces where 
they can be manipulated. The position will snap to the nearest 
keypoint on the object under the cursor (for example, a surface 
patch corner or a curve key point).  This label can also show the 
origin of a workplane. 

 On — Shows that the cursor is on a line and the position will snap 
to a point that lies exactly on the object, but not at one of its key 
points (for example, end, corner, centre points). 

If the Background Grid option is ON, a number representing a 
distance along the object from the last key point visited by the 
cursor is displayed. The values are rounded to the nearest sensible 
value. Zoom out to see coarser increments. Zoom in to see finer 
increments. 
 In 

Shows that the position will snap to a point on the inside of a 
surface patch or a solid face (not one of the keypoints or 
positions along a curve). 

 Intersection 
Shows where two objects cross and that the position will snap to 
the intersection between the two objects under the cursor. 
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 Tangent 
Displays when a tangent to an arc can be made. The position will 
be calculated so that the line or arc being created is tangential to 
the line or arc under the cursor. The position will not necessarily 
be under the cursor. This works whether you are placing a line to 
an arc, an arc to a line or an arc to an arc. 

 End sign  

This displays when clicking will complete a curve or continuous 
series of lines. 

 Closing a curve  

This displays when clicking will create a closed curve. 

 We strongly recommend that you normally work with the 
Construction Level switched OFF. For further details, see 
Format > Levels. 

 

Selection using the Intelligent Cursor 
When the Intelligent Cursor is enabled, objects are highlighted as 
you move the cursor over them. This shows which objects can be 
selected if you click at that point. For further details, see Turning 
the Intelligent cursor on or off (see page 53). 

When several objects are under the cursor and one of them is 
selected, the Intelligent Cursor highlights the next object from the 
database at that position. A click now deselects the selected object, 
selects the highlighted object, and highlights the next one. This 
enables you to select the correct object from the group. 

You can also right-click to display the object's menu and click Next 
Selection to select the next object. 

The Intelligent Cursor option is displayed on the context menu. 
Select or Deselect to toggle the Intelligent Cursor on and off.  
Selecting this option is the same as selecting the Intelligent Cursor 
Active option from the Mouse options page of the Options dialog. 

 

Using a locked axis with the Intelligent Cursor 
The Intelligent Cursor can be an effective tool when used with a 
locked axis. 

 Intelligent Cursor modification keys (see page 61) 

 Creation using a locked axis (see page 61) 

 Dragging on a locked axis (see page 62) 

 Moving points on a locked axis (see page 62) 
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 Snapping to points using a locked axis (see page 63) 
 

Intelligent Cursor modification keys 
The following keys on the keyboard can be used to modify the use 
of the Intelligent Cursor.  

X — Press and hold the X key on the keyboard to lock the X axis 
whilst in any construction mode, dragging objects and moving 
points.   

Y — Press and hold the Y key on the keyboard to lock the Y axis 
whilst in any construction mode, dragging objects and moving 
points.   

Z — Press and hold the Z key on the keyboard to lock the Z axis 
whilst in any construction mode, dragging objects and moving 
points.   

N — Press and hold the N key on the keyboard to move points 
locked on the axis of the normal of the surface. 

 

Creation using a locked axis 
As an alternative to using construction lines during line creation, 
you can use the X, Y, and Z keyboard modifier keys to lock the 
corresponding orthogonal axis. This can be useful for additional 
precision in complex models to control the direction of item 
construction. 

When you are creating in free space, the cursor grids the distance 
along the locked axis as you move the mouse. 

1 Select Line . 

2 Enter a point. 

3 Press and hold down the required X, Y or  Z  key to lock the X, 
Y, or Z axis. 

 You may need to change the plane you are working in to 
lock the required axis. For example, to lock the Z axis you 
need to be entering points in the XZ or YZ plane (not XY). 

4 Move the cursor to create the line to the required length.  
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The example below shows the construction line displaying along the 
X axis, whilst the mouse cursor is above. The potential line creation 
result is displayed at an angle of 25 . 

 
The example below shows a similar mouse position above the x 
axis, but the X key has been held down to force the line creation to 
be locked onto the X axis, despite the cursor position located above 
the X axis. 

 
 

Dragging on a locked axis 
You can drag existing objects along a locked axis, by pressing and 
holding the corresponding keyboard modifier key X, Y, or Z when 
you start to drag. The intelligent cursor remembers where the drag 
started and locks that axis.  

All objects in the selection are dragged along the corresponding 
locked axis, allowing multiple items to be moved together. 

 

Moving points on a locked axis 
When moving points on a power surface, you can use the N 
keyboard key to lock the axis to guarantee the point is being moved 
in a perpendicular direction from the surface. The locked axis is the 
original point's surface normal. 

When you use the N key, the drag point is locked on the axis, 
normal to the surface from where you picked the original point. 

 This does not work if you are using a view that looks down 
the surface normal. Change views to see the point moving 
perpendicular to the surface. 
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In these examples, both corner points on the surfaces have been 
dragged to change their shape from a standard plane. The N 
keyboard key was used for the image on the right to move the 
surface in a perpendicular direction to the surface normal. 

 
The effect is not truly visible until the surfaces are rotated, seen in 
the following rotated examples.  

 
 

Snapping to points using a locked axis 
When pressing and holding one of the keyboard keys X, Y, or Z to 
lock the axis during line construction, drag selected objects or move 
points, you can still move the cursor to a nearby point to snap to it. 
The axis remains locked as the intelligent cursor projects the 
resulting point from the snapped point to the locked axis. 
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The example below shows a plane with a selected corner, ready to 
snap to the centre of the circle in the direction shown by the arrow.  

 
The example below shows the corner point dragged and snapped to 
the circle centre. 

 
The example below shows the corner point dragged to the circle 
centre, but using the X key to lock the X axis.  
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Editing objects using the Intelligent Cursor 
When you start to drag an object, a group of objects or an editing 
handle of an object, the cursor feeds back information about points 
you can snap to. 

The Intelligent Cursor: 

 finds intersections between wireframe items and a surface or 
solid. 

 snaps to the projected intersection of wireframe items and 
surfaces. 

 snaps bezier curves to triangles in a symbol imported as a solid. 
For further details, see STL/DMT options in the Menus and 
Toolbars manual. 

 snaps to triangles in symbols (not applicable to components).  

For further details, see Using the Intelligent Cursor to enter 
positions (see page 58) and Selection using the Intelligent Cursor 
(see page 60). 

 

Object highlighting 
When the intelligent cursor is enabled, objects that you can select 
are highlighted when you move the cursor over them. 

The two keypoints nearest the cursor on a curve are highlighted and 
are displayed as small circles when you move the cursor over them. 
This helps you find them more easily and quickly. The keypoint 
markers display in both creation and edit modes. 

 
For further details, see Selection using the Intelligent Cursor (see 
page 60).  
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Models 
A model is a representation of a “real life” (usually engineering) 
component, built on the computer. You build models from a set of 
geometric objects (lines, arcs, curves, and surfaces) which together 
represent the components. 

You can view a model from any angle and shade it to look very 
similar to the real component. You can also model other properties 
such as weight and volume. 

 

Creating a model 
1 Select File > New from the menu. 

This creates a new model file and opens a new graphics window. 
The new window automatically becomes the active window. The 
window title shows the model name (in this case New_Model) 
and a sequential number. 

2 The first time you save this model, the Save Model As dialog is 
displayed, which prompts you to enter a name for your model. 
For further details, see Saving a model with a new name (see 
page 66). 

 

Saving a model 
When you want to keep your work, 

1 Select File > Save. 

If a model was originally opened with write access, it is 
automatically saved, overwriting the stored version. 

2 For a new or read-only model, you must use File > Save As to 
save the model with a new name. (see page 66) 

 
 

Saving a model with a new name 
When you want to keep your work but don’t want to overwrite an 
existing model, you can save the model using a new name. The 
location of the model you save is defined in the Tools > Options > 
File > Model dialog. As well as the path to the model, the Always 
save and open from outside the database option defines if the model is 
saved inside or outside the database. 

1 Select File > Save As from the menu.  
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2 The dialog that is displayed depends on the setting of the Always 
save and open from outside the database option: 

 When you first use the program, the Always save and open 
from outside the database option is selected by default and you 
automatically use the standard Windows Save As dialog to 
save models outside the database.  

 To save models in the shareddb database, select Tools > 
Options > File > Model and deselect the Always save and open 
from outside the database option. 

Selecting Save As from the File menu now displays the Save 
Model As dialog. (see page 192) 

 
3 Use the dialog to save your model using a new name. 

 If your models are single files and stored outside the 
database, you can display the Save As dialog instead of the 
Save Model As dialog. To do this, select the Always save and 
open from outside the database option. 

 

Checking for corruption 
To spot any corruption as soon as possible after it has occurred, the 
File Doctor is run whenever you save a model. For further details, 
see Tools > Model Fixing. 

If File Doctor finds any problems, you are asked to save the model 
under a new name or run File Doctor in fix mode to correct the 
problem. 

To stop running File Doctor on every save, deselect the Check Model 
Before Save option on the Model page of the Options dialog. 

A set of options is available from the Model page of the Options 
dialog. You can select which ones to use when using File Doctor. For 
further details, see Model options. 
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Closing a model 
1 If you have more than one model open, make active the model 

you want to close by clicking in its graphics window or selecting 
the model from the Window menu. 

2 Select File > Close from the menu. 

The active graphics window closes.  

3 You will be prompted to save changes you have made to the 
model: 

 Click Yes to save the changes to the original file name. 

 Click No to close the file and lose any changes that you have 
not saved. 

4 The model is checked to see if the data can be compressed. If 
the program decides that compression is possible, a dialog is 
displayed:  

 Click Yes to compress the model data and close the file. 

 Click No to close without compressing the model data. 

 To save an edited file to a new filename you need to use File 
> Save As (see page 66). 

 

Other ways to close a model 
A model is also closed if you do one of the following: 

 Close the last open graphics window of the model (by selecting 
Close from the Window menu). 

 Exit the program. 

 Using the File > Close and Zip command. 

In all cases, you are prompted to save any unsaved edits. 
 

Opening a model 
Each model you open is displayed in a separate graphics window on 
the screen. You can also show each model in a number of windows 
and can have up to 20 models open at the same time. 

You can open a model and select its read/write status. 

1 Select File > Open from the menu. 

The Open Model dialog is displayed 

2 Use the dialog to open a model. 

For further details, see Open Model dialog (see page 69). 
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If your models are single files and stored outside the database, you 
can always display the standard Windows Open Model dialog. To do 
this, turn on the Always save and open from outside the database 
option on the Model page of the Options dialog. For further details, 
see Model options. 

 

Open Model dialog 
Use this dialog to open models. 

 
Models — Select a model name from the list. 

If you select any item, you can use the keyboard arrow keys  to 
move to the next model. 

 Models of the form NEW_MODEL_<number> are created 
when File > New is selected. These only appear in the Models 
list if you have system administrator security. 

Filter — When the list of model names becomes very long, it can be 
difficult to find the model you want. Entering a filter reduces the list 
to only those models which match the filter pattern, for example, 
entering a filter of *.vl will list only those models which have the 
extension .vl. 

We suggest that you use a designer’s initials for model name 
extensions. For example, mymodel.vl. 
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The filter is not case sensitive. Entering a filter of *.VL will list 
models that have the extension .VL as well as those with the 
extension .vl. For further details, see Filter options (Menus and 
Toolbars). 

Clear — This clears the text in the Filter box. 

Password — If the model is protected by a password, enter it in the 
text box. 

Read only — If you want to open the model, but prevent it from 
being overwritten, click the Read only box until it shows a tick. 

If you decide to save any changes, you will need to save the model 
under a new name using File > Save As. For further details, see 
Saving a model with a new name (see page 66). 

Check & fix — When ON, File Doctor examines the selected model 
and corrects any errors before opening the model. For further 
details, see Tools > Model Fixing > File doctor (Menus and 
Toolbars). 

Preview picture and properties — If a thumbnail of the model has 
been saved, it is displayed in the top window. Information about the 
model appears in the bottom window, including file dates, size and 
description. 

Browse — This opens models stored as single files and not in the 
database. Click the Browse button to display the standard Windows 
Open Model dialog. Use this dialog to select and open a model. 

Models stored in the directory format and not in the database must 
be imported. 

Search — This allows you to create a filter based on the fields used 
for temporary and vault models. It is only available if you have a 
naming_convention.mac file in your shareddb folder. 

The naming_convention.mac file allows you to save vault and 
temporary models. For further details, see Defining your naming 
scheme (Managing your PowerSHAPE system). 

Click Search to display the Search for files dialog. 

Recover — This button only appears if you select a model that was 
not closed properly, for example, if there was a power failure while 
working on the model. Recover opens the model and restores it 
back to its state before the failure. 

Open — The selected model is opened. If the model you are opening 
is shaded, you can open the model in wireframe mode by pressing 
the  button next to the progress bar on the status bar. 

Cancel — Removes the dialog from the screen without opening a 
model. 
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Starting up PowerSHAPE and opening a model 
When you start up PowerSHAPE at the command prompt, you can 
open an existing model at the same time by typing: 

powershape model_name 
For further details, see Other ways of opening psmodels in 
PowerSHAPE (see page 71). 

 For the above commands to work, you must have FILE OPEN 
IFNONE in your login macro.  

 

Other ways of opening psmodels in PowerSHAPE 
As well as using the File Open command to open models in the 
single file format (.psmodel), you can also: 

 Double-click a .psmodel file. If the program is not running, it will 
start up and then open the model. 

 Right-click the .psmodel file in Windows Explorer and select Open. 
You can open a selection of models in this way. 

 Drag and drop one or more .psmodel files into the program 
window. 

 Double-click a PowerSHAPE.exe shortcut. 

 Double-click a .psmodel shortcut. 

 In a web browser, click on a URL to a .psmodel; for example, 
file://pshape/models/bottle_example.psmodel. You can either open the 
model immediately or download it and open it later. 

 

Recently opened models 
Select the Recent Files option at the bottom of the File menu to see 
the last four models listed. The read or write status when they were 
opened is also shown. 

To open a recently opened model, select the File menu and click the 
model name you want. It will open with the same read or write 
status as last time. 

If the model is not listed or you want a different read/write status, 
use the File > Open option. For further details, see Opening a model 
(see page 68) 
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Recovering a model 
If your PowerSHAPE session crashes, it may be possible to recover 
the model you were working on. When you restart PowerSHAPE, 
after a crash, the following dialog is displayed: 

 
1 Select the models that you wish to recover. You can use Select 

All and Invert to select multiple models. 

2 Click one of the following: 

 OK to recover all selected models in the list. 

 Cancel to cancel the recovery process. All recoverable changes 
will be lost. 

3 Following a model recovery, the recovered model must be saved 
to allow recovery from a second crash. 

 If your model does not contain any post-version 8 solid 
data (Parasolid), the models will be recovered to the 
command before the crash.  

If your model does contain post-version 8 solid data 
(Parasolid), models can only be recovered to the state at 
which the last autosave occurred. 

The time between autosaves is defined using the Time between 
autosaves option on the Tools>Options>File>Model dialog. 
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Closing and opening zipped models 
Files can be compressed to make them take less disk space. This is 
known as zipping a file. By zipping a model, you can save about 
60% of disk space, but it takes longer to open as it needs time to 
unzip. 
To close and zip a model, 
1 Save the model if you haven't already done so. 

2 Select File > Close and Zip from the menu. 

The model file is stored in a zip file and the original file of the 
model is deleted. 

To open a zipped model, 
1 Select File > Open from the menu. 

The Open Model dialog is displayed. 

2 Select the model using the dialog. 

3 If the model is stored outside the model database, click the 
Browse button to display the Open dialog. Use this dialog to 
select and open the zipped model. You may need to select Zip 
from the Files of type menu. 

4 Click Open. 

A copy of the model is extracted from the zip file and stored in 
the same folder as the zip file. While the model is open, any 
changes are saved to the copy. 

 Zipped directory models are opened using File Import. 
When you finish working on the model, you can close it using: 

 File > Close — This saves the copy you are working on and 
deletes the zip file. 

 File > Close and Zip — This adds the copy to the zip file and then 
deletes the copy. 

 

Changing the view of a model 
Each window can contain: 

 a single view of the model. 

 two views of the model splitting the model window vertically. 

 four views of the model splitting the model window vertically and 
horizontally. 
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Each of these views can be from any direction, at any scale, and can 
be parallel, isometric or perspective projections. Surfaces can be 
drawn as wireframe or shaded and objects can be blanked from 
specific views to reduce clutter. 

To change the view of a model: 

 Use the Window menu to create, delete and select windows. 

 Use the View menu commands to alter the view of the model in 
the active window. 

Select View > Layout to display the View Edit dialog which allows you 
to set up customised view arrangements. For further details, see 
View Edit dialog (Menus and Toolbars). 

Select View > Toolbars > Views to display the Views toolbar, which 
provides many options to change the view. For further details, see 
View > Toolbars > Views (Menus and Toolbars). 

 Use the middle mouse button (used with certain keyboard 
modifier keys) to dynamically alter the view by rotating, zooming 
and panning. For further details, see Middle mouse button (see 
page 42). 

 Quick Rotation allows rotation of the selected object when you 
hold down the R on the keyboard and scroll the mouse-wheel. 
The object is rotated about its principal axis by 1 degree for each 
notch on the mouse-wheel.  

 

Resetting a model 
You can delete all the changes you have made to a model since you 
last saved it. 

 Reset permanently removes all unsaved edits from the active 
model. A warning is displayed, but once you click Yes, it 
cannot be undone. 

1 From the File menu, select Reset. A warning is displayed. 

2 Click Yes to lose the edits. The model is reset. 

Click No to keep the edits. The reset command is ignored. 
 

Changing the password of a model 
You can change the password of a model as follows: 

1 Open the model with read-write permissions. 

2 In a graphics window of the model, click in an empty space to 
make sure nothing is selected. 
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3 From the File menu, select Properties to display the File 
Properties dialog 

4 Use the dialog to edit the details and password of the model. 
 

Finding out what a model contains 
You can find out how many objects are stored, details of current 
levels and levels of objects in the selected model. You can edit 
details and information about a model and you can change the 
password of a model. 

From the File menu, click Properties to display the File Properties 
dialog.  

This contains the following tabs: 
 Details 

 Properties (see page 77) 

 Custom (see page 78) 
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File Properties dialog - Details 
The Details page of the File Properties dialog contains information 
about levels and objects for the current model in PowerSHAPE. 

 
The Details page tells you the following: 

 Which levels are turned on and off. 

 The current creation levels for objects. 

 The number of objects of a particular type in the model. 

 The levels on which particular types of objects lie. 

 Totals for objects if they lie on more than one level. 

Some of the information is automatically generated by the program. 
This includes: 
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 Details about when the model was created, last modified and last 
accessed. The length of time that the model has been open is 
also included. 

 Path of the model. 

OK - This removes the dialog from the screen. 

 To print the information that is displayed, right click in the 
dialog and select Print from the popup. 
To save the information that is displayed, right click in the 
dialog and select Save To File. 

 

File properties dialog - Properties 
The Properties page of the File Properties dialog displays information 
about the model.  
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Name - Enter the name of the custom property and click Enter. 
Other parameters now become available and the name is added to 
the custom property list.  

 -Click to add a property.  

 - Highlight a name in the list and click this button to remove a 
name from the list. 

Type - The default property type is Text, but you can also choose 
Date, Number, Yes or No from the drop down list. The custom 
property list is updated to reflect your selection. 

Value - Enter an appropriate value. The custom property list is 
updated accordingly. 

OK - When you have entered all your custom properties, click OK. 

You can enter information in this dialog so that it can be included in 
text on your model or drawing. In addition, you can also use some 
information that is automatically generated by the program when 
you save a model. 

 

File properties dialog - Electrode Properties 
Use Electrode Properties to create setup strings that can be used to 
add custom electrode text to a drawing.  

You can enter information in this dialog so that it can be 
incorporated into text on your electrode model or drawing. In 
addition, you can also use some information that is automatically 
generated by the program when you save a model.  
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Information in this dialog is used when adding an electrode 
substitution string to a drawing template. 

 
Name - Enter the name of the property and click Enter. Other 
parameters now become available and the name is added to the 
property list.  

 - Click to add a property.  

 - Highlight a name in the list and click this button to remove a 
name from the list. 

 - Create a copy of the substitution string. on the Windows 
clipboard so it is ready to paste elsewhere. 
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Remember - Select Yes or No from the drop down list. If you select 
Yes, then the value for that property is automatically entered in the 
Additional Electrode Details dialog The custom property list is 
updated to reflect your selection. 

Value - Enter an appropriate value. The property list is updated 
accordingly. 

OK - When you have entered all your properties, click OK. 
 

Deleting a model 
You can delete unwanted models that are stored in the database. 
Models stored outside the database can be deleted like any other 
file using Windows Explorer. 

1 From the File menu, select Delete to display the Delete Model 
dialog (see page 80). 

2 Use the dialog to delete the model. 

 WARNING: Deleted models are permanently removed and 
cannot be recovered. 

 

Delete Model dialog 
Use this dialog to delete models. 
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Models — Click on a listed model name (to select it) and the item is 
highlighted. If you select any item, you can use the keyboard arrow 
keys  to move the highlight and scroll the list. The graphical 
tooltip displays a thumbnail of the model and file information. 

 

 Models of the form NEW_MODEL_<number> are created 
when you select File > New. These are displayed in the Models 
list only if you have system administrator security. 

Select multiple listed model names to be deleted using the standard 

SHIFT-Click  or CTRL-Click  technique to select them. Move 
the cursor over the selection to see the individual thumbnails. 

Filter — When the list of model names becomes very long, it can be 
difficult to find the model you want. Entering a filter reduces the list 
to only those models which match the filter pattern, for example, 
entering a filter of *.vl will list only those models which have the 
extension .vl. 
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The filter is not case sensitive. Entering a filter of *.vl will list 
models that have the extension .VL as well as those with the 
extension .vl.  

For further details, see Filter options (Menus and Toolbars). 

We suggest that you use a designer’s initials for model name 
extensions. For example, mymodel.vnl. 

Password — If the model is protected by a password, enter it in the 
text box. 

Delete — When you click this button, a confirmation message is 
displayed: 

 
Click Yes to remove the model from the database and return to 
the Delete Model dialog. If the Use Recycle Bin option is selected 
on the Model page of the Options dialog, the model is sent to the 
Recycle Bin (providing the bin is not full). Otherwise, the model 
is permanently removed from the system. 

Click No to do nothing and return to the dialog. 

Close — When you have finished deleting models, click Close to 
remove the Delete Model dialog from the screen. 

 

Finding out information about a model 
You can find certain information about a model, without opening it. 

1 In Windows Explorer, select a psmodel. 
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2 From the File menu, select Properties to display the File 
Properties dialog for the model. 

 
The different tabs display information that is stored whenever a 
model is saved as a psmodel. For example: 

 Date of creation 

 Application name 

 The name of the model and its description 

 Current user as the Author (on the Summary page) 

 Version of PowerSHAPE in the Comments section (on the 
Summary page) 

When opening a psmodel, the following will be read from the 
Windows Explorer's File > Properties dialog and stored by 
PowerSHAPE: 

 title 

 subject 

 author 

 keywords 

 comments 

 last saved by 

 revision number 
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 manager 

 company information 

This information can be used when creating text.  
 

Comparing two models 
You may have two models of the same component and want to see 
what the differences are between the two models. 

1 Open the two models you wish to compare. 

2 Suppose we have the following two models. 

 
3 Click in the graphics window of the model in which you want to 

display the differences. This makes the graphics window active. 

4 In our example, we made Model_1 the active model. 

 

5 Select Model Analysis  on the General edits  flyout. 

6 Click Model Compare on the Model Analysis toolbar. 

7 Use the Model Compare dialog (see page 85) to complete the 
comparison. 
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Model Compare dialog 
Use this dialog to compare models. 

 
Use the following options to control the comparison: 

Primary — Select the model in which the differences are to be 
shown. When the dialog is first displayed the Primary selection is the 
model of the active graphics window. You can change the primary 
selection by selecting the Primary option and clicking another 
graphics window. The icon indicates that a primary model is 
selected. 

Secondary — Select the model to compare against the Primary 
selection in the comparison To select the second model click the 
Secondary option and click in the graphics window of the model you 
want to compare. The  changes to a . 

Surface trimming comparison — You can choose how to compare 
surfaces with trim boundaries and p-curves. There are three 
options: 

Exact — This option finds surfaces with exactly the same pcurves 
and trim boundaries. 

Boundaries — This option finds surfaces with exactly the same 
trim boundaries. Any p-curve not part of a trim boundary is 
ignored in the comparison. 

None — This option treats two surfaces as the same if the 
untrimmed surfaces are the same, even if they have different 
trimmed regions. 

OK — Compares the two models. All objects, which are in the 
primary model and not in the secondary model, are highlighted as 
selected in the primary model. 
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 Objects that are in the secondary model but not in the 
primary model are not shown. To show these objects, simply 
carry out the above steps with the secondary model as the 
primary model and the primary model as the secondary. 

 Warning: Models are compared on the basis of positional 
information (XYZ coordinates) only. Differences, for example, 
in tangent direction, colour and level, are not picked up. This 
is done for reasons of speed. This command can be a useful 
tool to aid comparison of models, but you must use it with 
care and check manually for small differences that the 
command may not pick up. 

 

Finding duplicate objects in a model 
Sometimes, you may have a copy of an object on top of itself. Use 
this command to highlight any duplicate objects in the model. 

1 Click in the graphics window of the model in which you wish to 
find any duplicate objects. This makes the graphics window 
active. 

2 Select objects if you want to find duplicates in the current 
selection. 

3 Click Model Fixing  on the General edits  flyout. 

4 Click  on the Model Fixing toolbar 

The Find Duplicates dialog (see page 86) is displayed. 

5 Use the dialog to help you check if you have any duplicate 
objects. 

 

Find Duplicates dialog 
Use this dialog to find duplicate objects within a model. 
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Model — This displays the name of the model to find duplicates 
objects in. By default, it is the active model. You can choose 
another open model by either clicking in its graphics window or 
selecting it from the Window menu to make it active. 

Examine selected items only — Select this option to find duplicates 
only in the objects which are currently selected. Otherwise, the 
whole model is checked. 

Select first instances — If on, any instance of the object before the 
last is considered to be a duplicate. If off, any instance of the object 
after the first is considered to be a duplicated. 

Find Duplicates Method — Duplicate surfaces are selected depending 
on the two options below. 

All — This selects duplicate surfaces depending on the Surface 
Trimming Comparison option. 

Untrimmed — If all duplicate surfaces are untrimmed, this option 
selects all the duplicates. If some of the duplicate surfaces are 
trimmed, it selects all of those duplicates which are untrimmed. 

In some imported models, each surface is supplied untrimmed 
and trimmed. This command allows you to select all the 
untrimmed surfaces. 

Surface Trimming Comparison — You can choose how to compare 
surfaces with trim boundaries and p-curves. There are three 
options: 

Exact — This option finds surfaces with exactly the same pcurves 
and trim boundaries. 

Boundaries — This option finds surfaces with exactly the same 
trim boundaries. Any p-curve not part of a trim boundary is 
ignored in the comparison. 

None — This option treats two surfaces as the same if the 
untrimmed surfaces are the same, even if they have different 
trimmed regions. 

OK— Closes the dialog. All duplicated objects are highlighted as 
selected and an information box is displayed showing how many 
items are duplicates. 

 For each set of duplicate objects, one is not selected. This 
allows you to operate on all duplicates within a model. For 

example, you can now delete them all by clicking Delete . 
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 Warning: Duplicates are detected on the basis of positional 
information (XYZ coordinates) only. Objects may be selected 
as duplicates even if they differ in level, colour, tangent 
direction, or other non-positional ways. 

 

Tools > File doctor 
This option provides tools to check and repair model files and the 
shared database. File Doctor is automatically opened if there have 
been errors in the session and you try to save an model using Save 
As or Save. This gives you the opportunity to correct errors and will 
help prevent you working with a model that is already corrupt.  

 File Doctor contains powerful tools. If it is used incorrectly, 
serious damage can be caused to your model or to your 
shared database. Consult Delcam Customer Support before 
using File Doctor on the shared database and always make a 
Full system backup before proceeding. Ensure you have back-
up copies or duplicate models before using File Doctor on 
models. 

1 From the Tools menu, select File Doctor to display the File Doctor 
dialog. 

 
2 Use the File Doctor dialog (see page 91) or File Doctor (Advanced 

Mode) dialog (see page 93) to check the model. 

 When a model is recovered a copy of the original is kept. The 
settings that control the action and the location of the copy 
can be changed by editing powershape.con. The default 
settings keep a copy of the original in the temp directory. 
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Using the File Doctor - step by step 

 If you position the mouse in the information window of the 
File Doctor dialog and click the right mouse button, the 
context menu that is displayed includes printing and saving 
options.  

 
1 Ensure that the corrupt model is open. We recommend that this 

is the only model open. 

2 Select Tools - File Doctor to display the standard File Doctor 
dialog (see page 91). 
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3 Click Run. The File Doctor tries to identify the problem and uses 
the dialog to tell you what is wrong with the model. 

 
4 Click Save As. This is the recommended selection so that you 

have a ‘safe’ copy. 

 
5 The dialog that is displayed includes a suggestion of a fix that 

could be applied. 

The type of fix offered by the File Doctor depends on the errors 
that are detected in the model. If possible, File Doctor will offer a 
fix that does not delete model geometry, such as replaying or 
removing the solid history tree. 
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 Whilst replaying a solid history tree can fix some problems, 
it is possible that certain errors could cause PowerSHAPE to 
hang or crash whilst replaying. If this should happen, 

1. Restart PowerSHAPE. 

2. Reload the model that was saved before the fix (step 4). 

3. Run File Doctor and when offered to replay the solid(s), 
choose No. 

4. You are now offered the choice of keeping the surface 
geometry (but losing the solid history tree) or keeping as 
much of the history tree as possible (but losing some 
features from the tree). 

6 At the end of the process, File Doctor will tell you the geometry 
(if any) that had to be deleted to fix the model. 

 
7 Click Close to exit File Doctor. 

8 Check the model carefully and save it if you are satisfied with the 
fix.  

 Recovery from a crash is not possible until you have saved 
the fixed model. 

 

File Doctor dialog 
The standard version of the File Doctor dialog displays problems that 
are found with the model and suggested fixes. 
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The initial layout of buttons is shown. The buttons that are initially 
shown as Run and Advanced will change depending on the stage of 
the process. 

The following buttons may be displayed at the bottom of the dialog: 

Run - Start File Doctor check on the current model. 

Advanced - Switch to advanced version of the File Doctor and 
display the File Doctor (Advanced Mode) dialog (see page 93). This 
mode gives full control over the checks and fixes that are run by the 
File Doctor. Only experienced users should use this option. 

Save As - Save the model under a new name before proceeding with 
the File Doctor fixes. 

Skip Save - Skip saving the model under a new name and move 
onto the fixing stage of the File Doctor. 

Yes - Apply the possible fix. 

No - Skip the fix. 

Keep geometry - Fix a solid by maintaining surface geometry but 
removing the solid feature tree. 

Keep history - Fix a solid by removing features with errors from the 
feature tree. 

Reset - Reload the model that was saved before the File Doctor fix. 
This option is only available if the model was saved before the fix. 

Close - Finish File Doctor. 
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 If you position the mouse in the information window of the 
File Doctor dialog and click the right mouse button, the 
context menu that is displayed includes printing and saving 
options.  

 
 

File Doctor (Advanced Mode) dialog 
File doctor allows you to recover damaged models which would 
otherwise be unusable. If you would prefer to use the standard File 
Doctor dialog, type Standard in the command input box on the 
Status bar. 
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 - Options from this menu automatically turn on 
the checks on the dialog. Use this menu to select one of the 
following: 

Quick Check of Model - This selects only the Integrity check in the 
Quick Model section. 

Full Check of Model - This selects the Integrity check and all the 
checks in the Full Model section. 

Check Shared Database - This selects the Integrity check and all 
the checks in the Shared Database section. 

User-defined - This allows you to select any check. It is also 
selected if you change the checks after selecting one of the three 
options above. 

Quick Model - This section contains the following check: 

Integrity check - This checks if any objects within the model refer 
to missing objects and explicit indexes. 

If you select Check, an information window is displayed showing 
a list of errors. You will be alerted to any missing indexes. 

If you select Check & Fix, the objects containing errors are 
deleted from the model. File Doctor displays an information 
window, showing the list of faults (if any) within the model that 
have been cured and any missing indexes that have been 
created. However, under some circumstances (such as where 
many objects refers to a missing object), automatic fixing can 
cause considerable damage. We therefore recommend that 
Check & Fix is used only when you have made a backup copy of 
the model. 

Replay active solid (slow) and Replay all solids (very slow) allow you 
replay the solid feature trees. 

Full Model - This section contains the following checks: 

 Rebuild indexes - All models contain index files. This option clears 
the model indexes and builds new ones, but only when Check & 
Fix is clicked. There is no Check option for indexes. 
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 Rebuild Graphical Reps - ensures that each object geometry 
definition has a matching and valid graphical representation. The 
option is only available under the Check & Fix option. To explain 
what it does: 
Each object in PowerSHAPE (such as lines and arcs) has two 
main components. These are the geometry definition and the 
graphical representation. The latter describes how the object is 
currently displayed in the various views on the screen. It can 
sometimes become corrupted (e.g. missing or incorrect) while 
the geometry definition is correct. Typical problems are that the 
object displays incorrectly or not at all or is not selectable. 

 Rebuild General Attributes - If you choose Check, you are told if 
there are any errors in the styles of the objects. If you select 
Check & Fix, the styles with errors are replaced with a solid, 
foreground colour and width 0.3 style. 

 Dependencies - If you choose Check, you are told if there are any 
errors in surface and vector dependencies. Dependencies are 
relationships between geometric objects. For example, a solid 
block or cylinder has a relationship between the main surface 
and the two capping surfaces. Surface primitives have 
dependencies between the surface and the set of parameters (for 
example, length and diameter) that define them. 

If you select Check & Fix, File Doctor deletes any bad 
dependencies. 

 We recommend you first run Rebuild Indexes from this section 
as database table indexes are often corrupt when surface 
dependencies are corrupt. 

With Check & Fix, editing dependencies of some objects may 
alter the dependencies of other objects. We advise you to run 
Check & Fix repeatedly until no further dependency errors are 
reported. 

 Rezone - The model is divided into zones. When an object is 
picked, only the zones beneath the cursor are searched, which 
considerably speeds-up the picking operation. If an object 
becomes incorrectly zoned (as can happen occasionally), it 
displays correctly, but cannot be picked. This option regenerates 
these zones, curing most of the problems associated with 
unpickable objects. It is only available with Check & Fix. 

 Check Drawability - PowerSHAPE should be able to draw (on the 
screen) every object within a model. This option checks each 
object and deletes any that cannot be drawn. This option also 
checks for items that are undisplayable. If the File Doctor is run 
in Check & Fix mode, the undisplayable items are deleted. 
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 Drawability in this context has no connection with "drawing" 
as used in Drafting. 

 Check Surface Trimming - If you choose Check, you are told if 
there are any trimming problems on the surfaces. If you select 
Check & Fix, then PowerSHAPE attempts to repair the surfaces. If 
some boundaries can't be repaired, they are deleted and you are 
told which ones are deleted. 

Select the Check all trimming option on the Advanced File Doctor 
dialog to ignore any previous surface trimming checks and re-
check and fix every surface. 

 Check Names - If you choose Check, you are told if objects have 
duplicate or invalid names. If you select Check & Fix, 
PowerSHAPE renames objects with duplicate or invalid names. 

 Check Arcs - A valid arc has a start, end, mid and centre point 
and each point has a different ID and is owned by the arc. If you 
choose Check, you are told if any arc in the model is invalid. If 
you select Check & Fix, PowerSHAPE deletes invalid arcs. 

 Check Solids - This checks solids and their feature trees for 
corruption. If you select Check & Fix, the corruption is repaired. If 
the corruption is caused by one of the features in the solid tree, 
PowerSHAPE tries to fix this feature. If this is not possible, the 
feature tree for the solid is deleted. 

 Check Assembly Objects - This checks components and 
component definitions for corruption. If you select Check & Fix, 
the corruption is repaired. If this is not possible, data that cannot 
be repaired will be deleted. 

 Check Orphaned Drawing Items - Some model items that are 
displayed in a drawing view but not displayed in model windows, 
such as centrelines, can be orphaned if the drawing view is 
deleted. This option checks for and removes any orphaned 
drawing items.  

Shared Database - This section contains the following checks: 

 Integrity check - This does a full integrity check/fix on the shared 
database. 

 Rebuild indexes - This deletes and rebuilds the shared database 
indexes. These can sometimes become corrupted. For example, a 
hardware or software problem (such as insufficient disk space) 
occurring while creating, saving or deleting a model can cause 
damage. Affected models disappear from the menu list (as if 
deleted) or can appear twice. Regenerating usually solves these 
problems. The option is only available with Check & Fix. 
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 Page Files - rebuilds the page files, ensuring all are correct. It is 
available only with Check & Fix. To explain the purpose of the 
files: 
The database tables keep a temporary copy of their current state 
in page files, from which data is paged in and out from core 
memory. These files can be damaged by a hardware or software 
problem occurring during a database update. The damage will 
affect all Delcam programs which use that database. 

 We recommend that all users stop working with Delcam 
products before any option from the Shared Database section 
is used. 

Simple Fixing -  If ON, simple fixes will be carried out when running 
File Doctor checks. Any corrupted data will be deleted. If OFF, the 
File Doctor will attempt to work round the corrupted data. For 
example, it will attempt to remove a single corrupt feature from the 
solid tree instead of removing the entire tree. Using Simple Fixing is 
more reliable, but it may delete a lot more of the model data. 

Check - This checks and displays a report of any faults found by the 
File Doctor routine(s). 

 The Check only option is more useful to Delcam Technical 
Support staff than to regular users. You may find the errors 
reported rather unintelligible. 

Check & Fix - This checks and repairs the data within the model. 

 WARNING: All errors found by File Doctor are potentially 
serious and could cause the program to crash or malfunction 
(perhaps causing further corruption). You should always 
remove the errors with Check & Fix before continuing. In 
many cases, it works by deleting faulty objects. If this deletes 
large portions of your model, contact Delcam Technical 
Support, who may be able to retrieve some of the lost data. 
However, do NOT continue working on a corrupt model or 
database. 
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Submitting model information 
When a database error is detected a dialog is displayed with a 
request to submit your model and macros to Delcam. 

 
1 Click Yes to create the zip file. It is recommended that you create 

as requested.  

 
2 Click OK to complete the operation. 

3 Send the file to your local Delcam supplier. 

 Note that the date and the time are included in the filename. 

 

 

 
 
 
 
 

 
 

Importing and Exporting a model 
Use the following sections to import and export data: 

Exporting data from a model (see page 98) 

Importing data into a model (see page 104) 
 

Exporting data from a model 
You can export models to formats other than PowerSHAPE. 
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1 Select the model or the specific objects you want to export. 

2 Select File > Export from the menu to display the first page of 
the Export Wizard. 

3 Use the Export Wizard to select the target system and settings 
for exporting files. Alternatively, click Finish to export the data 
using the following defaults: 

 export selected items, or the entire model if nothing is 
selected. 

 if a workplane is active, export the geometry to active, 
otherwise, export to World. 

 if a drawing window is active, export the converted drawings. 

 The default for .dgk is to export to World. You can use the 
Export Wizard to export .dgk to the active workplane.  

For advanced modelling concepts, see: 

 Using Delcam Exchange to translate data (see page 197) 

 Exporting data without a licence (see page 204) 

 Exporting materials (see page 205) 
 

Using the Export Wizard 
Use the Export Wizard to: 

 export selected model items, visible items or all items. 

 export relative to an active workplane or World. 

 export drawings. 

1 Select File > Export to display the Export Wizard. 

 
2 Select the target system for export from the list. 
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3 Click Next to display the Export File dialog. 

The file name of your model is automatically displayed as the 
filename. Change the File name as required and select the file 
type from the Save as type list. 

4 Click Save. The subsequent pages that are displayed depends on 
your export: 

 if you are exporting a model that includes at least one 
drawing, page 2 is displayed (see page 101). 

 if you are exporting a model that does not include drawings, 
page 3 is displayed (see page 102). 

 if your model includes workplanes, page 4 is displayed (see 
page 103). 

 if you are exporting a model that includes mutiple drawings, 
page 5 is displayed (see page 103). 

5 Select the appropriate options on the export pages that are 
displayed. 

6 Click Finish to complete the export. 
 

Export File dialog 
Use this dialog to export files in the format selected on the Export 
dialog. 

 
1 Select the correct Save in folder. If necessary, use the following 

to locate the required folder: 
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 Click  to go up one level in the folder structure. 

 Click  to create a new folder. 

 Click  to display a menu containing options on how to 
display the files in the dialog. 

2 Enter the File name. If you enter a file name with no extension, 
the Save as type extension is automatically added.  

If you enter a filename with a valid export extension, the Save as 
type extension type overrides the type entered in the file's name. 

3 Select the required export file type from the Save as type list (see 
page 198). 

4 Click one of the following: 

 Save to export data as specified. 

 Cancel to remove the dialog from the screen without exporting 
any files. 

 You can use either the PowerSHAPE internal translators or 
Delcam Exchange to export data (see page 197). 

You cannot export badly trimmed surfaces. PowerSHAPE tells 
you if badly trimmed surfaces are detected on export and 
gives you two options: 

 Export the selection with the offending surfaces untrimmed. 

 Abandon the export. This allows you to fix the surfaces using 
the trim region editing tools. 

 

Page 2 - Exporting a model that includes drawings 
Use this page to export a model that includes drawings. 

 
1 Select one of the options to specify the items to be exported: 
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 model geometry only 

 drawings 

 drawings and associated model geometry 

2 Click Next or Finish. 
 

Page 3 - Exporting a model 
Use this page to specify the model items that you want to export. 

 
1 Select one of the options to specify the items to be exported: 

 If you pre-selected some items, then Selected is the default 
option. 

 Visible exports items that are visible on the screen; if an item 
is blanked it is not exported. This option is useful for 
exporting the workplanes with a model. 

 All is the default option and is automatically selected if there 
are no pre-selected items. 

2 Click Next or Finish. 
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Page 4 - Exporting workplanes 
Use this page to specify the workplane to be used at export.  

 
1 Select the option to be used when exporting: 

 Export relative to Active workplane. 

 Export relative to World. 

2 Click Next or Finish. 
 

Page 5 - Selecting a drawing to export 
Use this page to select the drawings to be exported. This page is 
displayed only if there are multiple drawings associated with the 
model. 

 
1 Select the drawings to be exported. 

2 Click Finish. 
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Importing data into a model 
When you import a model, it is automatically opened as a new 
model. However if you import any other file, it is opened in the 
current model window. 

 When you import a file, the model is zoomed to full, so the 
geometry is visible. This is particularly useful if the items are 
not close to the origin. 

You can use one of the following methods to import data: 

 Select File > Import. 
 Click Import (see page 104) on the Main toolbar. 

 Use the Advanced Import options (see page 208) to set up the 
data. 

 Drag and drop files into the graphics area to import them. 

For advanced modelling concepts, see: 

 Advanced Import options 

 Importing data without a licence (see page 216) 

 Importing Materials (see page 218) 
 

Using the Import option 
1 Select File > Import.  
2 Browse to the folder containing the file you want to import. 

 
3 Click Open. 

The file is imported and opened. 
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For further details, see Importing data into a model (see page 104). 
 

Import dialog 
Use this dialog to select files to import. 

 
1 Select the correct Look in folder. If necessary, use the following 

to locate the required folder: 

 Click  to go up one level in the folder structure. 

 Click  to create a new folder. 

 Click  to display a menu containing options on how to 
display the files in the dialog. 

2 Enter the File name.  

3 Select the required import file type from the Files of type list (see 
page 209). 

This displays the filter pattern which filter the file names of the 
current directory. By default, the pattern is *.* which displays all 
files. This selector lists the default filters for the file types that 
can be imported. You can select a filter from the list. When a 
filter is selected, files satisfying that filter are displayed. 

 Files of type is used only to help find files more easily. It 
does not determine the type of file to be imported. When a 
file is imported, the program looks at the contents of the 
file to determine its type and not its name. For example, if 
Files of type is set to *.pic, you can still import an IGES file 
by typing in the name in the File name text box. If an IGES 
file is called file.pic, this filter will help find it, but the file 
will still be imported as an IGES file. 
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When importing IGES files, the program uses its own default 
tolerance values. You can change the defaults on the Options 
dialog before importing. The new values affect only the current 
model. Remember, large tolerances produce poor quality 
surfaces and small tolerances make the application run slowly. 
You may need to experiment to find the best balance for your 
models. 

4 Click one of the following: 

 Open to import data as specified. 

When you import certain files, a log file is generated 
containing details about the import. This log file is added to 
either the directory containing the imported file or the temp 
directory. 

If you import a model that has the same name as one already 
in the model database, its name is appended with [n] where n 
is an integer. The integer starts at 1 and increases as other 
models with the same name are imported. When such a 
model is imported, you need to open it using the Open Model 
dialog. (see page 69) 

Generally, models are automatically opened in the program 
when they are imported. 

 Cancel to remove the dialog from the screen without 
importing any files. 

 If you import files into a new model, the name of the last 
imported file (minus its extension) is automatically displayed 
as the Model Name in the Save Model As dialog when you save 
the model. For example, if the name of the last file imported 
is handle.igs, the Model Name is handle in the Save Model As 
dialog. This name is also displayed in the banner of the 
model's window, next to the new model's name. For example, 
NEW_MODEL_1(handle). 

 You can use either PowerSHAPE's internal translators or 
Delcam Exchange to import data. For further details, see 
Using Delcam Exchange to translate data (see page 197). 

 

What is PowerSHAPE-e? 
PowerSHAPE-e is a free version of PowerSHAPE that enables you to 
design and share your design with others. 

When you are happy with your design, you can export it to another 
application using the voucher system. 
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 Before installing and using PowerSHAPE-e, please check the 
hardware and operating-system requirements on the Delcam 
website (http://www.delcam.com/hardware-updates). 

 

Exporting a model from PowerSHAPE-e 
To export a model from PowerSHAPE-e: 

1 Create your model. 

2 Save your model. 

3 Export your model. 

The Voucher Wizard (see page 108) is displayed. 

When you have purchased a voucher, you can do any number of 
exports of that model; if you change your model, you must buy a 
new voucher. 

 

Importing an e-model to PowerSHAPE 
To import an existing e-model into PowerSHAPE: 

1 Select File > Open from the menu. 

The Open Model dialog is displayed. 

2 Select the file you want to open and click the Open button. 

The Voucher Wizard (see page 108) is displayed. 

 

http://www.delcam.com/hardware-updates
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Voucher Wizard 
Select Tools > Voucher > Manage Account to display the Voucher 
Wizard to manage your account and make a deposit into your 
account. 

Use the pages of the Voucher Wizard to manage your account: 

Registration (see page 108) 

Login (see page 109) 

Account Deposit (see page 109) 

Address (see page 110) 

Card Details (see page 111) 

Deposit Receipt (see page 111) 
 

Voucher Wizard - Registration 
The first time you use the Voucher Wizard the Registration page is 
displayed.  

 
1 Enter the details requested. When you have entered information, 

the Next button becomes available. 

2 Click Next to display the Login page (see page 109). 
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Login 
To see your remaining credit, or purchase additional vouchers, you 
must connect to the Voucher Server. 

 
1 Enter your password. 

2 Click Next to display the Account Deposit page (see page 109). 
 

Account Deposit 
Use this page to buy additional vouchers. The table helps you 
calculate the bonus credit you will acquire (if any), based on the 
amount of your deposit. 
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1 Enter the amount of credit you wish to purchase and select the 
currency.  

2 Click Next to display the Address page (see page 110). 
 

Address 
Use this page to enter your address. 

 
1 Enter your name and address details in the dialog. 

2 Click Next to display the Card Details page (see page 111). 
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Card Details 
Use this page to enter your card details. 

 
1 Enter your card details. The amount of money you asked to 

deposit in your account on page 2 of the wizard is displayed 
below the Currency list. 

2 Click Next to display the Deposit Receipt page (see page 111). 
 

Deposit Receipt 
A confirmation is displayed. This shows the amount of credit you 
have purchased, your balance, and order reference number.  

You can print a copy of the information on the page. This is your 
receipt. 

 

The coordinate system 
The coordinate system defines the position of every object within 
the global workspace. The coordinate system contains the three 
axes X, Y, and Z which meet in the centre of the workspace, at a 
position called the origin.  

All models are created within the global workspace. Every position 
in a model is defined as three coordinates. For example, a position 
of 9,5,3 means 9 along the X axis, 5 along the Y axis and 3 along the 
Z axis. These coordinates are shown in the image below: 

 X = 9 
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 Y = 5 

 Z = 3 

 Position 9,5,3 

 
You create a model while working entirely within the global 
workspace, selecting the default drawing plane (also known as the 
principal plane) and entering coordinate values when necessary.  

However, models can contain many angled faces and it is often 
easier to specify coordinates relative to a face rather than to the 
model as a whole. You can do this using workplanes (see page 
112), shown in the image below: 

 Dimensional axes X,Y,Z 

 Origin 

 
For further details, see Creating a workplane in the Wireframe 
modelling manual. 

 

Workplanes and the coordinate system 
A workplane is a graphical object defining a local coordinate system.  
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You can:  

 have as many workplanes as you like. 

 place workplanes anywhere in the model. 

 rotate the axes to align conveniently with features of the model. 

The image below shows example of a local coordinate system: 

 
 Local coordinate system (Workplane). Convenient for: 

 Face D. 

 Angled feature E. 

 Local coordinates 20,0,0. Global coordinates 437,62.8,28.7 

 Global workspace coordinate system for faces A, B, C. 

 Local coordinate system (Workplane). Ideal for faces A,B,C 

Only one workplane can be active at a time, which is known as the 
active workplane. It is shown in red in the default colour scheme. 
Inactive workplanes are grey. 

Any specified coordinates apply to this workplane, not to the global 
workspace. PowerSHAPE converts the local values to global values 
automatically and invisibly. 

The three axes of a workspace listed below define three planes. 
These are known as the principal planes (see page 114). 

 the XY plane lies through the X and Y axes 

 the ZX plane lies through the X and Z axes 

 the YZ plane lies through the Y and Z axes 
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Principal planes and the coordinate system 
The Principal plane buttons  on the Status bar (see page 30) 
define which plane is the principal plane of the workspace. You can 
see this graphically as the axis of the rotation tracker updates in the 
modelling window. When clicking the mouse to enter positions in an 
empty space, the positions lie on the principal plane. 

 Each button displays the label of the axis which is normal to 
the principal plane. 

 

Entering positions 
To create an object, you need to specify its position in the 
workspace. Entering positions is one of the most common and 
important operations use the following methods for entering 
positions:  

Entering positions using the cursor (see page 114) 

Entering positions using the Intelligent Cursor (see page 58) 

Entering positions using the status bar  (see page 116) 

Entering positions using dialogs (see page 118) 

You can also create point objects to mark locations in your model.  
 

Entering positions using the cursor 
As the cursor moves across the principal plane (see page 114) (for 
example XY of the active workplane or global workspace), its 
coordinates with respect to the active workplane are shown in the 
status bar (see page 30). To enter a new position, move the cursor 
and click. 

If the cursor is clicked within a certain radius of an existing object, 
the cursor snaps to the closest key point that exists on the object or 
snaps to a point of intersection between objects. This radius is 
known as the hit radius. 

 

Entering positions using the Intelligent Cursor 
The Intelligent Cursor shows additional information to help you to 
define the position you want when entering positions.  

When you move the cursor over an object, construction labels (see 
page 59) are displayed by the Intelligent Cursor. These construction 
labels: 

 are shown and hidden as you move the cursor over them. 
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 indicate what happens if you click while the label is displayed. 

 make snapping with the cursor more accurate. The labels display 
when key points are within snap range of key positions in the 
model. You can click when a label (see page 59) is displayed to 
snap to the cursor at the labelled position.  

 The Intelligent Cursor (see page 53) is enabled by default. 
 

Construction lines 
When you hover the Intelligent Cursor over an important key point 
(one that displays any of the construction labels (see page 59)), 
construction lines are created from that key point. You can now 
drag the cursor along a construction line and see the appropriate 
labels display. Clicking causes the position to snap to that point.  

The following example draws a box: 

1 On the Main toolbar, select the Line  button. 

2 On the Line toolbar, select the Continuous  button. 

3 Click to start a line. 

 
Drag along a construction line and click. 

 
4 Drag along a 90  construction line and click. The line snaps to 

give a square intersection. 

 
5 Drag the cursor down to the original start point and hover. The 

cursor displays End and the construction lines display. 
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6 Drag along the vertical construction line until Intersection is 
shown. 

 
7 Snap to the start and finish with one more click when End is 

displayed. 

 
If the Intelligent Cursor Gridding is enabled, the label On in the 
above diagrams is replaced by a distance from the last point 
selected. For example: 

 
This provides a convenient way to enter accurate dimensions. 

 To disable construction lines temporarily, press and hold the 
Shift key. 

 

Entering positions using the status bar 
You can enter Cartesian (see page 116) and polar (see page 117) 
positions in the Data entry box on the Status Bar (see page 30). 

You can also type the coordinates in the graphics window and they 
are entered automatically into the Data entry box on the status bar. 
When you press the Enter key, coordinates are entered into 
PowerSHAPE.  

For more complex constructions click the Position  button on the 
Status Bar, to display the Position dialog (see page 119). 

 

Entering Cartesian positions 
The syntax for entering Cartesian positions (using the status bar) is 
as follows: 

[workspace] X [Y [Z]] [units] 
Square brackets [ ] show elements that are optional. 
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workspace specifies the origin from which to measure the 
coordinates. 

You can use the following options: 

 world = world workspace. You can abbreviate world to w. 

 absolute or @ = absolute workspace. This uses the origin of 
the current workspace. You can abbreviate absolute to abs. 

 relative = relative workspace. This uses the last point entered 
as the origin. You can abbreviate relative to re. 

X [Y [Z]] - These are the X Y and Z coordinates and are entered in 
this order by default. If the second and third values are not given, 
they are treated as zeros. 

The order of the X Y and Z coordinates is determined by the Local 
point input option on the Workplane page of the Options dialog. For 
further details, see Workplane options (Menus and Toolbars). 

units - You can enter the type of units, for example, mm or inches. 
Default units are used if none are specified. 

Examples of Cartesian coordinates are given below. 

20 30 40 

w 15 

@ 25 60.8 mm 

abs 50 mm 

re -30.7 0 90 

You can also enter polar positions. For further details, see Entering 
polar positions (see page 117). 

 

Entering polar positions 
The syntax for entering polar positions (using the status bar) is as 
follows: 

> angle [angle_units] length [length_units] 
Square brackets [ ] show elements which are optional. 

> indicates that polar coordinates are being entered. 

angle is the value of the angle. 

angle_units is the unit type, for example, degrees. 

length is the value of the length. 

length_units is the unit type, for example, mm. 

Examples of polar coordinates are given below. 

> 45 30 
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> 45 degrees 30 mm 

> 30 2.5 inches 
You can also enter Cartesian positions (see page 116). 

 

Entering positions using dialogs 
Where a dialog expects a position to be entered, separate text 
boxes for the X, Y, and Z axes are provided. Click the Position  
button to display the Position dialog (see page 119) for more 
complex point entry tools. 

 
To enter a position as three coordinate values directly into a dialog: 

1 Click in the X axis box to select it and enter the value  

2 Press the tab key to select the Y axis box, or click in the box.  

3 Enter the value and repeat to enter the value for the Z axis box. 

4 Click OK on the dialog to store the values. 
 

Position dialog overview 
When it is not sufficient to enter positions using the cursor, the 
status bar, or dialogs, use the tools on the Position dialog (see page 
119) to assist with more complex constructions. For example, you 
may want to specify a point at a particular proportion along an 
object. 

the values for the X, Y, Z axes 

Display the Position dialog (see page 119) using one of the following 
methods: 

 Click Position  on the status bar (see page 30) 

 Click  on a dialog.  

For further details, see Entering positions using dialogs (see page 
118). 

 The Position  button is active only when positions are 
required by the program. For example, when in object 
creation mode or when editing objects. 
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Position dialog 
Use the tools on the Position dialog to specify positions and 
constructions (see page 114). 

 
Click a tab on the dialog to display the relevant page of position 
entry tools: 

Cartesian (see page 119) 

Polar (see page 121) 

Along (see page 123) 

Between (see page 125) 

Intersect (see page 126) 

Normal (see page 128) 

KeyPoint (see page 130) 

Vector (see page 132) 

Circle (see page 134) 
 

Cartesian tab 
Use the Cartesian tab of the Position dialog (see page 119) to enter 
positions in the separate entry boxes provided for each axis. You 
can lock each individually by clicking . 

Usually you can enter a value in a box without affecting the other 
values. However if you have locked some components on the Polar 
tab (see page 121), then the values of the other fields may change 
to comply with the constraints created by the locks. 
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If you click a position in the graphics window, its Cartesian 
coordinates are displayed in the dialog. 

 
Workspace — Select the workspace you are working in. The 
available options are:  

Relative — The position being defined is relative to another 
position which becomes the origin of the workspace. The 
positions are aligned with the active workplane or the global 
workspace if no workplane is active. 

Relative mode is not always available since there may not be a 
suitable relative co-ordinate. In this case, select a suitable 
position (such as the intersection of two lines) and make it the 
origin of a relative workspace with the Become Origin option. 

Workplane — The position being defined is relative to the 
active workplane if one exists. 

World — The position being defined is relative to the global 
coordinate system. 

 If any items are locked, the locks are discarded when you 
select a different workspace. 

Current plane — Use this drop down list to select one of the three 
principal planes. The current plane is relative to the selected 
Workspace option. 

 Locked and  Unlocked — Click to toggle between Locked and 
Unlocked. Locking a value ensures that it remains fixed regardless 
of what happens to other components. The lock remains ON until 
you click again to unlock it. When an editing box is affected by a 
lock, it is dimmed to show that it is unavailable. 
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 Unlock all — Click this button to unlock all of the values above. 

Become origin — Click this button for the coordinates of the position 
defined by the dialog to become the origin. Any relative coordinates 
are measured from this origin. 

Apply — Inputs the position. If the current operation allows multiple 
points, the dialog remains displayed ready for you to enter more 
points. Otherwise, the dialog is removed from the screen. 

OK — Inputs the position and removes the dialog. 

Cancel — Aborts the position entry. 
 

Polar tab 
The Polar tab of the Position dialog (see page 119) is affected by the 
Current plane setting, which determines how the coordinates are 
calculated from the Angle and Elevation/Height fields. 

Click a position in the graphics window to enter Polar coordinates 
into the dialog. 

 
Workspace — Select the workspace you are working in. The 
available options are:  
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Relative — The position being defined is relative to another 
position which becomes the origin of the workspace. The 
positions are aligned with the active workplane or the global 
workspace if no workplane is active. 

Relative mode is not always available since there may not be a 
suitable relative co-ordinate. In this case, select a suitable 
position (such as the intersection of two lines) and make it the 
origin of a relative workspace with the Become Origin option. 

Workplane — The position being defined is relative to the 
active workplane if one exists. 

World — The position being defined is relative to the global 
coordinate system. 

 If any items are locked, the locks are discarded when you 
select a different workspace. 

Current plane — Use this drop down list to select one of the three 
principal planes. The current plane is relative to the selected 
Workspace option. 

Angle — Enter the polar angle from the origin in the currently 
selected plane in the selected workspace.  

Distance — Select one of the following options from the drop-down 
list: 

 Distance — Enter the distance from the workplane origin. 

 X, Y, or Z — Enter a distance on the axis on the current active 
plane. 

Elevation — Select one of the following options from the drop-down 
list: 

 Elevation — Enter the angle of elevation above the active plane 
from the origin of the workspace. 

 Height — Enter the distance perpendicular to the selected plane. 
For example, the Z component when the XY plane is selected. 

 Locked and  Unlocked — Click to toggle between Locked and 
Unlocked. Locking a value ensures that it remains fixed regardless 
of what happens to other components. The lock remains ON until 
you click again to unlock it. When an editing box is affected by a 
lock, it is dimmed to show that it is unavailable. 

 Unlock all — Click this button to unlock all of the values above. 

Become origin — Click this button for the coordinates of the position 
defined by the dialog to become the origin. Any relative coordinates 
are measured from this origin. 
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Apply — Inputs the position. If the current operation allows multiple 
points, the dialog remains displayed ready for you to enter more 
points. Otherwise, the dialog is removed from the screen. 

OK — Inputs the position and removes the dialog. 

Cancel — Aborts the position entry. 
 

Along tab 
Use the Along tab of the Position dialog (see page 119) to create a 
position at a chosen parameter along a selected object. 

 You can select composite curves when you are using the 
Along tab of the Position dialog: 

 
Workspace — Select the workspace you are working in. The 
available options are:  

Relative — The position being defined is relative to another 
position which becomes the origin of the workspace. The 
positions are aligned with the active workplane or the global 
workspace if no workplane is active. 

Relative mode is not always available since there may not be a 
suitable relative co-ordinate. In this case, select a suitable 
position (such as the intersection of two lines) and make it the 
origin of a relative workspace with the Become Origin option. 

Workplane — The position being defined is relative to the 
active workplane if one exists. 

World — The position being defined is relative to the global 
coordinate system. 
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 If any items are locked, the locks are discarded when you 
select a different workspace. 

Object — Select an object using the mouse. When an object is 
selected, its name is displayed in the text box. 

Select one of the following options and enter a value, or use the 
slider: 

Proportion — Enter a measurement for the proportional distance 
from the start of the object. For example, enter 0.5 for half way 
along or enter 0.25 for a quarter (or 25%) of the way along from 
the start of the object.  

Distance — Enter a measurement from the start of the object. 

The slider indicates the portion from the start of the object. By 
default, the slider has 10 divisions. You can change the number of 

graduations on the slider by using . Use the arrows to select 
a value or type a value into the box. 

 Locked and  Unlocked — Click to toggle between Locked and 
Unlocked. Locking a value ensures that it remains fixed regardless 
of what happens to other components. The lock remains ON until 
you click again to unlock it. When an editing box is affected by a 
lock, it is dimmed to show that it is unavailable. 

 Unlock all — Click this button to unlock all of the values above. 

Become origin — Click this button for the coordinates of the position 
defined by the dialog to become the origin. Any relative coordinates 
are measured from this origin. 

Apply — Inputs the position. If the current operation allows multiple 
points, the dialog remains displayed ready for you to enter more 
points. Otherwise, the dialog is removed from the screen. 

OK — Inputs the position and removes the dialog. 

Cancel — Aborts the position entry. 
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Between tab 
Use the Between tab of the Position dialog (see page 119) in the 
same way as the Along tab (see page 123), but instead of using 
points at the ends of an object, select the start and end points 
which need not be on the same object. This allows accurate 
placement of a position between two connected or unconnected 
positions. 

 
Workspace — Select the workspace you are working in. The 
available options are:  

Relative — The position being defined is relative to another 
position which becomes the origin of the workspace. The 
positions are aligned with the active workplane or the global 
workspace if no workplane is active. 

Relative mode is not always available since there may not be a 
suitable relative co-ordinate. In this case, select a suitable 
position (such as the intersection of two lines) and make it the 
origin of a relative workspace with the Become Origin option. 

Workplane — The position being defined is relative to the 
active workplane if one exists. 

World — The position being defined is relative to the global 
coordinate system. 
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 If any items are locked, the locks are discarded when you 
select a different workspace. 

Current plane — Use this drop down list to select one of the three 
principal planes. The current plane is relative to the selected 
Workspace option. 

Click two positions in the model to enter the values for the following 
options: 

First Point — This displays the coordinates of the first click. 

Second Point — This displays the coordinates of the second click. 

Select one of the following options and enter a value, or use the 
slider: 

Proportion — Enter a measurement for the proportional distance 
from the start of the object. For example, enter 0.5 for half way 
along or enter 0.25 for a quarter (or 25%) of the way along from 
the start of the object.  

Distance — Enter a measurement from the start of the object. 

The slider indicates the portion from the start of the object. By 
default, the slider has 10 divisions. You can change the number 

of graduations on the slider by using . Use the arrows to 
select a value or type a value into the box. 

Resultant point — This displays the coordinates of the between value 
as defined by the dialog. 

 Reset — Click this button to reset the values on the page. 

Become origin — Click this button for the coordinates of the position 
defined by the dialog to become the origin. Any relative coordinates 
are measured from this origin. 

Apply — Inputs the position. If the current operation allows multiple 
points, the dialog remains displayed ready for you to enter more 
points. Otherwise, the dialog is removed from the screen. 

OK — Inputs the position and removes the dialog. 

Cancel — Aborts the position entry. 
 

Intersect tab 
Use the Intersect tab of the Position dialog (see page 119) to find 
the position where two objects intersect. 
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 You can select composite curves when you are using the 
Intersect page of the Position dialog: 

 
Workspace — Select the workspace you are working in. The 
available options are:  

Relative — The position being defined is relative to another 
position which becomes the origin of the workspace. The 
positions are aligned with the active workplane or the global 
workspace if no workplane is active. 

Relative mode is not always available since there may not be a 
suitable relative co-ordinate. In this case, select a suitable 
position (such as the intersection of two lines) and make it the 
origin of a relative workspace with the Become Origin option. 

Workplane — The position being defined is relative to the 
active workplane if one exists. 

World — The position being defined is relative to the global 
coordinate system. 

 If any items are locked, the locks are discarded when you 
select a different workspace. 

Select two objects in the model to find the intersection. The names 
of the selected objects are displayed in the following options: 

One — The name of one of the objects selected is displayed. 

Two — The name of the other object selected is displayed. 

In order to find intersections, PowerSHAPE does the following: 

 If the position does not lie on either object, the objects are 
extended. 

 Lines are treated as if they are of infinite length. 
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The intersection point of two lines that don't cross is shown 
below. 

 
 Arcs are treated as full circles. 

 If there are two possible intersections, the intersection position is 
the one closest to the last mouse click. 

 Curves are extended by maintaining the curvature at the end 
point. 

 
Become origin — Click this button for the coordinates of the position 
defined by the dialog to become the origin. Any relative coordinates 
are measured from this origin. 

Apply — Inputs the position. If the current operation allows multiple 
points, the dialog remains displayed ready for you to enter more 
points. Otherwise, the dialog is removed from the screen. 

OK — Inputs the position and removes the dialog. 

Cancel — Aborts the position entry. 
 

Normal tab 
Use the normal tab of the Position dialog (see page 119) to enter a 
position which is perpendicular to an object from the origin of the 
workspace displayed on the dialog. 
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 You can select composite curves when you are using the 
Normal tab of the Position dialog: 

 
Workspace — Select the workspace you are working in. The 
available options are:  

Relative — The position being defined is relative to another 
position which becomes the origin of the workspace. The 
positions are aligned with the active workplane or the global 
workspace if no workplane is active. 

Relative mode is not always available since there may not be a 
suitable relative co-ordinate. In this case, select a suitable 
position (such as the intersection of two lines) and make it the 
origin of a relative workspace with the Become Origin option. 

Workplane — The position being defined is relative to the 
active workplane if one exists. 

World — The position being defined is relative to the global 
coordinate system. 

 If any items are locked, the locks are discarded when you 
select a different workspace. 

Normal to object — Click the object you want the position to be 
normal to. The name of the object is displayed in the box and the 
cursor moves to the position normal to the object. 

To allow positions to be found that do not lie on the object, 
PowerSHAPE does the following: 

 Lines are treated as if they are of infinite length  

 Arcs are treated as full circles. 

 An error dialog is displayed if a position cannot be found 
normal to the selected object. 
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Become origin — Click this button for the coordinates of the position 
defined by the dialog to become the origin. Any relative coordinates 
are measured from this origin. 

Apply — Inputs the position. If the current operation allows multiple 
points, the dialog remains displayed ready for you to enter more 
points. Otherwise, the dialog is removed from the screen. 

OK — Inputs the position and removes the dialog. 

Cancel — Aborts the position entry. 
 

Key point tab 
Use the Key point tab of the Position dialog (see page 119) to select 
a position at a specific key point on the selected object. This is 
useful where more than one object has key points at the same 
position and (for example) you want to snap to a hidden key point 
on a specific object. Key points are a quick and convenient method 
for selecting specific objects. 

 You can select composite curves when you are using the Key 
point page of the Position dialog: 

 
Workspace — Select the workspace you are working in. The 
available options are:  
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Relative — The position being defined is relative to another 
position which becomes the origin of the workspace. The 
positions are aligned with the active workplane or the global 
workspace if no workplane is active. 

Relative mode is not always available since there may not be a 
suitable relative co-ordinate. In this case, select a suitable 
position (such as the intersection of two lines) and make it the 
origin of a relative workspace with the Become Origin option. 

Workplane — The position being defined is relative to the 
active workplane if one exists. 

World — The position being defined is relative to the global 
coordinate system. 

 If any items are locked, the locks are discarded when you 
select a different workspace. 

Object — Select an object. The name of the object is displayed. 

Key point — This determines which point on the object is selected. 
Select from the following options: 

Centre — This applies to the centre point of arcs and circles. 

Start and End — This can apply to any object as they all have 
start and end positions. 

Point Number — This is intended for use with curves that can 
have many positions along their length. The Point Number box 
activates where you enter a number. 

Become origin — Click this button for the coordinates of the position 
defined by the dialog to become the origin. Any relative coordinates 
are measured from this origin. 

Apply — Inputs the position. If the current operation allows multiple 
points, the dialog remains displayed ready for you to enter more 
points. Otherwise, the dialog is removed from the screen. 

OK — Inputs the position and removes the dialog. 

Cancel — Aborts the position entry. 
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Vector tab 
Use the Vector tab of the Position dialog (see page 119) to measure 
a vector between two points and use it to define a position. The 
offsets, angles, length, and elevation between the two points are 
displayed. 

 
Workspace — Select the workspace you are working in. The 
available options are:  

Relative — The position being defined is relative to another 
position which becomes the origin of the workspace. The 
positions are aligned with the active workplane or the global 
workspace if no workplane is active. 

Relative mode is not always available since there may not be a 
suitable relative co-ordinate. In this case, select a suitable 
position (such as the intersection of two lines) and make it the 
origin of a relative workspace with the Become Origin option. 

Workplane — The position being defined is relative to the 
active workplane if one exists. 

World — The position being defined is relative to the global 
coordinate system. 
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 If any items are locked, the locks are discarded when you 
select a different workspace. 

Current plane — Use this drop down list to select one of the three 
principal planes. The current plane is relative to the selected 
Workspace option. 

You must already have a starting position from which the new 
position is entered. 

First Point — Enter the first point of the vector or click on a point 
on the model to enter its coordinates. This point is displayed in 
pink on the screen (using the default colour scheme). 

Second Point — Enter the second point of the vector or click on a 
point on the model to enter its coordinates. This point is 
displayed in red on the screen (using the default colour scheme). 

When you click OK or Apply, a new position is entered by going 
along the vector from the start position. 

Information from the two positions of the vector is displayed 
automatically in the boxes for the following options: 

Difference — These are the differences in the X, Y, and Z values of 
the first and second points of the vector. 

Apparent Angles — The apparent angle is measured between the 
projection of the vector onto a plane and the selected axis. If the 
axis is X, the plane is XY. For Y the plane is YZ and for Z it is ZX. An 
example is shown below of the apparent angle for the X axis: 

 

 Reset — Click this button to reset the values on the page. 

Length — This is the true length (in 3D) between the points. 
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Elevation — This is the elevation angle of the new vector from the 
current plane. 

 
Become origin — Click this button for the coordinates of the position 
defined by the dialog to become the origin. Any relative coordinates 
are measured from this origin. 

Apply — Inputs the position. If the current operation allows multiple 
points, the dialog remains displayed ready for you to enter more 
points. Otherwise, the dialog is removed from the screen. 

OK — Inputs the position and removes the dialog. 

Cancel — Aborts the position entry. 
 

Circle tab 
Use the Circle tab of the Position dialog (see page 119) to measure 
the dimensions of an arc using three points. 
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Workspace — Select the workspace you are working in. The 
available options are:  

Relative — The position being defined is relative to another 
position which becomes the origin of the workspace. The 
positions are aligned with the active workplane or the global 
workspace if no workplane is active. 

Relative mode is not always available since there may not be a 
suitable relative co-ordinate. In this case, select a suitable 
position (such as the intersection of two lines) and make it the 
origin of a relative workspace with the Become Origin option. 

Workplane — The position being defined is relative to the 
active workplane if one exists. 

World — The position being defined is relative to the global 
coordinate system. 

 If any items are locked, the locks are discarded when you 
select a different workspace. 

Current plane — Use this drop down list to select one of the three 
principal planes. The current plane is relative to the selected 
Workspace option. 

StartPpoint — Enter the start point of the arc or click on a point on 
the model to enter its coordinates. This point is displayed in pink on 
the screen (using the default colour scheme). 

End Point — Enter the end point of the arc or click on a point on the 
model to enter its coordinates. This point is displayed in pink on the 
screen (using the default colour scheme). 

Mid point — Enter the mid point of the arc or click on a point on the 
model to enter its coordinates. This point is displayed in pink on the 
screen (using the default colour scheme). 

Centre Point — The coordinates of the centre point of the arc are 
displayed. 

 Reset — Click this button to reset the values on the page. 

Radius — The radius of the arc is displayed. 

Diameter — The diameter of the arc is displayed. 

Become origin — Click this button for the coordinates of the position 
defined by the dialog to become the origin. Any relative coordinates 
are measured from this origin. 

Apply — Inputs the position. If the current operation allows multiple 
points, the dialog remains displayed ready for you to enter more 
points. Otherwise, the dialog is removed from the screen. 

OK — Inputs the position and removes the dialog. 
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Cancel — Aborts the position entry. 

 When you have opened the Position dialog in creation mode, 
clicking OK places the cursor in the circle centre. 

 

Entering angles 
Enter an angle using degrees, minutes, and seconds in any dialog 
that expects an angle. The format is one of the following: 

> d;m;s 
>-d;m;s    (for negative angle) 

>-(d;m;s)  (for negative angle) 

where d, m, and s are numbers. 

 This syntax does not work for the Calculator dialog, or for the 
calculator that is embedded in the Parameter dialog. 

 

The grid 
A grid is an array of points joined by lines. Use the grid as a guide 
to quickly enter positions by snapping to its points. 

 
 

Using the grid 
To use the grid turn the grid ON (see page 137).  

The grid is drawn on the principal plane. If you change the principal 
plane, the grid automatically redraws on the new plane. The 
principal plane is displayed on the grid. Also displayed is the arrow 
at the origin of the current workspace. This shows the axis normal 
to the principal plane.  

 
You can:  
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 Snap to the intersections of grid lines as if they are key points. 

View the grid as either ruled or dotted lines by changing the Grid type 
option on the View page of the Options dialogs 
The scale of the current grid is displayed in the Status bar (see page 
30). The scale can be locked (see page 30) in the status bar to fix 
the scale. The scale is locked by default to a value of 10. You can 
set your own grid scale by typing your value into the grid scale text 
box in the Status bar (see page 30). The grid scale is locked 
automatically to that value. 

To zoom in and out on a locked grid scale: 

 Click Zoom in  to increase the scale. 

 Click Zoom out  to decrease the scale. 

To unlock the scale, deselect the user defined scale option on the 
Blanking and Grid page of the Options dialog. For further details, see 
Blanking and Grid in the Menus and Toolbars manual. 

 

Turning the grid On and Off 
To turn ON the grid 

From the Status bar (see page 30), click Grid on/off  to draw the 
grid on the screen. 

To turn OFF the grid 

From the Status bar (see page 30), click Grid on/off  to remove 
the grid from the screen. 

 

Using point-locking 
When point-locking is ON, every position you enter using the mouse 
is locked onto the principal plane. For example, if the principal plane 
is XY, every point you enter using the mouse will have a Z 
coordinate of zero. 

You can: 

 Turn point-locking on (see page 137) 

 Turn point-locking off (see page 138) 
 

Turning point-locking on 
From the Status bar, click the Point lock button . (It changes to a 
shut lock ). 
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Point-locking affects only points entered using the mouse.  

To enter a position that is not on the principal plane, you can: 

 Use the Position dialog (see page 119). 

 Type in the coordinates. 

If you snap to a key point which does not lie on the principal plane 
(as shown below), 

 
then the new position is projected onto the principal plane. 

 
When you hover the intelligent cursor (see page 58) over such a 
key point, it changes to show that clicking the key point will project 
any new position onto the principal plane. 

 

Turning point-locking off 
From the Status bar, click the Point lock button . (It changes to 
an open lock ). 
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Calculator and measuring 
Use the following sections to find information on the calculator 
and measuring: 

What is the calculator? (see page 139) 

Using the calculator (see page 139) 

Using the calculator to measure (see page 146) 
 

What is the calculator? 
The calculator enables you to make calculations while working on a 
model. 

 
You can use the calculator in the following ways: 

 Operate it in the same way as any pocket calculator. 

 Enter complex expressions.  

 Measure objects in the model. 

 Interact data with dialogs, automatically entering the result into 
the selected boxes. 

For further details, see Using the calculator (see page 139). 
 

Using the calculator 
From the Status Bar, click the Calculator  button. 

 
The Calculator dialog (see page 140) is displayed.  
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The calculator operates in the same way as any pocket calculator. 
You can click buttons to enter numbers and commands or you can 
use the keyboard numeric keypad. 

 
To use the calculator from within a dialog:  

1 Right-click in a box (used to enter numbers).  

2 Use the calculator as required.  

3 Click OK.  

The results are automatically added to the box. 
 

Calculator dialog 
Use the calculator to make calculations while working on a model.  

For further details, see Using the calculator (see page 139) and 
Using the calculator to measure (see page 146). 

 
At the top of the dialog are tabs that provide the calculator with 
additional features for you to use to build expressions. You can 
switch between tabs as you calculate an expression. 
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 Scientific (see page 143) 

 Parameters (see page 144) 

 Functions (see page 145) 

 Measure (see page 146) 

The calculator has two boxes: 

 Displays the expression. 

 Displays the results of the calculations. 

 Controls the number of decimal places shown on the result. 

 - Increases the number of decimal places shown on the result. 

 - Decreases the number of decimal places shown on the 
result. 

 
Use the keyboard or the numeric keypad to enter an expression for 
calculation. As you enter expressions, the results in the expressions 
box are updated. 

The calculator also contains: 

 The numeric keypad. This is used in the same way as any other 
calculator to add, subtract, divide and multiply numbers. Memory 
function keys aid calculations. 

 Operations for the selected tab. The operations displayed 
correspond with the selected tab. 
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 The Projected option. If On, the measurement is projected onto 
the current plane. Use this option with the measurement options. 
For further details, see Using the Projected option (see page 158). 

 
Other keypad functions available are: 

MC - Clears expressions stored in the memory. 

MR - Retrieves a value from memory, for example after using M+ to 
see the result. 

MS - Stores the current expression into the memory. 

M+ - Adds the current expression to the value already in memory. 

 The calculator remembers the memory value when it is closed 
and reopened. 

1/x - Divides one by the current expression. 

Sqrt - This calculates the square root of the current expression. 

C - Removes the current expression. 

AC - Deletes any expression stored in the memory and removes the 
current expression. 

Backspace - Removes the character to the left of the cursor. 
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Scientific tab 
Use the Scientific tab of the Calculator (see page 140) to calculate 
expressions using the scientific functions. 

 
When you select a function, the current expression is enclosed in 
brackets and the function is performed on the value of the current 
expression.  

sin - This calculates the sine of the current expression. 

cos - This calculates the cosine of the current expression. 

tan - This calculates the tan of the current expression. 

asin - This calculates the angle whose sine is equal to value of the 
current expression. 

acos - This calculates the angle whose cosine is equal to value of 
the current expression. 

atan - This calculates the angle whose tangent is equal to value of 
the current expression. 

^ - This is the "to the power of" sign. 

For example, if the current value of the expression is 2 and you 
select ^  then enter the value 3, the following calculation is 
performed: 

(2)^3=2*2*2=8 

^2 - This calculates the expression to the power of 2. 

^3 - This calculates the expression to the power of 3. 

exp - This calculates the exponential value of the current expression 
with respect to e, the base of the natural logarithms. 

For example, if the current value of the expression is 2 and you 
select exp, the following calculation is performed: 

exp(2) = e2 = 7.389056 
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ln - This calculates the natural logarithm of the current expression. 

For example, if the current value of the expression is 7.389056 and 
you select ln, the following calculation is performed: 

ln(7.389056) = logarithm(7.389056) = 2 

abs - This calculates the absolute value of the current expression. In 
other words, removes the minus sign. 

For example, if the value of the expression is -56.98 and you select 
abs, the new value is 56.98. 

( ) - Adds brackets around the current expression. 

( - Adds a single left bracket to the current expression. 

) - Adds a single right bracket to the current expression. 
 

Parameters tab 
Use the Parameters tab of the Calculator (see page 140) to specify a 
parameter. 

A parameter is a user-defined variable that is used to store numbers 
and expressions. For further details, see Using a parameter (see 
page 185). 
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Functions tab 
Use the Functions tab of the Calculator (see page 140) to enter 
expressions using functions. 

 
The result of a logical expression is 0 or 1, where 0 is false and 1 is 
true. You can combine buttons to give more operators. 

Each logical operator is discussed below. 

A == B 
outputs 1 if A equals B and 0 otherwise 

A != B 
outputs 1 if A does not equal B and 0 otherwise 

A < B 
outputs 1 if A is less than B and 0 otherwise 

A <= B 
outputs 1 if A is less or equal to B and 0 otherwise 

A > B 
outputs 1 if A is greater than B and 0 otherwise 

A >= B 
outputs 1 if A is greater or equal to B and 0 otherwise 

A AND B 
outputs 1 if A and B are true and 0 otherwise 

A OR B 
outputs 1 if either A or B is true and 0 otherwise 

! A 
outputs 1 if A is false and 0 if true. This is known as the not 
operator. 

test ? result_true : result_false 
if test is true then output result_true otherwise output result_false. 

Example 1 
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a>=b ? a+b : a-b 

This outputs a+b if a>=b and a-b if a<b. 

Example 2 

a= (b>20)?10:((b>30)?20:30) 
This example uses a nested expression to determine the value of 
a, based on the value of b 

if b > 20 then 

   a = 10 

else if (b > 30) then 

   a = 20 

else 

   a = 30 

Min - This determines the minimum value of a list of values in the 
expression. 

The list of values in the expression must be of the form: 

A1; A2; … ; AN 

Max - This determines the maximum value of a list of values in the 
expression. 

The list of values in the expression must be of the form: 

A1; A2; … ; AN 
 

Using the calculator to measure 
Use the Measure tab of the Calculator (see page 140) to create 
expressions using the measurement options. The measuring options 
are displayed on the right of the Calculator.   

 Straight line segments of curves are treated as lines. 
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For further details, see Using the calculator (see page 139). 

 

 Auto measure (see page 147) 

 Measure length (see page 148) 

 Measure length using two points (see page 149) 

 Measure radius (see page 149) 

 Measure radius using 3 points (see page 156) 

 Measure diameter (see page 149) 

 Measure diameter using three points (see page 150) 

 Measure minor angle (see page 150) 

 Measure major angle (see page 150) 

Projected - Using the Projected option (see page 158) 

 Measure area (see page 155) 

 Measure volume (see page 155) 

 Measure minimum distance (see page 157) 

 Measure draft angles (see page 157) 

 Measure wall thickness (see page 156) 

 

 

 
 

Measuring automatically 
Use this option to intelligently measure lines, arcs, and the radius of 
curvature on arcs, curves, and surface curves. 
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1 Select Model Analysis  on the General edits  flyout. 

2 Click Calculator  (model analysis toolbar) 

3 Click the Auto-measure  button. 

4 Hover the mouse over an object. 

If the object is a line or an arc, the intelligent cursor displays the 
intelligent measurement of that object. The intelligent 
measurement of lines and arcs are: 

 Line - length 

 
 Arc - radius 

 
 Full arc (circle) - diameter 

 
If a span of a curve or a surface curve has constant curvature, 
the radius of curvature is displayed when you move the cursor 
over the span. 

To enter that value into the calculator, click the object. The value 
is entered into the expressions box. 

If no intelligent measurement is associated with an object, then 
no value is displayed. 

When no value is displayed and you click a position on the 
screen, the calculator waits for you to enter a second position. As 
you move the cursor, a rubber-banded line displays from the first 
position to the cursor position. The length of the rubber-banded 
line is also displayed. Once you enter the second position, the 
shortest distance between the two points is entered into the 
expressions box. 

 

Measuring the length 
This option measures: 
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 the length of a line 

 the span of an arc 

 the length of a curve or a composite curve 

 the distance between two points 
To measure the length, 

1 Select Model Analysis  on the General edits  flyout. 

2 Click Calculator  (model analysis toolbar) 

3 Click the Measure Length  button. 

4 Either select the object or click two points to enter the value into 
the expressions box. 

 

Measuring the radius 
Use this to measure the radius of any arc or circle, and the 
curvature on curves and surface curves. 

1 Select Model Analysis  on the General edits  flyout. 

2 Click Calculator  (model analysis toolbar) 

3 Click the Measure Radius  button. 

4 If you move the cursor over an arc, its radius is displayed. If a 
span of a curve or a surface curve has constant curvature, the 
radius of curvature is displayed when you move the cursor over 
the span. 

5 Click the object to enter the value into the expressions box. 
 

Measuring the diameter 
Use this to measure the diameter of an arc. 

1 Select Model Analysis  on the General edits  flyout. 

2 Click Calculator  (model analysis toolbar) 

3 Click the Measure Diameter  button. 

4 If you hover the mouse over an arc, its diameter is displayed. 

5 Click the arc to enter the value into the expressions box. 
 

Measuring the length using two points 
1 Click first point . 
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2 Hover over the second point  to display the length. Click the 
point to display the length value in the dialog. 

 
 

Measuring the diameter using three points 
1 Click first point . 

2 Click second point . 

3 Hover over the third point  to display the diameter. Click the 
point to display the diameter value in the dialog. 

 
 

Measuring angles 

1 Select Model Analysis  on the General edits  flyout. 

2 Click Calculator  (model analysis toolbar). 

3 Click the Measure Minor Angle  button to measure minor angles 
or click the Measure Major Angle  button to measure major 
angles. 

4 Select from the following items: 

 One line (see page 151)  

 Two lines (see page 151) 

 Arcs (see page 152)  

 One line and one position (see page 153) 
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 Three positions (see page 154) 
 

Measuring angles - one line 
1 Hover the cursor over the line. 

The minor and major angles are both displayed, where the type 
not required is in brackets. 

 
2 Double-click the line in exactly the same position to enter the 

value into the expressions box on the calculator. 
 

Measuring angles - two lines 
The minor and major angles are measured between the two lines as 
shown below. 

 

 Minor angle 
 Major angle 

Select one line and then select the other line. The angle between 
the two lines is entered into the expressions box on the calculator. 
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In the example below, there are two lines that do not lie on the 
same XY, YZ, or ZX plane, but intersect in space. The angle is 
measured on the plane that is defined by the intersection point and 
the end points of the lines that lay away from the intersection point. 

 
If you select two lines that do not intersect in space, no angle exists 
between two such lines. The position selected on the second line is 
treated as a position and the angle is calculated as described when 
a line and a position are selected. 

 

Measuring angles - arcs 
The minor and major angles are the spans of the sector of the arc 
and the missing sector of the arc, shown in the example image 
below: 

 
When you hover the mouse over an arc, both the minor and major 
angles are displayed, where the type not required is in brackets. 
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Measuring angles - one line and one position 
1 Select a line.  

Depending on which end of the line is selected, you will see a 
rubber-banded angle from the line to intelligent cursor. 

 
If the top end of the line is selected, the angle is measured from 
the top part of the line. As you move the mouse cursor, the 
rubber-banded angle moves too. 

 
Use this rubber-banded angle as a guide to determine the angle 
you want to measure. 

2 Enter the position. The angle is entered into the expressions box. 

 The angle is calculated in the plane made by the two end 
points of the line and the position. 
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Measuring angles - three positions 
The three positions define two lines, shown in the image below. The 
minor and major angles are measured between these two lines. 

 
1 Enter the first position, to display a rubber-banded line from the 

position to the mouse cursor. 
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2 Use the rubber-banded line to enter the second position. A 
rubber-banded angle is displayed, shown in the image below. 

 
3 Choose the third position. The angle is displayed in the 

expressions box. 

The angle is calculated in the plane made by the two end points 
of the line and the position. 

 

Measuring the volume 
Use this to measure the volume of surfaces, solids, or triangulated 
symbols. 

1 Select Model Analysis  on the General edits  flyout. 

2 Click Calculator  (model analysis toolbar) 

3 Click the Measure Volume  button. 

4 Select the surface or solid. 
 

Measuring the area 
Use this to measure the area of a composite curve, surface, solid, or 
triangulated symbols. 

1 Select Model Analysis  on the General edits  flyout. 

2 Click Calculator  (model analysis toolbar) 

3 Click the Measure Area  button. 

4 Select either a composite curve or a surface or a solid. 
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Measuring wall thickness 
This option measures the wall thickness of a solid. 

1 Select Model Analysis  on the General edits  flyout. 

2 Click Calculator  (model analysis toolbar). 

3 Click the Measure Wall Thickness  button. 

4 Move the cursor over the solid to display the wall thickness (see 
below). 

5 Click the solid to enter the value into the expressions box. 

 
 

Measuring the radius using 3 points 
Use this to measure the radius of an arc using three points. It is 
ideal for measuring the radius of curvature on curves and surface 
curves. 

1 Select Model Analysis  on the General edits  flyout. 

2 Click Calculator  (model analysis toolbar). 

3 Click the Measure Radius From 3 Points  button. 

4 Click the first position to define the start point of an arc. 

 
5 Click the second position to define the end point of an arc. 
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6 Click the third position to define a position on the circumference 
of the arc. 

 
 The value is entered into the expressions box. 

 

Measuring draft angles 
Use this to measure the draft angle of surface and solid points. 

1 Select Model Analysis  on the General edits  flyout. 

2 Click Calculator  (model analysis toolbar). 

3 Click the Measure Draft  button. 

4 Hover the mouse over a position on a surface or solid. The minor 
draft angle is displayed with the major draft angle in brackets. 
An arrow representing the surface normal of the position is also 
drawn. 

 
By default, only draft angles of positions on the surface curves 
are measured. You can measure the draft angle of positions 
within a surface patch by holding down the Shift key.  The draft 
angle is measured from the principle plane to the normal of the 
point on the surface under the cursor. 

5 Click the position on the surface to enter the draft angle into the 
expressions box. 

 

Measuring the minimum distance 
Use this to measure the minimum distance between two objects. 

1 Select Model Analysis  on the General edits  flyout. 

2 Click Calculator  (model analysis toolbar). 

3 Click the Minimum Distance  button. 
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4 Click two objects to enter the value into the expressions box. 

 
Arrows are drawn on the objects to show where the minimum 
distance is measured. 

 
 

Using the Projected option 
Use the Projected option on the Calculator dialog (see page 140) to 
take measurements from projections on the principal plane. 

A line is measured from a projection on the principal plane, shown 
in the image below. 

 
You can measure three values from the projection:  

 The length  
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 The length along either of the axes of the principal plane. 

 
To measure the length of the projection,  

1 Hover the mouse over the line until a value displays.  

2 Double click the line to enter the value into the expressions box. 

To measure the length along the axis,  

1 Click the line once. 

2 Move the mouse in the direction parallel to the axis you want. As 
you move the mouse, a value displays.  

3 Click the mouse to enter the value into the expressions box. 
To measure angles of lines and positions that are projected onto the 
principal plane,  

 Deselect the Projected option (OFF) to measure Angle A between 
Line 1 and Line 2  

 Select the Projected option (ON) to measure Angle B between 
Line 1 and Line 2. 
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 You cannot calculate projections of arcs. Therefore, if you 
measure an arc, its value is the same regardless of whether 
Projected is on or off. 

 

Measure dialog 
Use the Measure dialog to calculate points, coordinates, distances, 
angles, radii, or unit vectors. 

 

 Auto-measure (see page 147) 

 Measure length between two points 

1 Click first point . 

2 Hover over the second point  to display the length. Click the 
point to display the length value in the dialog. 

 

 Measure length (see page 148) 

 Measure radius (see page 149) 

 Measure Radius From Three Points (see page 156) 

 Measure Diameter (see page 149) 

 Measure Diameter from Three Points 
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1 Click first point . 

2 Click second point . 

3 Hover over the third point  to display the diameter. Click the 
point to display the diameter value in the dialog. 
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Objects 
Use the following sections to find information on objects: 

Creating an object (see page 162) 

Editing an object (see page 162) 

Object dialogs and toolbars (see page 164) 

Selecting objects (see page 165) 
 

Creating an object 
Creating an object to your specifications is a two-step creation 
process: 

1 Create an initial object in the model. At this stage, the object 
may not be exactly the shape you want. 

2 Edit the object until it is exactly the shape you want. 

To create an object: 
1 Select the object type and creation method from the Object 

menu or from the Main toolbar. 

2 Enter one or more positions and/or selections as necessary. 

3 Drag the edit handles at the object’s key points to resize it. 

As the cursor can operate only in two dimensions, all the positions it 
creates fall on the active plane. If the point you want is not on that 
plane, you will need to use the Status Bar (see page 30) to change 
the current active plane and/or enter a specific position. For more 
complex positions, you can use the Position dialog (see page 119). 

In some infrequent cases, you may need to provide more 
information about how the object is to be modified. This is achieved 
by Edit - Modify which provides appropriate tools for each object 
type. It is displayed by double clicking the object or by selecting 
Modify from the Edit menu.  

For further details, see Edit menu overview (Menus and Toolbars). 
 

Editing an object 
To edit object(s), first select the objects you want to change. If you 
select only one object, graphical handles are displayed that are 
specific to that type of object. If you select more than one object, 
the handles are not displayed. 

Delete the object 
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 Press the keyboard Delete key  

 Click  on the main toolbar or  

 Select Delete from the Edit menu.  

This works on any number of objects. 

Drag move an object  

This works with any number of objects. 

1 Select an object by positioning the cursor over it, but away from 
any of its edit handles or key points. 

2 Press and hold the left-hand mouse button. The object is picked 
by its key point closest to your click position and dragged as you 
move the mouse.  

3 Release the mouse button to drop the object.  

Drag copy an object 

 Press and hold the Ctrl key while drag moving an object. A copy 
of the original is moved to the new position. 

Cut or Copy an object 

1 Click  or  from the Main toolbar or select Cut or Copy from 
the Edit menu.  

2 Click Paste  into another position, another model window or 
another model. 

Reshape an object 

Drag edit handle(s) to alter the size and/or shape of an object. 

 Lines - For further details, see Graphically moving a line 
(Wireframe modelling). 

 Arcs - For further details, see Graphically editing arcs (Wireframe 
modelling). 

 Curves - For further details, see Graphically editing curves 
(Wireframe modelling). 

 Surfaces - For further details, see Editing the power surface 
(Surface modelling manual). 

 Solids - For further details, see Editing a solid (Solid modelling).. 

 Workplanes - For further details, see Graphically editing 
workplanes (Wireframe modelling). 

Trim or transform an object using the editing tools: 

 Limit - For further details, see Edit - General Edits - Limit 
Selection (Menus and Toolbars). 
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 Rotate - For further details, see Rotating by dragging (Menus and 
Toolbars). 

 Mirror -For further details, see Edit - General Edits - Mirror 
(Menus and Toolbars). 

 Move/Copy - For further details, see Edit - General Edits - Move 
(Menus and Toolbars). 

 Scale - For further details, see Edit - General Edits - Scale 
(Menus and Toolbars). 

Modify the parameters of an object: 

 Select Modify from the Edit menu or double click the object. This 
displays an object-specific dialog or toolbar. 

 

Editing objects using the Intelligent Cursor 
When you start to drag an object, a group of objects or an editing 
handle of an object, the cursor feeds back information about points 
you can snap to. 

The Intelligent Cursor: 

 finds intersections between wireframe items and a surface or 
solid. 

 snaps to the projected intersection of wireframe items and 
surfaces. 

 snaps bezier curves to triangles in a symbol imported as a solid. 
For further details, see STL/DMT options in the Menus and 
Toolbars manual. 

 snaps to triangles in symbols (not applicable to components).  

For further details, see Using the Intelligent Cursor to enter 
positions (see page 58) and Selection using the Intelligent Cursor 
(see page 60). 

 

Object dialogs and toolbars 
Double click on an object to display an object related dialog or a 
toolbar. The options displayed correspond with the object type. 

For further details, see: 

 Editing an arc  

 Editing a curve  

 Editing a line  

 Editing a workplane  

 Editing a Power Suface 



 

PowerSHAPE 2015 R2 Reference Help Basic modelling concepts • 165  

 Editing a primitive surface 
 

Selecting objects 
If you want to do anything to an object, you must select it first. This 
is a basic requirement for editing objects. 

Some creation and construction commands allow selection of 
objects, but most selection can be done by using the selection 
options on the Select flyout.  

1 Click the Select  flyout button to display the Select flyout 
toolbar.  

 
The Select flyout toolbar contains the following selection options: 

 Selection information — Move the cursor over the Select flyout 
button to display selection information as a Tooltip 
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 Partial box (see page 167) 

 Whole box (see page 168) 

 Drawing view 

 Selection filter (see page 169) 

 All wireframes (see page 171)  

 All surfaces (see page 172)  

 All solids (see page 171)  

 All surfaces and solids (see page 172) 

 All components and sub-assemblies (see page 172) 

 All meshes (see page 172) 

 All clouds (see page 172)  

 Selection information (see page 172) 

The current selection is highlighted. Single selected objects have 
their key points visible as graphical handles. When more than one 
object is selected, the key point handles are not displayed, but the 
objects remain highlighted. 

 

Selecting single objects 
Click on an object in the graphics window to select it. A selected 
object is highlighted with its key points visible as graphical handles.  

You can click: 

 on an object (see page 44). 

 over an object (see page 47). 
 

Selecting multiple objects 
Select multiple objects in one of the following ways: 



 

PowerSHAPE 2015 R2 Reference Help Basic modelling concepts • 167  

 Use the left mouse button to click on the object and it will 
highlight with its key points visible as graphical handles. Certain 
modifier keys are also used with the mouse to change the way 

the mouse behaves. For example, hold down  and click on 
another object. This object is also highlighted and added  to the 
selection. When more than one object is selected, the key point 
handles are not displayed, but the objects remain highlighted. 

Hold down  and click on objects to add a multiple number 
of items to the selection. For further details, see Using the 
mouse (see page 36). 

 Click the Select flyout  to display the selection and selection 
information options. You can use specific options on this flyout to 
select multiple objects. For further details, see Selecting objects 
(see page 165) 

 

 
 

Selecting objects - Partial box 

Partial box  (Selection flyout) is the default selection option (see 
page 165) when the program is started. 
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1 Using the left mouse button, click a point on the screen where 
you want the box to start. 

 
2 Keeping the mouse button pressed, move the mouse to a second 

position on the screen. This creates a rectangular "rubber band" 
on the screen. 

 
3 Release the mouse to select all of the objects that are partially or 

completely enclosed in the box. In the example shown below, all 
the lines are selected as they are partially or completely enclosed 
by the box. 

 
 

Using whole box selection 

1 Select the Whole Box  button (Selection flyout). For further 
details, see Selecting objects (see page 165) 

2 Using the left mouse button, click a position on the screen where 
you want the box to start. 
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3 Keeping the mouse button pressed, move the mouse to a second 
position on the screen. This creates a rectangular "rubber band" 
on the screen. 

 
4 Release the mouse to select all of the objects that are completely 

enclosed in the box. In the example shown below, only the line 
completely enclosed by the box is selected. 

 
 

Adding or removing objects 
To add or remove objects from a selection, press and hold the Ctrl 
key while clicking or dragging the mouse to: 

 deselect objects that are currently selected. 

 select objects that are currently deselected. 
 

Selection filter 
Complex models can become cluttered with objects making it 
difficult to select the ones you want. The selection filter helps you to 
choose the type of object you want to select. You can also select 
styles of objects and levels on which objects are kept. 

 Use the selection filter to specify the type of item you want to 
snap to. 

You can enter creation mode with the selection filter set. 

Using the selection filter 

1 Click the Selection Filter  button (Selection flyout). 

2 Use the Selection Filter dialog (see page 170) to filter the 
selections. 
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Selection Filter dialog 
You can use this dialog in one of the following ways: 

 Select an object on the screen and the dialog displays its Type, 
Style, and Level. 

 Choose the Type and Style of the objects to select and click Select 
All. All the objects that are of the correct type and style are 
selected. 

 
Type — This shows a list of the different objects that can be 
created. By default each type is selected. Clicking on an item selects 
or deselects it. Items that are selected are highlighted. When you 
have selected items from the list, then only those items can be 
selected on the screen. 

Style / Pattern / Colours / Widths / Materials — Select one of the 
following from the drop-down list. The list of styles, patterns, 
colours, width or materials used in the model is displayed in the 
centre panel of the dialog. Clicking on an item selects or deselects 
it. Items that are selected are highlighted. When you have selected 
items from the list, only those items can be chosen on the screen. 
For example, you can filter the selection of objects by colour, width 
or material. 
Level — Each level that is used is listed here. The level name is 
displayed alongside the level number. By default, each level is 
selected. Clicking on an item selects or deselects it. Items that are 
selected are highlighted. When you have selected items from the 
list, only those items can be chosen on the screen. 

Invert — This inverts the current selection, that is, those which are 
selected become unselected and those which are unselected, 
selected. 
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All — This selects all items in the list. Each item will be highlighted 
to show that it is selected. 

Select All — When you click on this, all items on the screen, which 
match the selections you made on the dialog, will be selected. 

 — Click this button to blank items according to the filter you 
have set. 

 — Click this button to unblank previously blanked items. 

Stored Selection Filters - You can save a selection filter that you 
have specified: 

1 Use Type, Style and Level to specify a filter. 

2 Enter a filter name to replace Unnamed 

3 Click  to save the selection filter. The filter is added to the 
drop-down list.  

To delete a stored selection filter: 

1 Select the filter from the Stored Selection Filters drop-down list. 

2 Click  

OK — This saves any changes and closes the dialog. You can only 
select those items you specified on the dialog. 

Cancel — This closes the dialog and discards any changes made to 
it. 

To return to normal selection after using a filtered selection 
1 Open the Filter dialog again. 

2 Make sure that all options in the three panels of the dialog are 
selected. 

3 Click OK.  
 

Selecting all wireframe objects 

Click the All Wireframe  button (Selection flyout) to select all the 
wireframe objects in a model. 

 

Selecting all solids 

Click the All Solids  button (Selection flyout) to select all the 
solids in a model.  
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Selecting all surfaces 

Click the All Surfaces  button (Selection flyout) to select all the 
surfaces in a model. 

 

Selecting all surfaces and solids 

Click the All Surfaces and Solids  button (Selection flyout) to 
select all the solids and surfaces in a model. 

 

Selecting all components and sub-assemblies 

Click the All Components  button (Selection flyout) to select all 
components and instances of sub-assemblies. 

 

Selecting all meshes 

Click the All Meshes  button (Selection flyout) to select all the 
meshes in a model. 

 

Selecting all clouds 

Click the All Clouds  button (Selection flyout) to select all 
clouds. 

 

Tools > Selection information 
Use this option to open the Selection Information dialog, which 
displays information about selected objects. You can find out the 
number of items in a selection by hovering the mouse over the 
Select flyout to display the tooltip. 

1 Select one or more objects. 

2 Click  (Selection flyout) or select Tools > Selection Information. 
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If a single object is selected, then information about that object 
is displayed in the Selection Information dialog (see page 173). 
The information is also displayed in the Command window. 

 
 

Selection information dialog 
Use this dialog to display information about the objects that are 
selected.  

 
As well as basic information about the selection, the following 
information will be displayed (where appropriate): 

 If the object is a surface, further detailed information will be 
given about any sub-selection (such as curves or p-points). 
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 If a group of objects is selected, the dialog tells you how many 
objects are selected and the type and name of each object. You 
can find out the number of items in a selection by hovering the 
mouse over the Select flyout to display the tooltip.  

 The Size of the bounding box containing the objects, and the 
minimum and maximum coordinates of the bounding box. 

 Any selected that is badly trimmed. 

 The centre of gravity for a multiple selection of components. 

The following buttons allow you to see additional information: 

 Toggle detailed information. When a single solid is selected, the 
names of the currently selected solid faces and features is displayed 

 Toggle sub item information. 

 Toggle centre of gravity. 

 Toggle moment of inertia. 

 Toggle the display of the area of the selection.  

 Toggle the display of the volume of the selection.to display the 
volume of the selection. 

Update — You can change the selection of objects and click Update. 
This updates the information to the new selection. 

Box — This displays a bounding box around the current selection. If 
a bounding box is already displayed, it undraws. You can create the 
bounding box around the current selection using the Selection box 
option on the line creation menu. 

 
OK — Close the dialog. If a bounding box has been drawn, this is 
removed.  

 Use the Selection information context menu (see page 175) to 
copy, print or save the information displayed in the dialog. 
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Selection information menu 
Right-click on the Selection information dialog (see page 173) to 
display a menu providing copying, printing, and saving functions. 

 
 

Deselecting objects 
To deselect all objects, either: 

 Click in a space away from any objects, or 

 Select Edit > Select > Clear Selection from the menu. 
 

Selecting coincident objects 
When several objects are beneath the cursor and clicking selects 
the wrong one, click again without moving the mouse and the 
program selects the next object in the database at that position. 
Repeat until the one you want is selected. 

 

Selection using the Intelligent Cursor 
When the Intelligent Cursor is enabled, objects are highlighted as 
you move the cursor over them. This shows which objects can be 
selected if you click at that point. For further details, see Turning 
the Intelligent cursor on or off (see page 53). 

When several objects are under the cursor and one of them is 
selected, the Intelligent Cursor highlights the next object from the 
database at that position. A click now deselects the selected object, 
selects the highlighted object, and highlights the next one. This 
enables you to select the correct object from the group. 

You can also right-click to display the object's menu and click Next 
Selection to select the next object. 

The Intelligent Cursor option is displayed on the context menu. 
Select or Deselect to toggle the Intelligent Cursor on and off.  
Selecting this option is the same as selecting the Intelligent Cursor 
Active option from the Mouse options page of the Options dialog. 

 

Object key points 
All objects have a number of key points which define the object’s 
position and size.  
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These are: 

 Lines - at each end and the mid-point. 

 Arcs - at each end of the sector, the centre point, and the mid-
point. 

 Curves - at each point where the curve can change direction. 

 Surfaces - at each corner of the surface patch (the key points on 
the associated curves behave as for curves). 

 Workplanes - at the origin and end of each axis pointer. 
 

Selection anchor point 
When the object is selected, the program chooses one of its key 
points as the object’s anchor point for the current selection. The 
next selection may (or may not) use a different key point. 

The anchor point is used by the program to decide where to position 
the object, for example during all types of moves and copies. The 
rules for which key point is chosen to be the anchor are as follows: 

 When a single object is selected, the anchor point is the object’s 
key point which was nearest the cursor when you selected the 
object. 

 When objects are selected using a rubber box, the anchor point 
is at the centre of the smallest box capable of containing the 
objects. This applies whether the rubber box contains one or 
many objects. 

 If objects are shift selected individually, the anchor point for the 
group is the key point nearest the cursor on the last object 
selected. 

When you want a specific anchor point for a group, 

1 Select a group of objects, using the rubber-box. 

2 Press the Control key and deselect the objects. 

3 Press the Control key and reselect an object.  

The anchor point for the group selection is now on this object 
rather than at the centre of the rubber box. 

 

Selecting an object by name 
To select an object by its name: 

1 Select Edit > Select > Select by Name from the menu.  

The Add Item To Selection dialog (see page 177) is displayed. 

2 Use the dialog to select an object by its name. 
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Add Item To Selection dialog 
Use this dialog to select an object by its name. 

 
Item type — Select the type of the object you want to select. 

Item name — Enter the name of the object. 

Clear the selection first — Select this option to deselect all currently 
selected objects. 

Add — This adds the selected object to the current selection. If the 
object is blank, it unblanks when selected. 

The dialog remains on the screen so that you can add more objects 
to the selection. 
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Parameters 
Use the following sections to find information on parameters: 

What is a parameter? (see page 178) 

Creating a parameter (see page 179) 

Creating parameters by typing in values (see page 185) 

Editing a parameter (see page 185) 

Using a parameter (see page 185) 

Finding out if a value uses parameters (see page 186) 
 

What is a parameter? 
A parameter is a user-defined variable, which is used to store 
numbers and expressions. 

For example, parameters pi and radius are defined as follows: 

pi = 3.141592654 

radius = 56 

A third parameter circumference can be defined using parameters pi 
and radius: 

circumference = 2*pi*radius 

When you update the radius, circumference is automatically 
updated. 

 Parameters can be used to automatically update your model 
when their definitions are updated. For this to work, you must 
create your model using relational geometry and define its 
objects using parameters. 

 Parameters can be used anywhere you need to enter numbers. 
Parameter names are case sensitive. So, 

FRED 

Fred 

fred 

are three different parameters 

 You can create a parameter in a text box on a dialog or toolbar 
by typing 

param_name=expression 
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where param_name is the name of the parameter and 
expression is an expression representing the numeric value of 
the parameter. 

 

Creating a parameter 
1 Select Object > Parameter from the menu. 

The Parameter Editor dialog is displayed showing the Measure tab. 

 
2 Click New to activate the options. 

3 In the Parameter text box, a default name for the parameter is 
displayed. Change it to something more meaningful to remind 
you what the parameter is used for. 

4 Click Apply. The parameter will now appear in the Parameter drop 
down list, although you have not attached a value to it at this 
stage. 

5 Using any of the pages on the dialog, select your newly created 
parameter from the drop down list.  

6 Enter a value and click Apply to assign the value to your 
parameter. 

You can enter the value in a number of formats. The following 
are all valid for a length parameter: 

8 + 1 gives a value of 9. If you don't include the unit of 
measure (in this case, length), your default unit is used, as 
defined on the Units and tolerances options page. The unit of 
measure will be displayed when you subsequently select the 
parameter from the drop down list. 

8mm + 1in gives a value of 33.4 mm (assuming that your length 
units are set to mm on the Units and tolerances options page) 
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When a parameter has been created it is available to be used. For 
further details, see Using a parameter (see page 185). 

 

Parameter Editor dialog 
The Parameter Editor dialog contains five tabs: 

Measure (see page 182) 

Functions (see page 182) 

Parameters (see page 183) 

Scientific (see page 183) 

Spreadsheet (see page 184) 

 
Each page on the dialog has the following features: 

 the parameter creation options 

 the numerical keypad 

 the calculator (see page 139) functions 

 the expression text box 

 the result text box  

Each page on the dialog has the following options.  

Parameter - Enter a name for the parameter or select a name from 
the drop down list. 

Dimension - By default, a parameter is a measurement of length. 
However, by using this option menu you set it to ratio, length, area, 
volume or angle. 

Tolerance - By default, a parameter has no tolerance associated 
with it. The Tolerance drop down list contains various types of 
tolerance you can set: 

None 
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-:- 
+:- 
-:+ 
+:+ 
Limit-Fit 

Values - If you choose one of the four Tolerance options with the + 
and - symbols, use the Values text boxes to enter the tolerance 
values. 

Limit-Fit - If you choose the tolerance value Limit-Fit, use the Limit-
Fit drop down list to enter a limit value or select one from the list of 
common values. 

New - Select this option to create a new parameter. 

Delete - To delete an existing parameter, use the Parameter drop 
down list to choose a parameter and then click the Delete button. 

Duplicate - To create a copy of an existing parameter, use the 
Parameter drop down list to choose a parameter and then click the 
Duplicate button. 

Result -  The measurement or calculation results are displayed 
here.  

Expression -  This displays values entered by using the numerical 
keypad and buttons. You can also enter a calculation or a value for 
a parameter. 

 
Numerical keypad - Use the keypad to enter a value for a parameter. 

Backspace - Use this to move the cursor one space to the left in the 
Expression text box. Any value entered in the space to the left is 
deleted.  

Apply - Click Apply to create the parameter. 
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OK -  Click to confirm the parameters you have created or modified. 
The dialog is removed. 

Cancel - Click to remove the dialog and deletes all the parameters 
created whilst the dialog was displayed. Any parameters modified 
are also changed back to their original values. 

 

Parameter dialog - Measure 
This page displays the calculator measurement buttons. 

 
Use the measurement options in the same way as Using the 
calculator to measure (see page 146). 

For further details, see Using the calculator (see page 139) 

Projected - If ON, the measurement is projected onto the current 
plane. Use this option with the measurement buttons. For further 
details, see Using the Projected option (see page 158). 

 

Parameter dialog - Functions 
Use the functions on this page to create calculations and logical 
expressions in parameters. 
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Use the functions in the same way as the calculator functions (see 
page 145). 

For further details, see Using the calculator (see page 139). 
 

Parameter dialog - Parameters 
Use this page to create or select previously created parameters and 
their values. 

 
Select parameter - The list of previously created parameters is 
displayed in the large text box . 

Current Value - The value for each parameter in the list is displayed 
in the small text box . 

 

Parameter dialog - Scientific 
Use this page to use scientific functions for creating calculations in 
parameters.  

 
The functions are used in the same way as the calculator scientific 
functions (see page 143). 
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For further details, see Using the calculator (see page 139). 
 

Parameter dialog - Spreadsheet 
Use this page to display a Microsoft Excel spreadsheet where you 
can create and edit data that you want to store with a model. For 
example, you might wish to enter complex calculations for material 
densities or volumes. 

Each new model has a new, blank spreadsheet ready for use. 

 You need a licence for Microsoft Excel to use the spreadsheet 
options. 

 

Worksheet -  This becomes active when the New button is 
selected. Select the worksheet you want to work with in the 
spreadsheet. 

Cell -  This becomes active when the New button is selected. Enter 
the spreadsheet cell containing the value you want to work with. For 
example A1 or D4. The value stored in the cell is displayed in the 
Expression text box . 

 Modify spreadsheet - Click to display a Microsoft Excel 
spreadsheet. You can edit existing data, or enter new data, that you 
want to store with the model. 

 Synchronise parameters with spreadsheet - This synchronises 
PowerSHAPE with the Excel spreadsheet to update all the values 
when changes have been made. Select this option each time you 
edit the spreadsheet. 

 Create multiple spreadsheet parameters - Select this option to 
create numerous parameter names and values in a Microsoft Excel 
spreadsheet. This allows you to apply the parameters all at the 
same time.  

For advanced modelling concepts, see  
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 Creating parameters in a spreadsheet (see page 219) 

 Creating multiple parameters in a spreadsheet (see page 221). 
 

Creating parameters by typing in values 
You can create a parameter in a text box on a dialog or toolbar by 
typing: 

param_name = value 
where param_name is the name of the parameter and value is the 
numeric value of the parameter. 

The type of parameter created (that is, length, angle, area, volume 
or ratio) is determined by the values used in the text box. 

For further details, see Creating a parameter (see page 179). 
 

Editing a parameter 
1 From the Object menu, select Parameter to display the Parameter 

Editor dialog. 

2 Use the Parameter drop-down list to select a parameter to edit. 

3 Use the Parameter Editor dialog (see page 180) to edit the 
parameter definition. 

 

Using a parameter 
Whenever you can enter a numeric expression using the calculator, 
you can specify a parameter instead. The current value of the 
parameter is used instead of  entering a number. To set up the 
parameters ready to be used, see Creating a parameter (see page 
179). 

1 Display the calculator (see page 139). If you are entering a value 
into a dialog, right clicking where you would enter the number 
displays the calculator. For further details, see Calculator dialog 
(see page 140). 

2 Use the calculator as normal. Steps 3 and 4 give instructions on 
putting the value of a parameter into your calculation. 

3 Click the Parameters tab to display the calculator parameters 
options (see page 144). 

All the parameters that have been created are listed .  
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4 Click a parameter to display its value  below the list of 
parameters. 

 
5 Double click on the parameter you want to use. 

The name of the parameter is entered into the calculation 
indicating that the parameter value will be used in the 
calculation. 

6 Once you have completed your calculation, click OK. 

The resulting value is entered into the dialog or toolbar. 
 

Finding out if a value uses parameters 
You can find out if a value uses parameters in one of the following 
ways: 

 A value that is defined with a parameter or expression is 
indicated by the use of = in addition to the value. 

 Display the dynamic help for a box on a dialog by putting the 
cursor in the box. If the value uses parameters, the dynamic 
help will show you the expression containing the parameters in 
addition to the usual help message. This only works for values 
that are parametric. A parametric value is one that remembers 
the parameters used to define it. When the value of any 
parameter is changed, the parametric value updates 
automatically. 

Create multiple parameter names (see page 221) and values in a 
Microsoft Excel spreadsheet in order to apply them to objects all 
at the same time.  

The following are examples of where Parametric values exist on 
dialogs: 

 Solid Cut  

 Solid Boss 
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 Primitive Solid 

 Primitive Surface 

 Solid Extrusion 

 Solid Fillet 

 Solid Bulge 

 Solid Thicken 

 Solid Chamfer 

 Solid Hole 

 Solid Hollow 

 Surface Extrusion 

 Chamfer Editor 

 Active Dimensions 

 



 

188 • Advanced modelling concepts PowerSHAPE 2015 R2 Reference Help  

Use the following sections to find information on advanced 
modelling concepts: 

Starting PowerSHAPE in different modes (see page 188) 

Models - Advanced (see page 192) 

Exporting Data - Advanced (see page 197) 

Table of file types that can be imported (see page 209) 

Importing Data - Advanced (see page 208) 

Parameters - Advanced (see page 219) 

Arm (see page 224) 
 

Starting PowerSHAPE in different 
modes 

You can start PowerSHAPE in different modes. 

1 Before starting the program, right click the PowerSHAPE icon 

 on your desktop. 

Advanced modelling 
concepts 
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2 Select Properties from the context menu. 

 
The PowerSHAPE Properties dialog is displayed, showing the 
following Target path: 

 
3 At the end of the Target path enter a space followed by the 

switch for the required start mode. The example below shows the 
switch -designer  
"C:\Program Files\Delcam\ *XXXX\sys\exec\*\DelcamLauncher.exe" -
designer 
where * is the product installed (for example PowerSHAPE Pro). 
This will start PowerSHAPE in PowerSHAPE Designer mode.  

For further details, see Table of PowerSHAPE start modes (see 
page 190). 
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 The availability of start modes is subject to obtaining the 
relevant product licence. 

To use a combination of start modes (for example -designer -normal) 
type them in the Target path leaving a space between them. 

To view the available start modes in PowerSHAPE, use the switch -
help in the Target path before starting the program. The dialog 
shown below is displayed: 

 
 

Table of PowerSHAPE start modes 
The available start modes are described in the following table.  
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Start mode Switch 
Products  
Start in PartMaker Modeling mode 
This mode checks for the 
COMPANION paf and will not start 
if the correct licence is missing.  
The default tolerances for this 
mode are:  
 general tolerance: 0.0001 

inches 
 shading tolerance: 0.001 inches 

-partmaker 

Start in Designer mode -designer 
Start in Designer evaluation mode -designere 
Start in Drafting mode -draft  

-df 
Start in Electrodemaker mode -electrode 
Start in Pressmaker mode -press 
Start in PowerMILL Modelling mode -mill 
Start in PowerSHAPE-e mode -e 

-free 
Start in PowerSHAPE Pro mode -pro 

Start in Sketcher mode -sketcher 

 
Start mode Switch 
Commands  

Start with n check level (-1->4) -check_level n 

Start with database core of n size in 
MB (1 or more) 

-db_core n 

Import given file -import filename 
Load named model file -file filename 
Load named library file -library filename 
Run macro file -macro filename 
Pass arguments to macro at runtime -macro filename 

arguments  
View these options -help 
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Window sizes  

Start normal size -normal 
Start maximised -max 

Start minimised -min 

Set window position, width and 
height 

size x,y,w,h 

Set window size and position -normal -
window_size:0,0,1280,100
0 

 The availability of start modes is subject to obtaining the 
relevant product licence. 

 

Models, advanced 
For further advanced details about models, select from the 
following: 

 Save Model As dialog (see page 192) 

 Creating a template model (see page 195) 

 Keeping track of changes made to a model (see page 196) 
 

Save Model As dialog 
Use this dialog to save a model using a new name. 

 
Model name — Type a suitable name for your model. If there is 
already a model with the name that you enter, a warning message 
is displayed, to avoid you accidentally overwriting an existing 
model. You can choose to continue saving your new model to an 
existing filename, in which case the existing model will be 
overwritten. 
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If you import files into a new model, the name of the last one 
imported minus its extension is automatically displayed as the 
Model Name when you save the model. For example, if the name of 
the last file imported is handle.igs, the Model Name is handle. 

Description — Type a suitable descriptive message. This is to help 
you find specific models that might have similar names. 

You can leave this box blank if you do not need a description. 

Password — If you want to protect the model, enter a password. 
However, don’t forget it, because you may not be able to open the 
model when you need to. 

 Store Outside Database — This allows you to store models 
anywhere on the local disk or network. Click the button to 
display the Save As dialog. Use the Save As dialog to select 
where to save the model and then click Save to store the 
model. 

If models are stored in the database, the models are saved and 
organised on the local disk or network. When you want to open the 
model, you only need to remember the model name to find the 
appropriate files. 

Save — This saves the model and removes the dialog from the 
screen. The model is saved in the default format. For further details, 
see Changing the default format for saving models (see page 194). 

 

Browse for folder dialog 
Use this dialog to define the folder for storing the vault model.  

1 Select the folder.  

2 Click OK. 
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Cancel - This removes the dialog from the screen without saving the 
model. 

 On a new or read-only model, File - Save displays the Save 
Model As dialog (see page 192). 

 

Changing the default format for saving models 
When you install PowerSHAPE, you can select the default format for 
storing models as follows: 

 a single file (psmodel). 

 a set of files in a folder. 

In the current session of PowerSHAPE you can change the default 
format for storing models. 

1 From the Tools menu, select Options to display the Options 
dialog. 

2 Select the Model option. 

3 In the Model Save As Format section, select the default method 
for storing models. 

4 Directory - Stores your model using the directory structure. 

5 Single - Stores your model as a single file. 

6 Click OK. 

 With the File Save command, a model is always saved using 
the same structure regardless of the Model Save As Format 
option. 

 

Saving a model with a thumbnail 
By default, a new thumbnail of your model is automatically created 
whenever you save your model. 

You can choose to save the thumbnail when you want by changing 
the settings as follows: 

1 Open the model. 

2 From the Tools menu, select Options to display the Options 
dialog. 

3 Use  to expand the File options.  

4 Click Model to display the Model page of the Options dialog. 

5 Change the Save Mode setting to Manual. 
6 Click OK. 
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To save the thumbnail, 
1 Change the view of the model to the one you want to appear in 

your thumbnail. 

2 From the File menu, select Save Thumbnail. 
3 From the File menu, select Save or Save As to save the model 

and the thumbnail. The Save mode setting is also saved so 
whenever you open the model you can manually update the 
thumbnail. 

 

NEW_MODEL_MASTER 
A template model is a model that is used as the basis for all new 
models. This model is called: 

NEW_MODEL_MASTER_29 

If a template model exists, a copy of this model is created each 
time you create a new model using the File > New command. 

Your template model can store things like: 

 your company defaults for model-dependent options on the 
Options dialog, such as tolerance. 

 your standard level settings and names. 

 line styles.  

Even standard geometry (such as symbols) can be included in this 
model. 

 You must have system administrator security to create and 
edit the template model. 

To create a template model: 
1 Make sure no-one else is using PowerSHAPE and that you have 

system administrator security. 

2 Create a model containing all the required settings. 

3 Save the model with the name NEW_MODEL_MASTER_29 as 
follows: 

a Select Tool > Options to display the Options dialog. 

b In the dialog, select File > Model from the tree. 

c Deselect Always save and open from outside the database.  

d Click OK. 

e Save the model. 

4 Delete all existing models with names of the form 
NEW_MODEL_<*>_29  
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(where * is the number of the model).  

For example, NEW_MODEL_1_29. 

If Always save and open from outside the database is deselected 
and you have administration access you will be able to do this by 
selecting File > Delete. Alternatively: 

a Open the Command window. 

b Type: admin delete model 
c Type: NEW_MODEL_*_29  

(where * is the number of the model). For example, 
NEW_MODEL_1_22. 

5 Select Always save and open from outside the database to start 
saving models outside the database again. 

 The template model can be edited as if it were any other 
model. 

 

Keeping track of changes made to a model 
If Delcam PS-Team is installed on a server and visible from your PC, 
you can set up a topic to keep track of the changes made to your 
models. 

On the PS-Team page of the Options dialog, you can specify the 
names of the topics to use for models named explicitly or by fields. 
We refer to vault and temporary models as models named 'by fields' 
and all other models as 'explicitly'. You can also specify the server 
and the URL for PS-Team. 

PS-Team is an Internet-based software tool, provided by Delcam, to 
support communication between teams of people. 

To start PS-Team, select PS-Team from the Application menu to 
display PS-Team in the browser window. If the server and URL for 
PS-Team are not set up on the PS-Team page of the Options dialog, 
a dialog appears asking for them. 

If the browser window is displayed, you can click: 

 the PS-Team tab  to display the Delcam PS-Team page. 

 the History tab  to display the task associated with the 
current model. 

When a model is saved with a new name, a new task is 
automatically created in PS-Team. In the task for the model, you 
can manually add information to the task associated with a model to 
record any changes. 
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When you import and export data, the task is automatically updated 
giving details of the import and export files. 

If you delete a model, the status of the task is changed to 
complete. 

For further details, click Help in the PS-Team window. 
 

Importing and exporting, advanced 
PowerSHAPE uses Delcam Exchange (see page 197) to translate 
data files from other software in cases where the in-built translators 
are not used. 

The following sections give details of advanced export and import 
methods: 

Exporting data, advanced (see page 197) 

Importing data, advanced (see page 208) 
 

Using Delcam Exchange to translate data 
Delcam Exchange is a stand-alone program which is linked to the 
program to allow you to translate certain types of data. It can also 
be used on its own. 

The following sections show you how to use Delcam Exchange 
within PowerSHAPE to translate data, but not how to use Delcam 
Exchange stand-alone. 

Use either PowerSHAPE or Delcam Exchange to translate data. For 
further details, see Importing files using Delcam Exchange (see 
page 215) and Exporting files using Delcam Exchange (see page 
204). 

Delcam Exchange understands the same licence options as the 
program's built-in translators. For example, if you have a licence for 
importing CATIA files, you can use this to import CATIA files using 
Delcam Exchange. However, if you have not purchased a licence for 
importing CATIA files, for example, you can still use Delcam 
Exchange to import the file by purchasing a 'pay-per-use' voucher 
from Delcam's web site. 

 

Exporting Data - Advanced 
Select Tools > Options > Data Exchange > Version 8/ Surfaces and 
use the Export options for exporting files. 

For further details about exporting data, select from the following: 

 Using Delcam Exchange to translate data (see page 197) 
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 Exporting data without a licence (see page 204) 

 Exporting materials (see page 205) 
 

Table of file types that can be exported 
The following table shows the file types that can be exported using 
the File > Export option. 

 

 indicates that this file format uses Delcam Exchange as the 
default translator. 
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Delcam Geometry (*.dgk) 
 

This is a special format that defines 
the product's data in a single file. 
If objects are selected, only symbols, 
points, surfaces, solids, and 
wireframe objects in the selection are 
exported. If a workplane is active, it 
is automatically exported. 
If nothing is selected, the program 
exports symbols, points, surfaces, 
solids, wireframe objects and 
workplanes on levels which are 
selected. 
A symbol is exported as its individual 
objects. 
Symbol triangles are exported as a 
dmt file during dgk export. They will 
have the same name as the dgk file 
but with an extension .dmt. 
Component names are preserved 
when exporting the components as 
solids, for example when exporting 
an assembly component as .dgk file. 
If you have a model containing 
solids, surfaces and triangle data, 
you can select all the objects and 
export to a .dgk file. A corresponding 
.dgk.dmt file will also be exported. 
For details on importing these 
exported files see Delcam Geometry 
(*.dgk) in Table of file types that can 
be imported (see page 209) 

Delcam Geometry + 
Features (.dgk) 

 

Features will be in .mac and .xml 
files. 
This works in the same way as 
exporting selecting the Create Hole 
Features for all DGK on the 
Manufacturing > Export options dialog.  

DDX (.ddz)  
 

Export data in the .ddz format. This 
format is used to transfer data in 
Sketcher and PowerMILL Modelling. 
Geometric tolerances and datums are 
included in the export file. 
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DDX + DGK (.ddz)  Export data in the .ddz format. This 
format is used to transfer data in 
Sketcher and PowerMILL Modelling. 
All Parasolid solids are converted to 
V8 solids. 
Geometric tolerances and datums are 
included in the export file 

Rhino  4(*.3dm)  
Rhino  5(*.3dm)  

Export the model as a Rhino file 

Point Formats (.asc) 
 

Export point cloud data in .asc format 

ACIS (*.sat)  
Export selected surfaces and solids to 
this format. If nothing is selected, all 
the solids and surfaces in the model 
are exported. 
Solids are exploded into surfaces 
when you export. 

Adobe Acrobat Document 
(*.pdf) 

 

Exports drawings as .pdf files. 

CADDS (*.c4x)  
Define the model as a CADDS file. 
CADDS files of version 4 can be 
exported from PowerSHAPE. 
The entire model is exported 
regardless of what is selected. 

CATIA5 (*.CATPart)  
Export CATIA5 files using Delcam 
Exchange for exporting surfaces. 

Delcam Machining 
Triangles (*.dmt) 

 

Export the selected triangles for use 
by other Delcam products. 
Set the tolerance for exporting 
triangles on the Triangle/Mesh page of 
the Options dialog. You can also set 
the tolerance for exporting triangles 
on the Import/Export page of the 
Options dialog.  

DWG Files (*.dwg)  
Export only the drawings in the 
model. 
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DXF Files (*.dxf)  
Define the model as DXF data 
(AutoCAD data). 
To export DXF files, you can use 
either Delcam Exchange or the DXF 
internal translator. 

HPGL (*.plt) 
 

Export the file as a plot file 

IGES (*.ige) 
IGES (*.igs) 
IGES (*.iges) 

 

Define the model according to the 
IGES (International Graphics 
Exchange Standard) specification. 
Most High level CAD systems can 
provide models in this model format. 
Only selected objects are exported. If 
nothing is selected, you are asked 
whether you want to export the 
entire model. 
If a drawing window is selected, only 
this drawing is exported. Otherwise 
the model and all its drawings are 
exported. 
You can set how data is exported to 
IGES files using the Options dialog.  
Delcam Exchange may not export 
drafting objects to an IGES file. If 
you try to do so, a message is 
displayed explaining the drawbacks 
of using Delcam Exchange. The 
message asks you if you want to 
continue to use Delcam Exchange. If 
you select NO, the command is 
cancelled. 

 

 

Parasolid (*x_b) 
Parasolid (*.x_t) 
Parasolid (*.xmt_bin) 
Parasolid (*.xmt_txt) 

 

Export the selected surfaces to this 
format. If no surfaces are selected, 
then all the surfaces are exported. It 
is possible to export to earlier 
versions of Parasolid by selecting the 
appropriate version in the Parasolid 
options dialog. 
For details on methods for exporting 
Parasolid files, see Parasolid export 
methods. 
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Picture (*.pic) 
 

Defines the model as a wireframe 
using arcs, lines and curves. 
PowerSHAPE can write DUCT5 
pictures. 
Only selected wireframe objects and 
surfaces are exported. 

pslast (*.pslast) Export a shoe last to MIND software. 
This option is only displayed in 
footwear mode. 

psstyle (*.psstyle) Export style lines  to MIND software. 
This option is only displayed in 
footwear mode.  

Rhino (*.3dm)  
Export the model as a Rhino file 

STEP (*.step) 
STEP (*.stp) 

 

Export selected surfaces and solids to 
this format. If nothing is selected, 
you are asked whether you want to 
export the entire model. 

 

Stereo lithographic file 
STL format (*.stl) 

 

Export a triangulated representation 
of each selected solid or surface in 
STL (Stereo Lithography) format. STL 
files normally represent closed solids 
as they are primarily used for rapid 
prototyping and many rapid 
prototyping machines require a fully 
closed triangular mesh. 
PowerSHAPE attempts to produce a 
closed mesh from the selected 
model. If it fails, you are prompted to 
close the mesh manually or save an 
'open' STL file which may not be 
suitable for rapid prototyping. 
You can set options for exporting 
triangles on the Triangle/Mesh page of 
the Options dialog.  
You can also set the tolerance for 
exporting triangles on the 
Import/Export page of the Options 
dialog.  

Universal 3D Sample 
Software (*.u3d) 

 

Export 3d data and embedded u3d 
data. 
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VDA-FS Files (*.vda)  
Defines the model as a VDA-FS file. 
VDA-FS version 2 files can be 
exported directly. All VDA-FS entities 
are supported, with the following 
constraints: curves of a degree 
higher than 3 are approximated by 
cubic beziers to tolerance. 
Only selected surface, solid and 
wireframe objects are exported. 

Virtual Reality Markup 
Language (*.wrl) 

 

Export the selected surfaces and 
solids to this format. Any VRML 
reader can then view these. 
By default, the material, lighting and 
view data are exported with the 
model. To export just the view data 
with the model, change the Output 
Mode option to model on the Options 
dialog.  

Wavefront (*.obj) 
 

Export a text file containing 
polygonal faces. 

POV-Ray scene (*.pov) 
 

Export a POV-Ray scene. 

Delcam Electrode Archive 
(*.trode) 

 

Export .trode files. 

PowerSHAPE-e Model 
(*.emodel) 

Export the model as a PowerSHAPE-e 
model. 

PowerSHAPE model 
version  
(*.psmodel VerXX) 
where XX is the model 
version number.  

Export the model to the previous 
PowerSHAPE format. 
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Exporting files using Delcam Exchange 
A list of file types that are available when exporting using Delcam 
Exchange are given below.  

 
For full details on what objects are exported using Delcam 
Exchange, see the on-line help available within Delcam Exchange. 

 

Exporting without a licence 
If you don't have a licence to export a particular type of file, you 
can purchase vouchers on a pay-per-use basis in Delcam Exchange. 

1 From the File menu, select Export (see page 98).  

The program detects automatically that there is no valid licence 
and displays a dialog giving you the option to view the file in 
Delcam Exchange. 

2 Select one of the following options: 

Yes — Starts Delcam Exchange where you can view the file and 
purchase a voucher to complete the export process (see page 
205).  

No — A dialog is displayed, detailing possible reasons for the 
failed export. The export may fail for opne of the following 
reasons: 

 You have an invalid licence file. 

 Delcam Exchange is incorrectly installed. 

 Delcam Exchange registry entries are invalid. 
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Exporting without a licence using Delcam Exchange 
Use this dialog to continue exporting files without a licence using 
Delcam Exchange. The file you want to export is displayed in the 
viewer. 

 
1 Select File - Export. 
2 Follow the Delcam Exchange file export process.  

You will be prompted to purchase a voucher in order to complete 
the export for the selected file.  

For further details, see the help provided with Delcam Exchange. 
 

Exporting files using PowerSHAPE-e 
If you want to use Delcam Exchange and don't have a licence to 
translate a particular type of file, you can purchase vouchers on a 
pay-per-use basis using the Voucher Wizard. For further details, see 
Using Vouchers (see page 108). 

 

Exporting materials 
1 Select Format > Materials to display the Material Selection dialog. 

2 Select Export.  
This option exports the following: 

 A group of materials. 

 A single material. 

 All materials. 
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Export Materials dialog 
Use this dialog to select materials to export. 

 

To export a group of materails 
1 Select Export group to export a group of materials. 

2 From the Select material type list, select the group of materials 
that you want to export. 

3 Enter the Export To path or click the Browse  button to specify 
the path to the new ExportMaterials folder that is created to hold 
the materials images and the .csv file for your exported 
materials. 

4 Click Export. 
5 Click OK to export the group of materials and close the dialog. 

To export a single material 
1 Select Export single Material to export a single material. 

2 From the Select material type list, select the group of materials 
that you want to export from. 

3 From the list of corresponding materials displayed in the dialog, 
select the specific material you wish to export. 

4 Enter the Export To path or click the Browse  button to specify 
the path to the new ExportMaterials folder that is created to hold 
the materials images and the .csv file for your exported 
materials. 

5 Click Export. 
6 Click OK to export the material and close the dialog. 
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To export all materials 
1 Select Export all to export all materials. 

2 Enter the Export To path or click the Browse  button to specify 
the path to the new ExportMaterials folder that is created to hold 
the materials images and the .csv file for your exported 
materials. 

3 Click Export. 
4 Click OK to export all materials and close the dialog. 

 Care must be taken if you modify the .csv file. If the .csv file 
is damaged, the Import Materials (see page 218) function, 
that you use to import the images into PowerSHAPE, will fail. 

 

Creating a .csv file for materials 
In order to use the Import Materials functionality you must have a 
.csv file that has been created previously. The .csv file is created 
automatically when you export using the Export Materials option. 
The .csv file can be viewed with Microsoft Excel or other editor. 

If you want to import user-created materials into PowerSHAPE you 
must create a .csv file manually. 

 To create or modify a .csv file you will be working with 
PowerSHAPE's database, and it is advisable to be familiar with 
the attributes of materials in the "Materials" table in the 
PowerSHAPE database. 

1 Create and name the .csv file. There are specific names for .csv 
files, as follows: 
Importing a group of materials 

GroupName_MaterialGroup.csv 
Importing a single material 
MaterialName_Material.csv 
Importing all materials 

Material_all.csv 

2 Enter the following lines as the top two lines in the file. 

Material File 
UserCreated 

3 Make entries in the file on the following lines in the sequence: 

Material name, Group Name, Red, Green, Blue, Polish, Emission, 
Translucency, reflect, shader_scale 



 

208 • Advanced modelling concepts PowerSHAPE 2015 R2 Reference Help  

4 You must also keep image files of the corresponding materials in 
the same folder where the .csv file is stored. The file names must 
follow the example below: 

Material_Name.extension 

where extension refers to ".jpg", ".bmp", ".tif" or ".rgb". 
 

Viewing the csv file for materials 
1 Locate the .csv file in the directory you specified as the directory 

to Export to on the Export Materials dialog. 

2 Double click the filename to open the spreadsheet. It shows all 
the details for all the materials selected to be exported, shown in 
the example below: 

 
 

Importing Data - Advanced 
Select Tools > Options > Data Exchange > Version 8/Surfaces and 
use the Import options for importing files. 

For further advanced details about importing data, select from the 
following: 

 Starting up PowerSHAPE and importing a file (see page 216) 

 Table of file types that can be imported (see page 209) 

 Importing files using Delcam Exchange (see page 215) 

 Importing data without a licence (see page 216) 

 Importing Materials (see page 218) 
 



 

PowerSHAPE 2015 R2 Reference Help Advanced modelling concepts • 209  

Table of file types that can be imported 
The file types that can be imported into PowerSHAPE are displayed 
in the drop-down list on the Select a file to import dialog. 

 

 The file types that are available to you will depend on the 
version of Delcam Exchange that you have installed 

The file types that can be imported (using the File > Import option) 
are shown in the following table:  

PowerSHAPE uses Delcam Exchange to import data, unless 
indicated in the table below. 
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File format Type of file 
PowerSHAPE Model 
(*.psmodel)  

This is a PowerSHAPE model using the 
single file format. If you have a model on 
removable media (tape or disk) which 
does not appear in your model database, it 
can be imported into your model 
database. Each model is held in a directory 
that contains the model files. 

PowerSHAPE-e Model 
(*.emodel)  

PowerSHAPE-e model. It can be imported 
into PowerSHAPE on a pay-per-use basis 
using the Voucher Wizard. 

ShoeMaker Model 
(*.shoe)  

This file format is created by Delcam 
Crispin ShoeMaker. 

ShoeMaker-e Model 
(*.eshoe)  

This file format is created by Delcam 
Crispin ShoeMaker -e. 

Model and DUCT Drawing 
(*.det)  

PowerSHAPE and DUCT5 model and 
drawing format. 
If you have a model that does not appear 
in your model database, it must be 
imported. Each model is held in a directory 
that contains the model files. 
The contents of the drawing are imported 
into a new model with the same name as 
the drawing. 

DDX (*.ddx, *.ddz)  This is data that has been exported from 
Delcam Exchange. 

Delcam Geometry 
(*.dgk)  

This is a special format that defines the 
product's data in a single file. 
If you import a model containing solids, 
surfaces and triangle data that has been 
previously exported, it will also import the 
corresponding .dgk.dmt file at the same 
time. So, both the solids, surfaces and 
triangle data will be imported. 
The .dgk and .dgk.dmt files must be in the 
same folder for the import to be successful 

Delcam Machining 
Triangles (*.dmt)  

A .dmt file is imported as a symbol. The 
symbol definition is also stored in the 
model and has the same name as the file. 
For further details, see Creating a symbol 
definition. 
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Delcam Electrode Archive 
(*.trode)  

This is a special format that defines the 
product's data in a single file. An electrode 
archive (.trode) file is a single file that 
stores a collection of one or more 
electrode .dgk files with associated 
metadata (.xml) files and setupsheet 
images. 

Delcam Crispin (*.lst, 
*.v3e, *.las)  

Import a last of created with Delcam 
Crispin software. 

CopyCAD session 
(*.ccs)  

All of the surfaces, curves and triangles 
within the file are converted to levels in 
the current PowerSHAPE model. 
Workplanes are also converted, but 
scanlines, points, images and views are 
not converted. 

CADDS 4 and 4.5(_pd*), 
(*.c4x)  

Delcam Exchange may not import drafting 
objects from an IGES file. If you try to do 
so, a message is displayed explaining the 
drawbacks of using Delcam Exchange. The 
message asks you if you want to continue 
to use Delcam Exchange. If you select NO, 
the PowerSHAPE translator is 
automatically used 

Cloud Formats (*.asc, 
*.mod, *.csv, *.xyz)  

Files containing point cloud information. 
The formats that are supported are 
.asc - ASCII 
.mod  
.csv - ASCII text encoded as Comma 
Separated Values. 
.xyz - Perceptron . 

Picture (*.pic)  This format defines the model as a 
wireframe using arcs, lines and curves. 
PowerSHAPE can read DUCT5 pictures. 
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Triangle files (*.dmt, *.obj, 
*.stl, *.tri)  

A .dmt or .obj file is imported as a symbol. 
The symbol definition is also stored in the 
model and has the same name as the file. 
For further details, see Creating a symbol 
definition. 
.obj imports a text file containing 
polygonal faces. 
.stl imports the triangulated 
representation in STL (Stereo Lithography) 
format. STL files normally represent closed 
solids as they are primarily used for rapid 
prototyping and many rapid prototyping 
machines require a fully closed triangular 
mesh. 
 

Adobe Acrobat Document 
(*pdf, *.ai) 

Files containing  text and wireframe can 
be imported.. PowerSHAPE Pro and 
Toolmaker Pro can also import curves. 

ACIS (*.sat)  This format defines the model as an ACIS 
file 

AutoCAD (*.dwg,*.dxf)  This format defines the model as DWG or 
DXF data (usually exported from AutoCAD) 

CATIA5 (*.CATpart, 
*.CATProduct) 
Catia (*.cat, *.exp, *fic*, 
*model)  

 

These define the model as a Catia file. 
The Catia export files *.cat and *.exp are 
made up of a number of Catia fic files. By 
default, each .fic file is imported into a 
separate new model. You can import the 
.fic files into the same model by turning 
off the Open a new file for each fic file 
option on the Import/Export page of the 
Options dialog.  

Cimatron (*.pfm)  This format defines the model as a CADDS 
file. CADDS files of version 4 and 5 can be 
imported into PowerSHAPE 

Cynovad (*.sme, *.spi, 
*.too) 

This file has been generated by dental 
software. 

Elite (*.elt)  This defines the model as a Cimatron file 

Ideas (*.mf1), (*.prt)  This format defines the model as an Ideas 
file 
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IGES (*.ig*)  This defines the model according to the 
IGES (International Graphics Exchange 
Standard) specification. Most high level 
CAD systems can provide models in this 
model format. 
You can set how data is imported from 
IGES files using the Options dialog. 
Blanked IGES surfaces are imported as 
blanked. 

Inventor (*ipt)  This format defines the model as an 
Autodesk Inventor file 

Last and Style (*.pslast, 
*.psstyle)  

Import a last and style created with MIND 
software This option is only displayed in 
footwear mode. 

Parasolid (*.x*)  This format defines the model as a UG 
Parasolid file 

Pro/Engineer (*.asm, 
*.prt*)  

These formats define the model as a Pro-
Engineer file. 

Rhino (*.3dm)  This format defines the model as a Rhino 
file. When importing Rhino files, all 
triangle data is also imported. 

Sirona (*.cdt, *.sdt, *.gdm, 
*.gdb, *.vtl, *.idt) 

Import a file from dental software inLab 
3D. 

Solidedge (*.par)  This format defines the model as a 
SolidEdge file. 

Solidworks (*.sldprt, 
*.sldasm)  

This format defines the model as a 
SolidWorks file. 

SpaceClaim (*.scdoc)  This format defines the model as a 
SpaceClaim file. 

STEP (*.step, *.stp)  This format defines the model as a STEP 
file. 

U3D This is a graphics file; U3D is the 3D 
element of a 3D PDF file; it can also be 
used as a stand-alone traingle file-format 

Unigraphics (*.prt)  This format defines the model as a 
Unigraphics file. 
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VDA-FS (*.vda)  This format defines the model as a VDA-FS 
file. VDA-FS version 2 files can be 
imported directly. All VDA-FS entities are 
supported, with the following constraints: 
curves of a degree higher than 3 are 
approximated by cubic beziers to 
tolerance. 

3Shape (*.dcm) Import a file from 3shape dental software 

Procera (*.c3s) Import a file that was generated by 
Procera dental software. 

FootCAD (*.IDS, *cad) Import a file that was generated by IDEAS 
orthotic software. 

3MLava (*ccd0, *.ccd1, 
*.ccd2) 

Import a file from 3M dental software. 

Amfit (*.abt, *e01) Import a file from Amfit orthotic software 

Schott (*.vec) Import a file from Schott general purpose 
3D software 

WinMAX (*.mxd) Import a file that was generated by 
WinMAX V3.7 MXD Files 

SoleCAD (*.smr, *.cad) Import a file that was generated by IDEAS 
orthotic software. 

ASCON (*.a3d, *.m3d, 
*.cdw) 

Import a file that was generated by 
ASCON general purpose CAD software. 

Paromed (*.pme) Import a file that was generated by 
Paromed orthetic software. 

Orthema (*.001) Import a file that was generated by 
Othema orthotic software. 

XTL (*.xtl) Import a file from dental software 
HICAD (*.neu) Import a file that was generated from the 

HICAD CAD system 

TopSolid (*.top, *.cam) This file was generated by the TopSolid 
CAD system. 

iTero (*.3dc) The file was generated by CADDent. 

AOMS (*.raw) The file is from a Sharp Shape orthotic 
scanner. 

GPSCAN (*.einlage) This file contains Gebiom orthotic scan 
data. 

Creo (*.prt, *.asm) This filewas generated by Creo CAD 
system 
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Shoe Design (*.des)  This file was generated by Delcam Crispin 
Shoe Design. 

Zip (*.zip)  You can import a zip file if it contains one 
of the following: 
 a single file such as IGES or dgk 
 a single psmodel file 
 a single directory model 

Mind (*s3d) Import a file from MIND shoe 
software. 

 
 

Importing files using Delcam Exchange 
A list of files you can import using Delcam Exchange are given 
below. We also give the benefits of using built in translators and 
Delcam Exchange (if any). 
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For full details on objects that are imported using Delcam Exchange, 
see the on-line help available within Delcam Exchange. 

 

Starting up PowerSHAPE and importing a file 
When you start up the program you can open a model and import a 
file at the same time by typing: 

powershape -file f1 -import f2 

where f1 is the name of the model and f2 is the path of the 
imported file.  

You can also use the following commands: 

powershape f1 f2 

powerSHAPE -import f2 -file f1 

To import a file into a new model, type one of the following 
commands: 

powerSHAPE -import f2 

powerSHAPE f2 

 For the above commands to work, you must have FILE OPEN 
IFNONE in your login macro. For further details, see What is 
the login macro? (Managing your PowerSHAPE system). 

 

Importing without a licence 
If you don't have a licence to import a particular type of file, you 
can purchase vouchers on a pay-per-use basis in Delcam Exchange. 

1 Select File > Import (see page 104).   

The program detects automatically that there is no valid licence 
and displays a dialog giving you the option to view the file in 
Delcam Exchange. 

2 Select one of the following options: 

Yes — Starts Delcam Exchange where you can view the file and 
purchase a voucher to complete the import process (see page 
217).   
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No — Exits the import process and displays a dialog 

 
3 Click OK to exit. A log report is displayed.  

 

Importing without a licence using Delcam Exchange 
Use this dialog to continue the file import process using Delcam 
Exchange. The file you want to import is displayed in the viewer. 

 
In order to import the file into PowerSHAPE you must first export it 
in Delcam Exchange. The file type you export to is automatically 
selected by Delcam Exchange.  

1 In the Delcam Exchange viewer, select File >Export 
The file type is already selected in the dialog.  

 It is recommended that you do not change this file type. 

2 Click Export and follow the Delcam Exchange export process.  

You will be prompted to purchase a voucher in order to complete 
the export for the selected file.  
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For further details, see the help provided with Delcam Exchange. 

Once the file is exported in Delcam Exchange, you can import the file 
directly into PowerSHAPE, using File >Import (see page 104).   

 

Importing Materials 
In order to import materials you must have a .csv file that has been 
created previously. A .csv file is created automatically when you 
export materials using the Export Materials option on the Material 
Selection dialog. For further details, see Exporting data from a 
model (see page 98) 

If you want to import user-created materials you must create a .csv 
file manually. 

1 Select Format > Materials to display the Material Selection dialog. 

2 Select Import. The Select CSV file to Import material dialog (see 
page 218) is displayed. For further details see, Creating a csv file 
for materials (see page 207)  

 

Select CSV file to import material dialog 
Use this dialog to select CSV files to import materials. 

 
1 Navigate to the required folder and select the valid .csv file 

containing the materials data that you wish to import into your 
databaserequired file. 
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 In order to import materials you must have a .csv file that 
has been created previously. A .csv file is created 
automatically when you export materials using the Export 
Materials option on the Material Selection dialog. If you 
want to import user-created materials into PowerSHAPE 
you must create a .csv file manually. 

2 Click Open to import the materials data contained in the .csv file. 

 You must restart the program  after importing materials in 
order to make the materials available for use. 

 

Parameters, advanced 
For further advanced details about creating parameters, select from 
the following: 

 Creating parameters in a spreadsheet (see page 219) 

 Creating multiple parameters in a spreadsheet (see page 221) 
 

Creating parameters in a spreadsheet 
For models that require complex calculations or have specific data 
associated with them, these values can be created and edited in a 
Microsoft Excel spreadsheet that is stored with the model. 

Each new model has a new, blank spreadsheet ready for use. 

 You need a licence for Microsoft Excel to use the spreadsheet 
options. 

1 From the Object menu, select Parameter to display the Parameter 
Editor dialog. 

2 Select the Spreadsheet tab. 
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3 Click  to display a Microsoft Excel spreadsheet. 

 
4 Enter values and any calculations into the spreadsheet. 

 
5 Select File, and select Close and return to New_Model_1, where 

New_Model_1 is the name of the current model in PowerSHAPE. 

6 In the Parameter Editor dialog, Select New and enter the 
parameter name in the Parameter text box. 

7 In the Cell text box, enter the cell for the value you want to work 
with.  

For example enter A3.  
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8 Click  to display the cell's value is displayed in the Expression 
text box. 

 
9 Click Apply to store the parameter and continue. 

10 Click OK to store the parameter and exit. 
 

Editing parameters in a spreadsheet 
To edit the values in the spreadsheet:  

1 Select . The spreadsheet stored with the model is displayed. 
You can make changes, add new values or delete values. 

2 In the spreadsheet, select File, and select Close and return to 
New_Model_1, where New_Model_1 is the name of the current 
model. 

3 Select  to synchronise the program with the Excel spreadsheet. 
The spreadsheet is updated with any changes to the values. 
Select this option each time you make any changes. 

 Use the same method to add new values. 
 

Creating multiple parameters in a spreadsheet 
You can create numerous parameter names and values in Microsoft 
Excel spreadsheets and apply them all at the same time. 

When these are created, the parameters are available to be used in 
a text box on dialogs. For further details, see Finding out if a value 
uses parameters (see page 186). 

 You need a licence for Microsoft Excel to use the spreadsheet 
options. 
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To create multiple parameters, you need to enter the data into the 
spreadsheet. 

1 From the Object menu, select Parameter to display the Parameter 
Editor dialog. 

2 Select the Spreadsheet page. 

 

3 Select  to modify the spreadsheet. A Microsoft Excel 
spreadsheet is displayed. 

 
4 Enter one column with parameter names and another column 

with their values. 
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The example below shows parameter names entered in column A 
and their values entered in column B. 

 
5 Select File, and select Close and return to New_Model_1, where 

New_Model_1 is the name of the current model in PowerSHAPE. 

6 On the Parameter Editor dialog, select  to create multiple 
spreadsheet parameters. 

The Multiple Spreadsheet Parameters dialog (see page 223) is 
displayed. 

Use this dialog to create a set of parameters with the values 
entered on the spreadsheet that are to be available to be 
selected in dialogs. 

 

Multiple Spreadsheet Parameters dialog 
Use this dialog to create a set of parameters for the values entered 
on the spreadsheet that are to be available to be selected in 
dialogs. For further details, see Creating multiple parameters in a 
spreadsheet (see page 221). 

 
1 Select a Worksheet from the drop down list. 

2 Enter the column letter from the spreadsheet where the 
parameter names were entered. For example A. For further 
details, see Creating multiple parameters in a spreadsheet (see 
page 221) 
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3 Enter the column letter from the spreadsheet where the 
parameter values were entered. For example B. For further 
details, see Creating multiple parameters in a spreadsheet (see 
page 221) 

4 Click OK. 

This creates a set of parameters with values that are now available 
to be selected in dialogs. For further details, see Finding out if a 
value uses parameters (see page 186) 

 

Editing multiple parameters in a spreadsheet 
Multiple parameters are entered in a Microsoft Excel spreadsheet 
that is stored with each model. To edit existing data in a 
spreadsheet, 

1 From the Object menu, select Parameter to display the Parameter 
Editor dialog. 

2 Select the Spreadsheet page. 

3 Select . A Microsoft Excel spreadsheet is displayed. 

4 You can edit existing data and add new data to the spreadsheet. 

5 On the spreadsheet, select File, and select Close and return to 
New_Model_1, where New_Model_1 is the name of the current 
model in PowerSHAPE. 

6 Select  on the Spreadsheet page of the Parameter Editor dialog 
(see page 184). For further details, see Creating multiple 
parameters in a spreadsheet (see page 221). 

This synchronises PowerSHAPE with the Excel spreadsheet to 
update all the values when changes have been made. 

Select Synch each time you edit the spreadsheet. 
 

Arm 
Click Arm  on the status bar (see page 30) and select from the 
following: 

 Connecting the Arm (see page 225) 

 Using the Arm probe (see page 226) 

 Using a bounding box to define an object (see page 227) 

 Creating objects using the probe (see page 227) 

 Basic Paddle Operations (see page 228) 

 Arm functionality does not work with 64-bit Windows. 
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Installing the Arm 
PowerSHAPE currently supports the following digitising devices: 

 MicroScribe G2X. The drivers for this are built into PowerSHAPE, 
so this is available without additional software. 

 WACOM tablet. The drivers for the specific tablet need to be 
installed. These are provided with the tablet, or can be 
downloaded from the relevant web site. 

To use other devices with PowerSHAPE: 

1 Install a version of PowerINSPECT. 
2 Run the PowerINSPECT DRO. This will register the .dll files 

3 Select CMM from the top toolbar followed by Configuration. 

4 Select the connection protocol for your device. Documentation on 
the installation of the correct protocol for your device can be 
obtained from your Sales Partner. 

5 Exit PowerINSPECT DRO. 

6 Start PowerSHAPEand click  (Status bar) 
 

Connecting the Arm 
Use the Arm  button on the status bar to connect or disconnect 
the Arm. To connect to the Arm, you need to have an appropriate 
licence file and drivers installed on your computer. 

1 Select the Arm  button from the status bar to connect to the 
Arm. 

2 The Workplane from three points dialog is displayed automatically 
where you can specify the three points to create a workplane. 
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 If you do not wish to define a workplane at this point select 
Cancel on the dialog. You can define a workplane later, if 
required, by selecting Workplane from three points option 
(Workplane menu). 

3 A spherical, red cursor is displayed to represent the Arm probe. 
PowerSHAPE is now ready to accept the digitised components of 
the probe. 

 If the Arm is not connected, the following dialog is displayed. 

 
 

Using the Arm probe 
To use the probe on the Arm: 

1 Select three points to create the workplane. The corresponding 
X, Y, Z option is selected interactively on the Workplane from 
three points dialog as each point is selected. 
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2 Select OK when you have defined the workplane. The Query 
dialog is displayed. 

 
3 Click one of the following: 

Yes to ignore the points outside the bounding box 

No to create a bounding box around all the object to be defined 
(see page 227). 

 

Using a bounding box to define an object 
Creating a bounding box can be helpful to fix the working area in 3D 
space. 

To define the bounding box, select two opposite corners using the 
probe on the Arm (see page 226). 

 
When a bounding box is created, the Arm cursor is only displayed if 
it is within the bounding box. You can only define points within the 
bounding box. If you try to define a point that is outside the 
bounding box, it is not registered. 

 

Creating objects using the probe 
Create objects using one of the following techniques: 
 Digitising physical geometry 
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Select a creation option, for example, line or bezier curve. 
 Digitising a surface   

Select the Surface Creation from Patches option. 
 Selecting a point  

Use the probe in the same way as you would use a mouse to 
select a point. The coordinates selected by the probe are in World 
workspace. 

 

Basic Paddle Operations 
Basic paddle operations are as follows: 

 The small green box shows the current X, Y and Z coordinates of 
arm probe. 

 Press the right button on the arm paddle to enter the point 
selected by the probe. 

 Press the left button to finish entering the command. 

 Press both the buttons simultaneously to cancel the current 
command. 

 Press the left button on the arm paddle to end the current 
creation of a line or curve. It stays in the same application mode 
so that you can continue to create the next line or curve. 
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