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The Main menu is located at the top of the main window. Use the 
options on this menu to control PowerSHAPE.  

 
Use the following sections to find information on PowerSHAPE 
menus: 

File (see page 7) 

Edit (see page 22) 

View (see page 112) 

Object (see page 17) 

Format (see page 28) 

Tools (see page 36) 

Macro (see page 158) 

Module (see page 163) 

Window (see page 167) 

Help (see page 171) 

Shortcuts (see page 176) 
 

Menus 



 

PowerSHAPE 2015 R2 Reference Help Menus • 7  

File menu 
The file menu enables you to access and manage the CAD model 
files. It also enables you to import and export files and exit the 
application. 

 
For further details, see: 

New (see page 8) 

Open (see page 8) 

Open Drawing (see page 16) 
Open Component Library 

Close (see page 8) 

Close and Zip (see page 8) 

Save (see page 8) 

Save As (see page 9) 

Save Thumbnail (see page 9) 

Properties (see page 9) 

Examples (see page 9) 

Print (see page 10) 
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Print Preview (see page 13) 

Page Setup (see page 16) 

Print to File (see page 18) 

Print drawings (see page 14) 

Reset (see page 20) 

Delete (see page 20) 

Import (see page 20) 

Export (see page 18) 

Recent Files (see page 21) 

Exit (see page 21) 
 

File > New 
Use this option to creating a new empty model and open a window 
to display it. 

 

File > Open 
Use this option to choose the model to open. By default the file is 
opened in read/write mode. To ensure that the original file does not 
get overwritten, select Open as read-only on the Open Model dialog. 

For further details, see Opening a model. 
 

File > Open Drawing 
Use this option to open drawings within a model. 

 

File > Close 
Use this option to close the active model. 

 

File > Close and Zip 
Use this option to close and zip a saved model. 

 

File > Save 
Use this option to save the active model. 
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 Occasionally there is a problem saving the model using File > 
Save and it is not possible to overwrite the existing version of 
the model. In this case, Save is disabled. Use File > Save As to 
save the current model. We recommend that you then use 
File Doctor to check the model. 

 

File > Save As 
Use this option to save the current model with a new name. 

 

File > Save Thumbnail 
Use this option to save a thumbnail image of the active model. This 
enables you to preview the model without opening it. 

 

File > Properties 
Use this option to display the File Properties dialog. This shows how 
many objects, details of current levels, and levels of objects are 
contained in the selected model. You can also change the password 
of a model. 

The File Properties dialog has the following tabs: 
 Details 
 Properties 
 Custom 

 

File > Examples 
Use this option to open the Run Macro dialog. 

If you want some data to experiment with in PowerSHAPE, you can 
import sample data as follows: 
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1 From the File menu, select Examples to open the following 
dialog: 

 
2 Select a file. 

3 Click Open to import the data. 

In some cases, a dialog is displayed to use with the data. 
 

File > Print 
This option enables you to print the contents of your graphics 

window. Selecting this option is the same as clicking the Print  
on the Main toolbar. 

1 Select the graphics window. 

2 Ensure your graphics window displays precisely what you want to 
print. 
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3 Select File > Print  to display the Print dialog. 

 
Use the Print dialog to print the contents of your graphics window. 
For further details, see Print dialog (see page 11). 

 

Print dialog 
Use the options on this dialog to print the contents of your graphics 
window. 

 
1 Select the Name of the printer installed on your computer. If you 

have more than one printer installed, select the required printer 
from the drop-down list. 

2 Click Properties to display a dialog with the current settings for 
your printer. Change the settings to adjust the paper type and 
paper orientation. 

3 Select Print to file to print the image to a printer file.  

4 Enter the number of Copies. 
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5 Select a Print Range option: 

 All — Print all the pages. 

 Pages — Print a range of pages. Enter the from and to page 
numbers. 

 Selection — Print a highlighted section. 

6 Click OK to send the image to the printer. 

7 If you selected Print to file, a dialog is displayed. Enter a filename 
for the image. 

 

Printing high resolution images 
PowerSHAPE uses two methods for printing windows: one for views 
containing only wireframe and the other for shaded images. 

If the view contains only wireframe, printing is done at the full 
resolution of the printer. 

If the view contains colour shading, OpenGL is used to render it into 
a bitmap and the bitmap is sent to the printer. Making a bitmap at 
the full resolution of the printer can be impractical as it could be 
very large. Instead, PowerSHAPE makes a bitmap which has the 
same aspect ratio as the printer but is limited in resolution so that 
its size doesn't exceed a limit. 

The limit is set by a resource in the following file: 
powershapexxxx\sys\misc\powershape.con 

The relevant section of code for setting the size is:  

# 

# Printing colour shading. 
# 

# This resource controls the size (in Mb) of the intermediate bitmap 

# which is used to print colour shaded images. Increasing its value 
# increases the printed resolution at the cost of temporary memory 

# usage and file size. Decreasing it reduces print resolution and 

# memory and file size requirements. 15Mb has been found to be a 
good 

# compromise on plain A4 paper in a typical inkjet printer. 
# print_opengl_bitmap_size: 15 

To set the size 
1 Open the resource file: 
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powershapexxxx\sys\misc\powershape.con 

2 Locate the relevant section of code (shown above) 

3 Remove the # from the command line so that it reads 

print_opengl_bitmap_size: 15 

4 Save the resource file. 

You can experiment with larger values for this resource. Each pixel 
of the image requires 3 bytes, so if you want a print resolution of X 
by Y dots, then set this resource to: 

X * Y * 3 / 1,000,000 
 

File > Print Preview 
This option displays a preview of the printed image. 

 
Print To — Click this button to send the image to the named printer 
and close the dialog. 
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OK — Click this button to close the dialog. 
 

File > Print drawings 
This option enables you to print your drawings using the Print 
Drawings dialog. 

To print drawings: 

1 Select Print Drawings from the File menu. This option is 
unavailable if your model contains no drawings. 
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The Print Drawings dialog is displayed. 

 
2 Select the drawing you want to print from the list. The drawing is 

displayed in the dialog. 

3 Use the options on the dialog to modify your print settings: 

 Printer — Select the printer location from the drop-down list. 

 Properties — Click this button to display the properties dialog 
for the selected printer. 

 Paper Size — Select the size of the drawing you want to print 
from the drop-down list and specify its orientation by selecting 
Portrait or Landscape. If As drawing is selected these options 
are unavailable. 

 As drawing — Select this option to print the drawing to its 
dimensions specified in its template. 

 Copies — Select the number of copies you want to print. 

 Monochrome — Select this option to print your drawings in 
black, on a white background. 
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 White background — Select this option to print the drawing 
with a white background, independent of your background 
colour defined in PowerSHAPE. This option is unavailable if 
Monochrome is selected. 

 Timestamp — Select this option to print the drawing with a 
timestamp. 

4 Click Print to close the dialog and print the drawing. 

 
 

File > Page Setup 
This option enables you to adjust the print settings. 

 
The default settings on this dialog depend on the mode you have 
selected from the Module menu. 

Paper 
These options enable you to choose the size of the paper. 
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Portrait — Orientate the image on the paper so that the height of 
the paper is greater than its width. 

Landscape — Orientate the image on the paper so that the width 
of the paper is greater than its height. 

As drawing — This option is selected by default if you are in 
drafting mode. PowerSHAPE selects the best paper size to suit 
the drawing from those available on the selected printer. As 
drawing is not available in modelling mode. 

A preview image is shown on the dialog. 

 

 If you click this image, the Print Preview dialog (see page 13) 
is displayed showing this image.  (see page 13) 

Mapping 
These options fit your image onto the paper. 

Fit — Scale the image to the size of the paper chosen. 

Scale — Scale the image to fit a specified size. 

 Your image may not fit the paper. In drafting mode, if the 
drawing is smaller than the paper, it is not scaled up. 

View 
These options determine what is printed from the model or drawing 
window. 

Detail — Print only the visible part of the screen. 

All — Print the whole model or drawing. 

In drafting mode, the default is All, which maps the whole 
drawing onto the paper. In modelling mode, the default is Detail, 
which maps only the visible part of the model in the graphics 
window onto the paper. 

Margins 
This gives the values to offset the margins from the edge of the 
paper. 

Force colours to black — Print all coloured objects as black. 

White background — Print the background as white. White objects 
are printed as black. 
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Draw margins — Draw a border around the image using the Margins 
values. 

Timestamp — Add the following to the image: 

 Name of the model. 

 Name of the drawing, if you are printing a drawing. 

 Date and time the model was printed. 

Printer — Open the Print Setup dialog, which you can use to change 
the current printer settings in PowerSHAPE.  

Files... — Open the Print to File Settings (see page 19) dialog. This is 
used to set the image size. 

OK — Save any changes and close the dialog. 

Cancel — Discard changes and close the dialog. 
 

File > Export 
Use this option to display the Export settings dialog where you can 
choose to save models in file formats other than the PowerSHAPE 
model format. For further details, see Exporting data from a model. 

 

File > Print to File 
Use this option to print the contents of your graphics window to the 
following file types: 
 jpeg (.jpg) 

 png (.png) 

 tiff (.tif) 
 bitmap (.bmp) 

 SGI rgb (.rgb) 

 DUCT image (.img) 

 neutral plot file (.npf) 

To print to a file: 
1 Select the graphics window. Make sure your graphics window 

displays precisely what you want to print. 
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2 Select File > Print to File to display the Print to File dialog. 

 
3 Use the Print to File dialog to select save location, the file type. 

4 Click Save to save the file. 

You can set options when printing an image to a file on the Print 
to File Settings dialog. 

 

Print to File Settings dialog 
Use this dialog to set the options to be used when printing an image 
to a file. To print to a file, you must select the Print to File option on 
the Print dialog (see page 11). 

 
1 Use the Neutral Plot File (NPF) Paper Size options to set the size 

and orientation of the paper used by the neutral plot file: 

 Select Standard and then select a standard paper size from 
the drop-down list. 
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 Select Custom to define your own paper sizes. Two boxes are 
displayed instead of the drop-down list. Enter maximum width 
and height values. The contents of your graphics window are 
scaled to fit the sizes specified. It is possible that your image 
may not fit the paper. 

 
 If you are in drafting mode, then by default, As Drawing is 

selected and PowerSHAPE selects the best paper size to suit 
the drawing from those available on the selected printer. As 
drawing is not available in modelling mode. 

2 Select the orientation of the image on the paper: 

 Portrait orientates the image on the paper such that the height 
of the paper is greater than its width. 

 Landscape orientates the image on the paper such that the 
width of the paper is greater than its height. 

3 Use Image Size options to set the size of the image: 

 Enter maximum Width and Height values (in terms of pixels) . 
The contents of your modelling window are scaled to fit the 
sizes specified. These options are only available if As Window 
is deselected 

 Select As Window to set the size of the image from the size of 
the modelling window. 

4 Click OK to save any changes made to the options on the dialog. 
The dialog is removed from the screen. 

 

File > Reset 
Use this option to remove all unsaved edits from the active model. 

 

File > Delete 
This is a powerful option, which enables you to permanently remove 
unwanted models. 

 

File > Import 
Use this option to display the Select a file to import dialog. 

For further details, see Importing data into a model. 
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File > Recent Files 
Recently opened models are listed in the Recent Files submenu at 
the bottom of the File menu. The read or write status when they 
were last opened is also shown.  

To open a recently opened model 
1 Select the File > Recent Files.  

2 Select the name of the file to be opened. It is opened with the 
same read or write status as the last time it was opened.  

If the model is not listed or you want a different read/write 
status, use the File > Open (see page 8) option. 

Four recently opened models are listed by default. You can 
specify the quantity of recently opened models up to a maximum 
of 20 on the Models options dialog. 

 

File > Exit 
Use this option to close PowerSHAPE.  

1 Save any changes that you want to keep.  

2 Select File > Exit. 
 If you have not made changes to the model, a dialog is 

displayed. Click Yes to close PowerSHAPE. 

 If any open models contain unsaved changes, a dialog is 
displayed. 

3 To save your work, click Yes and the dialog closes. You must now 
save any models and reselect Exit from the File menu. If you do 
not want to save your work, click No and wait for the software to 
shut down. Any unsaved edits are lost. 
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Edit menu 
The Edit menu contains options that modify aspects of the active 
model. 

 
Many of these options are only effective on items that are selected. 
This is indicated by the select colour and possibly displaying edit 
handles. If no object is selected, some of the options are 
unavailable. 

 

Edit > Undo 
Use this option to reverse the last Edit > Redo command. 

Alternatively, click Undo . 

You can undo multiple commands, back to when you last saved the 
model. To undo multiple commands, keep selecting Undo. 

For dialog operations, Undo reverses the overall action of a dialog. 
It does not undo individual operations within the dialog. 

 The Undo command does not undo changes made in the 
Options dialog. 

A set of last commands for each model opened are remembered; 
You can undo and redo commands in one model, then go to another 
model and undo and redo its commands too. 
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When creating Bezier, G2, and Spline curves, Undo undoes individual 
curve points. You can undo curve points back to the first point 
created, but once the curve is completed, Undo undoes the whole 
curve. 

 To undo all of your changes since you last saved the model, 
use the File > Reset command. If you are working on a new, 
unsaved model, the File > Reset command removes the entire 
model. 

 

Edit > Redo 
Use this option to reverse the last Edit > Undo command. 

Alternatively, click Redo . 
 

Edit > Cut 
Use this option to add the clipboard contents into the current model. 
You can paste as many times as you like, but old clipboard data is 
lost each time you make a new Cut or Copy. 

1 Select some objects. 

2 On the Main toolbar (see page 196), click the Cut  button. 

A copy of the selected objects is put onto the clipboard, 
overwriting anything already there. The original objects are 
deleted from the model. 

3 Paste the clipboard contents onto another model or the same 
model. The objects remain on the clipboard until you make 
another Cut or Copy. 

The memory area used by Cut (and Copy) to hold copied data is 
called the clipboard. It enables you to easily re-use objects in the 
current model or in other models. 

 Objects on the clipboard are not permanent. Each cut or copy 
erases any data that is already on the clipboard. The data is 
also lost when you close the program or when the model you 
copied or cut from is closed or reset. However, other editing 
tools which create copies of objects do not use the clipboard, 
so they do not overwrite data you have previously placed 
there. 

 

Edit > Copy 
Use this option to copy selected objects to the clipboard. 
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1 Select one or more objects. 

2 Click  (Main toolbar). 

The selected objects are copied to the clipboard, overwriting 
anything that is already there. The originals remain in the model. 

You can now Paste the clipboard contents onto another model or 
the same model. 

The objects will remain on the clipboard until you make another 
Cut or Copy. 

The clipboard is used by Copy (and Cut) to hold copied data. This 
lets you re-use objects in the current model or in other models. 

 Objects on the clipboard are not permanent. Each cut or copy 
erases any data that is already on the clipboard. The data is 
also lost when the program shuts down or when the model 
you copied or cut from is closed or reset. However, other 
editing tools which create copies of objects do not use the 
clipboard, so they will not overwrite data you have previously 
placed there. 

To copy objects using Drag copy 
1 Select one or more objects. 

2 Use Ctrl+drag to move the selection to another position. The 
originals remain in place, and copies appear when you release 
the mouse button. 

3 Confirm the action in the Confirm Copy dialog. Ths dialog also 
displays the distance (in terms of coordinates) of the copied 
objects from the original objects. 

 
4 Click OK to confirm the copy drag. 

 These copies do not affect objects already on the clipboard. 
 

Edit > Paste 
Use this option to add the clipboard contents into the current model. 

1 Cut or Copy at least one object. 

2 Click  (Main toolbar). 
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You can paste as many times as you like, but the old clipboard data 
is lost each time you make a new Cut or Copy. 

The pasted objects are inserted at the exact X, Y, Z co-ordinates of 
the originals and automatically selected. This is most convenient 
when pasting between models. However when pasting copies into 
the same model, it can appear that nothing has happened because 
the copies fall at exactly the same coordinates as the originals. 

 Pasting objects into the same model is easier if you use Paste 
Special or drag copies using the mouse. 

 

Edit > Paste Special 
This option is similar to Edit > Paste, except that pasted objects are 
attached to the cursor and pasted when you click. 

Paste Special is particularly useful on complex models where you 
can easily lose sight of the pasted objects. 

To paste objects using Paste Special 
1 Cut or Copy at least one object. 

An anchor point is used to position the pasted objects. 
PowerSHAPE chooses an anchor point when you select the 
objects. 

2 To change the anchor point, hold down Ctrl+Alt and click a 
position. 

3 Select Paste Special from the Edit menu. 

When you move the cursor over the current graphics window, 
the objects appear attached to the cursor at their anchor point. 

4 Position the cursor where you want the objects to fall and left-
click. 

When you left-click, the objects are pasted with their anchor 
point at the click position. 

Objects remain selected after pasting. 
 

Edit > Paste Attributes 
This option pastes the attributes of a selected object to another 
object. You can paste the Style, Level and Material attributes. 

1 Select the source object. 

2 Click  (Main toolbar). 
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The Attribute Selection dialog is displayed. 

 
3 Select the objects to which you want to paste the selected 

attributes. The attributes are pasted automatically. 

 If you want to paste attributes onto multiple objects, select 
them using a drag box. 

 

Edit > Paste Style 
Use this option to assign the style of an object to a group of objects. 

1 Select an object. 

2 From the Edit menu, select Cut or Copy. 

The selected object is now on the clipboard. 

3 Select a group of objects. 

4 From the Edit menu, select Paste Style. 

The selected group of objects are assigned the style of first 
object. 

 

Edit > Paste Level 
Use this option to put a group of objects on the same level as the 
object on the clipboard. 

1 Select an object. 

2 From the Edit menu, select Cut or Copy. 

The selected object is now on the clipboard. 

3 Select a group of objects. 

4 From the Edit menu, select Paste Level. 
The group of objects are put on the same level as the first 
object. 
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Edit > Select 
Use the options on the submenu to select objects. 

 
The following sections give details about the Selection options: 

 Select (see page 27) 

 Next Selection (see page 27) 

 Clear selection (see page 28) 

 Restore Previous Selection (see page 28) 

 Select All (see page 28) 

 Select All Workplanes (see page 28) 

 Selection Filter (see page 28) 

 Select by Name (see page 28) 

 Quick Select is the same as using the options on the Select flyout 
(see page 193) on the toolbar to select objects.  

 Use Manually select to select a particular type of object. For 
example, Manually select > Wireframe sets the selection filter to 
let you select just wireframe. 

 

Edit > Select > Select 
Use this option to enter normal selection mode. 

For further details, see Selecting objects. 
 

Edit > Select > Next Selection 
Use this option to help you select the correct object when objects 
intersect. 
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1 Click on an intersection in a model. 

2 Select Edit > Select > Next Selection. The next intersecting object 
created in the model is selected. 

If Show Next Selection is selected on the Mouse Options (see page 
80) dialog, a dialog is displayed containing buttons for each 
selectable intersecting object in the model. Click the buttons to 
select the corresponding intersecting object. 

Next Selection is also available if you: 

 Right-click to display the context menu. 

 Enter Alt + N. 
 

Edit > Select > Clear selection 
Use this option to clear the current selection. 

This option is also available on the View context menu, which you 
can display by right-clicking in the graphics window. 

 

Edit > Select > Restore Previous Selection 
Use this option to replace the current selection of items with the 
previous selection. 

 

Edit > Select > Select All 
Use this option to select all objects displayed on the model. 

This option is also available on the View context menu, which you 
can display by right-clicking in the graphics window. 

 

Edit > Select > Select All Workplanes 
Use this option to select all the workplanes displayed in the model. 

 

Edit > Select > Selection Filter 
Use this option to display the Selection Filter dialog. 

 

Edit > Select > Select by Name 
Use this option to display the Add Item to Selection dialog. 
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Edit > Delete 
Use this option to permanently remove selected objects from the 
model. You can also delete objects using the delete button on the 
toolbar. 

To delete objects using the delete button: 

1 Select some objects. 

2 Click  (Main toolbar). 

The objects are removed from the active model. If you want them 

back, select Undo , otherwise the objects will be lost 
permanently. 

 

Edit > Convert 
Use the options on the submenu to convert objects. 

  
The following sections give details about the Convert options: 
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Surface (see page 30) 

Solids to Surfaces (see page 30) 

Selection to Meshes (see page 31) 

Selection to Cloud (see page 31) 

Cloud to Points (see page 31) 

Convert solids from version 8 solids (see page 32) 

Convert solids to version 8 solids (see page 32) 

Copy Surfaces within solids (see page 33) 

To Wireframe (see page 33) 

Wireframe to Composite Curve (see page 33) 

Chamfers to Lines (see page 33) 

Symbol (see page 33) 

Component (see page 34) 

Sub-assembly (see page 34) 

Components into Sub-assembly (see page 34) 
 

Edit > Convert > Surface 
This options enables you to convert non-Power Surfaces to Power 
Surfaces, for example, convert a NURBS surface to a Power Surface. 

To convert a surface: 
1 Select one or more surfaces. 

2 Select Edit > Convert > Surface. 
For further information see the following topics: 

 Converting between surface types 

 Primitive surfaces 

 Power Surface 

 NURBS surfaces 

 BCP surfaces 

 Editing Power Surfaces 
 

Edit > Convert > Solids to surfaces 
1 Select the solid to be converted. 

2 Select Edit > Convert > Solids to Surfaces to convert a solid into 
the group of surfaces that define it. 
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Edit > Convert > Selection to Meshes 
1 Select the surfaces or solids to be converted. 

2 Select Edit > Convert > Selection to Meshes. 
 

Edit > Convert > Selection to Cloud 
1 Select the group of points or a mesh to be converted. 

2 Select Edit > Convert > Selection to Cloud to convert the selection 
to a point cloud. 

 
Use Edit > Convert > Selection to Cloud to convert: 

 all selected lines, arcs, curves and composite curves to a 
single point cloud. The cloud has no normal or colour 
information. 

 all points in the selection to a single cloud. This cloud is 
separate from the cloud that is created by converting lines, 
arcs, curves and composite curves. 

 all meshes in the selection to individual point clouds; a cloud 
retains the normal and colour information from the mesh. 

 You can cancel converting a selection to a cloud by pressing 
the Esc key on the keyboard, or by clicking the Stop  button 
on the progress bar. 

 

Edit > Convert > Cloud to Points 
1 Select a point cloud. 
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2 Select Edit > Convert > Cloud to Points to explode the selected 
cloud into points.  

 
 

Edit > Convert > Solids from version 8 solids 
Use this option to convert one or more selected version 8 solid to 

parasolids. This is the same as clicking  (Solid Edit toolbar).  

Right-click on the converted solid to display the Solid context menu 
for the converted solid 

 
 

Edit > Convert > Solids to version 8 solids 
Use this option to convert one or more selected post-version 8 

solids to version 8 solids. This is the same as clicking  (Solid 
Edit toolbar).  

Right-click on the converted solid to display the Solid context menu 
for the converted solid 
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Edit > Convert > Copy Surfaces within solids 
This option keeps a copy of the solid and creates a copy of all the 
surfaces. 

 

Edit > Convert > To wireframe 
Use this option to: 

 convert composite curves into wireframe. 

 create composite curves from surface curves (laterals, 
longitudinals and spine). 

 create composite curves from trim boundaries. 

 create curves from pcurves. 

 convert drawing views into wireframe. For further details see 
Editing a view. 

 convert text to wireframe. 

 convert hatch lines to wireframe. 

 Convert to wireframe is only available if your selection contains 
an object that can be converted.  

 

Edit > Convert > Wireframe to composite curve 
Use this option to create composite curves from all the selected 
wireframe objects, attempting to connect adjoining pieces. 

 

Edit > Convert > Chamfers to lines 
This option converts chamfers (which contain dependency data to 
their associated objects) into simple lines at the same location. This 
conversion cannot be reversed. 

To convert a chamfer to lines: 
1 Select a chamfer or a group of objects which contain chamfers. 

2 Select Edit > Convert > Chamfers to Lines. 

The chamfers are converted. 

3 Click OK to close the dialog. 

The selected chamfers have now been converted into ordinary 
lines. 

 

Edit > Convert > Symbol 
Use this option to convert a symbol into one of the following: 
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 its individual objects (if Keep items was selected when its symbol 
definition was created). 

 a series of lines. Links from the object definition to the symbol 
are lost. 

 

Edit > Convert > Component 
Use this option to convert a component into a solid. 

 

Edit > Convert > Sub-assembly 
Use this option to explode the currently selected sub-assemblies 
into their constituent parts. 

For further details. see Converting a sub-assembly into its 
components. 

 

Edit > Convert > Components into Sub-assembly 
Use this option to convert the currently selected components into a 
sub-assembly. 

For further details, see Converting components into a sub-assembly. 
 

Edit > Add to active workplane group 
Use this option to add objects to a grouped workplane. 

For further details, see Grouped workplanes. 
 

Edit > Remove from workplane group 
Use this option to remove objects from a grouped workplane. 

For further details, see Grouped workplanes. 
 

Edit > Modify 
Use this open to object-specific dialogs or toolbars so you can 
modify the selected objects. If no object is selected, this option is 
not available. 

 

Modifying an object 
1 Select an object. 

2 Select Edit > Modify. The appropriate dialog or toolbar for the 
selected object appears. 
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You can also double-click on the object to display the appropriate 
dialog or toolbar.  

3 You can now edit the object. 

For further details, see: 

 Editing a workplane 

 Editing a line  

 Editing an arc  

 Editing a curve  

 Editing a Power Surface 

 Editing a surface of revolution 

 Editing an extruded surface 

 Editing a primitive surface 
 

Edit > General Edits 
Use the options on this submenu to edit the model. The options 
correspond to the buttons on the General Edits toolbar (see page 
204). 

 
For further details see: 
Edit sub components 
(see page 36) 

Limit Selection (see 
page 37) 

Limit Point (see page 
52) 

Limit Cut (see page 54) 
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Limit Interactive (see 
page 55) 

Move (see page 56) 

Stretch (see page 59) Place Wireframe (see 
page 61) 

Align items (see page 
63) 

Best-fit align (see page 
63) 

Rotate (see page 63) Mirror (see page 69) 

Offset (see page 73) Scale (see page 78) 

Create Pattern (see 
page 86) 

Project (see page 103) 

Project Point (see page 
104) 

Morph Objects (see 
page 105) 

Sculpt Meshes (see 
page 107) 

 

 
 

Edit > General Edits > Edit Sub-components 
This allows you to move, rotate, scale and offset sub-components of 
certain objects. 

Sub-components can be: 

 laterals and longitudinals on surfaces. 

 points on curves (including composite curves and surface 
curves). 

To edit the sub-components using the tools on the Edit toolbar: 
1 Select the sub-components. The sub-component that is displayed 

on the toolbar will be determined by the type of sub-component 
you select. 

2 From the Edit menu, select General Edits followed by Edit Sub-
Components. 
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This is the same as selecting Show general edits options  from 
the toolbar. The General edits toolbar is displayed: 

 
3 From the Edit menu, select General Edits and then one of the 

following Move, Rotate, Scale, Offset and Project. These options 
are also available on the Edit toolbar. 

The Move, Scale, Offset and Project commands work in exactly the 
same way as for other objects except: 

 The Keep Original and No. of copies options are not available. 

 If you move the rotate direction to a spine point, it will take the 
spine direction (laterals and longitudinals only). 

 Offset does not allow continuous or discontinuous options. 

 Scale does not allow scale to volume. 
 

Edit > General Edits > Limit Selection 
You can use this option to limit/trim the following: 

 wireframe objects to: 

 wireframe object (see page 41) 

 surface (see page 43) 

 mesh. 
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 surfaces to: 

 surface (see page 44) 

 mesh. 

 solid to a mesh. 

 mesh to: 

 mesh 

 wireframe 

 surface using the Project option. The wireframe gets projected 
through the mesh along the principal plane of the active 
workplane. 

 clouds to: 

 mesh 

 surface (see page 51) 

 workplane 

 wireframe. 

 group of surfaces and solids to a wireframe object (see page 46). 

 objects to a plane (see page 49). 

To limit objects: 
Use the following technique to limit objects: 

1 Select the cutter (see page 39). 

2 Click the General Edits  flyout to display the General Edits 
toolbar. 

3 Click the Limit  flyout (General edits toolbar). 

4 Click Limit selection  (Limit flyout) to display the Limit 
selection toolbar (see page 206).  

 
5 Select the appropriate options from the toolbar to limit the 

selected objects. 

6 Select the object to limit. 
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The following sections give further information and examples on 
using this toolbar: 

 Cutting objects (see page 39) 

 Limiting wireframe objects to a wireframe object (see page 
41) 

 Limiting wireframe objects to a surface (see page 43) 

 Limiting surfaces to a surface (see page 44) 

 Limiting a group of surfaces and solids to a wireframe object 
(see page 46) 

 Limiting objects to a plane (see page 49) 

 Limiting a cloud to a surface (see page 51) 
 

Cutting objects 
Cutting objects are used to limit (extend or shorten) other objects. 
A cutting object may be: 

 an object that is already part of the model. 

 a composite curve or polygon that is created specifically as a 
cutting object. 

Selecting a cutting object 
Select a cutting object in one of the following ways: 

 Select an object before selecting Limit selection from the toolbar. 

 If no object is selected before selecting Limit selection, select one 
immediately after entering the command. To select a group of 
objects, you must use box selection. 

As soon as the limit operation is completed, the cutting object 
becomes deselected unless it is locked. 

 To use the same cutting objects many times, click Lock  
next to Cutting Object on the Limit selection toolbar. 

To change the cutting objects: 

1 If the cutting objects are locked, click the Lock button  to 
unlock them. 

2 Deselect the current cutting objects by either clicking the Tick 
button next to Cutting object or clicking in empty space in the 
graphics window. 

3 Select a new cutting object. To select a group of objects, use box 
selection. 
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Creating cutting objects 
Create a cutting object in one of the following ways: 

 Using Create composite curve  (Limit selection toolbar) to 
create a temporary composite curve. This composite curve 
becomes the cutting object and is automatically deleted when it 
is no longer required. 

 Using Limit to polygon  (Limit selection toolbar). 

 
1 Select a mesh. 

2 Select Limit selection  (Limit flyout, General Edits toolbar) 
to display the Limit selection toolbar. 

3 Click  (Limit selection toolbar). 

4 Click the start point and click additional points to create a 
polygon on the mesh. Click the start point again. 

 
The polygon is used as the cutting tool. 
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Limiting wireframe objects to a wireframe object 
1 Select the wireframe object to use as the cutting object . 

 

2 Click Limit selection  to display the Limit selection toolbar. 

 

3 To keep a copy of the wireframe to be limited, click  to select 

Keep original. The button changes to  to reflect the selection. 

4 Click . 

5 Select the wireframe object you want to limit. The selected 
object automatically extends or trims back to the cutting object.  

 Where you select the object determines how it is limited: 
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 You can limit multiple wireframe objects to the cutting object 

by box-selection. Click Keep both  to select this option. The 

button changes to . 
 

Limiting non-intersecting wireframe objects 
You can use the Limit selection command to limit two pieces of 
wireframe even though they do not intersect: 

1 Create two objects that do not intersect. 

 
2 Rotate the view so that the wireframe objects appear to 

intersect. 
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3 Click Limit selection  to display the Limit Selection toolbar. 

4 Select one of the objects as the cutting item. 

 
5 Select the other object to limit. 

 
The second object is trimmed to the intersection in the view. 

 
 

Limiting wireframe objects to a surface 
1 Select the surface to use as the cutting object. 
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2 Click Limit selection  to display the Limit Selection toolbar. 

 

3 Click the Intersect curve mode button  (Limit selection toolbar). 

4 Select the wireframe object you want to limit. 

The portion of the wireframe where you clicked is removed. 

 

 
You can also box-select a group of wireframe objects. 

 

Limiting surfaces to a surface 
You can limit surfaces to the intersection of a cutting surface. 
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1 Select the cutting surface. 

 

2 Click Limit selection . 

 
3 To keep a copy of the surfaces to be limited, select the Keep 

original  button. The button changes to . 

4 Once limited, surfaces are cut into two portions. If you want both 

portions of the limited surfaces, click the Keep both button  to 

turn it ON . 

5 If you do not want to trim the cutting surface to the other 

surfaces, the Keep both  button should be OFF. 

6 Select the surfaces you want to limit. The surfaces automatically 
trim back to the cutting object. 



 

46 • Menus PowerSHAPE 2015 R2 Reference Help  

If the top cylindrical surfaces are selected, the trim is as shown 
below: 

 
 

Limiting a group of surfaces and solids to a wireframe object 
You can limit a group of surfaces and solids to a wireframe object. If 
the wireframe object does not lie on the surfaces and solids, the 
wireframe object is projected onto the surfaces and solids and they 
are limited to it. 

There are two options: 

 wireframe object lies on surfaces and solids (see page 46). 

 wireframe object does not lie on surfaces and solids (see page 
47). 

 

Wireframe object lies on surfaces and solids 
1 Select the wireframe item as the cutting object. 

 

2 Click Limit selection . 
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3 On the Limit selection toolbar, click Limit mode . 

4 To keep a copy of the surfaces and solids to be limited, select the 

Keep original  button. The button changes to . 

5 Once limited, surfaces and solids are cut into two portions. To 

keep both portions of the limited surfaces, click Keep both . 

The button changes to . Both pieces of the solids are always 
kept. 

6 Select the surfaces and solids you want to limit. The surfaces and 
solids limit to the wireframe object, and trim boundaries are 
created along them. 

Using the above example, box select the surfaces. 

The surfaces trim as shown: 

 
If the projected wireframe object does not meet the edges of the 
surfaces and solids, the trim boundaries are automatically 
extended to meet the edges. 

7 If the limited surfaces are not as expected, click the Next Solution 

button  until the required solution is displayed. 

 Next Solution cycles through the range of solutions the trim 
boundaries can offer for your limited surfaces. 

 

Wireframe object does not lie on surfaces and solids 
The wireframe object is projected onto the surfaces and solids and 
they are then trimmed. 

You can project the wireframe onto the surfaces and solids along 
either: 

 the axis normal to the principal plane; or 

 the surface normal. 
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The methods for both are very similar, except in the first method 
you must make sure that one of the axes of the current workspace 
lies in a suitable direction to project the wireframe object. If it does 
not, add a workplane and orientate it to a suitable angle. 

1 Select the wireframe object as the cutting object. 

Consider the following objects. 

 

2 Click Limit selection  to display the Limit Selection toolbar. 

 
3 On the toolbar, click one of the projection options: 

 Project mode  projects the wireframe onto the surfaces and 
solids along the axis normal to the principal plane. 

 Project surface normal mode  projects the wireframe onto 
the surfaces and solids along the surface normal. 

4 If you chose Project mode , change the principal plane so that 
the axis you want to project along is normal to the principal 
plane. 

 The principal plane is changed using the selector in the 
Status bar. 

5 To keep a copy of the surfaces and solids to be limited, select the 

Keep original  button. The button changes to . 
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6 Once limited, surfaces and solids are cut into two portions. To 

keep both portions of the limited surfaces, click Keep both . 

The button changes to . Both pieces of the solids are always 
kept. 

7 Select the surfaces and solids you want to limit. 

The surfaces and solids limit to the wireframe object and trim 
boundaries are created along them. 

Using the above example, box-select the surfaces. 

The surfaces trim as shown: 

 

 If the projected wireframe object does not meet the edges 
of the surfaces and solids, the trim boundaries are 
automatically created extending to meet the edges. 

8 If the limited surfaces are not what you expected, click the Next 
Solution  button until you see the required solution.  

 Next Solution cycles through the possible solutions given by 
the trim boundaries on your limited surfaces. 

 

Limiting objects to a plane 
You can use the principal plane of any workplane as a cutting 
object. The workplane does not have to be active. 

1 Select any workplane as the cutting object. 

 



 

50 • Menus PowerSHAPE 2015 R2 Reference Help  

2 Click Limit selection  to display the Limit Selection toolbar. 

 
3 To keep a copy of the object to be limited, select the Keep 

original  button. The button changes to . 

4 Once limited, surfaces are cut into two portions. To keep both 

portions of the limited surface, click Keep both . The button 

changes to . 

5 Change the principal plane, as required. 

6 Select the objects you want to limit to the principal plane, which 
in this case is the XY plane. 

 
The object is trimmed to the principal plane. 

 
7 If the solution is not what you expected, click the Next Solution 

button  until you see the required solution.  

 Next Solution cycles through the possible solutions. 
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Limiting a cloud to a surface 
Limit a cloud using a surface that cuts through the cloud. 

1 Select the surface to use as the cutting object. 

 

2 Click Limit selection  to display the Limit Selection toolbar. 

 

3 Click  

4 Select the cloud to limit. The cloud is automatically trimmed back 
to the cutting object. 
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5 Click the Next Solution button  to see the alternative solution. 

 
 

Edit > General Edits > Limit Point 
Use this option to trim or extend objects to a point. The operation 
behaves slightly differently for various objects. 

1 Select an object. 

2 Click the General Edits  flyout to display the General Edits 
toolbar. 

3 Click Limit  flyout (General Edits toolbar) 

4 Click Point limit  (Limit flyout) 

The cursor icon changes to a magnet and a circle is drawn on the 
end point or edge to be limited. 

 
5 Do one of the following: 

 Drag an end of the object to a new position. The end of the 
object extends or trims to where you release the mouse. 

 Click a position on a wireframe object. The object trims back 
to that position from the nearest end key point. 

 Click a curve on a surface. The surface trims back to that 
curve from its nearest end. 

If there are only two curves in a particular direction, then you 
can't trim in that direction unless you drag the end of the 
surface. 

You can extend surfaces and curves either linearly or along their 
curvature. 
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Consider the following surface. 

 
This surface extends linearly as follows: 

 
It extends along its curvature as shown below. 

 
By default, surfaces and curves extend linearly. To change from 

linear to curvature mode, click the Extend linearly button  to 

toggle to the Extend along curvature button . 

The Next Solution  button cycles through the possible solutions 
given by the trim boundaries on your limited surfaces. 

 Enter a value in the Distance text box and press enter to limit 
the object. 

The edge or end point with the marker is limited. 

You can change the edge or end point using the Edge/End 
Point drop-down list. 
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Edit > General Edits > Limit Cut 
You can cut lines, arcs and curves into smaller pieces as follows: 

 an object at any position 

 an object in a number of equal sized parts 

 a hole into an object 

To cut an object 
1 Select an object. 

2 Click the General Edits  flyout to display the General Edits 
toolbar. 

3 Click Limit  flyout (General Edits toolbar) 

4 Click Cut object  (Limits flyout). 

 If you have not selected the correct object, you can change 
the selection while Limit Cut toolbar is displayed. 

5 Do one of the following: 
 To cut the object at any position, 

Click where you want to cut the object. If you cut a circle or a 
closed curve, it is cut into two pieces from its start point to its 
cutting point. 

 To cut the objects into equal sized parts, 
Enter a value in No. of pieces box, or select a number from the 
drop-down list. The object is cut equally into the required 
number of parts. 

 To cut a hole in the object, 
Left-click on the selected object at the point where you want 
to create the hole. 
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Click+drag the cursor to the end of the hole. 

 
Release the mouse. 

 

 When you create a hole in an open object, such as a line, you 
are effectively splitting the object into two. 

 

Edit > General Edits > Limit Interactive 
This option allows you to remove portions of wireframe objects by 
simply selecting them. The portion is removed to the position where 
another wireframe object intersects it. 

1 Click the General Edits  flyout to display the General Edits 
toolbar. 

2 Click Interactively limit wireframes  (General Edits toolbar).  

The cursor changes to the selection hand icon when you move it 
over objects that can be selected. 

3 Click to select a line, arc, curve or composite curve. 
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The selected portion is automatically limited to the intersection of 
any wireframe objects. 

 

 If no wireframe object intersects the selected object, then the 
object is deleted. 

 

Edit > General Edits > Move 

The Move  option allows you to move a group of objects or copy 
multiples of them by a specified offset. 

1 Select a group of objects. 

2 Click the General Edits  flyout to display the General Edits 
toolbar. 

3 Click  (General Edits toolbar) 

4 Click Move/copy object  (Move/copy flyout) tro display the 
Move toolbar. 

 
In the graphics window, the move origin marker is placed at the 
centre of the selection of objects. 

 
The move-origin is used to move the objects. When you input 
the position to move the objects, the move origin is moved to 
the new position and the objects are moved such that they are 
placed relative to the move origin. 
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If you are moving a single object and you select it at one of its 
key points, then the move origin is at the key point. 

5 Enter values for X, Y and Z to define the Movement. As you enter 
the coordinates, a preview of the transformed items is displayed 
to allow further modification before applying the change. 

 
6 You can move the marker to change the move origin using one of 

the following techniques: 

 drag the marker to a new position 

 
 click Move origin  and click anywhere in the graphics window 

or enter a new position using the Status bar. 

7 You can create copies of the objects. Click Keep original  and 
enter the number of copies you want in the No. of copies box. 

8 Input a position to move the Move origin. 
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If you are just moving the objects, they are moved relative to 
the move origin. 

 
If you are creating multiple copies, the offset of the move origin 
defines the offset of the copies from each other. 

 
9 Select new objects using box-selection. Box-selection is when 

you hold down the left mouse button and drag the mouse to 
form a box around a group of objects. 

Add further objects to the selection by pressing the Shift key and 
box-selecting. You can remove objects from the selection by 
pressing both the Shift and Ctrl keys and box-selecting. 

Pressing the Ctrl key and box-selecting objects removes them 
from the selection if they are already selected, otherwise they 
are selected. 

10 Click Apply  to apply the preview, or click Cancel  to cancel 
the operation. 

You can also move and copy objects using Drag move (see page 59) 
and Drag copy (see page 59). 
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Drag move 
1 Select one or more objects. 

2 Drag the selection to another position. The objects move to 
where you release the mouse button. 

A dialog is displayed asking you to confirm the drag move. It also 
displays the distance (in terms of coordinates) the objects have 
moved. 

 
3 Click Yes to confirm the drag move. 

 

Drag copy 
1 Select one or more objects. 

2 Hold down Ctrl and drag the selection to another position. The 
originals remain in place, and copies appear when you release 
the mouse button. 

A dialog is displayed asking you to confirm the drag copy. It also 
displays the distance (in terms of coordinates) of the copied 
objects from the original objects. 

 
These copies do not affect objects already on the clipboard. 

3 Click Yes to confirm the drag copy. 
 

Edit > General Edits > Stretch 
Use this option to stretch wireframe objects. 

To stretch wireframe objects 

1 Click the General Edits  flyout to display the General Edits 
toolbar. 
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2 Select the points on the wireframe objects by drag-selecting 
them. All points within the box are used to stretch the objects. 

 
For each object type, the points used to stretch the object are 
given below. 

Line — The start and end points are used to stretch a line. 

Arc — The start and end points are used to stretch an arc 

Curve and composite curve — All key points are used to 
stretch a curve. 

3 Click  (General Edits toolbar) 

4 Click Stretch object . 

In the graphics window, you will see the stretch origin marker 
. It is placed at the centre of the selection of objects. The stretch 
points are also marked . 

 
The stretch origin is used to stretch the objects. When you input 
the position to stretch the objects, the stretch origin is moved to 
the new position and the stretch points are moved such that they 
are placed relative to the stretch origin. 

If a whole object is selected, it is highlighted in the selection 
colour and is moved rather than stretched. 
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5 To move the relative position of the stretch origin, click the 
Stretch origin  button and enter a new position in the Status 
bar. 

6 To change the selection of stretch points, drag a box around a 
new set of points. You can also add to the selection by using 
Shift+drag and dragging a box around the required points. 

7 To stretch the objects, enter a position, drag a stretch point or 
click in the graphics window. 

If you enter a position, the stretch origin moves and the stretch 
points move relative to it. 

In this example, the stretch origin is moved by dragging the top 
stretch point. 

 
 

Edit > General Edits > Place Wireframe 
This option places a curve between two points on a single object or 
on separate objects. The curve is copied from a selected wireframe 

item. Place wireframe  is also available on the Move/Copy flyout 

 (General Edits toolbar) 
 

Placing wireframe between two points 
To place wireframe between two points: 

1 Select the wireframe item. You can use any open curve or line. 

 

2 Click the General Edits  flyout to display the General Edits 
toolbar. 
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3 Click the Move/copy object flyout  (General Edits toolbar). 

4 Click Place Wireframe  (Move/copy flyout).  

Two points are displayed on the selected wireframe and the 
Position curve (see page 62) dialog is displayed. 

5 Use the dialog to select the two points where you want to place 
the curve. 

 

Position curve dialog 
This is used to place a curve between two points on a single object 
or on separate objects. The curve is copied from a selected 
wireframe item. 

 
1 Select the wireframe item you want to place. 

2 Select Position 1; the first position on an object where you want 
the new curve to touch. 

 
3 Select Position 2; the second position on an object where you 

want the new curve to touch. 

 
4 Use the other options to adjust the position of the curve. 
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If ON, Reverse curve reverses the new curve. 

If ON, Keep keeps the original wireframe. If OFF, the original 
wireframe is deleted. 

If ON, Proportional scale resizes the new curve by keeping its 
ratio of width to height. 

Rotate allows you to specify an angle of rotation or you can use 
the slider to rotate the new curve. The curve rotates between the 
two points. 

The example below shows the curve rotated to -90 . 

 
5  Click OK to create the new curve with the specified options . 

 
 

Edit > General Edits > Align items 
Use this option to adjust the alignment of the model (see page 
208). 

 

Edit > General Edits > Best-fit Align 
Use this option to align multiple items (see page 211) that are 
already roughly aligned. 

 

Edit > General Edits > Rotate 
Use this option to rotate a group of objects by a specified angle. The 
objects are rotated around an axis normal to the principal plane, for 
example, if the principal plane is YZ, the objects are rotated around 
the X axis. 
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You can rotate the objects to give one or more copies. The following 
picture shows how three copies have been rotated from the original, 
each separated by an angle of 30 . 

 

 Original object. 

 Copies. 

 Rotate axis. 

To rotate a group of objects: 

1 Click the General Edits  flyout to display the General Edits 
toolbar. 

2 Select a group of objects. 

 

3 Click Rotate  (General Edits toolbar). 
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In the graphics window, you will see the rotate axis marker. It is 
an arrow which is placed at the origin of the current workspace 
and points along the axis normal to the principal plane. Objects 
are rotated around the rotate axis. 

 
4 To move the marker to change the axis, do one of the following: 

 Drag the marker to a new position. You can modify the angle 
value after dragging the selected item. 

 

 If you don't wish to enter a value, you can ignore the box; 
it will disappear when you continue with your work. 

 Click Rotate axis  and enter a position. 

 
If you change the principal plane, the rotate axis automatically 
points in the direction of the axis normal to the new principal 
plane. 

5 If you want to rotate the objects and keep a copy of the original 

objects, select the Keep original  button. The button changes 

to .. 
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If you want to create copies of the objects and the Copies box is 

greyed out, select the Keep original  button. The button 

changes to . Enter the number of copies you want in the 
Copies box. 

Enter the angle of rotation to rotate the objects or drag the 
objects around the rotate axis. A graphical preview of the 
transformed items is displayed when you enter an Angle. The 
example below shows the preview that is generated when the 
solids are selected and an Angle of 60 is entered. 

 
If you are creating many copies, the angle of rotation defines the 
angle of rotation of the copies from each other. 
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If we wanted 3 copies with an angle of rotation of 60 , we get the 
following where each surface is rotated 60  from the one next to 
it. 

 
6 You can select new objects to operate on using box selection. 

If you want to add further objects to the selection, use Shift+drag 
to select them. If you want to remove objects from the selection, 
use Ctrl+Shift and click or drag-select the objects. 

Ctrl+drag removes objects from the selection if they are already 
selected, otherwise they are added to the selection. 

7 Click Apply  to accept the changes or Cancel . 
 

Rotating by dragging 
You can define the rotation angle by dragging the selected objects. 

1 Left-click any point on the selected objects and hold down the 
mouse button. 
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Extra instrumentation is drawn to help you rotate the objects; 
The angle of rotation displayed, line is drawn from the selected 
objects to the rotate axis marker and a circle is drawn around 
the rotate axis from the position the line touches the objects.  

 Both the line and the circle are drawn in the plane parallel 
to the principal axis. 

The line is half solid and half dashed. If the cursor is over the 
solid part when you drag the objects , the rotation angle 
changes by increments of 15 . With the cursor over the dashed 
part , the angle changes by 1 . If you move the cursor so that 
it lies outside the circle , the angle changes by 0.1 . 

 
The circle shows the rotation path around the axis. 

2 Drag the objects to the rotation angle you want. As you move 
the mouse, the angle updates. 
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3 Release the mouse button when you reach angle you want. The 
objects are drawn at the new position. 

 
4 You can select new objects to operate on using box selection. 

If you want to add further objects to the selection, use Shift+drag 
to select them. If you want to remove objects from the selection, 
use Ctrl+Shift and click or drag-select the objects. 

Ctrl+drag removes objects from the selection if they are already 
selected, otherwise they are added to the selection. 

 

Edit > General Edits > Mirror 
Use this option to create objects that mirror selected objects 
through a particular plane. 

There are three ways of defining the mirror plane: 

 Selecting a line on your model. 

 Creating a temporary user-defined line by entering two points. 

 Using one of the plane buttons from the Mirror toolbar. 

To mirror objects: 

1 Click the General Edits  flyout to display the General Edits 
toolbar. 

2 Select the objects to be mirrored. If you use box selection, you 
can: 

 add further objects to the selection by holding down the Shift 
key and box selecting.  

 remove objects from the selection by holding down the Shift 
and Ctrl keys and box selecting. 

 add/remove objects by holding down the Ctrl key and box-
selecting objects. 
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3 Click Mirror items  (General Edits toolbar) to display the Mirror 

toolbar. The cursor changes to . 

 By default Keep Original  is selected. If Keep Original is 
deselected, mirrored objects will be created, but the 
original objects will be deleted. 

4 Use Create multiple copies  to copy the selected items three 
times, mirrored in the two non-principal planes.  

5 Use the buttons on the Mirror toolbar to mirror an object. 

Using a line to define the mirror plane 
1 Select the object to mirror. 

2 Click Mirror Items  (General Edits toolbar) 

3 Click Mirror in a wireframe line  (Mirror toolbar) to mirror 
objects across the mirror plane. 

 
4 Click a line. 
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A preview of the mirrored object is displayed, together with the 
mirror plane. 

 
5 Click  to confirm the edit or  to cancel. 

Using a user-defined line created from two points 
Define a mirror plane by creating a line on the principal plane. 

1 Click . The cursor changes to . 

2 Click a position on the screen to define the start point of the line 
.  

3 Move the mouse to position . As you move the mouse,the line 
and the mirrored objects are displayed on the screen to guide to 
you. 
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4 Click to define the point  and mirror the objects. A preview of 
the mirrored object is displayed, together with the mirror plane. 

 
5 Click  to confirm the edit or  to cancel. 

Using a plane button 
For some applications, such as creating symmetrical designs it can 
be quicker to use the plane buttons.  

 The workplane defines the origin of the mirror plane. The 
example uses a workplane on the object. Defining a different 
workplane will give different results. 

1 Select one of the plane buttons  to mirror the objects on 
the opposite side of your chosen plane. A preview of the mirrored 
object is displayed, together with the mirror plane. 

With YZ selected: 
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With ZX selected: 

 
2 Click  to confirm the edit or  to cancel. 

 Boolean features can be mirrored in the same way as other 
solid features. 

 

Edit > General Edits > Offset 
Use this option to offset objects by a set distance: 

1 Select the object or at least one surface that you want to offset. 

2 Click the General Edits  flyout to display the General Edits 
toolbar. 

3 Click Offset  flyout (General Edits toolbar). 

4 Click Offset object  (Offset flyout). 

5 Use the Offset toolbar to offset the objects. 

 
Surfaces and wireframe 

An arrow appears on each object, indicating the direction of the 
offset. If you want to offset an object in the opposite direction 
click its arrow or enter a negative value in the Distance box. 
Solids 
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Solids do not display arrows to indicate the direction of the 
offset. The outside material indicates the positive direction and 
the inside material indicates the negative direction. To reverse 
the offset direction, you need to reverse the whole solid's 
direction. (Note that the history tree is lost when a solid is 
reversed.) 
3D curves 

The offset direction of a 3D curve is not fixed. The principal plane 
will determine the shape of the offset curve. Try offsetting the 
curve using different principal planes. You may need to create a 
workplane. 
Meshes 

Meshes do not display arrows to indicate the direction of the 
offset. The outside material indicates the positive direction and 
the inside material indicates the negative direction. Use the 
Smoothing (see page 77) option to apply a boundary smoothing 
factor along the mesh edge. 

 

Selecting objects for offsetting 
You can select new objects using box-selection:  

 Add further objects to the selection using  to box select 
the required objects. 

 Remove objects from the selection using  to box select 
the required objects 

 Use Ctrl  to box-select objects to remove them from the 
selection if they are already selected, otherwise they are 
selected. 

 Box-selection is when you hold down the left mouse button 
and drag the mouse to form a box around a group of objects. 
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Offsetting objects with a discontinuity 
Select one of the following options from the Offset menu: 

 

 Retain discontinuities  preserves any discontinuities in the 
objects that are offset. 

 

 Round discontinuities  rounds any discontinuities when the 
objects are offset. 

 
 

Offsetting surfaces 
Select one of the following options from the Offset menu: 
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 Always create an offset surface  preserves any discontinuities in 
surfaces during surface offset creation. 

 

 Split surface at discontinuities  splits the suface at 
discontinuities during offset creation. The offset surface will be a 
solid, even if you started with a surface. 

The edges at the discontinuities are extended until they 
intersect. 

 
A solid is created from the set of offset surfaces. 

 
A discontinuity in a surface normal is defined by the Angular 
tolerance value in the Surface Discontinuity Tolerance section on 
the Units and Tolerance page of the Options dialog. 

 Primitive surfaces are automatically converted into power 
surfaces. 

If a curve or composite curve is dependent on a surface, its 
offset will lie on the surface. 
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Offsetting meshes 
You can use the Smoothing option on the Offset dialog (General Edit 
toolbar) when you are offsetting one or more meshes. 

 
The boundary smoothing factor recalculates and moves the points 
of the mesh boundary when it is being offset. This reduces the 
number of jagged edges and creates a boundary with smooth 
edges. 
Smoothing = 0 

 

 

Smoothing = 2 

 

Enter a numerical value into the Smoothing field to define how the 
mesh boundary is smoothed. The magnitude of the smoothing is 
determined by the following: 

 0 — no smoothing, the mesh boundary is unchanged (default). 

 Low values — the mesh boundary keeps most detail, but it 
retains some jagged edges. 

 High values —the mesh boundary loses most detail, but it 
becomes much smoother. 

 The Smoothing function only accepts values greater than or 
equal to 0. 

 

Offsetting specification options 
Use the following options to specify how you want to use the Offset 
surfaces and Offset objects with discontinuities options. 

 

 Keep Original  is selected by default. Deselect this option to 
offset the object and delete the original. 

 No. of Copies is set to 1. To offset multiple copies of the objects, 
enter the quantity and press Enter. 
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 Distance is set to 0. Enter an offset value and press Enter to 
offset the objects. To offset the selected objects in the opposite 
direction, enter a negative value. 

 

Edit > General Edits > Scale 
Use this option to expand or reduce objects in size. 

1 Select the objects to scale (see page 79). 

2 Click the General Edits  flyout to display the General Edits 
toolbar. 

3 Click  (General Edits toolbar). 

4 Use the Scale toolbar to expand or reduce the objects in size. 

 
The position of the scale origin controls the way the model is 
scaled. By default, the scale origin is placed at the origin of the 
current selection and objects are scaled relative to that position. 
It is important to position the scale origin correctly to achieve the 
required result. 

5 Change the scale origin by moving the marker in one of the 
following ways: 

 Drag the marker to a new position. 

 Click the Scale origin  button and enter a position. 

6 Use the drop-down list to select one of the following scale 
options. 

 Uniform (see page 79) 

 Non-uniform (see page 80) 

 To projected Volume (see page 81) 

 Enclosed Volume. Scale the volume enclosed by the selected 
solid and face of the active workplane. Enter the required 
volume in centilitres. 

 You can also scale objects by dragging them on the screen; 
this method works best when used to scale wireframe. 

1 Enter the scaling factor. A preview of the scaled item is 
displayed. 

2 Click one of the following: 

  to scale the selected items. 
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  to close the toolbar without scaling the selected items. 

The display of these buttons and the graphical preview is 
controlled by Show a preview of transformed items on the General 
Edits options dialog (see page 78). 

 

Selecting objects to scale 
Use the following techniques to select the objects to be scaled: 

 Select new objects to operate on using box selection. 

 Add further objects to the selection by holding down Shift and 
box-selecting. You can remove objects from the selection by 
holding down the Shift+Ctrl and box-selecting. 

 Remove objects from the selection by holding down Ctrl and box-
selecting objects that are already selected. 

 

Uniform scaling 
This option lets you resize selected objects in a uniform manner, 
making them larger or smaller equally in all directions. You can also 
lock the scaling factor in any of the directions to 1. 

1 Select the objects you want to scale. 

To scale a workplane with the objects, select it after entering the 
scale command. 

2 Click Scale items  (General Edits toolbar). 

In the graphics window, you will see the scale origin marker. It is 
placed at the origin of the current workspace. Objects are scaled 
relative to the scale origin. 

3 If you want, move the marker to change the scale origin. You 
can either drag the marker to a new position or click the 
Reposition scale origin  and enter a position. 

4 By default, Keep Original is deselected. To keep the original 

objects, click . 

5 To lock the scaling factor of any axes to 1, click on the required 

Axis Lock button on the toolbar. For example, click  to lock 
the scaling factor of the X axis. 

If you scale an arc and lock the scaling factor of any axis to 1, 
then the arc is converted to a curve. 

6 Enter a scale factor and press Enter. The model now shows the 
scaled objects. 

Primitive surfaces are converted to power surfaces and primitive 
solids to general ones. 
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7 Select new objects to operate on using box-selection. Box-
selection is when you hold down the left mouse button and drag 
the mouse to form a box around a group of objects. 

Add further objects to the selection by holding down Shift and 
box-selecting. You can remove objects from the selection by 
holding down the Shift+Ctrl and box-selecting. 

Holding down Ctrl and box-selecting objects removes them from 
the selection if they are already selected, otherwise they are 
selected. 

 

Non-uniform scaling 
This resizes selected objects in a non-uniform manner, allowing you 
to choose the scaling to be applied for each axis. Arcs are converted 
to curves and primitive surfaces to power surfaces by default. 

1 Select the objects to scale (see page 79). 

 To scale a workplane with the objects, select the workplane 
after starting selecting the scale option.. 

2 Click Scale items . 

The scale origin marker is displayed in the graphics window. It is 
placed at the origin of the current workspace. Objects are scaled 
relative to the scale origin. 

3 Move the marker to change the scale origin in one of the 
following ways: 

 Drag the marker to a new position. 

 Click the Scale origin  button and enter a position. 

4 By default, Keep Original is deselected. To keep the original 

objects, click . 

5 From the drop down list, select Non-Uniform. The toolbar is 
updated to show scale factor boxes for X, Y and Z. 

 
6 Enter a scaling factor for each axis. To lock the scaling factor of 

any axis to 1, click on the appropriate lock  button. 

 If scaled arcs are to remain as arcs, use the Uniform option 

7 Click  to scale the selected objects. 
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Scaling to projected volume 
This option resizes surfaces and solids according to their volume as 
projected on to the active workplane. Closed surfaces scale as you 
would expect because there is no ambiguity about the volume. 
However, the volume of open surfaces is ambiguous and can cause 
unexpected results. For example, the volume of a sphere which has 
a non-circular curved shape cut from it cannot be defined unless 
you apply some rules. 

To avoid ambiguity PowerSHAPE projects the surface on to the 
current active plane and then runs the volume calculations. The 
scale volume algorithm is explained in the next section. 

To scale to projected volume: 
1 Select a surface. 

2 Click Scale items . 

In the graphics window, you will see the scale origin marker. It is 
placed at the origin of the current workspace. Objects are scaled 
relative to the scale origin. 

3 If you want, move the marker to change the scale origin. You 
can either drag the marker to a new position or click the Scale 
origin button  and enter a position. 

4 By default, Keep Original is deselected. To keep the original 

objects, click . When the original object is retained and a copy 
scaled, any dependent items (for example the solid history tree) 
will be present in the scaled copy. 

5 From the Scale option menu, choose Projected Volume. The drop-
down list shows the present projected volume. 

6 Enter a new volume in the drop-down list box. The surface and 
solid is scaled when you press Enter. Primitive surfaces are 
converted to power surfaces and primitive solids to general ones. 

Change your selection using the following techniques: 

 You can select new objects to operate on using box-selection 
(hold down the left mouse button and drag the mouse to form a 
box around a group of objects). 

 You can add further objects to the selection by holding down 
Shift and box-selecting. You can remove objects from the 
selection by holding down Shift+Ctrl and box-selecting. 

Holding down Ctrl and box-selecting objects removes them from the 
selection if they are already selected, otherwise they are selected. 
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PowerSHAPE projected volume calculations 
PowerSHAPE calculates the volume of surfaces as follows: 

1 Looking perpendicular to the active plane, the projected volumes 
(Vol A) under the outside surface are calculated. 

2 Looking perpendicular to the active plane, the projected volumes 
(Vol B) under the inside surface are calculated. 

3 Vol A is deducted from Vol B to give the projected volume. 

With the following closed surface example, there is no ambiguity, so 
the calculated value is the actual volume contained by the surface. 

 
However, the volume of an open surface is ambiguous and varies 
according to how it is projected on to the workplane. The illustration 
below shows how the calculated values can vary depending where 
the active workplane falls in relation to the surface. 

A bottle is a good example of how the projections can affect the 
results. When standing upright above the workplane, the volume 
under the upward facing outer surface does not include the neck. 
When the volume under the upward facing inner surface is 
subtracted from it, the result is not the capacity of the bottle. 
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Inverting the bottle causes a similar problem. However, if the bottle 
is placed on its side, the open neck does not distort the calculations 
because it cannot be seen from above the workplane. The capacity 
is calculated correctly. 

 
With complex curved open surfaces, which do not have a flat open 
area, you need to be aware that the calculated values vary 
according to the surface position relative to the workplane. If 
possible, close all surfaces before calculating the projected volume 
or arrange the active workplane so that any openings are on the 
workplane or perpendicular to it. 

The following diagram shows how a bottle model can be arranged 
above a workplane  to produce a “correct” volume. 

 

 Central cylinder missing from parts of calculations. 

 Closed surface. 

 Open edge is on a workplane. 

 Open edge is perpendicular to the workplane. 
 

Dynamic scaling 
You can scale objects by dragging them on the screen. The selected 
objects are made larger or smaller in any direction. You can also 
lock the scaling factor in any of the directions to 1. 

 Dynamic scaling only works in uniform scaling mode because 
of conflicts with the interface for non-uniform and volume 
scaling. However, it does essentially do a non-uniform scale. 



 

84 • Menus PowerSHAPE 2015 R2 Reference Help  

1 Select the objects you want to scale. 

 

2 Click Scale items . 

In the graphics window, you will see the scale origin marker . 
It is placed at the origin of the current workspace. Objects are 
scaled relative to the scale origin. 

 
3 If you want, move the marker to change the scale origin. You 

can either drag the marker to a new position or click the Scale 
origin button  and enter a position. 

4 By default, Keep Original  is deselected. To keep the original 
objects, select Keep Original. 

5 If you want to lock the scaling factor of any axes to 1, click on 
the required Axis Lock button on the toolbar. For example, click 

 to lock the scaling factor of the X axis. 

6 Drag the objects on the screen. 

The line from the scale origin to where you first press the mouse 
button defines a scale of 1 in each axis. 
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Press the mouse button on the selected objects. 

 
The line, which defines the scale in our example, is drawn below. 
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When the mouse is dragged, the objects are scaled and the scale 
factors are displayed on the screen. 

 
When you release the mouse, the objects are scaled. A scale axis 
is the line through the scale origin, parallel to the axis of the 
current workspace. 

Change your selection using the following techniques: 

 You can select new objects to operate on using box-selection 
(hold down the left mouse button and drag the mouse to form a 
box around a group of objects). 

 You can add further objects to the selection by holding down 
Shift and box-selecting. You can remove objects from the 
selection by holding down Shift+Ctrl and box-selecting. 

Holding down Ctrl and box-selecting objects removes them from 
the selection if they are already selected, otherwise they are 
selected. 

 

Edit > General Edits > Create Pattern 
Use this option to create rectangular, honeycomb and circular 
patterns of items and to create patterns on wireframe items. You 
can also create patterns using the option on the General edits 
toolbar. 

 

Creating a pattern of items 
To create a pattern of items: 
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1 Click the General Edits  flyout to display the General Edits 
toolbar. 

2 Select the object you want to create a pattern from. 

3 Click Create pattern of items . The Pattern Edit dialog is 
displayed.  

4 Use the options on the dialog to create the pattern. 
 

Pattern Edit dialog 
The dialog has four tabs. Each tab is associated with a pattern style.  

 Rectangular (see page 87)  

 Honeycomb (see page 90)  

 Circular (see page 93)  

 Wireframe (see page 98)  
 

Create Rectangular pattern 
This page enables you to create rectangular patterns of objects by 
creating multiple copies of the selected item. 
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To create rectangular patterns of objects, you need to select the 
pattern objects you want to create the pattern with. Use the options 
to determine how the elements are created. 

 

 Number of rows — Enter the number of rows in the pattern 
or use the the arrow buttons to increase or decrease the value. 

 Distance between rows — Enter a value in the box or use the 
slider to increase or decrease the value. 

 Display suppress markers — Display a marker on each pattern 
element. Click on the markers to turn off individual elements in the 
created pattern. 

 

 Rotate pattern axes — Rotates the whole pattern 90  around the 
Z axis. 

 Set plane of pattern — Display the Pattern Plane dialog where you 
set the coordinates for the origin of where the pattern will be 
positioned. 

Row alignment 
Choose an alignment suitable for the pattern effect you want: 
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 Create all rows with the same alignment. 

 Create even rows with rotation. 

 Create even rows with mirror. 

Hollow Box — Only the outer elements of the pattern are created. 

 
The following additional options are displayed on the dialog if the 
item you are using to produce the pattern is a feature. They will not 
be displayed if the selected object just contains solid features. 

Remove feature — Control how the original feature is handled 
when the pattern is created. If ON, when the pattern is created, 
the original feature is absorbed by the pattern and they become 
one feature. In the solid tree, the feature icon is replaced by a 
pattern icon 

 
If OFF when the pattern is created, the pattern is created as a 
separate feature and both the original feature and the pattern 
feature can be edited separately. The solid tree will show both 
the feature icon and a pattern icon 
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 This option is not displayed on the dialog if you are editing an 
existing pattern feature. 

Tile — This option is not currently available. 

Edit Definition — This option is only available when you are 
editing an existing pattern feature. When you select this option, 
you can edit the pattern feature using the appropriate dialog. 

OK — Create the pattern and closes the dialog. 
 

Create Honeycomb pattern 
This page enables you to create honeycomb-shaped patterns of 
objects by creating multiple copies of the selected item. 

 
To create honeycomb shaped patterns of objects, you need to select 
the pattern objects you want to create the pattern with. Use the 
options to determine how the elements are created. 

 

 Enter number of rows in the pattern — Use the arrow buttons 
to increase or decrease the number of rows. 
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 Enter the y direction spacing — You can also use the slider to 
set the row spacing. 

 Display suppress markers — This displays a marker on each 
pattern element. Click on the markers to turn off individual 
elements in the created pattern. 

 

 Rotate pattern axes — This rotates the whole pattern through 90  
around the Z axis. 

 Set plane of pattern — This displays the Pattern Plane dialog 
where you set the coordinates for the origin of where the pattern is 
positioned. 

 Enter the x direction spacing — You can also use the slider to 
set the column spacing. 

 Enter the number of columns in pattern — Use the arrow 
buttons to increase or decrease the number of columns. 

Pattern shape 
Choose a pattern shape suitable for the pattern effect you want: 

 Create offset rows outwards. 

 Create offset rows to the right. 

 Create offset rows to the left. 

 Create offset rows inwards. 

The following additional options are displayed on the dialog if the 
object you have selected to produce the pattern is a feature. They 
will not be displayed if the selected object just contains solid 
features. 
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Remove feature — Controls how the original feature is handled 
when the pattern is created. If ON, when the pattern is created, 
the original feature is absorbed by the pattern and they become 
one feature. In the solid tree, the feature icon is replaced by a 
pattern icon 

 
If OFF when the pattern is created, the pattern is created as a 
separate feature and both the original feature and the pattern 
feature can be edited separately. The solid tree will show both 
the feature icon and a pattern icon 

 

 This option is not displayed on the dialog if you are editing an 
existing pattern feature. 

Tile — This option is not currently available. 

Edit Definition — This option is only available when you are 
editing an existing pattern feature. When you select this option, 
you can edit the pattern feature using the appropriate dialog. 

OK — This creates the pattern and closes the dialog. 
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Create Circular pattern 
Use this page to create circular patterns of objects by creating 
multiple copies of the selected item. 

 

Creating a circular patterns of objects 
1 Select the pattern objects you want to use to create the pattern.  

 
2 Use the options to determine how the elements are created. 

Options when creating a circular pattern of objects 

 Angle — Use the slider to set the angle between pattern 
elements. 

 Set angle between pattern elements — Enter the angle required 
between pattern elements. If you change the angle, the number of 
pattern elements is adjusted to create the pattern. 



 

94 • Menus PowerSHAPE 2015 R2 Reference Help  

In the example below, the angle is set to 40 and the quantity of 
elements has increased. 

 
 Lock the angle — When you have entered an value, click this to 

lock the angle. The button changes to  to indicate that the angle 
is locked. 

In the example below, the angle is set to 60 and locked. The 
number of elements has been reduced to 4. The pattern elements 
remain fixed. 

 
If the angle is unlocked, the spacing between the pattern elements 
is adjusted. 
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  Set pattern radius — Enter the required radius of the 
elements around the pattern origin axis and press the Enter or Tab 
key. The pattern is adjusted to reflect the value you entered. This 
option is only available when  is displayed (default). Click  to 
swap mode and specify the pattern radius as the distance between 
the origin and the original object.  
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  Set pattern radius — The pattern radius is specified as the 
distance between the origin and the original object. You cannot 
enter an alternative value. Click  to swap mode and enter a 
radius. 

 

 Rotate pattern anticlockwise — This rotates the pattern through 
half of the specified angle. 

 Set axis of pattern — This sets the coordinates for the centre of 
the circle. 

 Rotate pattern clockwise — This rotates the pattern through half 
of the specified angle. 

 Elements — Enter the fixed number of elements you want 
around the pattern. Use the arrow buttons to increase or decrease 
the number of elements. 

 Display suppress markers — This displays a marker on each 
pattern element. Click on the markers to turn off individual 
elements in the created pattern. 

Rotation 
Choose the rotation style for the pattern effect you want. In the 
examples below the angle is set to 60. 
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 Rotate around circle. 

 

 Move around circle. 

 
Centre element — This creates a pattern element at the centre of the 
circle. 

Additional options 
The following additional options are displayed on the dialog if you 
selected a feature to produce the pattern. These options are not 
displayed if the selected object just contains solids. 

Remove feature — Controls how the original feature is handled when 
the pattern is created. If selected when the pattern is created, the 
original feature is absorbed by the pattern and they become one 
feature. In the solid tree, the feature icon is replaced by a pattern 
icon. 

 
If deselected when the pattern is created, the pattern is created as 
a separate feature and both the original feature and the pattern 
feature can be edited separately. The solid tree will show both the 
feature icon and a pattern icon. 

 
Edit Definition — This option is only available when you are editing 
an existing pattern feature. When you select this option, you can 
edit the pattern feature using the appropriate dialog. 

OK — This creates the pattern. 
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Create pattern from Wireframe 
Use this page to create patterns of objects on wireframe items. 

 
To create patterns of objects on wireframe items, you need to: 

1 Select the pattern objects. 

2 Display the Wireframe page of the dialog. 

3 Select the wireframe item that you want to create the pattern 
on. 

4 Use the options to determine how the elements are created on 
the wireframe. 

 

 Keep the pattern wireframe — You can choose to keep the 
wireframe or delete it. Click this button to toggle between the two 
options. 

 Display suppress markers — This displays a marker on each 
pattern element. Click on the markers to turn off individual 
elements in the created pattern. 
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 Toggle curve point display — This turns the display of point 
numbers on the wireframe on or off. 

 

Range 
Set the range of the wireframe to create the pattern effect that you 
want: 

Full wireframe — Select this option to include the whole wireframe 
item when creating the pattern elements, as shown in the 
example above. 

Between — Select this option and specify the range of point 
numbers on the wireframe you want the pattern to be created 
between. In the example below the pattern is created between 
points 3 and 5. 

 
Click  to display the Position dialog to specify the position of 
the present point. 

Spacing 
Set how the wireframe will be used to position elements: 

At keypoints — Select this option to create the pattern at the key 
points on the wireframe, subject to the range you have specified. 

Equal with — Select this option and specify the fixed number of 
copies of pattern elements to be created within the range 
specified. The example below shows the pattern created with 20 
copies. 
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Every — Select this option and specify the spacing distance for 
the elements in the pattern. Choose an alignment option from 
the drop down list: 
 from end 

 
 from middle 

 
 from start 

 
You can also open the Position dialog  to specify the position of 
the present point. 

Placement 
Choose an alignment suitable for the pattern effect you want. 

 Copy along wireframe — This creates a copy of the pattern 
element at the points and range specified. This is the default 
setting. 

 Rotate copies to axis — This displays two points on the original 
pattern element, initially in the same position, approximately at 
the centre of the original pattern object. You position these 
points to create an axis that can be used to align with the normal 
of the curve.  

If the curve does not have surface dependencies, the pattern will 
align to the normal of the curve. If the curve has surface 
dependencies, the pattern will align to the normal of the surface. 

The Set plane of pattern  option becomes available. 

1 Select the pattern element. 

2 Use  to toggle between the selection of the points. The 
points are different colours. 
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3 Click on each point and move them into the positions where 
you want to create an axis to align with the normal of the 
curve. 

 
The example below shows the pattern element aligned with 
the normal on the curve at the axis between the two points. 

4 Click the Reverse button to change the normal and create the 
pattern on the other side of the curve at the same axis. 

 
When reversed, the pattern changes as shown below: 

 
Click  to display the Position dialog to specify the position of 
the present point. 

 Place two points on wireframe — This displays 2 points on the 

pattern element. Use  to toggle between the selection of the 
points and position them to choose the part of the pattern 
element you want to lie on the wireframe. 

The example below shows the points positioned on the edge of 
the pattern element, and the pattern elements created on the 
wireframe. 

 

 

 Set the point to be repositioned — This is used with the Alignment 
options to move the point markers on the pattern element. 

Reverse — This flips the side of the wireframe where the pattern will 
be created, corresponding with the curve normal. For example 
inside or outside. 
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 Set plane of pattern — This option becomes available when the 
Rotate copies to axis option is selected from the Alignment drop 
down list. Use the Pattern Plane dialog to set the coordinates for the 
alignment of the pattern elements on the wireframe. The workplane 
can also be edited dynamically. The normal of the pattern is along 
the Y axis and the tangent of the pattern is along the X axis. 

The following additional options are displayed on the dialog if the 
object you have selected to produce the pattern is a feature. They 
will not be displayed if the selected object just contains solid 
features. 

Remove feature — Controls how the original feature is handled 
when the pattern is created. If ON, when the pattern is created, 
the original feature is absorbed by the pattern and they become 
one feature. In the solid tree, the feature icon is replaced by a 
pattern icon 

 
If OFF when the pattern is created, the pattern is created as a 
separate feature and both the original feature and the pattern 
feature can be edited separately. The solid tree will show both 
the feature icon and a pattern icon. 

 
This option is not displayed on the dialog if you are editing an 
existing pattern feature. 

Edit Definition — This option is only available when you are 
editing an existing pattern feature. When you select this option, 
you can edit the pattern feature using the appropriate dialog. 

OK — This creates the pattern and closes the dialog. 
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Pattern Plane dialog 
This dialog is used to set the coordinates for the origin of where the 
pattern is positioned. 

 
These options allow you to: 

 Define the workspace in which to edit the workplane for the 
pattern. 

 Move the workplane's origin. 

 Change the direction of its axes. 

 Twist it about its axes. 

Use the Relationship  button to define the relative position of the 
pattern with respect to the solid. 

 

Edit > General Edits > Project 
This projects the following objects onto a plane at a particular point 
along an axis: 

 wireframe objects 

 points on curves, composite curves and surface curves 

 whole laterals and longitudinals on surfaces 

To project objects: 
1 Select some objects. 

2 Click the General Edits  flyout to display the General Edits 
toolbar. 
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3 Click Project items onto plane  (General Edits toolbar). 

 
4 Select the axis you want to project along. 

5 In the Position along axis box, type the coordinate of plane along 
the axis. 

6 If you want to keep a copy of the original, select Keep copy. 

7 Click OK to project the objects onto the defined plane. 
 

Edit > General Edits > Project Point 
You can also project points onto a surface or a mesh using the 
General edits toolbar. 

To project points along the principal axis onto surfaces 

1 Click the General Edits  flyout to display the General Edits 
toolbar. 

2 Ensure the principal axis of the current workspace is pointing in 
the correct direction. 

3 Select points and surfaces. 

4 Click Project points onto surface  (General Edits toolbar). 
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Edit > General Edits > Morph objects 
Select this option to morph the object you are editing. 

1 Ensure that you have an active solid. 

2 With the General Edits toolbar displayed, click  to display the 
Morphing dialog. 

3 Use the Morphing dialog to edit the solid. 
 

Edit > General Edits > Morph to Cloud or Mesh 
Select this option to morph a surface or solid model, with respect to 
a separate cloud or mesh. 
Before morph 

 

 

After morph 

 

 

 — Mesh measurement data. 

 — Solid model. 

 — Model morphed towards data. 
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To morph to a cloud or mesh: 

1 Ensure you have a solid or surface visible. 

2 With the General Edits toolbar displayed, click  to display the 
Morph to Cloud/Mesh dialog. 

3 Use the Morph to Cloud/Mesh dialog (see page 106) to edit the 
object. 

 

Morph to Cloud or Mesh dialog 
The Morph to Cloud/Mesh dialog is used to morph solids or surfaces 
with respect to a point cloud or mesh. 

 
Use the following options on the dialog to modify the morph: 

 Select mesh or point cloud to morph to — Select this option and 
then select the reference cloud or mesh to morph to. When an 
appropriate cloud or mesh is selected the changes to a . 

 Select solid or surfaces to morph from — Select this option and 
then select the solid or surface model that you want to perform 
the morph on. When an appropriate solid or surface is selected 
the changes to a . 

 Resolution — Use the slider to control the accuracy of the morph. 

At a low resolution the morph is faster, however small details are 
smoothed out. At a high resolution the morph is slower, but 
small details are captured. 

 Strength — Use the slider, or enter a value to control the morph 
movement. 
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At 100% the morph moves the solid or surface up to the mesh or 
cloud. If desirable you can move the solid or surface by a smaller 
or larger amount. For example, at 50% the CAD geometry is 
morphed half way to the measurement data. 

 Morph away from cloud/mesh — Select this option to apply an 
inverse morph, and move the CAD geometry in the opposite 
direction to the measurement data. This allows you to 
compensate for artefacts in the manufacturing process, such as 
springback. 

 Keep both — Select this option to keep both of the CAD models, 
before and after the morph. 

 Preview — Click this to display a preview of the morph. 
 

Edit > General Edits > Sculpt Meshes 
Use this option to change the shape of meshes and solids. 

 

Edit > Surface and Curve Edits 
Select the appropriate option from the flyout to display the edit 
options for surfaces and curves. 

 
 

Edit > Surface and Curve Edits > Surface edits 
Use this option to display options used to edit surfaces. 

 
For further details, see Editing Power Surfaces and Editing a surface 
using the toolbar. 
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Edit > Surface and Curve Edits > Curve edits 
This displays options used to edit curves. 

 
For further details, see Editing a curve. 

 

Edit > Surface and Curve Edits > Common edits 
This displays edit options that are common to editing surfaces and 
curves. 

 
For further details, see:  

 Editing a curve . 

 Editing a Power Surface 
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Edit > Solid Edits 
Use the options on this submenu to edit the model. The options 
correspond to the buttons on the Solid Edit toolbar. 

 
Active — Select this to make the selected solid active. 

Solid Doctor — Select this to find and fix faults using the Solid 
Doctor. 

Heal or Loosen Edges — Select this to heal or loosen edges in the 
solid using the Solid Doctor Healing dialog. 

Selection Mode: 

 Features — Select this and click on the solid to select features. 

 Individual Faces — Select this and click and individual faces on a 
solid to select them. Use this option with box selection to select 
faces that are completely inside the selection box. 

 Continuous Regions — Select this to highlight faces that are 
continuous with the selected face 

 Convex Regions — Select this and click on a face in the solid to 
select all the faces in the convex region of the face. 

 Concave Regions — Select this and click on a face in the solid to 
select all the faces in the concave region of the face. 

 Continious Lasso — Select this to select faces of the solid by 
drawing a lasso around the required faces. After making the 
selection, move the mouse over the selected faces to highlight 
the single faces.  
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 Discrete Lasso — Select this tos elect faces of the solid by 
drawing a lasso around the required faces. The cursor changes to 

 to show that you can complete the lasso. After making the 
selection, move the mouse over the selected faces to highlight 
the single faces.  

Copy Faces — Select this and select one or more faces to create 
surface copies. 

Remove Faces — Select this and select one or more faces to create 
surface copies and remove them from the solid. 

Sew Items — Select this to display the Sew dialog. Select one or 
more surfaces or solids and click OK. 

Heal Faces — Select this to heal and remove faces from the solid. 

Merge Faces — Select this to merge selected faces of a solid into 
one face. 

Divide Faces — Select this to divide the faces of the selected solid 
using wireframe. 

Draft Faces — Select this to display the Draft Faces dialog. This 
option is part of Direct Modelling functionality. 

Replace Faces — Select this to select faces of a solid and replace 
them with other existing faces or surfaces. 

Remove History — Select this to remove the history of the solid from 
the solid feature tree. 

Reverse Solids — Select this to reverse the faces of the solid. 

Divide Solids — Select this to divide an existing solid into separate 
solids. 

 

Edit > Active dimensions 
You can use Active dimensions to alter the geometry of a composite 
curve by changing the dimension value. 

 
1 With a composite curve selected, select Active dimensions from 

the menu. 

The appropriate options for editing the curve are displayed on 
the Surface/Curve Edit toolbar. 
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It is the same as selecting Edit the curve using active dimensions 

 (Curve Editing flyout). 

 
2 Double-click on the Dimension value you wish to change and 

enter a new value. The geometry will be modified accordingly. 

For further details, see Editing using active dimensions. 
 

Edit > Fillet Corner 
This is used to edit the corner of a fillet. 

For further details, see How do I edit a corner fillet? 
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View menu 

 
PowerSHAPE initially displays with a view from above (that is, down 
the global Z-axis). With the middle mouse button and certain 
keyboard keys, you can turn and roll the view (rotate), zoom in or 
out and pan across the view. 

The View menu lets you to choose from a selection of single and 
multiple views shown from specific angles. It also includes the View 
Edit dialog which allows you to create customised views. 

You can have more than one window open for the same model, any 
changes you make to objects within the model are shown in all the 
open windows. 

Remember that any changes to the view affect only the active 
window. This allows you to maintain views from various angles in 
separate windows. 

PowerSHAPE is designed to provide fast, intuitive view controls. 
These are all centred around the middle mouse button. 
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For further details, see Middle mouse button in Modelling Concepts. 
 

View > Layout 
Use this option to edit the way your model is displayed in the 
graphics window. 

1 From the View menu, select Layout to display the View Edit dialog 
(see page 113). 

2 Use the dialog to change how your model is displayed in the 
graphics window. 

 

View Edit dialog 
This dialog lets you to edit how your model is displayed in the 
graphics window. 

 
Preset Layout — You can choose one of the following options from 
this drop-down menu: 

Top looks down on the Z-axis. 

Bottom looks up on the Z-axis. 

Left and Right look along the X-axis. 

Front and Back look along the Y-axis. 

Iso offers four isometric options. 
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Third Angle and First Angle provide views where the model 
appears in plan and various elevations within the same window. 

Unknown is shown when the current window contains a custom 
view layout, or has been rotated using the middle mouse to an 
arbitrary viewpoint. 

The above options are the same as those available from the View > 
Single (of model) and View > Multiple menus. When you select an 
option, the View Edit dialog updates to show the configuration for 
the selected option. 

You can choose one of the preset layouts and then change it to your 
requirements. 

The isometric and perspective views have a default viewing angle 
that defines the visual depth of the model. Most people find the 
default 40  to be acceptable, but if required the angle can be 
changed having an effect similar to altering a camera lens focal 
length. For further details, see Perspective View Angle on the Views 
options (see page 121) dialog. 

Layout Configuration 
You can split the graphics window into 1, 2 or 4 views. Select one of 
the tabs: 

 Single  gives a single view. 

 Split 2 splits the view vertically into two separate views. 

 Split 4 splits the view vertically and horizontally to give four 
separate views. 
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When you select one of these tabs, the dialog updates to show the 
options available for each view. For example, when you select Split 2 
tab, the dialog updates to show options for the two views: 

 
For each view, you can set: 

 the direction of the view (using the options on the option menu 
given below); 

 
 how the surfaces and solids are displayed; 

 
 whether the view is parallel or perspective. 
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Parent and Child — (Only available for Split 2 and Split 4 views.) 
These control how the views rotate. When you rotate a parent view, 
the child also rotates in an appropriate manner. 

V-Split — Adjust the position of the vertical split between views. 

H-Split — Adjust the position of the horizontal split between views. 

Apply — Display your choice in the active window, but keep the 
dialog open. 

OK — Save any changes and close the dialog. 

Close — Discard changes and close the dialog. 
 

View > Single (of model) 
Use the options on the submenu to set the orientation of the single 
view of the model. 

1 From the View menu, select Single (of Model) to display the 
following menu: 

 
Each view looks towards the origin, down the axis given in the 
brackets. For example, the Top view is looking at the model 
down the Z axis. 

2 Select the view you require from the options. 

The view of the model changes to the selected orientation and 
the view is zoomed and panned so that the whole model fits 
centred in the window. 

Sometimes, for example when zoomed in on a feature of 
interest, this rescaling of the view is not desirable. Instead, you 
would like the feature of interest to remain fitted in the view 
after you change the view direction. To achieve this, select View 
> Single (about selection) (see page 116). 

 

View > Single (about selection) 
Use the options on the submenu to set the orientation of the single 
view of the selected objects. 
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1 Select your objects. 

2 Select Single (about Selection) > View to display the following 
menu: 

 
Each view looks towards the origin, down the axis given in the 
brackets. For example, the Top view is looking at the model 
down the Z axis. 

3 Select the view you require from the options. 

The view of the model changes to the selected orientation and 
the view is zoomed and panned so that the selected objects fit 
centred in the window. If no objects are selected, then the whole 
model fits the window. 

This command is useful when you are zoomed in on a selected 
feature of interest and you want to view this feature from a 
different direction. 

 

View > Multiple 
Use the options on the submenu to provide orthographic style 
images, each showing three or four separate views of the model. 

1 From the View menu, select Multiple to display the following 
menu. 

 
2 Select the view you require from the options. 

When an option is selected, the active window changes to show a 
number of views of the model within the window. 

The views are linked, so, if you rotate the top left hand view, all the 
other views follow the rotation. 

 All the views can be rotated with the middle mouse button, so 
they may no longer remain true orthographic projections. 
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View > Look From 
Use the options on the submenu to change the view to look from a 
direction relative to the current view. 

1 From the View menu, select Look From to display the following 
menu. 

 
Each option changes orientation relative to the current view 
direction. For example, if you are looking at the top view of a 
model (that is down the Z axis) and you select Above, the view 
of the model changes to look down -Y axis. 

2 Select the view you require from the options. 

The view of the model changes to the selected orientation and 
the view is zoomed and panned so that the whole model fits 
centred in the window. 

 

View > Look From > Last View 
This displays the view before it was changed (for example, by 
rotating or zooming) providing a toggle between the current view 
and the previous view. 

1 From the View menu, select Last View. The previous view is 
displayed in the graphics window in which the view was last 
changed. 

2 Select Last View again from the View menu, and the original view 
is shown in the graphics window. 

 

View > Look From > Stored View 
Use this option to restore the previously stored view. 

1 Select View > Stored View.  

The last view that you stored previously using Store View will be 
displayed. 

 

View > Zoom Full 
Use this option to fit the view of the model to the graphics window. 

1 Select View > Zoom full.  
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The whole model fills the active graphics window. 
 

View > Store Views 
Use this option to store a view to use at a later date. 

1 Rotate your model until you have the view that you wish to 
store. 

2 Select View > Store Views to display the Stored View dialog. 

 
3 Click Store and View 1 will be added to the list of views.  

4 Click OK. 

5 Rename this view by selecting Rename and using the Rename 
Stored View dialog 

 
 

View > Perspective 
Use this option to toggle the view from parallel to perspective. 

By default, the view is set to parallel . Objects are drawn to the 
same scale regardless of whether they are near or far away. 
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A perspective view  adds depth to the model. Objects are drawn 
as they appear to the human eye so that objects which are further 
away appear smaller than those which are close. 

 
 

View > Lock Rotation Centre 
This locks the rotation of the view to the centre of the current 
selection. 

1 Select one or more objects. 

2 Select Lock Rotation Centre from the Views menu 

3 Rotate the model. It will rotate around the centre of your 
selection. 

4 Change your selection. The view will still rotate around the 
centre of the original selection. 

5 If you unlock the rotation centre by selecting Lock Rotation 
Centre again, the view will revert to rotating as defined by the 
Rotate Around option on the Views page of the Options dialog. 

 

View > Cross Hair Cursor 
Use this option to change the display of the cursor to cross hairs. 
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Select this menu option to toggle the cross hair cursor ON and OFF. 

 
 

View > Dynamic Sectioning 
Use this option to take sections through the front and back of a 
model using the Dynamic Sectioning dialog (see page 43) 

 

View > Shading 
Use the options on the submenu to change the appearance of the 
model. 

1 From the View menu, select Shading to display the following 
menu: 

 
Each option changes the appearance of the model when it is 
displayed. 

2 Select the shading option you require. 
 

View > Shading > Wireframe 
This shows surfaces and solids as wireframe constructions. 
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1 From the View menu, select Wireframe. This changes any surfaces 
and solids that are shaded or have hidden lines to be shown as 
wireframe. 

This is the same as clicking the Wireframe view button  on the 
Views toolbar. 

 
All views in the currently selected window as wireframe are 
displayed. The objects are fully transparent with all the lines 
visible. This option requires the least processing power, so image 
rotation is fast and smooth. 

 

View > Shading > Shaded 
Select this option to use colour shading to make surfaces appear 
solid. 

1 Display the surfaces on the screen you want to shade. 

2 From the View menu, click on Shaded. The surfaces will now be 
shaded making them appear solid. 
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This is the same as clicking the Shaded view button  on the 
Views toolbar. 

 
When you first select View > Shaded, the view becomes shaded. If 
you select it again, the view becomes shaded wire. Pressing it 
again, toggles the view between shaded and shaded wire. 

The surface colours and lighting effects highlight any bumps, 
creases or ripples in a surface. This allows you to better visualise 
how the final product will look. The effects change as you rotate the 
image. 

 Rotations can be slow on complex models, because shaded 
images require considerable processing power. 

The shading is achieved by filling the surface with shaded triangles 
of varying colour and brightness to represent the solid surface. 
PowerSHAPE automatically chooses triangle sizes which best suit 
the model being shaded. However, where surfaces meet, gaps can 
appear between the triangles. This tendency can be minimised by 
changing the shaded surface options. 

For further details, see Changing the material of selected surfaces 
and solids. 

 On operating systems that do not support hardware graphics 
acceleration, redraws are slow during rotations and shading of 
complex models can take a considerable time. 

For further details see Shading options (see page 97). 
 

View > Shading > Transparent Shaded 
This displays transparent colour shading on surfaces and solids. 

1 Display the surfaces and solids you want to shade on the screen. 

2 From the View menu, select Transparent Shaded. 
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You can also use the Toggle Transparent Views  button on the 
Views toolbar. This button toggles the view from Transparent 
Shaded Wire to Transparent Shaded. 

The surfaces and solids are now shaded using transparent 
material. 

 
 

View > Shading > Transparent Shaded Wire 
This displays transparent colour shading on surfaces and solids, but 
the wireframe is not hidden. 

1 Display the surfaces and solids you want to shade on the screen. 

2 From the View menu, select Transparent Shaded Wire. 

You can also use the Toggle Transparent Views  button on the 
Views toolbar. This button toggles the view from Transparent 
Shaded Wire to Transparent Shaded. 
The surfaces and solids are now shaded using transparent 
material. 

 
 

View > Shading > Shaded Wire 
This uses colour shading and lighting effects to make surfaces 
appear solid, but the wireframe is not hidden. 

This shades your surfaces and draws the wireframe on top. 
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To use the Shaded Wire option: 
1 Display the surfaces you want to shade on the screen. 

2 From the View menu, select Shaded Wire. 

This is the same as clicking the Shaded and wireframe  button  
on the Views toolbar. 

The surfaces will now be shaded with the wireframe appearing on 
top. 

 

 On operating systems which do not support hardware 
graphics acceleration, redraws are slow during rotations and 
shading of complex models can take a considerable time. 

 

View > Shading > Dynamic Hidden Line 
This option shows the wireframe view but all lines which fall behind 
surfaces are hidden. 

To use the Dynamic Hidden Line option: 
1 Display the surfaces you want to process on the screen. 

2 From the View menu, select Dynamic Hidden Line. 

This is the same as clicking the Hidden Wire View  button on 
the Views toolbar. 
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The surfaces will now show only those lines which would be 
visible when viewed from the screen. When the model is rotated, 
these lines are removed as they go out of view and redrawn as 
they come into view. 

 
 

View > Shading > Enhanced Shaded 
Use this option to shade the selected object in a reflected 
environment, producing a more realistic image. 

This is the same as clicking the Enhanced Shading  button on the 
Views toolbar. 

The following options are automatically turned on: 

 View > Perspective to produce a more realistic image.  

 View Spinning on the Tools > Options > Views dialog. 

 
 

View > Shading > Inside Material 
This toggles the inside material to match the outside one when 
shading. 

 

View > Shading > Use wireframe colour 
Select this option to shade surfaces using their wireframe colour. 
This functionality is also available on the Materials selection dialog.  
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View > Render 
Use this option to render a model to create a photo-realistic image. 

Before rendering a scene, make sure the solids and surfaces have 
the correct materials assigned.  

 Rendering a scene is a very easy operation, but it can be 
time-consuming. 

1 Orientate and position your model as required. 

2 Click Render to render the image. The image is rendered using 
KeyShot in a separate window. 

 

Rendering using the Views toolbar 

1 Ensure your model is shaded. Select the Shaded  button on 
the Views toolbar. 

2 Click the Render with KeyShot  button on the Views toolbar. 

A new window is opened which contains the image. 

3 You can go back to your original model using the Window menu. 

4 KeyShot is the software that produces photo-realistic ray-traced 
images. KeyShot needs to be installed separate to Delcam 
software.  

If it is not already installed, download and install (free of charge) by 
clicking KeyShot (http://www.delcam.com/keyshot/download/ ) or by 
running the installation again. Ensure you install the appropriate 
version (32-bit or 64-bit) according to the type of computer you are 
using. 

 

View > Mesh Representation 
Use the options on this submenu to specify the display mode for 
triangles in a mesh. 

 
Use the following options to specify the way the mesh is displayed: 

http://www.delcam.com/keyshot/download/
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 No Edges displays the mesh as open edges only. Selecting this 

option is the same as clicking  on the Views toolbar. 

 
 Solid with Edges displays the mesh as open and interior edges 

over shaded triangles. Selecting this option is the same as 

clicking  on the Views toolbar. 

 
 Solid with Nodes displays the mesh as nodes and open edges 

over shaded triangles. Selecting this option is the same as 

clicking  on the Views toolbar. 

 
 Hollow with Edges displays the mesh as open and interior edges 

over hollow triangles. Selecting this option is the same as 

clicking  on the Views toolbar. 

 
 Hollow with Nodes displays the mesh as nodes and open edges 

over hollow triangles. Selecting this option is the same as 

clicking  on the Views toolbar. 

 
 



 

PowerSHAPE 2015 R2 Reference Help Menus • 129  

View > Colour Scheme 
Use this option to set the colour scheme for all views. 

Selecting this option displays the Properties dialog where you define 
the colour scheme that is used. 

 

View > Appearance 
Use this option to set the background of the modelling window and 
the environment which is reflected in a shaded model. 

1 From the View menu, select Appearance.  

2 Use the View Appearance dialog (see page 129) to set the 
options. 

 

View Appearance dialog 
This sets the background of the modelling window and the 
environment that is reflected in a shaded model. 

 

Background 
These options set the background of the modelling window. You can 
set the background to: 
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Graduated — Gradually change the background from one colour 
to another. Select this option and then select the top and bottom 
colours using the two drop-down colour selectors. 

Top Colour — This is the colour displayed at the top of the 
graduated background. 

Bottom Colour — This is the colour displayed at the bottom of 
the graduated background. 

Solid — A single colour is used for the background. Select this 
option and then select the colour from the drop-down menu. 

Image — Select this option to display the Image Selector. Use this 
dialog to select an image to display in the background. For 
further details, see Image Selector dialog. 

When you have selected an image, click OK. The Background 
Image Properties dialog is displayed. This contains the controls to 
fit the image on the screen. For further details, see Background 
Image Properties dialog (see page 132). 

The selected image and the Properties button appear on the View 
Appearance dialog. Click the Properties button to display the 
Background Image Properties dialog. 

The default background ensures that model objects do not merge 
into the background. The background options are not intended 
for normal modelling use, but: 

 to allow colour shaded images to be generated with good 
colour contrast to the shading colour. 

 to add a background image for tracing. 

 When you choose different colours, be aware that objects of 
the same colour as the background will be invisible. If you 
need to change the colour of your objects, see Setting up a 
colour scheme for graphics. 

Reflected Environment 
These options set an environment which is reflected in the shaded 
model. The following options are available: 
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None — No reflected environment is set. 

Solid — A solid colour is used. This is only visible in PowerSHAPE 
Render. Select this option and then select a solid colour. 

Image — An image is used as the reflected environment. Select 
this option to display the Image Selector dialog where you can 
select an image. For further details, see Image Selector dialog. 

When an image is selected, it is reflected in shiny materials in 
the shaded model. Shiny materials are those which show 
reflections in the Material Selection dialog, and include Metal, Cast 
Metal, Mirror (in Coated Metal), Glass and Metal25. 

The amount by which a material reflects the environment is 
controlled by its polish. A value of 15 gives a small amount of 
reflection, and 50 gives a mirror-like material. 

Reflecting images can seriously slow your graphics card, 
although most modern cards can handle it. If it is too slow, then 
either do not use the Image option or turn off the Preview in 
model window option. If the Preview in the model window option is 
off, the image only appears in the rendered view without slowing 
down the model window too much. 

 

Use defaults next session — If you do not want the settings to use 
default, turn this option OFF. PowerSHAPE will then use the 
program's original settings. To change the default colour scheme, 
see the Properties page of the Tools > Options dialog for further 
details.  

Set as Defaults — Set the current view appearance for the rest of the 
session. The settings are also stored in the registry so that they will 
be used in the next session. 

OK — Apply the changes. If you set the reflected environment 
options, you will need to render the model to see the results. 

Cancel — Discard any changes and close the dialog. 

 To cancel all your view appearance settings, choose the 
default colour scheme from the Properties page of the Options 
dialog. 
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Background Image Properties dialog 
This dialog contains the controls to fit the image on the screen. 

 

Image Fit Type 
These options determine how the image is displayed in the graphics 
window. 

Stretch — The image is stretched to fit the modelling window. 

Whole — Display the whole image on the screen and preserves 
the aspect ratio of the image. It is most useful for tracing. 

Clip — Clip the image to the view and preserves the aspect ratio 
of the image. 

Tile — This repeats and tiles the image to cover the entire area 
of the view. 

New Image... — Displays the Image Selector dialog so that you can 
select another image. For further details, see Image Selector dialog  
OK — Accept the changes and close the dialog. 

Cancel — Discard any changes and close the dialog. 
 

View > Stencil 
You can transfer a 2D image onto a surface using the Stencil 
functionality. This displays the image and lets you use the standard 
curve creation tool to trace the image onto the surface. This is 
particularly useful for tracing a design onto a shoe last. 

Use the following sections to explore the Stencil functionality: 

 Stencil toolbar (see page 134) 

 Creating a stencil (see page 133) 

 Editing a stencil (see page 135) 

 Hiding and displaying a stencil (see page 137) 
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Creating stencils 
Use a stencil to transfer a sketch to an object.  

To create a stencil: 
1 Ensure that you have an image file to use as the stencil. The 

image file can have one of the following extensions: 

jpg, bmp, png, tiff, obj 
2 Select the object to have the stencil applied. 

 

3 Select View > Stencil to display the Stencil toolbar. 

 

4 Click  to display the Load Image dialog 

5 Select an image file using the Load Image dialog.  

6 Click Open to display the image file on top of the model. 

 

7 Click True Size  to show the real size of the image. 
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8 Use the Editing tools (see page 136) to create the stencil you 
require. 

 
9 Save the model. Any stencils that you have created are saved 

with the model. 

10 An additional Stencil flyout is added to the Views toolbar. The 
flyout includes a separate button for each stencil that has been 
saved with the model. 

 
11 When you have created the required stencil, use wireframe 

functionality to sketch through the transparent stencil onto the 
last. This transfers a 2D sketch onto a 3D last. 

 

Creating a stencil the size of your image 
You can create a Stencil that is the same size as the image you are 
using.  

1 Create an image to sketch onto. 

2 Create and select a workplane that is to be the origin of your 
image.  

3 Create a stencil using the image. The surface to which the image 
is applied takes the size of the image. The image size is retained. 

 

Stencil toolbar 
1 Select View > Stencil to display the Stencil toolbar. 

 

2 Click  to load an image file. The other options become 
available on the toolbar. 

 
The following buttons are displayed on the stencil toolbar:  
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 Display the Load Image dialog. 

 Delete the selected stencil from the drop-down list. 

 Make the stencil True size; the stencil size will be determined 
by the attributes of the image (width and height). 

 Wrap the stencil onto the last or selected object (surface. 
solid or mesh). 

 Edit the stencil using the tools on the Editing section of the 
toolbar (see page 136). 

 Flip the stencil horizontally. 

 Flip the stencil vertically. 

 Display the Editing section of the toolbar (see page 136). 

 Adjust the Transparency of the stencil. 
 

Editing stencils 
You can edit a stencil in the following ways: 

 Adjust the transparency level of the stencil. 

 Adjust the horizontal and vertical location of the stencil. 

 Rotate the stencil. 

 Scale the stencil image. 

 Mirror the stencil image. 

 Delete the stencil (see page 137). 

To edit a stencil: 
1 Open a model that includes one or more stencils. 

 
2 If the stencil is not displayed, click View > Stencil. 
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3 Select  Edit. If necessary, click  to display the Stencil Editing 
toolbar (see page 136).  

4 Use the buttons on the Stencil Editing toolbar to position and size 
the stencil as required. Alternatively, use one of the following key 
combinations: 

Move the stencil - Shift+middle mouse button. 

Scale the stencil - Ctrl+middle mouse button. 

Rotate the stencil - R+scroll middle mouse button. 

5 Save the model. The updated stencils will also be saved. 
 

Stencil toolbar (editing) 
With the Stencil toolbar displayed: 

1 Click .  

2 If the Editing section of the toolbar is hidden, click  to display 
the following: 

 
3 Use the flyouts and buttons to edit the stencil: 

 Move 

 Move in both directions. 

 Move horizontally. 

 Move vertically 

 Rotate 

 Rotate 1 . 

 Rotate 5 . 

 Rotate 90 . 

 Scale 

 Scale in both directions. 
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 Scale horizontally. 

 Scale vertically. 

 Scale, maintaining aspect ratio. 

 Flip 

 Flip horizontally. 

 Flip vertically. 
 

Deleting a stencil 
Delete a stencil in one of the following ways: 

 Delete the currently selected stencil by clicking  on the 
Stencil toolbar. The active stencil is deleted, the next stencil is 
displayed and made active. 

 Delete a stencil from the drop-down list as follows: 

1 Select the stencil to be deleted. 

 

2 Click Delete Stencil . The selected stencil is removed from 
the drop-down list. 

 

Hiding a stencil 

Hide a stencil that is displayed on a model by clicking on  (Views 
toolbar) 

 
 



 

138 • Menus PowerSHAPE 2015 R2 Reference Help  

Displaying stencils on a model 

When you open a model that includes stencils,  is automatically 
included on the Views menu. 

 

1 Click . 

2 Select the required stencil from the flyout. 

 
The relevant view of the model is displayed with the selected 
stencil superimposed. 

 When you view the model for each of the stencils, the image 
is projected over the selected model. If you twiddle or select 
an ISO view, the stencil will stay in the original position. 

 

View > Blank 
Use these options to set the parts of the model to blank 
(temporarily undraw). 

1 From the View menu, select Blank to display the following menu: 

 
2 Select the option you require: 

Blank Selected (see page 138) 

Blank Except (see page 139) 

Blank Toggle (see page 139) 
 

View > Blank Selected 
This allows you to temporarily remove selected objects from the 
screen. 

1 Select the objects on the screen that you want to blank. 

2 Click Blank Selected  (Views toolbar). The selected objects are 
removed from the screen. 
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This command is useful when you want to temporarily remove some 
objects from view and using Levels is not always appropriate. This is 
because, a level may contain objects you don’t want to be hidden 
and/or changing the levels may affect the model’s logical structure. 

This option allow you to remove selected objects from the screen. 
They are not deleted, but merely hidden and can be unblanked 
when required. This allows you to concentrate on the objects you 
need to work on without being hindered by others close by. 

 

View > Blank Except 
This option blanks all objects on the screen apart from those which 
are selected. 

1 Select the objects you want to remain on the screen. 

2 Click View > Blank > Blank Except. 
3 All those which are not selected are blanked from the screen. 

This allows you to remove from view, everything except the selected 
objects. They are not deleted, but merely hidden and can be 
unblanked when required. This allows you to concentrate on the 
objects you need to work on without being hindered by others close 
by. 

 

View > Blank Toggle 
This option blanks all visible objects and unblanks all previously 
blanked objects. 

1 Click View > Blank > Blank Toggle. 

All visible objects become blanked and previously blanked 
objects become visible. 

 

View > Unblank 
This option displays all objects which were previously blanked. This 

option is the same as clicking  (Views toolbar) 

1 Click Unblank . If any objects have been blanked from the 
screen, they become visible. 

When this option is used, all objects that were hidden with either 
Blank option are displayed selected. If you only want to unblank 
a few, deselect them (hold down Shift while clicking on them) 
and re-blank the remaining selected objects with Blank Selected 

. 
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View > Refresh 
Sometimes, pieces of the display can remain on screen after the 
actual objects have been moved, deleted or are no longer displayed.  

Selecting Refresh redraws all graphics windows, cleaning up the 
display. 

A more powerful redraw function is available by using the Rebuild 
(see page 140) option. 

 

View > Rebuild 
Use this option to clear the graphics window of the current model 
and redisplay the items using data from the database. 

 Rebuild redisplays any blanked items and does not remember 
selected items. 

1 From the View menu, click on Rebuild. 

This clears the graphics window of the current model, recalls the 
definitions of the items from the database and redraws the items 
again. 

 Since Rebuild recalls the items' definitions from the database, 
Rebuild takes longer to perform than Refresh. We recommend 
that you first use Refresh to correct your view and if that does 
not work, use Rebuild. 

 

View > Full Screen 
Select Full Screen to increase the visible modelling area by removing 
the banner and the menu bar from the top of the display. Menus 
can still be accessed by moving the mouse across the top of the 
screen area. 
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View > Full Screen Preview 
Select Full Screen Preview to increase the visible modelling area by 
removing the banner, menu bar and all the toolbars from the 
display. Menus can sill be accessed by moving the mouse across the 
top of the screen. 

 
 

View > Drag Move 
Select Drag Move to toggle the ability to select and move and object, 
on or off. 

 If Drag Move is on, you can move an object to a new position by 
dragging it with the cursor. 

 If Drag Move is off, you can select an object, but not move it with 
the cursor. 

 

View > Toolbars 
Use the options on the submenu to control the toolbars that are 
displayed on the screen. 
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1 Select View > Toolbars to display the following menu: 

 
If an option is selected, the toolbar will be displayed 

2 Select the option you require. 
 

View > Toolbars > Views 
This displays and removes the Views toolbar from the screen. 

Most buttons on the Views toolbar are a shortcut to an option on the 
View menu. and are given below with their corresponding View 
menu option. 

 
View > Single (of model) > Right 

 
View > Single (of model) > Front 

 
View > Single (of model) > Top 

 
View > Single (of model) > Left 

 
View > Single (of model) > Back 

 
View > Single (of model) > Bottom 

 
View > Single (of model) > ISO1 

 
View > Single (of model) > ISO2 

 
View > Single (of model) > ISO3 

 
View > Single (of model) > ISO4 

 
View > Multiple > 3rd Angle + ISO (see page 144) 
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View > Multiple > 1st Angle + ISO 

 
Restore selection * 
Use this option to toggle between the previous and 
current selection. It also works on sub-item selection of a 
solid. 

 
Last view (see page 118)  

 
View > Zoom Full 

 
Zoom in (see page 145) * 

 
Zoom out (see page 145) * 

 
Actual size (see page 145) * 

 
Zoom to fit box (see page 146) * 

 
Zoom (see page 146) * 

 
Rotate (see page 148) * 

 
Pan (see page 147) * 

 
Blank Selected (see page 138) 

 
Unblank (see page 139) 

 
View > Shading > Wireframe (see page 121) 

 
View > Shading > Shaded (see page 122) 

 
View > Shading > Transparent Shaded (see page 123) 
(click to toggle Transparent Shaded Wire ON or OFF) 

 
View > Shading > Shaded Wire (see page 124) 

 
View > Shading > Dynamic Hidden Line (see page 125) 

 
View > Shading > Enhanced Shaded (see page 126) 

 
Not available (Under development) 

 
Not available (Under development) 
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Display meshes as nodes and open edges (hollow) (see 
page 127) 

 
Display meshes as open and interior edges (hollow) (see 
page 127) 

 
Display meshes as nodes and open edges (shaded) (see 
page 127) 

 
Display meshes as open and interior edges (shaded) (see 
page 127) 

 
Display meshes as open edges only (see page 127) 

 
Render an image (see page 127) 

 
Display the Render dialog *  

* Not on View menu. 
 

3rd angle + Iso 

Click  (Views toolbar). This displays four views.  

When viewing or sketching onto objects using the 3rd angle + Iso 

 view, each of the four views has  its own different principal 
plane which is at right angles to the view. The principal plane is 
automatically selected appropriate to each view. 

 This excludes the ISO1 view which will have the XY principal 
plane. 
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For best results to see the orientation of the principal plane in the 4 
views, click the Grid on/off  option on the Status Bar to display the 
grid. 

 
 

Zoom in 

Click  (Views toolbar). The new scale is double the original 
scale. 

You can also zoom into your model by holding down Ctrl and either 
the middle or right mouse button, and dragging the mouse up the 
screen. 

 

Zoom out 

Click  (Views toolbar). The new scale is half the original scale. 

You can also zoom out from your model by holding down Ctrl and 
either the middle or right mouse button, and dragging the mouse 
down the screen. 

 

Zoom to actual size 

Click  (Views toolbar). 
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The model is panned to the centre of the screen and drawn to its 
actual size. 

 

Zoom to box 
Use this button to select an area of the model that will be magnified 
to fill the graphics window. 

1 On the View toolbar click  (Views toolbar). The cursor 

changes to . This is the same as selecting View > Zoom to box. 

2 Using the left mouse button, click a point on the model, drag a 
box to enclose the required area and release the left mouse 
button. The area of the model will be magnified to fill the graphic 
window. 

 
You can also zoom to a box by: 

 holding down Shift+Ctrl and dragging a box using the middle 
mouse button.  

 holding down Alt and using the right mouse button. 
 

Zoom in and out 

1 Click  (Views toolbar). 
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2 Click the left mouse button in the graphics window and keep the 
mouse button pressed. 

 
3 Drag the cursor up and down the screen. 

 
Drag the cursor up the screen to zoom into the model. 

 
Drag the cursor down the screen to zoom out. 

 
4 When you have the required view, release the mouse. 

 

Panning the view 
Use this option to move the model in the graphics window. 

1 From the View menu, select Pan. The cursor changes to  
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2 Hold down the left mouse button and drag the mouse to move 
the view. The view of the model is temporarily attached to the 
cursor. 

3 When you have moved the view to the required position, release 
the mouse button . 

 
 

Rotating the view 

1 Click  (Views toolbar). 

2 Drag the mouse in the graphics window to rotate the view. 

As soon as you click the graphics window, a roller ball appears on 
the screen. 

 
You can drag the cursor in any direction. 
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As you drag the cursor, the view of the model changes. 

 
3 Release the mouse when the model is viewed at the required 

angle. 
 

View > Toolbars > Levels 
This displays and removes the Level toolbar from the bottom of the 
screen. 

 
The Levels form  button opens the Levels dialog. For further 
details, see Format > Levels (see page 29). 

The Level toolbar displays buttons for used and named levels. If you 
move the mouse over a button, the name of the level is displayed 
as dynamic help. 

 A level is ON if its button is pressed in. 

 To turn a level OFF, push out its button. You can also turn levels 
on or off using the Level dialog. For further details, see Level 
dialog (see page 29). 

 To turn a level ON, press in its button. 

To add objects onto a level: 
1 Select the group of objects. 

2 Click the middle mouse button on a level button on the Levels 
toolbar. 

The objects are put on that level. 
 

Grouping levels 
You can group levels together. To do this, put the name of the 
group in front of the name of the level and separate the names 
using a colon ':'. 

For example, suppose we have the following levels: 
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5 : bottle 

6 : handle 

To group these levels together, we rename the levels as follows: 

5 : top : bottle 

6 : top : handle 

You can name a level in the following ways: 

 Using the Levels drop-down list. 

 Using the Level dialog (see page 29). 

 Using the Edit groups dialog (see page 151).  

The two levels now belong to the group called top. 

 
On the Levels toolbar, the following changes can be seen: 

 the buttons of the two levels have changed to the same colour. 

 a new button appears representing the group of levels. It 
displays the first part of the name of the group. 

 the colour of the group button matches that of the two levels. 

You can turn OFF and ON a group of levels by turning on or off the 
group button. When a level in a group or a group is OFF, its button 
has a border containing the colour of the group to indicate it is off. 
In the example below, level 5 has been switched OFF . 

 
Each time you create another group, another group button is added 
with a different colour. 

You can add and remove levels from groups by adding and 
removing the group name from the level name. 

 

Levels context menu 
1 Right-click on a button on the Level toolbar to display the context 

menu. 
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2 Select an option to apply to the level. 

Solo — Turn on that level and turns off all other levels. 

Blank — Open a submenu with options to blank particular objects 
on that level. 

Unblank — Open a submenu with options to unblank particular 
objects on that level. 

Select All — Select all items on the level. 

Add selection — Move the current selection to the level. 

Edit groups — Display the Edit groups dialog (see page 151). 

Switch all on — Turn on all levels. 

Switch all off — Turn off all levels. 

 For group buttons, the options apply to all the levels in that 
group. 

 

Edit groups dialog 
This lets you to switch levels from one group to another and rename 
levels. 

 

Named levels 
You can use this box to name a level.  

For example, to name level 35 as handle and add it to the group 
called core, type: 

35 core: handle 
The format of the information you enter should be in the following 
format: 
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level_number group_name: level_name 
If no group name is given, just the level is named. 

The column below the Named levels box displays the other named 
levels not in the selected group. Click a level to remove it from this 
column and add its name to the other column. 

Select or create a group 
This is the name of the selected group. You can create a new group 
by typing a new name in this drop-down list. 

The column below this box displays the names of the levels in the 
selected group. Click a level to remove it from the group and add its 
name to the other column. 

If a group has no levels, it is automatically deleted. 

OK — Close the dialog. 
 

View > Toolbars > General Edit 
The General Edits toolbar is automatically displayed when you open 
PowerSHAPE.  
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If you have the Model Analysis or Model Fixing toolbar ON, you can 

swap to the General Edit toolbar by clicking the General edits  

button on the General edits  flyout. 

 
The type of item and sub-item that appear on the toolbar depend on 
your selection. Options for wireframe, surface and solids are 
included here. 

 Edit selected item (wireframe) 

 Edit selected sub-item (wireframe point) 

 Edit selected item (surface curve) 

 Edit selected sub-item (surface point) 

 Edit selected sub-item (surface curve) 

 Edit selected item (solid) 
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 Edit selected sub-item (solid feature) 

 Interactively limit wireframe 

 Point limit 

 Limit cut 

 Limit selection 

 Move/copy object 

 Stretch object 

 Place wireframe 

 Rotate object 

 Mirror/symmetrise object 

 Offset object 

 Variable offset 

 Scale the object(s) 

 Create pattern of objects 

 Project items onto a plane 

 Project points onto surface 

 Morph objects 

 
 

View > Toolbars > Surface/Curve Edits 
Use this option to display the Surface/Curve Edit toolbar. 

For further details, see: 

 Editing a curve. 

 Editing a surface using the toolbar. 
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View > Toolbars > Model Fixing 
This toolbar groups together the tools for fixing a model. 

1 Select Model Fixing from the Toolbars options on the View menu. 

This is the same as clicking the Model Fixing  button on the 

General edits  flyout. 

The Model Fixing toolbar is displayed. The options that are 
available depend on your model and selection. 

 
2 Select an option from the toolbar 

 
Identify badly trimmed surfaces from selection 

 
Open the Surface trim region editor 

 
Approximate surfaces 

 
Simplify surfaces outside trim 

 
Stitch the current surface to either another surface or a 
curve (Stitch surface) 

 
Automatic surfacing (Smart Surfacer) 
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Orient surface normals 

 
Create solid from selected surfaces 

 
Find and select duplicate attributes (Find duplicates) 

 
Display open edges of solid 

 
Repair selected solid. 

3 When required, turn OFF the Model Fixing toolbar by selecting 
General Edit or Model Analysis from the Toolbars menu. 

 

View > Toolbars > Model Analysis 
This toolbar groups together the tools for analysing a model. 

1 Select Model Analysis from the Toolbars options on the View 

menu. This is the same as clicking the Model Analysis  button 

on the General edits  flyout. 
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The Model Analysis toolbar is displayed. 

 
2 Select an option from the toolbar. 

 
Open the calculator (Calculator) 

 
Show model contents list 

 
Turn surface inspection on 

 
Turn surface inspection off 

 
Dynamic sectioning 

 
Smoothness shading 

 
Undercut shading 

 
Curvature shading 

 
Minimum radius shading 
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Display thickness of a solid as a colourmap (Thickness 
shading) 

 
Display minimum wall thickness of solid 

 
Compare two models and select the differences (Model 
compare) 

 
Model visual difference 

 
Comparison analysis 

3 When required, turn off the Model Analysis toolbar by selecting 
General Edit or Model Fixing from the Toolbars menu. 
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View > Toolbars > Style 
This displays and closes the Style toolbar. To use the Style toolbar, 
you must either have an object selected or be in an object creation 
mode. 

From the Format menu, select Style to display the Style toolbar. This 
is the same as clicking Style Toolbar on the Item colour drop-down 
menu (Main toolbar). 

 
If the Style toolbar is already raised, it is lowered. 

 
 Style name (see page 3). 

 Select colour (see page 3). 

 Line pattern (see page 4). 

 Create user defined line pattern (see page 4). 

 Line justification (see page 8). 

 Plotter pen (see page 10). 

 Copy style (see page 10). 

 Delete unused styles and pattern (see page 11). 

 Line width and weight/gap options (see page 11). 

Use the Style toolbar to change: 

 the style of a selected object. 

 the default creation style of an object. 
 

How do I change the style of selected objects? 
1 Select one or more objects. 
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2 Select a style by name using the Style name drop-down list or 
change settings (such as colour) on the Style toolbar. 

The objects use the new style or setting. You may need to 
unselect the objects to see the new style. 

The styles on the objects are renamed to existing styles with 
matching settings. If no existing style matches the settings, then 
a new one is created. 

 

How do I change the default creation style of objects? 
1 Enter any object creation mode. 

2 Select a style by name using the Style name drop-down list or 
change settings (such as colour) from the Style toolbar. 

When you change the settings on the Style toolbar, the style 
matching the new settings is displayed in the Style name drop-
down list. If no existing style matches the settings, then a new 
style is created. 

New styles are given a default name, which will not appear in the 
Style name drop-down list unless an object using the style is 
selected or the settings defining the style are selected. To allow a 
new style to be selected by its name, rename it by typing in the 
required name into the Style name drop-down list. 

By default, all objects created from now onwards will use the 
new settings. 

You can change the default so that the new settings are only 
used on objects of the selected creation mode or on objects 
belonging to a particular group (for example, if the object is 
wireframe then all wireframe use that style). To change the 
default, select the appropriate option on the Format page of the 
Options dialog. 

 

Style toolbar - Solid style 

 This drop-down list lets you choose how a style is applied to a 
solid. 

 Whole solid — Style is applied to whole solid. 

 Selected features — Style applies to selected features of solid. 
Select the features on the solid or by using the solid feature tree 

 Selected face — Style applies to selected face of solid. Select 
the face on the solid. 
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Style toolbar - Style name 
This drop-down list stores a list of names of the styles. When you 
create new styles, you can change their names using this drop-
down list. You can also select styles from this drop-down list to use 
on objects. 

When you select an option from the Style name drop-down list, a 
preview of the style is displayed. 

 
A style with a name of the format Unnamedn will not appear in the 
Style name drop-down list unless an object using the style is 
selected or the settings defining the style are selected. To allow 
such a style to be selected by its name, select the object displaying 
this style and rename the style by typing in the required name into 
the Style name drop-down list. 

 

Style toolbar - Style colour 

The Colour  drop-down menu changes the colour of the 
style. 
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Style toolbar - Line pattern 
The Line pattern drop down list on the toolbar provides a selection of 
patterns.  

 
 

Create user defined line pattern 
To create your own line patterns: 

1 Click the Create user defined line pattern  button.  

2 Select the appropriate tab on the User defined line patterns dialog 
to create your own line pattern using 

 dashed lines (see page 5) 

 symbols (see page 7) 
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Line patterns from Dashed tab 
This dialog is used to create user defined line patterns. 
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Sequence — In this box, input the pen down and up sequences. For 
example, 1 1 3 3 creates a pattern where the pen is down for 1 
unit, up for 1 unit, down for 3 units and up for 3 units. This pattern 
is repeated in the line. 

 
Start Mark and End Mark — Enables you to add a mark to the start or 
end of the line. 

Type — Select a mark to add to the end of the line pattern. There 
are standard marks in the list plus all the symbol definitions stored 
in the model. Symbol definitions are prefixed with *. This helps you 
to distinguish between the standard and the user-defined markers. 
For further details, see Symbols. 

Size — For the standard marks, you can set the size of the mark. 

Pattern name — This is the name of the line pattern. A unique 
default name is created. You can change it to your own 
requirements. 

The graphics window shows the pattern of the line as you define it. 
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OK — Creates the line pattern and adds its name to the Line pattern 
selector. A new style is also created using this pattern and given a 
default name. 

 

Line patterns from Symbols tab 
This page uses a symbol definition to define the line pattern. You 
must have a symbol definition in your model to use this page of the 
dialog.  

For further details see Symbols. 

 
Symbol — This contains the list of symbol definitions in your model. 
Select the name of the symbol definition. 

We will use the symbol below to show what each option means. 
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Fitted side by side — This fits the symbol side by side in the line 
pattern. 

 
Placed at set intervals — The symbol is placed at set distances apart 
in the line pattern. The distance is set using the Interval box. 

 
Aligned with line — The base of the symbol aligns with the line. 

Aligned at an angle — The base of the symbol is set at an angle 
relative to the current workspace. The angle is set in the Angle box. 

 
Minimum width — This is the width of the symbol in the line pattern. 

 
Pattern name — This is the name of the line pattern. A unique 
default name is created. You can change it to your own 
requirements. 

The graphics window shows the pattern of the line as you define it. 

OK — Create the line pattern and add its name to the Line pattern 
selector. A new style is also created using this pattern and given a 
default name. 

 

Style toolbar - Line justification 

The Line justification  drop-down menu has four justification 
options: 

 Left 

 Centre 

 Right 

 Round Ends. 
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Justification controls how lines are thickened. This can happen at 
either side or both sides of the “track” between the start and end 
key points. 

The following examples use thick lines to illustrate the point on a 
bold box shape: 

 
 Justification centre. 

 Justification right. 

 Justification left. 

You can see how the line justification can be used to produce sharp 
corners for square boxes. However, for lines which meet at other 
than 90°, none of the left, right or centre justification options can 
produce neat corners. The round-ends option is provided to solve 
this problem: 

 
 Square ends. 

 Round ends. 

The lines on the right have round ends. These are automatically 
centre justified and produce much neater corners than the square-
ended lines on the left. 

Justify left 

 puts the line thickness to the left of the track. 
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Justify centre 

 puts the line thickness either side of the track. 

 

Justify right 

 puts the line thickness to the right of the track. 

 

Round ends 

 draws round instead of square ends on selected lines. All round-
ended lines are centre justified. Their actual end points are inside 
the end radii as shown below. 

 
 

Style toolbar - Plotter pen 
When printing to a plotter, this allows you to specify the plotter pen 
to be used for a specific style. If the pen is set to 0, PowerSHAPE 
automatically chooses the most appropriate pen, based on the 
nearest match between the styles and available pens. 

 

Style toolbar - Copy style 
This option allows you to copy the current style. 

To copy a style: 

1 Click the Copy button  on the Style toolbar to display the New 
Style Name dialog. 

 
This dialog is used to name the copy of the selected style. 

2 In the Name text box, enter a new name for the style. 

3 Click OK. 
 



 

PowerSHAPE 2015 R2 Reference Help Menus • 11  

Style toolbar - Deleting unused styles and patterns 
This option is used to delete unused styles and patterns. 

1 Click the Delete style  button to display the Delete unused styles 
and patterns dialog. 

2 Use the Delete unused styles and patterns dialog (see page 11) 
to remove unused styles and patterns. 

 

Style toolbar - Delete unused styles and patterns dialog 
This dialog is used to delete unused styles and patterns. 

 
The Styles tab lists all the styles that are not used in the current 
model. Select the styles from the list. A single click on an item 
highlights it as selected. Clicking a second time removes it from the 
selection. 

The Patterns tab lists all the patterns that are not used in any of the 
styles. Select the patterns you want to delete from the list. A single 
click on an item highlights it as selected. Clicking a second time 
removes it from the selection. 

 If you want to delete a pattern and it is not listed, it must be 
used in one of the styles. You must delete the style first and 
then delete the pattern 

Delete — Deletes the selected item. 

Close — Closes the dialog. 
 

Style toolbar - Line Width and Weight/Gap option 
This is a drop-down menu showing: 

 Width. 

 Weight/Gap. 
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Line Width 
This controls the width of the line strand. 

 
1 On the Style toolbar, select Width. 

2 Type a value into the text box. 

3 Press Enter to update the style. 

 If you alter the line width and there is an existing matching 
style of a different width, the new style name has the new line 
width added as part of the style name. For example, if the 
original style was Red and you alter the line width to .7, a new 
style called Red .7 will be created. 

Line Weight/Gap 
This allows you to create lines with multiple strands and set the gap 
between the strands. The weight of a line is the number of strands. 

The overall line width is determined by the sum of strands  and 
gap widths . Note that the default thickness of a strand is 0.3. 

 
1 If Weight/Gap is not already displayed on the Style toolbar, from 

the option menu with Width select Weight/Gap. 

2 Type values into the two data entry boxes. 

Weight controls the number of strands. 

Gap controls the spacing between strands. 

3 Press Enter to update the style. 
 

View > Toolbars > Explorer 
This displays the Explorer toolbar in the browser window. It appears 
on the Browser and PS-Team pages of the browser window and 
contains tools, such as back and forward, for viewing web pages. 
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View > Windows 
Use the options on the submenu to control the windows that are 
displayed on the screen. 

1 From the View menu, select Windows to display the following 
menu: 

 
If an option is selected, the window will be displayed. 

2 Select the option you require. 
 

View > Windows > Command 
This displays the Command Window.  
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The command window allows you to type commands directly. It also 
lets you view commands and macros as they are run. 

 
The command window can appear in two different forms 

 Docked — The window is formatted to appear at the edge of the 
graphics window. One possible position is shown above. You dock 
the command window by dragging the floating window to the 
bottom of the graphics window. 

 Floating — The position of the command window is independent 
of the graphics window. 

You can float the Command Window using one of the following 
methods: 

 dragging the two parallel lines next to the  button on the 
edge of the frame. 

 holding down the Control key and clicking the two parallel 
lines. 

When dragging the floating window, you can prevent it from 
docking by holding down Ctrl. 
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You can remove the Command Window from the screen by either 
pressing the  button on its frame or selecting View > Windows > 
Command. 

 

View > Windows > Tree Window 
You can display and remove the window containing the solid tree by 
selecting and deselecting this option. The window will be opened 
automatically when you edit a solid. 

 

View > Windows > Browser 
You can display and remove the Browser window by selecting and 
deselecting this option. 

To shrink the browser window into the left side of the window: 
1 Click . 

 
The window is replaced by a bar with an arrow on it in the left 
side of the window. 

 
2 Click this bar to restore the browser window. 

The Browser displays the following tabs: 

 

 Home. 
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 Learning Assistant. This option becomes inactive when a 
Delcam Toolmaker wizard is running in the Browser. 

 Tutorials. 

 Help. 

 Delcam.com browser 

 PS-Team - currently under development. 

 Delcam Toolmaker. This tab is only active when a Delcam 
Toolmaker wizard is running in the Browser. 

 

View > Windows > Component Library 
You can display and remove the Component Library window by 
selecting and deselecting this option. 
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Object menu 
Use this menu to select the object to be created. 

 
The submenu for each object is explained in the relevant section. 

 

Object > Workplane 
Use the options on the submenu to create a workplane in your 
model. 

 
For further details, see Creating a workplane. 
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Object > Point 
Use this option to create a point in your model. 

For further details, see What is a point? 
 

Object > Line 
Use the options on the submenu to create lines. 

 
For further details, see What is a line? 

 

Object > Arc 
Use the options on the submenu to create arcs and circles. 

 
For further details, see What is an arc? 
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Object > Curve 
Use the options on the submenu to create curves. 

 
For further details, see What is a curve? 

 

Object > Text 
Use the options on the submenu to create text in the Drafting 
module. 

 
For futher details, see Entering annotation creation mode. 
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Object > Balloon 
Use the options on the submenu to create balloons in the Drafting 
module. 

 
For further details, see Entering balloon creation mode. 

 

Object > Dimension 
Use the options on the submenu to create dimensions in the 
Drafting module. 

 
For further details, see Entering dimension creation mode. 
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Object > Surface 
Use the options on the submenu to create surfaces. 

 
For further details, see Surface creation. 
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Object > Mesh 
Use the options on the submenus to edit meshes. 

 
For further details see Editing a mesh. 
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Object > Solid 
Use the options on the submenu to create solids. 

 
For further details, see Using the solid creation options. 
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Object > Feature 
Use the options on the submenu to create solid features. 

 
For further details, see Using the feature creation options. 
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Object > Wizards 
Use the options on the submenu to access the wizard options. 

 
For further details, see Using the wizard options. 

 

Object > Hatching 
Use this option to create hatching in the Drafting module. 

For further details, see Creating hatching. 
 

Object > Schedule 
Use the options on the submenu to create and append schedules in 
the Drafting module. 

 
For further details, see What is a schedule? 

 

Object > Symbol Definition 
Use the options on the submenu to access the create and edit 
options for symbol definitions. 

 
For further details, see Creating a symbol definition and Editing a 
symbol definition. 

 

Object > Symbol 
Use this option to create symbols in the Drafting module. 
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For further details, see What is a symbol? 
 

Object > Drawing 
This creates drawings in the Drafting module. 

For further details, see Creating a drawing in Delcam Draft.. 
 

Object > View 
Use the options on the submenu to create views in the Drafting 
module. 

 
For further details, see Entering view creation mode. 

 

Object > Assembly 
Use the options on the submenu to create an assembly when in 
Assembly modelling mode. 

 
For further details, see Creating a new assembly. 

 

Object > Component 
Use the options on the submenu to create components when in 
Assembly modelling mode. 

 
For further details, see Creating components. 
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Object > Relation 
Use the options on the submenu to create a relation and manage 
attachments when in Assembly modelling mode. 

 
For further details, see Adding relationships between components. 

 

Object > Multi-model 
Use the options on the submenu to manage multiple models when 
in Assembly modelling mode. 

 
For further details, see Assembly modelling. 

 

Object > Parameter 
Use this option to open the Parameter Editor dialog which enables 
you to calculate and input parameters for objects in your model. 

 
For further details, see Creating a parameter. 
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Format menu 
The options in this menu let you alter the format of the non-
geometric properties of objects. 

 
 

Format > Style Dashed 
Use this option to change the line style of selected lines and arcs to 
dashed. It is particularly useful in drawing views for displaying lines 
and arcs as hidden. 

If you use the Style toolbar to change the style of an object, the 
style affects all views of the object in all model and drawing 
windows. In drawing windows, the style of an object sometimes 
needs to be view dependent because an object may be hidden (and 
hence dashed) in one view, yet visible (hence solid) in another. 

The Format > Style Dashed option can be used to set the style of 
pattern of a line or an arc to dashed, in a particular drawing view 
only. 

You can change dashed lines and arcs to use solid lines using 
Format > Style Solid (see page 28). 

 When you change the lines and arcs in drawing views to 
dashed, the lines and arcs in the model don't change. 

In model windows, the command simply does the same as 
changing the pattern on the Style toolbar. 

 

Format > Style Solid 
Use this option to change the line style of selected lines and arcs to 
solid after it has been set to dashed with the Format > Style Dashed 
(see page 28). 
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Format > Levels 
As your models become more complex, you may find that some 
areas become cluttered. The Levels option enables you to assign 
objects to different drawing levels and then choose whether to show 
or hide them. 

Levels are purely a display feature. They have no effect on any 
other aspect of the model. However, good use of levels can add to 
the logical structure of a model. This makes it easier for you and 
others to understand your model. 

To create levels for your model 
1 From the Format menu, select Levels to display the Level dialog. 

2 Use the dialog to add different components to different levels. 
 

Level dialog 
Use this dialog to name and display levels.  

 
The above example shows the pre-set level options in their default 
view settings. You can change these, but as the program can handle 
up to 1000 levels, it is recommended that you leave the pre-sets in 
place and create more levels when you need them. 

 The cursor/construction level (located by default on Level 
998/999) is used by the intelligent cursor to create the 
construction lines.  
We strongly recommend that you do not remove or rename 
this level. You can switch it on, but the program can become 
confusing to use when all the construction objects are 
displayed. 
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Apply to — Use this option to specify where you want to change the 
levels. For example you might want to have the same model viewed 
in one window with all objects visible, but in another window with 
some objects hidden. Select one of the following: 

 Model — Change levels in all the windows of the model. 

 Window — Change levels in only the selected window of the 
model. 

 View — Change levels in only the selected view of a drawing. 

Level — Each level has a number. Visible levels are indicated by . 
Hidden levels are indicated by . You can turn ON a level by 
clicking and OFF by clicking . You can type in a new name for a 
level or edit an existing name. 

If the model is shaded and you turn on a level, you can view the 
model in wireframe mode by pressing the  button next to the 
progress bar on the status bar whilst the level is opening. 

You can also turn levels on and off using: 

 the Levels toolbar. 

 the Drop-down list on the status toolbar. 

If you type 15 in the drop-down list, level 15 is switched on.  

If you type 15 B surfaces, level 15 is switched on and named. This 
happens even if level 15 is not currently named or used and is 
therefore not displayed in the drop-down list. 

Options — This menu has three options: 

 Set All — Set all levels to be visible (apart from the Cursor level). 

 Unset All — Set all levels to be hidden. 

 Copy Names — Copy level names from another open model (see 
page 31). 

Filter — This menu is at the top of the dialog. It controls which 
levels are shown in the dialog. Each option has a toggle, allowing 
you to select any of the options. 

 Used — Shows only the levels being used in the current 
PowerSHAPE window. 

 Named — Shows only the levels with names, even if your model 
is not using them. 

 On — Shows only the levels which are set to ON (that is the 
levels that are visible). 

 Any changes you make to this filter, do not affect the filter 
used on the Levels drop down list on the Main toolbar. The 
toolbar filter is controlled from the Options dialog. 
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Copying level names from another model 
Copy level names from another open model by selecting Copy 
Names from the Options menu on the Level dialog. 

 

To copy a level name: 
1 Ensure that you have two open models: the model with the level 

to be copied (source) and the model that the level will be copied 
to.  

2 Click  to open the Levels dialog. 

3 Select Options > Copy Names to display the Copy Level Names 
dialog. 

 
4 Select the Source model from the drop-down list. 

5 Select the levels to be copied from the list using the following 
tools: 

 Shift+click and Ctrl+click selection technique. 

 Button on the dialog: 

 Select all levels 

 Invert selection 

 Clear selection 
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6 Click OK. 
 

Format > Materials 
This option lets you edit the shading effects applied to the surfaces 
and solids in your model using View > Shading > Shaded. Shading 
does not provide fully rendered images. It allows you to visualise 
your model as a finished article.  

The Material Selection dialog can be used in two ways: 

 To change the material of selected surfaces and solids 

 To change the default material 

Changing the material of selected surfaces and solids 
1 Shade the surfaces and solids by selecting View > Shading > 

Shaded. 

2 Select the surfaces and solids whose material you want to 
change. 

3 From the Format menu, select Materials to display the Material 
Selection dialog. 

4 Select a new material. 

5 Click OK to change the material of the selected objects. 

Changing the default material 
1 Ensure that no object is selected. 

2 From the Format menu, select Materials to display the Material 
Selection dialog. 

3 Select a new material. 

4 Click OK. The new material will be used for subsequent surface 
colour shading. 
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Material Editor dialog 
This lets you edit existing options or create your own material 
effects. 

 
New — Creates a new material as defined by the current slider 
settings. A default name is given to the material, which is displayed 
in the Material text box. You can use the Material text box to edit the 
name. 

Material — This displays the name of the selected material. 

Delete — If a user-defined material is selected, the material is 
deleted. 

Sliders — If a user-defined material is selected, adjust the sliders 
until the effect you want is displayed. 

For the colours, Red, Blue and Green, you can also type in the 
values in the text boxes. 

Apply — Save the changes. The dialog remains open so you can 
continue making changes. 

OK — Save the changes and close the dialog. 

Cancel — Discard any unsaved changes and close the dialog. 
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Transparency 
Use the options on the submenu to create transparency on a shaded 
object. 

 
1 Select the objects that are to be given transparency. 

2 Select Format > Transparency to create transparency on a shaded 
object, even if the material is not transparent. This 'quick' 
transparency is saved with the object and overrides any setting 
in the material. 

3 Select the appropriate option from the menu. Show Transparency 
is selected by default. If deselected, the following transparency 
options are not available: 

 Dynamic displays the Set Object Transparency toolbar (see 
page 34). Use the slider on this toolbar to adjust the 
transparency.  

 Selecting Dynamic is the same as selecting the objects 
and pressing Shift + F4. 

 None gives no transparency for selected objects. 

 0.25 sets  25% transparency for selected objects. 

 0.5 sets 50% transparency for selected objects. 

 0.75 sets 75% transparency for selected objects. 

Using the different transparency settings gives the following results: 

 
 

Set Object Transparency toolbar 
The Set Object Transparency toolbar is displayed when you select 
Dynamic from the Transparency (see page 34) options on the Format 
menu. You use the toolbar to set the transparency on selected 
objects.  
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 You can also display this toolbar by selecting the objects and 
pressing Shift+F4. 

 
You can use the toolbar in the following ways: 

 Use the buttons to cycle through the different increments of 
transparency, shown on the Transparency (see page 34) options on 
the Format menu. 

 Use the slider to gradually apply transparency as required. 
 

Format > Lights 
Use this option to set up the lights in the shaded and render views. 

1 From the Format menu, select Lights to display the Light Studio 
Selector dialog. 

 
2 Use this dialog to set up the lights. 

Light Studio Groups — You can choose either standard or spot 
lights. You can also set up custom lights 

Light Studio — This contains the direction of the lights.  

3 Select an option. 

4 Click OK to apply the changes to the shaded view and remove 
the dialog from the screen. 

For further details, see Changing lights in the lights studio. 
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Format > Labels 
Use this option to wrap labels onto shaded objects. 

For further details, see Wrapping a label onto objects. 
 

Tools menu 
This menu contains options that affect the operation of the 
program. It also controls how some of the functionality is applied. 

 
For further information, select from the following: 
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Model Fixing (see page 37) 

Model Analysis (see page 41) 

Selection information (see page 67) 

Component Drawings (see page 69) 

Create Titleblock (see page 69) 

Create Movie (see page 69) 

Login (see page 71) 

Preview Mode (see page 72) 

Release Licences (see page 72) 

Vouchers (see page 72) 

File Doctor (see page 72) 

Compress model (see page 73) 

Convert all Solids 

Customise (see page 73) 

Options (see page 75) 
 

Tools > Model Fixing 
Use the options on this submenu to fix your model. 

1 From the Tools menu, select Model Fixing to display the following 
menu: 

 
2 Select the option you require. 

Identify badly trimmed surfaces (see page 38) 

Surface trim region editing 

Find duplicates 

Stitch 

Approximate 

Simplify outside trim 
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Smart Surfacer 

Orient normals 

Solid from surfaces 

Show open edges in solid 

Repair solid (see page 40) 
 

Tools > Model Fixing > Identify badly trimmed surfaces 
Badly trimmed surfaces are usually drawn or shaded as untrimmed.  

To identify these surfaces in the current selection 
1 Select the surfaces/solids you want to check. 

You can select a group containing any type of objects. Surfaces 
are filtered out from the group. 

If the selection contains solids, the surfaces that make the solids 
are checked and you can decide how solids containing badly 
trimmed surfaces should be handled. 

2 Click Model Fixing  on the General edits  flyout. 

3 Click Identify badly trimmed surfaces  (Model Fixing toolbar). 

4 If any of the selected solids are found to have badly trimmed 
surfaces: 

 For version 8 solids, the Identify Badly Trimmed Surfaces dialog 
(see page 39) is displayed. This lists the names of any bad 
surfaces, identifies the solids with bad surfaces and lists the 
bad surfaces in the solid. The text is also displayed in the 
command window so you can still see the surfaces that are 
bad after the dialog has closed. 

 For Parasolids, you are warned that badly trimmed surfaces 
have been found. Use Trim region editing to fix the surfaces. 

 



 

PowerSHAPE 2015 R2 Reference Help Menus • 39  

Identify Badly Trimmed Surfaces dialog 

 This dialog is only displayed if your solid is a version 8 solid. 

 
Convert solids with bad surfaces — If selected, the solids with bad 
surfaces are converted to surfaces and added to the selection when 
OK is selected. If deselected, solids with bad surfaces will remain as 
solids. The option is selected by default. 

Cancel — Discard changes and close the dialog. 

OK — Any badly trimmed surfaces that do not belong to solids are 
selected. If Convert solids with bad surfaces was selected, any solids 
with bad surfaces are converted to surfaces and the bad surfaces 
added to the selection. 

 If all the solids contain correctly trimmed surfaces, or if there 
are only badly trimmed surfaces, no dialog is displayed. 

You can investigate the trim data in detail using the Generate 
diagnostic  button on the Trim region editing toolbar.  

 

Tools > Model Fixing > Surface Trim Region Editing 
Use this option to display the trim region editing options on the 
Boundary editing toolbar. The Trim region editing option is only active 
when you select a surface that has trim boundaries. 

 

Tools > Model Fixing > Find duplicates 
Use this option to select all duplicate objects in a model. 

For further details, see Finding duplicate objects in a model. 
 

Tools > Model Fixing > Stitch 
Use this option to close small gaps between surfaces and curves 

For further details, see Stitching surfaces. 
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Tools > Model Fixing > Approximate 
Use this option to remove laterals and longitudinals that do not 
support the surface structure within tolerance. 

For further details, see Approximating a surface to tolerance. 
 

Tools > Model Fixing > Simplify outside trim 
Use this option to remove laterals and longitudinal made entirely 
invisible by being outside the trim boundaries. 

For further details, see Simplifying outside trim. 
 

Tools > Model Fixing > Automatic Surfacing 
Use this option to create a surface from a selection of wireframe. 

For further details, see Using Automatic Surfacing. 
 

Tools > Model Fixing > Orient normals 
Use this option to orient the normals of multiple surfaces such that 
the outside of two adjacent surfaces match. 

For further details, see Orient surface normal. 
 

Tools > Model Fixing > Solid from surfaces 
Use this option to create a solid from a surface or group of surfaces. 

For further details, see Creating a solid from surfaces. 
 

Tools > Model Fixing > Show open edges in solid 
Use this option to highlight any segments of selected solids' 
boundaries which are open within tolerance. 

For further details, see Finding open boundaries on solids. 
 

Tools > Model Fixing > Repair solid 
This lets you repair a solid by filling large gaps and sealing gaps. 
One of the following tools is used to repair the solid: 

 Solid Doctor if the solid is a Parasolid (post-version 8 solids). 

 Make Watertight Wizard if the solid is a PowerSHAPE solid (version 
8 solids). 

For further details see Solid modelling. 
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Tools > Model Analysis 
Use the options on this submenu to analyse your model. 

1 From the Tools menu, select Model Analysis to display the 
following menu: 

 
2 Select the option you require. 

Calculator 

Properties 

Surface inspection 

Dynamic sectioning (see page 42) 

Smoothness shading (see page 45) 

Undercut shading (see page 49) 

Curvature shading (see page 51) 

Minimum radius shading (see page 53) 

Thickness shading (see page 54) 

Solid wall thickness (see page 56) 

Model compare 

Model visual difference (see page 57) 

Comparison analysis (see page 59) 
 

Tools > Model Analysis > Calculator 
Use this option to display the Calculator dialog. 

For further details, see Calculator dialog. 
 

Tools > Model Analysis > Properties 
Use this option to find out how many objects are stored, details of 
current levels and levels of objects in the selected model. 
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For further details, see File Properties dialog. 
 

Tools > Model Analysis > Surface Inspect 
Use this option to inspect a position on a surface to display its 
coordinates, surface normal, draft angle, the wall thickness and 
curvature. Surface inspection data can also be captured and pasted 
into any text editor. 

For further details, see Inspecting surfaces. 
 

Tools > Model Analysis > Dynamic Sectioning 
Use Dynamic sectioning to take sections through your model. Use 
the sliders to move the clipping planes backwards and forward 
through the model. This lets you view the interior detail of the 
model. 

 
The orientation of the front and back clipping planes is defined by 
selecting an Axis from the drop-down list in the Dynamic Sectioning 
dialog (see page 43). 

1 Shade your model. 

2 If you have more than one view of your model displayed, click 
the view in which you want to move the section plane. 

3 Select Model Analysis  on the General edits  flyout. 

4 Click the Dynamic Sectioning  (Model Analysis toolbar). 

5 Use the Dynamic Sectioning dialog (see page 43) to dynamically 
take sections through your model. 
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Dynamic Sectioning dialog 
Use the Dynamic Sectioning dialog to take sections through the 
model. 

 
1 Select the Axis from the drop-down list. This determines the 

orientation of the Front and Back planes. 

 
Around Y means rotate the clip plane around the Y axis of the 
world or active workplane. This is used for circular items that are 
centred on the workplane or world origin. In this case, the clip 
plane will give views of the cross section at particular angles. 

 Y axis selected. 

 Around Y axis selected. 

 
2 Specify the clipping planes to be used by selecting Front, Back or 

both. 
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3 Holding down the left mouse button, drag the mouse to move a 
slider along. As you move the slider, the position of the 
sectioning plane is moved to display a section through the 
model. 

 
If necessary, click Reset to reset the clipping planes to the 
default position for the current view. 

4 Click  to lock the clipping planes, so that the Front and Back 
planes maintain the same relative distance.  indicates that the 
planes are locked. 

 
5 If necessary, change the distance of the Front or Back plane from 

the origin. 

6 If required, click  to create a workplane on the clipping plane. 
There are separate buttons for the Front and Back planes. 

7 You can also click  to position the front and back planes at a 
position chosen using the Intelligent cursor. 

8 Click  to create wireframe of the intersection of the model and 
the clipping plane . There are separate buttons for the Front 
and Back planes. 

 
9 The following options determine the appearance of the clipped 

plane: 
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Draw edges — Select this option to draw the edges of the section, 
as shown in . 

 
Translucency — Select this option to draw the section 
translucent, as shown in . 

 
Cap solids — Select this option to display a cap on the solid 
where it is intersects with the clipping plane . 

 
10 Select the Arc fitting option to automatically apply Arc fitting to 

any curves created using the dialog. You can also click the Arc 
fitting options  button to open the Arc Fitting dialog. 

11 Click Close to remove the dialog and reset the clipping planes. 
 

Tools > Model Analysis > Smoothness Shading 
This option lets you check the smoothness of surfaces. 

Smoothness Shading shades surfaces in bands of colour to show how 
smooth surfaces are and how smoothly they join together. This type 
of shading will show up the following discontinuities in the surface. 

 Positional continuity. Surfaces have positional continuity if there 
is a smooth change in position as you move across the surface. 
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 Tangent continuity. Surfaces have tangent continuity if there is a 
smooth change in tangent direction (surface normal direction) as 
you move across the surface. Sharp corners have positional 
continuity but not tangent continuity. 

Where there is a tangent discontinuity, the bands of colour will 
not join up (the bands do not have positional continuity). 

 
 Curvature continuity. Surfaces have curvature continuity if there 

is a smooth change in curvature as you move across the surface. 
A rounded corner (as below) has tangent continuity but not 
curvature continuity as the curvature changes suddenly at point 
B from one value to another. 

 
Where there is a curvature discontinuity, the bands of colour will 
not have tangent continuity. 

 
 Band has positional and tangent continuity at the join, so the 

surface has curvature continuity at the join. 

 Band has positional continuity but not tangent continuity at 
the join, so the surface is tangent continuous, but not curvature 
continuous at the join. 
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Suppose we have the following surfaces on the screen. 

 
We will now orient the surfaces with respect to the light source. It is 
best to orient the surfaces when they are already shaded. 

We will use Smoothness Shading to shade the surfaces and orient 
them in the required position. 

1 From the Tools menu, select Model Analysis to display the 
following menu: 

 
2 Click on Smoothness Shading to shade the surfaces. 

3 Dynamically rotate the view using the middle mouse button. 

Remember that the contours will show the angle between the 
surface normal and a light shining from the top of the screen. Try 
and orient the model so that the surfaces you are interested in 
are pointing towards this imaginary light source. 

The shading will update, showing the bands of colour moving 
over the surfaces. 
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The surfaces will be shaded similar to those shown below. 

 
The surfaces are shaded with two bands of colour. These define how 
smooth the surfaces are and how smooth the join between surfaces 
is. 

If the bands of colour flow into one another but the bands change 
direction, it shows the surfaces are tangent continuous (smooth) 
but have a discontinuity in curvature. 

 
 The bands join, but there is a change in direction. 

When surfaces do not meet smoothly (with tangent continuity), you 
will see bands similar to the following. 
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 This area shows that the surfaces are not smoothly joined. 

Surfaces which join with tangent and curvature continuity show 
bands similar to the following: 

 
The colours of the bands shown are shades of colour of the default 
material for surfaces. If you change the colour of the material of the 
surface, the colours of the bands change too. 

For further details, see Format > Materials (see page 32). 
 

Tools > Model Analysis > Undercut Shading 
This lets you check if a mold design has any undercut 
areas.Undercut areas show where it would be difficult to separate 
the part from the mold. 

By using Undercut Shading, you can help reduce costs because you 
can check the model for any areas of undercut before 
manufacturing the model. If any areas of undercut are found, the 
surfaces can be adjusted to remove them. 

Undercut shading visualises the draft angle at all points on the 
surface. The draft angle is measured between the surface normal 
and the split plane. The split plane is the XY plane of the current 
workspace. 

Suppose we have the following mold design. 
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We will now use Undercut Shading to show areas where it will be 
difficult or impossible to extract our mold tool. 

1 Set the required minimum draft angle using the Draft Angle text 
box on the Surface Analysis page of the Options dialog. 

The Options dialog is displayed by choosing Options from the 
Tools menu. 

2 From the Tools menu, select Model Analysis to show the shading 
options. 

3 Click on Undercut Shading. 

The model is now shaded in three colours to show areas of 
undercut: 

Red - This warns you that the area will be undercut, because the 
draft angle on the model is less than the required minimum 
angle. 

Yellow - This warns you of possible undercutting, because the 
draft angle is greater than, but within a given warning angle of, 
the required minimum angle. You can set the warning angle on 
the Surface Analysis options (see page 128) dialog. 

Green - This area is well clear of undercutting. 

Our mold is shaded as follows. 

 
We need to adjust the surfaces in the red  (and possibly yellow 

) areas to avoid undercutting. 
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Tools > Model Analysis > Curvature Shading 
Curvature shading displays the curvature of a surface to help detect 
any defects. It can also help decide the optimum tool cutter size. 
Curvature shading can be considered as a form of surface 
inspection. It allows you to check the surface of a model in a 
number of ways. These include: 

 highlighting surface ripples. 

 showing the smoothness of the surface. 

 showing how surfaces blend with one another. 

This type of shading helps when designing products that need to 
have an aesthetic appearance. The shading indicates the level of 
curvature of the surface and whether the surfaces merge well with 
one another. 

 

1 Select Model Analysis  on the General edits  flyout. 

2 Click  (Model Analysis toolbar). This is the same as selecting 
Tools > Model Analysis > Curvature Shading. 
The surfaces in the model are painted using curvature shading, 
different colours are used to represent the different curvature on 
the surfaces. 

Curvature at a point on a curve is defined as: 

Curvature = 1/r 
where r is the radius of the arc which fits the curve at that point. 
Radius r is also known as the radius of curvature. 
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Curvature maps can be hard to interpret, and it is usually the 
case that the variations in curvature rather than absolute values 
are of more interest when viewing a curvature shaded surface. 
Irregular variations in curvature tend to indicate poor quality 
surfaces. 

Curvature of a point on a surface is obtained by intersecting the 
surface with a plane through the point to give a planar curve. 
The curvature of the point is then taken as the curvature of the 
point on the planar curve. At any point, an infinite number of 
planes can intersect the surface, therefore giving an infinite 
number of curvatures. So for each point, there will be a 
maximum and minimum curvature. These values are used for the 
curvature. 

3 Specify the display using Options dialog. Select Tools > Options > 
Tools > Analysis > Surface Analysis to display the following 
options. 

Type - This sets the type of curvature displayed. You can choose 
from one of the following: 

 Minimum curvature - This is the minimum curvature at a point. 

 Maximum curvature - This is the maximum curvature at a 
point. 

 Gaussian curvature - This is the product of the minimum and 
maximum curvatures. 

 Mean curvature - This is the average value of the minimum 
and maximum curvatures. 

Representation Type - This controls the representation of the 
curvature. You can choose from one of the following: 

 Banded - The curvature at each point is represented by a 
colour in a spectrum. The colours are in bands. 

 Spectrum - The curvature at each point is represented by a 
colour in a spectrum. The colours change smoothly. 

 Bicolour - This shows the positive and negative curvature 
using two colours, regardless of whether Signed Curvature is 
selected. The colour gets lighter as the magnitude of the 
curvature get higher. 
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In Banded and Spectrum shading, only the magnitude of the 
curvature is shown (unless the Signed Curvature option is 
selected). The maximum magnitude shown will be the larger 
of the absolute values of the minimum and maximum 
curvatures. The minimum magnitude shown will be the 
smaller of the absolute values of the minimum and maximum 
curvatures. The mean magnitude shown will be the mean of 
the absolute values of the minimum and maximum 
curvatures. 

Scaling - Select Log or Linear. With a linear curvature scale you 
would see a change in the colour of the shading more clearly if 
the curvature of a surface changed suddenly. To see a wider 
range of curvatures on the surface of a model, use the 
logarithmic curvature scale. 

Draw Scale - If selected, a colour-coded key is displayed in the 
lower left of the view. 

Signed Curvature - If selected, the negative and positive 
curvature is displayed. If deselected, then only the magnitude of 
curvature is considered, and the sign is ignored. 

 

Tools > Model Analysis > Minimum Radius Shading 
This shading lets you specify a radius for a tool, The model is then 
compared with the tool size and areas where the model would be 
machined to size or where material would be left are highlighted. 

Suppose we have the following model on the screen. 

 
We will shade it using Minimum Radius Shading to show any areas 
where material would be left on. 

1 Specify the Cutter Tip Radius of the tool you want to use to check 
the model using the Surface Analysis page of the Options dialog. 
(The Options dialog is displayed by choosing Options from the 
Tools menu.) 
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2 Click  (Tools flyout) 

3 Click  (Model Analysis toolbar). This is the same as selecting 
Minimum Radius Shading from the Model Analysis of the Tools 
menu. 

 
The model is now shaded to show areas that can be machined to 
size and any areas where material would be left on. Each colour 
of the shading is discussed below. 

 Red - This shows areas where the concave radius is less than the 
cutter radius. Machining here leaves material on. However if you 
decide to machine the model from the underside then these 
areas will be machined to size. 

 Green - This shows areas where the convex radius is less than 
the tool radius. These areas will be machined to size. However, if 
you decide to machine the model from the underside (for 
example, machine a cavity as opposed to a punch) these areas 
will leave material on. 

 White - These areas will machine to size. 
 

Tools > Model Analysis > Thickness Shading 
Use this option to apply thickness shading to your model. Thickness 
shading enables you to visualise the thickness of solids. This is 
useful for identifying thin regions of a model. 
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The thickness is measured by a ball that is placed inside the solid 
and made as large as possible without passing through any of the 
surfaces. As this ball rolls around inside the solid it grows or shrinks 
as appropriate in order to fill the available space. The front face of 
the model below has been cut away to show the measuring ball 
rolling around inside. 

 
The colour displayed at each point on the surface of the solid 
represents the diameter of the ball when it was touching that point. 

 

Using Thickness Shading 
1 Make sure you have the relevant solid selected. 

2 Click  (Tools flyout) 

3 Click  (Model Analysis toolbar) 

This is equivalent to selecting Thickness shading from Model 
Analysis option of the Tools menu. 

There will be a pause whilst the thicknesses are calculated; the 
length of time taken will depend on the size of the model. 

4 Use the Thickness Colour Scale dialog (see page 56) to 
dynamically rescale the colour thickness display. 
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Thickness Colour Scale dialog 
Use this dialog to dynamically rescale the colour thickness display 

 
Maximum thickness — Regions of the model that are thicker than the 
value shown in this box are displayed in blue. Adjusting this value 
by using the slider will be reflected in the colouring of the model. 

Minimum thickness — Regions of the model that are thinner than the 
value shown in this box are displayed in red. Adjusting this value by 
using the slider will be reflected in the colouring of the model. 

Intermediate thicknesses are represented according to the colour 
scale in the dialog. 

Make Sections — You can create dynamic wireframe sections of the 
areas of the model. 

Before creating the sections, ensure that you have the relevant 
plane defined. The plane through which the sections are created will 
be either the active workplane (if selected), or the plane of the 
graphics window when you click Make Sections. 
Selecting Make Sections displays the Section dialog (see page 43). 
The position of the section can be varied using the slider on the 
dialog. In the example on the right, the slider was set at 50%.  

 
 

Tools > Model Analysis > Solid wall thickness 
Use this option to find the wall thickness of a hollow solid. 
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This displays the Wall thickness dialog so you can define a series of 
sections relative to the active workplane. 

For further details see Wall thickness dialog. 
 

Tools > Model Analysis > Model Compare 
Use this option to compare two models and select the differences in 
one of the models. 

For further details see Comparing two models. 
 

Tools > Model Analysis > Model Visual Difference 
Model Visual Difference is a tool that gives a visual representation of 
the differences between two versions of a model. It considers 
surfaces and solids and also symbols created by importing triangle 
files 

The visual differences are worked out using the total shape of the 
two models and do not depend on how the shapes are constructed. 
This can be shown by creating the two models below. 

 
The first model is a single solid cylinder. The second model was 
constructed by joining two solids to create a cylinder of the same 
size. If you use Model Visual Difference on these models, no 
difference is detected. 

For further details, see Using Model Visual Difference (see page 58). 
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Using Model Visual Difference 
1 Create the model below. Save the model as model-visual-diff. 

 
2 Copy the model into a new model. Save this model as model-

visual-diff2. 
3 On the second model,  

 Delete the fillet indicated below. 

 
 Increase the size of the hole to 15. 

4 Select Model Visual Difference  from the Model Analysis 
toolbar. 

The Model Visual Difference dialog is displayed: 
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5 Select the Name of old model from the drop down list. 

6 Select the Name of new model from the drop down list. 

7 Click OK. 

The Visual Difference window is displayed. This window shows the 
differences between the models. Although you can navigate 
around the window, you cannot select anything in it and any 
change that you make to the models at this point are not 
reflected in existing Visual Difference window.  

 If you modify either model and want to get a new view of the 
difference, you must create another Visual Difference window. 
There can only be one Visual Difference window, so creating a 
new window will destroy the old window. 

1 Rotate the model in this window until your model looks like the 
one below. 

 
You will notice the following: 

 The area from where the fillet was removed is shown in blue. 
This indicates that material has been added to the model. 

 The change in the size of the hole is shown in red. This 
indicates that material has been removed from the model. 

These colours are the default colours for addition and removal of 
material. You can change the default settings using the Options 
page. For full details, see Model Visual Difference options (see 
page 127). 

 

Tools > Model Analysis > Comparison Analysis 
(available with PowerSHAPEPro licence only) 
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Use Comparison Analysis to find differences between any two 
objects, using the Comparison Analysis dialog (see page 60). The 
functionality is also available from the Model Analysis toolbar, but 
the button is only displayed if you have a PowerSHAPE Pro licence. 

 

Comparison Analysis dialog 

1 Select the Model Analysis  button from the Editing and 
Analysis flyout to display the Model Analysis toolbar. 

 

2 Click the Comparison Analysis  button to display the 
Comparison Analysis dialog. 

 You must have a PowerSHAPE Pro licence. 

 
3 Select the first item to compare against (source item). 

4 Select the second item to compare to (target item). 
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5 Click Calculate. 

The differences between the objects are shown as an error map. 

 
6 Use the options on the dialog as follows: 

 Click the Statistics  button to display the deviation 
statistics.  

 

 Click the Export  button to export differences to using the 
Export To dialog: 

You can export differences between objects to ASCII text file 
or STL file. 

 Click the Options  button to change the comparison 
analysis options (see page 64). 

 Click the Curve Deviations  button to display the curve 
deviations (see page 62). The option is deselected by default. 

 Use the Line scale slider or enter a value in the field to define 
the curve deviation line widths. This option is only available if 
you have clicked the Curve Deviations button. 

 Click the Shade   buttons to toggle shading on or off. 
The model below shows: 

 Difference shading off. 
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 Difference shading on. 

 
 

Display curve deviations 
1 Select one of the following: 

 curves dependent on an object 

 curves and the object 

 

2 Click the Comparison Analysis  button to display the 
Comparison Analysis dialog. 

 You must have a PowerSHAPE Pro licence. 
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3 Click the Curve Deviations  button to display the deviations. 

 
4 Use the Line scale slider or enter a value in the field to define the 

width of the curve deviation lines. 

 This option is only available if you have clicked the Curve 
Deviations button. 

5 Click the Curve Deviations button again to hide the curve 
deviation lines. 
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Comparison Analysis options 
Use this page to specify the parameters to be used in Comparison 
Analysis. 

 
 Display legend — Select this option to show or hide the error 

legend in the graphics window. 

 Always display errors — Select this option to automatically show 
or hide deviations after they have been calculated. 

 Display error under cursor — Select this option to show or hide 
the numerical deviation beneath the cursor when you hover your 
cursor over the comparison. 

 Colour bands — Select an option from the list to change how the 
deviations are displayed on the model: 

Continuous — The deviations are displayed using a continuous 
scale. 

Two — The deviations are displayed using two distinct colours. 
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Three — The deviations are displayed using three distinct 
colours. 

Five — The deviations are displayed using five distinct colours. 

Ten — The deviations are displayed using ten distinct colours. 

Twenty — The deviations are displayed using twenty distinct 
colours. 

Forty — The deviations are displayed using forty distinct 
colours. 

 Colour bands is not available if Display errors to tolerance is 
selected. 

 Width of error lines — Enter a value to define the width of the 
error bands shown on the model when curve deviations are 
displayed. 

 Display errors to tolerance — Select this option to display the 
deviations in two or three colour bands. The bands are set 
according to the general tolerance. 

This option is deselected by default. 

If Display errors to tolerance is deselected, select the required 
number of Colour bands from the list.  
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 Display absolute range — Select this option to display the 
absolute (modulus) values of deviation. That is the range of 
errors from 0 to the maximum value. 

 
 Set maximum value to maximum error — Select this option to set 

the maximum value of the error range to the largest deviation. 

 Maximum value of error range — Enter a value into the field to 
define the maximum value of the error range. In the following 
example : 

 Maximum value of error range is set 1. 

 Colour bands are Continuous. 

 

 This option is unavailable if Set maximum value to maximum 
error is selected. 
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 Sample Point Density — Use the slider to control the number 
density of points used to calculate differences between your 
models. A larger Sample Point Density produces more accurate 
results, with a longer computation time. A smaller Sample Point 
Density produces less accurate results, with a shorter 
computation time. 

 

Tools > Selection information 
Use this option to open the Selection Information dialog, which 
displays information about selected objects. You can find out the 
number of items in a selection by hovering the mouse over the 
Select flyout to display the tooltip. 

1 Select one or more objects. 

2 Click  (Selection flyout) or select Tools > Selection Information. 

If a single object is selected, then information about that object 
is displayed in the Selection Information dialog (see page 68). 
The information is also displayed in the Command window. 
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Selection information dialog 
Use this dialog to display information about the objects that are 
selected.  

 
As well as basic information about the selection, the following 
information will be displayed (where appropriate): 

 If the object is a surface, further detailed information will be 
given about any sub-selection (such as curves or p-points). 

 If a group of objects is selected, the dialog tells you how many 
objects are selected and the type and name of each object. You 
can find out the number of items in a selection by hovering the 
mouse over the Select flyout to display the tooltip.  

 The Size of the bounding box containing the objects, and the 
minimum and maximum coordinates of the bounding box. 

 Any selected that is badly trimmed. 

 The centre of gravity for a multiple selection of components. 

The following buttons allow you to see additional information: 

 Toggle detailed information. When a single solid is selected, the 
names of the currently selected solid faces and features is displayed 

 Toggle sub item information. 

 Toggle centre of gravity. 

 Toggle moment of inertia. 
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 Toggle the display of the area of the selection.  

 Toggle the display of the volume of the selection.to display the 
volume of the selection. 

Update — You can change the selection of objects and click Update. 
This updates the information to the new selection. 

Box — This displays a bounding box around the current selection. If 
a bounding box is already displayed, it undraws. You can create the 
bounding box around the current selection using the Selection box 
option on the line creation menu. 

 
OK — Close the dialog. If a bounding box has been drawn, this is 
removed.  

 Use the Selection information context menu to copy, print or 
save the information displayed in the dialog. 

 

Tools > Component Drawings 
Use this option to create component drawings for standard and non-
standard components using a template. 

For further details, see Creating components drawings. 
 

Tools > Create Titleblock 
Use this option to add a title block to a drawing. 

For further details, see Creating a title block on a drawing. 
 

Tools > Create Movie 
Use this option to create an .avi file that represents a 360  
rotational view of the objects you have selected. If nothing is 
selected, the movie is created using everything in the graphics 
window. 
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To create a movie: 
1 Select Create movie from the Tools menu. 

2 Use the options on the Movie Creation (see page 70) dialog to set 
options that control options such as the frame rate, axes of 
rotation and movie duration. You can also choose to view the 
object from different angles. 

 

Movie Creation dialog 
Use this dialog to adjust the options associated with creating a 
movie. 

 
1 Use the options in the Axes of rotation section of the dialog to 

define the axes and angle of rotation as follows: 

a Select the required axes of rotation (any combination of X, Y, 
Z). 

b For each selected axis, the default angle of rotation is 360 . 
Enter a different angle if required. 

c Set the sequence of the selected axes using  and  

d select Split rotation to half the value entered as the angle of 
rotation and rotate the model by that amount in the positive 
direction and the negative direction.  

For example, if you enter 120  as the rotation angle and this 
option is ON, the model will be rotated 60  in the positive 
direction and 60  in the negative direction. 

2 Select the Rotate about option to define the point of rotation: 

Centre rotates around the centre of the bounding box enclosing 
all the selected objects. 
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Origin rotate about the origin of the active workplane.  

3 Use the slider to specify the number of Frames per second. 
Alternatively, enter a value. The higher the number, the better 
the quality of the movie, but the longer it takes to create the 
movie. A rate of 25 provides a good balance between quality and 
creation time. 

4 Enter the Movie duration in seconds. 

5 Enter the Destination for the saved .avi file or click  to open the 
Browse for folder dialog. 

6 Enter the Movie name. The default name is the name of the 
model. 

7 Click OK to create the movie using the values entered in the 
dialog. If no values have been entered, default values will be 
used. 

 

Tools > Login 
This option lets another user log in to the program without closing 
the application. If any models are open, you are prompted to save 
and close them. 

1 From the Tools menu, select Login to display the Login dialog. 

2 Fill in the Login dialog (see page 71).This dialog also appears 
when you start the program if you are not a registered user or 
need to enter a password. 

 

Login dialog 
This dialog is used to log in. 

 
Login name — Type in your username. 

Password — Type in your password. 

OK — Start the program. The username and password you have 
entered are checked. If the username and password do not match, 
you are prompted. Type in your Login Name and Password again. If, 
after six attempts, you still cannot provide a valid username and 
password, the login is automatically aborted. 
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Tools > Preview Mode 
This option lets you use functionality that is still under development 
and not released. 

You can only preview functionality if you have security levels 1 and 
2. Usually, system administrators have security level 1 and design 
office managers have security level 2. 

 Warning: Be careful when using the additional functionality 
that is available in preview mode. This is functionality that is 
under development. 

 

Tools > Release Licences 
This allows you to release licences. 

A floating licence system is used, so licences for particular areas of 
functionality (for example, Drafting) are “grabbed” by the user 
when needed. 

Release licences allows you to "free-up" a licence when finished with 
it. The functionality covered by the licence is then available for 
another user. This allows a network of users to share a (relatively) 
small number of licences. 

When you have finished with a licence, select Release licences from 
the Tools menu. 

After a short delay, the licence will be free for others to use. 

 Licences are released when the program closes. 
 

Tools > Vouchers > Manage account 
If you are are importing from or exporting from PowerSHAPE-e, use 
this option to manage your voucher account. 

 

Tools > File Doctor 
Use this option to check and repair model files and the shared 
database. 

 File Doctor contains powerful tools. If it is used incorrectly, 
serious damage can be caused to your model or to your 
shared database. Consult Delcam Customer Support before 
using File Doctor on the shared database and always make a 
Full system backup before proceeding. Ensure you have back-
up copies or duplicate models before using File Doctor on 
models. 
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For further details, see File Doctor. 
 

Tools > Compress Model 
This lets you manually compress a model and can free disk space. 
This option compresses the space used by surface data and frees 
space allocated to deleted objects. It is useful if your model 
contains many surfaces or you have deleted many objects from the 
model. 

By default, a model is automatically compressed when it is closed. If 
you wish to turn off automatic compression, the Compress on close 
on the Tools > Options > File > Model dialog (see page 91) needs to 
be OFF. 

1 Open the model with write access. 

2 Make sure there are no unsaved edits. 

3 From the Tools menu, select Compress Model.  
4 Once the model is compressed, a dialog appears. 

 
This dialog gives the percentage of compression in terms of the 
reduction in size of the model after compressing the space used 
by surface data. The percentage does not include freed disk 
space, that was allocated to deleted objects.  

The value for maximum compression is set in the Tools > Options 
> File > Model options dialog 

 

Tools > Customise 
Use the options on this submenu to customise toolbars, menu 
shortcuts, and file paths. 

1 From the Tools menu, select Customise Toolbar to display the 
following menu: 

 
2 Select the option you require: 

 Toolbar (see page 74). 

 Paths (see page 74). 
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Tools > Customise > Toolbar 
Use this option to create user-defined toolbars and menu shortcuts 
using the Customise dialog. 

For further details see: 

 Customise dialog - toolbars (see page 189). 

 Customising menu shortcuts (see page 180). 
 

Tools > Customise > Paths 
Use this option to customise the default locations where 
PowerSHAPE looks for additional configuration files, and add your 
own locations using the Customise Paths dialog (see page 74). 

 

Customise Paths dialog 
Customise Paths enables you to define the search paths that are 
used to find custom toolbars, bill of materials and schedules, 
shortcuts, macros, models, and electrodes. 

Use this dialog to add, delete, and re-order the pathnames that are 
searched for within each type. 

 
Use the following options on the dialog to customise the paths: 

Path List — Select the type of path. 

 Add Path to Top of List — Click to add a new path to the top of 
the path list. 

 Add Path to Bottom of List — Click to add a new path to the 
bottom of the path list. 

 Edit selected path — Click to edit the path name. 

 Delete — Click to delete the selected path from the path list. 
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 Move Up — Click to move the selected path up the path list. 

 Move Down — Click to move the selected path down the path 
list. 

 

Tools > Options 
The Options dialog enables you to set the options that affect the 
overall operation of the program. 

 
The Options dialog contain many options that you can select and 
adjust to suit your needs. 

Use the tree (on the left of the dialog), to select a page. You can 
expand and collapse branches of the tree by clicking the  and  
icons. Each branch of the tree has a separate page. 

The OK, Cancel, and Help buttons are common to all pages. 



 

76 • Menus PowerSHAPE 2015 R2 Reference Help  

OK — Click this button to apply the settings and close the dialog. 
The current model and any new model you create use these 
settings. Existing models use the settings that were saved with 
the model. 

Cancel — Click this button to close the dialog without saving any 
changes. 

 The Undo command does not undo settings of the options on 
the Options dialog. 

 

General options 
The following options pages are grouped under the General 
category: 

 Help (see page 77) 

 General Edits (see page 78) 

 Mouse (see page 80) 

 Keyboard (see page 82) 

 Properties (see page 83) 

 Toolbars (see page 86) 

 Arm (see page 87) 

 Units and Tolerances (see page 88) 
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Help options 
Specify the help options using the Help dialog. 

 
Floating HTML Help — If on, the help is displayed in a separate 
floating window. If off, the help is displayed in the browser window 
in PowerSHAPE. 

Always show help on top — (Only available if Floating HTML Help is 
on) If on, the floating window is displayed in front of the 
PowerSHAPE window. If off, the floating window can be hidden 
behind the PowerSHAPE window. 

Display help — If on, help tips are displayed when you hover the 
cursor over items on the user interface. 

Automatic Check for Updates on the Internet 
Check for updates once a month — If on, a check is made on 
updates.delcam.com each month. The date of the check for 
updates will be based on the date of the installation of the 
PowerSHAPE release. 

When the relevant date is reached, 

 You receive a message that the Delcam website will be 
accessed to look for updates. 

 A check is made on your entitlement to updates, based on 
system security information. 
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 The list of updates to which you are entitled is displayed. Only 
the updates that have been issued since your current version 
are available to you. 

If you prefer, leave this option unchecked and do a manual check 
for updates by selecting Check for Updates on the internet from the 
Help menu. 

Check for updates on start up - If ON, a check is made on the 
Delcam website for any available updates every time you start 
the product. 

Restore Messages — This option will allow messages to be displayed 
that have previously been suppressed by clicking on the Do not 
show this message again option in a dialog. 

 

General Edits options 
Use this options page to specify how to handle dependencies and 
parameters when copying items. 

1 Select Tools > Options > General > General Edits. 

 
2 Specify the Copy dependencies and Create copy of parameters 

options: 

 Copy dependencies — If selected, associated dependencies are 
copied when copying items. If deselected, associated 
dependencies are not copied when copying items. 
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 Create copies of parameters — If selected, a copy of the 
parameters is used when dependencies are copied. If 
deselected, existing parameters are used when dependencies 
are copied. This option is only available when Copy 
dependencies is selected. 

3 Use Create solid transform features to specify if transform features 
will be created when using Move, Mirror or Rotate when one or 
more solids are selected. 

 If selected (default), transform features will be created when 
using Move, Mirror or Rotate if one or more solids are selected. 

If Copies are not created, the new transform feature appears 
at the top of the solid's history tree; a history tree is created if 
the solid has no existing history tree.  

If Copies are created, the original solids are left unchanged; 
the new solids have history trees with transform features at 
the top. 

 If deselected, transform features are not created. 

4 Use Automatically merge transform features to mergeadjacent 
transform features automatically. This option is selected as 
default. 

5 Use Show a preview of transformed items to control the way 
transformed items are displayed. This option is selected by 
default. 

When the option is selected: 

  and  buttons are displayed on the editing toolbars. 

 a graphical preview of the transformed items is displayed. 

When the option is deselected: 

  and  are not displayed on the editing toolbars. 

 no graphical previews are displayed. 

 the transform is applied immediately when the user inputs a 
value or a point.  

 



 

80 • Menus PowerSHAPE 2015 R2 Reference Help  

Mouse options 
This controls the mouse defaults. 

 

Mouse Click 
Hit Radius — This is the region (in pixels) around the cursor that 
recognises when the cursor has hit an object. Setting it to zero 
means you have to accurately hit the object before you can 
select it. Setting it to a high value makes it easier to hit an 
object. However, on complex models, you may have to zoom 
more often to avoid selecting the wrong object. 

Intelligent Cursor 
Active — Select this option to turn the Intelligent Cursor ON 
(default). The Intelligent Cursor provides dynamic assistance 
when you are selecting existing objects and/or positioning new 
objects. When active, PowerSHAPE highlights objects and snap 
points, and generates temporary construction lines as the cursor 
moves over the model. The Intelligent Cursor also: 

 finds intersections between wireframe items and a surface or 
solid. 

 snaps to the projected intersection of wireframe items and 
surfaces. 
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Show Construction Distances — This is only available when the 
Intelligent Cursor is active. It provides stepped graduations along 
objects such as lines and arcs to which the cursor can snap. It 
displays a dimensional value which changes as the cursor moves 
along objects. You can then snap to the displayed dimension. 

The units change according to the zoom level. Zoom in to see 
finer graduations. Zoom out for more coarse graduations. 

Shaded highlighting — If ON, a shaded object is highlighted when 
you move the cursor over it. If OFF, a shaded object is never 
highlighted. 

Fast rubber-banding — Use this to switch between faster rubber-
banding and higher quality graphics. Deselect this option to 
improve the rubber-band graphics and use the correct 
construction colours. 

Background Grid — If ON, an invisible grid is used to round any 
points that are entered using the cursor. The amount that a 
position is rounded depends on the scale of the view. If this is 
unchecked, the position of the point is not rounded. 

Edge picking — If ON, you can select edges of surfaces, solids 
and wireframe. The edges can then be used instead of a 
composite curve for creation and editing. This option is ON by 
default. 

Drag Move — This allows you to select and move an object. If ON, 
you can move an object to a new position by dragging it with the 
cursor. If OFF, you can select an object but not move it. This is 
useful when dealing with complex models where you do not want to 
accidentally move objects when selecting them.  

Show Next Selection — This option is used to aid selection of objects 
that intersect. This displays a dialog showing the name of each 
selectable object in the model that intersects with the currently 
selected object.  

In the example below, there are two possible surfaces that can be 
selected when an intersection point is selected. 

 
When you hover over the option, the corresponding item is 
highlighted. Select the required surface from the list. If no selection 
is made, the selection options are removed from the screen. 
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A variant of this, the Next Selection option, is displayed on context 
menus and is available on the Select options of the Edit menu. 
Choosing this option does not immediately display the dialog, but 
automatically selects the next item in the selection list and then 
displays the dialog. The shortcut Alt+N also activates Next Selection. 

See Also 
Turning the Intelligent cursor on or off . 

 

Keyboard options 
This page contains the options that are related to the behaviour of 
functionality controlled by the keyboard: 

 Options related to using the up arrow  and down arrow  keys. 

 The Zoom factor for the Tab key. 
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Properties 
Specify various settings associated with operation and appearance 
of PowerSHAPE using the Properties dialog. 

 

Save Time Warning 
At regular intervals, a warning can be displayed to tell you when 
you last saved a model. You can set the time interval or turn off the 
warning. 

Warning time delay — This defines the time interval in minutes for 
displaying the warning. 

Warning required — If deselected, the warning is not displayed. 

Long Operation Alert 
PowerSHAPE beeps when long operations finish. 

Long operation time delay — This defines the time in seconds that 
PowerSHAPE must be busy before the operation is classed as long. 
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Alert required — If deselected, the beep is turned off. 

When PowerSHAPE is busy, an hourglass appears at the bottom of 
the screen. 

Appearance 
Colour scheme — The selector contains a list of colour schemes 
provided. Select a colour scheme from the drop down list and press 
Set Colour Scheme as Default. This will save the scheme as your 
chosen default and this scheme will be used each time PowerSHAPE 
is started. You can set up your own colour scheme.   

Proportional font — This font is used by the intelligent cursor. It is 
also the default font for creating text and for text in balloons. 

Fixed width font — This font is used by scrolled texts in dialogs such 
as the Information dialog. 

IC font height — This is the height of the font used by the intelligent 
cursor. 

Set Colour Scheme as Default — When you select this option, the 
selected Colour Scheme is stored as the default and will be used 
each time PowerSHAPE is started. 

Session Options 
You can store the settings on the pages of the Options dialog and 
use them in the next session. 

Restart with default options — When you restart the program, the 
default values of the settings are used. 

Restart with current options — When you exit the program, it 
remembers the latest settings on the Options dialog. When you 
restart the program, it will use those settings again. 

Restart with stored options — When you exit the program, it will use 
your stored settings. 

Store restart options — This stores the current settings on the 
Options dialog. Store the settings as follows: 

1 Set the options on all the pages of the Options dialog. 

2 Select Restart with stored options. 
3 Select Store restart options. This option is automatically 

deselected after you click the OK button. 

4 Click OK. 

All the settings on the Options dialog are stored and will be used 
in the next session (providing Restart with stored options is turned 
selected). 

The settings that are stored will apply to either: 



 

PowerSHAPE 2015 R2 Reference Help Menus • 85  

 a model 

 a session 

as defined in Show difference between user and model (Options > 
General > Units and Tolerances). This option changes the font to 
indicate if the setting applies to a model or session. 

Template models can be used to store the model options. 

Reset / Load / Save — These buttons let you: 

 Reset the options to the state when PowerSHAPE was started. 

 Load a previously saved options file. 

 Save the options file. 

Query before starting multiple instances — If this option is selected 
and you try to startup another copy of the program, you will get a 
message displayed. 

 Session options are stored for each product variant, so you 
can have different options for PowerSHAPE, Partmaker 
Modeling, and Dental. 
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Toolbars options 
Use this dialog to specify the toolbars options. 

 

Buttons 
Choose the size of buttons to be used on the toolbars. 

Large buttons — Select this option to use large buttons on toolbars. 
Deselect it to use small buttons. 

Toolbar Management 
Automatically display/hide toolbars — If ON, the Dimension,Text and 
Surface/Curve toolbars display automatically when a corresponding 
object is selected and hide automatically when the object is 
deselected. If OFF, the Dimension,Text and Surface/Curve toolbars 
display automatically when a corresponding object is selected, but 
stay displayed once the corresponding object is deselected. 

Manage toolbars — You can manage the position of the toolbars by 
selecting and deselecting this option.  



 

PowerSHAPE 2015 R2 Reference Help Menus • 87  

If ON, toolbars are automatically positioned when you start the 
program. The toolbars will always appear in a standard order 
when docked and cannot be moved. You can float toolbars and 
dock them on another side of the screen. In practice, this still 
gives you some control over the toolbar layout but prevents 
accidental movement of toolbars and makes re-docking of floated 
toolbars easy (they will always re-dock in their correct position). 

If OFF, the toolbars can be positioned anywhere. 

Views and Creation Toolbars Positions 
The options in this section let you select the positioning of your 
toolbars. 

Default — Position the creation toolbar on the left and the views 
toolbar on the right. 

Reversed — Position the views toolbar on the left and the creation 
toolbar on the right. 

 

Arm options 
This dialog lets you set the defaults for using the Acquire Points (see 
page 201) toolbar. 

 
Auto commit sweeps — Sweeps are saved automatically when the 
number of points taken exceeds the number specified in the box. 
The clouds can be combined after all points have been acquired. 
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Assign unique colour to each sweep — Each sweep is assigned a 

unique colour. This is the same as clicking  on the Acquire 
Points toolbar. 

Keep part visible while scanning — The acquired points remain visible 
whilst you carry out further scanning. 

Show real-time scan information dialog — The Sweep Information 
dialog is displayed when the Acquire Points toolbar is displayed. This 

is the same as clicking  on the Acquire Points toolbar. 

Filter points as they are acquired — Filter points during scanning. 
Enter a value for Distance between points. This distance is used to 
remove points that lie within a specified distance of another point. 

 The distance is specified in the units that are defined in Tools 
> Options> General > Units and Tolerances. 

 

Units and tolerances options 
Define the length and angle units and the tolerance defaults for the 
active model using the Units and Tolerances dialog. 
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Standard — This list shows the standard used for the active model. 
You can select one of the following standards: 

 ANSI 

 BDC 

 BSI 

 DIN 

 ISO 

 JITS 

 USDD 

All models contain standard information. The System Administrator 
sets up the default for a particular installation. This controls the 
standard used by all new models. 

To change the drawing standards for all models, see Changing the 
drawing standard 

Length — Select the length units for the active model. The options 
are: 

 mm (millimetres) 

 inches 

 thousandths (0.001 inches). 

Angle — Select the angle units for the active model. The options 
are: 

 degrees 

 minutes 

 seconds 

 radians 

Volume — Select the volume units for the active model. The options 
are: 

 centilitres 

 litres 

 mm3 

 cm3 

 m3 

 gallons (UK) 

 gallons (US, liquid) 

 gallons (US, dry) 

 ounces (UK, liquid) 
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 ounces (US, liquid) 

 cubic inch 

General tolerance — Select the default tolerance that affects all 
constructions which do not have a specific tolerance.  This tolerance 
is also displayed in the Tol text box on the Status bar. 

Drawing tolerance - This allows you to change the tolerance used for 
drawing objects. When you draw an object, this tolerance allows 
you to change how smoothly it is drawn. 

 
 Drawing tolerance = 0.1 

 Drawing tolerance = 10 

Trim Region Editing Tolerances 
Angular tolerance - This tolerance is used when surfaces are 
trimmed. 

Surface Discontinuity Tolerances 
Angular tolerance - This tolerance is used to decide if a surface 
contains any discontinuities in the normal direction. This tolerance is 
compared with the angle between two normals at a point on a 
surface . 

 
If the angle is greater than the angular tolerance, then the surface 
is discontinuous at that point. 

Show difference between user and model options - If selected: 

 Options that apply to all models are shown in italics. 

 Options that apply to the current model only are shown in the 
standard font. 
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If deselected, all options are displayed in the standard font to make 
them easier to read. 

 

File options 
The following options pages are grouped under the File category: 

 Model (see page 91) 

 Print (see page 94) 

 Plotting (see page 95) 

 Filters (see page 96) 
 

Model options 
Use this dialog to specify model options.  
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Model Compression 
Compress on close — If selected, a model is compressed when 
the model is closed after saving. 

Compression limit (%) — The model will reduce in size by at least 
the percentage entered. For example if 25% is entered, models 
will only be compressed if they reduce in size by 25% or more. 

Autosave 
Set the Time between autosaves (minutes) to regularly save 
Parasolid (post-version 8) models. This allows model recovery up 
to the point of the last autosave.  

The default setting is 5 minutes.  

 The autosave will only occur while you are creating or 
editing geometry. It will not occur if PowerSHAPE is idle for 
5 minutes. 

Delete Models 
Use recycle bin — If selected, deleted models are sent to the 
recycle bin (providing the bin is not full). Otherwise, the models 
are permanently removed from the system. 

Thumbnail Save Mode 
This allows you to choose when the thumbnail is saved. 

Automatic — A thumbnail is automatically saved when the model 
is saved. 

Manual — This allows you to decide when you want to save the 
thumbnail.  

Model Location 
Always save and open from outside the database — If selected, the 
Save and Open commands will save and open models outside the 
model database and use the standard Windows dialogs. 

Search paths for models - This window displays the list of paths 
that are searched for models. You can change the search list by 
using the associated buttons. 

Use first model path as default model path — Select this option to 
set the default model location to the first entry in the list of 
model paths. 

 If the option is selected, open and save operations use the 
first model path as the default location. If the model path list 
is empty, the default location is set to the current directory. 
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 If this option is deselected, the default path is specified in the 
Start in option on the PowerSHAPE shortcut 

 — Add a new path to Search paths for component libraries. 
Clicking this displays the Browse For Folder dialog. Select the 
path to add to the list of search paths. 

 — Removes selected path from Search Paths for Models. 

 — Move selected path up in search order. 

 — Move selected path down in search order. 

You can replace a selected path by double-clicking on a path in 
the window and selecting a replacement path from the Browse for 
Folder dialog 

Model Export 
Restrict export by password — If selected, a password is required 
to export the model. 

Most Recently Used Files 
Number of files in menu — Enter the quantity of recently opened 
models to be listed at the bottom of the File menu in Recent Files. 
The default is 4 and the maximum number of files in the list is 20. 
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See Also 

Saving a model with a thumbnail 

Recent Files (see page 21) 

Print options 
Use this option to select the printing options. 

 
1 Click Tools > Options > File > Print. 
2 Select the printing of workplanes in the model window. 

3 Select the printing of drawing window. 
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Plotting options 
This option lets you set the plotting options for the File > Print 
command. 

 
Plotting Options — Each printer is assigned a set of plotter pens, 
which are only considered when plotting to the printer. Plotting 
options allow you to set up the pens to your requirements. Each pen 
has a Width, a Colour and a status flag. The status flag indicates 
whether a pen is Active or not. At least one pen must be active at 
all times. 
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Filters options 
This allows you to set the filters used in such commands as File > 
Open. 

 

Wildcard Characters 
This sets the defaults used by the filter controls in commands such 
as File > Open. Filters allow you to reduce lists so they show only the 
files similar to the one(s) you are looking for. 

The default wild card characters are the same as used by UNIX 
operating systems, but if you want to change them, just click in the 
text box and type a new character. 

Reset — This restores the PowerSHAPE defaults as shown. 

Pattern — This allows you to store a character string as a preset 
filter. If you regularly use the same filter string, this option saves 
the need to retype it each time. 

Clear — Empty the Pattern text box. 
 

View options 
The following options pages are grouped under the View category: 

 Shading (see page 97) 

 Views (see page 99) 

 Blanking and Grid (see page 102) 
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Shading options 
Control the settings for shading surfaces using the Shading page. 

 
Tolerance for shading — This controls how accurately the triangles 
generated when shading objects fit the surfaces. The default is 0.1. 
The smaller the value the better the shading quality, however the 
time taken to shade the objects increases. When the value is large 
the objects are shaded quickly however gaps may appear between 
the triangles. 

Tolerance to Current View — This sets the ideal value of Tolerance for 
Shading according to your current view and zoom level. Click the 
button and the value is displayed in the Tolerance for Shading text 
box. If you want a different tolerance, click in the box and enter a 
suitable value. The new tolerance will be used the next time the 
shading is regenerated. If you want to use it immediately, click 
Force Regeneration of Triangles. 

Force Regeneration of Triangles — This forces the shading triangles 
to be regenerated, using any settings that have been changed. 

Warn about shading failures — If selected (default), a warning is 
displayed if there is a problem when shading solids, surfaces and 
other items. 
Surfaces and Version 8 Solids  
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Shading Aagorithm — Select the algorithm used to generate the 
triangles for shading. The following options are available: 

Auto — This automatically choose between the Rockwood and 
Subdivision options, depending on the surface and trimming 
data in the model. 

Rockwood — This is like the Rockwood Patch option but is 
faster and produces fewer triangles. 

Subdivision — This produces fewer triangles on complex multi-
patch surfaces than all the other options. 

Rockwood Patch (older triangulation algorithm) — This is 
faster on complex curved objects than the Duct Patch option. 

Duct Patch (older triangulation algorithm) — This is the 
quickest way of shading simple objects. 

Solids 

Shading algorithm — Select the algorithm to be used for solids 
and then select Force Regeneration of Triangles. The following 
options are available: 

Whole solid — Use this option to close gaps in the shading of a 
Parasolid model. 

Individual faces — Use this option to close gaps in the shading 
of faces on a solid. 
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Views options 
Use the Views dialog to control the default view details. 

 
Perspective view angle — This affects how perspective views are 
displayed. Enter a value of 0  to put the vanishing point at an 
infinite distance, creating an orthographic view. Wider angles create 
a feeling of depth and distance, with really wide angles distorting 
the image to the point where there is no visible depth. The default 
angle is 40 . 

Depth cueing — Select this option to draw objects and parts of 
objects progressively less brightly as they fall further from you. This 
gives a feeling of depth as if receding into the mists of distance. 

Anti-aliasing — This option is now on by default, providing smoother 
outlines to rotated models.  
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Anti-aliasing provides greatly improved graphics display, but it can 
impact on performance. Consequently, this functionality is disabled 
automatically if the graphics card has less than 1Gb of video 
memory.  

If you wish to disable the anti-aliasing functionality, use one the of 
the following methods: 
 Make the following change to powershape.con and restart 

PowerSHAPE. 

enable_aa: false   
 Use the control panel of the graphics card to turn off the anti-

aliasing mode to of the graphics card.  

 Deselect Tools > Preferences > View > Views > Anti-aliasing   
Changing this option affects subsequently created windows; it 
has no effect on currently open windows.  

Instrumentation on top when shaded — When you select an object 
(for example a solid block) in shaded mode, its edit handles are 
displayed on top of the shading. 

Instrumentation — Select the style of the instrumentation from: 
 Wireframe 
 Shaded 
 Old style 

Open model in — Select the default view to be used when opening a 
model, from: 
 Saved visualisation mode 
 Wireframe 
 Shaded wire 
 Shaded 
 Dynamic hidden line 
 Transparent shaded wire 
 Transparent shaded 

Default Layout — This defines the default view layout for new 
windows. Click the Default Layout button to display the View Edit 
dialog (see page 113). Use this dialog to define the default view 
layout. 

View Rotation — When you drag the middle mouse button the view 
rotates in 3D as if within a ball. The two menus in this option control 
how the rotation behaves and the tracker ball graphic colour. 

Rotate around — Select one of the following options from the drop-
down list: 
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 Selection — The view rotates around the selected point on the 
selection. If nothing is selected, it reverts to the centre of the 
view. 

 Active workplane — The view rotates around the currently 
active workplane origin. If no workplane is active, it reverts to 
the centre of the view. 

 View centre — The view rotates around the centre of the view. 

Tracker ball colour — Select one of the following options from the 
drop-down: 

 Dull — The tracker ball lines are drawn in a colour which does 
not contrast heavily with the active window background 
colour. 

 Bright — The tracker ball lines are drawn in a colour which 
does contrast heavily with the active window background 
colour. 

 Invisible — The tracker ball lines are hidden during view 
rotations. 

View spinning — When you drag the middle mouse button on a view, 
the view rotates. You can turn on View Spinning so that the view 
continues to rotate after you release the middle mouse button. The 
view is rotated in the direction that you moved the mouse. 

Rotation tracker — If selected, axes are drawn in the bottom left 
corner of the view to show the direction of the X, Y, and Z axes. 

 
If an axis points away from you, it is drawn dim. 

 
The axes on the rotation tracker, which represent the active 
plane, are drawn in a different colour to the axis perpendicular to 
the plane. The colours are set in the scm file. 

Minimum frames per second — Enter the minimum acceptable 
number of frames per second when dynamically rotating, zooming, 
and panning. If the view cannot achieve the requested minimum 
frames per second, objects are omitted while dynamically changing 
the view. Enter 0 for no minimum. 

Time limit — Enter a maximum target time, in seconds, to animate 
between view orientations. 
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See Also 
Colours used in PowerSHAPE 

 

Blanking and Grid 
Use this dialog to define the grid and blanking options. 

 

Blanking 
Unblank items when model opened — Select this option to display 
blanked items when you open a model. 

Show blanked objects ghosted — Select this option to display blanked 
items as grey instead of being fully hidden. 

Grid 
Grid type — Select whether to draw the grid as ruled or dotted lines. 

Maximum number of lines — This value represents the maximum 
number of horizontal and vertical grid lines. The default number of 
grid lines in each direction is set to half the screen resolution. If you 
request a grid of more than 1000 lines in each direction, a warning 
is displayed to indicate the large number of lines may cause the grid 
to draw slowly. 

User defined scale — If selected, the grid scale is locked to the 
current user defined value. If deselected, the grid scale adjusts as 
the view is changed. 

Shaded plane — If selected, a shaded plane representing the current 
active workplane is displayed if the grid is switched off. 
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Automatic principal plane — If selected, the principal plane is set 
based on the viewing direction. The principal plane will be set to be 
at right angles to the axis you are looking down. So, if you are 
looking down the Z axis, the principal plane will be changed to XY. 

Automatic Principal plane in multiple views — Select this option to 
have a principal plane related to the viewing axis as follows: 

 Z - XY plane 

 X - YZ plane 

 Y - ZX plane 

An ISO view has an XY principal plane. 
 

Object options 
The following options pages are grouped under the Object category: 

 Arcs (see page 104) 

 Curves (see page 105) 

 Composite curves (see page 106) 

 Holes (see page 108) 

 Lines (see page 110) 

 Points (see page 112) 

 Solids (see page 112) 

 Surfaces (see page 115) 

 Mesh (see page 120) 

 Workplanes (see page 121) 
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Arcs options 
This page enables you to set the default arc creation tool, which is 
displayed in the arcs menu on the main toolbar. 

 
Default Creation mode — Set the default arc creation mode so that 
when you create an arc using the toolbar, this creation mode is 
automatically selected. 

Default Fllet radius — When you create a fillet arc, it is created with 
a default radius. Enter the default fillet radius. The Default Fillet 
radius is stored with each model. The option is available only if a 
model is open. 

Confirm radius — Select this option to display a dialog, which asks 
you to confirm or correct the radius value, when you create a new 
fitted arc. 

Trim tangent items — Select this option to trim the object to the 
tangency point when you create an arc tangent to an object. 

Mark centre of arc — Select this option to mark the centres of new 
arcs with a cross. 
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Curve options 
This page enables you to set the curvature options for creating B-
spline and g2 curves and to create composite curves automatically 
from a trimmed fillet solution. 

 

Curvature Continuous 
These options set the curvature to zero at the start or end point 
when creating B-spline and g2 curves. 

A zero curvature has a flattening effect on the curve. 

 

 Non-zero curvature. 

 Zero curvature. 

Curve Filleting 
The following two options are used with the Create a Trimmed Bezier 
Curve Fillet and Create a Radii Bezier Curve Fillet options on the 
Curves menu, where two adjoining items are trimmed and a fillet 
curve is created in between. 
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Prompt for trimming solutions — If this option is ON and the Create 
profile automatically from trimmed solution option is also ON, a 
composite curve is created for only 4 out of the 8 potential trim 
solutions that the Create a Trimmed Bezier Curve Fillet option offers. 
This is because a valid composite curve cannot be created 
automatically where there is a jump in the track in a trim solution. 

Create composite curve automatically from trimmed solution — Select 
this option to automatically create a composite curve from the 
trimmed fillet solution. 

 

Composite curve options 
This controls the default settings for adding composite curves to 
models. This also contains the setting to zoom in when entering 2D 
Editing. 

For further details, see: 

 Creating a composite curve by tracing 

 Setting composite curves options 

 Using the 2D curve editor 

 
Gap jumping multiplier — Define the gap used to search for suitable 
paths during composite curve creation. The number is a multiple of 
the general tolerance and can be changed during composite curve 
creation. For your convenience, the current value of the general 
tolerance is displayed below this option. 
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Search both ways — Select this option to enable the control panel to 
select items from the start of the composite curve when it reaches 
the last item. 

Keep original curves — This option is deselected by default and 
whole objects selected as part of a composite curve become part of 
the new composite curve (and can no longer be selected as single 
items). Items that are partially selected (for a portion of their 
length) cannot be partly consumed and so a copy of the selected 
portion is created and used in the new curve, and the original is left 
untouched. Select Keep Original Curves to copy all objects (whole or 
partial) to the new curve. The originals remain untouched. 

Follow edges only — When selecting surface curves to be part of a 
composite curve, there are two options. You can select either curves 
only at the edge of the surface or all the curves (at surface edges or 
patch edges). The latter involves much more work and slows down 
the searching operation. Because it is also less commonly required, 
the default is normally to search following surface edge curves only. 

If the option is ON, it behaves as OFF when: 

 The surface is closed in either direction. If any trimming 
makes the closed surface appear open, the surface is treated 
as open. 

 The surface is a surface extrusion. 

Solid lines only — This is used in hatching. For further details, see 
Hatching. 

Maximum discontinuity angle — This angle affects the way the 
strategy of Discontinuous selects the path to follow at branch points 
when in Fast forward mode. 

Go  At branch point — Select how the control panel, when in 
Fast forward mode, automatically selects items when a branch point 
is reached: 
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 Straight on — Select the path which is the most continuous 
(has the smallest change in direction) from the last object 
selected. 

 Left — Select the left most path. This is useful when choosing 
closed loops. 

 Right — Select the right most path. 

 Discontinuous — Select the path which has an angle that is 
less than the Maximum discontinuity. If there is more than one 
path which is less than the discontinuity angle, then the path 
which has the smallest discontinuity angle is chosen. 

Zoom 2D editor on enter — Define how a composite curve is viewed 
when using the 2D Editor. The option is selected by default. 

If this option is selected, when you select the Edit the curve in 2D 

 button (Curve Edits flyout), the display zooms into the 
selected composite curve, ready for editing using the 2D Editor. 

If this option is deselected, when you select the Edit the curve in 

2D  button (Curve Edits flyout), the selected composite curve 
is displayed for editing using the 2D Editor, but the display is not 
zoomed-in.  

 

Holes options 
Set the default hole options on the Holes page. 

Hole Category and Use — Use the lists to specify the default settings 
to be used in the Hole dialog. 

1 Select a hole category from the first list. 

2 Select the default use for the selected hole category.  

Delete category — (Available only if a user-defined hole category is 
selected). Click this button to delete the selected user-defined 
category. If the category is a standard one, all the user-defined hole 
uses within the selected category are deleted. 

Create — Click this button to open the Hole Use dialog to define a 
new category and use. 

Edit — (Available only if a user-defined hole use is selected) Click 
this button to use the Hole Use dialog to edit the hole use.  

Delete — (Available only if a user-defined hole use is selected) Click 
this button to delete the selected hole use. 
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Delete category — Click this button to delete the selected user-
defined category. If the category is a standard one, all the user-
defined hole uses within the selected category will be deleted. 

Mark centre of holes — If selected, the centres of all hole features 
are marked. When the centres are marked, you can snap to them 
and generate construction lines from them. 

Reuse last hole definition — If selected, the definition of the last hole 
feature created is always used to create the next hole feature, even 
if it is on another solid. If deselected, the definition is only 
remembered as long as you are in hole creation mode. 

Show hole threads — If selected, the thread detail for hole features 
is displayed. 

Give holes meaningful names — If selected, each hole will be given a 
meaningful name based on its use or tapping standard. If 
deselected, the hole will be named according to the integer name 
system. 

The following alignment options let you set initial options when 
placing a hole. You can reset the hole alignments for individual 
cases using the alignment options on the hole Plane Details dialog. 

Align with any surface — If selected, new holes are aligned to any 
face normal. If deselected, new holes are only aligned to planar face 
normals. 

Align with active workplane — If selected, the hole is aligned to the 
normal of the active workplane. If deselected, the hole is aligned to 
the face normals based on the Align with any surface option. 

Create chamfers on holes — Select this option to create chamfers on 
the holes. If deselected, chamfers are not included. 

Chamfer size — Enter the default size of all the chamfers on a 
hole. 

Chamfer angle — Enter the default angle of all the chamfers on a 
hole. 

Recognise tapped holes — This option is selected by default. 
Deselect this option to prevent holes from being recognised as 
tapped. 
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Line options 
Use this page to control the default settings used to create lines. 

 
The page is split into two main sections: 
 Lines 
 Chamfers 

Lines 
Default Creation Mode — Select the default mode for creating lines 
from: 
 Single lines 
 Continuous lines 
 Rectangles 
 Polygons 
 Chamfer 
 Chamfer untrimmed 

When you create a line using the toolbar, this creation mode is 
automatically selected. 
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Angular gridding — Select this option to use angular gridding when 
creating a continuous or non-continuous line. Angular gridding 
displays incremented angle values between the horizontal and the 
rubber band line displayed to the cursor, after the first point is 
input. 

Length gridding — Select this option to use gridded values for the 
length when creating continuous lines, non-continuous lines, or 
rectangles. 

Trim tangent items — Select this option to trim an object to the 
tangency point when you create a line tangent to an object. 

Length caption position — Select where you want the line length 
measurement to be displayed. Length measurements are displayed 
when you create a line or select an existing line. 

Off — Select this option to disable the length measurement 
display. 

End of line — Select this option to display the length 
measurement at the end of the line. 

Middle of line — Select this option to display the length 
measurement in the middle of the line. 

Chamfers 
Default Creation Mode — Select the default mode for creating 
chamfers from: 
 Angle-Distance 
 Angle-Length 
 Distance along 

When you create a chamfer, this type of chamfer is automatically 
created. 

Default length/distance — This is the length or distance used by the 
definition of the chamfer. 

Default angle — This is the default angle of the chamfer with the first 
line when the Default Creation Mode is Angle-Length or Angle-
Distance. 
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Points options 
This sets the options for points. 

 
Default mark type — Select a symbol to represent the mark from the 
drop down list. The possible options are: 

 
Draw points when drawings printed — Select this option to draw 
points when you print a drawing. 

 

Solids options 
This controls the default settings for solids within models.  
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Version 8 solids — Select this option to create new solids as Version 
8 solids. 

Put surfaces/meshes onto solid's level when converting — Select this 
option to put surfaces and meshes on the same level as the solid. If 
deselected, the surfaces and meshes remain on their original levels. 

Untrim surfaces with local trimming switched off — This option 
controls the behaviour of trimmed surfaces that have their local 
trimming flag switched off when they are made into a solid.  

If selected, the surfaces have their boundaries removed 
automatically when they are made into a solid. The surfaces in 
the solid therefore appear untrimmed. 

If deselected, these surfaces appear trimmed when made into a 
solid. 

Mark centre of arcs — Select this option to mark the centre points of 
wireframe arcs used in solids and solid features. If selected, the 
centre point of any arc is marked by a dot. Any object dragged over 
this dot snaps to the centre of the arc. The default setting for this 
option is selected. 

This option also marks the centre of the arcs used in composite 
curves when creating solid primitive extrusions, revolutions, cut 
features, boss features, bulge features, and network of curves 
features. 

Convert unconnected triangles to single solid — Select this option to 
convert unconnected triangles to a single solid. 
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Group features — Select this option to create a group of features 
when you: 

 sequentially create five or more features of the same type. 

 select individual features in the tree and select Group All from 
the Solid tree menu. 

 
 select individual features on the model and select Group All from 

the Solid tree menu. 

 
Give groups meaningful names — Select this option to give groups 
names that relate to their contents. This option is selected by 
default. 

Edit features in transformed positions — Select this option to edit a 
feature in its transformed position. So, if you have moved a Boolean 
block, the block is edited in the current position. 
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If Edit features in transformed positions is deselected, the feature is 
edited in its position before the transform was applied. So, if you 
move Boolean block, the block is edited in its original position. 

 
In PowerSHAPE 2015 R2, this option works for the following 
features in the tree: 

 base and primitive features 

 Boolean features 

 Boolean boss features 
 

Surfaces options 
Use this page to control the default settings for surfaces within 
models.  
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Trimming — Select this option to trim surfaces. Trimmed surfaces 
give a realistic shape. Untrimmed surfaces require less computer 
graphics processing, reducing screen redraw times. However, they 
can make the model confusing to look at. 

Draw surface orientation mark — Select this option to mark a 
surface’s outer face. Deselect this option to redraw complex models 
faster. 

Display normals for multiple surfaces — Select this option to show 
surface normals when you select multiple surfaces. 

Default draft angle — Enter the default angle to use when you create 
draft surfaces. 

Longitudinal detail lines per patch — When you select a surface for 
editing, additional grey detail lines are displayed to indicate the 
surface shape. Enter the number of detail lines between each pair of 
longitudinal curves. Enter 0 to disable detail lines. 
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Lateral detail lines per patch — When you select a surface for editing, 
additional grey detail lines are displayed to indicate the surface 
shape. Enter the number of detail lines between each pair of 
sectional curves. Enter 0 to disable detail lines. 

Default fillet radius — This sets the fillet radius which will be used by 
default when creating fillet surfaces. 

For further details, see How do I create a fillet surface? 

Keep pcurves generated by filleting — If ON, keeps the pcurves when 
Trim is turned off on the Fillet Surface dialog. 

Keep pcurves generated by limiting — If ON, keeps the pcurves when 
generated by limiting. No pcurves will be generated if Trim both is 
set to OFF on the Limit selection dialog. 

Suppress internal lines on surfaces — If ON, the laterals and 
longitudinals are only drawn: 

 on the surface edges; 

 in the direction where the surface is closed; 

 along a discontinuity in a surface; 

 on a single selected surface. 

If OFF, all the laterals and longitudinals are drawn on the 
surfaces. 

This option only applies to wireframe view. 

 



 

118 • Menus PowerSHAPE 2015 R2 Reference Help  

 Suppress internal lines on surfaces option OFF. 

 Suppress internal lines on surfaces option ON. 

Suppress internal lines on surfaces when shaded — This suppresses 
the drawing of internal lateral and longitudinal lines when shaded 
for clarity and efficiency. 

 

 Suppress internal lines on surfaces when shaded option OFF. 

 Suppress internal lines on surfaces when shaded option ON. 

Suppress internal lines on surfaces in solids — This allows you to set 
whether you want the internal lines to be drawn on surfaces in 
solids. If ON, internal lines are not drawn. 

Suppress internal lines on surfaces in components — This allows you 
to set whether you want the internal lines to be drawn on surfaces 
in components. If ON, internal lines are not drawn. 

Suppress detail on large surfaces — This allows you to set whether 
you want the detail lines to be drawn on single selected surfaces. If 
ON , detail lines are not drawn in a particular direction when there 
are more than 15 surface curves in that direction. 

Draw continuous interior laterals on NURBS — If ON, you can display 
the interior laterals on a NURB surface. 

By default, this option is OFF. So only surface curves at 
discontinuities and surface edges are displayed. 
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 Draw continuous interior laterals on NURBS option OFF. 

 Draw continuous interior laterals on NURBS option ON. 

You can only click curves on the screen if they are displayed. Even if 
the curves are not displayed, you can use the Surface Edits toolbar 
to select them. 

Core/Cavity Separation 
Min. visible region (pixels) — This tolerance is set to Automatic by 
default, but also provides a range of fixed values from 1 to 10. 

When finding the core and cavity separation for a mold, the 
program looks at the model from the top and bottom (along the Z 
axis). Any surfaces which are visible in either direction are assumed 
to be part of either the core or cavity of the mold.  

When calculating the separation, the surface is covered with 
triangles, however small gaps cannot be totally eliminated. 
Consequently, tiny areas (of an otherwise invisible surface) can be 
seen through these gaps. This option allows you to tell the 
core/cavity separation algorithm to ignore gaps (or other holes) of 
less than a set size. 

Primitives 
Use these options for creating primitives (such as blocks and 
cylinders), extrusions and revolutions. 

Create as NURBS — When ON, the primitives (such as blocks and 
cylinders) are created as NURB surfaces. 

Convert all surfaces to Power Surfaces — This option affects the 
behaviour of the Edit > Convert > Surface command. It controls how 
primitive, morph or other special surfaces (other than NURBS or 
Power Surfaces) are converted. 

If ON, all types of surfaces are converted to a Power Surface. 

If OFF, the surface is converted to a NURBS or PowerSurface 
according to the type of surface on which the surface is based. 

Keep wireframe (extrusions and revolutions) — When ON, the 
wireframe is automatically kept in the model. When OFF, the 
wireframe is removed from the model. You can add the wireframe 
to the model again using the Create a copy of the sketch option on 
Sketch tab of the dialog for the extrusion or revolution. The dialog is 
displayed by double clicking the object. 

Create extrusions normal to planar base — When ON and you create 
an extruded surface/solid using a planar base, then the extrusion is 
normal to the planar base. Otherwise the extrusion is in the positive 
direction of the axis normal to the principal plane. 
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Mesh options 
This controls the default settings for meshes within models. 

 
Use the following options to edit the Segmentation settings. 

Item type to fit — Select Surfaces or Solids to be the default item 
type to fit to the mesh when segmenting. 

Trim surfaces — Select this option to toggle between creating 
trimmed or full surfaces when segmenting. 

Alignment angle — Enter a value to define the tolerance for 
aligning primitives with a principal plane. If an axis of a primitive 
is within the tolerance of a principal plane, the axis is snapped to 
the principal plane. 

Extension distance — Enter a value to define the distance by 
which a primitive is extended beyond the edge of its region. 

Fit method — Select an option from the list to set the default 
setting for fitting primitive surfaces to a mesh when you are 
automatically or manually segmenting a mesh. 

 



 

PowerSHAPE 2015 R2 Reference Help Menus • 121  

Workplane options 
The Workplanes page of the Options dialog enables you to set the 
default workplane options. 

 
Grouped — When Grouped is on, associations are created between 
the workplane and objects created while the workplane is active. 
This means that if you reposition the grouped workplane, the 
associated objects move with it. If a grouped workplane is deleted, 
the objects remain in place, but their co-ordinates now relate only 
to the global workspace. If a grouped workplane is ungrouped, the 
object associations are lost. When Grouped is off, each workplane is 
treated as a simple 3D local coordinates system. These workplanes 
can be moved, but objects drawn previously remain in place. 
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Local point input — When this is off and you input a position into the 
coordinates text box on the status bar, then the position is input as 
XYZ coordinates. For example, if you type 20 0, the position is X20 
Y0 Z0. With Local point input on, the values are input relative to the 
current principal plane. For example, if ZX is the current principal 
plane, then 20 0 means a position of Z20 Y0 X0. 

Show active workplane when layer off — If ON, the active workplane 
is displayed when its layer is turned off. 

Default Creation Mode 
You can set the default workplane creation mode so that when you 
create a workplane using the toolbar, this creation mode is 
automatically selected. 

Object Creation Workspace 
Use relative workspace when available — If ON, the relative 
workspace is used if available. If OFF, the absolute workspace is 
used. 

Workplane Selector 
Filter — You can use a filter to display only certain names in the 
Workplane combo box on the Status bar. Enter the filter pattern in 
the text box. 

 

Format options 
The following options pages are grouped under the Format category: 

 Levels and Styles (see page 123) 
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Levels and styles options 
Use this dialog to specify the options for levels and styles. 

 

Main Toolbar Level Selector 
Use these options to set the defaults for the Levels list on the Main 
toolbar (see page 196).  

 
Select one or more of the following options to specify the levels that 
are displayed in the list on the Main toolbar. Use combinations of 
the options to keep the list of levels in the list to a reasonable size, 
even when there are many levels in a model. 

 Used — Display only the levels that are currently in use within 
the model. 

 Named — Display only the levels that are named. 

 On — Display only the levels that are active within the model. 
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Deselect all these options to display all levels in the Levels list. This 
option does not affect the filter in the Level dialog 

Max. number of. entries — Enter the maximum number of levels you 
want to display in the Levels list. The default is 50. 

Groups and Levels Toolbar 
Select one or more of the following options to specify the levels that 
are displayed in the list on the Levels toolbar. Use combinations of 
the options to keep the list of levels in the list to a reasonable size, 
even when there are many levels in a model. 

 Used — Display only the levels that are currently in use within 
the model. 

 Named — Display only the levels that are named. 

 On — Display only the levels that are active within the model. 

Copying Levels Names 
Use these options to specify the copying of level names when items 
are copied between models. Select one of the following: 

 Do not copy level names — When copying an item between 
models, do not copy its level name. 

 Copy level names of items — When copying an item between 
models, copy its level name. 

 Copy level names of items to unnamed level — When copying an 
item between models, copy its level name if the destination level 
is currently unnamed. This is the default setting. 

Object Creation Levels 
This determines which level an object is created on. You can choose 
from three options. 

Separate creation levels — With this option, each type of object 
can be created on a different level. For example, if you change 
the creation level of lines to level 4, then all new lines are 
created on that level. Other wireframe objects such as arcs and 
curves are still created on the default level. 

Grouped creation levels — With this option, if you change the 
level that an object is to be created on, then all objects of the 
same group are also created on this level. That is, wireframe 
objects are grouped together on the same level, solids and 
surfaces are grouped on the same level. For example, if you 
change the creation level of surfaces, then new solids are also 
created on the new level. 
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All objects have the same creation level — With this option, if you 
change the level that an object is to be created on, then all new 
objects are also created on this level. This is the default setting. 

 This functionality applies only when you change the level that 
a particular type of object is created on. 

Object Creation Styles  
Select one of the following options to specify the style used to 
create an object: 

 Separate creation styles — Create each type of object using a 
different style. For example, if you change the creation style of 
lines to StartArrow, all new lines are created with style 
StartArrow. Other wireframe objects such as arcs and curves are 
still created using the default style. 

 Grouped creation styles — If you change the creation style of an 
object, all objects of the same group (so wireframe objects are 
created using the same style, solids and surfaces are created 
from the same style) are also created using that style. For 
example, if you change the creation style of surfaces, new solids 
are also created using that style. 

 All objects have the same creation style — If you change the 
creation style of an object, all new objects are also created with 
that style. This is the default setting. 

 This functionality applies only when you change the style of a 
particular type of object. 

Example : A model has a level and style with the same name (for 
example Top); Object Creation Level and Object Creation Style are set 
to similar options. If you change the creation level of an object to 
Top: 

 The creation style of that object will automatically becomes Top.  

 Other objects may change to level and style Top depending on 
the options set for Object Creation Level and the Object Creation 
Style. 

 

Tools options 
The following options pages are grouped under the Tools category: 
 Analysis 

 Curve Analysis (see page 126) 

 Model Visual Difference (see page 127) 

 Surface Analysis (see page 128) 
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 Thickness Analysis (see page 129) 

 Comparison Analysis (see page 64) 

 FileDoctor (see page 134) 

 Macro (see page 137) 
 

Curve Analysis options 
Use this page to change the comb scale. 

 
Comb scale — Enter the size of the curvature combs display. The 
default comb size is multiplied by this value. 

Comb density — Enter the comb density. The default density is 1.0. 
Increase the density to add more teeth on curvature combs, 
decrease the density to reduce the number of teeth. The density 
must be greater than 0.0001. 

 A high comb density may take a long time to compute 
therefore it is recommended that you increase the density in 
small increments. 

Draw a comb normal to the curve — Select this option to draw the 
curvature combs normal to the curve. 

Draw a comb normal to the view — Select this option to draw the 
curvature combs normal to the view. 
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Model Visual Difference options 
The Model Visual Differences options dialog lets you control the 
appearance and colour of the model wireframes and shading 
displayed when you use this functionality. 

You can display the dialog in one of the following ways: 

 Select Options... from the Visual Difference context menu. 

 
 Select Model Visual Difference from the Analysis options of the 

Tools branch in the tree of the Options dialog. 

 

Wireframe 
Use these options to control the display of model wireframes. 

Shading 
Select colours for shading unchanged, added, and removed 
material. 
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Surface Analysis options 
Use this page to set the options for surface analysis. 

 

Undercut Shading 
Use these options to set the parameters that define if a surface is 
considered undercut (see page 49).  
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Draft angle — Enter a value between +90  and -90 . The default 
value is 0. 

Draft warning angle — Enter a value, between 0  and 90 , to show 
areas of the surface where the angle is close to the angular 
distance of the Draft angle. 

Align with — Select an axis of the active workplane from the list 
or align the undercut shading with the Principal axis (controlled 

by the axis buttons  on the Status toolbar). 

Minimum Radius Shading 
Cutter tip radius — Enter the cutter tip radius between 0 and 20. The 
default value is 5. 

Surface Cursor Inspection 
Use these options to specify the data that is displayed when 
inspecting a surface. 

Curvature Shading  
These options determine what is displayed when using curvature 
shading (see page 51). 

 

Thickness Analysis options 
Use this dialog to specify options for thickness analysis. 

 
Computation method — Select an option to define the way that the 
thickness is calculated. 
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 Coarse — Coarse, but fast calculation. This is the default 
setting and should be suitable for most users 

 Approximate — Slower, but more accurate calculation. 

 Precise — This option gives you micron accuracy, but this type 
of calculation takes longest to complete. 

Resolution — This enables you adjust the resolution of the 
colourmap, by adjusting the number of points on the model for 
which the thickness is calculated. The resolution can be entered as a 
percentage of the model size or as a figure to represent the 
thickness. For best results, enter the wall thickness in the region 
you want to analyse, particularly for models where the wall 
thickness is thin. So, if you already know that the relevant wall 
thickness is 3mm, enter this as your resolution, with Resolution in 
model units selected from the Units options. 

Units — Select from Resolution as a percentage of the model size 
(default), or Resolution in model units to define how you enter the 
Resolution. 
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Comparison Analysis options 
Use this page to specify the parameters to be used in Comparison 
Analysis. 

 
 Display legend — Select this option to show or hide the error 

legend in the graphics window. 

 Always display errors — Select this option to automatically show 
or hide deviations after they have been calculated. 

 Display error under cursor — Select this option to show or hide 
the numerical deviation beneath the cursor when you hover your 
cursor over the comparison. 

 Colour bands — Select an option from the list to change how the 
deviations are displayed on the model: 

Continuous — The deviations are displayed using a continuous 
scale. 

Two — The deviations are displayed using two distinct colours. 
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Three — The deviations are displayed using three distinct 
colours. 

Five — The deviations are displayed using five distinct colours. 

Ten — The deviations are displayed using ten distinct colours. 

Twenty — The deviations are displayed using twenty distinct 
colours. 

Forty — The deviations are displayed using forty distinct 
colours. 

 Colour bands is not available if Display errors to tolerance is 
selected. 

 Width of error lines — Enter a value to define the width of the 
error bands shown on the model when curve deviations are 
displayed. 

 Display errors to tolerance — Select this option to display the 
deviations in two or three colour bands. The bands are set 
according to the general tolerance. 

This option is deselected by default. 

If Display errors to tolerance is deselected, select the required 
number of Colour bands from the list.  
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 Display absolute range — Select this option to display the 
absolute (modulus) values of deviation. That is the range of 
errors from 0 to the maximum value. 

 
 Set maximum value to maximum error — Select this option to set 

the maximum value of the error range to the largest deviation. 

 Maximum value of error range — Enter a value into the field to 
define the maximum value of the error range. In the following 
example : 

 Maximum value of error range is set 1. 

 Colour bands are Continuous. 

 

 This option is unavailable if Set maximum value to maximum 
error is selected. 
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 Sample Point Density — Use the slider to control the number 
density of points used to calculate differences between your 
models. A larger Sample Point Density produces more accurate 
results, with a longer computation time. A smaller Sample Point 
Density produces less accurate results, with a shorter 
computation time. 

 

File Doctor options 
This sets the options to run the File Doctor while working on a model 
or before it is saved. Depending on your level of security, some or 
all of the options on the File Doctor options dialog may be 
unavailable. This is intended to improve the chance of you repairing 
the model. 

 
Do Integrity check after every command — PowerSHAPE checks the 
model for integrity after each command. 
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If a problem is found, the last commands are automatically 
undone until the model is in a state where the integrity check 
passes. This mode of checking is designed for use with problem 
models. 

If Do Integrity Check after every command is selected, PowerSHAPE 
also does a Check & Fix when you open a model. As a result, the 
model may lose some data. If you want to recover this lost data, 
we suggest you immediately do the following: 

1 Deselect the Do Integrity check after every command option. 

2 Close the model without saving it. 

3 Open the model again. 

Check model before save — PowerSHAPE uses the File Doctor to 
check your models each time you save using the selected File Doctor 
options. These checks are applied at file save, file reset, and when 
upgrading a model. 

 You can change the Check model before save options only if 
you have security levels 1 and 2. Usually, system 
administrators have security level 1 and design office 
managers have security level 2. 

Run File Doctor interactively when model updated — Specify how the 
File Doctor is run. 

 If Run File Doctor interactively when Model updated is selected 
(default) and the model version has been updated, the File 
Doctor is run interactively. The following warning dialog is 
displayed: 

 

 You are recommended to run File Doctor when opening an 
old version model in a version of PowerSHAPE that uses a 
later version model. However, if you select Close on the File 
Doctor dialog, the model is unchanged. 
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 If Run File Doctor interactively when Model updated is deselected 
and the model version has been updated, the File Doctor is run 
automatically (as in previous versions of PowerSHAPE). 

 
 If Run File Doctor interactively when Model updated is selected 

(default) and the model version has been updated, the File 
Doctor is run interactively. The following warning dialog is 
displayed: 

 

 You are recommended to run File Doctor when opening an 
old version model in a version of PowerSHAPE that uses a 
later version model. However, if you select Close on the File 
Doctor dialog, the model is unchanged. 

 If Run File Doctor interactively when Model updated is deselected 
and the model version has been updated, the File Doctor is run 
automatically (as in previous versions of PowerSHAPE) 

 
 



 

PowerSHAPE 2015 R2 Reference Help Menus • 137  

Macro options 
Use this page to define the mouse options when recording macros.  

 

Macro Mouse Simulation 
These options enable a macro to show mouse movements. 

When you record a macro, the button clicks and their positions are 
recorded, but by default the mouse movements between clicks are 
not recorded. This keeps the macro file to a reasonable size and 
optimises performance. However, for demonstration and testing 
purposes, this option can be useful to see the dragging and rubber-
banded mouse movements. 

Selecting the Dragging and Moving options affects subsequently 
recorded macros. When you run macros, the mouse is shown 
dragging and moving between the button press and release points. 
The mouse movement characteristics are controlled as follows: 

Increments affects the number of steps between points. A large 
value makes it move smoothly, but possibly more slowly. A low 
value means larger increments and faster movement, but 
possibly causing jerky motion. The default values provide a good 
compromise between speed and smoothness. 

Delay controls the wait time at each incremental step. 

Macro Directory 
This is the default directory where recorded macros are stored and 
run from. 

 

Assembly options 
These options are part of the Assembly modelling functionality.  



 

138 • Menus PowerSHAPE 2015 R2 Reference Help  

For further details, see Assembly options. 
 

Data Exchange options 
The following options pages are grouped under the Data Exchange 
category: 

 Version 8 / Surfaces (see page 139) 

 Delcam Exchange (see page 143) 

 IGES (see page 144) 

 U3D / PDF (see page 145) 

 HPGL (see page 146) 

 Parasolid (see page 148) 

 PIC (see page 149) 

 Triangle/Mesh (see page 149) 

 FBX (see page 152) 
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Version 8 / Surfaces options 
This page contains the options for data exchange.  

 
Import non-parasolid solids using — Select the method to use to 
import non-parasolid solids from: 

 Default settings — Select this option to detect the file type and 
import solids as Parasolids or version 8 solids depending on the 
file type: 

 If the file is from a solid modeller, it is imported as a 
Parasolid. 

 If the file is not from a solid modeller, it is imported as a 
version 8 solid. 

 Parasolid — Select this option to import a non-parasolid solid as 
a parasolid 

 Version 8 — Select this option to import a non-parasolid solid as 
a version 8 solid. 

 Surface — Select this option to import a non-parasolid solid as 
surfaces. 
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Surface trimming — In an IGES file, a trimming curve can be defined 
as either 2D parameter or 3D coordinate values. The Surface 
trimming options enable you to set: 

 whether a trimming curve is imported from an IGES file as either 
2D parameter or 3D coordinate values. 

 whether a pcurve is exported to an IGES file as 2D parameter or 
3D coordinate values. 

Select from: 

2D — Only the 2D parameter values are imported or exported. 

3D — Only the 3D coordinate values are imported or exported. 

2D and 3D — The 2D parameter values are imported, but if the 
trimming curve cannot be drawn using the 2D curve values, the 
3D coordinate values are imported. Both the 2D parameter and 
3D coordinate values are exported. 

None — No trimming curves are imported or exported, so 
untrimmed surfaces are imported or exported. 

You are advised to use the 2D option when importing 
Parasolid/Unigraphics, SolidWorks/SolidEdge. 

Duplicate PPoint tolerance — This controls the tolerance for removing 
duplicate PPoints when importing files. If two PPoints lie within this 
tolerance, they are treated as duplicate points and one of the 
PPoints is removed when the file is imported. 

Import 
The following import options are available: 
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Open a new model for each CATIA fic file — Catia export files *.cat 
and *.exp are made up of a number of Catia fic files. By default, 
each fic file is imported into a separate new model. You can 
import the fic files into the same model by turning off this option. 

Automatic viewing of the model after import — If selected, the 
model is viewed automatically when imported. This also turns on 
all the levels used and displays the model using the zoom full 
viewing option. 

Automatic orientation of surfaces after import — If selected, 
normals are orientated automatically to surfaces when the model 
is imported. This points the normals of surfaces on each level in 
the same direction. 

Remove surface patches outside trim boundary — If selected, 
surface patches outside the trim boundary are removed. If 
deselected, surface patches are retained. 

Export 
The following export options are available: 

Merge short edges — Enter a tolerance for merging short edges. 
Edges that are shorter than the tolerance are merged. 

Heal solids — for future development. 

Add trim boundaries — Select this option to add trim boundaries 
to the edges of all surfaces that are untrimmed. 

Link solids — Select this option to find and store the linked half-
edges of a solid, where a half-edge is a segment of a boundary 
of a face. 

Remove duplicate 3D ppoints — Select this option to remove all 
duplicate 3D ppoints within general tolerance. 

Orient surfaces — Level by level, all the normals of multiple 
surfaces are orientated so that the outside of two adjacent 
surfaces match. The model is unaltered. 

Break Surfaces 
These options determine how to break a surface when it is 
exported. 
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Discontinuity angle — If a surface contains a tangent 
discontinuity, it is broken at that point. A tangent discontinuity in 
a surface is defined by angle given in the box next to this option. 

Planar regions — Select this option to break surfaces at the edges 
of planar regions. 

Zero length patch — If a surface contains a zero length patch, it is 
split on either sides of the patch. 

Closed — Select this option to break a closed surface into two 
pieces. 

Patch borders — Select this option to break all surfaces at all 
longitudinal and lateral curves. 

See Also  
Export dialog  

Delcam Exchange options (see page 143)  

DDX options  

IGES options (see page 144)  

STL/DMT options (see page 149) 
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Delcam Exchange options 
This page contains the options for data exchange.  

 
Specify the options to be used with Delcam Exchange: 

Use DDX as intermediate file — Select this option to use .ddx as the 
intermediate file format during import and export. Deselect it to use 
the .dgk file format. 

Use names from the import files — Select this option to use the 
names of the items in the imported file when importing using 
Delcam Exchange. 

Write solids to separate levels — Select this option to place individual 
solids onto separate levels, when importing a file containing a 
number of solids, regardless of their previous level information.  

Open Exchange Input Resources — Select this option to display the 
Delcam Exchange Input Resources dialog when importing. 
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Open Exchange Output Resources — Select this option to display the 
Delcam Exchange Output Resources dialog when importing. 

 

IGES options 
Use this page to set how data is imported from or exported to IGES 
files. 

 If you have selected a Target System on the File Export 
dialog, the export settings for the Target System are 
displayed automatically. 

 

Import 
The following import options are available: 

Offset — Select the offset direction of the offset surface when 
importing IGES files. You can choose the direction to be along 
the surface normal or use the indicator in the IGES file. 

The next five items on the dialog are tolerances used to import 
IGES files. 

 When you import an IGES file, these tolerances are used 
regardless of those in the IGES file. For example, when 
importing from a solid modelling program with exceptionally 
high internal tolerances, the file is imported using the 
tolerances on this page rather than the really high values 
saved with it. 
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If you change the tolerances, and they are either too small or 
too large, a warning is displayed indicating the minimum or 
maximum recommended value you can have. 

3D curve point coincident — This is the maximum distance 
between two 3D points at which these points occupy the same 
position in 3D space. If more than this tolerance, the points are 
said to be distinct. 

3D curve approximation — Certain types of curves cannot be 
imported into PowerSHAPE, so they are changed to curves which 
can be read. This tolerance controls the maximum deviation of 
the approximated curve from the original curve. 

2D parametric/trim curve approximation — All 2D trimming curves 
are converted to pcurves. This tolerance controls the maximum 
deviation of the created pcurve from the original trimming curve. 

3D Surface approximation — Certain types of surfaces cannot be 
imported, therefore they are changed to surfaces which can be 
read. This tolerance controls how much the approximated surface 
differs to the original surface. 

Create a solid last — Select this option to create a solid last from 
a .pslast file 

 

U3D / PDF options 
Use this dialog to specify the U3D/PDF options 

 



 

146 • Menus PowerSHAPE 2015 R2 Reference Help  

General Settings 
Export animations — If selected, automatically generate animation if 
it is not present. 

Triangulation tolerance — If available, set the tolerance used to 
create triangles for export. 

Calculate triangulation tolerance automatically — If deselected, set the 
tolerance using the Triangulation tolerance option. 

 

HPGL options 
Use the HPGL options page to specify the conversion factors to be 
used when exporting to HP plotter format. 

 
Start position — Enter the X and Y positions to define the start 
position of the tool. 

End Position — Enter the X and Y positions to define the end 
position of the tool. 

Delay — The delay for the tool movement. 

HPGL conversion factor — Enter a value to define the conversion 
factor to be applied when PowerSHAPE units are converted to HPGL 
units. 

Export arcs as polylines — If ON, arcs are exported as polylines. If 
OFF, arcs are exported as arcs. 
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Select level — Select a level from the drop down list. All the objects 
that you assign to a particular level are grouped together when 
exported. 

Level 
These options let you select a level and define its attributes.  

 Pen Tool — Tool name. 

 Acceleration — Speed of the tool. 

 Up Speed — Up speed of the tool. 

 Down Speed — Down speed of the tool. 

 Passes — Enter the number of passes. 

 Pen pressure (g) — Pressure for the tool. 
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Parasolid options 
Use the Parasolid options page to specify the options to be used 
when importing and exporting Parasolid files. 

 
Flatten assembly hierarchy — Flatten the assembly hierarchy when 
exporting or importing Parasolid files.  

This option should be used when exporting Parasolid files to a 
system that does not support assemblies. It can also be used if 
you wish to work with the geometry as individual solids without 
the assembly structure. 

Parasolid version — Use the drop-down list to select the Parasolid 
version to be used when exporting. The default is Current version; 
use the drop-down list to select export to an earlier version.  
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PIC options 
Use this dialog to define settings to be applied to Picture (.pic) files 

 
Arc-fit — If ON, arc-fitting will be done automatically when a .pic file 
is imported. If OFF, no arc fitting is carried out when importing a 
.pic file. This option is ON by default 

 

Triangle/Mesh options 
This sets the options for exporting STL/DMT files. 

 If you have selected a Target System on the File Export 
dialog, the export settings for the Target System are 
displayed automatically. 
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DMT options are only applicable when using the built-in local 
translator. 

 

STL/DMT Import 
Name mesh according to filename — Select this option to use the 
filename as the name for the mesh. If necessary, a numerical suffix 
will be added to ensure that the mesh name is unique. This option is 
deactivated by default.  

Combine meshes from DMT file — If selected, everything in a DMT file 
is combined into a single mesh. This option is deselected by default. 

Split big meshes imported from STL files — This option is under 
development.  

Export 
These options are not applicable when the user switches to Delcam 
Exchange. 
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Triangulation tolerance — This is the tolerance used for exporting 
triangles. 

Solid shading — Uses the improved shading of watertight solids 
when triangulating for the export of triangles. 

Skip export of inner faces of objects — Select this option to skip the 
inner faces of the objects to reduce the file size when they are 
exported to .obj. 

Limit triangle edge length — If selected, the length of a triangle is 
limited to the given value. 

Maximum triangle length — If Limit triangle length is selected, you can 
enter a value in the text box. 

STL 
Auto-fix mesh on STL export — This option is deselected by default. If 
selected, the new triangles are automatically fixed so that the mesh 
is closed. Select this option to display the following: 

Reverse mesh during Auto-fix — The exported triangles are 
reversed when fixing triangles on STL export. 

Close model during Auto-fix — The model is closed when fixing 
triangles on export. The option is deselected by default. 

Reduce triangles during Auto-fix — Reduce the number of triangles 
on export. 

Output file format — Select the output file format from the drop-
down list. Files can be exported in binary or ASCII format. 

Move model into positive quadrant — If selected, all triangle 
coordinates are offset so that they are all positive. 

Export STL with colour information — If selected, the materials 
applied to surfaces are preserved when the file is exported and the 
colours that are stored with the individual triangles are exported. 

Generate random colours for surfaces — If selected, this assigns 
materials randomly to exported surfaces. 
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FBX options 
Use this dialog to define settings to be applied to Filmbox (.fbx) 
files. 

 
Set Y axis as up direction — Select this option to set the Y axis as the 
up direction for imported .fbx files. 

 

Drafting options 
The following options pages are grouped under the Drafting 
category: 

 Dimensions (see page 155) 
 Annotation 
 Lines 
 Tolerance / Dual 

 Views (see page 155) 
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 General 
 Section 
 Hidden 
 Centrelines 
 Tapped Details 
 Line Styles 

 Balloon (see page 153) 

 Bill Of Materials (see page 153) 

 Drawings (see page 154) 

 Hatching (see page 154) 

 Schedule (see page 154) 

 Text (see page 154) 
 

Balloon options 
This is part of the Drafting functionality.  

For further details, see Setting the balloons on the Options dialog. 
 

Bill of Materials 
Use this dialog to specify the Rough Oversize Value. 
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1 Select Tools > Options > Drafting > Bill of Materials to display the 
Options dialog. 

 
2 Enter Rough oversize value. This value is the additional allowance 

that is added to the bounding box to calculate the stock size 
required to make the item. 

 

Drawings options 
This is part of the Drafting functionality. For further details, see 
Changing the settings of a drawing. 

 

Hatching options 
This is part of the Drafting functionality. For further details, see 
Changing the default hatching. 

 

Schedule options 
This is part of the Drafting functionality. For further details, see 
Setting the schedule options on the Options dialog. 

 

Text options 
This page contains options for creating text in the Drafting module. 
For further details, see Changing the default settings for text. 
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Dimensions - Annotation/Lines/Tolerance options 
This is part of the Drafting functionality. For further details, see 
Editing dimension defaults using the Options dialog. 

 

Drafting Views options 
This is part of the Drafting functionality. For further details, see 
Changing the settings of a view in Delcam Draft.. 

 

PS-Team options 
Specify the PS-Team server and the user details using the PS-Team 
dialog. 

 
Set the following General Options for recording changes to models: 
 Server URL 
 User name 
 User password 

 

Manufacturing options 
The following options pages are grouped under the Manufacturing 
category: 

 Electrode (see page 156) 

 General 

 Base 

 Alignment 

 Toolmaker (see page 156) 

 General 

 Power Feature Clearances 
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 Export (see page 156) 
 

Electrode options 
This is part of the Delcam Electrode functionality. For further 
details, see Changing the Delcam Electrode options. 

 

Toolmaker options 
Use these Options pages to select default settings to be used in 
Toolmaker. There are two pages of Toolmaker options: 

General options 

Custom Power Feature Clearances 
 

Export options 
Use this dialog to specify options for exporting solid hole features to 
PowerMILL as PowerMILL hole features. 

 If PowerMILL and PowerSHAPE are installed on the same 
computer, you can export the data directly to PowerMILL by 
selecting PowerMILL from the Module menu. 

 If PowerMILL and PowerSHAPE are not on the same computer, 
you can create a macro and an xml file to export hole features as 
PowerMILL hole features using the Create Hole Features for all 
DGK option (see below). You can then run the file or macro in 
PowerMILL. 
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Hole Feature Export 
Export hole features from Module > PowerMILL — If selected, this 
option exports solid hole features as PowerMILL's hole features. If 
deselected, the features are exported as surface geometry. 

Create Hole Geometry — Export the hole as geometry as well as a 
feature. 

Hole workplane angular yolerance — This angular tolerance 
determines whether two holes lie in the same plane. If the holes 
lie in the same plane within the angular tolerance, one workplane 
is exported to define their common plane. If they don't, a 
workplane for each hole is exported. 

The macro and xml file contain the hole features as PowerMILL's 
hole features. If Generate Hole Toolpaths is ON, the macro and 
file also contains the toolpaths for the hole features. 

The name of the macro and the xml file is the same name as the 
dgk file. The macro will have a .mac extension and the xml file 
will have a .xml extension. Both are created in the same 
directory as the dgk file. 

Export to PowerMILL version — Select the version of PowerMILL 
you want the macro and xml file to be compatible with:  

 6.0 —  This is the default setting and only exports holes. 

 2013 — This export all feature types using multiple feature 
sets. 

 It is recommended that you use the xml file wherever 
possible. 

Hole chamfers — Select an option from the drop-down list to 
specify the export of holes chamfer sections to PowerMILL. 

Export Assembly Components 
Export assembly components in multiple files — If selected, a single 
file is exported containing all the exported entities plus individual 
files for exported components. If deselected, only the single file is 
exported. This option is only valid when exporting using Delcam 
Exchange. 

File prefix — Use this option with the multiple file export option to 
add a prefix to the file name being exported. 

 

Data Exchange options 
These options on the Options dialog, allow you to set how data is 
imported to or exported from PowerSHAPE. 

 Version 8 / Surfaces options (see page 139)  
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 Delcam Exchange options (see page 143)  

 DDX options 

 IGES options (see page 144)  

 U3D / PDF options (see page 145) 

 HPGL options (see page 146) 

 Parasolid options (see page 148) 

 PIC options (see page 149) 

 STL/DMT options (see page 149) 
Exporting 

 Exporting data from a model 

 Export dialog 

 Table of file types that can be exported  
Importing 

 Importing data into a model  

 Table of file types that can be imported 
 

Macro menu 
The Macro menu allows you to create and run macros. 

 
 

Macro 
Macros allow you to create automatic routines for repetitive 
operations. For example, you might want to loop through all the 
surfaces in a model and change the colours. 

Macros are usually created by recording a sequence of operations. 
The resulting file can then be edited using a text editor. The macro 
language is covered in Customising PowerSHAPE. 

Use the Macro options (see page 137) page of the Options dialog to 
set the mouse options to be used when recording macros. 
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For further details see: 
Macro > Run (see page 159) 

Macro > Step (see page 159) 

Macro > Step All (see page 160) 

Macro > Continue (see page 161) 

Macro > Until (see page 161) 

Macro > Abandon (see page 162) 

Macro > Record (see page 162) 
 

Macro > Run 
Select this option to run a previously recorded macro. 

1 Select Macro > Run to display the Select A Macro To Run dialog. 

 
2 Select the macro you want to run. Its name appears in the File 

name text box. 

3 Click on Open to run the macro. 

For further details, see Macros in the Customising PowerSHAPE 
manual. 

 

Macro > Step 
Select this option to run a macro one step at a time. Any macros 
which are nested will be run. 
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Step runs the macro one step at a time, however if there is a macro 
nested within the macro you are stepping, the nested macro is run. 
You are then returned back to the macro you are stepping through. 
A nested macro is one which is initialised within a macro that is 
already running. 

1 From Macro menu, select Step to display the Step Through Macro 
dialog. 

 
2 Select the macro to step through. 

3 Click Open to begin stepping through the macro. 

 Macros which are nested within the macro you are stepping 
are run rather than stepped. If you want to step nested 
macros, see Macro > Step All 

4 Press Enter each time you want to carry out another step. 

5 To stop stepping through the macro, select Macro/Abandon. 

For further details, see Running a macro one command at a time in 
the Customising PowerSHAPE manual. 

 

Macro > Step All 
Select this option to run the selected macro and any nested macros 
to be run one line at a time. 
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1 From the Macro menu, select Step All to display the Step Through 
Macro dialog. 

 
2 Select the macro to step through. 

3 Click Open to begin stepping through the macro. 

 Macros that are nested within the macro you are stepping 
through, are also stepped through. 

4 Press Enter each time you want to carry out another step. 

5 To stop stepping through any of the macros, select 
Macro/Abandon. 

For further details, see Running a macro one command at a time in 
the Customising PowerSHAPE manual. 

 

Macro > Continue 
Use this option to run the remainder of a stepping macro. 

1 Select Macro > Continue to run the macro. This will run the 
remainder of the macro rather than step through it. 

 

Macro > Until 
The Until command is only available when the macro is stepping. 

When issued, the command prompts for a regular expression. It will 
then run the macro up to and including the first line that contains 
the regular expression. It will then revert to stepping. 
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The regular expressions used are based on Perl and are caseless, so 
if the macro is 

if ($error == 1) {  
print e1  
} elseif ($error == 2) {  
print e2  
} 

the following expressions would all match the last but one line. 

print e2 

p.*2 

PRINT E2 

The advantage of this command is that it makes it easier to step 
through long macros or macros that include modal dialogs. Other 
techniques to do this require editing the macro. 

 

Macro > Abandon 
Use this option to stop a running or stepping macro. 

1 From the Macro menu, select Abandon to stop the macro. 

 Abandon will only be active if you are currently running or 
stepping a macro. 

 

Macro > Record 
Select this option to record a macro. 
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1 Select Macro > Record to display the Record Macro dialog. 

 
2 In the File name text box, enter the name of the file you want to 

record to. If you enter the name of an existing file, it is 
overwritten with the new commands.  

3 Click Save to begin recording the macro. 

4 Now work through the set of commands you want to record. 

5 To stop recording the macro, select Macro > Record. You can use 
any text editor to view and edit a macro. 

For further details on the macro language, see the Customising 
PowerSHAPE manual. 

 

Module menu 
The Module menu contains a list of modules you can run whilst using 
the program. 
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Module > PowerMILL 
This starts up PowerMILL.  

 

Module > Electrode 
This starts the Electrode wizard. 

For further details, see Starting Delcam Electrode from the Module 
menu. 

 

Module > Toolmaker 
This starts up Delcam Toolmaker. 

 

Module > Crispin 
Use this option to select one of the following Delcam Crispin shoe 
products. 

 

SoleEngineer 
Select this option to: 

 Model shoe soles and grade shoes and heels using Sole 
Engineering.  

 Create a shoe last by selecting a series of points and surfaces 
from a model of a shoe using Last Engineering. 

 Edit an existing last using the Last Editor. 
Additional options 

The following are available as a separate cost option: 

LastMaker  
Select this option to: 

 Define lasts, by  importing scans of physical lasts or importing 
digital lasts from other products  

 Edit lasts to generate new last designs. Editing options include: 

 Parametric changes (for example stick length and girth).  

 Local and global shaping.  

 Replacement of one toe shape by another. 
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Engineer 
Select this option to create and edit 2D patterns for every shoe 
piece.  

 Changes to the patterns will update all associated lines 
automatically ( for example mirrors and margins).  

 Template ‘edge types’ (including margins, notches and marker 
lines) can be applied in a single automated operation. 

 Once the patterns have been developed for the main size, the 
graded patterns for all other sizes in a range can be generated. 

ShoeDesign  
Select this option to design a shoe in three dimensions from a 3D 
digital last. Curves are sketched onto the last and thickened 
leather/fabric panels are generated, with realistic textures. The 
result is a photorealistic 3D image of the shoe. The image can be 
used for: 

 Design review and approval. 

 Automatically generating flattened 2D patterns that are ready for 
the pattern engineering process. 

 

Module > Drafting 
This starts up or exits Delcam Draft. It is the same as selecting 

Drafting mode  from the mode flyout on the Main or Drafting 
toolbars. 

When Delcam Draft starts, the main toolbar changes from Modelling 
tools to Drafting tools. 

For further details, see Entering Drafting mode. 

If you do not have a licence to run Delcam Draft, you can run an 
evaluation copy: 

1 From the Tools menu, select Evaluation Mode. 

2 From the Module menu, select Drafting. 
 

Module > Estimator 
This starts up or exits Delcam Estimator. When Delcam Estimator 
starts, the Estimator toolbars are displayed. 

 If Delcam Draft is not installed, then this is the same as 

selecting Drafting mode  on the Main or Estimator toolbars. 
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Module > Add-ins 
This allows you to add macros, commands and applications to the 
Add-in menu. 

For further details, see Introduction to creating OLE applications in 
the Customising PowerSHAPE for your application manual  

To add a macro or a command to the Add-in menu: 
1 Select Manager from the Add-in options of  the Module menu. 

 

2 Click  on the dialog to add a new item. 

3 Make sure the new item is selected. 

4 Give the item a suitable name in the Title box. This name will be 
used in the Add-in menu. 

5 If you are adding a macro, put its path in the Command box. 

6 If you want to add program commands, leave the Command box 
empty and put the commands in the Arguments box. 

7 Click Apply to add the item to the Add-in menu. 
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Window menu 
Use the Window menu to help you manage the windows. It controls 
how they are displayed and which is the active window. 

 
Up to 20 different models can be open at the same time and an 
unlimited number of graphics windows for each model. The only 
constraints are the power and capacity of your computer and your 
own ability to manage a large number of open windows. For further 
details, see Using the graphics area in the Modelling Concepts 
manual.  

 

Window > New Window 
Use this option to open a new window for the active model. It 
becomes the active window and initially shows the default top view 
of the whole model. You can change the views in the usual ways. 

 

Window > Fix 
Fix expands the active window to fill the working area. If set to a 
large size, this can give a larger working area without manually re-
sizing the active window. 

 If you set the program window to a small size, Fix can reduce 
the available working space. 

For further details, see Single window mode. 
 

Window > Float 
Float displays the active view in a window, at the default size. This 
window can be re-positioned and resized as required. All the 
currently open model windows are given their own working window. 
If Float is selected, the windows overlap in a cascade style. 

For further details, see Multi-window mode. 
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Window > Hide 
Hide reduces the need to open and close graphics windows by hiding 
the active window, without actually closing it. You can display the 
hidden window by selecting it from the list of windows on the 
Window menu. 

 If only one window is open, the Hide option is unavailable 
because you must have at least one window visible at any 
time. 

 

Window > Cascade 
This layers all open windows so that the title bar of each window is 
visible. 

 
Click on the Maximise button on a Cascaded window to revert to a 
single window display. 

 
 



 

PowerSHAPE 2015 R2 Reference Help Menus • 169  

Window > Tile Vertically 
This displays open model windows vertically so they are all visible 
within the graphics area. The sizes of each window depends on the 
number of windows open. 

 
You can resize and move tiled modelling windows. 

Click the Maximise  button on a tiled window to revert to a single 
window display. 

 



 

170 • Menus PowerSHAPE 2015 R2 Reference Help  

Window > Tile Horizontally 
This displays open modelling windows horizontally so they are all 
visible within the graphics area. Their individual sizes depend on the 
number of windows open. 

 
You can resize and move tiled modelling windows. 

Click the Maximise  button on a tiled window to revert to a single 
window display. 

 

Window > Close 
This closes the active window. If it is the last open window for the 
model, the model will also be closed. This is the same as selecting 
File > Close. 

 If there are any unsaved changes, a warning dialog is displayed. 

 If you have not made any changes, the model is closed 
immediately. 

 

Window > Notes 
This creates a drawing with predefined views and a title block. 

For further details, see What is a Notes drawing? 
 

Window > Individual graphics windows 
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All open windows are listed at the bottom of the Window menu. The 
tick next to the name of a window indicates the current active 
window. 

 To select another window, select the Window menu and click the 
name of the window you want to make active. 

 Use ALT W + number as a shortcut to access a particular 
modelling window. For example: 

ALT W 1 will display window 1 

ALT W 2 will display window 2 

ALT W 0 will display window 10 
 

Help menu 
The Help menu displays the tools related to the on-line help system. 

 
Contents and Index (see page 172) 

What's New (see page 172) 

Getting Started (see page 172) 

Learning Assistant (see page 172) 

Tutorials (see page 174) 

PowerSHAPE updates (see page 174) 

PAF updates (see page 174) 

PowerSHAPE newsletter (see page 174) 

User Forum (see page 174) 

Delcam on the Web (see page 175) 

About (see page 176) 
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Help > Contents and Index 
Select this option to display the contents and index of the help file. 
The right hand frame displays the welcome page and provides links 
to further information about the program and the on-line tutorials. 

 

Help > What's New 
Use this option to view details of new features in the latest release. 
The What's New is displayed in one of the following ways: 

 If full documentation is not installed, the What's New will appear 
in the browser window. 

 If full documentation is installed, the What's New will appear in a 
new, floating window. 

 

Help > Getting Started 
Select this option to display the browser. Use the browser tabs to 
select the type of help you require. 

 

Help > Learning Assistant 
This displays and removes the Learning Assistant window. 
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The Learning Assistant lists common PowerSHAPE tasks. A series of 
drop-down menus provide interactive help as you work through the 
tasks. The help is context sensitive and will update automatically as 
you use the program. 

You can also use the Learning Assistant's drop-down menus to 
execute a command. 

To create a single line using the Learning Assistant: 
1 In the Learning Assistant window, click the Creating Objects drop-

down menu. 

 
2 Click the Lines button. This will display a new list of options.  
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3 Click How? to see details about creating a line.  

4 Click the Single line  button and move the cursor into the 
graphics window to create the line. 

 

Help > Tutorials 
Tutorials is a free add-on module. If you are using a non-English 
version of PowerSHAPE, the tutorials may be displayed in English. 

 

Help > Check for PowerSHAPE updates 
Use this option to check the Product Download site so that you can 
download the latest release version of our products. 

 

Help > Check for PAF updates 
Use this option to check the Product Download site for a new PAF to 
download. To check for a PAF updated you need to be connected to 
the internet and have a valid licence file. 

 

Help > Subscribe to the PowerSHAPE newsletter 
This generates an email using your default mail tool. When you click 
Send, your email address is added to the email distribution list for 
the PowerSHAPE newsletter. 

 

Help > Visit the User Forum 
This links to the Power Solution User Forum on www.delcam.com 
(http://www.delcam.com). 

http://www.delcam.com/
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The User Forum is intended for new and established users to join 
and participate in user discussions to share ideas and experiences of 
PowerSHAPE or other Power Solution products. 

 
 

Help > Delcam on the Web 
This gives options to quickly access our website (providing you have 
internet access from you computer). 

 
PowerSHAPE Home Page — Select this option to display the product 
home page www.powershape.com/powershape/powershape.htm 
(http://www.powershape.com/powershape/powershape.htm). This 
includes news and information about the software. 

Delcam Home Page — Select this option to display the Delcam home 
page www.delcam.com (http://www.delcam.com). This includes and 
information on all Delcam products. 

 

http://www.powershape.com/powershape/powershape.htm
http://www.delcam.com/
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Help > About 
Select this option to display a dialog showing the PowerSHAPE 
version and copyright details. 

The dialog also provides: 

 licence and user information. 

 the language set on your PC and that used by PowerSHAPE. 

 patent information. 

Click OK to close the dialog. 
 

Use the following sections to find information on shortcuts: 

Shortcuts to menu options (see page 176) 

Shortcuts to frequent commands (see page 177) 

Customising menu shortcuts (see page 180) 

Mouse shortcuts (see page 181) 
 

Shortcuts to menu options 
The keyboard can be used to access the menus. Every menu item 
has an underlined letter. 

1 Look at the menu bar and find the menu you wish to access. One 
of its characters is underlined. 

For example, F is underlined for the File menu. 

2 Hold down the Alt key and press the appropriate character to 
display the menu option. 

For example, Alt+f opens the File menu. 

3 Look at the option menu and find the option you wish to access. 
One of its characters is underlined. 

Shortcuts 
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For example, O is underlined for the Open option. 

4 Press the character underlined in your required option. 

For example, O opens the Open dialog. 

If you prefer to use the keyboard, here are some other useful 
controls: 

 Once the Alt key has activated the menus, you can navigate 
using the arrow keys . 

 To accept a menu, press Enter. 
 To do nothing and close a menu, press Esc. 

 

Shortcuts to frequent commands 
The following table lists shortcuts to frequently used commands. 
These shortcuts also appear on the menus alongside their 
respective options. 
Menu option Shortcut* 
File > New Ctrl + n 

File > Open Ctrl + o 

File > Close Ctrl + F4 

File > Save Ctrl + s 

File > Print Ctrl + p 

File > Exit Alt + F4 

Edit > Undo Ctrl + z 

Edit > Cut Ctrl + x 

Edit > Copy Ctrl + c 

Edit > Paste Ctrl + v 

Edit > Paste Special Ctrl + e 

Edit > Select > Clear selection Ctrl + d 

Edit > Select > Select All Ctrl + a 

View > Single (of model) > Top Ctrl + keypad 
5 

View > Single (of model) > Bottom Ctrl + keypad 
0 

View > Single (of model) > Left Ctrl + keypad 
4 
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Menu option Shortcut* 
View > Single (of model) > Right Ctrl + keypad 

6 

View > Single (of model) > Front Ctrl + keypad 
2 

View > Single (of model) > Back Ctrl + keypad 
8 

View > Single (of model) > Iso 1 Ctrl + keypad 
1 

View > Single (of model) > Iso 2 Ctrl + keypad 
3 

View > Single (of model) > Iso 3 Ctrl + keypad 
9 

View > Single (of model) > Iso 4 Ctrl + keypad 
7 

View > Single (about selection) > Top Alt + keypad 
5 

View > Single (about selection) > Bottom Alt + keypad 
0 

View > Single (about selection) > Left Alt + keypad 
4 

View > Single (about selection) > Right Alt + keypad 
6 

View > Single (about selection) > Front Alt + keypad 
2 

View > Single (about selection) > Back Alt + keypad 
8 

View > Single (about selection) > Iso 1 Alt + keypad 
1 

View > Single (about selection) > Iso 2 Alt + keypad 
3 

View > Single (about selection) > Iso 3 Alt + keypad 
9 

View > Single (about selection) > Iso 4 Alt + keypad 
7 

View > Shading > Wireframe F2 

View > Shading > Shaded F3 
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Menu option Shortcut* 
View > Shading > Transparent Shaded F4 

View > Shading > Transparent Shaded Wire F10 

View > Shading > Shaded Wire F11 

View > Shading > Dynamic Hidden Line F12 

View > Look From > Last View F5 

View > Zoom Full F6 

Tools > Model Analysis > Smoothness Shading F7 

Tools > Model Analysis > Undercut Shading F8 

Tools > Model Analysis > Minimum Radius 
Shading 

F9 

View > Blank > Blank Selected Ctrl + j 

View > Blank > Blank Except Ctrl + k 

View > Blank > Blank Toggle Ctrl + y 

View > Unblank Ctrl + l 

View > Refresh Ctrl + r 

Object > Surface > Smart Surfacer Ctrl + t 

Object > Surface > Fillet Ctrl + f 

Object > Curve > Composite Curve Ctrl + h 

Macro > Run Ctrl + m 

Swap individual graphics windows in the 
Window menu 

Ctrl + F6 

Help > Contents F1 

* For the keyboard shortcuts to work, you must have Caps Lock Off 
and Num Lock On. 
Other shortcuts 
Operation Shortcut* 
Bold text Ctrl + b 

Italic text Ctrl + i 

Underline text Ctrl + u 

Diameter character in text Ctrl + Alt + d 

Degrees character in text Ctrl + Alt + s 

Plus/minus character in text Ctrl + Alt + p 
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Operation Shortcut* 
Interrupt current operation Esc 

Exiting a creation mode Esc 

Halt program (after accepting confirmation 
dialog) 

Esc - 3 times 
within 1 
second 

* For the keyboard shortcuts to work, you must have Caps Lock OFF 
and Num Lock ON. 

 

Customising menu shortcuts 
You can create your own shortcuts for menu options. 

1 From the Tools menu, select Customise toolbar. 
2 Use the Menu Shortcuts tab of the Customise dialog to set up 

your own shortcuts. 

 
Menu — Select a menu from the list of the menus that appear at the 
top of the screen. . 

Menu Item — The options for the selected menu. Select the option 
for which you want to create a shortcut. 

Shortcut — The current shortcut for the selected option. If a 
shortcut does not exist, None is displayed in the box. 

Replacement — The shortcut that you want to use for the selected 
menu option. 

Ctrl/Alt/Shift — Turn ON these options if you want to use any of 
these keys as part of the shortcut. 

Key — A list of keys you can use for the shortcut. If none of the 
Ctrl/Alt/Shift keys are selected, you can only choose one of the F 
function keys. If any of the Ctrl/Alt/Shift keys are selected, you can 
choose any alphanumeric character or an F function key. 
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Create — Assigns the replacement shortcut to the select menu 
option. The replacement shortcut now appears in the Shortcut box. 
The new shortcut will also appear next to the menu option. If a 
shortcut already exists, you are asked if you want change its use. 

Remove — Remove the current shortcut for the selected menu 
option. None appears in the Shortcut box. 

Reset — Reset all the shortcuts back to the original shortcuts. 

OK — Close the dialog. 
 

Mouse shortcuts 
The toolbars contain buttons, labelled with icons to indicate the tool 
function. In most cases, these are a quick way of implementing a 
menu option. Simply place the cursor over a button and click the 
left mouse button. 

 Greyed-out buttons cannot be used with the current selection. 
The equivalent menu options will also be unavailable. 

The mouse is often used with keyboard “modifier” keys to increase 
the range of options. These controls are central to using 
PowerSHAPE and therefore are not considered as shortcuts. 

For further details, see Using the mouse. 
 

For further general information on toolbars and flyouts, select one 
of the following: 

 Toolbars overview (see page 182) 

 Flyout overview (see page 192) 
 

Toolbars and flyouts 
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Toolbars overview 
Toolbars are areas of the screen that contain buttons. Click on 
buttons using the mouse to activate the functionality. In most 
cases, toolbar buttons provide shortcuts to options on the menus. 

The Main toolbar (see page 196) is always visible and is displayed 
across the top. 

 
The General Edits toolbar is displayed down the side by default.  

 
This is also where the following toolbars are displayed when you 
select a corresponding object, menu item, or button. 

 General Edits (see page 204) 

 Model Analysis (see page 234) 

 Model Fixing (see page 233) 
 Object Creation 

You can: 

 Display or hide some toolbars according to the functions in use. 
For example the Surface Edit toolbar (see page 202) and the 
Curve Edit toolbar (see page 202), shown in the image below, are 
displayed automatically when corresponding objects are selected. 

 
 Expand some toolbars using the flyout button to display similar 

items or functions grouped together. 

 Pin (see page 183) some toolbars anywhere on the screen, or 
dock them onto another toolbar using their pins to keep them 
visible when you display another toolbar. 
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 Create your own toolbars (see page 186) to contain your 
favourite buttons, menu items, or functions. 

 Display a toolbar as follows: 

1 Right-click on an empty space on any toolbar to display a 
menu of available toolbars. 

2 Select the toolbar that you wish to display from the menu. 

 Display large or small buttons on the toolbars using the Toolbars 
options (see page 86) page of the Options dialog. 

 Reverse the display of the (view and editing) toolbars using the 
Toolbars options (see page 86) page of the Options dialog. 

 Remove some toolbars from the screen by clicking the Close   
button on the toolbar.  

 

Pinned toolbars 
A pinned toolbar is always visible. You can move and reposition it 
anywhere on the screen, or dock it with another toolbar.  

Toolbars that are in their default location have the unpinned  
icon. 

 
You can pin the following toolbars: 
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 General Edit 
 Model Analysis 
 Model Fixing 

 

Using pinned toolbars 
If you have not used pinned toolbars before, pinned toolbars remain 
in their default location in the software.  

If you have already pinned a toolbar, it displays at its last pinned 
position. 

You can: 

 Reposition a pinned toolbar in the graphics area (see page 184). 

 Dock a pinned toolbar with another toolbar (see page 185). 
 

Repositioning a pinned toolbar 
To reposition a pinned toolbar in the graphics area: 

1 Click the pin  on the toolbar you wish to move, for example 
the General Edits toolbar. The whole pin is displayed only when 
the toolbar is in its default position. 
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The pin icon changes to pinned , the toolbar undocks and 
displays in the graphics area ready to be repositioned.  

2 Click on the title bar of the toolbar and drag it to the required 
position in the graphics area.  

3 Click the pin again to return the toolbar automatically to its 
default location. The pin changes back to unpinned . 

The next time you click the pin on the toolbar, the pinned toolbar 
is displayed automatically in the last pinned position. 

 

Docking a pinned toolbar 
To dock a pinned toolbar with another toolbar: 

1 Click the pin  button on the toolbar you wish to move, for 
example the General Edits toolbar. The whole pin is displayed 
only when the toolbar is in its default position. 

 
The pin icon changes to pinned , the toolbar undocks and 
displays in the graphics area ready to be repositioned.  

2 Click on the title bar of the toolbar and drag it over the edge of 
another toolbar. It snaps automatically into the toolbar area. You 
can also dock a toolbar at the edge of the screen. 
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3 Click the pin again to return the toolbar automatically to its 
default location. The pin changes back to the unpinned  
icon. 

The next time you click the pin on the toolbar, the pinned toolbar 
is displayed automatically in the last pinned position. 

 

User-defined toolbars 
A user-defined toolbar is a toolbar that you create to contain your 
favourite buttons, menu items, or functions.  

 Your customised toolbar can contain both menu and toolbar 
items as well as command lines.  

 You can send your user-defined toolbar to other users. 

 You can group or separate options on your toolbar using the 
Customise dialog (see page 189).  

 You can add your own icons and you can customise buttons to be 
added to your toolbar using the Customise Picture dialog. 

Using your personal toolbars 
Use the following sections to create and use your own toolbars: 

Create a user-defined toolbar (see page 186) 

Edit a user-defined toolbar  (see page 188) 

Display an existing user-defined toolbar (see page 188) 

Customise buttons for user-defined toolbars 

Sharing a user-defined toolbar and custom buttons (see page 
191) 

 

Creating a toolbar 
To create a toolbar: 
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1 Right-click on an empty section of any toolbar and select 
Customise toolbar from the menu.  

 
The Customise dialog (see page 189) is displayed. 

2 On the Toolbars tab define your toolbar and select the items you 
want to add.  

3 Click Add to add each new item to the toolbar. 

4 Use the buttons on the dialog to order and organise the toolbar 
items. 

The example below describes adding a block primitive from the 
surface creation toolbar to a new custom toolbar. 

 Select a toolbar and enter a new name, such as Surface items. 

 Select the Button Size size from: 
 Large 
 Small 
 As Options Page 

 For the Type, select Toolbar. 

 Select the Menu/Toolbar that contains the item you want to add 
to your toolbar, such as Surface/Solid Creation. 

 Select the Item to add, such as the Block Primitive  button. 

 Click Add to add the block to your toolbar.  

 Added items, for example the Block Primitive button, are 
displayed in the added items list.  
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 Click OK. 

 
 

Edit a user-defined toolbar 
1 Select Customise toolbar from the context menu, displayed when 

you right-click on an empty section of any toolbar. 

 
2 Select the Toolbars tab on the Customise dialog (see page 189). 

3 Select the toolbar you want to edit from the Toolbar drop-down 
list. 

4 Make your changes. 

5 Click OK. 
 

Displaying an existing user-defined toolbar 
1 Select View > Toolbars > Custom. 
2 Select the toolbar you want to display. 
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Customise dialog - Toolbars 
Use this dialog to define up to four customised toolbars. 

 
Toolbar — Enter a new name for a new toolbar or select an existing 
user-defined toolbar from the list. You can define up to four 
toolbars. 

Type — Select from the following: 

 Menu — Select this option to add a menu item to your toolbar 
and select the menu from the Menu/Toolbar list. 

 Toolbar — Select this option to add a toolbar item to your toolbar 
and select the toolbar from the Menu/Toolbar list. 

 Command — Select this option to enter your own Command and 
Description to be added to your toolbar. 

Menu/Toolbar — Select the menu or toolbar that contains the option 
you want to add to your new toolbar. 

Item — Select the menu option or toolbar button that you want to 
add to your new toolbar. 

Add Group — Click this button to add a group marker. The group 
marker  icon is displayed in the list of added items at the right of 
the dialog. A group marker shows the beginning of a group of 
buttons, menu items, or commands. On the toolbar, the group 
marker is a toggle button: 

 Hide Group — Click this button to contract the items in the 
group. 

 Show Group — Click this button to expand the items in the 
group. 

Add Separator — Click this buttom to add a separator marker to 
divide up your toolbar items. The separator marker  icon is 
displayed in the list of added items at the right of the dialog. 
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Add Gap — Click this button to add a small space between items on 
the toolbar. A gap is displayed in the list of added items at the right 
of the dialog. 

Add — Click this button to add the selected Item to the toolbar. The 
item is displayed in the list of added items at the right of the dialog. 

 Drag Crosshairs — Click and hold the mouse button and drag the 
crosshairs over a toolbar button. The button is added automatically 
to custom toolbar and is displayed on the dialog. 

 Remove — Click this button to remove the item selected in the 
added items list from your toolbar. 

 Move the item up the menu — Click this button to move the 
selected item up the order of items on the toolbar. 

 Move the item down the menu — Click this option to move it down 
the order of items on the toolbar. 

 Change button icon — Click this button to change the icon for the 
button selected in the added items list. The Customise Button dialog 
(see page 190) is displayed. 

 

Customise Button dialog 
Use this dialog to: 

 enter text to display as the item's button. 

 select a picture to be displayed as the item's button. 

 select a picture to edit or customise using the bitmap editing 
functionality on the Customise Picture dialog  
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 change the description of a command. This option is displayed 
only if you have selected Command from the Type list. 

 
Text — Select this option and enter text to be displayed as a button. 

Picture — Select this option and select an icon to be displayed as a 
button. 

Customise — If selected, the Modify button is displayed. 

Modify — Click this button to display the selected picture in the 
bitmap editor on the Customise Picture dialog to customise the 
picture before adding it to a user-defined toolbar.  

Command — The command is displayed and you can edit it. 

Description — The description for the command is displayed and you 
can edit it. 

 

Sharing a user-defined toolbar and custom buttons 
User-defined toolbars have a name in the format CustomToolbarX. 

Custom buttons have a name in the format ToolbarX_PictureY.bmp. 

To send a user-defined toolbar and its buttons to another user: 
1 Find the user-specific files. They are stored in xxxx\PowerSHAPE 

where xxxx is one of the following: 
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 C:\Documents and Settings\[username]\Application Data    (XP 
installation) 

 C:\Users\[username]\AppData\Roaming\   (Windows 7 and Windows 
8 installation) 

 the location that is indicated by your HOME variable. 

 To find the Local config folder (PowerSHAPE), enter print 
app.paths in the command window. 

2 Select the required files. They include: 
 a file that contains the toolbar, for example CustomToolbar1. 
 one or more button files from the toolbar, for example 

Toolbar1_Picture1.bmp. 

3 Email the files to another user, with instructions to copy the files 
into the folder containing their user-specific files. 

 

Flyout overview 
Access a flyout toolbar using a flyout button. Flyout buttons have a 
small triangle icon in the bottom right corner. There are two types 
of flyout buttons: 

 Red  icon — Flyouts with a red icon contain mode buttons. 
Right-click on the flyout button to display the flyout toolbar. 
Select a mode button to display the buttons for the mode on the 
toolbar. 

For example, if you select the Model Fixing  mode button 

from the General Edits  flyout, the toolbar displays the model-
fixing buttons.  

 You can cycle through the available modes by repeatedly 
clicking the flyout button. 

 Black  icon — Flyouts with a black icon group similar buttons, 

for example the Offset  flyout. Right-click on the flyout button 
to show the flyout toolbar and click the button you want. The 
most recently used button from the flyout toolbar is displayed as 
the flyout button. 
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Select flyout 

1 Click the Select flyout  button to display the selection and 
selection information options. 

 
For further details, see Selecting objects. 

 If you move the cursor over the Select flyout button, selection 
information is displayed as a Tooltip 

 

General editing flyout 

1 Click the General Edits  button to display the General Editing 
flyout 

 
2 Click one of the buttons on the flyout. The appropriate editing 

toolbar will be loaded. 

 General edits (see page 204) 

 Model fixing (see page 232) 

 Model analysis (see page 234) 
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Style toolbar 
This is displayed when you do one of the following: 

 Select Style from the Toolbars options of the View menu. 

 Select Style Toolbar from the Item colour drop-down menu (Main 
toolbar). 

 
You can use the Style toolbar to change: 

 the style of a selected object. 

 the default creation style of an object. 

 
For further details, see View > Toolbars > Style (see page 1). 

 

Annotation toolbar 
This combines the following tools and options when used in Drafting 
mode, 
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 — Text 

 — Drawing 

 — Dimensions 

 
The Annotation toolbar is also available when in Modelling mode but 
some drafting options, such as symbols and hatching, remain 
unavailable outside Drafting mode.  

To display the Annotation toolbar: 

1 Select Annotation  from the main toolbar.  

 
The Text Editor toolbar displays automatically. 
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2 Select the option you require from the toolbars. If you select a 
dimensioning or balloon option from the Annotation toolbar, the 
text options will be supplemented with the appropriate balloon or 
dimension options. 

For further details, see Balloon toolbar and Dimension toolbar. 
 

Main toolbar 
This toolbar is always visible and includes the following sections: 

 Model and file management. 

 Standard editing. 

 Modelling options. 

 Object creation. 

 The model management and standard editing sections can be 

collapsed and expanded by clicking on the toggle  button. 

Model and file management 
All the following options have corresponding commands on the File 
menu. 

 New (see page 8) — Click this button to open a new model.  
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 Open (see page 8) — Click this button to open an existing 
model.  

 Import (see page 20) — Click this button to import data into 
the model.  

 Save (see page 8) — Click this button to save the active 
model.  

 Print (see page 10) — Click this button to open the Print 
dialog to print the model.  

Standard editing 
All the following options have corresponding commands on the Edit 
menu. 

 Cut (see page 23) — Click this button to cut the selected 
objects from the model. 

 Copy (see page 23) — Click this button to copy the selected 
objects from the model.  

 Paste (see page 24) — Click this button to paste cut or 
copied objects into the model. 

 Paste Attributes (see page 25) — Click this button to paste 
attributes from one object to another.  

 Delete (see page 29) — Click this button to delete the 
selected objects.  

Modelling options 

 Undo — Undo the last command. This can be used with 
active dimensions to undo the last dimension change. When you 
have finished using active dimensions, Undo (see page 22) will 
undo all changes, rather than individual changes. 

 Redo — Reverse the last Undo command. Redo (see page 
23) can be used with active dimensions to redo the last 
dimension change. 
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 Item colour — Select the item colour using the colour palette 
that is displayed. When you hover over a colour selectors, the 
RGB value for the colour is displayed as a tooltip. The current 
colour for new objects is shown on the button. You can also 
display the style (see page 194) toolbar using this option. 

 Modelling/Drafting Mode — Select an option from this flyout 
to enter the Drafting (see page 165) mode and display the 
Drafting options on the toolbar. If Delcam Drafting it is not 
licensed or you have chosen to start PowerSHAPE in Estimator 
mode, you enter the Delcam Estimator instead. 

Object creation 
The following object creation options are displayed on the main 
toolbar. When you select one of these buttons, the corresponding 
toolbar is displayed. 

 Workplane 

 Line 

 Curve 

 Arc 

 Annotation (see page 194) 

 Surface 

 Solid 

 Feature 

 Assembly modelling (see page 199) 

 Wizards 
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Assembly toolbar 
Click the Assembly  button to display the Assembly toolbar. 

 
 

Drafting toolbar 
Click the Modelling Mode  button (Main toolbar). 

 This is the same as hovering over  and selecting  from 
the flyout. For further details, see Flyout overview (see page 
192). 

 
The Drawing Selector dialog and the drafting toolbar are displayed. 

 
For further details, see Entering Drafting mode. 
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Views toolbar 
This provides options to change the view. The toolbar below shows 
the options that are available from each flyout. 

 
For further details, see View > Toolbars > Views (see page 142) 

 

Cloud editing toolbar 
Use the Cloud editing toolbar to edit the imported cloud: 

 
Use the following options to edit the point cloud. 
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Use Box select to select cloud points by dragging a 
box around them. 

  
Use Discrete lasso to select points by drawing a 
discrete lasso around them. 

 
Use Continuous lasso to select points by drawing a 
continuous lasso around them. 

 
Use the Filter button to filter the number of points in 
the selected cloud. 

 
Use Generate Mesh to create single mesh from one or 
more selected clouds, or cloud points. 
When generating a mesh from a point cloud, you can 
cancel the generation by pressing Esc. 

 
Use Generate Curve to create a curve from a selected 
cloud. 

 
Use Extract selection to extract the currently selected 
points from the current cloud and create a new cloud 
from those points. 
 

 
Use Combine clouds to combine the selected clouds. 
It is the same as selecting Object > Cloud > Combine . 
 

 
Use Colour clouds uniquely to apply a different colour 
to all the selected clouds.  
The colour that is applied to a particular cloud is 
linked to the cloud number; whenever Colour clouds 
uniquely is selected, the clouds will always use the 
same colour. 

 
Reset to default colour applies the default colour (red) 
to every selected cloud 

 
Delete the selected points from the cloud. 

 
 

Use the Acquire Points toolbar to acquire point data from laser 
scanners directly into PowerSHAPE. 

 

 Configure — Click this button to open the Delcam CMMDriver 
Configuration dialog and select a connection protocol. 
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 Connect — Click this button to connect to the device. 

 Options — Click this button to configure the device settings 
using manufacturer specific dialogs. 

 Delete Sweep — Click this button to delete the most recent 
sweep. 

 Colour Sweeps — Select this button to assign a distinct colour 
to each sweep. 

 Lock View — Select this button to lock the view in the current 
position. 

 Information — Select this button to open the Sweep Information 
dialog and display the number of sweeps, points and scanlines. 

The status of the device is displayed on the toolbar: 

 Not Connected (red) 

 Acquiring (yellow) 

 Connected (green) 
 

Mesh surfacing toolbar 
Use the buttons on the Mesh surfacing toolbar to create a surface 
from selected triangles. 

 
 

Surface/Curve editing toolbar 
This toolbar appears when you do one of the following: 

 double-click a Power Surface. 

 double-click a curve which is not part of a surface. 

The options that are displayed reflect the object you are editing. 

The Surface edit toolbar looks like this: 
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The Curve edit toolbar looks like this: 

 
 

Mesh editing toolbar 
Modify your meshes using the buttons on the Mesh editing toolbar. 

 
 

Trim region editing toolbar 
The Trim region editing toolbar contains options for Pcurve mode  

and Boundary edit mode . Click to switch between the two 
modes. The options that are displayed on the toolbar are 
determined by the type of trim editing that is selected. 

For further details, see How do I trim surfaces? 
 

Boundary editing toolbar 
The Boundary editing toolbar enables you to edit the selected trim 
boundaries on a trimmed surface. The toolbar is displayed when the 

Boundary edit mode  option is selected on the Trim region editing 
toolbar. 

  
 



 

204 • Toolbars and flyouts PowerSHAPE 2015 R2 Reference Help  

Pcurve editing toolbar 
The Pcurve editing toolbar provides tools for editing pcurves. The 

toolbar is displayed when the Pcurve edit mode  option is 
selected on the Trim region editing toolbar. 

  
 

General Edits toolbar 
The General Edits toolbar is automatically displayed when the 
program is started. 

Use the buttons on this toolbar for standard editing functions that 
apply to all object types. Each object type has functionality for 
editing that is specific to the object type. 

 
For further information on specific general editing functionality see: 
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 Limit interactive (see 
page 207) 

 Limit point (see page 207) 

 Limit cut (see page 
207) 

 Limit selection (see page 
206) 

 Move (see page 207)  Stretch (see page 208) 

 Place wireframe (see 
page 208) 

 Align items (see page 208) 

 Best-fit-align (see 
page 211) 

 Rotate (see page 208) 

 Mirror (see page 
213) 

 Offset (see page 213) 

 Variable offset  Scale (see page 218)  

 Pattern of objects 
(see page 219) 

 Nest items (see page 219) 

 Project (see page 
231) 

 Project point (see page 232) 

 Morph objects (see 
page 232) 

 Morph to Cloud or 
Mesh (see page 232) 

 Sculpt meshes (see 
page 232) 

 
 

Editing faces 
Some General Edit operations can be used on faces of a solid as part 
of the Direct Modelling functionality. Examples of using the following 
can be found in the relevant sections of the Direct modelling 
manual: 

 Move 

 Rotate 

 Mirror 

 Offset 
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 Scale 

When used to edit faces, Next Solution and Previous Solution buttons 
are added.  

 
If there is more than one possible solution, use these buttons to 
select the required solution  

 

Edit sub-components 
Edit sub-components (see page 36) enables you to move, rotate, 
scale, and offset laterals and longitudinals rather than their parent 
surface. The type of item and sub-item that appear on the toolbar 
depend on your selection (wireframe, surface, or solid). 

 

Limit selection 

1 Click Limit selection  to display the Limit Selection toolbar. 

 
2 Use the following options on the toolbar to limit a selection of 

objects to a 'cutting' object: 

  Keep original 

  Cutting object deselected/selected. 

  Cutting object unlocked/locked. 

 Create and use polygon as cutter. 

 Create and use composite curve as cutter. 

  Keep both. 

 Trim both. 

 Next solution. 
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 Limit selection flyout. Repeatedly clicking on this button 
cycles through the following limit selection modes: 

 Limit selection. 

 Project along the axis normal to the principal plane. 

 Project along the axis normal to the view. 

 Project along surface normal. 

 Limit surface to a curve. 

For further details, see Edit > General Edits > Limit selection. (see 
page 37) 

 

Limit point 

The Limit point (see page 52)  button trims or extends objects to 
a point. 

  
 

Limit cut 

The Cut object (see page 54)  button enables you to cut lines, 
arcs, and curves into smaller pieces, using the Limit cut dialog. 

 
 

 

Limit interactive 

The Interactively Limit Wireframes (see page 55)  button enables 
you to remove portions of wireframe objects by selecting them. 

 

Move 

Click the Move  button to display the Move toolbar. 
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The toolbar is also displayed when you select Edit > General Edits > 
Move (see page 56). 

Use the options on the toolbar (see page 56) to move or copy an 
object or a group of objects by a specified offset or to a specified 
position. When switching between Move, Rotate, and Scale 
operations, the origin point is preserved. 

 

Stretch 

Click the Stretch (see page 59)  button to stretch wireframe 
objects. 

 

Rotate 

Click the Rotate  button to turn selected objects about the axis 
normal to the principal plane of the current workspace. It also 
enables you to create duplicate objects spaced around the rotation. 

 
This toolbar is also displayed if you select Edit > General Edits > 
Rotate (see page 63). 

When switching between Move, Rotate, and Scale operations, the 
origin point is preserved. 

 You can use the Rotate button to edit faces as part of Direct 
Modelling functionality.   

 

Place wireframe 

Use the Place Wireframe (see page 61)  button to place a curve 
between two points on a single object or on separate objects. 

 

Align items 
Use the Align items dialog to adjust the alignment of the model. 
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1 On the General Edits toolbar, click the Align Items  button to 
display the Align Items dialog. 

 
2 Select the alignment object . The alignment object is that 

object that moves. 

3 Select the fixed object . The fixed object does not move. 

 
If necessary, you can split the items into separate views by 

clicking the Split view  button. This button is only available 
when you have selected the alignment and fixed items. 

Clicking the Split view button enables the following buttons on 
the dialog: 

 Link views — Click this button to link the Alignment Item 
view and Fixed Item view together. You can pan, rotate, 
and zoom the views together when they are linked. This 
button is only available when you are using the split view. 

 Match views — Click this button to pan and scale the 
alignment view to match the fixed view. This button is only 
available when you are using the split view. 

 Preview — Click this button to display a preview of the 
alignment in a single view. This button is only available 
when all of the alignment points are defined. 
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4 Select points on the alignment and reference object to define 
sets of points. You must define at least three sets of points; the 
information panel tells you that you have sufficient points 
selected. 

Choose points in one of the following ways: 

 all points on alignment object followed by all points on the 
reference object. 

 pairs of points, one on the alignment object and one on the 
reference object. 

 
5 Adjust the point selection as appropriate. You can delete existing 

alignment points by clicking on them. 

The cursor changes  to indicate that you are hovering over a 
point that can be deleted. 

6 Click Apply. The alignment object will move so that the selected 
points are aligned.  

 
Continue to select objects and points to adjust the alignment as 
necessary. 
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7 Click OK to accept the changes and close the dialog. 

 
 

Best-fit align 
Use Best-fit roughly aligned items to align multiple items that are 
already roughly aligned. The example shown below has been 
roughly aligned using Align items, but the nose is not aligned 
correctly. 

 

1 On the General Edits toolbar, click the Best-fit items  button 
to display the Best-fit Align dialog. 

 
2 Select the alignment items . Thes are the items that move.  
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3 Select the fixed item . The fixed item does not move.  

 
4 Click Apply. The alignment item moves to align with the fixed 

item. In this example, the alignment is satisfactory; if necessary 
adjust the deviation and mean error values to improve the 
alignment. 

 
5 Click OK to accept the changes and close the dialog. 

 

 You can select multiple items before clicking the Best-fit items 

 button (General Edit toolbar).  

 One item is selected automatically to be the fixed item; you 
can change this selection if required.  
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 The items to be aligned are all highlighted in the primary 
colour; the fixed item is highlighted in the secondary colour 
(purple in the 2015 R2 default colour scheme) 

 

Mirror 

Click the Mirror Items  button to reverse the original or make a 
reversed copy of the original. Alternatively select Edit > General Edits 
> Mirror (see page 69) from the menu. 

 

Use Mirror  to: 

 Replace the original with a reversed copy. 

 Keep the original in place and position the reversed copy as 
required. 

 Mirror can be used to edit faces as part of Direct Modelling 
functionality.  

 

Offset 

Click the Offset  button to move or copies objects by a set 
distance along the object normal. Alternatively, select Edit > General 
Edits > Offset (see page 73) from the menu. 

 
Undo and redo operations are available when the toolbar is 
displayed. In previous versions, clicking Undo closed the offset 
operation and removed the toolbar. 

 Offset can be used to edit faces as part of Direct Modelling 
functionality. 

 

Variable Offset 

Use the Variable Offset  button to create variable offsets for 2D 
curves, composite curves, curves on surfaces, and single laterals 
and longitudinals. 
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To use Variable Offset: 
1 Select the curve. 

2 Click the General Edits  flyout to display the General Edits 
toolbar. 

3 Right-click the Offset  button to display the Offset flyout. 

4 Click the Variable Offset  button. 

5 Use the Variable Offset dialog (see page 214) to create the 
required offsets. 

 

Variable Offset Wireframe dialog 
Use this dialog to create the required offsets. 

 
Points — All the points on the selected curve are listed. This enables 
you to select individual points to offset. 

Offset — Enter the offset value for the points selected in the Points 
list. 

Insert — This enables you to insert extra points into the offset 
curve. For example, if you enter 2.5, an imaginary point is inserted 
halfway along the base curve between points 2 and 3. It is then 
mapped to the offset curve. This is the parametric value half way 
between points 2 and 3. 

Lock curve points — When you enter a value in the Offset text box, 
the offset point is locked and the Lock curve points option is selected 
automatically. Deselect the Lock curve points option to unlock an 

offset point. This option is used with Free the unlocked points . 

Free the unlocked points  — This releases unlocked points so they 
offset linearly between the locked points. 
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In the following example, points 1 and 2 are locked and offset to 
a value of 5. Point 5 is locked and offset to a value of 3. 

 

When you click the Free the unlocked points  button, the 
unlocked points 3 and 4 offset linearly between the locked 
points, as shown below. 

 
Free tangents — Select this option to free the tangent directions and 
its magnitudes at the offset points on the offset curve. 

In the following example, point 1 on the base curve is offset to 
the value of 10 and point 4 is offset to the value of 50. Selecting 

Free the unlocked points  has freed points 2 and 3 to be offset 
linearly. 

With Free Tangents selected, the offset curve is not straight and 
the tangent direction remains aligned with the base curve. 
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With Free Tangents deselected, the tangent directions and its 
magnitude are freed. The tangent direction now aligns with the 
offset curve that has straightened. 

 

 
Round corner — Select this option to create a rounded corner at 
selected points with a discontinuity. 

This is not available for offsetting laterals or longitudinals. 

In the following example, an extra point is inserted automatically 
at the point of discontinuity, creating 4 points on the curve. This 
extra point is displayed in the Points list and can be offset in the 
same way as the other points. 

 

 
Label curve points — Select this option to display point labels. 

Offset along surface normal — Select this option to offset the point in 
the direction of the surface normal. It is available for points that 
have dependencies on the surface. 

To use the offset option: 
1 Select the point on a surface curve. 

2 Select the Offset Along Surface Normal option.  
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Enter the offset value. The point offsets in the direction of 
surface normal. 

 

Offsetting points on a single surface 
To offset points on a single surface: 
1 Select the surface you want to offset. 

2 Click the General Edits  flyout to display the General Edits 
toolbar. 

3 Right-click the Offset  button to display the Offset flyout. 

4 Click the Variable Offset  button. 

5 Use the options on the Variable Offset Surface dialog (see page 
217) to select the four points on the outer boundary of the 
surface that you want to offset. 

 
 

Variable Offset Surface dialog 
Use the options in the dialog to select four points on the outer 
boundary of the surface that you want to offset. For further details, 
see Offsetting points on a single surface (see page 217). 

 
Offset position — Select each Offset Position and click on the outer 
boundary of the surface to position the four points, as shown in the 
example below. The  changes to . 
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Enter the offset distance for each point in the text box alongside 
each Offset position. 

 
Preview — This displays the results of the offset on the surface. 

OK — This creates the surface offset with the distances specified. 

 
 

Scale 
Use the options on the Scale toolbar to make objects larger or 
smaller. 

Click the Scale  button to display the Scale toolbar. 

 
You can also display the toolbar by selecting Edit > General Edits > 
Scale (see page 78). 

Use toolbar to resize objects in the following ways (see page 78): 

 Using Uniform (see page 79) scaling. 

 Using Non-uniform (see page 80) scaling. 

 To a Projected Volume (see page 81). 
 To an Enclosed Volume. Scale the volume enclosed by the 

selected solid and face of the active workplane. Enter the 
required volume in centilitres. 

When switching between Move, Rotate, and Scale operations, the 
origin point is preserved. 

 Scale can be used to edit faces as part of Direct Modelling 
functionality.   
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Pattern of objects 

Use the Pattern of objects (see page 86)  button to create 
rectangular, honeycomb, and circular patterns of objects and to 
create patterns on wireframe items. 

 

Nesting 
Use the Nesting dialog to arrange PowerSHAPE objects on the 
principal plane of the active workplane (see page 224).  
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Sheets 
Use this section to select the geometry of the sheet that is to be 
included in the nesting. 

 
The Usage column on the Nesting dialog displays the area occupied 
by parts nested on all the instances of the sheet. 

As you move the mouse cursor over a sheet in the current model, 
the area usage for a particular sheet instance is shown below the 
list of sheets. This is useful when you have several sheets on a 
model. 

 
Use the following buttons to add and remove sheets from the list: 

 Add Sheet — Register the selected geometry as a sheet for 
nesting and add into the list. 

 Remove Sheet — Remove the selected sheet from the list of 
sheets registered for nesting. 

More options — If a sheet is selected in the list, click this button to 
display additional nesting options for the selected sheet. 
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Nesting direction — Select the required nesting direction from the 
list. 

Starting corner — Select the starting position for the nesting from 
the list. 

Grain direction — Select the grain direction from the list 

Parts 
Use this section to select the parts to nest on the sheet. 

 
 Add as single — Add the selected geometry to the Parts list as 

single part. You can use this button to register multiple pieces of 
geometry as a single part.  

 A workplane can be registered with the part for nesting. This 
is useful if you want to machine the multiple parts, because 
the workplanes can be used to copy the toolpaths. 

 Add as separate — Add the selected geometry to the Parts list as 
multiple parts. You can use this button to register multiple pieces of 
geometry as multiple parts. 

 Remove part — Remove the selected part from the Parts list. 
The Parts table includes the following columns: 

Border — Specify the clearance around a part. 

Quantity — Specify the minimum number of parts to nest. 

Nested — PowerSHAPE indicates the number of parts that were 
nested when the last nesting operation was applied. 

 Choose boundaries — When an item has multiple boundaries (see 
page 230), click this button to select: 

 the boundary that is used as the outline of the part for nesting 
purposes. 

 boundaries that are simply transformed along with the part. 
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More options — If a part is selected in the list, click this button to 
display additional options for the selected part. 

 
Border — Specify the clearance around a part. 

Quantity — This is the minimum number of items of this type that 
the PowerSHAPE ,will attempt to nest on the sheets. When this 
number of items has been nested, PowerSHAPEwill attempt to 
nest more items, up to Maximum quantity. 

Part rotation— Select the part rotation method from the drop 
down list. 

Rotation angle — Enter a part rotation step angle, or a list of 
angles separated by spaces. 

Maximum quantity — Enter the maximum number of that part 
that can be nested. Alternatively, use the arrows  to set the 
value. Use a priority of 1 to indicate that the part has the highest 
priority. 

Part priority — Enter the priority of the part. Alternatively, use 
the arrows  to set the value. 

Mirroring — Select an option to specify if the part can be mirrored 
and the mirroring method to be used. 

Grain direction — Select the grain direction of the part from the 
drop-down list 

General options 
Use this section to specify the general parameters that are to be 
used when nesting the parts. 

 
Part distance — Use these buttons to select how the distance 
between the parts is to be calculated. 
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 Border to border — Distance between adjacent parts is the 
sum of the part borders.  

 Border to clearance — Distance between adjacent parts is the 
sum of the part borders and the border clearance. 

 Overlapping — Distance between adjacent parts is the largest 
part border. 

 Create copies — Use this toggle button to specify if a copy of the 
original sheets and part geometry should be created. 

 Nesting boundaries — Use this toggle button to specify if the 
nesting boundaries of the sheets and parts should be created. 

More options — Click this button to display additional general 
options. 

 
Sequence parts by — Select the order in which parts with the 
same priority are ordered for nesting.  

By area — Nest parts with the biggest area first. 

By perimeter — Nest parts with the biggest perimeter first. 

Nesting resolution — Specify the accuracy of the nested pattern. 
The actual distance between the parts could be greater than the 
specified value, by one resolution unit. The smaller the 
resolution, the higher is the accuracy of the nesting, but the 
slower it is to calculate the layout. 

Nest parts in holes of larger parts — If this option is selected, parts 
can be nested in the holes within larger parts. 

Prefer nesting in part holes — If some of the nested parts have 
holes and this option is selected, PowerSHAPE will try to nest 
parts in the holes of the previously nested parts. If it isn't 
possible, parts will be nested elsewhere on the sheet. 

 You must select Nest parts in holes of larger parts to 
access this option.  
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Prefer nesting in sheet material islands — If the sheet material 
includes some islands and this option is selected, PowerSHAPE 
tries to nest parts in the holes of the sheet material islands. If it 
isn't possible, parts are nested elsewhere on the sheet. 

 Sheet material islands are holes of locked parts; parts that 
are not nested but stay in the same position on the sheet. 

Nest filler parts up to the nesting height — A filler is a part that is 
included in any space after the other parts have been nested in 
priority order. You define a filler part by setting a maximum 
number of parts.  

 If this option is deselected (default), the minimum number of 
main parts are nested and filler parts are included as required.  

 If this option is selected, the minimum number of main parts 
are nested and filler parts are included only up to the nesting 
height that is determined by the nesting of the main parts.  

Use guillotine cuts — Select this option to align nested parts 
orthogonally so that a guillotine cut can be used to cut across the 
sheet (in either direction), without intersecting the nested parts. 

 

Nesting — an example 
This example shows you how to nest three different parts in a 
sheet. 

 

1 On the General Edits toolbar, click the Nest Items  button to 
display the Nesting dialog 



 

PowerSHAPE 2015 R2 Reference Help Toolbars and flyouts • 225  

2 Select a sheet . 

 
3 Click the Add sheet  button. The sheet is added to the Nesting 

dialog 

  
4 Select a part: Curve 'figure_eight' . 

 



 

226 • Toolbars and flyouts PowerSHAPE 2015 R2 Reference Help  

5 Click Add part . 

 
6 Set the following parameters: 

 Border: 5 

 Quantity: 3 

7 Click More options. 

8 Set the following parameter options for the part: 

 Rotation step angle: 1 

 Part Priority: 1 

 
9 Select part: Curve 'square' . 

10 Click Add part . 

11 Set the following parameters in the parts list: 

 Border: 1 

 Quantity: 2 
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12 Set the following parameter options for the part: 

 Rotation step angle: 1 

 Priority: 2 

 Maximum quantity: 2 

13 Select part: Curve 'filler' . 

14 Click Add part . 

15 Set the following parameters in the part list: 

 Border: 1 

 Quantity: 200 

16 Set the following parameters options for the part: 

 Rotation step angle: 1 

 Priority: 3 
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17 Click Apply. The parts are nested according to the parameters 
that you have selected.  

 
The list in the Parts section of the dialog is updated to show the 
number parts that are nested. 

 
This shows that: 

 all the required Curve 'figure_eight' parts (priority 1) parts 
have been included. 

 one of the Curve 'square' parts (priority 2) parts have been 
included. 

 51 of the Curve 'filler' parts (priority 3) have been included. 
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18 Click and drag the Curve 'square' part. As you move the part, 
overlapping parts turn red. 

 

 You can also rotate a part by selecting it in the graphics 
window and dragging the border outline. 

19 Click Apply to rearrange the parts based on the new position of 
the Curve 'square' part. 
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The number of Curve 'filler' parts that can be nested has 
reduced. 

 

 When you reposition an item manually, the item is locked in 
the new position and any subsequent nesting operations do 
not reposition the part. This is indicated by a red dot in the 
centre of the item. You can unlock a locked part by toggling 
the red dot to green. 

 

Nesting boundaries — an example 
The part to be nested on the sheet consists of of two concentric 
circles.  

1 Select the sheet and click Add sheet. 

2 Select the concentric circles and click the Add as a single part  
button. 

3 Enter 10 as the Maximum quatity to be nested. 

4 Click Apply to nest the parts. 

 

5 Click .  
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6 Click the outer boundary. The boundary turns red, to show that it 
will not be used when nesting. 

 
7 Click  on the Nesting toolbar to leave nesting boundary editing 

mode. The options on the dialog become active. 

8 Click Apply. The parts are re-nested, using the inner circle as the 
boundary. 

 
 

Project 

Use the Project (see page 103)  button to project wireframe 
objects along an axis onto a plane at a particular point. 
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Project point 

Use the Project point  button to project points along the principal 
axis onto a surface or a mesh (see page 104).  

 

Morph objects 

 Morph object(s) enables you to morph the object you are 
editing. 

For further details see Edit > General Edits > Morph object(s) (see 
page 105) 

 

Morph to Cloud or Mesh 

 Morph to Cloud or Mesh enables you to morph the object you 
are editing with respect to a separate cloud or mesh. 

For further details see Edit > General Edits > Morph to Cloud or 
Mesh (see page 105). 

 

Sculpt 
(Available in PowerSHAPE Pro) 

Use Sculpt  to change the shape of meshes and surfaces. This 
functionality is also available by selecting Edit > General Edits > 
Sculpt Meshes. 
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Model fixing toolbar 
Use the tools on the Model Fixing toolbar to fix your model. 

 
Select from the following: 

 Identify badly trimmed surfaces (see page 38) 

 Surface trim region editing 

 Approximate 

 Simplify outside trim 

 Stitch 

 Smart surfacer 

 Orient normals 

 Solid from surfaces 

 Find duplicates 
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 Show open edges in solid 

 Repair solid (see page 40) 
 

Model analysis toolbar 
Use the tools on the Model Analysis toolbar to analyse your model. 

 
Select from the following: 

 Calculator 

 Properties 

 Surface inspection 

 Dynamic sectioning (see page 42) 

 Smoothness shading (see page 45) 
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 Undercut shading (see page 49) 

 Curvature shading (see page 51) 

 Minimum radius shading (see page 53) 

 Thickness shading (see page 54) 

 Solid wall thickness (see page 56) 

 Model compare 

 Model visual difference (see page 57) 

 Comparison analysis (see page 59) (PowerSHAPE Pro licence 
only) 
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