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PowerShape Introduction 
PowerShape is a powerful CAD modelling package, which comprises core modules (wireframes, surfaces, solids, drafting and assembly) plus optional specialised modules. These include Ultimate for Reverse Engineering (meshes), Toolmaker (mold design) and Electrode (Electrode wizard).  

1 To open PowerShape, double click on the desktop icon.  
Once loaded, the screen looks like this: 
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 - Pull-down menus 
 - Main toolbar 
 - Viewing and shading options 
 - Status bar 
 - Command toolbar 
 - Graphics window 

 
PowerShape automatically starts a new empty model. The model name is displayed at the top left corner. The new model is not stored externally. 

 
The model can be saved permanently (recommended) with a more appropriate name and stored to an external directory. One or more previously stored models can be opened within the same PowerShape session. 
At the top of the screen there are a series of pull-down menus.  

 
2 Select the File menu, using the left mouse button. 

 
In the File menu, model files can be created, saved, imported, exported and printed. 
Sub-menus are accessed by clicking on  symbol. 
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If the mouse is held over a button for a short period, a box containing a description of the command (tooltip) is displayed. 

 
To the bottom left of the graphics area is the Levels menu. Entities can be 
assigned to a level for long term, group selections. 

 
At the bottom of the screen are the Workplane and Principal Plane selector, the grid definition, the cursor position, the tolerance and the XYZ position input area. 

 
The Main toolbar  provides access to the Sketch, Workplane, Line, Arc, 
Curve, Annotation, Surface, Solid, Feature, Assembly, and Wizard toolbars. 

 
Beneath the pull-down menus are the Main toolbar buttons . When 
selected, these buttons either open up a dialog or display the relevant 
functions on the Command toolbar  to the left of the graphics window. 

  
This Command toolbar contains all of the main options for creating the chosen main option. 

3 Select the Line creation button , the following toolbar is displayed to the left of the graphics window. 

 
The top two icons are fixed and comprise Selection  General editing 

Model fixing  and Model analysis . 
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 Toolbars 
All the toolbars can be shown or hidden from the View pull-down menu by selecting 
Toolbars and then left clicking on the toolbar name.  

 



1. Introduction  

 Copyright © Autodesk  Autodesk PowerShape 2017   1 - 5 

   PowerShape Options 
The Tools > Options page allows the user to configure PowerShape from the factory 
default settings. The options are stored within several main categories, accessible 
by clicking on the adjacent  symbol. 

 
It is possible to make changes to the factory default settings and store them as the new default settings to be active with subsequent PowerShape sessions. 

1 In Tools > Options >File > Model select Always save and open from outside the 
database, if not already selected.  

 
2 Select Cancel. 
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   PowerShape Help  
PowerShape has an extensive support that can be accessed by either selecting Help from the top menu or by pressing F1 on the keyboard. The  
1 Press F1 on the keyboard to launch the HTML browser window. 

 
The window displayed above is the welcome page and can be accessed by selecting 
the small home  tabbed icon at the top of the window. A number of other options are available to help navigate the information. 

 
 

2 Select the Learning assistant  to access an interactive list of common tasks. 
3 Select Tutorials to access free tutorials which can be downloaded or installed from the installation DVD. 
4 Select Help  to access the complete online reference help which allows you to search by Contents.  



1. Introduction  

 Copyright © Autodesk  Autodesk PowerShape 2017   1 - 7 

 
Topics are listed in the left-hand window and the specific help for a selected item is displayed in the right pane.  
The Hide button can be pressed to hide the topic list. The button then changes to 
Show which again redisplays the topic list. 

5 Close the browser window using the button at the top right corner. 
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  Mouse buttons 
Each of the three mouse buttons performs a different operation in PowerShape. By using the ALT, Ctrl or Shift key, these operations can be extended. 

        Left Mouse button 1: Picking and selecting 

 
This button is used for selecting items off the Main pull-down menus, entering data, 
and selecting parts of the model. 

         Middle Mouse button or wheel: Dynamics 

 
Zooming: Hold down the Ctrl key and Right button and move the mouse up and down to zoom in and out of the view. Hold down the Ctrl, Shift Key and middle button/wheel to select a framed area to zoom into. 
Panning: Hold down the Shift key with the right button moving the mouse, to move the view across the component.  
Rotating: Hold down the middle button/wheel and move the mouse. A tracker 
ball appears at the centre of rotation, as does the view orientation axis in the bottom left corner of the screen. If View Spinning is switched on (Tools > 
Options > Views) the view will spin around until the user executes a further mouse click. 
If available, the middle mouse wheel can be used to scroll text. 
 

            Right Mouse button 3: Special Menus 

 
When this button is held down a local menu is opened. The contents of the menu depend on the entity selected. For example, when the cursor is over a line, the Line menu appears; when the cursor is in the graphics area, the View menu appears. 
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The linked image cannot be displayed.  The file may have been moved, renamed, or deleted. Verify that the link  points to the correct file and location.

   Exercise 1: Dynamic mouse controls. 
In this exercise you will Import an existing, stored model and change the views 
using the dynamic mouse options. 

1 From the main menu select File > Open or  to open an existing 
PowerShape model (.psmodel). 
 

2 Open the model: 
.....\PowerShape_Data\pump housing.psmodel 

 
When a model is imported into a new PowerShape session, the default view is down the Z-axis. 
The model has opened in wireframe view as originally saved. Preferred shading options on opening models can be changed from Tools>Options>View>Views 

 
The view toolbar, on the right of the PowerShape window contains three main areas 
 Views. 
 Dynamics. 
 Shading. 

3 Select the view Iso 1 , the model is now displayed using the first of 4 isometric views. Surface or Solid entities of the model can be displayed as shaded if required. 
4 From the views toolbar open the Shaded view pull out menu.  

5 From the available options pick Shaded View.  
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The surfaces have been shaded to show the full extent of the surface area. The wireframe from which it is constructed can also be shown if required. The model can be rotated dynamically so that the user can view the underside detail. 

6 Hold down the middle mouse button and move the mouse to rotate the view to display the underside. 
7 Hold down the Shift key and middle mouse button and move the mouse to position (Pan) the view suitably. 

 When scrolling the middle button (wheel) to zoom, the position of the cursor is the focal point. 

 
The underside can now be seen clearly. There are many different options for viewing the model that you can select. There are also a variety of keyboard shortcuts that you can use. 

 
8 Select View > Single [about selection]. 
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The keyboard shortcuts for the views (and other functions) are listed, such as Ctrl+1 
(Press Ctrl on keyboard then number 1) for the Iso 1 view. By pressing Num Lock on the keyboard, the number pad can be used with the Ctrl key to change the views. 
There is also an enhanced shading option that displays the model in a Perspective view with the lines running to a vanishing point as if on the horizon. 

9 Select Back [+Y]. 

 
Another view is displayed.  
 

   Selecting Views from View Toolbar & View Cube 
 

As well as selecting views from the View menu Toolbar (shown below), you can use shortcut keys, such as Ctrl+5 for Z View from Top (+Z). 
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There is also a View Cube located in the top right hand corner. 

  
 
 
By clicking on the arrow keys we are able to quickly navigate the view of the model. 

 Click on the Home button to return view to Z Top (Z+) 
 

The PowerShape model needs to be closed. In this case it does not need to be saved, as the model has not been altered. 
 All PowerShape help options and keyboard shortcuts are listed in chapter 13 of the training manual. 
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   Selecting Entities 
To be able to perform any edits, individual entities must first be selected.  
If an entity is selected with the left mouse button it will be displayed with a yellow colour. If a box is dragged across a group of entities they will all be selected (The default setting does not require an entity to be completely boxed). 
To select more than one item within a group, hold down the Shift key while selecting individual entities to add to the selection. To toggle a selected item on or off, the Ctrl key is depressed while using the left mouse key to pick the entities. 

The Select flyout (above command toolbar) reveal the following options. 
 

 
 

There are options within this Selection toolbar to enable the user to quickly select all items in the view of a particular type. They are Wireframes, Surfaces, Solids, Surfaces & Solids and components (assembly), meshes and point cloud. 
 

 
 
For more complex models, the selection filter  can be used to discriminate 
entities using a more specific combination of search criteria, such as the type of wireframe, colour, and line style. 
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   Blanking Entities 
If one or more entities are selected, they can be temporarily removed from the graphics area by selecting Blank. This is available from the local menu (right mouse 
click) or selecting the Blank icon  from the Viewing and Shading toolbar. 
This command is useful when you want to temporarily undraw some objects from the current view where Levels is not appropriate. This is because, a level may contain objects you don’t want to be hidden and/or changing the levels may affect the model’s logical structure. 
Blanking allows you to remove selected objects from the screen. They are not deleted, but merely hidden and can be unblanked when required. This allows you to concentrate on the objects you need to work on without being hindered by other irrelevant entities. 
If it is required to temporarily keep the selected entities from the graphics area and hide the rest then Blank Except is applied. To return all entities back to the graphics area, Unblank is applied from the screen menu. Blank Toggle allows the user to 
toggle between the two views of Blanked and unblanked entities. 

 When using often, the shortcut keys are useful 
 
Ctrl+J Blank 
Ctrl+K Blank Except 
Ctrl+L   Unblank 
Ctrl+Y  Blank Toggle 
 
Each will be demonstrated using the current model 
 
1 Select the upper surface of the pump housing and its outline will change to a yellow colour. 

  
2 Select Ctrl+J to temporarily remove the upper surface from the graphics area as shown to the right (above). 
3 Select Ctrl+L to return the blanked surface back as the selected item. 

4 View the model from Left (–X) , then box select the flange surfaces as shown. 
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5 Select Ctrl+K to keep these surfaces and temporarily hide all others. 

6 View in ISO 1.  

 
7 Select Ctrl+Y to blank toggle and view the blanked surfaces 

 
8 Select Ctrl+Y to toggle the view again. 
9 Finally select Ctrl+L to return and show all surfaces. 
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10 Select File > Close. 

 
A message box appears asking if it is required to save the changes. In this case no changes have been made to the model. 

11 Select No. The current model is now close 
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2. Wireframe Modelling 

Introduction 
PowerShape can generate Sketches, points, lines, arcs, and curves in 2D and 
3D space, which are collectively known as Wireframes. These wireframes 
have several functions, which include being the basic framework for several 
types of surfaces and solids, and as the drawing entities in Delcam Draft. 
Wireframes can be exported in a variety of file formats for use in other 
software products. 

The buttons for generating Wireframe objects are located within the main 
toolbar. 

 

 

 Select Line from the Object menu.  

 

 

                The following Line creation options are available. 

 Single Lines 

 Continuous Lines 

 Rectangles 

 Polygons 
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 Selection Box  

 Create the shortest line between two selected objects 

 Chamfers 

 Untrimmed chamfers 

 

 Select Arc from the Object menu.  

 

 

The following Arc creation options are available. 

 Full arc (circle) 

 Create an arc through three points/items 

 Create an arc through centre, radius and span 

 Fillet arc 

 Untrimmed fillet arc 
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     Select Sketch from the Object menu 

 

 

When Sketch is selected the Sketch Mode Toolbar is automatically 
activated which enables the creation of constrained wireframe geometry. 
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The Intelligent Cursor 

The Intelligent Cursor provides dynamic assistance for its two primary 
functions: 

 Point input - it activates construction lines and labels for dragging, 
snapping and for point creation. 

 Selection - it highlights the object under the cursor ready for selection 

The Intelligent Cursor is ON by default. You can turn the Intelligent Cursor 
OFF (or back on) by using the options on the Intelligent Cursor flyout. 

 

 Click  to turn the Intelligent Cursor off.  

 Click  to turn the Intelligent Cursor on (default). 

 

When the Intelligent Cursor is turned on, objects are highlighted as you 
move the cursor over them. This shows which objects can be selected if you 
click at that point  

Key points and features available are: 

� End-point 

� Mid-point 

� Centre-point 

� Centre Key-point 

� On 

� In 

� Intersection 

� Tangent 

� End Closing a curve 
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Construction lines 

When you move the intelligent cursor over an important key point, 
construction lines are created from that key point. You can now drag the 
cursor along a construction line and see the appropriate labels display. 
Clicking causes the position to snap to that point.  

A simple box will be drawn to illustrate this: 

 From the top Menu bar, select File > New, or click on Open New Model 

 on the Main toolbar. A New Model is opened. 

 Select the Workplane Icon  and type 0 into the Command 
Window and then press Enter. 

 This will create a Workplane at 0, 0, 0 to allow us to visualise the 

position of the World UCS. We will cover workplanes in full later in 

the course 

 Select a View in (+Z).  

 From the Line toolbar , select create a Continuous line.   

 Click anywhere in the graphics area to start a line. 

Dynamic feedback on the cursor position indicates A for angle (from 
dashed line) and L for length.  

 

 Drag along a horizontal construction line (A:0) and then click to create it. 
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 Drag along a 90˚ construction line (A:90) and click. The line snaps to give 
a square intersection. 

 

 Drag the cursor down to the original start point and hover. The cursor 
displays End (do not click). 

 

 

 Drag along the vertical construction line until Intersection is shown. 
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 Click to snap at the intersection point then finally back down to the start 
point when End is displayed. 

     

 Select and delete all wireframes. 
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Wireframe Lines and Arcs Exercise 

The following exercise demonstrates basic Wireframe modelling by 
recreating the 2D profile shown below. Lines and Arcs will be used to complete 
the design. 

 

Line Creation 

To begin, a single line will be created from 0 to Y40 to coincide with the R 15 
arc centre shown above. 

 From the Line toolbar , select create a single line.   

 

 In the command input box, enter the value 0 followed by Enter.  

 

This defines the start coordinate for the single line (bottom left corner). 

 Input the values 0 40 followed by Enter. 
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 The X Y Z coordinates are entered in this order by default. Each input 

must be separated by a space and if the second or third values are not 

given, they are treated as zeros.  

 From the Line toolbar, select create a continuous line.   

 Snap to the start point of the first line, or enter 0 in the command input 
box. 

 Input the value 60 in the Command input box, then Enter. 

 

 Input the value 40 40 in the Command input box, then Enter. 

 

With the continuous line mode still active, a construction line to locate the 
R30 centre will be dragged dynamically while being monitored by the 
Intelligent Cursor.  

 

 By moving the mouse further, drag the end of a new line to a distance of 
30 along the normal (90 degrees) direction and left-click to accept the 
line. 

 

 Press the Esc key to exit line creation. 
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Arc Creation 

The remainder of the 2D model is to be created using various arc options. 

 From the Arc toolbar , select Full Arc.   

 Input the value r 15 in the Command box and press Enter. 

 

This input redefines the default radius 

 A space must be included between the command r and value. 

 

 Move the cursor over the open end of the vertical line until the text End is 
displayed then left-click to snap the circle centre position.  

 

 Press Esc to exit. 

 

Wireframe objects can be edited by: 

� Double left mouse clicking on the object. 

� Right mouse select on the object then Modify from the local menu. 

In both methods the editing form appears  
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 From the Arc toolbar , select Arc through centre, radius and 

span.  

 Snap on the open end of the construction line for the centre point as 
shown. 

 

 Move the cursor to the other end of the line and left-click.  

 

The position is now set for the start of the arc. 

 Release all mouse buttons and drag the arc around counter-clockwise. 

The intelligent cursor displays the current span angle. When you left-
click, the arc is created. 

 

 Left-click when the arc reaches about 250 degrees. 
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Next, a blend radius (R 60) will be generated between the arc and circle 
using Create an arc through three points. The first and second points 
will be snapped as tangencies to the existing full circle and arc with the 
third point being entered as the specified blend radius of 60. 

 

 From the Arc toolbar , select Arc through three points.  

 Use the Intelligent cursor to locate and click on the tangent point of the 
arc. 

 

 Locate and click on the tangent point of the circle. 
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 Drag the third radius point to the required shape and to a value as close 
as possible to 60, then left-click. 

 If necessary, in the Arc Confirm dialog, modify the Radius value to 60 
and toggle through Next Solution until the correct shape is achieved. 
Select OK. 

 

 

The new arc has been trimmed back to both the adjacent arc and circle.  

 

 Use Arc through three points/items  to create the radius of 10 
between the full circle and the vertical line.  
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Wireframe Lines and Arcs Editing 

Once Lines or Arcs have been created there are two main ways which they can be 

then edited. This can be done Graphically from within the graphics window or 

using the Line/Arc Editor dialog. 

Line Edits 

As with all Objects* in PowerShape a single left mouse click on the Object, 
in this case a Line enters the Graphical Edit mode with the 3D 
instrumentation to allow quick edits. 

 An Object within PowerShape can be decribed as anything you create 

within the graphics window such as: Workplane, Line Arc, Curve, Sold, 
Surface, Mesh etc. 

 

Within this mode the Line is highlighted yellow with an arrow indicating the 

Direction of the line and text showing its current Length. 

The blue Arrow and Sphere at either end of the line allows you to edit the 

characteristics quickly and easily while the intelligent cursor shows the original 
position and allows you to snap to other objects. 

Clicking and dragging the spheres will allow either end of the line to move freely 

in 3D space to change both the length and direction, while using the blue arrows 

will only affect the length and keep the same axial direction. 

When using the end arrows to change the length of a line, once the mouse button is 

released, PowerShape will give the opportunity to fine tune the length as seen in 
the next image. 
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To fully fine tune the Line, the most accurate option will be to enter the Line 
Editor dialog. Again, as with all Objects in PowerShape a double left mouse 
click on the Object, in this case a Line enters the Editor dialog. This dialog is 
particularly useful for naming and editing the relative Azimuth (Apparent) 
and Elevation angles of the line accurately. 

 

Within this dialog we can edit the Name, Direction, Length, Start and End Point 

and Angles highly accurately. 

Arc Edit 

Similarly to Lines a single left mouse click on the Arc enters the Graphical 
Edit mode with the 3D instrumentation to allow quick edits. 

Within this mode the Arc is highlighted yellow with an arrow indicating its Direction 
and text showing its current Radius. 

The blue Sphere at either end of the span allows you to edit the characteristics 

quickly and easily while the intelligent cursor allows you to snap the span to other 
objects. 
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Clicking and dragging the spheres will allow either end of the arc to move in a 
fixed circular motion dictated by the radius in order to graphically edit 
the span angle of the arc. 

The bidirectional blue arrows at the centre of the span allow the user to edit 
the radius of the line from the fixed arc centre. 

When using the arrows or spheres edit the arcs characteristics, when the 

mouse button is released, PowerShape will give the opportunity to fine tune these 

values such as span angle and radius. 

 

To fully fine tune the Arc, the most accurate option will be to enter the Arc 
Editor dialog. Again, as with all Objects in PowerShape a double left mouse 
click on the Object, in this case an Arc enters the Editor dialog.  
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Curve toolbar 

 

The following Curve creation options are available in PowerShape. 

 Bezier curve 

 Sketch a Bezier curve 

 G2-curve 

 B-spline curve 

 Ellipse 

 Spiral 
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 Helix 

 Fillet 

 Untrimmed blend 

 Trimmed Blend 

 Composite Curve 

 Draft curve 

 Curve by oblique sections 

 Surface or solid intersection 

 Curve projection 

 Curve wrapping 

 Curve unwrapping  

 

 

After creating geometry consisting of lines and arcs, it is often necessary (and 
good practice) to combine these into single entities, as wireframe curves. You 
will often require wireframe that is defined directly as complex curves.  

The most commonly used curve definitions are: 

Bezier curve - free form curve  

Composite curve – curve defined along existing wireframe and/or model 
edges. 
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Composite Curves 

In many applications, it is necessary for the required wireframe to be a single 
entity. This is achieved by creating the wireframe as a composite curve. 

 A composite curve can only be created along existing model entities. 

The basic wireframe shape is complete, but is made up of several separate 
lines and arcs. The extent of a composite curve can be limited between 
selected key points along the potential route (Define start point and Define 
end point).  

 From the Curve toolbar,  select Composite curve.   

The Create Composite Curve toolbar appears. 

 

 

 Select the Start Point option in the toolbar and left-click the lower-left 
corner on the wireframe model. 

 

 Left-click on the bottom horizontal line. 
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The composite curve is generated along the route until it hits a branch 
(intersection) point where optional directions will be arrowed for you to 
manually select the required route. 

 The asterisk at the start point indicates that the composite curve is 

currently open. 

 Left-click along the R60 arc. 

 

The composite curve has continued around the wireframe back to the 
defined start point. 

 A circle at the start point indicates the composite curve is a closed 

form.  

 On the toolbar, select Save  to accept the composite curve. 

The single composite curve is shown yellow in colour when highlighted.  
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 Select Eject  to close the toolbar. 

 Select Undo  to revert the last command (composite curve creation). 
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Exercise 1: Composite Curves 

1 From the main menu select File > Import  to import existing 
geometry into the current PowerShape model. 

2 Import the model: 

.....\PowerShape_Data\composite curve Ex1.dgk 

 

3 Use Composite curve  to generate the result shown below. 

 Use blanking to hide items not required. 

  

 

The wireframe is now complete and will be saved as a permanent model.  

 Composite curves can be converted back to wireframe by selecting 

Edit>Convert>To Wireframe from the main pull down menu. 

 Select File > Save As. 

 In the form save the model as: 

......\PowerShape-Models\Ex 1 composite curves.psmodel 

 Select File > Close. 
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Single Curve Point Edits 

Single points on curves can be edited directly in the graphics window using a 
variety of different graphical edit handles, as well as using the Command Box 
on the Status Bar. Use the handles on curve points to graphically modify 
single curve points. The handles will display only when a single point is 
selected. 

It is possible to change they different curve point handles within Edit>Surface 
and Curve Edits>Common Edits> Selected Point Graphical Handles or by right-
clicking with a single point selected. 

The following types of handles are currently available to use: 

• Tangent and Magnitude graphic handles. 

• Tangent and Normal graphic handles. 

• Workplane graphic handles. 

 

Tangent and Magnitude graphic handles 

 From the Curve Menu select Bezier Curve  and create a freeform curve 
within the Graphics Window. 

 

 Select a point on the curve and right-click and ensure that Tangent and 
Magnitude graphic handles is selected in the menu. 

 

These handles allow the user to graphically edit the Tangency and Magnitude 
of the curve point.  
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The arced handles offset from the end will modify the tangent angle of the 
curve in a fixed circular motion, without affecting the magnitude as can be 
seen below. 

 

The arrows at the end of each handle will graphically modify the magnitude 
of the curve along a fixed tangent angle, in this case to help the user, PowerShape 

will give interactive feedback of the magnitude. 

 

 

The Spherical handles will modify both the Tangent and Magnitude freely in 2D 
or 3D space. Again, PowerShape will give interactive feedback of the magnitude to 
the user. 

 

Finally, the spherical handle at the selected curve point position at the centre 
will edit the position of the point, without affecting the direction or magnitude 
of the point. For increased usability the intelligent cursor will remember the 
original position, and give coordinates (X, Y, Z) of the movement. 
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Tangent and Normal graphic handles 

Select a point on the curve and right-click and ensure that Tangent and Normal 
graphic handles is selected in the menu. 

 

These handles allow the user to graphically edit the position of the selected 
point in fixed Normal or Tangent directions, and alternatively freely in a 2D 
plane. 

 

The arrow handles tangent to the curve will modify the position of the 
point in a fixed direction along the tangent direction. For accuracy the 
offset distance from the orginal location will be visible, as well as editable 
once the mouse button has been released. 
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Similarly, the arrow handles normal to the curve will modify the position of 
the point in a fixed direction along the normal direction. For accuracy the 
offset distance from the orginal location will be visible, as well as editable 
once the mouse button has been released. 

 

The 4 Planar Handles surrounding the point will allow you to move the point 
freely in a 2D plane while again the original location is kept visible throughout. 

 

 

 

 

Again, the central spherical handle at the centre will move the point freely in 
3D space while showing X, Y, Z coordinates offset from its original location. 
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Workplane graphic handles 

 Select a point on the curve and right-click and ensure that Tangent and 
Normal graphic handles is selected in the menu. 

 

 

Clicking and dragging the workplane axis arrow handles will move the point in 
a fixed axial (X, Y or Z) direction with a visible offset distance from the 
original position, with the option to further edit or fine tune the offset once the 
mouse button has been released. The workplane origin in this case allows the 
point to be moved freely in 3D space. 
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Wireframe Arcs Example 

This example demonstrates the use of arcs to create the lever design shown        
below. 

 

 Start a New Model  

 Select the Arc toolbar.  

 Select create a full arc.  

When this button is selected, the centre position of the circle is defined 
first. This can be entered as a value or by snapping using the Intelligent 
Cursor. 

 In the Command Input box, type 0 for the circle centre and then press 
Enter.  

 

 

A preview of a circle is generated with a radius of the default value. You 
can change the radius by dragging one of the displayed arrows to the 
required value.  

To accept the circle, press the Esc key. 
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 With the circle selected, click and hold the handles (arrows) and move the 
mouse to drag a new radius of 35. 

 

 Alternatively open the arc editing form and modify the radius value. 

The circle now has the required radius. This method can be used to create 
the second circle at the same centre position, using the Intelligent 
Cursor. 

 Select create a full arc.  

 In the command input box enter r 20 then Enter. 

 Position the cursor over the centre of the first circle so the word Centre 
appears. 

 By default, the new circle will be exactly the same initial radius as 

the first circle. To change the default radius, type the new radius 

into the Command Input window.  

 Left-click to accept the centre of the new circle.  

 

The two basic circles are completed. Further circles are required for this 
model. 

Creating additional circles 

 Use the command input box to enter the circle centre if it cannot be 

snapped. 

 Create a circle at centre 100 –20 with a radius of 50. 

 Create a circle at centre 100 –20 with a radius to 35. 

 Create a circle at centre 200 -40 with a radius of 20. 

 Create a circle at centre 200 -40 with a radius of 10. 

 Press Esc. 
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The default option when creating tangent arcs is to trim back the 
associated geometry. In this case, it is not required, so the option (Trim 
Tangent Items) needs to be deselected.  

 Select Tools > Options, expand Object then select Arcs. 

 

 Deselect Trim Tangent items. 

  

 Select OK. 

Creating the tangent arcs 

For the tangent arcs, the fitted arc option is the most suitable as it provides 
full dynamic control through all possible combinations. 

 From the Arcs toolbar, select Create an arc through three 

points/items.  

 Move the cursor over the outer left circle until the word Tangent appears 
and left-click. 
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 Move the cursor over the middle outer circle so the word Tangent appears 
and left-click. 

 

 Move the cursor over up and down to get the tangent arc in the correct 
place and left-click. 

 

The Arc Confirm dialog is displayed. This can be used to enter an exact 
radius. 

 

 Enter a Radius of 75 and select OK.  

The tangent arc is drawn.  
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 Create an arc through three points/items  of radius 225 between 
the middle and outer circles shown below. 

 

 Create an arc between the left outer circle and the middle outer circle with 
a radius of 225. 

 Create a three point arc between the right outer circle and the middle 
outer circle with a radius of 75. 

 

The model is complete 

 Select Esc or click Select  to exit creation mode.  

 Select File > Save As. 

 In the form save the model as: 

.....\PowerShape_Models\lever example 

 Select File > Close. 
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General Edits example 

At the top of the left toolbar are two fixed buttons; the second button  
includes access to the General Edits toolbar. The buttons on this toolbar 
allow for standard editing functions that apply to all object types.  

 

A number of key editing options will be demonstrated in the following 
example. 

 Start a new model. 

 Select File > Import and load in the wireframe model: 

.....\PowerShape_Data\GeneralEdit_Wireframe.dgk 

  

The imported wireframe (shown above, left) will be modified using the 
General Edits options, to produce the 4 finished wireframes (shown 
above, right).  

 Click in the graphics area to deselect the wireframe.  

 Select  to display the General Edits toolbar. 

 Select the line that needs extending as shown 
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 Select the Point limit option.   

The Limit point toolbar is displayed, floating in the graphics window.  

 

The cursor also changes to a magnet symbol.  

 Move the cursor to the End of the line to be extended. 

 Hold down the left mouse button and drag the end of the line tangentially 
(along the preview line) until the word Intersection is displayed, then 
release the left mouse button. 

 

 Select the Interactively limit wireframes option  from the General 
Edits toolbar. The Limit point toolbar will be closed automatically. 

 Left-click the mid-span of any sections of the wireframe network that are 
to be trimmed away (as illustrated below). 
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 Create a composite curve from the network of lines and arc wireframes. 

 A quick way to create a composite curve is to hold down the Alt key 

and left-click anywhere along the wireframe network.  

 

 With the composite curve selected, select Move  from the General 
Edits toolbar. 

 With the toolbar displayed, enter the coordinate values X 25 Y 25 in the 
position boxes as shown. A preview of the transformed item is displayed 
and if required, can be changed. 

 

 Select the green tick  to accept the preview.  
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 The composite curve is shifted by 25 mm along both X and Y relative to 
the World datum 

 Workplanes and datums will be discussed in the next chapter. 

 With the composite curve still selected, select Rotate from the 
General edits toolbar.  

The Rotate toolbar is displayed. In addition, the blue arrow on the 
datum shows the current rotational axis (Z). In this example the 
wireframe will require rotation about the Y axis, so this must be changed. 

 Select the Y button  to make Y the operational axis. The 
axis buttons are located at the bottom-left of graphics area.  

The rotational axis in the graphics area reflects this change.  

 In the Rotate toolbar, select copy the selected item  (to keep original 
copy), Leave Copies as 1, and enter Angle of 180. Press Enter to display a 
preview. 
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 Select the green tick  to accept the preview.  

A copy of the composite curve is rotated by 180 degrees about the active 
Y axis. 

 In this case, the same result would have been obtained if the curve 

had been mirrored about the YZ plane. 

 With both curves selected, select Mirror  from the General edits 
toolbar. 

The preview shows the desired result. The selected wireframes are 
mirrored across the ZX plane (i.e. Y as operational axis). 

 

 

 

 

 Select the green tick  to accept the preview. 

 Close the Mirror toolbar.   
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Further General Edits options 

In addition to the General Edits options used, other options are used later in 
the course with other PowerShape entities, such as surfaces and solids. 

Offset 

 Select the composite curve located in the -X -Y quadrant. 

 

 Select Offset from the General edits toolbar.  

 

 Select the small red arrow on the curve to switch the positive direction 
outwards. 

 

 Select Round discontinuities  and enter a Distance of 10. 
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 Close the offset form by selecting the small cross in the corner.  

 

A 10mm offset with round corners has been applied. 

Scale 

 Select the composite curve located in the X Y quadrant.  

 

 If not already, ensure ts to/from he operational axis is set to Z. 

 Select Scale from the General edits toolbar 
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 Enter a Scale factor of 0.5 to reduce the size of the composite curve to 
50% of the original size. 

 Select the green tick  to accept the preview. 

 

 Scaling is from active workplane, therefore vectors to the active 

workplane origin also scale. This can be repositioned as required 

within the scale dialog 

Create Pattern of objects 

 With the scaled down composite curve selected, select Create Pattern of 

objects.  

  ` 

The current settings are immediately previewed. 

 

 Enter 3 rows along both Y and X with a Y pitch of 50 and X pitch of 75. 

 Select OK. 

 

Rectangular is one of 4 main functions in the Pattern Edits dialog. The 
other three include Honeycomb, Circular, and along Wireframe.  
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Honeycomb 

 

Circular 

 

Wireframe 

 

 Further layout options are available within each Pattern Edit tab. 

 Select File > Save As. 

 In the form save the model as: 

.....\PowerShape_Models\General Edits 

 Select File > Close. 
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Exercise 2: 2D Drawing 

 Use the dimensions provided to generate a Wireframe drawing. 

 

 

 Upon completion save the model as 

…/PowerShape_Models/Exercise 2 2D Drawing.psmodel 
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3. Workplanes 
 
 
 

Workplanes 
Workplanes are user-defined datums. They can be positioned and aligned as 
required to simplify model creation.  

 An active workplane represents the current workspace and its origin. 
Any number of workplanes may exist in your model, but only up to one can be 
active at a time. You may activate and deactivate workplanes at any stage. 
When a workplane is active it becomes the XYZ datum, visually larger in size, 
and changes colour from grey to the coloured symbol above (when selected) or red. 
Model entities can be copied or cut from the currently active workplane and 
then pasted back in a different position, relative to a new active workplane. 
 
The main Workplane button  is located in the Main toolbar. When selected, it 
displays the following buttons in the workplane toolbar to the left of the graphics 
window. 

 A simple wireframe box with angled top will be initially created to demonstrate the 
basic applications of workplanes. 
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Box Example 
1 Open a new model. 

The wireframe for the dimensioned model (as shown below) will now be created. 

 
2 Select Single Workplane  and enter 0 into the Command Input window to position it on the default World datum. 

3 Select the view Iso1  

4 From the Line toolbar , select Rectangle . 
5 Enter 0 in the Command input box and press Enter. 
6 Enter 100 75 in the Command input box and press Enter. 

 
 The rectangle is not a single entity, but consists of 4 separate, wireframe lines. 

7 From the Line toolbar, select Continuous Lines.  
8 Snap the start of the line onto the workplane (or enter 0) 
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9 Enter 0 0 100 in the Command input box and press Enter. 
10 Enter abs 0 75 150 in the Command input box and press Enter. 

 Adding the prefix abs changes the input from the default relative to absolute coordinates. 
11 Snap (left-click) the end of the current line to the top-left corner of the rectangle (marked as End by the Intelligent Cursor below). 

 

12 Press the Esc key or click  to end creation mode.  
13 Select the last three lines generated. 

A copy will be moved to the other side. 

14 Select Move  to display the Move toolbar. 
15 Select Copy the selected items , enter 100 in the X input box, and press Enter to display the preview 

 
16 Select the green tick  to accept. 
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17 Use Single Lines  to complete the model by snapping to End points as shown. 

                        The main wireframe model is now complete. 
Creating and Editing Workplanes 
          Workplanes within PowerShape can be created in the following ways 

 Create a Single Workplane 
 Create Multiple Workplanes 
 Create a Workplane aligned with geometry 

 Create a Workplane Aligned with minimal depth of selection 

 Create a Workplane Aligned with the average normal of selection 
 Create a Single workplane at top of selection 
 Create a Single workplane at centre of selection 
 Create a Single workplane at bottom of selection 
 Create a Workplane from three points 

 Create a Workplane Aligned with the current view 

 Create a point                   Depending on the option selected, Workplanes can be created by:  
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 Snapping onto the screen or geometry using the left mouse button.  
 Entering the coordinates using the command input box 
 Generated from the geometry and option type selected. 

              Workplanes can be edited using the Workplane dialog. This is accessed  
             by double clicking on the workplane or selecting modify from the right  
             click menu. 
 
 
 
 
 
 
 
 
 
 
 
 
 

Editing using Graphical handles 
                   Single selecting a Workplane will display its graphical handles. 

 
 
 
 
 
 
 
 

For each graphical edit, the handle to select is shown and summarised below. 

To move the Workplane origin, select the centre point 
(sphere) and drag. The Confirm Drag dialog will appear for confirmation and/or 
changes.  

To change the direction of the X, Y or Z axes, select 
the end arrow head and release over an item. The selected axis will point in that 
direction.  
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To move the workplane along the X, Y or Z axes, select 
the handle of the axis itself and drag. 

To twist around the X axis, select any blue handle. 

 To twist around the Y axis, select any green handle. 

 To twist around the Z axis, select any red handle 
 

18 Select Single Workplane , and snap a new workplane to the top end of the line running up Z from the original Workplane. 
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The new workplane is now active displayed in red, with the previous workplane now deactivated (shown in grey). 

19 Ensure the graphical handles are displayed, then drag any of the blue handles on the +Y and release at the upper left corner as shown. 

 
By rotating about the +X axis, the +Y axis is in line with the angled face. 
With the workplane now in the correct orientation, it will now be centred within the top wireframe boundary. 
 

20 Use Ctrl and left-click to select the four lines that enclose the angled top-face of the model 
21 From the Workplane toolbar, select Single workplane at centre of 

selection.  
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A new workplane is created, central to the four selected lines. This workplane is both active and selected. 

22 Create a Full Arc (Circle) of radius 40, about the currently active workplane.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The Radius 40 circle has been created on the XY face of the active workplane and is central to the angled-top face of the wireframe model.  
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Master Workplane 
1 Right-click on the active workplane to open the popup menu and then deselect Activate.   

 
 
 
 
 
 
 
 
 
 
 
 
 

There is no active workplane; all coordinates are now defaulted to the World coordinate system.  
 

If required, any Workplane can be assigned to be the Master Workplane. 
2 Right-click on the previous active workplane to open the popup menu and then select Master.  

 
 
 The Workplane is not currently active but has now been assigned as the Master Workplane. 
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3 Re-activate this Workplane. 

 
A previously created 2D model will now be copied and pasted onto the active workplane. 

1 Import the model: 
C:\\Training Data\PowerShape Data\workplane feature.dgk 

 
Workplane toolbar 

In the bottom left corner of the graphics area, is a drop-down menu that provides 
an alternative means to control the naming and activation of workplanes. 

 
1 Select the small black arrow to reveal the workplanes currently available in this session. 
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Simply selecting the workplane in this menu makes it active. In addition, Workplanes can be renamed from the default number provided. 
2 Select Workplane 3 and rename it to centre face by typing over and pressing Enter. 
3 Rename Workplane 4 to feature.  

 
 
 
 
 

4 Activate the workplane renamed feature.   
 
 
 
 

5 Select all the wireframe above of the imported model then copy 
 from the main menu. 

The selected wireframe is copied to the clipboard. 
6 Activate the workplane renamed centre face using the Workplane toolbar. 

7 Select Paste from the local menu.  
 
 
 
 
 
 
 
 
The wireframe imported away from the main model is copied relative to the workplane central to the top-angle face of the main wireframe model.  
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 Data relative to an active workplane in one model can be copied and pasted relative to an active workplane in a different model. 
8 Save the model as: 

...... Workplane box.psmodel 
 

9 is an section of toolbar that includes a Workplane button  for creating temporary workplanes 
Temporary Workplanes 

If a permanent Workplane is not required, then PowerShape provides the 
ability to create a temporary Workplane. The icon is visible next to the 
workplane toolbar. 

 

 A temporary workplane cannot be aligned dynamically, nor does it have 
access to a local editing dialog, but it can be modified using the General Edits 
toolbar. It is automatically named Temporary and can be deleted using the 
local (right click) menu or by reselecting the Temporary Workplane button. 

Workplane alignment of molding component 
When a component model is imported, it may not be in a suitable orientation 
for such tasks as creating a tool around it, or for maximum accessibility to a 
3-axis machining operation. In these cases, workplanes are applied to 
achieve a more suitable location and orientation for the model. To maintain 
dimensional accountability to the original component, it is essential to move 
workplanes around the model (as opposed to physically moving the model 
relative to the world datum). 

1 Close any previous PowerShape models. 
2 Import the surface model: 
.....\PowerShape_Data\InteriorTrim.dgk. 

3 If the model is not visible, select Resize to Fit  to centre in page. 
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The imported model of a plastic molding is not in a suitable orientation from which to create a mold tool. A suitably positioned workplane will be created to provide an appropriate tooling datum. 
The most obvious choice for a tooling alignment is normal to the base of the pocket. 

4 Use the middle mouse key to rotate the view to display the underside of the component. 

5 Select Single workplane aligned to geometry  and left-click anywhere on the flat surface defining the underside face of the pocket. 

 
The Z axis is normal to the surface. With this orientation, the centre of the pocket will be calculated. 

6 Select the surface only defining the underside face, the select Single 
workplane at top of selection.  
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The workplane is positioned central to the selected surface. 
7 Select and delete the original workplane used to create the alignment with the base of the pocket. 
8 View the model in all directions to check that a suitable tooling 

alignment has been achieved.   
It is possible that the model may need to be rotated 180 degrees about the X axis at some stage. This can be performed using the 
Workplane editing dialog. 

9 Right-click on the workplane, and select Modify in the popup menu.   

10 Select Twist X.   
11 Enter 180 in the Calculator dialog, and select OK.  
12 Select OK in the Workplane dialog. 

 
The model is now viewed the other way up, relative to the new orientation of the workplane. 

13 Save the model as: 
......\PowerShape-Models\Interior Trim ex1 

14 Close the model. 
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Exercise 3: Workplane creation 
 

1 Open the surface model: 
.....\PowerShape_Data\Exercise 3 model.psmodel 

2 View in ISO 1.   
3 Create a workplane at the centre of the pocket aligned to the top sloped face as shown. 

 
4 Rename the Workplane Angled left pocket. 
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5 Create a radius 15 circle in the position shown.  

 
6 Create a Workplane at the top centre (highest point) ensuring the +Z is directed towards the component as shown. 

  
 

7 Save the model as: 
....../PowerShape-Models/Ex 3 Workplane creation.psmodel 
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4. Levels  
Levels enable you to group model entities and help simplify the display and selection of items. Levels can be distinct groups of component surfaces, or 
different types of entity, and they can be renamed to identify the items they 
contain.  
Objects can be assigned to different levels, which can then be displayed or hidden to help manage the selection and visualisation of entities within a session. A typical example use is to assign the inner wall surfaces of a component to a one level, and the outer wall surfaces to another.  
PowerShape supports up to 1000 levels, but levels 998 and 999 are reserved for internal use.  

Example 
1 Create a New Model and Workplane at 0. 
2 Import the model......PowerShape_data/Corner Bowl.dgk 

 
The model contains a mixture of wireframe and solids. It may also contain duplicate entities that could be wireframe, solids, or a mixture of both. It is advisable to check and move these items to a level, or to delete them if not required. 

3 Select everything within the graphics area. 

4 Select Find duplicates  from Model Fixing toolbar. 
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5 Select the option Examine selected items only then OK. 

 
PowerShape examines the model and selects duplicate entities An information box is displayed, showing the number of duplicate entities. Click OK to close the dialog. 

 The duplicated items are also selected in the model.  

6 Select Selection information  from the Selection toolbar.  

 
A list of the current selected items is also summarised here.  
These duplicate entities will be moved to another level. 

7 Select OK. 
8 From the lower-left side of the window, open the Levels form.  
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Each level has a number. Visible levels are indicated by .  Hidden 
levels are indicated by . You can turn ON a level by clicking  and 
OFF by clicking .  
A new level is created simply typing a name into an empty box adjacent to the level number. 
Level names can be edited by just modifying the existing name. 

 
9 In level 5, enter the name Duplicates, and select the red X next to the number 5. 
10 Select OK. 

The duplicate items previously found are still highlighted. To transfer data to a level, the middle mouse button is used. 
11 Click the middle mouse button over the level 5 icon itself, to move the selected items to that level. 

 
12 Left-click on the Level 5 button to switch off visibility. 

By default, all new entities created or imported are placed on the default  
0:General layer. The ‘active’ layer can changed by simply by selecting 
the required layer (if created) from the drop down list shown. 

 
 

13 Open the Levels form and create two further levels. Name level 6 as Core and name level 7 as Cavity. 
14 Select OK on the form. 

This model contains solids. These are a different type of component, which can be used to make complex shapes. To select a solid, clicking on any part of it. 
15 Select the bottom solid and press Ctrl+K (Blank Except). 
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Adding the cavity and core to level 6 and 7 

1 With only the bottom solid selected, click the middle mouse button over level 6. 
The solid has disappeared as the level was switched off. 

2 Press Ctrl+L (Unblank). 
3 Select the top solid and press Ctrl+K (Blank Except). Only the top solid is shown. 

 
4 Transfer it to level 7. 
5 Select Ctrl+L to Unblank. 

 
 
The component solid and construction wireframe remain on level 0 (General). 
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Grouping levels 
PowerShape has the ability to group levels. By grouping levels together, you can manage parts of the model more efficiently and effectively. 
1 From the lower-left side of the window, open the Levels form.  
2 In level 8, enter the name Components : Wireframe and select the red X button next to the level number. 
3 In level 9, enter the name Components : Solid and select the red X button next to the level number. 

 
The word Component is the group name and Wireframe and Solid are the level names. 

4 Select OK. 
The two levels now belong to the group called Components.  

 
On the Levels toolbar, the buttons of levels 8 and 9 have changed to blue. In 
addition, a new Levels Group button is displayed, also in blue . You can use this Levels Group button to turn both levels on and off simultaneously 

 Each new group is assigned a different colour so you can distinguish between them.  
5 Select Quick select all wireframes  from the Select  toolbar. 

 
6 With all the wireframes highlighted, middle mouse button over level 8. 
7 Select the component solid and place it onto level 9. 
8 Select  to switch off both the associated components layers. 

Using Copy and Paste to make copies of entities 
In some instances, it is advisable to make safe copies of surface or wireframe entities. For this exercise, we will copy the core solid and paste it onto the general level. 
1 Turn on level 6 (Core) and select the solid. 
2 From the top toolbar, select Copy  and then Paste.   

Two identical solids are on level 6 
3 Select a solid and move it to level 0:General.  

4 Switch off level 6. Toggle level 0 on and off to see the new copy. 
 



               
4. Levels         
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5 File >Save as …\PowerShape-Models\Corner bowl levels.psmodel  
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   Introduction 
Solid modelling applies a different approach to the creation of a CAD model compared to surface modelling studied later in the course. The main difference is that a surface model is formed by a hollow, zero thickness skin, whereas a solid model is a mass of material. The main advantages of using solid modelling are the model creation speed, parametric qualities and the history tree. The user can use the history tree to reposition or edit operations performed earlier, resulting in the automatic update of other affected items. PowerShape is unique in the ability to convert solids to surfaces and surfaces to solids, depending on which approach is most suitable. Open surfaces can be converted to a solid, an extremely useful capability which is not available with dedicated solid-modelling packages.  
Within the Main toolbar there are two buttons for creating and Editing Solids.  

When Solid options  is selected, it displays the following buttons in the toolbar to the left of the graphics window. 
 

 
 

5. Solid Modelling 
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   Solid Primitives 
In addition to the primitive solids which are generated from wireframe items (e.g. Extrude, Rotate), the toolbar contains six pre-defined shapes. 

 
Primitive shapes can be edited dynamically with a single mouse click (select) 
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The workplane ‘type’ handles can be used to move, change orientation and twist about its axis. The blue handles can be dragged to edit the dimensions of the primitive solid. 
Alternatively, double clicking on the primitive solid will display the dialog in which edits can be applied. 

 
When Solid Features  is selected, it displays the following buttons in the toolbar to the left of the graphics window. 
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Active and inactive solids 

In older versions of PowerShape (Before 2015) many solid operations were performed on the currently active solid. 
 The active solid is usually the main component of your model  
 Only one solid can be active at any time 
 By default, the first solid you create automatically becomes the active solid and other solids are created as inactive  
 If you activate an inactive solid, the currently active solid (if any) becomes inactive 
The active solid is represented by the Red Flag in the solid history tree and by darker wireframe edges in the graphics area. 
Since PowerShape 2015 the selected solid or the active solid can be used to perform solid feature operations. However it is still good practice to keep control over which solid is used as the active. 
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Boolean Operations 
 

Boolean operations define the relationship between entities. As a solid is built up, additional solids and surfaces can be absorbed into it. This behaviour is illustrated below using the three Boolean operations available from the solid features toolbar. 
Observe the two primitive shapes below. With transparent shading applied, the yellow cylinder can be seen fully intersecting the blue sphere. 
In this case the Sphere is the primary solid and the cylinder is selected only. 

 
 

Selecting Add will combine the selected solids. 

 
The two separate solids have merged into one solid object. The cylinder is joined onto, and becomes part of the solid sphere.  
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Selecting Remove will subtract the secondary solid from the primary solid. If the active solid is visible in the graphics area that will automatically selected as the primary, although this can then be overridden in the dialog. 
 

 
A hole appears through the solid sphere caused by the removal of the solid cylinder. The hole is now part of the active solid sphere. 

Selecting Intesect  keeps the intersection of the selected solids. 

 
The new solid becomes the common volume of both solids, producing a solid tube with spherical ends.  
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   Snapping to Parasolids 
Following a recent update released in PowerShape 2014 R2, solids now support much improved snapping options using the intelligent cursor to parasolids within the graphics window. 
The intelligent cursor now snaps to the following, and are only visible once in a relevant creation mode: 

 Corners 
 Centres of Planar Faces 
 Centres of Arc Edges 
 Midpoints of Straight Line Edges 
 Tangent to Arc Edges 

Examples of these can be seen on the image on the next page. 
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Solid Modelling Example 1 
The following example illustrates the creation of a simple solid model. It emphasises the benefits; the ease of creation, and the ability to retrospectively make changes to existing features causing the remainder of the solid to be automatically updated. 

 
1 Create a new model.  
2 Create a workplane at 0 and set the Principal Axis to Z. 

3 Select Solid  from the main toolbar. 

4 From the Solids menu, select Create Solid Block.  
5 Centre the base of the solid block about the workplane by typing 0 in the command box (or snapping to workplane origin) then pressing Enter. 
6 Press the Esc key to break out of the command. 
7 Double-click the solid block to open the Block dialog.  
8 Enter Length 100, Width 50, and Height 50.  

 
 Screen shots have transparent shading applied.  

9 Select OK to apply the changes and close the dialog. 

10 From the Solids menu select Create Solid Cylinder.  
11 In the Command Input box at the bottom-right of the Status Bar, type the values 0 0 –20 to position the base of the solid cylinder. 
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12 Press the Esc key to break out of the command. 
13 Double-click the solid cylinder in the graphics area to open the 

Cylinder dialog and enter Radius 10mm and Length 90mm. 

 
14 Click OK to apply and close the dialog. 

15 Select Solid Features  from the main toolbar. 

16 Ensure the cylinder is selected then Boolean Subraction.   

 
 The selected cylinder is removed from the active block (created first) to leave the hole. Fillets will now be applied to the vertical edges. 

17 From the Solid Features toolbar , select Create solid fillet.   
 

18 In the Fillet dialog, enter a Radius of 5mm. Hold down the Ctrl key and 
click all the vertical edges of the solid block.  
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19 When all the edges are selected (yellow), select OK to apply and close the dialog. 

 
 
 

 

 
 All four vertical edges now have a fillet of radius 5mm. 

20 Select File > Save As: 
.....\Training Data\Coursework\Solid Modelling Example 1 
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  Solid Feature Tree 
The Solid Feature Tree contains the history of solid operations performed on the visible solids.  
Each solid operation is defined as a feature on the solid. 
When you create a solid, it is automatically added to the solid feature tree (also known as the solid history tree).  
When an additional feature is applied a branch representing that feature is added to the tree. The features are shown in reverise chronological order with the most recent one applied at the top and the earliest at the bottom.  
The solid feature tree is displayed in a dedicated window to the left of the 
graphics area. This can be viewed by selecting Show History Tree window  from the Solid Edits Toolbar, which automatically launches when any solid is selected. 

   
 

Modifying items and operations stored in the Feature Tree automatically updates the solid in the graphics area (provided the changes are possible). It is also possible to defer updates to allow a series of changes to be implemented at the same time. 

21 Select Show tree  window from the Solid Edits toolbar. 
The current features are displayed. 

 
A solid can be activated or deactivated by simply toggling the flag symbol. A 
Red Flag indicates an active solid  and grey flag  a inactivate solid. Flags can be toggled from within the feature tree or from the Solid Edits toolbar. 

 

 
 

If sub-items are not shown, click  to display them. To hide the sub-items, 
click.  
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A solid and/or feature can be selected directly on the model or from the feature tree. When a feature is selected, the name is outlined in a blue box and blue on the model itself. 

 

 
 

22 Double-click on the solid fillet near the top of the tree.  

 
 The editing form for the fillet feature is displayed.        

23 Input a new Radius of 10mm and select OK. The selected fillet radius on the solid changes to 10mm and the solid model is re-trimmed to suit. 

 
 You can also select solid sub-items by double-clicking the solid in the graphics area. 
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   Multiple Feature Edits 

In PowerShape 2015 we can now make simultaneuous edits to multiple versions of different sizes of the same feature (ie Solid Fillets). 
1 In the Solid History Tree select all four fillet features. 

 
2 Right-click on the selected features and select Modify. 

 
This will raise the normal Feature Edit dialog appropriate to the feature type selected. The main difference when multiple different features are selected are: 
 The properties that differ between the selected features are highlighted in pink. 
 The properties that cannot be edited for ALL the selected features are unavailable. 
 The range of values for each of the different properties are displayed when your mouse is hovered over the input box. 
3 In the Radius box type 8mm then click OK. 

 This has converted both the 5mm and 10mm fillets to 8mm fillets in one operation. 
 

 
 



5. Solid Modelling  

 Copyright © Autodesk  Autodesk PowerShape 2017   5 - 15 

   Editing preceding Boolean operations 
As well as the ability to modify the original parameters used in the creation of a sub-solid item, you can apply the General Edit options to preceding Boolean operations. 

1 Select only the Boolean Subtraction operation in the History Tree as 
indicated. 

 

 
The cylinder (Boolean operation) is highlighted in the graphics area. 

2 Select  to display the General Edits toolbar. 

3 Select Edit Sub Item  from the flyout. 

 
 

This ensures the next general edit will now apply to the selected sub-items only. In this case the cylinder and the Boolean Remove which created the hole through the block. 
 

4 Set X as the principle axis.  
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5 Select Rotate  from the General Edit toolbar. 

 
The blue arrow indicates the X axis as the rotational axis. However the rotation origin itself needs to be transformed to the centre of the cylinder in Z. 

6 On the rotate dialog select reposition rotation axis.  
7 In the command box enter 0 0 25 to position the rotation axis half way up the cylinder.  

 
8 In the dialog, select Copy the selected items (to keep original) and enter an Angle of 90°, press the Enter key to show a Preview.  

 
 

9 Press the green tick to accept. 
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The original sub-solid cylinder is copied and rotated within the solid. The new sub-solid cylinder appears at the top of the History Tree.  
 

 

10 Save  the model then close the session. 
 
 
 
 
 

Solid modelling example 2 
In this next example the following component will be created. 

 
The Mounting Block base dimensions are Length (X) = 100mm, Width (Y) = 75mm and Height (Z) = 50mm centrally positioned relative to the workplane at The Draft Angle on all 4 walls is 5°. 
A cylindrical section of Radius 15mm runs with its axis along and central to the sloping upper face. All fillets are Radius 5mm. 
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1 Create a new model.  
2 Set the principal plane to Z and create a workplane at 0. 

3 Select Solid options  from the main toolbar. 

4 From the Solids menu select Create Solid Block.   
5 Centre the base of the solid block about the workplane by typing 0 in the command box (or snapping to the workplane). 
6 Double-click on the solid in the graphics area to raise the Block Edit dialog. 

 
 A solid primitive block allows the draft angles to be applied immediately.     

7 Select the Workspace tab in the editing dialog. 
8 Enter -50mm in the third coordinate box (Z Axis) and select OK. 

   
 The block has been transformed 50mm in the –Z axis. This has resulted in the original workplane to be positioned on the top face of the solid block. 
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Applying fillets to the block 
Prior to the fillets the upper face will be modified to create the slope. An extruded surface will be used to demonstrate the ability of PowerShape to apply Boolean operations to solids using surfaces. 

 Primitive Surfaces are discussed in detail in the next chapter. 
1 From the Views toolbar, select a View from Front (-Y). 

 
 By default the Principal Axis automatically switches to the selected 

view.  

2 Select create a single line  from the Line menu. 
3 Enter the start point coordinates -50 -50 -25. 
4 Next, enter the absolute coordinates abs 50 -50 -10 to complete the line. 

            
 

5 Select the angled line. 
6 From the Main toolbar, select Surface to display the Surface menu. 

 
7 From Surface toolbar, select Create a Surface Extrusion.     

 This training manual will cover surface modelling in the next chapter. 
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With the line pre-selected, an extrusion surface is created immediately. 

 The upper side of the surface is shaded red (inside) while the underside is the current default colour for surfaces (outside).  
8 If the extrusion surface does not fully pass through the solid, double-click the surface to display the Extrusion dialog. Insert a Length of 95mm. 
9 Select OK. 

 
 You can also change the length by dragging the arrow at the end of the selected extrusion surface. 

 



5. Solid Modelling  

 Copyright © Autodesk  Autodesk PowerShape 2017   5 - 21 

10 With the surface selected and the solid active, select Solid Features 
 from the Main toolbar.  

11 Select Boolean Remove.   

 The Split Solid  button can also be used to same affect. 
The area of the solid on the red side of the surface is removed, with the surface removal registered in the Feature Tree. 

       

12 Apply a 5mm solid fillet  on each draft edge of the solid block. 

 
13 Repeat the fillet of Radius 5mm on the sloped rectangular face. 
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 By creating the fillets in two separate operations, the sidewall and top surface fillets are independent which makes it easier to make changes to the individual fillet groups at a later stage by control the grouping in the history tree. 
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Creating a cylinder 
A new solid cylinder will be created then removed from the existing solid.  
Before creating the cylinder a new workplane is required aligned to the sloping face and positioned at a known keypoint. 

14 Create a single Workplane aligned to geometry and place a workplane at the centre of the lower edge of the top sloping face to create a workplane with its Z axis normal to the sloping face of the solid. This can be done by snapping to the keypoint using the intelligent cursor. 

 
15 From the bottom-left of the graphics area, select X as the Principal Axis. 

 
16 From the Solid  toolbar, select Create Solid Cylinder.  
17 Left-click on the new workplane to locate the new solid cylinder on to it, or type 0 into the type command box and press the Enter key. 
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18 Modify the cylinder parameter to a Radius of 15mm and length of 125mm. 
19 In the Workspace tab of the cylinder dialog, modify the X coordinate to  

-20. 
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   Using a Boolean operation to remove the cylinder 
1 Boolean Remove  the solid cylinder from the main block solid. 

 
2 Activate the original workplane (Workplane 1) at the top centre of the component. 
3 From the bottom-left of the graphics area, select the Z Axis as the 

principal axis.  

4 Create a Solid Cylinder  positioned at -35 -25 -50. 
5 Modify the Radius to 4mm and the Length to 40mm. 

 
 You now need to remove the new solid cylinder from the main solid using a Boolean Subtraction operation. 

6 Boolean Subtraction  the cylinder from the main solid. 
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   Mirroring the hole feature 

The remaining hole features we require will be mirrored across for a more efficient process. 
1 Select the latest Boolean Subtraction feature displayed in the 

Feature Tree. 

 
2 Select  to display the General Edits toolbar. 

3 Select Edit Sub Item  from the flyout. 
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4 Mirror  the hole across the ZX plane.  
     

 
The new hole is displayed at the top of the Feature Tree. 

5 Ctrl + select (multi-select) the Boolean Subtraction feature for both holes in the Feature Tree. 
6 As before mirror the features but this time across the YZ plane. 
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Basic Solid Editing 
1 Double left-click on the original solid block symbol at the bottom 

of the Feature Tree. The Block dialog is displayed. 

      
2 Modify the value for Width (Y) from 75mm to 100mm, and all four Draft angles to -15° 
3 Select OK. 

The solid component is updated with the changes. 

 
The holes must now be moved clear of the fillets running around the upper sloping face. 

4 Zoom into the area containing the two latest holes in the +X direction. 
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5 Hold down Ctrl and click the two Boolean operations (holes) to select them both. The corresponding cylinders are highlighted in the CAD model. 

 
6 Select  to display the General Edits toolbar. 

7 Select Edit Sub Item  from the flyout. 

8 Select Move.  
9 In the X Input box, type -5 and press Enter, then green tick to confirm. 
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10 Select File > Save As: 

.....\Training Data\Coursework\Solid Modelling Example2 
11 Close the model. 
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Solid Modelling Example 3 – Die block 
1 Open a new model.  
2 Create a workplane at 0 and ensure the Principal Axis is set to Z. 

3 Create a solid block  at 0 0 -40.  
4 Modify the Length (X) 100mm, Width (Y) 150mm and Height (Z) 40mm.  

 
5 Set the Principal Axis to X. 

6 From the Solids menu select Create a solid cylinder  positioned at -55 0 0. 
7 Modify the Radius to 2mm and the Length to 20mm. 

8 Create a solid cone  at co-ordinates -35 0 0. 
9 Modify the top radius to 1mm, Base radius to 2mm, and Length to 30mm.  
The model now contains three solids; the large block is currently the active solid, you should be able to see this in the Solid Feature Tree. 
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10 Select and Blank (Ctrl+J) the solid block. 

11 Boolean Add  the Solid cone to the solid cylinder. 
The combined solids create the ‘sprue’ for the die block. (The hole through which molten material is channelled into a mould). 

12 Unblank (Ctrl+K) the solid block. 

 
 The Feature Tree shows that the ‘sprue’ solid comprises the solid cone and the solid cylinder.  

 
Suppressing a feature 

Solid features can be temporarily suppressed (removed from the solid) left clicking on the green tick in the History Tree. The green tick changes to a red cross.  

 
PowerShape remembers the details and history of the suppressed feature. 
The suppressed solid feature can be unsuppressed by clicking on the red cross which will a green tick and the feature is visible. 
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    Importing the molded component 

The molded component to be sunk into the die will be imported as surfaces and then converted into a solid. 
1 Select and Blank all of the solids and Import the model: 

C:\\Training Data\PowerShape Data\handle.dgk 
 

 
The imported model contains various surfaces, which will be used to create a single solid. 

2 Quick Select All Surfaces from the Selection menu. 

3 From the Solids toolbar  select Create a Solid from selected 
Surfaces.  
A single solid has been created and also listed in the Feature tree. 
 

 
4 Select Unblank (Ctrl+L) to redisplay the block and sprue solids. 
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During a Boolean Remove, the secondary solid is lost as it absorbs into the primary solid. In this case, a copy of the handle will be required for later use as the basis for an electrode. 
To achieve this a copy of the handle will be created and placed onto a separate level. 

5 From the lower-left corner of the window, open the levels form.  
 

6 Name level 5 as Handle copy and leave the level switched off.  
Select OK. 

 
7 Select the handle solid. 

8 Select Copy from the main toolbar followed by Paste.  
A copy of the handle has been created with two identical handle solids in the feature tree. 

 
9 With one of the handles selected, middle mouse click over the level 5 icon in the levels toolbar. 

 
A solid handle has been transferred to the new level. With the level 5 switched off the copy of the handle solid is now not visible. 
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Creating cavity 

1 Boolean Add  the ‘sprue’ solid to the handle solid. 

 
2 To finally create the required cavity, use the Boolean Subtraction  operation to remove the handle and sprue solid away from the block. 

 
 A single solid remains which has the handle and ‘sprue’ removed from the die block. 

Creating the electrode from the solid 
The copy of the handle solid you created earlier will now be used to create an electrode. 

1 Blank the main cavity solid and then switch ON level 5 to display the 
handle copy. 

 
 

2 Ensure Z is selected as the principal axis is selected. . 
The ability of a surface to split a solid will now be shown. 
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3 From the Main toolbar, select Surface to display the Surface menu. 

 
4 From Surface menu select Create a Plane primitive  and position on the Workplane at 0 0 0.   
5 Modify the parameters to Width (X) 80mm and Length (Y) 120mm. 

 
6 Blank ALL Solids EXCEPT the handle. 

 Select the handle and press Ctrl+K. 

7 With the surface selected, select Solid split  from the Solid Features 
toolbar . 

8 Select and delete the upper half of the handle. 

 
9 Create a composite curve around the upper edge of the remaining handle. 
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10 From the Solids  menu, Create a Solid Extrusion.  
11 Modify the extrusion and change its length to 15mm.  

 

12 Using the Boolean Addition  operation add the extrusion to the handle solid. 
 The solid extrusion forms a run off to provide clearance between the electrode and the back plate.  

13 Create a solid block  at position 0 0 15 with Length (X) 60mm, Width (Y) 130mm and Height (Z) 20mm. 

14 Boolean Addition the two solids together.  

       
15 Rename the solid as Cavity Electrode by right clicking the solid in the feature tree and selecting Rename. 

 
16 Switch OFF level 5.  
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Creating a slide 
A slide will be created to provide an undercut hole in the molding. 

1 Select Unblank to redisplay the main cavity solid. 
2 Ensure it is active and set principal axis as Y. 

3 Create a solid cone  positioned at 4 –52 -3. 
4 Modify to Top Radius 2mm, Bottom Radius 2.25mm and Length 5mm. 

 
5 Boolean Addition  the small cone to the main cavity block.  
The solid now has a localised undercut core that is to be separated onto a retractable slide. A workplane is required at the end of the core to assist with the separation of the slide. 
An extruded surface will be created and utilised again to split the solid and provide the required component. 
6 Zoom into the small cone solid and create a composite curve on the edge of the bottom flat as shown. 

 Switching to wireframe shaded or transparent view will display the edge clearer making it easier to select and trace. 

 
7 Create a single Workplane aligned to geometry and click and snap at the centre of the outer planar face of the small cone.  
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8 Select the composite curve and create a Surface extrusion.   

 
The surface needs to be extruded through the model including a taper angle. Both can be achieved simply from the extrusion form. 

9 Double-click on the extrusion surface to open the Extrusion dialog so you can edit the extrusion.  
10 Modify Direction Length 2 to 30mm then Direction 1 Length to 0mm. Tick the Draft angle box in Direction 2 and enter an angle of 5°. 

 
11 Select OK. 
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The extrusion surface will be used to split the main solid extracting the slide as a separate solid. 

12 Ensure the main solid is active and the extruded surface is selected. 

13 Select Solid Split  from the Solid Features toolbar . 

  
Both resultant solids retain their separate associations within the History Tree. 
14 Select File > Save As: 

.....\Training Data\Coursework\Solid Die.psmodel 
15 Close the model. 
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Burglar Alarm Box Example 
1 Open a new model.  
2 Create a workplane at 0 renamed Datum, and ensure the Principal Axis is set to Z. 

3 Create a solid block  at 0 0 0 of Length (X) 250mm, Width (Y) 300mm, Height (Z) 130mm and Draft 340° on all four sides.  

       
This has formed the basic shape for the alarm box. 

Adding solid features 
Further solid features  will now be added. 

1 Create a rectangle  starting from -60 -80 130 to 120 160. 
2 Create a composite curve from the rectangle. 
3 Create a Radius 10mm fillet on all corners of the composite curve. 
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4 With the composite curve selected, select Create Solid cut  from 
the Solid Features toolbar.   

  
5 In the Type drop-down list, select Blind and enter Depth of 1mm and select OK. 

 
A recess of depth 1mm is created in the solid downwards from the composite curve into the solid. 
The next stage is to remove the sharp edges from the main body by adding solid fillets. 

6 Select Create Solid Fillet  from the Features toolbar. 
7 Apply a fillet of radius 10mm on the four vertical and top edges. 
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Create four screw apertures 

1 Create a solid cone  at 80 -135 5.  
2 Double-click on the cone to display the Cone Edit dialog and enter the values as shown in the form below. Select OK. 

 

 
3 Make the new solid cone active. 
4 Apply a solid fillet of radius 2 around the base of the cone. 
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 You may need to use a transparent shaded view, or alternatively Blank (Ctrl+J) the main block. 

 
5 Mirror  the cone across the XZ and YZ planes of the worklplane 'Datum’ to produce 4 cones. 

 
6 Use Boolean Subtraction  to subtract the 4 cones away from the block. 
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7 Create a solid fillet of radius 1mm around the outer edge of each conical recess.  

 
Hollowing out the base 

We now need to select the face from which the hollow solid process is to occur. To do this, the solid must be shaded so that is possible to select the base as the specified face. 

1 Select Hollow Solid  from the Solid Features toolbar.  
2 Select the bottom face of the model which will then be highlighted yellow. 

The red cross adjacent to Removal Face Selected is replaced by a green tick. 

 
3 In the All Faces box, type 3mm, and then select OK.  

 The solid now has a uniform wall thickness hollowed out from the original base 
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Creating the air vents 

The next stage is to create air vent features on the side walls. 

1 Select View from left (-X)  which automatically sets the principal axis to X. 

2 Switch to Wireframe view.  
3 Create rectangle from 0 -7 12 to 0 14 88. 
4 Fillet  both left corners with radius 10mm. 
5 Create a composite curve of the profile. 

 
6 Box-Select both the solid and the composite curve. 

7 Select Curve Projection  from the Curve menu.  
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8 Select Through item then OK. The composite curve is projected through the entire solid in the direction of the Principal Axis (X). 

 
 Only the curves on the outside face are required. 

1 Select and Delete the two curves which were projected onto the inner face and the original central curve. 
2 Select the remaining outside curves. 

3 Select Create solid boss  from the Solid Features toolbar .  

 
4 Change the Extrusion height to 2mm and enter an angle (applies draft)    of - 60°. 
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Select the new boss feature (created as one) from the feature tree as shown. 

 
5 Select Move  from the General Edits toolbar.  
6 Select Copy selected item and enter 30mm in the Y input box, then teh green tick to confirm. 

 
A copy of the boss features have been created to the side of the original. 

 
7 With the Move dialog still open and the new boss features highlighted enter -60 in the Y input box to create a copy on the opposite side. 
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8 Select View down from left (-X).  

9 Create a rectangle of lines  at 0 -7 12 with sides 0 4 88. 
10 Create a composite curve from the rectangle. 
11 Copy the composite curve by 30mm along the Y axis on both sides of the original. 

 
12 Select all 3 rectangular composite curves. 

13 Select Create Solid Cut  from the Solid Features menu.   
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14 In the Type drop-down list, select Through and select the icon highlighted to Extrude both directions. Select OK.  

 

 
 The ventilation slots are cut out of the main solid. 

Creating a workplane for the mounting 
The next stage is to create a mounting for the strobe light on the end face of the alarm box. To assist alignment of the mounting, a workplane will be created aligned normal to the face. 

1 Select the Iso1 view.   

2 Select Workplane Aligned to Geometry  and select the face centre keypoint shown. 
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3 If necessary, Twist the workplane about Z so that its X axis is aligned 

towards the top of the alarm box. 
The Z axis of the new workplane is centrally aligned normal to the selected face. 

Creating a boss to provide access to the mounting 
A boss complete with through hole, will be created and aligned to the workplane Z Axis to provide access for a strobe light mounting. 

1 Generate a full arc (circle) of Radius 30 at the workplane 0 and create a solid extrusion of 10mm in both directions (Direction 1 and 2) 
2 Generate a solid block primitive at 0 0 -10 
3 Modify the block dimensions to Length 100, Width 40 and Height 20. 

 
4 Make the circular extrusion active and select the rectangle block.  

5 Boolean Intersect  the leave the combined solid. 
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Trimming the solid 
As seen below, the new solid is jutting beyond the inner wall of the main solid.  

 
The Solid Boolean Boss will be used to trim it back to the inside face and at the same time add the outer part to the main body solid as a Boss feature. 

1 Select the main casing solid and make it active. 

2 Select the intersected solid, and then select Solid Boolean Boss  
from the Solid Features menu.   

3 The Boolean Boss dialog offers 2 possible solutions. It allows the intersected feature to be split to exist either on the outside face or on the inside of the s. 

     
4 Toggle to the solution (in this case 1) with the highlighted boss (blue) on 

the outside and select OK. 

 
The solid boss has been trimmed back.  
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Creating a hole for the wiring 
A hole for the wiring will now be created. With a single active solid, the hole will penetrate both the boss and casing.  

1 Create a Workplane Aligned to Geometry and snap it to the centre of the Boss face. 
2 Then select select the outer face of the boss to create a workplane at the centre of the outside face  

3 Select Create a Hole  from the Solid Features toolbar.    
4 Position the hole by snapping to the local workplane, or by typing 0 in the 

Command input box. 

 
5 For Hole Category, select Untoleranced. 
6 For Use select Plain. 
7 Enter a length of 50 and diameter of 16. Select OK. 

 
8 Select File > Save As: 

.....\Training Data\Coursework\Alarm Box.psmodel 
9 Close the model.  
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Plastic Handle Example 
1 Open the model: 

…\PowerShape Data/toy_handle.psmodel 
The model contains a large handle solid along with six small rib feature 
solids, all of which are displayed in the History Tree.  

 
2 Select File > Save As and save the model to: 

…Training Data\Coursework\PlasticHandle.psmodel 

 
 

3 Make the main handle solid active in the Solid History Tree. 

4 From the Solid Features menu , select Solid Fillet .  
 The Solid Fillet dialog is displayed. Unlike surface filleting, solid filleting uses the sharp edges on the solid as the filleting track. The order and extent to which solid fillets are created is important if the correct design specification is to be achieved. 
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In this case, to provide the correct shape around the upper and lower edges of the D-shape, the vertical corner fillets must be created first. 
5 Set a Radius of 6mm and select the two outer vertical edges shown. 

 Hold down the Ctrl key to multi select edges. 

 
The fillet path runs until it finds a sharp edge (Discontinuity). 

6 Select Apply. 
 By selecting Apply the fillet dialog will stay open after the fillet has been created for further operations. 

7 Generate a radius 4mm fillet along the top and bottom faces of the solid. 

 
The outer edges are now complete.  

Modifying the D-shape 
The inner D-shape of the handle will now be modified to include a variable radius fillet of radius 4mm increasing to 6mm at the mid-point of the curved section. 

1 Zoom into the D-shape 
2 Fillet the vertical internal corners with a radius of 4mm. 

 Filletting these vertical edges first will provide one continuous edge around the entire D-shape. 
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3 Select the top inner edge. 
4 Select the Advanced option in the Fillet dialog to display the Variable Radius Fillet dialog. 

 
This dialog allows you to use the mouse to select an arc that represents the radius of the fillet at a location around the curve representing the shape. This works in a similar way to variable radius filleting of surfaces covered later. When you move the mouse along the track, the word Key appears. Click at these points to easily generate a numbered arc. The size of this arc can then be stretched or modified in the dialog. 
5 Select a View from Top (Ctrl+5). 
6 Click on the track to define locations for radius 4mm and radius 6mm. 

 
7 Modify the arc radii as indicated on the image above and select OK to produce the variable radius fillet. 
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8 Generate the equivalent variable radius fillet on the underside of the solid. 
9 Close the Fillet dialog. 

 
The main fillets have been generated.  

Removing the solid ribs 
The solid ribs can now be removed from the main solid to produce a grip effect on the handle. 

10 Select ALL the solid ribs, then navigate to Boolean Subtraction  
from the menu. The completed outer model is displayed. 

 
11 Select the Solid in the graphics area. 
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The outer must be cored with a 3 mm minimum wall thickness. Due to dimensional restrictions, some of the features must be suppressed before attempting to create a new solid to represent the inner. It is also necessary to perform additional material removal on the inner along the shaft to maintain the nominal wall thickness. 
In the History Tree click the green ticks next to all six ribs and the logo feature. 

 
 The ribs and logo recess are temporarily removed from the main handle solid. 

 

12 From the General Edits menu, Offset  a copy of the selected solid by    -3mm to provide the inner wall (excluding the ribs and logo detail). 

 
Now that the basic model for the inner solid has been created, the original outer solid must be updated to include the rib and logo features again.  
13 In the History Tree click on all red crosses adjacent to the suppressed features to reinstate them onto the outer solid. 
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Changes to the inner core solid 
Some design modifications are now required on the inner core solid. These include extending the shaft through the end of the outer solid and creating a minimum wall thickness of 3mm below the logo recess. To show these requirements more clearly the Dynamic Sectioning option of Model Analysis will be used. 

1 Select both the inner and outer solid. 

2 Select Model Analysis  then select Dynamic Sectioning .  
3 In the Dynamic Sectioning dialog, select Y in the Axis list. 

 
4 Enter 0 to position the Back face slider halfway across model, and then select the Create Wireframe button as indicated above. Select Close. 

5 Select View from Front (Ctrl+2)  and set the Prinicipal Axis as Y. 

 

6 Quick select ALL wireframe  and select Blank Except (Ctrl+K). 
7 Check the wireframe for acceptable wall thickness and then select the two composite curves defining the section along the shaft centre. 

 As you should hopefully see at the logo recess the minimum wall thickness his reduced to 1mm due to the depth of the recess. 

 
8 Snap a wireframe line to the outer composite curve as shown above, then edit the length to pass through the end wall (for example, increase the length to 200mm). 
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9 From the right hand end of the existing line create another line of suitable length (for example 15mm), at angle of 30° as shown above to create a taper internally and avoid sharp edges. 
10 Select and Blank (Ctrl+J) the two composite curves. 
11 Create a composite curve along both lines. 

12 From the General Edits  toolbar, select Offset . Specify Round discontinuities, No. of Copies 1, and Distance 3mm, then press the Enter key. 

 

 
13 Select the new offset curve, create an extrusion surface  from the 

Surface  menu of Length 40mm (along Y). 
14 Double click on the Surface Extrusion to open the extrusion edit dialog. 
15 Select the Workspace tab and enter a Y coordinate value of -20 to centralise the surface across the shaft. 

 
 
16 Unblank (Ctrl+L) the solids. 
17 Blank (Ctrl+J) the Main solid. 
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18 Make the inner-core solid active, and select the new extrusion surface. 

 This may be easiest in the Solid History Tree. 

19 From the Feature  toolbar, select Boolean Subtracction  to remove everything to the red side of the surface from the solid. 
 The core solid illustrated below also includes the revised wireframe obtained from a further dynamic sectioning operation to show the new wall thickness. 

 
20 Create a composite curve around the end of the core solid shaft. 

 
21 Set the Principal Axis to X and select the new composite curve. 
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22 Create a solid extrusion  and drag it along the -X direction until it 
has passed through the end of the outer solid (for example. Length 20mm). 

 
23 Make the main inner core solid active. 

24 Select the new solid extrusion and, from the Feature  toolbar, 
select Boolean Addition .  

 You may find that PowerShape will not initially add the extrusion to the inner core solid. This may be because the extrusion is of Version 8 format (mainly found in older PowerShape sessions). To fix this select the extrusion a from the Solid Edit toolbar, click on 

the Version 8 Converter icon.  

 
25 Make the outer solid active. 

26 Select the inner core solid and, from the Feature  toolbar, select 

Boolean Remove .  
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The completed solid spade handle component is a shown above. 

27 Select File > Save to update the content of the stored model file. 
28 Close the model. 

Radial Solid Cut 
The Radial Solid Cut feature was new in PowerShape 2014 R2 (available in PowerShape Pro, Toolmaker Pro, PartMaker Modelling and PowerShape Companion for FeatureCAM). It allows users to quickly wrap wireframe around cylindrical solid objects and cutout a pocket feature. Use this option to create a pocket that can be milled using a turn-mill machine. 
This is complete without any complex calculations by effectively unwrapping the selected face of the solid into a sketch plane, allowing wireframe to be created and then wrapped onto the solid face. This example will highlight the method used to create a Radial Solid Cut feature. 

Radial Pocket Example 
1 Open a New Model. 
2 Create a Workplane at 0. 
3 Import the file Radial Solid Cut.x_t from the data folder. 
4 Select an Isometric View (Ctrl + 1). 
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5 Ensure the solid is selected by clicking on it with the graphics window or in the solid history tree. 
 The Radial Solid Cut feature works on a selected solid, however it is good practice to have this as the Active solid when you are editing it. The selected solid is represented by the yellow outlining of the solid. 

6 Click the Solid Feature  button to activate the associated Sub-Menu for solid editing. 

7 Select the Radial Solid Cut  button from the Solid Feature menu. This is located in the solid cut flyout. 

 
This will open the Radial Solid Cut wizard which will guide you through a series of step by step windows enabling you to quickly and easily create a solid cut. 

 
The first window of the wizard requires a selection of the face(s) to be cut. Currently the wizard is best suited to cut separate faces at a time but can handle multiple cuts. 
To make a selection simply click your chosen face(s) in the graphics window, these will be highlighted in orange. In this first example we will create a rectangular pocket on the uppermost cylindrical face of the solid. 
8 Select the Upper Cylindrical Face on the solid as shown in the image on the next page. 
9 The two green ticks in the dialog box denotes when the selection is sufficient to move on to the next window. Note: The workplane will automatically be selected as the Active Workplane. 

 The Z Axis of the Active/Selected Workplane needs to be parallel to the axis of the cylindrical face(s) to be cut. 
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PowerShape now unwraps the selected face of the solid into a plane. Its upper and lower edges outlined by horizontal lines, while also creating guidelines at 0, 90°, 180°, 270° and 360° (same as 0° start and end) to help visualise the distance around the face. 
10 Select Next. 
11 Select a View from Top (Ctrl + 5). While in the wizard this will view down on the unwrapped face usng a temporary workplane normal the the sketch plane. 
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To further help position wireframe around the face of the solid, it is also possible to add further guidelines at any angle. Doing this will simply add extra vertical lines onto the sketch plane which can be used to snap to with the intelligent cursor. 

 
12 Within the wizard add guidelines at 135° and 250° by typing into the provided entry box and pressing the Enter key to accept each angle. Two new guidelines should appear in the view. 
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 Note: Selecting Finish in the wizard at this point will simply create the guidelines as wireframe allowing the user to create the wireframe at a later stage and re-enter the wizard to create the cut. However in this example we will use the wizard throughout to create a Radial Cut. 
13 Click Next. 

 
14 Select Sketch to hide the main wizard dialog and enter the sketch mode. 

 As noted above this will hide the main dialog to enable unobstructed sketching in the graphics window. Reducing down to a Save/Dismiss Changes sketch dialog seen below. 

 
15 By snapping to the 135° and 250° guidelines created, draw a rectangle of approximate height 4mm near to the centre of the solid face. The 

rectangle button from the line menu  is the most effective way of doing this. 
 The angle is measured in the XY plane from the positive X axis in a counter clockwise direction. 
 At this stage don’t focus on accuracy too much, as the process to create a radial cut using the wizard is the main aim of this first example. Although snapping the the correct guideline should give a length of 20.07mm. 



.  5. Solid Modelling 

5 - 68   Autodesk PowerShape 2017  Copyright © Autodesk  

 
 
16 Create a composite curve from the rectangle. As with other solid feature function the use of composite curves is required to perform the function. 

The Composite curve creator  from the Curves menu  is required. Trying to use the ALT + Click shortcut in this case will likely fail in this case. 
17 Once you are happy with the shape and position of you composite curve, SELECT all required curve(s) that you wish to wrap/cut and click the green tick to accept the changes and re-enter the wizard. 

 
Accepting this form will also create a view of the wrapped curve(s) onto the model to show there position and size in direct relation to the solid model. 

 
18 Select Next within the dialog.  
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19 Within the final window of the wizard there are two main options; Cut or Wrap. 
 Wrap will simply create a wrapped curve onto the face of the solid, while the Offset option allows the curve to be projected at a distance away from the face of the solid. 
 Cut will apply the wrap and make a cut in to the solid at any specified depth, or through. It is important to note that this cut is normal to the face of the solid. 
20 Select Cut and a Depth of 1mm, then select Apply. 

 If after you select Apply, changes are required and you are still in the wizard the Remove button will delete the current cut, allowing edits to be made. 
 A Green Tick will notify you that the current selection is OK and ready to be cut. 
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21 As you can see the Cut has been performed successfully, Select Finish. 

 
Looking to the left at the Solid History Tree we can see that this feature has been created by effectively creating a solid from the wrapped curve and the using a Boolean Remove function to create the cut. 
The curve that was created on the unwrapped solid face in the wizard is also kept after the operation. This can be deleted altogether, or you could put it on a separate construction level. 

 As this is a solid the cut faces are easily edited using further Solid Features like solid fillet and wall draft. 
22 Ensure the solid is active which is denoted by the red flag next to the solid in the solid history tree. 

23 From within the Solid Feature sub-menu select the Solid Fillet . 
24 Enter a Radius of 0.5mm and select the option to Fillet a Face. 

 The Fillet a Face allows you to select faces of the solid and automatically select and fillet all the face edges to save time multi-selecting faces. 
 Currently solid edits to the radial cut feature are only supported after the feature has been created and once the wizard has been finished. 

 



5. Solid Modelling  

 Copyright © Autodesk  Autodesk PowerShape 2017   5 - 71 

 
25 Select the face at the bottom of the radial cut pocket. 

 
26 Click Apply then OK to accept and save the changes and create the fillet. 
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Solid Base Groove 
Next we will create a complex radial groove round the lower cylindrical face of the solid. We can easily create a simple groove using a variety a solid feature methods, however for the groove to take a more complex path the Radial Solid Cut method simplifies this process. 

1 Ensure the Active Workplane has its Z Axis parallel to the axis of the cylindrical face you plan to cut using the Radial Solid Cut feature. 
 This should already be the in place from the previous example, however it is good practice to develop a process of checking everything is in place before you start the feature wizard. 

2 Select an Isometric View (Ctrl + 1). 
3 Ensure the solid is selected by clicking on it with the graphics window or in the solid history tree. 

4 Click the Solid Feature  button to activate the associated Sub-Menu for solid editing. 

5 Select the Radial Solid Cut  button from the Solid Feature menu. This is located in the solid cut flyout. 

 
Again, this will open the Radial Solid Cut wizard which will guide you through a series of step by step windows enabling you to quickly and easily create a solid cut. 

 
6 Select the Lowest “Base” Cylindrical Face on the solid as shown in the image on the next page. 
7 The two green ticks in the dialog box denotes when the selection is sufficient to move on to the next window. Note: The workplane will automatically be selected as the Active Workplane. 

 The Z Axis of the Active/Selected Workplane needs to be parallel to the axis of the cylindrical face(s) to be cut. 
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8 Click Next. 
9 Select a View from Top (Ctrl + 5). While in the wizard this will view down on the unwrapped face usng a temporary workplane normal the the sketch plane. 

 
This page of the wizard allows extra vertical guidelines to be created at any angle around the solid face beyond the default lines to further help position wireframe around the face of the solid. In this example we will use the default angular guidelines. 

10 Click Next. 
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11 Select Sketch to hide the main wizard dialog and enter the sketch mode. 

 This will hide the main dialog to enable unobstructed sketching in the graphics window. Reducing down to a Save/Dismiss Changes sketch dialog seen below. 

 
12 Using the Automatic Dimensioning  tool in Annotation Menu  select a vertical guideline to measure the overall height of the base. 

 
13 Select and Delete the dimension. 
14 Select the lower horizontal line that represents the bottom edge of the solid face. 

15 From the General Edits  menu, choose Offset . Ensuring the orange arrow is pointing upwards from the line, Offset copies of the line 2.5mm & 7.5mm, and then close the offset form.  
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 Note how in the sketch mode within the wizard all of the required PowerShape functionality is available. 

 
 This is currently the most efficient option to create horizontal guidelines to aid wireframe creation. As you can see by offsetting the lower line upwards we have created guidelines at known values in Z that can be snapped to using the intelligent cursor. 

Next we will create a zig-zag line with a height varying between 2.5mm & 7.5mm from the lower edge of the face changing direction every 90°. 

16 From the Lines  menu on the Main Toolbar select Continuous Line 
. 

17 Starting from Y = 2.5mm (current workplane in view) create the line as shown. 

 
18 Convert the wireframe into a composite curve . 
19 With the curve selected, move the curve and create copies 0.5mm vertically (in Y in this case) in both directions and delete the orginal. 

 
20 Using the vertical guidelines that are already in place and the two composite curves, track a single closed composite curve around both zig-zag profiles. 

 Using the guidelines that are already in the sketch saves using having to create lines to close the curve off. Remember to Zoom In and Pan around the model while tracking the curve to ensure the correct curve is produced. 
21 Once the curve is closed as shown below, save the curve in the composite curve creator and eject to close the form. 
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22 Once you are happy with the shape and position of you composite curve, SELECT all required curve(s) that you wish to wrap/cut and click the green tick on the sketch dialog to accept the changes and re-enter the wizard. 

 
Accepting this form will also create a view of the wrapped curve(s) onto the model to show there position and size in direct relation to the solid model. 

 
23 Select Next within the dialog. 
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24 Select Cut and a Depth of 0.5mm, then select Apply. 

 If after you select Apply, changes are required and you are still in the wizard the Remove button will delete the current cut, allowing edits to be made. 
 A Green Tick will notify you that the current selection is OK and ready to be cut. 
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25 As you can see the Cut has been performed successfully, Select Finish. 
26 The curve that was created on the unwrapped solid face in the wizard is also kept after the operation. This can be deleted altogether, or you could put it on a separate construction level. 

 As this is a solid the cut faces are easily edited using further Solid Features like solid fillet and wall draft. 
27 Ensure the solid is active which is denoted by the red flag next to the solid in the solid history tree. 

28 From within the Solid Feature sub-menu select the Solid Fillet . 
29 Enter a Radius of 0.25mm. 

 
30 Select the ALL the edges surrounding the face at the bottom of the radial cut zig-zag groove. 
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31 Click Apply then OK to accept and save the changes and create the fillet. 

 
Exercise 4: Solid model 

 
32 Using the basic dimensions provided generate a solid model.  
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33 Select File > Save As: 

.....\Training Data\Coursework\Exercise 4.psmodel 
Close the model.
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Exercise 5: Solid lever 
1 Open the previously completed wireframe model from Chapter 2 

.....\PowerShape_Models\lever-example.psmodel 

 
2 Generate a solid model using the following dimensions. Use the inner three circles to create the through holes. 

 
 

3 Apply a 5mm fillet to both upper and lower intersecting features as shown 
 

 
4 Select File > Save As: 

.....\Training Data\Coursework\Exercise 5.psmodel 
5 Close the model. 
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Exercise 6: Assembly plate 
 
1 Generate a solid model using the dimensions provided.  

 

 
 

2 Select File > Save As: 
.....\Training Data\Coursework\Exercise 5.psmodel 

3 Close the model. 
 

 



5. Solid Modelling  

 Copyright © Autodesk  Autodesk PowerShape 2017   5 - 83 
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What is a Surface? 
A surface is a skin of negligible thickness stretched across a defined 2D or 3D area.  
There are 3 main types of surface supported by PowerSHAPE: Primitives, NURBS and Power Surfaces. Each surface type has different constructional attributes and editing capabilities.  

When Surface  is selected from the main menu, the following buttons are displayed to the left of the graphics area. 

 

Surface Modelling 
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          A definition of each function is as follows. 
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Primitive Surfaces 
PowerSHAPE can quickly create a range of simple surfaces defined by a few basic parameters. These are Primitives; they include seven standard shapes, extruded surfaces and surfaces of revolution. Using primitive surfaces, only the basic dimensional parameters can be modified with the original defined shape being fixed. Other types of surfaces used in PowerSHAPE include NURB surfaces (frequently obtained from imported data) and Power Surfaces. NURB surfaces also have limited editing capability and along with primitive surfaces must be converted to Power Surfaces for more powerful and complete editing capability. 
The PowerSHAPE Primitive Surface options include: 
 
 Primitive - Plane, Block, Sphere, Cylinder, Cone, Torus. Helix. 
 Extruded surfaces (from pre-defined wireframe). 
 Surfaces of revolution (from pre-defined wireframe). 

 
The Primitive Cone Surface is shown selected with the Cone editing dialog displayed. 

 The Surface Cone is a skin with the top and base open. 

NURBS surfaces (Non-Uniform Rational B-Spline) 
It is common for a surface model created using a different CAD system to be imported into PowerSHAPE. For this to be possible, PowerSHAPE supports other types of surface definitions such as NURB surfaces. PowerSHAPE also creates NURBS Surfaces during certain applications or if specified by the user in PowerSHAPEs Surface options. 

Conversion of Primitives and NURB to Power Surfaces 
If you want to perform more complex modifications to the shape of a Primitive or NURB Surface, you must first convert it to a Power Surface. With a Power Surface, you have access to a full range of editing options through a comprehensive Surface/curve editing toolbar or Dynamic operations.  
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 You cannot convert a Power Surface to a Primitive or NURB Surface. 
Select Menu > Tools > Options > Objects > Surfaces ensure that in the section labelled Primitives that Create as NURBS is deselected if direct conversion from Primitives to Power Surfaces is required. Otherwise, when Convert Surface is applied to a Primitive, the surface becomes a NURBS which, in turn, will have to be converted to a Power Surface. 

 Several of the surface creation options directly create a Power Surface. 
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Power surfaces 
A Power Surface is based on a network of 4 sided wireframe elements appearing as curves along (longitudinals) and across (laterals) the surface. 
A Power Surface can generate complex forms while retaining full editing capability including the direction and magnitude through surface curve intersections (Control Points). 
To define holes within the surface area or an outside profile not compliant with a 4 sided wireframe structure, specialist trim curves called Boundaries are applied.  
The area of surface between adjacent pairs of laterals and longitudinals is called a patch.  
The curves on a Power Surface are called longitudinals (along the surface) and laterals (across the surface). In some cases another, optional curve exists called a spine. This generally runs along the longitudinal direction, often in free space controlling the orientation of the laterals. 
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Laterals  This surface contains the minimum, 2 laterals that run across the surface direction. 
Longitudinals  This surface contains a total of 7 longitudinals flowing from corresponding points from the first to the second lateral. 
Spine (Drive Curve) the spine (shown dotted) is used to control the orientation of the laterals. A spine is not mandatory and can be created or deleted as required without changing the surface shape. It occurs automatically such as during the creation of fillet surfaces or as part of the controlled geometry of a Drive Curve surface. 
The Cato mark  This identifies the start point for Laterals and Longitudinals on a Power Surface. It is positioned a short distance from point 1 along lateral 1 with a short line pointing from it, representing the Longitudinal direction. 
 
Laterals and Longitudinals can be indentified by selecting the Select Curves on Surface button from the Surface/Curve Edit Toolbar.  
The Surface below has 6 Longitudinals and 5 Laterals 

          



6. Surface Modelling  

 Copyright © Autodesk  Autodesk PowerShape 2017   6 - 7 

Standard Primitive Surfaces  
There are seven standard primitive surfaces in PowerSHAPE: Plane, Block, Sphere, Cylinder, Cone and Torus and Helix. Primitive surfaces are generated with minimal data input and can be an ideal starting point for many applications. Primitives are coloured blue or gold in the toolbar to distinguish them from other surface creation options. 

 
When you create a primitive, it is given a size that is proportional to the zoom of the screen. It can be modified as required. A primitive can be moved, copied, rotated, intersected and filleted. However, if you need to alter the defined shape by actions such as moving surface points or adding extra sections, you must first convert the primitive to a Power Surface. 
All primitives are created in the direction of the active Principal Axis (by default this is along the Z-Axis). 

Extrusion Surfaces  
This type of surface is formed as an extrusion of a wireframe entity, normal to the planer base of the wireframe (default). If required, it is possible to change the settings in Tools > Options > Objects > Surfaces for the extrusion surface to generate along the active X, Y, or Z axis. If several items are selected for extrusion, a series of separate surfaces are generated.  
As with standard primitives, you can change only basic parameters for an extrusion surface, unless you convert it to a Power Surface. 
By default, the wireframe used to create the extrusion surface is deleted. To retain the wireframe, select Tools > Options > Object > Surfaces and select- Keep wireframe (extrusions and revolutions). 
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Extrusion Example 1 
This example demonstrates creating a wireframe polygon which is then used to generate an octagonal extrusion surface. 

1 Open New Model.  

2 Select Polygon  from the Line toolbar.   
The Polygon dialog is displayed. This allows you to specify the Number of sides in the polygon. The option to Create composite curve provides the ability to create a polygon as a single entity. If this option is deselected, the sides of the polygon will consist of single lines. 

 
3 In the Number of sides box, type 8. Select Edge points and select Create composite curve. 
The start and end points of the first span need to be defined before closing the form. 
4 Enter 0 in the Command Input box and press Enter. 
5 Enter 50 in the Command Input box and press Enter. 
6 Select OK to close the Polygon dialog. 

 
The wireframe is completed as a single closed composite curve. This will be used as the shape of the Extrusion Surface. 

7 Select the composite curve and switch to View Iso1.   
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8 Select Extrusion  from the Surface toolbar.   

 
This produces an extrusion surface from the selected composite curve up the Z-axis by a default value.  
The extrusion has a set of double arrows (indicated by yellow arrow above), which are used to change the length up or down the Z axis and, if required, to create a negative extrusion (lower set). The workplane handles can be used to dynamically edit the position and orientation of the surface. 
9 Drag the arrows to a length of 50. 

 
10 Alternatively Double-click on the surface to display the Extrusion dialog. This can be used to enter or modify the dimensional values. The extrusion can be given a positive or negative draft angle. 

 
Using the Workspace Tab the extrusion can be repositioned by entering new origin coordinates, and aligned to, or rotated about an axis. 
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11 Enter a length of 100mm and select OK. 
12 Deselect the surface by clicking away from it. The extrusion surface is completed. 
PowerSHAPE can also simultaneously extrude several separate geometry items to make individual surfaces. 
13 Select the extrusion surface. 
14 Right-click and select Delete from the popup menu. Alternatively, press the Delete key. 
The surface has now been deleted; the original composite curve does not exist either. This was deleted by default when the extrusion was created. To automatically retain curves, select Tools > Options > Object > Surfaces and select Keep wireframe (extrusions and revolutions). 

Extrusion Example 2 
 
A 3D wireframe can be used to create an extrusion surface. 
1 Import the model from: 

.....\PowerSHAPE Data\3D_Wireframe.dgk 
2 Activate Workplane 1 from the Workplane selector. 

 
An extrusion surface will be created from the imported 3D composite curve. 

3 Select the composite curve and create a surface extrusion  to a length of 50mm. 
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The extrusion direction is normal to the planar base. This default can be changed. 
4 Select Undo  to return to the stage prior to creating the extrusion surface. 
5 Select Tools > Options > Object > Surfaces. 
The Primitives section controls the default behaviour when primitives are generated. By default, Create extrusions normal to planar base is selected. 

 
6 Deselect Create extrusions normal to planar base and select OK. 
7 Select the Z Axis , and select the composite curve. 
8 As before, create a surface extrusion. 

 
9 Select File > Close without saving the model. 
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Surfaces of Revolution Example 
(Using constraint based sketching) 
 
A surface of revolution is created by rotating single geometry or a composite curve around a specified Principal Axis.  

1 Open New Model  and create a Workplane at 0 on the XY ‘face’. 

2 Select Sketch command  this will display and activate the Sketch Toolbar 

3  
 

4 Using the continous line command create the following sketch and dimension with the Dimension constraint. 

 
 
Modify any dimension that is required by double clicking and entering a figure in the checkbox. When complete select the green tick to accept. 
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Select all of the wireframe geometry and then rotate 360° around the workplane to generate a surface. The correct axis for rotation must be pre-selected using the principal axis selector. In this case, it can be clearly seen the Y axis is required for the correct revolution. 
5 Select the Y-Axis.   
6 Create a composite curve of the section geometry, and select the wireframe.  

7 Select Surface of Revolution  from the Surface menu.   

 
 The selected Geometry is spun around the active axis (Y) producing the bottle shape.  

The red side of the surface represents the negative side. If the cylinder appears red following the revolution, then reverse the surface by selecting 
 from the Surface Edit toolbar, or alternatively right-click>reverse.  

If any dimension or geometrical changes are required Right Click on model and select Modify to display the Edit Revolution dialogue form. Select Sketch followed by Edit Sketch 
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When changes are complete accept. 
An end cap will be created by generating a curve around the end profile, and applying the Fill-In surface option. 

8 Select the view Iso3 (Ctrl+7).   
9 Create a Composite Curve on the open edge.   

 
10 Select the new composite curve. 
A fill-in surface can be generated from a composite curve or a series of wireframe entities. It is useful for filling in gaps in models. 

11 Select the Smart Surfacer  from the Surface toolbar.   
12 In the drop-down list, select Fill In (if not already selected). 

 
 This Wizard will be used in detail later in the chapter. 

13 Select OK. 
 The surface is generated but negative side up. 

14 Right-click and select Reverse from the menu. 



6. Surface Modelling  

 Copyright © Autodesk  Autodesk PowerShape 2017   6 - 15 

The surface is reversed showing the user-defined, coloured side, which is the outside. 

 
15 Select File > Save As and save the file as: 

.....\Coursework\Primitive cylinder.psmodel 
 When you save a model the undo/redo history is reset. Only changes made after the last save can be undone or redone. 

16 Close the model. 
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Wheel Example  
Create the following wheel shape section. This will then be altered using various commands. 
1 Open a New Model and Create a Workplane at 0. 

2 Select View from top.   
 

3 Generate the basic wireframe shape and apply constraints as shown below. 

 
4 From the Curve  menu create a Composite Curve  of the wireframe. 

 With simple composite curves with an obvious route, holding the Alt key and clicking the wireframe will create the composite curve. 

5 Select the composite curve and create a surface of revolution.   
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6 Double-click the surface. The Revolution dialog appears showing the workplane options as well as the Angle of Rotation. 
7 Change the Angle to 180° and select OK. The surface is generated through an angle of 180 degrees. 

  
 Due to the properties of surface models as described earlier, the ends of the primitive surface will not be capped. 

Changing the shape of the surface of revolution 
To alter the physical shape of the surface of revolution, the original wireframe must be altered. The wireframe can edited beforehand in the normal way or after the surface has been generated. Both methods will be shown. 

1 Click on Undo  twice to return to the original wireframe curve. 

2 Select Stretch Object  from the General Edits toolbar.    

 
3 Select the top half of the shape, by dragging a box over it as shown. 

 Ensure the geometry to select is completely within the drag box. 
4 Enter 0 50 to move the selected parts 50 mm along Y, stretching the back and inner wall. 

The top half is dragged upwards and the connecting geometry is stretched. 
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5 Select all the wireframe and recreate a surface of revolution.   

 
6 Double-click the surface to display the Revolution dialog. 

 The surface will be modified by directly editing the wireframe.  
7 Select the Sketch tab. 

 
 If required, a copy of the original wireframe can be created. 

8 Select Edit Sketch... 
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9 From the Surface/Curve editing toolbar, select Edit the curve using 
active dimensions.   

 
PowerSHAPE undraws the surface and displays the dimensions for the 

wireframe.  
 
These dimensions can be double-clicked and edited. The surface editing toolbar now displays additional functionality. 

10 Select the upper 15 dimension then Edit active Dimension. . 
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11 In the Value box, enter 35 and select OK. 
12 Change the 200mm dimension to 150mm. 
13 In the Revolution dialog, select the Finish button. 
14 Select OK to accept and close the form .  

The surface revolution is updated to reflect the wireframe changes. 
15 Select File > Save As and save the file as: 

.....\Coursework\Primitive wheel.psmodel 
16 Close the model 
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     Exercise 7: Surface bottle 
1 Using the information provided, create the surface bottle shown. 

 
 The following wireframe defines the sectional shape of the body. 
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 The main bottle body is 200mm in height. 

 
 The following wireframe defines the profile of the bottle top. 
 

 Create the bottle top arc using  arc through centre, radius and 
span from the circle menu.   

 
 Ensure fill in surfaces are applied to both top and bottom of the body. 
2 Save the model as: 

.....\Coursework\Ex7 Surface bottle.psmodel 
3 Close the model. 
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Power Surfaces from Wireframe 
Smart Surfacer  

Several of the PowerSHAPE surface creation options have been included into the Smart Surfacer. If you select wireframe before opening the wizard then the most likely surfacing method is selected ready to be previewed and/or applied. If an alternative, valid surfacing method is required, you can toggle to it by opening the list of options and clicking on the downward pointing chevron. 

 
Automatic Surfacing options covered in this section are: 
 Fill-In 
 From-Network 
 Drive-Curve 
 From Separate 
 Two Rails 

Fill-In Surface  
A Fill-in surface is usually created from one or more enclosed wireframes.  A Fill-in surface  can also be created from open-ended wireframes and point data. 
1 Create a new model. 
2 Create a Rectangle from the 0 datum with sides of X50 and Y75. 
3 Create R 15 fillets at both of the top corners. 
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4 Select all the wireframe entities. 

5 Select the Smart Surfacer  from the Surface toolbar.   

 
The dialog automatically selects the most likely surface creation options for the selected wireframes. In this case, a Fill-in surface. 
6 Select OK to accept the surface and close the form. 
7 Select and delete the fill-in surface. 

8 Select Create a point  from the Workplane menu.   
9 In the Command input box enter the following 5 coordinate positions, pressing the Enter key after each one to save them. 

 
 25   37.5   0 
 15   15      5 
 15   60      5 
 35   60      5 
 35   15      5 

 
10 Reselect all the wireframe, including the five 3D points. 

11 Select the Smart Surfacer  from the Surface toolbar.   
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A smooth Fill-in surface has been generated to include the point data. In this case, PowerSHAPE created a NURB surface. If required, the surface can be converted to a PowerSURFACE after. 
12 Select cancel then close the model 

Fill in Surface - Die Example 
A fill in surface can also be made up from several wireframes. When a fill-in surface is generated, the composite curve is used to create the trimmed area within a surface. 
1 Create a new model and Import the following data; 

.....\PowerSHAPE Data\Fill-in_Die.dgk 

 
A new Fill-in surface will be generated inside the rectangular wireframe and from composite curves traced around the top edges of the surface forms. 
2 Hold down  the Alt key, and left-click the upper edge of each surface form to create a new composite curve for each one. 
3 From the Selection toolbar, click Quick select all surfaces and then Blank (Ctrl+J) the selected surfaces. 
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4 Select all the composite curves and right-click on one of them to open the popup menu. Select Delete Dependencies. 

 
When a curve or composite curve is created on an object (for example, a surface), it may be dependent upon that object. This option removes any such relationships that may exist between the curve and in this case, the surfaces. 

5 Select all the composite curves, then the Smart Surfacer.  

 
6 Select OK to accept the fill in surface. 
7 Unblank (CTRL+L) the model. 

 
8 Save the model as 
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.....\Coursework\Surface Die example.psmodel 
9 Close the model 

3D Fill-in Surface Example 
A composite curve does not have to be created in advance because it can be generated within the Fill-in Surface form. 
1 Create a New Model and Workplane at 0.  
2 Start a single line at 50 0 0 and enter a relative end point using the coordinates   -20 0 20. 

3  Create a surface of revolution  around the Z axis. 
 

 
4 Select the Smart Surfacer  
5 Select Composite Curve Creator and trace a composite curve around the top edge of the surface. 

 
6 Select Save and Eject to save the curve. 
When the composite curve is completed, the Wizard recognises that the curve is suitable for producing a fill-in surface. The surface creation dialog is updated, and a preview of the surface is displayed. In this case, the surface is flat, but in many cases, you need a new surface that is tangential to the surrounding surfaces. 
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     Creating a tangential surface 
1 Select Tangent to surfaces in the Smart Surfacer dialog. 

 
 The preview is tangential to the adjacent surface. 
 

2 Select OK to accept the surface. 
3 Close the model without saving. 

Drive-curve Surface 
A drive-curve surface consists of a spine curve along which section curves, are aligned perpendicular, relative to the spine points. Below is a drive-curve surface using a two sections running along the whole length of the 
drive-curve.  The minimum requirement is one sectional wireframe, positioned anywhere along the single Drive-curve. 

 

Racket Example 
The first step is to create the wireframe for the drive-curve of the tennis racket.  
1 Open a New model. 
2 Create a workplane at 0 and then construct the following wireframe. 
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This shape will form the single drive-curve along which the surface will be generated.  
In this case, wireframe sections will be defined perpendicular to and at strategic positions along the drive-curve.  

Upper cross Section 
1 Create a new Workplane and position it at the midpoint at the top of the racket 

 
 

2 View from the Right (+X) and zoom in to the new Workplane. 
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3 Create the following wireframe section on the new Workplane.  

 
 

4 Select the Y principal plane. 
5 Generate two circles of radius 10 with their centres snapped to the end of the open lines. 

 
The drive-curve and each cross-section must be single entities before the required Drive-curve surface can be produced. The sections are already single Full Arc entities, but the drive-curve is a series of arcs and lines which must first be made into a single composite curves. 
6 Create a single composite curve out of the main drive-curve and upper cross section entities. 
7 Select all three sections and the drive-curve. 

8 Select the Smart Surfacer.   

 



6. Surface Modelling  

 Copyright © Autodesk  Autodesk PowerShape 2017   6 - 31 

The Smart Surfacer recognises that the wireframe selection is suitable for creating a drive-curve surface and changes the option in the drop-down list accordingly. A preview of the surface is displayed. 
9 Click OK to accept 

 
This generates a surface with a section that changes from the first circle to the defined section, and then back to the last circle. 
To maintain a particular cross-section at a position on the drive-curve, extra sections can be added.  
10 Select and delete only the surface. 
11 Select the composite curve section at the top of the racket and select the Z principal plane.  

12 Select Rotate items   from the General Edits toolbar.   

 
A blue arrow indicates the directional axis and position of rotation. Although the direction is correct, the position will need to be moved to the centre of the racket if the section is to be copied to the correct position.  

13 Select Reposition rotation axis  from the Rotate toolbar then snap to the centre key point of the circ le racket as shown. 
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The Rotational axis has moved to the centre of the racket. 
14 Select Copy the selected item button, enter Angle as 90 then Enter. 

 
A copy of the original section is previewed. 
15 Select the green tick to confirm. 
16 Enter 180 in the rotate form then green tick to accept. 

 
17 Close the rotate form and reselect the drive curve and 5 section entities. 
18 Generate a surface from drive-curve using all five sections. 



6. Surface Modelling  

 Copyright © Autodesk  Autodesk PowerShape 2017   6 - 33 

 
The elliptical shape is now constant between the three sections indicated. 
19 Select File > Save As: 

.....\Coursework\surface racket 
20 Select File > Close. 

Surface from separate curves  
If separate curves are selected, the Smart Surfacer uses the Create a surface from separate curves option. 
     

 
The separate curves are defined across the surface (laterals), which are then linked with curves of best fit along the surface (longitudinals). 

Lateral Curve Example 
1 Create a new model and workplane at 0. 
2 Create a continuous line from the workplane, using the distances 10 in Y, 10 in X, and 10 in -Y to produce an n-shape. 

 
This section is the basis for the other sections, so the next step is to copy it up the Z-axis as individual lines:  
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3 Select the three lines, then Move/Copy items  from the General 
Edits toolbar.   

4 Enter 2 for the No.```` of copies and the value of 0 0 5 in the position window.  

 
5 Confirm the preview with the green tick. 
Each composite curve will be filleted by a different radius. 
6 Make composite curves from each set of lines (Alt key and left-click). 
7 Create a fillet radius of 1 on the bottom curve. 
8 Create a fillet radius of 2 on the middle curve. 
9 Create a fillet radius of 3 on the top curve. 

 
An additional two curves will be copied to produce a total of 5 curves. 

10 Select the lowest composite curve and Move/Copy it up the Z-axis by 
20.   

11 Select the second from bottom composite curve, and Copy it up the Z-axis 
by 10.   
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All of the shapes have been turned into composite curves, ready for surface generation. Each of the composite curves will be turned into a lateral on the surface. 

12 Select all of the composite curves then Smart Surfacer.   
13 Select Surface  and select Smart Surfacer  from the Surface toolbar. 

 
The Wizard analyses the selected wireframe and selects the surface type to be created as From Separate. 
14 Select OK to create the surface from separate curves. 
15 Close the file without saving. 
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Surface From Network of Curves 
Surface from Network creates one or more four-sided surface patches over a network of wireframe. Surface definition will not occur on any open ended parts of wireframe that extend beyond the network. 

         
Surface Gap Example 

The following example uses Automatic surfacing and applies a Surface From Network to blend across a significant gap in the model. 
1 Open a new model. 
2 Import the model. 

.....\PowerSHAPE_data\network_example.dgk 

3 View in ISO1  to show the gap to be filled. 

 
To fill the gap with a smooth surface, additional wireframe curves will be created. By default, the tangencies of the existing surfaces are used by composite curves defined along existing surface edges.  

4 Switch to Wireframe view  so the internal geometry can be seen. 
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5 Select Create Composite Curve.    

 
The Composite Curve toolbar is displayed. 
6 Select Define Start Point, then click on the key-point on the corner of the surface shown. 

 
7 Select the bottom edge with the left mouse button to create the first part of the composite curve.  

 
The curve continues to the first branch point awaiting further interaction from the user. In this case, too far. 
8 On the Composite Curve toolbar, select Backwards  once to go back one span. 
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9 Left-click on the opposite corner indicated by the red arrow below. 

 
A dialog requests if the composite curve jump to this position? 
10 Select Yes. 

 
The composite curve jumps to the selected point while maintaining the tangencies relative to both surfaces. 
11 Select Save  on the Create Composite Curve toolbar. 
12 Create a second composite curve along the three edges shown.  

 
When a composite curve is created along a surface edge, it inherits the tangencies of the surface. These are reproduced if the curve is used to create a new surface from appropriate Smart Surfacer options.  
Although enough wireframe is now available to create a Surface - from Network, a more accurate alignment will be achieved by creating additional curves across the void. Existing lateral geometry will be used. 
13 Select and Blank the last composite curve. 
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14 Create a new composite curve along one of the intermediate curves on the right surface and as before attempt to bridge the gap to the corresponding curve on the left surface (as shown below). 

 
The end of the composite curve is aligning to the surface edge and not, as required, along the intermediate curve! 
15 On the Composite Curve toolbar, select Backwards  once to go back one span. 
16 Select Save  on the Create Composite Curve toolbar. 
17 Similarly, generate another composite curve along lateral above on the same surface as shown. 

 
18 Create two further composite curves along the corresponding surface curves on the left surface as shown below. 

 
19 Select and Blank all surfaces on the model. 
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20 Create a new composite curve with the start point at the start of the existing composite curve as shown. 

 
21 Click on the curve to include it as part of a new one and then click on the continuation at the end of the corresponding curve across the gap. 
22 Select Yes to use tangents. 

 
23 Save  the curve. 
24 Repeat on the curve(s) above. 
25 Delete the two curves that are not part of the required surface network. 

 
26 Unblank (CTRL+L) to bring back the surfaces and composite curve created earlier. 

27 Quick select all wireframe  and then Smart Surfacer.   
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The Wizard selects From Network as the most likely option to create a surface from the selected wireframe. 
28 Select OK. 
29 Select the new central curve running down the surface. Right-click the surface and select Free tangents and magnitudes in the local menu to provide a smoother transition. 
30 Deselect the curves. 

 
The gap in the model is filled in with the new surface which flows smoothly into the adjoining surfaces. 
31 Select File > Save As: 

.....\Coursework\network curve example.psmodel 
32 Select File > Close. 

Surface from Two Rails 
A surface can be generated from a section   that is scaled along two drive 
rails , defining the edge of the surface. 

 



.  6. Surface Modelling 

6 - 42   Autodesk PowerShape 2017  Copyright © Autodesk  

The section is scaled across corresponding points along the drive rails to generate the surface. Drive rail pairs must contain the same number of points and can both, if required, form a closed loop. The end points on an open 
section must be positioned exactly on the start point of each drive rail The linked image cannot 

. Both the section and the drive rails must be defined as composite curves. 

 
Surface from Two Rails Example 

1 Import the model: 
.....\PowerSHAPE_data\two_rail_data.dgk. 

 
2 Select one of the drive rail curves to display the Curve Editing toolbar. 

 
3 Shift-select the other drive rail curve. 

4 Select Show point labels.   
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Each drive rail must have the same direction and number of points. In this example, the opposite. 
5 Select just the top curve (10 points).  

6 From the Curve Editing toolbar, select Create a point. .  
The Insert point into curve form appears. For this example the Parameter Value tab is used. This enables you to insert a point positioned at a proportional distance between two existing ones. For example, 5.5 is half way between points 5 & 6. 

 
7 Select the Parameter tab and enter 5.5. Select Apply and then Dismiss. 

 It is easier to add points from the last number backwards because the curve is renumbered when each point is added. 

 
A point is added to the curve 

8 Select the bottom curve (6 points) then Reverse surface/curve.   

9 With the lower curve still selected, select Create a point. . 
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10 Select the Parameter tab and enter 4.5 then Apply. 
11 Enter 3.5 and select Apply. 
12 Enter 4.5 and select Apply. 
13 Enter 3.5 and select Apply. 
14 Enter 2.5 and select Apply and then Dismiss. 
15  Select both curves. 
Each curve has the same number of points so the generated surface aligns smoothly. 

 
16 Select all three composite curves then Smart Surfacer.  

 
 
The Wizard recognises that a Two Rails surface is the best choice for surface creation.  
However, the section height has scaled in proportion to the distance between the drive-curves at each section position. 
17 Select the Advanced button at the bottom right of the Smart Surfacer form. 

 
The Options for Surface from section and two rails dialog is displayed. It provides more control over the way in which the surface is defined from the selected wireframes. 
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18 Select the Maintain Depth option and select Preview. 

 
This time the height has been maintained to that of the original section. 
19 Select OK twice to accept. 
20 Select File > Save As: 

.....\Coursework\two rail surface example 
21 Select File > Close. 

Limit selection 
Limit Surface using a Surface as the Cutting 
Object 

When the Limit selection  option is applied with surfaces, they are trimmed back to their common intersection. The Next Solution option enables you to toggle through all possible trim combinations. When a surface has been included in the limit selection process, a boundary is created, and only the part of the surface either inside or outside is displayed. Several surfaces can be limited with a single cutting object. 
1 Create a new model and workplane at 0. 

2 Create a plane primitive surface  on the 0 datum of size X 50, Y 50. 

3 Create a cylinder primitive surface  of Length 40 and Radius 5 positioned at Z-20. 

 
The cylinder will be limited by the plane. 

4 Select Limit selection  from the General Edits toolbar.   
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5 Select the Plane surface. 

 
The Plane has been assigned as the cutting object.   

6 Click anywhere on the top side of the cylinder surface. 

 
The plane and cylinder are automatically trimmed back to their common intersection. 

 This is one of several solutions; the others can be obtained by 
clicking Next Solution.   

7 Keep selecting Next Solution  until the following trim combination is displayed. 

 
8 Close the Limit selection form.   

 If the lower half of the cylinder is clicked during the original selection process, it would be the initial solution. 
9 Select Undo.   



6. Surface Modelling  

 Copyright © Autodesk  Autodesk PowerShape 2017   6 - 47 

10 Select the plane surface first and then Select Limit selection.  

 
By selecting a surface first, the form opens with it assigned as the cutting object. 
 

11 Click  to change to the Keep both option.   
12 Select the cylinder surface.  

 
 When Keep both is active, Limit selection splits the secondary surface selection into two surfaces, one on each side of the Cutting Object. 

13 As before, close the form  then Undo.  
14 Select the plane surface first and then Select Limit selection.  
15 Click  to disable Trim both.   
16 Select the cylinder surface. 

 
 When Trim both is disabled, the Cutting Object (primary selection) is not trimmed back to the secondary selection. 

17 Close the model without saving. 
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Limit Surface using a Curve as the Cutting 
Object  

A wireframe entity can also be used as the Cutting object, This as shown in the following example.  
1 Open a new model and import the following data; 

.....\PowerSHAPE_Data\Limit2.dgk 

 
The imported model contains a component made up of six separated surfaces and some wireframes defining the 2D trimming requirements. 

2 Activate Workplane 1 located at the base of the component. 

 
3 Select X as the operational direction.  
4 Pre-select all the surfaces and the composite curve aligned on to the left (as shown above).  

5 Select Curve projection  from the Curve Toolbar.   
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6 Select the option Through item then OK. 

 
A composite curve has been generated through the component in the X axis. 
7 Select Z as the operational direction. 

8 Select the new composite curve then Limit selection.  
 The curve is the cutting object.  

 
9 Drag a box to select all the surfaces and, if required, click Next solution to produce a trim retaining the parts of the surfaces above the split curve. 

 
10 Close the form. 
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Limit Surface using a Workplane as the 
cutting object 

 
A Workplane can also be used as the cutting object as shown in this example. 
 
1 Activate Workplane 2 as shown. 

 
2 Select the Workplane itself then Limit selection.  
3 Box select all the surfaces and, if required, click Next solution to produce a trim retaining the parts of the surfaces below the workplane (-Z). 

 
4 Click the cross at the top-right corner to close the Limit selection toolbar. 
5 Close the model without saving. 
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Surface Filleting 
As with Solids, Surface filleting is mainly used to create a smooth join between two or more surfaces.  
A fillet surface is the developed outside contour of a ball if rolled between two or more surfaces. PowerSHAPE can create both fixed and variable radius fillets between surfaces. Where the ball makes contact defines the outer edges of the fillet to where, by default the original surfaces are trimmed back to the fillet edge. It is also possible to create a fillet between a composite curve and a selection of surfaces.   
PowerSHAPE creates concave fillets running from the outside (user-defined colour side) or convex fillets from the inside (red side) of the host surfaces. The concave filleting direction for each surface is marked by an arrow which, if clicked, reverses the surface causing a concave fillet to run from the other side. Otherwise, the convex option is applied. 

Basic Fillet Example 
This example demonstrates the basic filleting options between 2 surfaces. 
1 Create a new model. 

2 Create a plane primitive surface  of length 100 and width 100 at 0 0 0. 

3 Create a Cone Primitive of base radius 30, top radius 15 and length 50 at 0 0 0. 
4 Right-click over the cone and select Convert Surface (converts to Power Surface). 

 
A selected Power Surface displays more information graphically and editing options the Surface editing toolbar. 
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The small arrow points outwards from the surface, indicating that this is the outside edge of the surface. The large arrow indicates the operational direction for editing surface points  
 The large arrow does not affect filleting. 

5 Select both surfaces and switch to Transparent Shading.   

6 Select Surface fillet from the Surface toolbar.   

 
The surface direction arrows are displayed. If clicked, these turn the surface inside out. The small arrow points away from the outside (user-defined colour) face of surface. 
7 Leave the default 5mm radius and concave setting, and select Preview on the Fillet Surface dialog. 

 
The fillet track is displayed as the centreline of the rolling ball as it runs along the selected surfaces. If it is acceptable, select OK, otherwise enter alternative values and select Preview again until the end result is acceptable. 
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8 Select OK on the dialog. 

 
The Select Fillet Route dialog is displayed. 
The single drive curve now turns yellow to show that it is selected. As there is only one track available in this case, select OK to create the fillet.  
For examples with more than one track, no track is pre-selected. Select each one and Apply in turn, until all the required fillets have been created. Then, select OK to finish. 
9 Select Apply followed by OK in the dialog. 

 
The fillet surface is produced. The cone and plane are trimmed back to a 5mm concave fillet. 

 
10 Create a Plane Primitive at 0 0 40 with a length and width of 80. 
11 In the Workspace Tab of the Plane form, apply a Y Twist of 10 degrees. 

 
This top surface will be filleted to the cone, but this time the fillet is on the inside of the cone.  
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12 Select just the cone and the angled plane surface, then select Surface fillet 
  

 
13 Enter a Fillet Radius of 3 mm, select Convex and select Preview. 

 
14 Select OK (fillet surface) and then OK (Select fillet route). 

 
The fillet is produced trimming back the top of the cone and the plane. 
Fillets can also be produced with several surfaces. 
15 Select X as the operational axis and create a Cylinder Primitive positioned at  

-30 0 20. 
16 Change the radius to 6, length to 60 and rotate it with an  

X-Twist of–15. 
17 Select and reverse the cylinder surface only (red on outside). 
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18 Select all of the surfaces except the lower base fillet and plane. Then 

Surface fillet.  
19 Enter a Fillet Radius of 2 mm, select Convex, and select Preview. 

 
The available fillet tracks are displayed. The cylinder was initially reversed to control where the fillet tracks appeared. 
20 Select OK. 
In this case, PowerSHAPE has identified two complete fillet tracks. PowerSHAPE allows you to specify which track you wish to use. Fillet tracks are created only between the two separate groups and not surfaces within the same group. 
21 Select the first fillet track nearest the plane (lowest one), which turns yellow. 
22 Select Apply. 
23 Select the second track nearest the top, then select Apply. 
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The surface cylinder is limited back to the fillets. By reversing the cylinder, the fillets are produced internally and not on the outside. 

Filleting using Primary and Secondary sets of 
surfaces 

 
The Filleting option checks every selected surface to find all the potential tracks. Where there are a large number of surfaces involved, this can take some time, and it may be awkward to identify the required fillet tracks. 
By using the Secondary Selection option, it is possible to register the two separate sets of surfaces for the fillet to run between. With this option, the first pre-selection of surfaces (yellow) is registered to the Primary (selected) set. If the Secondary box is then selected, any further surface selection is registered as the Secondary set of surfaces (pink). PowerSHAPE only attempts to create the fillet tracks between the separate groups.  
1 Select the lower plane and fillet and delete them. 
2 Select X as the operational axis and create a Plane Primitive at 0 0 20 with a width of 110 and a length of 60. 
3 Ensure the positive side of the surface is facing (+X) as shown. 

 
4 Select the Primitive plane surface then Surface fillet.  
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This surface is now assigned as the primary surface. 

 
This set of selected surfaces will become the secondary set. The fillet routes are calculated only for the intersection between the primary and secondary surfaces. This results in a quicker calculation for the fillet routes. As fewer routes are produced, it is also easier to select the correct ones. 
5 Drag a box over the surfaces on the left as shown, to assign as the secondary set. 
6 Set a Fillet radius of 2 mm and select Convex. 
7 Select OK. 
8 Select the first track and then select Apply. 
9 Select the last track and then select Apply. 

The fillets are produced and most of the other surfaces have been trimmed back. 
10 Delete the detached surface. 

 
11 Use a suitable method to limit the bottom of the plane back to complete the model. 
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12 Select File > Save As: 

.....\Coursework\fillet example.psmodel 
13 Select File > Close. 

More filleting using Primary and 
Secondary surfaces  

The following example uses a simple tap design to demonstrate fillet creation between a Primary and Secondary set of surfaces. 
1 Create a New Model and Workplane at 0. 
2 Generate the following wireframe on the XY Plane. 
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3 Create a surface of revolution around the Y axis. 

4 Rotate the new surface 90 degrees about the X Axis to align it to the Z direction. 

 
5 Switch the operational axis to Z. 
6 Create a new workplane at 0 0 44. 
7 Generate a Sphere Primitive  of radius 7.5 at the new workplane. 

 
The lower half of the sphere will be limited to remove the overlapping surfaces. 
8 Select the workplane, then Limit selection.  
9 Select the Primitive Sphere, and, if necessary, select Next Solution to retain the top half before closing the dialog. 

 Ensure the correct operation axis is selected first! (Limiting occurs in the direction of the active Principal Plane) 
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The Primitive Sphere is limited back to the workplane with the top half being retained 

10 Select a view from Front (-Y) then create the following wireframe geometry for the tap lever shape around the workplane. 

 
11 Create a surface of revolution around the X Principal Plane. 
12 Rotate and copy this surface 3 times by 90 degrees around the Z Principal Plane to make the four levers. 
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The four arms need to be filleted to the central section. Make sure that when shaded, all the surfaces are positive. We do not want to fillet each arm to each other or to generate the route, so we are going to use the Secondary surfaces option. 

13 Select both the shaft and sphere surfaces then Surface fillet.  

 
With the primary surfaces pre-selected, the dialog now awaits the secondary surface selection.  
14 Select the four lever surfaces.  
15 Enter a Concave Fillet of Radius 2 then OK the fillet dialog. 
16 Select OK. 

 
The fillet tracks are displayed. 
17 Select and Apply each one to complete the exercise. 
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18 Select File > Save As: 

.....\Coursework\surface tap.psmodel 
19 Select File > Close. 

Variable Radius Fillets 
Variable radius fillets can be created along the fillet track using the mouse to identify key points or by applying specialist options to position the fillet arcs either by parametric, relative or absolute values.  

Example 
1 Select Create New Model and workplane at 0. 
2 Create two circles with radius 8.5 at X 30 and X -30.  
3 Create an arc through three points of radius 50 on both sides of the two circles to form the following shape. 

 
4 Create a Composite Curve from the wireframe. 
5 Generate a Surface Extrusion of length 60. 
When an Extrusion surface is created, the default option causes the wireframe used to be deleted. This default status can be altered to retain wireframes by selecting Tools > Options > Object > Surfaces>Keep wireframe (extrusions and revolutions). 
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Alternatively, the individual wireframe for an extrusion can be retrieved directly.  
6 From the sketch Tab, select Create a copy of the sketch then OK. 
This returns a copy of the original composite curve to be used to create a Fill in surface at the base of the extrusion. 
7 Select the new composite curve and create a Fill in surface. 
8 Reverse the surface so the red side is facing up the Z axis. 

 
9 Delete the composite curve. 
10 Select both surfaces then then Surface fillet.  
11 Input a Fillet radius of 3, select Convex and select OK. 

12 Select a View down +Z  and switch to wireframe view. 
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The fillet track is displayed (in yellow) with circles (in blue) showing Key points that can be snapped to using the mouse. By snapping at these Key points, an arc of the initial radius is created. The value of this radius can be modified in the Arc Radius area of the form.      
13 Snap to each of the 6 circles when the word Key appears. 
14 6 arcs have been created and can be selected from the Current Arc drop down list. 
A radius appears for each point and this becomes numbered in the current arc part of the form. Individual arcs can be selected from this form or by manually clicking on them. The radius can be changed in the form or dragged manually. 

Graphically, selected arcs are displayed in blue with unselected in red.  

 
New laterals are added either by clicking on the track, or, more accurately, by entering them in the form as a parametric position. To add a lateral at a parametric position, select the adjacent laterals, and check their number on the form in the Current Arc box. Switch the ABS box to PAR, enter the required parametric position (such as 4.5 for midway between 4 and 5) and press Return.   
15 Select the correct arcs (displayed in blue) and insert two new radii between the two at each side, as shown. 
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While the form is active, the values for individual fillet arcs can be edited or deleted. The radius progressively changes between the two arcs assigned with different values. 
16 Select the new arcs in turn and change the radius to 5 mm. 
17 Select the arcs (in turn) on each side of the new larger arcs and select Delete on the dialog (4 arcs in total). 

 
When there is an arc, the fillet value is fixed at that point. If the next radius value is different, the radius changes smoothly along the distance. 
18 Select Apply to create a variable radius fillet. 

 
19 Close the model without saving. 
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Editing a Power surface 
A Power Surface is a surface created from wireframe items.  
If you create or select a power surface, the Surface Editing toolbar will be displayed and the options that are appropriate for your surface are made available. 
There are three entities that you can edit on a surface: 
 the surface itself. 
 the curves within the surface. 
 the points on the surface within the curves. 

 

Editing curves and points on a surface 
Editing curves and points within a surface use the same methods as wireframe curves. 
You can use Edit > Convert > To Wireframe to create wireframe curves from 
selected surface curves (laterals, longitudinals and spines). 

 

Editing the power surface 
You can edit a power surface in a number of ways, most simply: 
 With the power surface selected, use the graphical surface editing features 

to edit it. For example below, a control point is being dragged. 

 
 Select the surface to display the Surface and Curve Editing toolbars. 

 

7. Surface Editing  
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You must have curves selected for the following options to be available from the right mouse local menu. 
Convert to wireframe - A composite curve is created from the selected curve.  
You must have curves or points selected for the following options to be available. 
Edit tangent angles - This displays the Tangent Editor dialog, which allows you to edit the tangent directions and magnitudes of curves. 
Free magnitudes - This frees tangent magnitudes through selected points along the selected surface curve. If no points are selected, the whole curve is freed. 
Free tangent and magnitudes - This frees the tangent directions and magnitudes through selected points along the selected curve. If no points are selected, the whole curve is freed. 

Single Surface Curve Point Edits 
In the same way as curve editing covered earlier, single points on surface curves can be edited directly in the graphics window using a variety of different graphical edit handles, as well as using the Command Box on the Status Bar. Use the handles on curve points to graphically modify single surface curve points. The handles will display only when a single point is selected. 
It is possible to change they different curve point handles within Edit>Surface 
and Curve Edits>Common Edits> Selected Point Graphical Handles or by right-
clicking with a single point selected. 
The following types of handles are currently available to use: 

 Tangent and Magnitude graphic handles. 
 Tangent and Normal graphic handles. 
 Workplane graphic handles. 
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       Tangent and Magnitude graphic handles 
1 Select a point on the curve and right-click and ensure that Tangent and 

Magnitude graphic handles is selected in the menu. 

 
These handles allow the user to graphically edit the Tangency and Magnitude of the curve point.  
The arced handles offset from the end will modify the tangent angle of the curve in a 
fixed circular motion, without affecting the magnitude as can be seen below. 

 
The arrows at the end of each handle will graphically modify the magnitude of the 
curve along a fixed tangent angle, in this case to help the user, PowerShape will give 
interactive feedback of the magnitude. 
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The Spherical handles will modify both the Tangent and Magnitude freely in 2D or 3D 
space. Again, PowerShape will give interactive feedback of the magnitude to the user. 

 
Finally, the spherical handle at the selected curve point position at the centre will edit 
the position of the point, without affecting the direction or magnitude of the point. For 
increased usability the intelligent cursor will remember the original position, and give 
coordinates (X, Y, Z) of the movement. 

 

Tangent and Normal graphic handles 
1 Select a point on the curve and right-click and ensure that Tangent and 

Normal graphic handles is selected in the menu. 
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These handles allow the user to graphically edit the position of the selected point in fixed Normal or Tangent directions, and alternatively freely in a 2D plane. 

 
The arrow handles tangent to the curve will modify the position of the point in a 
fixed direction along the tangent direction. For accuracy the offset distance from the orginal location will be visible, as well as editable once the mouse button has been released. 

 

 
Similarly, the arrow handles normal to the curve will modify the position of the 
point in a fixed direction along the normal direction. For accuracy the offset distance from the orginal location will be visible, as well as editable once the mouse button has been released. 
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The 4 Planar Handles surrounding the point will allow you to move the point freely in a 2D plane while again the original location is kept visible throughout (1). 

 
Again, the central spherical handle at the centre will move the point freely in 3D space while showing X, Y, Z coordinates offset from its original location. 

 

Workplane graphic handles 
2 Select a point on the curve and right-click and ensure that Tangent and 

Normal graphic handles is selected in the menu. 
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Clicking and dragging the workplane axis arrow handles will move the point in a fixed 
axial (X, Y or Z) direction with a visible offset distance from the original position, with the 
option to further edit or fine tune the offset once the mouse button has been released. 
The workplane origin in this case allows the point to be moved freely in 3D space. 

 

Graphically inserting a curve on a surface 
When any point on a surface is selected, the handles of the point will be 
displayed.  

 
 Hold down Ctrl, click on the instrumented point and drag the cursor to the 

position where you want to add the new curve.  
 Release Ctrl and the mouse button to input the curve. This also renumbers 

the other curves to reflect the change. 

 
 If you release the mouse over a lateral, only a longitudinal is inserted. If you release over a longitudinal, only a lateral is inserted. If you release the mouse at a position not on the surface, then no curve is inserted. 
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Graphically moving a point along a surface curve 
 
You can adjust the position of a point along its adjacent curves. 
When any point on a surface is selected, the handles of the point will be 
displayed.  

 
 Hold down the Shift key and drag the instrumented point along its adjacent surface curves. 

 
 Release the Shift key and the mouse button to move the point. 

The shape of the surface does not change. 

 
You can drag the point along a curve up to the next point on the surface. If you drag the point to any other position, the point is moved but the shape of the surface changes. 
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Editing a surface using the toolbar 
When you create or select a power surface, the Surface Editing toolbar will be 
displayed and the options that are appropriate for your surface are made available. 

 
Use the following table to identify the buttons on the toolbar.  
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     Food Container Example 
The project starts by importing the model shown below left, and progresses to the finished outer form of the food container. Key surface editing techniques will be shown. 

        
1 Import the pre-defined CAD data located in: 

.....\PowerShape_Data\SurfaceEditStart.dgk 

Conversion of primitive to Power Surface 
2 Select and Blank the wireframe only . 
3 Make Workplane 1 active.  

 Before any changes can be made, this primitive surface will be converted to a Power surface. 
4 Right-click on the surface and select Convert Surface in the local menu. 

     
 Depending on the settings, the surface is converted to a NURBS surface (the default) or directly to a Power surface. 
 The option can be changed in Tools>Options>Object>Surfaces. 
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With the default setting above, a Power Surface has been created with all of the surface editing toolbar options available. 

5 Select View From Top (+Z).   
6 Unblank to display all entities. 

Dynamic editing of a surface curve  

      
   

Two additional surface lateral curves will be added, using the lines above as a 
reference. Curves can be added in a number of ways. In this example curves will be added using the Workplane intersection option. The new curved will then be manipulated and aligned to the end points of the fillet radius along the route of the lip. 
1 Ensure that Workplane 1 is active. 
2 As shown on the right hand side image above, dynamically rotate it to align the Y Axis with the first of the construction lines that run from the 

centre to the ends of the radius on the modified corner geometry. 
3 Set the operational direction to X . 
4 Select the surface to display the Surface editing toolbar. 

5 Select Add curve.  

 
Four methods are available to add laterals or longitudinal curves. 

6 Select the Workplane intersection then lateral from the drop down list. 
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 If a cross-sectional surface curve itself was selected (not surface) prior to opening the form, the Insert option would have pre-set to 
Lateral. 

 
A red outline indicates the position of the new lateral. In this case on the XY plane of the active workplane.  

7 Select Apply to insert an additional lateral curve. 

 
 Image shaded here to show new curve generated. 

8 Rotate the workplane to align the Y Axis with the other of the construction lines that run from the centre to the ends of the radius on the modified corner geometry. 
9 Insert a second additional lateral, flush with the workplane YZ plane. 
10 Select and delete the three straight construction lines. 
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11 Select the two original laterals that are not aligned to key points on the lip-shaped composite curve.  

 
12 Select Delete curve  from the Surface/curve editing toolbar. 

13 Select any curve and ensure smoothing if OFF  from the curve editing 
toolbar.  

 If the option is ON  then smoothing is applied through all points including Powersurface editing. 
     

14 Select the middle surface point on the outer longitudinal in the top-right quadrant ,and dynamically drag it to the corresponding keypoint on the new lip-shaped composite curve (as shown below). 

 
15 Repeat the drag move on the adjacent surface points to create the following.  

 Ensure a keypoint (End) is selected on the compositive curve. 
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The tangency and magnitude through the 3 points requires freeing up to achieve the more natural transition through the points. If smoothing 
was ON  then this would have been achieved immediately. However this example will show how to smooth a surface after creation. 

 

16 Switch to Wireframe View . 
17 Use Shift Select to select the outer longitudinal line, followed by the 3 

points through which correct alignment is required. 
18 Right-click on the longitudinal and select Free tangents and magnitudes in the menu. This creates the most natural geometric flow through the selected 

surface points taking into account the adjacent non-selected points. 
19 Shade the model. 

 
20 Select the longitudinal running around the inside of the rim (indicated 

above) 
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21 Select Break surface  to split the surface into two separate upper and 
lower halves. 

22 Select and delete the upper surface. 

 
23 Select a view from top (down Z), then select the alternate six surface points 

around the outside of the lid as shown below. 

 
If one or more surface curves or surface points are selected, it is possible to select the Edit sub-item option. This lets you apply the General Edit options to the selected sub items and not the surface as a whole.  

 
24 Select Edit sub items  from the General Edits Toolbar. 

25 Select Offset , enter a value -2 and press the Enter key. 
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The selected surface points have been offset inwards, normal to the surface. 

26 Select and Delete  the inner most surface longitudinal curve. 
27 Create a composite curve along the new inner most surface curve. 

 
28 Generate a Fill in surface using the Smart Surfacer.  

 



7. Surface Editing  

 Copyright © Autodesk  Autodesk PowerShape 2017    7- 17 

29 Use the remaining composite curve defining the outer profile, and generate 
a surface of revolution.  
 

 
30 Save the model as 

.....\PowerShape-Models\food container.psmodel 
31 Close the model. 
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Exercise 8 : Surface Jug 
32 Create a surface model of the outside of the jug shown below. 

 

 
33 Save the model as 

.....\PowerShape-Models\Ex8 Surface Jug.psmodel 
34 Close the model 
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Surface Trim Region Editing  
Trim Boundaries 

A trim boundary on a surface defines the trim region of a surface.  
Trim boundaries are created automatically when: 
 creating fillet surfaces. 
 creating draft surfaces. 
 limiting surfaces using Limit Selection and Limit Point. 
A trim boundary consists of parameter curves (pcurves) and ultimately 
parameter points (ppoints) joined together to form a closed region of a surface. 

 
 

PowerShape provides powerful tools to help you define and edit your trim 
region accurately.  

Parameter Curves (Pcurves) and Points (Ppoints) 
Parameter Curves (pcurves) are made up of linear spans that run between 
Parameter Points (ppoints). As moves between ppoints are linear, any curvature is controlled by the proximity of adjacent ppoints within the tolerance setting. 
Ppoints are defined as a proportional distance between surface points. A ppoint defined at 2.5 1.5 is half way between points 2 and 3 along the longitudinal (T) direction and halfway between points 1 and 2 along the lateral 
(U) direction. 
Individual pcurves and Trim boundaries are unique to a surface and can be accessed from the Surface Trim Region Editing toolbar, which can be opened by right-clicking on a surface for menu options or from the Surface Edits toolbar. 

 
The Previous Surface editing Toolbar is now replaced with two toolbars to edit the associated boundary or Pcurve on the selected surface. 
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Selecting Boundary mode  displays the following trim boundary options. 
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Selecting Pcurve mode  displays the Pcurve edit options. 
 

 
 
The following examples will help demonstrate the above.  
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      Switch housing 
1 Open the model  

.....\PowerShape_Data\switch_housing.psmodel 

 
 

2 Select the upper surface and then Blank Except. 
3 Select the surface to display the Surface Edits toolbar. 

 
By default, trimming ON  displays the surfaces in its trimmed state. To 
view a selected surface untrimmed, toggle this icon to Trimming OFF.  

 
4 Ensure Trimming is ON.  
5 Right-click on the surface and select Surface Trim Region Editing. The Trim 

Region Editing toolbar is now displayed. 

6 Select Boundary Edit Mode.   
The whole surface is displayed with the trimmed area identified by a mesh of grey detail lines. All boundaries are displayed, marking the edge of the trimmed, surface area. The pcurves are not displayed in this mode. 
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 If a boundary is deleted from a surface, the associated pcurves remain. 

7 Select Pcurve Edit Mode.  
The pcurves are displayed along with trimmed areas. The boundaries are not displayed in this mode. 

 
If a pcurve is deleted from a surface, any associated boundary is also deleted. 

8 Toggle back to Boundary Edit Mode,  then select the Boundary Selector. 
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When a boundary is highlighted in the form, it is displayed in orange on the 
surface. 
Several boundaries can be selected by holding down the Ctrl key while left-clicking each boundary. Hold down the Up/Down keys to toggle the 
selection of a boundary. Boundaries can also be selected from within the graphics area. 

9 Select both boundaries by selecting them with the Ctrl key depressed. 
10 Select OK on the Boundaries form. 

11 Select Explode  to delete both boundaries. 

 
With the boundaries exploded, the trimming is removed to show the full original surface area. The pcurves remain intact, but are no longer in use as part of a boundary definition. 

 The pcurves still exist and can be displayed by toggling into Pcurve 
Edits.  
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12 Select Autocreate  regenerate the boundaries from the existing 
pcurves. 

 
One of the two boundaries has been regenerated. 
The second boundary did not appear due to the existence of a branch point along the network of pcurves that makes it impossible for PowerShape to determine which route to take (similar to composite curve creation). 

Define the route 
The easiest way to create the required trim option is to manually define the route around the pcurve network as demonstrated in the following section. 

13 Select Recreate  to open the toolbar and display all unused pcurves on the surface. 

 
The Create Trim Boundary toolbar is displayed. Similar to Composite curve creator, this is used to trace along the pcurves to define a boundary.  
All of the pcurves are displayed on the surface and are available for selection. To form a boundary, the pcurve must form a closed route. The edges of a surface can also be used as part of the route of a boundary. 

14 Click on a pcurve along the require route and sequentially, click on the direction arrows to produce the required closed boundary. 
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15 Select Save  and then select Eject.  
16 Deselect the surface to see the trimmed surface more clearly. 

 

Removing excess pcurve data 
The next stage is a repeat of the above, but this time, excess pcurve data is removed, allowing Autocreate to make the trim boundaries automatically. 
 
1 Select the surface. 
2 Select all boundaries  then Explode.  

3 Select Pcurve Edit Mode.  
4 Select the long pcurve along the part not required for boundary definition. 

 
When a pcurve is selected, the ppoints are displayed. These can be labelled, selected, repositioned or and deleted, as required.  

5 Shift-Select the four extra ppoints circled above. 

6 Click Delete Point.  

7 Switch back to Boundary Edit Mode  then Autocreate.  



7. Surface Editing  

 Copyright © Autodesk  Autodesk PowerShape 2017    7- 27 

 
Removing the unused ppoints enables future automatic trimming operations to immediately produce the desired results and not stray along a path defined by redundant pcurve data.  

8 Close the model without saving. 

Repair Incorrectly Trimmed Surfaces 
1 Open the model  

.....\PowerShape_Data\locationlug.psmodel 

 
The model includes several incorrectly trimmed surfaces that require a combination of pcurve and boundary editing to correct the faults. 
The more complex the network of pcurves on a surface, the less likely it is to obtain a trimmed surface automatically. The following worked example shows the stages of pcurve and boundary editing required to produce the correctly trimmed model shown above right. 

 
2 Select the large curved base surface and Blank Except (Ctrl+K). 
3 Enter Trim Region Editing. 

4 Explode  the only existing boundary. 
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5 Switch to Pcurve Edit Mode.  

 
The surface contains two pcurves: one correctly defines the intersection 
with the vertical face of the location lug  ; the other, U-shaped pcurve 

defines the path of an old fillet prior to an amendment, and needs to be deleted. 

6 Select the U-shaped pcurve  and Delete a pcurve.  
7 Select Unblank (Ctrl+L). 

Creating a pcurve from a composite curve  
Pcurves can also be created from standard wireframe and composite curves. 
In this case, a composite curve will be created from the lower edge of the fillet. This new composite curve is then turned into a pcurve and projected onto the 
original curved surface to help trace a new boundary.  
8 Create a composite curve on the lower edge of the fillet surface as shown. 
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9 Blank all except the new composite curve and the curved surface. 

 
10 Select the curved surface and switch to Pcurve Edit Mode.  

11 Select Make pcurves from projecting wireframe.  

 
12 Select Project along principle axis  then the composite curve. Select OK. 

 
13 Deselect the surface and delete the composite curve. 
14 Select the lower curved surface to display the pcurves on the surface. 

The linear pcurve needs to be extended to create a closed boundary. This will ultimately be traced as a D section. 

15 Select the straight pcurve then Extend pcurve.   
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16 In the Extend at list, select Both ends. In the Method list, select Tangentially 

to a pcurve. 
17 Select the other curved pcurve then OK. 

 
 The straight pcurve has extended to effectively create a closed boundary. 

Manually create a new boundary 
1 Switch back to Boundary Edit Mode  then Recreate.  
2 Trace the pcurves to define the new boundary as shown below. 
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 If the trimmed surface appears within the D-shape, select Reverse 
the Boundary  to create the result shown.  

 
3 Select Unblank (Ctrl+L). 

 
The new boundary has removed the overlap between the fillet and curved surface which previously existed. 

4 Blank all surfaces except the front vertical and fillet surfaces. 

Trimming the planar surface 
The planar surface needs to be correctly trimmed with the fillet. 
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1 Explode  all boundaries on the vertical surface. 

 
The vertical surface is untrimmed to its original size and will be limited to the fillet surface. 

2 Use limit select  to trim the surfaces and leave the solution below. 

 
The vertical surface to its full size was not available as a solution due to the complexity of the pcurve network in the surface. However a new boundary will be traced to include this. 

3 Select and Blank Except (Ctrl+K) the vertical surface. 

4 Explode  all boundaries on the vertical surface 

5 Switch to Pcurve Edit Mode to display all existing pcurves. 
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If required, a new boundary can simply be recreated  to include the 
vertical surface.  
However in this case the pcurves circled in red will be edited to leave a 
single closed path. With this, Autocreate  can then be used effectively. 

6 Select and delete  the horizontal pcurve.    
7 Zoom into region  select the vertical pcurve. 

8 Select Turn point labels on/off  to display the ppoint numbers. 

9 Shift select or use ppoint selector to select points 25 to 29 inclusive. 

 
10 Delete the ppoints  

 
Point 24 was not deleted. This will be moved up to the start of the fillet arc. 
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11 Select ppoint 24 and select Edit parametric value at ppoint.  

 
12 Click the point situated before ppoint 24 (shown as keypoint above) and note the updating of the values in the Edit ppoint position form (zoom in as 

close as possible). 
13 Select OK.  

 
 
The position of ppoint 24 updates to the new parametric values. The ppoint is now repositioned to join the start of the fillet arc. 

14 Repeat the above for the opposite side.  
15 Zoom into the bottom left corner region.   

16 Delete  just point 29 on the fillet pcurve. 
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The pcurve is trimmed back to point 28 which is also the intersection point with the adjoining pcurve. 
17 Repeat the above for the opposite side.     
18 Zoom into the top left corner region.   

19 Delete  just point 1 on the vertical pcurve. 

 
20 Repeat the above for the opposite side.   

 
A single pcurve path remains. 

21 Switch back to Boundary Edit Mode  then Autocreate.  

 
A single clean surface is generated. 
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22 Select Unblank (Ctrl+L). 

 
A final problem remains indicated by the arrow above. The vertical D section surface requires trimming back to the top edge of the fillet surface. An overlap can be clearly seen in transparent view. 

Trimming the vertical D-section 
It is possible in this instance that the trimming can be simply applied using 
Limit selection.   

 
23 Trace a composite curve along the top edge of the fillet surface. 
24 Using this curve as the cutting object, limit  the surface to leave the 

required result. 

 
25 Save the model as.....\PowerShape-Models\Location Lug repaired.psmodel 
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Exercise 9: Region trim camera 
 

26 Open the model  
.....\PowerShape_Data\camera repair.psmodel 

 
 

27 Use Trim Region editing ONLY * to repair the three areas highlighted on the surface model. 

 
 

28 Save the model as 
.....\PowerShape-Models\Ex9 region trim camera.psmodel. 

29 Close the model. 
 

*Try not to use Limit Selection  or Smart Surfacer!!    
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   Introduction 
Direct Solid Modelling provides tools to: 
 Make rapid edits to history-free solids.  
 Recognise key solid features for simple editing (for example, fillets, pockets) 
 Add draft to faces and automatically extend and intersect all surrounding geometry to keep a closed solid.  
 Remove and heal to simplify geometry for downstream manufacturing operations or to accommodate design changes.  
 Edit faces, automatically extending and intersecting surrounding faces to maintain a closed solid. This lets you do operations like copying a strengthening rib or offsetting the side faces of a pocket. 
Direct Modelling is particularly efficient for operations that are typically performed using surface modelling and would require you to extend and intersect each surrounding faces manually to create a closed solid. 
These powerful tools will be demonstrated in the following example. 

1 Import  the solid model: 
.....\PowerShape Data\Direct modelling plate.x_t  

 
2 Select the Solid to display the Solid Editing Toolbar. 

8. Direct Solid Modelling 
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Solid Edit Toolbar 
 

 
The following Solid Editing and a number of Direct Solid Modelling tools are available:  

 - Toggle display of the Solid Feature Tree. 

/  - Make the Solid Active/Inactive. 

 - Find and Fix faults in the solid. (Solid Doctor) 

 - Select a Feature on the solid.  

 - Select Individual Faces on the solid. 

 - Select Faces of Continuous Regions. 

 - Select Faces of Convex Regions. 

 - Select Faces of Concave Regions. 

 - Select Faces using a Continuous Lasso. 

 - Select Faces using a Discrete Lasso. 

 - Copy the Selected Faces. 

 - Extract the Selected Faces. 

 - Select and Sew items into the solid. 

 - Remove and Heal the Selected Faces. 

 - Merge Selected Faces. 
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 - Divide the Selected Faces. 

 - Draft Faces of the solid. 

 - Replace Faces of the solid. 

 - Divide Selected solid into Multiple Solids. 

 - Convert between Version 8 solid and Parasolid. 

 - Convert between Surfaces and Parasolid. 

 - Convert between Mesh and Parasolid. 

3 Select  to display the feature (history) tree of the imported solid.  

 
As you can see the solid has no features or history associated with it. 

Direct Solid Modelling demonstration 
Direct modelling functionality can fall into two categories. 
1 Direct editing - Tools which directly change or edit features without creating history (as a new feature). 
2 Feature recognition - Tools which create new features and history. These can then be edited as part of the active solid. 

Direct Editing 
Solid faces which require editing, must be selected first using one of the selection tools available in the Solid Edit toolbar. 

 
Once selected, the following General Edits  can be applied.  

 Move -  

 Rotate -  

 Mirror -  
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 Offset -  

 Scale -  
4 Select and highlight the large curved face shown in the next image. 

 
 By default, the surface select mode is Select individual 

faces.  

5 Select Offset  from the General Edits toolbar.  

 
6 Enter a value of 2mm on the Offset form. 

 
The face has been offset. More importantly however, all surrounding vertical faces have been retrimmed and reintersected automatically.  
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7 Select and highlight the top horizontal face. 

 
8 Select Move  from the General Edits toolbar.  
9 Enter a distance of 3mm in the Z axis and press Enter (for preview). 

 
As expected, the preview of the calculated result is displayed. 
10 Select the green tick  to accept. Note the effect in the region shown above.  

 
The top face has successfully moved by 3mm in the Z axis. All related vertical faces have reintersected and maintained the solid closure. The sloping face achieved this by extending its faces. 
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1 Rotate the part to view the bottom side and zoom into the region shown.  

 
2 Shift select the three faces highlighted. 

3 Select Rotate  from the General Edits toolbar.  

 
4 From the rotate form select Reposition  and click on the keypoint to specify the rotate origin. 
5 Select and drag only of the selected faces to dynamically preview the faces rotating about the origin. 
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6 Release the mouse and enter an angle of 345 before accepting the 
result.  

 
Only the selected faces have rotated to the specified angle. 

1 From the solid edit toolbar change the selection mode to faces of 
concave regions.  

2 Single click in the pocket to highlight all relevant faces. 

 

3 From the Solid Editing toolbar, Select Remove and Heal.  

 
This tool removes all selected faces and then closes the resulting gap by modifying the surrounding faces. 
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4 Remove the two holes and two fillets (indicated in the previous image) 

using Remove and heal.  

 
5 Select the top and cylindrical faces which define the boss feature. 

          
                                                         

6 Select Scale  from the General Edits toolbar.  

 
7 Select reposition scale origin  and snap to the centre of the face using the Arc-Centre keypoint. 
8 Lock the Z axis  and enter a scale factor of 1.5. Select the green tick 

 to confirm. 
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The boss feature has scaled in the X and Y axis by a factor of 1.5. 

 If the Z axis was not locked PowerShape would still have automatically limited back the Z intersection and provided the same result. 
PowerShape provides the ability to divide the default faces, thus providing more control over specific regions that require editing.  

 
1 Rotate the model to view the top and zoom into the area show. 

 
2 Create a single line approximately half way up the concave face, snapping the outside edges.  

 
3 Select the three vertical faces which define the concave recess. 
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4 From the Solid Editing toolbar, Select Divide faces.  

 
5 Select the single wireframe to nominate and update the Divide faces form. 
6 Keep the default projection mode of along face normal  then Apply. 

 
The curve is projected onto the selected faces and now the three faces become six. 

 New to PowerShape 2014 R2 is the option to merge faces  on a solid. This will merge adjacent continuous faces into one continuous face, essentially the reverse of the operation to Divide Faces described above. 
7 Dismiss the form and delete the single line. 

8 Select the lower three faces then Offset  from the General Edits 
toolbar.  
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9 Enter an Offset distance of 3mm. 

 
A 3mm deep step has been generated with relevant faces trimmed correctly. A further three faces have been created to define the horizontal step face(s). 
1 Zoom into and select the three faces defining the corner pocket  

` 
Direct modelling allows draft angles to be quickly applied to selected faces.   

2 From the Solid Editing toolbar, Select Draft faces.   

 
The red cross  indicates a required reference entity. This can be a face, Surface or a Workplane. 
3 Leave the default Face entity and select the top horizontal face. 
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The draft angle can be dynamically pulled to set and preview the required angle. 
4 Dynamically set or enter an Angle of 15° in the Draft faces form before selecting Apply. 
5 Dismiss the form to view the result. 

 
6 Rotate the part to view the bottom side and zoom into the region shown.  

 
7 Select the small flat surface defining the lug feature, as indicated. 

8 From the Solid Editing toolbar, Select Replace faces.   
This allows faces of a solid to be replaced with existing faces (as a reference). In this example, the length of the reinforcement lug will be extended. 
9 Select the face indicated to nominate as the replacement face. 
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10 Select Apply to confirm the preview then Dismiss the form. 

 
11 Repeat the above process to extend the lug on the opposite side. 

Feature Recognition 
The following Direct Modelling tools extract features and create history in the Solid Feature tree. 
1 Rotate the part and zoom into the area shown, then select Create a hole 

 from the Solid features toolbar.  

 
2 From the top right hand corner of the Plain hole dialog, select Feature 

creation  to toggle to Feature recognition mode.  
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In this mode PowerShape is capable of recognising the hole, the parameters that define it and then add it to the feature tree. 

 
3 Select hole.  

The hole is highlighted in blue and the dialog form displays its properties. 
4 Select Apply to accept the results. 
5 Repeat for hole.   
A counterbored tapped hole is recognised. 

 
The two hole features are now visible in the feature tree and can now be modified as a standard solid feature. 

6 Select Create a Solid pocket  from the Solid features toolbar.  

7 Toggle to Feature recognition mode.  
8 Zoom into the area shown and select the first pocket shown.  
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9 Select Apply to generate the pocket, then repeat for pockets  and . 
10 Do not close the pocket dialog. 

 
11 Attempt to select the adjacent pocket shown above. 
PowerShape does not recognise the feature as a standard pocket. In this instance the feature will be extracted as a solid cut feature. 

12 Close the Solid pocket form then select Solid cut.  
13 Extract the feature to add it to the feature tree. 

 
The Solid cut feature is added to the bottom of the solid feature tree below the three solid pockets created earlier.  

The feature recognition of fillets is similar in method. 

1 Select Create a Solid fillet  from the Solid features toolbar.  

 
2 Extract and create the three fillet features shown above. 
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Modifying extracted features 
Recognised features are modified in the same manner as if they were initially created directly in PowerShape.  All current features are displayed in 
the Solid feature tree.  

 
3 Display the dialog for the first pocket by double-clicking the item in the 

feature tree.  
 Or right-click>Modify... 

 
The pocket can now be modified dynamically using the drag handles or updating the Pocket dialog values themselves. 

 
4 Modify the overall dimensions as above and click OK the form to accept changes. 
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All other features can be edited using the same method. 
5 Display the Solid Cut dialog.  

 
In this example the actual profile of the cut will be modified by altering the sketch which defines it. This process was also demonstrated in the Surface Modelling chapter. 
A wireframe sketch was automatically created when the feature was generated. 
6 Select Edit on the Solid cut dialog.  

 
7 From the curve editing toolbar, Select Edit with active 

dimensions.  
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8 Double-click on the bottom right corner dimension (circled red above) to display the Dimension value form. 
9 Change the dimension from 4mm to 2mm. 

 
10 Select OK on the dimension form and the Solid cut dialogs. 

 
The solid cut feature has updated with the new 2mm corner radius. 

Smart Feature Manager 
PowerShape also allows multiple features and feature types to be recognised at once to speed up the process of recreating the solid tree. The 
Smart Feature Manager  is found in the Solid Feature  sub-menu. Selecting the feature type (which can be filtered down to specific sizes, sub-types etc) and then choosing Scan will search the model for features, adding them into the tree. These features can then be grouped automatically. 

 
 The smart feature manager is a very powerful tool however it uses a lot of processing power. It is advisable to scan for single feature types at one time. 



8. Direct Solid Modelling  

 Copyright © Autodesk  Autodesk PowerShape 2017   8 - 19 

Maintaining Solid history  
At this stage, If any direct editing tools were to be applied (e.g. Offset, Draft face), then PowerShape displays a warning to the user. 

 
Applying the edit now would now remove all previous feature history generated. However the following procedure shows how to apply the edit and maintain feature history. A rib feature will be thickened to outline this important step if required. 
1 Select the single face shown. 

 
2 Select Offset  from the General Edits toolbar  and enter a value of 2mm. 

 
The information dialog is displayed. 
3 Select OK to accept. 

 
The offset has been applied but associated history removed.  

 This is because a non history edit was applied to a part containing history. 

4 Select Undo  to revert to previous condition.  
At the bottom of the feature tree, the original imported solid is 
displayed.  
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Maintaining the Solid Tree: Method 1 
1 Right-click on the original imported solid at the bottom of the history tree and select the option to Rewind to Here. 

 

 
This will rewind the recreated build history until the original featureless solid. Note this will also suppress the features that are greyed out in the solid tree. 
2 Select the face on the copied base solid and create on offset of 2mm to thicken the rib. 

 The same warning message will still appear however anything greyed out above the blue rewind position line will be unaffected. 
 If a feature in the solid tree needs to be edited using a non-history edit you can move that feature to the bottom of the tree, just above the base solid and rewind to just above to perform the edit. This will only remove a single feature which can be re-recognised easily. 
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To remove the Rewind Position simply right-click in the solid tree on any feature and select the option to Remove Rewind Position. 

Maintaining the Solid Tree: Method 2 
1 Double click to modify the base solid 1.  

 
2 Select Copy solid  then OK. 

 
A copy of the base solid has been copied out into the feature tree. Note this base solid copy has no history including all the feature recognition items created earlier (holes, pockets...). 
3 Select and Blank the main solid with feature history.  
4 Select the face on the copied base solid and create on offset of 2mm to thicken the rib. 
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5 Unblank to bring back the main original solid with history. 

 
6 As before, double click to modify the original base solid 1.  

 
7 Select Replace Solid. 

 
A replacement solid must be selected. 

8 Select the copied out base solid from the feature tree.  
9 Select OK. 
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The original base solid has been replaced with the modified solid (thickened rib) whilst maintaining the previous history.  
This shows the powerful ability of PowerShape to combine direct and feature recognition features on a component which was imported with no history. 
10 Save the model as..... 

....\PowerShape Data\Direct modelling plate.psmodel 
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 Exercise 10: Pump housing 
 

1 Open the surface model  
.....\PowerShape_Data\pump housing.psmodel 

 
2 Select all the surfaces and convert to a solid.  
3 Using direct modelling to apply the following design changes to the pump housing. 
4 Remove the complete outer Rib feature. 
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5 Lower the inner step face by 5mm. 
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6 Thicken the end plate by an additional 5mm whilst maintaining the edge fillets and hole chamfers. 
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7 Change the outer bore diameter to 40mm. 
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8 Modify the base plate to have six holes (from four) on the same PCD (Pitch circle diameter).  

 
Ensure one of the holes is centrally located to the main vertical rib as shown below. 

 
9 Finally, apply a draft angle of 15 degrees to the bottom face plate as shown. 

 
10 Save the model as..... 

…/PowerShape-Models/Ex10 pump housing.psmodel. 
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Parasolids 
PowerShape uses Parasolids as the solid modelling engine (kernel); all new solids are created using Parasolids. This changeover was implemented from PowerShape 2010. All solids created in PowerShape before that release, are now known as V8 Solids. 
Parasolid is an industry-standard, and is used as the backbone of many of the leading solid modellers, including SolidWorks (Dassault Systèmes SolidWorks Corp), Solid Edge and NX (Siemens). 

Parasolid benefits 
The following are benefits you will get from PowerShape using the parasolid kernel: 
 Faultless data conversion to and from the other parasolid-based modellers. Higher quality transfer to and from other solid modellers because you can request parasolid data from customers instead of IGES or STEP. 
 Faster and more robust solid modelling operations.  
 Faster and more robust drawings. 
 Import and export of Parasolid file formats will conserve the parasolid data with no loss of quality. At present the recommended formats are: 

Parasolid (x_t, x_b, xmt_txt, xmt_bin) 
 Crisper, tidier graphics. 

Model conversion 
 Version 8 solids (pre 2010) will continue to work in PowerShape (post 2010). 
 All new solid models will use parasolid, unless you change the default by selecting the Version 8 solids option on the Tools > Options > Object > 

Solids dialog. 
 Parasolid and version 8 solids can co-exist in the same session. 
 It is not possible to perform Boolean operations between solids of different kernels. One solid must be converted before the operation is attempted. 
 It is possible to convert solids in existing models to parasolid and parasolid to version 8 solids. 

9. Fixing a solid 
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When a solid is selected the Solid Editing toolbar is displayed. 

  

The Find and fix faults wizard  and conversion tool  are located here. 

Identify solid type 
The type of solid can be identified in two ways. 
1 Right-click over the solid to display the local menu and note the name. 

 ‘Version 8 Solid’ prefixes the solid name  

 A Parasolid is simply prefixed as Solid. 
2 With the Solid selected: 

 With the icon IN, it identifies the solid as a V8 solid. 

 With the icon OUT, it identifies the solid as a parasolid.  
A solid can be converted to/from a Parasolid by simply clicking this icon. The default conversion for a surface model is directly to a Parasolid. In both cases, it is likely that the new Parasolid will require work to remove gaps and other inaccuracies. 
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Solid Model fixing 
 
The find and Fix faults Wizard can be selected to verify the solid for common problems. It will also request the user to run the wizard if problems are found during conversion between solid types and from surfaces. 

If the Find and fix faults in solid option  is selected, the Solid Doctor dialog opens for Parasolids, or the original Make Watertight Wizard for version 8 solids. 

If V8 solids require fixing  then the Make watertight Wizard is displayed automatically. 

 
If Parasolids (post V8) require fixing  then the Solid Doctor wizard is launched.  

 
 The Solid Doctor is used to repair parasolids and will be demonstrated in this chapter. 
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V8 Solid to Parasolid - convert and fix 
A Version 8 solid will be imported and converted to a Parasolid. After the conversion process, some areas of the model will require fixing for it to be fully compatible as a Parasolid. These problem areas will be identified and fixed using the Solid Doctor. 
1 Import the model: 

.....\Training Data\PowerShape Data\RadTank-V8solid.dgk 

 
2 Select File >Save as: 

…\Training Data\Coursework\RadTank-Parasolid 
3 Right-click on the solid, the first line confirms it is a Version 8 Solid. 

 

4 Select the Convert Solid  option from the Solid Edit toolbar.  When the conversion to a Parasolid is completed, the following message is displayed. 
 

 
5 Select Yes to launch the Solid Doctor wizard. 
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The Solid Doctor wizard is launched and all faults with the solid are 
organised and displayed into folders (branches).  To reveal the 
individual faults on a branch, click   to expand the branch. The following are classified as faults: 
 Holes. 
 Overlaps. 
 Self-intersections. 
 Bad trimming of surfaces. 
 New faults created by a previous repair option. 

The right hand window  summarises the fault highlighted with suggestions to help repair it. 
The drop down list offers the relevant repair methods which can be applied to the selected fault(s). 
In the graphics area, the faults are labelled on the solid in purple. 

6 Highlight the root folder Solid fault then select  to attempt an Automatic repair. 
 It is recommended the Automatic repair option is initially applied to let PowerShape fix as many faults possible itself. 

 
 One fault (Large Faulty Faces) is repaired and is now labelled in green instead of purple. The repair is identified with a green tick 

in the Solid Doctor Explorer. 
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7 Select the Re-check the solid for faults option.  
The repaired gap is removed from Solid Doctor, and is no longer identified by a green label on the Parasolid. 

 
 However note an extra Gap fault has been added following this Re-check. 

Fix gap (2) 
1 Select Gaps (2) in the Solid Doctor Explorer. Only the related faults (two in this case) are highlighted on the displayed solid. 

 
 Upon close inspection a small gap is evident where the cylindrical and spherical surfaces intersect on both top and bottom surfaces. 

 
In many circumstances a Gap can be repaired quickly using the Solid Doctor Wizard itself. 

2 With the Gaps (2) highlighted expand the drop down list and select Fill gap with tangential surface. 
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 Only valid repair options for the selected faults are listed in the drop down list. 

3 Select Process selected operation.   
 

 
The Solid doctor wizard updates the changes and in this case reports both faults have been repaired. 

4 Select the Re-check the solid for faults option  to confirm and remove 
from the list. 
 It is recommended rechecking the solid after each fix to highlight any new errors have might have been created following the last repair! 

Fix Overlaps (13) 
The 13 overlaps are repaired next. Although a high number of instances are reported, it seems they all originate from a single issue. 



.  9. Solid Modelling 

9 - 8   Autodesk PowerShape 2017  Copyright © Autodesk  

1 Select Overlaps (13) in the Solid Doctor tree. 

 
 

2 Zoom into a region highlighting the overlaps. 
 

 
On close inspection, it is clear that the selected fault is due to the inside wall of the solid overlapping beyond the fillet at the base. This must be repaired manually. 

3 Select the option Extract surfaces and edit them. (Do not process  yet)  

 
Faces that will be extracted are displayed in purple. However there are two upper corner and one lower fillet surface which require inclusion (arrowed above). 
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4 Shift select the two corner and lower fillet faces then Apply selected 

operation.   
 Surfaces can be deselected using the CTRL key. 

 
5 Select Blank Except (Ctrl+K) to hide all except the surfaces highlighted. 

The faulty surfaces are the only selected items in the graphics area. 
6 Switch to wireframe view and zoom into a corner to have a closer look. 

 
The main, inner-sidewall surfaces need to be trimmed back as they are extending upwards, beyond the tangency with the blend surfaces. 

 
7 Create a Composite Curve  and select the lower edge which defines the fillet 

base. 
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8 Select Fast Forward  to quickly trace the complete lower edge around the 

component. 
9 Save and close the form to create the composite curve.  

10 Use the composite curve as the cutting object to Limit  back the vertical surfaces and remove the overlap. 
11 Delete the composite curve. 

 
The overlap has been removed. 
12 Unblank (Ctrl+L) to redisplay the solid and as before, quick select all the 

Surfaces and solids. 
 In the selection menu you can quick select all solids and 

surfaces.  

13 Select Accept all surface edit changes  from the floating Solid Doctor Toolbar 
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The Solid Doctor confirms that the all 13 faults have been repaired. 

14 Select Re-check the solid for faults.   

 
 
 

Fix large hole (1) 
 
1 Select the remaining set of surfaces registered in Large holes (1) in the 

Solid Doctor Explorer. 

 
The process has exposed a surfaces-overlap problem at the base of the fifth rib, from the non-pipe end of the tank. 
2 Select the option Extract surfaces around the hole and edit them. 

3 Select Apply selected operation.   
4  Blank Except (Ctrl+K) to hide all entities apart from the extracted surfaces. 
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The fact that the base surface is not trimmed back to the inside of the rib suggests that there is likely to be a small gap. 

5 Select a wireframe view and zoom into the problem area.  
6 With the Alt key depressed, left-click a composite curve on the top edge of 

the rib surfaces. 

 
7 Select and delete the original rib surfaces (keep the base form surface). 
8 Select the composite curve and generate a surface extrusion which passes through the base surface as shown. 

 
9 Use Limit Selection  to trim back the new rib form surface to the base surface. 
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10 Unblank (Ctrl+L) to redisplay the solid and as before, quick select all the Surfaces and solids. 

11 Select Accept all surface edit changes  from the floating Solid Doctor 
Toolbar 

 
Although the hole fault was repaired, it seems the last operation caused additional faults. 

12 Select Re-check the solid for faults  to confirm.  

 
The new rib surface has created minor overlaps and a gap. 

13 Highlight Solid Fault then Attempt Automatic Repair.   
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The two overlaps have been repaired along with a related gap concern.  

14 Select Re-check the solid for faults  to confirm.  

 
The solid model is reported repaired.  

15 Select OK to accept. 
If the solid doctor was applied again, then the following message appears. 

 
16 Right mouse select on the Solid to display the local menu. 

 
A closed solid also indicates the faults have been repaired. 
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17 Save  to update the model. (Do not close). 

Export Wizard 
PowerShape can export models to formats other than DELCAM Geometry (.dgk).  
The Export Wizard in PowerShape allows the user to export data but providing the additional options. 
 Export selected model items, visible items or all items. 
 Export relative to an active workplane or World. 
 Export drawings (Delcam drafting) 

 
The above repaired solid will now be exported as a Parasolid relative to an active workplane.  
This Workplane will be created first. 
1 Select and highlight the end solid face of the outer pipe as shown. 

 
2 From the Solid edits toolbar, Copy the selected face.  

 
A surface of the selected face has been copied out. 
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3 Just select the surface and then create a Workplane at the centre of 
selection.   

 
 

4 Twist the Workplane in X so the Z axis is along the pipe axis. 

 
With the correct orientation, the model will now be exported. 

5 Select File>Export....from the pull down menu. 

 
The export wizard allows PowerShape geometry to be exported to most common formats (depending on licence).  

6 Highlight Parasolid based modellers then Next>. 
7 Browse to and save as \PowerShape-Models\RadTank 
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 The save as type has automatically set to Parasolid (*.x_t) 

 
With only a single model on the screen, all three options would be applicable. 

 
8 Select Visible, then Next>. 

 
The last workplane created in currently active. 
9 Select Active Workplane then Finish. 

 
10 Select OK to complete the process and export the data as a Parasolid. 

11 Save  to update the psmodel then close. 
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Exercise 11: Solid Doctor Speaker Core 
 
1 Open the PowerShape model: 

.....PowerShape_Data\Speaker Core_Surfs.psmodel 

 
 

2 Convert the surface model to a parasolid with no faults. 
3 Once completed, Select File >Save as 

…/PowerShape-Models/Ex 11 Solid Doctor spkrCore.psmodel 
 
 
 
 
 

 A more difficult challenge is available by opening:  
..../PowerShape_Data\Speaker Core_surfs_advanced.psmodel 
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Introduction 
Split and draft surfaces play an important role in designing components and tooling for material-forming applications. In most mold or die applications the establishment of the natural split line is crucial, and so is the need to design a split surface for machining. In most cases too, a draft angle has to be incorporated into the surface of a mold or die to enable the product to be withdrawn. 

Split Surfaces 
Also known as a ‘run-off’ surface, split Surfaces are an essential feature required in applications such as mold tools. The component wall thickness is formed by the gap between the separate Punch and Die Impression Blocks. The edges of the plastic component are formed by a Split Surface common to both halves, accurately bedding out when the Punch and Die Impressions are pushed together. 

 
A surface's natural split line or occluding boundary is the line around a surface where the surface, when looked at along the draw axis (that is, the direction in which the mold or die is to open), just dips out of sight. 
 

10. Surfaces for 
Manufacture  
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Split Surfaces are generated from split lines previously created around a component model. 
In areas where the surface model is vertical or does not reach the vertical angle, you must manually construct a suitable curve. This is not always evident until after the Create a Draft Curve with the Draft Angle value as 0 is applied. These areas are then identifiable as gaps along the Draft Curve.  
In the following example, the Split Line is obtained using Create a Draft 
Curve to obtain a curve for the natural split. This is then used with the Split 
Surface options.  

Split Surface Example 1 
In this example, a primitive cylinder is modified to produce a simple part. A split line for the part is calculated for the surfaces and a new split surface is made. 
1 Create a New Model and Workplane at 0. 
2 Set the X as the active Principal Plane. 
3 Create a Surface cylinder Primitive at 0 with a radius of 30 mm, and 

length 100 mm. 

 
4 Scale  the surface by 0.3 in the Z-axis (Lock the X & Y values).  

 
5 Right-click on the surface, and, from the popup menu, select 

Convert Surface to create a Power Surface. 
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The surface will undergo further modifications to illustrate split surface creation. 
To give a curved flow along the surface, a spine will be added. A spine is a curve that can be used to control the alignment of sections on a surface. A spine has a spine point for each section along the surface. If a spine point is moved, the corresponding section moves with it, retaining the same tangency if Apply smoothing to point edits is disabled. 

6 Select the surface to display the Surface edit toolbar. 
7 Select one of the surface curves to enable the Curve & Point Edit 

toolbar. 

8 Select  to enable labelling of points on a selected curve. 

 
9 Ensure the long arrow displayed on the selected surface is pointing along the surface. This sets the operational direction. This can be left-clicked to switch from across to along the selected surface. 

10 From the Surface edit toolbar, select Create Spine  (Add curve 
options). 
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This creates a spine running through the cross sections of the surface, shown as a dotted line. This spine can be deleted without affecting the surface. 

 
11 Select Spine Point 2 on the spine by left-clicking on it (shown above) 
12 In the Surface/Curves editing toolbar, ensure Apply smoothing to point 

edits is disabled.  
13 With Spine Point 2 selected, type 0 0 10 in the Command Input window; both the Spine Point and corresponding Section move up Z by 10 mm. 

The tangent angle along the surface remains the same, as shown below. 

 
14 Set the Y Principal plane and rotate the surface by -10 degrees. 

 
15 Generate a composite curve for each end lateral. 
16 Right-click over each composite curve in turn and select Delete 

Dependencies. 
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 When composite curves are traced from surfaces, the curve remembers the tangency of the underlying surfaces. When a further surface is generated from these composite curves, they match perfectly. To remove this relationship, Delete dependencies is used on the composite curve before a new surface is generated. 
17 Create a Fill-in surface for each composite curve. 
18 Delete the composite curves and reverse any surfaces to have the gold/blue outside. 
19 Create a Convex surface fillet on each end of Radius 2 mm. 

 
The model now is complete but before a split surface can be generated the appropriate Draft Curve must first be created. 
For a Draft Curve suitable for split surface creation, the Z principal 
plane must be set. 

 
For a draft angle of 0 degrees (as marked by a cross), it appears exactly half way down the sphere (equator).  
For a positive angle of 25 degrees, the draft curve appears on the upper half of the sphere as indicated.  
For a negative angle of –10 degrees, the draft curve appears on the 
lower half of the sphere. 

20 Select the Z principal plane. 
21 Select all surfaces.  

22 Select Draft Curve  from the Curve menu.  
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The draft angle is specified in this dialog. If the composite curve option is selected, PowerShape generates composite curves of the natural draft; otherwise, ordinary curves are generated. 

23 Leave the Draft Angle at 0 and Create Composite curves selected, then select OK. 
24 Select the composite curve just generated and Blank Except (Ctrl+K). 

 
The split surface can now be created from this composite curve. 

25 Select the composite curve then Split Surface  from the Surface 
menu.  

 
The Split Surface dialog is displayed and two arrows appear on the split 
line.  
The blue arrow shows the direction the split surface will flow from the curve. The brown arrow indicates the direction any optional Draft Angle will be applied.  

26 Click on the arrows if necessary to change the Split Surface directions to be as shown in the illustration above. 
27 Enter an Offset distance of 40 and select Preview. 
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A 40 mm wide split surface is previewed, tangentially outwards form the 
curve. 
It is likely that the new split surface contains localised ripples, especially 
where there is a group of surface curves that are close together. This is not an acceptable condition to achieve a satisfactory bed-out between the two halves of a mold. To achieve a smooth surface form, the ripples 
must be prevented or edited out. 

28 Select the Smooth Surface option, select Preview and then select OK. 

 
This produces a smoother surface on the outside edge by allowing the surface curves to rotate away from the original perpendicular direction from the draft curve. This helps improve the smoothness, but the split surface may still benefit further from further editing, this can be carried out retrospectively by moving or inputting points, removing or inputting curves, and editing tangent angles. 

29 Cancel the form. 
30 Select Unblank and delete the surfaces and workplane. 
31 Close the Model 

Split Surface Example 2 
1 Open a New Model and Import .....PowerShape_data/Split_surf_example.dgk 

The file contains a solid model and a predefined Composite Curve, which will be used to generate the split surface. 



.  10. Surfaces for Manufacture 

10 - 8   Autodesk PowerShape 2017  Copyright © Autodesk  

 
2 Select the Solid and then Blank (Ctrl+J). 
3 Select the pre-defined composite curve running around the handle.  

4 Select Split Surface  from the Surface menu.  
5 On the Split Surface dialog, enter an Offset distance of 50 and set the horizontal arrow to point outwards from the surface (if not already the case). 
6 Select smooth surface and the Split direction to Radially Out and then 

Preview. 

 
The surface curves are converging in 4 places due to the shape of the draft curve and the in-out length of the split surface. One way of improving this is to use the Align to Axes option. This aligns appropriate 
sections of the split surface along the X or Y directions. 

7 In the Split direction list, select Align to axes and select Preview. 
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The split surface is now aligned to the X & Y axes giving an overall smoother split surface. Further improvements can be made to the surface by using a combination of Radially out and Aligned to axes. 

8 Select Advanced on the dialog to display the Split Segments dialog. 

 
9 Select Clear to remove any existing segments from the curve. 
10 Using the mouse, click the breakpoints at the positions indicated. 

 
11 Deselect the Insert Breakpoints check box. 
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12 Use the drop down list to toggle through each segment and then select a suitable split direction. 

 
For example in this instance...segment 2 would require a Radial split direction. 
 

 
Segment 5 would require a split direction along the Axis (X automatically selected) 
13 Repeat for all segments assigning a suitable split direction. 
14 Select OK to accept and close the dialog. 
15 Select Preview from the Split Surface dialog. The Preview indicates a combination of radial and align to axis directions. 

 Do not cancel the dialog! 
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Automatic Stepped Split Surfaces 
Stepped Split Surfaces can be applied to reduce the extent of the shut out required to ensure correct matching of the two halves of a mold. Split Surfaces can be defined with: 
 Land Distance, which is the length from the outer edge of the part to 

the step. 
 Angle of inclination for the step. 
 Total Distance across the split surface. 
In addition, you can specify different radii from the joins between the various segments, or use chamfers.  
1 Select the Stepped Split Surface option.  

The form allows values to be defined for the stepped split. 

 
2 Enter the values in the dialog, as shown above, and select OK. 
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The Split Surface is produced with the defined step. An impression block will be created to be trimmed back to the split surface. 
 

3 Create a Rectangle from -60 -60 -60 of Width 120 and Length 120. 
4 Select Tools > Options >Object > Lines. 

 
Chamfers are created from the Default Creation Mode setting in the 
Options dialog. If required, a chamfer can be retrospectively edited both dimensionally or by any of the available creation modes. 

5 Set the Default length/distance to 10 and then OK. 

6 Select Create a chamfer  from the Lines menu.  
7 Click each corner in turn to apply a chamfer. 
8 Generate a composite curve. 

 
The curve will be used to generate the side walls of the block. 

9 Select the lower composite curve and create a Fill-in surface. 
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10 Select the composite curve and create a surface of extrusion with a length of 80. 

 
The sidewalls will be trimmed back to the split surface as shown above. 

11 Limit  the side walls back to the split surface as shown below. 

 
12 Select Unblank (Ctrl+L) to redisplay handle solid. 

 
The basic Impression block design is complete.  
13 Save the model as 

.....\PowerShape Data\Impression block.psmodel 
14 Close the model. 
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Mold Die Wizard 
An option has been included in PowerShape, called Mold Die Wizard. Using the active solid, the Mold Die Wizard will automatically split and trim the model creating cavity and core inserts.  
15 Open a New Model. 
16 Import the file Phone_Cover.dgk in the modelling window. 

 
The Phone_Cover.dgk contains the surface data of a mobile phone cover. For PowerShape to process the data through the Die Wizard, the model needs to be in the form of a solid. After conversion from a Surface model to a solid it is strongly advised to check for any potential faults. 
17 Box-select ALL surfaces. 

18 From the solids menu , select create solid from selected 

surfaces.  
 In doing this, PowerShape will attempt to convert all the selected surfaces in to solids. 

19 Click onto the newly converted solid to unlock the Solid Edit Toolbar. 

 
20 Select the option to “Find and Fix faults in the solid” highlighted above. 
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21 A form will appear informing you that the selected solid (phone) contains no faults. 

 If there are any faults in the solid you may have to follow the solid doctor wizard in order to fix the solid. Please refer to the Solid Doctor help file. 
22 Select the solid. 

23 From the Main Toolbar select Wizards  and then select Start Mold 

Die wizard.  

 
The first page of the Mold Die Wizard allows the user to select the objects to be used for die creation. These can be in the form of previously generated Split lines, Split Surfaces and Die blocks. In this example, Split lines, Split Surfaces and Die Blocks will be automatically created by the wizard and the object information area highlights the selection of the product only.  
24 Select Next. 
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The second page allows the user to create and edit split lines. The wizard has automatically generated the split lines to be used for this model.  
Each split line is numbered and can be selected, and modified if necessary from the Pull Down list. As a split curve is selected, it is displayed in the Die Wizard graphic window.  
The model can be dynamically manipulated in the Die Wizard graphic window in the same way it can be manipulated in the PowerShape graphic window. 
25 Again, select Next. 

 
This page gives the user the opportunity to change or create fill-in surfaces. In this case the surfaces created by the wizard do not need to be modified. 
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26 Click the Preview button to display the fill-in surfaces on the model. 

 
27 Select Next to continue through the wizard. 

 
This page allows the user to specify product shrinkage; the amount by which the mould cavity increases to allow for shrinkage.   
The drop down list displays the abbreviated names of the materials; when a material is selected, the full name of the material is displayed below. A predefined value (dependent on the material selected) will be automatically inserted into X, Y and Z. Uniform Shrinkage can be switched off to enable the user to set different shrinkage factors for X, Y and Z. 
28 From the Material drop-down menu select ABS. 
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This page of the wizard allows the user to specify block size for the die inserts. Size can be set using overall dimensions for the block or by setting a minimum land dimension. 
29 Set a block length of 200mm and a width of 100mm. 
30 Select Next. 

 
The next page allows the user to edit the created split surface. In this example the split surface is required to use a combination run off of radially and along axis. 
31 Select the Advanced Split Surface Options button highlighted above with a red border. 

 The split segments form will appear. 
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32 Select Clear to remove any existing segments from the curve and set the Corner Type to run in both directions. 
33 Using the mouse create breakpoint at the positions indicated below. 

 
34 Reset the corner type to run in a single direction. 
35 Create a single breakpoint at the position indicated below. 

 
36 Untick the Insert Breakpoints box to toggle the curve segments option. 
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37 Select segment 1 from the drop-down menu and set the split direction to be Along Axis. Note that the relevant axis will automatically be set upon selecting this option, but can be overridden if necessary. 
38 Repeat this procedure for the segments 2, 4 and 5. 
39 For, in this case Segment 3, which refers to the breakpoint created last around the hole in the top of the phone, set the split direction to be Radial. 

 
40 Select OK on the split segment form, and the press Next in the wizard. 

 
 
This page of the wizard allows the user to define block heights for the die inserts.  
Values can be determined using absolute or relative dimensions, specifying an overall height or by fixing maximum and minimum values of the upper and lower parts. 
41 Set a Minimum Upper value of 30. 
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42 Set a Minimum Lower value of 25. 
43 Select Next to continue. 

 
This page of the wizard allows the user to define corner types. There are three types of corner definition, Radial, Chamfer and none. These can be applied either individually or globally to the insert corners. 
44 Set a 10mm Chamfer and tick Apply to all corners. 
45 Select Next. 
The final page of the wizard allows the user to simulate core and cavity separation using the slider. 

 
46 Move the Slider to simulate separation. 
47 Select Finish to exit and complete wizard. 
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Draft Surfaces 
A Draft Surface can be created from a Composite Curve or from one or 
more Surfaces. A Draft Surface is projected relative to the active Principle Axis, either onto the 0 plane, or onto one or more additional Power Surfaces, selected after the original data has been taken into the open 
Draft Surface creation dialog. 

 
The Draft Surface is generated tangentially from the original surface dependent upon the angle selected, similar to the Draft Curve command. 
Where the split line is generated with an angle above or below 0 degrees, the resultant split surface edges on both the top and bottom may be mismatched. PowerShape increases the lower draft angle so the split surfaces edges match as shown. 

 

Draft Surfaces from Composite Curves Example 
1 Create a New Model and Workplane at 0. 

2 Create a Three point arc  using the following coordinates: 
-15  10   4 
-15 -10 10 
-15   0    8    

3 Create an extruded surface along the X-axis of Length 50 mm. 
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This extruded surface will be used later to project a draft surface onto. 

4 Convert the surface to a Power Surface. 

5 Blank the surface and select a view from the top.  
6 Generate the following wireframe. 

 
This section will be used to generate a Draft Surface. 

7 Create a composite curve and move it up in Z axis by 20 mm. 
8 Select Unblank (Ctrl+L) to display the extruded surface. 
9 Ensure the composite curve is selected. 

10 Select Draft Surface  from the Surface toolbar.        
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Draft Angle allows you to specify the taper angle of the surface to be produced. As with split surfaces, the direction in which the surface is created is determined by the two arrows displayed on the composite curve or surface selection. 
 

11 Set the Draft Angle to 2 degrees. 
12 If required, change the arrows by clicking on them so they point down and outwards. 
13 Select Preview. The draft surface is generated and projected onto the 

XY plane of the active workplane. 

 
14 Select the original extruded surface. 

When selected, the surface appears pink and the Split Surface option on the Draft Surface form changes to Project onto selected surface. 

 
15 Change the Draft Angle to 20 degrees and the projection arrows to 

inwards and downwards. 
16 Select Preview. The draft surface is automatically trimmed to the lower 

curved surface. 

 
17 Dismiss the dialog. 
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Draft Surfaces from Existing Surfaces 
Draft surfaces can be created tangential to existing surfaces.  
1 Create a Primitive Sphere of radius 4 at X18 Y0 Z20. 
2 Right-click over the Sphere and select Convert Surface. 
3 Select the Sphere. 

4 Open the Surface Draft  dialog and enter an angle of 10 degrees with 
the direction arrow pointing downwards. 

5 Select Preview.  

 
The draft surface that would be produced is displayed. 

6 Select the extruded surface and then select Preview. A new draft 
surface that project onto the curved surface is generated. 

 
7 Select Apply and dismiss the dialog. 

Variable Draft 
There is the ability to generate a variable draft surface from a selected profile. The variable draft surface may not be always tangential to the original surface, as it has to generate the draft from a fixed defined profile. 
1 Select the composite curve. 

2 Select Draft Surface  from the Surface toolbar. 
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3 Select the extruded surface and make sure that the arrows are pointing 
down and out. 

 
4 Enter a Draft Angle of 3 and select Variable.  
5 Select Apply.  

 
The Variable Draft dialog is displayed. This is an interactive command 
where lines to display the draft surface are generated by clicking on the draft curve. The draft angle is changed at these lines. 

6 Select a View from Top (down Z). 
We will create a variable draft of 5 degrees along the sides and 6 degrees around the ends. 
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7 Click 6 points around the draft curve as shown above using the intelligent cursor to snap onto End and Key 
Points.

 
The draft angle for each line can be changed by selecting the line from the drop down list and then changing of the draft angle in the dialog. Selected lines are highlighted in Red. 

8 Set both left and right end projection lines to 6 degrees. 
 

9 Set the remaining 4 lines to 5˚. 
10 Select Interpolation as Smooth, select Preview and select OK. 
11 Dismiss the dialog.  

 
The Draft Surface is shown. 

12 Close the model without saving. 

Surface Extension 
A surface extension can only be created from a composite curve that has been driven along, and is still in contact with, the edge of one or more surfaces. This causes the composite curve to inherit the tangencies of the surfaces, which will then control the directional flow of the surface extension. A typical application for the surface extension is in the creation of electrodes or slides, which must extend tangentially, outwards from the main, tool model. 
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Electrode Example 
The imported model of a punch insert will be used to illustrate the application of surface extension as the main option to create an electrode model. 
1 Select File > Import and select the model: 

.....\PowerShape_data\InteriorTrimPUNCH.dgk 

 
2 To re-orientate the model in the correct tooling alignment, activate the workplane named datum. 
3 Zoom into the rib area and Blank all surfaces outside the rib detail. 
4 Drive a composite curve around the top edge of the rib detail. 

 
The composite curve inherits the tangencies from the host surfaces. For this reason it is essential that the actual rib recess surfaces are used and not the main body surfaces when creating the composite curve. 

5 Select Create a surface extension.   
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6 In the Surface Extension form, select Along Principle Axis and enter 

Distance 35.  
7 Select Preview to display the proposed surface extension. 
8 Select the circular fill-in surface at the bottom of the rib form and create a workplane at centre of selection. 
9 Name the new active workplane as Electrode. 
10 Create a Temporary Workplane  at 0 0 35 (relative to the currently active workplane named Electrode). 

 
11 Limit  the extension surface using the temporary workplane to leave the result below. 

 
The electrode will be completed. 
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12 Create a Primitive Cylinder surface of Radius 40 and Length 25 from the temporary workplane (top of the extension surface) and central to the 
circular fill-in surface at the bottom of the rib. 

 
13 Create Fill-in surfaces for both top and bottom of the cylinder. 
14 Unblank (Ctrl+L) to redisplay the punch insert. 

 
15 File >Save as 

…/PowerShape-Models/Trim punch.psmodel 
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Model Preparation for Machining 
1 Create a New Model and Import:- 
...../PowerShape_Data/MC-Preparation1.dgk 
 

 
2 Save the model as:- 
 
...../COURSEWORK/PowerShape-Models/MC-Preparation-EX1 
 

In this example the imported model will undergo modifications to make it easier to apply machining strategies in PowerMILL:- 
 
a The Slot and Holes in the upper form will be capped with new, individual surfaces to make it easy to prevent cutting tools from 

plunging into these pockets. 
b The separate, front face surfaces will be replaced with 3 more suitable surfaces designed to provide the PowerMILL 5-axis Swarf 

Finishing strategy with a smoother tool flow. 
 

 
Swarf M/C using Original Surfaces     Swarf M/C using modified Surfaces 
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Creating Capping Surfaces 
3 Select the upper form surface and apply Blank Except (Ctrl K). 

 
4 Position the cursor on the edge of the slot and then press the ALT key to create a Composite Curve. 

 
 When a Composite Curve is created along a surface edge it inherits the tangencies. These tangencies will subsequently be applied when the capping surface is created. 

5 From the main toolbar activate the Surface options toolbar.  

6 With the new Composite Curve selected select Smart Surfacer.  
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The Smart Surfacer will automatically select the most likely valid option which in this case is Fill-In. 
7 With the Fill-In option selected Apply followed by OK. 

 
8 Use the same process to create separate capping surfaces for each 

of the 4 circular holes in the upper form. 

 
9 Select and Delete all 5 composite curves used to create the capping 

surfaces. 
10 Open the Levels dialog (bottom left of graphics area) and input the name CappingSurfaces on the row for level 7. 
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11 Select OK to close the Level dialog. 
12 With the new capping surfaces selected middle mouse click on the 

Level 7 in the levels toolbar located below the graphics area. 
 

13 Left mouse click on the level 7 box to re-display the newly acquired 
capping surfaces. 

 On import to PowerMILL the capping surfaces will already exist on a separate level named CappingSurfaces. 
 

Creating improved Swarfable Surfaces 
 

14 Open the Levels dialog (bottom left of graphics area) and input the name NewFrontFace on the row for level 9. 

 
15 Switch Level 9 on (green tick) and select OK to close the Level 

dialog. 
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16 Select all the surfaces except those that define the front edge of the model. 

 
17 Select Blank selected (Ctrl+J). 

 
18 Create separate Composite Curves along the upper and lower edges of the Front Edge surfaces. 

 
19 Select all of the Front Edge surfaces and acquire them to Level 9 (In the 

Level toolbar, middle mouse click on 9). 
20 Right mouse click on the left hand surface and from the local menu select Surface Trim Region Editing. 
21 In the dual toolbar select Pcurve edit mode. 
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22 Select all the lower edge Pcurves and select the Delete a pcurve option, 

as above.  

 
23 Currently there is no Pcurve running up the right hand edge of this 

face. We can create one using a wireframe, and then convert it to a 
Pcurve. 

24 Create a line  connecting the upper and lower edges of the surface. 
25 With the face selected, make Pcurve from projecting wireframe from the 

Pcurve toolbar.  
26 Choose project along a priciple axis and select the wireframe line, then select OK.  
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27 Select the new Pcurve running up right hand edge and Turn point labels 

on. 
 

 
 
 
28 In the dual toolbar select Boundary edit mode. 

 
29 Select the Autocreate option and then close the toolbar.  

 
30 Blank all items except the two Front Edge composite curves and the 2nd and 3rd surfaces from the left. 



10. Surfaces for Manufacture  

 Copyright © Autodesk  Autodesk PowerShape 2017   10 - 39 

 

31 From the general edits toolbar use Cut object  to split the 2 
composite curves at the 4 positions shown in the above illustration. 

 
32 Create composite curves down each of the existing surface curves (on the original surfaces) running from the upper edge to the lower edge. 
33 Delete the 2 existing surfaces and then select all the remaining 

composite curves. 

34 Select the Smart surfacer  and Preview the From network option. 

 
 

 
35 Select the Advanced tab and in the new dialog use Edge matching as 

Repoint and Interior interpolation as Linear. 
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36 Select Apply and OK to create the new surface. 

37 From the general edits toolbar use Point limit  to drag (extend) the lower edge of the new surface downwards (below the downward step in the original form). 

 
 
38 Select Unblank (Ctrl L).  
39 Create a line down the right hand side of the middle surface. 
40 Create and extend a line along the lower edge of the step in the right hand surface. 
41 Trim the horizontal line back to the line running up the right of the angled, middle front face, surface. 
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42 Select Unblank (Ctrl L) and then Blank all items that will get in the way 

of the next action. 

 
43 Drive a composite curve along the lower edge line along the step in the right hand surface, jump the gap tangentially onto the curve running along the lower edge of the recently modified, left hand surface. 

 No need to drive the new curve along the lower edge of the left hand surface. 

 
 

 

44 Set Y as the operational axis.  
45 Select both the new composite curve and the new central surface. 
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46 In the Curves  toolbar select Curve Projection . 

 
47 Select Through item and Project a copy of the new composite curve along 

Y onto the new central surface. 
 

 
 
48 With the new curve selected (Cutting Object) open the general editing - 

Limit Selection toolbar. 

 
 

 
 
49 Using the left mouse key, click on the surface somewhere below the 

curve. 
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50 If you haven’t already, select and Delete the 2 original, front face 

surfaces (shown below).  

 

 
51 At the bottom of the downward step on the right hand, front face surface extend the line to the right (as shown above). 
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52 Create a new composite curve (as shown above). 
 

53 Cut  the new composite curve (as shown below). 

 

54 In the Curves  toolbar select Create a fillet  , click on each 
curve in turn near to the intersection, and input Radius 8 before selecting 
OK. 
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55 Create a single composite curve along the above 3. 
56 Unblank (Ctrl L) all items. 
57 Select the original 2 right hand surfaces, the composite curve running along the outer edge (green), and the new composite curve (red). 

 
58 Input strategically positioned lines (shown blue) to enable the alignment of a cutting tool to the surface curves, during a PowerMILL 

Swarf Finishing strategy. 
59 Select the above 2 composite curves and lines and use the Smart 

Surfacer to create a From network surface. 

 
60 Select and Delete the original 2 surfaces (shown below) that will be replaced by the above new one. 



.  10. Surfaces for Manufacture 

10 - 46   Autodesk PowerShape 2017  Copyright © Autodesk  

 
61 Unblank (Ctrl L) all items. 
62 Select and Blank (Ctrl J) all wireframes.  

 
 The above selection of 3 new surfaces will provide a far better solution if they are to be used in a PowerMILL Swarf Finishing strategy.  

63 Select these 3 surfaces and add them to the NewFrontFace level using the middle mouse button over Level 9. 
 

64 Switch all Levels back on to restore the rest of the original surface 
model back to the graphics area. 

65 Select and Blank all wireframes to display the following in the graphics area. 
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66 Save the model to update:- 

.... /PowerShape-Models/MC-Preparation-EX1 
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Surface Model Fixing 
Model Fixing Toolbar 

The Model Analysis toolbar is opened by clicking the second button along the row in the toolbar opened by moving the cursor over the General Edits 
option. 

 
The left toolbar contains the Model Fixing options. It is shown below repositioned to a horizontal alignment. 

 

Piston Crown Example 
1 Create a New Model and import: 

…/PowerShape_Data/PistonCrown-Start.igs 
The imported model contains surfaces representing a quarter segment of a piston crown. The model is incomplete: it requires a few gaps to be filled, some re-trimming of existing surfaces, and the identification and transfer of missing data from another model.  
Before applying further surface modelling, it is necessary to identify and delete any duplicate surfaces and to identify and repair any badly trimmed surfaces 

 
2 Shade the model. 
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3 Save the model as: 
…/PowerShape-Models/PistonCrown-Example 

Find Duplicates 
1 Select all surfaces. Move the cursor over the General Edits option to open the local toolbar and left-click Model Fixing to activate the toolbar options. 

From the Model Fixing toolbar, select Find 

Duplicates.   
The Find Duplicates dialog appears. This provides the option to choose 
what to compare and the ability to compare all, exact, trimmed, or untrimmed surfaces. Select the Help button for a full listing. 

 
2 Select the Examine selected items only box. 
3 In the Find duplicates method list, select All. 
4 In the Surface trimming comparison list, select Exact.  
5 Select OK. The Information dialog displays the number of duplicate 

items that have been identified and selected. In this case, 9 duplicate surfaces have been found. 

 
6 Select Blank Except (Ctrl+K). Only the selected duplicate surfaces are 

shown in the graphics area. 
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7 Select Delete to remove the selected duplicate surfaces. 
8 Unblank (Ctrl+L) to display all surfaces hidden from the view earlier. 

Identify badly trimmed Surfaces 
The next action is to check the model for any badly trimmed surfaces. These are surfaces that contain invalid boundaries. These could be due to pcurves not forming a closed loop, or geometrical faults along one or more of the pcurves. 
9 Select all surfaces. 
10 From the Model Fixing toolbar, select Identify Badly Trimmed 

Surfaces.   
The Information dialog opens advising of surfaces with an incorrectly defined trim boundary.  

 
All badly trimmed surfaces are selected: 

 
11 Select Blank Except (Ctrl+K). 
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12 From the Model Fixing toolbar, select Surface trim region editing.  
The boundaries are now visible, but require rebuilding because they have failed to trim the surface. 

 

13 From the Boundary Edits toolbar, select Select all boundaries , and 
then select Explode to delete all boundaries.  

14 Toggle into the Pcurve Edits toolbar. 
  

 
The pcurve shown as a dotted line does not follow the correct trim, and it must be deleted from the surface. 
The other pcurve follows the correct trim path, but does not reach the top edge of the surface. Because this would result in a gap in the trim path, the pcurve must be extended to the edge before a boundary is created. 

 
15 Select the pcurve shown above as a dotted line and select Delete.  
16 Select the remaining pcurve and select  to open the Extend pcurve dialog. 

 
17 In the Extend at list, select Both ends of pcurve and in the Method list, select Tangentially to nearest edge. 
18 Select OK. The pcurve is extended to reach the edge of the surface. 
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19 Toggle into the Boundary Edits toolbar. 

20 Select Auto Create boundary  and check which side of the pcurve 
is trimmed. 

   

 

21 If the trim appears as above left, select Reverse the boundary  to 
change the trim to that shown above right. 

22 Close the Boundary Edits toolbar. The surface model is now correctly 
trimmed. 
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Repairing Gaps and Overlapping surfaces 
 
By shading and dynamically rotating the view of the cavity model, you will see three that require patching. 
 

 
 

Filling in Gap1 – Surface from Network of curves 
23 Zoom into the area labelled Gap 1. 
24 Create a composite curve using the edges of the gap. 

A patch surface from a network of curves is generated from the new composite curve. 

 
25 Using the Smart Surfacer , create a fill-in surface. 
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Filling in Gap2 – Stitch surface 
1 Zoom into the area around Gap 2. 

The bowl surface is a NURBS surface, which must first be converted to a 
Power Surface before editing can be performed. This gap will be filled by using the Stitch surface option.  

2 Right-click on the bowl surface, and, from the popup menu, select 
Convert Surface to change it to a power surface. 

 
Stitching moves the selected surface points to match the edge of other surfaces or composite curves. It is not possible to apply Stitch surface from a trimmed edge. The process benefits if further laterals are inserted to provide a more accurate edge-match for the Stitch surface operation.  
An easy way of inserting an additional lateral is to select a surface point, followed by holding down the Ctrl key and then left-clicking. A new lateral can then be dragged along an existing longitudinal. This is repeated until there are sufficient surface points along the edge to be stitched. 

3 Select the surface. The Surface Edits toolbar is displayed. 
4 Select a lateral/longitudinal point and drag a new longitudinal near to the end one using the Ctrl key and left mouse button, as shown below. 

 
5 Repeat the process of dynamically adding laterals to provide an even point distribution along the surface edge to be stitched, without going beyond the end of the adjacent surface edge. 



10. Surfaces for Manufacture  

 Copyright © Autodesk  Autodesk PowerShape 2017   10 - 55 

 
 
A more accurate method of adding a lateral will be used to match the end of the adjacent surface edge. 

6 Select Add Curve.  

 
The Through nearest point tab allows you to pick a point on the model. When picked, the XYZ co-ordinates are loaded into the dialog. 

7 Select the Through nearest point tab. In the Insert list, select Lateral.  
8 Click on the surface point indicated earlier at the end of the surface to be stitched to. 
9 In the dialog, select Apply and then select OK. The new lateral is 

generated. 
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The Stitch command uses the selected surface curve and matches it along the surface edge of a selected secondary surface. It is also necessary to specify a value for the maximum gap to stitch across.  
10 Select the edge (end longitudinal) of the lower surface and select Stitch. 

 
The Stitch dialog appears. It is essential to estimate and specify a value for the Maximum gap to stitch. This is used to eliminate any ambiguity about which surface edge to stitch onto. 

 
11 Enter 2 as the Maximum gap to stitch. 
12 Pick the edge surface on the edge curve to stitch onto, Surfaces is selected. 

 
13 Select Preview to view in advance, and then select Apply to perform the stitching. 

The fillet surface needs to be trimmed back to the stitched surface to finish off this area. 
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14 Select the two surfaces shown and Blank Except (Ctrl+K). 
15 Create a composite curve from the edge curve of the flange surface as shown below. 

 
16 Use Define Start and End points on the Composite Curve dialog to create the curve shown. 
17 Select the lower surface and enter into Trim Region Editing. 

18 In the Pcurves toolbar , select Make pcurves from projecting 
wireframe . 

19 In the dialog, select Projected, and then click on the composite curve and select OK. 

20 With the new pcurve selected, open the Extend pcurve option . 

 
21 Select: 

Extend at -  Both ends of pcurve 
Method -  Tangentially to nearest edge 

22 Select OK.  

23 In the Boundary toolbar , select Autocreate .  

24 If required, select Reverse the boundary  to achieve the following 
trim: 
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The bowl surface is now trimmed neatly to the flange. 

Selection and Import of Surface Data for Gap 3 
1   Unblank all of the surfaces. 

Gap 3 is a large hole in the model, due to missing data that will be supplied later from an IGES file. By loading it into a new model, it can be checked before copying the data into the original piston model. 
2 Create a new model and import the file …/PowerShape_Data/cyl_1_2.igs. 
3 Rearrange the models using Window > Tile 

Vertically.

 
 
Most of the surfaces in the new model already exist in the original PistonCrown-example. 

Model Compare  
Model Compare analyses two models and selects items on the first model that are different or that do not exist on the second model. The trimming options can be specified in the dialog. 

4 From the Model Analysis toolbar, select Model Compare.   
The Model Compare dialog is displayed. This allows you to choose which 
model is the primary (old) model, and which model is the secondary (new) model. The different model entities are then selected in the primary model. 
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5 Select Primary and then left click in the New Model window. 
6 Select Secondary and then left click in the PistonCrown-example 

window. 
7 In the Surface Trimming Comparison drop-down list, select None. 
8 Select OK. 

Some wireframe and two surfaces are highlighted in the Primary - New 
Model window. 

 
9 Blank Except (Ctrl+K) the selected items. 
10 Select and delete the wireframe. 

11 Select the extruded surfaces, and then select Copy Selection.  

12 Select the model PistonCrown and select Paste from clipboard.  
A copy of the new, different surfaces appears in the original model. 

13 Close the new model leaving the PistonCrown-example model open. 

Filleting 
The deep pocket will be filleted to the main surfaces with a radius of 3 and the bottom-edge of the pocket will be filleted with a radius of 2. 
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 The creation of the fillet of radius 3 does not trim the tapered pocket or some of the adjacent surfaces correctly due to poor surface-edge matching across the original model. Surface editing of the fillet surface along with pcurve and boundary editing on the tapered pocket and some of the adjacent surfaces must be applied to fix the problems 

14 Select the newly copied surfaces and those that intersect them. 
15 Select Blank Except. 
16 Generate a concave fillet (radius 3) between the original surfaces and the top of the new tapered pocket surface. 
17 Select the taper surface and the surface defining the flat base of the pocket. 
18 Create a convex fillet (radius 2) between these surfaces. 
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Now that the quarter of the Piston Crown is complete, a workplane will be created to provide a datum to mirror a copy of the surfaces to end up with half of the full Piston Crown. 
 

19 Select Unblank and create a workplane at 0. 

 
20 Select all the surfaces. 

21 From the General Edits toolbar, select Mirror.  

 
22 From the Mirror toolbar, select Mirror in YZ and accept .  
23 Close the dialog. 

 
24 Select File > Save to update the model. 
25 Close the model. 

 



.  10. Surfaces for Manufacture 

10 - 62   Autodesk PowerShape 2017  Copyright © Autodesk  

Further Model fixing 
Imported IGES file of a PC Front Cover surface 
model  

When you import a model saved in IGES format, it contains NURBS surfaces, which have a restricted editing capability. As will be shown later, when a NURBS surface is converted an excessive number of laterals and longitudinals can be generated on the resultant power surface. It will also be observed that several of the surfaces are in an orientation with the inner (red) side on the external faces of the model. Apart from the visual presentation, this causes problems if the model requires additional surfacing work, such as filleting.  
1 Import the model: 

…/PowerShape_Data/PC_FrontCoverSurfaces.igs 
A dialog appears displaying the progress as an Import IGES report. 
 

2 Save the model as: 
…/PowerShape_Data/PC-FrontCover-example.psmodel 

 
3 Select all surfaces in the model. 
4 From the Editing flyout, select the Model Fixing 

 
5 From the Model Fixing toolbar, select Find Duplicates.  

The Find Duplicates dialog is displayed. Various options allow you to control the criteria of the comparison, and whether to consider exact, trimmed or untrimmed surfaces. Select Help for a full listing. 



10. Surfaces for Manufacture  

 Copyright © Autodesk  Autodesk PowerShape 2017   10 - 63 

 
6 Select Examine selected items only. 
7 Select All and Exact and then select OK. 

In this case, no duplicate data is found, but it is still essential to perform the test 
8 From the Select flyout, select the Quick Select all Surfaces. 

 
From the Model Fixing toolbar, select Orient surface normals  to arrange for the outer faces of the surfaces in the selection to be on the outside of the component. 

 
 In some instances, it may not be obvious which way a surface should be orientated (such as when the model is missing data causing a surface to be isolated, or when the outer face of a surface exists on both the inside and outside of the model). If any surfaces remain in the wrong orientation, they can be selected and reversed using the local menu. 

9 Display the surface model as wireframe . 
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10 With all the surfaces still selected, right click over them and select 

Convert Surface from the popup menu to change the NURBS surfaces to 
Power Surfaces. 

 
The following diagram shows a surface before and after conversion to a power surface. 

     

 Depending on the type of file originally translated into IGES format, power surfaces can be created with an excessive number of surface curves (as shown above right). This can result in increased processing times and excessive memory consumption. It is good practice to apply the Approximate Surface option to reduce the amount of curves while keeping the surface definition within a specified tolerance value. 
11 With all power surfaces selected, select the Approximate Surfaces option 

 from the Model Fixing toolbar. 
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All surface curves are deleted that are not required to keep the model within the general tolerance value (default 0.01). The tolerance value can be modified on the Instrument toolbar located below the graphics area. 

 
The model is now ready for further operations such as constructing the components required for a suitable mold tool design. 

 

Core/Cavity separation 
This Core/Cavity separation option is located in the Wizards options  of the Main toolbar. It operates on the selected surfaces and discriminates 
surfaces that are out of view if looking down the Z axis. 

 
Depending on which option is selected, it selects the outer or inner surfaces so they can be transferred to another level. 

1 Open the Levels dialog. 
 

2 Enter the name CAVITY for level 6 and CORE for level 8. Leave these two levels switched off. 
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 If a name is assigned to a level, it appears in the Levels toolbar at the bottom left of the graphics area. 

3 Select all of the surfaces in the model. 
4 Open the Wizards options, and click on Core/Cavity separation split 

visible.  

 
The surfaces that are hidden from view when looking down the Z axis become deselected while the others remain selected. 

5 While the upper surfaces are still selected, middle mouse click on level 6 on the Levels toolbar. Level 6 is switched off and the surfaces disappear from view. 
6 Select all the remaining surfaces and middle mouse click on level 8.  Level 8 is switched off and the surfaces disappear from view. 
7 Toggle levels 6 and 8 on and off while checking that the surfaces have 

been assigned to the correct side of the molding. 

 
 
                     LEVEL 6 - CAVITY         LEVEL 8 – CORE 
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Basic Shading Options 
Basic shading is displayed by clicking the various icons in the Views toolbar to 
the right hand side of the graphics area. As surfaces must be identified with inside and outside, the outside is displayed in a user-defined colour, and the inside as red. It is possible to switch the inside colour off so that both sides are shaded with outside colour. 

 This also works very similarly when working with open solids. 
1 Import the model. 

.....\Training Data\PowerSHAPE Data\golf_fin.dgk 
2 Select and delete all wireframe entities. 
3 Activate workplane 2. 

4 Select Wireframe view.  

 
The model is displayed with the surface skin invisible, enabling visual access to the trimmed edges and surface curves. 

 
 

11. Shading & Model 
Analysis  
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5 Select Shaded view.   

 
The model is displayed with the surface skin shaded. The outside of a surface is the default or user-defined colour; the inside is shaded red. The use of shading restricts visual access to internal detail. 

6 Select Toggle Transparent wire.  

 
This view shows the model partially shaded (transparent), which provides a compromise with visual access to the inner and wireframe detail. 

 

7 Select Shaded wire view .  
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This view is a shaded view with the surfaces wireframe curves displayed. 

8 Select Hidden wire view.  

 
The model is displayed in wireframe mode with all the internal wireframe  removed or hidden. This option helps you see the model clearly. This special view mode must be turned off for surface manipulation. 
9 From the View menu on the main menu bar, select Shading>Inside Material (if not already ticked) 

 
This view enables/disables the mode which displays inside-out surfaces as red. This allows the user to shade the model without having to reverse inside-out surfaces. Ensure the option is ticked to view negative facing surfaces. 

10 With the model shaded, select Enhanced Shading.   
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This shows the model in Enhanced shading mode. This type of view includes 
perspective and reflections on the surface, giving a more realistic appearance with model feature lines visually converging towards vanishing points. 

11 From the Enhanced shading toolbar, select Render the View . This 
displays a photo-realistic image of the model in a separate, newly-opened graphics window, using default light settings and render options. 

 
To customise the way that the rendered image is generated, a dedicated 
options dialog is opened by clicking on the Raise the render form option.  

 
12 Closes the image and Keyshot (rendering system used) window appears.  

13 Select Shaded view.   
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Format > Shading Materials 
Shadings materials are accessed from the Format > Materials... menu option. 

 
By default, all surfaces are shaded using the same material. However, individual surfaces can be modified to use a shading colour and material type from the standard range or as customised by the user. There is a comprehensive range of pre-set Material type options available, such as 
metallic, glass, and neon. 
 
To change the material of selected surfaces: 
14 Ensure that shaded images are displayed  
15 Select a surface or group of surfaces. 
16 Open the Materials dialog and select a new material. 

 
To change the default material: 
17 Ensure that no surface is selected. 
18 Open the Materials dialog and select a new material. 
19 Select OK. The new material is used for subsequent surface colour shading. 
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Customising Materials 
You can create a custom material colour and texture to your requirements. 
1 Select Format > Materials… to display the Material Editor dialog.  

2 Select Spring from material type then Spring 13.  
3 Select   

 
The Material Editor dialog is displayed. This allows you to change the shading effect using various sliders. 
4 Select New. Leave the name as Spring13Copy. 
5 Change the material using the sliders, and observe the effect on the preview bead at the top of the dialog.  
6 When you have created a suitable material, select Apply. 
7 Select any surface and the material is changed to the new one. 
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Shading Tolerance 
When models are shaded the surface is covered in a triangular mesh, which is set at a certain tolerance; the smaller the tolerance value, the finer the mesh. These tolerance values are in the Shading options, found in the Tools menu. 
8 Select Tools > Options>View>Shading. 

 
Tolerance to current view is a quick way of entering the ideal value for your 
screen resolution and current zoom. PowerSHAPE uses the new tolerance when the shading is next regenerated. If you want to see it immediately, select Force regeneration of triangles.  
9 To exaggerate the effect, set the Tolerance for Shading to the value 5mm.  
10 Select Force Regeneration of triangles and select OK. 

 
The shaded surface model appears very faceted. If you want to check a surface model for tangencies or ripples along the surface, it is essential to apply a suitable shading tolerance. This depends on the physical size of the model, but a more suitable value is 0.01mm for an accurate visual representation. 
11 Set the Shading Tolerance to 0.01 then Regenerate.  
12 OK the options page.  
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Model Analysis toolbar 
The Model Analysis toolbar is opened by clicking the option located along 
the row third from the top of the left toolbar. 

 
The new toolbar contains the Model Analysis options. It is shown below in a 
horizontal alignment. 

 

Advanced Shading Options 
PowerSHAPE has several advanced shading options that can be used to check and analyse models in preparation for programming. 

 Smoothness Shading  exaggerates the degree of smoothness over the 
model surface with dual coloured stripes. A break in continuity along the stripes indicates a sharp transition from one face to another. 

 
 A sharp-cornered transition across adjacent surfaces is indicated by break in the continuity along the stripes. 
 Select the Smoothness Shading option and take a closer look at the displayed model. 

1 Undercut Shading  is used to check for correct draft angle on a molding component or to check for undercuts: 
 Green shading indicates that area of the model surface does not exceed the draft angle alignment. 
 Yellow shading indicates that area of the model surface is exactly aligned between the draft angle and warning angle. 
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 Red shading indicates that area of the model surface is undercut. 

 
 The above view is using the World datum. 

By default, the Draft Angle is set to 0° and Warning Angle is set to 5°. If you want to use a different value, you can modify the angle in Tools > Options > Tools > 
Analysis > Surface Analysis. 
2 Select the Undercut Shading option and take a closer look at the displayed 

model. 

 Minimum Radius Shading  displays internal radii with values below the 
specified minimum radius in red, and external radii in green. The remainder of the model is shown in grey. 
This illustration represents Minimum Radius Shading using a minimum radius of 2mm. 

 
By default, the Minimum Radius Shading value is 5mm. If you want to use a different value, it can be modified in Tools > Options > Tools > Analysis > 
Surface Analysis. 

 
3 Select the Minimum Radius Shading option and take a closer look at the displayed model.  
4 Close the model without saving. 
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Volumes  
PowerSHAPE calculates the volume of an enclosed object such as a sphere, based upon the direction of the principle plane. 
With an open surface, PowerSHAPE generates a projected volume, from the active workplane or the world origin. 

Bottle Volume Example 
5 Create a new model and workplane at 0. 
6 Create the following 2D geometry. 

 
 Use the following information for the bottom of the bottle. 
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7 Generate a composite curve of the wireframe and make a copy. 
8 Create a new level (5) named Wire Copy and place this copy onto it. 
9 Switch OFF level 5. 
10 Create a surface of revolution around the Y axis. 

 
11 Shade the surface and, if necessary, reverse it to have the positive outside. 
12 From the bottom of the window, select the Calculator.   
13 Select the Volume option  and then select the surface. 
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The calculator works out the volume as 637.0232mm3. To change the volume to 700mm3, we can expand the surface to the required volume. 

14 OK to close the calculator. 

15 Select the surface and from the General Edits toolbar, select Scale.  
16 Select the To Projected Volume option and change the volume to 700  

 
A new surface is produced, which is scaled in all three axes. If the X and Z movement had been locked (by clicking the padlocks), the scaling would occur only along the Y axis.  
Another way to change the volume is to increase the length of the bottle from just beyond the top recess to the cap. By trial and error, you could get close to the desired volume. The following sequence attempts to reach the target by locally stretching by 20.5. 
17 Delete the surface and switch on Level 5 Wire Copy (do not select it). 

18 Select Stretch Object in the Edits toolbar. 

 
19 Box over all the elements of the composite curve including and above the 

R35 Radius (these will turn to yellow), and enter 0 20.5 in the Command 
input box to stretch this part of the wireframe (as shown dotted below). 

 
20 Generate a new surface of revolution (and it reverse if required). 
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To find the volume between two surfaces and the wall thickness, we can use the calculator. 

21 Offset  the new bottle (keeping the original) outwards by 2. 

 
22 Select the Calculator and measure the volume of the new larger, offset 

surface. 

 
23 Enter a minus sign (-) on the calculator. 
24 Measure the volume of the original smaller surface by selecting it. 
The answer, which is the volume of the wall thickness of the bottle, is displayed in the top box of the calculator. 

 
 Volumes of solids can also be calculated in the same way. The method also works for multiple selected surfaces. 

25 File >Save as 
\PowerSHAPE-Models\Bottle volume.psmodel  

26 Close to close the model.  

Identifying Modifications on a new 
issue model  

1 Open a new model, and import: 
.....PowerSHAPE_Data\InteriorTrim-4a.dgk 

2 Fill the model to screen  to view it. 
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3 Create another new model  and import 

.....PowerSHAPE_Data\InteriorTrim-4b.dgk 

4 Fill the model to screen  to view it. 
5 From the Main menu, select Window > Tile Vertically. 

 
The separate models are arranged to co-exist side by side in the graphics area. At the moment, there are no obvious differences, except that the central pockets appear to be different depths. 

Dynamic Sectioning 
Dynamic Sectioning provides a fast means of taking a slice through a surface or solid model with the option of creating a 2D composite curve as a permanent record of the section.  
6 Select the New_Model_2 window to activate it. 

 The window border itself turns a darker shade of blue. 
7 Activate the RibCentre workplane as the datum. 
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A similar workplane is positioned to a common position on each model, to enable a dynamic section to pass exactly through the same plane.  

8 From the Model Analysis toolbar , select Dynamic Sectioning.  

 
9 Select X from the Axis list. This controls the direction along which the dynamic section is created normal to. 

 
10 Drag the Back slider. The model is cut back as the slider is moved. 
11 Input 0 in the data input box at the right of the Back slider to make the 

section line up with the active workplane, RibCentre. 
12 Select the Create Wireframe button  on the back to generate a 

composite curve through the dynamic section. 
13 Close the form and Blank all the surfaces. 
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14 Repeat the above to create a similarly positioned dynamic section on New_Model_1. 

 

Comparing the two curves 
At this stage, there is evidence that the central pocket is deeper in New_Model_1. To identify smaller differences, the two curves must be superimposed on each other. It is also necessary to apply other specialist model-analysis options  
1 Select the composite curves stored in New_Model_2 and open item 

colour.  
2 Select a red colour and deselect on the page to see the change. 
3 Ensure the RibCentre workplane is still active in both models.  

 This is to make sure that the composite curve produced in New_Model_2 is copied exactly to the same world coordinates as in New_Model_1. 

4 Select the composite curves in New_Model_2, then select Copy  on the Main toolbar. 

5 Select the window in New_Model_1 to activate it then Paste.  
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The view illustrates that the surface model stored in New_Model_2 has a reduced depth central pocket and a slightly larger core form in the rib area to the right. 

 

Model Visual Difference 
This option provides a fast means of viewing differences between two models. When two models are specified in the dialog, a new window displays the first model in light grey with areas of material on coloured blue and areas of material off coloured red. 
1 In both windows delete the composite curves and unblank the surfaces. 

2 From the Model Analysis toolbar, select Model Visual Difference.  
3 In the Model Visual Difference dialog, enter NEW_MODEL_1 in the Name of 

old model box, and enter NEW_MODEL_2 in the Name of new model box. 

 
4 Select OK to apply the Model Visual Difference process. A new window 

appears containing a light grey image of NEW_MODEL_2 with extra material shaded blue and removed material shaded red. 
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The base of the pocket is shaded blue, which confirms that extra material exists in this area. 
5 In the new window, rotate the image to view the other side of the model. 

 
6 Close this new window. 

Model Compare 
This option provides a means of identifying and selecting modified, model entities on an updated model while comparing it with the original model. The selected model data can then be copied and pasted into the original model without duplicating existing unchanged model entities. 

1 From the Model Analysis toolbar, select Model Compare.  
The Model Compare dialog appears requiring you to identify the primary 
and secondary models on which to compare and select the different model entities. 

 
2 Select the Primary box, and then click in the NEW_MODEL_2 window to register it as the primary. 
3 Select the Secondary box and then click in the NEW_MODEL_1 window to 

register it as the secondary. 
 

4 Click OK to apply the model compare process. 
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All entities in NEW_MODEL_2 that do not exist or that are different from those in NEW_MODEL_1 are automatically selected (highlighted) ready to be copied and pasted. 

 Copy and Paste options are included as buttons on the Main toolbar. 

5 With the new items already selected in New_Model_2, select Copy.  

6 Click in New_Model_1 to activate it, then select Paste.  The new data 
is pasted into the original model. 

 
7 Rename Level 10 as NewData and assign the copied model entities to it. 
8 Switch off all levels except NewData. 
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 The inner Rib Data has also been modified and copied to New_Model_1 as well as the pocket. 

To assess the manufacturing work required to modify any existing mold tool, the new and old data must be placed on different levels. Switching the levels on and off makes it more obvious whether the new data is material to be removed from or added to the existing tool. 
9 Rename Level 9 as Old Data, make sure it is switched off and then assign to it the original model entities to be replaced. 
10 Transfer the new model items currently assigned to the level named 

NewData to the appropriate Outer (level 6) or Inner (level 7) levels. 
The pocket requires more material to be machined off on the die half of a mold tool. On the punch half, material needs to be added to reduce the depth of the central pocket, and removed to create the increased size for the core, central to the 4 Ribs.  
11 Close without saving New_Model_2.  

 
12 Select File > Save New_Model_1  as: 

.....PowerSHAPE_Data\InteriorTrim-3.psmodel 
 

13 Maximise the window 
 

 
 Do not close the model because it is used in the next section. 
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Surface Inspect 
When active, the Surface Inspect option displays live dimensional information as the cursor is locked onto or moved along the surface model. 

 
1 Switch off all levels except 6 - Outer.  

2 Select all displayed surfaces and then Surface Inspect  on the Model 
Analysis toolbar. 

3 Left click and drag (hold) on the model on or near the location where dimensional information is required. 
4 Run the cursor along the model to lock on to key points or other, non-specific positions to give live feedback on varying dimensions. 

 
5 Select File > Close to close the model.  
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Other Model Analysis toolbar options 
This section summarizes the remaining Model Analysis options. 

 Model Content list 

 
This displays details of the selected models contents and levels used. 

  Thickness Shading 

 
This displays the wall thickness (Solids only) as a colour map. The required Min/Max parameters can be defined. 
 
 
These options operate on solid models only 
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Radiator Valve Cover 
 
Model the Radiator Valve component. 

 

12. Modelling Exercises 
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Keyboard Button 
 
Model the surfaces to form the keyboard button shown below. The button has a winding angle along one edge, which can be difficult to visualise. It is a constantly changing angle from one edge to the other. 
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Plastic Bottle 
 
The Plastic Shampoo Bottle shown has a variable radius fillet blend at the base. 
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Grommet 
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Help menu 
 
The Help menu provides the tools related to the on-line help system. 

 
 Contents and Index 
 What's New 
 Getting Started 
 Autodesk Account 
 Autodesk Knowledge Network 
 Autodesk on the Web 
 Learning Assistant 
 Tutorials 
 About 

 

Help > Contents and Index 
Select this option to display the contents and index of the help file.  
The right hand frame displays the welcome page and provides links to further information about the program and the on-line tutorials. 

 

Help > What's New 
Use this option to view details of new features in the latest release. The What's New is displayed in one of the following ways: 

13. Help and Shortcuts  
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 If full documentation is not installed, What's New will appear in the browser window. 
 If full documentation is installed, What's New will appear in a new, floating window. 

 

Help > Getting Started 
Select this option to display the browser. Use the browser tabs to select the type of help you require. 

 

Help > Learning Assistant 
This displays and removes the Learning Assistant window. 

 
The Learning Assistant lists common PowerShape tasks. A series of dropdown menus provide interactive help as you work through the tasks. The help is context sensitive and will update automatically as you use the program. 
You can also use the Learning Assistant's drop down menus to execute a command. 
To create a single line using the Learning Assistant, 
1 In the Assistant window, click the Creating Objects drop down menu. 
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2 Click the Lines button. This will display a new list of options.  

 
3 Click How? to see details about creating a line.  

 

Help > Tutorials 
PS-Tutorials are a free add-on module. If you are using a non-English version of PowerShape, the tutorials may be displayed in English. 

  

Help > About 
Select this option to display a dialog showing the PowerShape version and copyright details. 
The dialog also provides: 
 licence and user information. 
 the language set on your PC and that used by PowerShape. 
 patent information. 
Click OK to close the dialog. 

 

 

PowerShape Shortcuts 
Shortcuts to menu options 

The keyboard can be used to access the menus. Every menu item has an underlined letter. 
1 Look at the menu bar and find the menu you wish to access. One of its characters is underlined. 

For example, F is underlined for the File menu. 
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2 Hold down the Alt key and press the appropriate character to display the menu option. 
For example, Alt - f opens the File menu. 

3 Look at the option menu and find the option you wish to access. One of its characters is underlined. 
For example, O is underlined for the Open option. 

4 Press the character underlined in your required option. 
For example, O opens the Open dialog. 

If you prefer to use the keyboard, here are some other useful controls: 
 Once the Alt key has activated the menus, you can navigate using the 

arrow keys.  
 To accept a menu, press Enter. 
 To do nothing and close a menu, press Esc. 

 

Shortcuts to frequent commands 
The following table lists shortcuts to frequently used commands. These shortcuts also appear on the menus alongside their respective options. 

Menu option Shortcut* 
File - New Ctrl + n 
File - Open Ctrl + o 
File - Close Ctrl + F4 
File - Save Ctrl + s 
File - Print Ctrl + p 
File - Exit Alt + F4 
Edit - Undo Ctrl + z 
Edit - Cut Ctrl + x 
Edit - Copy Ctrl + c 
Edit - Paste Ctrl + v 
Edit - Paste Special Ctrl + e 
Edit - Select - Clear selection Ctrl + d 
Edit - Select - Select All Ctrl + a 
View - Single (of model) - Top Ctrl + keypad 5 
View - Single (of model) - Bottom Ctrl + keypad 0 
View - Single (of model) - Left Ctrl + keypad 4 
View - Single (of model) - Right Ctrl + keypad 6 
View - Single (of model) - Front Ctrl + keypad 2 
View - Single (of model) - Back Ctrl + keypad 8 
View - Single (of model) - Iso 1 Ctrl + keypad 1 
View - Single (of model) - Iso 2 Ctrl + keypad 3 
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Menu option Shortcut* 
View - Single (of model) - Iso 3 Ctrl + keypad 9 
View - Single (of model) - Iso 4 Ctrl + keypad 7 
View - Single (about selection) - Top Alt + keypad 5 
View - Single (about selection) - Bottom Alt + keypad 0 
View - Single (about selection) - Left Alt + keypad 4 
View - Single (about selection) - Right Alt + keypad 6 
View - Single (about selection) - Front Alt + keypad 2 
View - Single (about selection) - Back Alt + keypad 8 
View - Single (about selection) - Iso 1 Alt + keypad 1 
View - Single (about selection) - Iso 2 Alt + keypad 3 
View - Single (about selection) - Iso 3 Alt + keypad 9 
View - Single (about selection) - Iso 4 Alt + keypad 7 
View - Shading - Wireframe F2 
View - Shading - Shaded F3 
View - Shading - Transparent Shaded F4 
View - Shading - Transparent Shaded Wire F10 
View - Shading - Shaded Wire F11 
View - Shading - Dynamic Hidden Line F12 
View - Look From - Last View F5 
View - Zoom Full F6 
Tools - Model Analysis - Smoothness Shading F7 
Tools - Model Analysis - Undercut Shading F8 
Tools - Model Analysis - Minimum Radius Shading F9 
View - Blank - Blank Selected Ctrl + j 
View - Blank - Blank Except Ctrl + k 
View - Blank - Blank Toggle Ctrl + y 
View - Unblank Ctrl + l 
View - Refresh Ctrl + r 
Object - Surface - Smart Surfacer Ctrl + t 
Object - Surface - Fillet Ctrl + f 
Object - Curve - Composite Curve Ctrl + h 
Macro - Run Ctrl + m 
Swap individual graphics windows in the Window menu Ctrl + F6 
Help - Contents F1 

* For the keyboard shortcuts to work, you must have Caps Lock Off and Num Lock On. 
Other shortcuts 
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Operation Shortcut* 
Bold text Ctrl + b 
Italic text Ctrl + i 
Underline text Ctrl + u 
Diameter character in text Ctrl + Alt + d 
Degrees character in text Ctrl + Alt + s 
Plus/minus character in text Ctrl + Alt + p 
Interrupt current operation Esc 
Exiting a creation mode Esc 
Halt program (after accepting confirmation dialog) Esc - 3 times within 1 second 

* For the keyboard shortcuts to work, you must have Caps Lock Off and Num Lock On. 
 

Customising menu shortcuts 
You can create your own shortcuts for menu options. 
5 From the Tools menu, select Customise. 
6 Use the Menu Shortcuts tab of the Customise dialog to set up your own 

shortcuts. 

 
Menu - Select a menu from the list of the menus that appear at the top of the screen. . 
Menu Item - The options for the selected menu. Select the option for which you 
want to create a shortcut. 
Shortcut - The current shortcut for the selected option. If a shortcut does not exist, None is displayed in the box. 
Replacement - The shortcut that you want to use for the selected menu option. 
Ctrl/Alt/Shift - Turn ON these options if you want to use any of these keys as 
part of the shortcut. 
Key - A list of keys you can use for the shortcut. If none of the Ctrl/Alt/Shift keys are selected, you can only choose one of the F function keys. If any of the Ctrl/Alt/Shift keys are selected, you can choose any alphanumeric character or an F function key. 
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Create - Assigns the replacement shortcut to the select menu option. The replacement shortcut now appears in the Shortcut box. The new shortcut will 
also appear next to the menu option. If a shortcut already exists, you are asked if you want change its use. 
Remove - Removes the current shortcut for the selected menu option. None appears in the Shortcut box. 
Reset - Resets all the shortcuts back to the original shortcuts. 
OK - Removes the dialog from the screen. 
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