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The following areas have been updated in PowerSHAPE 2010:  
PowerSHAPE 2010 for all users   

Interface (see page 1) 
Solid modelling with Parasolid (see page 8) 
Modelling with triangles (see page 36) 
Assembly modelling (see page 40) 
Delcam Draft (see page 48) 
Other changes (see page 51) 

PowerSHAPE 2010 for users of variants  
Delcam CopyCAD (see page 48) 
Delcam Designer and Designer for Jewellery (see page 49) 
Delcam Electrode (see page 50) 
 

 

User interface 
The following changes have been made to the PowerSHAPE interface: 

 Toolbars (see page 6) 
 Dialog boxes (see page 5) 
 Menus (see page 7) 

What's New in 
PowerSHAPE 2010 
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Toolbars 
Changes have been made to the following toolbars: 

 Sculpt triangles (see page 2) 
 Mesh editing (see page 4) 
 Model fixing (see page 4) 
 Solid edit (see page 4) 
 Assembly toolbar (see page 5) 

 

Sculpt triangles 
The Sculpt triangles toolbar has replaced the Interactive Triangle 

Editing dialog box. The toolbar is displayed when you click  on the 
General Edits toolbar. By default, the toolbar is floating, but if 
required, the toolbar can be docked alongside existing toolbars. 

 
1. Select one of the following operations: 

 Add material. Use this option, in combination with the brush 
parameters, to add material. Using Add material does not 
increase the number of triangles, but lifts the existing nodes. The 
orientation of the model affects the way the area is built up. To 
undo the add action, use the Erase option. 

 Remove material. Use this option, in combination with the 
brush parameters, to lower the triangle nodes under the brush, to 
make it look as though material has been carved out of the model. 
To undo the remove action, use the Erase option. 

 Smooth. Use this option, in combination with the brush 
parameters, to smooth out irregularities in the triangle nodes. For 
each node in the smoothing area, PowerSHAPE calculates a 
position based on the surrounding nodes. 

 Erase. Use this option, in combination with the Strength, to 
undo changes that you have made during the current editing 
session. Set Strength to 100% to move the node to its original 
position in one step. Set the option to 50% to move the node to its 
original position in two steps. 

2. Use the following to adjust the brush: 
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 Brush diameter. Click the button and use the slider (or D + 
mouse scroll wheel) to increase or decrease the size of the brush. 

 Strength. Click the button and use the slider (or H + mouse 
scroll wheel) to increase or decrease the amount each node is raised 
or lowered as a percentage of the brush radius. 

 Brush Smoothness. Click the button and use the slider (or 
M + mouse scroll wheel) to increase or decrease the smoothness of 
the area you are sculpting. The smoothness determines whether 
there is any reduction in the strength towards the edges of the 
brush.  
A setting of 0% maintains full strength right to the edge of the 
brush.  
A setting of 100% smooths the material across the diameter of the 
brush. 

Use the slider to enter the value to be associated with 
the button you have selected. 

3. Use the following to specify maximum deviation and length: 

 Limit deviation. Click the button and enter the maximum 
deviation that the nodes can move. 

 Refine triangles. Click the button and enter the maximum 
length to be used when refining triangles. 

4. Move the cursor over the model to make the required changes. 
When you have finished editing click  to close the toolbar. 

 Show deviations  is under development. 
 

Sculpt triangles toolbar 
The Sculpt triangles (see page 2) toolbar has replaced the Interactive 
Triangle Editing dialog box. The toolbar is displayed when you click 

 on the General Edits toolbar. By default, the toolbar is floating, 
but if required, the toolbar can be docked alongside existing toolbars. 
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Mesh editing toolbar 
A new Z-compensation tool (see page 39) has been added to the Mesh 
editing toolbar. 

 
 

Model fixing toolbar 
Repair selected solid has replaced Make watertight on the Model 
Fixing toolbar.  

 

With a solid selected, click  to display one of the following: 
 Solid Doctor (see page 15) if the solid is a Parasolid (post-

version 8 solids). 
 Make Watertight if the solid is a PowerSHAPE solid (version 8 

solids). 
 

Solid edit toolbar 
Use the new Solid edit toolbar (see page 30) to make changes to a single 
solid.  

 
The toolbar is displayed automatically when you start to edit a solid. It is 
also displayed by selecting View > Toolbars > Solid Edit. 
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Assembly toolbar 
Manage attachments (see page 42) has been added to the Relation 
flyout.  

 
Clicking this button displays the new Manage attachment dialog box. 
This dialogue is also displayed if you select Manage attachment from 
the component popup menus.  

 

Dialog boxes 
The following changes have been made to dialog boxes: 

 The Interactive Triangle Editing dialog box has been replaced 
by the Sculpting toolbar (see page 2). 

 Use the Maximum edge length option on the Reduce mesh 
dialog box (see page 38) to restrict the maximum edge length that 
should be maintained during the reduce operation. 

 Use Close model during Autofix to close the model when 
fixing triangles on export (see page 39). 

 Add a component that you have modelled to a custom catalog (see 
page 40) by selecting Add new component (Manage custom 
catalogs dialog box). For clarity, Create a component has 
been renamed Copy existing component. 

 Create relations (see page 44) and Manage attachments (see page 
42) dialog boxes replace the Relations toolbar. 

 

Menus 
Changes have been made to the following menus: 

 File (see page 6) 
 Object (see page 6) 
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 Tools (see page 7) 
 

File menu 
Import Point Clouds (see page 48) has been added to the File menu. 

 
 

Object menu 
 Z compensation has been added to Object > Mesh options. 
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 Transform options have been added to Object > Feature 
options. 

 
 

Tools menu 
 Tools > Convert all solids has been added to the menu to let 

you convert (see page 12) all the solids in a model to or from 
version 8 solids.  
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 Make Watertight has been replaced by Tools > Model Fixing 
> Repair Solid.  

 
Select this option to display one of the following: 
 Solid Doctor (see page 15) if the solid is a Parasolid (post-

version 8 solids). 
 Make Watertight if the solid is a PowerSHAPE solid (version 

8 solids). 
 

Solid modelling 
The following areas of solid modelling have been updated in 
PowerSHAPE 2010: 

Solid modelling using Parasolid (see page 8) 
Converting solids (see page 12) 
Fixing solids using the Solid Doctor (see page 15) 
Editing solids using the Solid Edit toolbar (see page 30) 
Creating transform features (see page 32) 
Solid variables (see page 36) 

 

Parasolid in PowerSHAPE 2010 
The Parasolid kernel is now used to implement solid modelling 
commands. Parasolid is becoming an industry-standard, and is used as the 
backbone of many of the leading solid modellers, including SolidWorks 
(Dassault Systèmes SolidWorks Corp), Solid Edge and NX (Siemens). 
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In almost every way, the user interface remains the same. You should 
notice that the commands work faster and more reliably. The kernel will 
also make it easier for Delcam to develop new solid modelling commands 
in the future. 
The Parasolid kernel is only used with the following products: 

Delcam Estimator  
Delcam Crispin SoleEngineer 
Delcam PowerSHAPE  
Delcam PowerSHAPE Pro  
Delcam PowerSHAPE-e  
Delcam Draft  
Delcam Toolmaker  
Delcam Electrodemaker  
Delcam CopyCAD Pro  
Delcam Orthotics  
Delcam Designer  
Delcam Designer-e 
Delcam PowerMILL Modelling 

Use the information in the following sections to understand more about 
using Parasolid: 

Parasolid - the benefits (see page 9) 
Parasolid - do I need to model differently? (see page 10) 
Parasolid - overview of model conversion (see page 11) 
Parasolid - overview of fixing models (see page 12) 

 

Parasolid - the benefits 
The following are examples of the benefits you will get from 
PowerSHAPE using the parasolid kernel: 

 Faster and more robust solid modelling operations. Tests have 
shown that using the parasolid kernel is up to four times faster than 
using the PowerSHAPE kernel. 

 Faster and more robust drawings. 
 Faultless data conversion to and from other parasolid-based 

modellers. Higher quality transfer to and from other solid 
modellers because you can ask for parasolid data from customers 
instead of IGES or STEP. 
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 The .psmodel file size will be much smaller if the part has been 
created wholly using the parasolid kernel. If there has been any 
conversion from version 8 solids or to/from surfaces, this will not 
be the case. 

 Import and export of Parasolid file formats will conserve the 
parasolid data with no loss of quality. At present the recommended 
formats are: 
Parasolid (x_t, x_b, xmt_txt, xmt_bin) 
The following formats that support Parasolid are available with 
Delcam Exchange installed. 
SolidWorks (sldprt) 
UG NX (prt) 

 Crisper, tidier graphics. 
 

Parasolid - do I need to model differently? 
Generally, you do not need to change the way you model in 
PowerSHAPE, but there are a few exceptions: 

 If you want to boolean an open solid (sheet) to an active solid, and 
re-trim the active solid to the edges of the sheet, 
do one of the following: 
 Extend the sheet through the active solid. 

 
 Form a closed solid from the sheet. 
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 If you want to fill a hole in the active solid, use the Sew operation 
rather than a boolean addition. 

 
 A scale transform will cause a complete replay of the history tree. 

If the part has a very complex tree, this may take some time. 
 Parasolid is particular about the wireframe you use for creating 

solids: 
 Make sure that there are no zero magnitude points and that any 

point that is supposed to be tangent continuous really is 
continuous. If not, surfaces may be divided unnecessarily and 
operations (particularly thickening) may fail. 

 When creating extrusions or cuts/bosses from planar wireframe, 
always check that the wireframe really is planar. Parasolid uses 
a much tighter tolerance than PowerSHAPE when testing 
wireframe for planarity (flatness). If the wireframe is not planar, 
extrusions/cuts/bosses will not be capped and may fail. 

 Always try to create wireframe from lines and arcs rather linear 
or arc-like Bezier spans. 

 

Parasolid - overview of model conversion 
Separate, detailed information is available on converting models to and 
from an earlier version of PowerSHAPE (see page 12). The following is a 
summary: 

 Existing models that were created using the PowerSHAPE kernel 
will continue to work in PowerSHAPE 2010 
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 New models will use parasolid, unless you change the default by 
selecting the Version 8 solids option on the Tools > Options 
> Object > Solids dialog box. 

 Parasolid and version 8 solids will co-exist in the same model. 
 It is not possible to perform boolean operations between solids of 

different kernels. One solid must be converted before the operation 
is attempted. 

 It is possible to convert solids in existing models to parasolid and 
parasolid to version 8 solids. 

 

Parasolid - overview of fixing models 
There is separate and detailed information on fixing parasolid models. 
The following is a summary: 

 Parasolid has stricter rules on 'valid' geometry. Geometry that is 
valid in version 8 models is not necessarily valid in a parasolid. 

 Faults in a parasolid body can be viewed and fixed using the Solid 
Doctor (see page 15). 

 Generally, you only need to fix a fault if you are going to perform a 
modelling operation through the faulty area; for example, 
performing a boolean subtraction. 

 

Converting solids 
If a model contains post-version 8 solids (Parasolids), the solids need to 
be converted manually before exporting back to an earlier version that 
doesn't support Parasolids.  
Use the following tools to convert solids to and from version 8 solids 

 Use Tools > Convert all solids to convert all solids in a model 
(see page 12). 

 Use the Convert button on the Solid Edit toolbar to convert a 
single solid (see page 14). 

 Use Edit > Convert > Convert solids to version 8 solids 
and Edit > Convert > Convert solids from version 8 solids 
to convert multiple solids. 

 

Convert all solids 
1. Click the model that contains the solids. 
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2. Select Tools > Convert all solids to display the Convert 
Solids dialog box. 

 
3. Select the conversion option you require. 

 To check the type of solid in your model, right click on a 
solid. If a solid is version 8, Version 8 is displayed in the 
title of the solid popup menu. 

4. Click Convert. 
5. Click Yes to confirm that you want to convert all the solids in a 

model. A summary of the results of the conversion is displayed in 
the dialog box. 

 
6. Click Report to display the Convert Solids Report detailing 

any issues with the conversion. 
7. Right click on the converted solid to display the solid popup menu.  
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This will say:  
Solid for post-version 8 solids. 

 
Version 8 Solid if the solid is version 8. 

 
 

Convert selected solids 
1. Click the solid to be converted to display the Solid Edit toolbar. 

2. Click . 
3. Right click on the converted solid to display the solid popup menu.  

This will say:  
Solid for post-version 8 solids. 

 
Version 8 Solid if the solid is version 8. 
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Solid Doctor 
The Solid Doctor lets you find and fix the faults in a solid. Holes, 
overlaps, self-intersections and bad trimming of surfaces are classed as 
faults. These need to be removed as they can cause further solid feature 
operations to fail. 

To start the solid doctor: 
With a solid selected do one of the following to display the Solid Doctor 
dialog box: 

 Select Tools > Model Fixing > Solid Doctor. 

 Click  on the Solid Edit toolbar. 

For further details, see:  
 Using the Solid Doctor (see page 15) 
 Solid Doctor dialog box (see page 24) 
 List of fault options (see page 28) 
 Doctor Edit toolbar (see page 29) 
 Tips on using Solid Doctor (see page 29) 

 

Using the Solid Doctor 
Use the Solid Doctor to find and fix the faults in a solid. The following 
are classed as faults: 

 holes 
 overlaps 
 self-intersections 
 bad trimming of surfaces 

These faults need to be removed because they may cause further solid 
feature operations to fail. 
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The following model is used to illustrate creating a faultless solid. 

 

1. Click Quick select all surfaces  . 

 

2. Click Solid . 
3. Click Create solid from selected surfaces or meshes 

. 

 
4. If you are asked if you want to fix the faults in the solid, click Yes 

to display the Solid Doctor. 
If this message has not been displayed start Solid Doctor using 
one of the following ways: 
 Select Tools > Model Fixing > Solid Doctor. 

 Click  on the Solid Edit toolbar. 
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The Solid Doctor dialog box is displayed. 

 
The faults are listed in the fault tree and displayed in pink on the 
model. 

 
5. Ensure that Attempt automatic repair is selected from the 

Repair options drop down list. 

6. Click  to process the repair.  
On the model, the faults that have been repaired and the 
corresponding fault labels turn green. Fault has been repaired 
is displayed in green at the top of the information window in the 
dialog box.  
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7. Click  to re-check the model. Only the faults that still need 
fixing are displayed. Comparing this to the original shows that 
many of the faults have been fixed using the automatic repair 
feature. 

 
8. On the model, click the hole at the top of the model to select that 

hole for fixing. 
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9. Select Fill hole with non-tangential surface from the repair 
option drop-down list. 

 

10. Click . 

11. Click  to re-check the model.  
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12. Click the hole on the front of the model to select that hole for 
fixing. 

 
13. Select Fill hole with tangential surface from the repair option 

drop-down list. 

 

14. Click . 
Fault has been repaired is displayed at the top of the 
information window in the dialog box. 
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15. Click  to re-check the model. The model shows the remaining 
faults: a Gap and a large Hole round the outside. The Gap is in 
fact an overlap because it extends beyond the solid. 

 
16. Select Gaps (1) from the tree in the dialog box. 
17. Click Extract surfaces around gap and edit them from the 

Repair Options drop down list. 

 

18. Click . 
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19. Zoom around the gap in the model window. 

 
20. Convert the surface below to wireframe and select the composite 

curve . 

 

21. Select  Limit selection from Limit flyout on the General 
edits toolbar. 

22. Select the surface . 

23. Click Accept  on the Doctor Edit toolbar. 

  
If necessary re-select the surfaces that need to be included back in 
the solid 

24. Click Apply . 

25. Click  to re-check the model. 
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The outer edge of the solid is now marked as a hole. 

 
26. Select Ignore intentional large hole from the repair options. 

 

27. Click . Intentional hole in solid is displayed at the top of the 
information window and the Hole label is displayed in green. 

 



 

24 • What's New in PowerSHAPE 2010 PowerSHAPE 2010 What's New 

28. Click Finish. 

 
 

Solid Doctor dialog box 
Use the dialog box to fix all the faults in a solid by removing holes and 
repairing the trimming of the faulty surfaces. Resize the dialog box as 
required, so that you can see the faults. 
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Fault Tree is displayed in the left panel of the dialog box and lists the 
faults in the solid.  

 
Use one of the following methods to select faults in the Fault Tree 
or the model window: 
 If you select a fault in the tree, it will be highlighted in the 

model.  
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 If you select a fault label  or fault annotation  in the model 
it will be highlighted in the tree.  

 
Fault Information for the selected fault is displayed in the right panel 
of the dialog box.  

 
The following fault information is provided: 
 What is wrong: shows a description of the fault. 
 What to do: gives a suggested repair procedure. 
 Failed repair operations lists the fixing operation that 

failed. 
Fixing stage graphics show the progress on fixing faults. 

 

 - Click to enlarge the view of the selected fault. Zoom out to view the 
whole solid. 

 - Choose how you want to display the faults in the model window. 
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 displays the selected fault in the model window. 

 displays all the faults in the model window. 
Repair Options - Select a repair option from the list of available repair 
operations. The default option is Attempt automatic repair. For 
further details see List of fault options (see page 28). Depending on the 
repair option, the Doctor Edit toolbar (see page 29) is displayed.  

 

 - Click to apply the repair option to the selected faults. 

 - Click to undo the last repair operation. 

 - Click to re-check the solid for faults. 
Finish - Click to close the dialog box and re-check for faults. If faults are 
found the Faulty Solid Query dialog box is displayed. 

 
Continue - Click to open the Solid Doctor dialog box to 
continue fixing faults. 
Finish - Click to accept the changes made by the Solid Doctor. 
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List of fault options 
This lists the repair options displayed on the Solid Doctor dialog box. The 
repair options relevant to the selected fault are displayed in the Repair 
Options drop down list.  
 
Repair option Action 

 Attempt automatic repair Automatically fixes the fault. This 
combines other standard listed options to 
try to repair the solid. 

 Extract surfaces and edit them 
 Extract surfaces around gap 

and edit them 
 Extract surfaces around hole 

and edit them 
 Extract surfaces at edge and 

edit them 

Removes surfaces of the fault. Enters 
surface edit mode to fix the surfaces. 

 Delete surfaces Deletes the faulty surface. 
 Delete selected surfaces Deletes highlighted surfaces 
 Fix surface Enters surface edit mode when a surface 

is selected. 
 Add selected surfaces to solid Adds the selected surfaces and/or solids to 

the main solid to fill the open hole. 
 Fill gap with tangential surface 
 Fill gap with non-tangential 

surface 
 Fill hole with tangential surface 
 Fill hole with non-tangential 

surface 

Creates a fill-in surface for the selected 
hole in the solid. 

 Fill gap by removing boundary 
 Fill hole by removing boundary 

Extends the surfaces adjacent to the hole 
to try to fill the hole. 

 Link edge across gap and heal 
if possible 

Heals the open edge. This may increase 
the solid tolerance. 

 Ignore intentional large hole Marks the selected large hole as 
intentional. 
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 Mark problem area and leave 
faulty surface in solid  

 Mark hole boundary with curve 
for manual fixing 

Creates composite curves around the 
faulty surfaces and holes. 

 Global fault with unknown fix 
 Select individual fault  

Not currently available. For future 
development.  

 Enter edit mode Enters surface edit mode without 
changing the solid. 

 Fault repaired Displays if the fault has been repaired. 
 

 

Doctor Edit toolbar 
This toolbar is displayed when you use the surface creation and editing 
tools to fix the surface before adding it back into the solid. The necessary 
curve and surface creation and editing tools are displayed.  

 

 - Click to display the Surface Repair Information dialog box, 
that displays details of suggested repair operations. 

 

 - Click to accept the surface edit changes. If a surface is selected, 
Solid Doctor tries to add the surface back into the solid. 

 - Click to cancel any surface edit changes. 
 

Tips on using Solid Doctor 
It is useful to remember the following points when using Solid Doctor: 
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 When a fixing problems, look at the problem first and ask yourself 
how you would fix that problem using surfaces. Then make/repair 
the surfaces that way and sew them back into the solid. 

 Run automatic fixing as the first step. Select the top entry in the 

fault tree and click  It won't fix all the problems, but it will 
usually drastically reduce the number of faults that need fixing 
using other options. 

 Use  often to re-check the solid. 
 Only selected surfaces are sewn into the solid when you leave 

Doctor Edit mode. You will be prompted if you forget to select a 
surface to be used. 

 Gaps can be overlaps. 
 If there are any tiny gaps between surfaces, consider removing the 

surfaces that are adjacent to the fault. Use one of the hole filling 
options to fix the fault. 

 Use Shift and CTRL to add and remove surfaces from the 
selection. 

 

Using the Solid Edit toolbar 
The Solid Edit toolbar is displayed automatically when you start to edit 
a solid. It is also displayed by selecting View > Toolbars > Solid Edit. 
Functionality that is accessed from the toolbar has been removed from the 
solid popup menu, solid tree popup menu and Object > Solid menu. 

1. Select a solid to edit. The Solid Edit toolbar is displayed: 

 
2. Click one of the following buttons to edit the solid: 

 shows that the selected solid is active. Click the button to 

make the solid inactive . 

 Click this button and then select the individual face of a solid. 

 Click this button and click on a face in the solid. All the faces 
of the feature that the face belongs to will be selected. 
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 Click this button and click on a face in the solid to select all 
the faces in the convex region of the face. 

 Click this button and click on a face in the solid to select all 
the faces in the concave region of the face. 

 Click this button and select one or more faces to create surface 
copies. This replaces Copy Surface on the solid popup menu. 

 Click this button and select one or more faces to create surface 
copies and remove them from the solid. 

 (Only available for post-version 8 solids) Click this button to 
display the Sew dialog box. Select one or more surfaces or solids 
and click OK. This option replaces Object > Solid > Sew.  

 Click this button to find and fix faults. One of the following is 
displayed: 
 Solid Doctor (see page 15) if the solid is a Parasolid (post-

version 8 solids). 
 Make Watertight if the solid is a PowerSHAPE solid (version 

8 solids). 

 Click this button to convert to/from version 8 solid (see page 
12). 

 Click this button to convert the solid to surfaces. This replaces 
Convert on the solid popup menu. 

 Click this button to create a mesh from the selected solid. This 
replaces Convert to mesh on the solid popup menu. 

 Use normal selection methods:  to add/remove a face from the 

selection;  to add a face to the selection. 
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Solid transform feature 
New functionality has been added to PowerSHAPE 2010 to create solid 
transform features on solids so that its values can be changed, or the 
transform suppressed, unsuppressed or deleted. This means that the 
information about changes of position, rotation, scaling or mirroring are 
stored with the solid. 

Creating transform features 
Transform features can be created by: 

 Selecting one or more solids and selecting Move, Rotateor 
Mirror from the General Edits toolbar when the option Tools > 
Options > General Edits > Create solid transform 
features is selected. 

 Scale transform feature will not be created if you select Scale 
from the General Edits toolbar, even if the Tools > Options 
>General Edits > Create solid transform features is 
selected. 
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 Selecting one of the options on the Object > Feature > 
Transform menu. These options will create a transform feature on 
the active solid and let you enter the parameters and show a 
preview of the transformed solid. 

 
The following specific dialog boxes are displayed when using this 
method to create the transform feature: 
Move feature (see page 34) 
Rotate feature (see page 34) 
Mirror feature (see page 35) 
Scale feature (see page 35) 

Editing a transform feature 
1. Use one of the following methods to display the relevant transform 

feature dialog box. 
 Double click the transform feature in the solid tree. 
 Select Modify from the feature's popup menu. 

The transform feature dialog boxes will be displayed irrespective 
of how the transform feature was created. 

2. Use the dialog box to modify the feature. 
3. Click OK to make the changes. 

Tips when using transform features 
 When using the General Edits toolbar, transform features will not 

be created on solids that do not have history trees, whatever the 
setting on Tools > Options > General Edits. 



 

34 • What's New in PowerSHAPE 2010 PowerSHAPE 2010 What's New 

 If you use Copy original, the original won't have a feature 
associated with it, but the copies will. 

 Features below a transform feature in the solid tree are not 
transformed. When modifying an earlier feature it will appear in its 
original state. 

 Transform features can be suppressed, deleted and reordered. If the 
transform is suppressed or deleted, the solid will revert to its 
original state (before transformation) 

 

Move feature 

 
1. Movement Vector defines the distance to be moved along each 

axis. These axes refer to the feature's workplane. 

2. To define the translation by clicking on the model, use  to 
display the Position dialog box to Reposition start point and 
Reposition end point. 

3. Click  to edit the feature's workplane using the Workplane 
dialog box. The feature's workplane acts as a reference point for the 
transform. 

4. Click OK to create the transform feature. The move feature  is 
added to the feature tree. 

 

Rotate feature 

 
1. Enter an angle of rotation as measured around the z axis of the 

feature's workplane. A preview of the rotated solid is displayed 
with the existing position. 
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2. Click  to edit the feature's workplane using the Workplane 
dialog box. The feature's workplane acts as a reference point for the 
transform. 

3. Click OK to create the transform feature. The rotate feature  is 
added to the feature tree. 

 

Mirror feature 

 
1. Use  to change the plane in which the mirror transform 

takes place. 

2. Click  to edit the feature's workplane using the Workplane 
dialog box. The feature's workplane acts as a reference point for the 
transform. 

3. Click OK to create the transform feature. The mirror feature  is 
added to the feature tree. 

 

Scale feature 
A scale feature can only be created if you select Object > Feature > 
Transform > Scale to display the Scale Feature dialog box. It will 
not be created if you select  from the General Edits toolbar, even if the 
Tools > Options >General Edits > Create solid transform 
features is selected. 
Use this dialog box to specify the scale feature. 
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1. Use the drop down list to select the Type of scale to be used 
(Uniform, Non-uniform or Projected volume). 

2. Enter a single Scale factor for Uniform scaling. For Non-
uniform scaling enter scale factors for X, Y and Z. For scaling 
Projected volume, enter values for Original volume and 
Desired volume. 

3. Use  to lock the scale factor to 1 for a particular axis. The 
X, Y and Z scale factors refer to the axes of the feature's 
workplane. 

4. Click  to edit the feature's workplane using the Workplane 
dialog box. The feature's workplane acts as a reference point for the 
transform. 

5. Click OK to create the transform feature. The scale feature  is 
added to the feature tree. 

 The results that are achieved using transform features may not 
necessarily be as expected. This is because functionality such as 
Scaling Constraints is not applied. Therefore, if it is essential 
that the original behaviour is ensured, deselect the Create solid 
transform feature option on the Tools > Options > General 
edits dialog box. 

 

Solid variables 
The following new solid variables have been added: 

solid.active - returns the name of the currently active solid. 
solid[N].parasolid - returns 1 if the solid is a parasolid, else 0. 
solid[N].v8 - returns 1 if the solid is a version 8 solid, else 0. 
solid[N].surface[M].id - returns the id number of the Mth surface of 
solid N, or the representation number if a parasolid solid.  
solid[N].surface[M].name - returns the name of the Mth surface of 
solid N. This is the same as the existing command 
solid[N].surface[M].  

 

Modelling with triangles 
Additions have been made to the following areas of triangle modelling in 
PowerSHAPE 2010. 
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Sculpting triangles (see page 2) 
Reduce mesh dialog box (see page 38) 
Mesh editing toolbar (see page 39) 
Importing point data (see page 48) (Delcam CopyCAD only) 
Options (see page 39) 

 

Sculpt triangles 
The Sculpt triangles toolbar has replaced the Interactive Triangle 

Editing dialog box. The toolbar is displayed when you click  on the 
General Edits toolbar. By default, the toolbar is floating, but if 
required, the toolbar can be docked alongside existing toolbars. 

 
1. Select one of the following operations: 

 Add material. Use this option, in combination with the brush 
parameters, to add material. Using Add material does not 
increase the number of triangles, but lifts the existing nodes. The 
orientation of the model affects the way the area is built up. To 
undo the add action, use the Erase option. 

 Remove material. Use this option, in combination with the 
brush parameters, to lower the triangle nodes under the brush, to 
make it look as though material has been carved out of the model. 
To undo the remove action, use the Erase option. 

 Smooth. Use this option, in combination with the brush 
parameters, to smooth out irregularities in the triangle nodes. For 
each node in the smoothing area, PowerSHAPE calculates a 
position based on the surrounding nodes. 

 Erase. Use this option, in combination with the Strength, to 
undo changes that you have made during the current editing 
session. Set Strength to 100% to move the node to its original 
position in one step. Set the option to 50% to move the node to its 
original position in two steps. 

2. Use the following to adjust the brush: 

 Brush diameter. Click the button and use the slider (or D + 
mouse scroll wheel) to increase or decrease the size of the brush. 
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 Strength. Click the button and use the slider (or H + mouse 
scroll wheel) to increase or decrease the amount each node is raised 
or lowered as a percentage of the brush radius. 

 Brush Smoothness. Click the button and use the slider (or 
M + mouse scroll wheel) to increase or decrease the smoothness of 
the area you are sculpting. The smoothness determines whether 
there is any reduction in the strength towards the edges of the 
brush.  
A setting of 0% maintains full strength right to the edge of the 
brush.  
A setting of 100% smooths the material across the diameter of the 
brush. 

Use the slider to enter the value to be associated with 
the button you have selected. 

3. Use the following to specify maximum deviation and length: 

 Limit deviation. Click the button and enter the maximum 
deviation that the nodes can move. 

 Refine triangles. Click the button and enter the maximum 
length to be used when refining triangles. 

4. Move the cursor over the model to make the required changes. 
When you have finished editing click  to close the toolbar. 

 Show deviations  is under development. 
 

Reduce mesh dialog box 
Use the Maximum edge length option on the Reduce mesh dialog 
box to define the maximum edge length that should be maintained during 
the reduce operation. 

1. Select Limit triangle edge length to display the option. 

 
2. Enter the maximum length of the triangle edge. 
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Z-compensation tool 
Use the Z-compensation tool to cancel the overcure effect when 
preparing meshes for manufacture on stereolithography machines. 

1. Create a solid sphere. 

2. Select  (Solid editing toolbar) to convert the solid to triangles. 
3. Select the mesh to display the Mesh editing toolbar. 

4. Click  to display the Z compensation dialog box. 

 
5. Enter an Amount and press the tab key.  
6. Click Apply to display the model with the compensation applied. 

 

 In the example a large value has been used to exaggerate the effect. 
 

Options 
Use the new Close model during Autofix to close the model when 
fixing triangles on export. 

1. Select Tools > Options > Data Exchange > STL/DMT. 
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2. Select Auto fix mesh on STL export to display the options: 

 
Close model during Autofix is deselected by default. 

 

Assembly modelling 
Changes have been made to the following areas of Assembly modelling: 
Component wizard (see page 40) 
Manage attachments (see page 42) 
Create relations (see page 44) 
Other changes (see page 47) 

 

Component wizard 
The concept of Custom catalogs was introduced in PowerSHAPE 8.0. 
It is now possible to add a user-modelled component to a custom catalog. 

 For clarity, Create a component has been renamed Copy an 
existing component. 

Adding a user-modelled component: 
With the source component displayed: 
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1. Click Add new component. 

 
2. Select the following: 

 Source component on the model.  
 Destination folder. 

3. Click Use selected. 
4. Click Add to add the component to the custom catalog. The dialog 

box updates to display the component: 

 
5. Click Edit component details and dimensions to display the 

MS Excel spreadsheet for the component. 
6. Change the name and dimensions in the spreadsheet as required. 

Switch back to PowerSHAPE. 
7. Click Apply changes to: 

 Update the Custom Catalogs tree to reflect any component 
name change. 

 Close the spreadsheet. 
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 Display the component in the graphic window on the dialog 
box. 

 
8. Use the following options as required: 

 Click  to Add draft. Choose the required graphic from the 
Select a Draft dialog box. The selected graphic is added to a 
Draft tab. 

 To delete a tab, select the tab and click  to Delete draft.  
 To change the title of a tab, select the tab and click  Edit 

draft properties. Enter the new tab Title and click OK (just 
below the Title) to change the tab. 

9. Add further user-defined components as required. 
10. When all components have been added to the custom catalog, click 

OK to finish. 
 

Managing attachments 
Use the new Manage attachment dialog box to: 

 edit existing attachments. 
 create new attachments. 
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With a component selected, click  on the Relation flyout (Assembly 
toolbar). Alternatively, select Manage attachment from the component 
popup menus.  

 
The Manage attachment dialog box is displayed.  

 

Editing existing attachments 
Edit is selected by default. This lets you: 

 rename an attachment by selecting the existing name from the 
drop-down list and enter the new name. 

 set the selected attachment as the Default attachment. 

Creating attachments 
Use the Manage attachments dialog box to create attachments in one 
of the following ways: 
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 Creating an attachment in space is useful when you are trying to 
position a component and there is no other geometry to attach to.  
Click Create in space and click the required position. The 
attachment is created at the specified position. The attachment 
position will not update if the component geometry is modified.  

 Creating an attachment on surface is useful when you are trying to 
position a component and a default attachment of plane, point or 
line isn't available. Create on surface lets you attach to a 
specified position. 
To create an attachment on a surface, click Create on surface 
and click anywhere on the surface. The attachment is linked to the 
underlying surface parameters and will update if the geometry is 
modified. 

When you have created the attachment, the Edit option is selected on the 
dialog box. Use the following options to modify the attachment 

1. By default, the new attachment is named Unnamed. Enter a new 
name as required. 

2. Edit the X, Y and Z coordinates or click  to enter the 
coordinated using the Position dialog box. 

3. Click  to remove the attachment that you have just created. 
4. Click Default attachment to make the new attachment the 

default. 
 

Creating relations using attachments 
Use the Create Relations dialog box to create relations between 
components. Create Relations replaces the Relations toolbar. 
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1. Click  on the Relations flyout (Assembly toolbar) 

 
The following simple example illustrates the options on the dialog 
box: 

 
2. Select the first attachment . This is the master attachment.  

changes to . 

3. Select the second attachment . This is the slave attachment. The 
model and the dialog box are updated as follows: 
 A Coincident Plane to Plane relation is created between 

the two components. Selected Plane to Plane relation is 
displayed in the dialog box and  is displayed as the Relation 
type.   

 The slave component  is rotated to reflect the relationship you 
have defined. 

 The information panel is updated to indicate if there is a 
conflict. 
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4. Enter a Distance of 100 or click  and use the slider in the 
Angle/Distance Scaler dialog box to specify the distance. The 
model will be updated. 

 
5. Click  to display Relation type options. 

6. Select  to change the Relation type to Angular. 
7. Enter  25 as the Angle. 

 

8. Click  to Anti-align so that the slave attachment lies in the 
opposite direction to the master attachment.  

9. Click Apply to create the relation you have just defined. The 
dialog box is still displayed to allow you to specify additional 
relations in a more complicated model. 
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10. Click OK to finish creating relations. The relationship that you 
have created is added to the assembly tree. 

 

 Relations are added to the tree when the second attachment is 
selected. If you realise you have made an incorrect selection before 
you click Apply, do one of the following: 
*  Close the dialog box, delete the relation from the assembly tree 
and then create the relation using the correct selection. 
*  With the dialog box still displayed, use Select first attachment and 
Select second attachment to modify the relation. 

 

Other changes to Assembly modelling 
The following changes have been made to the general operation of 
Assembly modelling: 

 Use the Modify > Parameters option on the component popup 
menu to modify multiple parametric components that are selected 
in the assembly tree. 

Interface 
 Default attachment has been removed from the component 

popup menus. 
 Colours and styles for highlighting attachments and components 

have been modified to improve clarity. 

Assembly with Parasolids 
 Problems with lost attachments that may occur when converting 

component solids are reported in the conversion report. 
 Import assemblies from Parasolid XT files. 
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Delcam Draft 
The following change has been made to Delcam Draft: 

 If the drawing sheet numbers are not consecutive after a sheet 
number has been changed, renumber the sheets automatically by 
selecting Yes when asked if you wish to renumber. 

 

Delcam CopyCAD Pro 
Import Point Clouds (see page 48) has been added to the File menu. 

 
 

Importing point data 
1. Click File > Import Point Clouds to display the Point Import 

dialog box. 

 
2. Use the following buttons to import multiple points : 
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 Import a point cloud. 

 Import a point cloud using the Import Point wizard.  

3. Click  to display information about the model.  
4. Use the following buttons to model and edit the point data: 

 Point toolbar. 

 Scanline editing toolbar.  

 Modelling toolbar. 

 Triangle Generation toolbar.  
5. Use the following buttons to delete models: 

 Delete selected models  

 Delete all other models  

 Delete all  
 

Delcam Designer & Designer for 
Jewellery 

The following changes have been included in Delcam Designer and 
Delcam Designer for Jewellery. 

 Jewellery libraries have been added to Delcam Designer for 
Jewellery. They are loaded automatically when Delcam Designer 
for Jewellery is started and displayed in a window at the bottom of 
the screen. The example below shows the Baguette settings. 

 
 Specific settings are loaded when using Delcam Designer and 

Delcam Designer for Jewellery. These ensure that: 
 the assembly tree is not displayed automatically. 
 when using 'drag and drop', the default relation is Aligned.  
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 when using 'drag and drop', the cursor snaps to components 
attachments only.  

 base points of attachments are drawn when in shaded mode. 
 When using the Parameter List Editor dialog box, the 

component parameters have a pre-defined maximum and minimum 
value. The edit boxes for these parameters have slightly different 
coloured backgrounds. If you enter a value greater than the 
maximum, the maximum value will be used. If you enter a value 
less than the minimum, the minimum value will be used. 

 

Delcam Electrode 
Use the new selection options on the Electrode Wizard to select the 
surface data representing the part from which Delcam Electrode extracts 
the electrode.  

1. Select surfaces. 

2. Click  from the Wizard toolbar to display the Select 
product and electrode objects page of the Electrode wizard. 

 
3. If required, click Electrode and select additional electrode 

surfaces for shutout faces at the intersection of ribs.  
4. Click Next to display the Select Regions page of the Electrode 

Wizard and create the electrode in the normal way. 
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Other changes 
The following changes have been made to the general operation of 
PowerSHAPE: 

 PowerSHAPE releases now use a year-based title in the form 
PowerSHAPE 2010. This title is used in the About dialog box and 
the Main toolbar. 
For example: 
Delcam PowerSHAPE 2010 for the first customer release after 
July 1st 2009 
Delcam PowerSHAPE 2010 R2 for the second customer 
release after July 1st 2009 

 All models opened in PowerSHAPE 2010 use model version 21. 
When PowerSHAPE 2010 is installed and run for the first time, the 
initialisation work will open the latest 
NEW_MODEL_MASTER_XX you have (where XX <21) and 
save it as NEW_MODEL_MASTER_21 and also turn off the 
Version 8 solids option on the Tools > Options > Object > 
Solids dialog box. 
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