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The following areas have been updated in PowerSHAPE 2012:  

User interface (see page 2) 

Direct Modelling (see page 22) 

Surface modelling (see page 41) 

Solid modelling (see page 42) 

Triangle modelling (see page 46) 

Assembly modelling (see page 48) 

Delcam Draft (see page 50) 

Delcam Render (see page 50) 

Other changes in PowerSHAPE 2012 (see page 51) 

 

What's New in 
PowerSHAPE 2012 
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User interface 
A number of changes have been made to the user interface in 
PowerSHAPE 2012. Updated areas include: 

 Graphics and instrumentation (see page 2). 

 Toolbars (see page 8). 

 Dialogs (see page 10). 

 Menus (see page 20) 
 

Graphics and instrumentation 

Updated graphics and 3D instrumentation have been included in 
PowerSHAPE 2012. Changes include:  

 new default colour scheme (see page 2). 

 new 3D instrumentation (see page 4). 

 updated context-sensitive cursor graphics (see page 6). 
 

New colour scheme 

The following updates have been made to PowerSHAPE's colour 

scheme: 

 The new default colour scheme is black_on_grey. 
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 The default solid material is solid grey . The default surface 

material is unchanged surface_blue . 

 

 Solid features are now highlighted light blue . When individual 

faces are selected, they are highlighted orange . 

 

To compliment the new colour scheme, the context-sensitive 
cursors (see page 6) and 3D instrumentation (see page 4) have 

been updated. 
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3D instrumentation 

3D instrumentation has been added to: 

 workplanes (see page 4). 

 solid primitives and solid features (see page 5). 
 

3D instrumentation - Workplanes 

 The active workplane is now rendered in 3D and each axis has 
been given a separate colour. Use the new 3D instrumentation 

for improved selection and control when modifying workplanes. 

 Click and drag to move the workplane along the selected axis 

.  

 Click and drag to rotate the plane around the selected axis. 
The edges of the plane box are colour coded to match the axis 

. 

 

 Move the cursor over the workplane to highlight the available 

selection. 

 

 Dynamic angle feedback is displayed when rotating the edges of 
the plane box: 
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 Use  on the edge corresponding to the axis you want to 

rotate around . 

 Use  to rotate the plane box. The angle is displayed 

next to the cursor . 

 

 Use  to disable intelligent cursor snapping and allow easy 
relative rotation. 

 

3D instrumentation - Solid primitives and solid features 

The drag handles on solid primitives and solid features have been 
rendered in 3D. The shading of the handles lightens when you pass 

the cursor over them to make it clear which handle can be selected. 
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Context sensitive cursors 

Many of the PowerSHAPE cursors have been updated. 

 Annotation (see page 6). 

 Curve toolbar (see page 6). 

 Drafting (see page 6). 

 General edits toolbar (see page 7). 

 View toolbar (see page 7). 

 Other (see page 7). 
 

Context sensitive cursors - Annotation toolbar 

Old Function New 

 Add text along a curve 
 

 Add text (horizontally or vertically)  

 
 

Context sensitive cursors - Curve toolbar 

Old Function New 

 Stop curve  

 Close curve 
 

 Sketch curve 
 

 Select start and end point 
(composite curve) 

 

 
 

Context sensitive cursors - Drafting 

Old Function New 

 Active view 
 

 
View selection 

 

 
Drawing selection 
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Context sensitive cursors - General edits toolbar 

Old Function New 

 Limit cut 
 

 Limit point 
 

 Move/copy/stretch (also used for 
drag-move) 

 

 Rotate items 
 

 Mirror items 
 

 Mirror items across a user defined 

plane 
 

n/a Mirror items in a wireframe line 
 

 Offset items 
 

 Scale items 
 

 
 

Context sensitive cursors - View toolbar 

Old Function New 

 Zoom to box 
 

 Zoom 
 

 Rotate 
 

 
Pan 

 

 
 

Context sensitive cursors - Other 

Old Function New 

 Warning/error 
 

 Selection hand  

 Edge-pick hand  

 Closed selection hand  

 Add component  
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 Principal plane-lock toggled 
 

 No entry  

 No entry, plane 
 

 No entry, arc 
 

 
Paste attributes  

 Selection filter 
 

 
 

Toolbars 

Updates have been made in the following areas: 

 Solid editing: 

 Divide face (see page 43) 

 Solid selection modes (see page 42) 

 Text creation (see page 10). 

 Mesh surfacing (see page 41). 

 General editing (see page 8). 

In addition: 

 A component selection button has been added to the Select 

flyout. This selects components and instances of sub-assemblies. 

 

 Restore selection  has been added to the View toolbar. This 

toggles between the previous and current selection. It also works 
on sub-item selection of a solid. The corresponding Restore 

Selection option has been removed from the View popup menu. 
 

General editing 

The following changes have been made to the General Edits 

functionality: 

 The display of transformed items is controlled by Show a preview 

of transformed items on the Tools > Options > General > General 

Edits options dialog. By default the option is selected. 

 When the option is selected,  and  buttons are displayed 
on the editing toolbars. 
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 When the option is deselected,  and  are not displayed on 

the editing toolbars. 

 Transform operations can be used to edit faces of solids (see 

page 9). 

 Scale (see page 9) and Offset (see page 9) toolbars have been 

updated. 
 

Editing faces 

The following General Edits operations can be used to edit faces of a 

solid as part of the Direct Modelling functionality. 

 Move (see page 32) 

 Rotate (see page 33) 

 Mirror (see page 36) 

 Scale (see page 38) 

 Offset (see page 40) 

Next Solution and Previous Solution buttons are added when these 

toolbars are used to edit faces. If there is more than one possible 
solution, use these buttons to select the required solution  

 
 

Scale 

 The Scale toolbar has been updated as follows: 

 The scaling cursor has been redesigned (see page 7). 

  and  buttons have been added. The display of these is 
controlled by Show a preview of transformed items on the 

General Edits options dialog (see page 19). 

 Selecting Non-uniform scale from the drop-down list no longer 

displays the Non-uniform scaling dialog. Scale factor boxes for 

X, Y and Z are displayed on the toolbar. 

 A graphical preview of the scaled items is displayed. The 
display of this is controlled by Show a preview of transformed 

items on the General Edits options dialog (see page 19). 
 

Offset 

The Offset toolbar has been updated as follows: 
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 The corner drop-down list has been moved to the right-hand-side 

of the toolbar.  

 

 Undo and redo operations are now available when the toolbar is 
displayed. In previous versions, clicking Undo closed the offset 

operation and removed the toolbar. 
 

Annotation toolbar - Text creation 

Text creation buttons (Annotation toolbar) have been updated for 
PowerSHAPE 2012. 

Old Function New 

 
Create horizontal text 

 

 
Create vertical text 

 

 
Create text on a curve 

 

 
 

Dialogs 

There have been updates to the following dialogs: 

 Select Objects by Filter dialog has been updated to include 

Component in the Type list. This selects components and 

instances of sub-assemblies.  

 

 Align Items dialog has been updated so that the progression 

through the selection options is automatic. 

 Import File (see page 11) 

 Export (see page 11) 

 Options (see page 16) 
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Import File dialog 

The following file formats have been added to the file types that can 
be imported using the Import File dialog: 

 *.ai and *.pdf are imported using Delcam Exchange.  

Both formats are listed in the Acrobat Adobe Document 

section of the drop-down list . 

 *.prd (curve) and *.pim (cloud). 

Both formats are listed in the Clouds section of the drop-down 

list . 

 
 

Export dialog 

The Export dialog has been updated to include: 

 access to Delcam Exchange input and output resources . All 

the Delcam Exchange options are documented in that product. 
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 access to the remaining pages of the Export Wizard (see page 12) 

. 

 

If you export without using the wizard, the following defaults will be 
used: 

 export selected items or the entire model if nothing is selected. 

 if a workplane is active, export the geometry to active, 

otherwise, export to World. 

 if a drawing window is active, export the converted drawings. 

 The default for .dgk is to still export to World. You can use the 
Export Wizard to export .dgk to the active workplane.  

 

Using the Export Wizard 

Use the Export Wizard to: 

 export selected model items, visible items or all items. 

 export relative to an active workplane or World. 

 export drawings. 
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1 Select File > Export to display the Export dialog 

 

2 Select the target system for export from the scroll-down list. 

3 Click Next to display the Export File dialog. 

The filename of your model is automatically displayed as the 
filename. Change the Filename as required and select the file 
type from the Save as type drop-down list. 

4 Click Save. The subsequent pages that are displayed depends on 

your export: 

 if you are exporting a model that includes at least one 

drawing, page 2 is displayed (see page 14). 

 if you are exporting a model that does not include drawings, 
page 3 is displayed (see page 14). 

 if your model includes workplanes, page 4 is displayed (see 
page 15). 

 if you are exporting a model that includes mutiple drawings, 
page 5 is displayed (see page 16). 

5 Select the appropriate options on the export pages that are 
displayed. 

6 Click Finish to complete the export. 
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Page 2 - Exporting a model that includes drawings 

Use this page to export a model that includes drawings. 

 

1 Select one of the options to specify the items to be exported: 

 model geometry only 

 drawings 

 drawings and associated model geometry 

2 Click Next or Finish. 
 

Page 3 - Exporting a model 

Use this page to specify the model items that you want to export. 

 

1 Select one of the options to specify the items to be exported: 

 If items were pre-selected, then Selected is the default option. 
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 Visible exports items that are visible on the screen; if an item 

is blanked it will not be exported. This option is useful for 
exporting the workplanes with a model. 

 All is the default option and will be automatically selected if 

there are no pre-selected items. 

2 Click Next or Finish. 
 

Page 4 - Exporting workplanes 

Use this page to specify the workplane to be used at export.  

 

1 Select the option to be used when exporting: 

 Export relative to active workplane. 

 Export relative to World. 

2 Click Next or Finish. 
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Page 5 - Selecting a drawing to export 

Use this page to select the drawings to be exported. This page is 

only displayed if there are multiple drawings associated with the 
model. 

 

1 Select the drawings to be exported. 

2 Click Finish. 
 

Options dialogs 

In PowerSHAPE 2012 there have been some changes to several 
Tools > Options dialogs: 

 The following Options dialogs have been renamed: 

Data Exchange > Import/Export  Data Exchange > Version 
8/Surfaces 

Manufacturing > Feature Export  Manufacturing > Export 

 The following Options dialogs have been restructured as part of 

the rationalisation of import and export functionality: 

 IGES 

 Delcam Exchange 

Exchange options can now be accessed from the Export dialog. 

Updates have been made to the following Options dialogs: 

 Import/Export (see page 17) 

 File Doctor (see page 18) 

 General Edits (see page 19) 
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Import/Export 

Import / Export has been renamed Version 8 / Surfaces. 

 

Import non-parasolid solids using has been added to the dialog. This 

lets you specify the method to be used to import non-parasolid 

solids. 

 

Default settings detects the file type and imports solids as 

Parasolids or version 8 solids depending on the file type: 

 If the file is from a solid modeller, it is imported as a 

Parasolid. 

 If the file is not from a solid modeller, it is imported as a 

version 8 solid. 

Alternatively, you can use the options in the drop-down list to 

specify the import method. 
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File Doctor 

There is a new option on the Tools > Options > Tools > File Doctor 

dialog that controls how File Doctor is run. 

 

 If Run File Doctor interactively when Model updated is selected 

(default) and the model version has been updated, the File 

Doctor is run interactively. The following warning dialog is 

displayed: 

 

 You are recommended to run File Doctor when opening an 

old version model in a version of PowerSHAPE that uses a 
later version model. However, if you select Close on the File 

Doctor dialog, the model is unchanged. 
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 If Run File Doctor interactively when Model updated is deselected 

and the model version has been updated, the File Doctor is run 

automatically (as in previous versions of PowerSHAPE) 

 
 

General Edits 

Control the display of transformed items using the new option on 
the Tools > Options > General > General Edits dialog. 

 

Use Show a preview of transformed items to control the way 

transformed items are displayed. By default the option is selected. 

 When the option is selected: 

  and  buttons are displayed on the editing toolbars. 

 a graphical preview of the transformed items is displayed. 

 When the option is deselected: 

  and  are not displayed on the editing toolbars. 

 no graphical previews are displayed. 

 the transform is applied immediately when the user inputs a 

value or a point.  
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 This is the old behaviour of the editing toolbars.  
 

Menus 

The following options have been added to the PowerSHAPE Edit 

menu: 
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 Click Edit > Convert > Selection to Cloud to convert a group of 

points or a mesh to a point cloud. 

 

 Click Edit > Convert > Cloud to Points to explode a cloud into 

points.  
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Direct modelling 
In PowerSHAPE 2012, Direct Modelling has been extended to 
include: 

 Additional solid feature recognition and editing. The following are 
now included: 

 Pocket/Protrusion (see page 22) 

 Cut (see page 24) 

 Boss (see page 26) 

 Fillet (see page 28) 

 Using the following General Edits operations on faces of solids: 

 Move (see page 32) 

 Rotate (see page 33) 

 Mirror (see page 36) 

 Scale (see page 38) 

 Offset (see page 40) 
 

Pocket recognition & editing 

Use the Edit mode  button on the Pocket dialog to identify 

pocket-like geometry in a solid. 

1 Click  (Solid feature toolbar) to display the Pocket dialog. 

2 Click Edit mode  on the Pocket dialog.  
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3 Move the cursor over the model. Pocket-like geometry on the 

active solid is highlighted as you move the cursor over the solid. 

 

4 Click the required geometry to display the instrumentation. 

 

5 Use the Pocket dialog to edit the pocket as required. 

6 Click Apply to make the changes and create the pocket feature. 
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Edit mode remains active. 

7 Identify more pockets or edit existing pocket features as 
required. 

 If you want to identify multiple pockets or make changes to 
existing pockets without updating the geometry 

immediately, click  to turn on Defer update. The button 

changes to  to indicate that Defer is ON. Using Defer on 

multiple pockets is quicker because the tree is only updated 
when you click OK. 

8 Click one of the following: 

 Cancel to close the dialog and cancel any unapplied changes. 

 OK to close the dialog and apply any unapplied changes. 

The new pocket feature is added to the solid tree. 

 

 Protrusion recognition and editing works in a similar way. 
 

Cut recognition & editing 

Use the Edit mode  button on the Cut dialog to identify cut-like 

geometry in a solid. 

1 Click  (Solid feature toolbar) to display the Cut dialog. 

2 Click Edit mode  on the Cut dialog.  
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3 Move the cursor over the model. Cut-like geometry on the active 

solid is highlighted as you move the cursor over the solid. 

 

4 Click to select the required cut. 

 

5 Use the Cut dialog to edit the cut as required. 

6 Click Apply to make the changes and create the cut feature. 
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Edit mode remains active.  

7 Identify more cuts or edit existing cut features as required. 

 If you want to identify multiple cuts or make changes to 

existing cuts without updating the geometry immediately, 

click  to turn on Defer update. The button changes to  

to indicate that Defer is ON. Using Defer on multiple cuts is 

quicker because the tree is only updated when you click 
OK. 

8 Click one of the following: 

 Cancel to close the dialog cancel any unapplied changes. 

 OK to close the dialog and apply any unapplied changes. 

The new cut feature is added to the solid tree. 

 
 

Boss recognition & editing 

Use the Edit mode  button on the Boss dialog to identify 

boss-like geometry in a solid. 

1 Click  (Solid feature toolbar) to display the Boss dialog. 

2 Click Edit mode  on the Boss dialog. 
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3 Move the cursor over the model. Boss-like geometry on the 

active solid is highlighted as you move the cursor over the solid. 

 

4 Click to select the required boss. 

 

5 Use the Boss dialog to edit the boss as required. 

6 Click Apply to make the changes and create the boss feature. 

 

Edit mode remains active.  

7 Identify more bosses or edit existing boss features as required. 
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 If you want to identify multiple bosses or make changes to 

existing boss without updating the geometry immediately, 

click  to turn on Defer update .The button changes to  

to indicate that Defer is ON. Using Defer on multiple bosses 

is quicker because the tree is only updated when you click 
OK. 

8 Click one of the following: 

 Cancel to close the dialog cancel any unapplied changes. 

 OK to close the dialog and apply any unapplied changes. 

The new boss feature is added to the solid tree. 

 
 

Fillet recognition & editing 

Use the Edit mode  button on the Fillet dialog to identify 

fillet-like geometry in a solid. 

1 Click  (Solid feature toolbar) to display the Fillet dialog. 
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2 Click Edit mode  on the Fillet dialog to display the Recognise 

Solid Fillet dialog.  

 

3 Select the appropriate editing options on the Recognise Solid 

Fillet dialog. 

Interactive Recognition to use the cursor to recognise the fillets 

(default). 

Automatic Recognition to automatically recognise all fillets 

Manual Fix-Up Mode to edit the fillet recognition selection. 

Include All Connected Fillets to include all fillet faces that are 

directly or indirectly connected. 

Suppress to create a suppressed feature, effectively removing 

the fillet faces and healing the solids. 
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4 Move the cursor over the model. Fillets on the active solid are 

highlighted as you move the cursor over them. 

 

5 Click to select the required fillet. 
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6 Click Apply to make the changes and create the fillet feature. 

 

Edit mode remains active. 

7 Identify more fillets or edit existing fillet features as required. 

 If you want to identify multiple fillets or make changes to 

existing fillets without updating the geometry immediately, 

click  to turn on Defer update. The button changes to  

to indicate that Defer is ON. Using Defer on multiple fillets is 

quicker because the tree is only updated when you click 
OK. 

8 Click one of the following: 

 Cancel to close the dialog cancel any unapplied changes. 

 OK to close the dialog and apply any unapplied changes. 

The new fillet feature is added to the solid tree. 
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Using General Editing on faces 

The following General Edit operations can be used on faces of a solid 

as part of the Direct Modelling functionality: 

Move (see page 32) 

Rotate (see page 33) 

Mirror (see page 36) 

Offset (see page 40) 

Scale (see page 38) 

 Use Divide Face (Solid Edit toolbar) to divide the faces of the 

selected solid using wireframe. This lets you to limit the effect 

of general editing operations.  
 

Move - an example 

Use Move  to move a selected face. 

1 Zoom in and rotate the model so that the details are clearly 

visible. 

 

2 Select the faces to move . 

 

3 Click  (General Edit toolbar) to display the Move toolbar. 
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4 Enter Y value of -25. After entering the value, press the Tab key. 

The preview shows the new position, with an arrow indicating the 
direction of the move from the original. 

 

5 Click  to confirm the position 

 

6 Click  to close the toolbar. 
 

Rotate - an example 

Use Rotate  to rotate a selected face.  

1 Zoom in and rotate the model so that the details are clearly 

visible. 
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2 Select the face to rotate . 

 

3 Click  (General Edit toolbar) to display the Rotate toolbar. 

 

4 Click  and define the rotation axis as indicated . 

 

5 Click the face and drag the mouse to rotate the face around the 

rotation axis. The instrumentation information shows the 
updated angle of rotation and changes as you moves the mouse. 

The Angle value in the dialog  is updated when you release 

the mouse button. 
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The preview  shows the changes that will be made when you 

apply the specified angle. 

 

6 Click  to update the model. This solution leaves two steps  

. 
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7 Click  to display the Next solution to remove the steps as they 

aren't required in this example. 

 

8 Click  to close the toolbar. 
 

Mirror - an example 

Use Mirror  to mirror selected faces.  

1 Zoom in and rotate the model so that the details are clearly 

visible. 

 

2 Select the faces to mirror . 
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3 Click  (General Edit toolbar) to display the Mirror toolbar. 

 

4 Click . The cursor changes to . 

5 Click to define the start point of the mirror plane. As you move 

the mouse,the line and the mirrored objects are displayed. 

 

6 Click to define the end point of the mirror plane. The mirror 

plane is displayed  with a preview of the mirrored object . 

 

7 Click  to update the model.  

 

8 Click  to close the toolbar. 
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Scale - an example 

Use Scale  to move a selected face. 

1 Zoom in and rotate the model so that the details are clearly 

visible. 

 

2 Select the faces to scale . 

 

3 Click Scale  (General Edit toolbar) to display the Scale 

toolbar. 

 

4 Select Non-uniform from the drop-down list. 
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5 Click  and click the centre of the selection to create a scale 
origin. The Scale toolbar is updated. 

 

6 Enter an X value of 2 as the scaling factor.. After entering the 

value, press the Tab key.  

The preview displays the changes that will be made when the 
scaling factor is applied. 

 

7 Click  to apply the scaling factor and update the model. 

 

8 Click  to close the toolbar. 
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Offset - an example 

Use Offset  to offset the selected faces by a specified distance. 

1 Zoom in and rotate the model to make the details clearly visible. 

 

2 Select the face offset . 

 

3 Click  (General Edit toolbar) to display the Offset toolbar. 

 

4 Enter a Distance of 3. The face is updated . 

 

5 Click  to close the toolbar. 
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Surface modelling 
Changes have been made to the following: 

 Mesh surfacing (see page 41). 

 PowerSHAPE checks that you have an appropriate licence when 
you try to use Draft surfacing. An error message is displayed if 

the appropriate licence is not available. 
 

Mesh surfacing 

 The surfacing toolbar has been updated to display Mesh surfacing 

as the default button on the Mesh surfacing/Surface from Patches 

flyout.  

 

 The Mesh surfacing toolbar has been updated to include: 

 Separate Tol field for meshing tolerance. 

 Updated Show/hide deviations button. 

 

 Undo and Redo are available when you create a surface using the 

Mesh surfacing button. 

 You can now enter a value of 0 for U and V to choose to insert 

zero laterals and longitudinals. 
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Solid modelling 
Changes have been made to the following areas of solid modelling: 

 Solid Edit toolbar (see page 42) has a new button and updated 

functionality.  

 In the solid tree, a warning triangle is now displayed next to a 

solid whose tree contains any error-suppressed features. 

 

 Split solid (Solid feature toolbar) now lets you use a solid face as 

well as a workplane, solid or surface.  

1 Select a solid. 

2 Click to select one of the faces of the selected solid. 

3 Click the Split solid  (Solid feature toolbar).  

 When multiple solids are selected, Reverse is now available on 
the Solid popup menu. 

 
 

Solid Edit toolbar 

The following changes have been made to the Solid Edit toolbar: 
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 Use Divide face  to divide the faces of the selected solid (see 

page 43).  

 Draft Faces is now available when a primitive solid is selected. 

 When the Draft Faces dialog is displayed, you can use Restore 

Selection (Views toolbar) to restore the previous set of selected 

faces to draft.  

 Selection modes now highlight the areas under the cursor: 

1 Click one of the following buttons on the Solid Edit toolbar: 

 features. 

 continuous regions. 

 convex regions. 

 concave regions. 

2 Move the cursor over a model to see the faces that will be 

selected.  

 
 

Divide Face 

A new Divide face  button has been added to the Solid Edit 

toolbar.  
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Use this functionality to divide the faces of the selected solid using 

wireframe. This option is useful if you need to make small, localised 
changes, or to limit the effect of Direct Modelling editing operations 

(see page 32).  

1 Create the wireframe that will be used to divide the face. 

 

2 Click  (Solid Edit toolbar) to display the Divide Faces dialog. 

 

3 Select the face to divide. 
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4 Select the wireframe. 

 

5 Select an appropriate projection option. Project wireframe along 

face normal is the default setting. 

6 Click Apply. If you want to split another face, you can do this 

without closing the dialog. 

7 Click Dismiss.  

8 Move the cursor over the face to show the divided face or click 
one of the faces. 

 

 If you have an example where the wireframe does not 

completely divide the face, the Operation Fault report will be 
displayed. Add additional wireframe and repeat the divide face 

operation using both the original and additional wireframe. 
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Triangle modelling 
Changes have been made to the following areas of triangle 
modelling: 

 Files imported that contain grouped points will be imported as 
clouds. If the points are not in a group then individual point 

entities will be created. 

 You can now copy items from PowerINSPECT as a cloud and 

paste into PowerSHAPE. 

 When creating a curve that is snapped to a mesh, enter  a Value 

of 0 to create a curve with zero breakpoints. 

 Error messages are displayed in the following circumstances: 

 If you try to use Divide mesh by colour with no colour selected. 

 If you try to use Divide mesh by selection without selecting any 

triangles. 

Paint triangles 

When the Paint triangles dialog is displayed, the triangle selection 

tools are available from the flyout on the Mesh Edit toolbar.  

 

1 Choose the colour from the Paint Triangles dialog. 

2 Choose the method of triangle selection (for example, distance, 

horizon angle, discontinuity angle). 

3 Pick the triangles using your chosen method. The triangles are 
painted in the colour indicated in the Paint Triangles dialog. 

4 Click OK on the Paint dialog to paint the selection.  
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 Selecting triangles and colouring them in this way is useful for 

dividing the mesh. Once the triangles are painted, use  to 

divide the mesh by colour. 
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Assembly modelling 
Changes have been made to the following areas of assembly 
modelling: 

 Modify Properties dialog (see page 48).  

 A component selection button has been added to the Select 

flyout. This selects components and instances of sub-assemblies. 

 

 Highlighting of components has improved when using the popup 
menus to modify components.  

Move the mouse over the popup menu buttons to highlight the 
components that will be modified with the following: 

 Component popup menu (assembly tree or graphics area): 

All Instances > Modify Geometry 

All Instances > Modify Parameters 

All Instances > Modify Properties 

 Component library popup menu: 

Modify > Geometry 

Modify > Parameters 

Modify > Properties 
 

Modify Properties dialog 

 Both component and component definition properties are 
displayed when the Modify Properties dialog is displayed for a 

component.  

Component definition properties are inherited by all instances of 
the component definition. Individual component instances can, 

optionally, overwrite the default property values set by the 
component definition. 

 Name is case-sensitive, so "Width_1" is not the same as 

"width_1" 

 Information or Query dialogs are displayed if you attempt to use 

the Modify Properties dialog to delete or rename a property when 

this action could have unexpected consequences.  

The relevant query dialog is displayed if you try to do one of the 

following: 
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 Delete a property defined in the component and component 

definition. 

 

 Delete a property defined in the component definition only:  

 

 Rename a property defined in the component definition. 
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Delcam Draft 
The following changes have been made to drafting functionality: 

 Text creation buttons (Annotation toolbar) have been re-styled. 

 

 Arc and line lengths are displayed on the cursor when creating 

dimensions. 

        

 Bold corners have been added to stepped section lines. 

 
 

Delcam Render 
Changes have been made to the following areas of Delcam Render: 

 POV-Ray is now the default Render system. Lightworks is no 

longer available from the Render system drop-down list on the 
Render dialog.  
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If POV-Ray is not already installed, it can be installed from the 

PowerSHAPE installer.  

 PowerSHAPE will attempt to check the POV-Ray settings before 

launching POV-Ray and change the input/output restrictions 
where appropriate. If you do not install POV-Ray in the default 

location, a dialog is displayed to enable you to set the 
input/output restrictions manually. 

 Create rendered movie is now only available if POV-Ray is 
installed.  

 

Other changes 
Changes have been made to the following areas of PowerSHAPE: 

 Graphic formats (see page 51). 

 Variables (see page 52). 

 General operation (see page 52). 
 

Graphic formats 

Two resources have been added to control the image formats used 

in .psmodel files.  

 In the previous versions of PowerSHAPE, all label images were 

stored as .tifs, that could result in large model files. In 
PowerSHAPE 2012 you can, optionally, store the model version 

23 images in the format that will used in the next model version: 

 images that originated in .jpg files are stored as .jpgs in the 

model file 

 images that originated in lossless files such as .tif or .png are 

stored as .pngs.  

To enable this behaviour, uncomment the lossy_in_23 resource in 

the powershape.con file and restart the program.  

This change results in much smaller model files. This action is 
only required for version 23 models created with PowerSHAPE 

2012 or later. Future model versions will incorporate this change 
when creating models.  

 PowerSHAPE 2011 R3 used version 23 models; images from 
this version of PowerSHAPE store the images in the same 

way as they were in model version 22.  
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 Models using this resource that are saved using model 

version 23 in PowerSHAPE 2012, will not be readable by 
previous versions of PowerSHAPE. However, exporting such 

models to model version 22 creates psmodels that are valid 
for all model version 23 and later. 

 Models that are written using this resource can be read by 
PowerSHAPE 2012, irrespective of the settings in the .con 

file. 

 From PowerSHAPE 2012 onwards, you can force lossless images 
to be stored in the .tiff format.  

To enable this behaviour, uncomment the use_tiff_for_labels: true 

resource in the powershape.con file and restart the program. 
 

Variables 

Use VAR_NAME and NAME variables to rename the following:  

 lines. 

 chamfers. 

 arcs. 

 curves. 

 composite curves. 

 points. 

 primitive surfaces. 

 general surfaces. 

 primitive solids. 

 general solids. 

 workplanes. 
 

Other changes 

 The .dmp files that are created in the temp directory if 

PowerSHAPE crashes are now named using the following format: 

PowerSHAPEXXXXXx32_yyyymmdd-hhmmss.dmp  (32-bit 

PowerSHAPE) 

PowerSHAPEXXXXXx64_yyyymmdd-hhmmss.dmp(64-bit 

PowerSHAPE) 

Please send these files to Delcam support when reporting 

problems. 
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 Use Shift + F1 to display context-sensitive Help when used with 

64-bit versions of Windows 7.  

 

 Use Copy / Paste techniques to transfer solid and surface 

geometry as Parasolid (.x_t) data to FeatureCAM.  
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